vrecko: Vrecko - the Virtual Reality Engine

vrecko
virtual reality framework
  • Main Page
  • Related Pages
  • Namespaces
  • Classes
  • Files
Vrecko - the Virtual Reality Engine

About

The Vrecko system was developed on Faculty of Informatics, Masaryk University (Brno, Czech Republic).

It is based on the OpenSceneGraph library, used for rendering, and features plugin architecture with object abilities that supports messaging.

Manual

This is mainly a class and method reference. More information can be found at:

http://vrecko.cz

Authors

This software is work of many people. See http://vrecko.cz/home/about/team/ the developers of the core were (from the original author to the youngest guys :) ) Jan Flasar, Lubomir Markovic, Radek Oslejsek, Vit Kovalcik, Jiri Chmelik, Martin Bezdeka, Lukas Kalcok.

Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Dynamic Art module

  • Related Pages
  • Namespaces
  • Classes
  • Files
Dynamic Art module

About

Allows exploitation of virtual environment for artistic purposes

Features

  • Freehand spatial painting
  • Design of polyhedra sculptures
  • Real-time visualization of human body motion
  • Real-time visualization of fractal objects
  • Design of string sculptures, including support for NVIDIA PhysX

Links

  • vrecko framework: http://http://vrecko.cz
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: L-system plant modeler - module for Vrecko

  • Files
L-system plant modeler - module for Vrecko

About

This DLL library was developed as part of my Master thesis. It is a plant modeler plug-in for virtual reality system Vrecko. It is based on OpenSceneGraph. There is a parser for L-systems stored in LS or XML files. Many types of L-systems can be processed to generate a word. Word is then interpreted by turtle graphics. Interpretation process generates a geometry that is stored in scene graph. Vrecko then display this geometry.

Features

  • generating plants using L-systems
  • D0L-systems, parametric stochastic 0Lsystems, parametric stochastic 2L-systems
  • generating plants geometry using Turtle interpretation

Links

  • Vrecko: http://decibel.fi.muni.cz/wiki/index.php/Main_Page
  • Project website and svn: http://code.google.com/p/l-system-for-osg
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Head Up Display module

Head Up Display module

About

Allows showing up inormations on windows on a screen on top of the normal view.

Author

Lukas Kalcok (izy.i.nosp@m.zzy@.nosp@m.gmail.nosp@m..com)

Features

  • creating a Head Up display for View in VRECKO vindow
  • Supports multiple screens on window and manages them by itself
  • These windows may be animated

Links

  • vrecko framework: http://http://vrecko.cz
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Space Partitioning - module for Vrecko

Space Partitioning - module for Vrecko

About

Provides a support functions for multiple modules like haptic interaction (SNCH and PSVG methods). @ section Author Vit Kovalcik (contact at : www.pastel.cz) & Lukas Kalcok (izy.i.nosp@m.zzy@.nosp@m.gmail.nosp@m..com)

Features

  • detection of proximity of objects
  • construction of DistanceField and PointShell data structures
  • computation of collisions of objects in scene

Links

  • Vrecko: http://decibel.fi.muni.cz/wiki/index.php/Main_Page
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Todo List

Todo List
Member AP_LSystem::AbstractTurtle::randomTurnPitchRoll (std::vector< Parameter > &p)=0
Not implemented
Member AP_LSystem::AbstractTurtle::resetValues ()
Not implemented.
Member AP_LSystem::AbstractTurtle::rollArround ()=0
Not implemented
Member AP_LSystem::LongString::matchLeft (char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL)
Implement consider
Member AP_LSystem::LongString::matchRight (char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL)
Implement consider
Member APDYNAMICART::BrushStrokeControlPoint::frenetFremeComputed
make this private....
Member APDYNAMICART::METHOD_REQUEST_INPUT (Sensor_0_actionMain, MessageBool, MessageBool, DAEnvironment)
- save current state of ArtWork (for UNDO/REDO)
Member APDYNAMICART::PoA::getUpdateFlag ()
later
Member APDYNAMICART::ToolEraser::activate ()
Member APDYNAMICART::ToolSlice::activate ()
Class APDYNAMICART::ToolTongs
- write something abou what this tool do and some other info...
Member APDYNAMICART::ToolTongs::activate ()
File BoundingVol.h
getVertexN(), getVertexP() - examine the functionality
File Clouds.h
Add more randomness to the cloud position - see Cloud2DPlacement class. Now that the clouds can overlay each other, it should be far easier to do.
Member DAControlPoint::frenetFremeComputed
make this private....
Member MagicWandTool::activate ()
Class PseudoRand2DPlacement
Add more variability and randomness, replace the grid for something else.
Member SliceTool::activate ()
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Deprecated List

Deprecated List
Member Cloud::ComputeUpRightVectors ()
Should be rewritten in OSG. Computes the new Up and Right vectors based on the curent view - used in the update of cloud particle rotations.
Member Cloud::LightCloud (void)
Should be rewritten in OSG. Computes the lighting of the cloud.
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
o N AP_CableEditor |
o N AP_LSystem |
o N APCameraMovement |
o N APCameraPath |
o N APClouds |
o N APConnectEditor |
o N APConstrainedMovement |
o N APDYNAMICART |
o N APEditorController |
o N APEditorQAbilities |
o N APFFDEditor |
o N APGUI |
o N APHelloWorld |
o N APHUD |
o N APInputConnector |
o N APLightsEditor |
o N APMenu |
o N APNature |
o N APObjectUtils |
o N APRoomEdit |
o N APShootingSimulation |
o N APSpacePartitioning |
o N APTextOutput |
o N APWeather |
o N ArtificialWorld |
o N base |
o N behindO |
o N boids |
o N CarSim |
o N esg |
o N Filter |
o N grass |
o N ht |
o N mv |
o N navigation |
o N ode |
o N osg |
o N osgQ |
o N PhysXPlugin |
o N VirtualFixture |
o N VK_NoStepInto_Namespace |
o N vrecko | Second level of space paritioning queries - detailed searching inside object
o N vreckoDP_base |
o N vreckoDP_Kinect |
o N vreckoUtils |
o N WAVEFRONT |
\ N WGeometry |
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: AP_CableEditor Namespace Reference

  • Namespace List
  • Namespace Members
Classes
AP_CableEditor Namespace Reference

Classes

class | Cable
class | CableEditor
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
AP_LSystem Namespace Reference

Classes

class | Abstract0LSystem
class | AbstractFile
class | AbstractGenerator
class | AbstractInterpret
class | AbstractkLSystem
class | AbstractLSystem
class | AbstractTurtle
class | Configuration
class | D0LSystem
class | HermitPipe
class | JointedPipe
class | LoftTurtle
class | Log
class | LongString
class | LSFile
struct | TurtleProperties
class | LSGeode
class | LSObject
class | LSystem
class | LSystemException
class | ParsingException
class | FileException
class | ConfigurationException
class | LSystemGenerator
class | MovingTurtle
class | Par2LSystem
class | ParD0LSystem
class | ParseableString
class | ParStoch0LSystem
class | Query
class | QueryInterpret
class | QueryTurtle
class | RandomIndex
class | Randomizer
class | Rectangle
struct | Rule
class | StaticString
class | StraightPipe
class | TurtleInterpret
class | TurtleStack
class | StringUtils
struct | Parameter
class | XmlFile

Enumerations

enum InterpretErrorCodes {
LS_OK, LS_NOTIMPLEMENTED, LS_ERR_PAR_BADTYPE, LS_ERR_PAR_INVALIDCOUNT,
LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE, LS_ERR_STACK_UNKNOWN_TURTLE_TYPE, LS_ERR_STACK_NULL_LSGEODE
}
enum LSystemCapabilities {
LS_0L = 0x00000001, LS_1LL = 0x00000002, LS_1LR = 0x00000004, LS_2L = 0x00000008,
LS_IL = 0x00000080, LS_DETERMINISTIC = 0x00000100, LS_STOCHASTIC = 0x00000200, LS_PARAMETRIC = 0x00010000
}
enum TurtleType {
LS_TURTLE_JOINTEDPIPE, LS_TURTLE_STRAIGHTPIPE, LS_TURTLE_HERMITPIPE, LS_TURTLE_OBJMODEL,
LS_TURTLE_RECTANGLE, LS_TURTLE_QUERY
}

Functions

const osg::Vec3d | HeadVec (0.0, 1.0, 0.0)
Turtle head vector. More...
const osg::Vec3d | UpVec (1.0, 0.0, 0.0)
Turtle up vector. More...
const osg::Vec3d | LeftVec (0.0, 0.0, 1.0)
Turtle left vector. More...
const osg::Vec3d | Center (0.0, 0.0, 0.0)
Position of turtle. More...
const osg::Vec4d | White (1.0, 1.0, 1.0, 1.0)
White color. More...
std::basic_ostream< char > & | operator<< (std::basic_ostream< char > &os, const ParseableString ps)

Enumeration Type Documentation

enum AP_LSystem::InterpretErrorCodes

Error codes that returns methods during interpretation. Error codes are used instead of exception because of higher performance. Can be translated to error messages using AbstractInterpret::errorText() method.

Enumerator
LS_OK | OK. No error.
LS_NOTIMPLEMENTED | Method is not implemented.
LS_ERR_PAR_BADTYPE | Module has a different type.
LS_ERR_PAR_INVALIDCOUNT | Invalid count of module parameters.
LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE | Forward step has a negative length.
LS_ERR_STACK_UNKNOWN_TURTLE_TYPE | Unknown turtle ID.
LS_ERR_STACK_NULL_LSGEODE | Turtle not binded with LSGeode.
enum AP_LSystem::LSystemCapabilities

All L-system capabilities. L-system type is built as bitmap from this values.

Enumerator
LS_0L | 0L-system
LS_1LL | 1L-system with left context
LS_1LR | 1L-system with right context
LS_2L | 2L-system with left and right context
LS_IL | IL-system.
LS_DETERMINISTIC | Deterministic L-system.
LS_STOCHASTIC | Stochastic L-system.
LS_PARAMETRIC | Parametric L-system.
enum AP_LSystem::TurtleType

Turtle types

Enumerator
LS_TURTLE_JOINTEDPIPE | cylinders with hemispheres
LS_TURTLE_STRAIGHTPIPE | straight cylinders
LS_TURTLE_HERMITPIPE | hermit curve cylinders - not implemented
LS_TURTLE_OBJMODEL | *.obj object loader - not implemented
LS_TURTLE_RECTANGLE | rectangles - effective for translucent leaves
LS_TURTLE_QUERY | specialized turtle for query processing

Function Documentation

const osg::Vec3d AP_LSystem::Center | ( | 0. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |

Position of turtle.

const osg::Vec3d AP_LSystem::HeadVec | ( | 0. | 0,
 |  | 1. | 0,
 |  | 0. | 0
 | ) |  |

Turtle head vector.

const osg::Vec3d AP_LSystem::LeftVec | ( | 0. | 0,
 |  | 0. | 0,
 |  | 1. | 0
 | ) |  |

Turtle left vector.

std::basic_ostream< char > & AP_LSystem::operator<< | ( | std::basic_ostream< char > & | os,
 |  | const ParseableString | ps
 | ) |  |

Output operator

const osg::Vec3d AP_LSystem::UpVec | ( | 1. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |

Turtle up vector.

const osg::Vec4d AP_LSystem::White | ( | 1. | 0,
 |  | 1. | 0,
 |  | 1. | 0,
 |  | 1. | 0
 | ) |  |

White color.

Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: APCameraMovement Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APCameraMovement Namespace Reference

Classes

class | CameraMovementEditor
struct | ControlPoint
class | CameraPath
struct | MyReadCallback
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraPath Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Functions
APCameraPath Namespace Reference

Classes

struct | ControlPoint
class | Camera

Typedefs

typedef unsigned int _uint

Functions

float | F1 (float t)
float | F2 (float t)
float | F3 (float t)
float | F4 (float t)

Typedef Documentation

typedef unsigned int APCameraPath::_uint

Function Documentation

float APCameraPath::F1 ( float t )
inline
float APCameraPath::F2 ( float t )
inline
float APCameraPath::F3 ( float t )
inline
float APCameraPath::F4 ( float t )
inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APClouds Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APClouds Namespace Reference

Classes

class Clouds
Clouds ability - revised Atmospheric ability. More...
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APConnectEditor Namespace Reference

Classes

class | ConnectEditor
class | Cut
class | Optimalizer
class | PolygonState
class | Rotation
class | Scale
struct | MyReadCallback
class | EOLineSegmentIntersector
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConstrainedMovement Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Functions | Variables
APConstrainedMovement Namespace Reference

Classes

class | ConstrainedObjectMovement
class | ConstraintArea
class | ConstraintDescription

Typedefs

typedef vector< osg::Vec3 > | Vecs3
typedef vector< ConstraintArea * > | ConstraintAreas
typedef set< int > | EnvironmentObjectIDs

Functions

double | vectorAngle (osg::Vec3 vector1, osg::Vec3 vector2)
float | area (osg::Vec3 &point1, osg::Vec3 &point2, osg::Vec3 &point3)
osg::Vec3 | centroid (Vecs3 polygon)
int | orientation (float x1, float y1, float x2, float y2, float px, float py)
bool | convexPolygon (Vecs3 polygon)
double | calcAngleSum (osg::Vec3 q, Vecs3 &p)

Variables

vector< int > watchedObjectIDs

Typedef Documentation

typedef vector<ConstraintArea*> APConstrainedMovement::ConstraintAreas
typedef set<int> APConstrainedMovement::EnvironmentObjectIDs
typedef vector< osg::Vec3 > APConstrainedMovement::Vecs3

Function Documentation

float APConstrainedMovement::area | ( | osg::Vec3 & | point1,
 |  | osg::Vec3 & | point2,
 |  | osg::Vec3 & | point3
 | ) |  |
double APConstrainedMovement::calcAngleSum | ( | osg::Vec3 | q,
 |  | Vecs3 & | p
 | ) |  |

Calculates the sum of angles from a given point to given polygon points

osg::Vec3 APConstrainedMovement::centroid ( Vecs3 polygon )
bool APConstrainedMovement::convexPolygon ( Vecs3 polygon )
int APConstrainedMovement::orientation | ( | float | x1,
 |  | float | y1,
 |  | float | x2,
 |  | float | y2,
 |  | float | px,
 |  | float | py
 | ) |  |
double APConstrainedMovement::vectorAngle | ( | osg::Vec3 | vector1,
 |  | osg::Vec3 | vector2
 | ) |  |

Returns the angle between two vectors

Variable Documentation

vector<int> APConstrainedMovement::watchedObjectIDs

Functions and variables for efficiency testing and evaluation purposes

Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables
APDYNAMICART Namespace Reference

Classes

class | Attractor
class | Brush
Encapsulate data and functionality of sweepSurface related factories and adapters. More...
class | BrushStroke
Store data about and can render one brush stroke. More...
class | ColorGenAdapter
class | ConstantColorAdapter
class | GradientColorAdapter
class | ColorGenFactory
class | IComputeStrategy
class | NullStrategy
class | LorenzStrategy
class | Lorenz84Strategy
class | PickoverStrategy
class | RosslerStrategy
class | PolynomialStrategy
class | IkedaStrategy
struct | InitSettings
class | ComputeThread
struct | Configuration
class | Controller
class | Ctrl_Attractor
class | Ctrl_FreeHandPainting
controller of Brush Stroke PoA More...
class | Ctrl_MotionVisualization
controller of Motion Trail PoAs More...
class | Ctrl_PerlinLines
class | Ctrl_PolyhedraSculptures
class | Ctrl_StringSculptures
class | DAEnvironment
Dynamic Art Environment class - base class of Dynamic Art plugin. More...
class | DATool
Virtual class defining basis of all tools used in Dynamic Art. More...
class | ConstantDiamAdapter
class | GradientDiamAdapter
class | DiameterGenFactory
class | HookObject
class | HoopTrackerCallback
class | HookManager
Hook Manager. More...
class | Hoop
class | HoopShape
class | NullHoopShape
class | Rectangle
class | Ellipse
class | RegularPolygon
class | Line
class | ElongatedCircle
class | Painted
class | ShapeFactory
class | JuliaAttractor
class | Mode
class | Basic
class | Advanced
class | MotionTrail
class | NullAttractor
class | OrdinaryAttractor
struct | Parameter
class | IParameters
class | NullParameters
class | LorenzParameters
class | Lorenz84Parameters
class | JuliaParameters
class | PickoverParameters
class | RosslerParameters
class | PolynomialParameters
class | IkedaParameters
struct | ParticleSystemParameters
class | Pattern
class | PatternBase
class | PatternFactory
class | NullPattern
class | AcrossPattern
class | CrissCrossPattern
class | DoublePattern
class | HyperbolicPattern
class | TopPattern
class | TopReversePattern
class | StandardPattern
class | SplitPattern
class | SplitReversePattern
class | PatternsGeode
class | PerlinLines
class | PLNestTool
class | PLMagnetTool
class | PLControllerTool
struct | SimulationParameters
class | PhysXManager
class | PoA
PoA (Piece of Art) More...
class | PolyhedraSculpture
class | PS_Component
class | PS_Layer
class | PS_Face
class | PS_FacePlane
class | PS_FlatShape
class | PS_Polyhedron
class | PolyhedronFactory
struct | symmetry_axis
struct | symmetry_pair
class | PS_Symmetry
class | RotationFrameAdapter
class | RMFrameAdapter
class | AxisFrameAdapter
class | HandFrameAdapter
class | RotationFrameFactory
struct | SectorInfo
class | SectorManager
Sector Manager. More...
class | SimpleBox
Simple class for creating boxes. More...
class | SplineAdapter
class | RoundedSplineAdapter
class | RectangularSplineAdapter
class | WaveSplineAdapter
class | SplineFactory
class | ToolBrush
Brush tool. More...
class | ToolEraser
class | ToolHook
class | ToolMagicWand
class | ToolRotation
Rotation tool. More...
class | ToolSelector
class | ToolSlice
class | ToolTongs
class | Stroke
class | PoAAdapter
class | AdapterFactory
class | Utils
struct | Limits
class | colorGradient
class | PoAState
class | DAGizmo
Gizmo - graphical representation of something, e.g. Frenet frame. More...
class | BrushStrokeControlPoint
Control point of Sweep Surface. More...
struct | Trait
class | HoopGeometry
class | PoB
PoB (Piece of Behavior) More...
class | IShapeGenerator
class | NullShapeGenerator
class | LinearShapeGenerator
struct | SnapPoint

Typedefs

typedef std::vector< std::string > | AttractorNames
typedef osg::ref_ptr< Attractor > | AttractorPtr
typedef osg::ref_ptr< Brush > | BrushPtr
typedef osg::ref_ptr
< IComputeStrategy > 		IComputeStrategyPtr
typedef osg::ref_ptr
< ComputeThread > 		ComputeThreadPtr
typedef std::vector< DATool * > | DATools
virtual PoA controller More...
typedef PoAAdapter< DiameterGen > | DiameterGenAdapter
typedef osg::ref_ptr< Hoop > | HoopPtr
typedef osg::ref_ptr< HoopShape > | HoopShapePtr
typedef osg::ref_ptr< Mode > | ModePtr
typedef struct
APDYNAMICART::Parameter 		Parameter
typedef std::vector< Parameter > | Parameters
typedef osg::ref_ptr< IParameters > | IParametersPtr
typedef osg::ref_ptr< PatternBase > | PatternPtr
typedef std::vector< PatternPtr > | Patterns
typedef osg::ref_ptr
< PatternsGeode > 		PatternGeodePtr
typedef std::vector
< PatternGeodePtr > 		PatternGeodeList
typedef std::vector
< osg::ref_ptr< osg::Sphere > > 		Spheres
typedef osg::ref_ptr< PoA > | ref_ptr_PoA
type: reference pointer to PoA More...
typedef osg::ref_ptr
< PolyhedraSculpture > 		PolyhedraSculpturePtr
typedef osg::ref_ptr
< PS_Component > 		PS_ComponentPtr
typedef osg::ref_ptr< PS_Layer > | PS_LayerPtr
typedef osg::ref_ptr< PS_Face > | PS_FacePtr
typedef osg::ref_ptr
< PS_FacePlane > 		PS_FacePlanePtr
typedef osg::ref_ptr
< PS_FlatShape > 		PS_FlatShapePtr
typedef osg::ref_ptr
< PS_Polyhedron > 		PS_PolyhedronPtr
typedef osg::ref_ptr< SimpleBox > | ref_ptr_SimpleBox
typedef osg::ref_ptr< ToolBrush > | ref_ptr_ToolBrush
typedef std::pair< HoopPtr,
osg::ref_ptr< HookObject > > 		Hook
Hook tool. More...
typedef osg::ref_ptr
< ToolSelector > 		ToolSelectorPtr
typedef osg::ref_ptr
< osg::UIntArray > 		UIntArrayPtr
typedef osg::ref_ptr
< osg::Vec3Array > 		Vec3ArrayPtr
typedef osg::ref_ptr
< osg::Vec4Array > 		Vec4ArrayPtr
typedef osg::ref_ptr< osg::Geode > | GeodePtr
typedef osg::ref_ptr
< osg::Geometry > 		GeometryPtr
typedef osg::ref_ptr
< vreckoUtils::Menu > 		MenuPtr
typedef osg::ref_ptr
< vreckoUtils::MenuRoot > 		MenuRootPtr
typedef osg::ref_ptr
< vreckoUtils::IMenuComponent > 		IMenuComponentPtr
typedef osg::ref_ptr
< std::vector< osg::Vec4 > > 		ColorList
typedef std::map< std::string,
Trait > 		TraitMap
typedef osg::ref_ptr
< HoopGeometry > 		HoopGeometryPtr
typedef osg::ref_ptr
< IShapeGenerator > 		IShapeGeneratorPtr
typedef std::vector< SnapPoint > | SnapPointArray

Enumerations

enum | AttractorRenderingType { ATT__RENDER_POINTS = 1, ATT__RENDER_LINES, ATT__RENDER_TRIANGLES }
enum | PlaybackType { FHP__REAL_TIME = 1, FHP__LAG_SKIP }
enum DAToolType {
TOOL__BRUSH = 1, TOOL__TONGS, TOOL__ERASER, TOOL__SLICE,
TOOL__MAGICWAND, TOOL__NEST, TOOL__MAGNET, TOOL__PERLIN_LINES_CONTROLLER,
TOOL__SELECTOR, TOOL__ROTATION, TOOL__HOOK
}
enum PoAType {
POA__DUMMY = -1, POA__BRUSH_STROKE = 1, POA__MOTION_TRAIL, POA__CHAOTIC_ATTRACTOR,
POA__PERLIN_LINE, POA__STRING_SCULPTURES, POA__POLYHEDRA_SCULPTURES
}
Types of PoA. More...
enum PoAUpdateType {
POA__UPDATE_NONE = 0, POA__UPDATE_DELETE = 1, POA__UPDATE_RENDER, POA__UPDATE_COLOR_CHANGE,
POA__UPDATE_DYNAMIC, POA__MT_SAMPLING
}
Types of updates of PoA. More...
enum | PoBType { POB__ICON = 1 }
types of PoB More...

Functions

void createParticleSystem (osg::Group *emmitterParent, osg::Group *particleSystemParent, ParticleSystemParameters *params)
METHOD_INPUT (Colour, MessageVec4, BrushStroke)
METHOD_INPUT (Position_sensor_0, MessageVec3, Ctrl_PerlinLines)
METHOD_INPUT (Autorotation, MessageBool, DAEnvironment)
METHOD_INPUT (ChangeAutoRotationSpeed, MessageInt, DAEnvironment)
METHOD_INPUT (Colour, MessageVec4, DAEnvironment)
METHOD_INPUT (CreateMenuStructure, MessageInt, DAEnvironment)
METHOD_INPUT (DebugPurposeKey, MessageBool, DAEnvironment)
METHOD_INPUT (GUIItemClicked, MessageString, DAEnvironment)
METHOD_INPUT (HidingMenu, MessageBool, DAEnvironment)
METHOD_INPUT (SwitchGUIVisibility, MessageBool, DAEnvironment)
METHOD_INPUT (Import, MessageBool, DAEnvironment)
METHOD_INPUT (MenuItemClicked, MessageString, DAEnvironment)
METHOD_INPUT (ResetDAArea, MessageBool, DAEnvironment)
METHOD_INPUT (Sensor_0_position, MessageVec3, DAEnvironment)
METHOD_INPUT (Sensor_1_position, MessageVec3, DAEnvironment)
METHOD_INPUT (Sensor_0_orientation, MessageQuat, DAEnvironment)
METHOD_INPUT (Sensor_1_orientation, MessageQuat, DAEnvironment)
METHOD_INPUT (ScaleDAArea, MessageInt, DAEnvironment)
METHOD_INPUT (SwitchTool, MessageBool, DAEnvironment)
METHOD_INPUT (SwitchRenderingMethod, MessageBool, DAEnvironment)
METHOD_INPUT (QuickLoad, MessageBool, DAEnvironment)
METHOD_INPUT (QuickSave, MessageBool, DAEnvironment)
METHOD_REQUEST_INPUT (Sensor_1_actionMain, MessageBool, MessageBool, DAEnvironment)
METHOD_REQUEST_INPUT (Sensor_0_actionMain, MessageBool, MessageBool, DAEnvironment)
METHOD_INPUT (ExternalDeactivation, MessageObjectID, DAEnvironment)
METHOD_INPUT (Colour, MessageVec4, Hoop)
METHOD_INPUT (GUIItemClicked, MessageString, ToolBrush)
METHOD_INPUT (CreateMenuStructure, MessageInt, ToolBrush)
METHOD_INPUT (HidingMenu, MessageBool, ToolBrush)
METHOD_INPUT (GUIItemClicked, MessageString, ToolHook)
METHOD_INPUT (CreateMenuStructure, MessageInt, ToolHook)
METHOD_INPUT (HidingMenu, MessageBool, ToolHook)
METHOD_INPUT (GUIItemClicked, MessageString, ToolMagicWand)
METHOD_INPUT (CreateMenuStructure, MessageInt, ToolMagicWand)
METHOD_INPUT (HidingMenu, MessageBool, ToolMagicWand)
METHOD_INPUT (GUIItemClicked, MessageString, ToolRotation)
METHOD_INPUT (CreateMenuStructure, MessageInt, ToolRotation)
METHOD_INPUT (HidingMenu, MessageBool, ToolRotation)
METHOD_INPUT (GUIItemClicked, MessageString, ToolSelector)
METHOD_INPUT (CreateMenuStructure, MessageInt, ToolSelector)
METHOD_INPUT (HidingMenu, MessageBool, ToolSelector)

Variables

const unsigned int | NOT_FOUND = -1
Selector tool. More...
std::string | saveFileNameBase = "da_scene#"
__pad0__
colorGenAdapter
diamGenAdapt
crossSectionAdapter

Detailed Description

PoA class for visualizing Hooks

Author
Martin Bezdìka marti.nosp@m.n.be.nosp@m.zdeka.nosp@m.@gma.nosp@m.il.co.nosp@m.m
Date
$Id$

PoA class for generating hoops

Author
Martin Bezdeka
Date
$Id$
Author
Martin Bezdeka
Date
2012

PoA class for whole polyhedra sculpture

Author
Jiri Chmelik
Date
$Id$

class for management of one component of polyhedra sculpture

Author
Jiri Chmelik
Date
$Id$

class for

Author
Jiri Chmelik
Date
$Id$

interface for various flat shapes such as face or component

Author
Jiri Chmelik
Date
$Id$

class for management of one layer of polyhedra sculpture

Author
Jiri Chmelik
Date
$Id$

class for management of one polyhedron of polyhedra sculpture

Author
Jiri Chmelik
Date
$Id$

class for management of symmetries of polyhedron

Author
Jiri Chmelik
Date
$Id$

Typedef Documentation

typedef std::vector<std::string> APDYNAMICART::AttractorNames
typedef osg::ref_ptr<Attractor> APDYNAMICART::AttractorPtr
typedef osg::ref_ptr<Brush> APDYNAMICART::BrushPtr
typedef osg::ref_ptr<std::vector<osg::Vec4> > APDYNAMICART::ColorList
typedef osg::ref_ptr<ComputeThread> APDYNAMICART::ComputeThreadPtr
typedef std::vector<DATool*> APDYNAMICART::DATools

virtual PoA controller

Controllers manage PoAs of own type. For each type of PoA (Motion trails, Chaotic attractors, Perlin lines, ...) there have to be exactly one controller. One controller may contain only one type of PoAs. Controllers objects are defined in .xml file. All controllers ability must have same parent EO as DAEnvironment ability.

Author
Jiri Chmelik
Martin Bezdeka
Date
2010
typedef PoAAdapter<DiameterGen> APDYNAMICART::DiameterGenAdapter
typedef osg::ref_ptr<osg::Geode> APDYNAMICART::GeodePtr
typedef osg::ref_ptr<osg::Geometry> APDYNAMICART::GeometryPtr
typedef std::pair<HoopPtr, osg::ref_ptr<HookObject> > APDYNAMICART::Hook

Hook tool.

Used for PhysX simulation, every hoop can be hooked to a rope using this tool

typedef osg::ref_ptr<HoopGeometry> APDYNAMICART::HoopGeometryPtr

typedefs

typedef osg::ref_ptr<Hoop> APDYNAMICART::HoopPtr
typedef osg::ref_ptr<HoopShape> APDYNAMICART::HoopShapePtr
typedef osg::ref_ptr<IComputeStrategy> APDYNAMICART::IComputeStrategyPtr
typedef osg::ref_ptr<vreckoUtils::IMenuComponent> APDYNAMICART::IMenuComponentPtr
typedef osg::ref_ptr<IParameters> APDYNAMICART::IParametersPtr
typedef osg::ref_ptr<IShapeGenerator> APDYNAMICART::IShapeGeneratorPtr

typedefs

typedef osg::ref_ptr<vreckoUtils::Menu> APDYNAMICART::MenuPtr
typedef osg::ref_ptr<vreckoUtils::MenuRoot> APDYNAMICART::MenuRootPtr
typedef osg::ref_ptr<Mode> APDYNAMICART::ModePtr

typedefs

typedef struct APDYNAMICART::Parameter APDYNAMICART::Parameter

Parameter struct

typedef std::vector<Parameter> APDYNAMICART::Parameters
typedef std::vector<PatternGeodePtr> APDYNAMICART::PatternGeodeList
typedef osg::ref_ptr<PatternsGeode> APDYNAMICART::PatternGeodePtr
typedef osg::ref_ptr<PatternBase> APDYNAMICART::PatternPtr

typedefs

typedef std::vector<PatternPtr> APDYNAMICART::Patterns
typedef osg::ref_ptr<PolyhedraSculpture> APDYNAMICART::PolyhedraSculpturePtr
typedef osg::ref_ptr<PS_Component> APDYNAMICART::PS_ComponentPtr
typedef osg::ref_ptr<PS_FacePlane> APDYNAMICART::PS_FacePlanePtr
typedef osg::ref_ptr<PS_Face> APDYNAMICART::PS_FacePtr
typedef osg::ref_ptr<PS_FlatShape> APDYNAMICART::PS_FlatShapePtr
typedef osg::ref_ptr< PS_Layer > APDYNAMICART::PS_LayerPtr
typedef osg::ref_ptr<PS_Polyhedron> APDYNAMICART::PS_PolyhedronPtr
typedef osg::ref_ptr<PoA> APDYNAMICART::ref_ptr_PoA

type: reference pointer to PoA

typedef osg::ref_ptr<SimpleBox> APDYNAMICART::ref_ptr_SimpleBox
typedef osg::ref_ptr<ToolBrush> APDYNAMICART::ref_ptr_ToolBrush
typedef std::vector<SnapPoint> APDYNAMICART::SnapPointArray
typedef std::vector<osg::ref_ptr<osg::Sphere> > APDYNAMICART::Spheres
typedef osg::ref_ptr<ToolSelector> APDYNAMICART::ToolSelectorPtr
typedef std::map<std::string, Trait> APDYNAMICART::TraitMap
typedef osg::ref_ptr<osg::UIntArray> APDYNAMICART::UIntArrayPtr

general typedefs

typedef osg::ref_ptr<osg::Vec3Array> APDYNAMICART::Vec3ArrayPtr
typedef osg::ref_ptr<osg::Vec4Array> APDYNAMICART::Vec4ArrayPtr

Enumeration Type Documentation

enum APDYNAMICART::AttractorRenderingType

PoA class for generating an attractor

Author
Martin Bezdeka, Jiri Chmelik
Date
Id:
Attractor.h 349 2012-03-05 16:42:32Z xchmeli1
Enumerator
ATT__RENDER_POINTS
ATT__RENDER_LINES
ATT__RENDER_TRIANGLES
enum APDYNAMICART::DAToolType
Enumerator
TOOL__BRUSH
TOOL__TONGS
TOOL__ERASER
TOOL__SLICE
TOOL__MAGICWAND
TOOL__NEST
TOOL__MAGNET
TOOL__PERLIN_LINES_CONTROLLER
TOOL__SELECTOR
TOOL__ROTATION
TOOL__HOOK
enum APDYNAMICART::PlaybackType
Enumerator
FHP__REAL_TIME
FHP__LAG_SKIP
enum APDYNAMICART::PoAType

Types of PoA.

Enumerator
POA__DUMMY
POA__BRUSH_STROKE
POA__MOTION_TRAIL
POA__CHAOTIC_ATTRACTOR
POA__PERLIN_LINE
POA__STRING_SCULPTURES
POA__POLYHEDRA_SCULPTURES
enum APDYNAMICART::PoAUpdateType

Types of updates of PoA.

PoA may need different types of update during time, with different frequency of updates Set update type by calling setUpdateFlag() function.

Enumerator
POA__UPDATE_NONE | no update is required
POA__UPDATE_DELETE | PoA will be cleared immediately. Controller will later delete PoA object and free memory.
POA__UPDATE_RENDER | PoA will be re-rendered during next update.
POA__UPDATE_COLOR_CHANGE | change in colors... do something - partialy re-render, perhaps
POA__UPDATE_DYNAMIC | object is somehow dynamic and therefore requires more than one update
POA__MT_SAMPLING | Brush Stroke specific update - adding new samples to Brush Stroke PoA.
enum APDYNAMICART::PoBType

types of PoB

Enumerator
POB__ICON

Function Documentation

void APDYNAMICART::createParticleSystem | ( | osg::Group * | emmitterParent,
 |  | osg::Group * | particleSystemParent,
 |  | ParticleSystemParameters * | params
 | ) |  |

Create new particle system and add it to virtual scene

Parameters
emitterParent | parent object of particle emitter - oriented point in 3D space, where particles are emitted
particleSystemParent | parent object of whole particle system - when this parent moves, all particles moves... Usually, this is world or daArea
params | structure containing particle system parameters - see above.
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ToolHook |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ToolRotation |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | ToolHook |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | ToolHook |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | ToolRotation |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | ToolRotation |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Colour | ,
 |  | MessageVec4 | ,
 |  | Hoop |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ToolBrush |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | ToolBrush |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | ToolBrush |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ToolSelector |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ToolMagicWand |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | ToolSelector |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | ToolSelector |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | ToolMagicWand |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | ToolMagicWand |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Colour | ,
 |  | MessageVec4 | ,
 |  | BrushStroke |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Position_sensor_0 | ,
 |  | MessageVec3 | ,
 |  | Ctrl_PerlinLines |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Autorotation | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | ChangeAutoRotationSpeed | ,
 |  | MessageInt | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Colour | ,
 |  | MessageVec4 | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | DebugPurposeKey | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | SwitchGUIVisibility | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Import | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | MenuItemClicked | ,
 |  | MessageString | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | ResetDAArea | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Sensor_0_position | ,
 |  | MessageVec3 | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Sensor_1_position | ,
 |  | MessageVec3 | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Sensor_0_orientation | ,
 |  | MessageQuat | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | Sensor_1_orientation | ,
 |  | MessageQuat | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | ScaleDAArea | ,
 |  | MessageInt | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | SwitchTool | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | SwitchRenderingMethod | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | QuickLoad | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | QuickSave | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_INPUT | ( | ExternalDeactivation | ,
 |  | MessageObjectID | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_REQUEST_INPUT | ( | Sensor_1_actionMain | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
APDYNAMICART::METHOD_REQUEST_INPUT | ( | Sensor_0_actionMain | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | DAEnvironment |
 | ) |  |
Todo:
  • save current state of ArtWork (for UNDO/REDO)

Variable Documentation

APDYNAMICART::__pad0__
APDYNAMICART::colorGenAdapter
APDYNAMICART::crossSectionAdapter
Initial value:
{
this->setName("Motion-Trail")
APDYNAMICART::diamGenAdapt
const unsigned int APDYNAMICART::NOT_FOUND = -1

Selector tool.

Creates sectors to be coloredConstants

std::string APDYNAMICART::saveFileNameBase = "da_scene#"
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APEditorController Namespace Reference

Classes

class | AbilityMapper
class | EditorController

Functions

METHOD_INPUT (AbilityMapping, AbilityMapper::MessageMapping, EditorController)
METHOD_REQUEST_INPUT (AbilityMapping, MessageVoid, AbilityMapper::MessageMapping, EditorController)
METHOD_REQUEST_INPUT (SelectionID, MessageInt, MessageObjectID, EditorController)
METHOD_REQUEST_INPUT (SelectionPath, MessageInt, MessageNodeList, EditorController)
METHOD_REQUEST_INPUT (PointerPos, MessageInt, MessageVec3, EditorController)
METHOD_REQUEST_INPUT (PointerPosRaw, MessageInt, MessageVec3, EditorController)
METHOD_REQUEST_INPUT (PointerRot, MessageInt, MessageQuat, EditorController)
METHOD_REQUEST_INPUT (PointerRotRaw, MessageInt, MessageQuat, EditorController)

Function Documentation

APEditorController::METHOD_INPUT | ( | AbilityMapping | ,
 |  | AbilityMapper::MessageMapping | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | AbilityMapping | ,
 |  | MessageVoid | ,
 |  | AbilityMapper::MessageMapping | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | SelectionID | ,
 |  | MessageInt | ,
 |  | MessageObjectID | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | SelectionPath | ,
 |  | MessageInt | ,
 |  | MessageNodeList | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | PointerPos | ,
 |  | MessageInt | ,
 |  | MessageVec3 | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | PointerPosRaw | ,
 |  | MessageInt | ,
 |  | MessageVec3 | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | PointerRot | ,
 |  | MessageInt | ,
 |  | MessageQuat | ,
 |  | EditorController |
 | ) |  |
APEditorController::METHOD_REQUEST_INPUT | ( | PointerRotRaw | ,
 |  | MessageInt | ,
 |  | MessageQuat | ,
 |  | EditorController |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APEditorQAbilities Namespace Reference

Classes

class | AbilityEditor
class | AnimatorEditor
class | AvatarMovement
class | ObjectAdd
class | ObjectDelete
class | ObjectMovement
class | SceneSave
class | SimpleObjectMovement
class | UseTrigger
class | PresentAbility

Functions

int planesCompare (const ObjectMovement::CANDIDATEPLANE *elem1, const ObjectMovement::CANDIDATEPLANE *elem2)

Function Documentation

int APEditorQAbilities::planesCompare | ( | const ObjectMovement::CANDIDATEPLANE * | elem1,
 |  | const ObjectMovement::CANDIDATEPLANE * | elem2
 | ) |  |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APFFDEditor Namespace Reference

Classes

class | EditorLogic
class | GeometryLoader
class | GeometryLoaderBase
class | Grid

Functions

int | factorial (int num)
float | combNum (int x, int y)
bool | getParentsTransformMat (osg::Matrix &parentsTransform, vrecko::EnvironmentObject *object)
bool | getParentsTransform (osg::Matrix &parentsTransform, vrecko::EnvironmentObject *object)

Function Documentation

float APFFDEditor::combNum | ( | int | x,
 |  | int | y
 | ) |  |
int APFFDEditor::factorial ( int num )
bool APFFDEditor::getParentsTransform | ( | osg::Matrix & | parentsTransform,
 |  | vrecko::EnvironmentObject * | object
 | ) |  |
bool APFFDEditor::getParentsTransformMat | ( | osg::Matrix & | parentsTransform,
 |  | vrecko::EnvironmentObject * | object
 | ) |  |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions
APGUI Namespace Reference

Classes

class | ColorPicker
spatial HSL Color Picker More...
class | GUI_Controller
GUI Controller class. More...
class | Interconnection
used to simplify deletion of created interconnections (especially in menu) More...
class | GUI_Item
VRECKO GUI Item class. More...
class | GUI_Text
Text. More...
class | Icon
Icon. More...
class | IconColour
Color Icon. More...
class | ItemsGroup
Group of GUI Items. More...
class | Layout
GUI Layout class. More...
class | Menu
Menu. More...
class | Slider
Slider GUI item. More...

Typedefs

typedef std::map< string,
osg::ref_ptr< Layout > > 		LayoutMapType
typedef std::map< unsigned
long, GUI_Item * > 		GuiItemMapType

Enumerations

enum | GUI_ITEM_STATE { GUI_ITEM_STATE_DEFAULT = 1, GUI_ITEM_STATE_ACTIVE, GUI_ITEM_STATE_DISABLED }
enum | GUI_ACTION { GUI_ACTION_MAIN = 1, GUI_ACTION_CONTEXT }
enum | IconType { ICON__BUTTON = 1, ICON__SWITCH, ICON__MULTISWITCH }
types of Icon More...

Functions

METHOD_INPUT (GUIItemClicked, MessageString, ColorPicker)
METHOD_INPUT (ExternalDeactivation, MessageObjectID, ColorPicker)
METHOD_REQUEST_INPUT (EvokeHSLColorPicker, MessageString, MessageBool, ColorPicker)
METHOD_REQUEST_INPUT (Sensor_0_mainClick, MessageBool, MessageBool, GUI_Controller)
METHOD_REQUEST_INPUT (Sensor_1_mainClick, MessageBool, MessageBool, GUI_Controller)
METHOD_REQUEST_INPUT (Sensor_0_contextClick, MessageBool, MessageBool, GUI_Controller)
METHOD_REQUEST_INPUT (Sensor_1_contextClick, MessageBool, MessageBool, GUI_Controller)
METHOD_INPUT (SwitchLayout, MessageString, GUI_Controller)
METHOD_INPUT (HidingMenu, MessageBool, Menu)
METHOD_INPUT (SliderValue, MessageFloat, Slider)

Typedef Documentation

typedef std::map<unsigned long, GUI_Item *> APGUI::GuiItemMapType
typedef std::map<string, osg::ref_ptr<Layout> > APGUI::LayoutMapType

Enumeration Type Documentation

enum APGUI::GUI_ACTION
Enumerator
GUI_ACTION_MAIN
GUI_ACTION_CONTEXT
enum APGUI::GUI_ITEM_STATE
Enumerator
GUI_ITEM_STATE_DEFAULT
GUI_ITEM_STATE_ACTIVE
GUI_ITEM_STATE_DISABLED
enum APGUI::IconType

types of Icon

Enumerator
ICON__BUTTON | after clicking, single action happens
ICON__SWITCH | switch, with two possible states.
ICON__MULTISWITCH | switch, with more possible states.

Function Documentation

APGUI::METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | ColorPicker |
 | ) |  |
APGUI::METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | Menu |
 | ) |  |
APGUI::METHOD_INPUT | ( | ExternalDeactivation | ,
 |  | MessageObjectID | ,
 |  | ColorPicker |
 | ) |  |
APGUI::METHOD_INPUT | ( | SliderValue | ,
 |  | MessageFloat | ,
 |  | Slider |
 | ) |  |
APGUI::METHOD_INPUT | ( | SwitchLayout | ,
 |  | MessageString | ,
 |  | GUI_Controller |
 | ) |  |
APGUI::METHOD_REQUEST_INPUT | ( | Sensor_0_mainClick | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | GUI_Controller |
 | ) |  |
APGUI::METHOD_REQUEST_INPUT | ( | Sensor_1_mainClick | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | GUI_Controller |
 | ) |  |
APGUI::METHOD_REQUEST_INPUT | ( | Sensor_0_contextClick | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | GUI_Controller |
 | ) |  |
APGUI::METHOD_REQUEST_INPUT | ( | Sensor_1_contextClick | ,
 |  | MessageBool | ,
 |  | MessageBool | ,
 |  | GUI_Controller |
 | ) |  |
APGUI::METHOD_REQUEST_INPUT | ( | EvokeHSLColorPicker | ,
 |  | MessageString | ,
 |  | MessageBool | ,
 |  | ColorPicker |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APHelloWorld Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APHelloWorld Namespace Reference

Classes

class MyAbility
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APHUD Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APHUD Namespace Reference

Classes

struct | HUDColorProfile
struct | HUDField
struct | HUDWindow
class | HUDDisplay
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APInputConnector Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APInputConnector Namespace Reference

Classes

class InputConnector
Input Connector class. More...

Functions

METHOD_REQUEST_INPUT (SensorTransformation, MessageInt, MessageSensorTransformation, InputConnector)
METHOD_REQUEST_INPUT (SelectedObjectID, MessageInt, MessageObjectID, InputConnector)

Function Documentation

APInputConnector::METHOD_REQUEST_INPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation | ,
 |  | InputConnector |
 | ) |  |
APInputConnector::METHOD_REQUEST_INPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID | ,
 |  | InputConnector |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APLightsEditor Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APLightsEditor Namespace Reference

Classes

struct | _Light
class | Editor
class | Lights
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
APMenu Namespace Reference

Classes

class | MenuItem
class | MenuItemNull
class | MenuItemText
class | MenuItemSlider
class | DynamicMenuSign
class | DynamicMenu
class | MenuLoaderErrorHandler

Enumerations

enum MenuType { RadialBoxes, RadialSections, Boxes, Grid }

Functions

METHOD_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt, DynamicMenu)

Enumeration Type Documentation

enum APMenu::MenuType
Enumerator
RadialBoxes
RadialSections
Boxes
Grid

Function Documentation

APMenu::METHOD_REQUEST_INPUT | ( | ActivePointerID | ,
 |  | MessageInt | ,
 |  | MessageInt | ,
 |  | DynamicMenu |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
APNature Namespace Reference

Classes

class | MidpointDisplacementAlgorithm
class | PerlinNoiseAlgorithm
class | RandomFaultsAlgorithm
class | TerrainAlgorithm
class | Default
class | GeneratedTerrainProperties
class | HeightMapProperties
class | MidpointDisplacementProperties
class | PerlinNoiseProperties
class | RandomFaultsProperties
class | TerrainProperties
class | Terrain2D
2D terrain based on height map which consists of multiple equally large segments. More...
class | Terrain2DSegment
Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point. More...
class | TerrainAbility
class | TerrainRandom
class | TerrainUtility

Enumerations

enum | TerrainAlignment { Left, Centre, Right }
enum | DataSourceType { None, Image, Algorithm }
enum | AlgorithmType { Displacement, Faults, PerlinNoise }
enum | InterpolationType { Linear, Cosine }
enum FileTypeExport {
MAX3DS, OBJ, IVE, OSG,
FLT, AC, FBX
}

Enumeration Type Documentation

enum APNature::AlgorithmType

Represents a several different types of algorithm used for terrain generation.

Enumerator
Displacement
Faults
PerlinNoise
enum APNature::DataSourceType

Used to differ among the source of input data for the terrain surface.

Enumerator
None
Image
Algorithm
enum APNature::FileTypeExport

Format in which is the terrain exported and saved to the disk.

Enumerator
MAX3DS
OBJ
IVE
OSG
FLT
AC
FBX
enum APNature::InterpolationType

Type of interpolation which is supposed to be used in Perlin noise algorithm.

Enumerator
Linear
Cosine
enum APNature::TerrainAlignment

Represents an alignment of a terrain block in a single axis.

Enumerator
Left
Centre
Right
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APObjectUtils Namespace Reference

Classes

class | Animator
class | ConnectionViz
class | CopyProperties
class | KeepOnScreen
class | ObjectEffect
class | ObjectEffectMan
class | ObjectInfo
class | ObjectModif
class | ObjectSelector
class | UseToEvent
struct | MyReadCallback
class | EOLineSegmentIntersector

Functions

void HSVtoRGB (float *r, float *g, float *b, float h, float s, float v)
METHOD_REQUEST_INPUT (SelectionID, MessageVoid, MessageObjectID, ObjectSelector)
METHOD_REQUEST_INPUT (SelectionByPointerPos, MessageVec3, MessageObjectID, ObjectSelector)
METHOD_REQUEST_INPUT (SelectionByPointerPos_Path, MessageVec3, MessageNodeList, ObjectSelector)

Function Documentation

void APObjectUtils::HSVtoRGB | ( | float * | r,
 |  | float * | g,
 |  | float * | b,
 |  | float | h,
 |  | float | s,
 |  | float | v
 | ) |  |
APObjectUtils::METHOD_REQUEST_INPUT | ( | SelectionID | ,
 |  | MessageVoid | ,
 |  | MessageObjectID | ,
 |  | ObjectSelector |
 | ) |  |
APObjectUtils::METHOD_REQUEST_INPUT | ( | SelectionByPointerPos | ,
 |  | MessageVec3 | ,
 |  | MessageObjectID | ,
 |  | ObjectSelector |
 | ) |  |
APObjectUtils::METHOD_REQUEST_INPUT | ( | SelectionByPointerPos_Path | ,
 |  | MessageVec3 | ,
 |  | MessageNodeList | ,
 |  | ObjectSelector |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
APRoomEdit Namespace Reference

Classes

class | ColorBucket
class | CreateHole
class | HoleRemove
class | PointAdd
class | PointMove
class | RoomEditor
class | RoomLoader
class | RoomSaver
class | Tool
class | WallAdd
class | WallGeometry
class | WallMovement
class | WallRemove

Enumerations

enum ToolType {
NONE = 0, COLORBUCKET = 1, WALLREMOVE = 2, WALLADD = 3,
WALLMOVEMENT = 4, POINTMOVE = 5, SAVER = 6, LOADER = 7,
CREATEHOLE = 8, HOLEREMOVE = 9, NORMALSSWITCHER = 10, POINTADD = 11
}

Enumeration Type Documentation

enum APRoomEdit::ToolType
Enumerator
NONE
COLORBUCKET
WALLREMOVE
WALLADD
WALLMOVEMENT
POINTMOVE
SAVER
LOADER
CREATEHOLE
HOLEREMOVE
NORMALSSWITCHER
POINTADD
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APShootingSimulation Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
APShootingSimulation Namespace Reference

Classes

class ShootingSimulation

Enumerations

enum GameStates {
PREPARE_NEW_GAME, PREPARE_NEXT_LEVEL, WAITING_FOR_START, COUNTDOWN,
RUNNING_LEVEL
}
enum MoveDirections {
NO_MOVE, MOVE_UP, MOVE_DOWN, MOVE_LEFT,
MOVE_RIGHT
}

Enumeration Type Documentation

enum APShootingSimulation::GameStates

Enum for determine the current game state.

Enumerator
PREPARE_NEW_GAME
PREPARE_NEXT_LEVEL
WAITING_FOR_START
COUNTDOWN
RUNNING_LEVEL
enum APShootingSimulation::MoveDirections

Enum for determine the state of target's movement.

Enumerator
NO_MOVE
MOVE_UP
MOVE_DOWN
MOVE_LEFT
MOVE_RIGHT
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APSpacePartitioning Namespace Reference

Classes

class | GeometryLoaderBase
class | NoPartitioning_Scene
class | PointShellGeneric_Object_Data
class | PointShell_SimpleNode
class | PointShell_Object_Data
class | PointShell_Object_Data_Geometry
class | PointShell_Object_Data_Geometry_Analyser
class | mycomparisonMinMax
class | mycomparisonMaxMin
struct | VLOD
struct | ELOD
struct | PLOD
struct | int_3
class | PointShell_Object_Data_LOD_Builder
class | PointShellVSVoxel_Object
class | SNCH_Object
class | SNCH_Object_Data
class | SP_Object_Data_Base
class | SphereBVH_Object
class | SphereBVH_Object_Data
class | SphereBVH_Scene
class | VoxelGrid_Object_Data
struct | VGReadCallback

Functions

int __cdecl | vertPtrSort (const SNCH_Object_Data::VertexSNCH **elem1, const SNCH_Object_Data::VertexSNCH **elem2)
DWORD WINAPI | HierarchyThreadProc (SP_Object_Data_Base *lpParameter)
int | compareX (const void *elem1, const void *elem2)
int | compareY (const void *elem1, const void *elem2)
int | compareZ (const void *elem1, const void *elem2)

Function Documentation

int APSpacePartitioning::compareX | ( | const void * | elem1,
 |  | const void * | elem2
 | ) |  |
int APSpacePartitioning::compareY | ( | const void * | elem1,
 |  | const void * | elem2
 | ) |  |
int APSpacePartitioning::compareZ | ( | const void * | elem1,
 |  | const void * | elem2
 | ) |  |
DWORD WINAPI APSpacePartitioning::HierarchyThreadProc ( SP_Object_Data_Base * lpParameter )
int __cdecl APSpacePartitioning::vertPtrSort | ( | const SNCH_Object_Data::VertexSNCH ** | elem1,
 |  | const SNCH_Object_Data::VertexSNCH ** | elem2
 | ) |  |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APTextOutput Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
APTextOutput Namespace Reference

Classes

class Console

Functions

void loggerGraphicConsoleOutput (unsigned long dwOutputType, const char *outputLine, void *userParam)
METHOD_REQUEST_INPUT (Add, MessageString, MessageVoid, Console)

Function Documentation

void APTextOutput::loggerGraphicConsoleOutput | ( | unsigned long | dwOutputType,
 |  | const char * | outputLine,
 |  | void * | userParam
 | ) |  |
APTextOutput::METHOD_REQUEST_INPUT | ( | Add | ,
 |  | MessageString | ,
 |  | MessageVoid | ,
 |  | Console |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APWeather Namespace Reference

  • Namespace List
  • Namespace Members
Classes
APWeather Namespace Reference

Classes

class Weather
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
ArtificialWorld Namespace Reference

Classes

class | BlockAttributes
Atributy bloku. More...
class | BlockUpdater
Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky. More...
class | Model
Uchovava informace o modelu. More...
class | AnimatedModel
Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit. More...
class | SubBlock
Trida reprezentujici jeden blok ve scene. More...
class | AnimationPoint
Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode. More...
class | SubBlockAnimation
Trida reprezentujici animaci bloku. More...
class | WorldBuilder
Trida, ktera vytvori hierarchicky svet ve scene. More...

Enumerations

enum | BlockAttributesSetEnum { noneSet = 0, centerDirSet = 1, centerPointSet = 2, bothSet = 3 }
Ktery z atributu bloku je nastaveny. More...
enum | ModelType { none, geometry, cal3D, other }
typ modelu More...
enum | ModelFlags { NONE = 1, NO_SUBBLOCKS = NONE << 1 }
flagy modelu More...
enum | AnimationType { ScaleRotateTranslation = 1, Alpha = 2, NodeMask = 4 }
Typ animace bloku. More...
enum | AnimationLoopType { NoLoop, Simple, BiDirectional }
Typ opakovani animace. More...
enum | AnimationInterpolationType { Linear, Sine }
Typ interpolace mezi jednotlivymi body animace. More...

Enumeration Type Documentation

enum ArtificialWorld::AnimationInterpolationType

Typ interpolace mezi jednotlivymi body animace.

Enumerator
Linear | linearni interpolace
Sine | sinova interpolace
enum ArtificialWorld::AnimationLoopType

Typ opakovani animace.

Enumerator
NoLoop | zadne opakovani, animace se provede prave jednou
Simple | jednoduche opakovani, animace se provadi porad dokola
BiDirectional | obousmerne opakovani, animace se prehraje do konce a pak po zpatku do zacatku atd.
enum ArtificialWorld::AnimationType

Typ animace bloku.

Enumerator
ScaleRotateTranslation | animace pomoci presunu, rotace a zvetseni
Alpha | animace zmenou alfa
NodeMask | animace zmenou masky
enum ArtificialWorld::BlockAttributesSetEnum

Ktery z atributu bloku je nastaveny.

Enumerator
noneSet | zadny
centerDirSet | nastaven pouze atribut CenterDir
centerPointSet | nastaven pouze atribut CenterPoint
bothSet | nastaveny oba atributy
enum ArtificialWorld::ModelFlags

flagy modelu

Enumerator
NONE | zadny
NO_SUBBLOCKS | je-li zobrazen tento model, nezobrazuj zadne subbloky
enum ArtificialWorld::ModelType

typ modelu

Enumerator
none | zadny
geometry | normalni, staticky model
cal3D | animovany model Cal3D
other | jiny
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Functions
base Namespace Reference

Classes

class | Avatar
class | Display
class | hand
class | Light
class | MouseHand
class | MTMatrixTransform
class | Rotate
class | ShowFDH
class | ShowFDHModel
class | SystemInfo
struct | _CLIENT_ID
struct | _THREAD_BASIC_INFORMATION

Typedefs

typedef LONG | NTSTATUS
typedef LONG | KPRIORITY
typedef NTSTATUS(WINAPI * | pNtQIT )(HANDLE, LONG, PVOID, ULONG, PULONG)
typedef struct base::_CLIENT_ID | CLIENT_ID
typedef struct base::_CLIENT_ID * | PCLIENT_ID
typedef struct
base::_THREAD_BASIC_INFORMATION 		THREAD_BASIC_INFORMATION
typedef struct
base::_THREAD_BASIC_INFORMATION * 		PTHREAD_BASIC_INFORMATION

Functions

METHOD_REQUEST_INPUT (SetMatrix, MessageMatrix, MessageVoid, MTMatrixTransform)
METHOD_REQUEST_INPUT (GetMatrix, MessageVoid, MessageMatrix, MTMatrixTransform)
bool GetThreadInfo (HANDLE hThread, PDWORD pStartAddress, PDWORD pdwAffinity)

Typedef Documentation

typedef struct base::_CLIENT_ID base::CLIENT_ID
typedef LONG base::KPRIORITY
typedef LONG base::NTSTATUS
typedef struct base::_CLIENT_ID * base::PCLIENT_ID
typedef NTSTATUS(WINAPI * base::pNtQIT)(HANDLE, LONG, PVOID, ULONG, PULONG)
typedef struct base::_THREAD_BASIC_INFORMATION * base::PTHREAD_BASIC_INFORMATION
typedef struct base::_THREAD_BASIC_INFORMATION base::THREAD_BASIC_INFORMATION

Function Documentation

bool base::GetThreadInfo | ( | HANDLE | hThread,
 |  | PDWORD | pStartAddress,
 |  | PDWORD | pdwAffinity
 | ) |  |
base::METHOD_REQUEST_INPUT | ( | SetMatrix | ,
 |  | MessageMatrix | ,
 |  | MessageVoid | ,
 |  | MTMatrixTransform |
 | ) |  |
base::METHOD_REQUEST_INPUT | ( | GetMatrix | ,
 |  | MessageVoid | ,
 |  | MessageMatrix | ,
 |  | MTMatrixTransform |
 | ) |  |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: behindO Namespace Reference

  • Namespace List
  • Namespace Members
Classes
behindO Namespace Reference

Classes

class | AvatarManipulator
class | CentreObjectManipulator
class | ChangeOfVisibility
class | ContactObjectManipulator
class | CuttingPlane
class | EyeManipulator
class | HeadManipulator
class | HMDHeadManipulator
class | Lens
class | Manipulator
class | MappingFunctions
class | MyUpdateCallback
class | MyCullCallback
class | Mirror
class | WIM
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: boids Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Variables
boids Namespace Reference

Classes

class | Boid
class | BoidsLogic
class | BoidsPlanner

Variables

const float cycles_per_sec = 30.0f

Variable Documentation

const float boids::cycles_per_sec = 30.0f
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: CarSim Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
CarSim Namespace Reference

Classes

class | CarControlUnit
struct | CarEnvirons
struct | Lights
struct | GeometryPartsPath
class | CarExecutionUnit
class | CarPartsNodeCache
struct | CarSize
struct | CarState
struct | StartStopDestination
struct | Parameters
struct | First3Juncs
struct | CarEdgeData
class | MessageRoadAndDir
class | MessageCarEdge
class | MessageCarEdgeData
class | MessageEdgeOffset
class | MessageVectorUnsignedInt
class | MessageStartStopDestination
class | MessageFirst3Juncs
class | MessageCarSimParameters
class | MessageCarEnvirons
class | MessageCarStatePtr
struct | EdgesCar
struct | Edge
struct | InOutEdgesAttr
struct | JuncsEdge
struct | Junction
struct | PolygonPoint
class | Remover
struct | RoadsEdges
class | RoadsState
struct | TLcolorsMT
class | TLsOnJuncManager

Functions

float getBrakeDist (const float carVel, const float desiredVel, const float carDecel, const float hillAcc)

Function Documentation

float CarSim::getBrakeDist | ( | const float | carVel,
 |  | const float | desiredVel,
 |  | const float | carDecel,
 |  | const float | hillAcc
 | ) |  |
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: esg Namespace Reference

  • Namespace List
  • Namespace Members
esg Namespace Reference
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Filter Namespace Reference

  • Namespace List
  • Namespace Members
Classes
Filter Namespace Reference

Classes

class | Linear
class | PosNoiseRemover
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Variables
grass Namespace Reference

Classes

class | Grass
class | GrassCullCallback
class | GrassDrawable
struct | Vertex
struct | Triangle
class | Mesh
struct | GrassAbilityParameters
class | TriangleCollector

Variables

const float maxLODdifference = 0.1f

Variable Documentation

const float grass::maxLODdifference = 0.1f
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Functions
ht Namespace Reference

Classes

class | HeadTracking
class | Screen
Defines position of screen in real world. More...
class | ScreenSetup
class | ScreenSetupSimple
class | Variable
class | VariableVec3
class | VariableVec2
class | VariableFloat
class | VariableQuat
class | Function
class | SetupFunction
class | SimpleSetupFunction

Typedefs

typedef std::list< Function * > | ListOfFunctions
typedef std::list< Variable * > | ListOfVariables

Functions

void | solve (ListOfFunctions &fcns, ListOfVariables &vars, double start_step=0.01, double next_step_scale=0.8, double min_step_size=1e-6)
METHOD_INPUT (Transformation, vrecko::MessageSensorTransformation, HeadTracking)
METHOD_INPUT (Position, vrecko::MessageSensorTransformation, ScreenSetup)
METHOD_INPUT (Record, vrecko::MessageBool, ScreenSetup)
METHOD_INPUT (NextCorner, vrecko::MessageBool, ScreenSetup)
METHOD_INPUT (ShowPosition, vrecko::MessageBool, ScreenSetup)
METHOD_INPUT (RunCalculation, vrecko::MessageBool, ScreenSetup)
METHOD_INPUT (Position, vrecko::MessageSensorTransformation, ScreenSetupSimple)
METHOD_INPUT (Record, vrecko::MessageBool, ScreenSetupSimple)
METHOD_INPUT (ShowPosition, vrecko::MessageBool, ScreenSetupSimple)
METHOD_INPUT (RunCalculation, vrecko::MessageBool, ScreenSetupSimple)
double | get_func_value (ListOfFunctions &fcns)
void | der_approx (ListOfFunctions &fcns, Variable *var, int subvar, double step, double &first, double &second)

Typedef Documentation

typedef std::list<Function *> ht::ListOfFunctions
typedef std::list<Variable *> ht::ListOfVariables

Function Documentation

void ht::der_approx | ( | ListOfFunctions & | fcns,
 |  | Variable * | var,
 |  | int | subvar,
 |  | double | step,
 |  | double & | first,
 |  | double & | second
 | ) |  |
double ht::get_func_value ( ListOfFunctions & fcns )
ht::METHOD_INPUT | ( | Position | ,
 |  | vrecko::MessageSensorTransformation | ,
 |  | ScreenSetupSimple |
 | ) |  |
ht::METHOD_INPUT | ( | Record | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetupSimple |
 | ) |  |
ht::METHOD_INPUT | ( | Transformation | ,
 |  | vrecko::MessageSensorTransformation | ,
 |  | HeadTracking |
 | ) |  |
ht::METHOD_INPUT | ( | ShowPosition | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetupSimple |
 | ) |  |
ht::METHOD_INPUT | ( | Position | ,
 |  | vrecko::MessageSensorTransformation | ,
 |  | ScreenSetup |
 | ) |  |
ht::METHOD_INPUT | ( | RunCalculation | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetupSimple |
 | ) |  |
ht::METHOD_INPUT | ( | Record | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetup |
 | ) |  |
ht::METHOD_INPUT | ( | NextCorner | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetup |
 | ) |  |
ht::METHOD_INPUT | ( | ShowPosition | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetup |
 | ) |  |
ht::METHOD_INPUT | ( | RunCalculation | ,
 |  | vrecko::MessageBool | ,
 |  | ScreenSetup |
 | ) |  |
void ht::solve | ( | ListOfFunctions & | fcns,
 |  | ListOfVariables & | vars,
 |  | double | start_step = 0.01,
 |  | double | next_step_scale = 0.8,
 |  | double | min_step_size = 1e-6
 | ) |  |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions
mv Namespace Reference

Classes

class | CCollection
class | CGesture
struct | CPoint
class | CMVect
class | CPlayer
class | Reader

Functions

double | ActTtoP (double t, double v0, double v1, double l)
double | PtoActT (double p, double v0, double v1, double l)

Function Documentation

double mv::ActTtoP | ( | double | t,
 |  | double | v0,
 |  | double | v1,
 |  | double | l
 | ) |  |
double mv::PtoActT | ( | double | p,
 |  | double | v0,
 |  | double | v1,
 |  | double | l
 | ) |  |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: navigation Namespace Reference

  • Namespace List
  • Namespace Members
Classes
navigation Namespace Reference

Classes

class | AvatarInHand
class | KMTracker
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode Namespace Reference

  • Namespace List
  • Namespace Members
Classes
ode Namespace Reference

Classes

class | CappedCylinder
class | CompositeObject
class | Cube
struct | ODEObject
class | DynamicScene
class | Sphere
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: osg Namespace Reference

  • Namespace List
  • Namespace Members
osg Namespace Reference
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ Namespace Reference

  • Namespace List
  • Namespace Members
Classes
osgQ Namespace Reference

Classes

class | QShapeVisitor
class | QConstShapeVisitor
class | QSection
class | QShapeDrawable
class | QDrawShapeVisitor
class | QComputeBoundShapeVisitor
class | QPrimitiveShapeVisitor
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin Namespace Reference

  • Namespace List
  • Namespace Members
Classes
PhysXPlugin Namespace Reference

Classes

class | BaseActor
class | BaseJoint
class | BasePhysXObject
class | Box
class | Capsule
class | Cloth
class | ClothDrawable
class | CoreActorDesc
class | CylindricalJoint
class | DistanceJoint
class | ErrorReporter
class | FixedJoint
class | Fluid
class | FluidDrawable
class | ForceField
class | MaterialManager
struct | Particle
class | PhysXObject
class | PhysXScene
class | MessageNxActorWithName
class | Plane
class | PointInPlaneJoint
class | PointOnLineJoint
class | PrismaticJoint
class | PulleyJoint
class | RemoteDebugger
class | RevoluteJoint
class | Sphere
class | SphericalJoint
class | UpdatablePhysXObject
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions | Variables
VirtualFixture Namespace Reference

Classes

class | Avatar
class | AxisLock
class | Border
class | Box
class | Cone
class | Cylinder
class | Damper
class | Drag
class | Filter
class | Grid
class | Log
class | Marker
class | MarkerFactory
class | NavSphere
class | Plane
class | ProxiBorder
class | ProxiBox
class | ProxiCone
class | ProxiCylinder
class | ProxiSphere
class | Sphere
class | Trace
class | Vibration
class | VibrationLabel
class | VibrationLabelActivator

Functions

osg::Vec3 | ControlActualPositionReturnCleanPosition (osg::Vec3 Actual)
bool | ControlActualPosition (osg::Vec3 Actual)
osg::Vec3 | Vibrate (float frequency, float amplitude, osg::Vec3 direction)
osg::Vec3 | ForceTransformFunction (float maxforce, osg::Vec3 force)
float | SmoothEnding (float t)

Variables

osg::Timer | timer
osg::Timer | vtimer

Function Documentation

bool VirtualFixture::ControlActualPosition ( osg::Vec3 Actual )
osg::Vec3 VirtualFixture::ControlActualPositionReturnCleanPosition ( osg::Vec3 Actual )
osg::Vec3 VirtualFixture::ForceTransformFunction | ( | float | maxforce,
 |  | osg::Vec3 | force
 | ) |  |
float VirtualFixture::SmoothEnding ( float t )
osg::Vec3 VirtualFixture::Vibrate | ( | float | frequency,
 |  | float | amplitude,
 |  | osg::Vec3 | direction
 | ) |  |

Variable Documentation

osg::Timer VirtualFixture::timer
osg::Timer VirtualFixture::vtimer
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VK_NoStepInto_Namespace Namespace Reference

  • Namespace List
  • Namespace Members
Classes
VK_NoStepInto_Namespace Namespace Reference

Classes

class DynamicArray
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables
vrecko Namespace Reference

Second level of space paritioning queries - detailed searching inside object. More...

Classes

class | BufferedFile
class | BufferedFileWrite
class | Ability
class | AbilityDispatcher
used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities More...
class | Attribute
class | AttributesDescription
class | IOPinBase
Base class that defines the very basic method that every IO pin will have. More...
class | InputPinBase
class | OutputPinBase
class | IORequestPinBase
class | RequestInputPinBase
class | RequestOutputPinBase
class | BaseClass
class | BenchmarkWriter
Class to write any timings and other benchmark data into file. More...
class | Device
class | DeviceManager
class | DynamicAttribute
class | Enumeration
class | EnvironmentObject
class | EventDispatcher
class | Interval
class | InputPin
class | OutputPin
class | RequestInputPin
class | RequestOutputPin
class | Logger
class | VreckoMessage
class | MessageVoid
class | MessageSensorTransformation
class | MTLock
Base class for multi-thread access to a single variable. More...
class | MTAutoLock
class | MTReadWriteLock
class | MTReadWriteLockEx
class | MTTwoPrioLimitedLock
class | OctTree
class | PersistentCache
Caching that persists multiple application sessions. More...
class | PluginManager
Simple class to load and manage the plugins. More...
class | PyAbility
Python ability. More...
class | Range
class | RWErrorHandler
class | ReaderWriter
class | XercesStr
struct | ScenePSThreadInfo
class | Scene
class | Scheduler
class | CollisionPointInfo
class | CollisionInfo
class | CollisionParams__ver1
Parameters for the SP_SceneInterface::getCollisions() method. More...
class | SP_Object_DataInterface
class | SP_ObjectInterface
class | SP_SceneInterface
class | StaticAttribute
class | Timer
class | ViewerBase
Abstract VRECKO viewer class. More...
class | Viewer
Child class for classic one screen viewer - used for QUAD_STEREO. More...
class | CompositeViewer
Child class for more than one screen viewer. More...
class | vThread
class | World
struct | CABUTTONEVENT
class | MessageCAButtonEvent
struct | CAINFO__VER1
struct | CAINFO__VER2
class | ControllableAbility
class | logger_streambuf
class | MaterialDesc

Typedefs

typedef Enumeration< int > | IntEnumeration
used with integers More...
typedef Enumeration< long > | LongEnumeration
used with longs More...
typedef Enumeration< float > | FloatEnumeration
used with floats More...
typedef Enumeration< double > | DoubleEnumeration
used with doubles More...
typedef Enumeration< string,
const string & > 		StringEnumeration
used with strings More...
typedef Interval< int > | IntInterval
typedef Interval< long > | LongInterval
used with integers and strings More...
typedef Interval< float > | FloatInterval
used with longs More...
typedef Interval< double > | DoubleInterval
used with floats More...
typedef MTLock | MTLockSingleProcess
typedef pthread_mutex * | VRECKOMutex
typedef std::vector
< CollisionPointInfo > 		COLLISION_POINTS_VECTOR
typedef DynamicArray
< CollisionInfo > 		COLLISIONS_INFO_VECTOR
typedef CollisionParams__ver1 | CollisionParams
typedef StaticAttribute
< Attribute::TYPE_BOOL, bool > 		BoolAttribute
typedef StaticAttribute
< Attribute::TYPE_INT, int > 		IntAttribute
booleans More...
typedef StaticAttribute
< Attribute::TYPE_LONG, long > 		LongAttribute
integers More...
typedef StaticAttribute
< Attribute::TYPE_FLOAT, float > 		FloatAttribute
longs More...
typedef StaticAttribute
< Attribute::TYPE_DOUBLE,
double > 		DoubleAttribute
floats More...
typedef StaticAttribute
< Attribute::TYPE_STRING,
string, const string & > 		StringAttribute
doubles More...
typedef StaticAttribute
< Attribute::TYPE_VEC2, Vec2,
const Vec2 & > 		Vec2Attribute
strings More...
typedef StaticAttribute
< Attribute::TYPE_VEC3, Vec3,
const Vec3 & > 		Vec3Attribute
2D vectors More...
typedef StaticAttribute
< Attribute::TYPE_VEC4, Vec4,
const Vec4 & > 		Vec4Attribute
3D vectors More...
typedef StaticAttribute
< Attribute::TYPE_MATRIX,
Matrix, const Matrix & > 		MatrixAttribute
4D vectors More...
typedef StaticAttribute
< Attribute::TYPE_QUAT, Quat,
const Quat & > 		QuatAttribute
matrices More...
typedef CAINFO__VER2 | CAINFO

Enumerations

enum EventType { NORMAL_EVENT, PRIORITY_EVENT, EXPRESS_EVENT }
Type of the event. More...

Functions

bool | FileExists (const _TCHAR *pFileName)
virtual bool | setValueFromString (const char *valueAsString)
VRECKO_END_MESSAGE | MessageString (const std::string &_data)
MessageString (const char *_data)
virtual bool | isEqualTo (VreckoMessage *otherMsg)
VRECKO_END_MESSAGE | MessageVec2 (const osg::Vec2 &_data)
VRECKO_END_MESSAGE | MessageVec3 (const osg::Vec3 &_data)
VRECKO_END_MESSAGE | MessageVec4 (const osg::Vec4 &_data)
VRECKO_END_MESSAGE | MessageQuat (const osg::Quat &_data)
VRECKO_END_MESSAGE | MessageMatrix (const osg::Matrix &_data)
VRECKO_END_MESSAGE | MessageNodeList (const std::vector< osg::Node * > &_data)
VRECKO_END_MESSAGE | MessageNode (osg::Node *newNode)
MessageXMLNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *newNode)
DWORD WINAPI | ScenePSThreadProc (ScenePSThreadInfo *lpParameter)
VRECKO_EXPORT bool | initXML ()
VRECKO_EXPORT bool | doneXML ()
VRECKO_EXPORT const std::string & | getSafeSceneFile (const std::string &sceneFile)
VRECKO_EXPORT unsigned long | getNumSceneFiles ()
Returns the number of stored scene files. More...
VRECKO_EXPORT const std::string & | getSafeSceneFile (unsigned long index)
Return an appropriate scene file ([index] can be from 0 to getNumSceneFiles()-1) More...
VRECKO_EXPORT const std::string & | getSafeDefaultSceneFile ()
VRECKO_EXPORT void | setDefaultSceneFile (const std::string &newDefaultSceneFile)
bool | Wait (int nObjects, HANDLE *pObjects, DWORD Timeout=INFINITE)
bool | Wait1 (HANDLE hObj, DWORD Timeout=INFINITE)
bool | Wait2 (HANDLE hObj1, HANDLE hObj2, DWORD Timeout=INFINITE)
bool | Wait3 (HANDLE hObj1, HANDLE hObj2, HANDLE hObj3, DWORD Timeout=INFINITE)
osg::Vec4 | base1 (1.0, 0.0, 0.0, 0.0)
osg::Vec4 | base2 (0.0, 0.0,-1.0, 0.0)
osg::Vec4 | base3 (0.0, 1.0, 0.0, 0.0)
osg::Vec4 | baseR1 (-1.0, 0.0, 0.0, 0.0)
osg::Vec4 | baseR2 (0.0, 0.0, 1.0, 0.0)
osg::Vec4 | baseR3 (0.0,-1.0, 0.0, 0.0)
osg::Vec4 | origin (0.0, 0.0, 0.0, 1.0)
METHOD_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt, ControllableAbility)
METHOD_REQUEST_INPUT (GetInfo, MessageVoid, ControllableAbility::MessageCAINFO, ControllableAbility)

Variables

class VRECKO_EXPORT | EnvironmentObject
class VRECKO_EXPORT | World
class VRECKO_EXPORT | AutoPtrV
class VRECKO_EXPORT | BaseClass
class VRECKO_EXPORT | Scene
template class VRECKO_EXPORT | OutputPin< MessageBool >
template class VRECKO_EXPORT | InputPin< MessageBool >
template class VRECKO_EXPORT | OutputPin< MessageInt >
template class VRECKO_EXPORT | InputPin< MessageInt >
template class VRECKO_EXPORT | OutputPin< MessageUnsignedInt >
template class VRECKO_EXPORT | InputPin< MessageUnsignedInt >
template class VRECKO_EXPORT | OutputPin< MessageFloat >
template class VRECKO_EXPORT | InputPin< MessageFloat >
template class VRECKO_EXPORT | OutputPin< MessageObjectID >
template class VRECKO_EXPORT | InputPin< MessageObjectID >
template class VRECKO_EXPORT | OutputPin< MessageString >
template class VRECKO_EXPORT | InputPin< MessageString >
template class VRECKO_EXPORT | OutputPin< MessageVec2 >
template class VRECKO_EXPORT | InputPin< MessageVec2 >
template class VRECKO_EXPORT | OutputPin< MessageVec3 >
template class VRECKO_EXPORT | InputPin< MessageVec3 >
template class VRECKO_EXPORT | OutputPin< MessageVec4 >
template class VRECKO_EXPORT | InputPin< MessageVec4 >
template class VRECKO_EXPORT | OutputPin< MessageQuat >
template class VRECKO_EXPORT | InputPin< MessageQuat >
template class VRECKO_EXPORT | OutputPin< MessageMatrix >
template class VRECKO_EXPORT | InputPin< MessageMatrix >
VRECKO_EXPORT Logger | logger
VRECKO_END_MESSAGE class
XERCES_CPP_NAMESPACE_QUALIFIER 		DOMNode
class VRECKO_EXPORT | DeviceManager
class VRECKO_EXPORT | EventDispatcher
VRECKO_EXPORT World * | world = NULL
char | trash [256]

Detailed Description

Second level of space paritioning queries - detailed searching inside object.

First level of space paritioning queries - searching for object related to task.

Interval.h

Author: Martin [yanas] Janik yanas.nosp@m.@yan.nosp@m.as.cz ICQ: 125931550

Version: 02/02/2006

Range.h

Author: Martin [yanas] Janik yanas.nosp@m.@yan.nosp@m.as.cz ICQ: 125931550

Version: 02/02/2006

vreckoViewer

This adaptor class was created for better working with osg viewer classes. If you need method which is not listed here, feel free to add it.

Author
: Martin Bezdeka
Date
: 6. 12. 2010

Typedef Documentation

typedef StaticAttribute<Attribute::TYPE_BOOL, bool> vrecko::BoolAttribute

Definitions of basic attribute types.

typedef CAINFO__VER2 vrecko::CAINFO
typedef std::vector<CollisionPointInfo> vrecko::COLLISION_POINTS_VECTOR
typedef CollisionParams__ver1 vrecko::CollisionParams
typedef DynamicArray<CollisionInfo> vrecko::COLLISIONS_INFO_VECTOR
typedef StaticAttribute<Attribute::TYPE_DOUBLE, double> vrecko::DoubleAttribute

floats

typedef Enumeration<double> vrecko::DoubleEnumeration

used with doubles

typedef Interval<double> vrecko::DoubleInterval

used with floats

typedef StaticAttribute<Attribute::TYPE_FLOAT, float> vrecko::FloatAttribute

longs

typedef Enumeration<float> vrecko::FloatEnumeration

used with floats

typedef Interval<float> vrecko::FloatInterval

used with longs

typedef StaticAttribute<Attribute::TYPE_INT, int> vrecko::IntAttribute

booleans

typedef Enumeration<int> vrecko::IntEnumeration

used with integers

Definitions of basic enumeration types.

typedef Interval<int> vrecko::IntInterval

Definitions of interval types.

typedef StaticAttribute<Attribute::TYPE_LONG, long> vrecko::LongAttribute

integers

typedef Enumeration<long> vrecko::LongEnumeration

used with longs

typedef Interval<long> vrecko::LongInterval

used with integers and strings

typedef StaticAttribute<Attribute::TYPE_MATRIX, Matrix, const Matrix&> vrecko::MatrixAttribute

4D vectors

typedef MTLock vrecko::MTLockSingleProcess
typedef StaticAttribute<Attribute::TYPE_QUAT, Quat, const Quat&> vrecko::QuatAttribute

matrices

typedef StaticAttribute<Attribute::TYPE_STRING, string, const string&> vrecko::StringAttribute

doubles

Definitions of object attribute types.

typedef Enumeration<string, const string&> vrecko::StringEnumeration

used with strings

Definitions of obejct enumeration types.

typedef StaticAttribute<Attribute::TYPE_VEC2, Vec2, const Vec2&> vrecko::Vec2Attribute

strings

typedef StaticAttribute<Attribute::TYPE_VEC3, Vec3, const Vec3&> vrecko::Vec3Attribute

2D vectors

typedef StaticAttribute<Attribute::TYPE_VEC4, Vec4, const Vec4&> vrecko::Vec4Attribute

3D vectors

typedef pthread_mutex* vrecko::VRECKOMutex

Enumeration Type Documentation

enum vrecko::EventType

Type of the event.

Enumerator
NORMAL_EVENT
PRIORITY_EVENT
EXPRESS_EVENT

Function Documentation

osg::Vec4 vrecko::base1 | ( | 1. | 0,
 |  | 0. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec4 vrecko::base2 | ( | 0. | 0,
 |  | 0. | 0,
 |  | -1. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec4 vrecko::base3 | ( | 0. | 0,
 |  | 1. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec4 vrecko::baseR1 | ( | -1. | 0,
 |  | 0. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec4 vrecko::baseR2 | ( | 0. | 0,
 |  | 0. | 0,
 |  | 1. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec4 vrecko::baseR3 | ( | 0. | 0,
 |  | -1. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |
bool vrecko::doneXML ( )
bool vrecko::FileExists ( const _TCHAR * pFileName )
unsigned long vrecko::getNumSceneFiles ( )

Returns the number of stored scene files.

const std::string & vrecko::getSafeDefaultSceneFile ( )

Returns a default scene file, where all newly created objects/abilities/connections will be stored. Might be an empty string, which means "do not save to a file".

const std::string & vrecko::getSafeSceneFile ( const std::string & sceneFile )

Returns a pointer to the shared pool of scene file names. This pointer will be valid throughout the existence of the application. An empty string may be specified as a parameter, which means "no file".

const std::string & vrecko::getSafeSceneFile ( unsigned long index )

Return an appropriate scene file ([index] can be from 0 to getNumSceneFiles()-1)

bool vrecko::initXML ( )
bool vrecko::isEqualTo ( VreckoMessage * otherMsg )
virtual
VRECKO_END_MESSAGE vrecko::MessageMatrix ( const osg::Matrix & _data )
VRECKO_END_MESSAGE vrecko::MessageNode ( osg::Node * newNode )
VRECKO_END_MESSAGE vrecko::MessageNodeList ( const std::vector< osg::Node * > & _data )
VRECKO_END_MESSAGE vrecko::MessageQuat ( const osg::Quat & _data )
VRECKO_END_MESSAGE vrecko::MessageString ( const std::string & _data )
vrecko::MessageString ( const char * _data )
VRECKO_END_MESSAGE vrecko::MessageVec2 ( const osg::Vec2 & _data )
VRECKO_END_MESSAGE vrecko::MessageVec3 ( const osg::Vec3 & _data )
VRECKO_END_MESSAGE vrecko::MessageVec4 ( const osg::Vec4 & _data )
vrecko::MessageXMLNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * newNode )
vrecko::METHOD_REQUEST_INPUT | ( | ActivePointerID | ,
 |  | MessageInt | ,
 |  | MessageInt | ,
 |  | ControllableAbility |
 | ) |  |
vrecko::METHOD_REQUEST_INPUT | ( | GetInfo | ,
 |  | MessageVoid | ,
 |  | ControllableAbility::MessageCAINFO | ,
 |  | ControllableAbility |
 | ) |  |
osg::Vec4 vrecko::origin | ( | 0. | 0,
 |  | 0. | 0,
 |  | 0. | 0,
 |  | 1. | 0
 | ) |  |
DWORD WINAPI vrecko::ScenePSThreadProc ( ScenePSThreadInfo * lpParameter )
void vrecko::setDefaultSceneFile ( const std::string & newDefaultSceneFile )

Sets a new default scene file (will be automatically safe to use for anybody). Might be an empty string meaning "do not save to a file".

bool vrecko::setValueFromString ( const char * valueAsString )
virtual
The lines below are equivalent to the commented code:

class MessageBool : public VreckoMessage { public: virtual const char* getMessageId() { return "MessageBool"; }

MessageBool() {}; MessageBool(bool newData) { data = newData; }; virtual bool setValueFromString(const char *valueAsString) { data = (atoi(valueAsString) > 0); return true; };

bool data; };

bool vrecko::Wait | ( | int | nObjects,
 |  | HANDLE * | pObjects,
 |  | DWORD | Timeout = INFINITE
 | ) |  |
inline
bool vrecko::Wait1 | ( | HANDLE | hObj,
 |  | DWORD | Timeout = INFINITE
 | ) |  |
inline
bool vrecko::Wait2 | ( | HANDLE | hObj1,
 |  | HANDLE | hObj2,
 |  | DWORD | Timeout = INFINITE
 | ) |  |
inline
bool vrecko::Wait3 | ( | HANDLE | hObj1,
 |  | HANDLE | hObj2,
 |  | HANDLE | hObj3,
 |  | DWORD | Timeout = INFINITE
 | ) |  |
inline

Variable Documentation

class VRECKO_EXPORT vrecko::AutoPtrV
class VRECKO_EXPORT vrecko::BaseClass
class VRECKO_EXPORT vrecko::DeviceManager
VRECKO_END_MESSAGE class XERCES_CPP_NAMESPACE_QUALIFIER vrecko::DOMNode
class VRECKO_EXPORT vrecko::EnvironmentObject
class VRECKO_EXPORT vrecko::EventDispatcher
template class VRECKO_EXPORT vrecko::InputPin< MessageBool >
template class VRECKO_EXPORT vrecko::InputPin< MessageFloat >
template class VRECKO_EXPORT vrecko::InputPin< MessageInt >
template class VRECKO_EXPORT vrecko::InputPin< MessageMatrix >
template class VRECKO_EXPORT vrecko::InputPin< MessageObjectID >
template class VRECKO_EXPORT vrecko::InputPin< MessageQuat >
template class VRECKO_EXPORT vrecko::InputPin< MessageString >
template class VRECKO_EXPORT vrecko::InputPin< MessageUnsignedInt >
template class VRECKO_EXPORT vrecko::InputPin< MessageVec2 >
template class VRECKO_EXPORT vrecko::InputPin< MessageVec3 >
template class VRECKO_EXPORT vrecko::InputPin< MessageVec4 >
Logger vrecko::logger
template class VRECKO_EXPORT vrecko::OutputPin< MessageBool >
template class VRECKO_EXPORT vrecko::OutputPin< MessageFloat >
template class VRECKO_EXPORT vrecko::OutputPin< MessageInt >
template class VRECKO_EXPORT vrecko::OutputPin< MessageMatrix >
template class VRECKO_EXPORT vrecko::OutputPin< MessageObjectID >
template class VRECKO_EXPORT vrecko::OutputPin< MessageQuat >
template class VRECKO_EXPORT vrecko::OutputPin< MessageString >
template class VRECKO_EXPORT vrecko::OutputPin< MessageUnsignedInt >
template class VRECKO_EXPORT vrecko::OutputPin< MessageVec2 >
template class VRECKO_EXPORT vrecko::OutputPin< MessageVec3 >
template class VRECKO_EXPORT vrecko::OutputPin< MessageVec4 >
class VRECKO_EXPORT vrecko::Scene
char vrecko::trash[256]
class VRECKO_EXPORT vrecko::World
World * vrecko::world = NULL

Global variable accessible from anywhere. Holds pointer to the world and through it to all of the structures.

Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Variables
vreckoDP_base Namespace Reference

Classes

class | A3DBird
class | fdtDataGlove
struct | dataT
class | fsPinchGlove
class | KeyboardMouse
class | L3DMouse
class | LHeadTracker
class | MicroScribe3D
class | NestOfBirds
class | OptiTrack
class | Ultratrak
class | VRPN3DMouse
class | Wiimote

Enumerations

enum | htd_receiver_pos { HTD_REC_POS_OUT = 0, HTD_REC_POS_ACT, HTD_REC_POS_FRI }
enum | rotation_type { QUATERNION = 0, MATRIX, ANGLES }
enum virtualKeyCode {
V3DK_MENU =0, V3DK_FIT, V3DK_TOP, V3DK_LEFT,
V3DK_RIGHT, V3DK_FRONT, V3DK_BOTTOM, V3DK_BACK,
V3DK_CW, V3DK_CCW, V3DK_ISO1, V3DK_ISO2,
V3DK_1, V3DK_2, V3DK_3, V3DK_4,
V3DK_5, V3DK_6, V3DK_7, V3DK_8,
V3DK_9, V3DK_10, V3DK_ESC, V3DK_ALT,
V3DK_SHIFT, V3DK_CTRL, V3DK_ROTATE, V3DK_PANZOOM,
V3DK_DOMINANT, V3DK_PLUS, V3DK_MINUS
}

Variables

const std::string virtualKey []

Detailed Description

VRPN3DMouse.h - device class

This class provides interface with 3DConnexion SpacePilot Pro 3D Mouse using VRPN Server

Author
Martin Bezdeka
Date
Id:
VRPN3DMouse.h 238 2011-09-27 14:57:25Z xbezdeka

Missing this files? Get the latest VRPN distro at ftp://ftp.cs.unc.edu/pub/packages/GRIP/vrpn

Enumeration Type Documentation

enum vreckoDP_base::htd_receiver_pos
Enumerator
HTD_REC_POS_OUT
HTD_REC_POS_ACT
HTD_REC_POS_FRI
enum vreckoDP_base::rotation_type
Enumerator
QUATERNION
MATRIX
ANGLES
enum vreckoDP_base::virtualKeyCode
Enumerator
V3DK_MENU
V3DK_FIT
V3DK_TOP
V3DK_LEFT
V3DK_RIGHT
V3DK_FRONT
V3DK_BOTTOM
V3DK_BACK
V3DK_CW
V3DK_CCW
V3DK_ISO1
V3DK_ISO2
V3DK_1
V3DK_2
V3DK_3
V3DK_4
V3DK_5
V3DK_6
V3DK_7
V3DK_8
V3DK_9
V3DK_10
V3DK_ESC
V3DK_ALT
V3DK_SHIFT
V3DK_CTRL
V3DK_ROTATE
V3DK_PANZOOM
V3DK_DOMINANT
V3DK_PLUS
V3DK_MINUS

Variable Documentation

const std::string vreckoDP_base::virtualKey[]
Initial value:
=
{
"Menu", "Fit", "Top", "Left", "Right", "Front", "Bottom",
"Back", "CW", "CCW", "ISO1", "ISO2", "1", "2", "3", "4", "5",
"6", "7", "8", "9", "10", "Esc", "Alt", "Shift", "Ctrl", "Rotate",
"Panzoom", "Dominant", "Plus", "Minus"
}
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_Kinect Namespace Reference

  • Namespace List
  • Namespace Members
Classes
vreckoDP_Kinect Namespace Reference

Classes

class Kinect
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs
vreckoUtils Namespace Reference

Classes

class | HighlightCallback
class | Math
class | MenuCommon
class | IMenuComponent
class | MenuBase
class | MenuRoot
class | Menu
class | MenuItem
class | MenuSlider
class | MenuVisitor
class | Observer
class | Observable

Typedefs

typedef std::vector
< osg::ref_ptr< IMenuComponent >
>::const_iterator 		IMenuComponentIter
typedef osg::ref_ptr< Menu > MenuPtr

Typedef Documentation

typedef std::vector< osg::ref_ptr<IMenuComponent> >::const_iterator vreckoUtils::IMenuComponentIter
typedef osg::ref_ptr<Menu> vreckoUtils::MenuPtr
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
WAVEFRONT Namespace Reference

Classes

class | InPlaceParserInterface
class | InPlaceParser
class | GeometryVertex
class | GeometryInterface
class | OBJ
class | BuildMesh

Enumerations

enum SeparatorType { ST_DATA, ST_HARD, ST_SOFT, ST_EOS }

Enumeration Type Documentation

enum WAVEFRONT::SeparatorType
Enumerator
ST_DATA
ST_HARD
ST_SOFT
ST_EOS
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
WGeometry Namespace Reference

Classes

class | WG_Geometry
class | WG_Vertices
class | WG_Point
class | WG_Hole
class | WG_Wall

Enumerations

enum | PointType { WG_Q_POINT, WG_R_POINT }
enum | HoleType { ht_window, ht_door }

Enumeration Type Documentation

enum WGeometry::HoleType
Enumerator
ht_window
ht_door
enum WGeometry::PointType
Enumerator
WG_Q_POINT
WG_R_POINT
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- _ -

  • __pad0__ : APDYNAMICART
  • _uint : APCameraPath
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AC : APNature
  • ActTtoP() : mv
  • Algorithm : APNature
  • AlgorithmType : APNature
  • Alpha : ArtificialWorld
  • ANGLES : vreckoDP_base
  • AnimationInterpolationType : ArtificialWorld
  • AnimationLoopType : ArtificialWorld
  • AnimationType : ArtificialWorld
  • area() : APConstrainedMovement
  • ATT__RENDER_LINES : APDYNAMICART
  • ATT__RENDER_POINTS : APDYNAMICART
  • ATT__RENDER_TRIANGLES : APDYNAMICART
  • AttractorNames : APDYNAMICART
  • AttractorPtr : APDYNAMICART
  • AttractorRenderingType : APDYNAMICART
  • AutoPtrV : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • base1() : vrecko
  • base2() : vrecko
  • base3() : vrecko
  • BaseClass : vrecko
  • baseR1() : vrecko
  • baseR2() : vrecko
  • baseR3() : vrecko
  • BiDirectional : ArtificialWorld
  • BlockAttributesSetEnum : ArtificialWorld
  • BoolAttribute : vrecko
  • bothSet : ArtificialWorld
  • Boxes : APMenu
  • BrushPtr : APDYNAMICART
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • CAINFO : vrecko
  • cal3D : ArtificialWorld
  • calcAngleSum() : APConstrainedMovement
  • Center() : AP_LSystem
  • centerDirSet : ArtificialWorld
  • centerPointSet : ArtificialWorld
  • Centre : APNature
  • centroid() : APConstrainedMovement
  • CLIENT_ID : base
  • COLLISION_POINTS_VECTOR : vrecko
  • CollisionParams : vrecko
  • COLLISIONS_INFO_VECTOR : vrecko
  • COLORBUCKET : APRoomEdit
  • colorGenAdapter : APDYNAMICART
  • ColorList : APDYNAMICART
  • combNum() : APFFDEditor
  • compareX() : APSpacePartitioning
  • compareY() : APSpacePartitioning
  • compareZ() : APSpacePartitioning
  • ComputeThreadPtr : APDYNAMICART
  • ConstraintAreas : APConstrainedMovement
  • ControlActualPosition() : VirtualFixture
  • ControlActualPositionReturnCleanPosition() : VirtualFixture
  • convexPolygon() : APConstrainedMovement
  • Cosine : APNature
  • COUNTDOWN : APShootingSimulation
  • CREATEHOLE : APRoomEdit
  • createParticleSystem() : APDYNAMICART
  • crossSectionAdapter : APDYNAMICART
  • cycles_per_sec : boids
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • DataSourceType : APNature
  • DATools : APDYNAMICART
  • DAToolType : APDYNAMICART
  • der_approx() : ht
  • DeviceManager : vrecko
  • DiameterGenAdapter : APDYNAMICART
  • diamGenAdapt : APDYNAMICART
  • Displacement : APNature
  • DOMNode : vrecko
  • doneXML() : vrecko
  • DoubleAttribute : vrecko
  • DoubleEnumeration : vrecko
  • DoubleInterval : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EnvironmentObject : vrecko
  • EnvironmentObjectIDs : APConstrainedMovement
  • EventDispatcher : vrecko
  • EventType : vrecko
  • EXPRESS_EVENT : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • F1() : APCameraPath
  • F2() : APCameraPath
  • F3() : APCameraPath
  • F4() : APCameraPath
  • factorial() : APFFDEditor
  • Faults : APNature
  • FBX : APNature
  • FHP__LAG_SKIP : APDYNAMICART
  • FHP__REAL_TIME : APDYNAMICART
  • FileExists() : vrecko
  • FileTypeExport : APNature
  • FloatAttribute : vrecko
  • FloatEnumeration : vrecko
  • FloatInterval : vrecko
  • FLT : APNature
  • ForceTransformFunction() : VirtualFixture
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • GameStates : APShootingSimulation
  • GeodePtr : APDYNAMICART
  • geometry : ArtificialWorld
  • GeometryPtr : APDYNAMICART
  • get_func_value() : ht
  • getBrakeDist() : CarSim
  • getNumSceneFiles() : vrecko
  • getParentsTransform() : APFFDEditor
  • getParentsTransformMat() : APFFDEditor
  • getSafeDefaultSceneFile() : vrecko
  • getSafeSceneFile() : vrecko
  • GetThreadInfo() : base
  • Grid : APMenu
  • GUI_ACTION : APGUI
  • GUI_ACTION_CONTEXT : APGUI
  • GUI_ACTION_MAIN : APGUI
  • GUI_ITEM_STATE : APGUI
  • GUI_ITEM_STATE_ACTIVE : APGUI
  • GUI_ITEM_STATE_DEFAULT : APGUI
  • GUI_ITEM_STATE_DISABLED : APGUI
  • GuiItemMapType : APGUI
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • HeadVec() : AP_LSystem
  • HierarchyThreadProc() : APSpacePartitioning
  • HOLEREMOVE : APRoomEdit
  • HoleType : WGeometry
  • Hook : APDYNAMICART
  • HoopGeometryPtr : APDYNAMICART
  • HoopPtr : APDYNAMICART
  • HoopShapePtr : APDYNAMICART
  • HSVtoRGB() : APObjectUtils
  • ht_door : WGeometry
  • ht_window : WGeometry
  • HTD_REC_POS_ACT : vreckoDP_base
  • HTD_REC_POS_FRI : vreckoDP_base
  • HTD_REC_POS_OUT : vreckoDP_base
  • htd_receiver_pos : vreckoDP_base
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • IComputeStrategyPtr : APDYNAMICART
  • ICON__BUTTON : APGUI
  • ICON__MULTISWITCH : APGUI
  • ICON__SWITCH : APGUI
  • IconType : APGUI
  • Image : APNature
  • IMenuComponentIter : vreckoUtils
  • IMenuComponentPtr : APDYNAMICART
  • initXML() : vrecko
  • InputPin< MessageBool > : vrecko
  • InputPin< MessageFloat > : vrecko
  • InputPin< MessageInt > : vrecko
  • InputPin< MessageMatrix > : vrecko
  • InputPin< MessageObjectID > : vrecko
  • InputPin< MessageQuat > : vrecko
  • InputPin< MessageString > : vrecko
  • InputPin< MessageUnsignedInt > : vrecko
  • InputPin< MessageVec2 > : vrecko
  • InputPin< MessageVec3 > : vrecko
  • InputPin< MessageVec4 > : vrecko
  • IntAttribute : vrecko
  • IntEnumeration : vrecko
  • InterpolationType : APNature
  • InterpretErrorCodes : AP_LSystem
  • IntInterval : vrecko
  • IParametersPtr : APDYNAMICART
  • isEqualTo() : vrecko
  • IShapeGeneratorPtr : APDYNAMICART
  • IVE : APNature
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- k -

  • KPRIORITY : base
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LayoutMapType : APGUI
  • Left : APNature
  • LeftVec() : AP_LSystem
  • Linear : ArtificialWorld , APNature
  • ListOfFunctions : ht
  • ListOfVariables : ht
  • LOADER : APRoomEdit
  • logger : vrecko
  • loggerGraphicConsoleOutput() : APTextOutput
  • LongAttribute : vrecko
  • LongEnumeration : vrecko
  • LongInterval : vrecko
  • LS_0L : AP_LSystem
  • LS_1LL : AP_LSystem
  • LS_1LR : AP_LSystem
  • LS_2L : AP_LSystem
  • LS_DETERMINISTIC : AP_LSystem
  • LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE : AP_LSystem
  • LS_ERR_PAR_BADTYPE : AP_LSystem
  • LS_ERR_PAR_INVALIDCOUNT : AP_LSystem
  • LS_ERR_STACK_NULL_LSGEODE : AP_LSystem
  • LS_ERR_STACK_UNKNOWN_TURTLE_TYPE : AP_LSystem
  • LS_IL : AP_LSystem
  • LS_NOTIMPLEMENTED : AP_LSystem
  • LS_OK : AP_LSystem
  • LS_PARAMETRIC : AP_LSystem
  • LS_STOCHASTIC : AP_LSystem
  • LS_TURTLE_HERMITPIPE : AP_LSystem
  • LS_TURTLE_JOINTEDPIPE : AP_LSystem
  • LS_TURTLE_OBJMODEL : AP_LSystem
  • LS_TURTLE_QUERY : AP_LSystem
  • LS_TURTLE_RECTANGLE : AP_LSystem
  • LS_TURTLE_STRAIGHTPIPE : AP_LSystem
  • LSystemCapabilities : AP_LSystem
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MATRIX : vreckoDP_base
  • MatrixAttribute : vrecko
  • MAX3DS : APNature
  • maxLODdifference : grass
  • MenuPtr : APDYNAMICART , vreckoUtils
  • MenuRootPtr : APDYNAMICART
  • MenuType : APMenu
  • MessageMatrix() : vrecko
  • MessageNode() : vrecko
  • MessageNodeList() : vrecko
  • MessageQuat() : vrecko
  • MessageString() : vrecko
  • MessageVec2() : vrecko
  • MessageVec3() : vrecko
  • MessageVec4() : vrecko
  • MessageXMLNode() : vrecko
  • METHOD_INPUT() : APDYNAMICART , ht , APDYNAMICART , ht , APDYNAMICART , ht , APDYNAMICART , ht , APDYNAMICART , ht , APDYNAMICART , APGUI , APDYNAMICART , APGUI , APEditorController , APDYNAMICART , APGUI , APDYNAMICART
  • METHOD_REQUEST_INPUT() : APEditorController , APGUI , APEditorController , APInputConnector , APDYNAMICART , APTextOutput , APGUI , APEditorController , base , vrecko , APObjectUtils , APMenu , base , APGUI , APEditorController , APObjectUtils , APInputConnector , APGUI , APDYNAMICART , APEditorController , APObjectUtils , APGUI , vrecko
  • ModelFlags : ArtificialWorld
  • ModelType : ArtificialWorld
  • ModePtr : APDYNAMICART
  • MOVE_DOWN : APShootingSimulation
  • MOVE_LEFT : APShootingSimulation
  • MOVE_RIGHT : APShootingSimulation
  • MOVE_UP : APShootingSimulation
  • MoveDirections : APShootingSimulation
  • MTLockSingleProcess : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • NO_MOVE : APShootingSimulation
  • NO_SUBBLOCKS : ArtificialWorld
  • NodeMask : ArtificialWorld
  • NoLoop : ArtificialWorld
  • None : APNature
  • none : ArtificialWorld
  • NONE : ArtificialWorld , APRoomEdit
  • noneSet : ArtificialWorld
  • NORMAL_EVENT : vrecko
  • NORMALSSWITCHER : APRoomEdit
  • NOT_FOUND : APDYNAMICART
  • NTSTATUS : base
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • OBJ : APNature
  • operator<<() : AP_LSystem
  • orientation() : APConstrainedMovement
  • origin() : vrecko
  • OSG : APNature
  • other : ArtificialWorld
  • OutputPin< MessageBool > : vrecko
  • OutputPin< MessageFloat > : vrecko
  • OutputPin< MessageInt > : vrecko
  • OutputPin< MessageMatrix > : vrecko
  • OutputPin< MessageObjectID > : vrecko
  • OutputPin< MessageQuat > : vrecko
  • OutputPin< MessageString > : vrecko
  • OutputPin< MessageUnsignedInt > : vrecko
  • OutputPin< MessageVec2 > : vrecko
  • OutputPin< MessageVec3 > : vrecko
  • OutputPin< MessageVec4 > : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • Parameter : APDYNAMICART
  • Parameters : APDYNAMICART
  • PatternGeodeList : APDYNAMICART
  • PatternGeodePtr : APDYNAMICART
  • PatternPtr : APDYNAMICART
  • Patterns : APDYNAMICART
  • PCLIENT_ID : base
  • PerlinNoise : APNature
  • planesCompare() : APEditorQAbilities
  • PlaybackType : APDYNAMICART
  • pNtQIT : base
  • POA__BRUSH_STROKE : APDYNAMICART
  • POA__CHAOTIC_ATTRACTOR : APDYNAMICART
  • POA__DUMMY : APDYNAMICART
  • POA__MOTION_TRAIL : APDYNAMICART
  • POA__MT_SAMPLING : APDYNAMICART
  • POA__PERLIN_LINE : APDYNAMICART
  • POA__POLYHEDRA_SCULPTURES : APDYNAMICART
  • POA__STRING_SCULPTURES : APDYNAMICART
  • POA__UPDATE_COLOR_CHANGE : APDYNAMICART
  • POA__UPDATE_DELETE : APDYNAMICART
  • POA__UPDATE_DYNAMIC : APDYNAMICART
  • POA__UPDATE_NONE : APDYNAMICART
  • POA__UPDATE_RENDER : APDYNAMICART
  • PoAType : APDYNAMICART
  • PoAUpdateType : APDYNAMICART
  • POB__ICON : APDYNAMICART
  • PoBType : APDYNAMICART
  • POINTADD : APRoomEdit
  • POINTMOVE : APRoomEdit
  • PointType : WGeometry
  • PolyhedraSculpturePtr : APDYNAMICART
  • PREPARE_NEW_GAME : APShootingSimulation
  • PREPARE_NEXT_LEVEL : APShootingSimulation
  • PRIORITY_EVENT : vrecko
  • PS_ComponentPtr : APDYNAMICART
  • PS_FacePlanePtr : APDYNAMICART
  • PS_FacePtr : APDYNAMICART
  • PS_FlatShapePtr : APDYNAMICART
  • PS_LayerPtr : APDYNAMICART
  • PS_PolyhedronPtr : APDYNAMICART
  • PTHREAD_BASIC_INFORMATION : base
  • PtoActT() : mv
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- q -

  • QuatAttribute : vrecko
  • QUATERNION : vreckoDP_base
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • RadialBoxes : APMenu
  • RadialSections : APMenu
  • ref_ptr_PoA : APDYNAMICART
  • ref_ptr_SimpleBox : APDYNAMICART
  • ref_ptr_ToolBrush : APDYNAMICART
  • Right : APNature
  • rotation_type : vreckoDP_base
  • RUNNING_LEVEL : APShootingSimulation
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • saveFileNameBase : APDYNAMICART
  • SAVER : APRoomEdit
  • ScaleRotateTranslation : ArtificialWorld
  • Scene : vrecko
  • ScenePSThreadProc() : vrecko
  • SeparatorType : WAVEFRONT
  • setDefaultSceneFile() : vrecko
  • setValueFromString() : vrecko
  • Simple : ArtificialWorld
  • Sine : ArtificialWorld
  • SmoothEnding() : VirtualFixture
  • SnapPointArray : APDYNAMICART
  • solve() : ht
  • Spheres : APDYNAMICART
  • ST_DATA : WAVEFRONT
  • ST_EOS : WAVEFRONT
  • ST_HARD : WAVEFRONT
  • ST_SOFT : WAVEFRONT
  • StringAttribute : vrecko
  • StringEnumeration : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • TerrainAlignment : APNature
  • THREAD_BASIC_INFORMATION : base
  • timer : VirtualFixture
  • TOOL__BRUSH : APDYNAMICART
  • TOOL__ERASER : APDYNAMICART
  • TOOL__HOOK : APDYNAMICART
  • TOOL__MAGICWAND : APDYNAMICART
  • TOOL__MAGNET : APDYNAMICART
  • TOOL__NEST : APDYNAMICART
  • TOOL__PERLIN_LINES_CONTROLLER : APDYNAMICART
  • TOOL__ROTATION : APDYNAMICART
  • TOOL__SELECTOR : APDYNAMICART
  • TOOL__SLICE : APDYNAMICART
  • TOOL__TONGS : APDYNAMICART
  • ToolSelectorPtr : APDYNAMICART
  • ToolType : APRoomEdit
  • TraitMap : APDYNAMICART
  • trash : vrecko
  • TurtleType : AP_LSystem
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • UIntArrayPtr : APDYNAMICART
  • UpVec() : AP_LSystem
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • V3DK_1 : vreckoDP_base
  • V3DK_10 : vreckoDP_base
  • V3DK_2 : vreckoDP_base
  • V3DK_3 : vreckoDP_base
  • V3DK_4 : vreckoDP_base
  • V3DK_5 : vreckoDP_base
  • V3DK_6 : vreckoDP_base
  • V3DK_7 : vreckoDP_base
  • V3DK_8 : vreckoDP_base
  • V3DK_9 : vreckoDP_base
  • V3DK_ALT : vreckoDP_base
  • V3DK_BACK : vreckoDP_base
  • V3DK_BOTTOM : vreckoDP_base
  • V3DK_CCW : vreckoDP_base
  • V3DK_CTRL : vreckoDP_base
  • V3DK_CW : vreckoDP_base
  • V3DK_DOMINANT : vreckoDP_base
  • V3DK_ESC : vreckoDP_base
  • V3DK_FIT : vreckoDP_base
  • V3DK_FRONT : vreckoDP_base
  • V3DK_ISO1 : vreckoDP_base
  • V3DK_ISO2 : vreckoDP_base
  • V3DK_LEFT : vreckoDP_base
  • V3DK_MENU : vreckoDP_base
  • V3DK_MINUS : vreckoDP_base
  • V3DK_PANZOOM : vreckoDP_base
  • V3DK_PLUS : vreckoDP_base
  • V3DK_RIGHT : vreckoDP_base
  • V3DK_ROTATE : vreckoDP_base
  • V3DK_SHIFT : vreckoDP_base
  • V3DK_TOP : vreckoDP_base
  • Vec2Attribute : vrecko
  • Vec3ArrayPtr : APDYNAMICART
  • Vec3Attribute : vrecko
  • Vec4ArrayPtr : APDYNAMICART
  • Vec4Attribute : vrecko
  • Vecs3 : APConstrainedMovement
  • vectorAngle() : APConstrainedMovement
  • vertPtrSort() : APSpacePartitioning
  • Vibrate() : VirtualFixture
  • virtualKey : vreckoDP_base
  • virtualKeyCode : vreckoDP_base
  • VRECKOMutex : vrecko
  • vtimer : VirtualFixture
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • Wait() : vrecko
  • Wait1() : vrecko
  • Wait2() : vrecko
  • Wait3() : vrecko
  • WAITING_FOR_START : APShootingSimulation
  • WALLADD : APRoomEdit
  • WALLMOVEMENT : APRoomEdit
  • WALLREMOVE : APRoomEdit
  • watchedObjectIDs : APConstrainedMovement
  • WG_Q_POINT : WGeometry
  • WG_R_POINT : WGeometry
  • White() : AP_LSystem
  • world : vrecko
  • World : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • f
  • g
  • h
  • i
  • l
  • m
  • o
  • p
  • s
  • u
  • v
  • w

- a -

  • ActTtoP() : mv
  • area() : APConstrainedMovement

- b -

  • base1() : vrecko
  • base2() : vrecko
  • base3() : vrecko
  • baseR1() : vrecko
  • baseR2() : vrecko
  • baseR3() : vrecko

- c -

  • calcAngleSum() : APConstrainedMovement
  • Center() : AP_LSystem
  • centroid() : APConstrainedMovement
  • combNum() : APFFDEditor
  • compareX() : APSpacePartitioning
  • compareY() : APSpacePartitioning
  • compareZ() : APSpacePartitioning
  • ControlActualPosition() : VirtualFixture
  • ControlActualPositionReturnCleanPosition() : VirtualFixture
  • convexPolygon() : APConstrainedMovement
  • createParticleSystem() : APDYNAMICART

- d -

  • der_approx() : ht
  • doneXML() : vrecko

- f -

  • F1() : APCameraPath
  • F2() : APCameraPath
  • F3() : APCameraPath
  • F4() : APCameraPath
  • factorial() : APFFDEditor
  • FileExists() : vrecko
  • ForceTransformFunction() : VirtualFixture

- g -

  • get_func_value() : ht
  • getBrakeDist() : CarSim
  • getNumSceneFiles() : vrecko
  • getParentsTransform() : APFFDEditor
  • getParentsTransformMat() : APFFDEditor
  • getSafeDefaultSceneFile() : vrecko
  • getSafeSceneFile() : vrecko
  • GetThreadInfo() : base

- h -

  • HeadVec() : AP_LSystem
  • HierarchyThreadProc() : APSpacePartitioning
  • HSVtoRGB() : APObjectUtils

- i -

  • initXML() : vrecko
  • isEqualTo() : vrecko

- l -

  • LeftVec() : AP_LSystem
  • loggerGraphicConsoleOutput() : APTextOutput

- m -

  • MessageMatrix() : vrecko
  • MessageNode() : vrecko
  • MessageNodeList() : vrecko
  • MessageQuat() : vrecko
  • MessageString() : vrecko
  • MessageVec2() : vrecko
  • MessageVec3() : vrecko
  • MessageVec4() : vrecko
  • MessageXMLNode() : vrecko
  • METHOD_INPUT() : APDYNAMICART , ht , APDYNAMICART , ht , APDYNAMICART , APGUI , APEditorController , APDYNAMICART , ht , APDYNAMICART
  • METHOD_REQUEST_INPUT() : APEditorController , APObjectUtils , APGUI , APInputConnector , APObjectUtils , APInputConnector , APDYNAMICART , vrecko , APEditorController , APGUI , APObjectUtils , APEditorController , APMenu , APTextOutput , vrecko , APEditorController , APGUI , APEditorController , base , APDYNAMICART , APEditorController , base

- o -

  • operator<<() : AP_LSystem
  • orientation() : APConstrainedMovement
  • origin() : vrecko

- p -

  • planesCompare() : APEditorQAbilities
  • PtoActT() : mv

- s -

  • ScenePSThreadProc() : vrecko
  • setDefaultSceneFile() : vrecko
  • setValueFromString() : vrecko
  • SmoothEnding() : VirtualFixture
  • solve() : ht

- u -

  • UpVec() : AP_LSystem

- v -

  • vectorAngle() : APConstrainedMovement
  • vertPtrSort() : APSpacePartitioning
  • Vibrate() : VirtualFixture

- w -

  • Wait() : vrecko
  • Wait1() : vrecko
  • Wait2() : vrecko
  • Wait3() : vrecko
  • White() : AP_LSystem
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • i
  • l
  • m
  • n
  • o
  • s
  • t
  • v
  • w

- _ -

  • __pad0__ : APDYNAMICART

- a -

  • AutoPtrV : vrecko

- b -

  • BaseClass : vrecko

- c -

  • colorGenAdapter : APDYNAMICART
  • crossSectionAdapter : APDYNAMICART
  • cycles_per_sec : boids

- d -

  • DeviceManager : vrecko
  • diamGenAdapt : APDYNAMICART
  • DOMNode : vrecko

- e -

  • EnvironmentObject : vrecko
  • EventDispatcher : vrecko

- i -

  • InputPin< MessageBool > : vrecko
  • InputPin< MessageFloat > : vrecko
  • InputPin< MessageInt > : vrecko
  • InputPin< MessageMatrix > : vrecko
  • InputPin< MessageObjectID > : vrecko
  • InputPin< MessageQuat > : vrecko
  • InputPin< MessageString > : vrecko
  • InputPin< MessageUnsignedInt > : vrecko
  • InputPin< MessageVec2 > : vrecko
  • InputPin< MessageVec3 > : vrecko
  • InputPin< MessageVec4 > : vrecko

- l -

  • logger : vrecko

- m -

  • maxLODdifference : grass

- n -

  • NOT_FOUND : APDYNAMICART

- o -

  • OutputPin< MessageBool > : vrecko
  • OutputPin< MessageFloat > : vrecko
  • OutputPin< MessageInt > : vrecko
  • OutputPin< MessageMatrix > : vrecko
  • OutputPin< MessageObjectID > : vrecko
  • OutputPin< MessageQuat > : vrecko
  • OutputPin< MessageString > : vrecko
  • OutputPin< MessageUnsignedInt > : vrecko
  • OutputPin< MessageVec2 > : vrecko
  • OutputPin< MessageVec3 > : vrecko
  • OutputPin< MessageVec4 > : vrecko

- s -

  • saveFileNameBase : APDYNAMICART
  • Scene : vrecko

- t -

  • timer : VirtualFixture
  • trash : vrecko

- v -

  • virtualKey : vreckoDP_base
  • vtimer : VirtualFixture

- w -

  • watchedObjectIDs : APConstrainedMovement
  • World : vrecko
  • world : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • v

- _ -

  • _uint : APCameraPath

- a -

  • AttractorNames : APDYNAMICART
  • AttractorPtr : APDYNAMICART

- b -

  • BoolAttribute : vrecko
  • BrushPtr : APDYNAMICART

- c -

  • CAINFO : vrecko
  • CLIENT_ID : base
  • COLLISION_POINTS_VECTOR : vrecko
  • CollisionParams : vrecko
  • COLLISIONS_INFO_VECTOR : vrecko
  • ColorList : APDYNAMICART
  • ComputeThreadPtr : APDYNAMICART
  • ConstraintAreas : APConstrainedMovement

- d -

  • DATools : APDYNAMICART
  • DiameterGenAdapter : APDYNAMICART
  • DoubleAttribute : vrecko
  • DoubleEnumeration : vrecko
  • DoubleInterval : vrecko

- e -

  • EnvironmentObjectIDs : APConstrainedMovement

- f -

  • FloatAttribute : vrecko
  • FloatEnumeration : vrecko
  • FloatInterval : vrecko

- g -

  • GeodePtr : APDYNAMICART
  • GeometryPtr : APDYNAMICART
  • GuiItemMapType : APGUI

- h -

  • Hook : APDYNAMICART
  • HoopGeometryPtr : APDYNAMICART
  • HoopPtr : APDYNAMICART
  • HoopShapePtr : APDYNAMICART

- i -

  • IComputeStrategyPtr : APDYNAMICART
  • IMenuComponentIter : vreckoUtils
  • IMenuComponentPtr : APDYNAMICART
  • IntAttribute : vrecko
  • IntEnumeration : vrecko
  • IntInterval : vrecko
  • IParametersPtr : APDYNAMICART
  • IShapeGeneratorPtr : APDYNAMICART

- k -

  • KPRIORITY : base

- l -

  • LayoutMapType : APGUI
  • ListOfFunctions : ht
  • ListOfVariables : ht
  • LongAttribute : vrecko
  • LongEnumeration : vrecko
  • LongInterval : vrecko

- m -

  • MatrixAttribute : vrecko
  • MenuPtr : APDYNAMICART , vreckoUtils
  • MenuRootPtr : APDYNAMICART
  • ModePtr : APDYNAMICART
  • MTLockSingleProcess : vrecko

- n -

  • NTSTATUS : base

- p -

  • Parameter : APDYNAMICART
  • Parameters : APDYNAMICART
  • PatternGeodeList : APDYNAMICART
  • PatternGeodePtr : APDYNAMICART
  • PatternPtr : APDYNAMICART
  • Patterns : APDYNAMICART
  • PCLIENT_ID : base
  • pNtQIT : base
  • PolyhedraSculpturePtr : APDYNAMICART
  • PS_ComponentPtr : APDYNAMICART
  • PS_FacePlanePtr : APDYNAMICART
  • PS_FacePtr : APDYNAMICART
  • PS_FlatShapePtr : APDYNAMICART
  • PS_LayerPtr : APDYNAMICART
  • PS_PolyhedronPtr : APDYNAMICART
  • PTHREAD_BASIC_INFORMATION : base

- q -

  • QuatAttribute : vrecko

- r -

  • ref_ptr_PoA : APDYNAMICART
  • ref_ptr_SimpleBox : APDYNAMICART
  • ref_ptr_ToolBrush : APDYNAMICART

- s -

  • SnapPointArray : APDYNAMICART
  • Spheres : APDYNAMICART
  • StringAttribute : vrecko
  • StringEnumeration : vrecko

- t -

  • THREAD_BASIC_INFORMATION : base
  • ToolSelectorPtr : APDYNAMICART
  • TraitMap : APDYNAMICART

- u -

  • UIntArrayPtr : APDYNAMICART

- v -

  • Vec2Attribute : vrecko
  • Vec3ArrayPtr : APDYNAMICART
  • Vec3Attribute : vrecko
  • Vec4ArrayPtr : APDYNAMICART
  • Vec4Attribute : vrecko
  • Vecs3 : APConstrainedMovement
  • VRECKOMutex : vrecko
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • v

- a -

  • AlgorithmType : APNature
  • AnimationInterpolationType : ArtificialWorld
  • AnimationLoopType : ArtificialWorld
  • AnimationType : ArtificialWorld
  • AttractorRenderingType : APDYNAMICART

- b -

  • BlockAttributesSetEnum : ArtificialWorld

- d -

  • DataSourceType : APNature
  • DAToolType : APDYNAMICART

- e -

  • EventType : vrecko

- f -

  • FileTypeExport : APNature

- g -

  • GameStates : APShootingSimulation
  • GUI_ACTION : APGUI
  • GUI_ITEM_STATE : APGUI

- h -

  • HoleType : WGeometry
  • htd_receiver_pos : vreckoDP_base

- i -

  • IconType : APGUI
  • InterpolationType : APNature
  • InterpretErrorCodes : AP_LSystem

- l -

  • LSystemCapabilities : AP_LSystem

- m -

  • MenuType : APMenu
  • ModelFlags : ArtificialWorld
  • ModelType : ArtificialWorld
  • MoveDirections : APShootingSimulation

- p -

  • PlaybackType : APDYNAMICART
  • PoAType : APDYNAMICART
  • PoAUpdateType : APDYNAMICART
  • PoBType : APDYNAMICART
  • PointType : WGeometry

- r -

  • rotation_type : vreckoDP_base

- s -

  • SeparatorType : WAVEFRONT

- t -

  • TerrainAlignment : APNature
  • ToolType : APRoomEdit
  • TurtleType : AP_LSystem

- v -

  • virtualKeyCode : vreckoDP_base
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • v
  • w

- a -

  • AC : APNature
  • Algorithm : APNature
  • Alpha : ArtificialWorld
  • ANGLES : vreckoDP_base
  • ATT__RENDER_LINES : APDYNAMICART
  • ATT__RENDER_POINTS : APDYNAMICART
  • ATT__RENDER_TRIANGLES : APDYNAMICART

- b -

  • BiDirectional : ArtificialWorld
  • bothSet : ArtificialWorld
  • Boxes : APMenu

- c -

  • cal3D : ArtificialWorld
  • centerDirSet : ArtificialWorld
  • centerPointSet : ArtificialWorld
  • Centre : APNature
  • COLORBUCKET : APRoomEdit
  • Cosine : APNature
  • COUNTDOWN : APShootingSimulation
  • CREATEHOLE : APRoomEdit

- d -

  • Displacement : APNature

- e -

  • EXPRESS_EVENT : vrecko

- f -

  • Faults : APNature
  • FBX : APNature
  • FHP__LAG_SKIP : APDYNAMICART
  • FHP__REAL_TIME : APDYNAMICART
  • FLT : APNature

- g -

  • geometry : ArtificialWorld
  • Grid : APMenu
  • GUI_ACTION_CONTEXT : APGUI
  • GUI_ACTION_MAIN : APGUI
  • GUI_ITEM_STATE_ACTIVE : APGUI
  • GUI_ITEM_STATE_DEFAULT : APGUI
  • GUI_ITEM_STATE_DISABLED : APGUI

- h -

  • HOLEREMOVE : APRoomEdit
  • ht_door : WGeometry
  • ht_window : WGeometry
  • HTD_REC_POS_ACT : vreckoDP_base
  • HTD_REC_POS_FRI : vreckoDP_base
  • HTD_REC_POS_OUT : vreckoDP_base

- i -

  • ICON__BUTTON : APGUI
  • ICON__MULTISWITCH : APGUI
  • ICON__SWITCH : APGUI
  • Image : APNature
  • IVE : APNature

- l -

  • Left : APNature
  • Linear : ArtificialWorld , APNature
  • LOADER : APRoomEdit
  • LS_0L : AP_LSystem
  • LS_1LL : AP_LSystem
  • LS_1LR : AP_LSystem
  • LS_2L : AP_LSystem
  • LS_DETERMINISTIC : AP_LSystem
  • LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE : AP_LSystem
  • LS_ERR_PAR_BADTYPE : AP_LSystem
  • LS_ERR_PAR_INVALIDCOUNT : AP_LSystem
  • LS_ERR_STACK_NULL_LSGEODE : AP_LSystem
  • LS_ERR_STACK_UNKNOWN_TURTLE_TYPE : AP_LSystem
  • LS_IL : AP_LSystem
  • LS_NOTIMPLEMENTED : AP_LSystem
  • LS_OK : AP_LSystem
  • LS_PARAMETRIC : AP_LSystem
  • LS_STOCHASTIC : AP_LSystem
  • LS_TURTLE_HERMITPIPE : AP_LSystem
  • LS_TURTLE_JOINTEDPIPE : AP_LSystem
  • LS_TURTLE_OBJMODEL : AP_LSystem
  • LS_TURTLE_QUERY : AP_LSystem
  • LS_TURTLE_RECTANGLE : AP_LSystem
  • LS_TURTLE_STRAIGHTPIPE : AP_LSystem

- m -

  • MATRIX : vreckoDP_base
  • MAX3DS : APNature
  • MOVE_DOWN : APShootingSimulation
  • MOVE_LEFT : APShootingSimulation
  • MOVE_RIGHT : APShootingSimulation
  • MOVE_UP : APShootingSimulation

- n -

  • NO_MOVE : APShootingSimulation
  • NO_SUBBLOCKS : ArtificialWorld
  • NodeMask : ArtificialWorld
  • NoLoop : ArtificialWorld
  • None : APNature
  • NONE : APRoomEdit
  • none : ArtificialWorld
  • NONE : ArtificialWorld
  • noneSet : ArtificialWorld
  • NORMAL_EVENT : vrecko
  • NORMALSSWITCHER : APRoomEdit

- o -

  • OBJ : APNature
  • OSG : APNature
  • other : ArtificialWorld

- p -

  • PerlinNoise : APNature
  • POA__BRUSH_STROKE : APDYNAMICART
  • POA__CHAOTIC_ATTRACTOR : APDYNAMICART
  • POA__DUMMY : APDYNAMICART
  • POA__MOTION_TRAIL : APDYNAMICART
  • POA__MT_SAMPLING : APDYNAMICART
  • POA__PERLIN_LINE : APDYNAMICART
  • POA__POLYHEDRA_SCULPTURES : APDYNAMICART
  • POA__STRING_SCULPTURES : APDYNAMICART
  • POA__UPDATE_COLOR_CHANGE : APDYNAMICART
  • POA__UPDATE_DELETE : APDYNAMICART
  • POA__UPDATE_DYNAMIC : APDYNAMICART
  • POA__UPDATE_NONE : APDYNAMICART
  • POA__UPDATE_RENDER : APDYNAMICART
  • POB__ICON : APDYNAMICART
  • POINTADD : APRoomEdit
  • POINTMOVE : APRoomEdit
  • PREPARE_NEW_GAME : APShootingSimulation
  • PREPARE_NEXT_LEVEL : APShootingSimulation
  • PRIORITY_EVENT : vrecko

- q -

  • QUATERNION : vreckoDP_base

- r -

  • RadialBoxes : APMenu
  • RadialSections : APMenu
  • Right : APNature
  • RUNNING_LEVEL : APShootingSimulation

- s -

  • SAVER : APRoomEdit
  • ScaleRotateTranslation : ArtificialWorld
  • Simple : ArtificialWorld
  • Sine : ArtificialWorld
  • ST_DATA : WAVEFRONT
  • ST_EOS : WAVEFRONT
  • ST_HARD : WAVEFRONT
  • ST_SOFT : WAVEFRONT

- t -

  • TOOL__BRUSH : APDYNAMICART
  • TOOL__ERASER : APDYNAMICART
  • TOOL__HOOK : APDYNAMICART
  • TOOL__MAGICWAND : APDYNAMICART
  • TOOL__MAGNET : APDYNAMICART
  • TOOL__NEST : APDYNAMICART
  • TOOL__PERLIN_LINES_CONTROLLER : APDYNAMICART
  • TOOL__ROTATION : APDYNAMICART
  • TOOL__SELECTOR : APDYNAMICART
  • TOOL__SLICE : APDYNAMICART
  • TOOL__TONGS : APDYNAMICART

- v -

  • V3DK_1 : vreckoDP_base
  • V3DK_10 : vreckoDP_base
  • V3DK_2 : vreckoDP_base
  • V3DK_3 : vreckoDP_base
  • V3DK_4 : vreckoDP_base
  • V3DK_5 : vreckoDP_base
  • V3DK_6 : vreckoDP_base
  • V3DK_7 : vreckoDP_base
  • V3DK_8 : vreckoDP_base
  • V3DK_9 : vreckoDP_base
  • V3DK_ALT : vreckoDP_base
  • V3DK_BACK : vreckoDP_base
  • V3DK_BOTTOM : vreckoDP_base
  • V3DK_CCW : vreckoDP_base
  • V3DK_CTRL : vreckoDP_base
  • V3DK_CW : vreckoDP_base
  • V3DK_DOMINANT : vreckoDP_base
  • V3DK_ESC : vreckoDP_base
  • V3DK_FIT : vreckoDP_base
  • V3DK_FRONT : vreckoDP_base
  • V3DK_ISO1 : vreckoDP_base
  • V3DK_ISO2 : vreckoDP_base
  • V3DK_LEFT : vreckoDP_base
  • V3DK_MENU : vreckoDP_base
  • V3DK_MINUS : vreckoDP_base
  • V3DK_PANZOOM : vreckoDP_base
  • V3DK_PLUS : vreckoDP_base
  • V3DK_RIGHT : vreckoDP_base
  • V3DK_ROTATE : vreckoDP_base
  • V3DK_SHIFT : vreckoDP_base
  • V3DK_TOP : vreckoDP_base

- w -

  • WAITING_FOR_START : APShootingSimulation
  • WALLADD : APRoomEdit
  • WALLMOVEMENT : APRoomEdit
  • WALLREMOVE : APRoomEdit
  • WG_Q_POINT : WGeometry
  • WG_R_POINT : WGeometry
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
o N AP_CableEditor |
| o C Cable |
| \ C CableEditor |
o N AP_LSystem |
| o C Abstract0LSystem |
| o C AbstractFile |
| o C AbstractGenerator |
| o C AbstractInterpret |
| o C AbstractkLSystem |
| o C AbstractLSystem |
| o C AbstractTurtle |
| o C Configuration |
| o C D0LSystem |
| o C HermitPipe |
| o C JointedPipe |
| o C LoftTurtle |
| o C Log |
| o C LongString |
| o C LSFile |
| o C TurtleProperties |
| o C LSGeode |
| o C LSObject |
| o C LSystem |
| o C LSystemException |
| o C ParsingException |
| o C FileException |
| o C ConfigurationException |
| o C LSystemGenerator |
| o C MovingTurtle |
| o C Par2LSystem |
| o C ParD0LSystem |
| o C ParseableString |
| o C ParStoch0LSystem |
| o C Query |
| o C QueryInterpret |
| o C QueryTurtle |
| o C RandomIndex |
| o C Randomizer |
| o C Rectangle |
| o C Rule |
| o C StaticString |
| o C StraightPipe |
| o C TurtleInterpret |
| o C TurtleStack |
| o C StringUtils |
| o C Parameter |
| \ C XmlFile |
o N APCameraMovement |
| o C CameraMovementEditor |
| o C ControlPoint |
| o C CameraPath |
| \ C MyReadCallback |
o N APCameraPath |
| o C ControlPoint |
| \ C Camera |
o N APClouds |
| \ C Clouds | Clouds ability - revised Atmospheric ability
o N APConnectEditor |
| o C ConnectEditor |
| o C Cut |
| o C Optimalizer |
| o C PolygonState |
| o C Rotation |
| o C Scale |
| o C MyReadCallback |
| \ C EOLineSegmentIntersector |
o N APConstrainedMovement |
| o C ConstrainedObjectMovement |
| o C ConstraintArea |
| \ C ConstraintDescription |
o N APDYNAMICART |
| o C Attractor |
| o C Brush | Encapsulate data and functionality of sweepSurface related factories and adapters
| o C BrushStroke | Store data about and can render one brush stroke
| o C ColorGenAdapter |
| o C ConstantColorAdapter |
| o C GradientColorAdapter |
| o C ColorGenFactory |
| o C IComputeStrategy |
| o C NullStrategy |
| o C LorenzStrategy |
| o C Lorenz84Strategy |
| o C PickoverStrategy |
| o C RosslerStrategy |
| o C PolynomialStrategy |
| o C IkedaStrategy |
| o C InitSettings |
| o C ComputeThread |
| o C Configuration |
| o C Controller |
| o C Ctrl_Attractor |
| o C Ctrl_FreeHandPainting | Controller of Brush Stroke PoA
| o C Ctrl_MotionVisualization | Controller of Motion Trail PoAs
| o C Ctrl_PerlinLines |
| o C Ctrl_PolyhedraSculptures |
| o C Ctrl_StringSculptures |
| o C DAEnvironment | Dynamic Art Environment class - base class of Dynamic Art plugin
| o C DATool | Virtual class defining basis of all tools used in Dynamic Art
| o C ConstantDiamAdapter |
| o C GradientDiamAdapter |
| o C DiameterGenFactory |
| o C HookObject |
| o C HoopTrackerCallback |
| o C HookManager | Hook Manager
| o C Hoop |
| o C HoopShape |
| o C NullHoopShape |
| o C Rectangle |
| o C Ellipse |
| o C RegularPolygon |
| o C Line |
| o C ElongatedCircle |
| o C Painted |
| o C ShapeFactory |
| o C JuliaAttractor |
| o C Mode |
| o C Basic |
| o C Advanced |
| o C MotionTrail |
| o C NullAttractor |
| o C OrdinaryAttractor |
| o C Parameter |
| o C IParameters |
| o C NullParameters |
| o C LorenzParameters |
| o C Lorenz84Parameters |
| o C JuliaParameters |
| o C PickoverParameters |
| o C RosslerParameters |
| o C PolynomialParameters |
| o C IkedaParameters |
| o C ParticleSystemParameters |
| o C Pattern |
| o C PatternBase |
| o C PatternFactory |
| o C NullPattern |
| o C AcrossPattern |
| o C CrissCrossPattern |
| o C DoublePattern |
| o C HyperbolicPattern |
| o C TopPattern |
| o C TopReversePattern |
| o C StandardPattern |
| o C SplitPattern |
| o C SplitReversePattern |
| o C PatternsGeode |
| o C PerlinLines |
| o C PLNestTool |
| o C PLMagnetTool |
| o C PLControllerTool |
| o C SimulationParameters |
| o C PhysXManager |
| o C PoA | PoA (Piece of Art)
| o C PolyhedraSculpture |
| o C PS_Component |
| o C PS_Layer |
| o C PS_Face |
| o C PS_FacePlane |
| o C PS_FlatShape |
| o C PS_Polyhedron |
| o C PolyhedronFactory |
| o C symmetry_axis |
| o C symmetry_pair |
| o C PS_Symmetry |
| o C RotationFrameAdapter |
| o C RMFrameAdapter |
| o C AxisFrameAdapter |
| o C HandFrameAdapter |
| o C RotationFrameFactory |
| o C SectorInfo |
| o C SectorManager | Sector Manager
| o C SimpleBox | Simple class for creating boxes
| o C SplineAdapter |
| o C RoundedSplineAdapter |
| o C RectangularSplineAdapter |
| o C WaveSplineAdapter |
| o C SplineFactory |
| o C ToolBrush | Brush tool
| o C ToolEraser |
| o C ToolHook |
| o C ToolMagicWand |
| o C ToolRotation | Rotation tool
| o C ToolSelector |
| o C ToolSlice |
| o C ToolTongs |
| o C Stroke |
| o C PoAAdapter |
| o C AdapterFactory |
| o C Utils |
| o C Limits |
| o C colorGradient |
| o C PoAState |
| o C DAGizmo | Gizmo - graphical representation of something, e.g. Frenet frame
| o C BrushStrokeControlPoint | Control point of Sweep Surface
| o C Trait |
| o C HoopGeometry |
| o C PoB | PoB (Piece of Behavior)
| o C IShapeGenerator |
| o C NullShapeGenerator |
| o C LinearShapeGenerator |
| \ C SnapPoint |
o N APEditorController |
| o C AbilityMapper |
| | o C BUTTON_MAPPING |
| | o C MAPPING |
| | \ C MessageMapping |
| \ C EditorController |
| o C ECPOINTERBUTTONINFO |
| \ C ECPOINTERINFO |
o N APEditorQAbilities |
| o C AbilityEditor |
| | \ C AllowedAbility |
| o C AnimatorEditor |
| o C AvatarMovement |
| o C ObjectAdd |
| o C ObjectDelete |
| o C ObjectMovement |
| | o C CANDIDATEPLANE |
| | \ C SnapBox |
| o C SceneSave |
| o C SimpleObjectMovement |
| o C UseTrigger |
| \ C PresentAbility |
o N APFFDEditor |
| o C EditorLogic |
| o C GeometryLoader |
| | \ C Geometry |
| o C GeometryLoaderBase |
| | o C FaceBase |
| | \ C VertexBase |
| \ C Grid |
| o C ControlPoint |
| \ C Edge |
o N APGUI |
| o C ColorPicker | Spatial HSL Color Picker
| o C GUI_Controller | GUI Controller class
| o C Interconnection | Used to simplify deletion of created interconnections (especially in menu)
| o C GUI_Item | VRECKO GUI Item class
| o C GUI_Text | Text
| o C Icon | Icon
| o C IconColour | Color Icon
| o C ItemsGroup | Group of GUI Items
| o C Layout | GUI Layout class
| o C Menu | Menu
| \ C Slider | Slider GUI item
o N APHelloWorld |
| \ C MyAbility |
o N APHUD |
| o C HUDColorProfile |
| o C HUDField |
| o C HUDWindow |
| \ C HUDDisplay |
o N APInputConnector |
| \ C InputConnector | Input Connector class
o N APLightsEditor |
| o C _Light |
| o C Editor |
| \ C Lights |
o N APMenu |
| o C MenuItem |
| o C MenuItemNull |
| o C MenuItemText |
| o C MenuItemSlider |
| o C DynamicMenuSign |
| o C DynamicMenu |
| \ C MenuLoaderErrorHandler |
o N APNature |
| o C MidpointDisplacementAlgorithm |
| o C PerlinNoiseAlgorithm |
| o C RandomFaultsAlgorithm |
| o C TerrainAlgorithm |
| o C Terrain2D | 2D terrain based on height map which consists of multiple equally large segments
| o C Terrain2DSegment | Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point
| o C TerrainAbility |
| o C TerrainRandom |
| \ C TerrainUtility |
o N APObjectUtils |
| o C Animator |
| | \ C AnimationPoint |
| o C ConnectionViz |
| | \ C Connection |
| o C CopyProperties |
| o C KeepOnScreen |
| o C ObjectEffect |
| o C ObjectEffectMan |
| o C ObjectInfo |
| o C ObjectModif |
| o C ObjectSelector |
| o C UseToEvent |
| o C MyReadCallback |
| \ C EOLineSegmentIntersector |
o N APRoomEdit |
| o C ColorBucket |
| o C CreateHole |
| o C HoleRemove |
| o C PointAdd |
| o C PointMove |
| o C RoomEditor |
| o C RoomLoader |
| o C RoomSaver |
| o C Tool |
| o C WallAdd |
| o C WallGeometry |
| o C WallMovement |
| \ C WallRemove |
o N APShootingSimulation |
| \ C ShootingSimulation |
o N APSpacePartitioning |
| o C GeometryLoaderBase |
| | o C FaceBase |
| | \ C VertexBase |
| o C NoPartitioning_Scene |
| | o C CollisionStruct |
| | \ C CollisionStructObject |
| o C PointShellGeneric_Object_Data |
| o C PointShell_SimpleNode |
| o C PointShell_Object_Data |
| | \ C PSpoint |
| o C PointShell_Object_Data_Geometry |
| | o C E |
| | o C P |
| | \ C V |
| o C PointShell_Object_Data_Geometry_Analyser |
| | o C EExt |
| | o C PExt |
| | \ C VExt |
| o C mycomparisonMinMax |
| o C mycomparisonMaxMin |
| o C VLOD |
| o C ELOD |
| o C PLOD |
| o C int_3 |
| o C PointShell_Object_Data_LOD_Builder |
| o C PointShellVSVoxel_Object |
| o C SNCH_Object |
| | o C InternalPointStruct |
| | o C LMDStore |
| | o C LocalMinimumDistance |
| | \ C OneTri |
| o C SNCH_Object_Data |
| | o C DebugLevelStats |
| | o C DebugStats |
| | o C FaceSNCH |
| | o C STNodeSNCH |
| | \ C VertexSNCH |
| o C SP_Object_Data_Base |
| o C SphereBVH_Object |
| o C SphereBVH_Object_Data |
| | \ C STNodeSphere |
| o C SphereBVH_Scene |
| o C VoxelGrid_Object_Data |
| \ C VGReadCallback |
o N APTextOutput |
| \ C Console |
| \ C Line |
o N APWeather |
| \ C Weather |
o N ArtificialWorld |
| o C BlockAttributes | Atributy bloku
| o C BlockUpdater | Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky
| o C Model | Uchovava informace o modelu
| o C AnimatedModel | Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit
| o C SubBlock | Trida reprezentujici jeden blok ve scene
| o C AnimationPoint | Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode
| o C SubBlockAnimation | Trida reprezentujici animaci bloku
| \ C WorldBuilder | Trida, ktera vytvori hierarchicky svet ve scene
o N base |
| o C Avatar |
| o C Display |
| o C hand |
| o C Light |
| o C MouseHand |
| o C MTMatrixTransform |
| o C Rotate |
| o C ShowFDH |
| o C ShowFDHModel |
| o C SystemInfo |
| | o C MessageSIThreadCreated |
| | o C SIThreadInfo |
| | \ C SIThreadInit |
| o C _CLIENT_ID |
| \ C _THREAD_BASIC_INFORMATION |
o N behindO |
| o C AvatarManipulator |
| o C CentreObjectManipulator |
| o C ChangeOfVisibility |
| o C ContactObjectManipulator |
| o C CuttingPlane |
| o C EyeManipulator |
| o C HeadManipulator |
| o C HMDHeadManipulator |
| o C Lens |
| o C Manipulator |
| o C MappingFunctions |
| o C MyUpdateCallback |
| o C MyCullCallback |
| o C Mirror |
| \ C WIM |
| \ C ObjectCopy |
o N boids |
| o C Boid |
| o C BoidsLogic |
| \ C BoidsPlanner |
o N CarSim |
| o C CarControlUnit |
| o C CarEnvirons |
| o C Lights |
| o C GeometryPartsPath |
| o C CarExecutionUnit |
| o C CarPartsNodeCache |
| o C CarSize |
| o C CarState |
| o C StartStopDestination |
| o C Parameters |
| o C First3Juncs |
| o C CarEdgeData |
| o C MessageRoadAndDir |
| o C MessageCarEdge |
| o C MessageCarEdgeData |
| o C MessageEdgeOffset |
| o C MessageVectorUnsignedInt |
| o C MessageStartStopDestination |
| o C MessageFirst3Juncs |
| o C MessageCarSimParameters |
| o C MessageCarEnvirons |
| o C MessageCarStatePtr |
| o C EdgesCar |
| o C Edge |
| o C InOutEdgesAttr |
| o C JuncsEdge |
| o C Junction |
| o C PolygonPoint |
| o C Remover |
| o C RoadsEdges |
| o C RoadsState |
| o C TLcolorsMT |
| \ C TLsOnJuncManager |
o N esg |
o N Filter |
| o C Linear |
| \ C PosNoiseRemover |
| \ C SAMPLE |
o N grass |
| o C Grass |
| o C GrassCullCallback |
| o C GrassDrawable |
| o C Vertex |
| o C Triangle |
| o C Mesh |
| o C GrassAbilityParameters |
| \ C TriangleCollector |
o N ht |
| o C HeadTracking |
| o C Screen | Defines position of screen in real world
| o C ScreenSetup |
| | \ C ScreenSetupState |
| o C ScreenSetupSimple |
| | \ C ScreenSetupSimpleState |
| o C Variable |
| o C VariableVec3 |
| o C VariableVec2 |
| o C VariableFloat |
| o C VariableQuat |
| o C Function |
| o C SetupFunction |
| \ C SimpleSetupFunction |
o N mv |
| o C CCollection |
| o C CGesture |
| o C CPoint |
| o C CMVect |
| o C CPlayer |
| \ C Reader |
o N navigation |
| o C AvatarInHand |
| \ C KMTracker |
o N ode |
| o C CappedCylinder |
| o C CompositeObject |
| | \ C Data |
| o C Cube |
| o C ODEObject |
| o C DynamicScene |
| | \ C MessageODERequest |
| \ C Sphere |
o N osg |
o N osgQ |
| o C QShapeVisitor |
| o C QConstShapeVisitor |
| o C QSection |
| o C QShapeDrawable |
| o C QDrawShapeVisitor |
| o C QComputeBoundShapeVisitor |
| \ C QPrimitiveShapeVisitor |
o N PhysXPlugin |
| o C BaseActor |
| o C BaseJoint |
| o C BasePhysXObject |
| o C Box |
| o C Capsule |
| o C Cloth |
| o C ClothDrawable |
| o C CoreActorDesc |
| o C CylindricalJoint |
| o C DistanceJoint |
| o C ErrorReporter |
| o C FixedJoint |
| o C Fluid |
| o C FluidDrawable |
| o C ForceField |
| o C MaterialManager |
| o C Particle |
| o C PhysXObject |
| o C PhysXScene |
| o C MessageNxActorWithName |
| o C Plane |
| o C PointInPlaneJoint |
| o C PointOnLineJoint |
| o C PrismaticJoint |
| o C PulleyJoint |
| o C RemoteDebugger |
| o C RevoluteJoint |
| o C Sphere |
| o C SphericalJoint |
| \ C UpdatablePhysXObject |
o N VirtualFixture |
| o C Avatar |
| o C AxisLock |
| o C Border |
| o C Box |
| o C Cone |
| o C Cylinder |
| o C Damper |
| o C Drag |
| o C Filter |
| o C Grid |
| o C Log |
| o C Marker |
| o C MarkerFactory |
| o C NavSphere |
| o C Plane |
| o C ProxiBorder |
| o C ProxiBox |
| o C ProxiCone |
| o C ProxiCylinder |
| o C ProxiSphere |
| o C Sphere |
| o C Trace |
| o C Vibration |
| o C VibrationLabel |
| \ C VibrationLabelActivator |
o N VK_NoStepInto_Namespace |
| \ C DynamicArray |
o N vrecko | Second level of space paritioning queries - detailed searching inside object
| o C BufferedFile |
| o C BufferedFileWrite |
| o C Ability |
| | \ C ParameterStruct |
| o C AbilityDispatcher | Used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities
| o C Attribute |
| o C AttributesDescription |
| o C IOPinBase | Base class that defines the very basic method that every IO pin will have
| o C InputPinBase |
| o C OutputPinBase |
| o C IORequestPinBase |
| o C RequestInputPinBase |
| o C RequestOutputPinBase |
| o C BaseClass |
| | \ C NOTIFICATION_DESCRIPTION |
| o C BenchmarkWriter | Class to write any timings and other benchmark data into file
| o C Device |
| o C DeviceManager |
| | \ C DT |
| o C DynamicAttribute |
| o C Enumeration |
| o C EnvironmentObject |
| | \ C UserData | Here are stored pointer to UserData and its type
| o C EventDispatcher |
| | o C EventDefinitionStruct | Struct that defines an event
| | o C EventStruct | Struct contains received event
| | o C ICS |
| | o C ICSBase | Struct that holds identification of receiver and interconnection type
| | o C REQUEST_Struct |
| | o C StringWithHash |
| | \ C StringWithHashComparator |
| o C Interval |
| o C InputPin |
| o C OutputPin |
| o C RequestInputPin |
| o C RequestOutputPin |
| o C Logger |
| | o C OutputNotificationFuncStored |
| | o C OutstandingCounter |
| | o C OutstandingText |
| | \ C TimingInfo |
| o C VreckoMessage |
| o C MessageVoid |
| o C MessageSensorTransformation |
| o C MTLock | Base class for multi-thread access to a single variable
| o C MTAutoLock |
| o C MTReadWriteLock |
| o C MTReadWriteLockEx |
| o C MTTwoPrioLimitedLock |
| o C OctTree |
| | \ C OctTreeNode |
| o C PersistentCache | Caching that persists multiple application sessions
| | \ C OpenedCacheFile |
| o C PluginManager | Simple class to load and manage the plugins
| o C PyAbility | Python ability
| o C Range |
| o C RWErrorHandler |
| o C ReaderWriter |
| | \ C AbilityToInitialize |
| o C XercesStr |
| o C ScenePSThreadInfo |
| o C Scene |
| | o C EOIteratorHelper | Class for iterating through all environment objects in non-main threads
| | o C OBJ_INT_PRIO |
| | \ C SC_INT_PRIO |
| o C Scheduler |
| | o C classcomp |
| | \ C TimerStruct |
| o C CollisionPointInfo |
| o C CollisionInfo |
| o C CollisionParams__ver1 | Parameters for the SP_SceneInterface::getCollisions() method
| o C SP_Object_DataInterface |
| o C SP_ObjectInterface |
| o C SP_SceneInterface |
| o C StaticAttribute |
| o C Timer |
| o C ViewerBase | Abstract VRECKO viewer class
| o C Viewer | Child class for classic one screen viewer - used for QUAD_STEREO
| o C CompositeViewer | Child class for more than one screen viewer
| o C vThread |
| o C World |
| | o C AvatarEye | Struct AvatarEye - represents avatar eye's camera parameters
| | o C AvatarView | Struct for description of AvatarView
| | \ C SG_CHANGE | Struct that includes values of the operation parameters
| o C CABUTTONEVENT |
| o C MessageCAButtonEvent |
| o C CAINFO__VER1 |
| o C CAINFO__VER2 |
| o C ControllableAbility |
| | \ C MessageCAINFO |
| o C logger_streambuf |
| \ C MaterialDesc |
o N vreckoDP_base |
| o C A3DBird |
| o C fdtDataGlove |
| o C dataT |
| o C fsPinchGlove |
| o C KeyboardMouse |
| o C L3DMouse |
| o C LHeadTracker |
| o C MicroScribe3D |
| o C NestOfBirds |
| o C OptiTrack |
| | \ C info_struct |
| o C Ultratrak |
| o C VRPN3DMouse |
| \ C Wiimote |
o N vreckoDP_Kinect |
| \ C Kinect |
o N vreckoUtils |
| o C HighlightCallback |
| o C Math |
| o C MenuCommon |
| o C IMenuComponent |
| o C MenuBase |
| o C MenuRoot |
| o C Menu |
| o C MenuItem |
| o C MenuSlider |
| o C MenuVisitor |
| o C Observer |
| \ C Observable |
o N WAVEFRONT |
| o C InPlaceParserInterface |
| o C InPlaceParser |
| o C GeometryVertex |
| o C GeometryInterface |
| o C OBJ |
| \ C BuildMesh |
o N WGeometry |
| o C WG_Geometry |
| o C WG_Vertices |
| o C WG_Point |
| o C WG_Hole |
| \ C WG_Wall |
o C AABoundingBox | Represents a bounding box (a sphere, actually) of the object which wraps the object in it
o C AddObserver | Rozhrani pro objekty, ktere zajima udalost Add
o C AllCloudsUpdateCallBack | Structure containing camera data which is common for all of the clouds and overloaded callback method which is called once per frame
o C angle_3D |
o C AnimatedGeometryState | Uchovava informace o animovanem Cal3D modelu, jeho data v pameti a pocet referenci
o C Arm |
o C BasicPreloaderHeuristic |
o C BCLoaderErrorHandler |
o C BehindObstacleExp_wT |
| \ C ExperimentRec |
o C BehindObstacleExperiment |
| \ C ExperimentRec |
o C BinomialHeap |
| \ C BinomialHeapNode |
o C BufferedSpline |
o C Cache | Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM
o C CacheInfo | Trida pro drzeni informaci o polozce v Cache
o C CatmullRomInterpolator |
o C ChessBoard |
| \ C Request |
o C ChessPiece |
o C Cloud |
| \ C ParticleAwayComparison |
o C CloudDataType | Inherited class from osg::Referenced. Stores information about the camera and can be referenced by osg::ref_ptr
o C CloudParticle |
o C CloudSceneInfo |
o C CloudsManager | Manages all the clouds in the scene
o C CloudsProperties | Contains all the properties of the Clouds ability loaded from XML file
o C CloudVoxel | Represents a cloud voxel used for cloud generation
o C ConstantColorGen |
o C ConstraintHierarchyMember |
o C CubicInterpolator |
o C DAControlPoint | Control point of Motion trail
o C DAGizmo | Gizmo - graphical representation of something, e.g. Frenet frame
o C DASample |
o C DeleteObserver | Rozhrani pro objekty, ktere zajima udalost Delete
o C DynamicTree |
o C DynamicTreeIterator |
o C DynTreeNode |
o C EOLineSegmentIntersector |
o C FibonacciHeap |
| \ C FibonacciHeapNode |
o C FilletSpline |
o C filter1 |
o C filter2 |
o C FrenetFrame |
o C GenericHeap |
| \ C GenericHeapNode |
o C GeometryState | Uchovava informace o statickem modelu, jeho data v pameti a pocet referenci (instanci modelu ve scene)
o C GetObserver | Rozhrani pro objekty, ktere zajima udalost Get
o C gmMatrix3 |
o C gmMatrix4 |
o C gmVector2 |
o C gmVector3 |
o C gmVector4 |
o C GradientColorGen |
o C GradientDiameterGen |
o C Hci |
o C Icon | Icon
o C InterpolatedSpline |
o C Interpolator |
o C InterpolatorFactory |
o C length_3D |
o C LinearInterpolator |
o C LoadingConsole |
| o C Line |
| \ C OutstandingLine |
o C MagicWandTool |
o C MainObject |
o C MainSceneUpdateCallback |
o C MemoryReadBuffer |
o C MemoryWriteBuffer |
o C ModelManager |
o C MotionTrailTriangulator |
o C MTBrush | Store info about shape of cross-section of Motion trail
o C MTCreatorTool | Motion trails creator tool
o C MyReadCallback |
o C NullInterpolator |
o C packet_rec |
o C Particle |
o C PHANToMAvatar |
o C PHEffect |
o C Point3 |
o C Point3f |
o C Preloader | Nahrava pravdepodobne potrebne modely v blizke budoucnosti, modely jsou urceny podle pouzite heuristiky
o C PreloaderHeuristic | Rozhrani pro heuristiky, ktere se maji pouzit v Preloaderu
o C PreloaderLoadedInfo |
o C PreloaderToLoadInfo |
o C PseudoRand2DPlacement | Represents a class which pseudo-randomly scatters the clouds over the sky in form of the grid (for now)
o C RealCmp |
o C Receiver |
o C RegularPolygonSpline |
o C SampledSpline |
o C Sector |
o C SectorColorGen |
o C Serial |
o C SliceTool |
o C SmoothedSpline |
o C SnapObject |
o C SNCH_THREAD_START_INFO |
o C StrX |
o C SunLight |
o C SweepSurfaceGeode |
o C ThinHeap |
| \ C ThinHeapNode |
o C TimeLineSpline |
o C Timing |
o C Triangle |
o C Triangle3 |
o C Triangle3v |
o C UniformUpdateCallback |
o C UserStream |
\ C WavefrontObj |
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: AP_CableEditor::Cable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_CableEditor
  • Cable
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AP_CableEditor::Cable Class Reference

#include <Cable.h>

Inheritance diagram for AP_CableEditor::Cable:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Cable ()
virtual | ~Cable ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | setCableID (string ID)
string | getCableID ()
void | setShape (osg::ref_ptr< osg::Vec3Array > points)
osg::ref_ptr< osg::Vec3Array > | getShape ()
void | setInterpolation (unsigned int type, unsigned int num)
void | getInterpolation (unsigned int *type, unsigned int *num)
void | setRadius (float radius)
float | getRadius ()
void | setControlSpheresRadiusAdjust (float radius)
float | getControlSpheresRadiusAdjust ()
void | updateControlSpheresRadius ()
void | setCableColor (osg::Vec4f color)
osg::Vec4f | getCableColor ()
void | setControlSpheresColor (osg::Vec4f color)
osg::Vec4f | ControlSpheresColor ()
void | setShapeRotate (float angle)
float | getShapeRotate ()
void | setEoWrapper (EnvironmentObject *wrapper)
EnvironmentObject * getEoWrapper ()
osg::Node * | getCableWrapperNode ()
void | setControlPoints (osg::ref_ptr< osg::Vec3Array > points)
osg::ref_ptr< osg::Vec3Array > | getControlPoints ()
osg::ref_ptr< osg::Vec3Array > | getIntepolatedPoints ()
void | addControlPoint (osg::Vec3f position)
void | addControlPoint (unsigned int position, osg::Vec3f point)
void | addControlPointBetweenLine (osg::Vec3f position)
osg::Vec3f | getInterpolatedPoint (osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, double t=0.5) const
EnvironmentObject * | createSphere (osg::Vec3f center, float radius=0.25)
EnvironmentObject * | createSphere (osg::Vec3f center, osg::Vec4f color, float radius=0.25)
void | interpolate ()
osg::ref_ptr< osg::Vec3Array > | interpolateCatPerSegment (osg::ref_ptr< osg::Vec3Array > inputPoints, unsigned int pointsPerSegment) const
osg::ref_ptr< osg::Vec3Array > | interpolateCatIterate (osg::ref_ptr< osg::Vec3Array > inputPoints, unsigned int numIterations) const
void | wrapCable ()
void | setUpdate (bool state)
bool | getUpdate ()
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
int | computeRMF (osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals)
osg::Vec3Array * | transformVectors (osg::Vec3Array *vectors, osg::Vec3f point, osg::Vec3f tangent, osg::Vec3f normal, osg::Vec3f binormal, float scale=1)
osg::ref_ptr< osg::Geode > | wrap (osg::Vec3Array *shapeVectors, osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals, float scale=1, unsigned int wrapFrom=1, unsigned int wrapNum=0)
void | visualizeVectors (osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | updateSpheresPosition ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
void | createSpheres ()
void | clearSpheres ()
void | updateControlPoints ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | controlPointsChange
bool | isUpdateState
float | cableRadius
float | controlSpheresRadiusAdjust
float | basePlaneRotation
osg::Vec4f | cableColor
osg::Vec4f | controlSpheresColor
osg::ref_ptr< osg::Vec3Array > | controlPoints
osg::ref_ptr< osg::Vec3Array > | thisTangents
osg::ref_ptr< osg::Vec3Array > | thisNormals
osg::ref_ptr< osg::Vec3Array > | thisBinormals
osg::ref_ptr< osg::Vec3Array > | interpolatedPoints
osg::ref_ptr< osg::Vec3Array > | shapePoints
std::vector
< vrecko::EnvironmentObject * > * 		controlSpheres
EnvironmentObject * cableControlLine
EnvironmentObject * thisEoWrapper
osg::ref_ptr
< osg::MatrixTransform > 		lastWrapperTransformation
osg::ref_ptr< osg::Geode > | wrapperGeode
unsigned int | interpolationsNum
unsigned int | interpolationType
string | cableID
EnvironmentObject * controlVectors
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

AP_CableEditor::Cable::Cable ( )
AP_CableEditor::Cable::~Cable ( )
virtual

Member Function Documentation

void AP_CableEditor::Cable::addControlPoint ( osg::Vec3f position )
inline
void AP_CableEditor::Cable::addControlPoint | ( | unsigned int | position,
 |  | osg::Vec3f | point
 | ) |  |
void AP_CableEditor::Cable::addControlPointBetweenLine ( osg::Vec3f position )
void AP_CableEditor::Cable::clearSpheres ( )
protected
int AP_CableEditor::Cable::computeRMF | ( | osg::Vec3Array * | points,
 |  | osg::Vec3Array * | tangents,
 |  | osg::Vec3Array * | normals,
 |  | osg::Vec3Array * | binormals
 | ) |  |
osg::Vec4f AP_CableEditor::Cable::ControlSpheresColor ( )
inline
EnvironmentObject* AP_CableEditor::Cable::createSphere | ( | osg::Vec3f | center,
 |  | float | radius = 0.25
 | ) |  |
inline
EnvironmentObject * AP_CableEditor::Cable::createSphere | ( | osg::Vec3f | center,
 |  | osg::Vec4f | color,
 |  | float | radius = 0.25
 | ) |  |
void AP_CableEditor::Cable::createSpheres ( )
protected
osg::Vec4f AP_CableEditor::Cable::getCableColor ( )
inline
string AP_CableEditor::Cable::getCableID ( )
inline
osg::Node* AP_CableEditor::Cable::getCableWrapperNode ( )
inline
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::getControlPoints ( )
inline
float AP_CableEditor::Cable::getControlSpheresRadiusAdjust ( )
inline
EnvironmentObject* AP_CableEditor::Cable::getEoWrapper ( )
inline
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::getIntepolatedPoints ( )
inline
osg::Vec3f AP_CableEditor::Cable::getInterpolatedPoint | ( | osg::Vec3 | p0,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3,
 |  | double | t = 0.5
 | ) |  | const
void AP_CableEditor::Cable::getInterpolation | ( | unsigned int * | type,
 |  | unsigned int * | num
 | ) |  |
inline
float AP_CableEditor::Cable::getRadius ( )
inline
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::getShape ( )
inline
float AP_CableEditor::Cable::getShapeRotate ( )
inline
bool AP_CableEditor::Cable::getUpdate ( )
inline
void AP_CableEditor::Cable::interpolate ( )
osg::ref_ptr< osg::Vec3Array > AP_CableEditor::Cable::interpolateCatIterate | ( | osg::ref_ptr< osg::Vec3Array > | inputPoints,
 |  | unsigned int | numIterations
 | ) |  | const
osg::ref_ptr< osg::Vec3Array > AP_CableEditor::Cable::interpolateCatPerSegment | ( | osg::ref_ptr< osg::Vec3Array > | inputPoints,
 |  | unsigned int | pointsPerSegment
 | ) |  | const
void AP_CableEditor::Cable::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void AP_CableEditor::Cable::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

int AP_CableEditor::Cable::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

void AP_CableEditor::Cable::setCableColor ( osg::Vec4f color )
inline
void AP_CableEditor::Cable::setCableID ( string ID )
inline
void AP_CableEditor::Cable::setControlPoints ( osg::ref_ptr< osg::Vec3Array > points )
inline
void AP_CableEditor::Cable::setControlSpheresColor ( osg::Vec4f color )
inline
void AP_CableEditor::Cable::setControlSpheresRadiusAdjust ( float radius )
inline
void AP_CableEditor::Cable::setEoWrapper ( EnvironmentObject * wrapper )
inline
void AP_CableEditor::Cable::setInterpolation | ( | unsigned int | type,
 |  | unsigned int | num
 | ) |  |
inline
void AP_CableEditor::Cable::setRadius ( float radius )
inline
void AP_CableEditor::Cable::setShape ( osg::ref_ptr< osg::Vec3Array > points )
inline
void AP_CableEditor::Cable::setShapeRotate ( float angle )
inline
void AP_CableEditor::Cable::setUpdate ( bool state )
osg::Vec3Array * AP_CableEditor::Cable::transformVectors | ( | osg::Vec3Array * | vectors,
 |  | osg::Vec3f | point,
 |  | osg::Vec3f | tangent,
 |  | osg::Vec3f | normal,
 |  | osg::Vec3f | binormal,
 |  | float | scale = 1
 | ) |  |
void AP_CableEditor::Cable::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void AP_CableEditor::Cable::updateControlPoints ( )
protected
void AP_CableEditor::Cable::updateControlSpheresRadius ( )
void AP_CableEditor::Cable::updateSpheresPosition ( )
protected
void AP_CableEditor::Cable::visualizeVectors | ( | osg::Vec3Array * | points,
 |  | osg::Vec3Array * | tangents,
 |  | osg::Vec3Array * | normals,
 |  | osg::Vec3Array * | binormals
 | ) |  |
osg::ref_ptr< osg::Geode > AP_CableEditor::Cable::wrap | ( | osg::Vec3Array * | shapeVectors,
 |  | osg::Vec3Array * | points,
 |  | osg::Vec3Array * | tangents,
 |  | osg::Vec3Array * | normals,
 |  | osg::Vec3Array * | binormals,
 |  | float | scale = 1,
 |  | unsigned int | wrapFrom = 1,
 |  | unsigned int | wrapNum = 0
 | ) |  |
void AP_CableEditor::Cable::wrapCable ( )

Member Data Documentation

float AP_CableEditor::Cable::basePlaneRotation
protected
osg::Vec4f AP_CableEditor::Cable::cableColor
protected
EnvironmentObject* AP_CableEditor::Cable::cableControlLine
protected
string AP_CableEditor::Cable::cableID
protected
float AP_CableEditor::Cable::cableRadius
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::controlPoints
protected
bool AP_CableEditor::Cable::controlPointsChange
protected
std::vector<vrecko::EnvironmentObject *>* AP_CableEditor::Cable::controlSpheres
protected
osg::Vec4f AP_CableEditor::Cable::controlSpheresColor
protected
float AP_CableEditor::Cable::controlSpheresRadiusAdjust
protected
EnvironmentObject* AP_CableEditor::Cable::controlVectors
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::interpolatedPoints
protected
unsigned int AP_CableEditor::Cable::interpolationsNum
protected
unsigned int AP_CableEditor::Cable::interpolationType
protected
bool AP_CableEditor::Cable::isUpdateState
protected
osg::ref_ptr<osg::MatrixTransform> AP_CableEditor::Cable::lastWrapperTransformation
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::shapePoints
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::thisBinormals
protected
EnvironmentObject* AP_CableEditor::Cable::thisEoWrapper
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::thisNormals
protected
osg::ref_ptr<osg::Vec3Array> AP_CableEditor::Cable::thisTangents
protected
osg::ref_ptr<osg::Geode> AP_CableEditor::Cable::wrapperGeode
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/Cable.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor/Cable.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_CableEditor::CableEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_CableEditor
  • CableEditor
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AP_CableEditor::CableEditor Class Reference

#include <CableEditor.h>

Inheritance diagram for AP_CableEditor::CableEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

CableEditor ()
virtual | ~CableEditor ()
virtual void | update (void)
bool | isCable (unsigned int pEoID)
osg::ref_ptr< osg::Vec3Array > | createCircle (unsigned int steps)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Init ()
void | preInit ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
bool | makeMenu ()
Cable * | getCableAbility (unsigned int EoId, bool notify=false)
EnvironmentObject * | createEoAbility (bool addToWorld=true)
void | loadShapes ()
void | loadCables ()
void | saveCable (std::ofstream &outputFile, Cable *cable)
void | writeInfo (std::ofstream &outputFile)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

unsigned int | cableID
unsigned int | selectedCableId
bool | isSelectedCable
bool | isAddingPointState
bool | isDeletingSphereState
bool | isInsertBetweenState
unsigned int | insertIndex
osg::Vec3f | newPoint
Cable * selectedCablePtr
float | selectedCableBaseRadius
EnvironmentObject * sphereBetweenPoints
std::string | cablesFile
std::string | shapesFile
std::string | objFileDest
std::vector< osg::ref_ptr
< osg::Vec3Array > > 		loadedShapes
std::vector< osg::ref_ptr
< osg::Vec3Array > > 		predefinedShapes
std::list< EnvironmentObject * > | cablePointers
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

AP_CableEditor::CableEditor::CableEditor ( )
AP_CableEditor::CableEditor::~CableEditor ( )
virtual

Member Function Documentation

bool AP_CableEditor::CableEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

osg::ref_ptr< osg::Vec3Array > AP_CableEditor::CableEditor::createCircle ( unsigned int steps )
EnvironmentObject * AP_CableEditor::CableEditor::createEoAbility ( bool addToWorld = true )
protected
void AP_CableEditor::CableEditor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void AP_CableEditor::CableEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

Cable * AP_CableEditor::CableEditor::getCableAbility | ( | unsigned int | EoId,
 |  | bool | notify = false
 | ) |  |
protected
void AP_CableEditor::CableEditor::Init ( )
protected
bool AP_CableEditor::CableEditor::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
protectedvirtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

bool AP_CableEditor::CableEditor::isCable ( unsigned int pEoID )
void AP_CableEditor::CableEditor::loadCables ( )
protected
void AP_CableEditor::CableEditor::loadShapes ( )
protected
bool AP_CableEditor::CableEditor::makeMenu ( )
protected
void AP_CableEditor::CableEditor::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void AP_CableEditor::CableEditor::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
protectedvirtual

You should override this method if there is any slider in your menu.

Reimplemented from vrecko::ControllableAbility.

void AP_CableEditor::CableEditor::preInit ( )
protected
void AP_CableEditor::CableEditor::processButtonRelease ( CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

int AP_CableEditor::CableEditor::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Processes any notification. If you ever override this method, you MUST call the overridden one (this one).

Reimplemented from vrecko::ControllableAbility.

void AP_CableEditor::CableEditor::saveCable | ( | std::ofstream & | outputFile,
 |  | Cable * | cable
 | ) |  |
protected
void AP_CableEditor::CableEditor::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

void AP_CableEditor::CableEditor::writeInfo ( std::ofstream & outputFile )
protected

Member Data Documentation

unsigned int AP_CableEditor::CableEditor::cableID
protected
std::list<EnvironmentObject *> AP_CableEditor::CableEditor::cablePointers
protected
std::string AP_CableEditor::CableEditor::cablesFile
protected
unsigned int AP_CableEditor::CableEditor::insertIndex
protected
bool AP_CableEditor::CableEditor::isAddingPointState
protected
bool AP_CableEditor::CableEditor::isDeletingSphereState
protected
bool AP_CableEditor::CableEditor::isInsertBetweenState
protected
bool AP_CableEditor::CableEditor::isSelectedCable
protected
std::vector<osg::ref_ptr<osg::Vec3Array> > AP_CableEditor::CableEditor::loadedShapes
protected
osg::Vec3f AP_CableEditor::CableEditor::newPoint
protected
std::string AP_CableEditor::CableEditor::objFileDest
protected
std::vector<osg::ref_ptr<osg::Vec3Array> > AP_CableEditor::CableEditor::predefinedShapes
protected
float AP_CableEditor::CableEditor::selectedCableBaseRadius
protected
unsigned int AP_CableEditor::CableEditor::selectedCableId
protected
Cable* AP_CableEditor::CableEditor::selectedCablePtr
protected
std::string AP_CableEditor::CableEditor::shapesFile
protected
EnvironmentObject* AP_CableEditor::CableEditor::sphereBetweenPoints
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/CableEditor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor/CableEditor.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Abstract0LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Abstract0LSystem
Public Member Functions | Protected Member Functions | List of all members
AP_LSystem::Abstract0LSystem Class Reference

#include <abstract0lsystem.h>

Inheritance diagram for AP_LSystem::Abstract0LSystem:
AP_LSystem::LSystem AP_LSystem::AbstractLSystem AP_LSystem::ParD0LSystem AP_LSystem::ParStoch0LSystem

Public Member Functions

Abstract0LSystem (AbstractFile *)
Abstract0LSystem (const Abstract0LSystem &)
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
virtual boost::shared_ptr
< AbstractLSystem > 		clone () const =0
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Protected Member Functions

virtual void | processPredecessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processRuleSuccessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processHomomorphismSuccessor (Rule &rule, string *str, string::iterator &pos)
- Protected Member Functions inherited from AP_LSystem::LSystem
virtual void | setAxiom (std::string &)
virtual void | addRule (std::string *)
virtual void | addHomomorphism (std::string *)
virtual bool | nextIteration ()
virtual bool | transcribe (multimap< char, Rule > &rules)
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters)
virtual void | generateSuccessor (LongString *word, multimap< char, Rule >::iterator &rule, double *params)

Additional Inherited Members

- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Detailed Description

Abstract class for context-free 0L-systems

Constructor & Destructor Documentation

Abstract0LSystem::Abstract0LSystem ( AbstractFile * file )
Abstract0LSystem::Abstract0LSystem ( const Abstract0LSystem & c )

Member Function Documentation

void Abstract0LSystem::processHomomorphismSuccessor | ( | Rule & | rule,
 |  | string * | str,
 |  | string::iterator & | pos
 | ) |  |
protectedvirtual

Parses a homomorphism successor and stores it to Rule structure

Parameters
rule | structure of rule for storing parsed data
str | string with rule
pos | position of predecessor in rule string

Implements AP_LSystem::LSystem.

void Abstract0LSystem::processPredecessor | ( | Rule & | rule,
 |  | string * | str,
 |  | string::iterator & | pos
 | ) |  |
protectedvirtual

Parses a predecessor of rule or homomorphism and stores it to Rule structure

Parameters
rule | structure of rule for storing parsed data
str | string with rule
pos | position of predecessor in rule string

Implements AP_LSystem::LSystem.

void Abstract0LSystem::processRuleSuccessor | ( | Rule & | rule,
 |  | string * | str,
 |  | string::iterator & | pos
 | ) |  |
protectedvirtual

Parses a rule successor and stores it to Rule structure

Parameters
rule | structure of rule for storing parsed data
str | string with rule
pos | position of predecessor in rule string

Implements AP_LSystem::LSystem.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstract0lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstract0lsystem.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractFile
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AP_LSystem::AbstractFile Class Referenceabstract

#include <abstractfile.h>

Inheritance diagram for AP_LSystem::AbstractFile:
AP_LSystem::LSFile AP_LSystem::XmlFile

Public Member Functions

AbstractFile ()
virtual void | open (std::string &filename)=0
void | substitute (std::map< string, string > &pairs)
virtual std::vector< string > * | getHomomorphisms ()
virtual std::vector< string > * | getRules ()
virtual std::vector< string > * | getSubsystems ()
std::string & | getAxiom ()
unsigned int | type ()
std::string & | name ()

Protected Member Functions

void addType (std::string &type)

Protected Attributes

unsigned int | m_Type
type of loaded L-system More...
string | m_Name
name of loaded L-system More...
string | m_Axiom
loaded axiom More...
std::vector< string > | m_Rules
container with loaded rules strings More...
std::vector< string > | m_Homomorphisms
container with loaded homomorphism rules More...
std::vector< string > | m_Subsytems
container with subsystem's filenames More...

Detailed Description

Abstract class for file types.

Constructor & Destructor Documentation

AP_LSystem::AbstractFile::AbstractFile ( )
inline

Constructor - inicialize L-system type to zero

Member Function Documentation

void AP_LSystem::AbstractFile::addType ( std::string & type )
inlineprotected

Type of L-system is composed by binary adding of some capabilities. This method binary adds new capability. List of capability strings:

  • 0L
  • 1LL
  • 1LR
  • 2L
  • IL
  • DETERMINISTIC
  • STOCHASTIC
  • PARAMETRIC
    Parameters
    type string with type to add
std::string& AP_LSystem::AbstractFile::getAxiom ( )
inline

Get axiom - the initial word.

Returns
axiom
virtual std::vector<string>* AP_LSystem::AbstractFile::getHomomorphisms ( )
inlinevirtual

Get homomorphisms stored in std::vector.

Returns
homomorphisms in string format
virtual std::vector<string>* AP_LSystem::AbstractFile::getRules ( )
inlinevirtual

Get rules stored in std::vector.

Returns
rules in string format
virtual std::vector<string>* AP_LSystem::AbstractFile::getSubsystems ( )
inlinevirtual

Get filenames of all subsystems stored in std::vector.

Returns
subsystem filenames
std::string& AP_LSystem::AbstractFile::name ( )
inline

Returns name of L-system.

Returns
name of L-system
virtual void AP_LSystem::AbstractFile::open ( std::string & filename )
pure virtual

Pure method for opening file.

Parameters
filename filename of file

Implemented in AP_LSystem::XmlFile.

void AP_LSystem::AbstractFile::substitute ( std::map< string, string > & pairs )
inline

Substitute all occurences of map's keys by their values in axiom, rules and homomorphisms.

Parameters
pairs map with substitution pairs
unsigned int AP_LSystem::AbstractFile::type ( )
inline

Get type of L-system. Stored as bitmap of desired capabilities.

Returns
type of L-system

Member Data Documentation

string AP_LSystem::AbstractFile::m_Axiom
protected

loaded axiom

std::vector<string> AP_LSystem::AbstractFile::m_Homomorphisms
protected

container with loaded homomorphism rules

string AP_LSystem::AbstractFile::m_Name
protected

name of loaded L-system

std::vector<string> AP_LSystem::AbstractFile::m_Rules
protected

container with loaded rules strings

std::vector<string> AP_LSystem::AbstractFile::m_Subsytems
protected

container with subsystem's filenames

unsigned int AP_LSystem::AbstractFile::m_Type
protected

type of loaded L-system

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractfile.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractGenerator
Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
AP_LSystem::AbstractGenerator Class Referenceabstract

#include <abstractgenerator.h>

Inheritance diagram for AP_LSystem::AbstractGenerator:
AP_LSystem::LSystemGenerator

Public Member Functions

AbstractGenerator (void)
AbstractGenerator (const AbstractGenerator &c)
AbstractGenerator & | operator= (const AbstractGenerator &c)
~AbstractGenerator (void)
virtual void | loadFile (std::string &filename)=0
virtual void | nextIteration ()=0
virtual ParseableString * | getWord ()=0
virtual void | saveWordToFile (std::string &)
virtual void | loadWordFromFile (std::string &)

Static Public Member Functions

static boost::shared_ptr
< AbstractLSystem > 		createLSystem (AbstractFile *file)

Protected Attributes

ParseableString * m_Word
word generated by generator More...
boost::shared_ptr
< AbstractLSystem > 		m_MainLSystem
L-system that is used for generating. More...

Detailed Description

L-system generator is a main class ford word generation. It controls one L-system and use them for words generating. This is a base abstract class which is an interface for communication with higher levels.

Constructor & Destructor Documentation

AP_LSystem::AbstractGenerator::AbstractGenerator ( void )
inline

Incialize word and main L-system as NULL

AP_LSystem::AbstractGenerator::AbstractGenerator ( const AbstractGenerator & c )
inline

Copy constructor

AP_LSystem::AbstractGenerator::~AbstractGenerator ( void )
inline

Descructor release memory of generated word and l-system

Member Function Documentation

boost::shared_ptr< AbstractLSystem > AbstractGenerator::createLSystem ( AbstractFile * file )
static

Creates an L-system according to type. It chooses from all AbstractLSystem childs and select the best suitable L-system implementation for this type of L-system.

Parameters
file file with loaded L-system
Returns
created L-system
virtual ParseableString* AP_LSystem::AbstractGenerator::getWord ( )
pure virtual

Get generated word in format suitable for parsing and intepreting.

Returns
generated word

Implemented in AP_LSystem::LSystemGenerator.

virtual void AP_LSystem::AbstractGenerator::loadFile ( std::string & filename )
pure virtual

Loads an L-system. File is specified by it's filename.

Parameters
filename filename of file in one of supported L-system formats

Implemented in AP_LSystem::LSystemGenerator.

void AbstractGenerator::loadWordFromFile ( std::string & filename )
virtual

Not implemented

virtual void AP_LSystem::AbstractGenerator::nextIteration ( )
pure virtual

Process one iteration on generator's main L-system.

Implemented in AP_LSystem::LSystemGenerator.

AbstractGenerator& AP_LSystem::AbstractGenerator::operator= ( const AbstractGenerator & c )
inline

Asignment operator

void AbstractGenerator::saveWordToFile ( std::string & filename )
virtual

Not implemented

Member Data Documentation

boost::shared_ptr<AbstractLSystem> AP_LSystem::AbstractGenerator::m_MainLSystem
protected

L-system that is used for generating.

ParseableString* AP_LSystem::AbstractGenerator::m_Word
protected

word generated by generator

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractgenerator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstractgenerator.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractInterpret Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractInterpret
Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
AP_LSystem::AbstractInterpret Class Referenceabstract

#include <abstractinterpret.h>

Inheritance diagram for AP_LSystem::AbstractInterpret:
AP_LSystem::QueryInterpret AP_LSystem::TurtleInterpret

Public Member Functions

AbstractInterpret ()
int | switchGeode (std::vector< Parameter > &p)
void | createGeodes ()
virtual int | parse (ParseableString *word)=0

Static Public Member Functions

static const char * errorText (int error)

Protected Attributes

vector< LSGeode * > | m_Geodes
osg::Group * | m_Owner
scene graph owner More...
TurtleStack m_Turtles
stack for turtles More...

Constructor & Destructor Documentation

AP_LSystem::AbstractInterpret::AbstractInterpret ( )
inline

Member Function Documentation

void AP_LSystem::AbstractInterpret::createGeodes ( )
inline

Initialize interpret. Scan for loaded L-systems and create LSGeodes instances for them.

static const char* AP_LSystem::AbstractInterpret::errorText ( int error )
inlinestatic

Translates error codes to error messages.

Parameters
error error code
Returns
error message
virtual int AP_LSystem::AbstractInterpret::parse ( ParseableString * word )
pure virtual

Interpretes a word by converting L-system modules to turtle commands.

Parameters
word interpreted word
Returns
error code

Implemented in AP_LSystem::TurtleInterpret.

int AP_LSystem::AbstractInterpret::switchGeode ( std::vector< Parameter > & p )
inline

This method is called if change of L-system is interpreted.

Parameters
p vector with parameters of module.
  • 1 parameter: Begin of different L-system. Push new turtle of different L-system. The parameter is L-system ID
  • 0 parameters: End of current L-system subword. Pop turtle from the stack.

Member Data Documentation

vector< LSGeode *> AP_LSystem::AbstractInterpret::m_Geodes
protected

Instances of LSGeode for each loaded L-system. It contains geometry and information about turtle type and settings.

osg::Group* AP_LSystem::AbstractInterpret::m_Owner
protected

scene graph owner

TurtleStack AP_LSystem::AbstractInterpret::m_Turtles
protected

stack for turtles

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractinterpret.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractkLSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractkLSystem
Public Member Functions | List of all members
AP_LSystem::AbstractkLSystem Class Reference

#include <abstractklsystem.h>

Inheritance diagram for AP_LSystem::AbstractkLSystem:
AP_LSystem::LSystem AP_LSystem::AbstractLSystem AP_LSystem::Par2LSystem

Public Member Functions

AbstractkLSystem (AbstractFile *)
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
virtual boost::shared_ptr
< AbstractLSystem > 		clone () const =0
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::LSystem
virtual void | setAxiom (std::string &)
virtual void | addRule (std::string *)
virtual void | addHomomorphism (std::string *)
virtual void | processPredecessor (Rule &, string *, string::iterator &)=0
virtual void | processRuleSuccessor (Rule &, string *, string::iterator &)=0
virtual void | processHomomorphismSuccessor (Rule &, string *, string::iterator &)=0
virtual bool | nextIteration ()
virtual bool | transcribe (multimap< char, Rule > &rules)
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters)
virtual void | generateSuccessor (LongString *word, multimap< char, Rule >::iterator &rule, double *params)
- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Detailed Description

Abstract class for kL-Systems

Constructor & Destructor Documentation

AbstractkLSystem::AbstractkLSystem ( AbstractFile * file )

Constructor

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractklsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstractklsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractLSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractLSystem
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AP_LSystem::AbstractLSystem Class Referenceabstract

#include <abstractlsystem.h>

Inheritance diagram for AP_LSystem::AbstractLSystem:
AP_LSystem::LSystem AP_LSystem::Abstract0LSystem AP_LSystem::AbstractkLSystem AP_LSystem::D0LSystem AP_LSystem::ParD0LSystem AP_LSystem::ParStoch0LSystem AP_LSystem::Par2LSystem

Public Member Functions

AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
virtual boost::shared_ptr
< AbstractLSystem > 		clone () const =0
AbstractLSystem & | operator= (const AbstractLSystem &c)
virtual bool | nextIteration ()=0
virtual LongString * | translate ()=0
virtual void | loadFromFile (AbstractFile *file)=0
unsigned int | getIteration () const

Protected Member Functions

virtual void | addRule (std::string *)=0
virtual void | addHomomorphism (std::string *)=0
virtual void | setAxiom (std::string &)=0

Protected Attributes

std::string | m_Name
name of L-system More...
unsigned int | m_Iteration
number of processed iterations More...

Detailed Description

Abstract class for L-systems. It is basic interface for communication with L-system generator.

Constructor & Destructor Documentation

AP_LSystem::AbstractLSystem::AbstractLSystem ( )
inline
AP_LSystem::AbstractLSystem::AbstractLSystem ( const AbstractLSystem & c )
inline

Member Function Documentation

virtual void AP_LSystem::AbstractLSystem::addHomomorphism ( std::string * )
protectedpure virtual

Add homomorphism and convert it to instance of Rule class

Implemented in AP_LSystem::LSystem.

virtual void AP_LSystem::AbstractLSystem::addRule ( std::string * )
protectedpure virtual

Add rule and convert it to instance of Rule class

Implemented in AP_LSystem::LSystem.

virtual boost::shared_ptr<AbstractLSystem> AP_LSystem::AbstractLSystem::clone ( ) const
pure virtual

Virtual constructor

Implemented in AP_LSystem::ParStoch0LSystem, AP_LSystem::D0LSystem, and AP_LSystem::Par2LSystem.

unsigned int AP_LSystem::AbstractLSystem::getIteration ( ) const
inline

Get current iteration.

Returns
current L-system iteration
virtual void AP_LSystem::AbstractLSystem::loadFromFile ( AbstractFile * file )
pure virtual

Load and initialize L-system according to it's parameters.

Parameters
file Loaded L-system file

Implemented in AP_LSystem::LSystem.

virtual bool AP_LSystem::AbstractLSystem::nextIteration ( )
pure virtual

Process next iteration. It uses transcription rules to get a new word.

Returns
true if succeeded

Implemented in AP_LSystem::LSystem.

AbstractLSystem& AP_LSystem::AbstractLSystem::operator= ( const AbstractLSystem & c )
inline

Assignment operator

virtual void AP_LSystem::AbstractLSystem::setAxiom ( std::string & )
protectedpure virtual

Set axiom. Inicialize word.

Implemented in AP_LSystem::LSystem.

virtual LongString* AP_LSystem::AbstractLSystem::translate ( )
pure virtual

Translate a word to final form and get it.

Returns
word as LongString

Implemented in AP_LSystem::LSystem.

Member Data Documentation

unsigned int AP_LSystem::AbstractLSystem::m_Iteration
protected

number of processed iterations

std::string AP_LSystem::AbstractLSystem::m_Name
protected

name of L-system

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractlsystem.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::AbstractTurtle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractTurtle
Public Member Functions | Protected Attributes | List of all members
AP_LSystem::AbstractTurtle Class Referenceabstract

#include <abstractturtle.h>

Inheritance diagram for AP_LSystem::AbstractTurtle:
AP_LSystem::MovingTurtle AP_LSystem::LoftTurtle AP_LSystem::QueryTurtle AP_LSystem::Rectangle AP_LSystem::JointedPipe AP_LSystem::StraightPipe AP_LSystem::HermitPipe

Public Member Functions

virtual int | initialize ()
virtual int | finalize ()
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawFrame (osg::Matrixd &matrix, osg::Vec4d *color=NULL)=0
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)
virtual int | turnLeft (std::vector< Parameter > &p)=0
virtual int | turnRight (std::vector< Parameter > &p)=0
virtual int | pitchDown (std::vector< Parameter > &p)=0
virtual int | pitchUp (std::vector< Parameter > &p)=0
virtual int | rollLeft (std::vector< Parameter > &p)=0
virtual int | rollRight (std::vector< Parameter > &p)=0
virtual int | turnArround ()=0
virtual int | rollArround ()=0
virtual int | rollUntilHorizontal ()=0
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)=0
virtual int | multiplyLength (std::vector< Parameter > &p)=0
virtual int | multiplyRadius (std::vector< Parameter > &p)=0
virtual int | multiplyAngle (std::vector< Parameter > &p)=0
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)=0
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)=0
virtual int | drawForward (std::vector< Parameter > &p)=0
virtual int | drawForwardHalf ()=0
virtual int | moveForward (std::vector< Parameter > &p)=0
virtual int | moveForwardHalf ()=0

Protected Attributes

TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Abstract class for all turtles with declarations of all necessary functions.

Member Function Documentation

void AP_LSystem::AbstractTurtle::bindGeode ( LSGeode * geode )
inline

Bind a turtle with LSGeode. During interpretation, the turtle will generate geometry to this LSGeode.

Parameters
geode Geode to be binded.
Parameters
geode bind output geode with current turtle
virtual int AP_LSystem::AbstractTurtle::drawForward ( std::vector< Parameter > & p )
pure virtual

Move forward and generate a geometry

Parameters
p vector with parameters
  • 0 parameters: use a default distance/length for a movement
  • 1 parameter: use this parameter as distance for a movement. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::drawForwardHalf ( )
pure virtual

Move forward and generate a geometry. Use half of default length value for movement.

Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual void AP_LSystem::AbstractTurtle::drawFrame | ( | osg::Matrixd & | matrix,
 |  | osg::Vec4d * | color = NULL
 | ) |  |
pure virtual

For debugging. Draw a turtle frame.

Parameters
matrix | position matrix of turtle
color | color of all vectors. Default is red for heading, green for up and blue for left vector.

Implemented in AP_LSystem::MovingTurtle.

virtual void AP_LSystem::AbstractTurtle::drawVector | ( | const osg::Vec3d & | vector,
 |  | osg::Matrixd & | matrix,
 |  | osg::Vec4d & | color
 | ) |  |
inlinevirtual

For debugging. Draw a vector as arrow.

Parameters
vector | displayed vector
matrix | position matrix of vector
color | color of vector
virtual int AP_LSystem::AbstractTurtle::finalize ( )
inlinevirtual

Process a finalization of turtle. This method is called when turtle is removed from the stack.

Returns
error code

Reimplemented in AP_LSystem::StraightPipe, AP_LSystem::Rectangle, AP_LSystem::QueryTurtle, and AP_LSystem::HermitPipe.

LSGeode* AP_LSystem::AbstractTurtle::getGeode ( )
inline

Get pointer to binded geode.

Returns
binded geode.
osg::Matrixd AP_LSystem::AbstractTurtle::getMatrix ( )
inline

Get position matrix of turtle.

Returns
position matrix
TurtleProperties& AP_LSystem::AbstractTurtle::getProperties ( )
inline

Get turtle properties

Returns
properties
virtual void AP_LSystem::AbstractTurtle::inheritProperties ( TurtleProperties p )
inlinevirtual

Inherit some properties. This method is called if different L-system is detected. This subsystems has own properties, but some properties are inherited from the turtle on the stack.

Parameters
p properties
virtual int AP_LSystem::AbstractTurtle::initialize ( void )
inlinevirtual

Process an initialization of turtle. This method is called when turtle is pushed onto the stack.

Returns
error code

Reimplemented in AP_LSystem::StraightPipe, AP_LSystem::JointedPipe, AP_LSystem::Rectangle, AP_LSystem::HermitPipe, and AP_LSystem::QueryTurtle.

virtual int AP_LSystem::AbstractTurtle::moveForward ( std::vector< Parameter > & p )
pure virtual

Move forward and without generating a geometry

Parameters
p vector with parameters
  • 0 parameters: use a default distance/length for a movement
  • 1 parameter: use this parameter as distance for a movement. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::moveForwardHalf ( )
pure virtual

Move forward without generating a geometry. Use half of default length value for movement.

Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::multiplyAngle ( std::vector< Parameter > & p )
pure virtual

Multiply a default angle.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::multiplyGravitropismElasticity ( std::vector< Parameter > & p )
pure virtual

Multiply a gravitropism/geotropism elasticity.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::multiplyLength ( std::vector< Parameter > & p )
pure virtual

Multiply a default lenght.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::multiplyRadius ( std::vector< Parameter > & p )
pure virtual

Multiply a default radius/thickness.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::multiplyTropismElasticity ( std::vector< Parameter > & p )
pure virtual

Multiply a diatropism elasticity.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::pitchDown ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector L down.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::pitchUp ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector L up.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

double AP_LSystem::AbstractTurtle::rand ( double angle )
inline

Conditionally fluctuate the angle.

Parameters
angle input angle
Returns
conditionally randomized angle
virtual int AP_LSystem::AbstractTurtle::randomTurnPitchRoll ( std::vector< Parameter > & p )
pure virtual

Make a random rotation.

Todo:
Not implemented
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::resetValues ( )
inlinevirtual

Reset all values in properties to default value as set in Configuration.

Todo:
Not implemented.
Returns
error code
virtual int AP_LSystem::AbstractTurtle::rollArround ( )
pure virtual

Make a 180° rotation around vector U.

Todo:
Not implemented
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::rollLeft ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector H to the left.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::rollRight ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector H to the right.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::rollUntilHorizontal ( )
pure virtual

Make a rotation around vector H until left vector is in horizontal position.

Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual void AP_LSystem::AbstractTurtle::setProperties ( TurtleProperties p )
inlinevirtual

Set turtle properties. The setup must be part of turtle initialization.

Parameters
p properties
double AP_LSystem::AbstractTurtle::toRad ( double angle )
inline

Conditionally converts degrees to radians.

Parameters
angle angle in degrees or radians
Returns
angle in radians
virtual int AP_LSystem::AbstractTurtle::turnArround ( )
pure virtual

Make a 180° rotation around vector U.

Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::turnLeft ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector U to the left.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

virtual int AP_LSystem::AbstractTurtle::turnRight ( std::vector< Parameter > & p )
pure virtual

Make a rotation around vector U to the right.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implemented in AP_LSystem::MovingTurtle.

Member Data Documentation

LSGeode* AP_LSystem::AbstractTurtle::geode
protected

all geometry generated by turtle is stored to this output geode

TurtleProperties AP_LSystem::AbstractTurtle::properties
protected

properties of turtle is used for getting parameters for generation of geometry

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractturtle.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Configuration Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Configuration
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::Configuration Class Reference

#include <configuration.h>

Public Member Functions

bool | loadCfgFile (string filename)
void | setProperty (const string &prop)
void | setProperty (const string &lsystemID, const string &prop)
void | setProperty (const string &lsystemID, const string &prop, const string &value)
const int | getLSystemIndex (const string &lsystemID)
const int | getLSystemCount ()
const variable_value * | getProperty (const string &prop)
const variable_value * | getProperty (const string &lsystemID, const string &prop)
const variable_value * | getProperty (const unsigned int lsystemIndex, const string &prop)
const void | writeAll (std::basic_ostream< char > &, const string &)

Static Public Member Functions

static Configuration * get ()

Detailed Description

Configuration class for storing all properties of all L-systems. Every property must be set globally. It is possible to set properties also only for particular L-systems. This value has higher priority.

Member Function Documentation

Configuration * Configuration::get ( )
static

Returns instance of Configuration singleton

Returns
Configuration instance
const int Configuration::getLSystemCount ( )

Returns number L-systems that have stored some properties

Returns
number of L-systems
const int Configuration::getLSystemIndex ( const string & lsystemID )

Returns unique integer identifier of L-system

Parameters
lsystemID name of L-system
Returns
unique index of L-system
const variable_value * Configuration::getProperty ( const string & prop )

Returns property global value

Parameters
prop property name
Returns
property value
const variable_value * Configuration::getProperty | ( | const string & | lsystemID,
 |  | const string & | prop
 | ) |  |

Returns property value of one particular L-system

Parameters
lsystemID | name of L-system
prop | property name
Returns
property value
const variable_value * Configuration::getProperty | ( | const unsigned int | lsystemIndex,
 |  | const string & | prop
 | ) |  |

Returns property value of one particular L-system

Parameters
lsystemIndex | index of L-system
prop | property name
Returns
property value
bool Configuration::loadCfgFile ( string filename )

Loads a configuration file. Loaded properties are marked as global

Parameters
filename configuration file filename
Returns
true if succeeded
void Configuration::setProperty ( const string & prop )

Sets global property value

Parameters
prop property string in following form: (property)=(value)
void Configuration::setProperty | ( | const string & | lsystemID,
 |  | const string & | prop
 | ) |  |

Sets property only for one particular L-system

Parameters
lsystemID | name of L-system
prop | property string in following form: (property)=(value)
void Configuration::setProperty | ( | const string & | lsystemID,
 |  | const string & | prop,
 |  | const string & | value
 | ) |  |

Sets property only for one particular L-system

Parameters
lsystemID | name of L-system
prop | property name
value | property value
const void Configuration::writeAll | ( | std::basic_ostream< char > & | out,
 |  | const string & | lsystemID
 | ) |  |

Not implemented

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/configuration.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/configuration.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::D0LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • D0LSystem
Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Attributes | List of all members
AP_LSystem::D0LSystem Class Reference

#include <d0lsystem.h>

Inheritance diagram for AP_LSystem::D0LSystem:
AP_LSystem::LSystem AP_LSystem::AbstractLSystem

Public Member Functions

D0LSystem (AbstractFile *)
boost::shared_ptr
< AbstractLSystem > 		clone () const
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Static Public Member Functions

static bool isCapable (unsigned int type)

Protected Member Functions

virtual void | processPredecessor (Rule &, string *, string::iterator &)
virtual void | processRuleSuccessor (Rule &, string *, string::iterator &)
virtual void | processHomomorphismSuccessor (Rule &, string *, string::iterator &)
virtual bool | transcribe (multimap< char, Rule > &rules)
- Protected Member Functions inherited from AP_LSystem::LSystem
virtual void | setAxiom (std::string &)
virtual void | addRule (std::string *)
virtual void | addHomomorphism (std::string *)
virtual bool | nextIteration ()
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters)
virtual void | generateSuccessor (LongString *word, multimap< char, Rule >::iterator &rule, double *params)

Static Protected Attributes

static const unsigned int capabilities = LS_0L | LS_DETERMINISTIC

Additional Inherited Members

- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Constructor & Destructor Documentation

D0LSystem::D0LSystem ( AbstractFile * file )

Member Function Documentation

boost::shared_ptr<AbstractLSystem> AP_LSystem::D0LSystem::clone ( ) const
inlinevirtual

Virtual copy constructor

Implements AP_LSystem::AbstractLSystem.

static bool AP_LSystem::D0LSystem::isCapable ( unsigned int type )
inlinestatic

Decides if L-system of passed type can by processed by parametric stochastic context-free L-system

Parameters
type type of L-system that will be compared with D0LSytem capabilities
Returns
true if it is capable to process this type
void D0LSystem::processHomomorphismSuccessor | ( | Rule & | r,
 |  | string * | hom,
 |  | string::iterator & | it
 | ) |  |
protectedvirtual

Implements AP_LSystem::LSystem.

void D0LSystem::processPredecessor | ( | Rule & | r,
 |  | string * | rule,
 |  | string::iterator & | it
 | ) |  |
protectedvirtual

Implements AP_LSystem::LSystem.

void D0LSystem::processRuleSuccessor | ( | Rule & | r,
 |  | string * | rule,
 |  | string::iterator & | it
 | ) |  |
protectedvirtual

Implements AP_LSystem::LSystem.

bool D0LSystem::transcribe ( multimap< char, Rule > & rules )
protectedvirtual

This method provides a transcription funkcionality. It substitutes all modules in word by their successors.

Parameters
rules container with rules
Returns
true if succeeded

Reimplemented from AP_LSystem::LSystem.

Member Data Documentation

const unsigned int AP_LSystem::D0LSystem::capabilities = LS_0L | LS_DETERMINISTIC
staticprotected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/d0lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/d0lsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::HermitPipe Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • HermitPipe
Public Member Functions | List of all members
AP_LSystem::HermitPipe Class Reference

#include <hermitpipe.h>

Inheritance diagram for AP_LSystem::HermitPipe:
AP_LSystem::StraightPipe AP_LSystem::LoftTurtle AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle

Public Member Functions

HermitPipe (void)
~HermitPipe (void)
virtual int | drawStep (double dist)
virtual int | initialize ()
virtual int | finalize ()
- Public Member Functions inherited from AP_LSystem::StraightPipe
StraightPipe (void)
~StraightPipe (void)
virtual int | preStep ()
virtual int | insideStep ()
- Public Member Functions inherited from AP_LSystem::LoftTurtle
LoftTurtle (void)
~LoftTurtle (void)
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::LoftTurtle
void | createCircleContour ()
virtual int | addContourLoftGeometry ()
virtual int | createLoftGeometryOpening ()
- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Constructor & Destructor Documentation

AP_LSystem::HermitPipe::HermitPipe ( void )
inline
AP_LSystem::HermitPipe::~HermitPipe ( void )
inline

Member Function Documentation

int HermitPipe::drawStep ( double dist )
virtual

Do a drawing step forward. Call preStep() before step, insideStep() in the middle of the step and postStep() performing the step

Returns
error code

Reimplemented from AP_LSystem::LoftTurtle.

int HermitPipe::finalize ( )
virtual

Process a finalization of turtle. This method is called when turtle is removed from the stack.

Returns
error code

Reimplemented from AP_LSystem::StraightPipe.

int HermitPipe::initialize ( void )
virtual

Process an initialization of turtle. This method is called when turtle is pushed onto the stack.

Returns
error code

Reimplemented from AP_LSystem::StraightPipe.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/hermitpipe.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/hermitpipe.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::JointedPipe Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • JointedPipe
Public Member Functions | List of all members
AP_LSystem::JointedPipe Class Reference

#include <jointedpipe.h>

Inheritance diagram for AP_LSystem::JointedPipe:
AP_LSystem::LoftTurtle AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle

Public Member Functions

JointedPipe (void)
~JointedPipe (void)
virtual int | initialize ()
virtual int | preStep ()
virtual int | postStep ()
- Public Member Functions inherited from AP_LSystem::LoftTurtle
LoftTurtle (void)
~LoftTurtle (void)
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | finalize ()
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::LoftTurtle
virtual int | drawStep (double dist)
void | createCircleContour ()
virtual int | addContourLoftGeometry ()
virtual int | createLoftGeometryOpening ()
virtual int | insideStep ()
- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Turtle that creates cylinders with hemispheres at the end of cylinders. This creates a geometry that is useful for creating stems or some anorganic structures.

Constructor & Destructor Documentation

JointedPipe::JointedPipe ( void )
JointedPipe::~JointedPipe ( void )

Member Function Documentation

int JointedPipe::initialize ( void )
virtual

Initialize turtle: create a contour and hemisphere template.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

int JointedPipe::postStep ( )
virtual

Create a top contour of cylinder, create cylinder geometry and append hemisphere.

Returns
error code

Reimplemented from AP_LSystem::MovingTurtle.

int JointedPipe::preStep ( )
virtual

Create a bottom contour of cylinder.

Returns
error code

Reimplemented from AP_LSystem::MovingTurtle.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/jointedpipe.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/jointedpipe.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LoftTurtle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LoftTurtle
Public Member Functions | Protected Member Functions | List of all members
AP_LSystem::LoftTurtle Class Reference

#include <loftturtle.h>

Inheritance diagram for AP_LSystem::LoftTurtle:
AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle AP_LSystem::JointedPipe AP_LSystem::StraightPipe AP_LSystem::HermitPipe

Public Member Functions

LoftTurtle (void)
~LoftTurtle (void)
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | initialize ()
virtual int | finalize ()
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Protected Member Functions

virtual int | drawStep (double dist)
void | createCircleContour ()
virtual int | addContourLoftGeometry ()
virtual int | createLoftGeometryOpening ()
virtual int | insideStep ()
- Protected Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | makeRotate (osg::Quat &)
virtual int | preRotate ()
virtual int | postRotate ()
virtual int | doStep (double dist)
virtual int | preStep ()
virtual int | postStep ()
virtual void | drawFrame (osg::Matrixd &, osg::Vec4d *=NULL)
virtual void | adjustMatrices ()

Additional Inherited Members

- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Abstract turtle for loft geometry (typically stems). Provides operations with contour and loft operation with it.

Constructor & Destructor Documentation

LoftTurtle::LoftTurtle ( void )
LoftTurtle::~LoftTurtle ( void )

Member Function Documentation

int LoftTurtle::addContourLoftGeometry ( )
protectedvirtual

Creates a lofted contour.

Returns
error code
void AP_LSystem::LoftTurtle::createCircleContour ( )
inlineprotected

Creates a circle countour of predefined detail. This contour is then used for loft operations.

int LoftTurtle::createLoftGeometryOpening ( )
protectedvirtual

Create an openenig part of lofted geometry.

Returns
error code
virtual int AP_LSystem::LoftTurtle::drawStep ( double dist )
inlineprotectedvirtual

Do a drawing step forward. Call preStep() before step, insideStep() in the middle of the step and postStep() performing the step

Returns
error code

Reimplemented from AP_LSystem::MovingTurtle.

Reimplemented in AP_LSystem::HermitPipe.

virtual int AP_LSystem::LoftTurtle::insideStep ( )
inlineprotectedvirtual

Reimplemented in AP_LSystem::StraightPipe.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/loftturtle.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/loftturtle.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Log Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Log
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::Log Class Reference

#include <log.h>

Public Member Functions

void | write (std::string str)
void | write (int i)
unsigned int | getRewritingCounter () const
unsigned int | getModuleCounter () const
unsigned int | getTurtleCounter () const
unsigned int | getQueryCounter () const
void | incRewritingCounter ()
void | incModuleCounter ()
void | incTurtleCounter ()
void | incQueryCounter ()

Static Public Member Functions

static Log * get ()

Member Function Documentation

static Log* AP_LSystem::Log::get ( )
inlinestatic
unsigned int AP_LSystem::Log::getModuleCounter ( ) const
inline
unsigned int AP_LSystem::Log::getQueryCounter ( ) const
inline
unsigned int AP_LSystem::Log::getRewritingCounter ( ) const
inline
unsigned int AP_LSystem::Log::getTurtleCounter ( ) const
inline
void AP_LSystem::Log::incModuleCounter ( )
inline
void AP_LSystem::Log::incQueryCounter ( )
inline
void AP_LSystem::Log::incRewritingCounter ( )
inline
void AP_LSystem::Log::incTurtleCounter ( )
inline
void AP_LSystem::Log::write ( std::string str )
inline
void AP_LSystem::Log::write ( int i )
inline
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/log.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/log.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LongString Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LongString
Public Member Functions | List of all members
AP_LSystem::LongString Class Reference

#include <longstring.h>

Public Member Functions

LongString (unsigned int length=1048576)
LongString (const LongString &c)
LongString & | operator= (const LongString &c)
~LongString ()
void | convertFromString (std::string *str, unsigned int &=ZERO, const char= '\0')
template<class T >
void | append (T par)
void | append (const char ch)
void | append (const char *data, int length)
void | append (LongString *ls)
template<class T >
bool | getParameters (unsigned int &pos, T *pParams, int &paramsCnt)
char * | getData ()
char * | getData (unsigned int &pos, unsigned int &length, char delimiter)
char * | getSymbol (unsigned int &pos)
int | matchRight (char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL)
int | matchLeft (char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL)
char | peekSymbol (int &pos, bool direction)
int | findMatchingRightBracket (int pos)
int | findMatchingLeftBracket (int pos)
std::string | toString ()
char & | operator[] (unsigned int i) const
unsigned int | length () const

Detailed Description

Class for storing L-system string in fast form optimalized for append operation and for storing values/parameters of different types

Constructor & Destructor Documentation

LongString::LongString ( unsigned int length = 1048576 )

Create a LongString and set a default increment and initial length

Parameters
length initial length and also default increment
LongString::LongString ( const LongString & c )

Copy constructor

LongString::~LongString ( )

Destructor

Member Function Documentation

template<class T >
void AP_LSystem::LongString::append ( T par )
inline

Appends some parameter of any type declared in Parameter::Type. Can be used to append module parameter.

Parameters
par parameter
void LongString::append ( const char ch )

Appends one byte.

Parameters
ch byte to append
void LongString::append | ( | const char * | data,
 |  | int | length
 | ) |  |

Appends buffer with data.

Parameters
data | buffer with data
length | length of buffer
void LongString::append ( LongString * ls )

Appends another LongString

Parameters
ls string to append
void LongString::convertFromString | ( | std::string * | str,
 |  | unsigned int & | pos = ZERO,
 |  | const char | delimiter = '\0'
 | ) |  |

Converts standart string of L-system to internal LongString format. Useful for successors and axioms.

int LongString::findMatchingLeftBracket ( int pos )

Look for matching left bracket

Parameters
pos initial position
Returns
position of matching bracket.
int LongString::findMatchingRightBracket ( int pos )

Look for matching right bracket

Parameters
pos initial position
Returns
position of matching bracket.
char * LongString::getData ( )

Get pointer to string data in LongString in raw form

Returns
all raw data of LongString
char * LongString::getData | ( | unsigned int & | pos,
 |  | unsigned int & | length,
 |  | char | delimiter
 | ) |  |

Get pointer to string data in LongString in raw form

Parameters
pos | position of first byte in the string to be taken into consideration
length | maximum length of taken data
delimiter | optional delimiter
Returns
raw data
template<class T >
bool AP_LSystem::LongString::getParameters | ( | unsigned int & | pos,
 |  | T * | pParams,
 |  | int & | paramsCnt
 | ) |  |
inline

Extracts parameters of same type from some position in string

Parameters
pos | start position of parameters
pParams | array for storing parameters
paramsCnt | number of found parameters
Returns
- false: invalid position
  • true: success
char * LongString::getSymbol ( unsigned int & pos )

Returns data whole symbol/module with it's parameters

Parameters
pos Position of module. Will be changet to position after module
Returns
module in raw data form
unsigned int AP_LSystem::LongString::length ( ) const
inline

Length of longstring

Returns
length
int LongString::matchLeft | ( | char | ch,
 |  | int | pos,
 |  | const std::string * | ignore = NULL,
 |  | const std::string * | consider = NULL
 | ) |  |

Matches left context

Todo:
Implement consider
Parameters
ch | left context
pos | initial position - might be right behind identifier character
ignore | string of characters that should be ignored during matching algorithm
consider | string of characters that shoul be considered during matching algorithm
Returns
position of matching context or -1 if not found
int LongString::matchRight | ( | char | ch,
 |  | int | pos,
 |  | const std::string * | ignore = NULL,
 |  | const std::string * | consider = NULL
 | ) |  |

Match right context

Todo:
Implement consider
Parameters
ch | right context
pos | initial position - might be right behind identifier character
ignore | string of characters that should be ignored during matching algorithm
consider | string of characters that shoul be considered during matching algorithm
Returns
position of matching context or -1 if not found
LongString & LongString::operator= ( const LongString & c )

Assignment operator

char& AP_LSystem::LongString::operator[] ( unsigned int i ) const
inline

Access to any byte of string

char LongString::peekSymbol | ( | int & | pos,
 |  | bool | direction
 | ) |  |

Peek neighbouring symbol's identifier.

Parameters
pos | initial position
direction | true for searching to the right; false for searching to the left
Returns
module's/symbol's identifier
std::string LongString::toString ( )

Debug method for converting LongString from internal raw format to standart string. Becareful - very slow !

Returns
string in standart L-system format
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/longstring.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/longstring.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSFile
Public Member Functions | List of all members
AP_LSystem::LSFile Class Reference

#include <lsfile.h>

Inheritance diagram for AP_LSystem::LSFile:
AP_LSystem::AbstractFile

Public Member Functions

LSFile ()
virtual void | open (string &filename)
- Public Member Functions inherited from AP_LSystem::AbstractFile
AbstractFile ()
virtual void | open (std::string &filename)=0
void | substitute (std::map< string, string > &pairs)
virtual std::vector< string > * | getHomomorphisms ()
virtual std::vector< string > * | getRules ()
virtual std::vector< string > * | getSubsystems ()
std::string & | getAxiom ()
unsigned int | type ()
std::string & | name ()

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::AbstractFile
void | addType (std::string &type)
- Protected Attributes inherited from AP_LSystem::AbstractFile
unsigned int | m_Type
type of loaded L-system More...
string | m_Name
name of loaded L-system More...
string | m_Axiom
loaded axiom More...
std::vector< string > | m_Rules
container with loaded rules strings More...
std::vector< string > | m_Homomorphisms
container with loaded homomorphism rules More...
std::vector< string > | m_Subsytems
container with subsystem's filenames More...

Detailed Description

Class for loading file in *.ls format

Constructor & Destructor Documentation

LSFile::LSFile ( )

Member Function Documentation

void LSFile::open ( string & filename )
virtual

Open *.ls file and parse. All values are either set as COnfiguration properties or stored to AbstractFile containers and variables.

Parameters
filename name of file to open
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsfile.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsfile.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::TurtleProperties Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleProperties
Public Types | Public Member Functions | Public Attributes | List of all members
AP_LSystem::TurtleProperties Struct Reference

#include <lsgeode.h>

Public Types

enum Flags {
DRAW_DEBUG_GEOMETRY = 0x00000001, MINIMIZE_TWIST = 0x00000002, DEGREES_TO_RADIANS = 0x00000004, SEPARATE_GEOMETRY_FOR_TRANSLUCENT = 0x00000008,
USE_QUERIES = 0x00000010, DRAW_PIPE_CAPS = 0x00000100
}

Public Member Functions

TurtleProperties ()
void clean ()

Public Attributes

osg::ref_ptr< osg::Geometry > | geometry
pointer for quick access to geode's geometry More...
osg::Matrixd | matrix
matrix of turtle position and orientation More...
osg::Matrixd | lastMatrix
matrix of previous turtle position and orientation More...
osg::Matrixd | lastFrame
matrix for storing not twisted frame for contour drawing More...
double | length
default length of one step More...
double | lengthMultiplier
default length multiplier More...
double | angle
default angle of rotation More...
double | angleMultiplier
default angle multiplier More...
unsigned int | angleVariance
variance of angle - in percents More...
double | radius
default radius of each segment More...
double | radiusMultiplier
default radius multiplier More...
double | texCoordT
current texture coordinate in T direction More...
unsigned int | texRepeatingS
number of repeatings of texture arround contour - S direction More...
unsigned int | curveDetail
detail of generalized pipe curves More...
osg::Vec3 | controlPoint
coordinates of center point of each move. Used for curve generating and for texturing. More...
unsigned int | flags
double | elasticityMultiplier
default multiplier of gravitropism elasticity and diatropism elasticity More...
double | gravitropismElasticity
response of stems to gravity More...
double | tropismElasticity
response to general tropism More...
double | tropismAngle
angle of general tropism More...
osg::Vec3d | tropismVector
direction of general tropism More...
std::string * | modelFile
filename of model file - only for turtles that load models More...
osg::ref_ptr< osg::Vec3dArray > | contour
contour vertices More...
osg::ref_ptr< osg::Vec3dArray > | contourLastV
used for loft turtles - predecessing contour vertices More...
osg::ref_ptr< osg::Vec3dArray > | contourLastN
used for loft turtles - predecessing contour normals More...
unsigned int | contourDetail
detail of circle contour More...
vector< osg::ref_ptr
< osg::Vec3dArray > > 		hemisphere
hemisphere template geometry More...
double | debugGeometryScale
scale of debug geometry More...

Detailed Description

Struct for storing properties of turtles

Member Enumeration Documentation

enum AP_LSystem::TurtleProperties::Flags

Boolean properties of turtle

Enumerator
DRAW_DEBUG_GEOMETRY | indicates if debug geometry will be displayed
MINIMIZE_TWIST | turns on the twist minimalization
DEGREES_TO_RADIANS | converts all angles to radians
SEPARATE_GEOMETRY_FOR_TRANSLUCENT | for each translucent geometry will be created one geometry. It removes Halo efect but it is power consuming.
USE_QUERIES | turns on the query processing
DRAW_PIPE_CAPS | draw caps at the end of cylinders ?

Constructor & Destructor Documentation

AP_LSystem::TurtleProperties::TurtleProperties ( )
inline

Member Function Documentation

void AP_LSystem::TurtleProperties::clean ( void )
inline

Destructor of all objects in properties structure. This function is called in AbstractTurtle destructor.

Member Data Documentation

double AP_LSystem::TurtleProperties::angle

default angle of rotation

double AP_LSystem::TurtleProperties::angleMultiplier

default angle multiplier

unsigned int AP_LSystem::TurtleProperties::angleVariance

variance of angle - in percents

osg::ref_ptr<osg::Vec3dArray> AP_LSystem::TurtleProperties::contour

contour vertices

unsigned int AP_LSystem::TurtleProperties::contourDetail

detail of circle contour

osg::ref_ptr<osg::Vec3dArray> AP_LSystem::TurtleProperties::contourLastN

used for loft turtles - predecessing contour normals

osg::ref_ptr<osg::Vec3dArray> AP_LSystem::TurtleProperties::contourLastV

used for loft turtles - predecessing contour vertices

osg::Vec3 AP_LSystem::TurtleProperties::controlPoint

coordinates of center point of each move. Used for curve generating and for texturing.

unsigned int AP_LSystem::TurtleProperties::curveDetail

detail of generalized pipe curves

double AP_LSystem::TurtleProperties::debugGeometryScale

scale of debug geometry

double AP_LSystem::TurtleProperties::elasticityMultiplier

default multiplier of gravitropism elasticity and diatropism elasticity

unsigned int AP_LSystem::TurtleProperties::flags
osg::ref_ptr<osg::Geometry> AP_LSystem::TurtleProperties::geometry

pointer for quick access to geode's geometry

double AP_LSystem::TurtleProperties::gravitropismElasticity

response of stems to gravity

vector<osg::ref_ptr<osg::Vec3dArray> > AP_LSystem::TurtleProperties::hemisphere

hemisphere template geometry

osg::Matrixd AP_LSystem::TurtleProperties::lastFrame

matrix for storing not twisted frame for contour drawing

osg::Matrixd AP_LSystem::TurtleProperties::lastMatrix

matrix of previous turtle position and orientation

double AP_LSystem::TurtleProperties::length

default length of one step

double AP_LSystem::TurtleProperties::lengthMultiplier

default length multiplier

osg::Matrixd AP_LSystem::TurtleProperties::matrix

matrix of turtle position and orientation

std::string* AP_LSystem::TurtleProperties::modelFile

filename of model file - only for turtles that load models

double AP_LSystem::TurtleProperties::radius

default radius of each segment

double AP_LSystem::TurtleProperties::radiusMultiplier

default radius multiplier

double AP_LSystem::TurtleProperties::texCoordT

current texture coordinate in T direction

unsigned int AP_LSystem::TurtleProperties::texRepeatingS

number of repeatings of texture arround contour - S direction

double AP_LSystem::TurtleProperties::tropismAngle

angle of general tropism

double AP_LSystem::TurtleProperties::tropismElasticity

response to general tropism

osg::Vec3d AP_LSystem::TurtleProperties::tropismVector

direction of general tropism

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsgeode.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSGeode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSGeode
Public Member Functions | List of all members
AP_LSystem::LSGeode Class Reference

#include <lsgeode.h>

Inheritance diagram for AP_LSystem::LSGeode:

Public Member Functions

void | setTurtleType (const std::string &type)
void | setTurtleType (TurtleType type)
TurtleType getTurtleType ()
void | setDefaultTurtleProperties (TurtleProperties &p)
void | setDefaultTurtleProperties (int index)
TurtleProperties & getDefaultTurtleProperties ()
LSGeode (unsigned int index)

Detailed Description

OSG geometric node with added

  • capability to configure node properties from Configuration
  • storing of turtle type that will be used to generate geometry

Constructor & Destructor Documentation

LSGeode::LSGeode ( unsigned int index )

LSGeode can be created only by this constructor. It uses unique L-system ID to configure this LSGeode as geode for storing geometry of this L-system.

Parameters
index L-system ID

Member Function Documentation

TurtleProperties & LSGeode::getDefaultTurtleProperties ( )

Get default properties

Returns
default properties
TurtleType LSGeode::getTurtleType ( )

Get turtle type.

Returns
assigned turtle type
void LSGeode::setDefaultTurtleProperties ( TurtleProperties & p )

Set the default properties by copying another properties

Parameters
p This properties are copied
void LSGeode::setDefaultTurtleProperties ( int index )

Set the default properties by gathering info about L-system from Configuration.

Parameters
index unique L-system ID
void LSGeode::setTurtleType ( const std::string & type )

Set turtle type.

Parameters
type string is converted to turtle type and assigned to this LSGeode instance
void LSGeode::setTurtleType ( TurtleType type )

Set turtle type.

Parameters
type this type is assigned to this LSGeode instance
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsgeode.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsgeode.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSObject
Public Member Functions | List of all members
AP_LSystem::LSObject Class Reference

#include <lsobject.h>

Inheritance diagram for AP_LSystem::LSObject:
vrecko::Ability vrecko::BaseClass

Public Member Functions

LSObject ()
virtual | ~LSObject ()
virtual void | preInitialize ()
virtual void | postInitialize ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Main class of L-system object

Constructor & Destructor Documentation

AP_LSystem::LSObject::LSObject ( )

constructor

AP_LSystem::LSObject::~LSObject ( )
virtual

destructor

Member Function Documentation

bool AP_LSystem::LSObject::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

void AP_LSystem::LSObject::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void AP_LSystem::LSObject::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsobject.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsobject.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystem
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
AP_LSystem::LSystem Class Referenceabstract

#include <lsystem.h>

Inheritance diagram for AP_LSystem::LSystem:
AP_LSystem::AbstractLSystem AP_LSystem::Abstract0LSystem AP_LSystem::AbstractkLSystem AP_LSystem::D0LSystem AP_LSystem::ParD0LSystem AP_LSystem::ParStoch0LSystem AP_LSystem::Par2LSystem

Public Member Functions

LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
virtual boost::shared_ptr
< AbstractLSystem > 		clone () const =0
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Protected Member Functions

virtual void | setAxiom (std::string &)
virtual void | addRule (std::string *)
virtual void | addHomomorphism (std::string *)
virtual void | processPredecessor (Rule &, string *, string::iterator &)=0
virtual void | processRuleSuccessor (Rule &, string *, string::iterator &)=0
virtual void | processHomomorphismSuccessor (Rule &, string *, string::iterator &)=0
virtual bool | nextIteration ()
virtual bool | transcribe (multimap< char, Rule > &rules)
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters)
virtual void | generateSuccessor (LongString *word, multimap< char, Rule >::iterator &rule, double *params)

Protected Attributes

LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore
- Protected Attributes inherited from AP_LSystem::AbstractLSystem
std::string | m_Name
name of L-system More...
unsigned int | m_Iteration
number of processed iterations More...

Constructor & Destructor Documentation

LSystem::LSystem ( AbstractFile * file )

Constructor

LSystem::LSystem ( const LSystem & c )

Copy constructor

LSystem::~LSystem ( )

Destructor

Member Function Documentation

void LSystem::addHomomorphism ( std::string * )
protectedvirtual

Add homomorphism and convert it to instance of Rule class

Implements AP_LSystem::AbstractLSystem.

void LSystem::addRule ( std::string * )
protectedvirtual

Add rule and convert it to instance of Rule class

Implements AP_LSystem::AbstractLSystem.

void LSystem::generateSuccessor | ( | LongString * | word,
 |  | multimap< char, Rule >::iterator & | rule,
 |  | double * | params
 | ) |  |
protectedvirtual

Generates a successor of module by recurrent appending of rule's static strings and evaluated expressions.

Parameters
word | strings will bee appended to this word
rule | selected rule
params | parameter values for expressions evaluation
void LSystem::loadFromFile ( AbstractFile * file )
virtual

Load L-system from file

Parameters
file of L-system as instance of

Implements AP_LSystem::AbstractLSystem.

bool LSystem::nextIteration ( )
protectedvirtual

Transcription process with rules

Returns
true if succeeded

Implements AP_LSystem::AbstractLSystem.

LSystem & LSystem::operator= ( const LSystem & c )

Assignment operator

void LSystem::processCutSymbol ( )
virtual
virtual void AP_LSystem::LSystem::processHomomorphismSuccessor | ( | Rule & | ,
 |  | string * | ,
 |  | string::iterator & |
 | ) |  |
protectedpure virtual

Implemented in AP_LSystem::Abstract0LSystem, AP_LSystem::Par2LSystem, and AP_LSystem::D0LSystem.

virtual void AP_LSystem::LSystem::processPredecessor | ( | Rule & | ,
 |  | string * | ,
 |  | string::iterator & |
 | ) |  |
protectedpure virtual

Implemented in AP_LSystem::Abstract0LSystem, AP_LSystem::Par2LSystem, and AP_LSystem::D0LSystem.

virtual void AP_LSystem::LSystem::processRuleSuccessor | ( | Rule & | ,
 |  | string * | ,
 |  | string::iterator & |
 | ) |  |
protectedpure virtual

Implemented in AP_LSystem::Abstract0LSystem, AP_LSystem::Par2LSystem, and AP_LSystem::D0LSystem.

multimap< char, Rule >::iterator * LSystem::selectRule | ( | multimap< char, Rule >::iterator & | begin,
 |  | multimap< char, Rule >::iterator & | end,
 |  | LongString * | word,
 |  | unsigned int & | pos,
 |  | double * | parameters
 | ) |  |
protectedvirtual

This method is called during each transcription. It selects one or no rule from union of rules that have common predecessor. The selection procedure depends on type of L-system.

Parameters
begin | iterator to range of rules
end | iterator to range of rules
word | word that is currently processed
pos | position of current predecessor in word
parameters | array of parameters for transcription. Only double type.
Returns
pointer to iterator to rule that was selected. Returns NULL if no rule was selected.

Reimplemented in AP_LSystem::ParStoch0LSystem, and AP_LSystem::Par2LSystem.

void LSystem::setAxiom ( std::string & )
protectedvirtual

Set axiom. Inicialize word.

Implements AP_LSystem::AbstractLSystem.

bool LSystem::transcribe ( multimap< char, Rule > & rules )
protectedvirtual

This method provides a transcription funkcionality. It substitutes all modules in word by their successors.

Parameters
rules container with rules
Returns
true if succeeded

Reimplemented in AP_LSystem::D0LSystem.

void LSystem::transcribeSubSystems ( )
virtual
LongString * LSystem::translate ( )
virtual

Translate a word to final form and get it.

Returns
word as LongString

Implements AP_LSystem::AbstractLSystem.

unsigned int AP_LSystem::LSystem::wordLength ( )
inline

Member Data Documentation

multimap<char, Rule> AP_LSystem::LSystem::m_Homomorphisms
protected
string AP_LSystem::LSystem::m_Ignore
protected
multimap<char, Rule> AP_LSystem::LSystem::m_Rules
protected
vector<string> AP_LSystem::LSystem::m_SubSystemsFilenames
protected
vector< LongString *> AP_LSystem::LSystem::m_SubSystemsWords
protected
LongString* AP_LSystem::LSystem::m_Word
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSystemException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystemException
Public Member Functions | Public Attributes | List of all members
AP_LSystem::LSystemException Class Reference

#include <lsystemexception.h>

Inheritance diagram for AP_LSystem::LSystemException:
AP_LSystem::ConfigurationException AP_LSystem::FileException AP_LSystem::ParsingException

Public Member Functions

LSystemException ()
LSystemException (const char *description)
~LSystemException () throw ()
virtual const char * | what () const throw ()
virtual void | appendType ()

Public Attributes

std::string | type
std::string | message

Detailed Description

L-system exception class

Constructor & Destructor Documentation

AP_LSystem::LSystemException::LSystemException ( )
inline
AP_LSystem::LSystemException::LSystemException ( const char * description )
inline
AP_LSystem::LSystemException::~LSystemException ( ) throw ()
inline

Member Function Documentation

virtual void AP_LSystem::LSystemException::appendType ( )
inlinevirtual

Reimplemented in AP_LSystem::ConfigurationException, AP_LSystem::FileException, and AP_LSystem::ParsingException.

virtual const char* AP_LSystem::LSystemException::what ( ) const throw ()
inlinevirtual

Member Data Documentation

std::string AP_LSystem::LSystemException::message
std::string AP_LSystem::LSystemException::type
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::ParsingException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParsingException
Public Member Functions | List of all members
AP_LSystem::ParsingException Class Reference

#include <lsystemexception.h>

Inheritance diagram for AP_LSystem::ParsingException:
AP_LSystem::LSystemException

Public Member Functions

ParsingException ()
ParsingException (const char *description)
ParsingException (std::string description)
virtual void | appendType ()
- Public Member Functions inherited from AP_LSystem::LSystemException
LSystemException ()
LSystemException (const char *description)
~LSystemException () throw ()
virtual const char * | what () const throw ()

Additional Inherited Members

- Public Attributes inherited from AP_LSystem::LSystemException
std::string | type
std::string | message

Detailed Description

Exception during parsing L-system rules

Constructor & Destructor Documentation

AP_LSystem::ParsingException::ParsingException ( )
inline
AP_LSystem::ParsingException::ParsingException ( const char * description )
inline
AP_LSystem::ParsingException::ParsingException ( std::string description )
inline

Member Function Documentation

virtual void AP_LSystem::ParsingException::appendType ( )
inlinevirtual

Reimplemented from AP_LSystem::LSystemException.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::FileException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • FileException
Public Member Functions | List of all members
AP_LSystem::FileException Class Reference

#include <lsystemexception.h>

Inheritance diagram for AP_LSystem::FileException:
AP_LSystem::LSystemException

Public Member Functions

FileException ()
FileException (const char *description)
FileException (std::string description)
virtual void | appendType ()
- Public Member Functions inherited from AP_LSystem::LSystemException
LSystemException ()
LSystemException (const char *description)
~LSystemException () throw ()
virtual const char * | what () const throw ()

Additional Inherited Members

- Public Attributes inherited from AP_LSystem::LSystemException
std::string | type
std::string | message

Detailed Description

File error exception

Constructor & Destructor Documentation

AP_LSystem::FileException::FileException ( )
inline
AP_LSystem::FileException::FileException ( const char * description )
inline
AP_LSystem::FileException::FileException ( std::string description )
inline

Member Function Documentation

virtual void AP_LSystem::FileException::appendType ( )
inlinevirtual

Reimplemented from AP_LSystem::LSystemException.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::ConfigurationException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ConfigurationException
Public Member Functions | List of all members
AP_LSystem::ConfigurationException Class Reference

#include <lsystemexception.h>

Inheritance diagram for AP_LSystem::ConfigurationException:
AP_LSystem::LSystemException

Public Member Functions

ConfigurationException ()
ConfigurationException (const char *description)
ConfigurationException (std::string description)
virtual void | appendType ()
- Public Member Functions inherited from AP_LSystem::LSystemException
LSystemException ()
LSystemException (const char *description)
~LSystemException () throw ()
virtual const char * | what () const throw ()

Additional Inherited Members

- Public Attributes inherited from AP_LSystem::LSystemException
std::string | type
std::string | message

Detailed Description

Exception thrown in case of error in Configuration class.

Constructor & Destructor Documentation

AP_LSystem::ConfigurationException::ConfigurationException ( )
inline
AP_LSystem::ConfigurationException::ConfigurationException ( const char * description )
inline
AP_LSystem::ConfigurationException::ConfigurationException ( std::string description )
inline

Member Function Documentation

virtual void AP_LSystem::ConfigurationException::appendType ( )
inlinevirtual

Reimplemented from AP_LSystem::LSystemException.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::LSystemGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystemGenerator
Public Member Functions | List of all members
AP_LSystem::LSystemGenerator Class Reference

#include <lsystemgenerator.h>

Inheritance diagram for AP_LSystem::LSystemGenerator:
AP_LSystem::AbstractGenerator

Public Member Functions

LSystemGenerator (void)
~LSystemGenerator (void)
virtual void | loadFile (std::string &filename)
virtual void | nextIteration ()
virtual ParseableString * | getWord ()
- Public Member Functions inherited from AP_LSystem::AbstractGenerator
AbstractGenerator (void)
AbstractGenerator (const AbstractGenerator &c)
AbstractGenerator & | operator= (const AbstractGenerator &c)
~AbstractGenerator (void)
virtual void | saveWordToFile (std::string &)
virtual void | loadWordFromFile (std::string &)

Additional Inherited Members

- Static Public Member Functions inherited from AP_LSystem::AbstractGenerator
static boost::shared_ptr
< AbstractLSystem > 		createLSystem (AbstractFile *file)
- Protected Attributes inherited from AP_LSystem::AbstractGenerator
ParseableString * m_Word
word generated by generator More...
boost::shared_ptr
< AbstractLSystem > 		m_MainLSystem
L-system that is used for generating. More...

Detailed Description

This is a default generator for L-system generating.

Constructor & Destructor Documentation

LSystemGenerator::LSystemGenerator ( void )

Non-parametric constructor

LSystemGenerator::~LSystemGenerator ( void )

Destructor

Member Function Documentation

ParseableString * LSystemGenerator::getWord ( )
virtual

Get a final word.

Returns
word, ready for an interpretation.

Implements AP_LSystem::AbstractGenerator.

void LSystemGenerator::loadFile ( std::string & filename )
virtual

Loads an L-system. File is specified by it's filename.

Parameters
filename filename of file in one of supported L-system formats

Implements AP_LSystem::AbstractGenerator.

void LSystemGenerator::nextIteration ( )
virtual

Process next interation on the main L-system

Implements AP_LSystem::AbstractGenerator.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemgenerator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsystemgenerator.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::MovingTurtle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • MovingTurtle
Public Member Functions | Protected Member Functions | List of all members
AP_LSystem::MovingTurtle Class Reference

#include <movingturtle.h>

Inheritance diagram for AP_LSystem::MovingTurtle:
AP_LSystem::AbstractTurtle AP_LSystem::LoftTurtle AP_LSystem::QueryTurtle AP_LSystem::Rectangle AP_LSystem::JointedPipe AP_LSystem::StraightPipe AP_LSystem::HermitPipe

Public Member Functions

virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | initialize ()
virtual int | finalize ()
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Protected Member Functions

virtual int | makeRotate (osg::Quat &)
virtual int | preRotate ()
virtual int | postRotate ()
virtual int | doStep (double dist)
virtual int | drawStep (double)
virtual int | preStep ()
virtual int | postStep ()
virtual void | drawFrame (osg::Matrixd &, osg::Vec4d *=NULL)
virtual void | adjustMatrices ()

Additional Inherited Members

- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Member Function Documentation

void MovingTurtle::adjustMatrices ( )
protectedvirtual

Adjust position matrix after each step. This method applies effects like tropism and minimizing twist. It makes some corrections of position matrix depending on L-system parameters.

int MovingTurtle::doStep ( double dist )
protectedvirtual

Do a non-drawing forward move of predefined length.

Parameters
dist length of step
Returns
error code
int MovingTurtle::drawForward ( std::vector< Parameter > & p )
virtual

Move forward and generate a geometry

Parameters
p vector with parameters
  • 0 parameters: use a default distance/length for a movement
  • 1 parameter: use this parameter as distance for a movement. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::drawForwardHalf ( )
virtual

Move forward and generate a geometry. Use half of default length value for movement.

Returns
error code

Implements AP_LSystem::AbstractTurtle.

void MovingTurtle::drawFrame | ( | osg::Matrixd & | matrix,
 |  | osg::Vec4d * | color = NULL
 | ) |  |
protectedvirtual

For debugging. Draw a turtle frame.

Parameters
matrix | position matrix of turtle
color | color of all vectors. Default is red for heading, green for up and blue for left vector.

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::drawStep ( double dist )
protectedvirtual

Do a drawing forward move of predefined length.

Parameters
dist length of step
Returns
error code

Reimplemented in AP_LSystem::Rectangle, AP_LSystem::LoftTurtle, and AP_LSystem::HermitPipe.

int MovingTurtle::makeRotate ( osg::Quat & q )
protectedvirtual
int MovingTurtle::moveForward ( std::vector< Parameter > & p )
virtual

Move forward and without generating a geometry

Parameters
p vector with parameters
  • 0 parameters: use a default distance/length for a movement
  • 1 parameter: use this parameter as distance for a movement. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::moveForwardHalf ( )
virtual

Move forward without generating a geometry. Use half of default length value for movement.

Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::multiplyAngle ( std::vector< Parameter > & p )
virtual

Multiply a default angle.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::multiplyGravitropismElasticity ( std::vector< Parameter > & p )
virtual

Multiply a gravitropism/geotropism elasticity.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::multiplyLength ( std::vector< Parameter > & p )
virtual

Multiply a default lenght.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::multiplyRadius ( std::vector< Parameter > & p )
virtual

Multiply a default radius/thickness.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::multiplyTropismElasticity ( std::vector< Parameter > & p )
virtual

Multiply a diatropism elasticity.

Parameters
p vector with parameters
  • 0 parameters: multiply by default value
  • 1 parameter: use this parameter as multiplier. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::pitchDown ( std::vector< Parameter > & p )
virtual

Make a rotation around vector L down.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::pitchUp ( std::vector< Parameter > & p )
virtual

Make a rotation around vector L up.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

virtual int AP_LSystem::MovingTurtle::postRotate ( )
inlineprotectedvirtual
virtual int AP_LSystem::MovingTurtle::postStep ( )
inlineprotectedvirtual

This method is called after each step.

Returns
error code

Reimplemented in AP_LSystem::JointedPipe.

virtual int AP_LSystem::MovingTurtle::preRotate ( )
inlineprotectedvirtual
virtual int AP_LSystem::MovingTurtle::preStep ( )
inlineprotectedvirtual

This method is called before each step.

Returns
error code

Reimplemented in AP_LSystem::JointedPipe, and AP_LSystem::StraightPipe.

int MovingTurtle::randomTurnPitchRoll ( std::vector< Parameter > & p )
virtual

Make a random rotation.

Todo:
Not implemented
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::rollArround ( )
virtual

Make a 180° rotation around vector U.

Todo:
Not implemented
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::rollLeft ( std::vector< Parameter > & p )
virtual

Make a rotation around vector H to the left.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::rollRight ( std::vector< Parameter > & p )
virtual

Make a rotation around vector H to the right.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::rollUntilHorizontal ( )
virtual

Make a rotation around vector H until left vector is in horizontal position.

Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::turnArround ( )
virtual

Make a 180° rotation around vector U.

Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::turnLeft ( std::vector< Parameter > & p )
virtual

Make a rotation around vector U to the left.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

int MovingTurtle::turnRight ( std::vector< Parameter > & p )
virtual

Make a rotation around vector U to the right.

Parameters
p vector with parameters
  • 0 parameters: use default angle
  • 1 parameter: use this parameter as angle. Type is double.
Returns
error code

Implements AP_LSystem::AbstractTurtle.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/movingturtle.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/movingturtle.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Par2LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Par2LSystem
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::Par2LSystem Class Reference

#include <par2lsystem.h>

Inheritance diagram for AP_LSystem::Par2LSystem:
AP_LSystem::AbstractkLSystem AP_LSystem::LSystem AP_LSystem::AbstractLSystem

Public Member Functions

Par2LSystem (AbstractFile *)
virtual void | processPredecessor (Rule &, string *, string::iterator &)
virtual void | processRuleSuccessor (Rule &, string *, string::iterator &)
virtual void | processHomomorphismSuccessor (Rule &, string *, string::iterator &)
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &, multimap< char, Rule >::iterator &, LongString *, unsigned int &, double *)
boost::shared_ptr
< AbstractLSystem > 		clone () const
- Public Member Functions inherited from AP_LSystem::AbstractkLSystem
AbstractkLSystem (AbstractFile *)
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Static Public Member Functions

static bool isCapable (unsigned int type)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::LSystem
virtual void | setAxiom (std::string &)
virtual void | addRule (std::string *)
virtual void | addHomomorphism (std::string *)
virtual bool | nextIteration ()
virtual bool | transcribe (multimap< char, Rule > &rules)
virtual void | generateSuccessor (LongString *word, multimap< char, Rule >::iterator &rule, double *params)
- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Detailed Description

Class for processing parametric stochastic 2L-systems

Constructor & Destructor Documentation

Par2LSystem::Par2LSystem ( AbstractFile * file )

Member Function Documentation

boost::shared_ptr<AbstractLSystem> AP_LSystem::Par2LSystem::clone ( ) const
inlinevirtual

Virtual copy constructor

Implements AP_LSystem::AbstractLSystem.

static bool AP_LSystem::Par2LSystem::isCapable ( unsigned int type )
inlinestatic
void Par2LSystem::processHomomorphismSuccessor | ( | Rule & | r,
 |  | string * | hom,
 |  | string::iterator & | it
 | ) |  |
virtual

Implements AP_LSystem::LSystem.

void Par2LSystem::processPredecessor | ( | Rule & | r,
 |  | string * | rule,
 |  | string::iterator & | it
 | ) |  |
virtual

Implements AP_LSystem::LSystem.

void Par2LSystem::processRuleSuccessor | ( | Rule & | r,
 |  | string * | rule,
 |  | string::iterator & | it
 | ) |  |
virtual

Implements AP_LSystem::LSystem.

multimap< char, Rule >::iterator * Par2LSystem::selectRule | ( | multimap< char, Rule >::iterator & | begin,
 |  | multimap< char, Rule >::iterator & | end,
 |  | LongString * | word,
 |  | unsigned int & | pos,
 |  | double * | parameters
 | ) |  |
virtual

This method is called during each transcription. It selects one or no rule from union of rules that have common predecessor. The selection procedure depends on type of L-system.

Parameters
begin | iterator to range of rules
end | iterator to range of rules
word | word that is currently processed
pos | position of current predecessor in word
parameters | array of parameters for transcription. Only double type.
Returns
pointer to iterator to rule that was selected. Returns NULL if no rule was selected.

Reimplemented from AP_LSystem::LSystem.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/par2lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/par2lsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::ParD0LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParD0LSystem
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::ParD0LSystem Class Reference

#include <pard0lsystem.h>

Inheritance diagram for AP_LSystem::ParD0LSystem:
AP_LSystem::Abstract0LSystem AP_LSystem::LSystem AP_LSystem::AbstractLSystem

Public Member Functions

ParD0LSystem (AbstractFile *)
- Public Member Functions inherited from AP_LSystem::Abstract0LSystem
Abstract0LSystem (AbstractFile *)
Abstract0LSystem (const Abstract0LSystem &)
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
virtual boost::shared_ptr
< AbstractLSystem > 		clone () const =0
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Static Public Member Functions

static bool isCapable (unsigned int type)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::Abstract0LSystem
virtual void | processPredecessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processRuleSuccessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processHomomorphismSuccessor (Rule &rule, string *str, string::iterator &pos)
- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Constructor & Destructor Documentation

ParD0LSystem::ParD0LSystem ( AbstractFile * file )

Member Function Documentation

static bool AP_LSystem::ParD0LSystem::isCapable ( unsigned int type )
inlinestatic
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/pard0lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/pard0lsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::ParseableString Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParseableString
Public Member Functions | Protected Attributes | Friends | List of all members
AP_LSystem::ParseableString Class Reference

#include <parseablestring.h>

Public Member Functions

ParseableString (LongString *string)
ParseableString (char *string, unsigned int length)
ParseableString (const ParseableString &)
ParseableString & | operator= (const ParseableString &)
bool | eof ()
void | reset ()
char | next (std::vector< Parameter > &parameters)

Protected Attributes

char * | m_Str
unsigned | m_Length

Friends

std::basic_ostream< char > & operator<< (std::basic_ostream< char > &os, const ParseableString ps)

Constructor & Destructor Documentation

ParseableString::ParseableString ( LongString * string )

This constructor creates an instance by converting from LongString

Parameters
string string for conversion
ParseableString::ParseableString | ( | char * | string,
 |  | unsigned int | length
 | ) |  |

This constructor creates an instance from a byte buffer

Parameters
string | buffer with string data
length | length of buffer
ParseableString::ParseableString ( const ParseableString & c )

Copy contructor

Member Function Documentation

bool AP_LSystem::ParseableString::eof ( )
inline

Indicates end of string

Returns
true if end of string
char ParseableString::next ( std::vector< Parameter > & parameters )

Move interator forward and return next module

Parameters
parameters vector for storing module parameter
Returns
identifier of module
ParseableString& AP_LSystem::ParseableString::operator= ( const ParseableString & )

Assignement operator

void AP_LSystem::ParseableString::reset ( )
inline

Reset position of iterator to begin of string

Friends And Related Function Documentation

std::basic_ostream<char>& operator<< | ( | std::basic_ostream< char > & | os,
 |  | const ParseableString | ps
 | ) |  |
friend

Output operator

Member Data Documentation

unsigned AP_LSystem::ParseableString::m_Length
protected
char* AP_LSystem::ParseableString::m_Str
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parseablestring.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/parseablestring.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::ParStoch0LSystem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParStoch0LSystem
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::ParStoch0LSystem Class Reference

#include <parstoch0lsystem.h>

Inheritance diagram for AP_LSystem::ParStoch0LSystem:
AP_LSystem::Abstract0LSystem AP_LSystem::LSystem AP_LSystem::AbstractLSystem

Public Member Functions

ParStoch0LSystem (AbstractFile *)
ParStoch0LSystem (const ParStoch0LSystem &)
ParStoch0LSystem & | operator= (const ParStoch0LSystem &)
virtual multimap< char, Rule >
::iterator * 		selectRule (multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters)
boost::shared_ptr
< AbstractLSystem > 		clone () const
- Public Member Functions inherited from AP_LSystem::Abstract0LSystem
Abstract0LSystem (AbstractFile *)
Abstract0LSystem (const Abstract0LSystem &)
- Public Member Functions inherited from AP_LSystem::LSystem
LSystem (AbstractFile *)
LSystem (const LSystem &)
~LSystem ()
LSystem & | operator= (const LSystem &)
virtual void | loadFromFile (AbstractFile *file)
unsigned int | wordLength ()
virtual void | transcribeSubSystems ()
virtual LongString * | translate ()
virtual void | processCutSymbol ()
- Public Member Functions inherited from AP_LSystem::AbstractLSystem
AbstractLSystem ()
AbstractLSystem (const AbstractLSystem &c)
AbstractLSystem & | operator= (const AbstractLSystem &c)
unsigned int | getIteration () const

Static Public Member Functions

static bool isCapable (unsigned int type)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::Abstract0LSystem
virtual void | processPredecessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processRuleSuccessor (Rule &rule, string *str, string::iterator &pos)
virtual void | processHomomorphismSuccessor (Rule &rule, string *str, string::iterator &pos)
- Protected Attributes inherited from AP_LSystem::LSystem
LongString * m_Word
multimap< char, Rule > | m_Rules
multimap< char, Rule > | m_Homomorphisms
vector< string > | m_SubSystemsFilenames
vector< LongString * > | m_SubSystemsWords
string | m_Ignore

Detailed Description

Parametric stochastic context-free L-system

Constructor & Destructor Documentation

ParStoch0LSystem::ParStoch0LSystem ( AbstractFile * file )
ParStoch0LSystem::ParStoch0LSystem ( const ParStoch0LSystem & c )

Member Function Documentation

boost::shared_ptr<AbstractLSystem> AP_LSystem::ParStoch0LSystem::clone ( ) const
inlinevirtual

Virtual copy constructor

Implements AP_LSystem::AbstractLSystem.

static bool AP_LSystem::ParStoch0LSystem::isCapable ( unsigned int type )
inlinestatic

Decides if L-system of passed type can by processed by parametric stochastic context-free L-system

Parameters
type type of L-system that will be compared with ParStoch0LSytem capabilities
Returns
true if it is capable to process this type
ParStoch0LSystem & ParStoch0LSystem::operator= ( const ParStoch0LSystem & c )
multimap< char, Rule >::iterator * ParStoch0LSystem::selectRule | ( | multimap< char, Rule >::iterator & | begin,
 |  | multimap< char, Rule >::iterator & | end,
 |  | LongString * | word,
 |  | unsigned int & | pos,
 |  | double * | parameters
 | ) |  |
virtual

When some module is loaded this method selects max one rule that will be used for transcription. It search in range given by two iterators begin and end. The range contain only rules that has common predecessor. Current word and possition of predecessor must be passed. Parameters of selected module will be stored to parameters array.

Parameters
begin | iterator to range of rules
end | iterator to range of rules
word | word that is currently processed
pos | position of current predecessor in word
parameters | array of parameters for transcription. Only double type.
Returns
pointer to iterator to rule that was selected. Returns NULL if no rule was selected.

Reimplemented from AP_LSystem::LSystem.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parstoch0lsystem.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/parstoch0lsystem.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Query Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Query
Static Public Member Functions | List of all members
AP_LSystem::Query Class Reference

#include <query.h>

Static Public Member Functions

static double | positionX (const double *)
static double | positionY (const double *)
static double | positionZ (const double *)
static double | headingX (const double *)
static double | headingY (const double *)
static double | headingZ (const double *)
static double | upX (const double *)
static double | upY (const double *)
static double | upZ (const double *)
static double | leftX (const double *)
static double | leftY (const double *)
static double | leftZ (const double *)

Detailed Description

This class is an adapter class between FunctionParser and QueryInterpret. It contains a static methods that are added as custom functions to FunctionParser instances. They return coordinates of position matrix vectors.

Member Function Documentation

static double AP_LSystem::Query::headingX ( const double * )
inlinestatic

Query for heading x coordinate.

static double AP_LSystem::Query::headingY ( const double * )
inlinestatic

Query for heading y coordinate.

static double AP_LSystem::Query::headingZ ( const double * )
inlinestatic

Query for heading z coordinate.

static double AP_LSystem::Query::leftX ( const double * )
inlinestatic

Query for left x coordinate.

static double AP_LSystem::Query::leftY ( const double * )
inlinestatic

Query for left y coordinate.

static double AP_LSystem::Query::leftZ ( const double * )
inlinestatic

Query for left z coordinate.

static double AP_LSystem::Query::positionX ( const double * )
inlinestatic

Query for position x coordinate.

static double AP_LSystem::Query::positionY ( const double * )
inlinestatic

Query for position y coordinate.

static double AP_LSystem::Query::positionZ ( const double * )
inlinestatic

Query for position z coordinate.

static double AP_LSystem::Query::upX ( const double * )
inlinestatic

Query for up x coordinate.

static double AP_LSystem::Query::upY ( const double * )
inlinestatic

Query for up y coordinate.

static double AP_LSystem::Query::upZ ( const double * )
inlinestatic

Query for up z coordinate.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/query.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::QueryInterpret Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • QueryInterpret
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::QueryInterpret Class Reference

#include <queryinterpret.h>

Inheritance diagram for AP_LSystem::QueryInterpret:
AP_LSystem::AbstractInterpret

Public Member Functions

double | positionX ()
double | positionY ()
double | positionZ ()
double | headingX ()
double | headingY ()
double | headingZ ()
double | upX ()
double | upY ()
double | upZ ()
double | leftX ()
double | leftY ()
double | leftZ ()
void | bindWord (LongString *str)
- Public Member Functions inherited from AP_LSystem::AbstractInterpret
AbstractInterpret ()
int | switchGeode (std::vector< Parameter > &p)
void | createGeodes ()

Static Public Member Functions

static QueryInterpret * | get ()
- Static Public Member Functions inherited from AP_LSystem::AbstractInterpret
static const char * | errorText (int error)

Additional Inherited Members

- Protected Attributes inherited from AP_LSystem::AbstractInterpret
vector< LSGeode * > | m_Geodes
osg::Group * | m_Owner
scene graph owner More...
TurtleStack m_Turtles
stack for turtles More...

Member Function Documentation

void AP_LSystem::QueryInterpret::bindWord ( LongString * str )
inline

Bind word with interpreter. Interpreter uses this word if update is needed (calling update() method).

static QueryInterpret* AP_LSystem::QueryInterpret::get ( )
inlinestatic

Get singleton instance

double AP_LSystem::QueryInterpret::headingX ( )
inline

x coordinate of turtle heading vector

double AP_LSystem::QueryInterpret::headingY ( )
inline

y coordinate of turtle heading vector

double AP_LSystem::QueryInterpret::headingZ ( )
inline

z coordinate of turtle heading vector

double AP_LSystem::QueryInterpret::leftX ( )
inline

x coordinate of turtle left vector

double AP_LSystem::QueryInterpret::leftY ( )
inline

y coordinate of turtle left vector

double AP_LSystem::QueryInterpret::leftZ ( )
inline

z coordinate of turtle left vector

double AP_LSystem::QueryInterpret::positionX ( )
inline

x coordinate of turtle position vector

double AP_LSystem::QueryInterpret::positionY ( )
inline

y coordinate of turtle position vector

double AP_LSystem::QueryInterpret::positionZ ( )
inline

z coordinate of turtle position vector

double AP_LSystem::QueryInterpret::upX ( )
inline

x coordinate of turtle up vector

double AP_LSystem::QueryInterpret::upY ( )
inline

y coordinate of turtle up vector

double AP_LSystem::QueryInterpret::upZ ( )
inline

z coordinate of turtle up vector

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryinterpret.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/queryinterpret.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::QueryTurtle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • QueryTurtle
Public Member Functions | List of all members
AP_LSystem::QueryTurtle Class Reference

#include <queryturtle.h>

Inheritance diagram for AP_LSystem::QueryTurtle:
AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle

Public Member Functions

QueryTurtle (void)
~QueryTurtle (void)
virtual int | initialize ()
virtual int | finalize ()
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | makeRotate (osg::Quat &)
virtual int | preRotate ()
virtual int | postRotate ()
virtual int | doStep (double dist)
virtual int | drawStep (double)
virtual int | preStep ()
virtual int | postStep ()
virtual void | drawFrame (osg::Matrixd &, osg::Vec4d *=NULL)
virtual void | adjustMatrices ()
- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Specialized turtle for query processing. Doesn't generate any geometry. Only for determination of position matrix.

Constructor & Destructor Documentation

AP_LSystem::QueryTurtle::QueryTurtle ( void )
inline
AP_LSystem::QueryTurtle::~QueryTurtle ( void )
inline

Member Function Documentation

virtual int AP_LSystem::QueryTurtle::finalize ( )
inlinevirtual

Process a finalization of turtle. This method is called when turtle is removed from the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

virtual int AP_LSystem::QueryTurtle::initialize ( void )
inlinevirtual

Process an initialization of turtle. This method is called when turtle is pushed onto the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryturtle.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::RandomIndex Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • RandomIndex
Public Member Functions | Static Public Member Functions | List of all members
AP_LSystem::RandomIndex Class Reference

#include <randomindex.h>

Public Member Functions

RandomIndex ()
void | addProbability (double p)
unsigned int | getRandomIndex ()

Static Public Member Functions

static void init ()

Detailed Description

Class for generating random index for stochastic rule selection

Constructor & Destructor Documentation

AP_LSystem::RandomIndex::RandomIndex ( )
inline

Constructor

Member Function Documentation

void AP_LSystem::RandomIndex::addProbability ( double p )
inline

Add probability factor of rule.

Parameters
p probability
unsigned int AP_LSystem::RandomIndex::getRandomIndex ( )
inline

Returns random index according to probability factor

Returns
random index
static void AP_LSystem::RandomIndex::init ( void )
inlinestatic

Initialize random generator

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomindex.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Randomizer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Randomizer
Static Public Member Functions | List of all members
AP_LSystem::Randomizer Class Reference

#include <randomizer.h>

Static Public Member Functions

static void | init ()
static double | get (unsigned int maxPercents)
static double | get (const double *max)

Detailed Description

Library class for generating random numbers

Member Function Documentation

static double AP_LSystem::Randomizer::get ( unsigned int maxPercents )
inlinestatic

Returns random double number in percents with one decimal

Parameters
maxPercents maximum percents. Sets random number range as <-maxPercets, maxPercents>.
Returns
random number
static double AP_LSystem::Randomizer::get ( const double * max )
inlinestatic

Returns random double number with one decimal. This method is in form for using with FunctionParser.

Parameters
max maximum number. Sets random number range as <-max, max>.
Returns
random number
static void AP_LSystem::Randomizer::init ( void )
inlinestatic

Initialize random generator

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomizer.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Rectangle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Rectangle
Public Member Functions | List of all members
AP_LSystem::Rectangle Class Reference

#include <rectangle.h>

Inheritance diagram for AP_LSystem::Rectangle:
AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle

Public Member Functions

Rectangle (void)
~Rectangle (void)
virtual int | drawStep (double dist)
virtual int | initialize ()
virtual int | finalize ()
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | makeRotate (osg::Quat &)
virtual int | preRotate ()
virtual int | postRotate ()
virtual int | doStep (double dist)
virtual int | preStep ()
virtual int | postStep ()
virtual void | drawFrame (osg::Matrixd &, osg::Vec4d *=NULL)
virtual void | adjustMatrices ()
- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Turtle for generating simple rectangles. Can be used for simple leaves.

Constructor & Destructor Documentation

APDYNAMICART::Rectangle::Rectangle ( void )
inline

Rectangle class

AP_LSystem::Rectangle::~Rectangle ( void )
inline

Member Function Documentation

int Rectangle::drawStep ( double dist )
virtual

Draw one rectangle.

Reimplemented from AP_LSystem::MovingTurtle.

virtual int AP_LSystem::Rectangle::finalize ( )
inlinevirtual

Process a finalization of turtle. This method is called when turtle is removed from the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

virtual int AP_LSystem::Rectangle::initialize ( void )
inlinevirtual

Process an initialization of turtle. This method is called when turtle is pushed onto the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rectangle.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/rectangle.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Rule Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Rule
Public Member Functions | Public Attributes | List of all members
AP_LSystem::Rule Struct Reference

#include <rule.h>

Public Member Functions

Rule ()
Rule (const Rule &)
Rule & | operator= (const Rule &)
~Rule ()
void | processProbabilityFactor (string *rule, string::iterator &it)
void | processCondition (string *rule, string::iterator &it)
void | processParameters (string *rule, string::iterator &it)
bool | addStaticString (string *rule, string::iterator &it)
void | addDynamicString (string *rule, string::iterator &it)
bool | evaluateCondition (double *p)

Public Attributes

char | strictPredecessor
strict predecessor of rule More...
FunctionParser * | condition
rule condition - for parametric L-system More...
std::string | variables
list of variables in string More...
FunctionParser * | probabilityFactor
probability factor - for stochastic L-system More...
std::vector< StaticString * > | staticStrings
static parts of successor More...
std::vector< FunctionParser * > | dynamicStrings
dynamic parts of successor More...
string | leftContext
right context More...
string | rightContext
left context More...

Detailed Description

Structure for storing rule data. Common for all L-system.

Constructor & Destructor Documentation

AP_LSystem::Rule::Rule ( )
inline

Non-parametric constructor

Rule::Rule ( const Rule & c )

Copy constructor

Rule::~Rule ( )

Destructor

Member Function Documentation

void Rule::addDynamicString | ( | string * | rule,
 |  | string::iterator & | it
 | ) |  |

Parses string, processes and adds dynamic part(expressions) of successor

Parameters
rule | string to parse
it | opening variables position in rule string
bool Rule::addStaticString | ( | string * | rule,
 |  | string::iterator & | it
 | ) |  |

Parses string, processes and adds static part of successor

Parameters
rule | string to parse
it | opening static string position in rule string
Returns
- false - if successor end behind this parsed part
  • true - if successor continues with expression behind this static part
bool Rule::evaluateCondition ( double * p )

Evaluates rule's condition.

Parameters
p array of variables values
Returns
result of evaluation
Rule & Rule::operator= ( const Rule & c )

Assignment operator

void Rule::processCondition | ( | string * | rule,
 |  | string::iterator & | it
 | ) |  |

Parses string, processes and adds condition

Parameters
rule | string to parse
it | opening condition position in rule string
void Rule::processParameters | ( | string * | rule,
 |  | string::iterator & | it
 | ) |  |

Parses string, processes and adds parameter variables of predecessor or context

Parameters
rule | string to parse
it | opening variables position in rule string
void Rule::processProbabilityFactor | ( | string * | rule,
 |  | string::iterator & | it
 | ) |  |

Parses string, processes and adds probability factor

Parameters
rule | string to parse
it | opening probability factor position in rule string

Member Data Documentation

FunctionParser* AP_LSystem::Rule::condition

rule condition - for parametric L-system

std::vector<FunctionParser*> AP_LSystem::Rule::dynamicStrings

dynamic parts of successor

string AP_LSystem::Rule::leftContext

right context

FunctionParser* AP_LSystem::Rule::probabilityFactor

probability factor - for stochastic L-system

string AP_LSystem::Rule::rightContext

left context

std::vector<StaticString*> AP_LSystem::Rule::staticStrings

static parts of successor

char AP_LSystem::Rule::strictPredecessor

strict predecessor of rule

std::string AP_LSystem::Rule::variables

list of variables in string

The documentation for this struct was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rule.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/rule.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::StaticString Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StaticString
Public Member Functions | Public Attributes | List of all members
AP_LSystem::StaticString Class Reference

#include <staticstring.h>

Public Member Functions

StaticString (const char *str, int length)
StaticString (LongString *str)
StaticString (char ch)
StaticString (std::string str)
StaticString (const StaticString &c)
StaticString & | operator= (const StaticString &c)
std::string | toString ()
~StaticString ()

Public Attributes

char * | str
string buffer More...
int | length
string length More...

Detailed Description

Class for storing static strings. Can be used for storing static parts of successor.

Constructor & Destructor Documentation

AP_LSystem::StaticString::StaticString | ( | const char * | str,
 |  | int | length
 | ) |  |
inline
AP_LSystem::StaticString::StaticString ( LongString * str )
inline
AP_LSystem::StaticString::StaticString ( char ch )
inline
AP_LSystem::StaticString::StaticString ( std::string str )
inline
AP_LSystem::StaticString::StaticString ( const StaticString & c )
inline
AP_LSystem::StaticString::~StaticString ( )
inline

Member Function Documentation

StaticString& AP_LSystem::StaticString::operator= ( const StaticString & c )
inline
std::string AP_LSystem::StaticString::toString ( )
inline

Member Data Documentation

int AP_LSystem::StaticString::length

string length

char* AP_LSystem::StaticString::str

string buffer

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/staticstring.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::StraightPipe Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StraightPipe
Public Member Functions | List of all members
AP_LSystem::StraightPipe Class Reference

#include <straightpipe.h>

Inheritance diagram for AP_LSystem::StraightPipe:
AP_LSystem::LoftTurtle AP_LSystem::MovingTurtle AP_LSystem::AbstractTurtle AP_LSystem::HermitPipe

Public Member Functions

StraightPipe (void)
~StraightPipe (void)
virtual int | preStep ()
virtual int | insideStep ()
virtual int | initialize ()
virtual int | finalize ()
- Public Member Functions inherited from AP_LSystem::LoftTurtle
LoftTurtle (void)
~LoftTurtle (void)
- Public Member Functions inherited from AP_LSystem::MovingTurtle
virtual int | turnLeft (std::vector< Parameter > &p)
virtual int | turnRight (std::vector< Parameter > &p)
virtual int | pitchDown (std::vector< Parameter > &p)
virtual int | pitchUp (std::vector< Parameter > &p)
virtual int | rollLeft (std::vector< Parameter > &p)
virtual int | rollRight (std::vector< Parameter > &p)
virtual int | turnArround ()
virtual int | rollArround ()
virtual int | rollUntilHorizontal ()
virtual int | randomTurnPitchRoll (std::vector< Parameter > &p)
virtual int | multiplyLength (std::vector< Parameter > &p)
virtual int | multiplyRadius (std::vector< Parameter > &p)
virtual int | multiplyAngle (std::vector< Parameter > &p)
virtual int | multiplyTropismElasticity (std::vector< Parameter > &p)
virtual int | multiplyGravitropismElasticity (std::vector< Parameter > &p)
virtual int | drawForward (std::vector< Parameter > &p)
virtual int | drawForwardHalf ()
virtual int | moveForward (std::vector< Parameter > &p)
virtual int | moveForwardHalf ()
- Public Member Functions inherited from AP_LSystem::AbstractTurtle
virtual int | resetValues ()
TurtleProperties & getProperties ()
virtual void | setProperties (TurtleProperties p)
virtual void | inheritProperties (TurtleProperties p)
void | bindGeode (LSGeode *geode)
LSGeode * getGeode ()
osg::Matrixd | getMatrix ()
virtual void | drawVector (const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color)
double | toRad (double angle)
double | rand (double angle)

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::LoftTurtle
virtual int | drawStep (double dist)
void | createCircleContour ()
virtual int | addContourLoftGeometry ()
virtual int | createLoftGeometryOpening ()
- Protected Attributes inherited from AP_LSystem::AbstractTurtle
TurtleProperties properties
properties of turtle is used for getting parameters for generation of geometry More...
LSGeode * geode
all geometry generated by turtle is stored to this output geode More...

Detailed Description

Improved turtle for stem geometry generation. It creates cylinders without holes in geometry.

Constructor & Destructor Documentation

AP_LSystem::StraightPipe::StraightPipe ( void )
inline
AP_LSystem::StraightPipe::~StraightPipe ( void )
inline

Member Function Documentation

int StraightPipe::finalize ( )
virtual

Process a finalization of turtle. This method is called when turtle is removed from the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

Reimplemented in AP_LSystem::HermitPipe.

int StraightPipe::initialize ( void )
virtual

Process an initialization of turtle. This method is called when turtle is pushed onto the stack.

Returns
error code

Reimplemented from AP_LSystem::AbstractTurtle.

Reimplemented in AP_LSystem::HermitPipe.

int StraightPipe::insideStep ( )
virtual

Whole geometry generation is made in this method. Straight pipes generate geometry in the middle of each step.

Returns
error code

Reimplemented from AP_LSystem::LoftTurtle.

int StraightPipe::preStep ( )
virtual

This method is called before each step.

Returns
error code

Reimplemented from AP_LSystem::MovingTurtle.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/straightpipe.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/straightpipe.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::TurtleInterpret Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleInterpret
Public Member Functions | List of all members
AP_LSystem::TurtleInterpret Class Reference

#include <turtleinterpret.h>

Inheritance diagram for AP_LSystem::TurtleInterpret:
AP_LSystem::AbstractInterpret

Public Member Functions

TurtleInterpret (osg::Group *owner)
~TurtleInterpret (void)
virtual int | parse (ParseableString *word)
- Public Member Functions inherited from AP_LSystem::AbstractInterpret
AbstractInterpret ()
int | switchGeode (std::vector< Parameter > &p)
void | createGeodes ()

Additional Inherited Members

- Static Public Member Functions inherited from AP_LSystem::AbstractInterpret
static const char * | errorText (int error)
- Protected Attributes inherited from AP_LSystem::AbstractInterpret
vector< LSGeode * > | m_Geodes
osg::Group * | m_Owner
scene graph owner More...
TurtleStack m_Turtles
stack for turtles More...

Detailed Description

This class interprets a word generated by L-system word generator. It creates a geometry using turtle graphics.

Constructor & Destructor Documentation

TurtleInterpret::TurtleInterpret ( osg::Group * owner )

Creates a turtle interpret. This interpret has to be connected to scene graph. During interpretation It generates a geometry stored in LSGeode instances.

Parameters
owner parent in scene graph
TurtleInterpret::~TurtleInterpret ( void )

Member Function Documentation

int TurtleInterpret::parse ( ParseableString * word )
virtual

Interpretes a word by converting L-system modules to turtle commands.

Parameters
word interpreted word
Returns
error code

Implements AP_LSystem::AbstractInterpret.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtleinterpret.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/turtleinterpret.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::TurtleStack Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleStack
Public Member Functions | List of all members
AP_LSystem::TurtleStack Class Reference

#include <turtlestack.h>

Public Member Functions

TurtleStack (void)
~TurtleStack (void)
int | pop ()
int | push ()
int | push (LSGeode *geode)
AbstractTurtle * top ()
void | clear ()

Detailed Description

Specialized stack for turtle processing.

Constructor & Destructor Documentation

TurtleStack::TurtleStack ( void )
TurtleStack::~TurtleStack ( void )

Member Function Documentation

void TurtleStack::clear ( void )

Removes all turtles

int TurtleStack::pop ( )

Pops a turtle on the top of the stack.

Returns
error code
int TurtleStack::push ( )

Adds turtle on the top of the stack. The turtle will have same type as current turtle on the top of the stack. Turtle is also binded with the same LSGeode.

Returns
error code
int TurtleStack::push ( LSGeode * geode )

Adds turtle of different type on the top of the stack. Type of the turtle is determined from LSGeode. Turtle is binded with LSGeode to write there a geometry.

Parameters
geode Inserted turtle will be binded with this geode.
Returns
error code
AbstractTurtle * TurtleStack::top ( )

Get turtle from the top of the stack.

Returns
turtle from the top of the stack
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtlestack.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/turtlestack.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::StringUtils Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StringUtils
Static Public Member Functions | List of all members
AP_LSystem::StringUtils Class Reference

#include <utils.h>

Static Public Member Functions

static void | uncommentLine (std::string &)
static std::string & | eraseWhiteSpaces (std::string &)
static std::string | processLine (std::fstream *, std::stringstream &)
static int | processVector (std::string str, std::vector< double > &v)

Detailed Description

Library class with some utility functions for strings

Member Function Documentation

std::string & StringUtils::eraseWhiteSpaces ( std::string & str )
static

Erases all white spaces in string

std::string StringUtils::processLine | ( | std::fstream * | pFile,
 |  | std::stringstream & | pLine
 | ) |  |
static

Get one line from file and extract first word

int StringUtils::processVector | ( | std::string | str,
 |  | std::vector< double > & | v
 | ) |  |
static

Convert vector in string format ( double, double, ... , double ) to std::vector

void StringUtils::uncommentLine ( std::string & line )
static

Erases every char behind '//' including this sign

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/utils.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/utils.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::Parameter Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Parameter
Public Types | Public Member Functions | Public Attributes | List of all members
AP_LSystem::Parameter Struct Reference

#include <utils.h>

Public Types

enum Type {
LS_BYTE = 1, LS_UBYTE, LS_INT, LS_UINT,
LS_FLOAT, LS_DOUBLE
}

Public Member Functions

Parameter (void *value, Type type)

Public Attributes

void * value
value of parameter More...
Type type
parameter type More...

Detailed Description

Structure for storing parameter values

Member Enumeration Documentation

enum AP_LSystem::Parameter::Type

Parameter types

Enumerator
LS_BYTE
LS_UBYTE
LS_INT
LS_UINT
LS_FLOAT
LS_DOUBLE

Constructor & Destructor Documentation

AP_LSystem::Parameter::Parameter | ( | void * | value,
 |  | Type | type
 | ) |  |
inline

Member Data Documentation

Type AP_LSystem::Parameter::type

parameter type

void* AP_LSystem::Parameter::value

value of parameter

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/utils.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: AP_LSystem::XmlFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • XmlFile
Public Member Functions | List of all members
AP_LSystem::XmlFile Class Reference

#include <xmlfile.h>

Inheritance diagram for AP_LSystem::XmlFile:
AP_LSystem::AbstractFile

Public Member Functions

XmlFile ()
virtual void | open (std::string &filename)
- Public Member Functions inherited from AP_LSystem::AbstractFile
AbstractFile ()
void | substitute (std::map< string, string > &pairs)
virtual std::vector< string > * | getHomomorphisms ()
virtual std::vector< string > * | getRules ()
virtual std::vector< string > * | getSubsystems ()
std::string & | getAxiom ()
unsigned int | type ()
std::string & | name ()

Additional Inherited Members

- Protected Member Functions inherited from AP_LSystem::AbstractFile
void | addType (std::string &type)
- Protected Attributes inherited from AP_LSystem::AbstractFile
unsigned int | m_Type
type of loaded L-system More...
string | m_Name
name of loaded L-system More...
string | m_Axiom
loaded axiom More...
std::vector< string > | m_Rules
container with loaded rules strings More...
std::vector< string > | m_Homomorphisms
container with loaded homomorphism rules More...
std::vector< string > | m_Subsytems
container with subsystem's filenames More...

Detailed Description

This class opens and processes XML files with L-systems.

Constructor & Destructor Documentation

XmlFile::XmlFile ( )

Member Function Documentation

void XmlFile::open ( std::string & filename )
virtual

Opens XML file.

Parameters
filename name of XML file

Implements AP_LSystem::AbstractFile.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/xmlfile.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/xmlfile.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraMovement::CameraMovementEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • CameraMovementEditor
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APCameraMovement::CameraMovementEditor Class Reference

#include <CameraMovementEditor.h>

Inheritance diagram for APCameraMovement::CameraMovementEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

CameraMovementEditor ()
virtual | ~CameraMovementEditor ()
void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
bool | setIntersection (osg::Vec3 &position, vrecko::Scene *scenePtr)
bool | viewMenu ()
virtual void | menuItemClicked (const char *itemID)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

unsigned long | selectedObjectID
osgUtil::LineSegmentIntersector::Intersection | intersection
Action | action
EnvironmentObject * pathObject
CameraPath * pCameraPath
bool | menuShowed
bool | bFirstUpdate
unsigned int | pointIndex
unsigned int | pointType
osg::Vec3 | firstPointerPos
osg::Vec3 | firstObjectPos
osg::Vec3 | firstObjectPosCo
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APCameraMovement::CameraMovementEditor::CameraMovementEditor ( )
virtual APCameraMovement::CameraMovementEditor::~CameraMovementEditor ( )
inlinevirtual

Member Function Documentation

bool APCameraMovement::CameraMovementEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APCameraMovement::CameraMovementEditor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APCameraMovement::CameraMovementEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APCameraMovement::CameraMovementEditor::issueRequests ( bool bStopIfNoSelection )
protected
void APCameraMovement::CameraMovementEditor::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

bool APCameraMovement::CameraMovementEditor::setIntersection | ( | osg::Vec3 & | position,
 |  | vrecko::Scene * | scenePtr
 | ) |  |
protected
void APCameraMovement::CameraMovementEditor::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

bool APCameraMovement::CameraMovementEditor::viewMenu ( )
protected

Member Data Documentation

Action APCameraMovement::CameraMovementEditor::action
protected
bool APCameraMovement::CameraMovementEditor::bFirstUpdate
protected
osg::Vec3 APCameraMovement::CameraMovementEditor::firstObjectPos
protected
osg::Vec3 APCameraMovement::CameraMovementEditor::firstObjectPosCo
protected
osg::Vec3 APCameraMovement::CameraMovementEditor::firstPointerPos
protected
osgUtil::LineSegmentIntersector::Intersection APCameraMovement::CameraMovementEditor::intersection
protected
bool APCameraMovement::CameraMovementEditor::menuShowed
protected
EnvironmentObject* APCameraMovement::CameraMovementEditor::pathObject
protected
CameraPath* APCameraMovement::CameraMovementEditor::pCameraPath
protected
unsigned int APCameraMovement::CameraMovementEditor::pointIndex
protected
unsigned int APCameraMovement::CameraMovementEditor::pointType
protected
unsigned long APCameraMovement::CameraMovementEditor::selectedObjectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraMovementEditor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/CameraMovementEditor.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraMovement::ControlPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • ControlPoint
Public Attributes | List of all members
APCameraMovement::ControlPoint Struct Reference

#include <CameraPath.h>

Public Attributes

osg::Vec3 | position
osg::Vec3 | vectorPathWise
osg::Vec3 | vectorCounterPathWise
osg::Quat | cameraRotation
double | totalPathLength
double | pathLength
unsigned int | pathIndex

Member Data Documentation

osg::Quat APCameraMovement::ControlPoint::cameraRotation
unsigned int APCameraMovement::ControlPoint::pathIndex
double APCameraMovement::ControlPoint::pathLength
osg::Vec3 APCameraMovement::ControlPoint::position
double APCameraMovement::ControlPoint::totalPathLength
osg::Vec3 APCameraMovement::ControlPoint::vectorCounterPathWise
osg::Vec3 APCameraMovement::ControlPoint::vectorPathWise
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraPath.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraMovement::CameraPath Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • CameraPath
Public Member Functions | List of all members
APCameraMovement::CameraPath Class Reference

#include <CameraPath.h>

Inheritance diagram for APCameraMovement::CameraPath:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CameraPath ()
~CameraPath ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
void | draw ()
void | setDirty (bool d)
std::vector< ControlPoint > * | getControlPoints ()
void | addPoint (osg::Vec3 pos, osg::Vec3 vecPW=DEFAULT_VECPW, osg::Vec3 vecCPW=DEFAULT_VECCPW, osg::Quat cDir=DEFAULT_CDIR)
bool | animating ()
bool | startAnimation ()
bool | stopAnimation ()
bool | updateActTime ()
float | convertActTimeToActPos ()
bool | updateAnimation (float fActPos)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

APCameraMovement::CameraPath::CameraPath ( )
APCameraMovement::CameraPath::~CameraPath ( )

Member Function Documentation

void APCameraMovement::CameraPath::addPoint | ( | osg::Vec3 | pos,
 |  | osg::Vec3 | vecPW = DEFAULT_VECPW,
 |  | osg::Vec3 | vecCPW = DEFAULT_VECCPW,
 |  | osg::Quat | cDir = DEFAULT_CDIR
 | ) |  |
inline
bool APCameraMovement::CameraPath::animating ( )
inline
float APCameraMovement::CameraPath::convertActTimeToActPos ( )
void APCameraMovement::CameraPath::draw ( )
std::vector<ControlPoint>* APCameraMovement::CameraPath::getControlPoints ( )
inline
bool APCameraMovement::CameraPath::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APCameraMovement::CameraPath::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APCameraMovement::CameraPath::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APCameraMovement::CameraPath::setDirty ( bool d )
inline
bool APCameraMovement::CameraPath::startAnimation ( )
bool APCameraMovement::CameraPath::stopAnimation ( )
void APCameraMovement::CameraPath::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

bool APCameraMovement::CameraPath::updateActTime ( )
bool APCameraMovement::CameraPath::updateAnimation ( float fActPos )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraPath.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/CameraPath.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraMovement::MyReadCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • MyReadCallback
Public Member Functions | List of all members
APCameraMovement::MyReadCallback Struct Reference
Inheritance diagram for APCameraMovement::MyReadCallback:

Public Member Functions

virtual osg::Node * readNodeFile (const std::string &filename)

Member Function Documentation

virtual osg::Node* APCameraMovement::MyReadCallback::readNodeFile ( const std::string & filename )
inlinevirtual
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/CameraMovementEditor.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraPath::ControlPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraPath
  • ControlPoint
Public Attributes | List of all members
APCameraPath::ControlPoint Struct Reference

#include <Camera.h>

Public Attributes

vrecko::EnvironmentObject * Path_ptr
vrecko::EnvironmentObject * View_ptr

Member Data Documentation

vrecko::EnvironmentObject* APCameraPath::ControlPoint::Path_ptr
vrecko::EnvironmentObject* APCameraPath::ControlPoint::View_ptr
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/Camera.h
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APCameraPath::Camera Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraPath
  • Camera
Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
APCameraPath::Camera Class Reference

#include <Camera.h>

Inheritance diagram for APCameraPath::Camera:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Camera ()
virtual | ~Camera ()
void | update (void)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

enum | state { STATE_EDITING, STATE_ANIMATING, STATE_MOVING }
enum | animate { ANIM_1ST_VIEW, ANIM_3RD_VIEW }

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | menuItemClicked (const char *itemID)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
void | ComputePath (std::vector< ControlPoint > &ControlPoints, osg::Vec3Array *Path, osg::Vec3Array *View)
void | ComputeSpline (const std::vector< osg::Vec3 > &PointList, osg::Vec3Array *arrayToStorePoints, bool bDynamicSpeed, const std::vector< double > *LengthsOfParts)
std::vector< double > | ArcLength (osg::Vec3Array *PointList, int PointsOnPart=100)
void | DrawSpline (vrecko::EnvironmentObject *pCurveOwner, osg::Vec3Array *PointSet, osg::Vec4 colorOfLine)
void | CreateCurs2ViewPts ()
void | DrawVecCursor (vrecko::EnvironmentObject *pCursorOwner, double dVecLength, const osg::Matrix &rotationMatrix, osg::Vec3 &position)
vrecko::EnvironmentObject * | DrawPoint (osg::Vec3 position, float pointRadius, osg::Vec4 pointColor)
void | UpdatePath ()
void | InitAnimation (osg::Vec3Array *path, osg::Vec3Array *view)
void | Animate ()
osg::Matrix | Orient2Vec (osg::Vec3 Vector)
bool | makeMenu ()
bool | makeMovementMenu ()
bool | FindPoint (double dDistance, osg::Vec3Array *PointList, osg::Vec3Array *newControlPoints)
void | Clear ()
void | Init ()
void | AddPathPoint (osg::Vec3 position)
void | AddViewPoint (osg::Vec3 position)
void | DeletePoint (unsigned long ID)
void | start1stAnimation ()
void | SaveAnimation (const char *FileName)
bool | LoadAnimation (const char *FileName, std::vector< osg::Vec3 > &newPathControlPoints, std::vector< osg::Vec3 > &newViewControlPoints)
void | issueRequests (bool bStopIfNoSelection)
bool | objectTransformationFromPointer (vrecko::EnvironmentObject *eo, osg::Matrix *outTrans)
void | UpdateMove ()
bool | ActivateMove ()
void | DeactivateMove ()
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

enum APCameraPath::Camera::state | m_eState
enum APCameraPath::Camera::animate | m_eAnimate
vrecko::World::AvatarView avView
vrecko::EnvironmentObject * m_pEOPathLine
vrecko::EnvironmentObject * m_pEOPathPoints
vrecko::EnvironmentObject * m_pEOViewLine
vrecko::EnvironmentObject * m_pEOCursor
vrecko::EnvironmentObject * m_pEOCamera
bool | bStartAnimation
bool | b3rdCamera
unsigned int | m_numOfViewPts
std::vector< ControlPoint > | m_ControlPoints
std::vector< osg::Vec3 > | m_ActPathLine
std::vector< osg::Vec3 > | m_ActViewLine
float | fPointRadius
bool | bShowViewLine
bool | bShowLinesWhileAnim
int | iSpeed
float | fTransparency
float | fAnimationTime
string | sAnimationFile
bool | bAnimationFile
bool | bAutoRun
bool | bDynamicSpeed
std::vector< osg::Vec3 > | PathCtrlPts
std::vector< osg::Vec3 > | ViewCtrlPts
osg::Vec3 | firstPointerPos
osg::Vec3 | firstObjectPos
unsigned long | movingObjectID
bool | bFirstUpdate
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...

Member Enumeration Documentation

enum APCameraPath::Camera::animate
protected
Enumerator
ANIM_1ST_VIEW
ANIM_3RD_VIEW
enum APCameraPath::Camera::state
protected
Enumerator
STATE_EDITING
STATE_ANIMATING
STATE_MOVING

Constructor & Destructor Documentation

APCameraPath::Camera::Camera ( )
virtual APCameraPath::Camera::~Camera ( )
inlinevirtual

Member Function Documentation

bool APCameraPath::Camera::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

bool APCameraPath::Camera::ActivateMove ( )
protected
void APCameraPath::Camera::AddPathPoint ( osg::Vec3 position )
protected
void APCameraPath::Camera::AddViewPoint ( osg::Vec3 position )
protected
void APCameraPath::Camera::Animate ( )
protected
std::vector< double > APCameraPath::Camera::ArcLength | ( | osg::Vec3Array * | PointList,
 |  | int | PointsOnPart = 100
 | ) |  |
protected

Computes length of each spline segment created by "PointsOnPart" points(default is 100 points);

void APCameraPath::Camera::Clear ( )
protected

Clear all

void APCameraPath::Camera::ComputePath | ( | std::vector< ControlPoint > & | ControlPoints,
 |  | osg::Vec3Array * | Path,
 |  | osg::Vec3Array * | View
 | ) |  |
protected
void APCameraPath::Camera::ComputeSpline | ( | const std::vector< osg::Vec3 > & | PointList,
 |  | osg::Vec3Array * | arrayToStorePoints,
 |  | bool | bDynamicSpeed,
 |  | const std::vector< double > * | LengthsOfParts
 | ) |  |
protected

Catmull-rom algorithm implementation for creating a spline

void APCameraPath::Camera::CreateCurs2ViewPts ( )
protected

Create and draw a 3D pointer from each path control point to each view control point

void APCameraPath::Camera::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APCameraPath::Camera::DeactivateMove ( )
protected
void APCameraPath::Camera::DeletePoint ( unsigned long ID )
protected
EnvironmentObject * APCameraPath::Camera::DrawPoint | ( | osg::Vec3 | position,
 |  | float | pointRadius,
 |  | osg::Vec4 | pointColor
 | ) |  |
protected

Draw a point of given radius and color, return pointer to EO

void APCameraPath::Camera::DrawSpline | ( | vrecko::EnvironmentObject * | pCurveOwner,
 |  | osg::Vec3Array * | PointSet,
 |  | osg::Vec4 | colorOfLine
 | ) |  |
protected
void APCameraPath::Camera::DrawVecCursor | ( | vrecko::EnvironmentObject * | pCursorOwner,
 |  | double | dVecLength,
 |  | const osg::Matrix & | rotationMatrix,
 |  | osg::Vec3 & | position
 | ) |  |
protected

Draw a cursor pointing to view point

void APCameraPath::Camera::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APCameraPath::Camera::FindPoint | ( | double | dDistance,
 |  | osg::Vec3Array * | PointList,
 |  | osg::Vec3Array * | newControlPoints
 | ) |  |
protected

Finds all points in accurate length in given PointList and store them to 'newControlPoints'structure

void APCameraPath::Camera::Init ( )
protected
void APCameraPath::Camera::InitAnimation | ( | osg::Vec3Array * | path,
 |  | osg::Vec3Array * | view
 | ) |  |
protected

Initialization and animation processing

virtual bool APCameraPath::Camera::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
inlinevirtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

void APCameraPath::Camera::issueRequests ( bool bStopIfNoSelection )
protected
bool APCameraPath::Camera::LoadAnimation | ( | const char * | FileName,
 |  | std::vector< osg::Vec3 > & | newPathControlPoints,
 |  | std::vector< osg::Vec3 > & | newViewControlPoints
 | ) |  |
protected
bool APCameraPath::Camera::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
protectedvirtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

bool APCameraPath::Camera::makeMenu ( )
protected

Base menu

bool APCameraPath::Camera::makeMovementMenu ( )
protected

Menu for disabling point movement

void APCameraPath::Camera::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

bool APCameraPath::Camera::objectTransformationFromPointer | ( | vrecko::EnvironmentObject * | eo,
 |  | osg::Matrix * | outTrans
 | ) |  |
protected
osg::Matrix APCameraPath::Camera::Orient2Vec ( osg::Vec3 Vector )
protected

Return a Matrix for rotation to specific vector (Orientation of object is computed for +Z)

void APCameraPath::Camera::SaveAnimation ( const char * FileName )
protected
void APCameraPath::Camera::start1stAnimation ( )
protected
void APCameraPath::Camera::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

void APCameraPath::Camera::UpdateMove ( )
protected
void APCameraPath::Camera::UpdatePath ( )
protected

Updates every CameraPath object in scene

Member Data Documentation

vrecko::World::AvatarView APCameraPath::Camera::avView
protected
bool APCameraPath::Camera::b3rdCamera
protected
bool APCameraPath::Camera::bAnimationFile
protected
bool APCameraPath::Camera::bAutoRun
protected
bool APCameraPath::Camera::bDynamicSpeed
protected
bool APCameraPath::Camera::bFirstUpdate
protected
bool APCameraPath::Camera::bShowLinesWhileAnim
protected
bool APCameraPath::Camera::bShowViewLine
protected
bool APCameraPath::Camera::bStartAnimation
protected
float APCameraPath::Camera::fAnimationTime
protected
osg::Vec3 APCameraPath::Camera::firstObjectPos
protected
osg::Vec3 APCameraPath::Camera::firstPointerPos
protected
float APCameraPath::Camera::fPointRadius
protected
float APCameraPath::Camera::fTransparency
protected
int APCameraPath::Camera::iSpeed
protected
std::vector<osg::Vec3> APCameraPath::Camera::m_ActPathLine
protected
std::vector<osg::Vec3> APCameraPath::Camera::m_ActViewLine
protected
std::vector<ControlPoint> APCameraPath::Camera::m_ControlPoints
protected
enum APCameraPath::Camera::animate APCameraPath::Camera::m_eAnimate
protected
enum APCameraPath::Camera::state APCameraPath::Camera::m_eState
protected
unsigned int APCameraPath::Camera::m_numOfViewPts
protected
vrecko::EnvironmentObject* APCameraPath::Camera::m_pEOCamera
protected
vrecko::EnvironmentObject* APCameraPath::Camera::m_pEOCursor
protected
vrecko::EnvironmentObject* APCameraPath::Camera::m_pEOPathLine
protected
vrecko::EnvironmentObject* APCameraPath::Camera::m_pEOPathPoints
protected
vrecko::EnvironmentObject* APCameraPath::Camera::m_pEOViewLine
protected
unsigned long APCameraPath::Camera::movingObjectID
protected
std::vector<osg::Vec3> APCameraPath::Camera::PathCtrlPts
protected
string APCameraPath::Camera::sAnimationFile
protected
std::vector<osg::Vec3> APCameraPath::Camera::ViewCtrlPts
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/Camera.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraPath/Camera.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APClouds::Clouds Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APClouds
  • Clouds
Public Member Functions | Protected Member Functions | List of all members
APClouds::Clouds Class Reference

Clouds ability - revised Atmospheric ability. More...

#include <Clouds.h>

Inheritance diagram for APClouds::Clouds:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Clouds ()
virtual | ~Clouds ()
virtual void | preInitialize (void)
virtual void | postInitialize (void)
virtual void | processEvent (const std::string &input_name, void *value)
virtual void | update ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | AddSkybox ()
void | AddGround ()
void | AddSun ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Clouds ability - revised Atmospheric ability.

Constructor & Destructor Documentation

Clouds::Clouds ( )

Initializes the Clouds ability.

Clouds::~Clouds ( )
virtual

Virtual destructor.

Member Function Documentation

void Clouds::AddGround ( )
protected

Adds the ground to the scene graph if it's allowed in the input XML file.

void Clouds::AddSkybox ( )
protected

Adds the skybox to the scene graph if it's allowed in the input XML file.

void Clouds::AddSun ( )
protected

Adds the sun to the scene graph if it's allowed in the input XML file.

bool Clouds::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Loads the ability-related parameters from the XML file to the appropriate structure

Parameters
pParametersNode Path to the file
Returns
TRUE if everything went well, FALSE otherwise

Reimplemented from vrecko::BaseClass.

void Clouds::postInitialize ( void )
virtual

Initializes the whole Clouds ability - clouds, skybox, ground, sun, lighting of clouds.

Reimplemented from vrecko::BaseClass.

void Clouds::preInitialize ( void )
virtual

Preinitializes the whole Clouds ability, sets it priority and frequency of update

Reimplemented from vrecko::BaseClass.

void Clouds::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
virtual

Should process all the required events. However, it does nothing since no events are required at the moment.

Parameters
input_name | Name of the event.
value | Value of the event.
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Clouds::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Should create an XML with the scene. However, it does nothing since no XML creation is required at the moment.

Parameters
pDocNode Path to file, where the XML document should be saved.
Returns
NULL

Reimplemented from vrecko::BaseClass.

void Clouds::update ( void )
virtual

Update method, which is being called on a regular basis as set in preInitialize() method. Gets information about the camera from the world and passes it to the instance of CloudDataType.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Clouds.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Clouds.cpp
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::ConnectEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • ConnectEditor
Public Member Functions | Protected Member Functions | List of all members
APConnectEditor::ConnectEditor Class Reference

#include <ConnectEditor.h>

Inheritance diagram for APConnectEditor::ConnectEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

ConnectEditor ()
virtual | ~ConnectEditor ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | processButtonRelease (vrecko::CABUTTONEVENT *eventData)
bool | init ()
bool | snap ()
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APConnectEditor::ConnectEditor::ConnectEditor ( )
virtual APConnectEditor::ConnectEditor::~ConnectEditor ( )
inlinevirtual

Member Function Documentation

bool APConnectEditor::ConnectEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::ConnectEditor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::ConnectEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APConnectEditor::ConnectEditor::init ( )
protected
bool APConnectEditor::ConnectEditor::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::ConnectEditor::processButtonRelease ( vrecko::CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

bool APConnectEditor::ConnectEditor::snap ( )
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/ConnectEditor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_Connecting.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_icp.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_Morphing.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_SnappingRegion.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::Cut Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Cut
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APConnectEditor::Cut Class Reference

#include <Cut.h>

Inheritance diagram for APConnectEditor::Cut:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Cut ()
virtual | ~Cut ()
virtual void | update ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
void | menuItemClicked (const char *itemID)
bool | closeLoop ()
void | showCuttingLoop ()
void | showCloseCuttingLoop ()
void | createNewCuttingLoop ()
void | cutObject ()
bool | addNewPartObject (set< int > partSet, bool move)
void | optimalizeCuttingLoop ()
void | resetCuttingLoop ()
void | processPoint (osg::Vec3 point)
void | resolveSelection ()
EnvironmentObject * | resolveIntersections (osg::Vec3 &position, std::vector< osg::Node * > **nodePath=NULL)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | isMenu
SnapObject * selectedObject
vector< int > | cuttingLoop
SnapObject * soCuttingLoop
bool | pFirstActivation
int | lastAddedPoint
EnvironmentObject * owner
unsigned long | freeID
osg::Vec3 | lastPosition
osg::Vec3 | lastSelTest
unsigned long | selObjectID
DynamicArray< int > | intersectedObjects
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APConnectEditor::Cut::Cut ( )
APConnectEditor::Cut::~Cut ( )
virtual

Member Function Documentation

bool APConnectEditor::Cut::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

bool APConnectEditor::Cut::addNewPartObject | ( | set< int > | partSet,
 |  | bool | move
 | ) |  |
protected
bool APConnectEditor::Cut::closeLoop ( )
protected
void APConnectEditor::Cut::createNewCuttingLoop ( )
protected
void APConnectEditor::Cut::cutObject ( )
protected
void APConnectEditor::Cut::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Cut::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APConnectEditor::Cut::issueRequests ( bool bStopIfNoSelection )
protected
bool APConnectEditor::Cut::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
protectedvirtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Cut::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Cut::optimalizeCuttingLoop ( )
protected
void APConnectEditor::Cut::processPoint ( osg::Vec3 point )
protected
void APConnectEditor::Cut::resetCuttingLoop ( )
protected
EnvironmentObject * APConnectEditor::Cut::resolveIntersections | ( | osg::Vec3 & | position,
 |  | std::vector< osg::Node * > ** | nodePath = NULL
 | ) |  |
protected
void APConnectEditor::Cut::resolveSelection ( )
protected
void APConnectEditor::Cut::showCloseCuttingLoop ( )
protected
void APConnectEditor::Cut::showCuttingLoop ( )
protected
void APConnectEditor::Cut::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

vector<int> APConnectEditor::Cut::cuttingLoop
protected
unsigned long APConnectEditor::Cut::freeID
protected
DynamicArray<int> APConnectEditor::Cut::intersectedObjects
protected
bool APConnectEditor::Cut::isMenu
protected
int APConnectEditor::Cut::lastAddedPoint
protected
osg::Vec3 APConnectEditor::Cut::lastPosition
protected
osg::Vec3 APConnectEditor::Cut::lastSelTest
protected
EnvironmentObject* APConnectEditor::Cut::owner
protected
bool APConnectEditor::Cut::pFirstActivation
protected
SnapObject* APConnectEditor::Cut::selectedObject
protected
unsigned long APConnectEditor::Cut::selObjectID
protected
SnapObject* APConnectEditor::Cut::soCuttingLoop
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Cut.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Cut.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::Optimalizer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Optimalizer
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APConnectEditor::Optimalizer Class Reference

#include <Optimalizer.h>

Inheritance diagram for APConnectEditor::Optimalizer:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Optimalizer ()
virtual | ~Optimalizer ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | processButtonRelease (vrecko::CABUTTONEVENT *eventData)
bool | optimalizeAndSave ()
void | optimalizeObject (EnvironmentObject *eo)
void | optimalizeGeometry (osg::Geometry *geometry)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

unsigned long | targetID
unsigned long | sourceID
vrecko::EnvironmentObject * _source
vrecko::EnvironmentObject * _target
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APConnectEditor::Optimalizer::Optimalizer ( )
virtual APConnectEditor::Optimalizer::~Optimalizer ( )
inlinevirtual

Member Function Documentation

bool APConnectEditor::Optimalizer::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Optimalizer::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Optimalizer::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APConnectEditor::Optimalizer::optimalizeAndSave ( )
protected
void APConnectEditor::Optimalizer::optimalizeGeometry ( osg::Geometry * geometry )
protected

!!!!!!!!! fungovalo i s > ????? - ///je to jedno i by tam nemelo byt - bylo odstraneno

void APConnectEditor::Optimalizer::optimalizeObject ( EnvironmentObject * eo )
protected
void APConnectEditor::Optimalizer::processButtonRelease ( vrecko::CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

vrecko::EnvironmentObject* APConnectEditor::Optimalizer::_source
protected
vrecko::EnvironmentObject * APConnectEditor::Optimalizer::_target
protected
unsigned long APConnectEditor::Optimalizer::sourceID
protected
unsigned long APConnectEditor::Optimalizer::targetID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Optimalizer.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Optimalizer.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::PolygonState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • PolygonState
Public Member Functions | Protected Member Functions | List of all members
APConnectEditor::PolygonState Class Reference

#include <PolygonState.h>

Inheritance diagram for APConnectEditor::PolygonState:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

PolygonState ()
virtual | ~PolygonState ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APConnectEditor::PolygonState::PolygonState ( )
inline
virtual APConnectEditor::PolygonState::~PolygonState ( )
inlinevirtual

Member Function Documentation

bool APConnectEditor::PolygonState::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::PolygonState::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APConnectEditor::PolygonState::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/PolygonState.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/PolygonState.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::Rotation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Rotation
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APConnectEditor::Rotation Class Reference

#include <Rotation.h>

Inheritance diagram for APConnectEditor::Rotation:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Rotation ()
virtual | ~Rotation ()
void | update (void)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
bool | objectTransformationFromPointer (EnvironmentObject *eo, osg::Matrix *outTrans)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bLocalRotation
osg::Vec3 | firstPointerPos
osg::Vec3 | eyePos
osg::Vec3 | lastPointerPos
osg::Matrix | firstObjectMatrix
unsigned long | movingObjectID
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APConnectEditor::Rotation::Rotation ( )
virtual APConnectEditor::Rotation::~Rotation ( )
inlinevirtual

Member Function Documentation

bool APConnectEditor::Rotation::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Rotation::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Rotation::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APConnectEditor::Rotation::issueRequests ( bool bStopIfNoSelection )
protected
bool APConnectEditor::Rotation::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

bool APConnectEditor::Rotation::objectTransformationFromPointer | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | outTrans
 | ) |  |
protected
void APConnectEditor::Rotation::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

bool APConnectEditor::Rotation::bLocalRotation
protected
osg::Vec3 APConnectEditor::Rotation::eyePos
protected
osg::Matrix APConnectEditor::Rotation::firstObjectMatrix
protected
osg::Vec3 APConnectEditor::Rotation::firstPointerPos
protected
osg::Vec3 APConnectEditor::Rotation::lastPointerPos
protected
unsigned long APConnectEditor::Rotation::movingObjectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Rotation.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Rotation.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::Scale Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Scale
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APConnectEditor::Scale Class Reference

#include <Scale.h>

Inheritance diagram for APConnectEditor::Scale:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Scale ()
virtual | ~Scale ()
void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
bool | objectTransformationFromPointer (EnvironmentObject *eo, osg::Matrix *outTrans)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | firstPointerPos
osg::Vec3 | eyePos
osg::Matrix | firstObjectMatrix
unsigned long | movingObjectID
bool | bFirstUpdate
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APConnectEditor::Scale::Scale ( )
virtual APConnectEditor::Scale::~Scale ( )
inlinevirtual

Member Function Documentation

bool APConnectEditor::Scale::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Scale::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APConnectEditor::Scale::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APConnectEditor::Scale::issueRequests ( bool bStopIfNoSelection )
protected
bool APConnectEditor::Scale::objectTransformationFromPointer | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | outTrans
 | ) |  |
protected
void APConnectEditor::Scale::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

bool APConnectEditor::Scale::bFirstUpdate
protected
osg::Vec3 APConnectEditor::Scale::eyePos
protected
osg::Matrix APConnectEditor::Scale::firstObjectMatrix
protected
osg::Vec3 APConnectEditor::Scale::firstPointerPos
protected
unsigned long APConnectEditor::Scale::movingObjectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Scale.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Scale.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::MyReadCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • MyReadCallback
Public Member Functions | List of all members
APConnectEditor::MyReadCallback Struct Reference
Inheritance diagram for APConnectEditor::MyReadCallback:

Public Member Functions

virtual osg::Node * readNodeFile (const std::string &filename)

Member Function Documentation

virtual osg::Node* APConnectEditor::MyReadCallback::readNodeFile ( const std::string & filename )
inlinevirtual
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Cut.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConnectEditor::EOLineSegmentIntersector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • EOLineSegmentIntersector
Public Member Functions | List of all members
APConnectEditor::EOLineSegmentIntersector Class Reference
Inheritance diagram for APConnectEditor::EOLineSegmentIntersector:

Public Member Functions

EOLineSegmentIntersector (const osg::Vec3d &start, const osg::Vec3d &end)
virtual bool enter (const osg::Node &node)

Constructor & Destructor Documentation

APConnectEditor::EOLineSegmentIntersector::EOLineSegmentIntersector | ( | const osg::Vec3d & | start,
 |  | const osg::Vec3d & | end
 | ) |  |
inline

Member Function Documentation

bool EOLineSegmentIntersector::enter ( const osg::Node & node )
virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Cut.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConstrainedMovement::ConstrainedObjectMovement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstrainedObjectMovement
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APConstrainedMovement::ConstrainedObjectMovement Class Reference

#include <ConstrainedObjectMovement.h>

Inheritance diagram for APConstrainedMovement::ConstrainedObjectMovement:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

ConstrainedObjectMovement ()
virtual | ~ConstrainedObjectMovement ()
virtual void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual CAINFO * | createInfo ()
virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
void | issueRequests (bool bStopIfNoSelection)
bool | objectTransformationFromPointer (EnvironmentObject *eo, osg::Matrix *outTrans, osg::Vec3 *outTranslationVector)
bool | applyConstrainedSnapping (EnvironmentObject *eo, osg::Matrix *inoutTrans, osg::Vec3 *inoutTranslationVector)
void | readWatchedObjectIDs ()
void | writeObjectPosition (int id, ofstream &stream)
void | writeObjectRotation (int id, ofstream &stream)
void | writeObjectFullMatrix (int id, ofstream &stream)
void | writeObjectPositionsAndRotations ()
void | compareObjectPosition (int id, ifstream &stream, double &linearDifference, double &quadraticDifference)
void | compareObjectRotation (int id, ifstream &stream, double &linearDifference, double &quadraticDifference)
void | compareObjectPositionsAndRotations ()
void | loadObjectFullMatrix (int id, ifstream &stream)
void | loadObjectPositionsAndRotations ()
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

ConstraintHierarchyMember * constraintHierarchyRoot
bool | rotating
osg::Vec3 | prevPointerPos
osg::Vec3 | firstPointerPos
osg::Quat | firstPointerRot
osg::Vec3 | firstObjectPos
osg::Quat | firstObjectRot
unsigned long | movingObjectID
float | firstTransparency
bool | bFirstUpdate
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

The ability for semantically constrained movement of objects

Constructor & Destructor Documentation

APConstrainedMovement::ConstrainedObjectMovement::ConstrainedObjectMovement ( )

Creates the ability

APConstrainedMovement::ConstrainedObjectMovement::~ConstrainedObjectMovement ( )
virtual

Frees the ability

Member Function Documentation

bool APConstrainedMovement::ConstrainedObjectMovement::activate ( )
protectedvirtual

Activation of the ability

Reimplemented from vrecko::ControllableAbility.

bool APConstrainedMovement::ConstrainedObjectMovement::applyConstrainedSnapping | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | inoutTransformation,
 |  | osg::Vec3 * | inoutTranslationVector
 | ) |  |
protected

MAIN SNAPPING PART

void APConstrainedMovement::ConstrainedObjectMovement::compareObjectPosition | ( | int | id,
 |  | ifstream & | stream,
 |  | double & | linearDifference,
 |  | double & | quadraticDifference
 | ) |  |
protected
void APConstrainedMovement::ConstrainedObjectMovement::compareObjectPositionsAndRotations ( )
protected
void APConstrainedMovement::ConstrainedObjectMovement::compareObjectRotation | ( | int | id,
 |  | ifstream & | stream,
 |  | double & | linearDifference,
 |  | double & | quadraticDifference
 | ) |  |
protected
CAINFO * APConstrainedMovement::ConstrainedObjectMovement::createInfo ( )
protectedvirtual

Creates the info of the ability

Reimplemented from vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::deactivate ( )
protectedvirtual

Deactivation of the ability

Reimplemented from vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::fillDefaultInfo ( )
protectedvirtual

Fills the info of the ability

Implements vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::issueRequests ( bool bStopIfNoSelection )
protected

Request pointer data

void APConstrainedMovement::ConstrainedObjectMovement::loadObjectFullMatrix | ( | int | id,
 |  | ifstream & | stream
 | ) |  |
protected
void APConstrainedMovement::ConstrainedObjectMovement::loadObjectPositionsAndRotations ( )
protected
bool APConstrainedMovement::ConstrainedObjectMovement::objectTransformationFromPointer | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | trans,
 |  | osg::Vec3 * | outTranslationVector
 | ) |  |
protected

Calculates object transformation from pointer position. Can perform either translation, or rotation. If objectTransformationFromPointer returns false, neither movement nor rotation should take place.

void APConstrainedMovement::ConstrainedObjectMovement::processButtonPress ( CABUTTONEVENT * eventData )
protectedvirtual

Process button pressing: depending on the button, start either translation, or rotation

Reimplemented from vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::processButtonRelease ( CABUTTONEVENT * eventData )
protectedvirtual

Process button releasing

Reimplemented from vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::readWatchedObjectIDs ( )
protected

Functions for efficiency testing and evaluation purposes

void APConstrainedMovement::ConstrainedObjectMovement::update ( void )
virtual

Update the object position

Reimplemented from vrecko::ControllableAbility.

void APConstrainedMovement::ConstrainedObjectMovement::writeObjectFullMatrix | ( | int | id,
 |  | ofstream & | stream
 | ) |  |
protected
void APConstrainedMovement::ConstrainedObjectMovement::writeObjectPosition | ( | int | id,
 |  | ofstream & | stream
 | ) |  |
protected
void APConstrainedMovement::ConstrainedObjectMovement::writeObjectPositionsAndRotations ( )
protected
void APConstrainedMovement::ConstrainedObjectMovement::writeObjectRotation | ( | int | id,
 |  | ofstream & | stream
 | ) |  |
protected

Member Data Documentation

bool APConstrainedMovement::ConstrainedObjectMovement::bFirstUpdate
protected
ConstraintHierarchyMember* APConstrainedMovement::ConstrainedObjectMovement::constraintHierarchyRoot
protected
osg::Vec3 APConstrainedMovement::ConstrainedObjectMovement::firstObjectPos
protected
osg::Quat APConstrainedMovement::ConstrainedObjectMovement::firstObjectRot
protected
osg::Vec3 APConstrainedMovement::ConstrainedObjectMovement::firstPointerPos
protected
osg::Quat APConstrainedMovement::ConstrainedObjectMovement::firstPointerRot
protected
float APConstrainedMovement::ConstrainedObjectMovement::firstTransparency
protected
unsigned long APConstrainedMovement::ConstrainedObjectMovement::movingObjectID
protected
osg::Vec3 APConstrainedMovement::ConstrainedObjectMovement::prevPointerPos
protected
bool APConstrainedMovement::ConstrainedObjectMovement::rotating
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConstrainedMovement::ConstraintArea Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstraintArea
Public Member Functions | List of all members
APConstrainedMovement::ConstraintArea Class Reference

#include <ConstraintArea.h>

Public Member Functions

ConstraintArea ()
virtual | ~ConstraintArea ()
ConstraintHierarchyMember * | getAreaClass (ConstraintHierarchyMember *constraintHierarchyRoot)
string | getAreaClassString ()
void | setAreaClassString (string str)
string | getRestrictorString ()
void | setRestrictorString (string str)
void | addBoundingPoint (osg::Vec3 &coords)
Vecs3 getBoundingPoints ()
Vecs3 getBoundingPointsWorld ()
void | shift (osg::Vec3 shiftVector)
void | setNormalVector (osg::Vec3 &normalVector)
osg::Vec3 | getNormalVector ()
osg::Vec3 | getNormalVectorWorld ()
void | setWorldTransformationFromObject (EnvironmentObject *eo)
void | applyTransformation (osg::Matrix transformationMatrix)
void | writeInfo ()
bool | liesWithinArea (ConstraintArea *area)
double | ConstraintArea::distanceFactorToArea (ConstraintArea *area)
bool | getPlaneDistanceFrom (ConstraintArea *area, double &distance)

Detailed Description

Class representing a constraint area; any ConstraintArea can function as binding, offer or dual

Constructor & Destructor Documentation

APConstrainedMovement::ConstraintArea::ConstraintArea ( )

Creates a constraint area with no bounding points

APConstrainedMovement::ConstraintArea::~ConstraintArea ( )
virtual

Frees a constraint area

Member Function Documentation

void APConstrainedMovement::ConstraintArea::addBoundingPoint ( osg::Vec3 & coords )

Adds a new bounding point to the area

void APConstrainedMovement::ConstraintArea::applyTransformation ( osg::Matrix transformationMatrix )

Applies a transformation to the area

double APConstrainedMovement::ConstraintArea::ConstraintArea::distanceFactorToArea ( ConstraintArea * area )
ConstraintHierarchyMember * APConstrainedMovement::ConstraintArea::getAreaClass ( ConstraintHierarchyMember * constraintHierarchyRoot )
string APConstrainedMovement::ConstraintArea::getAreaClassString ( )
inline
Vecs3 APConstrainedMovement::ConstraintArea::getBoundingPoints ( )
inline
Vecs3 APConstrainedMovement::ConstraintArea::getBoundingPointsWorld ( )
inline
osg::Vec3 APConstrainedMovement::ConstraintArea::getNormalVector ( )
inline
osg::Vec3 APConstrainedMovement::ConstraintArea::getNormalVectorWorld ( )
inline
bool APConstrainedMovement::ConstraintArea::getPlaneDistanceFrom | ( | ConstraintArea * | area,
 |  | double & | distance
 | ) |  |

Returns whether the areas are parallel. If they are parallel, stores their distance in the distance parameter.

string APConstrainedMovement::ConstraintArea::getRestrictorString ( )
inline
bool APConstrainedMovement::ConstraintArea::liesWithinArea ( ConstraintArea * area )

Returns whether one area lies completely within another

void APConstrainedMovement::ConstraintArea::setAreaClassString ( string str )
inline
void APConstrainedMovement::ConstraintArea::setNormalVector ( osg::Vec3 & normalVector )

Sets the normal vector of the area

void APConstrainedMovement::ConstraintArea::setRestrictorString ( string str )
inline
void APConstrainedMovement::ConstraintArea::setWorldTransformationFromObject ( EnvironmentObject * eo )

Updates area's world coordinates according to the world coordinates of its owner EnvironmentObject

void APConstrainedMovement::ConstraintArea::shift ( osg::Vec3 shiftVector )

Shifts the whole area (i. e. all of its bounding points)

void APConstrainedMovement::ConstraintArea::writeInfo ( )

Writes the area information to standard output

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintArea.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintArea.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APConstrainedMovement::ConstraintDescription Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstraintDescription
Public Member Functions | List of all members
APConstrainedMovement::ConstraintDescription Class Reference

#include <ConstraintDescription.h>

Inheritance diagram for APConstrainedMovement::ConstraintDescription:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ConstraintDescription ()
virtual | ~ConstraintDescription ()
bool | loadXMLFile (const char *xmlFile)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
ConstraintAreas getOfferAreas ()
ConstraintAreas getBindingAreas ()
ConstraintAreas getDualAreas ()
bool | getJustMoving ()
void | setJustMoving (bool justMoving)
bool | getWasTested ()
void | setWasTested (bool wasTested)
int | getConstraintParentID ()
EnvironmentObjectIDs getConstrainedChildrenIDs ()
EnvironmentObjectIDs getConstrainedDualPartnerIDs ()
EnvironmentObjectIDs getFreshDualPartnerIDs ()
void | clearFreshDualPartnerIDs ()
void | addConstrainedChildID (int id)
void | removeConstrainedChildID (int id)
void | addConstrainedDualPartnerID (int id, bool addAsFresh)
void | removeConstrainedDualPartnerID (int id)
void | freeFromConstraintParent ()
void | shiftAllConstrainedObjects (EnvironmentObject *eo, const osg::Matrix &transformationMatrix)
void | processDualSplitting (EnvironmentObject *eo, osg::Vec3 splittingDirection)
bool | isConstraintParentOf (EnvironmentObject *eo)
int | getBoundAreaCount ()
osg::Vec3 | getBoundAreaNormal ()
void | setBoundAreaCount (int boundAreaCount)
void | setBoundAreaNormal (osg::Vec3 boundAreaNormal)
void | writeInfo ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Class representing constraint description of an object

Constructor & Destructor Documentation

APConstrainedMovement::ConstraintDescription::ConstraintDescription ( )

Creates an empty constraint description

APConstrainedMovement::ConstraintDescription::~ConstraintDescription ( )
virtual

Frees a constraint description

Member Function Documentation

void APConstrainedMovement::ConstraintDescription::addConstrainedChildID ( int id )

Environment object identified by id will become a child of this object

void APConstrainedMovement::ConstraintDescription::addConstrainedDualPartnerID | ( | int | id,
 |  | bool | addAsFresh
 | ) |  |

Adding a dual partner

void APConstrainedMovement::ConstraintDescription::clearFreshDualPartnerIDs ( )
inline
void APConstrainedMovement::ConstraintDescription::freeFromConstraintParent ( )

Remove the parent-child relationship between the owner of this constraint description and its constraint parent

ConstraintAreas APConstrainedMovement::ConstraintDescription::getBindingAreas ( )
inline
int APConstrainedMovement::ConstraintDescription::getBoundAreaCount ( )
inline
osg::Vec3 APConstrainedMovement::ConstraintDescription::getBoundAreaNormal ( )
inline
EnvironmentObjectIDs APConstrainedMovement::ConstraintDescription::getConstrainedChildrenIDs ( )
inline
EnvironmentObjectIDs APConstrainedMovement::ConstraintDescription::getConstrainedDualPartnerIDs ( )
inline
int APConstrainedMovement::ConstraintDescription::getConstraintParentID ( )
inline
ConstraintAreas APConstrainedMovement::ConstraintDescription::getDualAreas ( )
inline
EnvironmentObjectIDs APConstrainedMovement::ConstraintDescription::getFreshDualPartnerIDs ( )
inline
bool APConstrainedMovement::ConstraintDescription::getJustMoving ( )
inline
ConstraintAreas APConstrainedMovement::ConstraintDescription::getOfferAreas ( )
inline
bool APConstrainedMovement::ConstraintDescription::getWasTested ( )
inline
bool APConstrainedMovement::ConstraintDescription::isConstraintParentOf ( EnvironmentObject * eo )

Returns whether this object is a constraint parent or partner of the given object

bool APConstrainedMovement::ConstraintDescription::loadXMLFile ( const char * xmlFile )

Loading the description from the specified file

bool APConstrainedMovement::ConstraintDescription::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Loading the constraint description itself (either recursively from a file specified by <ConstraintDescriptionFileName>, or using inline XML data)

Reimplemented from vrecko::BaseClass.

void APConstrainedMovement::ConstraintDescription::processDualSplitting | ( | EnvironmentObject * | eo,
 |  | osg::Vec3 | splittingDirection
 | ) |  |

Split eo from dual partners that lie in a wrong direction

void APConstrainedMovement::ConstraintDescription::removeConstrainedChildID ( int id )

Environment object identified by id will no longer be a child of this object

void APConstrainedMovement::ConstraintDescription::removeConstrainedDualPartnerID ( int id )

Removing a dual partner

void APConstrainedMovement::ConstraintDescription::setBoundAreaCount ( int boundAreaCount )
inline
void APConstrainedMovement::ConstraintDescription::setBoundAreaNormal ( osg::Vec3 boundAreaNormal )
inline
void APConstrainedMovement::ConstraintDescription::setJustMoving ( bool justMoving )
inline
void APConstrainedMovement::ConstraintDescription::setWasTested ( bool wasTested )
inline
void APConstrainedMovement::ConstraintDescription::shiftAllConstrainedObjects | ( | EnvironmentObject * | eo,
 |  | const osg::Matrix & | transformationMatrix
 | ) |  |

Shift all objects constrained to this object

void APConstrainedMovement::ConstraintDescription::writeInfo ( )

Writes the description information to standard output

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintDescription.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintDescription.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Attractor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Attractor
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Attractor Class Referenceabstract

#include <Attractor.h>

Inheritance diagram for APDYNAMICART::Attractor:
APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass APDYNAMICART::JuliaAttractor APDYNAMICART::NullAttractor APDYNAMICART::OrdinaryAttractor

Public Member Functions

virtual std::string | createMenuStructure (void) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
void | generate ()
virtual void | init ()
virtual void | compute ()=0
Parameters & getParameters ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0
Creates structure of menu items for this PoA. More...
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
Save current state of PoA to .XML node. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static AttractorPtr | createInstance (std::string attName, Controller *controller)
static AttractorNames | getAvailableAttractors ()

Protected Member Functions

Attractor (Controller *controller)
void | setSliderParameter (const char *sliderID, float sliderPos)
bool | valueChanged (float sliderPos)
IMenuComponentPtr | createParameterSubMenu () const

Protected Attributes

Parameters _params
float | _size
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Attractor::Attractor ( Controller * controller )
inlineprotected

Constructors

Member Function Documentation

virtual void APDYNAMICART::Attractor::compute ( )
pure virtual

Implemented in APDYNAMICART::OrdinaryAttractor, APDYNAMICART::JuliaAttractor, and APDYNAMICART::NullAttractor.

AttractorPtr APDYNAMICART::Attractor::createInstance | ( | std::string | attName,
 |  | Controller * | controller
 | ) |  |
static

Static methods

virtual std::string APDYNAMICART::Attractor::createMenuStructure ( void ) const
inlinevirtual

Inherited virtual methods

IMenuComponentPtr APDYNAMICART::Attractor::createParameterSubMenu ( ) const
protected
void APDYNAMICART::Attractor::generate ( )

Algorithm methods

AttractorNames APDYNAMICART::Attractor::getAvailableAttractors ( )
static
Parameters& APDYNAMICART::Attractor::getParameters ( )
inline

Helper methods

virtual void APDYNAMICART::Attractor::GUIItemClicked ( const char * itemID )
inlinevirtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

Reimplemented in APDYNAMICART::OrdinaryAttractor, and APDYNAMICART::JuliaAttractor.

virtual void APDYNAMICART::Attractor::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlinevirtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

Reimplemented in APDYNAMICART::OrdinaryAttractor, and APDYNAMICART::JuliaAttractor.

virtual void APDYNAMICART::Attractor::init ( void )
inlinevirtual

Reimplemented in APDYNAMICART::OrdinaryAttractor.

virtual int APDYNAMICART::Attractor::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
inlinevirtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Implements APDYNAMICART::PoA.

Reimplemented in APDYNAMICART::OrdinaryAttractor.

virtual void APDYNAMICART::Attractor::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::Attractor::setColor ( osg::Vec4 newColour )
inlinevirtual
void APDYNAMICART::Attractor::setSliderParameter | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
protected

Helper methods

virtual void APDYNAMICART::Attractor::update ( )
inlinevirtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

Reimplemented in APDYNAMICART::OrdinaryAttractor, and APDYNAMICART::JuliaAttractor.

bool APDYNAMICART::Attractor::valueChanged ( float sliderPos )
protected

Member Data Documentation

Parameters APDYNAMICART::Attractor::_params
protected

Attributes

float APDYNAMICART::Attractor::_size
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Attractor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Attractor.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Brush Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Brush
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::Brush Class Reference

Encapsulate data and functionality of sweepSurface related factories and adapters. More...

#include <Brush.h>

Inheritance diagram for APDYNAMICART::Brush:

Public Member Functions

Brush (string colorAdapterName, string diameterAdapterName, string crossSectionAdapterName, string rotationFrameAdapterName)
Brush (const Brush &orig)
~Brush ()
osg::ref_ptr< ColorGenAdapter > | getColorGenAdapter ()
osg::ref_ptr< DiameterGenAdapter > | getDiameterGenAdapter ()
osg::ref_ptr< SplineAdapter > | getCrossSectionAdapter ()
osg::ref_ptr
< RotationFrameAdapter > 		getRotationFrameAdapter ()
string | getCrossSectionAdapterName () const
string | getRotationFrameAdapterName () const
double | getSmoothness () const
ColorGenFactory * getColorGenFactory ()
int | getCrossSectionInterpolationSteps () const
int | getInterpolationSteps () const
double | getDiameter ()
bool | sliderChanged (const char *sliderID, float sliderPos)
bool | guiItemClicked (const char *itemID)
bool | setDiameterAdapter (string name)
bool | setColorAdapter (string name)
bool | setCrossSectionAdapter (string name)
bool | setRotationFrameAdapter (string name)
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
void | createMenu (MenuPtr menu, bool colorMenu=true)
void | load (DOMNode *ParametersNode)
void | setDiameter (float sliderPos)
void | setInterpolationSteps (int steps)
void | setCrossSectionInterpolationSteps (int steps)
void | setSmoothness (double val)

Protected Attributes

int | _interpolationSteps
int | _crossSectionInterpolationSteps
double | _smoothness
string | _colorGenAdapterName
Object for managing color(s) of sweep surface. More...
string | _diamGenAdapterName
Object for managing diameter(s) of sweep surface. More...
string | _crossSectionAdapterName
Object for managing cross-section shape of sweep surface. More...
string | _rotationFrameAdapterName
object for managing tilting of the brush More...
ColorGenFactory _colorGenFactory
factories - for simple generation and data storage of sweep surface parameters generators More...
DiameterGenFactory _diamGenFactory
SplineFactory _crossSectionFactory
RotationFrameFactory _rotationFrameFactory

Detailed Description

Encapsulate data and functionality of sweepSurface related factories and adapters.

Constructor & Destructor Documentation

APDYNAMICART::Brush::Brush | ( | string | colorAdapterName,
 |  | string | diameterAdapterName,
 |  | string | crossSectionAdapterName,
 |  | string | rotationFrameAdapterName
 | ) |  |
APDYNAMICART::Brush::Brush ( const Brush & orig )
APDYNAMICART::Brush::~Brush ( )
inline

Member Function Documentation

void APDYNAMICART::Brush::createMenu | ( | MenuPtr | menu,
 |  | bool | colorMenu = true
 | ) |  |
osg::ref_ptr<ColorGenAdapter> APDYNAMICART::Brush::getColorGenAdapter ( )
inline
ColorGenFactory* APDYNAMICART::Brush::getColorGenFactory ( )
inline
osg::ref_ptr<SplineAdapter> APDYNAMICART::Brush::getCrossSectionAdapter ( )
inline
string APDYNAMICART::Brush::getCrossSectionAdapterName ( ) const
inline
int APDYNAMICART::Brush::getCrossSectionInterpolationSteps ( ) const
inline
double APDYNAMICART::Brush::getDiameter ( )
osg::ref_ptr<DiameterGenAdapter> APDYNAMICART::Brush::getDiameterGenAdapter ( )
inline
int APDYNAMICART::Brush::getInterpolationSteps ( ) const
inline
osg::ref_ptr<RotationFrameAdapter> APDYNAMICART::Brush::getRotationFrameAdapter ( )
inline
string APDYNAMICART::Brush::getRotationFrameAdapterName ( ) const
inline
double APDYNAMICART::Brush::getSmoothness ( ) const
inline
bool APDYNAMICART::Brush::guiItemClicked ( const char * itemID )
void APDYNAMICART::Brush::load ( DOMNode * ParametersNode )
void APDYNAMICART::Brush::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | ParametersNode
 | ) |  |
bool APDYNAMICART::Brush::setColorAdapter ( string name )
bool APDYNAMICART::Brush::setCrossSectionAdapter ( string name )
void APDYNAMICART::Brush::setCrossSectionInterpolationSteps ( int steps )
void APDYNAMICART::Brush::setDiameter ( float sliderPos )
bool APDYNAMICART::Brush::setDiameterAdapter ( string name )
void APDYNAMICART::Brush::setInterpolationSteps ( int steps )
inline
bool APDYNAMICART::Brush::setRotationFrameAdapter ( string name )
void APDYNAMICART::Brush::setSmoothness ( double val )
inline
bool APDYNAMICART::Brush::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |

Member Data Documentation

string APDYNAMICART::Brush::_colorGenAdapterName
protected

Object for managing color(s) of sweep surface.

ColorGenFactory APDYNAMICART::Brush::_colorGenFactory
protected

factories - for simple generation and data storage of sweep surface parameters generators

string APDYNAMICART::Brush::_crossSectionAdapterName
protected

Object for managing cross-section shape of sweep surface.

SplineFactory APDYNAMICART::Brush::_crossSectionFactory
protected
int APDYNAMICART::Brush::_crossSectionInterpolationSteps
protected
string APDYNAMICART::Brush::_diamGenAdapterName
protected

Object for managing diameter(s) of sweep surface.

DiameterGenFactory APDYNAMICART::Brush::_diamGenFactory
protected
int APDYNAMICART::Brush::_interpolationSteps
protected
string APDYNAMICART::Brush::_rotationFrameAdapterName
protected

object for managing tilting of the brush

RotationFrameFactory APDYNAMICART::Brush::_rotationFrameFactory
protected
double APDYNAMICART::Brush::_smoothness
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Brush.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Brush.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::BrushStroke Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • BrushStroke
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::BrushStroke Class Reference

Store data about and can render one brush stroke. More...

#include <BrushStroke.h>

Inheritance diagram for APDYNAMICART::BrushStroke:
APDYNAMICART::PoA APDYNAMICART::Stroke vrecko::EnvironmentObject vrecko::BaseClass APDYNAMICART::MotionTrail

Public Member Functions

BrushStroke (Controller *contr, BrushPtr brush)
~BrushStroke ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
void | exportToFile (std::string file)
export the current state of the brush stroke to a file More...
double | getDuration ()
double | getRealStartTime ()
double | getComputedStartTime ()
virtual Vec3ArrayPtr | getPositionSamples () const
virtual Vec4ArrayPtr | getOrientationSamples () const
virtual osg::ref_ptr
< osg::DoubleArray > 		getTimeStamps () const
virtual SplinePtr | getLeadingSpline () const
void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
void | importControlPoints (std::vector< osg::Vec3 > *samples, std::vector< osg::Vec4 > *colours, double diameter, int usize)
int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *BrushStrokeNode)
Load configuration of PoA from .XML node. More...
void | playback (double playbackTime)
void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save PoA as one node to .xml file. More...
void | setLeadingSpline (InterpolatedSplinePtr val)
void | setCrossSectionInterpolation (int interpol)
void | setCrossSectionType (int type)
void | setInterpolationSteps (int interpol)
void | setSmoothness (double smooth)
void | setComputedTime (double newTime)
void | switchRenderingMethod ()
Switch between polygon = FILL and wire-frame = LINE modes. More...
void | update (void)
Update of PoA - e.g. re-rendering. More...
void | visualizeControlPoints (bool show)
Switch on or off showing box-likes visualization of control points of BrushStroke. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (EvokeHSLColorPicker, MessageString, MessageBool)

Protected Attributes

Vec3ArrayPtr _samplesPositions
All position samples tracked by input device during creation of BrushStroke. More...
Vec4ArrayPtr _samplesOrientations
All orientation samples tracked by input device during creation of BrushStroke. More...
DoubleArrayPtr | _samplesTimeStamps
All timeStamps samples. More...
TimeLineSplinePtr _timeLineDecorator
time-line decorator - used for playback feature More...
double | _StartTime
time when stroke was created. Number of seconds from beginning of painting. More...
double | _computedStrokeStartTime
based on used playback time. e.g. inter-strokes lags may be skipped More...
SplinePtr | _leadingSpline
leading, or so-called spine curve - computed from tracked samples, defines trail of user motion More...
SplinePtr | _leadingSplineInterpolated
SplinePtr | _leadingSplineTilting
osg::Vec3 | _lastValidSamplePosition
used during loading More...
SweepSurfaceGeodePtr _sweepSurface
object for visualization brush stroke - from defined splines and parameters, it generates triangle (quad) mesh More...
vreckoUtils::HighlightCallback * _highLightcallback
callback for "highlighting" sweep-surface More...
BrushPtr _brush
container for color, diameter and cross-section spline factories (and therefore adapters) More...
int | _strokeTime
time (in seconds) from beginning of painting to start of this stroke More...
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Store data about and can render one brush stroke.

members:

  • sets of samples - independent arrays for speed reasons
    • samplesPosition
    • samplesOrientation
    • samplesTimeStamps
  • functions:
    • load and save (xml format)
    • import form Modeller
    • ...

Constructor & Destructor Documentation

APDYNAMICART::BrushStroke::BrushStroke | ( | Controller * | contr,
 |  | BrushPtr | brush
 | ) |  |

request for evoking color picker

chosen color sent from color picker

APDYNAMICART::BrushStroke::~BrushStroke ( )

Member Function Documentation

void APDYNAMICART::BrushStroke::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implements APDYNAMICART::PoA.

APDYNAMICART::BrushStroke::DECLARE_INPUT | ( | Colour | ,
 |  | MessageVec4 |
 | ) |  |
APDYNAMICART::BrushStroke::DECLARE_REQUEST_OUTPUT | ( | EvokeHSLColorPicker | ,
 |  | MessageString | ,
 |  | MessageBool |
 | ) |  |
protected
void APDYNAMICART::BrushStroke::exportToFile ( std::string file )

export the current state of the brush stroke to a file

double APDYNAMICART::BrushStroke::getComputedStartTime ( )
inline
double APDYNAMICART::BrushStroke::getDuration ( )
virtual SplinePtr APDYNAMICART::BrushStroke::getLeadingSpline ( ) const
inlinevirtual

Implements APDYNAMICART::Stroke.

virtual Vec4ArrayPtr APDYNAMICART::BrushStroke::getOrientationSamples ( ) const
inlinevirtual

Implements APDYNAMICART::Stroke.

virtual Vec3ArrayPtr APDYNAMICART::BrushStroke::getPositionSamples ( ) const
inlinevirtual

Stroke methods

Implements APDYNAMICART::Stroke.

double APDYNAMICART::BrushStroke::getRealStartTime ( )
inline
virtual osg::ref_ptr<osg::DoubleArray> APDYNAMICART::BrushStroke::getTimeStamps ( ) const
inlinevirtual

Implements APDYNAMICART::Stroke.

void APDYNAMICART::BrushStroke::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::importControlPoints | ( | std::vector< osg::Vec3 > * | samples,
 |  | std::vector< osg::Vec4 > * | colours,
 |  | double | diameter,
 |  | int | usize
 | ) |  |
int APDYNAMICART::BrushStroke::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
virtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::playback ( double playbackTime )
void APDYNAMICART::BrushStroke::pointed ( bool pointed )
virtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save PoA as one node to .xml file.

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::setComputedTime ( double newTime )
inline
void APDYNAMICART::BrushStroke::setCrossSectionInterpolation ( int interpol )
void APDYNAMICART::BrushStroke::setCrossSectionType ( int type )
void APDYNAMICART::BrushStroke::setInterpolationSteps ( int interpol )
void APDYNAMICART::BrushStroke::setLeadingSpline ( InterpolatedSplinePtr val )
inline
void APDYNAMICART::BrushStroke::setSmoothness ( double smooth )
void APDYNAMICART::BrushStroke::switchRenderingMethod ( )

Switch between polygon = FILL and wire-frame = LINE modes.

void APDYNAMICART::BrushStroke::update ( void )
virtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

void APDYNAMICART::BrushStroke::visualizeControlPoints ( bool show )

Switch on or off showing box-likes visualization of control points of BrushStroke.

Member Data Documentation

BrushPtr APDYNAMICART::BrushStroke::_brush
protected

container for color, diameter and cross-section spline factories (and therefore adapters)

double APDYNAMICART::BrushStroke::_computedStrokeStartTime
protected

based on used playback time. e.g. inter-strokes lags may be skipped

vreckoUtils::HighlightCallback* APDYNAMICART::BrushStroke::_highLightcallback
protected

callback for "highlighting" sweep-surface

osg::Vec3 APDYNAMICART::BrushStroke::_lastValidSamplePosition
protected

used during loading

SplinePtr APDYNAMICART::BrushStroke::_leadingSpline
protected

leading, or so-called spine curve - computed from tracked samples, defines trail of user motion

SplinePtr APDYNAMICART::BrushStroke::_leadingSplineInterpolated
protected
SplinePtr APDYNAMICART::BrushStroke::_leadingSplineTilting
protected
Vec4ArrayPtr APDYNAMICART::BrushStroke::_samplesOrientations
protected

All orientation samples tracked by input device during creation of BrushStroke.

Vec3ArrayPtr APDYNAMICART::BrushStroke::_samplesPositions
protected

All position samples tracked by input device during creation of BrushStroke.

DoubleArrayPtr APDYNAMICART::BrushStroke::_samplesTimeStamps
protected

All timeStamps samples.

double APDYNAMICART::BrushStroke::_StartTime
protected

time when stroke was created. Number of seconds from beginning of painting.

int APDYNAMICART::BrushStroke::_strokeTime
protected

time (in seconds) from beginning of painting to start of this stroke

SweepSurfaceGeodePtr APDYNAMICART::BrushStroke::_sweepSurface
protected

object for visualization brush stroke - from defined splines and parameters, it generates triangle (quad) mesh

TimeLineSplinePtr APDYNAMICART::BrushStroke::_timeLineDecorator
protected

time-line decorator - used for playback feature

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/BrushStroke.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStroke.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ColorGenAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ColorGenAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::ColorGenAdapter Class Reference

#include <ColorGenAdapter.h>

Inheritance diagram for APDYNAMICART::ColorGenAdapter:
APDYNAMICART::PoAAdapter< ColorGen > APDYNAMICART::ConstantColorAdapter APDYNAMICART::GradientColorAdapter

Public Member Functions

ColorGenAdapter ()
virtual void | setColor (const osg::Vec4 &color)
virtual osg::Vec4 | getColor ()
int | getColorIndex () const
void | setColorIndex (int val)
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr< ColorGen > | getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

int _colorIndex

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual ~PoAAdapter ()

Detailed Description

Optional methods for set of similar classes, each class implements them

Constructor & Destructor Documentation

APDYNAMICART::ColorGenAdapter::ColorGenAdapter ( )
inline

Member Function Documentation

virtual osg::Vec4 APDYNAMICART::ColorGenAdapter::getColor ( )
inlinevirtual

Reimplemented in APDYNAMICART::GradientColorAdapter, and APDYNAMICART::ConstantColorAdapter.

int APDYNAMICART::ColorGenAdapter::getColorIndex ( ) const
inline
virtual void APDYNAMICART::ColorGenAdapter::setColor ( const osg::Vec4 & color )
inlinevirtual

Reimplemented in APDYNAMICART::GradientColorAdapter, and APDYNAMICART::ConstantColorAdapter.

void APDYNAMICART::ColorGenAdapter::setColorIndex ( int val )
inline

Member Data Documentation

int APDYNAMICART::ColorGenAdapter::_colorIndex
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ConstantColorAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ConstantColorAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::ConstantColorAdapter Class Reference

#include <ColorGenAdapter.h>

Inheritance diagram for APDYNAMICART::ConstantColorAdapter:
APDYNAMICART::ColorGenAdapter APDYNAMICART::PoAAdapter< ColorGen >

Public Member Functions

ConstantColorAdapter ()
ConstantColorAdapter (const osg::Vec4 &color)
META_DAObject (ConstantColorAdapter,"Constant") virtual void createMenu(MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual void | setColor (const osg::Vec4 &color)
virtual ColorGenPtr | getObject ()
returns adapted object More...
virtual osg::Vec4 | getColor ()
- Public Member Functions inherited from APDYNAMICART::ColorGenAdapter
ColorGenAdapter ()
int | getColorIndex () const
void | setColorIndex (int val)
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< ConstantColorGen > | _colorGen
- Protected Attributes inherited from APDYNAMICART::ColorGenAdapter
int | _colorIndex

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual ~PoAAdapter ()

Detailed Description

Constant color adapter

Constructor & Destructor Documentation

APDYNAMICART::ConstantColorAdapter::ConstantColorAdapter ( )
inline
APDYNAMICART::ConstantColorAdapter::ConstantColorAdapter ( const osg::Vec4 & color )
inline

Member Function Documentation

virtual osg::Vec4 APDYNAMICART::ConstantColorAdapter::getColor ( )
inlinevirtual

Reimplemented from APDYNAMICART::ColorGenAdapter.

virtual ColorGenPtr APDYNAMICART::ConstantColorAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< ColorGen >.

int ConstantColorAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

load data from given XML node

Reimplemented from APDYNAMICART::PoAAdapter< ColorGen >.

APDYNAMICART::ConstantColorAdapter::META_DAObject | ( | ConstantColorAdapter | ,
 |  | "Constant" |
 | ) |  |
void ConstantColorAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< ColorGen >.

virtual void APDYNAMICART::ConstantColorAdapter::setColor ( const osg::Vec4 & color )
inlinevirtual

Reimplemented from APDYNAMICART::ColorGenAdapter.

Member Data Documentation

osg::ref_ptr<ConstantColorGen> APDYNAMICART::ConstantColorAdapter::_colorGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ColorGenAdapter.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::GradientColorAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • GradientColorAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::GradientColorAdapter Class Reference

#include <ColorGenAdapter.h>

Inheritance diagram for APDYNAMICART::GradientColorAdapter:
APDYNAMICART::ColorGenAdapter APDYNAMICART::PoAAdapter< ColorGen >

Public Member Functions

GradientColorAdapter ()
GradientColorAdapter (const osg::Vec4 &color1, const osg::Vec4 &color2)
META_DAObject (GradientColorAdapter,"Gradient") virtual void createMenu(MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual ColorGenPtr | getObject ()
returns adapted object More...
virtual void | setColor (const osg::Vec4 &color)
virtual osg::Vec4 | getColor ()
- Public Member Functions inherited from APDYNAMICART::ColorGenAdapter
ColorGenAdapter ()
int | getColorIndex () const
void | setColorIndex (int val)
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< GradientColorGen > | _colorGen
- Protected Attributes inherited from APDYNAMICART::ColorGenAdapter
int | _colorIndex

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< ColorGen >
virtual ~PoAAdapter ()

Detailed Description

Gradient color adapter

Constructor & Destructor Documentation

APDYNAMICART::GradientColorAdapter::GradientColorAdapter ( )
inline
APDYNAMICART::GradientColorAdapter::GradientColorAdapter | ( | const osg::Vec4 & | color1,
 |  | const osg::Vec4 & | color2
 | ) |  |
inline

Member Function Documentation

virtual osg::Vec4 APDYNAMICART::GradientColorAdapter::getColor ( )
inlinevirtual

Reimplemented from APDYNAMICART::ColorGenAdapter.

virtual ColorGenPtr APDYNAMICART::GradientColorAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< ColorGen >.

int APDYNAMICART::GradientColorAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

load data from given XML node

Reimplemented from APDYNAMICART::PoAAdapter< ColorGen >.

APDYNAMICART::GradientColorAdapter::META_DAObject | ( | GradientColorAdapter | ,
 |  | "Gradient" |
 | ) |  |
void GradientColorAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< ColorGen >.

void APDYNAMICART::GradientColorAdapter::setColor ( const osg::Vec4 & color )
virtual

Reimplemented from APDYNAMICART::ColorGenAdapter.

Member Data Documentation

osg::ref_ptr<GradientColorGen> APDYNAMICART::GradientColorAdapter::_colorGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ColorGenAdapter.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ColorGenFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ColorGenFactory
Public Member Functions | List of all members
APDYNAMICART::ColorGenFactory Class Reference

#include <ColorGenAdapter.h>

Inheritance diagram for APDYNAMICART::ColorGenFactory:
APDYNAMICART::AdapterFactory< ColorGenAdapter >

Public Member Functions

ColorGenFactory ()
ColorGenFactory (const ColorGenFactory &orig)
- Public Member Functions inherited from APDYNAMICART::AdapterFactory< ColorGenAdapter >
const std::vector
< osg::ref_ptr
< ColorGenAdapter > > & 		getSupportedAdapters () const
osg::ref_ptr< ColorGenAdapter > getAdapter (const std::string &className)

Additional Inherited Members

- Protected Attributes inherited from APDYNAMICART::AdapterFactory< ColorGenAdapter >
std::vector< osg::ref_ptr
< ColorGenAdapter > > 		_adapters

Detailed Description

Sector color adapter Factory for color generator adapters

Constructor & Destructor Documentation

APDYNAMICART::ColorGenFactory::ColorGenFactory ( )
inline
APDYNAMICART::ColorGenFactory::ColorGenFactory ( const ColorGenFactory & orig )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::IComputeStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IComputeStrategy
Public Member Functions | List of all members
APDYNAMICART::IComputeStrategy Class Referenceabstract

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::IComputeStrategy:
APDYNAMICART::IkedaStrategy APDYNAMICART::Lorenz84Strategy APDYNAMICART::LorenzStrategy APDYNAMICART::NullStrategy APDYNAMICART::PickoverStrategy APDYNAMICART::PolynomialStrategy APDYNAMICART::RosslerStrategy

Public Member Functions

virtual osg::Vec3 | getNextPoint (double x, double y, double z, const Parameters &params)=0
virtual double | getDefaultSize ()=0
virtual | ~IComputeStrategy ()
virtual std::string const | AttractorName ()=0

Constructor & Destructor Documentation

virtual APDYNAMICART::IComputeStrategy::~IComputeStrategy ( )
inlinevirtual

Member Function Documentation

virtual std::string const APDYNAMICART::IComputeStrategy::AttractorName ( )
pure virtual
virtual double APDYNAMICART::IComputeStrategy::getDefaultSize ( )
pure virtual
virtual osg::Vec3 APDYNAMICART::IComputeStrategy::getNextPoint | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | const Parameters & | params
 | ) |  |
pure virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullStrategy
List of all members
APDYNAMICART::NullStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::NullStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::LorenzStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LorenzStrategy
List of all members
APDYNAMICART::LorenzStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::LorenzStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Lorenz84Strategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Lorenz84Strategy
List of all members
APDYNAMICART::Lorenz84Strategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::Lorenz84Strategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PickoverStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PickoverStrategy
List of all members
APDYNAMICART::PickoverStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::PickoverStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RosslerStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RosslerStrategy
List of all members
APDYNAMICART::RosslerStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::RosslerStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PolynomialStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolynomialStrategy
List of all members
APDYNAMICART::PolynomialStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::PolynomialStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::IkedaStrategy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IkedaStrategy
List of all members
APDYNAMICART::IkedaStrategy Class Reference

#include <ComputeStrategy.h>

Inheritance diagram for APDYNAMICART::IkedaStrategy:
APDYNAMICART::IComputeStrategy

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IComputeStrategy
virtual ~IComputeStrategy ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::InitSettings Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • InitSettings
Public Attributes | List of all members
APDYNAMICART::InitSettings Struct Reference

#include <ComputeThread.h>

Public Attributes

IComputeStrategyPtr strategy
Parameters params
float | size
int | settleIterations
int | iterationCount
int | interpolationSteps
bool | randomRun

Member Data Documentation

int APDYNAMICART::InitSettings::interpolationSteps
int APDYNAMICART::InitSettings::iterationCount
Parameters APDYNAMICART::InitSettings::params
bool APDYNAMICART::InitSettings::randomRun
int APDYNAMICART::InitSettings::settleIterations
float APDYNAMICART::InitSettings::size
IComputeStrategyPtr APDYNAMICART::InitSettings::strategy
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeThread.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ComputeThread Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ComputeThread
Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
APDYNAMICART::ComputeThread Class Reference

#include <ComputeThread.h>

Inheritance diagram for APDYNAMICART::ComputeThread:

Public Member Functions

ComputeThread ()
virtual void | run ()
bool | isTooSmall (int i, int iter)
virtual int | cancel ()
void | init (const InitSettings &settings)
bool | getData (osg::Vec3Array *points, osg::Vec4Array *colors, Limits &limits, Parameters &params)
void | addPoint (osg::Vec3 point)
void | setColor (osg::Vec4 color, int index)
void | interpolatePoints ()

Protected Attributes

bool | _dirty
bool | _done
OpenThreads::Mutex | _mutex
Vec3ArrayPtr _points
Vec4ArrayPtr _colors
Limits _lim
InitSettings _conf
osg::Vec3 | _initPoint

Static Protected Attributes

static std::tr1::mt19937 eng

Constructor & Destructor Documentation

APDYNAMICART::ComputeThread::ComputeThread ( )

Inherited methods

Member Function Documentation

void APDYNAMICART::ComputeThread::addPoint ( osg::Vec3 point )
int APDYNAMICART::ComputeThread::cancel ( )
virtual
bool APDYNAMICART::ComputeThread::getData | ( | osg::Vec3Array * | points,
 |  | osg::Vec4Array * | colors,
 |  | Limits & | limits,
 |  | Parameters & | params
 | ) |  |
void APDYNAMICART::ComputeThread::init ( const InitSettings & settings )

Helper methods

void APDYNAMICART::ComputeThread::interpolatePoints ( )
bool APDYNAMICART::ComputeThread::isTooSmall | ( | int | i,
 |  | int | iter
 | ) |  |
void APDYNAMICART::ComputeThread::run ( )
virtual
void APDYNAMICART::ComputeThread::setColor | ( | osg::Vec4 | color,
 |  | int | index
 | ) |  |

Member Data Documentation

Vec4ArrayPtr APDYNAMICART::ComputeThread::_colors
protected
InitSettings APDYNAMICART::ComputeThread::_conf
protected
bool APDYNAMICART::ComputeThread::_dirty
protected
bool APDYNAMICART::ComputeThread::_done
protected
osg::Vec3 APDYNAMICART::ComputeThread::_initPoint
protected
Limits APDYNAMICART::ComputeThread::_lim
protected
OpenThreads::Mutex APDYNAMICART::ComputeThread::_mutex
protected
Vec3ArrayPtr APDYNAMICART::ComputeThread::_points
protected
std::tr1::mt19937 APDYNAMICART::ComputeThread::eng
staticprotected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeThread.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ComputeThread.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Configuration Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Configuration
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::Configuration Struct Reference

#include <Configuration.h>

Public Member Functions

Configuration * get ()

Public Attributes

float sculptureSize
IShapeGeneratorPtr shapeCurveGenerator
IShapeGeneratorPtr crossSectionGenerator

Member Function Documentation

Configuration* APDYNAMICART::Configuration::get ( )
inline

Member Data Documentation

IShapeGeneratorPtr APDYNAMICART::Configuration::crossSectionGenerator
float APDYNAMICART::Configuration::sculptureSize

Items

IShapeGeneratorPtr APDYNAMICART::Configuration::shapeCurveGenerator
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Configuration.h
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Controller Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Controller
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Controller Class Referenceabstract

#include <Controller.h>

Inheritance diagram for APDYNAMICART::Controller:
vrecko::Ability vrecko::BaseClass APDYNAMICART::Ctrl_Attractor APDYNAMICART::Ctrl_FreeHandPainting APDYNAMICART::Ctrl_PerlinLines APDYNAMICART::Ctrl_PolyhedraSculptures APDYNAMICART::Ctrl_StringSculptures APDYNAMICART::Ctrl_MotionVisualization

Public Member Functions

Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
virtual void | activateTool ()=0
Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button. More...
virtual void | clear ()=0
clear controller - called before new scene is created or loaded More...
void | clearAllPoAs ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0
Creates structure of menu items for this Controller. More...
virtual void | deactivateTool ()=0
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
virtual void | debugKeyPressed ()=0
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
virtual void | guiItemClicked (const char *itemID)=0
Called when user click on some item of GUI - icon, slider, menu item, ... More...
virtual void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)=0
bool | isEmpty ()
virtual void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)=0
Load controller parameters and all PoAs from XML nodes. More...
virtual void | guiSliderChanged (const char *sliderID, float sliderPos)=0
Called when user moves with some GUI slider (menu sliders counts as well) More...
void | preInitialize ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | removePoA (PoA *toRemove)
Remove single PoA. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)=0
save controller settings (if there are some) and all PoAs to XML node More...
virtual DAToolType | getNextToolType ()
set pointer to Dynamic Art Environment ability More...
virtual void | switchTools (DAToolType newType)
switching between tools More...
virtual void | turnOn ()=0
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
virtual void | turnOff (void)=0
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
virtual void | update ()=0
Scheduled for per-frame updates. More...
std::vector< ref_ptr_PoA > * | getPoAs ()
virtual void | setColour (osg::Vec4 newColour)
virtual void | switchGUIVisibility ()=0
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static const PoAType getType (std::string type)

Protected Member Functions

void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Controller::Controller | ( | const char * | controllerID,
 |  | const char * | description,
 |  | PoAType | type
 | ) |  |
Parameters
controllerID | ability name - serves as ID, must be unique for each controller. Without space (due to xml parsing).
description | - user friendly name of this context / controller - may contain spaces, ...
type | type of PoAs controlled by this controller.
Returns
APDYNAMICART::Controller::~Controller ( )

Member Function Documentation

virtual void APDYNAMICART::Controller::activateTool ( )
pure virtual

Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button.

do whatever is necessary before activation of tool

  • e.g. create new PoA
  • set "link" between Tool and PoA(s)

activate current tool (or multiple tools)

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, APDYNAMICART::Ctrl_PolyhedraSculptures, and APDYNAMICART::Ctrl_PerlinLines.

void APDYNAMICART::Controller::clear ( void )
pure virtual

clear controller - called before new scene is created or loaded

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, APDYNAMICART::Ctrl_PolyhedraSculptures, and APDYNAMICART::Ctrl_PerlinLines.

void APDYNAMICART::Controller::clearAllPoAs ( )
virtual void APDYNAMICART::Controller::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
pure virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, APDYNAMICART::Ctrl_PerlinLines, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::deactivateTool ( )
pure virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::debugKeyPressed ( )
pure virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

float APDYNAMICART::Controller::getDaareaScale ( ) const
inline

scale of dynamic art area

const char* APDYNAMICART::Controller::getDescription ( void ) const
inline
APDYNAMICART::DAToolType APDYNAMICART::Controller::getNextToolType ( )
virtual

set pointer to Dynamic Art Environment ability

called from _daEnvironment during adding controller to environment If you need more control, override this method in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented in APDYNAMICART::Ctrl_FreeHandPainting, and APDYNAMICART::Ctrl_PerlinLines.

std::vector<ref_ptr_PoA>* APDYNAMICART::Controller::getPoAs ( )
inline
const char* APDYNAMICART::Controller::getPoAsName ( void ) const
inline

Return name of ...

const PoAType APDYNAMICART::Controller::getType ( void ) const
inline

Returns type of this controller.

const PoAType APDYNAMICART::Controller::getType ( std::string type )
static
virtual void APDYNAMICART::Controller::guiItemClicked ( const char * itemID )
pure virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_Attractor, APDYNAMICART::Ctrl_StringSculptures, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
pure virtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implemented in APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
pure virtual

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

void APDYNAMICART::Controller::initTools ( )
protected

Init available tools (filled in _tools)

bool APDYNAMICART::Controller::isEmpty ( )
inline
Returns
true if controller have 0 PoAs, false elsewhere
virtual void APDYNAMICART::Controller::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
pure virtual

Load controller parameters and all PoAs from XML nodes.

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

void APDYNAMICART::Controller::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Set proper pointer

Schedule controller to regular updates - all loaded controllers DO their updates all the time

Reimplemented from vrecko::BaseClass.

Reimplemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, and APDYNAMICART::Ctrl_PerlinLines.

void APDYNAMICART::Controller::preInitialize ( void )
virtual

This methods provide basic controller initialization. If you need more control, override them in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented from vrecko::BaseClass.

Reimplemented in APDYNAMICART::Ctrl_FreeHandPainting, and APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Controller::removePoA ( PoA * toRemove )

Remove single PoA.

virtual void APDYNAMICART::Controller::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
pure virtual

save controller settings (if there are some) and all PoAs to XML node

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

void APDYNAMICART::Controller::setColour ( osg::Vec4 newColour )
virtual

Reimplemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_StringSculptures, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::switchGUIVisibility ( )
pure virtual

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

void APDYNAMICART::Controller::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::turnOff ( void )
pure virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::turnOn ( )
pure virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implemented in APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_Attractor, and APDYNAMICART::Ctrl_PolyhedraSculptures.

virtual void APDYNAMICART::Controller::update ( )
pure virtual

Scheduled for per-frame updates.

Reimplemented from vrecko::BaseClass.

Implemented in APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::Ctrl_StringSculptures, APDYNAMICART::Ctrl_PolyhedraSculptures, and APDYNAMICART::Ctrl_Attractor.

Member Data Documentation

DATool* APDYNAMICART::Controller::_actualTool
protected

pointer to actual tool

EnvironmentObject* APDYNAMICART::Controller::_artArea
protected

Art Area = owner of this ability.

DAEnvironment* APDYNAMICART::Controller::_daEnvironment
protected

pointer to DA environment

const char* APDYNAMICART::Controller::_description
protected

users friendly name of controller / context... such as "Free-hand Painting". Appears in menus.

std::vector<ref_ptr_PoA>* APDYNAMICART::Controller::_poas
protected

vector containing all PoAs of this controller

const char* APDYNAMICART::Controller::_poasName
protected

ID for PoA (e.g. Attractor, BrushStroke, MotionTrail,..). It's use as a XML tag when loading/saving PoAs it should be unique for each controller and contain no spaces (due to xml parsing)

DATools APDYNAMICART::Controller::_tools
protected

Available tools.

const PoAType APDYNAMICART::Controller::_type
protected

Type of this controller - type of contained PoAs.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Controller.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Controller.cpp
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_Attractor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_Attractor
Public Member Functions | List of all members
APDYNAMICART::Ctrl_Attractor Class Reference

#include <Ctrl_Attractor.h>

Inheritance diagram for APDYNAMICART::Ctrl_Attractor:
APDYNAMICART::Controller vrecko::Ability vrecko::BaseClass

Public Member Functions

Ctrl_Attractor ()
void | activateTool ()
void | clear ()
clear controller - called before new scene is created or loaded More...
void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
void | createColorSubMenu (std::ostringstream &menuSS, Attractor *att) const
ref_ptr_PoA createPoA ()
void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
Load controller parameters and all PoAs from XML nodes. More...
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
void | update ()
Scheduled for per-frame updates. More...
void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
void | guiSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with some GUI slider (menu sliders counts as well) More...
void | switchGUIVisibility ()
void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
void | turnOff ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | preInitialize ()
void | removePoA (PoA *toRemove)
Remove single PoA. More...
virtual DAToolType | getNextToolType ()
set pointer to Dynamic Art Environment ability More...
virtual void | switchTools (DAToolType newType)
switching between tools More...
std::vector< ref_ptr_PoA > * | getPoAs ()
virtual void | setColour (osg::Vec4 newColour)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType | getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...

Detailed Description

Controller class for attractor management

Author
Martin Bezdeka, Jiri Chmelik
Date
Id:
Ctrl_Attractor.h 436 2012-10-12 08:57:42Z xchmeli1

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_Attractor::Ctrl_Attractor ( )

Constructor

Member Function Documentation

void APDYNAMICART::Ctrl_Attractor::activateTool ( )
virtual

Inherited methods from Controller

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::createColorSubMenu | ( | std::ostringstream & | menuSS,
 |  | Attractor * | att
 | ) |  | const
void APDYNAMICART::Ctrl_Attractor::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implements APDYNAMICART::Controller.

ref_ptr_PoA APDYNAMICART::Ctrl_Attractor::createPoA ( )
void APDYNAMICART::Ctrl_Attractor::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::debugKeyPressed ( )
inlinevirtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::guiItemClicked ( const char * itemID )
virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlinevirtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
virtual

Load controller parameters and all PoAs from XML nodes.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
virtual

save controller settings (if there are some) and all PoAs to XML node

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::switchGUIVisibility ( )
inlinevirtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::turnOff ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_Attractor::update ( )
virtual

Scheduled for per-frame updates.

Implements APDYNAMICART::Controller.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_Attractor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_Attractor.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_FreeHandPainting Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_FreeHandPainting
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ctrl_FreeHandPainting Class Reference

controller of Brush Stroke PoA More...

#include <Ctrl_FreeHandPainting.h>

Inheritance diagram for APDYNAMICART::Ctrl_FreeHandPainting:
APDYNAMICART::Controller vrecko::Ability vrecko::BaseClass APDYNAMICART::Ctrl_MotionVisualization

Public Member Functions

Ctrl_FreeHandPainting ()
warning IDs of controllers must contain NO spaces (because of XML parsing) More...
Ctrl_FreeHandPainting (const char *abName, const char *contextName, PoAType type)
~Ctrl_FreeHandPainting ()
void | activateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button. More...
void | clear ()
clear controller - called before new scene is created or loaded More...
void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
osg::ref_ptr< PoA > | createPoA ()
Crete new instance of BrushStroke object. More...
void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
DAToolType getNextToolType ()
set pointer to Dynamic Art Environment ability More...
double | getPaintingDuration ()
return how long the painting takes More...
void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
void | guiSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with some GUI slider (menu sliders counts as well) More...
int | importScene (const string &fileName)
Import scene from old Modeller plug-in. More...
void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
Load controller parameters and all PoAs from XML nodes. More...
void | processEvent (const std::string &input_name, void *value)
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
void | setColour (osg::Vec4 newColour)
void | switchGUIVisibility ()
void | switchTools (DAToolType newType)
switching between tools More...
void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
void | turnOff ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
void | update ()
Scheduled for per-frame updates. More...
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | removePoA (PoA *toRemove)
Remove single PoA. More...
std::vector< ref_ptr_PoA > * | getPoAs ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

std::string | getShowControlPointsString () const
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | preInitialize ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | playback (double _playbackTime)
string | getPlaybackTimeText ()
void | recomputeStrokesTimes ()
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | _firstTimeUpdate
solve initialization timing problems... first time update is used as last part of initialization, More...
BrushPtr _brush
default brush More...
bool | _showControlPoints
Flag determining if control points should be visualized by SimpleBoxes. More...
ToolBrush * _toolBrush
ToolTongs * _toolTongs
common tool for basic manipulation with PoAs More...
ToolEraser * _toolEraser
tool for deleting strokes More...
bool | _playbackActive
is playback active? More...
PlaybackType _playbackType
type of playback More...
double | _playbackTime
actual playback time More...
time_t | _lastPlaybackTime
last actualized playback time More...
time_t | _nowTime
APGUI::Slider * _playbackSlider
pointer to slider GUI item More...
APGUI::Icon * _playbackIcon
APGUI::Menu * _menuAbility
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

controller of Brush Stroke PoA

Controls Brush Strokes PoA manage tools, brushes definitions and other stuff

Author
Jiri Chmelik
Date
2010-...

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_FreeHandPainting::Ctrl_FreeHandPainting ( )

warning IDs of controllers must contain NO spaces (because of XML parsing)

APDYNAMICART::Ctrl_FreeHandPainting::Ctrl_FreeHandPainting | ( | const char * | abName,
 |  | const char * | contextName,
 |  | PoAType | type
 | ) |  |
APDYNAMICART::Ctrl_FreeHandPainting::~Ctrl_FreeHandPainting ( )

Member Function Documentation

void APDYNAMICART::Ctrl_FreeHandPainting::activateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button.

do whatever is necessary before activation of tool

  • e.g. create new PoA
  • set "link" between Tool and PoA(s)

activate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implements APDYNAMICART::Controller.

osg::ref_ptr< PoA > APDYNAMICART::Ctrl_FreeHandPainting::createPoA ( )

Crete new instance of BrushStroke object.

Creates new Brush Stroke object, set pointers, adds it to scene.

Returns
reference pointer to new object
void APDYNAMICART::Ctrl_FreeHandPainting::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::debugKeyPressed ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implements APDYNAMICART::Controller.

APDYNAMICART::DAToolType APDYNAMICART::Ctrl_FreeHandPainting::getNextToolType ( )
virtual

set pointer to Dynamic Art Environment ability

called from _daEnvironment during adding controller to environment If you need more control, override this method in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented from APDYNAMICART::Controller.

double APDYNAMICART::Ctrl_FreeHandPainting::getPaintingDuration ( )

return how long the painting takes

More possibilities how to compute exists...

Returns
how long the painting takes
std::string APDYNAMICART::Ctrl_FreeHandPainting::getPlaybackTimeText ( )
protected
std::string APDYNAMICART::Ctrl_FreeHandPainting::getShowControlPointsString ( ) const
inlineprotected
void APDYNAMICART::Ctrl_FreeHandPainting::guiItemClicked ( const char * itemID )
virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_FreeHandPainting::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

int APDYNAMICART::Ctrl_FreeHandPainting::importScene ( const string & fileName )

Import scene from old Modeller plug-in.

void APDYNAMICART::Ctrl_FreeHandPainting::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
virtual

Load controller parameters and all PoAs from XML nodes.

Implements APDYNAMICART::Controller.

bool APDYNAMICART::Ctrl_FreeHandPainting::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
protectedvirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::playback ( double _playbackTime )
protected
void APDYNAMICART::Ctrl_FreeHandPainting::postInitialize ( void )
protectedvirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Set proper pointer

Schedule controller to regular updates - all loaded controllers DO their updates all the time

Reimplemented from APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::preInitialize ( void )
protectedvirtual

This methods provide basic controller initialization. If you need more control, override them in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented from APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void APDYNAMICART::Ctrl_FreeHandPainting::recomputeStrokesTimes ( )
protected
void APDYNAMICART::Ctrl_FreeHandPainting::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
virtual

save controller settings (if there are some) and all PoAs to XML node

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_FreeHandPainting::setColour ( osg::Vec4 newColour )
virtual

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_FreeHandPainting::switchGUIVisibility ( )
virtual

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented from APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::turnOff ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

void APDYNAMICART::Ctrl_FreeHandPainting::update ( )
virtual

Scheduled for per-frame updates.

Implements APDYNAMICART::Controller.

Reimplemented in APDYNAMICART::Ctrl_MotionVisualization.

Member Data Documentation

BrushPtr APDYNAMICART::Ctrl_FreeHandPainting::_brush
protected

default brush

bool APDYNAMICART::Ctrl_FreeHandPainting::_firstTimeUpdate
protected

solve initialization timing problems... first time update is used as last part of initialization,

time_t APDYNAMICART::Ctrl_FreeHandPainting::_lastPlaybackTime
protected

last actualized playback time

APGUI::Menu* APDYNAMICART::Ctrl_FreeHandPainting::_menuAbility
protected
time_t APDYNAMICART::Ctrl_FreeHandPainting::_nowTime
protected
bool APDYNAMICART::Ctrl_FreeHandPainting::_playbackActive
protected

is playback active?

APGUI::Icon* APDYNAMICART::Ctrl_FreeHandPainting::_playbackIcon
protected
APGUI::Slider* APDYNAMICART::Ctrl_FreeHandPainting::_playbackSlider
protected

pointer to slider GUI item

double APDYNAMICART::Ctrl_FreeHandPainting::_playbackTime
protected

actual playback time

PlaybackType APDYNAMICART::Ctrl_FreeHandPainting::_playbackType
protected

type of playback

bool APDYNAMICART::Ctrl_FreeHandPainting::_showControlPoints
protected

Flag determining if control points should be visualized by SimpleBoxes.

ToolBrush* APDYNAMICART::Ctrl_FreeHandPainting::_toolBrush
protected
ToolEraser* APDYNAMICART::Ctrl_FreeHandPainting::_toolEraser
protected

tool for deleting strokes

ToolTongs* APDYNAMICART::Ctrl_FreeHandPainting::_toolTongs
protected

common tool for basic manipulation with PoAs

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_FreeHandPainting.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_FreeHandPainting.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_MotionVisualization Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_MotionVisualization
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ctrl_MotionVisualization Class Reference

controller of Motion Trail PoAs More...

#include <Ctrl_MotionVisualization.h>

Inheritance diagram for APDYNAMICART::Ctrl_MotionVisualization:
APDYNAMICART::Ctrl_FreeHandPainting APDYNAMICART::Controller vrecko::Ability vrecko::BaseClass

Public Member Functions

Ctrl_MotionVisualization ()
~Ctrl_MotionVisualization ()
void | activateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button. More...
void | clear ()
clear controller - called before new scene is created or loaded More...
std::string | createMenuStructure (void) const
osg::ref_ptr< PoA > | createPoA ()
Crete new instance of MotionTrail object. More...
void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
void | guiSliderChanged (const char *sliderID, float sliderPos)
void | setSensorCount (int newCount)
void | switchGUIVisibility ()
void | switchTools (DAToolType newType)
switching between tools More...
void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
void | turnOff ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
- Public Member Functions inherited from APDYNAMICART::Ctrl_FreeHandPainting
Ctrl_FreeHandPainting ()
warning IDs of controllers must contain NO spaces (because of XML parsing) More...
Ctrl_FreeHandPainting (const char *abName, const char *contextName, PoAType type)
~Ctrl_FreeHandPainting ()
void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
osg::ref_ptr< PoA > | createPoA ()
Crete new instance of BrushStroke object. More...
void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
DAToolType getNextToolType ()
set pointer to Dynamic Art Environment ability More...
double | getPaintingDuration ()
return how long the painting takes More...
void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
int | importScene (const string &fileName)
Import scene from old Modeller plug-in. More...
void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
Load controller parameters and all PoAs from XML nodes. More...
void | processEvent (const std::string &input_name, void *value)
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
void | setColour (osg::Vec4 newColour)
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | removePoA (PoA *toRemove)
Remove single PoA. More...
std::vector< ref_ptr_PoA > * | getPoAs ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | preInitialize ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | turnOnTool (DAToolType type)
Turn on given tool or tools - used only during turning on of this controller. More...
void | turnOffTool (DAToolType type)
Turn off given tool or tools - used only during turning off of this controller. More...
void | update ()
Scheduled for per-frame updates. More...
DECLARE_OUTPUT (SetSensorsCount, MessageInt)
- Protected Member Functions inherited from APDYNAMICART::Ctrl_FreeHandPainting
std::string | getShowControlPointsString () const
void | playback (double _playbackTime)
string | getPlaybackTimeText ()
void | recomputeStrokesTimes ()
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

int | _sensorCount
number of actually tracked input sensors More...
ToolBrush * _toolBrushes [MAX_NUMBER_OF_TRACKED_SENSORS]
- Protected Attributes inherited from APDYNAMICART::Ctrl_FreeHandPainting
bool | _firstTimeUpdate
solve initialization timing problems... first time update is used as last part of initialization, More...
BrushPtr _brush
default brush More...
bool | _showControlPoints
Flag determining if control points should be visualized by SimpleBoxes. More...
ToolBrush * _toolBrush
ToolTongs * _toolTongs
common tool for basic manipulation with PoAs More...
ToolEraser * _toolEraser
tool for deleting strokes More...
bool | _playbackActive
is playback active? More...
PlaybackType _playbackType
type of playback More...
double | _playbackTime
actual playback time More...
time_t | _lastPlaybackTime
last actualized playback time More...
time_t | _nowTime
APGUI::Slider * _playbackSlider
pointer to slider GUI item More...
APGUI::Icon * _playbackIcon
APGUI::Menu * _menuAbility
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

controller of Motion Trail PoAs

Controls Motion Trails PoA manage tools, brushes definitions and other stuff

most function are inherited from Free Hand Painting controller

Author
Jiri Chmelik
Date
2010-...

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_MotionVisualization::Ctrl_MotionVisualization ( )
APDYNAMICART::Ctrl_MotionVisualization::~Ctrl_MotionVisualization ( )

Member Function Documentation

void APDYNAMICART::Ctrl_MotionVisualization::activateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user press "useTool" button.

do whatever is necessary before activation of tool

  • e.g. create new PoA
  • set "link" between Tool and PoA(s)

activate current tool (or multiple tools)

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

std::string APDYNAMICART::Ctrl_MotionVisualization::createMenuStructure ( void ) const
osg::ref_ptr< PoA > APDYNAMICART::Ctrl_MotionVisualization::createPoA ( )

Crete new instance of MotionTrail object.

Creates new Motion Trail object, set pointers, adds it to scene.

Returns
reference pointer to new object
void APDYNAMICART::Ctrl_MotionVisualization::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

APDYNAMICART::Ctrl_MotionVisualization::DECLARE_OUTPUT | ( | SetSensorsCount | ,
 |  | MessageInt |
 | ) |  |
protected
void APDYNAMICART::Ctrl_MotionVisualization::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

not used

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

bool APDYNAMICART::Ctrl_MotionVisualization::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
protectedvirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::postInitialize ( void )
protectedvirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Set proper pointer

Schedule controller to regular updates - all loaded controllers DO their updates all the time

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::preInitialize ( void )
protectedvirtual

This methods provide basic controller initialization. If you need more control, override them in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::setSensorCount ( int newCount )
void APDYNAMICART::Ctrl_MotionVisualization::switchGUIVisibility ( )
virtual

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::turnOff ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::turnOffTool ( DAToolType type )
protected

Turn off given tool or tools - used only during turning off of this controller.

void APDYNAMICART::Ctrl_MotionVisualization::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

void APDYNAMICART::Ctrl_MotionVisualization::turnOnTool ( DAToolType type )
protected

Turn on given tool or tools - used only during turning on of this controller.

void APDYNAMICART::Ctrl_MotionVisualization::update ( )
protectedvirtual

Scheduled for per-frame updates.

Reimplemented from APDYNAMICART::Ctrl_FreeHandPainting.

Member Data Documentation

int APDYNAMICART::Ctrl_MotionVisualization::_sensorCount
protected

number of actually tracked input sensors

ToolBrush* APDYNAMICART::Ctrl_MotionVisualization::_toolBrushes[MAX_NUMBER_OF_TRACKED_SENSORS]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_MotionVisualization.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_MotionVisualization.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_PerlinLines Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_PerlinLines
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ctrl_PerlinLines Class Reference

#include <Ctrl_PerlinLines.h>

Inheritance diagram for APDYNAMICART::Ctrl_PerlinLines:
APDYNAMICART::Controller vrecko::Ability vrecko::BaseClass

Public Member Functions

Ctrl_PerlinLines ()
warning names of controllers must contain NO spaces (because of XML parsing) More...
void | activateTool ()
void | setParameters ()
void | clear ()
clear controller - called before new scene is created or loaded More...
void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
ref_ptr_PoA | createPoA (int count, double x, double y, double z)
ref_ptr_PoA | createMag (osg::Vec3 coords)
DAToolType getNextToolType ()
set pointer to Dynamic Art Environment ability More...
double | random (double min, double max)
void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
Load controller parameters and all PoAs from XML nodes. More...
void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
void | guiSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with some GUI slider (menu sliders counts as well) More...
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
void | switchGUIVisibility ()
void | update ()
Scheduled for per-frame updates. More...
void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
void | turnOff ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
void | switchTools (DAToolType newType)
switching between tools More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | preInitialize ()
void | removePoA (PoA *toRemove)
Remove single PoA. More...
std::vector< ref_ptr_PoA > * | getPoAs ()
virtual void | setColour (osg::Vec4 newColour)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

double | autoRotationStep
angle to rotate aech frame; More...
osg::Timer_t | lastAutorotationTime
osg::Timer_t | nowAutorotationTime

Protected Member Functions

void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
DECLARE_INPUT (Position_sensor_0, MessageVec3)
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector< PerlinLines * > | pl
u_int | _speed
u_int | _interpolationCount
u_int | _length
string | posString
float | _red
float | _green
float | _blue
double | _magnetSize
double | _boundingSize
bool | bounding
bool | boundingVisible
bool | magnetCreated
bool | boundingCreated
EnvironmentObject * magnetEO
osg::Vec3 | rightHandPosition
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_PerlinLines::Ctrl_PerlinLines ( )

warning names of controllers must contain NO spaces (because of XML parsing)

Constructor

Member Function Documentation

void APDYNAMICART::Ctrl_PerlinLines::activateTool ( )
virtual

Inherited methods from Controller

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Implements APDYNAMICART::Controller.

ref_ptr_PoA APDYNAMICART::Ctrl_PerlinLines::createMag ( osg::Vec3 coords )
void APDYNAMICART::Ctrl_PerlinLines::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implements APDYNAMICART::Controller.

ref_ptr_PoA APDYNAMICART::Ctrl_PerlinLines::createPoA | ( | int | count,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
void APDYNAMICART::Ctrl_PerlinLines::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::debugKeyPressed ( )
inlinevirtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implements APDYNAMICART::Controller.

APDYNAMICART::Ctrl_PerlinLines::DECLARE_INPUT | ( | Position_sensor_0 | ,
 |  | MessageVec3 |
 | ) |  |
protected
APDYNAMICART::DAToolType APDYNAMICART::Ctrl_PerlinLines::getNextToolType ( )
virtual

set pointer to Dynamic Art Environment ability

called from _daEnvironment during adding controller to environment If you need more control, override this method in your inherited class.

Warning
: When overriding, don't forget to call parent function first in order to correct variable initialize!

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::guiItemClicked ( const char * itemID )
virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
virtual

Load controller parameters and all PoAs from XML nodes.

Implements APDYNAMICART::Controller.

bool APDYNAMICART::Ctrl_PerlinLines::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::Ctrl_PerlinLines::postInitialize ( void )
protectedvirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Set proper pointer

Schedule controller to regular updates - all loaded controllers DO their updates all the time

Reimplemented from APDYNAMICART::Controller.

double APDYNAMICART::Ctrl_PerlinLines::random | ( | double | min,
 |  | double | max
 | ) |  |
inline
void APDYNAMICART::Ctrl_PerlinLines::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
virtual

save controller settings (if there are some) and all PoAs to XML node

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::setParameters ( )
void APDYNAMICART::Ctrl_PerlinLines::switchGUIVisibility ( )
inlinevirtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::turnOff ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PerlinLines::update ( )
virtual

Scheduled for per-frame updates.

Implements APDYNAMICART::Controller.

Member Data Documentation

float APDYNAMICART::Ctrl_PerlinLines::_blue
protected
double APDYNAMICART::Ctrl_PerlinLines::_boundingSize
protected
float APDYNAMICART::Ctrl_PerlinLines::_green
protected
u_int APDYNAMICART::Ctrl_PerlinLines::_interpolationCount
protected
u_int APDYNAMICART::Ctrl_PerlinLines::_length
protected
double APDYNAMICART::Ctrl_PerlinLines::_magnetSize
protected
float APDYNAMICART::Ctrl_PerlinLines::_red
protected
u_int APDYNAMICART::Ctrl_PerlinLines::_speed
protected
double APDYNAMICART::Ctrl_PerlinLines::autoRotationStep

angle to rotate aech frame;

bool APDYNAMICART::Ctrl_PerlinLines::bounding
protected
bool APDYNAMICART::Ctrl_PerlinLines::boundingCreated
protected
bool APDYNAMICART::Ctrl_PerlinLines::boundingVisible
protected
osg::Timer_t APDYNAMICART::Ctrl_PerlinLines::lastAutorotationTime
bool APDYNAMICART::Ctrl_PerlinLines::magnetCreated
protected
EnvironmentObject* APDYNAMICART::Ctrl_PerlinLines::magnetEO
protected
osg::Timer_t APDYNAMICART::Ctrl_PerlinLines::nowAutorotationTime
std::vector<PerlinLines*> APDYNAMICART::Ctrl_PerlinLines::pl
protected
string APDYNAMICART::Ctrl_PerlinLines::posString
protected
osg::Vec3 APDYNAMICART::Ctrl_PerlinLines::rightHandPosition
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PerlinLines.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_PerlinLines.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_PolyhedraSculptures Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_PolyhedraSculptures
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ctrl_PolyhedraSculptures Class Reference

#include <Ctrl_PolyhedraSculptures.h>

Inheritance diagram for APDYNAMICART::Ctrl_PolyhedraSculptures:
APDYNAMICART::Controller vrecko::Ability vrecko::BaseClass

Public Member Functions

virtual void | activateTool ()
virtual void | clear ()
clear controller - called before new scene is created or loaded More...
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
void | CreatePoA (const string &polyhedronName)
virtual void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
virtual void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
virtual void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
virtual void | guiSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with some GUI slider (menu sliders counts as well) More...
virtual void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
Load controller parameters and all PoAs from XML nodes. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
virtual void | switchTools (DAToolType newType)
switching between tools More...
virtual void | setColour (osg::Vec4 newColour)
virtual void | switchGUIVisibility ()
virtual void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
virtual void | turnOff (void)
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
virtual void | update ()
Scheduled for per-frame updates. More...
Ctrl_PolyhedraSculptures ()
~Ctrl_PolyhedraSculptures ()
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | preInitialize ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | removePoA (PoA *toRemove)
Remove single PoA. More...
virtual DAToolType | getNextToolType ()
set pointer to Dynamic Art Environment ability More...
std::vector< ref_ptr_PoA > * | getPoAs ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

MenuPtr | createNewPolyhedraMenu () const
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | isThereaSculpture
osg::ref_ptr< PolyhedraSculpture > | _sculpture
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_PolyhedraSculptures::Ctrl_PolyhedraSculptures ( )

Constructor & Destructor

APDYNAMICART::Ctrl_PolyhedraSculptures::~Ctrl_PolyhedraSculptures ( )

Member Function Documentation

void APDYNAMICART::Ctrl_PolyhedraSculptures::activateTool ( )
virtual

Inherited virtual methods - Controller

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implements APDYNAMICART::Controller.

MenuPtr APDYNAMICART::Ctrl_PolyhedraSculptures::createNewPolyhedraMenu ( ) const
protected

Helper methods

void APDYNAMICART::Ctrl_PolyhedraSculptures::CreatePoA ( const string & polyhedronName )
void APDYNAMICART::Ctrl_PolyhedraSculptures::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

virtual void APDYNAMICART::Ctrl_PolyhedraSculptures::debugKeyPressed ( )
inlinevirtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::guiItemClicked ( const char * itemID )
virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
virtual

Load controller parameters and all PoAs from XML nodes.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
virtual

save controller settings (if there are some) and all PoAs to XML node

Implements APDYNAMICART::Controller.

virtual void APDYNAMICART::Ctrl_PolyhedraSculptures::setColour ( osg::Vec4 newColour )
inlinevirtual

Reimplemented from APDYNAMICART::Controller.

virtual void APDYNAMICART::Ctrl_PolyhedraSculptures::switchGUIVisibility ( )
inlinevirtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::turnOff ( void )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_PolyhedraSculptures::update ( )
virtual

Scheduled for per-frame updates.

Implements APDYNAMICART::Controller.

Member Data Documentation

osg::ref_ptr<PolyhedraSculpture> APDYNAMICART::Ctrl_PolyhedraSculptures::_sculpture
protected
bool APDYNAMICART::Ctrl_PolyhedraSculptures::isThereaSculpture
protected

Helper methods

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ctrl_StringSculptures Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_StringSculptures
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ctrl_StringSculptures Class Reference

#include <Ctrl_StringSculptures.h>

Inheritance diagram for APDYNAMICART::Ctrl_StringSculptures:
APDYNAMICART::Controller vreckoUtils::Observer vrecko::Ability vrecko::BaseClass

Public Member Functions

virtual void | activateTool ()
virtual void | clear ()
clear controller - called before new scene is created or loaded More...
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this Controller. More...
virtual void | deactivateTool ()
Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button. More...
virtual void | debugKeyPressed ()
Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default) More...
virtual void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, slider, menu item, ... More...
virtual void | initialize (DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)
virtual void | guiSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with some GUI slider (menu sliders counts as well) More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)
save controller settings (if there are some) and all PoAs to XML node More...
virtual void | switchTools (DAToolType newType)
switching between tools More...
virtual void | setColour (osg::Vec4 newColour)
virtual void | switchGUIVisibility ()
virtual void | turnOn ()
Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller. More...
virtual void | turnOff (void)
Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller. More...
virtual void | update ()
Scheduled for per-frame updates. More...
virtual void | notify (vreckoUtils::Observable *object, void *userData)
Ctrl_StringSculptures ()
~Ctrl_StringSculptures ()
PoA * | createPoA (const string &name)
void | updateScene ()
- Public Member Functions inherited from APDYNAMICART::Controller
Controller (const char *controllerID, const char *description, PoAType type)
~Controller ()
void | clearAllPoAs ()
const char * | getDescription (void) const
const PoAType | getType (void) const
Returns type of this controller. More...
const char * | getPoAsName (void) const
Return name of ... More...
float | getDaareaScale () const
scale of dynamic art area More...
bool | isEmpty ()
void | preInitialize ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | removePoA (PoA *toRemove)
Remove single PoA. More...
virtual DAToolType | getNextToolType ()
set pointer to Dynamic Art Environment ability More...
std::vector< ref_ptr_PoA > * | getPoAs ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | setSectorEditing (bool enable)
void | setShowAxis (bool enable)
void | checkPoADeleteRequest (HoopPtr hoop)
void | checkHookDeleteRequest ()
HoopPtr | asHoop (PoA *poa)
void | startSimulation ()
void | disableAutorotation ()
void | stopSimulation ()
void | updatePoAs ()
void | disableTools ()
void | setPatternColor (float newValue, unsigned int index)
- Protected Member Functions inherited from APDYNAMICART::Controller
void | initTools ()
Init available tools (filled in _tools) More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...
- Protected Member Functions inherited from vreckoUtils::Observer
Observer ()

Protected Attributes

ModePtr _basic
ModePtr _advanced
ModePtr _mode
PatternGeodePtr _patternsGeode
PatternPtr _defaultPattern
unsigned int | _lineCount
osg::ref_ptr< Hoop > | _poa
osg::Vec4 | _defaultColor
osg::Vec4 | _patternColor
std::vector< Vec3ArrayPtr > | _finalArrays
osg::ref_ptr< LinearInterpolator > | _interpolator
PoAState _hoopsState
osg::ref_ptr< osg::Material > | _patternMaterial
ToolHook * _toolHook
ToolBrush * _toolBrush
bool | _closedPattern
bool | _simulation
bool | _dirtyScene
int | _lineWidth
GeodePtr _geode
PhysXManager * _physXManager
osg::ref_ptr< ConstantDiameterGen > | _ropeRadius
- Protected Attributes inherited from APDYNAMICART::Controller
const char * | _description
users friendly name of controller / context... such as "Free-hand Painting". Appears in menus. More...
const PoAType | _type
Type of this controller - type of contained PoAs. More...
const char * | _poasName
EnvironmentObject * _artArea
Art Area = owner of this ability. More...
DAEnvironment * _daEnvironment
pointer to DA environment More...
std::vector< ref_ptr_PoA > * | _poas
vector containing all PoAs of this controller More...
DATool * _actualTool
pointer to actual tool More...
DATools _tools
Available tools. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Static Public Member Functions inherited from APDYNAMICART::Controller
static const PoAType getType (std::string type)
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Ctrl_StringSculptures::Ctrl_StringSculptures ( )

Constructor & Destructor

APDYNAMICART::Ctrl_StringSculptures::~Ctrl_StringSculptures ( )

Member Function Documentation

void APDYNAMICART::Ctrl_StringSculptures::activateTool ( )
virtual

Inherited virtual methods - Controller

Implements APDYNAMICART::Controller.

HoopPtr APDYNAMICART::Ctrl_StringSculptures::asHoop ( PoA * poa )
inlineprotected
void APDYNAMICART::Ctrl_StringSculptures::checkHookDeleteRequest ( )
protected
void APDYNAMICART::Ctrl_StringSculptures::checkPoADeleteRequest ( HoopPtr hoop )
protected
void APDYNAMICART::Ctrl_StringSculptures::clear ( void )
virtual

clear controller - called before new scene is created or loaded

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this Controller.

Returns
xml description of menu items as string

Implements APDYNAMICART::Controller.

PoA * APDYNAMICART::Ctrl_StringSculptures::createPoA ( const string & name )

Helper methods

void APDYNAMICART::Ctrl_StringSculptures::deactivateTool ( )
virtual

Called by Dynamic Art Environment (DAEnvironment) when user release "useTool" button.

do whatever is necessary before deactivation of tool deactivate current tool (or multiple tools)

Implements APDYNAMICART::Controller.

virtual void APDYNAMICART::Ctrl_StringSculptures::debugKeyPressed ( )
inlinevirtual

Called by Dynamic Art Environment (DAEnvironment) when user release "Debug Purpose" Key (F11 by default)

do whatever helps you...

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::disableAutorotation ( )
protected
void APDYNAMICART::Ctrl_StringSculptures::disableTools ( )
protected
void APDYNAMICART::Ctrl_StringSculptures::guiItemClicked ( const char * itemID )
virtual

Called when user click on some item of GUI - icon, slider, menu item, ...

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::guiSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with some GUI slider (menu sliders counts as well)

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::initialize | ( | DAEnvironment * | p_dae,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parameters = NULL
 | ) |  |
virtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::load | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parametersNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList * | poaNodeList
 | ) |  |
virtual

Loading and saving

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::notify | ( | vreckoUtils::Observable * | object,
 |  | void * | userData
 | ) |  |
virtual

Inherited virtual methods - Observer

Implements vreckoUtils::Observer.

void APDYNAMICART::Ctrl_StringSculptures::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | controllerNode
 | ) |  |
virtual

save controller settings (if there are some) and all PoAs to XML node

Implements APDYNAMICART::Controller.

virtual void APDYNAMICART::Ctrl_StringSculptures::setColour ( osg::Vec4 newColour )
inlinevirtual

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::setPatternColor | ( | float | newValue,
 |  | unsigned int | index
 | ) |  |
protected
void APDYNAMICART::Ctrl_StringSculptures::setSectorEditing ( bool enable )
protected

Helper methods

void APDYNAMICART::Ctrl_StringSculptures::setShowAxis ( bool enable )
protected
void APDYNAMICART::Ctrl_StringSculptures::startSimulation ( )
protected
void APDYNAMICART::Ctrl_StringSculptures::stopSimulation ( )
protected
virtual void APDYNAMICART::Ctrl_StringSculptures::switchGUIVisibility ( )
inlinevirtual

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::switchTools ( DAToolType newType )
virtual

switching between tools

  • _actualTool->turnOff()
  • switch tools - do whatever is necessary
  • _actualTool->turnOn()

Reimplemented from APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::turnOff ( void )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to another controller.

do whatever is necessary when this controller stops (pause)

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::turnOn ( )
virtual

Called when Dynamic Art Environment (DAEnvironment) context is switched to this controller.

do whatever is necessary when this controller starts

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::update ( )
virtual

Scheduled for per-frame updates.

Implements APDYNAMICART::Controller.

void APDYNAMICART::Ctrl_StringSculptures::updatePoAs ( )
protected
void APDYNAMICART::Ctrl_StringSculptures::updateScene ( )

arrays.empty() &&

Member Data Documentation

ModePtr APDYNAMICART::Ctrl_StringSculptures::_advanced
protected
ModePtr APDYNAMICART::Ctrl_StringSculptures::_basic
protected

Modes

bool APDYNAMICART::Ctrl_StringSculptures::_closedPattern
protected

Test and debug

osg::Vec4 APDYNAMICART::Ctrl_StringSculptures::_defaultColor
protected
PatternPtr APDYNAMICART::Ctrl_StringSculptures::_defaultPattern
protected
bool APDYNAMICART::Ctrl_StringSculptures::_dirtyScene
protected
std::vector<Vec3ArrayPtr> APDYNAMICART::Ctrl_StringSculptures::_finalArrays
protected
GeodePtr APDYNAMICART::Ctrl_StringSculptures::_geode
protected
PoAState APDYNAMICART::Ctrl_StringSculptures::_hoopsState
protected
osg::ref_ptr<LinearInterpolator> APDYNAMICART::Ctrl_StringSculptures::_interpolator
protected
unsigned int APDYNAMICART::Ctrl_StringSculptures::_lineCount
protected

Member attributes

int APDYNAMICART::Ctrl_StringSculptures::_lineWidth
protected
ModePtr APDYNAMICART::Ctrl_StringSculptures::_mode
protected
osg::Vec4 APDYNAMICART::Ctrl_StringSculptures::_patternColor
protected
osg::ref_ptr<osg::Material> APDYNAMICART::Ctrl_StringSculptures::_patternMaterial
protected
PatternGeodePtr APDYNAMICART::Ctrl_StringSculptures::_patternsGeode
protected

Patterns

PhysXManager* APDYNAMICART::Ctrl_StringSculptures::_physXManager
protected

PhysX

osg::ref_ptr<Hoop> APDYNAMICART::Ctrl_StringSculptures::_poa
protected
osg::ref_ptr<ConstantDiameterGen> APDYNAMICART::Ctrl_StringSculptures::_ropeRadius
protected
bool APDYNAMICART::Ctrl_StringSculptures::_simulation
protected
ToolBrush* APDYNAMICART::Ctrl_StringSculptures::_toolBrush
protected
ToolHook* APDYNAMICART::Ctrl_StringSculptures::_toolHook
protected

DATools

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_StringSculptures.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_StringSculptures.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::DAEnvironment Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DAEnvironment
Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
APDYNAMICART::DAEnvironment Class Reference

Dynamic Art Environment class - base class of Dynamic Art plugin. More...

#include <DAEnvironment.h>

Inheritance diagram for APDYNAMICART::DAEnvironment:
vrecko::Ability vrecko::BaseClass

Public Types

typedef bool(* func )(const string &id, void *value, void *userData)
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

DAEnvironment ()
~DAEnvironment ()
void | enableGUI (bool enable)
Add given PoB to scene. More...
Controller * getController (PoAType type)
returns controller of given type More...
double | getElapsedArtTime ()
osg::Vec3 | getLeftHandPosition () const
osg::Quat | getLeftHandOrientation () const
osg::Vec3 | getRightHandPosition () const
osg::Quat | getRightHandOrientation () const
bool | getObjectSelectionActiveRight () const
void | setObjectSelectionbyRightHand (bool val)
bool | getAutoRotationActive () const
void | setAutoRotationActive (bool val)
double | getLoadedArtTime () const
void | listDirectory (const string &dirpath, const string &mask, std::vector< string > *fileNames)
evoke color chooser to choose color More...
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | CreateMenuAbilities ()
void | setUpCustomProcessEventCallback (bool(*func)(const std::string &input_name, void *value, void *userData), void *userData)
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static DAEnvironment * getInstance ()

Public Attributes

osg::ref_ptr< EnvironmentObject > | rightHandEO
Smart pointer to environmental object of right hand. More...
osg::ref_ptr< EnvironmentObject > | leftHandEO
Smart pointer to environmental object of left hand. More...

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Dynamic Art Environment class - base class of Dynamic Art plugin.

Includes:

  • basic environment
  • manipulation with whole dynamic art area (translation, rotation, scale)
  • basic menu functions - choose which menu will be show, creates it structure
  • loading and saving of whole Dynamic Art scene
  • handling of device-related (WII, Optitrack) events
  • basic function about dynamics - adding PoBs to scene
  • Object selection by pointing
Author
Jiri Chmelik
Martin Bezdeka
Date
2010
Warning
This class, as well as all other classes in Dynamic Art project are so dynamic, that they cannot be stable. In other words: they are unstable and full of bugs.

Member Typedef Documentation

typedef bool(* APDYNAMICART::DAEnvironment::func)(const string &id, void *value, void *userData)

Set up a custom callback for processEvent Just create your own processEvent function in poa or controller and pass it to the setUpCustomProcessEventCallback function, it will forward all events to you Callback returns true or false, to be able to stop event processing or not..

Constructor & Destructor Documentation

APDYNAMICART::DAEnvironment::DAEnvironment ( )

Use something with Right Hand:

  • tool (Brush, Magnet, ...)
  • PoB (icon, ...)

Use something with Left Hand

  • manipulate with DA area
  • PoB (icon, ...)
APDYNAMICART::DAEnvironment::~DAEnvironment ( )

Member Function Documentation

void APDYNAMICART::DAEnvironment::CreateMenuAbilities ( )
void APDYNAMICART::DAEnvironment::enableGUI ( bool enable )

Add given PoB to scene.

Parameters
newPoB | pointer to new PoB object
movable | flag saying if new PoB will be child of DAArea EO (and therefore movable) or child of dynamics EO (and therefore non-movable)
bool APDYNAMICART::DAEnvironment::getAutoRotationActive ( ) const
inline
Controller * APDYNAMICART::DAEnvironment::getController ( PoAType type )

returns controller of given type

or NULL if controller doesn't exists

double APDYNAMICART::DAEnvironment::getElapsedArtTime ( )
static DAEnvironment* APDYNAMICART::DAEnvironment::getInstance ( )
inlinestatic
osg::Quat APDYNAMICART::DAEnvironment::getLeftHandOrientation ( ) const
inline
osg::Vec3 APDYNAMICART::DAEnvironment::getLeftHandPosition ( ) const
inline
double APDYNAMICART::DAEnvironment::getLoadedArtTime ( ) const
inline
bool APDYNAMICART::DAEnvironment::getObjectSelectionActiveRight ( ) const
inline
osg::Quat APDYNAMICART::DAEnvironment::getRightHandOrientation ( ) const
inline
osg::Vec3 APDYNAMICART::DAEnvironment::getRightHandPosition ( ) const
inline
void APDYNAMICART::DAEnvironment::listDirectory | ( | const string & | dirpath,
 |  | const string & | mask,
 |  | std::vector< string > * | fileNames
 | ) |  |

evoke color chooser to choose color

store pointer to PoA evoke color-chooser

Parameters
rp_poa | reference pointer to poa awaiting new color Creates a list of all filenames in given directory
[in] | dirpath | is path to directory with will be parsed
[out] | fileNames | resulting list of file names
bool APDYNAMICART::DAEnvironment::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Called by the VRECKO to handle requests

Warning
CAN be overridden, but it HAS TO CALL the overridden method class from the ancestor class.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::DAEnvironment::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::DAEnvironment::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * APDYNAMICART::DAEnvironment::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::DAEnvironment::setAutoRotationActive ( bool val )
inline
void APDYNAMICART::DAEnvironment::setObjectSelectionbyRightHand ( bool val )
inline
void APDYNAMICART::DAEnvironment::setUpCustomProcessEventCallback | ( | bool(*)(const std::string &input_name, void *value, void *userData) | func,
 |  | void * | userData
 | ) |  |
inline
void APDYNAMICART::DAEnvironment::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::ref_ptr<EnvironmentObject> APDYNAMICART::DAEnvironment::leftHandEO

Smart pointer to environmental object of left hand.

osg::ref_ptr<EnvironmentObject> APDYNAMICART::DAEnvironment::rightHandEO

Smart pointer to environmental object of right hand.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DAEnvironment.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DAEnvironment.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::DATool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DATool
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::DATool Class Referenceabstract

Virtual class defining basis of all tools used in Dynamic Art. More...

#include <DATool.h>

Inheritance diagram for APDYNAMICART::DATool:
vrecko::Ability vreckoUtils::Observable vrecko::BaseClass APDYNAMICART::PLControllerTool APDYNAMICART::PLMagnetTool APDYNAMICART::PLNestTool APDYNAMICART::ToolBrush APDYNAMICART::ToolEraser APDYNAMICART::ToolHook APDYNAMICART::ToolMagicWand APDYNAMICART::ToolRotation APDYNAMICART::ToolSelector APDYNAMICART::ToolSlice APDYNAMICART::ToolTongs

Public Member Functions

DATool (const char *abilityName)
~DATool ()
virtual void | activate ()=0
Activate tool. More...
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
virtual void | deactivate ()=0
Deactivate tool. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
virtual void | turnOn ()=0
"Start" tool More...
virtual void | turnOff ()=0
"Stop" tool More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Attributes

DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vreckoUtils::Observable
Observable ()

Detailed Description

Virtual class defining basis of all tools used in Dynamic Art.

Cares about:

  • receiving and processing input data (mainly from optitrack)
  • visual cursor - visual representation of tool attached to virtual hand (e.g. magnet, brush, knife, ...)

Constructor & Destructor Documentation

DATool::DATool ( const char * abilityName )
DATool::~DATool ( )

Member Function Documentation

virtual void APDYNAMICART::DATool::activate ( )
pure virtual

Activate tool.

Implemented in APDYNAMICART::PLControllerTool, APDYNAMICART::PLMagnetTool, APDYNAMICART::ToolEraser, APDYNAMICART::ToolTongs, APDYNAMICART::ToolBrush, APDYNAMICART::ToolSelector, APDYNAMICART::ToolHook, APDYNAMICART::ToolSlice, APDYNAMICART::ToolMagicWand, APDYNAMICART::ToolRotation, and APDYNAMICART::PLNestTool.

void DATool::createCursor | ( | EnvironmentObject * | parent,
 |  | string | fileName
 | ) |  |

Create new EO, load geometry from given file and attach it to parent EnvironmentObject.

virtual void APDYNAMICART::DATool::deactivate ( )
pure virtual

Deactivate tool.

Implemented in APDYNAMICART::PLControllerTool, APDYNAMICART::PLMagnetTool, APDYNAMICART::ToolEraser, APDYNAMICART::ToolTongs, APDYNAMICART::ToolMagicWand, APDYNAMICART::ToolBrush, APDYNAMICART::ToolSelector, APDYNAMICART::ToolHook, APDYNAMICART::ToolSlice, APDYNAMICART::PLNestTool, and APDYNAMICART::ToolRotation.

EnvironmentObject* APDYNAMICART::DATool::getCursor ( )
inline
osg::Vec3* APDYNAMICART::DATool::getSize ( )
inline
DAToolType APDYNAMICART::DATool::getType ( void )
inline
bool APDYNAMICART::DATool::isActive ( )
inline
void APDYNAMICART::DATool::setPoA ( osg::ref_ptr< PoA > newPoa )
inline

Set reference pointer to PoA to work with.

void DATool::setSize ( osg::Vec3 p_size )

set size of tool and optional its visual cursor, too

virtual void APDYNAMICART::DATool::turnOff ( )
pure virtual

"Stop" tool

Implemented in APDYNAMICART::PLControllerTool, APDYNAMICART::PLMagnetTool, APDYNAMICART::ToolBrush, APDYNAMICART::ToolEraser, APDYNAMICART::ToolTongs, APDYNAMICART::ToolMagicWand, APDYNAMICART::ToolSelector, APDYNAMICART::PLNestTool, APDYNAMICART::ToolSlice, APDYNAMICART::ToolHook, and APDYNAMICART::ToolRotation.

virtual void APDYNAMICART::DATool::turnOn ( )
pure virtual

"Start" tool

Implemented in APDYNAMICART::PLControllerTool, APDYNAMICART::PLMagnetTool, APDYNAMICART::ToolBrush, APDYNAMICART::ToolEraser, APDYNAMICART::ToolTongs, APDYNAMICART::ToolMagicWand, APDYNAMICART::ToolSelector, APDYNAMICART::ToolSlice, APDYNAMICART::PLNestTool, APDYNAMICART::ToolHook, and APDYNAMICART::ToolRotation.

Member Data Documentation

osg::ref_ptr<EnvironmentObject> APDYNAMICART::DATool::_cursor
protected

visual cursor of tool

Cursor (3d model) attached to virtual hand visual cursor should represent (visualize) tool - brush, magnet, knife, etc.

EnvironmentObject* APDYNAMICART::DATool::_daArea
protected

owner of this ability

DAEnvironment* APDYNAMICART::DATool::_daEnvironment
protected

DAEnvironment.

osg::ref_ptr<PoA> APDYNAMICART::DATool::_poa
protected

actual _poa

bool APDYNAMICART::DATool::active
protected

Is active right now?

osg::Vec3* APDYNAMICART::DATool::size
protected

Size (area of influence) of tool.

DAToolType APDYNAMICART::DATool::toolType
protected

Type of tool.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DATool.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DATool.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ConstantDiamAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ConstantDiamAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::ConstantDiamAdapter Class Reference

#include <DiameterGenAdapter.h>

Inheritance diagram for APDYNAMICART::ConstantDiamAdapter:
APDYNAMICART::PoAAdapter< T >

Public Member Functions

ConstantDiamAdapter ()
ConstantDiamAdapter (double val)
META_DAObject (ConstantDiamAdapter,"Constant") virtual osg
virtual void | createMenu (MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< T >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr< T > | getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< ConstantDiameterGen > _diamGen

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< T >
virtual ~PoAAdapter ()

Detailed Description

Constant Diameter Adapter

Constructor & Destructor Documentation

APDYNAMICART::ConstantDiamAdapter::ConstantDiamAdapter ( )
inline
APDYNAMICART::ConstantDiamAdapter::ConstantDiamAdapter ( double val )
inline

Member Function Documentation

void ConstantDiamAdapter::createMenu ( MenuPtr menu )
virtual

Constant diameter adapter

int APDYNAMICART::ConstantDiamAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

load data from given XML node

Reimplemented from APDYNAMICART::PoAAdapter< T >.

APDYNAMICART::ConstantDiamAdapter::META_DAObject | ( | ConstantDiamAdapter | ,
 |  | "Constant" |
 | ) |  |
inline
void ConstantDiamAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< T >.

bool ConstantDiamAdapter::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Reimplemented from APDYNAMICART::PoAAdapter< T >.

Member Data Documentation

osg::ref_ptr<ConstantDiameterGen> APDYNAMICART::ConstantDiamAdapter::_diamGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DiameterGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DiameterGenAdapter.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::GradientDiamAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • GradientDiamAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::GradientDiamAdapter Class Reference

#include <DiameterGenAdapter.h>

Inheritance diagram for APDYNAMICART::GradientDiamAdapter:
APDYNAMICART::PoAAdapter< T >

Public Member Functions

GradientDiamAdapter ()
GradientDiamAdapter (double diam1, double diam2)
META_DAObject (GradientDiamAdapter,"Gradient") virtual osg
virtual void | createMenu (MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< T >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr< T > | getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< GradientDiameterGen > _diamGen

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< T >
virtual ~PoAAdapter ()

Detailed Description

Gradient Diameter Adapter

Constructor & Destructor Documentation

APDYNAMICART::GradientDiamAdapter::GradientDiamAdapter ( )
inline
APDYNAMICART::GradientDiamAdapter::GradientDiamAdapter | ( | double | diam1,
 |  | double | diam2
 | ) |  |
inline

Member Function Documentation

void GradientDiamAdapter::createMenu ( MenuPtr menu )
virtual

Gradient diameter adapter

int APDYNAMICART::GradientDiamAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

load data from given XML node

Reimplemented from APDYNAMICART::PoAAdapter< T >.

APDYNAMICART::GradientDiamAdapter::META_DAObject | ( | GradientDiamAdapter | ,
 |  | "Gradient" |
 | ) |  |
inline
void GradientDiamAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< T >.

bool GradientDiamAdapter::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Reimplemented from APDYNAMICART::PoAAdapter< T >.

Member Data Documentation

osg::ref_ptr<GradientDiameterGen> APDYNAMICART::GradientDiamAdapter::_diamGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DiameterGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DiameterGenAdapter.cpp
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::DiameterGenFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DiameterGenFactory
Public Member Functions | List of all members
APDYNAMICART::DiameterGenFactory Class Reference

#include <DiameterGenAdapter.h>

Inheritance diagram for APDYNAMICART::DiameterGenFactory:
APDYNAMICART::AdapterFactory< DiameterGenAdapter >

Public Member Functions

DiameterGenFactory ()
DiameterGenFactory (const DiameterGenFactory &orig)
- Public Member Functions inherited from APDYNAMICART::AdapterFactory< DiameterGenAdapter >
const std::vector
< osg::ref_ptr
< DiameterGenAdapter > > & 		getSupportedAdapters () const
osg::ref_ptr< DiameterGenAdapter > getAdapter (const std::string &className)

Additional Inherited Members

- Protected Attributes inherited from APDYNAMICART::AdapterFactory< DiameterGenAdapter >
std::vector< osg::ref_ptr
< DiameterGenAdapter > > 		_adapters

Detailed Description

Factory for diameter generator adapters

Constructor & Destructor Documentation

APDYNAMICART::DiameterGenFactory::DiameterGenFactory ( )
inline
APDYNAMICART::DiameterGenFactory::DiameterGenFactory ( const DiameterGenFactory & orig )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DiameterGenAdapter.h
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HookObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HookObject
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::HookObject Class Reference

#include <Hook.h>

Inheritance diagram for APDYNAMICART::HookObject:
APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

HookObject (Controller *contr, Hoop *hoop, const osg::Vec3 &position, double width)
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
Hoop * | getParentHoop () const
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

Controller * _contr
osg::observer_ptr< Hoop > | _hoop
osg::ref_ptr
< vreckoUtils::HighlightCallback > 		_highlight
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::EnvironmentObject
void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)

Constructor & Destructor Documentation

HookObject::HookObject | ( | Controller * | contr,
 |  | Hoop * | hoop,
 |  | const osg::Vec3 & | position,
 |  | double | width
 | ) |  |

Member Function Documentation

void HookObject::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Inherited methods

Implements APDYNAMICART::PoA.

Hoop* APDYNAMICART::HookObject::getParentHoop ( ) const
inline

Returns parent hoop

void HookObject::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::HookObject::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlinevirtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

int HookObject::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
virtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::HookObject::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

void HookObject::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::HookObject::setColor ( osg::Vec4 newColour )
inlinevirtual
virtual void APDYNAMICART::HookObject::update ( )
inlinevirtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

Member Data Documentation

Controller* APDYNAMICART::HookObject::_contr
protected
osg::ref_ptr<vreckoUtils::HighlightCallback> APDYNAMICART::HookObject::_highlight
protected
osg::observer_ptr<Hoop> APDYNAMICART::HookObject::_hoop
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hook.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Hook.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HoopTrackerCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopTrackerCallback
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::HoopTrackerCallback Class Reference

#include <Hook.h>

Inheritance diagram for APDYNAMICART::HoopTrackerCallback:

Public Member Functions

HoopTrackerCallback (PoA *poa, const osg::Vec3 &offset, double scale)
virtual void operator() (osg::Node *node, osg::NodeVisitor *nv)

Protected Member Functions

void update (osg::Node *node, osg::NodeVisitor *nv)

Protected Attributes

osg::observer_ptr< PoA > | _poa
osg::Vec3 | _offset
double | _scale

Constructor & Destructor Documentation

APDYNAMICART::HoopTrackerCallback::HoopTrackerCallback | ( | PoA * | poa,
 |  | const osg::Vec3 & | offset,
 |  | double | scale
 | ) |  |
inline

Member Function Documentation

virtual void APDYNAMICART::HoopTrackerCallback::operator() | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlinevirtual
void APDYNAMICART::HoopTrackerCallback::update | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlineprotected

Member Data Documentation

osg::Vec3 APDYNAMICART::HoopTrackerCallback::_offset
protected
osg::observer_ptr<PoA> APDYNAMICART::HoopTrackerCallback::_poa
protected
double APDYNAMICART::HoopTrackerCallback::_scale
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hook.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HookManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HookManager
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::HookManager Class Reference

Hook Manager. More...

#include <HookManager.h>

Public Types

typedef std::vector
< osg::ref_ptr< HookObject > > 		HookArray

Public Member Functions

void | init (EnvironmentObject *parent)
void | addHook (HookObject *hookObject)
void | removeHook (unsigned int index)
void | removeHook (HookObject *hookObject)
void | removeAllHooks ()
void | removeHooksOnHoop (Hoop *hoop)
const HookArray & | getHooks () const
void | load (HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
void | save (HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)

Static Public Member Functions

static HookManager * get ()

Protected Member Functions

HookManager ()

Protected Attributes

HookArray _hooks
EnvironmentObject * _parent

Detailed Description

Hook Manager.

Class responsible for managing hooks

Member Typedef Documentation

typedef std::vector< osg::ref_ptr<HookObject> > APDYNAMICART::HookManager::HookArray

Constructor & Destructor Documentation

HookManager::HookManager ( )
protected

Member Function Documentation

void HookManager::addHook ( HookObject * hookObject )
static HookManager* APDYNAMICART::HookManager::get ( )
inlinestatic
const HookArray& APDYNAMICART::HookManager::getHooks ( ) const
inline
void HookManager::init ( EnvironmentObject * parent )
void HookManager::load | ( | HoopPtr | hoop,
 |  | int | sectorsCount,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | PoANode
 | ) |  |

Saving and loading

void HookManager::removeAllHooks ( )
void HookManager::removeHook ( unsigned int index )
void HookManager::removeHook ( HookObject * hookObject )
void HookManager::removeHooksOnHoop ( Hoop * hoop )
void HookManager::save | ( | HoopPtr | hoop,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |

Member Data Documentation

HookArray APDYNAMICART::HookManager::_hooks
protected
EnvironmentObject* APDYNAMICART::HookManager::_parent
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HookManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HookManager.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Hoop Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Hoop
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Hoop Class Reference

#include <Hoop.h>

Inheritance diagram for APDYNAMICART::Hoop:
APDYNAMICART::PoA APDYNAMICART::Stroke vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

Hoop (Controller *controller, HoopShapePtr shape)
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
Vec3ArrayPtr getSnapPointArray ()
osg::Vec4 | getColor ()
SweepSurfaceGeodePtr | getSweepSurface () const
SectorColorGenPtr | getSectorMarker () const
ColorGenPtr | getCachedColorGenerator () const
double | getDiameter () const
void | setDiameter (double val)
HoopShapePtr | getShape () const
void | setShape (HoopShapePtr val)
NxActor * | getActor () const
void | setActor (NxActor *val)
void | showAxis ()
void | hideAxis ()
virtual Vec3ArrayPtr | getPositionSamples () const
virtual Vec4ArrayPtr | getOrientationSamples () const
virtual osg::ref_ptr
< osg::DoubleArray > 		getTimeStamps () const
virtual SplinePtr | getLeadingSpline () const
void | createActor ()
void | deleteActor ()
void | updateActor ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (EvokeHSLColorPicker, MessageString, MessageBool)
DECLARE_INPUT (Colour, MessageVec4)

Protected Attributes

Controller * _contr
SweepSurfaceGeodePtr _sweepSurface
NxActor * | _actor
osg::Matrix | _currentRotation
osg::Vec3 | _currentTransform
Vec3ArrayPtr _snapPointArray
RegularPolygonSplinePtr _crossSectionSpline
HoopShapePtr _shape
osg::ref_ptr< osg::Switch > | _axis
SectorColorGenPtr _sectorMarker
ColorGenPtr | _colorGen
osg::ref_ptr< ConstantDiameterGen > | _diameterGenerator
osg::ref_ptr
< vreckoUtils::HighlightCallback > 		_highlight
Vec3ArrayPtr _points
Vec4ArrayPtr _orientations
DoubleArrayPtr | _timeStamps
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::Hoop::Hoop | ( | Controller * | controller,
 |  | HoopShapePtr | shape
 | ) |  |

chosen color sent from color picker

Member Function Documentation

void APDYNAMICART::Hoop::createActor ( )

PhysX methods

void APDYNAMICART::Hoop::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Inherited methods

Implements APDYNAMICART::PoA.

APDYNAMICART::Hoop::DECLARE_INPUT | ( | Colour | ,
 |  | MessageVec4 |
 | ) |  |
protected
APDYNAMICART::Hoop::DECLARE_REQUEST_OUTPUT | ( | EvokeHSLColorPicker | ,
 |  | MessageString | ,
 |  | MessageBool |
 | ) |  |
protected
void APDYNAMICART::Hoop::deleteActor ( )
NxActor* APDYNAMICART::Hoop::getActor ( ) const
inline
ColorGenPtr APDYNAMICART::Hoop::getCachedColorGenerator ( ) const
inline
osg::Vec4 APDYNAMICART::Hoop::getColor ( )
double APDYNAMICART::Hoop::getDiameter ( ) const
inline
SplinePtr APDYNAMICART::Hoop::getLeadingSpline ( ) const
virtual

Implements APDYNAMICART::Stroke.

Vec4ArrayPtr APDYNAMICART::Hoop::getOrientationSamples ( ) const
virtual

Implements APDYNAMICART::Stroke.

Vec3ArrayPtr APDYNAMICART::Hoop::getPositionSamples ( ) const
virtual

Stroke methods

Implements APDYNAMICART::Stroke.

SectorColorGenPtr APDYNAMICART::Hoop::getSectorMarker ( ) const
inline
HoopShapePtr APDYNAMICART::Hoop::getShape ( ) const
inline
Vec3ArrayPtr APDYNAMICART::Hoop::getSnapPointArray ( )

Getters and setters

SweepSurfaceGeodePtr APDYNAMICART::Hoop::getSweepSurface ( ) const
inline
osg::ref_ptr< osg::DoubleArray > APDYNAMICART::Hoop::getTimeStamps ( ) const
virtual

Implements APDYNAMICART::Stroke.

void APDYNAMICART::Hoop::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

void APDYNAMICART::Hoop::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

void APDYNAMICART::Hoop::hideAxis ( )
inline
int APDYNAMICART::Hoop::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
virtual

Saving and loading

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::Hoop::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

void APDYNAMICART::Hoop::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

void APDYNAMICART::Hoop::setActor ( NxActor * val )
inline
void APDYNAMICART::Hoop::setColor ( osg::Vec4 newColour )
virtual
void APDYNAMICART::Hoop::setDiameter ( double val )
inline
void APDYNAMICART::Hoop::setShape ( HoopShapePtr val )
inline
void APDYNAMICART::Hoop::showAxis ( )
inline

Helper methods

void APDYNAMICART::Hoop::update ( )
virtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

void APDYNAMICART::Hoop::updateActor ( )

Member Data Documentation

NxActor* APDYNAMICART::Hoop::_actor
protected
osg::ref_ptr<osg::Switch> APDYNAMICART::Hoop::_axis
protected
ColorGenPtr APDYNAMICART::Hoop::_colorGen
protected
Controller* APDYNAMICART::Hoop::_contr
protected
RegularPolygonSplinePtr APDYNAMICART::Hoop::_crossSectionSpline
protected
osg::Matrix APDYNAMICART::Hoop::_currentRotation
protected
osg::Vec3 APDYNAMICART::Hoop::_currentTransform
protected
osg::ref_ptr<ConstantDiameterGen> APDYNAMICART::Hoop::_diameterGenerator
protected
osg::ref_ptr<vreckoUtils::HighlightCallback> APDYNAMICART::Hoop::_highlight
protected
Vec4ArrayPtr APDYNAMICART::Hoop::_orientations
protected
Vec3ArrayPtr APDYNAMICART::Hoop::_points
protected
SectorColorGenPtr APDYNAMICART::Hoop::_sectorMarker
protected
HoopShapePtr APDYNAMICART::Hoop::_shape
protected
Vec3ArrayPtr APDYNAMICART::Hoop::_snapPointArray
protected
SweepSurfaceGeodePtr APDYNAMICART::Hoop::_sweepSurface
protected
DoubleArrayPtr APDYNAMICART::Hoop::_timeStamps
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hoop.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Hoop.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HoopShape Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopShape
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::HoopShape Class Referenceabstract

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::HoopShape:
APDYNAMICART::Ellipse APDYNAMICART::ElongatedCircle APDYNAMICART::Line APDYNAMICART::NullHoopShape APDYNAMICART::Painted APDYNAMICART::Rectangle APDYNAMICART::RegularPolygon

Public Member Functions

HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Member Functions

virtual ~HoopShape ()

Protected Attributes

bool | _dirty
SplinePtr | _spline

Detailed Description

HoopShape abstract class

Constructor & Destructor Documentation

APDYNAMICART::HoopShape::HoopShape ( )
inline
virtual APDYNAMICART::HoopShape::~HoopShape ( )
inlineprotectedvirtual

Member Function Documentation

virtual osg::ref_ptr<HoopShape> APDYNAMICART::HoopShape::clone ( )
pure virtual

Implemented in APDYNAMICART::NullHoopShape.

virtual void APDYNAMICART::HoopShape::createMenu ( MenuPtr parent ) const
inlinevirtual
virtual void APDYNAMICART::HoopShape::dirty ( bool enable = true )
inlinevirtual
virtual SplinePtr APDYNAMICART::HoopShape::getLeadingSpline ( )
inlinevirtual
virtual std::string APDYNAMICART::HoopShape::getName ( )
pure virtual

Implemented in APDYNAMICART::NullHoopShape.

virtual bool APDYNAMICART::HoopShape::isDirty ( )
inlinevirtual
virtual bool APDYNAMICART::HoopShape::itemClicked ( const char * itemID )
inlinevirtual

Reimplemented in APDYNAMICART::Painted.

virtual int APDYNAMICART::HoopShape::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
pure virtual

Implemented in APDYNAMICART::NullHoopShape.

virtual void APDYNAMICART::HoopShape::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
pure virtual

Implemented in APDYNAMICART::NullHoopShape.

virtual void APDYNAMICART::HoopShape::setLeadingSpline ( SplinePtr val )
inlinevirtual
virtual bool APDYNAMICART::HoopShape::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlinevirtual

Member Data Documentation

bool APDYNAMICART::HoopShape::_dirty
protected
SplinePtr APDYNAMICART::HoopShape::_spline
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullHoopShape Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullHoopShape
Public Member Functions | List of all members
APDYNAMICART::NullHoopShape Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::NullHoopShape:
APDYNAMICART::HoopShape

Public Member Functions

virtual HoopShapePtr | clone ()
virtual std::string | getName ()
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual | ~HoopShape ()
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Member Function Documentation

virtual HoopShapePtr APDYNAMICART::NullHoopShape::clone ( )
inlinevirtual

Implements APDYNAMICART::HoopShape.

virtual std::string APDYNAMICART::NullHoopShape::getName ( void )
inlinevirtual

Implements APDYNAMICART::HoopShape.

virtual int APDYNAMICART::NullHoopShape::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
inlinevirtual

Implements APDYNAMICART::HoopShape.

virtual void APDYNAMICART::NullHoopShape::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
inlinevirtual

Implements APDYNAMICART::HoopShape.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Rectangle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Rectangle
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Rectangle Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::Rectangle:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (Rectangle,"Rectangle")
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Member Functions

void | init ()
void | updateSamplePoints ()
- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual | ~HoopShape ()

Protected Attributes

double | _width
double | _height
double | _scale
Vec3ArrayPtr _samplePoints
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Member Function Documentation

void APDYNAMICART::Rectangle::init ( void )
protected
APDYNAMICART::Rectangle::META_HoopShapeObject | ( | Rectangle | ,
 |  | "Rectangle" |
 | ) |  |
void APDYNAMICART::Rectangle::updateSamplePoints ( )
protected

Member Data Documentation

double APDYNAMICART::Rectangle::_height
protected
Vec3ArrayPtr APDYNAMICART::Rectangle::_samplePoints
protected
double APDYNAMICART::Rectangle::_scale
protected
double APDYNAMICART::Rectangle::_width
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Ellipse Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ellipse
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Ellipse Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::Ellipse:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (Ellipse,"Ellipse")
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Member Functions

void | init ()
void | updateSamplePoints ()
- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual | ~HoopShape ()

Protected Attributes

double | _a
double | _b
Vec3ArrayPtr _samplePoints
unsigned int | _detail
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Member Function Documentation

void APDYNAMICART::Ellipse::init ( void )
protected
APDYNAMICART::Ellipse::META_HoopShapeObject | ( | Ellipse | ,
 |  | "Ellipse" |
 | ) |  |
void APDYNAMICART::Ellipse::updateSamplePoints ( )
protected

Member Data Documentation

double APDYNAMICART::Ellipse::_a
protected
double APDYNAMICART::Ellipse::_b
protected
unsigned int APDYNAMICART::Ellipse::_detail
protected
Vec3ArrayPtr APDYNAMICART::Ellipse::_samplePoints
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RegularPolygon Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RegularPolygon
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::RegularPolygon Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::RegularPolygon:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (RegularPolygon,"Regular polygon")
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Attributes

RegularPolygonSplinePtr _rps
double | _scale
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual ~HoopShape ()

Member Function Documentation

APDYNAMICART::RegularPolygon::META_HoopShapeObject | ( | RegularPolygon | ,
 |  | "Regular polygon" |
 | ) |  |

Member Data Documentation

RegularPolygonSplinePtr APDYNAMICART::RegularPolygon::_rps
protected
double APDYNAMICART::RegularPolygon::_scale
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Line Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Line
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::Line Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::Line:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (Line,"Rod")
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Member Functions

void | init ()
void | updateSamplePoints ()
- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual | ~HoopShape ()

Protected Attributes

double | _length
SampledSplinePtr _sampledSpline
Vec3ArrayPtr _array
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Member Function Documentation

void APDYNAMICART::Line::init ( void )
protected
APDYNAMICART::Line::META_HoopShapeObject | ( | Line | ,
 |  | "Rod" |
 | ) |  |
void APDYNAMICART::Line::updateSamplePoints ( )
protected

Member Data Documentation

Vec3ArrayPtr APDYNAMICART::Line::_array
protected
double APDYNAMICART::Line::_length
protected
SampledSplinePtr APDYNAMICART::Line::_sampledSpline
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ElongatedCircle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ElongatedCircle
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ElongatedCircle Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::ElongatedCircle:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (ElongatedCircle,"Elongated Circle")
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | itemClicked (const char *itemID)
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Member Functions

void | init ()
void | updateSamplePoints ()
void | createCircleSide (double step)
- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual | ~HoopShape ()

Protected Attributes

double | _radius
Vec3ArrayPtr _samplePoints
unsigned int | _detail
double | _distance
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Member Function Documentation

void APDYNAMICART::ElongatedCircle::createCircleSide ( double step )
protected
void APDYNAMICART::ElongatedCircle::init ( void )
protected
APDYNAMICART::ElongatedCircle::META_HoopShapeObject | ( | ElongatedCircle | ,
 |  | "Elongated Circle" |
 | ) |  |
void APDYNAMICART::ElongatedCircle::updateSamplePoints ( )
protected

Member Data Documentation

unsigned int APDYNAMICART::ElongatedCircle::_detail
protected
double APDYNAMICART::ElongatedCircle::_distance
protected
double APDYNAMICART::ElongatedCircle::_radius
protected
Vec3ArrayPtr APDYNAMICART::ElongatedCircle::_samplePoints
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Painted Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Painted
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::Painted Class Reference

#include <HoopShape.h>

Inheritance diagram for APDYNAMICART::Painted:
APDYNAMICART::HoopShape

Public Member Functions

META_HoopShapeObject (Painted,"Painted")
virtual bool | itemClicked (const char *itemID)
void | setPointArray (Vec3ArrayPtr array)
- Public Member Functions inherited from APDYNAMICART::HoopShape
HoopShape ()
virtual SplinePtr | getLeadingSpline ()
virtual void | setLeadingSpline (SplinePtr val)
virtual void | createMenu (MenuPtr parent) const
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
virtual void | dirty (bool enable=true)
virtual bool | isDirty ()
virtual osg::ref_ptr< HoopShape > | clone ()=0
virtual std::string | getName ()=0

Protected Attributes

Vec3ArrayPtr _points
SampledSplinePtr _sampledSpline
- Protected Attributes inherited from APDYNAMICART::HoopShape
bool | _dirty
SplinePtr | _spline

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::HoopShape
virtual ~HoopShape ()

Member Function Documentation

bool APDYNAMICART::Painted::itemClicked ( const char * itemID )
virtual

Reimplemented from APDYNAMICART::HoopShape.

APDYNAMICART::Painted::META_HoopShapeObject | ( | Painted | ,
 |  | "Painted" |
 | ) |  |
void APDYNAMICART::Painted::setPointArray ( Vec3ArrayPtr array )
inline

Member Data Documentation

Vec3ArrayPtr APDYNAMICART::Painted::_points
protected
SampledSplinePtr APDYNAMICART::Painted::_sampledSpline
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ShapeFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ShapeFactory
Static Public Member Functions | List of all members
APDYNAMICART::ShapeFactory Class Reference

#include <HoopShape.h>

Static Public Member Functions

static std::vector< std::string > | getAvaiableHoopShapes ()
static HoopShapePtr | getHoopShape (const std::string &name)
static IShapeGeneratorPtr | getShapeGenerator (const std::string &name)

Detailed Description

Pattern simple factory

Shape factory

Member Function Documentation

static std::vector<std::string> APDYNAMICART::ShapeFactory::getAvaiableHoopShapes ( )
inlinestatic
static HoopShapePtr APDYNAMICART::ShapeFactory::getHoopShape ( const std::string & name )
inlinestatic
IShapeGeneratorPtr APDYNAMICART::ShapeFactory::getShapeGenerator ( const std::string & name )
static
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::JuliaAttractor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • JuliaAttractor
Public Member Functions | List of all members
APDYNAMICART::JuliaAttractor Class Reference

#include <JuliaAttractor.h>

Inheritance diagram for APDYNAMICART::JuliaAttractor:
APDYNAMICART::Attractor APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

JuliaAttractor (IParametersPtr parameters, Controller *controller)
virtual void | compute ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
- Public Member Functions inherited from APDYNAMICART::Attractor
virtual std::string | createMenuStructure (void) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
void | generate ()
virtual void | init ()
Parameters & getParameters ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Static Public Member Functions inherited from APDYNAMICART::Attractor
static AttractorPtr | createInstance (std::string attName, Controller *controller)
static AttractorNames | getAvailableAttractors ()
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from APDYNAMICART::Attractor
Attractor (Controller *controller)
void | setSliderParameter (const char *sliderID, float sliderPos)
bool | valueChanged (float sliderPos)
IMenuComponentPtr | createParameterSubMenu () const
- Protected Attributes inherited from APDYNAMICART::Attractor
Parameters _params
float | _size

Constructor & Destructor Documentation

APDYNAMICART::JuliaAttractor::JuliaAttractor | ( | IParametersPtr | parameters,
 |  | Controller * | controller
 | ) |  |

Constructors

Member Function Documentation

void APDYNAMICART::JuliaAttractor::compute ( )
virtual

Inherited virtual methods

Implements APDYNAMICART::Attractor.

void APDYNAMICART::JuliaAttractor::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implements APDYNAMICART::PoA.

void APDYNAMICART::JuliaAttractor::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Reimplemented from APDYNAMICART::Attractor.

void APDYNAMICART::JuliaAttractor::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Reimplemented from APDYNAMICART::Attractor.

void APDYNAMICART::JuliaAttractor::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::JuliaAttractor::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

void APDYNAMICART::JuliaAttractor::update ( )
virtual

Update of PoA - e.g. re-rendering.

Reimplemented from APDYNAMICART::Attractor.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/JuliaAttractor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/JuliaAttractor.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Mode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Mode
Public Member Functions | Protected Member Functions | List of all members
APDYNAMICART::Mode Class Referenceabstract

#include <Modes.h>

Inheritance diagram for APDYNAMICART::Mode:
APDYNAMICART::Advanced APDYNAMICART::Basic

Public Member Functions

virtual void setLayout ()=0

Protected Member Functions

virtual ~Mode ()

Constructor & Destructor Documentation

virtual APDYNAMICART::Mode::~Mode ( )
inlineprotectedvirtual

Member Function Documentation

virtual void APDYNAMICART::Mode::setLayout ( )
pure virtual

Implemented in APDYNAMICART::Advanced, and APDYNAMICART::Basic.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Modes.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Basic Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Basic
Public Member Functions | List of all members
APDYNAMICART::Basic Class Reference

#include <Modes.h>

Inheritance diagram for APDYNAMICART::Basic:
APDYNAMICART::Mode

Public Member Functions

Basic (Controller *controller)
virtual void setLayout ()

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::Mode
virtual ~Mode ()

Detailed Description

Derived classes

Constructor & Destructor Documentation

APDYNAMICART::Basic::Basic ( Controller * controller )
inline

Member Function Documentation

void APDYNAMICART::Basic::setLayout ( )
virtual

Implements APDYNAMICART::Mode.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Modes.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Modes.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Advanced Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Advanced
Public Member Functions | List of all members
APDYNAMICART::Advanced Class Reference

#include <Modes.h>

Inheritance diagram for APDYNAMICART::Advanced:
APDYNAMICART::Mode

Public Member Functions

Advanced (Controller *controller)
virtual void setLayout ()

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::Mode
virtual ~Mode ()

Constructor & Destructor Documentation

APDYNAMICART::Advanced::Advanced ( Controller * controller )
inline

Member Function Documentation

void APDYNAMICART::Advanced::setLayout ( )
virtual

Implements APDYNAMICART::Mode.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Modes.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Modes.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::MotionTrail Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • MotionTrail
Public Member Functions | List of all members
APDYNAMICART::MotionTrail Class Reference

#include <MotionTrail.h>

Inheritance diagram for APDYNAMICART::MotionTrail:
APDYNAMICART::BrushStroke APDYNAMICART::PoA APDYNAMICART::Stroke vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

MotionTrail (Controller *contr, ColorGenAdapter *colorGenAdapter, DiameterGenAdapter *diamGenAdapt, SplineAdapter *crossSectionAdapter)
~MotionTrail ()
- Public Member Functions inherited from APDYNAMICART::BrushStroke
BrushStroke (Controller *contr, BrushPtr brush)
~BrushStroke ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
void | exportToFile (std::string file)
export the current state of the brush stroke to a file More...
double | getDuration ()
double | getRealStartTime ()
double | getComputedStartTime ()
virtual Vec3ArrayPtr | getPositionSamples () const
virtual Vec4ArrayPtr | getOrientationSamples () const
virtual osg::ref_ptr
< osg::DoubleArray > 		getTimeStamps () const
virtual SplinePtr | getLeadingSpline () const
void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
void | importControlPoints (std::vector< osg::Vec3 > *samples, std::vector< osg::Vec4 > *colours, double diameter, int usize)
int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *BrushStrokeNode)
Load configuration of PoA from .XML node. More...
void | playback (double playbackTime)
void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save PoA as one node to .xml file. More...
void | setLeadingSpline (InterpolatedSplinePtr val)
void | setCrossSectionInterpolation (int interpol)
void | setCrossSectionType (int type)
void | setInterpolationSteps (int interpol)
void | setSmoothness (double smooth)
void | setComputedTime (double newTime)
void | switchRenderingMethod ()
Switch between polygon = FILL and wire-frame = LINE modes. More...
void | update (void)
Update of PoA - e.g. re-rendering. More...
void | visualizeControlPoints (bool show)
Switch on or off showing box-likes visualization of control points of BrushStroke. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from APDYNAMICART::BrushStroke
DECLARE_REQUEST_OUTPUT (EvokeHSLColorPicker, MessageString, MessageBool)
- Protected Attributes inherited from APDYNAMICART::BrushStroke
Vec3ArrayPtr _samplesPositions
All position samples tracked by input device during creation of BrushStroke. More...
Vec4ArrayPtr _samplesOrientations
All orientation samples tracked by input device during creation of BrushStroke. More...
DoubleArrayPtr | _samplesTimeStamps
All timeStamps samples. More...
TimeLineSplinePtr _timeLineDecorator
time-line decorator - used for playback feature More...
double | _StartTime
time when stroke was created. Number of seconds from beginning of painting. More...
double | _computedStrokeStartTime
based on used playback time. e.g. inter-strokes lags may be skipped More...
SplinePtr | _leadingSpline
leading, or so-called spine curve - computed from tracked samples, defines trail of user motion More...
SplinePtr | _leadingSplineInterpolated
SplinePtr | _leadingSplineTilting
osg::Vec3 | _lastValidSamplePosition
used during loading More...
SweepSurfaceGeodePtr _sweepSurface
object for visualization brush stroke - from defined splines and parameters, it generates triangle (quad) mesh More...
vreckoUtils::HighlightCallback * _highLightcallback
callback for "highlighting" sweep-surface More...
BrushPtr _brush
container for color, diameter and cross-section spline factories (and therefore adapters) More...
int | _strokeTime
time (in seconds) from beginning of painting to start of this stroke More...

Constructor & Destructor Documentation

APDYNAMICART::MotionTrail::MotionTrail | ( | Controller * | contr,
 |  | ColorGenAdapter * | colorGenAdapter,
 |  | DiameterGenAdapter * | diamGenAdapt,
 |  | SplineAdapter * | crossSectionAdapter
 | ) |  |
APDYNAMICART::MotionTrail::~MotionTrail ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/MotionTrail.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MotionTrail.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullAttractor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullAttractor
Public Member Functions | List of all members
APDYNAMICART::NullAttractor Class Reference

#include <NullAttractor.h>

Inheritance diagram for APDYNAMICART::NullAttractor:
APDYNAMICART::Attractor APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

NullAttractor (Controller *controller)
virtual void | compute ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
- Public Member Functions inherited from APDYNAMICART::Attractor
virtual std::string | createMenuStructure (void) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
void | generate ()
virtual void | init ()
Parameters & getParameters ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Static Public Member Functions inherited from APDYNAMICART::Attractor
static AttractorPtr | createInstance (std::string attName, Controller *controller)
static AttractorNames | getAvailableAttractors ()
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from APDYNAMICART::Attractor
Attractor (Controller *controller)
void | setSliderParameter (const char *sliderID, float sliderPos)
bool | valueChanged (float sliderPos)
IMenuComponentPtr | createParameterSubMenu () const
- Protected Attributes inherited from APDYNAMICART::Attractor
Parameters _params
float | _size

Constructor & Destructor Documentation

APDYNAMICART::NullAttractor::NullAttractor ( Controller * controller )

Member Function Documentation

void APDYNAMICART::NullAttractor::compute ( )
virtual

Implements APDYNAMICART::Attractor.

virtual void APDYNAMICART::NullAttractor::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
inlinevirtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::NullAttractor::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
inlinevirtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/NullAttractor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/NullAttractor.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::OrdinaryAttractor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • OrdinaryAttractor
Public Member Functions | List of all members
APDYNAMICART::OrdinaryAttractor Class Reference

#include <OrdinaryAttractor.h>

Inheritance diagram for APDYNAMICART::OrdinaryAttractor:
APDYNAMICART::Attractor APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

OrdinaryAttractor (IComputeStrategyPtr computeStrategy, IParametersPtr parameters, Controller *controller)
bool | colorChanged (const char *sliderID, float sliderPos)
virtual void | compute ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
int | getIterationCount ()
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | init ()
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
- Public Member Functions inherited from APDYNAMICART::Attractor
virtual std::string | createMenuStructure (void) const
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | setColor (osg::Vec4 newColour)
void | generate ()
Parameters & getParameters ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Static Public Member Functions inherited from APDYNAMICART::Attractor
static AttractorPtr | createInstance (std::string attName, Controller *controller)
static AttractorNames | getAvailableAttractors ()
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from APDYNAMICART::Attractor
Attractor (Controller *controller)
void | setSliderParameter (const char *sliderID, float sliderPos)
bool | valueChanged (float sliderPos)
IMenuComponentPtr | createParameterSubMenu () const
- Protected Attributes inherited from APDYNAMICART::Attractor
Parameters _params
float | _size

Constructor & Destructor Documentation

APDYNAMICART::OrdinaryAttractor::OrdinaryAttractor | ( | IComputeStrategyPtr | computeStrategy,
 |  | IParametersPtr | parameters,
 |  | Controller * | controller
 | ) |  |

Constructors

Member Function Documentation

bool APDYNAMICART::OrdinaryAttractor::colorChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
void APDYNAMICART::OrdinaryAttractor::compute ( )
virtual

Implements APDYNAMICART::Attractor.

void APDYNAMICART::OrdinaryAttractor::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implements APDYNAMICART::PoA.

int APDYNAMICART::OrdinaryAttractor::getIterationCount ( )
inline
void APDYNAMICART::OrdinaryAttractor::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Reimplemented from APDYNAMICART::Attractor.

void APDYNAMICART::OrdinaryAttractor::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Reimplemented from APDYNAMICART::Attractor.

void APDYNAMICART::OrdinaryAttractor::init ( void )
virtual

Reimplemented from APDYNAMICART::Attractor.

int APDYNAMICART::OrdinaryAttractor::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
virtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Reimplemented from APDYNAMICART::Attractor.

void APDYNAMICART::OrdinaryAttractor::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

void APDYNAMICART::OrdinaryAttractor::update ( )
virtual

Update of PoA - e.g. re-rendering.

Reimplemented from APDYNAMICART::Attractor.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/OrdinaryAttractor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/OrdinaryAttractor.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Parameter Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Parameter
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::Parameter Struct Reference

#include <Parameters.h>

Public Member Functions

Parameter (double rangeStart, double rangeEnd, double value, std::string title="", bool canBeRandom=true)

Public Attributes

std::string | title
double | rangeStart
double | rangeEnd
double | value
bool | canBeRandom

Detailed Description

Parameter struct

Constructor & Destructor Documentation

APDYNAMICART::Parameter::Parameter | ( | double | rangeStart,
 |  | double | rangeEnd,
 |  | double | value,
 |  | std::string | title = "",
 |  | bool | canBeRandom = true
 | ) |  |
inline

Member Data Documentation

bool APDYNAMICART::Parameter::canBeRandom
double APDYNAMICART::Parameter::rangeEnd
double APDYNAMICART::Parameter::rangeStart
std::string APDYNAMICART::Parameter::title
double APDYNAMICART::Parameter::value
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::IParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IParameters
Public Member Functions | List of all members
APDYNAMICART::IParameters Class Referenceabstract

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::IParameters:
APDYNAMICART::IkedaParameters APDYNAMICART::JuliaParameters APDYNAMICART::Lorenz84Parameters APDYNAMICART::LorenzParameters APDYNAMICART::NullParameters APDYNAMICART::PickoverParameters APDYNAMICART::PolynomialParameters APDYNAMICART::RosslerParameters

Public Member Functions

virtual Parameters | getParameters ()=0
virtual | ~IParameters ()

Constructor & Destructor Documentation

virtual APDYNAMICART::IParameters::~IParameters ( )
inlinevirtual

Member Function Documentation

virtual Parameters APDYNAMICART::IParameters::getParameters ( )
pure virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullParameters
List of all members
APDYNAMICART::NullParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::NullParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::LorenzParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LorenzParameters
List of all members
APDYNAMICART::LorenzParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::LorenzParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Lorenz84Parameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Lorenz84Parameters
List of all members
APDYNAMICART::Lorenz84Parameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::Lorenz84Parameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::JuliaParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • JuliaParameters
List of all members
APDYNAMICART::JuliaParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::JuliaParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PickoverParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PickoverParameters
List of all members
APDYNAMICART::PickoverParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::PickoverParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RosslerParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RosslerParameters
List of all members
APDYNAMICART::RosslerParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::RosslerParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PolynomialParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolynomialParameters
List of all members
APDYNAMICART::PolynomialParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::PolynomialParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::IkedaParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IkedaParameters
List of all members
APDYNAMICART::IkedaParameters Class Reference

#include <Parameters.h>

Inheritance diagram for APDYNAMICART::IkedaParameters:
APDYNAMICART::IParameters

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::IParameters
virtual ~IParameters ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ParticleSystemParameters Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ParticleSystemParameters
Public Attributes | List of all members
APDYNAMICART::ParticleSystemParameters Struct Reference

#include <ParticleSystem.h>

Public Attributes

double | lifeTime
double | gravity
double | BirthRateMin
double | BirthRateMax
double | sizeBirth
double | sizeDeath
double | speedMin
double | speedMax
double | dispersion
string | textureFile

Member Data Documentation

double APDYNAMICART::ParticleSystemParameters::BirthRateMax
double APDYNAMICART::ParticleSystemParameters::BirthRateMin
double APDYNAMICART::ParticleSystemParameters::dispersion
double APDYNAMICART::ParticleSystemParameters::gravity
double APDYNAMICART::ParticleSystemParameters::lifeTime
double APDYNAMICART::ParticleSystemParameters::sizeBirth
double APDYNAMICART::ParticleSystemParameters::sizeDeath
double APDYNAMICART::ParticleSystemParameters::speedMax
double APDYNAMICART::ParticleSystemParameters::speedMin
string APDYNAMICART::ParticleSystemParameters::textureFile
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ParticleSystem.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Pattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Pattern
Public Member Functions | List of all members
APDYNAMICART::Pattern Class Referenceabstract

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::Pattern:
APDYNAMICART::PatternBase APDYNAMICART::AcrossPattern APDYNAMICART::CrissCrossPattern APDYNAMICART::DoublePattern APDYNAMICART::HyperbolicPattern APDYNAMICART::NullPattern APDYNAMICART::SplitPattern APDYNAMICART::SplitReversePattern APDYNAMICART::StandardPattern APDYNAMICART::TopPattern APDYNAMICART::TopReversePattern

Public Member Functions

virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)=0
virtual std::string | getName ()=0

Detailed Description

Pattern interface

Member Function Documentation

virtual Vec3ArrayPtr APDYNAMICART::Pattern::generate | ( | Vec3ArrayPtr | left,
 |  | Vec3ArrayPtr | right
 | ) |  |
pure virtual

Implemented in APDYNAMICART::PatternBase.

virtual std::string APDYNAMICART::Pattern::getName ( )
pure virtual

Implemented in APDYNAMICART::PatternBase.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PatternBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternBase
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::PatternBase Class Referenceabstract

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::PatternBase:
APDYNAMICART::Pattern APDYNAMICART::AcrossPattern APDYNAMICART::CrissCrossPattern APDYNAMICART::DoublePattern APDYNAMICART::HyperbolicPattern APDYNAMICART::NullPattern APDYNAMICART::SplitPattern APDYNAMICART::SplitReversePattern APDYNAMICART::StandardPattern APDYNAMICART::TopPattern APDYNAMICART::TopReversePattern

Public Member Functions

PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
virtual std::string | getName ()=0
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)

Protected Member Functions

virtual | ~PatternBase ()
virtual Vec3ArrayPtr | compute (Vec3ArrayPtr left, Vec3ArrayPtr right)=0

Protected Attributes

Vec3ArrayPtr _array

Detailed Description

PatternBase class

Constructor & Destructor Documentation

APDYNAMICART::PatternBase::PatternBase ( )
inline
virtual APDYNAMICART::PatternBase::~PatternBase ( )
inlineprotectedvirtual

Member Function Documentation

virtual Vec3ArrayPtr APDYNAMICART::PatternBase::compute | ( | Vec3ArrayPtr | left,
 |  | Vec3ArrayPtr | right
 | ) |  |
protectedpure virtual
virtual Vec3ArrayPtr APDYNAMICART::PatternBase::generate | ( | Vec3ArrayPtr | left,
 |  | Vec3ArrayPtr | right
 | ) |  |
inlinevirtual

Implements APDYNAMICART::Pattern.

virtual std::string APDYNAMICART::PatternBase::getName ( )
pure virtual

Implements APDYNAMICART::Pattern.

Vec3ArrayPtr APDYNAMICART::PatternBase::getVertexArray ( ) const
inline

Getters and setters

void APDYNAMICART::PatternBase::setVertexArray ( Vec3ArrayPtr val )
inline

Member Data Documentation

Vec3ArrayPtr APDYNAMICART::PatternBase::_array
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PatternFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternFactory
Static Public Member Functions | List of all members
APDYNAMICART::PatternFactory Class Reference

#include <Pattern.h>

Static Public Member Functions

static std::vector< std::string > | getAvaiablePatterns ()
static PatternPtr | getPattern (const std::string &name)

Detailed Description

PatternBase factory

Member Function Documentation

std::vector< std::string > APDYNAMICART::PatternFactory::getAvaiablePatterns ( )
static
PatternPtr APDYNAMICART::PatternFactory::getPattern ( const std::string & name )
static
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullPattern
List of all members
APDYNAMICART::NullPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::NullPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array

Detailed Description

Patterns

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::AcrossPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AcrossPattern
List of all members
APDYNAMICART::AcrossPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::AcrossPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::CrissCrossPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • CrissCrossPattern
List of all members
APDYNAMICART::CrissCrossPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::CrissCrossPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::DoublePattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DoublePattern
List of all members
APDYNAMICART::DoublePattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::DoublePattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HyperbolicPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HyperbolicPattern
List of all members
APDYNAMICART::HyperbolicPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::HyperbolicPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::TopPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • TopPattern
List of all members
APDYNAMICART::TopPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::TopPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::TopReversePattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • TopReversePattern
List of all members
APDYNAMICART::TopReversePattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::TopReversePattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::StandardPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • StandardPattern
List of all members
APDYNAMICART::StandardPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::StandardPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SplitPattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplitPattern
List of all members
APDYNAMICART::SplitPattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::SplitPattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SplitReversePattern Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplitReversePattern
List of all members
APDYNAMICART::SplitReversePattern Class Reference

#include <Pattern.h>

Inheritance diagram for APDYNAMICART::SplitReversePattern:
APDYNAMICART::PatternBase APDYNAMICART::Pattern

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PatternBase
PatternBase ()
virtual Vec3ArrayPtr | generate (Vec3ArrayPtr left, Vec3ArrayPtr right)
Vec3ArrayPtr | getVertexArray () const
void | setVertexArray (Vec3ArrayPtr val)
- Protected Member Functions inherited from APDYNAMICART::PatternBase
virtual | ~PatternBase ()
- Protected Attributes inherited from APDYNAMICART::PatternBase
Vec3ArrayPtr _array
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PatternsGeode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternsGeode
Public Member Functions | List of all members
APDYNAMICART::PatternsGeode Class Reference

#include <PatternGeode.h>

Inheritance diagram for APDYNAMICART::PatternsGeode:

Public Member Functions

PatternsGeode ()
PatternsGeode (const PatternsGeode &, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY)
META_Node (APDYNAMICART, PatternsGeode)
float | getStringLineWidth () const
Vec3ArrayPtr | getPatternsPointsArray () const
void | setVertexArray (Vec3ArrayPtr points)
void | setStringLineWidth (float val)
void | updateGeometry ()

Constructor & Destructor Documentation

PatternsGeode::PatternsGeode ( )

Constructors

PatternsGeode::PatternsGeode | ( | const PatternsGeode & | patternGeode,
 |  | const osg::CopyOp & | copyop = osg::CopyOp::SHALLOW_COPY
 | ) |  |

Member Function Documentation

Vec3ArrayPtr APDYNAMICART::PatternsGeode::getPatternsPointsArray ( ) const
inline
float APDYNAMICART::PatternsGeode::getStringLineWidth ( ) const
inline

Getters

APDYNAMICART::PatternsGeode::META_Node | ( | APDYNAMICART | ,
 |  | PatternsGeode |
 | ) |  |
void APDYNAMICART::PatternsGeode::setStringLineWidth ( float val )
inline
void APDYNAMICART::PatternsGeode::setVertexArray ( Vec3ArrayPtr points )
inline

Setters

Inline methods

void PatternsGeode::updateGeometry ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PatternGeode.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PatternGeode.cpp
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PerlinLines Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PerlinLines
Public Member Functions | Protected Types | Protected Attributes | List of all members
APDYNAMICART::PerlinLines Class Reference

#include <PerlinLines.h>

Inheritance diagram for APDYNAMICART::PerlinLines:
APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

PerlinLines (Controller *contr, int numberOfLines, double x, double y, double z)
~PerlinLines ()
int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
Load configuration of PoA from .XML node. More...
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
Creates structure of menu items for this PoA. More...
void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
void | setColor (osg::Vec4 newColour)
void | update ()
Update of PoA - e.g. re-rendering. More...
void | draw ()
void | setLineParameters (int count)
void | setLinesParameters ()
double | perlinNoise (osg::Vec3 temp)
double | smooth (osg::Vec3 temp, double sx, double sy, double sz)
double | interpolate (double a, double b, double c)
void | interpolateVec3 (osg::Vec3Array *controlPoints, osg::Vec3Array *interpolatedPoints, int p_steps)
osg::Vec3 | interpolatePoint (double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0=osg::Vec3(0.0, 0.0, 0.0), osg::Vec3 point3=osg::Vec3(0.0, 0.0, 0.0))
double | random (double min, double max)
void | setMagnet (osg::Vec3 coordinates, float magnetSize)
void | createMagnet (EnvironmentObject *daarea, bool first)
void | updateMagnetPosition (osg::Vec3 vektor, float size)
void | unsetMagnet ()
void | setBounding (float boundingSize, bool first)
void | setBoundingVisible ()
void | unsetBounding ()
void | recalculateColorInterpolation ()
void | setColor (osg::Vec3 color)
void | setSpeed (int speed)
int | getSpeed ()
void | setInterpolationCount (int interpolationCount)
int | getInterpolationCount ()
void | setLength (int length)
void | setColor (float r, float g, float b)
void | setController (osg::Vec3 vektor)
void | unsetController ()
void | updateControllerPosition (osg::Vec3 vektor)
int | getLength ()
void | pause ()
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

typedef osg::ref_ptr
< osg::Vec3Array > 		Vec3Ptr

Protected Attributes

osg::ref_ptr< osg::Geode > | _lineGeode
osg::ref_ptr< osg::Geode > | _boxGeode
std::vector< osg::ref_ptr
< osg::Geometry > > 		_lineGeometry
osg::ref_ptr< osg::Vec4Array > | _linesColorArray
osg::ref_ptr< osg::Vec4Array > | _boxColorArray
osg::ref_ptr< osg::Vec4Array > | _newLinesColorArray
osg::ref_ptr< osg::StateSet > | _OSGState
osg::ref_ptr< osg::StateSet > | _boxOSGState
osg::ref_ptr< osg::LineWidth > | _linewidth
osg::ref_ptr< osg::Material > | _linesMaterial
osg::ref_ptr< osg::Material > | _boxMaterial
std::vector< Vec3Ptr > | _lines
std::vector< Vec3Ptr > | _interpolatedLines
Vec3Ptr gradient
int | _p [512]
float | _magnetSize
float | _boundingSize
u_int | _speed
u_int | _trigger
u_int | _interpolationCount
u_int | _length
osg::Vec3 | _magnetCoords
osg::Vec3 | _unusedMagnetCoords
osg::Vec3 | _controllerCoords
bool | _somethingChaned
bool | _request
bool | _pointed
bool | _paused
bool | _magnetUsed
bool | _magnetON
bool | _controllerUsed
bool | _boundingUsed
bool | _boundingVisible
bool | _magnetCreated
bool | _boundingCreated
u_int | changedSpeed
u_int | changedInterpolation
u_int | changedLength
float | _red
float | _green
float | _blue
float | _changedRed
float | _changedGreen
float | _changedBlue
EnvironmentObject * magnetEO
EnvironmentObject * particlesEO
EnvironmentObject * _daArea
bool | firstTimeUpdate
osg::ref_ptr< osg::Geode > | magnetGeode
osg::ref_ptr< osg::StateSet > | magnetStateSet
osg::ref_ptr< osg::Material > | magnetMaterial
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Member Functions inherited from vrecko::EnvironmentObject
void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)

Member Typedef Documentation

typedef osg::ref_ptr<osg::Vec3Array> APDYNAMICART::PerlinLines::Vec3Ptr
protected

Constructor & Destructor Documentation

APDYNAMICART::PerlinLines::PerlinLines | ( | Controller * | contr,
 |  | int | numberOfLines,
 |  | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
APDYNAMICART::PerlinLines::~PerlinLines ( )

Member Function Documentation

void APDYNAMICART::PerlinLines::createMagnet | ( | EnvironmentObject * | daarea,
 |  | bool | first
 | ) |  |
inline
void APDYNAMICART::PerlinLines::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PerlinLines::draw ( )
int APDYNAMICART::PerlinLines::getInterpolationCount ( )
inline
int APDYNAMICART::PerlinLines::getLength ( )
inline
int APDYNAMICART::PerlinLines::getSpeed ( )
inline
void APDYNAMICART::PerlinLines::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PerlinLines::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

double APDYNAMICART::PerlinLines::interpolate | ( | double | a,
 |  | double | b,
 |  | double | c
 | ) |  |
Vec3 APDYNAMICART::PerlinLines::interpolatePoint | ( | double | t,
 |  | osg::Vec3 | point1,
 |  | osg::Vec3 | point2,
 |  | osg::Vec3 | point0 = osg::Vec3(0.0, 0.0, 0.0),
 |  | osg::Vec3 | point3 = osg::Vec3(0.0, 0.0, 0.0)
 | ) |  |
void APDYNAMICART::PerlinLines::interpolateVec3 | ( | osg::Vec3Array * | controlPoints,
 |  | osg::Vec3Array * | interpolatedPoints,
 |  | int | p_steps
 | ) |  |
int APDYNAMICART::PerlinLines::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
inlinevirtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Implements APDYNAMICART::PoA.

void APDYNAMICART::PerlinLines::pause ( )
inline
double APDYNAMICART::PerlinLines::perlinNoise ( osg::Vec3 temp )
void APDYNAMICART::PerlinLines::pointed ( bool pointed )
virtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

double APDYNAMICART::PerlinLines::random | ( | double | min,
 |  | double | max
 | ) |  |
inline
void APDYNAMICART::PerlinLines::recalculateColorInterpolation ( )
void APDYNAMICART::PerlinLines::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
inlinevirtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PerlinLines::setBounding | ( | float | boundingSize,
 |  | bool | first
 | ) |  |
inline
void APDYNAMICART::PerlinLines::setBoundingVisible ( )
inline
void APDYNAMICART::PerlinLines::setColor ( osg::Vec4 newColour )
inline
void APDYNAMICART::PerlinLines::setColor ( osg::Vec3 color )
inline
void APDYNAMICART::PerlinLines::setColor | ( | float | r,
 |  | float | g,
 |  | float | b
 | ) |  |
inline
void APDYNAMICART::PerlinLines::setController ( osg::Vec3 vektor )
void APDYNAMICART::PerlinLines::setInterpolationCount ( int interpolationCount )
inline
void APDYNAMICART::PerlinLines::setLength ( int length )
inline
void APDYNAMICART::PerlinLines::setLineParameters ( int count )
void APDYNAMICART::PerlinLines::setLinesParameters ( )
void APDYNAMICART::PerlinLines::setMagnet | ( | osg::Vec3 | coordinates,
 |  | float | magnetSize
 | ) |  |
inline
void APDYNAMICART::PerlinLines::setSpeed ( int speed )
inline
double APDYNAMICART::PerlinLines::smooth | ( | osg::Vec3 | temp,
 |  | double | sx,
 |  | double | sy,
 |  | double | sz
 | ) |  |
void APDYNAMICART::PerlinLines::unsetBounding ( )
inline
void APDYNAMICART::PerlinLines::unsetController ( )
inline
void APDYNAMICART::PerlinLines::unsetMagnet ( )
inline
void APDYNAMICART::PerlinLines::update ( )
virtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PerlinLines::updateControllerPosition ( osg::Vec3 vektor )
inline
void APDYNAMICART::PerlinLines::updateMagnetPosition | ( | osg::Vec3 | vektor,
 |  | float | size
 | ) |  |

Member Data Documentation

float APDYNAMICART::PerlinLines::_blue
protected
bool APDYNAMICART::PerlinLines::_boundingCreated
protected
float APDYNAMICART::PerlinLines::_boundingSize
protected
bool APDYNAMICART::PerlinLines::_boundingUsed
protected
bool APDYNAMICART::PerlinLines::_boundingVisible
protected
osg::ref_ptr<osg::Vec4Array> APDYNAMICART::PerlinLines::_boxColorArray
protected
osg::ref_ptr<osg::Geode> APDYNAMICART::PerlinLines::_boxGeode
protected
osg::ref_ptr<osg::Material> APDYNAMICART::PerlinLines::_boxMaterial
protected
osg::ref_ptr<osg::StateSet> APDYNAMICART::PerlinLines::_boxOSGState
protected
float APDYNAMICART::PerlinLines::_changedBlue
protected
float APDYNAMICART::PerlinLines::_changedGreen
protected
float APDYNAMICART::PerlinLines::_changedRed
protected
osg::Vec3 APDYNAMICART::PerlinLines::_controllerCoords
protected
bool APDYNAMICART::PerlinLines::_controllerUsed
protected
EnvironmentObject* APDYNAMICART::PerlinLines::_daArea
protected
float APDYNAMICART::PerlinLines::_green
protected
std::vector<Vec3Ptr> APDYNAMICART::PerlinLines::_interpolatedLines
protected
u_int APDYNAMICART::PerlinLines::_interpolationCount
protected
u_int APDYNAMICART::PerlinLines::_length
protected
osg::ref_ptr<osg::Geode> APDYNAMICART::PerlinLines::_lineGeode
protected
std::vector<osg::ref_ptr<osg::Geometry> > APDYNAMICART::PerlinLines::_lineGeometry
protected
std::vector<Vec3Ptr> APDYNAMICART::PerlinLines::_lines
protected
osg::ref_ptr<osg::Vec4Array> APDYNAMICART::PerlinLines::_linesColorArray
protected
osg::ref_ptr<osg::Material> APDYNAMICART::PerlinLines::_linesMaterial
protected
osg::ref_ptr<osg::LineWidth> APDYNAMICART::PerlinLines::_linewidth
protected
osg::Vec3 APDYNAMICART::PerlinLines::_magnetCoords
protected
bool APDYNAMICART::PerlinLines::_magnetCreated
protected
bool APDYNAMICART::PerlinLines::_magnetON
protected
float APDYNAMICART::PerlinLines::_magnetSize
protected
bool APDYNAMICART::PerlinLines::_magnetUsed
protected
osg::ref_ptr<osg::Vec4Array> APDYNAMICART::PerlinLines::_newLinesColorArray
protected
osg::ref_ptr<osg::StateSet> APDYNAMICART::PerlinLines::_OSGState
protected
int APDYNAMICART::PerlinLines::_p[512]
protected
bool APDYNAMICART::PerlinLines::_paused
protected
bool APDYNAMICART::PerlinLines::_pointed
protected
float APDYNAMICART::PerlinLines::_red
protected
bool APDYNAMICART::PerlinLines::_request
protected
bool APDYNAMICART::PerlinLines::_somethingChaned
protected
u_int APDYNAMICART::PerlinLines::_speed
protected
u_int APDYNAMICART::PerlinLines::_trigger
protected
osg::Vec3 APDYNAMICART::PerlinLines::_unusedMagnetCoords
protected
u_int APDYNAMICART::PerlinLines::changedInterpolation
protected
u_int APDYNAMICART::PerlinLines::changedLength
protected
u_int APDYNAMICART::PerlinLines::changedSpeed
protected
bool APDYNAMICART::PerlinLines::firstTimeUpdate
protected
Vec3Ptr APDYNAMICART::PerlinLines::gradient
protected
EnvironmentObject* APDYNAMICART::PerlinLines::magnetEO
protected
osg::ref_ptr<osg::Geode> APDYNAMICART::PerlinLines::magnetGeode
protected
osg::ref_ptr<osg::Material> APDYNAMICART::PerlinLines::magnetMaterial
protected
osg::ref_ptr<osg::StateSet> APDYNAMICART::PerlinLines::magnetStateSet
protected
EnvironmentObject* APDYNAMICART::PerlinLines::particlesEO
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLines.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLines.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PLNestTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLNestTool
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PLNestTool Class Reference

#include <PerlinLinesTools.h>

Inheritance diagram for APDYNAMICART::PLNestTool:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

PLNestTool ()
~PLNestTool ()
void | activate ()
Activate tool. More...
void | deactivate ()
Deactivate tool. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Attributes

EnvironmentObject * DAArea
osg::ClipNode * | clipNode
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vreckoUtils::Observable
Observable ()

Constructor & Destructor Documentation

APDYNAMICART::PLNestTool::PLNestTool ( )
APDYNAMICART::PLNestTool::~PLNestTool ( )
inline

Member Function Documentation

void APDYNAMICART::PLNestTool::activate ( )
inlinevirtual

Activate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLNestTool::deactivate ( )
inlinevirtual

Deactivate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLNestTool::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::PLNestTool::turnOff ( )
inlinevirtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLNestTool::turnOn ( )
inlinevirtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLNestTool::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::ClipNode* APDYNAMICART::PLNestTool::clipNode
protected
EnvironmentObject* APDYNAMICART::PLNestTool::DAArea
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLinesTools.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLinesTools.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PLMagnetTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLMagnetTool
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PLMagnetTool Class Reference

#include <PerlinLinesTools.h>

Inheritance diagram for APDYNAMICART::PLMagnetTool:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

PLMagnetTool ()
~PLMagnetTool ()
void | activate ()
Activate tool. More...
void | deactivate ()
Deactivate tool. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Attributes

EnvironmentObject * DAArea
osg::ClipNode * | clipNode
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vreckoUtils::Observable
Observable ()

Constructor & Destructor Documentation

APDYNAMICART::PLMagnetTool::PLMagnetTool ( )
APDYNAMICART::PLMagnetTool::~PLMagnetTool ( )
inline

Member Function Documentation

void APDYNAMICART::PLMagnetTool::activate ( )
inlinevirtual

Activate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLMagnetTool::deactivate ( )
inlinevirtual

Deactivate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLMagnetTool::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::PLMagnetTool::turnOff ( )
inlinevirtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLMagnetTool::turnOn ( )
inlinevirtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLMagnetTool::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::ClipNode* APDYNAMICART::PLMagnetTool::clipNode
protected
EnvironmentObject* APDYNAMICART::PLMagnetTool::DAArea
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLinesTools.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLinesTools.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PLControllerTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLControllerTool
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PLControllerTool Class Reference

#include <PerlinLinesTools.h>

Inheritance diagram for APDYNAMICART::PLControllerTool:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

PLControllerTool ()
~PLControllerTool ()
void | activate ()
Activate tool. More...
void | deactivate ()
Deactivate tool. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Attributes

EnvironmentObject * DAArea
osg::ClipNode * | clipNode
osg::ClipPlane * | lowClipPlane
osg::ClipPlane * | topClipPlane
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vreckoUtils::Observable
Observable ()

Constructor & Destructor Documentation

APDYNAMICART::PLControllerTool::PLControllerTool ( )
APDYNAMICART::PLControllerTool::~PLControllerTool ( )
inline

Member Function Documentation

void APDYNAMICART::PLControllerTool::activate ( )
inlinevirtual

Activate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLControllerTool::deactivate ( )
inlinevirtual

Deactivate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLControllerTool::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

how thick will slice be

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::PLControllerTool::turnOff ( )
inlinevirtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLControllerTool::turnOn ( )
inlinevirtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::PLControllerTool::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::ClipNode* APDYNAMICART::PLControllerTool::clipNode
protected
EnvironmentObject* APDYNAMICART::PLControllerTool::DAArea
protected
osg::ClipPlane* APDYNAMICART::PLControllerTool::lowClipPlane
protected
osg::ClipPlane* APDYNAMICART::PLControllerTool::topClipPlane
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLinesTools.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLinesTools.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SimulationParameters Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SimulationParameters
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::SimulationParameters Struct Reference

#include <PhysXManager.h>

Public Member Functions

SimulationParameters ()

Public Attributes

double | detailCoef
double | hoopDensity
double | stringSpring
double | stringDamper

Constructor & Destructor Documentation

APDYNAMICART::SimulationParameters::SimulationParameters ( )
inline

Member Data Documentation

double APDYNAMICART::SimulationParameters::detailCoef
double APDYNAMICART::SimulationParameters::hoopDensity
double APDYNAMICART::SimulationParameters::stringDamper
double APDYNAMICART::SimulationParameters::stringSpring
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PhysXManager.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PhysXManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PhysXManager
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::PhysXManager Class Reference

#include <PhysXManager.h>

Public Member Functions

void | releasePhysics ()
bool | init ()
bool | createScene ()
void | getPhysicsResult ()
void | startPhysics ()
NxActor * | addHoopActorToScene (Hoop *hoop, NxVec3 linearVelocity=NxVec3(0.2, 0.0,-1.0))
void | setStringJoints (HoopPtr first, HoopPtr second, Vec3ArrayPtr points)
void | setActorPosition (HoopPtr hoop)
void | setActorOrientation (HoopPtr hoop)
void | addForceToHoop (HoopPtr hoop, const osg::Vec3 &direction)
void | resetScene ()
void | releaseHoopActor (HoopPtr hoop)
void | releaseHoopJoints ()
void | createRope (HoopPtr hoop, const osg::Vec3 &pos, double segHeight, double radius, unsigned int segments)
const std::vector< NxActor * > & | getRopeActors () const
SimulationParameters & getSimualtionParameters ()
bool | isRunning () const
void | setSimulationRun (bool val)

Static Public Member Functions

static PhysXManager * | get ()
static NxQuat | toNxQuat (const osg::Quat &qRot)
static NxVec3 | toNxVec3 (const osg::Vec3 &point)
static osg::Vec3 | toOsgVec3 (const NxVec3 &point)
static osg::Quat | toOsgQuat (const NxQuat &qRot)
static osg::Matrix | getDAMatrix ()

Protected Member Functions

PhysXManager ()
NxVec3 | transformToLocalCoord (Hoop *hoop, const osg::Vec3 &point)
NxSphericalJoint * | createRopeSphericalJoint (NxActor *a0, NxActor *a1, const NxVec3 &globalAnchor, const NxVec3 &globalAxis)
NxActor * | createCapsule (const NxVec3 &pos, const NxReal height, const NxReal radius)

Protected Attributes

NxPhysicsSDK * | _physicsSDK
NxScene * | _scene
float | _deltaTime
bool | _simulationRunning
NxVec3 | _linearVelocity
SimulationParameters _parameters
std::vector< NxJoint * > | _joints
std::vector< NxActor * > | _ropeSegs
std::vector< NxSphericalJoint * > | _ropeLinks

Constructor & Destructor Documentation

APDYNAMICART::PhysXManager::PhysXManager ( )
protected

Member Function Documentation

void APDYNAMICART::PhysXManager::addForceToHoop | ( | HoopPtr | hoop,
 |  | const osg::Vec3 & | direction
 | ) |  |
NxActor * APDYNAMICART::PhysXManager::addHoopActorToScene | ( | Hoop * | hoop,
 |  | NxVec3 | linearVelocity = NxVec3(0.2,0.0,-1.0)
 | ) |  |
NxActor * APDYNAMICART::PhysXManager::createCapsule | ( | const NxVec3 & | pos,
 |  | const NxReal | height,
 |  | const NxReal | radius
 | ) |  |
protected
void APDYNAMICART::PhysXManager::createRope | ( | HoopPtr | hoop,
 |  | const osg::Vec3 & | pos,
 |  | double | segHeight,
 |  | double | radius,
 |  | unsigned int | segments
 | ) |  |
NxSphericalJoint * APDYNAMICART::PhysXManager::createRopeSphericalJoint | ( | NxActor * | a0,
 |  | NxActor * | a1,
 |  | const NxVec3 & | globalAnchor,
 |  | const NxVec3 & | globalAxis
 | ) |  |
protected
bool APDYNAMICART::PhysXManager::createScene ( )
static PhysXManager* APDYNAMICART::PhysXManager::get ( )
inlinestatic
osg::Matrix APDYNAMICART::PhysXManager::getDAMatrix ( )
inlinestatic
void APDYNAMICART::PhysXManager::getPhysicsResult ( )
const std::vector< NxActor * > & APDYNAMICART::PhysXManager::getRopeActors ( ) const
SimulationParameters& APDYNAMICART::PhysXManager::getSimualtionParameters ( )
inline
bool APDYNAMICART::PhysXManager::init ( void )
bool APDYNAMICART::PhysXManager::isRunning ( ) const
inline
void APDYNAMICART::PhysXManager::releaseHoopActor ( HoopPtr hoop )
void APDYNAMICART::PhysXManager::releaseHoopJoints ( )
void APDYNAMICART::PhysXManager::releasePhysics ( )
void APDYNAMICART::PhysXManager::resetScene ( )
void APDYNAMICART::PhysXManager::setActorOrientation ( HoopPtr hoop )
void APDYNAMICART::PhysXManager::setActorPosition ( HoopPtr hoop )
void APDYNAMICART::PhysXManager::setSimulationRun ( bool val )
inline
void APDYNAMICART::PhysXManager::setStringJoints | ( | HoopPtr | first,
 |  | HoopPtr | second,
 |  | Vec3ArrayPtr | points
 | ) |  |
void APDYNAMICART::PhysXManager::startPhysics ( )
NxQuat APDYNAMICART::PhysXManager::toNxQuat ( const osg::Quat & qRot )
inlinestatic

Helper methods

NxVec3 APDYNAMICART::PhysXManager::toNxVec3 ( const osg::Vec3 & point )
inlinestatic
osg::Quat APDYNAMICART::PhysXManager::toOsgQuat ( const NxQuat & qRot )
inlinestatic
osg::Vec3 APDYNAMICART::PhysXManager::toOsgVec3 ( const NxVec3 & point )
inlinestatic
NxVec3 APDYNAMICART::PhysXManager::transformToLocalCoord | ( | Hoop * | hoop,
 |  | const osg::Vec3 & | point
 | ) |  |
inlineprotected

Member Data Documentation

float APDYNAMICART::PhysXManager::_deltaTime
protected
std::vector<NxJoint*> APDYNAMICART::PhysXManager::_joints
protected
NxVec3 APDYNAMICART::PhysXManager::_linearVelocity
protected
SimulationParameters APDYNAMICART::PhysXManager::_parameters
protected
NxPhysicsSDK* APDYNAMICART::PhysXManager::_physicsSDK
protected
std::vector<NxSphericalJoint*> APDYNAMICART::PhysXManager::_ropeLinks
protected
std::vector<NxActor*> APDYNAMICART::PhysXManager::_ropeSegs
protected
NxScene* APDYNAMICART::PhysXManager::_scene
protected
bool APDYNAMICART::PhysXManager::_simulationRunning
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PhysXManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PhysXManager.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PoA Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoA
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PoA Class Referenceabstract

PoA (Piece of Art) More...

#include <PoA.h>

Inheritance diagram for APDYNAMICART::PoA:
vrecko::EnvironmentObject vrecko::BaseClass APDYNAMICART::Attractor APDYNAMICART::BrushStroke APDYNAMICART::HookObject APDYNAMICART::Hoop APDYNAMICART::PerlinLines APDYNAMICART::PolyhedraSculpture APDYNAMICART::JuliaAttractor APDYNAMICART::NullAttractor APDYNAMICART::OrdinaryAttractor APDYNAMICART::MotionTrail

Public Member Functions

PoA (Controller *contr)
~PoA ()
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0
Creates structure of menu items for this PoA. More...
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0
Load configuration of PoA from .XML node. More...
virtual void | GUIItemClicked (const char *itemID)=0
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)=0
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)=0
Called when user point with cursor (hand) to this PoA. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0
Save current state of PoA to .XML node. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
virtual void | update ()=0
Update of PoA - e.g. re-rendering. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::EnvironmentObject
void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)

Detailed Description

PoA (Piece of Art)

Pure virtual class, serve as base for all types of top-level visual objects of Dynamic Art - BrushStroke, ChaoticAttractor, PerlinLines, Sculptures, ...

Author
Jiri Chmelik
Date
2010-...

Constructor & Destructor Documentation

APDYNAMICART::PoA::PoA ( Controller * contr )
APDYNAMICART::PoA::~PoA ( )

Member Function Documentation

virtual void APDYNAMICART::PoA::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
pure virtual

Creates structure of menu items for this PoA.

Returns
xml description of menu items as stringCreates structure of menu items for this PoA

add own menu items to given parent menu.

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::PerlinLines, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, APDYNAMICART::JuliaAttractor, and APDYNAMICART::NullAttractor.

APDYNAMICART::PoA::DECLARE_INPUT | ( | Colour | ,
 |  | MessageVec4 |
 | ) |  |
osg::Quat APDYNAMICART::PoA::getLeftHandOrientation ( ) const
virtual

Get actual orientation of left hand from DAEnvironment.

osg::Vec3 APDYNAMICART::PoA::getLeftHandPosition ( ) const
virtual

Get actual position of left hand from DAEnvironment.

osg::Quat APDYNAMICART::PoA::getRightHandOrientation ( ) const
virtual

Get actual orientation of right hand from DAEnvironment.

osg::Vec3 APDYNAMICART::PoA::getRightHandPosition ( ) const
virtual

Get actual position of right hand from DAEnvironment.

PoAUpdateType APDYNAMICART::PoA::getUpdateFlag ( )
inline

export current state of PoA to some file - .3ds or something like that

Todo:
later
virtual void APDYNAMICART::PoA::GUIItemClicked ( const char * itemID )
pure virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::Attractor, APDYNAMICART::PerlinLines, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, and APDYNAMICART::JuliaAttractor.

virtual void APDYNAMICART::PoA::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
pure virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::Attractor, APDYNAMICART::PerlinLines, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, and APDYNAMICART::JuliaAttractor.

virtual int APDYNAMICART::PoA::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
pure virtual

Load configuration of PoA from .XML node.

Parameters
PoANode pointer to node containing info about this PoA
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::Attractor, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, and APDYNAMICART::PerlinLines.

virtual void APDYNAMICART::PoA::pointed ( bool pointed )
pure virtual

Called when user point with cursor (hand) to this PoA.

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::Attractor, APDYNAMICART::PerlinLines, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, and APDYNAMICART::HookObject.

virtual void APDYNAMICART::PoA::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
pure virtual

Save current state of PoA to .XML node.

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, APDYNAMICART::PerlinLines, APDYNAMICART::JuliaAttractor, and APDYNAMICART::NullAttractor.

void APDYNAMICART::PoA::setUpdateFlag ( PoAUpdateType newType )

Set type of updates, add (or remove) PoA to (from) scheduler.

virtual void APDYNAMICART::PoA::update ( )
pure virtual

Update of PoA - e.g. re-rendering.

Reimplemented from vrecko::BaseClass.

Implemented in APDYNAMICART::BrushStroke, APDYNAMICART::OrdinaryAttractor, APDYNAMICART::Attractor, APDYNAMICART::PerlinLines, APDYNAMICART::PolyhedraSculpture, APDYNAMICART::Hoop, APDYNAMICART::HookObject, and APDYNAMICART::JuliaAttractor.

Member Data Documentation

const Controller* APDYNAMICART::PoA::_controller
protected

Pointer to controller of this PoA.

DAEnvironment* APDYNAMICART::PoA::_daEnvironment
protected

Pointer to DA environment.

PoAUpdateType APDYNAMICART::PoA::_updateFlag
protected

What type of update this PoA actualy need.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PoA.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoA.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PolyhedraSculpture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolyhedraSculpture
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::PolyhedraSculpture Class Reference

#include <PolyhedraSculpture.h>

Inheritance diagram for APDYNAMICART::PolyhedraSculpture:
APDYNAMICART::PoA vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

PolyhedraSculpture (Controller *controller, const string &polyhedronName)
void | addLayer (const string &polyhedronName)
void | addAndSwitchLayer (const string &polyhedronName)
virtual void | createMenuStructure (osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
Save current state of PoA to .XML node. More...
virtual void | GUIItemClicked (const char *itemID)
Called when user click on some item of PoA context menu. More...
virtual void | GUISliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
virtual void | pointed (bool pointed)
Called when user point with cursor (hand) to this PoA. More...
virtual void | update ()
Update of PoA - e.g. re-rendering. More...
void | switchToLayer (unsigned int number)
- Public Member Functions inherited from APDYNAMICART::PoA
PoA (Controller *contr)
~PoA ()
PoAUpdateType getUpdateFlag ()
virtual osg::Vec3 | getLeftHandPosition () const
Get actual position of left hand from DAEnvironment. More...
virtual osg::Quat | getLeftHandOrientation () const
Get actual orientation of left hand from DAEnvironment. More...
virtual osg::Vec3 | getRightHandPosition () const
Get actual position of right hand from DAEnvironment. More...
virtual osg::Quat | getRightHandOrientation () const
Get actual orientation of right hand from DAEnvironment. More...
void | setUpdateFlag (PoAUpdateType newType)
Set type of updates, add (or remove) PoA to (from) scheduler. More...
DECLARE_INPUT (Colour, MessageVec4)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

MenuPtr createNewShowHideMenu () const

Protected Attributes

Controller * _contr
PS_LayerPtr _activeLayer
pointer to currently active layer More...
std::vector< PS_LayerPtr > | _layers
vector of all existing layers More...
- Protected Attributes inherited from APDYNAMICART::PoA
DAEnvironment * _daEnvironment
Pointer to DA environment. More...
const Controller * | _controller
Pointer to controller of this PoA. More...
PoAUpdateType _updateFlag
What type of update this PoA actualy need. More...
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::PolyhedraSculpture::PolyhedraSculpture | ( | Controller * | controller,
 |  | const string & | polyhedronName
 | ) |  |

Member Function Documentation

void APDYNAMICART::PolyhedraSculpture::addAndSwitchLayer ( const string & polyhedronName )
void APDYNAMICART::PolyhedraSculpture::addLayer ( const string & polyhedronName )

add layer to vector

void APDYNAMICART::PolyhedraSculpture::createMenuStructure ( osg::ref_ptr< vreckoUtils::MenuBase > parentMenu ) const
virtual

Inherited methods

Implements APDYNAMICART::PoA.

MenuPtr APDYNAMICART::PolyhedraSculpture::createNewShowHideMenu ( ) const
protected

Helper methods

void APDYNAMICART::PolyhedraSculpture::GUIItemClicked ( const char * itemID )
virtual

Called when user click on some item of PoA context menu.

Parameters
itemID contains 'name' of menu item.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PolyhedraSculpture::GUISliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider

Implements APDYNAMICART::PoA.

int APDYNAMICART::PolyhedraSculpture::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoANode )
virtual

Saving and loading

Implements APDYNAMICART::PoA.

virtual void APDYNAMICART::PolyhedraSculpture::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand) to this PoA.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PolyhedraSculpture::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

Save current state of PoA to .XML node.

Implements APDYNAMICART::PoA.

void APDYNAMICART::PolyhedraSculpture::switchToLayer ( unsigned int number )
void APDYNAMICART::PolyhedraSculpture::update ( )
virtual

Update of PoA - e.g. re-rendering.

Implements APDYNAMICART::PoA.

Member Data Documentation

PS_LayerPtr APDYNAMICART::PolyhedraSculpture::_activeLayer
protected

pointer to currently active layer

Controller* APDYNAMICART::PolyhedraSculpture::_contr
protected

Getters and setters

std::vector<PS_LayerPtr> APDYNAMICART::PolyhedraSculpture::_layers
protected

vector of all existing layers

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PolyhedraSculpture.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PolyhedraSculpture.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_Component Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Component
Public Member Functions | List of all members
APDYNAMICART::PS_Component Class Reference

#include <PS_Component.h>

Inheritance diagram for APDYNAMICART::PS_Component:
APDYNAMICART::PS_FlatShape

Public Member Functions

PS_Component ()

Constructor & Destructor Documentation

APDYNAMICART::PS_Component::PS_Component ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Component.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Component.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_Layer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Layer
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PS_Layer Class Reference

#include <PS_emptyClass.h>

Inheritance diagram for APDYNAMICART::PS_Layer:

Public Member Functions

PS_Layer (osg::Group *group, const std::string &polyhedronName)
void | activate ()
void | deactivate ()
double | getOpacity () const
void | setOpacity (double val)

Protected Attributes

double _opacity
opacity of layer More...
PS_PolyhedronPtr _polyhedron
basic polyhedron of this layer More...
PS_ComponentPtr _component
definition of component of this layer More...
osg::ref_ptr
< osg::MatrixTransform > 		_visuals

Constructor & Destructor Documentation

APDYNAMICART::PS_Layer::PS_Layer | ( | osg::Group * | group,
 |  | const std::string & | polyhedronName
 | ) |  |

Member Function Documentation

void APDYNAMICART::PS_Layer::activate ( )
void APDYNAMICART::PS_Layer::deactivate ( )
double APDYNAMICART::PS_Layer::getOpacity ( ) const
inline
void APDYNAMICART::PS_Layer::setOpacity ( double val )
inline

Member Data Documentation

PS_ComponentPtr APDYNAMICART::PS_Layer::_component
protected

definition of component of this layer

double APDYNAMICART::PS_Layer::_opacity
protected

opacity of layer

PS_PolyhedronPtr APDYNAMICART::PS_Layer::_polyhedron
protected

basic polyhedron of this layer

osg::ref_ptr<osg::MatrixTransform> APDYNAMICART::PS_Layer::_visuals
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_emptyClass.h
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Layer.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Layer.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_Face Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Face
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PS_Face Class Reference

#include <PS_Face.h>

Inheritance diagram for APDYNAMICART::PS_Face:
APDYNAMICART::PS_FlatShape

Public Member Functions

PS_Face (osg::ref_ptr< osg::Vec3Array > vertices)
void | updateColors (osg::Vec4 color)
void | pointed (bool pointed)

Protected Attributes

osg::ref_ptr< osg::Vec3Array > | _vertices
osg::ref_ptr< osg::Geometry > | _geometry
osg::ref_ptr
< vreckoUtils::HighlightCallback > 		_highlight

Constructor & Destructor Documentation

APDYNAMICART::PS_Face::PS_Face ( osg::ref_ptr< osg::Vec3Array > vertices )

Member Function Documentation

void APDYNAMICART::PS_Face::pointed ( bool pointed )
inline
void APDYNAMICART::PS_Face::updateColors ( osg::Vec4 color )

Member Data Documentation

osg::ref_ptr<osg::Geometry> APDYNAMICART::PS_Face::_geometry
protected
osg::ref_ptr<vreckoUtils::HighlightCallback> APDYNAMICART::PS_Face::_highlight
protected
osg::ref_ptr<osg::Vec3Array> APDYNAMICART::PS_Face::_vertices
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Face.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Face.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_FacePlane Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_FacePlane
Public Member Functions | List of all members
APDYNAMICART::PS_FacePlane Class Reference

#include <PS_FacePlane.h>

Inheritance diagram for APDYNAMICART::PS_FacePlane:
vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

PS_FacePlane (double distance, osg::Quat rot)
void | pointed ()
void | setFace (PS_FacePtr face)
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::EnvironmentObject
void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...

Constructor & Destructor Documentation

APDYNAMICART::PS_FacePlane::PS_FacePlane | ( | double | distance,
 |  | osg::Quat | rot
 | ) |  |

Member Function Documentation

void APDYNAMICART::PS_FacePlane::pointed ( )
void APDYNAMICART::PS_FacePlane::setFace ( PS_FacePtr face )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FacePlane.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_FacePlane.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_FlatShape Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_FlatShape
APDYNAMICART::PS_FlatShape Class Reference

#include <PS_FlatShape.h>

Inheritance diagram for APDYNAMICART::PS_FlatShape:
APDYNAMICART::PS_Component APDYNAMICART::PS_Face
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FlatShape.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_Polyhedron Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Polyhedron
Public Member Functions | List of all members
APDYNAMICART::PS_Polyhedron Class Reference

#include <PS_Polyhedron.h>

Inheritance diagram for APDYNAMICART::PS_Polyhedron:

Public Member Functions

PS_Polyhedron (const string &name)
int | initialize (std::string name, osg::ref_ptr< osg::MatrixTransform > layerNode)
int | loadfromXML (std::string fileName)
void | createFacePlanes ()
void | setComponent (PS_ComponentPtr compo)

Constructor & Destructor Documentation

APDYNAMICART::PS_Polyhedron::PS_Polyhedron ( const string & name )

Member Function Documentation

void APDYNAMICART::PS_Polyhedron::createFacePlanes ( )
int APDYNAMICART::PS_Polyhedron::initialize | ( | std::string | name,
 |  | osg::ref_ptr< osg::MatrixTransform > | layerNode
 | ) |  |
int APDYNAMICART::PS_Polyhedron::loadfromXML ( std::string fileName )
void APDYNAMICART::PS_Polyhedron::setComponent ( PS_ComponentPtr compo )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Polyhedron.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Polyhedron.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PolyhedronFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolyhedronFactory
Static Public Member Functions | List of all members
APDYNAMICART::PolyhedronFactory Class Reference

#include <PS_Polyhedron.h>

Static Public Member Functions

static std::vector< std::string > | getAvaiablePolyhedronNames ()
static PS_PolyhedronPtr | getPolyhedron (const std::string &name)
static bool | isValidName (const std::string &name)

Detailed Description

Pattern simple factory

Member Function Documentation

static std::vector<std::string> APDYNAMICART::PolyhedronFactory::getAvaiablePolyhedronNames ( )
inlinestatic
static PS_PolyhedronPtr APDYNAMICART::PolyhedronFactory::getPolyhedron ( const std::string & name )
inlinestatic
static bool APDYNAMICART::PolyhedronFactory::isValidName ( const std::string & name )
inlinestatic
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Polyhedron.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::symmetry_axis Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • symmetry_axis
Public Attributes | List of all members
APDYNAMICART::symmetry_axis Struct Reference

#include <PS_Symmetry.h>

Public Attributes

int | order
osg::Vec3 | point

Member Data Documentation

int APDYNAMICART::symmetry_axis::order
osg::Vec3 APDYNAMICART::symmetry_axis::point
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Symmetry.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::symmetry_pair Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • symmetry_pair
Public Attributes | List of all members
APDYNAMICART::symmetry_pair Struct Reference

#include <PS_Symmetry.h>

Public Attributes

int | face
int | axis

Member Data Documentation

int APDYNAMICART::symmetry_pair::axis
int APDYNAMICART::symmetry_pair::face
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Symmetry.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PS_Symmetry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Symmetry
Public Member Functions | List of all members
APDYNAMICART::PS_Symmetry Class Reference

#include <PS_Symmetry.h>

Public Member Functions

void | makeInstances (std::vector< osg::Vec3 > *points)
creates other instances of given point (first item in vector) More...
std::vector< osg::Quat > * | makeRotations ()
creates vector of rotations - one for each face-plane More...
int | load (std::string fileName)
int | getNumberofFaces ()
std::vector< symmetry_axis * > * | getAxes ()

Member Function Documentation

std::vector<symmetry_axis *>* APDYNAMICART::PS_Symmetry::getAxes ( )
inline
int APDYNAMICART::PS_Symmetry::getNumberofFaces ( )
inline
int APDYNAMICART::PS_Symmetry::load ( std::string fileName )
void APDYNAMICART::PS_Symmetry::makeInstances ( std::vector< osg::Vec3 > * points )

creates other instances of given point (first item in vector)

std::vector< osg::Quat > * APDYNAMICART::PS_Symmetry::makeRotations ( )

creates vector of rotations - one for each face-plane

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Symmetry.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Symmetry.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RotationFrameAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RotationFrameAdapter
Public Member Functions | List of all members
APDYNAMICART::RotationFrameAdapter Class Reference

#include <RotationFrameGenAdapter.h>

Inheritance diagram for APDYNAMICART::RotationFrameAdapter:
APDYNAMICART::PoAAdapter< RotationFrameGenerator > APDYNAMICART::AxisFrameAdapter APDYNAMICART::HandFrameAdapter APDYNAMICART::RMFrameAdapter

Public Member Functions

RotationFrameAdapter ()
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr
< RotationFrameGenerator > 		getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual ~PoAAdapter ()

Detailed Description

Optional methods for set of similar classes, each class implements them

Constructor & Destructor Documentation

APDYNAMICART::RotationFrameAdapter::RotationFrameAdapter ( )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RMFrameAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RMFrameAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::RMFrameAdapter Class Reference

#include <RotationFrameGenAdapter.h>

Inheritance diagram for APDYNAMICART::RMFrameAdapter:
APDYNAMICART::RotationFrameAdapter APDYNAMICART::PoAAdapter< RotationFrameGenerator >

Public Member Functions

RMFrameAdapter ()
META_DAObject (RMFrameAdapter,"Automatic") virtual void createMenu(MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
virtual RotationFrameGeneratorPtr | getObject ()
returns adapted object More...
- Public Member Functions inherited from APDYNAMICART::RotationFrameAdapter
RotationFrameAdapter ()
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< RMFrame > _rotationFrameGen

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual ~PoAAdapter ()

Detailed Description

Rotation minimization frame adapter

Constructor & Destructor Documentation

APDYNAMICART::RMFrameAdapter::RMFrameAdapter ( )
inline

Member Function Documentation

virtual RotationFrameGeneratorPtr APDYNAMICART::RMFrameAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

int RMFrameAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

RMF adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

APDYNAMICART::RMFrameAdapter::META_DAObject | ( | RMFrameAdapter | ,
 |  | "Automatic" |
 | ) |  |
void RMFrameAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | ParametersNode
 | ) |  |
virtual

RMF adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

Member Data Documentation

osg::ref_ptr<RMFrame> APDYNAMICART::RMFrameAdapter::_rotationFrameGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RotationFrameGenAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::AxisFrameAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AxisFrameAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::AxisFrameAdapter Class Reference

#include <RotationFrameGenAdapter.h>

Inheritance diagram for APDYNAMICART::AxisFrameAdapter:
APDYNAMICART::RotationFrameAdapter APDYNAMICART::PoAAdapter< RotationFrameGenerator >

Public Member Functions

AxisFrameAdapter ()
META_DAObject (AxisFrameAdapter,"Tangent aligned") virtual void createMenu(MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
virtual RotationFrameGeneratorPtr | getObject ()
returns adapted object More...
- Public Member Functions inherited from APDYNAMICART::RotationFrameAdapter
RotationFrameAdapter ()
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< AxisRotationFrame > _rotationFrameGen

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual ~PoAAdapter ()

Detailed Description

Axis rotation frame adapter

Constructor & Destructor Documentation

APDYNAMICART::AxisFrameAdapter::AxisFrameAdapter ( )
inline

Member Function Documentation

virtual RotationFrameGeneratorPtr APDYNAMICART::AxisFrameAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

int AxisFrameAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

ARRF adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

APDYNAMICART::AxisFrameAdapter::META_DAObject | ( | AxisFrameAdapter | ,
 |  | "Tangent aligned" |
 | ) |  |
void AxisFrameAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | ParametersNode
 | ) |  |
virtual

ARRF adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

Member Data Documentation

osg::ref_ptr<AxisRotationFrame> APDYNAMICART::AxisFrameAdapter::_rotationFrameGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RotationFrameGenAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HandFrameAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HandFrameAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::HandFrameAdapter Class Reference

#include <RotationFrameGenAdapter.h>

Inheritance diagram for APDYNAMICART::HandFrameAdapter:
APDYNAMICART::RotationFrameAdapter APDYNAMICART::PoAAdapter< RotationFrameGenerator >

Public Member Functions

HandFrameAdapter ()
META_DAObject (HandFrameAdapter,"Manual") virtual void createMenu(MenuPtr menu)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
virtual RotationFrameGeneratorPtr | getObject ()
returns adapted object More...
- Public Member Functions inherited from APDYNAMICART::RotationFrameAdapter
RotationFrameAdapter ()
- Public Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual bool | itemClicked (const char *itemID)
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Attributes

osg::ref_ptr< HandFrame > _rotationFrameGen

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< RotationFrameGenerator >
virtual ~PoAAdapter ()

Detailed Description

Hand frame adapter

Constructor & Destructor Documentation

APDYNAMICART::HandFrameAdapter::HandFrameAdapter ( )
inline

Member Function Documentation

virtual RotationFrameGeneratorPtr APDYNAMICART::HandFrameAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

int HandFrameAdapter::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
virtual

HandFrame adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

APDYNAMICART::HandFrameAdapter::META_DAObject | ( | HandFrameAdapter | ,
 |  | "Manual" |
 | ) |  |
void HandFrameAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | ParametersNode
 | ) |  |
virtual

HandFrame adapter

Reimplemented from APDYNAMICART::PoAAdapter< RotationFrameGenerator >.

Member Data Documentation

osg::ref_ptr<HandFrame> APDYNAMICART::HandFrameAdapter::_rotationFrameGen
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RotationFrameGenAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RotationFrameFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RotationFrameFactory
Public Member Functions | List of all members
APDYNAMICART::RotationFrameFactory Class Reference

#include <RotationFrameGenAdapter.h>

Inheritance diagram for APDYNAMICART::RotationFrameFactory:
APDYNAMICART::AdapterFactory< RotationFrameAdapter >

Public Member Functions

RotationFrameFactory ()
RotationFrameFactory (const RotationFrameFactory &orig)
- Public Member Functions inherited from APDYNAMICART::AdapterFactory< RotationFrameAdapter >
const std::vector
< osg::ref_ptr
< RotationFrameAdapter > > & 		getSupportedAdapters () const
osg::ref_ptr
< RotationFrameAdapter > 		getAdapter (const std::string &className)

Additional Inherited Members

- Protected Attributes inherited from APDYNAMICART::AdapterFactory< RotationFrameAdapter >
std::vector< osg::ref_ptr
< RotationFrameAdapter > > 		_adapters

Constructor & Destructor Documentation

APDYNAMICART::RotationFrameFactory::RotationFrameFactory ( )
inline
APDYNAMICART::RotationFrameFactory::RotationFrameFactory ( const RotationFrameFactory & orig )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SectorInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SectorInfo
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::SectorInfo Struct Reference

#include <SectorManager.h>

Public Member Functions

SectorInfo (SectorPtr sector, PatternPtr pattern, HoopPtr hoop)

Public Attributes

SectorPtr sector
HoopPtr hoop
PatternPtr pattern

Constructor & Destructor Documentation

APDYNAMICART::SectorInfo::SectorInfo | ( | SectorPtr | sector,
 |  | PatternPtr | pattern,
 |  | HoopPtr | hoop
 | ) |  |
inline

Member Data Documentation

HoopPtr APDYNAMICART::SectorInfo::hoop
PatternPtr APDYNAMICART::SectorInfo::pattern
SectorPtr APDYNAMICART::SectorInfo::sector
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorManager.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SectorManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SectorManager
Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::SectorManager Class Reference

Sector Manager. More...

#include <SectorManager.h>

Public Types

typedef std::vector< SectorInfo > SectorInfoList

Public Member Functions

void | addSector (SectorPtr sector, HoopPtr hoop)
void | removeSector (unsigned int index)
void | setDefaultPattern (PatternPtr pattern)
void | removeAllSectorsOnHoop (HoopPtr hoop)
SectorPtr | getSector (unsigned int index)
HoopPtr | getHoop (unsigned int index)
PatternPtr | getPattern (unsigned int index)
unsigned int | getNumSectors ()
const SectorInfoList & | getSectorInfoList () const
SectorInfoList & getSectorInfoList ()
void | load (HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)
void | save (HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)

Static Public Member Functions

static SectorManager * getInstance ()

Protected Member Functions

SectorManager ()

Protected Attributes

std::vector< SectorInfo > | _sectorInfoList
std::string | _defaultPatternName

Detailed Description

Sector Manager.

Class responsible for managing adding/removing sectors

Member Typedef Documentation

typedef std::vector<SectorInfo> APDYNAMICART::SectorManager::SectorInfoList

Getters

Constructor & Destructor Documentation

SectorManager::SectorManager ( )
protected

Member Function Documentation

void SectorManager::addSector | ( | SectorPtr | sector,
 |  | HoopPtr | hoop
 | ) |  |
HoopPtr SectorManager::getHoop ( unsigned int index )
static SectorManager* APDYNAMICART::SectorManager::getInstance ( )
inlinestatic
unsigned int SectorManager::getNumSectors ( )
PatternPtr SectorManager::getPattern ( unsigned int index )
SectorPtr SectorManager::getSector ( unsigned int index )

Helper methods for easy access of SectorInfo items

const SectorInfoList& APDYNAMICART::SectorManager::getSectorInfoList ( ) const
inline
SectorInfoList& APDYNAMICART::SectorManager::getSectorInfoList ( )
inline
void SectorManager::load | ( | HoopPtr | hoop,
 |  | int | sectorsCount,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | PoANode
 | ) |  |

Saving and loading

void SectorManager::removeAllSectorsOnHoop ( HoopPtr hoop )
void SectorManager::removeSector ( unsigned int index )
void SectorManager::save | ( | HoopPtr | hoop,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
void SectorManager::setDefaultPattern ( PatternPtr pattern )

Member Data Documentation

std::string APDYNAMICART::SectorManager::_defaultPatternName
protected
std::vector<SectorInfo> APDYNAMICART::SectorManager::_sectorInfoList
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SectorManager.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SimpleBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SimpleBox
Public Member Functions | List of all members
APDYNAMICART::SimpleBox Class Reference

Simple class for creating boxes. More...

#include <SimpleBox.h>

Inheritance diagram for APDYNAMICART::SimpleBox:
vrecko::EnvironmentObject vrecko::BaseClass

Public Member Functions

SimpleBox (osg::Vec3 position, osg::Vec3 size, bool movable=true, osg::Vec4 colour=osg::Vec4(1.0, 1.0, 1.0, 1.0))
~SimpleBox ()
void | setColour (osg::Vec4 colour)
void | setHeight (double posY, double height)
void | set (osg::Vec3 point1, osg::Vec3 point2)
Set new position and size of box, thus box will lies between two points. More...
- Public Member Functions inherited from vrecko::EnvironmentObject
EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::EnvironmentObject
enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::EnvironmentObject
void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)
- Protected Attributes inherited from vrecko::EnvironmentObject
unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...

Detailed Description

Simple class for creating boxes.

mainly for debugging purposes

Constructor & Destructor Documentation

APDYNAMICART::SimpleBox::SimpleBox | ( | osg::Vec3 | position,
 |  | osg::Vec3 | size,
 |  | bool | movable = true,
 |  | osg::Vec4 | colour = osg::Vec4(1.0, 1.0, 1.0, 1.0)
 | ) |  |

Create new simple box.

Parameters
position | position of center of box
size | size of box
movable | will be box movable or not
colour | of box
APDYNAMICART::SimpleBox::~SimpleBox ( )

Member Function Documentation

void APDYNAMICART::SimpleBox::set | ( | osg::Vec3 | point1,
 |  | osg::Vec3 | point2
 | ) |  |

Set new position and size of box, thus box will lies between two points.

void APDYNAMICART::SimpleBox::setColour ( osg::Vec4 colour )
void APDYNAMICART::SimpleBox::setHeight | ( | double | posY,
 |  | double | height
 | ) |  |
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SimpleBox.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SimpleBox.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SplineAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplineAdapter
List of all members
APDYNAMICART::SplineAdapter Class Reference

#include <SplineAdapter.h>

Inheritance diagram for APDYNAMICART::SplineAdapter:
APDYNAMICART::PoAAdapter< Spline > APDYNAMICART::RectangularSplineAdapter APDYNAMICART::RoundedSplineAdapter APDYNAMICART::WaveSplineAdapter

Additional Inherited Members

- Public Member Functions inherited from APDYNAMICART::PoAAdapter< Spline >
virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr< Spline > | getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0
- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< Spline >
virtual | ~PoAAdapter ()

Detailed Description

Optional methods for set of similar classes, each class implements them

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RoundedSplineAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RoundedSplineAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::RoundedSplineAdapter Class Reference

#include <SplineAdapter.h>

Inheritance diagram for APDYNAMICART::RoundedSplineAdapter:
APDYNAMICART::SplineAdapter APDYNAMICART::PoAAdapter< Spline >

Public Member Functions

RoundedSplineAdapter (double diameter, int segmentCount)
META_DAObject (RoundedSplineAdapter,"Rounded")
virtual void | createMenu (MenuPtr menu)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
save data from adapter to given XML node More...
virtual osg::ref_ptr< Spline > | getObject ()
returns adapted object More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)

Protected Attributes

osg::ref_ptr< Spline > _spline

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< Spline >
virtual ~PoAAdapter ()

Detailed Description

Rounded spline adapter

Constructor & Destructor Documentation

APDYNAMICART::RoundedSplineAdapter::RoundedSplineAdapter | ( | double | diameter,
 |  | int | segmentCount
 | ) |  |
inline

Member Function Documentation

void RoundedSplineAdapter::createMenu ( MenuPtr menu )
virtual

Rounded Spline adapter

virtual osg::ref_ptr<Spline> APDYNAMICART::RoundedSplineAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< Spline >.

APDYNAMICART::RoundedSplineAdapter::META_DAObject | ( | RoundedSplineAdapter | ,
 |  | "Rounded" |
 | ) |  |
void RoundedSplineAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< Spline >.

bool APDYNAMICART::RoundedSplineAdapter::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
virtual

Reimplemented from APDYNAMICART::PoAAdapter< Spline >.

Member Data Documentation

osg::ref_ptr<Spline> APDYNAMICART::RoundedSplineAdapter::_spline
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SplineAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::RectangularSplineAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RectangularSplineAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::RectangularSplineAdapter Class Reference

#include <SplineAdapter.h>

Inheritance diagram for APDYNAMICART::RectangularSplineAdapter:
APDYNAMICART::SplineAdapter APDYNAMICART::PoAAdapter< Spline >

Public Member Functions

RectangularSplineAdapter (double width, double height)
META_DAObject (RectangularSplineAdapter,"Flat")
virtual void | createMenu (MenuPtr menu)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
save data from adapter to given XML node More...
virtual osg::ref_ptr< Spline > | getObject ()
returns adapted object More...
void | init ()

Protected Attributes

osg::ref_ptr< Spline > _spline

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< Spline >
virtual ~PoAAdapter ()

Detailed Description

Rectangular spline adapter

Constructor & Destructor Documentation

RectangularSplineAdapter::RectangularSplineAdapter | ( | double | width,
 |  | double | height
 | ) |  |

Rectangular Spline adapter

Member Function Documentation

void RectangularSplineAdapter::createMenu ( MenuPtr menu )
virtual
virtual osg::ref_ptr<Spline> APDYNAMICART::RectangularSplineAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< Spline >.

void APDYNAMICART::RectangularSplineAdapter::init ( )
APDYNAMICART::RectangularSplineAdapter::META_DAObject | ( | RectangularSplineAdapter | ,
 |  | "Flat" |
 | ) |  |
void RectangularSplineAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< Spline >.

Member Data Documentation

osg::ref_ptr<Spline> APDYNAMICART::RectangularSplineAdapter::_spline
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SplineAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::WaveSplineAdapter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • WaveSplineAdapter
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::WaveSplineAdapter Class Reference

#include <SplineAdapter.h>

Inheritance diagram for APDYNAMICART::WaveSplineAdapter:
APDYNAMICART::SplineAdapter APDYNAMICART::PoAAdapter< Spline >

Public Member Functions

WaveSplineAdapter ()
META_DAObject (WaveSplineAdapter,"Wave")
virtual void | createMenu (MenuPtr menu)
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
save data from adapter to given XML node More...
virtual osg::ref_ptr< Spline > | getObject ()
returns adapted object More...
void | init ()

Protected Attributes

osg::ref_ptr< Spline > _spline

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::PoAAdapter< Spline >
virtual ~PoAAdapter ()

Detailed Description

Wave spline adapter

Constructor & Destructor Documentation

WaveSplineAdapter::WaveSplineAdapter ( )

Wave Spline adapter

Member Function Documentation

void WaveSplineAdapter::createMenu ( MenuPtr menu )
virtual
virtual osg::ref_ptr<Spline> APDYNAMICART::WaveSplineAdapter::getObject ( )
inlinevirtual

returns adapted object

Implements APDYNAMICART::PoAAdapter< Spline >.

void APDYNAMICART::WaveSplineAdapter::init ( )
APDYNAMICART::WaveSplineAdapter::META_DAObject | ( | WaveSplineAdapter | ,
 |  | "Wave" |
 | ) |  |
void WaveSplineAdapter::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
virtual

save data from adapter to given XML node

Reimplemented from APDYNAMICART::PoAAdapter< Spline >.

Member Data Documentation

osg::ref_ptr<Spline> APDYNAMICART::WaveSplineAdapter::_spline
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SplineAdapter.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SplineFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplineFactory
Public Member Functions | List of all members
APDYNAMICART::SplineFactory Class Reference

#include <SplineAdapter.h>

Inheritance diagram for APDYNAMICART::SplineFactory:
APDYNAMICART::AdapterFactory< SplineAdapter >

Public Member Functions

SplineFactory ()
SplineFactory (const SplineFactory &orig)
- Public Member Functions inherited from APDYNAMICART::AdapterFactory< SplineAdapter >
const std::vector
< osg::ref_ptr< SplineAdapter > > & 		getSupportedAdapters () const
osg::ref_ptr< SplineAdapter > getAdapter (const std::string &className)

Additional Inherited Members

- Protected Attributes inherited from APDYNAMICART::AdapterFactory< SplineAdapter >
std::vector< osg::ref_ptr
< SplineAdapter > > 		_adapters

Detailed Description

Factory for spline adapters

Constructor & Destructor Documentation

APDYNAMICART::SplineFactory::SplineFactory ( )
inline
APDYNAMICART::SplineFactory::SplineFactory ( const SplineFactory & orig )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolBrush Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolBrush
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolBrush Class Reference

Brush tool. More...

#include <ToolBrush.h>

Inheritance diagram for APDYNAMICART::ToolBrush:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolBrush ()
~ToolBrush ()
void | activate ()
Activate tool. More...
void | deactivate ()
Deactivate tool. More...
void | CreateMenuAbilities ()
std::string | createMenuStructure ()
void | initialize (int newSensorNumber, BrushPtr brush, osg::Vec4 color)
void | menuSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
void | setSensorNumber (const int sensorNum)
void | storeSample (osg::Vec3 position, osg::Quat orientation)
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

void guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, menu item, ... More...
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (CreateMenuStructure, MessageInt)
DECLARE_INPUT (HidingMenu, MessageBool)
DECLARE_OUTPUT (MenuStructure, MessageString)
DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)

Protected Attributes

int | _sensorNumber
number of optitrack sensor (trackable in TrackingTools) More...
osg::ref_ptr< Brush > | _brush
referenced pointer to default brush More...
osg::Vec3 | _DAAposition
for transformations to local coords More...
osg::Quat | _DAAOrientation
for transformations to local coords More...
osg::Vec3 | _DAAScale
for transformations to local coords More...
osg::Vec3 | _lastValidPosition
position of last saved sample More...
APGUI::Menu * _MenuAbility
APGUI::GUI_Controller * _guiController
osg::Timer_t | _strokeStartTime
time when stroke was initiated More...
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Brush tool.

Track data from one input device sensor, transform them into local coordinate system (of DA area) and store it.

Constructor & Destructor Documentation

APDYNAMICART::ToolBrush::ToolBrush ( )
APDYNAMICART::ToolBrush::~ToolBrush ( )

Member Function Documentation

void APDYNAMICART::ToolBrush::activate ( )
virtual

Activate tool.

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolBrush::CreateMenuAbilities ( )
std::string APDYNAMICART::ToolBrush::createMenuStructure ( void )

Color of menu item representing actually selected choice e.g. actual context in switch context menu

void APDYNAMICART::ToolBrush::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolBrush::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolBrush::DECLARE_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APDYNAMICART::ToolBrush::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APDYNAMICART::ToolBrush::DECLARE_OUTPUT | ( | MenuStructure | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolBrush::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected
void APDYNAMICART::ToolBrush::guiItemClicked ( const char * itemID )
protected

Called when user click on some item of GUI - icon, menu item, ...

Parameters
itemID contains 'name' of menu item.
void APDYNAMICART::ToolBrush::initialize | ( | int | newSensorNumber,
 |  | BrushPtr | brush,
 |  | osg::Vec4 | color
 | ) |  |
void APDYNAMICART::ToolBrush::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider
void APDYNAMICART::ToolBrush::setSensorNumber ( const int sensorNum )
inline
void APDYNAMICART::ToolBrush::storeSample | ( | osg::Vec3 | position,
 |  | osg::Quat | orientation
 | ) |  |
void APDYNAMICART::ToolBrush::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolBrush::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolBrush::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::ref_ptr<Brush> APDYNAMICART::ToolBrush::_brush
protected

referenced pointer to default brush

osg::Quat APDYNAMICART::ToolBrush::_DAAOrientation
protected

for transformations to local coords

osg::Vec3 APDYNAMICART::ToolBrush::_DAAposition
protected

for transformations to local coords

osg::Vec3 APDYNAMICART::ToolBrush::_DAAScale
protected

for transformations to local coords

APGUI::GUI_Controller* APDYNAMICART::ToolBrush::_guiController
protected
osg::Vec3 APDYNAMICART::ToolBrush::_lastValidPosition
protected

position of last saved sample

APGUI::Menu* APDYNAMICART::ToolBrush::_MenuAbility
protected
int APDYNAMICART::ToolBrush::_sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools)

osg::Timer_t APDYNAMICART::ToolBrush::_strokeStartTime
protected

time when stroke was initiated

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolBrush.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolBrush.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolEraser Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolEraser
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolEraser Class Reference

#include <ToolEraser.h>

Inheritance diagram for APDYNAMICART::ToolEraser:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolEraser ()
~ToolEraser ()
void | activate ()
void | deactivate ()
Deactivate tool. More...
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setDAEnvironment (DAEnvironment *p_dae)
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

DECLARE_REQUEST_OUTPUT (SensorPosition, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)

Protected Attributes

int | _sensorNumber
number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand) More...
std::string | _PointerPosReqString
request for (initial) position string More...
std::string | _PointerOriReqString
request for (initial) orientation string More...
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Simple tool for erasing PoAs

Constructor & Destructor Documentation

APDYNAMICART::ToolEraser::ToolEraser ( )
APDYNAMICART::ToolEraser::~ToolEraser ( )

Member Function Documentation

void APDYNAMICART::ToolEraser::activate ( )
virtual

This tool requeres calling setDAEnvironment() before activation

Todo:

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolEraser::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolEraser::DECLARE_REQUEST_OUTPUT | ( | SensorPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
APDYNAMICART::ToolEraser::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
bool APDYNAMICART::ToolEraser::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolEraser::setDAEnvironment ( DAEnvironment * p_dae )
inline
void APDYNAMICART::ToolEraser::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolEraser::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

Member Data Documentation

std::string APDYNAMICART::ToolEraser::_PointerOriReqString
protected

request for (initial) orientation string

std::string APDYNAMICART::ToolEraser::_PointerPosReqString
protected

request for (initial) position string

int APDYNAMICART::ToolEraser::_sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolEraser.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolEraser.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolHook Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolHook
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolHook Class Reference

#include <ToolHook.h>

Inheritance diagram for APDYNAMICART::ToolHook:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolHook ()
virtual void | activate ()
virtual void | deactivate ()
Deactivate tool. More...
virtual void | turnOn ()
"Start" tool More...
virtual void | turnOff ()
"Stop" tool More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
float | getRopeRadius () const
std::string | createMenuStructure ()
void | guiItemClicked (const char *itemID)
void | menuSliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

PoA * getSelectedPoA ()
osg::Vec3 | getCursorPosition ()
void | initMenu ()
DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (CreateMenuStructure, MessageInt)
DECLARE_INPUT (HidingMenu, MessageBool)
DECLARE_OUTPUT (MenuStructure, MessageString)

Protected Attributes

osg::Vec3 | _DAAposition
osg::Quat | _DAAOrientation
osg::Vec3 | _DAAScale
HoopPtr _poa
osg::Vec3 | _hookPosition
float | _ropeRadius
APGUI::Menu * _menuAbility
APGUI::GUI_Controller * _guiController
osg::Vec3 | _axis
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::ToolHook::ToolHook ( )

Member Function Documentation

void APDYNAMICART::ToolHook::activate ( )
virtual

Inherited virtual methods

Implements APDYNAMICART::DATool.

std::string APDYNAMICART::ToolHook::createMenuStructure ( void )

Menu methods

void APDYNAMICART::ToolHook::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolHook::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected

Menu inputs/outputs

APDYNAMICART::ToolHook::DECLARE_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APDYNAMICART::ToolHook::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APDYNAMICART::ToolHook::DECLARE_OUTPUT | ( | MenuStructure | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolHook::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected

Debug and test purposes Message and request declarations

APDYNAMICART::ToolHook::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
osg::Vec3 APDYNAMICART::ToolHook::getCursorPosition ( )
protected
float APDYNAMICART::ToolHook::getRopeRadius ( ) const
inline

Getters

PoA * APDYNAMICART::ToolHook::getSelectedPoA ( )
protected

Helper methods

void APDYNAMICART::ToolHook::guiItemClicked ( const char * itemID )
bool APDYNAMICART::ToolHook::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolHook::initMenu ( )
protected
void APDYNAMICART::ToolHook::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
void APDYNAMICART::ToolHook::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolHook::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolHook::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 APDYNAMICART::ToolHook::_axis
protected
osg::Quat APDYNAMICART::ToolHook::_DAAOrientation
protected
osg::Vec3 APDYNAMICART::ToolHook::_DAAposition
protected
osg::Vec3 APDYNAMICART::ToolHook::_DAAScale
protected
APGUI::GUI_Controller* APDYNAMICART::ToolHook::_guiController
protected
osg::Vec3 APDYNAMICART::ToolHook::_hookPosition
protected
APGUI::Menu* APDYNAMICART::ToolHook::_menuAbility
protected
HoopPtr APDYNAMICART::ToolHook::_poa
protected
float APDYNAMICART::ToolHook::_ropeRadius
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolHook.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolHook.cpp
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolMagicWand Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolMagicWand
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolMagicWand Class Reference

#include <ToolMagicWand.h>

Inheritance diagram for APDYNAMICART::ToolMagicWand:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolMagicWand ()
virtual void | activate ()
Activate tool. More...
void | createMenuAbilities ()
std::string | createMenuStructure ()
PoA * getSelectedPoA ()
virtual void | deactivate ()
Deactivate tool. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual void | turnOn ()
"Start" tool More...
virtual void | turnOff ()
"Stop" tool More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

void | changeAttractor (osg::Vec3 newHandPosition)
void | setValuesXYZ (double newValueX, double newValueY, double newValueZ)
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (CreateMenuStructure, MessageInt)
DECLARE_INPUT (HidingMenu, MessageBool)
void | guiItemClicked (const char *itemID)
Called when user click on some item of GUI - icon, menu item, ... More...
void | menuSliderChanged (const char *sliderID, float sliderPos)
Called when user moves with slider on some item of menu. More...
DECLARE_OUTPUT (MenuStructure, MessageString)
DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)

Protected Attributes

int | _sensorNumber
number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand) More...
std::string | PointerPosReqString
request for (initial) position string More...
osg::ref_ptr< OrdinaryAttractor > | attractor
Attractor to be influenced by this tool. More...
bool | dominantAxis
dominant axis mode or free hand mode More...
APGUI::Menu * _MenuAbility
APGUI::GUI_Controller * _guiController
osg::Vec3 | _originalHandposition
osg::Vec3 | newHandPosition
double | handMoveMin
range of movement of hand - todo - may it differ in different axes? More...
double | handMoveMax
osg::Vec3 | paramRangeStart
osg::Vec3 | paramRangeEnd
osg::Vec3 | initialParamValue
osg::Vec3 | paramShift1
osg::Vec3 | paramShift2
osg::Vec3 | paramMult
int | indexX
index of parameter infuenced by movement in X axis More...
int | indexY
index of parameter infuenced by movement in Y axis More...
int | indexZ
index of parameter infuenced by movement in Z axis More...
Controller * controller
int | originalIterations
int | _lastDominantAxis
int | _precision
osg::Vec3 | _lastHandPosition
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::ToolMagicWand::ToolMagicWand ( )

Member Function Documentation

void APDYNAMICART::ToolMagicWand::activate ( )
virtual

Activate tool.

< index of parameter infuenced by movement in X axis

< index of parameter infuenced by movement in Y axis

< index of parameter infuenced by movement in Z axis

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolMagicWand::changeAttractor ( osg::Vec3 newHandPosition )
protected
void APDYNAMICART::ToolMagicWand::createMenuAbilities ( )
std::string APDYNAMICART::ToolMagicWand::createMenuStructure ( void )

Color of menu item representing actually selected choice e.g. actual context in switch context menu

void APDYNAMICART::ToolMagicWand::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolMagicWand::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolMagicWand::DECLARE_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APDYNAMICART::ToolMagicWand::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APDYNAMICART::ToolMagicWand::DECLARE_OUTPUT | ( | MenuStructure | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolMagicWand::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected
APDYNAMICART::ToolMagicWand::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
PoA * APDYNAMICART::ToolMagicWand::getSelectedPoA ( )
void APDYNAMICART::ToolMagicWand::guiItemClicked ( const char * itemID )
protected

Called when user click on some item of GUI - icon, menu item, ...

Parameters
itemID contains 'name' of menu item.
bool APDYNAMICART::ToolMagicWand::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolMagicWand::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
protected

Called when user moves with slider on some item of menu.

Parameters
sliderID | contains 'name' of menu item
value | contains current value of slider
void APDYNAMICART::ToolMagicWand::setValuesXYZ | ( | double | newValueX,
 |  | double | newValueY,
 |  | double | newValueZ
 | ) |  |
protected
void APDYNAMICART::ToolMagicWand::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolMagicWand::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolMagicWand::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

APGUI::GUI_Controller* APDYNAMICART::ToolMagicWand::_guiController
protected
int APDYNAMICART::ToolMagicWand::_lastDominantAxis
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::_lastHandPosition
protected
APGUI::Menu* APDYNAMICART::ToolMagicWand::_MenuAbility
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::_originalHandposition
protected
int APDYNAMICART::ToolMagicWand::_precision
protected
int APDYNAMICART::ToolMagicWand::_sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)

osg::ref_ptr<OrdinaryAttractor> APDYNAMICART::ToolMagicWand::attractor
protected

Attractor to be influenced by this tool.

Controller* APDYNAMICART::ToolMagicWand::controller
protected
bool APDYNAMICART::ToolMagicWand::dominantAxis
protected

dominant axis mode or free hand mode

double APDYNAMICART::ToolMagicWand::handMoveMax
protected
double APDYNAMICART::ToolMagicWand::handMoveMin
protected

range of movement of hand - todo - may it differ in different axes?

int APDYNAMICART::ToolMagicWand::indexX
protected

index of parameter infuenced by movement in X axis

int APDYNAMICART::ToolMagicWand::indexY
protected

index of parameter infuenced by movement in Y axis

int APDYNAMICART::ToolMagicWand::indexZ
protected

index of parameter infuenced by movement in Z axis

osg::Vec3 APDYNAMICART::ToolMagicWand::initialParamValue
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::newHandPosition
protected
int APDYNAMICART::ToolMagicWand::originalIterations
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::paramMult
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::paramRangeEnd
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::paramRangeStart
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::paramShift1
protected
osg::Vec3 APDYNAMICART::ToolMagicWand::paramShift2
protected
std::string APDYNAMICART::ToolMagicWand::PointerPosReqString
protected

request for (initial) position string

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolMagicWand.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolMagicWand.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolRotation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolRotation
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolRotation Class Reference

Rotation tool. More...

#include <ToolRotation.h>

Inheritance diagram for APDYNAMICART::ToolRotation:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolRotation ()
virtual void | activate ()
virtual void | deactivate ()
Deactivate tool. More...
virtual void | turnOn ()
"Start" tool More...
virtual void | turnOff ()
"Stop" tool More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
osg::Vec3 | getCursorPosition ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
std::string | createMenuStructure ()
void | guiItemClicked (const char *itemID)
void | menuSliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

PoA * getSelectedPoA ()
void initMenu ()
DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (CreateMenuStructure, MessageInt)
DECLARE_INPUT (HidingMenu, MessageBool)
DECLARE_OUTPUT (MenuStructure, MessageString)

Protected Attributes

osg::Vec3 | _DAAposition
osg::Quat | _DAAOrientation
osg::Vec3 | _DAAScale
osg::ref_ptr< PoA > | _poa
osg::Vec3 | _initCurPos
APGUI::Menu * _menuAbility
APGUI::GUI_Controller * _guiController
osg::Vec3 | _baseAxis
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Rotation tool.

Rotates with object around their origin. Snapping can be also enabled.

Constructor & Destructor Documentation

APDYNAMICART::ToolRotation::ToolRotation ( )

Member Function Documentation

void APDYNAMICART::ToolRotation::activate ( )
virtual

Inherited virtual methods

Implements APDYNAMICART::DATool.

std::string APDYNAMICART::ToolRotation::createMenuStructure ( void )

Menu methods

void APDYNAMICART::ToolRotation::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolRotation::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected

Menu inputs/outputs

APDYNAMICART::ToolRotation::DECLARE_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APDYNAMICART::ToolRotation::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APDYNAMICART::ToolRotation::DECLARE_OUTPUT | ( | MenuStructure | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolRotation::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected

Debug and test purposes Message and request declarations

APDYNAMICART::ToolRotation::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
osg::Vec3 APDYNAMICART::ToolRotation::getCursorPosition ( )
PoA * APDYNAMICART::ToolRotation::getSelectedPoA ( )
protected

Helper methods

void APDYNAMICART::ToolRotation::guiItemClicked ( const char * itemID )
bool APDYNAMICART::ToolRotation::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolRotation::initMenu ( )
protected
void APDYNAMICART::ToolRotation::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
void APDYNAMICART::ToolRotation::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolRotation::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolRotation::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 APDYNAMICART::ToolRotation::_baseAxis
protected
osg::Quat APDYNAMICART::ToolRotation::_DAAOrientation
protected
osg::Vec3 APDYNAMICART::ToolRotation::_DAAposition
protected
osg::Vec3 APDYNAMICART::ToolRotation::_DAAScale
protected
APGUI::GUI_Controller* APDYNAMICART::ToolRotation::_guiController
protected
osg::Vec3 APDYNAMICART::ToolRotation::_initCurPos
protected
APGUI::Menu* APDYNAMICART::ToolRotation::_menuAbility
protected
osg::ref_ptr<PoA> APDYNAMICART::ToolRotation::_poa
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolRotation.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolRotation.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolSelector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolSelector
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolSelector Class Reference

#include <ToolSelector.h>

Inheritance diagram for APDYNAMICART::ToolSelector:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolSelector ()
virtual void | activate ()
virtual void | deactivate ()
Deactivate tool. More...
virtual void | turnOn ()
"Start" tool More...
virtual void | turnOff ()
"Stop" tool More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
std::string | createMenuStructure ()
void | guiItemClicked (const char *itemID)
void | menuSliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

PoA * getSelectedPoA ()
void | resetValues ()
int | getNearestIndex ()
int | getSectorNumber ()
void | initMenu ()
DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (CreateMenuStructure, MessageInt)
DECLARE_INPUT (HidingMenu, MessageBool)
DECLARE_OUTPUT (MenuStructure, MessageString)

Protected Attributes

osg::Vec3 | _DAAposition
osg::Quat | _DAAOrientation
osg::Vec3 | _DAAScale
HoopPtr _hoop
Vec3ArrayPtr _snapPointArray
double | _selectStart
double | _selectEnd
double | _lastEnd
unsigned int | _sectorIndex
unsigned int | _arraySize
bool | _overZero
int | _sectorNumber
SectorManager * _sectorManager
APGUI::Menu * _menuAbility
APGUI::GUI_Controller * _guiController
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APDYNAMICART::ToolSelector::ToolSelector ( )

Member Function Documentation

void APDYNAMICART::ToolSelector::activate ( )
virtual

Inherited virtual methods

Implements APDYNAMICART::DATool.

std::string APDYNAMICART::ToolSelector::createMenuStructure ( void )

Menu methods

void APDYNAMICART::ToolSelector::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolSelector::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected

Menu inputs/outputs

APDYNAMICART::ToolSelector::DECLARE_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APDYNAMICART::ToolSelector::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APDYNAMICART::ToolSelector::DECLARE_OUTPUT | ( | MenuStructure | ,
 |  | MessageString |
 | ) |  |
protected
APDYNAMICART::ToolSelector::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected

Debug and test purposes Message and request declarations

APDYNAMICART::ToolSelector::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
int APDYNAMICART::ToolSelector::getNearestIndex ( )
protected
int APDYNAMICART::ToolSelector::getSectorNumber ( )
protected
PoA * APDYNAMICART::ToolSelector::getSelectedPoA ( )
protected

Helper methods

void APDYNAMICART::ToolSelector::guiItemClicked ( const char * itemID )
bool APDYNAMICART::ToolSelector::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolSelector::initMenu ( )
protected
void APDYNAMICART::ToolSelector::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
void APDYNAMICART::ToolSelector::resetValues ( )
protected
void APDYNAMICART::ToolSelector::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolSelector::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolSelector::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

unsigned int APDYNAMICART::ToolSelector::_arraySize
protected
osg::Quat APDYNAMICART::ToolSelector::_DAAOrientation
protected
osg::Vec3 APDYNAMICART::ToolSelector::_DAAposition
protected

Member attributes

osg::Vec3 APDYNAMICART::ToolSelector::_DAAScale
protected
APGUI::GUI_Controller* APDYNAMICART::ToolSelector::_guiController
protected
HoopPtr APDYNAMICART::ToolSelector::_hoop
protected
double APDYNAMICART::ToolSelector::_lastEnd
protected
APGUI::Menu* APDYNAMICART::ToolSelector::_menuAbility
protected
bool APDYNAMICART::ToolSelector::_overZero
protected
unsigned int APDYNAMICART::ToolSelector::_sectorIndex
protected
SectorManager* APDYNAMICART::ToolSelector::_sectorManager
protected
int APDYNAMICART::ToolSelector::_sectorNumber
protected
double APDYNAMICART::ToolSelector::_selectEnd
protected
double APDYNAMICART::ToolSelector::_selectStart
protected
Vec3ArrayPtr APDYNAMICART::ToolSelector::_snapPointArray
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSelector.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolSelector.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolSlice Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolSlice
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolSlice Class Reference

#include <ToolSlice.h>

Inheritance diagram for APDYNAMICART::ToolSlice:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolSlice ()
virtual void | activate ()
virtual void | deactivate ()
Deactivate tool. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual void | turnOn ()
"Start" tool More...
virtual void | turnOff ()
"Stop" tool More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Attributes

osg::ClipNode * | clipNode
osg::ClipPlane * | lowClipPlane
osg::ClipPlane * | topClipPlane
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vreckoUtils::Observable
Observable ()

Constructor & Destructor Documentation

APDYNAMICART::ToolSlice::ToolSlice ( )

Member Function Documentation

void APDYNAMICART::ToolSlice::activate ( )
virtual

This tool requeres calling setDAEnvironment() before activation

Todo:

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolSlice::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

bool APDYNAMICART::ToolSlice::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

how thick will slice be

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolSlice::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolSlice::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

Member Data Documentation

osg::ClipNode* APDYNAMICART::ToolSlice::clipNode
protected
osg::ClipPlane* APDYNAMICART::ToolSlice::lowClipPlane
protected
osg::ClipPlane* APDYNAMICART::ToolSlice::topClipPlane
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSlice.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolSlice.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::ToolTongs Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolTongs
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APDYNAMICART::ToolTongs Class Reference

#include <ToolTongs.h>

Inheritance diagram for APDYNAMICART::ToolTongs:
APDYNAMICART::DATool vrecko::Ability vreckoUtils::Observable vrecko::BaseClass

Public Member Functions

ToolTongs ()
~ToolTongs ()
void | activate ()
void | deactivate ()
Deactivate tool. More...
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setDAEnvironment (DAEnvironment *p_dae)
void | turnOn ()
"Start" tool More...
void | turnOff ()
"Stop" tool More...
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APDYNAMICART::DATool
DATool (const char *abilityName)
~DATool ()
void | createCursor (EnvironmentObject *parent, string fileName)
Create new EO, load geometry from given file and attach it to parent EnvironmentObject. More...
EnvironmentObject * getCursor ()
DAToolType getType ()
osg::Vec3 * | getSize ()
bool | isActive ()
void | setSize (osg::Vec3 p_size)
set size of tool and optional its visual cursor, too More...
void | setPoA (osg::ref_ptr< PoA > newPoa)
Set reference pointer to PoA to work with. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from vreckoUtils::Observable
void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

DECLARE_REQUEST_OUTPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)

Protected Attributes

int | _sensorNumber
number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand) More...
std::string | _posString
"Position_sensor_X" where X is sensor number More...
std::string | _oriString
"Orientation_sensor_X" where X is sensor number More...
osg::Vec3 | _originalHandposition
osg::Quat | _originalLocalHandOrientation
osg::Vec3 | _originalLocalHandposition
osg::Vec3 | _localHandDiffVec
osg::Vec3 | _newHandPosition
osg::Quat | _newHandOrientation
osg::Vec3 | _originalPoAPosition
osg::Quat | _originalPoAOrientation
osg::Vec3 | _originalPoAScale
osg::Vec3 | _daAreaPosition
osg::Quat | _daAreaOrientation
osg::Vec3 | _daAreaScale
- Protected Attributes inherited from APDYNAMICART::DATool
DAToolType toolType
Type of tool. More...
DAEnvironment * _daEnvironment
DAEnvironment. More...
EnvironmentObject * _daArea
owner of this ability More...
bool | active
Is active right now? More...
osg::ref_ptr< PoA > | _poa
actual _poa More...
osg::ref_ptr< EnvironmentObject > | _cursor
visual cursor of tool More...
osg::Vec3 * | size
Size (area of influence) of tool. More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from vreckoUtils::Observable
std::vector< Observer * > | _observers

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Todo:
  • write something abou what this tool do and some other info...

Constructor & Destructor Documentation

APDYNAMICART::ToolTongs::ToolTongs ( )
APDYNAMICART::ToolTongs::~ToolTongs ( )

Member Function Documentation

void APDYNAMICART::ToolTongs::activate ( )
virtual

This tool requeres calling setDAEnvironment() before activation

Todo:

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolTongs::deactivate ( )
virtual

Deactivate tool.

Implements APDYNAMICART::DATool.

APDYNAMICART::ToolTongs::DECLARE_REQUEST_OUTPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected
APDYNAMICART::ToolTongs::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
bool APDYNAMICART::ToolTongs::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APDYNAMICART::ToolTongs::setDAEnvironment ( DAEnvironment * p_dae )
inline
void APDYNAMICART::ToolTongs::turnOff ( )
virtual

"Stop" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolTongs::turnOn ( )
virtual

"Start" tool

Implements APDYNAMICART::DATool.

void APDYNAMICART::ToolTongs::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Quat APDYNAMICART::ToolTongs::_daAreaOrientation
protected
osg::Vec3 APDYNAMICART::ToolTongs::_daAreaPosition
protected
osg::Vec3 APDYNAMICART::ToolTongs::_daAreaScale
protected
osg::Vec3 APDYNAMICART::ToolTongs::_localHandDiffVec
protected
osg::Quat APDYNAMICART::ToolTongs::_newHandOrientation
protected
osg::Vec3 APDYNAMICART::ToolTongs::_newHandPosition
protected
osg::Vec3 APDYNAMICART::ToolTongs::_originalHandposition
protected
osg::Quat APDYNAMICART::ToolTongs::_originalLocalHandOrientation
protected
osg::Vec3 APDYNAMICART::ToolTongs::_originalLocalHandposition
protected
osg::Quat APDYNAMICART::ToolTongs::_originalPoAOrientation
protected
osg::Vec3 APDYNAMICART::ToolTongs::_originalPoAPosition
protected
osg::Vec3 APDYNAMICART::ToolTongs::_originalPoAScale
protected
std::string APDYNAMICART::ToolTongs::_oriString
protected

"Orientation_sensor_X" where X is sensor number

std::string APDYNAMICART::ToolTongs::_posString
protected

"Position_sensor_X" where X is sensor number

int APDYNAMICART::ToolTongs::_sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolTongs.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolTongs.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Stroke Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Stroke
Public Member Functions | List of all members
APDYNAMICART::Stroke Class Referenceabstract

#include <Utils.h>

Inheritance diagram for APDYNAMICART::Stroke:
APDYNAMICART::BrushStroke APDYNAMICART::Hoop APDYNAMICART::MotionTrail

Public Member Functions

virtual Vec3ArrayPtr | getPositionSamples () const =0
virtual Vec4ArrayPtr | getOrientationSamples () const =0
virtual osg::ref_ptr
< osg::DoubleArray > 		getTimeStamps () const =0
virtual SplinePtr | getLeadingSpline () const =0

Detailed Description

Stroke interface

Member Function Documentation

virtual SplinePtr APDYNAMICART::Stroke::getLeadingSpline ( ) const
pure virtual

Implemented in APDYNAMICART::BrushStroke, and APDYNAMICART::Hoop.

virtual Vec4ArrayPtr APDYNAMICART::Stroke::getOrientationSamples ( ) const
pure virtual

Implemented in APDYNAMICART::BrushStroke, and APDYNAMICART::Hoop.

virtual Vec3ArrayPtr APDYNAMICART::Stroke::getPositionSamples ( ) const
pure virtual

Implemented in APDYNAMICART::BrushStroke, and APDYNAMICART::Hoop.

virtual osg::ref_ptr<osg::DoubleArray> APDYNAMICART::Stroke::getTimeStamps ( ) const
pure virtual

Implemented in APDYNAMICART::BrushStroke, and APDYNAMICART::Hoop.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PoAAdapter< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoAAdapter
Public Member Functions | Protected Member Functions | List of all members
APDYNAMICART::PoAAdapter< T > Class Template Referenceabstract

#include <Utils.h>

Inheritance diagram for APDYNAMICART::PoAAdapter< T >:
APDYNAMICART::ConstantDiamAdapter APDYNAMICART::GradientDiamAdapter

Public Member Functions

virtual void | createMenu (osg::ref_ptr< vreckoUtils::Menu > menu)
creates structure of context menu More...
virtual osg::ref_ptr< T > | getObject ()=0
returns adapted object More...
virtual bool | itemClicked (const char *itemID)
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode)
load data from given XML node More...
virtual void | pointed (bool pointed)
implement reaction to pointing to object More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)
save data from adapter to given XML node More...
virtual bool | sliderChanged (const char *sliderID, float sliderPos)
virtual void | update ()
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Member Functions

virtual ~PoAAdapter ()

Detailed Description

template<class T>
class APDYNAMICART::PoAAdapter< T >

PoA Adapter

Constructor & Destructor Documentation

template<class T>
virtual APDYNAMICART::PoAAdapter< T >::~PoAAdapter ( )
inlineprotectedvirtual

Member Function Documentation

template<class T>
virtual std::string APDYNAMICART::PoAAdapter< T >::classDescription ( ) const
pure virtual
template<class T>
virtual std::string APDYNAMICART::PoAAdapter< T >::className ( ) const
pure virtual
template<class T>
virtual void APDYNAMICART::PoAAdapter< T >::createMenu ( osg::ref_ptr< vreckoUtils::Menu > menu )
inlinevirtual

creates structure of context menu

template<class T>
virtual osg::ref_ptr<T> APDYNAMICART::PoAAdapter< T >::getObject ( )
pure virtual

returns adapted object

Implemented in APDYNAMICART::HandFrameAdapter, APDYNAMICART::WaveSplineAdapter, APDYNAMICART::GradientColorAdapter, APDYNAMICART::AxisFrameAdapter, APDYNAMICART::RectangularSplineAdapter, APDYNAMICART::ConstantColorAdapter, APDYNAMICART::RMFrameAdapter, and APDYNAMICART::RoundedSplineAdapter.

template<class T>
virtual bool APDYNAMICART::PoAAdapter< T >::itemClicked ( const char * itemID )
inlinevirtual
template<class T>
virtual int APDYNAMICART::PoAAdapter< T >::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode )
inlinevirtual

load data from given XML node

Reimplemented in APDYNAMICART::HandFrameAdapter, APDYNAMICART::GradientColorAdapter, APDYNAMICART::AxisFrameAdapter, APDYNAMICART::GradientDiamAdapter, APDYNAMICART::ConstantColorAdapter, APDYNAMICART::RMFrameAdapter, and APDYNAMICART::ConstantDiamAdapter.

template<class T>
virtual void APDYNAMICART::PoAAdapter< T >::pointed ( bool pointed )
inlinevirtual

implement reaction to pointing to object

template<class T>
virtual void APDYNAMICART::PoAAdapter< T >::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | poaNode
 | ) |  |
inlinevirtual

save data from adapter to given XML node

Reimplemented in APDYNAMICART::HandFrameAdapter, APDYNAMICART::WaveSplineAdapter, APDYNAMICART::GradientColorAdapter, APDYNAMICART::RectangularSplineAdapter, APDYNAMICART::AxisFrameAdapter, APDYNAMICART::GradientDiamAdapter, APDYNAMICART::ConstantColorAdapter, APDYNAMICART::RoundedSplineAdapter, APDYNAMICART::RMFrameAdapter, and APDYNAMICART::ConstantDiamAdapter.

template<class T>
virtual bool APDYNAMICART::PoAAdapter< T >::sliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlinevirtual

Reimplemented in APDYNAMICART::GradientDiamAdapter, APDYNAMICART::RoundedSplineAdapter, and APDYNAMICART::ConstantDiamAdapter.

template<class T>
virtual void APDYNAMICART::PoAAdapter< T >::update ( void )
inlinevirtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::AdapterFactory< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AdapterFactory
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::AdapterFactory< T > Class Template Reference

#include <Utils.h>

Public Member Functions

const std::vector
< osg::ref_ptr< T > > & 		getSupportedAdapters () const
osg::ref_ptr< T > getAdapter (const std::string &className)

Protected Attributes

std::vector< osg::ref_ptr< T > > _adapters

Detailed Description

template<class T>
class APDYNAMICART::AdapterFactory< T >

PoA Adapter factory

Member Function Documentation

template<class T>
osg::ref_ptr<T> APDYNAMICART::AdapterFactory< T >::getAdapter ( const std::string & className )
inline

Returns adapter object if found in adapter list

template<class T>
const std::vector<osg::ref_ptr<T> >& APDYNAMICART::AdapterFactory< T >::getSupportedAdapters ( ) const
inline

Returns a list of supported adapters held by factory

Member Data Documentation

template<class T>
std::vector<osg::ref_ptr<T> > APDYNAMICART::AdapterFactory< T >::_adapters
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Utils Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Utils
Static Public Member Functions | List of all members
APDYNAMICART::Utils Class Reference

#include <Utils.h>

Static Public Member Functions

static void | interpolateVec3 (osg::Vec3Array *controlPoints, osg::Vec3Array *interpolatedPoints, int p_steps)
static osg::Vec3 | interpolatePoint (double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0, osg::Vec3 point3)
static bool | isValueInsideRange (double value, double rangeStart, double rangeEnd)
static DATool * | createDATool (const std::string &toolName, vrecko::BaseClass *owner)
static void | disableShaders (osg::StateSet *stateSet)
static void | setLayout (const std::string &name)
static std::vector< std::string > & | splitString (const std::string &s, char delim, std::vector< std::string > &elems)
static std::vector< std::string > | splitString (const std::string &s, char delim)
static string | convertInt (int number)
static int | convertString (string number)

Detailed Description

Utility class

Member Function Documentation

static string APDYNAMICART::Utils::convertInt ( int number )
inlinestatic
static int APDYNAMICART::Utils::convertString ( string number )
inlinestatic
static DATool* APDYNAMICART::Utils::createDATool | ( | const std::string & | toolName,
 |  | vrecko::BaseClass * | owner
 | ) |  |
inlinestatic
static void APDYNAMICART::Utils::disableShaders ( osg::StateSet * stateSet )
inlinestatic
osg::Vec3 APDYNAMICART::Utils::interpolatePoint | ( | double | t,
 |  | osg::Vec3 | point1,
 |  | osg::Vec3 | point2,
 |  | osg::Vec3 | point0,
 |  | osg::Vec3 | point3
 | ) |  |
static
void APDYNAMICART::Utils::interpolateVec3 | ( | osg::Vec3Array * | controlPoints,
 |  | osg::Vec3Array * | interpolatedPoints,
 |  | int | p_steps
 | ) |  |
static
bool APDYNAMICART::Utils::isValueInsideRange | ( | double | value,
 |  | double | rangeStart,
 |  | double | rangeEnd
 | ) |  |
static
void APDYNAMICART::Utils::setLayout ( const std::string & name )
static
static std::vector<std::string>& APDYNAMICART::Utils::splitString | ( | const std::string & | s,
 |  | char | delim,
 |  | std::vector< std::string > & | elems
 | ) |  |
inlinestatic
static std::vector<std::string> APDYNAMICART::Utils::splitString | ( | const std::string & | s,
 |  | char | delim
 | ) |  |
inlinestatic
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Utils.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Limits Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Limits
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::Limits Struct Reference

#include <Utils.h>

Public Member Functions

void | reset ()
void | adjustLimits (const osg::Vec3 &point)
double | getVolume ()

Public Attributes

double | minX
double | minY
double | minZ
double | maxX
double | maxY
double | maxZ

Detailed Description

Limits helper class

Member Function Documentation

void APDYNAMICART::Limits::adjustLimits ( const osg::Vec3 & point )
inline
double APDYNAMICART::Limits::getVolume ( )
inline
void APDYNAMICART::Limits::reset ( )
inline

Member Data Documentation

double APDYNAMICART::Limits::maxX
double APDYNAMICART::Limits::maxY
double APDYNAMICART::Limits::maxZ
double APDYNAMICART::Limits::minX
double APDYNAMICART::Limits::minY
double APDYNAMICART::Limits::minZ
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::colorGradient Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • colorGradient
Public Member Functions | List of all members
APDYNAMICART::colorGradient Class Reference

#include <Utils.h>

Public Member Functions

osg::Vec4 | getColor (double val)
void | addColor (osg::Vec4 color)

Detailed Description

Uniform Color gradient helper class

allow definition of gradient between arbitrary number of colors computes resulting color from gradient for given value (currently only from range <0.0, 1.0>)

Member Function Documentation

void APDYNAMICART::colorGradient::addColor ( osg::Vec4 color )
inline
osg::Vec4 APDYNAMICART::colorGradient::getColor ( double val )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Utils.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PoAState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoAState
Public Member Functions | Protected Types | Protected Attributes | List of all members
APDYNAMICART::PoAState Class Reference

#include <Utils.h>

Public Member Functions

void | saveState (ref_ptr_PoA poa)
void | removeState (ref_ptr_PoA poa)
void | restoreAllPoAStates ()

Protected Types

typedef std::pair< osg::Vec3,
osg::Quat > 		PosRot
typedef std::map< ref_ptr_PoA,
PosRot > 		StateMap

Protected Attributes

StateMap _stateMap

Detailed Description

PoAState class - used for saving/restoring poa's position and orientation

Member Typedef Documentation

typedef std::pair<osg::Vec3, osg::Quat> APDYNAMICART::PoAState::PosRot
protected
typedef std::map<ref_ptr_PoA, PosRot> APDYNAMICART::PoAState::StateMap
protected

Member Function Documentation

void APDYNAMICART::PoAState::removeState ( ref_ptr_PoA poa )
inline
void APDYNAMICART::PoAState::restoreAllPoAStates ( )
inline
void APDYNAMICART::PoAState::saveState ( ref_ptr_PoA poa )
inline

Member Data Documentation

StateMap APDYNAMICART::PoAState::_stateMap
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::DAGizmo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DAGizmo
Public Member Functions | List of all members
APDYNAMICART::DAGizmo Class Reference

Gizmo - graphical representation of something, e.g. Frenet frame. More...

#include <BrushStrokeControlPoint.h>

Inheritance diagram for APDYNAMICART::DAGizmo:

Public Member Functions

DAGizmo (osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius)
~DAGizmo ()
osg::ref_ptr< SimpleBox > | getNormal ()
osg::ref_ptr< SimpleBox > | getBinormal ()
bool | isVisible ()
void | hide ()
void | show ()

Detailed Description

Gizmo - graphical representation of something, e.g. Frenet frame.

Render tangent, normal and binormal as SimpleBox

Constructor & Destructor Documentation

DAGizmo::DAGizmo | ( | osg::Group * | p_EOOwner,
 |  | osg::Vec3 | position,
 |  | osg::Vec3 | tangent,
 |  | osg::Vec3 | normal,
 |  | osg::Vec3 | binormal,
 |  | double | radius
 | ) |  |
DAGizmo::~DAGizmo ( )

Member Function Documentation

osg::ref_ptr<SimpleBox> APDYNAMICART::DAGizmo::getBinormal ( )
inline
osg::ref_ptr<SimpleBox> APDYNAMICART::DAGizmo::getNormal ( )
inline
void DAGizmo::hide ( )
bool APDYNAMICART::DAGizmo::isVisible ( )
inline
void DAGizmo::show ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::BrushStrokeControlPoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • BrushStrokeControlPoint
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::BrushStrokeControlPoint Class Reference

Control point of Sweep Surface. More...

#include <BrushStrokeControlPoint.h>

Inheritance diagram for APDYNAMICART::BrushStrokeControlPoint:

Public Member Functions

BrushStrokeControlPoint (DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient)
~BrushStrokeControlPoint ()
osg::Vec3 | getBinormal ()
double | getCurvature ()
double | getDiameter ()
osg::Vec3 | getNormal ()
osg::Quat | getOrientation ()
osg::Vec3 | getPosition ()
double | getPriority ()
double | getSegmentLength ()
double | getSpeed ()
osg::Vec3 | getTangent ()
double | getTorsion ()
osg::Quat | getTriangulationAngle ()
double | getTvalue ()
DAControlPointType | getType ()
osg::Group * | getVisualOwner ()
string | getPositionString ()
bool | isSampled ()
void | setCharacteristics (osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion)
void | setDiameter (double diam)
void | setNormal (osg::Vec3 nrml)
void | setBinormal (osg::Vec3 binrml)
void | setPosition (osg::Vec3 pos)
void | setPosition (osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z)
void | setPriority (double prior)
void | setRotationFrame (osg::Vec3 normal, osg::Vec3 binormal, osg::Vec3 tangent)
void | setSegmentLength (double length)
double | setSpeed (double spee)
void | setTangent (osg::Vec3 tngt)
void | setTriangulationAngle (osg::Quat angle)
void | setTvalue (double tval)
void | setVisibleVisualBox (bool vis)
void | showGizmo (bool show)
show or hide graphical gizmo of point More...

Public Attributes

bool frenetFremeComputed

Detailed Description

Control point of Sweep Surface.

Set of control points is computed from set of samples. Control points are used as control points of leading curve of swept-volume of brush stroke. may contains:

  • position, orientation
  • Frenet-frame - local coordinate system
  • speed
  • priority

Constructor & Destructor Documentation

APDYNAMICART::BrushStrokeControlPoint::BrushStrokeControlPoint | ( | DAControlPointType | p_type,
 |  | osg::Group * | p_EOOwner,
 |  | osg::Vec3 | point,
 |  | osg::Quat | orient
 | ) |  |
Parameters
p_type | type of point - SAMPLED or interpolated
p_EOOwner | group for visuals of points - e.g. rotation frame gizmo will be added to this group
APDYNAMICART::BrushStrokeControlPoint::~BrushStrokeControlPoint ( )

Member Function Documentation

osg::Vec3 APDYNAMICART::BrushStrokeControlPoint::getBinormal ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getCurvature ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getDiameter ( )
inline
osg::Vec3 APDYNAMICART::BrushStrokeControlPoint::getNormal ( )
inline
osg::Quat APDYNAMICART::BrushStrokeControlPoint::getOrientation ( )
inline
osg::Vec3 APDYNAMICART::BrushStrokeControlPoint::getPosition ( )
inline
string APDYNAMICART::BrushStrokeControlPoint::getPositionString ( )
double APDYNAMICART::BrushStrokeControlPoint::getPriority ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getSegmentLength ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getSpeed ( )
inline
osg::Vec3 APDYNAMICART::BrushStrokeControlPoint::getTangent ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getTorsion ( )
inline
osg::Quat APDYNAMICART::BrushStrokeControlPoint::getTriangulationAngle ( )
inline
double APDYNAMICART::BrushStrokeControlPoint::getTvalue ( )
inline
DAControlPointType APDYNAMICART::BrushStrokeControlPoint::getType ( void )
inline
osg::Group* APDYNAMICART::BrushStrokeControlPoint::getVisualOwner ( )
inline
bool APDYNAMICART::BrushStrokeControlPoint::isSampled ( )
void APDYNAMICART::BrushStrokeControlPoint::setBinormal ( osg::Vec3 binrml )
inline
void APDYNAMICART::BrushStrokeControlPoint::setCharacteristics | ( | osg::Vec3 | tan,
 |  | osg::Vec3 | norm,
 |  | osg::Vec3 | binorm,
 |  | double | curvature,
 |  | double | torsion
 | ) |  |
void APDYNAMICART::BrushStrokeControlPoint::setDiameter ( double diam )
inline
void APDYNAMICART::BrushStrokeControlPoint::setNormal ( osg::Vec3 nrml )
inline
void APDYNAMICART::BrushStrokeControlPoint::setPosition ( osg::Vec3 pos )
void APDYNAMICART::BrushStrokeControlPoint::setPosition | ( | osg::Vec3f::value_type | x,
 |  | osg::Vec3f::value_type | y,
 |  | osg::Vec3f::value_type | z
 | ) |  |
void APDYNAMICART::BrushStrokeControlPoint::setPriority ( double prior )
inline
void APDYNAMICART::BrushStrokeControlPoint::setRotationFrame | ( | osg::Vec3 | normal,
 |  | osg::Vec3 | binormal,
 |  | osg::Vec3 | tangent
 | ) |  |
void APDYNAMICART::BrushStrokeControlPoint::setSegmentLength ( double length )
inline
double APDYNAMICART::BrushStrokeControlPoint::setSpeed ( double spee )
inline
void APDYNAMICART::BrushStrokeControlPoint::setTangent ( osg::Vec3 tngt )
inline
void APDYNAMICART::BrushStrokeControlPoint::setTriangulationAngle ( osg::Quat angle )
inline
void APDYNAMICART::BrushStrokeControlPoint::setTvalue ( double tval )
inline
void APDYNAMICART::BrushStrokeControlPoint::setVisibleVisualBox ( bool vis )
inline
void APDYNAMICART::BrushStrokeControlPoint::showGizmo ( bool show )

show or hide graphical gizmo of point

Member Data Documentation

bool APDYNAMICART::BrushStrokeControlPoint::frenetFremeComputed
Todo:
make this private....
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::Trait Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Trait
Public Attributes | List of all members
APDYNAMICART::Trait Struct Reference

#include <HoopGeometry.h>

Public Attributes

double | min
double | max
double | mean

Member Data Documentation

double APDYNAMICART::Trait::max
double APDYNAMICART::Trait::mean
double APDYNAMICART::Trait::min
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::HoopGeometry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopGeometry
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::HoopGeometry Class Reference

#include <HoopGeometry.h>

Inheritance diagram for APDYNAMICART::HoopGeometry:

Public Member Functions

HoopGeometry (IShapeGeneratorPtr crossSection, IShapeGeneratorPtr shapeCurve)
void | createGeometry (osg::Vec3Array *crossSectionFixPoints, osg::Vec3Array *shapeCurveFixPoints)
const IShapeGeneratorPtr | getCrossSectionGenerator () const
const IShapeGeneratorPtr | getShapeCurveGenerator () const
void | setCrossSectionGenerator (IShapeGeneratorPtr crossSectionGen)
void | setShapeCurveGenerator (IShapeGeneratorPtr shapeCurveGen)

Protected Attributes

IShapeGeneratorPtr _crossSection
IShapeGeneratorPtr _shapeCurve
BrushStrokeTriangulatorPtr _bst
BrushPtr _brush
TraitMap traits

Constructor & Destructor Documentation

APDYNAMICART::HoopGeometry::HoopGeometry | ( | IShapeGeneratorPtr | crossSection,
 |  | IShapeGeneratorPtr | shapeCurve
 | ) |  |

Member Function Documentation

void APDYNAMICART::HoopGeometry::createGeometry | ( | osg::Vec3Array * | crossSectionFixPoints,
 |  | osg::Vec3Array * | shapeCurveFixPoints
 | ) |  |
  1. Ziskame nejak body (snimanim, zadanim, vypocitanim, atd.) + nekdy dostaneme i orientaci => Sample(Position, Orientation) OPT: 1a. Interpolujeme je
  2. Vytvorime Brush a naplnime hodnoty
const IShapeGeneratorPtr APDYNAMICART::HoopGeometry::getCrossSectionGenerator ( ) const
inline

Getters and setters

inline functions

const IShapeGeneratorPtr APDYNAMICART::HoopGeometry::getShapeCurveGenerator ( ) const
inline
void APDYNAMICART::HoopGeometry::setCrossSectionGenerator ( IShapeGeneratorPtr crossSectionGen )
inline
void APDYNAMICART::HoopGeometry::setShapeCurveGenerator ( IShapeGeneratorPtr shapeCurveGen )
inline

Member Data Documentation

BrushPtr APDYNAMICART::HoopGeometry::_brush
protected
BrushStrokeTriangulatorPtr APDYNAMICART::HoopGeometry::_bst
protected
IShapeGeneratorPtr APDYNAMICART::HoopGeometry::_crossSection
protected
IShapeGeneratorPtr APDYNAMICART::HoopGeometry::_shapeCurve
protected
TraitMap APDYNAMICART::HoopGeometry::traits
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::PoB Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoB
Public Member Functions | Protected Attributes | List of all members
APDYNAMICART::PoB Class Referenceabstract

PoB (Piece of Behavior) More...

#include <PoB.h>

Inheritance diagram for APDYNAMICART::PoB:
vrecko::Ability vrecko::BaseClass

Public Member Functions

PoB (const char *abName)
~PoB ()
virtual void | clicked ()=0
Called by DAEnvironment, when user click on icon. More...
string | getpobName ()
string | getTarget ()
virtual int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoBNode)=0
load configuration of PoB from .XML node More...
virtual void | pointed (bool pointed)=0
Called when user point with cursor (hand) to this PoB. More...
virtual void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoBNode)=0
Save current state of PoB to .XML node. More...
virtual void | update ()=0
Update of PoB. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

string | pobName
name of this PoB More...
std::string | targetName
name of target object of this PoB More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Detailed Description

PoB (Piece of Behavior)

Pure virtual class, serve as base for all types of behavior objects of Dynamic Arts like Icon, Slider, Timeline, ...

Author
Jiri Chmelik
Date
2010-...

Constructor & Destructor Documentation

PoB::PoB ( const char * abName )
PoB::~PoB ( )

Member Function Documentation

virtual void APDYNAMICART::PoB::clicked ( )
pure virtual

Called by DAEnvironment, when user click on icon.

string APDYNAMICART::PoB::getpobName ( )
inline
string APDYNAMICART::PoB::getTarget ( )
inline
virtual int APDYNAMICART::PoB::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PoBNode )
pure virtual

load configuration of PoB from .XML node

Parameters
PoBNode pointer to node containing info about this PoB
Returns
error code.
  • 0 - OK
  • 1 - parameter node is missing
  • 2... other errors
virtual void APDYNAMICART::PoB::pointed ( bool pointed )
pure virtual

Called when user point with cursor (hand) to this PoB.

virtual void APDYNAMICART::PoB::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | PoBNode
 | ) |  |
pure virtual

Save current state of PoB to .XML node.

virtual void APDYNAMICART::PoB::update ( )
pure virtual

Update of PoB.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

string APDYNAMICART::PoB::pobName
protected

name of this PoB

std::string APDYNAMICART::PoB::targetName
protected

name of target object of this PoB

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoB.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoB.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::IShapeGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IShapeGenerator
Public Member Functions | Protected Member Functions | List of all members
APDYNAMICART::IShapeGenerator Class Referenceabstract

#include <ShapeGenerator.h>

Inheritance diagram for APDYNAMICART::IShapeGenerator:
APDYNAMICART::LinearShapeGenerator APDYNAMICART::NullShapeGenerator

Public Member Functions

virtual Vec3ArrayPtr generate (Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints)=0

Protected Member Functions

virtual ~IShapeGenerator ()

Detailed Description

Interface

Constructor & Destructor Documentation

virtual APDYNAMICART::IShapeGenerator::~IShapeGenerator ( )
inlineprotectedvirtual

Member Function Documentation

virtual Vec3ArrayPtr APDYNAMICART::IShapeGenerator::generate | ( | Vec3ArrayPtr | inputPoints,
 |  | u_int | numberOfOutputPoints
 | ) |  |
pure virtual

Implemented in APDYNAMICART::LinearShapeGenerator, and APDYNAMICART::NullShapeGenerator.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::NullShapeGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullShapeGenerator
Public Member Functions | List of all members
APDYNAMICART::NullShapeGenerator Class Reference

#include <ShapeGenerator.h>

Inheritance diagram for APDYNAMICART::NullShapeGenerator:
APDYNAMICART::IShapeGenerator

Public Member Functions

virtual Vec3ArrayPtr generate (Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints)

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::IShapeGenerator
virtual ~IShapeGenerator ()

Detailed Description

Generators

Member Function Documentation

Vec3ArrayPtr APDYNAMICART::NullShapeGenerator::generate | ( | Vec3ArrayPtr | inputPoints,
 |  | u_int | numberOfOutputPoints
 | ) |  |
virtual

Implements APDYNAMICART::IShapeGenerator.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::LinearShapeGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LinearShapeGenerator
Public Member Functions | List of all members
APDYNAMICART::LinearShapeGenerator Class Reference

#include <ShapeGenerator.h>

Inheritance diagram for APDYNAMICART::LinearShapeGenerator:
APDYNAMICART::IShapeGenerator

Public Member Functions

virtual Vec3ArrayPtr generate (Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints)

Additional Inherited Members

- Protected Member Functions inherited from APDYNAMICART::IShapeGenerator
virtual ~IShapeGenerator ()

Member Function Documentation

Vec3ArrayPtr APDYNAMICART::LinearShapeGenerator::generate | ( | Vec3ArrayPtr | inputPoints,
 |  | u_int | numberOfOutputPoints
 | ) |  |
virtual

Implements APDYNAMICART::IShapeGenerator.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APDYNAMICART::SnapPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SnapPoint
Public Member Functions | Public Attributes | List of all members
APDYNAMICART::SnapPoint Struct Reference

#include <SnapPoint.h>

Public Member Functions

SnapPoint (osg::Vec3 center)

Public Attributes

osg::Vec3 _center

Constructor & Destructor Documentation

APDYNAMICART::SnapPoint::SnapPoint ( osg::Vec3 center )
inline

Member Data Documentation

osg::Vec3 APDYNAMICART::SnapPoint::_center
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SnapPoint.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::AbilityMapper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APEditorController::AbilityMapper Class Reference

#include <AbilityMapper.h>

Inheritance diagram for APEditorController::AbilityMapper:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Classes

struct | BUTTON_MAPPING
struct | MAPPING
class | MessageMapping

Public Member Functions

AbilityMapper ()
virtual | ~AbilityMapper ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | createInterface ()
virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
void | sendNewMapping ()
DECLARE_INPUT (Mapping, MessageMapping)
DECLARE_OUTPUT (Mapping, MessageMapping)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

MAPPING mapping
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APEditorController::AbilityMapper::AbilityMapper ( )
APEditorController::AbilityMapper::~AbilityMapper ( )
virtual

Member Function Documentation

bool APEditorController::AbilityMapper::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorController::AbilityMapper::createInterface ( )
protectedvirtual

Method for creating the input/outputs/requests. If overridden, it has to call the ancestor method. This is the method to override, if you need to add any other inputs/outputs etc. Then you also have to override the destroyInterface() to destroy these connections. Please see notes about destroyInterface() to use it properly (!)

Reimplemented from vrecko::ControllableAbility.

APEditorController::AbilityMapper::DECLARE_INPUT | ( | Mapping | ,
 |  | MessageMapping |
 | ) |  |
protected
APEditorController::AbilityMapper::DECLARE_OUTPUT | ( | Mapping | ,
 |  | MessageMapping |
 | ) |  |
protected
void APEditorController::AbilityMapper::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorController::AbilityMapper::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void APEditorController::AbilityMapper::sendNewMapping ( )
protected

Member Data Documentation

MAPPING APEditorController::AbilityMapper::mapping
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/AbilityMapper.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::AbilityMapper::BUTTON_MAPPING Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • BUTTON_MAPPING
Public Attributes | List of all members
APEditorController::AbilityMapper::BUTTON_MAPPING Struct Reference

#include <AbilityMapper.h>

Public Attributes

int | pointerID
int | buttonID
std::string | mappedAbility

Member Data Documentation

int APEditorController::AbilityMapper::BUTTON_MAPPING::buttonID
std::string APEditorController::AbilityMapper::BUTTON_MAPPING::mappedAbility
int APEditorController::AbilityMapper::BUTTON_MAPPING::pointerID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::AbilityMapper::MAPPING Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • MAPPING
Public Member Functions | Public Attributes | List of all members
APEditorController::AbilityMapper::MAPPING Struct Reference

#include <AbilityMapper.h>

Public Member Functions

MAPPING & operator= (const MAPPING &rhs)

Public Attributes

std::vector< BUTTON_MAPPING > vector

Member Function Documentation

MAPPING& APEditorController::AbilityMapper::MAPPING::operator= ( const MAPPING & rhs )
inline

Member Data Documentation

std::vector<BUTTON_MAPPING> APEditorController::AbilityMapper::MAPPING::vector
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::AbilityMapper::MessageMapping Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • MessageMapping
Public Member Functions | Public Attributes | List of all members
APEditorController::AbilityMapper::MessageMapping Class Reference

#include <AbilityMapper.h>

Inheritance diagram for APEditorController::AbilityMapper::MessageMapping:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

MAPPING data

Member Function Documentation

virtual const char* APEditorController::AbilityMapper::MessageMapping::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

MAPPING APEditorController::AbilityMapper::MessageMapping::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::EditorController Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
APEditorController::EditorController Class Reference

#include <EditorController.h>

Inheritance diagram for APEditorController::EditorController:
vrecko::Ability vrecko::BaseClass

Classes

class | ECPOINTERBUTTONINFO
class | ECPOINTERINFO

Public Member Functions

EditorController ()
~EditorController ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Attributes

static const int | maxPointers = 2
static const int | maxButtonsPerPointer = 4

Protected Member Functions

bool | createAbilityMapper ()
void | removeAbilityMapper ()
void | setAbilityMapping (AbilityMapper::MAPPING *newMapping)
AbilityMapper::MessageMapping * compileAbilityMapping ()
void | setNewSelection (unsigned long newSelection)
void | pointerPosUpdate (int pointerID, const osg::Vec3 &newPos, bool bRaw=false)
void | pointerRotUpdate (int pointerID, const osg::Quat &newRot, bool bRaw=false)
void | pointerBtnUpdate (int poinerID, int buttonID, bool newState)
void | sendPointerBtnToRelevantOutputs (int pointerID, int buttonID)
void | pointerSelUpdate (int pointerID, unsigned long newSelection)
void | sendPointerSelectionEvent (int pointerID, unsigned long newSelection)
void | abilityActivationTest ()
void | selectionVisibilityUpdate ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
DECLARE_INPUT (Pointer1Pos, MessageVec3)
DECLARE_INPUT (Pointer1Rot, MessageQuat)
DECLARE_INPUT (Pointer1PosRaw, MessageVec3)
DECLARE_INPUT (Pointer1RotRaw, MessageQuat)
DECLARE_INPUT (Pointer1Btn1, MessageBool)
DECLARE_INPUT (Pointer1Btn2, MessageBool)
DECLARE_INPUT (Pointer1Btn3, MessageBool)
DECLARE_INPUT (Pointer1Btn4, MessageBool)
DECLARE_INPUT (Pointer2Pos, MessageVec3)
DECLARE_INPUT (Pointer2Rot, MessageQuat)
DECLARE_INPUT (Pointer2PosRaw, MessageVec3)
DECLARE_INPUT (Pointer2RotRaw, MessageQuat)
DECLARE_INPUT (Pointer2Btn1, MessageBool)
DECLARE_INPUT (Pointer2Btn2, MessageBool)
DECLARE_INPUT (Pointer2Btn3, MessageBool)
DECLARE_INPUT (Pointer2Btn4, MessageBool)
DECLARE_OUTPUT (SelectionID, MessageObjectID)
DECLARE_OUTPUT (Pointer1Selection, MessageObjectID)
DECLARE_OUTPUT (Pointer1Visible, MessageBool)
DECLARE_OUTPUT (Pointer2Selection, MessageObjectID)
DECLARE_OUTPUT (Pointer2Visible, MessageBool)
DECLARE_INPUT (AbilityMapping, AbilityMapper::MessageMapping)
DECLARE_OUTPUT (AbilityMapping, AbilityMapper::MessageMapping)
DECLARE_REQUEST_INPUT (AbilityMapping, MessageVoid, AbilityMapper::MessageMapping)
DECLARE_REQUEST_OUTPUT (SelectionByPointerPos_Path, MessageVec3, MessageNodeList)
DECLARE_REQUEST_INPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_INPUT (SelectionPath, MessageInt, MessageNodeList)
DECLARE_REQUEST_INPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_INPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_INPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_INPUT (PointerRotRaw, MessageInt, MessageQuat)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
std::string | activeAbilityName
int | activeAbilityPointerID
int | activeAbilityButtonID
osg::Vec3 | actViewPosition
ECPOINTERINFO | pointers [maxPointers+1]
Ability * abilityMapper
unsigned long | actSelection
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APEditorController::EditorController::EditorController ( )
APEditorController::EditorController::~EditorController ( )

Member Function Documentation

void APEditorController::EditorController::abilityActivationTest ( )
protected
AbilityMapper::MessageMapping * APEditorController::EditorController::compileAbilityMapping ( )
protected
bool APEditorController::EditorController::createAbilityMapper ( )
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Pos | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Rot | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1PosRaw | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1RotRaw | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Btn1 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Btn2 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Btn3 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer1Btn4 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Pos | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Rot | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2PosRaw | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2RotRaw | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Btn1 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Btn2 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Btn3 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | Pointer2Btn4 | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_INPUT | ( | AbilityMapping | ,
 |  | AbilityMapper::MessageMapping |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | SelectionID | ,
 |  | MessageObjectID |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | Pointer1Selection | ,
 |  | MessageObjectID |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | Pointer1Visible | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | Pointer2Selection | ,
 |  | MessageObjectID |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | Pointer2Visible | ,
 |  | MessageBool |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_OUTPUT | ( | AbilityMapping | ,
 |  | AbilityMapper::MessageMapping |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | AbilityMapping | ,
 |  | MessageVoid | ,
 |  | AbilityMapper::MessageMapping |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | SelectionID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | SelectionPath | ,
 |  | MessageInt | ,
 |  | MessageNodeList |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | PointerPos | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | PointerRot | ,
 |  | MessageInt | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | PointerPosRaw | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_INPUT | ( | PointerRotRaw | ,
 |  | MessageInt | ,
 |  | MessageQuat |
 | ) |  |
protected
APEditorController::EditorController::DECLARE_REQUEST_OUTPUT | ( | SelectionByPointerPos_Path | ,
 |  | MessageVec3 | ,
 |  | MessageNodeList |
 | ) |  |
protected
bool APEditorController::EditorController::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APEditorController::EditorController::pointerBtnUpdate | ( | int | poinerID,
 |  | int | buttonID,
 |  | bool | newState
 | ) |  |
protected
void APEditorController::EditorController::pointerPosUpdate | ( | int | pointerID,
 |  | const osg::Vec3 & | newPos,
 |  | bool | bRaw = false
 | ) |  |
protected
void APEditorController::EditorController::pointerRotUpdate | ( | int | pointerID,
 |  | const osg::Quat & | newRot,
 |  | bool | bRaw = false
 | ) |  |
protected
void APEditorController::EditorController::pointerSelUpdate | ( | int | pointerID,
 |  | unsigned long | newSelection
 | ) |  |
protected
int APEditorController::EditorController::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

void APEditorController::EditorController::removeAbilityMapper ( )
protected
void APEditorController::EditorController::selectionVisibilityUpdate ( )
protected
void APEditorController::EditorController::sendPointerBtnToRelevantOutputs | ( | int | pointerID,
 |  | int | buttonID
 | ) |  |
protected
void APEditorController::EditorController::sendPointerSelectionEvent | ( | int | pointerID,
 |  | unsigned long | newSelection
 | ) |  |
protected
void APEditorController::EditorController::setAbilityMapping ( AbilityMapper::MAPPING * newMapping )
protected
void APEditorController::EditorController::setNewSelection ( unsigned long newSelection )
protected
void APEditorController::EditorController::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

Ability* APEditorController::EditorController::abilityMapper
protected
int APEditorController::EditorController::activeAbilityButtonID
protected
std::string APEditorController::EditorController::activeAbilityName
protected
int APEditorController::EditorController::activeAbilityPointerID
protected
unsigned long APEditorController::EditorController::actSelection
protected
osg::Vec3 APEditorController::EditorController::actViewPosition
protected
const int APEditorController::EditorController::maxButtonsPerPointer = 4
static
const int APEditorController::EditorController::maxPointers = 2
static
EnvironmentObject* APEditorController::EditorController::owner
protected
ECPOINTERINFO APEditorController::EditorController::pointers[maxPointers+1]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/EditorController.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/EditorController.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::EditorController::ECPOINTERBUTTONINFO Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
  • ECPOINTERBUTTONINFO
Public Member Functions | Public Attributes | Protected Attributes | List of all members
APEditorController::EditorController::ECPOINTERBUTTONINFO Class Reference

#include <EditorController.h>

Public Member Functions

ECPOINTERBUTTONINFO ()
~ECPOINTERBUTTONINFO ()
void | setOwner (EditorController *_owner)
bool | setMappedAbility (const char *strID)
std::string & | getMappedAbilityID ()
CAINFO * | getMappedAbilityInfo (bool bForceRefresh)

Public Attributes

bool bState

Protected Attributes

EditorController * owner
std::string mappedAbilityID
ID of an ability that is mapped to this button. More...
CAINFO * cachedInfo
Cached info that the ability returned. More...

Constructor & Destructor Documentation

APEditorController::EditorController::ECPOINTERBUTTONINFO::ECPOINTERBUTTONINFO ( )
inline
APEditorController::EditorController::ECPOINTERBUTTONINFO::~ECPOINTERBUTTONINFO ( )
inline

Member Function Documentation

std::string& APEditorController::EditorController::ECPOINTERBUTTONINFO::getMappedAbilityID ( )
inline
CAINFO * APEditorController::EditorController::ECPOINTERBUTTONINFO::getMappedAbilityInfo ( bool bForceRefresh )
bool APEditorController::EditorController::ECPOINTERBUTTONINFO::setMappedAbility ( const char * strID )

NULL or an empty string means "unmap any ability".

void APEditorController::EditorController::ECPOINTERBUTTONINFO::setOwner ( EditorController * _owner )
inline

Member Data Documentation

bool APEditorController::EditorController::ECPOINTERBUTTONINFO::bState
CAINFO* APEditorController::EditorController::ECPOINTERBUTTONINFO::cachedInfo
protected

Cached info that the ability returned.

std::string APEditorController::EditorController::ECPOINTERBUTTONINFO::mappedAbilityID
protected

ID of an ability that is mapped to this button.

EditorController* APEditorController::EditorController::ECPOINTERBUTTONINFO::owner
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/EditorController.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/EditorController.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorController::EditorController::ECPOINTERINFO Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
  • ECPOINTERINFO
Public Member Functions | Public Attributes | List of all members
APEditorController::EditorController::ECPOINTERINFO Class Reference

#include <EditorController.h>

Public Member Functions

ECPOINTERINFO ()
~ECPOINTERINFO ()

Public Attributes

osg::Vec3 | pos
osg::Vec3 | posRaw
current position More...
osg::Quat | rot
osg::Quat | rotRaw
current rotation More...
unsigned long | actSelection
current selection More...
std::vector< osg::Node * > * | selPath
int | lastButtonPressed
ID of the last pressed button. More...
ECPOINTERBUTTONINFO | buttons [maxButtonsPerPointer+1]

Constructor & Destructor Documentation

APEditorController::EditorController::ECPOINTERINFO::ECPOINTERINFO ( )
inline
APEditorController::EditorController::ECPOINTERINFO::~ECPOINTERINFO ( )
inline

Member Data Documentation

unsigned long APEditorController::EditorController::ECPOINTERINFO::actSelection

current selection

ECPOINTERBUTTONINFO APEditorController::EditorController::ECPOINTERINFO::buttons[maxButtonsPerPointer+1]

Information about relevant buttons. Button 0 is only a filler, so it is not necessary to "shift" indexes.

int APEditorController::EditorController::ECPOINTERINFO::lastButtonPressed

ID of the last pressed button.

osg::Vec3 APEditorController::EditorController::ECPOINTERINFO::pos
osg::Vec3 APEditorController::EditorController::ECPOINTERINFO::posRaw

current position

osg::Quat APEditorController::EditorController::ECPOINTERINFO::rot
osg::Quat APEditorController::EditorController::ECPOINTERINFO::rotRaw

current rotation

std::vector<osg::Node*>* APEditorController::EditorController::ECPOINTERINFO::selPath

selection path (root -> ... EOs/Geodes/Transformation/any Nodes ... -> selected EO -> maybe some other Nodes [but no other EO])

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/EditorController.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::AbilityEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AbilityEditor
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APEditorQAbilities::AbilityEditor Class Reference

#include <AbilityEditor.h>

Inheritance diagram for APEditorQAbilities::AbilityEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Classes

class AllowedAbility

Public Member Functions

AbilityEditor ()
virtual | ~AbilityEditor ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | processButtonRelease (vrecko::CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
bool | createConnectionViz ()
void | destroyConnectionViz ()
bool | executeAddAbility (int iIndex)
bool | executeDeleteAbility (const char *abilityID)
bool | executeAddConnection (const char *connectionMenuString)
bool | executeDeleteConnection (const char *connectionMenuString)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

DynamicArray< AllowedAbility > allowedAbilities
unsigned long | object1ID
unsigned long | object2ID
vrecko::EnvironmentObject * object1
vrecko::EnvironmentObject * object2
APObjectUtils::ConnectionViz * conViz
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APEditorQAbilities::AbilityEditor::AbilityEditor ( )
virtual APEditorQAbilities::AbilityEditor::~AbilityEditor ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::AbilityEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

bool APEditorQAbilities::AbilityEditor::createConnectionViz ( )
protected
void APEditorQAbilities::AbilityEditor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AbilityEditor::destroyConnectionViz ( )
protected
bool APEditorQAbilities::AbilityEditor::executeAddAbility ( int iIndex )
protected
bool APEditorQAbilities::AbilityEditor::executeAddConnection ( const char * connectionMenuString )
protected
bool APEditorQAbilities::AbilityEditor::executeDeleteAbility ( const char * abilityID )
protected
bool APEditorQAbilities::AbilityEditor::executeDeleteConnection ( const char * connectionMenuString )
protected
void APEditorQAbilities::AbilityEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APEditorQAbilities::AbilityEditor::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AbilityEditor::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AbilityEditor::processButtonRelease ( vrecko::CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

DynamicArray<AllowedAbility> APEditorQAbilities::AbilityEditor::allowedAbilities
protected
APObjectUtils::ConnectionViz* APEditorQAbilities::AbilityEditor::conViz
protected
vrecko::EnvironmentObject* APEditorQAbilities::AbilityEditor::object1
protected
unsigned long APEditorQAbilities::AbilityEditor::object1ID
protected
vrecko::EnvironmentObject * APEditorQAbilities::AbilityEditor::object2
protected
unsigned long APEditorQAbilities::AbilityEditor::object2ID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AbilityEditor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AbilityEditor.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::AbilityEditor::AllowedAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AbilityEditor
  • AllowedAbility
Public Attributes | List of all members
APEditorQAbilities::AbilityEditor::AllowedAbility Class Reference

#include <AbilityEditor.h>

Public Attributes

std::string | abilityName
std::string | pluginName
bool | bProcessed

Member Data Documentation

std::string APEditorQAbilities::AbilityEditor::AllowedAbility::abilityName
bool APEditorQAbilities::AbilityEditor::AllowedAbility::bProcessed
std::string APEditorQAbilities::AbilityEditor::AllowedAbility::pluginName
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AbilityEditor.h
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::AnimatorEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AnimatorEditor
Public Member Functions | Protected Member Functions | List of all members
APEditorQAbilities::AnimatorEditor Class Reference

#include <AnimatorEditor.h>

Inheritance diagram for APEditorQAbilities::AnimatorEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

AnimatorEditor ()
virtual | ~AnimatorEditor ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
APObjectUtils::Animator * | GetAnim (bool bCreateIfNotExists=false)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APEditorQAbilities::AnimatorEditor::AnimatorEditor ( )
virtual APEditorQAbilities::AnimatorEditor::~AnimatorEditor ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::AnimatorEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AnimatorEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

Animator * APEditorQAbilities::AnimatorEditor::GetAnim ( bool bCreateIfNotExists = false )
protected
void APEditorQAbilities::AnimatorEditor::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AnimatorEditor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AnimatorEditor.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::AvatarMovement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AvatarMovement
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APEditorQAbilities::AvatarMovement Class Reference

#include <AvatarMovement.h>

Inheritance diagram for APEditorQAbilities::AvatarMovement:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

AvatarMovement ()
virtual | ~AvatarMovement ()
void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | lastRelPointerPos
osg::Quat | lastRelPointerRot
bool | bFirstUpdate
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APEditorQAbilities::AvatarMovement::AvatarMovement ( )
APEditorQAbilities::AvatarMovement::~AvatarMovement ( )
virtual

Member Function Documentation

bool APEditorQAbilities::AvatarMovement::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AvatarMovement::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::AvatarMovement::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorQAbilities::AvatarMovement::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

bool APEditorQAbilities::AvatarMovement::bFirstUpdate
protected
osg::Vec3 APEditorQAbilities::AvatarMovement::lastRelPointerPos
protected
osg::Quat APEditorQAbilities::AvatarMovement::lastRelPointerRot
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AvatarMovement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AvatarMovement.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::ObjectAdd Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectAdd
Public Member Functions | Protected Member Functions | List of all members
APEditorQAbilities::ObjectAdd Class Reference

#include <ObjectAdd.h>

Inheritance diagram for APEditorQAbilities::ObjectAdd:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectAdd ()
virtual | ~ObjectAdd ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
bool | showMenuWithObjects (const char *pDirectory)
bool | createNewObject (const char *pFileName)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APEditorQAbilities::ObjectAdd::ObjectAdd ( )
virtual APEditorQAbilities::ObjectAdd::~ObjectAdd ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::ObjectAdd::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

bool APEditorQAbilities::ObjectAdd::createNewObject ( const char * pFileName )
protected
void APEditorQAbilities::ObjectAdd::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorQAbilities::ObjectAdd::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

bool APEditorQAbilities::ObjectAdd::showMenuWithObjects ( const char * pDirectory )
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectAdd.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectAdd.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::ObjectDelete Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectDelete
Public Member Functions | Protected Member Functions | List of all members
APEditorQAbilities::ObjectDelete Class Reference

#include <ObjectDelete.h>

Inheritance diagram for APEditorQAbilities::ObjectDelete:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectDelete ()
virtual | ~ObjectDelete ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APEditorQAbilities::ObjectDelete::ObjectDelete ( )
inline
virtual APEditorQAbilities::ObjectDelete::~ObjectDelete ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::ObjectDelete::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::ObjectDelete::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorQAbilities::ObjectDelete::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectDelete.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectDelete.cpp
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::ObjectMovement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
Classes | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | Friends | List of all members
APEditorQAbilities::ObjectMovement Class Reference

#include <ObjectMovement.h>

Inheritance diagram for APEditorQAbilities::ObjectMovement:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Classes

struct | CANDIDATEPLANE
class | SnapBox

Public Member Functions

ObjectMovement ()
virtual | ~ObjectMovement ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

enum CandidatePlaneType { Other = 0, Horizontal_PrioritySnap }

Protected Member Functions

virtual CAINFO * | createInfo ()
virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
bool | objectTransformationFromPointer (EnvironmentObject *eo, osg::Matrix *outTrans)
bool | applySnapping (EnvironmentObject *eo, osg::Matrix *inoutTrans)
bool | addSnappingPlane (unsigned long objectID, unsigned long objectSide, osg::Vec3 &center, osg::Vec3 &normal, osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 shiftVec, float shiftLen2, osg::Vec3 &snapPoint, float halfRect1SnapMul, float halfRect2SnapMul, float fMinU, float fMaxU, float fMinV, float fMaxV, CandidatePlaneType type)
bool | isPlaneCompatibleWithSelectedSet (int iPlaneIndex)
bool | calcFinalShiftFromSelectedSet (osg::Vec3 &outShift, int additionalPlane=-1)
bool | intersect2Planes (osg::Vec3 &p1p, osg::Vec3 &p1normal, osg::Vec3 &p2p, osg::Vec3 &p2normal, osg::Vec3 &outLineStart, osg::Vec3 &outLineDir)
bool | intersectLinePlane (osg::Vec3 &lineStart, osg::Vec3 &lineDir, osg::Vec3 &planePoint, osg::Vec3 &planeNormal, osg::Vec3 &outPoint)
bool | projectPointOnPlaneUV (osg::Vec3 &point, osg::Vec3 &planePoint, osg::Vec3 &planeNormal, osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 *outProjectedPoint, float *outDist, float *outU, float *outV)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bApplySnapping
bool | bIgnoreRotation
osg::Vec3 | firstPointerPos
osg::Quat | firstPointerRot
osg::Vec3 | firstObjectPos
osg::Quat | firstObjectRot
unsigned long | movingObjectID
bool | bFirstUpdate
DynamicArray< SnapBox > snapBoxes
osg::BoundingBox | objAABox
osg::Matrix | objAABoxTrans
osg::ref_ptr< EnvironmentObject > | shadowObject
Ability * objectEffect
DynamicArray< CANDIDATEPLANE > planes
DynamicArray< DWORD > | selectedPlanes
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Friends

int planesCompare (const ObjectMovement::CANDIDATEPLANE *elem1, const ObjectMovement::CANDIDATEPLANE *elem2)

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...

Member Enumeration Documentation

enum APEditorQAbilities::ObjectMovement::CandidatePlaneType
protected
Enumerator
Other
Horizontal_PrioritySnap

Constructor & Destructor Documentation

APEditorQAbilities::ObjectMovement::ObjectMovement ( )
virtual APEditorQAbilities::ObjectMovement::~ObjectMovement ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::ObjectMovement::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

bool APEditorQAbilities::ObjectMovement::addSnappingPlane | ( | unsigned long | objectID,
 |  | unsigned long | objectSide,
 |  | osg::Vec3 & | center,
 |  | osg::Vec3 & | normal,
 |  | osg::Vec3 & | halfVec1,
 |  | osg::Vec3 & | halfVec2,
 |  | osg::Vec3 | shiftVec,
 |  | float | shiftLen2,
 |  | osg::Vec3 & | snapPoint,
 |  | float | halfRect1SnapMul,
 |  | float | halfRect2SnapMul,
 |  | float | fMinU,
 |  | float | fMaxU,
 |  | float | fMinV,
 |  | float | fMaxV,
 |  | CandidatePlaneType | type
 | ) |  |
protected
bool APEditorQAbilities::ObjectMovement::applySnapping | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | inoutTrans
 | ) |  |
protected
bool APEditorQAbilities::ObjectMovement::calcFinalShiftFromSelectedSet | ( | osg::Vec3 & | outShift,
 |  | int | additionalPlane = -1
 | ) |  |
protected
CAINFO * APEditorQAbilities::ObjectMovement::createInfo ( )
protectedvirtual
        This method creates a new instance of the CAINFO structure and copies data
        from the [defaltInfo] structure. Additionally, it may change
        some of the parameters of the new structure (especially [dwActiveFlags]).

        CAN be overridden although it is unnecessary in most cases.
        The overridden method should look like this:

        You have complete control over the structure, but some field have
        been already pre-filled: Especially size and some the [dwActiveFlags].
        The [dwActiveFlags] has been changed according to the current state of the ability
        (is Menu displayed -> prefer not to show the selections etc.)
        You can still change any of the attributes.

        CAINFO* info = ControllableAbility::createInfo();
        if (!info)
            return NULL;

Now adjust the members of the structure. Note: If adjusting for example info->dwActiveFlags for selection visibility, ... // you have to use the mask. For example, to set the visibility to _ACTPTR_FORCESHOW: info->dwActiveFlags = CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW | (info->dwActiveFlags & ~CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK);

        return info;

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::ObjectMovement::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::ObjectMovement::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APEditorQAbilities::ObjectMovement::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

bool APEditorQAbilities::ObjectMovement::intersect2Planes | ( | osg::Vec3 & | p1p,
 |  | osg::Vec3 & | p1normal,
 |  | osg::Vec3 & | p2p,
 |  | osg::Vec3 & | p2normal,
 |  | osg::Vec3 & | outLineStart,
 |  | osg::Vec3 & | outLineDir
 | ) |  |
protected
bool APEditorQAbilities::ObjectMovement::intersectLinePlane | ( | osg::Vec3 & | lineStart,
 |  | osg::Vec3 & | lineDir,
 |  | osg::Vec3 & | planePoint,
 |  | osg::Vec3 & | planeNormal,
 |  | osg::Vec3 & | outPoint
 | ) |  |
protected
bool APEditorQAbilities::ObjectMovement::isPlaneCompatibleWithSelectedSet ( int iPlaneIndex )
protected
bool APEditorQAbilities::ObjectMovement::objectTransformationFromPointer | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | outTrans
 | ) |  |
protected
bool APEditorQAbilities::ObjectMovement::projectPointOnPlaneUV | ( | osg::Vec3 & | point,
 |  | osg::Vec3 & | planePoint,
 |  | osg::Vec3 & | planeNormal,
 |  | osg::Vec3 & | halfVec1,
 |  | osg::Vec3 & | halfVec2,
 |  | osg::Vec3 * | outProjectedPoint,
 |  | float * | outDist,
 |  | float * | outU,
 |  | float * | outV
 | ) |  |
protected
void APEditorQAbilities::ObjectMovement::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Friends And Related Function Documentation

int planesCompare | ( | const ObjectMovement::CANDIDATEPLANE * | elem1,
 |  | const ObjectMovement::CANDIDATEPLANE * | elem2
 | ) |  |
friend

Member Data Documentation

bool APEditorQAbilities::ObjectMovement::bApplySnapping
protected
bool APEditorQAbilities::ObjectMovement::bFirstUpdate
protected
bool APEditorQAbilities::ObjectMovement::bIgnoreRotation
protected
osg::Vec3 APEditorQAbilities::ObjectMovement::firstObjectPos
protected
osg::Quat APEditorQAbilities::ObjectMovement::firstObjectRot
protected
osg::Vec3 APEditorQAbilities::ObjectMovement::firstPointerPos
protected
osg::Quat APEditorQAbilities::ObjectMovement::firstPointerRot
protected
unsigned long APEditorQAbilities::ObjectMovement::movingObjectID
protected
osg::BoundingBox APEditorQAbilities::ObjectMovement::objAABox
protected
osg::Matrix APEditorQAbilities::ObjectMovement::objAABoxTrans
protected
Ability* APEditorQAbilities::ObjectMovement::objectEffect
protected
DynamicArray<CANDIDATEPLANE> APEditorQAbilities::ObjectMovement::planes
protected
DynamicArray<DWORD> APEditorQAbilities::ObjectMovement::selectedPlanes
protected
osg::ref_ptr<EnvironmentObject> APEditorQAbilities::ObjectMovement::shadowObject
protected
DynamicArray<SnapBox> APEditorQAbilities::ObjectMovement::snapBoxes
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectMovement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectMovement.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::ObjectMovement::CANDIDATEPLANE Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
  • CANDIDATEPLANE
Public Attributes | List of all members
APEditorQAbilities::ObjectMovement::CANDIDATEPLANE Struct Reference

#include <ObjectMovement.h>

Public Attributes

bool | bIgnore
unsigned long | objectID
unsigned long | objectSide
osg::Vec3 | center
osg::Vec3 | normal
osg::Vec3 | halfRect1
osg::Vec3 | halfRect2
osg::Vec3 | shiftVec
float | shiftLen2
osg::Vec3 | snapPoint
float | hR1SnapMul
float | hR2SnapMul
float | fMinU
float | fMaxU
float | fMinV
float | fMaxV
float | fObjProjectionArea
CandidatePlaneType type

Member Data Documentation

bool APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::bIgnore
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::center
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::fMaxU
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::fMaxV
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::fMinU
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::fMinV
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::fObjProjectionArea
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::halfRect1
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::halfRect2
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::hR1SnapMul
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::hR2SnapMul
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::normal
unsigned long APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::objectID
unsigned long APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::objectSide
float APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::shiftLen2
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::shiftVec
osg::Vec3 APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::snapPoint
CandidatePlaneType APEditorQAbilities::ObjectMovement::CANDIDATEPLANE::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectMovement.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::ObjectMovement::SnapBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
  • SnapBox
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APEditorQAbilities::ObjectMovement::SnapBox Class Reference

#include <ObjectMovement.h>

Public Member Functions

SnapBox ()
~SnapBox ()
void | setOwner (ObjectMovement *_owner)
void | updateShape (const osg::Vec3 &center, const osg::Vec3 &halfLengths, const osg::Matrix &transform)
bool | show ()
bool | hide ()

Protected Member Functions

bool | Init ()
void | Done ()

Protected Attributes

osg::ref_ptr< EnvironmentObject > | graphicObject
osg::ref_ptr< osg::Geode > | osgGeode
osg::ref_ptr
< osg::MatrixTransform > 		osgTransform
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
osg::Vec4 | color
ObjectMovement * owner

Constructor & Destructor Documentation

APEditorQAbilities::ObjectMovement::SnapBox::SnapBox ( )
inline
APEditorQAbilities::ObjectMovement::SnapBox::~SnapBox ( )
inline

Member Function Documentation

void APEditorQAbilities::ObjectMovement::SnapBox::Done ( )
protected
bool APEditorQAbilities::ObjectMovement::SnapBox::hide ( )
bool APEditorQAbilities::ObjectMovement::SnapBox::Init ( )
protected
void APEditorQAbilities::ObjectMovement::SnapBox::setOwner ( ObjectMovement * _owner )
inline
bool APEditorQAbilities::ObjectMovement::SnapBox::show ( )
void APEditorQAbilities::ObjectMovement::SnapBox::updateShape | ( | const osg::Vec3 & | center,
 |  | const osg::Vec3 & | halfLengths,
 |  | const osg::Matrix & | transform
 | ) |  |

Member Data Documentation

osg::Vec4 APEditorQAbilities::ObjectMovement::SnapBox::color
protected
osg::ref_ptr<EnvironmentObject> APEditorQAbilities::ObjectMovement::SnapBox::graphicObject
protected
osg::ref_ptr<osg::Geode> APEditorQAbilities::ObjectMovement::SnapBox::osgGeode
protected
osg::ref_ptr<osg::MatrixTransform> APEditorQAbilities::ObjectMovement::SnapBox::osgTransform
protected
ObjectMovement* APEditorQAbilities::ObjectMovement::SnapBox::owner
protected
osg::ref_ptr<osg::Box> APEditorQAbilities::ObjectMovement::SnapBox::shapeBox
protected
osg::ref_ptr<osg::ShapeDrawable> APEditorQAbilities::ObjectMovement::SnapBox::shapeDraw
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectMovement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectMovement.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::SceneSave Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • SceneSave
Public Member Functions | Protected Member Functions | List of all members
APEditorQAbilities::SceneSave Class Reference

#include <SceneSave.h>

Inheritance diagram for APEditorQAbilities::SceneSave:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

SceneSave ()
virtual | ~SceneSave ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APEditorQAbilities::SceneSave::SceneSave ( )
inline
virtual APEditorQAbilities::SceneSave::~SceneSave ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::SceneSave::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::SceneSave::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorQAbilities::SceneSave::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SceneSave.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/SceneSave.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::SimpleObjectMovement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • SimpleObjectMovement
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APEditorQAbilities::SimpleObjectMovement Class Reference

#include <SimpleObjectMovement.h>

Inheritance diagram for APEditorQAbilities::SimpleObjectMovement:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

SimpleObjectMovement ()
virtual | ~SimpleObjectMovement ()
void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
bool | objectTransformationFromPointer (EnvironmentObject *eo, osg::Matrix *outTrans)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | firstPointerPos
osg::Vec3 | firstObjectPos
unsigned long | movingObjectID
bool | bFirstUpdate
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APEditorQAbilities::SimpleObjectMovement::SimpleObjectMovement ( )
virtual APEditorQAbilities::SimpleObjectMovement::~SimpleObjectMovement ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::SimpleObjectMovement::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::SimpleObjectMovement::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::SimpleObjectMovement::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

void APEditorQAbilities::SimpleObjectMovement::issueRequests ( bool bStopIfNoSelection )
protected
bool APEditorQAbilities::SimpleObjectMovement::objectTransformationFromPointer | ( | EnvironmentObject * | eo,
 |  | osg::Matrix * | outTrans
 | ) |  |
protected
void APEditorQAbilities::SimpleObjectMovement::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

bool APEditorQAbilities::SimpleObjectMovement::bFirstUpdate
protected
osg::Vec3 APEditorQAbilities::SimpleObjectMovement::firstObjectPos
protected
osg::Vec3 APEditorQAbilities::SimpleObjectMovement::firstPointerPos
protected
unsigned long APEditorQAbilities::SimpleObjectMovement::movingObjectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SimpleObjectMovement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/SimpleObjectMovement.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::UseTrigger Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • UseTrigger
Public Member Functions | Protected Member Functions | List of all members
APEditorQAbilities::UseTrigger Class Reference

#include <UseTrigger.h>

Inheritance diagram for APEditorQAbilities::UseTrigger:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

UseTrigger ()
virtual | ~UseTrigger ()
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
bool | SendUseSignal (bool bParameter)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APEditorQAbilities::UseTrigger::UseTrigger ( )
virtual APEditorQAbilities::UseTrigger::~UseTrigger ( )
inlinevirtual

Member Function Documentation

bool APEditorQAbilities::UseTrigger::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::UseTrigger::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

void APEditorQAbilities::UseTrigger::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APEditorQAbilities::UseTrigger::SendUseSignal ( bool bParameter )
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/UseTrigger.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/UseTrigger.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APEditorQAbilities::PresentAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • PresentAbility
Public Attributes | List of all members
APEditorQAbilities::PresentAbility Class Reference

Public Attributes

Ability * ptr
bool bExisting

Member Data Documentation

bool APEditorQAbilities::PresentAbility::bExisting
Ability* APEditorQAbilities::PresentAbility::ptr
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AbilityEditor.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::EditorLogic Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • EditorLogic
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APFFDEditor::EditorLogic Class Reference

#include <EditorLogic.h>

Inheritance diagram for APFFDEditor::EditorLogic:
vrecko::ControllableAbility APFFDEditor::GeometryLoader vrecko::Ability vrecko::BaseClass

Public Member Functions

EditorLogic ()
~EditorLogic ()
void | update (void)
void | postInitialize (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
- Public Member Functions inherited from APFFDEditor::GeometryLoader
GeometryLoader ()
~GeometryLoader ()
Geometry * | getGeometry (unsigned long index)
virtual bool | loadGeometry (osg::Node *pNode)
unsigned long | getGeometriesCount (void)

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
void | CPscale (float scale)
bool | isThisControlPoint (long ID)
void | updateObjectGeometry (void)
void | setAtributesForDeformation (void)
void | resetGeometry (void)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...
- Protected Member Functions inherited from APFFDEditor::GeometryLoader
void | allocateGeometryArray (int count)
void | deallocateGeometryArray ()
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &geometry_pos)
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pGeometriesCount)
virtual void | destroyGeometry ()

Protected Attributes

int | moveLock
float | CPsize
float | transparencyOfEditedObject
float | optimOfCP
osg::Vec3 | previousObjectPosition
vrecko::EnvironmentObject * pEditedObject
Grid * pGrid
bool | gridChanged
bool | objectWasMoved
osg::Vec3 | numberOfCPoints
osg::Matrix * | parentsTransform
osg::Matrix * | inverseParentsTransform
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList
- Protected Attributes inherited from APFFDEditor::GeometryLoader
Geometry * geometryArray
unsigned long | geometries_count

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APFFDEditor::EditorLogic::EditorLogic ( )
APFFDEditor::EditorLogic::~EditorLogic ( )
inline

Member Function Documentation

bool APFFDEditor::EditorLogic::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::CPscale ( float scale )
protected
void APFFDEditor::EditorLogic::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APFFDEditor::EditorLogic::isThisControlPoint ( long ID )
protected
bool APFFDEditor::EditorLogic::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
protectedvirtual

You should override this method if there is any slider in your menu.

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::postInitialize ( void )
virtual

Use initialize() instead.

In "private" section, so basically hidden as well as possible, so others cannot use it.

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::resetGeometry ( void )
protected
void APFFDEditor::EditorLogic::setAtributesForDeformation ( void )
protected
void APFFDEditor::EditorLogic::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

void APFFDEditor::EditorLogic::updateObjectGeometry ( void )
protected

Member Data Documentation

float APFFDEditor::EditorLogic::CPsize
protected
bool APFFDEditor::EditorLogic::gridChanged
protected
osg::Matrix* APFFDEditor::EditorLogic::inverseParentsTransform
protected
int APFFDEditor::EditorLogic::moveLock
protected
osg::Vec3 APFFDEditor::EditorLogic::numberOfCPoints
protected
bool APFFDEditor::EditorLogic::objectWasMoved
protected
float APFFDEditor::EditorLogic::optimOfCP
protected
osg::Matrix* APFFDEditor::EditorLogic::parentsTransform
protected
vrecko::EnvironmentObject* APFFDEditor::EditorLogic::pEditedObject
protected
Grid* APFFDEditor::EditorLogic::pGrid
protected
osg::Vec3 APFFDEditor::EditorLogic::previousObjectPosition
protected
float APFFDEditor::EditorLogic::transparencyOfEditedObject
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/EditorLogic.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/EditorLogic.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::GeometryLoader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoader
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APFFDEditor::GeometryLoader Class Reference

#include <GeometryLoader.h>

Inheritance diagram for APFFDEditor::GeometryLoader:
APFFDEditor::EditorLogic

Classes

struct Geometry

Public Member Functions

GeometryLoader ()
~GeometryLoader ()
Geometry * | getGeometry (unsigned long index)
virtual bool | loadGeometry (osg::Node *pNode)
unsigned long | getGeometriesCount (void)

Protected Member Functions

void | allocateGeometryArray (int count)
void | deallocateGeometryArray ()
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &geometry_pos)
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pGeometriesCount)
virtual void | destroyGeometry ()

Protected Attributes

Geometry * geometryArray
unsigned long geometries_count

Constructor & Destructor Documentation

APFFDEditor::GeometryLoader::GeometryLoader ( )
APFFDEditor::GeometryLoader::~GeometryLoader ( )

Member Function Documentation

void APFFDEditor::GeometryLoader::allocateGeometryArray ( int count )
inlineprotected
void APFFDEditor::GeometryLoader::deallocateGeometryArray ( )
inlineprotected
void APFFDEditor::GeometryLoader::destroyGeometry ( )
protectedvirtual
unsigned long APFFDEditor::GeometryLoader::getGeometriesCount ( void )
inline
Geometry* APFFDEditor::GeometryLoader::getGeometry ( unsigned long index )
inline
bool APFFDEditor::GeometryLoader::getOSGInitCounts | ( | osg::Node * | pNode,
 |  | unsigned long & | pGeometriesCount
 | ) |  |
protected
bool APFFDEditor::GeometryLoader::loadGeometry ( osg::Node * pNode )
virtual
bool APFFDEditor::GeometryLoader::loadGeometryHelper | ( | osg::Node * | pNode,
 |  | osg::Matrix & | transform,
 |  | unsigned long & | geometry_pos
 | ) |  |
protected

Member Data Documentation

unsigned long APFFDEditor::GeometryLoader::geometries_count
protected
Geometry* APFFDEditor::GeometryLoader::geometryArray
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoader.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/GeometryLoader.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::GeometryLoader::Geometry Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoader
  • Geometry
Public Attributes | List of all members
APFFDEditor::GeometryLoader::Geometry Struct Reference

#include <GeometryLoader.h>

Public Attributes

osg::Geometry * | SetNode
osg::Vec3Array * | pVertexStartArray
osg::Vec3 * | pVertexRelposition
osg::Matrix | transformMatrix

Member Data Documentation

osg::Vec3* APFFDEditor::GeometryLoader::Geometry::pVertexRelposition
osg::Vec3Array* APFFDEditor::GeometryLoader::Geometry::pVertexStartArray
osg::Geometry* APFFDEditor::GeometryLoader::Geometry::SetNode
osg::Matrix APFFDEditor::GeometryLoader::Geometry::transformMatrix
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoader.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::GeometryLoaderBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APFFDEditor::GeometryLoaderBase Class Reference

#include <GeometryLoaderBase.h>

Classes

struct | FaceBase
struct | VertexBase

Public Member Functions

GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()

Protected Member Functions

bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
Returns counts of vertices and primitives stored in OSG node. More...
virtual bool | loadGeometry (osg::Node *pNode)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()

Protected Attributes

void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
vrecko::EnvironmentObject * thisOwnerPtr

Constructor & Destructor Documentation

APFFDEditor::GeometryLoaderBase::GeometryLoaderBase ( )
APFFDEditor::GeometryLoaderBase::~GeometryLoaderBase ( )

Member Function Documentation

virtual void APFFDEditor::GeometryLoaderBase::allocateFaceArray ( unsigned long numFaces )
inlinevirtual
virtual void APFFDEditor::GeometryLoaderBase::allocateVertexArray ( unsigned long numVertices )
inlinevirtual
virtual void APFFDEditor::GeometryLoaderBase::deallocateFaceArray ( )
inlinevirtual
virtual void APFFDEditor::GeometryLoaderBase::deallocateVertexArray ( )
inlinevirtual
void APFFDEditor::GeometryLoaderBase::debugWriteNormals ( )
void APFFDEditor::GeometryLoaderBase::destroyGeometry ( )
protectedvirtual
void* APFFDEditor::GeometryLoaderBase::getFace ( unsigned long index )
inline
unsigned long APFFDEditor::GeometryLoaderBase::getFaceCount ( )
inline
virtual unsigned long APFFDEditor::GeometryLoaderBase::getFaceStructureSize ( )
inlinevirtual
osg::Vec3 * APFFDEditor::GeometryLoaderBase::getNormalByIndex | ( | osg::Geometry::AttributeBinding | normalBinding,
 |  | osg::Vec3Array * | pNormArray,
 |  | osg::IndexArray * | pNormIndices,
 |  | unsigned long | index
 | ) |  |
inlineprotected
bool APFFDEditor::GeometryLoaderBase::getOSGInitCounts | ( | osg::Node * | pNode,
 |  | unsigned long & | pVertexCount,
 |  | unsigned long & | pPrimitiveCount
 | ) |  |
protected

Returns counts of vertices and primitives stored in OSG node.

void* APFFDEditor::GeometryLoaderBase::getVertex ( unsigned long index )
inline
unsigned long APFFDEditor::GeometryLoaderBase::getVertexCount ( )
inline
virtual unsigned long APFFDEditor::GeometryLoaderBase::getVertexStructureSize ( )
inlinevirtual
bool APFFDEditor::GeometryLoaderBase::loadGeometry ( osg::Node * pNode )
protectedvirtual
bool APFFDEditor::GeometryLoaderBase::loadGeometryHelper | ( | osg::Node * | pNode,
 |  | osg::Matrix & | transform,
 |  | unsigned long & | vertex_pos,
 |  | unsigned long & | face_pos
 | ) |  |
protected
bool APFFDEditor::GeometryLoaderBase::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual
void APFFDEditor::GeometryLoaderBase::recalculateNormals ( )
protected
void APFFDEditor::GeometryLoaderBase::sortVerticesClockwise ( )
protected

Member Data Documentation

bool APFFDEditor::GeometryLoaderBase::bRecalculateNormals
protected
unsigned long APFFDEditor::GeometryLoaderBase::face_count
protected
unsigned long APFFDEditor::GeometryLoaderBase::face_size
protected
void* APFFDEditor::GeometryLoaderBase::faces
protected
vrecko::EnvironmentObject* APFFDEditor::GeometryLoaderBase::thisOwnerPtr
protected
unsigned long APFFDEditor::GeometryLoaderBase::vertex_count
protected
unsigned long APFFDEditor::GeometryLoaderBase::vertex_size
protected
void* APFFDEditor::GeometryLoaderBase::vertices
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoaderBase.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/GeometryLoaderBase.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::GeometryLoaderBase::FaceBase Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
  • FaceBase
Public Attributes | List of all members
APFFDEditor::GeometryLoaderBase::FaceBase Struct Reference

#include <GeometryLoaderBase.h>

Public Attributes

unsigned long | vIndex [3]
osg::Vec3 | min
osg::Vec3 | normal

Member Data Documentation

osg::Vec3 APFFDEditor::GeometryLoaderBase::FaceBase::min
osg::Vec3 APFFDEditor::GeometryLoaderBase::FaceBase::normal
unsigned long APFFDEditor::GeometryLoaderBase::FaceBase::vIndex[3]
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoaderBase.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::GeometryLoaderBase::VertexBase Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
  • VertexBase
Public Attributes | List of all members
APFFDEditor::GeometryLoaderBase::VertexBase Struct Reference

#include <GeometryLoaderBase.h>

Public Attributes

osg::Vec3 | pos
osg::Vec3 | realPos
osg::Vec3 | normal
osg::Vec3 | relPosInGrid

Member Data Documentation

osg::Vec3 APFFDEditor::GeometryLoaderBase::VertexBase::normal
osg::Vec3 APFFDEditor::GeometryLoaderBase::VertexBase::pos
osg::Vec3 APFFDEditor::GeometryLoaderBase::VertexBase::realPos
osg::Vec3 APFFDEditor::GeometryLoaderBase::VertexBase::relPosInGrid
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoaderBase.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::Grid Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
APFFDEditor::Grid Class Reference

#include <Grid.h>

Classes

struct | ControlPoint
struct | Edge

Public Member Functions

Grid ()
~Grid ()
void | setCountOfControlPoints (osg::Vec3 pom)
osg::Vec3 | getCountOfControlPoints (void)
bool | createGrid (vrecko::EnvironmentObject *object)
bool | updateGrid (void)
void | setOptimalizationOfCP (unsigned int value)

Protected Member Functions

void | allocateControlPointArray ()
void | allocateEdgeArray ()
void | deallocateEdgeArray ()
void | deallocateControlPointArray ()
virtual void | destroyGeometry ()

Protected Attributes

ControlPoint *** controlPoints
Edge * edges
osg::Vec3 | countOfCP
unsigned long | controlPoint_count
unsigned long | edge_count
osg::ref_ptr< osg::Geode > | osgGeode
float | CPscaling
bool | gridWasCreated
unsigned int | optimalizationOfCP

Friends

class EditorLogic

Constructor & Destructor Documentation

APFFDEditor::Grid::Grid ( )
APFFDEditor::Grid::~Grid ( )

Member Function Documentation

void APFFDEditor::Grid::allocateControlPointArray ( )
inlineprotected
void APFFDEditor::Grid::allocateEdgeArray ( )
inlineprotected
bool APFFDEditor::Grid::createGrid ( vrecko::EnvironmentObject * object )
void APFFDEditor::Grid::deallocateControlPointArray ( )
inlineprotected
void APFFDEditor::Grid::deallocateEdgeArray ( )
inlineprotected
void APFFDEditor::Grid::destroyGeometry ( )
protectedvirtual
osg::Vec3 APFFDEditor::Grid::getCountOfControlPoints ( void )
inline
void APFFDEditor::Grid::setCountOfControlPoints ( osg::Vec3 pom )
inline
void APFFDEditor::Grid::setOptimalizationOfCP ( unsigned int value )
inline
bool APFFDEditor::Grid::updateGrid ( void )

Friends And Related Function Documentation

friend class EditorLogic
friend

Member Data Documentation

unsigned long APFFDEditor::Grid::controlPoint_count
protected
ControlPoint*** APFFDEditor::Grid::controlPoints
protected
osg::Vec3 APFFDEditor::Grid::countOfCP
protected
float APFFDEditor::Grid::CPscaling
protected
unsigned long APFFDEditor::Grid::edge_count
protected
Edge* APFFDEditor::Grid::edges
protected
bool APFFDEditor::Grid::gridWasCreated
protected
unsigned int APFFDEditor::Grid::optimalizationOfCP
protected
osg::ref_ptr<osg::Geode> APFFDEditor::Grid::osgGeode
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/Grid.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/Grid.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::Grid::ControlPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
  • ControlPoint
Public Attributes | List of all members
APFFDEditor::Grid::ControlPoint Struct Reference

#include <Grid.h>

Public Attributes

vrecko::EnvironmentObject * EO
osg::Vec3 | startPos
osg::Vec3 | prevPos
bool | visited

Member Data Documentation

vrecko::EnvironmentObject* APFFDEditor::Grid::ControlPoint::EO
osg::Vec3 APFFDEditor::Grid::ControlPoint::prevPos
osg::Vec3 APFFDEditor::Grid::ControlPoint::startPos
bool APFFDEditor::Grid::ControlPoint::visited
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/Grid.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APFFDEditor::Grid::Edge Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
  • Edge
Public Attributes | List of all members
APFFDEditor::Grid::Edge Struct Reference

#include <Grid.h>

Public Attributes

unsigned long | ID1
unsigned long | ID2
osg::ref_ptr< osg::Geometry > | osgGeom

Member Data Documentation

unsigned long APFFDEditor::Grid::Edge::ID1
unsigned long APFFDEditor::Grid::Edge::ID2
osg::ref_ptr<osg::Geometry> APFFDEditor::Grid::Edge::osgGeom
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/Grid.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::ColorPicker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • ColorPicker
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::ColorPicker Class Reference

spatial HSL Color Picker More...

#include <ColorPicker.h>

Inheritance diagram for APGUI::ColorPicker:
APGUI::GUI_Item vrecko::Ability vrecko::BaseClass

Public Member Functions

ColorPicker ()
~ColorPicker ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
Core initialization. More...
bool | createVisuals ()
create visual representation of color picker More...
void | pointed (bool pointed)
Called when user point with cursor (hand, usually) to this GUI element. More...
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
process actions received from Input connector More...
void | setState (GUI_ITEM_STATE newState)
Set new state of item. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APGUI::GUI_Item
GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
virtual void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | createColorSphere (osg::Vec3 *pos, float radius, osg::Vec4 *colour)
void | evoke ()
show color picker, set-ut GUI controller More...
void | RGBtoHSL (osg::Vec4 *p_source, osg::Vec3 *target)
void | HSLtoPos (osg::Vec3 *p_hsl, osg::Vec3 *p_pos)
void | PostoHSL (osg::Vec3 *p_pos, osg::Vec3 *p_hsl)
void | HSLtoRGB (osg::Vec3 *source, osg::Vec4 *target)
osg::Vec3 | limitPosition (osg::Vec3 handPosition)
bool | linesIntersection (osg::Vec3 *p_point1, osg::Vec3 *p_orientation1, osg::Vec3 *p_point2, osg::Vec3 *p_orientation2, osg::Vec3 *result)
void | revoke ()
hide color picker, set-ut GUI controller More...
DECLARE_INPUT (Evoke, MessageBool)
DECLARE_INPUT (GUIItemClicked, MessageString)
DECLARE_INPUT (Select, MessageBool)
DECLARE_INPUT (ExternalDeactivation, MessageObjectID)
DECLARE_REQUEST_INPUT (EvokeHSLColorPicker, MessageString, MessageBool)
DECLARE_OUTPUT (Colour, MessageVec4)
DECLARE_REQUEST_OUTPUT (SensorPosition, MessageInt, MessageVec3)
- Protected Member Functions inherited from APGUI::GUI_Item
osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | _isActive
flag - is color picker active (visibile) right now? More...
bool | _alwaysInMiddle
not implemented at moment - always true. Says, if color picker should emerge at center of screen, or somewhere else More...
float | _pickerHeight
float | _pickerRadius
float | spheresRadius
osg::Geode * | osgGeode
float | handSphereRadius
osg::ShapeDrawable * | handShapeDraw
osg::Sphere * | handShapeSphere
Interconnection * _temporaryInterconnection
int | _icontoDeactivate
- Protected Attributes inherited from APGUI::GUI_Item
string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

spatial HSL Color Picker

Ability for simple adding HSL color picker to scene.

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::ColorPicker::ColorPicker ( )
APGUI::ColorPicker::~ColorPicker ( )

Member Function Documentation

void APGUI::ColorPicker::createColorSphere | ( | osg::Vec3 * | pos,
 |  | float | radius,
 |  | osg::Vec4 * | colour
 | ) |  |
protected
bool APGUI::ColorPicker::createVisuals ( )

create visual representation of color picker

APGUI::ColorPicker::DECLARE_INPUT | ( | Evoke | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_INPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_INPUT | ( | Select | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_INPUT | ( | ExternalDeactivation | ,
 |  | MessageObjectID |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_OUTPUT | ( | Colour | ,
 |  | MessageVec4 |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_REQUEST_INPUT | ( | EvokeHSLColorPicker | ,
 |  | MessageString | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::ColorPicker::DECLARE_REQUEST_OUTPUT | ( | SensorPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
void APGUI::ColorPicker::evoke ( )
protected

show color picker, set-ut GUI controller

void APGUI::ColorPicker::HSLtoPos | ( | osg::Vec3 * | p_hsl,
 |  | osg::Vec3 * | p_pos
 | ) |  |
protected
void APGUI::ColorPicker::HSLtoRGB | ( | osg::Vec3 * | source,
 |  | osg::Vec4 * | target
 | ) |  |
protected
bool APGUI::ColorPicker::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

osg::Vec3 APGUI::ColorPicker::limitPosition ( osg::Vec3 handPosition )
protected
bool APGUI::ColorPicker::linesIntersection | ( | osg::Vec3 * | p_point1,
 |  | osg::Vec3 * | p_orientation1,
 |  | osg::Vec3 * | p_point2,
 |  | osg::Vec3 * | p_orientation2,
 |  | osg::Vec3 * | result
 | ) |  |
protected
void APGUI::ColorPicker::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand, usually) to this GUI element.

When pointed, GUI item can change its geometry (e.g. change color, switch to different model) as visual feedback to user

Parameters
pointed is true when user points on this item and false when user "unpoint" it.

Implements APGUI::GUI_Item.

void APGUI::ColorPicker::PostoHSL | ( | osg::Vec3 * | p_pos,
 |  | osg::Vec3 * | p_hsl
 | ) |  |
protected
bool APGUI::ColorPicker::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
virtual

process actions received from Input connector

if color picker is active and 'main click' is send, pick color and send it to receiver otherwise, do nothing

Implements APGUI::GUI_Item.

void APGUI::ColorPicker::revoke ( )
protected

hide color picker, set-ut GUI controller

void APGUI::ColorPicker::RGBtoHSL | ( | osg::Vec4 * | p_source,
 |  | osg::Vec3 * | target
 | ) |  |
protected
void APGUI::ColorPicker::setState ( GUI_ITEM_STATE newState )
virtual

Set new state of item.

Implements APGUI::GUI_Item.

void APGUI::ColorPicker::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool APGUI::ColorPicker::_alwaysInMiddle
protected

not implemented at moment - always true. Says, if color picker should emerge at center of screen, or somewhere else

int APGUI::ColorPicker::_icontoDeactivate
protected
bool APGUI::ColorPicker::_isActive
protected

flag - is color picker active (visibile) right now?

float APGUI::ColorPicker::_pickerHeight
protected
float APGUI::ColorPicker::_pickerRadius
protected
Interconnection* APGUI::ColorPicker::_temporaryInterconnection
protected
osg::ShapeDrawable* APGUI::ColorPicker::handShapeDraw
protected
osg::Sphere* APGUI::ColorPicker::handShapeSphere
protected
float APGUI::ColorPicker::handSphereRadius
protected
osg::Geode* APGUI::ColorPicker::osgGeode
protected
float APGUI::ColorPicker::spheresRadius
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ColorPicker.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/ColorPicker.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::GUI_Controller Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Controller
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::GUI_Controller Class Reference

GUI Controller class. More...

#include <GUI_Controller.h>

Inheritance diagram for APGUI::GUI_Controller:
vrecko::Ability vrecko::BaseClass

Public Member Functions

GUI_Controller ()
~GUI_Controller ()
void | enableGUI (bool enable)
enable / disable GUI functions More...
ItemsGroup * | getorCreateGroup (string groupName)
If group doesn't exists, create it, return pointer to it, o. More...
GUI_Item * | getItembyName (string itemName)
string | getLayoutString ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
Core initialization. More...
void | registerPointableGuiItem (const unsigned int ID, GUI_Item *item)
Register a new point-able GUI item to the controller. More...
void | registerGlobalGuiItem (const int sensor, GUI_Item *item)
void | reset ()
reset GUI - set everything to default state (layouts, groups, ...) More...
void | setMenuShown (const int sensor, Menu *shownMenu)
Setting _menuShown flag. More...
bool | setLayout (string name)
bool | switchLayout (string name)
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
void | unregisterGlobalGuiItem (const int sensor, GUI_Item *item)
void | unregisterPointableGuiItem (const unsigned int ID)
Unregister a existing point-able GUI item from the controller. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | pointObjectByID (int sensor_number, unsigned long selectedID)
Handle pointing to objects. More...
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
bool | processContextClick (const int sensorNumber, const bool value)
DECLARE_REQUEST_INPUT (Sensor_0_mainClick, MessageBool, MessageBool)
DECLARE_REQUEST_INPUT (Sensor_1_mainClick, MessageBool, MessageBool)
DECLARE_REQUEST_INPUT (Sensor_0_contextClick, MessageBool, MessageBool)
DECLARE_REQUEST_INPUT (Sensor_1_contextClick, MessageBool, MessageBool)
DECLARE_REQUEST_OUTPUT (SelectedObjectID, MessageInt, MessageObjectID)
DECLARE_INPUT (SwitchLayout, MessageString)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | _disabled
flag for temporary disabling GUI functions More...
int | _maxNunberofInputDevices
Maximum number of input devices, that can interact with GUI. More...
int * | _pointedIndexes
array of actually pointed objects IDs - one for each position sensor More...
bool | _firstTimeUpdate
GUI_Item ** _pointedAbilities
array of pointers to GUI abilities of actually pointed GUI EOs More...
GUI_Item ** _pressedAbilities
array of pointers to GUI abilities of actually pointed GUI EOs More...
std::vector< GUI_Item * > * | _globalAbilities
array of stacks of pointers to GUI abilities of global GUI Items (menu, color picker, ) More...
Menu ** _shownMenus
osg::Vec3 * | _actualPositions
array of actual positions of input devices More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
LayoutMapType _layouts
map of all defined layouts More...
Layout * _actualLayout
Actually used layout. Just one layout is active at all times. More...
float | _toolTipTime
Time, in seconds, before tooltip appears. More...
osg::Timer | _timer
instance of osg::Timer class - meeasures time, can compute delte of two times, ... More...
osg::Timer_t * | _pointedTime
array of timestamp when something was pointed with one of sensors More...
bool * | _toolTipShown
array of flags if toolTip is shown for each sensor More...
GuiItemMapType _itemsMap
Map of all GUI related environment objects IDs (key) and pointers to theirs GUI abilities (value). More...
std::vector< osg::ref_ptr
< ItemsGroup > > 		_groups
Map of all used groups of items. More...
int | _debugButtonPressed
int | _debugButtonReleased
unsigned int | _selectionaccumulator
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

GUI Controller class.

Solving basic functionality of GUI - pointing to elements, clicking, receiving events

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::GUI_Controller::GUI_Controller ( )
APGUI::GUI_Controller::~GUI_Controller ( )

Member Function Documentation

APGUI::GUI_Controller::DECLARE_INPUT | ( | SwitchLayout | ,
 |  | MessageString |
 | ) |  |
protected
APGUI::GUI_Controller::DECLARE_REQUEST_INPUT | ( | Sensor_0_mainClick | ,
 |  | MessageBool | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::GUI_Controller::DECLARE_REQUEST_INPUT | ( | Sensor_1_mainClick | ,
 |  | MessageBool | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::GUI_Controller::DECLARE_REQUEST_INPUT | ( | Sensor_0_contextClick | ,
 |  | MessageBool | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::GUI_Controller::DECLARE_REQUEST_INPUT | ( | Sensor_1_contextClick | ,
 |  | MessageBool | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::GUI_Controller::DECLARE_REQUEST_OUTPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
void APGUI::GUI_Controller::enableGUI ( bool enable )

enable / disable GUI functions

GUI_Item * APGUI::GUI_Controller::getItembyName ( string itemName )
string APGUI::GUI_Controller::getLayoutString ( )
inline
ItemsGroup * APGUI::GUI_Controller::getorCreateGroup ( string groupName )

If group doesn't exists, create it, return pointer to it, o.

Parameters
groupName name of group
Returns
pointer to group
bool APGUI::GUI_Controller::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void APGUI::GUI_Controller::pointObjectByID | ( | int | sensor_number,
 |  | unsigned long | selectedID
 | ) |  |
protected

Handle pointing to objects.

Un-point old pointed object, if such exists. Check, if given ID is related to GUI ability If so, point (highlight) new object and store info about it

Parameters
sensor_number | number of sensor pointing to some object
selectedID | ID of newly pointed object
bool APGUI::GUI_Controller::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
protected
bool APGUI::GUI_Controller::processContextClick | ( | const int | sensorNumber,
 |  | const bool | value
 | ) |  |
protected
void APGUI::GUI_Controller::registerGlobalGuiItem | ( | const int | sensor,
 |  | GUI_Item * | item
 | ) |  |
void APGUI::GUI_Controller::registerPointableGuiItem | ( | const unsigned int | ID,
 |  | GUI_Item * | item
 | ) |  |

Register a new point-able GUI item to the controller.

Called from GUI_Item constructor. Should NOT be called from any other place.

Parameters
ID | ID of Environment Object related to GUI Item
item | pointer to GUI Item class instance
void APGUI::GUI_Controller::reset ( )

reset GUI - set everything to default state (layouts, groups, ...)

bool APGUI::GUI_Controller::setLayout ( string name )
void APGUI::GUI_Controller::setMenuShown | ( | const int | sensor,
 |  | Menu * | shownMenu
 | ) |  |

Setting _menuShown flag.

Parameters
sensor | index of related sensor
boolValue | flag indicating, if menu is shown or not
Returns
bool APGUI::GUI_Controller::switchLayout ( string name )
void APGUI::GUI_Controller::unregisterGlobalGuiItem | ( | const int | sensor,
 |  | GUI_Item * | item
 | ) |  |
void APGUI::GUI_Controller::unregisterPointableGuiItem ( const unsigned int ID )

Unregister a existing point-able GUI item from the controller.

Called from GUI_Item destructor. Should NOT be called from any other place.

Parameters
ID ID of Environment Object of removed GUI item
void APGUI::GUI_Controller::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

Layout* APGUI::GUI_Controller::_actualLayout
protected

Actually used layout. Just one layout is active at all times.

however, individual GUI Items can exist even out of scope of layouts. Those GUI items are not affected by layout changes

osg::Vec3* APGUI::GUI_Controller::_actualPositions
protected

array of actual positions of input devices

osg::Vec4 APGUI::GUI_Controller::_colourActive
protected
osg::Vec4 APGUI::GUI_Controller::_colourDefault
protected
osg::Vec4 APGUI::GUI_Controller::_colourDisabled
protected
osg::Vec4 APGUI::GUI_Controller::_colourHovered
protected
osg::Vec4 APGUI::GUI_Controller::_colourPressed
protected
int APGUI::GUI_Controller::_debugButtonPressed
protected
int APGUI::GUI_Controller::_debugButtonReleased
protected
bool APGUI::GUI_Controller::_disabled
protected

flag for temporary disabling GUI functions

For example - during virtual tools usage (like a brush) GUI should not react

bool APGUI::GUI_Controller::_firstTimeUpdate
protected
std::vector<GUI_Item *>* APGUI::GUI_Controller::_globalAbilities
protected

array of stacks of pointers to GUI abilities of global GUI Items (menu, color picker, )

std::vector<osg::ref_ptr<ItemsGroup> > APGUI::GUI_Controller::_groups
protected

Map of all used groups of items.

GuiItemMapType APGUI::GUI_Controller::_itemsMap
protected

Map of all GUI related environment objects IDs (key) and pointers to theirs GUI abilities (value).

Used to speed things (selection process) up. It is not entirely necessary - all information stored in map can be computed at any time.

Individual GUI item registers add unregisters them-selfs automatically, during constructor and destructor of GUI_Item class.

LayoutMapType APGUI::GUI_Controller::_layouts
protected

map of all defined layouts

There is always at least one layout defined: "Empty", with no items.

int APGUI::GUI_Controller::_maxNunberofInputDevices
protected

Maximum number of input devices, that can interact with GUI.

For one-person applications, two should be enough

GUI_Item** APGUI::GUI_Controller::_pointedAbilities
protected

array of pointers to GUI abilities of actually pointed GUI EOs

int* APGUI::GUI_Controller::_pointedIndexes
protected

array of actually pointed objects IDs - one for each position sensor

if no object is pointed, than 0 is stored.

osg::Timer_t* APGUI::GUI_Controller::_pointedTime
protected

array of timestamp when something was pointed with one of sensors

GUI_Item** APGUI::GUI_Controller::_pressedAbilities
protected

array of pointers to GUI abilities of actually pointed GUI EOs

unsigned int APGUI::GUI_Controller::_selectionaccumulator
protected
Menu** APGUI::GUI_Controller::_shownMenus
protected
osg::Timer APGUI::GUI_Controller::_timer
protected

instance of osg::Timer class - meeasures time, can compute delte of two times, ...

bool* APGUI::GUI_Controller::_toolTipShown
protected

array of flags if toolTip is shown for each sensor

float APGUI::GUI_Controller::_toolTipTime
protected

Time, in seconds, before tooltip appears.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Controller.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_Controller.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::Interconnection Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Interconnection
Public Member Functions | Public Attributes | List of all members
APGUI::Interconnection Class Reference

used to simplify deletion of created interconnections (especially in menu) More...

#include <GUI_item.h>

Public Member Functions

Interconnection (const string typ, const string sen, const string rec)

Public Attributes

string | type
string | sender
string | receiver

Detailed Description

used to simplify deletion of created interconnections (especially in menu)

Constructor & Destructor Documentation

APGUI::Interconnection::Interconnection | ( | const string | typ,
 |  | const string | sen,
 |  | const string | rec
 | ) |  |
inline

Member Data Documentation

string APGUI::Interconnection::receiver
string APGUI::Interconnection::sender
string APGUI::Interconnection::type
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_item.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::GUI_Item Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Item
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::GUI_Item Class Referenceabstract

VRECKO GUI Item class. More...

#include <GUI_item.h>

Inheritance diagram for APGUI::GUI_Item:
vrecko::Ability vrecko::BaseClass APGUI::ColorPicker APGUI::Icon APGUI::Menu APGUI::Slider APGUI::IconColour

Public Member Functions

GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
virtual void | pointed (bool pointed)=0
Called when user point with cursor (hand, usually) to this GUI element. More...
virtual void | setState (GUI_ITEM_STATE newState)=0
Set new state of item. More...
virtual bool | processAction (const int sensorNumber, const APGUI::GUI_ACTION action, const bool pressed)=0
Called when user presses defined button. More...
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
virtual void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

VRECKO GUI Item class.

Pure virtual class, serve as base for all types of elements of GUI like Icon, Slider, menu,...

Ability can be added as child of EO or world. Ability constructs its own geometry, so parent object can be empty. When ability is removed (e.g. via GUI controller) its removes its geometry from scene graph.

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::GUI_Item::GUI_Item ( const char * abName )
APGUI::GUI_Item::~GUI_Item ( )

Member Function Documentation

string APGUI::GUI_Item::getGUIItemName ( )
inline
osgText::Text* APGUI::GUI_Item::GUI_Item::createLabel ( )
protected
void APGUI::GUI_Item::hide ( )
inline
void APGUI::GUI_Item::hideTooltip ( )
bool APGUI::GUI_Item::initialize | ( | bool | pointable = true,
 |  | int | sensor = -1
 | ) |  |
protected

basic initialization - common for all GUI Item types

bool APGUI::GUI_Item::isDefaultStateActive ( )
inline

returns if initial state of this item is active (false in most cases)

virtual void APGUI::GUI_Item::pointed ( bool pointed )
pure virtual

Called when user point with cursor (hand, usually) to this GUI element.

When pointed, GUI item can change its geometry (e.g. change color, switch to different model) as visual feedback to user

Parameters
pointed is true when user points on this item and false when user "unpoint" it.

Implemented in APGUI::Icon, APGUI::Slider, APGUI::Menu, and APGUI::ColorPicker.

virtual bool APGUI::GUI_Item::processAction | ( | const int | sensorNumber,
 |  | const APGUI::GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
pure virtual

Called when user presses defined button.

Parameters
sensorNumber | which sensor is pressing the button
action | type of action (main, context, ...) \ param pressed - true if button/key was pressed, false if it was released
Returns
continue processing of action with other parts of vrecko? (see chain of responsibility in Input Connector)

Implemented in APGUI::Icon, APGUI::Slider, APGUI::Menu, APGUI::IconColour, and APGUI::ColorPicker.

void APGUI::GUI_Item::setColours | ( | osg::Vec4 | colourActive,
 |  | osg::Vec4 | colourDefault,
 |  | osg::Vec4 | colourHovered,
 |  | osg::Vec4 | colourPressed,
 |  | osg::Vec4 | colourDisabled
 | ) |  |
virtual

Called, when visual models have to be switched (user pointed or clicked on some GUI item)

Reimplemented in APGUI::Slider.

virtual void APGUI::GUI_Item::setState ( GUI_ITEM_STATE newState )
pure virtual

Set new state of item.

Implemented in APGUI::Icon, APGUI::Slider, APGUI::Menu, and APGUI::ColorPicker.

void APGUI::GUI_Item::show ( )
inline
void APGUI::GUI_Item::showTooltip ( )

Member Data Documentation

osg::Vec4 APGUI::GUI_Item::_colourActive
protected
osg::Vec4 APGUI::GUI_Item::_colourDefault
protected
osg::Vec4 APGUI::GUI_Item::_colourDisabled
protected
osg::Vec4 APGUI::GUI_Item::_colourHovered
protected
osg::Vec4 APGUI::GUI_Item::_colourPressed
protected
GUI_Controller* APGUI::GUI_Item::_controller
protected

pointer to GUI controller

bool APGUI::GUI_Item::_defaultStateActive
protected

flag, if this item should be in 'active' state after startup / reset

std::vector<Interconnection *> APGUI::GUI_Item::_interconnections
protected

list of all created interconnections,

osg::ref_ptr<osg::MatrixTransform> APGUI::GUI_Item::_itemTransform
protected

transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object

osg::ref_ptr<GUI_Text> APGUI::GUI_Item::_label
protected

Label - just a static label of Item.

string APGUI::GUI_Item::_name
protected

Identification of this GUI item.

should be unique for each item in GUI

EnvironmentObject* APGUI::GUI_Item::_parent
protected

Pointer to parent object.

int APGUI::GUI_Item::_pointedCounter
protected

How many sensors is pointing to this GUI Item.

bool APGUI::GUI_Item::_pressed
protected

True, when user holds GUI-interaction button pressed, pointing on this GUI item.

string APGUI::GUI_Item::_receiver
protected

name of target object or ability

int APGUI::GUI_Item::_sensorNumber
protected

index of input device, that currently pressed GUI item

GUI_ITEM_STATE APGUI::GUI_Item::_state
protected

state of item - default, active, disabled, ...

osg::Group* APGUI::GUI_Item::_texts
protected
osg::ref_ptr<GUI_Text> APGUI::GUI_Item::_toolTip
protected

Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_item.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_item.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::GUI_Text Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Text
Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
APGUI::GUI_Text Class Reference

Text. More...

#include <GUI_Text.h>

Inheritance diagram for APGUI::GUI_Text:

Public Member Functions

GUI_Text ()
~GUI_Text ()
void | setText (const std::string &content, const osg::Vec3 &pos, float size, osg::Vec4 &color=osg::Vec4(0.0, 0.0, 0.0, 1.0))
void | setText (const std::string &content)
void | show ()
void | hide ()

Protected Attributes

osg::ref_ptr< osgText::Text > _text

Static Protected Attributes

static osg::ref_ptr
< osgText::Font > 		_font = osgText::readFontFile("data/Fonts/arial.ttf")

Detailed Description

Text.

Derivation of Geode. Used in GUI plug-in for labels, tooltips and such stuff

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::GUI_Text::GUI_Text ( )
APGUI::GUI_Text::~GUI_Text ( )

Member Function Documentation

void APGUI::GUI_Text::hide ( )
void APGUI::GUI_Text::setText | ( | const std::string & | content,
 |  | const osg::Vec3 & | pos,
 |  | float | size,
 |  | osg::Vec4 & | color = osg::Vec4(0.0, 0.0, 0.0, 1.0)
 | ) |  |
void APGUI::GUI_Text::setText ( const std::string & content )
void APGUI::GUI_Text::show ( )

Member Data Documentation

osg::ref_ptr< osgText::Font > APGUI::GUI_Text::_font = osgText::readFontFile("data/Fonts/arial.ttf")
staticprotected
osg::ref_ptr<osgText::Text> APGUI::GUI_Text::_text
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Text.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_Text.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::Icon Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Icon
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::Icon Class Reference

Icon. More...

#include <Icon.h>

Inheritance diagram for APGUI::Icon:
APGUI::GUI_Item vrecko::Ability vrecko::BaseClass APGUI::IconColour

Public Member Functions

Icon ()
~Icon ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
bool | initialize (string name, string receiver, string label, string tooltip, string group, osg::Vec3 position=osg::Vec3())
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
Called when user presses defined button. More...
void | pointed (bool pointed)
Called when user point with cursor (hand, usually) to this GUI element. More...
void | setState (GUI_ITEM_STATE newState)
Set state (active / inactive) of switch icon. More...
void | setPartColour (string partName, osg::Vec4 newColour)
- Public Member Functions inherited from APGUI::GUI_Item
GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
virtual void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | createModels (string basicModelString, string hullModelString)
bool | postInitialize (string name, string receiver, string label, string tooltip, string group, osg::Vec3 position)
last part of initialization process - common for both initialize() methods More...
void | switchVisuals ()
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
DECLARE_OUTPUT (GUIItemClicked, MessageString)
DECLARE_OUTPUT (ExternalDeactivation, MessageObjectID)
- Protected Member Functions inherited from APGUI::GUI_Item
osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

IconType _type
Type of this icon. More...
bool | _switchActive_CoreChange
Current state of icon. More...
bool | _externalDeactivation
osg::Switch * | _models
pointer to OGS Switch group, containing all models (loaded, or constructed) of GUI item More...
ItemsGroup * _group
osg::Vec3 | _initialScale
- Protected Attributes inherited from APGUI::GUI_Item
string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Icon.

Ability for simple adding button or switches to scene. Handle situations, when user point to Icon and click on Icon.

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

Icon::Icon ( )
Icon::~Icon ( )

Member Function Documentation

bool Icon::createModels | ( | string | basicModelString,
 |  | string | hullModelString
 | ) |  |
protected
APGUI::Icon::DECLARE_OUTPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected
APGUI::Icon::DECLARE_OUTPUT | ( | ExternalDeactivation | ,
 |  | MessageObjectID |
 | ) |  |
protected
bool APGUI::Icon::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Initialization of GUI item Called when Icon is defined in XML scene description

Warning
do NOT call this method, if you are creating GUI Items from code - use other initialization method (the one with more parameters)
Returns
successfulness of operation

Reimplemented from vrecko::BaseClass.

Reimplemented in APGUI::IconColour.

bool Icon::initialize | ( | string | name,
 |  | string | receiver,
 |  | string | label,
 |  | string | tooltip,
 |  | string | group,
 |  | osg::Vec3 | position = osg::Vec3()
 | ) |  |

Initialization of GUI item Called when Icon is defined from source code (not from XML)

Parameters
name | - unique identifier of GUI Item, required
receiver | - identifier of receiver (target) of this icon, required
label | - text shown somewhere near icon, optional
tooltip | - textual tooltip, shown after some hover time, optional
position | - relative position of icon to its parent environment object
Returns
successfulness of operation
void Icon::pointed ( bool pointed )
virtual

Called when user point with cursor (hand, usually) to this GUI element.

When pointed, GUI item can change its geometry (e.g. change color, switch to different model) as visual feedback to user

Parameters
pointed is true when user points on this item and false when user "unpoint" it.

Implements APGUI::GUI_Item.

bool Icon::postInitialize | ( | string | name,
 |  | string | receiver,
 |  | string | label,
 |  | string | tooltip,
 |  | string | group,
 |  | osg::Vec3 | position
 | ) |  |
protected

last part of initialization process - common for both initialize() methods

bool Icon::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
virtual

Called when user presses defined button.

Implements APGUI::GUI_Item.

Reimplemented in APGUI::IconColour.

void Icon::setPartColour | ( | string | partName,
 |  | osg::Vec4 | newColour
 | ) |  |
void Icon::setState ( GUI_ITEM_STATE newState )
virtual

Set state (active / inactive) of switch icon.

Parameters
active new state

Implements APGUI::GUI_Item.

void Icon::switchVisuals ( )
protected

Called, when visual models have to be switched (user pointed or clicked on some GUI item)

Member Data Documentation

bool APGUI::Icon::_externalDeactivation
protected
ItemsGroup* APGUI::Icon::_group
protected
osg::Vec3 APGUI::Icon::_initialScale
protected
osg::Switch* APGUI::Icon::_models
protected

pointer to OGS Switch group, containing all models (loaded, or constructed) of GUI item

bool APGUI::Icon::_switchActive_CoreChange
protected

Current state of icon.

will 'Hull' part of Icon change color when icon is active? default value = true. 'false' value can be useful for color pallete icons, e.g.

IconType APGUI::Icon::_type
protected

Type of this icon.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Icon.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Icon.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::IconColour Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • IconColour
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::IconColour Class Reference

Color Icon. More...

#include <IconColour.h>

Inheritance diagram for APGUI::IconColour:
APGUI::Icon APGUI::GUI_Item vrecko::Ability vrecko::BaseClass

Public Member Functions

IconColour ()
~IconColour ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
Called when user presses defined button. More...
- Public Member Functions inherited from APGUI::Icon
Icon ()
~Icon ()
bool | initialize (string name, string receiver, string label, string tooltip, string group, osg::Vec3 position=osg::Vec3())
void | pointed (bool pointed)
Called when user point with cursor (hand, usually) to this GUI element. More...
void | setState (GUI_ITEM_STATE newState)
Set state (active / inactive) of switch icon. More...
void | setPartColour (string partName, osg::Vec4 newColour)
- Public Member Functions inherited from APGUI::GUI_Item
GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
virtual void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (Colour, MessageVec4)
- Protected Member Functions inherited from APGUI::Icon
bool | createModels (string basicModelString, string hullModelString)
bool | postInitialize (string name, string receiver, string label, string tooltip, string group, osg::Vec3 position)
last part of initialization process - common for both initialize() methods More...
void | switchVisuals ()
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
DECLARE_OUTPUT (GUIItemClicked, MessageString)
DECLARE_OUTPUT (ExternalDeactivation, MessageObjectID)
- Protected Member Functions inherited from APGUI::GUI_Item
osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec4 | _colour
- Protected Attributes inherited from APGUI::Icon
IconType _type
Type of this icon. More...
bool | _switchActive_CoreChange
Current state of icon. More...
bool | _externalDeactivation
osg::Switch * | _models
pointer to OGS Switch group, containing all models (loaded, or constructed) of GUI item More...
ItemsGroup * _group
osg::Vec3 | _initialScale
- Protected Attributes inherited from APGUI::GUI_Item
string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Color Icon.

derived from Icon, adding Color information

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::IconColour::IconColour ( )
APGUI::IconColour::~IconColour ( )

Member Function Documentation

APGUI::IconColour::DECLARE_OUTPUT | ( | Colour | ,
 |  | MessageVec4 |
 | ) |  |
protected
bool APGUI::IconColour::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Initialization of GUI item Called when Icon is defined in XML scene description

Warning
do NOT call this method, if you are creating GUI Items from code - use other initialization method (the one with more parameters)
Returns
successfulness of operation

Reimplemented from APGUI::Icon.

bool APGUI::IconColour::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
virtual

Called when user presses defined button.

Reimplemented from APGUI::Icon.

Member Data Documentation

osg::Vec4 APGUI::IconColour::_colour
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/IconColour.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/IconColour.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::ItemsGroup Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • ItemsGroup
Public Member Functions | Protected Attributes | List of all members
APGUI::ItemsGroup Class Reference

Group of GUI Items. More...

#include <ItemsGroup.h>

Inheritance diagram for APGUI::ItemsGroup:

Public Member Functions

ItemsGroup (string name)
~ItemsGroup ()
string | getName ()
returns name of this Items group More...
void | addItem (GUI_Item *newItem)
add new item to group More...
void | reset ()
void | setActiveMember (GUI_Item *activeItem)

Protected Attributes

string | _name
std::vector< GUI_Item * > | _members

Detailed Description

Group of GUI Items.

FIXME for now - only Icons may be members of itemGroup

Can change states of its member members states may be (default state) mutually exclusive = only one group member can be active at time

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::ItemsGroup::ItemsGroup ( string name )
APGUI::ItemsGroup::~ItemsGroup ( )

Member Function Documentation

void APGUI::ItemsGroup::addItem ( GUI_Item * newItem )

add new item to group

string APGUI::ItemsGroup::getName ( void )
inline

returns name of this Items group

void APGUI::ItemsGroup::reset ( )
void APGUI::ItemsGroup::setActiveMember ( GUI_Item * activeItem )

Member Data Documentation

std::vector<GUI_Item *> APGUI::ItemsGroup::_members
protected
string APGUI::ItemsGroup::_name
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ItemsGroup.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/ItemsGroup.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::Layout Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Layout
Public Member Functions | Protected Attributes | List of all members
APGUI::Layout Class Reference

GUI Layout class. More...

#include <Layout.h>

Inheritance diagram for APGUI::Layout:

Public Member Functions

Layout ()
~Layout ()
void | addItem (GUI_Item *)
add item to this layout More...
void | removeItem (GUI_Item *)
add item to this layout More...
string | getName ()
returns name of this layout More...
void | show ()
show all layout items More...
void | hide ()
hide all layout items More...
bool | loadfromXMLnode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
parse and load item from XML based parameters node More...
bool | initialize (string name, std::vector< string > *items)
void | actualize (GuiItemMapType *map)
actualize layout More...

Protected Attributes

std::string | _name
name of this layout More...
std::vector< string > | _itemsNames
list of layout items names More...
std::vector< GUI_Item * > | _items
list of layout items pointers More...

Detailed Description

GUI Layout class.

Serves as named group of GUI items, that can be easily shown / hide Each GUI element may be part of none, one or more layouts. In GUI controller, there can be arbitrary number of layouts defined.

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::Layout::Layout ( )
APGUI::Layout::~Layout ( )

Member Function Documentation

void APGUI::Layout::actualize ( GuiItemMapType * map )

actualize layout

clear old list of pointer to GUI items for each item-name on list of names, check if such GUI item exist and add it to list of layout items

Parameters
map map of actual GUI controller registered items
void APGUI::Layout::addItem ( GUI_Item * )

add item to this layout

string APGUI::Layout::getName ( void )
inline

returns name of this layout

void APGUI::Layout::hide ( )

hide all layout items

bool APGUI::Layout::initialize | ( | string | name,
 |  | std::vector< string > * | items
 | ) |  |
bool APGUI::Layout::loadfromXMLnode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )

parse and load item from XML based parameters node

Parameters
pParametersNode pointer to parameters node
Returns
successfulness of operation
void APGUI::Layout::removeItem ( GUI_Item * )

add item to this layout

void APGUI::Layout::show ( )

show all layout items

Member Data Documentation

std::vector<GUI_Item *> APGUI::Layout::_items
protected

list of layout items pointers

std::vector<string> APGUI::Layout::_itemsNames
protected

list of layout items names

std::string APGUI::Layout::_name
protected

name of this layout

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Layout.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Layout.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::Menu Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Menu
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::Menu Class Reference

Menu. More...

#include <Menu.h>

Inheritance diagram for APGUI::Menu:
APGUI::GUI_Item vrecko::Ability vrecko::BaseClass

Public Member Functions

Menu ()
~Menu ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
bool | initialize (string name, string receiver, int sensor, string label="", string tooltip="", bool pointable=true)
void | pointed (bool pointed)
Called when user point with cursor (hand, usually) to this GUI element. More...
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
Called when user presses defined button. More...
void | setState (GUI_ITEM_STATE newState)
Set new state of item. More...
- Public Member Functions inherited from APGUI::GUI_Item
GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
virtual void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | postInitialize (string name, string receiver, int sensorNumber, string label, string tooltip)
last part of initialization process - common for both initialize() methods More...
DECLARE_INPUT (HidingMenu, MessageBool)
DECLARE_OUTPUT (CreateMenuStructure, MessageInt)
DECLARE_OUTPUT (ButtonPress, MessageBool)
DECLARE_REQUEST_OUTPUT (ActivePointerID, MessageInt, MessageInt)
- Protected Member Functions inherited from APGUI::GUI_Item
osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

int | _activeSensor
index of sensor to which this menu will respond More...
bool | _opened
flag, if menu is actualy opened More...
vrecko::Ability * _dynamicMenuAbility
Pointer to Menu::DynamicMenu ability. More...
- Protected Attributes inherited from APGUI::GUI_Item
string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Menu.

For now, just "connector", it connects GUI functionality with existing Menu plug-in

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::Menu::Menu ( )
APGUI::Menu::~Menu ( )

Member Function Documentation

APGUI::Menu::DECLARE_INPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::Menu::DECLARE_OUTPUT | ( | CreateMenuStructure | ,
 |  | MessageInt |
 | ) |  |
protected
APGUI::Menu::DECLARE_OUTPUT | ( | ButtonPress | ,
 |  | MessageBool |
 | ) |  |
protected
APGUI::Menu::DECLARE_REQUEST_OUTPUT | ( | ActivePointerID | ,
 |  | MessageInt | ,
 |  | MessageInt |
 | ) |  |
protected
bool APGUI::Menu::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Initialization of GUI item Called when Icon is defined in XML scene description

Warning
do NOT call this method, if you are creating GUI Items from code - use other initialization method (the one with more parameters)
Returns
successfulness of operation

Reimplemented from vrecko::BaseClass.

bool APGUI::Menu::initialize | ( | string | name,
 |  | string | receiver,
 |  | int | sensor,
 |  | string | label = "",
 |  | string | tooltip = "",
 |  | bool | pointable = true
 | ) |  |

Initialization of GUI item - Menu Called when Icon is defined from source code (not from XML)

Parameters
name | - unique identifier of GUI Item. Required
receiver | - identifier of receiver (target) of this icon. Required
sensor | - to which sensor will menu respond. Other will be ignored. Required
label | - text shown somewhere near icon. Optional
tooltip | - textual tooltip, shown after some hover time. Optional
Returns
successfulness of operation
void APGUI::Menu::pointed ( bool pointed )
inlinevirtual

Called when user point with cursor (hand, usually) to this GUI element.

When pointed, GUI item can change its geometry (e.g. change color, switch to different model) as visual feedback to user

Parameters
pointed is true when user points on this item and false when user "unpoint" it.

Implements APGUI::GUI_Item.

bool APGUI::Menu::postInitialize | ( | string | name,
 |  | string | receiver,
 |  | int | sensorNumber,
 |  | string | label,
 |  | string | tooltip
 | ) |  |
protected

last part of initialization process - common for both initialize() methods

bool APGUI::Menu::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
virtual

Called when user presses defined button.

Implements APGUI::GUI_Item.

void APGUI::Menu::setState ( GUI_ITEM_STATE newState )
virtual

Set new state of item.

Implements APGUI::GUI_Item.

Member Data Documentation

int APGUI::Menu::_activeSensor
protected

index of sensor to which this menu will respond

vrecko::Ability* APGUI::Menu::_dynamicMenuAbility
protected

Pointer to Menu::DynamicMenu ability.

bool APGUI::Menu::_opened
protected

flag, if menu is actualy opened

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Menu.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APGUI::Slider Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Slider
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APGUI::Slider Class Reference

Slider GUI item. More...

#include <Slider.h>

Inheritance diagram for APGUI::Slider:
APGUI::GUI_Item vrecko::Ability vrecko::BaseClass

Public Member Functions

Slider ()
~Slider ()
bool | createModels (string geometryType)
bool | initialize (string name, string receiver, string label, string tooltip, osg::Vec3 position=osg::Vec3())
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
osg::ref_ptr< GUI_Text > | getText ()
double | getValue ()
bool | processAction (const int sensorNumber, const GUI_ACTION action, const bool pressed)
Called when user presses (or releases0 defined button. More...
virtual void | pointed (bool pointed)
Called when user point slider. More...
void | setColours (osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled)
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
void | setSliderParameters (double width, double heigh, double minValue, double MaxValue, double step)
void | setState (GUI_ITEM_STATE newState)
Set new state of item. More...
void | setValue (double value)
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from APGUI::GUI_Item
GUI_Item (const char *abName)
~GUI_Item ()
string | getGUIItemName ()
bool | isDefaultStateActive ()
returns if initial state of this item is active (false in most cases) More...
void | show ()
void | hide ()
void | hideTooltip ()
void | showTooltip ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | createGeometry ()
void | setAndSendValue (double value)
void | sendValue (double value)
void | switchVisuals ()
Called, when visual models have to be switched (user pointed or clicked on some GUI item) More...
void | updateSlider (osg::Vec3 handPosition)
osg::Vec3 | transformHandPosition (osg::Vec3 &handPosition)
int | Slider::intersectSegmentandPlane (osg::Vec3 point0, osg::Vec3 point1, osg::Vec3 planeNormal, osg::Vec3 planePoint, osg::Vec3 *resultPoint)
bool | postInitialize (string name, string receiver, string label, string tooltip, osg::Vec3 position)
last part of initialization process - common for both initialize() methods More...
DECLARE_INPUT (SliderValue, MessageFloat)
DECLARE_OUTPUT (GUIItemClicked, MessageString)
DECLARE_REQUEST_OUTPUT (SensorPosition, MessageInt, MessageVec3)
void | processInputPosition (int sensor_num, osg::Vec3 pos)
- Protected Member Functions inherited from APGUI::GUI_Item
osgText::Text * | GUI_Item::createLabel ()
bool | initialize (bool pointable=true, int sensor=-1)
basic initialization - common for all GUI Item types More...
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

int | _sensorNumber
number of sensor actually working with More...
double | _oldValue
double | _minimumValue
double | _maximumValue
double | _step
double | _width
width of slider More...
double | _height
osg::ref_ptr< osg::Switch > | _staticModel
osg::ref_ptr
< osg::MatrixTransform > 		_movableTransform
osg::ref_ptr< osg::Switch > | _movableModel
osg::ref_ptr< GUI_Text > | _text
- Protected Attributes inherited from APGUI::GUI_Item
string | _name
Identification of this GUI item. More...
string | _receiver
name of target object or ability More...
GUI_ITEM_STATE _state
state of item - default, active, disabled, ... More...
GUI_Controller * _controller
pointer to GUI controller More...
osg::Group * | _texts
osg::ref_ptr< GUI_Text > | _label
Label - just a static label of Item. More...
osg::ref_ptr< GUI_Text > | _toolTip
Tooltip - appears, when user hover with pointer over item for some time. Controller controls showing and hiding of tooltip. More...
EnvironmentObject * _parent
Pointer to parent object. More...
int | _sensorNumber
index of input device, that currently pressed GUI item More...
osg::ref_ptr
< osg::MatrixTransform > 		_itemTransform
transformation node of GUI item - mainly for setting position of GUI Item relatively to the parent Environment Object More...
int | _pointedCounter
How many sensors is pointing to this GUI Item. More...
bool | _pressed
True, when user holds GUI-interaction button pressed, pointing on this GUI item. More...
bool | _defaultStateActive
flag, if this item should be in 'active' state after startup / reset More...
osg::Vec4 | _colourActive
osg::Vec4 | _colourDefault
osg::Vec4 | _colourHovered
osg::Vec4 | _colourPressed
osg::Vec4 | _colourDisabled
std::vector< Interconnection * > | _interconnections
list of all created interconnections, More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Slider GUI item.

Ability for slider functionality to scene. Handle situations, when user point to slider and change slider value. Ability should be added as child to EO with some geometry.

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APGUI::Slider::Slider ( )
APGUI::Slider::~Slider ( )

Member Function Documentation

void APGUI::Slider::createGeometry ( )
protected
bool APGUI::Slider::createModels ( string geometryType )
APGUI::Slider::DECLARE_INPUT | ( | SliderValue | ,
 |  | MessageFloat |
 | ) |  |
protected
APGUI::Slider::DECLARE_OUTPUT | ( | GUIItemClicked | ,
 |  | MessageString |
 | ) |  |
protected
APGUI::Slider::DECLARE_REQUEST_OUTPUT | ( | SensorPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
osg::ref_ptr<GUI_Text> APGUI::Slider::getText ( )
inline
double APGUI::Slider::getValue ( )
inline
bool APGUI::Slider::initialize | ( | string | name,
 |  | string | receiver,
 |  | string | label,
 |  | string | tooltip,
 |  | osg::Vec3 | position = osg::Vec3()
 | ) |  |

Initialization of GUI item Called when Icon is defined from source code (not from XML)

Parameters
name | - unique identifier of GUI Item, required
receiver | - identifier of receiver (target) of this icon, required
label | - text shown somewhere near icon, optional
tooltip | - textual tooltip, shown after some hover time, optional
position | - relative position of icon to its parent environment object
Returns
successfulness of operation
bool APGUI::Slider::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Initialization of GUI item Called when Icon is defined in XML scene description

Warning
do NOT call this method, if you are creating GUI Items from code - use other initialization method (the one with more parameters)
Returns
successfulness of operation

Reimplemented from vrecko::BaseClass.

void APGUI::Slider::pointed ( bool pointed )
virtual

Called when user point slider.

Implements APGUI::GUI_Item.

bool APGUI::Slider::postInitialize | ( | string | name,
 |  | string | receiver,
 |  | string | label,
 |  | string | tooltip,
 |  | osg::Vec3 | position
 | ) |  |
protected

last part of initialization process - common for both initialize() methods

bool APGUI::Slider::processAction | ( | const int | sensorNumber,
 |  | const GUI_ACTION | action,
 |  | const bool | pressed
 | ) |  |
virtual

Called when user presses (or releases0 defined button.

Implements APGUI::GUI_Item.

void APGUI::Slider::processInputPosition | ( | int | sensor_num,
 |  | osg::Vec3 | pos
 | ) |  |
protected
void APGUI::Slider::sendValue ( double value )
protected
void APGUI::Slider::setAndSendValue ( double value )
protected
void APGUI::Slider::setColours | ( | osg::Vec4 | colourActive,
 |  | osg::Vec4 | colourDefault,
 |  | osg::Vec4 | colourHovered,
 |  | osg::Vec4 | colourPressed,
 |  | osg::Vec4 | colourDisabled
 | ) |  |
virtual

Called, when visual models have to be switched (user pointed or clicked on some GUI item)

Reimplemented from APGUI::GUI_Item.

void APGUI::Slider::setSliderParameters | ( | double | width,
 |  | double | heigh,
 |  | double | minValue,
 |  | double | MaxValue,
 |  | double | step
 | ) |  |
void APGUI::Slider::setState ( GUI_ITEM_STATE newState )
virtual

Set new state of item.

Implements APGUI::GUI_Item.

void APGUI::Slider::setValue ( double value )
int APGUI::Slider::Slider::intersectSegmentandPlane | ( | osg::Vec3 | point0,
 |  | osg::Vec3 | point1,
 |  | osg::Vec3 | planeNormal,
 |  | osg::Vec3 | planePoint,
 |  | osg::Vec3 * | resultPoint
 | ) |  |
protected
void APGUI::Slider::switchVisuals ( )
protected

Called, when visual models have to be switched (user pointed or clicked on some GUI item)

osg::Vec3 APGUI::Slider::transformHandPosition ( osg::Vec3 & handPosition )
protected
void APGUI::Slider::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void APGUI::Slider::updateSlider ( osg::Vec3 handPosition )
protected

Member Data Documentation

double APGUI::Slider::_height
protected
double APGUI::Slider::_maximumValue
protected
double APGUI::Slider::_minimumValue
protected
osg::ref_ptr<osg::Switch> APGUI::Slider::_movableModel
protected
osg::ref_ptr<osg::MatrixTransform> APGUI::Slider::_movableTransform
protected
double APGUI::Slider::_oldValue
protected
int APGUI::Slider::_sensorNumber
protected

number of sensor actually working with

osg::ref_ptr<osg::Switch> APGUI::Slider::_staticModel
protected
double APGUI::Slider::_step
protected
osg::ref_ptr<GUI_Text> APGUI::Slider::_text
protected
double APGUI::Slider::_width
protected

width of slider

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Slider.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Slider.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APHelloWorld::MyAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHelloWorld
  • MyAbility
Public Member Functions | List of all members
APHelloWorld::MyAbility Class Reference

#include <MyAbility.h>

Inheritance diagram for APHelloWorld::MyAbility:
vrecko::Ability vrecko::BaseClass

Public Member Functions

MyAbility ()
~MyAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

MyAbility::MyAbility ( )
MyAbility::~MyAbility ( )

Member Function Documentation

bool MyAbility::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void MyAbility::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld/MyAbility.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HelloWorld/MyAbility.cpp
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APHUD::HUDColorProfile Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDColorProfile
Public Attributes | List of all members
APHUD::HUDColorProfile Struct Reference

#include <HUDDisplay.h>

Public Attributes

osg::Vec4f | backgroundColor
osg::Vec4f | fontColor
osg::Vec4f | gradientStartColor
osg::Vec4f | gradientEndColor

Detailed Description

definition of a color profile that may be instantly set

Member Data Documentation

osg::Vec4f APHUD::HUDColorProfile::backgroundColor

Color of background of whole window

osg::Vec4f APHUD::HUDColorProfile::fontColor

Color of font

osg::Vec4f APHUD::HUDColorProfile::gradientEndColor

Color of gradient rectangle when the value is set to maximum

osg::Vec4f APHUD::HUDColorProfile::gradientStartColor

Color of gradient rectangle when the value is set to minimum

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: APHUD::HUDField Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDField
Public Attributes | List of all members
APHUD::HUDField Struct Reference

#include <HUDDisplay.h>

Public Attributes

osg::ref_ptr< osgText::Text > | text
osg::ref_ptr< osg::Geometry > | geometry
osg::Vec4f | color
string | name
string | actual_string
int | posX
int | posY
bool | animated
float | actualValue
float | maxValue
float | minValue
osg::Vec4f | colorMin
osg::Vec4f | colorMax

Detailed Description

definition of a hud field

Member Data Documentation

string APHUD::HUDField::actual_string

the text which is shown

float APHUD::HUDField::actualValue

Value of the field

bool APHUD::HUDField::animated

denotes whether the field has animated gradient background

osg::Vec4f APHUD::HUDField::color

Color of the field background

osg::Vec4f APHUD::HUDField::colorMax

Color of gradient rectangle when the value is set to maximum

osg::Vec4f APHUD::HUDField::colorMin

Color of gradient rectangle when the value is set to minimal

osg::ref_ptr<osg::Geometry> APHUD::HUDField::geometry
float APHUD::HUDField::maxValue

Maximal allowed value of the field

float APHUD::HUDField::minValue

Minimal allowed value of the field

string APHUD::HUDField::name

name of the field (ised as ID)

int APHUD::HUDField::posX
int APHUD::HUDField::posY

position X and Y in the window

osg::ref_ptr<osgText::Text> APHUD::HUDField::text
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APHUD::HUDWindow Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDWindow
Public Attributes | List of all members
APHUD::HUDWindow Struct Reference

#include <HUDDisplay.h>

Public Attributes

osg::ref_ptr< osg::Geometry > | geometry
string | name
int | sizeX
int | sizeY
int | posX
int | posY
osg::Vec4f | color
bool | visible
list< HUDField > | fields

Detailed Description

definition of a window struct. It holds an list of a hudFields

Member Data Documentation

osg::Vec4f APHUD::HUDWindow::color

Background color

list<HUDField> APHUD::HUDWindow::fields

list of HUDField

osg::ref_ptr<osg::Geometry> APHUD::HUDWindow::geometry
string APHUD::HUDWindow::name

Name of the window (serve as ID)

int APHUD::HUDWindow::posX
int APHUD::HUDWindow::posY

Sizes and positions of the field

int APHUD::HUDWindow::sizeX
int APHUD::HUDWindow::sizeY
bool APHUD::HUDWindow::visible

Denotes whether the field is visible

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APHUD::HUDDisplay Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDDisplay
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APHUD::HUDDisplay Class Reference

#include <HUDDisplay.h>

Inheritance diagram for APHUD::HUDDisplay:
vrecko::Ability vrecko::BaseClass

Public Member Functions

HUDDisplay ()
~HUDDisplay ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | addWindow (string plugin_name)
bool | updateWindowColor (string plugin_name, osg::Vec4f color)
bool | addField (string field_name, string plugin_name)
bool | updateFieldTextColor (string field_name, string plugin_name, osg::Vec4f color)
bool | setFieldAsAnimated (string field_name, string plugin_name, bool value)
bool | updateGradient (string field_name, string plugin_name, osg::Vec4f startColor, osg::Vec4f endColor)
bool | updateValuesRange (string field_name, string plugin_name, float minValue, float maxValue)
bool | removeWindow (string plugin_name)
bool | removeField (string field_name, string plugin_name)
bool | clearValue (string field_name, string plugin_name)
bool | updateText (string text, string field_name, string plugin_name)
bool | updateValue (float value, string field_name, string plugin_name)
bool | setColorProfileforWindow (string plugin_name, int colorprofile)
float | getActualValue (string field_name, string plugin_name)
bool | hudWindowExist (string plugin_name)
bool | hudFieldExist (string field_name, string plugin_name)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

list< HUDWindow >::iterator | getHUDWindow (string plugin_name)
list< HUDField >::iterator | getHUDField (string field_name, string plugin_name)
bool | correctName (string name)
bool | setValue (string text, string field_name, string plugin_name)
void | updateAllWindowsPositions ()
void | updateAllWindows ()
void | updateWindowSizeX (string plugin_name)
void | updateWindow (string plugin_name)
void | updateFieldsPosition (string plugin_name)
void | updateFields (string plugin_name)
void | updateField (string field_name, string plugin_name)
void | updateAllFields ()
void | updateAllFieldsPosition ()
void | removeAllFields (string plugin_name)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::ref_ptr< osg::Camera > | camera
osg::ref_ptr
< vrecko::EnvironmentObject > 		eo
osg::ref_ptr< osg::Geode > | geode
osg::ref_ptr< osg::StateSet > | stateSet
vrecko::ViewerBase * viewer
list< HUDWindow > | hudWindows
int | viewWidth
int | viewHeight
int | windowDefaultColorR
int | windowDefaultColorG
int | windowDefaultColorB
int | windowDefaultColorA
int | windowTabVertical
int | windowTabHorizontal
int | startWindowWidth
int | startWindowHeight
int | HUDDepthWindow
int | HUDDepthField
int | HUDDepthFieldBackground
int | HUDDivision
int | fieldDefaultColorR
int | fieldDefaultColorG
int | fieldDefaultColorB
int | fieldDefaultColorA
int | fieldTabVertical
int | fieldTabHorizontal
int | fieldSizeVertical
int | definedcolorprofiles
HUDColorProfile | cProfiles [10]
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APHUD::HUDDisplay::HUDDisplay ( )
APHUD::HUDDisplay::~HUDDisplay ( )
inline

Member Function Documentation

bool APHUD::HUDDisplay::addField | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |

Add a field to window

bool APHUD::HUDDisplay::addWindow ( string plugin_name )

Adds window into a hud.

bool APHUD::HUDDisplay::clearValue | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |

clears the value of a field (set it to a minValue)

bool APHUD::HUDDisplay::correctName ( string name )
protected

return TRUE if the specific given Name is Acceptable

float APHUD::HUDDisplay::getActualValue | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |

DO NOT USE THIS FOR DATA EXCHANGE BERTWEEN MODULES !!!! (It's extremly slow.)returns an actualValue of a field name

list< HUDField >::iterator APHUD::HUDDisplay::getHUDField | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |
protected

returns an iterator for a field with specific name (ID) in a window with specific name

list< HUDWindow >::iterator APHUD::HUDDisplay::getHUDWindow ( string plugin_name )
protected

returns an iterator for a window with specific name (ID)

bool APHUD::HUDDisplay::hudFieldExist | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |

return TRUE if the field in a window exists, vice versa

bool APHUD::HUDDisplay::hudWindowExist ( string plugin_name )

returns TRUE if window exists, vice versa

bool APHUD::HUDDisplay::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APHUD::HUDDisplay::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APHUD::HUDDisplay::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APHUD::HUDDisplay::removeAllFields ( string plugin_name )
protected

remove all fields in a given window

bool APHUD::HUDDisplay::removeField | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |

removes field from window

bool APHUD::HUDDisplay::removeWindow ( string plugin_name )

removes window from hud (with all it's fields)

bool APHUD::HUDDisplay::setColorProfileforWindow | ( | string | plugin_name,
 |  | int | colorprofile
 | ) |  |

sets a complete color profile for a window (values 1-10)

bool APHUD::HUDDisplay::setFieldAsAnimated | ( | string | field_name,
 |  | string | plugin_name,
 |  | bool | value
 | ) |  |

set whether the field behind a text shoud appear or not.

bool APHUD::HUDDisplay::setValue | ( | string | text,
 |  | string | field_name,
 |  | string | plugin_name
 | ) |  |
protected

not checked function may not be called from outside. Sets a Value to a Field

void APHUD::HUDDisplay::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void APHUD::HUDDisplay::updateAllFields ( )
protected

update and redraw all fields in all windows

void APHUD::HUDDisplay::updateAllFieldsPosition ( )
protected

update all fields in a all windows

void APHUD::HUDDisplay::updateAllWindows ( )
protected

updats positions and redraw all windows

void APHUD::HUDDisplay::updateAllWindowsPositions ( )
protected

updates position values of all windows

void APHUD::HUDDisplay::updateField | ( | string | field_name,
 |  | string | plugin_name
 | ) |  |
protected

update field with given name

void APHUD::HUDDisplay::updateFields ( string plugin_name )
protected

update all fields in a window

void APHUD::HUDDisplay::updateFieldsPosition ( string plugin_name )
protected

updates position of a field in a window

bool APHUD::HUDDisplay::updateFieldTextColor | ( | string | field_name,
 |  | string | plugin_name,
 |  | osg::Vec4f | color
 | ) |  |

Set a color of the fieldText

bool APHUD::HUDDisplay::updateGradient | ( | string | field_name,
 |  | string | plugin_name,
 |  | osg::Vec4f | startColor,
 |  | osg::Vec4f | endColor
 | ) |  |

set the colors for minValue(Start) and maxValue (EndColor)

bool APHUD::HUDDisplay::updateText | ( | string | text,
 |  | string | field_name,
 |  | string | plugin_name
 | ) |  |

set the text value to a field (actual value is set to maxValue)

bool APHUD::HUDDisplay::updateValue | ( | float | value,
 |  | string | field_name,
 |  | string | plugin_name
 | ) |  |

set the actualValue of a field

bool APHUD::HUDDisplay::updateValuesRange | ( | string | field_name,
 |  | string | plugin_name,
 |  | float | minValue,
 |  | float | maxValue
 | ) |  |

sets the boundaries for value

void APHUD::HUDDisplay::updateWindow ( string plugin_name )
protected

updates position of window and redraws

bool APHUD::HUDDisplay::updateWindowColor | ( | string | plugin_name,
 |  | osg::Vec4f | color
 | ) |  |

Sets the color of window

void APHUD::HUDDisplay::updateWindowSizeX ( string plugin_name )
protected

computes and save vertical size of a window

Member Data Documentation

osg::ref_ptr<osg::Camera> APHUD::HUDDisplay::camera
protected

OverView of a system work.

world -> camera -> eo -> geode -> (multiplae objects inside (Geometry, Geometru, Text))Camera used for rendering HUD

HUDColorProfile APHUD::HUDDisplay::cProfiles[10]
protected

field of color profiles

int APHUD::HUDDisplay::definedcolorprofiles
protected

defined number of color profiles

osg::ref_ptr<vrecko::EnvironmentObject> APHUD::HUDDisplay::eo
protected

environment object where to put all objects to render in HUD

int APHUD::HUDDisplay::fieldDefaultColorA
protected

default settting of A channel for field text color

int APHUD::HUDDisplay::fieldDefaultColorB
protected

default settting of B channel for field text color

int APHUD::HUDDisplay::fieldDefaultColorG
protected

default settting of G channel for field text color

int APHUD::HUDDisplay::fieldDefaultColorR
protected

default settting of R channel for field text color

int APHUD::HUDDisplay::fieldSizeVertical
protected

size of a field fertical in pixels

int APHUD::HUDDisplay::fieldTabHorizontal
protected

spaces between fields and field and windows vertical

int APHUD::HUDDisplay::fieldTabVertical
protected

spaces between fields and field and windows vertical

osg::ref_ptr<osg::Geode> APHUD::HUDDisplay::geode
protected

Geode where to store all

int APHUD::HUDDisplay::HUDDepthField
protected

depth values of field (-1000 = background, -1 foreground)

int APHUD::HUDDisplay::HUDDepthFieldBackground
protected

depth values of field background (-1000 = background, -1 foreground)

int APHUD::HUDDisplay::HUDDepthWindow
protected

depth values of window (-1000 = background, -1 foreground)

int APHUD::HUDDisplay::HUDDivision
protected

maximum allowed huds Windows at a time

list<HUDWindow> APHUD::HUDDisplay::hudWindows
protected

List of all windows

int APHUD::HUDDisplay::startWindowHeight
protected

default height of windows

int APHUD::HUDDisplay::startWindowWidth
protected

default width of windows

osg::ref_ptr<osg::StateSet> APHUD::HUDDisplay::stateSet
protected
vrecko::ViewerBase* APHUD::HUDDisplay::viewer
protected

Viewer that has the camera

int APHUD::HUDDisplay::viewHeight
protected

known height of viewer in pixels

int APHUD::HUDDisplay::viewWidth
protected

known width of viewer in pixels

int APHUD::HUDDisplay::windowDefaultColorA
protected

default settings of A channel for color

int APHUD::HUDDisplay::windowDefaultColorB
protected

default settings of B channel for color

int APHUD::HUDDisplay::windowDefaultColorG
protected

default settings of G channel for color

int APHUD::HUDDisplay::windowDefaultColorR
protected

default settings of R channel for color

int APHUD::HUDDisplay::windowTabHorizontal
protected

default space between windows horizontal

int APHUD::HUDDisplay::windowTabVertical
protected

default space between windows vertical

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HUD/HUDDisplay.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APInputConnector::InputConnector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APInputConnector
  • InputConnector
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APInputConnector::InputConnector Class Reference

Input Connector class. More...

#include <InputConnector.h>

Inheritance diagram for APInputConnector::InputConnector:
vrecko::Ability vrecko::BaseClass

Public Member Functions

InputConnector ()
~InputConnector ()
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
Core initialization. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *value)
Processing of all incoming events. More...
void | processAction (int sensorNumber, VreckoMessage *value, const std::string &input_name)
void | ProcessOrientation (int sensorNumber, VreckoMessage *value, const std::string &input_name)
void | processSensorTransformation (int sensorNumber, VreckoMessage *value, const std::string &input_name)
void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static int | parseSensorNumber (const std::string &input_name)
parse number from input name More...
static std::string | parseEventName (const std::string &input_name)
parse event name from input name More...

Protected Member Functions

bool | parseInputDevice (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode)
parse one device - load parameters from XML More...
bool | parseInputMappingPair (string deviceID, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode)
parse one mapping pair More...
bool | parseSenderReceiver (std::string sr, bool isSender, BaseClass **pEntity, bool bNoErrorOutput)
std::vector
< XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * > * 		getChildNodesbyName (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, const string childNodeName)
returns all child with given name More...
bool | parseReceiverAbility (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ChainPairNode)
bool | parseOutputMappingPair (vrecko::Ability *receiverAbility, std::string receiverString, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode)
bool | processChainofResponsibility (ReceiversList *receivers, MessageBool *value)
DECLARE_OUTPUT (Sensor_0_position, MessageVec3)
DECLARE_OUTPUT (Sensor_0_orientation, MessageQuat)
DECLARE_OUTPUT (Sensor_1_position, MessageVec3)
DECLARE_OUTPUT (Sensor_1_orientation, MessageQuat)
DECLARE_REQUEST_INPUT (SensorPosition, MessageInt, MessageVec3)
DECLARE_REQUEST_INPUT (SensorOrientation, MessageInt, MessageQuat)
DECLARE_REQUEST_INPUT (SensorTransformation, MessageInt, MessageSensorTransformation)
DECLARE_REQUEST_INPUT (MenuSensorPosition, MessageInt, MessageVec3)
DECLARE_REQUEST_INPUT (SelectedObjectID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionByPointerPos, MessageVec3, MessageObjectID)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _lastKnownPositions [SENSOR_MAX_COUNT]
osg::Quat | _lastKnownOrientations [SENSOR_MAX_COUNT]
unsigned int | _lastKnownPointedObjects [SENSOR_MAX_COUNT]
osg::Vec3 | _lastCheckedPositions [SENSOR_MAX_COUNT]
std::map< string, string > | _actionMap
std::map< string, ReceiversList * > | _outputMappingsWithPriorities
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Input Connector class.

Connector between input devices (Optitrack, Kinect, mouse, 3Dmouse, ...) and other VRECKO abilities Should simplify communication between VRECKO parts Manage chain of responsibilities - who will receive (and parse) message first, who (if) next, ...

Author
Jiri Chmelik
Date
2011

Constructor & Destructor Documentation

APInputConnector::InputConnector::InputConnector ( )
APInputConnector::InputConnector::~InputConnector ( )

Member Function Documentation

APInputConnector::InputConnector::DECLARE_OUTPUT | ( | Sensor_0_position | ,
 |  | MessageVec3 |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_OUTPUT | ( | Sensor_0_orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_OUTPUT | ( | Sensor_1_position | ,
 |  | MessageVec3 |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_OUTPUT | ( | Sensor_1_orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_INPUT | ( | SensorPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_INPUT | ( | SensorOrientation | ,
 |  | MessageInt | ,
 |  | MessageQuat |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_INPUT | ( | SensorTransformation | ,
 |  | MessageInt | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_INPUT | ( | MenuSensorPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_INPUT | ( | SelectedObjectID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
APInputConnector::InputConnector::DECLARE_REQUEST_OUTPUT | ( | SelectionByPointerPos | ,
 |  | MessageVec3 | ,
 |  | MessageObjectID |
 | ) |  |
protected
std::vector< XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * > * APInputConnector::InputConnector::getChildNodesbyName | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parentNode,
 |  | const string | childNodeName
 | ) |  |
protected

returns all child with given name

Only level 1 parsing

Parameters
parentNode | parent node
childNodeName | name of search node
Returns
vector of all child nodes with given name
bool APInputConnector::InputConnector::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

std::string APInputConnector::InputConnector::parseEventName ( const std::string & input_name )
static

parse event name from input name

bool APInputConnector::InputConnector::parseInputDevice ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * deviceNode )
protected

parse one device - load parameters from XML

process all mapping pairs

Parameters
deviceNode node containing informations about one input device
Returns
successfulness of operation
bool APInputConnector::InputConnector::parseInputMappingPair | ( | string | deviceID,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pairNode
 | ) |  |
protected

parse one mapping pair

Reads data from given node, parses it, creates input and output pins, interconnections

Parameters
pairNode node containing informations about one mapping pair
Returns
successfulness of operation
bool APInputConnector::InputConnector::parseOutputMappingPair | ( | vrecko::Ability * | receiverAbility,
 |  | std::string | receiverString,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pairNode
 | ) |  |
protected
bool APInputConnector::InputConnector::parseReceiverAbility ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ChainPairNode )
protected
bool APInputConnector::InputConnector::parseSenderReceiver | ( | std::string | sr,
 |  | bool | isSender,
 |  | BaseClass ** | pEntity,
 |  | bool | bNoErrorOutput
 | ) |  |
protected
int APInputConnector::InputConnector::parseSensorNumber ( const std::string & input_name )
static

parse number from input name

void APInputConnector::InputConnector::processAction | ( | int | sensorNumber,
 |  | VreckoMessage * | value,
 |  | const std::string & | input_name
 | ) |  |
bool APInputConnector::InputConnector::processChainofResponsibility | ( | ReceiversList * | receivers,
 |  | MessageBool * | value
 | ) |  |
protected
void APInputConnector::InputConnector::processEvent | ( | const std::string & | input_name,
 |  | VreckoMessage * | value
 | ) |  |
virtual

Processing of all incoming events.

Reimplemented from vrecko::BaseClass.

void APInputConnector::InputConnector::ProcessOrientation | ( | int | sensorNumber,
 |  | VreckoMessage * | value,
 |  | const std::string & | input_name
 | ) |  |
void APInputConnector::InputConnector::processSensorTransformation | ( | int | sensorNumber,
 |  | VreckoMessage * | value,
 |  | const std::string & | input_name
 | ) |  |
void APInputConnector::InputConnector::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

std::map<string, string> APInputConnector::InputConnector::_actionMap
protected
osg::Vec3 APInputConnector::InputConnector::_lastCheckedPositions[SENSOR_MAX_COUNT]
protected
osg::Quat APInputConnector::InputConnector::_lastKnownOrientations[SENSOR_MAX_COUNT]
protected
unsigned int APInputConnector::InputConnector::_lastKnownPointedObjects[SENSOR_MAX_COUNT]
protected
osg::Vec3 APInputConnector::InputConnector::_lastKnownPositions[SENSOR_MAX_COUNT]
protected
std::map<string, ReceiversList *> APInputConnector::InputConnector::_outputMappingsWithPriorities
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/InputConnector.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/InputConnector.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APLightsEditor::_Light Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • _Light
Public Member Functions | Public Attributes | List of all members
APLightsEditor::_Light Struct Reference

#include <Editor.h>

Public Member Functions

_Light (EnvironmentObject *eoPtr, int lightID, EnvironmentObject *eoSpotPtr=NULL)

Public Attributes

int _lightID
EnvironmentObject * _eoPtr
EnvironmentObject * _eoSpotPtr

Constructor & Destructor Documentation

APLightsEditor::_Light::_Light | ( | EnvironmentObject * | eoPtr,
 |  | int | lightID,
 |  | EnvironmentObject * | eoSpotPtr = NULL
 | ) |  |
inline

Member Data Documentation

EnvironmentObject* APLightsEditor::_Light::_eoPtr
EnvironmentObject* APLightsEditor::_Light::_eoSpotPtr
int APLightsEditor::_Light::_lightID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Editor.h
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APLightsEditor::Editor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • Editor
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APLightsEditor::Editor Class Reference

#include <Editor.h>

Inheritance diagram for APLightsEditor::Editor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

Editor ()
virtual | ~Editor ()
void | update (void)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | makeMenu ()
void | saveToXML (const char *FileName)
EnvironmentObject * | DrawPoint (osg::Vec3 position, float pointRadius, osg::Vec4 pointColor)
virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode=NULL)
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

Lights * lightManager
std::vector< _Light > | lightMarker
int | actLightID
int | sunID
Lights::shadingModes shadeMode
Lights::shadowModes shadowMode
Lights::giModes giMode
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APLightsEditor::Editor::Editor ( )
APLightsEditor::Editor::~Editor ( )
virtual

Member Function Documentation

bool APLightsEditor::Editor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

void APLightsEditor::Editor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

EnvironmentObject * APLightsEditor::Editor::DrawPoint | ( | osg::Vec3 | position,
 |  | float | pointRadius,
 |  | osg::Vec4 | pointColor
 | ) |  |
protected
void APLightsEditor::Editor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

bool APLightsEditor::Editor::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
protectedvirtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

bool APLightsEditor::Editor::makeMenu ( )
protected
void APLightsEditor::Editor::menuItemClicked ( const char * itemID )
protectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented from vrecko::ControllableAbility.

void APLightsEditor::Editor::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
protectedvirtual

You should override this method if there is any slider in your menu.

Reimplemented from vrecko::ControllableAbility.

void APLightsEditor::Editor::saveToXML ( const char * FileName )
protected
void APLightsEditor::Editor::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

Member Data Documentation

int APLightsEditor::Editor::actLightID
protected
Lights::giModes APLightsEditor::Editor::giMode
protected
Lights* APLightsEditor::Editor::lightManager
protected
std::vector<_Light> APLightsEditor::Editor::lightMarker
protected
Lights::shadingModes APLightsEditor::Editor::shadeMode
protected
Lights::shadowModes APLightsEditor::Editor::shadowMode
protected
int APLightsEditor::Editor::sunID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Editor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/Editor.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APLightsEditor::Lights Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • Lights
Public Types | Public Member Functions | Public Attributes | List of all members
APLightsEditor::Lights Class Reference

#include <Lights.h>

Inheritance diagram for APLightsEditor::Lights:
vrecko::Ability vrecko::BaseClass

Public Types

enum | shadowModes { NONE, SHADOW_MAP, SOFT_SHADOW_MAP }
enum | shadingModes { GOURAUD, PHONG }
enum | giModes { FULL, HALF, NO }
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
Lights (void)
~Lights (void)
void | InitializeGI ()
int | add (osg::Vec4 position=osg::Vec4(0, 0, 0, 1), osg::Vec3 direction=osg::Vec3(0, 0,-1), float spotCutOff=180, float spotExp=0)
int | add (osg::LightSource *lightSource)
int | addSun (int day, int month, int year, int hour, int minute, osg::Vec4 *sunPosition=NULL)
bool | remove (int lightNum)
bool | removeAll ()
int | size ()
osg::Light * | at (int lightNum)
osg::LightSource * | getLightSource (int lightNum)
osg::Light * | getLight (int lightNum)
bool | setLightVisibility (int lightNum, bool on)
bool | setActiveShadowLight (int lightNum)
void | enableShadows (bool OnOrOff)
void | setMode (shadowModes shadowMode, shadingModes shadingMode, giModes giMode)
bool | isShadowsEnabled ()
void | setClearColor (osg::Vec4 color)
osg::Vec4 & | getClearColor ()
int | getCurrentShadowLightID ()
shadowModes getCurrentShadowMode ()
shadingModes getCurrectShadingMode ()
giModes getCurrentGIMode ()
void | setGlobalAmbient (osg::Vec4 color)
const osg::Vec4 | getGlobalAmbient ()
int | getDOSampleCount ()
float | getDORadius ()
int | getBounceSampleCount ()
float | getBounceRadius ()
int | getBlurSize ()
void | setDOSampleCount (int count)
void | setDORadius (float radius)
void | setBounceSampleCount (int count)
void | setBounceRadius (float radius)
void | setBlurSize (int size)
void | createFlare (int lightNum)
const osg::Vec4 & | getSunDate ()
osgShadow::ShadowTechnique * | getShadowTechnique ()
std::vector< osg::Node * > & | getFlares ()
osg::Texture2D * | createBuffer (osg::Vec2 textureSize, osg::Texture::FilterMode filter, osg::Texture::WrapMode wrap, GLint internalFormat, GLenum sourceFormat)
void | setUpCamera (osg::ref_ptr< osg::Camera > camera, osg::Vec2 textureSize, osg::ref_ptr< osg::StateSet > camSS, osg::ref_ptr< osg::Shader > vert, osg::ref_ptr< osg::Shader > frag)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

enum
APLightsEditor::Lights::shadowModes 		shadowMode
enum
APLightsEditor::Lights::shadingModes 		shadeMode
enum
APLightsEditor::Lights::giModes 		giMode

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Member Enumeration Documentation

enum APLightsEditor::Lights::giModes
Enumerator
FULL
HALF
NO
enum APLightsEditor::Lights::shadingModes
Enumerator
GOURAUD
PHONG
enum APLightsEditor::Lights::shadowModes
Enumerator
NONE
SHADOW_MAP
SOFT_SHADOW_MAP

Constructor & Destructor Documentation

APLightsEditor::Lights::Lights ( void )
APLightsEditor::Lights::~Lights ( void )

Member Function Documentation

int APLightsEditor::Lights::add | ( | osg::Vec4 | position = osg::Vec4(0,0,0,1),
 |  | osg::Vec3 | direction = osg::Vec3(0,0,-1),
 |  | float | spotCutOff = 180,
 |  | float | spotExp = 0
 | ) |  |

Creates a new light and put it in the scene

Parameters
position | vec4 position of the light (if last coord is zero creates directional light)
direction | vec3 direction of the light
spotCutOff | angle from the light axis (only for spot lights)
spotExp | light intensity exponent from spot center to edges
Returns
light ID
int APLightsEditor::Lights::add ( osg::LightSource * lightSource )

Creates a new light and put it in the scene

Parameters
lightSource pointer to lightSource object
Returns
light ID
int APLightsEditor::Lights::addSun | ( | int | day,
 |  | int | month,
 |  | int | year,
 |  | int | hour,
 |  | int | minute,
 |  | osg::Vec4 * | sunPosition = NULL
 | ) |  |

Put Sun in the scene

Returns
lightID
osg::Light * APLightsEditor::Lights::at ( int lightNum )

Returns a specific light, if lightNum doesn't exist, returns NULL

osg::Texture2D * APLightsEditor::Lights::createBuffer | ( | osg::Vec2 | textureSize,
 |  | osg::Texture::FilterMode | filter,
 |  | osg::Texture::WrapMode | wrap,
 |  | GLint | internalFormat,
 |  | GLenum | sourceFormat
 | ) |  |

Creates texture object for render to texture

void APLightsEditor::Lights::createFlare ( int lightNum )

Creates a flare for specific light

void APLightsEditor::Lights::enableShadows ( bool OnOrOff )

Enable/disable shadows (only for PHONG shading)

int APLightsEditor::Lights::getBlurSize ( )

Returns size of blur kernel

float APLightsEditor::Lights::getBounceRadius ( )

Returns indirect bounce maximal radius

int APLightsEditor::Lights::getBounceSampleCount ( )

Returns indirect bounce sample count

osg::Vec4 & APLightsEditor::Lights::getClearColor ( )

Returns current background color

shadingModes APLightsEditor::Lights::getCurrectShadingMode ( )
inline

Returns current shading mode: PHONG, GORAUD

giModes APLightsEditor::Lights::getCurrentGIMode ( )
inline

Returns current global illumination mode: FULL, HALF, NO

int APLightsEditor::Lights::getCurrentShadowLightID ( )

Returns ID of current shadow light

shadowModes APLightsEditor::Lights::getCurrentShadowMode ( )
inline

Returns current shadow mode: SHADOW_MAP, SOFT_SHADOW_MAP, NONE

float APLightsEditor::Lights::getDORadius ( )

Returns ambient occlusion maximal radius

int APLightsEditor::Lights::getDOSampleCount ( )

Returns ambient occlusion sample count

std::vector<osg::Node*>& APLightsEditor::Lights::getFlares ( )
inline

Returns billboarding flares as a vector of pointers

const osg::Vec4 APLightsEditor::Lights::getGlobalAmbient ( )
inline

Returns the global ambient intensity

osg::Light * APLightsEditor::Lights::getLight ( int lightNum )

Returns light according to given lightNum, if there is no such light, returns NULL

osg::LightSource * APLightsEditor::Lights::getLightSource ( int lightNum )

Returns a light source, if light source with given lightNum doesn't exists, null is returned

osgShadow::ShadowTechnique * APLightsEditor::Lights::getShadowTechnique ( )

Returns current shadow technique, otherwise NULL

const osg::Vec4& APLightsEditor::Lights::getSunDate ( )
inline

Returns a sun date as in vec4 format - saved as osg::Vec4(day,month,year,hour*60+minute)

void APLightsEditor::Lights::InitializeGI ( )

Initializes all necessary parameters for Global Illumination

bool APLightsEditor::Lights::isShadowsEnabled ( )
bool APLightsEditor::Lights::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

XML parameters, options

|–ShadowTechnique, (ShadowMap,SoftShadowMap,None) | | | | //For ShadowMap and SoftShadowMap | |–TextureSize, (vec2) Size of the depth texture | | | | //For SoftShadowMap | |–JitteringScale (float) Set the values for jittering scale the shader will use. | | Zero is no jittering (i.e. see the banding in penumbra) | | High values (>64) cause 'pixelization' of the penumbra. | | Usually but not necessarily power of two number. | | Default is 32. | |–SoftnessWidth (float) Set the values for width of the soft penumbra the shader will use. | Zero is for hard shadow (no penumbra). 0.01 is already very soft penumbra. | Default is 0.005. | |–ShadingTechnique, (Gouraud,Phong) |–GlobalAmbient, (vec4) |–ClearColor, (vec4) |–Sun, (DD MM YYYY HH MM, SystemTime) | |–GlobalIlluminatonResolution, (Full, Half, No) Texture resolution of global illumination: | | Full - same size as viewport window; | | Half - half size of viewport window; | | No - global illumination is not computed. | | | |–AOSampleCount (int) Number of samples (different directions) per each pixel. | |–AOSamplesPerDirection (int) Number of samples per each direction. | |–AORadius (float) Radius of sampling, maximal length of sample. | |–DPSSampleCount (int) Number of samples per each pixel per each light. | |–DPSRadius (float) Radius of sampling. | |–PrimaryShadowTechnique (ShadowMap, SoftShadowMap, DPS) Primary shadow technique for scene | | with only one light source. | |–BounceSampleCount (int) Number of samples per each pixel. | |–BounceRadius (float) Radius of sampling, maximal length of sample. | |–BlurSize (int) Size of blur kernel. | |–LightList, | |–Light, | |–Position, (vec3) |–Direction, (vec3) |–Cutoff, (0.0 - 90.0) |–Exponent, (float) |–Ambient, (vec4) |–Diffuse, (vec4) |–Specular, (vec4) |–ConstAtt, (0.0 - 1.0) |–LinAtt, (0.0 - 1.0) |–QuadAtt, (0.0 - 1.0) |–ShadowLight, (0,1) |–LensFlare, (0,1)

Reimplemented from vrecko::BaseClass.

void APLightsEditor::Lights::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APLightsEditor::Lights::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool APLightsEditor::Lights::remove ( int lightNum )

Remove light form the scene and recount all lights IDs

Returns
true if lights was succesfully removed
bool APLightsEditor::Lights::removeAll ( )

Remove all lights from the scene

bool APLightsEditor::Lights::setActiveShadowLight ( int lightNum )

Set active shadow light return true if operation succeded

void APLightsEditor::Lights::setBlurSize ( int size )

Sets size of blur kernel

void APLightsEditor::Lights::setBounceRadius ( float radius )

Sets indirect bounce maximal radius

void APLightsEditor::Lights::setBounceSampleCount ( int count )

Sets indirect bounce sample count

void APLightsEditor::Lights::setClearColor ( osg::Vec4 color )

Set the background color

void APLightsEditor::Lights::setDORadius ( float radius )

Sets ambient occlusion maximal radius

void APLightsEditor::Lights::setDOSampleCount ( int count )

Sets ambient occlusion maximal radius

void APLightsEditor::Lights::setGlobalAmbient ( osg::Vec4 color )

Sets the global ambient intensity

bool APLightsEditor::Lights::setLightVisibility | ( | int | lightNum,
 |  | bool | on
 | ) |  |

Set light visibility, works only for gouraud shading If lightNum doesn't exist, returns false

void APLightsEditor::Lights::setMode | ( | shadowModes | shadowMode,
 |  | shadingModes | shadingMode,
 |  | giModes | giMode
 | ) |  |

Testing method for changing shadow/shading modes, osgShadow is not fully implemented, so it's not working yet.

void APLightsEditor::Lights::setUpCamera | ( | osg::ref_ptr< osg::Camera > | camera,
 |  | osg::Vec2 | textureSize,
 |  | osg::ref_ptr< osg::StateSet > | camSS,
 |  | osg::ref_ptr< osg::Shader > | vert,
 |  | osg::ref_ptr< osg::Shader > | frag
 | ) |  |

Sets up camera for render to texture

int APLightsEditor::Lights::size ( )

Returns currect number of active lights

Member Data Documentation

enum APLightsEditor::Lights::giModes APLightsEditor::Lights::giMode
enum APLightsEditor::Lights::shadingModes APLightsEditor::Lights::shadeMode
enum APLightsEditor::Lights::shadowModes APLightsEditor::Lights::shadowMode
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Lights.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/Lights.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::MenuItem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItem
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APMenu::MenuItem Class Referenceabstract

#include <DynamicMenu.h>

Inheritance diagram for APMenu::MenuItem:
DynTreeNode< MenuItem > vrecko::BaseClass APMenu::MenuItemNull APMenu::MenuItemText APMenu::MenuItemSlider

Public Member Functions

MenuItem (DynamicMenu *_owner)
virtual MenuItem * | createNewItem (DynamicMenu *_owner)=0
virtual | ~MenuItem ()
virtual void | destroy ()
virtual bool | loadParametersFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
void | setName (const char *newName)
const std::string & | getName ()
bool | setFlags (unsigned long dwNewFlags, bool bForceUpdate=false)
unsigned long | getFlags ()
virtual bool | invalidate (bool bIncludeSubItems=false)
bool | isPointed (osg::Vec3 *projPointerPos)
virtual bool | canBeClicked ()
bool | isVisible ()
bool | isGraphicsCreated ()
virtual bool | show (unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3)
virtual void | hide (bool bIncludeSubItems=false)
virtual bool | pointerButtonDown ()
virtual bool | pointerButtonUp ()
virtual bool | pointerMove (osg::Vec3 *projPointerPos)
virtual bool | clicked ()
virtual void | getClickedString (char *outClickedEventString, size_t bufferSize)
virtual bool | setAndPlayConfirmationEffect ()
virtual bool | resetConfirmationEffect ()
bool | isExpanded ()
bool | canBeExpanded ()
vrecko::EnvironmentObject * getChildMenuObject ()
- Public Member Functions inherited from DynTreeNode< MenuItem >
unsigned long | GetDepth ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | createGraphics ()
bool | destroyGraphics ()
float | menuRadial_CalcItemAngle (int _iItemIndex)
unsigned long | menuBoxes_CalcItemDisplayIndex ()
virtual bool | createGraphicsCore ()
virtual bool | destroyGraphicsCore ()
virtual bool | showGraphicsAtPoint ()
virtual bool | hideGraphics ()
virtual bool | setFlagsCore (unsigned long dwOldFlags, unsigned long dwNewFlags)
virtual const osg::BoundingBox & | getInnerBoundingBox ()=0
virtual bool | addInputOutputs ()
virtual bool | removeInputOutputs ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

DynamicMenu * owner
int | pos
bool | bIsVisible
bool | bGraphicsCreated
unsigned long | dwFlags
unsigned long | dwItemIndex
unsigned long | dwNumItems
osg::Vec3 | refPoint1
osg::Vec3 | refPoint2
osg::Vec3 | refPoint3
float | itemSize
float | itemSize2
osg::Vec4 | color
std::string | name
osg::ref_ptr
< osg::MatrixTransform > 		mainTransform
osg::ref_ptr
< vrecko::EnvironmentObject > 		childMenuObject
osg::ref_ptr
< vrecko::EnvironmentObject > 		osgTransform
osg::ref_ptr< osg::Geode > | osgGeode
APObjectUtils::Animator * childMenuAnimator
bool | bConfirmationEndedConnectionCreated
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
osg::ref_ptr< osgQ::QSection > | shapeSection
osg::ref_ptr
< osgQ::QShapeDrawable > 		qshapeDraw
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Public Attributes inherited from DynTreeNode< MenuItem >
MenuItem * | lpParent
MenuItem * | lpChild
MenuItem * | lpNext
MenuItem * | lpPrev
DynamicTree< MenuItem > * | tree
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APMenu::MenuItem::MenuItem ( DynamicMenu * _owner )
APMenu::MenuItem::~MenuItem ( )
virtual

Member Function Documentation

bool APMenu::MenuItem::addInputOutputs ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemText.

virtual bool APMenu::MenuItem::canBeClicked ( )
inlinevirtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemNull.

bool APMenu::MenuItem::canBeExpanded ( )
inline
virtual bool APMenu::MenuItem::clicked ( )
inlinevirtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemText.

bool APMenu::MenuItem::createGraphics ( )
protected
bool APMenu::MenuItem::createGraphicsCore ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider, APMenu::MenuItemText, and APMenu::MenuItemNull.

virtual MenuItem* APMenu::MenuItem::createNewItem ( DynamicMenu * _owner )
pure virtual

Implemented in APMenu::MenuItemSlider, APMenu::MenuItemText, and APMenu::MenuItemNull.

void APMenu::MenuItem::destroy ( )
virtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemText.

bool APMenu::MenuItem::destroyGraphics ( )
protected
bool APMenu::MenuItem::destroyGraphicsCore ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider, APMenu::MenuItemText, and APMenu::MenuItemNull.

vrecko::EnvironmentObject* APMenu::MenuItem::getChildMenuObject ( )
inline
virtual void APMenu::MenuItem::getClickedString | ( | char * | outClickedEventString,
 |  | size_t | bufferSize
 | ) |  |
inlinevirtual

Reimplemented in APMenu::MenuItemSlider.

unsigned long APMenu::MenuItem::getFlags ( )
inline
virtual const osg::BoundingBox& APMenu::MenuItem::getInnerBoundingBox ( )
protectedpure virtual

Implemented in APMenu::MenuItemSlider, APMenu::MenuItemText, and APMenu::MenuItemNull.

const std::string& APMenu::MenuItem::getName ( void )
inline
void APMenu::MenuItem::hide ( bool bIncludeSubItems = false )
virtual
bool APMenu::MenuItem::hideGraphics ( )
protectedvirtual

Reimplemented in APMenu::MenuItemNull.

bool APMenu::MenuItem::invalidate ( bool bIncludeSubItems = false )
virtual
bool APMenu::MenuItem::isExpanded ( )
inline
bool APMenu::MenuItem::isGraphicsCreated ( )
inline
bool APMenu::MenuItem::isPointed ( osg::Vec3 * projPointerPos )
bool APMenu::MenuItem::isVisible ( )
inline
bool APMenu::MenuItem::loadParametersFromNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemText.

unsigned long APMenu::MenuItem::menuBoxes_CalcItemDisplayIndex ( )
protected
float APMenu::MenuItem::menuRadial_CalcItemAngle ( int _iItemIndex )
protected
virtual bool APMenu::MenuItem::pointerButtonDown ( )
inlinevirtual

Reimplemented in APMenu::MenuItemSlider.

virtual bool APMenu::MenuItem::pointerButtonUp ( )
inlinevirtual

Reimplemented in APMenu::MenuItemSlider.

virtual bool APMenu::MenuItem::pointerMove ( osg::Vec3 * projPointerPos )
inlinevirtual

Reimplemented in APMenu::MenuItemSlider.

int APMenu::MenuItem::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

bool APMenu::MenuItem::removeInputOutputs ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider, and APMenu::MenuItemText.

bool APMenu::MenuItem::resetConfirmationEffect ( )
virtual
bool APMenu::MenuItem::setAndPlayConfirmationEffect ( )
virtual
bool APMenu::MenuItem::setFlags | ( | unsigned long | dwNewFlags,
 |  | bool | bForceUpdate = false
 | ) |  |
bool APMenu::MenuItem::setFlagsCore | ( | unsigned long | dwOldFlags,
 |  | unsigned long | dwNewFlags
 | ) |  |
protectedvirtual
void APMenu::MenuItem::setName ( const char * newName )
inline
bool APMenu::MenuItem::show | ( | unsigned long | _dwItemIndex,
 |  | unsigned long | _dwNumItems,
 |  | osg::Vec3 * | _refPoint1,
 |  | osg::Vec3 * | _refPoint2,
 |  | osg::Vec3 * | _refPoint3
 | ) |  |
virtual
bool APMenu::MenuItem::showGraphicsAtPoint ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider, APMenu::MenuItemText, and APMenu::MenuItemNull.

Member Data Documentation

bool APMenu::MenuItem::bConfirmationEndedConnectionCreated
protected
bool APMenu::MenuItem::bGraphicsCreated
protected
bool APMenu::MenuItem::bIsVisible
protected
APObjectUtils::Animator* APMenu::MenuItem::childMenuAnimator
protected
osg::ref_ptr<vrecko::EnvironmentObject> APMenu::MenuItem::childMenuObject
protected
osg::Vec4 APMenu::MenuItem::color
protected
unsigned long APMenu::MenuItem::dwFlags
protected
unsigned long APMenu::MenuItem::dwItemIndex
protected
unsigned long APMenu::MenuItem::dwNumItems
protected
float APMenu::MenuItem::itemSize
protected
float APMenu::MenuItem::itemSize2
protected
osg::ref_ptr<osg::MatrixTransform> APMenu::MenuItem::mainTransform
protected
std::string APMenu::MenuItem::name
protected
osg::ref_ptr<osg::Geode> APMenu::MenuItem::osgGeode
protected
osg::ref_ptr<vrecko::EnvironmentObject> APMenu::MenuItem::osgTransform
protected
DynamicMenu* APMenu::MenuItem::owner
protected
int APMenu::MenuItem::pos
protected
osg::ref_ptr<osgQ::QShapeDrawable> APMenu::MenuItem::qshapeDraw
protected
osg::Vec3 APMenu::MenuItem::refPoint1
protected
osg::Vec3 APMenu::MenuItem::refPoint2
protected
osg::Vec3 APMenu::MenuItem::refPoint3
protected
osg::ref_ptr<osg::Box> APMenu::MenuItem::shapeBox
protected
osg::ref_ptr<osg::ShapeDrawable> APMenu::MenuItem::shapeDraw
protected
osg::ref_ptr<osgQ::QSection> APMenu::MenuItem::shapeSection
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::MenuItemNull Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemNull
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APMenu::MenuItemNull Class Reference

#include <DynamicMenu.h>

Inheritance diagram for APMenu::MenuItemNull:
APMenu::MenuItem DynTreeNode< MenuItem > vrecko::BaseClass

Public Member Functions

MenuItemNull (DynamicMenu *_owner)
virtual MenuItem * | createNewItem (DynamicMenu *_owner)
virtual bool | canBeClicked ()
- Public Member Functions inherited from APMenu::MenuItem
MenuItem (DynamicMenu *_owner)
virtual | ~MenuItem ()
virtual void | destroy ()
virtual bool | loadParametersFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
void | setName (const char *newName)
const std::string & | getName ()
bool | setFlags (unsigned long dwNewFlags, bool bForceUpdate=false)
unsigned long | getFlags ()
virtual bool | invalidate (bool bIncludeSubItems=false)
bool | isPointed (osg::Vec3 *projPointerPos)
bool | isVisible ()
bool | isGraphicsCreated ()
virtual bool | show (unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3)
virtual void | hide (bool bIncludeSubItems=false)
virtual bool | pointerButtonDown ()
virtual bool | pointerButtonUp ()
virtual bool | pointerMove (osg::Vec3 *projPointerPos)
virtual bool | clicked ()
virtual void | getClickedString (char *outClickedEventString, size_t bufferSize)
virtual bool | setAndPlayConfirmationEffect ()
virtual bool | resetConfirmationEffect ()
bool | isExpanded ()
bool | canBeExpanded ()
vrecko::EnvironmentObject * getChildMenuObject ()
- Public Member Functions inherited from DynTreeNode< MenuItem >
unsigned long | GetDepth ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | createGraphicsCore ()
virtual bool | destroyGraphicsCore ()
virtual bool | showGraphicsAtPoint ()
virtual bool | hideGraphics ()
virtual const osg::BoundingBox & | getInnerBoundingBox ()
- Protected Member Functions inherited from APMenu::MenuItem
bool | createGraphics ()
bool | destroyGraphics ()
float | menuRadial_CalcItemAngle (int _iItemIndex)
unsigned long | menuBoxes_CalcItemDisplayIndex ()
virtual bool | setFlagsCore (unsigned long dwOldFlags, unsigned long dwNewFlags)
virtual bool | addInputOutputs ()
virtual bool | removeInputOutputs ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::BoundingBox | bbox
- Protected Attributes inherited from APMenu::MenuItem
DynamicMenu * owner
int | pos
bool | bIsVisible
bool | bGraphicsCreated
unsigned long | dwFlags
unsigned long | dwItemIndex
unsigned long | dwNumItems
osg::Vec3 | refPoint1
osg::Vec3 | refPoint2
osg::Vec3 | refPoint3
float | itemSize
float | itemSize2
osg::Vec4 | color
std::string | name
osg::ref_ptr
< osg::MatrixTransform > 		mainTransform
osg::ref_ptr
< vrecko::EnvironmentObject > 		childMenuObject
osg::ref_ptr
< vrecko::EnvironmentObject > 		osgTransform
osg::ref_ptr< osg::Geode > | osgGeode
APObjectUtils::Animator * childMenuAnimator
bool | bConfirmationEndedConnectionCreated
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
osg::ref_ptr< osgQ::QSection > | shapeSection
osg::ref_ptr
< osgQ::QShapeDrawable > 		qshapeDraw
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Public Attributes inherited from DynTreeNode< MenuItem >
MenuItem * | lpParent
MenuItem * | lpChild
MenuItem * | lpNext
MenuItem * | lpPrev
DynamicTree< MenuItem > * | tree
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APMenu::MenuItemNull::MenuItemNull ( DynamicMenu * _owner )
inline

Member Function Documentation

virtual bool APMenu::MenuItemNull::canBeClicked ( )
inlinevirtual

Reimplemented from APMenu::MenuItem.

virtual bool APMenu::MenuItemNull::createGraphicsCore ( )
inlineprotectedvirtual

Reimplemented from APMenu::MenuItem.

virtual MenuItem* APMenu::MenuItemNull::createNewItem ( DynamicMenu * _owner )
inlinevirtual

Implements APMenu::MenuItem.

virtual bool APMenu::MenuItemNull::destroyGraphicsCore ( )
inlineprotectedvirtual

Reimplemented from APMenu::MenuItem.

virtual const osg::BoundingBox& APMenu::MenuItemNull::getInnerBoundingBox ( )
inlineprotectedvirtual

Implements APMenu::MenuItem.

virtual bool APMenu::MenuItemNull::hideGraphics ( )
inlineprotectedvirtual

Reimplemented from APMenu::MenuItem.

virtual bool APMenu::MenuItemNull::showGraphicsAtPoint ( )
inlineprotectedvirtual

Reimplemented from APMenu::MenuItem.

Member Data Documentation

osg::BoundingBox APMenu::MenuItemNull::bbox
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::MenuItemText Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemText
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APMenu::MenuItemText Class Reference

#include <DynamicMenu.h>

Inheritance diagram for APMenu::MenuItemText:
APMenu::MenuItem DynTreeNode< MenuItem > vrecko::BaseClass APMenu::MenuItemSlider

Public Member Functions

MenuItemText (DynamicMenu *_owner)
virtual | ~MenuItemText ()
virtual MenuItem * | createNewItem (DynamicMenu *_owner)
virtual void | destroy ()
virtual bool | loadParametersFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | clicked ()
virtual const std::string & | getCaption ()
virtual bool | setCaption (const char *newCaption)
virtual const std::string & | getModelFile ()
virtual bool | setModelFile (const char *newModelFile)
void | setSignName (const char *name)
- Public Member Functions inherited from APMenu::MenuItem
MenuItem (DynamicMenu *_owner)
virtual | ~MenuItem ()
void | setName (const char *newName)
const std::string & | getName ()
bool | setFlags (unsigned long dwNewFlags, bool bForceUpdate=false)
unsigned long | getFlags ()
virtual bool | invalidate (bool bIncludeSubItems=false)
bool | isPointed (osg::Vec3 *projPointerPos)
virtual bool | canBeClicked ()
bool | isVisible ()
bool | isGraphicsCreated ()
virtual bool | show (unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3)
virtual void | hide (bool bIncludeSubItems=false)
virtual bool | pointerButtonDown ()
virtual bool | pointerButtonUp ()
virtual bool | pointerMove (osg::Vec3 *projPointerPos)
virtual void | getClickedString (char *outClickedEventString, size_t bufferSize)
virtual bool | setAndPlayConfirmationEffect ()
virtual bool | resetConfirmationEffect ()
bool | isExpanded ()
bool | canBeExpanded ()
vrecko::EnvironmentObject * getChildMenuObject ()
- Public Member Functions inherited from DynTreeNode< MenuItem >
unsigned long | GetDepth ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | createGraphicsCore ()
virtual bool | destroyGraphicsCore ()
virtual bool | showGraphicsAtPoint ()
virtual const osg::BoundingBox & | getInnerBoundingBox ()
bool | getTextBoundingBox (osg::BoundingBox *outBox)
virtual bool | addInputOutputs ()
virtual bool | removeInputOutputs ()
virtual bool | createModel ()
virtual void | destroyModel ()
virtual void | repositionModel ()
virtual void | updateText ()
DECLARE_OUTPUT (Clicked, MessageBool)
- Protected Member Functions inherited from APMenu::MenuItem
bool | createGraphics ()
bool | destroyGraphics ()
float | menuRadial_CalcItemAngle (int _iItemIndex)
unsigned long | menuBoxes_CalcItemDisplayIndex ()
virtual bool | hideGraphics ()
virtual bool | setFlagsCore (unsigned long dwOldFlags, unsigned long dwNewFlags)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::string | caption
std::string | modelFile
osg::ref_ptr< osg::Node > | model
osg::ref_ptr
< osg::MatrixTransform > 		modelTransform
osg::ref_ptr< osgText::Text > | osgText
osg::Vec2 | textShift
std::string | signName
osg::ref_ptr< osg::Node > | signObject
osg::ref_ptr
< osg::PositionAttitudeTransform > 		signTransform
osg::BoundingBox | boundingBox
- Protected Attributes inherited from APMenu::MenuItem
DynamicMenu * owner
int | pos
bool | bIsVisible
bool | bGraphicsCreated
unsigned long | dwFlags
unsigned long | dwItemIndex
unsigned long | dwNumItems
osg::Vec3 | refPoint1
osg::Vec3 | refPoint2
osg::Vec3 | refPoint3
float | itemSize
float | itemSize2
osg::Vec4 | color
std::string | name
osg::ref_ptr
< osg::MatrixTransform > 		mainTransform
osg::ref_ptr
< vrecko::EnvironmentObject > 		childMenuObject
osg::ref_ptr
< vrecko::EnvironmentObject > 		osgTransform
osg::ref_ptr< osg::Geode > | osgGeode
APObjectUtils::Animator * childMenuAnimator
bool | bConfirmationEndedConnectionCreated
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
osg::ref_ptr< osgQ::QSection > | shapeSection
osg::ref_ptr
< osgQ::QShapeDrawable > 		qshapeDraw
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Public Attributes inherited from DynTreeNode< MenuItem >
MenuItem * | lpParent
MenuItem * | lpChild
MenuItem * | lpNext
MenuItem * | lpPrev
DynamicTree< MenuItem > * | tree
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APMenu::MenuItemText::MenuItemText ( DynamicMenu * _owner )
APMenu::MenuItemText::~MenuItemText ( )
virtual

Member Function Documentation

bool APMenu::MenuItemText::addInputOutputs ( )
protectedvirtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

bool APMenu::MenuItemText::clicked ( )
virtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

bool APMenu::MenuItemText::createGraphicsCore ( )
protectedvirtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

bool APMenu::MenuItemText::createModel ( )
protectedvirtual
virtual MenuItem* APMenu::MenuItemText::createNewItem ( DynamicMenu * _owner )
inlinevirtual

Implements APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

APMenu::MenuItemText::DECLARE_OUTPUT | ( | Clicked | ,
 |  | MessageBool |
 | ) |  |
protected
void APMenu::MenuItemText::destroy ( )
virtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

bool APMenu::MenuItemText::destroyGraphicsCore ( )
protectedvirtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

void APMenu::MenuItemText::destroyModel ( )
protectedvirtual
virtual const std::string& APMenu::MenuItemText::getCaption ( )
inlinevirtual
const osg::BoundingBox & APMenu::MenuItemText::getInnerBoundingBox ( )
protectedvirtual

Implements APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

virtual const std::string& APMenu::MenuItemText::getModelFile ( )
inlinevirtual
bool APMenu::MenuItemText::getTextBoundingBox ( osg::BoundingBox * outBox )
protected
bool APMenu::MenuItemText::loadParametersFromNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

bool APMenu::MenuItemText::removeInputOutputs ( )
protectedvirtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

void APMenu::MenuItemText::repositionModel ( )
protectedvirtual
bool APMenu::MenuItemText::setCaption ( const char * newCaption )
virtual
bool APMenu::MenuItemText::setModelFile ( const char * newModelFile )
virtual
void APMenu::MenuItemText::setSignName ( const char * name )
bool APMenu::MenuItemText::showGraphicsAtPoint ( )
protectedvirtual

Reimplemented from APMenu::MenuItem.

Reimplemented in APMenu::MenuItemSlider.

void APMenu::MenuItemText::updateText ( )
protectedvirtual

Reimplemented in APMenu::MenuItemSlider.

Member Data Documentation

osg::BoundingBox APMenu::MenuItemText::boundingBox
protected
std::string APMenu::MenuItemText::caption
protected
osg::ref_ptr<osg::Node> APMenu::MenuItemText::model
protected
std::string APMenu::MenuItemText::modelFile
protected
osg::ref_ptr<osg::MatrixTransform> APMenu::MenuItemText::modelTransform
protected
osg::ref_ptr<osgText::Text> APMenu::MenuItemText::osgText
protected
std::string APMenu::MenuItemText::signName
protected
osg::ref_ptr<osg::Node> APMenu::MenuItemText::signObject
protected
osg::ref_ptr<osg::PositionAttitudeTransform> APMenu::MenuItemText::signTransform
protected
osg::Vec2 APMenu::MenuItemText::textShift
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::MenuItemSlider Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemSlider
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APMenu::MenuItemSlider Class Reference

#include <DynamicMenu.h>

Inheritance diagram for APMenu::MenuItemSlider:
APMenu::MenuItemText APMenu::MenuItem DynTreeNode< MenuItem > vrecko::BaseClass

Public Member Functions

MenuItemSlider (DynamicMenu *_owner)
virtual | ~MenuItemSlider ()
virtual MenuItem * | createNewItem (DynamicMenu *_owner)
virtual void | destroy ()
virtual bool | loadParametersFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | canBeClicked ()
virtual bool | clicked ()
virtual void | getClickedString (char *outClickedEventString, size_t bufferSize)
virtual bool | pointerButtonDown ()
virtual bool | pointerButtonUp ()
virtual bool | pointerMove (osg::Vec3 *projPointerPos)
virtual float | getSliderPos01 ()
virtual bool | setSliderPos01 (float fNewSliderPos01, bool bSendEvent=true)
virtual float | getSliderPosXY ()
virtual bool | setSliderPosXY (float fNewSliderPos, bool bSendEvent=true)
- Public Member Functions inherited from APMenu::MenuItemText
MenuItemText (DynamicMenu *_owner)
virtual | ~MenuItemText ()
virtual const std::string & | getCaption ()
virtual bool | setCaption (const char *newCaption)
virtual const std::string & | getModelFile ()
virtual bool | setModelFile (const char *newModelFile)
void | setSignName (const char *name)
- Public Member Functions inherited from APMenu::MenuItem
MenuItem (DynamicMenu *_owner)
virtual | ~MenuItem ()
void | setName (const char *newName)
const std::string & | getName ()
bool | setFlags (unsigned long dwNewFlags, bool bForceUpdate=false)
unsigned long | getFlags ()
virtual bool | invalidate (bool bIncludeSubItems=false)
bool | isPointed (osg::Vec3 *projPointerPos)
bool | isVisible ()
bool | isGraphicsCreated ()
virtual bool | show (unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3)
virtual void | hide (bool bIncludeSubItems=false)
virtual bool | setAndPlayConfirmationEffect ()
virtual bool | resetConfirmationEffect ()
bool | isExpanded ()
bool | canBeExpanded ()
vrecko::EnvironmentObject * getChildMenuObject ()
- Public Member Functions inherited from DynTreeNode< MenuItem >
unsigned long | GetDepth ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | createGraphicsCore ()
virtual bool | destroyGraphicsCore ()
virtual bool | showGraphicsAtPoint ()
virtual const osg::BoundingBox & | getInnerBoundingBox ()
virtual bool | addInputOutputs ()
virtual bool | removeInputOutputs ()
bool | updateSliderGraphicPos ()
float | getPointerSliderPos01 (bool *bIsOutside)
virtual void | updateText ()
DECLARE_OUTPUT (Slide, MessageFloat)
- Protected Member Functions inherited from APMenu::MenuItemText
bool | getTextBoundingBox (osg::BoundingBox *outBox)
virtual bool | createModel ()
virtual void | destroyModel ()
virtual void | repositionModel ()
DECLARE_OUTPUT (Clicked, MessageBool)
- Protected Member Functions inherited from APMenu::MenuItem
bool | createGraphics ()
bool | destroyGraphics ()
float | menuRadial_CalcItemAngle (int _iItemIndex)
unsigned long | menuBoxes_CalcItemDisplayIndex ()
virtual bool | hideGraphics ()
virtual bool | setFlagsCore (unsigned long dwOldFlags, unsigned long dwNewFlags)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

float | fSliderPos01
bool | bSliding
float | fSliderFromX
float | fSliderToY
bool | bIntegerOnlySlider
osg::ref_ptr< osg::Cylinder > | sliderNonmovable
osg::ref_ptr< osg::ShapeDrawable > | sliderDrawNM
osg::ref_ptr< osg::Box > | sliderMovable
osg::ref_ptr< osg::ShapeDrawable > | sliderDrawM
- Protected Attributes inherited from APMenu::MenuItemText
std::string | caption
std::string | modelFile
osg::ref_ptr< osg::Node > | model
osg::ref_ptr
< osg::MatrixTransform > 		modelTransform
osg::ref_ptr< osgText::Text > | osgText
osg::Vec2 | textShift
std::string | signName
osg::ref_ptr< osg::Node > | signObject
osg::ref_ptr
< osg::PositionAttitudeTransform > 		signTransform
osg::BoundingBox | boundingBox
- Protected Attributes inherited from APMenu::MenuItem
DynamicMenu * owner
int | pos
bool | bIsVisible
bool | bGraphicsCreated
unsigned long | dwFlags
unsigned long | dwItemIndex
unsigned long | dwNumItems
osg::Vec3 | refPoint1
osg::Vec3 | refPoint2
osg::Vec3 | refPoint3
float | itemSize
float | itemSize2
osg::Vec4 | color
std::string | name
osg::ref_ptr
< osg::MatrixTransform > 		mainTransform
osg::ref_ptr
< vrecko::EnvironmentObject > 		childMenuObject
osg::ref_ptr
< vrecko::EnvironmentObject > 		osgTransform
osg::ref_ptr< osg::Geode > | osgGeode
APObjectUtils::Animator * childMenuAnimator
bool | bConfirmationEndedConnectionCreated
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
osg::ref_ptr< osgQ::QSection > | shapeSection
osg::ref_ptr
< osgQ::QShapeDrawable > 		qshapeDraw
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Public Attributes inherited from DynTreeNode< MenuItem >
MenuItem * | lpParent
MenuItem * | lpChild
MenuItem * | lpNext
MenuItem * | lpPrev
DynamicTree< MenuItem > * | tree
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APMenu::MenuItemSlider::MenuItemSlider ( DynamicMenu * _owner )
APMenu::MenuItemSlider::~MenuItemSlider ( )
virtual

Member Function Documentation

bool APMenu::MenuItemSlider::addInputOutputs ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

virtual bool APMenu::MenuItemSlider::canBeClicked ( )
inlinevirtual

Reimplemented from APMenu::MenuItem.

virtual bool APMenu::MenuItemSlider::clicked ( )
inlinevirtual

Reimplemented from APMenu::MenuItemText.

bool APMenu::MenuItemSlider::createGraphicsCore ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

virtual MenuItem* APMenu::MenuItemSlider::createNewItem ( DynamicMenu * _owner )
inlinevirtual

Reimplemented from APMenu::MenuItemText.

APMenu::MenuItemSlider::DECLARE_OUTPUT | ( | Slide | ,
 |  | MessageFloat |
 | ) |  |
protected
void APMenu::MenuItemSlider::destroy ( )
virtual

Reimplemented from APMenu::MenuItemText.

bool APMenu::MenuItemSlider::destroyGraphicsCore ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

void APMenu::MenuItemSlider::getClickedString | ( | char * | outClickedEventString,
 |  | size_t | bufferSize
 | ) |  |
virtual

Reimplemented from APMenu::MenuItem.

const osg::BoundingBox & APMenu::MenuItemSlider::getInnerBoundingBox ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

float APMenu::MenuItemSlider::getPointerSliderPos01 ( bool * bIsOutside )
protected
virtual float APMenu::MenuItemSlider::getSliderPos01 ( )
inlinevirtual
float APMenu::MenuItemSlider::getSliderPosXY ( )
virtual
bool APMenu::MenuItemSlider::loadParametersFromNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual

Reimplemented from APMenu::MenuItemText.

bool APMenu::MenuItemSlider::pointerButtonDown ( )
virtual

Reimplemented from APMenu::MenuItem.

bool APMenu::MenuItemSlider::pointerButtonUp ( )
virtual

Reimplemented from APMenu::MenuItem.

bool APMenu::MenuItemSlider::pointerMove ( osg::Vec3 * projPointerPos )
virtual

Reimplemented from APMenu::MenuItem.

bool APMenu::MenuItemSlider::removeInputOutputs ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

bool APMenu::MenuItemSlider::setSliderPos01 | ( | float | fNewSliderPos01,
 |  | bool | bSendEvent = true
 | ) |  |
virtual
virtual bool APMenu::MenuItemSlider::setSliderPosXY | ( | float | fNewSliderPos,
 |  | bool | bSendEvent = true
 | ) |  |
inlinevirtual
bool APMenu::MenuItemSlider::showGraphicsAtPoint ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

bool APMenu::MenuItemSlider::updateSliderGraphicPos ( )
protected
void APMenu::MenuItemSlider::updateText ( )
protectedvirtual

Reimplemented from APMenu::MenuItemText.

Member Data Documentation

bool APMenu::MenuItemSlider::bIntegerOnlySlider
protected
bool APMenu::MenuItemSlider::bSliding
protected
float APMenu::MenuItemSlider::fSliderFromX
protected
float APMenu::MenuItemSlider::fSliderPos01
protected
float APMenu::MenuItemSlider::fSliderToY
protected
osg::ref_ptr<osg::ShapeDrawable> APMenu::MenuItemSlider::sliderDrawM
protected
osg::ref_ptr<osg::ShapeDrawable> APMenu::MenuItemSlider::sliderDrawNM
protected
osg::ref_ptr<osg::Box> APMenu::MenuItemSlider::sliderMovable
protected
osg::ref_ptr<osg::Cylinder> APMenu::MenuItemSlider::sliderNonmovable
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::DynamicMenuSign Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • DynamicMenuSign
Public Attributes | List of all members
APMenu::DynamicMenuSign Class Reference

#include <DynamicMenu.h>

Public Attributes

std::string | value
osg::ref_ptr< osg::Node > | geometry

Member Data Documentation

osg::ref_ptr<osg::Node> APMenu::DynamicMenuSign::geometry
std::string APMenu::DynamicMenuSign::value
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::DynamicMenu Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • DynamicMenu
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Friends | List of all members
APMenu::DynamicMenu Class Reference

#include <DynamicMenu.h>

Inheritance diagram for APMenu::DynamicMenu:
vrecko::Ability vrecko::BaseClass

Public Member Functions

DynamicMenu ()
virtual | ~DynamicMenu ()
EnvironmentObject * getOwner ()
EnvironmentObject * getMainObject ()
virtual void | preInitialize ()
called as the first initialization method, before loadXMLParameters More...
virtual void | postInitialize ()
called as the last initialization method, after loadXMLParameters More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
loads XML parameters from given node More...
virtual void | update ()
called by the VRECKO scheduler at specified frequency More...
bool | setMenuString (const char *newMenuString)
bool | addMenuItem (MenuItem *parentItem, MenuItem *itemToAdd)
bool | insertMenuItem (MenuItem *parentItem, MenuItem *prevSibling, MenuItem *itemToAdd)
bool | deleteMenuItem (MenuItem *item)
bool | registerNewItemType (MenuItem *itemTemplate)
MenuType getMenuType ()
void | setAttribute (const std::string &name, float value)
float | getAttribute (const std::string &name)
void | setSign (const std::string &name, const std::string &value)
osg::Node * | getSignObject (const std::string &name)
bool | isMainButtonPressed ()
bool | isSelectionLocked ()
bool | showMenu (osg::Vec3 *_menuPos)
void | hideMenu ()
osg::Vec3 & | getProjPointerPos ()
osg::Vec3 & | getLastPointerPos ()
void | sendToClickedOutput (char *eventValue)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

DynamicTree< MenuItem > itemTree

Protected Member Functions

bool | mainButtonPressed ()
bool | mainButtonReleased ()
bool | showChildMenu (MenuItem *parentItem, bool bSetNewRoot)
void | hideChildMenu (MenuItem *parentItem=NULL, bool bIncludeSubMenus=true)
bool | isVisible ()
bool | showMainMenuObject ()
void | hideMainMenuObject ()
void | updatePointerPosition ()
void | updateMainObjectTransformation ()
void | updateInverseCalc ()
bool | pointerMoved (osg::Vec3 *pointerPos)
bool | viewMoved ()
bool | pointerViewMovedHelper ()
bool | createMenuFromString ()
bool | createMenuFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *paramNode)
bool | loadMenuStructureFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *paramNode)
bool | loadSignsFromXML (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *attribsNode)
bool | loadAttributes (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *attribsNode)
bool | loadMenuItems (MenuItem *parentItem, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode)
void | destroyMenuStructure ()
bool | createMainObjects ()
void | destroyMainObjects ()
bool | createPointerTrail ()
void | destroyPointerTrail ()
void | showPointerTrail ()
void | hidePointerTrail ()
bool | pointerUnselectItem (bool bLeaveSelectedIfLocked=true)
bool | pointerSelectItem (MenuItem *item)
bool | solvePointerSelection ()
MenuItem * | getPointedItemRecursive (MenuItem *parent, int *depth)
bool | expandItem (MenuItem *item)
bool | collapseItem (MenuItem *item)
bool | collapseSiblings (MenuItem *item)
void | itemClicked (MenuItem *item)
void | confirmAnimationEnded ()
void | resetBaseValues ()
void | initStandardSignSet ()
void | changeToStructureOccured ()
bool | unselectItem ()
void | menuGrid_getSize (int *columns, int *rows)
DECLARE_INPUT (Create, MessageString)
DECLARE_INPUT (ButtonPress, MessageBool)
DECLARE_INPUT (ConfirmAnimationEnded, MessageBool)
DECLARE_OUTPUT (Clicked, MessageString)
DECLARE_OUTPUT (HidingMenu, MessageBool)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_OUTPUT (PointerPosition, MessageInt, MessageVec3)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
std::string | baseDirectory
int | activePointerID
osg::Vec3 | origMenuPos
osg::Vec3 | origViewPos
osg::Vec3 | origViewUp
osg::Vec3 | origViewLookAt
osg::Vec3 | autoMoveShift
osg::ref_ptr< EnvironmentObject > | mainObject
osg::ref_ptr< EnvironmentObject > | shadowEO
osg::ref_ptr< EnvironmentObject > | dispEO
osg::Matrix | inverseTransformMatrix
osg::Vec3 | lastPointerPos
osg::Vec3 | lastViewPos
osg::Vec3 | transPointerPos
osg::Vec3 | projPointerPos
osg::Vec3 | transViewPos
bool | bMainButtonPressed
bool | bAllowSelectOnRelease
DynamicArray< MenuItem * > registeredItemTypes
std::string | menuString
std::map< std::string, float > | attributes
std::map< std::string,
DynamicMenuSign * > 		signs
MenuType menuType
MenuItem * pointerSelected
MenuItem * visibleMenuRoot
MenuItem * selectedItem
osg::ref_ptr
< osg::MatrixTransform > 		osgPointerTrailTransform
osg::ref_ptr< osg::Geode > | osgPointerTrailGeode
osg::ref_ptr< osg::Cylinder > | osgPointerTrail
osg::ref_ptr< osg::ShapeDrawable > | osgPointerTrailDrawable
int | menuGrid_columnsCached
int | menuGrid_rowsCached
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Friends

class MenuItem

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APMenu::DynamicMenu::DynamicMenu ( )
APMenu::DynamicMenu::~DynamicMenu ( )
virtual

Member Function Documentation

bool APMenu::DynamicMenu::addMenuItem | ( | MenuItem * | parentItem,
 |  | MenuItem * | itemToAdd
 | ) |  |
void APMenu::DynamicMenu::changeToStructureOccured ( )
protected
bool APMenu::DynamicMenu::collapseItem ( MenuItem * item )
protected
bool APMenu::DynamicMenu::collapseSiblings ( MenuItem * item )
protected
void APMenu::DynamicMenu::confirmAnimationEnded ( )
protected
bool APMenu::DynamicMenu::createMainObjects ( )
protected
bool APMenu::DynamicMenu::createMenuFromNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * paramNode )
protected
bool APMenu::DynamicMenu::createMenuFromString ( void )
protected
bool APMenu::DynamicMenu::createPointerTrail ( )
protected
APMenu::DynamicMenu::DECLARE_INPUT | ( | Create | ,
 |  | MessageString |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_INPUT | ( | ButtonPress | ,
 |  | MessageBool |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_INPUT | ( | ConfirmAnimationEnded | ,
 |  | MessageBool |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_OUTPUT | ( | Clicked | ,
 |  | MessageString |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_OUTPUT | ( | HidingMenu | ,
 |  | MessageBool |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_REQUEST_INPUT | ( | ActivePointerID | ,
 |  | MessageInt | ,
 |  | MessageInt |
 | ) |  |
protected
APMenu::DynamicMenu::DECLARE_REQUEST_OUTPUT | ( | PointerPosition | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
bool APMenu::DynamicMenu::deleteMenuItem ( MenuItem * item )
void APMenu::DynamicMenu::destroyMainObjects ( )
protected
void APMenu::DynamicMenu::destroyMenuStructure ( )
protected
void APMenu::DynamicMenu::destroyPointerTrail ( )
protected
bool APMenu::DynamicMenu::expandItem ( MenuItem * item )
protected
float APMenu::DynamicMenu::getAttribute ( const std::string & name )
inline
osg::Vec3& APMenu::DynamicMenu::getLastPointerPos ( )
inline
EnvironmentObject* APMenu::DynamicMenu::getMainObject ( )
inline
MenuType APMenu::DynamicMenu::getMenuType ( )
inline
EnvironmentObject* APMenu::DynamicMenu::getOwner ( void )
inline
MenuItem * APMenu::DynamicMenu::getPointedItemRecursive | ( | MenuItem * | parent,
 |  | int * | depth
 | ) |  |
protected
osg::Vec3& APMenu::DynamicMenu::getProjPointerPos ( )
inline
osg::Node * APMenu::DynamicMenu::getSignObject ( const std::string & name )
void APMenu::DynamicMenu::hideChildMenu | ( | MenuItem * | parentItem = NULL,
 |  | bool | bIncludeSubMenus = true
 | ) |  |
protected
void APMenu::DynamicMenu::hideMainMenuObject ( )
protected
void APMenu::DynamicMenu::hideMenu ( )
void APMenu::DynamicMenu::hidePointerTrail ( )
protected
void APMenu::DynamicMenu::initStandardSignSet ( )
protected
bool APMenu::DynamicMenu::insertMenuItem | ( | MenuItem * | parentItem,
 |  | MenuItem * | prevSibling,
 |  | MenuItem * | itemToAdd
 | ) |  |
bool APMenu::DynamicMenu::isMainButtonPressed ( )
inline
bool APMenu::DynamicMenu::isSelectionLocked ( )
inline
bool APMenu::DynamicMenu::isVisible ( )
protected
void APMenu::DynamicMenu::itemClicked ( MenuItem * item )
protected
bool APMenu::DynamicMenu::loadAttributes ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * attribsNode )
protected
bool APMenu::DynamicMenu::loadMenuItems | ( | MenuItem * | parentItem,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parentNode
 | ) |  |
protected
bool APMenu::DynamicMenu::loadMenuStructureFromNode ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * paramNode )
protected
bool APMenu::DynamicMenu::loadSignsFromXML ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * attribsNode )
protected
bool APMenu::DynamicMenu::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

bool APMenu::DynamicMenu::mainButtonPressed ( )
protected
bool APMenu::DynamicMenu::mainButtonReleased ( )
protected
void APMenu::DynamicMenu::menuGrid_getSize | ( | int * | columns,
 |  | int * | rows
 | ) |  |
protected
bool APMenu::DynamicMenu::pointerMoved ( osg::Vec3 * pointerPos )
protected
bool APMenu::DynamicMenu::pointerSelectItem ( MenuItem * item )
protected
bool APMenu::DynamicMenu::pointerUnselectItem ( bool bLeaveSelectedIfLocked = true )
protected
bool APMenu::DynamicMenu::pointerViewMovedHelper ( )
protected
void APMenu::DynamicMenu::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APMenu::DynamicMenu::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

bool APMenu::DynamicMenu::registerNewItemType ( MenuItem * itemTemplate )
void APMenu::DynamicMenu::resetBaseValues ( )
protected
void APMenu::DynamicMenu::sendToClickedOutput ( char * eventValue )
void APMenu::DynamicMenu::setAttribute | ( | const std::string & | name,
 |  | float | value
 | ) |  |
inline
bool APMenu::DynamicMenu::setMenuString ( const char * newMenuString )
void APMenu::DynamicMenu::setSign | ( | const std::string & | name,
 |  | const std::string & | value
 | ) |  |
bool APMenu::DynamicMenu::showChildMenu | ( | MenuItem * | parentItem,
 |  | bool | bSetNewRoot
 | ) |  |
protected
bool APMenu::DynamicMenu::showMainMenuObject ( )
protected
bool APMenu::DynamicMenu::showMenu ( osg::Vec3 * _menuPos )
void APMenu::DynamicMenu::showPointerTrail ( )
protected
bool APMenu::DynamicMenu::solvePointerSelection ( )
protected
bool APMenu::DynamicMenu::unselectItem ( )
protected
void APMenu::DynamicMenu::update ( void )
virtual

called by the VRECKO scheduler at specified frequency

Reimplemented from vrecko::BaseClass.

void APMenu::DynamicMenu::updateInverseCalc ( )
protected
void APMenu::DynamicMenu::updateMainObjectTransformation ( )
protected
void APMenu::DynamicMenu::updatePointerPosition ( )
protected
bool APMenu::DynamicMenu::viewMoved ( )
protected

Friends And Related Function Documentation

friend class MenuItem
friend

Member Data Documentation

int APMenu::DynamicMenu::activePointerID
protected
std::map<std::string, float> APMenu::DynamicMenu::attributes
protected
osg::Vec3 APMenu::DynamicMenu::autoMoveShift
protected
bool APMenu::DynamicMenu::bAllowSelectOnRelease
protected
std::string APMenu::DynamicMenu::baseDirectory
protected
bool APMenu::DynamicMenu::bMainButtonPressed
protected
osg::ref_ptr<EnvironmentObject> APMenu::DynamicMenu::dispEO
protected
osg::Matrix APMenu::DynamicMenu::inverseTransformMatrix
protected
DynamicTree<MenuItem> APMenu::DynamicMenu::itemTree
osg::Vec3 APMenu::DynamicMenu::lastPointerPos
protected
osg::Vec3 APMenu::DynamicMenu::lastViewPos
protected
osg::ref_ptr<EnvironmentObject> APMenu::DynamicMenu::mainObject
protected
int APMenu::DynamicMenu::menuGrid_columnsCached
protected
int APMenu::DynamicMenu::menuGrid_rowsCached
protected
std::string APMenu::DynamicMenu::menuString
protected
MenuType APMenu::DynamicMenu::menuType
protected
osg::Vec3 APMenu::DynamicMenu::origMenuPos
protected
osg::Vec3 APMenu::DynamicMenu::origViewLookAt
protected
osg::Vec3 APMenu::DynamicMenu::origViewPos
protected
osg::Vec3 APMenu::DynamicMenu::origViewUp
protected
osg::ref_ptr<osg::Cylinder> APMenu::DynamicMenu::osgPointerTrail
protected
osg::ref_ptr<osg::ShapeDrawable> APMenu::DynamicMenu::osgPointerTrailDrawable
protected
osg::ref_ptr<osg::Geode> APMenu::DynamicMenu::osgPointerTrailGeode
protected
osg::ref_ptr<osg::MatrixTransform> APMenu::DynamicMenu::osgPointerTrailTransform
protected
EnvironmentObject* APMenu::DynamicMenu::owner
protected
MenuItem* APMenu::DynamicMenu::pointerSelected
protected
osg::Vec3 APMenu::DynamicMenu::projPointerPos
protected
DynamicArray<MenuItem*> APMenu::DynamicMenu::registeredItemTypes
protected
MenuItem* APMenu::DynamicMenu::selectedItem
protected
osg::ref_ptr<EnvironmentObject> APMenu::DynamicMenu::shadowEO
protected
std::map<std::string, DynamicMenuSign*> APMenu::DynamicMenu::signs
protected
osg::Vec3 APMenu::DynamicMenu::transPointerPos
protected
osg::Vec3 APMenu::DynamicMenu::transViewPos
protected
MenuItem* APMenu::DynamicMenu::visibleMenuRoot
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu_XMLPart.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APMenu::MenuLoaderErrorHandler Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuLoaderErrorHandler
Public Member Functions | List of all members
APMenu::MenuLoaderErrorHandler Class Reference

#include <DynamicMenu_XMLPart.h>

Inheritance diagram for APMenu::MenuLoaderErrorHandler:

Public Member Functions

MenuLoaderErrorHandler ()
~MenuLoaderErrorHandler ()
bool | getSawErrors () const
bool | handleError (const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError)
void | resetErrors ()

Constructor & Destructor Documentation

APMenu::MenuLoaderErrorHandler::MenuLoaderErrorHandler ( )
APMenu::MenuLoaderErrorHandler::~MenuLoaderErrorHandler ( )

Member Function Documentation

bool APMenu::MenuLoaderErrorHandler::getSawErrors ( ) const
inline
bool APMenu::MenuLoaderErrorHandler::handleError ( const XERCES_CPP_NAMESPACE_QUALIFIER DOMError & domError )
void APMenu::MenuLoaderErrorHandler::resetErrors ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu_XMLPart.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu_XMLPart.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::MidpointDisplacementAlgorithm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • MidpointDisplacementAlgorithm
Public Member Functions | Static Public Attributes | List of all members
APNature::MidpointDisplacementAlgorithm Class Reference

#include <MidpointDisplacementAlgorithm.h>

Inheritance diagram for APNature::MidpointDisplacementAlgorithm:
APNature::TerrainAlgorithm

Public Member Functions

MidpointDisplacementAlgorithm (int width, int height, float cornerValueFrom, float cornerValueTo)
void | RandomizeSurfaceCorners (float cornerValueFrom, float cornerValueTo)
float * | GenerateSurfaceByMidpointDisplacement (int x1, int y1, int x2, int y2, int level)
- Public Member Functions inherited from APNature::TerrainAlgorithm
TerrainAlgorithm (int width, int height)
~TerrainAlgorithm ()
unsigned int | PointIndex (int x, int y) const
float | GetLowestValue () const
float | GetHighestValue () const

Static Public Attributes

static const int InitialLevel = 1

Additional Inherited Members

- Protected Member Functions inherited from APNature::TerrainAlgorithm
float * | Allocate (int width, int height)
void | Release ()
void | Zero ()
void | Flatten (float height)
float | GetPointHeight (int x, int y) const
void | SetPointHeight (int x, int y, float height)
- Protected Attributes inherited from APNature::TerrainAlgorithm
float * | _terrain
int | _width
int | _height

Constructor & Destructor Documentation

MidpointDisplacementAlgorithm::MidpointDisplacementAlgorithm | ( | int | width,
 |  | int | height,
 |  | float | cornerValueFrom,
 |  | float | cornerValueTo
 | ) |  |

Initializes the attributes, allocates the memory for the terrain data and sets the corner values.

Parameters
[in] | width | Size of the terrain surface to generate in X-axis.
[in] | height | Size of the terrain surface to generate in Y-axis.
[in] | cornerValueFrom | Lower boundary of the interval from which the pseudo-random values are generated.
[in] | cornerValueTo | Upper boundary of the interval from which the pseudo-random values are generated.

Member Function Documentation

float * MidpointDisplacementAlgorithm::GenerateSurfaceByMidpointDisplacement | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | int | level
 | ) |  |

Core of the algorithm - method that is applied to the points which lie in a rectangle given by two corner points and subsequently divides the rectangle in four approximately large rectangles and calls itself upon them. Recursion stops when the smaller rectangle contains no more points.

[Based] on the midpoint displacement algorithm, described e.g. in Modern Computer Graphics, p.278

Parameters
[in] | northWest | North-West corner of the rectangle in which the computation takes place.
[in] | southeEast | South-East corner of the rectangle in which the computation takes place.
Returns
Terrain surface data stored in one-dimensional array.
void MidpointDisplacementAlgorithm::RandomizeSurfaceCorners | ( | float | cornerValueFrom,
 |  | float | cornerValueTo
 | ) |  |

Randomizes the corners of the terrain surface. To each of the four corners a new pseudo-radom value from the given interval will be assigned. Positive values only.

Parameters
[in] | cornerValueFrom | Lower boundary of the interval from which the pseudo-random values are generated.
[in] | cornerValueTo | Upper boundary of the interval from which the pseudo-random values are generated.

Member Data Documentation

const int MidpointDisplacementAlgorithm::InitialLevel = 1
static
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::PerlinNoiseAlgorithm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • PerlinNoiseAlgorithm
Public Member Functions | List of all members
APNature::PerlinNoiseAlgorithm Class Reference

#include <PerlinNoiseAlgorithm.h>

Inheritance diagram for APNature::PerlinNoiseAlgorithm:
APNature::TerrainAlgorithm

Public Member Functions

PerlinNoiseAlgorithm (int width, int height)
float | GetNoise (float x, float y)
float * | GenerateNoiseTexture (float frequencyX, float frequencyY)
float * | GenerateCloudsTexture (std::size_t octaveCount, float persistence)
- Public Member Functions inherited from APNature::TerrainAlgorithm
TerrainAlgorithm (int width, int height)
~TerrainAlgorithm ()
unsigned int | PointIndex (int x, int y) const
float | GetLowestValue () const
float | GetHighestValue () const

Additional Inherited Members

- Protected Member Functions inherited from APNature::TerrainAlgorithm
float * | Allocate (int width, int height)
void | Release ()
void | Zero ()
void | Flatten (float height)
float | GetPointHeight (int x, int y) const
void | SetPointHeight (int x, int y, float height)
- Protected Attributes inherited from APNature::TerrainAlgorithm
float * | _terrain
int | _width
int | _height

Constructor & Destructor Documentation

PerlinNoiseAlgorithm::PerlinNoiseAlgorithm | ( | int | width,
 |  | int | height
 | ) |  |

Initializes the attributes and generates the gradient and permutations tables.

Parameters
[in] | width | Size of the terrain surface to generate in X-axis.
[in] | height | Size of the terrain surface to generate in Y-axis.

Member Function Documentation

float * PerlinNoiseAlgorithm::GenerateCloudsTexture | ( | std::size_t | octaveCount,
 |  | float | persistence
 | ) |  |

Generates multiple noise surfaces at different frequencies and sums them up together with different weights given by persistence. Deallocation of the noise surface is automatic after the instance is deleted. If the method is called repeatedly, previous result is rewritten. Less surfaces result in a rough terrain with a small elevation differences, more surfaces result in smoother terrain with higher elevation differences.

[Based] on a theory from Ken Perlin's talk which can be found at http://www.noisemachine.com/talk1/21.html , with some parts inspired by algorithm at http://devmag.org.za/2009/04/25/perlin-noise/ (e.g. faster squaring (<<) in case base is always 2)

Parameters
[in] | octaveCount | Number of noise surfaces which are summed up together.
[in] | persistence | Property similar to fractal dimension - the higher the persistence is, the more rough the terrain is and vice versa.
Returns
Generated noise surface in one-dimensional array of size [width * height] if allocation succeded, NULL otherwise.
float * PerlinNoiseAlgorithm::GenerateNoiseTexture | ( | float | frequencyX,
 |  | float | frequencyY
 | ) |  |

Generates a new single noise texture of a given dimensions with points sampled at given frequencies. Deallocation of the noise texture is user's resposibility.

Parameters
[in] | frequencyX | Frequency at which is noise sampled in X-axis.
[in] | frequencyY | Frequency at which is noise sampled in Y-axis.
Returns
Pointer to the newly generated noise surface in one-dimensional array of size [width * height] if allocation succeded, NULL otherwise.
float PerlinNoiseAlgorithm::GetNoise | ( | float | x,
 |  | float | y
 | ) |  |

Returns the value of perlin noise function in two dimensions for the point located at the given coordinates.

[Adapted], modified and clarified version of function noise2() from original implementation by Ken Perlin which can be found at http://www.mrl.nyu.edu/~perlin/doc/oscar.html#noise

Parameters
[in] | x | Location of the point on the X-axis.
[in] | y | Location of the point on the Y-axis.
Returns
Intensity value of the perlin noise function for the point at the given two-dimensional coordinates.
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::RandomFaultsAlgorithm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • RandomFaultsAlgorithm
Public Member Functions | List of all members
APNature::RandomFaultsAlgorithm Class Reference

#include <RandomFaultsAlgorithm.h>

Inheritance diagram for APNature::RandomFaultsAlgorithm:
APNature::TerrainAlgorithm

Public Member Functions

RandomFaultsAlgorithm (int width, int height)
float * | GenerateSurfaceByRandomFaults (int iterations, float faultValueMin, float faultValueMax)
- Public Member Functions inherited from APNature::TerrainAlgorithm
TerrainAlgorithm (int width, int height)
~TerrainAlgorithm ()
unsigned int | PointIndex (int x, int y) const
float | GetLowestValue () const
float | GetHighestValue () const

Additional Inherited Members

- Protected Member Functions inherited from APNature::TerrainAlgorithm
float * | Allocate (int width, int height)
void | Release ()
void | Zero ()
void | Flatten (float height)
float | GetPointHeight (int x, int y) const
void | SetPointHeight (int x, int y, float height)
- Protected Attributes inherited from APNature::TerrainAlgorithm
float * | _terrain
int | _width
int | _height

Constructor & Destructor Documentation

RandomFaultsAlgorithm::RandomFaultsAlgorithm | ( | int | width,
 |  | int | height
 | ) |  |

Initializes the attributes and allocates the memory for the terrain data.

Parameters
[in] | width | Size of the terrain surface to generate in X-axis.
[in] | height | Size of the terrain surface to generate in Y-axis.

Member Function Documentation

float * RandomFaultsAlgorithm::GenerateSurfaceByRandomFaults | ( | int | iterations,
 |  | float | faultValueMin,
 |  | float | faultValueMax
 | ) |  |

Generates the terrain data according to the random faults generation algorithm.

[Based] on the random faults algorithm, described e.g. in Modern Computer Graphics, p.281

Parameters
[in] | iterations | Number of iterations.
[in] | faultValueMin | Lower boundary of the interval in which the fault value is generated.
[in] | faultValueMax | Upper boundary of the interval in which the fault value is generated.
Returns
Terrain surface data stored in one-dimensional array.
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::TerrainAlgorithm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainAlgorithm
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APNature::TerrainAlgorithm Class Reference

#include <TerrainAlgorithm.h>

Inheritance diagram for APNature::TerrainAlgorithm:
APNature::MidpointDisplacementAlgorithm APNature::PerlinNoiseAlgorithm APNature::RandomFaultsAlgorithm

Public Member Functions

TerrainAlgorithm (int width, int height)
~TerrainAlgorithm ()
unsigned int | PointIndex (int x, int y) const
float | GetLowestValue () const
float | GetHighestValue () const

Protected Member Functions

float * | Allocate (int width, int height)
void | Release ()
void | Zero ()
void | Flatten (float height)
float | GetPointHeight (int x, int y) const
void | SetPointHeight (int x, int y, float height)

Protected Attributes

float * | _terrain
int | _width
int | _height

Constructor & Destructor Documentation

TerrainAlgorithm::TerrainAlgorithm | ( | int | width,
 |  | int | height
 | ) |  |

Initializes the attributes and allocates the memory for the terrain data.

Parameters
[in] | width | Size of the terrain surface to generate in X-axis.
[in] | height | Size of the terrain surface to generate in Y-axis.
TerrainAlgorithm::~TerrainAlgorithm ( )

Member Function Documentation

float * TerrainAlgorithm::Allocate | ( | int | width,
 |  | int | height
 | ) |  |
protected

Allocates the memory needed to store the terrain height values, if possible. In case there is not enough memory available, std::bac_alloc is thrown.

Parameters
[in] | width | Size of the array in X-axis.
[in] | height | Size of the array in Y-axis.
Returns
Pointer to the first byte of the allocated array if the allocation succeeded, NULL otherwise.
void TerrainAlgorithm::Flatten ( float height )
protected

Sets the same height for all of the terrain points.

Parameters
[in] height Height which is set to every point.
float TerrainAlgorithm::GetHighestValue ( ) const

Returns the value of the point with the highest value in the whole array.

Returns
The highest value from from the whole array.
float TerrainAlgorithm::GetLowestValue ( ) const

Returns the value of the point with the lowest value in the whole array.

Returns
The lowest value from from the whole array.
float APNature::TerrainAlgorithm::GetPointHeight | ( | int | x,
 |  | int | y
 | ) |  | const
 inlineprotected

Returns the height value of the point at the given coordinates.

Parameters
[in] | x | Location of the point on the X-axis.
[in] | y | Location of the point on the Y-axis.
Returns
Height value of the point at the given coordinates
unsigned int APNature::TerrainAlgorithm::PointIndex | ( | int | x,
 |  | int | y
 | ) |  | const
 inline

Returns the mapped index in the one-dimensional data array. [in] X-coordinate [in] Y-coordinate

Returns
Mapped index in the one-dimensional data array.
void TerrainAlgorithm::Release ( )
protected

Releases all memory previously used by the object instance which was not deallocated yet.

void APNature::TerrainAlgorithm::SetPointHeight | ( | int | x,
 |  | int | y,
 |  | float | height
 | ) |  |
inlineprotected

Sets the height value of the point at the given coordinates.

Parameters
[in] | x | Location of the point on the X-axis.
[in] | y | Location of the point on the Y-axis.
[in] | height | Height value of the point at the given coordinates
void TerrainAlgorithm::Zero ( )
protected

Fills all of the terrain values with zeroes.

Member Data Documentation

int APNature::TerrainAlgorithm::_height
protected
float* APNature::TerrainAlgorithm::_terrain
protected
int APNature::TerrainAlgorithm::_width
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::Terrain2D Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • Terrain2D
Public Member Functions | List of all members
APNature::Terrain2D Class Reference

2D terrain based on height map which consists of multiple equally large segments. More...

#include <Terrain2D.h>

Public Member Functions

Terrain2D (void)
~Terrain2D (void)
osg::ref_ptr< osg::Group > | GetTerrainGroup () const
const osg::Vec3f & | GetPoint (int x, int y) const
void | SetPoint (int x, int y, const osg::Vec3f &point)
float | GetPointHeight (int x, int y) const
void | SetPointHeight (int x, int y, float height)
bool | ImportFromHeightMap (const std::string &path)
void | GenerateByRandomFaultsAlgorithm (int iterations, float faultValueMin, float faultValueMax)
void | GenerateByMidpointDisplacementAlgorithm (float cornerValueFrom, float cornerValueTo)
void | GenerateByPerlinNoiseAlgorithm (float persistence, int octaveCount)
void | Flatten (float height)
void | Export (FileTypeExport fileType)
void | Preprocessing ()
void | Postprocessing ()

Detailed Description

2D terrain based on height map which consists of multiple equally large segments.

Constructor & Destructor Documentation

Terrain2D::Terrain2D ( void )

Initializes the whole terrain object.

  • zeroes the segments pointer
  • initializes the terrain group node
Terrain2D::~Terrain2D ( void )

Releases all memory allocated by the object.

Member Function Documentation

void Terrain2D::Export ( FileTypeExport fileType )

Exports the whole terrain and all of its segments to the file on the disk with path and filetype specified by XML properties.

Parameters
[in] fileType Enumeration determining fileformat in which the terrain node is saved onto the disk.
void Terrain2D::Flatten ( float height )

Sets the same height of the terrain to all points in all segments. [in] Height which is set to every point in all segments.

void Terrain2D::GenerateByMidpointDisplacementAlgorithm | ( | float | cornerValueFrom,
 |  | float | cornerValueTo
 | ) |  |

Generates the terrain data according to the midpoint displacement generation algorithm.

Parameters
[in] | fractalDimension | Fractal dimension of the generated terrain surface.
[in] | cornerValueFrom | Lower boundary of the interval in which the corner value is generated.
[in] | cornerValueTo | Upper boundary of the interval in which the corner value is generated.
void Terrain2D::GenerateByPerlinNoiseAlgorithm | ( | float | persistence,
 |  | int | octaveCount
 | ) |  |

Generates the terrain data according to the Perlin noise algorithm.

Parameters
[in] | persistence | Property similar to fractal dimension - the higher the persistence is, the more rough the terrain is and vice versa.
[in] | octaveCount | Number of noise surfaces which are summed up together.
void Terrain2D::GenerateByRandomFaultsAlgorithm | ( | int | iterations,
 |  | float | faultValueMin,
 |  | float | faultValueMax
 | ) |  |

Generates the terrain data according to the random faults generation algorithm.

Parameters
[in] | iterations | Number of iterations of the algorithm.
[in] | faultValueMin | Lower boundary of the interval in which the fault value is generated.
[in] | faultValueMax | Upper boundary of the interval in which the fault value is generated.
const osg::Vec3f & Terrain2D::GetPoint | ( | int | x,
 |  | int | y
 | ) |  | const

Returns a point from the whole terrain surface.

Parameters
[in] | x | Coordinate of the point on the X-axis.
[in] | y | Coordinate of the point on the Y-axis.
Returns
Point from the terrain surface.
float Terrain2D::GetPointHeight | ( | int | x,
 |  | int | y
 | ) |  | const

Height value of the point at the given coordinates.

Parameters
[in] | x | Coordinate of the point on the X-axis.
[in] | y | Coordinate of the point on the Y-axis.
Returns
Height value of the point at the given coordinates.
osg::ref_ptr<osg::Group> APNature::Terrain2D::GetTerrainGroup ( ) const
inline

Return the OSG Geode containing the whole 2D terrain.

Returns
OSG Geode containing the whole 2D terrain.
bool Terrain2D::ImportFromHeightMap ( const std::string & path )

Loads the terrain data from the source image with values based on the intensity values in the specific channel(s). [in] Path to the source heightmap from which the terrain data are loaded.

Returns
TRUE if everything succeeded, FALSE otherwise.
void Terrain2D::Postprocessing ( )

Computes the normals for every point of every terrain segment and adds all of the terrain segments to terrain group.

void Terrain2D::Preprocessing ( )

Allocates all terrain segments and their points, and initializes their values (e.g. proper point position) and initializes neighbour connections among the terrain segments.

void Terrain2D::SetPoint | ( | int | x,
 |  | int | y,
 |  | const osg::Vec3f & | point
 | ) |  |

Changes value of a point in a terrain surface

Parameters
[in] | x | Coordinate of the point on the X-axis.
[in] | y | Coordinate of the point on the Y-axis.
[in] | point | New point that will replace the old one in the terrain surface.
void Terrain2D::SetPointHeight | ( | int | x,
 |  | int | y,
 |  | float | height
 | ) |  |

Changes only the height value of the point at the given coordinates, leaving other two coordinates unchanged.

Parameters
[in] | x | Coordinate of the point on the X-axis.
[in] | y | Coordinate of the point on the Y-axis.
[in] | height | New height value of the given point.
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2D.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Terrain2D.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::Terrain2DSegment Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • Terrain2DSegment
Public Member Functions | Friends | List of all members
APNature::Terrain2DSegment Class Reference

Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point. More...

#include <Terrain2DSegment.h>

Public Member Functions

Terrain2DSegment ()
~Terrain2DSegment (void)
int | Width () const
int | Height () const
const Terrain2DSegment * | GetNeighbourNorth () const
const Terrain2DSegment * | GetNeighbourSouthh () const
const Terrain2DSegment * | GetNeighbourWest () const
const Terrain2DSegment * | GetNeighbourEast () const
bool | IsNeighbourNorth () const
bool | IsNeighbourSouth () const
bool | IsNeighbourWest () const
bool | IsNeighbourEast () const
osg::ref_ptr< osg::Geode > | GetTerrainSegmentGeode () const
const osg::Vec3f & | GetPoint (int x, int y) const
void | SetPoint (int x, int y, const osg::Vec3f &point)
void | SetSegmentPosition (const osg::Vec2f &position)
void | InitializeGeode ()
void | Flatten (float height)

Friends

class Terrain2D

Detailed Description

Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point.

Constructor & Destructor Documentation

Terrain2DSegment::Terrain2DSegment ( )

Default constructor - initializes the default safe values for the inner variables.

APNature::Terrain2DSegment::~Terrain2DSegment ( void )
inline

Default destructor - Releases all memory used by object.

Member Function Documentation

void Terrain2DSegment::Flatten ( float height )

Sets the same height of the terrain in the whole segment. [in] Height which is set to every point in the segment.

const Terrain2DSegment* APNature::Terrain2DSegment::GetNeighbourEast ( ) const
inline
const Terrain2DSegment* APNature::Terrain2DSegment::GetNeighbourNorth ( ) const
inline
const Terrain2DSegment* APNature::Terrain2DSegment::GetNeighbourSouthh ( ) const
inline
const Terrain2DSegment* APNature::Terrain2DSegment::GetNeighbourWest ( ) const
inline
const osg::Vec3f& APNature::Terrain2DSegment::GetPoint | ( | int | x,
 |  | int | y
 | ) |  | const
 inline

Returns an address of a single point of the terrain. [in] Coordinate of the point in the segment in the X-axis. [in] Coordinate of the point in the segment in the Y-axis.

Returns
Address of the point of the segment.
osg::ref_ptr<osg::Geode> APNature::Terrain2DSegment::GetTerrainSegmentGeode ( ) const
inline

Returns the OSG Geode of the 2D terrain segment.

Returns
OSG Geode of the 2D terrain segment.
int APNature::Terrain2DSegment::Height ( ) const
inline

Actual height (north <-> south distance) of the segment in vertices.

Returns
Height of the terrain in vertices.
void Terrain2DSegment::InitializeGeode ( )

Initializes the segment geode.

bool APNature::Terrain2DSegment::IsNeighbourEast ( ) const
inline
bool APNature::Terrain2DSegment::IsNeighbourNorth ( ) const
inline
bool APNature::Terrain2DSegment::IsNeighbourSouth ( ) const
inline
bool APNature::Terrain2DSegment::IsNeighbourWest ( ) const
inline
void APNature::Terrain2DSegment::SetPoint | ( | int | x,
 |  | int | y,
 |  | const osg::Vec3f & | point
 | ) |  |
inline

Sets the new value of the given point in the segment. [in] Coordinate of the point in the segment in the X-axis. [in] Coordinate of the point in the segment in the Y-axis. [in] New value of terrain point.

void Terrain2DSegment::SetSegmentPosition ( const osg::Vec2f & position )

Sets the new position of the terrain segment, located in the most NW corner of the segment. Additionally recomputes the position of all segment points. [in] New position of the terrain segment in the XZ plane (in OSG coordinates) which is located in the NW corner of the segment.

int APNature::Terrain2DSegment::Width ( ) const
inline

Actual width (west <-> east distance) of the segment in vertices.

Returns
Width of the terrain in vertices.

Friends And Related Function Documentation

friend class Terrain2D
friend
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2DSegment.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Terrain2DSegment.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::TerrainAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainAbility
Public Member Functions | List of all members
APNature::TerrainAbility Class Reference

#include <TerrainAbility.h>

Inheritance diagram for APNature::TerrainAbility:
vrecko::Ability vrecko::BaseClass

Public Member Functions

TerrainAbility ()
~TerrainAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
void | InitializeMenu ()
void | BuildMenuLayouts ()
std::string | CreateMenuStructure ()
void | GuiItemClicked (const char *itemID)
void | MenuSliderChanged (const char *sliderID, float sliderPos)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

TerrainAbility::TerrainAbility ( )
APNature::TerrainAbility::~TerrainAbility ( )
inline

Member Function Documentation

void TerrainAbility::BuildMenuLayouts ( )

Builds all menu layouts which are needed for later use.

std::string TerrainAbility::CreateMenuStructure ( )

Creates the menu before it is shown on screen.

Returns
The whole menu in XML one string.
void TerrainAbility::GuiItemClicked ( const char * itemID )

Called whenever a used clicks on a menu button.

Parameters
[in] itemID Name of the item on which user clicked - should be unique.
bool TerrainAbility::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Initializes the whole ability.

Parameters
[in] parameters Appropriate sub-node of parsed XML file with the parameters of the ability.

Reimplemented from vrecko::BaseClass.

void TerrainAbility::InitializeMenu ( )

Menu methods Initializes the menu, GuiController, and registers it in VRECKO. Black magic.

void TerrainAbility::MenuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |

Called whenever the barrel of any slider is moved.

Parameters
[in] | sliderID | Name of the slider which is being modified - should be unique.
[in] | sliderPos | New value of the slider.
void TerrainAbility::update ( void )
virtual

Updates the terrain on a regular basis or when a specific event occurs.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainAbility.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainAbility.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::TerrainRandom Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainRandom
Static Public Member Functions | List of all members
APNature::TerrainRandom Class Reference

#include <TerrainRandom.h>

Static Public Member Functions

static float | GetRandomFloatUniform (float from, float to)
static float | GetRandomFloatGaussian (float mean, float standardDeviation)
static float | GetRandomFloatGaussianBasedOnPointDistance (int x1, int y1, int x2, int y2)

Member Function Documentation

float TerrainRandom::GetRandomFloatGaussian | ( | float | mean,
 |  | float | standardDeviation
 | ) |  |
static

Returns a pseudo-random float given by a normal distribution specified by its statistical parameters. Based on the Marsaglia polar method (more efficient Box-Muller algorithm).

[Inspired] by sample implementation from http://en.wikipedia.org/wiki/Marsaglia_polar_method

Parameters
[in] | mean | Mean value of the normal distribution.
[in] | standardDeviation | Standard deviation of the normal distribution.
[in] | Pseudo-random | float given by normal distribution.
float TerrainRandom::GetRandomFloatGaussianBasedOnPointDistance | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2
 | ) |  |
static

Return a pseudo-random gaussian number with a normal distribution with standard deviation proportionate to the point distance on the surface. The closer the points are, the smaller the standard deviation is and vice versa.

[Corrected] formula taken from Modern Computer Graphics (2004), page 279.

Parameters
[in] | x1 | X-coordinate of the first point.
[in] | y1 | Y-coordinate of the first point.
[in] | x2 | X-coordinate of the second point.
[in] | y2 | Y-coordinate of the second point.
Returns
Pseudo-random float generated with normal distribution dependent on point distance.
static float APNature::TerrainRandom::GetRandomFloatUniform | ( | float | from,
 |  | float | to
 | ) |  |
inlinestatic

Returns a pseudo-random float from the interval given by its boundaries (boundaries included) with a uniform probability distribution. Sampling of the float values depends on value RAND_MAX from the standard library (theoretically RAND_MAX possible results).

Parameters
[in] | from | Lower interval boundary.
[in] | to | Upper interval boundary.
Returns
Pseudo-random float from the interval given by its boundaries.
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainRandom.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainRandom.cpp
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: APNature::TerrainUtility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainUtility
Static Public Member Functions | List of all members
APNature::TerrainUtility Class Reference

#include <TerrainUtility.h>

Static Public Member Functions

static void | Info (const std::string &message)
static void | Error (const std::string &message)
static void | SetPointHeight (osg::Vec3 &point, float height)
static std::string | LowerCase (const std::string &input)
static std::string | UpperCase (const std::string &input)
static int | GreatestCommonDivisor (int x, int y)
static float | LinearMapping (float fromMin, float fromMax, float fromX, float toMin, float toMax)
static void | ListDirectory (const std::string &dirpath, const std::string &mask, std::vector< std::string > *fileNames)

Member Function Documentation

void TerrainUtility::Error ( const std::string & message )
static

Prints the given error message in a unified format.

Parameters
[in] message Message to be printed.
int TerrainUtility::GreatestCommonDivisor | ( | int | x,
 |  | int | y
 | ) |  |
static

Computes the greatest common divisor - based on the well-known euclidian algorithm.

[Based] on a well-known Euclidean algorithm

Parameters
[in] | x | The first number
[in] | y | The second number
Returns
Greatest common divisor of the input numbers 'x' and 'y'
void TerrainUtility::Info ( const std::string & message )
static

Prints the given informative message in a unified format.

Parameters
[in] message Message to be printed.
static float APNature::TerrainUtility::LinearMapping | ( | float | fromMin,
 |  | float | fromMax,
 |  | float | fromX,
 |  | float | toMin,
 |  | float | toMax
 | ) |  |
inlinestatic

Computes the linear mapping between two real intervals.

Parameters
[in] | fromMin | Lower boundary of the source interval.
[in] | fromMax | Upper boundary of the source interval.
[in] | fromX | Source value, which will be linearly mapped from source to destination interval.
[in] | toMin | Lower boundary of the destination interval.
[in] | toMax | Upper boundary of the destination interval.
void TerrainUtility::ListDirectory | ( | const std::string & | dirpath,
 |  | const std::string & | mask,
 |  | std::vector< std::string > * | fileNames
 | ) |  |
static

Returns all files from the given directory complying the given mask. [Written] by Jiri Chmelik. Copied from DynamicArt/Common/DAEnvironment.{h|cpp} until both methods are moved to vreckoUtils.

Parameters
[in] | dirpath | Directory in which the search is executed.
[in] | mask | Fileformat mask, e.g. "*.png" finds all PNG files.
[in,out] | fileNames | Valid pointer to vector in which all found results should be stored.
std::string TerrainUtility::LowerCase ( const std::string & input )
static

Returns the copy of the input string in which all characters are lowercase.

Parameters
[in] input Input string to be converted to lowercase. Original string remains unchanged.
Returns
Copy of the original string with all characters converted to lowercase.
static void APNature::TerrainUtility::SetPointHeight | ( | osg::Vec3 & | point,
 |  | float | height
 | ) |  |
inlinestatic

Sets the Y value of the given osg::Vec3 instance to the given value.

Parameters
[in] | point | Point the Y value of which is to be changed.
[in] | height | Desired Y value which is to be placed in the osg::Vec3 given instance.
std::string TerrainUtility::UpperCase ( const std::string & input )
static

Returns the copy of the input string in which all characters are uppercase.

Parameters
[in] input Input string to be converted to uppercase. Original string remains unchanged.
Returns
Copy of the original string with all characters converted to uppercase.
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainUtility.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainUtility.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::Animator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • Animator
Classes | Public Types | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::Animator Class Reference

#include <Animator.h>

Inheritance diagram for APObjectUtils::Animator:
vrecko::Ability vrecko::BaseClass

Classes

class AnimationPoint

Public Types

enum | AnimationTypes { AnimSRT = 1, AnimAlpha = 2, AnimNodeMask = 4 }
enum | LoopType { NoLoop, Simple, BiDi }
enum | InterpolationType { Linear, Sine }
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

Animator ()
virtual | ~Animator ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual void | clean ()
bool | removeAnimation ()
bool | isAnimating ()
bool | stopAnimation ()
bool | startAnimation ()
bool | animateToPoint (int pointIndex)
bool | resetToPos (float fPos)
bool | setAnimationPointsNumber (unsigned int number)
unsigned int | getAnimationPointsNumber ()
bool | setEnabledAnimations (unsigned long dwAnimations)
unsigned long | getEnabledAnimations ()
bool | setTranslation (int pointIndex, const osg::Vec3 &trans)
osg::Vec3 & | getTranslation (int pointIndex)
bool | setRotation (int pointIndex, const osg::Quat &rot)
osg::Quat & | getRotation (int pointIndex)
bool | setScale (int pointIndex, const osg::Vec3 &scale)
osg::Vec3 & | getScale (int pointIndex)
bool | setAlpha (int pointIndex, float alpha)
float | getAlpha (int pointIndex)
bool | setNodeMask (int pointIndex, osg::Node::NodeMask nodeMask)
osg::Node::NodeMask | getNodeMask (int pointIndex)
bool | setTimePerLoop (float timeInS)
float | getTimePerLoop ()
bool | setLoopType (LoopType newType)
LoopType getLoopType ()
bool | setInterpolationType (InterpolationType newType)
InterpolationType getInterpolationType ()
bool | setTransformationFromMatrix (int startPointIndex, int endPointIndex, const osg::Matrix &matrix)
bool | getAnimMatrix (float fActPos, osg::Matrix &outMatrix)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static Animator * | getAnimatorOnObject (vrecko::EnvironmentObject *object)
static Animator * | addAnimatorToObject (vrecko::EnvironmentObject *object, bool bReuseOldIfPossible=true)

Protected Member Functions

float | convertActTimeToActPos ()
float | convertActPosToNormPos (float fActPos, int *outPoint1, int *outPoint2)
bool | updateActTime ()
bool | updateAnimation (float fActPos)
bool | calcAnimMatrix (float fNormPos, int iPoint1, int iPoint2, osg::Matrix &outMatrix)
DECLARE_INPUT (Trigger, MessageVoid)
DECLARE_INPUT (AnimateToPoint, MessageInt)
DECLARE_OUTPUT (AnimationEnded, MessageBool)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
unsigned int | enabledAnimations
LoopType loopType
InterpolationType interpolationType
DynamicArray< AnimationPoint > points
osg::ref_ptr< osg::StateSet > | stateSet
float | timePerLoop
bool | bAnimating
float | fActTime
int | iActDir
osg::Timer_t | lastTimerTick
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Enumeration Documentation

enum APObjectUtils::Animator::AnimationTypes
Enumerator
AnimSRT
AnimAlpha
AnimNodeMask
enum APObjectUtils::Animator::InterpolationType
Enumerator
Linear
Sine
enum APObjectUtils::Animator::LoopType
Enumerator
NoLoop
Simple
BiDi

Constructor & Destructor Documentation

ANIMATOR_IMP_EXP APObjectUtils::Animator::Animator ( )
ANIMATOR_IMP_EXP APObjectUtils::Animator::~Animator ( )
virtual

Member Function Documentation

ANIMATOR_IMP_EXP Animator * APObjectUtils::Animator::addAnimatorToObject | ( | vrecko::EnvironmentObject * | object,
 |  | bool | bReuseOldIfPossible = true
 | ) |  |
static
bool APObjectUtils::Animator::animateToPoint ( int pointIndex )
bool APObjectUtils::Animator::calcAnimMatrix | ( | float | fNormPos,
 |  | int | iPoint1,
 |  | int | iPoint2,
 |  | osg::Matrix & | outMatrix
 | ) |  |
protected
ANIMATOR_IMP_EXP void APObjectUtils::Animator::clean ( void )
virtual

Reimplemented from vrecko::Ability.

float APObjectUtils::Animator::convertActPosToNormPos | ( | float | fActPos,
 |  | int * | outPoint1,
 |  | int * | outPoint2
 | ) |  |
protected
ANIMATOR_IMP_EXP float APObjectUtils::Animator::convertActTimeToActPos ( )
protected
APObjectUtils::Animator::DECLARE_INPUT | ( | Trigger | ,
 |  | MessageVoid |
 | ) |  |
protected
APObjectUtils::Animator::DECLARE_INPUT | ( | AnimateToPoint | ,
 |  | MessageInt |
 | ) |  |
protected
APObjectUtils::Animator::DECLARE_OUTPUT | ( | AnimationEnded | ,
 |  | MessageBool |
 | ) |  |
protected
ANIMATOR_IMP_EXP float APObjectUtils::Animator::getAlpha ( int pointIndex )
unsigned int APObjectUtils::Animator::getAnimationPointsNumber ( )
inline
ANIMATOR_IMP_EXP Animator * APObjectUtils::Animator::getAnimatorOnObject ( vrecko::EnvironmentObject * object )
static
bool APObjectUtils::Animator::getAnimMatrix | ( | float | fActPos,
 |  | osg::Matrix & | outMatrix
 | ) |  |
unsigned long APObjectUtils::Animator::getEnabledAnimations ( )
inline
InterpolationType APObjectUtils::Animator::getInterpolationType ( )
inline
LoopType APObjectUtils::Animator::getLoopType ( )
inline
ANIMATOR_IMP_EXP osg::Node::NodeMask APObjectUtils::Animator::getNodeMask ( int pointIndex )
ANIMATOR_IMP_EXP osg::Quat & APObjectUtils::Animator::getRotation ( int pointIndex )
inline
ANIMATOR_IMP_EXP osg::Vec3 & APObjectUtils::Animator::getScale ( int pointIndex )
float APObjectUtils::Animator::getTimePerLoop ( )
inline
ANIMATOR_IMP_EXP osg::Vec3 & APObjectUtils::Animator::getTranslation ( int pointIndex )
bool APObjectUtils::Animator::isAnimating ( )
inline
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

ANIMATOR_IMP_EXP void APObjectUtils::Animator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool APObjectUtils::Animator::removeAnimation ( )
bool APObjectUtils::Animator::resetToPos ( float fPos )
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setAlpha | ( | int | pointIndex,
 |  | float | alpha
 | ) |  |
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setAnimationPointsNumber ( unsigned int number )
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setEnabledAnimations ( unsigned long dwAnimations )
bool APObjectUtils::Animator::setInterpolationType ( InterpolationType newType )
inline
bool APObjectUtils::Animator::setLoopType ( LoopType newType )
inline
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setNodeMask | ( | int | pointIndex,
 |  | osg::Node::NodeMask | nodeMask
 | ) |  |
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setRotation | ( | int | pointIndex,
 |  | const osg::Quat & | rot
 | ) |  |
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setScale | ( | int | pointIndex,
 |  | const osg::Vec3 & | scale
 | ) |  |
bool APObjectUtils::Animator::setTimePerLoop ( float timeInS )
inline
bool APObjectUtils::Animator::setTransformationFromMatrix | ( | int | startPointIndex,
 |  | int | endPointIndex,
 |  | const osg::Matrix & | matrix
 | ) |  |
ANIMATOR_IMP_EXP bool APObjectUtils::Animator::setTranslation | ( | int | pointIndex,
 |  | const osg::Vec3 & | trans
 | ) |  |
bool APObjectUtils::Animator::startAnimation ( )
bool APObjectUtils::Animator::stopAnimation ( )
ANIMATOR_IMP_EXP void APObjectUtils::Animator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

bool APObjectUtils::Animator::updateActTime ( )
protected
bool APObjectUtils::Animator::updateAnimation ( float fActPos )
protected

Member Data Documentation

bool APObjectUtils::Animator::bAnimating
protected
unsigned int APObjectUtils::Animator::enabledAnimations
protected
float APObjectUtils::Animator::fActTime
protected
int APObjectUtils::Animator::iActDir
protected
InterpolationType APObjectUtils::Animator::interpolationType
protected
osg::Timer_t APObjectUtils::Animator::lastTimerTick
protected
LoopType APObjectUtils::Animator::loopType
protected
EnvironmentObject* APObjectUtils::Animator::owner
protected
DynamicArray<AnimationPoint> APObjectUtils::Animator::points
protected
osg::ref_ptr<osg::StateSet> APObjectUtils::Animator::stateSet
protected
float APObjectUtils::Animator::timePerLoop
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/Animator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/Animator.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::Animator::AnimationPoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • Animator
  • AnimationPoint
Public Member Functions | Public Attributes | List of all members
APObjectUtils::Animator::AnimationPoint Class Reference

#include <Animator.h>

Public Member Functions

AnimationPoint ()

Public Attributes

osg::Vec3 | translation
osg::Quat | rotation
osg::Vec3 | scale
float | fAlpha
osg::Node::NodeMask | nodeMask

Constructor & Destructor Documentation

APObjectUtils::Animator::AnimationPoint::AnimationPoint ( )

Member Data Documentation

float APObjectUtils::Animator::AnimationPoint::fAlpha
osg::Node::NodeMask APObjectUtils::Animator::AnimationPoint::nodeMask
osg::Quat APObjectUtils::Animator::AnimationPoint::rotation
osg::Vec3 APObjectUtils::Animator::AnimationPoint::scale
osg::Vec3 APObjectUtils::Animator::AnimationPoint::translation
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/Animator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/Animator.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ConnectionViz Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ConnectionViz
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ConnectionViz Class Reference

#include <ConnectionViz.h>

Inheritance diagram for APObjectUtils::ConnectionViz:
vrecko::Ability vrecko::BaseClass

Classes

class Connection

Public Member Functions

ConnectionViz ()
virtual | ~ConnectionViz ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual void | clean ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | createConnection (Connection::ConnectionType cType, const char *sender, const char *receiver, unsigned int dwFlags)
void | deleteConnection (int iIndex)
bool | createMainObject ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
bool | bOnlyOutput
bool | bColorize
osg::ref_ptr< EnvironmentObject > | graphicObject
osg::ref_ptr< osg::Geode > | osgGeode
DynamicArray< Connection > cons
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::ConnectionViz::ConnectionViz ( )
APObjectUtils::ConnectionViz::~ConnectionViz ( )
virtual

Member Function Documentation

void APObjectUtils::ConnectionViz::clean ( void )
virtual

Reimplemented from vrecko::Ability.

int APObjectUtils::ConnectionViz::createConnection | ( | Connection::ConnectionType | cType,
 |  | const char * | sender,
 |  | const char * | receiver,
 |  | unsigned int | dwFlags
 | ) |  |
protected
bool APObjectUtils::ConnectionViz::createMainObject ( )
protected
void APObjectUtils::ConnectionViz::deleteConnection ( int iIndex )
protected
bool APObjectUtils::ConnectionViz::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ConnectionViz::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ConnectionViz::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ConnectionViz::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool APObjectUtils::ConnectionViz::bColorize
protected
bool APObjectUtils::ConnectionViz::bOnlyOutput
protected
DynamicArray<Connection> APObjectUtils::ConnectionViz::cons
protected
osg::ref_ptr<EnvironmentObject> APObjectUtils::ConnectionViz::graphicObject
protected
osg::ref_ptr<osg::Geode> APObjectUtils::ConnectionViz::osgGeode
protected
EnvironmentObject* APObjectUtils::ConnectionViz::owner
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ConnectionViz.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ConnectionViz.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ConnectionViz::Connection Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ConnectionViz
  • Connection
Public Types | Public Attributes | List of all members
APObjectUtils::ConnectionViz::Connection Class Reference

#include <ConnectionViz.h>

Public Types

enum ConnectionType { Input, Output, InputRequest, OutputRequest }

Public Attributes

Ability * ability
ConnectionType type
unsigned long | dwFlags
std::string | pinName
bool | bUsedInUpdate
osg::ref_ptr< osg::Cone > | shapeCone
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw

Member Enumeration Documentation

enum APObjectUtils::ConnectionViz::Connection::ConnectionType
Enumerator
Input
Output
InputRequest
OutputRequest

Member Data Documentation

Ability* APObjectUtils::ConnectionViz::Connection::ability
bool APObjectUtils::ConnectionViz::Connection::bUsedInUpdate
unsigned long APObjectUtils::ConnectionViz::Connection::dwFlags
std::string APObjectUtils::ConnectionViz::Connection::pinName
osg::ref_ptr<osg::Cone> APObjectUtils::ConnectionViz::Connection::shapeCone
osg::ref_ptr<osg::ShapeDrawable> APObjectUtils::ConnectionViz::Connection::shapeDraw
ConnectionType APObjectUtils::ConnectionViz::Connection::type
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ConnectionViz.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::CopyProperties Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • CopyProperties
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::CopyProperties Class Reference

#include <CopyProperties.h>

Inheritance diagram for APObjectUtils::CopyProperties:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CopyProperties ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | setProperties (unsigned int dwNewCopiedProperties)
unsigned int | getProperties (void)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

unsigned long | dwCopyEO
unsigned int | dwCopiedProperties
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::CopyProperties::CopyProperties ( )

Member Function Documentation

unsigned int APObjectUtils::CopyProperties::getProperties ( void )
inlineprotected
bool APObjectUtils::CopyProperties::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APObjectUtils::CopyProperties::setProperties ( unsigned int dwNewCopiedProperties )
protected
void APObjectUtils::CopyProperties::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

unsigned int APObjectUtils::CopyProperties::dwCopiedProperties
protected
unsigned long APObjectUtils::CopyProperties::dwCopyEO
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/CopyProperties.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/CopyProperties.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::KeepOnScreen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • KeepOnScreen
Public Member Functions | Protected Attributes | List of all members
APObjectUtils::KeepOnScreen Class Reference

#include <KeepOnScreen.h>

Inheritance diagram for APObjectUtils::KeepOnScreen:
vrecko::Ability vrecko::BaseClass

Public Member Functions

KeepOnScreen ()
virtual | ~KeepOnScreen ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual void | clean ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

EnvironmentObject * owner
float | posX
float | posY
float | depth
bool | bRelativeToBoundingBox
float | horizAlign
float | vertAlign
float | scale
bool | bDontRotate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

APObjectUtils::KeepOnScreen::KeepOnScreen ( )
APObjectUtils::KeepOnScreen::~KeepOnScreen ( )
virtual

Member Function Documentation

void APObjectUtils::KeepOnScreen::clean ( void )
virtual

Reimplemented from vrecko::Ability.

bool APObjectUtils::KeepOnScreen::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APObjectUtils::KeepOnScreen::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APObjectUtils::KeepOnScreen::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool APObjectUtils::KeepOnScreen::bDontRotate
protected
bool APObjectUtils::KeepOnScreen::bRelativeToBoundingBox
protected
float APObjectUtils::KeepOnScreen::depth
protected
float APObjectUtils::KeepOnScreen::horizAlign
protected
EnvironmentObject* APObjectUtils::KeepOnScreen::owner
protected
float APObjectUtils::KeepOnScreen::posX
protected
float APObjectUtils::KeepOnScreen::posY
protected
float APObjectUtils::KeepOnScreen::scale
protected
float APObjectUtils::KeepOnScreen::vertAlign
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/KeepOnScreen.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/KeepOnScreen.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ObjectEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectEffect
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ObjectEffect Class Reference

#include <ObjectEffect.h>

Inheritance diagram for APObjectUtils::ObjectEffect:
vrecko::Ability vrecko::BaseClass

Public Types

enum EffectType {
None, BoundingSphere, BoundingBox, Transparency,
Colorize, Collisions, SphereBVH, SNCH,
SNCHFaceGroups, VertexNormals, FaceNormals, TransparencyOnTop,
ColorizeOnTop, VoxelGrid, VoxelGridCollisions, PointShell,
DoubleSided, PolygonNormals
}
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

ObjectEffect ()
virtual | ~ObjectEffect ()
virtual void | preInitialize ()
called as the first initialization method, before loadXMLParameters More...
virtual void | postInitialize ()
called as the last initialization method, after loadXMLParameters More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
loads XML parameters from given node More...
virtual void | update ()
called by the VRECKO scheduler at specified frequency More...
virtual void | clean ()
called mostly by the VRECKO to handle some received event More...
void | setEffectType (EffectType newType)
EffectType | getEffectType (void)
bool | isEffectCreated ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | getLevelMin ()
int | getLevelMax ()
void | setLevelMinMax (int newLevelMin, int newLevelMax)
void | createEffect ()
bool | createEffect_SphereHierarchy_ProcessLevel (vrecko::Ability *dataAbility, void *node, int iCurrentLevel)
bool | createEffect_PointShellHierarchy_ProcessLevel (vrecko::Ability *dataAbility, void *node, int iCurrentLevel, bool draw)
bool | draw_Effect_PointShellHierarchy_Node (vrecko::Ability *dataAbility, void *node, int iCurrentLevel)
bool | createEffect_Lines (vrecko::Ability *dataAbility)
bool | createEffect_Reconstruction (vrecko::Ability *dataAbility)
bool | createEffect_VoxelGrid (vrecko::Ability *dataAbility)
void | destroyEffect ()
void | HSVtoRGB (float *r, float *g, float *b, float h, float s, float v)
DECLARE_INPUT (ShiftLevels, MessageInt)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EffectType effectType
bool | bEffectCreated
int | iDistanceFieldValue
osg::Vec4 | color
int | iLevelMin
int | iLevelMax
float | fRadius
bool | bShowLeafInLevelNotReached
bool | bCollisions_NoCalculation
osg::ref_ptr< EnvironmentObject > | graphicObject
osg::ref_ptr< osg::Geode > | osgGeode
osg::ref_ptr
< osg::MatrixTransform > 		osgTransform
osg::ref_ptr< osg::Sphere > | shapeSphere
osg::ref_ptr< osg::Box > | shapeBox
osg::ref_ptr< osg::ShapeDrawable > | shapeDraw
std::vector< osg::ref_ptr
< osg::ShapeDrawable > > 		shapeDrawables
osg::ref_ptr< osg::StateSet > | originalStateSet
COLLISIONS_INFO_VECTOR * colInfo
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Enumeration Documentation

enum APObjectUtils::ObjectEffect::EffectType
Enumerator
None
BoundingSphere
BoundingBox
Transparency
Colorize
Collisions
SphereBVH
SNCH
SNCHFaceGroups
VertexNormals
FaceNormals
TransparencyOnTop
ColorizeOnTop
VoxelGrid
VoxelGridCollisions
PointShell
DoubleSided
PolygonNormals

Constructor & Destructor Documentation

APObjectUtils::ObjectEffect::ObjectEffect ( )
APObjectUtils::ObjectEffect::~ObjectEffect ( )
virtual

Member Function Documentation

void APObjectUtils::ObjectEffect::clean ( void )
virtual

called mostly by the VRECKO to handle some received event

called when the ability is removed from the object

Reimplemented from vrecko::Ability.

void APObjectUtils::ObjectEffect::createEffect ( )
protected
bool APObjectUtils::ObjectEffect::createEffect_Lines ( vrecko::Ability * dataAbility )
protected
bool APObjectUtils::ObjectEffect::createEffect_PointShellHierarchy_ProcessLevel | ( | vrecko::Ability * | dataAbility,
 |  | void * | node,
 |  | int | iCurrentLevel,
 |  | bool | draw
 | ) |  |
protected
bool APObjectUtils::ObjectEffect::createEffect_Reconstruction ( vrecko::Ability * dataAbility )
protected
bool APObjectUtils::ObjectEffect::createEffect_SphereHierarchy_ProcessLevel | ( | vrecko::Ability * | dataAbility,
 |  | void * | node,
 |  | int | iCurrentLevel
 | ) |  |
protected
bool APObjectUtils::ObjectEffect::createEffect_VoxelGrid ( vrecko::Ability * dataAbility )
protected
APObjectUtils::ObjectEffect::DECLARE_INPUT | ( | ShiftLevels | ,
 |  | MessageInt |
 | ) |  |
protected
void APObjectUtils::ObjectEffect::destroyEffect ( )
protected
bool APObjectUtils::ObjectEffect::draw_Effect_PointShellHierarchy_Node | ( | vrecko::Ability * | dataAbility,
 |  | void * | node,
 |  | int | iCurrentLevel
 | ) |  |
protected
EffectType APObjectUtils::ObjectEffect::getEffectType ( void )
inline
int APObjectUtils::ObjectEffect::getLevelMax ( )
inlineprotected
int APObjectUtils::ObjectEffect::getLevelMin ( )
inlineprotected
void APObjectUtils::ObjectEffect::HSVtoRGB | ( | float * | r,
 |  | float * | g,
 |  | float * | b,
 |  | float | h,
 |  | float | s,
 |  | float | v
 | ) |  |
protected
bool APObjectUtils::ObjectEffect::isEffectCreated ( )
inline
bool APObjectUtils::ObjectEffect::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffect::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffect::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffect::setEffectType ( EffectType newType )
void APObjectUtils::ObjectEffect::setLevelMinMax | ( | int | newLevelMin,
 |  | int | newLevelMax
 | ) |  |
protected
void APObjectUtils::ObjectEffect::update ( void )
virtual

called by the VRECKO scheduler at specified frequency

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool APObjectUtils::ObjectEffect::bCollisions_NoCalculation
protected
bool APObjectUtils::ObjectEffect::bEffectCreated
protected
bool APObjectUtils::ObjectEffect::bShowLeafInLevelNotReached
protected
COLLISIONS_INFO_VECTOR* APObjectUtils::ObjectEffect::colInfo
protected
osg::Vec4 APObjectUtils::ObjectEffect::color
protected
EffectType APObjectUtils::ObjectEffect::effectType
protected
float APObjectUtils::ObjectEffect::fRadius
protected
osg::ref_ptr<EnvironmentObject> APObjectUtils::ObjectEffect::graphicObject
protected
int APObjectUtils::ObjectEffect::iDistanceFieldValue
protected
int APObjectUtils::ObjectEffect::iLevelMax
protected
int APObjectUtils::ObjectEffect::iLevelMin
protected
osg::ref_ptr<osg::StateSet> APObjectUtils::ObjectEffect::originalStateSet
protected
osg::ref_ptr<osg::Geode> APObjectUtils::ObjectEffect::osgGeode
protected
osg::ref_ptr<osg::MatrixTransform> APObjectUtils::ObjectEffect::osgTransform
protected
osg::ref_ptr<osg::Box> APObjectUtils::ObjectEffect::shapeBox
protected
osg::ref_ptr<osg::ShapeDrawable> APObjectUtils::ObjectEffect::shapeDraw
protected
std::vector<osg::ref_ptr<osg::ShapeDrawable> > APObjectUtils::ObjectEffect::shapeDrawables
protected
osg::ref_ptr<osg::Sphere> APObjectUtils::ObjectEffect::shapeSphere
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffect.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectEffect.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ObjectEffectMan Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectEffectMan
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ObjectEffectMan Class Reference

#include <ObjectEffectMan.h>

Inheritance diagram for APObjectUtils::ObjectEffectMan:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectEffectMan ()
virtual | ~ObjectEffectMan ()
virtual void | preInitialize ()
called as the first initialization method, before loadXMLParameters More...
virtual void | postInitialize ()
called as the last initialization method, after loadXMLParameters More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
loads XML parameters from given node More...
virtual void | update ()
called by the VRECKO scheduler at specified frequency More...
virtual void | clean ()
called mostly by the VRECKO to handle some received event More...
void | SetState (unsigned long newObjectID, bool bNewVisible)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | createObjectEffect (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pEffectParametersNode)
void | deleteObjectEffect ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
DECLARE_INPUT (ObjectID, MessageObjectID)
DECLARE_INPUT (Visible, MessageBool)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
unsigned long | objectID
bool | bVisible
ObjectEffect * objectEffect
std::string | strObjectIDReq
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::ObjectEffectMan::ObjectEffectMan ( )
APObjectUtils::ObjectEffectMan::~ObjectEffectMan ( )
virtual

Member Function Documentation

void APObjectUtils::ObjectEffectMan::clean ( void )
virtual

called mostly by the VRECKO to handle some received event

called when the ability is removed from the object

Reimplemented from vrecko::Ability.

bool APObjectUtils::ObjectEffectMan::createObjectEffect ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pEffectParametersNode )
protected
APObjectUtils::ObjectEffectMan::DECLARE_INPUT | ( | ObjectID | ,
 |  | MessageObjectID |
 | ) |  |
protected
APObjectUtils::ObjectEffectMan::DECLARE_INPUT | ( | Visible | ,
 |  | MessageBool |
 | ) |  |
protected
void APObjectUtils::ObjectEffectMan::deleteObjectEffect ( )
protected
bool APObjectUtils::ObjectEffectMan::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffectMan::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffectMan::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

int APObjectUtils::ObjectEffectMan::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectEffectMan::SetState | ( | unsigned long | newObjectID,
 |  | bool | bNewVisible
 | ) |  |
void APObjectUtils::ObjectEffectMan::update ( void )
virtual

called by the VRECKO scheduler at specified frequency

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool APObjectUtils::ObjectEffectMan::bVisible
protected
ObjectEffect* APObjectUtils::ObjectEffectMan::objectEffect
protected
unsigned long APObjectUtils::ObjectEffectMan::objectID
protected
EnvironmentObject* APObjectUtils::ObjectEffectMan::owner
protected
std::string APObjectUtils::ObjectEffectMan::strObjectIDReq
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffectMan.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectEffectMan.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ObjectInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectInfo
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ObjectInfo Class Reference

#include <ObjectInfo.h>

Inheritance diagram for APObjectUtils::ObjectInfo:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectInfo ()
virtual | ~ObjectInfo ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (Position, MessageVec3)
DECLARE_OUTPUT (Orientation, MessageQuat)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
std::string | strPositionEvent
std::string | strOrientationEvent
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::ObjectInfo::ObjectInfo ( )
APObjectUtils::ObjectInfo::~ObjectInfo ( )
virtual

Member Function Documentation

APObjectUtils::ObjectInfo::DECLARE_OUTPUT | ( | Position | ,
 |  | MessageVec3 |
 | ) |  |
protected
APObjectUtils::ObjectInfo::DECLARE_OUTPUT | ( | Orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
void APObjectUtils::ObjectInfo::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectInfo::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

EnvironmentObject* APObjectUtils::ObjectInfo::owner
protected
std::string APObjectUtils::ObjectInfo::strOrientationEvent
protected
std::string APObjectUtils::ObjectInfo::strPositionEvent
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectInfo.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectInfo.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ObjectModif Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectModif
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ObjectModif Class Reference

#include <ObjectModif.h>

Inheritance diagram for APObjectUtils::ObjectModif:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectModif ()
virtual | ~ObjectModif ()
virtual void | preInitialize ()
called as the first initialization method, before loadXMLParameters More...
virtual void | postInitialize ()
called as the last initialization method, after loadXMLParameters More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
loads XML parameters from given node More...
virtual void | update ()
called by the VRECKO scheduler at specified frequency More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

EnvironmentObject * getSelectedObject ()
DECLARE_INPUT (RandomColor, MessageBool)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageVoid, MessageObjectID)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
called mostly by the VRECKO to handle some received event More...
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::ObjectModif::ObjectModif ( )
APObjectUtils::ObjectModif::~ObjectModif ( )
virtual

Member Function Documentation

APObjectUtils::ObjectModif::DECLARE_INPUT | ( | RandomColor | ,
 |  | MessageBool |
 | ) |  |
protected
APObjectUtils::ObjectModif::DECLARE_REQUEST_OUTPUT | ( | SelectionID | ,
 |  | MessageVoid | ,
 |  | MessageObjectID |
 | ) |  |
protected
EnvironmentObject * APObjectUtils::ObjectModif::getSelectedObject ( )
protected
bool APObjectUtils::ObjectModif::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectModif::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectModif::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectModif::update ( void )
virtual

called by the VRECKO scheduler at specified frequency

Reimplemented from vrecko::BaseClass.

Member Data Documentation

EnvironmentObject* APObjectUtils::ObjectModif::owner
protected

called mostly by the VRECKO to handle some received event

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectModif.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectModif.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::ObjectSelector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectSelector
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::ObjectSelector Class Reference

#include <ObjectSelector.h>

Inheritance diagram for APObjectUtils::ObjectSelector:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ObjectSelector ()
virtual | ~ObjectSelector ()
virtual void | preInitialize ()
called as the first initialization method, before loadXMLParameters More...
virtual void | postInitialize ()
called as the last initialization method, after loadXMLParameters More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
loads XML parameters from given node More...
virtual void | update ()
called by the VRECKO scheduler at specified frequency More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | resolveSelection ()
EnvironmentObject * | resolveIntersections (osg::Vec3 &position, std::vector< osg::Node * > *nodePath=NULL)
DECLARE_INPUT (PointerPosition, MessageVec3)
DECLARE_OUTPUT (SelectionID, MessageObjectID)
DECLARE_REQUEST_INPUT (SelectionID, MessageVoid, MessageObjectID)
DECLARE_REQUEST_INPUT (SelectionByPointerPos, MessageVec3, MessageObjectID)
DECLARE_REQUEST_INPUT (SelectionByPointerPos_Path, MessageVec3, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
called mostly by the VRECKO to handle some received event More...
ObjectEffect * objectEffect
osg::Vec3 | lastPosition
osg::Vec3 | lastSelTest
unsigned long | selObjectID
DynamicArray< int > | intersectedObjects
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::ObjectSelector::ObjectSelector ( )
APObjectUtils::ObjectSelector::~ObjectSelector ( )
virtual

Member Function Documentation

APObjectUtils::ObjectSelector::DECLARE_INPUT | ( | PointerPosition | ,
 |  | MessageVec3 |
 | ) |  |
protected
APObjectUtils::ObjectSelector::DECLARE_OUTPUT | ( | SelectionID | ,
 |  | MessageObjectID |
 | ) |  |
protected
APObjectUtils::ObjectSelector::DECLARE_REQUEST_INPUT | ( | SelectionID | ,
 |  | MessageVoid | ,
 |  | MessageObjectID |
 | ) |  |
protected
APObjectUtils::ObjectSelector::DECLARE_REQUEST_INPUT | ( | SelectionByPointerPos | ,
 |  | MessageVec3 | ,
 |  | MessageObjectID |
 | ) |  |
protected
APObjectUtils::ObjectSelector::DECLARE_REQUEST_INPUT | ( | SelectionByPointerPos_Path | ,
 |  | MessageVec3 | ,
 |  | MessageNodeList |
 | ) |  |
protected
bool APObjectUtils::ObjectSelector::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

loads XML parameters from given node

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectSelector::postInitialize ( void )
virtual

called as the last initialization method, after loadXMLParameters

Reimplemented from vrecko::BaseClass.

void APObjectUtils::ObjectSelector::preInitialize ( void )
virtual

called as the first initialization method, before loadXMLParameters

Reimplemented from vrecko::BaseClass.

EnvironmentObject * APObjectUtils::ObjectSelector::resolveIntersections | ( | osg::Vec3 & | position,
 |  | std::vector< osg::Node * > * | nodePath = NULL
 | ) |  |
protected
void APObjectUtils::ObjectSelector::resolveSelection ( )
protected
void APObjectUtils::ObjectSelector::update ( void )
virtual

called by the VRECKO scheduler at specified frequency

Reimplemented from vrecko::BaseClass.

Member Data Documentation

DynamicArray<int> APObjectUtils::ObjectSelector::intersectedObjects
protected
osg::Vec3 APObjectUtils::ObjectSelector::lastPosition
protected
osg::Vec3 APObjectUtils::ObjectSelector::lastSelTest
protected
ObjectEffect* APObjectUtils::ObjectSelector::objectEffect
protected
EnvironmentObject* APObjectUtils::ObjectSelector::owner
protected

called mostly by the VRECKO to handle some received event

unsigned long APObjectUtils::ObjectSelector::selObjectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectSelector.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectSelector.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::UseToEvent Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • UseToEvent
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APObjectUtils::UseToEvent Class Reference

#include <UseToEvent.h>

Inheritance diagram for APObjectUtils::UseToEvent:
vrecko::Ability vrecko::BaseClass

Public Member Functions

UseToEvent ()
virtual | ~UseToEvent ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (Use, MessageBool)
DECLARE_OUTPUT (Trigger, MessageBool)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

vrecko::EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APObjectUtils::UseToEvent::UseToEvent ( )
APObjectUtils::UseToEvent::~UseToEvent ( )
virtual

Member Function Documentation

APObjectUtils::UseToEvent::DECLARE_INPUT | ( | Use | ,
 |  | MessageBool |
 | ) |  |
protected
APObjectUtils::UseToEvent::DECLARE_OUTPUT | ( | Trigger | ,
 |  | MessageBool |
 | ) |  |
protected

Member Data Documentation

vrecko::EnvironmentObject* APObjectUtils::UseToEvent::owner
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/UseToEvent.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/UseToEvent.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::MyReadCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • MyReadCallback
Public Member Functions | List of all members
APObjectUtils::MyReadCallback Struct Reference
Inheritance diagram for APObjectUtils::MyReadCallback:

Public Member Functions

virtual osg::Node * readNodeFile (const std::string &filename)

Member Function Documentation

virtual osg::Node* APObjectUtils::MyReadCallback::readNodeFile ( const std::string & filename )
inlinevirtual
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectSelector.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APObjectUtils::EOLineSegmentIntersector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • EOLineSegmentIntersector
Public Member Functions | List of all members
APObjectUtils::EOLineSegmentIntersector Class Reference
Inheritance diagram for APObjectUtils::EOLineSegmentIntersector:

Public Member Functions

EOLineSegmentIntersector (const osg::Vec3d &start, const osg::Vec3d &end)
virtual bool enter (const osg::Node &node)

Constructor & Destructor Documentation

APObjectUtils::EOLineSegmentIntersector::EOLineSegmentIntersector | ( | const osg::Vec3d & | start,
 |  | const osg::Vec3d & | end
 | ) |  |
inline

Member Function Documentation

bool EOLineSegmentIntersector::enter ( const osg::Node & node )
virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectSelector.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::ColorBucket Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • ColorBucket
Public Member Functions | List of all members
APRoomEdit::ColorBucket Class Reference

#include <ColorBucket.h>

Inheritance diagram for APRoomEdit::ColorBucket:
APRoomEdit::Tool

Public Member Functions

ColorBucket (osg::Vec3 color)
virtual | ~ColorBucket ()
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::ColorBucket::ColorBucket ( osg::Vec3 color )
inline
virtual APRoomEdit::ColorBucket::~ColorBucket ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::ColorBucket::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::ColorBucket::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/ColorBucket.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::CreateHole Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • CreateHole
Public Member Functions | List of all members
APRoomEdit::CreateHole Class Reference

#include <CreateHole.h>

Inheritance diagram for APRoomEdit::CreateHole:
APRoomEdit::Tool

Public Member Functions

CreateHole (void)
~CreateHole (void)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::CreateHole::CreateHole ( void )
inline
APRoomEdit::CreateHole::~CreateHole ( void )
inline

Member Function Documentation

virtual void APRoomEdit::CreateHole::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::CreateHole::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/CreateHole.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::HoleRemove Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • HoleRemove
Public Member Functions | List of all members
APRoomEdit::HoleRemove Class Reference

#include <HoleRemove.h>

Inheritance diagram for APRoomEdit::HoleRemove:
APRoomEdit::Tool

Public Member Functions

HoleRemove (void)
virtual | ~HoleRemove (void)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::HoleRemove::HoleRemove ( void )
inline
virtual APRoomEdit::HoleRemove::~HoleRemove ( void )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::HoleRemove::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/HoleRemove.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::PointAdd Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • PointAdd
Public Member Functions | List of all members
APRoomEdit::PointAdd Class Reference

#include <PointAdd.h>

Inheritance diagram for APRoomEdit::PointAdd:
APRoomEdit::Tool

Public Member Functions

PointAdd (void)
virtual | ~PointAdd (void)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::PointAdd::PointAdd ( void )
inline
virtual APRoomEdit::PointAdd::~PointAdd ( void )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::PointAdd::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointAdd.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::PointMove Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • PointMove
Public Member Functions | List of all members
APRoomEdit::PointMove Class Reference

#include <PointMove.h>

Inheritance diagram for APRoomEdit::PointMove:
APRoomEdit::Tool

Public Member Functions

PointMove ()
virtual | ~PointMove ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::PointMove::PointMove ( )
inline
virtual APRoomEdit::PointMove::~PointMove ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::PointMove::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::PointMove::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual void APRoomEdit::PointMove::terminate | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual void APRoomEdit::PointMove::update | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray,
 |  | osg::Vec3 & | movingVector
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointMove.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::RoomEditor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomEditor
Public Member Functions | Protected Member Functions | List of all members
APRoomEdit::RoomEditor Class Reference

#include <RoomEditor.h>

Inheritance diagram for APRoomEdit::RoomEditor:
vrecko::ControllableAbility vrecko::Ability vrecko::BaseClass

Public Member Functions

RoomEditor ()
virtual | ~RoomEditor ()
virtual void | update (void)
void | setIntersection (osg::Vec3 &position, vrecko::Scene *scenePtr)
osgUtil::LineSegmentIntersector::Intersection | getIntersection ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
- Public Member Functions inherited from vrecko::ControllableAbility
ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | fillDefaultInfo ()
virtual bool | activate ()
virtual void | deactivate ()
void | issueRequests (bool bStopIfNoSelection)
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
void | RoomEditor::menuItemClicked (const char *itemID)
bool | showToolMenu ()
- Protected Member Functions inherited from vrecko::ControllableAbility
virtual void | createInterface ()
virtual void | destroyInterface ()
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual CAINFO * | createInfo ()
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::ControllableAbility
EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible

Constructor & Destructor Documentation

APRoomEdit::RoomEditor::RoomEditor ( )
virtual APRoomEdit::RoomEditor::~RoomEditor ( )
virtual

Member Function Documentation

virtual bool APRoomEdit::RoomEditor::activate ( )
protectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented from vrecko::ControllableAbility.

virtual void APRoomEdit::RoomEditor::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented from vrecko::ControllableAbility.

virtual void APRoomEdit::RoomEditor::fillDefaultInfo ( )
protectedvirtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implements vrecko::ControllableAbility.

osgUtil::LineSegmentIntersector::Intersection APRoomEdit::RoomEditor::getIntersection ( )
inline
virtual bool APRoomEdit::RoomEditor::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::ControllableAbility.

void APRoomEdit::RoomEditor::issueRequests ( bool bStopIfNoSelection )
protected
virtual void APRoomEdit::RoomEditor::processButtonPress ( CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been pressed). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

virtual void APRoomEdit::RoomEditor::processButtonRelease ( CABUTTONEVENT * eventData )
protectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented from vrecko::ControllableAbility.

void APRoomEdit::RoomEditor::RoomEditor::menuItemClicked ( const char * itemID )
protected
void APRoomEdit::RoomEditor::setIntersection | ( | osg::Vec3 & | position,
 |  | vrecko::Scene * | scenePtr
 | ) |  |
bool APRoomEdit::RoomEditor::showToolMenu ( )
protected
virtual void APRoomEdit::RoomEditor::update ( void )
virtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::ControllableAbility.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomEditor.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::RoomLoader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomLoader
Public Member Functions | List of all members
APRoomEdit::RoomLoader Class Reference

#include <RoomLoader.h>

Inheritance diagram for APRoomEdit::RoomLoader:
APRoomEdit::Tool

Public Member Functions

RoomLoader (std::string f)
virtual | ~RoomLoader ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::RoomLoader::RoomLoader ( std::string f )
inline
virtual APRoomEdit::RoomLoader::~RoomLoader ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::RoomLoader::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::RoomLoader::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomLoader.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::RoomSaver Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomSaver
Public Member Functions | List of all members
APRoomEdit::RoomSaver Class Reference

#include <RoomSaver.h>

Inheritance diagram for APRoomEdit::RoomSaver:
APRoomEdit::Tool

Public Member Functions

RoomSaver (std::string f)
virtual | ~RoomSaver ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::RoomSaver::RoomSaver ( std::string f )
inline
virtual APRoomEdit::RoomSaver::~RoomSaver ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::RoomSaver::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::RoomSaver::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomSaver.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::Tool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • Tool
Public Member Functions | Protected Attributes | List of all members
APRoomEdit::Tool Class Reference

#include <Tool.h>

Inheritance diagram for APRoomEdit::Tool:
APRoomEdit::ColorBucket APRoomEdit::CreateHole APRoomEdit::HoleRemove APRoomEdit::PointAdd APRoomEdit::PointMove APRoomEdit::RoomLoader APRoomEdit::RoomSaver APRoomEdit::WallAdd APRoomEdit::WallMovement APRoomEdit::WallRemove

Public Member Functions

Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)

Protected Attributes

ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::Tool::Tool ( )
inline
virtual APRoomEdit::Tool::~Tool ( )
inlinevirtual

Member Function Documentation

string APRoomEdit::Tool::getName ( void )
inline
ToolType APRoomEdit::Tool::getType ( void )
inline
virtual void APRoomEdit::Tool::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented in APRoomEdit::CreateHole, APRoomEdit::RoomLoader, APRoomEdit::RoomSaver, APRoomEdit::WallRemove, APRoomEdit::ColorBucket, APRoomEdit::PointMove, APRoomEdit::WallAdd, APRoomEdit::HoleRemove, and APRoomEdit::PointAdd.

bool APRoomEdit::Tool::isDirty ( )
inline
virtual bool APRoomEdit::Tool::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented in APRoomEdit::ColorBucket, APRoomEdit::PointMove, APRoomEdit::CreateHole, APRoomEdit::RoomLoader, APRoomEdit::RoomSaver, APRoomEdit::WallAdd, APRoomEdit::WallMovement, and APRoomEdit::WallRemove.

void APRoomEdit::Tool::setDirty ( bool d )
inline
void APRoomEdit::Tool::setName ( string n )
inline
virtual void APRoomEdit::Tool::terminate | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented in APRoomEdit::PointMove.

virtual void APRoomEdit::Tool::update | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray,
 |  | osg::Vec3 & | movingVector
 | ) |  |
inlinevirtual

Reimplemented in APRoomEdit::PointMove, and APRoomEdit::WallMovement.

Member Data Documentation

bool APRoomEdit::Tool::dirty
protected
std::string APRoomEdit::Tool::name
protected
ToolType APRoomEdit::Tool::type
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Tool.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::WallAdd Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallAdd
Public Member Functions | List of all members
APRoomEdit::WallAdd Class Reference

#include <WallAdd.h>

Inheritance diagram for APRoomEdit::WallAdd:
APRoomEdit::Tool

Public Member Functions

WallAdd ()
virtual | ~WallAdd ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::WallAdd::WallAdd ( )
inline
virtual APRoomEdit::WallAdd::~WallAdd ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::WallAdd::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::WallAdd::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallAdd.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::WallGeometry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallGeometry
Public Member Functions | List of all members
APRoomEdit::WallGeometry Class Reference

#include <WallGeometry.h>

Inheritance diagram for APRoomEdit::WallGeometry:
vrecko::Ability vrecko::BaseClass

Public Member Functions

WallGeometry ()
virtual | ~WallGeometry ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
osg::Geode * | getGeode ()
void | createDefaultRoom ()
void | setDirty ()
void | draw ()
WG_Wall * | getWall (osgUtil::LineSegmentIntersector::Intersection *intersection)
WG_Point * | getPoint (osgUtil::LineSegmentIntersector::Intersection *intersection)
void | activateTool (Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection)
void | deactivateTool (Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection)
void | updateTool (Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection, osg::Vec3 movingVector)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

APRoomEdit::WallGeometry::WallGeometry ( )
virtual APRoomEdit::WallGeometry::~WallGeometry ( )
virtual

Member Function Documentation

void APRoomEdit::WallGeometry::activateTool | ( | Tool * | tool,
 |  | osgUtil::LineSegmentIntersector::Intersection * | intersection
 | ) |  |
inline
void APRoomEdit::WallGeometry::createDefaultRoom ( )
void APRoomEdit::WallGeometry::deactivateTool | ( | Tool * | tool,
 |  | osgUtil::LineSegmentIntersector::Intersection * | intersection
 | ) |  |
inline
void APRoomEdit::WallGeometry::draw ( )
osg::Geode* APRoomEdit::WallGeometry::getGeode ( )
inline
WG_Point* APRoomEdit::WallGeometry::getPoint ( osgUtil::LineSegmentIntersector::Intersection * intersection )
inline
WG_Wall* APRoomEdit::WallGeometry::getWall ( osgUtil::LineSegmentIntersector::Intersection * intersection )
inline
virtual bool APRoomEdit::WallGeometry::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

virtual void APRoomEdit::WallGeometry::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

virtual void APRoomEdit::WallGeometry::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APRoomEdit::WallGeometry::setDirty ( )
inline
void APRoomEdit::WallGeometry::updateTool | ( | Tool * | tool,
 |  | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | osg::Vec3 | movingVector
 | ) |  |
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallGeometry.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::WallMovement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallMovement
Public Member Functions | List of all members
APRoomEdit::WallMovement Class Reference

#include <WallMovement.h>

Inheritance diagram for APRoomEdit::WallMovement:
APRoomEdit::Tool

Public Member Functions

WallMovement (void)
virtual | ~WallMovement (void)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::WallMovement::WallMovement ( void )
inline
virtual APRoomEdit::WallMovement::~WallMovement ( void )
inlinevirtual

Member Function Documentation

virtual bool APRoomEdit::WallMovement::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual void APRoomEdit::WallMovement::update | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray,
 |  | osg::Vec3 & | movingVector
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallMovement.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APRoomEdit::WallRemove Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallRemove
Public Member Functions | List of all members
APRoomEdit::WallRemove Class Reference

#include <WallRemove.h>

Inheritance diagram for APRoomEdit::WallRemove:
APRoomEdit::Tool

Public Member Functions

WallRemove ()
virtual | ~WallRemove ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
virtual void | init (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)
- Public Member Functions inherited from APRoomEdit::Tool
Tool ()
virtual | ~Tool ()
ToolType getType ()
string | getName ()
void | setName (string n)
bool | isDirty ()
void | setDirty (bool d)
virtual void | update (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector)
virtual void | terminate (osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray)

Additional Inherited Members

- Protected Attributes inherited from APRoomEdit::Tool
ToolType type
bool | dirty
std::string | name

Constructor & Destructor Documentation

APRoomEdit::WallRemove::WallRemove ( )
inline
virtual APRoomEdit::WallRemove::~WallRemove ( )
inlinevirtual

Member Function Documentation

virtual void APRoomEdit::WallRemove::init | ( | osgUtil::LineSegmentIntersector::Intersection * | intersection,
 |  | WG_Wall * | curWall,
 |  | WG_Point * | curPoint,
 |  | PointType | type,
 |  | vrecko::EnvironmentObject * | pEOOwner,
 |  | std::vector< osg::ref_ptr< WG_Wall > > * | walls,
 |  | std::vector< osg::ref_ptr< WG_Point > > * | points,
 |  | osg::Geode * | pOSGGeode,
 |  | osg::Vec3Array * | pOSGVertexArray
 | ) |  |
inlinevirtual

Reimplemented from APRoomEdit::Tool.

virtual bool APRoomEdit::WallRemove::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
inlinevirtual

Reimplemented from APRoomEdit::Tool.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallRemove.h
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APShootingSimulation::ShootingSimulation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APShootingSimulation
  • ShootingSimulation
Public Member Functions | Protected Member Functions | List of all members
APShootingSimulation::ShootingSimulation Class Reference

#include <ShootingSimulation.h>

Inheritance diagram for APShootingSimulation::ShootingSimulation:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ShootingSimulation ()
virtual | ~ShootingSimulation ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update (void)
osg::ref_ptr
< vrecko::EnvironmentObject > 		resolveIntersections (osg::Vec3 &vector, osg::Vec3 &position, std::vector< osg::Node * > **nodePath=NULL)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | addObject (osg::ref_ptr< vrecko::EnvironmentObject > &obj, const std::string &geoPath)
void | setCrosshairPos ()
void | moveTarget (osg::Vec3 currentTargetPos)
void | testAndHandleHit ()
DECLARE_INPUT (Start, MessageBool)
DECLARE_INPUT (Mouse, MessageVec2)
DECLARE_INPUT (Trigger, MessageBool)
DECLARE_INPUT (Sensor_Transformation, MessageSensorTransformation)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Class for basic simulation of shooting at targets behind a wall.

It is possible to aim with mouse or optiTrack+Wii. Mouse controls: Start level/game - right button Shoot - left button Aim - moving with mouse OptiTrack+Wii Start level/game - button A Shoot - button B Aim - with two OptiTracks

Constructor & Destructor Documentation

ShootingSimulation::ShootingSimulation ( )

Constructor initialize attributes to the default values.

virtual APShootingSimulation::ShootingSimulation::~ShootingSimulation ( )
inlinevirtual

Member Function Documentation

bool ShootingSimulation::addObject | ( | osg::ref_ptr< vrecko::EnvironmentObject > & | obj,
 |  | const std::string & | geoPath
 | ) |  |
inlineprotected

Helping function inserts an object to the world

Parameters
obj | Pointer to the object.
geoPath | Path to the file with geometry of the object.
Returns
True if the object was added succesful, false otherwise.
APShootingSimulation::ShootingSimulation::DECLARE_INPUT | ( | Start | ,
 |  | MessageBool |
 | ) |  |
protected
APShootingSimulation::ShootingSimulation::DECLARE_INPUT | ( | Mouse | ,
 |  | MessageVec2 |
 | ) |  |
protected
APShootingSimulation::ShootingSimulation::DECLARE_INPUT | ( | Trigger | ,
 |  | MessageBool |
 | ) |  |
protected
APShootingSimulation::ShootingSimulation::DECLARE_INPUT | ( | Sensor_Transformation | ,
 |  | MessageSensorTransformation |
 | ) |  |
protected
bool ShootingSimulation::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Function creates objets in the world, sets texts and turns on updating.

Reimplemented from vrecko::BaseClass.

void ShootingSimulation::moveTarget ( osg::Vec3 currentTargetPos )
protected

Functin handles target's movements.

Parameters
currentTargetPos Current target position.
osg::ref_ptr< vrecko::EnvironmentObject > ShootingSimulation::resolveIntersections | ( | osg::Vec3 & | vector,
 |  | osg::Vec3 & | position,
 |  | std::vector< osg::Node * > ** | nodePath = NULL
 | ) |  |

Function resolves which object was hit by a vector.

Parameters
vector | Vector for which we want to determine intersection. For example we can use 'aimVector'.
position | Point from which entered 'vector' will start.
Returns
Environment object which was hit by 'vector' aiming from 'position' or NULL if no object was hit.
void ShootingSimulation::setCrosshairPos ( )
protected

Function sets new possitin of the crosshair according to mouse or Optitrack.

void ShootingSimulation::testAndHandleHit ( )
protected

Function tests if a target was hit and sets state according to it.

void ShootingSimulation::update ( void )
virtual

Function handles main events of the game according to the game state.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation/ShootingSimulation.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/ShootingSimulation.cpp
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::GeometryLoaderBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::GeometryLoaderBase Class Reference

#include <GeometryLoaderBase.h>

Inheritance diagram for APSpacePartitioning::GeometryLoaderBase:
APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > APSpacePartitioning::SphereBVH_Object_Data APSpacePartitioning::VoxelGrid_Object_Data APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > APSpacePartitioning::SNCH_Object_Data APSpacePartitioning::PointShell_Object_Data

Classes

struct | FaceBase
struct | VertexBase

Public Member Functions

GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | loadGeometry (osg::Node *pNode)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()

Protected Member Functions

bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)

Protected Attributes

void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals

Detailed Description

Basic class to load geometry from OpenSceneGraph node

Idea : This class contains the basic loading routines. Descendant classes can create their descendant versions of VertexBase and FaceBase classes but in that case it is IMPORTANT to also override methods that take care of allocation and returns the correct size of the used structure! You have to also call destroyGeometry() in your destructor (of the GeometryLoaderBase descendant).

Constructor & Destructor Documentation

SPACEPARTITIONING_IMP_EXP APSpacePartitioning::GeometryLoaderBase::GeometryLoaderBase ( )
SPACEPARTITIONING_IMP_EXP APSpacePartitioning::GeometryLoaderBase::~GeometryLoaderBase ( )

Don't forget to call destroyGeometry() in your destructor.

Member Function Documentation

virtual void APSpacePartitioning::GeometryLoaderBase::allocateFaceArray ( unsigned long numFaces )
inlinevirtual

allocate space required for storing the faces

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

virtual void APSpacePartitioning::GeometryLoaderBase::allocateVertexArray ( unsigned long numVertices )
inlinevirtual

allocates the memory needed for storing the vhole structure

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

virtual void APSpacePartitioning::GeometryLoaderBase::deallocateFaceArray ( )
inlinevirtual

deallocate the space required for faces

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

virtual void APSpacePartitioning::GeometryLoaderBase::deallocateVertexArray ( )
inlinevirtual

deallocate the unnecessary space

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP void APSpacePartitioning::GeometryLoaderBase::debugWriteNormals ( )

writes out the normals

SPACEPARTITIONING_IMP_EXP void APSpacePartitioning::GeometryLoaderBase::destroyGeometry ( )
protectedvirtual

Deallocates loaded faces/vertices

void* APSpacePartitioning::GeometryLoaderBase::getFace ( unsigned long index )
inline

returns specified face

unsigned long APSpacePartitioning::GeometryLoaderBase::getFaceCount ( )
inline

returns total count of faces

virtual unsigned long APSpacePartitioning::GeometryLoaderBase::getFaceStructureSize ( )
inlinevirtual

returns the size of structure of stored faces

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

osg::Vec3* APSpacePartitioning::GeometryLoaderBase::getNormalByIndex | ( | osg::Geometry::AttributeBinding | normalBinding,
 |  | osg::Vec3Array * | pNormArray,
 |  | osg::IndexArray * | pNormIndices,
 |  | unsigned long | index
 | ) |  |
inlineprotected
SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::getOSGInitCounts | ( | osg::Node * | pNode,
 |  | unsigned long & | pVertexCount,
 |  | unsigned long & | pPrimitiveCount
 | ) |  |
protected

Returns counts of vertices and primitives stored in OSG node.

void* APSpacePartitioning::GeometryLoaderBase::getVertex ( unsigned long index )
inline

returns specified vertex

unsigned long APSpacePartitioning::GeometryLoaderBase::getVertexCount ( )
inline

returns total count of vertices

virtual unsigned long APSpacePartitioning::GeometryLoaderBase::getVertexStructureSize ( )
inlinevirtual

returns the size of structure of stored vertices

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::loadFacesFromFile ( vrecko::BufferedFile * bfile )
virtual

loads the faces to separate file

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::loadGeometry ( osg::Node * pNode )
virtual

Fills the buffers with vertices and faces loaded from a given OSG node.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::loadGeometryHelper | ( | osg::Node * | pNode,
 |  | osg::Matrix & | transform,
 |  | unsigned long & | vertex_pos,
 |  | unsigned long & | face_pos
 | ) |  |
protected

For details contact Vit Kovalcik

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::loadVerticesFromFile ( vrecko::BufferedFile * bfile )
virtual

load the vertice from separate file

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual

Reimplemented in APSpacePartitioning::PointShell_Object_Data, and APSpacePartitioning::VoxelGrid_Object_Data.

SPACEPARTITIONING_IMP_EXP void APSpacePartitioning::GeometryLoaderBase::recalculateNormals ( )
protected

Ignores the old normals and creates new ones.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::saveFacesToFile ( vrecko::BufferedFileWrite * bfile )
virtual

saves the faces to separate file

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP bool APSpacePartitioning::GeometryLoaderBase::saveVerticesToFile ( vrecko::BufferedFileWrite * bfile )
virtual

saving the vertices to separate file

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

SPACEPARTITIONING_IMP_EXP void APSpacePartitioning::GeometryLoaderBase::sortVerticesClockwise ( )
protected

Iterates throught all the faces and sorts vIndex-es clockwise

Member Data Documentation

bool APSpacePartitioning::GeometryLoaderBase::bRecalculateNormals
protected

denotes whether to recalculate normals or take the one that come with the source file

unsigned long APSpacePartitioning::GeometryLoaderBase::face_count
protected

total count of faces

unsigned long APSpacePartitioning::GeometryLoaderBase::face_size
protected

cached number from getFaceStructureSize()

void* APSpacePartitioning::GeometryLoaderBase::faces
protected
unsigned long APSpacePartitioning::GeometryLoaderBase::vertex_count
protected

total count of vertices

unsigned long APSpacePartitioning::GeometryLoaderBase::vertex_size
protected

cached number from getVertexStructureSize()

void* APSpacePartitioning::GeometryLoaderBase::vertices
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/GeometryLoaderBase.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/GeometryLoaderBase.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::GeometryLoaderBase::FaceBase Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
  • FaceBase
Public Attributes | List of all members
APSpacePartitioning::GeometryLoaderBase::FaceBase Struct Reference

#include <GeometryLoaderBase.h>

Public Attributes

unsigned long | vIndex [3]
osg::Vec3 | min
osg::Vec3 | normal

Detailed Description

structure for storing the faces (polygons)

Member Data Documentation

osg::Vec3 APSpacePartitioning::GeometryLoaderBase::FaceBase::min

minimum coordinate (used for sorting)

osg::Vec3 APSpacePartitioning::GeometryLoaderBase::FaceBase::normal

normal of the vertex

unsigned long APSpacePartitioning::GeometryLoaderBase::FaceBase::vIndex[3]

vertex indices (ordered clockwise)

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/GeometryLoaderBase.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::GeometryLoaderBase::VertexBase Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
  • VertexBase
Public Attributes | List of all members
APSpacePartitioning::GeometryLoaderBase::VertexBase Struct Reference

#include <GeometryLoaderBase.h>

Inheritance diagram for APSpacePartitioning::GeometryLoaderBase::VertexBase:
APSpacePartitioning::SNCH_Object_Data::VertexSNCH

Public Attributes

osg::Vec3 | pos
osg::Vec3 | normal

Detailed Description

structure for storing a vertices

Member Data Documentation

osg::Vec3 APSpacePartitioning::GeometryLoaderBase::VertexBase::normal
osg::Vec3 APSpacePartitioning::GeometryLoaderBase::VertexBase::pos
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/GeometryLoaderBase.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::NoPartitioning_Scene Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::NoPartitioning_Scene Class Reference

#include <NoPartitioning_Scene.h>

Inheritance diagram for APSpacePartitioning::NoPartitioning_Scene:
vrecko::SP_SceneInterface vrecko::Ability vrecko::BaseClass

Classes

struct | CollisionStruct
struct | CollisionStructObject

Public Member Functions

NoPartitioning_Scene ()
~NoPartitioning_Scene ()
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual bool | performCompleteTest (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)
virtual bool | performUpdate (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)
- Public Member Functions inherited from vrecko::SP_SceneInterface
SP_SceneInterface ()
~SP_SceneInterface ()
int | getId ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | findCollisionsWithObject (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long testedObject, unsigned long limitToEO2, float time, vrecko::Scene::EOIteratorHelper *iterator=NULL)
virtual bool | singleCollisionTest (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long obj1ID, unsigned long obj2ID, float time)
virtual void | fillCollisionLists (CollisionParams *params)
virtual bool | isIntersection (osg::Vec3f pos1, osg::Vec3f pos2, float radius1, float radius2)
virtual void | updateBoundingBox (osg::Node *pNode)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

CollisionStruct | collisionField [20]
__int64 | ctrTimeLast
__int64 | ctrTimeNew
__int64 | computeTimeLast
__int64 | computeTimeNew
__int64 | freq
LARGE_INTEGER | detectiontime1
LARGE_INTEGER | detectiontime2
LARGE_INTEGER | looptime1
LARGE_INTEGER | looptime2
LARGE_INTEGER | fr
APHUD::HUDDisplay * hud
bool | hudInitialized
- Protected Attributes inherited from vrecko::SP_SceneInterface
int | scIntId
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Basic class to compute proximity of objets and also for computing collisions

Idea : To generate the holded objects and stor in list. This list is updated in regular way (les then 1000Hz. For each objects in hand the collision are computed with all objects that are in a reasonable distance (boudning box)). For each of these pairs a collisions are computed and stored.

Constructor & Destructor Documentation

APSpacePartitioning::NoPartitioning_Scene::NoPartitioning_Scene ( )
APSpacePartitioning::NoPartitioning_Scene::~NoPartitioning_Scene ( )

Member Function Documentation

void APSpacePartitioning::NoPartitioning_Scene::fillCollisionLists ( CollisionParams * params )
protectedvirtual

function fills the list of objects that are could collide to each another.

bool APSpacePartitioning::NoPartitioning_Scene::findCollisionsWithObject | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | testedObject,
 |  | unsigned long | limitToEO2,
 |  | float | time,
 |  | vrecko::Scene::EOIteratorHelper * | iterator = NULL
 | ) |  |
protectedvirtual

Deteting collision of given helded objects with the given object.

Finds collisions with the specified object (i.e. one object vs. rest of the scene). If the [iterator] is not NULL, then the test will proceed only for objects from [iterator + 1] to the world->getScenePtr()->getEOMap().end(). The collisions may still be restricted by [params->pEO[1]]. If is expected that [*collisions] is now a valid pointer.

bool APSpacePartitioning::NoPartitioning_Scene::isIntersection | ( | osg::Vec3f | pos1,
 |  | osg::Vec3f | pos2,
 |  | float | radius1,
 |  | float | radius2
 | ) |  |
inlineprotectedvirtual

functions return true if bounding spheres (position + radius) intersects

bool APSpacePartitioning::NoPartitioning_Scene::performCompleteTest | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | limitToEO1,
 |  | unsigned long | limitToEO2
 | ) |  |
virtual

Performs a test on all objects

Reimplemented from vrecko::SP_SceneInterface.

bool APSpacePartitioning::NoPartitioning_Scene::performUpdate | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | limitToEO1,
 |  | unsigned long | limitToEO2
 | ) |  |
virtual

update function called from haptic loop

Reimplemented from vrecko::SP_SceneInterface.

void APSpacePartitioning::NoPartitioning_Scene::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool APSpacePartitioning::NoPartitioning_Scene::singleCollisionTest | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | obj1ID,
 |  | unsigned long | obj2ID,
 |  | float | time
 | ) |  |
protectedvirtual

A single object-object test

void APSpacePartitioning::NoPartitioning_Scene::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void APSpacePartitioning::NoPartitioning_Scene::updateBoundingBox ( osg::Node * pNode )
inlineprotectedvirtual

functions update the bounding sphere of given object

Member Data Documentation

CollisionStruct APSpacePartitioning::NoPartitioning_Scene::collisionField[20]
protected

Field for holded objects. Right now maximum heldable objects is set to 20 :(

__int64 APSpacePartitioning::NoPartitioning_Scene::computeTimeLast
protected
__int64 APSpacePartitioning::NoPartitioning_Scene::computeTimeNew
protected
__int64 APSpacePartitioning::NoPartitioning_Scene::ctrTimeLast
protected
__int64 APSpacePartitioning::NoPartitioning_Scene::ctrTimeNew
protected
LARGE_INTEGER APSpacePartitioning::NoPartitioning_Scene::detectiontime1
protected
LARGE_INTEGER APSpacePartitioning::NoPartitioning_Scene::detectiontime2
protected
LARGE_INTEGER APSpacePartitioning::NoPartitioning_Scene::fr
protected

time storage to minimize update frequency of hud

__int64 APSpacePartitioning::NoPartitioning_Scene::freq
protected

Values to store times of collisions and so on ...

APHUD::HUDDisplay* APSpacePartitioning::NoPartitioning_Scene::hud
protected

used for calling the hud display

bool APSpacePartitioning::NoPartitioning_Scene::hudInitialized
protected

internal for speedup calling the hud dsplay

LARGE_INTEGER APSpacePartitioning::NoPartitioning_Scene::looptime1
protected
LARGE_INTEGER APSpacePartitioning::NoPartitioning_Scene::looptime2
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/NoPartitioning_Scene.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/NoPartitioning_Scene.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::NoPartitioning_Scene::CollisionStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
  • CollisionStruct
Public Attributes | List of all members
APSpacePartitioning::NoPartitioning_Scene::CollisionStruct Struct Reference

#include <NoPartitioning_Scene.h>

Public Attributes

long | objectID
int | pointShellSize
float | boundingSphereRadius
osg::Vec3f | boundingSpherePosition
osg::Vec3f | position
list< CollisionStructObject > | collisionObjects

Detailed Description

Stores a position of bounding spehere, it's radius, object ID and pointshell size. Stores also a list of all objects that may collide with object

Member Data Documentation

osg::Vec3f APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::boundingSpherePosition
float APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::boundingSphereRadius
list<CollisionStructObject> APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::collisionObjects
long APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::objectID
int APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::pointShellSize

total amounth of points in pointshell of this object active datastructure

osg::Vec3f APSpacePartitioning::NoPartitioning_Scene::CollisionStruct::position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/NoPartitioning_Scene.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
  • CollisionStructObject
Public Attributes | List of all members
APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject Struct Reference

#include <NoPartitioning_Scene.h>

Public Attributes

long | objectID
int | voxelSize
float | boundingSphereRadius
osg::Vec3f | boundingSpherePosition
osg::Vec3f | position
float | timeDivision

Detailed Description

Stores a number of voxels of object, its bounding spehere, ID of object and time Division

Member Data Documentation

osg::Vec3f APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::boundingSpherePosition
float APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::boundingSphereRadius
long APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::objectID
osg::Vec3f APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::position
float APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::timeDivision

this is not TIME, it is timeDivision of a total avalaible time dedicated for computation of collisions [0.0 to 1.0]

int APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject::voxelSize

Total count of voxels the object datastructure posses

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/NoPartitioning_Scene.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShellGeneric_Object_Data
Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > Class Template Reference

#include <PointShell_Object_Data.h>

Inheritance diagram for APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >:
APSpacePartitioning::GeometryLoaderBase APSpacePartitioning::SP_Object_Data_Base vrecko::SP_Object_DataInterface vrecko::Ability vrecko::BaseClass

Public Types

enum CreationType {
LOD_Hierarchy, Simple, ByVoxels_SingleLevel, ByVoxels_MultiLevel,
Test
}

Public Member Functions

PointShellGeneric_Object_Data (const char *abName)
~PointShellGeneric_Object_Data ()
virtual bool | isHierarchyCreated ()
vector< pair< osg::Vec3f,
osg::Vec3f > > 		getPolygons ()
vector< pair< osg::Vec3f, float > > | getDrawSpheres ()
virtual int | getPolygonsCount ()
virtual void | destroyPointShells ()
virtual void | destroyPointShell (CreationType type)
int | getPointShellSize ()
_NodeType * | getRoot ()
_NodeType * | getRoot (CreationType type)
int | getCollisions (int id)
- Public Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | loadGeometry (osg::Node *pNode)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()
- Public Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
SP_Object_Data_Base (const char *abName)
~SP_Object_Data_Base ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

CreationType creationType
float | maxDist
osg::Vec3f | maxDistVect

Protected Member Functions

void | buildLODTree ()
bool | loadTreeFromFile (vrecko::BufferedFile *bfile, DynamicTree< _NodeType > *t)
bool | loadNodeFromFileRec (_NodeType *node, vrecko::BufferedFile *bfile, DynamicTree< _NodeType > *t)
bool | saveTreeToFile (vrecko::BufferedFileWrite *bfile, DynamicTree< _NodeType > *t)
bool | saveNodeToFileRec (_NodeType *node, vrecko::BufferedFileWrite *bfile)
bool | savePointShellCollisions ()
bool | ready ()
virtual bool | coreHierarchyCreation (void)
- Protected Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
- Protected Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
virtual bool | startThreadedHierarchyCreation ()
virtual void | destroyThread ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

pair< osg::Vec3f, osg::Vec3f > * | polygons
int | polygonsCount
DynamicTree< _NodeType > | treeSimple
DynamicTree< _NodeType > | treeLOD
DynamicTree< _NodeType > | treeSingleLevel
DynamicTree< _NodeType > | treeMultiLevel
bool | treeLODCreated
bool | treeSimpleCreated
bool | treeSingleLevelCreated
bool | treeMultiLevelCreated
int | rootSizeLOD
int | rootSizeSimple
int | rootSizeMulti
int | rootSizeSingle
int | rootSizeCollisions
bool | bCreated
- Protected Attributes inherited from APSpacePartitioning::GeometryLoaderBase
void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
- Protected Attributes inherited from APSpacePartitioning::SP_Object_Data_Base
vrecko::EnvironmentObject * owner
HANDLE | hHierarchyCreationThread
bool | bThreadShouldTerminate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Enumeration Documentation

template<class _NodeType>
enum APSpacePartitioning::PointShellGeneric_Object_Data::CreationType
Enumerator
LOD_Hierarchy | creating a voxel grid on demand of maximum vertexes on model
Simple | the simplest creation possible - take vertices and convert them into points in pointshell
ByVoxels_SingleLevel | distribute points using voxels and store the results into a single level
ByVoxels_MultiLevel | distribute points using voxels and store the results into a hierarchy
Test | Used for computation selected structures and save them in a different trees. The Real Time collision will be still computed as a Simple.

Constructor & Destructor Documentation

template<class _NodeType >
APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::PointShellGeneric_Object_Data ( const char * abName )
template<class _NodeType >
APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::~PointShellGeneric_Object_Data ( )

Member Function Documentation

template<class _NodeType>
void APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::buildLODTree ( )
protected
template<class _NodeType >
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::coreHierarchyCreation ( void )
protectedvirtual

Reimplemented from APSpacePartitioning::SP_Object_Data_Base.

Reimplemented in APSpacePartitioning::PointShell_Object_Data.

template<class _NodeType >
void APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::destroyPointShell ( CreationType type )
virtual

destrij pointshell used by specific creation type

template<class _NodeType >
void APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::destroyPointShells ( )
virtual

destroys all pointshells

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getCollisions ( int id )
inline

returns the amount of collisions stored in the pointshell node with requested ID)

template<class _NodeType>
vector<pair<osg::Vec3f,float> > APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getDrawSpheres ( )
inline

returns the vector of pairs (psition, radius) that represents spheres that represents all childs of requested node

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getPointShellSize ( )
inline

return size of pointshell by actual setting of CreationType

template<class _NodeType>
vector<pair<osg::Vec3f,osg::Vec3f> > APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getPolygons ( )
inline

returns the requested polygon

template<class _NodeType>
virtual int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getPolygonsCount ( )
inlinevirtual

returns total amounth of polygons

template<class _NodeType>
_NodeType* APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getRoot ( )
inline

returns the top node (Root) of the tree by actual setting of CreationType

template<class _NodeType>
_NodeType* APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::getRoot ( CreationType type )
inline
template<class _NodeType>
virtual bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::isHierarchyCreated ( )
inlinevirtual

returns whether the hierrarchy is created already or not

Reimplemented from vrecko::SP_Object_DataInterface.

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::loadNodeFromFileRec | ( | _NodeType * | node,
 |  | vrecko::BufferedFile * | bfile,
 |  | DynamicTree< _NodeType > * | t
 | ) |  |
protected
template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::loadTreeFromFile | ( | vrecko::BufferedFile * | bfile,
 |  | DynamicTree< _NodeType > * | t
 | ) |  |
protected
template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::ready ( )
inlineprotected
template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::saveNodeToFileRec | ( | _NodeType * | node,
 |  | vrecko::BufferedFileWrite * | bfile
 | ) |  |
protected
template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::savePointShellCollisions ( )
protected
template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::saveTreeToFile | ( | vrecko::BufferedFileWrite * | bfile,
 |  | DynamicTree< _NodeType > * | t
 | ) |  |
protected

Member Data Documentation

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::bCreated
protected

Denotes wheather the ability is ready

template<class _NodeType>
CreationType APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::creationType

current creation type

template<class _NodeType>
float APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::maxDist

maximal distance between two vertices in the pointshell

template<class _NodeType>
osg::Vec3f APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::maxDistVect

maximal vector of the maxdistance

template<class _NodeType>
pair<osg::Vec3f,osg::Vec3f>* APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::polygons
protected

normal, position

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::polygonsCount
protected

total amounth of polygons

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::rootSizeCollisions
protected

Amounth of the root nodes in the tree

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::rootSizeLOD
protected

Amounth of the root nodes in the tree

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::rootSizeMulti
protected

Amounth of the root nodes in the tree

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::rootSizeSimple
protected

Amounth of the root nodes in the tree

template<class _NodeType>
int APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::rootSizeSingle
protected

Amounth of the root nodes in the tree

template<class _NodeType>
DynamicTree<_NodeType> APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeLOD
protected

used for LODHeirearchy creation

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeLODCreated
protected

to check wheather the LOD tree is created

template<class _NodeType>
DynamicTree<_NodeType> APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeMultiLevel
protected

used for Multi Level Structure creation

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeMultiLevelCreated
protected

to check wheather the MultiLevel tree is created

template<class _NodeType>
DynamicTree<_NodeType> APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeSimple
protected

single root and simple layer of all points under it

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeSimpleCreated
protected

to check wheather the Simple tree is created

template<class _NodeType>
DynamicTree<_NodeType> APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeSingleLevel
protected

used for Single Level Structure creation

template<class _NodeType>
bool APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >::treeSingleLevelCreated
protected

to check wheather the SingleLevel tree is created

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_SimpleNode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_SimpleNode
Public Member Functions | Public Attributes | List of all members
APSpacePartitioning::PointShell_SimpleNode Class Reference

#include <PointShell_Object_Data.h>

Inheritance diagram for APSpacePartitioning::PointShell_SimpleNode:
DynTreeNode< PointShell_SimpleNode >

Public Member Functions

bool | loadDataFromFile (vrecko::BufferedFile *bfile)
bool | saveDataToFile (vrecko::BufferedFileWrite *bfile)
- Public Member Functions inherited from DynTreeNode< PointShell_SimpleNode >
unsigned long | GetDepth ()

Public Attributes

osg::Vec3 | pos
osg::Vec3 | iNorm
float | radius
int | id
int | collisions
- Public Attributes inherited from DynTreeNode< PointShell_SimpleNode >
PointShell_SimpleNode * | lpParent
PointShell_SimpleNode * | lpChild
PointShell_SimpleNode * | lpNext
PointShell_SimpleNode * | lpPrev
DynamicTree
< PointShell_SimpleNode > * 		tree

Member Function Documentation

bool APSpacePartitioning::PointShell_SimpleNode::loadDataFromFile ( vrecko::BufferedFile * bfile )
inline
bool APSpacePartitioning::PointShell_SimpleNode::saveDataToFile ( vrecko::BufferedFileWrite * bfile )
inline

Member Data Documentation

int APSpacePartitioning::PointShell_SimpleNode::collisions
int APSpacePartitioning::PointShell_SimpleNode::id
osg::Vec3 APSpacePartitioning::PointShell_SimpleNode::iNorm
osg::Vec3 APSpacePartitioning::PointShell_SimpleNode::pos
float APSpacePartitioning::PointShell_SimpleNode::radius
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data
Classes | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data Class Reference

#include <PointShell_Object_Data.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data:
APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > APSpacePartitioning::GeometryLoaderBase APSpacePartitioning::SP_Object_Data_Base vrecko::SP_Object_DataInterface vrecko::Ability vrecko::BaseClass

Classes

struct PSpoint

Public Member Functions

PointShell_Object_Data ()
~PointShell_Object_Data ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
float | getMaximumDistance ()
int | getPointShellRootSize ()
osg::Vec3f | getMaximumDistanceVector ()
osg::Vec4f | PointShell_Object_Data::getColor (int collisions)
- Public Member Functions inherited from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >
PointShellGeneric_Object_Data (const char *abName)
~PointShellGeneric_Object_Data ()
virtual bool | isHierarchyCreated ()
vector< pair< osg::Vec3f,
osg::Vec3f > > 		getPolygons ()
vector< pair< osg::Vec3f, float > > | getDrawSpheres ()
virtual int | getPolygonsCount ()
virtual void | destroyPointShells ()
virtual void | destroyPointShell (CreationType type)
int | getPointShellSize ()
PointShell_SimpleNode * getRoot ()
PointShell_SimpleNode * getRoot (CreationType type)
int | getCollisions (int id)
- Public Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadGeometry (osg::Node *pNode)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()
- Public Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
SP_Object_Data_Base (const char *abName)
~SP_Object_Data_Base ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

float | fMaxDistance
- Public Attributes inherited from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >
CreationType creationType
float | maxDist
osg::Vec3f | maxDistVect

Protected Member Functions

void | createSimple ()
void | createLODHierarchy ()
void | createSingleLevel (double minx, double miny, double minz, double velm)
void | createMultiLevel (double minx, double miny, double minz, double velm)
void | computeBBoxSheresRadius (DynamicTree< PointShell_SimpleNode > *tree)
void | computeBBoxShereRadius (PointShell_SimpleNode *node)
void | buildLODTree (PointShell_Object_Data_LOD_Builder *lod_builder)
void | insertPointsInLODTree (PointShell_Object_Data_LOD_Builder *lod_builder, PointShell_SimpleNode *p, int id)
bool | loadSubDivisionMeshFromFile (vrecko::BufferedFile *bfile)
bool | saveSubDivisionMeshToFile (vrecko::BufferedFileWrite *bfile)
double | distance_sqr (PSpoint *voxel1, PSpoint *voxel2)
double | distance (PSpoint *voxel1, PSpoint *voxel2)
bool | constructPointShellCacheDataName (char *pOutDataName)
bool | constructPointShellCacheDataName (char *pOutDataName, CreationType type)
bool | constructPointShellSubdividedMeshDataName (char *pOutDataName)
bool | loadFromCache (const char *pModelFileName)
bool | saveToCache (const char *pModelFileName)
virtual bool | coreHierarchyCreation (void)
bool | savePointShellCollisions ()
PointShell_SimpleNode * | getNodeWithIDFromTree (PointShell_SimpleNode *topNode, int ID)
void | getCollisionsFromTree (PointShell_SimpleNode *node)
- Protected Member Functions inherited from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >
void | buildLODTree ()
bool | loadTreeFromFile (vrecko::BufferedFile *bfile, DynamicTree< PointShell_SimpleNode > *t)
bool | loadNodeFromFileRec (PointShell_SimpleNode *node, vrecko::BufferedFile *bfile, DynamicTree< PointShell_SimpleNode > *t)
bool | saveTreeToFile (vrecko::BufferedFileWrite *bfile, DynamicTree< PointShell_SimpleNode > *t)
bool | saveNodeToFileRec (PointShell_SimpleNode *node, vrecko::BufferedFileWrite *bfile)
bool | savePointShellCollisions ()
bool | ready ()
- Protected Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
- Protected Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
virtual bool | startThreadedHierarchyCreation ()
virtual void | destroyThread ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

int | voxResolution
int | spBranchingFactor
float | lodEdgeImporatnce
float | lodEdgeDistanceImportance
float | lodVertexImporatnce
int | lodZeroLevelSize
bool | lodMovableVertices
float | lodPercentageZeroLevelSize
int | lodMaxLevels
int | lodMinimumVertices
int | collisionsTotal
int | collisionsMax
vector< PSpoint > | voxels
vector< PSpoint > | ordered
vector< vector< PSpoint > > | levels
- Protected Attributes inherited from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >
pair< osg::Vec3f, osg::Vec3f > * | polygons
int | polygonsCount
DynamicTree
< PointShell_SimpleNode > 		treeSimple
DynamicTree
< PointShell_SimpleNode > 		treeLOD
DynamicTree
< PointShell_SimpleNode > 		treeSingleLevel
DynamicTree
< PointShell_SimpleNode > 		treeMultiLevel
bool | treeLODCreated
bool | treeSimpleCreated
bool | treeSingleLevelCreated
bool | treeMultiLevelCreated
int | rootSizeLOD
int | rootSizeSimple
int | rootSizeMulti
int | rootSizeSingle
int | rootSizeCollisions
bool | bCreated
- Protected Attributes inherited from APSpacePartitioning::GeometryLoaderBase
void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
- Protected Attributes inherited from APSpacePartitioning::SP_Object_Data_Base
vrecko::EnvironmentObject * owner
HANDLE | hHierarchyCreationThread
bool | bThreadShouldTerminate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >
enum CreationType
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APSpacePartitioning::PointShell_Object_Data::PointShell_Object_Data ( )
APSpacePartitioning::PointShell_Object_Data::~PointShell_Object_Data ( )

Member Function Documentation

void APSpacePartitioning::PointShell_Object_Data::buildLODTree ( PointShell_Object_Data_LOD_Builder * lod_builder )
protected
void APSpacePartitioning::PointShell_Object_Data::computeBBoxShereRadius ( PointShell_SimpleNode * node )
protected
void APSpacePartitioning::PointShell_Object_Data::computeBBoxSheresRadius ( DynamicTree< PointShell_SimpleNode > * tree )
protected
bool APSpacePartitioning::PointShell_Object_Data::constructPointShellCacheDataName ( char * pOutDataName )
protected
bool APSpacePartitioning::PointShell_Object_Data::constructPointShellCacheDataName | ( | char * | pOutDataName,
 |  | CreationType | type
 | ) |  |
protected
bool APSpacePartitioning::PointShell_Object_Data::constructPointShellSubdividedMeshDataName ( char * pOutDataName )
protected
bool APSpacePartitioning::PointShell_Object_Data::coreHierarchyCreation ( void )
protectedvirtual

Reimplemented from APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >.

void APSpacePartitioning::PointShell_Object_Data::createLODHierarchy ( )
protected
void APSpacePartitioning::PointShell_Object_Data::createMultiLevel | ( | double | minx,
 |  | double | miny,
 |  | double | minz,
 |  | double | velm
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data::createSimple ( )
protected
void APSpacePartitioning::PointShell_Object_Data::createSingleLevel | ( | double | minx,
 |  | double | miny,
 |  | double | minz,
 |  | double | velm
 | ) |  |
protected
double APSpacePartitioning::PointShell_Object_Data::distance | ( | PSpoint * | voxel1,
 |  | PSpoint * | voxel2
 | ) |  |
inlineprotected
double APSpacePartitioning::PointShell_Object_Data::distance_sqr | ( | PSpoint * | voxel1,
 |  | PSpoint * | voxel2
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data::getCollisionsFromTree ( PointShell_SimpleNode * node )
protected
float APSpacePartitioning::PointShell_Object_Data::getMaximumDistance ( )
osg::Vec3f APSpacePartitioning::PointShell_Object_Data::getMaximumDistanceVector ( )
PointShell_SimpleNode * APSpacePartitioning::PointShell_Object_Data::getNodeWithIDFromTree | ( | PointShell_SimpleNode * | topNode,
 |  | int | ID
 | ) |  |
protected
int APSpacePartitioning::PointShell_Object_Data::getPointShellRootSize ( )
void APSpacePartitioning::PointShell_Object_Data::insertPointsInLODTree | ( | PointShell_Object_Data_LOD_Builder * | lod_builder,
 |  | PointShell_SimpleNode * | p,
 |  | int | id
 | ) |  |
protected
bool APSpacePartitioning::PointShell_Object_Data::loadFromCache ( const char * pModelFileName )
protected
bool APSpacePartitioning::PointShell_Object_Data::loadSubDivisionMeshFromFile ( vrecko::BufferedFile * bfile )
protected
bool APSpacePartitioning::PointShell_Object_Data::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

osg::Vec4f APSpacePartitioning::PointShell_Object_Data::PointShell_Object_Data::getColor ( int collisions )
inline
bool APSpacePartitioning::PointShell_Object_Data::savePointShellCollisions ( )
protected
bool APSpacePartitioning::PointShell_Object_Data::saveSubDivisionMeshToFile ( vrecko::BufferedFileWrite * bfile )
protected
bool APSpacePartitioning::PointShell_Object_Data::saveToCache ( const char * pModelFileName )
protected

Member Data Documentation

int APSpacePartitioning::PointShell_Object_Data::collisionsMax
protected
int APSpacePartitioning::PointShell_Object_Data::collisionsTotal
protected
float APSpacePartitioning::PointShell_Object_Data::fMaxDistance
vector< vector<PSpoint> > APSpacePartitioning::PointShell_Object_Data::levels
protected
float APSpacePartitioning::PointShell_Object_Data::lodEdgeDistanceImportance
protected
float APSpacePartitioning::PointShell_Object_Data::lodEdgeImporatnce
protected
int APSpacePartitioning::PointShell_Object_Data::lodMaxLevels
protected
int APSpacePartitioning::PointShell_Object_Data::lodMinimumVertices
protected
bool APSpacePartitioning::PointShell_Object_Data::lodMovableVertices
protected
float APSpacePartitioning::PointShell_Object_Data::lodPercentageZeroLevelSize
protected
float APSpacePartitioning::PointShell_Object_Data::lodVertexImporatnce
protected
int APSpacePartitioning::PointShell_Object_Data::lodZeroLevelSize
protected
vector<PSpoint> APSpacePartitioning::PointShell_Object_Data::ordered
protected
int APSpacePartitioning::PointShell_Object_Data::spBranchingFactor
protected
vector<PSpoint> APSpacePartitioning::PointShell_Object_Data::voxels
protected
int APSpacePartitioning::PointShell_Object_Data::voxResolution
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data::PSpoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data
  • PSpoint
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data::PSpoint Struct Reference

#include <PointShell_Object_Data.h>

Public Attributes

double | x
double | y
double | z
double | a
double | b
double | c

Member Data Documentation

double APSpacePartitioning::PointShell_Object_Data::PSpoint::a
double APSpacePartitioning::PointShell_Object_Data::PSpoint::b
double APSpacePartitioning::PointShell_Object_Data::PSpoint::c
double APSpacePartitioning::PointShell_Object_Data::PSpoint::x
double APSpacePartitioning::PointShell_Object_Data::PSpoint::y
double APSpacePartitioning::PointShell_Object_Data::PSpoint::z
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
Classes | Public Member Functions | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry Class Referenceabstract

#include <PointShell_Object_Data_Geometry.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry:
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser APSpacePartitioning::PointShell_Object_Data_LOD_Builder

Classes

struct | E
struct | P
struct | V

Public Member Functions

PointShell_Object_Data_Geometry ()
virtual | ~PointShell_Object_Data_Geometry ()
virtual void | setVerticesCount (int count)=0
virtual void | setPolygonsCount (int count)=0
virtual void | setEdgesCount (int count)=0
virtual void | writeVertex (int seqnum, osg::Vec3f pos, osg::Vec3f norm)=0
virtual void | writeVertex (int seqnum, osg::Vec3f pos)=0
virtual void | writeEdge (int seqnum, int vertexPos1, int vertexPos2)=0
virtual void | writePolygon (int seqnum, int v1, int v2, int v3)=0
virtual vector
< PointShell_Object_Data_Geometry::V > 		getVertices ()=0
virtual vector
< PointShell_Object_Data_Geometry::E > 		getEdges ()=0
virtual vector
< PointShell_Object_Data_Geometry::P > 		getPolygons ()=0
virtual
PointShell_Object_Data_Geometry::V 		getVertex (int seqnum)=0

Constructor & Destructor Documentation

APSpacePartitioning::PointShell_Object_Data_Geometry::PointShell_Object_Data_Geometry ( )
inline
virtual APSpacePartitioning::PointShell_Object_Data_Geometry::~PointShell_Object_Data_Geometry ( )
inlinevirtual

Member Function Documentation

virtual vector<PointShell_Object_Data_Geometry::E> APSpacePartitioning::PointShell_Object_Data_Geometry::getEdges ( )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual vector<PointShell_Object_Data_Geometry::P> APSpacePartitioning::PointShell_Object_Data_Geometry::getPolygons ( )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual PointShell_Object_Data_Geometry::V APSpacePartitioning::PointShell_Object_Data_Geometry::getVertex ( int seqnum )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual vector<PointShell_Object_Data_Geometry::V> APSpacePartitioning::PointShell_Object_Data_Geometry::getVertices ( )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::setEdgesCount ( int count )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::setPolygonsCount ( int count )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::setVerticesCount ( int count )
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::writeEdge | ( | int | seqnum,
 |  | int | vertexPos1,
 |  | int | vertexPos2
 | ) |  |
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::writePolygon | ( | int | seqnum,
 |  | int | v1,
 |  | int | v2,
 |  | int | v3
 | ) |  |
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos,
 |  | osg::Vec3f | norm
 | ) |  |
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

virtual void APSpacePartitioning::PointShell_Object_Data_Geometry::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos
 | ) |  |
pure virtual

Implemented in APSpacePartitioning::PointShell_Object_Data_LOD_Builder, and APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry::E Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • E
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry::E Struct Reference

#include <PointShell_Object_Data_Geometry.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry::E:
APSpacePartitioning::ELOD APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt

Public Attributes

int | v1ID
int | v2ID

Member Data Documentation

int APSpacePartitioning::PointShell_Object_Data_Geometry::E::v1ID
int APSpacePartitioning::PointShell_Object_Data_Geometry::E::v2ID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry::P Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • P
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry::P Struct Reference

#include <PointShell_Object_Data_Geometry.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry::P:
APSpacePartitioning::PLOD APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt

Public Attributes

int | v1ID
int | v2ID
int | v3ID
osg::Vec3f | norm

Member Data Documentation

osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry::P::norm
int APSpacePartitioning::PointShell_Object_Data_Geometry::P::v1ID
int APSpacePartitioning::PointShell_Object_Data_Geometry::P::v2ID
int APSpacePartitioning::PointShell_Object_Data_Geometry::P::v3ID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry::V Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • V
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry::V Struct Reference

#include <PointShell_Object_Data_Geometry.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry::V:
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt APSpacePartitioning::VLOD

Public Attributes

osg::Vec3f | pos
osg::Vec3f | norm

Member Data Documentation

osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry::V::norm
osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry::V::pos
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser Class Reference

#include <PointShell_Object_Data_Geometry_Analyser.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser:
APSpacePartitioning::PointShell_Object_Data_Geometry

Classes

struct | EExt
struct | PExt
struct | VExt

Public Member Functions

PointShell_Object_Data_Geometry_Analyser ()
~PointShell_Object_Data_Geometry_Analyser ()
void | setVerticesCount (int count)
void | setPolygonsCount (int count)
void | setEdgesCount (int count)
void | writeVertex (int seqnum, osg::Vec3f pos, osg::Vec3f norm)
void | writeVertex (int seqnum, osg::Vec3f pos)
void | writeEdge (int seqnum, int vertexPos1, int vertexPos2)
void | writeEdge (int seqnum, int vertexPos1, int vertexPos2, int polygonPos1, int polygonPos2)
void | writePolygon (int seqnum, int v1, int v2, int v3)
void | finishStructureBuild ()
vector
< PointShell_Object_Data_Geometry::V > 		getVertices ()
vector
< PointShell_Object_Data_Geometry::E > 		getEdges ()
vector
< PointShell_Object_Data_Geometry::P > 		getPolygons ()
PointShell_Object_Data_Geometry::V | getVertex (int seqnum)
float | getMaxDistance ()
osg::Vec3f | getMaxDistanceVector ()
- Public Member Functions inherited from APSpacePartitioning::PointShell_Object_Data_Geometry
PointShell_Object_Data_Geometry ()
virtual | ~PointShell_Object_Data_Geometry ()

Protected Member Functions

void | calculateEdgesLength ()
void | calculateEdgeLength (int edge)
void | calculateNormalOfPolygons ()
void | calculateNormalOfPolygon (int seqnum)
void | calculateVerticesNormals ()
void | calculateVertexNormal (int seqnum)
void | cleanVertexEdges ()
void | handleEdges (int polygon)
vector< int > | getEdges (int polygon)

Protected Attributes

VExt vertices [FIELD_SIZE]
EExt | edges [3 *FIELD_SIZE-2]
PExt | polygons [2 *FIELD_SIZE-2]
int | iVerticesCount
int | iEdgesCount
int | iPolygonsCount
float | maxDistance
int | maxDistanceV1
int | maxDistanceV2

Constructor & Destructor Documentation

APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PointShell_Object_Data_Geometry_Analyser ( )
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::~PointShell_Object_Data_Geometry_Analyser ( )
inline

Member Function Documentation

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateEdgeLength ( int edge )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateEdgesLength ( )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateNormalOfPolygon ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateNormalOfPolygons ( )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateVertexNormal ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::calculateVerticesNormals ( )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::cleanVertexEdges ( )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::finishStructureBuild ( )
vector< PointShell_Object_Data_Geometry::E > APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getEdges ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

vector< int > APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getEdges ( int polygon )
protected
float APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getMaxDistance ( )
osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getMaxDistanceVector ( )
vector< PointShell_Object_Data_Geometry::P > APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getPolygons ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

PointShell_Object_Data_Geometry::V APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getVertex ( int seqnum )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

vector< PointShell_Object_Data_Geometry::V > APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::getVertices ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::handleEdges ( int polygon )
protected
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::setEdgesCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::setPolygonsCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::setVerticesCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::writeEdge | ( | int | seqnum,
 |  | int | vertexPos1,
 |  | int | vertexPos2
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::writeEdge | ( | int | seqnum,
 |  | int | vertexPos1,
 |  | int | vertexPos2,
 |  | int | polygonPos1,
 |  | int | polygonPos2
 | ) |  |
void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::writePolygon | ( | int | seqnum,
 |  | int | v1,
 |  | int | v2,
 |  | int | v3
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos,
 |  | osg::Vec3f | norm
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

Member Data Documentation

EExt APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::edges[3 *FIELD_SIZE-2]
protected
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::iEdgesCount
protected
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::iPolygonsCount
protected
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::iVerticesCount
protected
float APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::maxDistance
protected
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::maxDistanceV1
protected
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::maxDistanceV2
protected
PExt APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::polygons[2 *FIELD_SIZE-2]
protected
VExt APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::vertices[FIELD_SIZE]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • EExt
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt Struct Reference

#include <PointShell_Object_Data_Geometry_Analyser.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt:
APSpacePartitioning::PointShell_Object_Data_Geometry::E

Public Attributes

float | length
int | p1ID
int | p2ID
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::E
int | v1ID
int | v2ID

Member Data Documentation

float APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt::length
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt::p1ID
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt::p2ID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • PExt
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt Struct Reference

#include <PointShell_Object_Data_Geometry_Analyser.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt:
APSpacePartitioning::PointShell_Object_Data_Geometry::P

Public Attributes

float | size
int | e1ID
int | e2ID
int | e3ID
osg::Vec3f | norm
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::P
int | v1ID
int | v2ID
int | v3ID
osg::Vec3f | norm

Member Data Documentation

int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt::e1ID
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt::e2ID
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt::e3ID
osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt::norm
float APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt::size
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • VExt
Public Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt Struct Reference

#include <PointShell_Object_Data_Geometry_Analyser.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt:
APSpacePartitioning::PointShell_Object_Data_Geometry::V

Public Attributes

osg::Vec3f | comNorm
int | id
list< int > | polygons
list< int > | edges
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::V
osg::Vec3f | pos
osg::Vec3f | norm

Member Data Documentation

osg::Vec3f APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt::comNorm
list<int> APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt::edges
int APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt::id
list<int> APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt::polygons
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::mycomparisonMinMax Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • mycomparisonMinMax
Public Member Functions | List of all members
APSpacePartitioning::mycomparisonMinMax Class Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Public Member Functions

mycomparisonMinMax ()
bool operator() (const std::pair< float, int > &first, const std::pair< float, int > &second) const

Constructor & Destructor Documentation

APSpacePartitioning::mycomparisonMinMax::mycomparisonMinMax ( )
inline

Member Function Documentation

bool APSpacePartitioning::mycomparisonMinMax::operator() | ( | const std::pair< float, int > & | first,
 |  | const std::pair< float, int > & | second
 | ) |  | const
 inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::mycomparisonMaxMin Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • mycomparisonMaxMin
Public Member Functions | List of all members
APSpacePartitioning::mycomparisonMaxMin Class Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Public Member Functions

mycomparisonMaxMin ()
bool operator() (const std::pair< float, int > &first, const std::pair< float, int > &second) const

Constructor & Destructor Documentation

APSpacePartitioning::mycomparisonMaxMin::mycomparisonMaxMin ( )
inline

Member Function Documentation

bool APSpacePartitioning::mycomparisonMaxMin::operator() | ( | const std::pair< float, int > & | first,
 |  | const std::pair< float, int > & | second
 | ) |  | const
 inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::VLOD Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VLOD
Public Attributes | List of all members
APSpacePartitioning::VLOD Struct Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Inheritance diagram for APSpacePartitioning::VLOD:
APSpacePartitioning::PointShell_Object_Data_Geometry::V

Public Attributes

osg::Vec3f | comPos
osg::Vec3f | comNorm
int | level
int | ancestor
list< int > | edges
list< int > | childs
int | id
float | radius
bool | leaf
float | importance
bool | visible
bool | valid
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::V
osg::Vec3f | pos
osg::Vec3f | norm

Member Data Documentation

int APSpacePartitioning::VLOD::ancestor
list<int> APSpacePartitioning::VLOD::childs
osg::Vec3f APSpacePartitioning::VLOD::comNorm
osg::Vec3f APSpacePartitioning::VLOD::comPos
list<int> APSpacePartitioning::VLOD::edges
int APSpacePartitioning::VLOD::id
float APSpacePartitioning::VLOD::importance
bool APSpacePartitioning::VLOD::leaf
int APSpacePartitioning::VLOD::level
float APSpacePartitioning::VLOD::radius
bool APSpacePartitioning::VLOD::valid
bool APSpacePartitioning::VLOD::visible
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::ELOD Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • ELOD
Public Attributes | List of all members
APSpacePartitioning::ELOD Struct Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Inheritance diagram for APSpacePartitioning::ELOD:
APSpacePartitioning::PointShell_Object_Data_Geometry::E

Public Attributes

float | importance
float | dist
float | cost
int | id
int | p1
int | p2
bool | valid
bool | visible
list< int > | requiredDeletedEdges
bool | edgeCostRecompute
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::E
int | v1ID
int | v2ID

Member Data Documentation

float APSpacePartitioning::ELOD::cost
float APSpacePartitioning::ELOD::dist
bool APSpacePartitioning::ELOD::edgeCostRecompute
int APSpacePartitioning::ELOD::id
float APSpacePartitioning::ELOD::importance
int APSpacePartitioning::ELOD::p1
int APSpacePartitioning::ELOD::p2
list<int> APSpacePartitioning::ELOD::requiredDeletedEdges
bool APSpacePartitioning::ELOD::valid
bool APSpacePartitioning::ELOD::visible
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PLOD Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PLOD
Public Attributes | List of all members
APSpacePartitioning::PLOD Struct Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Inheritance diagram for APSpacePartitioning::PLOD:
APSpacePartitioning::PointShell_Object_Data_Geometry::P

Public Attributes

osg::Vec3f | norm
int | e1
int | e2
int | e3
bool | visible
int | id
- Public Attributes inherited from APSpacePartitioning::PointShell_Object_Data_Geometry::P
int | v1ID
int | v2ID
int | v3ID
osg::Vec3f | norm

Member Data Documentation

int APSpacePartitioning::PLOD::e1
int APSpacePartitioning::PLOD::e2
int APSpacePartitioning::PLOD::e3
int APSpacePartitioning::PLOD::id
osg::Vec3f APSpacePartitioning::PLOD::norm
bool APSpacePartitioning::PLOD::visible
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::int_3 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • int_3
Public Attributes | List of all members
APSpacePartitioning::int_3 Struct Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Public Attributes

int | i1
int | i2
int | i3

Member Data Documentation

int APSpacePartitioning::int_3::i1
int APSpacePartitioning::int_3::i2
int APSpacePartitioning::int_3::i3
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShell_Object_Data_LOD_Builder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_LOD_Builder
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
APSpacePartitioning::PointShell_Object_Data_LOD_Builder Class Reference

#include <PointShell_Object_Data_LOD_Builder.h>

Inheritance diagram for APSpacePartitioning::PointShell_Object_Data_LOD_Builder:
APSpacePartitioning::PointShell_Object_Data_Geometry

Public Member Functions

PointShell_Object_Data_LOD_Builder ()
~PointShell_Object_Data_LOD_Builder ()
void | Clear ()
string | getStatusResult ()
int | getZeroLevelSize ()
int | getPolygonsCount ()
void | setVerticesCount (int count)
void | setPolygonsCount (int count)
void | setEdgesCount (int count)
void | setParameters (float lodEI, float lodEDI, float lodVI)
void | setMovableVertices (bool value)
void | setLevelZeroSize (int size, float percentage)
void | setFileName (string name)
void | setMaxLevels (int levels)
void | setMaxChildrens (int maxChild)
void | setMinimumVertices (int minimum)
void | writeVertex (int seqnum, osg::Vec3f pos, osg::Vec3f norm)
void | writeVertex (int seqnum, osg::Vec3f pos)
void | writeEdge (int seqnum, int vertexPos1, int vertexPos2)
void | writeEdge (int seqnum, int vertexPos1, int vertexPos2, int polygon1, int polygon2)
void | writePolygon (int seqnum, int v1, int v2, int v3)
void | printOutQueue ()
void | printOutStatus ()
void | printOutVerbouseStatus ()
void | computeRadiusOfBoundingSpheres ()
void | mergeLevels ()
void | finishStructureBuild ()
int | subdivideMesh ()
int | buildReductionLevelStructure ()
int | getMaxLvl ()
vector< VLOD > | getLvlVertices (int lvl)
vector< VLOD > | getVertices (int seqNum)
vector< VLOD > | getRoots ()
vector
< PointShell_Object_Data_Geometry::V > 		getVertices ()
vector
< PointShell_Object_Data_Geometry::E > 		getEdges ()
vector
< PointShell_Object_Data_Geometry::P > 		getPolygons ()
PointShell_Object_Data_Geometry::V | getVertex (int seqnum)
- Public Member Functions inherited from APSpacePartitioning::PointShell_Object_Data_Geometry
PointShell_Object_Data_Geometry ()
virtual | ~PointShell_Object_Data_Geometry ()

Protected Member Functions

void | handleEdges (int polygon)
int_3 | getEdges (int polygon)
void | calculateEdgesLength ()
void | calculateEdgeLength (int edge)
void | calculateEdgesImportance ()
void | calculateEdgeImportance (int seqnum)
void | calculateEdgesCost ()
void | calculateEdgeCost (int seqnum)
void | calculateNormalOfPolygons ()
void | calculateNormalOfPolygon (int seqnum)
void | calculateVerticesNormalAndImporatance ()
void | calculateVertexNormalAndImportance (int seqnum)
void | calculateNewVertexPosition (int vertexToSet, int vt[3])
void | cleanVertexEdges ()
void | removeRequiredEdges (int edge)
void | setVertexVisible (int vertex, bool visibility)
void | setPolygonVisible (int polygon, bool visibility)
void | setEdgeVisible (int edge, bool visibility)
void | addRequiredEdge (int edge, int reqEdge)
void | setValidEdges ()
void | setValidEdge (int edge)
void | setValidVertices ()
void | setValidVertex (int vertex, bool value)
float | getAngle (osg::Vec3f vec1, osg::Vec3f vec2)
list< int > | getSame (int *a, int *b)
bool | equalArrays (int a1[], int a2[], int size)
bool | legalToRemoveEdge (int edge)
bool | polygonHaveVertex (int polygon, int vertex)
bool | polygonHaveVertices (int polygon, int v1, int v2)
bool | have2Polygons2OrMoreVetrticesSame (int p1, int p2)
bool | edgesEqualByVertices (int e1, int e2)
int | getSameEdge (int p1, int p2)
list< int > | getSameEdges (int p1, int p2)
bool | polygonsEqualsByVertices (int p1, int p2)
int | getThirdVertex (int polygon, int v1, int v2)
pair< int, int > | getOkAndChangeEdges (int polygon, int v1, int edge)
void | computeVertexLevels ()
void | addVerticesLeafsAndChilds ()
float | edgeCost (int edge)
float | edgeLength (int edge)
float | edgeImportance (int edge)
float | vertexImportance (int vertex)
void | printOutList (string log, list< int > edgesList)
void | printOutEdge (string log, int edge)
void | printOutVertex (string log, int vertex)
void | printOutPolygon (string log, int polygon)
string | intToStr (int number)
string | floatToTimeString (float time)
void | buildQueue (bool verbouse)
int | reduceFront (int)

Protected Attributes

int | specialCase
bool | moveVerticesPosition
bool | refillQueue
string | filename
int | zeroLevelSize
int | maxLevels
int | maxChildrens
int | minVertices
float | maxDistance
float | lodEdgeImporatnce
float | lodEdgeDistanceImporatnce
float | lodVertexImporatnce
VLOD * vertices
int | iVerticesCount
ELOD * edges
int | iEdgesCount
PLOD * polygons
int | iPolygonsCount
priority_queue< pair< float,
int >, vector< pair< float,
int > >, mycomparisonMinMax > 		test_Queue
priority_queue< pair< float,
int >, vector< pair< float,
int > >, mycomparisonMaxMin > 		test_Subdivision_Queue
vector< int > | treeRoots

Static Protected Attributes

static const bool bDebug = false

Constructor & Destructor Documentation

APSpacePartitioning::PointShell_Object_Data_LOD_Builder::PointShell_Object_Data_LOD_Builder ( )
APSpacePartitioning::PointShell_Object_Data_LOD_Builder::~PointShell_Object_Data_LOD_Builder ( )

Member Function Documentation

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::addRequiredEdge | ( | int | edge,
 |  | int | reqEdge
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::addVerticesLeafsAndChilds ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::buildQueue ( bool verbouse )
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::buildReductionLevelStructure ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgeCost ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgeImportance ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgeLength ( int edge )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgesCost ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgesImportance ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateEdgesLength ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateNewVertexPosition | ( | int | vertexToSet,
 |  | int | vt[3]
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateNormalOfPolygon ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateNormalOfPolygons ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateVertexNormalAndImportance ( int seqnum )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::calculateVerticesNormalAndImporatance ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::cleanVertexEdges ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::Clear ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::computeRadiusOfBoundingSpheres ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::computeVertexLevels ( )
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::edgeCost ( int edge )
inlineprotected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::edgeImportance ( int edge )
inlineprotected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::edgeLength ( int edge )
inlineprotected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::edgesEqualByVertices | ( | int | e1,
 |  | int | e2
 | ) |  |
inlineprotected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::equalArrays | ( | int | a1[],
 |  | int | a2[],
 |  | int | size
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::finishStructureBuild ( )
string APSpacePartitioning::PointShell_Object_Data_LOD_Builder::floatToTimeString ( float time )
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getAngle | ( | osg::Vec3f | vec1,
 |  | osg::Vec3f | vec2
 | ) |  |
inlineprotected
vector< PointShell_Object_Data_Geometry::E > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getEdges ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

int_3 APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getEdges ( int polygon )
protected
vector< VLOD > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getLvlVertices ( int lvl )
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getMaxLvl ( )
pair< int, int > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getOkAndChangeEdges | ( | int | polygon,
 |  | int | v1,
 |  | int | edge
 | ) |  |
inlineprotected
vector< PointShell_Object_Data_Geometry::P > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getPolygons ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getPolygonsCount ( )
inline
vector< VLOD > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getRoots ( )
list< int > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getSame | ( | int * | a,
 |  | int * | b
 | ) |  |
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getSameEdge | ( | int | p1,
 |  | int | p2
 | ) |  |
inlineprotected
list< int > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getSameEdges | ( | int | p1,
 |  | int | p2
 | ) |  |
protected
string APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getStatusResult ( )
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getThirdVertex | ( | int | polygon,
 |  | int | v1,
 |  | int | v2
 | ) |  |
inlineprotected
PointShell_Object_Data_Geometry::V APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getVertex ( int seqnum )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

vector< VLOD > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getVertices ( int seqNum )
vector< PointShell_Object_Data_Geometry::V > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getVertices ( )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::getZeroLevelSize ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::handleEdges ( int polygon )
protected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::have2Polygons2OrMoreVetrticesSame | ( | int | p1,
 |  | int | p2
 | ) |  |
protected
string APSpacePartitioning::PointShell_Object_Data_LOD_Builder::intToStr ( int number )
protected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::legalToRemoveEdge ( int edge )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::mergeLevels ( )
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::polygonHaveVertex | ( | int | polygon,
 |  | int | vertex
 | ) |  |
inlineprotected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::polygonHaveVertices | ( | int | polygon,
 |  | int | v1,
 |  | int | v2
 | ) |  |
inlineprotected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::polygonsEqualsByVertices | ( | int | p1,
 |  | int | p2
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutEdge | ( | string | log,
 |  | int | edge
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutList | ( | string | log,
 |  | list< int > | edgesList
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutPolygon | ( | string | log,
 |  | int | polygon
 | ) |  |
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutQueue ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutStatus ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutVerbouseStatus ( )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::printOutVertex | ( | string | log,
 |  | int | vertex
 | ) |  |
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::reduceFront ( int reductions )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::removeRequiredEdges ( int edge )
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setEdgesCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setEdgeVisible | ( | int | edge,
 |  | bool | visibility
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setFileName ( string name )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setLevelZeroSize | ( | int | size,
 |  | float | percentage
 | ) |  |
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setMaxChildrens ( int maxChild )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setMaxLevels ( int levels )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setMinimumVertices ( int minimum )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setMovableVertices ( bool value )
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setParameters | ( | float | lodEI,
 |  | float | lodEDI,
 |  | float | lodVI
 | ) |  |
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setPolygonsCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setPolygonVisible | ( | int | polygon,
 |  | bool | visibility
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setValidEdge ( int edge )
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setValidEdges ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setValidVertex | ( | int | vertex,
 |  | bool | value
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setValidVertices ( )
protected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setVertexVisible | ( | int | vertex,
 |  | bool | visibility
 | ) |  |
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::setVerticesCount ( int count )
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::subdivideMesh ( )
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::vertexImportance ( int vertex )
inlineprotected
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::writeEdge | ( | int | seqnum,
 |  | int | vertexPos1,
 |  | int | vertexPos2
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::writeEdge | ( | int | seqnum,
 |  | int | vertexPos1,
 |  | int | vertexPos2,
 |  | int | polygon1,
 |  | int | polygon2
 | ) |  |
void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::writePolygon | ( | int | seqnum,
 |  | int | v1,
 |  | int | v2,
 |  | int | v3
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos,
 |  | osg::Vec3f | norm
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

void APSpacePartitioning::PointShell_Object_Data_LOD_Builder::writeVertex | ( | int | seqnum,
 |  | osg::Vec3f | pos
 | ) |  |
virtual

Implements APSpacePartitioning::PointShell_Object_Data_Geometry.

Member Data Documentation

const bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::bDebug = false
staticprotected
ELOD* APSpacePartitioning::PointShell_Object_Data_LOD_Builder::edges
protected
string APSpacePartitioning::PointShell_Object_Data_LOD_Builder::filename
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::iEdgesCount
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::iPolygonsCount
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::iVerticesCount
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::lodEdgeDistanceImporatnce
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::lodEdgeImporatnce
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::lodVertexImporatnce
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::maxChildrens
protected
float APSpacePartitioning::PointShell_Object_Data_LOD_Builder::maxDistance
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::maxLevels
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::minVertices
protected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::moveVerticesPosition
protected
PLOD* APSpacePartitioning::PointShell_Object_Data_LOD_Builder::polygons
protected
bool APSpacePartitioning::PointShell_Object_Data_LOD_Builder::refillQueue
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::specialCase
protected
priority_queue< pair<float,int>, vector<pair<float,int> >, mycomparisonMinMax > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::test_Queue
protected
priority_queue< pair<float,int>, vector<pair<float,int> >, mycomparisonMaxMin > APSpacePartitioning::PointShell_Object_Data_LOD_Builder::test_Subdivision_Queue
protected
vector<int> APSpacePartitioning::PointShell_Object_Data_LOD_Builder::treeRoots
protected
VLOD* APSpacePartitioning::PointShell_Object_Data_LOD_Builder::vertices
protected
int APSpacePartitioning::PointShell_Object_Data_LOD_Builder::zeroLevelSize
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::PointShellVSVoxel_Object Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShellVSVoxel_Object
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::PointShellVSVoxel_Object Class Reference

#include <PointShellVSVoxel_Object.h>

Inheritance diagram for APSpacePartitioning::PointShellVSVoxel_Object:
vrecko::SP_ObjectInterface vrecko::Ability vrecko::BaseClass

Public Member Functions

PointShellVSVoxel_Object ()
~PointShellVSVoxel_Object ()
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | setTestComputation (bool state)
bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time)
- Public Member Functions inherited from vrecko::SP_ObjectInterface
SP_ObjectInterface ()
~SP_ObjectInterface ()
int | getId ()
usually one of the SP_OBJECT_INTERFACE_ID__* constants More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

bool bTestComputation

Protected Member Functions

bool | getObjectTransformation (EnvironmentObject *pObj, CollisionParams *params, osg::Matrix *outMat)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

LARGE_INTEGER | collisiontime1
LARGE_INTEGER | collisiontime2
LARGE_INTEGER | looptime1
LARGE_INTEGER | looptime2
LARGE_INTEGER | fr
APHUD::HUDDisplay * hud
int | objectID
bool | hudInitialized
- Protected Attributes inherited from vrecko::SP_ObjectInterface
int | objIntId
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PointShellVSVoxel_Object::PointShellVSVoxel_Object ( )
PointShellVSVoxel_Object::~PointShellVSVoxel_Object ( )

Member Function Documentation

bool PointShellVSVoxel_Object::getCollisions | ( | CollisionParams * | params,
 |  | COLLISION_POINTS_VECTOR ** | colPoints,
 |  | unsigned long | obj1ID,
 |  | unsigned long | obj2ID,
 |  | float | time
 | ) |  |
virtual

Computes the collisions between objects. Returns "false" in case of error.

[*colPoints] may be NULL on the input. In case there is no collision, it will still be NULL at the end, otherwise the structure will be created and the pointer to it returned.

[colPoints] may also be NULL, which means that no collision points are to be returned. The reason to make such a call is to update the internal structures of the Object col. det. class.

Reimplemented from vrecko::SP_ObjectInterface.

bool PointShellVSVoxel_Object::getObjectTransformation | ( | EnvironmentObject * | pObj,
 |  | CollisionParams * | params,
 |  | osg::Matrix * | outMat
 | ) |  |
protected
void PointShellVSVoxel_Object::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool APSpacePartitioning::PointShellVSVoxel_Object::setTestComputation ( bool state )
inline

Member Data Documentation

bool APSpacePartitioning::PointShellVSVoxel_Object::bTestComputation
LARGE_INTEGER APSpacePartitioning::PointShellVSVoxel_Object::collisiontime1
protected
LARGE_INTEGER APSpacePartitioning::PointShellVSVoxel_Object::collisiontime2
protected
LARGE_INTEGER APSpacePartitioning::PointShellVSVoxel_Object::fr
protected
APHUD::HUDDisplay* APSpacePartitioning::PointShellVSVoxel_Object::hud
protected
bool APSpacePartitioning::PointShellVSVoxel_Object::hudInitialized
protected
LARGE_INTEGER APSpacePartitioning::PointShellVSVoxel_Object::looptime1
protected
LARGE_INTEGER APSpacePartitioning::PointShellVSVoxel_Object::looptime2
protected
int APSpacePartitioning::PointShellVSVoxel_Object::objectID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
Classes | Public Types | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::SNCH_Object Class Reference

#include <SNCH_Object.h>

Inheritance diagram for APSpacePartitioning::SNCH_Object:
APSpacePartitioning::SphereBVH_Object vrecko::SP_ObjectInterface vrecko::Ability vrecko::BaseClass

Classes

struct | InternalPointStruct
class | LMDStore
struct | LocalMinimumDistance
class | OneTri

Public Types

typedef std::vector
< LocalMinimumDistance > 		LMDvector

Public Member Functions

SNCH_Object ()
~SNCH_Object ()
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
float | getForce (void)
void | setNCoeficient (double nc)
double | getNCoeficient (void)
void | setMaxForce (double mforce)
double | getMaxForce (void)
virtual bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID)
- Public Member Functions inherited from APSpacePartitioning::SphereBVH_Object
SphereBVH_Object ()
~SphereBVH_Object ()
bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID)
- Public Member Functions inherited from vrecko::SP_ObjectInterface
SP_ObjectInterface ()
~SP_ObjectInterface ()
int | getId ()
usually one of the SP_OBJECT_INTERFACE_ID__* constants More...
virtual bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

enum | ProjectionIntersectionResult { NoIntersection, OriginalTriangleIntersection, ConeIntersection }
typedef __int64 | LMD_HASH
typedef Sgi::hash_map
< LMD_HASH, LMDStore * > 		LMD_STORE_MAP
typedef OneTri | TWO_TRIS [2]

Protected Member Functions

LMD_HASH | calcLMDHash (unsigned long int id1, unsigned long int id2)
LMDStore * | getLMDStore (LMD_HASH hash)
void | globalSearch (SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds, CollisionParams *params)
void | localSearch (SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds, CollisionParams *params, int lmdIndex, int dbgWriterGLIndex=0)
bool | testNodeNorec (SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1, SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2, LMDStore *lmds, CollisionParams *params)
bool | getObjectsTransformations (SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, CollisionParams *params, osg::Matrix *transf1, osg::Matrix *transf2)
ProjectionIntersectionResult | triProjectionIntersection (OneTri *points0, OneTri *points1, osg::Vec3 *outIntersectionPoint0=NULL, osg::Vec3 *outIntersectionPoint1=NULL, bool bPerformPretests=true)
bool | triIntersects (OneTri *points0, OneTri *points1, osg::Vec3 *outPoint0Trans=NULL, osg::Vec3 *outPoint1Trans=NULL, osg::Vec3 *outPoint0Tri0Cross=NULL, osg::Vec3 *outPoint1Tri0Cross=NULL, bool *bOutPointsTriCrossValid=NULL)
float | triDistance (OneTri *points0, OneTri *points1, osg::Vec3 *outPoint1Trans=NULL, osg::Vec3 *outPoint2Trans=NULL, unsigned short *closeFeature0=NULL, unsigned short *closeFeature1=NULL)
bool | old_getTriLMD (SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1, osg::Vec3 *center1, SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2, osg::Vec3 *center2, osg::Vec3 point[2][7], unsigned long *index1, unsigned long *index2)

Protected Attributes

double | ncoeficient
double | max_force
LMD_STORE_MAP lmd_store
MTLock lmd_store_access
double | reject_distance_for_surfaces
double | reject_distance_for_BS
double | angle_tolerance

Member Typedef Documentation

typedef __int64 APSpacePartitioning::SNCH_Object::LMD_HASH
protected
typedef Sgi::hash_map<LMD_HASH, LMDStore*> APSpacePartitioning::SNCH_Object::LMD_STORE_MAP
protected
typedef std::vector<LocalMinimumDistance> APSpacePartitioning::SNCH_Object::LMDvector
typedef OneTri APSpacePartitioning::SNCH_Object::TWO_TRIS[2]
protected

Member Enumeration Documentation

enum APSpacePartitioning::SNCH_Object::ProjectionIntersectionResult
protected
Enumerator
NoIntersection
OriginalTriangleIntersection
ConeIntersection

Constructor & Destructor Documentation

SNCH_Object::SNCH_Object ( )
SNCH_Object::~SNCH_Object ( )

Member Function Documentation

LMD_HASH APSpacePartitioning::SNCH_Object::calcLMDHash | ( | unsigned long int | id1,
 |  | unsigned long int | id2
 | ) |  |
inlineprotected
bool SNCH_Object::getCollisions | ( | CollisionParams * | params,
 |  | COLLISION_POINTS_VECTOR ** | colPoints,
 |  | unsigned long | obj1ID,
 |  | unsigned long | obj2ID
 | ) |  |
virtual
float SNCH_Object::getForce ( void )
SNCH_Object::LMDStore * SNCH_Object::getLMDStore ( LMD_HASH hash )
protected
double APSpacePartitioning::SNCH_Object::getMaxForce ( void )
inline
double APSpacePartitioning::SNCH_Object::getNCoeficient ( void )
inline
bool SNCH_Object::getObjectsTransformations | ( | SNCH_Object_Data * | pOData1,
 |  | SNCH_Object_Data * | pOData2,
 |  | CollisionParams * | params,
 |  | osg::Matrix * | transf1,
 |  | osg::Matrix * | transf2
 | ) |  |
protected
void SNCH_Object::globalSearch | ( | SNCH_Object_Data * | pOData1,
 |  | SNCH_Object_Data * | pOData2,
 |  | LMDStore * | lmds,
 |  | CollisionParams * | params
 | ) |  |
protected
void SNCH_Object::localSearch | ( | SNCH_Object_Data * | pOData1,
 |  | SNCH_Object_Data * | pOData2,
 |  | LMDStore * | lmds,
 |  | CollisionParams * | params,
 |  | int | lmdIndex,
 |  | int | dbgWriterGLIndex = 0
 | ) |  |
protected
bool SNCH_Object::old_getTriLMD | ( | SNCH_Object_Data::STNodeSNCH * | pSTNode1,
 |  | SNCH_Object_Data * | pOData1,
 |  | osg::Matrix * | transf1,
 |  | osg::Vec3 * | center1,
 |  | SNCH_Object_Data::STNodeSNCH * | pSTNode2,
 |  | SNCH_Object_Data * | pOData2,
 |  | osg::Matrix * | transf2,
 |  | osg::Vec3 * | center2,
 |  | osg::Vec3 | point[2][7],
 |  | unsigned long * | index1,
 |  | unsigned long * | index2
 | ) |  |
protected
void SNCH_Object::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from APSpacePartitioning::SphereBVH_Object.

void APSpacePartitioning::SNCH_Object::setMaxForce ( double mforce )
inline
void APSpacePartitioning::SNCH_Object::setNCoeficient ( double nc )
inline
bool SNCH_Object::testNodeNorec | ( | SNCH_Object_Data::STNodeSNCH * | pSTNode1,
 |  | SNCH_Object_Data * | pOData1,
 |  | osg::Matrix * | transf1,
 |  | SNCH_Object_Data::STNodeSNCH * | pSTNode2,
 |  | SNCH_Object_Data * | pOData2,
 |  | osg::Matrix * | transf2,
 |  | LMDStore * | lmds,
 |  | CollisionParams * | params
 | ) |  |
protected
float SNCH_Object::triDistance | ( | OneTri * | points0,
 |  | OneTri * | points1,
 |  | osg::Vec3 * | outPoint1Trans = NULL,
 |  | osg::Vec3 * | outPoint2Trans = NULL,
 |  | unsigned short * | closeFeature0 = NULL,
 |  | unsigned short * | closeFeature1 = NULL
 | ) |  |
protected
bool SNCH_Object::triIntersects | ( | OneTri * | points0,
 |  | OneTri * | points1,
 |  | osg::Vec3 * | outPoint0Trans = NULL,
 |  | osg::Vec3 * | outPoint1Trans = NULL,
 |  | osg::Vec3 * | outPoint0Tri0Cross = NULL,
 |  | osg::Vec3 * | outPoint1Tri0Cross = NULL,
 |  | bool * | bOutPointsTriCrossValid = NULL
 | ) |  |
protected
SNCH_Object::ProjectionIntersectionResult SNCH_Object::triProjectionIntersection | ( | OneTri * | points0,
 |  | OneTri * | points1,
 |  | osg::Vec3 * | outIntersectionPoint0 = NULL,
 |  | osg::Vec3 * | outIntersectionPoint1 = NULL,
 |  | bool | bPerformPretests = true
 | ) |  |
protected

Member Data Documentation

double APSpacePartitioning::SNCH_Object::angle_tolerance
protected
LMD_STORE_MAP APSpacePartitioning::SNCH_Object::lmd_store
protected
MTLock APSpacePartitioning::SNCH_Object::lmd_store_access
protected
double APSpacePartitioning::SNCH_Object::max_force
protected
double APSpacePartitioning::SNCH_Object::ncoeficient
protected
double APSpacePartitioning::SNCH_Object::reject_distance_for_BS
protected
double APSpacePartitioning::SNCH_Object::reject_distance_for_surfaces
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object::InternalPointStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • InternalPointStruct
Public Attributes | List of all members
APSpacePartitioning::SNCH_Object::InternalPointStruct Struct Reference

#include <SNCH_Object.h>

Public Attributes

osg::Vec3 | pos
osg::Vec3 | normal

Member Data Documentation

osg::Vec3 APSpacePartitioning::SNCH_Object::InternalPointStruct::normal
osg::Vec3 APSpacePartitioning::SNCH_Object::InternalPointStruct::pos
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object::LMDStore Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • LMDStore
Public Member Functions | Public Attributes | List of all members
APSpacePartitioning::SNCH_Object::LMDStore Class Reference

#include <SNCH_Object.h>

Public Member Functions

LMDStore ()

Public Attributes

unsigned char | active_LMD
bool | bLMDValid [2]
LMDvector | LMDs [2]
MTLock LMDswitch

Constructor & Destructor Documentation

APSpacePartitioning::SNCH_Object::LMDStore::LMDStore ( )
inline

Member Data Documentation

unsigned char APSpacePartitioning::SNCH_Object::LMDStore::active_LMD
bool APSpacePartitioning::SNCH_Object::LMDStore::bLMDValid[2]
LMDvector APSpacePartitioning::SNCH_Object::LMDStore::LMDs[2]
MTLock APSpacePartitioning::SNCH_Object::LMDStore::LMDswitch
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object::LocalMinimumDistance Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • LocalMinimumDistance
Public Attributes | List of all members
APSpacePartitioning::SNCH_Object::LocalMinimumDistance Struct Reference

#include <SNCH_Object.h>

Public Attributes

unsigned long | dwFlags
unsigned long | faces [2]
osg::Vec3 | pointsTrans [2]
unsigned short | closeFeatures [2]
osg::Vec3 | vecTriMaxNegDist

Member Data Documentation

unsigned short APSpacePartitioning::SNCH_Object::LocalMinimumDistance::closeFeatures[2]
unsigned long APSpacePartitioning::SNCH_Object::LocalMinimumDistance::dwFlags
unsigned long APSpacePartitioning::SNCH_Object::LocalMinimumDistance::faces[2]
osg::Vec3 APSpacePartitioning::SNCH_Object::LocalMinimumDistance::pointsTrans[2]
osg::Vec3 APSpacePartitioning::SNCH_Object::LocalMinimumDistance::vecTriMaxNegDist
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object::OneTri Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • OneTri
Public Member Functions | Public Attributes | List of all members
APSpacePartitioning::SNCH_Object::OneTri Class Reference

#include <SNCH_Object.h>

Public Member Functions

OneTri ()
void | reset ()
void | calcNormal ()
void | calcD ()

Public Attributes

InternalPointStruct | v [3]
bool | bZeroNormal
osg::Vec3 | planeNormal
float | planeD

Constructor & Destructor Documentation

APSpacePartitioning::SNCH_Object::OneTri::OneTri ( )
inline

Member Function Documentation

void APSpacePartitioning::SNCH_Object::OneTri::calcD ( )
inline
void APSpacePartitioning::SNCH_Object::OneTri::calcNormal ( )
inline
void APSpacePartitioning::SNCH_Object::OneTri::reset ( )
inline

Member Data Documentation

bool APSpacePartitioning::SNCH_Object::OneTri::bZeroNormal
float APSpacePartitioning::SNCH_Object::OneTri::planeD
osg::Vec3 APSpacePartitioning::SNCH_Object::OneTri::planeNormal
InternalPointStruct APSpacePartitioning::SNCH_Object::OneTri::v[3]
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data Class Reference

#include <SNCH_Object_Data.h>

Inheritance diagram for APSpacePartitioning::SNCH_Object_Data:
APSpacePartitioning::SphereBVH_Object_Data APSpacePartitioning::GeometryLoaderBase APSpacePartitioning::SP_Object_Data_Base vrecko::SP_Object_DataInterface vrecko::Ability vrecko::BaseClass

Classes

struct | DebugLevelStats
struct | DebugStats
struct | FaceSNCH
struct | STNodeSNCH
struct | VertexSNCH

Public Member Functions

SNCH_Object_Data ()
~SNCH_Object_Data ()
virtual bool | isHierarchyCreated ()
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
VertexSNCH * | getSNCHVertex (unsigned long index)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
FaceSNCH * | getSNCHFace (unsigned long index)
virtual void * | allocateSTNode ()
virtual unsigned long | getSTNodeStructureSize ()
virtual bool | saveTreeNodeToFile (void *node, vrecko::BufferedFileWrite *bfile)
virtual bool | loadTreeNodeFromFile (void *node, vrecko::BufferedFile *bfile)
- Public Member Functions inherited from APSpacePartitioning::SphereBVH_Object_Data
SphereBVH_Object_Data ()
SphereBVH_Object_Data (const char *abName)
~SphereBVH_Object_Data ()
void * | getRootPtr (void)
virtual bool | destroyHierarchy (STNodeSphere *subTreeToDestroy=NULL)
- Public Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | loadGeometry (osg::Node *pNode)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()
- Public Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
SP_Object_Data_Base (const char *abName)
~SP_Object_Data_Base ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | calculateGeometryProperties (void)
bool | generateVertexNeighbourhood (void)
bool | createEdgeGroups (void)
bool | createFaceGroups (void)
bool | computeSNCH (void *pSTNode)
void | calcSubtreeTriangleRepresentant (void *pNode, osg::Vec3 *axis, unsigned long *triangle, float *bestValue=NULL)
void | writeDebugStatistics ()
void | wdsInfoRec (void *pSTNode, int level, DebugStats *ds)
virtual bool | constructCacheDataName (char *pOutDataName, int *version)
virtual bool | loadDataFromPersistentCache_Init ()
virtual bool | coreHierarchyCreation (void)
- Protected Member Functions inherited from APSpacePartitioning::SphereBVH_Object_Data
virtual bool | saveDataToPersistentCache_Init ()
virtual bool | saveDataToPersistentCache_WriteData (vrecko::BufferedFileWrite *bfile)
virtual bool | saveDataToPC_SaveTreeNode (vrecko::BufferedFileWrite *bfile, STNodeSphere *node)
virtual bool | loadDataFromPersistentCache_ReadData (vrecko::BufferedFile *bfile)
virtual bool | loadDataFromPC_LoadTreeNode (vrecko::BufferedFile *bfile, STNodeSphere **ptrToStoreNode)
virtual bool | createTreeFromGeometry (osg::Node *pNode)
bool | constructTree (void *pSTNode, unsigned long left_pos, unsigned long right_pos, int last_sort)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
- Protected Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
virtual bool | startThreadedHierarchyCreation ()
virtual void | destroyThread ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bSNCHierarchyCreated
- Protected Attributes inherited from APSpacePartitioning::SphereBVH_Object_Data
bool | bSphereBVHierarchyCreated
void * | root
- Protected Attributes inherited from APSpacePartitioning::GeometryLoaderBase
void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
- Protected Attributes inherited from APSpacePartitioning::SP_Object_Data_Base
vrecko::EnvironmentObject * owner
HANDLE | hHierarchyCreationThread
bool | bThreadShouldTerminate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APSpacePartitioning::SNCH_Object_Data::SNCH_Object_Data ( )
APSpacePartitioning::SNCH_Object_Data::~SNCH_Object_Data ( )

Member Function Documentation

virtual void APSpacePartitioning::SNCH_Object_Data::allocateFaceArray ( unsigned long numFaces )
inlinevirtual

allocate space required for storing the faces

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

virtual void* APSpacePartitioning::SNCH_Object_Data::allocateSTNode ( )
inlinevirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

virtual void APSpacePartitioning::SNCH_Object_Data::allocateVertexArray ( unsigned long numVertices )
inlinevirtual

allocates the memory needed for storing the vhole structure

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

void APSpacePartitioning::SNCH_Object_Data::calcSubtreeTriangleRepresentant | ( | void * | pNode,
 |  | osg::Vec3 * | axis,
 |  | unsigned long * | triangle,
 |  | float * | bestValue = NULL
 | ) |  |
protected
bool APSpacePartitioning::SNCH_Object_Data::calculateGeometryProperties ( void )
protected
bool APSpacePartitioning::SNCH_Object_Data::computeSNCH ( void * pSTNode )
protected
bool APSpacePartitioning::SNCH_Object_Data::constructCacheDataName | ( | char * | pOutDataName,
 |  | int * | version
 | ) |  |
protectedvirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::coreHierarchyCreation ( void )
protectedvirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::createEdgeGroups ( void )
protected
bool APSpacePartitioning::SNCH_Object_Data::createFaceGroups ( void )
protected
virtual void APSpacePartitioning::SNCH_Object_Data::deallocateFaceArray ( )
inlinevirtual

deallocate the space required for faces

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

virtual void APSpacePartitioning::SNCH_Object_Data::deallocateVertexArray ( )
inlinevirtual

deallocate the unnecessary space

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

bool APSpacePartitioning::SNCH_Object_Data::generateVertexNeighbourhood ( void )
protected
virtual unsigned long APSpacePartitioning::SNCH_Object_Data::getFaceStructureSize ( )
inlinevirtual

returns the size of structure of stored faces

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

FaceSNCH* APSpacePartitioning::SNCH_Object_Data::getSNCHFace ( unsigned long index )
inline
VertexSNCH* APSpacePartitioning::SNCH_Object_Data::getSNCHVertex ( unsigned long index )
inline
virtual unsigned long APSpacePartitioning::SNCH_Object_Data::getSTNodeStructureSize ( )
inlinevirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

virtual unsigned long APSpacePartitioning::SNCH_Object_Data::getVertexStructureSize ( )
inlinevirtual

returns the size of structure of stored vertices

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

virtual bool APSpacePartitioning::SNCH_Object_Data::isHierarchyCreated ( )
inlinevirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::loadDataFromPersistentCache_Init ( )
protectedvirtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::loadFacesFromFile ( vrecko::BufferedFile * bfile )
virtual

loads the faces to separate file

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

bool APSpacePartitioning::SNCH_Object_Data::loadTreeNodeFromFile | ( | void * | node,
 |  | vrecko::BufferedFile * | bfile
 | ) |  |
virtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::loadVerticesFromFile ( vrecko::BufferedFile * bfile )
virtual

load the vertice from separate file

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

bool APSpacePartitioning::SNCH_Object_Data::saveFacesToFile ( vrecko::BufferedFileWrite * bfile )
virtual

saves the faces to separate file

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

bool APSpacePartitioning::SNCH_Object_Data::saveTreeNodeToFile | ( | void * | node,
 |  | vrecko::BufferedFileWrite * | bfile
 | ) |  |
virtual

Reimplemented from APSpacePartitioning::SphereBVH_Object_Data.

bool APSpacePartitioning::SNCH_Object_Data::saveVerticesToFile ( vrecko::BufferedFileWrite * bfile )
virtual

saving the vertices to separate file

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

void APSpacePartitioning::SNCH_Object_Data::wdsInfoRec | ( | void * | pSTNode,
 |  | int | level,
 |  | DebugStats * | ds
 | ) |  |
protected
void APSpacePartitioning::SNCH_Object_Data::writeDebugStatistics ( )
protected

Member Data Documentation

bool APSpacePartitioning::SNCH_Object_Data::bSNCHierarchyCreated
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SNCH_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data::DebugLevelStats Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • DebugLevelStats
Public Member Functions | Public Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data::DebugLevelStats Struct Reference

#include <SNCH_Object_Data.h>

Public Member Functions

DebugLevelStats ()

Public Attributes

int | cntNodes
float | cntAngle
float | cntRadius

Constructor & Destructor Documentation

APSpacePartitioning::SNCH_Object_Data::DebugLevelStats::DebugLevelStats ( )
inline

Member Data Documentation

float APSpacePartitioning::SNCH_Object_Data::DebugLevelStats::cntAngle
int APSpacePartitioning::SNCH_Object_Data::DebugLevelStats::cntNodes
float APSpacePartitioning::SNCH_Object_Data::DebugLevelStats::cntRadius
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data::DebugStats Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • DebugStats
Public Member Functions | Public Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data::DebugStats Struct Reference

#include <SNCH_Object_Data.h>

Public Member Functions

DebugStats ()

Public Attributes

int | totalNodes
int | twoTotal
int | twoNeighbours
DynamicArray< DebugLevelStats > levels

Constructor & Destructor Documentation

APSpacePartitioning::SNCH_Object_Data::DebugStats::DebugStats ( )
inline

Member Data Documentation

DynamicArray<DebugLevelStats> APSpacePartitioning::SNCH_Object_Data::DebugStats::levels
int APSpacePartitioning::SNCH_Object_Data::DebugStats::totalNodes
int APSpacePartitioning::SNCH_Object_Data::DebugStats::twoNeighbours
int APSpacePartitioning::SNCH_Object_Data::DebugStats::twoTotal
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data::FaceSNCH Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • FaceSNCH
Public Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data::FaceSNCH Struct Reference

#include <SNCH_Object_Data.h>

Inheritance diagram for APSpacePartitioning::SNCH_Object_Data::FaceSNCH:

Public Attributes

unsigned long | dwSNCHFlags
unsigned long | fIndex [3]
unsigned long | edgeFlags [3]
unsigned long | dwGroup

Member Data Documentation

unsigned long APSpacePartitioning::SNCH_Object_Data::FaceSNCH::dwGroup
unsigned long APSpacePartitioning::SNCH_Object_Data::FaceSNCH::dwSNCHFlags
unsigned long APSpacePartitioning::SNCH_Object_Data::FaceSNCH::edgeFlags[3]
unsigned long APSpacePartitioning::SNCH_Object_Data::FaceSNCH::fIndex[3]
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data::STNodeSNCH Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • STNodeSNCH
Public Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data::STNodeSNCH Struct Reference

#include <SNCH_Object_Data.h>

Inheritance diagram for APSpacePartitioning::SNCH_Object_Data::STNodeSNCH:

Public Attributes

osg::Vec3 | cone_axis
float | half_spread_angle

Member Data Documentation

osg::Vec3 APSpacePartitioning::SNCH_Object_Data::STNodeSNCH::cone_axis
float APSpacePartitioning::SNCH_Object_Data::STNodeSNCH::half_spread_angle
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SNCH_Object_Data::VertexSNCH Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • VertexSNCH
Public Attributes | List of all members
APSpacePartitioning::SNCH_Object_Data::VertexSNCH Struct Reference

#include <SNCH_Object_Data.h>

Inheritance diagram for APSpacePartitioning::SNCH_Object_Data::VertexSNCH:
APSpacePartitioning::GeometryLoaderBase::VertexBase

Public Attributes

std::vector< unsigned long > | faces
osg::Vec3 | averageNormal
unsigned long | dwRepresentant
- Public Attributes inherited from APSpacePartitioning::GeometryLoaderBase::VertexBase
osg::Vec3 | pos
osg::Vec3 | normal

Member Data Documentation

osg::Vec3 APSpacePartitioning::SNCH_Object_Data::VertexSNCH::averageNormal
unsigned long APSpacePartitioning::SNCH_Object_Data::VertexSNCH::dwRepresentant
std::vector<unsigned long> APSpacePartitioning::SNCH_Object_Data::VertexSNCH::faces
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SP_Object_Data_Base Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SP_Object_Data_Base
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
APSpacePartitioning::SP_Object_Data_Base Class Reference

#include <SP_Object_Data_Base.h>

Inheritance diagram for APSpacePartitioning::SP_Object_Data_Base:
vrecko::SP_Object_DataInterface vrecko::Ability vrecko::BaseClass APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > APSpacePartitioning::SphereBVH_Object_Data APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > APSpacePartitioning::SNCH_Object_Data APSpacePartitioning::PointShell_Object_Data

Public Member Functions

SP_Object_Data_Base (const char *abName)
~SP_Object_Data_Base ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
virtual bool | isHierarchyCreated ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | startThreadedHierarchyCreation ()
virtual void | destroyThread ()
virtual bool | coreHierarchyCreation ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

vrecko::EnvironmentObject * owner
HANDLE | hHierarchyCreationThread
bool | bThreadShouldTerminate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Friends

DWORD WINAPI HierarchyThreadProc (SP_Object_Data_Base *lpParameter)

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APSpacePartitioning::SP_Object_Data_Base::SP_Object_Data_Base ( const char * abName )
APSpacePartitioning::SP_Object_Data_Base::~SP_Object_Data_Base ( )
inline

Member Function Documentation

virtual bool APSpacePartitioning::SP_Object_Data_Base::coreHierarchyCreation ( void )
inlineprotectedvirtual

Reimplemented in APSpacePartitioning::PointShell_Object_Data, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >, APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >, APSpacePartitioning::SNCH_Object_Data, and APSpacePartitioning::SphereBVH_Object_Data.

void APSpacePartitioning::SP_Object_Data_Base::destroyThread ( )
protectedvirtual
void APSpacePartitioning::SP_Object_Data_Base::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool APSpacePartitioning::SP_Object_Data_Base::startThreadedHierarchyCreation ( )
protectedvirtual
void APSpacePartitioning::SP_Object_Data_Base::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Friends And Related Function Documentation

DWORD WINAPI HierarchyThreadProc ( SP_Object_Data_Base * lpParameter )
friend

Member Data Documentation

bool APSpacePartitioning::SP_Object_Data_Base::bThreadShouldTerminate
protected
HANDLE APSpacePartitioning::SP_Object_Data_Base::hHierarchyCreationThread
protected
vrecko::EnvironmentObject* APSpacePartitioning::SP_Object_Data_Base::owner
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SP_Object_Data_Base.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SP_Object_Data_Base.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SphereBVH_Object Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object
Public Member Functions | List of all members
APSpacePartitioning::SphereBVH_Object Class Reference

#include <SphereBVH_Object.h>

Inheritance diagram for APSpacePartitioning::SphereBVH_Object:
vrecko::SP_ObjectInterface vrecko::Ability vrecko::BaseClass APSpacePartitioning::SNCH_Object

Public Member Functions

SphereBVH_Object ()
~SphereBVH_Object ()
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID)
- Public Member Functions inherited from vrecko::SP_ObjectInterface
SP_ObjectInterface ()
~SP_ObjectInterface ()
int | getId ()
usually one of the SP_OBJECT_INTERFACE_ID__* constants More...
virtual bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::SP_ObjectInterface
int | objIntId
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

SphereBVH_Object::SphereBVH_Object ( )
SphereBVH_Object::~SphereBVH_Object ( )

Member Function Documentation

bool SphereBVH_Object::getCollisions | ( | CollisionParams * | params,
 |  | COLLISION_POINTS_VECTOR ** | colPoints,
 |  | unsigned long | obj1ID,
 |  | unsigned long | obj2ID
 | ) |  |
void SphereBVH_Object::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

Reimplemented in APSpacePartitioning::SNCH_Object.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Object.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SphereBVH_Object_Data Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object_Data
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::SphereBVH_Object_Data Class Reference

#include <SphereBVH_Object_Data.h>

Inheritance diagram for APSpacePartitioning::SphereBVH_Object_Data:
APSpacePartitioning::GeometryLoaderBase APSpacePartitioning::SP_Object_Data_Base vrecko::SP_Object_DataInterface vrecko::Ability vrecko::BaseClass APSpacePartitioning::SNCH_Object_Data

Classes

struct STNodeSphere

Public Member Functions

SphereBVH_Object_Data ()
SphereBVH_Object_Data (const char *abName)
~SphereBVH_Object_Data ()
virtual bool | isHierarchyCreated ()
virtual void * | allocateSTNode ()
virtual unsigned long | getSTNodeStructureSize ()
virtual bool | saveTreeNodeToFile (void *node, vrecko::BufferedFileWrite *bfile)
virtual bool | loadTreeNodeFromFile (void *node, vrecko::BufferedFile *bfile)
void * | getRootPtr (void)
virtual bool | destroyHierarchy (STNodeSphere *subTreeToDestroy=NULL)
- Public Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | loadGeometry (osg::Node *pNode)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()
- Public Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
SP_Object_Data_Base (const char *abName)
~SP_Object_Data_Base ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual bool | constructCacheDataName (char *pOutDataName, int *version)
virtual bool | saveDataToPersistentCache_Init ()
virtual bool | saveDataToPersistentCache_WriteData (vrecko::BufferedFileWrite *bfile)
virtual bool | saveDataToPC_SaveTreeNode (vrecko::BufferedFileWrite *bfile, STNodeSphere *node)
virtual bool | loadDataFromPersistentCache_Init ()
virtual bool | loadDataFromPersistentCache_ReadData (vrecko::BufferedFile *bfile)
virtual bool | loadDataFromPC_LoadTreeNode (vrecko::BufferedFile *bfile, STNodeSphere **ptrToStoreNode)
virtual bool | createTreeFromGeometry (osg::Node *pNode)
bool | constructTree (void *pSTNode, unsigned long left_pos, unsigned long right_pos, int last_sort)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
virtual bool | coreHierarchyCreation (void)
- Protected Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
- Protected Member Functions inherited from APSpacePartitioning::SP_Object_Data_Base
virtual bool | startThreadedHierarchyCreation ()
virtual void | destroyThread ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bSphereBVHierarchyCreated
void * | root
- Protected Attributes inherited from APSpacePartitioning::GeometryLoaderBase
void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
- Protected Attributes inherited from APSpacePartitioning::SP_Object_Data_Base
vrecko::EnvironmentObject * owner
HANDLE | hHierarchyCreationThread
bool | bThreadShouldTerminate
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APSpacePartitioning::SphereBVH_Object_Data::SphereBVH_Object_Data ( )
APSpacePartitioning::SphereBVH_Object_Data::SphereBVH_Object_Data ( const char * abName )
APSpacePartitioning::SphereBVH_Object_Data::~SphereBVH_Object_Data ( )

Member Function Documentation

virtual void* APSpacePartitioning::SphereBVH_Object_Data::allocateSTNode ( )
inlinevirtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

bool APSpacePartitioning::SphereBVH_Object_Data::constructCacheDataName | ( | char * | pOutDataName,
 |  | int * | version
 | ) |  |
protectedvirtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

bool APSpacePartitioning::SphereBVH_Object_Data::constructTree | ( | void * | pSTNode,
 |  | unsigned long | left_pos,
 |  | unsigned long | right_pos,
 |  | int | last_sort
 | ) |  |
protected
bool APSpacePartitioning::SphereBVH_Object_Data::coreHierarchyCreation ( void )
protectedvirtual

Reimplemented from APSpacePartitioning::SP_Object_Data_Base.

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

bool APSpacePartitioning::SphereBVH_Object_Data::createTreeFromGeometry ( osg::Node * pNode )
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::destroyHierarchy ( STNodeSphere * subTreeToDestroy = NULL )
virtual
void* APSpacePartitioning::SphereBVH_Object_Data::getRootPtr ( void )
inline
virtual unsigned long APSpacePartitioning::SphereBVH_Object_Data::getSTNodeStructureSize ( )
inlinevirtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

virtual bool APSpacePartitioning::SphereBVH_Object_Data::isHierarchyCreated ( )
inlinevirtual

Reimplemented from vrecko::SP_Object_DataInterface.

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

bool APSpacePartitioning::SphereBVH_Object_Data::loadDataFromPC_LoadTreeNode | ( | vrecko::BufferedFile * | bfile,
 |  | STNodeSphere ** | ptrToStoreNode
 | ) |  |
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::loadDataFromPersistentCache_Init ( )
protectedvirtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

bool APSpacePartitioning::SphereBVH_Object_Data::loadDataFromPersistentCache_ReadData ( vrecko::BufferedFile * bfile )
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::loadTreeNodeFromFile | ( | void * | node,
 |  | vrecko::BufferedFile * | bfile
 | ) |  |
virtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

int APSpacePartitioning::SphereBVH_Object_Data::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

bool APSpacePartitioning::SphereBVH_Object_Data::saveDataToPC_SaveTreeNode | ( | vrecko::BufferedFileWrite * | bfile,
 |  | STNodeSphere * | node
 | ) |  |
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::saveDataToPersistentCache_Init ( )
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::saveDataToPersistentCache_WriteData ( vrecko::BufferedFileWrite * bfile )
protectedvirtual
bool APSpacePartitioning::SphereBVH_Object_Data::saveTreeNodeToFile | ( | void * | node,
 |  | vrecko::BufferedFileWrite * | bfile
 | ) |  |
virtual

Reimplemented in APSpacePartitioning::SNCH_Object_Data.

Member Data Documentation

bool APSpacePartitioning::SphereBVH_Object_Data::bSphereBVHierarchyCreated
protected
void* APSpacePartitioning::SphereBVH_Object_Data::root
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object_Data
  • STNodeSphere
Public Attributes | List of all members
APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere Struct Reference

#include <SphereBVH_Object_Data.h>

Public Attributes

void * | pParent
osg::Vec3 | center
float | radius
void * | pChild [2]
unsigned long int | face_index

Member Data Documentation

osg::Vec3 APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere::center
unsigned long int APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere::face_index
void* APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere::pChild[2]
void* APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere::pParent
float APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere::radius
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::SphereBVH_Scene Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Scene
Public Member Functions | List of all members
APSpacePartitioning::SphereBVH_Scene Class Reference

#include <SphereBVH_Scene.h>

Inheritance diagram for APSpacePartitioning::SphereBVH_Scene:
vrecko::SP_SceneInterface vrecko::Ability vrecko::BaseClass

Public Member Functions

SphereBVH_Scene ()
~SphereBVH_Scene ()
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::SP_SceneInterface
SP_SceneInterface ()
~SP_SceneInterface ()
int | getId ()
virtual bool | performCompleteTest (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)
virtual bool | performUpdate (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::SP_SceneInterface
int | scIntId
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

APSpacePartitioning::SphereBVH_Scene::SphereBVH_Scene ( )
inline
APSpacePartitioning::SphereBVH_Scene::~SphereBVH_Scene ( )
inline

Member Function Documentation

void APSpacePartitioning::SphereBVH_Scene::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Scene.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Scene.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::VoxelGrid_Object_Data Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VoxelGrid_Object_Data
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APSpacePartitioning::VoxelGrid_Object_Data Class Reference

#include <VoxelGrid_Object_Data.h>

Inheritance diagram for APSpacePartitioning::VoxelGrid_Object_Data:
vrecko::SP_Object_DataInterface APSpacePartitioning::GeometryLoaderBase vrecko::Ability vrecko::BaseClass

Public Member Functions

VoxelGrid_Object_Data ()
~VoxelGrid_Object_Data ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
virtual bool | isHierarchyCreated ()
virtual bool | createHierarchy (void)
unsigned long | getXDFDim ()
unsigned long | getYDFDim ()
unsigned long | getZDFDim ()
osg::BoundingBox & | getBBoxDF ()
float | getDistanceFieldValue (int x, int y, int z)
int | getDistanceFieldValueEffect (unsigned long x, unsigned long y, unsigned long z, int level)
float | getDistanceTempFieldValue (int x, int y, int z)
float | getRequestedCellSize ()
osg::Vec3 & | getBBoxDFSize ()
void | VoxelGrid_Object_Data::increaseVoxelValueCollisions (int x, int y, int z)
void | VoxelGrid_Object_Data::setVoxelValueCollisions (int x, int y, int z, int value)
int | VoxelGrid_Object_Data::getCollisions (int x, int y, int z)
osg::Vec4f | returnColorOfVoxel (int x, int y, int z)
- Public Member Functions inherited from vrecko::SP_Object_DataInterface
SP_Object_DataInterface ()
~SP_Object_DataInterface ()
- Public Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
GeometryLoaderBase ()
~GeometryLoaderBase ()
virtual bool | loadGeometry (osg::Node *pNode)
virtual unsigned long | getVertexStructureSize ()
virtual void | allocateVertexArray (unsigned long numVertices)
virtual void | deallocateVertexArray ()
virtual bool | saveVerticesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadVerticesFromFile (vrecko::BufferedFile *bfile)
virtual unsigned long | getFaceStructureSize ()
virtual void | allocateFaceArray (unsigned long numFaces)
virtual void | deallocateFaceArray ()
virtual bool | saveFacesToFile (vrecko::BufferedFileWrite *bfile)
virtual bool | loadFacesFromFile (vrecko::BufferedFile *bfile)
void * | getFace (unsigned long index)
void * | getVertex (unsigned long index)
unsigned long | getFaceCount ()
unsigned long | getVertexCount ()
void | debugWriteNormals ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | createDistanceFieldGrid ()
void | destroyDistanceFieldGrid ()
bool | createDistanceFieldTempGrid ()
void | destroyDistanceFieldTempGrid ()
bool | createDistanceFieldGridCollision ()
void | destroyDistanceFieldGridCollision ()
void | setDistanceFieldValue (unsigned long x, unsigned long y, unsigned long z, float newValue)
void | setDistanceFieldTempValue (unsigned long x, unsigned long y, unsigned long z, float newValue)
bool | constructCacheDataName (char *pOutDataName)
bool | loadFromCache (const char *pModelFileName)
bool | saveToCache (const char *pModelFileName)
bool | loadGridFromFile (vrecko::BufferedFile *bfile)
bool | saveGridToFile (vrecko::BufferedFileWrite *bfile)
bool | saveCollisions ()
bool | saveCollisionsToFile (vrecko::BufferedFileWrite *bfile)
bool | loadCollisions ()
bool | loadCollisionsFromFile (vrecko::BufferedFile *bfile)
bool | updateDataInformation (char *data, char *file)
- Protected Member Functions inherited from APSpacePartitioning::GeometryLoaderBase
bool | getOSGInitCounts (osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount)
bool | loadGeometryHelper (osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos)
void | sortVerticesClockwise ()
virtual void | destroyGeometry ()
void | recalculateNormals ()
osg::Vec3 * | getNormalByIndex (osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bGridCreated
bool | bGridFilled
bool | bCollisionCreated
int | iMaxCollisionsFromLoadedVoxel
int | dFXDim
int | dFYDim
int | dFZDim
double | dRequestedCellLength
int | iDilatation
int | iDilatationStrategy
int | iGenType
float * | distanceField
float * | distanceFieldTemp
int * | distanceFieldCollsions
osg::BoundingBox | bboxDF
osg::Vec3f | bboxSizeDF
- Protected Attributes inherited from APSpacePartitioning::GeometryLoaderBase
void * | faces
unsigned long | face_count
unsigned long | face_size
void * | vertices
unsigned long | vertex_count
unsigned long | vertex_size
bool | bRecalculateNormals
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APSpacePartitioning::VoxelGrid_Object_Data::VoxelGrid_Object_Data ( )
APSpacePartitioning::VoxelGrid_Object_Data::~VoxelGrid_Object_Data ( )

Member Function Documentation

bool APSpacePartitioning::VoxelGrid_Object_Data::constructCacheDataName ( char * pOutDataName )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::createDistanceFieldGrid ( )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::createDistanceFieldGridCollision ( )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::createDistanceFieldTempGrid ( )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::createHierarchy ( void )
virtual
void APSpacePartitioning::VoxelGrid_Object_Data::destroyDistanceFieldGrid ( )
protected
void APSpacePartitioning::VoxelGrid_Object_Data::destroyDistanceFieldGridCollision ( )
protected
void APSpacePartitioning::VoxelGrid_Object_Data::destroyDistanceFieldTempGrid ( )
protected
osg::BoundingBox& APSpacePartitioning::VoxelGrid_Object_Data::getBBoxDF ( )
inline
osg::Vec3& APSpacePartitioning::VoxelGrid_Object_Data::getBBoxDFSize ( )
inline
float APSpacePartitioning::VoxelGrid_Object_Data::getDistanceFieldValue | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |
inline
int APSpacePartitioning::VoxelGrid_Object_Data::getDistanceFieldValueEffect | ( | unsigned long | x,
 |  | unsigned long | y,
 |  | unsigned long | z,
 |  | int | level
 | ) |  |
inline
float APSpacePartitioning::VoxelGrid_Object_Data::getDistanceTempFieldValue | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |
inline
float APSpacePartitioning::VoxelGrid_Object_Data::getRequestedCellSize ( )
inline
unsigned long APSpacePartitioning::VoxelGrid_Object_Data::getXDFDim ( )
inline
unsigned long APSpacePartitioning::VoxelGrid_Object_Data::getYDFDim ( )
inline
unsigned long APSpacePartitioning::VoxelGrid_Object_Data::getZDFDim ( )
inline
virtual bool APSpacePartitioning::VoxelGrid_Object_Data::isHierarchyCreated ( )
inlinevirtual

Reimplemented from vrecko::SP_Object_DataInterface.

bool APSpacePartitioning::VoxelGrid_Object_Data::loadCollisions ( )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::loadCollisionsFromFile ( vrecko::BufferedFile * bfile )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::loadFromCache ( const char * pModelFileName )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::loadGridFromFile ( vrecko::BufferedFile * bfile )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
virtual

Reimplemented from APSpacePartitioning::GeometryLoaderBase.

void APSpacePartitioning::VoxelGrid_Object_Data::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APSpacePartitioning::VoxelGrid_Object_Data::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

osg::Vec4f APSpacePartitioning::VoxelGrid_Object_Data::returnColorOfVoxel | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |
inline
bool APSpacePartitioning::VoxelGrid_Object_Data::saveCollisions ( )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::saveCollisionsToFile ( vrecko::BufferedFileWrite * bfile )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::saveGridToFile ( vrecko::BufferedFileWrite * bfile )
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::saveToCache ( const char * pModelFileName )
protected
void APSpacePartitioning::VoxelGrid_Object_Data::setDistanceFieldTempValue | ( | unsigned long | x,
 |  | unsigned long | y,
 |  | unsigned long | z,
 |  | float | newValue
 | ) |  |
inlineprotected
void APSpacePartitioning::VoxelGrid_Object_Data::setDistanceFieldValue | ( | unsigned long | x,
 |  | unsigned long | y,
 |  | unsigned long | z,
 |  | float | newValue
 | ) |  |
inlineprotected
void APSpacePartitioning::VoxelGrid_Object_Data::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

bool APSpacePartitioning::VoxelGrid_Object_Data::updateDataInformation | ( | char * | data,
 |  | char * | file
 | ) |  |
protected
int APSpacePartitioning::VoxelGrid_Object_Data::VoxelGrid_Object_Data::getCollisions | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |
inline
void APSpacePartitioning::VoxelGrid_Object_Data::VoxelGrid_Object_Data::increaseVoxelValueCollisions | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |
inline
void APSpacePartitioning::VoxelGrid_Object_Data::VoxelGrid_Object_Data::setVoxelValueCollisions | ( | int | x,
 |  | int | y,
 |  | int | z,
 |  | int | value
 | ) |  |
inline

Member Data Documentation

osg::BoundingBox APSpacePartitioning::VoxelGrid_Object_Data::bboxDF
protected
osg::Vec3f APSpacePartitioning::VoxelGrid_Object_Data::bboxSizeDF
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::bCollisionCreated
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::bGridCreated
protected
bool APSpacePartitioning::VoxelGrid_Object_Data::bGridFilled
protected
int APSpacePartitioning::VoxelGrid_Object_Data::dFXDim
protected
int APSpacePartitioning::VoxelGrid_Object_Data::dFYDim
protected
int APSpacePartitioning::VoxelGrid_Object_Data::dFZDim
protected
float* APSpacePartitioning::VoxelGrid_Object_Data::distanceField
protected
int* APSpacePartitioning::VoxelGrid_Object_Data::distanceFieldCollsions
protected
float* APSpacePartitioning::VoxelGrid_Object_Data::distanceFieldTemp
protected
double APSpacePartitioning::VoxelGrid_Object_Data::dRequestedCellLength
protected
int APSpacePartitioning::VoxelGrid_Object_Data::iDilatation
protected
int APSpacePartitioning::VoxelGrid_Object_Data::iDilatationStrategy
protected
int APSpacePartitioning::VoxelGrid_Object_Data::iGenType
protected
int APSpacePartitioning::VoxelGrid_Object_Data::iMaxCollisionsFromLoadedVoxel
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APSpacePartitioning::VGReadCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VGReadCallback
Public Member Functions | List of all members
APSpacePartitioning::VGReadCallback Struct Reference
Inheritance diagram for APSpacePartitioning::VGReadCallback:

Public Member Functions

virtual osg::Node * readNodeFile (const std::string &filename)

Member Function Documentation

virtual osg::Node* APSpacePartitioning::VGReadCallback::readNodeFile ( const std::string & filename )
inlinevirtual
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APTextOutput::Console Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APTextOutput
  • Console
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
APTextOutput::Console Class Reference

#include <Console.h>

Inheritance diagram for APTextOutput::Console:
vrecko::Ability vrecko::BaseClass

Classes

class Line

Public Member Functions

Console ()
~Console ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | addLine (const char *line, const osg::Vec4 &color=*((osg::Vec4 *) NULL))
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_INPUT (Add, MessageString, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector< Line > | lines
int | viewWidth
int | viewHeight
int | borderXSize
int | borderYSize
int | lineSpace
float | slideMax
osg::Timer_t | menuAwayTime
bool | bNewItemAdded
osg::ref_ptr
< vrecko::EnvironmentObject > 		eo
APObjectUtils::Animator * animator
osg::ref_ptr< osg::Camera > | camera
osg::ref_ptr< osg::Geode > | geode
osg::ref_ptr< osg::Geometry > | geom
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

APTextOutput::Console::Console ( )
APTextOutput::Console::~Console ( )

Member Function Documentation

void APTextOutput::Console::addLine | ( | const char * | line,
 |  | const osg::Vec4 & | color = *((osg::Vec4*)NULL)
 | ) |  |
APTextOutput::Console::DECLARE_REQUEST_INPUT | ( | Add | ,
 |  | MessageString | ,
 |  | MessageVoid |
 | ) |  |
protected
bool APTextOutput::Console::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void APTextOutput::Console::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APTextOutput::Console::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void APTextOutput::Console::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

APObjectUtils::Animator* APTextOutput::Console::animator
protected
bool APTextOutput::Console::bNewItemAdded
protected
int APTextOutput::Console::borderXSize
protected
int APTextOutput::Console::borderYSize
protected
osg::ref_ptr<osg::Camera> APTextOutput::Console::camera
protected
osg::ref_ptr<vrecko::EnvironmentObject> APTextOutput::Console::eo
protected
osg::ref_ptr<osg::Geode> APTextOutput::Console::geode
protected
osg::ref_ptr<osg::Geometry> APTextOutput::Console::geom
protected
std::vector<Line> APTextOutput::Console::lines
protected
int APTextOutput::Console::lineSpace
protected
osg::Timer_t APTextOutput::Console::menuAwayTime
protected
float APTextOutput::Console::slideMax
protected
int APTextOutput::Console::viewHeight
protected
int APTextOutput::Console::viewWidth
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/Console.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/TextOutput/Console.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APTextOutput::Console::Line Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APTextOutput
  • Console
  • Line
Public Attributes | List of all members
APTextOutput::Console::Line Class Reference

#include <Console.h>

Public Attributes

osg::ref_ptr< osgText::Text > | text
osg::Timer_t | logTime
osg::Timer_t | necessaryTime

Member Data Documentation

osg::Timer_t APTextOutput::Console::Line::logTime
osg::Timer_t APTextOutput::Console::Line::necessaryTime
osg::ref_ptr<osgText::Text> APTextOutput::Console::Line::text
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/Console.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: APWeather::Weather Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APWeather
  • Weather
Public Member Functions | Protected Attributes | List of all members
APWeather::Weather Class Reference

#include <Weather.h>

Inheritance diagram for APWeather::Weather:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Weather ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
bool | addToScene ()
bool | removeFromScene ()
osgParticle::PrecipitationEffect * | getEffect ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::ref_ptr
< osgParticle::PrecipitationEffect > 		_effect
osg::ref_ptr
< osg::MatrixTransform > 		_transformNode
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

APWeather::Weather::Weather ( )

Member Function Documentation

bool APWeather::Weather::addToScene ( )
osgParticle::PrecipitationEffect* APWeather::Weather::getEffect ( )
inline
bool APWeather::Weather::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

bool APWeather::Weather::removeFromScene ( )

Member Data Documentation

osg::ref_ptr<osgParticle::PrecipitationEffect> APWeather::Weather::_effect
protected
osg::ref_ptr<osg::MatrixTransform> APWeather::Weather::_transformNode
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Weather/Weather.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Weather/Weather.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::BlockAttributes Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • BlockAttributes
Public Member Functions | List of all members
ArtificialWorld::BlockAttributes Class Reference

Atributy bloku. More...

#include <BlockUpdater.h>

Public Member Functions

BlockAttributes ()
void | SetObjectCenterDir (osg::Vec3 newCenterDir)
nastavi smerovy vektor ke stredu objektu More...
void | SetObjectCenterPoint (osg::Vec3 newCenterPoint)
nastavi pozici stredu objektu More...
osg::Vec3 | GetObjectCenterDir (void)
vrati smerovy vektor ke stredu objektu More...
osg::Vec3 | GetObjectCenterPoint (void)
vrati pozici stredu objektu More...
BlockAttributesSetEnum | WhatIsSet (void)
vrati, jaky typ identifikace stredu objektu je pouzit More...

Detailed Description

Atributy bloku.

Constructor & Destructor Documentation

ArtificialWorld::BlockAttributes::BlockAttributes ( )
inline

Member Function Documentation

osg::Vec3 ArtificialWorld::BlockAttributes::GetObjectCenterDir ( void )
inline

vrati smerovy vektor ke stredu objektu

osg::Vec3 ArtificialWorld::BlockAttributes::GetObjectCenterPoint ( void )
inline

vrati pozici stredu objektu

void ArtificialWorld::BlockAttributes::SetObjectCenterDir ( osg::Vec3 newCenterDir )
inline

nastavi smerovy vektor ke stredu objektu

void ArtificialWorld::BlockAttributes::SetObjectCenterPoint ( osg::Vec3 newCenterPoint )
inline

nastavi pozici stredu objektu

BlockAttributesSetEnum ArtificialWorld::BlockAttributes::WhatIsSet ( void )
inline

vrati, jaky typ identifikace stredu objektu je pouzit

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/BlockUpdater.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::BlockUpdater Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • BlockUpdater
Public Member Functions | List of all members
ArtificialWorld::BlockUpdater Class Reference

Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky. More...

#include <BlockUpdater.h>

Inheritance diagram for ArtificialWorld::BlockUpdater:
vrecko::Ability vrecko::BaseClass

Public Member Functions

BlockUpdater ()
~BlockUpdater ()
virtual void | update (void)
Aktualizace kazdy Frame. More...
virtual void | preInitialize (void)
Predpriprava pred LoadXMLParametersFromFile. More...
virtual void | postInitialize (void)
Po LoadXMLParametersFromFile. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
nepouziva se More...
bool | LoadXMLParametersFromFile (string filename)
nahraje nastaveni tohoto bloku ze zadaneho souboru More...
void | SetParentEO (EnvironmentObject *newParentEO)
nastavi EO, reprezentujici blok ve scene, o ktere se ma tento Updater starat More...
void | Hide ()
schovej owner EO More...
void | Show ()
zobraz owner EO More...
void | HideSubBlocks ()
skryj subbloky More...
void | ShowSubBlocks ()
zobraz subbloky More...
bool | IsVisible ()
je tento subblok viditelny? More...
string | GetBlockType (void)
vrati typ tohoto bloku More...
vector< SubBlock * > | GetSubBlocks (void)
vrati seznam subbloku tohoto bloku More...
vector< BlockUpdater * > | GetSubBlocksUpdaters (void)
vrati seznam BlockUpdateru, ktere jsou asociovany se subbloky tohoto bloku More...
vector< Model * > | GetModels (void)
vrati seznam modelu tohoto bloku (Graphics) More...
osg::Vec4 | GetBoundingSphere (void)
vrati obalovou kouli tohoto bloku More...
osg::Vec3 * | GetBoundingBox (void)
vrati obalovy kvadr tohoto bloku More...
BlockAttributes * | GetAttributes (void)
vrati logicke atributy tohoto bloku More...
list< Model * > | getVisibleModels (osg::Vec3 position)
na zaklade pozice ziska viditelne modely, neni-li zadny viditelny, pak prazdny seznam More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMDocument * 		getDOMDocument ()
osg::Vec3 | GetCurrentWorldPosition (void)
Vrati aktualni svetovou pozici EO, o ktery se stara. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky.

Constructor & Destructor Documentation

BlockUpdater::BlockUpdater ( )
BlockUpdater::~BlockUpdater ( )

Member Function Documentation

BlockAttributes* ArtificialWorld::BlockUpdater::GetAttributes ( void )
inline

vrati logicke atributy tohoto bloku

string ArtificialWorld::BlockUpdater::GetBlockType ( void )
inline

vrati typ tohoto bloku

osg::Vec3* ArtificialWorld::BlockUpdater::GetBoundingBox ( void )
inline

vrati obalovy kvadr tohoto bloku

osg::Vec4 ArtificialWorld::BlockUpdater::GetBoundingSphere ( void )
inline

vrati obalovou kouli tohoto bloku

osg::Vec3 ArtificialWorld::BlockUpdater::GetCurrentWorldPosition ( void )
inline

Vrati aktualni svetovou pozici EO, o ktery se stara.

XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* ArtificialWorld::BlockUpdater::getDOMDocument ( )
inline
vector<Model*> ArtificialWorld::BlockUpdater::GetModels ( void )
inline

vrati seznam modelu tohoto bloku (Graphics)

vector<SubBlock*> ArtificialWorld::BlockUpdater::GetSubBlocks ( void )
inline

vrati seznam subbloku tohoto bloku

vector<BlockUpdater*> ArtificialWorld::BlockUpdater::GetSubBlocksUpdaters ( void )
inline

vrati seznam BlockUpdateru, ktere jsou asociovany se subbloky tohoto bloku

list< Model * > BlockUpdater::getVisibleModels ( osg::Vec3 position )

na zaklade pozice ziska viditelne modely, neni-li zadny viditelny, pak prazdny seznam

ziska seznam modelu viditelnych z dane pozice

void BlockUpdater::Hide ( )

schovej owner EO

skryj sebe

void BlockUpdater::HideSubBlocks ( )

skryj subbloky

bool BlockUpdater::IsVisible ( )

je tento subblok viditelny?

jsem zobrazeny?

bool BlockUpdater::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

nepouziva se

Reimplemented from vrecko::BaseClass.

bool BlockUpdater::LoadXMLParametersFromFile ( string filename )

nahraje nastaveni tohoto bloku ze zadaneho souboru

nacte konfiguraci z XML

void BlockUpdater::postInitialize ( void )
virtual

Po LoadXMLParametersFromFile.

provadi se po nacteni konfigurace z xml

Reimplemented from vrecko::BaseClass.

void BlockUpdater::preInitialize ( void )
virtual

Predpriprava pred LoadXMLParametersFromFile.

Reimplemented from vrecko::BaseClass.

void BlockUpdater::SetParentEO ( EnvironmentObject * newParentEO )

nastavi EO, reprezentujici blok ve scene, o ktere se ma tento Updater starat

nastavi rodicovske EO

void BlockUpdater::Show ( )

zobraz owner EO

zobraz sebe

void BlockUpdater::ShowSubBlocks ( )

zobraz subbloky

void BlockUpdater::update ( void )
virtual

Aktualizace kazdy Frame.

aktualizace jednou za frame

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/BlockUpdater.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/BlockUpdater.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::Model Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • Model
Public Member Functions | Public Attributes | Protected Attributes | List of all members
ArtificialWorld::Model Class Reference

Uchovava informace o modelu. More...

#include <model.h>

Inheritance diagram for ArtificialWorld::Model:
ArtificialWorld::AnimatedModel

Public Member Functions

Model (void)
virtual | ~Model (void)
void | SetModelFlags (ModelFlags flags)
nastaveni flagu modelu More...
void | SetMinVisibleDistance (unsigned long minDist)
nastaveni minimalni vzdalenosti, kdy je model viditelny More...
void | SetMaxVisibleDistance (unsigned long maxDist)
nastaveni maximalni vzdalenosti, kdy je model viditelny More...
void | SetPosition (osg::Vec3 pos)
nastaveni pozice More...
void | SetRotation (osg::Quat rot)
nastaveni rotace More...
void | SetScale (osg::Vec3 sc)
nastaveni zvetseni More...
void | SetFileName (string fname)
nastaveni jmena souboru, ve kterem je model ulozen More...
void | SetFileName (char *fname)
nastaveni jmena souboru, ve kterem je model ulozen More...
void | SetModelType (ModelType mtype)
nastaveni typu modelu More...
ModelFlags | GetModelFlags (void)
vrati falgy modelu More...
unsigned long | GetMaxVisibleDistance (void)
vrati maximalni vzdalenost, pri niz je model jeste viditelny More...
unsigned long | GetMinVisibleDistance (void)
vrati minimalni vzdalenost, pri niz je model jeste viditelny More...
osg::Vec3 | GetPosition (void)
vrati pozici modelu More...
osg::Quat | GetRotation (void)
vrati rotaci modelu More...
osg::Vec3 | GetScale (void)
vrati zvetseni modelu More...
string | GetFileName (void)
vrati jmeno souboru, v nemz je model ulozen More...
ModelType | GetModelType (void)
vrati typ modelu More...
bool | HasMinVisibleDistance (void)
ma model nastavenu minimalni vzdalenost viditelnosti More...
bool | HasMaxVisibleDistance (void)
ma model nastavenu maximalni vzdalenost viditelnosti More...
bool | HasPositionSet (void)
ma model nastavenu pozici More...

Public Attributes

osg::ref_ptr< EnvironmentObject > Geometry
nahrana geometrie modelu, pokud je prave zobrazovan, jinak NULL More...

Protected Attributes

ModelFlags modelFlags
flagy modelu More...
unsigned long | maxVisibleDistance
maximalni vzdalenost, pri niz je model viditelny More...
unsigned long | minVisibleDistance
minimalni vzdalenost, pri niz je model viditelny More...
osg::Vec3 | position
pozice More...
osg::Quat | rotation
rotace More...
osg::Vec3 | scale
zvetseni More...
string | fileName
jmeno souboru, v nemz je model ulozen More...
ModelType modelType
typ modelu More...
bool | hasMinDistance
ma nastavenu minimalni vzdalenost More...
bool | hasMaxDistance
ma nastavenu maximalni vzdalenost More...
bool | hasPositionSet
ma nastavenu pozici More...

Detailed Description

Uchovava informace o modelu.

Constructor & Destructor Documentation

Model::Model ( void )
virtual ArtificialWorld::Model::~Model ( void )
inlinevirtual

Member Function Documentation

string ArtificialWorld::Model::GetFileName ( void )
inline

vrati jmeno souboru, v nemz je model ulozen

unsigned long ArtificialWorld::Model::GetMaxVisibleDistance ( void )
inline

vrati maximalni vzdalenost, pri niz je model jeste viditelny

unsigned long ArtificialWorld::Model::GetMinVisibleDistance ( void )
inline

vrati minimalni vzdalenost, pri niz je model jeste viditelny

ModelFlags ArtificialWorld::Model::GetModelFlags ( void )
inline

vrati falgy modelu

ModelType ArtificialWorld::Model::GetModelType ( void )
inline

vrati typ modelu

osg::Vec3 ArtificialWorld::Model::GetPosition ( void )
inline

vrati pozici modelu

osg::Quat ArtificialWorld::Model::GetRotation ( void )
inline

vrati rotaci modelu

osg::Vec3 ArtificialWorld::Model::GetScale ( void )
inline

vrati zvetseni modelu

bool ArtificialWorld::Model::HasMaxVisibleDistance ( void )
inline

ma model nastavenu maximalni vzdalenost viditelnosti

bool ArtificialWorld::Model::HasMinVisibleDistance ( void )
inline

ma model nastavenu minimalni vzdalenost viditelnosti

bool ArtificialWorld::Model::HasPositionSet ( void )
inline

ma model nastavenu pozici

void ArtificialWorld::Model::SetFileName ( string fname )
inline

nastaveni jmena souboru, ve kterem je model ulozen

void ArtificialWorld::Model::SetFileName ( char * fname )
inline

nastaveni jmena souboru, ve kterem je model ulozen

void ArtificialWorld::Model::SetMaxVisibleDistance ( unsigned long maxDist )
inline

nastaveni maximalni vzdalenosti, kdy je model viditelny

void ArtificialWorld::Model::SetMinVisibleDistance ( unsigned long minDist )
inline

nastaveni minimalni vzdalenosti, kdy je model viditelny

void ArtificialWorld::Model::SetModelFlags ( ModelFlags flags )
inline

nastaveni flagu modelu

void ArtificialWorld::Model::SetModelType ( ModelType mtype )
inline

nastaveni typu modelu

void ArtificialWorld::Model::SetPosition ( osg::Vec3 pos )
inline

nastaveni pozice

void ArtificialWorld::Model::SetRotation ( osg::Quat rot )
inline

nastaveni rotace

void ArtificialWorld::Model::SetScale ( osg::Vec3 sc )
inline

nastaveni zvetseni

Member Data Documentation

string ArtificialWorld::Model::fileName
protected

jmeno souboru, v nemz je model ulozen

osg::ref_ptr<EnvironmentObject> ArtificialWorld::Model::Geometry

nahrana geometrie modelu, pokud je prave zobrazovan, jinak NULL

bool ArtificialWorld::Model::hasMaxDistance
protected

ma nastavenu maximalni vzdalenost

bool ArtificialWorld::Model::hasMinDistance
protected

ma nastavenu minimalni vzdalenost

bool ArtificialWorld::Model::hasPositionSet
protected

ma nastavenu pozici

unsigned long ArtificialWorld::Model::maxVisibleDistance
protected

maximalni vzdalenost, pri niz je model viditelny

unsigned long ArtificialWorld::Model::minVisibleDistance
protected

minimalni vzdalenost, pri niz je model viditelny

ModelFlags ArtificialWorld::Model::modelFlags
protected

flagy modelu

ModelType ArtificialWorld::Model::modelType
protected

typ modelu

osg::Vec3 ArtificialWorld::Model::position
protected

pozice

osg::Quat ArtificialWorld::Model::rotation
protected

rotace

osg::Vec3 ArtificialWorld::Model::scale
protected

zvetseni

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/model.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/model.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::AnimatedModel Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • AnimatedModel
Public Member Functions | List of all members
ArtificialWorld::AnimatedModel Class Reference

Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit. More...

#include <model.h>

Inheritance diagram for ArtificialWorld::AnimatedModel:
ArtificialWorld::Model

Public Member Functions

AnimatedModel (void)
void | SetAnimationIndex (int index)
nastavi cislo animace More...
int | GetAnimationIndex (void)
vrati cislo animace More...
- Public Member Functions inherited from ArtificialWorld::Model
Model (void)
virtual | ~Model (void)
void | SetModelFlags (ModelFlags flags)
nastaveni flagu modelu More...
void | SetMinVisibleDistance (unsigned long minDist)
nastaveni minimalni vzdalenosti, kdy je model viditelny More...
void | SetMaxVisibleDistance (unsigned long maxDist)
nastaveni maximalni vzdalenosti, kdy je model viditelny More...
void | SetPosition (osg::Vec3 pos)
nastaveni pozice More...
void | SetRotation (osg::Quat rot)
nastaveni rotace More...
void | SetScale (osg::Vec3 sc)
nastaveni zvetseni More...
void | SetFileName (string fname)
nastaveni jmena souboru, ve kterem je model ulozen More...
void | SetFileName (char *fname)
nastaveni jmena souboru, ve kterem je model ulozen More...
void | SetModelType (ModelType mtype)
nastaveni typu modelu More...
ModelFlags | GetModelFlags (void)
vrati falgy modelu More...
unsigned long | GetMaxVisibleDistance (void)
vrati maximalni vzdalenost, pri niz je model jeste viditelny More...
unsigned long | GetMinVisibleDistance (void)
vrati minimalni vzdalenost, pri niz je model jeste viditelny More...
osg::Vec3 | GetPosition (void)
vrati pozici modelu More...
osg::Quat | GetRotation (void)
vrati rotaci modelu More...
osg::Vec3 | GetScale (void)
vrati zvetseni modelu More...
string | GetFileName (void)
vrati jmeno souboru, v nemz je model ulozen More...
ModelType | GetModelType (void)
vrati typ modelu More...
bool | HasMinVisibleDistance (void)
ma model nastavenu minimalni vzdalenost viditelnosti More...
bool | HasMaxVisibleDistance (void)
ma model nastavenu maximalni vzdalenost viditelnosti More...
bool | HasPositionSet (void)
ma model nastavenu pozici More...

Additional Inherited Members

- Public Attributes inherited from ArtificialWorld::Model
osg::ref_ptr< EnvironmentObject > | Geometry
nahrana geometrie modelu, pokud je prave zobrazovan, jinak NULL More...
- Protected Attributes inherited from ArtificialWorld::Model
ModelFlags modelFlags
flagy modelu More...
unsigned long | maxVisibleDistance
maximalni vzdalenost, pri niz je model viditelny More...
unsigned long | minVisibleDistance
minimalni vzdalenost, pri niz je model viditelny More...
osg::Vec3 | position
pozice More...
osg::Quat | rotation
rotace More...
osg::Vec3 | scale
zvetseni More...
string | fileName
jmeno souboru, v nemz je model ulozen More...
ModelType modelType
typ modelu More...
bool | hasMinDistance
ma nastavenu minimalni vzdalenost More...
bool | hasMaxDistance
ma nastavenu maximalni vzdalenost More...
bool | hasPositionSet
ma nastavenu pozici More...

Detailed Description

Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit.

Constructor & Destructor Documentation

ArtificialWorld::AnimatedModel::AnimatedModel ( void )
inline

Member Function Documentation

int ArtificialWorld::AnimatedModel::GetAnimationIndex ( void )
inline

vrati cislo animace

void ArtificialWorld::AnimatedModel::SetAnimationIndex ( int index )
inline

nastavi cislo animace

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/model.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::SubBlock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • SubBlock
Public Member Functions | Protected Attributes | List of all members
ArtificialWorld::SubBlock Class Reference

Trida reprezentujici jeden blok ve scene. More...

#include <subblock.h>

Public Member Functions

SubBlock (void)
~SubBlock (void)
void | SetFileName (string fname)
nastavi jmeno souboru s definici bloku More...
void | SetPosition (osg::Vec3 pos)
nastavi pozici bloku vuci rodici More...
void | SetRotation (osg::Quat rot)
nastavi rotaci bloku vuci rodici More...
void | SetMaxVisibleDistance (unsigned long dist)
nastavi maximalni vzdalenost, po kterou je blok viditelny od pozorovatele More...
void | SetSubBlockType (string sbType)
nastavi typ bloku More...
bool | HasMaxVisibleDistance (void)
vrati, jestli ma blok nastavenu maximalni vzdalenost viditelnosti nebo ne More...
osg::Vec3 | GetPosition (void)
vrati pozici bloku vuci rodici More...
osg::Quat | GetRotation (void)
vrati rotaci bloku vuci rodici More...
string | GetFileName (void)
vrati jmeno souboru, ve kterem je ulozena definice bloku More...
unsigned long | GetMaxVisibleDistance (void)
vrati maximalni vzdalenost viditelnosti bloku More...
string | GetSubBlockType (void)
vrati typ bloku More...
SubBlockAnimation * | GetAnimation (void)
vrati animaci bloku, jestli nejakou ma, jestli nema, pak vrati NULL More...
void | SetAnimation (void)
vytvori novou prazdnou animaci, pokud jiz nejaka animace existuje, pak ji smaze a vytvori novou prazdnou More...
bool | HasAnimation (void)
vrati, jestli ma blok vytvorenou animaci More...
void | DeleteAnimation (void)
smaze animaci, pokud blok nejakou ma More...

Protected Attributes

osg::Vec3 | position
pozice bloku vuci rodici More...
osg::Quat | rotation
rotace bloku vuci rodici More...
unsigned long | maxVisibleDistance
maximalni viditelna vzdalenost bloku More...
string | filename
jmeno souboru s definici bloku More...
string | subBlockType
typ bloku More...
bool | hasMaxVisibleDistance
indikace, jestli ma nastavenu maximalni viditelnou vzdalenost More...
bool | hasAnimation
ma tento subblok animaci? More...
SubBlockAnimation animation
animace subbloku More...

Detailed Description

Trida reprezentujici jeden blok ve scene.

Constructor & Destructor Documentation

SubBlock::SubBlock ( void )
ArtificialWorld::SubBlock::~SubBlock ( void )
inline

Member Function Documentation

void ArtificialWorld::SubBlock::DeleteAnimation ( void )
inline

smaze animaci, pokud blok nejakou ma

SubBlockAnimation* ArtificialWorld::SubBlock::GetAnimation ( void )
inline

vrati animaci bloku, jestli nejakou ma, jestli nema, pak vrati NULL

string ArtificialWorld::SubBlock::GetFileName ( void )
inline

vrati jmeno souboru, ve kterem je ulozena definice bloku

unsigned long ArtificialWorld::SubBlock::GetMaxVisibleDistance ( void )
inline

vrati maximalni vzdalenost viditelnosti bloku

osg::Vec3 ArtificialWorld::SubBlock::GetPosition ( void )
inline

vrati pozici bloku vuci rodici

osg::Quat ArtificialWorld::SubBlock::GetRotation ( void )
inline

vrati rotaci bloku vuci rodici

string ArtificialWorld::SubBlock::GetSubBlockType ( void )
inline

vrati typ bloku

bool ArtificialWorld::SubBlock::HasAnimation ( void )
inline

vrati, jestli ma blok vytvorenou animaci

bool ArtificialWorld::SubBlock::HasMaxVisibleDistance ( void )
inline

vrati, jestli ma blok nastavenu maximalni vzdalenost viditelnosti nebo ne

void ArtificialWorld::SubBlock::SetAnimation ( void )
inline

vytvori novou prazdnou animaci, pokud jiz nejaka animace existuje, pak ji smaze a vytvori novou prazdnou

void ArtificialWorld::SubBlock::SetFileName ( string fname )
inline

nastavi jmeno souboru s definici bloku

void ArtificialWorld::SubBlock::SetMaxVisibleDistance ( unsigned long dist )
inline

nastavi maximalni vzdalenost, po kterou je blok viditelny od pozorovatele

void ArtificialWorld::SubBlock::SetPosition ( osg::Vec3 pos )
inline

nastavi pozici bloku vuci rodici

void ArtificialWorld::SubBlock::SetRotation ( osg::Quat rot )
inline

nastavi rotaci bloku vuci rodici

void ArtificialWorld::SubBlock::SetSubBlockType ( string sbType )
inline

nastavi typ bloku

Member Data Documentation

SubBlockAnimation ArtificialWorld::SubBlock::animation
protected

animace subbloku

string ArtificialWorld::SubBlock::filename
protected

jmeno souboru s definici bloku

bool ArtificialWorld::SubBlock::hasAnimation
protected

ma tento subblok animaci?

bool ArtificialWorld::SubBlock::hasMaxVisibleDistance
protected

indikace, jestli ma nastavenu maximalni viditelnou vzdalenost

unsigned long ArtificialWorld::SubBlock::maxVisibleDistance
protected

maximalni viditelna vzdalenost bloku

osg::Vec3 ArtificialWorld::SubBlock::position
protected

pozice bloku vuci rodici

osg::Quat ArtificialWorld::SubBlock::rotation
protected

rotace bloku vuci rodici

string ArtificialWorld::SubBlock::subBlockType
protected

typ bloku

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/subblock.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::AnimationPoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • AnimationPoint
Public Member Functions | Public Attributes | List of all members
ArtificialWorld::AnimationPoint Class Reference

Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode. More...

#include <subblock_animation.h>

Public Member Functions

AnimationPoint ()
AnimationPoint (osg::Vec3 trans, osg::Quat rot, osg::Vec3 scal, float alfa, osg::Node::NodeMask nmask)

Public Attributes

osg::Vec3 | translation
pozice More...
osg::Quat | rotation
rotace More...
osg::Vec3 | scale
zvetseni More...
float | alpha
alfa More...
osg::Node::NodeMask | nodeMask
maska More...
bool | translationSet
nastavena pozice? More...
bool | rotationSet
nastavena rotace? More...
bool | scaleSet
nastaveno zvetseni? More...
bool | alphaSet
nastavena alfa? More...
bool | nodeMaskSet
nastavena maska? More...

Detailed Description

Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode.

Constructor & Destructor Documentation

ArtificialWorld::AnimationPoint::AnimationPoint ( )
inline
ArtificialWorld::AnimationPoint::AnimationPoint | ( | osg::Vec3 | trans,
 |  | osg::Quat | rot,
 |  | osg::Vec3 | scal,
 |  | float | alfa,
 |  | osg::Node::NodeMask | nmask
 | ) |  |
inline

Member Data Documentation

float ArtificialWorld::AnimationPoint::alpha

alfa

bool ArtificialWorld::AnimationPoint::alphaSet

nastavena alfa?

osg::Node::NodeMask ArtificialWorld::AnimationPoint::nodeMask

maska

bool ArtificialWorld::AnimationPoint::nodeMaskSet

nastavena maska?

osg::Quat ArtificialWorld::AnimationPoint::rotation

rotace

bool ArtificialWorld::AnimationPoint::rotationSet

nastavena rotace?

osg::Vec3 ArtificialWorld::AnimationPoint::scale

zvetseni

bool ArtificialWorld::AnimationPoint::scaleSet

nastaveno zvetseni?

osg::Vec3 ArtificialWorld::AnimationPoint::translation

pozice

bool ArtificialWorld::AnimationPoint::translationSet

nastavena pozice?

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock_animation.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::SubBlockAnimation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • SubBlockAnimation
Public Member Functions | Protected Attributes | List of all members
ArtificialWorld::SubBlockAnimation Class Reference

Trida reprezentujici animaci bloku. More...

#include <subblock_animation.h>

Public Member Functions

SubBlockAnimation ()
vytvori novou animaci a nastavi typ na 0, interpolaci na Linear, looping na NoLoop a cas provadeni na 1 s More...
~SubBlockAnimation ()
void | AddAnimationPoint (AnimationPoint newPoint)
prida novy bod animace More...
int | NumberOfAnimantionPoints (void)
vrati pocet bodu animace More...
AnimationPoint * | GetAnimationPoint (int index)
vrati odkaz na bod animace na pozici 'index' More...
void | ClearAnimationPoints (void)
smaze vsechny body animace More...
void | SetAnimationType (unsigned int newType)
nastavi typ animace More...
unsigned int | GetAnimationType (void)
vrati typ animace More...
void | SetInterpolation (AnimationInterpolationType newInterpolation)
nastavi typ interpolace mezi body animace More...
AnimationInterpolationType | GetInterpolation (void)
vrati typ interpolace mezi body animace More...
void | SetLoopType (AnimationLoopType newLoop)
nastavi typ smycky animace More...
AnimationLoopType | GetLoopType (void)
vrati tyo smycky animace More...
void | SetTimePerLoop (int time)
nastavi cas v sekundach na provedeni jedne smycky animace More...
int | GetTimePerLoop (void)
vrati cas v sekundach nastaveny na provedeni jedne smycky animace More...
void | ClearAnimation (void)
smaze vsechny body animace a nastavi ostatni parametry na vychozi hodnoty More...

Protected Attributes

vector< AnimationPoint > | animationPoints
body animace More...
unsigned int | animationType
typ animace More...
AnimationInterpolationType interpolation
typ interpolace mezi body animace More...
AnimationLoopType looping
typ smycky animace More...
int | timeForLoop
cas v sekundach na provedeni jedne smycky animace More...

Detailed Description

Trida reprezentujici animaci bloku.

Constructor & Destructor Documentation

ArtificialWorld::SubBlockAnimation::SubBlockAnimation ( )
inline

vytvori novou animaci a nastavi typ na 0, interpolaci na Linear, looping na NoLoop a cas provadeni na 1 s

ArtificialWorld::SubBlockAnimation::~SubBlockAnimation ( )
inline

Member Function Documentation

void ArtificialWorld::SubBlockAnimation::AddAnimationPoint ( AnimationPoint newPoint )
inline

prida novy bod animace

void ArtificialWorld::SubBlockAnimation::ClearAnimation ( void )
inline

smaze vsechny body animace a nastavi ostatni parametry na vychozi hodnoty

void ArtificialWorld::SubBlockAnimation::ClearAnimationPoints ( void )
inline

smaze vsechny body animace

AnimationPoint* ArtificialWorld::SubBlockAnimation::GetAnimationPoint ( int index )
inline

vrati odkaz na bod animace na pozici 'index'

unsigned int ArtificialWorld::SubBlockAnimation::GetAnimationType ( void )
inline

vrati typ animace

AnimationInterpolationType ArtificialWorld::SubBlockAnimation::GetInterpolation ( void )
inline

vrati typ interpolace mezi body animace

AnimationLoopType ArtificialWorld::SubBlockAnimation::GetLoopType ( void )
inline

vrati tyo smycky animace

int ArtificialWorld::SubBlockAnimation::GetTimePerLoop ( void )
inline

vrati cas v sekundach nastaveny na provedeni jedne smycky animace

int ArtificialWorld::SubBlockAnimation::NumberOfAnimantionPoints ( void )
inline

vrati pocet bodu animace

void ArtificialWorld::SubBlockAnimation::SetAnimationType ( unsigned int newType )
inline

nastavi typ animace

void ArtificialWorld::SubBlockAnimation::SetInterpolation ( AnimationInterpolationType newInterpolation )
inline

nastavi typ interpolace mezi body animace

void ArtificialWorld::SubBlockAnimation::SetLoopType ( AnimationLoopType newLoop )
inline

nastavi typ smycky animace

void ArtificialWorld::SubBlockAnimation::SetTimePerLoop ( int time )
inline

nastavi cas v sekundach na provedeni jedne smycky animace

Member Data Documentation

vector<AnimationPoint> ArtificialWorld::SubBlockAnimation::animationPoints
protected

body animace

unsigned int ArtificialWorld::SubBlockAnimation::animationType
protected

typ animace

AnimationInterpolationType ArtificialWorld::SubBlockAnimation::interpolation
protected

typ interpolace mezi body animace

AnimationLoopType ArtificialWorld::SubBlockAnimation::looping
protected

typ smycky animace

int ArtificialWorld::SubBlockAnimation::timeForLoop
protected

cas v sekundach na provedeni jedne smycky animace

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock_animation.h
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: ArtificialWorld::WorldBuilder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • WorldBuilder
Public Member Functions | List of all members
ArtificialWorld::WorldBuilder Class Reference

Trida, ktera vytvori hierarchicky svet ve scene. More...

#include <WorldBuilder.h>

Inheritance diagram for ArtificialWorld::WorldBuilder:
vrecko::Ability vrecko::BaseClass

Public Member Functions

WorldBuilder ()
~WorldBuilder ()
void | initialize (void)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
nacteni parametru z xml uzlu More...
void | postInitialize (void)
inicializace po nacteni z xml More...
unsigned long | GetRootObjectID (void)
vrati id objektu, ktery reprezentuje koren hierarchicke sceny v celkove scene More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Trida, ktera vytvori hierarchicky svet ve scene.

Constructor & Destructor Documentation

WorldBuilder::WorldBuilder ( )
ArtificialWorld::WorldBuilder::~WorldBuilder ( )
inline

Member Function Documentation

unsigned long ArtificialWorld::WorldBuilder::GetRootObjectID ( void )
inline

vrati id objektu, ktery reprezentuje koren hierarchicke sceny v celkove scene

void ArtificialWorld::WorldBuilder::initialize ( void )
inline
bool WorldBuilder::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
virtual

nacteni parametru z xml uzlu

Reimplemented from vrecko::BaseClass.

void WorldBuilder::postInitialize ( void )
virtual

inicializace po nacteni z xml

Reimplemented from vrecko::BaseClass.

void ArtificialWorld::WorldBuilder::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/WorldBuilder.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/WorldBuilder.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::Avatar Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Avatar
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
base::Avatar Class Reference

#include <Avatar.h>

Inheritance diagram for base::Avatar:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Avatar ()
~Avatar ()
void | preInitialize (void)
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | setOrientationKeepUp (osg::Quat *newOrientation)
Sets the new orientation and updates it to point up ("naturally"). More...
void | updatePosRot (bool bUpdatePos, bool bUpdateRot, osg::Vec3 *position, osg::Quat *orientation)
DECLARE_INPUT (FreeMovement, MessageBool)
DECLARE_INPUT (Move, MessageVec3)
DECLARE_INPUT (MoveLocal, MessageVec3)
DECLARE_INPUT (Rotation, MessageQuat)
This means a relative rotation. More...
DECLARE_INPUT (RotationKeepUp, MessageQuat)
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
This means an absolute orientation. More...
DECLARE_INPUT (OrientationKeepUp, MessageQuat)
DECLARE_INPUT (DebugOutputViewPosition, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

World::AvatarView avatar_view
osg::Quat | orientation
EnvironmentObject * head
EnvironmentObject * left_hand
EnvironmentObject * right_hand
EnvironmentObject * left_leg
EnvironmentObject * right_leg
EnvironmentObject * free_move_EO
long int | headEO_ID
long int | leftHandEO_ID
long int | rightHandEO_ID
long int | freeMoveEO_ID
osg::Vec3 | cursor_shift
EnvironmentObject * owner
bool | gravity_mode
osg::Vec3 | reference_point
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Avatar::Avatar ( )
Avatar::~Avatar ( )

Member Function Documentation

base::Avatar::DECLARE_INPUT | ( | FreeMovement | ,
 |  | MessageBool |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | Move | ,
 |  | MessageVec3 |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | MoveLocal | ,
 |  | MessageVec3 |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | Rotation | ,
 |  | MessageQuat |
 | ) |  |
protected

This means a relative rotation.

base::Avatar::DECLARE_INPUT | ( | RotationKeepUp | ,
 |  | MessageQuat |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | Position | ,
 |  | MessageVec3 |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | Orientation | ,
 |  | MessageQuat |
 | ) |  |
protected

This means an absolute orientation.

base::Avatar::DECLARE_INPUT | ( | OrientationKeepUp | ,
 |  | MessageQuat |
 | ) |  |
protected
base::Avatar::DECLARE_INPUT | ( | DebugOutputViewPosition | ,
 |  | MessageVoid |
 | ) |  |
protected
bool Avatar::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Avatar::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Avatar::preInitialize ( void )
virtual

Process the Events.

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Avatar::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void Avatar::setOrientationKeepUp ( osg::Quat * newOrientation )
protected

Sets the new orientation and updates it to point up ("naturally").

void Avatar::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void Avatar::updatePosRot | ( | bool | bUpdatePos,
 |  | bool | bUpdateRot,
 |  | osg::Vec3 * | position,
 |  | osg::Quat * | orientation
 | ) |  |
protected

Member Data Documentation

World::AvatarView base::Avatar::avatar_view
protected
osg::Vec3 base::Avatar::cursor_shift
protected
EnvironmentObject* base::Avatar::free_move_EO
protected
long int base::Avatar::freeMoveEO_ID
protected
bool base::Avatar::gravity_mode
protected
EnvironmentObject* base::Avatar::head
protected
long int base::Avatar::headEO_ID
protected
EnvironmentObject* base::Avatar::left_hand
protected
EnvironmentObject* base::Avatar::left_leg
protected
long int base::Avatar::leftHandEO_ID
protected
osg::Quat base::Avatar::orientation
protected
EnvironmentObject* base::Avatar::owner
protected
osg::Vec3 base::Avatar::reference_point
protected
EnvironmentObject * base::Avatar::right_hand
protected
EnvironmentObject * base::Avatar::right_leg
protected
long int base::Avatar::rightHandEO_ID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/Avatar.h
  • C:/Documents/School/OSG/VRECKO/src/base/Avatar.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::Display Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Display
Public Member Functions | Protected Attributes | List of all members
base::Display Class Reference

#include <Display.h>

Inheritance diagram for base::Display:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Display ()
~Display ()
void | initialize (void)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osgText::Text ** | _display_line
std::vector< std::string > | _text_history
osg::Geode * | _text_geode
osg::Material * | _text_material
osg::StateSet * | _text_state
osgText::Font * | _texture_font
osgText::Font * | _polygon_font
int | _font_size
osg::BlendFunc * | _transp
float | _start_x
float | _start_y
float | _line_height
int | _line_count
bool | _first
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

base::Display::Display ( )
base::Display::~Display ( )
inline

Member Function Documentation

void base::Display::initialize ( void )
inline
void base::Display::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osgText::Text** base::Display::_display_line
protected
bool base::Display::_first
protected
int base::Display::_font_size
protected
int base::Display::_line_count
protected
float base::Display::_line_height
protected
osgText::Font* base::Display::_polygon_font
protected
float base::Display::_start_x
protected
float base::Display::_start_y
protected
osg::Geode* base::Display::_text_geode
protected
std::vector<std::string> base::Display::_text_history
protected
osg::Material* base::Display::_text_material
protected
osg::StateSet* base::Display::_text_state
protected
osgText::Font* base::Display::_texture_font
protected
osg::BlendFunc* base::Display::_transp
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/Display.h
  • C:/Documents/School/OSG/VRECKO/src/base/Display.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::hand Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • hand
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
base::hand Class Reference

#include <hand.h>

Inheritance diagram for base::hand:
vrecko::Ability vrecko::BaseClass

Public Member Functions

hand ()
~hand ()
void | update (void)
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (Grab, MessageBool)
DECLARE_OUTPUT (RelativeLocation, MessageMatrix)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _grab_position
osg::Vec3 | _actual_position
osg::Vec3 | _last_position
osg::Matrix | _grab_rotation
osg::Matrix | _actual_rotation
osg::Matrix | _last_rotation
osg::Matrix | _parent_rotation
osg::Matrix | _parent_inverse_rotation
bool | _first
bool | dyn_version
EnvironmentObject * selected_object
Ability * ab_with_input_Use
bool | manipulate
osg::Vec3 | _last_positions [200]
int | _current_pos
osg::Matrix | _grab_rotation2
osg::Vec3 | _grab_position2
osg::Vec3 | force
bool | first
osg::Matrix | grab_transform
osg::Matrix | current_transform
osg::Matrix | last_transform
osg::Matrix | grab_transform_SO
osg::Matrix | SOparent_mat
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

hand::hand ( )
base::hand::~hand ( )
inline

Member Function Documentation

base::hand::DECLARE_INPUT | ( | Grab | ,
 |  | MessageBool |
 | ) |  |
protected
base::hand::DECLARE_OUTPUT | ( | RelativeLocation | ,
 |  | MessageMatrix |
 | ) |  |
protected
void base::hand::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void hand::update ( void )
virtual

Process the Events.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 base::hand::_actual_position
protected
osg::Matrix base::hand::_actual_rotation
protected
int base::hand::_current_pos
protected
bool base::hand::_first
protected
osg::Vec3 base::hand::_grab_position
protected
osg::Vec3 base::hand::_grab_position2
protected
osg::Matrix base::hand::_grab_rotation
protected
osg::Matrix base::hand::_grab_rotation2
protected
osg::Vec3 base::hand::_last_position
protected
osg::Vec3 base::hand::_last_positions[200]
protected
osg::Matrix base::hand::_last_rotation
protected
osg::Matrix base::hand::_parent_inverse_rotation
protected
osg::Matrix base::hand::_parent_rotation
protected
Ability* base::hand::ab_with_input_Use
protected
osg::Matrix base::hand::current_transform
protected
bool base::hand::dyn_version
protected
bool base::hand::first
protected
osg::Vec3 base::hand::force
protected
osg::Matrix base::hand::grab_transform
protected
osg::Matrix base::hand::grab_transform_SO
protected
osg::Matrix base::hand::last_transform
protected
bool base::hand::manipulate
protected
EnvironmentObject* base::hand::owner
protected
EnvironmentObject* base::hand::selected_object
protected
osg::Matrix base::hand::SOparent_mat
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/hand.h
  • C:/Documents/School/OSG/VRECKO/src/base/hand.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::Light Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Light
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
base::Light Class Reference

#include <Light.h>

Inheritance diagram for base::Light:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Light ()
~Light ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (Enable, MessageBool)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Group * | lightGroup
osg::Light * | light
int | lightNumber
osg::Vec3 | position
osg::Vec3 | direction
osg::Vec4 | ambient
osg::Vec4 | diffuse
float | spotCutoff
float | spotExponent
float | constantAttenuation
float | linearAttenuation
float | quadraticAttenuation
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Light::Light ( )
base::Light::~Light ( )
inline

Member Function Documentation

base::Light::DECLARE_INPUT | ( | Enable | ,
 |  | MessageBool |
 | ) |  |
protected
bool Light::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Light::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Light::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Light::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec4 base::Light::ambient
protected
float base::Light::constantAttenuation
protected
osg::Vec4 base::Light::diffuse
protected
osg::Vec3 base::Light::direction
protected
osg::Light* base::Light::light
protected
osg::Group* base::Light::lightGroup
protected
int base::Light::lightNumber
protected
float base::Light::linearAttenuation
protected
EnvironmentObject* base::Light::owner
protected
osg::Vec3 base::Light::position
protected
float base::Light::quadraticAttenuation
protected
float base::Light::spotCutoff
protected
float base::Light::spotExponent
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/Light.h
  • C:/Documents/School/OSG/VRECKO/src/base/Light.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::MouseHand Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • MouseHand
Public Member Functions | Static Public Attributes | Protected Member Functions | Protected Attributes | List of all members
base::MouseHand Class Reference

#include <MouseHand.h>

Inheritance diagram for base::MouseHand:
vrecko::Ability vrecko::BaseClass

Public Member Functions

MouseHand ()
~MouseHand ()
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Attributes

static const std::string | GRAB_EVENT = "GrabEvent"
static const std::string | GRAB_RELEASE_EVENT = "GrabReleaseEvent"
static const std::string | BRICK_MOVE_EVENT = "BrickMoveEvent"

Protected Member Functions

DECLARE_INPUT (Grab, MessageBool)
DECLARE_INPUT (Position, MessageVec2)
DECLARE_INPUT (ZChange, MessageFloat)
DECLARE_OUTPUT (Grab, MessageObjectID)
DECLARE_OUTPUT (GrabRelease, MessageObjectID)
DECLARE_OUTPUT (BrickMove, MessageObjectID)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _grab_position
osg::Vec3 | _actual_position
osg::Vec3 | _last_position
osg::Matrix | _grab_rotation
osg::Matrix | _actual_rotation
osg::Matrix | _last_rotation
osg::Matrix | _parent_rotation
osg::Matrix | _parent_inverse_rotation
bool | _first
bool | dyn_version
EnvironmentObject * selected_object
Ability * ab_with_input_Use
bool | manipulate
osg::Vec3 | _last_positions [200]
int | _current_pos
osg::Matrix | _grab_rotation2
osg::Vec3 | _grab_position2
osg::Vec3 | force
bool | first
osg::Vec2 | mouse_position
osg::Vec3 | scene_mouse_position
float | z_position
float | z_step
osg::Matrix | grab_transform
osg::Matrix | current_transform
osg::Matrix | last_transform
osg::Matrix | grab_transform_SO
osg::Matrix | SOparent_mat
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

MouseHand::MouseHand ( )
base::MouseHand::~MouseHand ( )
inline

Member Function Documentation

base::MouseHand::DECLARE_INPUT | ( | Grab | ,
 |  | MessageBool |
 | ) |  |
protected
base::MouseHand::DECLARE_INPUT | ( | Position | ,
 |  | MessageVec2 |
 | ) |  |
protected
base::MouseHand::DECLARE_INPUT | ( | ZChange | ,
 |  | MessageFloat |
 | ) |  |
protected
base::MouseHand::DECLARE_OUTPUT | ( | Grab | ,
 |  | MessageObjectID |
 | ) |  |
protected
base::MouseHand::DECLARE_OUTPUT | ( | GrabRelease | ,
 |  | MessageObjectID |
 | ) |  |
protected
base::MouseHand::DECLARE_OUTPUT | ( | BrickMove | ,
 |  | MessageObjectID |
 | ) |  |
protected
void base::MouseHand::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void base::MouseHand::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void MouseHand::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 base::MouseHand::_actual_position
protected
osg::Matrix base::MouseHand::_actual_rotation
protected
int base::MouseHand::_current_pos
protected
bool base::MouseHand::_first
protected
osg::Vec3 base::MouseHand::_grab_position
protected
osg::Vec3 base::MouseHand::_grab_position2
protected
osg::Matrix base::MouseHand::_grab_rotation
protected
osg::Matrix base::MouseHand::_grab_rotation2
protected
osg::Vec3 base::MouseHand::_last_position
protected
osg::Vec3 base::MouseHand::_last_positions[200]
protected
osg::Matrix base::MouseHand::_last_rotation
protected
osg::Matrix base::MouseHand::_parent_inverse_rotation
protected
osg::Matrix base::MouseHand::_parent_rotation
protected
Ability* base::MouseHand::ab_with_input_Use
protected
const std::string MouseHand::BRICK_MOVE_EVENT = "BrickMoveEvent"
static
osg::Matrix base::MouseHand::current_transform
protected
bool base::MouseHand::dyn_version
protected
bool base::MouseHand::first
protected
osg::Vec3 base::MouseHand::force
protected
const std::string MouseHand::GRAB_EVENT = "GrabEvent"
static
const std::string MouseHand::GRAB_RELEASE_EVENT = "GrabReleaseEvent"
static
osg::Matrix base::MouseHand::grab_transform
protected
osg::Matrix base::MouseHand::grab_transform_SO
protected
osg::Matrix base::MouseHand::last_transform
protected
bool base::MouseHand::manipulate
protected
osg::Vec2 base::MouseHand::mouse_position
protected
EnvironmentObject* base::MouseHand::owner
protected
osg::Vec3 base::MouseHand::scene_mouse_position
protected
EnvironmentObject* base::MouseHand::selected_object
protected
osg::Matrix base::MouseHand::SOparent_mat
protected
float base::MouseHand::z_position
protected
float base::MouseHand::z_step
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/MouseHand.h
  • C:/Documents/School/OSG/VRECKO/src/base/MouseHand.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::MTMatrixTransform Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • MTMatrixTransform
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
base::MTMatrixTransform Class Reference

#include <MTMatrixTransform.h>

Inheritance diagram for base::MTMatrixTransform:
vrecko::Ability vrecko::BaseClass

Public Member Functions

MTMatrixTransform ()
virtual | ~MTMatrixTransform ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
bool | getMatrix (osg::Matrix *pMatrix)
void | setMatrix (osg::Matrix *newMatrix)
bool | getWorldTransformation (osg::Matrix *pMatrix)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_INPUT (SetMatrix, MessageMatrix, MessageVoid)
DECLARE_REQUEST_INPUT (GetMatrix, MessageVoid, MessageMatrix)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
osg::Matrix | matrix
bool | bRetrieved
bool | bUpdated
MTReadWriteLockEx generalLock
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

MTMATRIXTRANSFORM_IMP_EXP base::MTMatrixTransform::MTMatrixTransform ( )
MTMATRIXTRANSFORM_IMP_EXP base::MTMatrixTransform::~MTMatrixTransform ( )
virtual

Member Function Documentation

base::MTMatrixTransform::DECLARE_REQUEST_INPUT | ( | SetMatrix | ,
 |  | MessageMatrix | ,
 |  | MessageVoid |
 | ) |  |
protected
base::MTMatrixTransform::DECLARE_REQUEST_INPUT | ( | GetMatrix | ,
 |  | MessageVoid | ,
 |  | MessageMatrix |
 | ) |  |
protected
MTMATRIXTRANSFORM_IMP_EXP bool base::MTMatrixTransform::getMatrix ( osg::Matrix * pMatrix )
MTMATRIXTRANSFORM_IMP_EXP bool base::MTMatrixTransform::getWorldTransformation ( osg::Matrix * pMatrix )
MTMATRIXTRANSFORM_IMP_EXP void base::MTMatrixTransform::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

MTMATRIXTRANSFORM_IMP_EXP void base::MTMatrixTransform::setMatrix ( osg::Matrix * newMatrix )
MTMATRIXTRANSFORM_IMP_EXP void base::MTMatrixTransform::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool base::MTMatrixTransform::bRetrieved
protected
bool base::MTMatrixTransform::bUpdated
protected
MTReadWriteLockEx base::MTMatrixTransform::generalLock
protected
osg::Matrix base::MTMatrixTransform::matrix
protected
EnvironmentObject* base::MTMatrixTransform::owner
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/MTMatrixTransform.h
  • C:/Documents/School/OSG/VRECKO/src/base/MTMatrixTransform.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::Rotate Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Rotate
Public Member Functions | Static Public Attributes | Protected Attributes | List of all members
base::Rotate Class Reference

#include <Rotate.h>

Inheritance diagram for base::Rotate:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Rotate ()
~Rotate ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Attributes

static ParameterVector * pParameterVector = NULL

Protected Attributes

float | angle
float | step
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

Rotate::Rotate ( )
base::Rotate::~Rotate ( )
inline

Member Function Documentation

ParameterVector* base::Rotate::getParameterVector ( void )
inlinevirtual

Return vector of the parameter description.

Reimplemented from vrecko::Ability.

bool Rotate::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Rotate::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Rotate::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void Rotate::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

float base::Rotate::angle
protected
EnvironmentObject* base::Rotate::owner
protected
Ability::ParameterVector * Rotate::pParameterVector = NULL
static
float base::Rotate::step
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/Rotate.h
  • C:/Documents/School/OSG/VRECKO/src/base/Rotate.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::ShowFDH Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • ShowFDH
Public Member Functions | Static Public Attributes | Protected Attributes | List of all members
base::ShowFDH Class Reference

#include <ShowFDH.h>

Inheritance diagram for base::ShowFDH:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ShowFDH ()
~ShowFDH ()
void | initialize (void)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | setMaxLevel (long int _new_max)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Attributes

static ParameterVector * pParameterVector = NULL

Protected Attributes

osg::Geode * | _fdh_geode
osg::Geometry ** | _fdh_geom
osg::MatrixTransform * | transf
float * | vert
long int | maxLevel
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ShowFDH::ShowFDH ( )
base::ShowFDH::~ShowFDH ( )
inline

Member Function Documentation

ParameterVector* base::ShowFDH::getParameterVector ( void )
inlinevirtual

Return vector of the parameter description.

Reimplemented from vrecko::Ability.

void ShowFDH::initialize ( void )
bool ShowFDH::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ShowFDH::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void base::ShowFDH::setMaxLevel ( long int _new_max )
inline
void ShowFDH::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Geode* base::ShowFDH::_fdh_geode
protected
osg::Geometry** base::ShowFDH::_fdh_geom
protected
long int base::ShowFDH::maxLevel
protected
Ability::ParameterVector * ShowFDH::pParameterVector = NULL
static
osg::MatrixTransform* base::ShowFDH::transf
protected
float* base::ShowFDH::vert
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/ShowFDH.h
  • C:/Documents/School/OSG/VRECKO/src/base/ShowFDH.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::ShowFDHModel Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • ShowFDHModel
Public Member Functions | Protected Attributes | List of all members
base::ShowFDHModel Class Reference

#include <ShowFDHModel.h>

Inheritance diagram for base::ShowFDHModel:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ShowFDHModel ()
~ShowFDHModel ()
void | initialize (void)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::Geode * | _fdh_geode
osg::Geometry ** | _fdh_geom
osg::MatrixTransform * | transf
double * | vert
bool | _first
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ShowFDHModel::ShowFDHModel ( )
base::ShowFDHModel::~ShowFDHModel ( )
inline

Member Function Documentation

void ShowFDHModel::initialize ( void )
void ShowFDHModel::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Geode* base::ShowFDHModel::_fdh_geode
protected
osg::Geometry** base::ShowFDHModel::_fdh_geom
protected
bool base::ShowFDHModel::_first
protected
osg::MatrixTransform* base::ShowFDHModel::transf
protected
double* base::ShowFDHModel::vert
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/ShowFDHModel.h
  • C:/Documents/School/OSG/VRECKO/src/base/ShowFDHModel.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::SystemInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
base::SystemInfo Class Reference

#include <SystemInfo.h>

Inheritance diagram for base::SystemInfo:
vrecko::Ability vrecko::BaseClass

Classes

class | MessageSIThreadCreated
struct | SIThreadInfo
struct | SIThreadInit

Public Member Functions

SystemInfo ()
~SystemInfo ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static bool TryToSendThreadCreatedEvent (DWORD dwThreadId, const char *pName)

Protected Member Functions

bool | initThread (DWORD dwThreadId, std::string &threadName)
DECLARE_INPUT (ThreadCreated, MessageSIThreadCreated)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

DWORD | dwLastTick
bool | bWritePeriodicInfo
std::map< DWORD, SIThreadInfo > | threadsInfo
std::map< std::string,
SIThreadInit > 		threadsInit
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

base::SystemInfo::SystemInfo ( )
base::SystemInfo::~SystemInfo ( )

Member Function Documentation

base::SystemInfo::DECLARE_INPUT | ( | ThreadCreated | ,
 |  | MessageSIThreadCreated |
 | ) |  |
protected
bool base::SystemInfo::initThread | ( | DWORD | dwThreadId,
 |  | std::string & | threadName
 | ) |  |
protected
bool base::SystemInfo::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void base::SystemInfo::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void base::SystemInfo::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

static bool base::SystemInfo::TryToSendThreadCreatedEvent | ( | DWORD | dwThreadId,
 |  | const char * | pName
 | ) |  |
inlinestatic
void base::SystemInfo::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool base::SystemInfo::bWritePeriodicInfo
protected
DWORD base::SystemInfo::dwLastTick
protected
std::map<DWORD, SIThreadInfo> base::SystemInfo::threadsInfo
protected
std::map<std::string, SIThreadInit> base::SystemInfo::threadsInit
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h
  • C:/Documents/School/OSG/VRECKO/src/base/SystemInfo.cpp
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: base::SystemInfo::MessageSIThreadCreated Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • MessageSIThreadCreated
Public Member Functions | Public Attributes | List of all members
base::SystemInfo::MessageSIThreadCreated Class Reference

#include <SystemInfo.h>

Inheritance diagram for base::SystemInfo::MessageSIThreadCreated:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
MessageSIThreadCreated ()
MessageSIThreadCreated (DWORD _dwThreadId, const char *_name)
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

DWORD | dwThreadId
std::string | name

Constructor & Destructor Documentation

base::SystemInfo::MessageSIThreadCreated::MessageSIThreadCreated ( )
inline
base::SystemInfo::MessageSIThreadCreated::MessageSIThreadCreated | ( | DWORD | _dwThreadId,
 |  | const char * | _name
 | ) |  |
inline

Member Function Documentation

virtual const char* base::SystemInfo::MessageSIThreadCreated::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

virtual bool base::SystemInfo::MessageSIThreadCreated::isEqualTo ( VreckoMessage * otherMsg )
inlinevirtual
virtual bool base::SystemInfo::MessageSIThreadCreated::setValueFromString ( const char * valueAsString )
inlinevirtual

Parses the given string to get the data for this message.

OVERRIDING IS REQUIRED for ACTIVATE_INPUT message sending, i.e. "if ability A output pin O outputs message with <em>content</em> M, then create a message M2 (might be different type), send it to ability A2 input pin I". If the respective message is only used simply for direct (much more common) message sending, you DO NOT NEED TO OVERRIDE this method.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

DWORD base::SystemInfo::MessageSIThreadCreated::dwThreadId
std::string base::SystemInfo::MessageSIThreadCreated::name
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: base::SystemInfo::SIThreadInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • SIThreadInfo
Public Member Functions | Public Attributes | List of all members
base::SystemInfo::SIThreadInfo Struct Reference

#include <SystemInfo.h>

Public Member Functions

SIThreadInfo ()

Public Attributes

std::string | name
bool | bThreadInitialized
bool | bTimeInitialized
DWORD | dwLastUserTime
DWORD | dwLastKernelTime

Constructor & Destructor Documentation

base::SystemInfo::SIThreadInfo::SIThreadInfo ( )
inline

Member Data Documentation

bool base::SystemInfo::SIThreadInfo::bThreadInitialized
bool base::SystemInfo::SIThreadInfo::bTimeInitialized
DWORD base::SystemInfo::SIThreadInfo::dwLastKernelTime
DWORD base::SystemInfo::SIThreadInfo::dwLastUserTime
std::string base::SystemInfo::SIThreadInfo::name
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: base::SystemInfo::SIThreadInit Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • SIThreadInit
Public Attributes | List of all members
base::SystemInfo::SIThreadInit Struct Reference

#include <SystemInfo.h>

Public Attributes

DWORD dwAffinity

Member Data Documentation

DWORD base::SystemInfo::SIThreadInit::dwAffinity
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: base::_CLIENT_ID Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • _CLIENT_ID
Public Attributes | List of all members
base::_CLIENT_ID Struct Reference

Public Attributes

PVOID | UniqueProcess
PVOID | UniqueThread

Member Data Documentation

PVOID base::_CLIENT_ID::UniqueProcess
PVOID base::_CLIENT_ID::UniqueThread
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/base/SystemInfo.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: base::_THREAD_BASIC_INFORMATION Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • _THREAD_BASIC_INFORMATION
Public Attributes | List of all members
base::_THREAD_BASIC_INFORMATION Struct Reference

Public Attributes

NTSTATUS ExitStatus
PVOID | TebBaseAddress
CLIENT_ID ClientId
KAFFINITY | AffinityMask
KPRIORITY Priority
KPRIORITY BasePriority

Member Data Documentation

KAFFINITY base::_THREAD_BASIC_INFORMATION::AffinityMask
KPRIORITY base::_THREAD_BASIC_INFORMATION::BasePriority
CLIENT_ID base::_THREAD_BASIC_INFORMATION::ClientId
NTSTATUS base::_THREAD_BASIC_INFORMATION::ExitStatus
KPRIORITY base::_THREAD_BASIC_INFORMATION::Priority
PVOID base::_THREAD_BASIC_INFORMATION::TebBaseAddress
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/base/SystemInfo.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::AvatarManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • AvatarManipulator
Public Member Functions | Protected Attributes | List of all members
behindO::AvatarManipulator Class Reference

#include <AvatarManipulator.h>

Inheritance diagram for behindO::AvatarManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

AvatarManipulator ()
~AvatarManipulator ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
std::string | getAcceptableMessages (void)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | control
bool | _first
osg::Vec3 | sensor_relative_pos
osg::Vec3 | initial_sensor_pos
osg::Vec3 | last_sensor_pos
osg::Quat | last_sensor_orientation
float | eye_distance_scale_factor
osg::Vec3 | head_center
osg::Vec3 | eye_position
osg::Vec3 | up_vector
osg::Vec3 | look_at_center
osg::Vec3 | to_center
osg::Vec3 | EO_owner_grab_pos
osg::Vec3 | avatar_grab_pos
osg::Matrix | EO_owner_grab_rot
osg::Matrix | avatar_grab_transform
osg::Matrix | avatar_grab_inverse_transform
osg::Matrix | avatar_grab_rotation
osg::Matrix | avatar_grab_inverse_rotation
osg::Matrix | EO_owner_grab_Wrot
bool | active
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::AvatarManipulator::AvatarManipulator ( )
behindO::AvatarManipulator::~AvatarManipulator ( )
inline

Member Function Documentation

std::string behindO::AvatarManipulator::getAcceptableMessages ( void )
inline
void behindO::AvatarManipulator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::AvatarManipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void behindO::AvatarManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::AvatarManipulator::_first
protected
bool behindO::AvatarManipulator::active
protected
osg::Matrix behindO::AvatarManipulator::avatar_grab_inverse_rotation
protected
osg::Matrix behindO::AvatarManipulator::avatar_grab_inverse_transform
protected
osg::Vec3 behindO::AvatarManipulator::avatar_grab_pos
protected
osg::Matrix behindO::AvatarManipulator::avatar_grab_rotation
protected
osg::Matrix behindO::AvatarManipulator::avatar_grab_transform
protected
int behindO::AvatarManipulator::control
protected
osg::Vec3 behindO::AvatarManipulator::EO_owner_grab_pos
protected
osg::Matrix behindO::AvatarManipulator::EO_owner_grab_rot
protected
osg::Matrix behindO::AvatarManipulator::EO_owner_grab_Wrot
protected
float behindO::AvatarManipulator::eye_distance_scale_factor
protected
osg::Vec3 behindO::AvatarManipulator::eye_position
protected
osg::Vec3 behindO::AvatarManipulator::head_center
protected
osg::Vec3 behindO::AvatarManipulator::initial_sensor_pos
protected
osg::Quat behindO::AvatarManipulator::last_sensor_orientation
protected
osg::Vec3 behindO::AvatarManipulator::last_sensor_pos
protected
osg::Vec3 behindO::AvatarManipulator::look_at_center
protected
EnvironmentObject* behindO::AvatarManipulator::owner
protected
osg::Vec3 behindO::AvatarManipulator::sensor_relative_pos
protected
osg::Vec3 behindO::AvatarManipulator::to_center
protected
osg::Vec3 behindO::AvatarManipulator::up_vector
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/AvatarManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::CentreObjectManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • CentreObjectManipulator
Public Member Functions | Protected Attributes | List of all members
behindO::CentreObjectManipulator Class Reference

#include <CentreObjectManipulator.h>

Inheritance diagram for behindO::CentreObjectManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CentreObjectManipulator ()
~CentreObjectManipulator ()
void | processEvent (const std::string &input_name, void *value)
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

EnvironmentObject * focus_area
EnvironmentObject * focusing_marker
EnvironmentObject * located_object
int | control
std::map< double,
EnvironmentObject * > 		score_map
unsigned int | version
osg::Timer | timer
osg::Timer_t | last_tick
EnvironmentObject * owner
Ability * pAHMDHeadManipulator
Ability * pAHeadManipulator
Ability * pAManipulator
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::CentreObjectManipulator::CentreObjectManipulator ( )
behindO::CentreObjectManipulator::~CentreObjectManipulator ( )
inline

Member Function Documentation

void behindO::CentreObjectManipulator::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::CentreObjectManipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void behindO::CentreObjectManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

int behindO::CentreObjectManipulator::control
protected
EnvironmentObject* behindO::CentreObjectManipulator::focus_area
protected
EnvironmentObject* behindO::CentreObjectManipulator::focusing_marker
protected
osg::Timer_t behindO::CentreObjectManipulator::last_tick
protected
EnvironmentObject * behindO::CentreObjectManipulator::located_object
protected
EnvironmentObject* behindO::CentreObjectManipulator::owner
protected
Ability * behindO::CentreObjectManipulator::pAHeadManipulator
protected
Ability* behindO::CentreObjectManipulator::pAHMDHeadManipulator
protected
Ability * behindO::CentreObjectManipulator::pAManipulator
protected
std::map<double, EnvironmentObject*> behindO::CentreObjectManipulator::score_map
protected
osg::Timer behindO::CentreObjectManipulator::timer
protected
unsigned int behindO::CentreObjectManipulator::version
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CentreObjectManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::ChangeOfVisibility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • ChangeOfVisibility
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
behindO::ChangeOfVisibility Class Reference

#include <ChangeOfVisibility.h>

Inheritance diagram for behindO::ChangeOfVisibility:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ChangeOfVisibility ()
~ChangeOfVisibility ()
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | createBorder (void)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

int | control
std::vector< EnvironmentObject * > | wire_object_map
bool | continuous_selection
bool | wireframe
float | transparency
osg::Vec3 | selection_point [2]
osg::Vec3 | box_size
osg::MatrixTransform * | pSelectionBox
EnvironmentObject * border_object
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

behindO::ChangeOfVisibility::ChangeOfVisibility ( )
behindO::ChangeOfVisibility::~ChangeOfVisibility ( )
inline

Member Function Documentation

void behindO::ChangeOfVisibility::createBorder ( void )
protected
void behindO::ChangeOfVisibility::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void behindO::ChangeOfVisibility::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

EnvironmentObject* behindO::ChangeOfVisibility::border_object
protected
osg::Vec3 behindO::ChangeOfVisibility::box_size
protected
bool behindO::ChangeOfVisibility::continuous_selection
protected
int behindO::ChangeOfVisibility::control
protected
osg::MatrixTransform* behindO::ChangeOfVisibility::pSelectionBox
protected
osg::Vec3 behindO::ChangeOfVisibility::selection_point[2]
protected
float behindO::ChangeOfVisibility::transparency
protected
std::vector<EnvironmentObject *> behindO::ChangeOfVisibility::wire_object_map
protected
bool behindO::ChangeOfVisibility::wireframe
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ChangeOfVisibility.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::ContactObjectManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • ContactObjectManipulator
Public Member Functions | List of all members
behindO::ContactObjectManipulator Class Reference

#include <ContactObjectManipulator.h>

Inheritance diagram for behindO::ContactObjectManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ContactObjectManipulator ()
~ContactObjectManipulator ()
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

behindO::ContactObjectManipulator::ContactObjectManipulator ( )
behindO::ContactObjectManipulator::~ContactObjectManipulator ( )
inline

Member Function Documentation

void behindO::ContactObjectManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ContactObjectManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::CuttingPlane Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • CuttingPlane
Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
behindO::CuttingPlane Class Reference

#include <CuttingPlane.h>

Inheritance diagram for behindO::CuttingPlane:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CuttingPlane ()
~CuttingPlane ()
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | control
std::vector< EnvironmentObject * > | wire_object_map
EnvironmentObject * cutting_object
osg::ClipNode * | clipnode
osg::ClipNode * | clipnodeSS
std::map< osg::Node
*, osg::StateSet * > 		stateset_map
osg::MatrixTransform * | cutting_plane_transformation
bool | _first
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Static Protected Attributes

static int next_free_clipping_plane

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::CuttingPlane::CuttingPlane ( )
behindO::CuttingPlane::~CuttingPlane ( )
inline

Member Function Documentation

void behindO::CuttingPlane::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void behindO::CuttingPlane::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::CuttingPlane::_first
protected
osg::ClipNode* behindO::CuttingPlane::clipnode
protected
osg::ClipNode * behindO::CuttingPlane::clipnodeSS
protected
int behindO::CuttingPlane::control
protected
EnvironmentObject* behindO::CuttingPlane::cutting_object
protected
osg::MatrixTransform* behindO::CuttingPlane::cutting_plane_transformation
protected
int behindO::CuttingPlane::next_free_clipping_plane
staticprotected
std::map<osg::Node *, osg::StateSet *> behindO::CuttingPlane::stateset_map
protected
std::vector<EnvironmentObject *> behindO::CuttingPlane::wire_object_map
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CuttingPlane.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::EyeManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • EyeManipulator
Public Member Functions | Protected Attributes | List of all members
behindO::EyeManipulator Class Reference

#include <EyeManipulator.h>

Inheritance diagram for behindO::EyeManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

EyeManipulator ()
~EyeManipulator ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
std::string | getAcceptableMessages (void)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | control
bool | _first
osg::Vec3 | sensor_relative_pos
osg::Vec3 | initial_sensor_pos
osg::Vec3 | last_sensor_pos
osg::Quat | last_sensor_orientation
float | eye_distance_scale_factor
osg::Vec3 | head_center
osg::Vec3 | eye_position
osg::Vec3 | up_vector
osg::Vec3 | look_at_center
osg::Vec3 | to_center
osg::Vec3 | EO_owner_grab_pos
osg::Vec3 | avatar_grab_pos
osg::Matrix | EO_owner_grab_rot
osg::Matrix | avatar_grab_transform
osg::Matrix | avatar_grab_inverse_transform
osg::Matrix | avatar_grab_rotation
osg::Matrix | avatar_grab_inverse_rotation
osg::Matrix | EO_owner_grab_Wrot
bool | active
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::EyeManipulator::EyeManipulator ( )
behindO::EyeManipulator::~EyeManipulator ( )
inline

Member Function Documentation

std::string behindO::EyeManipulator::getAcceptableMessages ( void )
inline
void behindO::EyeManipulator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::EyeManipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void behindO::EyeManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::EyeManipulator::_first
protected
bool behindO::EyeManipulator::active
protected
osg::Matrix behindO::EyeManipulator::avatar_grab_inverse_rotation
protected
osg::Matrix behindO::EyeManipulator::avatar_grab_inverse_transform
protected
osg::Vec3 behindO::EyeManipulator::avatar_grab_pos
protected
osg::Matrix behindO::EyeManipulator::avatar_grab_rotation
protected
osg::Matrix behindO::EyeManipulator::avatar_grab_transform
protected
int behindO::EyeManipulator::control
protected
osg::Vec3 behindO::EyeManipulator::EO_owner_grab_pos
protected
osg::Matrix behindO::EyeManipulator::EO_owner_grab_rot
protected
osg::Matrix behindO::EyeManipulator::EO_owner_grab_Wrot
protected
float behindO::EyeManipulator::eye_distance_scale_factor
protected
osg::Vec3 behindO::EyeManipulator::eye_position
protected
osg::Vec3 behindO::EyeManipulator::head_center
protected
osg::Vec3 behindO::EyeManipulator::initial_sensor_pos
protected
osg::Quat behindO::EyeManipulator::last_sensor_orientation
protected
osg::Vec3 behindO::EyeManipulator::last_sensor_pos
protected
osg::Vec3 behindO::EyeManipulator::look_at_center
protected
EnvironmentObject* behindO::EyeManipulator::owner
protected
osg::Vec3 behindO::EyeManipulator::sensor_relative_pos
protected
osg::Vec3 behindO::EyeManipulator::to_center
protected
osg::Vec3 behindO::EyeManipulator::up_vector
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/EyeManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::HeadManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • HeadManipulator
Public Member Functions | Protected Attributes | List of all members
behindO::HeadManipulator Class Reference

#include <HeadManipulator.h>

Inheritance diagram for behindO::HeadManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

HeadManipulator ()
~HeadManipulator ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::Vec3 | sensor_relative_pos
osg::Vec3 | initial_sensor_pos
osg::Vec3 | last_sensor_pos
osg::Quat | initial_sensor_orientation
osg::Quat | last_sensor_orientation
float | eye_distance_scale_factor
float | left_border
float | right_border
float | top_border
float | bottom_border
float | near_border
float | far_border
osg::Vec3 | head_center
osg::Vec3 | eye_position
osg::Vec3 | up_vector
osg::Vec3 | look_at_center
osg::Vec3 | to_center
osg::Vec3 | avatar_grab_pos
osg::Matrix | avatar_grab_transform
osg::Matrix | avatar_grab_inverse_transform
osg::Matrix | avatar_grab_rotation
osg::Matrix | avatar_grab_inverse_rotation
EnvironmentObject * owner
bool | active
osg::Vec3 | difference_sensor_pos
osg::Vec3 | initial_sensor_x_orientation
osg::Quat | difference_sensor_orientation [2]
float | x_sensitivity
float | y_sensitivity
float | x_sensitivity_delta
float | delta_z
float | minimal_distance
int | mode
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::HeadManipulator::HeadManipulator ( )
behindO::HeadManipulator::~HeadManipulator ( )
inline

Member Function Documentation

bool behindO::HeadManipulator::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void behindO::HeadManipulator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::HeadManipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* behindO::HeadManipulator::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void behindO::HeadManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::HeadManipulator::active
protected
osg::Matrix behindO::HeadManipulator::avatar_grab_inverse_rotation
protected
osg::Matrix behindO::HeadManipulator::avatar_grab_inverse_transform
protected
osg::Vec3 behindO::HeadManipulator::avatar_grab_pos
protected
osg::Matrix behindO::HeadManipulator::avatar_grab_rotation
protected
osg::Matrix behindO::HeadManipulator::avatar_grab_transform
protected
float behindO::HeadManipulator::bottom_border
protected
float behindO::HeadManipulator::delta_z
protected
osg::Quat behindO::HeadManipulator::difference_sensor_orientation[2]
protected
osg::Vec3 behindO::HeadManipulator::difference_sensor_pos
protected
float behindO::HeadManipulator::eye_distance_scale_factor
protected
osg::Vec3 behindO::HeadManipulator::eye_position
protected
float behindO::HeadManipulator::far_border
protected
osg::Vec3 behindO::HeadManipulator::head_center
protected
osg::Quat behindO::HeadManipulator::initial_sensor_orientation
protected
osg::Vec3 behindO::HeadManipulator::initial_sensor_pos
protected
osg::Vec3 behindO::HeadManipulator::initial_sensor_x_orientation
protected
osg::Quat behindO::HeadManipulator::last_sensor_orientation
protected
osg::Vec3 behindO::HeadManipulator::last_sensor_pos
protected
float behindO::HeadManipulator::left_border
protected
osg::Vec3 behindO::HeadManipulator::look_at_center
protected
float behindO::HeadManipulator::minimal_distance
protected
int behindO::HeadManipulator::mode
protected
float behindO::HeadManipulator::near_border
protected
EnvironmentObject* behindO::HeadManipulator::owner
protected
float behindO::HeadManipulator::right_border
protected
osg::Vec3 behindO::HeadManipulator::sensor_relative_pos
protected
osg::Vec3 behindO::HeadManipulator::to_center
protected
float behindO::HeadManipulator::top_border
protected
osg::Vec3 behindO::HeadManipulator::up_vector
protected
float behindO::HeadManipulator::x_sensitivity
protected
float behindO::HeadManipulator::x_sensitivity_delta
protected
float behindO::HeadManipulator::y_sensitivity
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HeadManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::HMDHeadManipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • HMDHeadManipulator
Public Member Functions | Protected Attributes | List of all members
behindO::HMDHeadManipulator Class Reference

#include <HMDHeadManipulator.h>

Inheritance diagram for behindO::HMDHeadManipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

HMDHeadManipulator ()
~HMDHeadManipulator ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::Vec3 | sensor_relative_pos
osg::Vec3 | initial_sensor_pos
osg::Vec3 | last_sensor_pos
osg::Quat | last_sensor_orientation
float | eye_distance_scale_factor
osg::Vec3 | head_center
osg::Vec3 | eye_position
osg::Vec3 | up_vector
bool | active
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::HMDHeadManipulator::HMDHeadManipulator ( )
behindO::HMDHeadManipulator::~HMDHeadManipulator ( )
inline

Member Function Documentation

bool behindO::HMDHeadManipulator::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void behindO::HMDHeadManipulator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::HMDHeadManipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* behindO::HMDHeadManipulator::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void behindO::HMDHeadManipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::HMDHeadManipulator::active
protected
float behindO::HMDHeadManipulator::eye_distance_scale_factor
protected
osg::Vec3 behindO::HMDHeadManipulator::eye_position
protected
osg::Vec3 behindO::HMDHeadManipulator::head_center
protected
osg::Vec3 behindO::HMDHeadManipulator::initial_sensor_pos
protected
osg::Quat behindO::HMDHeadManipulator::last_sensor_orientation
protected
osg::Vec3 behindO::HMDHeadManipulator::last_sensor_pos
protected
osg::Vec3 behindO::HMDHeadManipulator::sensor_relative_pos
protected
osg::Vec3 behindO::HMDHeadManipulator::up_vector
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HMDHeadManipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::Lens Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Lens
Public Member Functions | List of all members
behindO::Lens Class Reference

#include <Lens.h>

Inheritance diagram for behindO::Lens:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Lens ()
~Lens ()
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

behindO::Lens::Lens ( )
behindO::Lens::~Lens ( )
inline

Member Function Documentation

void behindO::Lens::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Lens.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::Manipulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Manipulator
Public Member Functions | Protected Attributes | List of all members
behindO::Manipulator Class Reference

#include <Manipulator.h>

Inheritance diagram for behindO::Manipulator:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Manipulator ()
~Manipulator ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
std::string | getAcceptableMessages (void)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | control
bool | _first
osg::Vec3 | sensor_relative_pos
osg::Vec3 | initial_sensor_pos
osg::Vec3 | last_sensor_pos
osg::Quat | last_sensor_orientation
float | eye_distance_scale_factor
osg::Vec3 | head_center
osg::Vec3 | eye_position
osg::Vec3 | up_vector
osg::Vec3 | look_at_center
osg::Vec3 | to_center
osg::Vec3 | EO_owner_grab_pos
osg::Vec3 | avatar_grab_pos
osg::Matrix | EO_owner_grab_rot
osg::Matrix | avatar_grab_transform
osg::Matrix | avatar_grab_inverse_transform
osg::Matrix | avatar_grab_rotation
osg::Matrix | avatar_grab_inverse_rotation
osg::Matrix | EO_owner_grab_Wrot
bool | active
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::Manipulator::Manipulator ( )
behindO::Manipulator::~Manipulator ( )
inline

Member Function Documentation

std::string behindO::Manipulator::getAcceptableMessages ( void )
inline
void behindO::Manipulator::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::Manipulator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void behindO::Manipulator::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::Manipulator::_first
protected
bool behindO::Manipulator::active
protected
osg::Matrix behindO::Manipulator::avatar_grab_inverse_rotation
protected
osg::Matrix behindO::Manipulator::avatar_grab_inverse_transform
protected
osg::Vec3 behindO::Manipulator::avatar_grab_pos
protected
osg::Matrix behindO::Manipulator::avatar_grab_rotation
protected
osg::Matrix behindO::Manipulator::avatar_grab_transform
protected
int behindO::Manipulator::control
protected
osg::Vec3 behindO::Manipulator::EO_owner_grab_pos
protected
osg::Matrix behindO::Manipulator::EO_owner_grab_rot
protected
osg::Matrix behindO::Manipulator::EO_owner_grab_Wrot
protected
float behindO::Manipulator::eye_distance_scale_factor
protected
osg::Vec3 behindO::Manipulator::eye_position
protected
osg::Vec3 behindO::Manipulator::head_center
protected
osg::Vec3 behindO::Manipulator::initial_sensor_pos
protected
osg::Quat behindO::Manipulator::last_sensor_orientation
protected
osg::Vec3 behindO::Manipulator::last_sensor_pos
protected
osg::Vec3 behindO::Manipulator::look_at_center
protected
EnvironmentObject* behindO::Manipulator::owner
protected
osg::Vec3 behindO::Manipulator::sensor_relative_pos
protected
osg::Vec3 behindO::Manipulator::to_center
protected
osg::Vec3 behindO::Manipulator::up_vector
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Manipulator.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::MappingFunctions Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MappingFunctions
Public Member Functions | Protected Attributes | List of all members
behindO::MappingFunctions Class Reference

#include <MappingFunctions.h>

Inheritance diagram for behindO::MappingFunctions:
vrecko::Ability vrecko::BaseClass

Public Member Functions

MappingFunctions ()
~MappingFunctions ()
void | processEvent (const std::string &input_name, void *value)
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

std::vector< std::string > | sender_backup
std::vector< std::string > | receiver_backup
EnvironmentObject * owner
double | space_scale
bool | nonlinear
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::MappingFunctions::MappingFunctions ( )
behindO::MappingFunctions::~MappingFunctions ( )
inline

Member Function Documentation

void behindO::MappingFunctions::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::MappingFunctions::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void behindO::MappingFunctions::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::MappingFunctions::nonlinear
protected
EnvironmentObject* behindO::MappingFunctions::owner
protected
std::vector<std::string> behindO::MappingFunctions::receiver_backup
protected
std::vector<std::string> behindO::MappingFunctions::sender_backup
protected
double behindO::MappingFunctions::space_scale
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/MappingFunctions.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::MyUpdateCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MyUpdateCallback
Public Member Functions | Public Attributes | List of all members
behindO::MyUpdateCallback Class Reference

#include <Mirror.h>

Inheritance diagram for behindO::MyUpdateCallback:

Public Member Functions

MyUpdateCallback (osg::Node *subgraph)
virtual void operator() (osg::Node *node, osg::NodeVisitor *nv)

Public Attributes

osg::ref_ptr< osg::Node > _subgraph

Constructor & Destructor Documentation

behindO::MyUpdateCallback::MyUpdateCallback ( osg::Node * subgraph )
inline

Member Function Documentation

virtual void behindO::MyUpdateCallback::operator() | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlinevirtual

Member Data Documentation

osg::ref_ptr<osg::Node> behindO::MyUpdateCallback::_subgraph
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Mirror.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::MyCullCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MyCullCallback
Public Member Functions | Public Attributes | List of all members
behindO::MyCullCallback Class Reference

#include <Mirror.h>

Inheritance diagram for behindO::MyCullCallback:

Public Member Functions

MyCullCallback (osg::Node *subgraph, osg::Texture2D *texture)
MyCullCallback (osg::Node *subgraph, osg::Image *image)
virtual void | operator() (osg::Node *node, osg::NodeVisitor *nv)
void | doPreRender (osg::Node &node, osgUtil::CullVisitor &cv)

Public Attributes

osg::ref_ptr< osg::Node > | _subgraph
osg::ref_ptr< osg::Texture2D > | _texture
osg::ref_ptr< osg::Image > | _image
osg::ref_ptr< osg::StateSet > | _localState
bool | frame
osg::Vec3 | camera_position
osg::Vec3 | camera_direction
osg::Vec3 | camera_center
osg::Vec3 | old_camera_direction
osg::Vec3 | up_vector
EnvironmentObject * mirror_object
bool | dir

Constructor & Destructor Documentation

behindO::MyCullCallback::MyCullCallback | ( | osg::Node * | subgraph,
 |  | osg::Texture2D * | texture
 | ) |  |
inline
behindO::MyCullCallback::MyCullCallback | ( | osg::Node * | subgraph,
 |  | osg::Image * | image
 | ) |  |
inline

Member Function Documentation

void behindO::MyCullCallback::doPreRender | ( | osg::Node & | node,
 |  | osgUtil::CullVisitor & | cv
 | ) |  |
virtual void behindO::MyCullCallback::operator() | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlinevirtual

Member Data Documentation

osg::ref_ptr<osg::Image> behindO::MyCullCallback::_image
osg::ref_ptr<osg::StateSet> behindO::MyCullCallback::_localState
osg::ref_ptr<osg::Node> behindO::MyCullCallback::_subgraph
osg::ref_ptr<osg::Texture2D> behindO::MyCullCallback::_texture
osg::Vec3 behindO::MyCullCallback::camera_center
osg::Vec3 behindO::MyCullCallback::camera_direction
osg::Vec3 behindO::MyCullCallback::camera_position
bool behindO::MyCullCallback::dir
bool behindO::MyCullCallback::frame
EnvironmentObject* behindO::MyCullCallback::mirror_object
osg::Vec3 behindO::MyCullCallback::old_camera_direction
osg::Vec3 behindO::MyCullCallback::up_vector
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Mirror.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::Mirror Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Mirror
Public Member Functions | Protected Attributes | List of all members
behindO::Mirror Class Reference

#include <Mirror.h>

Inheritance diagram for behindO::Mirror:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Mirror ()
~Mirror ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::Geode * | _geode
osg::Geometry * | _geom
osgUtil::UpdateVisitor * | _updateVisitor
osg::Texture2D * | _texture
osg::MatrixTransform * | _parent
osg::MatrixTransform * | mirror_plane_transf
osg::Vec3 | _mirror_normal
osg::Vec3 | _eye_position
osg::Vec3 | _center_position
bool | _first
osg::Vec3Array * | mirror_plane_vertices
MyCullCallback * pMyCullCallback
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::Mirror::Mirror ( )
behindO::Mirror::~Mirror ( )
inline

Member Function Documentation

void behindO::Mirror::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::Mirror::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 behindO::Mirror::_center_position
protected
osg::Vec3 behindO::Mirror::_eye_position
protected
bool behindO::Mirror::_first
protected
osg::Geode* behindO::Mirror::_geode
protected
osg::Geometry* behindO::Mirror::_geom
protected
osg::Vec3 behindO::Mirror::_mirror_normal
protected
osg::MatrixTransform* behindO::Mirror::_parent
protected
osg::Texture2D* behindO::Mirror::_texture
protected
osgUtil::UpdateVisitor* behindO::Mirror::_updateVisitor
protected
osg::MatrixTransform * behindO::Mirror::mirror_plane_transf
protected
osg::Vec3Array* behindO::Mirror::mirror_plane_vertices
protected
MyCullCallback* behindO::Mirror::pMyCullCallback
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Mirror.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::WIM Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • WIM
Classes | Public Member Functions | Protected Attributes | List of all members
behindO::WIM Class Reference

#include <WIM.h>

Inheritance diagram for behindO::WIM:
vrecko::Ability vrecko::BaseClass

Classes

struct ObjectCopy

Public Member Functions

WIM ()
~WIM ()
void | processEvent (const std::string &input_name, void *value)
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
std::string | getAcceptableMessages (void)
Message * | getMessage (void)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | control
int | zooming
std::map< EnvironmentObject
*, ObjectCopy > 		copies_map
EnvironmentObject * border_object
EnvironmentObject * copies_root
osg::MatrixTransform * | visual_border_object
osg::Vec3 | WIM_size
osg::Vec3 | WIM_center
float | WIM_scale
float | origin_WIM_scale
bool | WIM_commit
bool | avatar_copy
bool | work_area_selection
esg::BVH * | border_bvh
Ability * pAvatarManipulator
EnvironmentObject * owner
EnvironmentObject * pAvatarCopy
EnvironmentObject * pAvatarOwner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

behindO::WIM::WIM ( )
behindO::WIM::~WIM ( )
inline

Member Function Documentation

std::string behindO::WIM::getAcceptableMessages ( void )
inline
Message* behindO::WIM::getMessage ( void )
inline
bool behindO::WIM::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void behindO::WIM::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void behindO::WIM::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* behindO::WIM::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void behindO::WIM::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool behindO::WIM::avatar_copy
protected
esg::BVH* behindO::WIM::border_bvh
protected
EnvironmentObject* behindO::WIM::border_object
protected
int behindO::WIM::control
protected
std::map<EnvironmentObject *, ObjectCopy> behindO::WIM::copies_map
protected
EnvironmentObject * behindO::WIM::copies_root
protected
float behindO::WIM::origin_WIM_scale
protected
EnvironmentObject* behindO::WIM::owner
protected
EnvironmentObject * behindO::WIM::pAvatarCopy
protected
Ability* behindO::WIM::pAvatarManipulator
protected
EnvironmentObject * behindO::WIM::pAvatarOwner
protected
osg::MatrixTransform* behindO::WIM::visual_border_object
protected
osg::Vec3 behindO::WIM::WIM_center
protected
bool behindO::WIM::WIM_commit
protected
float behindO::WIM::WIM_scale
protected
osg::Vec3 behindO::WIM::WIM_size
protected
bool behindO::WIM::work_area_selection
protected
int behindO::WIM::zooming
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/WIM.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: behindO::WIM::ObjectCopy Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • WIM
  • ObjectCopy
Public Attributes | List of all members
behindO::WIM::ObjectCopy Struct Reference

#include <WIM.h>

Public Attributes

EnvironmentObject * copy
osg::Vec3 | last_position
osg::Matrix | last_rotation

Member Data Documentation

EnvironmentObject* behindO::WIM::ObjectCopy::copy
osg::Vec3 behindO::WIM::ObjectCopy::last_position
osg::Matrix behindO::WIM::ObjectCopy::last_rotation
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/WIM.h
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: boids::Boid Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • Boid
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
boids::Boid Class Reference

#include <Boid.h>

Inheritance diagram for boids::Boid:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Boid ()
~Boid ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Velocity, MessageVec3)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
osg::Vec3 | up_vector
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Boid::Boid ( )
Boid::~Boid ( )

Member Function Documentation

boids::Boid::DECLARE_INPUT | ( | Position | ,
 |  | MessageVec3 |
 | ) |  |
protected
boids::Boid::DECLARE_INPUT | ( | Velocity | ,
 |  | MessageVec3 |
 | ) |  |
protected
bool Boid::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Boid::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Boid::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Boid::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void Boid::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

EnvironmentObject* boids::Boid::owner
protected
osg::Vec3 boids::Boid::up_vector
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/Boid.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/Boid.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: boids::BoidsLogic Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • BoidsLogic
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
boids::BoidsLogic Class Reference

#include <BoidsLogic.h>

Inheritance diagram for boids::BoidsLogic:
vrecko::Ability vrecko::BaseClass

Public Member Functions

BoidsLogic ()
~BoidsLogic ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | rule0_in_sight (int other_boid, int boid)
osg::Vec3 | rule1_centre_of_mass (int boid)
osg::Vec3 | rule2_away_from_others (int boid)
osg::Vec3 | rule3_match_velocity (int boid)
osg::Vec3 | rule4_bound_position (int boid)
osg::Vec3 | rule5_fly_to_waypoint (int boid)
osg::Vec3 | rule6_fly_from_danger (int boid)
void | limit_speed (int boid)
bool | rest_on_land (int boid)
DECLARE_INPUT (Waypoint, MessageVec3)
DECLARE_INPUT (Danger, MessageVec3)
DECLARE_OUTPUT (NextWaypoint, MessageBool)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector< osg::Vec3 > | boids_position
std::vector< osg::Vec3 > | boids_velocity
std::vector< float > | boids_rest_time
std::vector< string > | boids_position_output
std::vector< string > | boids_velocity_output
int | boids_count
osg::Vec3 | max_bound
osg::Vec3 | min_bound
osg::Vec3 | bound_velocity
float | move_factor
float | small_distance
float | velocity_factor
float | max_speed
float | waypoint_speed
float | next_waypoint_dist
bool | next_waypoint
osg::Vec3 | waypoint
float | scare_distance
float | danger_factor
osg::Vec3 | danger
float | land_level
float | takeoff_time
float | rest_time
float | sight_angle
std::string | mesg
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

BoidsLogic::BoidsLogic ( )
boids::BoidsLogic::~BoidsLogic ( )
inline

Member Function Documentation

boids::BoidsLogic::DECLARE_INPUT | ( | Waypoint | ,
 |  | MessageVec3 |
 | ) |  |
protected
boids::BoidsLogic::DECLARE_INPUT | ( | Danger | ,
 |  | MessageVec3 |
 | ) |  |
protected
boids::BoidsLogic::DECLARE_OUTPUT | ( | NextWaypoint | ,
 |  | MessageBool |
 | ) |  |
protected
void BoidsLogic::limit_speed ( int boid )
protected
bool BoidsLogic::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void BoidsLogic::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BoidsLogic::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

bool BoidsLogic::rest_on_land ( int boid )
protected
bool BoidsLogic::rule0_in_sight | ( | int | other_boid,
 |  | int | boid
 | ) |  |
protected
osg::Vec3 BoidsLogic::rule1_centre_of_mass ( int boid )
protected
osg::Vec3 BoidsLogic::rule2_away_from_others ( int boid )
protected
osg::Vec3 BoidsLogic::rule3_match_velocity ( int boid )
protected
osg::Vec3 BoidsLogic::rule4_bound_position ( int boid )
protected
osg::Vec3 BoidsLogic::rule5_fly_to_waypoint ( int boid )
protected
osg::Vec3 BoidsLogic::rule6_fly_from_danger ( int boid )
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * BoidsLogic::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void BoidsLogic::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

int boids::BoidsLogic::boids_count
protected
std::vector<osg::Vec3> boids::BoidsLogic::boids_position
protected
std::vector<string> boids::BoidsLogic::boids_position_output
protected
std::vector<float> boids::BoidsLogic::boids_rest_time
protected
std::vector<osg::Vec3> boids::BoidsLogic::boids_velocity
protected
std::vector<string> boids::BoidsLogic::boids_velocity_output
protected
osg::Vec3 boids::BoidsLogic::bound_velocity
protected
osg::Vec3 boids::BoidsLogic::danger
protected
float boids::BoidsLogic::danger_factor
protected
float boids::BoidsLogic::land_level
protected
osg::Vec3 boids::BoidsLogic::max_bound
protected
float boids::BoidsLogic::max_speed
protected
std::string boids::BoidsLogic::mesg
protected
osg::Vec3 boids::BoidsLogic::min_bound
protected
float boids::BoidsLogic::move_factor
protected
bool boids::BoidsLogic::next_waypoint
protected
float boids::BoidsLogic::next_waypoint_dist
protected
float boids::BoidsLogic::rest_time
protected
float boids::BoidsLogic::scare_distance
protected
float boids::BoidsLogic::sight_angle
protected
float boids::BoidsLogic::small_distance
protected
float boids::BoidsLogic::takeoff_time
protected
float boids::BoidsLogic::velocity_factor
protected
osg::Vec3 boids::BoidsLogic::waypoint
protected
float boids::BoidsLogic::waypoint_speed
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsLogic.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/BoidsLogic.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: boids::BoidsPlanner Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • BoidsPlanner
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
boids::BoidsPlanner Class Reference

#include <BoidsPlanner.h>

Inheritance diagram for boids::BoidsPlanner:
vrecko::Ability vrecko::BaseClass

Public Member Functions

BoidsPlanner ()
~BoidsPlanner ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (NextWaypoint, MessageBool)
DECLARE_OUTPUT (Waypoint, MessageVec3)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector< osg::Vec3 > | waypoints
int | current_waypoint
std::string | mesg
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

BoidsPlanner::BoidsPlanner ( )
boids::BoidsPlanner::~BoidsPlanner ( )
inline

Member Function Documentation

boids::BoidsPlanner::DECLARE_INPUT | ( | NextWaypoint | ,
 |  | MessageBool |
 | ) |  |
protected
boids::BoidsPlanner::DECLARE_OUTPUT | ( | Waypoint | ,
 |  | MessageVec3 |
 | ) |  |
protected
bool BoidsPlanner::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void BoidsPlanner::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BoidsPlanner::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * BoidsPlanner::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void BoidsPlanner::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

int boids::BoidsPlanner::current_waypoint
protected
std::string boids::BoidsPlanner::mesg
protected
std::vector<osg::Vec3> boids::BoidsPlanner::waypoints
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsPlanner.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/BoidsPlanner.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarControlUnit Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarControlUnit
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::CarControlUnit Class Reference

#include <CarControlUnit.h>

Inheritance diagram for CarSim::CarControlUnit:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CarControlUnit ()
CarControlUnit (const unsigned int startRoad, const unsigned int stopRoad, const bool startDirection, const bool stopDirection, const float startEdge, const float stopEdge, const float startOffset, const float stopOffset, const float recVelOnFstJunc, const unsigned int fstJuncTurn, Ability *const pRoadsState, Ability *const pCEU, const std::vector< unsigned int > *const pPath)
~CarControlUnit ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | init ()
void | initPositionAndDirection ()
void | checkInputXMLParameters ()
void | computeShortestPath ()
void | computeRecVelOnFstJunc ()
void | figureOutFirstJuncTurn ()
void | quitAfterError ()
float | getTimeFromLastUpdate ()
void | setBlinkers (Ability *const pCEU, const unsigned int blinkLightState, const bool isEmergency)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

Parameters params
float | timeWaiting
const bool | gen
bool | errorOccuredInInit
bool | initBool
unsigned int | startRoad
bool | startDirection
unsigned int | stopRoad
bool | stopDirection
float | recVelocityOnJunc
Ability * pRoadsState
osg::Timer_t | lastTick
unsigned int | nextJuncTurn
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

CarControlUnit::CarControlUnit ( )
CarControlUnit::CarControlUnit | ( | const unsigned int | startRoad,
 |  | const unsigned int | stopRoad,
 |  | const bool | startDirection,
 |  | const bool | stopDirection,
 |  | const float | startEdge,
 |  | const float | stopEdge,
 |  | const float | startOffset,
 |  | const float | stopOffset,
 |  | const float | recVelOnFstJunc,
 |  | const unsigned int | fstJuncTurn,
 |  | Ability *const | pRoadsState,
 |  | Ability *const | pCEU,
 |  | const std::vector< unsigned int > *const | pPath
 | ) |  |
CarControlUnit::~CarControlUnit ( )

Member Function Documentation

void CarControlUnit::checkInputXMLParameters ( )
protected
void CarControlUnit::computeRecVelOnFstJunc ( )
protected
void CarControlUnit::computeShortestPath ( )
protected
void CarControlUnit::figureOutFirstJuncTurn ( )
protected
float CarControlUnit::getTimeFromLastUpdate ( )
protected
void CarControlUnit::init ( void )
protected
void CarControlUnit::initPositionAndDirection ( )
protected
bool CarControlUnit::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void CarControlUnit::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void CarControlUnit::quitAfterError ( )
protected
void CarControlUnit::setBlinkers | ( | Ability *const | pCEU,
 |  | const unsigned int | blinkLightState,
 |  | const bool | isEmergency
 | ) |  |
protected
void CarControlUnit::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool CarSim::CarControlUnit::errorOccuredInInit
protected
const bool CarSim::CarControlUnit::gen
protected
bool CarSim::CarControlUnit::initBool
protected
osg::Timer_t CarSim::CarControlUnit::lastTick
protected
unsigned int CarSim::CarControlUnit::nextJuncTurn
protected
Parameters CarSim::CarControlUnit::params
protected
Ability* CarSim::CarControlUnit::pRoadsState
protected
float CarSim::CarControlUnit::recVelocityOnJunc
protected
bool CarSim::CarControlUnit::startDirection
protected
unsigned int CarSim::CarControlUnit::startRoad
protected
bool CarSim::CarControlUnit::stopDirection
protected
unsigned int CarSim::CarControlUnit::stopRoad
protected
float CarSim::CarControlUnit::timeWaiting
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarControlUnit.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarControlUnit.cpp
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarEnvirons Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarEnvirons
Public Attributes | List of all members
CarSim::CarEnvirons Struct Reference

#include <CarEnvirons.h>

Public Attributes

unsigned int | carNextJuncRel
bool | pass
float | distToNextPoint
float | wheelAngleOnJunc
float | recVelocityOnJunc
unsigned int | carEdgeId
float | nextCarDist
float | nextCarVel
unsigned int | nextJuncTurn

Member Data Documentation

unsigned int CarSim::CarEnvirons::carEdgeId
unsigned int CarSim::CarEnvirons::carNextJuncRel
float CarSim::CarEnvirons::distToNextPoint
float CarSim::CarEnvirons::nextCarDist
float CarSim::CarEnvirons::nextCarVel
unsigned int CarSim::CarEnvirons::nextJuncTurn
bool CarSim::CarEnvirons::pass
float CarSim::CarEnvirons::recVelocityOnJunc
float CarSim::CarEnvirons::wheelAngleOnJunc
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarEnvirons.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::Lights Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Lights
Public Attributes | List of all members
CarSim::Lights Struct Reference

#include <CarExecutionUnit.h>

Public Attributes

osg::MatrixTransform * | pFrontLightMT
osg::MatrixTransform * | pBrakeLightMT
osg::MatrixTransform * | pLeftBlinkerLightMT
osg::MatrixTransform * | pRightBlinkerLightMT

Member Data Documentation

osg::MatrixTransform* CarSim::Lights::pBrakeLightMT
osg::MatrixTransform* CarSim::Lights::pFrontLightMT
osg::MatrixTransform* CarSim::Lights::pLeftBlinkerLightMT
osg::MatrixTransform* CarSim::Lights::pRightBlinkerLightMT
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarExecutionUnit.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::GeometryPartsPath Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • GeometryPartsPath
Public Attributes | List of all members
CarSim::GeometryPartsPath Struct Reference

#include <CarExecutionUnit.h>

Public Attributes

std::string | carWithoutWheelsPath
std::vector< std::string > | leftWheelsPathVec
std::string | frontLightsPath
std::string | brakeLightsPath
std::string | leftBlinkerPath
std::string | rightBlinkerPath

Member Data Documentation

std::string CarSim::GeometryPartsPath::brakeLightsPath
std::string CarSim::GeometryPartsPath::carWithoutWheelsPath
std::string CarSim::GeometryPartsPath::frontLightsPath
std::string CarSim::GeometryPartsPath::leftBlinkerPath
std::vector<std::string> CarSim::GeometryPartsPath::leftWheelsPathVec
std::string CarSim::GeometryPartsPath::rightBlinkerPath
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarExecutionUnit.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarExecutionUnit Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarExecutionUnit
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::CarExecutionUnit Class Reference

#include <CarExecutionUnit.h>

Inheritance diagram for CarSim::CarExecutionUnit:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CarExecutionUnit ()
CarExecutionUnit (const CarSize &carSize, const float maxSpeed, const float minSpeed, const float maxAcc, const float minAcc, const float maxDispWheelAngle, std::vector< osg::MatrixTransform * > *const pWheelsVec, const float wheelR, Lights *const pLights, const osg::Vec3 &carDirection, const osg::Vec3 &carNormal, const osg::Vec3 &carPositionOnRoad, vrecko::EnvironmentObject *const pFutureCarEOownerToSet)
~CarExecutionUnit ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | checkXMLparameters ()
void | initDirection (const osg::Vec3 &dir)
void | initNormal (const osg::Vec3 &normal)
void | computeCarState (const float lastFrameLength)
void | switchLight (const unsigned int lightType, const unsigned int lightState)
void | blink (const float lastFrameLength)
void | loadGeometryParts ()
DECLARE_INPUT (InAcc, vrecko::MessageFloat)
DECLARE_INPUT (InWheelAngle, vrecko::MessageFloat)
DECLARE_INPUT (InStop, vrecko::MessageVoid)
DECLARE_INPUT (InUpdate, vrecko::MessageFloat)
DECLARE_INPUT (InInitNormal, vrecko::MessageVec3)
DECLARE_INPUT (InInitDirection, vrecko::MessageVec3)
DECLARE_INPUT (InInitPosition, vrecko::MessageVec3)
DECLARE_INPUT (InSetCarNormal, vrecko::MessageVec3)
DECLARE_INPUT (InPushCarInNormalDir, vrecko::MessageFloat)
DECLARE_INPUT (InPushCarInDirectionCrossNormalDir, vrecko::MessageFloat)
DECLARE_INPUT (InSetBlinker, vrecko::MessageUnsignedInt)
DECLARE_INPUT (InShow, vrecko::MessageVoid)
DECLARE_INPUT (InHide, vrecko::MessageVoid)
DECLARE_REQUEST_INPUT (InGetCarState, vrecko::MessageVoid, MessageCarStatePtr)
DECLARE_REQUEST_INPUT (InGetCarLength, vrecko::MessageVoid, vrecko::MessageFloat)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

CarState carState
float | vPrevious
float | maxSpeed
float | minSpeed
float | maxDispWheelAngle
float | wheelDisplayAngleAroundNormal
float | wheelRotateAngle
float | wheelR
std::vector
< osg::MatrixTransform * >
*const 		pWheelsVec
std::vector< osg::Matrix > | wheelsInitMatrixVec
Lights *const | pLights
unsigned int | frontLightState
unsigned int | brakeLightState
float | timeFromLastBlinkStart
const bool | isGenCar
GeometryPartsPath *const | pGeometryPartsPath
std::vector< osg::Vec3 > *const | pLeftWheelsPosVec
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

CarExecutionUnit::CarExecutionUnit ( )
CarSim::CarExecutionUnit::CarExecutionUnit | ( | const CarSize & | carSize,
 |  | const float | maxSpeed,
 |  | const float | minSpeed,
 |  | const float | maxAcc,
 |  | const float | minAcc,
 |  | const float | maxDispWheelAngle,
 |  | std::vector< osg::MatrixTransform * > *const | pWheelsVec,
 |  | const float | wheelR,
 |  | Lights *const | pLights,
 |  | const osg::Vec3 & | carDirection,
 |  | const osg::Vec3 & | carNormal,
 |  | const osg::Vec3 & | carPositionOnRoad,
 |  | vrecko::EnvironmentObject *const | pFutureCarEOownerToSet
 | ) |  |
CarExecutionUnit::~CarExecutionUnit ( )

Member Function Documentation

void CarExecutionUnit::blink ( const float lastFrameLength )
protected
void CarExecutionUnit::checkXMLparameters ( )
protected
void CarExecutionUnit::computeCarState ( const float lastFrameLength )
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InAcc | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InWheelAngle | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InStop | ,
 |  | vrecko::MessageVoid |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InUpdate | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InInitNormal | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InInitDirection | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InInitPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InSetCarNormal | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InPushCarInNormalDir | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InPushCarInDirectionCrossNormalDir | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InSetBlinker | ,
 |  | vrecko::MessageUnsignedInt |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InShow | ,
 |  | vrecko::MessageVoid |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_INPUT | ( | InHide | ,
 |  | vrecko::MessageVoid |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_REQUEST_INPUT | ( | InGetCarState | ,
 |  | vrecko::MessageVoid | ,
 |  | MessageCarStatePtr |
 | ) |  |
protected
CarSim::CarExecutionUnit::DECLARE_REQUEST_INPUT | ( | InGetCarLength | ,
 |  | vrecko::MessageVoid | ,
 |  | vrecko::MessageFloat |
 | ) |  |
protected
void CarExecutionUnit::initDirection ( const osg::Vec3 & dir )
protected
void CarExecutionUnit::initNormal ( const osg::Vec3 & normal )
protected
void CarExecutionUnit::loadGeometryParts ( )
protected
bool CarExecutionUnit::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void CarExecutionUnit::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void CarExecutionUnit::switchLight | ( | const unsigned int | lightType,
 |  | const unsigned int | lightState
 | ) |  |
protected
void CarExecutionUnit::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

unsigned int CarSim::CarExecutionUnit::brakeLightState
protected
CarState CarSim::CarExecutionUnit::carState
protected
unsigned int CarSim::CarExecutionUnit::frontLightState
protected
const bool CarSim::CarExecutionUnit::isGenCar
protected
float CarSim::CarExecutionUnit::maxDispWheelAngle
protected
float CarSim::CarExecutionUnit::maxSpeed
protected
float CarSim::CarExecutionUnit::minSpeed
protected
GeometryPartsPath* const CarSim::CarExecutionUnit::pGeometryPartsPath
protected
std::vector<osg::Vec3>* const CarSim::CarExecutionUnit::pLeftWheelsPosVec
protected
Lights* const CarSim::CarExecutionUnit::pLights
protected
std::vector<osg::MatrixTransform*>* const CarSim::CarExecutionUnit::pWheelsVec
protected
float CarSim::CarExecutionUnit::timeFromLastBlinkStart
protected
float CarSim::CarExecutionUnit::vPrevious
protected
float CarSim::CarExecutionUnit::wheelDisplayAngleAroundNormal
protected
float CarSim::CarExecutionUnit::wheelR
protected
float CarSim::CarExecutionUnit::wheelRotateAngle
protected
std::vector<osg::Matrix> CarSim::CarExecutionUnit::wheelsInitMatrixVec
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarExecutionUnit.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarExecutionUnit.cpp
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarPartsNodeCache Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarPartsNodeCache
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::CarPartsNodeCache Class Reference

#include <CarPartsNodeCache.h>

Inheritance diagram for CarSim::CarPartsNodeCache:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CarPartsNodeCache ()
~CarPartsNodeCache ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_INPUT (InGetCarPartNode, vrecko::MessageString, vrecko::MessageNode)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::map< std::string,
osg::ref_ptr< osg::Node > > 		carPartsPathNodeMap
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

CarPartsNodeCache::CarPartsNodeCache ( )
CarPartsNodeCache::~CarPartsNodeCache ( )

Member Function Documentation

CarSim::CarPartsNodeCache::DECLARE_REQUEST_INPUT | ( | InGetCarPartNode | ,
 |  | vrecko::MessageString | ,
 |  | vrecko::MessageNode |
 | ) |  |
protected

Member Data Documentation

std::map<std::string,osg::ref_ptr<osg::Node> > CarSim::CarPartsNodeCache::carPartsPathNodeMap
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarPartsNodeCache.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarPartsNodeCache.cpp
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarSize Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarSize
Public Attributes | List of all members
CarSim::CarSize Struct Reference

#include <CarState.h>

Public Attributes

float | height
float | length
float | width

Member Data Documentation

float CarSim::CarSize::height
float CarSim::CarSize::length
float CarSim::CarSize::width
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarState.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarState Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarState
Public Attributes | List of all members
CarSim::CarState Struct Reference

#include <CarState.h>

Public Attributes

float | acc
float | v
float | wheelAngle
osg::Vec3 | position
osg::Vec3 | bottomCarPosition
osg::Vec3 | direction
osg::Vec3 | normal
float | maxAcc
float | minAcc
bool | stoped
CarSize carSize
float | distFromLastFrame
unsigned int | blinkLightState

Member Data Documentation

float CarSim::CarState::acc
unsigned int CarSim::CarState::blinkLightState
osg::Vec3 CarSim::CarState::bottomCarPosition
CarSize CarSim::CarState::carSize
osg::Vec3 CarSim::CarState::direction
float CarSim::CarState::distFromLastFrame
float CarSim::CarState::maxAcc
float CarSim::CarState::minAcc
osg::Vec3 CarSim::CarState::normal
osg::Vec3 CarSim::CarState::position
bool CarSim::CarState::stoped
float CarSim::CarState::v
float CarSim::CarState::wheelAngle
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarState.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::StartStopDestination Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • StartStopDestination
Public Attributes | List of all members
CarSim::StartStopDestination Struct Reference

#include <CCUStructs.h>

Public Attributes

unsigned int | startEdge
unsigned int | stopEdge
float | startOffset
float | stopOffset

Member Data Documentation

unsigned int CarSim::StartStopDestination::startEdge
float CarSim::StartStopDestination::startOffset
unsigned int CarSim::StartStopDestination::stopEdge
float CarSim::StartStopDestination::stopOffset
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::Parameters Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Parameters
Public Attributes | List of all members
CarSim::Parameters Struct Reference

#include <CCUStructs.h>

Public Attributes

unsigned int | carId
vrecko::Ability * pCEU
std::vector< unsigned int > | path
unsigned int | lastJuncInPath
StartStopDestination startStopDestination
unsigned int | carNextJuncRel
unsigned int | carEdgeId
bool | pass

Member Data Documentation

unsigned int CarSim::Parameters::carEdgeId
unsigned int CarSim::Parameters::carId
unsigned int CarSim::Parameters::carNextJuncRel
unsigned int CarSim::Parameters::lastJuncInPath
bool CarSim::Parameters::pass
std::vector<unsigned int> CarSim::Parameters::path
vrecko::Ability* CarSim::Parameters::pCEU
StartStopDestination CarSim::Parameters::startStopDestination
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::First3Juncs Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • First3Juncs
Public Attributes | List of all members
CarSim::First3Juncs Struct Reference

#include <CCUStructs.h>

Public Attributes

unsigned int | lastJunc
unsigned int | nextJunc
unsigned int | nextNextJunc

Member Data Documentation

unsigned int CarSim::First3Juncs::lastJunc
unsigned int CarSim::First3Juncs::nextJunc
unsigned int CarSim::First3Juncs::nextNextJunc
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::CarEdgeData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarEdgeData
Public Attributes | List of all members
CarSim::CarEdgeData Struct Reference

#include <CCUStructs.h>

Public Attributes

unsigned int | carId
unsigned int | edgeId
float | offset
float | carLength

Member Data Documentation

unsigned int CarSim::CarEdgeData::carId
float CarSim::CarEdgeData::carLength
unsigned int CarSim::CarEdgeData::edgeId
float CarSim::CarEdgeData::offset
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageRoadAndDir Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageRoadAndDir
Public Member Functions | Public Attributes | List of all members
CarSim::MessageRoadAndDir Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageRoadAndDir:
vrecko::VreckoMessage

Public Member Functions

MessageRoadAndDir ()
MessageRoadAndDir (unsigned int newRoad, bool newDir)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

unsigned int | road
bool | direction

Constructor & Destructor Documentation

CarSim::MessageRoadAndDir::MessageRoadAndDir ( )
inline
CarSim::MessageRoadAndDir::MessageRoadAndDir | ( | unsigned int | newRoad,
 |  | bool | newDir
 | ) |  |
inline

Member Function Documentation

virtual const char* CarSim::MessageRoadAndDir::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

bool CarSim::MessageRoadAndDir::direction
unsigned int CarSim::MessageRoadAndDir::road
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageCarEdge Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEdge
Public Member Functions | Public Attributes | List of all members
CarSim::MessageCarEdge Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageCarEdge:
vrecko::VreckoMessage

Public Member Functions

MessageCarEdge ()
MessageCarEdge (unsigned int newCar, unsigned int newEdge)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

unsigned int | car
unsigned int | edge

Constructor & Destructor Documentation

CarSim::MessageCarEdge::MessageCarEdge ( )
inline
CarSim::MessageCarEdge::MessageCarEdge | ( | unsigned int | newCar,
 |  | unsigned int | newEdge
 | ) |  |
inline

Member Function Documentation

virtual const char* CarSim::MessageCarEdge::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

unsigned int CarSim::MessageCarEdge::car
unsigned int CarSim::MessageCarEdge::edge
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageCarEdgeData Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEdgeData
Public Member Functions | Public Attributes | List of all members
CarSim::MessageCarEdgeData Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageCarEdgeData:
vrecko::VreckoMessage

Public Member Functions

MessageCarEdgeData ()
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

CarEdgeData data

Constructor & Destructor Documentation

CarSim::MessageCarEdgeData::MessageCarEdgeData ( )
inline

Member Function Documentation

virtual const char* CarSim::MessageCarEdgeData::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

CarEdgeData CarSim::MessageCarEdgeData::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageEdgeOffset Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageEdgeOffset
Public Member Functions | Public Attributes | List of all members
CarSim::MessageEdgeOffset Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageEdgeOffset:
vrecko::VreckoMessage

Public Member Functions

MessageEdgeOffset ()
MessageEdgeOffset (unsigned int theEdge, float theOffset)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

unsigned int | edge
float | offset

Constructor & Destructor Documentation

CarSim::MessageEdgeOffset::MessageEdgeOffset ( )
inline
CarSim::MessageEdgeOffset::MessageEdgeOffset | ( | unsigned int | theEdge,
 |  | float | theOffset
 | ) |  |
inline

Member Function Documentation

virtual const char* CarSim::MessageEdgeOffset::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

unsigned int CarSim::MessageEdgeOffset::edge
float CarSim::MessageEdgeOffset::offset
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageVectorUnsignedInt Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageVectorUnsignedInt
Public Member Functions | Public Attributes | List of all members
CarSim::MessageVectorUnsignedInt Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageVectorUnsignedInt:
vrecko::VreckoMessage

Public Member Functions

MessageVectorUnsignedInt ()
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

std::vector< unsigned int > data

Constructor & Destructor Documentation

CarSim::MessageVectorUnsignedInt::MessageVectorUnsignedInt ( )
inline

Member Function Documentation

virtual const char* CarSim::MessageVectorUnsignedInt::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

std::vector<unsigned int> CarSim::MessageVectorUnsignedInt::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageStartStopDestination Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageStartStopDestination
Public Member Functions | Public Attributes | List of all members
CarSim::MessageStartStopDestination Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageStartStopDestination:
vrecko::VreckoMessage

Public Member Functions

MessageStartStopDestination ()
MessageStartStopDestination (StartStopDestination &dataToCopy)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

StartStopDestination data

Constructor & Destructor Documentation

CarSim::MessageStartStopDestination::MessageStartStopDestination ( )
inline
CarSim::MessageStartStopDestination::MessageStartStopDestination ( StartStopDestination & dataToCopy )
inline

Member Function Documentation

virtual const char* CarSim::MessageStartStopDestination::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

StartStopDestination CarSim::MessageStartStopDestination::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageFirst3Juncs Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageFirst3Juncs
Public Member Functions | Public Attributes | List of all members
CarSim::MessageFirst3Juncs Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageFirst3Juncs:
vrecko::VreckoMessage

Public Member Functions

MessageFirst3Juncs ()
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

First3Juncs data

Constructor & Destructor Documentation

CarSim::MessageFirst3Juncs::MessageFirst3Juncs ( )
inline

Member Function Documentation

virtual const char* CarSim::MessageFirst3Juncs::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

First3Juncs CarSim::MessageFirst3Juncs::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageCarSimParameters Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarSimParameters
Public Member Functions | Public Attributes | List of all members
CarSim::MessageCarSimParameters Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageCarSimParameters:
vrecko::VreckoMessage

Public Member Functions

MessageCarSimParameters ()
MessageCarSimParameters (Parameters &paramsToCopy)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

Parameters data

Constructor & Destructor Documentation

CarSim::MessageCarSimParameters::MessageCarSimParameters ( )
inline
CarSim::MessageCarSimParameters::MessageCarSimParameters ( Parameters & paramsToCopy )
inline

Member Function Documentation

virtual const char* CarSim::MessageCarSimParameters::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

Parameters CarSim::MessageCarSimParameters::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageCarEnvirons Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEnvirons
Public Member Functions | Public Attributes | List of all members
CarSim::MessageCarEnvirons Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageCarEnvirons:
vrecko::VreckoMessage

Public Member Functions

MessageCarEnvirons ()
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

CarEnvirons data

Constructor & Destructor Documentation

CarSim::MessageCarEnvirons::MessageCarEnvirons ( )
inline

Member Function Documentation

virtual const char* CarSim::MessageCarEnvirons::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

CarEnvirons CarSim::MessageCarEnvirons::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::MessageCarStatePtr Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarStatePtr
Public Member Functions | Public Attributes | List of all members
CarSim::MessageCarStatePtr Class Reference

#include <CCUStructs.h>

Inheritance diagram for CarSim::MessageCarStatePtr:
vrecko::VreckoMessage

Public Member Functions

MessageCarStatePtr ()
MessageCarStatePtr (CarState *csToPointAt)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

CarState * data

Constructor & Destructor Documentation

CarSim::MessageCarStatePtr::MessageCarStatePtr ( )
inline
CarSim::MessageCarStatePtr::MessageCarStatePtr ( CarState * csToPointAt )
inline

Member Function Documentation

virtual const char* CarSim::MessageCarStatePtr::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

CarState* CarSim::MessageCarStatePtr::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::EdgesCar Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • EdgesCar
Public Attributes | List of all members
CarSim::EdgesCar Struct Reference

#include <Edge.h>

Public Attributes

float | headOffset
float | rearOffset
unsigned int | frontCarId
unsigned int | backCarId
float | vel

Member Data Documentation

unsigned int CarSim::EdgesCar::backCarId
unsigned int CarSim::EdgesCar::frontCarId
float CarSim::EdgesCar::headOffset
float CarSim::EdgesCar::rearOffset
float CarSim::EdgesCar::vel
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Edge.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::Edge Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Edge
Public Attributes | List of all members
CarSim::Edge Struct Reference

#include <Edge.h>

Public Attributes

unsigned int | roadId
bool | direction
unsigned int | from
unsigned int | to
unsigned int | fromPointRight
unsigned int | toPointRight
unsigned int | numLanes
float | length
osg::Vec3 | inPos
osg::Vec3 | outPos
osg::Vec3 | outInVec
osg::Vec3 | normal
float | stopBeforeJuncOffset
float | stopOrGoDecisionOffset
unsigned int | type
float | widthTPR
float | widthFPR
float | lowBoundForStartStopPosOffset
std::map< unsigned int, EdgesCar > | edgesCars
unsigned int | fstCarId
unsigned int | lastCarId
std::map< unsigned int, bool > | incomingCars
std::queue< unsigned int > | putAsideCars
unsigned int | tlGreenInterv

Member Data Documentation

bool CarSim::Edge::direction
std::map<unsigned int,EdgesCar> CarSim::Edge::edgesCars
unsigned int CarSim::Edge::from
unsigned int CarSim::Edge::fromPointRight
unsigned int CarSim::Edge::fstCarId
std::map<unsigned int,bool> CarSim::Edge::incomingCars
osg::Vec3 CarSim::Edge::inPos
unsigned int CarSim::Edge::lastCarId
float CarSim::Edge::length
float CarSim::Edge::lowBoundForStartStopPosOffset
osg::Vec3 CarSim::Edge::normal
unsigned int CarSim::Edge::numLanes
osg::Vec3 CarSim::Edge::outInVec
osg::Vec3 CarSim::Edge::outPos
std::queue<unsigned int> CarSim::Edge::putAsideCars
unsigned int CarSim::Edge::roadId
float CarSim::Edge::stopBeforeJuncOffset
float CarSim::Edge::stopOrGoDecisionOffset
unsigned int CarSim::Edge::tlGreenInterv
unsigned int CarSim::Edge::to
unsigned int CarSim::Edge::toPointRight
unsigned int CarSim::Edge::type
float CarSim::Edge::widthFPR
float CarSim::Edge::widthTPR
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Edge.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::InOutEdgesAttr Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • InOutEdgesAttr
Public Attributes | List of all members
CarSim::InOutEdgesAttr Struct Reference

#include <Junction.h>

Public Attributes

float | angleInXZ
osg::Vec3 | hfCubicsBorder
osg::Vec3 | hfCubicsBorderVec

Member Data Documentation

float CarSim::InOutEdgesAttr::angleInXZ
osg::Vec3 CarSim::InOutEdgesAttr::hfCubicsBorder
osg::Vec3 CarSim::InOutEdgesAttr::hfCubicsBorderVec
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Junction.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::JuncsEdge Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • JuncsEdge
Public Attributes | List of all members
CarSim::JuncsEdge Struct Reference

#include <Junction.h>

Public Attributes

unsigned int | nextEdgeId
unsigned int | prevEdgeId
unsigned int | lockCount
float | angle
unsigned int | tlColors

Member Data Documentation

float CarSim::JuncsEdge::angle
unsigned int CarSim::JuncsEdge::lockCount
unsigned int CarSim::JuncsEdge::nextEdgeId
unsigned int CarSim::JuncsEdge::prevEdgeId
unsigned int CarSim::JuncsEdge::tlColors
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Junction.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::Junction Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Junction
Public Attributes | List of all members
CarSim::Junction Struct Reference

#include <Junction.h>

Public Attributes

unsigned int | id
osg::Vec3 | position
std::map< unsigned int, JuncsEdge > | orderedEdges
std::map< unsigned int,
std::map< unsigned int,
InOutEdgesAttr > > 		inOutEdgesAttrMap
unsigned int | partJuncCardinality
unsigned int | complexJunc
unsigned int | carIdUnlockedEdge
unsigned int | controlSystem
unsigned int | lastCarInEdge
unsigned int | lastCarOutEdge

Member Data Documentation

unsigned int CarSim::Junction::carIdUnlockedEdge
unsigned int CarSim::Junction::complexJunc
unsigned int CarSim::Junction::controlSystem
unsigned int CarSim::Junction::id
std::map<unsigned int, std::map<unsigned int,InOutEdgesAttr> > CarSim::Junction::inOutEdgesAttrMap
unsigned int CarSim::Junction::lastCarInEdge
unsigned int CarSim::Junction::lastCarOutEdge
std::map<unsigned int,JuncsEdge> CarSim::Junction::orderedEdges
unsigned int CarSim::Junction::partJuncCardinality
osg::Vec3 CarSim::Junction::position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Junction.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::PolygonPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • PolygonPoint
Public Attributes | List of all members
CarSim::PolygonPoint Struct Reference

#include <PolygonPoint.h>

Public Attributes

unsigned int | id
unsigned int | junctionId
osg::Vec3 | position

Member Data Documentation

unsigned int CarSim::PolygonPoint::id
unsigned int CarSim::PolygonPoint::junctionId
osg::Vec3 CarSim::PolygonPoint::position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/PolygonPoint.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::Remover Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Remover
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::Remover Class Reference

#include <Remover.h>

Inheritance diagram for CarSim::Remover:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Remover ()
~Remover ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | processEvent (const std::string &input_name, void *value)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (InCarToRemove, vrecko::MessageUnsignedInt)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::set< unsigned int > | carsToRemove
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Remover::Remover ( )
CarSim::Remover::~Remover ( )
inline

Member Function Documentation

CarSim::Remover::DECLARE_INPUT | ( | InCarToRemove | ,
 |  | vrecko::MessageUnsignedInt |
 | ) |  |
protected
void Remover::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void CarSim::Remover::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Remover::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

std::set<unsigned int> CarSim::Remover::carsToRemove
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Remover.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/Remover.cpp
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::RoadsEdges Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • RoadsEdges
Public Attributes | List of all members
CarSim::RoadsEdges Struct Reference

#include <RoadsEdges.h>

Public Attributes

unsigned int | forwardEdgeId
unsigned int | backEdgeId

Member Data Documentation

unsigned int CarSim::RoadsEdges::backEdgeId
unsigned int CarSim::RoadsEdges::forwardEdgeId
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsEdges.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::RoadsState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • RoadsState
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::RoadsState Class Reference

#include <RoadsState.h>

Inheritance diagram for CarSim::RoadsState:
vrecko::Ability vrecko::BaseClass

Public Member Functions

RoadsState ()
~RoadsState ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, void *value)
void * | processRequest (const std::string &input_name, void *value)
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | loadJuncPolyRoad (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode const *const pRoadNetNode)
void | loadJunction (XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes)
void | loadPolygonPoint (XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes)
void | loadRoad (XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes)
void | addEdgesAsEO ()
void | checkEdgesFromToAndTheirPolygonPoints ()
void | findShortestPath (std::vector< unsigned int > *const pResultPath, const StartStopDestination *const pStartStopDestination)
void | findPath (std::vector< unsigned int > *const pResultPath, const unsigned int startEdge)
void | getAbsPos (osg::Vec3 &resultPos, const unsigned int edge, const float offset)
void | computeEdgesAttributes ()
void | computeJunctionsEdges ()
void | interPointOfLineAndPerpendicularPlane (osg::Vec3 &inter, const osg::Vec3 &linePoint, const osg::Vec3 &lineVec, const osg::Vec3 &planePoint)
const float | distFromPointToLine (const osg::Vec3 &linePoint, const osg::Vec3 &lineVec, const osg::Vec3 &point)
void | herFerDeriv (osg::Vec3 &result, const float d, const osg::Vec3 &P1, const osg::Vec3 &P4, const osg::Vec3 &R1, const osg::Vec3 &R4)
bool | pointInHalfSpace (const osg::Vec3 &point, const osg::Vec3 &halfSpacePoint, const osg::Vec3 &halfSpaceVec)
void | getCarEdgeId (unsigned int &carEdgeId, const unsigned int lastCarEdgeId, const osg::Vec3 &bottomCarPosition, const unsigned int juncId, const unsigned int outEdgeId)
void | distPointToPlane (float &dist, const osg::Vec3 &point, const osg::Vec3 &planePoint, const osg::Vec3 &planeNormal)
void | linesInter2D (osg::Vec2 &result, const osg::Vec2 &line1Point, const osg::Vec2 &line1Vec, const osg::Vec2 &line2Point, const osg::Vec2 &line2Vec)
void | findJuncsSinglePolyPoints ()
void | addTerminatorEdges (unsigned int fstSinglePolyPoint, unsigned int sndSinglePolyPoint, unsigned int fstEdgeId, unsigned int sndEdgeId, const unsigned int juncId)
void | mergeCloseJunctions ()
void | addEdgeAsEO (const unsigned int edgeId)
void | orderJunctionsEdges ()
void | computeJuncInOutEdgesAttr ()
void | unregCarForEdge (const unsigned int carId, const unsigned int edgeId)
void | unregLastCarForEdge (const unsigned int edgeId)
bool | regCarForEdge (const unsigned int carId, const unsigned int startEdgeId, const float startOffset, const float carLength, const bool showErrors)
void | regFstCarForEdge (const unsigned int carId, const unsigned int edgeId, const float offset, const float carLength, const float vel)
bool | isCarRegForEdge (const unsigned int carId, const unsigned int edgeId)
void | updateCarForEdge (const unsigned int carId, const unsigned int edgeId, const float headOffset, const float rearOffset, const float vel)
void | getNextCarDistAndVel (float &nextCarDist, float &nextCarVel, const unsigned int carId, const unsigned int edgeId)
bool | isCarStopPositionRight (const unsigned int stopEdgeId, const float stopOffset, const float carLength)
bool | isFreeSpaceForCarGroupOnEdge (const unsigned int edgeId, const float fstCarInGroupLength, unsigned int carCount)
bool | lockJuncsEdgesForNewCar (const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const bool isLastCar, const bool isStopedCar, const float carLength, const unsigned int carId)
void | regIncomingCarToShortEdges (const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const unsigned int carId)
void | setStopedIncomingCarToShortEdges (const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const unsigned int carId)
bool | rightHandRule (bool &withDeadlock, const unsigned int inEdge, const unsigned int outEdge, const unsigned int juncId, const bool isCarLastStoped, const unsigned int carId)
void | decreaseLockCountForPrevEdge (const unsigned int edgeId, const unsigned int lastJuncId, const unsigned int nextJuncId, const unsigned int nextNextJuncId, const bool mergedEdgeSkiped, const unsigned int carId)
void | computeRecVelocityOnJunc (float &recVel, const unsigned int juncId, const unsigned int inEdge, const unsigned int outEdge)
void | getTurnOnJunc (unsigned int &turnOnJunc, const unsigned int juncId, const unsigned int inEdge, const unsigned int outEdge)
void | generateCars (const unsigned int numOfGenCars, const bool genShortestPath)
void | showPoint (const osg::Vec3 &point)
bool | isDeadlock (const unsigned int juncId)
void | loadTLparameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *const pTLparametersNode)
void | createTrafficLights (void)
bool | isValidJuncWithTLs (unsigned int juncId)
DECLARE_INPUT (InUnregCarForEdge, MessageCarEdge)
DECLARE_INPUT (InAddForEdgeRegisteredCarToPutAsideCars, MessageCarEdge)
DECLARE_REQUEST_INPUT (InGetReady, MessageVoid, MessageBool)
DECLARE_REQUEST_INPUT (InGetDataPath, MessageVoid, MessageString)
DECLARE_REQUEST_INPUT (InGetEdgeAbsPos, MessageEdgeOffset, MessageVec3)
DECLARE_REQUEST_INPUT (InGetEdgeOutInVec, MessageUnsignedInt, MessageVec3)
DECLARE_REQUEST_INPUT (InGetEdgeNormal, MessageUnsignedInt, MessageVec3)
DECLARE_REQUEST_INPUT (InFindShortestPath, MessageStartStopDestination, MessageVectorUnsignedInt)
DECLARE_REQUEST_INPUT (InCheckCarStopPosition, MessageCarEdgeData, MessageBool)
DECLARE_REQUEST_INPUT (InGetStartOrStopEdgeFromRoadAndDirection, MessageRoadAndDir, MessageUnsignedInt)
DECLARE_REQUEST_INPUT (InRegCarForEdge, MessageCarEdgeData, MessageBool)
DECLARE_REQUEST_INPUT (InGetRecVelOnJunc, MessageFirst3Juncs, MessageFloat)
DECLARE_REQUEST_INPUT (InGetTurnOnJunc, MessageFirst3Juncs, MessageUnsignedInt)
DECLARE_REQUEST_INPUT (InIsCarFstPutAsideOnEdge, MessageCarEdge, MessageBool)
DECLARE_REQUEST_INPUT (InRegisterPutAsideCarForEdge, MessageCarEdgeData, MessageBool)
DECLARE_REQUEST_INPUT (InGetCarEnvirons, MessageCarSimParameters, MessageCarEnvirons)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::string | dataPath
bool | invalidRefToJuncOrPolygPoint
std::map< unsigned int,
std::map< unsigned int,
unsigned int > > 		roads
std::map< unsigned int, Junction > | junctions
unsigned int | maxJuncId
unsigned int | maxPolygonPointId
std::map< unsigned int,
PolygonPoint > 		polygonPoints
std::vector< Edge > | edges
unsigned int | numOfNonTermEdges
std::map< unsigned int,
RoadsEdges > 		roadsEdges
Ability * pRemover
Ability * pCarPartsNodeCache
osg::Node * | pTLcolumnModel
osg::Node * | pTLorangeModel
float | tlColorsCenterDist
bool | bDrawRoads
int | iNumGenCars
bool | bGenShortestPaths
bool | bAttemptToLoadRoadsFromArtificalWorld
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

XERCES_CPP_NAMESPACE_USE RoadsState::RoadsState ( )
CarSim::RoadsState::~RoadsState ( )
inline

Member Function Documentation

void RoadsState::addEdgeAsEO ( const unsigned int edgeId )
protected
void RoadsState::addEdgesAsEO ( )
protected
void RoadsState::addTerminatorEdges | ( | unsigned int | fstSinglePolyPoint,
 |  | unsigned int | sndSinglePolyPoint,
 |  | unsigned int | fstEdgeId,
 |  | unsigned int | sndEdgeId,
 |  | const unsigned int | juncId
 | ) |  |
protected
void RoadsState::checkEdgesFromToAndTheirPolygonPoints ( )
protected
void RoadsState::computeEdgesAttributes ( )
protected
void RoadsState::computeJuncInOutEdgesAttr ( )
protected
void RoadsState::computeJunctionsEdges ( )
protected
void RoadsState::computeRecVelocityOnJunc | ( | float & | recVel,
 |  | const unsigned int | juncId,
 |  | const unsigned int | inEdge,
 |  | const unsigned int | outEdge
 | ) |  |
protected
void RoadsState::createTrafficLights ( void )
protected
CarSim::RoadsState::DECLARE_INPUT | ( | InUnregCarForEdge | ,
 |  | MessageCarEdge |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_INPUT | ( | InAddForEdgeRegisteredCarToPutAsideCars | ,
 |  | MessageCarEdge |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetReady | ,
 |  | MessageVoid | ,
 |  | MessageBool |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetDataPath | ,
 |  | MessageVoid | ,
 |  | MessageString |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetEdgeAbsPos | ,
 |  | MessageEdgeOffset | ,
 |  | MessageVec3 |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetEdgeOutInVec | ,
 |  | MessageUnsignedInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetEdgeNormal | ,
 |  | MessageUnsignedInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InFindShortestPath | ,
 |  | MessageStartStopDestination | ,
 |  | MessageVectorUnsignedInt |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InCheckCarStopPosition | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetStartOrStopEdgeFromRoadAndDirection | ,
 |  | MessageRoadAndDir | ,
 |  | MessageUnsignedInt |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InRegCarForEdge | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetRecVelOnJunc | ,
 |  | MessageFirst3Juncs | ,
 |  | MessageFloat |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetTurnOnJunc | ,
 |  | MessageFirst3Juncs | ,
 |  | MessageUnsignedInt |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InIsCarFstPutAsideOnEdge | ,
 |  | MessageCarEdge | ,
 |  | MessageBool |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InRegisterPutAsideCarForEdge | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool |
 | ) |  |
protected
CarSim::RoadsState::DECLARE_REQUEST_INPUT | ( | InGetCarEnvirons | ,
 |  | MessageCarSimParameters | ,
 |  | MessageCarEnvirons |
 | ) |  |
protected
void RoadsState::decreaseLockCountForPrevEdge | ( | const unsigned int | edgeId,
 |  | const unsigned int | lastJuncId,
 |  | const unsigned int | nextJuncId,
 |  | const unsigned int | nextNextJuncId,
 |  | const bool | mergedEdgeSkiped,
 |  | const unsigned int | carId
 | ) |  |
protected
const float RoadsState::distFromPointToLine | ( | const osg::Vec3 & | linePoint,
 |  | const osg::Vec3 & | lineVec,
 |  | const osg::Vec3 & | point
 | ) |  |
protected
void RoadsState::distPointToPlane | ( | float & | dist,
 |  | const osg::Vec3 & | point,
 |  | const osg::Vec3 & | planePoint,
 |  | const osg::Vec3 & | planeNormal
 | ) |  |
protected
void RoadsState::findJuncsSinglePolyPoints ( )
protected
void RoadsState::findPath | ( | std::vector< unsigned int > *const | pResultPath,
 |  | const unsigned int | startEdge
 | ) |  |
protected
void RoadsState::findShortestPath | ( | std::vector< unsigned int > *const | pResultPath,
 |  | const StartStopDestination *const | pStartStopDestination
 | ) |  |
protected
void RoadsState::generateCars | ( | const unsigned int | numOfGenCars,
 |  | const bool | genShortestPath
 | ) |  |
protected
void RoadsState::getAbsPos | ( | osg::Vec3 & | resultPos,
 |  | const unsigned int | edge,
 |  | const float | offset
 | ) |  |
protected
void RoadsState::getCarEdgeId | ( | unsigned int & | carEdgeId,
 |  | const unsigned int | lastCarEdgeId,
 |  | const osg::Vec3 & | bottomCarPosition,
 |  | const unsigned int | juncId,
 |  | const unsigned int | outEdgeId
 | ) |  |
protected
void RoadsState::getNextCarDistAndVel | ( | float & | nextCarDist,
 |  | float & | nextCarVel,
 |  | const unsigned int | carId,
 |  | const unsigned int | edgeId
 | ) |  |
protected
void RoadsState::getTurnOnJunc | ( | unsigned int & | turnOnJunc,
 |  | const unsigned int | juncId,
 |  | const unsigned int | inEdge,
 |  | const unsigned int | outEdge
 | ) |  |
protected
void RoadsState::herFerDeriv | ( | osg::Vec3 & | result,
 |  | const float | d,
 |  | const osg::Vec3 & | P1,
 |  | const osg::Vec3 & | P4,
 |  | const osg::Vec3 & | R1,
 |  | const osg::Vec3 & | R4
 | ) |  |
protected
void RoadsState::interPointOfLineAndPerpendicularPlane | ( | osg::Vec3 & | inter,
 |  | const osg::Vec3 & | linePoint,
 |  | const osg::Vec3 & | lineVec,
 |  | const osg::Vec3 & | planePoint
 | ) |  |
protected
bool RoadsState::isCarRegForEdge | ( | const unsigned int | carId,
 |  | const unsigned int | edgeId
 | ) |  |
protected
bool RoadsState::isCarStopPositionRight | ( | const unsigned int | stopEdgeId,
 |  | const float | stopOffset,
 |  | const float | carLength
 | ) |  |
protected
bool RoadsState::isDeadlock ( const unsigned int juncId )
protected
bool RoadsState::isFreeSpaceForCarGroupOnEdge | ( | const unsigned int | edgeId,
 |  | const float | fstCarInGroupLength,
 |  | unsigned int | carCount
 | ) |  |
protected
bool RoadsState::isValidJuncWithTLs ( unsigned int juncId )
protected
void RoadsState::linesInter2D | ( | osg::Vec2 & | result,
 |  | const osg::Vec2 & | line1Point,
 |  | const osg::Vec2 & | line1Vec,
 |  | const osg::Vec2 & | line2Point,
 |  | const osg::Vec2 & | line2Vec
 | ) |  |
protected
void RoadsState::loadJuncPolyRoad ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode const *const pRoadNetNode )
protected
void RoadsState::loadJunction ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes )
protected
void RoadsState::loadPolygonPoint ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes )
protected
void RoadsState::loadRoad ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes )
protected
void RoadsState::loadTLparameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *const pTLparametersNode )
protected
bool RoadsState::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

bool RoadsState::lockJuncsEdgesForNewCar | ( | const std::vector< unsigned int > *const | pPath,
 |  | const unsigned int | lastJuncInPath,
 |  | const bool | isLastCar,
 |  | const bool | isStopedCar,
 |  | const float | carLength,
 |  | const unsigned int | carId
 | ) |  |
protected
void RoadsState::mergeCloseJunctions ( )
protected
void RoadsState::orderJunctionsEdges ( )
protected
bool RoadsState::pointInHalfSpace | ( | const osg::Vec3 & | point,
 |  | const osg::Vec3 & | halfSpacePoint,
 |  | const osg::Vec3 & | halfSpaceVec
 | ) |  |
protected
void RoadsState::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void CarSim::RoadsState::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void* CarSim::RoadsState::processRequest | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
bool RoadsState::regCarForEdge | ( | const unsigned int | carId,
 |  | const unsigned int | startEdgeId,
 |  | const float | startOffset,
 |  | const float | carLength,
 |  | const bool | showErrors
 | ) |  |
protected
void RoadsState::regFstCarForEdge | ( | const unsigned int | carId,
 |  | const unsigned int | edgeId,
 |  | const float | offset,
 |  | const float | carLength,
 |  | const float | vel
 | ) |  |
protected
void RoadsState::regIncomingCarToShortEdges | ( | const std::vector< unsigned int > *const | pPath,
 |  | const unsigned int | lastJuncInPath,
 |  | const unsigned int | carId
 | ) |  |
protected
bool RoadsState::rightHandRule | ( | bool & | withDeadlock,
 |  | const unsigned int | inEdge,
 |  | const unsigned int | outEdge,
 |  | const unsigned int | juncId,
 |  | const bool | isCarLastStoped,
 |  | const unsigned int | carId
 | ) |  |
protected
void RoadsState::setStopedIncomingCarToShortEdges | ( | const std::vector< unsigned int > *const | pPath,
 |  | const unsigned int | lastJuncInPath,
 |  | const unsigned int | carId
 | ) |  |
protected
void RoadsState::showPoint ( const osg::Vec3 & point )
protected
void RoadsState::unregCarForEdge | ( | const unsigned int | carId,
 |  | const unsigned int | edgeId
 | ) |  |
protected
void RoadsState::unregLastCarForEdge ( const unsigned int edgeId )
protected
void RoadsState::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

void RoadsState::updateCarForEdge | ( | const unsigned int | carId,
 |  | const unsigned int | edgeId,
 |  | const float | headOffset,
 |  | const float | rearOffset,
 |  | const float | vel
 | ) |  |
protected

Member Data Documentation

bool CarSim::RoadsState::bAttemptToLoadRoadsFromArtificalWorld
protected
bool CarSim::RoadsState::bDrawRoads
protected
bool CarSim::RoadsState::bGenShortestPaths
protected
std::string CarSim::RoadsState::dataPath
protected
std::vector<Edge> CarSim::RoadsState::edges
protected
int CarSim::RoadsState::iNumGenCars
protected
bool CarSim::RoadsState::invalidRefToJuncOrPolygPoint
protected
std::map<unsigned int,Junction> CarSim::RoadsState::junctions
protected
unsigned int CarSim::RoadsState::maxJuncId
protected
unsigned int CarSim::RoadsState::maxPolygonPointId
protected
unsigned int CarSim::RoadsState::numOfNonTermEdges
protected
Ability* CarSim::RoadsState::pCarPartsNodeCache
protected
std::map<unsigned int,PolygonPoint> CarSim::RoadsState::polygonPoints
protected
Ability* CarSim::RoadsState::pRemover
protected
osg::Node* CarSim::RoadsState::pTLcolumnModel
protected
osg::Node* CarSim::RoadsState::pTLorangeModel
protected
std::map<unsigned int, std::map<unsigned int,unsigned int> > CarSim::RoadsState::roads
protected
std::map<unsigned int,RoadsEdges> CarSim::RoadsState::roadsEdges
protected
float CarSim::RoadsState::tlColorsCenterDist
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsState.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/RoadsState.cpp
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::TLcolorsMT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • TLcolorsMT
Public Attributes | List of all members
CarSim::TLcolorsMT Struct Reference

#include <TLsOnJuncManager.h>

Public Attributes

osg::ref_ptr
< osg::MatrixTransform > 		pRedMT
osg::ref_ptr
< osg::MatrixTransform > 		pOrangeMT
osg::ref_ptr
< osg::MatrixTransform > 		pGreenMT

Member Data Documentation

osg::ref_ptr<osg::MatrixTransform> CarSim::TLcolorsMT::pGreenMT
osg::ref_ptr<osg::MatrixTransform> CarSim::TLcolorsMT::pOrangeMT
osg::ref_ptr<osg::MatrixTransform> CarSim::TLcolorsMT::pRedMT
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/TLsOnJuncManager.h
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: CarSim::TLsOnJuncManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • TLsOnJuncManager
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
CarSim::TLsOnJuncManager Class Reference

#include <TLsOnJuncManager.h>

Inheritance diagram for CarSim::TLsOnJuncManager:
vrecko::Ability vrecko::BaseClass

Public Member Functions

TLsOnJuncManager ()
TLsOnJuncManager (std::vector< TLcolorsMT > *const pTLcolorsMTvec, const std::vector< unsigned int *const > *const pTLcolorsVec, const std::vector< unsigned int > *const pTLgreenIntervVec)
~TLsOnJuncManager ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | initColorsOnTLs (void)
void | switchColorsOnTL (void)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector< TLcolorsMT > *const | pTLcolorsMTvec
const std::vector< unsigned
int *const > *const 		pTLcolorsVec
const std::vector< unsigned
int > *const 		pTLgreenIntervVec
unsigned int | tlIndex
unsigned int | secCount
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

TLsOnJuncManager::TLsOnJuncManager ( )
TLsOnJuncManager::TLsOnJuncManager | ( | std::vector< TLcolorsMT > *const | pTLcolorsMTvec,
 |  | const std::vector< unsigned int *const > *const | pTLcolorsVec,
 |  | const std::vector< unsigned int > *const | pTLgreenIntervVec
 | ) |  |
TLsOnJuncManager::~TLsOnJuncManager ( )

Member Function Documentation

void TLsOnJuncManager::initColorsOnTLs ( void )
protected
void TLsOnJuncManager::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void TLsOnJuncManager::switchColorsOnTL ( void )
protected
void TLsOnJuncManager::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

std::vector<TLcolorsMT>* const CarSim::TLsOnJuncManager::pTLcolorsMTvec
protected
const std::vector<unsigned int*const>* const CarSim::TLsOnJuncManager::pTLcolorsVec
protected
const std::vector<unsigned int>* const CarSim::TLsOnJuncManager::pTLgreenIntervVec
protected
unsigned int CarSim::TLsOnJuncManager::secCount
protected
unsigned int CarSim::TLsOnJuncManager::tlIndex
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/TLsOnJuncManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/TLsOnJuncManager.cpp
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Filter::Linear Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • Linear
Public Member Functions | Protected Attributes | List of all members
Filter::Linear Class Reference

#include <Linear.h>

Inheritance diagram for Filter::Linear:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Linear ()
~Linear ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, void *value)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

float | coef1
osg::Vec2 | coef2
osg::Vec3 | coef3
osg::Vec4 | coef4
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

Filter::Linear::Linear ( )
Filter::Linear::~Linear ( )
inline

Member Function Documentation

bool Filter::Linear::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Filter::Linear::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Filter::Linear::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* Filter::Linear::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

Member Data Documentation

float Filter::Linear::coef1
protected
osg::Vec2 Filter::Linear::coef2
protected
osg::Vec3 Filter::Linear::coef3
protected
osg::Vec4 Filter::Linear::coef4
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/Linear.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Filter::PosNoiseRemover Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • PosNoiseRemover
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
Filter::PosNoiseRemover Class Reference

#include <PosNoiseRemover.h>

Inheritance diagram for Filter::PosNoiseRemover:
vrecko::Ability vrecko::BaseClass

Classes

struct SAMPLE

Public Member Functions

PosNoiseRemover ()
~PosNoiseRemover ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, void *value)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (In3, vrecko::MessageVec3)
DECLARE_OUTPUT (Out3, vrecko::MessageVec3)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

DynamicArray< SAMPLE > pastSamples
bool | bOn
osg::Vec3 | lastInput
osg::Vec3 | lastResult
int | iCorrectedSamplesCounter
float | fTolerance
int | iMaxPastSamples
int | iMaxCorrectedSamplesInRow
bool | bCompareExtrapolatedValue
bool | bExtrapolateCorrectValue
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Filter::PosNoiseRemover::PosNoiseRemover ( )
Filter::PosNoiseRemover::~PosNoiseRemover ( )
inline

Member Function Documentation

Filter::PosNoiseRemover::DECLARE_INPUT | ( | In3 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
Filter::PosNoiseRemover::DECLARE_OUTPUT | ( | Out3 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
bool Filter::PosNoiseRemover::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Filter::PosNoiseRemover::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Filter::PosNoiseRemover::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* Filter::PosNoiseRemover::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool Filter::PosNoiseRemover::bCompareExtrapolatedValue
protected
bool Filter::PosNoiseRemover::bExtrapolateCorrectValue
protected
bool Filter::PosNoiseRemover::bOn
protected
float Filter::PosNoiseRemover::fTolerance
protected
int Filter::PosNoiseRemover::iCorrectedSamplesCounter
protected
int Filter::PosNoiseRemover::iMaxCorrectedSamplesInRow
protected
int Filter::PosNoiseRemover::iMaxPastSamples
protected
osg::Vec3 Filter::PosNoiseRemover::lastInput
protected
osg::Vec3 Filter::PosNoiseRemover::lastResult
protected
DynamicArray<SAMPLE> Filter::PosNoiseRemover::pastSamples
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/PosNoiseRemover.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Filter::PosNoiseRemover::SAMPLE Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • PosNoiseRemover
  • SAMPLE
Public Attributes | List of all members
Filter::PosNoiseRemover::SAMPLE Struct Reference

#include <PosNoiseRemover.h>

Public Attributes

osg::Vec3 | vec
osg::Timer_t | time

Member Data Documentation

osg::Timer_t Filter::PosNoiseRemover::SAMPLE::time
osg::Vec3 Filter::PosNoiseRemover::SAMPLE::vec
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/PosNoiseRemover.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::Grass Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Grass
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
grass::Grass Class Reference

#include <grass.h>

Inheritance diagram for grass::Grass:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Grass ()
virtual | ~Grass ()
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *d)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | CoatWithGrass (Group *pGroup)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

ref_ptr< GrassAbilityParameters > | params
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

grass::Grass::Grass ( )
inline
virtual grass::Grass::~Grass ( )
inlinevirtual

Member Function Documentation

void grass::Grass::CoatWithGrass ( Group * pGroup )
protected
bool grass::Grass::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void grass::Grass::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* grass::Grass::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
inlinevirtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void grass::Grass::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

ref_ptr<GrassAbilityParameters> grass::Grass::params
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::GrassCullCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassCullCallback
List of all members
grass::GrassCullCallback Class Reference

#include <grass_cullcallback.h>

Inheritance diagram for grass::GrassCullCallback:
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_cullcallback.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::GrassDrawable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassDrawable
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
grass::GrassDrawable Class Reference

#include <grass_drawable.h>

Inheritance diagram for grass::GrassDrawable:

Public Types

enum ROLE { TOP_LEVEL, INTERMEDIATE, DETAILED }

Public Member Functions

GrassDrawable (Geode &g, GrassAbilityParameters *parameters)
GrassDrawable (Mesh *newMesh, GrassAbilityParameters *parameters)
virtual | ~GrassDrawable ()
GrassDrawable (const GrassDrawable &gd, const CopyOp &copyop=CopyOp::SHALLOW_COPY)
virtual Object * | cloneType () const
virtual Object * | clone (const CopyOp &copyop) const
virtual bool | isSameKindAs (const Object *obj) const
virtual const char * | libraryName () const
virtual const char * | className () const
virtual void | drawImplementation (RenderInfo &renderInfo) const
void | ManageCulling (osgUtil::CullVisitor *cv, RenderInfo *renderInfo)

Protected Member Functions

void | PrepareDisplayList (osg::RenderInfo &renderInfo) const
void | EnsureDetailedVersionIsReady ()

Protected Attributes

float | LOD
float | distanceFromEye
bool | displayListValid
ref_ptr< GrassAbilityParameters > | params
ROLE role
std::vector< ref_ptr
< GrassDrawable > > 		moreDetailedVersion
GLuint | grassDisplayList
ref_ptr< Mesh > | mesh

Member Enumeration Documentation

enum grass::GrassDrawable::ROLE
Enumerator
TOP_LEVEL
INTERMEDIATE
DETAILED

Constructor & Destructor Documentation

grass::GrassDrawable::GrassDrawable | ( | Geode & | g,
 |  | GrassAbilityParameters * | parameters
 | ) |  |
grass::GrassDrawable::GrassDrawable | ( | Mesh * | newMesh,
 |  | GrassAbilityParameters * | parameters
 | ) |  |
grass::GrassDrawable::~GrassDrawable ( )
virtual
grass::GrassDrawable::GrassDrawable | ( | const GrassDrawable & | gd,
 |  | const CopyOp & | copyop = CopyOp::SHALLOW_COPY
 | ) |  |

Member Function Documentation

virtual const char* grass::GrassDrawable::className ( ) const
inlinevirtual
virtual Object* grass::GrassDrawable::clone ( const CopyOp & copyop ) const
inlinevirtual
virtual Object* grass::GrassDrawable::cloneType ( ) const
inlinevirtual
void grass::GrassDrawable::drawImplementation ( RenderInfo & renderInfo ) const
virtual
void grass::GrassDrawable::EnsureDetailedVersionIsReady ( )
protected
virtual bool grass::GrassDrawable::isSameKindAs ( const Object * obj ) const
inlinevirtual
virtual const char* grass::GrassDrawable::libraryName ( ) const
inlinevirtual
void grass::GrassDrawable::ManageCulling | ( | osgUtil::CullVisitor * | cv,
 |  | RenderInfo * | renderInfo
 | ) |  |
void grass::GrassDrawable::PrepareDisplayList ( osg::RenderInfo & renderInfo ) const
protected

Member Data Documentation

bool grass::GrassDrawable::displayListValid
mutableprotected
float grass::GrassDrawable::distanceFromEye
protected
GLuint grass::GrassDrawable::grassDisplayList
mutableprotected
float grass::GrassDrawable::LOD
protected
ref_ptr<Mesh> grass::GrassDrawable::mesh
protected
std::vector<ref_ptr<GrassDrawable> > grass::GrassDrawable::moreDetailedVersion
protected
ref_ptr<GrassAbilityParameters> grass::GrassDrawable::params
protected
ROLE grass::GrassDrawable::role
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_drawable.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_drawable.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::Vertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Vertex
Public Member Functions | Public Attributes | List of all members
grass::Vertex Struct Reference

#include <grass_mesh.h>

Public Member Functions

Vertex ()
Vertex (Vec3 nPosition)
Vertex (Vec3 nPosition, Vec3 nNormal)
void IsAverageOf (const Vertex &a, const Vertex &b)

Public Attributes

Vec3 | position
Vec3 | normal

Constructor & Destructor Documentation

grass::Vertex::Vertex ( )
inline
grass::Vertex::Vertex ( Vec3 nPosition )
inline
grass::Vertex::Vertex | ( | Vec3 | nPosition,
 |  | Vec3 | nNormal
 | ) |  |
inline

Member Function Documentation

void grass::Vertex::IsAverageOf | ( | const Vertex & | a,
 |  | const Vertex & | b
 | ) |  |
inline

Member Data Documentation

Vec3 grass::Vertex::normal
Vec3 grass::Vertex::position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_mesh.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::Triangle Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Triangle
Public Member Functions | Public Attributes | List of all members
grass::Triangle Struct Reference

#include <grass_mesh.h>

Public Member Functions

Triangle ()
Triangle (Vertex *nA, Vertex *nB, Vertex *nC)
Vertex GetRandomPoint () const

Public Attributes

Vertex * A
Vertex * B
Vertex * C
float | area
Vec3 | center

Constructor & Destructor Documentation

grass::Triangle::Triangle ( )
inline
grass::Triangle::Triangle | ( | Vertex * | nA,
 |  | Vertex * | nB,
 |  | Vertex * | nC
 | ) |  |
inline

Member Function Documentation

Vertex grass::Triangle::GetRandomPoint ( ) const
inline

Member Data Documentation

Vertex* grass::Triangle::A
float grass::Triangle::area
Vertex * grass::Triangle::B
Vertex * grass::Triangle::C
Vec3 grass::Triangle::center
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_mesh.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::Mesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Mesh
Public Member Functions | Public Attributes | Friends | List of all members
grass::Mesh Class Reference

#include <grass_mesh.h>

Inheritance diagram for grass::Mesh:

Public Member Functions

Mesh (const float nMaxGrassHeight)
virtual | ~Mesh ()
BoundingBox | GetBound () const
std::vector< Mesh * > | Divide () const

Public Attributes

std::vector< Triangle * > triangles

Friends

class TriangleCollector

Constructor & Destructor Documentation

grass::Mesh::Mesh ( const float nMaxGrassHeight )
inline
virtual grass::Mesh::~Mesh ( )
inlinevirtual

Member Function Documentation

std::vector< Mesh * > grass::Mesh::Divide ( ) const
BoundingBox grass::Mesh::GetBound ( ) const
inline

Friends And Related Function Documentation

friend class TriangleCollector
friend

Member Data Documentation

std::vector<Triangle*> grass::Mesh::triangles
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_mesh.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_mesh.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::GrassAbilityParameters Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassAbilityParameters
Public Member Functions | Public Attributes | List of all members
grass::GrassAbilityParameters Struct Reference

#include <grass_parameters.h>

Inheritance diagram for grass::GrassAbilityParameters:

Public Member Functions

void | EnsureGrassBladesArePrepared ()
virtual | ~GrassAbilityParameters ()
void | Init ()
GrassAbilityParameters ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Public Attributes

float | density
float | minHeight
float | maxHeight
float | minWidth
float | maxWidth
float | minBend
float | maxBend
int | minFractions
int | maxFractions
float | maxArea
float | maxVisibility
float | minVisibility
float | maxLODdifference
float | invVisibilityRange
float | visibilityRange
std::vector< GLuint > | grassBlades
osg::ref_ptr< osg::StateSet > | lowDetailGrassStateSet
osg::ref_ptr< osg::StateSet > | detailedGrassStateSet
osg::Vec4 | neutralColor
osg::ref_ptr< GrassCullCallback > | grassCullCallback

Constructor & Destructor Documentation

virtual grass::GrassAbilityParameters::~GrassAbilityParameters ( )
inlinevirtual
grass::GrassAbilityParameters::GrassAbilityParameters ( )

Member Function Documentation

void grass::GrassAbilityParameters::EnsureGrassBladesArePrepared ( )
inline
void grass::GrassAbilityParameters::Init ( )
bool grass::GrassAbilityParameters::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * grass::GrassAbilityParameters::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )

Member Data Documentation

float grass::GrassAbilityParameters::density
osg::ref_ptr<osg::StateSet> grass::GrassAbilityParameters::detailedGrassStateSet
std::vector<GLuint> grass::GrassAbilityParameters::grassBlades
osg::ref_ptr<GrassCullCallback> grass::GrassAbilityParameters::grassCullCallback
float grass::GrassAbilityParameters::invVisibilityRange
osg::ref_ptr<osg::StateSet> grass::GrassAbilityParameters::lowDetailGrassStateSet
float grass::GrassAbilityParameters::maxArea
float grass::GrassAbilityParameters::maxBend
int grass::GrassAbilityParameters::maxFractions
float grass::GrassAbilityParameters::maxHeight
float grass::GrassAbilityParameters::maxLODdifference
float grass::GrassAbilityParameters::maxVisibility
float grass::GrassAbilityParameters::maxWidth
float grass::GrassAbilityParameters::minBend
int grass::GrassAbilityParameters::minFractions
float grass::GrassAbilityParameters::minHeight
float grass::GrassAbilityParameters::minVisibility
float grass::GrassAbilityParameters::minWidth
osg::Vec4 grass::GrassAbilityParameters::neutralColor
float grass::GrassAbilityParameters::visibilityRange
The documentation for this struct was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_parameters.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_parameters.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: grass::TriangleCollector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • TriangleCollector
Public Member Functions | Static Public Member Functions | List of all members
grass::TriangleCollector Class Reference

#include <grass_triangle_collector.h>

Public Member Functions

void operator() (const osg::Vec3 v1, const osg::Vec3 v2, const osg::Vec3 v3, bool treatVertexDataAsTemporary)

Static Public Member Functions

static Mesh * GetMesh (const Geode &geode, const float maxGrassHeight)

Member Function Documentation

Mesh * grass::TriangleCollector::GetMesh | ( | const Geode & | geode,
 |  | const float | maxGrassHeight
 | ) |  |
static
void grass::TriangleCollector::operator() | ( | const osg::Vec3 | v1,
 |  | const osg::Vec3 | v2,
 |  | const osg::Vec3 | v3,
 |  | bool | treatVertexDataAsTemporary
 | ) |  |
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_triangle_collector.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_triangle_collector.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::HeadTracking Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • HeadTracking
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ht::HeadTracking Class Reference

#include <HeadTracking.h>

Inheritance diagram for ht::HeadTracking:
vrecko::Ability vrecko::BaseClass

Public Member Functions

HeadTracking ()
virtual | ~HeadTracking ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual void | update ()
This method is called periodically in case this instance is registered in Scheduler. More...
DECLARE_INPUT (Transformation, vrecko::MessageSensorTransformation)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (MoveAvatar, vrecko::MessageVec3)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

float | unit
ht::Screen screen
osg::Vec3 | s_corner
osg::Vec3 | s_width
osg::Vec3 | s_height
osg::Vec3 | head_pos
osg::Quat | head_orientation
int | head_sensor_number
osg::Vec3 | left_eye_off
osg::Vec3 | right_eye_off
float | optitrack_scale
osg::Vec3 | optitrack_origin_position
osg::Vec3 | optitrack_translate_mapping
float | head_tracking_scale
osg::Vec3 | head_tracking_origin_position
osg::Vec3 | head_tracking_translate_mapping
osg::Vec4 | last_avatar_pos
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ht::HeadTracking::HeadTracking ( )
ht::HeadTracking::~HeadTracking ( )
virtual

Member Function Documentation

ht::HeadTracking::DECLARE_INPUT | ( | Transformation | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
ht::HeadTracking::DECLARE_OUTPUT | ( | MoveAvatar | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
bool ht::HeadTracking::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void ht::HeadTracking::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Quat ht::HeadTracking::head_orientation
protected
osg::Vec3 ht::HeadTracking::head_pos
protected
int ht::HeadTracking::head_sensor_number
protected
osg::Vec3 ht::HeadTracking::head_tracking_origin_position
protected
float ht::HeadTracking::head_tracking_scale
protected
osg::Vec3 ht::HeadTracking::head_tracking_translate_mapping
protected
osg::Vec4 ht::HeadTracking::last_avatar_pos
protected
osg::Vec3 ht::HeadTracking::left_eye_off
protected
osg::Vec3 ht::HeadTracking::optitrack_origin_position
protected
float ht::HeadTracking::optitrack_scale
protected
osg::Vec3 ht::HeadTracking::optitrack_translate_mapping
protected
osg::Vec3 ht::HeadTracking::right_eye_off
protected
osg::Vec3 ht::HeadTracking::s_corner
protected
osg::Vec3 ht::HeadTracking::s_height
protected
osg::Vec3 ht::HeadTracking::s_width
protected
ht::Screen ht::HeadTracking::screen
protected
float ht::HeadTracking::unit
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/HeadTracking.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/HeadTracking.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::Screen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Screen
Public Member Functions | List of all members
ht::Screen Class Reference

Defines position of screen in real world. More...

#include <htUtils.h>

Public Member Functions

Screen ()
void | SetScreen (osg::Vec3 corner, osg::Vec3 width, osg::Vec3 height)
const osg::Matrix & | GetMatrix () const
Returns screen matrix. More...
const osg::Matrix & | GetMatrixInv () const
bool | IsValid () const
Returns true if screen is valid (width and height are not zero) More...

Detailed Description

Defines position of screen in real world.

Constructor & Destructor Documentation

ht::Screen::Screen ( )

Member Function Documentation

const osg::Matrix& ht::Screen::GetMatrix ( ) const
inline

Returns screen matrix.

Returns position of the screen in real world

Parameters
corner | - position of bottom left corner of the screen in real world coordinate system
width | - left-to-right direction of screen in real world coordinate system, size of this vector defines width of the screen
height | - bottom-to-top direction of screen in real world coordinate system, size of this vector defines height of the screen
Returns
Returns true is the screen is valid, false if not (nothing may be returned)
const osg::Matrix& ht::Screen::GetMatrixInv ( ) const
inline

Returns inverse of the screen matrix Use preMult(Vec4) to get virtual coordinate from real world coordinate

bool ht::Screen::IsValid ( ) const
inline

Returns true if screen is valid (width and height are not zero)

void ht::Screen::SetScreen | ( | osg::Vec3 | corner,
 |  | osg::Vec3 | width,
 |  | osg::Vec3 | height
 | ) |  |

Sets position of the screen in real world Width and height should be perpendicular. Z axis is chosen so that z = cross(width, height) holds true

Parameters
corner | - position of bottom left corner of the screen in real world coordinate system
width | - left-to-right direction of screen in real world coordinate system, size of this vector defines width of the screen
height | - bottom-to-top direction of screen in real world coordinate system, size of this vector defines height of the screen
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/htUtils.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/htUtils.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::ScreenSetup Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetup
Classes | Public Types | Public Member Functions | Protected Member Functions | List of all members
ht::ScreenSetup Class Reference

#include <ScreenSetup.h>

Inheritance diagram for ht::ScreenSetup:
vrecko::Ability vrecko::BaseClass

Classes

struct ScreenSetupState

Public Types

enum Corner { LeftBottom, RightBottom, LeftTop, RightTop }
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

ScreenSetup ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
DECLARE_INPUT (Position, vrecko::MessageSensorTransformation)
DECLARE_INPUT (Record, vrecko::MessageBool)
DECLARE_INPUT (NextCorner, vrecko::MessageBool)
DECLARE_INPUT (ShowPosition, vrecko::MessageBool)
DECLARE_INPUT (RunCalculation, vrecko::MessageBool)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual | ~ScreenSetup ()
void | SaveSetup ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Member Enumeration Documentation

enum ht::ScreenSetup::Corner
Enumerator
LeftBottom
RightBottom
LeftTop
RightTop

Constructor & Destructor Documentation

ht::ScreenSetup::~ScreenSetup ( )
protectedvirtual
ht::ScreenSetup::ScreenSetup ( )

Member Function Documentation

ht::ScreenSetup::DECLARE_INPUT | ( | Position | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
ht::ScreenSetup::DECLARE_INPUT | ( | Record | ,
 |  | vrecko::MessageBool |
 | ) |  |
ht::ScreenSetup::DECLARE_INPUT | ( | NextCorner | ,
 |  | vrecko::MessageBool |
 | ) |  |
ht::ScreenSetup::DECLARE_INPUT | ( | ShowPosition | ,
 |  | vrecko::MessageBool |
 | ) |  |
ht::ScreenSetup::DECLARE_INPUT | ( | RunCalculation | ,
 |  | vrecko::MessageBool |
 | ) |  |
bool ht::ScreenSetup::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void ht::ScreenSetup::SaveSetup ( )
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetup.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetup.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::ScreenSetup::ScreenSetupState Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetup
  • ScreenSetupState
Public Attributes | List of all members
ht::ScreenSetup::ScreenSetupState Struct Reference

#include <ScreenSetup.h>

Public Attributes

VariableVec3 * monitor_position
VariableQuat * monitor_orientation
double | rim_width
double | rim_height
osg::Vec2d | monitor_corner
VariableVec3 * sensor_offset
osg::Vec3d | wire_position
osg::Quat | wire_orientation
double | wire_length

Member Data Documentation

osg::Vec2d ht::ScreenSetup::ScreenSetupState::monitor_corner
VariableQuat* ht::ScreenSetup::ScreenSetupState::monitor_orientation
VariableVec3* ht::ScreenSetup::ScreenSetupState::monitor_position
double ht::ScreenSetup::ScreenSetupState::rim_height
double ht::ScreenSetup::ScreenSetupState::rim_width
VariableVec3* ht::ScreenSetup::ScreenSetupState::sensor_offset
double ht::ScreenSetup::ScreenSetupState::wire_length
osg::Quat ht::ScreenSetup::ScreenSetupState::wire_orientation
osg::Vec3d ht::ScreenSetup::ScreenSetupState::wire_position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetup.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::ScreenSetupSimple Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetupSimple
Classes | Public Member Functions | Protected Member Functions | List of all members
ht::ScreenSetupSimple Class Reference

#include <ScreenSetupSimple.h>

Inheritance diagram for ht::ScreenSetupSimple:
vrecko::Ability vrecko::BaseClass

Classes

struct ScreenSetupSimpleState

Public Member Functions

ScreenSetupSimple ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
DECLARE_INPUT (Position, vrecko::MessageSensorTransformation)
DECLARE_INPUT (Record, vrecko::MessageBool)
DECLARE_INPUT (ShowPosition, vrecko::MessageBool)
DECLARE_INPUT (RunCalculation, vrecko::MessageBool)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual | ~ScreenSetupSimple ()
void | SaveSetup ()
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

ht::ScreenSetupSimple::~ScreenSetupSimple ( )
protectedvirtual
ht::ScreenSetupSimple::ScreenSetupSimple ( )

Member Function Documentation

ht::ScreenSetupSimple::DECLARE_INPUT | ( | Position | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
ht::ScreenSetupSimple::DECLARE_INPUT | ( | Record | ,
 |  | vrecko::MessageBool |
 | ) |  |
ht::ScreenSetupSimple::DECLARE_INPUT | ( | ShowPosition | ,
 |  | vrecko::MessageBool |
 | ) |  |
ht::ScreenSetupSimple::DECLARE_INPUT | ( | RunCalculation | ,
 |  | vrecko::MessageBool |
 | ) |  |
bool ht::ScreenSetupSimple::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void ht::ScreenSetupSimple::SaveSetup ( )
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetupSimple.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetupSimple.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::ScreenSetupSimple::ScreenSetupSimpleState Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetupSimple
  • ScreenSetupSimpleState
Public Attributes | List of all members
ht::ScreenSetupSimple::ScreenSetupSimpleState Struct Reference

#include <ScreenSetupSimple.h>

Public Attributes

VariableVec3 * mon_cor_position
VariableVec3 * sensor_offset
osg::Vec3d | wire_position
osg::Quat | wire_orientation
double | wire_length

Member Data Documentation

VariableVec3* ht::ScreenSetupSimple::ScreenSetupSimpleState::mon_cor_position
VariableVec3* ht::ScreenSetupSimple::ScreenSetupSimpleState::sensor_offset
double ht::ScreenSetupSimple::ScreenSetupSimpleState::wire_length
osg::Quat ht::ScreenSetupSimple::ScreenSetupSimpleState::wire_orientation
osg::Vec3d ht::ScreenSetupSimple::ScreenSetupSimpleState::wire_position
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetupSimple.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::Variable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Variable
Public Member Functions | List of all members
ht::Variable Class Referenceabstract

#include <Solver.h>

Inheritance diagram for ht::Variable:
ht::VariableFloat ht::VariableQuat ht::VariableVec2 ht::VariableVec3

Public Member Functions

virtual | ~Variable ()
virtual int | GetVariablesCount ()=0
virtual void | SetDelta (int variable, double delta)=0
virtual void | AddDelta (int variable, double delta)=0
virtual void | ResetDelta ()=0

Constructor & Destructor Documentation

virtual ht::Variable::~Variable ( )
inlinevirtual

Member Function Documentation

virtual void ht::Variable::AddDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
pure virtual

Implemented in ht::VariableQuat, ht::VariableFloat, ht::VariableVec2, and ht::VariableVec3.

virtual int ht::Variable::GetVariablesCount ( )
pure virtual

Implemented in ht::VariableQuat, ht::VariableFloat, ht::VariableVec2, and ht::VariableVec3.

virtual void ht::Variable::ResetDelta ( )
pure virtual

Implemented in ht::VariableQuat, ht::VariableFloat, ht::VariableVec2, and ht::VariableVec3.

virtual void ht::Variable::SetDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
pure virtual

Implemented in ht::VariableQuat, ht::VariableFloat, ht::VariableVec2, and ht::VariableVec3.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::VariableVec3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableVec3
Public Member Functions | List of all members
ht::VariableVec3 Class Reference

#include <Solver.h>

Inheritance diagram for ht::VariableVec3:
ht::Variable

Public Member Functions

VariableVec3 ()
VariableVec3 (const VariableVec3 &v)
VariableVec3 & | operator= (const VariableVec3 &v)
virtual int | GetVariablesCount () override
virtual void | SetDelta (int variable, double delta) override
virtual void | AddDelta (int variable, double delta) override
virtual void | ResetDelta () override
void | SetValue (osg::Vec3d v)
osg::Vec3d | GetValue ()
osg::Vec3d | GetValueInFunction ()
- Public Member Functions inherited from ht::Variable
virtual | ~Variable ()

Constructor & Destructor Documentation

ht::VariableVec3::VariableVec3 ( )
inline
ht::VariableVec3::VariableVec3 ( const VariableVec3 & v )
inline

Member Function Documentation

virtual void ht::VariableVec3::AddDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

osg::Vec3d ht::VariableVec3::GetValue ( )
inline
osg::Vec3d ht::VariableVec3::GetValueInFunction ( )
inline
virtual int ht::VariableVec3::GetVariablesCount ( )
inlineoverridevirtual

Implements ht::Variable.

VariableVec3& ht::VariableVec3::operator= ( const VariableVec3 & v )
inline
virtual void ht::VariableVec3::ResetDelta ( )
inlineoverridevirtual

Implements ht::Variable.

virtual void ht::VariableVec3::SetDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

void ht::VariableVec3::SetValue ( osg::Vec3d v )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::VariableVec2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableVec2
Public Member Functions | List of all members
ht::VariableVec2 Class Reference

#include <Solver.h>

Inheritance diagram for ht::VariableVec2:
ht::Variable

Public Member Functions

VariableVec2 ()
VariableVec2 (const VariableVec2 &v)
VariableVec2 & | operator= (const VariableVec2 &v)
virtual int | GetVariablesCount () override
virtual void | SetDelta (int variable, double delta) override
virtual void | AddDelta (int variable, double delta) override
virtual void | ResetDelta () override
void | SetValue (osg::Vec2d v)
osg::Vec2d | GetValue ()
osg::Vec2d | GetValueInFunction ()
- Public Member Functions inherited from ht::Variable
virtual | ~Variable ()

Constructor & Destructor Documentation

ht::VariableVec2::VariableVec2 ( )
inline
ht::VariableVec2::VariableVec2 ( const VariableVec2 & v )
inline

Member Function Documentation

virtual void ht::VariableVec2::AddDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

osg::Vec2d ht::VariableVec2::GetValue ( )
inline
osg::Vec2d ht::VariableVec2::GetValueInFunction ( )
inline
virtual int ht::VariableVec2::GetVariablesCount ( )
inlineoverridevirtual

Implements ht::Variable.

VariableVec2& ht::VariableVec2::operator= ( const VariableVec2 & v )
inline
virtual void ht::VariableVec2::ResetDelta ( )
inlineoverridevirtual

Implements ht::Variable.

virtual void ht::VariableVec2::SetDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

void ht::VariableVec2::SetValue ( osg::Vec2d v )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::VariableFloat Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableFloat
Public Member Functions | List of all members
ht::VariableFloat Class Reference

#include <Solver.h>

Inheritance diagram for ht::VariableFloat:
ht::Variable

Public Member Functions

VariableFloat ()
VariableFloat (const VariableFloat &f)
VariableFloat & | operator= (const VariableFloat &f)
virtual int | GetVariablesCount () override
virtual void | SetDelta (int variable, double delta) override
virtual void | AddDelta (int variable, double delta) override
virtual void | ResetDelta () override
void | SetValue (double v)
double | GetValue ()
double | GetValueInFunction ()
- Public Member Functions inherited from ht::Variable
virtual | ~Variable ()

Constructor & Destructor Documentation

ht::VariableFloat::VariableFloat ( )
inline
ht::VariableFloat::VariableFloat ( const VariableFloat & f )
inline

Member Function Documentation

virtual void ht::VariableFloat::AddDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

double ht::VariableFloat::GetValue ( )
inline
double ht::VariableFloat::GetValueInFunction ( )
inline
virtual int ht::VariableFloat::GetVariablesCount ( )
inlineoverridevirtual

Implements ht::Variable.

VariableFloat& ht::VariableFloat::operator= ( const VariableFloat & f )
inline
virtual void ht::VariableFloat::ResetDelta ( )
inlineoverridevirtual

Implements ht::Variable.

virtual void ht::VariableFloat::SetDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

void ht::VariableFloat::SetValue ( double v )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::VariableQuat Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableQuat
Public Member Functions | List of all members
ht::VariableQuat Class Reference

#include <Solver.h>

Inheritance diagram for ht::VariableQuat:
ht::Variable

Public Member Functions

VariableQuat ()
VariableQuat (const VariableQuat &v)
VariableQuat & | operator= (const VariableQuat &v)
virtual int | GetVariablesCount () override
virtual void | SetDelta (int variable, double delta) override
virtual void | AddDelta (int variable, double delta) override
virtual void | ResetDelta () override
void | SetValue (osg::Quat v)
osg::Quat | GetValue ()
osg::Quat | GetValueInFunction ()
- Public Member Functions inherited from ht::Variable
virtual | ~Variable ()

Constructor & Destructor Documentation

ht::VariableQuat::VariableQuat ( )
inline
ht::VariableQuat::VariableQuat ( const VariableQuat & v )
inline

Member Function Documentation

virtual void ht::VariableQuat::AddDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

osg::Quat ht::VariableQuat::GetValue ( )
inline
osg::Quat ht::VariableQuat::GetValueInFunction ( )
inline
virtual int ht::VariableQuat::GetVariablesCount ( )
inlineoverridevirtual

Implements ht::Variable.

VariableQuat& ht::VariableQuat::operator= ( const VariableQuat & v )
inline
virtual void ht::VariableQuat::ResetDelta ( )
inlineoverridevirtual

Implements ht::Variable.

virtual void ht::VariableQuat::SetDelta | ( | int | variable,
 |  | double | delta
 | ) |  |
inlineoverridevirtual

Implements ht::Variable.

void ht::VariableQuat::SetValue ( osg::Quat v )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::Function Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Function
Public Member Functions | Protected Member Functions | List of all members
ht::Function Class Referenceabstract

#include <Solver.h>

Inheritance diagram for ht::Function:
ht::SetupFunction ht::SimpleSetupFunction

Public Member Functions

virtual double Evaluate ()=0

Protected Member Functions

double | _dist_line (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)
double | _dist_line2 (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)

Member Function Documentation

double ht::Function::_dist_line | ( | osg::Vec3d | v,
 |  | osg::Vec3d | l1,
 |  | osg::Vec3d | l2
 | ) |  |
inlineprotected
double ht::Function::_dist_line2 | ( | osg::Vec3d | v,
 |  | osg::Vec3d | l1,
 |  | osg::Vec3d | l2
 | ) |  |
inlineprotected
virtual double ht::Function::Evaluate ( )
pure virtual

Implemented in ht::SetupFunction, and ht::SimpleSetupFunction.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::SetupFunction Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • SetupFunction
Public Member Functions | Public Attributes | List of all members
ht::SetupFunction Class Reference
Inheritance diagram for ht::SetupFunction:
ht::Function

Public Member Functions

SetupFunction (const ScreenSetup::ScreenSetupState &st)
virtual double Evaluate () override

Public Attributes

VariableVec3 * monitor_position
VariableQuat * monitor_orientation
double | rim_width
double | rim_height
osg::Vec2d | monitor_corner
VariableVec3 * sensor_offset
osg::Vec3d | wire_position
osg::Quat | wire_orientation
double | wire_length

Additional Inherited Members

- Protected Member Functions inherited from ht::Function
double | _dist_line (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)
double | _dist_line2 (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)

Constructor & Destructor Documentation

ht::SetupFunction::SetupFunction ( const ScreenSetup::ScreenSetupState & st )
inline

Member Function Documentation

virtual double ht::SetupFunction::Evaluate ( )
inlineoverridevirtual

Implements ht::Function.

Member Data Documentation

osg::Vec2d ht::SetupFunction::monitor_corner
VariableQuat* ht::SetupFunction::monitor_orientation
VariableVec3* ht::SetupFunction::monitor_position
double ht::SetupFunction::rim_height
double ht::SetupFunction::rim_width
VariableVec3* ht::SetupFunction::sensor_offset
double ht::SetupFunction::wire_length
osg::Quat ht::SetupFunction::wire_orientation
osg::Vec3d ht::SetupFunction::wire_position
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetup.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ht::SimpleSetupFunction Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • SimpleSetupFunction
Public Member Functions | Public Attributes | List of all members
ht::SimpleSetupFunction Class Reference
Inheritance diagram for ht::SimpleSetupFunction:
ht::Function

Public Member Functions

SimpleSetupFunction (const ScreenSetupSimple::ScreenSetupSimpleState &st)
virtual double Evaluate () override

Public Attributes

VariableVec3 * mon_cor_position
VariableVec3 * sensor_offset
osg::Vec3d | wire_position
osg::Quat | wire_orientation
double | wire_length

Additional Inherited Members

- Protected Member Functions inherited from ht::Function
double | _dist_line (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)
double | _dist_line2 (osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)

Constructor & Destructor Documentation

ht::SimpleSetupFunction::SimpleSetupFunction ( const ScreenSetupSimple::ScreenSetupSimpleState & st )
inline

Member Function Documentation

virtual double ht::SimpleSetupFunction::Evaluate ( )
inlineoverridevirtual

Implements ht::Function.

Member Data Documentation

VariableVec3* ht::SimpleSetupFunction::mon_cor_position
VariableVec3* ht::SimpleSetupFunction::sensor_offset
double ht::SimpleSetupFunction::wire_length
osg::Quat ht::SimpleSetupFunction::wire_orientation
osg::Vec3d ht::SimpleSetupFunction::wire_position
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetupSimple.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::CCollection Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CCollection
Public Member Functions | Public Attributes | List of all members
mv::CCollection Class Reference

#include <collection.h>

Public Member Functions

CCollection ()
~CCollection ()

Public Attributes

std::vector< CGesture > glist

Constructor & Destructor Documentation

mv::CCollection::CCollection ( )
mv::CCollection::~CCollection ( )

Member Data Documentation

std::vector<CGesture> mv::CCollection::glist
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/collection.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::CGesture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CGesture
Public Member Functions | Public Attributes | List of all members
mv::CGesture Class Reference

#include <gesture.h>

Public Member Functions

CGesture ()
CGesture (const CGesture &othergesture)
~CGesture ()
void | addVectOnEnd (CMVect *newmvect)
void | delVectOnEnd ()
void | delAllVect ()
void | setSPoint (gmVector3 newpoint)
gmVector3 getSPoint ()
void | setMovable (bool val)
bool | getMovable ()
void | setWTime (double newwtime)
double | getWTime ()

Public Attributes

CMVect RVect
std::vector< CMVect * > | Vectors
gmVector3 SPoint
bool | Movable
double | WTime

Constructor & Destructor Documentation

mv::CGesture::CGesture ( )
mv::CGesture::CGesture ( const CGesture & othergesture )
mv::CGesture::~CGesture ( )

Member Function Documentation

void mv::CGesture::addVectOnEnd ( CMVect * newmvect )
void mv::CGesture::delAllVect ( )
void mv::CGesture::delVectOnEnd ( )
bool mv::CGesture::getMovable ( )
inline
gmVector3 mv::CGesture::getSPoint ( )
inline
double mv::CGesture::getWTime ( )
inline
void mv::CGesture::setMovable ( bool val )
inline
void mv::CGesture::setSPoint ( gmVector3 newpoint )
inline
void mv::CGesture::setWTime ( double newwtime )
inline

Member Data Documentation

bool mv::CGesture::Movable
CMVect mv::CGesture::RVect
gmVector3 mv::CGesture::SPoint
std::vector<CMVect *> mv::CGesture::Vectors
double mv::CGesture::WTime
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gesture.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gesture.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::CPoint Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CPoint
Public Attributes | List of all members
mv::CPoint Struct Reference

#include <mvect.h>

Public Attributes

gmVector3 Pos
bool | Movable
double | WTime

Member Data Documentation

bool mv::CPoint::Movable
gmVector3 mv::CPoint::Pos
double mv::CPoint::WTime
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::CMVect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CMVect
Public Member Functions | List of all members
mv::CMVect Class Reference

#include <mvect.h>

Public Member Functions

CMVect (gmVector3 newvect, double newv0=1, double newv1=1, bool newonce=false)
CMVect (double nx=0, double ny=0, double nz=0, double newv0=1, double newv1=1, bool newonce=false)
CMVect (CMVect &OtherVector)
~CMVect ()
void | setOnce (bool newonce)
bool | getOnce ()
void | setV0 (double newv0)
double | getV0 ()
void | setV1 (double newv1)
double | getV1 ()
void | setVect (gmVector3 newvect)
gmVector3 getVect ()
gmVector3 | Eval (double p)
double | Length ()

Constructor & Destructor Documentation

mv::CMVect::CMVect | ( | gmVector3 | newvect,
 |  | double | newv0 = 1,
 |  | double | newv1 = 1,
 |  | bool | newonce = false
 | ) |  |
mv::CMVect::CMVect | ( | double | nx = 0,
 |  | double | ny = 0,
 |  | double | nz = 0,
 |  | double | newv0 = 1,
 |  | double | newv1 = 1,
 |  | bool | newonce = false
 | ) |  |
mv::CMVect::CMVect ( CMVect & OtherVector )
mv::CMVect::~CMVect ( )

Member Function Documentation

gmVector3 mv::CMVect::Eval ( double p )
bool mv::CMVect::getOnce ( )
inline
double mv::CMVect::getV0 ( )
inline
double mv::CMVect::getV1 ( )
inline
gmVector3 mv::CMVect::getVect ( )
inline
double mv::CMVect::Length ( )
inline
void mv::CMVect::setOnce ( bool newonce )
inline
void mv::CMVect::setV0 ( double newv0 )
inline
void mv::CMVect::setV1 ( double newv1 )
inline
void mv::CMVect::setVect ( gmVector3 newvect )
inline
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::CPlayer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CPlayer
Public Member Functions | Public Attributes | List of all members
mv::CPlayer Class Reference

#include <player.h>

Public Member Functions

CPlayer ()
~CPlayer ()
void | addGesture (CGesture *newgesture)
void | delGesture ()
void | delAllGestures ()
gmVector3 getActPos ()
gmVector3 getActVel ()
unsigned int | getActGesture ()
unsigned int | getActVect ()
double | getActT ()
bool | getLoop ()
void | setLoop (bool val)
bool | getAll ()
void | setAll (bool val)
bool | getPlay ()
void | setPlay (bool val)
bool | getPause ()
void | setPause (bool val)
bool | getForce ()
void | setForce (bool val)
bool | getDirection ()
void | setDirection (bool val)
gmVector3 | ControlPosition (gmVector3 Pos)
gmVector3 | ComputeForce (gmVector3 DevicePos, gmVector3 DeviceVel, gmVector3 Pos)
gmVector3 | Step_forward (gmVector3 &r, double &wtime, bool &rflag, double &p, double &v0, double &v1, double &l)
gmVector3 | Step_backward (gmVector3 &r, double &wtime, bool &rflag, double &p, double &v0, double &v1, double &l)
gmVector3 Step ()
gmVector3 | Step (gmVector3 DevicePos, gmVector3 DeviceVel)

Public Attributes

std::vector< CGesture * > | ActCollection
std::vector< CGesture * >::iterator | i

Constructor & Destructor Documentation

mv::CPlayer::CPlayer ( )
mv::CPlayer::~CPlayer ( )

Member Function Documentation

void mv::CPlayer::addGesture ( CGesture * newgesture )
gmVector3 mv::CPlayer::ComputeForce | ( | gmVector3 | DevicePos,
 |  | gmVector3 | DeviceVel,
 |  | gmVector3 | Pos
 | ) |  |
gmVector3 mv::CPlayer::ControlPosition ( gmVector3 Pos )
void mv::CPlayer::delAllGestures ( )
void mv::CPlayer::delGesture ( )
unsigned int mv::CPlayer::getActGesture ( )
inline
gmVector3 mv::CPlayer::getActPos ( )
inline
double mv::CPlayer::getActT ( )
inline
unsigned int mv::CPlayer::getActVect ( )
inline
gmVector3 mv::CPlayer::getActVel ( )
inline
bool mv::CPlayer::getAll ( )
inline
bool mv::CPlayer::getDirection ( )
inline
bool mv::CPlayer::getForce ( )
inline
bool mv::CPlayer::getLoop ( )
inline
bool mv::CPlayer::getPause ( )
inline
bool mv::CPlayer::getPlay ( )
inline
void mv::CPlayer::setAll ( bool val )
inline
void mv::CPlayer::setDirection ( bool val )
inline
void mv::CPlayer::setForce ( bool val )
inline
void mv::CPlayer::setLoop ( bool val )
inline
void mv::CPlayer::setPause ( bool val )
inline
void mv::CPlayer::setPlay ( bool val )
inline
gmVector3 mv::CPlayer::Step ( )
gmVector3 mv::CPlayer::Step | ( | gmVector3 | DevicePos,
 |  | gmVector3 | DeviceVel
 | ) |  |
gmVector3 mv::CPlayer::Step_backward | ( | gmVector3 & | r,
 |  | double & | wtime,
 |  | bool & | rflag,
 |  | double & | p,
 |  | double & | v0,
 |  | double & | v1,
 |  | double & | l
 | ) |  |
gmVector3 mv::CPlayer::Step_forward | ( | gmVector3 & | r,
 |  | double & | wtime,
 |  | bool & | rflag,
 |  | double & | p,
 |  | double & | v0,
 |  | double & | v1,
 |  | double & | l
 | ) |  |

Member Data Documentation

std::vector<CGesture *> mv::CPlayer::ActCollection
std::vector<CGesture *>::iterator mv::CPlayer::i
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/player.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/player.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: mv::Reader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • Reader
Public Member Functions | List of all members
mv::Reader Class Reference

#include <reader.h>

Public Member Functions

Reader ()
Reader (const char *filename)
~Reader ()
void | Load (const char *filename)
void | Save (const char *filename)

Constructor & Destructor Documentation

mv::Reader::Reader ( )
mv::Reader::Reader ( const char * filename )
mv::Reader::~Reader ( )

Member Function Documentation

void mv::Reader::Load ( const char * filename )
void mv::Reader::Save ( const char * filename )
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/reader.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: navigation::AvatarInHand Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • navigation
  • AvatarInHand
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
navigation::AvatarInHand Class Reference

#include <AvatarInHand.h>

Inheritance diagram for navigation::AvatarInHand:
vrecko::Ability vrecko::BaseClass

Public Member Functions

AvatarInHand ()
~AvatarInHand ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, VreckoMessage *message)
void | initialize (void)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
std::string | getAcceptableMessages (void)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (Position, MessageVec3)
DECLARE_OUTPUT (Orientation, MessageQuat)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * eo
osg::Vec3 | _actual_position
osg::Vec3 | _last_position
World::AvatarView * av
osg::Vec3 | avatar_position
osg::Vec3 | avatar_look_at
osg::Vec3 | avatar_up_vector
osg::Vec3 | _actual_left_hand_position
osg::Vec3 | _actual_right_hand_position
osg::Vec3 | _actual_head_position
osg::Quat | _actual_left_hand_orientation
osg::Quat | _actual_right_hand_orientation
osg::Quat | _actual_head_orientation
osg::Vec3 | grab_position
osg::Quat * | qc
osg::Quat * | qc_old
osg::Quat * | qd_old2
osg::Quat * | qd
osg::Quat * | qd_old
osg::Quat * | qd_init
osg::Quat | q
double | angle
bool | absolut
bool | pom
bool | fly
bool | start
osg::Vec3 | av_pos
string | mesg
bool | immersive
float | const_d
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

AvatarInHand::AvatarInHand ( )
navigation::AvatarInHand::~AvatarInHand ( )
inline

Member Function Documentation

navigation::AvatarInHand::DECLARE_OUTPUT | ( | Position | ,
 |  | MessageVec3 |
 | ) |  |
protected
navigation::AvatarInHand::DECLARE_OUTPUT | ( | Orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
std::string navigation::AvatarInHand::getAcceptableMessages ( void )
inline
void AvatarInHand::initialize ( void )
bool AvatarInHand::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void AvatarInHand::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void AvatarInHand::processEvent | ( | const std::string & | input_name,
 |  | VreckoMessage * | message
 | ) |  |
virtual

Receives an Event.

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * AvatarInHand::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void AvatarInHand::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Quat navigation::AvatarInHand::_actual_head_orientation
protected
osg::Vec3 navigation::AvatarInHand::_actual_head_position
protected
osg::Quat navigation::AvatarInHand::_actual_left_hand_orientation
protected
osg::Vec3 navigation::AvatarInHand::_actual_left_hand_position
protected
osg::Vec3 navigation::AvatarInHand::_actual_position
protected
osg::Quat navigation::AvatarInHand::_actual_right_hand_orientation
protected
osg::Vec3 navigation::AvatarInHand::_actual_right_hand_position
protected
osg::Vec3 navigation::AvatarInHand::_last_position
protected
bool navigation::AvatarInHand::absolut
protected
double navigation::AvatarInHand::angle
protected
World::AvatarView* navigation::AvatarInHand::av
protected
osg::Vec3 navigation::AvatarInHand::av_pos
protected
osg::Vec3 navigation::AvatarInHand::avatar_look_at
protected
osg::Vec3 navigation::AvatarInHand::avatar_position
protected
osg::Vec3 navigation::AvatarInHand::avatar_up_vector
protected
float navigation::AvatarInHand::const_d
protected
EnvironmentObject* navigation::AvatarInHand::eo
protected
bool navigation::AvatarInHand::fly
protected
osg::Vec3 navigation::AvatarInHand::grab_position
protected
bool navigation::AvatarInHand::immersive
protected
string navigation::AvatarInHand::mesg
protected
bool navigation::AvatarInHand::pom
protected
osg::Quat navigation::AvatarInHand::q
protected
osg::Quat* navigation::AvatarInHand::qc
protected
osg::Quat* navigation::AvatarInHand::qc_old
protected
osg::Quat* navigation::AvatarInHand::qd
protected
osg::Quat* navigation::AvatarInHand::qd_init
protected
osg::Quat* navigation::AvatarInHand::qd_old
protected
osg::Quat* navigation::AvatarInHand::qd_old2
protected
bool navigation::AvatarInHand::start
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/AvatarInHand.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/AvatarInHand.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: navigation::KMTracker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • navigation
  • KMTracker
Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
navigation::KMTracker Class Reference

#include <KMTracker.h>

Inheritance diagram for navigation::KMTracker:
vrecko::Ability vrecko::BaseClass

Public Member Functions

KMTracker ()
~KMTracker ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, VreckoMessage *message)
Internal method for processing the events. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

enum Plane_type { plane_xz = 0, plane_xy, plane_yz }

Protected Member Functions

void | KMTracker::sendSensorInfo (bool rightHand)
DECLARE_OUTPUT (Orientation, MessageQuat)
DECLARE_OUTPUT (Move, MessageVec3)
DECLARE_OUTPUT (MoveLocal, MessageVec3)
DECLARE_OUTPUT (PositionRight, MessageVec3)
DECLARE_OUTPUT (PositionLeft, MessageVec3)
DECLARE_OUTPUT (OrientationRight, MessageQuat)
DECLARE_OUTPUT (OrientationLeft, MessageQuat)
DECLARE_OUTPUT (ButtonLeft, MessageBool)
DECLARE_OUTPUT (ButtonRight, MessageBool)
DECLARE_OUTPUT (LH_ButtonLeft, MessageBool)
DECLARE_OUTPUT (LH_ButtonRight, MessageBool)
DECLARE_OUTPUT (Sensor_Transformation, vrecko::MessageSensorTransformation)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _actual_position
osg::Vec3 | _last_position
World::AvatarView * av
osg::Vec3 | avatar_position
osg::Vec3 | avatar_look_at
osg::Vec3 | avatar_up_vector
osg::Vec3 | smer3d
osg::Vec3 | move_direction
osg::Vec3 | hand_position_left
osg::Vec3 | hand_position_right
osg::Quat | hand_orientation_left
osg::Quat | hand_orientation_right
osg::Vec4 | direction
osg::Vec2 | smer
double | vert
double | horiz
osg::Vec2 | mouse_pos
osg::Vec2 | old_mouse_pos
int | mouse_scroll
osg::Vec2 | mouse_sensitivity_avatar
osg::Vec2 | mouse_sensitivity_hands
float | move_step
float | rotation_step
Plane_type move_plane
bool | moving
bool | stopped
bool | _avatarMovement
bool | right_hand
bool | alwaysSendOrientationWithPosition
int | i
std::string | mesg
World * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...

Member Enumeration Documentation

enum navigation::KMTracker::Plane_type
protected
Enumerator
plane_xz
plane_xy
plane_yz

Constructor & Destructor Documentation

KMTracker::KMTracker ( )
navigation::KMTracker::~KMTracker ( )
inline

Member Function Documentation

navigation::KMTracker::DECLARE_OUTPUT | ( | Orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | Move | ,
 |  | MessageVec3 |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | MoveLocal | ,
 |  | MessageVec3 |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | PositionRight | ,
 |  | MessageVec3 |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | PositionLeft | ,
 |  | MessageVec3 |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | OrientationRight | ,
 |  | MessageQuat |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | OrientationLeft | ,
 |  | MessageQuat |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | ButtonLeft | ,
 |  | MessageBool |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | ButtonRight | ,
 |  | MessageBool |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | LH_ButtonLeft | ,
 |  | MessageBool |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | LH_ButtonRight | ,
 |  | MessageBool |
 | ) |  |
protected
navigation::KMTracker::DECLARE_OUTPUT | ( | Sensor_Transformation | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
protected
void navigation::KMTracker::KMTracker::sendSensorInfo ( bool rightHand )
protected
bool KMTracker::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void KMTracker::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void KMTracker::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void KMTracker::processEvent | ( | const std::string & | input_name,
 |  | VreckoMessage * | pMessage
 | ) |  |
virtual

Internal method for processing the events.

After the message reimplementation, this is a method, which redistributes the events into your methods attached to the respective inputs. There is usually now no need to override this method or interact with it in any way. You can usually easily define your inputs via the DECLARE_INPUT and INIT_INPUT macros and declare handling method using the METHOD_INPUT macro.

Internally, this method is used to process all the messages and find the appropriate handling method defined by the METHOD_INPUT.

Parameters
input_name | (const std::string &) Name of the input pin
pMessage | (VreckoMessage *) Pointer to the message. This will be automatically cast to the correct message type, if you are using the DECLARE_INPUT (etc.) macros.
Returns
(void)

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * KMTracker::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void KMTracker::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 navigation::KMTracker::_actual_position
protected
bool navigation::KMTracker::_avatarMovement
protected
osg::Vec3 navigation::KMTracker::_last_position
protected
bool navigation::KMTracker::alwaysSendOrientationWithPosition
protected
World::AvatarView* navigation::KMTracker::av
protected
osg::Vec3 navigation::KMTracker::avatar_look_at
protected
osg::Vec3 navigation::KMTracker::avatar_position
protected
osg::Vec3 navigation::KMTracker::avatar_up_vector
protected
osg::Vec4 navigation::KMTracker::direction
protected
osg::Quat navigation::KMTracker::hand_orientation_left
protected
osg::Quat navigation::KMTracker::hand_orientation_right
protected
osg::Vec3 navigation::KMTracker::hand_position_left
protected
osg::Vec3 navigation::KMTracker::hand_position_right
protected
double navigation::KMTracker::horiz
protected
int navigation::KMTracker::i
protected
std::string navigation::KMTracker::mesg
protected
osg::Vec2 navigation::KMTracker::mouse_pos
protected
int navigation::KMTracker::mouse_scroll
protected
osg::Vec2 navigation::KMTracker::mouse_sensitivity_avatar
protected
osg::Vec2 navigation::KMTracker::mouse_sensitivity_hands
protected
osg::Vec3 navigation::KMTracker::move_direction
protected
Plane_type navigation::KMTracker::move_plane
protected
float navigation::KMTracker::move_step
protected
bool navigation::KMTracker::moving
protected
osg::Vec2 navigation::KMTracker::old_mouse_pos
protected
World* navigation::KMTracker::owner
protected
bool navigation::KMTracker::right_hand
protected
float navigation::KMTracker::rotation_step
protected
osg::Vec2 navigation::KMTracker::smer
protected
osg::Vec3 navigation::KMTracker::smer3d
protected
bool navigation::KMTracker::stopped
protected
double navigation::KMTracker::vert
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/KMTracker.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/KMTracker.cpp
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::CappedCylinder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CappedCylinder
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ode::CappedCylinder Class Reference

#include <CappedCylinder.h>

Inheritance diagram for ode::CappedCylinder:
vrecko::Ability vrecko::BaseClass

Public Member Functions

CappedCylinder ()
~CappedCylinder ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (ODE, DynamicScene::MessageODERequest, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

double | _radius
double | _length
int | _direction
double | _density
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ode::CappedCylinder::CappedCylinder ( )
ode::CappedCylinder::~CappedCylinder ( )
inline

Member Function Documentation

ode::CappedCylinder::DECLARE_REQUEST_OUTPUT | ( | ODE | ,
 |  | DynamicScene::MessageODERequest | ,
 |  | MessageVoid |
 | ) |  |
protected
bool ode::CappedCylinder::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ode::CappedCylinder::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ode::CappedCylinder::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void ode::CappedCylinder::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

double ode::CappedCylinder::_density
protected
int ode::CappedCylinder::_direction
protected
double ode::CappedCylinder::_length
protected
double ode::CappedCylinder::_radius
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CappedCylinder.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::CompositeObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CompositeObject
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ode::CompositeObject Class Reference

#include <CompositeObject.h>

Inheritance diagram for ode::CompositeObject:
vrecko::Ability vrecko::BaseClass

Classes

struct Data

Public Member Functions

CompositeObject ()
~CompositeObject ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (ODE, DynamicScene::MessageODERequest, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | translate
std::vector< Data * > | _data
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ode::CompositeObject::CompositeObject ( )
ode::CompositeObject::~CompositeObject ( )
inline

Member Function Documentation

ode::CompositeObject::DECLARE_REQUEST_OUTPUT | ( | ODE | ,
 |  | DynamicScene::MessageODERequest | ,
 |  | MessageVoid |
 | ) |  |
protected
bool ode::CompositeObject::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ode::CompositeObject::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ode::CompositeObject::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void ode::CompositeObject::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

std::vector<Data *> ode::CompositeObject::_data
protected
osg::Vec3 ode::CompositeObject::translate
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CompositeObject.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::CompositeObject::Data Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CompositeObject
  • Data
Public Attributes | List of all members
ode::CompositeObject::Data Struct Reference

#include <CompositeObject.h>

Public Attributes

int | _type
osg::Vec3 | _size
double | _radius
double | _length
int | _direction
double | _density
osg::Vec3 | _translate

Member Data Documentation

double ode::CompositeObject::Data::_density
int ode::CompositeObject::Data::_direction
double ode::CompositeObject::Data::_length
double ode::CompositeObject::Data::_radius
osg::Vec3 ode::CompositeObject::Data::_size
osg::Vec3 ode::CompositeObject::Data::_translate
int ode::CompositeObject::Data::_type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CompositeObject.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::Cube Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • Cube
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ode::Cube Class Reference

#include <Cube.h>

Inheritance diagram for ode::Cube:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Cube ()
~Cube ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (ODE, DynamicScene::MessageODERequest, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _size
double | _density
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ode::Cube::Cube ( )
ode::Cube::~Cube ( )
inline

Member Function Documentation

ode::Cube::DECLARE_REQUEST_OUTPUT | ( | ODE | ,
 |  | DynamicScene::MessageODERequest | ,
 |  | MessageVoid |
 | ) |  |
protected
bool ode::Cube::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ode::Cube::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ode::Cube::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void ode::Cube::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

double ode::Cube::_density
protected
osg::Vec3 ode::Cube::_size
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Cube.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::ODEObject Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • ODEObject
Public Attributes | List of all members
ode::ODEObject Struct Reference

#include <DynamicScene.h>

Public Attributes

dBodyID | body
std::vector< dGeomID * > | geom
std::vector< double * > | geom_translate
double | translate [3]
bool | enable
unsigned | steps_before_disable_state

Member Data Documentation

dBodyID ode::ODEObject::body
bool ode::ODEObject::enable
std::vector<dGeomID*> ode::ODEObject::geom
std::vector<double *> ode::ODEObject::geom_translate
unsigned ode::ODEObject::steps_before_disable_state
double ode::ODEObject::translate[3]
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/DynamicScene.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::DynamicScene Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • DynamicScene
Classes | Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
ode::DynamicScene Class Reference

#include <DynamicScene.h>

Inheritance diagram for ode::DynamicScene:
vrecko::Ability vrecko::BaseClass

Classes

class MessageODERequest

Public Types

typedef std::pair< std::string,
double * > 		Object_Pair
- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

DynamicScene ()
~DynamicScene ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | update (void)
void | setEnableFlag (vrecko::EnvironmentObject *_eobject, bool _new_state)
void | enableAllObjects (void)
void | setForceToDynamicObject (vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz)
void | setTorqueToDynamicObject (vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz)
void | setForce (vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv)
void | setTorque (vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv)
void | setLinearVel (vrecko::EnvironmentObject *_eobject, osg::Vec3 _lv)
void | setAngularVel (vrecko::EnvironmentObject *_eobject, osg::Vec3 _av)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

dWorldID | _world
dSpaceID | _space
dJointGroupID | _contact_group

Protected Member Functions

void | updateLocationInDynamic (void)
void | updateLocationInNonDynamic (void)
void | disableThreshold (void)
DECLARE_REQUEST_INPUT (ODE, MessageODERequest, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Vec3 | _gravity
double | _CFM
double | _ERP
osg::Vec4 | _plane
std::map
< vrecko::EnvironmentObject
*, ODEObject * > 		_scene_objects
std::vector< dGeomID > | _objects_dGeomID
std::vector< ODEObject * > | _dynamic_object
osg::Vec3 | _retv
osg::Quat | _retq
std::map
< vrecko::EnvironmentObject
*, bool > 		_enabled_objects
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Typedef Documentation

typedef std::pair<std::string, double*> ode::DynamicScene::Object_Pair

Constructor & Destructor Documentation

ode::DynamicScene::DynamicScene ( )
ode::DynamicScene::~DynamicScene ( )

Member Function Documentation

ode::DynamicScene::DECLARE_REQUEST_INPUT | ( | ODE | ,
 |  | MessageODERequest | ,
 |  | MessageVoid |
 | ) |  |
protected
void ode::DynamicScene::disableThreshold ( void )
protected
void ode::DynamicScene::enableAllObjects ( void )
virtual bool ode::DynamicScene::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

void ode::DynamicScene::setAngularVel | ( | vrecko::EnvironmentObject * | _eobject,
 |  | osg::Vec3 | _av
 | ) |  |
void ode::DynamicScene::setEnableFlag | ( | vrecko::EnvironmentObject * | _eobject,
 |  | bool | _new_state
 | ) |  |
void ode::DynamicScene::setForce | ( | vrecko::EnvironmentObject * | _eobject,
 |  | osg::Vec3 | _fv
 | ) |  |
void ode::DynamicScene::setForceToDynamicObject | ( | vrecko::EnvironmentObject * | _eobject,
 |  | float | _fx,
 |  | float | _fy,
 |  | float | _fz
 | ) |  |
void ode::DynamicScene::setLinearVel | ( | vrecko::EnvironmentObject * | _eobject,
 |  | osg::Vec3 | _lv
 | ) |  |
void ode::DynamicScene::setTorque | ( | vrecko::EnvironmentObject * | _eobject,
 |  | osg::Vec3 | _fv
 | ) |  |
void ode::DynamicScene::setTorqueToDynamicObject | ( | vrecko::EnvironmentObject * | _eobject,
 |  | float | _fx,
 |  | float | _fy,
 |  | float | _fz
 | ) |  |
void ode::DynamicScene::update ( void )
virtual

Process the Events.

Reimplemented from vrecko::BaseClass.

void ode::DynamicScene::updateLocationInDynamic ( void )
protected
void ode::DynamicScene::updateLocationInNonDynamic ( void )
protected

Member Data Documentation

double ode::DynamicScene::_CFM
protected
dJointGroupID ode::DynamicScene::_contact_group
std::vector<ODEObject *> ode::DynamicScene::_dynamic_object
protected
std::map<vrecko::EnvironmentObject *, bool> ode::DynamicScene::_enabled_objects
protected
double ode::DynamicScene::_ERP
protected
osg::Vec3 ode::DynamicScene::_gravity
protected
std::vector<dGeomID> ode::DynamicScene::_objects_dGeomID
protected
osg::Vec4 ode::DynamicScene::_plane
protected
osg::Quat ode::DynamicScene::_retq
protected
osg::Vec3 ode::DynamicScene::_retv
protected
std::map<vrecko::EnvironmentObject *, ODEObject *> ode::DynamicScene::_scene_objects
protected
dSpaceID ode::DynamicScene::_space
dWorldID ode::DynamicScene::_world
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/DynamicScene.h
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: ode::DynamicScene::MessageODERequest Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • DynamicScene
  • MessageODERequest
Public Member Functions | Public Attributes | List of all members
ode::DynamicScene::MessageODERequest Class Reference

#include <DynamicScene.h>

Inheritance diagram for ode::DynamicScene::MessageODERequest:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

EnvironmentObject * sender
std::string | type
double | parameter [20]
std::multimap< std::string,
double * > 		object

Member Function Documentation

virtual const char* ode::DynamicScene::MessageODERequest::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

std::multimap<std::string, double*> ode::DynamicScene::MessageODERequest::object
double ode::DynamicScene::MessageODERequest::parameter[20]
EnvironmentObject* ode::DynamicScene::MessageODERequest::sender
std::string ode::DynamicScene::MessageODERequest::type
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/DynamicScene.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: ode::Sphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • Sphere
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ode::Sphere Class Reference

#include <Sphere.h>

Inheritance diagram for ode::Sphere:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Sphere ()
~Sphere ()
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (ODE, DynamicScene::MessageODERequest, MessageVoid)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

double | _radius
double | _density
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ode::Sphere::Sphere ( )
ode::Sphere::~Sphere ( )
inline

Member Function Documentation

ode::Sphere::DECLARE_REQUEST_OUTPUT | ( | ODE | ,
 |  | DynamicScene::MessageODERequest | ,
 |  | MessageVoid |
 | ) |  |
protected
bool ode::Sphere::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ode::Sphere::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ode::Sphere::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void ode::Sphere::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

double ode::Sphere::_density
protected
double ode::Sphere::_radius
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Sphere.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QShapeVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QShapeVisitor
Public Member Functions | List of all members
osgQ::QShapeVisitor Class Reference

#include <osgQ_QSection.h>

Public Member Functions

QShapeVisitor ()
virtual | ~QShapeVisitor ()
virtual void | apply (const QSection &)

Constructor & Destructor Documentation

osgQ::QShapeVisitor::QShapeVisitor ( )
inline
virtual osgQ::QShapeVisitor::~QShapeVisitor ( )
inlinevirtual

Member Function Documentation

virtual void osgQ::QShapeVisitor::apply ( const QSection & )
inlinevirtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QSection.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QConstShapeVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QConstShapeVisitor
Public Member Functions | List of all members
osgQ::QConstShapeVisitor Class Reference

#include <osgQ_QSection.h>

Inheritance diagram for osgQ::QConstShapeVisitor:
osgQ::QComputeBoundShapeVisitor osgQ::QDrawShapeVisitor osgQ::QPrimitiveShapeVisitor

Public Member Functions

QConstShapeVisitor ()
virtual | ~QConstShapeVisitor ()
virtual void | apply (const QSection &)

Constructor & Destructor Documentation

osgQ::QConstShapeVisitor::QConstShapeVisitor ( )
inline
virtual osgQ::QConstShapeVisitor::~QConstShapeVisitor ( )
inlinevirtual

Member Function Documentation

virtual void osgQ::QConstShapeVisitor::apply ( const QSection & )
inlinevirtual

Reimplemented in osgQ::QPrimitiveShapeVisitor, osgQ::QComputeBoundShapeVisitor, and osgQ::QDrawShapeVisitor.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QSection.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QSection Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QSection
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
osgQ::QSection Class Reference

#include <osgQ_QSection.h>

Inheritance diagram for osgQ::QSection:

Public Member Functions

QSection ()
QSection (const osg::Vec3 &center, float innerRadius, float outerRadius, float angleFrom, float angleTo, float outerAngleAddition, float height)
QSection (const QSection &qsection, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY)
virtual osg::Object * | cloneType () const
virtual osg::Object * | clone (const osg::CopyOp &copyop) const
virtual bool | isSameKindAs (const osg::Object *obj) const
virtual const char * | libraryName () const
virtual const char * | className () const
virtual void | accept (osg::ShapeVisitor &sv)
virtual void | accept (osg::ConstShapeVisitor &csv) const
bool | valid () const
void | set (const osg::Vec3 &center, float outerRadius, float innerRadius, float angleFrom, float angleTo, float outerAngleAddition, float height)
void | setCenter (const osg::Vec3 &center)
const osg::Vec3 & | getCenter () const
void | setOuterRadius (float outerRadius)
float | getOuterRadius () const
void | setInnerRadius (float innerRadius)
float | getInnerRadius () const
void | setAngleFrom (float angleFrom)
float | getAngleFrom () const
void | setAngleTo (float angleTo)
float | getAngleTo () const
void | setOuterAngleAddition (float outerAngleAddition)
float | getOuterAngleAddition () const
void | setHeight (float height)
float | getHeight () const
void | setRotation (const osg::Quat &quat)
const osg::Quat & | getRotation () const
osg::Matrix | computeRotationMatrix () const
bool | zeroRotation () const
int | computeNumberOfSegments () const

Protected Member Functions

virtual ~QSection ()

Protected Attributes

osg::Vec3 | _center
float | _outerRadius
float | _innerRadius
float | _angleFrom
float | _angleTo
float | _outerAngleAddition
float | _height
osg::Quat | _rotation

Constructor & Destructor Documentation

osgQ::QSection::QSection ( )
inline
osgQ::QSection::QSection | ( | const osg::Vec3 & | center,
 |  | float | innerRadius,
 |  | float | outerRadius,
 |  | float | angleFrom,
 |  | float | angleTo,
 |  | float | outerAngleAddition,
 |  | float | height
 | ) |  |
inline
osgQ::QSection::QSection | ( | const QSection & | qsection,
 |  | const osg::CopyOp & | copyop = osg::CopyOp::SHALLOW_COPY
 | ) |  |
inline
virtual osgQ::QSection::~QSection ( )
inlineprotectedvirtual

Member Function Documentation

virtual void osgQ::QSection::accept ( osg::ShapeVisitor & sv )
inlinevirtual
virtual void osgQ::QSection::accept ( osg::ConstShapeVisitor & csv ) const
inlinevirtual
virtual const char* osgQ::QSection::className ( ) const
inlinevirtual
virtual osg::Object* osgQ::QSection::clone ( const osg::CopyOp & copyop ) const
inlinevirtual
virtual osg::Object* osgQ::QSection::cloneType ( ) const
inlinevirtual
int osgQ::QSection::computeNumberOfSegments ( ) const
inline
osg::Matrix osgQ::QSection::computeRotationMatrix ( ) const
inline
float osgQ::QSection::getAngleFrom ( ) const
inline
float osgQ::QSection::getAngleTo ( ) const
inline
const osg::Vec3& osgQ::QSection::getCenter ( ) const
inline
float osgQ::QSection::getHeight ( ) const
inline
float osgQ::QSection::getInnerRadius ( ) const
inline
float osgQ::QSection::getOuterAngleAddition ( ) const
inline
float osgQ::QSection::getOuterRadius ( ) const
inline
const osg::Quat& osgQ::QSection::getRotation ( ) const
inline
virtual bool osgQ::QSection::isSameKindAs ( const osg::Object * obj ) const
inlinevirtual
virtual const char* osgQ::QSection::libraryName ( ) const
inlinevirtual
void osgQ::QSection::set | ( | const osg::Vec3 & | center,
 |  | float | outerRadius,
 |  | float | innerRadius,
 |  | float | angleFrom,
 |  | float | angleTo,
 |  | float | outerAngleAddition,
 |  | float | height
 | ) |  |
inline
void osgQ::QSection::setAngleFrom ( float angleFrom )
inline
void osgQ::QSection::setAngleTo ( float angleTo )
inline
void osgQ::QSection::setCenter ( const osg::Vec3 & center )
inline
void osgQ::QSection::setHeight ( float height )
inline
void osgQ::QSection::setInnerRadius ( float innerRadius )
inline
void osgQ::QSection::setOuterAngleAddition ( float outerAngleAddition )
inline
void osgQ::QSection::setOuterRadius ( float outerRadius )
inline
void osgQ::QSection::setRotation ( const osg::Quat & quat )
inline
bool osgQ::QSection::valid ( ) const
inline
bool osgQ::QSection::zeroRotation ( ) const
inline

Member Data Documentation

float osgQ::QSection::_angleFrom
protected
float osgQ::QSection::_angleTo
protected
osg::Vec3 osgQ::QSection::_center
protected
float osgQ::QSection::_height
protected
float osgQ::QSection::_innerRadius
protected
float osgQ::QSection::_outerAngleAddition
protected
float osgQ::QSection::_outerRadius
protected
osg::Quat osgQ::QSection::_rotation
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QSection.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QShapeDrawable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QShapeDrawable
Public Member Functions | List of all members
osgQ::QShapeDrawable Class Reference

#include <osgQ_QShapeDrawable.h>

Inheritance diagram for osgQ::QShapeDrawable:

Public Member Functions

QShapeDrawable (osg::Shape *shape, osg::TessellationHints *hints=0)
virtual void | drawImplementation (osg::RenderInfo &renderInfo) const
virtual void | accept (osg::PrimitiveFunctor &pf) const
virtual osg::BoundingBox | computeBound () const

Constructor & Destructor Documentation

osgQ::QShapeDrawable::QShapeDrawable | ( | osg::Shape * | shape,
 |  | osg::TessellationHints * | hints = 0
 | ) |  |
inline

Member Function Documentation

void osgQ::QShapeDrawable::accept ( osg::PrimitiveFunctor & pf ) const
virtual
BoundingBox osgQ::QShapeDrawable::computeBound ( ) const
virtual
void osgQ::QShapeDrawable::drawImplementation ( osg::RenderInfo & renderInfo ) const
virtual
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QShapeDrawable.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QDrawShapeVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QDrawShapeVisitor
Public Member Functions | Public Attributes | List of all members
osgQ::QDrawShapeVisitor Class Reference
Inheritance diagram for osgQ::QDrawShapeVisitor:
osgQ::QConstShapeVisitor

Public Member Functions

QDrawShapeVisitor (State &state, const TessellationHints *hints)
virtual void | apply (const QSection &)
- Public Member Functions inherited from osgQ::QConstShapeVisitor
QConstShapeVisitor ()
virtual | ~QConstShapeVisitor ()

Public Attributes

State & | _state
const TessellationHints * | _hints

Constructor & Destructor Documentation

osgQ::QDrawShapeVisitor::QDrawShapeVisitor | ( | State & | state,
 |  | const TessellationHints * | hints
 | ) |  |
inline

Member Function Documentation

void osgQ::QDrawShapeVisitor::apply ( const QSection & section )
virtual

Reimplemented from osgQ::QConstShapeVisitor.

Member Data Documentation

const TessellationHints* osgQ::QDrawShapeVisitor::_hints
State& osgQ::QDrawShapeVisitor::_state
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QComputeBoundShapeVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QComputeBoundShapeVisitor
Public Member Functions | Public Attributes | List of all members
osgQ::QComputeBoundShapeVisitor Class Reference
Inheritance diagram for osgQ::QComputeBoundShapeVisitor:
osgQ::QConstShapeVisitor

Public Member Functions

QComputeBoundShapeVisitor (BoundingBox &bb)
virtual void | apply (const QSection &)
- Public Member Functions inherited from osgQ::QConstShapeVisitor
QConstShapeVisitor ()
virtual | ~QConstShapeVisitor ()

Public Attributes

BoundingBox & _bb

Constructor & Destructor Documentation

osgQ::QComputeBoundShapeVisitor::QComputeBoundShapeVisitor ( BoundingBox & bb )
inline

Member Function Documentation

void osgQ::QComputeBoundShapeVisitor::apply ( const QSection & section )
virtual

Reimplemented from osgQ::QConstShapeVisitor.

Member Data Documentation

BoundingBox& osgQ::QComputeBoundShapeVisitor::_bb
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: osgQ::QPrimitiveShapeVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QPrimitiveShapeVisitor
Public Member Functions | Public Attributes | List of all members
osgQ::QPrimitiveShapeVisitor Class Reference
Inheritance diagram for osgQ::QPrimitiveShapeVisitor:
osgQ::QConstShapeVisitor

Public Member Functions

QPrimitiveShapeVisitor (PrimitiveFunctor &functor, const TessellationHints *hints)
virtual void | apply (const QSection &)
- Public Member Functions inherited from osgQ::QConstShapeVisitor
QConstShapeVisitor ()
virtual | ~QConstShapeVisitor ()

Public Attributes

PrimitiveFunctor & | _functor
const TessellationHints * | _hints

Constructor & Destructor Documentation

osgQ::QPrimitiveShapeVisitor::QPrimitiveShapeVisitor | ( | PrimitiveFunctor & | functor,
 |  | const TessellationHints * | hints
 | ) |  |
inline

Member Function Documentation

void osgQ::QPrimitiveShapeVisitor::apply ( const QSection & section )
virtual

Reimplemented from osgQ::QConstShapeVisitor.

Member Data Documentation

PrimitiveFunctor& osgQ::QPrimitiveShapeVisitor::_functor
const TessellationHints* osgQ::QPrimitiveShapeVisitor::_hints
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::BaseActor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BaseActor
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::BaseActor Class Reference

#include <BaseActor.h>

Inheritance diagram for PhysXPlugin::BaseActor:
PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass PhysXPlugin::Box PhysXPlugin::Capsule PhysXPlugin::Plane PhysXPlugin::Sphere

Public Member Functions

BaseActor (const char *abName)
virtual | ~BaseActor ()
virtual void | Create ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void UpdateEnvironmentObject ()
DECLARE_INPUT (ResetPosition, MessageBool)
DECLARE_INPUT (MoveTo, MessageVec3)
DECLARE_INPUT (RotateTo, MessageQuat)
DECLARE_INPUT (DynamicActorOutputs, MessageBool)
DECLARE_OUTPUT (LinearMomentum, MessageVec3)
DECLARE_OUTPUT (AngularMomentum, MessageVec3)
DECLARE_OUTPUT (LinearVelocity, MessageVec3)
DECLARE_OUTPUT (AngularVelocity, MessageVec3)
DECLARE_REQUEST_OUTPUT (Material, MessageString, MessageNxMaterialIndex)
DECLARE_REQUEST_OUTPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)

Protected Attributes

bool | _bDynamicActorOutputs
NxActorDesc | _actorDesc
NxBodyDesc | _bodyDesc
std::string | _MaterialName
NxMaterialIndex | _MaterialIndex
NxActor * | _pPO
float | _move_step_limit
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::BaseActor::BaseActor ( const char * abName )
inline
PhysXPlugin::BaseActor::~BaseActor ( )
virtual

Member Function Documentation

void PhysXPlugin::BaseActor::Create ( )
virtual

Implements PhysXPlugin::BasePhysXObject.

Reimplemented in PhysXPlugin::Box, PhysXPlugin::Sphere, PhysXPlugin::Capsule, and PhysXPlugin::Plane.

PhysXPlugin::BaseActor::DECLARE_INPUT | ( | ResetPosition | ,
 |  | MessageBool |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_INPUT | ( | MoveTo | ,
 |  | MessageVec3 |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_INPUT | ( | RotateTo | ,
 |  | MessageQuat |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_INPUT | ( | DynamicActorOutputs | ,
 |  | MessageBool |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_OUTPUT | ( | LinearMomentum | ,
 |  | MessageVec3 |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_OUTPUT | ( | AngularMomentum | ,
 |  | MessageVec3 |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_OUTPUT | ( | LinearVelocity | ,
 |  | MessageVec3 |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_OUTPUT | ( | AngularVelocity | ,
 |  | MessageVec3 |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_REQUEST_OUTPUT | ( | Material | ,
 |  | MessageString | ,
 |  | MessageNxMaterialIndex |
 | ) |  |
protected
PhysXPlugin::BaseActor::DECLARE_REQUEST_OUTPUT | ( | RegisterJointedActor | ,
 |  | MessageNxActorWithName | ,
 |  | MessageBool |
 | ) |  |
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * BaseActor::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented in PhysXPlugin::Box, PhysXPlugin::Capsule, PhysXPlugin::Plane, and PhysXPlugin::Sphere.

bool BaseActor::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BasePhysXObject.

Reimplemented in PhysXPlugin::Box, PhysXPlugin::Capsule, PhysXPlugin::Plane, and PhysXPlugin::Sphere.

void PhysXPlugin::BaseActor::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::BasePhysXObject.

void BaseActor::UpdateEnvironmentObject ( )
inlineprotectedvirtual

Implements PhysXPlugin::UpdatablePhysXObject.

Member Data Documentation

NxActorDesc PhysXPlugin::BaseActor::_actorDesc
protected
bool PhysXPlugin::BaseActor::_bDynamicActorOutputs
protected
NxBodyDesc PhysXPlugin::BaseActor::_bodyDesc
protected
NxMaterialIndex PhysXPlugin::BaseActor::_MaterialIndex
protected
std::string PhysXPlugin::BaseActor::_MaterialName
protected
float PhysXPlugin::BaseActor::_move_step_limit
protected
NxActor* PhysXPlugin::BaseActor::_pPO
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseActor.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseActor.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::BaseJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BaseJoint
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::BaseJoint Class Reference

#include <BaseJoint.h>

Inheritance diagram for PhysXPlugin::BaseJoint:
PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass PhysXPlugin::CylindricalJoint PhysXPlugin::DistanceJoint PhysXPlugin::FixedJoint PhysXPlugin::PointInPlaneJoint PhysXPlugin::PointOnLineJoint PhysXPlugin::PrismaticJoint PhysXPlugin::PulleyJoint PhysXPlugin::RevoluteJoint PhysXPlugin::SphericalJoint

Public Member Functions

BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)
- Protected Member Functions inherited from PhysXPlugin::BasePhysXObject
DECLARE_REQUEST_OUTPUT (PhysXScene, MessageString, MessageNxScenePtr)
- Protected Member Functions inherited from PhysXPlugin::PhysXObject
bool | addUserDrawable (osg::Drawable *userDrawable)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::BaseJoint::BaseJoint | ( | const char * | abName,
 |  | NxJointDesc * | descripter
 | ) |  |
inline
virtual PhysXPlugin::BaseJoint::~BaseJoint ( )
inlinevirtual

Member Function Documentation

void PhysXPlugin::BaseJoint::Create ( )
virtual

Implements PhysXPlugin::BasePhysXObject.

PhysXPlugin::BaseJoint::DECLARE_REQUEST_OUTPUT | ( | GetJointedActor | ,
 |  | MessageString | ,
 |  | MessageNxActorPtr |
 | ) |  |
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * BaseJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented in PhysXPlugin::CylindricalJoint, PhysXPlugin::PointInPlaneJoint, PhysXPlugin::PointOnLineJoint, PhysXPlugin::PrismaticJoint, PhysXPlugin::FixedJoint, PhysXPlugin::PulleyJoint, PhysXPlugin::RevoluteJoint, PhysXPlugin::SphericalJoint, and PhysXPlugin::DistanceJoint.

bool BaseJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BasePhysXObject.

Reimplemented in PhysXPlugin::CylindricalJoint, PhysXPlugin::PointInPlaneJoint, PhysXPlugin::PointOnLineJoint, PhysXPlugin::PrismaticJoint, PhysXPlugin::SphericalJoint, PhysXPlugin::DistanceJoint, PhysXPlugin::FixedJoint, PhysXPlugin::PulleyJoint, and PhysXPlugin::RevoluteJoint.

Member Data Documentation

NxVec3 PhysXPlugin::BaseJoint::_globalAnchor
protected
NxVec3 PhysXPlugin::BaseJoint::_globalAxis
protected
std::string PhysXPlugin::BaseJoint::_ID[2]
protected
NxJointDesc* PhysXPlugin::BaseJoint::_pBaseDescripter
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseJoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseJoint.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::BasePhysXObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BasePhysXObject
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::BasePhysXObject Class Referenceabstract

#include <BasePhysXObject.h>

Inheritance diagram for PhysXPlugin::BasePhysXObject:
PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass PhysXPlugin::BaseJoint PhysXPlugin::ForceField PhysXPlugin::UpdatablePhysXObject PhysXPlugin::CylindricalJoint PhysXPlugin::DistanceJoint PhysXPlugin::FixedJoint PhysXPlugin::PointInPlaneJoint PhysXPlugin::PointOnLineJoint PhysXPlugin::PrismaticJoint PhysXPlugin::PulleyJoint PhysXPlugin::RevoluteJoint PhysXPlugin::SphericalJoint PhysXPlugin::BaseActor PhysXPlugin::Cloth PhysXPlugin::Fluid

Public Member Functions

BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | Create ()=0
DECLARE_REQUEST_OUTPUT (PhysXScene, MessageString, MessageNxScenePtr)
- Protected Member Functions inherited from PhysXPlugin::PhysXObject
bool | addUserDrawable (osg::Drawable *userDrawable)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::BasePhysXObject::BasePhysXObject ( const char * abName )
inline

Member Function Documentation

virtual void PhysXPlugin::BasePhysXObject::Create ( )
protectedpure virtual

Implemented in PhysXPlugin::Cloth, PhysXPlugin::Fluid, PhysXPlugin::BaseJoint, PhysXPlugin::BaseActor, PhysXPlugin::Box, PhysXPlugin::Sphere, PhysXPlugin::Capsule, PhysXPlugin::Plane, and PhysXPlugin::ForceField.

PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT | ( | PhysXScene | ,
 |  | MessageString | ,
 |  | MessageNxScenePtr |
 | ) |  |
protected
bool PhysXPlugin::BasePhysXObject::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

Reimplemented in PhysXPlugin::Cloth, PhysXPlugin::BaseActor, PhysXPlugin::BaseJoint, PhysXPlugin::Box, PhysXPlugin::Capsule, PhysXPlugin::CylindricalJoint, PhysXPlugin::Fluid, PhysXPlugin::Plane, PhysXPlugin::PointInPlaneJoint, PhysXPlugin::PointOnLineJoint, PhysXPlugin::PrismaticJoint, PhysXPlugin::Sphere, PhysXPlugin::SphericalJoint, PhysXPlugin::DistanceJoint, PhysXPlugin::FixedJoint, PhysXPlugin::PulleyJoint, PhysXPlugin::RevoluteJoint, and PhysXPlugin::ForceField.

void BasePhysXObject::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::PhysXObject.

Reimplemented in PhysXPlugin::BaseActor, and PhysXPlugin::UpdatablePhysXObject.

void PhysXPlugin::BasePhysXObject::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::PhysXObject.

Member Data Documentation

NxScene* PhysXPlugin::BasePhysXObject::_pScene
protected
std::string PhysXPlugin::BasePhysXObject::_strScene
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BasePhysXObject.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BasePhysXObject.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Box Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Box
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Box Class Reference

#include <Box.h>

Inheritance diagram for PhysXPlugin::Box:
PhysXPlugin::BaseActor PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Box ()
~Box ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from PhysXPlugin::BaseActor
BaseActor (const char *abName)
virtual | ~BaseActor ()
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | Create ()
- Protected Member Functions inherited from PhysXPlugin::BaseActor
void | UpdateEnvironmentObject ()
DECLARE_INPUT (ResetPosition, MessageBool)
DECLARE_INPUT (MoveTo, MessageVec3)
DECLARE_INPUT (RotateTo, MessageQuat)
DECLARE_INPUT (DynamicActorOutputs, MessageBool)
DECLARE_OUTPUT (LinearMomentum, MessageVec3)
DECLARE_OUTPUT (AngularMomentum, MessageVec3)
DECLARE_OUTPUT (LinearVelocity, MessageVec3)
DECLARE_OUTPUT (AngularVelocity, MessageVec3)
DECLARE_REQUEST_OUTPUT (Material, MessageString, MessageNxMaterialIndex)
DECLARE_REQUEST_OUTPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)

Protected Attributes

NxBoxShapeDesc | _boxDesc
- Protected Attributes inherited from PhysXPlugin::BaseActor
bool | _bDynamicActorOutputs
NxActorDesc | _actorDesc
NxBodyDesc | _bodyDesc
std::string | _MaterialName
NxMaterialIndex | _MaterialIndex
NxActor * | _pPO
float | _move_step_limit
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Box::Box ( )
Box::~Box ( )

Member Function Documentation

void Box::Create ( )
protectedvirtual

Reimplemented from PhysXPlugin::BaseActor.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Box::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented from PhysXPlugin::BaseActor.

bool Box::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseActor.

Member Data Documentation

NxBoxShapeDesc PhysXPlugin::Box::_boxDesc
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Box.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Box.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Capsule Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Capsule
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Capsule Class Reference

#include <Capsule.h>

Inheritance diagram for PhysXPlugin::Capsule:
PhysXPlugin::BaseActor PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Capsule ()
~Capsule ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from PhysXPlugin::BaseActor
BaseActor (const char *abName)
virtual | ~BaseActor ()
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Create ()
- Protected Member Functions inherited from PhysXPlugin::BaseActor
void | UpdateEnvironmentObject ()
DECLARE_INPUT (ResetPosition, MessageBool)
DECLARE_INPUT (MoveTo, MessageVec3)
DECLARE_INPUT (RotateTo, MessageQuat)
DECLARE_INPUT (DynamicActorOutputs, MessageBool)
DECLARE_OUTPUT (LinearMomentum, MessageVec3)
DECLARE_OUTPUT (AngularMomentum, MessageVec3)
DECLARE_OUTPUT (LinearVelocity, MessageVec3)
DECLARE_OUTPUT (AngularVelocity, MessageVec3)
DECLARE_REQUEST_OUTPUT (Material, MessageString, MessageNxMaterialIndex)
DECLARE_REQUEST_OUTPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)

Protected Attributes

NxCapsuleShapeDesc | _capsuleDesc
- Protected Attributes inherited from PhysXPlugin::BaseActor
bool | _bDynamicActorOutputs
NxActorDesc | _actorDesc
NxBodyDesc | _bodyDesc
std::string | _MaterialName
NxMaterialIndex | _MaterialIndex
NxActor * | _pPO
float | _move_step_limit
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::Capsule::Capsule ( )
inline
PhysXPlugin::Capsule::~Capsule ( )
inline

Member Function Documentation

void Capsule::Create ( )
protectedvirtual

Reimplemented from PhysXPlugin::BaseActor.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Capsule::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented from PhysXPlugin::BaseActor.

bool Capsule::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseActor.

Member Data Documentation

NxCapsuleShapeDesc PhysXPlugin::Capsule::_capsuleDesc
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Capsule.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Capsule.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Cloth Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Cloth
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Cloth Class Reference

#include <Cloth.h>

Inheritance diagram for PhysXPlugin::Cloth:
PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Cloth ()
virtual | ~Cloth ()
virtual void | Create ()
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void UpdateEnvironmentObject ()

Protected Attributes

ClothDrawable * _pClothDrawable
NxCloth * | _pCloth
NxClothMesh * | _pClothMesh
NxMeshData | _meshData
NxClothDesc | _clothDesc
NxClothMeshDesc | _clothMeshDesc
CoreActorDesc _coreActorDesc
NxVec3 | _scale
NxVec3 | _offset
std::vector< unsigned long > | _attachment_ids
std::string | _fileName
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::Cloth::Cloth ( )
inline
virtual PhysXPlugin::Cloth::~Cloth ( )
inlinevirtual

Member Function Documentation

void PhysXPlugin::Cloth::Create ( )
virtual

Implements PhysXPlugin::BasePhysXObject.

bool PhysXPlugin::Cloth::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BasePhysXObject.

void PhysXPlugin::Cloth::UpdateEnvironmentObject ( )
protectedvirtual

Implements PhysXPlugin::UpdatablePhysXObject.

Member Data Documentation

std::vector<unsigned long> PhysXPlugin::Cloth::_attachment_ids
protected
NxClothDesc PhysXPlugin::Cloth::_clothDesc
protected
NxClothMeshDesc PhysXPlugin::Cloth::_clothMeshDesc
protected
CoreActorDesc PhysXPlugin::Cloth::_coreActorDesc
protected
std::string PhysXPlugin::Cloth::_fileName
protected
NxMeshData PhysXPlugin::Cloth::_meshData
protected
NxVec3 PhysXPlugin::Cloth::_offset
protected
NxCloth* PhysXPlugin::Cloth::_pCloth
protected
ClothDrawable* PhysXPlugin::Cloth::_pClothDrawable
protected
NxClothMesh* PhysXPlugin::Cloth::_pClothMesh
protected
NxVec3 PhysXPlugin::Cloth::_scale
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Cloth.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Cloth.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::ClothDrawable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ClothDrawable
Public Member Functions | Protected Member Functions | Friends | List of all members
PhysXPlugin::ClothDrawable Class Reference

#include <ClothDrawable.h>

Inheritance diagram for PhysXPlugin::ClothDrawable:

Public Member Functions

ClothDrawable ()
ClothDrawable (NxCloth *pCloth)
virtual | ~ClothDrawable ()
ClothDrawable (const ClothDrawable &drawable, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY)
virtual osg::Object * | cloneType () const
virtual osg::Object * | clone (const osg::CopyOp &copyop) const
virtual void | drawImplementation (osg::RenderInfo &renderInfo) const
virtual void | Update ()
virtual bool | isSameKindAs (const osg::Object *obj) const
virtual const char * | libaryName () const
virtual const char * | className () const
virtual osg::BoundingBox | computeBound () const

Protected Member Functions

void | PCloth (NxCloth *val)
ClothDrawable & | operator= (const ClothDrawable &)

Friends

class Cloth

Constructor & Destructor Documentation

PhysXPlugin::ClothDrawable::ClothDrawable ( )
inline
PhysXPlugin::ClothDrawable::ClothDrawable ( NxCloth * pCloth )
inline
virtual PhysXPlugin::ClothDrawable::~ClothDrawable ( )
inlinevirtual
PhysXPlugin::ClothDrawable::ClothDrawable | ( | const ClothDrawable & | drawable,
 |  | const osg::CopyOp & | copyop = osg::CopyOp::SHALLOW_COPY
 | ) |  |
inline

Member Function Documentation

virtual const char* PhysXPlugin::ClothDrawable::className ( ) const
inlinevirtual
virtual osg::Object* PhysXPlugin::ClothDrawable::clone ( const osg::CopyOp & copyop ) const
inlinevirtual
virtual osg::Object* PhysXPlugin::ClothDrawable::cloneType ( ) const
inlinevirtual
virtual osg::BoundingBox PhysXPlugin::ClothDrawable::computeBound ( ) const
inlinevirtual
virtual void PhysXPlugin::ClothDrawable::drawImplementation ( osg::RenderInfo & renderInfo ) const
inlinevirtual
virtual bool PhysXPlugin::ClothDrawable::isSameKindAs ( const osg::Object * obj ) const
inlinevirtual
virtual const char* PhysXPlugin::ClothDrawable::libaryName ( ) const
inlinevirtual
ClothDrawable& PhysXPlugin::ClothDrawable::operator= ( const ClothDrawable & )
inlineprotected
void PhysXPlugin::ClothDrawable::PCloth ( NxCloth * val )
inlineprotected
virtual void PhysXPlugin::ClothDrawable::Update ( void )
inlinevirtual

Friends And Related Function Documentation

friend class Cloth
friend
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ClothDrawable.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::CoreActorDesc Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • CoreActorDesc
Public Member Functions | List of all members
PhysXPlugin::CoreActorDesc Class Reference

#include <CoreActorDesc.h>

Public Member Functions

CoreActorDesc ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
void | Create (NxScene *pScene, NxCloth *pCloth)

Constructor & Destructor Documentation

PhysXPlugin::CoreActorDesc::CoreActorDesc ( )
inline

Member Function Documentation

void PhysXPlugin::CoreActorDesc::Create | ( | NxScene * | pScene,
 |  | NxCloth * | pCloth
 | ) |  |
bool PhysXPlugin::CoreActorDesc::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CoreActorDesc.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CoreActorDesc.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::CylindricalJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • CylindricalJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::CylindricalJoint Class Reference

#include <CylindricalJoint.h>

Inheritance diagram for PhysXPlugin::CylindricalJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

CylindricalJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxCylindricalJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::CylindricalJoint::CylindricalJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::CylindricalJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::CylindricalJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxCylindricalJointDesc PhysXPlugin::CylindricalJoint::_descripter
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CylindricalJoint.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::DistanceJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • DistanceJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::DistanceJoint Class Reference

#include <DistanceJoint.h>

Inheritance diagram for PhysXPlugin::DistanceJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

DistanceJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxDistanceJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::DistanceJoint::DistanceJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PhysXPlugin::DistanceJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
virtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::DistanceJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxDistanceJointDesc PhysXPlugin::DistanceJoint::_descripter
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/DistanceJoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/DistanceJoint.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::ErrorReporter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ErrorReporter
List of all members
PhysXPlugin::ErrorReporter Class Reference

#include <ErrorReporter.h>

Inheritance diagram for PhysXPlugin::ErrorReporter:
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ErrorReporter.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::FixedJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • FixedJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::FixedJoint Class Reference

#include <FixedJoint.h>

Inheritance diagram for PhysXPlugin::FixedJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

FixedJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxFixedJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::FixedJoint::FixedJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::FixedJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::FixedJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxFixedJointDesc PhysXPlugin::FixedJoint::_descripter
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FixedJoint.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Fluid Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Fluid
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Fluid Class Reference

#include <Fluid.h>

Inheritance diagram for PhysXPlugin::Fluid:
PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Fluid ()
virtual | ~Fluid ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | BeforeInitialization ()
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Create ()
void | UpdateEnvironmentObject ()

Protected Attributes

FluidDrawable * _pFluidDrawable
NxFluid * | _pFluid
NxParticleData | _Particles
NxFluidDesc | _fluidDesc
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::Fluid::Fluid ( )
inline
virtual PhysXPlugin::Fluid::~Fluid ( )
inlinevirtual

Member Function Documentation

void PhysXPlugin::Fluid::BeforeInitialization ( )
virtual

Reimplemented from PhysXPlugin::PhysXObject.

void Fluid::Create ( )
protectedvirtual

Implements PhysXPlugin::BasePhysXObject.

bool Fluid::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BasePhysXObject.

void PhysXPlugin::Fluid::UpdateEnvironmentObject ( )
protectedvirtual

Implements PhysXPlugin::UpdatablePhysXObject.

Member Data Documentation

NxFluidDesc PhysXPlugin::Fluid::_fluidDesc
protected
NxParticleData PhysXPlugin::Fluid::_Particles
protected
NxFluid* PhysXPlugin::Fluid::_pFluid
protected
FluidDrawable* PhysXPlugin::Fluid::_pFluidDrawable
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Fluid.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Fluid.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::FluidDrawable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • FluidDrawable
Public Member Functions | Protected Member Functions | Friends | List of all members
PhysXPlugin::FluidDrawable Class Reference

#include <FluidDrawable.h>

Inheritance diagram for PhysXPlugin::FluidDrawable:

Public Member Functions

FluidDrawable ()
FluidDrawable (NxFluid *pFluid)
virtual | ~FluidDrawable ()
FluidDrawable (const FluidDrawable &drawable, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY)
virtual osg::Object * | cloneType () const
virtual osg::Object * | clone (const osg::CopyOp &copyop) const
virtual void | drawImplementation (osg::RenderInfo &renderInfo) const
virtual void | Update ()
virtual bool | isSameKindAs (const osg::Object *obj) const
virtual const char * | libaryName () const
virtual const char * | className () const
virtual osg::BoundingBox | computeBound () const

Protected Member Functions

FluidDrawable & operator= (const FluidDrawable &)

Friends

class Fluid

Constructor & Destructor Documentation

PhysXPlugin::FluidDrawable::FluidDrawable ( )
inline
PhysXPlugin::FluidDrawable::FluidDrawable ( NxFluid * pFluid )
inline
virtual PhysXPlugin::FluidDrawable::~FluidDrawable ( )
inlinevirtual
PhysXPlugin::FluidDrawable::FluidDrawable | ( | const FluidDrawable & | drawable,
 |  | const osg::CopyOp & | copyop = osg::CopyOp::SHALLOW_COPY
 | ) |  |
inline

Member Function Documentation

virtual const char* PhysXPlugin::FluidDrawable::className ( ) const
inlinevirtual
virtual osg::Object* PhysXPlugin::FluidDrawable::clone ( const osg::CopyOp & copyop ) const
inlinevirtual
virtual osg::Object* PhysXPlugin::FluidDrawable::cloneType ( ) const
inlinevirtual
virtual osg::BoundingBox PhysXPlugin::FluidDrawable::computeBound ( ) const
inlinevirtual
virtual void PhysXPlugin::FluidDrawable::drawImplementation ( osg::RenderInfo & renderInfo ) const
inlinevirtual
virtual bool PhysXPlugin::FluidDrawable::isSameKindAs ( const osg::Object * obj ) const
inlinevirtual
virtual const char* PhysXPlugin::FluidDrawable::libaryName ( ) const
inlinevirtual
FluidDrawable& PhysXPlugin::FluidDrawable::operator= ( const FluidDrawable & )
inlineprotected
virtual void PhysXPlugin::FluidDrawable::Update ( void )
inlinevirtual

Friends And Related Function Documentation

friend class Fluid
friend
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FluidDrawable.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::ForceField Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ForceField
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::ForceField Class Reference

#include <ForceField.h>

Inheritance diagram for PhysXPlugin::ForceField:
PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

ForceField ()
virtual | ~ForceField ()
std::string | getAcceptableMessages (void)
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Create ()
- Protected Member Functions inherited from PhysXPlugin::BasePhysXObject
DECLARE_REQUEST_OUTPUT (PhysXScene, MessageString, MessageNxScenePtr)
- Protected Member Functions inherited from PhysXPlugin::PhysXObject
bool | addUserDrawable (osg::Drawable *userDrawable)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

NxForceFieldDesc | _forceFieldDesc
NxForceFieldLinearKernelDesc | _forceFieldLinearKernelDesc
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

ForceField::ForceField ( )
virtual PhysXPlugin::ForceField::~ForceField ( )
inlinevirtual

Member Function Documentation

void ForceField::Create ( )
protectedvirtual

Implements PhysXPlugin::BasePhysXObject.

std::string PhysXPlugin::ForceField::getAcceptableMessages ( void )
inline
bool PhysXPlugin::ForceField::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BasePhysXObject.

Member Data Documentation

NxForceFieldDesc PhysXPlugin::ForceField::_forceFieldDesc
protected
NxForceFieldLinearKernelDesc PhysXPlugin::ForceField::_forceFieldLinearKernelDesc
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ForceField.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ForceField.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::MaterialManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • MaterialManager
Public Member Functions | List of all members
PhysXPlugin::MaterialManager Class Reference

#include <MaterialManager.h>

Public Member Functions

bool | loadXMLMaterial (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
void | Create (NxScene *pScene)
NxMaterialIndex | indexByName (const std::string &)

Member Function Documentation

void PhysXPlugin::MaterialManager::Create ( NxScene * pScene )
NxMaterialIndex PhysXPlugin::MaterialManager::indexByName ( const std::string & name )
bool PhysXPlugin::MaterialManager::loadXMLMaterial ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialManager.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Particle Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Particle
Public Attributes | List of all members
PhysXPlugin::Particle Struct Reference

#include <Particle.h>

Public Attributes

NxVec3 | position
NxVec3 | velocity
NxReal | density
NxReal | lifetime
NxU32 | id
NxVec3 | collisionNormal

Member Data Documentation

NxVec3 PhysXPlugin::Particle::collisionNormal
NxReal PhysXPlugin::Particle::density
NxU32 PhysXPlugin::Particle::id
NxReal PhysXPlugin::Particle::lifetime
NxVec3 PhysXPlugin::Particle::position
NxVec3 PhysXPlugin::Particle::velocity
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Particle.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PhysXObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PhysXObject
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::PhysXObject Class Reference

#include <PhysXObject.h>

Inheritance diagram for PhysXPlugin::PhysXObject:
vrecko::Ability vrecko::BaseClass PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXScene PhysXPlugin::RemoteDebugger PhysXPlugin::BaseJoint PhysXPlugin::ForceField PhysXPlugin::UpdatablePhysXObject PhysXPlugin::CylindricalJoint PhysXPlugin::DistanceJoint PhysXPlugin::FixedJoint PhysXPlugin::PointInPlaneJoint PhysXPlugin::PointOnLineJoint PhysXPlugin::PrismaticJoint PhysXPlugin::PulleyJoint PhysXPlugin::RevoluteJoint PhysXPlugin::SphericalJoint PhysXPlugin::BaseActor PhysXPlugin::Cloth PhysXPlugin::Fluid

Public Member Functions

PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | addUserDrawable (osg::Drawable *userDrawable)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

PhysXPlugin::PhysXObject::PhysXObject ( const char * abName )
inline
virtual PhysXPlugin::PhysXObject::~PhysXObject ( )
inlinevirtual

Member Function Documentation

bool PhysXPlugin::PhysXObject::addUserDrawable ( osg::Drawable * userDrawable )
inlineprotected
virtual void PhysXPlugin::PhysXObject::AfterInitialization ( )
inlinevirtual
virtual void PhysXPlugin::PhysXObject::BeforeInitialization ( )
inlinevirtual

Reimplemented in PhysXPlugin::Fluid.

virtual void PhysXPlugin::PhysXObject::postInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

Reimplemented in PhysXPlugin::PhysXScene, PhysXPlugin::BaseActor, PhysXPlugin::BasePhysXObject, PhysXPlugin::RemoteDebugger, and PhysXPlugin::UpdatablePhysXObject.

virtual void PhysXPlugin::PhysXObject::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

Reimplemented in PhysXPlugin::PhysXScene, and PhysXPlugin::BasePhysXObject.

Member Data Documentation

NxPhysicsSDK* PhysXPlugin::PhysXObject::_pPhysicsSDK
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXObject.h
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PhysXScene Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PhysXScene
Public Member Functions | List of all members
PhysXPlugin::PhysXScene Class Reference

#include <PhysXScene.h>

Inheritance diagram for PhysXPlugin::PhysXScene:
PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

PhysXScene ()
virtual | ~PhysXScene ()
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
DECLARE_REQUEST_INPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
DECLARE_REQUEST_INPUT (PhysXScene, MessageVoid, MessageNxScenePtr)
DECLARE_REQUEST_INPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)
DECLARE_REQUEST_INPUT (GetJointedActor, MessageString, MessageNxActorPtr)
DECLARE_REQUEST_INPUT (Material, MessageString, MessageNxMaterialIndex)
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::PhysXObject
bool | addUserDrawable (osg::Drawable *userDrawable)
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK

Constructor & Destructor Documentation

PhysXPlugin::PhysXScene::PhysXScene ( )
virtual PhysXPlugin::PhysXScene::~PhysXScene ( )
inlinevirtual

Member Function Documentation

PhysXPlugin::PhysXScene::DECLARE_REQUEST_INPUT | ( | RegisterPhysXObject | ,
 |  | MessageUpdatablePhysXObjectPtr | ,
 |  | MessageBool |
 | ) |  |
PhysXPlugin::PhysXScene::DECLARE_REQUEST_INPUT | ( | PhysXScene | ,
 |  | MessageVoid | ,
 |  | MessageNxScenePtr |
 | ) |  |
PhysXPlugin::PhysXScene::DECLARE_REQUEST_INPUT | ( | RegisterJointedActor | ,
 |  | MessageNxActorWithName | ,
 |  | MessageBool |
 | ) |  |
PhysXPlugin::PhysXScene::DECLARE_REQUEST_INPUT | ( | GetJointedActor | ,
 |  | MessageString | ,
 |  | MessageNxActorPtr |
 | ) |  |
PhysXPlugin::PhysXScene::DECLARE_REQUEST_INPUT | ( | Material | ,
 |  | MessageString | ,
 |  | MessageNxMaterialIndex |
 | ) |  |
bool PhysXPlugin::PhysXScene::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void PhysXPlugin::PhysXScene::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::PhysXObject.

void PhysXPlugin::PhysXScene::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::PhysXObject.

void PhysXScene::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXScene.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXScene.cpp
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::MessageNxActorWithName Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • MessageNxActorWithName
Public Member Functions | Public Attributes | List of all members
PhysXPlugin::MessageNxActorWithName Class Reference

#include <PhysXVreckoMessages.h>

Inheritance diagram for PhysXPlugin::MessageNxActorWithName:
vrecko::VreckoMessage

Public Member Functions

MessageNxActorWithName ()
MessageNxActorWithName (NxActor *actor, const char *name)
virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

NxActor * | _actor
std::string | _name

Constructor & Destructor Documentation

PhysXPlugin::MessageNxActorWithName::MessageNxActorWithName ( )
inline
PhysXPlugin::MessageNxActorWithName::MessageNxActorWithName | ( | NxActor * | actor,
 |  | const char * | name
 | ) |  |
inline

Member Function Documentation

virtual const char* PhysXPlugin::MessageNxActorWithName::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

NxActor* PhysXPlugin::MessageNxActorWithName::_actor
std::string PhysXPlugin::MessageNxActorWithName::_name
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXVreckoMessages.h
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Plane Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Plane
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Plane Class Reference

#include <Plane.h>

Inheritance diagram for PhysXPlugin::Plane:
PhysXPlugin::BaseActor PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Plane ()
~Plane ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from PhysXPlugin::BaseActor
BaseActor (const char *abName)
virtual | ~BaseActor ()
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Create ()
- Protected Member Functions inherited from PhysXPlugin::BaseActor
void | UpdateEnvironmentObject ()
DECLARE_INPUT (ResetPosition, MessageBool)
DECLARE_INPUT (MoveTo, MessageVec3)
DECLARE_INPUT (RotateTo, MessageQuat)
DECLARE_INPUT (DynamicActorOutputs, MessageBool)
DECLARE_OUTPUT (LinearMomentum, MessageVec3)
DECLARE_OUTPUT (AngularMomentum, MessageVec3)
DECLARE_OUTPUT (LinearVelocity, MessageVec3)
DECLARE_OUTPUT (AngularVelocity, MessageVec3)
DECLARE_REQUEST_OUTPUT (Material, MessageString, MessageNxMaterialIndex)
DECLARE_REQUEST_OUTPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)

Protected Attributes

NxPlaneShapeDesc | _planeDesc
- Protected Attributes inherited from PhysXPlugin::BaseActor
bool | _bDynamicActorOutputs
NxActorDesc | _actorDesc
NxBodyDesc | _bodyDesc
std::string | _MaterialName
NxMaterialIndex | _MaterialIndex
NxActor * | _pPO
float | _move_step_limit
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Plane::Plane ( )
PhysXPlugin::Plane::~Plane ( )
inline

Member Function Documentation

void Plane::Create ( )
protectedvirtual

Reimplemented from PhysXPlugin::BaseActor.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Plane::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented from PhysXPlugin::BaseActor.

bool Plane::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseActor.

Member Data Documentation

NxPlaneShapeDesc PhysXPlugin::Plane::_planeDesc
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Plane.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Plane.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PointInPlaneJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PointInPlaneJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::PointInPlaneJoint Class Reference

#include <PointInPlaneJoint.h>

Inheritance diagram for PhysXPlugin::PointInPlaneJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

PointInPlaneJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxPointInPlaneJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::PointInPlaneJoint::PointInPlaneJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::PointInPlaneJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::PointInPlaneJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxPointInPlaneJointDesc PhysXPlugin::PointInPlaneJoint::_descripter
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointInPlaneJoint.h
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PointOnLineJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PointOnLineJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::PointOnLineJoint Class Reference

#include <PointOnLineJoint.h>

Inheritance diagram for PhysXPlugin::PointOnLineJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

PointOnLineJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxPointOnLineJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::PointOnLineJoint::PointOnLineJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::PointOnLineJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::PointOnLineJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxPointOnLineJointDesc PhysXPlugin::PointOnLineJoint::_descripter
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointOnLineJoint.h
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PrismaticJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PrismaticJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::PrismaticJoint Class Reference

#include <PrismaticJoint.h>

Inheritance diagram for PhysXPlugin::PrismaticJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

PrismaticJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxPrismaticJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::PrismaticJoint::PrismaticJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::PrismaticJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::PrismaticJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxPrismaticJointDesc PhysXPlugin::PrismaticJoint::_descripter
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PrismaticJoint.h
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::PulleyJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PulleyJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::PulleyJoint Class Reference

#include <PulleyJoint.h>

Inheritance diagram for PhysXPlugin::PulleyJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

PulleyJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxPulleyJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::PulleyJoint::PulleyJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PhysXPlugin::PulleyJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
virtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::PulleyJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxPulleyJointDesc PhysXPlugin::PulleyJoint::_descripter
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PulleyJoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PulleyJoint.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::RemoteDebugger Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • RemoteDebugger
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::RemoteDebugger Class Reference

#include <RemoteDebugger.h>

Inheritance diagram for PhysXPlugin::RemoteDebugger:
PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

RemoteDebugger ()
virtual | ~RemoteDebugger ()
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode)
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxRemoteDebugger * | _pRemoteDebugger
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::PhysXObject
bool addUserDrawable (osg::Drawable *userDrawable)

Constructor & Destructor Documentation

PhysXPlugin::RemoteDebugger::RemoteDebugger ( )
inline
PhysXPlugin::RemoteDebugger::~RemoteDebugger ( )
virtual

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PhysXPlugin::RemoteDebugger::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual
bool PhysXPlugin::RemoteDebugger::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void PhysXPlugin::RemoteDebugger::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::PhysXObject.

Member Data Documentation

NxRemoteDebugger* PhysXPlugin::RemoteDebugger::_pRemoteDebugger
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RemoteDebugger.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RemoteDebugger.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::RevoluteJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • RevoluteJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::RevoluteJoint Class Reference

#include <RevoluteJoint.h>

Inheritance diagram for PhysXPlugin::RevoluteJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

RevoluteJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxRevoluteJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::RevoluteJoint::RevoluteJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PhysXPlugin::RevoluteJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
inlinevirtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::RevoluteJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxRevoluteJointDesc PhysXPlugin::RevoluteJoint::_descripter
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RevoluteJoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RevoluteJoint.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::Sphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Sphere
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
PhysXPlugin::Sphere Class Reference

#include <Sphere.h>

Inheritance diagram for PhysXPlugin::Sphere:
PhysXPlugin::BaseActor PhysXPlugin::UpdatablePhysXObject PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

Sphere ()
~Sphere ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from PhysXPlugin::BaseActor
BaseActor (const char *abName)
virtual | ~BaseActor ()
virtual void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::UpdatablePhysXObject
UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | Create ()
- Protected Member Functions inherited from PhysXPlugin::BaseActor
void | UpdateEnvironmentObject ()
DECLARE_INPUT (ResetPosition, MessageBool)
DECLARE_INPUT (MoveTo, MessageVec3)
DECLARE_INPUT (RotateTo, MessageQuat)
DECLARE_INPUT (DynamicActorOutputs, MessageBool)
DECLARE_OUTPUT (LinearMomentum, MessageVec3)
DECLARE_OUTPUT (AngularMomentum, MessageVec3)
DECLARE_OUTPUT (LinearVelocity, MessageVec3)
DECLARE_OUTPUT (AngularVelocity, MessageVec3)
DECLARE_REQUEST_OUTPUT (Material, MessageString, MessageNxMaterialIndex)
DECLARE_REQUEST_OUTPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool)

Protected Attributes

NxSphereShapeDesc | _sphereDesc
- Protected Attributes inherited from PhysXPlugin::BaseActor
bool | _bDynamicActorOutputs
NxActorDesc | _actorDesc
NxBodyDesc | _bodyDesc
std::string | _MaterialName
NxMaterialIndex | _MaterialIndex
NxActor * | _pPO
float | _move_step_limit
- Protected Attributes inherited from PhysXPlugin::UpdatablePhysXObject
std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Sphere::Sphere ( )
Sphere::~Sphere ( )

Member Function Documentation

void Sphere::Create ( )
protectedvirtual

Reimplemented from PhysXPlugin::BaseActor.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Sphere::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
virtual

Reimplemented from PhysXPlugin::BaseActor.

bool Sphere::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseActor.

Member Data Documentation

NxSphereShapeDesc PhysXPlugin::Sphere::_sphereDesc
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Sphere.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Sphere.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::SphericalJoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • SphericalJoint
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::SphericalJoint Class Reference

#include <SphericalJoint.h>

Inheritance diagram for PhysXPlugin::SphericalJoint:
PhysXPlugin::BaseJoint PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass

Public Member Functions

SphericalJoint ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument)
- Public Member Functions inherited from PhysXPlugin::BaseJoint
BaseJoint (const char *abName, NxJointDesc *descripter)
virtual | ~BaseJoint ()
virtual void | Create ()
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

NxSphericalJointDesc | _descripter
- Protected Attributes inherited from PhysXPlugin::BaseJoint
NxVec3 | _globalAnchor
NxVec3 | _globalAxis
std::string | _ID [2]
NxJointDesc * | _pBaseDescripter
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BaseJoint
DECLARE_REQUEST_OUTPUT (GetJointedActor, MessageString, MessageNxActorPtr)

Constructor & Destructor Documentation

PhysXPlugin::SphericalJoint::SphericalJoint ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PhysXPlugin::SphericalJoint::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument )
virtual

Reimplemented from PhysXPlugin::BaseJoint.

bool PhysXPlugin::SphericalJoint::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from PhysXPlugin::BaseJoint.

Member Data Documentation

NxSphericalJointDesc PhysXPlugin::SphericalJoint::_descripter
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/SphericalJoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/SphericalJoint.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: PhysXPlugin::UpdatablePhysXObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • UpdatablePhysXObject
Public Member Functions | Protected Attributes | List of all members
PhysXPlugin::UpdatablePhysXObject Class Referenceabstract

#include <UpdatablePhysXObject.h>

Inheritance diagram for PhysXPlugin::UpdatablePhysXObject:
PhysXPlugin::BasePhysXObject PhysXPlugin::PhysXObject vrecko::Ability vrecko::BaseClass PhysXPlugin::BaseActor PhysXPlugin::Cloth PhysXPlugin::Fluid PhysXPlugin::Box PhysXPlugin::Capsule PhysXPlugin::Plane PhysXPlugin::Sphere

Public Member Functions

UpdatablePhysXObject (const char *abName)
virtual | ~UpdatablePhysXObject ()
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | RegisterUpatablePO ()
virtual void | UpdateEnvironmentObject ()=0
DECLARE_REQUEST_OUTPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool)
- Public Member Functions inherited from PhysXPlugin::BasePhysXObject
BasePhysXObject (const char *abName)
virtual void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from PhysXPlugin::PhysXObject
PhysXObject (const char *abName)
virtual | ~PhysXObject ()
virtual void | BeforeInitialization ()
virtual void | AfterInitialization ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

std::string | _strRegisterPhysXObject
- Protected Attributes inherited from PhysXPlugin::BasePhysXObject
std::string | _strScene
NxScene * | _pScene
- Protected Attributes inherited from PhysXPlugin::PhysXObject
NxPhysicsSDK * | _pPhysicsSDK
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from PhysXPlugin::BasePhysXObject
virtual void Create ()=0
DECLARE_REQUEST_OUTPUT (PhysXScene, MessageString, MessageNxScenePtr)

Constructor & Destructor Documentation

PhysXPlugin::UpdatablePhysXObject::UpdatablePhysXObject ( const char * abName )
inline
virtual PhysXPlugin::UpdatablePhysXObject::~UpdatablePhysXObject ( )
inlinevirtual

Member Function Documentation

PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT | ( | RegisterPhysXObject | ,
 |  | MessageUpdatablePhysXObjectPtr | ,
 |  | MessageBool |
 | ) |  |
void PhysXPlugin::UpdatablePhysXObject::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from PhysXPlugin::BasePhysXObject.

void PhysXPlugin::UpdatablePhysXObject::RegisterUpatablePO ( )
virtual
virtual void PhysXPlugin::UpdatablePhysXObject::UpdateEnvironmentObject ( )
pure virtual

Implemented in PhysXPlugin::Cloth, PhysXPlugin::BaseActor, and PhysXPlugin::Fluid.

Member Data Documentation

std::string PhysXPlugin::UpdatablePhysXObject::_strRegisterPhysXObject
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/UpdatablePhysXObject.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/UpdatablePhysXObject.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Avatar Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Avatar
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Avatar Class Reference

#include <Avatar.h>

Inheritance diagram for VirtualFixture::Avatar:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Avatar ()
~Avatar ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

World::AvatarView * avatar_view
EnvironmentObject * head
EnvironmentObject * left_hand
EnvironmentObject * right_hand
EnvironmentObject * left_leg
EnvironmentObject * right_leg
EnvironmentObject * free_move_EO
long int | headEO_ID
long int | leftHandEO_ID
long int | rightHandEO_ID
long int | freeMoveEO_ID
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

Avatar::Avatar ( )
VirtualFixture::Avatar::~Avatar ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Avatar::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Avatar::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Avatar::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Avatar::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Avatar::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void Avatar::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

World::AvatarView* VirtualFixture::Avatar::avatar_view
protected
EnvironmentObject* VirtualFixture::Avatar::free_move_EO
protected
long int VirtualFixture::Avatar::freeMoveEO_ID
protected
EnvironmentObject* VirtualFixture::Avatar::head
protected
long int VirtualFixture::Avatar::headEO_ID
protected
EnvironmentObject* VirtualFixture::Avatar::left_hand
protected
EnvironmentObject* VirtualFixture::Avatar::left_leg
protected
long int VirtualFixture::Avatar::leftHandEO_ID
protected
EnvironmentObject* VirtualFixture::Avatar::owner
protected
EnvironmentObject * VirtualFixture::Avatar::right_hand
protected
EnvironmentObject * VirtualFixture::Avatar::right_leg
protected
long int VirtualFixture::Avatar::rightHandEO_ID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Avatar.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Avatar.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::AxisLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • AxisLock
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::AxisLock Class Reference

#include <AxisLock.h>

Inheritance diagram for VirtualFixture::AxisLock:

Public Member Functions

AxisLock ()
~AxisLock ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | locked
osg::Vec3 | position
float | nullradius
float | stiffness
string | defstring

Constructor & Destructor Documentation

AxisLock::AxisLock ( )
VirtualFixture::AxisLock::~AxisLock ( )
inline

Member Function Documentation

void AxisLock::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * AxisLock::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool AxisLock::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void AxisLock::postInitialize ( void )
void AxisLock::preInitialize ( void )
void AxisLock::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void AxisLock::update ( void )

Member Data Documentation

bool VirtualFixture::AxisLock::active
protected
bool VirtualFixture::AxisLock::all_on
protected
string VirtualFixture::AxisLock::defstring
protected
bool VirtualFixture::AxisLock::locked
protected
float VirtualFixture::AxisLock::nullradius
protected
PHANToM* VirtualFixture::AxisLock::PHANToMDevice
protected
osg::Vec3 VirtualFixture::AxisLock::position
protected
float VirtualFixture::AxisLock::stiffness
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AxisLock.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AxisLock.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Border Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Border
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Border Class Reference

#include <Border.h>

Inheritance diagram for VirtualFixture::Border:

Public Member Functions

Border ()
~Border ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
osg::Vec4 | color
osg::Vec4 | color2
float | transparency
float | transparency2
osg::Vec3 | direction
float | frequency
float | amplitude

Constructor & Destructor Documentation

Border::Border ( )
VirtualFixture::Border::~Border ( )
inline

Member Function Documentation

void Border::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Border::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Border::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Border::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Border::postInitialize ( void )
void Border::preInitialize ( void )
void Border::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Border::update ( void )

Member Data Documentation

bool VirtualFixture::Border::active
protected
bool VirtualFixture::Border::all_on
protected
float VirtualFixture::Border::amplitude
protected
osg::Vec4 VirtualFixture::Border::color
protected
osg::Vec4 VirtualFixture::Border::color2
protected
osg::Vec3 VirtualFixture::Border::direction
protected
float VirtualFixture::Border::frequency
protected
osg::Group* VirtualFixture::Border::gnode
protected
osg::Geode* VirtualFixture::Border::node
protected
osg::Geode* VirtualFixture::Border::node2
protected
PHANToM* VirtualFixture::Border::PHANToMDevice
protected
osg::MatrixTransform* VirtualFixture::Border::tnode
protected
float VirtualFixture::Border::transparency
protected
float VirtualFixture::Border::transparency2
protected
bool VirtualFixture::Border::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Border.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Border.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Box Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Box
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Box Class Reference

#include <Box.h>

Inheritance diagram for VirtualFixture::Box:

Public Member Functions

Box ()
~Box ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
float | transparency
osg::Vec3 | position
osg::Vec3 | size
osg::Vec3 | nullsize
float | stiffness

Constructor & Destructor Documentation

Box::Box ( )
VirtualFixture::Box::~Box ( )
inline

Member Function Documentation

void Box::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Box::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Box::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Box::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Box::postInitialize ( void )
void Box::preInitialize ( void )
void Box::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Box::update ( void )

Member Data Documentation

bool VirtualFixture::Box::active
protected
bool VirtualFixture::Box::all_on
protected
osg::Vec4 VirtualFixture::Box::color
protected
osg::Group* VirtualFixture::Box::gnode
protected
osg::Geode* VirtualFixture::Box::node
protected
osg::Vec3 VirtualFixture::Box::nullsize
protected
PHANToM* VirtualFixture::Box::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Box::position
protected
osg::Vec3 VirtualFixture::Box::size
protected
float VirtualFixture::Box::stiffness
protected
osg::MatrixTransform* VirtualFixture::Box::tnode
protected
float VirtualFixture::Box::transparency
protected
bool VirtualFixture::Box::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Box.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Box.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Cone Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Cone
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Cone Class Reference

#include <Cone.h>

Inheritance diagram for VirtualFixture::Cone:

Public Member Functions

Cone ()
~Cone ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
osg::Vec4 | color
osg::Vec4 | color2
float | transparency
float | transparency2
osg::Vec3 | position
osg::Vec3 | vector
float | radius1
float | radius2
float | nullradius
float | stiffness
float | pushingforce
bool | pushing

Constructor & Destructor Documentation

Cone::Cone ( )
VirtualFixture::Cone::~Cone ( )
inline

Member Function Documentation

void Cone::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Cone::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Cone::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Cone::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Cone::postInitialize ( void )
void Cone::preInitialize ( void )
void Cone::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Cone::update ( void )

Member Data Documentation

bool VirtualFixture::Cone::active
protected
bool VirtualFixture::Cone::all_on
protected
osg::Vec4 VirtualFixture::Cone::color
protected
osg::Vec4 VirtualFixture::Cone::color2
protected
osg::Group* VirtualFixture::Cone::gnode
protected
osg::Geode* VirtualFixture::Cone::node
protected
osg::Geode* VirtualFixture::Cone::node2
protected
float VirtualFixture::Cone::nullradius
protected
PHANToM* VirtualFixture::Cone::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Cone::position
protected
bool VirtualFixture::Cone::pushing
protected
float VirtualFixture::Cone::pushingforce
protected
float VirtualFixture::Cone::radius1
protected
float VirtualFixture::Cone::radius2
protected
float VirtualFixture::Cone::stiffness
protected
osg::MatrixTransform* VirtualFixture::Cone::tnode
protected
float VirtualFixture::Cone::transparency
protected
float VirtualFixture::Cone::transparency2
protected
osg::Vec3 VirtualFixture::Cone::vector
protected
bool VirtualFixture::Cone::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cone.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cone.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Cylinder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Cylinder
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Cylinder Class Reference

#include <Cylinder.h>

Inheritance diagram for VirtualFixture::Cylinder:

Public Member Functions

Cylinder ()
~Cylinder ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
float | transparency
float | transparency2
osg::Vec4 | color
osg::Vec4 | color2
osg::Vec3 | position
osg::Vec3 | vector
float | radius
float | nullradius
float | stiffness
float | pushingforce
bool | pushing

Constructor & Destructor Documentation

Cylinder::Cylinder ( )
VirtualFixture::Cylinder::~Cylinder ( )
inline

Member Function Documentation

void Cylinder::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Cylinder::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Cylinder::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Cylinder::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Cylinder::postInitialize ( void )
void Cylinder::preInitialize ( void )
void Cylinder::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Cylinder::update ( void )

Member Data Documentation

bool VirtualFixture::Cylinder::active
protected
bool VirtualFixture::Cylinder::all_on
protected
osg::Vec4 VirtualFixture::Cylinder::color
protected
osg::Vec4 VirtualFixture::Cylinder::color2
protected
osg::Group* VirtualFixture::Cylinder::gnode
protected
osg::Geode* VirtualFixture::Cylinder::node
protected
osg::Geode* VirtualFixture::Cylinder::node2
protected
float VirtualFixture::Cylinder::nullradius
protected
PHANToM* VirtualFixture::Cylinder::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Cylinder::position
protected
bool VirtualFixture::Cylinder::pushing
protected
float VirtualFixture::Cylinder::pushingforce
protected
float VirtualFixture::Cylinder::radius
protected
float VirtualFixture::Cylinder::stiffness
protected
osg::MatrixTransform* VirtualFixture::Cylinder::tnode
protected
float VirtualFixture::Cylinder::transparency
protected
float VirtualFixture::Cylinder::transparency2
protected
osg::Vec3 VirtualFixture::Cylinder::vector
protected
bool VirtualFixture::Cylinder::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cylinder.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cylinder.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Damper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Damper
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Damper Class Reference

#include <Damper.h>

Inheritance diagram for VirtualFixture::Damper:

Public Member Functions

Damper ()
~Damper ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
float | minspeed
float | speed2force

Constructor & Destructor Documentation

Damper::Damper ( )
VirtualFixture::Damper::~Damper ( )
inline

Member Function Documentation

void Damper::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Damper::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Damper::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Damper::postInitialize ( void )
void Damper::preInitialize ( void )
void Damper::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Damper::update ( void )

Member Data Documentation

bool VirtualFixture::Damper::active
protected
bool VirtualFixture::Damper::all_on
protected
float VirtualFixture::Damper::minspeed
protected
PHANToM* VirtualFixture::Damper::PHANToMDevice
protected
float VirtualFixture::Damper::speed2force
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Damper.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Damper.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Drag Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Drag
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Drag Class Reference

#include <Drag.h>

Inheritance diagram for VirtualFixture::Drag:

Public Member Functions

Drag ()
~Drag ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | dispatchEvent (const std::string &pInputName, void *pValue)
void | dispatchMessage (Message *pMessage)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
void | displayAllGestures (void)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | force
osg::Vec3 | position
CPlayer * player

Constructor & Destructor Documentation

Drag::Drag ( )
VirtualFixture::Drag::~Drag ( )
inline

Member Function Documentation

void Drag::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Drag::dispatchEvent | ( | const std::string & | pInputName,
 |  | void * | pValue
 | ) |  |
void Drag::dispatchMessage ( Message * pMessage )
void Drag::displayAllGestures ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Drag::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Drag::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Drag::postInitialize ( void )
void Drag::preInitialize ( void )
void Drag::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Drag::update ( void )

Member Data Documentation

bool VirtualFixture::Drag::active
protected
bool VirtualFixture::Drag::all_on
protected
bool VirtualFixture::Drag::force
protected
PHANToM* VirtualFixture::Drag::PHANToMDevice
protected
CPlayer* VirtualFixture::Drag::player
protected
osg::Vec3 VirtualFixture::Drag::position
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Drag.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Drag.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Filter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Filter
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Filter Class Reference

#include <Filter.h>

Inheritance diagram for VirtualFixture::Filter:

Public Member Functions

Filter ()
~Filter ()
void | Filter_Initialize (void)
void | Filter_Update (void)
void | Filter_SetX_hat1 (osg::Vec3 nx)
void | Filter_SetX_hat2 (osg::Vec3 nx)
void | Filter_Mesurement (osg::Vec3 z)
void | Filter_Prediction (void)
osg::Vec3 | Filter_GetPosition (void)
osg::Vec3 | Filter_GetVelocity (void)
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
unsigned int | freq
float | k1
float | k2
osg::Vec3 | x_hat1
osg::Vec3 | x_hat2
osg::Vec3 | x_hat_prev1
osg::Vec3 | x_hat_prev2
osg::Vec3 | inovation

Constructor & Destructor Documentation

VirtualFixture::Filter::Filter ( )
VirtualFixture::Filter::~Filter ( )
inline

Member Function Documentation

void VirtualFixture::Filter::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

osg::Vec3 VirtualFixture::Filter::Filter_GetPosition ( void )
osg::Vec3 VirtualFixture::Filter::Filter_GetVelocity ( void )
void VirtualFixture::Filter::Filter_Initialize ( void )
void VirtualFixture::Filter::Filter_Mesurement ( osg::Vec3 z )
void VirtualFixture::Filter::Filter_Prediction ( void )
void VirtualFixture::Filter::Filter_SetX_hat1 ( osg::Vec3 nx )
void VirtualFixture::Filter::Filter_SetX_hat2 ( osg::Vec3 nx )
void VirtualFixture::Filter::Filter_Update ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* VirtualFixture::Filter::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
bool VirtualFixture::Filter::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void VirtualFixture::Filter::postInitialize ( void )
void VirtualFixture::Filter::preInitialize ( void )
void VirtualFixture::Filter::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void VirtualFixture::Filter::update ( void )

Member Data Documentation

bool VirtualFixture::Filter::active
protected
bool VirtualFixture::Filter::all_on
protected
unsigned int VirtualFixture::Filter::freq
protected
osg::Vec3 VirtualFixture::Filter::inovation
protected
float VirtualFixture::Filter::k1
protected
float VirtualFixture::Filter::k2
protected
PHANToM* VirtualFixture::Filter::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Filter::x_hat1
protected
osg::Vec3 VirtualFixture::Filter::x_hat2
protected
osg::Vec3 VirtualFixture::Filter::x_hat_prev1
protected
osg::Vec3 VirtualFixture::Filter::x_hat_prev2
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Filter.h
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Grid Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Grid
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Grid Class Reference

#include <Grid.h>

Inheritance diagram for VirtualFixture::Grid:

Public Member Functions

Grid ()
~Grid ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
osg::Vec3 | position
osg::Vec3 | vector
float | nullradius
float | stiffness
float | gravity
bool | gravity_on

Constructor & Destructor Documentation

Grid::Grid ( )
VirtualFixture::Grid::~Grid ( )
inline

Member Function Documentation

void Grid::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Grid::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Grid::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Grid::postInitialize ( void )
void Grid::preInitialize ( void )
void Grid::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Grid::update ( void )

Member Data Documentation

bool VirtualFixture::Grid::active
protected
bool VirtualFixture::Grid::all_on
protected
float VirtualFixture::Grid::gravity
protected
bool VirtualFixture::Grid::gravity_on
protected
float VirtualFixture::Grid::nullradius
protected
PHANToM* VirtualFixture::Grid::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Grid::position
protected
float VirtualFixture::Grid::stiffness
protected
osg::Vec3 VirtualFixture::Grid::vector
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Grid.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Grid.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Log Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Log
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Log Class Reference

#include <Log.h>

Inheritance diagram for VirtualFixture::Log:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Log ()
~Log ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

osg::Vec3 | position
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

Log::Log ( )
VirtualFixture::Log::~Log ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Log::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Log::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Log::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Log::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Log::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void Log::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 VirtualFixture::Log::position
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Log.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Log.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Marker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Marker
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Marker Class Reference

#include <Marker.h>

Inheritance diagram for VirtualFixture::Marker:

Public Member Functions

Marker ()
Marker (int newid, osg::Vec3 newposition)
Marker (int newid, osg::Vec3 newposition, std::string newlabel, std::string newdescribtion)
~Marker ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | setPosition (osg::Vec3 newposition)
osg::Vec3 | getPosition ()
void | setId (int newid)
int | getId ()
void | setLabel (std::string newlabel)
std::string | getLabel ()
void | setDescribtion (std::string newdescribtion)
std::string | getDescribtion ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
osg::Vec3 | position
int | id
std::string | label
std::string | describtion

Constructor & Destructor Documentation

Marker::Marker ( )
VirtualFixture::Marker::Marker | ( | int | newid,
 |  | osg::Vec3 | newposition
 | ) |  |
VirtualFixture::Marker::Marker | ( | int | newid,
 |  | osg::Vec3 | newposition,
 |  | std::string | newlabel,
 |  | std::string | newdescribtion
 | ) |  |
VirtualFixture::Marker::~Marker ( )
inline

Member Function Documentation

void Marker::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

std::string VirtualFixture::Marker::getDescribtion ( )
inline
int VirtualFixture::Marker::getId ( )
inline
std::string VirtualFixture::Marker::getLabel ( )
inline
osg::Vec3 VirtualFixture::Marker::getPosition ( )
inline
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Marker::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Marker::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Marker::postInitialize ( void )
void Marker::preInitialize ( void )
void Marker::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void VirtualFixture::Marker::setDescribtion ( std::string newdescribtion )
inline
void VirtualFixture::Marker::setId ( int newid )
inline
void VirtualFixture::Marker::setLabel ( std::string newlabel )
inline
void VirtualFixture::Marker::setPosition ( osg::Vec3 newposition )
inline
void Marker::update ( void )

Member Data Documentation

bool VirtualFixture::Marker::active
protected
bool VirtualFixture::Marker::all_on
protected
std::string VirtualFixture::Marker::describtion
protected
int VirtualFixture::Marker::id
protected
std::string VirtualFixture::Marker::label
protected
PHANToM* VirtualFixture::Marker::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Marker::position
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Marker.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Marker.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::MarkerFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • MarkerFactory
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::MarkerFactory Class Reference

#include <MarkerFactory.h>

Inheritance diagram for VirtualFixture::MarkerFactory:

Public Member Functions

MarkerFactory ()
~MarkerFactory ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
int | addMarker ()
void | removeAllMarkers ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
int | num_of_markers
vector< Marker > | markers
osg::Vec3 | act_position

Constructor & Destructor Documentation

MarkerFactory::MarkerFactory ( )
VirtualFixture::MarkerFactory::~MarkerFactory ( )
inline

Member Function Documentation

int MarkerFactory::addMarker ( void )
void MarkerFactory::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * MarkerFactory::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool MarkerFactory::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void MarkerFactory::postInitialize ( void )
void MarkerFactory::preInitialize ( void )
void MarkerFactory::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void MarkerFactory::removeAllMarkers ( void )
void MarkerFactory::update ( void )

Member Data Documentation

osg::Vec3 VirtualFixture::MarkerFactory::act_position
protected
bool VirtualFixture::MarkerFactory::active
protected
bool VirtualFixture::MarkerFactory::all_on
protected
vector<Marker> VirtualFixture::MarkerFactory::markers
protected
int VirtualFixture::MarkerFactory::num_of_markers
protected
PHANToM* VirtualFixture::MarkerFactory::PHANToMDevice
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/MarkerFactory.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/MarkerFactory.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::NavSphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • NavSphere
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::NavSphere Class Reference

#include <NavSphere.h>

Inheritance diagram for VirtualFixture::NavSphere:

Public Member Functions

NavSphere ()
~NavSphere ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
float | radius
float | stiffness
bool | store_origin_flag
osg::Vec3 | origin
int | attenuationtype
float | attenuationparam
osg::Vec3 | actpos
osg::Vec3 | actdir
bool | vibration_flag
float | amplitude
float | frequency
osg::Vec3 | direction
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geometry * | geom
osg::Vec4 | color
float | transparency

Constructor & Destructor Documentation

NavSphere::NavSphere ( )
VirtualFixture::NavSphere::~NavSphere ( )
inline

Member Function Documentation

void NavSphere::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void NavSphere::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * NavSphere::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool NavSphere::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void NavSphere::postInitialize ( void )
void NavSphere::preInitialize ( void )
void NavSphere::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void NavSphere::update ( void )

Member Data Documentation

osg::Vec3 VirtualFixture::NavSphere::actdir
protected
bool VirtualFixture::NavSphere::active
protected
osg::Vec3 VirtualFixture::NavSphere::actpos
protected
bool VirtualFixture::NavSphere::all_on
protected
float VirtualFixture::NavSphere::amplitude
protected
float VirtualFixture::NavSphere::attenuationparam
protected
int VirtualFixture::NavSphere::attenuationtype
protected
osg::Vec4 VirtualFixture::NavSphere::color
protected
osg::Vec3 VirtualFixture::NavSphere::direction
protected
float VirtualFixture::NavSphere::frequency
protected
osg::Geometry* VirtualFixture::NavSphere::geom
protected
osg::Group* VirtualFixture::NavSphere::gnode
protected
osg::Geode* VirtualFixture::NavSphere::node
protected
osg::Vec3 VirtualFixture::NavSphere::origin
protected
PHANToM* VirtualFixture::NavSphere::PHANToMDevice
protected
float VirtualFixture::NavSphere::radius
protected
float VirtualFixture::NavSphere::stiffness
protected
bool VirtualFixture::NavSphere::store_origin_flag
protected
osg::MatrixTransform* VirtualFixture::NavSphere::tnode
protected
float VirtualFixture::NavSphere::transparency
protected
bool VirtualFixture::NavSphere::vibration_flag
protected
bool VirtualFixture::NavSphere::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/NavSphere.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/NavSphere.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Plane Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Plane
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Plane Class Reference

#include <Plane.h>

Inheritance diagram for VirtualFixture::Plane:

Public Member Functions

Plane ()
~Plane ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
float | transparency
float | transparency2
osg::Vec4 | color
osg::Vec4 | color2
osg::Vec3 | position
osg::Vec3 | vector
float | radius
float | nullradius
float | stiffness
float | pushingforce
bool | pushing

Constructor & Destructor Documentation

Plane::Plane ( )
VirtualFixture::Plane::~Plane ( )
inline

Member Function Documentation

void Plane::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Plane::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Plane::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Plane::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Plane::postInitialize ( void )
void Plane::preInitialize ( void )
void Plane::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Plane::update ( void )

Member Data Documentation

bool VirtualFixture::Plane::active
protected
bool VirtualFixture::Plane::all_on
protected
osg::Vec4 VirtualFixture::Plane::color
protected
osg::Vec4 VirtualFixture::Plane::color2
protected
osg::Group* VirtualFixture::Plane::gnode
protected
osg::Geode* VirtualFixture::Plane::node
protected
osg::Geode* VirtualFixture::Plane::node2
protected
float VirtualFixture::Plane::nullradius
protected
PHANToM* VirtualFixture::Plane::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Plane::position
protected
bool VirtualFixture::Plane::pushing
protected
float VirtualFixture::Plane::pushingforce
protected
float VirtualFixture::Plane::radius
protected
float VirtualFixture::Plane::stiffness
protected
osg::MatrixTransform* VirtualFixture::Plane::tnode
protected
float VirtualFixture::Plane::transparency
protected
float VirtualFixture::Plane::transparency2
protected
osg::Vec3 VirtualFixture::Plane::vector
protected
bool VirtualFixture::Plane::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Plane.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Plane.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::ProxiBorder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiBorder
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::ProxiBorder Class Reference

#include <ProxiBorder.h>

Inheritance diagram for VirtualFixture::ProxiBorder:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ProxiBorder ()
~ProxiBorder ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
osg::Vec4 | color
float | transparency
osg::Vec4 | color2
float | transparency2
bool | once
bool | justonce
bool | sendflag
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ProxiBorder::ProxiBorder ( )
VirtualFixture::ProxiBorder::~ProxiBorder ( )
inline

Member Function Documentation

void ProxiBorder::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ProxiBorder::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool ProxiBorder::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ProxiBorder::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiBorder::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiBorder::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ProxiBorder::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::ProxiBorder::active
protected
bool VirtualFixture::ProxiBorder::all_on
protected
osg::Vec4 VirtualFixture::ProxiBorder::color
protected
osg::Vec4 VirtualFixture::ProxiBorder::color2
protected
osg::Group* VirtualFixture::ProxiBorder::gnode
protected
bool VirtualFixture::ProxiBorder::justonce
protected
osg::Geode* VirtualFixture::ProxiBorder::node
protected
osg::Geode* VirtualFixture::ProxiBorder::node2
protected
bool VirtualFixture::ProxiBorder::once
protected
PHANToM* VirtualFixture::ProxiBorder::PHANToMDevice
protected
bool VirtualFixture::ProxiBorder::sendflag
protected
osg::MatrixTransform* VirtualFixture::ProxiBorder::tnode
protected
float VirtualFixture::ProxiBorder::transparency
protected
float VirtualFixture::ProxiBorder::transparency2
protected
bool VirtualFixture::ProxiBorder::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBorder.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBorder.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::ProxiBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiBox
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::ProxiBox Class Reference

#include <ProxiBox.h>

Inheritance diagram for VirtualFixture::ProxiBox:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ProxiBox ()
~ProxiBox ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
float | transparency
osg::Vec3 | position
osg::Vec3 | size
bool | once
bool | justonce
bool | sendflag
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ProxiBox::ProxiBox ( )
VirtualFixture::ProxiBox::~ProxiBox ( )
inline

Member Function Documentation

void ProxiBox::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ProxiBox::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool ProxiBox::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ProxiBox::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiBox::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiBox::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ProxiBox::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::ProxiBox::active
protected
bool VirtualFixture::ProxiBox::all_on
protected
osg::Vec4 VirtualFixture::ProxiBox::color
protected
osg::Group* VirtualFixture::ProxiBox::gnode
protected
bool VirtualFixture::ProxiBox::justonce
protected
osg::Geode* VirtualFixture::ProxiBox::node
protected
bool VirtualFixture::ProxiBox::once
protected
PHANToM* VirtualFixture::ProxiBox::PHANToMDevice
protected
osg::Vec3 VirtualFixture::ProxiBox::position
protected
bool VirtualFixture::ProxiBox::sendflag
protected
osg::Vec3 VirtualFixture::ProxiBox::size
protected
osg::MatrixTransform* VirtualFixture::ProxiBox::tnode
protected
float VirtualFixture::ProxiBox::transparency
protected
bool VirtualFixture::ProxiBox::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBox.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBox.cpp
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::ProxiCone Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiCone
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::ProxiCone Class Reference

#include <ProxiCone.h>

Inheritance diagram for VirtualFixture::ProxiCone:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ProxiCone ()
~ProxiCone ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
float | transparency
osg::Vec3 | position
float | radius
bool | once
bool | justonce
bool | sendflag
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ProxiCone::ProxiCone ( )
VirtualFixture::ProxiCone::~ProxiCone ( )
inline

Member Function Documentation

void ProxiCone::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ProxiCone::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool ProxiCone::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ProxiCone::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiCone::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiCone::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ProxiCone::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::ProxiCone::active
protected
bool VirtualFixture::ProxiCone::all_on
protected
osg::Vec4 VirtualFixture::ProxiCone::color
protected
osg::Group* VirtualFixture::ProxiCone::gnode
protected
bool VirtualFixture::ProxiCone::justonce
protected
osg::Geode* VirtualFixture::ProxiCone::node
protected
bool VirtualFixture::ProxiCone::once
protected
PHANToM* VirtualFixture::ProxiCone::PHANToMDevice
protected
osg::Vec3 VirtualFixture::ProxiCone::position
protected
float VirtualFixture::ProxiCone::radius
protected
bool VirtualFixture::ProxiCone::sendflag
protected
osg::MatrixTransform* VirtualFixture::ProxiCone::tnode
protected
float VirtualFixture::ProxiCone::transparency
protected
bool VirtualFixture::ProxiCone::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCone.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCone.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::ProxiCylinder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiCylinder
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::ProxiCylinder Class Reference

#include <ProxiCylinder.h>

Inheritance diagram for VirtualFixture::ProxiCylinder:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ProxiCylinder ()
~ProxiCylinder ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
float | transparency
osg::Vec3 | vector
osg::Vec3 | position
float | radius
bool | once
bool | justonce
bool | sendflag
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ProxiCylinder::ProxiCylinder ( )
VirtualFixture::ProxiCylinder::~ProxiCylinder ( )
inline

Member Function Documentation

void ProxiCylinder::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ProxiCylinder::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool ProxiCylinder::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ProxiCylinder::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiCylinder::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiCylinder::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ProxiCylinder::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::ProxiCylinder::active
protected
bool VirtualFixture::ProxiCylinder::all_on
protected
osg::Vec4 VirtualFixture::ProxiCylinder::color
protected
osg::Group* VirtualFixture::ProxiCylinder::gnode
protected
bool VirtualFixture::ProxiCylinder::justonce
protected
osg::Geode* VirtualFixture::ProxiCylinder::node
protected
bool VirtualFixture::ProxiCylinder::once
protected
PHANToM* VirtualFixture::ProxiCylinder::PHANToMDevice
protected
osg::Vec3 VirtualFixture::ProxiCylinder::position
protected
float VirtualFixture::ProxiCylinder::radius
protected
bool VirtualFixture::ProxiCylinder::sendflag
protected
osg::MatrixTransform* VirtualFixture::ProxiCylinder::tnode
protected
float VirtualFixture::ProxiCylinder::transparency
protected
osg::Vec3 VirtualFixture::ProxiCylinder::vector
protected
bool VirtualFixture::ProxiCylinder::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCylinder.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCylinder.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::ProxiSphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiSphere
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::ProxiSphere Class Reference

#include <ProxiSphere.h>

Inheritance diagram for VirtualFixture::ProxiSphere:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ProxiSphere ()
~ProxiSphere ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
float | transparency
osg::Vec3 | position
float | radius
bool | once
bool | justonce
bool | sendflag
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ProxiSphere::ProxiSphere ( )
VirtualFixture::ProxiSphere::~ProxiSphere ( )
inline

Member Function Documentation

void ProxiSphere::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ProxiSphere::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool ProxiSphere::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ProxiSphere::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiSphere::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ProxiSphere::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ProxiSphere::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::ProxiSphere::active
protected
bool VirtualFixture::ProxiSphere::all_on
protected
osg::Vec4 VirtualFixture::ProxiSphere::color
protected
osg::Group* VirtualFixture::ProxiSphere::gnode
protected
bool VirtualFixture::ProxiSphere::justonce
protected
osg::Geode* VirtualFixture::ProxiSphere::node
protected
bool VirtualFixture::ProxiSphere::once
protected
PHANToM* VirtualFixture::ProxiSphere::PHANToMDevice
protected
osg::Vec3 VirtualFixture::ProxiSphere::position
protected
float VirtualFixture::ProxiSphere::radius
protected
bool VirtualFixture::ProxiSphere::sendflag
protected
osg::MatrixTransform* VirtualFixture::ProxiSphere::tnode
protected
float VirtualFixture::ProxiSphere::transparency
protected
bool VirtualFixture::ProxiSphere::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiSphere.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiSphere.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Sphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Sphere
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Sphere Class Reference

#include <Sphere.h>

Inheritance diagram for VirtualFixture::Sphere:

Public Member Functions

Sphere ()
~Sphere ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
void | display (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Geode * | node2
osg::Vec4 | color
osg::Vec4 | color2
float | transparency
float | transparency2
osg::Vec3 | position
float | radius
float | nullradius
float | stiffness

Constructor & Destructor Documentation

Sphere::Sphere ( )
VirtualFixture::Sphere::~Sphere ( )
inline

Member Function Documentation

void Sphere::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

void Sphere::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Sphere::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Sphere::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Sphere::postInitialize ( void )
void Sphere::preInitialize ( void )
void Sphere::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Sphere::update ( void )

Member Data Documentation

bool VirtualFixture::Sphere::active
protected
bool VirtualFixture::Sphere::all_on
protected
osg::Vec4 VirtualFixture::Sphere::color
protected
osg::Vec4 VirtualFixture::Sphere::color2
protected
osg::Group* VirtualFixture::Sphere::gnode
protected
osg::Geode* VirtualFixture::Sphere::node
protected
osg::Geode* VirtualFixture::Sphere::node2
protected
float VirtualFixture::Sphere::nullradius
protected
PHANToM* VirtualFixture::Sphere::PHANToMDevice
protected
osg::Vec3 VirtualFixture::Sphere::position
protected
float VirtualFixture::Sphere::radius
protected
float VirtualFixture::Sphere::stiffness
protected
osg::MatrixTransform* VirtualFixture::Sphere::tnode
protected
float VirtualFixture::Sphere::transparency
protected
float VirtualFixture::Sphere::transparency2
protected
bool VirtualFixture::Sphere::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Sphere.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Sphere.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Trace Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Trace
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::Trace Class Reference

#include <Trace.h>

Inheritance diagram for VirtualFixture::Trace:
vrecko::Ability vrecko::BaseClass

Public Member Functions

Trace ()
~Trace ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | display (void)
void | addMarker (osg::Vec3 position)
void | removeAllMarkers ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

bool | active
bool | visible
osg::MatrixTransform * | tnode
osg::Group * | gnode
osg::Geode * | node
osg::Vec4 | color
osg::Vec4 | color2
float | transparency
float | transparency2
float | radius
float | mindistance
int | num_of_markers
osg::Vec3 | latestpos
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

Trace::Trace ( )
VirtualFixture::Trace::~Trace ( )
inline

Member Function Documentation

void Trace::addMarker ( osg::Vec3 position )
void Trace::display ( void )
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Trace::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Trace::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void Trace::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Trace::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void Trace::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void Trace::removeAllMarkers ( void )
void Trace::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool VirtualFixture::Trace::active
protected
osg::Vec4 VirtualFixture::Trace::color
protected
osg::Vec4 VirtualFixture::Trace::color2
protected
osg::Group* VirtualFixture::Trace::gnode
protected
osg::Vec3 VirtualFixture::Trace::latestpos
protected
float VirtualFixture::Trace::mindistance
protected
osg::Geode* VirtualFixture::Trace::node
protected
int VirtualFixture::Trace::num_of_markers
protected
float VirtualFixture::Trace::radius
protected
osg::MatrixTransform* VirtualFixture::Trace::tnode
protected
float VirtualFixture::Trace::transparency
protected
float VirtualFixture::Trace::transparency2
protected
bool VirtualFixture::Trace::visible
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Trace.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Trace.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::Vibration Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Vibration
Public Member Functions | Public Attributes | Protected Attributes | List of all members
VirtualFixture::Vibration Class Reference

#include <Vibration.h>

Inheritance diagram for VirtualFixture::Vibration:

Public Member Functions

Vibration ()
~Vibration ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Public Attributes

bool | active
float | frequency
float | amplitude
osg::Vec3 | direction
float | duration
osg::Timer_t | vstart_tick

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on

Constructor & Destructor Documentation

Vibration::Vibration ( )
VirtualFixture::Vibration::~Vibration ( )
inline

Member Function Documentation

void Vibration::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Vibration::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool Vibration::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void Vibration::postInitialize ( void )
void Vibration::preInitialize ( void )
void Vibration::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void Vibration::update ( void )

Member Data Documentation

bool VirtualFixture::Vibration::active
bool VirtualFixture::Vibration::all_on
protected
float VirtualFixture::Vibration::amplitude
osg::Vec3 VirtualFixture::Vibration::direction
float VirtualFixture::Vibration::duration
float VirtualFixture::Vibration::frequency
PHANToM* VirtualFixture::Vibration::PHANToMDevice
protected
osg::Timer_t VirtualFixture::Vibration::vstart_tick
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Vibration.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Vibration.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::VibrationLabel Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • VibrationLabel
Public Member Functions | Public Attributes | Protected Attributes | List of all members
VirtualFixture::VibrationLabel Class Reference

#include <VibrationLabel.h>

Inheritance diagram for VirtualFixture::VibrationLabel:

Public Member Functions

VibrationLabel ()
~VibrationLabel ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Public Attributes

bool | active
float | frequency
float | amplitude
osg::Vec3 | direction

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on

Constructor & Destructor Documentation

VibrationLabel::VibrationLabel ( )
VirtualFixture::VibrationLabel::~VibrationLabel ( )
inline

Member Function Documentation

void VibrationLabel::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * VibrationLabel::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool VibrationLabel::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void VibrationLabel::postInitialize ( void )
void VibrationLabel::preInitialize ( void )
void VibrationLabel::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void VibrationLabel::update ( void )

Member Data Documentation

bool VirtualFixture::VibrationLabel::active
bool VirtualFixture::VibrationLabel::all_on
protected
float VirtualFixture::VibrationLabel::amplitude
osg::Vec3 VirtualFixture::VibrationLabel::direction
float VirtualFixture::VibrationLabel::frequency
PHANToM* VirtualFixture::VibrationLabel::PHANToMDevice
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabel.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabel.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VirtualFixture::VibrationLabelActivator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • VibrationLabelActivator
Public Member Functions | Protected Attributes | List of all members
VirtualFixture::VibrationLabelActivator Class Reference

#include <VibrationLabelActivator.h>

Inheritance diagram for VirtualFixture::VibrationLabelActivator:

Public Member Functions

VibrationLabelActivator ()
~VibrationLabelActivator ()
void | apply (PHANToM *pPHANToM, osg::Vec3 &force)
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
void | postInitialize (void)
void | update (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
bool | active

Constructor & Destructor Documentation

VibrationLabelActivator::VibrationLabelActivator ( )
VirtualFixture::VibrationLabelActivator::~VibrationLabelActivator ( )
inline

Member Function Documentation

void VibrationLabelActivator::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |

Process the Events.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * VibrationLabelActivator::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool VibrationLabelActivator::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
void VibrationLabelActivator::postInitialize ( void )
void VibrationLabelActivator::preInitialize ( void )
void VibrationLabelActivator::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void VibrationLabelActivator::update ( void )

Member Data Documentation

bool VirtualFixture::VibrationLabelActivator::active
protected
bool VirtualFixture::VibrationLabelActivator::all_on
protected
PHANToM* VirtualFixture::VibrationLabelActivator::PHANToMDevice
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabelActivator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabelActivator.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: VK_NoStepInto_Namespace::DynamicArray< _Type > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VK_NoStepInto_Namespace
  • DynamicArray
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
VK_NoStepInto_Namespace::DynamicArray< _Type > Class Template Reference

#include <DynamicArray.h>

Public Member Functions

DAINLINE unsigned long | GetAllocated ()
DynamicArray (void)
DynamicArray (unsigned long _dwAllocBy)
DynamicArray (DynamicArray< _Type > &src)
~DynamicArray (void)
DAINLINE const unsigned int | size () const
DAINLINE void | push_back (const _Type &elem)
bool | FreeArray (void)
bool | Truncate (void)
bool | PrepareNext (unsigned long _dwNum)
bool | Delete (unsigned long dwStartIndex, unsigned long dwNumStructs)
DAINLINE bool | DeleteAll (void)
bool | clear (void)
DAINLINE bool | DeleteUnnecessary (void)
bool | Insert (unsigned long dwStartIndex, unsigned long dwNumStructs)
bool | CopyFrom (DynamicArray< _Type > *src)
bool | Swap (unsigned long dwIndex1, unsigned long dwIndex2)
DAINLINE bool | AddItem (const _Type &newItem)
DAINLINE _Type & | Last (void)
DAINLINE _Type & | Act (void)
DAINLINE unsigned long & | ActDWORD (void)
DAINLINE int & | ActInt (void)
DAINLINE _Type & | Get (unsigned long index)
DAINLINE const _Type & | Get (unsigned long index) const
DAINLINE bool | StoreByte (unsigned char bData)
DAINLINE bool | StoreDWORD (unsigned long dwData)
DAINLINE unsigned char | ReadByte (void)
DAINLINE unsigned long | ReadDWORD (void)
DAINLINE _Type & | operator[] (unsigned long dw)
DAINLINE const _Type & | operator[] (unsigned long dw) const
DAINLINE _Type & | at (unsigned long dw)
DAINLINE const _Type & | at (unsigned long dw) const

Public Attributes

_Type * | lpBuffer
unsigned long | dwNum

Protected Member Functions

bool InitItems (unsigned long dwStartIndex, unsigned long dwNumStructs)

Protected Attributes

unsigned long | dwAllocBy
unsigned long | dwAlloc
unsigned long | dwInited

Constructor & Destructor Documentation

template<class _Type >
VK_NoStepInto_Namespace::DynamicArray< _Type >::DynamicArray ( void )
template<class _Type >
VK_NoStepInto_Namespace::DynamicArray< _Type >::DynamicArray ( unsigned long _dwAllocBy )
template<class _Type>
VK_NoStepInto_Namespace::DynamicArray< _Type >::DynamicArray ( DynamicArray< _Type > & src )
template<class _Type >
VK_NoStepInto_Namespace::DynamicArray< _Type >::~DynamicArray ( void )

Member Function Documentation

template<class _Type >
DAINLINE _Type & VK_NoStepInto_Namespace::DynamicArray< _Type >::Act ( void )
template<class _Type >
DAINLINE unsigned long & VK_NoStepInto_Namespace::DynamicArray< _Type >::ActDWORD ( void )
template<class _Type >
DAINLINE int & VK_NoStepInto_Namespace::DynamicArray< _Type >::ActInt ( void )
template<class _Type>
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::AddItem ( const _Type & newItem )
template<class _Type>
DAINLINE _Type& VK_NoStepInto_Namespace::DynamicArray< _Type >::at ( unsigned long dw )
inline
template<class _Type>
DAINLINE const _Type& VK_NoStepInto_Namespace::DynamicArray< _Type >::at ( unsigned long dw ) const
inline
template<class _Type>
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::clear ( void )
inline
template<class _Type>
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::CopyFrom ( DynamicArray< _Type > * src )
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::Delete | ( | unsigned long | dwStartIndex,
 |  | unsigned long | dwNumStructs
 | ) |  |
template<class _Type >
DAINLINE bool VK_NoStepInto_Namespace::DynamicArray< _Type >::DeleteAll ( void )
template<class _Type >
DAINLINE bool VK_NoStepInto_Namespace::DynamicArray< _Type >::DeleteUnnecessary ( void )
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::FreeArray ( void )
template<class _Type>
DAINLINE _Type& VK_NoStepInto_Namespace::DynamicArray< _Type >::Get ( unsigned long index )
inline
template<class _Type>
DAINLINE const _Type& VK_NoStepInto_Namespace::DynamicArray< _Type >::Get ( unsigned long index ) const
inline
template<class _Type >
unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::GetAllocated ( )
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::InitItems | ( | unsigned long | dwStartIndex,
 |  | unsigned long | dwNumStructs
 | ) |  |
protected
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::Insert | ( | unsigned long | dwStartIndex,
 |  | unsigned long | dwNumStructs
 | ) |  |
template<class _Type >
DAINLINE _Type & VK_NoStepInto_Namespace::DynamicArray< _Type >::Last ( void )
template<class _Type >
DAINLINE _Type & VK_NoStepInto_Namespace::DynamicArray< _Type >::operator[] ( unsigned long dw )
template<class _Type >
DAINLINE const _Type & VK_NoStepInto_Namespace::DynamicArray< _Type >::operator[] ( unsigned long dw ) const
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::PrepareNext ( unsigned long _dwNum )
template<class _Type>
DAINLINE void VK_NoStepInto_Namespace::DynamicArray< _Type >::push_back ( const _Type & elem )
inline
template<class _Type >
DAINLINE unsigned char VK_NoStepInto_Namespace::DynamicArray< _Type >::ReadByte ( void )
template<class _Type >
DAINLINE unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::ReadDWORD ( void )
template<class _Type>
DAINLINE const unsigned int VK_NoStepInto_Namespace::DynamicArray< _Type >::size ( ) const
inline
template<class _Type >
DAINLINE bool VK_NoStepInto_Namespace::DynamicArray< _Type >::StoreByte ( unsigned char bData )
template<class _Type >
DAINLINE bool VK_NoStepInto_Namespace::DynamicArray< _Type >::StoreDWORD ( unsigned long dwData )
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::Swap | ( | unsigned long | dwIndex1,
 |  | unsigned long | dwIndex2
 | ) |  |
template<class _Type >
bool VK_NoStepInto_Namespace::DynamicArray< _Type >::Truncate ( void )

Member Data Documentation

template<class _Type>
unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::dwAlloc
protected
template<class _Type>
unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::dwAllocBy
protected
template<class _Type>
unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::dwInited
protected
template<class _Type>
unsigned long VK_NoStepInto_Namespace::DynamicArray< _Type >::dwNum
template<class _Type>
_Type* VK_NoStepInto_Namespace::DynamicArray< _Type >::lpBuffer
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/DynamicArray.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::BufferedFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BufferedFile
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
vrecko::BufferedFile Class Reference

#include <BufFile.h>

Public Member Functions

BufferedFile (void)
~BufferedFile (void)
bool | setBehaviour (DWORD dwBehvFlags)
bool | init (_TCHAR *lpFileName)
bool | init (HANDLE hFile, bool bCallSPF)
HANDLE | getHandle ()
DWORD | getFilePos (void) const
void | close (void)
bool | setFilePos (DWORD dwNewFilePos)
DWORD | getMaxPos (void) const
DWORD | getBufSize (void) const
DWORD | getFileSize (void) const
void | setBufSize (DWORD dwNewSize)
bool | preReadBytes (DWORD dwNumOfBytes)
bool | readBytes (LPVOID lpDest, DWORD dwBytesToRead)
bool | readBytes (LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead)
BYTE | readByte (void)
bool | readWCharTrans (WCHAR *wChar)
bool | readBool (bool *pData)
bool | readByte (BYTE *pData)
bool | readWORD (WORD *pData)
bool | readDWORD (DWORD *pData)
bool | readLONG (LONG *pData)
bool | readFloat (float *pData)
bool | readVec3f (osg::Vec3f *v)
bool | readInt (int *pData)
bool | readPOINT (POINT *pData)
bool | readInt64 (__int64 *pData)
bool | readRECT (RECT *pData)
bool | readStr (CHAR *pData)
bool | tReadLine (_TCHAR *tBuffer, PDWORD pdwCharSize)
bool | readLine (PSTR pBuffer, PDWORD pdwCharSize)
bool | readLineW (PWSTR pBuffer, PDWORD pdwCharSize)
bool | isEOF (void)

Public Attributes

LPBYTE | lpBuffer
DWORD | dwPos

Protected Member Functions

bool | readBytesCore (LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead)
void | UNICODECheck (void)

Protected Attributes

HANDLE | hFile
DWORD | dwFilePos
DWORD | dwMaxPos
DWORD | dwBufSize
DWORD | dwFileSize
bool | bCloseFile
bool | bCallSFP
DWORD | dwBehvFlags
bool | bFileIsUTF
bool | bReversedWChar
DWORD | dwZeroPos

Constructor & Destructor Documentation

vrecko::BufferedFile::BufferedFile ( void )
vrecko::BufferedFile::~BufferedFile ( void )

Member Function Documentation

void vrecko::BufferedFile::close ( void )
DWORD vrecko::BufferedFile::getBufSize ( void ) const
inline
DWORD vrecko::BufferedFile::getFilePos ( void ) const
inline
DWORD vrecko::BufferedFile::getFileSize ( void ) const
inline
HANDLE vrecko::BufferedFile::getHandle ( )
inline
DWORD vrecko::BufferedFile::getMaxPos ( void ) const
inline
bool vrecko::BufferedFile::init ( _TCHAR * lpFileName )
bool vrecko::BufferedFile::init | ( | HANDLE | hFile,
 |  | bool | bCallSPF
 | ) |  |
bool vrecko::BufferedFile::isEOF ( void )
inline
bool vrecko::BufferedFile::preReadBytes ( DWORD dwNumOfBytes )
bool vrecko::BufferedFile::readBool ( bool * pData )
inline
BYTE vrecko::BufferedFile::readByte ( void )
inline
bool vrecko::BufferedFile::readByte ( BYTE * pData )
inline
bool vrecko::BufferedFile::readBytes | ( | LPVOID | lpDest,
 |  | DWORD | dwBytesToRead
 | ) |  |
inline
bool vrecko::BufferedFile::readBytes | ( | LPVOID | lpDest,
 |  | DWORD | dwBytesToRead,
 |  | LPDWORD | lpdwBytesRead
 | ) |  |
inline
bool vrecko::BufferedFile::readBytesCore | ( | LPVOID | lpDest,
 |  | DWORD | dwBytesToRead,
 |  | LPDWORD | lpdwBytesRead
 | ) |  |
protected
bool vrecko::BufferedFile::readDWORD ( DWORD * pData )
inline
bool vrecko::BufferedFile::readFloat ( float * pData )
inline
bool vrecko::BufferedFile::readInt ( int * pData )
inline
bool vrecko::BufferedFile::readInt64 ( __int64 * pData )
inline
bool vrecko::BufferedFile::readLine | ( | PSTR | pBuffer,
 |  | PDWORD | pdwCharSize
 | ) |  |
bool vrecko::BufferedFile::readLineW | ( | PWSTR | pBuffer,
 |  | PDWORD | pdwCharSize
 | ) |  |
bool vrecko::BufferedFile::readLONG ( LONG * pData )
inline
bool vrecko::BufferedFile::readPOINT ( POINT * pData )
inline
bool vrecko::BufferedFile::readRECT ( RECT * pData )
inline
bool vrecko::BufferedFile::readStr ( CHAR * pData )
inline
bool vrecko::BufferedFile::readVec3f ( osg::Vec3f * v )
inline
bool vrecko::BufferedFile::readWCharTrans ( WCHAR * wChar )
bool vrecko::BufferedFile::readWORD ( WORD * pData )
inline
bool vrecko::BufferedFile::setBehaviour ( DWORD dwBehvFlags )
void vrecko::BufferedFile::setBufSize ( DWORD dwNewSize )
bool vrecko::BufferedFile::setFilePos ( DWORD dwNewFilePos )
bool vrecko::BufferedFile::tReadLine | ( | _TCHAR * | tBuffer,
 |  | PDWORD | pdwCharSize
 | ) |  |
inline
void vrecko::BufferedFile::UNICODECheck ( void )
protected

Member Data Documentation

bool vrecko::BufferedFile::bCallSFP
protected
bool vrecko::BufferedFile::bCloseFile
protected
bool vrecko::BufferedFile::bFileIsUTF
protected
bool vrecko::BufferedFile::bReversedWChar
protected
DWORD vrecko::BufferedFile::dwBehvFlags
protected
DWORD vrecko::BufferedFile::dwBufSize
protected
DWORD vrecko::BufferedFile::dwFilePos
protected
DWORD vrecko::BufferedFile::dwFileSize
protected
DWORD vrecko::BufferedFile::dwMaxPos
protected
DWORD vrecko::BufferedFile::dwPos
DWORD vrecko::BufferedFile::dwZeroPos
protected
HANDLE vrecko::BufferedFile::hFile
protected
LPBYTE vrecko::BufferedFile::lpBuffer
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/helpers/BufFile.h
  • C:/Documents/School/OSG/VRECKO/src/helpers/BufFile.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::BufferedFileWrite Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BufferedFileWrite
Public Member Functions | Protected Attributes | List of all members
vrecko::BufferedFileWrite Class Reference

#include <BufFile.h>

Public Member Functions

BufferedFileWrite (void)
~BufferedFileWrite (void)
bool | init (TCHAR *lpFileName)
HANDLE | getHandle ()
bool | write (LPVOID lpBuffer, DWORD dwSize)
bool | writeByte (BYTE bData)
bool | writeBool (bool bData)
bool | writeWORD (WORD wData)
bool | writeLONG (LONG lData)
bool | writeDWORD (DWORD dwData)
bool | writeFloat (float fData)
bool | writeVec3f (osg::Vec3f *v)
bool | writeInt (int iData)
bool | writePOINT (POINT *pnt)
bool | writeInt64 (__int64 iData)
bool | writeRECT (RECT *rData)
bool | writeStr (PSTR pData)
bool | writeFormattedString (TCHAR *pFormat,...)
bool | flush (void)
bool | close (void)

Protected Attributes

HANDLE | hFile
DynamicArray< BYTE > | buffer
DWORD | dwBufMaxSize

Constructor & Destructor Documentation

vrecko::BufferedFileWrite::BufferedFileWrite ( void )
vrecko::BufferedFileWrite::~BufferedFileWrite ( void )

Member Function Documentation

bool vrecko::BufferedFileWrite::close ( void )
bool vrecko::BufferedFileWrite::flush ( void )
HANDLE vrecko::BufferedFileWrite::getHandle ( )
inline
bool vrecko::BufferedFileWrite::init ( TCHAR * lpFileName )
bool vrecko::BufferedFileWrite::write | ( | LPVOID | lpBuffer,
 |  | DWORD | dwSize
 | ) |  |
inline
bool vrecko::BufferedFileWrite::writeBool ( bool bData )
inline
bool vrecko::BufferedFileWrite::writeByte ( BYTE bData )
inline
bool vrecko::BufferedFileWrite::writeDWORD ( DWORD dwData )
inline
bool vrecko::BufferedFileWrite::writeFloat ( float fData )
inline
bool vrecko::BufferedFileWrite::writeFormattedString | ( | TCHAR * | pFormat,
 |  |  | ...
 | ) |  |
bool vrecko::BufferedFileWrite::writeInt ( int iData )
inline
bool vrecko::BufferedFileWrite::writeInt64 ( __int64 iData )
inline
bool vrecko::BufferedFileWrite::writeLONG ( LONG lData )
inline
bool vrecko::BufferedFileWrite::writePOINT ( POINT * pnt )
inline
bool vrecko::BufferedFileWrite::writeRECT ( RECT * rData )
inline
bool vrecko::BufferedFileWrite::writeStr ( PSTR pData )
inline
bool vrecko::BufferedFileWrite::writeVec3f ( osg::Vec3f * v )
inline
bool vrecko::BufferedFileWrite::writeWORD ( WORD wData )
inline

Member Data Documentation

DynamicArray<BYTE> vrecko::BufferedFileWrite::buffer
protected
DWORD vrecko::BufferedFileWrite::dwBufMaxSize
protected
HANDLE vrecko::BufferedFileWrite::hFile
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/helpers/BufFile.h
  • C:/Documents/School/OSG/VRECKO/src/helpers/BufFile.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Ability Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Ability
Classes | Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::Ability Class Reference

#include <Ability.h>

Inheritance diagram for vrecko::Ability:
vrecko::BaseClass AP_CableEditor::Cable AP_LSystem::LSObject APCameraMovement::CameraPath APClouds::Clouds APConstrainedMovement::ConstraintDescription APDYNAMICART::Controller APDYNAMICART::DAEnvironment APDYNAMICART::DATool APDYNAMICART::PoB APEditorController::EditorController APGUI::GUI_Controller APGUI::GUI_Item APHelloWorld::MyAbility APHUD::HUDDisplay APInputConnector::InputConnector APLightsEditor::Lights APMenu::DynamicMenu APNature::TerrainAbility APObjectUtils::Animator APObjectUtils::ConnectionViz APObjectUtils::CopyProperties APObjectUtils::KeepOnScreen APObjectUtils::ObjectEffect APObjectUtils::ObjectEffectMan APObjectUtils::ObjectInfo APObjectUtils::ObjectModif APObjectUtils::ObjectSelector APObjectUtils::UseToEvent APRoomEdit::WallGeometry APShootingSimulation::ShootingSimulation APSpacePartitioning::NoPartitioning_Scene APSpacePartitioning::PointShellVSVoxel_Object APSpacePartitioning::SP_Object_Data_Base APSpacePartitioning::SphereBVH_Object APSpacePartitioning::SphereBVH_Scene APSpacePartitioning::VoxelGrid_Object_Data APTextOutput::Console APWeather::Weather ArtificialWorld::BlockUpdater ArtificialWorld::WorldBuilder base::Avatar base::Display base::hand base::Light base::MouseHand base::MTMatrixTransform base::Rotate base::ShowFDH base::ShowFDHModel base::SystemInfo behindO::AvatarManipulator behindO::CentreObjectManipulator behindO::ChangeOfVisibility behindO::ContactObjectManipulator behindO::CuttingPlane behindO::EyeManipulator behindO::HeadManipulator behindO::HMDHeadManipulator behindO::Lens behindO::Manipulator behindO::MappingFunctions behindO::Mirror behindO::WIM BehindObstacleExp_wT BehindObstacleExperiment boids::Boid boids::BoidsLogic boids::BoidsPlanner Cache CarSim::CarControlUnit CarSim::CarExecutionUnit CarSim::CarPartsNodeCache CarSim::Remover CarSim::RoadsState CarSim::TLsOnJuncManager ChessBoard ChessPiece Filter::Linear Filter::PosNoiseRemover grass::Grass ht::HeadTracking ht::ScreenSetup ht::ScreenSetupSimple navigation::AvatarInHand navigation::KMTracker ode::CappedCylinder ode::CompositeObject ode::Cube ode::DynamicScene ode::Sphere PHANToMAvatar PHEffect PhysXPlugin::PhysXObject VirtualFixture::Avatar VirtualFixture::Log VirtualFixture::ProxiBorder VirtualFixture::ProxiBox VirtualFixture::ProxiCone VirtualFixture::ProxiCylinder VirtualFixture::ProxiSphere VirtualFixture::Trace vrecko::ControllableAbility vrecko::PyAbility

Classes

struct ParameterStruct

Public Types

typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Ability class represents ability of any entity in VRECKO.

Member Typedef Documentation

typedef std::vector<ParameterStruct> vrecko::Ability::ParameterVector

Vector of the description of parameters.

Constructor & Destructor Documentation

Ability::Ability ( const char * theAbilityName )
protected

Main ability constructor.

The constructor should contain only the very basic initialization (setting variables to zero etc.) AND setting the priority AND adding the ability to the scheduler/setting the update frequency. (The reason for setting these two things is that the user can also specify them in the XML file to overwrite default setting. This will be processed after the constructor, but before the initialize().)

The main initialization should be made in the initialize() method. The reason is that in the constructor, the Ability doesn't know who will be its owner and what will be its ID.

Note that there is no default constructor, so the programmer is forced to use this one and name their ability. Also note that this constructor is protected, so the Ability class cannot be constructed directly, only its descendants can (and in their constructors they can use this constructor without problems).

Parameters
theAbilityName is usually the name of your class, e.g. "ObjectEffect".
Ability::~Ability ( )
virtual

copy constructor

Member Function Documentation

virtual void vrecko::Ability::clean ( void )
inlinevirtual

Reimplemented in APObjectUtils::ObjectEffect, APObjectUtils::KeepOnScreen, APObjectUtils::Animator, APObjectUtils::ObjectEffectMan, and APObjectUtils::ConnectionViz.

const std::string& vrecko::Ability::getID ( void ) const
inline

Returns ability the identification string.

This is either:

  • plugin name + "::" + ability name or
  • user specified ID set by the setID() function (through World::createAbility())
Returns
(const std::string &) Reference to the stored ability string.
const std::string& vrecko::Ability::getName ( ) const
inline

Returns the ability name.

Returns
(const std::string &) Reference to the ability name-string.
BaseClass* vrecko::Ability::getOwner ( void )
inline

Returns the ability owner.

The owner is in almost all cases an EnvironmetObject class, so you can safely cast it to EO, i.e. ((EnvironmentObject*)getOwner())

Returns
(BaseClass *)
virtual ParameterVector* vrecko::Ability::getParameterVector ( void )
inlinevirtual

Return vector of the parameter description.

Reimplemented in base::ShowFDH, and base::Rotate.

const std::string& vrecko::Ability::getPluginName ( void ) const
inline

Returns the plugin name.

const std::string & Ability::getSenderString ( void )
virtual

Returns the identification string of sender.

The sender string might be for example something like "EO|2073#Ab|Modeller::ModellingTool#Grab", which means Environment object #2073, Ability with ID "Modeller::ModellingTool" with "Grab" input or output (depending on the usage).

Reimplemented from vrecko::BaseClass.

bool Ability::isUpdated ( void )

Set update flag.

Return true if ability is updated else false Is the ability periodically updated?

Returns true if the ability is scheduled to be updated automatically at a given time interval (might be X Hz or simply every frame)

void Ability::setID ( const char * pID )

(Internal usage, most people should not need to use it.) Sets the ability ID.

Called automatically by the World::createAbility().

Warning
!!! WARNING !!! This function can be called only immediately after creating the ability (before adding ability to owner/world and before calling Ability::initialize()), because the mentioned function store the ID in their internal structures.

If the parameter is NULL or an empty string the standard ability ID will be used (plugin name + "::" + ability name). Note that calling the setPluginName() causes the ID to be set back to the default value.

Parameters
pID (const char *)
Returns
(void)
void vrecko::Ability::setOwner ( BaseClass * owner )
inline

(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly.

Parameters
owner (BaseClass *) The owner object, in most usual cases it is an EnvironmentObject class.
Returns
(void)
void Ability::setPluginName ( const char * pName )

Sets the plugin name.

Should be only used by plugins when constructing the ability (in their getAbilityInstance() method).

Parameters
pName (const char *)
Returns
(void)

Member Data Documentation

std::vector<std::string> vrecko::Ability::parameterString
protected

VYHODIT --------------------------------— Vector of parameterString

BaseClass* vrecko::Ability::pOwner
protected

Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class.

bool vrecko::Ability::updated
protected

Update flag. It is used for save.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Ability.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Ability.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Ability::ParameterStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Ability
  • ParameterStruct
Public Attributes | List of all members
vrecko::Ability::ParameterStruct Struct Reference

#include <Ability.h>

Public Attributes

std::string | name
std::string | description
std::string | range

Detailed Description

It returns a list of acceptable message. This ability is able to react on these types of messages. Parameters, value, ...

Member Data Documentation

std::string vrecko::Ability::ParameterStruct::description
std::string vrecko::Ability::ParameterStruct::name
std::string vrecko::Ability::ParameterStruct::range
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Ability.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::AbilityDispatcher Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • AbilityDispatcher
Public Types | Public Member Functions | Protected Attributes | List of all members
vrecko::AbilityDispatcher Class Reference

used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities More...

#include <Ability.h>

Inheritance diagram for vrecko::AbilityDispatcher:
vrecko::BaseClass

Public Types

typedef std::map< std::string,
Ability * > 		AbilityMap
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

AbilityDispatcher ()
~AbilityDispatcher ()
void | addAbility (Ability *pAbility)
void | removeAbility (Ability *pAbility)
void | removeAllAbilities ()
Ability * | getAbility (const std::string &ab_id)
AbilityMap & | getAbilityMap (void)
Ability * | getAbilityWithInput (const std::string &input_name)
Ability * | getAbilityWithOutput (const std::string &output_name)
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

std::map< std::string, Ability * > | ability_map
Map where is recorded the abilities handled in AbilityDispatcher. More...
AbilityMap ability_name_map
Map where is recorded the name and pointer to abilities. More...
MTLock mainLock
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Detailed Description

used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities

This class is used in the World and EnvironmentObject classes internally. Others probably won't need to use it directly, because World and EO hides all its methods and exposes theirs instead.

Warning
NOT completely THREAD SAFE yet... some main functions are ok, but getAbilityMap() might cause serious troubles if you use it wrongly.
Author
Jan Flasar
Date
2002

Member Typedef Documentation

typedef std::map<std::string, Ability*> vrecko::AbilityDispatcher::AbilityMap

Return reference to ability map.

Constructor & Destructor Documentation

AbilityDispatcher::AbilityDispatcher ( )
AbilityDispatcher::~AbilityDispatcher ( )

Member Function Documentation

void AbilityDispatcher::addAbility ( Ability * pAbility )

When an ability is added to an environment object this function is called. It adds this ability to the AbilityDispatcher.

Ability * AbilityDispatcher::getAbility ( const std::string & ab_id )

Return Ability with given ID (ability name + plugin ID).

AbilityMap& vrecko::AbilityDispatcher::getAbilityMap ( void )
inline
Ability * AbilityDispatcher::getAbilityWithInput ( const std::string & input_name )
Ability * AbilityDispatcher::getAbilityWithOutput ( const std::string & output_name )
void AbilityDispatcher::removeAbility ( Ability * pAbility )

It removes the ability from ability dispatcher.

void AbilityDispatcher::removeAllAbilities ( )

Member Data Documentation

std::map<std::string, Ability*> vrecko::AbilityDispatcher::ability_map
protected

Map where is recorded the abilities handled in AbilityDispatcher.

AbilityMap vrecko::AbilityDispatcher::ability_name_map
protected

Map where is recorded the name and pointer to abilities.

MTLock vrecko::AbilityDispatcher::mainLock
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Ability.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Ability.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Attribute Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Attribute
Public Types | Public Member Functions | Protected Member Functions | List of all members
vrecko::Attribute Class Reference

#include <Attribute.h>

Inheritance diagram for vrecko::Attribute:
vrecko::DynamicAttribute vrecko::StaticAttribute< type, tval, tref >

Public Types

enum DataType {
TYPE_BOOL, TYPE_INT, TYPE_LONG, TYPE_FLOAT,
TYPE_DOUBLE, TYPE_STRING, TYPE_VEC2, TYPE_VEC3,
TYPE_VEC4, TYPE_MATRIX, TYPE_QUAT, TYPE_DYNAMIC
}

Public Member Functions

const string & | getName () const
DataType | getDataType () const
const string & | getDescription () const
bool | isStatic () const
bool | isDynamic () const

Protected Member Functions

Attribute (const string &strName, DataType dataType, const string &strDescription)
Attribute (const Attribute &attribute)

Detailed Description

Represents a general attribute class.

You cannot create any instances of this class, use subclasses. This class is meant solely as an abstract parent class for classes StaticAttribute and DynamicAttribute.

See Also
StaticAttribute
DynamicAttribute

Member Enumeration Documentation

enum vrecko::Attribute::DataType

Data types enumeration.

All basic and object data types are pronounced static. By dynamic attributes we mean attributes which can be composed of one or more static attributes. The thing is that a dynamic attribute doesn't have to have any instances; instances can be created and manipulated. On the other hand, static attributes cannot be removed or created, it's only possible to set their values.

Enumerator
TYPE_BOOL | boolean attribute
TYPE_INT | integer attribute
TYPE_LONG | long attribute
TYPE_FLOAT | float attribute
TYPE_DOUBLE | double attribute
TYPE_STRING | string attribute
TYPE_VEC2 | two-dimensional vector attribute
TYPE_VEC3 | three-dimensional vector attribute
TYPE_VEC4 | four-dimensional vector attribute
TYPE_MATRIX | matrix attribute
TYPE_QUAT | quaternion attribute
TYPE_DYNAMIC | dynamic (structured) attribute

Constructor & Destructor Documentation

vrecko::Attribute::Attribute | ( | const string & | strName,
 |  | DataType | dataType,
 |  | const string & | strDescription
 | ) |  |
inlineprotected

Constructs an Attribute object.

Parameters
strName | reference to a constant attribute name
dataType | attribute data type identificator
strDescription | reference to a constant attribute description
vrecko::Attribute::Attribute ( const Attribute & attribute )
inlineprotected

Constructs an Attribute object by copying an existing one.

Parameters
attribute a reference to a constant Attribute instance

Member Function Documentation

DataType vrecko::Attribute::getDataType ( ) const
inline

Returns attribute data type identificator.

Returns
attribute data type identificator
const string& vrecko::Attribute::getDescription ( ) const
inline

Returns attribute description.

Returns
reference to a constant attribute description
const string& vrecko::Attribute::getName ( ) const
inline

Returns attribute name.

Returns
reference to a constant attribute name
bool vrecko::Attribute::isDynamic ( ) const
inline

"Is dynamic" predicate.

Returns
true if the attribute is dynamic, false otherwise
bool vrecko::Attribute::isStatic ( ) const
inline

"Is static" predicate.

Returns
true if the attribute is static, false otherwise
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Attribute.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::AttributesDescription Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • AttributesDescription
Public Member Functions | List of all members
vrecko::AttributesDescription Class Reference

#include <AttributesDescription.h>

Public Member Functions

~AttributesDescription ()
bool | addAttribute (Attribute *pAttribute)
bool | hasAnyAttributes () const
unsigned int | attributesCount () const
bool | containsAttribute (const string &strName) const
const Attribute * | getAttributePtr (const string &strName) const
void | startIteration ()
bool | hasNextAttribute () const
const Attribute * | nextAttributePtr ()

Detailed Description

Represents a attributes description container.

This class serves as a container for objects of Attribute class. It is meant to be used as a root node in the attributes description hierarchy. You can insert both static and dynamic attributes (provided these have at least one sub-attribute).

See Also
Attribute
StaticAttribute
DynamicAttribute

Constructor & Destructor Documentation

vrecko::AttributesDescription::~AttributesDescription ( )
inline

Performs cleanup before object destruction.

Member Function Documentation

bool vrecko::AttributesDescription::addAttribute ( Attribute * pAttribute )
inline

Adds an attribute if not already included.

Any pointers passed to this method as parameters are used directly, no copy is made. You have to ensure a unique pointer is passed per each call of this method. Also ensure that the pointer is used only wihtin the context of this method and nowhere else and stays valid all the time. Allocated memory is freed automatically.

Parameters
pAttribute pointer to an Attribute object on the heap
Returns
true if the attribute has been added, false otherwise
unsigned int vrecko::AttributesDescription::attributesCount ( ) const
inline

Returns attributes count.

Returns
number of attributes present
bool vrecko::AttributesDescription::containsAttribute ( const string & strName ) const
inline

"Contains attribute" predicate.

Parameters
strName reference to a constant attribute name used as a key for searching
Returns
true if an attribute with given name is contained, false otherwise
const Attribute* vrecko::AttributesDescription::getAttributePtr ( const string & strName ) const
inline

Returns pointer to an attribute based on its name.

Parameters
strName reference to a constant attribute name used as a key for searching
Returns
pointer to a constant Attribute object
bool vrecko::AttributesDescription::hasAnyAttributes ( ) const
inline

"Has any attribute" predicate.

Returns
true if any attribute is contained, false otherwise
bool vrecko::AttributesDescription::hasNextAttribute ( ) const
inline

"Has next attribute" predicate.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
true if there is a next attribute in the object
See Also
startIteration()
nextAttributePtr()
const Attribute* vrecko::AttributesDescription::nextAttributePtr ( )
inline

Returns pointer to current attribute and increments the iterator.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
pointer to a constant Attribute object pointed to by the internal iterator
See Also
startIteration()
hasNextAttribute()
void vrecko::AttributesDescription::startIteration ( )
inline

Initializes the internal iterator.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/AttributesDescription.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::IOPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • IOPinBase
Public Member Functions | Protected Attributes | List of all members
vrecko::IOPinBase Class Referenceabstract

Base class that defines the very basic method that every IO pin will have. More...

#include <BaseClass.h>

Inheritance diagram for vrecko::IOPinBase:
vrecko::InputPinBase vrecko::IORequestPinBase vrecko::OutputPinBase vrecko::InputPin< _MessageType > vrecko::RequestInputPinBase vrecko::RequestOutputPinBase vrecko::OutputPin< _MessageType > vrecko::RequestInputPin< _MessageType, _ReturningMessageType > vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >

Public Member Functions

std::string & | getPinName ()
Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name. More...
virtual VreckoMessage * | createCompatibleMessage ()=0
Creates an instance of a message type that is recognized by this input/output. More...

Protected Attributes

std::string pinName
BaseClass * owner

Detailed Description

Base class that defines the very basic method that every IO pin will have.

The input or output pins are the basis for message sending between objects in Vrecko. All the usual messages should pass through some output pin and are received in other object's input pin.

Author
Vit Kovalcik
Date
2011

Member Function Documentation

virtual VreckoMessage* vrecko::IOPinBase::createCompatibleMessage ( )
pure virtual

Creates an instance of a message type that is recognized by this input/output.

If you will create a new descendant class of type XY, this method will generally be:

virtual VreckoMessage* createCompatibleMessage() { return new XY; };

Returns
(VreckoMessage*)

Implemented in vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >, vrecko::OutputPin< _MessageType >, and vrecko::InputPin< _MessageType >.

std::string& vrecko::IOPinBase::getPinName ( )
inline

Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name.

Returns
(std::string&) Reference to a pin name.

Member Data Documentation

BaseClass* vrecko::IOPinBase::owner
protected
std::string vrecko::IOPinBase::pinName
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::InputPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • InputPinBase
Public Member Functions | List of all members
vrecko::InputPinBase Class Referenceabstract

#include <BaseClass.h>

Inheritance diagram for vrecko::InputPinBase:
vrecko::IOPinBase vrecko::InputPin< _MessageType >

Public Member Functions

virtual void | processMessage (VreckoMessage *message)=0
Method that is called when the actual message is received. More...
- Public Member Functions inherited from vrecko::IOPinBase
std::string & | getPinName ()
Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name. More...
virtual VreckoMessage * | createCompatibleMessage ()=0
Creates an instance of a message type that is recognized by this input/output. More...

Additional Inherited Members

- Protected Attributes inherited from vrecko::IOPinBase
std::string pinName
BaseClass * owner

Member Function Documentation

virtual void vrecko::InputPinBase::processMessage ( VreckoMessage * message )
pure virtual

Method that is called when the actual message is received.

Parameters
message (VreckoMessage *)
Returns
(void)

Implemented in vrecko::InputPin< _MessageType >.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::OutputPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OutputPinBase
List of all members
vrecko::OutputPinBase Class Reference

#include <BaseClass.h>

Inheritance diagram for vrecko::OutputPinBase:
vrecko::IOPinBase vrecko::OutputPin< _MessageType >

Additional Inherited Members

- Public Member Functions inherited from vrecko::IOPinBase
std::string & | getPinName ()
Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name. More...
virtual VreckoMessage * | createCompatibleMessage ()=0
Creates an instance of a message type that is recognized by this input/output. More...
- Protected Attributes inherited from vrecko::IOPinBase
std::string | pinName
BaseClass * owner
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::IORequestPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • IORequestPinBase
Public Member Functions | List of all members
vrecko::IORequestPinBase Class Referenceabstract

#include <BaseClass.h>

Inheritance diagram for vrecko::IORequestPinBase:
vrecko::IOPinBase vrecko::RequestInputPinBase vrecko::RequestOutputPinBase vrecko::RequestInputPin< _MessageType, _ReturningMessageType > vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >

Public Member Functions

virtual VreckoMessage * | createReturningCompatibleMessage ()=0
Same as IOPinBase::createCompatibleMessage() but for the returning message type. More...
- Public Member Functions inherited from vrecko::IOPinBase
std::string & | getPinName ()
Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name. More...
virtual VreckoMessage * | createCompatibleMessage ()=0
Creates an instance of a message type that is recognized by this input/output. More...

Additional Inherited Members

- Protected Attributes inherited from vrecko::IOPinBase
std::string pinName
BaseClass * owner

Member Function Documentation

virtual VreckoMessage* vrecko::IORequestPinBase::createReturningCompatibleMessage ( )
pure virtual

Same as IOPinBase::createCompatibleMessage() but for the returning message type.

Returns
(VreckoMessage*)

Implemented in vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >, and vrecko::RequestInputPin< _MessageType, _ReturningMessageType >.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::RequestInputPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestInputPinBase
Public Member Functions | List of all members
vrecko::RequestInputPinBase Class Referenceabstract

#include <BaseClass.h>

Inheritance diagram for vrecko::RequestInputPinBase:
vrecko::IORequestPinBase vrecko::IOPinBase vrecko::RequestInputPin< _MessageType, _ReturningMessageType >

Public Member Functions

virtual osg::ref_ptr
< VreckoMessage > 		processRequest (VreckoMessage *message)=0
Method that is called when actual request is received. More...
- Public Member Functions inherited from vrecko::IORequestPinBase
virtual VreckoMessage * | createReturningCompatibleMessage ()=0
Same as IOPinBase::createCompatibleMessage() but for the returning message type. More...
- Public Member Functions inherited from vrecko::IOPinBase
std::string & | getPinName ()
Returns the name of the current IO pin. Every pin must have a name that is unique in its ability and in its "type", i.e. two input pins with the same name should exist, but you can create input and also output pins with the identical name. More...
virtual VreckoMessage * | createCompatibleMessage ()=0
Creates an instance of a message type that is recognized by this input/output. More...

Additional Inherited Members

- Protected Attributes inherited from vrecko::IOPinBase
std::string pinName
BaseClass * owner

Member Function Documentation

virtual osg::ref_ptr<VreckoMessage> vrecko::RequestInputPinBase::processRequest ( VreckoMessage * message )
pure virtual

Method that is called when actual request is received.

Parameters
message (VreckoMessage *)
Returns
(osg::ref_ptr<VreckoMessage>)

Implemented in vrecko::RequestInputPin< _MessageType, _ReturningMessageType >.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::RequestOutputPinBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestOutputPinBase
List of all members
vrecko::RequestOutputPinBase Class Reference

#include <BaseClass.h>

Inheritance diagram for vrecko::RequestOutputPinBase:
vrecko::IORequestPinBase vrecko::IOPinBase vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >

Additional Inherited Members

- Public Member Functions inherited from vrecko::IORequestPinBase
virtual VreckoMessage * | createReturningCompatibleMessage ()=0
Same as IOPinBase::createCompatibleMessage() but for the returning message type. More...
- Protected Attributes inherited from vrecko::IOPinBase
std::string | pinName
BaseClass * owner
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::BaseClass Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BaseClass
Classes | Public Types | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
vrecko::BaseClass Class Reference

#include <BaseClass.h>

Inheritance diagram for vrecko::BaseClass:
APMenu::MenuItem MainObject vrecko::Ability vrecko::AbilityDispatcher vrecko::Device vrecko::DeviceManager vrecko::EnvironmentObject vrecko::EventDispatcher vrecko::OctTree vrecko::Scene vrecko::Scene::EOIteratorHelper vrecko::World

Classes

struct NOTIFICATION_DESCRIPTION

Public Types

enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Protected Member Functions

bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Detailed Description

Class BaseClass is the base class of the VRECKO. It includes functions for inputs/outputs operations and event processing. And it also includes termination flag and pointers to the World.

Member Typedef Documentation

typedef std::map<std::string, int> vrecko::BaseClass::AttributeMap
protected

Attributes.

typedef std::vector<osg::ref_ptr<IOPinBase> > vrecko::BaseClass::PinList
protected

Member Enumeration Documentation

enum vrecko::BaseClass::NotificationTypes
Enumerator
NOTIFICATION_DELETE_CLASS

notification will be sent on class deletion

NOTIFICATION_EO_REGISTERING

sent when an EO object is being registered to the Scene. !!! WARNING !!! This notification is sent when the internal EOMap is locked from updates -

  • if you will try to register or unregister any object in this handler, the application will freeze forever. BE AWARE! [sender] will be the Scene, [notificationData] will be the given object.
NOTIFICATION_EO_UNREGISTERING

sent when an EO object is unregistered from Scene !!! WARNING !!! This notification is sent when the internal EOMap is locked from updates -

  • if you will try to register or unregister any object in this handler, the application will freeze forever. BE AWARE! [sender] will be the Scene, [notificationData] will be the given object.
NOTIFICATION_PROGRAM_TERMINATION
 Sent when the program will be terminated,

BEFORE the actual destruction of the world/devices/object/abilities/... Sent ONLY to objects, which were registered to World.

NOTIFICATION_ALL

every type of notification

Constructor & Destructor Documentation

BaseClass::BaseClass ( const char * startingSenderString )

The main constructor.

Especially in the case of abilities: The constructor should contain only the very basic initialization (setting variables to zero etc.) AND IF REALLY NECESSARY then also setting the priority AND adding the ability to the scheduler and setting the update frequency. (The reason for setting these two things is the user can also specify them in the XML file to overwrite default setting. This will be processed after the constructor, but before the initialize().)

The main initialization should be made in the initialize() method. The reason is that in the constructor, the Ability doesn't know who will be its owner and what will be its ID.

Parameters
startingSenderString (const char *)
Returns
()
BaseClass::BaseClass ( BaseClass & bc )

Copy constructor. Probably not really used.

Parameters
bc (BaseClass &)
Returns
()
BaseClass::~BaseClass ( )
virtual

Destructor.

This has to be virtual - see for example http://blogs.msdn.com/b/oldnewthing/archive/2004/05/07/127826.aspx .

Returns
()

Member Function Documentation

void BaseClass::addInputPin ( InputPinBase * pin )

Adds an input pin.

Usually not used directly, but using the INIT_INPUT macro in IOPins.h .

It still may be useful to use it directly at times, but usually for highly dynamic abilities, which need to register and unregister plenty of different pins at runtime.

The usual declaration/definition/initialization on an input pit comprises of using macros DECLARE_INPUT, INIT_INPUT and METHOD_INPUT. The usage is described in manual in more detail. See this page: http://decibel.fi.muni.cz/wiki/index.php/VRECKO_Zpravy

Parameters
pin (InputPinBase *)
Returns
(void)
bool BaseClass::addNotification | ( | BaseClass * | receiver,
 |  | unsigned long | notificationTypes
 | ) |  |

Registers an observer that will be notified if a specific change occurs.

Note: Due to the locking mechanism used, this is ok to use in multi-threading environment.

Parameters
receiver | (BaseClass *) Pointer to the object that will be notified - its processNotification() method will be called.
notificationTypes | (unsigned long) Any combination of bitvalues defined in the NotificationTypes enum (combine them using bitwise OR, i.e. operator | ).
Returns
(bool) True if everything went ok.
void BaseClass::addOutputPin ( OutputPinBase * pin )

Adds an output pin.

Usually not used directly, but using the INIT_OUTPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (OutputPinBase *)
Returns
(void)
void BaseClass::addRequestInputPin ( RequestInputPinBase * pin )

Adds a request input pin.

Usually not used directly, but using the INIT_REQUEST_INPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (RequestInputPinBase *)
Returns
(void)
void BaseClass::addRequestOutputPin ( RequestOutputPinBase * pin )

Adds a request output pin.

Usually not used directly, but using the INIT_REQUEST_OUTPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (RequestOutputPinBase *)
Returns
(void)
void BaseClass::deleteAttribute ( const std::string & attr_name )

Delete an attribute.

Any other subsequent calls to getAttribute() will return 0.

Parameters
attr_name (const std::string &)
Returns
(void)
IOPinBase* vrecko::BaseClass::findPinInList | ( | const char * | strName,
 |  | PinList * | pinList
 | ) |  |
inlineprotected

Internal method to find a given pin in a given list.

Parameters
strName | (const char *) Pin name.
pinList | (PinList *) List to be searched.
Returns
(IOPinBase*) Pointer to the pin or NULL if not found.
int vrecko::BaseClass::getAttribute ( const std::string & attr_name )
inline

Returns attribute value.

If you specify a non-existing attribute, 0 will be returned.

Parameters
attr_name (const std::string &)
Returns
(int)
int vrecko::BaseClass::getAttribute ( const char * attr_name )
inline

Returns attribute value.

If you specify a non-existing attribute, 0 will be returned.

Parameters
attr_name (const char *)
Returns
(int)
InputPinBase * BaseClass::getInputPin ( const char * strName )

Returns pointer to an input pin with specified name.

Parameters
strName (const char *) Pin name.
Returns
(InputPinBase*) Returned pointer or NULL if not found.
OutputPinBase * BaseClass::getOutputPin ( const char * strName )

Returns pointer to an output pin with specified name.

Parameters
strName (const char *) Pin name.
Returns
(OutputPinBase*) Returned pointer or NULL if not found.
long int vrecko::BaseClass::getPriority ( void ) const
inline

Returns current object priority.

For more information about priority and its usage see setPriority().

Returns
(long int) The current object priority.
RequestInputPinBase * BaseClass::getRequestInputPin ( const char * strName )

Returns pointer to an request input pin with specified name.

Parameters
strName (const char *) Pin name.
Returns
(RequestInputPinBase*) Returned pointer or NULL if not found.
RequestOutputPinBase * BaseClass::getRequestOutputPin ( const char * strName )

Returns pointer to an input pin with specified name.

Parameters
strName (const char *) Pin name.
Returns
(RequestOutputPinBase*) Returned pointer or NULL if not found.
const std::string& vrecko::BaseClass::getSceneFile ( ) const
inline

Get the name of the file this component was in.

The method may return NULL.

Warning
Note that the string pointer may point to the shared memory pool (so don't change the string directly!)
Returns
(const std::string &)
virtual const std::string& vrecko::BaseClass::getSenderString ( void )
inlinevirtual

Returns the sender (or receiver) identification string.

Returns
(const std::string &) Reference to the stored sender string.

Reimplemented in vrecko::Ability.

bool BaseClass::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented in vrecko::ControllableAbility, AP_CableEditor::CableEditor, APLightsEditor::Editor, APNature::TerrainAbility, ht::ScreenSetup, APGUI::GUI_Controller, APShootingSimulation::ShootingSimulation, ht::ScreenSetupSimple, APGUI::Icon, APCameraPath::Camera, APGUI::Slider, vrecko::EnvironmentObject, ode::DynamicScene, APInputConnector::InputConnector, APRoomEdit::RoomEditor, APGUI::IconColour, APGUI::Menu, vreckoDP_base::Wiimote, APDYNAMICART::ToolEraser, APDYNAMICART::ToolTongs, APGUI::ColorPicker, APDYNAMICART::ToolSelector, APDYNAMICART::ToolMagicWand, APDYNAMICART::ToolHook, APDYNAMICART::ToolRotation, APDYNAMICART::ToolSlice, APEditorController::EditorController, APEditorQAbilities::ObjectMovement, ht::HeadTracking, APEditorQAbilities::AbilityEditor, APHelloWorld::MyAbility, and APWeather::Weather.

bool BaseClass::initializeFromString ( const char * xmlString )
virtual

Helper method that allows to initialize ability from a XML-formatted string.

This method takes string, converts it to XML nodes and passes the result to the "real" initialize() method.

Parameters
xmlString (const char *) The string formatted like this: "<Parameters>...</Parameters>"
Returns
(bool) True in case the function was successful.
bool BaseClass::inputPresent ( const std::string & name )

Returns true if input pin (not request inputpin ) with given name is present.

Return vector with description of all inputs for the object. Return type of the input. Return vector with description of all outputs for the object. Return type of the output.

Parameters
name (const std::string &) Pin name
Returns
(bool) True if the pin already exists.
virtual bool vrecko::BaseClass::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented in APMenu::DynamicMenu, APSpacePartitioning::PointShell_Object_Data, vrecko::World, APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::DAEnvironment, APLightsEditor::Lights, APDYNAMICART::Ctrl_MotionVisualization, ArtificialWorld::BlockUpdater, APCameraPath::Camera, vreckoDP_base::LHeadTracker, APRoomEdit::WallGeometry, APCameraMovement::CameraPath, APObjectUtils::ObjectEffect, APObjectUtils::KeepOnScreen, vreckoDP_base::NestOfBirds, APHUD::HUDDisplay, Cache, APObjectUtils::Animator, PhysXPlugin::PhysXScene, APDYNAMICART::Ctrl_PerlinLines, APClouds::Clouds, CarSim::CarExecutionUnit, vreckoDP_base::VRPN3DMouse, APTextOutput::Console, grass::Grass, APConstrainedMovement::ConstraintDescription, AP_LSystem::LSObject, APConnectEditor::ConnectEditor, base::SystemInfo, vreckoDP_base::OptiTrack, CarSim::RoadsState, vreckoDP_base::L3DMouse, boids::Boid, boids::BoidsLogic, vreckoDP_Kinect::Kinect, PhysXPlugin::BasePhysXObject, PhysXPlugin::Cloth, boids::BoidsPlanner, VirtualFixture::Trace, navigation::AvatarInHand, PhysXPlugin::BaseActor, VirtualFixture::ProxiBorder, BehindObstacleExp_wT, BehindObstacleExperiment, base::Avatar, APConnectEditor::Cut, base::ShowFDH, CarSim::CarControlUnit, APObjectUtils::CopyProperties, VirtualFixture::ProxiBox, VirtualFixture::ProxiCone, VirtualFixture::ProxiCylinder, VirtualFixture::ProxiSphere, behindO::WIM, APObjectUtils::ConnectionViz, APObjectUtils::ObjectModif, APObjectUtils::ObjectSelector, APSpacePartitioning::VoxelGrid_Object_Data, PhysXPlugin::BaseJoint, VirtualFixture::Avatar, behindO::HeadManipulator, APObjectUtils::ObjectEffectMan, PhysXPlugin::RemoteDebugger, behindO::HMDHeadManipulator, APFFDEditor::EditorLogic, VirtualFixture::Log, base::Rotate, ChessBoard, PhysXPlugin::Box, PhysXPlugin::Capsule, PhysXPlugin::CylindricalJoint, PhysXPlugin::Fluid, PhysXPlugin::Plane, PhysXPlugin::PointInPlaneJoint, PhysXPlugin::PointOnLineJoint, PhysXPlugin::PrismaticJoint, PhysXPlugin::Sphere, PhysXPlugin::SphericalJoint, PHEffect, PhysXPlugin::DistanceJoint, PhysXPlugin::FixedJoint, PhysXPlugin::PulleyJoint, PhysXPlugin::RevoluteJoint, PHANToMAvatar, base::Light, ArtificialWorld::WorldBuilder, APConnectEditor::Rotation, navigation::KMTracker, ode::Cube, Filter::Linear, ChessPiece, ode::CompositeObject, ode::Sphere, PhysXPlugin::ForceField, ode::CappedCylinder, and Filter::PosNoiseRemover.

bool BaseClass::loadXMLParameters ( const char * xmlString )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
xmlString (const char *)
Returns
(bool)
bool BaseClass::outputPresent ( const std::string & name )

Returns true if output pin (not request output pin) with given name is present.

Parameters
name (const std::string &) Pin name
Returns
(bool) True if the pin already exists.
virtual void vrecko::BaseClass::postInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented in APMenu::DynamicMenu, APLightsEditor::Lights, APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Controller, AP_CableEditor::Cable, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::DAEnvironment, ArtificialWorld::BlockUpdater, APRoomEdit::WallGeometry, APDYNAMICART::Ctrl_PerlinLines, APObjectUtils::ObjectEffect, APCameraMovement::CameraPath, APDYNAMICART::PLControllerTool, APHUD::HUDDisplay, PhysXPlugin::PhysXScene, APDYNAMICART::PLMagnetTool, APTextOutput::Console, APClouds::Clouds, AP_LSystem::LSObject, grass::Grass, base::SystemInfo, vrecko::PyAbility, PhysXPlugin::PhysXObject, vreckoDP_base::OptiTrack, PhysXPlugin::BaseActor, boids::BoidsLogic, boids::Boid, PhysXPlugin::BasePhysXObject, boids::BoidsPlanner, VirtualFixture::ProxiBorder, base::Avatar, APDYNAMICART::JuliaAttractor, APObjectUtils::ConnectionViz, BehindObstacleExp_wT, BehindObstacleExperiment, APDYNAMICART::PLNestTool, behindO::WIM, APObjectUtils::ObjectModif, APObjectUtils::ObjectSelector, VirtualFixture::ProxiBox, VirtualFixture::ProxiCone, VirtualFixture::ProxiCylinder, VirtualFixture::ProxiSphere, VirtualFixture::Trace, ArtificialWorld::WorldBuilder, APObjectUtils::ObjectEffectMan, APSpacePartitioning::VoxelGrid_Object_Data, PhysXPlugin::RemoteDebugger, VirtualFixture::Avatar, APFFDEditor::EditorLogic, navigation::AvatarInHand, PhysXPlugin::UpdatablePhysXObject, VirtualFixture::Log, PHEffect, PHANToMAvatar, behindO::CentreObjectManipulator, behindO::MappingFunctions, navigation::KMTracker, ode::Cube, base::Light, ode::CompositeObject, ode::Sphere, and ode::CappedCylinder.

virtual void vrecko::BaseClass::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented in APMenu::DynamicMenu, APLightsEditor::Lights, APDYNAMICART::Ctrl_FreeHandPainting, APDYNAMICART::Controller, AP_CableEditor::Cable, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::DAEnvironment, ArtificialWorld::BlockUpdater, behindO::Mirror, APRoomEdit::WallGeometry, APObjectUtils::KeepOnScreen, APObjectUtils::ObjectEffect, APCameraMovement::CameraPath, APHUD::HUDDisplay, APObjectUtils::Animator, PhysXPlugin::PhysXScene, APSpacePartitioning::SNCH_Object, CarSim::CarExecutionUnit, APTextOutput::Console, CarSim::TLsOnJuncManager, APClouds::Clouds, base::MTMatrixTransform, base::SystemInfo, vrecko::PyAbility, AP_LSystem::LSObject, vreckoDP_base::OptiTrack, CarSim::RoadsState, boids::BoidsLogic, APSpacePartitioning::NoPartitioning_Scene, base::MouseHand, boids::Boid, PhysXPlugin::BasePhysXObject, boids::BoidsPlanner, PhysXPlugin::PhysXObject, APSpacePartitioning::SphereBVH_Scene, VirtualFixture::ProxiBorder, base::Avatar, CarSim::CarControlUnit, APObjectUtils::ConnectionViz, APSpacePartitioning::SphereBVH_Object, behindO::AvatarManipulator, BehindObstacleExp_wT, BehindObstacleExperiment, behindO::EyeManipulator, behindO::Manipulator, APSpacePartitioning::PointShellVSVoxel_Object, base::hand, VirtualFixture::ProxiBox, VirtualFixture::ProxiCone, VirtualFixture::ProxiCylinder, VirtualFixture::ProxiSphere, VirtualFixture::Trace, behindO::HeadManipulator, APObjectUtils::ObjectModif, APObjectUtils::ObjectSelector, APSpacePartitioning::VoxelGrid_Object_Data, VirtualFixture::Avatar, behindO::HMDHeadManipulator, APObjectUtils::ObjectEffectMan, APObjectUtils::ObjectInfo, base::Light, base::Rotate, VirtualFixture::Log, PHEffect, CarSim::Remover, ChessPiece, APSpacePartitioning::SP_Object_Data_Base, PHANToMAvatar, Filter::Linear, navigation::KMTracker, and Filter::PosNoiseRemover.

void BaseClass::processEvent | ( | const std::string & | input_name,
 |  | VreckoMessage * | pMessage
 | ) |  |
virtual

Internal method for processing the events.

After the message reimplementation, this is a method, which redistributes the events into your methods attached to the respective inputs. There is usually now no need to override this method or interact with it in any way. You can usually easily define your inputs via the DECLARE_INPUT and INIT_INPUT macros and declare handling method using the METHOD_INPUT macro.

Internally, this method is used to process all the messages and find the appropriate handling method defined by the METHOD_INPUT.

Parameters
input_name | (const std::string &) Name of the input pin
pMessage | (VreckoMessage *) Pointer to the message. This will be automatically cast to the correct message type, if you are using the DECLARE_INPUT (etc.) macros.
Returns
(void)

Reimplemented in APInputConnector::InputConnector, navigation::AvatarInHand, and navigation::KMTracker.

virtual int vrecko::BaseClass::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
inlineprotectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented in vrecko::ControllableAbility, APMenu::MenuItem, vrecko::Scene::EOIteratorHelper, AP_CableEditor::CableEditor, APEditorController::EditorController, AP_CableEditor::Cable, APSpacePartitioning::SphereBVH_Object_Data, and APObjectUtils::ObjectEffectMan.

VreckoMessage * BaseClass::processRequest | ( | const std::string & | request_input_name,
 |  | VreckoMessage * | pMessage
 | ) |  |
virtual

Internal method for processing the requests.

After the message reimplementation, this is a method, which redistributes the requests into your methods attached to the respective request inputs. There is now no need to override this method or interact with it in any way. You can usually easily define your inputs via the DECLARE_REQUEST_INPUT and INIT_REQUEST_INPUT macros and declare handling method using the METHOD_REQUEST_INPUT macro.

Internally, this method is used to process all the requests and find the appropriate handling method defined by the METHOD_REQUEST_INPUT.

Parameters
request_input_name | (const std::string &) Request input name
pMessage | (VreckoMessage *) Message sent to the input
Returns
(VreckoMessage *) Returning message
void BaseClass::removeInputPin ( InputPinBase * pin )

Removes an input pin.

Usually not used directly, but using the UNINIT_INPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (InputPinBase *)
Returns
(void)
bool BaseClass::removeNotification | ( | BaseClass * | receiver,
 |  | unsigned long | notificationTypes = NOTIFICATION_ALL
 | ) |  |

Unregisters a previously registered observer.

Note: Due to the locking mechanism used, this is ok to use in multi-threading environment.

Only specified notifications will be unregistered. You can specify the ALL_NOTIFICATIONS constant to unregister everything.

MUTLITHREADING note: Since we are using locks, it is guaranteed that after this method returns there is no "pending" notification and no other notifications will arise.

Parameters
receiver | (BaseClass *) Registered object that is receiving notifications.
notificationTypes | (unsigned long) Any combination of bitvalues defined in the NotificationTypes enum (combine them using bitwise OR, i.e. operator | ).
Returns
(bool) True if everything went ok.
void BaseClass::removeOutputPin ( OutputPinBase * pin )

Removes and output pin.

Usually not used directly, but using the UNINIT_OUTPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (OutputPinBase *)
Returns
(void)
void BaseClass::removeRequestInputPin ( RequestInputPinBase * pin )

Removes a request input pin.

Usually not used directly, but using the UNINIT_REQUEST_INPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (RequestInputPinBase *)
Returns
(void)
void BaseClass::removeRequestOutputPin ( RequestOutputPinBase * pin )

Removes a request output pin.

Usually not used directly, but using the UNINIT_REQUEST_OUTPUT macro in IOPins.h .

For more information see addInputPin().

Parameters
pin (RequestOutputPinBase *)
Returns
(void)
void BaseClass::reportError ( const std::string & error )

Print error message.

This method is not really used, but might be good for inspiration in the future (attaches own identification to a given error message).

Parameters
error (const std::string &)
Returns
(void)
virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* vrecko::BaseClass::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
inlinevirtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented in APDYNAMICART::DAEnvironment, vreckoDP_base::LHeadTracker, vreckoDP_base::NestOfBirds, APClouds::Clouds, grass::Grass, vreckoDP_base::OptiTrack, vreckoDP_base::L3DMouse, vreckoDP_base::Wiimote, boids::Boid, boids::BoidsLogic, boids::BoidsPlanner, navigation::AvatarInHand, BehindObstacleExp_wT, BehindObstacleExperiment, base::Avatar, base::ShowFDH, behindO::WIM, behindO::HeadManipulator, behindO::HMDHeadManipulator, base::Rotate, navigation::KMTracker, ode::Cube, Filter::Linear, ode::CompositeObject, ode::Sphere, ode::CappedCylinder, and Filter::PosNoiseRemover.

bool BaseClass::sendNotifications | ( | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protected

Send notifications to all BaseClasses, which are registered to receive the selected notification type (only ONE type at a time, i.e. the notificationType have to have only ONE bit set).

void vrecko::BaseClass::setAttribute | ( | const std::string & | attr_name,
 |  | int | attr_value
 | ) |  |
inline

Sets an attribute value.

This method either sets value for a new attribute or replace value of an old attribute.

Parameters
attr_name | (const std::string &) Attribute name.
attr_value | (int) New value.
Returns
(void)
void vrecko::BaseClass::setPriority ( long int pr )
inline

Sets the priority. (Possible problems - read the full description for more info)

The priority is used if the update() method is called periodically (i.e. every frame). The objects with highest priority will be called first.

If not set explicitly, the default priority of an object is 0.

Once the object is registered in Scheduler, the priority is used to insert sort the object between the "competing" ones. Any later change of priority is allowed and the object will be correctly re-sorted in Scheduler (happens usually in the next frame).

Warning
The priority for most abilities should be set in their constructor, because the user has also an option to set the priority in the XML configuration file. The priority set in constructor will then act as a default value and can be overridden in the XML.
Parameters
pr (long int) The new priority, can be negative meaning simply lower-than-default priority. The default is 0.
Returns
(void)
void BaseClass::setSceneFile ( const std::string & sceneFileName )

Set the name of the file this component was in (and possibly will be saved to).

You can specify an empty string meaning "no file".

Parameters
sceneFileName (const std::string &)
Returns
(void)
virtual void vrecko::BaseClass::update ( void )
inlinevirtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented in APMenu::DynamicMenu, AP_CableEditor::Cable, vrecko::EventDispatcher, vrecko::Scene, APDYNAMICART::Controller, vrecko::ControllableAbility, APDYNAMICART::DAEnvironment, APDYNAMICART::PoA, APDYNAMICART::Ctrl_MotionVisualization, APDYNAMICART::Ctrl_FreeHandPainting, ArtificialWorld::BlockUpdater, behindO::Mirror, APGUI::GUI_Controller, APDYNAMICART::BrushStroke, vreckoDP_base::LHeadTracker, vreckoDP_base::fsPinchGlove, APCameraMovement::CameraPath, APObjectUtils::ObjectEffect, APNature::TerrainAbility, APDYNAMICART::PoB, APObjectUtils::KeepOnScreen, APDYNAMICART::PLControllerTool, APGUI::Slider, vreckoDP_base::Ultratrak, APHUD::HUDDisplay, vreckoDP_base::NestOfBirds, APInputConnector::InputConnector, APObjectUtils::Animator, PhysXPlugin::PhysXScene, Cache, APShootingSimulation::ShootingSimulation, APLightsEditor::Editor, vrecko::Device, ode::DynamicScene, APClouds::Clouds, APCameraPath::Camera, APDYNAMICART::Ctrl_PerlinLines, APDYNAMICART::PLMagnetTool, CarSim::CarExecutionUnit, APDYNAMICART::ToolBrush, vreckoDP_base::VRPN3DMouse, APDYNAMICART::OrdinaryAttractor, APTextOutput::Console, AP_CableEditor::CableEditor, APDYNAMICART::Ctrl_StringSculptures, APGUI::ColorPicker, vreckoDP_base::KeyboardMouse, CarSim::TLsOnJuncManager, APRoomEdit::RoomEditor, base::SystemInfo, APDYNAMICART::Ctrl_PolyhedraSculptures, APDYNAMICART::ToolTongs, APDYNAMICART::Attractor, base::MTMatrixTransform, APDYNAMICART::PerlinLines, grass::Grass, vreckoDP_base::fdtDataGlove, vreckoDP_base::OptiTrack, boids::BoidsLogic, CarSim::RoadsState, APDYNAMICART::Ctrl_Attractor, APDYNAMICART::PolyhedraSculpture, vrecko::PyAbility, APDYNAMICART::Hoop, vreckoDP_base::L3DMouse, boids::BoidsPlanner, vreckoDP_base::Wiimote, vreckoDP_Kinect::Kinect, boids::Boid, APDYNAMICART::HookObject, APDYNAMICART::ToolMagicWand, APSpacePartitioning::NoPartitioning_Scene, APDYNAMICART::PLNestTool, APDYNAMICART::ToolSelector, navigation::AvatarInHand, base::MouseHand, APCameraMovement::CameraMovementEditor, APDYNAMICART::JuliaAttractor, BehindObstacleExp_wT, BehindObstacleExperiment, APConstrainedMovement::ConstrainedObjectMovement, APDYNAMICART::ToolHook, APObjectUtils::CopyProperties, vreckoDP_base::MicroScribe3D, VirtualFixture::ProxiBorder, base::Avatar, APObjectUtils::ConnectionViz, APObjectUtils::ObjectModif, APObjectUtils::ObjectSelector, base::Display, APEditorController::EditorController, APObjectUtils::ObjectEffectMan, CarSim::CarControlUnit, APDYNAMICART::ToolRotation, APEditorQAbilities::ObjectMovement, behindO::AvatarManipulator, behindO::EyeManipulator, behindO::Manipulator, behindO::WIM, VirtualFixture::ProxiBox, VirtualFixture::ProxiCone, VirtualFixture::ProxiCylinder, VirtualFixture::ProxiSphere, VirtualFixture::Trace, base::ShowFDH, base::ShowFDHModel, navigation::KMTracker, APSpacePartitioning::VoxelGrid_Object_Data, VirtualFixture::Avatar, behindO::HeadManipulator, ht::HeadTracking, behindO::CuttingPlane, behindO::HMDHeadManipulator, APConnectEditor::Cut, APObjectUtils::ObjectInfo, VirtualFixture::Log, base::hand, base::Rotate, behindO::ChangeOfVisibility, CarSim::Remover, PHEffect, behindO::CentreObjectManipulator, behindO::MappingFunctions, APEditorQAbilities::AvatarMovement, APEditorQAbilities::SimpleObjectMovement, APFFDEditor::EditorLogic, PHANToMAvatar, APConnectEditor::Rotation, APConnectEditor::Scale, ChessBoard, ode::Cube, APSpacePartitioning::SP_Object_Data_Base, base::Light, ArtificialWorld::WorldBuilder, APHelloWorld::MyAbility, ode::CompositeObject, ode::Sphere, ChessPiece, ode::CappedCylinder, behindO::ContactObjectManipulator, and behindO::Lens.

Member Data Documentation

AttributeMap vrecko::BaseClass::attribute
protected
MTReadWriteLock vrecko::BaseClass::attributeLock
protected
PinList vrecko::BaseClass::inputPinsList
protected

List of all input pins for this object... we know that all of them are of type InputPinBase, but the ancestor class is used, so the same methods can be used to manipulate with similar lists.

std::vector<NOTIFICATION_DESCRIPTION> vrecko::BaseClass::notifications
protected

Array with all the notifications.

MTLock vrecko::BaseClass::notificationsLock
protected

Lock to protect access to the notifications vector.

PinList vrecko::BaseClass::outputPinsList
protected

List of all input pins for this object... we know that all of them are of type OutputPinBase, but the ancestor class is used, so the same methods can be used to manipulate with similar lists.

long int vrecko::BaseClass::priority
protected

Priority.

The default priority is 0, but can be changed (even to a negative number).

See setPriority() for more information.

PinList vrecko::BaseClass::requestInputPinsList
protected

List of all input pins for this object... we know that all of them are of type RequestInputPinBase, but the ancestor class is used, so the same methods can be used to manipulate with similar lists.

PinList vrecko::BaseClass::requestOutputPinsList
protected

List of all input pins for this object... we know that all of them are of type RequestOutputPinBase, but the ancestor class is used, so the same methods can be used to manipulate with similar lists.

const std::string* vrecko::BaseClass::sceneFile
protected

Name of the scene file this component was in (and will be saved to). This will be a pointer to the shared memory pool, so don't deallocate it. (variable pointer to a const string)

std::string vrecko::BaseClass::senderString
protected

Pre-constructed sender string to be returned by the getSenderString() method.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/BaseClass.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::BaseClass::NOTIFICATION_DESCRIPTION Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BaseClass
  • NOTIFICATION_DESCRIPTION
Public Attributes | List of all members
vrecko::BaseClass::NOTIFICATION_DESCRIPTION Struct Reference

#include <BaseClass.h>

Public Attributes

BaseClass * receiver
unsigned long notificationTypes

Detailed Description

Internal structure to hold data about a single notification.

Member Data Documentation

unsigned long vrecko::BaseClass::NOTIFICATION_DESCRIPTION::notificationTypes
BaseClass* vrecko::BaseClass::NOTIFICATION_DESCRIPTION::receiver
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::BenchmarkWriter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BenchmarkWriter
Public Member Functions | Protected Attributes | List of all members
vrecko::BenchmarkWriter Class Reference

Class to write any timings and other benchmark data into file. More...

#include <BenchmarkWriter.h>

Public Member Functions

BenchmarkWriter ()
~BenchmarkWriter ()
void | setWriting (bool bValue)
bool | writingAllowed ()
bool | openFile (const char *pFileName=NULL)
bool | isOpened ()
bool | writeInfoStart ()
bool | writeInfoLine (const char *pText,...)
bool | writeInfoEnd ()
bool | writeSettingsStart ()
bool | writeParam (const char *pName, const char *pValue)
bool | writeParam (const char *pName, float fValue)
bool | writeSettingsEnd ()
bool | writeDataStart ()
bool | writeFrameStart (unsigned int dwTime)
bool | writeCounter (const char *pName, float fValue)
bool | writeFrameEnd ()
bool | writeMiscStatsStart ()
bool | writeRunTime (unsigned int dwTime)
bool | writeFramesRendered (unsigned int dwNum)
bool | writeMiscStatsEnd ()
bool | writeDataEnd ()
bool | closeFile ()

Protected Attributes

FILE * | file
bool | bWriting
bool | bOpenMain
bool | bOpenInfo
bool | bOpenSettings
bool | bOpenData
bool | bOpenFrame
bool | bOpenMiscStats

Detailed Description

Class to write any timings and other benchmark data into file.

Very suitable for writing data that come every second or even much faster (Phantom-ready :) ). For example, you can output every frame your time to calculate visibility, process the messages, number of visible objects etc.

All these data will be written to an XML file in the "log" directory. These files are easily viewable in our BenchmarkStats application (proprietary, should come with Vrecko).

This class is usually not used directly, but through a simple interface in the Logger class.

Author
Vit Kovalcik
Date
2009

Constructor & Destructor Documentation

vrecko::BenchmarkWriter::BenchmarkWriter ( )
vrecko::BenchmarkWriter::~BenchmarkWriter ( )

Member Function Documentation

bool vrecko::BenchmarkWriter::closeFile ( )
bool vrecko::BenchmarkWriter::isOpened ( )
inline
bool vrecko::BenchmarkWriter::openFile ( const char * pFileName = NULL )

The [FileName] can be NULL, in which case unique filename will be automatically generated.

void vrecko::BenchmarkWriter::setWriting ( bool bValue )

If [bValue] is false, then NO WRITING will be performed at all.

bool vrecko::BenchmarkWriter::writeCounter | ( | const char * | pName,
 |  | float | fValue
 | ) |  |
Warning
The final line should be XML-save (no '<' characters etc.)
bool vrecko::BenchmarkWriter::writeDataEnd ( )
bool vrecko::BenchmarkWriter::writeDataStart ( )
bool vrecko::BenchmarkWriter::writeFrameEnd ( )
bool vrecko::BenchmarkWriter::writeFramesRendered ( unsigned int dwNum )
bool vrecko::BenchmarkWriter::writeFrameStart ( unsigned int dwTime )
bool vrecko::BenchmarkWriter::writeInfoEnd ( )
bool vrecko::BenchmarkWriter::writeInfoLine | ( | const char * | pText,
 |  |  | ...
 | ) |  |
Warning
The final line should be XML-save (no '<' characters etc.)
bool vrecko::BenchmarkWriter::writeInfoStart ( )
bool vrecko::BenchmarkWriter::writeMiscStatsEnd ( )
bool vrecko::BenchmarkWriter::writeMiscStatsStart ( )
bool vrecko::BenchmarkWriter::writeParam | ( | const char * | pName,
 |  | const char * | pValue
 | ) |  |
Warning
The final line should be XML-save (no '<' characters etc.)
bool vrecko::BenchmarkWriter::writeParam | ( | const char * | pName,
 |  | float | fValue
 | ) |  |
Warning
The final line should be XML-save (no '<' characters etc.)
bool vrecko::BenchmarkWriter::writeRunTime ( unsigned int dwTime )
bool vrecko::BenchmarkWriter::writeSettingsEnd ( )
bool vrecko::BenchmarkWriter::writeSettingsStart ( )
bool vrecko::BenchmarkWriter::writingAllowed ( )
inline

Member Data Documentation

bool vrecko::BenchmarkWriter::bOpenData
protected
bool vrecko::BenchmarkWriter::bOpenFrame
protected
bool vrecko::BenchmarkWriter::bOpenInfo
protected
bool vrecko::BenchmarkWriter::bOpenMain
protected
bool vrecko::BenchmarkWriter::bOpenMiscStats
protected
bool vrecko::BenchmarkWriter::bOpenSettings
protected
bool vrecko::BenchmarkWriter::bWriting
protected
FILE* vrecko::BenchmarkWriter::file
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/BenchmarkWriter.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/BenchmarkWriter.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Device Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Device
Public Member Functions | Protected Attributes | List of all members
vrecko::Device Class Referenceabstract

#include <Device.h>

Inheritance diagram for vrecko::Device:
vrecko::BaseClass vreckoDP_base::A3DBird vreckoDP_base::fdtDataGlove vreckoDP_base::fsPinchGlove vreckoDP_base::KeyboardMouse vreckoDP_base::LHeadTracker vreckoDP_base::MicroScribe3D vreckoDP_base::NestOfBirds vreckoDP_base::OptiTrack vreckoDP_base::Ultratrak vreckoDP_base::VRPN3DMouse vreckoDP_base::Wiimote vreckoDP_Kinect::Kinect

Public Member Functions

Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | openDevice (void)=0
Opens device and performs the initialization routines. More...
virtual int | closeDevice (void)=0
Closes device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
virtual void | update (void)=0
Updates the device - scan device and send required outputs. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Detailed Description

Basic class for devices that are implemented in VRECKO.

Constructor & Destructor Documentation

Device::Device | ( | const char * | startingDeviceName,
 |  | const char * | pname = ""
 | ) |  |
virtual vrecko::Device::~Device ( )
inlinevirtual

Member Function Documentation

virtual int vrecko::Device::calibrateDevice ( void )
inlinevirtual

Device calibration.

Reimplemented in vreckoDP_base::KeyboardMouse, and vreckoDP_base::fdtDataGlove.

virtual int vrecko::Device::closeDevice ( void )
pure virtual

Closes device.

Implemented in vreckoDP_base::LHeadTracker, vreckoDP_base::fsPinchGlove, vreckoDP_base::Ultratrak, vreckoDP_base::NestOfBirds, vreckoDP_base::VRPN3DMouse, vreckoDP_base::KeyboardMouse, vreckoDP_base::fdtDataGlove, vreckoDP_base::L3DMouse, vreckoDP_base::OptiTrack, vreckoDP_Kinect::Kinect, vreckoDP_base::Wiimote, and vreckoDP_base::MicroScribe3D.

virtual const std::string vrecko::Device::getCalibrationString ( void )
inlinevirtual

Returns the description of the calibration process.

const std::string& vrecko::Device::getDeviceType ( void )
inline

Returns the type of the device.

int vrecko::Device::getID ( void )
inline

Returns the ID of the device.

const char* vrecko::Device::getPortName ( void )
inline

Returns port name of the device.

virtual int vrecko::Device::openDevice ( void )
pure virtual

Opens device and performs the initialization routines.

Implemented in vreckoDP_base::LHeadTracker, vreckoDP_base::fsPinchGlove, vreckoDP_base::Ultratrak, vreckoDP_base::NestOfBirds, vreckoDP_base::VRPN3DMouse, vreckoDP_base::KeyboardMouse, vreckoDP_base::fdtDataGlove, vreckoDP_base::L3DMouse, vreckoDP_base::OptiTrack, vreckoDP_Kinect::Kinect, vreckoDP_base::Wiimote, and vreckoDP_base::MicroScribe3D.

void Device::setID ( int new_id )

Sets ID of the device.

void vrecko::Device::setPortName ( const char * pname )
inline

Sets the port name for the device.

virtual void vrecko::Device::update ( void )
pure virtual

Updates the device - scan device and send required outputs.

Reimplemented from vrecko::BaseClass.

Implemented in vreckoDP_base::LHeadTracker, vreckoDP_base::fsPinchGlove, vreckoDP_base::Ultratrak, vreckoDP_base::NestOfBirds, vreckoDP_base::VRPN3DMouse, vreckoDP_base::KeyboardMouse, vreckoDP_base::fdtDataGlove, vreckoDP_base::OptiTrack, vreckoDP_base::L3DMouse, vreckoDP_base::Wiimote, vreckoDP_Kinect::Kinect, and vreckoDP_base::MicroScribe3D.

Member Data Documentation

std::string vrecko::Device::device_type
protected

device type

int vrecko::Device::id
protected

device ID

std::string vrecko::Device::port_name
protected

name of the port

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Device.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Device.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::DeviceManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DeviceManager
Classes | Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
vrecko::DeviceManager Class Reference

#include <DeviceManager.h>

Inheritance diagram for vrecko::DeviceManager:
vrecko::BaseClass

Classes

struct DT

Public Member Functions

DeviceManager ()
~DeviceManager ()
int | requestForDevice (const std::string &plugin_name, const std::string &device_type, const char *port, float frequency)
bool | requestForDevice (const std::string &plugin_name, const std::string &device_type, const char *port, int id, float frequency)
Device * | getDevicePtr (int device_id)
Device * | getDevicePtrByType (const std::string &device_type)
std::map< int, DT > & | getDeviceMap (void)
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static vrecko::Device * getDeviceInstance (const std::string &plugin_name, const std::string &device_type)

Protected Member Functions

bool | connectDevice (const std::string &plugin_name, const std::string &device_type, const char *port, Device **device_ptr)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::map< int, DT > | device_map
Map of device pointer for the device with the ID. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Static Protected Attributes

static std::map< std::string,
osgDB::DynamicLibrary * > 		_dl_map

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

DeviceManager is used to maintain devices that are actually used.

Constructor & Destructor Documentation

DeviceManager::DeviceManager ( )
DeviceManager::~DeviceManager ( )

Member Function Documentation

bool DeviceManager::connectDevice | ( | const std::string & | plugin_name,
 |  | const std::string & | device_type,
 |  | const char * | port,
 |  | Device ** | device_ptr
 | ) |  |
protected

Open a new device and put it into DeviceManager structures.

Device * DeviceManager::getDeviceInstance | ( | const std::string & | plugin_name,
 |  | const std::string & | device_type
 | ) |  |
static
std::map<int, DT>& vrecko::DeviceManager::getDeviceMap ( void )
inline

Return map of the devices.

Device * DeviceManager::getDevicePtr ( int device_id )

Returns the pointer to the device with the given ID.

Device * DeviceManager::getDevicePtrByType ( const std::string & device_type )

Returns the pointer to the device of the specific device type.

int DeviceManager::requestForDevice | ( | const std::string & | plugin_name,
 |  | const std::string & | device_type,
 |  | const char * | port,
 |  | float | frequency
 | ) |  |

Processes the request for a device. If the DeviceManager detects the required device is already created its ID is returned, otherwise the device is initialized and a new ID is returned.

bool DeviceManager::requestForDevice | ( | const std::string & | plugin_name,
 |  | const std::string & | device_type,
 |  | const char * | port,
 |  | int | id,
 |  | float | frequency
 | ) |  |

Processes the request for a device. If the DeviceManager detects the required device is already created its ID is returned, otherwise the device is initialized and a new ID is returned.

Member Data Documentation

std::map< std::string, osgDB::DynamicLibrary * > DeviceManager::_dl_map
staticprotected
std::map<int, DT> vrecko::DeviceManager::device_map
protected

Map of device pointer for the device with the ID.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/DeviceManager.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/DeviceManager.cpp
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::DeviceManager::DT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DeviceManager
  • DT
Public Attributes | List of all members
vrecko::DeviceManager::DT Struct Reference

#include <DeviceManager.h>

Public Attributes

Device * devicePtr
vThread * threadPtr

Detailed Description

Struct with pointers to device and its thread.

Member Data Documentation

Device* vrecko::DeviceManager::DT::devicePtr
vThread* vrecko::DeviceManager::DT::threadPtr
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/DeviceManager.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::DynamicAttribute Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DynamicAttribute
Public Member Functions | List of all members
vrecko::DynamicAttribute Class Reference

#include <DynamicAttribute.h>

Inheritance diagram for vrecko::DynamicAttribute:
vrecko::Attribute

Public Member Functions

DynamicAttribute (const string &strName, const string &strDescription, unsigned int minInstancesCount=0, unsigned int maxInstancesCount=10)
~DynamicAttribute ()
unsigned int | getMinInstancesCount () const
unsigned int | getMaxInstancesCount () const
bool | addAttribute (Attribute *pAttribute)
unsigned int | attributesCount () const
bool | containsAttribute (const string &strName) const
const Attribute * | getAttributePtr (const string &strName) const
void | startIteration ()
bool | hasNextAttribute () const
const Attribute * | nextAttributePtr ()
- Public Member Functions inherited from vrecko::Attribute
const string & | getName () const
DataType | getDataType () const
const string & | getDescription () const
bool | isStatic () const
bool | isDynamic () const

Additional Inherited Members

- Public Types inherited from vrecko::Attribute
enum DataType {
TYPE_BOOL, TYPE_INT, TYPE_LONG, TYPE_FLOAT,
TYPE_DOUBLE, TYPE_STRING, TYPE_VEC2, TYPE_VEC3,
TYPE_VEC4, TYPE_MATRIX, TYPE_QUAT, TYPE_DYNAMIC
}
- Protected Member Functions inherited from vrecko::Attribute
Attribute (const string &strName, DataType dataType, const string &strDescription)
Attribute (const Attribute &attribute)

Detailed Description

Represents a dynamic attribute which can be composed of one or more static attributes.

This class serves as a container for objects of Attribute class. Therefore it can be used as a node in the attributes hierarchy. You can insert only static attributes now. More complex tree structure of the attributes hierarchy might be available later on.

See Also
Attribute
StaticAttribute

Constructor & Destructor Documentation

vrecko::DynamicAttribute::DynamicAttribute | ( | const string & | strName,
 |  | const string & | strDescription,
 |  | unsigned int | minInstancesCount = 0,
 |  | unsigned int | maxInstancesCount = 10
 | ) |  |
inline

Constructs a DynamicAttribute object.

Parameters
strName | reference to a constant attribute name
strDescription | reference to a constant attribute description
minInstancesCount | number of min instances
maxInstancesCount | number of max instances
vrecko::DynamicAttribute::~DynamicAttribute ( )
inline

Performs cleanup before object destruction.

Member Function Documentation

bool vrecko::DynamicAttribute::addAttribute ( Attribute * pAttribute )
inline

Adds a static attribute if not already included.

Any pointers passed to this method as parameters are used directly, no copy is made. You have to ensure a unique pointer is passed per each call of this method. Also ensure that the pointer is used only wihtin the context of this method and nowhere else and stays valid all the time. Allocated memory is freed automatically.

Parameters
pAttribute pointer to an Attribute object on the heap
Returns
true if the attribute has been added, false otherwise
unsigned int vrecko::DynamicAttribute::attributesCount ( ) const
inline

Returns attributes count.

Returns
number of attributes present
bool vrecko::DynamicAttribute::containsAttribute ( const string & strName ) const
inline

"Contains attribute" predicate.

Parameters
strName reference to a constant attribute name used as a key for searching
Returns
true if an attribute with given name is contained, false otherwise
const Attribute* vrecko::DynamicAttribute::getAttributePtr ( const string & strName ) const
inline

Returns pointer to an attribute based on its name.

Parameters
strName reference to a constant attribute name used as a key for searching
Returns
pointer to a constant Attribute object
unsigned int vrecko::DynamicAttribute::getMaxInstancesCount ( ) const
inline

Returns number of max attribute instances.

Returns
number of max instances of this attribute that can be created
unsigned int vrecko::DynamicAttribute::getMinInstancesCount ( ) const
inline

Returns number of min attribute instances.

Returns
number of min instances of this attribute that should be created
bool vrecko::DynamicAttribute::hasNextAttribute ( ) const
inline

"Has next attribute" predicate.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
true if there is a next attribute in the object
See Also
startIteration()
nextAttributePtr()
const Attribute* vrecko::DynamicAttribute::nextAttributePtr ( )
inline

Returns pointer to current attribute and increments the iterator.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
pointer to a constant Attribute object pointed to by the internal iterator
See Also
startIteration()
hasNextAttribute()
void vrecko::DynamicAttribute::startIteration ( )
inline

Initializes the internal iterator.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/DynamicAttribute.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Enumeration< tval, tref > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Enumeration
Public Member Functions | List of all members
vrecko::Enumeration< tval, tref > Class Template Reference

#include <Enumeration.h>

Inheritance diagram for vrecko::Enumeration< tval, tref >:
vrecko::Range

Public Member Functions

Enumeration (unsigned int valuesCount,...)
unsigned int | valuesCount () const
bool | containsValue (tref value) const
void | startIteration ()
bool | hasNextValue () const
tref | nextValue ()
- Public Member Functions inherited from vrecko::Range
bool | isInterval () const
bool | isEnumeration () const

Additional Inherited Members

- Public Types inherited from vrecko::Range
enum RangeType { RANGE_INTERVAL, RANGE_ENUMERATION }
- Protected Member Functions inherited from vrecko::Range
Range (RangeType rangeType)
Range (const Range &range)

Detailed Description

template<class tval, class tref = tval>
class vrecko::Enumeration< tval, tref >

Represents an immutable enumeration.

This class uses templates. Specialized classes are prepared for bool, int, long, float, double and string data types. No other specializations should be used. Specialized classes are listed below definition of this class.

Parameters
tval | data type used for values storage
tref | data type used for arguments and results passing
See Also
Range
Interval
IntEnumeration
LongEnumeration
FloatEnumeration
DoubleEnumeration
StringEnumeration

Constructor & Destructor Documentation

template<class tval , class tref = tval>
vrecko::Enumeration< tval, tref >::Enumeration | ( | unsigned int | valuesCount,
 |  |  | ...
 | ) |  |
inline

Constructs an Enumeration object by adding all the values.

Parameters
valuesCount number of values supplied (should be >= 1)
... values to be inserted

Member Function Documentation

template<class tval , class tref = tval>
bool vrecko::Enumeration< tval, tref >::containsValue ( tref value ) const
inline

"Contains value" predicate.

Parameters
value value to be checked
Returns
true if the value is contained in the enum, false otherwise
template<class tval , class tref = tval>
bool vrecko::Enumeration< tval, tref >::hasNextValue ( ) const
inline

"Has next value" predicate.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
true if there is a next value in the enumeration
See Also
startIteration()
nextValue()
template<class tval , class tref = tval>
tref vrecko::Enumeration< tval, tref >::nextValue ( )
inline

Returns current value and increments the iterator.

You have to initialize the internal interator first by calling startIteration() before you call this method!

Returns
a value pointed to by the internal iterator
See Also
startIteration()
hasNextValue()
template<class tval , class tref = tval>
void vrecko::Enumeration< tval, tref >::startIteration ( )
inline

Initializes the internal iterator.

template<class tval , class tref = tval>
unsigned int vrecko::Enumeration< tval, tref >::valuesCount ( ) const
inline

Returns values count.

Returns
number of values in the enumeration
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Enumeration.h
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EnvironmentObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EnvironmentObject
Classes | Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
vrecko::EnvironmentObject Class Reference

#include <EnvironmentObject.h>

Inheritance diagram for vrecko::EnvironmentObject:
vrecko::BaseClass APDYNAMICART::PoA APDYNAMICART::PS_FacePlane APDYNAMICART::SimpleBox APDYNAMICART::Attractor APDYNAMICART::BrushStroke APDYNAMICART::HookObject APDYNAMICART::Hoop APDYNAMICART::PerlinLines APDYNAMICART::PolyhedraSculpture APDYNAMICART::JuliaAttractor APDYNAMICART::NullAttractor APDYNAMICART::OrdinaryAttractor APDYNAMICART::MotionTrail

Classes

struct UserData
Here are stored pointer to UserData and its type. More...

Public Types

enum UserData_Type {
UD_UNKNOWN = 0, UD_BOOL, UD_INT, UD_LONG_INT,
UD_FLOAT, UD_DOUBLE, UD_STRING, UD_VEC2,
UD_VEC3, UD_VEC4, UD_MATRIX, UD_QUAT,
UD_POINTER, UD_USER
}
Types of the UserData. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

EnvironmentObject ()
~EnvironmentObject ()
EnvironmentObject (EnvironmentObject &eo)
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
void | setID (unsigned long new_id)
Set the ID of the object. More...
const unsigned long | getID () const
Returns the ID of the object. More...
void | setName (const std::string &n)
Sets the name of the object. More...
const std::string & | getName (void) const
Returns the name of the object. More...
bool | loadGeometry (const char *filename, bool bOutputErrors=true)
Loads geometry (usually a 3D model) from a file. More...
bool | setGeometry (osg::Geode *new_geomtetry, long int k=1, long int l=100000)
Adds a new geometry to the EO. More...
void | setModelFileName (const std::string mfn)
Sets the filename for the model. More...
const std::string & | getModelFileName (void) const
Returns the model filename. More...
bool | addAbility (Ability *ability, bool bCreateNewIdIfColliding=true)
Adds an ability to the EO. Use World::createAbility() instead. More...
bool | removeAbility (Ability *pAbility)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAbility (const std::string &ability_id)
Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use. More...
bool | removeAllAbilities ()
"Unregisters" and deallocates all abilities of an object. More...
Ability * | getAbility (const std::string &ab_id)
Returns ability with a specified ID. More...
Ability * | getAbility (const std::string &pluginName, const std::string &abilityName)
Returns ability of a given type. More...
Ability * | getAbilityWithInput (const std::string &input_name)
Returns ability with a given input. More...
Ability * | getAbilityWithOutput (const std::string &output_name)
Returns ability with a given output. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Returns map of the abilities in the EO. More...
osg::Matrix & | getWorldTransformation (void)
Returns the transformation matrix of the EO in world coordinate system. More...
osg::Vec3 | getWorldPosition (void)
Returns just the position (translation) in the world coordinates. More...
osg::Matrix | getWorldRotation (void)
Returns the rotation of the EO in world coordinates. More...
void | setIdentityTransformation (void)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation. More...
void | setPosition (const osg::Vec3 &coords)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO. More...
void | setPosition (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getPosition ()
BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO. More...
void | setRotation (float angle, float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO. More...
void | setRotation (const osg::Vec3 &angles)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Matrix &new_matrix)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setRotation (const osg::Quat &quat)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Matrix & | getRotation (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix. More...
void | setScale (const osg::Vec3 &new_scale)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
void | setScale (float x, float y, float z)
BECOMING OBSOLETE - Please use the setMatrix() method instead. More...
osg::Vec3 & | getScale (void)
BECOMING OBSOLETE - Please use the getMatrix() method instead. More...
void | setOSGAdapter (std::vector< esg::OSGAdapter * > new_osga)
(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful. More...
std::vector< esg::OSGAdapter * > * | getOSGAdapter (void)
(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful. More...
EnvironmentObject * | getParentEO (void)
Return the nearest parental EO from the scene hierarchy. More...
bool | addEOChild (EnvironmentObject *new_EO)
Add EnvironmentObject child. More...
bool | removeEOChild (EnvironmentObject *new_EO)
Removes and EO from the current object. More...
void | addUserData (const std::string &nlabel, void *npointer, UserData_Type ntype)
Adds an user data with a label. If old data with the same name exists, it will be dallocated. More...
bool | removeUserData (const std::string &label)
Removes an user data with the label. DOES NOT DEALLOCATE THE DATA. More...
UserData * | getUserData (const std::string &label)
Returns an user data with given label. More...
std::map< std::string, UserData * > | getUserDataMap (void)
Returns an user data map. More...
void | setTransparency (float transp)
Sets the transparency in interval <0;1> More...
float | getTransparency (void)
Returns the current transparency. More...
void | show ()
Make the object visible after hiding it with hide(). More...
void | hide ()
Hides the object. More...
bool | isVisible ()
Returns true if the object is current visible (use hide() / show() methods to change the visibility). More...
bool | isCollisionFree ()
Returns true if the object has some geometry loaded. More...
void | setCastShadows (bool cast)
Set whether the objects should cast shadows or not. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | updateNodeMask ()
Solve visibility, shadows and other masks bits. More...
void | createCollisionHierarchy (osg::Node *pNode)
Create collision hierarchy. More...
void | fixGeometryMirroring (const osg::Node *node)
void | fixGeometryHelper (const osg::Node *node, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
void | fixGeometryDrawableHelper (const osg::Drawable *draw, bool bMirrored)
Helper method for fixGeometryMirroring(). More...
DECLARE_INPUT (Position, MessageVec3)
DECLARE_INPUT (Orientation, MessageQuat)
DECLARE_INPUT (Location, MessageMatrix)
DECLARE_INPUT (RelativePosition, MessageVec3)
DECLARE_INPUT (RelativeOrientation, MessageQuat)
DECLARE_INPUT (RelativeLocation, MessageMatrix)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

unsigned long | id
Identification number. More...
std::string | name
Name of the EO. More...
std::string | modelFileName
Filename of the geometry. More...
AbilityDispatcher ability_dispatcher
Internal AbilityDispatcher that serve to maintain abilities in EO. More...
osg::Matrix | tempTransformMatrix
osg::Vec3 | trans_vec
Translation vector. More...
osg::Matrix | rotation_matrix
Rotation matrix. More...
osg::Vec3 | scale_vec
Scale vector. More...
float | transparency
Transparency of geometry. More...
bool | bVisible
bool | bCollisionFree
std::vector< esg::OSGAdapter * > | osgadapter_vector
Vector of the OSGAdapters. More...
std::map< std::string, UserData * > | user_data
User data map. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Friends

class World

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Enumeration Documentation

enum vrecko::EnvironmentObject::UserData_Type

Types of the UserData.

Enumerator
UD_UNKNOWN
UD_BOOL
UD_INT
UD_LONG_INT
UD_FLOAT
UD_DOUBLE
UD_STRING
UD_VEC2
UD_VEC3
UD_VEC4
UD_MATRIX
UD_QUAT
UD_POINTER
UD_USER

Constructor & Destructor Documentation

EnvironmentObject::EnvironmentObject ( )
EnvironmentObject::~EnvironmentObject ( )
EnvironmentObject::EnvironmentObject ( EnvironmentObject & eo )

Member Function Documentation

bool EnvironmentObject::addAbility | ( | Ability * | ability,
 |  | bool | bCreateNewIdIfColliding = true
 | ) |  |

Adds an ability to the EO. Use World::createAbility() instead.

Generally this method won't be used directly.

TODO (General core problem): Nowadays, it is not problem yet, but it might be someday in a multi-threaded app (think Phantom): The ability is firstly assigned to an object and THEN initialized (initialize()). If any other thread asks for this ability in the meantime, it will receive the pointer and might try to use the ability, before it is initialized.

Parameters
ability | (Ability *)
bCreateNewIdIfColliding | (bool)
Returns
(bool)
bool EnvironmentObject::addEOChild ( EnvironmentObject * new_EO )

Add EnvironmentObject child.

Adds and EO to this EO as its child.

Simply adds it between its children and registers the EO to the Scene, so the Scene knows about the EO and can send messages to it.

If you would like to add an EO as a children to a non-EO object, this is also possible, but you have to call EnvironmentObject::addChild() and Scene::registerEnvironmentObject().

Upon deletion, you would have to call Scene::unregisterEnvironmentObject() and EnvironmentObect::removeChild().

Parameters
new_EO (EnvironmentObject *)
Returns
(bool)
void EnvironmentObject::addUserData | ( | const std::string & | nlabel,
 |  | void * | npointer,
 |  | UserData_Type | ntype
 | ) |  |

Adds an user data with a label. If old data with the same name exists, it will be dallocated.

Not a recommended way, but still working. This is an alternative to using simple attributes via setAttribute() method, though much more low-level.

Parameters
nlabel | (const std::string &)
npointer | (void *)
ntype | (UserData_Type)
Returns
(void)
void EnvironmentObject::createCollisionHierarchy ( osg::Node * pNode )
protected

Create collision hierarchy.

vrecko::EnvironmentObject::DECLARE_INPUT | ( | Position | ,
 |  | MessageVec3 |
 | ) |  |
protected
The first macro below is equivalent to this:

///     osg::ref_ptr<InputPin<MessageVec3>> inputPosition;
///     void onMessagePosition(MessageVec3 *message);
///
vrecko::EnvironmentObject::DECLARE_INPUT | ( | Orientation | ,
 |  | MessageQuat |
 | ) |  |
protected
vrecko::EnvironmentObject::DECLARE_INPUT | ( | Location | ,
 |  | MessageMatrix |
 | ) |  |
protected
vrecko::EnvironmentObject::DECLARE_INPUT | ( | RelativePosition | ,
 |  | MessageVec3 |
 | ) |  |
protected
vrecko::EnvironmentObject::DECLARE_INPUT | ( | RelativeOrientation | ,
 |  | MessageQuat |
 | ) |  |
protected
vrecko::EnvironmentObject::DECLARE_INPUT | ( | RelativeLocation | ,
 |  | MessageMatrix |
 | ) |  |
protected
void EnvironmentObject::fixGeometryDrawableHelper | ( | const osg::Drawable * | draw,
 |  | bool | bMirrored
 | ) |  |
protected

Helper method for fixGeometryMirroring().

void EnvironmentObject::fixGeometryHelper | ( | const osg::Node * | node,
 |  | bool | bMirrored
 | ) |  |
protected

Helper method for fixGeometryMirroring().

void EnvironmentObject::fixGeometryMirroring ( const osg::Node * node )
protected

Corrects the wrong triangle order of mirrored objects (problem with the Skoda Fabia model). Idea: Find transformation matrices which are mirrored and reverse order of triangles in sub-objects

Ability* vrecko::EnvironmentObject::getAbility ( const std::string & ab_id )
inline

Returns ability with a specified ID.

Parameters
ab_id (const std::string &) ID to look for.
Returns
(Ability *) Pointer to an ability or NULL if not found.
Ability * EnvironmentObject::getAbility | ( | const std::string & | pluginName,
 |  | const std::string & | abilityName
 | ) |  |

Returns ability of a given type.

Note: It is really the original ability name and plugin name that will be searched for. This is stored separately from the ID, so even if you set your own ID for ability, this search will still work.

Parameters
pluginName | (const std::string &)
abilityName | (const std::string &)
Returns
(Ability *) Pointer to the ability or NULL if not found.
std::map<std::string, Ability*>& vrecko::EnvironmentObject::getAbilityMap ( void )
inline

Returns map of the abilities in the EO.

Note: In single-threaded environment, you can iterate through the map as you wish, but generally you should use this method at all in other than non-main thread. (If you don't know what is this comment talking about, you do no need to worry.)

Returns
(std::map<std::string, Ability*> &) Reference to the stored map of abilities.
Ability* vrecko::EnvironmentObject::getAbilityWithInput ( const std::string & input_name )
inline

Returns ability with a given input.

Ability* vrecko::EnvironmentObject::getAbilityWithOutput ( const std::string & output_name )
inline

Returns ability with a given output.

const unsigned long vrecko::EnvironmentObject::getID ( ) const
inline

Returns the ID of the object.

Returns
(const unsigned long) The ID.
const std::string& vrecko::EnvironmentObject::getModelFileName ( void ) const
inline

Returns the model filename.

Returns
(const std::string &)
const std::string& vrecko::EnvironmentObject::getName ( void ) const
inline

Returns the name of the object.

For details, see comments for the setName() method.

Returns
(const std::string&) The curent object name.
std::vector<esg::OSGAdapter *>* vrecko::EnvironmentObject::getOSGAdapter ( void )
inline

(OBSOLETE) Returns the vector of OSGAdapters. Currently not useful.

This method was (probably) designed for interaction with the ESG collision detection system, which is not in use at this time (summer 2011).

Returns
(std::vector<esg::OSGAdapter *>*)
EnvironmentObject * EnvironmentObject::getParentEO ( void )

Return the nearest parental EO from the scene hierarchy.

Please note that it might be not only the direct parent of this object, but also a node several levels far. This is a simple function that doesn't take instancing into account - it is always going through the parent(0), but one node can have several parents in the OSG hierarchy.

One EO with several parents could result in an undetermined situation - I don't know if it won't result into some kind of a problem (by Vit Kovalcik, one of the later core developers, summer 2011).

Returns
(EnvironmentObject*)
osg::Vec3 & EnvironmentObject::getPosition ( )

BECOMING OBSOLETE - Please use the getMatrix() method instead. Returns the position of the EO.

osg::Matrix& vrecko::EnvironmentObject::getRotation ( void )
inline

BECOMING OBSOLETE - Please use the getMatrix() method instead. Return the rotation matrix.

osg::Vec3& vrecko::EnvironmentObject::getScale ( void )
inline

BECOMING OBSOLETE - Please use the getMatrix() method instead.

float vrecko::EnvironmentObject::getTransparency ( void )
inline

Returns the current transparency.

EnvironmentObject::UserData * EnvironmentObject::getUserData ( const std::string & label )

Returns an user data with given label.

Not a recommended way, but still working. This is an alternative to using simple attributes via setAttribute() method, though much more low-level.

Parameters
label (const std::string &)
Returns
(UserData *)
std::map<std::string, UserData *> vrecko::EnvironmentObject::getUserDataMap ( void )
inline

Returns an user data map.

Not a recommended way, but still working. This is an alternative to using simple attributes via setAttribute() method, though much more low-level.

Returns
(std::map<std::string, UserData *>)
osg::Vec3 EnvironmentObject::getWorldPosition ( void )

Returns just the position (translation) in the world coordinates.

Better to use the getWorldTransformation() directly. Internally calls the getWorldTransformation() and just returns the translation (discards the rest of the data).

Returns
(osg::Vec3)
osg::Matrix EnvironmentObject::getWorldRotation ( void )

Returns the rotation of the EO in world coordinates.

Better to use the getWorldTransformation() directly. Internally calls the getWorldTransformation() and just returns the rotation (discards the rest of the data).

Returns
(osg::Matrix)
osg::Matrix & EnvironmentObject::getWorldTransformation ( void )

Returns the transformation matrix of the EO in world coordinate system.

The world transformation matrix is calculated from the object matrix and matrices of its parents, all the way up to the root.

The matrix is cached in the EO object itself and the reference to this cached copy is returned, so this is NOT THREAD SAFE. If you need to get or set object transformation in different threads, use the base::MTMatrixTransform ability. (MTMatrixTransform usage is simple, example can be found in vreckoDP_PHANToM library)

Returns
(osg::Matrix &)
void vrecko::EnvironmentObject::hide ( )
inline

Hides the object.

bool EnvironmentObject::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

bool vrecko::EnvironmentObject::isCollisionFree ( )
inline

Returns true if the object has some geometry loaded.

bool vrecko::EnvironmentObject::isVisible ( )
inline

Returns true if the object is current visible (use hide() / show() methods to change the visibility).

bool EnvironmentObject::loadGeometry | ( | const char * | filename,
 |  | bool | bOutputErrors = true
 | ) |  |

Loads geometry (usually a 3D model) from a file.

The core method to fill the EnvironmentObject with 3D data. Additionally to loading, it supports automatic "persistent caching", i.e. the file will be loaded on the first time and then immediately saved into a binary OSG format, which is very fast to load. (The saved models reside in the "cache" directory) Next time the loadGeometry() method is called, the cache is checked and if the cached data matches the original file (some date & time check is performed), the cached version is loaded instead. If the original file is modified, the cached version is automatically deleted and created again.

See Manual, this section: http://decibel.fi.muni.cz/wiki/index.php/VRECKO_PersistentCaching for more detail

Parameters
filename (const char *) Name of the file to load.
Returns
(bool) True on success.
bool EnvironmentObject::removeAbility ( Ability * pAbility )

Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use.

Warning
If you REALLY need to remove ability from an object (and attach it to another for example), please contact some core developer and ask if this is ok.
Parameters
pAbility (Ability *) Ability identified by the pointer.
Returns
(bool)
bool EnvironmentObject::removeAbility ( const std::string & ability_id )

Remove ability from the EO, but DO NOT deallocate it. WARNING - Currently it is not sure if this method is safe to use.

Warning
If you REALLY need to remove ability from an object (and attach it to another for example), please contact some core developer and ask if this is ok.
Parameters
ability_id (const std::string &) Ability identified by its ID.
Returns
(bool)
bool vrecko::EnvironmentObject::removeAllAbilities ( )
inline

"Unregisters" and deallocates all abilities of an object.

Returns
(bool) True on success.
bool EnvironmentObject::removeEOChild ( EnvironmentObject * new_EO )

Removes and EO from the current object.

Must be used instead of simple removeChild(), because removeEOChild() also unregisters object from the Scene.

Parameters
new_EO (EnvironmentObject *)
Returns
(bool)
bool EnvironmentObject::removeUserData ( const std::string & label )

Removes an user data with the label. DOES NOT DEALLOCATE THE DATA.

Not a recommended way, but still working. This is an alternative to using simple attributes via setAttribute() method, though much more low-level.

Parameters
label (const std::string &)
void EnvironmentObject::setCastShadows ( bool cast )

Set whether the objects should cast shadows or not.

bool EnvironmentObject::setGeometry | ( | osg::Geode * | new_geomtetry,
 |  | long int | k = 1,
 |  | long int | l = 100000
 | ) |  |

Adds a new geometry to the EO.

Parameters
new_geomtetry | (osg::Geode *)
k | (long int) OBSOLETE, used previously for the collision hierarchy, which has been replaced.
l | (long int) OBSOLETE, used previously for the collision hierarchy, which has been replaced.
Returns
(bool) True on success.
void EnvironmentObject::setID ( unsigned long new_id )

Set the ID of the object.

You don't need to call the method, unique ID will be assigned automatically. However, you can set your own ID if you wish. Upon adding the EO into the Scene it will be checked if the ID is unique and if it is not the nearest higher unique ID will be used.

Parameters
new_id (unsigned long) The desired ID
Returns
(void)
void EnvironmentObject::setIdentityTransformation ( void )

BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the identity transformation.

void vrecko::EnvironmentObject::setModelFileName ( const std::string mfn )
inline

Sets the filename for the model.

Useful is you are generating a new model and want to save it afterwards.

Parameters
mfn (const std::string) New model file name.
Returns
(void)
void vrecko::EnvironmentObject::setName ( const std::string & n )
inline

Sets the name of the object.

You can do it in runtime or in the XML configuration file, but it is not necessary for the system. (It might help you in debugging, for example.)

Parameters
n (const std::string &) The new name to be set.
Returns
(void)
void vrecko::EnvironmentObject::setOSGAdapter ( std::vector< esg::OSGAdapter * > new_osga )
inline

(OBSOLETE) Sets the vector of OSGAdapters. Currently not useful.

This method was (probably) designed for interaction with the ESG collision detection system, which is not in use at this time (summer 2011).

Parameters
new_osga (std::vector<esg::OSGAdapter * >)
Returns
(void)
void EnvironmentObject::setPosition ( const osg::Vec3 & coords )

BECOMING OBSOLETE - Please use the setMatrix() method instead. Sets the position of the EO.

void EnvironmentObject::setPosition | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setRotation | ( | float | angle,
 |  | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

BECOMING OBSOLETE - Please use the setMatrix() method instead. Set rotation of the EO.

void EnvironmentObject::setRotation ( const osg::Vec3 & angles )

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setRotation ( const osg::Matrix & new_matrix )

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setRotation ( const osg::Quat & quat )

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setScale ( const osg::Vec3 & new_scale )

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setScale | ( | float | x,
 |  | float | y,
 |  | float | z
 | ) |  |

BECOMING OBSOLETE - Please use the setMatrix() method instead.

void EnvironmentObject::setTransparency ( float transp )

Sets the transparency in interval <0;1>

You can get much more effects if you create the ObjectUtils::ObjectEffect ability.

Parameters
transp (float) Transparency in the range 0.0 ... 1.0
Returns
(void)
void vrecko::EnvironmentObject::show ( )
inline

Make the object visible after hiding it with hide().

void EnvironmentObject::updateNodeMask ( )
protected

Solve visibility, shadows and other masks bits.

Friends And Related Function Documentation

friend class World
friend

Member Data Documentation

AbilityDispatcher vrecko::EnvironmentObject::ability_dispatcher
protected

Internal AbilityDispatcher that serve to maintain abilities in EO.

bool vrecko::EnvironmentObject::bCollisionFree
protected
bool vrecko::EnvironmentObject::bVisible
protected
unsigned long vrecko::EnvironmentObject::id
protected

Identification number.

std::string vrecko::EnvironmentObject::modelFileName
protected

Filename of the geometry.

std::string vrecko::EnvironmentObject::name
protected

Name of the EO.

std::vector<esg::OSGAdapter *> vrecko::EnvironmentObject::osgadapter_vector
protected

Vector of the OSGAdapters.

osg::Matrix vrecko::EnvironmentObject::rotation_matrix
protected

Rotation matrix.

osg::Vec3 vrecko::EnvironmentObject::scale_vec
protected

Scale vector.

osg::Matrix vrecko::EnvironmentObject::tempTransformMatrix
protected
osg::Vec3 vrecko::EnvironmentObject::trans_vec
protected

Translation vector.

float vrecko::EnvironmentObject::transparency
protected

Transparency of geometry.

std::map<std::string, UserData *> vrecko::EnvironmentObject::user_data
protected

User data map.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EnvironmentObject.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/EnvironmentObject.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EnvironmentObject::UserData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EnvironmentObject
  • UserData
Public Attributes | List of all members
vrecko::EnvironmentObject::UserData Struct Reference

Here are stored pointer to UserData and its type. More...

#include <EnvironmentObject.h>

Public Attributes

void * pointer
UserData_Type type

Detailed Description

Here are stored pointer to UserData and its type.

Member Data Documentation

void* vrecko::EnvironmentObject::UserData::pointer
UserData_Type vrecko::EnvironmentObject::UserData::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EnvironmentObject.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
Classes | Public Types | Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
vrecko::EventDispatcher Class Reference

#include <EventDispatcher.h>

Inheritance diagram for vrecko::EventDispatcher:
vrecko::BaseClass

Classes

struct | EventDefinitionStruct
Struct that defines an event. More...
struct | EventStruct
Struct contains received event. More...
struct | ICS
struct | ICSBase
Struct that holds identification of receiver and interconnection type. More...
struct | REQUEST_Struct
struct | StringWithHash
struct | StringWithHashComparator

Public Types

enum InterconnectionType { FORWARD_OUTPUT = 1, ACTIVATE_INPUT, REQUEST }
Types of an interconnection in the EventDispatcher. More...
enum SRType {
UNKNOWN = 0, ENVIRONMENTOBJECT, ABILITY, DEVICE,
SCENE, WORLD, OUTER_OBJECT
}
Type of an sender/receiver. More...
typedef std::multimap
< StringWithHash, ICS
*, StringWithHashComparator > 		EI_Type
typedef std::map
< StringWithHash,
REQUEST_Struct,
StringWithHashComparator > 		REQUEST_Map
The type of the request/default_request maps. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

EventDispatcher ()
~EventDispatcher ()
EventDispatcher (EventDispatcher &ed)
void | setMainThreadId (pthread_t ptID)
bool | insertEventInterconnection (const std::string &sender, const std::string &receiver, InterconnectionType type=FORWARD_OUTPUT, const std::string &sceneFile=*((std::string *) NULL))
bool | deleteEventInterconnection (const std::string &sender, const std::string &receiver, InterconnectionType type=FORWARD_OUTPUT)
void | dirtyInterconnectionsForObject (BaseClass *object, bool bProcessEvents=true, bool bProcessRequests=true)
bool | reportEvent (const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT)
bool | reportEvent (BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT)
osg::ref_ptr< VreckoMessage > | request (const std::string &req_sender, VreckoMessage *pMessage)
osg::ref_ptr< VreckoMessage > | request (BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage)
void | update (void)
void | setScenePtr (Scene *ptr)
bool | addOuterObject (const std::string &object_id, BaseClass *pOObject)
bool | removeOuterObject (const std::string &object_id)
bool | removeOuterObject (BaseClass *pOObject)
EI_Type & getEventInterconnectionMap ()
REQUEST_Map & getRequestInterconnectionMap ()
REQUEST_Map & getDefaultRequestInterconnectionMap ()
std::vector
< EventDefinitionStruct > & 		getEventsVector (void)
Return reference to eventsVector. More...
void | setNetSupport (bool status)
bool | parseSR (const std::string &sr, bool isSender, BaseClass **pEntity, SRType *pSRType, std::string *pIOName, osg::ref_ptr< VreckoMessage > *pRefMessage, bool isRequest=false, bool noErrorOuptut=false)
Core method to parse render (or receiver) string and return all the components independently. More...
int | getProcessedEventsCounter ()
void | resetProcessedEventsCounter ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

typedef std::vector< std::string > Decomposition_vec
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Protected Member Functions

bool | isInMainThread ()
void | processBatchOfEvents (std::vector< EventStruct * > *ref_incoming_events, bool bTurnOffForegroundQueing)
void | processEvent (EventStruct *pES)
bool | reportEventCore (BaseClass *receiver_ptr, const std::string &sender, VreckoMessage *pMessage, EventType eType)
void | debugPrintInterconnectionMap (EI_Type *map)
void | debugPrintRequestMap (REQUEST_Map *map)
bool | checkInterconnection (const std::string &sender, const std::string &receiver, bool bRequest)
Checks interconnection for any problems (missing sender/receiver), incorrect output/input types. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::vector
< EventDefinitionStruct > 		eventsVector
Vector with all defined events. More...
EI_Type event_interconnection_map
Multimap where the interconnection between sender and receiver are stored . More...
std::vector< EventStruct * > | incoming_events [2]
List of the incoming events. More...
int | bgListId
bool | bAllowForegroundListQueing
std::map< std::string, void * > | received_event_map
Multimap with all last received events. More...
std::map< std::string,
Decomposition_vec > 		sender_decomposition
Decomposition of the sender string. More...
std::map< std::string,
Decomposition_vec > 		receiver_decomposition
Decomposition of the receiver string. More...
REQUEST_Map request_interconnection_map
REQUEST_Map default_request_interconnection_map
Scene * scene_ptr
Pointer to the Scene that holds this EventDispatcher. More...
std::map< std::string,
BaseClass * > 		outerObject_map
Pointer to the Outer receiveEvents function. More...
int | iProcessedEventsCounter
bool | net_support
Net support flag. More...
pthread_t | hMainThreadId
MTLock mainLock
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Detailed Description

EventDispatcher class is an entity that is used for message/request sending and manages the interconnections.

Member Typedef Documentation

typedef std::vector<std::string> vrecko::EventDispatcher::Decomposition_vec
protected
typedef std::multimap<StringWithHash, ICS *, StringWithHashComparator> vrecko::EventDispatcher::EI_Type

Type of event_interconnection_map.

TODO OPTIM?: The message sending can probably be sped up without much effort. This is the idea: Multimap is a tree in reality, searching is done in log-time, which is good. The keys are strings and comparing strings is not that fast. We could use some struct { string originalValue; unsigned long calculatedHash; } and create own comparator to compare the hash first and the string second. But we would need to make some tests to see if this brings any performance increase. (There will be drawback that we would need to calculate the hash for every message.)

typedef std::map<StringWithHash, REQUEST_Struct, StringWithHashComparator> vrecko::EventDispatcher::REQUEST_Map

The type of the request/default_request maps.

Member Enumeration Documentation

enum vrecko::EventDispatcher::InterconnectionType

Types of an interconnection in the EventDispatcher.

Enumerator
FORWARD_OUTPUT | Just forward the message to the other object.
ACTIVATE_INPUT | If the received message has value X then send the message with value Y to the other object (X and Y might be of a completely differrent types).
REQUEST | Immediately send a request and receive a return value.
enum vrecko::EventDispatcher::SRType

Type of an sender/receiver.

Enumerator
UNKNOWN
ENVIRONMENTOBJECT
ABILITY
DEVICE
SCENE
WORLD
OUTER_OBJECT

Constructor & Destructor Documentation

EventDispatcher::EventDispatcher ( )
EventDispatcher::~EventDispatcher ( )
EventDispatcher::EventDispatcher ( EventDispatcher & ed )

Member Function Documentation

bool EventDispatcher::addOuterObject | ( | const std::string & | object_id,
 |  | BaseClass * | pOObject
 | ) |  |

Adds an outer object. Not useful for 99 % of people.

Outer object can receive messages from Vrecko.

bool EventDispatcher::checkInterconnection | ( | const std::string & | sender,
 |  | const std::string & | receiver,
 |  | bool | bRequest
 | ) |  |
protected

Checks interconnection for any problems (missing sender/receiver), incorrect output/input types.

Great for debug, but can be turned off.

void EventDispatcher::debugPrintInterconnectionMap ( EI_Type * map )
protected

Prints out the interconnection map for debug purposes.

void EventDispatcher::debugPrintRequestMap ( REQUEST_Map * map )
protected

Prints out the requests interconnection map for debug purposes.

bool EventDispatcher::deleteEventInterconnection | ( | const std::string & | sender,
 |  | const std::string & | receiver,
 |  | InterconnectionType | type = FORWARD_OUTPUT
 | ) |  |

This function serves to delete an event interconnection from the database. Returns true if no problem occurs.

void EventDispatcher::dirtyInterconnectionsForObject | ( | BaseClass * | object,
 |  | bool | bProcessEvents = true,
 |  | bool | bProcessRequests = true
 | ) |  |

An object/ability/device/... might be deleted or added, so we have to recheck the interconnections whether the pointers to receivers are still valid. This is not done immediately, but on the next usage of the respective interconnection.

REQUEST_Map& vrecko::EventDispatcher::getDefaultRequestInterconnectionMap ( )
inline
EI_Type& vrecko::EventDispatcher::getEventInterconnectionMap ( )
inline
std::vector<EventDefinitionStruct>& vrecko::EventDispatcher::getEventsVector ( void )
inline

Return reference to eventsVector.

int vrecko::EventDispatcher::getProcessedEventsCounter ( )
inline

Debug method to get number of processed events.

REQUEST_Map& vrecko::EventDispatcher::getRequestInterconnectionMap ( )
inline
bool EventDispatcher::insertEventInterconnection | ( | const std::string & | sender,
 |  | const std::string & | receiver,
 |  | InterconnectionType | type = FORWARD_OUTPUT,
 |  | const std::string & | sceneFile = *((std::string*)NULL)
 | ) |  |

This function serves to insert new event interconnection to the database.

Returns true if no problem occurs. The [sceneFile] is a file that this connection was loaded from and will be saved to. 1) Might be NULL which means the defaultSceneFile will be used (see getSafeDefaultSceneFile() etc.) 2) Might be an empty string meaning "don't save to a file"

bool EventDispatcher::isInMainThread ( )
protected

returns true if we are currently in the main thread.

bool EventDispatcher::parseSR | ( | const std::string & | sr,
 |  | bool | isSender,
 |  | BaseClass ** | pEntity,
 |  | SRType * | pSRType,
 |  | std::string * | pIOName,
 |  | osg::ref_ptr< VreckoMessage > * | pRefMessage,
 |  | bool | isRequest = false,
 |  | bool | noErrorOuptut = false
 | ) |  |

Core method to parse render (or receiver) string and return all the components independently.

This method also checks if the specified object and input/output exists and prints out an error message if it doesn't (you can disable this behaviour - see the "noErrorOutput" parameter).

Parameters
sr | (const std::string &) Complete sender string in the form "Wr#Ab|navigation::KMTracker#Orientation" or "Wr#Ab|navigation::KMTracker#Right|0"
isSender | (bool) Is it a sender string or a receiver string? (this will be mostly used to check whether the specified output or input exists)
pEntity | (BaseClass * *) Output variable to hold a pointer to a specified entity.
pSRType | (SRType *) Output variable to hold SRType
pIOName | (std::string *) Output variable to hold the input name
pRefMessage | (osg::ref_ptr<VreckoMessage> *) Output variable to hold a "reference message", this is only created for inputs/outputs with a value specified (the "|0" in the above example)
isRequest | (bool) Input - is it a request?
noErrorOuptut | (bool) If "true" then no errors will be printed if a specified object or input/output doesn't exist.
Returns
(bool) Returns "true" if there was no error.
void EventDispatcher::processBatchOfEvents | ( | std::vector< EventStruct * > * | ref_incoming_events,
 |  | bool | bTurnOffForegroundQueing
 | ) |  |
protected
void EventDispatcher::processEvent ( EventStruct * pES )
protected
bool EventDispatcher::removeOuterObject ( const std::string & object_id )

Removes an outer object specified by its ID.

bool EventDispatcher::removeOuterObject ( BaseClass * pOObject )

Removes an outer object specified by the pointer.

bool vrecko::EventDispatcher::reportEvent | ( | const std::string & | senderAndOutputString,
 |  | VreckoMessage * | pMessage,
 |  | EventType | eType = EXPRESS_EVENT
 | ) |  |
inline

(Very low-level, you should use input pins with DECLARE_INPUT etc. macros if possible) Through this function, any object can send an event to EventDispatcher.

Returns true if the event will be processed.

bool vrecko::EventDispatcher::reportEvent | ( | BaseClass * | receiver_ptr,
 |  | const std::string & | input_name,
 |  | VreckoMessage * | pMessage,
 |  | EventType | eType = EXPRESS_EVENT
 | ) |  |
inline

(A bit low-level, you should use input pins with DECLARE_INPUT etc. macros if possible) Through this function, any object can send an event to EventDispatcher. Returns true if the event will be processed.

bool EventDispatcher::reportEventCore | ( | BaseClass * | receiver_ptr,
 |  | const std::string & | sender,
 |  | VreckoMessage * | pMessage,
 |  | EventType | eType
 | ) |  |
protected
osg::ref_ptr< VreckoMessage > EventDispatcher::request | ( | const std::string & | req_sender,
 |  | VreckoMessage * | pMessage
 | ) |  |

(Very low-level, you should use input pins with DECLARE_REQUEST_INPUT etc. macros) Send a request.

osg::ref_ptr< VreckoMessage > EventDispatcher::request | ( | BaseClass * | receiver_ptr,
 |  | const std::string & | request_name,
 |  | VreckoMessage * | pMessage
 | ) |  |

(A bit low-level, you should use input pins with DECLARE_REQUEST_INPUT etc. macros if possible) Send a direct request.

void vrecko::EventDispatcher::resetProcessedEventsCounter ( )
inline

Debug method to reset the number of processed messages.

void vrecko::EventDispatcher::setMainThreadId ( pthread_t ptID )
inline
void EventDispatcher::setNetSupport ( bool status )

OBSOLETE - Network support is not working (was never fully working and with requests it is not probable it will ever be).

void vrecko::EventDispatcher::setScenePtr ( Scene * ptr )
inline

Sets the Scene that holds this EventDispatcher.

void EventDispatcher::update ( void )
virtual

Updates the EventDispatcher.

Will process pending messages.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool vrecko::EventDispatcher::bAllowForegroundListQueing
protected
int vrecko::EventDispatcher::bgListId
protected
REQUEST_Map vrecko::EventDispatcher::default_request_interconnection_map
protected
EI_Type vrecko::EventDispatcher::event_interconnection_map
protected

Multimap where the interconnection between sender and receiver are stored .

std::vector<EventDefinitionStruct> vrecko::EventDispatcher::eventsVector
protected

Vector with all defined events.

pthread_t vrecko::EventDispatcher::hMainThreadId
protected
std::vector<EventStruct*> vrecko::EventDispatcher::incoming_events[2]
protected

List of the incoming events.

int vrecko::EventDispatcher::iProcessedEventsCounter
protected
MTLock vrecko::EventDispatcher::mainLock
protected
bool vrecko::EventDispatcher::net_support
protected

Net support flag.

std::map<std::string, BaseClass *> vrecko::EventDispatcher::outerObject_map
protected

Pointer to the Outer receiveEvents function.

std::map<std::string, void*> vrecko::EventDispatcher::received_event_map
protected

Multimap with all last received events.

std::map<std::string, Decomposition_vec> vrecko::EventDispatcher::receiver_decomposition
protected

Decomposition of the receiver string.

REQUEST_Map vrecko::EventDispatcher::request_interconnection_map
protected
Scene* vrecko::EventDispatcher::scene_ptr
protected

Pointer to the Scene that holds this EventDispatcher.

std::map<std::string, Decomposition_vec> vrecko::EventDispatcher::sender_decomposition
protected

Decomposition of the sender string.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/EventDispatcher.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::EventDefinitionStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • EventDefinitionStruct
Public Attributes | List of all members
vrecko::EventDispatcher::EventDefinitionStruct Struct Reference

Struct that defines an event. More...

#include <EventDispatcher.h>

Public Attributes

std::string | sender
std::string | receiver
InterconnectionType type
const std::string * | sceneFile

Detailed Description

Struct that defines an event.

Member Data Documentation

std::string vrecko::EventDispatcher::EventDefinitionStruct::receiver
const std::string* vrecko::EventDispatcher::EventDefinitionStruct::sceneFile
std::string vrecko::EventDispatcher::EventDefinitionStruct::sender
InterconnectionType vrecko::EventDispatcher::EventDefinitionStruct::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::EventStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • EventStruct
Public Attributes | List of all members
vrecko::EventDispatcher::EventStruct Struct Reference

Struct contains received event. More...

#include <EventDispatcher.h>

Public Attributes

EventType eventType
BaseClass * pReceiver
std::string | senderIdOrInputName
osg::ref_ptr< VreckoMessage > | message

Detailed Description

Struct contains received event.

Member Data Documentation

EventType vrecko::EventDispatcher::EventStruct::eventType
osg::ref_ptr<VreckoMessage> vrecko::EventDispatcher::EventStruct::message
BaseClass* vrecko::EventDispatcher::EventStruct::pReceiver
std::string vrecko::EventDispatcher::EventStruct::senderIdOrInputName
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::ICS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • ICS
Public Attributes | List of all members
vrecko::EventDispatcher::ICS Struct Reference

#include <EventDispatcher.h>

Inheritance diagram for vrecko::EventDispatcher::ICS:
vrecko::EventDispatcher::ICSBase

Public Attributes

std::string | sender
osg::ref_ptr< VreckoMessage > | conditionalMessage
osg::ref_ptr< VreckoMessage > | activationMessage
- Public Attributes inherited from vrecko::EventDispatcher::ICSBase
friend | EventDispatcher
std::string | receiver
std::string | receiverPin
InterconnectionType type

Additional Inherited Members

- Public Member Functions inherited from vrecko::EventDispatcher::ICSBase
ICSBase ()
void | setReceiverPtrDirty ()
BaseClass * getReceiverPtr ()
- Protected Member Functions inherited from vrecko::EventDispatcher::ICSBase
VRECKO_EXPORT BaseClass * | getReceiverPtrCore ()
- Protected Attributes inherited from vrecko::EventDispatcher::ICSBase
BaseClass * _receiver_ptr
This is just a cache. If the pointer is NULL, it is "dirty" and should be recached on the next use. More...

Member Data Documentation

osg::ref_ptr<VreckoMessage> vrecko::EventDispatcher::ICS::activationMessage
osg::ref_ptr<VreckoMessage> vrecko::EventDispatcher::ICS::conditionalMessage

Might be NULL (in case of FORWARD_MESSAGE behavior) or a message if the event should be sent only if it is of certain value (ACTIVATE_INPUT behavior). (The incoming message would be than compared to this reference one)

std::string vrecko::EventDispatcher::ICS::sender
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::ICSBase Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • ICSBase
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | List of all members
vrecko::EventDispatcher::ICSBase Struct Reference

Struct that holds identification of receiver and interconnection type. More...

#include <EventDispatcher.h>

Inheritance diagram for vrecko::EventDispatcher::ICSBase:
vrecko::EventDispatcher::ICS vrecko::EventDispatcher::REQUEST_Struct

Public Member Functions

ICSBase ()
void setReceiverPtrDirty ()
BaseClass * getReceiverPtr ()

Public Attributes

friend | EventDispatcher
std::string | receiver
std::string | receiverPin
InterconnectionType type

Protected Member Functions

VRECKO_EXPORT BaseClass * getReceiverPtrCore ()

Protected Attributes

BaseClass * _receiver_ptr
This is just a cache. If the pointer is NULL, it is "dirty" and should be recached on the next use. More...

Detailed Description

Struct that holds identification of receiver and interconnection type.

Constructor & Destructor Documentation

vrecko::EventDispatcher::ICSBase::ICSBase ( )
inline

Member Function Documentation

BaseClass* vrecko::EventDispatcher::ICSBase::getReceiverPtr ( )
inline

Returns the receiver pointer. The pointer is cached, which means it has to be invalidated (externally) when a change occurs. This is done for example during the pin removal by calling EventDispatcher::dirtyInterconnectionsForObject().

BaseClass * EventDispatcher::ICSBase::getReceiverPtrCore ( )
protected
void vrecko::EventDispatcher::ICSBase::setReceiverPtrDirty ( )
inline

Member Data Documentation

BaseClass* vrecko::EventDispatcher::ICSBase::_receiver_ptr
protected

This is just a cache. If the pointer is NULL, it is "dirty" and should be recached on the next use.

friend vrecko::EventDispatcher::ICSBase::EventDispatcher
std::string vrecko::EventDispatcher::ICSBase::receiver
std::string vrecko::EventDispatcher::ICSBase::receiverPin
InterconnectionType vrecko::EventDispatcher::ICSBase::type
The documentation for this struct was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/EventDispatcher.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::REQUEST_Struct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • REQUEST_Struct
Public Attributes | List of all members
vrecko::EventDispatcher::REQUEST_Struct Struct Reference

#include <EventDispatcher.h>

Inheritance diagram for vrecko::EventDispatcher::REQUEST_Struct:
vrecko::EventDispatcher::ICSBase

Public Attributes

const std::string * | sceneFile
- Public Attributes inherited from vrecko::EventDispatcher::ICSBase
friend | EventDispatcher
std::string | receiver
std::string | receiverPin
InterconnectionType type

Additional Inherited Members

- Public Member Functions inherited from vrecko::EventDispatcher::ICSBase
ICSBase ()
void | setReceiverPtrDirty ()
BaseClass * getReceiverPtr ()
- Protected Member Functions inherited from vrecko::EventDispatcher::ICSBase
VRECKO_EXPORT BaseClass * | getReceiverPtrCore ()
- Protected Attributes inherited from vrecko::EventDispatcher::ICSBase
BaseClass * _receiver_ptr
This is just a cache. If the pointer is NULL, it is "dirty" and should be recached on the next use. More...

Member Data Documentation

const std::string* vrecko::EventDispatcher::REQUEST_Struct::sceneFile
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::StringWithHash Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • StringWithHash
Public Member Functions | Public Attributes | List of all members
vrecko::EventDispatcher::StringWithHash Struct Reference

#include <EventDispatcher.h>

Public Member Functions

StringWithHash ()
StringWithHash (const std::string &str)
StringWithHash (const StringWithHash &src)
unsigned int calculateHash (const char *str)

Public Attributes

std::string | originalString
unsigned int | hashValue

Constructor & Destructor Documentation

vrecko::EventDispatcher::StringWithHash::StringWithHash ( )
inline
vrecko::EventDispatcher::StringWithHash::StringWithHash ( const std::string & str )
inline
vrecko::EventDispatcher::StringWithHash::StringWithHash ( const StringWithHash & src )
inline

Member Function Documentation

unsigned int vrecko::EventDispatcher::StringWithHash::calculateHash ( const char * str )
inline

Member Data Documentation

unsigned int vrecko::EventDispatcher::StringWithHash::hashValue
std::string vrecko::EventDispatcher::StringWithHash::originalString
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::EventDispatcher::StringWithHashComparator Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • StringWithHashComparator
Public Member Functions | List of all members
vrecko::EventDispatcher::StringWithHashComparator Struct Reference

#include <EventDispatcher.h>

Public Member Functions

bool operator() (const StringWithHash &a, StringWithHash const &b)

Member Function Documentation

bool vrecko::EventDispatcher::StringWithHashComparator::operator() | ( | const StringWithHash & | a,
 |  | StringWithHash const & | b
 | ) |  |
inline
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Interval< tval, tref > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Interval
Public Member Functions | List of all members
vrecko::Interval< tval, tref > Class Template Reference

#include <Interval.h>

Inheritance diagram for vrecko::Interval< tval, tref >:
vrecko::Range

Public Member Functions

Interval (tref lowerBound, tref upperBound)
Interval (tref lowerBound, tref upperBound, bool lowerInclusive, bool upperInclusive)
tref | getLowerBound () const
tref | getUpperBound () const
bool | isLowerInclusive () const
bool | isUpperInclusive () const
bool | includesValue (tref value) const
- Public Member Functions inherited from vrecko::Range
bool | isInterval () const
bool | isEnumeration () const

Additional Inherited Members

- Public Types inherited from vrecko::Range
enum RangeType { RANGE_INTERVAL, RANGE_ENUMERATION }
- Protected Member Functions inherited from vrecko::Range
Range (RangeType rangeType)
Range (const Range &range)

Detailed Description

template<class tval, class tref = tval>
class vrecko::Interval< tval, tref >

Represents an immutable interval.

This class uses templates. Specialized classes are prepared for int, long, float and double data types. No other specializations should be used. Specialized classes are listed below definition of this class.

Parameters
tval | data type used for values storage
tref | data type used for arguments and results passing
See Also
Range
Enumeration
IntInterval
LongInterval
FloatInterval
DoubleInterval

Constructor & Destructor Documentation

template<class tval , class tref = tval>
vrecko::Interval< tval, tref >::Interval | ( | tref | lowerBound,
 |  | tref | upperBound
 | ) |  |
inline

Constructs an implicitly closed Interval object.

Parameters
lowerBound | value of the lower bound of the interval
upperBound | value of the upper bound of the interval
template<class tval , class tref = tval>
vrecko::Interval< tval, tref >::Interval | ( | tref | lowerBound,
 |  | tref | upperBound,
 |  | bool | lowerInclusive,
 |  | bool | upperInclusive
 | ) |  |
inline

Constructs an Interval object.

Parameters
lowerBound | value of the lower bound of the interval
upperBound | value of the upper bound of the interval
lowerInclusive | inclusion flag for the lower bound
upperInclusive | inclusion flag for the upper bound

Member Function Documentation

template<class tval , class tref = tval>
tref vrecko::Interval< tval, tref >::getLowerBound ( ) const
inline

Returns the lower bound.

Returns
current value of the lower bound
template<class tval , class tref = tval>
tref vrecko::Interval< tval, tref >::getUpperBound ( ) const
inline

Returns the upper bound.

Returns
current value of the upper bound
template<class tval , class tref = tval>
bool vrecko::Interval< tval, tref >::includesValue ( tref value ) const
inline

"Includes value" predicate.

Parameters
value value to be checked
Returns
true if the value is included in the interval, false otherwise
template<class tval , class tref = tval>
bool vrecko::Interval< tval, tref >::isLowerInclusive ( ) const
inline

"Is lower inclusive" predicate.

Returns
true if the interval is lower bound inclusive, false otherwise
template<class tval , class tref = tval>
bool vrecko::Interval< tval, tref >::isUpperInclusive ( ) const
inline

"Is upper inclusive" predicate.

Returns
true if the interval is upper bound inclusive, false otherwise
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Interval.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::InputPin< _MessageType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • InputPin
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::InputPin< _MessageType > Class Template Reference

#include <IOPins.h>

Inheritance diagram for vrecko::InputPin< _MessageType >:
vrecko::InputPinBase vrecko::IOPinBase

Public Types

typedef void(BaseClass::* PROCESSING_METHOD )(_MessageType *message)

Public Member Functions

InputPin (BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing)
~InputPin ()
virtual VreckoMessage * | createCompatibleMessage ()
Creates an instance of a message type that is recognized by this input/output. More...
virtual void | processMessage (VreckoMessage *message)
Method that is called when the actual message is received. More...

Protected Member Functions

void coreInit (BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing)

Protected Attributes

PROCESSING_METHOD methodForProcessing

Member Typedef Documentation

template<class _MessageType >
typedef void(BaseClass::* vrecko::InputPin< _MessageType >::PROCESSING_METHOD)(_MessageType *message)

Constructor & Destructor Documentation

template<class _MessageType >
vrecko::InputPin< _MessageType >::InputPin | ( | BaseClass * | _owner,
 |  | const char * | _inputName,
 |  | PROCESSING_METHOD | _methodForProcessing
 | ) |  |
inline
template<class _MessageType >
vrecko::InputPin< _MessageType >::~InputPin ( )
inline

Member Function Documentation

template<class _MessageType >
void vrecko::InputPin< _MessageType >::coreInit | ( | BaseClass * | _owner,
 |  | const char * | _inputName,
 |  | PROCESSING_METHOD | _methodForProcessing
 | ) |  |
inlineprotected
template<class _MessageType >
virtual VreckoMessage* vrecko::InputPin< _MessageType >::createCompatibleMessage ( )
inlinevirtual

Creates an instance of a message type that is recognized by this input/output.

If you will create a new descendant class of type XY, this method will generally be:

virtual VreckoMessage* createCompatibleMessage() { return new XY; };

Returns
(VreckoMessage*)

Implements vrecko::IOPinBase.

template<class _MessageType >
virtual void vrecko::InputPin< _MessageType >::processMessage ( VreckoMessage * message )
inlinevirtual

Method that is called when the actual message is received.

Parameters
message (VreckoMessage *)
Returns
(void)

Implements vrecko::InputPinBase.

Member Data Documentation

template<class _MessageType >
PROCESSING_METHOD vrecko::InputPin< _MessageType >::methodForProcessing
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::OutputPin< _MessageType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OutputPin
Public Member Functions | Protected Attributes | List of all members
vrecko::OutputPin< _MessageType > Class Template Reference

#include <IOPins.h>

Inheritance diagram for vrecko::OutputPin< _MessageType >:
vrecko::OutputPinBase vrecko::IOPinBase

Public Member Functions

OutputPin (BaseClass *_owner, const char *_outputName)
~OutputPin ()
virtual VreckoMessage * | createCompatibleMessage ()
Creates an instance of a message type that is recognized by this input/output. More...
bool | send (_MessageType *messageToBeSent, EventType eventType=EXPRESS_EVENT)

Protected Attributes

std::string senderStringWithOutputName

Constructor & Destructor Documentation

template<class _MessageType>
vrecko::OutputPin< _MessageType >::OutputPin | ( | BaseClass * | _owner,
 |  | const char * | _outputName
 | ) |  |
inline
template<class _MessageType>
vrecko::OutputPin< _MessageType >::~OutputPin ( )
inline

Member Function Documentation

template<class _MessageType>
virtual VreckoMessage* vrecko::OutputPin< _MessageType >::createCompatibleMessage ( )
inlinevirtual

Creates an instance of a message type that is recognized by this input/output.

If you will create a new descendant class of type XY, this method will generally be:

virtual VreckoMessage* createCompatibleMessage() { return new XY; };

Returns
(VreckoMessage*)

Implements vrecko::IOPinBase.

template<class _MessageType>
bool vrecko::OutputPin< _MessageType >::send | ( | _MessageType * | messageToBeSent,
 |  | EventType | eventType = EXPRESS_EVENT
 | ) |  |
inline

Member Data Documentation

template<class _MessageType>
std::string vrecko::OutputPin< _MessageType >::senderStringWithOutputName
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::RequestInputPin< _MessageType, _ReturningMessageType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestInputPin
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::RequestInputPin< _MessageType, _ReturningMessageType > Class Template Reference

#include <IOPins.h>

Inheritance diagram for vrecko::RequestInputPin< _MessageType, _ReturningMessageType >:
vrecko::RequestInputPinBase vrecko::IORequestPinBase vrecko::IOPinBase

Public Types

typedef osg::ref_ptr
< _ReturningMessageType >
(BaseClass::* 		PROCESSING_METHOD )(_MessageType *message)

Public Member Functions

RequestInputPin (BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing)
~RequestInputPin ()
virtual VreckoMessage * | createCompatibleMessage ()
Creates an instance of a message type that is recognized by this input/output. More...
virtual VreckoMessage * | createReturningCompatibleMessage ()
Same as IOPinBase::createCompatibleMessage() but for the returning message type. More...
virtual osg::ref_ptr
< VreckoMessage > 		processRequest (VreckoMessage *message)
Method that is called when actual request is received. More...

Protected Member Functions

void coreInit (BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing)

Protected Attributes

PROCESSING_METHOD methodForProcessing

Member Typedef Documentation

template<class _MessageType , class _ReturningMessageType >
typedef osg::ref_ptr<_ReturningMessageType>(BaseClass::* vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::PROCESSING_METHOD)(_MessageType *message)

Constructor & Destructor Documentation

template<class _MessageType , class _ReturningMessageType >
vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::RequestInputPin | ( | BaseClass * | _owner,
 |  | const char * | _requestInputName,
 |  | PROCESSING_METHOD | _methodForProcessing
 | ) |  |
inline
template<class _MessageType , class _ReturningMessageType >
vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::~RequestInputPin ( )
inline

Member Function Documentation

template<class _MessageType , class _ReturningMessageType >
void vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::coreInit | ( | BaseClass * | _owner,
 |  | const char * | _requestInputName,
 |  | PROCESSING_METHOD | _methodForProcessing
 | ) |  |
inlineprotected
template<class _MessageType , class _ReturningMessageType >
virtual VreckoMessage* vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::createCompatibleMessage ( )
inlinevirtual

Creates an instance of a message type that is recognized by this input/output.

If you will create a new descendant class of type XY, this method will generally be:

virtual VreckoMessage* createCompatibleMessage() { return new XY; };

Returns
(VreckoMessage*)

Implements vrecko::IOPinBase.

template<class _MessageType , class _ReturningMessageType >
virtual VreckoMessage* vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::createReturningCompatibleMessage ( )
inlinevirtual

Same as IOPinBase::createCompatibleMessage() but for the returning message type.

Returns
(VreckoMessage*)

Implements vrecko::IORequestPinBase.

template<class _MessageType , class _ReturningMessageType >
virtual osg::ref_ptr<VreckoMessage> vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::processRequest ( VreckoMessage * message )
inlinevirtual

Method that is called when actual request is received.

Parameters
message (VreckoMessage *)
Returns
(osg::ref_ptr<VreckoMessage>)

Implements vrecko::RequestInputPinBase.

Member Data Documentation

template<class _MessageType , class _ReturningMessageType >
PROCESSING_METHOD vrecko::RequestInputPin< _MessageType, _ReturningMessageType >::methodForProcessing
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestOutputPin
Public Member Functions | Protected Attributes | List of all members
vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > Class Template Reference

#include <IOPins.h>

Inheritance diagram for vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >:
vrecko::RequestOutputPinBase vrecko::IORequestPinBase vrecko::IOPinBase

Public Member Functions

RequestOutputPin (BaseClass *_owner, const char *_requestOutputName)
~RequestOutputPin ()
virtual VreckoMessage * | createCompatibleMessage ()
Creates an instance of a message type that is recognized by this input/output. More...
virtual VreckoMessage * | createReturningCompatibleMessage ()
Same as IOPinBase::createCompatibleMessage() but for the returning message type. More...
osg::ref_ptr
< _ReturningMessageType > 		request (_MessageType *messageToBeSent)

Protected Attributes

std::string senderStringWithOutputName

Constructor & Destructor Documentation

template<class _MessageType , class _ReturningMessageType >
vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::RequestOutputPin | ( | BaseClass * | _owner,
 |  | const char * | _requestOutputName
 | ) |  |
inline
template<class _MessageType , class _ReturningMessageType >
vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::~RequestOutputPin ( )
inline

Member Function Documentation

template<class _MessageType , class _ReturningMessageType >
virtual VreckoMessage* vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::createCompatibleMessage ( )
inlinevirtual

Creates an instance of a message type that is recognized by this input/output.

If you will create a new descendant class of type XY, this method will generally be:

virtual VreckoMessage* createCompatibleMessage() { return new XY; };

Returns
(VreckoMessage*)

Implements vrecko::IOPinBase.

template<class _MessageType , class _ReturningMessageType >
virtual VreckoMessage* vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::createReturningCompatibleMessage ( )
inlinevirtual

Same as IOPinBase::createCompatibleMessage() but for the returning message type.

Returns
(VreckoMessage*)

Implements vrecko::IORequestPinBase.

template<class _MessageType , class _ReturningMessageType >
osg::ref_ptr<_ReturningMessageType> vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::request ( _MessageType * messageToBeSent )
inline

Member Data Documentation

template<class _MessageType , class _ReturningMessageType >
std::string vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >::senderStringWithOutputName
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Logger Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
Classes | Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
vrecko::Logger Class Reference

#include <Logger.h>

Classes

struct | OutputNotificationFuncStored
class | OutstandingCounter
class | OutstandingText
struct | TimingInfo

Public Types

typedef void(* OutputNotificationFuncType )(unsigned long dwOutputType, const char *outputLine, void *userParam)

Public Member Functions

Logger ()
~Logger ()
bool | init ()
void | done ()
void | update ()
void | noticeLog (const char *notice="",...)
void | vnoticeLog (const char *notice, va_list args)
void | warningLog (const char *warning="",...)
void | vwarningLog (const char *warning, va_list args)
void | errorLog (const char *error="",...)
void | verrorLog (const char *error, va_list args)
void | debugLog (const char *debugText="",...)
void | vdebugLog (const char *debugText, va_list args)
void | debugFileLog (const char *debugText="",...)
void | vdebugFileLog (const char *debugText, va_list args)
void | debugFlush (const char *debugText="",...)
void | vdebugFlush (const char *debugText, va_list args)
unsigned long | getAllowedOutput ()
void | setAllowedOutput (unsigned long dwNewOutput)
unsigned long | getOutputDest ()
void | setOutputDest (unsigned long dwNewOutputDest)
void | startTiming (std::string sectionName)
void | stopTiming (std::string sectionName, DWORD dwOutputType=LOGGER_OUTPUTTYPE_DEBUG)
void | writeBMCounter (const char *pName, float fValue)
osg::Timer_t | tick ()
bool | registerOutputNotification (OutputNotificationFuncType aFunc, void *userParam)
bool | unregisterOutputNotification (OutputNotificationFuncType aFunc)

Protected Member Functions

void | addOutstandingText (unsigned long dwOutputType, const char *buffer)
void | processOutstandingTexts ()
void | writeBMCounterLowLevel (unsigned int time, const char *pName, float fValue)
void | processOutstandingCounters ()
void | processTextMain (unsigned long dwOutputType, const char *buffer)
bool | openBenchmarkFile ()
void | textLog (unsigned long dwOutputType, const char *text="",...)
void | vtextLog (unsigned long dwOutputType, const char *text, va_list args)

Protected Attributes

std::ofstream | log_file
osg::Timer_t | starttime_stamp
DWORD | dwMainThreadId
MTLock generalLock
BenchmarkWriter bm
DynamicArray< OutstandingText > outstandingTexts
DynamicArray< OutstandingCounter > | outstandingCounters [2]
int | countersActiveIndex
MTLock countersActiveLock
std::map< std::string,
TimingInfo, std::less
< std::string > > 		sectionsTiming
DynamicArray
< OutputNotificationFuncStored > 		outFuncs
logger_streambuf * new_cout
logger_streambuf * new_cerr
std::streambuf * | old_cout_buf
std::streambuf * | old_cerr_buf
std::ostream * | old_cout
unsigned long | dwAllowedOutput
unsigned long | dwOutputDest
HANDLE | hOriginalStdHandle
WORD | wOriginalConsoleAttributes

Friends

class World

Member Typedef Documentation

typedef void(* vrecko::Logger::OutputNotificationFuncType)(unsigned long dwOutputType, const char *outputLine, void *userParam)

Constructor & Destructor Documentation

vrecko::Logger::Logger ( )
vrecko::Logger::~Logger ( )

Member Function Documentation

void vrecko::Logger::addOutstandingText | ( | unsigned long | dwOutputType,
 |  | const char * | buffer
 | ) |  |
protected
void vrecko::Logger::debugFileLog | ( | const char * | debugText = "",
 |  |  | ...
 | ) |  |
void vrecko::Logger::debugFlush | ( | const char * | debugText = "",
 |  |  | ...
 | ) |  |
void vrecko::Logger::debugLog | ( | const char * | debugText = "",
 |  |  | ...
 | ) |  |
void vrecko::Logger::done ( )
void vrecko::Logger::errorLog | ( | const char * | error = "",
 |  |  | ...
 | ) |  |
unsigned long vrecko::Logger::getAllowedOutput ( )
inline
unsigned long vrecko::Logger::getOutputDest ( )
inline
bool vrecko::Logger::init ( )
void vrecko::Logger::noticeLog | ( | const char * | notice = "",
 |  |  | ...
 | ) |  |
bool vrecko::Logger::openBenchmarkFile ( )
protected
void vrecko::Logger::processOutstandingCounters ( )
protected
void vrecko::Logger::processOutstandingTexts ( )
protected
void vrecko::Logger::processTextMain | ( | unsigned long | dwOutputType,
 |  | const char * | buffer
 | ) |  |
protected
bool vrecko::Logger::registerOutputNotification | ( | OutputNotificationFuncType | aFunc,
 |  | void * | userParam
 | ) |  |
void vrecko::Logger::setAllowedOutput ( unsigned long dwNewOutput )
inline
void vrecko::Logger::setOutputDest ( unsigned long dwNewOutputDest )
inline
void vrecko::Logger::startTiming ( std::string sectionName )
void vrecko::Logger::stopTiming | ( | std::string | sectionName,
 |  | DWORD | dwOutputType = LOGGER_OUTPUTTYPE_DEBUG
 | ) |  |
void vrecko::Logger::textLog | ( | unsigned long | dwOutputType,
 |  | const char * | text = "",
 |  |  | ...
 | ) |  |
protected
osg::Timer_t vrecko::Logger::tick ( )
inline
bool vrecko::Logger::unregisterOutputNotification ( OutputNotificationFuncType aFunc )
void vrecko::Logger::update ( void )
void vrecko::Logger::vdebugFileLog | ( | const char * | debugText,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::vdebugFlush | ( | const char * | debugText,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::vdebugLog | ( | const char * | debugText,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::verrorLog | ( | const char * | error,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::vnoticeLog | ( | const char * | notice,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::vtextLog | ( | unsigned long | dwOutputType,
 |  | const char * | text,
 |  | va_list | args
 | ) |  |
protected
void vrecko::Logger::vwarningLog | ( | const char * | warning,
 |  | va_list | args
 | ) |  |
void vrecko::Logger::warningLog | ( | const char * | warning = "",
 |  |  | ...
 | ) |  |
void vrecko::Logger::writeBMCounter | ( | const char * | pName,
 |  | float | fValue
 | ) |  |
void vrecko::Logger::writeBMCounterLowLevel | ( | unsigned int | time,
 |  | const char * | pName,
 |  | float | fValue
 | ) |  |
protected

Friends And Related Function Documentation

friend class World
friend

Member Data Documentation

BenchmarkWriter vrecko::Logger::bm
protected
int vrecko::Logger::countersActiveIndex
protected
MTLock vrecko::Logger::countersActiveLock
protected
unsigned long vrecko::Logger::dwAllowedOutput
protected
DWORD vrecko::Logger::dwMainThreadId
protected
unsigned long vrecko::Logger::dwOutputDest
protected
MTLock vrecko::Logger::generalLock
protected
HANDLE vrecko::Logger::hOriginalStdHandle
protected
std::ofstream vrecko::Logger::log_file
protected
logger_streambuf * vrecko::Logger::new_cerr
protected
logger_streambuf* vrecko::Logger::new_cout
protected
std::streambuf * vrecko::Logger::old_cerr_buf
protected
std::ostream* vrecko::Logger::old_cout
protected
std::streambuf* vrecko::Logger::old_cout_buf
protected
DynamicArray<OutputNotificationFuncStored> vrecko::Logger::outFuncs
protected
DynamicArray<OutstandingCounter> vrecko::Logger::outstandingCounters[2]
protected
DynamicArray<OutstandingText> vrecko::Logger::outstandingTexts
protected
std::map<std::string, TimingInfo, std::less<std::string> > vrecko::Logger::sectionsTiming
protected
osg::Timer_t vrecko::Logger::starttime_stamp
protected
WORD vrecko::Logger::wOriginalConsoleAttributes
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Logger.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Logger::OutputNotificationFuncStored Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutputNotificationFuncStored
Public Attributes | List of all members
vrecko::Logger::OutputNotificationFuncStored Struct Reference

#include <Logger.h>

Public Attributes

OutputNotificationFuncType outFunc
void * userParam

Member Data Documentation

OutputNotificationFuncType vrecko::Logger::OutputNotificationFuncStored::outFunc
void* vrecko::Logger::OutputNotificationFuncStored::userParam
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Logger::OutstandingCounter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutstandingCounter
Public Attributes | List of all members
vrecko::Logger::OutstandingCounter Class Reference

#include <Logger.h>

Public Attributes

unsigned int | time
std::string | strName
float | fValue

Member Data Documentation

float vrecko::Logger::OutstandingCounter::fValue
std::string vrecko::Logger::OutstandingCounter::strName
unsigned int vrecko::Logger::OutstandingCounter::time
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Logger::OutstandingText Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutstandingText
Public Attributes | List of all members
vrecko::Logger::OutstandingText Class Reference

#include <Logger.h>

Public Attributes

unsigned long | dwOutputType
std::string | str

Member Data Documentation

unsigned long vrecko::Logger::OutstandingText::dwOutputType
std::string vrecko::Logger::OutstandingText::str
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Logger::TimingInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • TimingInfo
Public Member Functions | Public Attributes | List of all members
vrecko::Logger::TimingInfo Struct Reference

#include <Logger.h>

Public Member Functions

TimingInfo ()

Public Attributes

osg::Timer_t | startTime
osg::Timer_t | totalTime
int | numRuns

Constructor & Destructor Documentation

vrecko::Logger::TimingInfo::TimingInfo ( )
inline

Member Data Documentation

int vrecko::Logger::TimingInfo::numRuns
osg::Timer_t vrecko::Logger::TimingInfo::startTime
osg::Timer_t vrecko::Logger::TimingInfo::totalTime
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::VreckoMessage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • VreckoMessage
Public Member Functions | List of all members
vrecko::VreckoMessage Class Reference

#include <Message.h>

Inheritance diagram for vrecko::VreckoMessage:
APEditorController::AbilityMapper::MessageMapping base::SystemInfo::MessageSIThreadCreated CarSim::MessageCarEdge CarSim::MessageCarEdgeData CarSim::MessageCarEnvirons CarSim::MessageCarSimParameters CarSim::MessageCarStatePtr CarSim::MessageEdgeOffset CarSim::MessageFirst3Juncs CarSim::MessageRoadAndDir CarSim::MessageStartStopDestination CarSim::MessageVectorUnsignedInt ode::DynamicScene::MessageODERequest PhysXPlugin::MessageNxActorWithName vrecko::ControllableAbility::MessageCAINFO vrecko::MessageCAButtonEvent vrecko::MessageSensorTransformation vrecko::MessageVoid

Public Member Functions

VreckoMessage ()
virtual | ~VreckoMessage ()
virtual const char * | getMessageId ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Constructor & Destructor Documentation

vrecko::VreckoMessage::VreckoMessage ( )
inline
virtual vrecko::VreckoMessage::~VreckoMessage ( )
inlinevirtual

Member Function Documentation

virtual const char* vrecko::VreckoMessage::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented in CarSim::MessageCarStatePtr, CarSim::MessageCarEnvirons, vrecko::ControllableAbility::MessageCAINFO, CarSim::MessageCarSimParameters, vrecko::MessageVoid, CarSim::MessageFirst3Juncs, CarSim::MessageStartStopDestination, CarSim::MessageVectorUnsignedInt, CarSim::MessageEdgeOffset, CarSim::MessageCarEdgeData, CarSim::MessageCarEdge, CarSim::MessageRoadAndDir, vrecko::MessageCAButtonEvent, ode::DynamicScene::MessageODERequest, APEditorController::AbilityMapper::MessageMapping, PhysXPlugin::MessageNxActorWithName, and base::SystemInfo::MessageSIThreadCreated.

virtual bool vrecko::VreckoMessage::isEqualTo ( VreckoMessage * otherMsg )
inlinevirtual

Is the contents of this message same as of the other one (of the same kind)?

Again, OVERRIDING IS REQUIRED for ACTIVATE_INPUT message sending, i.e. "if ability A output pin O outputs message with <em>content</em> M, then create a message M2 (might be different type), send it to ability A2 input pin I". If the respective message is only used simply for direct (much more common) message sending, you DO NOT NEED TO OVERRIDE this method.

Reimplemented in vrecko::MessageVoid.

virtual bool vrecko::VreckoMessage::setValueFromString ( const char * valueAsString )
inlinevirtual

Parses the given string to get the data for this message.

OVERRIDING IS REQUIRED for ACTIVATE_INPUT message sending, i.e. "if ability A output pin O outputs message with <em>content</em> M, then create a message M2 (might be different type), send it to ability A2 input pin I". If the respective message is only used simply for direct (much more common) message sending, you DO NOT NEED TO OVERRIDE this method.

Reimplemented in vrecko::MessageVoid, and base::SystemInfo::MessageSIThreadCreated.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Message.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MessageVoid Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageVoid
Public Member Functions | List of all members
vrecko::MessageVoid Class Reference

#include <Message.h>

Inheritance diagram for vrecko::MessageVoid:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
MessageVoid ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()

Constructor & Destructor Documentation

vrecko::MessageVoid::MessageVoid ( )
inline

Member Function Documentation

virtual const char* vrecko::MessageVoid::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

virtual bool vrecko::MessageVoid::isEqualTo ( VreckoMessage * otherMsg )
inlinevirtual

Is the contents of this message same as of the other one (of the same kind)?

Again, OVERRIDING IS REQUIRED for ACTIVATE_INPUT message sending, i.e. "if ability A output pin O outputs message with <em>content</em> M, then create a message M2 (might be different type), send it to ability A2 input pin I". If the respective message is only used simply for direct (much more common) message sending, you DO NOT NEED TO OVERRIDE this method.

Reimplemented from vrecko::VreckoMessage.

virtual bool vrecko::MessageVoid::setValueFromString ( const char * valueAsString )
inlinevirtual

Parses the given string to get the data for this message.

OVERRIDING IS REQUIRED for ACTIVATE_INPUT message sending, i.e. "if ability A output pin O outputs message with <em>content</em> M, then create a message M2 (might be different type), send it to ability A2 input pin I". If the respective message is only used simply for direct (much more common) message sending, you DO NOT NEED TO OVERRIDE this method.

Reimplemented from vrecko::VreckoMessage.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Message.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MessageSensorTransformation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageSensorTransformation
Public Member Functions | Public Attributes | List of all members
vrecko::MessageSensorTransformation Class Reference

#include <Message.h>

Inheritance diagram for vrecko::MessageSensorTransformation:
vrecko::VreckoMessage

Public Member Functions

MessageSensorTransformation ()
MessageSensorTransformation (int number, osg::Vec3 &position, osg::Quat &orientation)
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual const char * | getMessageId ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

int | _sensorNumber
osg::Vec3 | _sensorPosition
osg::Quat | _sensorOrientation

Constructor & Destructor Documentation

vrecko::MessageSensorTransformation::MessageSensorTransformation ( )
inline
vrecko::MessageSensorTransformation::MessageSensorTransformation | ( | int | number,
 |  | osg::Vec3 & | position,
 |  | osg::Quat & | orientation
 | ) |  |
inline

Member Data Documentation

int vrecko::MessageSensorTransformation::_sensorNumber
osg::Quat vrecko::MessageSensorTransformation::_sensorOrientation
osg::Vec3 vrecko::MessageSensorTransformation::_sensorPosition
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Message.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MTLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTLock
Public Member Functions | Protected Attributes | List of all members
vrecko::MTLock Class Reference

Base class for multi-thread access to a single variable. More...

#include <MTLock.h>

Public Member Functions

MTLock ()
~MTLock ()
bool | lock ()
void | unlock ()
HANDLE | getHandle () const

Protected Attributes

pthread_mutex_t * mutex

Detailed Description

Base class for multi-thread access to a single variable.

After locking, the given thread can be sure that no other thread can lock the same MTLock. After performing the exclusive operation (accessing the variable etc.), the thread which issued the lock must unlock it again.

Author
Vit Kovalcik
Date
2011

Constructor & Destructor Documentation

MTLOCK_IMP_EXP vrecko::MTLock::MTLock ( )
MTLOCK_IMP_EXP vrecko::MTLock::~MTLock ( )

Member Function Documentation

HANDLE vrecko::MTLock::getHandle ( ) const
inline

Really a lower- level method, you don't need it usually.

MTLOCK_IMP_EXP bool vrecko::MTLock::lock ( )
MTLOCK_IMP_EXP void vrecko::MTLock::unlock ( )

Member Data Documentation

pthread_mutex_t* vrecko::MTLock::mutex
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/MTLock.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MTAutoLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTAutoLock
Public Member Functions | Protected Attributes | List of all members
vrecko::MTAutoLock Class Reference

#include <MTLock.h>

Public Member Functions

MTAutoLock (MTLock *lockToLock)
~MTAutoLock ()

Protected Attributes

MTLock * theLock

Detailed Description

automatic locking and unlocking at the enter/exit of a scope (condition/function/method/class/...)

Constructor & Destructor Documentation

vrecko::MTAutoLock::MTAutoLock ( MTLock * lockToLock )
inline
vrecko::MTAutoLock::~MTAutoLock ( )
inline

Member Data Documentation

MTLock* vrecko::MTAutoLock::theLock
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MTReadWriteLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTReadWriteLock
Public Member Functions | Protected Attributes | List of all members
vrecko::MTReadWriteLock Class Reference

#include <MTLock.h>

Public Member Functions

MTReadWriteLock ()
~MTReadWriteLock ()
bool | lockRead (DWORD Timeout=INFINITE)
bool | lockWrite (DWORD Timeout=INFINITE)
void | unlockRead (DWORD Timeout=INFINITE)
void | unlockWrite (DWORD Timeout=INFINITE)

Protected Attributes

HANDLE | m_Access
int | m_Readers
HANDLE | m_WriterMutex
HANDLE | m_CanRead
HANDLE | m_CanWrite

Detailed Description

ReadWrite locks are from the following article by Ivan Krivyakov: http://www.codeguru.com/cpp/w-p/system/misc/article.php/c5679

MTReadWriteLock is a read/write mutex.

Any number of readers can acquire the mutex for read (LockRead()). Only single writer can acquire the mutex for write (LockWrite()). No other writers or readers can hold the mutex while writer uses it.

MTReadWriteLock does not prefer neither writers nor readers. I.e. if both writers and readers are waiting for the lock, any of them can grab the lock when it is released by previous owner.

MTReadWriteLock is recursive, but not upgradable. This means that

if you have a read lock, you can safely acquire another read lock. if you have a read lock, you CANNOT acquire a write lock (deadlock!).

if you have a write lock, you can safely acquire another write lock. if you have a write lock, you CANNOT acquire a read lock (deadlock!).

Constructor & Destructor Documentation

vrecko::MTReadWriteLock::MTReadWriteLock ( )
vrecko::MTReadWriteLock::~MTReadWriteLock ( )

Member Function Documentation

MTLOCK_IMP_EXP bool vrecko::MTReadWriteLock::lockRead ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP bool vrecko::MTReadWriteLock::lockWrite ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP void vrecko::MTReadWriteLock::unlockRead ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP void vrecko::MTReadWriteLock::unlockWrite ( DWORD Timeout = INFINITE )

Member Data Documentation

HANDLE vrecko::MTReadWriteLock::m_Access
protected
HANDLE vrecko::MTReadWriteLock::m_CanRead
protected
HANDLE vrecko::MTReadWriteLock::m_CanWrite
protected
int vrecko::MTReadWriteLock::m_Readers
protected
HANDLE vrecko::MTReadWriteLock::m_WriterMutex
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/MTLock.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MTReadWriteLockEx Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTReadWriteLockEx
Classes | Public Member Functions | List of all members
vrecko::MTReadWriteLockEx Class Reference

#include <MTLock.h>

Public Member Functions

MTReadWriteLockEx ()
~MTReadWriteLockEx ()
bool | lockRead (DWORD Timeout=INFINITE)
bool | lockWrite (DWORD Timeout=INFINITE)
void | unlockRead (DWORD Timeout=INFINITE)
void | unlockWrite (DWORD Timeout=INFINITE)

Detailed Description

MTReadWriteLockEx is more sofisticated read/write mutex. It is recursive and upgradable.

That is, a thread can acquire and release read and write locks in arbitrary order The only rule is that every successfully acquired lock must be eventually released

E.g. LockRead(), LockWrite(), UnlockRead(), UnlockWrite() is allowed sequence.

MTReadWriteLockEx prefers writers over readers. E.g., when a writer is waiting for the lock, no new readers can acquire the lock. Existing readers may continue to use the lock. This policy prevents so-called "writer starvation" when writers never get access to the lock because of too much readers.

Constructor & Destructor Documentation

vrecko::MTReadWriteLockEx::MTReadWriteLockEx ( )
vrecko::MTReadWriteLockEx::~MTReadWriteLockEx ( )

Member Function Documentation

MTLOCK_IMP_EXP bool vrecko::MTReadWriteLockEx::lockRead ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP bool vrecko::MTReadWriteLockEx::lockWrite ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP void vrecko::MTReadWriteLockEx::unlockRead ( DWORD Timeout = INFINITE )
MTLOCK_IMP_EXP void vrecko::MTReadWriteLockEx::unlockWrite ( DWORD Timeout = INFINITE )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/MTLock.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MTTwoPrioLimitedLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTTwoPrioLimitedLock
Public Member Functions | Protected Attributes | List of all members
vrecko::MTTwoPrioLimitedLock Class Reference

#include <MTLock.h>

Public Member Functions

MTTwoPrioLimitedLock ()
~MTTwoPrioLimitedLock ()
bool | lockHigh ()
void | unlockHigh ()
bool | lockLow ()
void | unlockLow ()

Protected Attributes

HANDLE | m_AllowLowPrio
HANDLE | m_Access
HANDLE | m_WritersMutex

Constructor & Destructor Documentation

MTLOCK_IMP_EXP vrecko::MTTwoPrioLimitedLock::MTTwoPrioLimitedLock ( )
MTLOCK_IMP_EXP vrecko::MTTwoPrioLimitedLock::~MTTwoPrioLimitedLock ( )

Member Function Documentation

MTLOCK_IMP_EXP bool vrecko::MTTwoPrioLimitedLock::lockHigh ( )
MTLOCK_IMP_EXP bool vrecko::MTTwoPrioLimitedLock::lockLow ( )
MTLOCK_IMP_EXP void vrecko::MTTwoPrioLimitedLock::unlockHigh ( )
MTLOCK_IMP_EXP void vrecko::MTTwoPrioLimitedLock::unlockLow ( )

Member Data Documentation

HANDLE vrecko::MTTwoPrioLimitedLock::m_Access
protected
HANDLE vrecko::MTTwoPrioLimitedLock::m_AllowLowPrio
protected
HANDLE vrecko::MTTwoPrioLimitedLock::m_WritersMutex
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/MTLock.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::OctTree Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OctTree
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::OctTree Class Reference

#include <OctTree.h>

Inheritance diagram for vrecko::OctTree:
vrecko::BaseClass

Classes

struct OctTreeNode

Public Member Functions

OctTree ()
OctTree (double _new_cell_size, double _new_space_size)
~OctTree ()
void | addObject (EnvironmentObject *_object)
void | removeObject (EnvironmentObject *_object)
EnvironmentObject ** | getObjectNeighbourhood (EnvironmentObject *_object, int &_object_count)
void | objectChanged (EnvironmentObject *_object)
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

OctTreeNode * | addToNode (int _node_id, OctTreeNode *_parent, EnvironmentObject *_object)
OctTreeNode * | addToCell (int _node_id, OctTreeNode *_parent, EnvironmentObject *_object)
void | delFromNode (OctTreeNode *_node, EnvironmentObject *_object)
void | delFromCell (OctTreeNode *_node, EnvironmentObject *_object)
bool | isObjectInNode (OctTreeNode *_node, EnvironmentObject *_object)
bool | isObjectInCell (OctTreeNode *_node, EnvironmentObject *_object)
OctTreeNode * | findObject (EnvironmentObject *_object)
OctTreeNode * | findObjectInNode (int _node_id, OctTreeNode *_node, EnvironmentObject *_object)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

double | cell_size
double | space_size
OctTreeNode * root_node
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

OctTree::OctTree ( )
OctTree::OctTree | ( | double | _new_cell_size,
 |  | double | _new_space_size
 | ) |  |
OctTree::~OctTree ( )

Member Function Documentation

void OctTree::addObject ( EnvironmentObject * _object )
OctTree::OctTreeNode * OctTree::addToCell | ( | int | _node_id,
 |  | OctTreeNode * | _parent,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
OctTree::OctTreeNode * OctTree::addToNode | ( | int | _node_id,
 |  | OctTreeNode * | _parent,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
void OctTree::delFromCell | ( | OctTreeNode * | _node,
 |  | EnvironmentObject * | _object
 | ) |  |
protected

(V.K.) I've never used this, but the method seems to be buggy - it always deletes THE LAST object, not the given one.

(V.K.) I've never used this, but the method seems to be buggy - it always deletes THE LAST object, not the given one.

void OctTree::delFromNode | ( | OctTreeNode * | _node,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
OctTree::OctTreeNode * OctTree::findObject ( EnvironmentObject * _object )
protected
OctTree::OctTreeNode * OctTree::findObjectInNode | ( | int | _node_id,
 |  | OctTreeNode * | _node,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
EnvironmentObject ** OctTree::getObjectNeighbourhood | ( | EnvironmentObject * | _object,
 |  | int & | _object_count
 | ) |  |
bool OctTree::isObjectInCell | ( | OctTreeNode * | _node,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
bool OctTree::isObjectInNode | ( | OctTreeNode * | _node,
 |  | EnvironmentObject * | _object
 | ) |  |
protected
void OctTree::objectChanged ( EnvironmentObject * _object )
void OctTree::removeObject ( EnvironmentObject * _object )

Member Data Documentation

double vrecko::OctTree::cell_size
protected
OctTreeNode* vrecko::OctTree::root_node
protected
double vrecko::OctTree::space_size
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/OctTree.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/OctTree.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::OctTree::OctTreeNode Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OctTree
  • OctTreeNode
Public Attributes | List of all members
vrecko::OctTree::OctTreeNode Struct Reference

#include <OctTree.h>

Public Attributes

OctTreeNode * parent_node
OctTreeNode * | child_nodes [8]
double | subspace_size
osg::Vec3 | position
long int | object_count
EnvironmentObject ** objects_in_cell
bool | isCell

Member Data Documentation

OctTreeNode* vrecko::OctTree::OctTreeNode::child_nodes[8]
bool vrecko::OctTree::OctTreeNode::isCell
long int vrecko::OctTree::OctTreeNode::object_count
EnvironmentObject** vrecko::OctTree::OctTreeNode::objects_in_cell
OctTreeNode* vrecko::OctTree::OctTreeNode::parent_node
osg::Vec3 vrecko::OctTree::OctTreeNode::position
double vrecko::OctTree::OctTreeNode::subspace_size
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/OctTree.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::PersistentCache Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PersistentCache
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::PersistentCache Class Reference

Caching that persists multiple application sessions. More...

#include <PersistentCache.h>

Classes

class OpenedCacheFile

Public Member Functions

PersistentCache ()
~PersistentCache ()
void | setEnable (bool bNewEnableCache)
bool | getEnable ()
const char * | getCacheDir ()
osg::Node * | loadModel (const char *relatedFileName, vrecko::EnvironmentObject *obj)
bool | saveModel (const char *relatedFileName, osg::Node *node, vrecko::EnvironmentObject *obj)
bool | openCacheFileForReading (const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFile **bfile, unsigned long ulWaitTimeout=0)
void | closeCacheFile (OpenedCacheFile *cacheData, vrecko::BufferedFile *bfile)
bool | openCacheFileForWriting (const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFileWrite **bfile, unsigned long ulWaitTimeout=0)
void | closeCacheFile (OpenedCacheFile *cacheData, vrecko::BufferedFileWrite *bfile)

Protected Member Functions

void | translateName (char *outTranslatedName, const char *inDataName, const char *inRelatedFileName)
int | internalFindAndLock (const char *originalFileName, const char *translatedFileName, unsigned long version, const char *desiredExtension, bool bReading, unsigned long ulWaitTimeout)
bool | internalOpenReadWrite (const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFile **bfile, vrecko::BufferedFileWrite **bfileWrite, unsigned long ulWaitTimeout)
void | internalDecrementReaderWriter (OpenedCacheFile *cacheData, bool bReading)
bool | testVersionIsAtLeast (const char *fileName, int minVersion)
void | constructModelDataName (char *outDataName, vrecko::EnvironmentObject *obj)

Protected Attributes

bool | bEnableCache
DynamicArray< OpenedCacheFile * > openedFiles
MTLock filesLock
CHAR | baseDir [1000]
CHAR | cacheDir [1000]

Detailed Description

Caching that persists multiple application sessions.

Persistent cache with data saving into files (into the "cache" directory). The class is multithread safe, multiple threads can read from the same file. Only one writer can write into a file - readers will be blocked and everything should be correctly managed automatically, i.e. from the time the writer requests writing, the next requesting readers will be blocked and remaining readers will finish their reading. Then the writer will be allowed to write (all this happen if the [Timeout] is sufficient).

IDEAS: 0. Most of the data are related to files - i.e. we will check whether the specific file hasn't changed.

  1. Two different names for data (data taken from a file):
  • the first is the ORIGINAL file name or data name (might be for example "..\data\model.obj")
  • the second is the name of cached object, with some characters translated into safer ones and with the added timestamp (i.e. "~~$data$model~obj$2009.12.20.19.44.20.dat")

This second name is composed of [the translated original file name] + [data name] + [timestamp] + [extension]

Author
Vit Kovalcik
Date
2011

Constructor & Destructor Documentation

vrecko::PersistentCache::PersistentCache ( )
vrecko::PersistentCache::~PersistentCache ( )

Member Function Documentation

void vrecko::PersistentCache::closeCacheFile | ( | OpenedCacheFile * | cacheData,
 |  | vrecko::BufferedFile * | bfile
 | ) |  |

The [cacheData] + [bfile] structures will be NO LONGER VALID after calling this method.

void vrecko::PersistentCache::closeCacheFile | ( | OpenedCacheFile * | cacheData,
 |  | vrecko::BufferedFileWrite * | bfile
 | ) |  |

The [cacheData] + [bfile] structures will be NO LONGER VALID after calling this method.

void vrecko::PersistentCache::constructModelDataName | ( | char * | outDataName,
 |  | vrecko::EnvironmentObject * | obj
 | ) |  |
protected

Used mainly in the loadModel() and saveModel() methods. The [obj] is necessary for getting attributes related to the model, i.e. Is it optimized? Is it smoothed? etc. - all produces different cache file The [obj] might be NULL in which case the default parameters are used.

const char* vrecko::PersistentCache::getCacheDir ( )
inline
bool vrecko::PersistentCache::getEnable ( )
inline

Is caching enabled?

void vrecko::PersistentCache::internalDecrementReaderWriter | ( | OpenedCacheFile * | cacheData,
 |  | bool | bReading
 | ) |  |
protected

Effectively UNLOCK a FILE for reading/writing. The [cacheData] MIGHT BE INVALID after calling this method. It might get deleted if noone else uses that file. The real file should be close BEFORE calling this method.

int vrecko::PersistentCache::internalFindAndLock | ( | const char * | originalFileName,
 |  | const char * | translatedFileName,
 |  | unsigned long | version,
 |  | const char * | desiredExtension,
 |  | bool | bReading,
 |  | unsigned long | ulWaitTimeout
 | ) |  |
protected

Note: The function will acquire the [filesLock] itself. This function will find correct entry in [openedFiles] OR will create a new one if it doesn't exist. If the entry exist, the function will check if the file itself is readable/writable and in case it is not it will wait for [ulWaitTimeout] ms (may be also 0 or INFINITE). Result is a 0 or positive number (if the entry was found/created) and the file can be processed, or -1 in case of blockage. If the result is 0 or positive number, the [filesLock] will REMAIN LOCKED AT THE END OF THIS FUNCTION. The function employs a busy-waiting (with 1 milisecond Sleep() ). The [ulWaitTimeout] is probably only approximate and not a precise number. The [desiredExtension] is used only if writing.

bool vrecko::PersistentCache::internalOpenReadWrite | ( | const char * | dataName,
 |  | const char * | relatedFileName,
 |  | unsigned long | version,
 |  | OpenedCacheFile ** | cacheData,
 |  | vrecko::BufferedFile ** | bfile,
 |  | vrecko::BufferedFileWrite ** | bfileWrite,
 |  | unsigned long | ulWaitTimeout
 | ) |  |
protected
osg::Node * vrecko::PersistentCache::loadModel | ( | const char * | relatedFileName,
 |  | vrecko::EnvironmentObject * | obj
 | ) |  |

The [obj] is necessary for getting attributes related to the model, i.e. Is it optimized? Is it smoothed? etc. - all produces different cache file The [obj] might be NULL in which case the default parameters are used.

bool vrecko::PersistentCache::openCacheFileForReading | ( | const char * | dataName,
 |  | const char * | relatedFileName,
 |  | unsigned long | version,
 |  | OpenedCacheFile ** | cacheData,
 |  | vrecko::BufferedFile ** | bfile,
 |  | unsigned long | ulWaitTimeout = 0
 | ) |  |
inline

NOTE: [version] = 0 is NOT RECOMMENDED In case of success the [bfile] will hold a pointer to the existing file opened for reading and [cacheData] will hold proper structure which acts as a handle. Note: [ulWaitTimeout] can be INFINITE (= Windows' numeric constant). The [cacheData] may be NULL.

bool vrecko::PersistentCache::openCacheFileForWriting | ( | const char * | dataName,
 |  | const char * | relatedFileName,
 |  | unsigned long | version,
 |  | OpenedCacheFile ** | cacheData,
 |  | vrecko::BufferedFileWrite ** | bfile,
 |  | unsigned long | ulWaitTimeout = 0
 | ) |  |
inline

NOTE: [version] = 0 is NOT RECOMMENDED In case of success the [bfile] will hold a pointer to the new empty file opened for writing and [cacheData] will hold proper structure which acts as a handle. Note: [ulWaitTimeout] can be INFINITE (= Windows' numeric constant).

bool vrecko::PersistentCache::saveModel | ( | const char * | relatedFileName,
 |  | osg::Node * | node,
 |  | vrecko::EnvironmentObject * | obj
 | ) |  |

The [obj] is necessary for getting attributes related to the model, i.e. Is it optimized? Is it smoothed? etc. - all produces different cache file The [obj] might be NULL in which case the default parameters are used.

void vrecko::PersistentCache::setEnable ( bool bNewEnableCache )

Can be used to disable and enable the whole caching system.

bool vrecko::PersistentCache::testVersionIsAtLeast | ( | const char * | fileName,
 |  | int | minVersion
 | ) |  |
protected

Test whether the file name contains version at the end (returning "false" if not) and the version is at least [minVersion].

void vrecko::PersistentCache::translateName | ( | char * | outTranslatedName,
 |  | const char * | inDataName,
 |  | const char * | inRelatedFileName
 | ) |  |
protected

Translates original file name into the safe name ending with '$', the date part and the final extension of the resulting file will be missing. The file path will be translated into a path relative to the main vrecko directory.

Member Data Documentation

CHAR vrecko::PersistentCache::baseDir[1000]
protected

Main program directory. Ending with backslash.

bool vrecko::PersistentCache::bEnableCache
protected
CHAR vrecko::PersistentCache::cacheDir[1000]
protected

Cache directory. Ending with backslash.

MTLock vrecko::PersistentCache::filesLock
protected

Lock for access to the [openedFiles] structure. ( It doesn't block (accesses to multiple files at once) or (multiple read accesses to a single file)

DynamicArray<OpenedCacheFile*> vrecko::PersistentCache::openedFiles
protected

MUST be array of pointers and NOT array of structures -> we will send these pointers as parameters and this would be screwed if the array was reallocated.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/PersistentCache.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/PersistentCache.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::PersistentCache::OpenedCacheFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PersistentCache
  • OpenedCacheFile
Public Member Functions | Protected Attributes | List of all members
vrecko::PersistentCache::OpenedCacheFile Class Reference

#include <PersistentCache.h>

Public Member Functions

OpenedCacheFile ()
~OpenedCacheFile ()
const std::string & | getTranslatedFileName ()
const std::string & | getCachedFileName ()

Protected Attributes

std::string | translatedFileName
std::string | cachedFileName
int | iReaders
int | iWaitingWriters
int | iWriters

Constructor & Destructor Documentation

vrecko::PersistentCache::OpenedCacheFile::OpenedCacheFile ( )
vrecko::PersistentCache::OpenedCacheFile::~OpenedCacheFile ( )

Member Function Documentation

const std::string& vrecko::PersistentCache::OpenedCacheFile::getCachedFileName ( )
inline
const std::string& vrecko::PersistentCache::OpenedCacheFile::getTranslatedFileName ( )
inline

Member Data Documentation

std::string vrecko::PersistentCache::OpenedCacheFile::cachedFileName
protected

full name of the cached file as found on the disk (without path, used for accessing the actual cached file).

int vrecko::PersistentCache::OpenedCacheFile::iReaders
protected

There can be only one [iWriters]. If there are any [iWaitingWriters] OR [iWriters], no [iReaders] can read the file.

int vrecko::PersistentCache::OpenedCacheFile::iWaitingWriters
protected
int vrecko::PersistentCache::OpenedCacheFile::iWriters
protected
std::string vrecko::PersistentCache::OpenedCacheFile::translatedFileName
protected

translated data/filename name (used for checks).

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/PersistentCache.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/PersistentCache.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::PluginManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PluginManager
Public Member Functions | Static Public Member Functions | Static Protected Attributes | List of all members
vrecko::PluginManager Class Reference

Simple class to load and manage the plugins. More...

#include <PluginManager.h>

Public Member Functions

PluginManager ()
~PluginManager ()

Static Public Member Functions

static vrecko::Ability * | getAbilityInstance (const std::string &plugin_name, const std::string &ability_name)
static void * | getFuncPtr (std::string dl_name, std::string func_name)

Static Protected Attributes

static std::map< std::string,
osgDB::DynamicLibrary * > 		_dl_map

Detailed Description

Simple class to load and manage the plugins.

Author
[your name]
Date
2011

Constructor & Destructor Documentation

vrecko::PluginManager::PluginManager ( )
inline
vrecko::PluginManager::~PluginManager ( )
inline

Member Function Documentation

Ability * PluginManager::getAbilityInstance | ( | const std::string & | plugin_name,
 |  | const std::string & | ability_name
 | ) |  |
static
void * PluginManager::getFuncPtr | ( | std::string | dl_name,
 |  | std::string | func_name
 | ) |  |
static

Member Data Documentation

std::map< std::string, osgDB::DynamicLibrary * > PluginManager::_dl_map
staticprotected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/PluginManager.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/PluginManager.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::PyAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PyAbility
Public Member Functions | Protected Attributes | Static Protected Attributes | List of all members
vrecko::PyAbility Class Reference

Python ability. More...

#include <PyAbility.h>

Inheritance diagram for vrecko::PyAbility:
vrecko::Ability vrecko::BaseClass

Public Member Functions

PyAbility ()
~PyAbility ()
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | processEvent (const std::string &, void *)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | setCallBacks (PyObject *update, PyObject *processEvent, PyObject *post)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

std::string | id_string
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Static Protected Attributes

static PyObject * | mUpdate = NULL
static PyObject * | mProcessEvent = NULL
static PyObject * | mPost = NULL
static unsigned long int | counter = 0

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Detailed Description

Python ability.

V.K.: Not sure how or even if it works.

Author
[your name]
Date
2011

Constructor & Destructor Documentation

vrecko::PyAbility::PyAbility ( )
vrecko::PyAbility::~PyAbility ( )

Member Function Documentation

void vrecko::PyAbility::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void vrecko::PyAbility::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void vrecko::PyAbility::processEvent | ( | const std::string & | ,
 |  | void * |
 | ) |  |
inline
void vrecko::PyAbility::setCallBacks | ( | PyObject * | update,
 |  | PyObject * | processEvent,
 |  | PyObject * | post
 | ) |  |
void vrecko::PyAbility::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

unsigned long int vrecko::PyAbility::counter = 0
staticprotected
std::string vrecko::PyAbility::id_string
protected
PyObject * vrecko::PyAbility::mPost = NULL
staticprotected
PyObject * vrecko::PyAbility::mProcessEvent = NULL
staticprotected
PyObject * vrecko::PyAbility::mUpdate = NULL
staticprotected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/PyAbility.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/PyAbility.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Range Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Range
Public Types | Public Member Functions | Protected Member Functions | List of all members
vrecko::Range Class Reference

#include <Range.h>

Inheritance diagram for vrecko::Range:
vrecko::Enumeration< tval, tref > vrecko::Interval< tval, tref >

Public Types

enum RangeType { RANGE_INTERVAL, RANGE_ENUMERATION }

Public Member Functions

bool | isInterval () const
bool | isEnumeration () const

Protected Member Functions

Range (RangeType rangeType)
Range (const Range &range)

Detailed Description

Represents a general range class.

You cannot create any instances of this class, use subclasses. This class is meant solely as an abstract parent class for classes Interval and Enumeration.

See Also
Interval
Enumeration

Member Enumeration Documentation

enum vrecko::Range::RangeType

Range types enumeration.

Enumerator
RANGE_INTERVAL | interval
RANGE_ENUMERATION | enumeration

Constructor & Destructor Documentation

vrecko::Range::Range ( RangeType rangeType )
inlineprotected

Constructs a Range object of the range type specified.

Parameters
rangeType type of range
vrecko::Range::Range ( const Range & range )
inlineprotected

Constructs a Range object by copying an existing one.

Parameters
range a reference to a constant Range instance

Member Function Documentation

bool vrecko::Range::isEnumeration ( ) const
inline

"Is enumeration" predicate.

Returns
true if the range is an enumeration, false otherwise
bool vrecko::Range::isInterval ( ) const
inline

"Is interval" predicate.

Returns
true if the range is an interval, false otherwise
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Range.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::RWErrorHandler Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RWErrorHandler
Public Member Functions | List of all members
vrecko::RWErrorHandler Class Reference

#include <ReaderWriter.h>

Inheritance diagram for vrecko::RWErrorHandler:

Public Member Functions

RWErrorHandler ()
~RWErrorHandler ()
bool | getSawErrors () const
bool | handleError (const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError)
void | resetErrors ()

Constructor & Destructor Documentation

vrecko::RWErrorHandler::RWErrorHandler ( )
vrecko::RWErrorHandler::~RWErrorHandler ( )

Member Function Documentation

bool vrecko::RWErrorHandler::getSawErrors ( ) const
inline
bool vrecko::RWErrorHandler::handleError ( const XERCES_CPP_NAMESPACE_QUALIFIER DOMError & domError )
void vrecko::RWErrorHandler::resetErrors ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/ReaderWriter.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ReaderWriter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ReaderWriter
Classes | Public Member Functions | Static Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
vrecko::ReaderWriter Class Reference

#include <ReaderWriter.h>

Classes

struct AbilityToInitialize

Public Member Functions

ReaderWriter ()
~ReaderWriter ()
bool | loadMultipleFiles (std::vector< std::string > &files, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex)
bool | loadOld (const char *configName, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex)
int | save (const char *configName, const char *originalSceneFile, float *savingPosition, std::string *savingCategory, VRECKOMutex save_Mutex)

Static Public Member Functions

static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		findNodeByName (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int level=1)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		findChildByName (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *xChChildNodeName, int level=1)
static void | getStringValue (std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const std::string &failReturn="", int level=1)
static const XMLCh * | getStringValueXCh (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, const XMLCh *childNodeName)
static bool | getBoolValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, bool failReturn=false, int level=1)
static int | getIntValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int failReturn=0, int level=1)
static long int | getLongIntValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, long int failReturn=0, int level=1)
static float | getFloatValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, float failReturn=0.0, int level=1)
static double | getDoubleValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, double failReturn=0.0, int level=1)
static void | getVec2Value (osg::Vec2 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec2 &failReturn=osg::Vec2(0.0, 0.0), int level=1)
static void | getVec3Value (osg::Vec3 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec3 &failReturn=osg::Vec3(0.0, 0.0, 0.0), int level=1)
static void | getVec4Value (osg::Vec4 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec4 &failReturn=osg::Vec4(0.0, 0.0, 0.0, 0.0), int level=1)
static void | getMatrixValue (osg::Matrix &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Matrix &failReturn=osg::Matrix::identity(), int level=1)
static void | getQuatValue (osg::Quat &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Quat &failReturn=osg::Quat(), int level=1)
static bool | getAttribStringValue (std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &attribName, const std::string &failReturn="")
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		createElement (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, const std::string &elementName)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		appendElementAndStringValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, const std::string &value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndBoolValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, bool value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndIntValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, int value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndLongIntValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, long int value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndFloatValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, float value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndDoubleValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, double value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndVec2Value (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec2 value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndVec3Value (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec3 value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndVec4Value (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec4 value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndMatrixValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Matrix value)
static
XERCES_CPP_NAMESPACE_QUALIFIER
DOMElement * 		appendElementAndQuatValue (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Quat value)

Protected Types

enum FDNNodeType {
FDNSimpleNode = 0, FDNFilter, FDNAbility, FDNDevice,
FDNEnvironmentObject, FDNAttribute, FDNUserData, FDNEvent,
FDNReceiver
}
typedef std::vector
< AbilityToInitialize > 		AbInitVector

Protected Member Functions

bool | loadVirtualEnvironment (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *veNode)
bool | loadScene (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *sceneNode, AbInitVector &abilitiesToInitialize)
bool | loadDevice (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode)
bool | loadAbilities (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, bool bLoadingWorldAbility, AbInitVector &abilitiesToInitialize)
vrecko::EnvironmentObject * | loadEnvironmentObject (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, osg::Group *parentSceneNode)
bool | loadEvent (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eventNode)
void | saveEnvironmentObject (const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, vrecko::EnvironmentObject *pEO)
void | saveChildren (const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, vrecko::EnvironmentObject *pEO)
void | analyzeXMLTree (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode)
unsigned int | getNodeCountByName (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode, const std::string &nodeName)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMBuilder * 		createParser ()
void | releaseParser (XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMDocument * 		loadXMLDocument (const char *configName, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser)
bool | findRealFile (char *outputFileWithPath, const char *inputFile, const char *currentDir, std::vector< std::string > *requiredBy=NULL, bool bOutputErrors=true)
void | removeUnnecessaryWhitespace (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode)
bool | saveXMLDocument (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDoc, const char *strPath)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		mergeFiles (std::vector< std::string > &files, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser)
bool | processNodeToMergeRecursive (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *secNode, const XMLCh *xChConfigFile)
bool | removeAttribRecursive (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *attribName)
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		findDuplicateNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainParentNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *origNode)
bool | getNodeIdentification (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, FDNNodeType nodeType, XMLCh *strId1, XMLCh *strId2)
bool | addCreatorInfoRecursive (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *xChConfigFile)
void | addSceneFileInfoIfPossible (vrecko::BaseClass *bc, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
bool | incrementActNode ()

Protected Attributes

std::string | _cfg_file
std::string | _cfg_path
The path includes the ending slash. More...
vrecko::DeviceManager * device_manager_local
vrecko::EventDispatcher * event_dispatcher_local
vrecko::EnvironmentObject * _eobject
unsigned int | nodes_count
unsigned int | act_node
pthread_mutex_t * | loadsave_Mutex
float * | loadsave_position
std::string * | loadsave_category

Detailed Description

Class to handle reading from (and in the future possibly writing to) XML configuration files.

Member Typedef Documentation

typedef std::vector<AbilityToInitialize> vrecko::ReaderWriter::AbInitVector
protected

At first all the abilities are created and after that all are initialized. This array holds the list of abilities to initialize.

Member Enumeration Documentation

enum vrecko::ReaderWriter::FDNNodeType
protected
Enumerator
FDNSimpleNode
FDNFilter
FDNAbility
FDNDevice
FDNEnvironmentObject
FDNAttribute
FDNUserData
FDNEvent
FDNReceiver

Constructor & Destructor Documentation

vrecko::ReaderWriter::ReaderWriter ( )
inline
vrecko::ReaderWriter::~ReaderWriter ( )
inline

Member Function Documentation

bool vrecko::ReaderWriter::addCreatorInfoRecursive | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const XMLCh * | xChConfigFile
 | ) |  |
protected

Adds the attribute containing the original file name to each node in the specified subtree.

void vrecko::ReaderWriter::addSceneFileInfoIfPossible | ( | vrecko::BaseClass * | bc,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node
 | ) |  |
protected

Sets the SceneFile of the given [bc] (BaseClass::setSceneFile()). This is set only if the given [node] has an attribute CREATOR_FILENAME_ID.

void vrecko::ReaderWriter::analyzeXMLTree ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pNode )
protected

Analyzes the XML tree in memory.

Calculates the number of nodes.

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndBoolValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | bool | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndDoubleValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | double | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndFloatValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | float | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndIntValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | int | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndLongIntValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | long int | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndMatrixValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | osg::Matrix | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndQuatValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | osg::Quat | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::appendElementAndStringValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | const std::string & | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndVec2Value | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | osg::Vec2 | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndVec3Value | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | osg::Vec3 | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMElement * vrecko::ReaderWriter::appendElementAndVec4Value | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pParentNode,
 |  | const std::string & | elementName,
 |  | osg::Vec4 | value
 | ) |  |
static

Creates a new XML element and fills out its value (usually your parameter name and parameter value).

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::createElement | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | const std::string & | elementName
 | ) |  |
static

Creates a new XML element (node) (usually "Parameters")

XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * vrecko::ReaderWriter::createParser ( )
protected

Creates a XML parser.

Note: Assumes the XML4C is already initialized. (done in vreckoApp/Main.cpp)

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::findChildByName | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const XMLCh * | xChChildNodeName,
 |  | int | level = 1
 | ) |  |
static
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::findDuplicateNode | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | mainParentNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | origNode
 | ) |  |
protected

Finds a duplicate of a given node if it exists.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::findNodeByName | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | int | level = 1
 | ) |  |
static

Finds a node with a specific name. Can return even the specified node. Level = 0 means the specified node only. Level = 1 means the node AND its direct children. etc.

bool vrecko::ReaderWriter::findRealFile | ( | char * | outputFileWithPath,
 |  | const char * | inputFile,
 |  | const char * | currentDir,
 |  | std::vector< std::string > * | requiredBy = NULL,
 |  | bool | bOutputErrors = true
 | ) |  |
protected

Checks if the file exists and if not tries the alternative paths.

Returns true if the file has been found somewhere and the real path + filename.

bool vrecko::ReaderWriter::getAttribStringValue | ( | std::string & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | attribName,
 |  | const std::string & | failReturn = ""
 | ) |  |
static

Searches ATTRIBUTES of a [node] for an attribute named [attribName] and returns its value. Returns [failReturn] in case of a problem.

* Example of attributes: <Node attribute1="value" attribute2="value">...</Node>
*
bool vrecko::ReaderWriter::getBoolValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | bool | failReturn = false,
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

double vrecko::ReaderWriter::getDoubleValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | double | failReturn = 0.0,
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

float vrecko::ReaderWriter::getFloatValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | float | failReturn = 0.0,
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

int vrecko::ReaderWriter::getIntValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | int | failReturn = 0,
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

long int vrecko::ReaderWriter::getLongIntValue | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | long int | failReturn = 0,
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

void vrecko::ReaderWriter::getMatrixValue | ( | osg::Matrix & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const osg::Matrix & | failReturn = osg::Matrix::identity(),
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

unsigned int vrecko::ReaderWriter::getNodeCountByName | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | pNode,
 |  | const std::string & | nodeName
 | ) |  |
protected

Returns the number of children nodes of a given name.

bool vrecko::ReaderWriter::getNodeIdentification | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | FDNNodeType | nodeType,
 |  | XMLCh * | strId1,
 |  | XMLCh * | strId2
 | ) |  |
protected

Assembles a node identificator, that can be used in a search for duplicates. Can return false in case the identification cannot be retrieved. This doesn't necessarily mean an error.

void vrecko::ReaderWriter::getQuatValue | ( | osg::Quat & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const osg::Quat & | failReturn = osg::Quat(),
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

void vrecko::ReaderWriter::getStringValue | ( | std::string & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const std::string & | failReturn = "",
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

const XMLCh * vrecko::ReaderWriter::getStringValueXCh | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parentNode,
 |  | const XMLCh * | childNodeName
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

void vrecko::ReaderWriter::getVec2Value | ( | osg::Vec2 & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const osg::Vec2 & | failReturn = osg::Vec2(0.0, 0.0),
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

void vrecko::ReaderWriter::getVec3Value | ( | osg::Vec3 & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const osg::Vec3 & | failReturn = osg::Vec3(0.0, 0.0, 0.0),
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

void vrecko::ReaderWriter::getVec4Value | ( | osg::Vec4 & | returnValue,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const std::string & | nodeName,
 |  | const osg::Vec4 & | failReturn = osg::Vec4(0.0, 0.0, 0.0, 0.0),
 |  | int | level = 1
 | ) |  |
static

Searches children of a [node] for a node with name [nodeName] and reads its value. Returns [failReturn] if the value cannot be read. Can go deeper than one level - specify the limit in [level] parameter.

bool vrecko::ReaderWriter::incrementActNode ( )
protected

Increment the number of processed nodes to keep track and draw the progress bar.

bool vrecko::ReaderWriter::loadAbilities | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | eoNode,
 |  | bool | bLoadingWorldAbility,
 |  | AbInitVector & | abilitiesToInitialize
 | ) |  |
protected

Reads the "Abilities" node.

bool vrecko::ReaderWriter::loadDevice ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * deviceNode )
protected

Reads a given "Device" node.

vrecko::EnvironmentObject * vrecko::ReaderWriter::loadEnvironmentObject | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | eoNode,
 |  | osg::Group * | parentSceneNode
 | ) |  |
protected

Reads the "EnvironmentObject" node.

bool vrecko::ReaderWriter::loadEvent ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * eventNode )
protected

Reads the "Event" node.

bool vrecko::ReaderWriter::loadMultipleFiles | ( | std::vector< std::string > & | files,
 |  | float * | loadingPosition,
 |  | std::string * | loadingCategory,
 |  | VRECKOMutex | load_Mutex
 | ) |  |

Loads a list of .xml files.

It performs a merge first, then attempts to load the resulting tree from memory.

bool vrecko::ReaderWriter::loadOld | ( | const char * | configName,
 |  | float * | loadingPosition,
 |  | std::string * | loadingCategory,
 |  | VRECKOMutex | load_Mutex
 | ) |  |

Old loading method to load the files one-by-one without merging. (OBSOLETE, probably can be deleted)

bool vrecko::ReaderWriter::loadScene | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | sceneNode,
 |  | AbInitVector & | abilitiesToInitialize
 | ) |  |
protected

Reads the "Scene" node and its subtree.

bool vrecko::ReaderWriter::loadVirtualEnvironment ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * veNode )
protected

Main loading function called to load a whole XML tree.

XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * vrecko::ReaderWriter::loadXMLDocument | ( | const char * | configName,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * | parser
 | ) |  |
protected

Loads a XML file and returns the tree in memory.

Needs an externally created parser.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * vrecko::ReaderWriter::mergeFiles | ( | std::vector< std::string > & | files,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * | parser
 | ) |  |
protected

Merges multiple files into one XML tree. Understands the vrecko XML syntax and makes proper changes to the XML trees.

bool vrecko::ReaderWriter::processNodeToMergeRecursive | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | mainNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | secNode,
 |  | const XMLCh * | xChConfigFile
 | ) |  |
protected

Merges children of the specified nodes.

void vrecko::ReaderWriter::releaseParser ( XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * parser )
protected

Releases a XML parser.

Note: Doesn't release the XML4C (done in vreckoApp/Main.cpp)

bool vrecko::ReaderWriter::removeAttribRecursive | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | node,
 |  | const XMLCh * | attribName
 | ) |  |
protected

Removes the specified attribute from the whole specified subtree.

void vrecko::ReaderWriter::removeUnnecessaryWhitespace ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pNode )
protected

Removes empty text nodes in the given node and its children.

int vrecko::ReaderWriter::save | ( | const char * | configName,
 |  | const char * | originalSceneFile,
 |  | float * | savingPosition,
 |  | std::string * | savingCategory,
 |  | VRECKOMutex | save_Mutex
 | ) |  |

(V.K. - summer 2011) I am not sure, how well method works. At least some of the data are NOT SAVED (some abilitity attributes etc.).

[originalSceneFile] represents the scene file that was used for loading (probably). This method will EITHER ONLY save those objects/abilities/connections that originated from this originalSceneFile OR will save EVERYTHING if [originalsceneFile] is "". TODO ?: Save the path to models relatively to the main .exe?

void vrecko::ReaderWriter::saveChildren | ( | const char * | originalSceneFile,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | eoNode,
 |  | vrecko::EnvironmentObject * | pEO
 | ) |  |
protected

Save children EO. This method will ONLY save objects with sceneFile == originalSceneFile.

void vrecko::ReaderWriter::saveEnvironmentObject | ( | const char * | originalSceneFile,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDocNode,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | parentNode,
 |  | vrecko::EnvironmentObject * | pEO
 | ) |  |
protected

Save an EO. This method will ONLY save objects with sceneFile == originalSceneFile.

bool vrecko::ReaderWriter::saveXMLDocument | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | pDoc,
 |  | const char * | strPath
 | ) |  |
protected

Saves a XML tree from memory into file.

Member Data Documentation

std::string vrecko::ReaderWriter::_cfg_file
protected
std::string vrecko::ReaderWriter::_cfg_path
protected

The path includes the ending slash.

vrecko::EnvironmentObject* vrecko::ReaderWriter::_eobject
protected
unsigned int vrecko::ReaderWriter::act_node
protected
vrecko::DeviceManager* vrecko::ReaderWriter::device_manager_local
protected
vrecko::EventDispatcher* vrecko::ReaderWriter::event_dispatcher_local
protected
std::string* vrecko::ReaderWriter::loadsave_category
protected
pthread_mutex_t* vrecko::ReaderWriter::loadsave_Mutex
protected
float* vrecko::ReaderWriter::loadsave_position
protected
unsigned int vrecko::ReaderWriter::nodes_count
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/ReaderWriter.cpp
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ReaderWriter::AbilityToInitialize Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ReaderWriter
  • AbilityToInitialize
Public Member Functions | Public Attributes | List of all members
vrecko::ReaderWriter::AbilityToInitialize Struct Reference

#include <ReaderWriter.h>

Public Member Functions

AbilityToInitialize (Ability *_ab, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *_params)

Public Attributes

Ability * ability
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		parameters

Constructor & Destructor Documentation

vrecko::ReaderWriter::AbilityToInitialize::AbilityToInitialize | ( | Ability * | _ab,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | _params
 | ) |  |
inline

Member Data Documentation

Ability* vrecko::ReaderWriter::AbilityToInitialize::ability
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* vrecko::ReaderWriter::AbilityToInitialize::parameters
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::XercesStr Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • XercesStr
Public Member Functions | List of all members
vrecko::XercesStr Class Reference

#include <ReaderWriter.h>

Public Member Functions

XercesStr (const char *const toTranscode)
~XercesStr ()
const XMLCh * unicodeForm () const

Constructor & Destructor Documentation

vrecko::XercesStr::XercesStr ( const char *const toTranscode )
inline
vrecko::XercesStr::~XercesStr ( )
inline

Member Function Documentation

const XMLCh* vrecko::XercesStr::unicodeForm ( ) const
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ScenePSThreadInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ScenePSThreadInfo
Public Attributes | List of all members
vrecko::ScenePSThreadInfo Struct Reference

#include <Scene.h>

Public Attributes

Scene * scene
HANDLE | hThreadHandle
bool | bTerminateThread
osg::Timer_t | lastRequest
CollisionParams params
unsigned long | limitToEO1
unsigned long | limitToEO2

Member Data Documentation

bool vrecko::ScenePSThreadInfo::bTerminateThread

Set this variable to "true" to terminate the thread as soon as possible.

HANDLE vrecko::ScenePSThreadInfo::hThreadHandle
osg::Timer_t vrecko::ScenePSThreadInfo::lastRequest

The time of the last request. If no request is issued for a certain amount of time, the thread is stopped.

unsigned long vrecko::ScenePSThreadInfo::limitToEO1
unsigned long vrecko::ScenePSThreadInfo::limitToEO2
CollisionParams vrecko::ScenePSThreadInfo::params
Scene* vrecko::ScenePSThreadInfo::scene
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scene Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
Classes | Public Types | Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
vrecko::Scene Class Reference

#include <Scene.h>

Inheritance diagram for vrecko::Scene:
vrecko::BaseClass

Classes

class | EOIteratorHelper
Class for iterating through all environment objects in non-main threads. More...
struct | OBJ_INT_PRIO
struct | SC_INT_PRIO

Public Types

typedef Sgi::hash_map
< unsigned long,
EnvironmentObject * > 		EOMap
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

Scene ()
~Scene ()
void | prepareForTermination ()
void | setDescription (const std::string &desc)
Set scene description. More...
const std::string & | getDescription (void)
Return scene description. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
osg::MatrixTransform * | getRoot ()
Return pointer to the root. More...
osg::MatrixTransform * | getEORoot ()
Return pointer to the node where the EOs are added. More...
unsigned long | getFreeID (unsigned long req_id)
Returns free ID for EnvironmentObject. More...
int | addEnvironmentObject (EnvironmentObject *environment_object, osg::Group *parentNode)
Add EnvironmentObject to the scene to the scene under the parent node. More...
int | addEnvironmentObject (EnvironmentObject *environment_object)
Add EnvironmentObject to the scene. More...
bool | removeEnvironmentObject (unsigned long id)
Remove EnvironmentObject from the scene (unregister id + remove object from ALL of its parents) More...
EnvironmentObject * | getEnvironmentObject (unsigned long id, bool bReportErrorIfNotFound=true)
Return pointer to the EnvironmentObject with given ID. More...
bool | registerEnvironmentObject (EnvironmentObject *environment_object)
bool | unregisterEnvironmentObject (EnvironmentObject *environment_object)
bool | unregisterEnvironmentObject (unsigned long id)
EOMap & | getEOMap (void)
Return reference to the map with EnvironmentObjects. More...
void | lockEOMapForRead (void)
Usage is not required in the main thread. More...
void | unlockEOMapForRead (void)
Usage is not required in the main thread. More...
void | lockEOMapForWrite (void)
Usage is not required in the main thread. More...
void | unlockEOMapForWrite (void)
Usage is not required in the main thread. More...
bool | isLoaded (void)
Has the Scene class finished loading its data from the XML files? More...
void | setIsLoaded (bool bNewValue)
EnvironmentObject * | getCollisionObject (EnvironmentObject *eobject)
EnvironmentObject ** | getCollisionObjects (EnvironmentObject *eobject, int &size)
EnvironmentObject ** | getCollisionObjects (esg::OSGAdapter *pOSGAdapter, const osg::Matrix &transf, int &size)
EnvironmentObject * | getRayIntersection (const osg::Vec3 &origin, const osg::Vec3 &dir)
EnvironmentObject * | getRayIntersection (const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point)
bool | getRayIntersection (EnvironmentObject *eobject, const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point)
void | getObjectExtent (EnvironmentObject *eobject, const osg::Vec3 &dir, float &min, float &max)
bool | separation (esg::Matrix4 *trMat1, std::vector< esg::OSGAdapter * > object1, esg::Matrix4 *trMat2, std::vector< esg::OSGAdapter * > object2, unsigned d1=UINT_MAX, unsigned d2=UINT_MAX)
bool | calcNodeBBox (osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed=NULL, unsigned long dwFlags=0, osg::Node *subTreeToIgnore=NULL)
bool | getCollisions (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1=0, unsigned long limitToEO2=0)
bool | addPartitioningSceneInterface (SP_SceneInterface *newInterface, int priority=0)
void | removePartitioningSceneInterface (SP_SceneInterface *anInterface)
SP_SceneInterface * | getPartitioningSceneInterface (int id=PARTITIONING_INTERFACE_DEFAULT)
bool | addPartitioningObjectInterface (SP_ObjectInterface *newInterface, int priority=0)
void | removePartitioningObjectInterface (SP_ObjectInterface *anInterface)
SP_ObjectInterface * | getPartitioningObjectInterface (int id=PARTITIONING_INTERFACE_DEFAULT)
void | logHierarchy (const osg::Node *topNode, const char *note=NULL)
Output the (sub-)scene the hierarchy into the logger. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | calcNodeBBoxHelper (osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed, unsigned long dwFlags, osg::Node *nodeToStopTraversalAt, osg::Node *subTreeToIgnore)
void | logHierarchyHelper (int level, const osg::Node *node)
void | logHierarchyDrawableHelper (int level, const osg::Drawable *dw)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

std::string | description
Scene description. More...
MTReadWriteLock eoMapLock
EOMap environment_objects_map
Map with EnvironmentObjects that have been added to the scene. More...
osg::MatrixTransform * | rootNode
Root of the scenegraph - ... More...
osg::MatrixTransform * | eoRootNode
Node where most EOs are added. More...
unsigned long | nextFreeID
bool | _bIsLoaded
Has the Scene class finished loading its data from the XML files? More...
DynamicArray< SC_INT_PRIO > partitioningSceneInterfaces
Partitioning interfaces for scene operations, sorted by priority. More...
DynamicArray< OBJ_INT_PRIO > partitioningObjectInterfaces
Partitioning interface for object operations, sorted by priority. More...
std::vector< ScenePSThreadInfo * > | partThreadsInfo
int | lastUpdatePartThrIndex
Which "partitioning" thread was last checked in the update. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Friends

DWORD WINAPI ScenePSThreadProc (ScenePSThreadInfo *lpParameter)

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Member Typedef Documentation

typedef Sgi::hash_map<unsigned long, EnvironmentObject *> vrecko::Scene::EOMap

Constructor & Destructor Documentation

vrecko::Scene::Scene ( )
vrecko::Scene::~Scene ( )

Member Function Documentation

int vrecko::Scene::addEnvironmentObject | ( | EnvironmentObject * | environment_object,
 |  | osg::Group * | parentNode
 | ) |  |

Add EnvironmentObject to the scene to the scene under the parent node.

int vrecko::Scene::addEnvironmentObject ( EnvironmentObject * environment_object )
inline

Add EnvironmentObject to the scene.

bool vrecko::Scene::addPartitioningObjectInterface | ( | SP_ObjectInterface * | newInterface,
 |  | int | priority = 0
 | ) |  |
bool vrecko::Scene::addPartitioningSceneInterface | ( | SP_SceneInterface * | newInterface,
 |  | int | priority = 0
 | ) |  |
bool vrecko::Scene::calcNodeBBox | ( | osg::Node * | node,
 |  | osg::BoundingBox * | outBox,
 |  | osg::Matrix * | outTransform,
 |  | bool * | bTransformUsed = NULL,
 |  | unsigned long | dwFlags = 0,
 |  | osg::Node * | subTreeToIgnore = NULL
 | ) |  |

Calculates the bounding box of the scene node. Has various working modes - see the dwFlags parameter.

[bTransformUsed] returns whether the resulting transformation is identity (hence the AABox was created) or the transformation is not identity (so the oriented box was created). [subTreeToIgnore] is a child node (not necessarily a direct child) which will be ignored in the bounding box calculations. [dwFlags] is a combination of CNBB_F_*

bool vrecko::Scene::calcNodeBBoxHelper | ( | osg::Node * | node,
 |  | osg::BoundingBox * | outBox,
 |  | osg::Matrix * | outTransform,
 |  | bool * | bTransformUsed,
 |  | unsigned long | dwFlags,
 |  | osg::Node * | nodeToStopTraversalAt,
 |  | osg::Node * | subTreeToIgnore
 | ) |  |
protected
EnvironmentObject * vrecko::Scene::getCollisionObject ( EnvironmentObject * eobject )

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return (the nearest - but not yet:( ) EnvironmentObject that collides with eobject

If any collision occurs (collision is detected) between an environment object and any env. object within the scene, it returns pointer to env. object which have collided with _eobject. Else it returns NULL. Collision detection is made using FDH14.

EnvironmentObject ** vrecko::Scene::getCollisionObjects | ( | EnvironmentObject * | eobject,
 |  | int & | size
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return all EnvironmentObjects that collide with eobject.

If the collision occurs (collision is detected) between an environment object and any env. object within the scene, it returns pointer to env. objects which have collided with _eobject. Else it returs NULL. Collision detection is made with FDH14.

EnvironmentObject ** vrecko::Scene::getCollisionObjects | ( | esg::OSGAdapter * | pOSGAdapter,
 |  | const osg::Matrix & | transf,
 |  | int & | size
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return all EnvironmentObjects that collide with given OSGAdapter.

bool vrecko::Scene::getCollisions | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | limitToEO1 = 0,
 |  | unsigned long | limitToEO2 = 0
 | ) |  |

Get collision between object using currently registered collision detection structures.

Beware that by default there are NO STRUCTURES, so you would have to set them up to get proper collision detection.

This method will work only if scene and object partitioning interfaces have been added into the scene and objects have assigned the proper data abilities. Currently (4/2011) only useful for PHANToM precise multicontact collision detection using SNCH or Pointshell/Voxelgrid collision algorithms. For common projects you won't be able to run it - if you think you need collision detection, ask core developers about the current possibilities.

const std::string& vrecko::Scene::getDescription ( void )
inline

Return scene description.

EnvironmentObject * vrecko::Scene::getEnvironmentObject | ( | unsigned long | id,
 |  | bool | bReportErrorIfNotFound = true
 | ) |  |

Return pointer to the EnvironmentObject with given ID.

EOMap& vrecko::Scene::getEOMap ( void )
inline

Return reference to the map with EnvironmentObjects.

osg::MatrixTransform* vrecko::Scene::getEORoot ( )
inline

Return pointer to the node where the EOs are added.

unsigned long vrecko::Scene::getFreeID ( unsigned long req_id )

Returns free ID for EnvironmentObject.

void vrecko::Scene::getObjectExtent | ( | EnvironmentObject * | eobject,
 |  | const osg::Vec3 & | dir,
 |  | float & | min,
 |  | float & | max
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return extent of the EnvironmentObject in given direction.

SP_ObjectInterface * vrecko::Scene::getPartitioningObjectInterface ( int id = PARTITIONING_INTERFACE_DEFAULT )
SP_SceneInterface * vrecko::Scene::getPartitioningSceneInterface ( int id = PARTITIONING_INTERFACE_DEFAULT )
EnvironmentObject * vrecko::Scene::getRayIntersection | ( | const osg::Vec3 & | origin,
 |  | const osg::Vec3 & | dir
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return first EnvironmentObject that collides with given ray.

Better to use osgUtil::LineSegmentIntersector, see example here: http://decibel.fi.muni.cz/wiki/index.php/VRECKO_TestPruseciku

EnvironmentObject * vrecko::Scene::getRayIntersection | ( | const osg::Vec3 & | origin,
 |  | const osg::Vec3 & | dir,
 |  | osg::Vec3 & | intersection_point
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) Return first EnvironmentObject that collides with given ray and intersection point.

Better to use osgUtil::LineSegmentIntersector, see example here: http://decibel.fi.muni.cz/wiki/index.php/VRECKO_TestPruseciku

bool vrecko::Scene::getRayIntersection | ( | EnvironmentObject * | eobject,
 |  | const osg::Vec3 & | origin,
 |  | const osg::Vec3 & | dir,
 |  | osg::Vec3 & | intersection_point
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) It tests if given EnvironmentObject is intersected by ray.

Better to use osgUtil::LineSegmentIntersector, see example here: http://decibel.fi.muni.cz/wiki/index.php/VRECKO_TestPruseciku

osg::MatrixTransform* vrecko::Scene::getRoot ( )
inline

Return pointer to the root.

bool vrecko::Scene::isLoaded ( void )
inline

Has the Scene class finished loading its data from the XML files?

void vrecko::Scene::lockEOMapForRead ( void )
inline

Usage is not required in the main thread.

void vrecko::Scene::lockEOMapForWrite ( void )
inline

Usage is not required in the main thread.

void vrecko::Scene::logHierarchy | ( | const osg::Node * | topNode,
 |  | const char * | note = NULL
 | ) |  |

Output the (sub-)scene the hierarchy into the logger.

void vrecko::Scene::logHierarchyDrawableHelper | ( | int | level,
 |  | const osg::Drawable * | dw
 | ) |  |
protected
void vrecko::Scene::logHierarchyHelper | ( | int | level,
 |  | const osg::Node * | node
 | ) |  |
protected
void vrecko::Scene::prepareForTermination ( )

Some preparation steps before the World is ending. This is called by the vreckoApp before the abilities are terminated.

bool vrecko::Scene::registerEnvironmentObject ( EnvironmentObject * environment_object )

This function only registers an object (anywhere in the scene) to the internal structures, so VRECKO knows about the object. You can insert it anywhere in the scene tree, even under a non-EO object.

bool vrecko::Scene::removeEnvironmentObject ( unsigned long id )

Remove EnvironmentObject from the scene (unregister id + remove object from ALL of its parents)

void vrecko::Scene::removePartitioningObjectInterface ( SP_ObjectInterface * anInterface )
void vrecko::Scene::removePartitioningSceneInterface ( SP_SceneInterface * anInterface )
bool vrecko::Scene::separation | ( | esg::Matrix4 * | trMat1,
 |  | std::vector< esg::OSGAdapter * > | object1,
 |  | esg::Matrix4 * | trMat2,
 |  | std::vector< esg::OSGAdapter * > | object2,
 |  | unsigned | d1 = UINT_MAX,
 |  | unsigned | d2 = UINT_MAX
 | ) |  |

(OBSOLETE? - Uses FDH structure, but its calculation is now turned off when loading EO) It detects if the separation exists between two given object.

void vrecko::Scene::setDescription ( const std::string & desc )
inline

Set scene description.

void vrecko::Scene::setIsLoaded ( bool bNewValue )
inline
void vrecko::Scene::unlockEOMapForRead ( void )
inline

Usage is not required in the main thread.

void vrecko::Scene::unlockEOMapForWrite ( void )
inline

Usage is not required in the main thread.

bool vrecko::Scene::unregisterEnvironmentObject ( EnvironmentObject * environment_object )

Unregisters an EnvObj from the internal structures. Doesn't remove the object from the scene tree.

bool vrecko::Scene::unregisterEnvironmentObject ( unsigned long id )

Unregisters an EnvObj from the internal structures. Doesn't remove the object from the scene tree.

void vrecko::Scene::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Friends And Related Function Documentation

DWORD WINAPI ScenePSThreadProc ( ScenePSThreadInfo * lpParameter )
friend

Member Data Documentation

bool vrecko::Scene::_bIsLoaded
protected

Has the Scene class finished loading its data from the XML files?

std::string vrecko::Scene::description
protected

Scene description.

EOMap vrecko::Scene::environment_objects_map
protected

Map with EnvironmentObjects that have been added to the scene.

MTReadWriteLock vrecko::Scene::eoMapLock
protected
osg::MatrixTransform* vrecko::Scene::eoRootNode
protected

Node where most EOs are added.

int vrecko::Scene::lastUpdatePartThrIndex
protected

Which "partitioning" thread was last checked in the update.

unsigned long vrecko::Scene::nextFreeID
protected
DynamicArray<OBJ_INT_PRIO> vrecko::Scene::partitioningObjectInterfaces
protected

Partitioning interface for object operations, sorted by priority.

DynamicArray<SC_INT_PRIO> vrecko::Scene::partitioningSceneInterfaces
protected

Partitioning interfaces for scene operations, sorted by priority.

std::vector<ScenePSThreadInfo*> vrecko::Scene::partThreadsInfo
protected

Threads for calculating the partitioning queries in background. The ScebePSThreadInfo structures are accessible also from the thread, but this vector itself is modified only in the main thread. So we don't need any locking mechanism.

osg::MatrixTransform* vrecko::Scene::rootNode
protected

Root of the scenegraph - ...

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Scene.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scene::EOIteratorHelper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • EOIteratorHelper
Public Member Functions | Protected Types | Protected Member Functions | Protected Attributes | List of all members
vrecko::Scene::EOIteratorHelper Class Reference

Class for iterating through all environment objects in non-main threads. More...

#include <Scene.h>

Inheritance diagram for vrecko::Scene::EOIteratorHelper:
vrecko::BaseClass

Public Member Functions

EOIteratorHelper ()
~EOIteratorHelper ()
bool | initIteration ()
bool | initIterationFrom (Scene::EOIteratorHelper *sourceHelper, unsigned long dwInitFlags=EOIH_IF_START_BEGINNING)
void | endIteration ()
bool | getAndLockNextObject (EnvironmentObject **outObject)
bool | releaseObject (void)
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Types

typedef DynamicArray
< EnvironmentObject * > 		EOVector
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Protected Member Functions

virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

bool | bInited
was the search initialized? More...
MTLock generalLock
EOVector objects
A list of all objects in the scene. More...
int | currentObjectIndex
bool | bObjectLocked
HANDLE | hCollisionEvent1
HANDLE | hCollisionEvent2
bool | bCollisionOccured_EventExpected
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Detailed Description

Class for iterating through all environment objects in non-main threads.

Iterating through objects in the main thread is simple, but other threads must watch for sudden objects deletion and additions. This helper class will take care of the problems. HOWEWER, IT IS NECCESSARY to use the helper methods to lock and to RELEASE currently processed object.

NOTE: This class in not fully multihread-protected. It expects that all of the itetration will happen in one thread. Also, it expects that the object unregistrations notifications will came from the main thread (which should happen if other other plug-ins are written correctly)

Author
Vit Kovalcik
Date
2010

Member Typedef Documentation

typedef DynamicArray<EnvironmentObject*> vrecko::Scene::EOIteratorHelper::EOVector
protected

Constructor & Destructor Documentation

vrecko::Scene::EOIteratorHelper::EOIteratorHelper ( )
vrecko::Scene::EOIteratorHelper::~EOIteratorHelper ( )

Member Function Documentation

void vrecko::Scene::EOIteratorHelper::endIteration ( )

Releases internal structures and deletes the notification interfaces from the scene. Automatically releases the locked object if necessary.

bool vrecko::Scene::EOIteratorHelper::getAndLockNextObject ( EnvironmentObject ** outObject )

Retrieves the object that is next in the iteration and LOCKS it (!!!). That said, other threads (including the main one) can still use the object, but any call to Scene::unregisterEnvironmentObject() will cause that thread to stop and wait until YOU call the EOIteratorHelper::ReleaseObject().

  • i.e. the object basically cannot be deleted from scene.

(Note: Multiple iterator helpers can lock the same object. That is not a problem.)

Returns "false" and resets the [*outObject] to NULL in case the helper reached the end of the list.

Automatically releases previously locked object if necessary.

bool vrecko::Scene::EOIteratorHelper::initIteration ( )

Initializes internal structures (retrieves list of all objects in the scene) and sets the scene to inform this helper about every object addition and deletion.

bool vrecko::Scene::EOIteratorHelper::initIterationFrom | ( | Scene::EOIteratorHelper * | sourceHelper,
 |  | unsigned long | dwInitFlags = EOIH_IF_START_BEGINNING
 | ) |  |

Similar to [initIteration], but the iteration doesn't need to start from the exact beginning, but can start from the object that the other interatorHelper is processing. This is defined through [dwInitFlags], which is a combination of EOIH_IF_* flags.

int vrecko::Scene::EOIteratorHelper::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Process an incoming notification.

Override this method to react to a registered notification (see addNotification() method).

Parameters
sender | (BaseClass *) The sender of the notification
notificationType | (unsigned long) Type of the notification, only ONE bit will be set
notificationData | (void *) Appropriate notification data, dependent on the notificationType.
Returns
(int) Should return 0, other values are reserved for future use.

Reimplemented from vrecko::BaseClass.

bool vrecko::Scene::EOIteratorHelper::releaseObject ( void )

Releases the object that was previously locked through this helper.

Member Data Documentation

bool vrecko::Scene::EOIteratorHelper::bCollisionOccured_EventExpected
protected
bool vrecko::Scene::EOIteratorHelper::bInited
protected

was the search initialized?

bool vrecko::Scene::EOIteratorHelper::bObjectLocked
protected

whether or not is the object with [currentObjectIndex] locked.

int vrecko::Scene::EOIteratorHelper::currentObjectIndex
protected

Current position of the iterator. The given object is "LOCKED" if the [bObjectLocked] is true i.e. the object cannot be unregistered from the scene (= deleted). At the beginning the currentObjectIndex is -1.

MTLock vrecko::Scene::EOIteratorHelper::generalLock
protected
HANDLE vrecko::Scene::EOIteratorHelper::hCollisionEvent1
protected
HANDLE vrecko::Scene::EOIteratorHelper::hCollisionEvent2
protected
EOVector vrecko::Scene::EOIteratorHelper::objects
protected

A list of all objects in the scene.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Scene.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scene::OBJ_INT_PRIO Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • OBJ_INT_PRIO
Public Attributes | List of all members
vrecko::Scene::OBJ_INT_PRIO Struct Reference

#include <Scene.h>

Public Attributes

SP_ObjectInterface * objInt
int priority

Member Data Documentation

SP_ObjectInterface* vrecko::Scene::OBJ_INT_PRIO::objInt
int vrecko::Scene::OBJ_INT_PRIO::priority
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scene::SC_INT_PRIO Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • SC_INT_PRIO
Public Attributes | List of all members
vrecko::Scene::SC_INT_PRIO Struct Reference

#include <Scene.h>

Public Attributes

SP_SceneInterface * scInt
int priority

Member Data Documentation

int vrecko::Scene::SC_INT_PRIO::priority
SP_SceneInterface* vrecko::Scene::SC_INT_PRIO::scInt
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scheduler Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
Classes | Public Member Functions | Protected Types | Protected Attributes | List of all members
vrecko::Scheduler Class Reference

#include <Scheduler.h>

Classes

struct | classcomp
struct | TimerStruct

Public Member Functions

Scheduler ()
~Scheduler ()
Scheduler (Scheduler &s)
void | update (void)
void | start (void)
void | stop (void)
void | addEntity (BaseClass *ent, float frequency=FRAME_FREQUENCY)
void | addEntity (BaseClass *ent, const std::string &private_timer_name, float frequency=FRAME_FREQUENCY)
void | removeEntity (BaseClass *ent)
bool | isEntityPresent (BaseClass *ent)
bool | getState ()
void | resetObjectUpdatesCounter ()
int | getObjectUpdatesCounter ()

Protected Types

typedef std::map< float,
TimerStruct > 		TimerMap
typedef std::map< std::string,
TimerStruct > 		PrivateTimerMap

Protected Attributes

TimerMap timer_map
PrivateTimerMap private_timer_map
bool | state
int | iObjectUpdatesCounter
std::multimap< long int,
BaseClass *, classcomp > 		updateMMap

Detailed Description

Class Scheduler serves for periodic updates of other entities.

Member Typedef Documentation

typedef std::map<std::string, TimerStruct > vrecko::Scheduler::PrivateTimerMap
protected
typedef std::map<float, TimerStruct > vrecko::Scheduler::TimerMap
protected

Constructor & Destructor Documentation

Scheduler::Scheduler ( )
Scheduler::~Scheduler ( )
Scheduler::Scheduler ( Scheduler & s )

Member Function Documentation

void Scheduler::addEntity | ( | BaseClass * | ent,
 |  | float | frequency = FRAME_FREQUENCY
 | ) |  |

This is the good version addEntity() method you would want to use when registering your class to be called periodically.

The system will attempt to call your object at specified intervals, however, it will do so ONLY ONCE PER FRAME in the main thread together with processing the graphics and other abilities.

This will mean, for example: If your frequency is 100 Hz and the main thread runs at 30 Hz, your ability will be called approximately three times IN A ROW, then other processing happens (rendering, other abilities), then your ability is called three times etc.

Because of this, it is usually good to use the FRAME_FREQUENCY constant, so your object is called exactly once per frame (you have to use the osg::Timer to get the delay between calls)

You can also use very low frequencies, such as 1/60, meaning once per minute.

void Scheduler::addEntity | ( | BaseClass * | ent,
 |  | const std::string & | private_timer_name,
 |  | float | frequency = FRAME_FREQUENCY
 | ) |  |

[SEE WARNINGS IN THE DESCRIPTION] This method creates a new thread and runs it on a different frequency to achieve really asynchronous run.

However:

1) (V.K. - summer 2011) I am not sure, it if runs properly now.

2) (V.K.) You have to take EXTREMELY GOOD CARE that you won't break anything on your thread, which is fairly difficult. For starters, you can't delete objects from the scene and when accessing the existing object, you should probably not modify them (but you can use MTMatrixTransform ability instead of using the getMatrix()/setMatrix() methods).

Sending events from any thread is ok (they will be automatically processed in the main thread at one time during the frame). Sending requests is not recommended - thay have to be processed immediately, i.e. the target ability has to know it can be called from a non-main thread.

int vrecko::Scheduler::getObjectUpdatesCounter ( )
inline

Debug method.

bool vrecko::Scheduler::getState ( )
inline

Is the Scheduler running?

bool Scheduler::isEntityPresent ( BaseClass * ent )

Is the entity currently periodically updated?

void Scheduler::removeEntity ( BaseClass * ent )

Remove entity from being periodically updated.

void vrecko::Scheduler::resetObjectUpdatesCounter ( )
inline

Debug method.

void Scheduler::start ( void )
void Scheduler::stop ( void )
void Scheduler::update ( void )

Member Data Documentation

int vrecko::Scheduler::iObjectUpdatesCounter
protected
PrivateTimerMap vrecko::Scheduler::private_timer_map
protected
bool vrecko::Scheduler::state
protected
TimerMap vrecko::Scheduler::timer_map
protected
std::multimap<long int, BaseClass*, classcomp> vrecko::Scheduler::updateMMap
protected

A multimap used for the update(). The reason for the declaration here is that it can be accessed also in the removeEntity() method. NOTE that unusual sorting is used (reversed).

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scheduler.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Scheduler.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scheduler::classcomp Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
  • classcomp
Public Member Functions | List of all members
vrecko::Scheduler::classcomp Struct Reference

#include <Scheduler.h>

Public Member Functions

bool operator() (const long int &lhs, const long int &rhs) const

Member Function Documentation

bool vrecko::Scheduler::classcomp::operator() | ( | const long int & | lhs,
 |  | const long int & | rhs
 | ) |  | const
 inline
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scheduler.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Scheduler::TimerStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
  • TimerStruct
Public Attributes | List of all members
vrecko::Scheduler::TimerStruct Struct Reference

#include <Scheduler.h>

Public Attributes

float | frequency
vThread * thread_ptr
osg::Timer_t | last_tick
std::vector< BaseClass * > | entity_vector

Member Data Documentation

std::vector<BaseClass*> vrecko::Scheduler::TimerStruct::entity_vector
float vrecko::Scheduler::TimerStruct::frequency
osg::Timer_t vrecko::Scheduler::TimerStruct::last_tick
vThread* vrecko::Scheduler::TimerStruct::thread_ptr
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Scheduler.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CollisionPointInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionPointInfo
Public Attributes | List of all members
vrecko::CollisionPointInfo Class Reference

#include <SP_CommonDefs.h>

Public Attributes

unsigned long | dwFlags
A combination of COLPOINT_FLAGS_*. More...
osg::Vec3 | points [2]
osg::Vec3 | vecTriMaxNegativeDistance
ONLY IF REQUESTED and ONLY IF [dwFlags] contains COLPOINT_FLAGS_NEG_DIST_PRESENT. More...

Member Data Documentation

unsigned long vrecko::CollisionPointInfo::dwFlags

A combination of COLPOINT_FLAGS_*.

osg::Vec3 vrecko::CollisionPointInfo::points[2]

The points can mean either a close (possible-)collision pair or an intersection line depending of the presence of COLPOINT_FLAGS_INTERSECTION_LINE in [dwFlags].

osg::Vec3 vrecko::CollisionPointInfo::vecTriMaxNegativeDistance

ONLY IF REQUESTED and ONLY IF [dwFlags] contains COLPOINT_FLAGS_NEG_DIST_PRESENT.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_CommonDefs.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CollisionInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionInfo
Public Member Functions | Public Attributes | List of all members
vrecko::CollisionInfo Class Reference

#include <SP_CommonDefs.h>

Public Member Functions

CollisionInfo ()
~CollisionInfo ()

Public Attributes

unsigned long eoID [2]
who collides with what More...
COLLISION_POINTS_VECTOR * points

Constructor & Destructor Documentation

vrecko::CollisionInfo::CollisionInfo ( )
inline
vrecko::CollisionInfo::~CollisionInfo ( )
inline

Member Data Documentation

unsigned long vrecko::CollisionInfo::eoID[2]

who collides with what

COLLISION_POINTS_VECTOR* vrecko::CollisionInfo::points
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_CommonDefs.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CollisionParams__ver1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionParams__ver1
Public Member Functions | Public Attributes | List of all members
vrecko::CollisionParams__ver1 Class Reference

Parameters for the SP_SceneInterface::getCollisions() method. More...

#include <SP_CommonDefs.h>

Public Member Functions

CollisionParams__ver1 ()
virtual bool isSame (const CollisionParams__ver1 *other) const

Public Attributes

unsigned long | dwStructureVersion
version of this structure. It is filled automatically in the constructor. More...
int | preferredSceneInterface
which scene partitioning interface to use (is set to PARTITIONING_INTERFACE_DEFAULT in constructor) More...
int | preferredObjectInterface
which object partitioning interface to use (is set to PARTITIONING_INTERFACE_DEFAULT in constructor) More...
unsigned long | dwFlags
float | maxCollisionDistance
osg::Vec3 | rayStart
osg::Vec3 | rayEnd
DynamicArray< unsigned long > | ignoredObjects
Objects that are ignored during the collision tests (if they are not enforced in getCollisions() parameters [limitToEO1] or [limitToEO2]) More...
unsigned int | bgThreadAffinityMask
unsigned long | debugGlobalUpdatesCounter
debug variable to count the number of global updates More...
SP_SceneInterface * scIntPtr
internal usage (cache): Pointer to the scene interface retrieved using the [preferrefSceneInterface] id. More...
SP_ObjectInterface * objIntPtr
internal usage (cache): Pointer to the object interface retrieved using the [preferrefObjectInterface] id. More...

Detailed Description

Parameters for the SP_SceneInterface::getCollisions() method.

Constructor & Destructor Documentation

vrecko::CollisionParams__ver1::CollisionParams__ver1 ( )
inline

Member Function Documentation

COLL_VRECKO_EXPORT bool vrecko::CollisionParams__ver1::isSame ( const CollisionParams__ver1 * other ) const
virtual

Member Data Documentation

unsigned int vrecko::CollisionParams__ver1::bgThreadAffinityMask

Optional and only useful if COLLISION_FLAGS_RUN_IN_BACKGROUND is specified in [dwFlags]. Can set the affinity of the background thread, thus forcing it to run on the specified processor(s). By default it can run on any processor and can switch processors as needed (will be decided by the operating system).

unsigned long vrecko::CollisionParams__ver1::debugGlobalUpdatesCounter

debug variable to count the number of global updates

unsigned long vrecko::CollisionParams__ver1::dwFlags

A combination of COLLISION_FLAGS_* constants. Defines the behaviour of the getCollisions() method

unsigned long vrecko::CollisionParams__ver1::dwStructureVersion

version of this structure. It is filled automatically in the constructor.

DynamicArray<unsigned long> vrecko::CollisionParams__ver1::ignoredObjects

Objects that are ignored during the collision tests (if they are not enforced in getCollisions() parameters [limitToEO1] or [limitToEO2])

float vrecko::CollisionParams__ver1::maxCollisionDistance

If == 0.0 then only contact points are returned. If > 0.0 then also soon-to-be collisions are included in the output. If == FLT_MAX then meaning is similar to > 0.0, but also no distance tests are made. (i.e. it is assumed that any pair can satisfy this condition)

SP_ObjectInterface* vrecko::CollisionParams__ver1::objIntPtr

internal usage (cache): Pointer to the object interface retrieved using the [preferrefObjectInterface] id.

int vrecko::CollisionParams__ver1::preferredObjectInterface

which object partitioning interface to use (is set to PARTITIONING_INTERFACE_DEFAULT in constructor)

int vrecko::CollisionParams__ver1::preferredSceneInterface

which scene partitioning interface to use (is set to PARTITIONING_INTERFACE_DEFAULT in constructor)

osg::Vec3 vrecko::CollisionParams__ver1::rayEnd
osg::Vec3 vrecko::CollisionParams__ver1::rayStart

If dwFlags includes COLLISION_FLAGS_RAYCASTING then these variables specify the ray start and end positions. (The ray is not infinite, it ends in the [rayEnd])

SP_SceneInterface* vrecko::CollisionParams__ver1::scIntPtr

internal usage (cache): Pointer to the scene interface retrieved using the [preferrefSceneInterface] id.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_CommonDefs.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/SP_CommonDefs.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::SP_Object_DataInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_Object_DataInterface
Public Member Functions | List of all members
vrecko::SP_Object_DataInterface Class Reference

#include <SP_ObjectInterface.h>

Inheritance diagram for vrecko::SP_Object_DataInterface:
APSpacePartitioning::SP_Object_Data_Base APSpacePartitioning::VoxelGrid_Object_Data APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > APSpacePartitioning::SphereBVH_Object_Data APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > APSpacePartitioning::SNCH_Object_Data APSpacePartitioning::PointShell_Object_Data

Public Member Functions

SP_Object_DataInterface ()
~SP_Object_DataInterface ()
virtual bool isHierarchyCreated ()

Constructor & Destructor Documentation

vrecko::SP_Object_DataInterface::SP_Object_DataInterface ( )
inline
vrecko::SP_Object_DataInterface::~SP_Object_DataInterface ( )
inline

Member Function Documentation

virtual bool vrecko::SP_Object_DataInterface::isHierarchyCreated ( )
inlinevirtual

Reimplemented in APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >, APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode >, APSpacePartitioning::SNCH_Object_Data, APSpacePartitioning::VoxelGrid_Object_Data, and APSpacePartitioning::SphereBVH_Object_Data.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_ObjectInterface.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::SP_ObjectInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_ObjectInterface
Public Member Functions | Protected Attributes | List of all members
vrecko::SP_ObjectInterface Class Reference

#include <SP_ObjectInterface.h>

Inheritance diagram for vrecko::SP_ObjectInterface:
APSpacePartitioning::PointShellVSVoxel_Object APSpacePartitioning::SphereBVH_Object APSpacePartitioning::SNCH_Object

Public Member Functions

SP_ObjectInterface ()
~SP_ObjectInterface ()
int | getId ()
usually one of the SP_OBJECT_INTERFACE_ID__* constants More...
virtual bool | getCollisions (CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time)

Protected Attributes

int objIntId

Constructor & Destructor Documentation

vrecko::SP_ObjectInterface::SP_ObjectInterface ( )
inline
vrecko::SP_ObjectInterface::~SP_ObjectInterface ( )
inline

Member Function Documentation

virtual bool vrecko::SP_ObjectInterface::getCollisions | ( | CollisionParams * | params,
 |  | COLLISION_POINTS_VECTOR ** | colPoints,
 |  | unsigned long | obj1ID,
 |  | unsigned long | obj2ID,
 |  | float | time
 | ) |  |
inlinevirtual

Computes the collisions between objects. Returns "false" in case of error.

[*colPoints] may be NULL on the input. In case there is no collision, it will still be NULL at the end, otherwise the structure will be created and the pointer to it returned.

[colPoints] may also be NULL, which means that no collision points are to be returned. The reason to make such a call is to update the internal structures of the Object col. det. class.

Reimplemented in APSpacePartitioning::PointShellVSVoxel_Object.

int vrecko::SP_ObjectInterface::getId ( )
inline

usually one of the SP_OBJECT_INTERFACE_ID__* constants

Member Data Documentation

int vrecko::SP_ObjectInterface::objIntId
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_ObjectInterface.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::SP_SceneInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_SceneInterface
Public Member Functions | Protected Attributes | List of all members
vrecko::SP_SceneInterface Class Reference

#include <SP_SceneInterface.h>

Inheritance diagram for vrecko::SP_SceneInterface:
APSpacePartitioning::NoPartitioning_Scene APSpacePartitioning::SphereBVH_Scene

Public Member Functions

SP_SceneInterface ()
~SP_SceneInterface ()
int | getId ()
virtual bool | performCompleteTest (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)
virtual bool | performUpdate (CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2)

Protected Attributes

int scIntId

Constructor & Destructor Documentation

vrecko::SP_SceneInterface::SP_SceneInterface ( )
inline
vrecko::SP_SceneInterface::~SP_SceneInterface ( )
inline

Member Function Documentation

int vrecko::SP_SceneInterface::getId ( )
inline
virtual bool vrecko::SP_SceneInterface::performCompleteTest | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | limitToEO1,
 |  | unsigned long | limitToEO2
 | ) |  |
inlinevirtual

This method performs the complete collision test as requested. It assumes that all parameters are already validated. The reason to split the validation and this method is that this method may be called from a thread.

Reimplemented in APSpacePartitioning::NoPartitioning_Scene.

virtual bool vrecko::SP_SceneInterface::performUpdate | ( | CollisionParams * | params,
 |  | COLLISIONS_INFO_VECTOR ** | collisions,
 |  | unsigned long | limitToEO1,
 |  | unsigned long | limitToEO2
 | ) |  |
inlinevirtual

Performs an update of results gathered in a previous run (or a background thread). [iThreadIndex] is an index to the [threadsInfo] array.

Reimplemented in APSpacePartitioning::NoPartitioning_Scene.

Member Data Documentation

int vrecko::SP_SceneInterface::scIntId
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/SP_SceneInterface.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::StaticAttribute< type, tval, tref > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • StaticAttribute
Public Member Functions | List of all members
vrecko::StaticAttribute< type, tval, tref > Class Template Reference

#include <StaticAttribute.h>

Inheritance diagram for vrecko::StaticAttribute< type, tval, tref >:
vrecko::Attribute

Public Member Functions

StaticAttribute (const string &strName, const string &strDescription, tref defaultValue, Range *pRange=null)
~StaticAttribute ()
tref | getDefaultValue () const
const Range * | getRangePtr () const
bool | hasRange () const
- Public Member Functions inherited from vrecko::Attribute
const string & | getName () const
DataType | getDataType () const
const string & | getDescription () const
bool | isStatic () const
bool | isDynamic () const

Additional Inherited Members

- Public Types inherited from vrecko::Attribute
enum DataType {
TYPE_BOOL, TYPE_INT, TYPE_LONG, TYPE_FLOAT,
TYPE_DOUBLE, TYPE_STRING, TYPE_VEC2, TYPE_VEC3,
TYPE_VEC4, TYPE_MATRIX, TYPE_QUAT, TYPE_DYNAMIC
}
- Protected Member Functions inherited from vrecko::Attribute
Attribute (const string &strName, DataType dataType, const string &strDescription)
Attribute (const Attribute &attribute)

Detailed Description

template<Attribute::DataType type, class tval, class tref = tval>
class vrecko::StaticAttribute< type, tval, tref >

Represents a static attribute.

This class uses templates. Specialized classes are prepared for bool, int, long, float, double, string, Vec2, Vec3, Vec4, Matrix and Quat data types. No other specializations should be used. Specialized classes are listed below this class.

Parameters
dataType | data type identificator
tval | data type used to store values
tref | data type used for passing arguments and results
See Also
Attribute
DynamicAttribute
BoolAttribute
IntAttribute
LongAttribute
FloatAttribute
DoubleAttribute
StringAttribute
Vec2Attribute
Vec3Attribute
Vec4Attribute
MatrixAttribute
QuatAttribute

Constructor & Destructor Documentation

template<Attribute::DataType type, class tval , class tref = tval>
vrecko::StaticAttribute< type, tval, tref >::StaticAttribute | ( | const string & | strName,
 |  | const string & | strDescription,
 |  | tref | defaultValue,
 |  | Range * | pRange = null
 | ) |  |
inline

Constructs a StaticAttribute object.

Any pointers passed to this constructor as parameters are used directly, no copy is made. You have to ensure a unique pointer is passed per each call of this constructor. Also ensure that the pointer is used only wihtin the context of this constructor and nowhere else and stays valid all the time. Allocated memory is freed automatically.

Parameters
strName | reference to a constant attribute name
strDescription | reference to a constant attribute description
defaultValue | attribute default value
pRange | pointer to a Range object on the heap or null if no range is used
template<Attribute::DataType type, class tval , class tref = tval>
vrecko::StaticAttribute< type, tval, tref >::~StaticAttribute ( )
inline

Performs cleanup before object destruction.

Member Function Documentation

template<Attribute::DataType type, class tval , class tref = tval>
tref vrecko::StaticAttribute< type, tval, tref >::getDefaultValue ( ) const
inline

Returns attribute default value.

Returns
attribute default value
template<Attribute::DataType type, class tval , class tref = tval>
const Range* vrecko::StaticAttribute< type, tval, tref >::getRangePtr ( ) const
inline

Returns attribute range.

Returns
pointer to a constant Range object or null if not set
template<Attribute::DataType type, class tval , class tref = tval>
bool vrecko::StaticAttribute< type, tval, tref >::hasRange ( ) const
inline

"Has range" predicate.

Returns
true if the attribute has a range, false otherwise
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/StaticAttribute.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Timer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Timer
Public Member Functions | Static Public Member Functions | Protected Attributes | List of all members
vrecko::Timer Class Reference

#include <Timer.h>

Public Member Functions

Timer ()
~Timer ()
osg::Timer_t | tick () const
void | setStartTick ()
void | setStartTick (osg::Timer_t t)
osg::Timer_t | getStartTick () const
double | time_s () const
double | time_m () const
double | time_u () const
double | time_n () const
double | delta_s (osg::Timer_t t1, osg::Timer_t t2) const
double | delta_m (osg::Timer_t t1, osg::Timer_t t2) const
double | delta_u (osg::Timer_t t1, osg::Timer_t t2) const
double | delta_n (osg::Timer_t t1, osg::Timer_t t2) const
double | getSecondsPerTick () const

Static Public Member Functions

static Timer * instance ()

Protected Attributes

osg::Timer_t | _startTick
double | _secsPerTick

Constructor & Destructor Documentation

vrecko::Timer::Timer ( )
vrecko::Timer::~Timer ( )

Member Function Documentation

double vrecko::Timer::delta_m | ( | osg::Timer_t | t1,
 |  | osg::Timer_t | t2
 | ) |  | const
 inline

Get the time in milliseconds between timer ticks t1 and t2.

double vrecko::Timer::delta_n | ( | osg::Timer_t | t1,
 |  | osg::Timer_t | t2
 | ) |  | const
 inline

Get the time in nanoseconds between timer ticks t1 and t2.

double vrecko::Timer::delta_s | ( | osg::Timer_t | t1,
 |  | osg::Timer_t | t2
 | ) |  | const
 inline

Get the time in seconds between timer ticks t1 and t2.

double vrecko::Timer::delta_u | ( | osg::Timer_t | t1,
 |  | osg::Timer_t | t2
 | ) |  | const
 inline

Get the time in microseconds between timer ticks t1 and t2.

double vrecko::Timer::getSecondsPerTick ( ) const
inline

Get the the number of ticks per second.

osg::Timer_t vrecko::Timer::getStartTick ( ) const
inline
Timer * vrecko::Timer::instance ( )
static
void vrecko::Timer::setStartTick ( )
inline

Set the start.

void vrecko::Timer::setStartTick ( osg::Timer_t t )
inline
osg::Timer_t vrecko::Timer::tick ( ) const

Get the timers tick value.

double vrecko::Timer::time_m ( ) const
inline

Get elapsed time in milliseconds.

double vrecko::Timer::time_n ( ) const
inline

Get elapsed time in nanoseconds.

double vrecko::Timer::time_s ( ) const
inline

Get elapsed time in seconds.

double vrecko::Timer::time_u ( ) const
inline

Get elapsed time in microseconds.

Member Data Documentation

double vrecko::Timer::_secsPerTick
protected
osg::Timer_t vrecko::Timer::_startTick
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Timer.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Timer.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ViewerBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ViewerBase
Public Member Functions | List of all members
vrecko::ViewerBase Class Referenceabstract

Abstract VRECKO viewer class. More...

#include <Viewer.h>

Inheritance diagram for vrecko::ViewerBase:
vrecko::CompositeViewer vrecko::Viewer

Public Member Functions

virtual osgViewer::ViewerBase * | getViewer ()=0
virtual void | addView (osgViewer::View *view)=0
virtual void | setDisplaySettings (osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL)=0
virtual void | setFusionDistance (osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f)=0
virtual void | addEventHandler (osgGA::GUIEventHandler *eventHandler)=0
virtual void | setSceneData (osg::Node *node)=0
virtual void | camera_setViewMatrixAsLookAt (const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up)=0
virtual void | setLight (osg::Light *light)=0
virtual osg::Light * | getLight ()=0
virtual osg::Camera * | getCamera (int screenNum=0)=0
virtual int | getStereoMode ()=0
bool | done ()
void | realize ()
void | setThreadingModel (osgViewer::ViewerBase::ThreadingModel threadingModel)
void | getWindows (osgViewer::ViewerBase::Windows &windows, bool onlyValid=true)
void | getCameras (osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true)
void | getContexts (osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true)
void | frame (double simulationTime=USE_REFERENCE_TIME)

Detailed Description

Abstract VRECKO viewer class.

Member Function Documentation

virtual void vrecko::ViewerBase::addEventHandler ( osgGA::GUIEventHandler * eventHandler )
pure virtual

Add an EventHandler that adds handling of events to the View.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual void vrecko::ViewerBase::addView ( osgViewer::View * view )
pure virtual

Adds new view to existing viewer

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual void vrecko::ViewerBase::camera_setViewMatrixAsLookAt | ( | const osg::Vec3d & | eye,
 |  | const osg::Vec3d & | center,
 |  | const osg::Vec3d & | up
 | ) |  |
pure virtual

Set to the position and orientation of view matrix, using the same convention as gluLookAt.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

bool vrecko::ViewerBase::done ( )
inline

Return true if viewer's work is done and should exit the frame loop.

void vrecko::ViewerBase::frame ( double simulationTime = USE_REFERENCE_TIME )
inline
virtual osg::Camera* vrecko::ViewerBase::getCamera ( int screenNum = 0 )
pure virtual

Get the master camera of the view.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

void vrecko::ViewerBase::getCameras | ( | osgViewer::ViewerBase::Cameras & | cameras,
 |  | bool | onlyActive = true
 | ) |  |
inline
void vrecko::ViewerBase::getContexts | ( | osgViewer::ViewerBase::Contexts & | contexts,
 |  | bool | onlyValid = true
 | ) |  |
inline
virtual osg::Light* vrecko::ViewerBase::getLight ( )
pure virtual

Get the global lighting if assigned.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual int vrecko::ViewerBase::getStereoMode ( )
pure virtual

Get stereo mode

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual osgViewer::ViewerBase* vrecko::ViewerBase::getViewer ( )
pure virtual

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

void vrecko::ViewerBase::getWindows | ( | osgViewer::ViewerBase::Windows & | windows,
 |  | bool | onlyValid = true
 | ) |  |
inline
void vrecko::ViewerBase::realize ( )
inline

Set up windows and associated threads.

virtual void vrecko::ViewerBase::setDisplaySettings | ( | osg::DisplaySettings * | ds1,
 |  | osg::DisplaySettings * | ds2 = NULL
 | ) |  |
pure virtual

Set the DisplaySettings object associated with this view.

Parameters
ds1 | first screen
ds2 | second screen

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual void vrecko::ViewerBase::setFusionDistance | ( | osgUtil::SceneView::FusionDistanceMode | mode,
 |  | float | value = 1.0f
 | ) |  |
pure virtual

Set the FusionDistanceMode and Value. Note, is used only when working in stereo.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual void vrecko::ViewerBase::setLight ( osg::Light * light )
pure virtual

Get the global light.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

virtual void vrecko::ViewerBase::setSceneData ( osg::Node * node )
pure virtual

Set the scene graph that the View will use.

Implemented in vrecko::CompositeViewer, and vrecko::Viewer.

void vrecko::ViewerBase::setThreadingModel ( osgViewer::ViewerBase::ThreadingModel threadingModel )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Viewer.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::Viewer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Viewer
Public Member Functions | List of all members
vrecko::Viewer Class Reference

Child class for classic one screen viewer - used for QUAD_STEREO. More...

#include <Viewer.h>

Inheritance diagram for vrecko::Viewer:
vrecko::ViewerBase

Public Member Functions

Viewer (int stereoMode)
virtual osgViewer::ViewerBase * | getViewer ()
virtual void | addView (osgViewer::View *view)
virtual void | setDisplaySettings (osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL)
virtual void | setFusionDistance (osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f)
virtual void | addEventHandler (osgGA::GUIEventHandler *eventHandler)
virtual void | setSceneData (osg::Node *node)
virtual void | camera_setViewMatrixAsLookAt (const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up)
virtual void | setLight (osg::Light *light)
virtual osg::Light * | getLight ()
virtual osg::Camera * | getCamera (int screenNum=0)
virtual int | getStereoMode ()
- Public Member Functions inherited from vrecko::ViewerBase
bool | done ()
void | realize ()
void | setThreadingModel (osgViewer::ViewerBase::ThreadingModel threadingModel)
void | getWindows (osgViewer::ViewerBase::Windows &windows, bool onlyValid=true)
void | getCameras (osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true)
void | getContexts (osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true)
void | frame (double simulationTime=USE_REFERENCE_TIME)

Detailed Description

Child class for classic one screen viewer - used for QUAD_STEREO.

Constructor & Destructor Documentation

Viewer::Viewer ( int stereoMode )

Viewer class

Member Function Documentation

virtual void vrecko::Viewer::addEventHandler ( osgGA::GUIEventHandler * eventHandler )
inlinevirtual

Add an EventHandler that adds handling of events to the View.

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::addView ( osgViewer::View * view )
inlinevirtual

Not supported in this mode

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::camera_setViewMatrixAsLookAt | ( | const osg::Vec3d & | eye,
 |  | const osg::Vec3d & | center,
 |  | const osg::Vec3d & | up
 | ) |  |
inlinevirtual

Set to the position and orientation of view matrix, using the same convention as gluLookAt.

Implements vrecko::ViewerBase.

virtual osg::Camera* vrecko::Viewer::getCamera ( int screenNum = 0 )
inlinevirtual

Get the master camera of the view.

Implements vrecko::ViewerBase.

virtual osg::Light* vrecko::Viewer::getLight ( )
inlinevirtual

Get the global lighting if assigned.

Implements vrecko::ViewerBase.

virtual int vrecko::Viewer::getStereoMode ( )
inlinevirtual

Get stereo mode

Implements vrecko::ViewerBase.

virtual osgViewer::ViewerBase* vrecko::Viewer::getViewer ( )
inlinevirtual

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::setDisplaySettings | ( | osg::DisplaySettings * | ds1,
 |  | osg::DisplaySettings * | ds2 = NULL
 | ) |  |
inlinevirtual

Set the DisplaySettings object associated with this view.

Parameters
ds1 | first screen
ds2 | second screen

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::setFusionDistance | ( | osgUtil::SceneView::FusionDistanceMode | mode,
 |  | float | value = 1.0f
 | ) |  |
inlinevirtual

Set the FusionDistanceMode and Value. Note, is used only when working in stereo.

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::setLight ( osg::Light * light )
inlinevirtual

Get the global light.

Implements vrecko::ViewerBase.

virtual void vrecko::Viewer::setSceneData ( osg::Node * node )
inlinevirtual

Set the scene graph that the View will use.

Implements vrecko::ViewerBase.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Viewer.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Viewer.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CompositeViewer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CompositeViewer
Public Member Functions | List of all members
vrecko::CompositeViewer Class Reference

Child class for more than one screen viewer. More...

#include <Viewer.h>

Inheritance diagram for vrecko::CompositeViewer:
vrecko::ViewerBase

Public Member Functions

CompositeViewer (int stereoMode)
virtual osgViewer::ViewerBase * | getViewer ()
virtual void | addView (osgViewer::View *view)
virtual void | setDisplaySettings (osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL)
virtual void | setFusionDistance (osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f)
virtual void | addEventHandler (osgGA::GUIEventHandler *eventHandler)
virtual void | setSceneData (osg::Node *node)
virtual void | camera_setViewMatrixAsLookAt (const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up)
virtual void | setLight (osg::Light *light)
virtual osg::Light * | getLight ()
virtual osg::Camera * | getCamera (int screenNum=0)
virtual int | getStereoMode ()
- Public Member Functions inherited from vrecko::ViewerBase
bool | done ()
void | realize ()
void | setThreadingModel (osgViewer::ViewerBase::ThreadingModel threadingModel)
void | getWindows (osgViewer::ViewerBase::Windows &windows, bool onlyValid=true)
void | getCameras (osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true)
void | getContexts (osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true)
void | frame (double simulationTime=USE_REFERENCE_TIME)

Detailed Description

Child class for more than one screen viewer.

Stereo modes: 0-none, 1-anaglyph, 2-vertical, 3-horizontal, 4-quad (3DVision), 5-DualScreen

Constructor & Destructor Documentation

CompositeViewer::CompositeViewer ( int stereoMode )

CompositeViewer class

Member Function Documentation

virtual void vrecko::CompositeViewer::addEventHandler ( osgGA::GUIEventHandler * eventHandler )
inlinevirtual

Add an EventHandler that adds handling of events to the View.

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::addView ( osgViewer::View * view )
inlinevirtual

Adds new view to existing viewer

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::camera_setViewMatrixAsLookAt | ( | const osg::Vec3d & | eye,
 |  | const osg::Vec3d & | center,
 |  | const osg::Vec3d & | up
 | ) |  |
inlinevirtual

Set to the position and orientation of view matrix, using the same convention as gluLookAt.

Implements vrecko::ViewerBase.

virtual osg::Camera* vrecko::CompositeViewer::getCamera ( int screenNum = 0 )
inlinevirtual

Get the master camera of the view.

Implements vrecko::ViewerBase.

virtual osg::Light* vrecko::CompositeViewer::getLight ( )
inlinevirtual

Get the global lighting if assigned.

Implements vrecko::ViewerBase.

virtual int vrecko::CompositeViewer::getStereoMode ( )
inlinevirtual

Get stereo mode

Implements vrecko::ViewerBase.

virtual osgViewer::ViewerBase* vrecko::CompositeViewer::getViewer ( )
inlinevirtual

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::setDisplaySettings | ( | osg::DisplaySettings * | ds1,
 |  | osg::DisplaySettings * | ds2 = NULL
 | ) |  |
inlinevirtual

Set the DisplaySettings object associated with this view.

Parameters
ds1 | first screen
ds2 | second screen

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::setFusionDistance | ( | osgUtil::SceneView::FusionDistanceMode | mode,
 |  | float | value = 1.0f
 | ) |  |
inlinevirtual

Set the FusionDistanceMode and Value. Note, is used only when working in stereo.

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::setLight ( osg::Light * light )
inlinevirtual

Get the global light.

Implements vrecko::ViewerBase.

virtual void vrecko::CompositeViewer::setSceneData ( osg::Node * node )
inlinevirtual

Set the scene graph that the View will use.

Implements vrecko::ViewerBase.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/Viewer.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Viewer.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::vThread Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • vThread
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Attributes | Static Protected Attributes | List of all members
vrecko::vThread Class Reference

#include <vThread.h>

Public Member Functions

vThread (BaseClass *ent_ptr, float freq)
vThread (std::vector< BaseClass * > ent_vec, float freq)
vThread (void(*funcPtr)(void), float freq)
vThread (void(*funcPtr)(void), unsigned int step, float freq)
~vThread ()
void | start (void)
void | stop (void)
bool | getDone (void)
bool | getRun (void)
float | getFrequency (void)
osg::Timer_t | getLastTick (void)
BaseClass * | getEntityPtr (int pos)
bool | addEntity (BaseClass *ent)
bool | removeEntity (BaseClass *ent)
void | syncEntityVector (void)
std::vector< BaseClass * > * | getEntityVec (void)
unsigned int | getStepCounter (void)
pthread_mutex_t * | getMutex (void)
void | reportError (const std::string &error)
void | reportError (char *error)
unsigned long | getDelay (void)

Static Public Member Functions

static pthread_mutex_t * | createMutex ()
static void | destroyMutex (pthread_mutex_t *mutex)
static unsigned long | getDelay (osg::Timer_t last_t, float freq)
static const osg::Timer * | getTimerPtr (void)

Public Attributes

void(*)() | getFuncPtr (void)
osg::Timer_t | last_tick

Protected Attributes

pthread_t | th_read
std::vector< BaseClass * > * | entity_vector
std::map< BaseClass *, bool > | temp_entity_map
void(* | voidFuncPtr )(void)
float | frequency
bool | done
bool | run
unsigned int | step_counter
pthread_mutex_t * | hvT_Mutex

Static Protected Attributes

static const osg::Timer * timer = osg::Timer::instance()

Constructor & Destructor Documentation

vThread::vThread | ( | BaseClass * | ent_ptr,
 |  | float | freq
 | ) |  |
vThread::vThread | ( | std::vector< BaseClass * > | ent_vec,
 |  | float | freq
 | ) |  |
vThread::vThread | ( | void(*)(void) | funcPtr,
 |  | float | freq
 | ) |  |
vThread::vThread | ( | void(*)(void) | funcPtr,
 |  | unsigned int | step,
 |  | float | freq
 | ) |  |
vThread::~vThread ( )

Member Function Documentation

bool vThread::addEntity ( BaseClass * ent )
pthread_mutex_t * vThread::createMutex ( )
static
void vThread::destroyMutex ( pthread_mutex_t * mutex )
static
unsigned long vThread::getDelay | ( | osg::Timer_t | last_t,
 |  | float | freq
 | ) |  |
static
unsigned long vrecko::vThread::getDelay ( void )
inline
bool vrecko::vThread::getDone ( void )
inline
BaseClass* vrecko::vThread::getEntityPtr ( int pos )
inline
std::vector<BaseClass*>* vrecko::vThread::getEntityVec ( void )
inline
float vrecko::vThread::getFrequency ( void )
inline
osg::Timer_t vrecko::vThread::getLastTick ( void )
inline
pthread_mutex_t* vrecko::vThread::getMutex ( void )
inline
bool vrecko::vThread::getRun ( void )
inline
unsigned int vrecko::vThread::getStepCounter ( void )
inline
static const osg::Timer* vrecko::vThread::getTimerPtr ( void )
inlinestatic
bool vThread::removeEntity ( BaseClass * ent )
void vThread::reportError ( const std::string & error )
void vrecko::vThread::reportError ( char * error )
inline
void vrecko::vThread::start ( void )
inline
void vrecko::vThread::stop ( void )
inline
void vThread::syncEntityVector ( void )

Member Data Documentation

bool vrecko::vThread::done
protected
std::vector<BaseClass*>* vrecko::vThread::entity_vector
protected
float vrecko::vThread::frequency
protected
void(*)() vrecko::vThread::getFuncPtr(void)
inline
pthread_mutex_t* vrecko::vThread::hvT_Mutex
protected
osg::Timer_t vrecko::vThread::last_tick
bool vrecko::vThread::run
protected
unsigned int vrecko::vThread::step_counter
protected
std::map<BaseClass*, bool> vrecko::vThread::temp_entity_map
protected
pthread_t vrecko::vThread::th_read
protected
const osg::Timer * vThread::timer = osg::Timer::instance()
staticprotected
void(* vrecko::vThread::voidFuncPtr)(void)
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/vThread.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/vThread.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::World Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
Classes | Public Types | Public Member Functions | Public Attributes | Protected Attributes | List of all members
vrecko::World Class Reference

#include <World.h>

Inheritance diagram for vrecko::World:
vrecko::BaseClass

Classes

struct | AvatarEye
Struct AvatarEye - represents avatar eye's camera parameters. More...
struct | AvatarView
Struct for description of AvatarView. More...
struct | SG_CHANGE
Struct that includes values of the operation parameters. More...

Public Types

enum SG_OPERATION_TYPE {
UNKNOWN, ADD_CHILD, ADD_EOCHILD, REMOVE_CHILD,
REMOVE_EOCHILD, SET_STATESET, DELETE_STATESET, SET_TEXT
}
Enum to describe scenegraph operation. More...
- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}

Public Member Functions

World ()
~World ()
World (const World &w)
void | setViewerPtr (ViewerBase *pV)
ViewerBase * getViewerPtr ()
osg::Camera * | getCamera (void)
osgShadow::ShadowedScene * | getShadowedScenePtr ()
osg::LightSource * | getShadowedSceneLight ()
void | setDescription (const std::string &desc)
Set description of the World. More...
const std::string & | getDescription (void) const
Return the description. More...
void | setScenePtr (Scene *nScene)
Set pointer to the Scene. More...
Scene * | getScenePtr (void)
Return pointer to the Scene. More...
AvatarView * | getActualAvatarView (void)
Return pointer to actual AvatarView. More...
void | setActualAvatarView (AvatarView *av)
Set actual AvatarView. More...
bool | removeAvatarView (AvatarView *av)
Remove AvatarView with given pointer. More...
vrecko::Ability * | createAbility (const std::string &plugin_name, const std::string &ability_name, BaseClass *_owner, const char *_overridingID=NULL)
void | setDeviceManagerPtr (DeviceManager *ptr)
DeviceManager * getDeviceManagerPtr ()
void | setEventDispatcherPtr (EventDispatcher *ptr)
EventDispatcher * getEventDispatcherPtr ()
void | setSchedulerPtr (Scheduler *sched)
Scheduler * getSchedulerPtr ()
PersistentCache * getPersistentCache ()
bool | getTerminationFlag ()
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
void | noticeLog (const char *notice="",...)
void | warningLog (const char *warning="",...)
void | errorLog (const char *error="",...)
void | debugLog (const char *debugText="",...)
void | debugFileLog (const char *debugText="",...)
bool | addAbility (Ability *pAbility)
Adds ability to EO. More...
bool | removeAbility (Ability *pAbility)
Removes ability from EO. More...
bool | removeAbility (const std::string &ability_id)
Ability * | getAbility (const std::string &ab_id)
Return pointer to ability with given ID. More...
std::map< std::string, Ability * > & | getAbilityMap (void)
Return map of the abilities in the EO. More...
bool | reportEvent (const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT)
bool | reportEvent (BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT)
osg::ref_ptr< VreckoMessage > | request (const std::string &req_sender, VreckoMessage *pMessage)
osg::ref_ptr< VreckoMessage > | request (BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage)
unsigned long | getFrameID ()
void | incrementFrameID ()
bool | getShowTimeWarnings ()
void | setShowTimeWarnings (bool bNewValue)
unsigned long | getTimeWarningsTime ()
void | setTimeWarningsTime (unsigned long ulNewValue)
void | SendTerminationNotifications ()
void | setArgumens (int &count, char **arguments)
int | getNumberOfArguments ()
char ** | getArguments ()
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

osg::ref_ptr
< osgShadow::ShadowedScene > 		shadowedScene
class {
} AvatarEyes

Protected Attributes

std::string | description
Description string. More...
Scene * pScene
Pointer to the Scene. More...
std::vector< AvatarView * > | avatar_view_vector
Vector of AvatarViews. More...
ViewerBase * viewer
osg::ref_ptr< osg::LightSource > | mainLightSource
AbilityDispatcher * ability_dispatcher
Internal AbilityDispatcher that serves to maintain abilities in EO. More...
PersistentCache * persistentCache
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Member Enumeration Documentation

enum vrecko::World::SG_OPERATION_TYPE

Enum to describe scenegraph operation.

Enumerator
UNKNOWN
ADD_CHILD
ADD_EOCHILD
REMOVE_CHILD
REMOVE_EOCHILD
SET_STATESET
DELETE_STATESET
SET_TEXT

Constructor & Destructor Documentation

vrecko::World::World ( )
vrecko::World::~World ( )
vrecko::World::World ( const World & w )

Member Function Documentation

bool vrecko::World::addAbility ( Ability * pAbility )
inline

Adds ability to EO.

vrecko::Ability * vrecko::World::createAbility | ( | const std::string & | plugin_name,
 |  | const std::string & | ability_name,
 |  | BaseClass * | _owner,
 |  | const char * | _overridingID = NULL
 | ) |  |
void vrecko::World::debugFileLog | ( | const char * | debugText = "",
 |  |  | ...
 | ) |  |
void vrecko::World::debugLog | ( | const char * | debugText = "",
 |  |  | ...
 | ) |  |
void vrecko::World::errorLog | ( | const char * | error = "",
 |  |  | ...
 | ) |  |
Ability* vrecko::World::getAbility ( const std::string & ab_id )
inline

Return pointer to ability with given ID.

std::map<std::string, Ability*>& vrecko::World::getAbilityMap ( void )
inline

Return map of the abilities in the EO.

AvatarView* vrecko::World::getActualAvatarView ( void )
inline

Return pointer to actual AvatarView.

char ** vrecko::World::getArguments ( )
osg::Camera* vrecko::World::getCamera ( void )
inline
const std::string& vrecko::World::getDescription ( void ) const
inline

Return the description.

DeviceManager* vrecko::World::getDeviceManagerPtr ( )
inline

Get DeviceManager pointer.

EventDispatcher* vrecko::World::getEventDispatcherPtr ( )
inline

Get EventDispatcher pointer.

unsigned long vrecko::World::getFrameID ( )
inline
int vrecko::World::getNumberOfArguments ( )
PersistentCache* vrecko::World::getPersistentCache ( )
inline
Scene* vrecko::World::getScenePtr ( void )
inline

Return pointer to the Scene.

Scheduler* vrecko::World::getSchedulerPtr ( )
inline

Get Scheduler pointer

osg::LightSource* vrecko::World::getShadowedSceneLight ( )
inline
osgShadow::ShadowedScene* vrecko::World::getShadowedScenePtr ( )
inline
bool vrecko::World::getShowTimeWarnings ( )
inline
bool vrecko::World::getTerminationFlag ( )
inline

Get value of the termination flag.

unsigned long vrecko::World::getTimeWarningsTime ( )
inline
ViewerBase* vrecko::World::getViewerPtr ( )
inline
void vrecko::World::incrementFrameID ( )
inline
bool vrecko::World::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

Load parameters from xml file

Reimplemented from vrecko::BaseClass.

void vrecko::World::noticeLog | ( | const char * | notice = "",
 |  |  | ...
 | ) |  |
bool vrecko::World::removeAbility ( Ability * pAbility )
inline

Removes ability from EO.

bool vrecko::World::removeAbility ( const std::string & ability_id )
bool vrecko::World::removeAvatarView ( AvatarView * av )

Remove AvatarView with given pointer.

bool vrecko::World::reportEvent | ( | const std::string & | senderAndOutputString,
 |  | VreckoMessage * | pMessage,
 |  | EventType | eType = EXPRESS_EVENT
 | ) |  |
inline
bool vrecko::World::reportEvent | ( | BaseClass * | receiver_ptr,
 |  | const std::string & | input_name,
 |  | VreckoMessage * | pMessage,
 |  | EventType | eType = EXPRESS_EVENT
 | ) |  |
inline
osg::ref_ptr<VreckoMessage> vrecko::World::request | ( | const std::string & | req_sender,
 |  | VreckoMessage * | pMessage
 | ) |  |
inline
osg::ref_ptr<VreckoMessage> vrecko::World::request | ( | BaseClass * | receiver_ptr,
 |  | const std::string & | request_name,
 |  | VreckoMessage * | pMessage
 | ) |  |
inline
void vrecko::World::SendTerminationNotifications ( )
inline
void vrecko::World::setActualAvatarView ( AvatarView * av )
inline

Set actual AvatarView.

void vrecko::World::setArgumens | ( | int & | count,
 |  | char ** | arguments
 | ) |  |
void vrecko::World::setDescription ( const std::string & desc )
inline

Set description of the World.

void vrecko::World::setDeviceManagerPtr ( DeviceManager * ptr )
inline

Set DeviceManager pointer.

void vrecko::World::setEventDispatcherPtr ( EventDispatcher * ptr )
inline

Set EventDispatcher pointer.

void vrecko::World::setScenePtr ( Scene * nScene )

Set pointer to the Scene.

void vrecko::World::setSchedulerPtr ( Scheduler * sched )
inline

Set Scheduler pointer

void vrecko::World::setShowTimeWarnings ( bool bNewValue )
inline
void vrecko::World::setTimeWarningsTime ( unsigned long ulNewValue )
inline
void vrecko::World::setViewerPtr ( vrecko::ViewerBase * pV )
void vrecko::World::warningLog | ( | const char * | warning = "",
 |  |  | ...
 | ) |  |

Member Data Documentation

AbilityDispatcher* vrecko::World::ability_dispatcher
protected

Internal AbilityDispatcher that serves to maintain abilities in EO.

std::vector<AvatarView *> vrecko::World::avatar_view_vector
protected

Vector of AvatarViews.

class { ... } vrecko::World::AvatarEyes
std::string vrecko::World::description
protected

Description string.

osg::ref_ptr<osg::LightSource> vrecko::World::mainLightSource
protected
PersistentCache* vrecko::World::persistentCache
protected
Scene* vrecko::World::pScene
protected

Pointer to the Scene.

osg::ref_ptr<osgShadow::ShadowedScene> vrecko::World::shadowedScene
ViewerBase* vrecko::World::viewer
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/World.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/World.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::World::AvatarEye Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • AvatarEye
Public Attributes | List of all members
vrecko::World::AvatarEye Struct Reference

Struct AvatarEye - represents avatar eye's camera parameters. More...

#include <World.h>

Public Attributes

osg::Vec3 | eye_offset
offset - Vector from avatar to its eye More...
osg::Matrix | projection
projection - Projection matrix of a camera at avatar's eye More...

Detailed Description

Struct AvatarEye - represents avatar eye's camera parameters.

Member Data Documentation

osg::Vec3 vrecko::World::AvatarEye::eye_offset

offset - Vector from avatar to its eye

osg::Matrix vrecko::World::AvatarEye::projection

projection - Projection matrix of a camera at avatar's eye

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/World.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::World::AvatarView Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • AvatarView
Public Attributes | List of all members
vrecko::World::AvatarView Struct Reference

Struct for description of AvatarView. More...

#include <World.h>

Public Attributes

std::string | ID
Identification string. More...
BaseClass * owner
Pointer to owner. More...
osg::Vec3 | eye_position
Position of the avatar eye. More...
osg::Vec3 | look_at_center
Center, where the avatar is looking. More...
osg::Vec3 | up_vector
Up vector of the view. More...

Detailed Description

Struct for description of AvatarView.

Member Data Documentation

osg::Vec3 vrecko::World::AvatarView::eye_position

Position of the avatar eye.

std::string vrecko::World::AvatarView::ID

Identification string.

osg::Vec3 vrecko::World::AvatarView::look_at_center

Center, where the avatar is looking.

BaseClass* vrecko::World::AvatarView::owner

Pointer to owner.

osg::Vec3 vrecko::World::AvatarView::up_vector

Up vector of the view.

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/World.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::World::SG_CHANGE Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • SG_CHANGE
Public Attributes | List of all members
vrecko::World::SG_CHANGE Struct Reference

Struct that includes values of the operation parameters. More...

#include <World.h>

Public Attributes

osg::Node * | pNode
osg::Group * | pGroup
osg::StateSet * | pStateSet
osgText::Text * | pText
std::string | text_string
SG_OPERATION_TYPE type

Detailed Description

Struct that includes values of the operation parameters.

Member Data Documentation

osg::Group* vrecko::World::SG_CHANGE::pGroup
osg::Node* vrecko::World::SG_CHANGE::pNode
osg::StateSet* vrecko::World::SG_CHANGE::pStateSet
osgText::Text* vrecko::World::SG_CHANGE::pText
std::string vrecko::World::SG_CHANGE::text_string
SG_OPERATION_TYPE vrecko::World::SG_CHANGE::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vrecko/World.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CABUTTONEVENT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CABUTTONEVENT
Public Attributes | List of all members
vrecko::CABUTTONEVENT Struct Reference

#include <ControllableAbility.h>

Public Attributes

unsigned long | dwSize
int | iPointerID
int | iButtonID
bool | bState

Member Data Documentation

bool vrecko::CABUTTONEVENT::bState
unsigned long vrecko::CABUTTONEVENT::dwSize
int vrecko::CABUTTONEVENT::iButtonID
int vrecko::CABUTTONEVENT::iPointerID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MessageCAButtonEvent Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageCAButtonEvent
Public Member Functions | Public Attributes | List of all members
vrecko::MessageCAButtonEvent Class Reference

#include <ControllableAbility.h>

Inheritance diagram for vrecko::MessageCAButtonEvent:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

CABUTTONEVENT data

Member Function Documentation

virtual const char* vrecko::MessageCAButtonEvent::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

CABUTTONEVENT vrecko::MessageCAButtonEvent::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CAINFO__VER1 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CAINFO__VER1
Public Types | Public Attributes | List of all members
vrecko::CAINFO__VER1 Struct Reference

#include <ControllableAbility.h>

Inheritance diagram for vrecko::CAINFO__VER1:
vrecko::CAINFO__VER2

Public Types

enum CAType { Unknown = 0, SimpleVREdit = 1, AbilityMapper = 2, DummyCATypeToDWORD = 0xFFFFFFFF }

Public Attributes

unsigned long | dwSize
CAType type
unsigned long | dwFlags

Member Enumeration Documentation

enum vrecko::CAINFO__VER1::CAType

Type of the ability.

Enumerator
Unknown | Unknown type, something completely new.
SimpleVREdit | Simple editing ability. What does it mean to the ability programmer? Basically you need only to implement activate() / deactivate() and possibly update() (and fillDefaultInfo(), of course). Everything else is done automatically, you ability activate() function will be called when the user presses a button and the deactivate() will be called when the same button will be released. You may disable the automatic ability deactivation upon mouse release by including the CAINFO_FLAGS_NO_AUTO_DEACTIVATE flag in [dwFlags]. What does it mean to the controlling ability? Issue the "ActivePointerID" requests upon mouse button press and release. If CAINFO_FLAGS_NO_AUTO_DEACTIVATE is specified in [dwFlags] then do not issue the release request.
AbilityMapper | An ability to map other abilities to finger presses. Requires some additional communication with the EditorController. There will be probably only one ability of such type.
DummyCATypeToDWORD | Just to have this enum sized to 4 bytes.

Member Data Documentation

unsigned long vrecko::CAINFO__VER1::dwFlags

Flags. A combination of CAINFO_FLAGS_* constants.

unsigned long vrecko::CAINFO__VER1::dwSize

Size of the structure.

CAType vrecko::CAINFO__VER1::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::CAINFO__VER2 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CAINFO__VER2
Public Attributes | List of all members
vrecko::CAINFO__VER2 Struct Reference

#include <ControllableAbility.h>

Inheritance diagram for vrecko::CAINFO__VER2:
vrecko::CAINFO__VER1

Public Attributes

unsigned long | dwActiveFlags
- Public Attributes inherited from vrecko::CAINFO__VER1
unsigned long | dwSize
CAType type
unsigned long | dwFlags

Additional Inherited Members

- Public Types inherited from vrecko::CAINFO__VER1
enum CAType { Unknown = 0, SimpleVREdit = 1, AbilityMapper = 2, DummyCATypeToDWORD = 0xFFFFFFFF }

Member Data Documentation

unsigned long vrecko::CAINFO__VER2::dwActiveFlags

A flags that may be different every time the CAINFO structure is filled. (i.e. different every frame or even more often) A combination of CAINFO_AFLAGS_* constants.

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ControllableAbility Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ControllableAbility
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::ControllableAbility Class Referenceabstract

#include <ControllableAbility.h>

Inheritance diagram for vrecko::ControllableAbility:
vrecko::Ability vrecko::BaseClass AP_CableEditor::CableEditor APCameraMovement::CameraMovementEditor APCameraPath::Camera APConnectEditor::ConnectEditor APConnectEditor::Cut APConnectEditor::Optimalizer APConnectEditor::PolygonState APConnectEditor::Rotation APConnectEditor::Scale APConstrainedMovement::ConstrainedObjectMovement APEditorController::AbilityMapper APEditorQAbilities::AbilityEditor APEditorQAbilities::AnimatorEditor APEditorQAbilities::AvatarMovement APEditorQAbilities::ObjectAdd APEditorQAbilities::ObjectDelete APEditorQAbilities::ObjectMovement APEditorQAbilities::SceneSave APEditorQAbilities::SimpleObjectMovement APEditorQAbilities::UseTrigger APFFDEditor::EditorLogic APLightsEditor::Editor APRoomEdit::RoomEditor

Classes

class MessageCAINFO

Public Member Functions

ControllableAbility (const char *abilityName)
virtual | ~ControllableAbility ()
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
virtual void | update ()
virtual bool | isActive ()
It shouldn't be necessary to override this function. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

virtual void | createInterface ()
virtual void | destroyInterface ()
virtual void | processButtonPress (CABUTTONEVENT *eventData)
virtual void | processButtonRelease (CABUTTONEVENT *eventData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
virtual bool | activate ()
virtual void | deactivate ()
virtual CAINFO * | createInfo ()
virtual void | fillDefaultInfo ()=0
bool | requestPointerLoc (bool bCancelIfNotActive=true)
bool | requestPointerLocRaw (bool bCancelIfNotActive=true)
bool | requestSelectionID (bool bCancelIfNotActive=true)
bool | requestSelectionPath (bool bCancelIfNotActive=true)
bool | isMenuCreated ()
bool | isMenuVisible ()
virtual bool | createMenu (const char *menuString, bool bForceCreate=true)
virtual void | destroyMenu ()
virtual bool | showMenu ()
virtual bool | hideMenu ()
virtual void | processMenuButtonPress (CABUTTONEVENT *eventData)
virtual void | processMenuButtonRelease (CABUTTONEVENT *eventData)
virtual void | menuItemClicked (const char *itemID)
virtual void | menuSliderChanged (const char *sliderID, float sliderPos)
DECLARE_INPUT (ButtonStateChange, MessageCAButtonEvent)
DECLARE_INPUT (Menu_Clicked, MessageString)
DECLARE_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt)
DECLARE_REQUEST_INPUT (GetInfo, MessageVoid, MessageCAINFO)
DECLARE_REQUEST_OUTPUT (PointerPos, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRot, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (PointerPosRaw, MessageInt, MessageVec3)
DECLARE_REQUEST_OUTPUT (PointerRotRaw, MessageInt, MessageQuat)
DECLARE_REQUEST_OUTPUT (SelectionID, MessageInt, MessageObjectID)
DECLARE_REQUEST_OUTPUT (SelectionPath, MessageInt, MessageNodeList)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

EnvironmentObject * owner
The owner object. More...
int | activePointerID
Active pointer ID or 0 if not active. More...
int | lastEventButtonID
ID of a button that was received in the last button press/release event. More...
osg::Vec3 | actPointerPos
osg::Vec3 | actPointerPosRaw
osg::Quat | actPointerRot
osg::Quat | actPointerRotRaw
unsigned long | actSelectedObjectID
std::vector< osg::Node * > * | actSelectedPath
int | actPosInPath
CAINFO defaultInfo
Ability * menu
bool | bMenuVisible
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

EDITORCONTROLLER_IMP_EXP vrecko::ControllableAbility::ControllableAbility ( const char * abilityName )
EDITORCONTROLLER_IMP_EXP vrecko::ControllableAbility::~ControllableAbility ( )
virtual

Member Function Documentation

virtual bool vrecko::ControllableAbility::activate ( )
inlineprotectedvirtual

Called when the ability is about to be activated. Returns true if the ability is activated or false otherwise (so the activation will be cancelled). CAN/SHOULD be overriden to activate the ability properly, but should call the ancestor method and return "false" if the ancestor returned false too.

Reimplemented in APCameraPath::Camera, AP_CableEditor::CableEditor, APLightsEditor::Editor, APRoomEdit::RoomEditor, APConnectEditor::ConnectEditor, APEditorController::AbilityMapper, APCameraMovement::CameraMovementEditor, APEditorQAbilities::AbilityEditor, APConstrainedMovement::ConstrainedObjectMovement, APEditorQAbilities::ObjectMovement, APConnectEditor::Optimalizer, APFFDEditor::EditorLogic, APConnectEditor::Cut, APConnectEditor::Rotation, APEditorQAbilities::AvatarMovement, APEditorQAbilities::SimpleObjectMovement, APConnectEditor::Scale, APEditorQAbilities::AnimatorEditor, APEditorQAbilities::UseTrigger, APConnectEditor::PolygonState, APEditorQAbilities::ObjectAdd, APEditorQAbilities::ObjectDelete, and APEditorQAbilities::SceneSave.

EDITORCONTROLLER_IMP_EXP CAINFO * vrecko::ControllableAbility::createInfo ( )
protectedvirtual
        This method creates a new instance of the CAINFO structure and copies data
        from the [defaltInfo] structure. Additionally, it may change
        some of the parameters of the new structure (especially [dwActiveFlags]).

        CAN be overridden although it is unnecessary in most cases.
        The overridden method should look like this:

        You have complete control over the structure, but some field have
        been already pre-filled: Especially size and some the [dwActiveFlags].
        The [dwActiveFlags] has been changed according to the current state of the ability
        (is Menu displayed -> prefer not to show the selections etc.)
        You can still change any of the attributes.

        CAINFO* info = ControllableAbility::createInfo();
        if (!info)
            return NULL;

Now adjust the members of the structure. Note: If adjusting for example info->dwActiveFlags for selection visibility, ... // you have to use the mask. For example, to set the visibility to _ACTPTR_FORCESHOW: info->dwActiveFlags = CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW | (info->dwActiveFlags & ~CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK);

        return info;

Reimplemented in APConstrainedMovement::ConstrainedObjectMovement, and APEditorQAbilities::ObjectMovement.

EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::createInterface ( )
protectedvirtual

Method for creating the input/outputs/requests. If overridden, it has to call the ancestor method. This is the method to override, if you need to add any other inputs/outputs etc. Then you also have to override the destroyInterface() to destroy these connections. Please see notes about destroyInterface() to use it properly (!)

Reimplemented in APEditorController::AbilityMapper.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::createMenu | ( | const char * | menuString,
 |  | bool | bForceCreate = true
 | ) |  |
protectedvirtual

If [bForceCreate] is "false", then the menu is NOT created if it was already created before.

EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::deactivate ( )
protectedvirtual

Called when the ability is about to be deactivated. CAN be overridden to unlock used objects etc., but should call the ancestor method. You may wan to call isActive() in the overriden method to check whether the ability is really being deactivated.

Reimplemented in APCameraPath::Camera, AP_CableEditor::CableEditor, APLightsEditor::Editor, APRoomEdit::RoomEditor, APConnectEditor::ConnectEditor, APCameraMovement::CameraMovementEditor, APEditorQAbilities::AbilityEditor, APConstrainedMovement::ConstrainedObjectMovement, APEditorQAbilities::ObjectMovement, APConnectEditor::Optimalizer, APConnectEditor::Cut, APConnectEditor::Rotation, APEditorQAbilities::AvatarMovement, APEditorQAbilities::SimpleObjectMovement, APConnectEditor::Scale, and APEditorQAbilities::UseTrigger.

vrecko::ControllableAbility::DECLARE_INPUT | ( | ButtonStateChange | ,
 |  | MessageCAButtonEvent |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_INPUT | ( | Menu_Clicked | ,
 |  | MessageString |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_INPUT | ( | ActivePointerID | ,
 |  | MessageInt | ,
 |  | MessageInt |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_INPUT | ( | GetInfo | ,
 |  | MessageVoid | ,
 |  | MessageCAINFO |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | PointerPos | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | PointerRot | ,
 |  | MessageInt | ,
 |  | MessageQuat |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | PointerPosRaw | ,
 |  | MessageInt | ,
 |  | MessageVec3 |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | PointerRotRaw | ,
 |  | MessageInt | ,
 |  | MessageQuat |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | SelectionID | ,
 |  | MessageInt | ,
 |  | MessageObjectID |
 | ) |  |
protected
vrecko::ControllableAbility::DECLARE_REQUEST_OUTPUT | ( | SelectionPath | ,
 |  | MessageInt | ,
 |  | MessageNodeList |
 | ) |  |
protected
EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::destroyInterface ( )
protectedvirtual

Destroys the inputs/outputs/requests. If you override it, you have to:

  • call the ancestor method in you new method.
  • (!) call the destroyInterface in your destructor (this is necessary because of some virtual table problems in C++)
EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::destroyMenu ( )
protectedvirtual
virtual void vrecko::ControllableAbility::fillDefaultInfo ( )
protectedpure virtual

MUST be overridden. The overridden method have to fill in the [defaultInfo]. The structure is already filled by zeroes and the size is set correctly, so you need to only change what is necessary. The [defaultInfo] is used as a base information that will be used in createInfo() method. The createInfo() may adjust some of the parameters and you can adjust it even further by overriding createInfo().

Implemented in APCameraPath::Camera, AP_CableEditor::CableEditor, APLightsEditor::Editor, APRoomEdit::RoomEditor, APConnectEditor::ConnectEditor, APEditorController::AbilityMapper, APCameraMovement::CameraMovementEditor, APEditorQAbilities::AbilityEditor, APConstrainedMovement::ConstrainedObjectMovement, APEditorQAbilities::ObjectMovement, APConnectEditor::Optimalizer, APFFDEditor::EditorLogic, APConnectEditor::Cut, APConnectEditor::Rotation, APEditorQAbilities::AvatarMovement, APEditorQAbilities::SimpleObjectMovement, APConnectEditor::Scale, APEditorQAbilities::AnimatorEditor, APEditorQAbilities::UseTrigger, APConnectEditor::PolygonState, APEditorQAbilities::ObjectAdd, APEditorQAbilities::ObjectDelete, and APEditorQAbilities::SceneSave.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::hideMenu ( )
protectedvirtual
EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Called as the first initialization method COULD be overridden, but it HAS TO CALL the method from the ancestor class. But BETTER SOLUTION is to override the createInterface() and destroyInterface() functions instead.

Reimplemented from vrecko::BaseClass.

Reimplemented in AP_CableEditor::CableEditor, APLightsEditor::Editor, APCameraPath::Camera, APRoomEdit::RoomEditor, APEditorQAbilities::ObjectMovement, and APEditorQAbilities::AbilityEditor.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::isActive ( )
virtual

It shouldn't be necessary to override this function.

bool vrecko::ControllableAbility::isMenuCreated ( )
inlineprotected
EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::isMenuVisible ( )
protected

This method may issue a request to detect the current state of the menu.

virtual void vrecko::ControllableAbility::menuItemClicked ( const char * itemID )
inlineprotectedvirtual

This method should be overridden for the menu to work. The [itemID] could be NULL in case the user hasn't clicked on any item. (It is expected that the menu will disappear.) If [itemID] is a valid pointer, it will contain the name (not caption) of the item clicked.

Reimplemented in APCameraPath::Camera, AP_CableEditor::CableEditor, APLightsEditor::Editor, APCameraMovement::CameraMovementEditor, APEditorController::AbilityMapper, APEditorQAbilities::AbilityEditor, APConnectEditor::Cut, APFFDEditor::EditorLogic, APEditorQAbilities::AnimatorEditor, APConnectEditor::PolygonState, APEditorQAbilities::ObjectAdd, APEditorQAbilities::ObjectDelete, and APEditorQAbilities::SceneSave.

virtual void vrecko::ControllableAbility::menuSliderChanged | ( | const char * | sliderID,
 |  | float | sliderPos
 | ) |  |
inlineprotectedvirtual

You should override this method if there is any slider in your menu.

Reimplemented in AP_CableEditor::CableEditor, APLightsEditor::Editor, and APFFDEditor::EditorLogic.

virtual void vrecko::ControllableAbility::processButtonPress ( CABUTTONEVENT * eventData )
inlineprotectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been pressed). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented in APRoomEdit::RoomEditor, and APConstrainedMovement::ConstrainedObjectMovement.

virtual void vrecko::ControllableAbility::processButtonRelease ( CABUTTONEVENT * eventData )
inlineprotectedvirtual

This function must be able to handle also cases when [eventData] == NULL (which means the "standard button" has been released). SHOULD be overridden if any button functionality is required. If the menu is visible, this method won't be executed.

Reimplemented in AP_CableEditor::CableEditor, APRoomEdit::RoomEditor, APConnectEditor::ConnectEditor, APEditorQAbilities::AbilityEditor, APConstrainedMovement::ConstrainedObjectMovement, and APConnectEditor::Optimalizer.

EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::processMenuButtonPress ( CABUTTONEVENT * eventData )
protectedvirtual

Sending the button press to the menu ability. Descendants should not need to override this function.

EDITORCONTROLLER_IMP_EXP void vrecko::ControllableAbility::processMenuButtonRelease ( CABUTTONEVENT * eventData )
protectedvirtual

Sending the button release to the menu ability. Descendants should not need to override this function.

EDITORCONTROLLER_IMP_EXP int vrecko::ControllableAbility::processNotification | ( | BaseClass * | sender,
 |  | unsigned long | notificationType,
 |  | void * | notificationData
 | ) |  |
protectedvirtual

Processes any notification. If you ever override this method, you MUST call the overridden one (this one).

Reimplemented from vrecko::BaseClass.

Reimplemented in AP_CableEditor::CableEditor.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::requestPointerLoc ( bool bCancelIfNotActive = true )
protected

Requests the "real" pointer position and orientation and stores it in [actPointerPos] and [actPointerRot] member variables. Works only when CAINFO_FLAGS_POINTERLOC_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::requestPointerLocRaw ( bool bCancelIfNotActive = true )
protected

Requests the "raw" pointer position and orientation and stores it in [actPointerPosRaw] and [actPointerRotRaw] member variables. Works only when CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::requestSelectionID ( bool bCancelIfNotActive = true )
protected

Requests the current SELECTION (ONLY) of the active pointer and stores it in [actSelectedObjectID] member variable. Returns "true" if the request finished successfully (doesn't imply that something is selected!). Works only when CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT is specified in CAINFO::dwFlags in GetInfo() function.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::requestSelectionPath ( bool bCancelIfNotActive = true )
protected

Requests the current SELECTION AND selection PATH of the active pointer and stores it in [actSelectedObjectID] + [actSelectedPath] + [actPosInPath] member variables. Returns "true" if the request finished successfully (doesn't imply that something is selected!). Works only when CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT is specified in CAINFO::dwFlags in GetInfo() function.

EDITORCONTROLLER_IMP_EXP bool vrecko::ControllableAbility::showMenu ( )
protectedvirtual
virtual void vrecko::ControllableAbility::update ( void )
inlinevirtual

Called by the VRECKO scheduler at the specified frequency. CAN be overridden, but it HAS TO CALL the method from the ancestor class. (For future updates)

Reimplemented from vrecko::BaseClass.

Reimplemented in APLightsEditor::Editor, APCameraPath::Camera, AP_CableEditor::CableEditor, APRoomEdit::RoomEditor, APCameraMovement::CameraMovementEditor, APConstrainedMovement::ConstrainedObjectMovement, APEditorQAbilities::ObjectMovement, APConnectEditor::Cut, APEditorQAbilities::AvatarMovement, APEditorQAbilities::SimpleObjectMovement, APFFDEditor::EditorLogic, APConnectEditor::Rotation, and APConnectEditor::Scale.

Member Data Documentation

int vrecko::ControllableAbility::activePointerID
protected

Active pointer ID or 0 if not active.

osg::Vec3 vrecko::ControllableAbility::actPointerPos
protected

"Real" pointer position (including view transformation) as received from [POINTERPOS_REQUEST_NAME] request output.

NOTE: You have to call requestPointerLoc() method to update this member variable (it is not updated automatically). Works only when CAINFO_FLAGS_POINTERLOC_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

osg::Vec3 vrecko::ControllableAbility::actPointerPosRaw
protected

"Raw" pointer position (not including the view transformation) as received from [POINTERPOS_RAW_REQUEST_NAME] request output.

NOTE: You have to call requestPointerLocRaw() method to update this member variable (it is not updated automatically).

Works only when CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

osg::Quat vrecko::ControllableAbility::actPointerRot
protected

"Real" pointer rotation (including the view transformation) as received from [POINTERROT_REQUEST_NAME] request output.

NOTE: You have to call requestPointerLoc() method to update this member variable (it is not updated automatically).

Works only when CAINFO_FLAGS_POINTERLOC_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

osg::Quat vrecko::ControllableAbility::actPointerRotRaw
protected

"Raw" pointer rotation (not including the view transformation) as received from [POINTERROT_RAW_REQUEST_NAME] request output. Works only when CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUPUTS is specified in CAINFO::dwFlags in GetInfo() function.

int vrecko::ControllableAbility::actPosInPath
protected

The position of the selected object in the path. Can be -1 if not applicable. The variable is also set in requestSelectionPath() method.

unsigned long vrecko::ControllableAbility::actSelectedObjectID
protected

Selected object is received from [SELECTIONID_REQUEST_NAME] request output. This variable is updated every time requestSelectionID() or requestSelectionPath() methods are called. Works only when CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT is specified in CAINFO::dwFlags in GetInfo() method.

std::vector<osg::Node*>* vrecko::ControllableAbility::actSelectedPath
protected

Path to the selected object from the root of the scene (first in the vector). This variable is updated by requestSelectionPath() method, which requires CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT to be specified in CAINFO::dwFlags in GetInfo() method.

IMPORTANT NOTE: The final Node on the path is the real section (some Geometry etc.) and it doesn't need to be the EnvironmentObject. The usual path is something like this: Root -> ... EOs/Transforms/other Nodes ... -> selected EO -> ... something else, but no other EOs

bool vrecko::ControllableAbility::bMenuVisible
protected
CAINFO vrecko::ControllableAbility::defaultInfo
protected
int vrecko::ControllableAbility::lastEventButtonID
protected

ID of a button that was received in the last button press/release event.

Ability* vrecko::ControllableAbility::menu
protected

To get the menu selection the menuItemClicked() method should be overriden.

EnvironmentObject* vrecko::ControllableAbility::owner
protected

The owner object.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/ControllableAbility.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::ControllableAbility::MessageCAINFO Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ControllableAbility
  • MessageCAINFO
Public Member Functions | Public Attributes | List of all members
vrecko::ControllableAbility::MessageCAINFO Class Reference

#include <ControllableAbility.h>

Inheritance diagram for vrecko::ControllableAbility::MessageCAINFO:
vrecko::VreckoMessage

Public Member Functions

virtual const char * | getMessageId ()
- Public Member Functions inherited from vrecko::VreckoMessage
VreckoMessage ()
virtual | ~VreckoMessage ()
virtual bool | setValueFromString (const char *valueAsString)
virtual bool | isEqualTo (VreckoMessage *otherMsg)

Public Attributes

CAINFO data

Member Function Documentation

virtual const char* vrecko::ControllableAbility::MessageCAINFO::getMessageId ( )
inlinevirtual

Should be overridden to return the name of new class.

Reimplemented from vrecko::VreckoMessage.

Member Data Documentation

CAINFO vrecko::ControllableAbility::MessageCAINFO::data
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::logger_streambuf Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • logger_streambuf
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vrecko::logger_streambuf Class Reference
Inheritance diagram for vrecko::logger_streambuf:

Public Member Functions

logger_streambuf (Logger *loggerPtr, bool forErrors)

Protected Member Functions

virtual int overflow (int c=EOF)

Protected Attributes

std::string pendingLine

Constructor & Destructor Documentation

vrecko::logger_streambuf::logger_streambuf | ( | Logger * | loggerPtr,
 |  | bool | forErrors
 | ) |  |
inline

Member Function Documentation

virtual int vrecko::logger_streambuf::overflow ( int c = EOF )
inlineprotectedvirtual

Member Data Documentation

std::string vrecko::logger_streambuf::pendingLine
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Logger.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vrecko::MaterialDesc Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MaterialDesc
Public Member Functions | List of all members
vrecko::MaterialDesc Class Reference

#include <MaterialDesc.h>

Public Member Functions

NxMaterialIndex | MatIndex () const
std::string | Name () const
void | Create (NxScene *pScene)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)

Member Function Documentation

void vrecko::MaterialDesc::Create ( NxScene * pScene )
bool vrecko::MaterialDesc::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )
NxMaterialIndex vrecko::MaterialDesc::MatIndex ( ) const
inline
std::string vrecko::MaterialDesc::Name ( ) const
inline
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialDesc.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialDesc.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::A3DBird Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • A3DBird
Public Member Functions | List of all members
vreckoDP_base::A3DBird Class Reference

#include <A3DBird.h>

Inheritance diagram for vreckoDP_base::A3DBird:
vrecko::Device vrecko::BaseClass

Public Member Functions

A3DBird (char *port)
~A3DBird ()
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | openDevice (void)=0
Opens device and performs the initialization routines. More...
virtual int | closeDevice (void)=0
Closes device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
virtual void | update (void)=0
Updates the device - scan device and send required outputs. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...

Constructor & Destructor Documentation

A3DBird::A3DBird ( char * port )
A3DBird::~A3DBird ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/A3DBird.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/A3DBird.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::fdtDataGlove Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • fdtDataGlove
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::fdtDataGlove Class Reference

#include <fdtDataGlove.h>

Inheritance diagram for vreckoDP_base::fdtDataGlove:
vrecko::Device vrecko::BaseClass

Public Member Functions

fdtDataGlove ()
fdtDataGlove (char *port)
~fdtDataGlove ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
int | calibrateDevice (void)
Device calibration. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
int * | getSignal (void)
int | getActualValue (float *p_actual_value)
void | freezeRotation (bool new_freezeR)
void | freezeFingerSensor (int id_FS, bool new_freezeFS)
int | getFingerDirection (int id_finger, float *p_finger_direction)
int | getRotate (float *p_rotate)
void | setSignalType (int _signal_id, int _type)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int scanDevice (void)

Protected Attributes

char * | hand_type
int | num_sensors
bool | freeze_rotation
bool | freeze_finger_sensor [1+18]
float | finger_direction [5][6]
float * | actual_sensor_values
std::map< int, int > | _signal_type_table
int | _last_signal
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

fdtDataGlove::fdtDataGlove ( )
fdtDataGlove::fdtDataGlove ( char * port )
fdtDataGlove::~fdtDataGlove ( )

Member Function Documentation

int fdtDataGlove::calibrateDevice ( void )
virtual

Device calibration.

Reimplemented from vrecko::Device.

int fdtDataGlove::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

void fdtDataGlove::freezeFingerSensor | ( | int | id_FS,
 |  | bool | new_freezeFS
 | ) |  |
void fdtDataGlove::freezeRotation ( bool new_freezeR )
inline
int fdtDataGlove::getActualValue ( float * p_actual_value )
int fdtDataGlove::getFingerDirection | ( | int | id_finger,
 |  | float * | p_finger_direction
 | ) |  |
int fdtDataGlove::getRotate ( float * p_rotate )
int * fdtDataGlove::getSignal ( void )
int fdtDataGlove::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

int fdtDataGlove::scanDevice ( void )
protected
void vreckoDP_base::fdtDataGlove::setSignalType | ( | int | _signal_id,
 |  | int | _type
 | ) |  |
inline
void vreckoDP_base::fdtDataGlove::update ( void )
inlinevirtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

int vreckoDP_base::fdtDataGlove::_last_signal
protected
std::map<int, int> vreckoDP_base::fdtDataGlove::_signal_type_table
protected
float* vreckoDP_base::fdtDataGlove::actual_sensor_values
protected
float vreckoDP_base::fdtDataGlove::finger_direction[5][6]
protected
bool vreckoDP_base::fdtDataGlove::freeze_finger_sensor[1+18]
protected
bool vreckoDP_base::fdtDataGlove::freeze_rotation
protected
char* vreckoDP_base::fdtDataGlove::hand_type
protected
int vreckoDP_base::fdtDataGlove::num_sensors
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fdtDataGlove.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/fdtDataGlove.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::dataT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • dataT
Public Attributes | List of all members
vreckoDP_base::dataT Struct Reference

#include <fsPinchGlove.h>

Public Attributes

int(* | callback )(void *)
void * | data

Member Data Documentation

int(* vreckoDP_base::dataT::callback)(void *)
void* vreckoDP_base::dataT::data
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fsPinchGlove.h
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::fsPinchGlove Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • fsPinchGlove
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::fsPinchGlove Class Reference

#include <fsPinchGlove.h>

Inheritance diagram for vreckoDP_base::fsPinchGlove:
vrecko::Device vrecko::BaseClass

Public Member Functions

fsPinchGlove ()
fsPinchGlove (const char *port_name)
~fsPinchGlove ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
int | initPort (char *port)
int * | getGesture (void)
void | setGestureFunc (int(*func)(void *), void *g_object, int t1, int t2=0, int t3=0, int t4=0, int t5=0)
int | activateGesture (int t1, int t2=0, int t3=0, int t4=0, int t5=0)
int | deactivateGesture (int t1, int t2=0, int t3=0, int t4=0, int t5=0)
int | checkGesture (void)
int | disableTS (void)
int | enableTS (void)
void | setReleaseFunc (int(*func)(void *), void *data)
void | printConf (void)
void | printGests (void)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | checkBox (void)
void | pgd_close (void)
int | getByte (char *buf)
int | getPacket (char *buf)
int | pgdRead (char *buf, int n)
int | pgdComm (const char buf[2], char *reply)
int | getData (char *buf, int len, int *time_st)
int | checkConnection (void)
void | printBuf (const char *buf, int length)
void | delay (int msec)

Protected Attributes

int | port_fd
bool | gestureOn
std::map< std::string, dataT * > | callbacks
std::map< std::string, int > | _signal_transf_table
std::map< std::string, int > | _signal_type_table
int | _current_type
int | _signal_backup
dataT relCall
char | bufx [2 *PGI_MAX_PACKET_LEN]
char | bufxe [5][3]
std::map< std::string, int > | _active_contact
int | _contact_count
float | ticks
int(* | relFunc )(void)
int | _signal [10]
int | _signal_count
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

fsPinchGlove::fsPinchGlove ( )
fsPinchGlove::fsPinchGlove ( const char * port_name )
fsPinchGlove::~fsPinchGlove ( )

Member Function Documentation

int vreckoDP_base::fsPinchGlove::activateGesture | ( | int | t1,
 |  | int | t2 = 0,
 |  | int | t3 = 0,
 |  | int | t4 = 0,
 |  | int | t5 = 0
 | ) |  |
int vreckoDP_base::fsPinchGlove::checkBox ( void )
protected
int fsPinchGlove::checkConnection ( void )
protected
int fsPinchGlove::checkGesture ( void )
int fsPinchGlove::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

int vreckoDP_base::fsPinchGlove::deactivateGesture | ( | int | t1,
 |  | int | t2 = 0,
 |  | int | t3 = 0,
 |  | int | t4 = 0,
 |  | int | t5 = 0
 | ) |  |
void fsPinchGlove::delay ( int msec )
protected
int fsPinchGlove::disableTS ( void )
int fsPinchGlove::enableTS ( void )
int fsPinchGlove::getByte ( char * buf )
protected
int fsPinchGlove::getData | ( | char * | buf,
 |  | int | len,
 |  | int * | time_st
 | ) |  |
protected
int* vreckoDP_base::fsPinchGlove::getGesture ( void )
int fsPinchGlove::getPacket ( char * buf )
protected
int fsPinchGlove::initPort ( char * port )
int fsPinchGlove::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

void vreckoDP_base::fsPinchGlove::pgd_close ( void )
protected
int fsPinchGlove::pgdComm | ( | const char | buf[2],
 |  | char * | reply
 | ) |  |
protected
int fsPinchGlove::pgdRead | ( | char * | buf,
 |  | int | n
 | ) |  |
protected
void fsPinchGlove::printBuf | ( | const char * | buf,
 |  | int | length
 | ) |  |
protected
void fsPinchGlove::printConf ( void )
void fsPinchGlove::printGests ( void )
void fsPinchGlove::setGestureFunc | ( | int(*)(void *) | func,
 |  | void * | g_object,
 |  | int | t1,
 |  | int | t2 = 0,
 |  | int | t3 = 0,
 |  | int | t4 = 0,
 |  | int | t5 = 0
 | ) |  |
void fsPinchGlove::setReleaseFunc | ( | int(*)(void *) | func,
 |  | void * | data
 | ) |  |
void fsPinchGlove::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

std::map<std::string, int> vreckoDP_base::fsPinchGlove::_active_contact
protected
int vreckoDP_base::fsPinchGlove::_contact_count
protected
int vreckoDP_base::fsPinchGlove::_current_type
protected
int vreckoDP_base::fsPinchGlove::_signal[10]
protected
int vreckoDP_base::fsPinchGlove::_signal_backup
protected
int vreckoDP_base::fsPinchGlove::_signal_count
protected
std::map<std::string, int> vreckoDP_base::fsPinchGlove::_signal_transf_table
protected
std::map<std::string, int> vreckoDP_base::fsPinchGlove::_signal_type_table
protected
char vreckoDP_base::fsPinchGlove::bufx[2 *PGI_MAX_PACKET_LEN]
protected
char vreckoDP_base::fsPinchGlove::bufxe[5][3]
protected
std::map<std::string, dataT*> vreckoDP_base::fsPinchGlove::callbacks
protected
bool vreckoDP_base::fsPinchGlove::gestureOn
protected
int vreckoDP_base::fsPinchGlove::port_fd
protected
dataT vreckoDP_base::fsPinchGlove::relCall
protected
int(* vreckoDP_base::fsPinchGlove::relFunc)(void)
protected
float vreckoDP_base::fsPinchGlove::ticks
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fsPinchGlove.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/fsPinchGlove.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::KeyboardMouse Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • KeyboardMouse
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::KeyboardMouse Class Reference

#include <KeyboardMouse.h>

Inheritance diagram for vreckoDP_base::KeyboardMouse:
vrecko::Device vrecko::BaseClass

Public Member Functions

KeyboardMouse ()
~KeyboardMouse ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
int | calibrateDevice (void)
Device calibration. More...
bool | isKeyDown (int keyCode)
void | update (void)
Updates the device - scan device and send required outputs. More...
virtual bool | handle (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &)
virtual void | accept (osgGA::GUIEventHandlerVisitor &v)
void | mouseScroll (osgGA::GUIEventAdapter::ScrollingMotion)
void | mouseMotion (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa)
void | passiveMouseMotion (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my)
void | buttonPress (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb)
void | doubleButtonPress (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb)
void | buttonRelease (const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb)
void | keyPress (int)
void | keyRelease (int)
void | specialKeyPress (int)
void | specialKeyRelease (int)
void | shutdown ()
bool | idle ()
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

bool | sendMousePosIfReady ()
bool | keyToString (int key, std::string *str)
DECLARE_OUTPUT (Key, MessageString)
DECLARE_OUTPUT (MousePosition, MessageVec2)
DECLARE_OUTPUT (MouseButton, MessageString)
DECLARE_OUTPUT (MouseDoubleButton, MessageString)
DECLARE_OUTPUT (MouseScroll, MessageString)

Protected Attributes

unsigned int | mouse_button
osg::Vec2 | mouse_position
std::map< int, osg::Timer_t > | autorepeat_map
std::map< int, bool > | keydown_map
osg::Timer | timer
bool | new_mouse_pos_ready
int | mouseUpdateCounter
EventDispatcher * pEventDispatcher
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Detailed Description

Class KeyboardMouse serves for processing the keyboard and mouse actions.

Constructor & Destructor Documentation

KeyboardMouse::KeyboardMouse ( )
KeyboardMouse::~KeyboardMouse ( )

Member Function Documentation

virtual void vreckoDP_base::KeyboardMouse::accept ( osgGA::GUIEventHandlerVisitor & v )
inlinevirtual
void KeyboardMouse::buttonPress | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa,
 |  | float | mx,
 |  | float | my,
 |  | unsigned int | mb
 | ) |  |
void KeyboardMouse::buttonRelease | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa,
 |  | float | mx,
 |  | float | my,
 |  | unsigned int | mb
 | ) |  |
int vreckoDP_base::KeyboardMouse::calibrateDevice ( void )
inlinevirtual

Device calibration.

Reimplemented from vrecko::Device.

int KeyboardMouse::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::KeyboardMouse::DECLARE_OUTPUT | ( | Key | ,
 |  | MessageString |
 | ) |  |
protected
vreckoDP_base::KeyboardMouse::DECLARE_OUTPUT | ( | MousePosition | ,
 |  | MessageVec2 |
 | ) |  |
protected
vreckoDP_base::KeyboardMouse::DECLARE_OUTPUT | ( | MouseButton | ,
 |  | MessageString |
 | ) |  |
protected
vreckoDP_base::KeyboardMouse::DECLARE_OUTPUT | ( | MouseDoubleButton | ,
 |  | MessageString |
 | ) |  |
protected
vreckoDP_base::KeyboardMouse::DECLARE_OUTPUT | ( | MouseScroll | ,
 |  | MessageString |
 | ) |  |
protected
void KeyboardMouse::doubleButtonPress | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa,
 |  | float | mx,
 |  | float | my,
 |  | unsigned int | mb
 | ) |  |
bool KeyboardMouse::handle | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa
 | ) |  |
virtual
bool vreckoDP_base::KeyboardMouse::idle ( )
inline
bool vreckoDP_base::KeyboardMouse::isKeyDown ( int keyCode )
inline
void KeyboardMouse::keyPress ( int key )
void KeyboardMouse::keyRelease ( int key )
bool KeyboardMouse::keyToString | ( | int | key,
 |  | std::string * | str
 | ) |  |
protected
void KeyboardMouse::mouseMotion | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa
 | ) |  |
void KeyboardMouse::mouseScroll ( osgGA::GUIEventAdapter::ScrollingMotion )
int KeyboardMouse::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

void vreckoDP_base::KeyboardMouse::passiveMouseMotion | ( | const osgGA::GUIEventAdapter & | ea,
 |  | osgGA::GUIActionAdapter & | aa,
 |  | float | mx,
 |  | float | my
 | ) |  |
bool KeyboardMouse::sendMousePosIfReady ( )
protected
void vreckoDP_base::KeyboardMouse::shutdown ( )
inline
void KeyboardMouse::specialKeyPress ( int key )
void KeyboardMouse::specialKeyRelease ( int key )
void KeyboardMouse::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

std::map<int, osg::Timer_t> vreckoDP_base::KeyboardMouse::autorepeat_map
protected
std::map<int, bool> vreckoDP_base::KeyboardMouse::keydown_map
protected
unsigned int vreckoDP_base::KeyboardMouse::mouse_button
protected
osg::Vec2 vreckoDP_base::KeyboardMouse::mouse_position
protected
int vreckoDP_base::KeyboardMouse::mouseUpdateCounter
protected
bool vreckoDP_base::KeyboardMouse::new_mouse_pos_ready
protected
EventDispatcher* vreckoDP_base::KeyboardMouse::pEventDispatcher
protected
osg::Timer vreckoDP_base::KeyboardMouse::timer
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/KeyboardMouse.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/KeyboardMouse.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::L3DMouse Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • L3DMouse
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::L3DMouse Class Reference

#include <L3DMouse.h>

Inheritance diagram for vreckoDP_base::L3DMouse:
vreckoDP_base::LHeadTracker vrecko::Device vrecko::BaseClass

Public Member Functions

L3DMouse ()
L3DMouse (const char *port)
~L3DMouse ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | getLButton (void)
bool | getMButton (void)
bool | getRButton (void)
bool | getSButton (void)
- Public Member Functions inherited from vreckoDP_base::LHeadTracker
LHeadTracker ()
LHeadTracker (const char *port_name)
LHeadTracker (const char *port_name1, const char *port_name2)
~LHeadTracker ()
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
int | getRotate (float *p_rotate)
osg::Vec3 & | getRotate (void)
void | setRotationType (rotation_type _type)
osg::Vec3 & | getRotateA (void)
osg::Matrix & | getRotateM (void)
osg::Quat & | getRotateQ (void)
int | getTranslate (float *p_trans)
osg::Vec3 & | getTranslate (void)
void | printPos (void)
void | setInitialPosition (osg::Vec4 &_pos)
void | setInitialRotation (osg::Vec4 &_rot)
void | setInitialPosition (osg::Vec4 &_pos1, osg::Vec4 &_pos2)
void | setInitialRotation (osg::Vec4 &_rot1, osg::Vec4 &_rot2)
void | demandReport (void)
void | setBaseT (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | setBaseR (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | resetBase (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | setSlaveTransmitterType (unsigned char transmitter_type)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | scanDevice (void)
int | getRecData (long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet)
DECLARE_OUTPUT (Button_Left, vrecko::MessageBool)
DECLARE_OUTPUT (Button_Middle, vrecko::MessageBool)
DECLARE_OUTPUT (Button_Right, vrecko::MessageBool)
DECLARE_OUTPUT (Button_Suspend, vrecko::MessageBool)
DECLARE_OUTPUT (Button_Mouse_stand, vrecko::MessageBool)
- Protected Member Functions inherited from vreckoDP_base::LHeadTracker
int | scanDevice (void)
bool | openPort (const char *_pname, int *temp_port_fd)
bool | scanDeviceX (void)
int | diagnostic (void)
int | getRecData (long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet)
void | delay (int msec)
int | lhtRead (char *buf, int n)
void | reset (void)
int | singleReport (char *reply)
void | printBuffer (const char *buf, int length)
osg::Vec4 | getEuler (osg::Matrix &_mat)
osg::Vec4 | get_rel_pos (long int x, long int y, long int z)
bool | checkDiff (const long int &x, const long int &y, const long int &z, const long int &n_pi, const long int &n_ya, const long int &n_ro)
DECLARE_OUTPUT (Position, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation, vrecko::MessageQuat)

Protected Attributes

bool | left_button
bool | middle_button
bool | right_button
bool | suspend_button
bool | mouse_stand_button
char | button [5]
- Protected Attributes inherited from vreckoDP_base::LHeadTracker
int | port_fd
int | port_fd_dual
int | _port_fd
std::string | _port_name_dual
int | actual_p
bool | rec_out [2]
osg::Vec4 | pos [2]
osg::Vec4 | rot [2]
osg::Vec3 | ret_pos
osg::Vec3 | ret_rot
osg::Quat | rotq [2]
osg::Quat | rotq_diff [2]
rotation_type rot_type
osg::Matrix | ret_rotm
osg::Quat | ret_rotq
osg::Vec4 | base1
osg::Vec4 | base2
osg::Vec4 | base3
osg::Vec4 | origin
char | tx_buf [HTD_COMMAND_LEN]
char | rx_buf [2 *HTD_PACKET_LEN]
int | req_len
int | read_len
long int | absX [2]
long int | absY [2]
long int | absZ [2]
long int | absPI [2]
long int | absYA [2]
long int | absRO [2]
osg::Vec4 | pos_diff [2]
osg::Vec4 | rot_diff [2]
long int | last_absPI [2]
long int | last_absYA [2]
long int | last_absRO [2]
osg::Vec4 | last_rot [2]
osg::Matrix | tr_matrix
osg::Matrix | tr_matrix2
bool | first_report [2]
jmp_buf | tenv
osg::Vec3 | translate_mapping
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

L3DMouse::L3DMouse ( )
L3DMouse::L3DMouse ( const char * port )
L3DMouse::~L3DMouse ( )

Member Function Documentation

int L3DMouse::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::L3DMouse::DECLARE_OUTPUT | ( | Button_Left | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
vreckoDP_base::L3DMouse::DECLARE_OUTPUT | ( | Button_Middle | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
vreckoDP_base::L3DMouse::DECLARE_OUTPUT | ( | Button_Right | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
vreckoDP_base::L3DMouse::DECLARE_OUTPUT | ( | Button_Suspend | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
vreckoDP_base::L3DMouse::DECLARE_OUTPUT | ( | Button_Mouse_stand | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
bool vreckoDP_base::L3DMouse::getLButton ( void )
inline
bool vreckoDP_base::L3DMouse::getMButton ( void )
inline
bool vreckoDP_base::L3DMouse::getRButton ( void )
inline
int L3DMouse::getRecData | ( | long int * | x,
 |  | long int * | y,
 |  | long int * | z,
 |  | long int * | pi,
 |  | long int * | ya,
 |  | long int * | ro,
 |  | char * | packet
 | ) |  |
protected
bool vreckoDP_base::L3DMouse::getSButton ( void )
inline
bool L3DMouse::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int L3DMouse::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Reimplemented from vreckoDP_base::LHeadTracker.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * L3DMouse::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

int L3DMouse::scanDevice ( void )
protected
void L3DMouse::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

char vreckoDP_base::L3DMouse::button[5]
protected
bool vreckoDP_base::L3DMouse::left_button
protected
bool vreckoDP_base::L3DMouse::middle_button
protected
bool vreckoDP_base::L3DMouse::mouse_stand_button
protected
bool vreckoDP_base::L3DMouse::right_button
protected
bool vreckoDP_base::L3DMouse::suspend_button
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/L3DMouse.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/L3DMouse.cpp
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::LHeadTracker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • LHeadTracker
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::LHeadTracker Class Reference

#include <LHeadTracker.h>

Inheritance diagram for vreckoDP_base::LHeadTracker:
vrecko::Device vrecko::BaseClass vreckoDP_base::L3DMouse

Public Member Functions

LHeadTracker ()
LHeadTracker (const char *port_name)
LHeadTracker (const char *port_name1, const char *port_name2)
~LHeadTracker ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
int | getRotate (float *p_rotate)
osg::Vec3 & | getRotate (void)
void | setRotationType (rotation_type _type)
osg::Vec3 & | getRotateA (void)
osg::Matrix & | getRotateM (void)
osg::Quat & | getRotateQ (void)
int | getTranslate (float *p_trans)
osg::Vec3 & | getTranslate (void)
void | printPos (void)
void | setInitialPosition (osg::Vec4 &_pos)
void | setInitialRotation (osg::Vec4 &_rot)
void | setInitialPosition (osg::Vec4 &_pos1, osg::Vec4 &_pos2)
void | setInitialRotation (osg::Vec4 &_rot1, osg::Vec4 &_rot2)
void | demandReport (void)
void | setBaseT (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | setBaseR (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | resetBase (osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig)
void | setSlaveTransmitterType (unsigned char transmitter_type)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | scanDevice (void)
bool | openPort (const char *_pname, int *temp_port_fd)
bool | scanDeviceX (void)
int | diagnostic (void)
int | getRecData (long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet)
void | delay (int msec)
int | lhtRead (char *buf, int n)
void | reset (void)
int | singleReport (char *reply)
void | printBuffer (const char *buf, int length)
osg::Vec4 | getEuler (osg::Matrix &_mat)
osg::Vec4 | get_rel_pos (long int x, long int y, long int z)
bool | checkDiff (const long int &x, const long int &y, const long int &z, const long int &n_pi, const long int &n_ya, const long int &n_ro)
DECLARE_OUTPUT (Position, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation, vrecko::MessageQuat)

Protected Attributes

int | port_fd
int | port_fd_dual
int | _port_fd
std::string | _port_name_dual
int | actual_p
bool | rec_out [2]
osg::Vec4 | pos [2]
osg::Vec4 | rot [2]
osg::Vec3 | ret_pos
osg::Vec3 | ret_rot
osg::Quat | rotq [2]
osg::Quat | rotq_diff [2]
rotation_type rot_type
osg::Matrix | ret_rotm
osg::Quat | ret_rotq
osg::Vec4 | base1
osg::Vec4 | base2
osg::Vec4 | base3
osg::Vec4 | origin
char | tx_buf [HTD_COMMAND_LEN]
char | rx_buf [2 *HTD_PACKET_LEN]
int | req_len
int | read_len
long int | absX [2]
long int | absY [2]
long int | absZ [2]
long int | absPI [2]
long int | absYA [2]
long int | absRO [2]
osg::Vec4 | pos_diff [2]
osg::Vec4 | rot_diff [2]
long int | last_absPI [2]
long int | last_absYA [2]
long int | last_absRO [2]
osg::Vec4 | last_rot [2]
osg::Matrix | tr_matrix
osg::Matrix | tr_matrix2
bool | first_report [2]
jmp_buf | tenv
osg::Vec3 | translate_mapping
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

LHeadTracker::LHeadTracker ( )
LHeadTracker::LHeadTracker ( const char * port_name )
LHeadTracker::LHeadTracker | ( | const char * | port_name1,
 |  | const char * | port_name2
 | ) |  |
LHeadTracker::~LHeadTracker ( )

Member Function Documentation

bool LHeadTracker::checkDiff | ( | const long int & | x,
 |  | const long int & | y,
 |  | const long int & | z,
 |  | const long int & | n_pi,
 |  | const long int & | n_ya,
 |  | const long int & | n_ro
 | ) |  |
protected
int LHeadTracker::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::LHeadTracker::DECLARE_OUTPUT | ( | Position | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::LHeadTracker::DECLARE_OUTPUT | ( | Orientation | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
void LHeadTracker::delay ( int msec )
inlineprotected
void LHeadTracker::demandReport ( void )
int LHeadTracker::diagnostic ( void )
protected
osg::Vec4 LHeadTracker::get_rel_pos | ( | long int | x,
 |  | long int | y,
 |  | long int | z
 | ) |  |
protected

given absolute position of the tracker in HT coord system evaluate relative position in world coordinates

osg::Vec4 LHeadTracker::getEuler ( osg::Matrix & _mat )
protected
int LHeadTracker::getRecData | ( | long int * | x,
 |  | long int * | y,
 |  | long int * | z,
 |  | long int * | pi,
 |  | long int * | ya,
 |  | long int * | ro,
 |  | char * | packet
 | ) |  |
protected

htd_get_rec_data

given a packet from control unit, get the actual position and rotation of the receiver return the value of {REC_OUT, REC_FRI, REC_IN} which means {receiver out of active area, receiver in fringe area, receiver in active area}

int LHeadTracker::getRotate ( float * p_rotate )
osg::Vec3 & LHeadTracker::getRotate ( void )
osg::Vec3 & LHeadTracker::getRotateA ( void )
osg::Matrix & LHeadTracker::getRotateM ( void )
osg::Quat & LHeadTracker::getRotateQ ( void )
int LHeadTracker::getTranslate ( float * p_trans )
osg::Vec3 & LHeadTracker::getTranslate ( void )
int LHeadTracker::lhtRead | ( | char * | buf,
 |  | int | n
 | ) |  |
protected
bool LHeadTracker::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int LHeadTracker::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

Reimplemented in vreckoDP_base::L3DMouse.

bool LHeadTracker::openPort | ( | const char * | _pname,
 |  | int * | temp_port_fd
 | ) |  |
protected
void LHeadTracker::printBuffer | ( | const char * | buf,
 |  | int | length
 | ) |  |
protected
void LHeadTracker::printPos ( void )
void LHeadTracker::reset ( void )
protected
void LHeadTracker::resetBase | ( | osg::Vec4 | b1,
 |  | osg::Vec4 | b2,
 |  | osg::Vec4 | b3,
 |  | osg::Vec4 | orig
 | ) |  |
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * LHeadTracker::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

int LHeadTracker::scanDevice ( void )
protected
bool LHeadTracker::scanDeviceX ( void )
protected
void LHeadTracker::setBaseR | ( | osg::Vec4 | b1,
 |  | osg::Vec4 | b2,
 |  | osg::Vec4 | b3,
 |  | osg::Vec4 | orig
 | ) |  |

set the base of HT coordinate system in world coordinates - Rotation

void LHeadTracker::setBaseT | ( | osg::Vec4 | b1,
 |  | osg::Vec4 | b2,
 |  | osg::Vec4 | b3,
 |  | osg::Vec4 | orig
 | ) |  |

set the base of HT coordinate system in world coordinates

void LHeadTracker::setInitialPosition ( osg::Vec4 & _pos )
void LHeadTracker::setInitialPosition | ( | osg::Vec4 & | _pos1,
 |  | osg::Vec4 & | _pos2
 | ) |  |
void LHeadTracker::setInitialRotation ( osg::Vec4 & _rot )
void LHeadTracker::setInitialRotation | ( | osg::Vec4 & | _rot1,
 |  | osg::Vec4 & | _rot2
 | ) |  |
void vreckoDP_base::LHeadTracker::setRotationType ( rotation_type _type )
inline
void LHeadTracker::setSlaveTransmitterType ( unsigned char transmitter_type )
int LHeadTracker::singleReport ( char * reply )
protected
void LHeadTracker::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

int vreckoDP_base::LHeadTracker::_port_fd
protected
std::string vreckoDP_base::LHeadTracker::_port_name_dual
protected
long int vreckoDP_base::LHeadTracker::absPI[2]
protected
long int vreckoDP_base::LHeadTracker::absRO[2]
protected
long int vreckoDP_base::LHeadTracker::absX[2]
protected
long int vreckoDP_base::LHeadTracker::absY[2]
protected
long int vreckoDP_base::LHeadTracker::absYA[2]
protected
long int vreckoDP_base::LHeadTracker::absZ[2]
protected
int vreckoDP_base::LHeadTracker::actual_p
protected
osg::Vec4 vreckoDP_base::LHeadTracker::base1
protected
osg::Vec4 vreckoDP_base::LHeadTracker::base2
protected
osg::Vec4 vreckoDP_base::LHeadTracker::base3
protected
bool vreckoDP_base::LHeadTracker::first_report[2]
protected
long int vreckoDP_base::LHeadTracker::last_absPI[2]
protected
long int vreckoDP_base::LHeadTracker::last_absRO[2]
protected
long int vreckoDP_base::LHeadTracker::last_absYA[2]
protected
osg::Vec4 vreckoDP_base::LHeadTracker::last_rot[2]
protected
osg::Vec4 vreckoDP_base::LHeadTracker::origin
protected
int vreckoDP_base::LHeadTracker::port_fd
protected
int vreckoDP_base::LHeadTracker::port_fd_dual
protected
osg::Vec4 vreckoDP_base::LHeadTracker::pos[2]
protected
osg::Vec4 vreckoDP_base::LHeadTracker::pos_diff[2]
protected
int vreckoDP_base::LHeadTracker::read_len
protected
bool vreckoDP_base::LHeadTracker::rec_out[2]
protected
int vreckoDP_base::LHeadTracker::req_len
protected
osg::Vec3 vreckoDP_base::LHeadTracker::ret_pos
protected
osg::Vec3 vreckoDP_base::LHeadTracker::ret_rot
protected
osg::Matrix vreckoDP_base::LHeadTracker::ret_rotm
protected
osg::Quat vreckoDP_base::LHeadTracker::ret_rotq
protected
osg::Vec4 vreckoDP_base::LHeadTracker::rot[2]
protected
osg::Vec4 vreckoDP_base::LHeadTracker::rot_diff[2]
protected
rotation_type vreckoDP_base::LHeadTracker::rot_type
protected
osg::Quat vreckoDP_base::LHeadTracker::rotq[2]
protected
osg::Quat vreckoDP_base::LHeadTracker::rotq_diff[2]
protected
char vreckoDP_base::LHeadTracker::rx_buf[2 *HTD_PACKET_LEN]
protected
jmp_buf vreckoDP_base::LHeadTracker::tenv
protected
osg::Matrix vreckoDP_base::LHeadTracker::tr_matrix
protected
osg::Matrix vreckoDP_base::LHeadTracker::tr_matrix2
protected
osg::Vec3 vreckoDP_base::LHeadTracker::translate_mapping
protected
char vreckoDP_base::LHeadTracker::tx_buf[HTD_COMMAND_LEN]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/LHeadTracker.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/LHeadTracker.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::MicroScribe3D Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • MicroScribe3D
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::MicroScribe3D Class Reference

#include <MicroScribe3D.h>

Inheritance diagram for vreckoDP_base::MicroScribe3D:
vrecko::Device vrecko::BaseClass

Public Member Functions

MicroScribe3D ()
MicroScribe3D (const char *port_name)
~MicroScribe3D ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
int | getButt ()
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (Buttons, vrecko::MessageInt)
DECLARE_OUTPUT (Position, vrecko::MessageVec3)
DECLARE_OUTPUT (Normal, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation, vrecko::MessageQuat)

Protected Attributes

vrecko::EventDispatcher * pEventDispatcher
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

MicroScribe3D::MicroScribe3D ( )
MicroScribe3D::MicroScribe3D ( const char * port_name )
MicroScribe3D::~MicroScribe3D ( )

Member Function Documentation

int MicroScribe3D::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::MicroScribe3D::DECLARE_OUTPUT | ( | Buttons | ,
 |  | vrecko::MessageInt |
 | ) |  |
protected
vreckoDP_base::MicroScribe3D::DECLARE_OUTPUT | ( | Position | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::MicroScribe3D::DECLARE_OUTPUT | ( | Normal | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::MicroScribe3D::DECLARE_OUTPUT | ( | Orientation | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
int vreckoDP_base::MicroScribe3D::getButt ( )
inline
int MicroScribe3D::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

void MicroScribe3D::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

vrecko::EventDispatcher* vreckoDP_base::MicroScribe3D::pEventDispatcher
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/MicroScribe3D.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/MicroScribe3D.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::NestOfBirds Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • NestOfBirds
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::NestOfBirds Class Reference

#include <NestOfBirds.h>

Inheritance diagram for vreckoDP_base::NestOfBirds:
vrecko::Device vrecko::BaseClass

Public Member Functions

NestOfBirds ()
NestOfBirds (const char *_port_number)
~NestOfBirds ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
int | getRotate (float *p_rotate)
osg::Vec3 & | getRotate (void)
osg::Vec3 & | getRotateA (void)
osg::Matrix & | getRotateM (void)
osg::Quat & | getRotateQ (void)
int | getTranslate (float *p_trans)
osg::Vec3 & | getTranslate (void)
void | setInitialPosition (osg::Vec4 &_pos)
void | setInitialRotation (osg::Vec4 &_rot)
void | setInitialPosition (osg::Vec4 &_pos1, osg::Vec4 &_pos2)
void | setInitialRotation (osg::Vec4 &_rot1, osg::Vec4 &_rot2)
void | setOriginPosition (float _nx, float _ny, float _nz)
osg::Vec3 | getOriginPosition (void)
void | setTranslateMapping (float _nx, float _ny, float _nz)
osg::Vec3 | getTranslateMapping (void)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | scanDevice (void)
bool | openSocket (void)
bool | scanDeviceX (void)
DECLARE_OUTPUT (Position_sensor_0, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_0, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_1, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_1, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_2, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_2, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_3, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_3, vrecko::MessageQuat)

Protected Attributes

std::string | _hostname
int | _port
char | _buf [BUFSIZE]
int | sockfd
struct sockaddr_in | sockname
int | length
osg::Vec3 | _translate [4]
osg::Vec3 | _ret_translate [4]
osg::Quat | _rotate [4]
osg::Quat | _ret_rotate [4]
osg::Vec3 | _origin_pos
osg::Vec3 | _trans_mapp
vrecko::EventDispatcher * pEventDispatcher
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

NestOfBirds::NestOfBirds ( )
NestOfBirds::NestOfBirds ( const char * _port_number )
NestOfBirds::~NestOfBirds ( )

Member Function Documentation

int NestOfBirds::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Position_sensor_0 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Orientation_sensor_0 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Position_sensor_1 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Orientation_sensor_1 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Position_sensor_2 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Orientation_sensor_2 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Position_sensor_3 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::NestOfBirds::DECLARE_OUTPUT | ( | Orientation_sensor_3 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
osg::Vec3 vreckoDP_base::NestOfBirds::getOriginPosition ( void )
inline
int vreckoDP_base::NestOfBirds::getRotate ( float * p_rotate )
osg::Vec3& vreckoDP_base::NestOfBirds::getRotate ( void )
osg::Vec3& vreckoDP_base::NestOfBirds::getRotateA ( void )
osg::Matrix& vreckoDP_base::NestOfBirds::getRotateM ( void )
osg::Quat & NestOfBirds::getRotateQ ( void )
int vreckoDP_base::NestOfBirds::getTranslate ( float * p_trans )
osg::Vec3 & NestOfBirds::getTranslate ( void )
osg::Vec3 vreckoDP_base::NestOfBirds::getTranslateMapping ( void )
inline
bool NestOfBirds::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int NestOfBirds::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

bool NestOfBirds::openSocket ( void )
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * NestOfBirds::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

int NestOfBirds::scanDevice ( void )
protected
bool vreckoDP_base::NestOfBirds::scanDeviceX ( void )
protected
void vreckoDP_base::NestOfBirds::setInitialPosition ( osg::Vec4 & _pos )
void vreckoDP_base::NestOfBirds::setInitialPosition | ( | osg::Vec4 & | _pos1,
 |  | osg::Vec4 & | _pos2
 | ) |  |
void vreckoDP_base::NestOfBirds::setInitialRotation ( osg::Vec4 & _rot )
void vreckoDP_base::NestOfBirds::setInitialRotation | ( | osg::Vec4 & | _rot1,
 |  | osg::Vec4 & | _rot2
 | ) |  |
void vreckoDP_base::NestOfBirds::setOriginPosition | ( | float | _nx,
 |  | float | _ny,
 |  | float | _nz
 | ) |  |
inline
void vreckoDP_base::NestOfBirds::setTranslateMapping | ( | float | _nx,
 |  | float | _ny,
 |  | float | _nz
 | ) |  |
inline
void NestOfBirds::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

char vreckoDP_base::NestOfBirds::_buf[BUFSIZE]
protected
std::string vreckoDP_base::NestOfBirds::_hostname
protected
osg::Vec3 vreckoDP_base::NestOfBirds::_origin_pos
protected
int vreckoDP_base::NestOfBirds::_port
protected
osg::Quat vreckoDP_base::NestOfBirds::_ret_rotate[4]
protected
osg::Vec3 vreckoDP_base::NestOfBirds::_ret_translate[4]
protected
osg::Quat vreckoDP_base::NestOfBirds::_rotate[4]
protected
osg::Vec3 vreckoDP_base::NestOfBirds::_trans_mapp
protected
osg::Vec3 vreckoDP_base::NestOfBirds::_translate[4]
protected
int vreckoDP_base::NestOfBirds::length
protected
vrecko::EventDispatcher* vreckoDP_base::NestOfBirds::pEventDispatcher
protected
int vreckoDP_base::NestOfBirds::sockfd
protected
struct sockaddr_in vreckoDP_base::NestOfBirds::sockname
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/NestOfBirds.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/NestOfBirds.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::OptiTrack Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • OptiTrack
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::OptiTrack Class Reference

#include <OptiTrack.h>

Inheritance diagram for vreckoDP_base::OptiTrack:
vrecko::Device vrecko::BaseClass

Classes

struct info_struct

Public Member Functions

OptiTrack ()
OptiTrack (const char *_port_number)
~OptiTrack ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
void | sendEvent (int sid, osg::Vec3 *p, osg::Quat *o)
float | getSensorScale ()
osg::Vec3 * | getOriginPosition ()
osg::Vec3 * | getTranslateMapping ()
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void addSensor (int i)
DECLARE_INPUT (SetSensorCount, vrecko::MessageInt)
DECLARE_OUTPUT (Sensor_Transformation, vrecko::MessageSensorTransformation)

Protected Attributes

std::string | _hostname
int | _port
vrpn_Connection * | connection
char | connectionName [128]
vrpn_Tracker_Remote * | tracker [TRACKER_MAX_COUNT]
info_struct * is [TRACKER_MAX_COUNT]
osg::Vec3 | _origin_pos
osg::Vec3 | _trans_mapp
float | sensorScale
unsigned int | sensor_count
bool | deprecated_version
std::string | server_address
vrecko::EventDispatcher * pEventDispatcher
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

OptiTrack::OptiTrack ( )
OptiTrack::OptiTrack ( const char * _port_number )
OptiTrack::~OptiTrack ( )

Member Function Documentation

void OptiTrack::addSensor ( int i )
protected
int OptiTrack::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::OptiTrack::DECLARE_INPUT | ( | SetSensorCount | ,
 |  | vrecko::MessageInt |
 | ) |  |
protected
vreckoDP_base::OptiTrack::DECLARE_OUTPUT | ( | Sensor_Transformation | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
protected
osg::Vec3* vreckoDP_base::OptiTrack::getOriginPosition ( )
inline
float vreckoDP_base::OptiTrack::getSensorScale ( )
inline
osg::Vec3* vreckoDP_base::OptiTrack::getTranslateMapping ( )
inline
bool OptiTrack::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int OptiTrack::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

void OptiTrack::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void OptiTrack::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * OptiTrack::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void OptiTrack::sendEvent | ( | int | sid,
 |  | osg::Vec3 * | p,
 |  | osg::Quat * | o
 | ) |  |
void OptiTrack::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

std::string vreckoDP_base::OptiTrack::_hostname
protected
osg::Vec3 vreckoDP_base::OptiTrack::_origin_pos
protected
int vreckoDP_base::OptiTrack::_port
protected
osg::Vec3 vreckoDP_base::OptiTrack::_trans_mapp
protected
vrpn_Connection* vreckoDP_base::OptiTrack::connection
protected
char vreckoDP_base::OptiTrack::connectionName[128]
protected
bool vreckoDP_base::OptiTrack::deprecated_version
protected
info_struct* vreckoDP_base::OptiTrack::is[TRACKER_MAX_COUNT]
protected
vrecko::EventDispatcher* vreckoDP_base::OptiTrack::pEventDispatcher
protected
unsigned int vreckoDP_base::OptiTrack::sensor_count
protected
float vreckoDP_base::OptiTrack::sensorScale
protected
std::string vreckoDP_base::OptiTrack::server_address
protected
vrpn_Tracker_Remote* vreckoDP_base::OptiTrack::tracker[TRACKER_MAX_COUNT]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/OptiTrack.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/OptiTrack.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::OptiTrack::info_struct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • OptiTrack
  • info_struct
Public Attributes | List of all members
vreckoDP_base::OptiTrack::info_struct Struct Reference

#include <OptiTrack.h>

Public Attributes

int T_ID
OptiTrack * pOT

Member Data Documentation

OptiTrack* vreckoDP_base::OptiTrack::info_struct::pOT
int vreckoDP_base::OptiTrack::info_struct::T_ID
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/OptiTrack.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::Ultratrak Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • Ultratrak
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::Ultratrak Class Reference

#include <Ultratrak.h>

Inheritance diagram for vreckoDP_base::Ultratrak:
vrecko::Device vrecko::BaseClass

Public Member Functions

Ultratrak ()
Ultratrak (const char *_port_number)
~Ultratrak ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
int | getRotate (float *p_rotate)
osg::Vec3 & | getRotate (void)
osg::Vec3 & | getRotateA (void)
osg::Matrix & | getRotateM (void)
osg::Quat & | getRotateQ (void)
int | getTranslate (float *p_trans)
osg::Vec3 & | getTranslate (void)
void | setInitialPosition (osg::Vec4 &_pos)
void | setInitialRotation (osg::Vec4 &_rot)
void | setInitialPosition (osg::Vec4 &_pos1, osg::Vec4 &_pos2)
void | setInitialRotation (osg::Vec4 &_rot1, osg::Vec4 &_rot2)
void | setOriginPosition (float _nx, float _ny, float _nz)
void | setTranslateMapping (float _nx, float _ny, float _nz)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

int | scanDevice (void)
bool | openSocket (void)
bool | scanDeviceX (void)
DECLARE_OUTPUT (Position_sensor_0, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_0, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_1, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_1, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_2, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_2, vrecko::MessageQuat)
DECLARE_OUTPUT (Position_sensor_3, vrecko::MessageVec3)
DECLARE_OUTPUT (Orientation_sensor_3, vrecko::MessageQuat)

Protected Attributes

std::string | _hostname
int | _port
char | _buf [BUFSIZE]
int | sockfd
struct sockaddr_in | sockname
int | length
osg::Vec3 | _translate [4]
osg::Vec3 | _ret_translate [4]
osg::Quat | _rotate [4]
osg::Quat | _ret_rotate [4]
osg::Vec3 | _origin_pos
osg::Vec3 | _trans_mapp
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

vreckoDP_base::Ultratrak::Ultratrak ( )
inline
Ultratrak::Ultratrak ( const char * _port_number )
Ultratrak::~Ultratrak ( )

Member Function Documentation

int Ultratrak::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Position_sensor_0 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Orientation_sensor_0 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Position_sensor_1 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Orientation_sensor_1 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Position_sensor_2 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Orientation_sensor_2 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Position_sensor_3 | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::Ultratrak::DECLARE_OUTPUT | ( | Orientation_sensor_3 | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
int vreckoDP_base::Ultratrak::getRotate ( float * p_rotate )
osg::Vec3& vreckoDP_base::Ultratrak::getRotate ( void )
osg::Vec3& vreckoDP_base::Ultratrak::getRotateA ( void )
osg::Matrix& vreckoDP_base::Ultratrak::getRotateM ( void )
osg::Quat & Ultratrak::getRotateQ ( void )
int vreckoDP_base::Ultratrak::getTranslate ( float * p_trans )
osg::Vec3 & Ultratrak::getTranslate ( void )
int Ultratrak::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

bool Ultratrak::openSocket ( void )
protected
int Ultratrak::scanDevice ( void )
protected
bool vreckoDP_base::Ultratrak::scanDeviceX ( void )
protected
void vreckoDP_base::Ultratrak::setInitialPosition ( osg::Vec4 & _pos )
void vreckoDP_base::Ultratrak::setInitialPosition | ( | osg::Vec4 & | _pos1,
 |  | osg::Vec4 & | _pos2
 | ) |  |
void vreckoDP_base::Ultratrak::setInitialRotation ( osg::Vec4 & _rot )
void vreckoDP_base::Ultratrak::setInitialRotation | ( | osg::Vec4 & | _rot1,
 |  | osg::Vec4 & | _rot2
 | ) |  |
void vreckoDP_base::Ultratrak::setOriginPosition | ( | float | _nx,
 |  | float | _ny,
 |  | float | _nz
 | ) |  |
inline
void vreckoDP_base::Ultratrak::setTranslateMapping | ( | float | _nx,
 |  | float | _ny,
 |  | float | _nz
 | ) |  |
inline
void Ultratrak::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

char vreckoDP_base::Ultratrak::_buf[BUFSIZE]
protected
std::string vreckoDP_base::Ultratrak::_hostname
protected
osg::Vec3 vreckoDP_base::Ultratrak::_origin_pos
protected
int vreckoDP_base::Ultratrak::_port
protected
osg::Quat vreckoDP_base::Ultratrak::_ret_rotate[4]
protected
osg::Vec3 vreckoDP_base::Ultratrak::_ret_translate[4]
protected
osg::Quat vreckoDP_base::Ultratrak::_rotate[4]
protected
osg::Vec3 vreckoDP_base::Ultratrak::_trans_mapp
protected
osg::Vec3 vreckoDP_base::Ultratrak::_translate[4]
protected
int vreckoDP_base::Ultratrak::length
protected
int vreckoDP_base::Ultratrak::sockfd
protected
struct sockaddr_in vreckoDP_base::Ultratrak::sockname
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Ultratrak.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Ultratrak.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::VRPN3DMouse Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • VRPN3DMouse
Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes | List of all members
vreckoDP_base::VRPN3DMouse Class Reference

#include <VRPN3DMouse.h>

Inheritance diagram for vreckoDP_base::VRPN3DMouse:
vrecko::Device vrecko::BaseClass

Public Member Functions

VRPN3DMouse ()
virtual int | openDevice (void)
int | closeDevice (void)
Closes device. More...
void | processEvent (const std::string &input_name, void *value)
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | VRPN3DMouse::sendAnalogEvent (osg::Vec3 *p, osg::Vec3 *o)
void | VRPN3DMouse::sendButtonEvent (u_int key, u_int state)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_OUTPUT (Button, vrecko::MessageString)
DECLARE_OUTPUT (Position, vrecko::MessageVec3)
DECLARE_OUTPUT (Move, vrecko::MessageVec3)
DECLARE_OUTPUT (Rotation, vrecko::MessageQuat)
DECLARE_OUTPUT (Orientation, vrecko::MessageQuat)

Static Protected Member Functions

static void VRPN_CALLBACK | handle_analog (void *userdata, vrpn_ANALOGCB b)
static void VRPN_CALLBACK | handle_button (void *userdata, vrpn_BUTTONCB b)

Protected Attributes

vrecko::EventDispatcher * pEventDispatcher
vrpn_Analog_Remote * | ana
vrpn_Button_Remote * | but
HANDLE | vrpnServerHandle
osg::Vec3 | _originPos
osg::Vec3 | _curMove
osg::Quat | _originRot
osg::Quat | _curRotate
float | _speedFactor
float | _rotateRatio
bool | _speedControl
bool | _axisControl
bool | _rotateControl
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

VRPN3DMouse::VRPN3DMouse ( )

Member Function Documentation

int VRPN3DMouse::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::VRPN3DMouse::DECLARE_OUTPUT | ( | Button | ,
 |  | vrecko::MessageString |
 | ) |  |
protected
vreckoDP_base::VRPN3DMouse::DECLARE_OUTPUT | ( | Position | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::VRPN3DMouse::DECLARE_OUTPUT | ( | Move | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_base::VRPN3DMouse::DECLARE_OUTPUT | ( | Rotation | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
vreckoDP_base::VRPN3DMouse::DECLARE_OUTPUT | ( | Orientation | ,
 |  | vrecko::MessageQuat |
 | ) |  |
protected
void VRPN_CALLBACK VRPN3DMouse::handle_analog | ( | void * | userdata,
 |  | vrpn_ANALOGCB | b
 | ) |  |
staticprotected

Handlers for analog input and buttons

void VRPN_CALLBACK VRPN3DMouse::handle_button | ( | void * | userdata,
 |  | vrpn_BUTTONCB | b
 | ) |  |
staticprotected
bool VRPN3DMouse::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int VRPN3DMouse::openDevice ( void )
virtual

Inherited functions from Device class

Implements vrecko::Device.

void VRPN3DMouse::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void VRPN3DMouse::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

void vreckoDP_base::VRPN3DMouse::VRPN3DMouse::sendAnalogEvent | ( | osg::Vec3 * | p,
 |  | osg::Vec3 * | o
 | ) |  |

Processing of analog and button events

void vreckoDP_base::VRPN3DMouse::VRPN3DMouse::sendButtonEvent | ( | u_int | key,
 |  | u_int | state
 | ) |  |

Member Data Documentation

bool vreckoDP_base::VRPN3DMouse::_axisControl
protected
osg::Vec3 vreckoDP_base::VRPN3DMouse::_curMove
protected
osg::Quat vreckoDP_base::VRPN3DMouse::_curRotate
protected
osg::Vec3 vreckoDP_base::VRPN3DMouse::_originPos
protected
osg::Quat vreckoDP_base::VRPN3DMouse::_originRot
protected
bool vreckoDP_base::VRPN3DMouse::_rotateControl
protected
float vreckoDP_base::VRPN3DMouse::_rotateRatio
protected
bool vreckoDP_base::VRPN3DMouse::_speedControl
protected
float vreckoDP_base::VRPN3DMouse::_speedFactor
protected
vrpn_Analog_Remote* vreckoDP_base::VRPN3DMouse::ana
protected
vrpn_Button_Remote* vreckoDP_base::VRPN3DMouse::but
protected
vrecko::EventDispatcher* vreckoDP_base::VRPN3DMouse::pEventDispatcher
protected
HANDLE vreckoDP_base::VRPN3DMouse::vrpnServerHandle
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/VRPN3DMouse.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/VRPN3DMouse.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_base::Wiimote Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • Wiimote
Public Member Functions | Protected Member Functions | Protected Attributes | Static Protected Attributes | List of all members
vreckoDP_base::Wiimote Class Reference

#include <Wiimote.h>

Inheritance diagram for vreckoDP_base::Wiimote:
vrecko::Device vrecko::BaseClass

Public Member Functions

Wiimote ()
~Wiimote ()
virtual int | openDevice (void)
Opens device and performs the initialization routines. More...
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode=NULL)
Core initialization. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
void | handle_event (int currentWiimoteID, struct wiimote_t *wm)
Callback that handles an event. More...
void | handle_read (struct wiimote_t *wm, byte *data, unsigned short len)
Callback that handles a read event. More...
void | handle_ctrl_status (struct wiimote_t *wm)
Callback that handles a controller status event. More...
void | handle_disconnect (wiimote *wm)
Callback that handles a disconnection event. More...
void | test (struct wiimote_t *wm, byte *data, unsigned short len)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

DECLARE_INPUT (Vibration, vrecko::MessageBool)
DECLARE_OUTPUT (Button, vrecko::MessageString)
DECLARE_OUTPUT (Orientation, vrecko::MessageVec3)

Protected Attributes

bool | main_wiimote
unsigned int | wiimoteID
bool | vibration
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Static Protected Attributes

static bool | is_initialized = false
static bool | disabled = false
static bool | check_failed = true
static wiimote ** | pWiimote = NULL

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

Wiimote::Wiimote ( )
Wiimote::~Wiimote ( )

Member Function Documentation

int Wiimote::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_base::Wiimote::DECLARE_INPUT | ( | Vibration | ,
 |  | vrecko::MessageBool |
 | ) |  |
protected
vreckoDP_base::Wiimote::DECLARE_OUTPUT | ( | Button | ,
 |  | vrecko::MessageString |
 | ) |  |
protected
vreckoDP_base::Wiimote::DECLARE_OUTPUT | ( | Orientation | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
void Wiimote::handle_ctrl_status ( struct wiimote_t * wm )

Callback that handles a controller status event.

Parameters
wm | Pointer to a wiimote_t structure.
attachment | Is there an attachment? (1 for yes, 0 for no)
speaker | Is the speaker enabled? (1 for yes, 0 for no)
ir | Is the IR support enabled? (1 for yes, 0 for no)
led | What LEDs are lit.
battery_level | Battery level, between 0.0 (0%) and 1.0 (100%).

This occurs when either the controller status changed or the controller status was requested explicitly by wiiuse_status().

One reason the status can change is if the nunchuk was inserted or removed from the expansion port.

void Wiimote::handle_disconnect ( wiimote * wm )

Callback that handles a disconnection event.

Parameters
wm Pointer to a wiimote_t structure.

This can happen if the POWER button is pressed, or if the connection is interrupted.

void Wiimote::handle_event | ( | int | currentWiimoteID,
 |  | struct wiimote_t * | wm
 | ) |  |

Callback that handles an event.

Parameters
wm Pointer to a wiimote_t structure.

This function is called automatically by the wiiuse library when an event occurs on the specified wiimote.

void Wiimote::handle_read | ( | struct wiimote_t * | wm,
 |  | byte * | data,
 |  | unsigned short | len
 | ) |  |

Callback that handles a read event.

Parameters
wm | Pointer to a wiimote_t structure.
data | Pointer to the filled data block.
len | Length in bytes of the data block.

This function is called automatically by the wiiuse library when the wiimote has returned the full data requested by a previous call to wiiuse_read_data().

You can read data on the wiimote, such as Mii data, if you know the offset address and the length.

The data pointer was specified on the call to wiiuse_read_data(). At the time of this function being called, it is not safe to deallocate this buffer.

bool Wiimote::initialize ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parameters = NULL )
virtual

Core initialization.

It is important to place the initializing code here, because especially in the case of Abilities, this is the point when the ID and owner is known and we can react accordingly. (This information is unknown in the constructor.)

You will probably want to override this method. This method supersedes the original preInitialize() / loadXMLParameters() / postInitialize() methods, which are now obsolete, but for the sake of compatibility they are called from the initialize() if the method is not overridden. You can override it and forget about pre/postInitialize() or loadParameters() - it's now an old solution.

Parameters
parameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) Pointer to a XML DOM node, might be NULL if no parameters were specified. The ability should initialize to default values in that case.
Returns
(bool) Returns true on success.

Reimplemented from vrecko::BaseClass.

int Wiimote::openDevice ( void )
virtual

Opens device and performs the initialization routines.

Implements vrecko::Device.

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * Wiimote::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void Wiimote::test | ( | struct wiimote_t * | wm,
 |  | byte * | data,
 |  | unsigned short | len
 | ) |  |
void Wiimote::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

bool Wiimote::check_failed = true
staticprotected
bool Wiimote::disabled = false
staticprotected
bool Wiimote::is_initialized = false
staticprotected
bool vreckoDP_base::Wiimote::main_wiimote
protected
wiimote ** Wiimote::pWiimote = NULL
staticprotected
bool vreckoDP_base::Wiimote::vibration
protected
unsigned int vreckoDP_base::Wiimote::wiimoteID
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Wiimote.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Wiimote.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoDP_Kinect::Kinect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_Kinect
  • Kinect
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoDP_Kinect::Kinect Class Reference

#include <Kinect.h>

Inheritance diagram for vreckoDP_Kinect::Kinect:
vrecko::Device vrecko::BaseClass

Public Member Functions

Kinect ()
virtual int | openDevice (void)
int | closeDevice (void)
Closes device. More...
void | update (void)
Updates the device - scan device and send required outputs. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | getSkeleton ()
void | sendSkeletonPositions (NUI_SKELETON_DATA *pSkel)
void | sendPosition (vrecko::OutputPin< vrecko::MessageVec3 > *outputPin, int index, NUI_SKELETON_DATA *pSkel)
void | sendSensorTransformation (int sensorNumber, int SkeletonIndex, NUI_SKELETON_DATA *pSkel)
- Public Member Functions inherited from vrecko::Device
Device (const char *startingDeviceName, const char *pname="")
virtual | ~Device ()
int | getID (void)
Returns the ID of the device. More...
void | setID (int new_id)
Sets ID of the device. More...
const std::string & | getDeviceType (void)
Returns the type of the device. More...
void | setPortName (const char *pname)
Sets the port name for the device. More...
const char * | getPortName (void)
Returns port name of the device. More...
virtual int | calibrateDevice (void)
Device calibration. More...
virtual const std::string | getCalibrationString (void)
Returns the description of the calibration process. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Static Public Member Functions

static DWORD WINAPI KinectThread (LPVOID pParam)

Protected Member Functions

DECLARE_OUTPUT (HipCenterPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (SpinePosition, vrecko::MessageVec3)
DECLARE_OUTPUT (ShoulderCenterPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (HeadPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (ShoulderLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (ElbowLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (WristLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (HandLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (ShoulderRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (ElbowRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (WristRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (HandRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (HipLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (KneeLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (AnkleLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (FootLeftPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (HipRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (KneeRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (AnkleRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (FootRightPosition, vrecko::MessageVec3)
DECLARE_OUTPUT (Sensor_Transformation, vrecko::MessageSensorTransformation)

Protected Attributes

HANDLE | _hNextSkeletonEvent
float | _scale
bool | _smoothing
osg::Vec3 | _worldOrigin
bool | _inputConnector
int * | _inputConnectorMappings
HANDLE | _hThNuiProcess
HANDLE | _hEvNuiProcessStop
- Protected Attributes inherited from vrecko::Device
int | id
device ID More...
std::string | device_type
device type More...
std::string | port_name
name of the port More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

XERCES_CPP_NAMESPACE_USE Kinect::Kinect ( )

Member Function Documentation

int Kinect::closeDevice ( void )
virtual

Closes device.

Implements vrecko::Device.

vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HipCenterPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | SpinePosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | ShoulderCenterPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HeadPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | ShoulderLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | ElbowLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | WristLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HandLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | ShoulderRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | ElbowRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | WristRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HandRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HipLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | KneeLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | AnkleLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | FootLeftPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | HipRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | KneeRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | AnkleRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | FootRightPosition | ,
 |  | vrecko::MessageVec3 |
 | ) |  |
protected
vreckoDP_Kinect::Kinect::DECLARE_OUTPUT | ( | Sensor_Transformation | ,
 |  | vrecko::MessageSensorTransformation |
 | ) |  |
protected
void vreckoDP_Kinect::Kinect::getSkeleton ( )
DWORD WINAPI Kinect::KinectThread ( LPVOID pParam )
static
bool Kinect::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

int Kinect::openDevice ( void )
virtual

Inherited functions from Device class

Implements vrecko::Device.

void vreckoDP_Kinect::Kinect::sendPosition | ( | vrecko::OutputPin< vrecko::MessageVec3 > * | outputPin,
 |  | int | index,
 |  | NUI_SKELETON_DATA * | pSkel
 | ) |  |
void vreckoDP_Kinect::Kinect::sendSensorTransformation | ( | int | sensorNumber,
 |  | int | SkeletonIndex,
 |  | NUI_SKELETON_DATA * | pSkel
 | ) |  |
void vreckoDP_Kinect::Kinect::sendSkeletonPositions ( NUI_SKELETON_DATA * pSkel )
void Kinect::update ( void )
virtual

Updates the device - scan device and send required outputs.

Implements vrecko::Device.

Member Data Documentation

HANDLE vreckoDP_Kinect::Kinect::_hEvNuiProcessStop
protected
HANDLE vreckoDP_Kinect::Kinect::_hNextSkeletonEvent
protected
HANDLE vreckoDP_Kinect::Kinect::_hThNuiProcess
protected
bool vreckoDP_Kinect::Kinect::_inputConnector
protected
int* vreckoDP_Kinect::Kinect::_inputConnectorMappings
protected
float vreckoDP_Kinect::Kinect::_scale
protected
bool vreckoDP_Kinect::Kinect::_smoothing
protected
osg::Vec3 vreckoDP_Kinect::Kinect::_worldOrigin
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect/Kinect.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/Kinect.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::HighlightCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • HighlightCallback
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::HighlightCallback Class Reference

#include <HighlightCallback.h>

Inheritance diagram for vreckoUtils::HighlightCallback:

Public Member Functions

HighlightCallback (double increment)
virtual void | operator() (osg::Node *node, osg::NodeVisitor *nv)
double | getIncrementValue () const
void | setIncrementValue (double val)
bool | getHighlighted () const
void | setHighlighting (bool val)
void | switchHighlighting ()

Protected Attributes

bool | _highlighted
bool | _dirty
double | _increment
osg::Vec4 | _incrementVec
osg::ref_ptr< osg::Vec4Array > | _origColors

Detailed Description

Highlights any kind of node

Constructor & Destructor Documentation

vreckoUtils::HighlightCallback::HighlightCallback ( double increment )
inline

Member Function Documentation

bool vreckoUtils::HighlightCallback::getHighlighted ( ) const
inline
double vreckoUtils::HighlightCallback::getIncrementValue ( ) const
inline

Getters and setters

void vreckoUtils::HighlightCallback::operator() | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
virtual
void vreckoUtils::HighlightCallback::setHighlighting ( bool val )
inline
void vreckoUtils::HighlightCallback::setIncrementValue ( double val )
inline
void vreckoUtils::HighlightCallback::switchHighlighting ( )
inline

Member Data Documentation

bool vreckoUtils::HighlightCallback::_dirty
protected
bool vreckoUtils::HighlightCallback::_highlighted
protected
double vreckoUtils::HighlightCallback::_increment
protected
osg::Vec4 vreckoUtils::HighlightCallback::_incrementVec
protected
osg::ref_ptr<osg::Vec4Array> vreckoUtils::HighlightCallback::_origColors
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/HighlightCallback.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/HighlightCallback.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::Math Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Math
Static Public Member Functions | List of all members
vreckoUtils::Math Class Reference

#include <Math.h>

Static Public Member Functions

static int | gcd (int a, int b)
static int | lcm (int a, int b)

Member Function Documentation

int vreckoUtils::Math::gcd | ( | int | a,
 |  | int | b
 | ) |  |
static

Finds the greatest common divider

int vreckoUtils::Math::lcm | ( | int | a,
 |  | int | b
 | ) |  |
static

Finds the least common multiple

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Math.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Math.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuCommon Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuCommon
Static Public Member Functions | List of all members
vreckoUtils::MenuCommon Class Reference

#include <Menu.h>

Static Public Member Functions

static void | createMenuItem (std::ostringstream &menuSS, const char *itemName, const char *caption, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f))
static void | createMenuSlider (std::ostringstream &menuSS, const char *itemName, const char *caption, double sliderFrom, double sliderTo, bool integerOnly, double sliderPos, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f))

Member Function Documentation

void MenuCommon::createMenuItem | ( | std::ostringstream & | menuSS,
 |  | const char * | itemName,
 |  | const char * | caption,
 |  | osg::Vec3 | color = osg::Vec3(0.9f, 0.8f, 0.8f)
 | ) |  |
static
void MenuCommon::createMenuSlider | ( | std::ostringstream & | menuSS,
 |  | const char * | itemName,
 |  | const char * | caption,
 |  | double | sliderFrom,
 |  | double | sliderTo,
 |  | bool | integerOnly,
 |  | double | sliderPos,
 |  | osg::Vec3 | color = osg::Vec3(0.9f, 0.8f, 0.8f)
 | ) |  |
static
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::IMenuComponent Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • IMenuComponent
Public Member Functions | List of all members
vreckoUtils::IMenuComponent Class Referenceabstract

#include <Menu.h>

Inheritance diagram for vreckoUtils::IMenuComponent:
vreckoUtils::MenuBase vreckoUtils::MenuItem vreckoUtils::MenuSlider vreckoUtils::Menu vreckoUtils::MenuRoot

Public Member Functions

virtual std::string | toXMLString ()=0
virtual std::string | getName ()=0
virtual std::string | getCaption ()=0
virtual void | accept (MenuVisitor &visitor)=0
virtual | ~IMenuComponent ()

Constructor & Destructor Documentation

virtual vreckoUtils::IMenuComponent::~IMenuComponent ( )
inlinevirtual

Member Function Documentation

virtual void vreckoUtils::IMenuComponent::accept ( MenuVisitor & visitor )
pure virtual

Implemented in vreckoUtils::MenuSlider, vreckoUtils::MenuItem, vreckoUtils::Menu, and vreckoUtils::MenuRoot.

virtual std::string vreckoUtils::IMenuComponent::getCaption ( )
pure virtual

Implemented in vreckoUtils::MenuSlider, vreckoUtils::MenuItem, vreckoUtils::Menu, and vreckoUtils::MenuRoot.

virtual std::string vreckoUtils::IMenuComponent::getName ( )
pure virtual

Implemented in vreckoUtils::MenuSlider, vreckoUtils::MenuItem, vreckoUtils::Menu, and vreckoUtils::MenuRoot.

virtual std::string vreckoUtils::IMenuComponent::toXMLString ( )
pure virtual

Implemented in vreckoUtils::MenuSlider, vreckoUtils::MenuItem, vreckoUtils::Menu, and vreckoUtils::MenuRoot.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuBase
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::MenuBase Class Reference

#include <Menu.h>

Inheritance diagram for vreckoUtils::MenuBase:
vreckoUtils::IMenuComponent vreckoUtils::Menu vreckoUtils::MenuRoot

Public Member Functions

void | addChild (osg::ref_ptr< IMenuComponent > menuComponent)
void | removeChild (int index)
IMenuComponent * | getChild (u_int index)
- Public Member Functions inherited from vreckoUtils::IMenuComponent
virtual std::string | toXMLString ()=0
virtual std::string | getName ()=0
virtual std::string | getCaption ()=0
virtual void | accept (MenuVisitor &visitor)=0
virtual | ~IMenuComponent ()

Protected Attributes

std::vector< osg::ref_ptr
< IMenuComponent > > 		_items

Member Function Documentation

void vreckoUtils::MenuBase::addChild ( osg::ref_ptr< IMenuComponent > menuComponent )
inline
IMenuComponent* vreckoUtils::MenuBase::getChild ( u_int index )
inline
void vreckoUtils::MenuBase::removeChild ( int index )
inline

Member Data Documentation

std::vector<osg::ref_ptr<IMenuComponent> > vreckoUtils::MenuBase::_items
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuRoot Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuRoot
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::MenuRoot Class Reference

#include <Menu.h>

Inheritance diagram for vreckoUtils::MenuRoot:
vreckoUtils::MenuBase vreckoUtils::IMenuComponent

Public Member Functions

MenuRoot ()
virtual std::string | toXMLString ()
virtual std::string | getName ()
virtual std::string | getCaption ()
void | addAttribute (const std::string &name, double value)
bool | removeAttribute (const std::string &name)
virtual void | accept (MenuVisitor &visitor)
- Public Member Functions inherited from vreckoUtils::MenuBase
void | addChild (osg::ref_ptr< IMenuComponent > menuComponent)
void | removeChild (int index)
IMenuComponent * | getChild (u_int index)
- Public Member Functions inherited from vreckoUtils::IMenuComponent
virtual | ~IMenuComponent ()

Protected Attributes

std::map< std::string, double > _attributes
- Protected Attributes inherited from vreckoUtils::MenuBase
std::vector< osg::ref_ptr
< IMenuComponent > > 		_items

Constructor & Destructor Documentation

vreckoUtils::MenuRoot::MenuRoot ( )
inline

Member Function Documentation

void MenuRoot::accept ( MenuVisitor & visitor )
virtual

Implements vreckoUtils::IMenuComponent.

void vreckoUtils::MenuRoot::addAttribute | ( | const std::string & | name,
 |  | double | value
 | ) |  |
inline
virtual std::string vreckoUtils::MenuRoot::getCaption ( )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::MenuRoot::getName ( void )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

bool vreckoUtils::MenuRoot::removeAttribute ( const std::string & name )
inline
std::string MenuRoot::toXMLString ( )
virtual

Implements vreckoUtils::IMenuComponent.

Member Data Documentation

std::map<std::string, double> vreckoUtils::MenuRoot::_attributes
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::Menu Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Menu
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::Menu Class Reference

#include <Menu.h>

Inheritance diagram for vreckoUtils::Menu:
vreckoUtils::MenuBase vreckoUtils::IMenuComponent

Public Member Functions

Menu (string name="", string caption="")
virtual std::string | toXMLString ()
virtual std::string | getName ()
virtual std::string | getCaption ()
virtual void | accept (MenuVisitor &visitor)
- Public Member Functions inherited from vreckoUtils::MenuBase
void | addChild (osg::ref_ptr< IMenuComponent > menuComponent)
void | removeChild (int index)
IMenuComponent * | getChild (u_int index)
- Public Member Functions inherited from vreckoUtils::IMenuComponent
virtual | ~IMenuComponent ()

Protected Attributes

std::string | _menuName
std::string | _menuCaption
- Protected Attributes inherited from vreckoUtils::MenuBase
std::vector< osg::ref_ptr
< IMenuComponent > > 		_items

Constructor & Destructor Documentation

vreckoUtils::Menu::Menu | ( | string | name = "",
 |  | string | caption = ""
 | ) |  |
inline

Member Function Documentation

void Menu::accept ( MenuVisitor & visitor )
virtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::Menu::getCaption ( )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::Menu::getName ( void )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

std::string Menu::toXMLString ( )
virtual

Implements vreckoUtils::IMenuComponent.

Member Data Documentation

std::string vreckoUtils::Menu::_menuCaption
protected
std::string vreckoUtils::Menu::_menuName
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuItem Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuItem
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::MenuItem Class Reference

#include <Menu.h>

Inheritance diagram for vreckoUtils::MenuItem:
vreckoUtils::IMenuComponent

Public Member Functions

MenuItem (string name, string caption, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f))
MenuItem (string name, string caption, osg::Vec4 color)
virtual std::string | toXMLString ()
virtual std::string | getName ()
virtual std::string | getCaption ()
virtual void | accept (MenuVisitor &visitor)
- Public Member Functions inherited from vreckoUtils::IMenuComponent
virtual | ~IMenuComponent ()

Protected Attributes

std::string | _itemName
std::string | _itemCaption
osg::Vec3 | _color

Constructor & Destructor Documentation

vreckoUtils::MenuItem::MenuItem | ( | string | name,
 |  | string | caption,
 |  | osg::Vec3 | color = osg::Vec3(0.9f, 0.8f, 0.8f)
 | ) |  |
inline
vreckoUtils::MenuItem::MenuItem | ( | string | name,
 |  | string | caption,
 |  | osg::Vec4 | color
 | ) |  |
inline

Member Function Documentation

void MenuItem::accept ( MenuVisitor & visitor )
virtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::MenuItem::getCaption ( )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::MenuItem::getName ( void )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

std::string MenuItem::toXMLString ( )
virtual

Implements vreckoUtils::IMenuComponent.

Member Data Documentation

osg::Vec3 vreckoUtils::MenuItem::_color
protected
std::string vreckoUtils::MenuItem::_itemCaption
protected
std::string vreckoUtils::MenuItem::_itemName
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuSlider Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuSlider
Public Member Functions | Protected Attributes | List of all members
vreckoUtils::MenuSlider Class Reference

#include <Menu.h>

Inheritance diagram for vreckoUtils::MenuSlider:
vreckoUtils::IMenuComponent

Public Member Functions

MenuSlider (string name, string caption, double from, double to, double value, bool onlyInt, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f))
virtual std::string | toXMLString ()
virtual std::string | getName ()
virtual std::string | getCaption ()
double | getValue () const
void | setValue (double val)
virtual void | accept (MenuVisitor &visitor)
- Public Member Functions inherited from vreckoUtils::IMenuComponent
virtual | ~IMenuComponent ()

Protected Attributes

std::string | _sliderName
std::string | _sliderCaption
osg::Vec3 | _color
double | _from
double | _to
double | _value
bool | _onlyInt

Constructor & Destructor Documentation

vreckoUtils::MenuSlider::MenuSlider | ( | string | name,
 |  | string | caption,
 |  | double | from,
 |  | double | to,
 |  | double | value,
 |  | bool | onlyInt,
 |  | osg::Vec3 | color = osg::Vec3(0.9f, 0.8f, 0.8f)
 | ) |  |
inline

Member Function Documentation

void MenuSlider::accept ( MenuVisitor & visitor )
virtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::MenuSlider::getCaption ( )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

virtual std::string vreckoUtils::MenuSlider::getName ( void )
inlinevirtual

Implements vreckoUtils::IMenuComponent.

double vreckoUtils::MenuSlider::getValue ( ) const
inline
void vreckoUtils::MenuSlider::setValue ( double val )
inline
std::string MenuSlider::toXMLString ( )
virtual

Implements vreckoUtils::IMenuComponent.

Member Data Documentation

osg::Vec3 vreckoUtils::MenuSlider::_color
protected
double vreckoUtils::MenuSlider::_from
protected
bool vreckoUtils::MenuSlider::_onlyInt
protected
std::string vreckoUtils::MenuSlider::_sliderCaption
protected
std::string vreckoUtils::MenuSlider::_sliderName
protected
double vreckoUtils::MenuSlider::_to
protected
double vreckoUtils::MenuSlider::_value
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::MenuVisitor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuVisitor
Public Member Functions | List of all members
vreckoUtils::MenuVisitor Class Reference

#include <Menu.h>

Public Member Functions

MenuVisitor ()
virtual | ~MenuVisitor ()
virtual void | apply (IMenuComponent &)
virtual void | apply (Menu &)
virtual void | apply (MenuRoot &)
virtual void | apply (MenuItem &)
virtual void | apply (MenuSlider &)

Constructor & Destructor Documentation

vreckoUtils::MenuVisitor::MenuVisitor ( )
inline
virtual vreckoUtils::MenuVisitor::~MenuVisitor ( )
inlinevirtual

Member Function Documentation

virtual void vreckoUtils::MenuVisitor::apply ( IMenuComponent & )
inlinevirtual
virtual void vreckoUtils::MenuVisitor::apply ( Menu & )
inlinevirtual
virtual void vreckoUtils::MenuVisitor::apply ( MenuRoot & )
inlinevirtual
virtual void vreckoUtils::MenuVisitor::apply ( MenuItem & )
inlinevirtual
virtual void vreckoUtils::MenuVisitor::apply ( MenuSlider & )
inlinevirtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::Observer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Observer
Public Member Functions | Protected Member Functions | List of all members
vreckoUtils::Observer Class Referenceabstract

#include <Observer.h>

Inheritance diagram for vreckoUtils::Observer:
APDYNAMICART::Ctrl_StringSculptures

Public Member Functions

virtual void notify (Observable *object, void *userData)=0

Protected Member Functions

Observer ()

Constructor & Destructor Documentation

vreckoUtils::Observer::Observer ( )
inlineprotected

Member Function Documentation

virtual void vreckoUtils::Observer::notify | ( | Observable * | object,
 |  | void * | userData
 | ) |  |
pure virtual

Implemented in APDYNAMICART::Ctrl_StringSculptures.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Observer.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: vreckoUtils::Observable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Observable
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
vreckoUtils::Observable Class Reference

#include <Observer.h>

Inheritance diagram for vreckoUtils::Observable:
APDYNAMICART::DATool APDYNAMICART::PLControllerTool APDYNAMICART::PLMagnetTool APDYNAMICART::PLNestTool APDYNAMICART::ToolBrush APDYNAMICART::ToolEraser APDYNAMICART::ToolHook APDYNAMICART::ToolMagicWand APDYNAMICART::ToolRotation APDYNAMICART::ToolSelector APDYNAMICART::ToolSlice APDYNAMICART::ToolTongs

Public Member Functions

void | addObserver (Observer *observer)
void | removeObserver (Observer *observer)
void | notifyObservers (void *userData=NULL)

Protected Member Functions

Observable ()

Protected Attributes

std::vector< Observer * > _observers

Constructor & Destructor Documentation

vreckoUtils::Observable::Observable ( )
inlineprotected

Member Function Documentation

void vreckoUtils::Observable::addObserver ( Observer * observer )
inline
void vreckoUtils::Observable::notifyObservers ( void * userData = NULL )
inline
void vreckoUtils::Observable::removeObserver ( Observer * observer )
inline

Member Data Documentation

std::vector<Observer*> vreckoUtils::Observable::_observers
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Observer.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::InPlaceParserInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • InPlaceParserInterface
Public Member Functions | List of all members
WAVEFRONT::InPlaceParserInterface Class Referenceabstract
Inheritance diagram for WAVEFRONT::InPlaceParserInterface:
WAVEFRONT::OBJ

Public Member Functions

virtual int ParseLine (int lineno, int argc, const char **argv)=0

Member Function Documentation

virtual int WAVEFRONT::InPlaceParserInterface::ParseLine | ( | int | lineno,
 |  | int | argc,
 |  | const char ** | argv
 | ) |  |
pure virtual

Implemented in WAVEFRONT::OBJ.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::InPlaceParser Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • InPlaceParser
Public Member Functions | List of all members
WAVEFRONT::InPlaceParser Class Reference

Public Member Functions

InPlaceParser (void)
InPlaceParser (char *data, int len)
InPlaceParser (const char *fname)
~InPlaceParser (void)
void | Init (void)
void | SetFile (const char *fname)
void | SetSourceData (char *data, int len)
int | Parse (InPlaceParserInterface *callback)
int | ProcessLine (int lineno, char *line, InPlaceParserInterface *callback)
const char ** | GetArglist (char *source, int &count)
void | SetHardSeparator (char c)
void | SetHard (char c)
void | SetCommentSymbol (char c)
void | ClearHardSeparator (char c)
void | DefaultSymbols (void)
bool | EOS (char c)
void | SetQuoteChar (char c)

Constructor & Destructor Documentation

WAVEFRONT::InPlaceParser::InPlaceParser ( void )
inline
WAVEFRONT::InPlaceParser::InPlaceParser | ( | char * | data,
 |  | int | len
 | ) |  |
inline
WAVEFRONT::InPlaceParser::InPlaceParser ( const char * fname )
inline
WAVEFRONT::InPlaceParser::~InPlaceParser ( void )

Member Function Documentation

void WAVEFRONT::InPlaceParser::ClearHardSeparator ( char c )
inline
void WAVEFRONT::InPlaceParser::DefaultSymbols ( void )
bool WAVEFRONT::InPlaceParser::EOS ( char c )
inline
const char ** WAVEFRONT::InPlaceParser::GetArglist | ( | char * | source,
 |  | int & | count
 | ) |  |
void WAVEFRONT::InPlaceParser::Init ( void )
inline
int WAVEFRONT::InPlaceParser::Parse ( InPlaceParserInterface * callback )
int WAVEFRONT::InPlaceParser::ProcessLine | ( | int | lineno,
 |  | char * | line,
 |  | InPlaceParserInterface * | callback
 | ) |  |
void WAVEFRONT::InPlaceParser::SetCommentSymbol ( char c )
inline
void WAVEFRONT::InPlaceParser::SetFile ( const char * fname )
void WAVEFRONT::InPlaceParser::SetHard ( char c )
inline
void WAVEFRONT::InPlaceParser::SetHardSeparator ( char c )
inline
void WAVEFRONT::InPlaceParser::SetQuoteChar ( char c )
inline
void WAVEFRONT::InPlaceParser::SetSourceData | ( | char * | data,
 |  | int | len
 | ) |  |
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::GeometryVertex Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • GeometryVertex
Public Attributes | List of all members
WAVEFRONT::GeometryVertex Class Reference

Public Attributes

float | mPos [3]
float | mNormal [3]
float | mTexel [2]

Member Data Documentation

float WAVEFRONT::GeometryVertex::mNormal[3]
float WAVEFRONT::GeometryVertex::mPos[3]
float WAVEFRONT::GeometryVertex::mTexel[2]
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::GeometryInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • GeometryInterface
Public Member Functions | List of all members
WAVEFRONT::GeometryInterface Class Reference
Inheritance diagram for WAVEFRONT::GeometryInterface:
WAVEFRONT::BuildMesh

Public Member Functions

virtual void NodeTriangle (const GeometryVertex *v1, const GeometryVertex *v2, const GeometryVertex *v3, bool textured)

Member Function Documentation

virtual void WAVEFRONT::GeometryInterface::NodeTriangle | ( | const GeometryVertex * | v1,
 |  | const GeometryVertex * | v2,
 |  | const GeometryVertex * | v3,
 |  | bool | textured
 | ) |  |
inlinevirtual

Reimplemented in WAVEFRONT::BuildMesh.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::OBJ Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • OBJ
Public Member Functions | List of all members
WAVEFRONT::OBJ Class Reference
Inheritance diagram for WAVEFRONT::OBJ:
WAVEFRONT::InPlaceParserInterface

Public Member Functions

int | LoadMesh (const char *fname, GeometryInterface *callback, bool textured)
int | ParseLine (int lineno, int argc, const char **argv)

Member Function Documentation

int WAVEFRONT::OBJ::LoadMesh | ( | const char * | fname,
 |  | GeometryInterface * | callback,
 |  | bool | textured
 | ) |  |
int WAVEFRONT::OBJ::ParseLine | ( | int | lineno,
 |  | int | argc,
 |  | const char ** | argv
 | ) |  |
virtual

Implements WAVEFRONT::InPlaceParserInterface.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WAVEFRONT::BuildMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • BuildMesh
Public Member Functions | List of all members
WAVEFRONT::BuildMesh Class Reference
Inheritance diagram for WAVEFRONT::BuildMesh:
WAVEFRONT::GeometryInterface

Public Member Functions

int | GetIndex (const float *p, const float *texCoord)
virtual void | NodeTriangle (const GeometryVertex *v1, const GeometryVertex *v2, const GeometryVertex *v3, bool textured)
const FloatVector & | GetVertices (void) const
const FloatVector & | GetTexCoords (void) const
const IntVector & | GetIndices (void) const

Member Function Documentation

int WAVEFRONT::BuildMesh::GetIndex | ( | const float * | p,
 |  | const float * | texCoord
 | ) |  |
inline
const IntVector& WAVEFRONT::BuildMesh::GetIndices ( void ) const
inline
const FloatVector& WAVEFRONT::BuildMesh::GetTexCoords ( void ) const
inline
const FloatVector& WAVEFRONT::BuildMesh::GetVertices ( void ) const
inline
virtual void WAVEFRONT::BuildMesh::NodeTriangle | ( | const GeometryVertex * | v1,
 |  | const GeometryVertex * | v2,
 |  | const GeometryVertex * | v3,
 |  | bool | textured
 | ) |  |
inlinevirtual

Reimplemented from WAVEFRONT::GeometryInterface.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry::WG_Geometry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Geometry
Public Member Functions | Static Public Member Functions | List of all members
WGeometry::WG_Geometry Class Reference

#include <Geometry.h>

Public Member Functions

WG_Geometry ()
~WG_Geometry ()

Static Public Member Functions

static bool | getCrossingPoint (osg::Vec2 &destPoint, osg::Vec2 pPoint, osg::Vec2 pNormal, osg::Vec2 rPoint, osg::Vec2 rNormal, bool justStroke)
static bool | barycentricTest (osg::Vec2 P, osg::Vec2 A, osg::Vec2 B, osg::Vec2 C)
static float | getAngle (osg::Vec2 &vector)

Constructor & Destructor Documentation

WGeometry::WG_Geometry::WG_Geometry ( )
inline
WGeometry::WG_Geometry::~WG_Geometry ( )
inline

Member Function Documentation

static bool WGeometry::WG_Geometry::barycentricTest | ( | osg::Vec2 | P,
 |  | osg::Vec2 | A,
 |  | osg::Vec2 | B,
 |  | osg::Vec2 | C
 | ) |  |
inlinestatic
static float WGeometry::WG_Geometry::getAngle ( osg::Vec2 & vector )
inlinestatic
static bool WGeometry::WG_Geometry::getCrossingPoint | ( | osg::Vec2 & | destPoint,
 |  | osg::Vec2 | pPoint,
 |  | osg::Vec2 | pNormal,
 |  | osg::Vec2 | rPoint,
 |  | osg::Vec2 | rNormal,
 |  | bool | justStroke
 | ) |  |
inlinestatic
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry::WG_Vertices Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Vertices
Public Member Functions | List of all members
WGeometry::WG_Vertices Class Reference

#include <Geometry.h>

Public Member Functions

WG_Vertices ()
virtual | ~WG_Vertices ()
void | setTopCWVertex (osg::Vec3 P)
osg::Vec3 | getTopCWVertex ()
void | setTopCCWVertex (osg::Vec3 P)
osg::Vec3 | getTopCCWVertex ()
void | setBottomCWVertex (osg::Vec3 P)
osg::Vec3 | getBottomCWVertex ()
void | setBottomCCWVertex (osg::Vec3 P)
osg::Vec3 | getBottomCCWVertex ()
void | setNormalCWVertex (osg::Vec2 P)
osg::Vec2 | getNormalCWVertex ()
void | setNormalCCWVertex (osg::Vec2 P)
osg::Vec2 | getNormalCCWVertex ()
void | setValidVertices (bool valid)
bool | areValidVertices ()

Constructor & Destructor Documentation

WGeometry::WG_Vertices::WG_Vertices ( )
inline
virtual WGeometry::WG_Vertices::~WG_Vertices ( )
inlinevirtual

Member Function Documentation

bool WGeometry::WG_Vertices::areValidVertices ( )
inline
osg::Vec3 WGeometry::WG_Vertices::getBottomCCWVertex ( )
inline
osg::Vec3 WGeometry::WG_Vertices::getBottomCWVertex ( )
inline
osg::Vec2 WGeometry::WG_Vertices::getNormalCCWVertex ( )
inline
osg::Vec2 WGeometry::WG_Vertices::getNormalCWVertex ( )
inline
osg::Vec3 WGeometry::WG_Vertices::getTopCCWVertex ( )
inline
osg::Vec3 WGeometry::WG_Vertices::getTopCWVertex ( )
inline
void WGeometry::WG_Vertices::setBottomCCWVertex ( osg::Vec3 P )
inline
void WGeometry::WG_Vertices::setBottomCWVertex ( osg::Vec3 P )
inline
void WGeometry::WG_Vertices::setNormalCCWVertex ( osg::Vec2 P )
inline
void WGeometry::WG_Vertices::setNormalCWVertex ( osg::Vec2 P )
inline
void WGeometry::WG_Vertices::setTopCCWVertex ( osg::Vec3 P )
inline
void WGeometry::WG_Vertices::setTopCWVertex ( osg::Vec3 P )
inline
void WGeometry::WG_Vertices::setValidVertices ( bool valid )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry::WG_Point Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Point
Public Member Functions | List of all members
WGeometry::WG_Point Class Reference

#include <Geometry.h>

Inheritance diagram for WGeometry::WG_Point:

Public Member Functions

WG_Point (osg::Vec2 position, float height=RE_DEFAULT_HEIGHT)
virtual | ~WG_Point ()
void | setPosition (osg::Vec2 position)
osg::Vec2 | getPosition ()
float | getHeight ()
void | addWall (WG_Wall *wall, PointType connectionPointType, bool compute=true)
void | removeWall (WG_Wall *wall)
std::vector< std::pair
< osg::ref_ptr< WG_Wall >
, PointType > > * 		getWalls ()
void | setId (unsigned int i)
unsigned int | getId ()
void | setIndexTop (unsigned int i)
unsigned int | getIndexTop ()
void | setIndexBottom (unsigned int i)
unsigned int | getIndexBottom ()
std::vector< osg::Vec3 > * | getPlusVertices ()
std::vector< osg::Vec3 > * | getPlusNormals ()
std::vector< osg::Vec3 > * | getPlusColors ()
bool | getWallNeighbours (WG_Wall *wall, std::pair< osg::ref_ptr< WG_Wall >, PointType > &wallCW, std::pair< osg::ref_ptr< WG_Wall >, PointType > &wallCCW)

Constructor & Destructor Documentation

WGeometry::WG_Point::WG_Point | ( | osg::Vec2 | position,
 |  | float | height = RE_DEFAULT_HEIGHT
 | ) |  |
inline
virtual WGeometry::WG_Point::~WG_Point ( )
inlinevirtual

Member Function Documentation

void WGeometry::WG_Point::addWall | ( | WG_Wall * | wall,
 |  | PointType | connectionPointType,
 |  | bool | compute = true
 | ) |  |
float WGeometry::WG_Point::getHeight ( )
inline
unsigned int WGeometry::WG_Point::getId ( )
inline
unsigned int WGeometry::WG_Point::getIndexBottom ( )
inline
unsigned int WGeometry::WG_Point::getIndexTop ( )
inline
std::vector<osg::Vec3>* WGeometry::WG_Point::getPlusColors ( )
inline
std::vector<osg::Vec3>* WGeometry::WG_Point::getPlusNormals ( )
inline
std::vector<osg::Vec3>* WGeometry::WG_Point::getPlusVertices ( )
inline
osg::Vec2 WGeometry::WG_Point::getPosition ( )
inline
bool WGeometry::WG_Point::getWallNeighbours | ( | WG_Wall * | wall,
 |  | std::pair< osg::ref_ptr< WG_Wall >, PointType > & | wallCW,
 |  | std::pair< osg::ref_ptr< WG_Wall >, PointType > & | wallCCW
 | ) |  |
std::vector<std::pair<osg::ref_ptr<WG_Wall>, PointType> >* WGeometry::WG_Point::getWalls ( )
inline
void WGeometry::WG_Point::removeWall ( WG_Wall * wall )
void WGeometry::WG_Point::setId ( unsigned int i )
inline
void WGeometry::WG_Point::setIndexBottom ( unsigned int i )
inline
void WGeometry::WG_Point::setIndexTop ( unsigned int i )
inline
void WGeometry::WG_Point::setPosition ( osg::Vec2 position )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry::WG_Hole Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Hole
Public Member Functions | List of all members
WGeometry::WG_Hole Class Reference

#include <Geometry.h>

Public Member Functions

WG_Hole (float position, float y, float height, float width, HoleType type)
~WG_Hole ()
void | setPosition (float position)
float | getPosition ()
void | setY (float y)
float | getY ()
void | setHeight (float height)
float | getHeight ()
void | setWidth (float width)
float | getWidth ()
void | setType (HoleType type)
HoleType getType ()
WG_Vertices * getQVertices ()
WG_Vertices * getRVertices ()

Constructor & Destructor Documentation

WGeometry::WG_Hole::WG_Hole | ( | float | position,
 |  | float | y,
 |  | float | height,
 |  | float | width,
 |  | HoleType | type
 | ) |  |
inline
WGeometry::WG_Hole::~WG_Hole ( )
inline

Member Function Documentation

float WGeometry::WG_Hole::getHeight ( )
inline
float WGeometry::WG_Hole::getPosition ( )
inline
WG_Vertices* WGeometry::WG_Hole::getQVertices ( )
inline
WG_Vertices* WGeometry::WG_Hole::getRVertices ( )
inline
HoleType WGeometry::WG_Hole::getType ( void )
inline
float WGeometry::WG_Hole::getWidth ( )
inline
float WGeometry::WG_Hole::getY ( )
inline
void WGeometry::WG_Hole::setHeight ( float height )
inline
void WGeometry::WG_Hole::setPosition ( float position )
inline
void WGeometry::WG_Hole::setType ( HoleType type )
inline
void WGeometry::WG_Hole::setWidth ( float width )
inline
void WGeometry::WG_Hole::setY ( float y )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: WGeometry::WG_Wall Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Wall
Classes | Public Member Functions | List of all members
WGeometry::WG_Wall Class Reference

#include <Geometry.h>

Inheritance diagram for WGeometry::WG_Wall:

Public Member Functions

WG_Wall (WG_Point *qPoint, WG_Point *rPoint, bool compute=true)
virtual | ~WG_Wall ()
void | setPoints (WG_Point *qPoint, WG_Point *rPoint)
void | setPoint (WG_Point *point, PointType type)
WG_Point * getPoint (PointType type)
osg::ref_ptr< WG_Point > | getPointRef (PointType type)
osg::Vec2 | getVector (PointType type)
float | getAngle (PointType type)
WG_Vertices * getVertices (PointType type)
void | setColor (osg::Vec3 color, PointType type)
osg::Vec3 | getColor (PointType type)
void | setId (unsigned int i)
unsigned int | getId ()
void | setFlag (int flag)
int | getFlag ()
void | setTopNormal (osg::Vec3 n)
osg::Vec3 | getTopNormal ()
void | setBottomNormal (osg::Vec3 n)
osg::Vec3 | getBottomNormal ()
void | setFaceNormal (osg::Vec3 n, PointType type)
osg::Vec3 | getFaceNormal (PointType type)
std::vector< WG_Hole > * | getHoles ()
void | computeAttrVectorsAndAngles ()
bool | areAnglesComputed ()
void | computeAttrVertices (PointType type)
void | computeAttrVertices ()
bool | computeAttrNormals ()
void | computeHoleVertices ()

Constructor & Destructor Documentation

WGeometry::WG_Wall::WG_Wall | ( | WG_Point * | qPoint,
 |  | WG_Point * | rPoint,
 |  | bool | compute = true
 | ) |  |
inline
virtual WGeometry::WG_Wall::~WG_Wall ( )
inlinevirtual

Member Function Documentation

bool WGeometry::WG_Wall::areAnglesComputed ( )
inline
bool WGeometry::WG_Wall::computeAttrNormals ( )
void WGeometry::WG_Wall::computeAttrVectorsAndAngles ( )
void WGeometry::WG_Wall::computeAttrVertices ( PointType type )
void WGeometry::WG_Wall::computeAttrVertices ( )
inline
void WGeometry::WG_Wall::computeHoleVertices ( )
float WGeometry::WG_Wall::getAngle ( PointType type )
inline
osg::Vec3 WGeometry::WG_Wall::getBottomNormal ( )
inline
osg::Vec3 WGeometry::WG_Wall::getColor ( PointType type )
inline
osg::Vec3 WGeometry::WG_Wall::getFaceNormal ( PointType type )
inline
int WGeometry::WG_Wall::getFlag ( )
inline
std::vector<WG_Hole>* WGeometry::WG_Wall::getHoles ( )
inline
unsigned int WGeometry::WG_Wall::getId ( )
inline
WG_Point* WGeometry::WG_Wall::getPoint ( PointType type )
inline
osg::ref_ptr<WG_Point> WGeometry::WG_Wall::getPointRef ( PointType type )
inline
osg::Vec3 WGeometry::WG_Wall::getTopNormal ( )
inline
osg::Vec2 WGeometry::WG_Wall::getVector ( PointType type )
inline
WG_Vertices* WGeometry::WG_Wall::getVertices ( PointType type )
inline
void WGeometry::WG_Wall::setBottomNormal ( osg::Vec3 n )
inline
void WGeometry::WG_Wall::setColor | ( | osg::Vec3 | color,
 |  | PointType | type
 | ) |  |
inline
void WGeometry::WG_Wall::setFaceNormal | ( | osg::Vec3 | n,
 |  | PointType | type
 | ) |  |
inline
void WGeometry::WG_Wall::setFlag ( int flag )
inline
void WGeometry::WG_Wall::setId ( unsigned int i )
inline
void WGeometry::WG_Wall::setPoint | ( | WG_Point * | point,
 |  | PointType | type
 | ) |  |
inline
void WGeometry::WG_Wall::setPoints | ( | WG_Point * | qPoint,
 |  | WG_Point * | rPoint
 | ) |  |
inline
void WGeometry::WG_Wall::setTopNormal ( osg::Vec3 n )
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: AABoundingBox Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
AABoundingBox Class Reference

Represents a bounding box (a sphere, actually) of the object which wraps the object in it. More...

#include <BoundingVol.h>

Public Attributes

osg::Vec3f | min
osg::Vec3f | max
float | radius
float | side
float | halfside

Detailed Description

Represents a bounding box (a sphere, actually) of the object which wraps the object in it.

Member Data Documentation

float AABoundingBox::halfside
osg::Vec3f AABoundingBox::max
osg::Vec3f AABoundingBox::min
float AABoundingBox::radius
float AABoundingBox::side
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/BoundingVol.h
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: AddObserver Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AddObserver Class Referenceabstract

rozhrani pro objekty, ktere zajima udalost Add More...

#include <ModelManager.h>

Inheritance diagram for AddObserver:
Cache

Public Member Functions

AddObserver ()
virtual void AddUpdate (string modelFilename, ModelType modelType)=0

Detailed Description

rozhrani pro objekty, ktere zajima udalost Add

Constructor & Destructor Documentation

AddObserver::AddObserver ( )
inline

Member Function Documentation

virtual void AddObserver::AddUpdate | ( | string | modelFilename,
 |  | ModelType | modelType
 | ) |  |
pure virtual

metoda, ktera se zavola, nastane-li udalost Add v pozorovanem objektu modelFilename - nazev modelu, ktery se pridal, modelType - typ modelu

Implemented in Cache.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: AllCloudsUpdateCallBack Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
AllCloudsUpdateCallBack Struct Reference

Structure containing camera data which is common for all of the clouds and overloaded callback method which is called once per frame. More...

#include <OSGCloudWrap.h>

Inheritance diagram for AllCloudsUpdateCallBack:

Public Member Functions

AllCloudsUpdateCallBack ()
AllCloudsUpdateCallBack (osg::ref_ptr< CloudDataType > data)
AllCloudsUpdateCallBack (const AllCloudsUpdateCallBack &, const osg::CopyOp &)
META_Object (osgCloud, AllCloudsUpdateCallBack) virtual void operator()(const osg
Cloud::SetViewMatrix (camera.getViewMatrix())
g_Clouds Update (cloudData->getCameraPos(), cloudData->getCameraView(), cloudData->getCameraUp())

Public Attributes

osg::ref_ptr< CloudDataType > cloudData

Detailed Description

Structure containing camera data which is common for all of the clouds and overloaded callback method which is called once per frame.

Constructor & Destructor Documentation

AllCloudsUpdateCallBack::AllCloudsUpdateCallBack ( )
inline
AllCloudsUpdateCallBack::AllCloudsUpdateCallBack ( osg::ref_ptr< CloudDataType > data )
inline
AllCloudsUpdateCallBack::AllCloudsUpdateCallBack | ( | const AllCloudsUpdateCallBack & | ,
 |  | const osg::CopyOp & |
 | ) |  |
inline

Member Function Documentation

AllCloudsUpdateCallBack::Cloud::SetViewMatrix ( camera. getViewMatrix() )
AllCloudsUpdateCallBack::META_Object | ( | osgCloud | ,
 |  | AllCloudsUpdateCallBack |
 | ) |  | const
 inline
g_Clouds AllCloudsUpdateCallBack::Update | ( | cloudData-> | getCameraPos(),
 |  | cloudData-> | getCameraView(),
 |  | cloudData-> | getCameraUp()
 | ) |  |

Member Data Documentation

osg::ref_ptr<CloudDataType> AllCloudsUpdateCallBack::cloudData
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGCloudWrap.h
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: angle_3D Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
angle_3D Struct Reference

#include <arm.h>

Public Attributes

angle x
angle y
angle z

Member Data Documentation

angle angle_3D::x
angle angle_3D::y
angle angle_3D::z
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/arm.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: AnimatedGeometryState Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
AnimatedGeometryState Struct Reference

uchovava informace o animovanem Cal3D modelu, jeho data v pameti a pocet referenci More...

#include <ModelManager.h>

Public Member Functions

AnimatedGeometryState ()
AnimatedGeometryState (osgCal::CoreModel *cm)
osg::ref_ptr< osgCal::CoreModel > | GetAnimatedGeometry ()
vrati data modelu More...
void | RemoveGeometry ()
smaze data modelu More...
int | Count ()
vrati pocet referenci na model More...
void | AddReference ()
zvysi pocet referenci na model o 1 More...
void | RemoveReference ()
snizi pocet referenci na model o 1 More...

Detailed Description

uchovava informace o animovanem Cal3D modelu, jeho data v pameti a pocet referenci

Constructor & Destructor Documentation

AnimatedGeometryState::AnimatedGeometryState ( )
inline
AnimatedGeometryState::AnimatedGeometryState ( osgCal::CoreModel * cm )
inline

Member Function Documentation

void AnimatedGeometryState::AddReference ( )
inline

zvysi pocet referenci na model o 1

int AnimatedGeometryState::Count ( )
inline

vrati pocet referenci na model

osg::ref_ptr<osgCal::CoreModel> AnimatedGeometryState::GetAnimatedGeometry ( )
inline

vrati data modelu

void AnimatedGeometryState::RemoveGeometry ( )
inline

smaze data modelu

void AnimatedGeometryState::RemoveReference ( )
inline

snizi pocet referenci na model o 1

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Arm Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
Arm Class Reference

#include <arm.h>

Public Member Functions

arm_result homePos ()
length_3D getStylusTip ()
angle_3D getStylusDir ()
float | getT (int, int)
int | getButt ()
void | init ()
arm_result | connect (const char *port)
void | disconnect ()
arm_result stylus6DOFupdate ()
arm_result stylus3DOFupdate ()
arm_result joint_update3 ()
arm_result joint_update6 ()
arm_result full_update ()
arm_result checkBckg ()
void | stylus6DOFbckg ()
void | stylus3DOFbckg ()
void | jointBckg3 ()
void | jointBckg6 ()
void | fullBckg ()
arm_result check_motion ()
void | end_motion ()
void | stylus6DOFmotion (int motion_thresh, int packet_delay, int btns_active)
void | stylus3DOFmotion (int motion_thresh, int packet_delay, int btns_active)
void | installSimple ()
void | calcStylus6DOF ()
void | calcStylus3DOF ()
void | calcTrig ()
void | calcJoints ()
void | calcFull ()
void | calcNothing ()
void | calcT ()
void | calcM ()
void | calcStylusDir ()
void | mul4x4 (matrix_4 M1, matrix_4 M2, matrix_4 X)
void | identity4x4 (matrix_4 M)
void | assign4x4 (matrix_4 to, matrix_4 from)
arm_result convertParams ()
arm_result convertExtParams ()
int | paramsDH0_5 ()
void | calcParams ()
arm_result getConstants ()
void | startMotion (int num_encoders, int motion_thresh, int packet_delay, int btns_active)

Public Attributes

Hci hci

Member Function Documentation

void Arm::assign4x4 | ( | matrix_4 | to,
 |  | matrix_4 | from
 | ) |  |
void Arm::calcFull ( )
void Arm::calcJoints ( )
void Arm::calcM ( )
void Arm::calcNothing ( )
void Arm::calcParams ( )
void Arm::calcStylus3DOF ( )
void Arm::calcStylus6DOF ( )
void Arm::calcStylusDir ( )
void Arm::calcT ( )
void Arm::calcTrig ( )
arm_result Arm::check_motion ( )
arm_result Arm::checkBckg ( )
arm_result Arm::connect ( const char * port )
arm_result Arm::convertExtParams ( )
arm_result Arm::convertParams ( )
void Arm::disconnect ( )
void Arm::end_motion ( )
arm_result Arm::full_update ( )
void Arm::fullBckg ( )
int Arm::getButt ( )
arm_result Arm::getConstants ( )
angle_3D Arm::getStylusDir ( )
length_3D Arm::getStylusTip ( )
float Arm::getT | ( | int | a,
 |  | int | b
 | ) |  |
arm_result Arm::homePos ( )
void Arm::identity4x4 ( matrix_4 M )
void Arm::init ( void )
void Arm::installSimple ( )
arm_result Arm::joint_update3 ( )
arm_result Arm::joint_update6 ( )
void Arm::jointBckg3 ( )
void Arm::jointBckg6 ( )
void Arm::mul4x4 | ( | matrix_4 | M1,
 |  | matrix_4 | M2,
 |  | matrix_4 | X
 | ) |  |
int Arm::paramsDH0_5 ( )
void Arm::startMotion | ( | int | num_encoders,
 |  | int | motion_thresh,
 |  | int | packet_delay,
 |  | int | btns_active
 | ) |  |
void Arm::stylus3DOFbckg ( )
void Arm::stylus3DOFmotion | ( | int | motion_thresh,
 |  | int | packet_delay,
 |  | int | btns_active
 | ) |  |
arm_result Arm::stylus3DOFupdate ( )
void Arm::stylus6DOFbckg ( )
void Arm::stylus6DOFmotion | ( | int | motion_thresh,
 |  | int | packet_delay,
 |  | int | btns_active
 | ) |  |
arm_result Arm::stylus6DOFupdate ( )

Member Data Documentation

Hci Arm::hci
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/arm.h
  • C:/Documents/School/OSG/VRECKO/src/vrecko/Arm.cpp
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Arm.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BasicPreloaderHeuristic Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
BasicPreloaderHeuristic Class Reference

#include <PreloaderHeuristic.h>

Inheritance diagram for BasicPreloaderHeuristic:
PreloaderHeuristic

Public Member Functions

BasicPreloaderHeuristic ()
void | Update (void)
jeden krok heuristiky More...
void | Restart (void)
restart heuristiky More...
- Public Member Functions inherited from PreloaderHeuristic
~PreloaderHeuristic ()
void | SetWorldRoot (BlockUpdater *_rootBlockUpdater)
nastavi updater korenoveho bloku sceny More...
virtual list
< PreloaderToLoadInfo * > 		GetObjectsToPreload (void)
vrati seznam nalezenych objektu More...
virtual bool | SearchFinnished (void)
vrati, jestli je vyhledavani ukonceno More...

Additional Inherited Members

- Protected Attributes inherited from PreloaderHeuristic
BlockUpdater * rootBlockUpdater
list< PreloaderToLoadInfo * > | objectsToPreload
bool | searchFinnished

Detailed Description

Jednoducha heuristika, zalozena na uhlu zmeny pohybu od predchoziho pohybu, jeho velikosti a smeru V kazdem kroku ziska aktualni pozici pozorovatele, vypocte vektor zmeny z minule pozice, ziska uhel, ktery svira s minulym vektorem, vypocte velikost tohoto vektoru a pozici vzhledem k primce definovane minulym vektorem. Vypocita ze vsech takto sejmutych dat jejich prumerne hodnoty. Na jejich zaklade vypocte predpokladane nasledujici pozice pozorovatele.

Constructor & Destructor Documentation

BasicPreloaderHeuristic::BasicPreloaderHeuristic ( )
inline

Member Function Documentation

void BasicPreloaderHeuristic::Restart ( void )
inlinevirtual

restart heuristiky

Reimplemented from PreloaderHeuristic.

void BasicPreloaderHeuristic::Update ( void )
virtual

jeden krok heuristiky

aktualizace heuristiky, jeden krok

Reimplemented from PreloaderHeuristic.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/PreloaderHeuristic.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BCLoaderErrorHandler Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
BCLoaderErrorHandler Class Reference
Inheritance diagram for BCLoaderErrorHandler:

Public Member Functions

BCLoaderErrorHandler ()
~BCLoaderErrorHandler ()
bool | getSawErrors () const
bool | handleError (const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError)
void | resetErrors ()

Constructor & Destructor Documentation

BCLoaderErrorHandler::BCLoaderErrorHandler ( )
BCLoaderErrorHandler::~BCLoaderErrorHandler ( )

Member Function Documentation

bool BCLoaderErrorHandler::getSawErrors ( ) const
inline
bool BCLoaderErrorHandler::handleError ( const XERCES_CPP_NAMESPACE_QUALIFIER DOMError & domError )
void BCLoaderErrorHandler::resetErrors ( )
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vrecko/BaseClass.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BehindObstacleExp_wT Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
BehindObstacleExp_wT Class Reference

#include <BehindObstacleExp_wT.h>

Inheritance diagram for BehindObstacleExp_wT:
vrecko::Ability vrecko::BaseClass

Classes

struct ExperimentRec

Public Member Functions

BehindObstacleExp_wT ()
~BehindObstacleExp_wT ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | createScenes (void)
void | setScene (int scene_id)
void | initScene (int scene_id)
void | setAllBindingForMethod (int method_id)
int | checkLocation (int scene_id)
void | resetView (void)
std::string | getInfoString (void)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Timer | timer
osg::Timer_t | start_tick
osg::Timer_t | end_tick
int | current_state
int | internal_state
int | test_counter
bool | first_enter
std::ofstream | result_file
std::string | user_name
bool | stereoscopic
bool | two_handed
bool | large_projection
bool | dynamics_used
int | current_method
int | last_method
int | grasp_count
std::map< std::string,
ExperimentRec > 		experiment_map
std::string | method_desc [20]
osgText::Text * | experiment_description
osgText::Text * | timer_board
osgText::Text * | remaining_tests
osgText::Text * | method_board
osg::Geode * | text_geode
osg::Material * | text_material
osg::StateSet * | text_state
osgText::Font * | texture_font
int | font_size
osg::BlendFunc * | transp
EnvironmentObject * pCube1
EnvironmentObject * pCube2
EnvironmentObject * pCube3
EnvironmentObject * pObstacle1
EnvironmentObject * pObstacle2
EnvironmentObject * pObstacle3
EnvironmentObject * pObstacle4
EnvironmentObject * pFloor
EnvironmentObject * pObstacle5
EnvironmentObject * pObstacle6
EnvironmentObject * pObstacle7
EnvironmentObject * pObstacle8
EnvironmentObject * pObstacle9
EnvironmentObject * pObstacle10
EnvironmentObject * pObstacle11
EnvironmentObject * pObstacle12
EnvironmentObject * pObstacle13
EnvironmentObject * pObstacle14
EnvironmentObject * pObstacle15
EnvironmentObject * pObstacle16
EnvironmentObject * pObstacle17
EnvironmentObject * pObstacle18
EnvironmentObject * pObstacle19
EnvironmentObject * pObstacle20
Scene * pScene
EnvironmentObject * pEOAvatar
EnvironmentObject * owner
EnvironmentObject * pLeftHand
EnvironmentObject * pRightHand
EnvironmentObject * pWIMEO
EnvironmentObject * pCuttingPlaneEO
EnvironmentObject * pCuttingPlaneEO2
EnvironmentObject * pMirrorEO1
EnvironmentObject * pMirrorEO2
EnvironmentObject * pMirrorEO3
long int | lefthand_id
long int | righthand_id
Ability * pHMDHeadManipulator
Ability * pHeadManipulator
Ability * pManipulator
Ability * pCenterObjectManipulator
Ability * pCuttingPlane
Ability * pCuttingPlane2
Ability * pChangeOfVisibility
Ability * pMirror1
Ability * pMirror2
Ability * pMirror3
Ability * pWIM
Ability * pAvatarManipulator
Ability * | pMappingFunctions [2]
osg::MatrixTransform * | pTempl [3]
osg::Vec3 | final_object_position [3]
osg::Matrix | final_object_rotation [3]
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

BehindObstacleExp_wT::BehindObstacleExp_wT ( )
BehindObstacleExp_wT::~BehindObstacleExp_wT ( )

Member Function Documentation

int BehindObstacleExp_wT::checkLocation ( int scene_id )
protected
void BehindObstacleExp_wT::createScenes ( void )
protected
std::string BehindObstacleExp_wT::getInfoString ( void )
protected
void BehindObstacleExp_wT::initScene ( int scene_id )
protected
bool BehindObstacleExp_wT::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void BehindObstacleExp_wT::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BehindObstacleExp_wT::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BehindObstacleExp_wT::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void BehindObstacleExp_wT::resetView ( void )
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* BehindObstacleExp_wT::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void BehindObstacleExp_wT::setAllBindingForMethod ( int method_id )
protected
void BehindObstacleExp_wT::setScene ( int scene_id )
protected
void BehindObstacleExp_wT::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

int BehindObstacleExp_wT::current_method
protected
int BehindObstacleExp_wT::current_state
protected
bool BehindObstacleExp_wT::dynamics_used
protected
osg::Timer_t BehindObstacleExp_wT::end_tick
protected
osgText::Text* BehindObstacleExp_wT::experiment_description
protected
std::map<std::string, ExperimentRec> BehindObstacleExp_wT::experiment_map
protected
osg::Vec3 BehindObstacleExp_wT::final_object_position[3]
protected
osg::Matrix BehindObstacleExp_wT::final_object_rotation[3]
protected
bool BehindObstacleExp_wT::first_enter
protected
int BehindObstacleExp_wT::font_size
protected
int BehindObstacleExp_wT::grasp_count
protected
int BehindObstacleExp_wT::internal_state
protected
bool BehindObstacleExp_wT::large_projection
protected
int BehindObstacleExp_wT::last_method
protected
long int BehindObstacleExp_wT::lefthand_id
protected
osgText::Text * BehindObstacleExp_wT::method_board
protected
std::string BehindObstacleExp_wT::method_desc[20]
protected
EnvironmentObject * BehindObstacleExp_wT::owner
protected
Ability * BehindObstacleExp_wT::pAvatarManipulator
protected
Ability * BehindObstacleExp_wT::pCenterObjectManipulator
protected
Ability * BehindObstacleExp_wT::pChangeOfVisibility
protected
EnvironmentObject* BehindObstacleExp_wT::pCube1
protected
EnvironmentObject * BehindObstacleExp_wT::pCube2
protected
EnvironmentObject * BehindObstacleExp_wT::pCube3
protected
Ability* BehindObstacleExp_wT::pCuttingPlane
protected
Ability * BehindObstacleExp_wT::pCuttingPlane2
protected
EnvironmentObject * BehindObstacleExp_wT::pCuttingPlaneEO
protected
EnvironmentObject * BehindObstacleExp_wT::pCuttingPlaneEO2
protected
EnvironmentObject* BehindObstacleExp_wT::pEOAvatar
protected
EnvironmentObject * BehindObstacleExp_wT::pFloor
protected
Ability * BehindObstacleExp_wT::pHeadManipulator
protected
Ability* BehindObstacleExp_wT::pHMDHeadManipulator
protected
EnvironmentObject * BehindObstacleExp_wT::pLeftHand
protected
Ability * BehindObstacleExp_wT::pManipulator
protected
Ability * BehindObstacleExp_wT::pMappingFunctions[2]
protected
Ability * BehindObstacleExp_wT::pMirror1
protected
Ability * BehindObstacleExp_wT::pMirror2
protected
Ability * BehindObstacleExp_wT::pMirror3
protected
EnvironmentObject* BehindObstacleExp_wT::pMirrorEO1
protected
EnvironmentObject * BehindObstacleExp_wT::pMirrorEO2
protected
EnvironmentObject * BehindObstacleExp_wT::pMirrorEO3
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle1
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle10
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle11
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle12
protected
EnvironmentObject* BehindObstacleExp_wT::pObstacle13
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle14
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle15
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle16
protected
EnvironmentObject* BehindObstacleExp_wT::pObstacle17
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle18
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle19
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle2
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle20
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle3
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle4
protected
EnvironmentObject* BehindObstacleExp_wT::pObstacle5
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle6
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle7
protected
EnvironmentObject * BehindObstacleExp_wT::pObstacle8
protected
EnvironmentObject* BehindObstacleExp_wT::pObstacle9
protected
EnvironmentObject * BehindObstacleExp_wT::pRightHand
protected
Scene* BehindObstacleExp_wT::pScene
protected
osg::MatrixTransform* BehindObstacleExp_wT::pTempl[3]
protected
Ability * BehindObstacleExp_wT::pWIM
protected
EnvironmentObject * BehindObstacleExp_wT::pWIMEO
protected
osgText::Text * BehindObstacleExp_wT::remaining_tests
protected
std::ofstream BehindObstacleExp_wT::result_file
protected
long int BehindObstacleExp_wT::righthand_id
protected
osg::Timer_t BehindObstacleExp_wT::start_tick
protected
bool BehindObstacleExp_wT::stereoscopic
protected
int BehindObstacleExp_wT::test_counter
protected
osg::Geode* BehindObstacleExp_wT::text_geode
protected
osg::Material* BehindObstacleExp_wT::text_material
protected
osg::StateSet* BehindObstacleExp_wT::text_state
protected
osgText::Font* BehindObstacleExp_wT::texture_font
protected
osg::Timer BehindObstacleExp_wT::timer
protected
osgText::Text * BehindObstacleExp_wT::timer_board
protected
osg::BlendFunc* BehindObstacleExp_wT::transp
protected
bool BehindObstacleExp_wT::two_handed
protected
std::string BehindObstacleExp_wT::user_name
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExp_wT.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BehindObstacleExp_wT::ExperimentRec Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BehindObstacleExp_wT
  • ExperimentRec
Public Attributes | List of all members
BehindObstacleExp_wT::ExperimentRec Struct Reference

#include <BehindObstacleExp_wT.h>

Public Attributes

int nic

Member Data Documentation

int BehindObstacleExp_wT::ExperimentRec::nic
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExp_wT.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BehindObstacleExperiment Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
BehindObstacleExperiment Class Reference

#include <BehindObstacleExperiment.h>

Inheritance diagram for BehindObstacleExperiment:
vrecko::Ability vrecko::BaseClass

Classes

struct ExperimentRec

Public Member Functions

BehindObstacleExperiment ()
~BehindObstacleExperiment ()
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Member Functions

void | createScenes (void)
void | setScene (int scene_id)
void | initScene (int scene_id)
void | setAllBindingForMethod (int method_id)
int | checkLocation (int scene_id)
void | resetView (void)
std::string | getInfoString (void)
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Protected Attributes

osg::Timer | timer
osg::Timer_t | start_tick
osg::Timer_t | end_tick
int | current_state
int | internal_state
int | test_counter
bool | first_enter
std::ofstream | result_file
std::string | user_name
bool | stereoscopic
bool | two_handed
bool | large_projection
bool | dynamics_used
int | current_method
int | last_method
int | grasp_count
std::map< std::string,
ExperimentRec > 		experiment_map
std::string | method_desc [20]
osgText::Text * | experiment_description
osgText::Text * | timer_board
osgText::Text * | remaining_tests
osgText::Text * | method_board
osg::Geode * | text_geode
osg::Material * | text_material
osg::StateSet * | text_state
osgText::Font * | texture_font
int | font_size
osg::BlendFunc * | transp
EnvironmentObject * pCube1
EnvironmentObject * pCube2
EnvironmentObject * pCube3
EnvironmentObject * pObstacle1
EnvironmentObject * pObstacle2
EnvironmentObject * pObstacle3
EnvironmentObject * pObstacle4
EnvironmentObject * pFloor
EnvironmentObject * pEOAvatar
EnvironmentObject * owner
EnvironmentObject * pLeftHand
EnvironmentObject * pRightHand
EnvironmentObject * pWIMEO
EnvironmentObject * pCuttingPlaneEO
EnvironmentObject * pCuttingPlaneEO2
EnvironmentObject * pMirrorEO1
EnvironmentObject * pMirrorEO2
EnvironmentObject * pMirrorEO3
long int | lefthand_id
long int | righthand_id
Ability * pHMDHeadManipulator
Ability * pHeadManipulator
Ability * pManipulator
Ability * pCenterObjectManipulator
Ability * pCuttingPlane
Ability * pCuttingPlane2
Ability * pChangeOfVisibility
Ability * pMirror1
Ability * pMirror2
Ability * pMirror3
Ability * pWIM
Ability * pAvatarManipulator
Ability * | pMappingFunctions [2]
osg::MatrixTransform * | pTempl [3]
osg::Vec3 | final_object_position [3]
osg::Matrix | final_object_rotation [3]
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList

Constructor & Destructor Documentation

BehindObstacleExperiment::BehindObstacleExperiment ( )
BehindObstacleExperiment::~BehindObstacleExperiment ( )

Member Function Documentation

int BehindObstacleExperiment::checkLocation ( int scene_id )
protected
void BehindObstacleExperiment::createScenes ( void )
protected
std::string BehindObstacleExperiment::getInfoString ( void )
protected
void BehindObstacleExperiment::initScene ( int scene_id )
protected
bool BehindObstacleExperiment::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void BehindObstacleExperiment::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BehindObstacleExperiment::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void BehindObstacleExperiment::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void BehindObstacleExperiment::resetView ( void )
protected
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* BehindObstacleExperiment::saveXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * )
virtual

Save current setting into a XML node.

Warning
Currently not supported. It is safe to leave it without overriding.
Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument)
Returns
(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)

Reimplemented from vrecko::BaseClass.

void BehindObstacleExperiment::setAllBindingForMethod ( int method_id )
protected
void BehindObstacleExperiment::setScene ( int scene_id )
protected
void BehindObstacleExperiment::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

int BehindObstacleExperiment::current_method
protected
int BehindObstacleExperiment::current_state
protected
bool BehindObstacleExperiment::dynamics_used
protected
osg::Timer_t BehindObstacleExperiment::end_tick
protected
osgText::Text* BehindObstacleExperiment::experiment_description
protected
std::map<std::string, ExperimentRec> BehindObstacleExperiment::experiment_map
protected
osg::Vec3 BehindObstacleExperiment::final_object_position[3]
protected
osg::Matrix BehindObstacleExperiment::final_object_rotation[3]
protected
bool BehindObstacleExperiment::first_enter
protected
int BehindObstacleExperiment::font_size
protected
int BehindObstacleExperiment::grasp_count
protected
int BehindObstacleExperiment::internal_state
protected
bool BehindObstacleExperiment::large_projection
protected
int BehindObstacleExperiment::last_method
protected
long int BehindObstacleExperiment::lefthand_id
protected
osgText::Text * BehindObstacleExperiment::method_board
protected
std::string BehindObstacleExperiment::method_desc[20]
protected
EnvironmentObject * BehindObstacleExperiment::owner
protected
Ability * BehindObstacleExperiment::pAvatarManipulator
protected
Ability * BehindObstacleExperiment::pCenterObjectManipulator
protected
Ability * BehindObstacleExperiment::pChangeOfVisibility
protected
EnvironmentObject* BehindObstacleExperiment::pCube1
protected
EnvironmentObject * BehindObstacleExperiment::pCube2
protected
EnvironmentObject * BehindObstacleExperiment::pCube3
protected
Ability* BehindObstacleExperiment::pCuttingPlane
protected
Ability * BehindObstacleExperiment::pCuttingPlane2
protected
EnvironmentObject * BehindObstacleExperiment::pCuttingPlaneEO
protected
EnvironmentObject * BehindObstacleExperiment::pCuttingPlaneEO2
protected
EnvironmentObject* BehindObstacleExperiment::pEOAvatar
protected
EnvironmentObject * BehindObstacleExperiment::pFloor
protected
Ability * BehindObstacleExperiment::pHeadManipulator
protected
Ability* BehindObstacleExperiment::pHMDHeadManipulator
protected
EnvironmentObject * BehindObstacleExperiment::pLeftHand
protected
Ability * BehindObstacleExperiment::pManipulator
protected
Ability * BehindObstacleExperiment::pMappingFunctions[2]
protected
Ability * BehindObstacleExperiment::pMirror1
protected
Ability * BehindObstacleExperiment::pMirror2
protected
Ability * BehindObstacleExperiment::pMirror3
protected
EnvironmentObject* BehindObstacleExperiment::pMirrorEO1
protected
EnvironmentObject * BehindObstacleExperiment::pMirrorEO2
protected
EnvironmentObject * BehindObstacleExperiment::pMirrorEO3
protected
EnvironmentObject * BehindObstacleExperiment::pObstacle1
protected
EnvironmentObject * BehindObstacleExperiment::pObstacle2
protected
EnvironmentObject * BehindObstacleExperiment::pObstacle3
protected
EnvironmentObject * BehindObstacleExperiment::pObstacle4
protected
EnvironmentObject * BehindObstacleExperiment::pRightHand
protected
osg::MatrixTransform* BehindObstacleExperiment::pTempl[3]
protected
Ability * BehindObstacleExperiment::pWIM
protected
EnvironmentObject * BehindObstacleExperiment::pWIMEO
protected
osgText::Text * BehindObstacleExperiment::remaining_tests
protected
std::ofstream BehindObstacleExperiment::result_file
protected
long int BehindObstacleExperiment::righthand_id
protected
osg::Timer_t BehindObstacleExperiment::start_tick
protected
bool BehindObstacleExperiment::stereoscopic
protected
int BehindObstacleExperiment::test_counter
protected
osg::Geode* BehindObstacleExperiment::text_geode
protected
osg::Material* BehindObstacleExperiment::text_material
protected
osg::StateSet* BehindObstacleExperiment::text_state
protected
osgText::Font* BehindObstacleExperiment::texture_font
protected
osg::Timer BehindObstacleExperiment::timer
protected
osgText::Text * BehindObstacleExperiment::timer_board
protected
osg::BlendFunc* BehindObstacleExperiment::transp
protected
bool BehindObstacleExperiment::two_handed
protected
std::string BehindObstacleExperiment::user_name
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExperiment.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BehindObstacleExperiment::ExperimentRec Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BehindObstacleExperiment
  • ExperimentRec
Public Attributes | List of all members
BehindObstacleExperiment::ExperimentRec Struct Reference

#include <BehindObstacleExperiment.h>

Public Attributes

int nic

Member Data Documentation

int BehindObstacleExperiment::ExperimentRec::nic
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExperiment.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BinomialHeap< _NodeClass, _keyType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
BinomialHeap< _NodeClass, _keyType > Class Template Reference

#include <Heaps.h>

Inheritance diagram for BinomialHeap< _NodeClass, _keyType >:
GenericHeap< _NodeClass, _keyType >

Classes

class BinomialHeapNode

Public Member Functions

BinomialHeap (void)
~BinomialHeap (void)
virtual void | Insert (_NodeClass *node)
virtual _NodeClass * | ExtractMin (void)
virtual void | DecreaseKey (_NodeClass *node, _keyType value)
virtual _NodeClass * | GetMin (void)
virtual _NodeClass * | Delete (_NodeClass *node)
virtual void | Union (BinomialHeap< _NodeClass, _keyType > *heap)
virtual void | FreeAllNodes ()
virtual bool | IsEmpty ()

Protected Member Functions

void | Link (_NodeClass *root1, _NodeClass *root2)
void | Merge (BinomialHeap< _NodeClass, _keyType > *heap)
void | FreeNodeSimple (_NodeClass *node)

Protected Attributes

_NodeClass * head

Constructor & Destructor Documentation

template<class _NodeClass, class _keyType>
BinomialHeap< _NodeClass, _keyType >::BinomialHeap ( void )
template<class _NodeClass, class _keyType>
BinomialHeap< _NodeClass, _keyType >::~BinomialHeap ( void )

Member Function Documentation

template<class _NodeClass, class _keyType>
virtual void BinomialHeap< _NodeClass, _keyType >::DecreaseKey | ( | _NodeClass * | node,
 |  | _keyType | value
 | ) |  |
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* BinomialHeap< _NodeClass, _keyType >::Delete ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* BinomialHeap< _NodeClass, _keyType >::ExtractMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual void BinomialHeap< _NodeClass, _keyType >::FreeAllNodes ( )
virtual
template<class _NodeClass, class _keyType>
void BinomialHeap< _NodeClass, _keyType >::FreeNodeSimple ( _NodeClass * node )
protected
template<class _NodeClass, class _keyType>
virtual _NodeClass* BinomialHeap< _NodeClass, _keyType >::GetMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual void BinomialHeap< _NodeClass, _keyType >::Insert ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual bool BinomialHeap< _NodeClass, _keyType >::IsEmpty ( )
inlinevirtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
void BinomialHeap< _NodeClass, _keyType >::Link | ( | _NodeClass * | root1,
 |  | _NodeClass * | root2
 | ) |  |
inlineprotected
template<class _NodeClass, class _keyType>
void BinomialHeap< _NodeClass, _keyType >::Merge ( BinomialHeap< _NodeClass, _keyType > * heap )
protected
template<class _NodeClass, class _keyType>
virtual void BinomialHeap< _NodeClass, _keyType >::Union ( BinomialHeap< _NodeClass, _keyType > * heap )
virtual

Member Data Documentation

template<class _NodeClass, class _keyType>
_NodeClass* BinomialHeap< _NodeClass, _keyType >::head
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BinomialHeap
  • BinomialHeapNode
Public Member Functions | Public Attributes | List of all members
BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode Class Reference

#include <Heaps.h>

Inheritance diagram for BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode:
GenericHeap< _NodeClass, _keyType >::GenericHeapNode

Public Member Functions

virtual void Swap (void *node)

Public Attributes

BinomialHeapNode * parent
BinomialHeapNode * child
BinomialHeapNode * sibling
int | degree
- Public Attributes inherited from GenericHeap< _NodeClass, _keyType >::GenericHeapNode
_keyType | key

Member Function Documentation

template<class _NodeClass , class _keyType >
void BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode::Swap ( void * node )
virtual

Member Data Documentation

template<class _NodeClass, class _keyType>
BinomialHeapNode* BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode::child
template<class _NodeClass, class _keyType>
int BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode::degree
template<class _NodeClass, class _keyType>
BinomialHeapNode* BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode::parent
template<class _NodeClass, class _keyType>
BinomialHeapNode* BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode::sibling
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: BufferedSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
BufferedSpline Class Reference

#include <BufferedSpline.h>

Inheritance diagram for BufferedSpline:

Public Member Functions

BufferedSpline ()
BufferedSpline (const Vec3ArrayPtr sampleArray)
META_DAObject (BufferedSpline,"Buffered Spline") virtual Vec3ArrayPtr getPoints()
virtual bool | isClosed ()
void | setVertexArray (const Vec3ArrayPtr array)
Vec3ArrayPtr | getVertexArray () const

Protected Attributes

Vec3ArrayPtr | _array
double | _minDistance
bool | _closed
unsigned int | _lastIndex

Constructor & Destructor Documentation

BufferedSpline::BufferedSpline ( )

Constructors

BufferedSpline::BufferedSpline ( const Vec3ArrayPtr sampleArray )

Member Function Documentation

Vec3ArrayPtr BufferedSpline::getVertexArray ( ) const
inline
virtual bool BufferedSpline::isClosed ( )
inlinevirtual
BufferedSpline::META_DAObject | ( | BufferedSpline | ,
 |  | "Buffered Spline" |
 | ) |  |

Inherited virtual methods

void BufferedSpline::setVertexArray ( const Vec3ArrayPtr array )
inline

Setters and getters

Member Data Documentation

Vec3ArrayPtr BufferedSpline::_array
protected
bool BufferedSpline::_closed
protected
unsigned int BufferedSpline::_lastIndex
protected
double BufferedSpline::_minDistance
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BufferedSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BufferedSpline.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Cache Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
Cache Class Reference

Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM. More...

#include <Cache.h>

Inheritance diagram for Cache:
GetObserver DeleteObserver AddObserver vrecko::Ability vrecko::BaseClass

Public Member Functions

Cache ()
~Cache (void)
void | initialize (void)
void | init (bool useTime, unsigned long time, bool useDistance, unsigned long distance, unsigned long update_time)
void | update (void)
provadi se jednou za frame More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
nepouziva se More...
void | GetUpdate (string modelFilename, int num, ModelType modelType)
reakce na udalost Get v MM More...
void | DeleteUpdate (osg::ref_ptr< EnvironmentObject > deletingObject, int num, ModelType modelType)
reakce na udalost Delete, objekt, ktery se maze, aktualni pocet objektu ve scene, typ modelu More...
void | AddUpdate (string modelFilename, ModelType modelType)
reakce na udalost Add, nazev modelu, typ modelu More...
void | CreatePreloader (BlockUpdater *rootBlockUpdater)
vytvori a spusti preloader, Updater korenoveho bloku More...
void | DeletePreloader (void)
ukonci a smaze preloader More...
- Public Member Functions inherited from GetObserver
GetObserver ()
- Public Member Functions inherited from DeleteObserver
DeleteObserver ()
- Public Member Functions inherited from AddObserver
AddObserver ()
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Detailed Description

Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM.

Constructor & Destructor Documentation

Cache::Cache ( )
inline
Cache::~Cache ( void )

Member Function Documentation

void Cache::AddUpdate | ( | string | modelFilename,
 |  | ModelType | modelType
 | ) |  |
virtual

reakce na udalost Add, nazev modelu, typ modelu

reakce na udalost Add v MM

Implements AddObserver.

void Cache::CreatePreloader ( BlockUpdater * rootBlockUpdater )
inline

vytvori a spusti preloader, Updater korenoveho bloku

void Cache::DeletePreloader ( void )
inline

ukonci a smaze preloader

void Cache::DeleteUpdate | ( | osg::ref_ptr< EnvironmentObject > | deletingObject,
 |  | int | num,
 |  | ModelType | modelType
 | ) |  |
virtual

reakce na udalost Delete, objekt, ktery se maze, aktualni pocet objektu ve scene, typ modelu

reakce na udalost Delete v MM

Implements DeleteObserver.

void Cache::GetUpdate | ( | string | modelFilename,
 |  | int | num,
 |  | ModelType | modelType
 | ) |  |
virtual

reakce na udalost Get v MM

pokud existuje zaznam k danemu jmenu, pak provede MemoryManager::Delete a odstrani jej z listu i mapy mazani v listu na pozici - const vyhledani v listu - linear vyhledani v mape - log mazani v mape - iteratorem - const, klicem - log reakce na udalost Get, nazev modelu, aktualni pocet modelu ve scene, typ modelu

Implements GetObserver.

void Cache::init | ( | bool | useTime,
 |  | unsigned long | time,
 |  | bool | useDistance,
 |  | unsigned long | distance,
 |  | unsigned long | update_time
 | ) |  |
inline
void Cache::initialize ( void )
bool Cache::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
virtual

nepouziva se

Reimplemented from vrecko::BaseClass.

void Cache::update ( void )
virtual

provadi se jednou za frame

  1. je nastaven cas: od zacatku listu ziskej seznam elementu, kterym vyprsel cas a) pouze casova cache - odstran vsechny elementy s vyprsenym casem b) cas + pozice - zkontroluj jejich vzdalenost, ty, ktere jsou dal, nez je povolena vzdalenost, odstran
  2. neni nastaven cas: projdi cely seznam a odstran vsechny elementy, ktere maji vetsi vzdalenost, nez je povolena (odeber jej (ModelManager::Delete) a odstran jej z listu i map)

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Cache.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/Cache.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CacheInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CacheInfo Class Reference

Trida pro drzeni informaci o polozce v Cache. More...

#include <Cache.h>

Public Member Functions

CacheInfo ()
CacheInfo (osg::ref_ptr< EnvironmentObject > _eo, osg::Vec3 _position, osg::Timer_t _timestamp, ModelType _modelType)
~CacheInfo ()
bool | operator== (const CacheInfo &ci2) const
bool | operator!= (const CacheInfo &ci2) const

Public Attributes

osg::ref_ptr< EnvironmentObject > | eo
data objektu More...
osg::Vec3 | position
pozice avatara pri vlozeni objektu do cache More...
osg::Timer_t | timestamp
cas pri vlozeni objektu do cache More...
ModelType modelType
typ modelu More...

Detailed Description

Trida pro drzeni informaci o polozce v Cache.

Constructor & Destructor Documentation

CacheInfo::CacheInfo ( )
inline
CacheInfo::CacheInfo | ( | osg::ref_ptr< EnvironmentObject > | _eo,
 |  | osg::Vec3 | _position,
 |  | osg::Timer_t | _timestamp,
 |  | ModelType | _modelType
 | ) |  |
inline
CacheInfo::~CacheInfo ( )
inline

Member Function Documentation

bool CacheInfo::operator!= ( const CacheInfo & ci2 ) const
inline
bool CacheInfo::operator== ( const CacheInfo & ci2 ) const
inline

Member Data Documentation

osg::ref_ptr<EnvironmentObject> CacheInfo::eo

data objektu

ModelType CacheInfo::modelType

typ modelu

osg::Vec3 CacheInfo::position

pozice avatara pri vlozeni objektu do cache

osg::Timer_t CacheInfo::timestamp

cas pri vlozeni objektu do cache

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Cache.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CatmullRomInterpolator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CatmullRomInterpolator Class Reference

#include <CatmullRomInterpolator.h>

Inheritance diagram for CatmullRomInterpolator:
Interpolator

Public Member Functions

META_DAObject (CatmullRomInterpolator,"Catmull-Rom Interpolator") virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array
osg::Vec3 | interpolatePoint (const double &t, const osg::Vec3 &p0, const osg::Vec3 &p1, const osg::Vec3 &p2, const osg::Vec3 &p3)
- Public Member Functions inherited from Interpolator
virtual Vec3ArrayPtr | interpolate (const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Public Attributes

unsigned int | interpolationSteps
unsigned int bool | closed

Additional Inherited Members

- Protected Member Functions inherited from Interpolator
virtual ~Interpolator ()

Member Function Documentation

osg::Vec3 CatmullRomInterpolator::interpolatePoint | ( | const double & | t,
 |  | const osg::Vec3 & | p0,
 |  | const osg::Vec3 & | p1,
 |  | const osg::Vec3 & | p2,
 |  | const osg::Vec3 & | p3
 | ) |  |

Public methods

CatmullRomInterpolator::META_DAObject | ( | CatmullRomInterpolator | ,
 |  | "Catmull-Rom Interpolator" |
 | ) |  | const

Inherited virtual methods

Member Data Documentation

unsigned int bool CatmullRomInterpolator::closed
unsigned int CatmullRomInterpolator::interpolationSteps
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CatmullRomInterpolator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CatmullRomInterpolator.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: ChessBoard Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Attributes | List of all members
ChessBoard Class Reference

#include <ChessBoard.h>

Inheritance diagram for ChessBoard:
vrecko::Ability vrecko::BaseClass

Classes

struct Request

Public Member Functions

ChessBoard ()
~ChessBoard ()
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
std::string | getAcceptableMessages (void)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

FILE * | chess_pipe
bool | status
bool | play
bool | color
unsigned int | wait
bool | generate_board
float | square_size
osg::Vec3 | a1pos
osg::Node * | WRook
osg::Node * | WKnight
osg::Node * | WBishop
osg::Node * | WQueen
osg::Node * | WKing
osg::Node * | WPawn
osg::Node * | BRook
osg::Node * | BKnight
osg::Node * | BBishop
osg::Node * | BQueen
osg::Node * | BKing
osg::Node * | BPawn
std::map< std::string, long int > | pieces_map
int | pfd_to [2]
int | pfd_from [2]
osg::Vec3 | white_out_pos
osg::Vec3 | black_out_pos
bool | _first
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ChessBoard::ChessBoard ( )
ChessBoard::~ChessBoard ( )
inline

Member Function Documentation

std::string ChessBoard::getAcceptableMessages ( void )
inline
bool ChessBoard::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ChessBoard::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ChessBoard::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool ChessBoard::_first
protected
osg::Vec3 ChessBoard::a1pos
protected
osg::Node * ChessBoard::BBishop
protected
osg::Node * ChessBoard::BKing
protected
osg::Node * ChessBoard::BKnight
protected
osg::Vec3 ChessBoard::black_out_pos
protected
osg::Node * ChessBoard::BPawn
protected
osg::Node * ChessBoard::BQueen
protected
osg::Node* ChessBoard::BRook
protected
FILE* ChessBoard::chess_pipe
protected
bool ChessBoard::color
protected
bool ChessBoard::generate_board
protected
int ChessBoard::pfd_from[2]
protected
int ChessBoard::pfd_to[2]
protected
std::map<std::string, long int> ChessBoard::pieces_map
protected
bool ChessBoard::play
protected
float ChessBoard::square_size
protected
bool ChessBoard::status
protected
unsigned int ChessBoard::wait
protected
osg::Node * ChessBoard::WBishop
protected
osg::Vec3 ChessBoard::white_out_pos
protected
osg::Node * ChessBoard::WKing
protected
osg::Node * ChessBoard::WKnight
protected
osg::Node * ChessBoard::WPawn
protected
osg::Node * ChessBoard::WQueen
protected
osg::Node* ChessBoard::WRook
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessBoard.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: ChessBoard::Request Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ChessBoard
  • Request
Public Attributes | List of all members
ChessBoard::Request Struct Reference

#include <ChessBoard.h>

Public Attributes

std::string | type
std::string | location
osg::Vec3 | new_position

Member Data Documentation

std::string ChessBoard::Request::location
osg::Vec3 ChessBoard::Request::new_position
std::string ChessBoard::Request::type
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessBoard.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: ChessPiece Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
ChessPiece Class Reference

#include <ChessPiece.h>

Inheritance diagram for ChessPiece:
vrecko::Ability vrecko::BaseClass

Public Member Functions

ChessPiece ()
~ChessPiece ()
void | processEvent (const std::string &input_name, void *value)
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
void | preInitialize ()
OBSOLETE METHOD, kept for backwards compatibility. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
std::string | getAcceptableMessages (void)
void | setType (std::string _type)
void | setLocation (std::string _location)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

std::string | piece_type
std::string | piece_location
long int | chessboard_id
unsigned int | move
osg::Vec3 | final_position
osg::Vec3 | actual_position
osg::Vec3 | move_step
EnvironmentObject * owner
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

ChessPiece::ChessPiece ( )
ChessPiece::~ChessPiece ( )
inline

Member Function Documentation

std::string ChessPiece::getAcceptableMessages ( void )
inline
bool ChessPiece::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void ChessPiece::preInitialize ( void )
inlinevirtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void ChessPiece::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void ChessPiece::setLocation ( std::string _location )
inline
void ChessPiece::setType ( std::string _type )
inline
void ChessPiece::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

osg::Vec3 ChessPiece::actual_position
protected
long int ChessPiece::chessboard_id
protected
osg::Vec3 ChessPiece::final_position
protected
unsigned int ChessPiece::move
protected
osg::Vec3 ChessPiece::move_step
protected
EnvironmentObject* ChessPiece::owner
protected
std::string ChessPiece::piece_location
protected
std::string ChessPiece::piece_type
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessPiece.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Cloud Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Static Public Member Functions | Public Attributes | List of all members
Cloud Class Reference

#include <Cloud.h>

Classes

class ParticleAwayComparison

Public Member Functions

Cloud ()
void | CalculateBoundingBox (void)
void | ComputeUpRightVectors ()
void | LightCloud (void)
void | RegularUpdate ()
void | InitCloudGeometry (osg::ref_ptr< osg::Geometry > cloudGeometry)
void | UpdateCloudLotRocScale ()
void | UpdateCloudColor ()
void | UpdateCloud ()
void | Delete (void)
void | SetLastCam (osg::Vec3f last_cam)

Static Public Member Functions

static void | SetSunLight (SunLight &sun)
static void | GenerateLightTexture (void)
static void | DestroyLightTexture (void)
static bool | AddToQueue (Cloud *cloudToUpdate)
static void | RealizeQueue (void)
static void | SetTranslateErrorTolerance (float tolerance)
static void | SetMaxCloudUpdates (unsigned int max)
static void | SetSceneInfo (const CloudSceneInfo &info)
static void | SetCloudParticleTexture (osg::ref_ptr< osg::Texture2D > newCloudParticleTexture)
static void | SetCamera (const osg::Vec3f &newCameraPosition, const osg::Vec3f &newCameraView, const osg::Vec3f &newCameraUp)
static void | SetViewMatrix (const osg::Matrix &newViewMatrix)

Public Attributes

AABoundingBox boundingBox
std::vector< CloudParticle > | cloudParticle
class Cloud::ParticleAwayComparison | SortAway

Detailed Description

Represents a cloud and all data and functionality associated with it.

Constructor & Destructor Documentation

Cloud::Cloud ( )
inline

Member Function Documentation

bool Cloud::AddToQueue ( Cloud * cloudToUpdate )
static

Adds the cloud to the update queue.

Parameters
cloud Cloud to be added to the update queue.
Returns
TRUE if the cloud has been added to the queue, FALSE if the cloud had already been in the queue.
void Cloud::CalculateBoundingBox ( void )

Computes the bounding box (bounding sphere, actually) of the cloud.

void Cloud::ComputeUpRightVectors ( )
Deprecated:
Should be rewritten in OSG. Computes the new Up and Right vectors based on the curent view - used in the update of cloud particle rotations.
void Cloud::Delete ( void )

Deletes all the data associated with the cloud.

void Cloud::DestroyLightTexture ( void )
static

Destroys the temporary texture used for the computation of lighting.

void Cloud::GenerateLightTexture ( void )
static

Generates a temporary texture which is used for light computation. Based on the function used by Harris et al. (www.markmark.net/SkyWorks/)

void Cloud::InitCloudGeometry ( osg::ref_ptr< osg::Geometry > cloudGeometry )

Initializes the geometry of the cloud, its vertices and color and texture coordinates.

Parameters
cloudGeometry Geometry of the cloud which is used to create the cloud in it.
void Cloud::LightCloud ( void )
Deprecated:
Should be rewritten in OSG. Computes the lighting of the cloud.
void Cloud::RealizeQueue ( void )
static

Realizes the cloud update queue.

void Cloud::RegularUpdate ( )

Regular update of the cloud which is being called once per frame.

void Cloud::SetCamera | ( | const osg::Vec3f & | newCameraPosition,
 |  | const osg::Vec3f & | newCameraView,
 |  | const osg::Vec3f & | newCameraUp
 | ) |  |
static

Updates the camera data.

Parameters
newCameraPosition | Current position vector of the camera.
newCameraView | Current view vector of the camera.
newCameraUp | Current up vector of the camera.
static void Cloud::SetCloudParticleTexture ( osg::ref_ptr< osg::Texture2D > newCloudParticleTexture )
inlinestatic
void Cloud::SetLastCam ( osg::Vec3f last_cam )
inline
static void Cloud::SetMaxCloudUpdates ( unsigned int max )
inlinestatic
static void Cloud::SetSceneInfo ( const CloudSceneInfo & info )
inlinestatic
static void Cloud::SetSunLight ( SunLight & sun )
inlinestatic
static void Cloud::SetTranslateErrorTolerance ( float tolerance )
inlinestatic
static void Cloud::SetViewMatrix ( const osg::Matrix & newViewMatrix )
inlinestatic
void Cloud::UpdateCloud ( )

Updates the vertices and color of the cloud.

void Cloud::UpdateCloudColor ( )

Updates the color of the cloud.

void Cloud::UpdateCloudLotRocScale ( )

Updates the vertices of the cloud.

Member Data Documentation

AABoundingBox Cloud::boundingBox
std::vector<CloudParticle> Cloud::cloudParticle
class Cloud::ParticleAwayComparison Cloud::SortAway
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Cloud.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Cloud::ParticleAwayComparison Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Cloud
  • ParticleAwayComparison
Public Member Functions | List of all members
Cloud::ParticleAwayComparison Class Reference

#include <Cloud.h>

Public Member Functions

bool operator() (CloudParticle particle1, CloudParticle particle2)

Member Function Documentation

bool Cloud::ParticleAwayComparison::operator() | ( | CloudParticle | particle1,
 |  | CloudParticle | particle2
 | ) |  |
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudDataType Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CloudDataType Class Reference

Inherited class from osg::Referenced. Stores information about the camera and can be referenced by osg::ref_ptr. More...

#include <OSGCloudWrap.h>

Inheritance diagram for CloudDataType:

Public Member Functions

void | setCameraData (const osg::Vec3f &cameraPos, const osg::Vec3f &cameraView, const osg::Vec3f &cameraUp)
osg::Vec3f | getCameraPos (void)
osg::Vec3f | getCameraView (void)
osg::Vec3f | getCameraUp (void)

Detailed Description

Inherited class from osg::Referenced. Stores information about the camera and can be referenced by osg::ref_ptr.

Member Function Documentation

osg::Vec3f CloudDataType::getCameraPos ( void )
inline

Returns the position of the camera.

Returns
The position of the camera.
osg::Vec3f CloudDataType::getCameraUp ( void )
inline

Returns the 'Up' direction of the camera.

Returns
The 'Up' direction of the camera.
osg::Vec3f CloudDataType::getCameraView ( void )
inline

Returns the direction in which the camera is looking.

Returns
The direction in which the camera is looking.
void CloudDataType::setCameraData | ( | const osg::Vec3f & | cameraPos,
 |  | const osg::Vec3f & | cameraView,
 |  | const osg::Vec3f & | cameraUp
 | ) |  |
inline

Updates the information about the camera on the new values given by parameters.

Parameters
[in] | cameraPos | Position of the camera.
[in] | cameraView | Direction in which the camera is looking.
[in] | cameraUp | The 'Up' direction of the camera.
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGCloudWrap.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudParticle Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CloudParticle Struct Reference

#include <Cloud.h>

Inheritance diagram for CloudParticle:
Particle

Public Attributes

float | distToCam
float | render_cloud_tex_u1
float | render_cloud_tex_v1
float | render_cloud_tex_u2
float | render_cloud_tex_v2
- Public Attributes inherited from Particle
float | size
osg::Vec3f | position
osg::Vec4f | color

Detailed Description

Extended cloud particle which also contains UV texture coordinates and distance of the particle to the camera.

Member Data Documentation

float CloudParticle::distToCam
float CloudParticle::render_cloud_tex_u1
float CloudParticle::render_cloud_tex_u2
float CloudParticle::render_cloud_tex_v1
float CloudParticle::render_cloud_tex_v2
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudSceneInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CloudSceneInfo Struct Reference

#include <Cloud.h>

Public Attributes

int | screenWidth
int | screenHeight
double | Fovy
double | Aspect
double | Near
double | Far

Detailed Description

Stores the screen and projection properties.

Member Data Documentation

double CloudSceneInfo::Aspect
double CloudSceneInfo::Far
double CloudSceneInfo::Fovy
double CloudSceneInfo::Near
int CloudSceneInfo::screenHeight
int CloudSceneInfo::screenWidth
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudsManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
CloudsManager Class Reference

Manages all the clouds in the scene. More...

#include <CloudsManager.h>

Public Member Functions

CloudsManager ()
~CloudsManager ()
void | LoadAndInitiate (void)
void | SetUVCoords (bool singleTexture=false)
void | Update (const osg::Vec3f &cameraPosition, const osg::Vec3f &cameraView, const osg::Vec3f &cameraUp)
int | SaveToFile (void)
int | LoadFromFile (void)
void | Delete (void)

Public Attributes

std::vector< Cloud > clouds
CloudsProperties properties
CloudSceneInfo sceneInfo
PseudoRand2DPlacement flatLayer

Detailed Description

Manages all the clouds in the scene.

Constructor & Destructor Documentation

CloudsManager::CloudsManager ( )
inline
CloudsManager::~CloudsManager ( )
inline

Member Function Documentation

void CloudsManager::Delete ( void )

Deletes the cloud manager and all clouds associated with it.

void CloudsManager::LoadAndInitiate ( void )

Initializes and generates (loads from files) all the clouds and attributes associated with them (also saves them afterwards to disk if necessary).

int CloudsManager::LoadFromFile ( void )

Loads previously saved cloud files from the disk into the manager's std::vector. Files are loaded sequentially in ascending order. If the loading process of one of any them fails, all the following files are not loaded.

Returns
0 if at least one cloud file was successfully loaded, false otherwise.
int CloudsManager::SaveToFile ( void )

Saves the clouds into filesystem, every cloud in a separate .txt file.

Returns
0 if everything went well and all files were saved to the disk, -1 otherwise.
void CloudsManager::SetUVCoords ( bool singleTexture = false )

Set up the UV texture coordinates for all of the cloud particles.

Parameters
singleTexture Indicates whether the cloud texture cotains a single texture which is displayed on every particle or four different textures for different values of alpha channel (optional, default = false)
void CloudsManager::Update | ( | const osg::Vec3f & | cameraPosition,
 |  | const osg::Vec3f & | cameraView,
 |  | const osg::Vec3f & | cameraUp
 | ) |  |

Updates the status of all of the clouds and launches the realization of the update of impostors from the priority queue.

Parameters
[in] | cameraPos | Position of the camera.
[in] | cameraView | Direction in which the camera is looking.
[in] | cameraUp | The 'Up' direction of the camera.

Member Data Documentation

std::vector<Cloud> CloudsManager::clouds
PseudoRand2DPlacement CloudsManager::flatLayer
CloudsProperties CloudsManager::properties
CloudSceneInfo CloudsManager::sceneInfo
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/CloudsManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/CloudsManager.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudsProperties Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CloudsProperties Struct Reference

Contains all the properties of the Clouds ability loaded from XML file. More...

#include <CloudsManager.h>

Public Attributes

SunLight sun
bool | sunShow
unsigned int | numOfClouds
float | scale
unsigned int | CloudGrowth [3]
unsigned int | CloudGrowthRand [3]
unsigned int | GrowthSimulationSteps
unsigned int | GrowthSimulationStepsRand
int | CloudFlatAreaPosition [3]
unsigned int | CloudFlatAreaSize [3]
std::string | renderCloudTexturePath
unsigned int | maxCloudUpdatesParFrame
float | translateErrorTolerance
bool | loadFromFile
bool | saveToFile
bool | skyboxShow
long | skyboxSize
long | skyboxCenterPosition [3]
std::string | skyBoxTexturePathTop
std::string | skyBoxTexturePathNorth
std::string | skyBoxTexturePathSouth
std::string | skyBoxTexturePathWest
std::string | skyBoxTexturePathEast
bool | groundShow
long | groundCenterPosition [3]
std::string | groundTexturePath

Detailed Description

Contains all the properties of the Clouds ability loaded from XML file.

Member Data Documentation

int CloudsProperties::CloudFlatAreaPosition[3]
unsigned int CloudsProperties::CloudFlatAreaSize[3]
unsigned int CloudsProperties::CloudGrowth[3]
unsigned int CloudsProperties::CloudGrowthRand[3]
long CloudsProperties::groundCenterPosition[3]
bool CloudsProperties::groundShow
std::string CloudsProperties::groundTexturePath
unsigned int CloudsProperties::GrowthSimulationSteps
unsigned int CloudsProperties::GrowthSimulationStepsRand
bool CloudsProperties::loadFromFile
unsigned int CloudsProperties::maxCloudUpdatesParFrame
unsigned int CloudsProperties::numOfClouds
std::string CloudsProperties::renderCloudTexturePath
bool CloudsProperties::saveToFile
float CloudsProperties::scale
long CloudsProperties::skyboxCenterPosition[3]
bool CloudsProperties::skyboxShow
long CloudsProperties::skyboxSize
std::string CloudsProperties::skyBoxTexturePathEast
std::string CloudsProperties::skyBoxTexturePathNorth
std::string CloudsProperties::skyBoxTexturePathSouth
std::string CloudsProperties::skyBoxTexturePathTop
std::string CloudsProperties::skyBoxTexturePathWest
SunLight CloudsProperties::sun
bool CloudsProperties::sunShow
float CloudsProperties::translateErrorTolerance
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/CloudsManager.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CloudVoxel Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
CloudVoxel Struct Reference

Represents a cloud voxel used for cloud generation. More...

#include <GenClouds.h>

Public Attributes

bool | act
bool | hum
bool | cld
float | p_ext
float | p_act
float | p_hum

Detailed Description

Represents a cloud voxel used for cloud generation.

Member Data Documentation

bool CloudVoxel::act
bool CloudVoxel::cld
bool CloudVoxel::hum
float CloudVoxel::p_act
float CloudVoxel::p_ext
float CloudVoxel::p_hum
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/GenClouds.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: ConstantColorGen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Attributes | List of all members
ConstantColorGen Class Reference

#include <ConstantColorGen.h>

Inheritance diagram for ConstantColorGen:

Public Member Functions

ConstantColorGen ()
ConstantColorGen (const osg::Vec4 &color)
META_DAObject (ConstantColorGen,"Constant Brush") virtual Vec4ArrayPtr getColors(unsigned int leadSplineSize
result reserve (arraySize)
result assign (arraySize, _color)
osg::Vec4 | getColorValue () const
void | setColorValue (const osg::Vec4 &val)

Public Attributes

unsigned int crossSectionSize | _dirty = false
Vec4ArrayPtr | result = new osg::Vec4Array
unsigned int | arraySize = leadSplineSize * crossSectionSize
return | result

Protected Attributes

osg::Vec4 _color

Constructor & Destructor Documentation

ConstantColorGen::ConstantColorGen ( )
inline
ConstantColorGen::ConstantColorGen ( const osg::Vec4 & color )
inline

Member Function Documentation

result ConstantColorGen::assign | ( | arraySize | ,
 |  | _color |
 | ) |  |
osg::Vec4 ConstantColorGen::getColorValue ( ) const
inline
ConstantColorGen::META_DAObject | ( | ConstantColorGen | ,
 |  | "Constant Brush" |
 | ) |  |

Inherited methods

result ConstantColorGen::reserve ( arraySize )
void ConstantColorGen::setColorValue ( const osg::Vec4 & val )
inline

Member Data Documentation

osg::Vec4 ConstantColorGen::_color
protected
unsigned int crossSectionSize ConstantColorGen::_dirty = false
unsigned int ConstantColorGen::arraySize = leadSplineSize * crossSectionSize
Vec4ArrayPtr ConstantColorGen::result = new osg::Vec4Array
return ConstantColorGen::result
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ConstantColorGen.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: ConstraintHierarchyMember Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
ConstraintHierarchyMember Class Reference

#include <ConstraintHierarchy.h>

Public Member Functions

ConstraintHierarchyMember ()
virtual | ~ConstraintHierarchyMember ()
string | getAreaClassString ()
void | setAreaClassString (string areaClassString)
bool | loadXMLFile (const char *xmlFile)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
void | write (int level=0)
ConstraintHierarchyMember * | findHierarchyMember (string areaClassStringLookingFor)
bool | isHierarchyAncestorOf (ConstraintHierarchyMember *hierarchyMember)

Detailed Description

Class representing a constraint class hierarchy member

Constructor & Destructor Documentation

ConstraintHierarchyMember::ConstraintHierarchyMember ( )

Creates a constraint area hierarchy node with no children

ConstraintHierarchyMember::~ConstraintHierarchyMember ( )
virtual

Frees a constraint area hierarchy node and all its children

Member Function Documentation

ConstraintHierarchyMember * ConstraintHierarchyMember::findHierarchyMember ( string areaClassStringLookingFor )

Tries to find a hierarchy member with the specified areaClassString

string ConstraintHierarchyMember::getAreaClassString ( )
inline
bool ConstraintHierarchyMember::isHierarchyAncestorOf ( ConstraintHierarchyMember * hierarchyMember )

Returns whether this hierarchy node is an ancestor of the specified node (or that node itself)

bool ConstraintHierarchyMember::loadXMLFile ( const char * xmlFile )

Loads a constraint area hierarchy node and its children from the specified XML file

bool ConstraintHierarchyMember::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * pParametersNode )

Loads a constraint area hierarchy node and its children from a DOM node

void ConstraintHierarchyMember::setAreaClassString ( string areaClassString )
inline
void ConstraintHierarchyMember::write ( int level = 0 )

Writes the hierarchy information to standard output (indenting according to the level parameter)

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintHierarchy.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintHierarchy.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: CubicInterpolator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
CubicInterpolator Class Reference

#include <CubicInterpolator.h>

Inheritance diagram for CubicInterpolator:
Interpolator

Public Member Functions

CubicInterpolator (void)
~CubicInterpolator (void)
- Public Member Functions inherited from Interpolator
virtual Vec3ArrayPtr | interpolate (const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Additional Inherited Members

- Protected Member Functions inherited from Interpolator
virtual ~Interpolator ()

Constructor & Destructor Documentation

CubicInterpolator::CubicInterpolator ( void )
CubicInterpolator::~CubicInterpolator ( void )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CubicInterpolator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CubicInterpolator.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DAControlPoint Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
DAControlPoint Class Reference

Control point of Motion trail. More...

#include <MTControlPoint.h>

Inheritance diagram for DAControlPoint:

Public Member Functions

DAControlPoint (DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient)
~DAControlPoint ()
osg::Vec3 | getBinormal ()
double | getCurvature ()
osg::Vec3 | getNormal ()
osg::Quat | getOrientation ()
osg::Vec3 | getPosition ()
double | getPriority ()
double | getSegmentLength ()
double | getSpeed ()
osg::Vec3 | getTangent ()
double | getTorsion ()
double | getTvalue ()
DAControlPointType | getType ()
osg::Group * | getVisualOwner ()
string | getPositionString ()
void | setCharacteristics (osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion)
void | setNormal (osg::Vec3 nrml)
void | setBinormal (osg::Vec3 binrml)
void | setPosition (osg::Vec3 pos)
void | setPosition (osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z)
void | setPriority (double prior)
void | setSegmentLength (double length)
double | setSpeed (double spee)
void | setTangent (osg::Vec3 tngt)
void | setTvalue (double tval)
void | setVisibleVisualBox (bool vis)
void | showGizmo (bool show)
show or hide graphical gizmo of point More...

Public Attributes

bool frenetFremeComputed

Detailed Description

Control point of Motion trail.

Set of control points is computed from set of samples. Control points are used as control points of leading curve of swept-volume of motion trail. may contains:

  • position, orientation
  • Frenet-frame - local coordinate system
  • speed
  • priority

Constructor & Destructor Documentation

DAControlPoint::DAControlPoint | ( | DAControlPointType | p_type,
 |  | osg::Group * | p_EOOwner,
 |  | osg::Vec3 | point,
 |  | osg::Quat | orient
 | ) |  |
DAControlPoint::~DAControlPoint ( )

Member Function Documentation

osg::Vec3 DAControlPoint::getBinormal ( )
inline
double DAControlPoint::getCurvature ( )
inline
osg::Vec3 DAControlPoint::getNormal ( )
inline
osg::Quat DAControlPoint::getOrientation ( )
inline
osg::Vec3 DAControlPoint::getPosition ( )
inline
string DAControlPoint::getPositionString ( )
double DAControlPoint::getPriority ( )
inline
double DAControlPoint::getSegmentLength ( )
inline
double DAControlPoint::getSpeed ( )
inline
osg::Vec3 DAControlPoint::getTangent ( )
inline
double DAControlPoint::getTorsion ( )
inline
double DAControlPoint::getTvalue ( )
inline
DAControlPointType DAControlPoint::getType ( void )
inline
osg::Group* DAControlPoint::getVisualOwner ( )
inline
void DAControlPoint::setBinormal ( osg::Vec3 binrml )
inline
void DAControlPoint::setCharacteristics | ( | osg::Vec3 | tan,
 |  | osg::Vec3 | norm,
 |  | osg::Vec3 | binorm,
 |  | double | curvature,
 |  | double | torsion
 | ) |  |
void DAControlPoint::setNormal ( osg::Vec3 nrml )
inline
void DAControlPoint::setPosition ( osg::Vec3 pos )
void DAControlPoint::setPosition | ( | osg::Vec3f::value_type | x,
 |  | osg::Vec3f::value_type | y,
 |  | osg::Vec3f::value_type | z
 | ) |  |
void DAControlPoint::setPriority ( double prior )
inline
void DAControlPoint::setSegmentLength ( double length )
inline
double DAControlPoint::setSpeed ( double spee )
inline
void DAControlPoint::setTangent ( osg::Vec3 tngt )
inline
void DAControlPoint::setTvalue ( double tval )
inline
void DAControlPoint::setVisibleVisualBox ( bool vis )
inline
void DAControlPoint::showGizmo ( bool show )

show or hide graphical gizmo of point

Member Data Documentation

bool DAControlPoint::frenetFremeComputed
Todo:
make this private....
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DAGizmo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
DAGizmo Class Reference

Gizmo - graphical representation of something, e.g. Frenet frame. More...

#include <MTControlPoint.h>

Inheritance diagram for DAGizmo:

Public Member Functions

DAGizmo (osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius)
~DAGizmo ()
osg::ref_ptr< SimpleBox > | getNormal ()
osg::ref_ptr< SimpleBox > | getBinormal ()
bool | isVisible ()
void | hide ()
void | show ()

Detailed Description

Gizmo - graphical representation of something, e.g. Frenet frame.

Render tangent, normal and binormal as SimpleBox

Constructor & Destructor Documentation

DAGizmo::DAGizmo | ( | osg::Group * | p_EOOwner,
 |  | osg::Vec3 | position,
 |  | osg::Vec3 | tangent,
 |  | osg::Vec3 | normal,
 |  | osg::Vec3 | binormal,
 |  | double | radius
 | ) |  |
DAGizmo::~DAGizmo ( )

Member Function Documentation

osg::ref_ptr<SimpleBox> DAGizmo::getBinormal ( )
inline
osg::ref_ptr<SimpleBox> DAGizmo::getNormal ( )
inline
void DAGizmo::hide ( )
bool DAGizmo::isVisible ( )
inline
void DAGizmo::show ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DASample Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
DASample Class Reference

#include <precompiled.h>

Public Member Functions

DASample ()
DASample (osg::Vec3 p_pos, osg::Quat p_orient)

Public Attributes

osg::Vec3 | position
osg::Quat | orientation

Constructor & Destructor Documentation

DASample::DASample ( )
inline
DASample::DASample | ( | osg::Vec3 | p_pos,
 |  | osg::Quat | p_orient
 | ) |  |
inline

Member Data Documentation

osg::Quat DASample::orientation
osg::Vec3 DASample::position
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/precompiled.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DeleteObserver Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
DeleteObserver Class Referenceabstract

rozhrani pro objekty, ktere zajima udalost Delete More...

#include <ModelManager.h>

Inheritance diagram for DeleteObserver:
Cache

Public Member Functions

DeleteObserver ()
virtual void DeleteUpdate (osg::ref_ptr< EnvironmentObject > deletingObject, int num, ModelType modelType)=0

Detailed Description

rozhrani pro objekty, ktere zajima udalost Delete

Constructor & Destructor Documentation

DeleteObserver::DeleteObserver ( )
inline

Member Function Documentation

virtual void DeleteObserver::DeleteUpdate | ( | osg::ref_ptr< EnvironmentObject > | deletingObject,
 |  | int | num,
 |  | ModelType | modelType
 | ) |  |
pure virtual

metoda, ktera se zavola, nastane-li udalost Delete v pozorovanem objektu, deletingObject - objekt, ktery se maze, num - aktualni pocet stejnych objektu ve scene (pocet referenci), modelType - typ modelu

Implemented in Cache.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DynamicTree< _Type > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Attributes | List of all members
DynamicTree< _Type > Class Template Reference

#include <DynamicTree.h>

Public Types

typedef bool(* | DYNTREE_NODEALLOWED )(DynTreeNode< _Type > *node)
typedef bool(* | DYNTREE_SUBTREEALLOWED )(DynTreeNode< _Type > *node)

Public Member Functions

DynamicTree (void)
virtual | ~DynamicTree (void)
unsigned long | GetCount (void)
bool | AddNode (_Type *lpParent, _Type *lpNode)
bool | AddNodeLast (_Type *lpParent, _Type *lpNode)
bool | InsertNode (_Type *lpParent, _Type *lpPrevSibling, _Type *lpNode)
bool | DeleteNode (_Type *lpNode, bool bCallDelete=false)
_Type * | GetRoot (void)
bool | Clear (bool bCallDelete=false)

Protected Attributes

_Type * | lpRoot
unsigned long | dwCount

Member Typedef Documentation

template<class _Type>
typedef bool(* DynamicTree< _Type >::DYNTREE_NODEALLOWED)(DynTreeNode< _Type > *node)
template<class _Type>
typedef bool(* DynamicTree< _Type >::DYNTREE_SUBTREEALLOWED)(DynTreeNode< _Type > *node)

Constructor & Destructor Documentation

template<class _Type >
DynamicTree< _Type >::DynamicTree ( void )
template<class _Type >
DynamicTree< _Type >::~DynamicTree ( void )
virtual

Member Function Documentation

template<class _Type>
bool DynamicTree< _Type >::AddNode | ( | _Type * | lpParent,
 |  | _Type * | lpNode
 | ) |  |
template<class _Type>
bool DynamicTree< _Type >::AddNodeLast | ( | _Type * | lpParent,
 |  | _Type * | lpNode
 | ) |  |
template<class _Type >
bool DynamicTree< _Type >::Clear ( bool bCallDelete = false )
template<class _Type>
bool DynamicTree< _Type >::DeleteNode | ( | _Type * | lpNode,
 |  | bool | bCallDelete = false
 | ) |  |
template<class _Type>
unsigned long DynamicTree< _Type >::GetCount ( void )
inline
template<class _Type>
_Type* DynamicTree< _Type >::GetRoot ( void )
inline
template<class _Type>
bool DynamicTree< _Type >::InsertNode | ( | _Type * | lpParent,
 |  | _Type * | lpPrevSibling,
 |  | _Type * | lpNode
 | ) |  |

Member Data Documentation

template<class _Type>
unsigned long DynamicTree< _Type >::dwCount
protected
template<class _Type>
_Type* DynamicTree< _Type >::lpRoot
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/DynamicTree.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DynamicTreeIterator< _Type > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Friends | List of all members
DynamicTreeIterator< _Type > Class Template Reference

#include <DynamicTree.h>

Public Member Functions

DynamicTreeIterator (void)
void | Reset (void)
void | SetNodeAllowedCallback (typename DynamicTree< _Type >::DYNTREE_NODEALLOWED cb)
void | SetSubTreeAllowedCallback (typename DynamicTree< _Type >::DYNTREE_SUBTREEALLOWED cb)
void | Start (_Type *lpTravStart, unsigned long dwFlags)
bool | IsFinished (void)
bool | operator== (const DynamicTreeIterator< _Type > &iter)
DynamicTreeIterator< _Type > & | operator++ (void)
DynamicTreeIterator< _Type > | operator++ (int)
_Type * | GetNode (void)
void | SetTree (DynamicTree< _Type > *_tree)

Protected Member Functions

bool | IsNodeAllowed (_Type *node)
bool | IsSubTreeAllowed (_Type *node)

Protected Attributes

DynamicTree< _Type > * | tree
_Type * | nodePtr
_Type * | nodeStart
unsigned long | dwFlags
DynamicTree< _Type >
::DYNTREE_NODEALLOWED 		cbNodeAllowed
DynamicTree< _Type >
::DYNTREE_SUBTREEALLOWED 		cbSubTreeAllowed
bool | bStarting

Friends

bool operator!= (const DynamicTreeIterator< _Type > &iter1, const DynamicTreeIterator< _Type > &iter2)

Constructor & Destructor Documentation

template<class _Type>
DynamicTreeIterator< _Type >::DynamicTreeIterator ( void )
inline

Member Function Documentation

template<class _Type>
_Type* DynamicTreeIterator< _Type >::GetNode ( void )
inline
template<class _Type>
bool DynamicTreeIterator< _Type >::IsFinished ( void )
inline
template<class _Type>
bool DynamicTreeIterator< _Type >::IsNodeAllowed ( _Type * node )
inlineprotected
template<class _Type>
bool DynamicTreeIterator< _Type >::IsSubTreeAllowed ( _Type * node )
inlineprotected
template<class _Type >
DynamicTreeIterator< _Type > & DynamicTreeIterator< _Type >::operator++ ( void )
template<class _Type >
DynamicTreeIterator< _Type > DynamicTreeIterator< _Type >::operator++ ( int )
template<class _Type>
bool DynamicTreeIterator< _Type >::operator== ( const DynamicTreeIterator< _Type > & iter )
inline
template<class _Type>
void DynamicTreeIterator< _Type >::Reset ( void )
inline
template<class _Type>
void DynamicTreeIterator< _Type >::SetNodeAllowedCallback ( typename DynamicTree< _Type >::DYNTREE_NODEALLOWED cb )
inline
template<class _Type>
void DynamicTreeIterator< _Type >::SetSubTreeAllowedCallback ( typename DynamicTree< _Type >::DYNTREE_SUBTREEALLOWED cb )
inline
template<class _Type>
void DynamicTreeIterator< _Type >::SetTree ( DynamicTree< _Type > * _tree )
inline
template<class _Type >
void DynamicTreeIterator< _Type >::Start | ( | _Type * | lpTravStart,
 |  | unsigned long | dwFlags
 | ) |  |

Friends And Related Function Documentation

template<class _Type>
bool operator!= | ( | const DynamicTreeIterator< _Type > & | iter1,
 |  | const DynamicTreeIterator< _Type > & | iter2
 | ) |  |
friend

Member Data Documentation

template<class _Type>
bool DynamicTreeIterator< _Type >::bStarting
protected
template<class _Type>
DynamicTree<_Type>::DYNTREE_NODEALLOWED DynamicTreeIterator< _Type >::cbNodeAllowed
protected
template<class _Type>
DynamicTree<_Type>::DYNTREE_SUBTREEALLOWED DynamicTreeIterator< _Type >::cbSubTreeAllowed
protected
template<class _Type>
unsigned long DynamicTreeIterator< _Type >::dwFlags
protected
template<class _Type>
_Type* DynamicTreeIterator< _Type >::nodePtr
protected
template<class _Type>
_Type* DynamicTreeIterator< _Type >::nodeStart
protected
template<class _Type>
DynamicTree<_Type>* DynamicTreeIterator< _Type >::tree
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/DynamicTree.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: DynTreeNode< _Type > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
DynTreeNode< _Type > Class Template Reference

#include <DynamicTree.h>

Public Member Functions

unsigned long GetDepth ()

Public Attributes

_Type * | lpParent
_Type * | lpChild
_Type * | lpNext
_Type * | lpPrev
DynamicTree< _Type > * | tree

Member Function Documentation

template<class _Type >
unsigned long DynTreeNode< _Type >::GetDepth ( )

Member Data Documentation

template<class _Type>
_Type * DynTreeNode< _Type >::lpChild
template<class _Type>
_Type * DynTreeNode< _Type >::lpNext
template<class _Type>
_Type* DynTreeNode< _Type >::lpParent
template<class _Type>
_Type * DynTreeNode< _Type >::lpPrev
template<class _Type>
DynamicTree<_Type>* DynTreeNode< _Type >::tree
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/DynamicTree.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: EOLineSegmentIntersector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
EOLineSegmentIntersector Class Reference
Inheritance diagram for EOLineSegmentIntersector:

Public Member Functions

EOLineSegmentIntersector (const osg::Vec3d &start, const osg::Vec3d &end)
virtual bool enter (const osg::Node &node)

Constructor & Destructor Documentation

EOLineSegmentIntersector::EOLineSegmentIntersector | ( | const osg::Vec3d & | start,
 |  | const osg::Vec3d & | end
 | ) |  |
inline

Member Function Documentation

bool EOLineSegmentIntersector::enter ( const osg::Node & node )
virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/ShootingSimulation.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: FibonacciHeap< _NodeClass, _keyType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
FibonacciHeap< _NodeClass, _keyType > Class Template Reference

#include <Heaps.h>

Inheritance diagram for FibonacciHeap< _NodeClass, _keyType >:
GenericHeap< _NodeClass, _keyType >

Classes

class FibonacciHeapNode

Public Member Functions

FibonacciHeap (void)
~FibonacciHeap (void)
virtual void | Insert (_NodeClass *node)
virtual _NodeClass * | ExtractMin (void)
virtual void | DecreaseKey (_NodeClass *node, _keyType value)
virtual _NodeClass * | GetMin (void)
virtual _NodeClass * | Delete (_NodeClass *node)
virtual void | Union (FibonacciHeap< _NodeClass, _keyType > *heap)
virtual void | FreeAllNodes ()
virtual bool | IsEmpty ()

Protected Member Functions

void | Consolidate (void)
void | Link (_NodeClass *child, _NodeClass *parent)
virtual void | Cut (_NodeClass *node1, _NodeClass *node2)
virtual void | CascadingCut (_NodeClass *node)
void | FreeNodeSimple (_NodeClass *node)

Protected Attributes

_NodeClass * | head
_NodeClass * | min

Constructor & Destructor Documentation

template<class _NodeClass, class _keyType>
FibonacciHeap< _NodeClass, _keyType >::FibonacciHeap ( void )
template<class _NodeClass, class _keyType>
FibonacciHeap< _NodeClass, _keyType >::~FibonacciHeap ( void )

Member Function Documentation

template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::CascadingCut ( _NodeClass * node )
protectedvirtual
template<class _NodeClass, class _keyType>
void FibonacciHeap< _NodeClass, _keyType >::Consolidate ( void )
protected
template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::Cut | ( | _NodeClass * | node1,
 |  | _NodeClass * | node2
 | ) |  |
protectedvirtual
template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::DecreaseKey | ( | _NodeClass * | node,
 |  | _keyType | value
 | ) |  |
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* FibonacciHeap< _NodeClass, _keyType >::Delete ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* FibonacciHeap< _NodeClass, _keyType >::ExtractMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::FreeAllNodes ( )
virtual
template<class _NodeClass, class _keyType>
void FibonacciHeap< _NodeClass, _keyType >::FreeNodeSimple ( _NodeClass * node )
protected
template<class _NodeClass, class _keyType>
virtual _NodeClass* FibonacciHeap< _NodeClass, _keyType >::GetMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::Insert ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual bool FibonacciHeap< _NodeClass, _keyType >::IsEmpty ( )
inlinevirtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
void FibonacciHeap< _NodeClass, _keyType >::Link | ( | _NodeClass * | child,
 |  | _NodeClass * | parent
 | ) |  |
protected
template<class _NodeClass, class _keyType>
virtual void FibonacciHeap< _NodeClass, _keyType >::Union ( FibonacciHeap< _NodeClass, _keyType > * heap )
virtual

Member Data Documentation

template<class _NodeClass, class _keyType>
_NodeClass* FibonacciHeap< _NodeClass, _keyType >::head
protected
template<class _NodeClass, class _keyType>
_NodeClass* FibonacciHeap< _NodeClass, _keyType >::min
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • FibonacciHeap
  • FibonacciHeapNode
Public Attributes | List of all members
FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode Class Reference

#include <Heaps.h>

Inheritance diagram for FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode:
GenericHeap< _NodeClass, _keyType >::GenericHeapNode

Public Attributes

FibonacciHeapNode * parent
FibonacciHeapNode * left
FibonacciHeapNode * right
FibonacciHeapNode * child
int | degree: ((sizeof(int) * 8) - 1)
unsigned int | mark: 1
- Public Attributes inherited from GenericHeap< _NodeClass, _keyType >::GenericHeapNode
_keyType | key

Member Data Documentation

template<class _NodeClass, class _keyType>
FibonacciHeapNode* FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::child
template<class _NodeClass, class _keyType>
int FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::degree
template<class _NodeClass, class _keyType>
FibonacciHeapNode* FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::left
template<class _NodeClass, class _keyType>
unsigned int FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::mark
template<class _NodeClass, class _keyType>
FibonacciHeapNode* FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::parent
template<class _NodeClass, class _keyType>
FibonacciHeapNode* FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode::right
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: FilletSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
FilletSpline Class Reference

#include <FilletSpline.h>

Inheritance diagram for FilletSpline:

Public Member Functions

FilletSpline (double filletRadius, unsigned int filletSteps, SplinePtr decoratedSpline)
META_DAObjectDecorator (_decoratedSpline, FilletSpline,"Fillet Spline") virtual Vec3ArrayPtr getPoints()

Protected Member Functions

void | generateAllFilletPoints (Vec3ArrayPtr result, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3)
void | getFilletPoints (osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, osg::Vec3 &f1, osg::Vec3 &f2)

Protected Attributes

double | _filletRadius
unsigned int | _filletSteps

Detailed Description

Spline decorator

Each of origin points is replaced by two new points creating fillet with given radius. fillet is interpolated by Catmull-Rom interpolation by given interpolation steps

Constructor & Destructor Documentation

FilletSpline::FilletSpline | ( | double | filletRadius,
 |  | unsigned int | filletSteps,
 |  | SplinePtr | decoratedSpline
 | ) |  |

Member Function Documentation

void FilletSpline::generateAllFilletPoints | ( | Vec3ArrayPtr | result,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3
 | ) |  |
protected
void FilletSpline::getFilletPoints | ( | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3,
 |  | osg::Vec3 & | f1,
 |  | osg::Vec3 & | f2
 | ) |  |
protected
FilletSpline::META_DAObjectDecorator | ( | _decoratedSpline | ,
 |  | FilletSpline | ,
 |  | "Fillet Spline" |
 | ) |  |

Inherited methods

Member Data Documentation

double FilletSpline::_filletRadius
protected
unsigned int FilletSpline::_filletSteps
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FilletSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FilletSpline.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: filter1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
filter1 Class Reference
Inheritance diagram for filter1:

Public Member Functions

filter1 ()
~filter1 ()
void apply (PHANToM *pPHANToM, osg::Vec3 &force)

Constructor & Destructor Documentation

filter1::filter1 ( )
inline
filter1::~filter1 ( )
inline

Member Function Documentation

void filter1::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: filter2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
filter2 Class Reference
Inheritance diagram for filter2:

Public Member Functions

filter2 ()
~filter2 ()
void apply (PHANToM *pPHANToM, osg::Vec3 &force)

Protected Attributes

int flag

Constructor & Destructor Documentation

filter2::filter2 ( )
inline
filter2::~filter2 ( )
inline

Member Function Documentation

void filter2::apply | ( | PHANToM * | pPHANToM,
 |  | osg::Vec3 & | force
 | ) |  |
inline

Member Data Documentation

int filter2::flag
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: FrenetFrame Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
FrenetFrame Class Reference

#include <FrenetFrame.h>

Inheritance diagram for FrenetFrame:

Public Member Functions

FrenetFrame (void)
~FrenetFrame (void)

Constructor & Destructor Documentation

FrenetFrame::FrenetFrame ( void )
FrenetFrame::~FrenetFrame ( void )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FrenetFrame.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FrenetFrame.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: GenericHeap< _NodeClass, _keyType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | List of all members
GenericHeap< _NodeClass, _keyType > Class Template Referenceabstract

#include <Heaps.h>

Inheritance diagram for GenericHeap< _NodeClass, _keyType >:
BinomialHeap< _NodeClass, _keyType > FibonacciHeap< _NodeClass, _keyType > ThinHeap< _NodeClass, _keyType >

Classes

class GenericHeapNode

Public Member Functions

virtual void | Insert (_NodeClass *node)=0
virtual _NodeClass * | ExtractMin (void)=0
virtual void | DecreaseKey (_NodeClass *node, _keyType value)=0
virtual _NodeClass * | GetMin (void)=0
virtual _NodeClass * | Delete (_NodeClass *node)=0
virtual bool | IsEmpty ()=0

Member Function Documentation

template<class _NodeClass , class _keyType >
virtual void GenericHeap< _NodeClass, _keyType >::DecreaseKey | ( | _NodeClass * | node,
 |  | _keyType | value
 | ) |  |
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

template<class _NodeClass , class _keyType >
virtual _NodeClass* GenericHeap< _NodeClass, _keyType >::Delete ( _NodeClass * node )
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

template<class _NodeClass , class _keyType >
virtual _NodeClass* GenericHeap< _NodeClass, _keyType >::ExtractMin ( void )
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

template<class _NodeClass , class _keyType >
virtual _NodeClass* GenericHeap< _NodeClass, _keyType >::GetMin ( void )
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

template<class _NodeClass , class _keyType >
virtual void GenericHeap< _NodeClass, _keyType >::Insert ( _NodeClass * node )
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

template<class _NodeClass , class _keyType >
virtual bool GenericHeap< _NodeClass, _keyType >::IsEmpty ( )
pure virtual

Implemented in ThinHeap< _NodeClass, _keyType >, FibonacciHeap< _NodeClass, _keyType >, and BinomialHeap< _NodeClass, _keyType >.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: GenericHeap< _NodeClass, _keyType >::GenericHeapNode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • GenericHeap
  • GenericHeapNode
Public Attributes | List of all members
GenericHeap< _NodeClass, _keyType >::GenericHeapNode Class Reference

#include <Heaps.h>

Inheritance diagram for GenericHeap< _NodeClass, _keyType >::GenericHeapNode:
BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode

Public Attributes

_keyType key

Member Data Documentation

template<class _NodeClass , class _keyType >
_keyType GenericHeap< _NodeClass, _keyType >::GenericHeapNode::key
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: GeometryState Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
GeometryState Struct Reference

uchovava informace o statickem modelu, jeho data v pameti a pocet referenci (instanci modelu ve scene) More...

#include <ModelManager.h>

Public Member Functions

GeometryState ()
GeometryState (EnvironmentObject *eo)
osg::ref_ptr< EnvironmentObject > | GetGeometry ()
vrati data modelu More...
void | RemoveGeometry ()
smaze data modelu More...
int | Count ()
vrati pocet referenci na model More...
void | AddReference ()
zvysi pocet referenci na model o 1 More...
void | RemoveReference ()
snizi pocet referenci na model o 1 More...

Detailed Description

uchovava informace o statickem modelu, jeho data v pameti a pocet referenci (instanci modelu ve scene)

Constructor & Destructor Documentation

GeometryState::GeometryState ( )
inline
GeometryState::GeometryState ( EnvironmentObject * eo )
inline

Member Function Documentation

void GeometryState::AddReference ( )
inline

zvysi pocet referenci na model o 1

int GeometryState::Count ( )
inline

vrati pocet referenci na model

osg::ref_ptr<EnvironmentObject> GeometryState::GetGeometry ( )
inline

vrati data modelu

void GeometryState::RemoveGeometry ( )
inline

smaze data modelu

void GeometryState::RemoveReference ( )
inline

snizi pocet referenci na model o 1

The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: GetObserver Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
GetObserver Class Referenceabstract

rozhrani pro objekty, ktere zajima udalost Get More...

#include <ModelManager.h>

Inheritance diagram for GetObserver:
Cache

Public Member Functions

GetObserver ()
virtual void GetUpdate (string modelFilename, int num, ModelType modelType)=0

Detailed Description

rozhrani pro objekty, ktere zajima udalost Get

Constructor & Destructor Documentation

GetObserver::GetObserver ( )
inline

Member Function Documentation

virtual void GetObserver::GetUpdate | ( | string | modelFilename,
 |  | int | num,
 |  | ModelType | modelType
 | ) |  |
pure virtual

metoda, ktera se zavola, nastane-li udalost Get v pozorovanem objektu modelFilename - jmeno modelu, ktery se ma ziskat, num - aktualni pocet stejnych objektu ve scene (pocet referenci), modelType - typ modelu

Implemented in Cache.

The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: gmMatrix3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Attributes | Friends | List of all members
gmMatrix3 Class Reference

#include <gm_mat3.h>

Public Member Functions

gmMatrix3 ()
gmMatrix3 (const gmMatrix3 &)
gmMatrix3 (double, double, double, double, double, double, double, double, double)
double * | operator[] (int)
const double * | operator[] (int) const
gmMatrix3 & | assign (double, double, double, double, double, double, double, double, double)
gmMatrix3 & | operator= (const gmMatrix3 &)
gmMatrix3 & | operator+= (const gmMatrix3 &)
gmMatrix3 & | operator-= (const gmMatrix3 &)
gmMatrix3 & | operator*= (const gmMatrix3 &)
gmMatrix3 & | operator*= (double)
gmMatrix3 & | operator/= (double)
gmMatrix3 | operator+ (const gmMatrix3 &) const
gmMatrix3 | operator- (const gmMatrix3 &) const
gmMatrix3 | operator- () const
gmMatrix3 | operator* (const gmMatrix3 &) const
gmMatrix3 | operator* (double) const
gmMatrix3 | operator/ (double) const
bool | operator== (const gmMatrix3 &) const
bool | operator!= (const gmMatrix3 &) const
gmVector3 | operator* (const gmVector3 &) const
gmMatrix3 | inverse () const
gmMatrix3 | transpose () const
gmMatrix3 | adjoint () const
double | determinant () const
bool | isSingular () const
gmVector2 | transform (const gmVector2 &) const
void | copyTo (float[3][3]) const
void | copyTo (double[3][3]) const

Static Public Member Functions

static gmMatrix3 | identity ()
static gmMatrix3 | scale (double, double)
static gmMatrix3 | translate (double, double)
static gmMatrix3 | rotate (double)
static gmMatrix3 | arb_rotate (gmVector3 &, double)

Protected Attributes

double m_ [3][3]

Friends

gmMatrix3 | operator* (double, const gmMatrix3 &)
gmVector3 | operator* (const gmVector3 &, const gmMatrix3 &)
ostream & | operator<< (ostream &, const gmMatrix3 &)

Constructor & Destructor Documentation

gmMatrix3::gmMatrix3 ( )
gmMatrix3::gmMatrix3 ( const gmMatrix3 & M )
gmMatrix3::gmMatrix3 | ( | double | a00,
 |  | double | a01,
 |  | double | a02,
 |  | double | a10,
 |  | double | a11,
 |  | double | a12,
 |  | double | a20,
 |  | double | a21,
 |  | double | a22
 | ) |  |

Member Function Documentation

gmMatrix3 gmMatrix3::adjoint ( ) const
gmMatrix3 gmMatrix3::arb_rotate | ( | gmVector3 & | v,
 |  | double | angle
 | ) |  |
static
gmMatrix3 & gmMatrix3::assign | ( | double | a00,
 |  | double | a01,
 |  | double | a02,
 |  | double | a10,
 |  | double | a11,
 |  | double | a12,
 |  | double | a20,
 |  | double | a21,
 |  | double | a22
 | ) |  |
void gmMatrix3::copyTo ( float f[3][3] ) const
inline
void gmMatrix3::copyTo ( double f[3][3] ) const
inline
double gmMatrix3::determinant ( ) const
gmMatrix3 gmMatrix3::identity ( )
static
gmMatrix3 gmMatrix3::inverse ( ) const
bool gmMatrix3::isSingular ( ) const
bool gmMatrix3::operator!= ( const gmMatrix3 & M ) const
gmMatrix3 gmMatrix3::operator* ( const gmMatrix3 & M ) const
gmMatrix3 gmMatrix3::operator* ( double d ) const
gmVector3 gmMatrix3::operator* ( const gmVector3 & v ) const
gmMatrix3 & gmMatrix3::operator*= ( const gmMatrix3 & M )
gmMatrix3 & gmMatrix3::operator*= ( double d )
gmMatrix3 gmMatrix3::operator+ ( const gmMatrix3 & M ) const
gmMatrix3 & gmMatrix3::operator+= ( const gmMatrix3 & M )
gmMatrix3 gmMatrix3::operator- ( const gmMatrix3 & M ) const
gmMatrix3 gmMatrix3::operator- ( ) const
gmMatrix3 & gmMatrix3::operator-= ( const gmMatrix3 & M )
gmMatrix3 gmMatrix3::operator/ ( double d ) const
gmMatrix3 & gmMatrix3::operator/= ( double d )
gmMatrix3 & gmMatrix3::operator= ( const gmMatrix3 & M )
bool gmMatrix3::operator== ( const gmMatrix3 & M ) const
double * gmMatrix3::operator[] ( int i )
inline
const double * gmMatrix3::operator[] ( int i ) const
inline
gmMatrix3 gmMatrix3::rotate ( double angle )
static
gmMatrix3 gmMatrix3::scale | ( | double | x,
 |  | double | y
 | ) |  |
static
gmVector2 gmMatrix3::transform ( const gmVector2 & v ) const
gmMatrix3 gmMatrix3::translate | ( | double | x,
 |  | double | y
 | ) |  |
static
gmMatrix3 gmMatrix3::transpose ( ) const

Friends And Related Function Documentation

gmMatrix3 operator* | ( | double | d,
 |  | const gmMatrix3 & | M
 | ) |  |
friend
gmVector3 operator* | ( | const gmVector3 & | v,
 |  | const gmMatrix3 & | M
 | ) |  |
friend
ostream& operator<< | ( | ostream & | os,
 |  | const gmMatrix3 & | M
 | ) |  |
friend

Member Data Documentation

double gmMatrix3::m_[3][3]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat3.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat3.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: gmMatrix4 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Attributes | Friends | List of all members
gmMatrix4 Class Reference

#include <gm_mat4.h>

Public Member Functions

gmMatrix4 ()
gmMatrix4 (const gmMatrix4 &)
gmMatrix4 (double, double, double, double, double, double, double, double, double, double, double, double, double, double, double, double)
double * | operator[] (int)
const double * | operator[] (int) const
gmMatrix4 & | assign (double, double, double, double, double, double, double, double, double, double, double, double, double, double, double, double)
gmMatrix4 & | operator= (const gmMatrix4 &)
gmMatrix4 & | operator+= (const gmMatrix4 &)
gmMatrix4 & | operator-= (const gmMatrix4 &)
gmMatrix4 & | operator*= (const gmMatrix4 &)
gmMatrix4 & | operator*= (double)
gmMatrix4 & | operator/= (double)
gmMatrix4 | operator+ (const gmMatrix4 &) const
gmMatrix4 | operator- (const gmMatrix4 &) const
gmMatrix4 | operator- () const
gmMatrix4 | operator* (const gmMatrix4 &) const
gmMatrix4 | operator* (double) const
gmMatrix4 | operator/ (double) const
bool | operator== (const gmMatrix4 &) const
bool | operator!= (const gmMatrix4 &) const
gmVector4 | operator* (const gmVector4 &) const
gmVector3 | mixed_mult (gmVector3 &, const double &)
gmMatrix4 | inverse () const
gmMatrix4 | transpose () const
gmMatrix4 | adjoint () const
double | determinant () const
bool | isSingular () const
gmVector3 | transform (const gmVector3 &) const
void | copyTo (float[4][4]) const
void | copyTo (double[4][4]) const

Static Public Member Functions

static gmMatrix4 | identity ()
static gmMatrix4 | rotate (double, const gmVector3 &axis)
static gmMatrix4 | scale (double, double, double)
static gmMatrix4 | translate (double, double, double)
static gmMatrix4 | arb_rotate (gmVector3 &, double)
static gmMatrix4 | bezierBasis ()
static gmMatrix4 | bsplineBasis ()
static gmMatrix4 | catmullromBasis ()
static gmMatrix4 | hermiteBasis ()
static gmMatrix4 | tensedBSplineBasis (double)
static gmMatrix4 | cardinalBasis (double)
static gmMatrix4 | tauBasis (double, double)
static gmMatrix4 | betaSplineBasis (double, double)

Protected Attributes

double m_ [4][4]

Friends

gmMatrix4 | operator* (double, const gmMatrix4 &)
gmVector4 | operator* (const gmVector4 &, const gmMatrix4 &)
ostream & | operator<< (ostream &, const gmMatrix4 &)

Constructor & Destructor Documentation

gmMatrix4::gmMatrix4 ( )
gmMatrix4::gmMatrix4 ( const gmMatrix4 & M )
gmMatrix4::gmMatrix4 | ( | double | a00,
 |  | double | a01,
 |  | double | a02,
 |  | double | a03,
 |  | double | a10,
 |  | double | a11,
 |  | double | a12,
 |  | double | a13,
 |  | double | a20,
 |  | double | a21,
 |  | double | a22,
 |  | double | a23,
 |  | double | a30,
 |  | double | a31,
 |  | double | a32,
 |  | double | a33
 | ) |  |

Member Function Documentation

gmMatrix4 gmMatrix4::adjoint ( ) const
gmMatrix4 gmMatrix4::arb_rotate | ( | gmVector3 & | v,
 |  | double | angle
 | ) |  |
static
gmMatrix4 & gmMatrix4::assign | ( | double | a00,
 |  | double | a01,
 |  | double | a02,
 |  | double | a03,
 |  | double | a10,
 |  | double | a11,
 |  | double | a12,
 |  | double | a13,
 |  | double | a20,
 |  | double | a21,
 |  | double | a22,
 |  | double | a23,
 |  | double | a30,
 |  | double | a31,
 |  | double | a32,
 |  | double | a33
 | ) |  |
gmMatrix4 gmMatrix4::betaSplineBasis | ( | double | bias,
 |  | double | tension
 | ) |  |
static
gmMatrix4 gmMatrix4::bezierBasis ( )
static
gmMatrix4 gmMatrix4::bsplineBasis ( )
static
gmMatrix4 gmMatrix4::cardinalBasis ( double tension )
static
gmMatrix4 gmMatrix4::catmullromBasis ( )
static
void gmMatrix4::copyTo ( float f[4][4] ) const
inline
void gmMatrix4::copyTo ( double f[4][4] ) const
inline
double gmMatrix4::determinant ( ) const
gmMatrix4 gmMatrix4::hermiteBasis ( )
static
gmMatrix4 gmMatrix4::identity ( )
static
gmMatrix4 gmMatrix4::inverse ( ) const
bool gmMatrix4::isSingular ( ) const
gmVector3 gmMatrix4::mixed_mult | ( | gmVector3 & | v,
 |  | const double & | d
 | ) |  |
bool gmMatrix4::operator!= ( const gmMatrix4 & M ) const
gmMatrix4 gmMatrix4::operator* ( const gmMatrix4 & M ) const
gmMatrix4 gmMatrix4::operator* ( double d ) const
gmVector4 gmMatrix4::operator* ( const gmVector4 & v ) const
gmMatrix4 & gmMatrix4::operator*= ( const gmMatrix4 & M )
gmMatrix4 & gmMatrix4::operator*= ( double d )
gmMatrix4 gmMatrix4::operator+ ( const gmMatrix4 & M ) const
gmMatrix4 & gmMatrix4::operator+= ( const gmMatrix4 & M )
gmMatrix4 gmMatrix4::operator- ( const gmMatrix4 & M ) const
gmMatrix4 gmMatrix4::operator- ( ) const
gmMatrix4 & gmMatrix4::operator-= ( const gmMatrix4 & M )
gmMatrix4 gmMatrix4::operator/ ( double d ) const
gmMatrix4 & gmMatrix4::operator/= ( double d )
gmMatrix4 & gmMatrix4::operator= ( const gmMatrix4 & M )
bool gmMatrix4::operator== ( const gmMatrix4 & M ) const
double * gmMatrix4::operator[] ( int i )
inline
const double * gmMatrix4::operator[] ( int i ) const
inline
gmMatrix4 gmMatrix4::rotate | ( | double | angle,
 |  | const gmVector3 & | axis
 | ) |  |
static
gmMatrix4 gmMatrix4::scale | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
static
gmMatrix4 gmMatrix4::tauBasis | ( | double | bias,
 |  | double | tension
 | ) |  |
static
gmMatrix4 gmMatrix4::tensedBSplineBasis ( double tension )
static
gmVector3 gmMatrix4::transform ( const gmVector3 & v ) const
gmMatrix4 gmMatrix4::translate | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
static
gmMatrix4 gmMatrix4::transpose ( ) const

Friends And Related Function Documentation

gmMatrix4 operator* | ( | double | d,
 |  | const gmMatrix4 & | M
 | ) |  |
friend
gmVector4 operator* | ( | const gmVector4 & | v,
 |  | const gmMatrix4 & | M
 | ) |  |
friend
ostream& operator<< | ( | ostream & | os,
 |  | const gmMatrix4 & | M
 | ) |  |
friend

Member Data Documentation

double gmMatrix4::m_[4][4]
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat4.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat4.cpp
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: gmVector2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
gmVector2 Class Reference

#include <gm_vec2.h>

Public Member Functions

gmVector2 ()
gmVector2 (const gmVector2 &)
gmVector2 (double, double)
double & | operator[] (int)
const double & | operator[] (int) const
gmVector2 & | assign (double, double)
gmVector2 & | operator= (const gmVector2 &)
gmVector2 & | operator+= (const gmVector2 &)
gmVector2 & | operator-= (const gmVector2 &)
gmVector2 & | operator*= (double)
gmVector2 & | operator/= (double)
gmVector2 | operator+ (const gmVector2 &) const
gmVector2 | operator- (const gmVector2 &) const
gmVector2 | operator- () const
gmVector2 | operator* (double) const
gmVector2 | operator/ (double) const
bool | operator== (const gmVector2 &) const
bool | operator!= (const gmVector2 &) const
gmVector2 & | clamp (double, double)
double | length () const
double | lengthSquared () const
gmVector2 & normalize ()
void | copyTo (float[2]) const
void | copyTo (double[2]) const

Protected Attributes

double v_ [2]

Friends

gmVector2 | operator* (double, const gmVector2 &)
double | distance (const gmVector2 &, const gmVector2 &)
double | distanceSquared (const gmVector2 &, const gmVector2 &)
double | dot (const gmVector2 &, const gmVector2 &)
gmVector2 | lerp (double, const gmVector2 &, const gmVector2 &)
ostream & | operator<< (ostream &, const gmVector2 &)

Constructor & Destructor Documentation

gmVector2::gmVector2 ( )
inline
gmVector2::gmVector2 ( const gmVector2 & v )
inline
gmVector2::gmVector2 | ( | double | x,
 |  | double | y
 | ) |  |
inline

Member Function Documentation

gmVector2 & gmVector2::assign | ( | double | x,
 |  | double | y
 | ) |  |
inline
gmVector2 & gmVector2::clamp | ( | double | lo,
 |  | double | hi
 | ) |  |
inline
void gmVector2::copyTo ( float f[2] ) const
inline
void gmVector2::copyTo ( double f[2] ) const
inline
double gmVector2::length ( ) const
inline
double gmVector2::lengthSquared ( ) const
inline
gmVector2 & gmVector2::normalize ( )
inline
bool gmVector2::operator!= ( const gmVector2 & v ) const
inline
gmVector2 gmVector2::operator* ( double c ) const
inline
gmVector2 & gmVector2::operator*= ( double c )
inline
gmVector2 gmVector2::operator+ ( const gmVector2 & v ) const
inline
gmVector2 & gmVector2::operator+= ( const gmVector2 & v )
inline
gmVector2 gmVector2::operator- ( const gmVector2 & v ) const
inline
gmVector2 gmVector2::operator- ( ) const
inline
gmVector2 & gmVector2::operator-= ( const gmVector2 & v )
inline
gmVector2 gmVector2::operator/ ( double c ) const
inline
gmVector2 & gmVector2::operator/= ( double c )
inline
gmVector2 & gmVector2::operator= ( const gmVector2 & v )
inline
bool gmVector2::operator== ( const gmVector2 & v ) const
inline
double & gmVector2::operator[] ( int i )
inline
const double & gmVector2::operator[] ( int i ) const
inline

Friends And Related Function Documentation

double distance | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
friend
double distanceSquared | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
friend
double dot | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
friend
gmVector2 lerp | ( | double | f,
 |  | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
friend
gmVector2 operator* | ( | double | c,
 |  | const gmVector2 & | v
 | ) |  |
friend
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector2 & | v
 | ) |  |
friend

Member Data Documentation

double gmVector2::v_[2]
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec2.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: gmVector3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
gmVector3 Class Reference

#include <gm_vec3.h>

Public Member Functions

gmVector3 ()
gmVector3 (const gmVector3 &)
gmVector3 (double, double, double)
double & | operator[] (int)
const double & | operator[] (int) const
gmVector3 & | assign (double, double, double)
gmVector3 & | operator= (const gmVector3 &)
gmVector3 & | operator+= (const gmVector3 &)
gmVector3 & | operator-= (const gmVector3 &)
gmVector3 & | operator*= (double)
gmVector3 & | operator/= (double)
gmVector3 | operator+ (const gmVector3 &) const
gmVector3 | operator- (const gmVector3 &) const
gmVector3 | operator- () const
gmVector3 | operator* (double) const
gmVector3 | operator/ (double) const
bool | operator== (const gmVector3 &) const
bool | operator!= (const gmVector3 &) const
gmVector3 & | clamp (double, double)
double | length () const
double | lengthSquared () const
gmVector3 & normalize ()
bool | isZero ()
void | copyTo (float[3]) const
void | copyTo (double[3]) const
void | float2double (const float *v)
void | double2float (const double *v)

Protected Attributes

double v_ [3]

Friends

gmVector3 | operator* (double, const gmVector3 &)
gmVector3 | cross (const gmVector3 &, const gmVector3 &)
double | distance (const gmVector3 &, const gmVector3 &)
double | distanceSquared (const gmVector3 &, const gmVector3 &)
double | dot (const gmVector3 &, const gmVector3 &)
gmVector3 | lerp (double, const gmVector3 &, const gmVector3 &)
double | plane_intersect (const gmVector3 &, const gmVector3 &, const gmVector3 &, const gmVector3 &)
double | line_distance (const gmVector3 &, const gmVector3 &, const gmVector3 &, const gmVector3 &)
double | plane_distance (const gmVector3 &, const gmVector3 &, const gmVector3 &)
ostream & | operator<< (ostream &, const gmVector3 &)

Constructor & Destructor Documentation

gmVector3::gmVector3 ( )
inline
gmVector3::gmVector3 ( const gmVector3 & v )
inline
gmVector3::gmVector3 | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
inline

Member Function Documentation

gmVector3 & gmVector3::assign | ( | double | x,
 |  | double | y,
 |  | double | z
 | ) |  |
inline
gmVector3 & gmVector3::clamp | ( | double | lo,
 |  | double | hi
 | ) |  |
inline
void gmVector3::copyTo ( float f[3] ) const
inline
void gmVector3::copyTo ( double f[3] ) const
inline
void gmVector3::double2float ( const double * v )
inline
void gmVector3::float2double ( const float * v )
inline
bool gmVector3::isZero ( )
inline
double gmVector3::length ( ) const
inline
double gmVector3::lengthSquared ( ) const
inline
gmVector3 & gmVector3::normalize ( )
inline
bool gmVector3::operator!= ( const gmVector3 & v ) const
inline
gmVector3 gmVector3::operator* ( double c ) const
inline
gmVector3 & gmVector3::operator*= ( double c )
inline
gmVector3 gmVector3::operator+ ( const gmVector3 & v ) const
inline
gmVector3 & gmVector3::operator+= ( const gmVector3 & v )
inline
gmVector3 gmVector3::operator- ( const gmVector3 & v ) const
inline
gmVector3 gmVector3::operator- ( ) const
inline
gmVector3 & gmVector3::operator-= ( const gmVector3 & v )
inline
gmVector3 gmVector3::operator/ ( double c ) const
inline
gmVector3 & gmVector3::operator/= ( double c )
inline
gmVector3 & gmVector3::operator= ( const gmVector3 & v )
inline
bool gmVector3::operator== ( const gmVector3 & v ) const
inline
double & gmVector3::operator[] ( int i )
inline
const double & gmVector3::operator[] ( int i ) const
inline

Friends And Related Function Documentation

gmVector3 cross | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
friend
double distance | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
friend
double distanceSquared | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
friend
double dot | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
friend
gmVector3 lerp | ( | double | f,
 |  | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
friend
double line_distance | ( | const gmVector3 & | p1,
 |  | const gmVector3 & | v1,
 |  | const gmVector3 & | p2,
 |  | const gmVector3 & | v2
 | ) |  |
friend
gmVector3 operator* | ( | double | c,
 |  | const gmVector3 & | v
 | ) |  |
friend
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector3 & | v
 | ) |  |
friend
double plane_distance | ( | const gmVector3 & | p,
 |  | const gmVector3 & | plane_p,
 |  | const gmVector3 & | plane_norm
 | ) |  |
friend
double plane_intersect | ( | const gmVector3 & | p,
 |  | const gmVector3 & | v,
 |  | const gmVector3 & | plane_p,
 |  | const gmVector3 & | plane_norm
 | ) |  |
friend

Member Data Documentation

double gmVector3::v_[3]
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec3.h
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: gmVector4 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Friends | List of all members
gmVector4 Class Reference

#include <gm_vec4.h>

Public Member Functions

gmVector4 ()
gmVector4 (const gmVector4 &)
gmVector4 (double, double, double, double)
double & | operator[] (int)
const double & | operator[] (int) const
gmVector4 & | assign (double, double, double, double)
gmVector4 & | operator= (const gmVector4 &)
gmVector4 & | operator+= (const gmVector4 &)
gmVector4 & | operator-= (const gmVector4 &)
gmVector4 & | operator*= (double)
gmVector4 & | operator/= (double)
gmVector4 | operator+ (const gmVector4 &) const
gmVector4 | operator- (const gmVector4 &) const
gmVector4 | operator- () const
gmVector4 | operator* (double) const
gmVector4 | operator/ (double) const
bool | operator== (const gmVector4 &) const
bool | operator!= (const gmVector4 &) const
gmVector4 & | clamp (double, double)
double | length () const
double | lengthSquared () const
gmVector4 & normalize ()
void | copyTo (float[4]) const
void | copyTo (double[4]) const

Protected Attributes

double v_ [4]

Friends

gmVector4 | operator* (double, const gmVector4 &)
double | distance (const gmVector4 &, const gmVector4 &)
double | distanceSquared (const gmVector4 &, const gmVector4 &)
double | dot (const gmVector4 &, const gmVector4 &)
gmVector4 | lerp (double, const gmVector4 &, const gmVector4 &)
ostream & | operator<< (ostream &, const gmVector4 &)

Constructor & Destructor Documentation

gmVector4::gmVector4 ( )
inline
gmVector4::gmVector4 ( const gmVector4 & v )
inline
gmVector4::gmVector4 | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | double | a
 | ) |  |
inline

Member Function Documentation

gmVector4 & gmVector4::assign | ( | double | x,
 |  | double | y,
 |  | double | z,
 |  | double | a
 | ) |  |
inline
gmVector4 & gmVector4::clamp | ( | double | lo,
 |  | double | hi
 | ) |  |
inline
void gmVector4::copyTo ( float f[4] ) const
inline
void gmVector4::copyTo ( double f[4] ) const
inline
double gmVector4::length ( ) const
inline
double gmVector4::lengthSquared ( ) const
inline
gmVector4 & gmVector4::normalize ( )
inline
bool gmVector4::operator!= ( const gmVector4 & v ) const
inline
gmVector4 gmVector4::operator* ( double c ) const
inline
gmVector4 & gmVector4::operator*= ( double c )
inline
gmVector4 gmVector4::operator+ ( const gmVector4 & v ) const
inline
gmVector4 & gmVector4::operator+= ( const gmVector4 & v )
inline
gmVector4 gmVector4::operator- ( const gmVector4 & v ) const
inline
gmVector4 gmVector4::operator- ( ) const
inline
gmVector4 & gmVector4::operator-= ( const gmVector4 & v )
inline
gmVector4 gmVector4::operator/ ( double c ) const
inline
gmVector4 & gmVector4::operator/= ( double c )
inline
gmVector4 & gmVector4::operator= ( const gmVector4 & v )
inline
bool gmVector4::operator== ( const gmVector4 & v ) const
inline
double & gmVector4::operator[] ( int i )
inline
const double & gmVector4::operator[] ( int i ) const
inline

Friends And Related Function Documentation

double distance | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
friend
double distanceSquared | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
friend
double dot | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
friend
gmVector4 lerp | ( | double | f,
 |  | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
friend
gmVector4 operator* | ( | double | c,
 |  | const gmVector4 & | v
 | ) |  |
friend
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector4 & | v
 | ) |  |
friend

Member Data Documentation

double gmVector4::v_[4]
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec4.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: GradientColorGen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Attributes | List of all members
GradientColorGen Class Reference

#include <GradientColorGen.h>

Inheritance diagram for GradientColorGen:

Public Member Functions

GradientColorGen ()
GradientColorGen (const osg::Vec4 &colorStart, const osg::Vec4 &colorEnd)
META_DAObject (GradientColorGen,"Gradient Brush") virtual Vec4ArrayPtr getColors(unsigned int leadSplineSize
result reserve (arraySize)
for (unsigned int i=0;i< leadSplineSize;i++)
osg::Vec4 | getColorEnd () const
void | setColorEnd (osg::Vec4 val)
osg::Vec4 | getColorStart () const
void | setColorStart (osg::Vec4 val)

Public Attributes

unsigned int | crossSectionSize
Vec4ArrayPtr | result = new osg::Vec4Array
unsigned int | arraySize = leadSplineSize * crossSectionSize
osg::Vec4 | gradientStep = (_colorEnd - _colorStart) / (double)leadSplineSize
osg::Vec4 | actualColor
return | result

Protected Attributes

osg::Vec4 | _colorStart
osg::Vec4 | _colorEnd

Constructor & Destructor Documentation

GradientColorGen::GradientColorGen ( )
inline
GradientColorGen::GradientColorGen | ( | const osg::Vec4 & | colorStart,
 |  | const osg::Vec4 & | colorEnd
 | ) |  |
inline

Member Function Documentation

GradientColorGen::for ( )
inline
osg::Vec4 GradientColorGen::getColorEnd ( ) const
inline
osg::Vec4 GradientColorGen::getColorStart ( ) const
inline
GradientColorGen::META_DAObject | ( | GradientColorGen | ,
 |  | "Gradient Brush" |
 | ) |  |

Inherited methods

result GradientColorGen::reserve ( arraySize )
void GradientColorGen::setColorEnd ( osg::Vec4 val )
inline
void GradientColorGen::setColorStart ( osg::Vec4 val )
inline

Member Data Documentation

osg::Vec4 GradientColorGen::_colorEnd
protected
osg::Vec4 GradientColorGen::_colorStart
protected
osg::Vec4 GradientColorGen::actualColor
unsigned int GradientColorGen::arraySize = leadSplineSize * crossSectionSize
unsigned int GradientColorGen::crossSectionSize
Initial value:
{
_dirty = false
osg::Vec4 GradientColorGen::gradientStep = (_colorEnd - _colorStart) / (double)leadSplineSize
Vec4ArrayPtr GradientColorGen::result = new osg::Vec4Array
return GradientColorGen::result
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientColorGen.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: GradientDiameterGen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
GradientDiameterGen Class Reference

#include <GradientDiameterGen.h>

Inheritance diagram for GradientDiameterGen:

Public Member Functions

GradientDiameterGen ()
GradientDiameterGen (double diameterStart, double diameterEnd)
META_DAObject (GradientDiameterGen,"Gradient Diameter") virtual DoubleArrayPtr getDiameters(unsigned int arraySize)
double | getDiameterEnd () const
void | setDiameterEnd (double val)
double | getDiameterStart () const
void | setDiameterStart (double val)

Protected Attributes

double | _diameterStart
double | _diameterEnd

Constructor & Destructor Documentation

GradientDiameterGen::GradientDiameterGen ( )
inline
GradientDiameterGen::GradientDiameterGen | ( | double | diameterStart,
 |  | double | diameterEnd
 | ) |  |
inline

Member Function Documentation

double GradientDiameterGen::getDiameterEnd ( ) const
inline
double GradientDiameterGen::getDiameterStart ( ) const
inline
GradientDiameterGen::META_DAObject | ( | GradientDiameterGen | ,
 |  | "Gradient Diameter" |
 | ) |  |
inline

Inherited methods

void GradientDiameterGen::setDiameterEnd ( double val )
inline
void GradientDiameterGen::setDiameterStart ( double val )
inline

Member Data Documentation

double GradientDiameterGen::_diameterEnd
protected
double GradientDiameterGen::_diameterStart
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientDiameterGen.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Hci Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
Hci Class Reference

#include <hci.h>

Public Member Functions

void | init (const char *port)
hci_result connect ()
void | disconnect ()
hci_result getStrings ()
hci_result autosynch ()
hci_result begin ()
void | end ()
void | clearPacket ()
void | comParams (const char *port)
void | fastTimeout ()
void | slowTimeout ()
void | stdCmd (int timer_flag, int analog_reports, int encoder_reports)
void | simpleCfgCmd (byte cmnd)
hci_result | stringCmd (byte cmnd)
hci_result | getParams (byte *block, int *block_size)
hci_result | getExtParams (byte *block, int *block_size)
hci_result goHomePos ()
hci_result getMaxes ()
hci_result waitPacket ()
hci_result | checkPacket (int checkType)
hci_result | buildPacket (int checkTYpe)
hci_result parsePacket ()
hci_result parseCfgPacket ()
hci_result | readString (char *str)
hci_result | readBlock (byte *block, int *bytes_read)
void | invalidateFields ()
hci_result | error (hci_result condition)
hci_result | simpleString (hci_result condition)

Public Attributes

char | serial_number [MAX_STRING_SIZE]
char | product_name [MAX_STRING_SIZE]
char | product_id [MAX_STRING_SIZE]
char | model_name [MAX_STRING_SIZE]
char | comment [MAX_STRING_SIZE]
char | param_format [MAX_STRING_SIZE]
char | version [MAX_STRING_SIZE]
int | buttons
int | button [NUM_BUTTONS]
long | timer
int | analog [NUM_ANALOGS]
int | encoder [NUM_ENCODERS]
int | timer_updated
int | analog_updated [NUM_ANALOGS]
int | encoder_updated [NUM_ENCODERS]
int | button_supported [NUM_BUTTONS]
int | max_timer
int | max_analog [NUM_ANALOGS]
int | max_encoder [NUM_ENCODERS]
hci_result(* | BAD_PORT_handler )(hci_result condition)
hci_result(* | CANT_OPEN_handler )(hci_result condition)
hci_result(* | NO_HCI_handler )(hci_result condition)
hci_result(* | CANT_BEGIN_handler )(hci_result condition)
hci_result(* | TIMED_OUT_handler )(hci_result condition)
hci_result(* | BAD_PACKET_handler )(hci_result condition)
hci_result(* | BAD_PASSWORD_handler )(hci_result condition)
hci_result(* | BAD_VERSION_handler )(hci_result condition)
hci_result(* | BAD_FORMAT_handler )(hci_result condition)
hci_result(* default_handler )()

Member Function Documentation

hci_result Hci::autosynch ( )
hci_result Hci::begin ( )
hci_result Hci::buildPacket ( int checkTYpe )
hci_result Hci::checkPacket ( int checkType )
void Hci::clearPacket ( )
void Hci::comParams ( const char * port )
hci_result Hci::connect ( )
void Hci::disconnect ( )
void Hci::end ( )
hci_result Hci::error ( hci_result condition )
void Hci::fastTimeout ( )
hci_result Hci::getExtParams | ( | byte * | block,
 |  | int * | block_size
 | ) |  |
hci_result Hci::getMaxes ( )
hci_result Hci::getParams | ( | byte * | block,
 |  | int * | block_size
 | ) |  |
hci_result Hci::getStrings ( )
hci_result Hci::goHomePos ( )
void Hci::init ( const char * port )
void Hci::invalidateFields ( )
hci_result Hci::parseCfgPacket ( )
hci_result Hci::parsePacket ( )
hci_result Hci::readBlock | ( | byte * | block,
 |  | int * | bytes_read
 | ) |  |
hci_result Hci::readString ( char * str )
void Hci::simpleCfgCmd ( byte cmnd )
hci_result Hci::simpleString ( hci_result condition )
void Hci::slowTimeout ( )
void Hci::stdCmd | ( | int | timer_flag,
 |  | int | analog_reports,
 |  | int | encoder_reports
 | ) |  |
hci_result Hci::stringCmd ( byte cmnd )
hci_result Hci::waitPacket ( )

Member Data Documentation

int Hci::analog[NUM_ANALOGS]
int Hci::analog_updated[NUM_ANALOGS]
hci_result(* Hci::BAD_FORMAT_handler)(hci_result condition)
hci_result(* Hci::BAD_PACKET_handler)(hci_result condition)
hci_result(* Hci::BAD_PASSWORD_handler)(hci_result condition)
hci_result(* Hci::BAD_PORT_handler)(hci_result condition)
hci_result(* Hci::BAD_VERSION_handler)(hci_result condition)
int Hci::button[NUM_BUTTONS]
int Hci::button_supported[NUM_BUTTONS]
int Hci::buttons
hci_result(* Hci::CANT_BEGIN_handler)(hci_result condition)
hci_result(* Hci::CANT_OPEN_handler)(hci_result condition)
char Hci::comment[MAX_STRING_SIZE]
hci_result(* Hci::default_handler)()
int Hci::encoder[NUM_ENCODERS]
int Hci::encoder_updated[NUM_ENCODERS]
int Hci::max_analog[NUM_ANALOGS]
int Hci::max_encoder[NUM_ENCODERS]
int Hci::max_timer
char Hci::model_name[MAX_STRING_SIZE]
hci_result(* Hci::NO_HCI_handler)(hci_result condition)
char Hci::param_format[MAX_STRING_SIZE]
char Hci::product_id[MAX_STRING_SIZE]
char Hci::product_name[MAX_STRING_SIZE]
char Hci::serial_number[MAX_STRING_SIZE]
hci_result(* Hci::TIMED_OUT_handler)(hci_result condition)
long Hci::timer
int Hci::timer_updated
char Hci::version[MAX_STRING_SIZE]
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/hci.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Hci.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Icon Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
Icon Class Reference

Icon. More...

#include <Icon.h>

Inheritance diagram for Icon:

Public Member Functions

Icon ()
~Icon ()
void | clicked ()
int | load (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *IconNode)
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
void | postInitialize ()
void | pointed (bool pointed)
void | save (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *IconNode)
void | setColorofPart (std::string partName, osg::Vec4 *newColor)
Recolor given part of geometry of icon. More...
virtual void | update ()

Protected Attributes

IconType type
Type of this icon. More...
bool | defaultState
Used only if this Icon type is switch. More...
osg::Vec4 | originalColor
Original (loaded from .3ds) color of part of icon. More...
std::string | colorablePartName

Detailed Description

Icon.

Ability for simple adding button or switches to scene. Handle situations, when user point to Icon and click on Icon. Ability should be added as child to EO with some geometry.

Author
Jiri Chmelik
Date
2010

Constructor & Destructor Documentation

Icon::Icon ( )
Icon::~Icon ( )

Member Function Documentation

void Icon::clicked ( )
int Icon::load ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * IconNode )
bool Icon::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * parametersNode )
void Icon::pointed ( bool pointed )
void Icon::postInitialize ( void )
void Icon::save | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * | Document,
 |  | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | IconNode
 | ) |  |
void Icon::setColorofPart | ( | std::string | partName,
 |  | osg::Vec4 * | newColor
 | ) |  |

Recolor given part of geometry of icon.

void Icon::update ( void )
virtual

Member Data Documentation

std::string Icon::colorablePartName
protected
bool Icon::defaultState
protected

Used only if this Icon type is switch.

osg::Vec4 Icon::originalColor
protected

Original (loaded from .3ds) color of part of icon.

IconType Icon::type
protected

Type of this icon.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Icon.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Icon.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: InterpolatedSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
InterpolatedSpline Class Reference

#include <InterpolatedSpline.h>

Inheritance diagram for InterpolatedSpline:

Public Member Functions

InterpolatedSpline (SplinePtr decoratedSpline)
InterpolatedSpline (InterpolatorPtr interpolator, unsigned int interpolationSteps, SplinePtr decoratedSpline)
META_DAObjectDecorator (_decoratedSpline, InterpolatedSpline,"Interpolated Spline") virtual Vec3ArrayPtr getPoints()
void | setInterpolator (InterpolatorPtr interpolator)
InterpolatorPtr getInterpolator ()
int | getInterpolationSteps () const
void | setInterpolationSteps (int val)

Protected Attributes

InterpolatorPtr _interpolator
unsigned int _interpolationSteps

Constructor & Destructor Documentation

InterpolatedSpline::InterpolatedSpline ( SplinePtr decoratedSpline )
InterpolatedSpline::InterpolatedSpline | ( | InterpolatorPtr | interpolator,
 |  | unsigned int | interpolationSteps,
 |  | SplinePtr | decoratedSpline
 | ) |  |

Member Function Documentation

int InterpolatedSpline::getInterpolationSteps ( ) const
inline
InterpolatorPtr InterpolatedSpline::getInterpolator ( )
inline
InterpolatedSpline::META_DAObjectDecorator | ( | _decoratedSpline | ,
 |  | InterpolatedSpline | ,
 |  | "Interpolated Spline" |
 | ) |  |

Inherited methods

void InterpolatedSpline::setInterpolationSteps ( int val )
inline
void InterpolatedSpline::setInterpolator ( InterpolatorPtr interpolator )
inline

Getters and setters

Member Data Documentation

unsigned int InterpolatedSpline::_interpolationSteps
protected
InterpolatorPtr InterpolatedSpline::_interpolator
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/InterpolatedSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/InterpolatedSpline.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Interpolator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | List of all members
Interpolator Class Referenceabstract

#include <Interpolator.h>

Inheritance diagram for Interpolator:
CatmullRomInterpolator CubicInterpolator LinearInterpolator NullInterpolator

Public Member Functions

virtual Vec3ArrayPtr | interpolate (const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Protected Member Functions

virtual ~Interpolator ()

Constructor & Destructor Documentation

virtual Interpolator::~Interpolator ( )
inlineprotectedvirtual

Member Function Documentation

virtual std::string Interpolator::classDescription ( ) const
pure virtual
virtual std::string Interpolator::className ( ) const
pure virtual
virtual Vec3ArrayPtr Interpolator::interpolate | ( | const Vec3ArrayPtr | array,
 |  | unsigned int | interpolationSteps,
 |  | bool | closed
 | ) |  |
pure virtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Interpolator.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: InterpolatorFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
InterpolatorFactory Class Reference

#include <Factories.h>

Static Public Member Functions

static std::vector< std::string > | getSupportedInterpolators ()
static InterpolatorPtr | get (const std::string &name)

Member Function Documentation

static InterpolatorPtr InterpolatorFactory::get ( const std::string & name )
inlinestatic
static std::vector<std::string> InterpolatorFactory::getSupportedInterpolators ( )
inlinestatic
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Factories.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: length_3D Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
length_3D Struct Reference

#include <arm.h>

Public Attributes

length x
length y
length z

Member Data Documentation

length length_3D::x
length length_3D::y
length length_3D::z
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/arm.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: LinearInterpolator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
LinearInterpolator Class Reference

#include <LinearInterpolator.h>

Inheritance diagram for LinearInterpolator:
Interpolator

Public Member Functions

META_DAObject (LinearInterpolator,"Linear Interpolator") virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array
- Public Member Functions inherited from Interpolator
virtual Vec3ArrayPtr | interpolate (const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0
virtual std::string | classDescription () const =0
virtual std::string | className () const =0

Public Attributes

unsigned int | interpolationSteps
unsigned int bool | closed

Additional Inherited Members

- Protected Member Functions inherited from Interpolator
virtual ~Interpolator ()

Member Function Documentation

LinearInterpolator::META_DAObject | ( | LinearInterpolator | ,
 |  | "Linear Interpolator" |
 | ) |  | const

Inherited virtual methods

Member Data Documentation

unsigned int bool LinearInterpolator::closed
unsigned int LinearInterpolator::interpolationSteps
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/LinearInterpolator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/LinearInterpolator.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: LoadingConsole Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Attributes | List of all members
LoadingConsole Class Reference

#include <LoadingConsole.h>

Classes

class | Line
class | OutstandingLine

Public Member Functions

LoadingConsole ()
~LoadingConsole ()
bool | create (vrecko::ViewerBase *_viewer, osg::Group *_rootNode)
void | destroy ()
void | addLine (unsigned long dwOutputType, const char *outputLine)
void | update ()

Protected Attributes

std::vector< Line > | lines
MTLock olLock
std::vector< OutstandingLine > | outstandingLines
vrecko::ViewerBase * viewer
osg::Group * | rootNode
int | viewWidth
int | viewHeight
int | borderXSize
int | borderYSize
int | lineSpace
int | lineHeight
osg::ref_ptr< osg::Vec3Array > | vertices
osg::ref_ptr< osg::ClipNode > | mainNode
osg::ref_ptr< osg::Camera > | camera
osg::ref_ptr< osg::Geode > | geode
osg::ref_ptr< osg::Geometry > | geom

Constructor & Destructor Documentation

LoadingConsole::LoadingConsole ( )
LoadingConsole::~LoadingConsole ( )

Member Function Documentation

void LoadingConsole::addLine | ( | unsigned long | dwOutputType,
 |  | const char * | outputLine
 | ) |  |
bool LoadingConsole::create | ( | vrecko::ViewerBase * | _viewer,
 |  | osg::Group * | _rootNode
 | ) |  |
void LoadingConsole::destroy ( )
void LoadingConsole::update ( void )

Member Data Documentation

int LoadingConsole::borderXSize
protected
int LoadingConsole::borderYSize
protected
osg::ref_ptr<osg::Camera> LoadingConsole::camera
protected
osg::ref_ptr<osg::Geode> LoadingConsole::geode
protected
osg::ref_ptr<osg::Geometry> LoadingConsole::geom
protected
int LoadingConsole::lineHeight
protected
std::vector<Line> LoadingConsole::lines
protected
int LoadingConsole::lineSpace
protected
osg::ref_ptr<osg::ClipNode> LoadingConsole::mainNode
protected
MTLock LoadingConsole::olLock
protected
std::vector<OutstandingLine> LoadingConsole::outstandingLines
protected
osg::Group* LoadingConsole::rootNode
protected
osg::ref_ptr<osg::Vec3Array> LoadingConsole::vertices
protected
vrecko::ViewerBase* LoadingConsole::viewer
protected
int LoadingConsole::viewHeight
protected
int LoadingConsole::viewWidth
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.h
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: LoadingConsole::Line Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LoadingConsole
  • Line
Public Member Functions | Public Attributes | List of all members
LoadingConsole::Line Class Reference

#include <LoadingConsole.h>

Public Member Functions

Line (osgText::Text *_text)

Public Attributes

osg::ref_ptr< osgText::Text > text

Constructor & Destructor Documentation

APDYNAMICART::Line::Line ( osgText::Text * _text )
inline

Line class

Member Data Documentation

osg::ref_ptr<osgText::Text> LoadingConsole::Line::text
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: LoadingConsole::OutstandingLine Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LoadingConsole
  • OutstandingLine
Public Member Functions | Public Attributes | List of all members
LoadingConsole::OutstandingLine Class Reference

#include <LoadingConsole.h>

Public Member Functions

OutstandingLine (unsigned long _dwType, const char *_line)

Public Attributes

std::string | line
unsigned long | dwType

Constructor & Destructor Documentation

LoadingConsole::OutstandingLine::OutstandingLine | ( | unsigned long | _dwType,
 |  | const char * | _line
 | ) |  |
inline

Member Data Documentation

unsigned long LoadingConsole::OutstandingLine::dwType
std::string LoadingConsole::OutstandingLine::line
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MagicWandTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
MagicWandTool Class Reference

#include <MagicWandTool.h>

Inheritance diagram for MagicWandTool:

Public Member Functions

MagicWandTool (Controller *contr)
~MagicWandTool ()
void | activate ()
void | deactivate ()
void | postInitialize (void)
void | processEvent (const std::string &input_name, void *value)
void | turnOn ()
void | turnOff ()

Protected Attributes

int | sensorNumber
number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand) More...
std::string | posString
"Position_sensor_X" where X is sensor number More...
std::string | PointerPosReqString
request for (initial) position string More...
osg::ref_ptr< Attractor > | attractor
Attractor to be influenced by this tool. More...
bool | dominantAxis
dominant axis mode or free hand mode More...
osg::Vec3 | originalHandposition
osg::Vec3 | newHandPosition
double | handMoveMin
range of movement of hand - todo - may it differ in different axes? More...
double | handMoveMax
osg::Vec3 | paramRangeStart
osg::Vec3 | paramRangeEnd
osg::Vec3 | initialParamValue
osg::Vec3 | paramShift1
osg::Vec3 | paramShift2
osg::Vec3 | paramMult
int | indexX
index of parameter infuenced by movement in X axis More...
int | indexY
index of parameter infuenced by movement in Y axis More...
int | indexZ
index of parameter infuenced by movement in Z axis More...
Controller * | controller
int | originalIterations
int | lastDominantAxis

Constructor & Destructor Documentation

MagicWandTool::MagicWandTool ( Controller * contr )
MagicWandTool::~MagicWandTool ( )

Member Function Documentation

void MagicWandTool::activate ( )

This tool requeres calling setDAEnvironment() before activation

Todo:

< index of parameter infuenced by movement in X axis

void MagicWandTool::deactivate ( )
void MagicWandTool::postInitialize ( void )
void MagicWandTool::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void MagicWandTool::turnOff ( void )
void MagicWandTool::turnOn ( )

Member Data Documentation

osg::ref_ptr<Attractor> MagicWandTool::attractor
protected

Attractor to be influenced by this tool.

Controller* MagicWandTool::controller
protected
bool MagicWandTool::dominantAxis
protected

dominant axis mode or free hand mode

double MagicWandTool::handMoveMax
protected
double MagicWandTool::handMoveMin
protected

range of movement of hand - todo - may it differ in different axes?

int MagicWandTool::indexX
protected

index of parameter infuenced by movement in X axis

int MagicWandTool::indexY
protected

index of parameter infuenced by movement in Y axis

int MagicWandTool::indexZ
protected

index of parameter infuenced by movement in Z axis

osg::Vec3 MagicWandTool::initialParamValue
protected
int MagicWandTool::lastDominantAxis
protected
osg::Vec3 MagicWandTool::newHandPosition
protected
osg::Vec3 MagicWandTool::originalHandposition
protected
int MagicWandTool::originalIterations
protected
osg::Vec3 MagicWandTool::paramMult
protected
osg::Vec3 MagicWandTool::paramRangeEnd
protected
osg::Vec3 MagicWandTool::paramRangeStart
protected
osg::Vec3 MagicWandTool::paramShift1
protected
osg::Vec3 MagicWandTool::paramShift2
protected
std::string MagicWandTool::PointerPosReqString
protected

request for (initial) position string

std::string MagicWandTool::posString
protected

"Position_sensor_X" where X is sensor number

int MagicWandTool::sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MagicWandTool.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MagicWandTool.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MainObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Attributes | List of all members
MainObject Class Reference
Inheritance diagram for MainObject:
vrecko::BaseClass

Public Member Functions

void | onMessageExit (MessageBool *message)
void | onMessageProjection (MessageMatrix *message)
MainObject ()
~MainObject ()
bool | exit (void)
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
virtual const std::string & | getSenderString (void)
Returns the sender (or receiver) identification string. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
OBSOLETE METHOD, kept for backwards compatibility. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Public Attributes

osg::ref_ptr< InputPin
< MessageBool > > 		inputExit
osg::ref_ptr< InputPin
< MessageMatrix > > 		inputProjection

Protected Attributes

bool | done
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::BaseClass
enum NotificationTypes {
NOTIFICATION_DELETE_CLASS = 1, NOTIFICATION_EO_REGISTERING = 2, NOTIFICATION_EO_UNREGISTERING = 4, NOTIFICATION_PROGRAM_TERMINATION = 8,
NOTIFICATION_ALL = 0xFFFFFFFF
}
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::BaseClass
bool | sendNotifications (unsigned long notificationType, void *notificationData)
virtual int | processNotification (BaseClass *sender, unsigned long notificationType, void *notificationData)
Process an incoming notification. More...
IOPinBase * | findPinInList (const char *strName, PinList *pinList)
Internal method to find a given pin in a given list. More...

Constructor & Destructor Documentation

MainObject::MainObject ( )
inline
MainObject::~MainObject ( )
inline

Member Function Documentation

bool MainObject::exit ( void )
inline
void MainObject::onMessageExit ( MessageBool * message )
inline
void MainObject::onMessageProjection ( MessageMatrix * message )
inline

Member Data Documentation

bool MainObject::done
protected
osg::ref_ptr<InputPin<MessageBool> > MainObject::inputExit
osg::ref_ptr<InputPin<MessageMatrix> > MainObject::inputProjection
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/Main.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MainSceneUpdateCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
MainSceneUpdateCallback Class Reference
Inheritance diagram for MainSceneUpdateCallback:

Public Member Functions

MainSceneUpdateCallback ()
virtual void operator() (osg::Node *node, osg::NodeVisitor *nv)

Constructor & Destructor Documentation

MainSceneUpdateCallback::MainSceneUpdateCallback ( )
inline

Member Function Documentation

virtual void MainSceneUpdateCallback::operator() | ( | osg::Node * | node,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlinevirtual
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/Main.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MemoryReadBuffer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
MemoryReadBuffer Class Reference

#include <Stream.h>

Inheritance diagram for MemoryReadBuffer:

Public Member Functions

MemoryReadBuffer (const NxU8 *data)
virtual | ~MemoryReadBuffer ()
virtual NxU8 | readByte () const
virtual NxU16 | readWord () const
virtual NxU32 | readDword () const
virtual float | readFloat () const
virtual double | readDouble () const
virtual void | readBuffer (void *buffer, NxU32 size) const
virtual NxStream & | storeByte (NxU8 b)
virtual NxStream & | storeWord (NxU16 w)
virtual NxStream & | storeDword (NxU32 d)
virtual NxStream & | storeFloat (NxReal f)
virtual NxStream & | storeDouble (NxF64 f)
virtual NxStream & | storeBuffer (const void *buffer, NxU32 size)

Public Attributes

const NxU8 * buffer

Constructor & Destructor Documentation

MemoryReadBuffer::MemoryReadBuffer ( const NxU8 * data )
MemoryReadBuffer::~MemoryReadBuffer ( )
virtual

Member Function Documentation

void MemoryReadBuffer::readBuffer | ( | void * | buffer,
 |  | NxU32 | size
 | ) |  | const
 virtual
NxU8 MemoryReadBuffer::readByte ( void ) const
virtual
double MemoryReadBuffer::readDouble ( ) const
virtual
NxU32 MemoryReadBuffer::readDword ( ) const
virtual
float MemoryReadBuffer::readFloat ( ) const
virtual
NxU16 MemoryReadBuffer::readWord ( ) const
virtual
virtual NxStream& MemoryReadBuffer::storeBuffer | ( | const void * | buffer,
 |  | NxU32 | size
 | ) |  |
inlinevirtual
virtual NxStream& MemoryReadBuffer::storeByte ( NxU8 b )
inlinevirtual
virtual NxStream& MemoryReadBuffer::storeDouble ( NxF64 f )
inlinevirtual
virtual NxStream& MemoryReadBuffer::storeDword ( NxU32 d )
inlinevirtual
virtual NxStream& MemoryReadBuffer::storeFloat ( NxReal f )
inlinevirtual
virtual NxStream& MemoryReadBuffer::storeWord ( NxU16 w )
inlinevirtual

Member Data Documentation

const NxU8* MemoryReadBuffer::buffer
mutable
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MemoryWriteBuffer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
MemoryWriteBuffer Class Reference

#include <Stream.h>

Inheritance diagram for MemoryWriteBuffer:

Public Member Functions

MemoryWriteBuffer ()
virtual | ~MemoryWriteBuffer ()
void | clear ()
virtual NxU8 | readByte () const
virtual NxU16 | readWord () const
virtual NxU32 | readDword () const
virtual float | readFloat () const
virtual double | readDouble () const
virtual void | readBuffer (void *buffer, NxU32 size) const
virtual NxStream & | storeByte (NxU8 b)
virtual NxStream & | storeWord (NxU16 w)
virtual NxStream & | storeDword (NxU32 d)
virtual NxStream & | storeFloat (NxReal f)
virtual NxStream & | storeDouble (NxF64 f)
virtual NxStream & | storeBuffer (const void *buffer, NxU32 size)

Public Attributes

NxU32 | currentSize
NxU32 | maxSize
NxU8 * | data

Constructor & Destructor Documentation

MemoryWriteBuffer::MemoryWriteBuffer ( )
MemoryWriteBuffer::~MemoryWriteBuffer ( )
virtual

Member Function Documentation

void MemoryWriteBuffer::clear ( void )
virtual void MemoryWriteBuffer::readBuffer | ( | void * | buffer,
 |  | NxU32 | size
 | ) |  | const
 inlinevirtual
virtual NxU8 MemoryWriteBuffer::readByte ( void ) const
inlinevirtual
virtual double MemoryWriteBuffer::readDouble ( ) const
inlinevirtual
virtual NxU32 MemoryWriteBuffer::readDword ( ) const
inlinevirtual
virtual float MemoryWriteBuffer::readFloat ( ) const
inlinevirtual
virtual NxU16 MemoryWriteBuffer::readWord ( ) const
inlinevirtual
NxStream & MemoryWriteBuffer::storeBuffer | ( | const void * | buffer,
 |  | NxU32 | size
 | ) |  |
virtual
NxStream & MemoryWriteBuffer::storeByte ( NxU8 b )
virtual
NxStream & MemoryWriteBuffer::storeDouble ( NxF64 f )
virtual
NxStream & MemoryWriteBuffer::storeDword ( NxU32 d )
virtual
NxStream & MemoryWriteBuffer::storeFloat ( NxReal f )
virtual
NxStream & MemoryWriteBuffer::storeWord ( NxU16 w )
virtual

Member Data Documentation

NxU32 MemoryWriteBuffer::currentSize
NxU8* MemoryWriteBuffer::data
NxU32 MemoryWriteBuffer::maxSize
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: ModelManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
ModelManager Class Reference

#include <ModelManager.h>

Static Public Member Functions

static osg::ref_ptr
< EnvironmentObject > 		GetModelGeometry (string modelFilename)
Vrati EO s nahranou geometrii ze souboru modelFilename, pokud jiz je dany model nahrany, jinak jej nejprve nahraje ze souboru a pak vrati. More...
static void | DeleteModelGeometry (osg::ref_ptr< EnvironmentObject > *ptr)
Smaze hodnotu ptr na EO, byl-li to posledni ukazatel na dane EO, pak vymaze odpovidajici model z pameti. More...
static bool | ContainsModelGeometry (string modelFilename)
zjisti, jestli MM obsahuje v pameti normalni model se zadanym jmenem More...
static bool | ContainsAnimatedModelGeometry (string modelFilename)
zjisti, jestli MM obsahuje v pameti animovany model se zadanym jmenem More...
static bool | ContainsModelGeometry (string modelFilename, ModelType modelType)
zjisti, jestli MM obsahuje v pameti model se zadanym typem a jmenem More...
static osg::ref_ptr
< EnvironmentObject > 		GetAnimatedModelGeometry (string modelFilename, int animationIndex, bool startAnimation)
vrati animovany model z pameti, pripadne jej i nacte ze souboru More...
static void | DeleteAnimatedModelGeometry (osg::ref_ptr< EnvironmentObject > *ptr)
smaze data v 'ptr', snizi pocet ukazatelu v MM a pripadne i odstrani z pameti animovany model More...
static void | DeleteModelGeometry (osg::ref_ptr< EnvironmentObject > *ptr, ModelType modelType)
smaze data v 'ptr', snizi pocet ukazatelu v MM a pripadne i odstrani z pameti model daneho typu More...
static void | AddModelGeometry (string modelFilename, osg::ref_ptr< EnvironmentObject > newGeometry)
umozni vlozit novy model do pameti, aniz by jej nekdo ted potreboval a odkazoval se na nej More...
static void | AddDeleteObserver (DeleteObserver *newObserver)
pridani observeru delete udalosti More...
static void | AddGetObserver (GetObserver *newObserver)
pridani observeru get udalosti More...
static void | AddAddObserver (AddObserver *newObserver)
pridani add observeru More...
static void | RemoveDeleteObserver (DeleteObserver *observer)
odebrani delete observeru More...
static void | RemoveGetObserver (GetObserver *observer)
odebrani get observeru More...
static void | RemoveAddObserver (AddObserver *observer)
odebrani add observeru More...

Detailed Description

Trida, ktera se stara o nahravani modelu do pameti, jejich poskytovani a mazani Umoznuje nacitani modelu ze souboru jen jednou, pri dalsim pozadavku na jiz nacteny model jej ziska z pameti Z pameti maze model az tehdy, kdy je mazana jeho posledni instance

Member Function Documentation

void ModelManager::AddAddObserver ( AddObserver * newObserver )
static

pridani add observeru

prida zajemce o informace o Add udalostech

void ModelManager::AddDeleteObserver ( DeleteObserver * newObserver )
static

pridani observeru delete udalosti

prida zajemce o informace o Delete udalostech

void ModelManager::AddGetObserver ( GetObserver * newObserver )
static

pridani observeru get udalosti

prida zajemce o informace o Get udalostech

void ModelManager::AddModelGeometry | ( | string | modelFilename,
 |  | osg::ref_ptr< EnvironmentObject > | newGeometry
 | ) |  |
static

umozni vlozit novy model do pameti, aniz by jej nekdo ted potreboval a odkazoval se na nej

prida novy normalni model do pameti, nastavi pocet referenci na 0

bool ModelManager::ContainsAnimatedModelGeometry ( string modelFilename )
static

zjisti, jestli MM obsahuje v pameti animovany model se zadanym jmenem

zjisti, jestli je v pameti nacteny animovany model s danym jmenem

bool ModelManager::ContainsModelGeometry ( string modelFilename )
static

zjisti, jestli MM obsahuje v pameti normalni model se zadanym jmenem

zjisti, jestli je v pameti nacteny normalni model s danym jmenem

bool ModelManager::ContainsModelGeometry | ( | string | modelFilename,
 |  | ModelType | modelType
 | ) |  |
static

zjisti, jestli MM obsahuje v pameti model se zadanym typem a jmenem

zjisti, jestli je v pameti nacteny model s danym jmenenm a daneho typu

void ModelManager::DeleteAnimatedModelGeometry ( osg::ref_ptr< EnvironmentObject > * ptr )
static

smaze data v 'ptr', snizi pocet ukazatelu v MM a pripadne i odstrani z pameti animovany model

smaze animovany model z pameti, pouzivat radsi DeleteModelGeometry(*ptr, ModelType::cal3d)

void ModelManager::DeleteModelGeometry ( osg::ref_ptr< EnvironmentObject > * ptr )
static

Smaze hodnotu ptr na EO, byl-li to posledni ukazatel na dane EO, pak vymaze odpovidajici model z pameti.

smaze normalni model z pameti, pouzivat radsi DeleteModelGeometry(*ptr, ModelType::geometry)

void ModelManager::DeleteModelGeometry | ( | osg::ref_ptr< EnvironmentObject > * | ptr,
 |  | ModelType | modelType
 | ) |  |
static

smaze data v 'ptr', snizi pocet ukazatelu v MM a pripadne i odstrani z pameti model daneho typu

smaze dany model (snizi referenci, pripadne jej i odstrani z pameti), vynuluje ukazatel

osg::ref_ptr< EnvironmentObject > ModelManager::GetAnimatedModelGeometry | ( | string | modelFilename,
 |  | int | animationIndex,
 |  | bool | startAnimation
 | ) |  |
static

vrati animovany model z pameti, pripadne jej i nacte ze souboru

nahraje animovany model s danym jmenem, indexem animace a pripadne animaci i spusti

osg::ref_ptr< EnvironmentObject > ModelManager::GetModelGeometry ( string modelFilename )
static

Vrati EO s nahranou geometrii ze souboru modelFilename, pokud jiz je dany model nahrany, jinak jej nejprve nahraje ze souboru a pak vrati.

vrati normalni model daneho jmena, neni-li tento model v pameti, nacte jej ze souboru

static void ModelManager::RemoveAddObserver ( AddObserver * observer )
static

odebrani add observeru

void ModelManager::RemoveDeleteObserver ( DeleteObserver * observer )
static

odebrani delete observeru

smaze zajemce o Delete

void ModelManager::RemoveGetObserver ( GetObserver * observer )
static

odebrani get observeru

smaze zajemce o Get

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/ModelManager.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MotionTrailTriangulator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
MotionTrailTriangulator Class Reference

#include <MTTriangulator.h>

Inheritance diagram for MotionTrailTriangulator:

Public Member Functions

MotionTrailTriangulator (osg::ref_ptr< MTBrush > br)
~MotionTrailTriangulator ()
void | interpolateVec3 (std::vector< osg::Vec3 > *controlPoints, std::vector< osg::Vec3 > *interpolatedPoints, PoAInterpolationType type, bool closed, int p_steps)
Interpolate set of Vec3 points. More...
osg::Vec4 | highlightColour (osg::Vec4 col)
Change colour of MotionTrail. More...
void | interpolate (std::vector< ref_ptr_DAControlPoint > *controlPoints, std::vector< osg::Vec3 > *interpolatedPoints, std::vector< double > *tvalues=NULL, int p_steps=0, bool lengthOptimization=false, bool closed=false)
Create set of interpolated points from set of control points. More...
void | interpolateCrossSection ()
void | interpolateCrossSection (MTBrush *brush, std::vector< osg::Vec3 > *interpolatedPoints, std::vector< osg::Vec3 > *interpolatedNormals)
bool | getHighLighting ()
void | setHighLighting (bool high)
void | setUseFrenetFrame (bool frenet)
void | triangulate (std::vector< ref_ptr_DAControlPoint > *controlPoints)
osg::Vec3 | catmullRomInterpolation (double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3)
osg::Vec3 | derivedCRI (double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3)
osg::Vec3 | doubleDerivedCRI (double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3)
osg::Vec3 | tripleDerivedCRI (double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3)

Constructor & Destructor Documentation

MotionTrailTriangulator::MotionTrailTriangulator ( osg::ref_ptr< MTBrush > br )
MotionTrailTriangulator::~MotionTrailTriangulator ( )

Member Function Documentation

osg::Vec3 MotionTrailTriangulator::catmullRomInterpolation | ( | double | t,
 |  | osg::Vec3 | p0,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3
 | ) |  |
osg::Vec3 MotionTrailTriangulator::derivedCRI | ( | double | t,
 |  | osg::Vec3 | p0,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3
 | ) |  |
osg::Vec3 MotionTrailTriangulator::doubleDerivedCRI | ( | double | t,
 |  | osg::Vec3 | p0,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3
 | ) |  |
bool MotionTrailTriangulator::getHighLighting ( )
inline
osg::Vec4 MotionTrailTriangulator::highlightColour ( osg::Vec4 col )

Change colour of MotionTrail.

void MotionTrailTriangulator::interpolate | ( | std::vector< ref_ptr_DAControlPoint > * | controlPoints,
 |  | std::vector< osg::Vec3 > * | interpolatedPoints,
 |  | std::vector< double > * | tvalues = NULL,
 |  | int | p_steps = 0,
 |  | bool | lengthOptimization = false,
 |  | bool | closed = false
 | ) |  |

Create set of interpolated points from set of control points.

void MotionTrailTriangulator::interpolateCrossSection ( )
inline
void MotionTrailTriangulator::interpolateCrossSection | ( | MTBrush * | brush,
 |  | std::vector< osg::Vec3 > * | interpolatedPoints,
 |  | std::vector< osg::Vec3 > * | interpolatedNormals
 | ) |  |
void MotionTrailTriangulator::interpolateVec3 | ( | std::vector< osg::Vec3 > * | controlPoints,
 |  | std::vector< osg::Vec3 > * | interpolatedPoints,
 |  | PoAInterpolationType | type,
 |  | bool | closed,
 |  | int | p_steps
 | ) |  |

Interpolate set of Vec3 points.

void MotionTrailTriangulator::setHighLighting ( bool high )
inline
void MotionTrailTriangulator::setUseFrenetFrame ( bool frenet )
inline
void MotionTrailTriangulator::triangulate ( std::vector< ref_ptr_DAControlPoint > * controlPoints )
osg::Vec3 MotionTrailTriangulator::tripleDerivedCRI | ( | double | t,
 |  | osg::Vec3 | p0,
 |  | osg::Vec3 | p1,
 |  | osg::Vec3 | p2,
 |  | osg::Vec3 | p3
 | ) |  |
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTTriangulator.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTTriangulator.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MTBrush Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
MTBrush Class Reference

Store info about shape of cross-section of Motion trail. More...

#include <MTBrush.h>

Inheritance diagram for MTBrush:

Public Member Functions

MTBrush ()
~MTBrush ()
osg::Vec4 | getColour (double value=0.0)
std::map< double, osg::Vec4 > * | getColoursMap ()
MTBrushParameterType getColouringType ()
MTBrushParameterType getcrossSectionType ()
std::vector< osg::Vec3 > * | getCrosssPoints ()
double | getDiameter (double value=0.0)
std::map< double, double > * | getDiameters ()
int | getInterpolationSteps ()
int | getCrossSectionInterpolationSteps ()
PoAInterpolationType | getCrossSectionInterpolationType ()
double | getMinSpeed ()
double | getMaxSpeed ()
void | setColour (osg::Vec4 colour, double value=0.0)
void | setColourType (MTBrushParameterType type)
void | setCrossSectionType (MTBrushParameterType type)
void | setCrossSectionShape (MTBrushShapeType sh)
void | setDiameter (double diam, double value=0.0)
void | setInterpolationSteps (int interpol)
void | setSpeeds (double min, double max)

Detailed Description

Store info about shape of cross-section of Motion trail.

Constructor & Destructor Documentation

MTBrush::MTBrush ( )
MTBrush::~MTBrush ( )

Member Function Documentation

osg::Vec4 MTBrush::getColour ( double value = 0.0 )
MTBrushParameterType MTBrush::getColouringType ( )
inline
std::map<double, osg::Vec4>* MTBrush::getColoursMap ( )
inline
int MTBrush::getCrossSectionInterpolationSteps ( )
inline
PoAInterpolationType MTBrush::getCrossSectionInterpolationType ( )
inline
MTBrushParameterType MTBrush::getcrossSectionType ( )
inline
std::vector<osg::Vec3>* MTBrush::getCrosssPoints ( )
inline
double MTBrush::getDiameter ( double value = 0.0 )
std::map<double, double>* MTBrush::getDiameters ( )
inline
int MTBrush::getInterpolationSteps ( )
inline
double MTBrush::getMaxSpeed ( )
inline
double MTBrush::getMinSpeed ( )
inline
void MTBrush::setColour | ( | osg::Vec4 | colour,
 |  | double | value = 0.0
 | ) |  |
void MTBrush::setColourType ( MTBrushParameterType type )
inline
void MTBrush::setCrossSectionShape ( MTBrushShapeType sh )
void MTBrush::setCrossSectionType ( MTBrushParameterType type )
inline
void MTBrush::setDiameter | ( | double | diam,
 |  | double | value = 0.0
 | ) |  |
void MTBrush::setInterpolationSteps ( int interpol )
inline
void MTBrush::setSpeeds | ( | double | min,
 |  | double | max
 | ) |  |
inline
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTBrush.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTBrush.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MTCreatorTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
MTCreatorTool Class Reference

Motion trails creator tool. More...

#include <MTCreatorTool.h>

Inheritance diagram for MTCreatorTool:

Public Member Functions

MTCreatorTool (int sensorNumber)
~MTCreatorTool ()
void | activate ()
void | deactivate ()
std::vector< DASample > * | getSamples ()
Create copy of stored data, clear internal copy and return pointer to new copy. More...
void | postInitialize (void)
void | processEvent (const std::string &input_name, void *value)
void | turnOn ()
void | turnOff ()
void | update ()

Protected Attributes

int | sensorNumber
number of optitrack sensor (trackable in TrackingTools) More...
string | posString
"SensorXPosition" where X is sensor number More...
string | oriString
"SensorXOrientation" where X is sensor number More...
EnvironmentObject * DAArea
owner of this ability More...
osg::Vec3 | position
last known position More...
osg::Quat | orientation
last known orientation More...
osg::Vec3 | DAAposition
for transformations to local coords More...
osg::Quat | DAAOrientation
for transformations to local coords More...
osg::Vec3 | DAAScale
for transformations to local coords More...
bool | newPosition
flags for ensuring correct position+orientation pairing More...
bool | newOrientation
std::vector< DASample > * | samples
samples - position+orientation pairs More...

Detailed Description

Motion trails creator tool.

Track data from one Optitrack sensor, transform them into local coordinate system (of DA area) and store it. Motion trail PoA pop stored data by calling getSamples() function.

Constructor & Destructor Documentation

MTCreatorTool::MTCreatorTool ( int sensorNumber )
MTCreatorTool::~MTCreatorTool ( )

Member Function Documentation

void MTCreatorTool::activate ( )
void MTCreatorTool::deactivate ( )
std::vector<DASample>* MTCreatorTool::getSamples ( )

Create copy of stored data, clear internal copy and return pointer to new copy.

void MTCreatorTool::postInitialize ( void )
void MTCreatorTool::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |
void MTCreatorTool::turnOff ( void )
void MTCreatorTool::turnOn ( )
void MTCreatorTool::update ( void )

Member Data Documentation

osg::Quat MTCreatorTool::DAAOrientation
protected

for transformations to local coords

osg::Vec3 MTCreatorTool::DAAposition
protected

for transformations to local coords

EnvironmentObject* MTCreatorTool::DAArea
protected

owner of this ability

osg::Vec3 MTCreatorTool::DAAScale
protected

for transformations to local coords

bool MTCreatorTool::newOrientation
protected
bool MTCreatorTool::newPosition
protected

flags for ensuring correct position+orientation pairing

osg::Quat MTCreatorTool::orientation
protected

last known orientation

string MTCreatorTool::oriString
protected

"SensorXOrientation" where X is sensor number

osg::Vec3 MTCreatorTool::position
protected

last known position

string MTCreatorTool::posString
protected

"SensorXPosition" where X is sensor number

std::vector<DASample>* MTCreatorTool::samples
protected

samples - position+orientation pairs

int MTCreatorTool::sensorNumber
protected

number of optitrack sensor (trackable in TrackingTools)

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTCreatorTool.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTCreatorTool.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: MyReadCallback Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
MyReadCallback Struct Reference
Inheritance diagram for MyReadCallback:

Public Member Functions

virtual osg::Node * readNodeFile (const std::string &filename)

Member Function Documentation

virtual osg::Node* MyReadCallback::readNodeFile ( const std::string & filename )
inlinevirtual
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/ShootingSimulation.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: NullInterpolator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
List of all members
NullInterpolator Class Reference

#include <Interpolator.h>

Inheritance diagram for NullInterpolator:
Interpolator

Additional Inherited Members

- Public Member Functions inherited from Interpolator
virtual std::string | classDescription () const =0
virtual std::string | className () const =0
- Protected Member Functions inherited from Interpolator
virtual | ~Interpolator ()
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Interpolator.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: packet_rec Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
packet_rec Struct Reference

#include <hci.h>

Public Attributes

int | parsed
int | error
int | num_bytes_needed
byte cmd_byte
byte data [MAX_PACKET_SIZE]
byte * data_ptr

Member Data Documentation

byte packet_rec::cmd_byte
byte packet_rec::data[MAX_PACKET_SIZE]
byte* packet_rec::data_ptr
int packet_rec::error
int packet_rec::num_bytes_needed
int packet_rec::parsed
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/hci.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Particle Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Particle Struct Reference

#include <Cloud.h>

Inheritance diagram for Particle:
CloudParticle

Public Attributes

float | size
osg::Vec3f | position
osg::Vec4f | color

Detailed Description

Base particle structure containing size, position and color.

Member Data Documentation

osg::Vec4f Particle::color
osg::Vec3f Particle::position
float Particle::size
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PHANToMAvatar Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
PHANToMAvatar Class Reference

#include <PHANToMAvatar.h>

Inheritance diagram for PHANToMAvatar:
vrecko::Ability vrecko::BaseClass

Public Member Functions

PHANToMAvatar ()
~PHANToMAvatar ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...

Constructor & Destructor Documentation

PHANToMAvatar::PHANToMAvatar ( )
PHANToMAvatar::~PHANToMAvatar ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PHANToMAvatar::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool PHANToMAvatar::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void PHANToMAvatar::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void PHANToMAvatar::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void PHANToMAvatar::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void PHANToMAvatar::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PHEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
PHEffect Class Reference

#include <PHEffect.h>

Inheritance diagram for PHEffect:
vrecko::Ability vrecko::BaseClass

Public Member Functions

PHEffect ()
~PHEffect ()
void | processEvent (const std::string &input_name, void *value)
void | preInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | postInitialize (void)
OBSOLETE METHOD, kept for backwards compatibility. More...
void | update (void)
This method is called periodically in case this instance is registered in Scheduler. More...
bool | loadXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode)
OBSOLETE METHOD, kept for backwards compatibility. More...
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		getXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
- Public Member Functions inherited from vrecko::Ability
virtual | ~Ability ()
copy constructor More...
const std::string & | getName () const
Returns the ability name. More...
void | setPluginName (const char *pName)
Sets the plugin name. More...
const std::string & | getPluginName (void) const
Returns the plugin name. More...
const std::string & | getID (void) const
Returns ability the identification string. More...
void | setID (const char *pID)
(Internal usage, most people should not need to use it.) Sets the ability ID. More...
virtual void | clean (void)
void | setOwner (BaseClass *owner)
(Internal usage, most people should not need to use it.) Sets ability owner. *l This method is called automatically in World::createAbility(), so one would (almost?) never want to use it directly. More...
BaseClass * | getOwner (void)
Returns the ability owner. More...
virtual ParameterVector * | getParameterVector (void)
Return vector of the parameter description. More...
bool | isUpdated (void)
Set update flag. More...
virtual const std::string & | getSenderString (void)
Returns the identification string of sender. More...
- Public Member Functions inherited from vrecko::BaseClass
BaseClass (const char *startingSenderString)
The main constructor. More...
BaseClass (BaseClass &bc)
Copy constructor. Probably not really used. More...
virtual | ~BaseClass ()
Destructor. More...
virtual bool | initialize (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)
Core initialization. More...
virtual bool | initializeFromString (const char *xmlString)
Helper method that allows to initialize ability from a XML-formatted string. More...
virtual
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		saveXMLParameters (XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *)
Save current setting into a XML node. More...
bool | inputPresent (const std::string &name)
Returns true if input pin (not request inputpin ) with given name is present. More...
bool | outputPresent (const std::string &name)
Returns true if output pin (not request output pin) with given name is present. More...
void | addInputPin (InputPinBase *pin)
Adds an input pin. More...
void | removeInputPin (InputPinBase *pin)
Removes an input pin. More...
void | addOutputPin (OutputPinBase *pin)
Adds an output pin. More...
void | removeOutputPin (OutputPinBase *pin)
Removes and output pin. More...
void | addRequestInputPin (RequestInputPinBase *pin)
Adds a request input pin. More...
void | removeRequestInputPin (RequestInputPinBase *pin)
Removes a request input pin. More...
void | addRequestOutputPin (RequestOutputPinBase *pin)
Adds a request output pin. More...
void | removeRequestOutputPin (RequestOutputPinBase *pin)
Removes a request output pin. More...
bool | addNotification (BaseClass *receiver, unsigned long notificationTypes)
Registers an observer that will be notified if a specific change occurs. More...
bool | removeNotification (BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL)
Unregisters a previously registered observer. More...
virtual void | processEvent (const std::string &input_name, VreckoMessage *pMessage)
Internal method for processing the events. More...
virtual VreckoMessage * | processRequest (const std::string &request_input_name, VreckoMessage *pMessage)
Internal method for processing the requests. More...
void | reportError (const std::string &error)
Print error message. More...
void | setPriority (long int pr)
Sets the priority. (Possible problems - read the full description for more info) More...
long int | getPriority (void) const
Returns current object priority. More...
void | setAttribute (const std::string &attr_name, int attr_value)
Sets an attribute value. More...
int | getAttribute (const std::string &attr_name)
Returns attribute value. More...
int | getAttribute (const char *attr_name)
Returns attribute value. More...
void | deleteAttribute (const std::string &attr_name)
Delete an attribute. More...
void | setSceneFile (const std::string &sceneFileName)
Set the name of the file this component was in (and possibly will be saved to). More...
const std::string & | getSceneFile () const
Get the name of the file this component was in. More...
virtual bool | loadXMLParameters (const char *xmlString)
OBSOLETE METHOD, kept for backwards compatibility. More...
InputPinBase * | getInputPin (const char *strName)
Returns pointer to an input pin with specified name. More...
OutputPinBase * | getOutputPin (const char *strName)
Returns pointer to an output pin with specified name. More...
RequestInputPinBase * | getRequestInputPin (const char *strName)
Returns pointer to an request input pin with specified name. More...
RequestOutputPinBase * | getRequestOutputPin (const char *strName)
Returns pointer to an input pin with specified name. More...

Protected Attributes

PHANToM * | PHANToMDevice
bool | all_on
- Protected Attributes inherited from vrecko::Ability
BaseClass * pOwner
Pointer to the owner of this ability. (Almost?) always an EnvironmentObject class. More...
std::vector< std::string > | parameterString
bool | updated
Update flag. It is used for save. More...
- Protected Attributes inherited from vrecko::BaseClass
AttributeMap attribute
MTReadWriteLock attributeLock
std::string | senderString
MTLock notificationsLock
std::vector
< NOTIFICATION_DESCRIPTION > 		notifications
long int | priority
const std::string * | sceneFile
PinList inputPinsList
PinList outputPinsList
PinList requestInputPinsList
PinList requestOutputPinsList

Additional Inherited Members

- Public Types inherited from vrecko::Ability
typedef std::vector
< ParameterStruct > 		ParameterVector
Vector of the description of parameters. More...
- Protected Types inherited from vrecko::BaseClass
typedef std::map< std::string,
int > 		AttributeMap
Attributes. More...
typedef std::vector
< osg::ref_ptr< IOPinBase > > 		PinList
- Protected Member Functions inherited from vrecko::Ability
Ability (const char *theAbilityName)

Constructor & Destructor Documentation

PHEffect::PHEffect ( )
PHEffect::~PHEffect ( )
inline

Member Function Documentation

XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * PHEffect::getXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * pDocNode )
bool PHEffect::loadXMLParameters ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Parameters
* (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode)
Returns
(bool)

Reimplemented from vrecko::BaseClass.

void PHEffect::postInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void PHEffect::preInitialize ( void )
virtual

OBSOLETE METHOD, kept for backwards compatibility.

The preInitialize(), loadXMLParameters() and postInitialize() methods were replaced in 2011 by a single method initialize().

Reimplemented from vrecko::BaseClass.

void PHEffect::processEvent | ( | const std::string & | input_name,
 |  | void * | value
 | ) |  |

Process the Events.

void PHEffect::update ( void )
virtual

This method is called periodically in case this instance is registered in Scheduler.

The method is called periodically at specified frequency or every frame. Use the Scheduler::addEntity() method to register your class and set the frequency.

Reimplemented from vrecko::BaseClass.

Member Data Documentation

bool PHEffect::all_on
protected
PHANToM* PHEffect::PHANToMDevice
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Point3 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Point3 Struct Reference

#include <triangleCube.h>

Public Attributes

float | x
float | y
float | z

Member Data Documentation

float Point3::x
float Point3::y
float Point3::z
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/triangleCube.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Point3f Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Point3f Struct Reference

Public Attributes

float | x
float | y
float | z

Member Data Documentation

float Point3f::x
float Point3f::y
float Point3f::z
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/triangleCube.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Preloader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
Preloader Class Reference

Nahrava pravdepodobne potrebne modely v blizke budoucnosti, modely jsou urceny podle pouzite heuristiky. More...

#include <Preloader.h>

Public Member Functions

Preloader (BlockUpdater *_rootBlockUpdater)
~Preloader (void)
bool | ExitLoadingFunction (void)
vrati, jestli je treba ukoncit nacitaci vlakno More...
void | LoadingFunctionFinnished (void)
nacitaci vlakno ukonceno More...
MTLock * | GetLock (void)
vrati zamek More...
bool | Running (void)
vrati, jestli preloader bezi More...
void | Update (void)
aktualizace preloaderu More...
void | Start (void)
spusti preloader a vytvori nacitaci vlakno More...
void | Stop (void)
zastavi preloader a znici nacitaci vlakno More...

Public Attributes

list< PreloaderToLoadInfo * > | loadingQueue
fronta objektu cekajicich na nacteni More...
list< PreloaderLoadedInfo * > | loadedObjects
fronta nactenych objektu, ktere se maji vlozit do MemoryManageru More...

Detailed Description

Nahrava pravdepodobne potrebne modely v blizke budoucnosti, modely jsou urceny podle pouzite heuristiky.

Constructor & Destructor Documentation

Preloader::Preloader ( BlockUpdater * _rootBlockUpdater )
inline
Preloader::~Preloader ( void )
inline

Member Function Documentation

bool Preloader::ExitLoadingFunction ( void )
inline

vrati, jestli je treba ukoncit nacitaci vlakno

MTLock* Preloader::GetLock ( void )
inline

vrati zamek

void Preloader::LoadingFunctionFinnished ( void )
inline

nacitaci vlakno ukonceno

bool Preloader::Running ( void )
inline

vrati, jestli preloader bezi

void Preloader::Start ( void )

spusti preloader a vytvori nacitaci vlakno

spusti preloader

void Preloader::Stop ( void )

zastavi preloader a znici nacitaci vlakno

zastavi preloader

void Preloader::Update ( void )

aktualizace preloaderu

aktualizuje preloader

Member Data Documentation

list<PreloaderLoadedInfo*> Preloader::loadedObjects

fronta nactenych objektu, ktere se maji vlozit do MemoryManageru

list<PreloaderToLoadInfo*> Preloader::loadingQueue

fronta objektu cekajicich na nacteni

The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Preloader.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/Preloader.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PreloaderHeuristic Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
PreloaderHeuristic Class Reference

Rozhrani pro heuristiky, ktere se maji pouzit v Preloaderu. More...

#include <PreloaderHeuristic.h>

Inheritance diagram for PreloaderHeuristic:
BasicPreloaderHeuristic

Public Member Functions

~PreloaderHeuristic ()
void | SetWorldRoot (BlockUpdater *_rootBlockUpdater)
nastavi updater korenoveho bloku sceny More...
virtual list
< PreloaderToLoadInfo * > 		GetObjectsToPreload (void)
vrati seznam nalezenych objektu More...
virtual void | Update (void)
aktualizace heuristiky, jeden jeji krok More...
virtual bool | SearchFinnished (void)
vrati, jestli je vyhledavani ukonceno More...
virtual void | Restart (void)
restartovani heuristiky More...

Protected Attributes

BlockUpdater * rootBlockUpdater
list< PreloaderToLoadInfo * > | objectsToPreload
bool | searchFinnished

Detailed Description

Rozhrani pro heuristiky, ktere se maji pouzit v Preloaderu.

Constructor & Destructor Documentation

PreloaderHeuristic::~PreloaderHeuristic ( )
inline

Member Function Documentation

virtual list<PreloaderToLoadInfo*> PreloaderHeuristic::GetObjectsToPreload ( void )
inlinevirtual

vrati seznam nalezenych objektu

virtual void PreloaderHeuristic::Restart ( void )
inlinevirtual

restartovani heuristiky

Reimplemented in BasicPreloaderHeuristic.

virtual bool PreloaderHeuristic::SearchFinnished ( void )
inlinevirtual

vrati, jestli je vyhledavani ukonceno

void PreloaderHeuristic::SetWorldRoot ( BlockUpdater * _rootBlockUpdater )
inline

nastavi updater korenoveho bloku sceny

virtual void PreloaderHeuristic::Update ( void )
inlinevirtual

aktualizace heuristiky, jeden jeji krok

Reimplemented in BasicPreloaderHeuristic.

Member Data Documentation

list<PreloaderToLoadInfo*> PreloaderHeuristic::objectsToPreload
protected
BlockUpdater* PreloaderHeuristic::rootBlockUpdater
protected
bool PreloaderHeuristic::searchFinnished
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PreloaderLoadedInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PreloaderLoadedInfo Class Reference

#include <PreloaderHeuristic.h>

Public Attributes

osg::ref_ptr< EnvironmentObject > | geometry
string | filename

Member Data Documentation

string PreloaderLoadedInfo::filename
osg::ref_ptr<EnvironmentObject> PreloaderLoadedInfo::geometry
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PreloaderToLoadInfo Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
PreloaderToLoadInfo Class Reference

#include <PreloaderHeuristic.h>

Public Attributes

string filename
ModelType type

Member Data Documentation

string PreloaderToLoadInfo::filename
ModelType PreloaderToLoadInfo::type
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: PseudoRand2DPlacement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
PseudoRand2DPlacement Class Reference

Represents a class which pseudo-randomly scatters the clouds over the sky in form of the grid (for now) More...

#include <Cloud2DPlacement.h>

Public Member Functions

PseudoRand2DPlacement ()
void | SetGridUnitSizeXYZ (int x, int y, int z)
void | GetRandPosition (int gridX, int gridY, int gridZ, int *posX, int *posY, int *posZ, int radius=0) const
float | Noise1D (int x, int y) const

Public Attributes

int | gridUnitSizeX
int | gridUnitSizeY
int | gridUnitSizeZ
int | gridUnitHalfSizeX
int | gridUnitHalfSizeZ

Detailed Description

Represents a class which pseudo-randomly scatters the clouds over the sky in form of the grid (for now)

Todo:
Add more variability and randomness, replace the grid for something else.

Constructor & Destructor Documentation

PseudoRand2DPlacement::PseudoRand2DPlacement ( )
inline

Member Function Documentation

void PseudoRand2DPlacement::GetRandPosition | ( | int | gridX,
 |  | int | gridY,
 |  | int | gridZ,
 |  | int * | posX,
 |  | int * | posY,
 |  | int * | posZ,
 |  | int | radius = 0
 | ) |  | const

Computes a pseudo random location for a cloud of a given radius and coordinates in the grid of clouds

Parameters
[in] | gridX | X coordinate in cloud grid
[in] | gridY | Y coordinate in cloud grid
[in] | gridY | Y coordinate in cloud grid
[out] | posX | Pseudo random X coordinate in cloud grid
[out] | posY | Pseudo random Y coordinate in cloud grid
[out] | posZ | Pseudo random Z coordinate in cloud grid
[in] | radius | Radius of the cloud (optional, default = 0)
float PseudoRand2DPlacement::Noise1D | ( | int | x,
 |  | int | y
 | ) |  | const

Generates a noise value for the given x and y parameters

Parameters
[in] | x | The x parameter
[in] | y | The y parameter
Returns
Noise value for the given parameters
void PseudoRand2DPlacement::SetGridUnitSizeXYZ | ( | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

Sets the grid unit size of all the axes

Parameters
[in] | x | The x axis unit size
[in] | y | The y axis unit size
[in] | z | The z axis unit size

Member Data Documentation

int PseudoRand2DPlacement::gridUnitHalfSizeX
int PseudoRand2DPlacement::gridUnitHalfSizeZ
int PseudoRand2DPlacement::gridUnitSizeX
int PseudoRand2DPlacement::gridUnitSizeY
int PseudoRand2DPlacement::gridUnitSizeZ
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud2DPlacement.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Cloud2DPlacement.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: RealCmp< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions | List of all members
RealCmp< T > Class Template Reference

#include <RealCmp.h>

Static Public Member Functions

static FloatCmp | comparator (T a, T b)
static bool | compareLT (T a, T b)
static bool | compareGT (T a, T b)
static bool | compareEQ (T a, T b)
static bool | compareLTEQ (T a, T b)
static bool | compareGTEQ (T a, T b)

Member Function Documentation

template<class T >
static FloatCmp RealCmp< T >::comparator | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
template<class T >
static bool RealCmp< T >::compareEQ | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
template<class T >
static bool RealCmp< T >::compareGT | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
template<class T >
static bool RealCmp< T >::compareGTEQ | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
template<class T >
static bool RealCmp< T >::compareLT | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
template<class T >
static bool RealCmp< T >::compareLTEQ | ( | T | a,
 |  | T | b
 | ) |  |
inlinestatic
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RealCmp.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Receiver Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Receiver Struct Reference

#include <InputConnector.h>

Public Attributes

Ability * receiver
string | senderString
string | inputPin

Member Data Documentation

string Receiver::inputPin
Ability* Receiver::receiver
string Receiver::senderString
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/InputConnector.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: RegularPolygonSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Attributes | List of all members
RegularPolygonSpline Class Reference

#include <RegularPolygonSpline.h>

Inheritance diagram for RegularPolygonSpline:

Public Types

enum PlaneType { XY, XZ, YZ }

Public Member Functions

RegularPolygonSpline ()
RegularPolygonSpline (double radius, unsigned int segmentCount, double rotationShiftInDegress=0.0, PlaneType plane=XY)
META_DAObject (RegularPolygonSpline,"Regular Polygon Spline") virtual Vec3ArrayPtr getPoints()
virtual bool | isClosed ()
double | getRadius () const
void | setRadius (double val)
unsigned int | getSegmentCount () const
void | setSegmentCount (unsigned int val)
RegularPolygonSpline::PlaneType | getPlane () const
void | setPlane (RegularPolygonSpline::PlaneType val)
double | getRotationShift () const
void | setRotationShift (double val)

Protected Attributes

unsigned int | _segmentCount
double | _invSegmentCount
double | _radius
PlaneType _plane
double | _rotationInDegress
double | _shift

Member Enumeration Documentation

enum RegularPolygonSpline::PlaneType
Enumerator
XY
XZ
YZ

Constructor & Destructor Documentation

RegularPolygonSpline::RegularPolygonSpline ( void )
RegularPolygonSpline::RegularPolygonSpline | ( | double | radius,
 |  | unsigned int | segmentCount,
 |  | double | rotationShiftInDegress = 0.0,
 |  | PlaneType | plane = XY
 | ) |  |

Member Function Documentation

RegularPolygonSpline::PlaneType RegularPolygonSpline::getPlane ( ) const
inline
double RegularPolygonSpline::getRadius ( ) const
inline

Getters and setters

double RegularPolygonSpline::getRotationShift ( ) const
inline
unsigned int RegularPolygonSpline::getSegmentCount ( ) const
inline
virtual bool RegularPolygonSpline::isClosed ( )
inlinevirtual
RegularPolygonSpline::META_DAObject | ( | RegularPolygonSpline | ,
 |  | "Regular Polygon Spline" |
 | ) |  |

Virtual methods

void RegularPolygonSpline::setPlane ( RegularPolygonSpline::PlaneType val )
inline
void RegularPolygonSpline::setRadius ( double val )
inline
void RegularPolygonSpline::setRotationShift ( double val )
inline
void RegularPolygonSpline::setSegmentCount ( unsigned int val )
inline

Member Data Documentation

double RegularPolygonSpline::_invSegmentCount
protected
PlaneType RegularPolygonSpline::_plane
protected
double RegularPolygonSpline::_radius
protected
double RegularPolygonSpline::_rotationInDegress
protected
unsigned int RegularPolygonSpline::_segmentCount
protected
double RegularPolygonSpline::_shift
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RegularPolygonSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RegularPolygonSpline.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SampledSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
SampledSpline Class Reference

#include <SampledSpline.h>

Inheritance diagram for SampledSpline:

Public Member Functions

SampledSpline ()
SampledSpline (double minSampleDistance, bool closed, const Vec3ArrayPtr sampleArray)
META_DAObject (SampledSpline,"Sampled Spline")
virtual Vec3ArrayPtr | getPoints ()
virtual bool | isClosed ()
void | setVertexArray (const Vec3ArrayPtr array)
Vec3ArrayPtr | getVertexArray () const
double | getMinimalSampleDistance () const
void | setMinimalSampleDistance (double val)
void | setClosed (bool val)

Protected Attributes

Vec3ArrayPtr | _array
double | _minDistance
bool | _closed

Constructor & Destructor Documentation

SampledSpline::SampledSpline ( )

Constructors

SampledSpline::SampledSpline | ( | double | minSampleDistance,
 |  | bool | closed,
 |  | const Vec3ArrayPtr | sampleArray
 | ) |  |

Member Function Documentation

double SampledSpline::getMinimalSampleDistance ( ) const
inline
Vec3ArrayPtr SampledSpline::getPoints ( )
virtual
Vec3ArrayPtr SampledSpline::getVertexArray ( ) const
inline
virtual bool SampledSpline::isClosed ( )
inlinevirtual
SampledSpline::META_DAObject | ( | SampledSpline | ,
 |  | "Sampled Spline" |
 | ) |  |

Inherited virtual methods

void SampledSpline::setClosed ( bool val )
inline
void SampledSpline::setMinimalSampleDistance ( double val )
inline
void SampledSpline::setVertexArray ( const Vec3ArrayPtr array )
inline

Setters and getters

Member Data Documentation

Vec3ArrayPtr SampledSpline::_array
protected
bool SampledSpline::_closed
protected
double SampledSpline::_minDistance
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SampledSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SampledSpline.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Sector Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes | Protected Member Functions | Static Protected Attributes | List of all members
Sector Struct Reference

#include <SectorColorGen.h>

Inheritance diagram for Sector:

Public Types

enum | Direction { SD_REVERSE, SD_FORWARD }
typedef std::pair< double, double > | DoublePair

Public Member Functions

Sector ()
Sector (double start, double end, const osg::Vec4 &color, Direction direction=SD_FORWARD)
DoublePair | getSectorRange (unsigned int arraySize)
void | set (double start, double end, const osg::Vec4 &color, Direction direction=SD_FORWARD)

Public Attributes

const unsigned int | ID
double | start
double | end
osg::Vec4 | color
Direction direction

Protected Member Functions

virtual ~Sector ()

Static Protected Attributes

static unsigned int counter = 0

Member Typedef Documentation

typedef std::pair<double, double> Sector::DoublePair

Methods

Member Enumeration Documentation

enum Sector::Direction
Enumerator
SD_REVERSE
SD_FORWARD

Constructor & Destructor Documentation

Sector::Sector ( )
inline

Constructors

Sector::Sector | ( | double | start,
 |  | double | end,
 |  | const osg::Vec4 & | color,
 |  | Direction | direction = SD_FORWARD
 | ) |  |
inline
virtual Sector::~Sector ( )
inlineprotectedvirtual

Member Function Documentation

DoublePair Sector::getSectorRange ( unsigned int arraySize )
inline
void Sector::set | ( | double | start,
 |  | double | end,
 |  | const osg::Vec4 & | color,
 |  | Direction | direction = SD_FORWARD
 | ) |  |
inline

Member Data Documentation

osg::Vec4 Sector::color
unsigned int Sector::counter = 0
staticprotected
Direction Sector::direction
double Sector::end
const unsigned int Sector::ID
double Sector::start
The documentation for this struct was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorColorGen.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SectorColorGen.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SectorColorGen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
SectorColorGen Class Reference

#include <SectorColorGen.h>

Inheritance diagram for SectorColorGen:

Public Member Functions

SectorColorGen (const osg::Vec4 &defaultColor)
META_DAObject (SectorColorGen,"Sector Color")
virtual Vec4ArrayPtr | getColors (unsigned int leadSplineSize, unsigned int crossSectionSize)
const osg::Vec4 & | getDefaultColor () const
void | setDefaultColor (osg::Vec4 val)
void | addSector (SectorPtr sector)
void | setSector (unsigned int i, SectorPtr val)
const SectorPtr | getSector (unsigned int i)
int | getNumSectors ()
void | removeSectors (unsigned int i, int numSectorsToRemove=1)

Protected Attributes

SectorArray _sectors
osg::Vec4 _defaultColor

Constructor & Destructor Documentation

SectorColorGen::SectorColorGen ( const osg::Vec4 & defaultColor )
inline

Member Function Documentation

void SectorColorGen::addSector ( SectorPtr sector )
inline

SectorArray operations

virtual Vec4ArrayPtr SectorColorGen::getColors | ( | unsigned int | leadSplineSize,
 |  | unsigned int | crossSectionSize
 | ) |  |
inlinevirtual

Inherited methods

const osg::Vec4& SectorColorGen::getDefaultColor ( ) const
inline
int SectorColorGen::getNumSectors ( )
inline
const SectorPtr SectorColorGen::getSector ( unsigned int i )
inline
SectorColorGen::META_DAObject | ( | SectorColorGen | ,
 |  | "Sector Color" |
 | ) |  |
void SectorColorGen::removeSectors | ( | unsigned int | i,
 |  | int | numSectorsToRemove = 1
 | ) |  |
inline
void SectorColorGen::setDefaultColor ( osg::Vec4 val )
inline
void SectorColorGen::setSector | ( | unsigned int | i,
 |  | SectorPtr | val
 | ) |  |
inline

Member Data Documentation

osg::Vec4 SectorColorGen::_defaultColor
protected
SectorArray SectorColorGen::_sectors
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorColorGen.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Serial Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
Serial Class Reference

#include <classes.h>

Public Member Functions

char | openSerial (char *)
void | closeSerial ()
void | flushSerial ()
int | readChar ()
int | readBytes (char *, const int, const int)
char | writeChar (const char)
int | writeString (char *)

Member Function Documentation

void Serial::closeSerial ( )
void Serial::flushSerial ( )
char Serial::openSerial ( char * port )
int Serial::readBytes | ( | char * | buf,
 |  | const int | count,
 |  | const int | timeout
 | ) |  |
int Serial::readChar ( )
char Serial::writeChar ( const char byte )
int Serial::writeString ( char * str )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/classes.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Serial.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SliceTool Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
SliceTool Class Reference

#include <SliceTool.h>

Inheritance diagram for SliceTool:

Public Member Functions

SliceTool ()
~SliceTool ()
void | activate ()
void | deactivate ()
void | postInitialize (void)
void | turnOn ()
void | turnOff ()

Protected Attributes

EnvironmentObject * DAArea
Owner of this ability. More...
osg::ClipNode * | clipNode
osg::ClipPlane * | lowClipPlane
osg::ClipPlane * | topClipPlane

Constructor & Destructor Documentation

SliceTool::SliceTool ( )
SliceTool::~SliceTool ( )

Member Function Documentation

void SliceTool::activate ( )

This tool requeres calling setDAEnvironment() before activation

Todo:
void SliceTool::deactivate ( )
void SliceTool::postInitialize ( void )

how thick will slice be

void SliceTool::turnOff ( void )
void SliceTool::turnOn ( )

Member Data Documentation

osg::ClipNode* SliceTool::clipNode
protected
EnvironmentObject* SliceTool::DAArea
protected

Owner of this ability.

osg::ClipPlane* SliceTool::lowClipPlane
protected
osg::ClipPlane* SliceTool::topClipPlane
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SliceTool.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SliceTool.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SmoothedSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
SmoothedSpline Class Reference

#include <SmoothedSpline.h>

Inheritance diagram for SmoothedSpline:

Public Member Functions

SmoothedSpline (double smoothFactor, SplinePtr decoratedSpline)
META_DAObjectDecorator (_decoratedSpline, SmoothedSpline,"Smoothed Spline") virtual Vec3ArrayPtr getPoints()

Protected Attributes

double _smoothFactor

Constructor & Destructor Documentation

SmoothedSpline::SmoothedSpline | ( | double | smoothFactor,
 |  | SplinePtr | decoratedSpline
 | ) |  |

Member Function Documentation

SmoothedSpline::META_DAObjectDecorator | ( | _decoratedSpline | ,
 |  | SmoothedSpline | ,
 |  | "Smoothed Spline" |
 | ) |  |

Inherited methods

Member Data Documentation

double SmoothedSpline::_smoothFactor
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SmoothedSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SmoothedSpline.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SnapObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
SnapObject Class Reference

#include <SnapObject.h>

Public Member Functions

SnapObject ()
SnapObject (int id)
SnapObject (int id, vrecko::EnvironmentObject *eo)
~SnapObject ()
void | setId (unsigned long ID)
unsigned long | getId ()
void | setEo (vrecko::EnvironmentObject *eo)
vrecko::EnvironmentObject * getEo ()
void | setDirtyGraph (bool dirty)
bool | getDirtyGraph ()
void | setDirtyMaxDistance (bool dirty)
bool | getDirtyMaxDistance ()
void | setDirtySnappingRegion (bool dirty)
bool | getDirtySnappingRegion ()
void | setDirtyBoundaryLoop (bool dirty)
bool | getDirtyBoundaryLoop ()
void | setDirtyClosestPoint (bool dirty)
bool | getDirtyClosestPoint ()
void | setDirtyAll (bool dirty)
void | setChoosenBoundaryLoop (unsigned long position)
unsigned long | getChoosenBoundaryLoop ()
osg::Geode * | getGeode ()
osg::Geode * | getGeodeOf (osg::Node *eo)
osg::Geometry * | getGeometry ()
osg::Vec3Array * | getVertices ()
osg::Vec4Array * | getColors ()
osg::Vec3Array * | getNormals ()
osg::DrawElementsUShort * | getFaces ()
osg::PrimitiveSet * | getPrimitiveSet ()
vector< vector< int > > * | getBoundaryLoops ()
vector< vector< int > > * | findBoundaryLoops ()
vector< int > | getBoundaryLoop ()
vector< osg::Vec3 > | getBoundaryLoopCentroids ()
bool | chooseBoundaryLoop (SnapObject *object)
vector< map< int, int > > * | getGraph ()
vector< map< int, int > > * | createGraph ()
vector< set< int > > * | getSimpleGraph ()
vector< set< int > > * | createSimpleGraph ()
vector< int > | getSnapRegion ()
vector< int > | getClosestPoint (SnapObject *object)
vector< int > | findClosestPoint (SnapObject *object)
vector< int > | getClosestSnappingRegionPoints (SnapObject *object)
vector< int > | findClosestSnappingRegionPoints (SnapObject *object)
vector< int > | getSnappingRegion ()
vector< float > * | getSnappingRegionValues ()
float | getMaxDistance ()
vector< int > | getSnapRegionWithDistanceSet ()
vector< int > | findShortestPath (int pointA, int pointB)
void | updateDisplayList ()
void | deleteFromScene ()
void | recomputeNormal ()
bool | erasePoints (vector< int > &boundaryLoopToErase, vector< int > &eraseLoop)
bool | erasePointsAndAllFaces (vector< int > &boundaryLoopToErase, vector< int > &eraseLoop)
bool | mergeObject (SnapObject *object)
int | findClosestPoint (osg::Vec3 point)
set< int > | getPartOfObject (int seed, set< int > cuttingLoopSet)
bool | isSuitable ()
void | optimalizeLoop (vector< int > &loop)

Constructor & Destructor Documentation

SnapObject::SnapObject ( )
SnapObject::SnapObject ( int id )
SnapObject::SnapObject | ( | int | id,
 |  | vrecko::EnvironmentObject * | eo
 | ) |  |
SnapObject::~SnapObject ( )

Member Function Documentation

bool SnapObject::chooseBoundaryLoop ( SnapObject * object )
vector< map< int, int > > * SnapObject::createGraph ( )
vector< set< int > > * SnapObject::createSimpleGraph ( )
void SnapObject::deleteFromScene ( )
bool SnapObject::erasePoints | ( | vector< int > & | boundaryLoopToErase,
 |  | vector< int > & | eraseLoop
 | ) |  |
bool SnapObject::erasePointsAndAllFaces | ( | vector< int > & | boundaryLoopToErase,
 |  | vector< int > & | eraseLoop
 | ) |  |
vector< vector< int > > * SnapObject::findBoundaryLoops ( )
vector< int > SnapObject::findClosestPoint ( SnapObject * object )
int SnapObject::findClosestPoint ( osg::Vec3 point )
vector< int > SnapObject::findClosestSnappingRegionPoints ( SnapObject * object )
vector< int > SnapObject::findShortestPath | ( | int | pointA,
 |  | int | pointB
 | ) |  |
vector< int > SnapObject::getBoundaryLoop ( )
vector< osg::Vec3 > SnapObject::getBoundaryLoopCentroids ( )
vector< vector< int > > * SnapObject::getBoundaryLoops ( )
unsigned long SnapObject::getChoosenBoundaryLoop ( )
vector< int > SnapObject::getClosestPoint ( SnapObject * object )
vector<int> SnapObject::getClosestSnappingRegionPoints ( SnapObject * object )
osg::Vec4Array * SnapObject::getColors ( )
bool SnapObject::getDirtyBoundaryLoop ( )
bool SnapObject::getDirtyClosestPoint ( )
bool SnapObject::getDirtyGraph ( )
bool SnapObject::getDirtyMaxDistance ( )
bool SnapObject::getDirtySnappingRegion ( )
vrecko::EnvironmentObject * SnapObject::getEo ( )
osg::DrawElementsUShort * SnapObject::getFaces ( )
osg::Geode * SnapObject::getGeode ( )
osg::Geode * SnapObject::getGeodeOf ( osg::Node * eo )
osg::Geometry * SnapObject::getGeometry ( )
vector< map< int, int > > * SnapObject::getGraph ( )
unsigned long SnapObject::getId ( )
float SnapObject::getMaxDistance ( )
osg::Vec3Array * SnapObject::getNormals ( )
set< int > SnapObject::getPartOfObject | ( | int | seed,
 |  | set< int > | cuttingLoopSet
 | ) |  |
osg::PrimitiveSet * SnapObject::getPrimitiveSet ( )
vector< set< int > > * SnapObject::getSimpleGraph ( )
vector< int > SnapObject::getSnappingRegion ( )
vector< float > * SnapObject::getSnappingRegionValues ( )
vector< int > SnapObject::getSnapRegion ( )
vector< int > SnapObject::getSnapRegionWithDistanceSet ( )
osg::Vec3Array * SnapObject::getVertices ( )
bool SnapObject::isSuitable ( )
bool SnapObject::mergeObject ( SnapObject * object )
void SnapObject::optimalizeLoop ( vector< int > & loop )
void SnapObject::recomputeNormal ( )
void SnapObject::setChoosenBoundaryLoop ( unsigned long position )
void SnapObject::setDirtyAll ( bool dirty )
void SnapObject::setDirtyBoundaryLoop ( bool dirty )
void SnapObject::setDirtyClosestPoint ( bool dirty )
void SnapObject::setDirtyGraph ( bool dirty )
void SnapObject::setDirtyMaxDistance ( bool dirty )
void SnapObject::setDirtySnappingRegion ( bool dirty )
void SnapObject::setEo ( vrecko::EnvironmentObject * eo )
void SnapObject::setId ( unsigned long ID )
void SnapObject::updateDisplayList ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/SnapObject.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/SnapObject.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SNCH_THREAD_START_INFO Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
SNCH_THREAD_START_INFO Struct Reference

Public Attributes

SNCH_Object * objectClass

Member Data Documentation

SNCH_Object* SNCH_THREAD_START_INFO::objectClass
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: StrX Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
StrX Class Reference

#include <XercesXMLUtils.h>

Public Member Functions

StrX (const XMLCh *const toTranscode)
~StrX ()
const char * localForm () const

Constructor & Destructor Documentation

StrX::StrX ( const XMLCh *const toTranscode )
inline
StrX::~StrX ( )
inline

Member Function Documentation

const char* StrX::localForm ( ) const
inline
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/XercesXMLUtils.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SunLight Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
SunLight Struct Reference

#include <Cloud.h>

Public Attributes

osg::Vec4f | ambientLight
osg::Vec4f | sunColor
osg::Vec3f | position

Detailed Description

Stores the information about the sun.

Member Data Documentation

osg::Vec4f SunLight::ambientLight
osg::Vec3f SunLight::position
osg::Vec4f SunLight::sunColor
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: SweepSurfaceGeode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
SweepSurfaceGeode Class Reference

#include <SweepSurfaceGeode.h>

Inheritance diagram for SweepSurfaceGeode:

Public Member Functions

SweepSurfaceGeode ()
SweepSurfaceGeode (const SweepSurfaceGeode &, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY)
META_Node (APDYNAMICART, SweepSurfaceGeode)
virtual void | traverse (osg::NodeVisitor &nv)
SplinePtr | getLeadingSpline () const
SplinePtr | getLeadingSpline ()
void | setLeadingSpline (SplinePtr val)
ColorGenPtr | getColorGenerator () const
ColorGenPtr | getColorGenerator ()
void | setColorGenerator (ColorGenPtr val)
DiameterGenPtr | getDiameterGenerator () const
DiameterGenPtr | getDiameterGenerator ()
void | setDiameterGenerator (DiameterGenPtr val)
SplinePtr | getCrossSectionSpline () const
SplinePtr | getCrossSectionSpline ()
void | setCrossSectionSpline (SplinePtr val)
RotationFrameGeneratorPtr | getRFGenerator () const
RotationFrameGeneratorPtr | getRFGenerator ()
void | setRFGenerator (RotationFrameGeneratorPtr val)
const Vec3ArrayPtr | getCrossSectionArray () const
const Vec3ArrayPtr | getLeadSplineArray () const

Protected Member Functions

void | updateGeometry ()
void | createDrawableObject ()
void | updateVertexArray ()
void | updateNormalArray ()
void | updatePrimitiveSet ()
void | showDebugNormals ()
Vec3ArrayPtr | compute2DNormals ()
osg::Vec3 | compute2DNormal (const osg::Vec3 &p1, const osg::Vec3 &p2)
void | updateColorArray ()

Protected Attributes

SplinePtr | _leadSpline
SplinePtr | _crossSectionSpline
ColorGenPtr | _colorGen
DiameterGenPtr | _diameterGen
osg::ref_ptr< osg::Geometry > | _geometry
RotationFrameGeneratorPtr | _rfGenerator
Vec3ArrayPtr | _leadSplineArray
Vec3ArrayPtr | _crossSectionArray
std::vector< osg::Quat > | _rotationAngles
RotationFrameArray | _rfArray
DoubleArrayPtr | _diameters

Constructor & Destructor Documentation

SweepSurfaceGeode::SweepSurfaceGeode ( )
SweepSurfaceGeode::SweepSurfaceGeode | ( | const SweepSurfaceGeode & | ,
 |  | const osg::CopyOp & | copyop = osg::CopyOp::SHALLOW_COPY
 | ) |  |

Member Function Documentation

osg::Vec3 SweepSurfaceGeode::compute2DNormal | ( | const osg::Vec3 & | p1,
 |  | const osg::Vec3 & | p2
 | ) |  |
inlineprotected
Vec3ArrayPtr SweepSurfaceGeode::compute2DNormals ( )
protected
void SweepSurfaceGeode::createDrawableObject ( )
protected
ColorGenPtr SweepSurfaceGeode::getColorGenerator ( ) const
inline
ColorGenPtr SweepSurfaceGeode::getColorGenerator ( )
inline
const Vec3ArrayPtr SweepSurfaceGeode::getCrossSectionArray ( ) const
inline
SplinePtr SweepSurfaceGeode::getCrossSectionSpline ( ) const
inline
SplinePtr SweepSurfaceGeode::getCrossSectionSpline ( )
inline
DiameterGenPtr SweepSurfaceGeode::getDiameterGenerator ( ) const
inline
DiameterGenPtr SweepSurfaceGeode::getDiameterGenerator ( )
inline
SplinePtr SweepSurfaceGeode::getLeadingSpline ( ) const
inline

Getters and setters

SplinePtr SweepSurfaceGeode::getLeadingSpline ( )
inline
const Vec3ArrayPtr SweepSurfaceGeode::getLeadSplineArray ( ) const
inline
RotationFrameGeneratorPtr SweepSurfaceGeode::getRFGenerator ( ) const
inline
RotationFrameGeneratorPtr SweepSurfaceGeode::getRFGenerator ( )
inline
SweepSurfaceGeode::META_Node | ( | APDYNAMICART | ,
 |  | SweepSurfaceGeode |
 | ) |  |
void SweepSurfaceGeode::setColorGenerator ( ColorGenPtr val )
inline
void SweepSurfaceGeode::setCrossSectionSpline ( SplinePtr val )
inline

Inline methods

void SweepSurfaceGeode::setDiameterGenerator ( DiameterGenPtr val )
inline
void SweepSurfaceGeode::setLeadingSpline ( SplinePtr val )
inline
void SweepSurfaceGeode::setRFGenerator ( RotationFrameGeneratorPtr val )
inline
void SweepSurfaceGeode::showDebugNormals ( )
protected
void SweepSurfaceGeode::traverse ( osg::NodeVisitor & nv )
virtual

Inherited virtual functions

void SweepSurfaceGeode::updateColorArray ( )
protected
void SweepSurfaceGeode::updateGeometry ( )
protected
void SweepSurfaceGeode::updateNormalArray ( )
protected
void SweepSurfaceGeode::updatePrimitiveSet ( )
protected
void SweepSurfaceGeode::updateVertexArray ( )
protected

Member Data Documentation

ColorGenPtr SweepSurfaceGeode::_colorGen
protected
Vec3ArrayPtr SweepSurfaceGeode::_crossSectionArray
protected
SplinePtr SweepSurfaceGeode::_crossSectionSpline
protected
DiameterGenPtr SweepSurfaceGeode::_diameterGen
protected
DoubleArrayPtr SweepSurfaceGeode::_diameters
protected
osg::ref_ptr<osg::Geometry> SweepSurfaceGeode::_geometry
protected
SplinePtr SweepSurfaceGeode::_leadSpline
protected
Vec3ArrayPtr SweepSurfaceGeode::_leadSplineArray
protected
RotationFrameArray SweepSurfaceGeode::_rfArray
protected
RotationFrameGeneratorPtr SweepSurfaceGeode::_rfGenerator
protected
std::vector<osg::Quat> SweepSurfaceGeode::_rotationAngles
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SweepSurfaceGeode.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SweepSurfaceGeode.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: ThinHeap< _NodeClass, _keyType > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | List of all members
ThinHeap< _NodeClass, _keyType > Class Template Reference

#include <Heaps.h>

Inheritance diagram for ThinHeap< _NodeClass, _keyType >:
GenericHeap< _NodeClass, _keyType >

Classes

class ThinHeapNode

Public Member Functions

ThinHeap (void)
virtual void | Insert (_NodeClass *node)
virtual _NodeClass * | ExtractMin (void)
virtual void | DecreaseKey (_NodeClass *node, _keyType value)
virtual _NodeClass * | GetMin (void)
virtual _NodeClass * | Delete (_NodeClass *node)
virtual void | Union (ThinHeap< _NodeClass, _keyType > *heap)
virtual bool | IsEmpty ()

Protected Member Functions

void | Consolidate (void)
void | Link (_NodeClass *child, _NodeClass *parent)
virtual void | RepairViolations (_NodeClass *node)

Protected Attributes

_NodeClass * | head
_NodeClass * | min

Constructor & Destructor Documentation

template<class _NodeClass, class _keyType>
ThinHeap< _NodeClass, _keyType >::ThinHeap ( void )

Member Function Documentation

template<class _NodeClass, class _keyType>
void ThinHeap< _NodeClass, _keyType >::Consolidate ( void )
protected
template<class _NodeClass, class _keyType>
virtual void ThinHeap< _NodeClass, _keyType >::DecreaseKey | ( | _NodeClass * | node,
 |  | _keyType | value
 | ) |  |
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* ThinHeap< _NodeClass, _keyType >::Delete ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* ThinHeap< _NodeClass, _keyType >::ExtractMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual _NodeClass* ThinHeap< _NodeClass, _keyType >::GetMin ( void )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual void ThinHeap< _NodeClass, _keyType >::Insert ( _NodeClass * node )
virtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
virtual bool ThinHeap< _NodeClass, _keyType >::IsEmpty ( )
inlinevirtual

Implements GenericHeap< _NodeClass, _keyType >.

template<class _NodeClass, class _keyType>
void ThinHeap< _NodeClass, _keyType >::Link | ( | _NodeClass * | child,
 |  | _NodeClass * | parent
 | ) |  |
protected
template<class _NodeClass, class _keyType>
virtual void ThinHeap< _NodeClass, _keyType >::RepairViolations ( _NodeClass * node )
protectedvirtual
template<class _NodeClass, class _keyType>
virtual void ThinHeap< _NodeClass, _keyType >::Union ( ThinHeap< _NodeClass, _keyType > * heap )
virtual

Member Data Documentation

template<class _NodeClass, class _keyType>
_NodeClass* ThinHeap< _NodeClass, _keyType >::head
protected
template<class _NodeClass, class _keyType>
_NodeClass* ThinHeap< _NodeClass, _keyType >::min
protected
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: ThinHeap< _NodeClass, _keyType >::ThinHeapNode Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ThinHeap
  • ThinHeapNode
Public Attributes | List of all members
ThinHeap< _NodeClass, _keyType >::ThinHeapNode Class Reference

#include <Heaps.h>

Inheritance diagram for ThinHeap< _NodeClass, _keyType >::ThinHeapNode:

Public Attributes

ThinHeapNode * pl
ThinHeapNode * right
ThinHeapNode * child
int rank

Member Data Documentation

template<class _NodeClass, class _keyType>
ThinHeapNode* ThinHeap< _NodeClass, _keyType >::ThinHeapNode::child
template<class _NodeClass, class _keyType>
ThinHeapNode* ThinHeap< _NodeClass, _keyType >::ThinHeapNode::pl
template<class _NodeClass, class _keyType>
int ThinHeap< _NodeClass, _keyType >::ThinHeapNode::rank
template<class _NodeClass, class _keyType>
ThinHeapNode* ThinHeap< _NodeClass, _keyType >::ThinHeapNode::right
The documentation for this class was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: TimeLineSpline Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | List of all members
TimeLineSpline Class Reference

#include <TimeLineSpline.h>

Inheritance diagram for TimeLineSpline:

Public Member Functions

TimeLineSpline (DoubleArrayPtr timeStamps, SplinePtr decoratedSpline)
META_DAObjectDecorator (_decoratedSpline, TimeLineSpline,"Time line Spline") virtual Vec3ArrayPtr getPoints()
void setTime (double time)

Protected Attributes

double | _time
DoubleArrayPtr | _timeStamps

Detailed Description

Returns only part of decorated spline, based on set time - samples with timestamp bigger than threshold are discarded.

TODO

Warning
ONLY SAMPLED SPLINE should be used as decorated spline, otherwise, it will not work
also, minSample distance of sampled spline have to be set to 0.0 if time-line should work properly

Constructor & Destructor Documentation

TimeLineSpline::TimeLineSpline | ( | DoubleArrayPtr | timeStamps,
 |  | SplinePtr | decoratedSpline
 | ) |  |

Member Function Documentation

TimeLineSpline::META_DAObjectDecorator | ( | _decoratedSpline | ,
 |  | TimeLineSpline | ,
 |  | "Time line Spline" |
 | ) |  |

Inherited methods

void TimeLineSpline::setTime ( double time )

Member Data Documentation

double TimeLineSpline::_time
protected
DoubleArrayPtr TimeLineSpline::_timeStamps
protected
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/TimeLineSpline.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/TimeLineSpline.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Timing Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
Timing Class Reference

#include <classes.h>

Public Member Functions

void | pause (const unsigned int)
void | setTimeout (const int t_ms)
void | start ()
char | timedOut ()

Member Function Documentation

void Timing::pause ( const unsigned int delay_msec )
void Timing::setTimeout ( const int t_ms )
inline
void Timing::start ( void )
char Timing::timedOut ( )
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/classes.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Timing.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Triangle Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Triangle Struct Reference

Public Attributes

esg::OSGPolygon * | triangle
osg::Matrix | transf
osg::Matrix | rot
osg::Vec3 | vertex [3]
osg::Vec3 | normal

Member Data Documentation

osg::Vec3 Triangle::normal
osg::Matrix Triangle::rot
osg::Matrix Triangle::transf
esg::OSGPolygon* Triangle::triangle
osg::Vec3 Triangle::vertex[3]
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Triangle3 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Triangle3 Struct Reference

#include <triangleCube.h>

Public Attributes

Point3 v1
Point3 v2
Point3 v3

Member Data Documentation

Point3 Triangle3::v1
Point3 Triangle3::v2
Point3 Triangle3::v3
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/triangleCube.h
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Triangle3v Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes | List of all members
Triangle3v Struct Reference

Public Attributes

Point3 v1
Point3 v2
Point3 v3

Member Data Documentation

Point3 Triangle3v::v1
Point3 Triangle3v::v2
Point3 Triangle3v::v3
The documentation for this struct was generated from the following file:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/triangleCube.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: UniformUpdateCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | List of all members
UniformUpdateCallback Class Reference

#include <UniformUpdateCallback.h>

Inheritance diagram for UniformUpdateCallback:

Public Member Functions

UniformUpdateCallback (osg::Camera *_camera)
virtual void operator() (osg::Uniform *un, osg::NodeVisitor *nv)

Constructor & Destructor Documentation

UniformUpdateCallback::UniformUpdateCallback ( osg::Camera * _camera )
inline

Member Function Documentation

virtual void UniformUpdateCallback::operator() | ( | osg::Uniform * | un,
 |  | osg::NodeVisitor * | nv
 | ) |  |
inlinevirtual
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/UniformUpdateCallback.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/UniformUpdateCallback.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: UserStream Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
UserStream Class Reference

#include <Stream.h>

Inheritance diagram for UserStream:

Public Member Functions

UserStream (const char *filename, bool load)
virtual | ~UserStream ()
virtual NxU8 | readByte () const
virtual NxU16 | readWord () const
virtual NxU32 | readDword () const
virtual float | readFloat () const
virtual double | readDouble () const
virtual void | readBuffer (void *buffer, NxU32 size) const
virtual NxStream & | storeByte (NxU8 b)
virtual NxStream & | storeWord (NxU16 w)
virtual NxStream & | storeDword (NxU32 d)
virtual NxStream & | storeFloat (NxReal f)
virtual NxStream & | storeDouble (NxF64 f)
virtual NxStream & | storeBuffer (const void *buffer, NxU32 size)

Public Attributes

FILE * fp

Constructor & Destructor Documentation

UserStream::UserStream | ( | const char * | filename,
 |  | bool | load
 | ) |  |
UserStream::~UserStream ( )
virtual

Member Function Documentation

void UserStream::readBuffer | ( | void * | buffer,
 |  | NxU32 | size
 | ) |  | const
 virtual
NxU8 UserStream::readByte ( void ) const
virtual
double UserStream::readDouble ( ) const
virtual
NxU32 UserStream::readDword ( ) const
virtual
float UserStream::readFloat ( ) const
virtual
NxU16 UserStream::readWord ( ) const
virtual
NxStream & UserStream::storeBuffer | ( | const void * | buffer,
 |  | NxU32 | size
 | ) |  |
virtual
NxStream & UserStream::storeByte ( NxU8 b )
virtual
NxStream & UserStream::storeDouble ( NxF64 f )
virtual
NxStream & UserStream::storeDword ( NxU32 d )
virtual
NxStream & UserStream::storeFloat ( NxReal f )
virtual
NxStream & UserStream::storeWord ( NxU16 w )
virtual

Member Data Documentation

FILE* UserStream::fp
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: WavefrontObj Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | List of all members
WavefrontObj Class Reference

#include <wavefront.h>

Public Member Functions

WavefrontObj (void)
~WavefrontObj (void)
unsigned int loadObj (const char *fname, bool textured)

Public Attributes

int | mVertexCount
int | mTriCount
int * | mIndices
float * | mVertices
float * | mTexCoords

Constructor & Destructor Documentation

WavefrontObj::WavefrontObj ( void )
WavefrontObj::~WavefrontObj ( void )

Member Function Documentation

unsigned int WavefrontObj::loadObj | ( | const char * | fname,
 |  | bool | textured
 | ) |  |

Member Data Documentation

int* WavefrontObj::mIndices
float* WavefrontObj::mTexCoords
int WavefrontObj::mTriCount
int WavefrontObj::mVertexCount
float* WavefrontObj::mVertices
The documentation for this class was generated from the following files:
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.h
  • C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Class Index

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Index
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | _
A
Cut (APConnectEditor) InterpolatorFactory SNCH_Object::OneTri (APSpacePartitioning) ScreenSetupSimple::ScreenSetupSimpleState (ht)
CuttingPlane (behindO) Interval (vrecko) PersistentCache::OpenedCacheFile (vrecko) ScreenSetup::ScreenSetupState (ht)
A3DBird (vreckoDP_base) Cylinder (VirtualFixture) IOPinBase (vrecko) Optimalizer (APConnectEditor) Sector
AABoundingBox CylindricalJoint (PhysXPlugin) IORequestPinBase (vrecko) OptiTrack (vreckoDP_base) SectorColorGen
Ability (vrecko)
D
IParameters (APDYNAMICART) OrdinaryAttractor (APDYNAMICART) SectorInfo (APDYNAMICART)
AbilityDispatcher (vrecko) IShapeGenerator (APDYNAMICART) Logger::OutputNotificationFuncStored (vrecko) SectorManager (APDYNAMICART)
AbilityEditor (APEditorQAbilities) D0LSystem (AP_LSystem) ItemsGroup (APGUI) OutputPin (vrecko) Serial
AbilityMapper (APEditorController) DAControlPoint
J
OutputPinBase (vrecko) SetupFunction (ht)
ReaderWriter::AbilityToInitialize (vrecko) DAEnvironment (APDYNAMICART) Logger::OutstandingCounter (vrecko) World::SG_CHANGE (vrecko)
Abstract0LSystem (AP_LSystem) DAGizmo JointedPipe (AP_LSystem) LoadingConsole::OutstandingLine ShapeFactory (APDYNAMICART)
AbstractFile (AP_LSystem) DAGizmo (APDYNAMICART) JuliaAttractor (APDYNAMICART) Logger::OutstandingText (vrecko) ShootingSimulation (APShootingSimulation)
AbstractGenerator (AP_LSystem) Damper (VirtualFixture) JuliaParameters (APDYNAMICART)
P
ShowFDH (base)
AbstractInterpret (AP_LSystem) DASample JuncsEdge (CarSim) ShowFDHModel (base)
AbstractkLSystem (AP_LSystem) CompositeObject::Data (ode) Junction (CarSim) PointShell_Object_Data_Geometry::P (APSpacePartitioning) SimpleBox (APDYNAMICART)
AbstractLSystem (AP_LSystem) dataT (vreckoDP_base)
K
packet_rec SimpleObjectMovement (APEditorQAbilities)
AbstractTurtle (AP_LSystem) DATool (APDYNAMICART) Painted (APDYNAMICART) SimpleSetupFunction (ht)
AcrossPattern (APDYNAMICART) SNCH_Object_Data::DebugLevelStats (APSpacePartitioning) KeepOnScreen (APObjectUtils) Par2LSystem (AP_LSystem) SimulationParameters (APDYNAMICART)
AdapterFactory (APDYNAMICART) SNCH_Object_Data::DebugStats (APSpacePartitioning) KeyboardMouse (vreckoDP_base) Parameter (AP_LSystem) SystemInfo::SIThreadInfo (base)
AddObserver DeleteObserver Kinect (vreckoDP_Kinect) Parameter (APDYNAMICART) SystemInfo::SIThreadInit (base)
Advanced (APDYNAMICART) Device (vrecko) KMTracker (navigation) Parameters (CarSim) SliceTool
AllCloudsUpdateCallBack DeviceManager (vrecko)
L
Ability::ParameterStruct (vrecko) Slider (APGUI)
AbilityEditor::AllowedAbility (APEditorQAbilities) DiameterGenFactory (APDYNAMICART) ParD0LSystem (AP_LSystem) SmoothedSpline
angle_3D Display (base) L3DMouse (vreckoDP_base) ParseableString (AP_LSystem) ObjectMovement::SnapBox (APEditorQAbilities)
AnimatedGeometryState DistanceJoint (PhysXPlugin) Layout (APGUI) ParsingException (AP_LSystem) SnapObject
AnimatedModel (ArtificialWorld) DoublePattern (APDYNAMICART) length_3D ParStoch0LSystem (AP_LSystem) SnapPoint (APDYNAMICART)
Animator::AnimationPoint (APObjectUtils) Drag (VirtualFixture) Lens (behindO) Particle SNCH_Object (APSpacePartitioning)
AnimationPoint (ArtificialWorld) DeviceManager::DT (vrecko) LHeadTracker (vreckoDP_base) Particle (PhysXPlugin) SNCH_Object_Data (APSpacePartitioning)
Animator (APObjectUtils) DynamicArray (VK_NoStepInto_Namespace) Light (base) Cloud::ParticleAwayComparison SNCH_THREAD_START_INFO
AnimatorEditor (APEditorQAbilities) DynamicAttribute (vrecko) Lights (APLightsEditor) ParticleSystemParameters (APDYNAMICART) SP_Object_Data_Base (APSpacePartitioning)
Arm DynamicMenu (APMenu) Lights (CarSim) Pattern (APDYNAMICART) SP_Object_DataInterface (vrecko)
Attractor (APDYNAMICART) DynamicMenuSign (APMenu) Limits (APDYNAMICART) PatternBase (APDYNAMICART) SP_ObjectInterface (vrecko)
Attribute (vrecko) DynamicScene (ode) Line (APDYNAMICART) PatternFactory (APDYNAMICART) SP_SceneInterface (vrecko)
AttributesDescription (vrecko) DynamicTree LoadingConsole::Line PatternsGeode (APDYNAMICART) Sphere (VirtualFixture)
Avatar (base) DynamicTreeIterator Console::Line (APTextOutput) PerlinLines (APDYNAMICART) Sphere (PhysXPlugin)
Avatar (VirtualFixture) DynTreeNode Linear (Filter) PerlinNoiseAlgorithm (APNature) Sphere (ode)
World::AvatarEye (vrecko)
E
LinearInterpolator PersistentCache (vrecko) SphereBVH_Object (APSpacePartitioning)
AvatarInHand (navigation) LinearShapeGenerator (APDYNAMICART) PointShell_Object_Data_Geometry_Analyser::PExt (APSpacePartitioning) SphereBVH_Object_Data (APSpacePartitioning)
AvatarManipulator (behindO) PointShell_Object_Data_Geometry::E (APSpacePartitioning) SNCH_Object::LMDStore (APSpacePartitioning) PHANToMAvatar SphereBVH_Scene (APSpacePartitioning)
AvatarMovement (APEditorQAbilities) EditorController::ECPOINTERBUTTONINFO (APEditorController) LoadingConsole PHEffect SphericalJoint (PhysXPlugin)
World::AvatarView (vrecko) EditorController::ECPOINTERINFO (APEditorController) SNCH_Object::LocalMinimumDistance (APSpacePartitioning) PhysXManager (APDYNAMICART) SplineAdapter (APDYNAMICART)
AxisFrameAdapter (APDYNAMICART) Edge (CarSim) LoftTurtle (AP_LSystem) PhysXObject (PhysXPlugin) SplineFactory (APDYNAMICART)
AxisLock (VirtualFixture) Grid::Edge (APFFDEditor) Log (VirtualFixture) PhysXScene (PhysXPlugin) SplitPattern (APDYNAMICART)
B
EdgesCar (CarSim) Log (AP_LSystem) PickoverParameters (APDYNAMICART) SplitReversePattern (APDYNAMICART)
Editor (APLightsEditor) Logger (vrecko) PickoverStrategy (APDYNAMICART) StandardPattern (APDYNAMICART)
BaseActor (PhysXPlugin) EditorController (APEditorController) logger_streambuf (vrecko) Plane (VirtualFixture) StartStopDestination (CarSim)
BaseClass (vrecko) EditorLogic (APFFDEditor) LongString (AP_LSystem) Plane (PhysXPlugin) StaticAttribute (vrecko)
BaseJoint (PhysXPlugin) PointShell_Object_Data_Geometry_Analyser::EExt (APSpacePartitioning) Lorenz84Parameters (APDYNAMICART) PLControllerTool (APDYNAMICART) StaticString (AP_LSystem)
BasePhysXObject (PhysXPlugin) Ellipse (APDYNAMICART) Lorenz84Strategy (APDYNAMICART) PLMagnetTool (APDYNAMICART) SNCH_Object_Data::STNodeSNCH (APSpacePartitioning)
Basic (APDYNAMICART) ELOD (APSpacePartitioning) LorenzParameters (APDYNAMICART) PLNestTool (APDYNAMICART) SphereBVH_Object_Data::STNodeSphere (APSpacePartitioning)
BasicPreloaderHeuristic ElongatedCircle (APDYNAMICART) LorenzStrategy (APDYNAMICART) PLOD (APSpacePartitioning) StraightPipe (AP_LSystem)
BCLoaderErrorHandler Enumeration (vrecko) LSFile (AP_LSystem) PluginManager (vrecko) StringUtils (AP_LSystem)
BehindObstacleExp_wT EnvironmentObject (vrecko) LSGeode (AP_LSystem) PoA (APDYNAMICART) EventDispatcher::StringWithHash (vrecko)
BehindObstacleExperiment Scene::EOIteratorHelper (vrecko) LSObject (AP_LSystem) PoAAdapter (APDYNAMICART) EventDispatcher::StringWithHashComparator (vrecko)
BenchmarkWriter (vrecko) EOLineSegmentIntersector LSystem (AP_LSystem) PoAState (APDYNAMICART) Stroke (APDYNAMICART)
BinomialHeap EOLineSegmentIntersector (APObjectUtils) LSystemException (AP_LSystem) PoB (APDYNAMICART) StrX
BinomialHeap::BinomialHeapNode EOLineSegmentIntersector (APConnectEditor) LSystemGenerator (AP_LSystem) Point3 SubBlock (ArtificialWorld)
BlockAttributes (ArtificialWorld) ErrorReporter (PhysXPlugin)
M
Point3f SubBlockAnimation (ArtificialWorld)
BlockUpdater (ArtificialWorld) EventDispatcher::EventDefinitionStruct (vrecko) PointAdd (APRoomEdit) SunLight
Boid (boids) EventDispatcher (vrecko) MagicWandTool PointInPlaneJoint (PhysXPlugin) SweepSurfaceGeode
BoidsLogic (boids) EventDispatcher::EventStruct (vrecko) MainObject PointMove (APRoomEdit) symmetry_axis (APDYNAMICART)
BoidsPlanner (boids) BehindObstacleExperiment::ExperimentRec MainSceneUpdateCallback PointOnLineJoint (PhysXPlugin) symmetry_pair (APDYNAMICART)
Border (VirtualFixture) BehindObstacleExp_wT::ExperimentRec Manipulator (behindO) PointShell_Object_Data (APSpacePartitioning) SystemInfo (base)
Box (VirtualFixture) EyeManipulator (behindO) AbilityMapper::MAPPING (APEditorController) PointShell_Object_Data_Geometry (APSpacePartitioning)
T
Box (PhysXPlugin)
F
MappingFunctions (behindO) PointShell_Object_Data_Geometry_Analyser (APSpacePartitioning)
Brush (APDYNAMICART) Marker (VirtualFixture) PointShell_Object_Data_LOD_Builder (APSpacePartitioning) Terrain2D (APNature)
BrushStroke (APDYNAMICART) GeometryLoaderBase::FaceBase (APFFDEditor) MarkerFactory (VirtualFixture) PointShell_SimpleNode (APSpacePartitioning) Terrain2DSegment (APNature)
BrushStrokeControlPoint (APDYNAMICART) GeometryLoaderBase::FaceBase (APSpacePartitioning) MaterialDesc (vrecko) PointShellGeneric_Object_Data (APSpacePartitioning) TerrainAbility (APNature)
BufferedFile (vrecko) SNCH_Object_Data::FaceSNCH (APSpacePartitioning) MaterialManager (PhysXPlugin) PointShellVSVoxel_Object (APSpacePartitioning) TerrainAlgorithm (APNature)
BufferedFileWrite (vrecko) fdtDataGlove (vreckoDP_base) Math (vreckoUtils) PolygonPoint (CarSim) TerrainRandom (APNature)
BufferedSpline FibonacciHeap MemoryReadBuffer PolygonState (APConnectEditor) TerrainUtility (APNature)
BuildMesh (WAVEFRONT) FibonacciHeap::FibonacciHeapNode MemoryWriteBuffer PolyhedraSculpture (APDYNAMICART) ThinHeap
AbilityMapper::BUTTON_MAPPING (APEditorController) FileException (AP_LSystem) Menu (APGUI) PolyhedronFactory (APDYNAMICART) ThinHeap::ThinHeapNode
C
FilletSpline Menu (vreckoUtils) PolynomialParameters (APDYNAMICART) TimeLineSpline
Filter (VirtualFixture) MenuBase (vreckoUtils) PolynomialStrategy (APDYNAMICART) Timer (vrecko)
Cable (AP_CableEditor) filter1 MenuCommon (vreckoUtils) PosNoiseRemover (Filter) Scheduler::TimerStruct (vrecko)
CableEditor (AP_CableEditor) filter2 MenuItem (APMenu) Preloader Timing
CABUTTONEVENT (vrecko) First3Juncs (CarSim) MenuItem (vreckoUtils) PreloaderHeuristic Logger::TimingInfo (vrecko)
Cache FixedJoint (PhysXPlugin) MenuItemNull (APMenu) PreloaderLoadedInfo TLcolorsMT (CarSim)
CacheInfo Fluid (PhysXPlugin) MenuItemSlider (APMenu) PreloaderToLoadInfo TLsOnJuncManager (CarSim)
CAINFO__VER1 (vrecko) FluidDrawable (PhysXPlugin) MenuItemText (APMenu) PresentAbility (APEditorQAbilities) Tool (APRoomEdit)
CAINFO__VER2 (vrecko) ForceField (PhysXPlugin) MenuLoaderErrorHandler (APMenu) PrismaticJoint (PhysXPlugin) ToolBrush (APDYNAMICART)
Camera (APCameraPath) FrenetFrame MenuRoot (vreckoUtils) ProxiBorder (VirtualFixture) ToolEraser (APDYNAMICART)
CameraMovementEditor (APCameraMovement) fsPinchGlove (vreckoDP_base) MenuSlider (vreckoUtils) ProxiBox (VirtualFixture) ToolHook (APDYNAMICART)
CameraPath (APCameraMovement) Function (ht) MenuVisitor (vreckoUtils) ProxiCone (VirtualFixture) ToolMagicWand (APDYNAMICART)
ObjectMovement::CANDIDATEPLANE (APEditorQAbilities)
G
Mesh (grass) ProxiCylinder (VirtualFixture) ToolRotation (APDYNAMICART)
CappedCylinder (ode) MessageCAButtonEvent (vrecko) ProxiSphere (VirtualFixture) ToolSelector (APDYNAMICART)
Capsule (PhysXPlugin) GenericHeap ControllableAbility::MessageCAINFO (vrecko) PS_Component (APDYNAMICART) ToolSlice (APDYNAMICART)
CarControlUnit (CarSim) GenericHeap::GenericHeapNode MessageCarEdge (CarSim) PS_Face (APDYNAMICART) ToolTongs (APDYNAMICART)
CarEdgeData (CarSim) GeometryLoader::Geometry (APFFDEditor) MessageCarEdgeData (CarSim) PS_FacePlane (APDYNAMICART) TopPattern (APDYNAMICART)
CarEnvirons (CarSim) GeometryInterface (WAVEFRONT) MessageCarEnvirons (CarSim) PS_FlatShape (APDYNAMICART) TopReversePattern (APDYNAMICART)
CarExecutionUnit (CarSim) GeometryLoader (APFFDEditor) MessageCarSimParameters (CarSim) PS_Layer (APDYNAMICART) Trace (VirtualFixture)
CarPartsNodeCache (CarSim) GeometryLoaderBase (APFFDEditor) MessageCarStatePtr (CarSim) PS_Polyhedron (APDYNAMICART) Trait (APDYNAMICART)
CarSize (CarSim) GeometryLoaderBase (APSpacePartitioning) MessageEdgeOffset (CarSim) PS_Symmetry (APDYNAMICART) Triangle
CarState (CarSim) GeometryPartsPath (CarSim) MessageFirst3Juncs (CarSim) PseudoRand2DPlacement Triangle (grass)
CatmullRomInterpolator GeometryState AbilityMapper::MessageMapping (APEditorController) PointShell_Object_Data::PSpoint (APSpacePartitioning) Triangle3
CCollection (mv) GeometryVertex (WAVEFRONT) MessageNxActorWithName (PhysXPlugin) PulleyJoint (PhysXPlugin) Triangle3v
CentreObjectManipulator (behindO) GetObserver DynamicScene::MessageODERequest (ode) PyAbility (vrecko) TriangleCollector (grass)
CGesture (mv) gmMatrix3 MessageRoadAndDir (CarSim)
Q
TurtleInterpret (AP_LSystem)
ChangeOfVisibility (behindO) gmMatrix4 MessageSensorTransformation (vrecko) TurtleProperties (AP_LSystem)
ChessBoard gmVector2 SystemInfo::MessageSIThreadCreated (base) QComputeBoundShapeVisitor (osgQ) TurtleStack (AP_LSystem)
ChessPiece gmVector3 MessageStartStopDestination (CarSim) QConstShapeVisitor (osgQ)
U
Scheduler::classcomp (vrecko) gmVector4 MessageVectorUnsignedInt (CarSim) QDrawShapeVisitor (osgQ)
Cloth (PhysXPlugin) GradientColorAdapter (APDYNAMICART) MessageVoid (vrecko) QPrimitiveShapeVisitor (osgQ) Ultratrak (vreckoDP_base)
ClothDrawable (PhysXPlugin) GradientColorGen MicroScribe3D (vreckoDP_base) QSection (osgQ) UniformUpdateCallback
Cloud GradientDiamAdapter (APDYNAMICART) MidpointDisplacementAlgorithm (APNature) QShapeDrawable (osgQ) UpdatablePhysXObject (PhysXPlugin)
CloudDataType GradientDiameterGen Mirror (behindO) QShapeVisitor (osgQ) EnvironmentObject::UserData (vrecko)
CloudParticle Grass (grass) Mode (APDYNAMICART) Query (AP_LSystem) UserStream
Clouds (APClouds) GrassAbilityParameters (grass) Model (ArtificialWorld) QueryInterpret (AP_LSystem) UseToEvent (APObjectUtils)
CloudSceneInfo GrassCullCallback (grass) ModelManager QueryTurtle (AP_LSystem) UseTrigger (APEditorQAbilities)
CloudsManager GrassDrawable (grass) MotionTrail (APDYNAMICART)
R
Utils (APDYNAMICART)
CloudsProperties Grid (VirtualFixture) MotionTrailTriangulator
V
CloudVoxel Grid (APFFDEditor) MouseHand (base) RandomFaultsAlgorithm (APNature)
CMVect (mv) GUI_Controller (APGUI) MovingTurtle (AP_LSystem) RandomIndex (AP_LSystem) PointShell_Object_Data_Geometry::V (APSpacePartitioning)
CollisionInfo (vrecko) GUI_Item (APGUI) MTAutoLock (vrecko) Randomizer (AP_LSystem) Variable (ht)
CollisionParams__ver1 (vrecko) GUI_Text (APGUI) MTBrush Range (vrecko) VariableFloat (ht)
CollisionPointInfo (vrecko)
H
MTCreatorTool Reader (mv) VariableQuat (ht)
NoPartitioning_Scene::CollisionStruct (APSpacePartitioning) MTLock (vrecko) ReaderWriter (vrecko) VariableVec2 (ht)
NoPartitioning_Scene::CollisionStructObject (APSpacePartitioning) hand (base) MTMatrixTransform (base) RealCmp VariableVec3 (ht)
ColorBucket (APRoomEdit) HandFrameAdapter (APDYNAMICART) MTReadWriteLock (vrecko) Receiver Vertex (grass)
ColorGenAdapter (APDYNAMICART) Hci MTReadWriteLockEx (vrecko) Rectangle (AP_LSystem) GeometryLoaderBase::VertexBase (APFFDEditor)
ColorGenFactory (APDYNAMICART) HeadManipulator (behindO) MTTwoPrioLimitedLock (vrecko) Rectangle (APDYNAMICART) GeometryLoaderBase::VertexBase (APSpacePartitioning)
colorGradient (APDYNAMICART) HeadTracking (ht) MyAbility (APHelloWorld) RectangularSplineAdapter (APDYNAMICART) SNCH_Object_Data::VertexSNCH (APSpacePartitioning)
ColorPicker (APGUI) HermitPipe (AP_LSystem) mycomparisonMaxMin (APSpacePartitioning) RegularPolygon (APDYNAMICART) PointShell_Object_Data_Geometry_Analyser::VExt (APSpacePartitioning)
CompositeObject (ode) HighlightCallback (vreckoUtils) mycomparisonMinMax (APSpacePartitioning) RegularPolygonSpline VGReadCallback (APSpacePartitioning)
CompositeViewer (vrecko) HMDHeadManipulator (behindO) MyCullCallback (behindO) RemoteDebugger (PhysXPlugin) Vibration (VirtualFixture)
ComputeThread (APDYNAMICART) HoleRemove (APRoomEdit) MyReadCallback (APCameraMovement) Remover (CarSim) VibrationLabel (VirtualFixture)
Cone (VirtualFixture) HookManager (APDYNAMICART) MyReadCallback (APConnectEditor) ChessBoard::Request VibrationLabelActivator (VirtualFixture)
Configuration (APDYNAMICART) HookObject (APDYNAMICART) MyReadCallback EventDispatcher::REQUEST_Struct (vrecko) Viewer (vrecko)
Configuration (AP_LSystem) Hoop (APDYNAMICART) MyReadCallback (APObjectUtils) RequestInputPin (vrecko) ViewerBase (vrecko)
ConfigurationException (AP_LSystem) HoopGeometry (APDYNAMICART) MyUpdateCallback (behindO) RequestInputPinBase (vrecko) VLOD (APSpacePartitioning)
ConnectEditor (APConnectEditor) HoopShape (APDYNAMICART)
N
RequestOutputPin (vrecko) VoxelGrid_Object_Data (APSpacePartitioning)
ConnectionViz::Connection (APObjectUtils) HoopTrackerCallback (APDYNAMICART) RequestOutputPinBase (vrecko) VreckoMessage (vrecko)
ConnectionViz (APObjectUtils) HUDColorProfile (APHUD) NavSphere (VirtualFixture) RevoluteJoint (PhysXPlugin) VRPN3DMouse (vreckoDP_base)
Console (APTextOutput) HUDDisplay (APHUD) NestOfBirds (vreckoDP_base) RMFrameAdapter (APDYNAMICART) vThread (vrecko)
ConstantColorAdapter (APDYNAMICART) HUDField (APHUD) NoPartitioning_Scene (APSpacePartitioning) RoadsEdges (CarSim)
W
ConstantColorGen HUDWindow (APHUD) BaseClass::NOTIFICATION_DESCRIPTION (vrecko) RoadsState (CarSim)
ConstantDiamAdapter (APDYNAMICART) HyperbolicPattern (APDYNAMICART) NullAttractor (APDYNAMICART) RoomEditor (APRoomEdit) WallAdd (APRoomEdit)
ConstrainedObjectMovement (APConstrainedMovement)
I
NullHoopShape (APDYNAMICART) RoomLoader (APRoomEdit) WallGeometry (APRoomEdit)
ConstraintArea (APConstrainedMovement) NullInterpolator RoomSaver (APRoomEdit) WallMovement (APRoomEdit)
ConstraintDescription (APConstrainedMovement) IComputeStrategy (APDYNAMICART) NullParameters (APDYNAMICART) RosslerParameters (APDYNAMICART) WallRemove (APRoomEdit)
ConstraintHierarchyMember Icon (APGUI) NullPattern (APDYNAMICART) RosslerStrategy (APDYNAMICART) WavefrontObj
ContactObjectManipulator (behindO) Icon NullShapeGenerator (APDYNAMICART) Rotate (base) WaveSplineAdapter (APDYNAMICART)
ControllableAbility (vrecko) IconColour (APGUI) NullStrategy (APDYNAMICART) Rotation (APConnectEditor) Weather (APWeather)
Controller (APDYNAMICART) EventDispatcher::ICS (vrecko)
O
RotationFrameAdapter (APDYNAMICART) WG_Geometry (WGeometry)
Grid::ControlPoint (APFFDEditor) EventDispatcher::ICSBase (vrecko) RotationFrameFactory (APDYNAMICART) WG_Hole (WGeometry)
ControlPoint (APCameraPath) IkedaParameters (APDYNAMICART) OBJ (WAVEFRONT) RoundedSplineAdapter (APDYNAMICART) WG_Point (WGeometry)
ControlPoint (APCameraMovement) IkedaStrategy (APDYNAMICART) Scene::OBJ_INT_PRIO (vrecko) Rule (AP_LSystem) WG_Vertices (WGeometry)
CopyProperties (APObjectUtils) IMenuComponent (vreckoUtils) ObjectAdd (APEditorQAbilities) RWErrorHandler (vrecko) WG_Wall (WGeometry)
CoreActorDesc (PhysXPlugin) OptiTrack::info_struct (vreckoDP_base) WIM::ObjectCopy (behindO)
S
Wiimote (vreckoDP_base)
CPlayer (mv) InitSettings (APDYNAMICART) ObjectDelete (APEditorQAbilities) WIM (behindO)
CPoint (mv) InOutEdgesAttr (CarSim) ObjectEffect (APObjectUtils) PosNoiseRemover::SAMPLE (Filter) World (vrecko)
CreateHole (APRoomEdit) InPlaceParser (WAVEFRONT) ObjectEffectMan (APObjectUtils) SampledSpline WorldBuilder (ArtificialWorld)
CrissCrossPattern (APDYNAMICART) InPlaceParserInterface (WAVEFRONT) ObjectInfo (APObjectUtils) Scene::SC_INT_PRIO (vrecko)
X
Ctrl_Attractor (APDYNAMICART) InputConnector (APInputConnector) ObjectModif (APObjectUtils) Scale (APConnectEditor)
Ctrl_FreeHandPainting (APDYNAMICART) InputPin (vrecko) ObjectMovement (APEditorQAbilities) Scene (vrecko) XercesStr (vrecko)
Ctrl_MotionVisualization (APDYNAMICART) InputPinBase (vrecko) ObjectSelector (APObjectUtils) ScenePSThreadInfo (vrecko) XmlFile (AP_LSystem)
Ctrl_PerlinLines (APDYNAMICART) int_3 (APSpacePartitioning) Observable (vreckoUtils) SceneSave (APEditorQAbilities)
_
Ctrl_PolyhedraSculptures (APDYNAMICART) Interconnection (APGUI) Observer (vreckoUtils) Scheduler (vrecko)
Ctrl_StringSculptures (APDYNAMICART) SNCH_Object::InternalPointStruct (APSpacePartitioning) OctTree (vrecko) Screen (ht) _CLIENT_ID (base)
Cube (ode) InterpolatedSpline OctTree::OctTreeNode (vrecko) ScreenSetup (ht) _Light (APLightsEditor)
CubicInterpolator Interpolator ODEObject (ode) ScreenSetupSimple (ht) _THREAD_BASIC_INFORMATION (base)
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | _
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Hierarchy

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 1234567]
o C base::_CLIENT_ID |
o C APLightsEditor::_Light |
o C base::_THREAD_BASIC_INFORMATION |
o C AABoundingBox | Represents a bounding box (a sphere, actually) of the object which wraps the object in it
o C vrecko::ReaderWriter::AbilityToInitialize |
o C AP_LSystem::AbstractFile |
| o C AP_LSystem::LSFile |
| \ C AP_LSystem::XmlFile |
o C AP_LSystem::AbstractGenerator |
| \ C AP_LSystem::LSystemGenerator |
o C AP_LSystem::AbstractInterpret |
| o C AP_LSystem::QueryInterpret |
| \ C AP_LSystem::TurtleInterpret |
o C AP_LSystem::AbstractLSystem |
| \ C AP_LSystem::LSystem |
| o C AP_LSystem::Abstract0LSystem |
| | o C AP_LSystem::ParD0LSystem |
| | \ C AP_LSystem::ParStoch0LSystem |
| o C AP_LSystem::AbstractkLSystem |
| | \ C AP_LSystem::Par2LSystem |
| \ C AP_LSystem::D0LSystem |
o C AP_LSystem::AbstractTurtle |
| \ C AP_LSystem::MovingTurtle |
| o C AP_LSystem::LoftTurtle |
| | o C AP_LSystem::JointedPipe |
| | \ C AP_LSystem::StraightPipe |
| | \ C AP_LSystem::HermitPipe |
| o C AP_LSystem::QueryTurtle |
| \ C AP_LSystem::Rectangle |
o C APDYNAMICART::AdapterFactory< T > |
o C APDYNAMICART::AdapterFactory< ColorGenAdapter > |
| \ C APDYNAMICART::ColorGenFactory |
o C APDYNAMICART::AdapterFactory< DiameterGenAdapter > |
| \ C APDYNAMICART::DiameterGenFactory |
o C APDYNAMICART::AdapterFactory< RotationFrameAdapter > |
| \ C APDYNAMICART::RotationFrameFactory |
o C APDYNAMICART::AdapterFactory< SplineAdapter > |
| \ C APDYNAMICART::SplineFactory |
o C AddObserver | Rozhrani pro objekty, ktere zajima udalost Add
| \ C Cache | Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM
o C APEditorQAbilities::AbilityEditor::AllowedAbility |
o C angle_3D |
o C AnimatedGeometryState | Uchovava informace o animovanem Cal3D modelu, jeho data v pameti a pocet referenci
o C ArtificialWorld::AnimationPoint | Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode
o C APObjectUtils::Animator::AnimationPoint |
o C Arm |
o C vrecko::Attribute |
| o C vrecko::DynamicAttribute |
| \ C vrecko::StaticAttribute< type, tval, tref > |
o C vrecko::AttributesDescription |
o C vrecko::World::AvatarEye | Struct AvatarEye - represents avatar eye's camera parameters
o C vrecko::World::AvatarView | Struct for description of AvatarView
o C vrecko::BaseClass |
| o C APMenu::MenuItem |
| | o C APMenu::MenuItemNull |
| | \ C APMenu::MenuItemText |
| | \ C APMenu::MenuItemSlider |
| o C MainObject |
| o C vrecko::Ability |
| | o C AP_CableEditor::Cable |
| | o C AP_LSystem::LSObject |
| | o C APCameraMovement::CameraPath |
| | o C APClouds::Clouds | Clouds ability - revised Atmospheric ability
| | o C APConstrainedMovement::ConstraintDescription |
| | o C APDYNAMICART::Controller |
| | | o C APDYNAMICART::Ctrl_Attractor |
| | | o C APDYNAMICART::Ctrl_FreeHandPainting | Controller of Brush Stroke PoA
| | | | \ C APDYNAMICART::Ctrl_MotionVisualization | Controller of Motion Trail PoAs
| | | o C APDYNAMICART::Ctrl_PerlinLines |
| | | o C APDYNAMICART::Ctrl_PolyhedraSculptures |
| | | \ C APDYNAMICART::Ctrl_StringSculptures |
| | o C APDYNAMICART::DAEnvironment | Dynamic Art Environment class - base class of Dynamic Art plugin
| | o C APDYNAMICART::DATool | Virtual class defining basis of all tools used in Dynamic Art
| | | o C APDYNAMICART::PLControllerTool |
| | | o C APDYNAMICART::PLMagnetTool |
| | | o C APDYNAMICART::PLNestTool |
| | | o C APDYNAMICART::ToolBrush | Brush tool
| | | o C APDYNAMICART::ToolEraser |
| | | o C APDYNAMICART::ToolHook |
| | | o C APDYNAMICART::ToolMagicWand |
| | | o C APDYNAMICART::ToolRotation | Rotation tool
| | | o C APDYNAMICART::ToolSelector |
| | | o C APDYNAMICART::ToolSlice |
| | | \ C APDYNAMICART::ToolTongs |
| | o C APDYNAMICART::PoB | PoB (Piece of Behavior)
| | o C APEditorController::EditorController |
| | o C APGUI::GUI_Controller | GUI Controller class
| | o C APGUI::GUI_Item | VRECKO GUI Item class
| | | o C APGUI::ColorPicker | Spatial HSL Color Picker
| | | o C APGUI::Icon | Icon
| | | | \ C APGUI::IconColour | Color Icon
| | | o C APGUI::Menu | Menu
| | | \ C APGUI::Slider | Slider GUI item
| | o C APHelloWorld::MyAbility |
| | o C APHUD::HUDDisplay |
| | o C APInputConnector::InputConnector | Input Connector class
| | o C APLightsEditor::Lights |
| | o C APMenu::DynamicMenu |
| | o C APNature::TerrainAbility |
| | o C APObjectUtils::Animator |
| | o C APObjectUtils::ConnectionViz |
| | o C APObjectUtils::CopyProperties |
| | o C APObjectUtils::KeepOnScreen |
| | o C APObjectUtils::ObjectEffect |
| | o C APObjectUtils::ObjectEffectMan |
| | o C APObjectUtils::ObjectInfo |
| | o C APObjectUtils::ObjectModif |
| | o C APObjectUtils::ObjectSelector |
| | o C APObjectUtils::UseToEvent |
| | o C APRoomEdit::WallGeometry |
| | o C APShootingSimulation::ShootingSimulation |
| | o C APSpacePartitioning::NoPartitioning_Scene |
| | o C APSpacePartitioning::PointShellVSVoxel_Object |
| | o C APSpacePartitioning::SP_Object_Data_Base |
| | | o C APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
| | | o C APSpacePartitioning::SphereBVH_Object_Data |
| | | | \ C APSpacePartitioning::SNCH_Object_Data |
| | | \ C APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
| | | \ C APSpacePartitioning::PointShell_Object_Data |
| | o C APSpacePartitioning::SphereBVH_Object |
| | | \ C APSpacePartitioning::SNCH_Object |
| | o C APSpacePartitioning::SphereBVH_Scene |
| | o C APSpacePartitioning::VoxelGrid_Object_Data |
| | o C APTextOutput::Console |
| | o C APWeather::Weather |
| | o C ArtificialWorld::BlockUpdater | Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky
| | o C ArtificialWorld::WorldBuilder | Trida, ktera vytvori hierarchicky svet ve scene
| | o C base::Avatar |
| | o C base::Display |
| | o C base::hand |
| | o C base::Light |
| | o C base::MouseHand |
| | o C base::MTMatrixTransform |
| | o C base::Rotate |
| | o C base::ShowFDH |
| | o C base::ShowFDHModel |
| | o C base::SystemInfo |
| | o C behindO::AvatarManipulator |
| | o C behindO::CentreObjectManipulator |
| | o C behindO::ChangeOfVisibility |
| | o C behindO::ContactObjectManipulator |
| | o C behindO::CuttingPlane |
| | o C behindO::EyeManipulator |
| | o C behindO::HeadManipulator |
| | o C behindO::HMDHeadManipulator |
| | o C behindO::Lens |
| | o C behindO::Manipulator |
| | o C behindO::MappingFunctions |
| | o C behindO::Mirror |
| | o C behindO::WIM |
| | o C BehindObstacleExp_wT |
| | o C BehindObstacleExperiment |
| | o C boids::Boid |
| | o C boids::BoidsLogic |
| | o C boids::BoidsPlanner |
| | o C Cache | Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM
| | o C CarSim::CarControlUnit |
| | o C CarSim::CarExecutionUnit |
| | o C CarSim::CarPartsNodeCache |
| | o C CarSim::Remover |
| | o C CarSim::RoadsState |
| | o C CarSim::TLsOnJuncManager |
| | o C ChessBoard |
| | o C ChessPiece |
| | o C Filter::Linear |
| | o C Filter::PosNoiseRemover |
| | o C grass::Grass |
| | o C ht::HeadTracking |
| | o C ht::ScreenSetup |
| | o C ht::ScreenSetupSimple |
| | o C navigation::AvatarInHand |
| | o C navigation::KMTracker |
| | o C ode::CappedCylinder |
| | o C ode::CompositeObject |
| | o C ode::Cube |
| | o C ode::DynamicScene |
| | o C ode::Sphere |
| | o C PHANToMAvatar |
| | o C PHEffect |
| | o C PhysXPlugin::PhysXObject |
| | | o C PhysXPlugin::BasePhysXObject |
| | | | o C PhysXPlugin::BaseJoint |
| | | | | o C PhysXPlugin::CylindricalJoint |
| | | | | o C PhysXPlugin::DistanceJoint |
| | | | | o C PhysXPlugin::FixedJoint |
| | | | | o C PhysXPlugin::PointInPlaneJoint |
| | | | | o C PhysXPlugin::PointOnLineJoint |
| | | | | o C PhysXPlugin::PrismaticJoint |
| | | | | o C PhysXPlugin::PulleyJoint |
| | | | | o C PhysXPlugin::RevoluteJoint |
| | | | | \ C PhysXPlugin::SphericalJoint |
| | | | o C PhysXPlugin::ForceField |
| | | | \ C PhysXPlugin::UpdatablePhysXObject |
| | | | o C PhysXPlugin::BaseActor |
| | | | | o C PhysXPlugin::Box |
| | | | | o C PhysXPlugin::Capsule |
| | | | | o C PhysXPlugin::Plane |
| | | | | \ C PhysXPlugin::Sphere |
| | | | o C PhysXPlugin::Cloth |
| | | | \ C PhysXPlugin::Fluid |
| | | o C PhysXPlugin::PhysXScene |
| | | \ C PhysXPlugin::RemoteDebugger |
| | o C VirtualFixture::Avatar |
| | o C VirtualFixture::Log |
| | o C VirtualFixture::ProxiBorder |
| | o C VirtualFixture::ProxiBox |
| | o C VirtualFixture::ProxiCone |
| | o C VirtualFixture::ProxiCylinder |
| | o C VirtualFixture::ProxiSphere |
| | o C VirtualFixture::Trace |
| | o C vrecko::ControllableAbility |
| | | o C AP_CableEditor::CableEditor |
| | | o C APCameraMovement::CameraMovementEditor |
| | | o C APCameraPath::Camera |
| | | o C APConnectEditor::ConnectEditor |
| | | o C APConnectEditor::Cut |
| | | o C APConnectEditor::Optimalizer |
| | | o C APConnectEditor::PolygonState |
| | | o C APConnectEditor::Rotation |
| | | o C APConnectEditor::Scale |
| | | o C APConstrainedMovement::ConstrainedObjectMovement |
| | | o C APEditorController::AbilityMapper |
| | | o C APEditorQAbilities::AbilityEditor |
| | | o C APEditorQAbilities::AnimatorEditor |
| | | o C APEditorQAbilities::AvatarMovement |
| | | o C APEditorQAbilities::ObjectAdd |
| | | o C APEditorQAbilities::ObjectDelete |
| | | o C APEditorQAbilities::ObjectMovement |
| | | o C APEditorQAbilities::SceneSave |
| | | o C APEditorQAbilities::SimpleObjectMovement |
| | | o C APEditorQAbilities::UseTrigger |
| | | o C APFFDEditor::EditorLogic |
| | | o C APLightsEditor::Editor |
| | | \ C APRoomEdit::RoomEditor |
| | \ C vrecko::PyAbility | Python ability
| o C vrecko::AbilityDispatcher | Used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities
| o C vrecko::Device |
| | o C vreckoDP_base::A3DBird |
| | o C vreckoDP_base::fdtDataGlove |
| | o C vreckoDP_base::fsPinchGlove |
| | o C vreckoDP_base::KeyboardMouse |
| | o C vreckoDP_base::LHeadTracker |
| | | \ C vreckoDP_base::L3DMouse |
| | o C vreckoDP_base::MicroScribe3D |
| | o C vreckoDP_base::NestOfBirds |
| | o C vreckoDP_base::OptiTrack |
| | o C vreckoDP_base::Ultratrak |
| | o C vreckoDP_base::VRPN3DMouse |
| | o C vreckoDP_base::Wiimote |
| | \ C vreckoDP_Kinect::Kinect |
| o C vrecko::DeviceManager |
| o C vrecko::EnvironmentObject |
| | o C APDYNAMICART::PoA | PoA (Piece of Art)
| | | o C APDYNAMICART::Attractor |
| | | | o C APDYNAMICART::JuliaAttractor |
| | | | o C APDYNAMICART::NullAttractor |
| | | | \ C APDYNAMICART::OrdinaryAttractor |
| | | o C APDYNAMICART::BrushStroke | Store data about and can render one brush stroke
| | | | \ C APDYNAMICART::MotionTrail |
| | | o C APDYNAMICART::HookObject |
| | | o C APDYNAMICART::Hoop |
| | | o C APDYNAMICART::PerlinLines |
| | | \ C APDYNAMICART::PolyhedraSculpture |
| | o C APDYNAMICART::PS_FacePlane |
| | \ C APDYNAMICART::SimpleBox | Simple class for creating boxes
| o C vrecko::EventDispatcher |
| o C vrecko::OctTree |
| o C vrecko::Scene |
| o C vrecko::Scene::EOIteratorHelper | Class for iterating through all environment objects in non-main threads
| \ C vrecko::World |
o C vrecko::BenchmarkWriter | Class to write any timings and other benchmark data into file
o C ArtificialWorld::BlockAttributes | Atributy bloku
o C vrecko::BufferedFile |
o C vrecko::BufferedFileWrite |
o C APEditorController::AbilityMapper::BUTTON_MAPPING |
o C vrecko::CABUTTONEVENT |
o C CacheInfo | Trida pro drzeni informaci o polozce v Cache
o C vrecko::CAINFO__VER1 |
| \ C vrecko::CAINFO__VER2 |
o C Callback |
| \ C UniformUpdateCallback |
o C APEditorQAbilities::ObjectMovement::CANDIDATEPLANE |
o C CarSim::CarEdgeData |
o C CarSim::CarEnvirons |
o C CarSim::CarSize |
o C CarSim::CarState |
o C mv::CCollection |
o C mv::CGesture |
o C vrecko::Scheduler::classcomp |
o C Cloud |
o C CloudSceneInfo |
o C CloudsManager | Manages all the clouds in the scene
o C CloudsProperties | Contains all the properties of the Clouds ability loaded from XML file
o C CloudVoxel | Represents a cloud voxel used for cloud generation
o C mv::CMVect |
o C vrecko::CollisionInfo |
o C vrecko::CollisionParams__ver1 | Parameters for the SP_SceneInterface::getCollisions() method
o C vrecko::CollisionPointInfo |
o C APSpacePartitioning::NoPartitioning_Scene::CollisionStruct |
o C APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject |
o C ColorGen |
| o C ConstantColorGen |
| o C GradientColorGen |
| \ C SectorColorGen |
o C APDYNAMICART::colorGradient |
o C AP_LSystem::Configuration |
o C APDYNAMICART::Configuration |
o C APObjectUtils::ConnectionViz::Connection |
o C APConstrainedMovement::ConstraintArea |
o C ConstraintHierarchyMember |
o C ConstShapeVisitor |
| \ C osgQ::QConstShapeVisitor |
| o C osgQ::QComputeBoundShapeVisitor |
| o C osgQ::QDrawShapeVisitor |
| \ C osgQ::QPrimitiveShapeVisitor |
o C APCameraMovement::ControlPoint |
o C APCameraPath::ControlPoint |
o C APFFDEditor::Grid::ControlPoint |
o C PhysXPlugin::CoreActorDesc |
o C mv::CPlayer |
o C mv::CPoint |
o C CullCallback |
| \ C grass::GrassCullCallback |
o C DASample |
o C ode::CompositeObject::Data |
o C vreckoDP_base::dataT |
o C DATool |
| o C MagicWandTool |
| o C MTCreatorTool | Motion trails creator tool
| \ C SliceTool |
o C APSpacePartitioning::SNCH_Object_Data::DebugLevelStats |
o C APSpacePartitioning::SNCH_Object_Data::DebugStats |
o C DeleteObserver | Rozhrani pro objekty, ktere zajima udalost Delete
| \ C Cache | Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM
o C DiameterGen |
| \ C GradientDiameterGen |
o C Drawable |
| \ C grass::GrassDrawable |
o C Drawable |
| o C PhysXPlugin::ClothDrawable |
| \ C PhysXPlugin::FluidDrawable |
o C DrawCallback |
| \ C AllCloudsUpdateCallBack | Structure containing camera data which is common for all of the clouds and overloaded callback method which is called once per frame
o C vrecko::DeviceManager::DT |
o C VK_NoStepInto_Namespace::DynamicArray< _Type > |
o C VK_NoStepInto_Namespace::DynamicArray< APEditorQAbilities::AbilityEditor::AllowedAbility > |
o C VK_NoStepInto_Namespace::DynamicArray< APEditorQAbilities::ObjectMovement::CANDIDATEPLANE > |
o C VK_NoStepInto_Namespace::DynamicArray< APEditorQAbilities::ObjectMovement::SnapBox > |
o C VK_NoStepInto_Namespace::DynamicArray< APMenu::MenuItem * > |
o C VK_NoStepInto_Namespace::DynamicArray< APObjectUtils::Animator::AnimationPoint > |
o C VK_NoStepInto_Namespace::DynamicArray< APObjectUtils::ConnectionViz::Connection > |
o C VK_NoStepInto_Namespace::DynamicArray< APSpacePartitioning::SNCH_Object_Data::DebugLevelStats > |
o C VK_NoStepInto_Namespace::DynamicArray< BYTE > |
o C VK_NoStepInto_Namespace::DynamicArray< DWORD > |
o C VK_NoStepInto_Namespace::DynamicArray< EnvironmentObject * > |
o C VK_NoStepInto_Namespace::DynamicArray< Filter::PosNoiseRemover::SAMPLE > |
o C VK_NoStepInto_Namespace::DynamicArray< int > |
o C VK_NoStepInto_Namespace::DynamicArray< unsigned long > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::Logger::OutputNotificationFuncStored > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::Logger::OutstandingCounter > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::Logger::OutstandingText > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::PersistentCache::OpenedCacheFile * > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::Scene::OBJ_INT_PRIO > |
o C VK_NoStepInto_Namespace::DynamicArray< vrecko::Scene::SC_INT_PRIO > |
o C APMenu::DynamicMenuSign |
o C DynamicTree< _Type > |
o C DynamicTree< _NodeType > |
o C DynamicTree< APMenu::MenuItem > |
o C DynamicTree< MenuItem > |
o C DynamicTree< PointShell_SimpleNode > |
o C DynamicTreeIterator< _Type > |
o C DynTreeNode< _Type > |
o C DynTreeNode< MenuItem > |
| \ C APMenu::MenuItem |
o C DynTreeNode< PointShell_SimpleNode > |
| \ C APSpacePartitioning::PointShell_SimpleNode |
o C APSpacePartitioning::PointShell_Object_Data_Geometry::E |
| o C APSpacePartitioning::ELOD |
| \ C APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt |
o C APEditorController::EditorController::ECPOINTERBUTTONINFO |
o C APEditorController::EditorController::ECPOINTERINFO |
o C APFFDEditor::Grid::Edge |
o C CarSim::Edge |
o C CarSim::EdgesCar |
o C vrecko::EventDispatcher::EventDefinitionStruct | Struct that defines an event
o C vrecko::EventDispatcher::EventStruct | Struct contains received event
o C exception |
| \ C AP_LSystem::LSystemException |
| o C AP_LSystem::ConfigurationException |
| o C AP_LSystem::FileException |
| \ C AP_LSystem::ParsingException |
o C BehindObstacleExp_wT::ExperimentRec |
o C BehindObstacleExperiment::ExperimentRec |
o C APSpacePartitioning::GeometryLoaderBase::FaceBase |
o C APFFDEditor::GeometryLoaderBase::FaceBase |
o C FaceBase |
| \ C APSpacePartitioning::SNCH_Object_Data::FaceSNCH |
o C CarSim::First3Juncs |
o C ht::Function |
| o C ht::SetupFunction |
| \ C ht::SimpleSetupFunction |
o C GenericHeap< _NodeClass, _keyType > |
| o C BinomialHeap< _NodeClass, _keyType > |
| o C FibonacciHeap< _NodeClass, _keyType > |
| \ C ThinHeap< _NodeClass, _keyType > |
o C GenericHeap< _NodeClass, _keyType >::GenericHeapNode |
| o C BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode |
| \ C FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode |
o C GenericHeapNode |
| \ C ThinHeap< _NodeClass, _keyType >::ThinHeapNode |
o C Geode |
| o C AP_LSystem::LSGeode |
| o C APDYNAMICART::PatternsGeode |
| o C APDYNAMICART::PS_FlatShape |
| | o C APDYNAMICART::PS_Component |
| | \ C APDYNAMICART::PS_Face |
| o C APGUI::GUI_Text | Text
| o C MotionTrailTriangulator |
| \ C SweepSurfaceGeode |
o C APFFDEditor::GeometryLoader::Geometry |
o C WAVEFRONT::GeometryInterface |
| \ C WAVEFRONT::BuildMesh |
o C APFFDEditor::GeometryLoader |
| \ C APFFDEditor::EditorLogic |
o C APSpacePartitioning::GeometryLoaderBase |
| o C APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
| o C APSpacePartitioning::SphereBVH_Object_Data |
| o C APSpacePartitioning::VoxelGrid_Object_Data |
| \ C APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
o C APFFDEditor::GeometryLoaderBase |
o C CarSim::GeometryPartsPath |
o C GeometryState | Uchovava informace o statickem modelu, jeho data v pameti a pocet referenci (instanci modelu ve scene)
o C WAVEFRONT::GeometryVertex |
o C GetObserver | Rozhrani pro objekty, ktere zajima udalost Get
| \ C Cache | Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM
o C gmMatrix3 |
o C gmMatrix4 |
o C gmVector2 |
o C gmVector3 |
o C gmVector4 |
o C APFFDEditor::Grid |
o C Group |
| o C APDYNAMICART::HoopGeometry |
| \ C vrecko::World |
o C GUIEventHandler |
| \ C vreckoDP_base::KeyboardMouse |
o C Hci |
o C APDYNAMICART::HookManager | Hook Manager
o C APHUD::HUDColorProfile |
o C APHUD::HUDField |
o C APHUD::HUDWindow |
o C vrecko::EventDispatcher::ICSBase | Struct that holds identification of receiver and interconnection type
| o C vrecko::EventDispatcher::ICS |
| \ C vrecko::EventDispatcher::REQUEST_Struct |
o C vreckoDP_base::OptiTrack::info_struct |
o C APDYNAMICART::InitSettings |
o C CarSim::InOutEdgesAttr |
o C WAVEFRONT::InPlaceParser |
o C WAVEFRONT::InPlaceParserInterface |
| \ C WAVEFRONT::OBJ |
o C APSpacePartitioning::int_3 |
o C APGUI::Interconnection | Used to simplify deletion of created interconnections (especially in menu)
o C APSpacePartitioning::SNCH_Object::InternalPointStruct |
o C InterpolatorFactory |
o C CarSim::JuncsEdge |
o C CarSim::Junction |
o C length_3D |
o C CarSim::Lights |
o C APDYNAMICART::Limits |
o C APTextOutput::Console::Line |
o C LoadingConsole::Line |
o C LineSegmentIntersector |
| o C APConnectEditor::EOLineSegmentIntersector |
| o C APObjectUtils::EOLineSegmentIntersector |
| \ C EOLineSegmentIntersector |
o C APSpacePartitioning::SNCH_Object::LMDStore |
o C LoadingConsole |
o C APSpacePartitioning::SNCH_Object::LocalMinimumDistance |
o C AP_LSystem::Log |
o C vrecko::Logger |
o C AP_LSystem::LongString |
o C APEditorController::AbilityMapper::MAPPING |
o C vrecko::MaterialDesc |
o C PhysXPlugin::MaterialManager |
o C vreckoUtils::Math |
o C MatrixTransform |
| o C vrecko::EnvironmentObject |
| \ C vrecko::Scene |
o C vreckoUtils::MenuCommon |
o C vreckoUtils::MenuVisitor |
o C ArtificialWorld::Model | Uchovava informace o modelu
| \ C ArtificialWorld::AnimatedModel | Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit
o C ModelManager |
o C vrecko::MTAutoLock |
o C vrecko::MTLock | Base class for multi-thread access to a single variable
o C vrecko::MTReadWriteLock |
o C vrecko::MTReadWriteLockEx |
o C vrecko::MTTwoPrioLimitedLock |
o C APSpacePartitioning::mycomparisonMaxMin |
o C APSpacePartitioning::mycomparisonMinMax |
o C NodeCallback |
| o C APDYNAMICART::HoopTrackerCallback |
| o C behindO::MyCullCallback |
| o C behindO::MyUpdateCallback |
| o C MainSceneUpdateCallback |
| \ C vreckoUtils::HighlightCallback |
o C vrecko::BaseClass::NOTIFICATION_DESCRIPTION |
o C NxStream |
| o C MemoryReadBuffer |
| o C MemoryWriteBuffer |
| \ C UserStream |
o C NxUserOutputStream |
| \ C PhysXPlugin::ErrorReporter |
o C vrecko::Scene::OBJ_INT_PRIO |
o C behindO::WIM::ObjectCopy |
o C vreckoUtils::Observable |
| \ C APDYNAMICART::DATool | Virtual class defining basis of all tools used in Dynamic Art
o C vreckoUtils::Observer |
| \ C APDYNAMICART::Ctrl_StringSculptures |
o C vrecko::OctTree::OctTreeNode |
o C ode::ODEObject |
o C APSpacePartitioning::SNCH_Object::OneTri |
o C vrecko::PersistentCache::OpenedCacheFile |
o C vrecko::Logger::OutputNotificationFuncStored |
o C vrecko::Logger::OutstandingCounter |
o C LoadingConsole::OutstandingLine |
o C vrecko::Logger::OutstandingText |
o C APSpacePartitioning::PointShell_Object_Data_Geometry::P |
| o C APSpacePartitioning::PLOD |
| \ C APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt |
o C packet_rec |
o C APDYNAMICART::Parameter |
o C AP_LSystem::Parameter |
o C CarSim::Parameters |
o C vrecko::Ability::ParameterStruct |
o C AP_LSystem::ParseableString |
o C PhysXPlugin::Particle |
o C Particle |
| \ C CloudParticle |
o C Cloud::ParticleAwayComparison |
o C APDYNAMICART::ParticleSystemParameters |
o C APDYNAMICART::PatternFactory |
o C vrecko::PersistentCache | Caching that persists multiple application sessions
o C PHANToMFilter |
| o C filter1 |
| o C filter2 |
| o C VirtualFixture::AxisLock |
| o C VirtualFixture::Border |
| o C VirtualFixture::Box |
| o C VirtualFixture::Cone |
| o C VirtualFixture::Cylinder |
| o C VirtualFixture::Damper |
| o C VirtualFixture::Drag |
| o C VirtualFixture::Filter |
| o C VirtualFixture::Grid |
| o C VirtualFixture::Marker |
| o C VirtualFixture::MarkerFactory |
| o C VirtualFixture::NavSphere |
| o C VirtualFixture::Plane |
| o C VirtualFixture::Sphere |
| o C VirtualFixture::Vibration |
| o C VirtualFixture::VibrationLabel |
| \ C VirtualFixture::VibrationLabelActivator |
o C APDYNAMICART::PhysXManager |
o C vrecko::PluginManager | Simple class to load and manage the plugins
o C APDYNAMICART::PoAState |
o C PoB |
| \ C Icon | Icon
o C Point3 |
o C Point3f |
o C APSpacePartitioning::PointShell_Object_Data_Geometry |
| o C APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
| \ C APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
o C CarSim::PolygonPoint |
o C APDYNAMICART::PolyhedronFactory |
o C Preloader | Nahrava pravdepodobne potrebne modely v blizke budoucnosti, modely jsou urceny podle pouzite heuristiky
o C PreloaderHeuristic | Rozhrani pro heuristiky, ktere se maji pouzit v Preloaderu
| \ C BasicPreloaderHeuristic |
o C PreloaderLoadedInfo |
o C PreloaderToLoadInfo |
o C APEditorQAbilities::PresentAbility |
o C APDYNAMICART::PS_Symmetry |
o C PseudoRand2DPlacement | Represents a class which pseudo-randomly scatters the clouds over the sky in form of the grid (for now)
o C APSpacePartitioning::PointShell_Object_Data::PSpoint |
o C osgQ::QShapeVisitor |
o C AP_LSystem::Query |
o C AP_LSystem::RandomIndex |
o C AP_LSystem::Randomizer |
o C vrecko::Range |
| o C vrecko::Enumeration< tval, tref > |
| \ C vrecko::Interval< tval, tref > |
o C ReadCallback |
| o C APCameraMovement::MyReadCallback |
| o C APConnectEditor::MyReadCallback |
| o C APObjectUtils::MyReadCallback |
| o C APSpacePartitioning::VGReadCallback |
| \ C MyReadCallback |
o C mv::Reader |
o C vrecko::ReaderWriter |
o C RealCmp< T > |
o C Receiver |
o C Referenced |
| o C APDYNAMICART::Brush | Encapsulate data and functionality of sweepSurface related factories and adapters
| o C APDYNAMICART::BrushStrokeControlPoint | Control point of Sweep Surface
| o C APDYNAMICART::ComputeThread |
| o C APDYNAMICART::Controller |
| o C APDYNAMICART::DAGizmo | Gizmo - graphical representation of something, e.g. Frenet frame
| o C APDYNAMICART::DATool | Virtual class defining basis of all tools used in Dynamic Art
| o C APDYNAMICART::HoopShape |
| | o C APDYNAMICART::Ellipse |
| | o C APDYNAMICART::ElongatedCircle |
| | o C APDYNAMICART::Line |
| | o C APDYNAMICART::NullHoopShape |
| | o C APDYNAMICART::Painted |
| | o C APDYNAMICART::Rectangle |
| | \ C APDYNAMICART::RegularPolygon |
| o C APDYNAMICART::IComputeStrategy |
| | o C APDYNAMICART::IkedaStrategy |
| | o C APDYNAMICART::Lorenz84Strategy |
| | o C APDYNAMICART::LorenzStrategy |
| | o C APDYNAMICART::NullStrategy |
| | o C APDYNAMICART::PickoverStrategy |
| | o C APDYNAMICART::PolynomialStrategy |
| | \ C APDYNAMICART::RosslerStrategy |
| o C APDYNAMICART::IParameters |
| | o C APDYNAMICART::IkedaParameters |
| | o C APDYNAMICART::JuliaParameters |
| | o C APDYNAMICART::Lorenz84Parameters |
| | o C APDYNAMICART::LorenzParameters |
| | o C APDYNAMICART::NullParameters |
| | o C APDYNAMICART::PickoverParameters |
| | o C APDYNAMICART::PolynomialParameters |
| | \ C APDYNAMICART::RosslerParameters |
| o C APDYNAMICART::IShapeGenerator |
| | o C APDYNAMICART::LinearShapeGenerator |
| | \ C APDYNAMICART::NullShapeGenerator |
| o C APDYNAMICART::Mode |
| | o C APDYNAMICART::Advanced |
| | \ C APDYNAMICART::Basic |
| o C APDYNAMICART::Pattern |
| | \ C APDYNAMICART::PatternBase |
| | o C APDYNAMICART::AcrossPattern |
| | o C APDYNAMICART::CrissCrossPattern |
| | o C APDYNAMICART::DoublePattern |
| | o C APDYNAMICART::HyperbolicPattern |
| | o C APDYNAMICART::NullPattern |
| | o C APDYNAMICART::SplitPattern |
| | o C APDYNAMICART::SplitReversePattern |
| | o C APDYNAMICART::StandardPattern |
| | o C APDYNAMICART::TopPattern |
| | \ C APDYNAMICART::TopReversePattern |
| o C APDYNAMICART::PoAAdapter< T > |
| | o C APDYNAMICART::ConstantDiamAdapter |
| | \ C APDYNAMICART::GradientDiamAdapter |
| o C APDYNAMICART::PS_Layer |
| o C APDYNAMICART::PS_Layer |
| o C APDYNAMICART::PS_Polyhedron |
| o C APGUI::ItemsGroup | Group of GUI Items
| o C APGUI::Layout | GUI Layout class
| o C CloudDataType | Inherited class from osg::Referenced. Stores information about the camera and can be referenced by osg::ref_ptr
| o C DAControlPoint | Control point of Motion trail
| o C DAGizmo | Gizmo - graphical representation of something, e.g. Frenet frame
| o C grass::GrassAbilityParameters |
| o C grass::Mesh |
| o C Interpolator |
| | o C CatmullRomInterpolator |
| | o C CubicInterpolator |
| | o C LinearInterpolator |
| | \ C NullInterpolator |
| o C MTBrush | Store info about shape of cross-section of Motion trail
| o C APDYNAMICART::PoAAdapter< ColorGen > |
| | \ C APDYNAMICART::ColorGenAdapter |
| | o C APDYNAMICART::ConstantColorAdapter |
| | \ C APDYNAMICART::GradientColorAdapter |
| o C APDYNAMICART::PoAAdapter< RotationFrameGenerator > |
| | \ C APDYNAMICART::RotationFrameAdapter |
| | o C APDYNAMICART::AxisFrameAdapter |
| | o C APDYNAMICART::HandFrameAdapter |
| | \ C APDYNAMICART::RMFrameAdapter |
| o C APDYNAMICART::PoAAdapter< Spline > |
| | \ C APDYNAMICART::SplineAdapter |
| | o C APDYNAMICART::RectangularSplineAdapter |
| | o C APDYNAMICART::RoundedSplineAdapter |
| | \ C APDYNAMICART::WaveSplineAdapter |
| o C Sector |
| o C vrecko::IOPinBase | Base class that defines the very basic method that every IO pin will have
| | o C vrecko::InputPinBase |
| | | \ C vrecko::InputPin< _MessageType > |
| | o C vrecko::IORequestPinBase |
| | | o C vrecko::RequestInputPinBase |
| | | | \ C vrecko::RequestInputPin< _MessageType, _ReturningMessageType > |
| | | \ C vrecko::RequestOutputPinBase |
| | | \ C vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > |
| | \ C vrecko::OutputPinBase |
| | \ C vrecko::OutputPin< _MessageType > |
| o C vrecko::ViewerBase | Abstract VRECKO viewer class
| | o C vrecko::CompositeViewer | Child class for more than one screen viewer
| | \ C vrecko::Viewer | Child class for classic one screen viewer - used for QUAD_STEREO
| o C vrecko::VreckoMessage |
| | o C APEditorController::AbilityMapper::MessageMapping |
| | o C base::SystemInfo::MessageSIThreadCreated |
| | o C CarSim::MessageCarEdge |
| | o C CarSim::MessageCarEdgeData |
| | o C CarSim::MessageCarEnvirons |
| | o C CarSim::MessageCarSimParameters |
| | o C CarSim::MessageCarStatePtr |
| | o C CarSim::MessageEdgeOffset |
| | o C CarSim::MessageFirst3Juncs |
| | o C CarSim::MessageRoadAndDir |
| | o C CarSim::MessageStartStopDestination |
| | o C CarSim::MessageVectorUnsignedInt |
| | o C ode::DynamicScene::MessageODERequest |
| | o C PhysXPlugin::MessageNxActorWithName |
| | o C vrecko::ControllableAbility::MessageCAINFO |
| | o C vrecko::MessageCAButtonEvent |
| | o C vrecko::MessageSensorTransformation |
| | \ C vrecko::MessageVoid |
| o C vreckoUtils::IMenuComponent |
| | o C vreckoUtils::MenuBase |
| | | o C vreckoUtils::Menu |
| | | \ C vreckoUtils::MenuRoot |
| | o C vreckoUtils::MenuItem |
| | \ C vreckoUtils::MenuSlider |
| o C WGeometry::WG_Point |
| \ C WGeometry::WG_Wall |
o C ChessBoard::Request |
o C CarSim::RoadsEdges |
o C RotationFrameGenerator |
| \ C FrenetFrame |
o C AP_LSystem::Rule |
o C Filter::PosNoiseRemover::SAMPLE |
o C vrecko::Scene::SC_INT_PRIO |
o C vrecko::ScenePSThreadInfo |
o C vrecko::Scheduler |
o C ht::Screen | Defines position of screen in real world
o C ht::ScreenSetupSimple::ScreenSetupSimpleState |
o C ht::ScreenSetup::ScreenSetupState |
o C APDYNAMICART::SectorInfo |
o C APDYNAMICART::SectorManager | Sector Manager
o C Serial |
o C vrecko::World::SG_CHANGE | Struct that includes values of the operation parameters
o C Shape |
| \ C osgQ::QSection |
o C ShapeDrawable |
| \ C osgQ::QShapeDrawable |
o C APDYNAMICART::ShapeFactory |
o C APDYNAMICART::SimulationParameters |
o C base::SystemInfo::SIThreadInfo |
o C base::SystemInfo::SIThreadInit |
o C APEditorQAbilities::ObjectMovement::SnapBox |
o C SnapObject |
o C APDYNAMICART::SnapPoint |
o C SNCH_THREAD_START_INFO |
o C vrecko::SP_Object_DataInterface |
| o C APSpacePartitioning::SP_Object_Data_Base |
| \ C APSpacePartitioning::VoxelGrid_Object_Data |
o C vrecko::SP_ObjectInterface |
| o C APSpacePartitioning::PointShellVSVoxel_Object |
| \ C APSpacePartitioning::SphereBVH_Object |
o C vrecko::SP_SceneInterface |
| o C APSpacePartitioning::NoPartitioning_Scene |
| \ C APSpacePartitioning::SphereBVH_Scene |
o C Spline |
| o C BufferedSpline |
| o C RegularPolygonSpline |
| \ C SampledSpline |
o C SplineDecorator |
| o C FilletSpline |
| o C InterpolatedSpline |
| o C SmoothedSpline |
| \ C TimeLineSpline |
o C CarSim::StartStopDestination |
o C AP_LSystem::StaticString |
o C APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere |
o C STNodeSphere |
| \ C APSpacePartitioning::SNCH_Object_Data::STNodeSNCH |
o C streambuf |
| \ C vrecko::logger_streambuf |
o C AP_LSystem::StringUtils |
o C vrecko::EventDispatcher::StringWithHash |
o C vrecko::EventDispatcher::StringWithHashComparator |
o C APDYNAMICART::Stroke |
| o C APDYNAMICART::BrushStroke | Store data about and can render one brush stroke
| \ C APDYNAMICART::Hoop |
o C StrX |
o C ArtificialWorld::SubBlock | Trida reprezentujici jeden blok ve scene
o C ArtificialWorld::SubBlockAnimation | Trida reprezentujici animaci bloku
o C SunLight |
o C APDYNAMICART::symmetry_axis |
o C APDYNAMICART::symmetry_pair |
o C APNature::Terrain2D | 2D terrain based on height map which consists of multiple equally large segments
o C APNature::Terrain2DSegment | Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point
o C APNature::TerrainAlgorithm |
| o C APNature::MidpointDisplacementAlgorithm |
| o C APNature::PerlinNoiseAlgorithm |
| \ C APNature::RandomFaultsAlgorithm |
o C APNature::TerrainRandom |
o C APNature::TerrainUtility |
o C Thread |
| \ C APDYNAMICART::ComputeThread |
o C vrecko::Timer |
o C vrecko::Scheduler::TimerStruct |
o C Timing |
o C vrecko::Logger::TimingInfo |
o C CarSim::TLcolorsMT |
o C APRoomEdit::Tool |
| o C APRoomEdit::ColorBucket |
| o C APRoomEdit::CreateHole |
| o C APRoomEdit::HoleRemove |
| o C APRoomEdit::PointAdd |
| o C APRoomEdit::PointMove |
| o C APRoomEdit::RoomLoader |
| o C APRoomEdit::RoomSaver |
| o C APRoomEdit::WallAdd |
| o C APRoomEdit::WallMovement |
| \ C APRoomEdit::WallRemove |
o C APDYNAMICART::Trait |
o C grass::Triangle |
o C Triangle |
o C Triangle3 |
o C Triangle3v |
o C grass::TriangleCollector |
o C AP_LSystem::TurtleProperties |
o C AP_LSystem::TurtleStack |
o C vrecko::EnvironmentObject::UserData | Here are stored pointer to UserData and its type
o C APDYNAMICART::Utils |
o C APSpacePartitioning::PointShell_Object_Data_Geometry::V |
| o C APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt |
| \ C APSpacePartitioning::VLOD |
o C ht::Variable |
| o C ht::VariableFloat |
| o C ht::VariableQuat |
| o C ht::VariableVec2 |
| \ C ht::VariableVec3 |
o C grass::Vertex |
o C APSpacePartitioning::GeometryLoaderBase::VertexBase |
| \ C APSpacePartitioning::SNCH_Object_Data::VertexSNCH |
o C APFFDEditor::GeometryLoaderBase::VertexBase |
o C vrecko::vThread |
o C WavefrontObj |
o C WGeometry::WG_Geometry |
o C WGeometry::WG_Hole |
o C WGeometry::WG_Vertices |
o C XERCES_CPP_NAMESPACE_QUALIFIER DOMErrorHandler |
| o C APMenu::MenuLoaderErrorHandler |
| o C BCLoaderErrorHandler |
| \ C vrecko::RWErrorHandler |
\ C vrecko::XercesStr |
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _a : APDYNAMICART::Ellipse
  • _actionMap : APInputConnector::InputConnector
  • _active_contact : vreckoDP_base::fsPinchGlove
  • _activeLayer : APDYNAMICART::PolyhedraSculpture
  • _activeSensor : APGUI::Menu
  • _actor : APDYNAMICART::Hoop , PhysXPlugin::MessageNxActorWithName
  • _actorDesc : PhysXPlugin::BaseActor
  • _actual_head_orientation : navigation::AvatarInHand
  • _actual_head_position : navigation::AvatarInHand
  • _actual_left_hand_orientation : navigation::AvatarInHand
  • _actual_left_hand_position : navigation::AvatarInHand
  • _actual_position
: navigation::KMTracker
, base::hand
, base::MouseHand
, navigation::AvatarInHand
  • _actual_right_hand_orientation : navigation::AvatarInHand
  • _actual_right_hand_position : navigation::AvatarInHand
  • _actual_rotation : base::hand , base::MouseHand
  • _actualLayout : APGUI::GUI_Controller
  • _actualPositions : APGUI::GUI_Controller
  • _actualTool : APDYNAMICART::Controller
  • _adapters : APDYNAMICART::AdapterFactory< T >
  • _advanced : APDYNAMICART::Ctrl_StringSculptures
  • _alwaysInMiddle : APGUI::ColorPicker
  • _angleFrom : osgQ::QSection
  • _angleTo : osgQ::QSection
  • _array : SampledSpline , APDYNAMICART::Line , APDYNAMICART::PatternBase , BufferedSpline
  • _arraySize : APDYNAMICART::ToolSelector
  • _artArea : APDYNAMICART::Controller
  • _attachment_ids : PhysXPlugin::Cloth
  • _attributes : vreckoUtils::MenuRoot
  • _avatarMovement : navigation::KMTracker
  • _axis : APDYNAMICART::Hoop , APDYNAMICART::ToolHook
  • _axisControl : vreckoDP_base::VRPN3DMouse
  • _b : APDYNAMICART::Ellipse
  • _baseAxis : APDYNAMICART::ToolRotation
  • _basic : APDYNAMICART::Ctrl_StringSculptures
  • _bb : osgQ::QComputeBoundShapeVisitor
  • _bDynamicActorOutputs : PhysXPlugin::BaseActor
  • _bIsLoaded : vrecko::Scene
  • _blue : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _bodyDesc : PhysXPlugin::BaseActor
  • _boundingCreated : APDYNAMICART::PerlinLines
  • _boundingSize : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _boundingUsed : APDYNAMICART::PerlinLines
  • _boundingVisible : APDYNAMICART::PerlinLines
  • _boxColorArray : APDYNAMICART::PerlinLines
  • _boxDesc : PhysXPlugin::Box
  • _boxGeode : APDYNAMICART::PerlinLines
  • _boxMaterial : APDYNAMICART::PerlinLines
  • _boxOSGState : APDYNAMICART::PerlinLines
  • _brush
: APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolBrush
, APDYNAMICART::HoopGeometry
  • _bst : APDYNAMICART::HoopGeometry
  • _buf : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • _capsuleDesc : PhysXPlugin::Capsule
  • _center : osgQ::QSection , APDYNAMICART::SnapPoint
  • _center_position : behindO::Mirror
  • _cfg_file : vrecko::ReaderWriter
  • _cfg_path : vrecko::ReaderWriter
  • _CFM : ode::DynamicScene
  • _changedBlue : APDYNAMICART::PerlinLines
  • _changedGreen : APDYNAMICART::PerlinLines
  • _changedRed : APDYNAMICART::PerlinLines
  • _closed : BufferedSpline , SampledSpline
  • _closedPattern : APDYNAMICART::Ctrl_StringSculptures
  • _clothDesc : PhysXPlugin::Cloth
  • _clothMeshDesc : PhysXPlugin::Cloth
  • _color : vreckoUtils::MenuItem , vreckoUtils::MenuSlider , ConstantColorGen
  • _colorEnd : GradientColorGen
  • _colorGen
: APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Hoop
, SweepSurfaceGeode
  • _colorGenAdapterName : APDYNAMICART::Brush
  • _colorGenFactory : APDYNAMICART::Brush
  • _colorIndex : APDYNAMICART::ColorGenAdapter
  • _colors : APDYNAMICART::ComputeThread
  • _colorStart : GradientColorGen
  • _colour : APGUI::IconColour
  • _colourActive : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourDefault : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourDisabled : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourHovered : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourPressed : APGUI::GUI_Controller , APGUI::GUI_Item
  • _component : APDYNAMICART::PS_Layer
  • _computedStrokeStartTime : APDYNAMICART::BrushStroke
  • _conf : APDYNAMICART::ComputeThread
  • _contact_count : vreckoDP_base::fsPinchGlove
  • _contact_group : ode::DynamicScene
  • _contr
: APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PolyhedraSculpture
  • _controller : APDYNAMICART::PoA , APGUI::GUI_Item
  • _controllerCoords : APDYNAMICART::PerlinLines
  • _controllerUsed : APDYNAMICART::PerlinLines
  • _coreActorDesc : PhysXPlugin::Cloth
  • _crossSection : APDYNAMICART::HoopGeometry
  • _crossSectionAdapterName : APDYNAMICART::Brush
  • _crossSectionArray : SweepSurfaceGeode
  • _crossSectionFactory : APDYNAMICART::Brush
  • _crossSectionInterpolationSteps : APDYNAMICART::Brush
  • _crossSectionSpline : APDYNAMICART::Hoop , SweepSurfaceGeode
  • _curMove : vreckoDP_base::VRPN3DMouse
  • _current_pos : base::MouseHand , base::hand
  • _current_type : vreckoDP_base::fsPinchGlove
  • _currentRotation : APDYNAMICART::Hoop
  • _currentTransform : APDYNAMICART::Hoop
  • _curRotate : vreckoDP_base::VRPN3DMouse
  • _cursor : APDYNAMICART::DATool
  • _DAAOrientation
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _DAAposition
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _daArea : APDYNAMICART::DATool , APDYNAMICART::PerlinLines
  • _daAreaOrientation : APDYNAMICART::ToolTongs
  • _daAreaPosition : APDYNAMICART::ToolTongs
  • _daAreaScale : APDYNAMICART::ToolTongs
  • _DAAScale
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _daEnvironment
: APDYNAMICART::Controller
, APDYNAMICART::DATool
, APDYNAMICART::PoA
  • _data : ode::CompositeObject
  • _debugButtonPressed : APGUI::GUI_Controller
  • _debugButtonReleased : APGUI::GUI_Controller
  • _defaultColor : APDYNAMICART::Ctrl_StringSculptures , SectorColorGen
  • _defaultPattern : APDYNAMICART::Ctrl_StringSculptures
  • _defaultPatternName : APDYNAMICART::SectorManager
  • _defaultStateActive : APGUI::GUI_Item
  • _deltaTime : APDYNAMICART::PhysXManager
  • _density
: ode::CappedCylinder
, ode::CompositeObject::Data
, ode::Cube
, ode::Sphere
  • _descripter
: PhysXPlugin::CylindricalJoint
, PhysXPlugin::DistanceJoint
, PhysXPlugin::FixedJoint
, PhysXPlugin::PointInPlaneJoint
, PhysXPlugin::PointOnLineJoint
, PhysXPlugin::PrismaticJoint
, PhysXPlugin::PulleyJoint
, PhysXPlugin::RevoluteJoint
, PhysXPlugin::SphericalJoint
  • _description : APDYNAMICART::Controller
  • _detail : APDYNAMICART::Ellipse , APDYNAMICART::ElongatedCircle
  • _diameterEnd : GradientDiameterGen
  • _diameterGen : SweepSurfaceGeode
  • _diameterGenerator : APDYNAMICART::Hoop
  • _diameters : SweepSurfaceGeode
  • _diameterStart : GradientDiameterGen
  • _diamGen : APDYNAMICART::ConstantDiamAdapter , APDYNAMICART::GradientDiamAdapter
  • _diamGenAdapterName : APDYNAMICART::Brush
  • _diamGenFactory : APDYNAMICART::Brush
  • _direction : ode::CappedCylinder , ode::CompositeObject::Data
  • _dirty
: APDYNAMICART::ComputeThread
, APDYNAMICART::HoopShape
, vreckoUtils::HighlightCallback
, ConstantColorGen
  • _dirtyScene : APDYNAMICART::Ctrl_StringSculptures
  • _disabled : APGUI::GUI_Controller
  • _display_line : base::Display
  • _dist_line() : ht::Function
  • _dist_line2() : ht::Function
  • _distance : APDYNAMICART::ElongatedCircle
  • _dl_map : vrecko::DeviceManager , vrecko::PluginManager
  • _done : APDYNAMICART::ComputeThread
  • _dynamic_object : ode::DynamicScene
  • _dynamicMenuAbility : APGUI::Menu
  • _effect : APWeather::Weather
  • _enabled_objects : ode::DynamicScene
  • _eobject : vrecko::ReaderWriter
  • _eoPtr : APLightsEditor::_Light
  • _eoSpotPtr : APLightsEditor::_Light
  • _ERP : ode::DynamicScene
  • _externalDeactivation : APGUI::Icon
  • _eye_position : behindO::Mirror
  • _fdh_geode : base::ShowFDH , base::ShowFDHModel
  • _fdh_geom : base::ShowFDH , base::ShowFDHModel
  • _fileName : PhysXPlugin::Cloth
  • _filletRadius : FilletSpline
  • _filletSteps : FilletSpline
  • _finalArrays : APDYNAMICART::Ctrl_StringSculptures
  • _first
: base::Display
, base::hand
, base::MouseHand
, base::ShowFDHModel
, behindO::AvatarManipulator
, behindO::CuttingPlane
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::Mirror
, ChessBoard
  • _firstTimeUpdate : APDYNAMICART::Ctrl_FreeHandPainting , APGUI::GUI_Controller
  • _fluidDesc : PhysXPlugin::Fluid
  • _font : APGUI::GUI_Text
  • _font_size : base::Display
  • _forceFieldDesc : PhysXPlugin::ForceField
  • _forceFieldLinearKernelDesc : PhysXPlugin::ForceField
  • _from : vreckoUtils::MenuSlider
  • _functor : osgQ::QPrimitiveShapeVisitor
  • _geode : behindO::Mirror , APDYNAMICART::Ctrl_StringSculptures
  • _geom : behindO::Mirror
  • _geometry : APDYNAMICART::PS_Face , SweepSurfaceGeode
  • _globalAbilities : APGUI::GUI_Controller
  • _globalAnchor : PhysXPlugin::BaseJoint
  • _globalAxis : PhysXPlugin::BaseJoint
  • _grab_position : base::hand , base::MouseHand
  • _grab_position2 : base::hand , base::MouseHand
  • _grab_rotation : base::hand , base::MouseHand
  • _grab_rotation2 : base::hand , base::MouseHand
  • _gravity : ode::DynamicScene
  • _green : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _group : APGUI::Icon
  • _groups : APGUI::GUI_Controller
  • _guiController
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _height
: APDYNAMICART::Rectangle
, APGUI::Slider
, osgQ::QSection
, APNature::TerrainAlgorithm
  • _hEvNuiProcessStop : vreckoDP_Kinect::Kinect
  • _highlight
: APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PS_Face
  • _highLightcallback : APDYNAMICART::BrushStroke
  • _highlighted : vreckoUtils::HighlightCallback
  • _hints : osgQ::QDrawShapeVisitor , osgQ::QPrimitiveShapeVisitor
  • _hNextSkeletonEvent : vreckoDP_Kinect::Kinect
  • _hookPosition : APDYNAMICART::ToolHook
  • _hooks : APDYNAMICART::HookManager
  • _hoop : APDYNAMICART::HookObject , APDYNAMICART::ToolSelector
  • _hoopsState : APDYNAMICART::Ctrl_StringSculptures
  • _hostname
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
  • _hThNuiProcess : vreckoDP_Kinect::Kinect
  • _icontoDeactivate : APGUI::ColorPicker
  • _ID : PhysXPlugin::BaseJoint
  • _image : behindO::MyCullCallback
  • _increment : vreckoUtils::HighlightCallback
  • _incrementVec : vreckoUtils::HighlightCallback
  • _initCurPos : APDYNAMICART::ToolRotation
  • _initialScale : APGUI::Icon
  • _initPoint : APDYNAMICART::ComputeThread
  • _innerRadius : osgQ::QSection
  • _inputConnector : vreckoDP_Kinect::Kinect
  • _inputConnectorMappings : vreckoDP_Kinect::Kinect
  • _interconnections : APGUI::GUI_Item
  • _interpolatedLines : APDYNAMICART::PerlinLines
  • _interpolationCount : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _interpolationSteps : APDYNAMICART::Brush , InterpolatedSpline
  • _interpolator : APDYNAMICART::Ctrl_StringSculptures , InterpolatedSpline
  • _invSegmentCount : RegularPolygonSpline
  • _isActive : APGUI::ColorPicker
  • _itemCaption : vreckoUtils::MenuItem
  • _itemName : vreckoUtils::MenuItem
  • _items : APGUI::Layout , vreckoUtils::MenuBase
  • _itemsMap : APGUI::GUI_Controller
  • _itemsNames : APGUI::Layout
  • _itemTransform : APGUI::GUI_Item
  • _joints : APDYNAMICART::PhysXManager
  • _label : APGUI::GUI_Item
  • _last_position
: base::hand
, base::MouseHand
, navigation::AvatarInHand
, navigation::KMTracker
  • _last_positions : base::hand , base::MouseHand
  • _last_rotation : base::hand , base::MouseHand
  • _last_signal : vreckoDP_base::fdtDataGlove
  • _lastCheckedPositions : APInputConnector::InputConnector
  • _lastDominantAxis : APDYNAMICART::ToolMagicWand
  • _lastEnd : APDYNAMICART::ToolSelector
  • _lastHandPosition : APDYNAMICART::ToolMagicWand
  • _lastIndex : BufferedSpline
  • _lastKnownOrientations : APInputConnector::InputConnector
  • _lastKnownPointedObjects : APInputConnector::InputConnector
  • _lastKnownPositions : APInputConnector::InputConnector
  • _lastPlaybackTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _lastValidPosition : APDYNAMICART::ToolBrush
  • _lastValidSamplePosition : APDYNAMICART::BrushStroke
  • _layers : APDYNAMICART::PolyhedraSculpture
  • _layouts : APGUI::GUI_Controller
  • _leadingSpline : APDYNAMICART::BrushStroke
  • _leadingSplineInterpolated : APDYNAMICART::BrushStroke
  • _leadingSplineTilting : APDYNAMICART::BrushStroke
  • _leadSpline : SweepSurfaceGeode
  • _leadSplineArray : SweepSurfaceGeode
  • _length
: APDYNAMICART::PerlinLines
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Line
, ode::CappedCylinder
, ode::CompositeObject::Data
  • _Light() : APLightsEditor::_Light
  • _lightID : APLightsEditor::_Light
  • _lim : APDYNAMICART::ComputeThread
  • _line_count : base::Display
  • _line_height : base::Display
  • _linearVelocity : APDYNAMICART::PhysXManager
  • _lineCount : APDYNAMICART::Ctrl_StringSculptures
  • _lineGeode : APDYNAMICART::PerlinLines
  • _lineGeometry : APDYNAMICART::PerlinLines
  • _lines : APDYNAMICART::PerlinLines
  • _linesColorArray : APDYNAMICART::PerlinLines
  • _linesMaterial : APDYNAMICART::PerlinLines
  • _linewidth : APDYNAMICART::PerlinLines
  • _lineWidth : APDYNAMICART::Ctrl_StringSculptures
  • _localHandDiffVec : APDYNAMICART::ToolTongs
  • _localState : behindO::MyCullCallback
  • _magnetCoords : APDYNAMICART::PerlinLines
  • _magnetCreated : APDYNAMICART::PerlinLines
  • _magnetON : APDYNAMICART::PerlinLines
  • _magnetSize : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _magnetUsed : APDYNAMICART::PerlinLines
  • _MaterialIndex : PhysXPlugin::BaseActor
  • _MaterialName : PhysXPlugin::BaseActor
  • _maximumValue : APGUI::Slider
  • _maxNunberofInputDevices : APGUI::GUI_Controller
  • _members : APGUI::ItemsGroup
  • _menuAbility
: APDYNAMICART::ToolRotation
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolSelector
  • _MenuAbility : APDYNAMICART::ToolBrush , APDYNAMICART::ToolMagicWand
  • _menuCaption : vreckoUtils::Menu
  • _menuName : vreckoUtils::Menu
  • _meshData : PhysXPlugin::Cloth
  • _minDistance : BufferedSpline , SampledSpline
  • _minimumValue : APGUI::Slider
  • _mirror_normal : behindO::Mirror
  • _mode : APDYNAMICART::Ctrl_StringSculptures
  • _models : APGUI::Icon
  • _movableModel : APGUI::Slider
  • _movableTransform : APGUI::Slider
  • _move_step_limit : PhysXPlugin::BaseActor
  • _mutex : APDYNAMICART::ComputeThread
  • _name
: PhysXPlugin::MessageNxActorWithName
, APGUI::GUI_Item
, APGUI::ItemsGroup
, APGUI::Layout
  • _newHandOrientation : APDYNAMICART::ToolTongs
  • _newHandPosition : APDYNAMICART::ToolTongs
  • _newLinesColorArray : APDYNAMICART::PerlinLines
  • _nowTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _objects_dGeomID : ode::DynamicScene
  • _observers : vreckoUtils::Observable
  • _offset : PhysXPlugin::Cloth , APDYNAMICART::HoopTrackerCallback
  • _oldValue : APGUI::Slider
  • _onlyInt : vreckoUtils::MenuSlider
  • _opacity : APDYNAMICART::PS_Layer
  • _opened : APGUI::Menu
  • _orientations : APDYNAMICART::Hoop
  • _origColors : vreckoUtils::HighlightCallback
  • _origin_pos
: vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • _originalHandposition : APDYNAMICART::ToolMagicWand , APDYNAMICART::ToolTongs
  • _originalLocalHandOrientation : APDYNAMICART::ToolTongs
  • _originalLocalHandposition : APDYNAMICART::ToolTongs
  • _originalPoAOrientation : APDYNAMICART::ToolTongs
  • _originalPoAPosition : APDYNAMICART::ToolTongs
  • _originalPoAScale : APDYNAMICART::ToolTongs
  • _originPos : vreckoDP_base::VRPN3DMouse
  • _originRot : vreckoDP_base::VRPN3DMouse
  • _oriString : APDYNAMICART::ToolTongs
  • _OSGState : APDYNAMICART::PerlinLines
  • _outerAngleAddition : osgQ::QSection
  • _outerRadius : osgQ::QSection
  • _outputMappingsWithPriorities : APInputConnector::InputConnector
  • _overZero : APDYNAMICART::ToolSelector
  • _p : APDYNAMICART::PerlinLines
  • _parameters : APDYNAMICART::PhysXManager
  • _params : APDYNAMICART::Attractor
  • _parent
: behindO::Mirror
, APDYNAMICART::HookManager
, APGUI::GUI_Item
  • _parent_inverse_rotation : base::hand , base::MouseHand
  • _parent_rotation : base::hand , base::MouseHand
  • _Particles : PhysXPlugin::Fluid
  • _patternColor : APDYNAMICART::Ctrl_StringSculptures
  • _patternMaterial : APDYNAMICART::Ctrl_StringSculptures
  • _patternsGeode : APDYNAMICART::Ctrl_StringSculptures
  • _paused : APDYNAMICART::PerlinLines
  • _pBaseDescripter : PhysXPlugin::BaseJoint
  • _pCloth : PhysXPlugin::Cloth
  • _pClothDrawable : PhysXPlugin::Cloth
  • _pClothMesh : PhysXPlugin::Cloth
  • _pFluid : PhysXPlugin::Fluid
  • _pFluidDrawable : PhysXPlugin::Fluid
  • _physicsSDK : APDYNAMICART::PhysXManager
  • _physXManager : APDYNAMICART::Ctrl_StringSculptures
  • _pickerHeight : APGUI::ColorPicker
  • _pickerRadius : APGUI::ColorPicker
  • _plane : RegularPolygonSpline , ode::DynamicScene
  • _planeDesc : PhysXPlugin::Plane
  • _playbackActive : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackIcon : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackSlider : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackType : APDYNAMICART::Ctrl_FreeHandPainting
  • _poa
: APDYNAMICART::HoopTrackerCallback
, APDYNAMICART::DATool
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
  • _poas : APDYNAMICART::Controller
  • _poasName : APDYNAMICART::Controller
  • _pointed : APDYNAMICART::PerlinLines
  • _pointedAbilities : APGUI::GUI_Controller
  • _pointedCounter : APGUI::GUI_Item
  • _pointedIndexes : APGUI::GUI_Controller
  • _pointedTime : APGUI::GUI_Controller
  • _PointerOriReqString : APDYNAMICART::ToolEraser
  • _PointerPosReqString : APDYNAMICART::ToolEraser
  • _points
: APDYNAMICART::ComputeThread
, APDYNAMICART::Hoop
, APDYNAMICART::Painted
  • _polygon_font : base::Display
  • _polyhedron : APDYNAMICART::PS_Layer
  • _port
: vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
  • _port_fd : vreckoDP_base::LHeadTracker
  • _port_name_dual : vreckoDP_base::LHeadTracker
  • _posString : APDYNAMICART::ToolTongs
  • _pPhysicsSDK : PhysXPlugin::PhysXObject
  • _pPO : PhysXPlugin::BaseActor
  • _precision : APDYNAMICART::ToolMagicWand
  • _pRemoteDebugger : PhysXPlugin::RemoteDebugger
  • _pressed : APGUI::GUI_Item
  • _pressedAbilities : APGUI::GUI_Controller
  • _pScene : PhysXPlugin::BasePhysXObject
  • _radius
: RegularPolygonSpline
, ode::CompositeObject::Data
, ode::CappedCylinder
, APDYNAMICART::ElongatedCircle
, ode::Sphere
  • _receiver : APGUI::GUI_Item
  • _receiver_ptr : vrecko::EventDispatcher::ICSBase
  • _red : APDYNAMICART::PerlinLines , APDYNAMICART::Ctrl_PerlinLines
  • _request : APDYNAMICART::PerlinLines
  • _ret_rotate : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • _ret_translate : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • _retq : ode::DynamicScene
  • _retv : ode::DynamicScene
  • _rfArray : SweepSurfaceGeode
  • _rfGenerator : SweepSurfaceGeode
  • _ropeLinks : APDYNAMICART::PhysXManager
  • _ropeRadius : APDYNAMICART::Ctrl_StringSculptures , APDYNAMICART::ToolHook
  • _ropeSegs : APDYNAMICART::PhysXManager
  • _rotate : vreckoDP_base::Ultratrak , vreckoDP_base::NestOfBirds
  • _rotateControl : vreckoDP_base::VRPN3DMouse
  • _rotateRatio : vreckoDP_base::VRPN3DMouse
  • _rotation : osgQ::QSection
  • _rotationAngles : SweepSurfaceGeode
  • _rotationFrameAdapterName : APDYNAMICART::Brush
  • _rotationFrameFactory : APDYNAMICART::Brush
  • _rotationFrameGen
: APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::RMFrameAdapter
  • _rotationInDegress : RegularPolygonSpline
  • _rps : APDYNAMICART::RegularPolygon
  • _sampledSpline : APDYNAMICART::Line , APDYNAMICART::Painted
  • _samplePoints
: APDYNAMICART::Rectangle
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::Ellipse
  • _samplesOrientations : APDYNAMICART::BrushStroke
  • _samplesPositions : APDYNAMICART::BrushStroke
  • _samplesTimeStamps : APDYNAMICART::BrushStroke
  • _scale
: APDYNAMICART::HoopTrackerCallback
, APDYNAMICART::RegularPolygon
, PhysXPlugin::Cloth
, APDYNAMICART::Rectangle
, vreckoDP_Kinect::Kinect
  • _scene : APDYNAMICART::PhysXManager
  • _scene_objects : ode::DynamicScene
  • _sculpture : APDYNAMICART::Ctrl_PolyhedraSculptures
  • _secsPerTick : vrecko::Timer
  • _sectorIndex : APDYNAMICART::ToolSelector
  • _sectorInfoList : APDYNAMICART::SectorManager
  • _sectorManager : APDYNAMICART::ToolSelector
  • _sectorMarker : APDYNAMICART::Hoop
  • _sectorNumber : APDYNAMICART::ToolSelector
  • _sectors : SectorColorGen
  • _segmentCount : RegularPolygonSpline
  • _selectEnd : APDYNAMICART::ToolSelector
  • _selectionaccumulator : APGUI::GUI_Controller
  • _selectStart : APDYNAMICART::ToolSelector
  • _sensorCount : APDYNAMICART::Ctrl_MotionVisualization
  • _sensorNumber
: vrecko::MessageSensorTransformation
, APGUI::GUI_Item
, APDYNAMICART::ToolTongs
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APGUI::Slider
, APDYNAMICART::ToolMagicWand
  • _sensorOrientation : vrecko::MessageSensorTransformation
  • _sensorPosition : vrecko::MessageSensorTransformation
  • _shape : APDYNAMICART::Hoop
  • _shapeCurve : APDYNAMICART::HoopGeometry
  • _shift : RegularPolygonSpline
  • _showControlPoints : APDYNAMICART::Ctrl_FreeHandPainting
  • _shownMenus : APGUI::GUI_Controller
  • _signal : vreckoDP_base::fsPinchGlove
  • _signal_backup : vreckoDP_base::fsPinchGlove
  • _signal_count : vreckoDP_base::fsPinchGlove
  • _signal_transf_table : vreckoDP_base::fsPinchGlove
  • _signal_type_table : vreckoDP_base::fsPinchGlove , vreckoDP_base::fdtDataGlove
  • _simulation : APDYNAMICART::Ctrl_StringSculptures
  • _simulationRunning : APDYNAMICART::PhysXManager
  • _size
: APDYNAMICART::Attractor
, ode::CompositeObject::Data
, ode::Cube
  • _sliderCaption : vreckoUtils::MenuSlider
  • _sliderName : vreckoUtils::MenuSlider
  • _smoothFactor : SmoothedSpline
  • _smoothing : vreckoDP_Kinect::Kinect
  • _smoothness : APDYNAMICART::Brush
  • _snapPointArray : APDYNAMICART::Hoop , APDYNAMICART::ToolSelector
  • _somethingChaned : APDYNAMICART::PerlinLines
  • _source : APConnectEditor::Optimalizer
  • _space : ode::DynamicScene
  • _speed : APDYNAMICART::PerlinLines , APDYNAMICART::Ctrl_PerlinLines
  • _speedControl : vreckoDP_base::VRPN3DMouse
  • _speedFactor : vreckoDP_base::VRPN3DMouse
  • _sphereDesc : PhysXPlugin::Sphere
  • _spline
: APDYNAMICART::HoopShape
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::WaveSplineAdapter
  • _start_x : base::Display
  • _start_y : base::Display
  • _startTick : vrecko::Timer
  • _StartTime : APDYNAMICART::BrushStroke
  • _state : APGUI::GUI_Item , osgQ::QDrawShapeVisitor
  • _stateMap : APDYNAMICART::PoAState
  • _staticModel : APGUI::Slider
  • _step : APGUI::Slider
  • _strokeStartTime : APDYNAMICART::ToolBrush
  • _strokeTime : APDYNAMICART::BrushStroke
  • _strRegisterPhysXObject : PhysXPlugin::UpdatablePhysXObject
  • _strScene : PhysXPlugin::BasePhysXObject
  • _subgraph : behindO::MyCullCallback , behindO::MyUpdateCallback
  • _sweepSurface : APDYNAMICART::BrushStroke , APDYNAMICART::Hoop
  • _switchActive_CoreChange : APGUI::Icon
  • _target : APConnectEditor::Optimalizer
  • _temporaryInterconnection : APGUI::ColorPicker
  • _terrain : APNature::TerrainAlgorithm
  • _text : APGUI::GUI_Text , APGUI::Slider
  • _text_geode : base::Display
  • _text_history : base::Display
  • _text_material : base::Display
  • _text_state : base::Display
  • _texts : APGUI::GUI_Item
  • _texture : behindO::Mirror , behindO::MyCullCallback
  • _texture_font : base::Display
  • _time : TimeLineSpline
  • _timeLineDecorator : APDYNAMICART::BrushStroke
  • _timer : APGUI::GUI_Controller
  • _timeStamps : APDYNAMICART::Hoop , TimeLineSpline
  • _to : vreckoUtils::MenuSlider
  • _toolBrush : APDYNAMICART::Ctrl_FreeHandPainting , APDYNAMICART::Ctrl_StringSculptures
  • _toolBrushes : APDYNAMICART::Ctrl_MotionVisualization
  • _toolEraser : APDYNAMICART::Ctrl_FreeHandPainting
  • _toolHook : APDYNAMICART::Ctrl_StringSculptures
  • _tools : APDYNAMICART::Controller
  • _toolTip : APGUI::GUI_Item
  • _toolTipShown : APGUI::GUI_Controller
  • _toolTipTime : APGUI::GUI_Controller
  • _toolTongs : APDYNAMICART::Ctrl_FreeHandPainting
  • _trans_mapp
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, vreckoDP_base::OptiTrack
  • _transformNode : APWeather::Weather
  • _translate
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, ode::CompositeObject::Data
  • _transp : base::Display
  • _trigger : APDYNAMICART::PerlinLines
  • _type
: APDYNAMICART::Controller
, ode::CompositeObject::Data
, APGUI::Icon
  • _unusedMagnetCoords : APDYNAMICART::PerlinLines
  • _updateFlag : APDYNAMICART::PoA
  • _updateVisitor : behindO::Mirror
  • _value : vreckoUtils::MenuSlider
  • _vertices : APDYNAMICART::PS_Face
  • _visuals : APDYNAMICART::PS_Layer
  • _width
: APGUI::Slider
, APDYNAMICART::Rectangle
, APNature::TerrainAlgorithm
  • _world : ode::DynamicScene
  • _worldOrigin : vreckoDP_Kinect::Kinect
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • A : grass::Triangle
  • a : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • a1pos : ChessBoard
  • A3DBird() : vreckoDP_base::A3DBird
  • ab_with_input_Use : base::hand , base::MouseHand
  • ability : vrecko::ReaderWriter::AbilityToInitialize , APObjectUtils::ConnectionViz::Connection
  • Ability() : vrecko::Ability
  • ABILITY : vrecko::EventDispatcher
  • ability_dispatcher : vrecko::EnvironmentObject , vrecko::World
  • ability_map : vrecko::AbilityDispatcher
  • ability_name_map : vrecko::AbilityDispatcher
  • abilityActivationTest() : APEditorController::EditorController
  • AbilityDispatcher() : vrecko::AbilityDispatcher
  • AbilityEditor() : APEditorQAbilities::AbilityEditor
  • AbilityMap : vrecko::AbilityDispatcher
  • AbilityMapper : vrecko::CAINFO__VER1 , APEditorController::AbilityMapper
  • abilityMapper : APEditorController::EditorController
  • abilityName : APEditorQAbilities::AbilityEditor::AllowedAbility
  • AbilityToInitialize() : vrecko::ReaderWriter::AbilityToInitialize
  • AbInitVector : vrecko::ReaderWriter
  • absolut : navigation::AvatarInHand
  • absPI : vreckoDP_base::LHeadTracker
  • absRO : vreckoDP_base::LHeadTracker
  • Abstract0LSystem() : AP_LSystem::Abstract0LSystem
  • AbstractFile() : AP_LSystem::AbstractFile
  • AbstractGenerator() : AP_LSystem::AbstractGenerator
  • AbstractInterpret() : AP_LSystem::AbstractInterpret
  • AbstractkLSystem() : AP_LSystem::AbstractkLSystem
  • AbstractLSystem() : AP_LSystem::AbstractLSystem
  • absX : vreckoDP_base::LHeadTracker
  • absY : vreckoDP_base::LHeadTracker
  • absYA : vreckoDP_base::LHeadTracker
  • absZ : vreckoDP_base::LHeadTracker
  • acc : CarSim::CarState
  • accept()
: osgQ::QSection
, osgQ::QShapeDrawable
, vreckoDP_base::KeyboardMouse
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • act : CloudVoxel
  • Act() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • act_node : vrecko::ReaderWriter
  • act_position : VirtualFixture::MarkerFactory
  • ActCollection : mv::CPlayer
  • actdir : VirtualFixture::NavSphere
  • ActDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • ActInt() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • action : APCameraMovement::CameraMovementEditor
  • activate()
: APConnectEditor::Cut
, APConnectEditor::Optimalizer
, APConnectEditor::PolygonState
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APDYNAMICART::DATool
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APDYNAMICART::PS_Layer
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AnimatorEditor
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectAdd
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SceneSave
, APEditorQAbilities::SimpleObjectMovement
, APEditorQAbilities::UseTrigger
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
, APRoomEdit::RoomEditor
, MagicWandTool
, MTCreatorTool
, SliceTool
, AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::ConnectEditor
  • ACTIVATE_INPUT : vrecko::EventDispatcher
  • activateGesture() : vreckoDP_base::fsPinchGlove
  • ActivateMove() : APCameraPath::Camera
  • activateTool()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APRoomEdit::WallGeometry
  • activationMessage : vrecko::EventDispatcher::ICS
  • active
: VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
, APDYNAMICART::DATool
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
  • active_LMD : APSpacePartitioning::SNCH_Object::LMDStore
  • activeAbilityButtonID : APEditorController::EditorController
  • activeAbilityName : APEditorController::EditorController
  • activeAbilityPointerID : APEditorController::EditorController
  • activePointerID : vrecko::ControllableAbility , APMenu::DynamicMenu
  • actLightID : APLightsEditor::Editor
  • actPointerPos : vrecko::ControllableAbility
  • actPointerPosRaw : vrecko::ControllableAbility
  • actPointerRot : vrecko::ControllableAbility
  • actPointerRotRaw : vrecko::ControllableAbility
  • actpos : VirtualFixture::NavSphere
  • actPosInPath : vrecko::ControllableAbility
  • actSelectedObjectID : vrecko::ControllableAbility
  • actSelectedPath : vrecko::ControllableAbility
  • actSelection : APEditorController::EditorController::ECPOINTERINFO , APEditorController::EditorController
  • actual_p : vreckoDP_base::LHeadTracker
  • actual_position : ChessPiece
  • actual_sensor_values : vreckoDP_base::fdtDataGlove
  • actual_string : APHUD::HUDField
  • actualColor : GradientColorGen
  • actualize() : APGUI::Layout
  • actualValue : APHUD::HUDField
  • actViewPosition : APEditorController::EditorController
  • add() : APLightsEditor::Lights
  • ADD_CHILD : vrecko::World
  • ADD_EOCHILD : vrecko::World
  • addAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • AddAddObserver() : ModelManager
  • addAndSwitchLayer() : APDYNAMICART::PolyhedraSculpture
  • AddAnimationPoint() : ArtificialWorld::SubBlockAnimation
  • addAnimatorToObject() : APObjectUtils::Animator
  • addAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
, vreckoUtils::MenuRoot
  • addBoundingPoint() : APConstrainedMovement::ConstraintArea
  • addChild() : vreckoUtils::MenuBase
  • addColor() : APDYNAMICART::colorGradient
  • addConstrainedChildID() : APConstrainedMovement::ConstraintDescription
  • addConstrainedDualPartnerID() : APConstrainedMovement::ConstraintDescription
  • addContourLoftGeometry() : AP_LSystem::LoftTurtle
  • addControlPoint() : AP_CableEditor::Cable
  • addControlPointBetweenLine() : AP_CableEditor::Cable
  • addCreatorInfoRecursive() : vrecko::ReaderWriter
  • AddDeleteObserver() : ModelManager
  • AddDelta()
: ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
, ht::VariableQuat
  • addDynamicString() : AP_LSystem::Rule
  • addEdgeAsEO() : CarSim::RoadsState
  • addEdgesAsEO() : CarSim::RoadsState
  • addEntity()
: vrecko::Scheduler
, vrecko::vThread
  • addEnvironmentObject() : vrecko::Scene
  • addEOChild() : vrecko::EnvironmentObject
  • addEventHandler()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • addField() : APHUD::HUDDisplay
  • addForceToHoop() : APDYNAMICART::PhysXManager
  • addGesture() : mv::CPlayer
  • AddGetObserver() : ModelManager
  • AddGround() : APClouds::Clouds
  • addHomomorphism()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • addHook() : APDYNAMICART::HookManager
  • addHoopActorToScene() : APDYNAMICART::PhysXManager
  • addInputOutputs()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • addInputPin() : vrecko::BaseClass
  • addItem()
: APGUI::ItemsGroup
, APGUI::Layout
  • AddItem() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • addLayer() : APDYNAMICART::PolyhedraSculpture
  • addLine() : APTextOutput::Console , LoadingConsole
  • addMarker()
: VirtualFixture::MarkerFactory
, VirtualFixture::Trace
  • addMenuItem() : APMenu::DynamicMenu
  • AddModelGeometry() : ModelManager
  • addNewPartObject() : APConnectEditor::Cut
  • AddNode() : DynamicTree< _Type >
  • AddNodeLast() : DynamicTree< _Type >
  • addNotification() : vrecko::BaseClass
  • addObject()
: vrecko::OctTree
, APShootingSimulation::ShootingSimulation
  • addObserver() : vreckoUtils::Observable
  • AddObserver() : AddObserver
  • addOuterObject() : vrecko::EventDispatcher
  • addOutputPin() : vrecko::BaseClass
  • addOutstandingText() : vrecko::Logger
  • addPartitioningObjectInterface() : vrecko::Scene
  • addPartitioningSceneInterface() : vrecko::Scene
  • AddPathPoint() : APCameraPath::Camera
  • addPoint()
: APCameraMovement::CameraPath
, APDYNAMICART::ComputeThread
  • addProbability() : AP_LSystem::RandomIndex
  • AddReference() : GeometryState , AnimatedGeometryState
  • addRequestInputPin() : vrecko::BaseClass
  • addRequestOutputPin() : vrecko::BaseClass
  • addRequiredEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • addRule()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • addSceneFileInfoIfPossible() : vrecko::ReaderWriter
  • addSector() : SectorColorGen , APDYNAMICART::SectorManager
  • addSensor() : vreckoDP_base::OptiTrack
  • AddSkybox() : APClouds::Clouds
  • addSnappingPlane() : APEditorQAbilities::ObjectMovement
  • addStaticString() : AP_LSystem::Rule
  • addSun() : APLightsEditor::Lights
  • AddSun() : APClouds::Clouds
  • addTerminatorEdges() : CarSim::RoadsState
  • addToCell() : vrecko::OctTree
  • addToNode() : vrecko::OctTree
  • AddToQueue() : Cloud
  • addToScene() : APWeather::Weather
  • addType() : AP_LSystem::AbstractFile
  • AddUpdate() : Cache , AddObserver
  • addUserData() : vrecko::EnvironmentObject
  • addUserDrawable() : PhysXPlugin::PhysXObject
  • addVectOnEnd() : mv::CGesture
  • addVerticesLeafsAndChilds() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • addView()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • AddViewPoint() : APCameraPath::Camera
  • addWall() : WGeometry::WG_Point
  • addWindow() : APHUD::HUDDisplay
  • adjoint() : gmMatrix3 , gmMatrix4
  • adjustLimits() : APDYNAMICART::Limits
  • adjustMatrices() : AP_LSystem::MovingTurtle
  • Advanced() : APDYNAMICART::Advanced
  • AffinityMask : base::_THREAD_BASIC_INFORMATION
  • AfterInitialization() : PhysXPlugin::PhysXObject
  • all_on
: VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
, VirtualFixture::NavSphere
, PHEffect
, VirtualFixture::Plane
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, VirtualFixture::ProxiBorder
, VirtualFixture::Drag
, VirtualFixture::MarkerFactory
  • AllCloudsUpdateCallBack() : AllCloudsUpdateCallBack
  • Allocate() : APNature::TerrainAlgorithm
  • allocateControlPointArray() : APFFDEditor::Grid
  • allocateEdgeArray() : APFFDEditor::Grid
  • allocateFaceArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::GeometryLoaderBase
  • allocateGeometryArray() : APFFDEditor::GeometryLoader
  • allocateSTNode()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • allocateVertexArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • allowedAbilities : APEditorQAbilities::AbilityEditor
  • alpha : ArtificialWorld::AnimationPoint
  • alphaSet : ArtificialWorld::AnimationPoint
  • alwaysSendOrientationWithPosition : navigation::KMTracker
  • ambient : base::Light
  • ambientLight : SunLight
  • amplitude
: VirtualFixture::Border
, VirtualFixture::NavSphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
  • ana : vreckoDP_base::VRPN3DMouse
  • analog : Hci
  • analog_updated : Hci
  • analyzeXMLTree() : vrecko::ReaderWriter
  • ancestor : APSpacePartitioning::VLOD
  • angle
: CarSim::JuncsEdge
, base::Rotate
, AP_LSystem::TurtleProperties
, navigation::AvatarInHand
  • angle_tolerance : APSpacePartitioning::SNCH_Object
  • angleInXZ : CarSim::InOutEdgesAttr
  • angleMultiplier : AP_LSystem::TurtleProperties
  • angleVariance : AP_LSystem::TurtleProperties
  • ANIM_1ST_VIEW : APCameraPath::Camera
  • ANIM_3RD_VIEW : APCameraPath::Camera
  • AnimAlpha : APObjectUtils::Animator
  • Animate() : APCameraPath::Camera
  • animate : APCameraPath::Camera
  • animated : APHUD::HUDField
  • AnimatedGeometryState() : AnimatedGeometryState
  • AnimatedModel() : ArtificialWorld::AnimatedModel
  • animateToPoint() : APObjectUtils::Animator
  • animating() : APCameraMovement::CameraPath
  • animation : ArtificialWorld::SubBlock
  • AnimationPoint()
: ArtificialWorld::AnimationPoint
, APObjectUtils::Animator::AnimationPoint
  • animationPoints : ArtificialWorld::SubBlockAnimation
  • animationType : ArtificialWorld::SubBlockAnimation
  • AnimationTypes : APObjectUtils::Animator
  • animator : APTextOutput::Console
  • Animator() : APObjectUtils::Animator
  • AnimatorEditor() : APEditorQAbilities::AnimatorEditor
  • AnimNodeMask : APObjectUtils::Animator
  • AnimSRT : APObjectUtils::Animator
  • append() : AP_LSystem::LongString
  • appendElementAndBoolValue() : vrecko::ReaderWriter
  • appendElementAndDoubleValue() : vrecko::ReaderWriter
  • appendElementAndFloatValue() : vrecko::ReaderWriter
  • appendElementAndIntValue() : vrecko::ReaderWriter
  • appendElementAndLongIntValue() : vrecko::ReaderWriter
  • appendElementAndMatrixValue() : vrecko::ReaderWriter
  • appendElementAndQuatValue() : vrecko::ReaderWriter
  • appendElementAndStringValue() : vrecko::ReaderWriter
  • appendElementAndVec2Value() : vrecko::ReaderWriter
  • appendElementAndVec3Value() : vrecko::ReaderWriter
  • appendElementAndVec4Value() : vrecko::ReaderWriter
  • appendType()
: AP_LSystem::ParsingException
, AP_LSystem::FileException
, AP_LSystem::LSystemException
, AP_LSystem::ConfigurationException
  • apply()
: vreckoUtils::MenuVisitor
, VirtualFixture::VibrationLabel
, VirtualFixture::Cylinder
, filter1
, VirtualFixture::AxisLock
, vreckoUtils::MenuVisitor
, VirtualFixture::Plane
, VirtualFixture::Vibration
, VirtualFixture::Cone
, osgQ::QComputeBoundShapeVisitor
, VirtualFixture::Sphere
, osgQ::QShapeVisitor
, VirtualFixture::NavSphere
, vreckoUtils::MenuVisitor
, VirtualFixture::Damper
, VirtualFixture::Box
, VirtualFixture::Drag
, VirtualFixture::Border
, VirtualFixture::VibrationLabelActivator
, filter2
, osgQ::QDrawShapeVisitor
, osgQ::QPrimitiveShapeVisitor
, VirtualFixture::Filter
, vreckoUtils::MenuVisitor
, VirtualFixture::Grid
, osgQ::QConstShapeVisitor
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
  • applyConstrainedSnapping() : APConstrainedMovement::ConstrainedObjectMovement
  • applySnapping() : APEditorQAbilities::ObjectMovement
  • applyTransformation() : APConstrainedMovement::ConstraintArea
  • arb_rotate() : gmMatrix4 , gmMatrix3
  • ArcLength() : APCameraPath::Camera
  • area : grass::Triangle
  • areAnglesComputed() : WGeometry::WG_Wall
  • areValidVertices() : WGeometry::WG_Vertices
  • arraySize : GradientColorGen , ConstantColorGen
  • asHoop() : APDYNAMICART::Ctrl_StringSculptures
  • Aspect : CloudSceneInfo
  • assign() : ConstantColorGen , gmVector3 , gmVector4 , gmMatrix3 , gmMatrix4 , gmVector2
  • assign4x4() : Arm
  • at()
: VK_NoStepInto_Namespace::DynamicArray< _Type >
, APLightsEditor::Lights
, VK_NoStepInto_Namespace::DynamicArray< _Type >
  • attenuationparam : VirtualFixture::NavSphere
  • attenuationtype : VirtualFixture::NavSphere
  • attractor : MagicWandTool , APDYNAMICART::ToolMagicWand
  • Attractor() : APDYNAMICART::Attractor
  • AttractorName() : APDYNAMICART::IComputeStrategy
  • Attribute() : vrecko::Attribute
  • attribute : vrecko::BaseClass
  • attributeLock : vrecko::BaseClass
  • AttributeMap : vrecko::BaseClass
  • attributes : APMenu::DynamicMenu
  • attributesCount()
: vrecko::DynamicAttribute
, vrecko::AttributesDescription
  • autoMoveShift : APMenu::DynamicMenu
  • autorepeat_map : vreckoDP_base::KeyboardMouse
  • autoRotationStep : APDYNAMICART::Ctrl_PerlinLines
  • autosynch() : Hci
  • av : navigation::KMTracker , navigation::AvatarInHand
  • av_pos : navigation::AvatarInHand
  • Avatar()
: base::Avatar
, VirtualFixture::Avatar
  • avatar_copy : behindO::WIM
  • avatar_grab_inverse_rotation
: behindO::HeadManipulator
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • avatar_grab_inverse_transform
: behindO::HeadManipulator
, behindO::AvatarManipulator
, behindO::Manipulator
, behindO::EyeManipulator
  • avatar_grab_pos
: behindO::HeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
, behindO::EyeManipulator
  • avatar_grab_rotation
: behindO::Manipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::AvatarManipulator
  • avatar_grab_transform
: behindO::HeadManipulator
, behindO::AvatarManipulator
, behindO::Manipulator
, behindO::EyeManipulator
  • avatar_look_at : navigation::KMTracker , navigation::AvatarInHand
  • avatar_position : navigation::KMTracker , navigation::AvatarInHand
  • avatar_up_vector : navigation::KMTracker , navigation::AvatarInHand
  • avatar_view : VirtualFixture::Avatar , base::Avatar
  • avatar_view_vector : vrecko::World
  • AvatarEyes : vrecko::World
  • AvatarInHand() : navigation::AvatarInHand
  • AvatarManipulator() : behindO::AvatarManipulator
  • AvatarMovement() : APEditorQAbilities::AvatarMovement
  • averageNormal : APSpacePartitioning::SNCH_Object_Data::VertexSNCH
  • avView : APCameraPath::Camera
  • axis : APDYNAMICART::symmetry_pair
  • AxisFrameAdapter() : APDYNAMICART::AxisFrameAdapter
  • AxisLock() : VirtualFixture::AxisLock
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • B : grass::Triangle
  • b : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • b3rdCamera : APCameraPath::Camera
  • backCarId : CarSim::EdgesCar
  • backEdgeId : CarSim::RoadsEdges
  • backgroundColor : APHUD::HUDColorProfile
  • BAD_FORMAT_handler : Hci
  • BAD_PACKET_handler : Hci
  • BAD_PASSWORD_handler : Hci
  • BAD_PORT_handler : Hci
  • BAD_VERSION_handler : Hci
  • bAllowForegroundListQueing : vrecko::EventDispatcher
  • bAllowSelectOnRelease : APMenu::DynamicMenu
  • bAnimating : APObjectUtils::Animator
  • bAnimationFile : APCameraPath::Camera
  • bApplySnapping : APEditorQAbilities::ObjectMovement
  • barycentricTest() : WGeometry::WG_Geometry
  • base1 : vreckoDP_base::LHeadTracker
  • base2 : vreckoDP_base::LHeadTracker
  • base3 : vreckoDP_base::LHeadTracker
  • BaseActor() : PhysXPlugin::BaseActor
  • BaseClass() : vrecko::BaseClass
  • baseDir : vrecko::PersistentCache
  • baseDirectory : APMenu::DynamicMenu
  • BaseJoint() : PhysXPlugin::BaseJoint
  • BasePhysXObject() : PhysXPlugin::BasePhysXObject
  • basePlaneRotation : AP_CableEditor::Cable
  • BasePriority : base::_THREAD_BASIC_INFORMATION
  • Basic() : APDYNAMICART::Basic
  • BasicPreloaderHeuristic() : BasicPreloaderHeuristic
  • bAttemptToLoadRoadsFromArtificalWorld : CarSim::RoadsState
  • bAutoRun : APCameraPath::Camera
  • BBishop : ChessBoard
  • bbox : APMenu::MenuItemNull
  • bboxDF : APSpacePartitioning::VoxelGrid_Object_Data
  • bboxSizeDF : APSpacePartitioning::VoxelGrid_Object_Data
  • bCallSFP : vrecko::BufferedFile
  • BCLoaderErrorHandler() : BCLoaderErrorHandler
  • bCloseFile : vrecko::BufferedFile
  • bCollisionCreated : APSpacePartitioning::VoxelGrid_Object_Data
  • bCollisionFree : vrecko::EnvironmentObject
  • bCollisionOccured_EventExpected : vrecko::Scene::EOIteratorHelper
  • bCollisions_NoCalculation : APObjectUtils::ObjectEffect
  • bColorize : APObjectUtils::ConnectionViz
  • bCompareExtrapolatedValue : Filter::PosNoiseRemover
  • bConfirmationEndedConnectionCreated : APMenu::MenuItem
  • bCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • bDebug : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • bDontRotate : APObjectUtils::KeepOnScreen
  • bDrawRoads : CarSim::RoadsState
  • bDynamicSpeed : APCameraPath::Camera
  • bEffectCreated : APObjectUtils::ObjectEffect
  • BeforeInitialization()
: PhysXPlugin::Fluid
, PhysXPlugin::PhysXObject
  • begin() : Hci
  • BehindObstacleExp_wT() : BehindObstacleExp_wT
  • BehindObstacleExperiment() : BehindObstacleExperiment
  • bEnableCache : vrecko::PersistentCache
  • BenchmarkWriter() : vrecko::BenchmarkWriter
  • betaSplineBasis() : gmMatrix4
  • bExisting : APEditorQAbilities::PresentAbility
  • bExtrapolateCorrectValue : Filter::PosNoiseRemover
  • bezierBasis() : gmMatrix4
  • bFileIsUTF : vrecko::BufferedFile
  • bFirstUpdate
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • bGenShortestPaths : CarSim::RoadsState
  • bgListId : vrecko::EventDispatcher
  • bGraphicsCreated : APMenu::MenuItem
  • bGridCreated : APSpacePartitioning::VoxelGrid_Object_Data
  • bGridFilled : APSpacePartitioning::VoxelGrid_Object_Data
  • bgThreadAffinityMask : vrecko::CollisionParams__ver1
  • BiDi : APObjectUtils::Animator
  • bIgnore : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • bIgnoreRotation : APEditorQAbilities::ObjectMovement
  • bindGeode() : AP_LSystem::AbstractTurtle
  • bindWord() : AP_LSystem::QueryInterpret
  • bInited : vrecko::Scene::EOIteratorHelper
  • BinomialHeap() : BinomialHeap< _NodeClass, _keyType >
  • bIntegerOnlySlider : APMenu::MenuItemSlider
  • BirthRateMax : APDYNAMICART::ParticleSystemParameters
  • BirthRateMin : APDYNAMICART::ParticleSystemParameters
  • bIsVisible : APMenu::MenuItem
  • BKing : ChessBoard
  • BKnight : ChessBoard
  • black_out_pos : ChessBoard
  • blink() : CarSim::CarExecutionUnit
  • blinkLightState : CarSim::CarState
  • bLMDValid : APSpacePartitioning::SNCH_Object::LMDStore
  • bLocalRotation : APConnectEditor::Rotation
  • BlockAttributes() : ArtificialWorld::BlockAttributes
  • BlockUpdater() : ArtificialWorld::BlockUpdater
  • bm : vrecko::Logger
  • bMainButtonPressed : APMenu::DynamicMenu
  • bMenuVisible : vrecko::ControllableAbility
  • bNewItemAdded : APTextOutput::Console
  • bObjectLocked : vrecko::Scene::EOIteratorHelper
  • body : ode::ODEObject
  • Boid() : boids::Boid
  • boids_count : boids::BoidsLogic
  • boids_position : boids::BoidsLogic
  • boids_position_output : boids::BoidsLogic
  • boids_rest_time : boids::BoidsLogic
  • boids_velocity : boids::BoidsLogic
  • boids_velocity_output : boids::BoidsLogic
  • BoidsLogic() : boids::BoidsLogic
  • BoidsPlanner() : boids::BoidsPlanner
  • bOn : Filter::PosNoiseRemover
  • bOnlyOutput : APObjectUtils::ConnectionViz
  • bOpenData : vrecko::BenchmarkWriter
  • bOpenFrame : vrecko::BenchmarkWriter
  • bOpenInfo : vrecko::BenchmarkWriter
  • bOpenMain : vrecko::BenchmarkWriter
  • bOpenMiscStats : vrecko::BenchmarkWriter
  • bOpenSettings : vrecko::BenchmarkWriter
  • Border() : VirtualFixture::Border
  • border_bvh : behindO::WIM
  • border_object : behindO::ChangeOfVisibility , behindO::WIM
  • borderXSize : LoadingConsole , APTextOutput::Console
  • borderYSize : APTextOutput::Console , LoadingConsole
  • bottom_border : behindO::HeadManipulator
  • bottomCarPosition : CarSim::CarState
  • bound_velocity : boids::BoidsLogic
  • bounding : APDYNAMICART::Ctrl_PerlinLines
  • boundingBox : APMenu::MenuItemText
  • BoundingBox : APObjectUtils::ObjectEffect
  • boundingBox : Cloud
  • boundingCreated : APDYNAMICART::Ctrl_PerlinLines
  • BoundingSphere : APObjectUtils::ObjectEffect
  • boundingSpherePosition : APSpacePartitioning::NoPartitioning_Scene::CollisionStruct , APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • boundingSphereRadius : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject , APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • boundingVisible : APDYNAMICART::Ctrl_PerlinLines
  • Box()
: PhysXPlugin::Box
, VirtualFixture::Box
  • box_size : behindO::ChangeOfVisibility
  • BPawn : ChessBoard
  • bProcessed : APEditorQAbilities::AbilityEditor::AllowedAbility
  • BQueen : ChessBoard
  • brakeLightsPath : CarSim::GeometryPartsPath
  • brakeLightState : CarSim::CarExecutionUnit
  • bRecalculateNormals : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • bRelativeToBoundingBox : APObjectUtils::KeepOnScreen
  • bRetrieved : base::MTMatrixTransform
  • bReversedWChar : vrecko::BufferedFile
  • BRICK_MOVE_EVENT : base::MouseHand
  • BRook : ChessBoard
  • Brush() : APDYNAMICART::Brush
  • BrushStroke() : APDYNAMICART::BrushStroke
  • BrushStrokeControlPoint() : APDYNAMICART::BrushStrokeControlPoint
  • bShowLeafInLevelNotReached : APObjectUtils::ObjectEffect
  • bShowLinesWhileAnim : APCameraPath::Camera
  • bShowViewLine : APCameraPath::Camera
  • bSliding : APMenu::MenuItemSlider
  • bSNCHierarchyCreated : APSpacePartitioning::SNCH_Object_Data
  • bSphereBVHierarchyCreated : APSpacePartitioning::SphereBVH_Object_Data
  • bsplineBasis() : gmMatrix4
  • bStartAnimation : APCameraPath::Camera
  • bStarting : DynamicTreeIterator< _Type >
  • bState : APEditorController::EditorController::ECPOINTERBUTTONINFO , vrecko::CABUTTONEVENT
  • bTerminateThread : vrecko::ScenePSThreadInfo
  • bTestComputation : APSpacePartitioning::PointShellVSVoxel_Object
  • bThreadInitialized : base::SystemInfo::SIThreadInfo
  • bThreadShouldTerminate : APSpacePartitioning::SP_Object_Data_Base
  • bTimeInitialized : base::SystemInfo::SIThreadInfo
  • buffer : vrecko::BufferedFileWrite , MemoryReadBuffer
  • BufferedFile() : vrecko::BufferedFile
  • BufferedFileWrite() : vrecko::BufferedFileWrite
  • BufferedSpline() : BufferedSpline
  • bufx : vreckoDP_base::fsPinchGlove
  • bufxe : vreckoDP_base::fsPinchGlove
  • buildLODTree()
: APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • BuildMenuLayouts() : APNature::TerrainAbility
  • buildPacket() : Hci
  • buildQueue() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • buildReductionLevelStructure() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • bUpdated : base::MTMatrixTransform
  • bUsedInUpdate : APObjectUtils::ConnectionViz::Connection
  • but : vreckoDP_base::VRPN3DMouse
  • button : vreckoDP_base::L3DMouse , Hci
  • button_supported : Hci
  • buttonID : APEditorController::AbilityMapper::BUTTON_MAPPING
  • buttonPress() : vreckoDP_base::KeyboardMouse
  • buttonRelease() : vreckoDP_base::KeyboardMouse
  • buttons : Hci , APEditorController::EditorController::ECPOINTERINFO
  • bVisible : vrecko::EnvironmentObject , APObjectUtils::ObjectEffectMan
  • bWritePeriodicInfo : base::SystemInfo
  • bWriting : vrecko::BenchmarkWriter
  • ByVoxels_MultiLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • ByVoxels_SingleLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • bZeroNormal : APSpacePartitioning::SNCH_Object::OneTri
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • C : grass::Triangle
  • c : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • Cable() : AP_CableEditor::Cable
  • cableColor : AP_CableEditor::Cable
  • cableControlLine : AP_CableEditor::Cable
  • CableEditor() : AP_CableEditor::CableEditor
  • cableID : AP_CableEditor::CableEditor , AP_CableEditor::Cable
  • cablePointers : AP_CableEditor::CableEditor
  • cableRadius : AP_CableEditor::Cable
  • cablesFile : AP_CableEditor::CableEditor
  • Cache() : Cache
  • cachedFileName : vrecko::PersistentCache::OpenedCacheFile
  • cachedInfo : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • cacheDir : vrecko::PersistentCache
  • CacheInfo() : CacheInfo
  • calcAnimMatrix() : APObjectUtils::Animator
  • calcD() : APSpacePartitioning::SNCH_Object::OneTri
  • calcFinalShiftFromSelectedSet() : APEditorQAbilities::ObjectMovement
  • calcFull() : Arm
  • calcJoints() : Arm
  • calcLMDHash() : APSpacePartitioning::SNCH_Object
  • calcM() : Arm
  • calcNodeBBox() : vrecko::Scene
  • calcNodeBBoxHelper() : vrecko::Scene
  • calcNormal() : APSpacePartitioning::SNCH_Object::OneTri
  • calcNothing() : Arm
  • calcParams() : Arm
  • calcStylus3DOF() : Arm
  • calcStylus6DOF() : Arm
  • calcStylusDir() : Arm
  • calcSubtreeTriangleRepresentant() : APSpacePartitioning::SNCH_Object_Data
  • calcT() : Arm
  • calcTrig() : Arm
  • CalculateBoundingBox() : Cloud
  • calculateEdgeCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgeImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgeLength()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesLength()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateGeometryProperties() : APSpacePartitioning::SNCH_Object_Data
  • calculateHash() : vrecko::EventDispatcher::StringWithHash
  • calculateNewVertexPosition() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateNormalOfPolygon()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateNormalOfPolygons()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVertexNormal() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • calculateVertexNormalAndImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVerticesNormalAndImporatance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVerticesNormals() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • calibrateDevice()
: vrecko::Device
, vreckoDP_base::fdtDataGlove
, vreckoDP_base::KeyboardMouse
  • callback : vreckoDP_base::dataT
  • callbacks : vreckoDP_base::fsPinchGlove
  • camera : LoadingConsole
  • Camera() : APCameraPath::Camera
  • camera : APHUD::HUDDisplay , APTextOutput::Console
  • camera_center : behindO::MyCullCallback
  • camera_direction : behindO::MyCullCallback
  • camera_position : behindO::MyCullCallback
  • camera_setViewMatrixAsLookAt()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • CameraMovementEditor() : APCameraMovement::CameraMovementEditor
  • CameraPath() : APCameraMovement::CameraPath
  • cameraRotation : APCameraMovement::ControlPoint
  • canBeClicked()
: APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemSlider
  • canBeExpanded() : APMenu::MenuItem
  • canBeRandom : APDYNAMICART::Parameter
  • cancel() : APDYNAMICART::ComputeThread
  • CandidatePlaneType : APEditorQAbilities::ObjectMovement
  • CANT_BEGIN_handler : Hci
  • CANT_OPEN_handler : Hci
  • capabilities : AP_LSystem::D0LSystem
  • CappedCylinder() : ode::CappedCylinder
  • Capsule() : PhysXPlugin::Capsule
  • caption : APMenu::MenuItemText
  • car : CarSim::MessageCarEdge
  • CarControlUnit() : CarSim::CarControlUnit
  • cardinalBasis() : gmMatrix4
  • carEdgeId : CarSim::CarEnvirons , CarSim::Parameters
  • CarExecutionUnit() : CarSim::CarExecutionUnit
  • carId : CarSim::Parameters , CarSim::CarEdgeData
  • carIdUnlockedEdge : CarSim::Junction
  • carLength : CarSim::CarEdgeData
  • carNextJuncRel : CarSim::CarEnvirons , CarSim::Parameters
  • CarPartsNodeCache() : CarSim::CarPartsNodeCache
  • carPartsPathNodeMap : CarSim::CarPartsNodeCache
  • carSize : CarSim::CarState
  • carState : CarSim::CarExecutionUnit
  • carsToRemove : CarSim::Remover
  • carWithoutWheelsPath : CarSim::GeometryPartsPath
  • CascadingCut() : FibonacciHeap< _NodeClass, _keyType >
  • catmullromBasis() : gmMatrix4
  • catmullRomInterpolation() : MotionTrailTriangulator
  • CAType : vrecko::CAINFO__VER1
  • cbNodeAllowed : DynamicTreeIterator< _Type >
  • cbSubTreeAllowed : DynamicTreeIterator< _Type >
  • CCollection() : mv::CCollection
  • cell_size : vrecko::OctTree
  • center
: APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, grass::Triangle
, APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • CentreObjectManipulator() : behindO::CentreObjectManipulator
  • CGesture() : mv::CGesture
  • changeAttractor() : APDYNAMICART::ToolMagicWand
  • changedInterpolation : APDYNAMICART::PerlinLines
  • changedLength : APDYNAMICART::PerlinLines
  • changedSpeed : APDYNAMICART::PerlinLines
  • ChangeOfVisibility() : behindO::ChangeOfVisibility
  • changeToStructureOccured() : APMenu::DynamicMenu
  • check_failed : vreckoDP_base::Wiimote
  • check_motion() : Arm
  • checkBckg() : Arm
  • checkBox() : vreckoDP_base::fsPinchGlove
  • checkConnection() : vreckoDP_base::fsPinchGlove
  • checkDiff() : vreckoDP_base::LHeadTracker
  • checkEdgesFromToAndTheirPolygonPoints() : CarSim::RoadsState
  • checkGesture() : vreckoDP_base::fsPinchGlove
  • checkHookDeleteRequest() : APDYNAMICART::Ctrl_StringSculptures
  • checkInputXMLParameters() : CarSim::CarControlUnit
  • checkInterconnection() : vrecko::EventDispatcher
  • checkLocation() : BehindObstacleExp_wT , BehindObstacleExperiment
  • checkPacket() : Hci
  • checkPoADeleteRequest() : APDYNAMICART::Ctrl_StringSculptures
  • checkXMLparameters() : CarSim::CarExecutionUnit
  • chess_pipe : ChessBoard
  • ChessBoard() : ChessBoard
  • chessboard_id : ChessPiece
  • ChessPiece() : ChessPiece
  • child
: BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
, FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
, ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • child_nodes : vrecko::OctTree::OctTreeNode
  • childMenuAnimator : APMenu::MenuItem
  • childMenuObject : APMenu::MenuItem
  • childs : APSpacePartitioning::VLOD
  • chooseBoundaryLoop() : SnapObject
  • clamp() : gmVector2 , gmVector3 , gmVector4
  • classDescription() : APDYNAMICART::PoAAdapter< T > , Interpolator
  • className()
: APDYNAMICART::PoAAdapter< T >
, osgQ::QSection
, grass::GrassDrawable
, Interpolator
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • cld : CloudVoxel
  • clean()
: vrecko::Ability
, AP_LSystem::TurtleProperties
, APObjectUtils::Animator
, APObjectUtils::ConnectionViz
, APObjectUtils::KeepOnScreen
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
  • cleanVertexEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • clear()
: VK_NoStepInto_Namespace::DynamicArray< _Type >
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, AP_LSystem::TurtleStack
, MemoryWriteBuffer
  • Clear() : DynamicTree< _Type > , APCameraPath::Camera , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • clearAllPoAs() : APDYNAMICART::Controller
  • ClearAnimation() : ArtificialWorld::SubBlockAnimation
  • ClearAnimationPoints() : ArtificialWorld::SubBlockAnimation
  • clearFreshDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • ClearHardSeparator() : WAVEFRONT::InPlaceParser
  • clearPacket() : Hci
  • clearSpheres() : AP_CableEditor::Cable
  • clearValue() : APHUD::HUDDisplay
  • clicked()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, Icon
, APDYNAMICART::PoB
  • ClientId : base::_THREAD_BASIC_INFORMATION
  • clipNode
: APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APDYNAMICART::ToolSlice
, SliceTool
  • clipnode : behindO::CuttingPlane
  • clipnodeSS : behindO::CuttingPlane
  • clone()
: APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, AP_LSystem::AbstractLSystem
, AP_LSystem::D0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParStoch0LSystem
, osgQ::QSection
, grass::GrassDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • cloneType()
: osgQ::QSection
, grass::GrassDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • close()
: vrecko::BufferedFile
, vrecko::BufferedFileWrite
  • closeCacheFile() : vrecko::PersistentCache
  • closed : CatmullRomInterpolator , LinearInterpolator
  • closeDevice()
: vrecko::Device
, vreckoDP_base::fdtDataGlove
, vreckoDP_base::fsPinchGlove
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
  • closeFeatures : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • closeFile() : vrecko::BenchmarkWriter
  • closeLoop() : APConnectEditor::Cut
  • closeSerial() : Serial
  • Cloth : PhysXPlugin::ClothDrawable , PhysXPlugin::Cloth
  • ClothDrawable() : PhysXPlugin::ClothDrawable
  • Cloud() : Cloud
  • Cloud::SetViewMatrix() : AllCloudsUpdateCallBack
  • cloudData : AllCloudsUpdateCallBack
  • CloudFlatAreaPosition : CloudsProperties
  • CloudFlatAreaSize : CloudsProperties
  • CloudGrowth : CloudsProperties
  • CloudGrowthRand : CloudsProperties
  • cloudParticle : Cloud
  • clouds : CloudsManager
  • Clouds() : APClouds::Clouds
  • CloudsManager() : CloudsManager
  • cmd_byte : packet_rec
  • CMVect() : mv::CMVect
  • cntAngle : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • cntNodes : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • cntRadius : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • CoatWithGrass() : grass::Grass
  • coef1 : Filter::Linear
  • coef2 : Filter::Linear
  • coef3 : Filter::Linear
  • coef4 : Filter::Linear
  • colInfo : APObjectUtils::ObjectEffect
  • collapseItem() : APMenu::DynamicMenu
  • collapseSiblings() : APMenu::DynamicMenu
  • collisionField : APSpacePartitioning::NoPartitioning_Scene
  • CollisionInfo() : vrecko::CollisionInfo
  • collisionNormal : PhysXPlugin::Particle
  • collisionObjects : APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • CollisionParams__ver1() : vrecko::CollisionParams__ver1
  • Collisions : APObjectUtils::ObjectEffect
  • collisions : APSpacePartitioning::PointShell_SimpleNode
  • collisionsMax : APSpacePartitioning::PointShell_Object_Data
  • collisionsTotal : APSpacePartitioning::PointShell_Object_Data
  • collisiontime1 : APSpacePartitioning::PointShellVSVoxel_Object
  • collisiontime2 : APSpacePartitioning::PointShellVSVoxel_Object
  • color
: Sector
, APEditorQAbilities::ObjectMovement::SnapBox
, ChessBoard
, APHUD::HUDField
, APHUD::HUDWindow
, APMenu::MenuItem
, Particle
, APObjectUtils::ObjectEffect
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • color2
: VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • colorablePartName : Icon
  • ColorBucket() : APRoomEdit::ColorBucket
  • colorChanged() : APDYNAMICART::OrdinaryAttractor
  • ColorGenAdapter() : APDYNAMICART::ColorGenAdapter
  • ColorGenFactory() : APDYNAMICART::ColorGenFactory
  • Colorize : APObjectUtils::ObjectEffect
  • ColorizeOnTop : APObjectUtils::ObjectEffect
  • colorMax : APHUD::HUDField
  • colorMin : APHUD::HUDField
  • ColorPicker() : APGUI::ColorPicker
  • comment : Hci
  • comNorm : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt , APSpacePartitioning::VLOD
  • comParams() : Hci
  • comparator() : RealCmp< T >
  • compareEQ() : RealCmp< T >
  • compareGT() : RealCmp< T >
  • compareGTEQ() : RealCmp< T >
  • compareLT() : RealCmp< T >
  • compareLTEQ() : RealCmp< T >
  • compareObjectPosition() : APConstrainedMovement::ConstrainedObjectMovement
  • compareObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • compareObjectRotation() : APConstrainedMovement::ConstrainedObjectMovement
  • compileAbilityMapping() : APEditorController::EditorController
  • complexJunc : CarSim::Junction
  • comPos : APSpacePartitioning::VLOD
  • CompositeObject() : ode::CompositeObject
  • CompositeViewer() : vrecko::CompositeViewer
  • compute()
: APDYNAMICART::Attractor
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::NullAttractor
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PatternBase
  • compute2DNormal() : SweepSurfaceGeode
  • compute2DNormals() : SweepSurfaceGeode
  • computeAttrNormals() : WGeometry::WG_Wall
  • computeAttrVectorsAndAngles() : WGeometry::WG_Wall
  • computeAttrVertices() : WGeometry::WG_Wall
  • computeBBoxShereRadius() : APSpacePartitioning::PointShell_Object_Data
  • computeBBoxSheresRadius() : APSpacePartitioning::PointShell_Object_Data
  • computeBound()
: osgQ::QShapeDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • computeCarState() : CarSim::CarExecutionUnit
  • computeEdgesAttributes() : CarSim::RoadsState
  • ComputeForce() : mv::CPlayer
  • computeHoleVertices() : WGeometry::WG_Wall
  • computeJuncInOutEdgesAttr() : CarSim::RoadsState
  • computeJunctionsEdges() : CarSim::RoadsState
  • computeNumberOfSegments() : osgQ::QSection
  • ComputePath() : APCameraPath::Camera
  • computeRadiusOfBoundingSpheres() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • computeRecVelocityOnJunc() : CarSim::RoadsState
  • computeRecVelOnFstJunc() : CarSim::CarControlUnit
  • computeRMF() : AP_CableEditor::Cable
  • computeRotationMatrix() : osgQ::QSection
  • computeShortestPath() : CarSim::CarControlUnit
  • computeSNCH() : APSpacePartitioning::SNCH_Object_Data
  • ComputeSpline() : APCameraPath::Camera
  • ComputeThread() : APDYNAMICART::ComputeThread
  • computeTimeLast : APSpacePartitioning::NoPartitioning_Scene
  • computeTimeNew : APSpacePartitioning::NoPartitioning_Scene
  • ComputeUpRightVectors() : Cloud
  • computeVertexLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • condition : AP_LSystem::Rule
  • conditionalMessage : vrecko::EventDispatcher::ICS
  • Cone() : VirtualFixture::Cone
  • cone_axis : APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
  • ConeIntersection : APSpacePartitioning::SNCH_Object
  • ConfigurationException() : AP_LSystem::ConfigurationException
  • confirmAnimationEnded() : APMenu::DynamicMenu
  • connect() : Arm , Hci
  • connectDevice() : vrecko::DeviceManager
  • ConnectEditor() : APConnectEditor::ConnectEditor
  • connection : vreckoDP_base::OptiTrack
  • connectionName : vreckoDP_base::OptiTrack
  • ConnectionType : APObjectUtils::ConnectionViz::Connection
  • ConnectionViz() : APObjectUtils::ConnectionViz
  • cons : APObjectUtils::ConnectionViz
  • Console() : APTextOutput::Console
  • Consolidate() : FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • const_d : navigation::AvatarInHand
  • constantAttenuation : base::Light
  • ConstantColorAdapter() : APDYNAMICART::ConstantColorAdapter
  • ConstantColorGen() : ConstantColorGen
  • ConstantDiamAdapter() : APDYNAMICART::ConstantDiamAdapter
  • ConstrainedObjectMovement() : APConstrainedMovement::ConstrainedObjectMovement
  • ConstraintArea() : APConstrainedMovement::ConstraintArea
  • ConstraintArea::distanceFactorToArea() : APConstrainedMovement::ConstraintArea
  • ConstraintDescription() : APConstrainedMovement::ConstraintDescription
  • ConstraintHierarchyMember() : ConstraintHierarchyMember
  • constraintHierarchyRoot : APConstrainedMovement::ConstrainedObjectMovement
  • constructCacheDataName()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • constructModelDataName() : vrecko::PersistentCache
  • constructPointShellCacheDataName() : APSpacePartitioning::PointShell_Object_Data
  • constructPointShellSubdividedMeshDataName() : APSpacePartitioning::PointShell_Object_Data
  • constructTree() : APSpacePartitioning::SphereBVH_Object_Data
  • ContactObjectManipulator() : behindO::ContactObjectManipulator
  • ContainsAnimatedModelGeometry() : ModelManager
  • containsAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • ContainsModelGeometry() : ModelManager
  • containsValue() : vrecko::Enumeration< tval, tref >
  • continuous_selection : behindO::ChangeOfVisibility
  • contour : AP_LSystem::TurtleProperties
  • contourDetail : AP_LSystem::TurtleProperties
  • contourLastN : AP_LSystem::TurtleProperties
  • contourLastV : AP_LSystem::TurtleProperties
  • control
: behindO::Manipulator
, behindO::CentreObjectManipulator
, behindO::AvatarManipulator
, behindO::ChangeOfVisibility
, behindO::CuttingPlane
, behindO::EyeManipulator
, behindO::WIM
  • ControllableAbility() : vrecko::ControllableAbility
  • controller : APDYNAMICART::ToolMagicWand
  • Controller() : APDYNAMICART::Controller
  • controller : MagicWandTool
  • controlPoint : AP_LSystem::TurtleProperties
  • controlPoint_count : APFFDEditor::Grid
  • controlPoints : AP_CableEditor::Cable , APFFDEditor::Grid
  • controlPointsChange : AP_CableEditor::Cable
  • ControlPosition() : mv::CPlayer
  • controlSpheres : AP_CableEditor::Cable
  • ControlSpheresColor() : AP_CableEditor::Cable
  • controlSpheresColor : AP_CableEditor::Cable
  • controlSpheresRadiusAdjust : AP_CableEditor::Cable
  • controlSystem : CarSim::Junction
  • controlVectors : AP_CableEditor::Cable
  • convertActPosToNormPos() : APObjectUtils::Animator
  • convertActTimeToActPos()
: APCameraMovement::CameraPath
, APObjectUtils::Animator
  • convertExtParams() : Arm
  • convertFromString() : AP_LSystem::LongString
  • convertInt() : APDYNAMICART::Utils
  • convertParams() : Arm
  • convertString() : APDYNAMICART::Utils
  • conViz : APEditorQAbilities::AbilityEditor
  • copies_map : behindO::WIM
  • copies_root : behindO::WIM
  • copy : behindO::WIM::ObjectCopy
  • CopyFrom() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • CopyProperties() : APObjectUtils::CopyProperties
  • copyTo() : gmVector4 , gmMatrix3 , gmVector2 , gmMatrix3 , gmVector2 , gmVector3 , gmVector4 , gmMatrix4
  • CoreActorDesc() : PhysXPlugin::CoreActorDesc
  • coreHierarchyCreation()
: APSpacePartitioning::SP_Object_Data_Base
, APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::SNCH_Object_Data
  • coreInit()
: vrecko::InputPin< _MessageType >
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • Corner : ht::ScreenSetup
  • correctName() : APHUD::HUDDisplay
  • cost : APSpacePartitioning::ELOD
  • Count() : GeometryState , AnimatedGeometryState
  • counter : Sector , vrecko::PyAbility
  • countersActiveIndex : vrecko::Logger
  • countersActiveLock : vrecko::Logger
  • countOfCP : APFFDEditor::Grid
  • CPlayer() : mv::CPlayer
  • cProfiles : APHUD::HUDDisplay
  • CPscale() : APFFDEditor::EditorLogic
  • CPscaling : APFFDEditor::Grid
  • CPsize : APFFDEditor::EditorLogic
  • Create()
: PhysXPlugin::Capsule
, PhysXPlugin::Cloth
, PhysXPlugin::CoreActorDesc
, PhysXPlugin::ForceField
, PhysXPlugin::Sphere
, PhysXPlugin::BaseJoint
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::Fluid
  • create() : LoadingConsole
  • Create()
: PhysXPlugin::Plane
, PhysXPlugin::Box
, vrecko::MaterialDesc
, PhysXPlugin::MaterialManager
, PhysXPlugin::BaseActor
  • createAbility() : vrecko::World
  • createAbilityMapper() : APEditorController::EditorController
  • createActor() : APDYNAMICART::Hoop
  • createBorder() : behindO::ChangeOfVisibility
  • createBuffer() : APLightsEditor::Lights
  • createCapsule() : APDYNAMICART::PhysXManager
  • createCircle() : AP_CableEditor::CableEditor
  • createCircleContour() : AP_LSystem::LoftTurtle
  • createCircleSide() : APDYNAMICART::ElongatedCircle
  • createCollisionHierarchy() : vrecko::EnvironmentObject
  • createColorSphere() : APGUI::ColorPicker
  • createColorSubMenu() : APDYNAMICART::Ctrl_Attractor
  • createCompatibleMessage()
: vrecko::OutputPin< _MessageType >
, vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
, vrecko::InputPin< _MessageType >
, vrecko::IOPinBase
  • createConnection() : APObjectUtils::ConnectionViz
  • createConnectionViz() : APEditorQAbilities::AbilityEditor
  • CreateCurs2ViewPts() : APCameraPath::Camera
  • createCursor() : APDYNAMICART::DATool
  • createDATool() : APDYNAMICART::Utils
  • createDefaultRoom() : APRoomEdit::WallGeometry
  • createDistanceFieldGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDistanceFieldGridCollision() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDistanceFieldTempGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDrawableObject() : SweepSurfaceGeode
  • createEdgeGroups() : APSpacePartitioning::SNCH_Object_Data
  • createEffect() : APObjectUtils::ObjectEffect
  • createEffect_Lines() : APObjectUtils::ObjectEffect
  • createEffect_PointShellHierarchy_ProcessLevel() : APObjectUtils::ObjectEffect
  • createEffect_Reconstruction() : APObjectUtils::ObjectEffect
  • createEffect_SphereHierarchy_ProcessLevel() : APObjectUtils::ObjectEffect
  • createEffect_VoxelGrid() : APObjectUtils::ObjectEffect
  • createElement() : vrecko::ReaderWriter
  • createEoAbility() : AP_CableEditor::CableEditor
  • createFaceGroups() : APSpacePartitioning::SNCH_Object_Data
  • createFacePlanes() : APDYNAMICART::PS_Polyhedron
  • createFlare() : APLightsEditor::Lights
  • createGeodes() : AP_LSystem::AbstractInterpret
  • createGeometry()
: APGUI::Slider
, APDYNAMICART::HoopGeometry
  • createGraph() : SnapObject
  • createGraphics() : APMenu::MenuItem
  • createGraphicsCore()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, APMenu::MenuItemNull
  • createGrid() : APFFDEditor::Grid
  • createHierarchy() : APSpacePartitioning::VoxelGrid_Object_Data
  • CreateHole() : APRoomEdit::CreateHole
  • createInfo()
: APEditorQAbilities::ObjectMovement
, vrecko::ControllableAbility
, APConstrainedMovement::ConstrainedObjectMovement
  • createInstance() : APDYNAMICART::Attractor
  • createInterface()
: vrecko::ControllableAbility
, APEditorController::AbilityMapper
  • createLODHierarchy() : APSpacePartitioning::PointShell_Object_Data
  • createLoftGeometryOpening() : AP_LSystem::LoftTurtle
  • createLSystem() : AP_LSystem::AbstractGenerator
  • createMag() : APDYNAMICART::Ctrl_PerlinLines
  • createMagnet() : APDYNAMICART::PerlinLines
  • createMainObject() : APObjectUtils::ConnectionViz
  • createMainObjects() : APMenu::DynamicMenu
  • createMenu()
: APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::WaveSplineAdapter
, vrecko::ControllableAbility
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::Brush
, APDYNAMICART::HoopShape
, APDYNAMICART::ConstantDiamAdapter
  • CreateMenuAbilities() : APDYNAMICART::ToolBrush
  • createMenuAbilities() : APDYNAMICART::ToolMagicWand
  • CreateMenuAbilities() : APDYNAMICART::DAEnvironment
  • createMenuFromNode() : APMenu::DynamicMenu
  • createMenuFromString() : APMenu::DynamicMenu
  • createMenuItem() : vreckoUtils::MenuCommon
  • createMenuSlider() : vreckoUtils::MenuCommon
  • createMenuStructure()
: APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::PerlinLines
, APDYNAMICART::ToolRotation
, APDYNAMICART::Ctrl_PerlinLines
  • CreateMenuStructure() : APNature::TerrainAbility
  • createMenuStructure()
: APDYNAMICART::Attractor
, APDYNAMICART::ToolSelector
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PoA
, APDYNAMICART::HookObject
, APDYNAMICART::NullAttractor
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Controller
, APDYNAMICART::Hoop
  • createModel() : APMenu::MenuItemText
  • createModels()
: APGUI::Slider
, APGUI::Icon
  • createMultiLevel() : APSpacePartitioning::PointShell_Object_Data
  • createMutex() : vrecko::vThread
  • createNewCuttingLoop() : APConnectEditor::Cut
  • createNewItem()
: APMenu::MenuItemSlider
, APMenu::MenuItemText
, APMenu::MenuItemNull
, APMenu::MenuItem
  • createNewObject() : APEditorQAbilities::ObjectAdd
  • createNewPolyhedraMenu() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • createNewShowHideMenu() : APDYNAMICART::PolyhedraSculpture
  • createObjectEffect() : APObjectUtils::ObjectEffectMan
  • createParameterSubMenu() : APDYNAMICART::Attractor
  • createParser() : vrecko::ReaderWriter
  • createPoA()
: APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
  • CreatePoA() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • createPoA()
: APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Ctrl_MotionVisualization
  • createPointerTrail() : APMenu::DynamicMenu
  • CreatePreloader() : Cache
  • createReturningCompatibleMessage()
: vrecko::IORequestPinBase
, vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • createRope() : APDYNAMICART::PhysXManager
  • createRopeSphericalJoint() : APDYNAMICART::PhysXManager
  • createScene() : APDYNAMICART::PhysXManager
  • createScenes() : BehindObstacleExp_wT , BehindObstacleExperiment
  • createSimple() : APSpacePartitioning::PointShell_Object_Data
  • createSimpleGraph() : SnapObject
  • createSingleLevel() : APSpacePartitioning::PointShell_Object_Data
  • createSphere() : AP_CableEditor::Cable
  • createSpheres() : AP_CableEditor::Cable
  • createTrafficLights() : CarSim::RoadsState
  • createTreeFromGeometry() : APSpacePartitioning::SphereBVH_Object_Data
  • createVisuals() : APGUI::ColorPicker
  • CreationType : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • creationType : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • cross : gmVector3
  • crossSectionGenerator : APDYNAMICART::Configuration
  • crossSectionSize : GradientColorGen
  • Ctrl_Attractor() : APDYNAMICART::Ctrl_Attractor
  • Ctrl_FreeHandPainting() : APDYNAMICART::Ctrl_FreeHandPainting
  • Ctrl_MotionVisualization() : APDYNAMICART::Ctrl_MotionVisualization
  • Ctrl_PerlinLines() : APDYNAMICART::Ctrl_PerlinLines
  • Ctrl_PolyhedraSculptures() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • Ctrl_StringSculptures() : APDYNAMICART::Ctrl_StringSculptures
  • ctrTimeLast : APSpacePartitioning::NoPartitioning_Scene
  • ctrTimeNew : APSpacePartitioning::NoPartitioning_Scene
  • Cube() : ode::Cube
  • CubicInterpolator() : CubicInterpolator
  • current_method : BehindObstacleExp_wT , BehindObstacleExperiment
  • current_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • current_transform : base::hand , base::MouseHand
  • current_waypoint : boids::BoidsPlanner
  • currentObjectIndex : vrecko::Scene::EOIteratorHelper
  • currentSize : MemoryWriteBuffer
  • cursor_shift : base::Avatar
  • curveDetail : AP_LSystem::TurtleProperties
  • Cut() : APConnectEditor::Cut , FibonacciHeap< _NodeClass, _keyType >
  • cutObject() : APConnectEditor::Cut
  • cutting_object : behindO::CuttingPlane
  • cutting_plane_transformation : behindO::CuttingPlane
  • cuttingLoop : APConnectEditor::Cut
  • CuttingPlane() : behindO::CuttingPlane
  • Cylinder() : VirtualFixture::Cylinder
  • CylindricalJoint() : PhysXPlugin::CylindricalJoint
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • D0LSystem() : AP_LSystem::D0LSystem
  • DAAOrientation : MTCreatorTool
  • DAAposition : MTCreatorTool
  • DAArea : APDYNAMICART::PLNestTool , SliceTool , APDYNAMICART::PLMagnetTool , APDYNAMICART::PLControllerTool , MTCreatorTool
  • DAAScale : MTCreatorTool
  • DAControlPoint() : DAControlPoint
  • DAEnvironment() : APDYNAMICART::DAEnvironment
  • DAGizmo() : APDYNAMICART::DAGizmo , DAGizmo
  • Damper() : VirtualFixture::Damper
  • danger : boids::BoidsLogic
  • danger_factor : boids::BoidsLogic
  • DASample() : DASample
  • data
: CarSim::MessageCarEdgeData
, CarSim::MessageVectorUnsignedInt
, CarSim::MessageStartStopDestination
, CarSim::MessageFirst3Juncs
, CarSim::MessageCarSimParameters
, CarSim::MessageCarEnvirons
, CarSim::MessageCarStatePtr
, APEditorController::AbilityMapper::MessageMapping
, vrecko::MessageCAButtonEvent
, vrecko::ControllableAbility::MessageCAINFO
, vreckoDP_base::dataT
, packet_rec
, MemoryWriteBuffer
  • data_ptr : packet_rec
  • dataPath : CarSim::RoadsState
  • DataType : vrecko::Attribute
  • DATool() : APDYNAMICART::DATool
  • deactivate()
: APLightsEditor::Editor
, APRoomEdit::RoomEditor
, MagicWandTool
, MTCreatorTool
, SliceTool
, AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::ConnectEditor
, APConnectEditor::Cut
, APConnectEditor::Optimalizer
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APDYNAMICART::DATool
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APDYNAMICART::PS_Layer
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
, APEditorQAbilities::UseTrigger
  • deactivateGesture() : vreckoDP_base::fsPinchGlove
  • DeactivateMove() : APCameraPath::Camera
  • deactivateTool()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APRoomEdit::WallGeometry
  • deallocateControlPointArray() : APFFDEditor::Grid
  • deallocateEdgeArray() : APFFDEditor::Grid
  • deallocateFaceArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • deallocateGeometryArray() : APFFDEditor::GeometryLoader
  • deallocateVertexArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • debugFileLog()
: vrecko::Logger
, vrecko::World
  • debugFlush() : vrecko::Logger
  • debugGeometryScale : AP_LSystem::TurtleProperties
  • debugGlobalUpdatesCounter : vrecko::CollisionParams__ver1
  • debugKeyPressed()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
  • DebugLevelStats() : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • debugLog()
: vrecko::Logger
, vrecko::World
  • debugPrintInterconnectionMap() : vrecko::EventDispatcher
  • debugPrintRequestMap() : vrecko::EventDispatcher
  • DebugStats() : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • debugWriteNormals()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • DECLARE_INPUT()
: boids::Boid
, boids::BoidsLogic
, boids::BoidsPlanner
, CarSim::CarExecutionUnit
, CarSim::Remover
, CarSim::RoadsState
, APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Hoop
, APDYNAMICART::PoA
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorController::EditorController
, Filter::PosNoiseRemover
, APGUI::ColorPicker
, APGUI::GUI_Controller
, APGUI::Menu
, APGUI::Slider
, ht::HeadTracking
, ht::ScreenSetup
, ht::ScreenSetupSimple
, APMenu::DynamicMenu
, APObjectUtils::Animator
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
, base::Avatar
, APObjectUtils::ObjectModif
, APObjectUtils::ObjectSelector
, base::Avatar
, APObjectUtils::UseToEvent
, APShootingSimulation::ShootingSimulation
, base::Avatar
, APShootingSimulation::ShootingSimulation
, base::Avatar
, APShootingSimulation::ShootingSimulation
, vreckoDP_base::OptiTrack
, base::Avatar
, vreckoDP_base::Wiimote
, PhysXPlugin::BaseActor
, base::Avatar
, PhysXPlugin::BaseActor
, base::Avatar
, PhysXPlugin::BaseActor
, base::Avatar
, base::hand
, base::Light
, base::MouseHand
, base::SystemInfo
, vrecko::EnvironmentObject
  • DECLARE_OUTPUT()
: APInputConnector::InputConnector
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, APMenu::DynamicMenu
, navigation::AvatarInHand
, navigation::KMTracker
, APObjectUtils::Animator
, APObjectUtils::ObjectInfo
, APObjectUtils::ObjectSelector
, APObjectUtils::UseToEvent
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
, PhysXPlugin::BaseActor
, base::hand
, base::MouseHand
, boids::BoidsLogic
, boids::BoidsPlanner
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APEditorController::AbilityMapper
, APEditorController::EditorController
, Filter::PosNoiseRemover
, APGUI::ColorPicker
, APGUI::Icon
, APGUI::IconColour
, APGUI::Menu
, APGUI::Slider
, ht::HeadTracking
, APInputConnector::InputConnector
  • DECLARE_REQUEST_INPUT()
: base::MTMatrixTransform
, CarSim::CarExecutionUnit
, CarSim::CarPartsNodeCache
, vrecko::ControllableAbility
, CarSim::RoadsState
, vrecko::ControllableAbility
, APEditorController::EditorController
, APGUI::GUI_Controller
, APInputConnector::InputConnector
, APMenu::DynamicMenu
, APObjectUtils::ObjectSelector
, ode::DynamicScene
, APTextOutput::Console
, PhysXPlugin::PhysXScene
, APGUI::ColorPicker
, APInputConnector::InputConnector
, APGUI::GUI_Controller
  • DECLARE_REQUEST_OUTPUT()
: PhysXPlugin::BaseJoint
, ode::Cube
, APMenu::DynamicMenu
, vrecko::ControllableAbility
, APDYNAMICART::ToolSelector
, APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolTongs
, vrecko::ControllableAbility
, APEditorController::EditorController
, APGUI::ColorPicker
, APGUI::GUI_Controller
, APGUI::Menu
, APGUI::Slider
, APInputConnector::InputConnector
, APObjectUtils::ObjectModif
, ode::CappedCylinder
, ode::CompositeObject
, ode::Sphere
, PhysXPlugin::BaseActor
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::UpdatablePhysXObject
, APDYNAMICART::ToolEraser
  • Decomposition_vec : vrecko::EventDispatcher
  • DecreaseKey() : GenericHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • decreaseLockCountForPrevEdge() : CarSim::RoadsState
  • default_handler : Hci
  • default_request_interconnection_map : vrecko::EventDispatcher
  • defaultInfo : vrecko::ControllableAbility
  • defaultState : Icon
  • DefaultSymbols() : WAVEFRONT::InPlaceParser
  • definedcolorprofiles : APHUD::HUDDisplay
  • defstring : VirtualFixture::AxisLock
  • degree : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode , FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • DEGREES_TO_RADIANS : AP_LSystem::TurtleProperties
  • delAllGestures() : mv::CPlayer
  • delAllVect() : mv::CGesture
  • delay()
: vreckoDP_base::fsPinchGlove
, vreckoDP_base::LHeadTracker
  • Delete() : Cloud , GenericHeap< _NodeClass, _keyType > , VK_NoStepInto_Namespace::DynamicArray< _Type > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , CloudsManager
  • DELETE_STATESET : vrecko::World
  • deleteActor() : APDYNAMICART::Hoop
  • DeleteAll() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DeleteAnimatedModelGeometry() : ModelManager
  • DeleteAnimation() : ArtificialWorld::SubBlock
  • deleteAttribute() : vrecko::BaseClass
  • deleteConnection() : APObjectUtils::ConnectionViz
  • deleteEventInterconnection() : vrecko::EventDispatcher
  • deleteFromScene() : SnapObject
  • deleteMenuItem() : APMenu::DynamicMenu
  • DeleteModelGeometry() : ModelManager
  • DeleteNode() : DynamicTree< _Type >
  • deleteObjectEffect() : APObjectUtils::ObjectEffectMan
  • DeleteObserver() : DeleteObserver
  • DeletePoint() : APCameraPath::Camera
  • DeletePreloader() : Cache
  • DeleteUnnecessary() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DeleteUpdate() : Cache , DeleteObserver
  • delFromCell() : vrecko::OctTree
  • delFromNode() : vrecko::OctTree
  • delGesture() : mv::CPlayer
  • delta_m() : vrecko::Timer
  • delta_n() : vrecko::Timer
  • delta_s() : vrecko::Timer
  • delta_u() : vrecko::Timer
  • delta_z : behindO::HeadManipulator
  • delVectOnEnd() : mv::CGesture
  • demandReport() : vreckoDP_base::LHeadTracker
  • density : grass::GrassAbilityParameters , PhysXPlugin::Particle
  • deprecated_version : vreckoDP_base::OptiTrack
  • depth : APObjectUtils::KeepOnScreen
  • derivedCRI() : MotionTrailTriangulator
  • describtion : VirtualFixture::Marker
  • description
: vrecko::World
, vrecko::Ability::ParameterStruct
, vrecko::Scene
  • destroy() : APMenu::MenuItemText , LoadingConsole , APMenu::MenuItemSlider , APMenu::MenuItem
  • destroyConnectionViz() : APEditorQAbilities::AbilityEditor
  • destroyDistanceFieldGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyDistanceFieldGridCollision() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyDistanceFieldTempGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyEffect() : APObjectUtils::ObjectEffect
  • destroyGeometry()
: APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoader
, APFFDEditor::Grid
, APFFDEditor::GeometryLoaderBase
  • destroyGraphics() : APMenu::MenuItem
  • destroyGraphicsCore()
: APMenu::MenuItemText
, APMenu::MenuItemNull
, APMenu::MenuItem
, APMenu::MenuItemSlider
  • destroyHierarchy() : APSpacePartitioning::SphereBVH_Object_Data
  • destroyInterface() : vrecko::ControllableAbility
  • DestroyLightTexture() : Cloud
  • destroyMainObjects() : APMenu::DynamicMenu
  • destroyMenu() : vrecko::ControllableAbility
  • destroyMenuStructure() : APMenu::DynamicMenu
  • destroyModel() : APMenu::MenuItemText
  • destroyMutex() : vrecko::vThread
  • destroyPointerTrail() : APMenu::DynamicMenu
  • destroyPointShell() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • destroyPointShells() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • destroyThread() : APSpacePartitioning::SP_Object_Data_Base
  • detailCoef : APDYNAMICART::SimulationParameters
  • DETAILED : grass::GrassDrawable
  • detailedGrassStateSet : grass::GrassAbilityParameters
  • detectiontime1 : APSpacePartitioning::NoPartitioning_Scene
  • detectiontime2 : APSpacePartitioning::NoPartitioning_Scene
  • determinant() : gmMatrix4 , gmMatrix3
  • Device() : vrecko::Device
  • DEVICE : vrecko::EventDispatcher
  • device_manager_local : vrecko::ReaderWriter
  • device_map : vrecko::DeviceManager
  • device_type : vrecko::Device
  • DeviceManager() : vrecko::DeviceManager
  • devicePtr : vrecko::DeviceManager::DT
  • dFXDim : APSpacePartitioning::VoxelGrid_Object_Data
  • dFYDim : APSpacePartitioning::VoxelGrid_Object_Data
  • dFZDim : APSpacePartitioning::VoxelGrid_Object_Data
  • diagnostic() : vreckoDP_base::LHeadTracker
  • DiameterGenFactory() : APDYNAMICART::DiameterGenFactory
  • difference_sensor_orientation : behindO::HeadManipulator
  • difference_sensor_pos : behindO::HeadManipulator
  • diffuse : base::Light
  • dir : behindO::MyCullCallback
  • direction
: Sector
, navigation::KMTracker
, VirtualFixture::Border
, VirtualFixture::Vibration
, CarSim::MessageRoadAndDir
, CarSim::Edge
  • Direction : Sector
  • direction
: CarSim::CarState
, base::Light
, VirtualFixture::NavSphere
, VirtualFixture::VibrationLabel
  • dirty : APRoomEdit::Tool , APDYNAMICART::HoopShape
  • dirtyInterconnectionsForObject() : vrecko::EventDispatcher
  • disableAutorotation() : APDYNAMICART::Ctrl_StringSculptures
  • disabled : vreckoDP_base::Wiimote
  • disableShaders() : APDYNAMICART::Utils
  • disableThreshold() : ode::DynamicScene
  • disableTools() : APDYNAMICART::Ctrl_StringSculptures
  • disableTS() : vreckoDP_base::fsPinchGlove
  • disconnect() : Arm , Hci
  • dispatchEvent() : VirtualFixture::Drag
  • dispatchMessage() : VirtualFixture::Drag
  • dispEO : APMenu::DynamicMenu
  • dispersion : APDYNAMICART::ParticleSystemParameters
  • display()
: VirtualFixture::Cone
, VirtualFixture::Trace
, VirtualFixture::Sphere
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::NavSphere
, VirtualFixture::ProxiBorder
, VirtualFixture::Border
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBox
  • Display() : base::Display
  • display() : VirtualFixture::Box
  • displayAllGestures() : VirtualFixture::Drag
  • displayListValid : grass::GrassDrawable
  • dist : APSpacePartitioning::ELOD
  • distance() : APSpacePartitioning::PointShell_Object_Data , gmVector4 , gmVector3 , gmVector2
  • distance_sqr() : APSpacePartitioning::PointShell_Object_Data
  • distanceField : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFieldCollsions : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFieldTemp : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFromEye : grass::GrassDrawable
  • DistanceJoint() : PhysXPlugin::DistanceJoint
  • distanceSquared : gmVector3 , gmVector4 , gmVector2
  • distFromLastFrame : CarSim::CarState
  • distFromPointToLine() : CarSim::RoadsState
  • distPointToPlane() : CarSim::RoadsState
  • distToCam : CloudParticle
  • distToNextPoint : CarSim::CarEnvirons
  • Divide() : grass::Mesh
  • dominantAxis : MagicWandTool , APDYNAMICART::ToolMagicWand
  • done()
: vrecko::ViewerBase
, vrecko::Logger
, MainObject
, vrecko::vThread
  • Done() : APEditorQAbilities::ObjectMovement::SnapBox
  • doPreRender() : behindO::MyCullCallback
  • doStep() : AP_LSystem::MovingTurtle
  • dot : gmVector4 , gmVector2 , gmVector3
  • double2float() : gmVector3
  • doubleButtonPress() : vreckoDP_base::KeyboardMouse
  • doubleDerivedCRI() : MotionTrailTriangulator
  • DoublePair : Sector
  • DoubleSided : APObjectUtils::ObjectEffect
  • Drag() : VirtualFixture::Drag
  • draw()
: APCameraMovement::CameraPath
, APRoomEdit::WallGeometry
, APDYNAMICART::PerlinLines
  • DRAW_DEBUG_GEOMETRY : AP_LSystem::TurtleProperties
  • draw_Effect_PointShellHierarchy_Node() : APObjectUtils::ObjectEffect
  • DRAW_PIPE_CAPS : AP_LSystem::TurtleProperties
  • drawForward()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • drawForwardHalf()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • drawFrame()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • drawImplementation()
: PhysXPlugin::ClothDrawable
, grass::GrassDrawable
, PhysXPlugin::FluidDrawable
, osgQ::QShapeDrawable
  • DrawPoint()
: APCameraPath::Camera
, APLightsEditor::Editor
  • DrawSpline() : APCameraPath::Camera
  • drawStep()
: AP_LSystem::Rectangle
, AP_LSystem::LoftTurtle
, AP_LSystem::MovingTurtle
, AP_LSystem::HermitPipe
  • DrawVecCursor() : APCameraPath::Camera
  • drawVector() : AP_LSystem::AbstractTurtle
  • dRequestedCellLength : APSpacePartitioning::VoxelGrid_Object_Data
  • DummyCATypeToDWORD : vrecko::CAINFO__VER1
  • duration : VirtualFixture::Vibration
  • dwActiveFlags : vrecko::CAINFO__VER2
  • dwAffinity : base::SystemInfo::SIThreadInit
  • dwAlloc : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwAllocBy : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwAllowedOutput : vrecko::Logger
  • dwBehvFlags : vrecko::BufferedFile
  • dwBufMaxSize : vrecko::BufferedFileWrite
  • dwBufSize : vrecko::BufferedFile
  • dwCopiedProperties : APObjectUtils::CopyProperties
  • dwCopyEO : APObjectUtils::CopyProperties
  • dwCount : DynamicTree< _Type >
  • dwFilePos : vrecko::BufferedFile
  • dwFileSize : vrecko::BufferedFile
  • dwFlags
: DynamicTreeIterator< _Type >
, APMenu::MenuItem
, vrecko::CAINFO__VER1
, vrecko::CollisionPointInfo
, APObjectUtils::ConnectionViz::Connection
, vrecko::CollisionParams__ver1
, APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • dwGroup : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • dwInited : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwItemIndex : APMenu::MenuItem
  • dwLastKernelTime : base::SystemInfo::SIThreadInfo
  • dwLastTick : base::SystemInfo
  • dwLastUserTime : base::SystemInfo::SIThreadInfo
  • dwMainThreadId : vrecko::Logger
  • dwMaxPos : vrecko::BufferedFile
  • dwNum : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwNumItems : APMenu::MenuItem
  • dwOutputDest : vrecko::Logger
  • dwOutputType : vrecko::Logger::OutstandingText
  • dwPos : vrecko::BufferedFile
  • dwRepresentant : APSpacePartitioning::SNCH_Object_Data::VertexSNCH
  • dwSize : vrecko::CABUTTONEVENT , vrecko::CAINFO__VER1
  • dwSNCHFlags : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • dwStructureVersion : vrecko::CollisionParams__ver1
  • dwThreadId : base::SystemInfo::MessageSIThreadCreated
  • dwType : LoadingConsole::OutstandingLine
  • dwZeroPos : vrecko::BufferedFile
  • dyn_version : base::hand , base::MouseHand
  • DynamicArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DynamicAttribute() : vrecko::DynamicAttribute
  • DynamicMenu() : APMenu::DynamicMenu
  • dynamics_used : BehindObstacleExperiment , BehindObstacleExp_wT
  • DynamicScene() : ode::DynamicScene
  • dynamicStrings : AP_LSystem::Rule
  • DynamicTree() : DynamicTree< _Type >
  • DynamicTreeIterator() : DynamicTreeIterator< _Type >
  • DYNTREE_NODEALLOWED : DynamicTree< _Type >
  • DYNTREE_SUBTREEALLOWED : DynamicTree< _Type >
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • e1 : APSpacePartitioning::PLOD
  • e1ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • e2 : APSpacePartitioning::PLOD
  • e2ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • e3 : APSpacePartitioning::PLOD
  • e3ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • ECPOINTERBUTTONINFO() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • ECPOINTERINFO() : APEditorController::EditorController::ECPOINTERINFO
  • edge : CarSim::MessageCarEdge , CarSim::MessageEdgeOffset
  • edge_count : APFFDEditor::Grid
  • edgeCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgeCostRecompute : APSpacePartitioning::ELOD
  • edgeFlags : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • edgeId : CarSim::CarEdgeData
  • edgeImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgeLength() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edges
: CarSim::RoadsState
, APFFDEditor::Grid
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::VLOD
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgesCars : CarSim::Edge
  • edgesEqualByVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Editor() : APLightsEditor::Editor
  • EditorController() : APEditorController::EditorController
  • EditorLogic : APFFDEditor::Grid , APFFDEditor::EditorLogic
  • effectType : APObjectUtils::ObjectEffect
  • EffectType : APObjectUtils::ObjectEffect
  • EI_Type : vrecko::EventDispatcher
  • elasticityMultiplier : AP_LSystem::TurtleProperties
  • enable : ode::ODEObject
  • enableAllObjects() : ode::DynamicScene
  • enabledAnimations : APObjectUtils::Animator
  • enableGUI()
: APDYNAMICART::DAEnvironment
, APGUI::GUI_Controller
  • enableShadows() : APLightsEditor::Lights
  • enableTS() : vreckoDP_base::fsPinchGlove
  • encoder : Hci
  • encoder_updated : Hci
  • end : Sector , Hci
  • end_motion() : Arm
  • end_tick : BehindObstacleExp_wT , BehindObstacleExperiment
  • endIteration() : vrecko::Scene::EOIteratorHelper
  • eng : APDYNAMICART::ComputeThread
  • EnsureDetailedVersionIsReady() : grass::GrassDrawable
  • EnsureGrassBladesArePrepared() : grass::GrassAbilityParameters
  • enter()
: APConnectEditor::EOLineSegmentIntersector
, APObjectUtils::EOLineSegmentIntersector
, EOLineSegmentIntersector
  • entity_vector : vrecko::Scheduler::TimerStruct , vrecko::vThread
  • Enumeration() : vrecko::Enumeration< tval, tref >
  • environment_objects_map : vrecko::Scene
  • ENVIRONMENTOBJECT : vrecko::EventDispatcher
  • EnvironmentObject() : vrecko::EnvironmentObject
  • eo : navigation::AvatarInHand , APTextOutput::Console
  • EO : APFFDEditor::Grid::ControlPoint
  • eo : CacheInfo , APHUD::HUDDisplay
  • EO_owner_grab_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
  • EO_owner_grab_rot
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
  • EO_owner_grab_Wrot
: behindO::Manipulator
, behindO::AvatarManipulator
, behindO::EyeManipulator
  • eof() : AP_LSystem::ParseableString
  • eoID : vrecko::CollisionInfo
  • EOIteratorHelper() : vrecko::Scene::EOIteratorHelper
  • EOLineSegmentIntersector() : APObjectUtils::EOLineSegmentIntersector , EOLineSegmentIntersector , APConnectEditor::EOLineSegmentIntersector
  • EOMap : vrecko::Scene
  • eoMapLock : vrecko::Scene
  • eoRootNode : vrecko::Scene
  • EOS() : WAVEFRONT::InPlaceParser
  • EOVector : vrecko::Scene::EOIteratorHelper
  • equalArrays() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • erasePoints() : SnapObject
  • erasePointsAndAllFaces() : SnapObject
  • eraseWhiteSpaces() : AP_LSystem::StringUtils
  • error() : Hci
  • Error() : APNature::TerrainUtility
  • error : packet_rec
  • errorLog()
: vrecko::Logger
, vrecko::World
  • errorOccuredInInit : CarSim::CarControlUnit
  • errorText() : AP_LSystem::AbstractInterpret
  • Eval() : mv::CMVect
  • Evaluate()
: ht::Function
, ht::SetupFunction
, ht::SimpleSetupFunction
  • evaluateCondition() : AP_LSystem::Rule
  • event_dispatcher_local : vrecko::ReaderWriter
  • event_interconnection_map : vrecko::EventDispatcher
  • EventDispatcher()
: vrecko::EventDispatcher
, vrecko::EventDispatcher::ICSBase
  • eventsVector : vrecko::EventDispatcher
  • eventType : vrecko::EventDispatcher::EventStruct
  • evoke() : APGUI::ColorPicker
  • executeAddAbility() : APEditorQAbilities::AbilityEditor
  • executeAddConnection() : APEditorQAbilities::AbilityEditor
  • executeDeleteAbility() : APEditorQAbilities::AbilityEditor
  • executeDeleteConnection() : APEditorQAbilities::AbilityEditor
  • exit() : MainObject
  • ExitLoadingFunction() : Preloader
  • ExitStatus : base::_THREAD_BASIC_INFORMATION
  • expandItem() : APMenu::DynamicMenu
  • experiment_description : BehindObstacleExp_wT , BehindObstacleExperiment
  • experiment_map : BehindObstacleExp_wT , BehindObstacleExperiment
  • Export() : APNature::Terrain2D
  • exportToFile() : APDYNAMICART::BrushStroke
  • ExtractMin() : ThinHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , GenericHeap< _NodeClass, _keyType >
  • eye_distance_scale_factor
: behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • eye_offset : vrecko::World::AvatarEye
  • eye_position
: behindO::EyeManipulator
, vrecko::World::AvatarView
, behindO::HMDHeadManipulator
, behindO::HeadManipulator
, behindO::AvatarManipulator
, behindO::Manipulator
  • EyeManipulator() : behindO::EyeManipulator
  • eyePos : APConnectEditor::Rotation , APConnectEditor::Scale
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • face : APDYNAMICART::symmetry_pair
  • face_count : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • face_index : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • face_size : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • FaceNormals : APObjectUtils::ObjectEffect
  • faces
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object::LocalMinimumDistance
, APSpacePartitioning::SNCH_Object_Data::VertexSNCH
  • fActTime : APObjectUtils::Animator
  • fAlpha : APObjectUtils::Animator::AnimationPoint
  • fAnimationTime : APCameraPath::Camera
  • Far : CloudSceneInfo
  • far_border : behindO::HeadManipulator
  • fastTimeout() : Hci
  • FDNAbility : vrecko::ReaderWriter
  • FDNAttribute : vrecko::ReaderWriter
  • FDNDevice : vrecko::ReaderWriter
  • FDNEnvironmentObject : vrecko::ReaderWriter
  • FDNEvent : vrecko::ReaderWriter
  • FDNFilter : vrecko::ReaderWriter
  • FDNNodeType : vrecko::ReaderWriter
  • FDNReceiver : vrecko::ReaderWriter
  • FDNSimpleNode : vrecko::ReaderWriter
  • FDNUserData : vrecko::ReaderWriter
  • fdtDataGlove() : vreckoDP_base::fdtDataGlove
  • FibonacciHeap() : FibonacciHeap< _NodeClass, _keyType >
  • fieldDefaultColorA : APHUD::HUDDisplay
  • fieldDefaultColorB : APHUD::HUDDisplay
  • fieldDefaultColorG : APHUD::HUDDisplay
  • fieldDefaultColorR : APHUD::HUDDisplay
  • fields : APHUD::HUDWindow
  • fieldSizeVertical : APHUD::HUDDisplay
  • fieldTabHorizontal : APHUD::HUDDisplay
  • fieldTabVertical : APHUD::HUDDisplay
  • figureOutFirstJuncTurn() : CarSim::CarControlUnit
  • file : vrecko::BenchmarkWriter
  • FileException() : AP_LSystem::FileException
  • fileName : ArtificialWorld::Model
  • filename : PreloaderLoadedInfo , PreloaderToLoadInfo , ArtificialWorld::SubBlock , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • filesLock : vrecko::PersistentCache
  • fillCollisionLists() : APSpacePartitioning::NoPartitioning_Scene
  • fillDefaultInfo()
: APEditorQAbilities::AnimatorEditor
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectAdd
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SceneSave
, APEditorQAbilities::SimpleObjectMovement
, APEditorQAbilities::UseTrigger
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
, APRoomEdit::RoomEditor
, AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::ConnectEditor
, APConnectEditor::Cut
, APConnectEditor::Optimalizer
, APConnectEditor::PolygonState
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
  • FilletSpline() : FilletSpline
  • Filter() : VirtualFixture::Filter
  • filter1() : filter1
  • filter2() : filter2
  • Filter_GetPosition() : VirtualFixture::Filter
  • Filter_GetVelocity() : VirtualFixture::Filter
  • Filter_Initialize() : VirtualFixture::Filter
  • Filter_Mesurement() : VirtualFixture::Filter
  • Filter_Prediction() : VirtualFixture::Filter
  • Filter_SetX_hat1() : VirtualFixture::Filter
  • Filter_SetX_hat2() : VirtualFixture::Filter
  • Filter_Update() : VirtualFixture::Filter
  • final_object_position : BehindObstacleExp_wT , BehindObstacleExperiment
  • final_object_rotation : BehindObstacleExp_wT , BehindObstacleExperiment
  • final_position : ChessPiece
  • finalize()
: AP_LSystem::AbstractTurtle
, AP_LSystem::HermitPipe
, AP_LSystem::QueryTurtle
, AP_LSystem::Rectangle
, AP_LSystem::StraightPipe
  • findBoundaryLoops() : SnapObject
  • findChildByName() : vrecko::ReaderWriter
  • findClosestPoint() : SnapObject
  • findClosestSnappingRegionPoints() : SnapObject
  • findCollisionsWithObject() : APSpacePartitioning::NoPartitioning_Scene
  • findDuplicateNode() : vrecko::ReaderWriter
  • fIndex : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • findHierarchyMember() : ConstraintHierarchyMember
  • findJuncsSinglePolyPoints() : CarSim::RoadsState
  • findMatchingLeftBracket() : AP_LSystem::LongString
  • findMatchingRightBracket() : AP_LSystem::LongString
  • findNodeByName() : vrecko::ReaderWriter
  • findObject() : vrecko::OctTree
  • findObjectInNode() : vrecko::OctTree
  • findPath() : CarSim::RoadsState
  • findPinInList() : vrecko::BaseClass
  • FindPoint() : APCameraPath::Camera
  • findRealFile() : vrecko::ReaderWriter
  • findShortestPath() : CarSim::RoadsState , SnapObject
  • finger_direction : vreckoDP_base::fdtDataGlove
  • finishStructureBuild()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • first : base::hand , base::MouseHand
  • first_enter : BehindObstacleExp_wT , BehindObstacleExperiment
  • first_report : vreckoDP_base::LHeadTracker
  • firstObjectMatrix : APConnectEditor::Scale , APConnectEditor::Rotation
  • firstObjectPos
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • firstObjectPosCo : APCameraMovement::CameraMovementEditor
  • firstObjectRot : APConstrainedMovement::ConstrainedObjectMovement , APEditorQAbilities::ObjectMovement
  • firstPointerPos
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Rotation
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
, APConnectEditor::Scale
  • firstPointerRot : APEditorQAbilities::ObjectMovement , APConstrainedMovement::ConstrainedObjectMovement
  • firstTimeUpdate : APDYNAMICART::PerlinLines
  • firstTransparency : APConstrainedMovement::ConstrainedObjectMovement
  • FixedJoint() : PhysXPlugin::FixedJoint
  • fixGeometryDrawableHelper() : vrecko::EnvironmentObject
  • fixGeometryHelper() : vrecko::EnvironmentObject
  • fixGeometryMirroring() : vrecko::EnvironmentObject
  • flag : filter2
  • Flags : AP_LSystem::TurtleProperties
  • flags : AP_LSystem::TurtleProperties
  • flatLayer : CloudsManager
  • Flatten()
: APNature::Terrain2D
, APNature::Terrain2DSegment
, APNature::TerrainAlgorithm
  • float2double() : gmVector3
  • floatToTimeString() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Fluid : PhysXPlugin::FluidDrawable , PhysXPlugin::Fluid
  • FluidDrawable() : PhysXPlugin::FluidDrawable
  • flush() : vrecko::BufferedFileWrite
  • flushSerial() : Serial
  • fly : navigation::AvatarInHand
  • fMaxDistance : APSpacePartitioning::PointShell_Object_Data
  • fMaxU : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMaxV : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMinU : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMinV : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fObjProjectionArea : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • focus_area : behindO::CentreObjectManipulator
  • focusing_marker : behindO::CentreObjectManipulator
  • font_size : BehindObstacleExp_wT , BehindObstacleExperiment
  • fontColor : APHUD::HUDColorProfile
  • for() : GradientColorGen
  • force
: base::hand
, VirtualFixture::Drag
, base::MouseHand
  • ForceField() : PhysXPlugin::ForceField
  • FORWARD_OUTPUT : vrecko::EventDispatcher
  • forwardEdgeId : CarSim::RoadsEdges
  • Fovy : CloudSceneInfo
  • fp : UserStream
  • fPointRadius : APCameraPath::Camera
  • fr : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • fRadius : APObjectUtils::ObjectEffect
  • frame : behindO::MyCullCallback , vrecko::ViewerBase
  • free_move_EO : VirtualFixture::Avatar , base::Avatar
  • FreeAllNodes() : FibonacciHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType >
  • FreeArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • freeFromConstraintParent() : APConstrainedMovement::ConstraintDescription
  • freeID : APConnectEditor::Cut
  • freeMoveEO_ID : VirtualFixture::Avatar , base::Avatar
  • FreeNodeSimple() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType >
  • freeze_finger_sensor : vreckoDP_base::fdtDataGlove
  • freeze_rotation : vreckoDP_base::fdtDataGlove
  • freezeFingerSensor() : vreckoDP_base::fdtDataGlove
  • freezeRotation() : vreckoDP_base::fdtDataGlove
  • FrenetFrame() : FrenetFrame
  • frenetFremeComputed : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • freq : VirtualFixture::Filter , APSpacePartitioning::NoPartitioning_Scene
  • frequency
: VirtualFixture::Border
, VirtualFixture::Vibration
, VirtualFixture::NavSphere
, VirtualFixture::VibrationLabel
, vrecko::Scheduler::TimerStruct
, vrecko::vThread
  • from : CarSim::Edge
  • fromPointRight : CarSim::Edge
  • frontCarId : CarSim::EdgesCar
  • frontLightsPath : CarSim::GeometryPartsPath
  • frontLightState : CarSim::CarExecutionUnit
  • fSliderFromX : APMenu::MenuItemSlider
  • fSliderPos01 : APMenu::MenuItemSlider
  • fSliderToY : APMenu::MenuItemSlider
  • fsPinchGlove() : vreckoDP_base::fsPinchGlove
  • fstCarId : CarSim::Edge
  • fTolerance : Filter::PosNoiseRemover
  • fTransparency : APCameraPath::Camera
  • FULL : APLightsEditor::Lights
  • full_update() : Arm
  • fullBckg() : Arm
  • func : APDYNAMICART::DAEnvironment
  • fValue : vrecko::Logger::OutstandingCounter
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • gcd() : vreckoUtils::Math
  • gen : CarSim::CarControlUnit
  • generalLock
: vrecko::Logger
, vrecko::Scene::EOIteratorHelper
, base::MTMatrixTransform
  • generate()
: APDYNAMICART::PatternBase
, APDYNAMICART::IShapeGenerator
, APDYNAMICART::NullShapeGenerator
, APDYNAMICART::LinearShapeGenerator
, APDYNAMICART::Attractor
, APDYNAMICART::Pattern
  • generate_board : ChessBoard
  • generateAllFilletPoints() : FilletSpline
  • GenerateByMidpointDisplacementAlgorithm() : APNature::Terrain2D
  • GenerateByPerlinNoiseAlgorithm() : APNature::Terrain2D
  • GenerateByRandomFaultsAlgorithm() : APNature::Terrain2D
  • generateCars() : CarSim::RoadsState
  • GenerateCloudsTexture() : APNature::PerlinNoiseAlgorithm
  • GenerateLightTexture() : Cloud
  • GenerateNoiseTexture() : APNature::PerlinNoiseAlgorithm
  • generateSuccessor() : AP_LSystem::LSystem
  • GenerateSurfaceByMidpointDisplacement() : APNature::MidpointDisplacementAlgorithm
  • GenerateSurfaceByRandomFaults() : APNature::RandomFaultsAlgorithm
  • generateVertexNeighbourhood() : APSpacePartitioning::SNCH_Object_Data
  • geode
: AP_LSystem::AbstractTurtle
, APHUD::HUDDisplay
, APTextOutput::Console
, LoadingConsole
  • geom
: VirtualFixture::NavSphere
, ode::ODEObject
, APTextOutput::Console
, LoadingConsole
  • geom_translate : ode::ODEObject
  • geometries_count : APFFDEditor::GeometryLoader
  • Geometry : ArtificialWorld::Model
  • geometry
: PreloaderLoadedInfo
, AP_LSystem::TurtleProperties
, APHUD::HUDField
, APHUD::HUDWindow
, APMenu::DynamicMenuSign
  • geometryArray : APFFDEditor::GeometryLoader
  • GeometryLoader() : APFFDEditor::GeometryLoader
  • GeometryLoaderBase()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • GeometryState() : GeometryState
  • gestureOn : vreckoDP_base::fsPinchGlove
  • get()
: APDYNAMICART::Configuration
, APDYNAMICART::HookManager
, APDYNAMICART::PhysXManager
, AP_LSystem::Configuration
, AP_LSystem::Log
, AP_LSystem::QueryInterpret
, AP_LSystem::Randomizer
, InterpolatorFactory
  • Get() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • get_rel_pos() : vreckoDP_base::LHeadTracker
  • getAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • getAbilityInstance() : vrecko::PluginManager
  • getAbilityMap()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • getAbilityWithInput()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • getAbilityWithOutput()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • getAbsPos() : CarSim::RoadsState
  • getAcceptableMessages()
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::WIM
, ChessBoard
, ChessPiece
, navigation::AvatarInHand
, PhysXPlugin::ForceField
  • getActGesture() : mv::CPlayer
  • getActor() : APDYNAMICART::Hoop
  • getActPos() : mv::CPlayer
  • getActT() : mv::CPlayer
  • getActualAvatarView() : vrecko::World
  • getActualValue()
: APHUD::HUDDisplay
, vreckoDP_base::fdtDataGlove
  • getActVect() : mv::CPlayer
  • getActVel() : mv::CPlayer
  • getAdapter() : APDYNAMICART::AdapterFactory< T >
  • getAll() : mv::CPlayer
  • GetAllocated() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • getAllowedOutput() : vrecko::Logger
  • getAlpha() : APObjectUtils::Animator
  • getAndLockNextObject() : vrecko::Scene::EOIteratorHelper
  • getAngle()
: WGeometry::WG_Geometry
, WGeometry::WG_Wall
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getAngleFrom() : osgQ::QSection
  • getAngleTo() : osgQ::QSection
  • GetAnim() : APEditorQAbilities::AnimatorEditor
  • GetAnimatedGeometry() : AnimatedGeometryState
  • GetAnimatedModelGeometry() : ModelManager
  • GetAnimation() : ArtificialWorld::SubBlock
  • GetAnimationIndex() : ArtificialWorld::AnimatedModel
  • GetAnimationPoint() : ArtificialWorld::SubBlockAnimation
  • getAnimationPointsNumber() : APObjectUtils::Animator
  • GetAnimationType() : ArtificialWorld::SubBlockAnimation
  • getAnimatorOnObject() : APObjectUtils::Animator
  • getAnimMatrix() : APObjectUtils::Animator
  • getAreaClass() : APConstrainedMovement::ConstraintArea
  • getAreaClassString() : APConstrainedMovement::ConstraintArea , ConstraintHierarchyMember
  • GetArglist() : WAVEFRONT::InPlaceParser
  • getArguments() : vrecko::World
  • getAttribStringValue() : vrecko::ReaderWriter
  • getAttribute()
: vrecko::BaseClass
, APMenu::DynamicMenu
  • getAttributePtr()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • GetAttributes() : ArtificialWorld::BlockUpdater
  • getAutoRotationActive() : APDYNAMICART::DAEnvironment
  • getAvaiableHoopShapes() : APDYNAMICART::ShapeFactory
  • getAvaiablePatterns() : APDYNAMICART::PatternFactory
  • getAvaiablePolyhedronNames() : APDYNAMICART::PolyhedronFactory
  • getAvailableAttractors() : APDYNAMICART::Attractor
  • getAxes() : APDYNAMICART::PS_Symmetry
  • getAxiom() : AP_LSystem::AbstractFile
  • getBBoxDF() : APSpacePartitioning::VoxelGrid_Object_Data
  • getBBoxDFSize() : APSpacePartitioning::VoxelGrid_Object_Data
  • getBindingAreas() : APConstrainedMovement::ConstraintDescription
  • getBinormal()
: APDYNAMICART::DAGizmo
, APDYNAMICART::BrushStrokeControlPoint
, DAGizmo
, DAControlPoint
  • GetBlockType() : ArtificialWorld::BlockUpdater
  • getBlurSize() : APLightsEditor::Lights
  • getBoolValue() : vrecko::ReaderWriter
  • getBottomCCWVertex() : WGeometry::WG_Vertices
  • getBottomCWVertex() : WGeometry::WG_Vertices
  • getBottomNormal() : WGeometry::WG_Wall
  • getBounceRadius() : APLightsEditor::Lights
  • getBounceSampleCount() : APLightsEditor::Lights
  • GetBound() : grass::Mesh
  • getBoundAreaCount() : APConstrainedMovement::ConstraintDescription
  • getBoundAreaNormal() : APConstrainedMovement::ConstraintDescription
  • getBoundaryLoop() : SnapObject
  • getBoundaryLoopCentroids() : SnapObject
  • getBoundaryLoops() : SnapObject
  • GetBoundingBox() : ArtificialWorld::BlockUpdater
  • getBoundingPoints() : APConstrainedMovement::ConstraintArea
  • getBoundingPointsWorld() : APConstrainedMovement::ConstraintArea
  • GetBoundingSphere() : ArtificialWorld::BlockUpdater
  • getBufSize() : vrecko::BufferedFile
  • getButt() : Arm , vreckoDP_base::MicroScribe3D
  • getByte() : vreckoDP_base::fsPinchGlove
  • getCableAbility() : AP_CableEditor::CableEditor
  • getCableColor() : AP_CableEditor::Cable
  • getCableID() : AP_CableEditor::Cable
  • getCableWrapperNode() : AP_CableEditor::Cable
  • getCachedColorGenerator() : APDYNAMICART::Hoop
  • getCachedFileName() : vrecko::PersistentCache::OpenedCacheFile
  • getCacheDir() : vrecko::PersistentCache
  • getCalibrationString() : vrecko::Device
  • getCamera()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
, vrecko::World
  • getCameraPos() : CloudDataType
  • getCameras() : vrecko::ViewerBase
  • getCameraUp() : CloudDataType
  • getCameraView() : CloudDataType
  • getCaption()
: APMenu::MenuItemText
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • getCarEdgeId() : CarSim::RoadsState
  • getCenter() : osgQ::QSection
  • getChild() : vreckoUtils::MenuBase
  • getChildMenuObject() : APMenu::MenuItem
  • getChildNodesbyName() : APInputConnector::InputConnector
  • getChoosenBoundaryLoop() : SnapObject
  • getClearColor() : APLightsEditor::Lights
  • getClickedString()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • getClosestPoint() : SnapObject
  • getClosestSnappingRegionPoints() : SnapObject
  • getCollisionObject() : vrecko::Scene
  • getCollisionObjects() : vrecko::Scene
  • getCollisions()
: vrecko::Scene
, vrecko::SP_ObjectInterface
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShellVSVoxel_Object
, APSpacePartitioning::SNCH_Object
, APSpacePartitioning::SphereBVH_Object
  • getCollisionsFromTree() : APSpacePartitioning::PointShell_Object_Data
  • getColor()
: APDYNAMICART::ColorGenAdapter
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Hoop
, APDYNAMICART::colorGradient
, WGeometry::WG_Wall
  • getColorEnd() : GradientColorGen
  • getColorGenAdapter() : APDYNAMICART::Brush
  • getColorGenerator() : SweepSurfaceGeode
  • getColorGenFactory() : APDYNAMICART::Brush
  • getColorIndex() : APDYNAMICART::ColorGenAdapter
  • getColors() : SnapObject , SectorColorGen
  • getColorStart() : GradientColorGen
  • getColorValue() : ConstantColorGen
  • getColour() : MTBrush
  • getColouringType() : MTBrush
  • getColoursMap() : MTBrush
  • getComputedStartTime() : APDYNAMICART::BrushStroke
  • getConstants() : Arm
  • getConstrainedChildrenIDs() : APConstrainedMovement::ConstraintDescription
  • getConstrainedDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • getConstraintParentID() : APConstrainedMovement::ConstraintDescription
  • getContexts() : vrecko::ViewerBase
  • getController() : APDYNAMICART::DAEnvironment
  • getControlPoints()
: AP_CableEditor::Cable
, APCameraMovement::CameraPath
  • getControlSpheresRadiusAdjust() : AP_CableEditor::Cable
  • GetCount() : DynamicTree< _Type >
  • getCountOfControlPoints() : APFFDEditor::Grid
  • getCrossingPoint() : WGeometry::WG_Geometry
  • getCrossSectionAdapter() : APDYNAMICART::Brush
  • getCrossSectionAdapterName() : APDYNAMICART::Brush
  • getCrossSectionArray() : SweepSurfaceGeode
  • getCrossSectionGenerator() : APDYNAMICART::HoopGeometry
  • getCrossSectionInterpolationSteps() : APDYNAMICART::Brush , MTBrush
  • getCrossSectionInterpolationType() : MTBrush
  • getCrossSectionSpline() : SweepSurfaceGeode
  • getcrossSectionType() : MTBrush
  • getCrosssPoints() : MTBrush
  • getCurrectShadingMode() : APLightsEditor::Lights
  • getCurrentGIMode() : APLightsEditor::Lights
  • getCurrentShadowLightID() : APLightsEditor::Lights
  • getCurrentShadowMode() : APLightsEditor::Lights
  • GetCurrentWorldPosition() : ArtificialWorld::BlockUpdater
  • getCursor() : APDYNAMICART::DATool
  • getCursorPosition()
: APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
  • getCurvature() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getDaareaScale() : APDYNAMICART::Controller
  • getDAMatrix() : APDYNAMICART::PhysXManager
  • getData()
: APDYNAMICART::ComputeThread
, AP_LSystem::LongString
, vreckoDP_base::fsPinchGlove
  • getDataType() : vrecko::Attribute
  • getDefaultColor() : SectorColorGen
  • getDefaultRequestInterconnectionMap() : vrecko::EventDispatcher
  • getDefaultSize() : APDYNAMICART::IComputeStrategy
  • getDefaultTurtleProperties() : AP_LSystem::LSGeode
  • getDefaultValue() : vrecko::StaticAttribute< type, tval, tref >
  • getDelay() : vrecko::vThread
  • GetDepth() : DynTreeNode< _Type >
  • getDescribtion() : VirtualFixture::Marker
  • getDescription()
: vrecko::Attribute
, vrecko::Scene
, vrecko::World
, APDYNAMICART::Controller
  • getDeviceInstance() : vrecko::DeviceManager
  • getDeviceManagerPtr() : vrecko::World
  • getDeviceMap() : vrecko::DeviceManager
  • getDevicePtr() : vrecko::DeviceManager
  • getDevicePtrByType() : vrecko::DeviceManager
  • getDeviceType() : vrecko::Device
  • getDiameter()
: APDYNAMICART::Brush
, APDYNAMICART::Hoop
, APDYNAMICART::BrushStrokeControlPoint
, MTBrush
  • getDiameterEnd() : GradientDiameterGen
  • getDiameterGenAdapter() : APDYNAMICART::Brush
  • getDiameterGenerator() : SweepSurfaceGeode
  • getDiameters() : MTBrush
  • getDiameterStart() : GradientDiameterGen
  • getDirection() : mv::CPlayer
  • getDirtyBoundaryLoop() : SnapObject
  • getDirtyClosestPoint() : SnapObject
  • getDirtyGraph() : SnapObject
  • getDirtyMaxDistance() : SnapObject
  • getDirtySnappingRegion() : SnapObject
  • getDistanceFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDistanceFieldValueEffect() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDistanceTempFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDOMDocument() : ArtificialWorld::BlockUpdater
  • getDone() : vrecko::vThread
  • getDORadius() : APLightsEditor::Lights
  • getDOSampleCount() : APLightsEditor::Lights
  • getDoubleValue() : vrecko::ReaderWriter
  • getDrawSpheres() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • getDualAreas() : APConstrainedMovement::ConstraintDescription
  • getDuration() : APDYNAMICART::BrushStroke
  • getEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getEffect() : APWeather::Weather
  • getEffectType() : APObjectUtils::ObjectEffect
  • getElapsedArtTime() : APDYNAMICART::DAEnvironment
  • getEnable() : vrecko::PersistentCache
  • getEnabledAnimations() : APObjectUtils::Animator
  • getEntityPtr() : vrecko::vThread
  • getEntityVec() : vrecko::vThread
  • getEnvironmentObject() : vrecko::Scene
  • getEo() : SnapObject
  • getEOMap() : vrecko::Scene
  • getEORoot() : vrecko::Scene
  • getEoWrapper() : AP_CableEditor::Cable
  • getEuler() : vreckoDP_base::LHeadTracker
  • getEventDispatcherPtr() : vrecko::World
  • getEventInterconnectionMap() : vrecko::EventDispatcher
  • getEventsVector() : vrecko::EventDispatcher
  • getExtParams() : Hci
  • getFace()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getFaceCount()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getFaceNormal() : WGeometry::WG_Wall
  • getFaces() : SnapObject
  • getFaceStructureSize()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • GetFileName()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getFilePos() : vrecko::BufferedFile
  • getFileSize() : vrecko::BufferedFile
  • getFilletPoints() : FilletSpline
  • getFingerDirection() : vreckoDP_base::fdtDataGlove
  • getFlag() : WGeometry::WG_Wall
  • getFlags() : APMenu::MenuItem
  • getFlares() : APLightsEditor::Lights
  • getFloatValue() : vrecko::ReaderWriter
  • getForce()
: APSpacePartitioning::SNCH_Object
, mv::CPlayer
  • getFrameID() : vrecko::World
  • getFreeID() : vrecko::Scene
  • getFrequency() : vrecko::vThread
  • getFreshDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • getFuncPtr : vrecko::vThread , vrecko::PluginManager
  • getGeode() : SnapObject , AP_LSystem::AbstractTurtle , APRoomEdit::WallGeometry
  • getGeodeOf() : SnapObject
  • getGeometriesCount() : APFFDEditor::GeometryLoader
  • getGeometry() : SnapObject , APFFDEditor::GeometryLoader
  • GetGeometry() : GeometryState
  • getGesture() : vreckoDP_base::fsPinchGlove
  • getGlobalAmbient() : APLightsEditor::Lights
  • getGraph() : SnapObject
  • getGUIItemName() : APGUI::GUI_Item
  • getHandle()
: vrecko::BufferedFile
, vrecko::BufferedFileWrite
, vrecko::MTLock
  • getHeight()
: osgQ::QSection
, WGeometry::WG_Point
, WGeometry::WG_Hole
  • GetHighestValue() : APNature::TerrainAlgorithm
  • getHighlighted() : vreckoUtils::HighlightCallback
  • getHighLighting() : MotionTrailTriangulator
  • getHoles() : WGeometry::WG_Wall
  • getHomomorphisms() : AP_LSystem::AbstractFile
  • getHooks() : APDYNAMICART::HookManager
  • getHoop() : APDYNAMICART::SectorManager
  • getHoopShape() : APDYNAMICART::ShapeFactory
  • getHUDField() : APHUD::HUDDisplay
  • getHUDWindow() : APHUD::HUDDisplay
  • getID()
: vrecko::Ability
, vrecko::Device
, vrecko::EnvironmentObject
  • getId()
: vrecko::SP_ObjectInterface
, vrecko::SP_SceneInterface
, SnapObject
, WGeometry::WG_Point
, WGeometry::WG_Wall
, VirtualFixture::Marker
  • getIncrementValue() : vreckoUtils::HighlightCallback
  • GetIndex() : WAVEFRONT::BuildMesh
  • getIndexBottom() : WGeometry::WG_Point
  • getIndexTop() : WGeometry::WG_Point
  • GetIndices() : WAVEFRONT::BuildMesh
  • getInfoString() : BehindObstacleExp_wT , BehindObstacleExperiment
  • getInnerBoundingBox()
: APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • getInnerRadius() : osgQ::QSection
  • getInputPin() : vrecko::BaseClass
  • getInstance()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::SectorManager
  • getIntepolatedPoints() : AP_CableEditor::Cable
  • getInterpolatedPoint() : AP_CableEditor::Cable
  • getInterpolation() : AP_CableEditor::Cable
  • GetInterpolation() : ArtificialWorld::SubBlockAnimation
  • getInterpolationCount() : APDYNAMICART::PerlinLines
  • getInterpolationSteps() : APDYNAMICART::Brush , InterpolatedSpline , MTBrush
  • getInterpolationType() : APObjectUtils::Animator
  • getInterpolator() : InterpolatedSpline
  • getIntersection() : APRoomEdit::RoomEditor
  • getIntValue() : vrecko::ReaderWriter
  • getItembyName() : APGUI::GUI_Controller
  • getIteration() : AP_LSystem::AbstractLSystem
  • getIterationCount() : APDYNAMICART::OrdinaryAttractor
  • getJustMoving() : APConstrainedMovement::ConstraintDescription
  • getLabel() : VirtualFixture::Marker
  • getLastPointerPos() : APMenu::DynamicMenu
  • getLastTick() : vrecko::vThread
  • getLayoutString() : APGUI::GUI_Controller
  • getLButton() : vreckoDP_base::L3DMouse
  • getLeadingSpline()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::HoopShape
, APDYNAMICART::Stroke
, SweepSurfaceGeode
  • getLeadSplineArray() : SweepSurfaceGeode
  • getLeftHandOrientation()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getLeftHandPosition()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getLength() : APDYNAMICART::PerlinLines
  • getLevelMax() : APObjectUtils::ObjectEffect
  • getLevelMin() : APObjectUtils::ObjectEffect
  • getLight()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
, APLightsEditor::Lights
  • getLightSource() : APLightsEditor::Lights
  • getLMDStore() : APSpacePartitioning::SNCH_Object
  • getLoadedArtTime() : APDYNAMICART::DAEnvironment
  • GetLock() : Preloader
  • getLongIntValue() : vrecko::ReaderWriter
  • getLoop() : mv::CPlayer
  • getLoopType() : APObjectUtils::Animator
  • GetLoopType() : ArtificialWorld::SubBlockAnimation
  • getLowerBound() : vrecko::Interval< tval, tref >
  • GetLowestValue() : APNature::TerrainAlgorithm
  • getLSystemCount() : AP_LSystem::Configuration
  • getLSystemIndex() : AP_LSystem::Configuration
  • getLvlVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getMainObject() : APMenu::DynamicMenu
  • getMappedAbilityID() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • getMappedAbilityInfo() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • GetMatrix() : ht::Screen
  • getMatrix()
: base::MTMatrixTransform
, AP_LSystem::AbstractTurtle
  • GetMatrixInv() : ht::Screen
  • getMatrixValue() : vrecko::ReaderWriter
  • getMaxDistance() : SnapObject , APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • getMaxDistanceVector() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • getMaxes() : Hci
  • getMaxForce() : APSpacePartitioning::SNCH_Object
  • getMaximumDistance() : APSpacePartitioning::PointShell_Object_Data
  • getMaximumDistanceVector() : APSpacePartitioning::PointShell_Object_Data
  • getMaxInstancesCount() : vrecko::DynamicAttribute
  • getMaxLvl() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getMaxPos() : vrecko::BufferedFile
  • getMaxSpeed() : MTBrush
  • GetMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getMButton() : vreckoDP_base::L3DMouse
  • getMenuType() : APMenu::DynamicMenu
  • GetMesh() : grass::TriangleCollector
  • getMessage() : behindO::WIM
  • getMessageId()
: base::SystemInfo::MessageSIThreadCreated
, vrecko::VreckoMessage
, vrecko::MessageVoid
, CarSim::MessageRoadAndDir
, CarSim::MessageCarEdge
, CarSim::MessageCarEdgeData
, CarSim::MessageEdgeOffset
, CarSim::MessageVectorUnsignedInt
, CarSim::MessageStartStopDestination
, CarSim::MessageFirst3Juncs
, CarSim::MessageCarSimParameters
, CarSim::MessageCarEnvirons
, CarSim::MessageCarStatePtr
, APEditorController::AbilityMapper::MessageMapping
, vrecko::MessageCAButtonEvent
, vrecko::ControllableAbility::MessageCAINFO
, ode::DynamicScene::MessageODERequest
, PhysXPlugin::MessageNxActorWithName
  • GetMin() : GenericHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • getMinimalSampleDistance() : SampledSpline
  • getMinInstancesCount() : vrecko::DynamicAttribute
  • getMinSpeed() : MTBrush
  • GetMinVisibleDistance() : ArtificialWorld::Model
  • getModelFile() : APMenu::MenuItemText
  • getModelFileName() : vrecko::EnvironmentObject
  • GetModelFlags() : ArtificialWorld::Model
  • GetModelGeometry() : ModelManager
  • GetModels() : ArtificialWorld::BlockUpdater
  • GetModelType() : ArtificialWorld::Model
  • getModuleCounter() : AP_LSystem::Log
  • getMovable() : mv::CGesture
  • getMutex() : vrecko::vThread
  • getName()
: vrecko::Ability
, vrecko::Attribute
, vrecko::EnvironmentObject
, APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, APDYNAMICART::Pattern
, APDYNAMICART::PatternBase
, APGUI::ItemsGroup
, APGUI::Layout
, APMenu::MenuItem
, APRoomEdit::Tool
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • getNCoeficient() : APSpacePartitioning::SNCH_Object
  • getNearestIndex() : APDYNAMICART::ToolSelector
  • GetNeighbourEast() : APNature::Terrain2DSegment
  • GetNeighbourNorth() : APNature::Terrain2DSegment
  • GetNeighbourSouthh() : APNature::Terrain2DSegment
  • GetNeighbourWest() : APNature::Terrain2DSegment
  • getNextCarDistAndVel() : CarSim::RoadsState
  • getNextPoint() : APDYNAMICART::IComputeStrategy
  • getNextToolType()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
  • GetNode() : DynamicTreeIterator< _Type >
  • getNodeCountByName() : vrecko::ReaderWriter
  • getNodeIdentification() : vrecko::ReaderWriter
  • getNodeMask() : APObjectUtils::Animator
  • getNodeWithIDFromTree() : APSpacePartitioning::PointShell_Object_Data
  • GetNoise() : APNature::PerlinNoiseAlgorithm
  • getNormal()
: APDYNAMICART::DAGizmo
, APDYNAMICART::BrushStrokeControlPoint
, DAGizmo
, DAControlPoint
  • getNormalByIndex()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getNormalCCWVertex() : WGeometry::WG_Vertices
  • getNormalCWVertex() : WGeometry::WG_Vertices
  • getNormals() : SnapObject
  • getNormalVector() : APConstrainedMovement::ConstraintArea
  • getNormalVectorWorld() : APConstrainedMovement::ConstraintArea
  • getNumberOfArguments() : vrecko::World
  • getNumberofFaces() : APDYNAMICART::PS_Symmetry
  • getNumSectors() : SectorColorGen , APDYNAMICART::SectorManager
  • getObject()
: APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::PoAAdapter< T >
  • GetObjectCenterDir() : ArtificialWorld::BlockAttributes
  • GetObjectCenterPoint() : ArtificialWorld::BlockAttributes
  • getObjectExtent() : vrecko::Scene
  • getObjectNeighbourhood() : vrecko::OctTree
  • getObjectSelectionActiveRight() : APDYNAMICART::DAEnvironment
  • GetObjectsToPreload() : PreloaderHeuristic
  • getObjectsTransformations() : APSpacePartitioning::SNCH_Object
  • getObjectTransformation() : APSpacePartitioning::PointShellVSVoxel_Object
  • getObjectUpdatesCounter() : vrecko::Scheduler
  • GetObserver() : GetObserver
  • getOfferAreas() : APConstrainedMovement::ConstraintDescription
  • getOkAndChangeEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getOnce() : mv::CMVect
  • getOpacity() : APDYNAMICART::PS_Layer
  • getorCreateGroup() : APGUI::GUI_Controller
  • getOrientation() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getOrientationSamples()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::Stroke
  • getOriginPosition()
: vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
  • getOSGAdapter() : vrecko::EnvironmentObject
  • getOSGInitCounts()
: APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
  • getOuterAngleAddition() : osgQ::QSection
  • getOuterRadius() : osgQ::QSection
  • getOutputDest() : vrecko::Logger
  • getOutputPin() : vrecko::BaseClass
  • getOwner()
: vrecko::Ability
, APMenu::DynamicMenu
  • getPacket() : vreckoDP_base::fsPinchGlove
  • getPaintingDuration() : APDYNAMICART::Ctrl_FreeHandPainting
  • getParameters()
: APDYNAMICART::Attractor
, APDYNAMICART::IParameters
, AP_LSystem::LongString
  • getParameterVector()
: base::Rotate
, base::ShowFDH
, vrecko::Ability
  • getParams() : Hci
  • getParentEO() : vrecko::EnvironmentObject
  • getParentHoop() : APDYNAMICART::HookObject
  • getPartitioningObjectInterface() : vrecko::Scene
  • getPartitioningSceneInterface() : vrecko::Scene
  • getPartOfObject() : SnapObject
  • getPattern()
: APDYNAMICART::PatternFactory
, APDYNAMICART::SectorManager
  • getPatternsPointsArray() : APDYNAMICART::PatternsGeode
  • getPause() : mv::CPlayer
  • getPersistentCache() : vrecko::World
  • getPhysicsResult() : APDYNAMICART::PhysXManager
  • getPinName() : vrecko::IOPinBase
  • getPlane() : RegularPolygonSpline
  • getPlaneDistanceFrom() : APConstrainedMovement::ConstraintArea
  • getPlay() : mv::CPlayer
  • getPlaybackTimeText() : APDYNAMICART::Ctrl_FreeHandPainting
  • getPluginName() : vrecko::Ability
  • getPlusColors() : WGeometry::WG_Point
  • getPlusNormals() : WGeometry::WG_Point
  • getPlusVertices() : WGeometry::WG_Point
  • getPoAs() : APDYNAMICART::Controller
  • getPoAsName() : APDYNAMICART::Controller
  • getpobName() : APDYNAMICART::PoB
  • GetPoint()
: APNature::Terrain2D
, APNature::Terrain2DSegment
  • getPoint()
: WGeometry::WG_Wall
, APRoomEdit::WallGeometry
  • getPointedItemRecursive() : APMenu::DynamicMenu
  • getPointerSliderPos01() : APMenu::MenuItemSlider
  • GetPointHeight()
: APNature::TerrainAlgorithm
, APNature::Terrain2D
  • getPointRef() : WGeometry::WG_Wall
  • getPoints() : SampledSpline
  • getPointShellRootSize() : APSpacePartitioning::PointShell_Object_Data
  • getPointShellSize() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • getPolygons()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
  • getPolygonsCount()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getPolyhedron() : APDYNAMICART::PolyhedronFactory
  • getPortName() : vrecko::Device
  • getPosition()
: vrecko::EnvironmentObject
, WGeometry::WG_Hole
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • GetPosition()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getPosition()
: WGeometry::WG_Point
, VirtualFixture::Marker
  • getPositionSamples()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Stroke
, APDYNAMICART::Hoop
  • getPositionString() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getPrimitiveSet() : SnapObject
  • getPriority()
: vrecko::BaseClass
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • getProcessedEventsCounter() : vrecko::EventDispatcher
  • getProjPointerPos() : APMenu::DynamicMenu
  • getProperties()
: AP_LSystem::AbstractTurtle
, APObjectUtils::CopyProperties
  • getProperty() : AP_LSystem::Configuration
  • getQuatValue() : vrecko::ReaderWriter
  • getQueryCounter() : AP_LSystem::Log
  • getQVertices() : WGeometry::WG_Hole
  • getRadius() : AP_CableEditor::Cable , RegularPolygonSpline
  • GetRandomFloatGaussian() : APNature::TerrainRandom
  • GetRandomFloatGaussianBasedOnPointDistance() : APNature::TerrainRandom
  • GetRandomFloatUniform() : APNature::TerrainRandom
  • getRandomIndex() : AP_LSystem::RandomIndex
  • GetRandomPoint() : grass::Triangle
  • GetRandPosition() : PseudoRand2DPlacement
  • getRangePtr() : vrecko::StaticAttribute< type, tval, tref >
  • getRayIntersection() : vrecko::Scene
  • getRButton() : vreckoDP_base::L3DMouse
  • getRealStartTime() : APDYNAMICART::BrushStroke
  • getRecData()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::L3DMouse
  • getReceiverPtr() : vrecko::EventDispatcher::ICSBase
  • getReceiverPtrCore() : vrecko::EventDispatcher::ICSBase
  • getRequestedCellSize() : APSpacePartitioning::VoxelGrid_Object_Data
  • getRequestInputPin() : vrecko::BaseClass
  • getRequestInterconnectionMap() : vrecko::EventDispatcher
  • getRequestOutputPin() : vrecko::BaseClass
  • getRestrictorString() : APConstrainedMovement::ConstraintArea
  • getRewritingCounter() : AP_LSystem::Log
  • getRFGenerator() : SweepSurfaceGeode
  • getRightHandOrientation()
: APDYNAMICART::PoA
, APDYNAMICART::DAEnvironment
  • getRightHandPosition()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getRoot()
: vrecko::Scene
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • GetRoot() : DynamicTree< _Type >
  • GetRootObjectID() : ArtificialWorld::WorldBuilder
  • getRootPtr() : APSpacePartitioning::SphereBVH_Object_Data
  • getRoots() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getRopeActors() : APDYNAMICART::PhysXManager
  • getRopeRadius() : APDYNAMICART::ToolHook
  • getRotate()
: vreckoDP_base::fdtDataGlove
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
  • getRotateA()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, vreckoDP_base::LHeadTracker
  • getRotateM()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • getRotateQ()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • getRotation()
: vrecko::EnvironmentObject
, osgQ::QSection
, APObjectUtils::Animator
  • GetRotation()
: ArtificialWorld::SubBlock
, ArtificialWorld::Model
  • getRotationFrameAdapter() : APDYNAMICART::Brush
  • getRotationFrameAdapterName() : APDYNAMICART::Brush
  • getRotationShift() : RegularPolygonSpline
  • getRules() : AP_LSystem::AbstractFile
  • getRun() : vrecko::vThread
  • getRVertices() : WGeometry::WG_Hole
  • getSame() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSameEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSameEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSamples() : MTCreatorTool
  • getSawErrors()
: vrecko::RWErrorHandler
, APMenu::MenuLoaderErrorHandler
, BCLoaderErrorHandler
  • getSButton() : vreckoDP_base::L3DMouse
  • GetScale() : ArtificialWorld::Model
  • getScale()
: APObjectUtils::Animator
, vrecko::EnvironmentObject
  • getSceneFile() : vrecko::BaseClass
  • getScenePtr() : vrecko::World
  • getSchedulerPtr() : vrecko::World
  • getSecondsPerTick() : vrecko::Timer
  • getSector() : APDYNAMICART::SectorManager , SectorColorGen
  • getSectorInfoList() : APDYNAMICART::SectorManager
  • getSectorMarker() : APDYNAMICART::Hoop
  • getSectorNumber() : APDYNAMICART::ToolSelector
  • getSectorRange() : Sector
  • getSegmentCount() : RegularPolygonSpline
  • getSegmentLength() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • getSelectedObject() : APObjectUtils::ObjectModif
  • getSelectedPoA()
: APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
  • getSenderString()
: vrecko::Ability
, vrecko::BaseClass
  • getSensorScale() : vreckoDP_base::OptiTrack
  • getShadowedSceneLight() : vrecko::World
  • getShadowedScenePtr() : vrecko::World
  • getShadowTechnique() : APLightsEditor::Lights
  • getShape()
: APDYNAMICART::Hoop
, AP_CableEditor::Cable
  • getShapeCurveGenerator() : APDYNAMICART::HoopGeometry
  • getShapeGenerator() : APDYNAMICART::ShapeFactory
  • getShapeRotate() : AP_CableEditor::Cable
  • getShowControlPointsString() : APDYNAMICART::Ctrl_FreeHandPainting
  • getShowTimeWarnings() : vrecko::World
  • getSignal() : vreckoDP_base::fdtDataGlove
  • getSignObject() : APMenu::DynamicMenu
  • getSimpleGraph() : SnapObject
  • getSimualtionParameters() : APDYNAMICART::PhysXManager
  • getSize() : APDYNAMICART::DATool
  • getSkeleton() : vreckoDP_Kinect::Kinect
  • getSliderPos01() : APMenu::MenuItemSlider
  • getSliderPosXY() : APMenu::MenuItemSlider
  • getSmoothness() : APDYNAMICART::Brush
  • getSnappingRegion() : SnapObject
  • getSnappingRegionValues() : SnapObject
  • getSnapPointArray() : APDYNAMICART::Hoop
  • getSnapRegion() : SnapObject
  • getSnapRegionWithDistanceSet() : SnapObject
  • getSNCHFace() : APSpacePartitioning::SNCH_Object_Data
  • getSNCHVertex() : APSpacePartitioning::SNCH_Object_Data
  • getSpeed() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint , APDYNAMICART::PerlinLines
  • getSPoint() : mv::CGesture
  • getStartTick() : vrecko::Timer
  • getState() : vrecko::Scheduler
  • getStatusResult() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getStepCounter() : vrecko::vThread
  • getStereoMode()
: vrecko::ViewerBase
, vrecko::CompositeViewer
, vrecko::Viewer
  • getSTNodeStructureSize()
: APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::SNCH_Object_Data
  • getStringLineWidth() : APDYNAMICART::PatternsGeode
  • getStrings() : Hci
  • getStringValue() : vrecko::ReaderWriter
  • getStringValueXCh() : vrecko::ReaderWriter
  • getStylusDir() : Arm
  • getStylusTip() : Arm
  • GetSubBlocks() : ArtificialWorld::BlockUpdater
  • GetSubBlocksUpdaters() : ArtificialWorld::BlockUpdater
  • GetSubBlockType() : ArtificialWorld::SubBlock
  • getSubsystems() : AP_LSystem::AbstractFile
  • getSunDate() : APLightsEditor::Lights
  • getSupportedAdapters() : APDYNAMICART::AdapterFactory< T >
  • getSupportedInterpolators() : InterpolatorFactory
  • getSweepSurface() : APDYNAMICART::Hoop
  • getSymbol() : AP_LSystem::LongString
  • getT() : Arm
  • getTangent() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getTarget() : APDYNAMICART::PoB
  • getTerminationFlag() : vrecko::World
  • GetTerrainGroup() : APNature::Terrain2D
  • GetTerrainSegmentGeode() : APNature::Terrain2DSegment
  • GetTexCoords() : WAVEFRONT::BuildMesh
  • getText() : APGUI::Slider
  • getTextBoundingBox() : APMenu::MenuItemText
  • getThirdVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getTimeFromLastUpdate() : CarSim::CarControlUnit
  • getTimePerLoop() : APObjectUtils::Animator
  • GetTimePerLoop() : ArtificialWorld::SubBlockAnimation
  • getTimerPtr() : vrecko::vThread
  • getTimeStamps()
: APDYNAMICART::Stroke
, APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
  • getTimeWarningsTime() : vrecko::World
  • getTopCCWVertex() : WGeometry::WG_Vertices
  • getTopCWVertex() : WGeometry::WG_Vertices
  • getTopNormal() : WGeometry::WG_Wall
  • getTorsion() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getTranslate()
: vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
, vreckoDP_base::LHeadTracker
, vreckoDP_base::Ultratrak
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
  • getTranslatedFileName() : vrecko::PersistentCache::OpenedCacheFile
  • getTranslateMapping()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
  • getTranslation() : APObjectUtils::Animator
  • getTransparency() : vrecko::EnvironmentObject
  • getTriangulationAngle() : APDYNAMICART::BrushStrokeControlPoint
  • getTurnOnJunc() : CarSim::RoadsState
  • getTurtleCounter() : AP_LSystem::Log
  • getTurtleType() : AP_LSystem::LSGeode
  • getTvalue() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • getType()
: APDYNAMICART::Controller
, APDYNAMICART::BrushStrokeControlPoint
, APDYNAMICART::DATool
, WGeometry::WG_Hole
, APRoomEdit::Tool
, DAControlPoint
  • getUpdate() : AP_CableEditor::Cable
  • GetUpdate() : GetObserver , Cache
  • getUpdateFlag() : APDYNAMICART::PoA
  • getUpperBound() : vrecko::Interval< tval, tref >
  • getUserData() : vrecko::EnvironmentObject
  • getUserDataMap() : vrecko::EnvironmentObject
  • getV0() : mv::CMVect
  • getV1() : mv::CMVect
  • GetValue() : ht::VariableVec2
  • getValue() : vreckoUtils::MenuSlider
  • GetValue()
: ht::VariableVec3
, ht::VariableQuat
, ht::VariableFloat
  • getValue() : APGUI::Slider
  • GetValueInFunction()
: ht::VariableVec2
, ht::VariableQuat
, ht::VariableFloat
, ht::VariableVec3
  • GetVariablesCount()
: ht::VariableVec2
, ht::VariableFloat
, ht::VariableQuat
, ht::VariableVec3
, ht::Variable
  • getVec2Value() : vrecko::ReaderWriter
  • getVec3Value() : vrecko::ReaderWriter
  • getVec4Value() : vrecko::ReaderWriter
  • getVect() : mv::CMVect
  • getVector() : WGeometry::WG_Wall
  • getVertex()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::PointShell_Object_Data_Geometry
  • getVertexArray() : BufferedSpline , APDYNAMICART::PatternBase , SampledSpline
  • getVertexCount()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getVertexStructureSize()
: APSpacePartitioning::SNCH_Object_Data
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getVertices()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, WGeometry::WG_Wall
, SnapObject
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • GetVertices() : WAVEFRONT::BuildMesh
  • getVertices() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • getViewer()
: vrecko::CompositeViewer
, vrecko::ViewerBase
, vrecko::Viewer
  • getViewerPtr() : vrecko::World
  • getVisibleModels() : ArtificialWorld::BlockUpdater
  • getVisualOwner() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getVolume() : APDYNAMICART::Limits
  • getWall() : APRoomEdit::WallGeometry
  • getWallNeighbours() : WGeometry::WG_Point
  • getWalls() : WGeometry::WG_Point
  • getWasTested() : APConstrainedMovement::ConstraintDescription
  • getWidth() : WGeometry::WG_Hole
  • getWindows() : vrecko::ViewerBase
  • getWord()
: AP_LSystem::LSystemGenerator
, AP_LSystem::AbstractGenerator
  • getWorldPosition() : vrecko::EnvironmentObject
  • getWorldRotation() : vrecko::EnvironmentObject
  • getWorldTransformation()
: vrecko::EnvironmentObject
, base::MTMatrixTransform
  • getWTime() : mv::CGesture
  • getXDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getXMLParameters()
: VirtualFixture::ProxiCylinder
, VirtualFixture::Damper
, VirtualFixture::Marker
, VirtualFixture::Cylinder
, VirtualFixture::Cone
, VirtualFixture::VibrationLabelActivator
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Vibration
, VirtualFixture::ProxiBox
, VirtualFixture::VibrationLabel
, VirtualFixture::NavSphere
, PHANToMAvatar
, VirtualFixture::Log
, VirtualFixture::Grid
, VirtualFixture::Border
, VirtualFixture::ProxiBorder
, PhysXPlugin::CylindricalJoint
, VirtualFixture::Box
, PhysXPlugin::PulleyJoint
, VirtualFixture::Avatar
, VirtualFixture::Plane
, PhysXPlugin::BaseJoint
, PhysXPlugin::FixedJoint
, PhysXPlugin::PointInPlaneJoint
, PhysXPlugin::Box
, PhysXPlugin::BaseActor
, PhysXPlugin::PrismaticJoint
, PhysXPlugin::RemoteDebugger
, PhysXPlugin::PointOnLineJoint
, VirtualFixture::MarkerFactory
, PhysXPlugin::SphericalJoint
, PhysXPlugin::Capsule
, PhysXPlugin::Sphere
, VirtualFixture::AxisLock
, PhysXPlugin::DistanceJoint
, VirtualFixture::Drag
, PhysXPlugin::Plane
, PhysXPlugin::RevoluteJoint
, PHEffect
, VirtualFixture::ProxiCone
, VirtualFixture::Filter
, VirtualFixture::Trace
  • getY() : WGeometry::WG_Hole
  • getYDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getZDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getZeroLevelSize() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • giMode : APLightsEditor::Lights , APLightsEditor::Editor
  • giModes : APLightsEditor::Lights
  • glist : mv::CCollection
  • globalSearch() : APSpacePartitioning::SNCH_Object
  • gmMatrix3() : gmMatrix3
  • gmMatrix4() : gmMatrix4
  • gmVector2() : gmVector2
  • gmVector3() : gmVector3
  • gmVector4() : gmVector4
  • gnode
: VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::Cylinder
, VirtualFixture::ProxiCone
, VirtualFixture::Cone
, VirtualFixture::Box
, VirtualFixture::Trace
, VirtualFixture::Border
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Plane
, VirtualFixture::NavSphere
  • goHomePos() : Hci
  • GOURAUD : APLightsEditor::Lights
  • GRAB_EVENT : base::MouseHand
  • grab_position : navigation::AvatarInHand
  • GRAB_RELEASE_EVENT : base::MouseHand
  • grab_transform : base::MouseHand , base::hand
  • grab_transform_SO : base::hand , base::MouseHand
  • gradient : APDYNAMICART::PerlinLines
  • GradientColorAdapter() : APDYNAMICART::GradientColorAdapter
  • GradientColorGen() : GradientColorGen
  • GradientDiamAdapter() : APDYNAMICART::GradientDiamAdapter
  • GradientDiameterGen() : GradientDiameterGen
  • gradientEndColor : APHUD::HUDColorProfile
  • gradientStartColor : APHUD::HUDColorProfile
  • gradientStep : GradientColorGen
  • graphicObject
: APObjectUtils::ConnectionViz
, APEditorQAbilities::ObjectMovement::SnapBox
, APObjectUtils::ObjectEffect
  • grasp_count : BehindObstacleExperiment , BehindObstacleExp_wT
  • Grass() : grass::Grass
  • GrassAbilityParameters() : grass::GrassAbilityParameters
  • grassBlades : grass::GrassAbilityParameters
  • grassCullCallback : grass::GrassAbilityParameters
  • grassDisplayList : grass::GrassDrawable
  • GrassDrawable() : grass::GrassDrawable
  • gravitropismElasticity : AP_LSystem::TurtleProperties
  • gravity : APDYNAMICART::ParticleSystemParameters , VirtualFixture::Grid
  • gravity_mode : base::Avatar
  • gravity_on : VirtualFixture::Grid
  • GreatestCommonDivisor() : APNature::TerrainUtility
  • Grid()
: APFFDEditor::Grid
, VirtualFixture::Grid
  • gridChanged : APFFDEditor::EditorLogic
  • gridUnitHalfSizeX : PseudoRand2DPlacement
  • gridUnitHalfSizeZ : PseudoRand2DPlacement
  • gridUnitSizeX : PseudoRand2DPlacement
  • gridUnitSizeY : PseudoRand2DPlacement
  • gridUnitSizeZ : PseudoRand2DPlacement
  • gridWasCreated : APFFDEditor::Grid
  • groundCenterPosition : CloudsProperties
  • groundShow : CloudsProperties
  • groundTexturePath : CloudsProperties
  • GrowthSimulationSteps : CloudsProperties
  • GrowthSimulationStepsRand : CloudsProperties
  • GUI_Controller() : APGUI::GUI_Controller
  • GUI_Item() : APGUI::GUI_Item
  • GUI_Item::createLabel() : APGUI::GUI_Item
  • GUI_Text() : APGUI::GUI_Text
  • GUIItemClicked() : APDYNAMICART::BrushStroke
  • guiItemClicked()
: APDYNAMICART::ToolSelector
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolMagicWand
  • GUIItemClicked() : APDYNAMICART::Attractor
  • guiItemClicked() : APDYNAMICART::ToolBrush
  • GUIItemClicked()
: APDYNAMICART::PoA
, APDYNAMICART::OrdinaryAttractor
  • guiItemClicked() : APDYNAMICART::ToolHook
  • GUIItemClicked()
: APDYNAMICART::HookObject
, APDYNAMICART::JuliaAttractor
  • guiItemClicked()
: APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Brush
, APDYNAMICART::ToolRotation
, APDYNAMICART::Ctrl_PolyhedraSculptures
  • GUIItemClicked() : APDYNAMICART::PerlinLines
  • guiItemClicked() : APDYNAMICART::Ctrl_Attractor
  • GUIItemClicked() : APDYNAMICART::Hoop
  • GuiItemClicked() : APNature::TerrainAbility
  • GUIItemClicked() : APDYNAMICART::PolyhedraSculpture
  • guiSliderChanged() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • GUISliderChanged() : APDYNAMICART::OrdinaryAttractor
  • guiSliderChanged()
: APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Controller
  • GUISliderChanged() : APDYNAMICART::PoA
  • guiSliderChanged() : APDYNAMICART::Ctrl_Attractor
  • GUISliderChanged()
: APDYNAMICART::PerlinLines
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::BrushStroke
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::Hoop
  • guiSliderChanged() : APDYNAMICART::Ctrl_FreeHandPainting
  • GUISliderChanged() : APDYNAMICART::HookObject
  • guiSliderChanged()
: APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_MotionVisualization
  • GUISliderChanged() : APDYNAMICART::Attractor
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • HALF : APLightsEditor::Lights
  • half_spread_angle : APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
  • halfRect1 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • halfRect2 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • halfside : AABoundingBox
  • hand() : base::hand
  • hand_orientation_left : navigation::KMTracker
  • hand_orientation_right : navigation::KMTracker
  • hand_position_left : navigation::KMTracker
  • hand_position_right : navigation::KMTracker
  • hand_type : vreckoDP_base::fdtDataGlove
  • HandFrameAdapter() : APDYNAMICART::HandFrameAdapter
  • handle() : vreckoDP_base::KeyboardMouse
  • handle_analog() : vreckoDP_base::VRPN3DMouse
  • handle_button() : vreckoDP_base::VRPN3DMouse
  • handle_ctrl_status() : vreckoDP_base::Wiimote
  • handle_disconnect() : vreckoDP_base::Wiimote
  • handle_event() : vreckoDP_base::Wiimote
  • handle_read() : vreckoDP_base::Wiimote
  • handleEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • handleError()
: vrecko::RWErrorHandler
, APMenu::MenuLoaderErrorHandler
, BCLoaderErrorHandler
  • handMoveMax : APDYNAMICART::ToolMagicWand , MagicWandTool
  • handMoveMin : APDYNAMICART::ToolMagicWand , MagicWandTool
  • handShapeDraw : APGUI::ColorPicker
  • handShapeSphere : APGUI::ColorPicker
  • handSphereRadius : APGUI::ColorPicker
  • hasAnimation : ArtificialWorld::SubBlock
  • HasAnimation() : ArtificialWorld::SubBlock
  • hasAnyAttributes() : vrecko::AttributesDescription
  • hashValue : vrecko::EventDispatcher::StringWithHash
  • hasMaxDistance : ArtificialWorld::Model
  • hasMaxVisibleDistance : ArtificialWorld::SubBlock
  • HasMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • hasMinDistance : ArtificialWorld::Model
  • HasMinVisibleDistance() : ArtificialWorld::Model
  • hasNextAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • hasNextValue() : vrecko::Enumeration< tval, tref >
  • hasPositionSet : ArtificialWorld::Model
  • HasPositionSet() : ArtificialWorld::Model
  • hasRange() : vrecko::StaticAttribute< type, tval, tref >
  • have2Polygons2OrMoreVetrticesSame() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • hci : Arm
  • hCollisionEvent1 : vrecko::Scene::EOIteratorHelper
  • hCollisionEvent2 : vrecko::Scene::EOIteratorHelper
  • head : base::Avatar , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , VirtualFixture::Avatar
  • head_center
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • head_orientation : ht::HeadTracking
  • head_pos : ht::HeadTracking
  • head_sensor_number : ht::HeadTracking
  • head_tracking_origin_position : ht::HeadTracking
  • head_tracking_scale : ht::HeadTracking
  • head_tracking_translate_mapping : ht::HeadTracking
  • headEO_ID : base::Avatar , VirtualFixture::Avatar
  • headingX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • headingY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • headingZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • HeadManipulator() : behindO::HeadManipulator
  • headOffset : CarSim::EdgesCar
  • HeadTracking() : ht::HeadTracking
  • Height() : APNature::Terrain2DSegment
  • height : CarSim::CarSize
  • hemisphere : AP_LSystem::TurtleProperties
  • herFerDeriv() : CarSim::RoadsState
  • hermiteBasis() : gmMatrix4
  • HermitPipe() : AP_LSystem::HermitPipe
  • hfCubicsBorder : CarSim::InOutEdgesAttr
  • hfCubicsBorderVec : CarSim::InOutEdgesAttr
  • hFile : vrecko::BufferedFileWrite , vrecko::BufferedFile
  • hHierarchyCreationThread : APSpacePartitioning::SP_Object_Data_Base
  • hide()
: vrecko::EnvironmentObject
, APGUI::GUI_Item
, APGUI::GUI_Text
, APGUI::Layout
, APDYNAMICART::DAGizmo
, DAGizmo
  • Hide() : ArtificialWorld::BlockUpdater
  • hide()
: APMenu::MenuItem
, APEditorQAbilities::ObjectMovement::SnapBox
  • hideAxis() : APDYNAMICART::Hoop
  • hideChildMenu() : APMenu::DynamicMenu
  • hideGraphics()
: APMenu::MenuItem
, APMenu::MenuItemNull
  • hideMainMenuObject() : APMenu::DynamicMenu
  • hideMenu()
: APMenu::DynamicMenu
, vrecko::ControllableAbility
  • hidePointerTrail() : APMenu::DynamicMenu
  • HideSubBlocks() : ArtificialWorld::BlockUpdater
  • hideTooltip() : APGUI::GUI_Item
  • HierarchyThreadProc : APSpacePartitioning::SP_Object_Data_Base
  • HighlightCallback() : vreckoUtils::HighlightCallback
  • highlightColour() : MotionTrailTriangulator
  • hMainThreadId : vrecko::EventDispatcher
  • HMDHeadManipulator() : behindO::HMDHeadManipulator
  • HoleRemove() : APRoomEdit::HoleRemove
  • homePos() : Arm
  • HookArray : APDYNAMICART::HookManager
  • HookManager() : APDYNAMICART::HookManager
  • HookObject() : APDYNAMICART::HookObject
  • hoop : APDYNAMICART::SectorInfo
  • Hoop() : APDYNAMICART::Hoop
  • hoopDensity : APDYNAMICART::SimulationParameters
  • HoopGeometry() : APDYNAMICART::HoopGeometry
  • HoopShape() : APDYNAMICART::HoopShape
  • HoopTrackerCallback() : APDYNAMICART::HoopTrackerCallback
  • hOriginalStdHandle : vrecko::Logger
  • horiz : navigation::KMTracker
  • horizAlign : APObjectUtils::KeepOnScreen
  • Horizontal_PrioritySnap : APEditorQAbilities::ObjectMovement
  • hR1SnapMul : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • hR2SnapMul : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • HSLtoPos() : APGUI::ColorPicker
  • HSLtoRGB() : APGUI::ColorPicker
  • HSVtoRGB() : APObjectUtils::ObjectEffect
  • hThreadHandle : vrecko::ScenePSThreadInfo
  • hud : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • HUDDepthField : APHUD::HUDDisplay
  • HUDDepthFieldBackground : APHUD::HUDDisplay
  • HUDDepthWindow : APHUD::HUDDisplay
  • HUDDisplay() : APHUD::HUDDisplay
  • HUDDivision : APHUD::HUDDisplay
  • hudFieldExist() : APHUD::HUDDisplay
  • hudInitialized : APSpacePartitioning::NoPartitioning_Scene , APSpacePartitioning::PointShellVSVoxel_Object
  • hudWindowExist() : APHUD::HUDDisplay
  • hudWindows : APHUD::HUDDisplay
  • hum : CloudVoxel
  • hvT_Mutex : vrecko::vThread
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • i : navigation::KMTracker , mv::CPlayer
  • i1 : APSpacePartitioning::int_3
  • i2 : APSpacePartitioning::int_3
  • i3 : APSpacePartitioning::int_3
  • iActDir : APObjectUtils::Animator
  • iButtonID : vrecko::CABUTTONEVENT
  • Icon() : APGUI::Icon , Icon
  • IconColour() : APGUI::IconColour
  • iCorrectedSamplesCounter : Filter::PosNoiseRemover
  • ICSBase() : vrecko::EventDispatcher::ICSBase
  • id
: vrecko::EnvironmentObject
, CarSim::Junction
, CarSim::PolygonPoint
, APSpacePartitioning::PointShell_SimpleNode
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
, APSpacePartitioning::VLOD
, APSpacePartitioning::ELOD
, APSpacePartitioning::PLOD
, PhysXPlugin::Particle
, VirtualFixture::Marker
  • ID : vrecko::World::AvatarView , Sector
  • id : vrecko::Device
  • ID1 : APFFDEditor::Grid::Edge
  • ID2 : APFFDEditor::Grid::Edge
  • id_string : vrecko::PyAbility
  • identity() : gmMatrix3 , gmMatrix4
  • identity4x4() : Arm
  • iDilatation : APSpacePartitioning::VoxelGrid_Object_Data
  • iDilatationStrategy : APSpacePartitioning::VoxelGrid_Object_Data
  • iDistanceFieldValue : APObjectUtils::ObjectEffect
  • idle() : vreckoDP_base::KeyboardMouse
  • iEdgesCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iGenType : APSpacePartitioning::VoxelGrid_Object_Data
  • ignoredObjects : vrecko::CollisionParams__ver1
  • iLevelMax : APObjectUtils::ObjectEffect
  • iLevelMin : APObjectUtils::ObjectEffect
  • iMaxCollisionsFromLoadedVoxel : APSpacePartitioning::VoxelGrid_Object_Data
  • iMaxCorrectedSamplesInRow : Filter::PosNoiseRemover
  • iMaxPastSamples : Filter::PosNoiseRemover
  • immersive : navigation::AvatarInHand
  • importance : APSpacePartitioning::VLOD , APSpacePartitioning::ELOD
  • importControlPoints() : APDYNAMICART::BrushStroke
  • ImportFromHeightMap() : APNature::Terrain2D
  • importScene() : APDYNAMICART::Ctrl_FreeHandPainting
  • includesValue() : vrecko::Interval< tval, tref >
  • incModuleCounter() : AP_LSystem::Log
  • incoming_events : vrecko::EventDispatcher
  • incomingCars : CarSim::Edge
  • incQueryCounter() : AP_LSystem::Log
  • incrementActNode() : vrecko::ReaderWriter
  • incrementFrameID() : vrecko::World
  • incRewritingCounter() : AP_LSystem::Log
  • incTurtleCounter() : AP_LSystem::Log
  • indexByName() : PhysXPlugin::MaterialManager
  • indexX : APDYNAMICART::ToolMagicWand , MagicWandTool
  • indexY : MagicWandTool , APDYNAMICART::ToolMagicWand
  • indexZ : APDYNAMICART::ToolMagicWand , MagicWandTool
  • Info() : APNature::TerrainUtility
  • inheritProperties() : AP_LSystem::AbstractTurtle
  • Init()
: AP_CableEditor::CableEditor
, APCameraPath::Camera
, APEditorQAbilities::ObjectMovement::SnapBox
, grass::GrassAbilityParameters
, WAVEFRONT::InPlaceParser
  • init()
: vrecko::BufferedFile
, vrecko::BufferedFileWrite
, vrecko::Logger
, Cache
, CarSim::CarControlUnit
, APConnectEditor::ConnectEditor
, APDYNAMICART::Attractor
, APDYNAMICART::ComputeThread
, APDYNAMICART::HookManager
, APDYNAMICART::Rectangle
, APDYNAMICART::Ellipse
, APDYNAMICART::Line
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PhysXManager
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::WaveSplineAdapter
, AP_LSystem::RandomIndex
, AP_LSystem::Randomizer
, APRoomEdit::ColorBucket
, APRoomEdit::CreateHole
, APRoomEdit::HoleRemove
, APRoomEdit::PointAdd
, APRoomEdit::PointMove
, APRoomEdit::RoomLoader
, APRoomEdit::RoomSaver
, APRoomEdit::Tool
, APRoomEdit::WallAdd
, APRoomEdit::WallRemove
, Arm
, Hci
  • InitAnimation() : APCameraPath::Camera
  • initBool : CarSim::CarControlUnit
  • InitCloudGeometry() : Cloud
  • initColorsOnTLs() : CarSim::TLsOnJuncManager
  • initDirection() : CarSim::CarExecutionUnit
  • initial_sensor_orientation : behindO::HeadManipulator
  • initial_sensor_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • initial_sensor_x_orientation : behindO::HeadManipulator
  • initialize()
: APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::PS_Polyhedron
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, vrecko::ControllableAbility
, APEditorController::EditorController
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::ObjectMovement
, AP_LSystem::AbstractTurtle
, AP_LSystem::HermitPipe
, AP_LSystem::JointedPipe
, AP_LSystem::QueryTurtle
, AP_LSystem::Rectangle
, AP_LSystem::StraightPipe
, APGUI::ColorPicker
, APGUI::GUI_Controller
, APGUI::GUI_Item
, APGUI::Icon
, APGUI::IconColour
, APGUI::Layout
, APGUI::Menu
, APGUI::Slider
, ht::HeadTracking
, ht::ScreenSetup
, ht::ScreenSetupSimple
, APHelloWorld::MyAbility
, APInputConnector::InputConnector
, APLightsEditor::Editor
, APNature::TerrainAbility
, APWeather::Weather
, navigation::AvatarInHand
, ode::DynamicScene
, APRoomEdit::RoomEditor
, APShootingSimulation::ShootingSimulation
, vreckoDP_base::Wiimote
, base::Display
, base::ShowFDH
, base::ShowFDHModel
, vrecko::BaseClass
, vrecko::EnvironmentObject
, Cache
, ArtificialWorld::WorldBuilder
, AP_CableEditor::CableEditor
, APCameraPath::Camera
, APDYNAMICART::Controller
  • initializeFromString() : vrecko::BaseClass
  • InitializeGeode() : APNature::Terrain2DSegment
  • InitializeGI() : APLightsEditor::Lights
  • InitializeMenu() : APNature::TerrainAbility
  • InitialLevel : APNature::MidpointDisplacementAlgorithm
  • initialParamValue : APDYNAMICART::ToolMagicWand , MagicWandTool
  • InitItems() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • initIteration() : vrecko::Scene::EOIteratorHelper
  • initIterationFrom() : vrecko::Scene::EOIteratorHelper
  • initMenu()
: APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • initNormal() : CarSim::CarExecutionUnit
  • initPort() : vreckoDP_base::fsPinchGlove
  • initPositionAndDirection() : CarSim::CarControlUnit
  • initScene() : BehindObstacleExp_wT , BehindObstacleExperiment
  • initStandardSignSet() : APMenu::DynamicMenu
  • initThread() : base::SystemInfo
  • initTools() : APDYNAMICART::Controller
  • iNorm : APSpacePartitioning::PointShell_SimpleNode
  • inOutEdgesAttrMap : CarSim::Junction
  • inovation : VirtualFixture::Filter
  • InPlaceParser() : WAVEFRONT::InPlaceParser
  • inPos : CarSim::Edge
  • Input : APObjectUtils::ConnectionViz::Connection
  • InputConnector() : APInputConnector::InputConnector
  • inputExit : MainObject
  • InputPin() : vrecko::InputPin< _MessageType >
  • inputPin : Receiver
  • inputPinsList : vrecko::BaseClass
  • inputPresent() : vrecko::BaseClass
  • inputProjection : MainObject
  • InputRequest : APObjectUtils::ConnectionViz::Connection
  • Insert() : GenericHeap< _NodeClass, _keyType > , VK_NoStepInto_Namespace::DynamicArray< _Type > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • insertEventInterconnection() : vrecko::EventDispatcher
  • insertIndex : AP_CableEditor::CableEditor
  • insertMenuItem() : APMenu::DynamicMenu
  • InsertNode() : DynamicTree< _Type >
  • insertPointsInLODTree() : APSpacePartitioning::PointShell_Object_Data
  • insideStep()
: AP_LSystem::LoftTurtle
, AP_LSystem::StraightPipe
  • installSimple() : Arm
  • instance() : vrecko::Timer
  • Interconnection() : APGUI::Interconnection
  • InterconnectionType : vrecko::EventDispatcher
  • INTERMEDIATE : grass::GrassDrawable
  • internal_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • internalDecrementReaderWriter() : vrecko::PersistentCache
  • internalFindAndLock() : vrecko::PersistentCache
  • internalOpenReadWrite() : vrecko::PersistentCache
  • interPointOfLineAndPerpendicularPlane() : CarSim::RoadsState
  • interpolate()
: AP_CableEditor::Cable
, APDYNAMICART::PerlinLines
, MotionTrailTriangulator
, Interpolator
  • interpolateCatIterate() : AP_CableEditor::Cable
  • interpolateCatPerSegment() : AP_CableEditor::Cable
  • interpolateCrossSection() : MotionTrailTriangulator
  • interpolatedPoints : AP_CableEditor::Cable
  • InterpolatedSpline() : InterpolatedSpline
  • interpolatePoint()
: APDYNAMICART::Utils
, APDYNAMICART::PerlinLines
, CatmullRomInterpolator
  • interpolatePoints() : APDYNAMICART::ComputeThread
  • interpolateVec3() : MotionTrailTriangulator , APDYNAMICART::Utils , APDYNAMICART::PerlinLines
  • interpolation : ArtificialWorld::SubBlockAnimation
  • interpolationsNum : AP_CableEditor::Cable
  • interpolationSteps : APDYNAMICART::InitSettings , CatmullRomInterpolator , LinearInterpolator
  • InterpolationType : APObjectUtils::Animator
  • interpolationType : AP_CableEditor::Cable , APObjectUtils::Animator
  • intersect2Planes() : APEditorQAbilities::ObjectMovement
  • intersectedObjects : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • intersection : APCameraMovement::CameraMovementEditor
  • intersectLinePlane() : APEditorQAbilities::ObjectMovement
  • Interval() : vrecko::Interval< tval, tref >
  • intToStr() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iNumGenCars : CarSim::RoadsState
  • invalidate() : APMenu::MenuItem
  • invalidateFields() : Hci
  • invalidRefToJuncOrPolygPoint : CarSim::RoadsState
  • inverse() : gmMatrix3 , gmMatrix4
  • inverseParentsTransform : APFFDEditor::EditorLogic
  • inverseTransformMatrix : APMenu::DynamicMenu
  • invVisibilityRange : grass::GrassAbilityParameters
  • iObjectUpdatesCounter : vrecko::Scheduler
  • iPointerID : vrecko::CABUTTONEVENT
  • iPolygonsCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iProcessedEventsCounter : vrecko::EventDispatcher
  • iReaders : vrecko::PersistentCache::OpenedCacheFile
  • is : vreckoDP_base::OptiTrack
  • is_initialized : vreckoDP_base::Wiimote
  • isActive()
: APDYNAMICART::DATool
, vrecko::ControllableAbility
  • isAddingPointState : AP_CableEditor::CableEditor
  • isAnimating() : APObjectUtils::Animator
  • IsAverageOf() : grass::Vertex
  • isCable() : AP_CableEditor::CableEditor
  • isCapable()
: AP_LSystem::D0LSystem
, AP_LSystem::ParD0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParStoch0LSystem
  • isCarRegForEdge() : CarSim::RoadsState
  • isCarStopPositionRight() : CarSim::RoadsState
  • isCell : vrecko::OctTree::OctTreeNode
  • isClosed() : BufferedSpline , RegularPolygonSpline , SampledSpline
  • isCollisionFree() : vrecko::EnvironmentObject
  • isConstraintParentOf() : APConstrainedMovement::ConstraintDescription
  • isDeadlock() : CarSim::RoadsState
  • isDefaultStateActive() : APGUI::GUI_Item
  • isDeletingSphereState : AP_CableEditor::CableEditor
  • isDirty()
: APRoomEdit::Tool
, APDYNAMICART::HoopShape
  • isDynamic() : vrecko::Attribute
  • isEffectCreated() : APObjectUtils::ObjectEffect
  • IsEmpty() : FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType >
  • isEmpty() : APDYNAMICART::Controller
  • IsEmpty() : GenericHeap< _NodeClass, _keyType >
  • isEntityPresent() : vrecko::Scheduler
  • isEnumeration() : vrecko::Range
  • isEOF() : vrecko::BufferedFile
  • isEqualTo()
: base::SystemInfo::MessageSIThreadCreated
, vrecko::MessageVoid
, vrecko::VreckoMessage
  • isExpanded() : APMenu::MenuItem
  • IsFinished() : DynamicTreeIterator< _Type >
  • isFreeSpaceForCarGroupOnEdge() : CarSim::RoadsState
  • isGenCar : CarSim::CarExecutionUnit
  • isGraphicsCreated() : APMenu::MenuItem
  • isHierarchyAncestorOf() : ConstraintHierarchyMember
  • isHierarchyCreated()
: APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::SNCH_Object_Data
, vrecko::SP_Object_DataInterface
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::VoxelGrid_Object_Data
  • isInMainThread() : vrecko::EventDispatcher
  • isInsertBetweenState : AP_CableEditor::CableEditor
  • isIntersection() : APSpacePartitioning::NoPartitioning_Scene
  • isInterval() : vrecko::Range
  • isKeyDown() : vreckoDP_base::KeyboardMouse
  • isLoaded() : vrecko::Scene
  • isLowerInclusive() : vrecko::Interval< tval, tref >
  • isMainButtonPressed() : APMenu::DynamicMenu
  • isMenu : APConnectEditor::Cut
  • isMenuCreated() : vrecko::ControllableAbility
  • isMenuVisible() : vrecko::ControllableAbility
  • IsNeighbourEast() : APNature::Terrain2DSegment
  • IsNeighbourNorth() : APNature::Terrain2DSegment
  • IsNeighbourSouth() : APNature::Terrain2DSegment
  • IsNeighbourWest() : APNature::Terrain2DSegment
  • IsNodeAllowed() : DynamicTreeIterator< _Type >
  • isObjectInCell() : vrecko::OctTree
  • isObjectInNode() : vrecko::OctTree
  • isOpened() : vrecko::BenchmarkWriter
  • iSpeed : APCameraPath::Camera
  • isPlaneCompatibleWithSelectedSet() : APEditorQAbilities::ObjectMovement
  • isPointed() : APMenu::MenuItem
  • isRunning() : APDYNAMICART::PhysXManager
  • isSame() : vrecko::CollisionParams__ver1
  • isSameKindAs()
: osgQ::QSection
, grass::GrassDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • isSampled() : APDYNAMICART::BrushStrokeControlPoint
  • isSelectedCable : AP_CableEditor::CableEditor
  • isSelectionLocked() : APMenu::DynamicMenu
  • isShadowsEnabled() : APLightsEditor::Lights
  • isSingular() : gmMatrix4 , gmMatrix3
  • isStatic() : vrecko::Attribute
  • IsSubTreeAllowed() : DynamicTreeIterator< _Type >
  • issueRequests()
: APEditorQAbilities::SimpleObjectMovement
, APConnectEditor::Rotation
, APCameraPath::Camera
, APRoomEdit::RoomEditor
, APConnectEditor::Cut
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APCameraMovement::CameraMovementEditor
  • isSuitable() : SnapObject
  • isThereaSculpture : APDYNAMICART::Ctrl_PolyhedraSculptures
  • isThisControlPoint() : APFFDEditor::EditorLogic
  • isTooSmall() : APDYNAMICART::ComputeThread
  • isUpdated() : vrecko::Ability
  • isUpdateState : AP_CableEditor::Cable
  • isUpperInclusive() : vrecko::Interval< tval, tref >
  • IsValid() : ht::Screen
  • isValidJuncWithTLs() : CarSim::RoadsState
  • isValidName() : APDYNAMICART::PolyhedronFactory
  • isValueInsideRange() : APDYNAMICART::Utils
  • isVisible()
: APDYNAMICART::DAGizmo
, vrecko::EnvironmentObject
, DAGizmo
  • IsVisible() : ArtificialWorld::BlockUpdater
  • isVisible()
: APMenu::MenuItem
, APMenu::DynamicMenu
  • isZero() : gmVector3
  • itemClicked()
: APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::Painted
, APMenu::DynamicMenu
, APDYNAMICART::HoopShape
  • ItemsGroup() : APGUI::ItemsGroup
  • itemSize : APMenu::MenuItem
  • itemSize2 : APMenu::MenuItem
  • itemTree : APMenu::DynamicMenu
  • iterationCount : APDYNAMICART::InitSettings
  • iVerticesCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iWaitingWriters : vrecko::PersistentCache::OpenedCacheFile
  • iWriters : vrecko::PersistentCache::OpenedCacheFile
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • joint_update3() : Arm
  • joint_update6() : Arm
  • jointBckg3() : Arm
  • jointBckg6() : Arm
  • JointedPipe() : AP_LSystem::JointedPipe
  • JuliaAttractor() : APDYNAMICART::JuliaAttractor
  • junctionId : CarSim::PolygonPoint
  • junctions : CarSim::RoadsState
  • justonce
: VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiSphere
, VirtualFixture::ProxiBorder
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- k -

  • k1 : VirtualFixture::Filter
  • k2 : VirtualFixture::Filter
  • KeepOnScreen() : APObjectUtils::KeepOnScreen
  • key : GenericHeap< _NodeClass, _keyType >::GenericHeapNode
  • KeyboardMouse() : vreckoDP_base::KeyboardMouse
  • keydown_map : vreckoDP_base::KeyboardMouse
  • keyPress() : vreckoDP_base::KeyboardMouse
  • keyRelease() : vreckoDP_base::KeyboardMouse
  • keyToString() : vreckoDP_base::KeyboardMouse
  • Kinect() : vreckoDP_Kinect::Kinect
  • KinectThread() : vreckoDP_Kinect::Kinect
  • KMTracker() : navigation::KMTracker
  • KMTracker::sendSensorInfo() : navigation::KMTracker
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • L3DMouse() : vreckoDP_base::L3DMouse
  • label : VirtualFixture::Marker
  • land_level : boids::BoidsLogic
  • large_projection : BehindObstacleExp_wT , BehindObstacleExperiment
  • Last() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • last_absPI : vreckoDP_base::LHeadTracker
  • last_absRO : vreckoDP_base::LHeadTracker
  • last_absYA : vreckoDP_base::LHeadTracker
  • last_avatar_pos : ht::HeadTracking
  • last_method : BehindObstacleExp_wT , BehindObstacleExperiment
  • last_position : behindO::WIM::ObjectCopy
  • last_rot : vreckoDP_base::LHeadTracker
  • last_rotation : behindO::WIM::ObjectCopy
  • last_sensor_orientation
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • last_sensor_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • last_tick
: vrecko::Scheduler::TimerStruct
, vrecko::vThread
, behindO::CentreObjectManipulator
  • last_transform : base::hand , base::MouseHand
  • lastAddedPoint : APConnectEditor::Cut
  • lastAutorotationTime : APDYNAMICART::Ctrl_PerlinLines
  • lastButtonPressed : APEditorController::EditorController::ECPOINTERINFO
  • lastCarId : CarSim::Edge
  • lastCarInEdge : CarSim::Junction
  • lastCarOutEdge : CarSim::Junction
  • lastDominantAxis : MagicWandTool
  • lastEventButtonID : vrecko::ControllableAbility
  • lastFrame : AP_LSystem::TurtleProperties
  • lastInput : Filter::PosNoiseRemover
  • lastJunc : CarSim::First3Juncs
  • lastJuncInPath : CarSim::Parameters
  • lastMatrix : AP_LSystem::TurtleProperties
  • lastPointerPos : APConnectEditor::Rotation , APMenu::DynamicMenu
  • lastPosition : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • lastRelPointerPos : APEditorQAbilities::AvatarMovement
  • lastRelPointerRot : APEditorQAbilities::AvatarMovement
  • lastRequest : vrecko::ScenePSThreadInfo
  • lastResult : Filter::PosNoiseRemover
  • lastSelTest : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • lastTick : CarSim::CarControlUnit
  • lastTimerTick : APObjectUtils::Animator
  • lastUpdatePartThrIndex : vrecko::Scene
  • lastViewPos : APMenu::DynamicMenu
  • lastWrapperTransformation : AP_CableEditor::Cable
  • latestpos : VirtualFixture::Trace
  • Layout() : APGUI::Layout
  • lcm() : vreckoUtils::Math
  • leaf : APSpacePartitioning::VLOD
  • left : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • left_border : behindO::HeadManipulator
  • left_button : vreckoDP_base::L3DMouse
  • left_eye_off : ht::HeadTracking
  • left_hand : base::Avatar , VirtualFixture::Avatar
  • left_leg : base::Avatar , VirtualFixture::Avatar
  • leftBlinkerPath : CarSim::GeometryPartsPath
  • LeftBottom : ht::ScreenSetup
  • leftContext : AP_LSystem::Rule
  • lefthand_id : BehindObstacleExp_wT , BehindObstacleExperiment
  • leftHandEO : APDYNAMICART::DAEnvironment
  • leftHandEO_ID : base::Avatar , VirtualFixture::Avatar
  • LeftTop : ht::ScreenSetup
  • leftWheelsPathVec : CarSim::GeometryPartsPath
  • leftX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • leftY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • leftZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • legalToRemoveEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Length() : mv::CMVect
  • length
: CarSim::CarSize
, CarSim::Edge
, AP_LSystem::TurtleProperties
, AP_LSystem::StaticString
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, AP_LSystem::LongString
, gmVector2
, gmVector3
, gmVector4
  • lengthMultiplier : AP_LSystem::TurtleProperties
  • lengthSquared() : gmVector2 , gmVector3 , gmVector4
  • Lens() : behindO::Lens
  • lerp : gmVector2 , gmVector3 , gmVector4
  • level : APSpacePartitioning::VLOD
  • levels : APSpacePartitioning::PointShell_Object_Data , APSpacePartitioning::SNCH_Object_Data::DebugStats
  • LHeadTracker() : vreckoDP_base::LHeadTracker
  • lhtRead() : vreckoDP_base::LHeadTracker
  • libaryName()
: PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • libraryName()
: osgQ::QSection
, grass::GrassDrawable
  • liesWithinArea() : APConstrainedMovement::ConstraintArea
  • lifetime : PhysXPlugin::Particle
  • lifeTime : APDYNAMICART::ParticleSystemParameters
  • Light() : base::Light
  • light : base::Light
  • LightCloud() : Cloud
  • lightGroup : base::Light
  • lightManager : APLightsEditor::Editor
  • lightMarker : APLightsEditor::Editor
  • lightNumber : base::Light
  • Lights() : APLightsEditor::Lights
  • limit_speed() : boids::BoidsLogic
  • limitPosition() : APGUI::ColorPicker
  • limitToEO1 : vrecko::ScenePSThreadInfo
  • limitToEO2 : vrecko::ScenePSThreadInfo
  • line : LoadingConsole::OutstandingLine
  • Line() : LoadingConsole::Line
  • line_distance : gmVector3
  • Linear : APObjectUtils::Animator , Filter::Linear
  • linearAttenuation : base::Light
  • LinearMapping() : APNature::TerrainUtility
  • lineHeight : LoadingConsole
  • lines : APTextOutput::Console , LoadingConsole
  • linesInter2D() : CarSim::RoadsState
  • linesIntersection() : APGUI::ColorPicker
  • lineSpace : APTextOutput::Console , LoadingConsole
  • Link() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • listDirectory() : APDYNAMICART::DAEnvironment
  • ListDirectory() : APNature::TerrainUtility
  • LMD_HASH : APSpacePartitioning::SNCH_Object
  • lmd_store : APSpacePartitioning::SNCH_Object
  • lmd_store_access : APSpacePartitioning::SNCH_Object
  • LMD_STORE_MAP : APSpacePartitioning::SNCH_Object
  • LMDs : APSpacePartitioning::SNCH_Object::LMDStore
  • LMDStore() : APSpacePartitioning::SNCH_Object::LMDStore
  • LMDswitch : APSpacePartitioning::SNCH_Object::LMDStore
  • LMDvector : APSpacePartitioning::SNCH_Object
  • load()
: APDYNAMICART::Attractor
, APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ConstantDiamAdapter
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::HookObject
, APDYNAMICART::HookManager
, APDYNAMICART::Hoop
, APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PerlinLines
, APDYNAMICART::PoA
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::PS_Symmetry
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::SectorManager
, APDYNAMICART::PoAAdapter< T >
, Icon
, APDYNAMICART::PoB
  • Load() : mv::Reader
  • loadAbilities() : vrecko::ReaderWriter
  • LoadAndInitiate() : CloudsManager
  • LoadAnimation() : APCameraPath::Camera
  • loadAttributes() : APMenu::DynamicMenu
  • loadCables() : AP_CableEditor::CableEditor
  • loadCfgFile() : AP_LSystem::Configuration
  • loadCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • loadCollisionsFromFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • loadDataFromFile() : APSpacePartitioning::PointShell_SimpleNode
  • loadDataFromPC_LoadTreeNode() : APSpacePartitioning::SphereBVH_Object_Data
  • loadDataFromPersistentCache_Init()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • loadDataFromPersistentCache_ReadData() : APSpacePartitioning::SphereBVH_Object_Data
  • loadDevice() : vrecko::ReaderWriter
  • loadedObjects : Preloader
  • loadedShapes : AP_CableEditor::CableEditor
  • loadEnvironmentObject() : vrecko::ReaderWriter
  • loadEvent() : vrecko::ReaderWriter
  • loadFacesFromFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • loadFile()
: AP_LSystem::AbstractGenerator
, AP_LSystem::LSystemGenerator
  • loadFromCache()
: APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • loadFromFile : CloudsProperties , AP_LSystem::AbstractLSystem , AP_LSystem::LSystem
  • LoadFromFile() : CloudsManager
  • loadfromXML() : APDYNAMICART::PS_Polyhedron
  • loadfromXMLnode() : APGUI::Layout
  • loadGeometry()
: vrecko::EnvironmentObject
, APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • loadGeometryHelper()
: APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • loadGeometryParts() : CarSim::CarExecutionUnit
  • loadGridFromFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • LoadingConsole() : LoadingConsole
  • LoadingFunctionFinnished() : Preloader
  • loadingQueue : Preloader
  • loadJuncPolyRoad() : CarSim::RoadsState
  • loadJunction() : CarSim::RoadsState
  • loadMenuItems() : APMenu::DynamicMenu
  • loadMenuStructureFromNode() : APMenu::DynamicMenu
  • LoadMesh() : WAVEFRONT::OBJ
  • loadModel() : vrecko::PersistentCache
  • loadMultipleFiles() : vrecko::ReaderWriter
  • loadNodeFromFileRec() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • loadObj() : WavefrontObj
  • loadObjectFullMatrix() : APConstrainedMovement::ConstrainedObjectMovement
  • loadObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • loadOld() : vrecko::ReaderWriter
  • loadParametersFromNode()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • loadPolygonPoint() : CarSim::RoadsState
  • loadRoad() : CarSim::RoadsState
  • loadsave_category : vrecko::ReaderWriter
  • loadsave_Mutex : vrecko::ReaderWriter
  • loadsave_position : vrecko::ReaderWriter
  • loadScene() : vrecko::ReaderWriter
  • loadShapes() : AP_CableEditor::CableEditor
  • loadSignsFromXML() : APMenu::DynamicMenu
  • loadSubDivisionMeshFromFile() : APSpacePartitioning::PointShell_Object_Data
  • loadTLparameters() : CarSim::RoadsState
  • loadTreeFromFile() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • loadTreeNodeFromFile()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • loadVerticesFromFile()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::GeometryLoaderBase
  • loadVirtualEnvironment() : vrecko::ReaderWriter
  • loadWordFromFile() : AP_LSystem::AbstractGenerator
  • loadXMLDocument() : vrecko::ReaderWriter
  • loadXMLFile() : APConstrainedMovement::ConstraintDescription , ConstraintHierarchyMember
  • loadXMLMaterial() : PhysXPlugin::MaterialManager
  • loadXMLParameters()
: APObjectUtils::ObjectModif
, APSpacePartitioning::PointShell_Object_Data
, PhysXPlugin::Box
, APSpacePartitioning::VoxelGrid_Object_Data
, vreckoDP_base::OptiTrack
, base::Light
, base::Rotate
, base::ShowFDH
, vreckoDP_base::VRPN3DMouse
, vrecko::BaseClass
, vreckoDP_Kinect::Kinect
, vreckoDP_base::NestOfBirds
, Cache
, ArtificialWorld::WorldBuilder
, BehindObstacleExp_wT
, VirtualFixture::ProxiCone
, vreckoDP_base::L3DMouse
, VirtualFixture::Drag
, VirtualFixture::NavSphere
, behindO::HeadManipulator
, behindO::WIM
, APObjectUtils::ObjectSelector
, APRoomEdit::RoomSaver
, VirtualFixture::Box
, boids::BoidsLogic
, boids::BoidsPlanner
, PhysXPlugin::RevoluteJoint
, PhysXPlugin::PulleyJoint
, APCameraMovement::CameraPath
, APSpacePartitioning::GeometryLoaderBase
, CarSim::CarControlUnit
, PhysXPlugin::Fluid
, CarSim::RoadsState
, PHEffect
, PhysXPlugin::Capsule
, APRoomEdit::WallMovement
, APConnectEditor::Cut
, APConnectEditor::Rotation
, APConstrainedMovement::ConstraintDescription
, vreckoDP_base::LHeadTracker
, APRoomEdit::WallAdd
, APDYNAMICART::Ctrl_FreeHandPainting
, APRoomEdit::WallRemove
, APRoomEdit::WallGeometry
, APDYNAMICART::Ctrl_PerlinLines
, ode::CappedCylinder
, APFFDEditor::EditorLogic
, ode::Sphere
, APFFDEditor::GeometryLoaderBase
, VirtualFixture::Trace
, APObjectUtils::ObjectEffectMan
, APObjectUtils::KeepOnScreen
, Filter::Linear
, navigation::KMTracker
, grass::GrassAbilityParameters
, APClouds::Clouds
, APRoomEdit::PointMove
, ChessBoard
, APRoomEdit::RoomLoader
, APRoomEdit::ColorBucket
, APLightsEditor::Lights
, APMenu::DynamicMenu
, ode::Cube
, CarSim::CarExecutionUnit
, AP_LSystem::LSObject
, APObjectUtils::Animator
, APObjectUtils::ConnectionViz
, APObjectUtils::CopyProperties
, PHANToMAvatar
, APObjectUtils::ObjectEffect
, ode::CompositeObject
, APRoomEdit::CreateHole
, APHUD::HUDDisplay
, VirtualFixture::Vibration
, APRoomEdit::Tool
, navigation::AvatarInHand
, grass::Grass
, APTextOutput::Console
, VirtualFixture::VibrationLabelActivator
, APDYNAMICART::DAEnvironment
, VirtualFixture::ProxiCylinder
, PhysXPlugin::BaseActor
, PhysXPlugin::BasePhysXObject
, ChessPiece
, Filter::PosNoiseRemover
, PhysXPlugin::DistanceJoint
, VirtualFixture::Sphere
, APConnectEditor::ConnectEditor
, VirtualFixture::Plane
, PhysXPlugin::PointOnLineJoint
, APDYNAMICART::Ctrl_MotionVisualization
, ConstraintHierarchyMember
, VirtualFixture::AxisLock
, PhysXPlugin::PrismaticJoint
, VirtualFixture::ProxiBox
, vrecko::World
, boids::Boid
, VirtualFixture::MarkerFactory
, VirtualFixture::Grid
, VirtualFixture::Marker
, PhysXPlugin::Sphere
, APCameraPath::Camera
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiSphere
, ArtificialWorld::BlockUpdater
, VirtualFixture::Damper
, VirtualFixture::Cylinder
, PhysXPlugin::SphericalJoint
, VirtualFixture::Filter
, VirtualFixture::VibrationLabel
, behindO::HMDHeadManipulator
, BehindObstacleExperiment
, VirtualFixture::Log
, base::Avatar
, VirtualFixture::Cone
, vrecko::BaseClass
, base::SystemInfo
, VirtualFixture::Avatar
, PhysXPlugin::BaseJoint
, VirtualFixture::Border
, PhysXPlugin::RemoteDebugger
, PhysXPlugin::Cloth
, PhysXPlugin::Plane
, Icon
, PhysXPlugin::PointInPlaneJoint
, PhysXPlugin::FixedJoint
, PhysXPlugin::PhysXScene
, PhysXPlugin::ForceField
, vrecko::MaterialDesc
, PhysXPlugin::CoreActorDesc
, PhysXPlugin::CylindricalJoint
  • LoadXMLParametersFromFile() : ArtificialWorld::BlockUpdater
  • localForm() : StrX
  • localSearch() : APSpacePartitioning::SNCH_Object
  • located_object : behindO::CentreObjectManipulator
  • location : ChessBoard::Request
  • lock() : vrecko::MTLock
  • lockCount : CarSim::JuncsEdge
  • locked : VirtualFixture::AxisLock
  • lockEOMapForRead() : vrecko::Scene
  • lockEOMapForWrite() : vrecko::Scene
  • lockHigh() : vrecko::MTTwoPrioLimitedLock
  • lockJuncsEdgesForNewCar() : CarSim::RoadsState
  • lockLow() : vrecko::MTTwoPrioLimitedLock
  • lockRead()
: vrecko::MTReadWriteLock
, vrecko::MTReadWriteLockEx
  • lockWrite()
: vrecko::MTReadWriteLockEx
, vrecko::MTReadWriteLock
  • LOD : grass::GrassDrawable
  • LOD_Hierarchy : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • lodEdgeDistanceImporatnce : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • lodEdgeDistanceImportance : APSpacePartitioning::PointShell_Object_Data
  • lodEdgeImporatnce : APSpacePartitioning::PointShell_Object_Data_LOD_Builder , APSpacePartitioning::PointShell_Object_Data
  • lodMaxLevels : APSpacePartitioning::PointShell_Object_Data
  • lodMinimumVertices : APSpacePartitioning::PointShell_Object_Data
  • lodMovableVertices : APSpacePartitioning::PointShell_Object_Data
  • lodPercentageZeroLevelSize : APSpacePartitioning::PointShell_Object_Data
  • lodVertexImporatnce : APSpacePartitioning::PointShell_Object_Data_LOD_Builder , APSpacePartitioning::PointShell_Object_Data
  • lodZeroLevelSize : APSpacePartitioning::PointShell_Object_Data
  • LoftTurtle() : AP_LSystem::LoftTurtle
  • Log() : VirtualFixture::Log
  • log_file : vrecko::Logger
  • Logger() : vrecko::Logger
  • logger_streambuf() : vrecko::logger_streambuf
  • logHierarchy() : vrecko::Scene
  • logHierarchyDrawableHelper() : vrecko::Scene
  • logHierarchyHelper() : vrecko::Scene
  • logTime : APTextOutput::Console::Line
  • LongString() : AP_LSystem::LongString
  • look_at_center
: behindO::EyeManipulator
, vrecko::World::AvatarView
, behindO::HeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • looping : ArtificialWorld::SubBlockAnimation
  • looptime1 : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • looptime2 : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • loopType : APObjectUtils::Animator
  • LoopType : APObjectUtils::Animator
  • lowBoundForStartStopPosOffset : CarSim::Edge
  • lowClipPlane : SliceTool , APDYNAMICART::ToolSlice , APDYNAMICART::PLControllerTool
  • lowDetailGrassStateSet : grass::GrassAbilityParameters
  • LowerCase() : APNature::TerrainUtility
  • lpBuffer : vrecko::BufferedFile , VK_NoStepInto_Namespace::DynamicArray< _Type >
  • lpChild : DynTreeNode< _Type >
  • lpNext : DynTreeNode< _Type >
  • lpParent : DynTreeNode< _Type >
  • lpPrev : DynTreeNode< _Type >
  • lpRoot : DynamicTree< _Type >
  • LS_BYTE : AP_LSystem::Parameter
  • LS_DOUBLE : AP_LSystem::Parameter
  • LS_FLOAT : AP_LSystem::Parameter
  • LS_INT : AP_LSystem::Parameter
  • LS_UBYTE : AP_LSystem::Parameter
  • LS_UINT : AP_LSystem::Parameter
  • LSFile() : AP_LSystem::LSFile
  • LSGeode() : AP_LSystem::LSGeode
  • LSObject() : AP_LSystem::LSObject
  • LSystem() : AP_LSystem::LSystem
  • LSystemException() : AP_LSystem::LSystemException
  • LSystemGenerator() : AP_LSystem::LSystemGenerator
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • m_ : gmMatrix3 , gmMatrix4
  • m_Access : vrecko::MTTwoPrioLimitedLock , vrecko::MTReadWriteLock
  • m_ActPathLine : APCameraPath::Camera
  • m_ActViewLine : APCameraPath::Camera
  • m_AllowLowPrio : vrecko::MTTwoPrioLimitedLock
  • m_Axiom : AP_LSystem::AbstractFile
  • m_CanRead : vrecko::MTReadWriteLock
  • m_CanWrite : vrecko::MTReadWriteLock
  • m_ControlPoints : APCameraPath::Camera
  • m_eAnimate : APCameraPath::Camera
  • m_eState : APCameraPath::Camera
  • m_Geodes : AP_LSystem::AbstractInterpret
  • m_Homomorphisms : AP_LSystem::LSystem , AP_LSystem::AbstractFile
  • m_Ignore : AP_LSystem::LSystem
  • m_Iteration : AP_LSystem::AbstractLSystem
  • m_Length : AP_LSystem::ParseableString
  • m_MainLSystem : AP_LSystem::AbstractGenerator
  • m_Name : AP_LSystem::AbstractFile , AP_LSystem::AbstractLSystem
  • m_numOfViewPts : APCameraPath::Camera
  • m_Owner : AP_LSystem::AbstractInterpret
  • m_pEOCamera : APCameraPath::Camera
  • m_pEOCursor : APCameraPath::Camera
  • m_pEOPathLine : APCameraPath::Camera
  • m_pEOPathPoints : APCameraPath::Camera
  • m_pEOViewLine : APCameraPath::Camera
  • m_Readers : vrecko::MTReadWriteLock
  • m_Rules : AP_LSystem::LSystem , AP_LSystem::AbstractFile
  • m_Str : AP_LSystem::ParseableString
  • m_SubSystemsFilenames : AP_LSystem::LSystem
  • m_SubSystemsWords : AP_LSystem::LSystem
  • m_Subsytems : AP_LSystem::AbstractFile
  • m_Turtles : AP_LSystem::AbstractInterpret
  • m_Type : AP_LSystem::AbstractFile
  • m_Word : AP_LSystem::AbstractGenerator , AP_LSystem::LSystem
  • m_WriterMutex : vrecko::MTReadWriteLock
  • m_WritersMutex : vrecko::MTTwoPrioLimitedLock
  • MagicWandTool() : MagicWandTool
  • magnetCreated : APDYNAMICART::Ctrl_PerlinLines
  • magnetEO : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • magnetGeode : APDYNAMICART::PerlinLines
  • magnetMaterial : APDYNAMICART::PerlinLines
  • magnetStateSet : APDYNAMICART::PerlinLines
  • main_wiimote : vreckoDP_base::Wiimote
  • mainButtonPressed() : APMenu::DynamicMenu
  • mainButtonReleased() : APMenu::DynamicMenu
  • mainLightSource : vrecko::World
  • mainLock : vrecko::AbilityDispatcher , vrecko::EventDispatcher
  • mainNode : LoadingConsole
  • mainObject : APMenu::DynamicMenu
  • MainObject() : MainObject
  • MainSceneUpdateCallback() : MainSceneUpdateCallback
  • mainTransform : APMenu::MenuItem
  • makeInstances() : APDYNAMICART::PS_Symmetry
  • makeMenu()
: APLightsEditor::Editor
, AP_CableEditor::CableEditor
, APCameraPath::Camera
  • makeMovementMenu() : APCameraPath::Camera
  • makeRotate() : AP_LSystem::MovingTurtle
  • makeRotations() : APDYNAMICART::PS_Symmetry
  • ManageCulling() : grass::GrassDrawable
  • manipulate : base::hand , base::MouseHand
  • Manipulator() : behindO::Manipulator
  • mappedAbility : APEditorController::AbilityMapper::BUTTON_MAPPING
  • mappedAbilityID : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • mapping : APEditorController::AbilityMapper
  • MappingFunctions() : behindO::MappingFunctions
  • mark : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • Marker() : VirtualFixture::Marker
  • MarkerFactory() : VirtualFixture::MarkerFactory
  • markers : VirtualFixture::MarkerFactory
  • matchLeft() : AP_LSystem::LongString
  • matchRight() : AP_LSystem::LongString
  • MatIndex() : vrecko::MaterialDesc
  • matrix : base::MTMatrixTransform , AP_LSystem::TurtleProperties
  • max : AABoundingBox , APDYNAMICART::Trait
  • max_analog : Hci
  • max_bound : boids::BoidsLogic
  • max_encoder : Hci
  • max_force : APSpacePartitioning::SNCH_Object
  • max_speed : boids::BoidsLogic
  • max_timer : Hci
  • maxAcc : CarSim::CarState
  • maxArea : grass::GrassAbilityParameters
  • maxBend : grass::GrassAbilityParameters
  • maxButtonsPerPointer : APEditorController::EditorController
  • maxChildrens : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxCloudUpdatesParFrame : CloudsProperties
  • maxCollisionDistance : vrecko::CollisionParams__ver1
  • maxDispWheelAngle : CarSim::CarExecutionUnit
  • maxDist : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • maxDistance : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxDistanceV1 : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • maxDistanceV2 : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • maxDistVect : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • maxFractions : grass::GrassAbilityParameters
  • maxHeight : grass::GrassAbilityParameters
  • maxJuncId : CarSim::RoadsState
  • maxLevel : base::ShowFDH
  • maxLevels : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxLODdifference : grass::GrassAbilityParameters
  • maxPointers : APEditorController::EditorController
  • maxPolygonPointId : CarSim::RoadsState
  • maxSize : MemoryWriteBuffer
  • maxSpeed : CarSim::CarExecutionUnit
  • maxValue : APHUD::HUDField
  • maxVisibility : grass::GrassAbilityParameters
  • maxVisibleDistance : ArtificialWorld::Model , ArtificialWorld::SubBlock
  • maxWidth : grass::GrassAbilityParameters
  • maxX : APDYNAMICART::Limits
  • maxY : APDYNAMICART::Limits
  • maxZ : APDYNAMICART::Limits
  • mean : APDYNAMICART::Trait
  • MemoryReadBuffer() : MemoryReadBuffer
  • MemoryWriteBuffer() : MemoryWriteBuffer
  • Menu()
: APGUI::Menu
, vreckoUtils::Menu
  • menu : vrecko::ControllableAbility
  • menuAwayTime : APTextOutput::Console
  • menuBoxes_CalcItemDisplayIndex() : APMenu::MenuItem
  • menuGrid_columnsCached : APMenu::DynamicMenu
  • menuGrid_getSize() : APMenu::DynamicMenu
  • menuGrid_rowsCached : APMenu::DynamicMenu
  • MenuItem
: APMenu::DynamicMenu
, APMenu::MenuItem
, vreckoUtils::MenuItem
  • menuItemClicked()
: AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Cut
, APConnectEditor::PolygonState
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AnimatorEditor
, APEditorQAbilities::ObjectAdd
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::SceneSave
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
  • MenuItemNull() : APMenu::MenuItemNull
  • MenuItemSlider() : APMenu::MenuItemSlider
  • MenuItemText() : APMenu::MenuItemText
  • MenuLoaderErrorHandler() : APMenu::MenuLoaderErrorHandler
  • menuRadial_CalcItemAngle() : APMenu::MenuItem
  • MenuRoot() : vreckoUtils::MenuRoot
  • menuShowed : APCameraMovement::CameraMovementEditor
  • MenuSlider() : vreckoUtils::MenuSlider
  • menuSliderChanged()
: AP_CableEditor::CableEditor
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, vrecko::ControllableAbility
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
  • MenuSliderChanged() : APNature::TerrainAbility
  • menuString : APMenu::DynamicMenu
  • menuType : APMenu::DynamicMenu
  • MenuVisitor() : vreckoUtils::MenuVisitor
  • Merge() : BinomialHeap< _NodeClass, _keyType >
  • mergeCloseJunctions() : CarSim::RoadsState
  • mergeFiles() : vrecko::ReaderWriter
  • mergeLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • mergeObject() : SnapObject
  • mesg
: boids::BoidsLogic
, boids::BoidsPlanner
, navigation::AvatarInHand
, navigation::KMTracker
  • mesh : grass::GrassDrawable
  • Mesh() : grass::Mesh
  • message : vrecko::EventDispatcher::EventStruct , AP_LSystem::LSystemException
  • MessageCarEdge() : CarSim::MessageCarEdge
  • MessageCarEdgeData() : CarSim::MessageCarEdgeData
  • MessageCarEnvirons() : CarSim::MessageCarEnvirons
  • MessageCarSimParameters() : CarSim::MessageCarSimParameters
  • MessageCarStatePtr() : CarSim::MessageCarStatePtr
  • MessageEdgeOffset() : CarSim::MessageEdgeOffset
  • MessageFirst3Juncs() : CarSim::MessageFirst3Juncs
  • MessageNxActorWithName() : PhysXPlugin::MessageNxActorWithName
  • MessageRoadAndDir() : CarSim::MessageRoadAndDir
  • MessageSensorTransformation() : vrecko::MessageSensorTransformation
  • MessageSIThreadCreated() : base::SystemInfo::MessageSIThreadCreated
  • MessageStartStopDestination() : CarSim::MessageStartStopDestination
  • MessageVectorUnsignedInt() : CarSim::MessageVectorUnsignedInt
  • MessageVoid() : vrecko::MessageVoid
  • META_DAObject() : SampledSpline , APDYNAMICART::WaveSplineAdapter , APDYNAMICART::HandFrameAdapter , APDYNAMICART::ConstantDiamAdapter , APDYNAMICART::ConstantColorAdapter , APDYNAMICART::GradientColorAdapter , APDYNAMICART::GradientDiamAdapter , APDYNAMICART::RMFrameAdapter , APDYNAMICART::AxisFrameAdapter , SectorColorGen , APDYNAMICART::RoundedSplineAdapter , APDYNAMICART::RectangularSplineAdapter , BufferedSpline , CatmullRomInterpolator , ConstantColorGen , GradientColorGen , GradientDiameterGen , LinearInterpolator , RegularPolygonSpline
  • META_DAObjectDecorator() : SmoothedSpline , TimeLineSpline , FilletSpline , InterpolatedSpline
  • META_HoopShapeObject()
: APDYNAMICART::Line
, APDYNAMICART::Rectangle
, APDYNAMICART::Ellipse
, APDYNAMICART::RegularPolygon
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::Painted
  • META_Node() : APDYNAMICART::PatternsGeode , SweepSurfaceGeode
  • META_Object() : AllCloudsUpdateCallBack
  • method_board : BehindObstacleExp_wT , BehindObstacleExperiment
  • method_desc : BehindObstacleExp_wT , BehindObstacleExperiment
  • methodForProcessing : vrecko::InputPin< _MessageType > , vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • MicroScribe3D() : vreckoDP_base::MicroScribe3D
  • middle_button : vreckoDP_base::L3DMouse
  • MidpointDisplacementAlgorithm() : APNature::MidpointDisplacementAlgorithm
  • min : ThinHeap< _NodeClass, _keyType > , APFFDEditor::GeometryLoaderBase::FaceBase , AABoundingBox , APDYNAMICART::Trait , FibonacciHeap< _NodeClass, _keyType > , APSpacePartitioning::GeometryLoaderBase::FaceBase
  • min_bound : boids::BoidsLogic
  • minAcc : CarSim::CarState
  • minBend : grass::GrassAbilityParameters
  • mIndices : WavefrontObj
  • mindistance : VirtualFixture::Trace
  • minFractions : grass::GrassAbilityParameters
  • minHeight : grass::GrassAbilityParameters
  • minimal_distance : behindO::HeadManipulator
  • MINIMIZE_TWIST : AP_LSystem::TurtleProperties
  • minSpeed : CarSim::CarExecutionUnit
  • minspeed : VirtualFixture::Damper
  • minValue : APHUD::HUDField
  • minVertices : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • minVisibility : grass::GrassAbilityParameters
  • minVisibleDistance : ArtificialWorld::Model
  • minWidth : grass::GrassAbilityParameters
  • minX : APDYNAMICART::Limits
  • minY : APDYNAMICART::Limits
  • minZ : APDYNAMICART::Limits
  • Mirror() : behindO::Mirror
  • mirror_object : behindO::MyCullCallback
  • mirror_plane_transf : behindO::Mirror
  • mirror_plane_vertices : behindO::Mirror
  • mixed_mult() : gmMatrix4
  • mNormal : WAVEFRONT::GeometryVertex
  • mode : behindO::HeadManipulator
  • Model() : ArtificialWorld::Model
  • model : APMenu::MenuItemText
  • model_name : Hci
  • modelFile : APMenu::MenuItemText , AP_LSystem::TurtleProperties
  • modelFileName : vrecko::EnvironmentObject
  • modelFlags : ArtificialWorld::Model
  • modelTransform : APMenu::MenuItemText
  • modelType : ArtificialWorld::Model , CacheInfo
  • mon_cor_position : ht::SimpleSetupFunction , ht::ScreenSetupSimple::ScreenSetupSimpleState
  • monitor_corner : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • monitor_orientation : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • monitor_position : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • moreDetailedVersion : grass::GrassDrawable
  • MotionTrail() : APDYNAMICART::MotionTrail
  • MotionTrailTriangulator() : MotionTrailTriangulator
  • mouse_button : vreckoDP_base::KeyboardMouse
  • mouse_pos : navigation::KMTracker
  • mouse_position : base::MouseHand , vreckoDP_base::KeyboardMouse
  • mouse_scroll : navigation::KMTracker
  • mouse_sensitivity_avatar : navigation::KMTracker
  • mouse_sensitivity_hands : navigation::KMTracker
  • mouse_stand_button : vreckoDP_base::L3DMouse
  • MouseHand() : base::MouseHand
  • mouseMotion() : vreckoDP_base::KeyboardMouse
  • mouseScroll() : vreckoDP_base::KeyboardMouse
  • mouseUpdateCounter : vreckoDP_base::KeyboardMouse
  • Movable : mv::CPoint , mv::CGesture
  • move : ChessPiece
  • move_direction : navigation::KMTracker
  • move_factor : boids::BoidsLogic
  • move_plane : navigation::KMTracker
  • move_step : ChessPiece , navigation::KMTracker
  • moveForward()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • moveForwardHalf()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • moveLock : APFFDEditor::EditorLogic
  • moveTarget() : APShootingSimulation::ShootingSimulation
  • moveVerticesPosition : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • moving : navigation::KMTracker
  • movingObjectID
: APConnectEditor::Rotation
, APEditorQAbilities::SimpleObjectMovement
, APEditorQAbilities::ObjectMovement
, APConstrainedMovement::ConstrainedObjectMovement
, APConnectEditor::Scale
, APCameraPath::Camera
  • mPos : WAVEFRONT::GeometryVertex
  • mPost : vrecko::PyAbility
  • mProcessEvent : vrecko::PyAbility
  • MTAutoLock() : vrecko::MTAutoLock
  • MTBrush() : MTBrush
  • MTCreatorTool() : MTCreatorTool
  • mTexCoords : WavefrontObj
  • mTexel : WAVEFRONT::GeometryVertex
  • MTLock() : vrecko::MTLock
  • MTMatrixTransform() : base::MTMatrixTransform
  • MTReadWriteLock() : vrecko::MTReadWriteLock
  • MTReadWriteLockEx() : vrecko::MTReadWriteLockEx
  • mTriCount : WavefrontObj
  • MTTwoPrioLimitedLock() : vrecko::MTTwoPrioLimitedLock
  • mul4x4() : Arm
  • multiplyAngle()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • multiplyGravitropismElasticity()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • multiplyLength()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • multiplyRadius()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • multiplyTropismElasticity()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • mUpdate : vrecko::PyAbility
  • mutex : vrecko::MTLock
  • mVertexCount : WavefrontObj
  • mVertices : WavefrontObj
  • MyAbility() : APHelloWorld::MyAbility
  • mycomparisonMaxMin() : APSpacePartitioning::mycomparisonMaxMin
  • mycomparisonMinMax() : APSpacePartitioning::mycomparisonMinMax
  • MyCullCallback() : behindO::MyCullCallback
  • MyUpdateCallback() : behindO::MyUpdateCallback
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • Name() : vrecko::MaterialDesc
  • name
: base::SystemInfo::MessageSIThreadCreated
, vrecko::Ability::ParameterStruct
, APMenu::MenuItem
, APRoomEdit::Tool
, vrecko::EnvironmentObject
, AP_LSystem::AbstractFile
, base::SystemInfo::SIThreadInfo
, APHUD::HUDField
, APHUD::HUDWindow
  • NavSphere() : VirtualFixture::NavSphere
  • ncoeficient : APSpacePartitioning::SNCH_Object
  • Near : CloudSceneInfo
  • near_border : behindO::HeadManipulator
  • necessaryTime : APTextOutput::Console::Line
  • NestOfBirds() : vreckoDP_base::NestOfBirds
  • net_support : vrecko::EventDispatcher
  • neutralColor : grass::GrassAbilityParameters
  • new_cerr : vrecko::Logger
  • new_cout : vrecko::Logger
  • new_mouse_pos_ready : vreckoDP_base::KeyboardMouse
  • new_position : ChessBoard::Request
  • newHandPosition : APDYNAMICART::ToolMagicWand , MagicWandTool
  • newOrientation : MTCreatorTool
  • newPoint : AP_CableEditor::CableEditor
  • newPosition : MTCreatorTool
  • next() : AP_LSystem::ParseableString
  • next_free_clipping_plane : behindO::CuttingPlane
  • next_waypoint : boids::BoidsLogic
  • next_waypoint_dist : boids::BoidsLogic
  • nextAttributePtr()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • nextCarDist : CarSim::CarEnvirons
  • nextCarVel : CarSim::CarEnvirons
  • nextEdgeId : CarSim::JuncsEdge
  • nextFreeID : vrecko::Scene
  • nextIteration()
: AP_LSystem::AbstractGenerator
, AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
, AP_LSystem::LSystemGenerator
  • nextJunc : CarSim::First3Juncs
  • nextJuncTurn : CarSim::CarControlUnit , CarSim::CarEnvirons
  • nextNextJunc : CarSim::First3Juncs
  • nextValue() : vrecko::Enumeration< tval, tref >
  • nic : BehindObstacleExp_wT::ExperimentRec , BehindObstacleExperiment::ExperimentRec
  • NO : APLightsEditor::Lights
  • NO_HCI_handler : Hci
  • node
: VirtualFixture::Trace
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
  • node2
: VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::Sphere
  • nodeMask : ArtificialWorld::AnimationPoint , APObjectUtils::Animator::AnimationPoint
  • nodeMaskSet : ArtificialWorld::AnimationPoint
  • nodePtr : DynamicTreeIterator< _Type >
  • nodes_count : vrecko::ReaderWriter
  • nodeStart : DynamicTreeIterator< _Type >
  • NodeTriangle()
: WAVEFRONT::GeometryInterface
, WAVEFRONT::BuildMesh
  • NoIntersection : APSpacePartitioning::SNCH_Object
  • Noise1D() : PseudoRand2DPlacement
  • NoLoop : APObjectUtils::Animator
  • None : APObjectUtils::ObjectEffect
  • NONE : APLightsEditor::Lights
  • nonlinear : behindO::MappingFunctions
  • NoPartitioning_Scene() : APSpacePartitioning::NoPartitioning_Scene
  • norm
: APSpacePartitioning::PointShell_Object_Data_Geometry::V
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
, APSpacePartitioning::PLOD
, APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • normal
: APFFDEditor::GeometryLoaderBase::FaceBase
, APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, Triangle
, grass::Vertex
, CarSim::CarState
, APFFDEditor::GeometryLoaderBase::VertexBase
, APSpacePartitioning::GeometryLoaderBase::VertexBase
, APSpacePartitioning::GeometryLoaderBase::FaceBase
, APSpacePartitioning::SNCH_Object::InternalPointStruct
, CarSim::Edge
  • normalize() : gmVector4 , gmVector2 , gmVector3
  • noticeLog()
: vrecko::Logger
, vrecko::World
  • NOTIFICATION_ALL : vrecko::BaseClass
  • NOTIFICATION_DELETE_CLASS : vrecko::BaseClass
  • NOTIFICATION_EO_REGISTERING : vrecko::BaseClass
  • NOTIFICATION_EO_UNREGISTERING : vrecko::BaseClass
  • NOTIFICATION_PROGRAM_TERMINATION : vrecko::BaseClass
  • notifications : vrecko::BaseClass
  • notificationsLock : vrecko::BaseClass
  • NotificationTypes : vrecko::BaseClass
  • notificationTypes : vrecko::BaseClass::NOTIFICATION_DESCRIPTION
  • notify()
: APDYNAMICART::Ctrl_StringSculptures
, vreckoUtils::Observer
  • notifyObservers() : vreckoUtils::Observable
  • nowAutorotationTime : APDYNAMICART::Ctrl_PerlinLines
  • NullAttractor() : APDYNAMICART::NullAttractor
  • nullradius
: VirtualFixture::Cone
, VirtualFixture::AxisLock
, VirtualFixture::Cylinder
, VirtualFixture::Grid
, VirtualFixture::Plane
, VirtualFixture::Sphere
  • nullsize : VirtualFixture::Box
  • num_bytes_needed : packet_rec
  • num_of_markers : VirtualFixture::MarkerFactory , VirtualFixture::Trace
  • num_sensors : vreckoDP_base::fdtDataGlove
  • NumberOfAnimantionPoints() : ArtificialWorld::SubBlockAnimation
  • numberOfCPoints : APFFDEditor::EditorLogic
  • numLanes : CarSim::Edge
  • numOfClouds : CloudsProperties
  • numOfNonTermEdges : CarSim::RoadsState
  • numRuns : vrecko::Logger::TimingInfo
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • objAABox : APEditorQAbilities::ObjectMovement
  • objAABoxTrans : APEditorQAbilities::ObjectMovement
  • object : ode::DynamicScene::MessageODERequest
  • object1 : APEditorQAbilities::AbilityEditor
  • object1ID : APEditorQAbilities::AbilityEditor
  • object2 : APEditorQAbilities::AbilityEditor
  • object2ID : APEditorQAbilities::AbilityEditor
  • object_count : vrecko::OctTree::OctTreeNode
  • Object_Pair : ode::DynamicScene
  • ObjectAdd() : APEditorQAbilities::ObjectAdd
  • objectChanged() : vrecko::OctTree
  • objectClass : SNCH_THREAD_START_INFO
  • ObjectDelete() : APEditorQAbilities::ObjectDelete
  • objectEffect : APObjectUtils::ObjectEffectMan , APObjectUtils::ObjectSelector
  • ObjectEffect() : APObjectUtils::ObjectEffect
  • objectEffect : APEditorQAbilities::ObjectMovement
  • ObjectEffectMan() : APObjectUtils::ObjectEffectMan
  • objectID
: APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, APObjectUtils::ObjectEffectMan
, APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
, APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
, APSpacePartitioning::PointShellVSVoxel_Object
  • ObjectInfo() : APObjectUtils::ObjectInfo
  • ObjectModif() : APObjectUtils::ObjectModif
  • ObjectMovement() : APEditorQAbilities::ObjectMovement
  • objects : vrecko::Scene::EOIteratorHelper
  • objects_in_cell : vrecko::OctTree::OctTreeNode
  • ObjectSelector() : APObjectUtils::ObjectSelector
  • objectSide : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • objectsToPreload : PreloaderHeuristic
  • objectTransformationFromPointer()
: APCameraPath::Camera
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • objectWasMoved : APFFDEditor::EditorLogic
  • objFileDest : AP_CableEditor::CableEditor
  • objInt : vrecko::Scene::OBJ_INT_PRIO
  • objIntId : vrecko::SP_ObjectInterface
  • objIntPtr : vrecko::CollisionParams__ver1
  • Observable() : vreckoUtils::Observable
  • Observer() : vreckoUtils::Observer
  • OctTree() : vrecko::OctTree
  • offset : CarSim::CarEdgeData , CarSim::MessageEdgeOffset
  • old_camera_direction : behindO::MyCullCallback
  • old_cerr_buf : vrecko::Logger
  • old_cout : vrecko::Logger
  • old_cout_buf : vrecko::Logger
  • old_getTriLMD() : APSpacePartitioning::SNCH_Object
  • old_mouse_pos : navigation::KMTracker
  • olLock : LoadingConsole
  • once
: VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
  • OneTri() : APSpacePartitioning::SNCH_Object::OneTri
  • onMessageExit() : MainObject
  • onMessageProjection() : MainObject
  • open()
: AP_LSystem::AbstractFile
, AP_LSystem::LSFile
, AP_LSystem::XmlFile
  • openBenchmarkFile() : vrecko::Logger
  • openCacheFileForReading() : vrecko::PersistentCache
  • openCacheFileForWriting() : vrecko::PersistentCache
  • openDevice()
: vrecko::Device
, vreckoDP_base::fdtDataGlove
, vreckoDP_base::fsPinchGlove
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
  • OpenedCacheFile() : vrecko::PersistentCache::OpenedCacheFile
  • openedFiles : vrecko::PersistentCache
  • openFile() : vrecko::BenchmarkWriter
  • openPort() : vreckoDP_base::LHeadTracker
  • openSerial() : Serial
  • openSocket()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • operator!= : DynamicTreeIterator< _Type > , CacheInfo , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator()()
: vrecko::EventDispatcher::StringWithHashComparator
, vrecko::Scheduler::classcomp
, behindO::MyUpdateCallback
, behindO::MyCullCallback
, APDYNAMICART::HoopTrackerCallback
, UniformUpdateCallback
, Cloud::ParticleAwayComparison
, grass::TriangleCollector
, APSpacePartitioning::mycomparisonMinMax
, APSpacePartitioning::mycomparisonMaxMin
, vreckoUtils::HighlightCallback
, MainSceneUpdateCallback
  • operator*() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator*=() : gmMatrix4 , gmVector2 , gmVector3 , gmVector4 , gmMatrix3 , gmMatrix4
  • operator+() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator++() : DynamicTreeIterator< _Type >
  • operator+=() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator-() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator-=() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator/() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator/=() : gmVector3 , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector4
  • operator<< : gmMatrix4 , AP_LSystem::ParseableString , gmMatrix3 , gmVector2 , gmVector3 , gmVector4
  • operator=()
: AP_LSystem::StaticString
, gmMatrix4
, ht::VariableQuat
, APEditorController::AbilityMapper::MAPPING
, AP_LSystem::AbstractGenerator
, AP_LSystem::AbstractLSystem
, AP_LSystem::LongString
, AP_LSystem::LSystem
, AP_LSystem::ParseableString
, AP_LSystem::ParStoch0LSystem
, AP_LSystem::Rule
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
, gmMatrix3
, gmVector2
, gmVector3
, gmVector4
  • operator==() : gmVector2 , DynamicTreeIterator< _Type > , CacheInfo , gmMatrix3 , gmMatrix4 , gmVector3 , gmVector4
  • operator[]() : VK_NoStepInto_Namespace::DynamicArray< _Type > , AP_LSystem::LongString , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4 , gmMatrix4 , VK_NoStepInto_Namespace::DynamicArray< _Type >
  • optimalizationOfCP : APFFDEditor::Grid
  • optimalizeAndSave() : APConnectEditor::Optimalizer
  • optimalizeCuttingLoop() : APConnectEditor::Cut
  • optimalizeGeometry() : APConnectEditor::Optimalizer
  • optimalizeLoop() : SnapObject
  • optimalizeObject() : APConnectEditor::Optimalizer
  • Optimalizer() : APConnectEditor::Optimalizer
  • optimOfCP : APFFDEditor::EditorLogic
  • OptiTrack() : vreckoDP_base::OptiTrack
  • optitrack_origin_position : ht::HeadTracking
  • optitrack_scale : ht::HeadTracking
  • optitrack_translate_mapping : ht::HeadTracking
  • order : APDYNAMICART::symmetry_axis
  • ordered : APSpacePartitioning::PointShell_Object_Data
  • orderedEdges : CarSim::Junction
  • orderJunctionsEdges() : CarSim::RoadsState
  • OrdinaryAttractor() : APDYNAMICART::OrdinaryAttractor
  • Orient2Vec() : APCameraPath::Camera
  • orientation : MTCreatorTool , base::Avatar , DASample
  • origin : vreckoDP_base::LHeadTracker , VirtualFixture::NavSphere
  • origin_WIM_scale : behindO::WIM
  • originalColor : Icon
  • originalHandposition : MagicWandTool
  • originalIterations : MagicWandTool , APDYNAMICART::ToolMagicWand
  • originalStateSet : APObjectUtils::ObjectEffect
  • originalString : vrecko::EventDispatcher::StringWithHash
  • OriginalTriangleIntersection : APSpacePartitioning::SNCH_Object
  • origMenuPos : APMenu::DynamicMenu
  • origViewLookAt : APMenu::DynamicMenu
  • origViewPos : APMenu::DynamicMenu
  • origViewUp : APMenu::DynamicMenu
  • oriString : MTCreatorTool
  • osgadapter_vector : vrecko::EnvironmentObject
  • osgGeode
: APMenu::MenuItem
, APObjectUtils::ConnectionViz
, APGUI::ColorPicker
, APObjectUtils::ObjectEffect
, APEditorQAbilities::ObjectMovement::SnapBox
, APFFDEditor::Grid
  • osgGeom : APFFDEditor::Grid::Edge
  • osgPointerTrail : APMenu::DynamicMenu
  • osgPointerTrailDrawable : APMenu::DynamicMenu
  • osgPointerTrailGeode : APMenu::DynamicMenu
  • osgPointerTrailTransform : APMenu::DynamicMenu
  • osgText : APMenu::MenuItemText
  • osgTransform
: APMenu::MenuItem
, APEditorQAbilities::ObjectMovement::SnapBox
, APObjectUtils::ObjectEffect
  • Other : APEditorQAbilities::ObjectMovement
  • OUTER_OBJECT : vrecko::EventDispatcher
  • outerObject_map : vrecko::EventDispatcher
  • outFunc : vrecko::Logger::OutputNotificationFuncStored
  • outFuncs : vrecko::Logger
  • outInVec : CarSim::Edge
  • outPos : CarSim::Edge
  • Output : APObjectUtils::ConnectionViz::Connection
  • OutputNotificationFuncType : vrecko::Logger
  • OutputPin() : vrecko::OutputPin< _MessageType >
  • outputPinsList : vrecko::BaseClass
  • outputPresent() : vrecko::BaseClass
  • OutputRequest : APObjectUtils::ConnectionViz::Connection
  • outstandingCounters : vrecko::Logger
  • OutstandingLine() : LoadingConsole::OutstandingLine
  • outstandingLines : LoadingConsole
  • outstandingTexts : vrecko::Logger
  • overflow() : vrecko::logger_streambuf
  • owner
: APEditorQAbilities::ObjectMovement::SnapBox
, vrecko::IOPinBase
, base::Light
, behindO::CentreObjectManipulator
, behindO::AvatarManipulator
, APEditorController::EditorController::ECPOINTERBUTTONINFO
, BehindObstacleExp_wT
, APObjectUtils::UseToEvent
, base::MTMatrixTransform
, base::Avatar
, base::MouseHand
, behindO::EyeManipulator
, APConnectEditor::Cut
, APEditorController::EditorController
, base::hand
, APObjectUtils::ObjectEffectMan
, behindO::WIM
, vrecko::ControllableAbility
, behindO::HeadManipulator
, behindO::MappingFunctions
, navigation::KMTracker
, APObjectUtils::ObjectModif
, base::Rotate
, APMenu::MenuItem
, APObjectUtils::KeepOnScreen
, vrecko::World::AvatarView
, ChessPiece
, APObjectUtils::Animator
, APObjectUtils::ObjectSelector
, APSpacePartitioning::SP_Object_Data_Base
, VirtualFixture::Avatar
, APObjectUtils::ObjectInfo
, boids::Boid
, BehindObstacleExperiment
, APObjectUtils::ConnectionViz
, behindO::Manipulator
, APMenu::DynamicMenu
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • p1 : APSpacePartitioning::ELOD
  • p1ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
  • p2 : APSpacePartitioning::ELOD
  • p2ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
  • p_act : CloudVoxel
  • p_ext : CloudVoxel
  • p_hum : CloudVoxel
  • pAHeadManipulator : behindO::CentreObjectManipulator
  • pAHMDHeadManipulator : behindO::CentreObjectManipulator
  • pAManipulator : behindO::CentreObjectManipulator
  • Par2LSystem() : AP_LSystem::Par2LSystem
  • param_format : Hci
  • Parameter()
: APDYNAMICART::Parameter
, AP_LSystem::Parameter
  • parameter : ode::DynamicScene::MessageODERequest
  • parameters : vrecko::ReaderWriter::AbilityToInitialize
  • parameterString : vrecko::Ability
  • ParameterVector : vrecko::Ability
  • paramMult : APDYNAMICART::ToolMagicWand , MagicWandTool
  • paramRangeEnd : APDYNAMICART::ToolMagicWand , MagicWandTool
  • paramRangeStart : APDYNAMICART::ToolMagicWand , MagicWandTool
  • params
: vrecko::ScenePSThreadInfo
, CarSim::CarControlUnit
, APDYNAMICART::InitSettings
, grass::Grass
, grass::GrassDrawable
  • paramsDH0_5() : Arm
  • paramShift1 : MagicWandTool , APDYNAMICART::ToolMagicWand
  • paramShift2 : APDYNAMICART::ToolMagicWand , MagicWandTool
  • ParD0LSystem() : AP_LSystem::ParD0LSystem
  • parent : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode , FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • parent_node : vrecko::OctTree::OctTreeNode
  • parentsTransform : APFFDEditor::EditorLogic
  • parse()
: AP_LSystem::AbstractInterpret
, AP_LSystem::TurtleInterpret
  • Parse() : WAVEFRONT::InPlaceParser
  • ParseableString() : AP_LSystem::ParseableString
  • parseCfgPacket() : Hci
  • parsed : packet_rec
  • parseEventName() : APInputConnector::InputConnector
  • parseInputDevice() : APInputConnector::InputConnector
  • parseInputMappingPair() : APInputConnector::InputConnector
  • ParseLine()
: WAVEFRONT::InPlaceParserInterface
, WAVEFRONT::OBJ
  • parseOutputMappingPair() : APInputConnector::InputConnector
  • parsePacket() : Hci
  • parseReceiverAbility() : APInputConnector::InputConnector
  • parseSenderReceiver() : APInputConnector::InputConnector
  • parseSensorNumber() : APInputConnector::InputConnector
  • parseSR() : vrecko::EventDispatcher
  • ParsingException() : AP_LSystem::ParsingException
  • ParStoch0LSystem() : AP_LSystem::ParStoch0LSystem
  • particlesEO : APDYNAMICART::PerlinLines
  • partitioningObjectInterfaces : vrecko::Scene
  • partitioningSceneInterfaces : vrecko::Scene
  • partJuncCardinality : CarSim::Junction
  • partThreadsInfo : vrecko::Scene
  • pass : CarSim::CarEnvirons , CarSim::Parameters
  • passiveMouseMotion() : vreckoDP_base::KeyboardMouse
  • pastSamples : Filter::PosNoiseRemover
  • path : CarSim::Parameters
  • Path_ptr : APCameraPath::ControlPoint
  • PathCtrlPts : APCameraPath::Camera
  • pathIndex : APCameraMovement::ControlPoint
  • pathLength : APCameraMovement::ControlPoint
  • pathObject : APCameraMovement::CameraMovementEditor
  • pattern : APDYNAMICART::SectorInfo
  • PatternBase() : APDYNAMICART::PatternBase
  • PatternsGeode() : APDYNAMICART::PatternsGeode
  • pause() : APDYNAMICART::PerlinLines , Timing
  • pAvatarCopy : behindO::WIM
  • pAvatarManipulator : BehindObstacleExp_wT , BehindObstacleExperiment , behindO::WIM
  • pAvatarOwner : behindO::WIM
  • pBrakeLightMT : CarSim::Lights
  • pCameraPath : APCameraMovement::CameraMovementEditor
  • pCarPartsNodeCache : CarSim::RoadsState
  • pCenterObjectManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCEU : CarSim::Parameters
  • pChangeOfVisibility : BehindObstacleExp_wT , BehindObstacleExperiment
  • pChild : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • PCloth() : PhysXPlugin::ClothDrawable
  • pCube1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCube2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCube3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlane : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlane2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlaneEO : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlaneEO2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pEditedObject : APFFDEditor::EditorLogic
  • peekSymbol() : AP_LSystem::LongString
  • pendingLine : vrecko::logger_streambuf
  • pEOAvatar : BehindObstacleExp_wT , BehindObstacleExperiment
  • performCompleteTest()
: vrecko::SP_SceneInterface
, APSpacePartitioning::NoPartitioning_Scene
  • performUpdate()
: vrecko::SP_SceneInterface
, APSpacePartitioning::NoPartitioning_Scene
  • PerlinLines() : APDYNAMICART::PerlinLines
  • perlinNoise() : APDYNAMICART::PerlinLines
  • PerlinNoiseAlgorithm() : APNature::PerlinNoiseAlgorithm
  • persistentCache : vrecko::World
  • PersistentCache() : vrecko::PersistentCache
  • pEventDispatcher
: vreckoDP_base::KeyboardMouse
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::VRPN3DMouse
  • pfd_from : ChessBoard
  • pfd_to : ChessBoard
  • pFirstActivation : APConnectEditor::Cut
  • pFloor : BehindObstacleExp_wT , BehindObstacleExperiment
  • pFrontLightMT : CarSim::Lights
  • pgd_close() : vreckoDP_base::fsPinchGlove
  • pgdComm() : vreckoDP_base::fsPinchGlove
  • pgdRead() : vreckoDP_base::fsPinchGlove
  • pGeometryPartsPath : CarSim::CarExecutionUnit
  • pGreenMT : CarSim::TLcolorsMT
  • pGrid : APFFDEditor::EditorLogic
  • pGroup : vrecko::World::SG_CHANGE
  • PHANToMAvatar() : PHANToMAvatar
  • PHANToMDevice
: VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, PHEffect
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
  • pHeadManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • PHEffect() : PHEffect
  • pHMDHeadManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • PHONG : APLightsEditor::Lights
  • PhysXManager() : APDYNAMICART::PhysXManager
  • PhysXObject() : PhysXPlugin::PhysXObject
  • PhysXScene() : PhysXPlugin::PhysXScene
  • piece_location : ChessPiece
  • piece_type : ChessPiece
  • pieces_map : ChessBoard
  • PinList : vrecko::BaseClass
  • pinName : vrecko::IOPinBase , APObjectUtils::ConnectionViz::Connection
  • pitchDown()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • pitchUp()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • pl : ThinHeap< _NodeClass, _keyType >::ThinHeapNode , APDYNAMICART::Ctrl_PerlinLines
  • Plane()
: PhysXPlugin::Plane
, VirtualFixture::Plane
  • plane_distance : gmVector3
  • plane_intersect : gmVector3
  • Plane_type : navigation::KMTracker
  • plane_xy : navigation::KMTracker
  • plane_xz : navigation::KMTracker
  • plane_yz : navigation::KMTracker
  • planeD : APSpacePartitioning::SNCH_Object::OneTri
  • planeNormal : APSpacePartitioning::SNCH_Object::OneTri
  • planes : APEditorQAbilities::ObjectMovement
  • planesCompare : APEditorQAbilities::ObjectMovement
  • PlaneType : RegularPolygonSpline
  • play : ChessBoard
  • playback()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_FreeHandPainting
  • player : VirtualFixture::Drag
  • PLControllerTool() : APDYNAMICART::PLControllerTool
  • pLeftBlinkerLightMT : CarSim::Lights
  • pLeftHand : BehindObstacleExp_wT , BehindObstacleExperiment
  • pLeftWheelsPosVec : CarSim::CarExecutionUnit
  • pLights : CarSim::CarExecutionUnit
  • PLMagnetTool() : APDYNAMICART::PLMagnetTool
  • PLNestTool() : APDYNAMICART::PLNestTool
  • PluginManager() : vrecko::PluginManager
  • pluginName : APEditorQAbilities::AbilityEditor::AllowedAbility
  • pManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMappingFunctions : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMyCullCallback : behindO::Mirror
  • pNode : vrecko::World::SG_CHANGE
  • PoA() : APDYNAMICART::PoA
  • PoB() : APDYNAMICART::PoB
  • pobName : APDYNAMICART::PoB
  • pObstacle1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle10 : BehindObstacleExp_wT
  • pObstacle11 : BehindObstacleExp_wT
  • pObstacle12 : BehindObstacleExp_wT
  • pObstacle13 : BehindObstacleExp_wT
  • pObstacle14 : BehindObstacleExp_wT
  • pObstacle15 : BehindObstacleExp_wT
  • pObstacle16 : BehindObstacleExp_wT
  • pObstacle17 : BehindObstacleExp_wT
  • pObstacle18 : BehindObstacleExp_wT
  • pObstacle19 : BehindObstacleExp_wT
  • pObstacle2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle20 : BehindObstacleExp_wT
  • pObstacle3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle4 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle5 : BehindObstacleExp_wT
  • pObstacle6 : BehindObstacleExp_wT
  • pObstacle7 : BehindObstacleExp_wT
  • pObstacle8 : BehindObstacleExp_wT
  • pObstacle9 : BehindObstacleExp_wT
  • point : APDYNAMICART::symmetry_axis
  • PointAdd() : APRoomEdit::PointAdd
  • pointed()
: APDYNAMICART::Attractor
, APDYNAMICART::BrushStroke
, APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PerlinLines
, APDYNAMICART::PoA
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::PS_Face
, APDYNAMICART::PS_FacePlane
, APDYNAMICART::PoAAdapter< T >
, APGUI::ColorPicker
, APGUI::GUI_Item
, APGUI::Icon
, APGUI::Menu
, APGUI::Slider
, Icon
, APDYNAMICART::PoB
  • pointer : vrecko::EnvironmentObject::UserData
  • pointerBtnUpdate() : APEditorController::EditorController
  • pointerButtonDown()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerButtonUp()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerID : APEditorController::AbilityMapper::BUTTON_MAPPING
  • pointerMove()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerMoved() : APMenu::DynamicMenu
  • PointerPosReqString : APDYNAMICART::ToolMagicWand , MagicWandTool
  • pointerPosUpdate() : APEditorController::EditorController
  • pointerRotUpdate() : APEditorController::EditorController
  • pointers : APEditorController::EditorController
  • pointerSelected : APMenu::DynamicMenu
  • pointerSelectItem() : APMenu::DynamicMenu
  • pointerSelUpdate() : APEditorController::EditorController
  • pointerUnselectItem() : APMenu::DynamicMenu
  • pointerViewMovedHelper() : APMenu::DynamicMenu
  • PointIndex() : APNature::TerrainAlgorithm
  • pointIndex : APCameraMovement::CameraMovementEditor
  • pointInHalfSpace() : CarSim::RoadsState
  • PointInPlaneJoint() : PhysXPlugin::PointInPlaneJoint
  • PointMove() : APRoomEdit::PointMove
  • pointObjectByID() : APGUI::GUI_Controller
  • PointOnLineJoint() : PhysXPlugin::PointOnLineJoint
  • points
: vrecko::CollisionPointInfo
, vrecko::CollisionInfo
, APObjectUtils::Animator
  • PointShell : APObjectUtils::ObjectEffect
  • PointShell_Object_Data() : APSpacePartitioning::PointShell_Object_Data
  • PointShell_Object_Data::getColor() : APSpacePartitioning::PointShell_Object_Data
  • PointShell_Object_Data_Geometry() : APSpacePartitioning::PointShell_Object_Data_Geometry
  • PointShell_Object_Data_Geometry_Analyser() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • PointShell_Object_Data_LOD_Builder() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • PointShellGeneric_Object_Data() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • pointShellSize : APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • PointShellVSVoxel_Object() : APSpacePartitioning::PointShellVSVoxel_Object
  • pointsTrans : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • pointType : APCameraMovement::CameraMovementEditor
  • polygonHaveVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • polygonHaveVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • PolygonNormals : APObjectUtils::ObjectEffect
  • polygonPoints : CarSim::RoadsState
  • polygons
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • polygonsCount : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • polygonsEqualsByVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • PolygonState() : APConnectEditor::PolygonState
  • PolyhedraSculpture() : APDYNAMICART::PolyhedraSculpture
  • pom : navigation::AvatarInHand
  • pop() : AP_LSystem::TurtleStack
  • pOrangeMT : CarSim::TLcolorsMT
  • port_fd : vreckoDP_base::fsPinchGlove , vreckoDP_base::LHeadTracker
  • port_fd_dual : vreckoDP_base::LHeadTracker
  • port_name : vrecko::Device
  • Pos : mv::CPoint
  • pos
: APEditorController::EditorController::ECPOINTERINFO
, APFFDEditor::GeometryLoaderBase::VertexBase
, APMenu::MenuItem
, APSpacePartitioning::GeometryLoaderBase::VertexBase
, APSpacePartitioning::PointShell_SimpleNode
, APSpacePartitioning::PointShell_Object_Data_Geometry::V
, APSpacePartitioning::SNCH_Object::InternalPointStruct
, vreckoDP_base::LHeadTracker
  • pos_diff : vreckoDP_base::LHeadTracker
  • position
: base::Light
, vrecko::OctTree::OctTreeNode
, CacheInfo
, ArtificialWorld::Model
, ArtificialWorld::SubBlock
, APCameraMovement::ControlPoint
, CarSim::CarState
, CarSim::Junction
, CarSim::PolygonPoint
, SunLight
, Particle
, grass::Vertex
, APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
, APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
, MTCreatorTool
, DASample
, PhysXPlugin::Particle
, VirtualFixture::AxisLock
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Drag
, VirtualFixture::Grid
, VirtualFixture::Log
, VirtualFixture::Marker
, VirtualFixture::Plane
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
  • positionX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • positionY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • positionZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • PosNoiseRemover() : Filter::PosNoiseRemover
  • posRaw : APEditorController::EditorController::ECPOINTERINFO
  • PosRot : APDYNAMICART::PoAState
  • posString : APDYNAMICART::Ctrl_PerlinLines , MagicWandTool , MTCreatorTool
  • postInitialize()
: VirtualFixture::Trace
, APDYNAMICART::Ctrl_PerlinLines
, VirtualFixture::Drag
, VirtualFixture::ProxiCone
, PHEffect
, APCameraMovement::CameraPath
, MagicWandTool
, VirtualFixture::Box
, PhysXPlugin::UpdatablePhysXObject
, boids::Boid
, navigation::AvatarInHand
, APSpacePartitioning::VoxelGrid_Object_Data
, ode::CompositeObject
, APLightsEditor::Lights
, APGUI::Icon
, base::Avatar
, base::Light
, base::SystemInfo
, vrecko::BaseClass
, vrecko::PyAbility
, ArtificialWorld::BlockUpdater
, ArtificialWorld::WorldBuilder
, BehindObstacleExp_wT
, BehindObstacleExperiment
, behindO::CentreObjectManipulator
, behindO::MappingFunctions
, behindO::WIM
, boids::BoidsLogic
, boids::BoidsPlanner
, AP_CableEditor::Cable
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::DAEnvironment
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APFFDEditor::EditorLogic
, AP_LSystem::LSObject
, APGUI::Menu
, APGUI::Slider
, APHUD::HUDDisplay
, APMenu::DynamicMenu
, APClouds::Clouds
, grass::Grass
, navigation::KMTracker
, APObjectUtils::ConnectionViz
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
, APObjectUtils::ObjectModif
, APObjectUtils::ObjectSelector
, ode::CappedCylinder
, ode::Cube
, ode::Sphere
, APRoomEdit::WallGeometry
, APTextOutput::Console
, vreckoDP_base::OptiTrack
, Icon
, MTCreatorTool
, SliceTool
, PhysXPlugin::BaseActor
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::PhysXObject
, PhysXPlugin::PhysXScene
, PhysXPlugin::RemoteDebugger
, VirtualFixture::Avatar
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Log
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, PHANToMAvatar
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
  • PostoHSL() : APGUI::ColorPicker
  • Postprocessing() : APNature::Terrain2D
  • postRotate() : AP_LSystem::MovingTurtle
  • postStep()
: AP_LSystem::MovingTurtle
, AP_LSystem::JointedPipe
  • posX
: APHUD::HUDField
, APHUD::HUDWindow
, APObjectUtils::KeepOnScreen
  • posY
: APHUD::HUDField
, APHUD::HUDWindow
, APObjectUtils::KeepOnScreen
  • pOT : vreckoDP_base::OptiTrack::info_struct
  • pOwner : vrecko::Ability
  • pParameterVector : base::Rotate , base::ShowFDH
  • pParent : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • pReceiver : vrecko::EventDispatcher::EventStruct
  • predefinedShapes : AP_CableEditor::CableEditor
  • pRedMT : CarSim::TLcolorsMT
  • preferredObjectInterface : vrecko::CollisionParams__ver1
  • preferredSceneInterface : vrecko::CollisionParams__ver1
  • preInit() : AP_CableEditor::CableEditor
  • preInitialize()
: AP_CableEditor::Cable
, APMenu::DynamicMenu
, vrecko::BaseClass
, vrecko::PyAbility
, ArtificialWorld::BlockUpdater
, behindO::AvatarManipulator
, BehindObstacleExp_wT
, BehindObstacleExperiment
, behindO::EyeManipulator
, APObjectUtils::ObjectSelector
, behindO::HMDHeadManipulator
, boids::Boid
, behindO::Manipulator
, behindO::Mirror
, boids::BoidsLogic
, PHEffect
, PHANToMAvatar
, boids::BoidsPlanner
, APSpacePartitioning::NoPartitioning_Scene
, CarSim::RoadsState
, APObjectUtils::ObjectEffect
, CarSim::CarControlUnit
, CarSim::CarExecutionUnit
, APDYNAMICART::Ctrl_MotionVisualization
, PhysXPlugin::BasePhysXObject
, CarSim::Remover
, CarSim::TLsOnJuncManager
, ChessPiece
, APDYNAMICART::Controller
, APObjectUtils::ObjectInfo
, APDYNAMICART::DAEnvironment
, APObjectUtils::ObjectEffectMan
, APObjectUtils::KeepOnScreen
, Filter::Linear
, Filter::PosNoiseRemover
, AP_LSystem::LSObject
, APHUD::HUDDisplay
, APObjectUtils::ConnectionViz
, APCameraMovement::CameraPath
, APClouds::Clouds
, navigation::KMTracker
, APObjectUtils::Animator
, APLightsEditor::Lights
, APObjectUtils::ObjectModif
, APRoomEdit::WallGeometry
, APSpacePartitioning::PointShellVSVoxel_Object
, APSpacePartitioning::SphereBVH_Scene
, APSpacePartitioning::VoxelGrid_Object_Data
, APTextOutput::Console
, APDYNAMICART::Ctrl_FreeHandPainting
, VirtualFixture::AxisLock
, base::Rotate
, base::MTMatrixTransform
, VirtualFixture::Box
, VirtualFixture::Cylinder
, base::SystemInfo
, VirtualFixture::Grid
, VirtualFixture::Log
, VirtualFixture::Marker
, VirtualFixture::NavSphere
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiSphere
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, behindO::HeadManipulator
, VirtualFixture::Border
, base::Light
, PhysXPlugin::PhysXObject
, PhysXPlugin::PhysXScene
, APSpacePartitioning::SphereBVH_Object
, VirtualFixture::Damper
, VirtualFixture::Avatar
, VirtualFixture::Filter
, VirtualFixture::ProxiBox
, VirtualFixture::Plane
, VirtualFixture::Vibration
, VirtualFixture::Sphere
, VirtualFixture::Trace
, APSpacePartitioning::SNCH_Object
, VirtualFixture::Drag
, VirtualFixture::ProxiCylinder
, VirtualFixture::MarkerFactory
, APSpacePartitioning::SP_Object_Data_Base
, VirtualFixture::Cone
, vreckoDP_base::OptiTrack
, base::Avatar
, base::hand
, base::MouseHand
  • Preloader() : Preloader
  • pRemover : CarSim::RoadsState
  • PrepareDisplayList() : grass::GrassDrawable
  • prepareForTermination() : vrecko::Scene
  • PrepareNext() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • Preprocessing() : APNature::Terrain2D
  • preReadBytes() : vrecko::BufferedFile
  • preRotate() : AP_LSystem::MovingTurtle
  • preStep()
: AP_LSystem::JointedPipe
, AP_LSystem::StraightPipe
, AP_LSystem::MovingTurtle
  • prevEdgeId : CarSim::JuncsEdge
  • previousObjectPosition : APFFDEditor::EditorLogic
  • prevPointerPos : APConstrainedMovement::ConstrainedObjectMovement
  • prevPos : APFFDEditor::Grid::ControlPoint
  • pRightBlinkerLightMT : CarSim::Lights
  • pRightHand : BehindObstacleExp_wT , BehindObstacleExperiment
  • printBuf() : vreckoDP_base::fsPinchGlove
  • printBuffer() : vreckoDP_base::LHeadTracker
  • printConf() : vreckoDP_base::fsPinchGlove
  • printGests() : vreckoDP_base::fsPinchGlove
  • printOutEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutList() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutPolygon() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutQueue() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutStatus() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutVerbouseStatus() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printPos() : vreckoDP_base::LHeadTracker
  • priority : vrecko::BaseClass
  • Priority : base::_THREAD_BASIC_INFORMATION
  • priority : vrecko::Scene::OBJ_INT_PRIO , vrecko::Scene::SC_INT_PRIO
  • PrismaticJoint() : PhysXPlugin::PrismaticJoint
  • private_timer_map : vrecko::Scheduler
  • PrivateTimerMap : vrecko::Scheduler
  • pRoadsState : CarSim::CarControlUnit
  • probabilityFactor : AP_LSystem::Rule
  • processAction()
: APGUI::Icon
, APInputConnector::InputConnector
, APGUI::Menu
, APGUI::Slider
, APGUI::IconColour
, APGUI::GUI_Item
, APGUI::ColorPicker
, APGUI::GUI_Controller
  • processBatchOfEvents() : vrecko::EventDispatcher
  • processButtonPress()
: vrecko::ControllableAbility
, APConstrainedMovement::ConstrainedObjectMovement
, APRoomEdit::RoomEditor
  • processButtonRelease()
: APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::AbilityEditor
, APRoomEdit::RoomEditor
, vrecko::ControllableAbility
, AP_CableEditor::CableEditor
, APConnectEditor::ConnectEditor
, APConnectEditor::Optimalizer
  • processChainofResponsibility() : APInputConnector::InputConnector
  • processCondition() : AP_LSystem::Rule
  • processContextClick() : APGUI::GUI_Controller
  • processCutSymbol() : AP_LSystem::LSystem
  • processDualSplitting() : APConstrainedMovement::ConstraintDescription
  • processEvent()
: VirtualFixture::NavSphere
, VirtualFixture::Border
, APDYNAMICART::Ctrl_FreeHandPainting
, behindO::Manipulator
, ChessPiece
, BehindObstacleExp_wT
, navigation::KMTracker
, navigation::AvatarInHand
, behindO::MappingFunctions
, APClouds::Clouds
, Filter::PosNoiseRemover
, VirtualFixture::Box
, CarSim::Remover
, VirtualFixture::Damper
, Filter::Linear
, behindO::CentreObjectManipulator
, MagicWandTool
, VirtualFixture::VibrationLabelActivator
, behindO::HeadManipulator
, APInputConnector::InputConnector
, vrecko::PyAbility
, behindO::WIM
, VirtualFixture::Cylinder
, VirtualFixture::AxisLock
, VirtualFixture::Sphere
, VirtualFixture::Grid
, base::MouseHand
, vrecko::BaseClass
, VirtualFixture::VibrationLabel
, VirtualFixture::Marker
, behindO::EyeManipulator
, VirtualFixture::ProxiBox
, vrecko::EventDispatcher
, vreckoDP_base::VRPN3DMouse
, ChessBoard
, CarSim::RoadsState
, PHANToMAvatar
, VirtualFixture::Trace
, PHEffect
, VirtualFixture::ProxiBorder
, behindO::AvatarManipulator
, VirtualFixture::Vibration
, VirtualFixture::ProxiCylinder
, behindO::CuttingPlane
, VirtualFixture::Plane
, VirtualFixture::Drag
, VirtualFixture::MarkerFactory
, behindO::ChangeOfVisibility
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiSphere
, VirtualFixture::Filter
, BehindObstacleExperiment
, VirtualFixture::Log
, VirtualFixture::Cone
, MTCreatorTool
, behindO::HMDHeadManipulator
, VirtualFixture::Avatar
  • processHomomorphismSuccessor()
: AP_LSystem::Par2LSystem
, AP_LSystem::Abstract0LSystem
, AP_LSystem::D0LSystem
, AP_LSystem::LSystem
  • PROCESSING_METHOD : vrecko::InputPin< _MessageType > , vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • processInputPosition() : APGUI::Slider
  • processLine() : AP_LSystem::StringUtils
  • ProcessLine() : WAVEFRONT::InPlaceParser
  • processMenuButtonPress() : vrecko::ControllableAbility
  • processMenuButtonRelease() : vrecko::ControllableAbility
  • processMessage()
: vrecko::InputPinBase
, vrecko::InputPin< _MessageType >
  • processNodeToMergeRecursive() : vrecko::ReaderWriter
  • processNotification()
: AP_CableEditor::CableEditor
, APObjectUtils::ObjectEffectMan
, AP_CableEditor::Cable
, APEditorController::EditorController
, vrecko::BaseClass
, vrecko::Scene::EOIteratorHelper
, vrecko::ControllableAbility
, APSpacePartitioning::SphereBVH_Object_Data
, APMenu::MenuItem
  • ProcessOrientation() : APInputConnector::InputConnector
  • processOutstandingCounters() : vrecko::Logger
  • processOutstandingTexts() : vrecko::Logger
  • processParameters() : AP_LSystem::Rule
  • processPoint() : APConnectEditor::Cut
  • processPredecessor()
: AP_LSystem::D0LSystem
, AP_LSystem::Abstract0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::LSystem
  • processProbabilityFactor() : AP_LSystem::Rule
  • processRequest()
: vrecko::RequestInputPinBase
, vrecko::BaseClass
, CarSim::RoadsState
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • processRuleSuccessor()
: AP_LSystem::Abstract0LSystem
, AP_LSystem::LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::D0LSystem
  • processSensorTransformation() : APInputConnector::InputConnector
  • processTextMain() : vrecko::Logger
  • processVector() : AP_LSystem::StringUtils
  • product_id : Hci
  • product_name : Hci
  • projection : vrecko::World::AvatarEye
  • ProjectionIntersectionResult : APSpacePartitioning::SNCH_Object
  • projectPointOnPlaneUV() : APEditorQAbilities::ObjectMovement
  • projPointerPos : APMenu::DynamicMenu
  • properties : AP_LSystem::AbstractTurtle , CloudsManager
  • ProxiBorder() : VirtualFixture::ProxiBorder
  • ProxiBox() : VirtualFixture::ProxiBox
  • ProxiCone() : VirtualFixture::ProxiCone
  • ProxiCylinder() : VirtualFixture::ProxiCylinder
  • ProxiSphere() : VirtualFixture::ProxiSphere
  • PS_Component() : APDYNAMICART::PS_Component
  • PS_Face() : APDYNAMICART::PS_Face
  • PS_FacePlane() : APDYNAMICART::PS_FacePlane
  • PS_Layer() : APDYNAMICART::PS_Layer
  • PS_Polyhedron() : APDYNAMICART::PS_Polyhedron
  • pScene : BehindObstacleExp_wT , vrecko::World
  • pSelectionBox : behindO::ChangeOfVisibility
  • PseudoRand2DPlacement() : PseudoRand2DPlacement
  • pStateSet : vrecko::World::SG_CHANGE
  • pTempl : BehindObstacleExperiment , BehindObstacleExp_wT
  • pText : vrecko::World::SG_CHANGE
  • pTLcolorsMTvec : CarSim::TLsOnJuncManager
  • pTLcolorsVec : CarSim::TLsOnJuncManager
  • pTLcolumnModel : CarSim::RoadsState
  • pTLgreenIntervVec : CarSim::TLsOnJuncManager
  • pTLorangeModel : CarSim::RoadsState
  • ptr : APEditorQAbilities::PresentAbility
  • PulleyJoint() : PhysXPlugin::PulleyJoint
  • push() : AP_LSystem::TurtleStack
  • push_back() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • pushing
: VirtualFixture::Cone
, VirtualFixture::Plane
, VirtualFixture::Cylinder
  • pushingforce
: VirtualFixture::Plane
, VirtualFixture::Cone
, VirtualFixture::Cylinder
  • putAsideCars : CarSim::Edge
  • pVertexRelposition : APFFDEditor::GeometryLoader::Geometry
  • pVertexStartArray : APFFDEditor::GeometryLoader::Geometry
  • pWheelsVec : CarSim::CarExecutionUnit
  • pWiimote : vreckoDP_base::Wiimote
  • pWIM : BehindObstacleExp_wT , BehindObstacleExperiment
  • pWIMEO : BehindObstacleExp_wT , BehindObstacleExperiment
  • PyAbility() : vrecko::PyAbility
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • q : navigation::AvatarInHand
  • qc : navigation::AvatarInHand
  • qc_old : navigation::AvatarInHand
  • QComputeBoundShapeVisitor() : osgQ::QComputeBoundShapeVisitor
  • QConstShapeVisitor() : osgQ::QConstShapeVisitor
  • qd : navigation::AvatarInHand
  • qd_init : navigation::AvatarInHand
  • qd_old : navigation::AvatarInHand
  • qd_old2 : navigation::AvatarInHand
  • QDrawShapeVisitor() : osgQ::QDrawShapeVisitor
  • QPrimitiveShapeVisitor() : osgQ::QPrimitiveShapeVisitor
  • QSection() : osgQ::QSection
  • qshapeDraw : APMenu::MenuItem
  • QShapeDrawable() : osgQ::QShapeDrawable
  • QShapeVisitor() : osgQ::QShapeVisitor
  • quadraticAttenuation : base::Light
  • QueryTurtle() : AP_LSystem::QueryTurtle
  • quitAfterError() : CarSim::CarControlUnit
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • radius
: AP_LSystem::TurtleProperties
, AABoundingBox
, APSpacePartitioning::VLOD
, VirtualFixture::Plane
, VirtualFixture::ProxiCone
, APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, APSpacePartitioning::PointShell_SimpleNode
, VirtualFixture::Cylinder
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::NavSphere
  • radius1 : VirtualFixture::Cone
  • radius2 : VirtualFixture::Cone
  • radiusMultiplier : AP_LSystem::TurtleProperties
  • rand() : AP_LSystem::AbstractTurtle
  • random()
: APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::PerlinLines
  • RandomFaultsAlgorithm() : APNature::RandomFaultsAlgorithm
  • RandomIndex() : AP_LSystem::RandomIndex
  • RandomizeSurfaceCorners() : APNature::MidpointDisplacementAlgorithm
  • randomRun : APDYNAMICART::InitSettings
  • randomTurnPitchRoll()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • Range() : vrecko::Range
  • range : vrecko::Ability::ParameterStruct
  • RANGE_ENUMERATION : vrecko::Range
  • RANGE_INTERVAL : vrecko::Range
  • rangeEnd : APDYNAMICART::Parameter
  • rangeStart : APDYNAMICART::Parameter
  • RangeType : vrecko::Range
  • rank : ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • rayEnd : vrecko::CollisionParams__ver1
  • rayStart : vrecko::CollisionParams__ver1
  • read_len : vreckoDP_base::LHeadTracker
  • readBlock() : Hci
  • readBool() : vrecko::BufferedFile
  • readBuffer() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readByte() : vrecko::BufferedFile , UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • ReadByte() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • readBytes() : vrecko::BufferedFile , Serial
  • readBytesCore() : vrecko::BufferedFile
  • readChar() : Serial
  • readDouble() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • ReadDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • readDWORD() : vrecko::BufferedFile
  • readDword() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • Reader() : mv::Reader
  • ReaderWriter() : vrecko::ReaderWriter
  • readFloat() : vrecko::BufferedFile , UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readInt() : vrecko::BufferedFile
  • readInt64() : vrecko::BufferedFile
  • readLine() : vrecko::BufferedFile
  • readLineW() : vrecko::BufferedFile
  • readLONG() : vrecko::BufferedFile
  • readNodeFile()
: APCameraMovement::MyReadCallback
, APConnectEditor::MyReadCallback
, APObjectUtils::MyReadCallback
, MyReadCallback
, APSpacePartitioning::VGReadCallback
  • readPOINT() : vrecko::BufferedFile
  • readRECT() : vrecko::BufferedFile
  • readStr() : vrecko::BufferedFile
  • readString() : Hci
  • readVec3f() : vrecko::BufferedFile
  • readWatchedObjectIDs() : APConstrainedMovement::ConstrainedObjectMovement
  • readWCharTrans() : vrecko::BufferedFile
  • readWord() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readWORD() : vrecko::BufferedFile
  • ready() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • realize() : vrecko::ViewerBase
  • RealizeQueue() : Cloud
  • realPos : APFFDEditor::GeometryLoaderBase::VertexBase
  • rearOffset : CarSim::EdgesCar
  • rec_out : vreckoDP_base::LHeadTracker
  • recalculateColorInterpolation() : APDYNAMICART::PerlinLines
  • recalculateNormals()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • received_event_map : vrecko::EventDispatcher
  • receiver
: vrecko::BaseClass::NOTIFICATION_DESCRIPTION
, vrecko::EventDispatcher::ICSBase
, vrecko::EventDispatcher::EventDefinitionStruct
, APGUI::Interconnection
, Receiver
  • receiver_backup : behindO::MappingFunctions
  • receiver_decomposition : vrecko::EventDispatcher
  • receiverPin : vrecko::EventDispatcher::ICSBase
  • recomputeNormal() : SnapObject
  • recomputeStrokesTimes() : APDYNAMICART::Ctrl_FreeHandPainting
  • Rectangle() : AP_LSystem::Rectangle
  • RectangularSplineAdapter() : APDYNAMICART::RectangularSplineAdapter
  • recVelocityOnJunc : CarSim::CarControlUnit , CarSim::CarEnvirons
  • reduceFront() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • reference_point : base::Avatar
  • refillQueue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • refPoint1 : APMenu::MenuItem
  • refPoint2 : APMenu::MenuItem
  • refPoint3 : APMenu::MenuItem
  • regCarForEdge() : CarSim::RoadsState
  • regFstCarForEdge() : CarSim::RoadsState
  • regIncomingCarToShortEdges() : CarSim::RoadsState
  • registeredItemTypes : APMenu::DynamicMenu
  • registerEnvironmentObject() : vrecko::Scene
  • registerGlobalGuiItem() : APGUI::GUI_Controller
  • registerNewItemType() : APMenu::DynamicMenu
  • registerOutputNotification() : vrecko::Logger
  • registerPointableGuiItem() : APGUI::GUI_Controller
  • RegisterUpatablePO() : PhysXPlugin::UpdatablePhysXObject
  • RegularPolygonSpline() : RegularPolygonSpline
  • RegularUpdate() : Cloud
  • reject_distance_for_BS : APSpacePartitioning::SNCH_Object
  • reject_distance_for_surfaces : APSpacePartitioning::SNCH_Object
  • relCall : vreckoDP_base::fsPinchGlove
  • Release() : APNature::TerrainAlgorithm
  • releaseHoopActor() : APDYNAMICART::PhysXManager
  • releaseHoopJoints() : APDYNAMICART::PhysXManager
  • releaseObject() : vrecko::Scene::EOIteratorHelper
  • releaseParser() : vrecko::ReaderWriter
  • releasePhysics() : APDYNAMICART::PhysXManager
  • relFunc : vreckoDP_base::fsPinchGlove
  • relPosInGrid : APFFDEditor::GeometryLoaderBase::VertexBase
  • remaining_tests : BehindObstacleExp_wT , BehindObstacleExperiment
  • RemoteDebugger() : PhysXPlugin::RemoteDebugger
  • remove() : APLightsEditor::Lights
  • REMOVE_CHILD : vrecko::World
  • REMOVE_EOCHILD : vrecko::World
  • removeAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • removeAbilityMapper() : APEditorController::EditorController
  • RemoveAddObserver() : ModelManager
  • removeAll() : APLightsEditor::Lights
  • removeAllAbilities()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • removeAllFields() : APHUD::HUDDisplay
  • removeAllHooks() : APDYNAMICART::HookManager
  • removeAllMarkers()
: VirtualFixture::MarkerFactory
, VirtualFixture::Trace
  • removeAllSectorsOnHoop() : APDYNAMICART::SectorManager
  • removeAnimation() : APObjectUtils::Animator
  • removeAttribRecursive() : vrecko::ReaderWriter
  • removeAttribute() : vreckoUtils::MenuRoot
  • removeAvatarView() : vrecko::World
  • removeChild() : vreckoUtils::MenuBase
  • removeConstrainedChildID() : APConstrainedMovement::ConstraintDescription
  • removeConstrainedDualPartnerID() : APConstrainedMovement::ConstraintDescription
  • RemoveDeleteObserver() : ModelManager
  • removeEntity()
: vrecko::Scheduler
, vrecko::vThread
  • removeEnvironmentObject() : vrecko::Scene
  • removeEOChild() : vrecko::EnvironmentObject
  • removeField() : APHUD::HUDDisplay
  • removeFromScene() : APWeather::Weather
  • RemoveGeometry() : GeometryState , AnimatedGeometryState
  • RemoveGetObserver() : ModelManager
  • removeHook() : APDYNAMICART::HookManager
  • removeHooksOnHoop() : APDYNAMICART::HookManager
  • removeInputOutputs()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • removeInputPin() : vrecko::BaseClass
  • removeItem() : APGUI::Layout
  • removeNotification() : vrecko::BaseClass
  • removeObject() : vrecko::OctTree
  • removeObserver() : vreckoUtils::Observable
  • removeOuterObject() : vrecko::EventDispatcher
  • removeOutputPin() : vrecko::BaseClass
  • removePartitioningObjectInterface() : vrecko::Scene
  • removePartitioningSceneInterface() : vrecko::Scene
  • removePoA() : APDYNAMICART::Controller
  • Remover() : CarSim::Remover
  • RemoveReference() : GeometryState , AnimatedGeometryState
  • removeRequestInputPin() : vrecko::BaseClass
  • removeRequestOutputPin() : vrecko::BaseClass
  • removeRequiredEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • removeSector() : APDYNAMICART::SectorManager
  • removeSectors() : SectorColorGen
  • removeState() : APDYNAMICART::PoAState
  • removeUnnecessaryWhitespace() : vrecko::ReaderWriter
  • removeUserData() : vrecko::EnvironmentObject
  • removeWall() : WGeometry::WG_Point
  • removeWindow() : APHUD::HUDDisplay
  • render_cloud_tex_u1 : CloudParticle
  • render_cloud_tex_u2 : CloudParticle
  • render_cloud_tex_v1 : CloudParticle
  • render_cloud_tex_v2 : CloudParticle
  • renderCloudTexturePath : CloudsProperties
  • RepairViolations() : ThinHeap< _NodeClass, _keyType >
  • reportError()
: vrecko::vThread
, vrecko::BaseClass
, vrecko::vThread
  • reportEvent()
: vrecko::World
, vrecko::EventDispatcher
, vrecko::World
  • reportEventCore() : vrecko::EventDispatcher
  • repositionModel() : APMenu::MenuItemText
  • req_len : vreckoDP_base::LHeadTracker
  • request() : vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • REQUEST : vrecko::EventDispatcher
  • request()
: vrecko::EventDispatcher
, vrecko::World
  • request_interconnection_map : vrecko::EventDispatcher
  • REQUEST_Map : vrecko::EventDispatcher
  • requestForDevice() : vrecko::DeviceManager
  • RequestInputPin() : vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • requestInputPinsList : vrecko::BaseClass
  • RequestOutputPin() : vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • requestOutputPinsList : vrecko::BaseClass
  • requestPointerLoc() : vrecko::ControllableAbility
  • requestPointerLocRaw() : vrecko::ControllableAbility
  • requestSelectionID() : vrecko::ControllableAbility
  • requestSelectionPath() : vrecko::ControllableAbility
  • requiredDeletedEdges : APSpacePartitioning::ELOD
  • reserve() : ConstantColorGen , GradientColorGen
  • Reset() : DynamicTreeIterator< _Type >
  • reset()
: APGUI::GUI_Controller
, APDYNAMICART::Limits
, AP_LSystem::ParseableString
, APGUI::ItemsGroup
, APSpacePartitioning::SNCH_Object::OneTri
, vreckoDP_base::LHeadTracker
  • resetBase() : vreckoDP_base::LHeadTracker
  • resetBaseValues() : APMenu::DynamicMenu
  • resetConfirmationEffect() : APMenu::MenuItem
  • resetCuttingLoop() : APConnectEditor::Cut
  • ResetDelta()
: ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableQuat
, ht::VariableFloat
  • resetErrors()
: vrecko::RWErrorHandler
, APMenu::MenuLoaderErrorHandler
, BCLoaderErrorHandler
  • resetGeometry() : APFFDEditor::EditorLogic
  • resetObjectUpdatesCounter() : vrecko::Scheduler
  • resetProcessedEventsCounter() : vrecko::EventDispatcher
  • resetScene() : APDYNAMICART::PhysXManager
  • resetToPos() : APObjectUtils::Animator
  • resetValues()
: AP_LSystem::AbstractTurtle
, APDYNAMICART::ToolSelector
  • resetView() : BehindObstacleExperiment , BehindObstacleExp_wT
  • resolveIntersections()
: APConnectEditor::Cut
, APObjectUtils::ObjectSelector
, APShootingSimulation::ShootingSimulation
  • resolveSelection()
: APConnectEditor::Cut
, APObjectUtils::ObjectSelector
  • rest_on_land() : boids::BoidsLogic
  • rest_time : boids::BoidsLogic
  • Restart() : PreloaderHeuristic , BasicPreloaderHeuristic
  • restoreAllPoAStates() : APDYNAMICART::PoAState
  • result : ConstantColorGen , GradientColorGen , ConstantColorGen
  • result_file : BehindObstacleExperiment , BehindObstacleExp_wT
  • ret_pos : vreckoDP_base::LHeadTracker
  • ret_rot : vreckoDP_base::LHeadTracker
  • ret_rotm : vreckoDP_base::LHeadTracker
  • ret_rotq : vreckoDP_base::LHeadTracker
  • returnColorOfVoxel() : APSpacePartitioning::VoxelGrid_Object_Data
  • revoke() : APGUI::ColorPicker
  • RevoluteJoint() : PhysXPlugin::RevoluteJoint
  • RGBtoHSL() : APGUI::ColorPicker
  • right : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode , ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • right_border : behindO::HeadManipulator
  • right_button : vreckoDP_base::L3DMouse
  • right_eye_off : ht::HeadTracking
  • right_hand
: navigation::KMTracker
, base::Avatar
, VirtualFixture::Avatar
  • right_leg : base::Avatar , VirtualFixture::Avatar
  • rightBlinkerPath : CarSim::GeometryPartsPath
  • RightBottom : ht::ScreenSetup
  • rightContext : AP_LSystem::Rule
  • righthand_id : BehindObstacleExp_wT , BehindObstacleExperiment
  • rightHandEO : APDYNAMICART::DAEnvironment
  • rightHandEO_ID : VirtualFixture::Avatar , base::Avatar
  • rightHandPosition : APDYNAMICART::Ctrl_PerlinLines
  • rightHandRule() : CarSim::RoadsState
  • RightTop : ht::ScreenSetup
  • rim_height : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • rim_width : ht::ScreenSetup::ScreenSetupState , ht::SetupFunction
  • RMFrameAdapter() : APDYNAMICART::RMFrameAdapter
  • road : CarSim::MessageRoadAndDir
  • roadId : CarSim::Edge
  • roads : CarSim::RoadsState
  • roadsEdges : CarSim::RoadsState
  • RoadsState() : CarSim::RoadsState
  • role : grass::GrassDrawable
  • ROLE : grass::GrassDrawable
  • rollArround()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • rollLeft()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • rollRight()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • rollUntilHorizontal()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • RoomEditor() : APRoomEdit::RoomEditor
  • RoomEditor::menuItemClicked() : APRoomEdit::RoomEditor
  • RoomLoader() : APRoomEdit::RoomLoader
  • RoomSaver() : APRoomEdit::RoomSaver
  • root : APSpacePartitioning::SphereBVH_Object_Data
  • root_node : vrecko::OctTree
  • rootBlockUpdater : PreloaderHeuristic
  • rootNode : vrecko::Scene , LoadingConsole
  • rootSizeCollisions : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeLOD : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeMulti : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeSimple : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeSingle : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rot : Triangle , vreckoDP_base::LHeadTracker , APEditorController::EditorController::ECPOINTERINFO
  • rot_diff : vreckoDP_base::LHeadTracker
  • rot_type : vreckoDP_base::LHeadTracker
  • rotate() : gmMatrix3 , gmMatrix4
  • Rotate() : base::Rotate
  • rotating : APConstrainedMovement::ConstrainedObjectMovement
  • Rotation() : APConnectEditor::Rotation
  • rotation
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
, APObjectUtils::Animator::AnimationPoint
, ArtificialWorld::AnimationPoint
  • rotation_matrix : vrecko::EnvironmentObject
  • rotation_step : navigation::KMTracker
  • RotationFrameAdapter() : APDYNAMICART::RotationFrameAdapter
  • RotationFrameFactory() : APDYNAMICART::RotationFrameFactory
  • rotationSet : ArtificialWorld::AnimationPoint
  • rotq : vreckoDP_base::LHeadTracker
  • rotq_diff : vreckoDP_base::LHeadTracker
  • rotRaw : APEditorController::EditorController::ECPOINTERINFO
  • RoundedSplineAdapter() : APDYNAMICART::RoundedSplineAdapter
  • Rule() : AP_LSystem::Rule
  • rule0_in_sight() : boids::BoidsLogic
  • rule1_centre_of_mass() : boids::BoidsLogic
  • rule2_away_from_others() : boids::BoidsLogic
  • rule3_match_velocity() : boids::BoidsLogic
  • rule4_bound_position() : boids::BoidsLogic
  • rule5_fly_to_waypoint() : boids::BoidsLogic
  • rule6_fly_from_danger() : boids::BoidsLogic
  • run : vrecko::vThread , APDYNAMICART::ComputeThread
  • Running() : Preloader
  • RVect : mv::CGesture
  • RWErrorHandler() : vrecko::RWErrorHandler
  • rx_buf : vreckoDP_base::LHeadTracker
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • s_corner : ht::HeadTracking
  • s_height : ht::HeadTracking
  • s_width : ht::HeadTracking
  • SampledSpline() : SampledSpline
  • samples : MTCreatorTool
  • sAnimationFile : APCameraPath::Camera
  • Save() : mv::Reader
  • save()
: APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, vrecko::ReaderWriter
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::SectorManager
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::Brush
, APDYNAMICART::ConstantDiamAdapter
, APDYNAMICART::PoAAdapter< T >
, Icon
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::PoB
, APDYNAMICART::BrushStroke
, APDYNAMICART::HookObject
, APDYNAMICART::HookManager
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::Hoop
, APDYNAMICART::HoopShape
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::NullHoopShape
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::Controller
, APDYNAMICART::NullAttractor
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::PerlinLines
, APDYNAMICART::PoA
  • SaveAnimation() : APCameraPath::Camera
  • saveCable() : AP_CableEditor::CableEditor
  • saveChildren() : vrecko::ReaderWriter
  • saveCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveCollisionsToFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveDataToFile() : APSpacePartitioning::PointShell_SimpleNode
  • saveDataToPC_SaveTreeNode() : APSpacePartitioning::SphereBVH_Object_Data
  • saveDataToPersistentCache_Init() : APSpacePartitioning::SphereBVH_Object_Data
  • saveDataToPersistentCache_WriteData() : APSpacePartitioning::SphereBVH_Object_Data
  • saveEnvironmentObject() : vrecko::ReaderWriter
  • saveFacesToFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • saveGridToFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveModel() : vrecko::PersistentCache
  • saveNodeToFileRec() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • savePointShellCollisions()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data
  • SaveSetup()
: ht::ScreenSetup
, ht::ScreenSetupSimple
  • saveState() : APDYNAMICART::PoAState
  • saveSubDivisionMeshToFile() : APSpacePartitioning::PointShell_Object_Data
  • saveToCache()
: APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • saveToFile : CloudsProperties
  • SaveToFile() : CloudsManager
  • saveToXML() : APLightsEditor::Editor
  • saveTreeNodeToFile()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • saveTreeToFile() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • saveVerticesToFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • saveWordToFile() : AP_LSystem::AbstractGenerator
  • saveXMLDocument() : vrecko::ReaderWriter
  • saveXMLParameters()
: base::Avatar
, base::Rotate
, base::ShowFDH
, vrecko::BaseClass
, BehindObstacleExp_wT
, BehindObstacleExperiment
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::WIM
, boids::Boid
, boids::BoidsLogic
, boids::BoidsPlanner
, APDYNAMICART::DAEnvironment
, Filter::Linear
, Filter::PosNoiseRemover
, APClouds::Clouds
, grass::Grass
, grass::GrassAbilityParameters
, navigation::AvatarInHand
, navigation::KMTracker
, ode::CappedCylinder
, ode::CompositeObject
, ode::Cube
, ode::Sphere
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Wiimote
  • Scale() : APConnectEditor::Scale
  • scale : ArtificialWorld::Model , ArtificialWorld::AnimationPoint , CloudsProperties , APObjectUtils::Animator::AnimationPoint , APObjectUtils::KeepOnScreen , gmMatrix3 , gmMatrix4
  • scale_vec : vrecko::EnvironmentObject
  • scaleSet : ArtificialWorld::AnimationPoint
  • scanDevice()
: vreckoDP_base::fdtDataGlove
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • scanDeviceX()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • scare_distance : boids::BoidsLogic
  • SCENE : vrecko::EventDispatcher
  • Scene() : vrecko::Scene
  • scene : vrecko::ScenePSThreadInfo
  • scene_mouse_position : base::MouseHand
  • scene_ptr : vrecko::EventDispatcher
  • sceneFile
: vrecko::BaseClass
, vrecko::EventDispatcher::REQUEST_Struct
, vrecko::EventDispatcher::EventDefinitionStruct
  • sceneInfo : CloudsManager
  • ScenePSThreadProc : vrecko::Scene
  • SceneSave() : APEditorQAbilities::SceneSave
  • Scheduler() : vrecko::Scheduler
  • scInt : vrecko::Scene::SC_INT_PRIO
  • scIntId : vrecko::SP_SceneInterface
  • scIntPtr : vrecko::CollisionParams__ver1
  • score_map : behindO::CentreObjectManipulator
  • Screen() : ht::Screen
  • screen : ht::HeadTracking
  • screenHeight : CloudSceneInfo
  • ScreenSetup() : ht::ScreenSetup
  • ScreenSetupSimple() : ht::ScreenSetupSimple
  • screenWidth : CloudSceneInfo
  • sculptureSize : APDYNAMICART::Configuration
  • SD_FORWARD : Sector
  • SD_REVERSE : Sector
  • searchFinnished : PreloaderHeuristic
  • SearchFinnished() : PreloaderHeuristic
  • secCount : CarSim::TLsOnJuncManager
  • sectionsTiming : vrecko::Logger
  • sector : APDYNAMICART::SectorInfo
  • Sector() : Sector
  • SectorColorGen() : SectorColorGen
  • SectorInfo() : APDYNAMICART::SectorInfo
  • SectorInfoList : APDYNAMICART::SectorManager
  • SectorManager() : APDYNAMICART::SectorManager
  • selected_object : base::hand , base::MouseHand
  • selectedCableBaseRadius : AP_CableEditor::CableEditor
  • selectedCableId : AP_CableEditor::CableEditor
  • selectedCablePtr : AP_CableEditor::CableEditor
  • selectedItem : APMenu::DynamicMenu
  • selectedObject : APConnectEditor::Cut
  • selectedObjectID : APCameraMovement::CameraMovementEditor
  • selectedPlanes : APEditorQAbilities::ObjectMovement
  • selection_point : behindO::ChangeOfVisibility
  • selectionVisibilityUpdate() : APEditorController::EditorController
  • selectRule()
: AP_LSystem::LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParStoch0LSystem
  • selObjectID : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • selPath : APEditorController::EditorController::ECPOINTERINFO
  • send() : vrecko::OutputPin< _MessageType >
  • sender
: vrecko::EventDispatcher::ICS
, vrecko::EventDispatcher::EventDefinitionStruct
, APGUI::Interconnection
, ode::DynamicScene::MessageODERequest
  • sender_backup : behindO::MappingFunctions
  • sender_decomposition : vrecko::EventDispatcher
  • senderIdOrInputName : vrecko::EventDispatcher::EventStruct
  • senderString : vrecko::BaseClass , Receiver
  • senderStringWithOutputName : vrecko::OutputPin< _MessageType > , vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • sendEvent() : vreckoDP_base::OptiTrack
  • sendflag
: VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
  • sendMousePosIfReady() : vreckoDP_base::KeyboardMouse
  • sendNewMapping() : APEditorController::AbilityMapper
  • sendNotifications() : vrecko::BaseClass
  • sendPointerBtnToRelevantOutputs() : APEditorController::EditorController
  • sendPointerSelectionEvent() : APEditorController::EditorController
  • sendPosition() : vreckoDP_Kinect::Kinect
  • sendSensorTransformation() : vreckoDP_Kinect::Kinect
  • sendSkeletonPositions() : vreckoDP_Kinect::Kinect
  • SendTerminationNotifications() : vrecko::World
  • sendToClickedOutput() : APMenu::DynamicMenu
  • SendUseSignal() : APEditorQAbilities::UseTrigger
  • sendValue() : APGUI::Slider
  • sensor_count : vreckoDP_base::OptiTrack
  • sensor_offset
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • sensor_relative_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • sensorNumber : MagicWandTool , MTCreatorTool
  • sensorScale : vreckoDP_base::OptiTrack
  • SEPARATE_GEOMETRY_FOR_TRANSLUCENT : AP_LSystem::TurtleProperties
  • separation() : vrecko::Scene
  • serial_number : Hci
  • server_address : vreckoDP_base::OptiTrack
  • set() : Sector , APDYNAMICART::SimpleBox , osgQ::QSection
  • SET_STATESET : vrecko::World
  • SET_TEXT : vrecko::World
  • setAbilityMapping() : APEditorController::EditorController
  • setActiveMember() : APGUI::ItemsGroup
  • setActiveShadowLight() : APLightsEditor::Lights
  • setActor() : APDYNAMICART::Hoop
  • setActorOrientation() : APDYNAMICART::PhysXManager
  • setActorPosition() : APDYNAMICART::PhysXManager
  • setActualAvatarView() : vrecko::World
  • setAll() : mv::CPlayer
  • setAllBindingForMethod() : BehindObstacleExp_wT , BehindObstacleExperiment
  • setAllowedOutput() : vrecko::Logger
  • setAlpha() : APObjectUtils::Animator
  • setAndPlayConfirmationEffect() : APMenu::MenuItem
  • setAndSendValue() : APGUI::Slider
  • setAngleFrom() : osgQ::QSection
  • setAngleTo() : osgQ::QSection
  • setAngularVel() : ode::DynamicScene
  • SetAnimation() : ArtificialWorld::SubBlock
  • SetAnimationIndex() : ArtificialWorld::AnimatedModel
  • setAnimationPointsNumber() : APObjectUtils::Animator
  • SetAnimationType() : ArtificialWorld::SubBlockAnimation
  • setAreaClassString() : APConstrainedMovement::ConstraintArea , ConstraintHierarchyMember
  • setArgumens() : vrecko::World
  • setAtributesForDeformation() : APFFDEditor::EditorLogic
  • setAttribute()
: APMenu::DynamicMenu
, vrecko::BaseClass
  • setAutoRotationActive() : APDYNAMICART::DAEnvironment
  • setAxiom()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • setBaseR() : vreckoDP_base::LHeadTracker
  • setBaseT() : vreckoDP_base::LHeadTracker
  • setBehaviour() : vrecko::BufferedFile
  • setBinormal() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setBlinkers() : CarSim::CarControlUnit
  • setBlurSize() : APLightsEditor::Lights
  • setBottomCCWVertex() : WGeometry::WG_Vertices
  • setBottomCWVertex() : WGeometry::WG_Vertices
  • setBottomNormal() : WGeometry::WG_Wall
  • setBounceRadius() : APLightsEditor::Lights
  • setBounceSampleCount() : APLightsEditor::Lights
  • setBoundAreaCount() : APConstrainedMovement::ConstraintDescription
  • setBoundAreaNormal() : APConstrainedMovement::ConstraintDescription
  • setBounding() : APDYNAMICART::PerlinLines
  • setBoundingVisible() : APDYNAMICART::PerlinLines
  • setBufSize() : vrecko::BufferedFile
  • setCableColor() : AP_CableEditor::Cable
  • setCableID() : AP_CableEditor::Cable
  • setCallBacks() : vrecko::PyAbility
  • SetCamera() : Cloud
  • setCameraData() : CloudDataType
  • setCaption() : APMenu::MenuItemText
  • setCastShadows() : vrecko::EnvironmentObject
  • setCenter() : osgQ::QSection
  • setCharacteristics() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setChoosenBoundaryLoop() : SnapObject
  • setClearColor() : APLightsEditor::Lights
  • setClosed() : SampledSpline
  • SetCloudParticleTexture() : Cloud
  • setColor()
: APDYNAMICART::Attractor
, APDYNAMICART::ColorGenAdapter
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::ComputeThread
, APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PerlinLines
, WGeometry::WG_Wall
  • setColorAdapter() : APDYNAMICART::Brush
  • setColorEnd() : GradientColorGen
  • setColorGenerator() : SweepSurfaceGeode
  • setColorIndex() : APDYNAMICART::ColorGenAdapter
  • setColorofPart() : Icon
  • setColorProfileforWindow() : APHUD::HUDDisplay
  • setColorStart() : GradientColorGen
  • setColorValue() : ConstantColorGen
  • setColour()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::SimpleBox
, MTBrush
  • setColours()
: APGUI::GUI_Item
, APGUI::Slider
  • setColourType() : MTBrush
  • SetCommentSymbol() : WAVEFRONT::InPlaceParser
  • setComponent() : APDYNAMICART::PS_Polyhedron
  • setComputedTime() : APDYNAMICART::BrushStroke
  • setController() : APDYNAMICART::PerlinLines
  • setControlPoints() : AP_CableEditor::Cable
  • setControlSpheresColor() : AP_CableEditor::Cable
  • setControlSpheresRadiusAdjust() : AP_CableEditor::Cable
  • setCountOfControlPoints() : APFFDEditor::Grid
  • setCrosshairPos() : APShootingSimulation::ShootingSimulation
  • setCrossSectionAdapter() : APDYNAMICART::Brush
  • setCrossSectionGenerator() : APDYNAMICART::HoopGeometry
  • setCrossSectionInterpolation() : APDYNAMICART::BrushStroke
  • setCrossSectionInterpolationSteps() : APDYNAMICART::Brush
  • setCrossSectionShape() : MTBrush
  • setCrossSectionSpline() : SweepSurfaceGeode
  • setCrossSectionType() : APDYNAMICART::BrushStroke , MTBrush
  • setDAEnvironment()
: APDYNAMICART::ToolEraser
, APDYNAMICART::ToolTongs
  • setDefaultColor() : SectorColorGen
  • setDefaultPattern() : APDYNAMICART::SectorManager
  • setDefaultTurtleProperties() : AP_LSystem::LSGeode
  • SetDelta()
: ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
, ht::VariableQuat
  • setDescribtion() : VirtualFixture::Marker
  • setDescription()
: vrecko::Scene
, vrecko::World
  • setDeviceManagerPtr() : vrecko::World
  • setDiameter()
: APDYNAMICART::Brush
, APDYNAMICART::Hoop
, APDYNAMICART::BrushStrokeControlPoint
, MTBrush
  • setDiameterAdapter() : APDYNAMICART::Brush
  • setDiameterEnd() : GradientDiameterGen
  • setDiameterGenerator() : SweepSurfaceGeode
  • setDiameterStart() : GradientDiameterGen
  • setDirection() : mv::CPlayer
  • setDirty()
: APCameraMovement::CameraPath
, APRoomEdit::Tool
, APRoomEdit::WallGeometry
  • setDirtyAll() : SnapObject
  • setDirtyBoundaryLoop() : SnapObject
  • setDirtyClosestPoint() : SnapObject
  • setDirtyGraph() : SnapObject
  • setDirtyMaxDistance() : SnapObject
  • setDirtySnappingRegion() : SnapObject
  • setDisplaySettings()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setDistanceFieldTempValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • setDistanceFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • setDORadius() : APLightsEditor::Lights
  • setDOSampleCount() : APLightsEditor::Lights
  • setEdgesCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setEdgeVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setEffectType() : APObjectUtils::ObjectEffect
  • setEnable() : vrecko::PersistentCache
  • setEnabledAnimations() : APObjectUtils::Animator
  • setEnableFlag() : ode::DynamicScene
  • setEo() : SnapObject
  • setEoWrapper() : AP_CableEditor::Cable
  • setEventDispatcherPtr() : vrecko::World
  • setFace() : APDYNAMICART::PS_FacePlane
  • setFaceNormal() : WGeometry::WG_Wall
  • setFieldAsAnimated() : APHUD::HUDDisplay
  • SetFile() : WAVEFRONT::InPlaceParser
  • setFileName() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetFileName()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setFilePos() : vrecko::BufferedFile
  • setFlag() : WGeometry::WG_Wall
  • setFlags() : APMenu::MenuItem
  • setFlagsCore() : APMenu::MenuItem
  • setForce()
: ode::DynamicScene
, mv::CPlayer
  • setForceToDynamicObject() : ode::DynamicScene
  • setFusionDistance()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setGeometry() : vrecko::EnvironmentObject
  • setGestureFunc() : vreckoDP_base::fsPinchGlove
  • setGlobalAmbient() : APLightsEditor::Lights
  • SetGridUnitSizeXYZ() : PseudoRand2DPlacement
  • SetHard() : WAVEFRONT::InPlaceParser
  • SetHardSeparator() : WAVEFRONT::InPlaceParser
  • setHeight()
: APDYNAMICART::SimpleBox
, osgQ::QSection
, WGeometry::WG_Hole
  • setHighLighting() : MotionTrailTriangulator
  • setHighlighting() : vreckoUtils::HighlightCallback
  • setId()
: SnapObject
, WGeometry::WG_Point
, WGeometry::WG_Wall
, VirtualFixture::Marker
  • setID()
: vrecko::Ability
, vrecko::Device
, vrecko::EnvironmentObject
  • setIdentityTransformation() : vrecko::EnvironmentObject
  • setIncrementValue() : vreckoUtils::HighlightCallback
  • setIndexBottom() : WGeometry::WG_Point
  • setIndexTop() : WGeometry::WG_Point
  • setInitialPosition()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setInitialRotation()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setInnerRadius() : osgQ::QSection
  • SetInterpolation() : ArtificialWorld::SubBlockAnimation
  • setInterpolation() : AP_CableEditor::Cable
  • setInterpolationCount() : APDYNAMICART::PerlinLines
  • setInterpolationSteps()
: APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
, InterpolatedSpline
, MTBrush
  • setInterpolationType() : APObjectUtils::Animator
  • setInterpolator() : InterpolatedSpline
  • setIntersection()
: APCameraMovement::CameraMovementEditor
, APRoomEdit::RoomEditor
  • setIsLoaded() : vrecko::Scene
  • setJustMoving() : APConstrainedMovement::ConstraintDescription
  • setLabel() : VirtualFixture::Marker
  • SetLastCam() : Cloud
  • setLayout()
: APDYNAMICART::Mode
, APDYNAMICART::Basic
, APDYNAMICART::Advanced
, APDYNAMICART::Utils
, APGUI::GUI_Controller
  • setLeadingSpline()
: APDYNAMICART::BrushStroke
, APDYNAMICART::HoopShape
, SweepSurfaceGeode
  • setLength() : APDYNAMICART::PerlinLines
  • setLevelMinMax() : APObjectUtils::ObjectEffect
  • setLevelZeroSize() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setLight()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setLightVisibility() : APLightsEditor::Lights
  • setLinearVel() : ode::DynamicScene
  • setLineParameters() : APDYNAMICART::PerlinLines
  • setLinesParameters() : APDYNAMICART::PerlinLines
  • setLocation() : ChessPiece
  • setLoop() : mv::CPlayer
  • setLoopType() : APObjectUtils::Animator
  • SetLoopType() : ArtificialWorld::SubBlockAnimation
  • setMagnet() : APDYNAMICART::PerlinLines
  • setMainThreadId() : vrecko::EventDispatcher
  • setMappedAbility() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • setMatrix() : base::MTMatrixTransform
  • setMaxChildrens() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMaxCloudUpdates() : Cloud
  • setMaxForce() : APSpacePartitioning::SNCH_Object
  • setMaxLevel() : base::ShowFDH
  • setMaxLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setMenuShown() : APGUI::GUI_Controller
  • setMenuString() : APMenu::DynamicMenu
  • setMinimalSampleDistance() : SampledSpline
  • setMinimumVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMinVisibleDistance() : ArtificialWorld::Model
  • setMode() : APLightsEditor::Lights
  • setModelFile() : APMenu::MenuItemText
  • setModelFileName() : vrecko::EnvironmentObject
  • SetModelFlags() : ArtificialWorld::Model
  • SetModelType() : ArtificialWorld::Model
  • setMovable() : mv::CGesture
  • setMovableVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setName()
: vrecko::EnvironmentObject
, APMenu::MenuItem
, APRoomEdit::Tool
  • setNCoeficient() : APSpacePartitioning::SNCH_Object
  • setNetSupport() : vrecko::EventDispatcher
  • setNewSelection() : APEditorController::EditorController
  • SetNode : APFFDEditor::GeometryLoader::Geometry
  • SetNodeAllowedCallback() : DynamicTreeIterator< _Type >
  • setNodeMask() : APObjectUtils::Animator
  • setNormal() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setNormalCCWVertex() : WGeometry::WG_Vertices
  • setNormalCWVertex() : WGeometry::WG_Vertices
  • setNormalVector() : APConstrainedMovement::ConstraintArea
  • SetObjectCenterDir() : ArtificialWorld::BlockAttributes
  • SetObjectCenterPoint() : ArtificialWorld::BlockAttributes
  • setObjectSelectionbyRightHand() : APDYNAMICART::DAEnvironment
  • setOnce() : mv::CMVect
  • setOpacity() : APDYNAMICART::PS_Layer
  • setOptimalizationOfCP() : APFFDEditor::Grid
  • setOrientationKeepUp() : base::Avatar
  • setOriginPosition()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setOSGAdapter() : vrecko::EnvironmentObject
  • setOuterAngleAddition() : osgQ::QSection
  • setOuterRadius() : osgQ::QSection
  • setOutputDest() : vrecko::Logger
  • setOwner()
: vrecko::Ability
, APEditorController::EditorController::ECPOINTERBUTTONINFO
, APEditorQAbilities::ObjectMovement::SnapBox
  • setParameters()
: APDYNAMICART::Ctrl_PerlinLines
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetParentEO() : ArtificialWorld::BlockUpdater
  • setPartColour() : APGUI::Icon
  • setPatternColor() : APDYNAMICART::Ctrl_StringSculptures
  • setPause() : mv::CPlayer
  • setPlane() : RegularPolygonSpline
  • setPlay() : mv::CPlayer
  • setPluginName() : vrecko::Ability
  • setPoA() : APDYNAMICART::DATool
  • SetPoint()
: APNature::Terrain2D
, APNature::Terrain2DSegment
  • setPoint() : WGeometry::WG_Wall
  • setPointArray() : APDYNAMICART::Painted
  • SetPointHeight()
: APNature::TerrainAlgorithm
, APNature::Terrain2D
, APNature::TerrainUtility
  • setPoints() : WGeometry::WG_Wall
  • setPolygonsCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setPolygonVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setPortName() : vrecko::Device
  • setPosition()
: APDYNAMICART::BrushStrokeControlPoint
, vrecko::EnvironmentObject
  • SetPosition()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setPosition()
: vrecko::EnvironmentObject
, WGeometry::WG_Point
, WGeometry::WG_Hole
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
, VirtualFixture::Marker
  • setPriority()
: vrecko::BaseClass
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • setProperties()
: APObjectUtils::CopyProperties
, AP_LSystem::AbstractTurtle
  • setProperty() : AP_LSystem::Configuration
  • SetQuoteChar() : WAVEFRONT::InPlaceParser
  • setRadius() : AP_CableEditor::Cable , RegularPolygonSpline
  • setReceiverPtrDirty() : vrecko::EventDispatcher::ICSBase
  • setReleaseFunc() : vreckoDP_base::fsPinchGlove
  • setRestrictorString() : APConstrainedMovement::ConstraintArea
  • setRFGenerator() : SweepSurfaceGeode
  • setRotation()
: vrecko::EnvironmentObject
, APObjectUtils::Animator
  • SetRotation()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setRotation() : osgQ::QSection
  • setRotationFrame() : APDYNAMICART::BrushStrokeControlPoint
  • setRotationFrameAdapter() : APDYNAMICART::Brush
  • setRotationShift() : RegularPolygonSpline
  • setRotationType() : vreckoDP_base::LHeadTracker
  • setScale()
: vrecko::EnvironmentObject
, APObjectUtils::Animator
  • SetScale() : ArtificialWorld::Model
  • setScene() : BehindObstacleExp_wT , BehindObstacleExperiment
  • setSceneData()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setSceneFile() : vrecko::BaseClass
  • SetSceneInfo() : Cloud
  • setScenePtr()
: vrecko::EventDispatcher
, vrecko::World
  • setSchedulerPtr() : vrecko::World
  • SetScreen() : ht::Screen
  • setSector() : SectorColorGen
  • setSectorEditing() : APDYNAMICART::Ctrl_StringSculptures
  • setSegmentCount() : RegularPolygonSpline
  • setSegmentLength() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • SetSegmentPosition() : APNature::Terrain2DSegment
  • setSensorCount() : APDYNAMICART::Ctrl_MotionVisualization
  • setSensorNumber() : APDYNAMICART::ToolBrush
  • setShape()
: AP_CableEditor::Cable
, APDYNAMICART::Hoop
  • setShapeCurveGenerator() : APDYNAMICART::HoopGeometry
  • setShapeRotate() : AP_CableEditor::Cable
  • setShowAxis() : APDYNAMICART::Ctrl_StringSculptures
  • setShowTimeWarnings() : vrecko::World
  • setSign() : APMenu::DynamicMenu
  • setSignalType() : vreckoDP_base::fdtDataGlove
  • setSignName() : APMenu::MenuItemText
  • setSimulationRun() : APDYNAMICART::PhysXManager
  • setSize() : APDYNAMICART::DATool
  • setSlaveTransmitterType() : vreckoDP_base::LHeadTracker
  • setSliderParameter() : APDYNAMICART::Attractor
  • setSliderParameters() : APGUI::Slider
  • setSliderPos01() : APMenu::MenuItemSlider
  • setSliderPosXY() : APMenu::MenuItemSlider
  • setSmoothness()
: APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
  • SetSourceData() : WAVEFRONT::InPlaceParser
  • setSpeed()
: APDYNAMICART::PerlinLines
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • setSpeeds() : MTBrush
  • setSPoint() : mv::CGesture
  • setStartTick() : vrecko::Timer
  • setState()
: APGUI::ColorPicker
, APGUI::GUI_Item
, APGUI::Icon
, APGUI::Menu
, APGUI::Slider
  • SetState() : APObjectUtils::ObjectEffectMan
  • setStopedIncomingCarToShortEdges() : CarSim::RoadsState
  • setStringJoints() : APDYNAMICART::PhysXManager
  • setStringLineWidth() : APDYNAMICART::PatternsGeode
  • SetSubBlockType() : ArtificialWorld::SubBlock
  • SetSubTreeAllowedCallback() : DynamicTreeIterator< _Type >
  • SetSunLight() : Cloud
  • setTangent() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setTestComputation() : APSpacePartitioning::PointShellVSVoxel_Object
  • setText() : APGUI::GUI_Text
  • setThreadingModel() : vrecko::ViewerBase
  • setTime() : TimeLineSpline
  • setTimeout() : Timing
  • setTimePerLoop() : APObjectUtils::Animator
  • SetTimePerLoop() : ArtificialWorld::SubBlockAnimation
  • setTimeWarningsTime() : vrecko::World
  • settleIterations : APDYNAMICART::InitSettings
  • setTopCCWVertex() : WGeometry::WG_Vertices
  • setTopCWVertex() : WGeometry::WG_Vertices
  • setTopNormal() : WGeometry::WG_Wall
  • setTorque() : ode::DynamicScene
  • setTorqueToDynamicObject() : ode::DynamicScene
  • setTransformationFromMatrix() : APObjectUtils::Animator
  • SetTranslateErrorTolerance() : Cloud
  • setTranslateMapping()
: vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
  • setTranslation() : APObjectUtils::Animator
  • setTransparency() : vrecko::EnvironmentObject
  • SetTree() : DynamicTreeIterator< _Type >
  • setTriangulationAngle() : APDYNAMICART::BrushStrokeControlPoint
  • setTurtleType() : AP_LSystem::LSGeode
  • setTvalue() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • setType() : ChessPiece , WGeometry::WG_Hole
  • setUpCamera() : APLightsEditor::Lights
  • setUpCustomProcessEventCallback() : APDYNAMICART::DAEnvironment
  • setUpdate() : AP_CableEditor::Cable
  • setUpdateFlag() : APDYNAMICART::PoA
  • SetupFunction() : ht::SetupFunction
  • setUseFrenetFrame() : MotionTrailTriangulator
  • SetUVCoords() : CloudsManager
  • setV0() : mv::CMVect
  • setV1() : mv::CMVect
  • setValidEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidVertices()
: APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, WGeometry::WG_Vertices
  • SetValue()
: ht::VariableVec3
, ht::VariableVec2
, ht::VariableQuat
  • setValue()
: APGUI::Slider
, APHUD::HUDDisplay
, vreckoUtils::MenuSlider
  • SetValue() : ht::VariableFloat
  • setValueFromString()
: base::SystemInfo::MessageSIThreadCreated
, vrecko::VreckoMessage
, vrecko::MessageVoid
  • setValuesXYZ() : APDYNAMICART::ToolMagicWand
  • setVect() : mv::CMVect
  • setVertexArray()
: APDYNAMICART::PatternBase
, APDYNAMICART::PatternsGeode
, SampledSpline
, BufferedSpline
  • setVertexVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setVerticesCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • setViewerPtr() : vrecko::World
  • SetViewMatrix() : Cloud
  • setVisibleVisualBox() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setWasTested() : APConstrainedMovement::ConstraintDescription
  • setWidth() : WGeometry::WG_Hole
  • SetWorldRoot() : PreloaderHeuristic
  • setWorldTransformationFromObject() : APConstrainedMovement::ConstraintArea
  • setWriting() : vrecko::BenchmarkWriter
  • setWTime() : mv::CGesture
  • setY() : WGeometry::WG_Hole
  • SG_OPERATION_TYPE : vrecko::World
  • shadeMode : APLightsEditor::Lights , APLightsEditor::Editor
  • shadingModes : APLightsEditor::Lights
  • SHADOW_MAP : APLightsEditor::Lights
  • shadowedScene : vrecko::World
  • shadowEO : APMenu::DynamicMenu
  • shadowMode : APLightsEditor::Lights , APLightsEditor::Editor
  • shadowModes : APLightsEditor::Lights
  • shadowObject : APEditorQAbilities::ObjectMovement
  • shapeBox
: APMenu::MenuItem
, APEditorQAbilities::ObjectMovement::SnapBox
, APObjectUtils::ObjectEffect
  • shapeCone : APObjectUtils::ConnectionViz::Connection
  • shapeCurveGenerator : APDYNAMICART::Configuration
  • shapeDraw
: APObjectUtils::ConnectionViz::Connection
, APMenu::MenuItem
, APEditorQAbilities::ObjectMovement::SnapBox
, APObjectUtils::ObjectEffect
  • shapeDrawables : APObjectUtils::ObjectEffect
  • shapePoints : AP_CableEditor::Cable
  • shapeSection : APMenu::MenuItem
  • shapesFile : AP_CableEditor::CableEditor
  • shapeSphere : APObjectUtils::ObjectEffect
  • shift() : APConstrainedMovement::ConstraintArea
  • shiftAllConstrainedObjects() : APConstrainedMovement::ConstraintDescription
  • shiftLen2 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • shiftVec : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • ShootingSimulation() : APShootingSimulation::ShootingSimulation
  • show() : APDYNAMICART::DAGizmo , DAGizmo
  • Show() : ArtificialWorld::BlockUpdater
  • show()
: APGUI::GUI_Text
, APEditorQAbilities::ObjectMovement::SnapBox
, APMenu::MenuItem
, vrecko::EnvironmentObject
, APGUI::Layout
, APGUI::GUI_Item
  • showAxis() : APDYNAMICART::Hoop
  • showChildMenu() : APMenu::DynamicMenu
  • showCloseCuttingLoop() : APConnectEditor::Cut
  • showCuttingLoop() : APConnectEditor::Cut
  • showDebugNormals() : SweepSurfaceGeode
  • ShowFDH() : base::ShowFDH
  • ShowFDHModel() : base::ShowFDHModel
  • showGizmo() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • showGraphicsAtPoint()
: APMenu::MenuItemText
, APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemSlider
  • showMainMenuObject() : APMenu::DynamicMenu
  • showMenu()
: vrecko::ControllableAbility
, APMenu::DynamicMenu
  • showMenuWithObjects() : APEditorQAbilities::ObjectAdd
  • showPoint() : CarSim::RoadsState
  • showPointerTrail() : APMenu::DynamicMenu
  • ShowSubBlocks() : ArtificialWorld::BlockUpdater
  • showToolMenu() : APRoomEdit::RoomEditor
  • showTooltip() : APGUI::GUI_Item
  • shutdown() : vreckoDP_base::KeyboardMouse
  • sibling : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
  • side : AABoundingBox
  • sight_angle : boids::BoidsLogic
  • signName : APMenu::MenuItemText
  • signObject : APMenu::MenuItemText
  • signs : APMenu::DynamicMenu
  • signTransform : APMenu::MenuItemText
  • Simple : APObjectUtils::Animator , APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • SimpleBox() : APDYNAMICART::SimpleBox
  • simpleCfgCmd() : Hci
  • SimpleObjectMovement() : APEditorQAbilities::SimpleObjectMovement
  • SimpleSetupFunction() : ht::SimpleSetupFunction
  • simpleString() : Hci
  • SimpleVREdit : vrecko::CAINFO__VER1
  • SimulationParameters() : APDYNAMICART::SimulationParameters
  • Sine : APObjectUtils::Animator
  • singleCollisionTest() : APSpacePartitioning::NoPartitioning_Scene
  • singleReport() : vreckoDP_base::LHeadTracker
  • SIThreadInfo() : base::SystemInfo::SIThreadInfo
  • size
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
, VirtualFixture::Box
, VirtualFixture::ProxiBox
, APDYNAMICART::DATool
, APDYNAMICART::InitSettings
, Particle
, VK_NoStepInto_Namespace::DynamicArray< _Type >
, APLightsEditor::Lights
  • sizeBirth : APDYNAMICART::ParticleSystemParameters
  • sizeDeath : APDYNAMICART::ParticleSystemParameters
  • sizeX : APHUD::HUDWindow
  • sizeY : APHUD::HUDWindow
  • skyboxCenterPosition : CloudsProperties
  • skyboxShow : CloudsProperties
  • skyboxSize : CloudsProperties
  • skyBoxTexturePathEast : CloudsProperties
  • skyBoxTexturePathNorth : CloudsProperties
  • skyBoxTexturePathSouth : CloudsProperties
  • skyBoxTexturePathTop : CloudsProperties
  • skyBoxTexturePathWest : CloudsProperties
  • SliceTool() : SliceTool
  • slideMax : APTextOutput::Console
  • Slider() : APGUI::Slider
  • Slider::intersectSegmentandPlane() : APGUI::Slider
  • sliderChanged()
: APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::HoopShape
, APDYNAMICART::Brush
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::ConstantDiamAdapter
, APDYNAMICART::PoAAdapter< T >
  • sliderDrawM : APMenu::MenuItemSlider
  • sliderDrawNM : APMenu::MenuItemSlider
  • sliderMovable : APMenu::MenuItemSlider
  • sliderNonmovable : APMenu::MenuItemSlider
  • slowTimeout() : Hci
  • small_distance : boids::BoidsLogic
  • smer : navigation::KMTracker
  • smer3d : navigation::KMTracker
  • smooth() : APDYNAMICART::PerlinLines
  • SmoothedSpline() : SmoothedSpline
  • snap() : APConnectEditor::ConnectEditor
  • SnapBox() : APEditorQAbilities::ObjectMovement::SnapBox
  • snapBoxes : APEditorQAbilities::ObjectMovement
  • SnapObject() : SnapObject
  • snapPoint : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • SnapPoint() : APDYNAMICART::SnapPoint
  • SNCH : APObjectUtils::ObjectEffect
  • SNCH_Object() : APSpacePartitioning::SNCH_Object
  • SNCH_Object_Data() : APSpacePartitioning::SNCH_Object_Data
  • SNCHFaceGroups : APObjectUtils::ObjectEffect
  • sockfd : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • sockname : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • soCuttingLoop : APConnectEditor::Cut
  • SOFT_SHADOW_MAP : APLightsEditor::Lights
  • solvePointerSelection() : APMenu::DynamicMenu
  • SOparent_mat : base::hand , base::MouseHand
  • SortAway : Cloud
  • sortVerticesClockwise()
: APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoaderBase
  • sourceID : APConnectEditor::Optimalizer
  • SP_Object_Data_Base() : APSpacePartitioning::SP_Object_Data_Base
  • SP_Object_DataInterface() : vrecko::SP_Object_DataInterface
  • SP_ObjectInterface() : vrecko::SP_ObjectInterface
  • SP_SceneInterface() : vrecko::SP_SceneInterface
  • space_scale : behindO::MappingFunctions
  • space_size : vrecko::OctTree
  • spBranchingFactor : APSpacePartitioning::PointShell_Object_Data
  • specialCase : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • specialKeyPress() : vreckoDP_base::KeyboardMouse
  • specialKeyRelease() : vreckoDP_base::KeyboardMouse
  • speed2force : VirtualFixture::Damper
  • speedMax : APDYNAMICART::ParticleSystemParameters
  • speedMin : APDYNAMICART::ParticleSystemParameters
  • Sphere()
: ode::Sphere
, VirtualFixture::Sphere
, PhysXPlugin::Sphere
  • sphereBetweenPoints : AP_CableEditor::CableEditor
  • SphereBVH : APObjectUtils::ObjectEffect
  • SphereBVH_Object() : APSpacePartitioning::SphereBVH_Object
  • SphereBVH_Object_Data() : APSpacePartitioning::SphereBVH_Object_Data
  • SphereBVH_Scene() : APSpacePartitioning::SphereBVH_Scene
  • spheresRadius : APGUI::ColorPicker
  • SphericalJoint() : PhysXPlugin::SphericalJoint
  • SplineFactory() : APDYNAMICART::SplineFactory
  • splitString() : APDYNAMICART::Utils
  • SPoint : mv::CGesture
  • spotCutoff : base::Light
  • spotExponent : base::Light
  • square_size : ChessBoard
  • SRType : vrecko::EventDispatcher
  • start() : Timing , Sector , navigation::AvatarInHand , vrecko::vThread
  • Start() : Preloader
  • start() : vrecko::Scheduler
  • Start() : DynamicTreeIterator< _Type >
  • start1stAnimation() : APCameraPath::Camera
  • start_tick : BehindObstacleExperiment , BehindObstacleExp_wT
  • startAnimation()
: APCameraMovement::CameraPath
, APObjectUtils::Animator
  • startDirection : CarSim::CarControlUnit
  • startEdge : CarSim::StartStopDestination
  • startIteration()
: vrecko::Enumeration< tval, tref >
, vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • startMotion() : Arm
  • startOffset : CarSim::StartStopDestination
  • startPhysics() : APDYNAMICART::PhysXManager
  • startPos : APFFDEditor::Grid::ControlPoint
  • startRoad : CarSim::CarControlUnit
  • startSimulation() : APDYNAMICART::Ctrl_StringSculptures
  • startStopDestination : CarSim::Parameters
  • startThreadedHierarchyCreation() : APSpacePartitioning::SP_Object_Data_Base
  • startTime : vrecko::Logger::TimingInfo
  • starttime_stamp : vrecko::Logger
  • startTiming() : vrecko::Logger
  • startWindowHeight : APHUD::HUDDisplay
  • startWindowWidth : APHUD::HUDDisplay
  • state : vrecko::Scheduler , APCameraPath::Camera
  • STATE_ANIMATING : APCameraPath::Camera
  • STATE_EDITING : APCameraPath::Camera
  • STATE_MOVING : APCameraPath::Camera
  • StateMap : APDYNAMICART::PoAState
  • stateSet : APObjectUtils::Animator , APHUD::HUDDisplay
  • stateset_map : behindO::CuttingPlane
  • StaticAttribute() : vrecko::StaticAttribute< type, tval, tref >
  • StaticString() : AP_LSystem::StaticString
  • staticStrings : AP_LSystem::Rule
  • status : ChessBoard
  • stdCmd() : Hci
  • Step() : mv::CPlayer
  • step : base::Rotate
  • Step() : mv::CPlayer
  • Step_backward() : mv::CPlayer
  • step_counter : vrecko::vThread
  • Step_forward() : mv::CPlayer
  • steps_before_disable_state : ode::ODEObject
  • stereoscopic : BehindObstacleExp_wT , BehindObstacleExperiment
  • stiffness
: VirtualFixture::AxisLock
, VirtualFixture::Sphere
, VirtualFixture::Box
, VirtualFixture::Plane
, VirtualFixture::Cylinder
, VirtualFixture::Grid
, VirtualFixture::NavSphere
, VirtualFixture::Cone
  • Stop() : Preloader
  • stop()
: vrecko::vThread
, vrecko::Scheduler
  • stopAnimation()
: APObjectUtils::Animator
, APCameraMovement::CameraPath
  • stopBeforeJuncOffset : CarSim::Edge
  • stopDirection : CarSim::CarControlUnit
  • stoped : CarSim::CarState
  • stopEdge : CarSim::StartStopDestination
  • stopOffset : CarSim::StartStopDestination
  • stopOrGoDecisionOffset : CarSim::Edge
  • stopped : navigation::KMTracker
  • stopRoad : CarSim::CarControlUnit
  • stopSimulation() : APDYNAMICART::Ctrl_StringSculptures
  • stopTiming() : vrecko::Logger
  • store_origin_flag : VirtualFixture::NavSphere
  • storeBuffer() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • storeByte() : MemoryWriteBuffer
  • StoreByte() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • storeByte() : MemoryReadBuffer , UserStream
  • storeDouble() : MemoryWriteBuffer , MemoryReadBuffer , UserStream
  • storeDword() : MemoryWriteBuffer , UserStream , MemoryReadBuffer
  • StoreDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • storeFloat() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • storeSample() : APDYNAMICART::ToolBrush
  • storeWord() : MemoryReadBuffer , UserStream , MemoryWriteBuffer
  • str : AP_LSystem::StaticString , vrecko::Logger::OutstandingText
  • StraightPipe() : AP_LSystem::StraightPipe
  • strategy : APDYNAMICART::InitSettings
  • strictPredecessor : AP_LSystem::Rule
  • stringCmd() : Hci
  • stringDamper : APDYNAMICART::SimulationParameters
  • stringSpring : APDYNAMICART::SimulationParameters
  • StringWithHash() : vrecko::EventDispatcher::StringWithHash
  • strName : vrecko::Logger::OutstandingCounter
  • strObjectIDReq : APObjectUtils::ObjectEffectMan
  • strOrientationEvent : APObjectUtils::ObjectInfo
  • strPositionEvent : APObjectUtils::ObjectInfo
  • StrX() : StrX
  • stylus3DOFbckg() : Arm
  • stylus3DOFmotion() : Arm
  • stylus3DOFupdate() : Arm
  • stylus6DOFbckg() : Arm
  • stylus6DOFmotion() : Arm
  • stylus6DOFupdate() : Arm
  • SubBlock() : ArtificialWorld::SubBlock
  • SubBlockAnimation() : ArtificialWorld::SubBlockAnimation
  • subBlockType : ArtificialWorld::SubBlock
  • subdivideMesh() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • subspace_size : vrecko::OctTree::OctTreeNode
  • substitute() : AP_LSystem::AbstractFile
  • sun : CloudsProperties
  • sunColor : SunLight
  • sunID : APLightsEditor::Editor
  • sunShow : CloudsProperties
  • suspend_button : vreckoDP_base::L3DMouse
  • Swap()
: VK_NoStepInto_Namespace::DynamicArray< _Type >
, BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
  • SweepSurfaceGeode() : SweepSurfaceGeode
  • switchColorsOnTL() : CarSim::TLsOnJuncManager
  • switchGeode() : AP_LSystem::AbstractInterpret
  • switchGUIVisibility()
: APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Controller
  • switchHighlighting() : vreckoUtils::HighlightCallback
  • switchLayout() : APGUI::GUI_Controller
  • switchLight() : CarSim::CarExecutionUnit
  • switchRenderingMethod() : APDYNAMICART::BrushStroke
  • switchToLayer() : APDYNAMICART::PolyhedraSculpture
  • switchTools()
: APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
  • switchVisuals()
: APGUI::Slider
, APGUI::Icon
  • syncEntityVector() : vrecko::vThread
  • SystemInfo() : base::SystemInfo
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • T_ID : vreckoDP_base::OptiTrack::info_struct
  • takeoff_time : boids::BoidsLogic
  • targetID : APConnectEditor::Optimalizer
  • targetName : APDYNAMICART::PoB
  • tauBasis() : gmMatrix4
  • TebBaseAddress : base::_THREAD_BASIC_INFORMATION
  • temp_entity_map : vrecko::vThread
  • tempTransformMatrix : vrecko::EnvironmentObject
  • tensedBSplineBasis() : gmMatrix4
  • tenv : vreckoDP_base::LHeadTracker
  • terminate()
: APRoomEdit::PointMove
, APRoomEdit::Tool
  • Terrain2D : APNature::Terrain2DSegment , APNature::Terrain2D
  • Terrain2DSegment() : APNature::Terrain2DSegment
  • TerrainAbility() : APNature::TerrainAbility
  • TerrainAlgorithm() : APNature::TerrainAlgorithm
  • test() : vreckoDP_base::Wiimote
  • Test : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • test_counter : BehindObstacleExp_wT , BehindObstacleExperiment
  • test_Queue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • test_Subdivision_Queue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • testAndHandleHit() : APShootingSimulation::ShootingSimulation
  • testNodeNorec() : APSpacePartitioning::SNCH_Object
  • testVersionIsAtLeast() : vrecko::PersistentCache
  • texCoordT : AP_LSystem::TurtleProperties
  • texRepeatingS : AP_LSystem::TurtleProperties
  • text
: APHUD::HUDField
, APTextOutput::Console::Line
, LoadingConsole::Line
  • text_geode : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_material : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_string : vrecko::World::SG_CHANGE
  • textLog() : vrecko::Logger
  • textShift : APMenu::MenuItemText
  • texture_font : BehindObstacleExp_wT , BehindObstacleExperiment
  • textureFile : APDYNAMICART::ParticleSystemParameters
  • th_read : vrecko::vThread
  • theLock : vrecko::MTAutoLock
  • ThinHeap() : ThinHeap< _NodeClass, _keyType >
  • thisBinormals : AP_CableEditor::Cable
  • thisEoWrapper : AP_CableEditor::Cable
  • thisNormals : AP_CableEditor::Cable
  • thisOwnerPtr : APFFDEditor::GeometryLoaderBase
  • thisTangents : AP_CableEditor::Cable
  • thread_ptr : vrecko::Scheduler::TimerStruct
  • threadPtr : vrecko::DeviceManager::DT
  • threadsInfo : base::SystemInfo
  • threadsInit : base::SystemInfo
  • tick()
: vrecko::Logger
, vrecko::Timer
  • ticks : vreckoDP_base::fsPinchGlove
  • time : vrecko::Logger::OutstandingCounter , Filter::PosNoiseRemover::SAMPLE
  • time_m() : vrecko::Timer
  • time_n() : vrecko::Timer
  • time_s() : vrecko::Timer
  • time_u() : vrecko::Timer
  • TIMED_OUT_handler : Hci
  • timeDivision : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • timedOut() : Timing
  • timeForLoop : ArtificialWorld::SubBlockAnimation
  • timeFromLastBlinkStart : CarSim::CarExecutionUnit
  • TimeLineSpline() : TimeLineSpline
  • timePerLoop : APObjectUtils::Animator
  • Timer() : vrecko::Timer
  • timer : vrecko::vThread , BehindObstacleExp_wT , BehindObstacleExperiment , behindO::CentreObjectManipulator , Hci , vreckoDP_base::KeyboardMouse
  • timer_board : BehindObstacleExp_wT , BehindObstacleExperiment
  • timer_map : vrecko::Scheduler
  • timer_updated : Hci
  • TimerMap : vrecko::Scheduler
  • timestamp : CacheInfo
  • timeWaiting : CarSim::CarControlUnit
  • TimingInfo() : vrecko::Logger::TimingInfo
  • title : APDYNAMICART::Parameter
  • tlColors : CarSim::JuncsEdge
  • tlColorsCenterDist : CarSim::RoadsState
  • tlGreenInterv : CarSim::Edge
  • tlIndex : CarSim::TLsOnJuncManager
  • TLsOnJuncManager() : CarSim::TLsOnJuncManager
  • tnode
: VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • to : CarSim::Edge
  • to_center
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::Manipulator
  • toNxQuat() : APDYNAMICART::PhysXManager
  • toNxVec3() : APDYNAMICART::PhysXManager
  • Tool() : APRoomEdit::Tool
  • ToolBrush() : APDYNAMICART::ToolBrush
  • ToolEraser() : APDYNAMICART::ToolEraser
  • ToolHook() : APDYNAMICART::ToolHook
  • ToolMagicWand() : APDYNAMICART::ToolMagicWand
  • ToolRotation() : APDYNAMICART::ToolRotation
  • ToolSelector() : APDYNAMICART::ToolSelector
  • ToolSlice() : APDYNAMICART::ToolSlice
  • ToolTongs() : APDYNAMICART::ToolTongs
  • toolType : APDYNAMICART::DATool
  • toOsgQuat() : APDYNAMICART::PhysXManager
  • toOsgVec3() : APDYNAMICART::PhysXManager
  • top() : AP_LSystem::TurtleStack
  • top_border : behindO::HeadManipulator
  • TOP_LEVEL : grass::GrassDrawable
  • topClipPlane : APDYNAMICART::PLControllerTool , APDYNAMICART::ToolSlice , SliceTool
  • toPointRight : CarSim::Edge
  • toRad() : AP_LSystem::AbstractTurtle
  • toString()
: AP_LSystem::LongString
, AP_LSystem::StaticString
  • totalNodes : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • totalPathLength : APCameraMovement::ControlPoint
  • totalTime : vrecko::Logger::TimingInfo
  • toXMLString()
: vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • tr_matrix : vreckoDP_base::LHeadTracker
  • tr_matrix2 : vreckoDP_base::LHeadTracker
  • Trace() : VirtualFixture::Trace
  • tracker : vreckoDP_base::OptiTrack
  • traits : APDYNAMICART::HoopGeometry
  • trans_vec : vrecko::EnvironmentObject
  • transcribe()
: AP_LSystem::D0LSystem
, AP_LSystem::LSystem
  • transcribeSubSystems() : AP_LSystem::LSystem
  • transf : base::ShowFDH , base::ShowFDHModel , Triangle
  • transform() : gmMatrix3 , gmMatrix4
  • transformHandPosition() : APGUI::Slider
  • transformMatrix : APFFDEditor::GeometryLoader::Geometry
  • transformToLocalCoord() : APDYNAMICART::PhysXManager
  • transformVectors() : AP_CableEditor::Cable
  • translate()
: gmMatrix4
, ode::CompositeObject
, ode::ODEObject
, AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
, gmMatrix3
  • translate_mapping : vreckoDP_base::LHeadTracker
  • translatedFileName : vrecko::PersistentCache::OpenedCacheFile
  • translateErrorTolerance : CloudsProperties
  • translateName() : vrecko::PersistentCache
  • translation : ArtificialWorld::AnimationPoint , APObjectUtils::Animator::AnimationPoint
  • translationSet : ArtificialWorld::AnimationPoint
  • transp : BehindObstacleExp_wT , BehindObstacleExperiment
  • transparency
: VirtualFixture::Trace
, VirtualFixture::ProxiCone
, VirtualFixture::NavSphere
, vrecko::EnvironmentObject
, behindO::ChangeOfVisibility
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
  • Transparency : APObjectUtils::ObjectEffect
  • transparency2
: VirtualFixture::Trace
, VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::Sphere
  • transparencyOfEditedObject : APFFDEditor::EditorLogic
  • TransparencyOnTop : APObjectUtils::ObjectEffect
  • transPointerPos : APMenu::DynamicMenu
  • transpose() : gmMatrix4 , gmMatrix3
  • transViewPos : APMenu::DynamicMenu
  • traverse() : SweepSurfaceGeode
  • tReadLine() : vrecko::BufferedFile
  • tree : DynTreeNode< _Type > , DynamicTreeIterator< _Type >
  • treeLOD : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeLODCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeMultiLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeMultiLevelCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeRoots : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • treeSimple : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSimpleCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSingleLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSingleLevelCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • Triangle() : grass::Triangle
  • triangle : Triangle
  • TriangleCollector : grass::Mesh
  • triangles : grass::Mesh
  • triangulate() : MotionTrailTriangulator
  • triDistance() : APSpacePartitioning::SNCH_Object
  • triIntersects() : APSpacePartitioning::SNCH_Object
  • tripleDerivedCRI() : MotionTrailTriangulator
  • triProjectionIntersection() : APSpacePartitioning::SNCH_Object
  • tropismAngle : AP_LSystem::TurtleProperties
  • tropismElasticity : AP_LSystem::TurtleProperties
  • tropismVector : AP_LSystem::TurtleProperties
  • Truncate() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • TryToSendThreadCreatedEvent() : base::SystemInfo
  • turnArround()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • turnLeft()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • turnOff()
: APDYNAMICART::ToolTongs
, MagicWandTool
, MTCreatorTool
, SliceTool
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolSlice
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::DATool
, APDYNAMICART::Controller
, APDYNAMICART::ToolEraser
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::PLControllerTool
, APDYNAMICART::ToolMagicWand
  • turnOffTool() : APDYNAMICART::Ctrl_MotionVisualization
  • turnOn()
: APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::ToolTongs
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::DATool
, SliceTool
, APDYNAMICART::ToolBrush
, MagicWandTool
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PolyhedraSculptures
, MTCreatorTool
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Controller
, APDYNAMICART::ToolSelector
, APDYNAMICART::PLNestTool
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolRotation
, APDYNAMICART::PLControllerTool
  • turnOnTool() : APDYNAMICART::Ctrl_MotionVisualization
  • turnRight()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • TurtleInterpret() : AP_LSystem::TurtleInterpret
  • TurtleProperties() : AP_LSystem::TurtleProperties
  • TurtleStack() : AP_LSystem::TurtleStack
  • two_handed : BehindObstacleExperiment , BehindObstacleExp_wT
  • TWO_TRIS : APSpacePartitioning::SNCH_Object
  • twoNeighbours : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • twoTotal : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • tx_buf : vreckoDP_base::LHeadTracker
  • type
: ode::DynamicScene::MessageODERequest
, ChessBoard::Request
, Icon
, AP_LSystem::Parameter
, vrecko::EventDispatcher::ICSBase
, CarSim::Edge
, AP_LSystem::AbstractFile
, PreloaderToLoadInfo
, vrecko::CAINFO__VER1
, APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, APRoomEdit::Tool
, APGUI::Interconnection
, vrecko::EventDispatcher::EventDefinitionStruct
, vrecko::EnvironmentObject::UserData
, APObjectUtils::ConnectionViz::Connection
, AP_LSystem::LSystemException
, vrecko::World::SG_CHANGE
  • Type : AP_LSystem::Parameter
  • TYPE_BOOL : vrecko::Attribute
  • TYPE_DOUBLE : vrecko::Attribute
  • TYPE_DYNAMIC : vrecko::Attribute
  • TYPE_FLOAT : vrecko::Attribute
  • TYPE_INT : vrecko::Attribute
  • TYPE_LONG : vrecko::Attribute
  • TYPE_MATRIX : vrecko::Attribute
  • TYPE_QUAT : vrecko::Attribute
  • TYPE_STRING : vrecko::Attribute
  • TYPE_VEC2 : vrecko::Attribute
  • TYPE_VEC3 : vrecko::Attribute
  • TYPE_VEC4 : vrecko::Attribute
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UD_BOOL : vrecko::EnvironmentObject
  • UD_DOUBLE : vrecko::EnvironmentObject
  • UD_FLOAT : vrecko::EnvironmentObject
  • UD_INT : vrecko::EnvironmentObject
  • UD_LONG_INT : vrecko::EnvironmentObject
  • UD_MATRIX : vrecko::EnvironmentObject
  • UD_POINTER : vrecko::EnvironmentObject
  • UD_QUAT : vrecko::EnvironmentObject
  • UD_STRING : vrecko::EnvironmentObject
  • UD_UNKNOWN : vrecko::EnvironmentObject
  • UD_USER : vrecko::EnvironmentObject
  • UD_VEC2 : vrecko::EnvironmentObject
  • UD_VEC3 : vrecko::EnvironmentObject
  • UD_VEC4 : vrecko::EnvironmentObject
  • Ultratrak() : vreckoDP_base::Ultratrak
  • uncommentLine() : AP_LSystem::StringUtils
  • UNICODECheck() : vrecko::BufferedFile
  • unicodeForm() : vrecko::XercesStr
  • UniformUpdateCallback() : UniformUpdateCallback
  • Union() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • UniqueProcess : base::_CLIENT_ID
  • UniqueThread : base::_CLIENT_ID
  • unit : ht::HeadTracking
  • UNKNOWN : vrecko::EventDispatcher , vrecko::World
  • Unknown : vrecko::CAINFO__VER1
  • unlock() : vrecko::MTLock
  • unlockEOMapForRead() : vrecko::Scene
  • unlockEOMapForWrite() : vrecko::Scene
  • unlockHigh() : vrecko::MTTwoPrioLimitedLock
  • unlockLow() : vrecko::MTTwoPrioLimitedLock
  • unlockRead()
: vrecko::MTReadWriteLock
, vrecko::MTReadWriteLockEx
  • unlockWrite()
: vrecko::MTReadWriteLock
, vrecko::MTReadWriteLockEx
  • unregCarForEdge() : CarSim::RoadsState
  • unregisterEnvironmentObject() : vrecko::Scene
  • unregisterGlobalGuiItem() : APGUI::GUI_Controller
  • unregisterOutputNotification() : vrecko::Logger
  • unregisterPointableGuiItem() : APGUI::GUI_Controller
  • unregLastCarForEdge() : CarSim::RoadsState
  • unselectItem() : APMenu::DynamicMenu
  • unsetBounding() : APDYNAMICART::PerlinLines
  • unsetController() : APDYNAMICART::PerlinLines
  • unsetMagnet() : APDYNAMICART::PerlinLines
  • up_vector
: vrecko::World::AvatarView
, behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
, behindO::MyCullCallback
, boids::Boid
  • UpdatablePhysXObject() : PhysXPlugin::UpdatablePhysXObject
  • Update() : PhysXPlugin::ClothDrawable
  • update()
: APDYNAMICART::HookObject
, APDYNAMICART::HoopTrackerCallback
  • Update() : PhysXPlugin::FluidDrawable
  • update()
: APDYNAMICART::Hoop
, APDYNAMICART::JuliaAttractor
, base::Avatar
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PerlinLines
, base::Display
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, base::hand
, APDYNAMICART::PLControllerTool
, APDYNAMICART::PoA
, base::Light
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::ToolBrush
, base::MouseHand
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, base::MTMatrixTransform
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, base::Rotate
, APDYNAMICART::ToolTongs
, APDYNAMICART::PoAAdapter< T >
, VirtualFixture::VibrationLabelActivator
, base::ShowFDH
, vrecko::ControllableAbility
, VirtualFixture::Trace
, VirtualFixture::Sphere
, VirtualFixture::ProxiSphere
, APEditorController::EditorController
, VirtualFixture::ProxiCone
, base::ShowFDHModel
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, PHEffect
, PHANToMAvatar
, VirtualFixture::NavSphere
, base::SystemInfo
, VirtualFixture::Marker
, VirtualFixture::Log
, APEditorQAbilities::SimpleObjectMovement
, APFFDEditor::EditorLogic
, VirtualFixture::Drag
, VirtualFixture::Damper
, VirtualFixture::Cylinder
, vrecko::BaseClass
, VirtualFixture::Box
, VirtualFixture::Border
, ChessBoard
, ChessPiece
, PhysXPlugin::PhysXScene
, APDYNAMICART::PoB
, MTCreatorTool
, vrecko::Device
, LoadingConsole
, vreckoDP_Kinect::Kinect
, APGUI::ColorPicker
, APGUI::GUI_Controller
, vreckoDP_base::Ultratrak
, vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
, vrecko::EventDispatcher
, APGUI::Slider
, ht::HeadTracking
, vrecko::Logger
, APHelloWorld::MyAbility
, vreckoDP_base::fdtDataGlove
, APTextOutput::Console
, APSpacePartitioning::VoxelGrid_Object_Data
, APHUD::HUDDisplay
, APSpacePartitioning::NoPartitioning_Scene
, APShootingSimulation::ShootingSimulation
, vrecko::PyAbility
, APInputConnector::InputConnector
, APRoomEdit::RoomEditor
, APRoomEdit::PointMove
, ode::Sphere
, APLightsEditor::Editor
, ode::Cube
, ode::CompositeObject
, vrecko::Scene
, APMenu::DynamicMenu
, APObjectUtils::ObjectModif
, APObjectUtils::ObjectInfo
, APObjectUtils::ObjectEffectMan
, APClouds::Clouds
, APObjectUtils::KeepOnScreen
, APObjectUtils::CopyProperties
, vrecko::Scheduler
, grass::Grass
, APNature::TerrainAbility
, ArtificialWorld::BlockUpdater
, navigation::AvatarInHand
, navigation::KMTracker
, Cache
, APObjectUtils::Animator
, APObjectUtils::ConnectionViz
, ArtificialWorld::WorldBuilder
, behindO::AvatarManipulator
, APObjectUtils::ObjectEffect
, BehindObstacleExp_wT
, BehindObstacleExperiment
, APObjectUtils::ObjectSelector
, ode::CappedCylinder
, behindO::CentreObjectManipulator
, behindO::ChangeOfVisibility
, ode::DynamicScene
, behindO::ContactObjectManipulator
, behindO::CuttingPlane
, APRoomEdit::Tool
, APRoomEdit::WallMovement
, behindO::EyeManipulator
, behindO::HeadManipulator
, APSpacePartitioning::SP_Object_Data_Base
, behindO::HMDHeadManipulator
, behindO::Lens
, vreckoDP_base::fsPinchGlove
, vreckoDP_base::KeyboardMouse
, behindO::Manipulator
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, behindO::MappingFunctions
, vreckoDP_base::MicroScribe3D
, behindO::Mirror
, behindO::WIM
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, boids::Boid
, boids::BoidsLogic
, Icon
, APDYNAMICART::DAEnvironment
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Ctrl_PolyhedraSculptures
, boids::BoidsPlanner
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_FreeHandPainting
, AP_CableEditor::Cable
, VirtualFixture::Avatar
, APDYNAMICART::BrushStroke
, APDYNAMICART::Attractor
, APConstrainedMovement::ConstrainedObjectMovement
, VirtualFixture::VibrationLabel
, APConnectEditor::Rotation
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiBox
, VirtualFixture::AxisLock
, CarSim::Remover
, VirtualFixture::MarkerFactory
, CarSim::CarControlUnit
, VirtualFixture::Grid
, AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, VirtualFixture::Cone
, APCameraMovement::CameraPath
, APCameraPath::Camera
, VirtualFixture::Filter
, CarSim::CarExecutionUnit
, CarSim::RoadsState
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, CarSim::TLsOnJuncManager
, APConnectEditor::Cut
, APConnectEditor::Scale
, VirtualFixture::Vibration
  • Update() : Preloader , PreloaderHeuristic
  • update()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
  • Update() : BasicPreloaderHeuristic , CloudsManager
  • update() : APDYNAMICART::Ctrl_PerlinLines
  • Update() : AllCloudsUpdateCallBack
  • updateActor() : APDYNAMICART::Hoop
  • updateActTime()
: APCameraMovement::CameraPath
, APObjectUtils::Animator
  • updateAllFields() : APHUD::HUDDisplay
  • updateAllFieldsPosition() : APHUD::HUDDisplay
  • updateAllWindows() : APHUD::HUDDisplay
  • updateAllWindowsPositions() : APHUD::HUDDisplay
  • updateAnimation()
: APObjectUtils::Animator
, APCameraMovement::CameraPath
  • updateBoundingBox() : APSpacePartitioning::NoPartitioning_Scene
  • updateCarForEdge() : CarSim::RoadsState
  • UpdateCloud() : Cloud
  • UpdateCloudColor() : Cloud
  • UpdateCloudLotRocScale() : Cloud
  • updateColorArray() : SweepSurfaceGeode
  • updateColors() : APDYNAMICART::PS_Face
  • updateControllerPosition() : APDYNAMICART::PerlinLines
  • updateControlPoints() : AP_CableEditor::Cable
  • updateControlSpheresRadius() : AP_CableEditor::Cable
  • updated : vrecko::Ability
  • updateDataInformation() : APSpacePartitioning::VoxelGrid_Object_Data
  • updateDisplayList() : SnapObject
  • UpdateEnvironmentObject()
: PhysXPlugin::BaseActor
, PhysXPlugin::UpdatablePhysXObject
, PhysXPlugin::Fluid
, PhysXPlugin::Cloth
  • updateField() : APHUD::HUDDisplay
  • updateFields() : APHUD::HUDDisplay
  • updateFieldsPosition() : APHUD::HUDDisplay
  • updateFieldTextColor() : APHUD::HUDDisplay
  • updateGeometry() : APDYNAMICART::PatternsGeode , SweepSurfaceGeode
  • updateGradient() : APHUD::HUDDisplay
  • updateGrid() : APFFDEditor::Grid
  • updateInverseCalc() : APMenu::DynamicMenu
  • updateLocationInDynamic() : ode::DynamicScene
  • updateLocationInNonDynamic() : ode::DynamicScene
  • updateMagnetPosition() : APDYNAMICART::PerlinLines
  • updateMainObjectTransformation() : APMenu::DynamicMenu
  • updateMMap : vrecko::Scheduler
  • UpdateMove() : APCameraPath::Camera
  • updateNodeMask() : vrecko::EnvironmentObject
  • updateNormalArray() : SweepSurfaceGeode
  • updateObjectGeometry() : APFFDEditor::EditorLogic
  • UpdatePath() : APCameraPath::Camera
  • updatePoAs() : APDYNAMICART::Ctrl_StringSculptures
  • updatePointerPosition() : APMenu::DynamicMenu
  • updatePosRot() : base::Avatar
  • updatePrimitiveSet() : SweepSurfaceGeode
  • updateSamplePoints()
: APDYNAMICART::Ellipse
, APDYNAMICART::Line
, APDYNAMICART::Rectangle
, APDYNAMICART::ElongatedCircle
  • updateScene() : APDYNAMICART::Ctrl_StringSculptures
  • updateShape() : APEditorQAbilities::ObjectMovement::SnapBox
  • updateSlider() : APGUI::Slider
  • updateSliderGraphicPos() : APMenu::MenuItemSlider
  • updateSpheresPosition() : AP_CableEditor::Cable
  • updateText()
: APHUD::HUDDisplay
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • updateTool() : APRoomEdit::WallGeometry
  • updateValue() : APHUD::HUDDisplay
  • updateValuesRange() : APHUD::HUDDisplay
  • updateVertexArray() : SweepSurfaceGeode
  • updateWindow() : APHUD::HUDDisplay
  • updateWindowColor() : APHUD::HUDDisplay
  • updateWindowSizeX() : APHUD::HUDDisplay
  • UpperCase() : APNature::TerrainUtility
  • upX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • upY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • upZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • USE_QUERIES : AP_LSystem::TurtleProperties
  • user_data : vrecko::EnvironmentObject
  • user_name : BehindObstacleExp_wT , BehindObstacleExperiment
  • UserData_Type : vrecko::EnvironmentObject
  • userParam : vrecko::Logger::OutputNotificationFuncStored
  • UserStream() : UserStream
  • UseToEvent() : APObjectUtils::UseToEvent
  • UseTrigger() : APEditorQAbilities::UseTrigger
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • v : CarSim::CarState , APSpacePartitioning::SNCH_Object::OneTri
  • v1 : Triangle3v , Triangle3
  • v1ID : APSpacePartitioning::PointShell_Object_Data_Geometry::E , APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v2 : Triangle3v , Triangle3
  • v2ID : APSpacePartitioning::PointShell_Object_Data_Geometry::E , APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v3 : Triangle3 , Triangle3v
  • v3ID : APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v_ : gmVector4 , gmVector2 , gmVector3
  • valid
: APSpacePartitioning::VLOD
, APSpacePartitioning::ELOD
, osgQ::QSection
  • value
: APDYNAMICART::Parameter
, AP_LSystem::Parameter
, APMenu::DynamicMenuSign
  • valueChanged() : APDYNAMICART::Attractor
  • valuesCount() : vrecko::Enumeration< tval, tref >
  • VariableFloat() : ht::VariableFloat
  • VariableQuat() : ht::VariableQuat
  • variables : AP_LSystem::Rule
  • VariableVec2() : ht::VariableVec2
  • VariableVec3() : ht::VariableVec3
  • vdebugFileLog() : vrecko::Logger
  • vdebugFlush() : vrecko::Logger
  • vdebugLog() : vrecko::Logger
  • vec : Filter::PosNoiseRemover::SAMPLE
  • Vec3Ptr : APDYNAMICART::PerlinLines
  • vector
: APEditorController::AbilityMapper::MAPPING
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Grid
, VirtualFixture::Plane
, VirtualFixture::ProxiCylinder
  • vectorCounterPathWise : APCameraMovement::ControlPoint
  • vectorPathWise : APCameraMovement::ControlPoint
  • Vectors : mv::CGesture
  • vecTriMaxNegativeDistance : vrecko::CollisionPointInfo
  • vecTriMaxNegDist : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • vel : CarSim::EdgesCar
  • velocity : PhysXPlugin::Particle
  • velocity_factor : boids::BoidsLogic
  • verrorLog() : vrecko::Logger
  • version : behindO::CentreObjectManipulator , Hci
  • vert
: base::ShowFDH
, base::ShowFDHModel
, navigation::KMTracker
  • vertAlign : APObjectUtils::KeepOnScreen
  • vertex : Triangle
  • Vertex() : grass::Vertex
  • vertex_count : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • vertex_size : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • vertexImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • VertexNormals : APObjectUtils::ObjectEffect
  • vertices
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, LoadingConsole
  • vibration : vreckoDP_base::Wiimote
  • Vibration() : VirtualFixture::Vibration
  • vibration_flag : VirtualFixture::NavSphere
  • VibrationLabel() : VirtualFixture::VibrationLabel
  • VibrationLabelActivator() : VirtualFixture::VibrationLabelActivator
  • View_ptr : APCameraPath::ControlPoint
  • ViewCtrlPts : APCameraPath::Camera
  • Viewer() : vrecko::Viewer
  • viewer : vrecko::World , APHUD::HUDDisplay , LoadingConsole
  • viewHeight : APHUD::HUDDisplay , LoadingConsole , APTextOutput::Console
  • viewMenu() : APCameraMovement::CameraMovementEditor
  • viewMoved() : APMenu::DynamicMenu
  • viewWidth : APTextOutput::Console , LoadingConsole , APHUD::HUDDisplay
  • vIndex : APFFDEditor::GeometryLoaderBase::FaceBase , APSpacePartitioning::GeometryLoaderBase::FaceBase
  • visibilityRange : grass::GrassAbilityParameters
  • visible
: VirtualFixture::ProxiSphere
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiBorder
, VirtualFixture::Cone
, VirtualFixture::Plane
, APSpacePartitioning::ELOD
, APSpacePartitioning::VLOD
, VirtualFixture::Box
, APHUD::HUDWindow
, APSpacePartitioning::PLOD
, VirtualFixture::Border
, VirtualFixture::Cylinder
, VirtualFixture::ProxiBox
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::NavSphere
  • visibleMenuRoot : APMenu::DynamicMenu
  • visited : APFFDEditor::Grid::ControlPoint
  • visual_border_object : behindO::WIM
  • visualizeControlPoints() : APDYNAMICART::BrushStroke
  • visualizeVectors() : AP_CableEditor::Cable
  • vnoticeLog() : vrecko::Logger
  • voidFuncPtr : vrecko::vThread
  • VoxelGrid : APObjectUtils::ObjectEffect
  • VoxelGrid_Object_Data() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::getCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::increaseVoxelValueCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::setVoxelValueCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGridCollisions : APObjectUtils::ObjectEffect
  • voxels : APSpacePartitioning::PointShell_Object_Data
  • voxelSize : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • voxResolution : APSpacePartitioning::PointShell_Object_Data
  • vPrevious : CarSim::CarExecutionUnit
  • VreckoMessage() : vrecko::VreckoMessage
  • VRPN3DMouse() : vreckoDP_base::VRPN3DMouse
  • VRPN3DMouse::sendAnalogEvent() : vreckoDP_base::VRPN3DMouse
  • VRPN3DMouse::sendButtonEvent() : vreckoDP_base::VRPN3DMouse
  • vrpnServerHandle : vreckoDP_base::VRPN3DMouse
  • vstart_tick : VirtualFixture::Vibration
  • vtextLog() : vrecko::Logger
  • vThread() : vrecko::vThread
  • vwarningLog() : vrecko::Logger
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • wait : ChessBoard
  • waitPacket() : Hci
  • WallAdd() : APRoomEdit::WallAdd
  • WallGeometry() : APRoomEdit::WallGeometry
  • WallMovement() : APRoomEdit::WallMovement
  • WallRemove() : APRoomEdit::WallRemove
  • warningLog()
: vrecko::World
, vrecko::Logger
  • WavefrontObj() : WavefrontObj
  • WaveSplineAdapter() : APDYNAMICART::WaveSplineAdapter
  • waypoint : boids::BoidsLogic
  • waypoint_speed : boids::BoidsLogic
  • waypoints : boids::BoidsPlanner
  • WBishop : ChessBoard
  • wdsInfoRec() : APSpacePartitioning::SNCH_Object_Data
  • Weather() : APWeather::Weather
  • WG_Geometry() : WGeometry::WG_Geometry
  • WG_Hole() : WGeometry::WG_Hole
  • WG_Point() : WGeometry::WG_Point
  • WG_Vertices() : WGeometry::WG_Vertices
  • WG_Wall() : WGeometry::WG_Wall
  • what() : AP_LSystem::LSystemException
  • WhatIsSet() : ArtificialWorld::BlockAttributes
  • wheelAngle : CarSim::CarState
  • wheelAngleOnJunc : CarSim::CarEnvirons
  • wheelDisplayAngleAroundNormal : CarSim::CarExecutionUnit
  • wheelR : CarSim::CarExecutionUnit
  • wheelRotateAngle : CarSim::CarExecutionUnit
  • wheelsInitMatrixVec : CarSim::CarExecutionUnit
  • white_out_pos : ChessBoard
  • width : CarSim::CarSize
  • Width() : APNature::Terrain2DSegment
  • widthFPR : CarSim::Edge
  • widthTPR : CarSim::Edge
  • Wiimote() : vreckoDP_base::Wiimote
  • wiimoteID : vreckoDP_base::Wiimote
  • WIM() : behindO::WIM
  • WIM_center : behindO::WIM
  • WIM_commit : behindO::WIM
  • WIM_scale : behindO::WIM
  • WIM_size : behindO::WIM
  • windowDefaultColorA : APHUD::HUDDisplay
  • windowDefaultColorB : APHUD::HUDDisplay
  • windowDefaultColorG : APHUD::HUDDisplay
  • windowDefaultColorR : APHUD::HUDDisplay
  • windowTabHorizontal : APHUD::HUDDisplay
  • windowTabVertical : APHUD::HUDDisplay
  • wire_length
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • wire_object_map : behindO::ChangeOfVisibility , behindO::CuttingPlane
  • wire_orientation
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • wire_position
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • wireframe : behindO::ChangeOfVisibility
  • WKing : ChessBoard
  • WKnight : ChessBoard
  • wordLength() : AP_LSystem::LSystem
  • wOriginalConsoleAttributes : vrecko::Logger
  • work_area_selection : behindO::WIM
  • World
: vrecko::EnvironmentObject
, vrecko::Logger
, vrecko::World
  • WORLD : vrecko::EventDispatcher
  • WorldBuilder() : ArtificialWorld::WorldBuilder
  • WPawn : ChessBoard
  • WQueen : ChessBoard
  • wrap() : AP_CableEditor::Cable
  • wrapCable() : AP_CableEditor::Cable
  • wrapperGeode : AP_CableEditor::Cable
  • write() : vrecko::BufferedFileWrite , ConstraintHierarchyMember , AP_LSystem::Log
  • writeAll() : AP_LSystem::Configuration
  • writeBMCounter() : vrecko::Logger
  • writeBMCounterLowLevel() : vrecko::Logger
  • writeBool() : vrecko::BufferedFileWrite
  • writeByte() : vrecko::BufferedFileWrite
  • writeChar() : Serial
  • writeCounter() : vrecko::BenchmarkWriter
  • writeDataEnd() : vrecko::BenchmarkWriter
  • writeDataStart() : vrecko::BenchmarkWriter
  • writeDebugStatistics() : APSpacePartitioning::SNCH_Object_Data
  • writeDWORD() : vrecko::BufferedFileWrite
  • writeEdge()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • writeFloat() : vrecko::BufferedFileWrite
  • writeFormattedString() : vrecko::BufferedFileWrite
  • writeFrameEnd() : vrecko::BenchmarkWriter
  • writeFramesRendered() : vrecko::BenchmarkWriter
  • writeFrameStart() : vrecko::BenchmarkWriter
  • writeInfo()
: APConstrainedMovement::ConstraintDescription
, AP_CableEditor::CableEditor
, APConstrainedMovement::ConstraintArea
  • writeInfoEnd() : vrecko::BenchmarkWriter
  • writeInfoLine() : vrecko::BenchmarkWriter
  • writeInfoStart() : vrecko::BenchmarkWriter
  • writeInt() : vrecko::BufferedFileWrite
  • writeInt64() : vrecko::BufferedFileWrite
  • writeLONG() : vrecko::BufferedFileWrite
  • writeMiscStatsEnd() : vrecko::BenchmarkWriter
  • writeMiscStatsStart() : vrecko::BenchmarkWriter
  • writeObjectFullMatrix() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectPosition() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectRotation() : APConstrainedMovement::ConstrainedObjectMovement
  • writeParam() : vrecko::BenchmarkWriter
  • writePOINT() : vrecko::BufferedFileWrite
  • writePolygon()
: APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • writeRECT() : vrecko::BufferedFileWrite
  • writeRunTime() : vrecko::BenchmarkWriter
  • writeSettingsEnd() : vrecko::BenchmarkWriter
  • writeSettingsStart() : vrecko::BenchmarkWriter
  • writeStr() : vrecko::BufferedFileWrite
  • writeString() : Serial
  • writeVec3f() : vrecko::BufferedFileWrite
  • writeVertex()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • writeWORD() : vrecko::BufferedFileWrite
  • writingAllowed() : vrecko::BenchmarkWriter
  • WRook : ChessBoard
  • WTime : mv::CGesture , mv::CPoint
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • x : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , angle_3D , Point3f , length_3D
  • x_hat1 : VirtualFixture::Filter
  • x_hat2 : VirtualFixture::Filter
  • x_hat_prev1 : VirtualFixture::Filter
  • x_hat_prev2 : VirtualFixture::Filter
  • x_sensitivity : behindO::HeadManipulator
  • x_sensitivity_delta : behindO::HeadManipulator
  • XercesStr() : vrecko::XercesStr
  • XmlFile() : AP_LSystem::XmlFile
  • XY : RegularPolygonSpline
  • XZ : RegularPolygonSpline
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- y -

  • y : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , angle_3D , Point3f , length_3D
  • y_sensitivity : behindO::HeadManipulator
  • YZ : RegularPolygonSpline
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • z : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , angle_3D , Point3f , length_3D
  • z_position : base::MouseHand
  • z_step : base::MouseHand
  • Zero() : APNature::TerrainAlgorithm
  • zeroLevelSize : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • zeroRotation() : osgQ::QSection
  • zooming : behindO::WIM
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~A3DBird() : vreckoDP_base::A3DBird
  • ~Ability() : vrecko::Ability
  • ~AbilityDispatcher() : vrecko::AbilityDispatcher
  • ~AbilityEditor() : APEditorQAbilities::AbilityEditor
  • ~AbilityMapper() : APEditorController::AbilityMapper
  • ~AbstractGenerator() : AP_LSystem::AbstractGenerator
  • ~Animator() : APObjectUtils::Animator
  • ~AnimatorEditor() : APEditorQAbilities::AnimatorEditor
  • ~AttributesDescription() : vrecko::AttributesDescription
  • ~Avatar()
: base::Avatar
, VirtualFixture::Avatar
  • ~AvatarInHand() : navigation::AvatarInHand
  • ~AvatarManipulator() : behindO::AvatarManipulator
  • ~AvatarMovement() : APEditorQAbilities::AvatarMovement
  • ~AxisLock() : VirtualFixture::AxisLock
  • ~BaseActor() : PhysXPlugin::BaseActor
  • ~BaseClass() : vrecko::BaseClass
  • ~BaseJoint() : PhysXPlugin::BaseJoint
  • ~BCLoaderErrorHandler() : BCLoaderErrorHandler
  • ~BehindObstacleExp_wT() : BehindObstacleExp_wT
  • ~BehindObstacleExperiment() : BehindObstacleExperiment
  • ~BenchmarkWriter() : vrecko::BenchmarkWriter
  • ~BinomialHeap() : BinomialHeap< _NodeClass, _keyType >
  • ~BlockUpdater() : ArtificialWorld::BlockUpdater
  • ~Boid() : boids::Boid
  • ~BoidsLogic() : boids::BoidsLogic
  • ~BoidsPlanner() : boids::BoidsPlanner
  • ~Border() : VirtualFixture::Border
  • ~Box()
: PhysXPlugin::Box
, VirtualFixture::Box
  • ~Brush() : APDYNAMICART::Brush
  • ~BrushStroke() : APDYNAMICART::BrushStroke
  • ~BrushStrokeControlPoint() : APDYNAMICART::BrushStrokeControlPoint
  • ~BufferedFile() : vrecko::BufferedFile
  • ~BufferedFileWrite() : vrecko::BufferedFileWrite
  • ~Cable() : AP_CableEditor::Cable
  • ~CableEditor() : AP_CableEditor::CableEditor
  • ~Cache() : Cache
  • ~CacheInfo() : CacheInfo
  • ~Camera() : APCameraPath::Camera
  • ~CameraMovementEditor() : APCameraMovement::CameraMovementEditor
  • ~CameraPath() : APCameraMovement::CameraPath
  • ~CappedCylinder() : ode::CappedCylinder
  • ~Capsule() : PhysXPlugin::Capsule
  • ~CarControlUnit() : CarSim::CarControlUnit
  • ~CarExecutionUnit() : CarSim::CarExecutionUnit
  • ~CarPartsNodeCache() : CarSim::CarPartsNodeCache
  • ~CCollection() : mv::CCollection
  • ~CentreObjectManipulator() : behindO::CentreObjectManipulator
  • ~CGesture() : mv::CGesture
  • ~ChangeOfVisibility() : behindO::ChangeOfVisibility
  • ~ChessBoard() : ChessBoard
  • ~ChessPiece() : ChessPiece
  • ~Cloth() : PhysXPlugin::Cloth
  • ~ClothDrawable() : PhysXPlugin::ClothDrawable
  • ~Clouds() : APClouds::Clouds
  • ~CloudsManager() : CloudsManager
  • ~CMVect() : mv::CMVect
  • ~CollisionInfo() : vrecko::CollisionInfo
  • ~ColorBucket() : APRoomEdit::ColorBucket
  • ~ColorPicker() : APGUI::ColorPicker
  • ~CompositeObject() : ode::CompositeObject
  • ~Cone() : VirtualFixture::Cone
  • ~ConnectEditor() : APConnectEditor::ConnectEditor
  • ~ConnectionViz() : APObjectUtils::ConnectionViz
  • ~Console() : APTextOutput::Console
  • ~ConstrainedObjectMovement() : APConstrainedMovement::ConstrainedObjectMovement
  • ~ConstraintArea() : APConstrainedMovement::ConstraintArea
  • ~ConstraintDescription() : APConstrainedMovement::ConstraintDescription
  • ~ConstraintHierarchyMember() : ConstraintHierarchyMember
  • ~ContactObjectManipulator() : behindO::ContactObjectManipulator
  • ~ControllableAbility() : vrecko::ControllableAbility
  • ~Controller() : APDYNAMICART::Controller
  • ~CPlayer() : mv::CPlayer
  • ~CreateHole() : APRoomEdit::CreateHole
  • ~Ctrl_FreeHandPainting() : APDYNAMICART::Ctrl_FreeHandPainting
  • ~Ctrl_MotionVisualization() : APDYNAMICART::Ctrl_MotionVisualization
  • ~Ctrl_PolyhedraSculptures() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • ~Ctrl_StringSculptures() : APDYNAMICART::Ctrl_StringSculptures
  • ~Cube() : ode::Cube
  • ~CubicInterpolator() : CubicInterpolator
  • ~Cut() : APConnectEditor::Cut
  • ~CuttingPlane() : behindO::CuttingPlane
  • ~Cylinder() : VirtualFixture::Cylinder
  • ~DAControlPoint() : DAControlPoint
  • ~DAEnvironment() : APDYNAMICART::DAEnvironment
  • ~DAGizmo() : APDYNAMICART::DAGizmo , DAGizmo
  • ~Damper() : VirtualFixture::Damper
  • ~DATool() : APDYNAMICART::DATool
  • ~Device() : vrecko::Device
  • ~DeviceManager() : vrecko::DeviceManager
  • ~Display() : base::Display
  • ~Drag() : VirtualFixture::Drag
  • ~DynamicArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • ~DynamicAttribute() : vrecko::DynamicAttribute
  • ~DynamicMenu() : APMenu::DynamicMenu
  • ~DynamicScene() : ode::DynamicScene
  • ~DynamicTree() : DynamicTree< _Type >
  • ~ECPOINTERBUTTONINFO() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • ~ECPOINTERINFO() : APEditorController::EditorController::ECPOINTERINFO
  • ~Editor() : APLightsEditor::Editor
  • ~EditorController() : APEditorController::EditorController
  • ~EditorLogic() : APFFDEditor::EditorLogic
  • ~EnvironmentObject() : vrecko::EnvironmentObject
  • ~EOIteratorHelper() : vrecko::Scene::EOIteratorHelper
  • ~EventDispatcher() : vrecko::EventDispatcher
  • ~EyeManipulator() : behindO::EyeManipulator
  • ~fdtDataGlove() : vreckoDP_base::fdtDataGlove
  • ~FibonacciHeap() : FibonacciHeap< _NodeClass, _keyType >
  • ~Filter() : VirtualFixture::Filter
  • ~filter1() : filter1
  • ~filter2() : filter2
  • ~Fluid() : PhysXPlugin::Fluid
  • ~FluidDrawable() : PhysXPlugin::FluidDrawable
  • ~ForceField() : PhysXPlugin::ForceField
  • ~FrenetFrame() : FrenetFrame
  • ~fsPinchGlove() : vreckoDP_base::fsPinchGlove
  • ~GeometryLoader() : APFFDEditor::GeometryLoader
  • ~GeometryLoaderBase()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • ~Grass() : grass::Grass
  • ~GrassAbilityParameters() : grass::GrassAbilityParameters
  • ~GrassDrawable() : grass::GrassDrawable
  • ~Grid()
: APFFDEditor::Grid
, VirtualFixture::Grid
  • ~GUI_Controller() : APGUI::GUI_Controller
  • ~GUI_Item() : APGUI::GUI_Item
  • ~GUI_Text() : APGUI::GUI_Text
  • ~hand() : base::hand
  • ~HeadManipulator() : behindO::HeadManipulator
  • ~HeadTracking() : ht::HeadTracking
  • ~HermitPipe() : AP_LSystem::HermitPipe
  • ~HMDHeadManipulator() : behindO::HMDHeadManipulator
  • ~HoleRemove() : APRoomEdit::HoleRemove
  • ~HoopShape() : APDYNAMICART::HoopShape
  • ~HUDDisplay() : APHUD::HUDDisplay
  • ~IComputeStrategy() : APDYNAMICART::IComputeStrategy
  • ~Icon() : APGUI::Icon , Icon
  • ~IconColour() : APGUI::IconColour
  • ~IMenuComponent() : vreckoUtils::IMenuComponent
  • ~InPlaceParser() : WAVEFRONT::InPlaceParser
  • ~InputConnector() : APInputConnector::InputConnector
  • ~InputPin() : vrecko::InputPin< _MessageType >
  • ~Interpolator() : Interpolator
  • ~IParameters() : APDYNAMICART::IParameters
  • ~IShapeGenerator() : APDYNAMICART::IShapeGenerator
  • ~ItemsGroup() : APGUI::ItemsGroup
  • ~JointedPipe() : AP_LSystem::JointedPipe
  • ~KeepOnScreen() : APObjectUtils::KeepOnScreen
  • ~KeyboardMouse() : vreckoDP_base::KeyboardMouse
  • ~KMTracker() : navigation::KMTracker
  • ~L3DMouse() : vreckoDP_base::L3DMouse
  • ~Layout() : APGUI::Layout
  • ~Lens() : behindO::Lens
  • ~LHeadTracker() : vreckoDP_base::LHeadTracker
  • ~Light() : base::Light
  • ~Lights() : APLightsEditor::Lights
  • ~Linear() : Filter::Linear
  • ~LoadingConsole() : LoadingConsole
  • ~LoftTurtle() : AP_LSystem::LoftTurtle
  • ~Log() : VirtualFixture::Log
  • ~Logger() : vrecko::Logger
  • ~LongString() : AP_LSystem::LongString
  • ~LSObject() : AP_LSystem::LSObject
  • ~LSystem() : AP_LSystem::LSystem
  • ~LSystemException() : AP_LSystem::LSystemException
  • ~LSystemGenerator() : AP_LSystem::LSystemGenerator
  • ~MagicWandTool() : MagicWandTool
  • ~MainObject() : MainObject
  • ~Manipulator() : behindO::Manipulator
  • ~MappingFunctions() : behindO::MappingFunctions
  • ~Marker() : VirtualFixture::Marker
  • ~MarkerFactory() : VirtualFixture::MarkerFactory
  • ~MemoryReadBuffer() : MemoryReadBuffer
  • ~MemoryWriteBuffer() : MemoryWriteBuffer
  • ~Menu() : APGUI::Menu
  • ~MenuItem() : APMenu::MenuItem
  • ~MenuItemSlider() : APMenu::MenuItemSlider
  • ~MenuItemText() : APMenu::MenuItemText
  • ~MenuLoaderErrorHandler() : APMenu::MenuLoaderErrorHandler
  • ~MenuVisitor() : vreckoUtils::MenuVisitor
  • ~Mesh() : grass::Mesh
  • ~MicroScribe3D() : vreckoDP_base::MicroScribe3D
  • ~Mirror() : behindO::Mirror
  • ~Mode() : APDYNAMICART::Mode
  • ~Model() : ArtificialWorld::Model
  • ~MotionTrail() : APDYNAMICART::MotionTrail
  • ~MotionTrailTriangulator() : MotionTrailTriangulator
  • ~MouseHand() : base::MouseHand
  • ~MTAutoLock() : vrecko::MTAutoLock
  • ~MTBrush() : MTBrush
  • ~MTCreatorTool() : MTCreatorTool
  • ~MTLock() : vrecko::MTLock
  • ~MTMatrixTransform() : base::MTMatrixTransform
  • ~MTReadWriteLock() : vrecko::MTReadWriteLock
  • ~MTReadWriteLockEx() : vrecko::MTReadWriteLockEx
  • ~MTTwoPrioLimitedLock() : vrecko::MTTwoPrioLimitedLock
  • ~MyAbility() : APHelloWorld::MyAbility
  • ~NavSphere() : VirtualFixture::NavSphere
  • ~NestOfBirds() : vreckoDP_base::NestOfBirds
  • ~NoPartitioning_Scene() : APSpacePartitioning::NoPartitioning_Scene
  • ~ObjectAdd() : APEditorQAbilities::ObjectAdd
  • ~ObjectDelete() : APEditorQAbilities::ObjectDelete
  • ~ObjectEffect() : APObjectUtils::ObjectEffect
  • ~ObjectEffectMan() : APObjectUtils::ObjectEffectMan
  • ~ObjectInfo() : APObjectUtils::ObjectInfo
  • ~ObjectModif() : APObjectUtils::ObjectModif
  • ~ObjectMovement() : APEditorQAbilities::ObjectMovement
  • ~ObjectSelector() : APObjectUtils::ObjectSelector
  • ~OctTree() : vrecko::OctTree
  • ~OpenedCacheFile() : vrecko::PersistentCache::OpenedCacheFile
  • ~Optimalizer() : APConnectEditor::Optimalizer
  • ~OptiTrack() : vreckoDP_base::OptiTrack
  • ~OutputPin() : vrecko::OutputPin< _MessageType >
  • ~PatternBase() : APDYNAMICART::PatternBase
  • ~PerlinLines() : APDYNAMICART::PerlinLines
  • ~PersistentCache() : vrecko::PersistentCache
  • ~PHANToMAvatar() : PHANToMAvatar
  • ~PHEffect() : PHEffect
  • ~PhysXObject() : PhysXPlugin::PhysXObject
  • ~PhysXScene() : PhysXPlugin::PhysXScene
  • ~Plane()
: PhysXPlugin::Plane
, VirtualFixture::Plane
  • ~PLControllerTool() : APDYNAMICART::PLControllerTool
  • ~PLMagnetTool() : APDYNAMICART::PLMagnetTool
  • ~PLNestTool() : APDYNAMICART::PLNestTool
  • ~PluginManager() : vrecko::PluginManager
  • ~PoA() : APDYNAMICART::PoA
  • ~PoAAdapter() : APDYNAMICART::PoAAdapter< T >
  • ~PoB() : APDYNAMICART::PoB
  • ~PointAdd() : APRoomEdit::PointAdd
  • ~PointMove() : APRoomEdit::PointMove
  • ~PointShell_Object_Data() : APSpacePartitioning::PointShell_Object_Data
  • ~PointShell_Object_Data_Geometry() : APSpacePartitioning::PointShell_Object_Data_Geometry
  • ~PointShell_Object_Data_Geometry_Analyser() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • ~PointShell_Object_Data_LOD_Builder() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • ~PointShellGeneric_Object_Data() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • ~PointShellVSVoxel_Object() : APSpacePartitioning::PointShellVSVoxel_Object
  • ~PolygonState() : APConnectEditor::PolygonState
  • ~PosNoiseRemover() : Filter::PosNoiseRemover
  • ~Preloader() : Preloader
  • ~PreloaderHeuristic() : PreloaderHeuristic
  • ~ProxiBorder() : VirtualFixture::ProxiBorder
  • ~ProxiBox() : VirtualFixture::ProxiBox
  • ~ProxiCone() : VirtualFixture::ProxiCone
  • ~ProxiCylinder() : VirtualFixture::ProxiCylinder
  • ~ProxiSphere() : VirtualFixture::ProxiSphere
  • ~PyAbility() : vrecko::PyAbility
  • ~QConstShapeVisitor() : osgQ::QConstShapeVisitor
  • ~QSection() : osgQ::QSection
  • ~QShapeVisitor() : osgQ::QShapeVisitor
  • ~QueryTurtle() : AP_LSystem::QueryTurtle
  • ~Reader() : mv::Reader
  • ~ReaderWriter() : vrecko::ReaderWriter
  • ~Rectangle() : AP_LSystem::Rectangle
  • ~RemoteDebugger() : PhysXPlugin::RemoteDebugger
  • ~Remover() : CarSim::Remover
  • ~RequestInputPin() : vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • ~RequestOutputPin() : vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • ~RoadsState() : CarSim::RoadsState
  • ~RoomEditor() : APRoomEdit::RoomEditor
  • ~RoomLoader() : APRoomEdit::RoomLoader
  • ~RoomSaver() : APRoomEdit::RoomSaver
  • ~Rotate() : base::Rotate
  • ~Rotation() : APConnectEditor::Rotation
  • ~Rule() : AP_LSystem::Rule
  • ~RWErrorHandler() : vrecko::RWErrorHandler
  • ~Scale() : APConnectEditor::Scale
  • ~Scene() : vrecko::Scene
  • ~SceneSave() : APEditorQAbilities::SceneSave
  • ~Scheduler() : vrecko::Scheduler
  • ~ScreenSetup() : ht::ScreenSetup
  • ~ScreenSetupSimple() : ht::ScreenSetupSimple
  • ~Sector() : Sector
  • ~ShootingSimulation() : APShootingSimulation::ShootingSimulation
  • ~ShowFDH() : base::ShowFDH
  • ~ShowFDHModel() : base::ShowFDHModel
  • ~SimpleBox() : APDYNAMICART::SimpleBox
  • ~SimpleObjectMovement() : APEditorQAbilities::SimpleObjectMovement
  • ~SliceTool() : SliceTool
  • ~Slider() : APGUI::Slider
  • ~SnapBox() : APEditorQAbilities::ObjectMovement::SnapBox
  • ~SnapObject() : SnapObject
  • ~SNCH_Object() : APSpacePartitioning::SNCH_Object
  • ~SNCH_Object_Data() : APSpacePartitioning::SNCH_Object_Data
  • ~SP_Object_Data_Base() : APSpacePartitioning::SP_Object_Data_Base
  • ~SP_Object_DataInterface() : vrecko::SP_Object_DataInterface
  • ~SP_ObjectInterface() : vrecko::SP_ObjectInterface
  • ~SP_SceneInterface() : vrecko::SP_SceneInterface
  • ~Sphere()
: ode::Sphere
, PhysXPlugin::Sphere
, VirtualFixture::Sphere
  • ~SphereBVH_Object() : APSpacePartitioning::SphereBVH_Object
  • ~SphereBVH_Object_Data() : APSpacePartitioning::SphereBVH_Object_Data
  • ~SphereBVH_Scene() : APSpacePartitioning::SphereBVH_Scene
  • ~StaticAttribute() : vrecko::StaticAttribute< type, tval, tref >
  • ~StaticString() : AP_LSystem::StaticString
  • ~StraightPipe() : AP_LSystem::StraightPipe
  • ~StrX() : StrX
  • ~SubBlock() : ArtificialWorld::SubBlock
  • ~SubBlockAnimation() : ArtificialWorld::SubBlockAnimation
  • ~SystemInfo() : base::SystemInfo
  • ~Terrain2D() : APNature::Terrain2D
  • ~Terrain2DSegment() : APNature::Terrain2DSegment
  • ~TerrainAbility() : APNature::TerrainAbility
  • ~TerrainAlgorithm() : APNature::TerrainAlgorithm
  • ~Timer() : vrecko::Timer
  • ~TLsOnJuncManager() : CarSim::TLsOnJuncManager
  • ~Tool() : APRoomEdit::Tool
  • ~ToolBrush() : APDYNAMICART::ToolBrush
  • ~ToolEraser() : APDYNAMICART::ToolEraser
  • ~ToolTongs() : APDYNAMICART::ToolTongs
  • ~Trace() : VirtualFixture::Trace
  • ~TurtleInterpret() : AP_LSystem::TurtleInterpret
  • ~TurtleStack() : AP_LSystem::TurtleStack
  • ~Ultratrak() : vreckoDP_base::Ultratrak
  • ~UpdatablePhysXObject() : PhysXPlugin::UpdatablePhysXObject
  • ~UserStream() : UserStream
  • ~UseToEvent() : APObjectUtils::UseToEvent
  • ~UseTrigger() : APEditorQAbilities::UseTrigger
  • ~Variable() : ht::Variable
  • ~Vibration() : VirtualFixture::Vibration
  • ~VibrationLabel() : VirtualFixture::VibrationLabel
  • ~VibrationLabelActivator() : VirtualFixture::VibrationLabelActivator
  • ~VoxelGrid_Object_Data() : APSpacePartitioning::VoxelGrid_Object_Data
  • ~VreckoMessage() : vrecko::VreckoMessage
  • ~vThread() : vrecko::vThread
  • ~WallAdd() : APRoomEdit::WallAdd
  • ~WallGeometry() : APRoomEdit::WallGeometry
  • ~WallMovement() : APRoomEdit::WallMovement
  • ~WallRemove() : APRoomEdit::WallRemove
  • ~WavefrontObj() : WavefrontObj
  • ~WG_Geometry() : WGeometry::WG_Geometry
  • ~WG_Hole() : WGeometry::WG_Hole
  • ~WG_Point() : WGeometry::WG_Point
  • ~WG_Vertices() : WGeometry::WG_Vertices
  • ~WG_Wall() : WGeometry::WG_Wall
  • ~Wiimote() : vreckoDP_base::Wiimote
  • ~WIM() : behindO::WIM
  • ~World() : vrecko::World
  • ~WorldBuilder() : ArtificialWorld::WorldBuilder
  • ~XercesStr() : vrecko::XercesStr
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- _ -

  • _dist_line() : ht::Function
  • _dist_line2() : ht::Function
  • _Light() : APLightsEditor::_Light
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- a -

  • A3DBird() : vreckoDP_base::A3DBird
  • Ability() : vrecko::Ability
  • abilityActivationTest() : APEditorController::EditorController
  • AbilityDispatcher() : vrecko::AbilityDispatcher
  • AbilityEditor() : APEditorQAbilities::AbilityEditor
  • AbilityMapper() : APEditorController::AbilityMapper
  • AbilityToInitialize() : vrecko::ReaderWriter::AbilityToInitialize
  • Abstract0LSystem() : AP_LSystem::Abstract0LSystem
  • AbstractFile() : AP_LSystem::AbstractFile
  • AbstractGenerator() : AP_LSystem::AbstractGenerator
  • AbstractInterpret() : AP_LSystem::AbstractInterpret
  • AbstractkLSystem() : AP_LSystem::AbstractkLSystem
  • AbstractLSystem() : AP_LSystem::AbstractLSystem
  • accept()
: osgQ::QSection
, osgQ::QShapeDrawable
, vreckoDP_base::KeyboardMouse
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • Act() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • ActDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • ActInt() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • activate()
: APConnectEditor::ConnectEditor
, APLightsEditor::Editor
, APRoomEdit::RoomEditor
, APConnectEditor::Cut
, MagicWandTool
, MTCreatorTool
, APConnectEditor::Optimalizer
, SliceTool
, APConnectEditor::PolygonState
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APDYNAMICART::DATool
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APDYNAMICART::PS_Layer
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AnimatorEditor
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectAdd
, AP_CableEditor::CableEditor
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::ObjectMovement
, APCameraMovement::CameraMovementEditor
, APEditorQAbilities::SceneSave
, APEditorQAbilities::SimpleObjectMovement
, APCameraPath::Camera
, APEditorQAbilities::UseTrigger
, APFFDEditor::EditorLogic
  • activateGesture() : vreckoDP_base::fsPinchGlove
  • ActivateMove() : APCameraPath::Camera
  • activateTool()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APRoomEdit::WallGeometry
  • actualize() : APGUI::Layout
  • add() : APLightsEditor::Lights
  • addAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • AddAddObserver() : ModelManager
  • addAndSwitchLayer() : APDYNAMICART::PolyhedraSculpture
  • AddAnimationPoint() : ArtificialWorld::SubBlockAnimation
  • addAnimatorToObject() : APObjectUtils::Animator
  • addAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
, vreckoUtils::MenuRoot
  • addBoundingPoint() : APConstrainedMovement::ConstraintArea
  • addChild() : vreckoUtils::MenuBase
  • addColor() : APDYNAMICART::colorGradient
  • addConstrainedChildID() : APConstrainedMovement::ConstraintDescription
  • addConstrainedDualPartnerID() : APConstrainedMovement::ConstraintDescription
  • addContourLoftGeometry() : AP_LSystem::LoftTurtle
  • addControlPoint() : AP_CableEditor::Cable
  • addControlPointBetweenLine() : AP_CableEditor::Cable
  • addCreatorInfoRecursive() : vrecko::ReaderWriter
  • AddDeleteObserver() : ModelManager
  • AddDelta()
: ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
, ht::VariableQuat
  • addDynamicString() : AP_LSystem::Rule
  • addEdgeAsEO() : CarSim::RoadsState
  • addEdgesAsEO() : CarSim::RoadsState
  • addEntity()
: vrecko::Scheduler
, vrecko::vThread
  • addEnvironmentObject() : vrecko::Scene
  • addEOChild() : vrecko::EnvironmentObject
  • addEventHandler()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • addField() : APHUD::HUDDisplay
  • addForceToHoop() : APDYNAMICART::PhysXManager
  • addGesture() : mv::CPlayer
  • AddGetObserver() : ModelManager
  • AddGround() : APClouds::Clouds
  • addHomomorphism()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • addHook() : APDYNAMICART::HookManager
  • addHoopActorToScene() : APDYNAMICART::PhysXManager
  • addInputOutputs()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • addInputPin() : vrecko::BaseClass
  • addItem()
: APGUI::ItemsGroup
, APGUI::Layout
  • AddItem() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • addLayer() : APDYNAMICART::PolyhedraSculpture
  • addLine() : APTextOutput::Console , LoadingConsole
  • addMarker()
: VirtualFixture::MarkerFactory
, VirtualFixture::Trace
  • addMenuItem() : APMenu::DynamicMenu
  • AddModelGeometry() : ModelManager
  • addNewPartObject() : APConnectEditor::Cut
  • AddNode() : DynamicTree< _Type >
  • AddNodeLast() : DynamicTree< _Type >
  • addNotification() : vrecko::BaseClass
  • addObject()
: vrecko::OctTree
, APShootingSimulation::ShootingSimulation
  • addObserver() : vreckoUtils::Observable
  • AddObserver() : AddObserver
  • addOuterObject() : vrecko::EventDispatcher
  • addOutputPin() : vrecko::BaseClass
  • addOutstandingText() : vrecko::Logger
  • addPartitioningObjectInterface() : vrecko::Scene
  • addPartitioningSceneInterface() : vrecko::Scene
  • AddPathPoint() : APCameraPath::Camera
  • addPoint()
: APCameraMovement::CameraPath
, APDYNAMICART::ComputeThread
  • addProbability() : AP_LSystem::RandomIndex
  • AddReference() : GeometryState , AnimatedGeometryState
  • addRequestInputPin() : vrecko::BaseClass
  • addRequestOutputPin() : vrecko::BaseClass
  • addRequiredEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • addRule()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • addSceneFileInfoIfPossible() : vrecko::ReaderWriter
  • addSector() : SectorColorGen , APDYNAMICART::SectorManager
  • addSensor() : vreckoDP_base::OptiTrack
  • AddSkybox() : APClouds::Clouds
  • addSnappingPlane() : APEditorQAbilities::ObjectMovement
  • addStaticString() : AP_LSystem::Rule
  • AddSun() : APClouds::Clouds
  • addSun() : APLightsEditor::Lights
  • addTerminatorEdges() : CarSim::RoadsState
  • addToCell() : vrecko::OctTree
  • addToNode() : vrecko::OctTree
  • AddToQueue() : Cloud
  • addToScene() : APWeather::Weather
  • addType() : AP_LSystem::AbstractFile
  • AddUpdate() : Cache , AddObserver
  • addUserData() : vrecko::EnvironmentObject
  • addUserDrawable() : PhysXPlugin::PhysXObject
  • addVectOnEnd() : mv::CGesture
  • addVerticesLeafsAndChilds() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • addView()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • AddViewPoint() : APCameraPath::Camera
  • addWall() : WGeometry::WG_Point
  • addWindow() : APHUD::HUDDisplay
  • adjoint() : gmMatrix3 , gmMatrix4
  • adjustLimits() : APDYNAMICART::Limits
  • adjustMatrices() : AP_LSystem::MovingTurtle
  • Advanced() : APDYNAMICART::Advanced
  • AfterInitialization() : PhysXPlugin::PhysXObject
  • AllCloudsUpdateCallBack() : AllCloudsUpdateCallBack
  • Allocate() : APNature::TerrainAlgorithm
  • allocateControlPointArray() : APFFDEditor::Grid
  • allocateEdgeArray() : APFFDEditor::Grid
  • allocateFaceArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::GeometryLoaderBase
  • allocateGeometryArray() : APFFDEditor::GeometryLoader
  • allocateSTNode()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • allocateVertexArray()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoaderBase
  • analyzeXMLTree() : vrecko::ReaderWriter
  • Animate() : APCameraPath::Camera
  • AnimatedGeometryState() : AnimatedGeometryState
  • AnimatedModel() : ArtificialWorld::AnimatedModel
  • animateToPoint() : APObjectUtils::Animator
  • animating() : APCameraMovement::CameraPath
  • AnimationPoint()
: ArtificialWorld::AnimationPoint
, APObjectUtils::Animator::AnimationPoint
, ArtificialWorld::AnimationPoint
  • Animator() : APObjectUtils::Animator
  • AnimatorEditor() : APEditorQAbilities::AnimatorEditor
  • append() : AP_LSystem::LongString
  • appendElementAndBoolValue() : vrecko::ReaderWriter
  • appendElementAndDoubleValue() : vrecko::ReaderWriter
  • appendElementAndFloatValue() : vrecko::ReaderWriter
  • appendElementAndIntValue() : vrecko::ReaderWriter
  • appendElementAndLongIntValue() : vrecko::ReaderWriter
  • appendElementAndMatrixValue() : vrecko::ReaderWriter
  • appendElementAndQuatValue() : vrecko::ReaderWriter
  • appendElementAndStringValue() : vrecko::ReaderWriter
  • appendElementAndVec2Value() : vrecko::ReaderWriter
  • appendElementAndVec3Value() : vrecko::ReaderWriter
  • appendElementAndVec4Value() : vrecko::ReaderWriter
  • appendType()
: AP_LSystem::LSystemException
, AP_LSystem::ParsingException
, AP_LSystem::FileException
, AP_LSystem::ConfigurationException
  • apply()
: filter1
, VirtualFixture::NavSphere
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Drag
, VirtualFixture::Marker
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabelActivator
, filter2
, VirtualFixture::Plane
, VirtualFixture::Damper
, osgQ::QConstShapeVisitor
, VirtualFixture::Sphere
, vreckoUtils::MenuVisitor
, VirtualFixture::VibrationLabel
, vreckoUtils::MenuVisitor
, VirtualFixture::Box
, vreckoUtils::MenuVisitor
, VirtualFixture::Cylinder
, VirtualFixture::MarkerFactory
, osgQ::QPrimitiveShapeVisitor
, osgQ::QDrawShapeVisitor
, VirtualFixture::Cone
, osgQ::QComputeBoundShapeVisitor
, VirtualFixture::Grid
, osgQ::QShapeVisitor
, VirtualFixture::Filter
  • applyConstrainedSnapping() : APConstrainedMovement::ConstrainedObjectMovement
  • applySnapping() : APEditorQAbilities::ObjectMovement
  • applyTransformation() : APConstrainedMovement::ConstraintArea
  • arb_rotate() : gmMatrix4 , gmMatrix3
  • ArcLength() : APCameraPath::Camera
  • areAnglesComputed() : WGeometry::WG_Wall
  • areValidVertices() : WGeometry::WG_Vertices
  • asHoop() : APDYNAMICART::Ctrl_StringSculptures
  • assign() : ConstantColorGen , gmVector2 , gmVector3 , gmMatrix3 , gmVector4 , gmMatrix4
  • assign4x4() : Arm
  • at()
: APLightsEditor::Lights
, VK_NoStepInto_Namespace::DynamicArray< _Type >
  • Attractor() : APDYNAMICART::Attractor
  • AttractorName() : APDYNAMICART::IComputeStrategy
  • Attribute() : vrecko::Attribute
  • attributesCount()
: vrecko::DynamicAttribute
, vrecko::AttributesDescription
  • autosynch() : Hci
  • Avatar()
: base::Avatar
, VirtualFixture::Avatar
  • AvatarInHand() : navigation::AvatarInHand
  • AvatarManipulator() : behindO::AvatarManipulator
  • AvatarMovement() : APEditorQAbilities::AvatarMovement
  • AxisFrameAdapter() : APDYNAMICART::AxisFrameAdapter
  • AxisLock() : VirtualFixture::AxisLock
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- b -

  • barycentricTest() : WGeometry::WG_Geometry
  • BaseActor() : PhysXPlugin::BaseActor
  • BaseClass() : vrecko::BaseClass
  • BaseJoint() : PhysXPlugin::BaseJoint
  • BasePhysXObject() : PhysXPlugin::BasePhysXObject
  • Basic() : APDYNAMICART::Basic
  • BasicPreloaderHeuristic() : BasicPreloaderHeuristic
  • BCLoaderErrorHandler() : BCLoaderErrorHandler
  • BeforeInitialization()
: PhysXPlugin::Fluid
, PhysXPlugin::PhysXObject
  • begin() : Hci
  • BehindObstacleExp_wT() : BehindObstacleExp_wT
  • BehindObstacleExperiment() : BehindObstacleExperiment
  • BenchmarkWriter() : vrecko::BenchmarkWriter
  • betaSplineBasis() : gmMatrix4
  • bezierBasis() : gmMatrix4
  • bindGeode() : AP_LSystem::AbstractTurtle
  • bindWord() : AP_LSystem::QueryInterpret
  • BinomialHeap() : BinomialHeap< _NodeClass, _keyType >
  • blink() : CarSim::CarExecutionUnit
  • BlockAttributes() : ArtificialWorld::BlockAttributes
  • BlockUpdater() : ArtificialWorld::BlockUpdater
  • Boid() : boids::Boid
  • BoidsLogic() : boids::BoidsLogic
  • BoidsPlanner() : boids::BoidsPlanner
  • Border() : VirtualFixture::Border
  • Box()
: PhysXPlugin::Box
, VirtualFixture::Box
  • Brush() : APDYNAMICART::Brush
  • BrushStroke() : APDYNAMICART::BrushStroke
  • BrushStrokeControlPoint() : APDYNAMICART::BrushStrokeControlPoint
  • bsplineBasis() : gmMatrix4
  • BufferedFile() : vrecko::BufferedFile
  • BufferedFileWrite() : vrecko::BufferedFileWrite
  • BufferedSpline() : BufferedSpline
  • buildLODTree()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data
  • BuildMenuLayouts() : APNature::TerrainAbility
  • buildPacket() : Hci
  • buildQueue() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • buildReductionLevelStructure() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • buttonPress() : vreckoDP_base::KeyboardMouse
  • buttonRelease() : vreckoDP_base::KeyboardMouse
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- c -

  • Cable() : AP_CableEditor::Cable
  • CableEditor() : AP_CableEditor::CableEditor
  • Cache() : Cache
  • CacheInfo() : CacheInfo
  • calcAnimMatrix() : APObjectUtils::Animator
  • calcD() : APSpacePartitioning::SNCH_Object::OneTri
  • calcFinalShiftFromSelectedSet() : APEditorQAbilities::ObjectMovement
  • calcFull() : Arm
  • calcJoints() : Arm
  • calcLMDHash() : APSpacePartitioning::SNCH_Object
  • calcM() : Arm
  • calcNodeBBox() : vrecko::Scene
  • calcNodeBBoxHelper() : vrecko::Scene
  • calcNormal() : APSpacePartitioning::SNCH_Object::OneTri
  • calcNothing() : Arm
  • calcParams() : Arm
  • calcStylus3DOF() : Arm
  • calcStylus6DOF() : Arm
  • calcStylusDir() : Arm
  • calcSubtreeTriangleRepresentant() : APSpacePartitioning::SNCH_Object_Data
  • calcT() : Arm
  • calcTrig() : Arm
  • CalculateBoundingBox() : Cloud
  • calculateEdgeCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgeImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgeLength()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateEdgesLength()
: APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • calculateGeometryProperties() : APSpacePartitioning::SNCH_Object_Data
  • calculateHash() : vrecko::EventDispatcher::StringWithHash
  • calculateNewVertexPosition() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateNormalOfPolygon()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateNormalOfPolygons()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVertexNormal() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • calculateVertexNormalAndImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVerticesNormalAndImporatance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • calculateVerticesNormals() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • calibrateDevice()
: vrecko::Device
, vreckoDP_base::fdtDataGlove
, vreckoDP_base::KeyboardMouse
  • Camera() : APCameraPath::Camera
  • camera_setViewMatrixAsLookAt()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • CameraMovementEditor() : APCameraMovement::CameraMovementEditor
  • CameraPath() : APCameraMovement::CameraPath
  • canBeClicked()
: APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemSlider
  • canBeExpanded() : APMenu::MenuItem
  • cancel() : APDYNAMICART::ComputeThread
  • CappedCylinder() : ode::CappedCylinder
  • Capsule() : PhysXPlugin::Capsule
  • CarControlUnit() : CarSim::CarControlUnit
  • cardinalBasis() : gmMatrix4
  • CarExecutionUnit() : CarSim::CarExecutionUnit
  • CarPartsNodeCache() : CarSim::CarPartsNodeCache
  • CascadingCut() : FibonacciHeap< _NodeClass, _keyType >
  • catmullromBasis() : gmMatrix4
  • catmullRomInterpolation() : MotionTrailTriangulator
  • CCollection() : mv::CCollection
  • CentreObjectManipulator() : behindO::CentreObjectManipulator
  • CGesture() : mv::CGesture
  • changeAttractor() : APDYNAMICART::ToolMagicWand
  • ChangeOfVisibility() : behindO::ChangeOfVisibility
  • changeToStructureOccured() : APMenu::DynamicMenu
  • check_motion() : Arm
  • checkBckg() : Arm
  • checkBox() : vreckoDP_base::fsPinchGlove
  • checkConnection() : vreckoDP_base::fsPinchGlove
  • checkDiff() : vreckoDP_base::LHeadTracker
  • checkEdgesFromToAndTheirPolygonPoints() : CarSim::RoadsState
  • checkGesture() : vreckoDP_base::fsPinchGlove
  • checkHookDeleteRequest() : APDYNAMICART::Ctrl_StringSculptures
  • checkInputXMLParameters() : CarSim::CarControlUnit
  • checkInterconnection() : vrecko::EventDispatcher
  • checkLocation() : BehindObstacleExp_wT , BehindObstacleExperiment
  • checkPacket() : Hci
  • checkPoADeleteRequest() : APDYNAMICART::Ctrl_StringSculptures
  • checkXMLparameters() : CarSim::CarExecutionUnit
  • ChessBoard() : ChessBoard
  • ChessPiece() : ChessPiece
  • chooseBoundaryLoop() : SnapObject
  • clamp() : gmVector2 , gmVector3 , gmVector4
  • classDescription() : APDYNAMICART::PoAAdapter< T > , Interpolator
  • className()
: APDYNAMICART::PoAAdapter< T >
, osgQ::QSection
, grass::GrassDrawable
, Interpolator
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • clean()
: vrecko::Ability
, AP_LSystem::TurtleProperties
, APObjectUtils::Animator
, APObjectUtils::ConnectionViz
, APObjectUtils::KeepOnScreen
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
  • cleanVertexEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • clear()
: VK_NoStepInto_Namespace::DynamicArray< _Type >
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, AP_LSystem::TurtleStack
, MemoryWriteBuffer
  • Clear() : DynamicTree< _Type > , APCameraPath::Camera , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • clearAllPoAs() : APDYNAMICART::Controller
  • ClearAnimation() : ArtificialWorld::SubBlockAnimation
  • ClearAnimationPoints() : ArtificialWorld::SubBlockAnimation
  • clearFreshDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • ClearHardSeparator() : WAVEFRONT::InPlaceParser
  • clearPacket() : Hci
  • clearSpheres() : AP_CableEditor::Cable
  • clearValue() : APHUD::HUDDisplay
  • clicked()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, Icon
, APDYNAMICART::PoB
  • clone()
: APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, AP_LSystem::AbstractLSystem
, AP_LSystem::D0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParStoch0LSystem
, osgQ::QSection
, grass::GrassDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • cloneType()
: osgQ::QSection
, grass::GrassDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • close()
: vrecko::BufferedFile
, vrecko::BufferedFileWrite
  • closeCacheFile() : vrecko::PersistentCache
  • closeDevice()
: vrecko::Device
, vreckoDP_base::fdtDataGlove
, vreckoDP_base::fsPinchGlove
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
  • closeFile() : vrecko::BenchmarkWriter
  • closeLoop() : APConnectEditor::Cut
  • closeSerial() : Serial
  • Cloth() : PhysXPlugin::Cloth
  • ClothDrawable() : PhysXPlugin::ClothDrawable
  • Cloud() : Cloud
  • Cloud::SetViewMatrix() : AllCloudsUpdateCallBack
  • Clouds() : APClouds::Clouds
  • CloudsManager() : CloudsManager
  • CMVect() : mv::CMVect
  • CoatWithGrass() : grass::Grass
  • collapseItem() : APMenu::DynamicMenu
  • collapseSiblings() : APMenu::DynamicMenu
  • CollisionInfo() : vrecko::CollisionInfo
  • CollisionParams__ver1() : vrecko::CollisionParams__ver1
  • ColorBucket() : APRoomEdit::ColorBucket
  • colorChanged() : APDYNAMICART::OrdinaryAttractor
  • ColorGenAdapter() : APDYNAMICART::ColorGenAdapter
  • ColorGenFactory() : APDYNAMICART::ColorGenFactory
  • ColorPicker() : APGUI::ColorPicker
  • comParams() : Hci
  • comparator() : RealCmp< T >
  • compareEQ() : RealCmp< T >
  • compareGT() : RealCmp< T >
  • compareGTEQ() : RealCmp< T >
  • compareLT() : RealCmp< T >
  • compareLTEQ() : RealCmp< T >
  • compareObjectPosition() : APConstrainedMovement::ConstrainedObjectMovement
  • compareObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • compareObjectRotation() : APConstrainedMovement::ConstrainedObjectMovement
  • compileAbilityMapping() : APEditorController::EditorController
  • CompositeObject() : ode::CompositeObject
  • CompositeViewer() : vrecko::CompositeViewer
  • compute()
: APDYNAMICART::Attractor
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::NullAttractor
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PatternBase
  • compute2DNormal() : SweepSurfaceGeode
  • compute2DNormals() : SweepSurfaceGeode
  • computeAttrNormals() : WGeometry::WG_Wall
  • computeAttrVectorsAndAngles() : WGeometry::WG_Wall
  • computeAttrVertices() : WGeometry::WG_Wall
  • computeBBoxShereRadius() : APSpacePartitioning::PointShell_Object_Data
  • computeBBoxSheresRadius() : APSpacePartitioning::PointShell_Object_Data
  • computeBound()
: osgQ::QShapeDrawable
, PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • computeCarState() : CarSim::CarExecutionUnit
  • computeEdgesAttributes() : CarSim::RoadsState
  • ComputeForce() : mv::CPlayer
  • computeHoleVertices() : WGeometry::WG_Wall
  • computeJuncInOutEdgesAttr() : CarSim::RoadsState
  • computeJunctionsEdges() : CarSim::RoadsState
  • computeNumberOfSegments() : osgQ::QSection
  • ComputePath() : APCameraPath::Camera
  • computeRadiusOfBoundingSpheres() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • computeRecVelocityOnJunc() : CarSim::RoadsState
  • computeRecVelOnFstJunc() : CarSim::CarControlUnit
  • computeRMF() : AP_CableEditor::Cable
  • computeRotationMatrix() : osgQ::QSection
  • computeShortestPath() : CarSim::CarControlUnit
  • computeSNCH() : APSpacePartitioning::SNCH_Object_Data
  • ComputeSpline() : APCameraPath::Camera
  • ComputeThread() : APDYNAMICART::ComputeThread
  • ComputeUpRightVectors() : Cloud
  • computeVertexLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Cone() : VirtualFixture::Cone
  • ConfigurationException() : AP_LSystem::ConfigurationException
  • confirmAnimationEnded() : APMenu::DynamicMenu
  • connect() : Arm , Hci
  • connectDevice() : vrecko::DeviceManager
  • ConnectEditor() : APConnectEditor::ConnectEditor
  • ConnectionViz() : APObjectUtils::ConnectionViz
  • Console() : APTextOutput::Console
  • Consolidate() : ThinHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType >
  • ConstantColorAdapter() : APDYNAMICART::ConstantColorAdapter
  • ConstantColorGen() : ConstantColorGen
  • ConstantDiamAdapter() : APDYNAMICART::ConstantDiamAdapter
  • ConstrainedObjectMovement() : APConstrainedMovement::ConstrainedObjectMovement
  • ConstraintArea() : APConstrainedMovement::ConstraintArea
  • ConstraintArea::distanceFactorToArea() : APConstrainedMovement::ConstraintArea
  • ConstraintDescription() : APConstrainedMovement::ConstraintDescription
  • ConstraintHierarchyMember() : ConstraintHierarchyMember
  • constructCacheDataName()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • constructModelDataName() : vrecko::PersistentCache
  • constructPointShellCacheDataName() : APSpacePartitioning::PointShell_Object_Data
  • constructPointShellSubdividedMeshDataName() : APSpacePartitioning::PointShell_Object_Data
  • constructTree() : APSpacePartitioning::SphereBVH_Object_Data
  • ContactObjectManipulator() : behindO::ContactObjectManipulator
  • ContainsAnimatedModelGeometry() : ModelManager
  • containsAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • ContainsModelGeometry() : ModelManager
  • containsValue() : vrecko::Enumeration< tval, tref >
  • ControllableAbility() : vrecko::ControllableAbility
  • Controller() : APDYNAMICART::Controller
  • ControlPosition() : mv::CPlayer
  • ControlSpheresColor() : AP_CableEditor::Cable
  • convertActPosToNormPos() : APObjectUtils::Animator
  • convertActTimeToActPos()
: APCameraMovement::CameraPath
, APObjectUtils::Animator
  • convertExtParams() : Arm
  • convertFromString() : AP_LSystem::LongString
  • convertInt() : APDYNAMICART::Utils
  • convertParams() : Arm
  • convertString() : APDYNAMICART::Utils
  • CopyFrom() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • CopyProperties() : APObjectUtils::CopyProperties
  • copyTo() : gmVector3 , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4 , gmMatrix4
  • CoreActorDesc() : PhysXPlugin::CoreActorDesc
  • coreHierarchyCreation()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::SP_Object_Data_Base
  • coreInit()
: vrecko::InputPin< _MessageType >
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • correctName() : APHUD::HUDDisplay
  • Count() : GeometryState , AnimatedGeometryState
  • CPlayer() : mv::CPlayer
  • CPscale() : APFFDEditor::EditorLogic
  • Create()
: PhysXPlugin::BaseActor
, PhysXPlugin::BaseJoint
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::Box
, PhysXPlugin::Capsule
, PhysXPlugin::Cloth
, PhysXPlugin::CoreActorDesc
, PhysXPlugin::Plane
, PhysXPlugin::ForceField
, vrecko::MaterialDesc
, PhysXPlugin::MaterialManager
, PhysXPlugin::Sphere
  • create() : LoadingConsole
  • Create() : PhysXPlugin::Fluid
  • createAbility() : vrecko::World
  • createAbilityMapper() : APEditorController::EditorController
  • createActor() : APDYNAMICART::Hoop
  • createBorder() : behindO::ChangeOfVisibility
  • createBuffer() : APLightsEditor::Lights
  • createCapsule() : APDYNAMICART::PhysXManager
  • createCircle() : AP_CableEditor::CableEditor
  • createCircleContour() : AP_LSystem::LoftTurtle
  • createCircleSide() : APDYNAMICART::ElongatedCircle
  • createCollisionHierarchy() : vrecko::EnvironmentObject
  • createColorSphere() : APGUI::ColorPicker
  • createColorSubMenu() : APDYNAMICART::Ctrl_Attractor
  • createCompatibleMessage()
: vrecko::InputPin< _MessageType >
, vrecko::IOPinBase
, vrecko::OutputPin< _MessageType >
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
, vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • createConnection() : APObjectUtils::ConnectionViz
  • createConnectionViz() : APEditorQAbilities::AbilityEditor
  • CreateCurs2ViewPts() : APCameraPath::Camera
  • createCursor() : APDYNAMICART::DATool
  • createDATool() : APDYNAMICART::Utils
  • createDefaultRoom() : APRoomEdit::WallGeometry
  • createDistanceFieldGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDistanceFieldGridCollision() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDistanceFieldTempGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • createDrawableObject() : SweepSurfaceGeode
  • createEdgeGroups() : APSpacePartitioning::SNCH_Object_Data
  • createEffect() : APObjectUtils::ObjectEffect
  • createEffect_Lines() : APObjectUtils::ObjectEffect
  • createEffect_PointShellHierarchy_ProcessLevel() : APObjectUtils::ObjectEffect
  • createEffect_Reconstruction() : APObjectUtils::ObjectEffect
  • createEffect_SphereHierarchy_ProcessLevel() : APObjectUtils::ObjectEffect
  • createEffect_VoxelGrid() : APObjectUtils::ObjectEffect
  • createElement() : vrecko::ReaderWriter
  • createEoAbility() : AP_CableEditor::CableEditor
  • createFaceGroups() : APSpacePartitioning::SNCH_Object_Data
  • createFacePlanes() : APDYNAMICART::PS_Polyhedron
  • createFlare() : APLightsEditor::Lights
  • createGeodes() : AP_LSystem::AbstractInterpret
  • createGeometry()
: APGUI::Slider
, APDYNAMICART::HoopGeometry
  • createGraph() : SnapObject
  • createGraphics() : APMenu::MenuItem
  • createGraphicsCore()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, APMenu::MenuItemNull
  • createGrid() : APFFDEditor::Grid
  • createHierarchy() : APSpacePartitioning::VoxelGrid_Object_Data
  • CreateHole() : APRoomEdit::CreateHole
  • createInfo()
: vrecko::ControllableAbility
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
  • createInstance() : APDYNAMICART::Attractor
  • createInterface()
: vrecko::ControllableAbility
, APEditorController::AbilityMapper
  • createLODHierarchy() : APSpacePartitioning::PointShell_Object_Data
  • createLoftGeometryOpening() : AP_LSystem::LoftTurtle
  • createLSystem() : AP_LSystem::AbstractGenerator
  • createMag() : APDYNAMICART::Ctrl_PerlinLines
  • createMagnet() : APDYNAMICART::PerlinLines
  • createMainObject() : APObjectUtils::ConnectionViz
  • createMainObjects() : APMenu::DynamicMenu
  • createMenu()
: APDYNAMICART::ConstantDiamAdapter
, vrecko::ControllableAbility
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::Brush
, APDYNAMICART::HoopShape
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::PoAAdapter< T >
  • createMenuAbilities() : APDYNAMICART::ToolMagicWand
  • CreateMenuAbilities()
: APDYNAMICART::ToolBrush
, APDYNAMICART::DAEnvironment
  • createMenuFromNode() : APMenu::DynamicMenu
  • createMenuFromString() : APMenu::DynamicMenu
  • createMenuItem() : vreckoUtils::MenuCommon
  • createMenuSlider() : vreckoUtils::MenuCommon
  • createMenuStructure()
: APDYNAMICART::PerlinLines
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolBrush
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_StringSculptures
  • CreateMenuStructure() : APNature::TerrainAbility
  • createMenuStructure()
: APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::HookObject
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Attractor
, APDYNAMICART::BrushStroke
, APDYNAMICART::Controller
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::Hoop
, APDYNAMICART::PoA
, APDYNAMICART::NullAttractor
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • createModel() : APMenu::MenuItemText
  • createModels()
: APGUI::Slider
, APGUI::Icon
  • createMultiLevel() : APSpacePartitioning::PointShell_Object_Data
  • createMutex() : vrecko::vThread
  • createNewCuttingLoop() : APConnectEditor::Cut
  • createNewItem()
: APMenu::MenuItemNull
, APMenu::MenuItemText
, APMenu::MenuItem
, APMenu::MenuItemSlider
  • createNewObject() : APEditorQAbilities::ObjectAdd
  • createNewPolyhedraMenu() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • createNewShowHideMenu() : APDYNAMICART::PolyhedraSculpture
  • createObjectEffect() : APObjectUtils::ObjectEffectMan
  • createParameterSubMenu() : APDYNAMICART::Attractor
  • createParser() : vrecko::ReaderWriter
  • createPoA() : APDYNAMICART::Ctrl_StringSculptures
  • CreatePoA() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • createPoA()
: APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
  • createPointerTrail() : APMenu::DynamicMenu
  • CreatePreloader() : Cache
  • createReturningCompatibleMessage()
: vrecko::IORequestPinBase
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
, vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • createRope() : APDYNAMICART::PhysXManager
  • createRopeSphericalJoint() : APDYNAMICART::PhysXManager
  • createScene() : APDYNAMICART::PhysXManager
  • createScenes() : BehindObstacleExp_wT , BehindObstacleExperiment
  • createSimple() : APSpacePartitioning::PointShell_Object_Data
  • createSimpleGraph() : SnapObject
  • createSingleLevel() : APSpacePartitioning::PointShell_Object_Data
  • createSphere() : AP_CableEditor::Cable
  • createSpheres() : AP_CableEditor::Cable
  • createTrafficLights() : CarSim::RoadsState
  • createTreeFromGeometry() : APSpacePartitioning::SphereBVH_Object_Data
  • createVisuals() : APGUI::ColorPicker
  • Ctrl_Attractor() : APDYNAMICART::Ctrl_Attractor
  • Ctrl_FreeHandPainting() : APDYNAMICART::Ctrl_FreeHandPainting
  • Ctrl_MotionVisualization() : APDYNAMICART::Ctrl_MotionVisualization
  • Ctrl_PerlinLines() : APDYNAMICART::Ctrl_PerlinLines
  • Ctrl_PolyhedraSculptures() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • Ctrl_StringSculptures() : APDYNAMICART::Ctrl_StringSculptures
  • Cube() : ode::Cube
  • CubicInterpolator() : CubicInterpolator
  • Cut() : APConnectEditor::Cut , FibonacciHeap< _NodeClass, _keyType >
  • cutObject() : APConnectEditor::Cut
  • CuttingPlane() : behindO::CuttingPlane
  • Cylinder() : VirtualFixture::Cylinder
  • CylindricalJoint() : PhysXPlugin::CylindricalJoint
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- d -

  • D0LSystem() : AP_LSystem::D0LSystem
  • DAControlPoint() : DAControlPoint
  • DAEnvironment() : APDYNAMICART::DAEnvironment
  • DAGizmo() : APDYNAMICART::DAGizmo , DAGizmo
  • Damper() : VirtualFixture::Damper
  • DASample() : DASample
  • DATool() : APDYNAMICART::DATool
  • deactivate()
: APConnectEditor::Rotation
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APConnectEditor::Scale
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::SimpleObjectMovement
, APEditorQAbilities::UseTrigger
, APDYNAMICART::DATool
, APLightsEditor::Editor
, APRoomEdit::RoomEditor
, AP_CableEditor::CableEditor
, APDYNAMICART::PLNestTool
, MagicWandTool
, MTCreatorTool
, APDYNAMICART::PLMagnetTool
, SliceTool
, APCameraMovement::CameraMovementEditor
, APDYNAMICART::PLControllerTool
, APDYNAMICART::PS_Layer
, APCameraPath::Camera
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APConnectEditor::ConnectEditor
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APConnectEditor::Cut
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APConnectEditor::Optimalizer
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
  • deactivateGesture() : vreckoDP_base::fsPinchGlove
  • DeactivateMove() : APCameraPath::Camera
  • deactivateTool()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APRoomEdit::WallGeometry
  • deallocateControlPointArray() : APFFDEditor::Grid
  • deallocateEdgeArray() : APFFDEditor::Grid
  • deallocateFaceArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • deallocateGeometryArray() : APFFDEditor::GeometryLoader
  • deallocateVertexArray()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • debugFileLog()
: vrecko::Logger
, vrecko::World
  • debugFlush() : vrecko::Logger
  • debugKeyPressed()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
  • DebugLevelStats() : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • debugLog()
: vrecko::Logger
, vrecko::World
  • debugPrintInterconnectionMap() : vrecko::EventDispatcher
  • debugPrintRequestMap() : vrecko::EventDispatcher
  • DebugStats() : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • debugWriteNormals()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • DECLARE_INPUT()
: APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorController::EditorController
, base::Avatar
, APEditorController::EditorController
, base::Avatar
, Filter::PosNoiseRemover
, APGUI::ColorPicker
, base::Avatar
, APGUI::ColorPicker
, base::Avatar
, APGUI::ColorPicker
, APGUI::GUI_Controller
, base::Avatar
, APGUI::Menu
, APGUI::Slider
, base::Avatar
, ht::HeadTracking
, ht::ScreenSetup
, base::Avatar
, ht::ScreenSetup
, base::Avatar
, ht::ScreenSetup
, base::Avatar
, ht::ScreenSetupSimple
, base::hand
, ht::ScreenSetupSimple
, base::Light
, APMenu::DynamicMenu
, base::MouseHand
, APMenu::DynamicMenu
, APObjectUtils::Animator
, base::MouseHand
, APObjectUtils::Animator
, APObjectUtils::ObjectEffect
, base::MouseHand
, APObjectUtils::ObjectEffectMan
, base::SystemInfo
, APObjectUtils::ObjectModif
, APObjectUtils::ObjectSelector
, vrecko::EnvironmentObject
, APObjectUtils::UseToEvent
, APShootingSimulation::ShootingSimulation
, vrecko::EnvironmentObject
, APShootingSimulation::ShootingSimulation
, vrecko::EnvironmentObject
, APShootingSimulation::ShootingSimulation
, vreckoDP_base::OptiTrack
, vrecko::EnvironmentObject
, vreckoDP_base::Wiimote
, PhysXPlugin::BaseActor
, vrecko::EnvironmentObject
, PhysXPlugin::BaseActor
, vrecko::EnvironmentObject
, PhysXPlugin::BaseActor
, boids::Boid
, boids::BoidsLogic
, boids::BoidsPlanner
, CarSim::CarExecutionUnit
, CarSim::Remover
, CarSim::RoadsState
, APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Hoop
, APDYNAMICART::PoA
, APDYNAMICART::ToolBrush
  • DECLARE_OUTPUT()
: vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
, PhysXPlugin::BaseActor
, vreckoDP_Kinect::Kinect
, PhysXPlugin::BaseActor
, base::hand
, base::MouseHand
, boids::BoidsLogic
, boids::BoidsPlanner
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APEditorController::AbilityMapper
, APEditorController::EditorController
, Filter::PosNoiseRemover
, APGUI::ColorPicker
, APGUI::Icon
, APGUI::IconColour
, APGUI::Menu
, APGUI::Slider
, ht::HeadTracking
, APInputConnector::InputConnector
, APMenu::MenuItemText
, APMenu::MenuItemSlider
, APMenu::DynamicMenu
, navigation::AvatarInHand
, navigation::KMTracker
, vreckoDP_base::KeyboardMouse
, navigation::KMTracker
, APObjectUtils::Animator
, APObjectUtils::ObjectInfo
, APObjectUtils::ObjectSelector
, APObjectUtils::UseToEvent
, vreckoDP_base::KeyboardMouse
  • DECLARE_REQUEST_INPUT()
: APGUI::GUI_Controller
, PhysXPlugin::PhysXScene
, APObjectUtils::ObjectSelector
, CarSim::RoadsState
, APGUI::ColorPicker
, APEditorController::EditorController
, base::MTMatrixTransform
, CarSim::RoadsState
, base::MTMatrixTransform
, CarSim::CarExecutionUnit
, CarSim::CarPartsNodeCache
, CarSim::RoadsState
, vrecko::ControllableAbility
, APEditorController::EditorController
, APGUI::GUI_Controller
, APInputConnector::InputConnector
, APMenu::DynamicMenu
, APObjectUtils::ObjectSelector
, ode::DynamicScene
, APTextOutput::Console
, PhysXPlugin::PhysXScene
  • DECLARE_REQUEST_OUTPUT()
: vrecko::ControllableAbility
, APGUI::Menu
, PhysXPlugin::BaseJoint
, APDYNAMICART::ToolTongs
, APDYNAMICART::ToolRotation
, APInputConnector::InputConnector
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolEraser
, ode::CompositeObject
, ode::CappedCylinder
, PhysXPlugin::UpdatablePhysXObject
, APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APGUI::ColorPicker
, PhysXPlugin::BaseActor
, vrecko::ControllableAbility
, PhysXPlugin::BaseActor
, APMenu::DynamicMenu
, ode::Cube
, APObjectUtils::ObjectModif
, APGUI::GUI_Controller
, ode::Sphere
, PhysXPlugin::BasePhysXObject
, APGUI::Slider
, vrecko::ControllableAbility
, APEditorController::EditorController
, vrecko::ControllableAbility
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolMagicWand
  • DecreaseKey() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , GenericHeap< _NodeClass, _keyType >
  • decreaseLockCountForPrevEdge() : CarSim::RoadsState
  • DefaultSymbols() : WAVEFRONT::InPlaceParser
  • delAllGestures() : mv::CPlayer
  • delAllVect() : mv::CGesture
  • delay()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::fsPinchGlove
  • Delete() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , CloudsManager , VK_NoStepInto_Namespace::DynamicArray< _Type > , ThinHeap< _NodeClass, _keyType > , GenericHeap< _NodeClass, _keyType > , Cloud
  • deleteActor() : APDYNAMICART::Hoop
  • DeleteAll() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DeleteAnimatedModelGeometry() : ModelManager
  • DeleteAnimation() : ArtificialWorld::SubBlock
  • deleteAttribute() : vrecko::BaseClass
  • deleteConnection() : APObjectUtils::ConnectionViz
  • deleteEventInterconnection() : vrecko::EventDispatcher
  • deleteFromScene() : SnapObject
  • deleteMenuItem() : APMenu::DynamicMenu
  • DeleteModelGeometry() : ModelManager
  • DeleteNode() : DynamicTree< _Type >
  • deleteObjectEffect() : APObjectUtils::ObjectEffectMan
  • DeleteObserver() : DeleteObserver
  • DeletePoint() : APCameraPath::Camera
  • DeletePreloader() : Cache
  • DeleteUnnecessary() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DeleteUpdate() : DeleteObserver , Cache
  • delFromCell() : vrecko::OctTree
  • delFromNode() : vrecko::OctTree
  • delGesture() : mv::CPlayer
  • delta_m() : vrecko::Timer
  • delta_n() : vrecko::Timer
  • delta_s() : vrecko::Timer
  • delta_u() : vrecko::Timer
  • delVectOnEnd() : mv::CGesture
  • demandReport() : vreckoDP_base::LHeadTracker
  • derivedCRI() : MotionTrailTriangulator
  • destroy()
: APMenu::MenuItemText
, APMenu::MenuItemSlider
, LoadingConsole
, APMenu::MenuItem
  • destroyConnectionViz() : APEditorQAbilities::AbilityEditor
  • destroyDistanceFieldGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyDistanceFieldGridCollision() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyDistanceFieldTempGrid() : APSpacePartitioning::VoxelGrid_Object_Data
  • destroyEffect() : APObjectUtils::ObjectEffect
  • destroyGeometry()
: APFFDEditor::GeometryLoaderBase
, APFFDEditor::Grid
, APFFDEditor::GeometryLoader
, APSpacePartitioning::GeometryLoaderBase
  • destroyGraphics() : APMenu::MenuItem
  • destroyGraphicsCore()
: APMenu::MenuItemText
, APMenu::MenuItemSlider
, APMenu::MenuItemNull
, APMenu::MenuItem
  • destroyHierarchy() : APSpacePartitioning::SphereBVH_Object_Data
  • destroyInterface() : vrecko::ControllableAbility
  • DestroyLightTexture() : Cloud
  • destroyMainObjects() : APMenu::DynamicMenu
  • destroyMenu() : vrecko::ControllableAbility
  • destroyMenuStructure() : APMenu::DynamicMenu
  • destroyModel() : APMenu::MenuItemText
  • destroyMutex() : vrecko::vThread
  • destroyPointerTrail() : APMenu::DynamicMenu
  • destroyPointShell() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • destroyPointShells() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • destroyThread() : APSpacePartitioning::SP_Object_Data_Base
  • determinant() : gmMatrix4 , gmMatrix3
  • Device() : vrecko::Device
  • DeviceManager() : vrecko::DeviceManager
  • diagnostic() : vreckoDP_base::LHeadTracker
  • DiameterGenFactory() : APDYNAMICART::DiameterGenFactory
  • dirty() : APDYNAMICART::HoopShape
  • dirtyInterconnectionsForObject() : vrecko::EventDispatcher
  • disableAutorotation() : APDYNAMICART::Ctrl_StringSculptures
  • disableShaders() : APDYNAMICART::Utils
  • disableThreshold() : ode::DynamicScene
  • disableTools() : APDYNAMICART::Ctrl_StringSculptures
  • disableTS() : vreckoDP_base::fsPinchGlove
  • disconnect() : Hci , Arm
  • dispatchEvent() : VirtualFixture::Drag
  • dispatchMessage() : VirtualFixture::Drag
  • display()
: VirtualFixture::ProxiSphere
, VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Sphere
, VirtualFixture::ProxiCylinder
, VirtualFixture::Trace
, VirtualFixture::ProxiBox
, VirtualFixture::NavSphere
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiCone
  • Display() : base::Display
  • display()
: VirtualFixture::Plane
, VirtualFixture::Cylinder
, VirtualFixture::Box
  • displayAllGestures() : VirtualFixture::Drag
  • distance() : APSpacePartitioning::PointShell_Object_Data
  • distance_sqr() : APSpacePartitioning::PointShell_Object_Data
  • DistanceJoint() : PhysXPlugin::DistanceJoint
  • distFromPointToLine() : CarSim::RoadsState
  • distPointToPlane() : CarSim::RoadsState
  • Divide() : grass::Mesh
  • Done() : APEditorQAbilities::ObjectMovement::SnapBox
  • done()
: vrecko::Logger
, vrecko::ViewerBase
  • doPreRender() : behindO::MyCullCallback
  • doStep() : AP_LSystem::MovingTurtle
  • double2float() : gmVector3
  • doubleButtonPress() : vreckoDP_base::KeyboardMouse
  • doubleDerivedCRI() : MotionTrailTriangulator
  • Drag() : VirtualFixture::Drag
  • draw()
: APCameraMovement::CameraPath
, APDYNAMICART::PerlinLines
, APRoomEdit::WallGeometry
  • draw_Effect_PointShellHierarchy_Node() : APObjectUtils::ObjectEffect
  • drawForward()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • drawForwardHalf()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • drawFrame()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • drawImplementation()
: osgQ::QShapeDrawable
, PhysXPlugin::FluidDrawable
, PhysXPlugin::ClothDrawable
, grass::GrassDrawable
  • DrawPoint()
: APCameraPath::Camera
, APLightsEditor::Editor
  • DrawSpline() : APCameraPath::Camera
  • drawStep()
: AP_LSystem::HermitPipe
, AP_LSystem::LoftTurtle
, AP_LSystem::Rectangle
, AP_LSystem::MovingTurtle
  • DrawVecCursor() : APCameraPath::Camera
  • drawVector() : AP_LSystem::AbstractTurtle
  • DynamicArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • DynamicAttribute() : vrecko::DynamicAttribute
  • DynamicMenu() : APMenu::DynamicMenu
  • DynamicScene() : ode::DynamicScene
  • DynamicTree() : DynamicTree< _Type >
  • DynamicTreeIterator() : DynamicTreeIterator< _Type >
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- e -

  • ECPOINTERBUTTONINFO() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • ECPOINTERINFO() : APEditorController::EditorController::ECPOINTERINFO
  • edgeCost() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgeImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgeLength() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • edgesEqualByVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Editor() : APLightsEditor::Editor
  • EditorController() : APEditorController::EditorController
  • EditorLogic() : APFFDEditor::EditorLogic
  • enableAllObjects() : ode::DynamicScene
  • enableGUI()
: APDYNAMICART::DAEnvironment
, APGUI::GUI_Controller
  • enableShadows() : APLightsEditor::Lights
  • enableTS() : vreckoDP_base::fsPinchGlove
  • end() : Hci
  • end_motion() : Arm
  • endIteration() : vrecko::Scene::EOIteratorHelper
  • EnsureDetailedVersionIsReady() : grass::GrassDrawable
  • EnsureGrassBladesArePrepared() : grass::GrassAbilityParameters
  • enter()
: APConnectEditor::EOLineSegmentIntersector
, APObjectUtils::EOLineSegmentIntersector
, EOLineSegmentIntersector
  • Enumeration() : vrecko::Enumeration< tval, tref >
  • EnvironmentObject() : vrecko::EnvironmentObject
  • eof() : AP_LSystem::ParseableString
  • EOIteratorHelper() : vrecko::Scene::EOIteratorHelper
  • EOLineSegmentIntersector()
: APConnectEditor::EOLineSegmentIntersector
, APObjectUtils::EOLineSegmentIntersector
, EOLineSegmentIntersector
  • EOS() : WAVEFRONT::InPlaceParser
  • equalArrays() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • erasePoints() : SnapObject
  • erasePointsAndAllFaces() : SnapObject
  • eraseWhiteSpaces() : AP_LSystem::StringUtils
  • error() : Hci
  • Error() : APNature::TerrainUtility
  • errorLog()
: vrecko::Logger
, vrecko::World
  • errorText() : AP_LSystem::AbstractInterpret
  • Eval() : mv::CMVect
  • Evaluate()
: ht::Function
, ht::SetupFunction
, ht::SimpleSetupFunction
  • evaluateCondition() : AP_LSystem::Rule
  • EventDispatcher() : vrecko::EventDispatcher
  • evoke() : APGUI::ColorPicker
  • executeAddAbility() : APEditorQAbilities::AbilityEditor
  • executeAddConnection() : APEditorQAbilities::AbilityEditor
  • executeDeleteAbility() : APEditorQAbilities::AbilityEditor
  • executeDeleteConnection() : APEditorQAbilities::AbilityEditor
  • exit() : MainObject
  • ExitLoadingFunction() : Preloader
  • expandItem() : APMenu::DynamicMenu
  • Export() : APNature::Terrain2D
  • exportToFile() : APDYNAMICART::BrushStroke
  • ExtractMin() : BinomialHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , GenericHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType >
  • EyeManipulator() : behindO::EyeManipulator
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- f -

  • fastTimeout() : Hci
  • fdtDataGlove() : vreckoDP_base::fdtDataGlove
  • FibonacciHeap() : FibonacciHeap< _NodeClass, _keyType >
  • figureOutFirstJuncTurn() : CarSim::CarControlUnit
  • FileException() : AP_LSystem::FileException
  • fillCollisionLists() : APSpacePartitioning::NoPartitioning_Scene
  • fillDefaultInfo()
: APConnectEditor::PolygonState
, APLightsEditor::Editor
, APRoomEdit::RoomEditor
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, AP_CableEditor::CableEditor
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APCameraMovement::CameraMovementEditor
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AnimatorEditor
, APCameraPath::Camera
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectAdd
, APConnectEditor::ConnectEditor
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::ObjectMovement
, APConnectEditor::Cut
, APEditorQAbilities::SceneSave
, APEditorQAbilities::SimpleObjectMovement
, APConnectEditor::Optimalizer
, APEditorQAbilities::UseTrigger
, APFFDEditor::EditorLogic
  • FilletSpline() : FilletSpline
  • Filter() : VirtualFixture::Filter
  • filter1() : filter1
  • filter2() : filter2
  • Filter_GetPosition() : VirtualFixture::Filter
  • Filter_GetVelocity() : VirtualFixture::Filter
  • Filter_Initialize() : VirtualFixture::Filter
  • Filter_Mesurement() : VirtualFixture::Filter
  • Filter_Prediction() : VirtualFixture::Filter
  • Filter_SetX_hat1() : VirtualFixture::Filter
  • Filter_SetX_hat2() : VirtualFixture::Filter
  • Filter_Update() : VirtualFixture::Filter
  • finalize()
: AP_LSystem::AbstractTurtle
, AP_LSystem::HermitPipe
, AP_LSystem::QueryTurtle
, AP_LSystem::Rectangle
, AP_LSystem::StraightPipe
  • findBoundaryLoops() : SnapObject
  • findChildByName() : vrecko::ReaderWriter
  • findClosestPoint() : SnapObject
  • findClosestSnappingRegionPoints() : SnapObject
  • findCollisionsWithObject() : APSpacePartitioning::NoPartitioning_Scene
  • findDuplicateNode() : vrecko::ReaderWriter
  • findHierarchyMember() : ConstraintHierarchyMember
  • findJuncsSinglePolyPoints() : CarSim::RoadsState
  • findMatchingLeftBracket() : AP_LSystem::LongString
  • findMatchingRightBracket() : AP_LSystem::LongString
  • findNodeByName() : vrecko::ReaderWriter
  • findObject() : vrecko::OctTree
  • findObjectInNode() : vrecko::OctTree
  • findPath() : CarSim::RoadsState
  • findPinInList() : vrecko::BaseClass
  • FindPoint() : APCameraPath::Camera
  • findRealFile() : vrecko::ReaderWriter
  • findShortestPath() : CarSim::RoadsState , SnapObject
  • finishStructureBuild()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • FixedJoint() : PhysXPlugin::FixedJoint
  • fixGeometryDrawableHelper() : vrecko::EnvironmentObject
  • fixGeometryHelper() : vrecko::EnvironmentObject
  • fixGeometryMirroring() : vrecko::EnvironmentObject
  • Flatten()
: APNature::Terrain2D
, APNature::Terrain2DSegment
, APNature::TerrainAlgorithm
  • float2double() : gmVector3
  • floatToTimeString() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Fluid() : PhysXPlugin::Fluid
  • FluidDrawable() : PhysXPlugin::FluidDrawable
  • flush() : vrecko::BufferedFileWrite
  • flushSerial() : Serial
  • for() : GradientColorGen
  • ForceField() : PhysXPlugin::ForceField
  • frame() : vrecko::ViewerBase
  • FreeAllNodes() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType >
  • FreeArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • freeFromConstraintParent() : APConstrainedMovement::ConstraintDescription
  • FreeNodeSimple() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType >
  • freezeFingerSensor() : vreckoDP_base::fdtDataGlove
  • freezeRotation() : vreckoDP_base::fdtDataGlove
  • FrenetFrame() : FrenetFrame
  • fsPinchGlove() : vreckoDP_base::fsPinchGlove
  • full_update() : Arm
  • fullBckg() : Arm
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- g -

  • gcd() : vreckoUtils::Math
  • generate()
: APDYNAMICART::Attractor
, APDYNAMICART::PatternBase
, APDYNAMICART::IShapeGenerator
, APDYNAMICART::Pattern
, APDYNAMICART::NullShapeGenerator
, APDYNAMICART::LinearShapeGenerator
  • generateAllFilletPoints() : FilletSpline
  • GenerateByMidpointDisplacementAlgorithm() : APNature::Terrain2D
  • GenerateByPerlinNoiseAlgorithm() : APNature::Terrain2D
  • GenerateByRandomFaultsAlgorithm() : APNature::Terrain2D
  • generateCars() : CarSim::RoadsState
  • GenerateCloudsTexture() : APNature::PerlinNoiseAlgorithm
  • GenerateLightTexture() : Cloud
  • GenerateNoiseTexture() : APNature::PerlinNoiseAlgorithm
  • generateSuccessor() : AP_LSystem::LSystem
  • GenerateSurfaceByMidpointDisplacement() : APNature::MidpointDisplacementAlgorithm
  • GenerateSurfaceByRandomFaults() : APNature::RandomFaultsAlgorithm
  • generateVertexNeighbourhood() : APSpacePartitioning::SNCH_Object_Data
  • GeometryLoader() : APFFDEditor::GeometryLoader
  • GeometryLoaderBase()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • GeometryState() : GeometryState
  • get() : AP_LSystem::Randomizer , InterpolatorFactory
  • Get() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • get()
: APDYNAMICART::Configuration
, APDYNAMICART::HookManager
, APDYNAMICART::PhysXManager
, AP_LSystem::Configuration
, AP_LSystem::Log
, AP_LSystem::QueryInterpret
, AP_LSystem::Randomizer
  • get_rel_pos() : vreckoDP_base::LHeadTracker
  • getAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • getAbilityInstance() : vrecko::PluginManager
  • getAbilityMap()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • getAbilityWithInput()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • getAbilityWithOutput()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • getAbsPos() : CarSim::RoadsState
  • getAcceptableMessages()
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::WIM
, ChessBoard
, ChessPiece
, navigation::AvatarInHand
, PhysXPlugin::ForceField
  • getActGesture() : mv::CPlayer
  • getActor() : APDYNAMICART::Hoop
  • getActPos() : mv::CPlayer
  • getActT() : mv::CPlayer
  • getActualAvatarView() : vrecko::World
  • getActualValue()
: vreckoDP_base::fdtDataGlove
, APHUD::HUDDisplay
  • getActVect() : mv::CPlayer
  • getActVel() : mv::CPlayer
  • getAdapter() : APDYNAMICART::AdapterFactory< T >
  • getAll() : mv::CPlayer
  • GetAllocated() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • getAllowedOutput() : vrecko::Logger
  • getAlpha() : APObjectUtils::Animator
  • getAndLockNextObject() : vrecko::Scene::EOIteratorHelper
  • getAngle()
: WGeometry::WG_Geometry
, WGeometry::WG_Wall
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getAngleFrom() : osgQ::QSection
  • getAngleTo() : osgQ::QSection
  • GetAnim() : APEditorQAbilities::AnimatorEditor
  • GetAnimatedGeometry() : AnimatedGeometryState
  • GetAnimatedModelGeometry() : ModelManager
  • GetAnimation() : ArtificialWorld::SubBlock
  • GetAnimationIndex() : ArtificialWorld::AnimatedModel
  • GetAnimationPoint() : ArtificialWorld::SubBlockAnimation
  • getAnimationPointsNumber() : APObjectUtils::Animator
  • GetAnimationType() : ArtificialWorld::SubBlockAnimation
  • getAnimatorOnObject() : APObjectUtils::Animator
  • getAnimMatrix() : APObjectUtils::Animator
  • getAreaClass() : APConstrainedMovement::ConstraintArea
  • getAreaClassString() : APConstrainedMovement::ConstraintArea , ConstraintHierarchyMember
  • GetArglist() : WAVEFRONT::InPlaceParser
  • getArguments() : vrecko::World
  • getAttribStringValue() : vrecko::ReaderWriter
  • getAttribute()
: vrecko::BaseClass
, APMenu::DynamicMenu
  • getAttributePtr()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • GetAttributes() : ArtificialWorld::BlockUpdater
  • getAutoRotationActive() : APDYNAMICART::DAEnvironment
  • getAvaiableHoopShapes() : APDYNAMICART::ShapeFactory
  • getAvaiablePatterns() : APDYNAMICART::PatternFactory
  • getAvaiablePolyhedronNames() : APDYNAMICART::PolyhedronFactory
  • getAvailableAttractors() : APDYNAMICART::Attractor
  • getAxes() : APDYNAMICART::PS_Symmetry
  • getAxiom() : AP_LSystem::AbstractFile
  • getBBoxDF() : APSpacePartitioning::VoxelGrid_Object_Data
  • getBBoxDFSize() : APSpacePartitioning::VoxelGrid_Object_Data
  • getBindingAreas() : APConstrainedMovement::ConstraintDescription
  • getBinormal()
: APDYNAMICART::DAGizmo
, APDYNAMICART::BrushStrokeControlPoint
, DAGizmo
, DAControlPoint
  • GetBlockType() : ArtificialWorld::BlockUpdater
  • getBlurSize() : APLightsEditor::Lights
  • getBoolValue() : vrecko::ReaderWriter
  • getBottomCCWVertex() : WGeometry::WG_Vertices
  • getBottomCWVertex() : WGeometry::WG_Vertices
  • getBottomNormal() : WGeometry::WG_Wall
  • getBounceRadius() : APLightsEditor::Lights
  • getBounceSampleCount() : APLightsEditor::Lights
  • GetBound() : grass::Mesh
  • getBoundAreaCount() : APConstrainedMovement::ConstraintDescription
  • getBoundAreaNormal() : APConstrainedMovement::ConstraintDescription
  • getBoundaryLoop() : SnapObject
  • getBoundaryLoopCentroids() : SnapObject
  • getBoundaryLoops() : SnapObject
  • GetBoundingBox() : ArtificialWorld::BlockUpdater
  • getBoundingPoints() : APConstrainedMovement::ConstraintArea
  • getBoundingPointsWorld() : APConstrainedMovement::ConstraintArea
  • GetBoundingSphere() : ArtificialWorld::BlockUpdater
  • getBufSize() : vrecko::BufferedFile
  • getButt() : Arm , vreckoDP_base::MicroScribe3D
  • getByte() : vreckoDP_base::fsPinchGlove
  • getCableAbility() : AP_CableEditor::CableEditor
  • getCableColor() : AP_CableEditor::Cable
  • getCableID() : AP_CableEditor::Cable
  • getCableWrapperNode() : AP_CableEditor::Cable
  • getCachedColorGenerator() : APDYNAMICART::Hoop
  • getCachedFileName() : vrecko::PersistentCache::OpenedCacheFile
  • getCacheDir() : vrecko::PersistentCache
  • getCalibrationString() : vrecko::Device
  • getCamera()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
, vrecko::World
  • getCameraPos() : CloudDataType
  • getCameras() : vrecko::ViewerBase
  • getCameraUp() : CloudDataType
  • getCameraView() : CloudDataType
  • getCaption()
: APMenu::MenuItemText
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • getCarEdgeId() : CarSim::RoadsState
  • getCenter() : osgQ::QSection
  • getChild() : vreckoUtils::MenuBase
  • getChildMenuObject() : APMenu::MenuItem
  • getChildNodesbyName() : APInputConnector::InputConnector
  • getChoosenBoundaryLoop() : SnapObject
  • getClearColor() : APLightsEditor::Lights
  • getClickedString()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • getClosestPoint() : SnapObject
  • getClosestSnappingRegionPoints() : SnapObject
  • getCollisionObject() : vrecko::Scene
  • getCollisionObjects() : vrecko::Scene
  • getCollisions()
: vrecko::Scene
, vrecko::SP_ObjectInterface
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShellVSVoxel_Object
, APSpacePartitioning::SNCH_Object
, APSpacePartitioning::SphereBVH_Object
  • getCollisionsFromTree() : APSpacePartitioning::PointShell_Object_Data
  • getColor()
: APDYNAMICART::ColorGenAdapter
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Hoop
, APDYNAMICART::colorGradient
, WGeometry::WG_Wall
  • getColorEnd() : GradientColorGen
  • getColorGenAdapter() : APDYNAMICART::Brush
  • getColorGenerator() : SweepSurfaceGeode
  • getColorGenFactory() : APDYNAMICART::Brush
  • getColorIndex() : APDYNAMICART::ColorGenAdapter
  • getColors() : SnapObject , SectorColorGen
  • getColorStart() : GradientColorGen
  • getColorValue() : ConstantColorGen
  • getColour() : MTBrush
  • getColouringType() : MTBrush
  • getColoursMap() : MTBrush
  • getComputedStartTime() : APDYNAMICART::BrushStroke
  • getConstants() : Arm
  • getConstrainedChildrenIDs() : APConstrainedMovement::ConstraintDescription
  • getConstrainedDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • getConstraintParentID() : APConstrainedMovement::ConstraintDescription
  • getContexts() : vrecko::ViewerBase
  • getController() : APDYNAMICART::DAEnvironment
  • getControlPoints()
: AP_CableEditor::Cable
, APCameraMovement::CameraPath
  • getControlSpheresRadiusAdjust() : AP_CableEditor::Cable
  • GetCount() : DynamicTree< _Type >
  • getCountOfControlPoints() : APFFDEditor::Grid
  • getCrossingPoint() : WGeometry::WG_Geometry
  • getCrossSectionAdapter() : APDYNAMICART::Brush
  • getCrossSectionAdapterName() : APDYNAMICART::Brush
  • getCrossSectionArray() : SweepSurfaceGeode
  • getCrossSectionGenerator() : APDYNAMICART::HoopGeometry
  • getCrossSectionInterpolationSteps() : APDYNAMICART::Brush , MTBrush
  • getCrossSectionInterpolationType() : MTBrush
  • getCrossSectionSpline() : SweepSurfaceGeode
  • getcrossSectionType() : MTBrush
  • getCrosssPoints() : MTBrush
  • getCurrectShadingMode() : APLightsEditor::Lights
  • getCurrentGIMode() : APLightsEditor::Lights
  • getCurrentShadowLightID() : APLightsEditor::Lights
  • getCurrentShadowMode() : APLightsEditor::Lights
  • GetCurrentWorldPosition() : ArtificialWorld::BlockUpdater
  • getCursor() : APDYNAMICART::DATool
  • getCursorPosition()
: APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
  • getCurvature() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getDaareaScale() : APDYNAMICART::Controller
  • getDAMatrix() : APDYNAMICART::PhysXManager
  • getData()
: APDYNAMICART::ComputeThread
, AP_LSystem::LongString
, vreckoDP_base::fsPinchGlove
  • getDataType() : vrecko::Attribute
  • getDefaultColor() : SectorColorGen
  • getDefaultRequestInterconnectionMap() : vrecko::EventDispatcher
  • getDefaultSize() : APDYNAMICART::IComputeStrategy
  • getDefaultTurtleProperties() : AP_LSystem::LSGeode
  • getDefaultValue() : vrecko::StaticAttribute< type, tval, tref >
  • getDelay() : vrecko::vThread
  • GetDepth() : DynTreeNode< _Type >
  • getDescribtion() : VirtualFixture::Marker
  • getDescription()
: vrecko::Attribute
, vrecko::Scene
, vrecko::World
, APDYNAMICART::Controller
  • getDeviceInstance() : vrecko::DeviceManager
  • getDeviceManagerPtr() : vrecko::World
  • getDeviceMap() : vrecko::DeviceManager
  • getDevicePtr() : vrecko::DeviceManager
  • getDevicePtrByType() : vrecko::DeviceManager
  • getDeviceType() : vrecko::Device
  • getDiameter()
: APDYNAMICART::Brush
, APDYNAMICART::Hoop
, APDYNAMICART::BrushStrokeControlPoint
, MTBrush
  • getDiameterEnd() : GradientDiameterGen
  • getDiameterGenAdapter() : APDYNAMICART::Brush
  • getDiameterGenerator() : SweepSurfaceGeode
  • getDiameters() : MTBrush
  • getDiameterStart() : GradientDiameterGen
  • getDirection() : mv::CPlayer
  • getDirtyBoundaryLoop() : SnapObject
  • getDirtyClosestPoint() : SnapObject
  • getDirtyGraph() : SnapObject
  • getDirtyMaxDistance() : SnapObject
  • getDirtySnappingRegion() : SnapObject
  • getDistanceFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDistanceFieldValueEffect() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDistanceTempFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • getDOMDocument() : ArtificialWorld::BlockUpdater
  • getDone() : vrecko::vThread
  • getDORadius() : APLightsEditor::Lights
  • getDOSampleCount() : APLightsEditor::Lights
  • getDoubleValue() : vrecko::ReaderWriter
  • getDrawSpheres() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • getDualAreas() : APConstrainedMovement::ConstraintDescription
  • getDuration() : APDYNAMICART::BrushStroke
  • getEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getEffect() : APWeather::Weather
  • getEffectType() : APObjectUtils::ObjectEffect
  • getElapsedArtTime() : APDYNAMICART::DAEnvironment
  • getEnable() : vrecko::PersistentCache
  • getEnabledAnimations() : APObjectUtils::Animator
  • getEntityPtr() : vrecko::vThread
  • getEntityVec() : vrecko::vThread
  • getEnvironmentObject() : vrecko::Scene
  • getEo() : SnapObject
  • getEOMap() : vrecko::Scene
  • getEORoot() : vrecko::Scene
  • getEoWrapper() : AP_CableEditor::Cable
  • getEuler() : vreckoDP_base::LHeadTracker
  • getEventDispatcherPtr() : vrecko::World
  • getEventInterconnectionMap() : vrecko::EventDispatcher
  • getEventsVector() : vrecko::EventDispatcher
  • getExtParams() : Hci
  • getFace()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getFaceCount()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getFaceNormal() : WGeometry::WG_Wall
  • getFaces() : SnapObject
  • getFaceStructureSize()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • GetFileName()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getFilePos() : vrecko::BufferedFile
  • getFileSize() : vrecko::BufferedFile
  • getFilletPoints() : FilletSpline
  • getFingerDirection() : vreckoDP_base::fdtDataGlove
  • getFlag() : WGeometry::WG_Wall
  • getFlags() : APMenu::MenuItem
  • getFlares() : APLightsEditor::Lights
  • getFloatValue() : vrecko::ReaderWriter
  • getForce()
: APSpacePartitioning::SNCH_Object
, mv::CPlayer
  • getFrameID() : vrecko::World
  • getFreeID() : vrecko::Scene
  • getFrequency() : vrecko::vThread
  • getFreshDualPartnerIDs() : APConstrainedMovement::ConstraintDescription
  • getFuncPtr() : vrecko::PluginManager
  • getGeode() : SnapObject , AP_LSystem::AbstractTurtle , APRoomEdit::WallGeometry
  • getGeodeOf() : SnapObject
  • getGeometriesCount() : APFFDEditor::GeometryLoader
  • getGeometry() : SnapObject , APFFDEditor::GeometryLoader
  • GetGeometry() : GeometryState
  • getGesture() : vreckoDP_base::fsPinchGlove
  • getGlobalAmbient() : APLightsEditor::Lights
  • getGraph() : SnapObject
  • getGUIItemName() : APGUI::GUI_Item
  • getHandle()
: vrecko::BufferedFile
, vrecko::BufferedFileWrite
, vrecko::MTLock
  • getHeight()
: osgQ::QSection
, WGeometry::WG_Point
, WGeometry::WG_Hole
  • GetHighestValue() : APNature::TerrainAlgorithm
  • getHighlighted() : vreckoUtils::HighlightCallback
  • getHighLighting() : MotionTrailTriangulator
  • getHoles() : WGeometry::WG_Wall
  • getHomomorphisms() : AP_LSystem::AbstractFile
  • getHooks() : APDYNAMICART::HookManager
  • getHoop() : APDYNAMICART::SectorManager
  • getHoopShape() : APDYNAMICART::ShapeFactory
  • getHUDField() : APHUD::HUDDisplay
  • getHUDWindow() : APHUD::HUDDisplay
  • getID()
: vrecko::Ability
, vrecko::Device
, vrecko::EnvironmentObject
  • getId()
: vrecko::SP_ObjectInterface
, vrecko::SP_SceneInterface
, SnapObject
, WGeometry::WG_Point
, WGeometry::WG_Wall
, VirtualFixture::Marker
  • getIncrementValue() : vreckoUtils::HighlightCallback
  • GetIndex() : WAVEFRONT::BuildMesh
  • getIndexBottom() : WGeometry::WG_Point
  • getIndexTop() : WGeometry::WG_Point
  • GetIndices() : WAVEFRONT::BuildMesh
  • getInfoString() : BehindObstacleExp_wT , BehindObstacleExperiment
  • getInnerBoundingBox()
: APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • getInnerRadius() : osgQ::QSection
  • getInputPin() : vrecko::BaseClass
  • getInstance()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::SectorManager
  • getIntepolatedPoints() : AP_CableEditor::Cable
  • getInterpolatedPoint() : AP_CableEditor::Cable
  • getInterpolation() : AP_CableEditor::Cable
  • GetInterpolation() : ArtificialWorld::SubBlockAnimation
  • getInterpolationCount() : APDYNAMICART::PerlinLines
  • getInterpolationSteps() : APDYNAMICART::Brush , InterpolatedSpline , MTBrush
  • getInterpolationType() : APObjectUtils::Animator
  • getInterpolator() : InterpolatedSpline
  • getIntersection() : APRoomEdit::RoomEditor
  • getIntValue() : vrecko::ReaderWriter
  • getItembyName() : APGUI::GUI_Controller
  • getIteration() : AP_LSystem::AbstractLSystem
  • getIterationCount() : APDYNAMICART::OrdinaryAttractor
  • getJustMoving() : APConstrainedMovement::ConstraintDescription
  • getLabel() : VirtualFixture::Marker
  • getLastPointerPos() : APMenu::DynamicMenu
  • getLastTick() : vrecko::vThread
  • getLayoutString() : APGUI::GUI_Controller
  • getLButton() : vreckoDP_base::L3DMouse
  • getLeadingSpline()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::HoopShape
, APDYNAMICART::Stroke
, SweepSurfaceGeode
  • getLeadSplineArray() : SweepSurfaceGeode
  • getLeftHandOrientation()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getLeftHandPosition()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getLength() : APDYNAMICART::PerlinLines
  • getLevelMax() : APObjectUtils::ObjectEffect
  • getLevelMin() : APObjectUtils::ObjectEffect
  • getLight()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
, APLightsEditor::Lights
  • getLightSource() : APLightsEditor::Lights
  • getLMDStore() : APSpacePartitioning::SNCH_Object
  • getLoadedArtTime() : APDYNAMICART::DAEnvironment
  • GetLock() : Preloader
  • getLongIntValue() : vrecko::ReaderWriter
  • getLoop() : mv::CPlayer
  • getLoopType() : APObjectUtils::Animator
  • GetLoopType() : ArtificialWorld::SubBlockAnimation
  • getLowerBound() : vrecko::Interval< tval, tref >
  • GetLowestValue() : APNature::TerrainAlgorithm
  • getLSystemCount() : AP_LSystem::Configuration
  • getLSystemIndex() : AP_LSystem::Configuration
  • getLvlVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getMainObject() : APMenu::DynamicMenu
  • getMappedAbilityID() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • getMappedAbilityInfo() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • GetMatrix() : ht::Screen
  • getMatrix()
: base::MTMatrixTransform
, AP_LSystem::AbstractTurtle
  • GetMatrixInv() : ht::Screen
  • getMatrixValue() : vrecko::ReaderWriter
  • getMaxDistance() : SnapObject , APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • getMaxDistanceVector() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • getMaxes() : Hci
  • getMaxForce() : APSpacePartitioning::SNCH_Object
  • getMaximumDistance() : APSpacePartitioning::PointShell_Object_Data
  • getMaximumDistanceVector() : APSpacePartitioning::PointShell_Object_Data
  • getMaxInstancesCount() : vrecko::DynamicAttribute
  • getMaxLvl() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getMaxPos() : vrecko::BufferedFile
  • getMaxSpeed() : MTBrush
  • GetMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getMButton() : vreckoDP_base::L3DMouse
  • getMenuType() : APMenu::DynamicMenu
  • GetMesh() : grass::TriangleCollector
  • getMessage() : behindO::WIM
  • getMessageId()
: base::SystemInfo::MessageSIThreadCreated
, vrecko::VreckoMessage
, vrecko::MessageVoid
, CarSim::MessageRoadAndDir
, CarSim::MessageCarEdge
, CarSim::MessageCarEdgeData
, CarSim::MessageEdgeOffset
, CarSim::MessageVectorUnsignedInt
, CarSim::MessageStartStopDestination
, CarSim::MessageFirst3Juncs
, CarSim::MessageCarSimParameters
, CarSim::MessageCarEnvirons
, CarSim::MessageCarStatePtr
, APEditorController::AbilityMapper::MessageMapping
, vrecko::MessageCAButtonEvent
, vrecko::ControllableAbility::MessageCAINFO
, ode::DynamicScene::MessageODERequest
, PhysXPlugin::MessageNxActorWithName
  • GetMin() : GenericHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • getMinimalSampleDistance() : SampledSpline
  • getMinInstancesCount() : vrecko::DynamicAttribute
  • getMinSpeed() : MTBrush
  • GetMinVisibleDistance() : ArtificialWorld::Model
  • getModelFile() : APMenu::MenuItemText
  • getModelFileName() : vrecko::EnvironmentObject
  • GetModelFlags() : ArtificialWorld::Model
  • GetModelGeometry() : ModelManager
  • GetModels() : ArtificialWorld::BlockUpdater
  • GetModelType() : ArtificialWorld::Model
  • getModuleCounter() : AP_LSystem::Log
  • getMovable() : mv::CGesture
  • getMutex() : vrecko::vThread
  • getName()
: vreckoUtils::MenuSlider
, vrecko::Ability
, vrecko::Attribute
, vrecko::EnvironmentObject
, APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, APDYNAMICART::Pattern
, APDYNAMICART::PatternBase
, APGUI::ItemsGroup
, APGUI::Layout
, APMenu::MenuItem
, APRoomEdit::Tool
, vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
  • getNCoeficient() : APSpacePartitioning::SNCH_Object
  • getNearestIndex() : APDYNAMICART::ToolSelector
  • GetNeighbourEast() : APNature::Terrain2DSegment
  • GetNeighbourNorth() : APNature::Terrain2DSegment
  • GetNeighbourSouthh() : APNature::Terrain2DSegment
  • GetNeighbourWest() : APNature::Terrain2DSegment
  • getNextCarDistAndVel() : CarSim::RoadsState
  • getNextPoint() : APDYNAMICART::IComputeStrategy
  • getNextToolType()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
  • GetNode() : DynamicTreeIterator< _Type >
  • getNodeCountByName() : vrecko::ReaderWriter
  • getNodeIdentification() : vrecko::ReaderWriter
  • getNodeMask() : APObjectUtils::Animator
  • getNodeWithIDFromTree() : APSpacePartitioning::PointShell_Object_Data
  • GetNoise() : APNature::PerlinNoiseAlgorithm
  • getNormal()
: APDYNAMICART::DAGizmo
, APDYNAMICART::BrushStrokeControlPoint
, DAGizmo
, DAControlPoint
  • getNormalByIndex()
: APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoaderBase
  • getNormalCCWVertex() : WGeometry::WG_Vertices
  • getNormalCWVertex() : WGeometry::WG_Vertices
  • getNormals() : SnapObject
  • getNormalVector() : APConstrainedMovement::ConstraintArea
  • getNormalVectorWorld() : APConstrainedMovement::ConstraintArea
  • getNumberOfArguments() : vrecko::World
  • getNumberofFaces() : APDYNAMICART::PS_Symmetry
  • getNumSectors() : SectorColorGen , APDYNAMICART::SectorManager
  • getObject()
: APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::RectangularSplineAdapter
  • GetObjectCenterDir() : ArtificialWorld::BlockAttributes
  • GetObjectCenterPoint() : ArtificialWorld::BlockAttributes
  • getObjectExtent() : vrecko::Scene
  • getObjectNeighbourhood() : vrecko::OctTree
  • getObjectSelectionActiveRight() : APDYNAMICART::DAEnvironment
  • GetObjectsToPreload() : PreloaderHeuristic
  • getObjectsTransformations() : APSpacePartitioning::SNCH_Object
  • getObjectTransformation() : APSpacePartitioning::PointShellVSVoxel_Object
  • getObjectUpdatesCounter() : vrecko::Scheduler
  • GetObserver() : GetObserver
  • getOfferAreas() : APConstrainedMovement::ConstraintDescription
  • getOkAndChangeEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getOnce() : mv::CMVect
  • getOpacity() : APDYNAMICART::PS_Layer
  • getorCreateGroup() : APGUI::GUI_Controller
  • getOrientation() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getOrientationSamples()
: APDYNAMICART::Hoop
, APDYNAMICART::Stroke
, APDYNAMICART::BrushStroke
  • getOriginPosition()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
  • getOSGAdapter() : vrecko::EnvironmentObject
  • getOSGInitCounts()
: APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getOuterAngleAddition() : osgQ::QSection
  • getOuterRadius() : osgQ::QSection
  • getOutputDest() : vrecko::Logger
  • getOutputPin() : vrecko::BaseClass
  • getOwner()
: vrecko::Ability
, APMenu::DynamicMenu
  • getPacket() : vreckoDP_base::fsPinchGlove
  • getPaintingDuration() : APDYNAMICART::Ctrl_FreeHandPainting
  • getParameters()
: APDYNAMICART::Attractor
, APDYNAMICART::IParameters
, AP_LSystem::LongString
  • getParameterVector()
: base::ShowFDH
, vrecko::Ability
, base::Rotate
  • getParams() : Hci
  • getParentEO() : vrecko::EnvironmentObject
  • getParentHoop() : APDYNAMICART::HookObject
  • getPartitioningObjectInterface() : vrecko::Scene
  • getPartitioningSceneInterface() : vrecko::Scene
  • getPartOfObject() : SnapObject
  • getPattern()
: APDYNAMICART::PatternFactory
, APDYNAMICART::SectorManager
  • getPatternsPointsArray() : APDYNAMICART::PatternsGeode
  • getPause() : mv::CPlayer
  • getPersistentCache() : vrecko::World
  • getPhysicsResult() : APDYNAMICART::PhysXManager
  • getPinName() : vrecko::IOPinBase
  • getPlane() : RegularPolygonSpline
  • getPlaneDistanceFrom() : APConstrainedMovement::ConstraintArea
  • getPlay() : mv::CPlayer
  • getPlaybackTimeText() : APDYNAMICART::Ctrl_FreeHandPainting
  • getPluginName() : vrecko::Ability
  • getPlusColors() : WGeometry::WG_Point
  • getPlusNormals() : WGeometry::WG_Point
  • getPlusVertices() : WGeometry::WG_Point
  • getPoAs() : APDYNAMICART::Controller
  • getPoAsName() : APDYNAMICART::Controller
  • getpobName() : APDYNAMICART::PoB
  • GetPoint() : APNature::Terrain2D
  • getPoint()
: WGeometry::WG_Wall
, APRoomEdit::WallGeometry
  • GetPoint() : APNature::Terrain2DSegment
  • getPointedItemRecursive() : APMenu::DynamicMenu
  • getPointerSliderPos01() : APMenu::MenuItemSlider
  • GetPointHeight()
: APNature::TerrainAlgorithm
, APNature::Terrain2D
  • getPointRef() : WGeometry::WG_Wall
  • getPoints() : SampledSpline
  • getPointShellRootSize() : APSpacePartitioning::PointShell_Object_Data
  • getPointShellSize() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • getPolygons()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
  • getPolygonsCount()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getPolyhedron() : APDYNAMICART::PolyhedronFactory
  • getPortName() : vrecko::Device
  • getPosition()
: vrecko::EnvironmentObject
, WGeometry::WG_Hole
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
, VirtualFixture::Marker
  • GetPosition()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • getPosition() : WGeometry::WG_Point
  • getPositionSamples()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Stroke
, APDYNAMICART::Hoop
  • getPositionString() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getPrimitiveSet() : SnapObject
  • getPriority()
: vrecko::BaseClass
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • getProcessedEventsCounter() : vrecko::EventDispatcher
  • getProjPointerPos() : APMenu::DynamicMenu
  • getProperties()
: AP_LSystem::AbstractTurtle
, APObjectUtils::CopyProperties
  • getProperty() : AP_LSystem::Configuration
  • getQuatValue() : vrecko::ReaderWriter
  • getQueryCounter() : AP_LSystem::Log
  • getQVertices() : WGeometry::WG_Hole
  • getRadius() : AP_CableEditor::Cable , RegularPolygonSpline
  • GetRandomFloatGaussian() : APNature::TerrainRandom
  • GetRandomFloatGaussianBasedOnPointDistance() : APNature::TerrainRandom
  • GetRandomFloatUniform() : APNature::TerrainRandom
  • getRandomIndex() : AP_LSystem::RandomIndex
  • GetRandomPoint() : grass::Triangle
  • GetRandPosition() : PseudoRand2DPlacement
  • getRangePtr() : vrecko::StaticAttribute< type, tval, tref >
  • getRayIntersection() : vrecko::Scene
  • getRButton() : vreckoDP_base::L3DMouse
  • getRealStartTime() : APDYNAMICART::BrushStroke
  • getRecData()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::L3DMouse
  • getReceiverPtr() : vrecko::EventDispatcher::ICSBase
  • getReceiverPtrCore() : vrecko::EventDispatcher::ICSBase
  • getRequestedCellSize() : APSpacePartitioning::VoxelGrid_Object_Data
  • getRequestInputPin() : vrecko::BaseClass
  • getRequestInterconnectionMap() : vrecko::EventDispatcher
  • getRequestOutputPin() : vrecko::BaseClass
  • getRestrictorString() : APConstrainedMovement::ConstraintArea
  • getRewritingCounter() : AP_LSystem::Log
  • getRFGenerator() : SweepSurfaceGeode
  • getRightHandOrientation()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getRightHandPosition()
: APDYNAMICART::DAEnvironment
, APDYNAMICART::PoA
  • getRoot()
: vrecko::Scene
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • GetRoot() : DynamicTree< _Type >
  • GetRootObjectID() : ArtificialWorld::WorldBuilder
  • getRootPtr() : APSpacePartitioning::SphereBVH_Object_Data
  • getRoots() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getRopeActors() : APDYNAMICART::PhysXManager
  • getRopeRadius() : APDYNAMICART::ToolHook
  • getRotate()
: vreckoDP_base::fdtDataGlove
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
  • getRotateA()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • getRotateM()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::Ultratrak
, vreckoDP_base::NestOfBirds
  • getRotateQ()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::LHeadTracker
, vreckoDP_base::Ultratrak
  • getRotation()
: APObjectUtils::Animator
, vrecko::EnvironmentObject
, osgQ::QSection
  • GetRotation()
: ArtificialWorld::SubBlock
, ArtificialWorld::Model
  • getRotationFrameAdapter() : APDYNAMICART::Brush
  • getRotationFrameAdapterName() : APDYNAMICART::Brush
  • getRotationShift() : RegularPolygonSpline
  • getRules() : AP_LSystem::AbstractFile
  • getRun() : vrecko::vThread
  • getRVertices() : WGeometry::WG_Hole
  • getSame() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSameEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSameEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getSamples() : MTCreatorTool
  • getSawErrors() : APMenu::MenuLoaderErrorHandler , BCLoaderErrorHandler , vrecko::RWErrorHandler
  • getSButton() : vreckoDP_base::L3DMouse
  • GetScale() : ArtificialWorld::Model
  • getScale()
: APObjectUtils::Animator
, vrecko::EnvironmentObject
  • getSceneFile() : vrecko::BaseClass
  • getScenePtr() : vrecko::World
  • getSchedulerPtr() : vrecko::World
  • getSecondsPerTick() : vrecko::Timer
  • getSector() : SectorColorGen , APDYNAMICART::SectorManager
  • getSectorInfoList() : APDYNAMICART::SectorManager
  • getSectorMarker() : APDYNAMICART::Hoop
  • getSectorNumber() : APDYNAMICART::ToolSelector
  • getSectorRange() : Sector
  • getSegmentCount() : RegularPolygonSpline
  • getSegmentLength() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getSelectedObject() : APObjectUtils::ObjectModif
  • getSelectedPoA()
: APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolRotation
  • getSenderString()
: vrecko::BaseClass
, vrecko::Ability
  • getSensorScale() : vreckoDP_base::OptiTrack
  • getShadowedSceneLight() : vrecko::World
  • getShadowedScenePtr() : vrecko::World
  • getShadowTechnique() : APLightsEditor::Lights
  • getShape()
: APDYNAMICART::Hoop
, AP_CableEditor::Cable
  • getShapeCurveGenerator() : APDYNAMICART::HoopGeometry
  • getShapeGenerator() : APDYNAMICART::ShapeFactory
  • getShapeRotate() : AP_CableEditor::Cable
  • getShowControlPointsString() : APDYNAMICART::Ctrl_FreeHandPainting
  • getShowTimeWarnings() : vrecko::World
  • getSignal() : vreckoDP_base::fdtDataGlove
  • getSignObject() : APMenu::DynamicMenu
  • getSimpleGraph() : SnapObject
  • getSimualtionParameters() : APDYNAMICART::PhysXManager
  • getSize() : APDYNAMICART::DATool
  • getSkeleton() : vreckoDP_Kinect::Kinect
  • getSliderPos01() : APMenu::MenuItemSlider
  • getSliderPosXY() : APMenu::MenuItemSlider
  • getSmoothness() : APDYNAMICART::Brush
  • getSnappingRegion() : SnapObject
  • getSnappingRegionValues() : SnapObject
  • getSnapPointArray() : APDYNAMICART::Hoop
  • getSnapRegion() : SnapObject
  • getSnapRegionWithDistanceSet() : SnapObject
  • getSNCHFace() : APSpacePartitioning::SNCH_Object_Data
  • getSNCHVertex() : APSpacePartitioning::SNCH_Object_Data
  • getSpeed() : APDYNAMICART::PerlinLines , DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • getSPoint() : mv::CGesture
  • getStartTick() : vrecko::Timer
  • getState() : vrecko::Scheduler
  • getStatusResult() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getStepCounter() : vrecko::vThread
  • getStereoMode()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • getSTNodeStructureSize()
: APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::SNCH_Object_Data
  • getStringLineWidth() : APDYNAMICART::PatternsGeode
  • getStrings() : Hci
  • getStringValue() : vrecko::ReaderWriter
  • getStringValueXCh() : vrecko::ReaderWriter
  • getStylusDir() : Arm
  • getStylusTip() : Arm
  • GetSubBlocks() : ArtificialWorld::BlockUpdater
  • GetSubBlocksUpdaters() : ArtificialWorld::BlockUpdater
  • GetSubBlockType() : ArtificialWorld::SubBlock
  • getSubsystems() : AP_LSystem::AbstractFile
  • getSunDate() : APLightsEditor::Lights
  • getSupportedAdapters() : APDYNAMICART::AdapterFactory< T >
  • getSupportedInterpolators() : InterpolatorFactory
  • getSweepSurface() : APDYNAMICART::Hoop
  • getSymbol() : AP_LSystem::LongString
  • getT() : Arm
  • getTangent() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • getTarget() : APDYNAMICART::PoB
  • getTerminationFlag() : vrecko::World
  • GetTerrainGroup() : APNature::Terrain2D
  • GetTerrainSegmentGeode() : APNature::Terrain2DSegment
  • GetTexCoords() : WAVEFRONT::BuildMesh
  • getText() : APGUI::Slider
  • getTextBoundingBox() : APMenu::MenuItemText
  • getThirdVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getTimeFromLastUpdate() : CarSim::CarControlUnit
  • getTimePerLoop() : APObjectUtils::Animator
  • GetTimePerLoop() : ArtificialWorld::SubBlockAnimation
  • getTimerPtr() : vrecko::vThread
  • getTimeStamps()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Hoop
, APDYNAMICART::Stroke
  • getTimeWarningsTime() : vrecko::World
  • getTopCCWVertex() : WGeometry::WG_Vertices
  • getTopCWVertex() : WGeometry::WG_Vertices
  • getTopNormal() : WGeometry::WG_Wall
  • getTorsion() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getTranslate()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
, vreckoDP_base::LHeadTracker
  • getTranslatedFileName() : vrecko::PersistentCache::OpenedCacheFile
  • getTranslateMapping()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
  • getTranslation() : APObjectUtils::Animator
  • getTransparency() : vrecko::EnvironmentObject
  • getTriangulationAngle() : APDYNAMICART::BrushStrokeControlPoint
  • getTurnOnJunc() : CarSim::RoadsState
  • getTurtleCounter() : AP_LSystem::Log
  • getTurtleType() : AP_LSystem::LSGeode
  • getTvalue() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • getType()
: APDYNAMICART::DATool
, DAControlPoint
, APDYNAMICART::BrushStrokeControlPoint
, APDYNAMICART::Controller
, APRoomEdit::Tool
, APDYNAMICART::Controller
, WGeometry::WG_Hole
  • GetUpdate() : Cache
  • getUpdate() : AP_CableEditor::Cable
  • GetUpdate() : GetObserver
  • getUpdateFlag() : APDYNAMICART::PoA
  • getUpperBound() : vrecko::Interval< tval, tref >
  • getUserData() : vrecko::EnvironmentObject
  • getUserDataMap() : vrecko::EnvironmentObject
  • getV0() : mv::CMVect
  • getV1() : mv::CMVect
  • GetValue() : ht::VariableFloat
  • getValue() : vreckoUtils::MenuSlider
  • GetValue()
: ht::VariableVec2
, ht::VariableVec3
, ht::VariableQuat
  • getValue() : APGUI::Slider
  • GetValueInFunction()
: ht::VariableFloat
, ht::VariableVec2
, ht::VariableVec3
, ht::VariableQuat
  • GetVariablesCount()
: ht::VariableFloat
, ht::VariableVec2
, ht::VariableQuat
, ht::Variable
, ht::VariableVec3
  • getVec2Value() : vrecko::ReaderWriter
  • getVec3Value() : vrecko::ReaderWriter
  • getVec4Value() : vrecko::ReaderWriter
  • getVect() : mv::CMVect
  • getVector() : WGeometry::WG_Wall
  • getVertex()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • getVertexArray() : SampledSpline , BufferedSpline , APDYNAMICART::PatternBase
  • getVertexCount()
: APSpacePartitioning::GeometryLoaderBase
, APFFDEditor::GeometryLoaderBase
  • getVertexStructureSize()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::GeometryLoaderBase
  • getVertices()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_Geometry
, WGeometry::WG_Wall
, SnapObject
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • GetVertices() : WAVEFRONT::BuildMesh
  • getVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • getViewer()
: vrecko::CompositeViewer
, vrecko::Viewer
, vrecko::ViewerBase
  • getViewerPtr() : vrecko::World
  • getVisibleModels() : ArtificialWorld::BlockUpdater
  • getVisualOwner() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • getVolume() : APDYNAMICART::Limits
  • getWall() : APRoomEdit::WallGeometry
  • getWallNeighbours() : WGeometry::WG_Point
  • getWalls() : WGeometry::WG_Point
  • getWasTested() : APConstrainedMovement::ConstraintDescription
  • getWidth() : WGeometry::WG_Hole
  • getWindows() : vrecko::ViewerBase
  • getWord()
: AP_LSystem::AbstractGenerator
, AP_LSystem::LSystemGenerator
  • getWorldPosition() : vrecko::EnvironmentObject
  • getWorldRotation() : vrecko::EnvironmentObject
  • getWorldTransformation()
: vrecko::EnvironmentObject
, base::MTMatrixTransform
  • getWTime() : mv::CGesture
  • getXDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getXMLParameters()
: VirtualFixture::Marker
, PhysXPlugin::PrismaticJoint
, VirtualFixture::Log
, PhysXPlugin::BaseJoint
, VirtualFixture::MarkerFactory
, PhysXPlugin::CylindricalJoint
, PhysXPlugin::FixedJoint
, VirtualFixture::ProxiBorder
, PHEffect
, PhysXPlugin::PointOnLineJoint
, PhysXPlugin::Plane
, PhysXPlugin::Sphere
, PhysXPlugin::PulleyJoint
, VirtualFixture::Filter
, VirtualFixture::VibrationLabel
, VirtualFixture::Sphere
, VirtualFixture::VibrationLabelActivator
, VirtualFixture::ProxiCylinder
, PHANToMAvatar
, VirtualFixture::ProxiCone
, VirtualFixture::Avatar
, VirtualFixture::AxisLock
, VirtualFixture::NavSphere
, VirtualFixture::Cone
, VirtualFixture::Grid
, VirtualFixture::Cylinder
, VirtualFixture::ProxiBox
, PhysXPlugin::SphericalJoint
, PhysXPlugin::PointInPlaneJoint
, PhysXPlugin::DistanceJoint
, PhysXPlugin::RemoteDebugger
, VirtualFixture::Box
, VirtualFixture::Plane
, VirtualFixture::Damper
, VirtualFixture::Vibration
, VirtualFixture::Border
, PhysXPlugin::Capsule
, VirtualFixture::ProxiSphere
, PhysXPlugin::RevoluteJoint
, VirtualFixture::Drag
, VirtualFixture::Trace
, PhysXPlugin::Box
, PhysXPlugin::BaseActor
  • getY() : WGeometry::WG_Hole
  • getYDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getZDFDim() : APSpacePartitioning::VoxelGrid_Object_Data
  • getZeroLevelSize() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • globalSearch() : APSpacePartitioning::SNCH_Object
  • gmMatrix3() : gmMatrix3
  • gmMatrix4() : gmMatrix4
  • gmVector2() : gmVector2
  • gmVector3() : gmVector3
  • gmVector4() : gmVector4
  • goHomePos() : Hci
  • GradientColorAdapter() : APDYNAMICART::GradientColorAdapter
  • GradientColorGen() : GradientColorGen
  • GradientDiamAdapter() : APDYNAMICART::GradientDiamAdapter
  • GradientDiameterGen() : GradientDiameterGen
  • Grass() : grass::Grass
  • GrassAbilityParameters() : grass::GrassAbilityParameters
  • GrassDrawable() : grass::GrassDrawable
  • GreatestCommonDivisor() : APNature::TerrainUtility
  • Grid()
: VirtualFixture::Grid
, APFFDEditor::Grid
  • GUI_Controller() : APGUI::GUI_Controller
  • GUI_Item() : APGUI::GUI_Item
  • GUI_Item::createLabel() : APGUI::GUI_Item
  • GUI_Text() : APGUI::GUI_Text
  • GUIItemClicked()
: APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::Attractor
  • guiItemClicked()
: APDYNAMICART::Controller
, APDYNAMICART::ToolSelector
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolRotation
  • GUIItemClicked() : APDYNAMICART::PoA
  • guiItemClicked() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • GUIItemClicked() : APDYNAMICART::BrushStroke
  • guiItemClicked()
: APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_Attractor
  • GUIItemClicked() : APDYNAMICART::PolyhedraSculpture
  • guiItemClicked()
: APDYNAMICART::Brush
, APDYNAMICART::Ctrl_PerlinLines
  • GUIItemClicked()
: APDYNAMICART::HookObject
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::Hoop
  • GuiItemClicked() : APNature::TerrainAbility
  • GUIItemClicked() : APDYNAMICART::PerlinLines
  • guiSliderChanged() : APDYNAMICART::Controller
  • GUISliderChanged()
: APDYNAMICART::JuliaAttractor
, APDYNAMICART::PoA
  • guiSliderChanged() : APDYNAMICART::Ctrl_PerlinLines
  • GUISliderChanged()
: APDYNAMICART::PerlinLines
, APDYNAMICART::BrushStroke
  • guiSliderChanged()
: APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_PolyhedraSculptures
  • GUISliderChanged() : APDYNAMICART::HookObject
  • guiSliderChanged()
: APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_StringSculptures
  • GUISliderChanged()
: APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::Hoop
  • guiSliderChanged() : APDYNAMICART::Ctrl_FreeHandPainting
  • GUISliderChanged()
: APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::Attractor
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- h -

  • hand() : base::hand
  • HandFrameAdapter() : APDYNAMICART::HandFrameAdapter
  • handle() : vreckoDP_base::KeyboardMouse
  • handle_analog() : vreckoDP_base::VRPN3DMouse
  • handle_button() : vreckoDP_base::VRPN3DMouse
  • handle_ctrl_status() : vreckoDP_base::Wiimote
  • handle_disconnect() : vreckoDP_base::Wiimote
  • handle_event() : vreckoDP_base::Wiimote
  • handle_read() : vreckoDP_base::Wiimote
  • handleEdges()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • handleError()
: vrecko::RWErrorHandler
, APMenu::MenuLoaderErrorHandler
, BCLoaderErrorHandler
  • HasAnimation() : ArtificialWorld::SubBlock
  • hasAnyAttributes() : vrecko::AttributesDescription
  • HasMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • HasMinVisibleDistance() : ArtificialWorld::Model
  • hasNextAttribute()
: vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • hasNextValue() : vrecko::Enumeration< tval, tref >
  • HasPositionSet() : ArtificialWorld::Model
  • hasRange() : vrecko::StaticAttribute< type, tval, tref >
  • have2Polygons2OrMoreVetrticesSame() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • headingX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • headingY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • headingZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • HeadManipulator() : behindO::HeadManipulator
  • HeadTracking() : ht::HeadTracking
  • Height() : APNature::Terrain2DSegment
  • herFerDeriv() : CarSim::RoadsState
  • hermiteBasis() : gmMatrix4
  • HermitPipe() : AP_LSystem::HermitPipe
  • hide()
: APMenu::MenuItem
, vrecko::EnvironmentObject
, APEditorQAbilities::ObjectMovement::SnapBox
, APGUI::GUI_Item
, APGUI::GUI_Text
, APGUI::Layout
, APDYNAMICART::DAGizmo
, DAGizmo
  • Hide() : ArtificialWorld::BlockUpdater
  • hideAxis() : APDYNAMICART::Hoop
  • hideChildMenu() : APMenu::DynamicMenu
  • hideGraphics()
: APMenu::MenuItem
, APMenu::MenuItemNull
  • hideMainMenuObject() : APMenu::DynamicMenu
  • hideMenu()
: APMenu::DynamicMenu
, vrecko::ControllableAbility
  • hidePointerTrail() : APMenu::DynamicMenu
  • HideSubBlocks() : ArtificialWorld::BlockUpdater
  • hideTooltip() : APGUI::GUI_Item
  • HighlightCallback() : vreckoUtils::HighlightCallback
  • highlightColour() : MotionTrailTriangulator
  • HMDHeadManipulator() : behindO::HMDHeadManipulator
  • HoleRemove() : APRoomEdit::HoleRemove
  • homePos() : Arm
  • HookManager() : APDYNAMICART::HookManager
  • HookObject() : APDYNAMICART::HookObject
  • Hoop() : APDYNAMICART::Hoop
  • HoopGeometry() : APDYNAMICART::HoopGeometry
  • HoopShape() : APDYNAMICART::HoopShape
  • HoopTrackerCallback() : APDYNAMICART::HoopTrackerCallback
  • HSLtoPos() : APGUI::ColorPicker
  • HSLtoRGB() : APGUI::ColorPicker
  • HSVtoRGB() : APObjectUtils::ObjectEffect
  • HUDDisplay() : APHUD::HUDDisplay
  • hudFieldExist() : APHUD::HUDDisplay
  • hudWindowExist() : APHUD::HUDDisplay
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- i -

  • Icon() : APGUI::Icon , Icon
  • IconColour() : APGUI::IconColour
  • ICSBase() : vrecko::EventDispatcher::ICSBase
  • identity() : gmMatrix3 , gmMatrix4
  • identity4x4() : Arm
  • idle() : vreckoDP_base::KeyboardMouse
  • importControlPoints() : APDYNAMICART::BrushStroke
  • ImportFromHeightMap() : APNature::Terrain2D
  • importScene() : APDYNAMICART::Ctrl_FreeHandPainting
  • includesValue() : vrecko::Interval< tval, tref >
  • incModuleCounter() : AP_LSystem::Log
  • incQueryCounter() : AP_LSystem::Log
  • incrementActNode() : vrecko::ReaderWriter
  • incrementFrameID() : vrecko::World
  • incRewritingCounter() : AP_LSystem::Log
  • incTurtleCounter() : AP_LSystem::Log
  • indexByName() : PhysXPlugin::MaterialManager
  • Info() : APNature::TerrainUtility
  • inheritProperties() : AP_LSystem::AbstractTurtle
  • init()
: CarSim::CarControlUnit
, APConnectEditor::ConnectEditor
, APDYNAMICART::Attractor
, APDYNAMICART::ComputeThread
, APDYNAMICART::HookManager
, APDYNAMICART::Rectangle
, APDYNAMICART::Ellipse
, APDYNAMICART::Line
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PhysXManager
, APDYNAMICART::RectangularSplineAdapter
  • Init() : AP_CableEditor::CableEditor
  • init()
: APDYNAMICART::WaveSplineAdapter
, AP_LSystem::RandomIndex
  • Init() : APCameraPath::Camera
  • init()
: AP_LSystem::Randomizer
, APRoomEdit::ColorBucket
  • Init() : APEditorQAbilities::ObjectMovement::SnapBox
  • init()
: APRoomEdit::CreateHole
, APRoomEdit::HoleRemove
  • Init() : grass::GrassAbilityParameters
  • init()
: APRoomEdit::PointAdd
, APRoomEdit::PointMove
  • Init() : WAVEFRONT::InPlaceParser
  • init()
: APRoomEdit::RoomLoader
, APRoomEdit::RoomSaver
, vrecko::BufferedFile
, APRoomEdit::Tool
, APRoomEdit::WallAdd
, vrecko::BufferedFile
, APRoomEdit::WallRemove
, Arm
, vrecko::BufferedFileWrite
, Hci
, vrecko::Logger
, Cache
  • InitAnimation() : APCameraPath::Camera
  • InitCloudGeometry() : Cloud
  • initColorsOnTLs() : CarSim::TLsOnJuncManager
  • initDirection() : CarSim::CarExecutionUnit
  • initialize()
: base::ShowFDH
, base::ShowFDHModel
, vrecko::BaseClass
, vrecko::EnvironmentObject
, Cache
, ArtificialWorld::WorldBuilder
, AP_CableEditor::CableEditor
, APCameraPath::Camera
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::PS_Polyhedron
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolEraser
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, vrecko::ControllableAbility
, APEditorController::EditorController
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::ObjectMovement
, AP_LSystem::AbstractTurtle
, AP_LSystem::HermitPipe
, AP_LSystem::JointedPipe
, AP_LSystem::QueryTurtle
, AP_LSystem::Rectangle
, AP_LSystem::StraightPipe
, APGUI::ColorPicker
, APGUI::GUI_Controller
, APGUI::GUI_Item
, APGUI::Icon
, APGUI::IconColour
, APGUI::Layout
, APGUI::Menu
, APGUI::Slider
, ht::HeadTracking
, ht::ScreenSetup
, ht::ScreenSetupSimple
, APHelloWorld::MyAbility
, APInputConnector::InputConnector
, APLightsEditor::Editor
, APNature::TerrainAbility
, APWeather::Weather
, navigation::AvatarInHand
, ode::DynamicScene
, APRoomEdit::RoomEditor
, APShootingSimulation::ShootingSimulation
, vreckoDP_base::Wiimote
, base::Display
  • initializeFromString() : vrecko::BaseClass
  • InitializeGeode() : APNature::Terrain2DSegment
  • InitializeGI() : APLightsEditor::Lights
  • InitializeMenu() : APNature::TerrainAbility
  • InitItems() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • initIteration() : vrecko::Scene::EOIteratorHelper
  • initIterationFrom() : vrecko::Scene::EOIteratorHelper
  • initMenu()
: APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • initNormal() : CarSim::CarExecutionUnit
  • initPort() : vreckoDP_base::fsPinchGlove
  • initPositionAndDirection() : CarSim::CarControlUnit
  • initScene() : BehindObstacleExp_wT , BehindObstacleExperiment
  • initStandardSignSet() : APMenu::DynamicMenu
  • initThread() : base::SystemInfo
  • initTools() : APDYNAMICART::Controller
  • InPlaceParser() : WAVEFRONT::InPlaceParser
  • InputConnector() : APInputConnector::InputConnector
  • InputPin() : vrecko::InputPin< _MessageType >
  • inputPresent() : vrecko::BaseClass
  • Insert() : VK_NoStepInto_Namespace::DynamicArray< _Type > , GenericHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • insertEventInterconnection() : vrecko::EventDispatcher
  • insertMenuItem() : APMenu::DynamicMenu
  • InsertNode() : DynamicTree< _Type >
  • insertPointsInLODTree() : APSpacePartitioning::PointShell_Object_Data
  • insideStep()
: AP_LSystem::LoftTurtle
, AP_LSystem::StraightPipe
  • installSimple() : Arm
  • instance() : vrecko::Timer
  • Interconnection() : APGUI::Interconnection
  • internalDecrementReaderWriter() : vrecko::PersistentCache
  • internalFindAndLock() : vrecko::PersistentCache
  • internalOpenReadWrite() : vrecko::PersistentCache
  • interPointOfLineAndPerpendicularPlane() : CarSim::RoadsState
  • interpolate() : MotionTrailTriangulator , AP_CableEditor::Cable , APDYNAMICART::PerlinLines , Interpolator
  • interpolateCatIterate() : AP_CableEditor::Cable
  • interpolateCatPerSegment() : AP_CableEditor::Cable
  • interpolateCrossSection() : MotionTrailTriangulator
  • InterpolatedSpline() : InterpolatedSpline
  • interpolatePoint() : APDYNAMICART::PerlinLines , CatmullRomInterpolator , APDYNAMICART::Utils
  • interpolatePoints() : APDYNAMICART::ComputeThread
  • interpolateVec3()
: APDYNAMICART::PerlinLines
, APDYNAMICART::Utils
, MotionTrailTriangulator
  • intersect2Planes() : APEditorQAbilities::ObjectMovement
  • intersectLinePlane() : APEditorQAbilities::ObjectMovement
  • Interval() : vrecko::Interval< tval, tref >
  • intToStr() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • invalidate() : APMenu::MenuItem
  • invalidateFields() : Hci
  • inverse() : gmMatrix3 , gmMatrix4
  • isActive()
: APDYNAMICART::DATool
, vrecko::ControllableAbility
  • isAnimating() : APObjectUtils::Animator
  • IsAverageOf() : grass::Vertex
  • isCable() : AP_CableEditor::CableEditor
  • isCapable()
: AP_LSystem::D0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParD0LSystem
, AP_LSystem::ParStoch0LSystem
  • isCarRegForEdge() : CarSim::RoadsState
  • isCarStopPositionRight() : CarSim::RoadsState
  • isClosed() : BufferedSpline , RegularPolygonSpline , SampledSpline
  • isCollisionFree() : vrecko::EnvironmentObject
  • isConstraintParentOf() : APConstrainedMovement::ConstraintDescription
  • isDeadlock() : CarSim::RoadsState
  • isDefaultStateActive() : APGUI::GUI_Item
  • isDirty()
: APDYNAMICART::HoopShape
, APRoomEdit::Tool
  • isDynamic() : vrecko::Attribute
  • isEffectCreated() : APObjectUtils::ObjectEffect
  • IsEmpty() : FibonacciHeap< _NodeClass, _keyType >
  • isEmpty() : APDYNAMICART::Controller
  • IsEmpty() : ThinHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType > , GenericHeap< _NodeClass, _keyType >
  • isEntityPresent() : vrecko::Scheduler
  • isEnumeration() : vrecko::Range
  • isEOF() : vrecko::BufferedFile
  • isEqualTo()
: vrecko::VreckoMessage
, vrecko::MessageVoid
, base::SystemInfo::MessageSIThreadCreated
  • isExpanded() : APMenu::MenuItem
  • IsFinished() : DynamicTreeIterator< _Type >
  • isFreeSpaceForCarGroupOnEdge() : CarSim::RoadsState
  • isGraphicsCreated() : APMenu::MenuItem
  • isHierarchyAncestorOf() : ConstraintHierarchyMember
  • isHierarchyCreated()
: APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::SNCH_Object_Data
, vrecko::SP_Object_DataInterface
, APSpacePartitioning::VoxelGrid_Object_Data
  • isInMainThread() : vrecko::EventDispatcher
  • isIntersection() : APSpacePartitioning::NoPartitioning_Scene
  • isInterval() : vrecko::Range
  • isKeyDown() : vreckoDP_base::KeyboardMouse
  • isLoaded() : vrecko::Scene
  • isLowerInclusive() : vrecko::Interval< tval, tref >
  • isMainButtonPressed() : APMenu::DynamicMenu
  • isMenuCreated() : vrecko::ControllableAbility
  • isMenuVisible() : vrecko::ControllableAbility
  • IsNeighbourEast() : APNature::Terrain2DSegment
  • IsNeighbourNorth() : APNature::Terrain2DSegment
  • IsNeighbourSouth() : APNature::Terrain2DSegment
  • IsNeighbourWest() : APNature::Terrain2DSegment
  • IsNodeAllowed() : DynamicTreeIterator< _Type >
  • isObjectInCell() : vrecko::OctTree
  • isObjectInNode() : vrecko::OctTree
  • isOpened() : vrecko::BenchmarkWriter
  • isPlaneCompatibleWithSelectedSet() : APEditorQAbilities::ObjectMovement
  • isPointed() : APMenu::MenuItem
  • isRunning() : APDYNAMICART::PhysXManager
  • isSame() : vrecko::CollisionParams__ver1
  • isSameKindAs()
: PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
, grass::GrassDrawable
, osgQ::QSection
  • isSampled() : APDYNAMICART::BrushStrokeControlPoint
  • isSelectionLocked() : APMenu::DynamicMenu
  • isShadowsEnabled() : APLightsEditor::Lights
  • isSingular() : gmMatrix4 , gmMatrix3
  • isStatic() : vrecko::Attribute
  • IsSubTreeAllowed() : DynamicTreeIterator< _Type >
  • issueRequests()
: APConnectEditor::Cut
, APRoomEdit::RoomEditor
, APConnectEditor::Rotation
, APConstrainedMovement::ConstrainedObjectMovement
, APConnectEditor::Scale
, APCameraPath::Camera
, APCameraMovement::CameraMovementEditor
, APEditorQAbilities::SimpleObjectMovement
  • isSuitable() : SnapObject
  • isThisControlPoint() : APFFDEditor::EditorLogic
  • isTooSmall() : APDYNAMICART::ComputeThread
  • isUpdated() : vrecko::Ability
  • isUpperInclusive() : vrecko::Interval< tval, tref >
  • IsValid() : ht::Screen
  • isValidJuncWithTLs() : CarSim::RoadsState
  • isValidName() : APDYNAMICART::PolyhedronFactory
  • isValueInsideRange() : APDYNAMICART::Utils
  • isVisible() : APMenu::MenuItem
  • IsVisible() : ArtificialWorld::BlockUpdater
  • isVisible() : APMenu::DynamicMenu , DAGizmo , vrecko::EnvironmentObject , APDYNAMICART::DAGizmo
  • isZero() : gmVector3
  • itemClicked()
: APDYNAMICART::HoopShape
, APMenu::DynamicMenu
, APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::Painted
  • ItemsGroup() : APGUI::ItemsGroup
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- j -

  • joint_update3() : Arm
  • joint_update6() : Arm
  • jointBckg3() : Arm
  • jointBckg6() : Arm
  • JointedPipe() : AP_LSystem::JointedPipe
  • JuliaAttractor() : APDYNAMICART::JuliaAttractor
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- k -

  • KeepOnScreen() : APObjectUtils::KeepOnScreen
  • KeyboardMouse() : vreckoDP_base::KeyboardMouse
  • keyPress() : vreckoDP_base::KeyboardMouse
  • keyRelease() : vreckoDP_base::KeyboardMouse
  • keyToString() : vreckoDP_base::KeyboardMouse
  • Kinect() : vreckoDP_Kinect::Kinect
  • KinectThread() : vreckoDP_Kinect::Kinect
  • KMTracker() : navigation::KMTracker
  • KMTracker::sendSensorInfo() : navigation::KMTracker
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- l -

  • L3DMouse() : vreckoDP_base::L3DMouse
  • Last() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • Layout() : APGUI::Layout
  • lcm() : vreckoUtils::Math
  • leftX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • leftY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • leftZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • legalToRemoveEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • length() : gmVector3 , gmVector4
  • Length() : mv::CMVect
  • length() : AP_LSystem::LongString , gmVector2
  • lengthSquared() : gmVector2 , gmVector3 , gmVector4
  • Lens() : behindO::Lens
  • LHeadTracker() : vreckoDP_base::LHeadTracker
  • lhtRead() : vreckoDP_base::LHeadTracker
  • libaryName()
: PhysXPlugin::ClothDrawable
, PhysXPlugin::FluidDrawable
  • libraryName()
: osgQ::QSection
, grass::GrassDrawable
  • liesWithinArea() : APConstrainedMovement::ConstraintArea
  • Light() : base::Light
  • LightCloud() : Cloud
  • Lights() : APLightsEditor::Lights
  • limit_speed() : boids::BoidsLogic
  • limitPosition() : APGUI::ColorPicker
  • Line() : LoadingConsole::Line
  • Linear() : Filter::Linear
  • LinearMapping() : APNature::TerrainUtility
  • linesInter2D() : CarSim::RoadsState
  • linesIntersection() : APGUI::ColorPicker
  • Link() : BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType >
  • listDirectory() : APDYNAMICART::DAEnvironment
  • ListDirectory() : APNature::TerrainUtility
  • LMDStore() : APSpacePartitioning::SNCH_Object::LMDStore
  • load()
: APDYNAMICART::NullHoopShape
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PerlinLines
, APDYNAMICART::PoA
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::PS_Symmetry
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::SectorManager
, APDYNAMICART::PoAAdapter< T >
, Icon
, APDYNAMICART::PoB
  • Load() : mv::Reader
  • load()
: APDYNAMICART::Attractor
, APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ConstantDiamAdapter
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::HookObject
, APDYNAMICART::HookManager
, APDYNAMICART::Hoop
, APDYNAMICART::HoopShape
  • loadAbilities() : vrecko::ReaderWriter
  • LoadAndInitiate() : CloudsManager
  • LoadAnimation() : APCameraPath::Camera
  • loadAttributes() : APMenu::DynamicMenu
  • loadCables() : AP_CableEditor::CableEditor
  • loadCfgFile() : AP_LSystem::Configuration
  • loadCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • loadCollisionsFromFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • loadDataFromFile() : APSpacePartitioning::PointShell_SimpleNode
  • loadDataFromPC_LoadTreeNode() : APSpacePartitioning::SphereBVH_Object_Data
  • loadDataFromPersistentCache_Init()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • loadDataFromPersistentCache_ReadData() : APSpacePartitioning::SphereBVH_Object_Data
  • loadDevice() : vrecko::ReaderWriter
  • loadEnvironmentObject() : vrecko::ReaderWriter
  • loadEvent() : vrecko::ReaderWriter
  • loadFacesFromFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • loadFile()
: AP_LSystem::AbstractGenerator
, AP_LSystem::LSystemGenerator
  • loadFromCache()
: APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • loadFromFile()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • LoadFromFile() : CloudsManager
  • loadfromXML() : APDYNAMICART::PS_Polyhedron
  • loadfromXMLnode() : APGUI::Layout
  • loadGeometry()
: vrecko::EnvironmentObject
, APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • loadGeometryHelper()
: APFFDEditor::GeometryLoader
, APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • loadGeometryParts() : CarSim::CarExecutionUnit
  • loadGridFromFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • LoadingConsole() : LoadingConsole
  • LoadingFunctionFinnished() : Preloader
  • loadJuncPolyRoad() : CarSim::RoadsState
  • loadJunction() : CarSim::RoadsState
  • loadMenuItems() : APMenu::DynamicMenu
  • loadMenuStructureFromNode() : APMenu::DynamicMenu
  • LoadMesh() : WAVEFRONT::OBJ
  • loadModel() : vrecko::PersistentCache
  • loadMultipleFiles() : vrecko::ReaderWriter
  • loadNodeFromFileRec() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • loadObj() : WavefrontObj
  • loadObjectFullMatrix() : APConstrainedMovement::ConstrainedObjectMovement
  • loadObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • loadOld() : vrecko::ReaderWriter
  • loadParametersFromNode()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • loadPolygonPoint() : CarSim::RoadsState
  • loadRoad() : CarSim::RoadsState
  • loadScene() : vrecko::ReaderWriter
  • loadShapes() : AP_CableEditor::CableEditor
  • loadSignsFromXML() : APMenu::DynamicMenu
  • loadSubDivisionMeshFromFile() : APSpacePartitioning::PointShell_Object_Data
  • loadTLparameters() : CarSim::RoadsState
  • loadTreeFromFile() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • loadTreeNodeFromFile()
: APSpacePartitioning::SNCH_Object_Data
, APSpacePartitioning::SphereBVH_Object_Data
  • loadVerticesFromFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • loadVirtualEnvironment() : vrecko::ReaderWriter
  • loadWordFromFile() : AP_LSystem::AbstractGenerator
  • loadXMLDocument() : vrecko::ReaderWriter
  • loadXMLFile() : APConstrainedMovement::ConstraintDescription , ConstraintHierarchyMember
  • loadXMLMaterial() : PhysXPlugin::MaterialManager
  • loadXMLParameters()
: behindO::HMDHeadManipulator
, boids::Boid
, CarSim::CarExecutionUnit
, APRoomEdit::WallMovement
, ArtificialWorld::WorldBuilder
, Cache
, ArtificialWorld::BlockUpdater
, vrecko::World
, vrecko::BaseClass
, VirtualFixture::MarkerFactory
, VirtualFixture::Box
, VirtualFixture::VibrationLabelActivator
, base::Rotate
, base::Light
, PhysXPlugin::Capsule
, VirtualFixture::Drag
, PhysXPlugin::Sphere
, APDYNAMICART::DAEnvironment
, VirtualFixture::Marker
, VirtualFixture::NavSphere
, APConnectEditor::Rotation
, VirtualFixture::Log
, VirtualFixture::ProxiSphere
, APFFDEditor::GeometryLoaderBase
, CarSim::RoadsState
, VirtualFixture::Filter
, VirtualFixture::ProxiCone
, APDYNAMICART::Ctrl_FreeHandPainting
, VirtualFixture::Trace
, APDYNAMICART::Ctrl_MotionVisualization
, APConnectEditor::ConnectEditor
, VirtualFixture::Grid
, APConnectEditor::Cut
, boids::BoidsLogic
, boids::BoidsPlanner
, VirtualFixture::Cone
, APLightsEditor::Lights
, PhysXPlugin::FixedJoint
, PhysXPlugin::DistanceJoint
, PhysXPlugin::PulleyJoint
, VirtualFixture::Sphere
, VirtualFixture::VibrationLabel
, VirtualFixture::Cylinder
, base::Avatar
, VirtualFixture::Damper
, PhysXPlugin::PhysXScene
, vrecko::MaterialDesc
, VirtualFixture::Avatar
, PhysXPlugin::CoreActorDesc
, base::ShowFDH
, vreckoDP_base::OptiTrack
, base::SystemInfo
, ode::CompositeObject
, PhysXPlugin::PrismaticJoint
, PhysXPlugin::PointOnLineJoint
, vrecko::BaseClass
, VirtualFixture::AxisLock
, APRoomEdit::RoomLoader
, APRoomEdit::CreateHole
, VirtualFixture::Vibration
, APRoomEdit::Tool
, APObjectUtils::ObjectSelector
, PhysXPlugin::RevoluteJoint
, APObjectUtils::ObjectEffect
, APObjectUtils::ConnectionViz
, navigation::KMTracker
, grass::GrassAbilityParameters
, grass::Grass
, APTextOutput::Console
, VirtualFixture::Plane
, PHEffect
, Filter::Linear
, APFFDEditor::EditorLogic
, APDYNAMICART::Ctrl_PerlinLines
, VirtualFixture::ProxiBorder
, ConstraintHierarchyMember
, PhysXPlugin::BaseActor
, VirtualFixture::ProxiCylinder
, CarSim::CarControlUnit
, APCameraPath::Camera
, PhysXPlugin::SphericalJoint
, behindO::WIM
, behindO::HeadManipulator
, BehindObstacleExperiment
, VirtualFixture::Border
, APRoomEdit::WallRemove
, vreckoDP_base::VRPN3DMouse
, VirtualFixture::ProxiBox
, BehindObstacleExp_wT
, PhysXPlugin::Box
, PhysXPlugin::BaseJoint
, APCameraMovement::CameraPath
, Icon
, APSpacePartitioning::GeometryLoaderBase
, PHANToMAvatar
, APConstrainedMovement::ConstraintDescription
, vreckoDP_base::NestOfBirds
, APSpacePartitioning::PointShell_Object_Data
, vreckoDP_base::L3DMouse
, APSpacePartitioning::VoxelGrid_Object_Data
, APHUD::HUDDisplay
, APMenu::DynamicMenu
, PhysXPlugin::Plane
, PhysXPlugin::Fluid
, APObjectUtils::Animator
, PhysXPlugin::BasePhysXObject
, vreckoDP_Kinect::Kinect
, vreckoDP_base::LHeadTracker
, ode::CappedCylinder
, APRoomEdit::WallGeometry
, APRoomEdit::ColorBucket
, ode::Sphere
, APRoomEdit::RoomSaver
, APObjectUtils::KeepOnScreen
, PhysXPlugin::Cloth
, APClouds::Clouds
, Filter::PosNoiseRemover
, APObjectUtils::ObjectEffectMan
, APRoomEdit::PointMove
, PhysXPlugin::RemoteDebugger
, APRoomEdit::WallAdd
, APObjectUtils::ObjectModif
, PhysXPlugin::PointInPlaneJoint
, ode::Cube
, ChessBoard
, navigation::AvatarInHand
, PhysXPlugin::ForceField
, APObjectUtils::CopyProperties
, ChessPiece
, PhysXPlugin::CylindricalJoint
, AP_LSystem::LSObject
  • LoadXMLParametersFromFile() : ArtificialWorld::BlockUpdater
  • localForm() : StrX
  • localSearch() : APSpacePartitioning::SNCH_Object
  • lock() : vrecko::MTLock
  • lockEOMapForRead() : vrecko::Scene
  • lockEOMapForWrite() : vrecko::Scene
  • lockHigh() : vrecko::MTTwoPrioLimitedLock
  • lockJuncsEdgesForNewCar() : CarSim::RoadsState
  • lockLow() : vrecko::MTTwoPrioLimitedLock
  • lockRead()
: vrecko::MTReadWriteLock
, vrecko::MTReadWriteLockEx
  • lockWrite()
: vrecko::MTReadWriteLockEx
, vrecko::MTReadWriteLock
  • LoftTurtle() : AP_LSystem::LoftTurtle
  • Log() : VirtualFixture::Log
  • Logger() : vrecko::Logger
  • logger_streambuf() : vrecko::logger_streambuf
  • logHierarchy() : vrecko::Scene
  • logHierarchyDrawableHelper() : vrecko::Scene
  • logHierarchyHelper() : vrecko::Scene
  • LongString() : AP_LSystem::LongString
  • LowerCase() : APNature::TerrainUtility
  • LSFile() : AP_LSystem::LSFile
  • LSGeode() : AP_LSystem::LSGeode
  • LSObject() : AP_LSystem::LSObject
  • LSystem() : AP_LSystem::LSystem
  • LSystemException() : AP_LSystem::LSystemException
  • LSystemGenerator() : AP_LSystem::LSystemGenerator
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- m -

  • MagicWandTool() : MagicWandTool
  • mainButtonPressed() : APMenu::DynamicMenu
  • mainButtonReleased() : APMenu::DynamicMenu
  • MainObject() : MainObject
  • MainSceneUpdateCallback() : MainSceneUpdateCallback
  • makeInstances() : APDYNAMICART::PS_Symmetry
  • makeMenu()
: APCameraPath::Camera
, APLightsEditor::Editor
, AP_CableEditor::CableEditor
  • makeMovementMenu() : APCameraPath::Camera
  • makeRotate() : AP_LSystem::MovingTurtle
  • makeRotations() : APDYNAMICART::PS_Symmetry
  • ManageCulling() : grass::GrassDrawable
  • Manipulator() : behindO::Manipulator
  • MappingFunctions() : behindO::MappingFunctions
  • Marker() : VirtualFixture::Marker
  • MarkerFactory() : VirtualFixture::MarkerFactory
  • matchLeft() : AP_LSystem::LongString
  • matchRight() : AP_LSystem::LongString
  • MatIndex() : vrecko::MaterialDesc
  • MemoryReadBuffer() : MemoryReadBuffer
  • MemoryWriteBuffer() : MemoryWriteBuffer
  • Menu()
: APGUI::Menu
, vreckoUtils::Menu
  • menuBoxes_CalcItemDisplayIndex() : APMenu::MenuItem
  • menuGrid_getSize() : APMenu::DynamicMenu
  • MenuItem()
: APMenu::MenuItem
, vreckoUtils::MenuItem
  • menuItemClicked()
: AP_CableEditor::CableEditor
, APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Cut
, APConnectEditor::PolygonState
, APEditorController::AbilityMapper
, vrecko::ControllableAbility
, APEditorQAbilities::AbilityEditor
, APEditorQAbilities::AnimatorEditor
, APEditorQAbilities::ObjectAdd
, APEditorQAbilities::ObjectDelete
, APEditorQAbilities::SceneSave
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
  • MenuItemNull() : APMenu::MenuItemNull
  • MenuItemSlider() : APMenu::MenuItemSlider
  • MenuItemText() : APMenu::MenuItemText
  • MenuLoaderErrorHandler() : APMenu::MenuLoaderErrorHandler
  • menuRadial_CalcItemAngle() : APMenu::MenuItem
  • MenuRoot() : vreckoUtils::MenuRoot
  • MenuSlider() : vreckoUtils::MenuSlider
  • menuSliderChanged()
: AP_CableEditor::CableEditor
, APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
, vrecko::ControllableAbility
, APFFDEditor::EditorLogic
, APLightsEditor::Editor
  • MenuSliderChanged() : APNature::TerrainAbility
  • MenuVisitor() : vreckoUtils::MenuVisitor
  • Merge() : BinomialHeap< _NodeClass, _keyType >
  • mergeCloseJunctions() : CarSim::RoadsState
  • mergeFiles() : vrecko::ReaderWriter
  • mergeLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • mergeObject() : SnapObject
  • Mesh() : grass::Mesh
  • MessageCarEdge() : CarSim::MessageCarEdge
  • MessageCarEdgeData() : CarSim::MessageCarEdgeData
  • MessageCarEnvirons() : CarSim::MessageCarEnvirons
  • MessageCarSimParameters() : CarSim::MessageCarSimParameters
  • MessageCarStatePtr() : CarSim::MessageCarStatePtr
  • MessageEdgeOffset() : CarSim::MessageEdgeOffset
  • MessageFirst3Juncs() : CarSim::MessageFirst3Juncs
  • MessageNxActorWithName() : PhysXPlugin::MessageNxActorWithName
  • MessageRoadAndDir() : CarSim::MessageRoadAndDir
  • MessageSensorTransformation() : vrecko::MessageSensorTransformation
  • MessageSIThreadCreated() : base::SystemInfo::MessageSIThreadCreated
  • MessageStartStopDestination() : CarSim::MessageStartStopDestination
  • MessageVectorUnsignedInt() : CarSim::MessageVectorUnsignedInt
  • MessageVoid() : vrecko::MessageVoid
  • META_DAObject() : APDYNAMICART::WaveSplineAdapter , APDYNAMICART::ConstantDiamAdapter , APDYNAMICART::ConstantColorAdapter , APDYNAMICART::GradientColorAdapter , APDYNAMICART::GradientDiamAdapter , APDYNAMICART::RMFrameAdapter , APDYNAMICART::AxisFrameAdapter , APDYNAMICART::HandFrameAdapter , SectorColorGen , APDYNAMICART::RoundedSplineAdapter , APDYNAMICART::RectangularSplineAdapter , BufferedSpline , CatmullRomInterpolator , ConstantColorGen , GradientDiameterGen , LinearInterpolator , RegularPolygonSpline , SampledSpline , GradientColorGen
  • META_DAObjectDecorator() : InterpolatedSpline , TimeLineSpline , FilletSpline , SmoothedSpline
  • META_HoopShapeObject()
: APDYNAMICART::Line
, APDYNAMICART::Painted
, APDYNAMICART::RegularPolygon
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::Ellipse
, APDYNAMICART::Rectangle
  • META_Node() : SweepSurfaceGeode , APDYNAMICART::PatternsGeode
  • META_Object() : AllCloudsUpdateCallBack
  • MicroScribe3D() : vreckoDP_base::MicroScribe3D
  • MidpointDisplacementAlgorithm() : APNature::MidpointDisplacementAlgorithm
  • Mirror() : behindO::Mirror
  • mixed_mult() : gmMatrix4
  • Model() : ArtificialWorld::Model
  • MotionTrail() : APDYNAMICART::MotionTrail
  • MotionTrailTriangulator() : MotionTrailTriangulator
  • MouseHand() : base::MouseHand
  • mouseMotion() : vreckoDP_base::KeyboardMouse
  • mouseScroll() : vreckoDP_base::KeyboardMouse
  • moveForward()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • moveForwardHalf()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • moveTarget() : APShootingSimulation::ShootingSimulation
  • MTAutoLock() : vrecko::MTAutoLock
  • MTBrush() : MTBrush
  • MTCreatorTool() : MTCreatorTool
  • MTLock() : vrecko::MTLock
  • MTMatrixTransform() : base::MTMatrixTransform
  • MTReadWriteLock() : vrecko::MTReadWriteLock
  • MTReadWriteLockEx() : vrecko::MTReadWriteLockEx
  • MTTwoPrioLimitedLock() : vrecko::MTTwoPrioLimitedLock
  • mul4x4() : Arm
  • multiplyAngle()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • multiplyGravitropismElasticity()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • multiplyLength()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • multiplyRadius()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • multiplyTropismElasticity()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • MyAbility() : APHelloWorld::MyAbility
  • mycomparisonMaxMin() : APSpacePartitioning::mycomparisonMaxMin
  • mycomparisonMinMax() : APSpacePartitioning::mycomparisonMinMax
  • MyCullCallback() : behindO::MyCullCallback
  • MyUpdateCallback() : behindO::MyUpdateCallback
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- n -

  • Name() : vrecko::MaterialDesc
  • name() : AP_LSystem::AbstractFile
  • NavSphere() : VirtualFixture::NavSphere
  • NestOfBirds() : vreckoDP_base::NestOfBirds
  • next() : AP_LSystem::ParseableString
  • nextAttributePtr()
: vrecko::DynamicAttribute
, vrecko::AttributesDescription
  • nextIteration()
: AP_LSystem::AbstractGenerator
, AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
, AP_LSystem::LSystemGenerator
  • nextValue() : vrecko::Enumeration< tval, tref >
  • NodeTriangle()
: WAVEFRONT::GeometryInterface
, WAVEFRONT::BuildMesh
  • Noise1D() : PseudoRand2DPlacement
  • NoPartitioning_Scene() : APSpacePartitioning::NoPartitioning_Scene
  • normalize() : gmVector2 , gmVector3 , gmVector4
  • noticeLog()
: vrecko::World
, vrecko::Logger
  • notify()
: vreckoUtils::Observer
, APDYNAMICART::Ctrl_StringSculptures
  • notifyObservers() : vreckoUtils::Observable
  • NullAttractor() : APDYNAMICART::NullAttractor
  • NumberOfAnimantionPoints() : ArtificialWorld::SubBlockAnimation
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- o -

  • ObjectAdd() : APEditorQAbilities::ObjectAdd
  • objectChanged() : vrecko::OctTree
  • ObjectDelete() : APEditorQAbilities::ObjectDelete
  • ObjectEffect() : APObjectUtils::ObjectEffect
  • ObjectEffectMan() : APObjectUtils::ObjectEffectMan
  • ObjectInfo() : APObjectUtils::ObjectInfo
  • ObjectModif() : APObjectUtils::ObjectModif
  • ObjectMovement() : APEditorQAbilities::ObjectMovement
  • ObjectSelector() : APObjectUtils::ObjectSelector
  • objectTransformationFromPointer()
: APCameraPath::Camera
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • Observable() : vreckoUtils::Observable
  • Observer() : vreckoUtils::Observer
  • OctTree() : vrecko::OctTree
  • old_getTriLMD() : APSpacePartitioning::SNCH_Object
  • OneTri() : APSpacePartitioning::SNCH_Object::OneTri
  • onMessageExit() : MainObject
  • onMessageProjection() : MainObject
  • open()
: AP_LSystem::AbstractFile
, AP_LSystem::LSFile
, AP_LSystem::XmlFile
  • openBenchmarkFile() : vrecko::Logger
  • openCacheFileForReading() : vrecko::PersistentCache
  • openCacheFileForWriting() : vrecko::PersistentCache
  • openDevice()
: vreckoDP_base::fsPinchGlove
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Wiimote
, vreckoDP_Kinect::Kinect
, vrecko::Device
, vreckoDP_base::fdtDataGlove
  • OpenedCacheFile() : vrecko::PersistentCache::OpenedCacheFile
  • openFile() : vrecko::BenchmarkWriter
  • openPort() : vreckoDP_base::LHeadTracker
  • openSerial() : Serial
  • openSocket()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • operator!=() : CacheInfo , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator()()
: APSpacePartitioning::mycomparisonMaxMin
, vreckoUtils::HighlightCallback
, MainSceneUpdateCallback
, vrecko::EventDispatcher::StringWithHashComparator
, vrecko::Scheduler::classcomp
, behindO::MyUpdateCallback
, behindO::MyCullCallback
, APDYNAMICART::HoopTrackerCallback
, UniformUpdateCallback
, Cloud::ParticleAwayComparison
, grass::TriangleCollector
, APSpacePartitioning::mycomparisonMinMax
  • operator*() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator*=() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator+() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator++() : DynamicTreeIterator< _Type >
  • operator+=() : gmMatrix4 , gmMatrix3 , gmVector2 , gmVector3 , gmVector4
  • operator-() : gmVector4 , gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator-=() : gmVector2 , gmMatrix3 , gmMatrix4 , gmVector3 , gmVector4
  • operator/() : gmMatrix3 , gmMatrix4 , gmVector2 , gmVector3 , gmVector4
  • operator/=() : gmVector4 , gmVector2 , gmMatrix4 , gmVector3 , gmMatrix3
  • operator=()
: AP_LSystem::AbstractLSystem
, AP_LSystem::AbstractGenerator
, AP_LSystem::StaticString
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableQuat
, gmMatrix4
, gmVector3
, AP_LSystem::ParStoch0LSystem
, gmVector2
, gmVector4
, PhysXPlugin::ClothDrawable
, ht::VariableFloat
, PhysXPlugin::FluidDrawable
, AP_LSystem::Rule
, AP_LSystem::ParseableString
, AP_LSystem::LongString
, gmMatrix3
, APEditorController::AbilityMapper::MAPPING
, AP_LSystem::LSystem
  • operator==() : DynamicTreeIterator< _Type > , CacheInfo , gmVector2 , gmMatrix3 , gmVector4 , gmVector3 , gmMatrix4
  • operator[]() : AP_LSystem::LongString , gmMatrix3 , gmVector4 , gmVector2 , gmVector3 , gmMatrix3 , gmMatrix4 , gmVector3 , VK_NoStepInto_Namespace::DynamicArray< _Type >
  • optimalizeAndSave() : APConnectEditor::Optimalizer
  • optimalizeCuttingLoop() : APConnectEditor::Cut
  • optimalizeGeometry() : APConnectEditor::Optimalizer
  • optimalizeLoop() : SnapObject
  • optimalizeObject() : APConnectEditor::Optimalizer
  • Optimalizer() : APConnectEditor::Optimalizer
  • OptiTrack() : vreckoDP_base::OptiTrack
  • orderJunctionsEdges() : CarSim::RoadsState
  • OrdinaryAttractor() : APDYNAMICART::OrdinaryAttractor
  • Orient2Vec() : APCameraPath::Camera
  • OutputPin() : vrecko::OutputPin< _MessageType >
  • outputPresent() : vrecko::BaseClass
  • OutstandingLine() : LoadingConsole::OutstandingLine
  • overflow() : vrecko::logger_streambuf
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- p -

  • Par2LSystem() : AP_LSystem::Par2LSystem
  • Parameter()
: APDYNAMICART::Parameter
, AP_LSystem::Parameter
  • paramsDH0_5() : Arm
  • ParD0LSystem() : AP_LSystem::ParD0LSystem
  • Parse() : WAVEFRONT::InPlaceParser
  • parse()
: AP_LSystem::AbstractInterpret
, AP_LSystem::TurtleInterpret
  • ParseableString() : AP_LSystem::ParseableString
  • parseCfgPacket() : Hci
  • parseEventName() : APInputConnector::InputConnector
  • parseInputDevice() : APInputConnector::InputConnector
  • parseInputMappingPair() : APInputConnector::InputConnector
  • ParseLine()
: WAVEFRONT::InPlaceParserInterface
, WAVEFRONT::OBJ
  • parseOutputMappingPair() : APInputConnector::InputConnector
  • parsePacket() : Hci
  • parseReceiverAbility() : APInputConnector::InputConnector
  • parseSenderReceiver() : APInputConnector::InputConnector
  • parseSensorNumber() : APInputConnector::InputConnector
  • parseSR() : vrecko::EventDispatcher
  • ParsingException() : AP_LSystem::ParsingException
  • ParStoch0LSystem() : AP_LSystem::ParStoch0LSystem
  • passiveMouseMotion() : vreckoDP_base::KeyboardMouse
  • PatternBase() : APDYNAMICART::PatternBase
  • PatternsGeode() : APDYNAMICART::PatternsGeode
  • pause() : APDYNAMICART::PerlinLines , Timing
  • PCloth() : PhysXPlugin::ClothDrawable
  • peekSymbol() : AP_LSystem::LongString
  • performCompleteTest()
: vrecko::SP_SceneInterface
, APSpacePartitioning::NoPartitioning_Scene
  • performUpdate()
: vrecko::SP_SceneInterface
, APSpacePartitioning::NoPartitioning_Scene
  • PerlinLines() : APDYNAMICART::PerlinLines
  • perlinNoise() : APDYNAMICART::PerlinLines
  • PerlinNoiseAlgorithm() : APNature::PerlinNoiseAlgorithm
  • PersistentCache() : vrecko::PersistentCache
  • pgd_close() : vreckoDP_base::fsPinchGlove
  • pgdComm() : vreckoDP_base::fsPinchGlove
  • pgdRead() : vreckoDP_base::fsPinchGlove
  • PHANToMAvatar() : PHANToMAvatar
  • PHEffect() : PHEffect
  • PhysXManager() : APDYNAMICART::PhysXManager
  • PhysXObject() : PhysXPlugin::PhysXObject
  • PhysXScene() : PhysXPlugin::PhysXScene
  • pitchDown()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • pitchUp()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • Plane()
: PhysXPlugin::Plane
, VirtualFixture::Plane
  • playback()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_FreeHandPainting
  • PLControllerTool() : APDYNAMICART::PLControllerTool
  • PLMagnetTool() : APDYNAMICART::PLMagnetTool
  • PLNestTool() : APDYNAMICART::PLNestTool
  • PluginManager() : vrecko::PluginManager
  • PoA() : APDYNAMICART::PoA
  • PoB() : APDYNAMICART::PoB
  • PointAdd() : APRoomEdit::PointAdd
  • pointed()
: APDYNAMICART::Attractor
, APDYNAMICART::BrushStroke
, APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PerlinLines
, APDYNAMICART::PoA
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::PS_Face
, APDYNAMICART::PS_FacePlane
, APDYNAMICART::PoAAdapter< T >
, APGUI::ColorPicker
, APGUI::GUI_Item
, APGUI::Icon
, APGUI::Menu
, APGUI::Slider
, Icon
, APDYNAMICART::PoB
  • pointerBtnUpdate() : APEditorController::EditorController
  • pointerButtonDown()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerButtonUp()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerMove()
: APMenu::MenuItem
, APMenu::MenuItemSlider
  • pointerMoved() : APMenu::DynamicMenu
  • pointerPosUpdate() : APEditorController::EditorController
  • pointerRotUpdate() : APEditorController::EditorController
  • pointerSelectItem() : APMenu::DynamicMenu
  • pointerSelUpdate() : APEditorController::EditorController
  • pointerUnselectItem() : APMenu::DynamicMenu
  • pointerViewMovedHelper() : APMenu::DynamicMenu
  • PointIndex() : APNature::TerrainAlgorithm
  • pointInHalfSpace() : CarSim::RoadsState
  • PointInPlaneJoint() : PhysXPlugin::PointInPlaneJoint
  • PointMove() : APRoomEdit::PointMove
  • pointObjectByID() : APGUI::GUI_Controller
  • PointOnLineJoint() : PhysXPlugin::PointOnLineJoint
  • PointShell_Object_Data() : APSpacePartitioning::PointShell_Object_Data
  • PointShell_Object_Data::getColor() : APSpacePartitioning::PointShell_Object_Data
  • PointShell_Object_Data_Geometry() : APSpacePartitioning::PointShell_Object_Data_Geometry
  • PointShell_Object_Data_Geometry_Analyser() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • PointShell_Object_Data_LOD_Builder() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • PointShellGeneric_Object_Data() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • PointShellVSVoxel_Object() : APSpacePartitioning::PointShellVSVoxel_Object
  • polygonHaveVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • polygonHaveVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • polygonsEqualsByVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • PolygonState() : APConnectEditor::PolygonState
  • PolyhedraSculpture() : APDYNAMICART::PolyhedraSculpture
  • pop() : AP_LSystem::TurtleStack
  • positionX()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • positionY()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • positionZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • PosNoiseRemover() : Filter::PosNoiseRemover
  • postInitialize()
: vrecko::BaseClass
, vrecko::PyAbility
, ArtificialWorld::BlockUpdater
, ArtificialWorld::WorldBuilder
, BehindObstacleExp_wT
, BehindObstacleExperiment
, behindO::CentreObjectManipulator
, behindO::MappingFunctions
, behindO::WIM
, boids::Boid
, boids::BoidsLogic
, boids::BoidsPlanner
, AP_CableEditor::Cable
, APCameraMovement::CameraPath
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::DAEnvironment
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLControllerTool
, APFFDEditor::EditorLogic
, AP_LSystem::LSObject
, APGUI::Icon
, APGUI::Menu
, APGUI::Slider
, APHUD::HUDDisplay
, APLightsEditor::Lights
, APMenu::DynamicMenu
, APClouds::Clouds
, grass::Grass
, navigation::AvatarInHand
, navigation::KMTracker
, APObjectUtils::ConnectionViz
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
, APObjectUtils::ObjectModif
, APObjectUtils::ObjectSelector
, ode::CappedCylinder
, ode::CompositeObject
, ode::Cube
, ode::Sphere
, APRoomEdit::WallGeometry
, APSpacePartitioning::VoxelGrid_Object_Data
, APTextOutput::Console
, vreckoDP_base::OptiTrack
, Icon
, MagicWandTool
, MTCreatorTool
, SliceTool
, PhysXPlugin::BaseActor
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::PhysXObject
, PhysXPlugin::PhysXScene
, PhysXPlugin::RemoteDebugger
, PhysXPlugin::UpdatablePhysXObject
, VirtualFixture::Avatar
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Log
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, PHANToMAvatar
, PHEffect
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, base::Avatar
, base::Light
, base::SystemInfo
  • PostoHSL() : APGUI::ColorPicker
  • Postprocessing() : APNature::Terrain2D
  • postRotate() : AP_LSystem::MovingTurtle
  • postStep()
: AP_LSystem::JointedPipe
, AP_LSystem::MovingTurtle
  • preInit() : AP_CableEditor::CableEditor
  • preInitialize()
: APLightsEditor::Lights
, APMenu::DynamicMenu
, Filter::Linear
, APClouds::Clouds
, navigation::KMTracker
, APObjectUtils::Animator
, APDYNAMICART::Controller
, APObjectUtils::ConnectionViz
, APObjectUtils::KeepOnScreen
, APObjectUtils::ObjectEffectMan
, APObjectUtils::ObjectInfo
, APObjectUtils::ObjectModif
, APRoomEdit::WallGeometry
, APSpacePartitioning::NoPartitioning_Scene
, boids::BoidsPlanner
, APSpacePartitioning::PointShellVSVoxel_Object
, APSpacePartitioning::SP_Object_Data_Base
, APSpacePartitioning::SphereBVH_Object
, behindO::Manipulator
, APSpacePartitioning::SphereBVH_Scene
, APSpacePartitioning::VoxelGrid_Object_Data
, APTextOutput::Console
, BehindObstacleExperiment
, vreckoDP_base::OptiTrack
, PhysXPlugin::BasePhysXObject
, PhysXPlugin::PhysXScene
, VirtualFixture::Avatar
, VirtualFixture::AxisLock
, VirtualFixture::Box
, VirtualFixture::Cone
, base::MTMatrixTransform
, VirtualFixture::Cylinder
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Log
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, PHEffect
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Trace
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, VirtualFixture::Sphere
, PHANToMAvatar
, VirtualFixture::ProxiBox
, VirtualFixture::Damper
, APHUD::HUDDisplay
, PhysXPlugin::PhysXObject
, VirtualFixture::Border
, APSpacePartitioning::SNCH_Object
, APObjectUtils::ObjectSelector
, base::Avatar
, base::hand
, base::Light
, base::MouseHand
, base::Rotate
, base::SystemInfo
, vrecko::BaseClass
, vrecko::PyAbility
, ArtificialWorld::BlockUpdater
, behindO::AvatarManipulator
, BehindObstacleExp_wT
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Mirror
, boids::Boid
, boids::BoidsLogic
, AP_CableEditor::Cable
, APCameraMovement::CameraPath
, CarSim::CarControlUnit
, CarSim::CarExecutionUnit
, CarSim::Remover
, CarSim::RoadsState
, CarSim::TLsOnJuncManager
, APObjectUtils::ObjectEffect
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::DAEnvironment
, Filter::PosNoiseRemover
, ChessPiece
, AP_LSystem::LSObject
  • Preloader() : Preloader
  • PrepareDisplayList() : grass::GrassDrawable
  • prepareForTermination() : vrecko::Scene
  • PrepareNext() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • Preprocessing() : APNature::Terrain2D
  • preReadBytes() : vrecko::BufferedFile
  • preRotate() : AP_LSystem::MovingTurtle
  • preStep()
: AP_LSystem::MovingTurtle
, AP_LSystem::StraightPipe
, AP_LSystem::JointedPipe
  • printBuf() : vreckoDP_base::fsPinchGlove
  • printBuffer() : vreckoDP_base::LHeadTracker
  • printConf() : vreckoDP_base::fsPinchGlove
  • printGests() : vreckoDP_base::fsPinchGlove
  • printOutEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutList() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutPolygon() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutQueue() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutStatus() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutVerbouseStatus() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printOutVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • printPos() : vreckoDP_base::LHeadTracker
  • PrismaticJoint() : PhysXPlugin::PrismaticJoint
  • processAction()
: APGUI::Icon
, APGUI::ColorPicker
, APGUI::GUI_Controller
, APGUI::Menu
, APGUI::Slider
, APGUI::GUI_Item
, APGUI::IconColour
, APInputConnector::InputConnector
  • processBatchOfEvents() : vrecko::EventDispatcher
  • processButtonPress()
: APConstrainedMovement::ConstrainedObjectMovement
, vrecko::ControllableAbility
, APRoomEdit::RoomEditor
  • processButtonRelease()
: AP_CableEditor::CableEditor
, APRoomEdit::RoomEditor
, vrecko::ControllableAbility
, APConnectEditor::ConnectEditor
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::AbilityEditor
, APConnectEditor::Optimalizer
  • processChainofResponsibility() : APInputConnector::InputConnector
  • processCondition() : AP_LSystem::Rule
  • processContextClick() : APGUI::GUI_Controller
  • processCutSymbol() : AP_LSystem::LSystem
  • processDualSplitting() : APConstrainedMovement::ConstraintDescription
  • processEvent()
: MagicWandTool
, ChessPiece
, VirtualFixture::ProxiSphere
, VirtualFixture::ProxiBox
, vrecko::PyAbility
, vrecko::EventDispatcher
, base::MouseHand
, VirtualFixture::VibrationLabel
, behindO::HeadManipulator
, behindO::EyeManipulator
, behindO::WIM
, VirtualFixture::Sphere
, Filter::PosNoiseRemover
, VirtualFixture::ProxiCone
, Filter::Linear
, VirtualFixture::NavSphere
, VirtualFixture::ProxiCylinder
, APInputConnector::InputConnector
, VirtualFixture::Marker
, VirtualFixture::Drag
, BehindObstacleExperiment
, VirtualFixture::ProxiBorder
, vreckoDP_base::VRPN3DMouse
, navigation::KMTracker
, CarSim::RoadsState
, VirtualFixture::Damper
, BehindObstacleExp_wT
, behindO::CuttingPlane
, navigation::AvatarInHand
, behindO::Manipulator
, ChessBoard
, vrecko::BaseClass
, VirtualFixture::Cylinder
, MTCreatorTool
, behindO::CentreObjectManipulator
, VirtualFixture::Cone
, VirtualFixture::AxisLock
, PHEffect
, VirtualFixture::Trace
, VirtualFixture::Box
, behindO::ChangeOfVisibility
, behindO::MappingFunctions
, CarSim::Remover
, behindO::HMDHeadManipulator
, VirtualFixture::Vibration
, VirtualFixture::Avatar
, VirtualFixture::Grid
, behindO::AvatarManipulator
, VirtualFixture::Log
, VirtualFixture::Plane
, PHANToMAvatar
, APClouds::Clouds
, VirtualFixture::VibrationLabelActivator
, APDYNAMICART::Ctrl_FreeHandPainting
, VirtualFixture::MarkerFactory
, VirtualFixture::Filter
, VirtualFixture::Border
  • processHomomorphismSuccessor()
: AP_LSystem::LSystem
, AP_LSystem::Abstract0LSystem
, AP_LSystem::D0LSystem
, AP_LSystem::Par2LSystem
  • processInputPosition() : APGUI::Slider
  • ProcessLine() : WAVEFRONT::InPlaceParser
  • processLine() : AP_LSystem::StringUtils
  • processMenuButtonPress() : vrecko::ControllableAbility
  • processMenuButtonRelease() : vrecko::ControllableAbility
  • processMessage()
: vrecko::InputPinBase
, vrecko::InputPin< _MessageType >
  • processNodeToMergeRecursive() : vrecko::ReaderWriter
  • processNotification()
: AP_CableEditor::CableEditor
, APEditorController::EditorController
, APMenu::MenuItem
, AP_CableEditor::Cable
, APSpacePartitioning::SphereBVH_Object_Data
, vrecko::ControllableAbility
, vrecko::Scene::EOIteratorHelper
, vrecko::BaseClass
, APObjectUtils::ObjectEffectMan
  • ProcessOrientation() : APInputConnector::InputConnector
  • processOutstandingCounters() : vrecko::Logger
  • processOutstandingTexts() : vrecko::Logger
  • processParameters() : AP_LSystem::Rule
  • processPoint() : APConnectEditor::Cut
  • processPredecessor()
: AP_LSystem::D0LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::LSystem
, AP_LSystem::Abstract0LSystem
  • processProbabilityFactor() : AP_LSystem::Rule
  • processRequest()
: vrecko::BaseClass
, vrecko::RequestInputPinBase
, CarSim::RoadsState
, vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • processRuleSuccessor()
: AP_LSystem::LSystem
, AP_LSystem::D0LSystem
, AP_LSystem::Abstract0LSystem
, AP_LSystem::Par2LSystem
  • processSensorTransformation() : APInputConnector::InputConnector
  • processTextMain() : vrecko::Logger
  • processVector() : AP_LSystem::StringUtils
  • projectPointOnPlaneUV() : APEditorQAbilities::ObjectMovement
  • ProxiBorder() : VirtualFixture::ProxiBorder
  • ProxiBox() : VirtualFixture::ProxiBox
  • ProxiCone() : VirtualFixture::ProxiCone
  • ProxiCylinder() : VirtualFixture::ProxiCylinder
  • ProxiSphere() : VirtualFixture::ProxiSphere
  • PS_Component() : APDYNAMICART::PS_Component
  • PS_Face() : APDYNAMICART::PS_Face
  • PS_FacePlane() : APDYNAMICART::PS_FacePlane
  • PS_Layer() : APDYNAMICART::PS_Layer
  • PS_Polyhedron() : APDYNAMICART::PS_Polyhedron
  • PseudoRand2DPlacement() : PseudoRand2DPlacement
  • PulleyJoint() : PhysXPlugin::PulleyJoint
  • push() : AP_LSystem::TurtleStack
  • push_back() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • PyAbility() : vrecko::PyAbility
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- q -

  • QComputeBoundShapeVisitor() : osgQ::QComputeBoundShapeVisitor
  • QConstShapeVisitor() : osgQ::QConstShapeVisitor
  • QDrawShapeVisitor() : osgQ::QDrawShapeVisitor
  • QPrimitiveShapeVisitor() : osgQ::QPrimitiveShapeVisitor
  • QSection() : osgQ::QSection
  • QShapeDrawable() : osgQ::QShapeDrawable
  • QShapeVisitor() : osgQ::QShapeVisitor
  • QueryTurtle() : AP_LSystem::QueryTurtle
  • quitAfterError() : CarSim::CarControlUnit
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- r -

  • rand() : AP_LSystem::AbstractTurtle
  • random()
: APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::PerlinLines
  • RandomFaultsAlgorithm() : APNature::RandomFaultsAlgorithm
  • RandomIndex() : AP_LSystem::RandomIndex
  • RandomizeSurfaceCorners() : APNature::MidpointDisplacementAlgorithm
  • randomTurnPitchRoll()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • Range() : vrecko::Range
  • readBlock() : Hci
  • readBool() : vrecko::BufferedFile
  • readBuffer() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readByte() : vrecko::BufferedFile , UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • ReadByte() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • readBytes() : vrecko::BufferedFile , Serial
  • readBytesCore() : vrecko::BufferedFile
  • readChar() : Serial
  • readDouble() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readDword() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • ReadDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • readDWORD() : vrecko::BufferedFile
  • Reader() : mv::Reader
  • ReaderWriter() : vrecko::ReaderWriter
  • readFloat() : vrecko::BufferedFile , UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readInt() : vrecko::BufferedFile
  • readInt64() : vrecko::BufferedFile
  • readLine() : vrecko::BufferedFile
  • readLineW() : vrecko::BufferedFile
  • readLONG() : vrecko::BufferedFile
  • readNodeFile()
: APCameraMovement::MyReadCallback
, APConnectEditor::MyReadCallback
, APObjectUtils::MyReadCallback
, MyReadCallback
, APSpacePartitioning::VGReadCallback
  • readPOINT() : vrecko::BufferedFile
  • readRECT() : vrecko::BufferedFile
  • readStr() : vrecko::BufferedFile
  • readString() : Hci
  • readVec3f() : vrecko::BufferedFile
  • readWatchedObjectIDs() : APConstrainedMovement::ConstrainedObjectMovement
  • readWCharTrans() : vrecko::BufferedFile
  • readWord() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • readWORD() : vrecko::BufferedFile
  • ready() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • realize() : vrecko::ViewerBase
  • RealizeQueue() : Cloud
  • recalculateColorInterpolation() : APDYNAMICART::PerlinLines
  • recalculateNormals()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • recomputeNormal() : SnapObject
  • recomputeStrokesTimes() : APDYNAMICART::Ctrl_FreeHandPainting
  • Rectangle() : AP_LSystem::Rectangle
  • RectangularSplineAdapter() : APDYNAMICART::RectangularSplineAdapter
  • reduceFront() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • regCarForEdge() : CarSim::RoadsState
  • regFstCarForEdge() : CarSim::RoadsState
  • regIncomingCarToShortEdges() : CarSim::RoadsState
  • registerEnvironmentObject() : vrecko::Scene
  • registerGlobalGuiItem() : APGUI::GUI_Controller
  • registerNewItemType() : APMenu::DynamicMenu
  • registerOutputNotification() : vrecko::Logger
  • registerPointableGuiItem() : APGUI::GUI_Controller
  • RegisterUpatablePO() : PhysXPlugin::UpdatablePhysXObject
  • RegularPolygonSpline() : RegularPolygonSpline
  • RegularUpdate() : Cloud
  • Release() : APNature::TerrainAlgorithm
  • releaseHoopActor() : APDYNAMICART::PhysXManager
  • releaseHoopJoints() : APDYNAMICART::PhysXManager
  • releaseObject() : vrecko::Scene::EOIteratorHelper
  • releaseParser() : vrecko::ReaderWriter
  • releasePhysics() : APDYNAMICART::PhysXManager
  • RemoteDebugger() : PhysXPlugin::RemoteDebugger
  • remove() : APLightsEditor::Lights
  • removeAbility()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
, vrecko::World
  • removeAbilityMapper() : APEditorController::EditorController
  • RemoveAddObserver() : ModelManager
  • removeAll() : APLightsEditor::Lights
  • removeAllAbilities()
: vrecko::AbilityDispatcher
, vrecko::EnvironmentObject
  • removeAllFields() : APHUD::HUDDisplay
  • removeAllHooks() : APDYNAMICART::HookManager
  • removeAllMarkers()
: VirtualFixture::MarkerFactory
, VirtualFixture::Trace
  • removeAllSectorsOnHoop() : APDYNAMICART::SectorManager
  • removeAnimation() : APObjectUtils::Animator
  • removeAttribRecursive() : vrecko::ReaderWriter
  • removeAttribute() : vreckoUtils::MenuRoot
  • removeAvatarView() : vrecko::World
  • removeChild() : vreckoUtils::MenuBase
  • removeConstrainedChildID() : APConstrainedMovement::ConstraintDescription
  • removeConstrainedDualPartnerID() : APConstrainedMovement::ConstraintDescription
  • RemoveDeleteObserver() : ModelManager
  • removeEntity()
: vrecko::Scheduler
, vrecko::vThread
  • removeEnvironmentObject() : vrecko::Scene
  • removeEOChild() : vrecko::EnvironmentObject
  • removeField() : APHUD::HUDDisplay
  • removeFromScene() : APWeather::Weather
  • RemoveGeometry() : GeometryState , AnimatedGeometryState
  • RemoveGetObserver() : ModelManager
  • removeHook() : APDYNAMICART::HookManager
  • removeHooksOnHoop() : APDYNAMICART::HookManager
  • removeInputOutputs()
: APMenu::MenuItem
, APMenu::MenuItemText
, APMenu::MenuItemSlider
  • removeInputPin() : vrecko::BaseClass
  • removeItem() : APGUI::Layout
  • removeNotification() : vrecko::BaseClass
  • removeObject() : vrecko::OctTree
  • removeObserver() : vreckoUtils::Observable
  • removeOuterObject() : vrecko::EventDispatcher
  • removeOutputPin() : vrecko::BaseClass
  • removePartitioningObjectInterface() : vrecko::Scene
  • removePartitioningSceneInterface() : vrecko::Scene
  • removePoA() : APDYNAMICART::Controller
  • Remover() : CarSim::Remover
  • RemoveReference() : GeometryState , AnimatedGeometryState
  • removeRequestInputPin() : vrecko::BaseClass
  • removeRequestOutputPin() : vrecko::BaseClass
  • removeRequiredEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • removeSector() : APDYNAMICART::SectorManager
  • removeSectors() : SectorColorGen
  • removeState() : APDYNAMICART::PoAState
  • removeUnnecessaryWhitespace() : vrecko::ReaderWriter
  • removeUserData() : vrecko::EnvironmentObject
  • removeWall() : WGeometry::WG_Point
  • removeWindow() : APHUD::HUDDisplay
  • RepairViolations() : ThinHeap< _NodeClass, _keyType >
  • reportError()
: vrecko::BaseClass
, vrecko::vThread
  • reportEvent()
: vrecko::EventDispatcher
, vrecko::World
  • reportEventCore() : vrecko::EventDispatcher
  • repositionModel() : APMenu::MenuItemText
  • request()
: vrecko::EventDispatcher
, vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
, vrecko::World
, vrecko::EventDispatcher
  • requestForDevice() : vrecko::DeviceManager
  • RequestInputPin() : vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • RequestOutputPin() : vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • requestPointerLoc() : vrecko::ControllableAbility
  • requestPointerLocRaw() : vrecko::ControllableAbility
  • requestSelectionID() : vrecko::ControllableAbility
  • requestSelectionPath() : vrecko::ControllableAbility
  • reserve() : GradientColorGen , ConstantColorGen
  • reset()
: AP_LSystem::ParseableString
, vreckoDP_base::LHeadTracker
, APGUI::ItemsGroup
, APGUI::GUI_Controller
  • Reset() : DynamicTreeIterator< _Type >
  • reset()
: APSpacePartitioning::SNCH_Object::OneTri
, APDYNAMICART::Limits
  • resetBase() : vreckoDP_base::LHeadTracker
  • resetBaseValues() : APMenu::DynamicMenu
  • resetConfirmationEffect() : APMenu::MenuItem
  • resetCuttingLoop() : APConnectEditor::Cut
  • ResetDelta()
: ht::VariableQuat
, ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
  • resetErrors()
: APMenu::MenuLoaderErrorHandler
, vrecko::RWErrorHandler
, BCLoaderErrorHandler
  • resetGeometry() : APFFDEditor::EditorLogic
  • resetObjectUpdatesCounter() : vrecko::Scheduler
  • resetProcessedEventsCounter() : vrecko::EventDispatcher
  • resetScene() : APDYNAMICART::PhysXManager
  • resetToPos() : APObjectUtils::Animator
  • resetValues()
: APDYNAMICART::ToolSelector
, AP_LSystem::AbstractTurtle
  • resetView() : BehindObstacleExperiment , BehindObstacleExp_wT
  • resolveIntersections()
: APShootingSimulation::ShootingSimulation
, APObjectUtils::ObjectSelector
, APConnectEditor::Cut
  • resolveSelection()
: APObjectUtils::ObjectSelector
, APConnectEditor::Cut
  • rest_on_land() : boids::BoidsLogic
  • Restart() : PreloaderHeuristic , BasicPreloaderHeuristic
  • restoreAllPoAStates() : APDYNAMICART::PoAState
  • returnColorOfVoxel() : APSpacePartitioning::VoxelGrid_Object_Data
  • revoke() : APGUI::ColorPicker
  • RevoluteJoint() : PhysXPlugin::RevoluteJoint
  • RGBtoHSL() : APGUI::ColorPicker
  • rightHandRule() : CarSim::RoadsState
  • RMFrameAdapter() : APDYNAMICART::RMFrameAdapter
  • RoadsState() : CarSim::RoadsState
  • rollArround()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • rollLeft()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • rollRight()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • rollUntilHorizontal()
: AP_LSystem::MovingTurtle
, AP_LSystem::AbstractTurtle
  • RoomEditor() : APRoomEdit::RoomEditor
  • RoomEditor::menuItemClicked() : APRoomEdit::RoomEditor
  • RoomLoader() : APRoomEdit::RoomLoader
  • RoomSaver() : APRoomEdit::RoomSaver
  • Rotate() : base::Rotate
  • rotate() : gmMatrix4 , gmMatrix3
  • Rotation() : APConnectEditor::Rotation
  • RotationFrameAdapter() : APDYNAMICART::RotationFrameAdapter
  • RotationFrameFactory() : APDYNAMICART::RotationFrameFactory
  • RoundedSplineAdapter() : APDYNAMICART::RoundedSplineAdapter
  • Rule() : AP_LSystem::Rule
  • rule0_in_sight() : boids::BoidsLogic
  • rule1_centre_of_mass() : boids::BoidsLogic
  • rule2_away_from_others() : boids::BoidsLogic
  • rule3_match_velocity() : boids::BoidsLogic
  • rule4_bound_position() : boids::BoidsLogic
  • rule5_fly_to_waypoint() : boids::BoidsLogic
  • rule6_fly_from_danger() : boids::BoidsLogic
  • run() : APDYNAMICART::ComputeThread
  • Running() : Preloader
  • RWErrorHandler() : vrecko::RWErrorHandler
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- s -

  • SampledSpline() : SampledSpline
  • save()
: vrecko::ReaderWriter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::HookObject
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::Controller
, APDYNAMICART::HookManager
, Icon
, APDYNAMICART::PoB
, APDYNAMICART::Hoop
, APDYNAMICART::Brush
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::HoopShape
, APDYNAMICART::NullHoopShape
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::JuliaAttractor
, APDYNAMICART::NullAttractor
  • Save() : mv::Reader
  • save()
: APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PerlinLines
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::PoA
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::ConstantDiamAdapter
, APDYNAMICART::HandFrameAdapter
, APDYNAMICART::SectorManager
  • SaveAnimation() : APCameraPath::Camera
  • saveCable() : AP_CableEditor::CableEditor
  • saveChildren() : vrecko::ReaderWriter
  • saveCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveCollisionsToFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveDataToFile() : APSpacePartitioning::PointShell_SimpleNode
  • saveDataToPC_SaveTreeNode() : APSpacePartitioning::SphereBVH_Object_Data
  • saveDataToPersistentCache_Init() : APSpacePartitioning::SphereBVH_Object_Data
  • saveDataToPersistentCache_WriteData() : APSpacePartitioning::SphereBVH_Object_Data
  • saveEnvironmentObject() : vrecko::ReaderWriter
  • saveFacesToFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • saveGridToFile() : APSpacePartitioning::VoxelGrid_Object_Data
  • saveModel() : vrecko::PersistentCache
  • saveNodeToFileRec() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • savePointShellCollisions()
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data
  • SaveSetup()
: ht::ScreenSetup
, ht::ScreenSetupSimple
  • saveState() : APDYNAMICART::PoAState
  • saveSubDivisionMeshToFile() : APSpacePartitioning::PointShell_Object_Data
  • saveToCache()
: APSpacePartitioning::PointShell_Object_Data
, APSpacePartitioning::VoxelGrid_Object_Data
  • SaveToFile() : CloudsManager
  • saveToXML() : APLightsEditor::Editor
  • saveTreeNodeToFile()
: APSpacePartitioning::SphereBVH_Object_Data
, APSpacePartitioning::SNCH_Object_Data
  • saveTreeToFile() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • saveVerticesToFile()
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object_Data
  • saveWordToFile() : AP_LSystem::AbstractGenerator
  • saveXMLDocument() : vrecko::ReaderWriter
  • saveXMLParameters()
: base::Avatar
, base::Rotate
, base::ShowFDH
, vrecko::BaseClass
, BehindObstacleExp_wT
, BehindObstacleExperiment
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::WIM
, boids::Boid
, boids::BoidsLogic
, boids::BoidsPlanner
, APDYNAMICART::DAEnvironment
, Filter::Linear
, Filter::PosNoiseRemover
, APClouds::Clouds
, grass::Grass
, grass::GrassAbilityParameters
, navigation::AvatarInHand
, navigation::KMTracker
, ode::CappedCylinder
, ode::CompositeObject
, ode::Cube
, ode::Sphere
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Wiimote
  • Scale() : APConnectEditor::Scale
  • scale() : gmMatrix3 , gmMatrix4
  • scanDevice()
: vreckoDP_base::fdtDataGlove
, vreckoDP_base::L3DMouse
, vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • scanDeviceX()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • Scene() : vrecko::Scene
  • SceneSave() : APEditorQAbilities::SceneSave
  • Scheduler() : vrecko::Scheduler
  • Screen() : ht::Screen
  • ScreenSetup() : ht::ScreenSetup
  • ScreenSetupSimple() : ht::ScreenSetupSimple
  • SearchFinnished() : PreloaderHeuristic
  • Sector() : Sector
  • SectorColorGen() : SectorColorGen
  • SectorInfo() : APDYNAMICART::SectorInfo
  • SectorManager() : APDYNAMICART::SectorManager
  • selectionVisibilityUpdate() : APEditorController::EditorController
  • selectRule()
: AP_LSystem::LSystem
, AP_LSystem::Par2LSystem
, AP_LSystem::ParStoch0LSystem
  • send() : vrecko::OutputPin< _MessageType >
  • sendEvent() : vreckoDP_base::OptiTrack
  • sendMousePosIfReady() : vreckoDP_base::KeyboardMouse
  • sendNewMapping() : APEditorController::AbilityMapper
  • sendNotifications() : vrecko::BaseClass
  • sendPointerBtnToRelevantOutputs() : APEditorController::EditorController
  • sendPointerSelectionEvent() : APEditorController::EditorController
  • sendPosition() : vreckoDP_Kinect::Kinect
  • sendSensorTransformation() : vreckoDP_Kinect::Kinect
  • sendSkeletonPositions() : vreckoDP_Kinect::Kinect
  • SendTerminationNotifications() : vrecko::World
  • sendToClickedOutput() : APMenu::DynamicMenu
  • SendUseSignal() : APEditorQAbilities::UseTrigger
  • sendValue() : APGUI::Slider
  • separation() : vrecko::Scene
  • set() : Sector , APDYNAMICART::SimpleBox , osgQ::QSection
  • setAbilityMapping() : APEditorController::EditorController
  • setActiveMember() : APGUI::ItemsGroup
  • setActiveShadowLight() : APLightsEditor::Lights
  • setActor() : APDYNAMICART::Hoop
  • setActorOrientation() : APDYNAMICART::PhysXManager
  • setActorPosition() : APDYNAMICART::PhysXManager
  • setActualAvatarView() : vrecko::World
  • setAll() : mv::CPlayer
  • setAllBindingForMethod() : BehindObstacleExp_wT , BehindObstacleExperiment
  • setAllowedOutput() : vrecko::Logger
  • setAlpha() : APObjectUtils::Animator
  • setAndPlayConfirmationEffect() : APMenu::MenuItem
  • setAndSendValue() : APGUI::Slider
  • setAngleFrom() : osgQ::QSection
  • setAngleTo() : osgQ::QSection
  • setAngularVel() : ode::DynamicScene
  • SetAnimation() : ArtificialWorld::SubBlock
  • SetAnimationIndex() : ArtificialWorld::AnimatedModel
  • setAnimationPointsNumber() : APObjectUtils::Animator
  • SetAnimationType() : ArtificialWorld::SubBlockAnimation
  • setAreaClassString() : APConstrainedMovement::ConstraintArea , ConstraintHierarchyMember
  • setArgumens() : vrecko::World
  • setAtributesForDeformation() : APFFDEditor::EditorLogic
  • setAttribute()
: vrecko::BaseClass
, APMenu::DynamicMenu
  • setAutoRotationActive() : APDYNAMICART::DAEnvironment
  • setAxiom()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
  • setBaseR() : vreckoDP_base::LHeadTracker
  • setBaseT() : vreckoDP_base::LHeadTracker
  • setBehaviour() : vrecko::BufferedFile
  • setBinormal() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setBlinkers() : CarSim::CarControlUnit
  • setBlurSize() : APLightsEditor::Lights
  • setBottomCCWVertex() : WGeometry::WG_Vertices
  • setBottomCWVertex() : WGeometry::WG_Vertices
  • setBottomNormal() : WGeometry::WG_Wall
  • setBounceRadius() : APLightsEditor::Lights
  • setBounceSampleCount() : APLightsEditor::Lights
  • setBoundAreaCount() : APConstrainedMovement::ConstraintDescription
  • setBoundAreaNormal() : APConstrainedMovement::ConstraintDescription
  • setBounding() : APDYNAMICART::PerlinLines
  • setBoundingVisible() : APDYNAMICART::PerlinLines
  • setBufSize() : vrecko::BufferedFile
  • setCableColor() : AP_CableEditor::Cable
  • setCableID() : AP_CableEditor::Cable
  • setCallBacks() : vrecko::PyAbility
  • SetCamera() : Cloud
  • setCameraData() : CloudDataType
  • setCaption() : APMenu::MenuItemText
  • setCastShadows() : vrecko::EnvironmentObject
  • setCenter() : osgQ::QSection
  • setCharacteristics() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setChoosenBoundaryLoop() : SnapObject
  • setClearColor() : APLightsEditor::Lights
  • setClosed() : SampledSpline
  • SetCloudParticleTexture() : Cloud
  • setColor()
: APDYNAMICART::Attractor
, APDYNAMICART::ColorGenAdapter
, APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::ComputeThread
, APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PerlinLines
, WGeometry::WG_Wall
  • setColorAdapter() : APDYNAMICART::Brush
  • setColorEnd() : GradientColorGen
  • setColorGenerator() : SweepSurfaceGeode
  • setColorIndex() : APDYNAMICART::ColorGenAdapter
  • setColorofPart() : Icon
  • setColorProfileforWindow() : APHUD::HUDDisplay
  • setColorStart() : GradientColorGen
  • setColorValue() : ConstantColorGen
  • setColour()
: APDYNAMICART::Controller
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::SimpleBox
, MTBrush
  • setColours()
: APGUI::GUI_Item
, APGUI::Slider
  • setColourType() : MTBrush
  • SetCommentSymbol() : WAVEFRONT::InPlaceParser
  • setComponent() : APDYNAMICART::PS_Polyhedron
  • setComputedTime() : APDYNAMICART::BrushStroke
  • setController() : APDYNAMICART::PerlinLines
  • setControlPoints() : AP_CableEditor::Cable
  • setControlSpheresColor() : AP_CableEditor::Cable
  • setControlSpheresRadiusAdjust() : AP_CableEditor::Cable
  • setCountOfControlPoints() : APFFDEditor::Grid
  • setCrosshairPos() : APShootingSimulation::ShootingSimulation
  • setCrossSectionAdapter() : APDYNAMICART::Brush
  • setCrossSectionGenerator() : APDYNAMICART::HoopGeometry
  • setCrossSectionInterpolation() : APDYNAMICART::BrushStroke
  • setCrossSectionInterpolationSteps() : APDYNAMICART::Brush
  • setCrossSectionShape() : MTBrush
  • setCrossSectionSpline() : SweepSurfaceGeode
  • setCrossSectionType() : APDYNAMICART::BrushStroke , MTBrush
  • setDAEnvironment()
: APDYNAMICART::ToolEraser
, APDYNAMICART::ToolTongs
  • setDefaultColor() : SectorColorGen
  • setDefaultPattern() : APDYNAMICART::SectorManager
  • setDefaultTurtleProperties() : AP_LSystem::LSGeode
  • SetDelta()
: ht::Variable
, ht::VariableVec3
, ht::VariableVec2
, ht::VariableFloat
, ht::VariableQuat
  • setDescribtion() : VirtualFixture::Marker
  • setDescription()
: vrecko::Scene
, vrecko::World
  • setDeviceManagerPtr() : vrecko::World
  • setDiameter()
: APDYNAMICART::Brush
, APDYNAMICART::Hoop
, APDYNAMICART::BrushStrokeControlPoint
, MTBrush
  • setDiameterAdapter() : APDYNAMICART::Brush
  • setDiameterEnd() : GradientDiameterGen
  • setDiameterGenerator() : SweepSurfaceGeode
  • setDiameterStart() : GradientDiameterGen
  • setDirection() : mv::CPlayer
  • setDirty()
: APCameraMovement::CameraPath
, APRoomEdit::Tool
, APRoomEdit::WallGeometry
  • setDirtyAll() : SnapObject
  • setDirtyBoundaryLoop() : SnapObject
  • setDirtyClosestPoint() : SnapObject
  • setDirtyGraph() : SnapObject
  • setDirtyMaxDistance() : SnapObject
  • setDirtySnappingRegion() : SnapObject
  • setDisplaySettings()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setDistanceFieldTempValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • setDistanceFieldValue() : APSpacePartitioning::VoxelGrid_Object_Data
  • setDORadius() : APLightsEditor::Lights
  • setDOSampleCount() : APLightsEditor::Lights
  • setEdgesCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setEdgeVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setEffectType() : APObjectUtils::ObjectEffect
  • setEnable() : vrecko::PersistentCache
  • setEnabledAnimations() : APObjectUtils::Animator
  • setEnableFlag() : ode::DynamicScene
  • setEo() : SnapObject
  • setEoWrapper() : AP_CableEditor::Cable
  • setEventDispatcherPtr() : vrecko::World
  • setFace() : APDYNAMICART::PS_FacePlane
  • setFaceNormal() : WGeometry::WG_Wall
  • setFieldAsAnimated() : APHUD::HUDDisplay
  • SetFile() : WAVEFRONT::InPlaceParser
  • setFileName() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetFileName()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setFilePos() : vrecko::BufferedFile
  • setFlag() : WGeometry::WG_Wall
  • setFlags() : APMenu::MenuItem
  • setFlagsCore() : APMenu::MenuItem
  • setForce()
: ode::DynamicScene
, mv::CPlayer
  • setForceToDynamicObject() : ode::DynamicScene
  • setFusionDistance()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setGeometry() : vrecko::EnvironmentObject
  • setGestureFunc() : vreckoDP_base::fsPinchGlove
  • setGlobalAmbient() : APLightsEditor::Lights
  • SetGridUnitSizeXYZ() : PseudoRand2DPlacement
  • SetHard() : WAVEFRONT::InPlaceParser
  • SetHardSeparator() : WAVEFRONT::InPlaceParser
  • setHeight()
: APDYNAMICART::SimpleBox
, osgQ::QSection
, WGeometry::WG_Hole
  • setHighLighting() : MotionTrailTriangulator
  • setHighlighting() : vreckoUtils::HighlightCallback
  • setId()
: SnapObject
, WGeometry::WG_Point
, WGeometry::WG_Wall
, VirtualFixture::Marker
  • setID()
: vrecko::Ability
, vrecko::Device
, vrecko::EnvironmentObject
  • setIdentityTransformation() : vrecko::EnvironmentObject
  • setIncrementValue() : vreckoUtils::HighlightCallback
  • setIndexBottom() : WGeometry::WG_Point
  • setIndexTop() : WGeometry::WG_Point
  • setInitialPosition()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setInitialRotation()
: vreckoDP_base::LHeadTracker
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setInnerRadius() : osgQ::QSection
  • SetInterpolation() : ArtificialWorld::SubBlockAnimation
  • setInterpolation() : AP_CableEditor::Cable
  • setInterpolationCount() : APDYNAMICART::PerlinLines
  • setInterpolationSteps()
: APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
, InterpolatedSpline
, MTBrush
  • setInterpolationType() : APObjectUtils::Animator
  • setInterpolator() : InterpolatedSpline
  • setIntersection()
: APCameraMovement::CameraMovementEditor
, APRoomEdit::RoomEditor
  • setIsLoaded() : vrecko::Scene
  • setJustMoving() : APConstrainedMovement::ConstraintDescription
  • setLabel() : VirtualFixture::Marker
  • SetLastCam() : Cloud
  • setLayout()
: APDYNAMICART::Mode
, APDYNAMICART::Basic
, APDYNAMICART::Advanced
, APDYNAMICART::Utils
, APGUI::GUI_Controller
  • setLeadingSpline()
: APDYNAMICART::BrushStroke
, APDYNAMICART::HoopShape
, SweepSurfaceGeode
  • setLength() : APDYNAMICART::PerlinLines
  • setLevelMinMax() : APObjectUtils::ObjectEffect
  • setLevelZeroSize() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setLight()
: vrecko::ViewerBase
, vrecko::Viewer
, vrecko::CompositeViewer
  • setLightVisibility() : APLightsEditor::Lights
  • setLinearVel() : ode::DynamicScene
  • setLineParameters() : APDYNAMICART::PerlinLines
  • setLinesParameters() : APDYNAMICART::PerlinLines
  • setLocation() : ChessPiece
  • setLoop() : mv::CPlayer
  • setLoopType() : APObjectUtils::Animator
  • SetLoopType() : ArtificialWorld::SubBlockAnimation
  • setMagnet() : APDYNAMICART::PerlinLines
  • setMainThreadId() : vrecko::EventDispatcher
  • setMappedAbility() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • setMatrix() : base::MTMatrixTransform
  • setMaxChildrens() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMaxCloudUpdates() : Cloud
  • setMaxForce() : APSpacePartitioning::SNCH_Object
  • setMaxLevel() : base::ShowFDH
  • setMaxLevels() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMaxVisibleDistance()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setMenuShown() : APGUI::GUI_Controller
  • setMenuString() : APMenu::DynamicMenu
  • setMinimalSampleDistance() : SampledSpline
  • setMinimumVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetMinVisibleDistance() : ArtificialWorld::Model
  • setMode() : APLightsEditor::Lights
  • setModelFile() : APMenu::MenuItemText
  • setModelFileName() : vrecko::EnvironmentObject
  • SetModelFlags() : ArtificialWorld::Model
  • SetModelType() : ArtificialWorld::Model
  • setMovable() : mv::CGesture
  • setMovableVertices() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setName()
: vrecko::EnvironmentObject
, APMenu::MenuItem
, APRoomEdit::Tool
  • setNCoeficient() : APSpacePartitioning::SNCH_Object
  • setNetSupport() : vrecko::EventDispatcher
  • setNewSelection() : APEditorController::EditorController
  • SetNodeAllowedCallback() : DynamicTreeIterator< _Type >
  • setNodeMask() : APObjectUtils::Animator
  • setNormal() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setNormalCCWVertex() : WGeometry::WG_Vertices
  • setNormalCWVertex() : WGeometry::WG_Vertices
  • setNormalVector() : APConstrainedMovement::ConstraintArea
  • SetObjectCenterDir() : ArtificialWorld::BlockAttributes
  • SetObjectCenterPoint() : ArtificialWorld::BlockAttributes
  • setObjectSelectionbyRightHand() : APDYNAMICART::DAEnvironment
  • setOnce() : mv::CMVect
  • setOpacity() : APDYNAMICART::PS_Layer
  • setOptimalizationOfCP() : APFFDEditor::Grid
  • setOrientationKeepUp() : base::Avatar
  • setOriginPosition()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setOSGAdapter() : vrecko::EnvironmentObject
  • setOuterAngleAddition() : osgQ::QSection
  • setOuterRadius() : osgQ::QSection
  • setOutputDest() : vrecko::Logger
  • setOwner()
: APEditorQAbilities::ObjectMovement::SnapBox
, vrecko::Ability
, APEditorController::EditorController::ECPOINTERBUTTONINFO
  • setParameters()
: APDYNAMICART::Ctrl_PerlinLines
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • SetParentEO() : ArtificialWorld::BlockUpdater
  • setPartColour() : APGUI::Icon
  • setPatternColor() : APDYNAMICART::Ctrl_StringSculptures
  • setPause() : mv::CPlayer
  • setPlane() : RegularPolygonSpline
  • setPlay() : mv::CPlayer
  • setPluginName() : vrecko::Ability
  • setPoA() : APDYNAMICART::DATool
  • SetPoint()
: APNature::Terrain2DSegment
, APNature::Terrain2D
  • setPoint() : WGeometry::WG_Wall
  • setPointArray() : APDYNAMICART::Painted
  • SetPointHeight()
: APNature::Terrain2D
, APNature::TerrainAlgorithm
, APNature::TerrainUtility
  • setPoints() : WGeometry::WG_Wall
  • setPolygonsCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setPolygonVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setPortName() : vrecko::Device
  • setPosition() : DAControlPoint , WGeometry::WG_Point
  • SetPosition()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setPosition()
: vrecko::EnvironmentObject
, WGeometry::WG_Hole
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
, VirtualFixture::Marker
  • setPriority()
: APDYNAMICART::BrushStrokeControlPoint
, vrecko::BaseClass
, DAControlPoint
  • setProperties()
: AP_LSystem::AbstractTurtle
, APObjectUtils::CopyProperties
  • setProperty() : AP_LSystem::Configuration
  • SetQuoteChar() : WAVEFRONT::InPlaceParser
  • setRadius() : AP_CableEditor::Cable , RegularPolygonSpline
  • setReceiverPtrDirty() : vrecko::EventDispatcher::ICSBase
  • setReleaseFunc() : vreckoDP_base::fsPinchGlove
  • setRestrictorString() : APConstrainedMovement::ConstraintArea
  • setRFGenerator() : SweepSurfaceGeode
  • setRotation()
: vrecko::EnvironmentObject
, osgQ::QSection
, APObjectUtils::Animator
  • SetRotation()
: ArtificialWorld::Model
, ArtificialWorld::SubBlock
  • setRotationFrame() : APDYNAMICART::BrushStrokeControlPoint
  • setRotationFrameAdapter() : APDYNAMICART::Brush
  • setRotationShift() : RegularPolygonSpline
  • setRotationType() : vreckoDP_base::LHeadTracker
  • setScale() : vrecko::EnvironmentObject
  • SetScale() : ArtificialWorld::Model
  • setScale()
: vrecko::EnvironmentObject
, APObjectUtils::Animator
  • setScene() : BehindObstacleExp_wT , BehindObstacleExperiment
  • setSceneData()
: vrecko::Viewer
, vrecko::CompositeViewer
, vrecko::ViewerBase
  • setSceneFile() : vrecko::BaseClass
  • SetSceneInfo() : Cloud
  • setScenePtr()
: vrecko::EventDispatcher
, vrecko::World
  • setSchedulerPtr() : vrecko::World
  • SetScreen() : ht::Screen
  • setSector() : SectorColorGen
  • setSectorEditing() : APDYNAMICART::Ctrl_StringSculptures
  • setSegmentCount() : RegularPolygonSpline
  • setSegmentLength() : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • SetSegmentPosition() : APNature::Terrain2DSegment
  • setSensorCount() : APDYNAMICART::Ctrl_MotionVisualization
  • setSensorNumber() : APDYNAMICART::ToolBrush
  • setShape()
: AP_CableEditor::Cable
, APDYNAMICART::Hoop
  • setShapeCurveGenerator() : APDYNAMICART::HoopGeometry
  • setShapeRotate() : AP_CableEditor::Cable
  • setShowAxis() : APDYNAMICART::Ctrl_StringSculptures
  • setShowTimeWarnings() : vrecko::World
  • setSign() : APMenu::DynamicMenu
  • setSignalType() : vreckoDP_base::fdtDataGlove
  • setSignName() : APMenu::MenuItemText
  • setSimulationRun() : APDYNAMICART::PhysXManager
  • setSize() : APDYNAMICART::DATool
  • setSlaveTransmitterType() : vreckoDP_base::LHeadTracker
  • setSliderParameter() : APDYNAMICART::Attractor
  • setSliderParameters() : APGUI::Slider
  • setSliderPos01() : APMenu::MenuItemSlider
  • setSliderPosXY() : APMenu::MenuItemSlider
  • setSmoothness()
: APDYNAMICART::Brush
, APDYNAMICART::BrushStroke
  • SetSourceData() : WAVEFRONT::InPlaceParser
  • setSpeed()
: APDYNAMICART::PerlinLines
, APDYNAMICART::BrushStrokeControlPoint
, DAControlPoint
  • setSpeeds() : MTBrush
  • setSPoint() : mv::CGesture
  • setStartTick() : vrecko::Timer
  • setState()
: APGUI::Icon
, APGUI::Slider
, APGUI::Menu
, APGUI::ColorPicker
, APGUI::GUI_Item
  • SetState() : APObjectUtils::ObjectEffectMan
  • setStopedIncomingCarToShortEdges() : CarSim::RoadsState
  • setStringJoints() : APDYNAMICART::PhysXManager
  • setStringLineWidth() : APDYNAMICART::PatternsGeode
  • SetSubBlockType() : ArtificialWorld::SubBlock
  • SetSubTreeAllowedCallback() : DynamicTreeIterator< _Type >
  • SetSunLight() : Cloud
  • setTangent() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setTestComputation() : APSpacePartitioning::PointShellVSVoxel_Object
  • setText() : APGUI::GUI_Text
  • setThreadingModel() : vrecko::ViewerBase
  • setTime() : TimeLineSpline
  • setTimeout() : Timing
  • setTimePerLoop() : APObjectUtils::Animator
  • SetTimePerLoop() : ArtificialWorld::SubBlockAnimation
  • setTimeWarningsTime() : vrecko::World
  • setTopCCWVertex() : WGeometry::WG_Vertices
  • setTopCWVertex() : WGeometry::WG_Vertices
  • setTopNormal() : WGeometry::WG_Wall
  • setTorque() : ode::DynamicScene
  • setTorqueToDynamicObject() : ode::DynamicScene
  • setTransformationFromMatrix() : APObjectUtils::Animator
  • SetTranslateErrorTolerance() : Cloud
  • setTranslateMapping()
: vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • setTranslation() : APObjectUtils::Animator
  • setTransparency() : vrecko::EnvironmentObject
  • SetTree() : DynamicTreeIterator< _Type >
  • setTriangulationAngle() : APDYNAMICART::BrushStrokeControlPoint
  • setTurtleType() : AP_LSystem::LSGeode
  • setTvalue() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setType() : ChessPiece , WGeometry::WG_Hole
  • setUpCamera() : APLightsEditor::Lights
  • setUpCustomProcessEventCallback() : APDYNAMICART::DAEnvironment
  • setUpdate() : AP_CableEditor::Cable
  • setUpdateFlag() : APDYNAMICART::PoA
  • SetupFunction() : ht::SetupFunction
  • setUseFrenetFrame() : MotionTrailTriangulator
  • SetUVCoords() : CloudsManager
  • setV0() : mv::CMVect
  • setV1() : mv::CMVect
  • setValidEdge() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidEdges() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidVertex() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValidVertices()
: WGeometry::WG_Vertices
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setValue() : APGUI::Slider
  • SetValue()
: ht::VariableVec3
, ht::VariableFloat
  • setValue() : vreckoUtils::MenuSlider
  • SetValue() : ht::VariableVec2
  • setValue() : APHUD::HUDDisplay
  • SetValue() : ht::VariableQuat
  • setValueFromString()
: vrecko::VreckoMessage
, vrecko::MessageVoid
, base::SystemInfo::MessageSIThreadCreated
  • setValuesXYZ() : APDYNAMICART::ToolMagicWand
  • setVect() : mv::CMVect
  • setVertexArray() : BufferedSpline , SampledSpline , APDYNAMICART::PatternsGeode , APDYNAMICART::PatternBase
  • setVertexVisible() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • setVerticesCount()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
  • setViewerPtr() : vrecko::World
  • SetViewMatrix() : Cloud
  • setVisibleVisualBox() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • setWasTested() : APConstrainedMovement::ConstraintDescription
  • setWidth() : WGeometry::WG_Hole
  • SetWorldRoot() : PreloaderHeuristic
  • setWorldTransformationFromObject() : APConstrainedMovement::ConstraintArea
  • setWriting() : vrecko::BenchmarkWriter
  • setWTime() : mv::CGesture
  • setY() : WGeometry::WG_Hole
  • shift() : APConstrainedMovement::ConstraintArea
  • shiftAllConstrainedObjects() : APConstrainedMovement::ConstraintDescription
  • ShootingSimulation() : APShootingSimulation::ShootingSimulation
  • show() : APEditorQAbilities::ObjectMovement::SnapBox
  • Show() : ArtificialWorld::BlockUpdater
  • show()
: APGUI::GUI_Text
, APMenu::MenuItem
, DAGizmo
, APGUI::Layout
, APDYNAMICART::DAGizmo
, APGUI::GUI_Item
, vrecko::EnvironmentObject
  • showAxis() : APDYNAMICART::Hoop
  • showChildMenu() : APMenu::DynamicMenu
  • showCloseCuttingLoop() : APConnectEditor::Cut
  • showCuttingLoop() : APConnectEditor::Cut
  • showDebugNormals() : SweepSurfaceGeode
  • ShowFDH() : base::ShowFDH
  • ShowFDHModel() : base::ShowFDHModel
  • showGizmo() : APDYNAMICART::BrushStrokeControlPoint , DAControlPoint
  • showGraphicsAtPoint()
: APMenu::MenuItemText
, APMenu::MenuItem
, APMenu::MenuItemNull
, APMenu::MenuItemSlider
  • showMainMenuObject() : APMenu::DynamicMenu
  • showMenu()
: vrecko::ControllableAbility
, APMenu::DynamicMenu
  • showMenuWithObjects() : APEditorQAbilities::ObjectAdd
  • showPoint() : CarSim::RoadsState
  • showPointerTrail() : APMenu::DynamicMenu
  • ShowSubBlocks() : ArtificialWorld::BlockUpdater
  • showToolMenu() : APRoomEdit::RoomEditor
  • showTooltip() : APGUI::GUI_Item
  • shutdown() : vreckoDP_base::KeyboardMouse
  • SimpleBox() : APDYNAMICART::SimpleBox
  • simpleCfgCmd() : Hci
  • SimpleObjectMovement() : APEditorQAbilities::SimpleObjectMovement
  • SimpleSetupFunction() : ht::SimpleSetupFunction
  • simpleString() : Hci
  • SimulationParameters() : APDYNAMICART::SimulationParameters
  • singleCollisionTest() : APSpacePartitioning::NoPartitioning_Scene
  • singleReport() : vreckoDP_base::LHeadTracker
  • SIThreadInfo() : base::SystemInfo::SIThreadInfo
  • size()
: APLightsEditor::Lights
, VK_NoStepInto_Namespace::DynamicArray< _Type >
  • SliceTool() : SliceTool
  • Slider() : APGUI::Slider
  • Slider::intersectSegmentandPlane() : APGUI::Slider
  • sliderChanged()
: APDYNAMICART::Brush
, APDYNAMICART::RoundedSplineAdapter
, APDYNAMICART::PoAAdapter< T >
, APDYNAMICART::HoopShape
, APDYNAMICART::GradientDiamAdapter
, APDYNAMICART::ConstantDiamAdapter
  • slowTimeout() : Hci
  • smooth() : APDYNAMICART::PerlinLines
  • SmoothedSpline() : SmoothedSpline
  • snap() : APConnectEditor::ConnectEditor
  • SnapBox() : APEditorQAbilities::ObjectMovement::SnapBox
  • SnapObject() : SnapObject
  • SnapPoint() : APDYNAMICART::SnapPoint
  • SNCH_Object() : APSpacePartitioning::SNCH_Object
  • SNCH_Object_Data() : APSpacePartitioning::SNCH_Object_Data
  • solvePointerSelection() : APMenu::DynamicMenu
  • sortVerticesClockwise()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • SP_Object_Data_Base() : APSpacePartitioning::SP_Object_Data_Base
  • SP_Object_DataInterface() : vrecko::SP_Object_DataInterface
  • SP_ObjectInterface() : vrecko::SP_ObjectInterface
  • SP_SceneInterface() : vrecko::SP_SceneInterface
  • specialKeyPress() : vreckoDP_base::KeyboardMouse
  • specialKeyRelease() : vreckoDP_base::KeyboardMouse
  • Sphere()
: ode::Sphere
, PhysXPlugin::Sphere
, VirtualFixture::Sphere
  • SphereBVH_Object() : APSpacePartitioning::SphereBVH_Object
  • SphereBVH_Object_Data() : APSpacePartitioning::SphereBVH_Object_Data
  • SphereBVH_Scene() : APSpacePartitioning::SphereBVH_Scene
  • SphericalJoint() : PhysXPlugin::SphericalJoint
  • SplineFactory() : APDYNAMICART::SplineFactory
  • splitString() : APDYNAMICART::Utils
  • start()
: vrecko::vThread
, vrecko::Scheduler
  • Start() : Preloader
  • start() : Timing
  • Start() : DynamicTreeIterator< _Type >
  • start1stAnimation() : APCameraPath::Camera
  • startAnimation()
: APObjectUtils::Animator
, APCameraMovement::CameraPath
  • startIteration()
: vrecko::Enumeration< tval, tref >
, vrecko::AttributesDescription
, vrecko::DynamicAttribute
  • startMotion() : Arm
  • startPhysics() : APDYNAMICART::PhysXManager
  • startSimulation() : APDYNAMICART::Ctrl_StringSculptures
  • startThreadedHierarchyCreation() : APSpacePartitioning::SP_Object_Data_Base
  • startTiming() : vrecko::Logger
  • StaticAttribute() : vrecko::StaticAttribute< type, tval, tref >
  • StaticString() : AP_LSystem::StaticString
  • stdCmd() : Hci
  • Step() : mv::CPlayer
  • Step_backward() : mv::CPlayer
  • Step_forward() : mv::CPlayer
  • stop() : vrecko::Scheduler
  • Stop() : Preloader
  • stop() : vrecko::vThread
  • stopAnimation()
: APCameraMovement::CameraPath
, APObjectUtils::Animator
  • stopSimulation() : APDYNAMICART::Ctrl_StringSculptures
  • stopTiming() : vrecko::Logger
  • storeBuffer() : MemoryWriteBuffer , MemoryReadBuffer , UserStream
  • storeByte() : MemoryReadBuffer , UserStream
  • StoreByte() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • storeByte() : MemoryWriteBuffer
  • storeDouble() : MemoryWriteBuffer , MemoryReadBuffer , UserStream
  • storeDword() : MemoryWriteBuffer
  • StoreDWORD() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • storeDword() : MemoryReadBuffer , UserStream
  • storeFloat() : UserStream , MemoryWriteBuffer , MemoryReadBuffer
  • storeSample() : APDYNAMICART::ToolBrush
  • storeWord() : MemoryWriteBuffer , MemoryReadBuffer , UserStream
  • StraightPipe() : AP_LSystem::StraightPipe
  • stringCmd() : Hci
  • StringWithHash() : vrecko::EventDispatcher::StringWithHash
  • StrX() : StrX
  • stylus3DOFbckg() : Arm
  • stylus3DOFmotion() : Arm
  • stylus3DOFupdate() : Arm
  • stylus6DOFbckg() : Arm
  • stylus6DOFmotion() : Arm
  • stylus6DOFupdate() : Arm
  • SubBlock() : ArtificialWorld::SubBlock
  • SubBlockAnimation() : ArtificialWorld::SubBlockAnimation
  • subdivideMesh() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • substitute() : AP_LSystem::AbstractFile
  • Swap()
: VK_NoStepInto_Namespace::DynamicArray< _Type >
, BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
  • SweepSurfaceGeode() : SweepSurfaceGeode
  • switchColorsOnTL() : CarSim::TLsOnJuncManager
  • switchGeode() : AP_LSystem::AbstractInterpret
  • switchGUIVisibility()
: APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Ctrl_MotionVisualization
  • switchHighlighting() : vreckoUtils::HighlightCallback
  • switchLayout() : APGUI::GUI_Controller
  • switchLight() : CarSim::CarExecutionUnit
  • switchRenderingMethod() : APDYNAMICART::BrushStroke
  • switchToLayer() : APDYNAMICART::PolyhedraSculpture
  • switchTools()
: APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_StringSculptures
  • switchVisuals()
: APGUI::Slider
, APGUI::Icon
  • syncEntityVector() : vrecko::vThread
  • SystemInfo() : base::SystemInfo
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- t -

  • tauBasis() : gmMatrix4
  • tensedBSplineBasis() : gmMatrix4
  • terminate()
: APRoomEdit::Tool
, APRoomEdit::PointMove
  • Terrain2D() : APNature::Terrain2D
  • Terrain2DSegment() : APNature::Terrain2DSegment
  • TerrainAbility() : APNature::TerrainAbility
  • TerrainAlgorithm() : APNature::TerrainAlgorithm
  • test() : vreckoDP_base::Wiimote
  • testAndHandleHit() : APShootingSimulation::ShootingSimulation
  • testNodeNorec() : APSpacePartitioning::SNCH_Object
  • testVersionIsAtLeast() : vrecko::PersistentCache
  • textLog() : vrecko::Logger
  • ThinHeap() : ThinHeap< _NodeClass, _keyType >
  • tick()
: vrecko::Timer
, vrecko::Logger
  • time_m() : vrecko::Timer
  • time_n() : vrecko::Timer
  • time_s() : vrecko::Timer
  • time_u() : vrecko::Timer
  • timedOut() : Timing
  • TimeLineSpline() : TimeLineSpline
  • Timer() : vrecko::Timer
  • TimingInfo() : vrecko::Logger::TimingInfo
  • TLsOnJuncManager() : CarSim::TLsOnJuncManager
  • toNxQuat() : APDYNAMICART::PhysXManager
  • toNxVec3() : APDYNAMICART::PhysXManager
  • Tool() : APRoomEdit::Tool
  • ToolBrush() : APDYNAMICART::ToolBrush
  • ToolEraser() : APDYNAMICART::ToolEraser
  • ToolHook() : APDYNAMICART::ToolHook
  • ToolMagicWand() : APDYNAMICART::ToolMagicWand
  • ToolRotation() : APDYNAMICART::ToolRotation
  • ToolSelector() : APDYNAMICART::ToolSelector
  • ToolSlice() : APDYNAMICART::ToolSlice
  • ToolTongs() : APDYNAMICART::ToolTongs
  • toOsgQuat() : APDYNAMICART::PhysXManager
  • toOsgVec3() : APDYNAMICART::PhysXManager
  • top() : AP_LSystem::TurtleStack
  • toRad() : AP_LSystem::AbstractTurtle
  • toString()
: AP_LSystem::LongString
, AP_LSystem::StaticString
  • toXMLString()
: vreckoUtils::IMenuComponent
, vreckoUtils::MenuRoot
, vreckoUtils::Menu
, vreckoUtils::MenuItem
, vreckoUtils::MenuSlider
  • Trace() : VirtualFixture::Trace
  • transcribe()
: AP_LSystem::D0LSystem
, AP_LSystem::LSystem
  • transcribeSubSystems() : AP_LSystem::LSystem
  • transform() : gmMatrix3 , gmMatrix4
  • transformHandPosition() : APGUI::Slider
  • transformToLocalCoord() : APDYNAMICART::PhysXManager
  • transformVectors() : AP_CableEditor::Cable
  • translate()
: AP_LSystem::AbstractLSystem
, AP_LSystem::LSystem
, gmMatrix3
, gmMatrix4
  • translateName() : vrecko::PersistentCache
  • transpose() : gmMatrix4 , gmMatrix3
  • traverse() : SweepSurfaceGeode
  • tReadLine() : vrecko::BufferedFile
  • Triangle() : grass::Triangle
  • triangulate() : MotionTrailTriangulator
  • triDistance() : APSpacePartitioning::SNCH_Object
  • triIntersects() : APSpacePartitioning::SNCH_Object
  • tripleDerivedCRI() : MotionTrailTriangulator
  • triProjectionIntersection() : APSpacePartitioning::SNCH_Object
  • Truncate() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • TryToSendThreadCreatedEvent() : base::SystemInfo
  • turnArround()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • turnLeft()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • turnOff()
: APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolRotation
, MagicWandTool
, MTCreatorTool
, APDYNAMICART::DATool
, APDYNAMICART::Controller
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::ToolEraser
, APDYNAMICART::PLControllerTool
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolBrush
, APDYNAMICART::PLNestTool
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolTongs
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_MotionVisualization
, SliceTool
  • turnOffTool() : APDYNAMICART::Ctrl_MotionVisualization
  • turnOn()
: APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Controller
, APDYNAMICART::PLNestTool
, APDYNAMICART::Ctrl_Attractor
, APDYNAMICART::ToolBrush
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolTongs
, MagicWandTool
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APDYNAMICART::Ctrl_MotionVisualization
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::PLControllerTool
, SliceTool
, APDYNAMICART::ToolSlice
, APDYNAMICART::ToolRotation
, APDYNAMICART::DATool
, MTCreatorTool
, APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolEraser
  • turnOnTool() : APDYNAMICART::Ctrl_MotionVisualization
  • turnRight()
: AP_LSystem::AbstractTurtle
, AP_LSystem::MovingTurtle
  • TurtleInterpret() : AP_LSystem::TurtleInterpret
  • TurtleProperties() : AP_LSystem::TurtleProperties
  • TurtleStack() : AP_LSystem::TurtleStack
  • type() : AP_LSystem::AbstractFile
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- u -

  • Ultratrak() : vreckoDP_base::Ultratrak
  • uncommentLine() : AP_LSystem::StringUtils
  • UNICODECheck() : vrecko::BufferedFile
  • unicodeForm() : vrecko::XercesStr
  • UniformUpdateCallback() : UniformUpdateCallback
  • Union() : FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , BinomialHeap< _NodeClass, _keyType >
  • unlock() : vrecko::MTLock
  • unlockEOMapForRead() : vrecko::Scene
  • unlockEOMapForWrite() : vrecko::Scene
  • unlockHigh() : vrecko::MTTwoPrioLimitedLock
  • unlockLow() : vrecko::MTTwoPrioLimitedLock
  • unlockRead()
: vrecko::MTReadWriteLockEx
, vrecko::MTReadWriteLock
  • unlockWrite()
: vrecko::MTReadWriteLock
, vrecko::MTReadWriteLockEx
  • unregCarForEdge() : CarSim::RoadsState
  • unregisterEnvironmentObject() : vrecko::Scene
  • unregisterGlobalGuiItem() : APGUI::GUI_Controller
  • unregisterOutputNotification() : vrecko::Logger
  • unregisterPointableGuiItem() : APGUI::GUI_Controller
  • unregLastCarForEdge() : CarSim::RoadsState
  • unselectItem() : APMenu::DynamicMenu
  • unsetBounding() : APDYNAMICART::PerlinLines
  • unsetController() : APDYNAMICART::PerlinLines
  • unsetMagnet() : APDYNAMICART::PerlinLines
  • UpdatablePhysXObject() : PhysXPlugin::UpdatablePhysXObject
  • Update() : PreloaderHeuristic
  • update()
: behindO::CuttingPlane
, APGUI::Slider
, ht::HeadTracking
, behindO::EyeManipulator
, APHelloWorld::MyAbility
, APHUD::HUDDisplay
  • Update() : BasicPreloaderHeuristic
  • update()
: behindO::HeadManipulator
, APInputConnector::InputConnector
, APLightsEditor::Editor
, behindO::HMDHeadManipulator
, APMenu::DynamicMenu
, APClouds::Clouds
  • Update() : CloudsManager
  • update()
: behindO::Lens
, grass::Grass
, APNature::TerrainAbility
, behindO::Manipulator
, navigation::AvatarInHand
, navigation::KMTracker
  • Update() : AllCloudsUpdateCallBack
  • update()
: behindO::MappingFunctions
, APObjectUtils::Animator
, APObjectUtils::ConnectionViz
, behindO::Mirror
, APObjectUtils::CopyProperties
, APObjectUtils::KeepOnScreen
  • Update() : PhysXPlugin::ClothDrawable
  • update()
: behindO::WIM
, APObjectUtils::ObjectEffect
, APObjectUtils::ObjectEffectMan
, boids::Boid
, APObjectUtils::ObjectInfo
, APObjectUtils::ObjectModif
  • Update() : PhysXPlugin::FluidDrawable
  • update()
: boids::BoidsLogic
, APObjectUtils::ObjectSelector
, ode::CappedCylinder
, boids::BoidsPlanner
, ode::CompositeObject
, ode::Cube
, base::Avatar
, AP_CableEditor::Cable
, ode::DynamicScene
, ode::Sphere
, AP_CableEditor::CableEditor
, VirtualFixture::VibrationLabelActivator
, VirtualFixture::VibrationLabel
, VirtualFixture::Vibration
, VirtualFixture::Trace
, VirtualFixture::Sphere
, VirtualFixture::ProxiSphere
, APRoomEdit::PointMove
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiBorder
, VirtualFixture::Plane
, PHEffect
, APRoomEdit::RoomEditor
, base::Display
, APCameraMovement::CameraMovementEditor
, VirtualFixture::Marker
, VirtualFixture::Log
, VirtualFixture::Grid
, VirtualFixture::Filter
, VirtualFixture::Drag
, VirtualFixture::Damper
, VirtualFixture::Cylinder
, APRoomEdit::Tool
, VirtualFixture::Box
, VirtualFixture::Border
, VirtualFixture::AxisLock
, VirtualFixture::Avatar
, PhysXPlugin::PhysXScene
, APDYNAMICART::PoB
, APRoomEdit::WallMovement
, APCameraMovement::CameraPath
, LoadingConsole
, vreckoDP_Kinect::Kinect
, vreckoDP_base::Wiimote
, vreckoDP_base::VRPN3DMouse
, vreckoDP_base::Ultratrak
, vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
, APShootingSimulation::ShootingSimulation
, vreckoDP_base::LHeadTracker
, vreckoDP_base::L3DMouse
, vreckoDP_base::KeyboardMouse
, vreckoDP_base::fsPinchGlove
, vreckoDP_base::fdtDataGlove
, APTextOutput::Console
, APSpacePartitioning::NoPartitioning_Scene
, base::hand
, APCameraPath::Camera
, APSpacePartitioning::SP_Object_Data_Base
, APSpacePartitioning::VoxelGrid_Object_Data
, CarSim::CarControlUnit
, base::Light
, CarSim::CarExecutionUnit
, CarSim::Remover
, base::MouseHand
, CarSim::RoadsState
, vreckoDP_base::MicroScribe3D
, CarSim::TLsOnJuncManager
, base::MTMatrixTransform
, APConnectEditor::Cut
, APConnectEditor::Rotation
, base::Rotate
, APConnectEditor::Scale
, Icon
, MTCreatorTool
, APConstrainedMovement::ConstrainedObjectMovement
, base::ShowFDH
, APDYNAMICART::Attractor
, APDYNAMICART::BrushStroke
, base::ShowFDHModel
, APDYNAMICART::Controller
, VirtualFixture::Cone
, APDYNAMICART::Ctrl_Attractor
, base::SystemInfo
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::Ctrl_MotionVisualization
, vrecko::BaseClass
, APDYNAMICART::Ctrl_PerlinLines
, VirtualFixture::MarkerFactory
, APGUI::GUI_Controller
, APGUI::ColorPicker
, ChessPiece
, ChessBoard
, APFFDEditor::EditorLogic
, APEditorQAbilities::SimpleObjectMovement
, VirtualFixture::NavSphere
, APDYNAMICART::Ctrl_PolyhedraSculptures
, APEditorController::EditorController
, vrecko::ControllableAbility
, APDYNAMICART::PoAAdapter< T >
, PHANToMAvatar
, APDYNAMICART::ToolSelector
, APDYNAMICART::ToolRotation
, vrecko::Device
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::ToolBrush
, APDYNAMICART::PolyhedraSculpture
, APDYNAMICART::PoA
, APDYNAMICART::DAEnvironment
, APDYNAMICART::PLMagnetTool
, APDYNAMICART::PLNestTool
, vrecko::EventDispatcher
, APDYNAMICART::HookObject
, VirtualFixture::ProxiCylinder
, APDYNAMICART::HoopTrackerCallback
, vrecko::Logger
, APDYNAMICART::Hoop
, APDYNAMICART::JuliaAttractor
, vrecko::PyAbility
, APDYNAMICART::OrdinaryAttractor
, APDYNAMICART::PerlinLines
, vrecko::Scene
, vrecko::Scheduler
, APDYNAMICART::PLControllerTool
, ArtificialWorld::BlockUpdater
, Cache
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, ArtificialWorld::WorldBuilder
, behindO::AvatarManipulator
, APDYNAMICART::ToolTongs
, BehindObstacleExp_wT
, BehindObstacleExperiment
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, behindO::CentreObjectManipulator
  • Update() : Preloader
  • update()
: behindO::ChangeOfVisibility
, behindO::ContactObjectManipulator
  • updateActor() : APDYNAMICART::Hoop
  • updateActTime()
: APObjectUtils::Animator
, APCameraMovement::CameraPath
  • updateAllFields() : APHUD::HUDDisplay
  • updateAllFieldsPosition() : APHUD::HUDDisplay
  • updateAllWindows() : APHUD::HUDDisplay
  • updateAllWindowsPositions() : APHUD::HUDDisplay
  • updateAnimation()
: APObjectUtils::Animator
, APCameraMovement::CameraPath
  • updateBoundingBox() : APSpacePartitioning::NoPartitioning_Scene
  • updateCarForEdge() : CarSim::RoadsState
  • UpdateCloud() : Cloud
  • UpdateCloudColor() : Cloud
  • UpdateCloudLotRocScale() : Cloud
  • updateColorArray() : SweepSurfaceGeode
  • updateColors() : APDYNAMICART::PS_Face
  • updateControllerPosition() : APDYNAMICART::PerlinLines
  • updateControlPoints() : AP_CableEditor::Cable
  • updateControlSpheresRadius() : AP_CableEditor::Cable
  • updateDataInformation() : APSpacePartitioning::VoxelGrid_Object_Data
  • updateDisplayList() : SnapObject
  • UpdateEnvironmentObject()
: PhysXPlugin::BaseActor
, PhysXPlugin::Cloth
, PhysXPlugin::Fluid
, PhysXPlugin::UpdatablePhysXObject
  • updateField() : APHUD::HUDDisplay
  • updateFields() : APHUD::HUDDisplay
  • updateFieldsPosition() : APHUD::HUDDisplay
  • updateFieldTextColor() : APHUD::HUDDisplay
  • updateGeometry() : SweepSurfaceGeode , APDYNAMICART::PatternsGeode
  • updateGradient() : APHUD::HUDDisplay
  • updateGrid() : APFFDEditor::Grid
  • updateInverseCalc() : APMenu::DynamicMenu
  • updateLocationInDynamic() : ode::DynamicScene
  • updateLocationInNonDynamic() : ode::DynamicScene
  • updateMagnetPosition() : APDYNAMICART::PerlinLines
  • updateMainObjectTransformation() : APMenu::DynamicMenu
  • UpdateMove() : APCameraPath::Camera
  • updateNodeMask() : vrecko::EnvironmentObject
  • updateNormalArray() : SweepSurfaceGeode
  • updateObjectGeometry() : APFFDEditor::EditorLogic
  • UpdatePath() : APCameraPath::Camera
  • updatePoAs() : APDYNAMICART::Ctrl_StringSculptures
  • updatePointerPosition() : APMenu::DynamicMenu
  • updatePosRot() : base::Avatar
  • updatePrimitiveSet() : SweepSurfaceGeode
  • updateSamplePoints()
: APDYNAMICART::Ellipse
, APDYNAMICART::Rectangle
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::Line
  • updateScene() : APDYNAMICART::Ctrl_StringSculptures
  • updateShape() : APEditorQAbilities::ObjectMovement::SnapBox
  • updateSlider() : APGUI::Slider
  • updateSliderGraphicPos() : APMenu::MenuItemSlider
  • updateSpheresPosition() : AP_CableEditor::Cable
  • updateText()
: APMenu::MenuItemSlider
, APMenu::MenuItemText
, APHUD::HUDDisplay
  • updateTool() : APRoomEdit::WallGeometry
  • updateValue() : APHUD::HUDDisplay
  • updateValuesRange() : APHUD::HUDDisplay
  • updateVertexArray() : SweepSurfaceGeode
  • updateWindow() : APHUD::HUDDisplay
  • updateWindowColor() : APHUD::HUDDisplay
  • updateWindowSizeX() : APHUD::HUDDisplay
  • UpperCase() : APNature::TerrainUtility
  • upX()
: AP_LSystem::QueryInterpret
, AP_LSystem::Query
  • upY()
: AP_LSystem::QueryInterpret
, AP_LSystem::Query
  • upZ()
: AP_LSystem::Query
, AP_LSystem::QueryInterpret
  • UserStream() : UserStream
  • UseToEvent() : APObjectUtils::UseToEvent
  • UseTrigger() : APEditorQAbilities::UseTrigger
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- v -

  • valid() : osgQ::QSection
  • valueChanged() : APDYNAMICART::Attractor
  • valuesCount() : vrecko::Enumeration< tval, tref >
  • VariableFloat() : ht::VariableFloat
  • VariableQuat() : ht::VariableQuat
  • VariableVec2() : ht::VariableVec2
  • VariableVec3() : ht::VariableVec3
  • vdebugFileLog() : vrecko::Logger
  • vdebugFlush() : vrecko::Logger
  • vdebugLog() : vrecko::Logger
  • verrorLog() : vrecko::Logger
  • Vertex() : grass::Vertex
  • vertexImportance() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • Vibration() : VirtualFixture::Vibration
  • VibrationLabel() : VirtualFixture::VibrationLabel
  • VibrationLabelActivator() : VirtualFixture::VibrationLabelActivator
  • Viewer() : vrecko::Viewer
  • viewMenu() : APCameraMovement::CameraMovementEditor
  • viewMoved() : APMenu::DynamicMenu
  • visualizeControlPoints() : APDYNAMICART::BrushStroke
  • visualizeVectors() : AP_CableEditor::Cable
  • vnoticeLog() : vrecko::Logger
  • VoxelGrid_Object_Data() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::getCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::increaseVoxelValueCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VoxelGrid_Object_Data::setVoxelValueCollisions() : APSpacePartitioning::VoxelGrid_Object_Data
  • VreckoMessage() : vrecko::VreckoMessage
  • VRPN3DMouse() : vreckoDP_base::VRPN3DMouse
  • VRPN3DMouse::sendAnalogEvent() : vreckoDP_base::VRPN3DMouse
  • VRPN3DMouse::sendButtonEvent() : vreckoDP_base::VRPN3DMouse
  • vtextLog() : vrecko::Logger
  • vThread() : vrecko::vThread
  • vwarningLog() : vrecko::Logger
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- w -

  • waitPacket() : Hci
  • WallAdd() : APRoomEdit::WallAdd
  • WallGeometry() : APRoomEdit::WallGeometry
  • WallMovement() : APRoomEdit::WallMovement
  • WallRemove() : APRoomEdit::WallRemove
  • warningLog()
: vrecko::Logger
, vrecko::World
  • WavefrontObj() : WavefrontObj
  • WaveSplineAdapter() : APDYNAMICART::WaveSplineAdapter
  • wdsInfoRec() : APSpacePartitioning::SNCH_Object_Data
  • Weather() : APWeather::Weather
  • WG_Geometry() : WGeometry::WG_Geometry
  • WG_Hole() : WGeometry::WG_Hole
  • WG_Point() : WGeometry::WG_Point
  • WG_Vertices() : WGeometry::WG_Vertices
  • WG_Wall() : WGeometry::WG_Wall
  • what() : AP_LSystem::LSystemException
  • WhatIsSet() : ArtificialWorld::BlockAttributes
  • Width() : APNature::Terrain2DSegment
  • Wiimote() : vreckoDP_base::Wiimote
  • WIM() : behindO::WIM
  • wordLength() : AP_LSystem::LSystem
  • World() : vrecko::World
  • WorldBuilder() : ArtificialWorld::WorldBuilder
  • wrap() : AP_CableEditor::Cable
  • wrapCable() : AP_CableEditor::Cable
  • write() : vrecko::BufferedFileWrite , ConstraintHierarchyMember , AP_LSystem::Log
  • writeAll() : AP_LSystem::Configuration
  • writeBMCounter() : vrecko::Logger
  • writeBMCounterLowLevel() : vrecko::Logger
  • writeBool() : vrecko::BufferedFileWrite
  • writeByte() : vrecko::BufferedFileWrite
  • writeChar() : Serial
  • writeCounter() : vrecko::BenchmarkWriter
  • writeDataEnd() : vrecko::BenchmarkWriter
  • writeDataStart() : vrecko::BenchmarkWriter
  • writeDebugStatistics() : APSpacePartitioning::SNCH_Object_Data
  • writeDWORD() : vrecko::BufferedFileWrite
  • writeEdge()
: APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • writeFloat() : vrecko::BufferedFileWrite
  • writeFormattedString() : vrecko::BufferedFileWrite
  • writeFrameEnd() : vrecko::BenchmarkWriter
  • writeFramesRendered() : vrecko::BenchmarkWriter
  • writeFrameStart() : vrecko::BenchmarkWriter
  • writeInfo()
: APConstrainedMovement::ConstraintDescription
, AP_CableEditor::CableEditor
, APConstrainedMovement::ConstraintArea
  • writeInfoEnd() : vrecko::BenchmarkWriter
  • writeInfoLine() : vrecko::BenchmarkWriter
  • writeInfoStart() : vrecko::BenchmarkWriter
  • writeInt() : vrecko::BufferedFileWrite
  • writeInt64() : vrecko::BufferedFileWrite
  • writeLONG() : vrecko::BufferedFileWrite
  • writeMiscStatsEnd() : vrecko::BenchmarkWriter
  • writeMiscStatsStart() : vrecko::BenchmarkWriter
  • writeObjectFullMatrix() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectPosition() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectPositionsAndRotations() : APConstrainedMovement::ConstrainedObjectMovement
  • writeObjectRotation() : APConstrainedMovement::ConstrainedObjectMovement
  • writeParam() : vrecko::BenchmarkWriter
  • writePOINT() : vrecko::BufferedFileWrite
  • writePolygon()
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry
  • writeRECT() : vrecko::BufferedFileWrite
  • writeRunTime() : vrecko::BenchmarkWriter
  • writeSettingsEnd() : vrecko::BenchmarkWriter
  • writeSettingsStart() : vrecko::BenchmarkWriter
  • writeStr() : vrecko::BufferedFileWrite
  • writeString() : Serial
  • writeVec3f() : vrecko::BufferedFileWrite
  • writeVertex()
: APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_Geometry
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • writeWORD() : vrecko::BufferedFileWrite
  • writingAllowed() : vrecko::BenchmarkWriter
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- x -

  • XercesStr() : vrecko::XercesStr
  • XmlFile() : AP_LSystem::XmlFile
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- z -

  • Zero() : APNature::TerrainAlgorithm
  • zeroRotation() : osgQ::QSection
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • z
  • ~

- ~ -

  • ~A3DBird() : vreckoDP_base::A3DBird
  • ~Ability() : vrecko::Ability
  • ~AbilityDispatcher() : vrecko::AbilityDispatcher
  • ~AbilityEditor() : APEditorQAbilities::AbilityEditor
  • ~AbilityMapper() : APEditorController::AbilityMapper
  • ~AbstractGenerator() : AP_LSystem::AbstractGenerator
  • ~Animator() : APObjectUtils::Animator
  • ~AnimatorEditor() : APEditorQAbilities::AnimatorEditor
  • ~AttributesDescription() : vrecko::AttributesDescription
  • ~Avatar()
: base::Avatar
, VirtualFixture::Avatar
  • ~AvatarInHand() : navigation::AvatarInHand
  • ~AvatarManipulator() : behindO::AvatarManipulator
  • ~AvatarMovement() : APEditorQAbilities::AvatarMovement
  • ~AxisLock() : VirtualFixture::AxisLock
  • ~BaseActor() : PhysXPlugin::BaseActor
  • ~BaseClass() : vrecko::BaseClass
  • ~BaseJoint() : PhysXPlugin::BaseJoint
  • ~BCLoaderErrorHandler() : BCLoaderErrorHandler
  • ~BehindObstacleExp_wT() : BehindObstacleExp_wT
  • ~BehindObstacleExperiment() : BehindObstacleExperiment
  • ~BenchmarkWriter() : vrecko::BenchmarkWriter
  • ~BinomialHeap() : BinomialHeap< _NodeClass, _keyType >
  • ~BlockUpdater() : ArtificialWorld::BlockUpdater
  • ~Boid() : boids::Boid
  • ~BoidsLogic() : boids::BoidsLogic
  • ~BoidsPlanner() : boids::BoidsPlanner
  • ~Border() : VirtualFixture::Border
  • ~Box()
: PhysXPlugin::Box
, VirtualFixture::Box
  • ~Brush() : APDYNAMICART::Brush
  • ~BrushStroke() : APDYNAMICART::BrushStroke
  • ~BrushStrokeControlPoint() : APDYNAMICART::BrushStrokeControlPoint
  • ~BufferedFile() : vrecko::BufferedFile
  • ~BufferedFileWrite() : vrecko::BufferedFileWrite
  • ~Cable() : AP_CableEditor::Cable
  • ~CableEditor() : AP_CableEditor::CableEditor
  • ~Cache() : Cache
  • ~CacheInfo() : CacheInfo
  • ~Camera() : APCameraPath::Camera
  • ~CameraMovementEditor() : APCameraMovement::CameraMovementEditor
  • ~CameraPath() : APCameraMovement::CameraPath
  • ~CappedCylinder() : ode::CappedCylinder
  • ~Capsule() : PhysXPlugin::Capsule
  • ~CarControlUnit() : CarSim::CarControlUnit
  • ~CarExecutionUnit() : CarSim::CarExecutionUnit
  • ~CarPartsNodeCache() : CarSim::CarPartsNodeCache
  • ~CCollection() : mv::CCollection
  • ~CentreObjectManipulator() : behindO::CentreObjectManipulator
  • ~CGesture() : mv::CGesture
  • ~ChangeOfVisibility() : behindO::ChangeOfVisibility
  • ~ChessBoard() : ChessBoard
  • ~ChessPiece() : ChessPiece
  • ~Cloth() : PhysXPlugin::Cloth
  • ~ClothDrawable() : PhysXPlugin::ClothDrawable
  • ~Clouds() : APClouds::Clouds
  • ~CloudsManager() : CloudsManager
  • ~CMVect() : mv::CMVect
  • ~CollisionInfo() : vrecko::CollisionInfo
  • ~ColorBucket() : APRoomEdit::ColorBucket
  • ~ColorPicker() : APGUI::ColorPicker
  • ~CompositeObject() : ode::CompositeObject
  • ~Cone() : VirtualFixture::Cone
  • ~ConnectEditor() : APConnectEditor::ConnectEditor
  • ~ConnectionViz() : APObjectUtils::ConnectionViz
  • ~Console() : APTextOutput::Console
  • ~ConstrainedObjectMovement() : APConstrainedMovement::ConstrainedObjectMovement
  • ~ConstraintArea() : APConstrainedMovement::ConstraintArea
  • ~ConstraintDescription() : APConstrainedMovement::ConstraintDescription
  • ~ConstraintHierarchyMember() : ConstraintHierarchyMember
  • ~ContactObjectManipulator() : behindO::ContactObjectManipulator
  • ~ControllableAbility() : vrecko::ControllableAbility
  • ~Controller() : APDYNAMICART::Controller
  • ~CPlayer() : mv::CPlayer
  • ~CreateHole() : APRoomEdit::CreateHole
  • ~Ctrl_FreeHandPainting() : APDYNAMICART::Ctrl_FreeHandPainting
  • ~Ctrl_MotionVisualization() : APDYNAMICART::Ctrl_MotionVisualization
  • ~Ctrl_PolyhedraSculptures() : APDYNAMICART::Ctrl_PolyhedraSculptures
  • ~Ctrl_StringSculptures() : APDYNAMICART::Ctrl_StringSculptures
  • ~Cube() : ode::Cube
  • ~CubicInterpolator() : CubicInterpolator
  • ~Cut() : APConnectEditor::Cut
  • ~CuttingPlane() : behindO::CuttingPlane
  • ~Cylinder() : VirtualFixture::Cylinder
  • ~DAControlPoint() : DAControlPoint
  • ~DAEnvironment() : APDYNAMICART::DAEnvironment
  • ~DAGizmo() : APDYNAMICART::DAGizmo , DAGizmo
  • ~Damper() : VirtualFixture::Damper
  • ~DATool() : APDYNAMICART::DATool
  • ~Device() : vrecko::Device
  • ~DeviceManager() : vrecko::DeviceManager
  • ~Display() : base::Display
  • ~Drag() : VirtualFixture::Drag
  • ~DynamicArray() : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • ~DynamicAttribute() : vrecko::DynamicAttribute
  • ~DynamicMenu() : APMenu::DynamicMenu
  • ~DynamicScene() : ode::DynamicScene
  • ~DynamicTree() : DynamicTree< _Type >
  • ~ECPOINTERBUTTONINFO() : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • ~ECPOINTERINFO() : APEditorController::EditorController::ECPOINTERINFO
  • ~Editor() : APLightsEditor::Editor
  • ~EditorController() : APEditorController::EditorController
  • ~EditorLogic() : APFFDEditor::EditorLogic
  • ~EnvironmentObject() : vrecko::EnvironmentObject
  • ~EOIteratorHelper() : vrecko::Scene::EOIteratorHelper
  • ~EventDispatcher() : vrecko::EventDispatcher
  • ~EyeManipulator() : behindO::EyeManipulator
  • ~fdtDataGlove() : vreckoDP_base::fdtDataGlove
  • ~FibonacciHeap() : FibonacciHeap< _NodeClass, _keyType >
  • ~Filter() : VirtualFixture::Filter
  • ~filter1() : filter1
  • ~filter2() : filter2
  • ~Fluid() : PhysXPlugin::Fluid
  • ~FluidDrawable() : PhysXPlugin::FluidDrawable
  • ~ForceField() : PhysXPlugin::ForceField
  • ~FrenetFrame() : FrenetFrame
  • ~fsPinchGlove() : vreckoDP_base::fsPinchGlove
  • ~GeometryLoader() : APFFDEditor::GeometryLoader
  • ~GeometryLoaderBase()
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
  • ~Grass() : grass::Grass
  • ~GrassAbilityParameters() : grass::GrassAbilityParameters
  • ~GrassDrawable() : grass::GrassDrawable
  • ~Grid()
: APFFDEditor::Grid
, VirtualFixture::Grid
  • ~GUI_Controller() : APGUI::GUI_Controller
  • ~GUI_Item() : APGUI::GUI_Item
  • ~GUI_Text() : APGUI::GUI_Text
  • ~hand() : base::hand
  • ~HeadManipulator() : behindO::HeadManipulator
  • ~HeadTracking() : ht::HeadTracking
  • ~HermitPipe() : AP_LSystem::HermitPipe
  • ~HMDHeadManipulator() : behindO::HMDHeadManipulator
  • ~HoleRemove() : APRoomEdit::HoleRemove
  • ~HoopShape() : APDYNAMICART::HoopShape
  • ~HUDDisplay() : APHUD::HUDDisplay
  • ~IComputeStrategy() : APDYNAMICART::IComputeStrategy
  • ~Icon() : APGUI::Icon , Icon
  • ~IconColour() : APGUI::IconColour
  • ~IMenuComponent() : vreckoUtils::IMenuComponent
  • ~InPlaceParser() : WAVEFRONT::InPlaceParser
  • ~InputConnector() : APInputConnector::InputConnector
  • ~InputPin() : vrecko::InputPin< _MessageType >
  • ~Interpolator() : Interpolator
  • ~IParameters() : APDYNAMICART::IParameters
  • ~IShapeGenerator() : APDYNAMICART::IShapeGenerator
  • ~ItemsGroup() : APGUI::ItemsGroup
  • ~JointedPipe() : AP_LSystem::JointedPipe
  • ~KeepOnScreen() : APObjectUtils::KeepOnScreen
  • ~KeyboardMouse() : vreckoDP_base::KeyboardMouse
  • ~KMTracker() : navigation::KMTracker
  • ~L3DMouse() : vreckoDP_base::L3DMouse
  • ~Layout() : APGUI::Layout
  • ~Lens() : behindO::Lens
  • ~LHeadTracker() : vreckoDP_base::LHeadTracker
  • ~Light() : base::Light
  • ~Lights() : APLightsEditor::Lights
  • ~Linear() : Filter::Linear
  • ~LoadingConsole() : LoadingConsole
  • ~LoftTurtle() : AP_LSystem::LoftTurtle
  • ~Log() : VirtualFixture::Log
  • ~Logger() : vrecko::Logger
  • ~LongString() : AP_LSystem::LongString
  • ~LSObject() : AP_LSystem::LSObject
  • ~LSystem() : AP_LSystem::LSystem
  • ~LSystemException() : AP_LSystem::LSystemException
  • ~LSystemGenerator() : AP_LSystem::LSystemGenerator
  • ~MagicWandTool() : MagicWandTool
  • ~MainObject() : MainObject
  • ~Manipulator() : behindO::Manipulator
  • ~MappingFunctions() : behindO::MappingFunctions
  • ~Marker() : VirtualFixture::Marker
  • ~MarkerFactory() : VirtualFixture::MarkerFactory
  • ~MemoryReadBuffer() : MemoryReadBuffer
  • ~MemoryWriteBuffer() : MemoryWriteBuffer
  • ~Menu() : APGUI::Menu
  • ~MenuItem() : APMenu::MenuItem
  • ~MenuItemSlider() : APMenu::MenuItemSlider
  • ~MenuItemText() : APMenu::MenuItemText
  • ~MenuLoaderErrorHandler() : APMenu::MenuLoaderErrorHandler
  • ~MenuVisitor() : vreckoUtils::MenuVisitor
  • ~Mesh() : grass::Mesh
  • ~MicroScribe3D() : vreckoDP_base::MicroScribe3D
  • ~Mirror() : behindO::Mirror
  • ~Mode() : APDYNAMICART::Mode
  • ~Model() : ArtificialWorld::Model
  • ~MotionTrail() : APDYNAMICART::MotionTrail
  • ~MotionTrailTriangulator() : MotionTrailTriangulator
  • ~MouseHand() : base::MouseHand
  • ~MTAutoLock() : vrecko::MTAutoLock
  • ~MTBrush() : MTBrush
  • ~MTCreatorTool() : MTCreatorTool
  • ~MTLock() : vrecko::MTLock
  • ~MTMatrixTransform() : base::MTMatrixTransform
  • ~MTReadWriteLock() : vrecko::MTReadWriteLock
  • ~MTReadWriteLockEx() : vrecko::MTReadWriteLockEx
  • ~MTTwoPrioLimitedLock() : vrecko::MTTwoPrioLimitedLock
  • ~MyAbility() : APHelloWorld::MyAbility
  • ~NavSphere() : VirtualFixture::NavSphere
  • ~NestOfBirds() : vreckoDP_base::NestOfBirds
  • ~NoPartitioning_Scene() : APSpacePartitioning::NoPartitioning_Scene
  • ~ObjectAdd() : APEditorQAbilities::ObjectAdd
  • ~ObjectDelete() : APEditorQAbilities::ObjectDelete
  • ~ObjectEffect() : APObjectUtils::ObjectEffect
  • ~ObjectEffectMan() : APObjectUtils::ObjectEffectMan
  • ~ObjectInfo() : APObjectUtils::ObjectInfo
  • ~ObjectModif() : APObjectUtils::ObjectModif
  • ~ObjectMovement() : APEditorQAbilities::ObjectMovement
  • ~ObjectSelector() : APObjectUtils::ObjectSelector
  • ~OctTree() : vrecko::OctTree
  • ~OpenedCacheFile() : vrecko::PersistentCache::OpenedCacheFile
  • ~Optimalizer() : APConnectEditor::Optimalizer
  • ~OptiTrack() : vreckoDP_base::OptiTrack
  • ~OutputPin() : vrecko::OutputPin< _MessageType >
  • ~PatternBase() : APDYNAMICART::PatternBase
  • ~PerlinLines() : APDYNAMICART::PerlinLines
  • ~PersistentCache() : vrecko::PersistentCache
  • ~PHANToMAvatar() : PHANToMAvatar
  • ~PHEffect() : PHEffect
  • ~PhysXObject() : PhysXPlugin::PhysXObject
  • ~PhysXScene() : PhysXPlugin::PhysXScene
  • ~Plane()
: PhysXPlugin::Plane
, VirtualFixture::Plane
  • ~PLControllerTool() : APDYNAMICART::PLControllerTool
  • ~PLMagnetTool() : APDYNAMICART::PLMagnetTool
  • ~PLNestTool() : APDYNAMICART::PLNestTool
  • ~PluginManager() : vrecko::PluginManager
  • ~PoA() : APDYNAMICART::PoA
  • ~PoAAdapter() : APDYNAMICART::PoAAdapter< T >
  • ~PoB() : APDYNAMICART::PoB
  • ~PointAdd() : APRoomEdit::PointAdd
  • ~PointMove() : APRoomEdit::PointMove
  • ~PointShell_Object_Data() : APSpacePartitioning::PointShell_Object_Data
  • ~PointShell_Object_Data_Geometry() : APSpacePartitioning::PointShell_Object_Data_Geometry
  • ~PointShell_Object_Data_Geometry_Analyser() : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • ~PointShell_Object_Data_LOD_Builder() : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • ~PointShellGeneric_Object_Data() : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • ~PointShellVSVoxel_Object() : APSpacePartitioning::PointShellVSVoxel_Object
  • ~PolygonState() : APConnectEditor::PolygonState
  • ~PosNoiseRemover() : Filter::PosNoiseRemover
  • ~Preloader() : Preloader
  • ~PreloaderHeuristic() : PreloaderHeuristic
  • ~ProxiBorder() : VirtualFixture::ProxiBorder
  • ~ProxiBox() : VirtualFixture::ProxiBox
  • ~ProxiCone() : VirtualFixture::ProxiCone
  • ~ProxiCylinder() : VirtualFixture::ProxiCylinder
  • ~ProxiSphere() : VirtualFixture::ProxiSphere
  • ~PyAbility() : vrecko::PyAbility
  • ~QConstShapeVisitor() : osgQ::QConstShapeVisitor
  • ~QSection() : osgQ::QSection
  • ~QShapeVisitor() : osgQ::QShapeVisitor
  • ~QueryTurtle() : AP_LSystem::QueryTurtle
  • ~Reader() : mv::Reader
  • ~ReaderWriter() : vrecko::ReaderWriter
  • ~Rectangle() : AP_LSystem::Rectangle
  • ~RemoteDebugger() : PhysXPlugin::RemoteDebugger
  • ~Remover() : CarSim::Remover
  • ~RequestInputPin() : vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • ~RequestOutputPin() : vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • ~RoadsState() : CarSim::RoadsState
  • ~RoomEditor() : APRoomEdit::RoomEditor
  • ~RoomLoader() : APRoomEdit::RoomLoader
  • ~RoomSaver() : APRoomEdit::RoomSaver
  • ~Rotate() : base::Rotate
  • ~Rotation() : APConnectEditor::Rotation
  • ~Rule() : AP_LSystem::Rule
  • ~RWErrorHandler() : vrecko::RWErrorHandler
  • ~Scale() : APConnectEditor::Scale
  • ~Scene() : vrecko::Scene
  • ~SceneSave() : APEditorQAbilities::SceneSave
  • ~Scheduler() : vrecko::Scheduler
  • ~ScreenSetup() : ht::ScreenSetup
  • ~ScreenSetupSimple() : ht::ScreenSetupSimple
  • ~Sector() : Sector
  • ~ShootingSimulation() : APShootingSimulation::ShootingSimulation
  • ~ShowFDH() : base::ShowFDH
  • ~ShowFDHModel() : base::ShowFDHModel
  • ~SimpleBox() : APDYNAMICART::SimpleBox
  • ~SimpleObjectMovement() : APEditorQAbilities::SimpleObjectMovement
  • ~SliceTool() : SliceTool
  • ~Slider() : APGUI::Slider
  • ~SnapBox() : APEditorQAbilities::ObjectMovement::SnapBox
  • ~SnapObject() : SnapObject
  • ~SNCH_Object() : APSpacePartitioning::SNCH_Object
  • ~SNCH_Object_Data() : APSpacePartitioning::SNCH_Object_Data
  • ~SP_Object_Data_Base() : APSpacePartitioning::SP_Object_Data_Base
  • ~SP_Object_DataInterface() : vrecko::SP_Object_DataInterface
  • ~SP_ObjectInterface() : vrecko::SP_ObjectInterface
  • ~SP_SceneInterface() : vrecko::SP_SceneInterface
  • ~Sphere()
: ode::Sphere
, PhysXPlugin::Sphere
, VirtualFixture::Sphere
  • ~SphereBVH_Object() : APSpacePartitioning::SphereBVH_Object
  • ~SphereBVH_Object_Data() : APSpacePartitioning::SphereBVH_Object_Data
  • ~SphereBVH_Scene() : APSpacePartitioning::SphereBVH_Scene
  • ~StaticAttribute() : vrecko::StaticAttribute< type, tval, tref >
  • ~StaticString() : AP_LSystem::StaticString
  • ~StraightPipe() : AP_LSystem::StraightPipe
  • ~StrX() : StrX
  • ~SubBlock() : ArtificialWorld::SubBlock
  • ~SubBlockAnimation() : ArtificialWorld::SubBlockAnimation
  • ~SystemInfo() : base::SystemInfo
  • ~Terrain2D() : APNature::Terrain2D
  • ~Terrain2DSegment() : APNature::Terrain2DSegment
  • ~TerrainAbility() : APNature::TerrainAbility
  • ~TerrainAlgorithm() : APNature::TerrainAlgorithm
  • ~Timer() : vrecko::Timer
  • ~TLsOnJuncManager() : CarSim::TLsOnJuncManager
  • ~Tool() : APRoomEdit::Tool
  • ~ToolBrush() : APDYNAMICART::ToolBrush
  • ~ToolEraser() : APDYNAMICART::ToolEraser
  • ~ToolTongs() : APDYNAMICART::ToolTongs
  • ~Trace() : VirtualFixture::Trace
  • ~TurtleInterpret() : AP_LSystem::TurtleInterpret
  • ~TurtleStack() : AP_LSystem::TurtleStack
  • ~Ultratrak() : vreckoDP_base::Ultratrak
  • ~UpdatablePhysXObject() : PhysXPlugin::UpdatablePhysXObject
  • ~UserStream() : UserStream
  • ~UseToEvent() : APObjectUtils::UseToEvent
  • ~UseTrigger() : APEditorQAbilities::UseTrigger
  • ~Variable() : ht::Variable
  • ~Vibration() : VirtualFixture::Vibration
  • ~VibrationLabel() : VirtualFixture::VibrationLabel
  • ~VibrationLabelActivator() : VirtualFixture::VibrationLabelActivator
  • ~VoxelGrid_Object_Data() : APSpacePartitioning::VoxelGrid_Object_Data
  • ~VreckoMessage() : vrecko::VreckoMessage
  • ~vThread() : vrecko::vThread
  • ~WallAdd() : APRoomEdit::WallAdd
  • ~WallGeometry() : APRoomEdit::WallGeometry
  • ~WallMovement() : APRoomEdit::WallMovement
  • ~WallRemove() : APRoomEdit::WallRemove
  • ~WavefrontObj() : WavefrontObj
  • ~WG_Geometry() : WGeometry::WG_Geometry
  • ~WG_Hole() : WGeometry::WG_Hole
  • ~WG_Point() : WGeometry::WG_Point
  • ~WG_Vertices() : WGeometry::WG_Vertices
  • ~WG_Wall() : WGeometry::WG_Wall
  • ~Wiimote() : vreckoDP_base::Wiimote
  • ~WIM() : behindO::WIM
  • ~World() : vrecko::World
  • ~WorldBuilder() : ArtificialWorld::WorldBuilder
  • ~XercesStr() : vrecko::XercesStr
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- _ -

  • _a : APDYNAMICART::Ellipse
  • _actionMap : APInputConnector::InputConnector
  • _active_contact : vreckoDP_base::fsPinchGlove
  • _activeLayer : APDYNAMICART::PolyhedraSculpture
  • _activeSensor : APGUI::Menu
  • _actor : APDYNAMICART::Hoop , PhysXPlugin::MessageNxActorWithName
  • _actorDesc : PhysXPlugin::BaseActor
  • _actual_head_orientation : navigation::AvatarInHand
  • _actual_head_position : navigation::AvatarInHand
  • _actual_left_hand_orientation : navigation::AvatarInHand
  • _actual_left_hand_position : navigation::AvatarInHand
  • _actual_position
: navigation::KMTracker
, base::hand
, base::MouseHand
, navigation::AvatarInHand
  • _actual_right_hand_orientation : navigation::AvatarInHand
  • _actual_right_hand_position : navigation::AvatarInHand
  • _actual_rotation : base::hand , base::MouseHand
  • _actualLayout : APGUI::GUI_Controller
  • _actualPositions : APGUI::GUI_Controller
  • _actualTool : APDYNAMICART::Controller
  • _adapters : APDYNAMICART::AdapterFactory< T >
  • _advanced : APDYNAMICART::Ctrl_StringSculptures
  • _alwaysInMiddle : APGUI::ColorPicker
  • _angleFrom : osgQ::QSection
  • _angleTo : osgQ::QSection
  • _array : SampledSpline , APDYNAMICART::Line , APDYNAMICART::PatternBase , BufferedSpline
  • _arraySize : APDYNAMICART::ToolSelector
  • _artArea : APDYNAMICART::Controller
  • _attachment_ids : PhysXPlugin::Cloth
  • _attributes : vreckoUtils::MenuRoot
  • _avatarMovement : navigation::KMTracker
  • _axis : APDYNAMICART::Hoop , APDYNAMICART::ToolHook
  • _axisControl : vreckoDP_base::VRPN3DMouse
  • _b : APDYNAMICART::Ellipse
  • _baseAxis : APDYNAMICART::ToolRotation
  • _basic : APDYNAMICART::Ctrl_StringSculptures
  • _bb : osgQ::QComputeBoundShapeVisitor
  • _bDynamicActorOutputs : PhysXPlugin::BaseActor
  • _bIsLoaded : vrecko::Scene
  • _blue : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _bodyDesc : PhysXPlugin::BaseActor
  • _boundingCreated : APDYNAMICART::PerlinLines
  • _boundingSize : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _boundingUsed : APDYNAMICART::PerlinLines
  • _boundingVisible : APDYNAMICART::PerlinLines
  • _boxColorArray : APDYNAMICART::PerlinLines
  • _boxDesc : PhysXPlugin::Box
  • _boxGeode : APDYNAMICART::PerlinLines
  • _boxMaterial : APDYNAMICART::PerlinLines
  • _boxOSGState : APDYNAMICART::PerlinLines
  • _brush
: APDYNAMICART::BrushStroke
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolBrush
, APDYNAMICART::HoopGeometry
  • _bst : APDYNAMICART::HoopGeometry
  • _buf : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • _capsuleDesc : PhysXPlugin::Capsule
  • _center : osgQ::QSection , APDYNAMICART::SnapPoint
  • _center_position : behindO::Mirror
  • _cfg_file : vrecko::ReaderWriter
  • _cfg_path : vrecko::ReaderWriter
  • _CFM : ode::DynamicScene
  • _changedBlue : APDYNAMICART::PerlinLines
  • _changedGreen : APDYNAMICART::PerlinLines
  • _changedRed : APDYNAMICART::PerlinLines
  • _closed : BufferedSpline , SampledSpline
  • _closedPattern : APDYNAMICART::Ctrl_StringSculptures
  • _clothDesc : PhysXPlugin::Cloth
  • _clothMeshDesc : PhysXPlugin::Cloth
  • _color : vreckoUtils::MenuItem , vreckoUtils::MenuSlider , ConstantColorGen
  • _colorEnd : GradientColorGen
  • _colorGen
: APDYNAMICART::ConstantColorAdapter
, APDYNAMICART::GradientColorAdapter
, APDYNAMICART::Hoop
, SweepSurfaceGeode
  • _colorGenAdapterName : APDYNAMICART::Brush
  • _colorGenFactory : APDYNAMICART::Brush
  • _colorIndex : APDYNAMICART::ColorGenAdapter
  • _colors : APDYNAMICART::ComputeThread
  • _colorStart : GradientColorGen
  • _colour : APGUI::IconColour
  • _colourActive : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourDefault : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourDisabled : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourHovered : APGUI::GUI_Controller , APGUI::GUI_Item
  • _colourPressed : APGUI::GUI_Controller , APGUI::GUI_Item
  • _component : APDYNAMICART::PS_Layer
  • _computedStrokeStartTime : APDYNAMICART::BrushStroke
  • _conf : APDYNAMICART::ComputeThread
  • _contact_count : vreckoDP_base::fsPinchGlove
  • _contact_group : ode::DynamicScene
  • _contr
: APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PolyhedraSculpture
  • _controller : APDYNAMICART::PoA , APGUI::GUI_Item
  • _controllerCoords : APDYNAMICART::PerlinLines
  • _controllerUsed : APDYNAMICART::PerlinLines
  • _coreActorDesc : PhysXPlugin::Cloth
  • _crossSection : APDYNAMICART::HoopGeometry
  • _crossSectionAdapterName : APDYNAMICART::Brush
  • _crossSectionArray : SweepSurfaceGeode
  • _crossSectionFactory : APDYNAMICART::Brush
  • _crossSectionInterpolationSteps : APDYNAMICART::Brush
  • _crossSectionSpline : APDYNAMICART::Hoop , SweepSurfaceGeode
  • _curMove : vreckoDP_base::VRPN3DMouse
  • _current_pos : base::MouseHand , base::hand
  • _current_type : vreckoDP_base::fsPinchGlove
  • _currentRotation : APDYNAMICART::Hoop
  • _currentTransform : APDYNAMICART::Hoop
  • _curRotate : vreckoDP_base::VRPN3DMouse
  • _cursor : APDYNAMICART::DATool
  • _DAAOrientation
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _DAAposition
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _daArea : APDYNAMICART::DATool , APDYNAMICART::PerlinLines
  • _daAreaOrientation : APDYNAMICART::ToolTongs
  • _daAreaPosition : APDYNAMICART::ToolTongs
  • _daAreaScale : APDYNAMICART::ToolTongs
  • _DAAScale
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _daEnvironment
: APDYNAMICART::Controller
, APDYNAMICART::DATool
, APDYNAMICART::PoA
  • _data : ode::CompositeObject
  • _debugButtonPressed : APGUI::GUI_Controller
  • _debugButtonReleased : APGUI::GUI_Controller
  • _defaultColor : APDYNAMICART::Ctrl_StringSculptures , SectorColorGen
  • _defaultPattern : APDYNAMICART::Ctrl_StringSculptures
  • _defaultPatternName : APDYNAMICART::SectorManager
  • _defaultStateActive : APGUI::GUI_Item
  • _deltaTime : APDYNAMICART::PhysXManager
  • _density
: ode::CappedCylinder
, ode::CompositeObject::Data
, ode::Cube
, ode::Sphere
  • _descripter
: PhysXPlugin::CylindricalJoint
, PhysXPlugin::DistanceJoint
, PhysXPlugin::FixedJoint
, PhysXPlugin::PointInPlaneJoint
, PhysXPlugin::PointOnLineJoint
, PhysXPlugin::PrismaticJoint
, PhysXPlugin::PulleyJoint
, PhysXPlugin::RevoluteJoint
, PhysXPlugin::SphericalJoint
  • _description : APDYNAMICART::Controller
  • _detail : APDYNAMICART::Ellipse , APDYNAMICART::ElongatedCircle
  • _diameterEnd : GradientDiameterGen
  • _diameterGen : SweepSurfaceGeode
  • _diameterGenerator : APDYNAMICART::Hoop
  • _diameters : SweepSurfaceGeode
  • _diameterStart : GradientDiameterGen
  • _diamGen : APDYNAMICART::ConstantDiamAdapter , APDYNAMICART::GradientDiamAdapter
  • _diamGenAdapterName : APDYNAMICART::Brush
  • _diamGenFactory : APDYNAMICART::Brush
  • _direction : ode::CappedCylinder , ode::CompositeObject::Data
  • _dirty
: APDYNAMICART::ComputeThread
, APDYNAMICART::HoopShape
, vreckoUtils::HighlightCallback
, ConstantColorGen
  • _dirtyScene : APDYNAMICART::Ctrl_StringSculptures
  • _disabled : APGUI::GUI_Controller
  • _display_line : base::Display
  • _distance : APDYNAMICART::ElongatedCircle
  • _dl_map : vrecko::DeviceManager , vrecko::PluginManager
  • _done : APDYNAMICART::ComputeThread
  • _dynamic_object : ode::DynamicScene
  • _dynamicMenuAbility : APGUI::Menu
  • _effect : APWeather::Weather
  • _enabled_objects : ode::DynamicScene
  • _eobject : vrecko::ReaderWriter
  • _eoPtr : APLightsEditor::_Light
  • _eoSpotPtr : APLightsEditor::_Light
  • _ERP : ode::DynamicScene
  • _externalDeactivation : APGUI::Icon
  • _eye_position : behindO::Mirror
  • _fdh_geode : base::ShowFDH , base::ShowFDHModel
  • _fdh_geom : base::ShowFDH , base::ShowFDHModel
  • _fileName : PhysXPlugin::Cloth
  • _filletRadius : FilletSpline
  • _filletSteps : FilletSpline
  • _finalArrays : APDYNAMICART::Ctrl_StringSculptures
  • _first
: base::Display
, base::hand
, base::MouseHand
, base::ShowFDHModel
, behindO::AvatarManipulator
, behindO::CuttingPlane
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::Mirror
, ChessBoard
  • _firstTimeUpdate : APDYNAMICART::Ctrl_FreeHandPainting , APGUI::GUI_Controller
  • _fluidDesc : PhysXPlugin::Fluid
  • _font : APGUI::GUI_Text
  • _font_size : base::Display
  • _forceFieldDesc : PhysXPlugin::ForceField
  • _forceFieldLinearKernelDesc : PhysXPlugin::ForceField
  • _from : vreckoUtils::MenuSlider
  • _functor : osgQ::QPrimitiveShapeVisitor
  • _geode : behindO::Mirror , APDYNAMICART::Ctrl_StringSculptures
  • _geom : behindO::Mirror
  • _geometry : APDYNAMICART::PS_Face , SweepSurfaceGeode
  • _globalAbilities : APGUI::GUI_Controller
  • _globalAnchor : PhysXPlugin::BaseJoint
  • _globalAxis : PhysXPlugin::BaseJoint
  • _grab_position : base::hand , base::MouseHand
  • _grab_position2 : base::hand , base::MouseHand
  • _grab_rotation : base::hand , base::MouseHand
  • _grab_rotation2 : base::hand , base::MouseHand
  • _gravity : ode::DynamicScene
  • _green : APDYNAMICART::PerlinLines , APDYNAMICART::Ctrl_PerlinLines
  • _group : APGUI::Icon
  • _groups : APGUI::GUI_Controller
  • _guiController
: APDYNAMICART::ToolBrush
, APDYNAMICART::ToolHook
, APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _height
: APDYNAMICART::Rectangle
, APGUI::Slider
, osgQ::QSection
, APNature::TerrainAlgorithm
  • _hEvNuiProcessStop : vreckoDP_Kinect::Kinect
  • _highlight
: APDYNAMICART::HookObject
, APDYNAMICART::Hoop
, APDYNAMICART::PS_Face
  • _highLightcallback : APDYNAMICART::BrushStroke
  • _highlighted : vreckoUtils::HighlightCallback
  • _hints : osgQ::QDrawShapeVisitor , osgQ::QPrimitiveShapeVisitor
  • _hNextSkeletonEvent : vreckoDP_Kinect::Kinect
  • _hookPosition : APDYNAMICART::ToolHook
  • _hooks : APDYNAMICART::HookManager
  • _hoop : APDYNAMICART::HookObject , APDYNAMICART::ToolSelector
  • _hoopsState : APDYNAMICART::Ctrl_StringSculptures
  • _hostname
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
  • _hThNuiProcess : vreckoDP_Kinect::Kinect
  • _icontoDeactivate : APGUI::ColorPicker
  • _ID : PhysXPlugin::BaseJoint
  • _image : behindO::MyCullCallback
  • _increment : vreckoUtils::HighlightCallback
  • _incrementVec : vreckoUtils::HighlightCallback
  • _initCurPos : APDYNAMICART::ToolRotation
  • _initialScale : APGUI::Icon
  • _initPoint : APDYNAMICART::ComputeThread
  • _innerRadius : osgQ::QSection
  • _inputConnector : vreckoDP_Kinect::Kinect
  • _inputConnectorMappings : vreckoDP_Kinect::Kinect
  • _interconnections : APGUI::GUI_Item
  • _interpolatedLines : APDYNAMICART::PerlinLines
  • _interpolationCount : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _interpolationSteps : APDYNAMICART::Brush , InterpolatedSpline
  • _interpolator : APDYNAMICART::Ctrl_StringSculptures , InterpolatedSpline
  • _invSegmentCount : RegularPolygonSpline
  • _isActive : APGUI::ColorPicker
  • _itemCaption : vreckoUtils::MenuItem
  • _itemName : vreckoUtils::MenuItem
  • _items : APGUI::Layout , vreckoUtils::MenuBase
  • _itemsMap : APGUI::GUI_Controller
  • _itemsNames : APGUI::Layout
  • _itemTransform : APGUI::GUI_Item
  • _joints : APDYNAMICART::PhysXManager
  • _label : APGUI::GUI_Item
  • _last_position
: base::hand
, base::MouseHand
, navigation::AvatarInHand
, navigation::KMTracker
  • _last_positions : base::hand , base::MouseHand
  • _last_rotation : base::hand , base::MouseHand
  • _last_signal : vreckoDP_base::fdtDataGlove
  • _lastCheckedPositions : APInputConnector::InputConnector
  • _lastDominantAxis : APDYNAMICART::ToolMagicWand
  • _lastEnd : APDYNAMICART::ToolSelector
  • _lastHandPosition : APDYNAMICART::ToolMagicWand
  • _lastIndex : BufferedSpline
  • _lastKnownOrientations : APInputConnector::InputConnector
  • _lastKnownPointedObjects : APInputConnector::InputConnector
  • _lastKnownPositions : APInputConnector::InputConnector
  • _lastPlaybackTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _lastValidPosition : APDYNAMICART::ToolBrush
  • _lastValidSamplePosition : APDYNAMICART::BrushStroke
  • _layers : APDYNAMICART::PolyhedraSculpture
  • _layouts : APGUI::GUI_Controller
  • _leadingSpline : APDYNAMICART::BrushStroke
  • _leadingSplineInterpolated : APDYNAMICART::BrushStroke
  • _leadingSplineTilting : APDYNAMICART::BrushStroke
  • _leadSpline : SweepSurfaceGeode
  • _leadSplineArray : SweepSurfaceGeode
  • _length
: ode::CompositeObject::Data
, APDYNAMICART::Ctrl_PerlinLines
, APDYNAMICART::Line
, APDYNAMICART::PerlinLines
, ode::CappedCylinder
  • _lightID : APLightsEditor::_Light
  • _lim : APDYNAMICART::ComputeThread
  • _line_count : base::Display
  • _line_height : base::Display
  • _linearVelocity : APDYNAMICART::PhysXManager
  • _lineCount : APDYNAMICART::Ctrl_StringSculptures
  • _lineGeode : APDYNAMICART::PerlinLines
  • _lineGeometry : APDYNAMICART::PerlinLines
  • _lines : APDYNAMICART::PerlinLines
  • _linesColorArray : APDYNAMICART::PerlinLines
  • _linesMaterial : APDYNAMICART::PerlinLines
  • _lineWidth : APDYNAMICART::Ctrl_StringSculptures
  • _linewidth : APDYNAMICART::PerlinLines
  • _localHandDiffVec : APDYNAMICART::ToolTongs
  • _localState : behindO::MyCullCallback
  • _magnetCoords : APDYNAMICART::PerlinLines
  • _magnetCreated : APDYNAMICART::PerlinLines
  • _magnetON : APDYNAMICART::PerlinLines
  • _magnetSize : APDYNAMICART::PerlinLines , APDYNAMICART::Ctrl_PerlinLines
  • _magnetUsed : APDYNAMICART::PerlinLines
  • _MaterialIndex : PhysXPlugin::BaseActor
  • _MaterialName : PhysXPlugin::BaseActor
  • _maximumValue : APGUI::Slider
  • _maxNunberofInputDevices : APGUI::GUI_Controller
  • _members : APGUI::ItemsGroup
  • _MenuAbility : APDYNAMICART::ToolMagicWand
  • _menuAbility
: APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_FreeHandPainting
, APDYNAMICART::ToolRotation
, APDYNAMICART::ToolSelector
  • _MenuAbility : APDYNAMICART::ToolBrush
  • _menuCaption : vreckoUtils::Menu
  • _menuName : vreckoUtils::Menu
  • _meshData : PhysXPlugin::Cloth
  • _minDistance : BufferedSpline , SampledSpline
  • _minimumValue : APGUI::Slider
  • _mirror_normal : behindO::Mirror
  • _mode : APDYNAMICART::Ctrl_StringSculptures
  • _models : APGUI::Icon
  • _movableModel : APGUI::Slider
  • _movableTransform : APGUI::Slider
  • _move_step_limit : PhysXPlugin::BaseActor
  • _mutex : APDYNAMICART::ComputeThread
  • _name
: APGUI::Layout
, APGUI::GUI_Item
, APGUI::ItemsGroup
, PhysXPlugin::MessageNxActorWithName
  • _newHandOrientation : APDYNAMICART::ToolTongs
  • _newHandPosition : APDYNAMICART::ToolTongs
  • _newLinesColorArray : APDYNAMICART::PerlinLines
  • _nowTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _objects_dGeomID : ode::DynamicScene
  • _observers : vreckoUtils::Observable
  • _offset : APDYNAMICART::HoopTrackerCallback , PhysXPlugin::Cloth
  • _oldValue : APGUI::Slider
  • _onlyInt : vreckoUtils::MenuSlider
  • _opacity : APDYNAMICART::PS_Layer
  • _opened : APGUI::Menu
  • _orientations : APDYNAMICART::Hoop
  • _origColors : vreckoUtils::HighlightCallback
  • _origin_pos
: vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::Ultratrak
  • _originalHandposition : APDYNAMICART::ToolTongs , APDYNAMICART::ToolMagicWand
  • _originalLocalHandOrientation : APDYNAMICART::ToolTongs
  • _originalLocalHandposition : APDYNAMICART::ToolTongs
  • _originalPoAOrientation : APDYNAMICART::ToolTongs
  • _originalPoAPosition : APDYNAMICART::ToolTongs
  • _originalPoAScale : APDYNAMICART::ToolTongs
  • _originPos : vreckoDP_base::VRPN3DMouse
  • _originRot : vreckoDP_base::VRPN3DMouse
  • _oriString : APDYNAMICART::ToolTongs
  • _OSGState : APDYNAMICART::PerlinLines
  • _outerAngleAddition : osgQ::QSection
  • _outerRadius : osgQ::QSection
  • _outputMappingsWithPriorities : APInputConnector::InputConnector
  • _overZero : APDYNAMICART::ToolSelector
  • _p : APDYNAMICART::PerlinLines
  • _parameters : APDYNAMICART::PhysXManager
  • _params : APDYNAMICART::Attractor
  • _parent
: behindO::Mirror
, APDYNAMICART::HookManager
, APGUI::GUI_Item
  • _parent_inverse_rotation : base::hand , base::MouseHand
  • _parent_rotation : base::hand , base::MouseHand
  • _Particles : PhysXPlugin::Fluid
  • _patternColor : APDYNAMICART::Ctrl_StringSculptures
  • _patternMaterial : APDYNAMICART::Ctrl_StringSculptures
  • _patternsGeode : APDYNAMICART::Ctrl_StringSculptures
  • _paused : APDYNAMICART::PerlinLines
  • _pBaseDescripter : PhysXPlugin::BaseJoint
  • _pCloth : PhysXPlugin::Cloth
  • _pClothDrawable : PhysXPlugin::Cloth
  • _pClothMesh : PhysXPlugin::Cloth
  • _pFluid : PhysXPlugin::Fluid
  • _pFluidDrawable : PhysXPlugin::Fluid
  • _physicsSDK : APDYNAMICART::PhysXManager
  • _physXManager : APDYNAMICART::Ctrl_StringSculptures
  • _pickerHeight : APGUI::ColorPicker
  • _pickerRadius : APGUI::ColorPicker
  • _plane : ode::DynamicScene , RegularPolygonSpline
  • _planeDesc : PhysXPlugin::Plane
  • _playbackActive : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackIcon : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackSlider : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackTime : APDYNAMICART::Ctrl_FreeHandPainting
  • _playbackType : APDYNAMICART::Ctrl_FreeHandPainting
  • _poa
: APDYNAMICART::ToolRotation
, APDYNAMICART::HoopTrackerCallback
, APDYNAMICART::ToolHook
, APDYNAMICART::Ctrl_StringSculptures
, APDYNAMICART::DATool
  • _poas : APDYNAMICART::Controller
  • _poasName : APDYNAMICART::Controller
  • _pointed : APDYNAMICART::PerlinLines
  • _pointedAbilities : APGUI::GUI_Controller
  • _pointedCounter : APGUI::GUI_Item
  • _pointedIndexes : APGUI::GUI_Controller
  • _pointedTime : APGUI::GUI_Controller
  • _PointerOriReqString : APDYNAMICART::ToolEraser
  • _PointerPosReqString : APDYNAMICART::ToolEraser
  • _points
: APDYNAMICART::Painted
, APDYNAMICART::Hoop
, APDYNAMICART::ComputeThread
  • _polygon_font : base::Display
  • _polyhedron : APDYNAMICART::PS_Layer
  • _port
: vreckoDP_base::Ultratrak
, vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
  • _port_fd : vreckoDP_base::LHeadTracker
  • _port_name_dual : vreckoDP_base::LHeadTracker
  • _posString : APDYNAMICART::ToolTongs
  • _pPhysicsSDK : PhysXPlugin::PhysXObject
  • _pPO : PhysXPlugin::BaseActor
  • _precision : APDYNAMICART::ToolMagicWand
  • _pRemoteDebugger : PhysXPlugin::RemoteDebugger
  • _pressed : APGUI::GUI_Item
  • _pressedAbilities : APGUI::GUI_Controller
  • _pScene : PhysXPlugin::BasePhysXObject
  • _radius
: APDYNAMICART::ElongatedCircle
, ode::CappedCylinder
, ode::CompositeObject::Data
, ode::Sphere
, RegularPolygonSpline
  • _receiver : APGUI::GUI_Item
  • _receiver_ptr : vrecko::EventDispatcher::ICSBase
  • _red : APDYNAMICART::PerlinLines , APDYNAMICART::Ctrl_PerlinLines
  • _request : APDYNAMICART::PerlinLines
  • _ret_rotate : vreckoDP_base::Ultratrak , vreckoDP_base::NestOfBirds
  • _ret_translate : vreckoDP_base::Ultratrak , vreckoDP_base::NestOfBirds
  • _retq : ode::DynamicScene
  • _retv : ode::DynamicScene
  • _rfArray : SweepSurfaceGeode
  • _rfGenerator : SweepSurfaceGeode
  • _ropeLinks : APDYNAMICART::PhysXManager
  • _ropeRadius : APDYNAMICART::Ctrl_StringSculptures , APDYNAMICART::ToolHook
  • _ropeSegs : APDYNAMICART::PhysXManager
  • _rotate : vreckoDP_base::Ultratrak , vreckoDP_base::NestOfBirds
  • _rotateControl : vreckoDP_base::VRPN3DMouse
  • _rotateRatio : vreckoDP_base::VRPN3DMouse
  • _rotation : osgQ::QSection
  • _rotationAngles : SweepSurfaceGeode
  • _rotationFrameAdapterName : APDYNAMICART::Brush
  • _rotationFrameFactory : APDYNAMICART::Brush
  • _rotationFrameGen
: APDYNAMICART::RMFrameAdapter
, APDYNAMICART::AxisFrameAdapter
, APDYNAMICART::HandFrameAdapter
  • _rotationInDegress : RegularPolygonSpline
  • _rps : APDYNAMICART::RegularPolygon
  • _sampledSpline : APDYNAMICART::Line , APDYNAMICART::Painted
  • _samplePoints
: APDYNAMICART::Ellipse
, APDYNAMICART::ElongatedCircle
, APDYNAMICART::Rectangle
  • _samplesOrientations : APDYNAMICART::BrushStroke
  • _samplesPositions : APDYNAMICART::BrushStroke
  • _samplesTimeStamps : APDYNAMICART::BrushStroke
  • _scale
: APDYNAMICART::Rectangle
, vreckoDP_Kinect::Kinect
, APDYNAMICART::HoopTrackerCallback
, APDYNAMICART::RegularPolygon
, PhysXPlugin::Cloth
  • _scene : APDYNAMICART::PhysXManager
  • _scene_objects : ode::DynamicScene
  • _sculpture : APDYNAMICART::Ctrl_PolyhedraSculptures
  • _secsPerTick : vrecko::Timer
  • _sectorIndex : APDYNAMICART::ToolSelector
  • _sectorInfoList : APDYNAMICART::SectorManager
  • _sectorManager : APDYNAMICART::ToolSelector
  • _sectorMarker : APDYNAMICART::Hoop
  • _sectorNumber : APDYNAMICART::ToolSelector
  • _sectors : SectorColorGen
  • _segmentCount : RegularPolygonSpline
  • _selectEnd : APDYNAMICART::ToolSelector
  • _selectionaccumulator : APGUI::GUI_Controller
  • _selectStart : APDYNAMICART::ToolSelector
  • _sensorCount : APDYNAMICART::Ctrl_MotionVisualization
  • _sensorNumber
: APDYNAMICART::ToolMagicWand
, APDYNAMICART::ToolBrush
, APGUI::GUI_Item
, vrecko::MessageSensorTransformation
, APGUI::Slider
, APDYNAMICART::ToolTongs
, APDYNAMICART::ToolEraser
  • _sensorOrientation : vrecko::MessageSensorTransformation
  • _sensorPosition : vrecko::MessageSensorTransformation
  • _shape : APDYNAMICART::Hoop
  • _shapeCurve : APDYNAMICART::HoopGeometry
  • _shift : RegularPolygonSpline
  • _showControlPoints : APDYNAMICART::Ctrl_FreeHandPainting
  • _shownMenus : APGUI::GUI_Controller
  • _signal : vreckoDP_base::fsPinchGlove
  • _signal_backup : vreckoDP_base::fsPinchGlove
  • _signal_count : vreckoDP_base::fsPinchGlove
  • _signal_transf_table : vreckoDP_base::fsPinchGlove
  • _signal_type_table : vreckoDP_base::fsPinchGlove , vreckoDP_base::fdtDataGlove
  • _simulation : APDYNAMICART::Ctrl_StringSculptures
  • _simulationRunning : APDYNAMICART::PhysXManager
  • _size
: ode::CompositeObject::Data
, ode::Cube
, APDYNAMICART::Attractor
  • _sliderCaption : vreckoUtils::MenuSlider
  • _sliderName : vreckoUtils::MenuSlider
  • _smoothFactor : SmoothedSpline
  • _smoothing : vreckoDP_Kinect::Kinect
  • _smoothness : APDYNAMICART::Brush
  • _snapPointArray : APDYNAMICART::Hoop , APDYNAMICART::ToolSelector
  • _somethingChaned : APDYNAMICART::PerlinLines
  • _source : APConnectEditor::Optimalizer
  • _space : ode::DynamicScene
  • _speed : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • _speedControl : vreckoDP_base::VRPN3DMouse
  • _speedFactor : vreckoDP_base::VRPN3DMouse
  • _sphereDesc : PhysXPlugin::Sphere
  • _spline
: APDYNAMICART::HoopShape
, APDYNAMICART::WaveSplineAdapter
, APDYNAMICART::RectangularSplineAdapter
, APDYNAMICART::RoundedSplineAdapter
  • _start_x : base::Display
  • _start_y : base::Display
  • _startTick : vrecko::Timer
  • _StartTime : APDYNAMICART::BrushStroke
  • _state : osgQ::QDrawShapeVisitor , APGUI::GUI_Item
  • _stateMap : APDYNAMICART::PoAState
  • _staticModel : APGUI::Slider
  • _step : APGUI::Slider
  • _strokeStartTime : APDYNAMICART::ToolBrush
  • _strokeTime : APDYNAMICART::BrushStroke
  • _strRegisterPhysXObject : PhysXPlugin::UpdatablePhysXObject
  • _strScene : PhysXPlugin::BasePhysXObject
  • _subgraph : behindO::MyCullCallback , behindO::MyUpdateCallback
  • _sweepSurface : APDYNAMICART::BrushStroke , APDYNAMICART::Hoop
  • _switchActive_CoreChange : APGUI::Icon
  • _target : APConnectEditor::Optimalizer
  • _temporaryInterconnection : APGUI::ColorPicker
  • _terrain : APNature::TerrainAlgorithm
  • _text : APGUI::Slider , APGUI::GUI_Text
  • _text_geode : base::Display
  • _text_history : base::Display
  • _text_material : base::Display
  • _text_state : base::Display
  • _texts : APGUI::GUI_Item
  • _texture : behindO::Mirror , behindO::MyCullCallback
  • _texture_font : base::Display
  • _time : TimeLineSpline
  • _timeLineDecorator : APDYNAMICART::BrushStroke
  • _timer : APGUI::GUI_Controller
  • _timeStamps : TimeLineSpline , APDYNAMICART::Hoop
  • _to : vreckoUtils::MenuSlider
  • _toolBrush : APDYNAMICART::Ctrl_StringSculptures , APDYNAMICART::Ctrl_FreeHandPainting
  • _toolBrushes : APDYNAMICART::Ctrl_MotionVisualization
  • _toolEraser : APDYNAMICART::Ctrl_FreeHandPainting
  • _toolHook : APDYNAMICART::Ctrl_StringSculptures
  • _tools : APDYNAMICART::Controller
  • _toolTip : APGUI::GUI_Item
  • _toolTipShown : APGUI::GUI_Controller
  • _toolTipTime : APGUI::GUI_Controller
  • _toolTongs : APDYNAMICART::Ctrl_FreeHandPainting
  • _trans_mapp
: vreckoDP_base::OptiTrack
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • _transformNode : APWeather::Weather
  • _translate
: ode::CompositeObject::Data
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • _transp : base::Display
  • _trigger : APDYNAMICART::PerlinLines
  • _type
: APDYNAMICART::Controller
, APGUI::Icon
, ode::CompositeObject::Data
  • _unusedMagnetCoords : APDYNAMICART::PerlinLines
  • _updateFlag : APDYNAMICART::PoA
  • _updateVisitor : behindO::Mirror
  • _value : vreckoUtils::MenuSlider
  • _vertices : APDYNAMICART::PS_Face
  • _visuals : APDYNAMICART::PS_Layer
  • _width
: APNature::TerrainAlgorithm
, APDYNAMICART::Rectangle
, APGUI::Slider
  • _world : ode::DynamicScene
  • _worldOrigin : vreckoDP_Kinect::Kinect
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • A : grass::Triangle
  • a : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • a1pos : ChessBoard
  • ab_with_input_Use : base::hand , base::MouseHand
  • ability : vrecko::ReaderWriter::AbilityToInitialize , APObjectUtils::ConnectionViz::Connection
  • ability_dispatcher : vrecko::EnvironmentObject , vrecko::World
  • ability_map : vrecko::AbilityDispatcher
  • ability_name_map : vrecko::AbilityDispatcher
  • abilityMapper : APEditorController::EditorController
  • abilityName : APEditorQAbilities::AbilityEditor::AllowedAbility
  • absolut : navigation::AvatarInHand
  • absPI : vreckoDP_base::LHeadTracker
  • absRO : vreckoDP_base::LHeadTracker
  • absX : vreckoDP_base::LHeadTracker
  • absY : vreckoDP_base::LHeadTracker
  • absYA : vreckoDP_base::LHeadTracker
  • absZ : vreckoDP_base::LHeadTracker
  • acc : CarSim::CarState
  • act : CloudVoxel
  • act_node : vrecko::ReaderWriter
  • act_position : VirtualFixture::MarkerFactory
  • ActCollection : mv::CPlayer
  • actdir : VirtualFixture::NavSphere
  • action : APCameraMovement::CameraMovementEditor
  • activationMessage : vrecko::EventDispatcher::ICS
  • active
: behindO::HMDHeadManipulator
, behindO::Manipulator
, APDYNAMICART::DATool
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
, behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
  • active_LMD : APSpacePartitioning::SNCH_Object::LMDStore
  • activeAbilityButtonID : APEditorController::EditorController
  • activeAbilityName : APEditorController::EditorController
  • activeAbilityPointerID : APEditorController::EditorController
  • activePointerID : vrecko::ControllableAbility , APMenu::DynamicMenu
  • actLightID : APLightsEditor::Editor
  • actPointerPos : vrecko::ControllableAbility
  • actPointerPosRaw : vrecko::ControllableAbility
  • actPointerRot : vrecko::ControllableAbility
  • actPointerRotRaw : vrecko::ControllableAbility
  • actpos : VirtualFixture::NavSphere
  • actPosInPath : vrecko::ControllableAbility
  • actSelectedObjectID : vrecko::ControllableAbility
  • actSelectedPath : vrecko::ControllableAbility
  • actSelection : APEditorController::EditorController::ECPOINTERINFO , APEditorController::EditorController
  • actual_p : vreckoDP_base::LHeadTracker
  • actual_position : ChessPiece
  • actual_sensor_values : vreckoDP_base::fdtDataGlove
  • actual_string : APHUD::HUDField
  • actualColor : GradientColorGen
  • actualValue : APHUD::HUDField
  • actViewPosition : APEditorController::EditorController
  • AffinityMask : base::_THREAD_BASIC_INFORMATION
  • all_on
: VirtualFixture::Vibration
, VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, PHEffect
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
  • allowedAbilities : APEditorQAbilities::AbilityEditor
  • alpha : ArtificialWorld::AnimationPoint
  • alphaSet : ArtificialWorld::AnimationPoint
  • alwaysSendOrientationWithPosition : navigation::KMTracker
  • ambient : base::Light
  • ambientLight : SunLight
  • amplitude
: VirtualFixture::Border
, VirtualFixture::NavSphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
  • ana : vreckoDP_base::VRPN3DMouse
  • analog : Hci
  • analog_updated : Hci
  • ancestor : APSpacePartitioning::VLOD
  • angle
: navigation::AvatarInHand
, base::Rotate
, CarSim::JuncsEdge
, AP_LSystem::TurtleProperties
  • angle_tolerance : APSpacePartitioning::SNCH_Object
  • angleInXZ : CarSim::InOutEdgesAttr
  • angleMultiplier : AP_LSystem::TurtleProperties
  • angleVariance : AP_LSystem::TurtleProperties
  • animated : APHUD::HUDField
  • animation : ArtificialWorld::SubBlock
  • animationPoints : ArtificialWorld::SubBlockAnimation
  • animationType : ArtificialWorld::SubBlockAnimation
  • animator : APTextOutput::Console
  • area : grass::Triangle
  • arraySize : GradientColorGen , ConstantColorGen
  • Aspect : CloudSceneInfo
  • attenuationparam : VirtualFixture::NavSphere
  • attenuationtype : VirtualFixture::NavSphere
  • attractor : MagicWandTool , APDYNAMICART::ToolMagicWand
  • attribute : vrecko::BaseClass
  • attributeLock : vrecko::BaseClass
  • attributes : APMenu::DynamicMenu
  • autoMoveShift : APMenu::DynamicMenu
  • autorepeat_map : vreckoDP_base::KeyboardMouse
  • autoRotationStep : APDYNAMICART::Ctrl_PerlinLines
  • av : navigation::KMTracker , navigation::AvatarInHand
  • av_pos : navigation::AvatarInHand
  • avatar_copy : behindO::WIM
  • avatar_grab_inverse_rotation
: behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • avatar_grab_inverse_transform
: behindO::Manipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::AvatarManipulator
  • avatar_grab_pos
: behindO::EyeManipulator
, behindO::AvatarManipulator
, behindO::Manipulator
, behindO::HeadManipulator
  • avatar_grab_rotation
: behindO::Manipulator
, behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
  • avatar_grab_transform
: behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • avatar_look_at : navigation::AvatarInHand , navigation::KMTracker
  • avatar_position : navigation::KMTracker , navigation::AvatarInHand
  • avatar_up_vector : navigation::AvatarInHand , navigation::KMTracker
  • avatar_view : base::Avatar , VirtualFixture::Avatar
  • avatar_view_vector : vrecko::World
  • AvatarEyes : vrecko::World
  • averageNormal : APSpacePartitioning::SNCH_Object_Data::VertexSNCH
  • avView : APCameraPath::Camera
  • axis : APDYNAMICART::symmetry_pair
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • B : grass::Triangle
  • b : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • b3rdCamera : APCameraPath::Camera
  • backCarId : CarSim::EdgesCar
  • backEdgeId : CarSim::RoadsEdges
  • backgroundColor : APHUD::HUDColorProfile
  • BAD_FORMAT_handler : Hci
  • BAD_PACKET_handler : Hci
  • BAD_PASSWORD_handler : Hci
  • BAD_PORT_handler : Hci
  • BAD_VERSION_handler : Hci
  • bAllowForegroundListQueing : vrecko::EventDispatcher
  • bAllowSelectOnRelease : APMenu::DynamicMenu
  • bAnimating : APObjectUtils::Animator
  • bAnimationFile : APCameraPath::Camera
  • bApplySnapping : APEditorQAbilities::ObjectMovement
  • base1 : vreckoDP_base::LHeadTracker
  • base2 : vreckoDP_base::LHeadTracker
  • base3 : vreckoDP_base::LHeadTracker
  • baseDir : vrecko::PersistentCache
  • baseDirectory : APMenu::DynamicMenu
  • basePlaneRotation : AP_CableEditor::Cable
  • BasePriority : base::_THREAD_BASIC_INFORMATION
  • bAttemptToLoadRoadsFromArtificalWorld : CarSim::RoadsState
  • bAutoRun : APCameraPath::Camera
  • BBishop : ChessBoard
  • bbox : APMenu::MenuItemNull
  • bboxDF : APSpacePartitioning::VoxelGrid_Object_Data
  • bboxSizeDF : APSpacePartitioning::VoxelGrid_Object_Data
  • bCallSFP : vrecko::BufferedFile
  • bCloseFile : vrecko::BufferedFile
  • bCollisionCreated : APSpacePartitioning::VoxelGrid_Object_Data
  • bCollisionFree : vrecko::EnvironmentObject
  • bCollisionOccured_EventExpected : vrecko::Scene::EOIteratorHelper
  • bCollisions_NoCalculation : APObjectUtils::ObjectEffect
  • bColorize : APObjectUtils::ConnectionViz
  • bCompareExtrapolatedValue : Filter::PosNoiseRemover
  • bConfirmationEndedConnectionCreated : APMenu::MenuItem
  • bCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • bDebug : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • bDontRotate : APObjectUtils::KeepOnScreen
  • bDrawRoads : CarSim::RoadsState
  • bDynamicSpeed : APCameraPath::Camera
  • bEffectCreated : APObjectUtils::ObjectEffect
  • bEnableCache : vrecko::PersistentCache
  • bExisting : APEditorQAbilities::PresentAbility
  • bExtrapolateCorrectValue : Filter::PosNoiseRemover
  • bFileIsUTF : vrecko::BufferedFile
  • bFirstUpdate
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::AvatarMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • bGenShortestPaths : CarSim::RoadsState
  • bgListId : vrecko::EventDispatcher
  • bGraphicsCreated : APMenu::MenuItem
  • bGridCreated : APSpacePartitioning::VoxelGrid_Object_Data
  • bGridFilled : APSpacePartitioning::VoxelGrid_Object_Data
  • bgThreadAffinityMask : vrecko::CollisionParams__ver1
  • bIgnore : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • bIgnoreRotation : APEditorQAbilities::ObjectMovement
  • bInited : vrecko::Scene::EOIteratorHelper
  • bIntegerOnlySlider : APMenu::MenuItemSlider
  • BirthRateMax : APDYNAMICART::ParticleSystemParameters
  • BirthRateMin : APDYNAMICART::ParticleSystemParameters
  • bIsVisible : APMenu::MenuItem
  • BKing : ChessBoard
  • BKnight : ChessBoard
  • black_out_pos : ChessBoard
  • blinkLightState : CarSim::CarState
  • bLMDValid : APSpacePartitioning::SNCH_Object::LMDStore
  • bLocalRotation : APConnectEditor::Rotation
  • bm : vrecko::Logger
  • bMainButtonPressed : APMenu::DynamicMenu
  • bMenuVisible : vrecko::ControllableAbility
  • bNewItemAdded : APTextOutput::Console
  • bObjectLocked : vrecko::Scene::EOIteratorHelper
  • body : ode::ODEObject
  • boids_count : boids::BoidsLogic
  • boids_position : boids::BoidsLogic
  • boids_position_output : boids::BoidsLogic
  • boids_rest_time : boids::BoidsLogic
  • boids_velocity : boids::BoidsLogic
  • boids_velocity_output : boids::BoidsLogic
  • bOn : Filter::PosNoiseRemover
  • bOnlyOutput : APObjectUtils::ConnectionViz
  • bOpenData : vrecko::BenchmarkWriter
  • bOpenFrame : vrecko::BenchmarkWriter
  • bOpenInfo : vrecko::BenchmarkWriter
  • bOpenMain : vrecko::BenchmarkWriter
  • bOpenMiscStats : vrecko::BenchmarkWriter
  • bOpenSettings : vrecko::BenchmarkWriter
  • border_bvh : behindO::WIM
  • border_object : behindO::ChangeOfVisibility , behindO::WIM
  • borderXSize : APTextOutput::Console , LoadingConsole
  • borderYSize : APTextOutput::Console , LoadingConsole
  • bottom_border : behindO::HeadManipulator
  • bottomCarPosition : CarSim::CarState
  • bound_velocity : boids::BoidsLogic
  • bounding : APDYNAMICART::Ctrl_PerlinLines
  • boundingBox : APMenu::MenuItemText , Cloud
  • boundingCreated : APDYNAMICART::Ctrl_PerlinLines
  • boundingSpherePosition : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject , APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • boundingSphereRadius : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject , APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • boundingVisible : APDYNAMICART::Ctrl_PerlinLines
  • box_size : behindO::ChangeOfVisibility
  • BPawn : ChessBoard
  • bProcessed : APEditorQAbilities::AbilityEditor::AllowedAbility
  • BQueen : ChessBoard
  • brakeLightsPath : CarSim::GeometryPartsPath
  • brakeLightState : CarSim::CarExecutionUnit
  • bRecalculateNormals : APSpacePartitioning::GeometryLoaderBase , APFFDEditor::GeometryLoaderBase
  • bRelativeToBoundingBox : APObjectUtils::KeepOnScreen
  • bRetrieved : base::MTMatrixTransform
  • bReversedWChar : vrecko::BufferedFile
  • BRICK_MOVE_EVENT : base::MouseHand
  • BRook : ChessBoard
  • bShowLeafInLevelNotReached : APObjectUtils::ObjectEffect
  • bShowLinesWhileAnim : APCameraPath::Camera
  • bShowViewLine : APCameraPath::Camera
  • bSliding : APMenu::MenuItemSlider
  • bSNCHierarchyCreated : APSpacePartitioning::SNCH_Object_Data
  • bSphereBVHierarchyCreated : APSpacePartitioning::SphereBVH_Object_Data
  • bStartAnimation : APCameraPath::Camera
  • bStarting : DynamicTreeIterator< _Type >
  • bState : APEditorController::EditorController::ECPOINTERBUTTONINFO , vrecko::CABUTTONEVENT
  • bTerminateThread : vrecko::ScenePSThreadInfo
  • bTestComputation : APSpacePartitioning::PointShellVSVoxel_Object
  • bThreadInitialized : base::SystemInfo::SIThreadInfo
  • bThreadShouldTerminate : APSpacePartitioning::SP_Object_Data_Base
  • bTimeInitialized : base::SystemInfo::SIThreadInfo
  • buffer : vrecko::BufferedFileWrite , MemoryReadBuffer
  • bufx : vreckoDP_base::fsPinchGlove
  • bufxe : vreckoDP_base::fsPinchGlove
  • bUpdated : base::MTMatrixTransform
  • bUsedInUpdate : APObjectUtils::ConnectionViz::Connection
  • but : vreckoDP_base::VRPN3DMouse
  • button : Hci , vreckoDP_base::L3DMouse
  • button_supported : Hci
  • buttonID : APEditorController::AbilityMapper::BUTTON_MAPPING
  • buttons : Hci , APEditorController::EditorController::ECPOINTERINFO
  • bVisible : APObjectUtils::ObjectEffectMan , vrecko::EnvironmentObject
  • bWritePeriodicInfo : base::SystemInfo
  • bWriting : vrecko::BenchmarkWriter
  • bZeroNormal : APSpacePartitioning::SNCH_Object::OneTri
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • C : grass::Triangle
  • c : APSpacePartitioning::PointShell_Object_Data::PSpoint
  • cableColor : AP_CableEditor::Cable
  • cableControlLine : AP_CableEditor::Cable
  • cableID : AP_CableEditor::Cable , AP_CableEditor::CableEditor
  • cablePointers : AP_CableEditor::CableEditor
  • cableRadius : AP_CableEditor::Cable
  • cablesFile : AP_CableEditor::CableEditor
  • cachedFileName : vrecko::PersistentCache::OpenedCacheFile
  • cachedInfo : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • cacheDir : vrecko::PersistentCache
  • callback : vreckoDP_base::dataT
  • callbacks : vreckoDP_base::fsPinchGlove
  • camera : APTextOutput::Console , LoadingConsole , APHUD::HUDDisplay
  • camera_center : behindO::MyCullCallback
  • camera_direction : behindO::MyCullCallback
  • camera_position : behindO::MyCullCallback
  • cameraRotation : APCameraMovement::ControlPoint
  • canBeRandom : APDYNAMICART::Parameter
  • CANT_BEGIN_handler : Hci
  • CANT_OPEN_handler : Hci
  • capabilities : AP_LSystem::D0LSystem
  • caption : APMenu::MenuItemText
  • car : CarSim::MessageCarEdge
  • carEdgeId : CarSim::CarEnvirons , CarSim::Parameters
  • carId : CarSim::Parameters , CarSim::CarEdgeData
  • carIdUnlockedEdge : CarSim::Junction
  • carLength : CarSim::CarEdgeData
  • carNextJuncRel : CarSim::CarEnvirons , CarSim::Parameters
  • carPartsPathNodeMap : CarSim::CarPartsNodeCache
  • carSize : CarSim::CarState
  • carState : CarSim::CarExecutionUnit
  • carsToRemove : CarSim::Remover
  • carWithoutWheelsPath : CarSim::GeometryPartsPath
  • cbNodeAllowed : DynamicTreeIterator< _Type >
  • cbSubTreeAllowed : DynamicTreeIterator< _Type >
  • cell_size : vrecko::OctTree
  • center
: APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, grass::Triangle
, APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • changedInterpolation : APDYNAMICART::PerlinLines
  • changedLength : APDYNAMICART::PerlinLines
  • changedSpeed : APDYNAMICART::PerlinLines
  • check_failed : vreckoDP_base::Wiimote
  • chess_pipe : ChessBoard
  • chessboard_id : ChessPiece
  • child
: BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
, FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
, ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • child_nodes : vrecko::OctTree::OctTreeNode
  • childMenuAnimator : APMenu::MenuItem
  • childMenuObject : APMenu::MenuItem
  • childs : APSpacePartitioning::VLOD
  • cld : CloudVoxel
  • ClientId : base::_THREAD_BASIC_INFORMATION
  • clipNode : APDYNAMICART::PLControllerTool , APDYNAMICART::ToolSlice , SliceTool
  • clipnode : behindO::CuttingPlane
  • clipNode : APDYNAMICART::PLNestTool , APDYNAMICART::PLMagnetTool
  • clipnodeSS : behindO::CuttingPlane
  • closed : CatmullRomInterpolator , LinearInterpolator
  • closeFeatures : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • cloudData : AllCloudsUpdateCallBack
  • CloudFlatAreaPosition : CloudsProperties
  • CloudFlatAreaSize : CloudsProperties
  • CloudGrowth : CloudsProperties
  • CloudGrowthRand : CloudsProperties
  • cloudParticle : Cloud
  • clouds : CloudsManager
  • cmd_byte : packet_rec
  • cntAngle : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • cntNodes : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • cntRadius : APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
  • coef1 : Filter::Linear
  • coef2 : Filter::Linear
  • coef3 : Filter::Linear
  • coef4 : Filter::Linear
  • colInfo : APObjectUtils::ObjectEffect
  • collisionField : APSpacePartitioning::NoPartitioning_Scene
  • collisionNormal : PhysXPlugin::Particle
  • collisionObjects : APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • collisions : APSpacePartitioning::PointShell_SimpleNode
  • collisionsMax : APSpacePartitioning::PointShell_Object_Data
  • collisionsTotal : APSpacePartitioning::PointShell_Object_Data
  • collisiontime1 : APSpacePartitioning::PointShellVSVoxel_Object
  • collisiontime2 : APSpacePartitioning::PointShellVSVoxel_Object
  • color
: VirtualFixture::Cylinder
, APObjectUtils::ObjectEffect
, VirtualFixture::ProxiBox
, Sector
, APEditorQAbilities::ObjectMovement::SnapBox
, ChessBoard
, APHUD::HUDField
, APHUD::HUDWindow
, APMenu::MenuItem
, Particle
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • color2
: VirtualFixture::Trace
, VirtualFixture::Cylinder
, VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::Sphere
  • colorablePartName : Icon
  • colorMax : APHUD::HUDField
  • colorMin : APHUD::HUDField
  • comment : Hci
  • comNorm : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt , APSpacePartitioning::VLOD
  • complexJunc : CarSim::Junction
  • comPos : APSpacePartitioning::VLOD
  • computeTimeLast : APSpacePartitioning::NoPartitioning_Scene
  • computeTimeNew : APSpacePartitioning::NoPartitioning_Scene
  • condition : AP_LSystem::Rule
  • conditionalMessage : vrecko::EventDispatcher::ICS
  • cone_axis : APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
  • connection : vreckoDP_base::OptiTrack
  • connectionName : vreckoDP_base::OptiTrack
  • cons : APObjectUtils::ConnectionViz
  • const_d : navigation::AvatarInHand
  • constantAttenuation : base::Light
  • constraintHierarchyRoot : APConstrainedMovement::ConstrainedObjectMovement
  • continuous_selection : behindO::ChangeOfVisibility
  • contour : AP_LSystem::TurtleProperties
  • contourDetail : AP_LSystem::TurtleProperties
  • contourLastN : AP_LSystem::TurtleProperties
  • contourLastV : AP_LSystem::TurtleProperties
  • control
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::WIM
, behindO::ChangeOfVisibility
, behindO::CentreObjectManipulator
, behindO::CuttingPlane
, behindO::Manipulator
  • controller : MagicWandTool , APDYNAMICART::ToolMagicWand
  • controlPoint : AP_LSystem::TurtleProperties
  • controlPoint_count : APFFDEditor::Grid
  • controlPoints : AP_CableEditor::Cable , APFFDEditor::Grid
  • controlPointsChange : AP_CableEditor::Cable
  • controlSpheres : AP_CableEditor::Cable
  • controlSpheresColor : AP_CableEditor::Cable
  • controlSpheresRadiusAdjust : AP_CableEditor::Cable
  • controlSystem : CarSim::Junction
  • controlVectors : AP_CableEditor::Cable
  • conViz : APEditorQAbilities::AbilityEditor
  • copies_map : behindO::WIM
  • copies_root : behindO::WIM
  • copy : behindO::WIM::ObjectCopy
  • cost : APSpacePartitioning::ELOD
  • counter : Sector , vrecko::PyAbility
  • countersActiveIndex : vrecko::Logger
  • countersActiveLock : vrecko::Logger
  • countOfCP : APFFDEditor::Grid
  • cProfiles : APHUD::HUDDisplay
  • CPscaling : APFFDEditor::Grid
  • CPsize : APFFDEditor::EditorLogic
  • creationType : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • crossSectionGenerator : APDYNAMICART::Configuration
  • crossSectionSize : GradientColorGen
  • ctrTimeLast : APSpacePartitioning::NoPartitioning_Scene
  • ctrTimeNew : APSpacePartitioning::NoPartitioning_Scene
  • current_method : BehindObstacleExperiment , BehindObstacleExp_wT
  • current_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • current_transform : base::MouseHand , base::hand
  • current_waypoint : boids::BoidsPlanner
  • currentObjectIndex : vrecko::Scene::EOIteratorHelper
  • currentSize : MemoryWriteBuffer
  • cursor_shift : base::Avatar
  • curveDetail : AP_LSystem::TurtleProperties
  • cutting_object : behindO::CuttingPlane
  • cutting_plane_transformation : behindO::CuttingPlane
  • cuttingLoop : APConnectEditor::Cut
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • DAAOrientation : MTCreatorTool
  • DAAposition : MTCreatorTool
  • DAArea : APDYNAMICART::PLMagnetTool , APDYNAMICART::PLControllerTool , APDYNAMICART::PLNestTool , MTCreatorTool , SliceTool
  • DAAScale : MTCreatorTool
  • danger : boids::BoidsLogic
  • danger_factor : boids::BoidsLogic
  • data
: CarSim::MessageCarEnvirons
, CarSim::MessageCarStatePtr
, APEditorController::AbilityMapper::MessageMapping
, vrecko::MessageCAButtonEvent
, vrecko::ControllableAbility::MessageCAINFO
, vreckoDP_base::dataT
, CarSim::MessageCarEdgeData
, packet_rec
, MemoryWriteBuffer
, CarSim::MessageVectorUnsignedInt
, CarSim::MessageStartStopDestination
, CarSim::MessageFirst3Juncs
, CarSim::MessageCarSimParameters
  • data_ptr : packet_rec
  • dataPath : CarSim::RoadsState
  • debugGeometryScale : AP_LSystem::TurtleProperties
  • debugGlobalUpdatesCounter : vrecko::CollisionParams__ver1
  • default_handler : Hci
  • default_request_interconnection_map : vrecko::EventDispatcher
  • defaultInfo : vrecko::ControllableAbility
  • defaultState : Icon
  • definedcolorprofiles : APHUD::HUDDisplay
  • defstring : VirtualFixture::AxisLock
  • degree : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode , FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • delta_z : behindO::HeadManipulator
  • density : grass::GrassAbilityParameters , PhysXPlugin::Particle
  • deprecated_version : vreckoDP_base::OptiTrack
  • depth : APObjectUtils::KeepOnScreen
  • describtion : VirtualFixture::Marker
  • description
: vrecko::Ability::ParameterStruct
, vrecko::Scene
, vrecko::World
  • detailCoef : APDYNAMICART::SimulationParameters
  • detailedGrassStateSet : grass::GrassAbilityParameters
  • detectiontime1 : APSpacePartitioning::NoPartitioning_Scene
  • detectiontime2 : APSpacePartitioning::NoPartitioning_Scene
  • device_manager_local : vrecko::ReaderWriter
  • device_map : vrecko::DeviceManager
  • device_type : vrecko::Device
  • devicePtr : vrecko::DeviceManager::DT
  • dFXDim : APSpacePartitioning::VoxelGrid_Object_Data
  • dFYDim : APSpacePartitioning::VoxelGrid_Object_Data
  • dFZDim : APSpacePartitioning::VoxelGrid_Object_Data
  • difference_sensor_orientation : behindO::HeadManipulator
  • difference_sensor_pos : behindO::HeadManipulator
  • diffuse : base::Light
  • dir : behindO::MyCullCallback
  • direction
: Sector
, navigation::KMTracker
, VirtualFixture::Border
, VirtualFixture::NavSphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, base::Light
, CarSim::CarState
, CarSim::MessageRoadAndDir
, CarSim::Edge
  • dirty : APRoomEdit::Tool
  • disabled : vreckoDP_base::Wiimote
  • dispEO : APMenu::DynamicMenu
  • dispersion : APDYNAMICART::ParticleSystemParameters
  • displayListValid : grass::GrassDrawable
  • dist : APSpacePartitioning::ELOD
  • distanceField : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFieldCollsions : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFieldTemp : APSpacePartitioning::VoxelGrid_Object_Data
  • distanceFromEye : grass::GrassDrawable
  • distFromLastFrame : CarSim::CarState
  • distToCam : CloudParticle
  • distToNextPoint : CarSim::CarEnvirons
  • dominantAxis : APDYNAMICART::ToolMagicWand , MagicWandTool
  • done : vrecko::vThread , MainObject
  • dRequestedCellLength : APSpacePartitioning::VoxelGrid_Object_Data
  • duration : VirtualFixture::Vibration
  • dwActiveFlags : vrecko::CAINFO__VER2
  • dwAffinity : base::SystemInfo::SIThreadInit
  • dwAlloc : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwAllocBy : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwAllowedOutput : vrecko::Logger
  • dwBehvFlags : vrecko::BufferedFile
  • dwBufMaxSize : vrecko::BufferedFileWrite
  • dwBufSize : vrecko::BufferedFile
  • dwCopiedProperties : APObjectUtils::CopyProperties
  • dwCopyEO : APObjectUtils::CopyProperties
  • dwCount : DynamicTree< _Type >
  • dwFilePos : vrecko::BufferedFile
  • dwFileSize : vrecko::BufferedFile
  • dwFlags
: vrecko::CollisionPointInfo
, DynamicTreeIterator< _Type >
, vrecko::CAINFO__VER1
, vrecko::CollisionParams__ver1
, APMenu::MenuItem
, APSpacePartitioning::SNCH_Object::LocalMinimumDistance
, APObjectUtils::ConnectionViz::Connection
  • dwGroup : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • dwInited : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwItemIndex : APMenu::MenuItem
  • dwLastKernelTime : base::SystemInfo::SIThreadInfo
  • dwLastTick : base::SystemInfo
  • dwLastUserTime : base::SystemInfo::SIThreadInfo
  • dwMainThreadId : vrecko::Logger
  • dwMaxPos : vrecko::BufferedFile
  • dwNum : VK_NoStepInto_Namespace::DynamicArray< _Type >
  • dwNumItems : APMenu::MenuItem
  • dwOutputDest : vrecko::Logger
  • dwOutputType : vrecko::Logger::OutstandingText
  • dwPos : vrecko::BufferedFile
  • dwRepresentant : APSpacePartitioning::SNCH_Object_Data::VertexSNCH
  • dwSize : vrecko::CABUTTONEVENT , vrecko::CAINFO__VER1
  • dwSNCHFlags : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • dwStructureVersion : vrecko::CollisionParams__ver1
  • dwThreadId : base::SystemInfo::MessageSIThreadCreated
  • dwType : LoadingConsole::OutstandingLine
  • dwZeroPos : vrecko::BufferedFile
  • dyn_version : base::MouseHand , base::hand
  • dynamics_used : BehindObstacleExp_wT , BehindObstacleExperiment
  • dynamicStrings : AP_LSystem::Rule
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • e1 : APSpacePartitioning::PLOD
  • e1ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • e2 : APSpacePartitioning::PLOD
  • e2ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • e3 : APSpacePartitioning::PLOD
  • e3ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
  • edge : CarSim::MessageEdgeOffset , CarSim::MessageCarEdge
  • edge_count : APFFDEditor::Grid
  • edgeCostRecompute : APSpacePartitioning::ELOD
  • edgeFlags : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • edgeId : CarSim::CarEdgeData
  • edges
: APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::VLOD
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, CarSim::RoadsState
, APFFDEditor::Grid
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
  • edgesCars : CarSim::Edge
  • effectType : APObjectUtils::ObjectEffect
  • elasticityMultiplier : AP_LSystem::TurtleProperties
  • enable : ode::ODEObject
  • enabledAnimations : APObjectUtils::Animator
  • encoder : Hci
  • encoder_updated : Hci
  • end : Sector
  • end_tick : BehindObstacleExp_wT , BehindObstacleExperiment
  • eng : APDYNAMICART::ComputeThread
  • entity_vector : vrecko::Scheduler::TimerStruct , vrecko::vThread
  • environment_objects_map : vrecko::Scene
  • eo
: CacheInfo
, APHUD::HUDDisplay
, navigation::AvatarInHand
, APTextOutput::Console
  • EO : APFFDEditor::Grid::ControlPoint
  • EO_owner_grab_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
  • EO_owner_grab_rot
: behindO::Manipulator
, behindO::AvatarManipulator
, behindO::EyeManipulator
  • EO_owner_grab_Wrot
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::Manipulator
  • eoID : vrecko::CollisionInfo
  • eoMapLock : vrecko::Scene
  • eoRootNode : vrecko::Scene
  • error : packet_rec
  • errorOccuredInInit : CarSim::CarControlUnit
  • event_dispatcher_local : vrecko::ReaderWriter
  • event_interconnection_map : vrecko::EventDispatcher
  • EventDispatcher : vrecko::EventDispatcher::ICSBase
  • eventsVector : vrecko::EventDispatcher
  • eventType : vrecko::EventDispatcher::EventStruct
  • ExitStatus : base::_THREAD_BASIC_INFORMATION
  • experiment_description : BehindObstacleExp_wT , BehindObstacleExperiment
  • experiment_map : BehindObstacleExp_wT , BehindObstacleExperiment
  • eye_distance_scale_factor
: behindO::AvatarManipulator
, behindO::HeadManipulator
, behindO::EyeManipulator
, behindO::Manipulator
, behindO::HMDHeadManipulator
  • eye_offset : vrecko::World::AvatarEye
  • eye_position
: behindO::HeadManipulator
, vrecko::World::AvatarView
, behindO::EyeManipulator
, behindO::HMDHeadManipulator
, behindO::AvatarManipulator
, behindO::Manipulator
  • eyePos : APConnectEditor::Scale , APConnectEditor::Rotation
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • face : APDYNAMICART::symmetry_pair
  • face_count : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • face_index : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • face_size : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • faces
: APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::SNCH_Object::LocalMinimumDistance
, APSpacePartitioning::SNCH_Object_Data::VertexSNCH
, APFFDEditor::GeometryLoaderBase
  • fActTime : APObjectUtils::Animator
  • fAlpha : APObjectUtils::Animator::AnimationPoint
  • fAnimationTime : APCameraPath::Camera
  • Far : CloudSceneInfo
  • far_border : behindO::HeadManipulator
  • fieldDefaultColorA : APHUD::HUDDisplay
  • fieldDefaultColorB : APHUD::HUDDisplay
  • fieldDefaultColorG : APHUD::HUDDisplay
  • fieldDefaultColorR : APHUD::HUDDisplay
  • fields : APHUD::HUDWindow
  • fieldSizeVertical : APHUD::HUDDisplay
  • fieldTabHorizontal : APHUD::HUDDisplay
  • fieldTabVertical : APHUD::HUDDisplay
  • file : vrecko::BenchmarkWriter
  • fileName : ArtificialWorld::Model
  • filename : PreloaderLoadedInfo , PreloaderToLoadInfo , ArtificialWorld::SubBlock , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • filesLock : vrecko::PersistentCache
  • final_object_position : BehindObstacleExperiment , BehindObstacleExp_wT
  • final_object_rotation : BehindObstacleExp_wT , BehindObstacleExperiment
  • final_position : ChessPiece
  • fIndex : APSpacePartitioning::SNCH_Object_Data::FaceSNCH
  • finger_direction : vreckoDP_base::fdtDataGlove
  • first : base::hand , base::MouseHand
  • first_enter : BehindObstacleExp_wT , BehindObstacleExperiment
  • first_report : vreckoDP_base::LHeadTracker
  • firstObjectMatrix : APConnectEditor::Rotation , APConnectEditor::Scale
  • firstObjectPos
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • firstObjectPosCo : APCameraMovement::CameraMovementEditor
  • firstObjectRot : APConstrainedMovement::ConstrainedObjectMovement , APEditorQAbilities::ObjectMovement
  • firstPointerPos
: APCameraMovement::CameraMovementEditor
, APCameraPath::Camera
, APConnectEditor::Rotation
, APConnectEditor::Scale
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • firstPointerRot : APConstrainedMovement::ConstrainedObjectMovement , APEditorQAbilities::ObjectMovement
  • firstTimeUpdate : APDYNAMICART::PerlinLines
  • firstTransparency : APConstrainedMovement::ConstrainedObjectMovement
  • flag : filter2
  • flags : AP_LSystem::TurtleProperties
  • flatLayer : CloudsManager
  • fly : navigation::AvatarInHand
  • fMaxDistance : APSpacePartitioning::PointShell_Object_Data
  • fMaxU : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMaxV : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMinU : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fMinV : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • fObjProjectionArea : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • focus_area : behindO::CentreObjectManipulator
  • focusing_marker : behindO::CentreObjectManipulator
  • font_size : BehindObstacleExp_wT , BehindObstacleExperiment
  • fontColor : APHUD::HUDColorProfile
  • force
: base::hand
, base::MouseHand
, VirtualFixture::Drag
  • forwardEdgeId : CarSim::RoadsEdges
  • Fovy : CloudSceneInfo
  • fp : UserStream
  • fPointRadius : APCameraPath::Camera
  • fr : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • fRadius : APObjectUtils::ObjectEffect
  • frame : behindO::MyCullCallback
  • free_move_EO : base::Avatar , VirtualFixture::Avatar
  • freeID : APConnectEditor::Cut
  • freeMoveEO_ID : VirtualFixture::Avatar , base::Avatar
  • freeze_finger_sensor : vreckoDP_base::fdtDataGlove
  • freeze_rotation : vreckoDP_base::fdtDataGlove
  • frenetFremeComputed : DAControlPoint , APDYNAMICART::BrushStrokeControlPoint
  • freq : VirtualFixture::Filter , APSpacePartitioning::NoPartitioning_Scene
  • frequency
: VirtualFixture::Vibration
, VirtualFixture::NavSphere
, vrecko::vThread
, VirtualFixture::Border
, VirtualFixture::VibrationLabel
, vrecko::Scheduler::TimerStruct
  • from : CarSim::Edge
  • fromPointRight : CarSim::Edge
  • frontCarId : CarSim::EdgesCar
  • frontLightsPath : CarSim::GeometryPartsPath
  • frontLightState : CarSim::CarExecutionUnit
  • fSliderFromX : APMenu::MenuItemSlider
  • fSliderPos01 : APMenu::MenuItemSlider
  • fSliderToY : APMenu::MenuItemSlider
  • fstCarId : CarSim::Edge
  • fTolerance : Filter::PosNoiseRemover
  • fTransparency : APCameraPath::Camera
  • fValue : vrecko::Logger::OutstandingCounter
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • gen : CarSim::CarControlUnit
  • generalLock
: base::MTMatrixTransform
, vrecko::Scene::EOIteratorHelper
, vrecko::Logger
  • generate_board : ChessBoard
  • geode : APTextOutput::Console , LoadingConsole , AP_LSystem::AbstractTurtle , APHUD::HUDDisplay
  • geom : ode::ODEObject , APTextOutput::Console , LoadingConsole , VirtualFixture::NavSphere
  • geom_translate : ode::ODEObject
  • geometries_count : APFFDEditor::GeometryLoader
  • Geometry : ArtificialWorld::Model
  • geometry
: PreloaderLoadedInfo
, AP_LSystem::TurtleProperties
, APHUD::HUDField
, APHUD::HUDWindow
, APMenu::DynamicMenuSign
  • geometryArray : APFFDEditor::GeometryLoader
  • gestureOn : vreckoDP_base::fsPinchGlove
  • getFuncPtr : vrecko::vThread
  • giMode : APLightsEditor::Editor , APLightsEditor::Lights
  • glist : mv::CCollection
  • gnode
: VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
  • GRAB_EVENT : base::MouseHand
  • grab_position : navigation::AvatarInHand
  • GRAB_RELEASE_EVENT : base::MouseHand
  • grab_transform : base::hand , base::MouseHand
  • grab_transform_SO : base::MouseHand , base::hand
  • gradient : APDYNAMICART::PerlinLines
  • gradientEndColor : APHUD::HUDColorProfile
  • gradientStartColor : APHUD::HUDColorProfile
  • gradientStep : GradientColorGen
  • graphicObject
: APObjectUtils::ObjectEffect
, APObjectUtils::ConnectionViz
, APEditorQAbilities::ObjectMovement::SnapBox
  • grasp_count : BehindObstacleExp_wT , BehindObstacleExperiment
  • grassBlades : grass::GrassAbilityParameters
  • grassCullCallback : grass::GrassAbilityParameters
  • grassDisplayList : grass::GrassDrawable
  • gravitropismElasticity : AP_LSystem::TurtleProperties
  • gravity : APDYNAMICART::ParticleSystemParameters , VirtualFixture::Grid
  • gravity_mode : base::Avatar
  • gravity_on : VirtualFixture::Grid
  • gridChanged : APFFDEditor::EditorLogic
  • gridUnitHalfSizeX : PseudoRand2DPlacement
  • gridUnitHalfSizeZ : PseudoRand2DPlacement
  • gridUnitSizeX : PseudoRand2DPlacement
  • gridUnitSizeY : PseudoRand2DPlacement
  • gridUnitSizeZ : PseudoRand2DPlacement
  • gridWasCreated : APFFDEditor::Grid
  • groundCenterPosition : CloudsProperties
  • groundShow : CloudsProperties
  • groundTexturePath : CloudsProperties
  • GrowthSimulationSteps : CloudsProperties
  • GrowthSimulationStepsRand : CloudsProperties
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • half_spread_angle : APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
  • halfRect1 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • halfRect2 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • halfside : AABoundingBox
  • hand_orientation_left : navigation::KMTracker
  • hand_orientation_right : navigation::KMTracker
  • hand_position_left : navigation::KMTracker
  • hand_position_right : navigation::KMTracker
  • hand_type : vreckoDP_base::fdtDataGlove
  • handMoveMax : APDYNAMICART::ToolMagicWand , MagicWandTool
  • handMoveMin : APDYNAMICART::ToolMagicWand , MagicWandTool
  • handShapeDraw : APGUI::ColorPicker
  • handShapeSphere : APGUI::ColorPicker
  • handSphereRadius : APGUI::ColorPicker
  • hasAnimation : ArtificialWorld::SubBlock
  • hashValue : vrecko::EventDispatcher::StringWithHash
  • hasMaxDistance : ArtificialWorld::Model
  • hasMaxVisibleDistance : ArtificialWorld::SubBlock
  • hasMinDistance : ArtificialWorld::Model
  • hasPositionSet : ArtificialWorld::Model
  • hci : Arm
  • hCollisionEvent1 : vrecko::Scene::EOIteratorHelper
  • hCollisionEvent2 : vrecko::Scene::EOIteratorHelper
  • head : base::Avatar , BinomialHeap< _NodeClass, _keyType > , FibonacciHeap< _NodeClass, _keyType > , ThinHeap< _NodeClass, _keyType > , VirtualFixture::Avatar
  • head_center
: behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
  • head_orientation : ht::HeadTracking
  • head_pos : ht::HeadTracking
  • head_sensor_number : ht::HeadTracking
  • head_tracking_origin_position : ht::HeadTracking
  • head_tracking_scale : ht::HeadTracking
  • head_tracking_translate_mapping : ht::HeadTracking
  • headEO_ID : base::Avatar , VirtualFixture::Avatar
  • headOffset : CarSim::EdgesCar
  • height : CarSim::CarSize
  • hemisphere : AP_LSystem::TurtleProperties
  • hfCubicsBorder : CarSim::InOutEdgesAttr
  • hfCubicsBorderVec : CarSim::InOutEdgesAttr
  • hFile : vrecko::BufferedFile , vrecko::BufferedFileWrite
  • hHierarchyCreationThread : APSpacePartitioning::SP_Object_Data_Base
  • hMainThreadId : vrecko::EventDispatcher
  • hoop : APDYNAMICART::SectorInfo
  • hoopDensity : APDYNAMICART::SimulationParameters
  • hOriginalStdHandle : vrecko::Logger
  • horiz : navigation::KMTracker
  • horizAlign : APObjectUtils::KeepOnScreen
  • hR1SnapMul : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • hR2SnapMul : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • hThreadHandle : vrecko::ScenePSThreadInfo
  • hud : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • HUDDepthField : APHUD::HUDDisplay
  • HUDDepthFieldBackground : APHUD::HUDDisplay
  • HUDDepthWindow : APHUD::HUDDisplay
  • HUDDivision : APHUD::HUDDisplay
  • hudInitialized : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • hudWindows : APHUD::HUDDisplay
  • hum : CloudVoxel
  • hvT_Mutex : vrecko::vThread
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • i : navigation::KMTracker , mv::CPlayer
  • i1 : APSpacePartitioning::int_3
  • i2 : APSpacePartitioning::int_3
  • i3 : APSpacePartitioning::int_3
  • iActDir : APObjectUtils::Animator
  • iButtonID : vrecko::CABUTTONEVENT
  • iCorrectedSamplesCounter : Filter::PosNoiseRemover
  • id : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt , APSpacePartitioning::VLOD
  • ID : vrecko::World::AvatarView
  • id : APSpacePartitioning::ELOD , APSpacePartitioning::PLOD
  • ID : Sector
  • id
: PhysXPlugin::Particle
, VirtualFixture::Marker
, vrecko::Device
, vrecko::EnvironmentObject
, CarSim::Junction
, CarSim::PolygonPoint
, APSpacePartitioning::PointShell_SimpleNode
  • ID1 : APFFDEditor::Grid::Edge
  • ID2 : APFFDEditor::Grid::Edge
  • id_string : vrecko::PyAbility
  • iDilatation : APSpacePartitioning::VoxelGrid_Object_Data
  • iDilatationStrategy : APSpacePartitioning::VoxelGrid_Object_Data
  • iDistanceFieldValue : APObjectUtils::ObjectEffect
  • iEdgesCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iGenType : APSpacePartitioning::VoxelGrid_Object_Data
  • ignoredObjects : vrecko::CollisionParams__ver1
  • iLevelMax : APObjectUtils::ObjectEffect
  • iLevelMin : APObjectUtils::ObjectEffect
  • iMaxCollisionsFromLoadedVoxel : APSpacePartitioning::VoxelGrid_Object_Data
  • iMaxCorrectedSamplesInRow : Filter::PosNoiseRemover
  • iMaxPastSamples : Filter::PosNoiseRemover
  • immersive : navigation::AvatarInHand
  • importance : APSpacePartitioning::VLOD , APSpacePartitioning::ELOD
  • incoming_events : vrecko::EventDispatcher
  • incomingCars : CarSim::Edge
  • indexX : APDYNAMICART::ToolMagicWand , MagicWandTool
  • indexY : APDYNAMICART::ToolMagicWand , MagicWandTool
  • indexZ : APDYNAMICART::ToolMagicWand , MagicWandTool
  • initBool : CarSim::CarControlUnit
  • initial_sensor_orientation : behindO::HeadManipulator
  • initial_sensor_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • initial_sensor_x_orientation : behindO::HeadManipulator
  • InitialLevel : APNature::MidpointDisplacementAlgorithm
  • initialParamValue : APDYNAMICART::ToolMagicWand , MagicWandTool
  • iNorm : APSpacePartitioning::PointShell_SimpleNode
  • inOutEdgesAttrMap : CarSim::Junction
  • inovation : VirtualFixture::Filter
  • inPos : CarSim::Edge
  • inputExit : MainObject
  • inputPin : Receiver
  • inputPinsList : vrecko::BaseClass
  • inputProjection : MainObject
  • insertIndex : AP_CableEditor::CableEditor
  • internal_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • interpolatedPoints : AP_CableEditor::Cable
  • interpolation : ArtificialWorld::SubBlockAnimation
  • interpolationsNum : AP_CableEditor::Cable
  • interpolationSteps : APDYNAMICART::InitSettings , CatmullRomInterpolator , LinearInterpolator
  • interpolationType : APObjectUtils::Animator , AP_CableEditor::Cable
  • intersectedObjects : APObjectUtils::ObjectSelector , APConnectEditor::Cut
  • intersection : APCameraMovement::CameraMovementEditor
  • iNumGenCars : CarSim::RoadsState
  • invalidRefToJuncOrPolygPoint : CarSim::RoadsState
  • inverseParentsTransform : APFFDEditor::EditorLogic
  • inverseTransformMatrix : APMenu::DynamicMenu
  • invVisibilityRange : grass::GrassAbilityParameters
  • iObjectUpdatesCounter : vrecko::Scheduler
  • iPointerID : vrecko::CABUTTONEVENT
  • iPolygonsCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iProcessedEventsCounter : vrecko::EventDispatcher
  • iReaders : vrecko::PersistentCache::OpenedCacheFile
  • is : vreckoDP_base::OptiTrack
  • is_initialized : vreckoDP_base::Wiimote
  • isAddingPointState : AP_CableEditor::CableEditor
  • isCell : vrecko::OctTree::OctTreeNode
  • isDeletingSphereState : AP_CableEditor::CableEditor
  • isGenCar : CarSim::CarExecutionUnit
  • isInsertBetweenState : AP_CableEditor::CableEditor
  • isMenu : APConnectEditor::Cut
  • iSpeed : APCameraPath::Camera
  • isSelectedCable : AP_CableEditor::CableEditor
  • isThereaSculpture : APDYNAMICART::Ctrl_PolyhedraSculptures
  • isUpdateState : AP_CableEditor::Cable
  • itemSize : APMenu::MenuItem
  • itemSize2 : APMenu::MenuItem
  • itemTree : APMenu::DynamicMenu
  • iterationCount : APDYNAMICART::InitSettings
  • iVerticesCount : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • iWaitingWriters : vrecko::PersistentCache::OpenedCacheFile
  • iWriters : vrecko::PersistentCache::OpenedCacheFile
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • junctionId : CarSim::PolygonPoint
  • junctions : CarSim::RoadsState
  • justonce
: VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiSphere
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • k1 : VirtualFixture::Filter
  • k2 : VirtualFixture::Filter
  • key : GenericHeap< _NodeClass, _keyType >::GenericHeapNode
  • keydown_map : vreckoDP_base::KeyboardMouse
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • label : VirtualFixture::Marker
  • land_level : boids::BoidsLogic
  • large_projection : BehindObstacleExperiment , BehindObstacleExp_wT
  • last_absPI : vreckoDP_base::LHeadTracker
  • last_absRO : vreckoDP_base::LHeadTracker
  • last_absYA : vreckoDP_base::LHeadTracker
  • last_avatar_pos : ht::HeadTracking
  • last_method : BehindObstacleExp_wT , BehindObstacleExperiment
  • last_position : behindO::WIM::ObjectCopy
  • last_rot : vreckoDP_base::LHeadTracker
  • last_rotation : behindO::WIM::ObjectCopy
  • last_sensor_orientation
: behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
, behindO::EyeManipulator
  • last_sensor_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • last_tick
: vrecko::Scheduler::TimerStruct
, vrecko::vThread
, behindO::CentreObjectManipulator
  • last_transform : base::hand , base::MouseHand
  • lastAddedPoint : APConnectEditor::Cut
  • lastAutorotationTime : APDYNAMICART::Ctrl_PerlinLines
  • lastButtonPressed : APEditorController::EditorController::ECPOINTERINFO
  • lastCarId : CarSim::Edge
  • lastCarInEdge : CarSim::Junction
  • lastCarOutEdge : CarSim::Junction
  • lastDominantAxis : MagicWandTool
  • lastEventButtonID : vrecko::ControllableAbility
  • lastFrame : AP_LSystem::TurtleProperties
  • lastInput : Filter::PosNoiseRemover
  • lastJunc : CarSim::First3Juncs
  • lastJuncInPath : CarSim::Parameters
  • lastMatrix : AP_LSystem::TurtleProperties
  • lastPointerPos : APConnectEditor::Rotation , APMenu::DynamicMenu
  • lastPosition : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • lastRelPointerPos : APEditorQAbilities::AvatarMovement
  • lastRelPointerRot : APEditorQAbilities::AvatarMovement
  • lastRequest : vrecko::ScenePSThreadInfo
  • lastResult : Filter::PosNoiseRemover
  • lastSelTest : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • lastTick : CarSim::CarControlUnit
  • lastTimerTick : APObjectUtils::Animator
  • lastUpdatePartThrIndex : vrecko::Scene
  • lastViewPos : APMenu::DynamicMenu
  • lastWrapperTransformation : AP_CableEditor::Cable
  • latestpos : VirtualFixture::Trace
  • leaf : APSpacePartitioning::VLOD
  • left : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • left_border : behindO::HeadManipulator
  • left_button : vreckoDP_base::L3DMouse
  • left_eye_off : ht::HeadTracking
  • left_hand : VirtualFixture::Avatar , base::Avatar
  • left_leg : base::Avatar , VirtualFixture::Avatar
  • leftBlinkerPath : CarSim::GeometryPartsPath
  • leftContext : AP_LSystem::Rule
  • lefthand_id : BehindObstacleExp_wT , BehindObstacleExperiment
  • leftHandEO : APDYNAMICART::DAEnvironment
  • leftHandEO_ID : base::Avatar , VirtualFixture::Avatar
  • leftWheelsPathVec : CarSim::GeometryPartsPath
  • length
: CarSim::CarSize
, CarSim::Edge
, AP_LSystem::TurtleProperties
, AP_LSystem::StaticString
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
, vreckoDP_base::NestOfBirds
, vreckoDP_base::Ultratrak
  • lengthMultiplier : AP_LSystem::TurtleProperties
  • level : APSpacePartitioning::VLOD
  • levels : APSpacePartitioning::PointShell_Object_Data , APSpacePartitioning::SNCH_Object_Data::DebugStats
  • lifeTime : APDYNAMICART::ParticleSystemParameters
  • lifetime : PhysXPlugin::Particle
  • light : base::Light
  • lightGroup : base::Light
  • lightManager : APLightsEditor::Editor
  • lightMarker : APLightsEditor::Editor
  • lightNumber : base::Light
  • limitToEO1 : vrecko::ScenePSThreadInfo
  • limitToEO2 : vrecko::ScenePSThreadInfo
  • line : LoadingConsole::OutstandingLine
  • linearAttenuation : base::Light
  • lineHeight : LoadingConsole
  • lines : APTextOutput::Console , LoadingConsole
  • lineSpace : APTextOutput::Console , LoadingConsole
  • lmd_store : APSpacePartitioning::SNCH_Object
  • lmd_store_access : APSpacePartitioning::SNCH_Object
  • LMDs : APSpacePartitioning::SNCH_Object::LMDStore
  • LMDswitch : APSpacePartitioning::SNCH_Object::LMDStore
  • loadedObjects : Preloader
  • loadedShapes : AP_CableEditor::CableEditor
  • loadFromFile : CloudsProperties
  • loadingQueue : Preloader
  • loadsave_category : vrecko::ReaderWriter
  • loadsave_Mutex : vrecko::ReaderWriter
  • loadsave_position : vrecko::ReaderWriter
  • located_object : behindO::CentreObjectManipulator
  • location : ChessBoard::Request
  • lockCount : CarSim::JuncsEdge
  • locked : VirtualFixture::AxisLock
  • LOD : grass::GrassDrawable
  • lodEdgeDistanceImporatnce : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • lodEdgeDistanceImportance : APSpacePartitioning::PointShell_Object_Data
  • lodEdgeImporatnce : APSpacePartitioning::PointShell_Object_Data_LOD_Builder , APSpacePartitioning::PointShell_Object_Data
  • lodMaxLevels : APSpacePartitioning::PointShell_Object_Data
  • lodMinimumVertices : APSpacePartitioning::PointShell_Object_Data
  • lodMovableVertices : APSpacePartitioning::PointShell_Object_Data
  • lodPercentageZeroLevelSize : APSpacePartitioning::PointShell_Object_Data
  • lodVertexImporatnce : APSpacePartitioning::PointShell_Object_Data , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • lodZeroLevelSize : APSpacePartitioning::PointShell_Object_Data
  • log_file : vrecko::Logger
  • logTime : APTextOutput::Console::Line
  • look_at_center
: behindO::Manipulator
, behindO::HeadManipulator
, behindO::EyeManipulator
, vrecko::World::AvatarView
, behindO::AvatarManipulator
  • looping : ArtificialWorld::SubBlockAnimation
  • looptime1 : APSpacePartitioning::NoPartitioning_Scene , APSpacePartitioning::PointShellVSVoxel_Object
  • looptime2 : APSpacePartitioning::PointShellVSVoxel_Object , APSpacePartitioning::NoPartitioning_Scene
  • loopType : APObjectUtils::Animator
  • lowBoundForStartStopPosOffset : CarSim::Edge
  • lowClipPlane : APDYNAMICART::ToolSlice , SliceTool , APDYNAMICART::PLControllerTool
  • lowDetailGrassStateSet : grass::GrassAbilityParameters
  • lpBuffer : VK_NoStepInto_Namespace::DynamicArray< _Type > , vrecko::BufferedFile
  • lpChild : DynTreeNode< _Type >
  • lpNext : DynTreeNode< _Type >
  • lpParent : DynTreeNode< _Type >
  • lpPrev : DynTreeNode< _Type >
  • lpRoot : DynamicTree< _Type >
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • m_ : gmMatrix3 , gmMatrix4
  • m_Access : vrecko::MTTwoPrioLimitedLock , vrecko::MTReadWriteLock
  • m_ActPathLine : APCameraPath::Camera
  • m_ActViewLine : APCameraPath::Camera
  • m_AllowLowPrio : vrecko::MTTwoPrioLimitedLock
  • m_Axiom : AP_LSystem::AbstractFile
  • m_CanRead : vrecko::MTReadWriteLock
  • m_CanWrite : vrecko::MTReadWriteLock
  • m_ControlPoints : APCameraPath::Camera
  • m_eAnimate : APCameraPath::Camera
  • m_eState : APCameraPath::Camera
  • m_Geodes : AP_LSystem::AbstractInterpret
  • m_Homomorphisms : AP_LSystem::LSystem , AP_LSystem::AbstractFile
  • m_Ignore : AP_LSystem::LSystem
  • m_Iteration : AP_LSystem::AbstractLSystem
  • m_Length : AP_LSystem::ParseableString
  • m_MainLSystem : AP_LSystem::AbstractGenerator
  • m_Name : AP_LSystem::AbstractFile , AP_LSystem::AbstractLSystem
  • m_numOfViewPts : APCameraPath::Camera
  • m_Owner : AP_LSystem::AbstractInterpret
  • m_pEOCamera : APCameraPath::Camera
  • m_pEOCursor : APCameraPath::Camera
  • m_pEOPathLine : APCameraPath::Camera
  • m_pEOPathPoints : APCameraPath::Camera
  • m_pEOViewLine : APCameraPath::Camera
  • m_Readers : vrecko::MTReadWriteLock
  • m_Rules : AP_LSystem::LSystem , AP_LSystem::AbstractFile
  • m_Str : AP_LSystem::ParseableString
  • m_SubSystemsFilenames : AP_LSystem::LSystem
  • m_SubSystemsWords : AP_LSystem::LSystem
  • m_Subsytems : AP_LSystem::AbstractFile
  • m_Turtles : AP_LSystem::AbstractInterpret
  • m_Type : AP_LSystem::AbstractFile
  • m_Word : AP_LSystem::AbstractGenerator , AP_LSystem::LSystem
  • m_WriterMutex : vrecko::MTReadWriteLock
  • m_WritersMutex : vrecko::MTTwoPrioLimitedLock
  • magnetCreated : APDYNAMICART::Ctrl_PerlinLines
  • magnetEO : APDYNAMICART::Ctrl_PerlinLines , APDYNAMICART::PerlinLines
  • magnetGeode : APDYNAMICART::PerlinLines
  • magnetMaterial : APDYNAMICART::PerlinLines
  • magnetStateSet : APDYNAMICART::PerlinLines
  • main_wiimote : vreckoDP_base::Wiimote
  • mainLightSource : vrecko::World
  • mainLock : vrecko::AbilityDispatcher , vrecko::EventDispatcher
  • mainNode : LoadingConsole
  • mainObject : APMenu::DynamicMenu
  • mainTransform : APMenu::MenuItem
  • manipulate : base::hand , base::MouseHand
  • mappedAbility : APEditorController::AbilityMapper::BUTTON_MAPPING
  • mappedAbilityID : APEditorController::EditorController::ECPOINTERBUTTONINFO
  • mapping : APEditorController::AbilityMapper
  • mark : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • markers : VirtualFixture::MarkerFactory
  • matrix : AP_LSystem::TurtleProperties , base::MTMatrixTransform
  • max : AABoundingBox , APDYNAMICART::Trait
  • max_analog : Hci
  • max_bound : boids::BoidsLogic
  • max_encoder : Hci
  • max_force : APSpacePartitioning::SNCH_Object
  • max_speed : boids::BoidsLogic
  • max_timer : Hci
  • maxAcc : CarSim::CarState
  • maxArea : grass::GrassAbilityParameters
  • maxBend : grass::GrassAbilityParameters
  • maxButtonsPerPointer : APEditorController::EditorController
  • maxChildrens : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxCloudUpdatesParFrame : CloudsProperties
  • maxCollisionDistance : vrecko::CollisionParams__ver1
  • maxDispWheelAngle : CarSim::CarExecutionUnit
  • maxDist : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • maxDistance : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser , APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxDistanceV1 : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • maxDistanceV2 : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • maxDistVect : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • maxFractions : grass::GrassAbilityParameters
  • maxHeight : grass::GrassAbilityParameters
  • maxJuncId : CarSim::RoadsState
  • maxLevel : base::ShowFDH
  • maxLevels : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • maxLODdifference : grass::GrassAbilityParameters
  • maxPointers : APEditorController::EditorController
  • maxPolygonPointId : CarSim::RoadsState
  • maxSize : MemoryWriteBuffer
  • maxSpeed : CarSim::CarExecutionUnit
  • maxValue : APHUD::HUDField
  • maxVisibility : grass::GrassAbilityParameters
  • maxVisibleDistance : ArtificialWorld::Model , ArtificialWorld::SubBlock
  • maxWidth : grass::GrassAbilityParameters
  • maxX : APDYNAMICART::Limits
  • maxY : APDYNAMICART::Limits
  • maxZ : APDYNAMICART::Limits
  • mean : APDYNAMICART::Trait
  • menu : vrecko::ControllableAbility
  • menuAwayTime : APTextOutput::Console
  • menuGrid_columnsCached : APMenu::DynamicMenu
  • menuGrid_rowsCached : APMenu::DynamicMenu
  • menuShowed : APCameraMovement::CameraMovementEditor
  • menuString : APMenu::DynamicMenu
  • menuType : APMenu::DynamicMenu
  • mesg
: boids::BoidsLogic
, boids::BoidsPlanner
, navigation::AvatarInHand
, navigation::KMTracker
  • mesh : grass::GrassDrawable
  • message : AP_LSystem::LSystemException , vrecko::EventDispatcher::EventStruct
  • method_board : BehindObstacleExp_wT , BehindObstacleExperiment
  • method_desc : BehindObstacleExperiment , BehindObstacleExp_wT
  • methodForProcessing : vrecko::InputPin< _MessageType > , vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • middle_button : vreckoDP_base::L3DMouse
  • min : ThinHeap< _NodeClass, _keyType > , APFFDEditor::GeometryLoaderBase::FaceBase , AABoundingBox , APSpacePartitioning::GeometryLoaderBase::FaceBase , APDYNAMICART::Trait , FibonacciHeap< _NodeClass, _keyType >
  • min_bound : boids::BoidsLogic
  • minAcc : CarSim::CarState
  • minBend : grass::GrassAbilityParameters
  • mIndices : WavefrontObj
  • mindistance : VirtualFixture::Trace
  • minFractions : grass::GrassAbilityParameters
  • minHeight : grass::GrassAbilityParameters
  • minimal_distance : behindO::HeadManipulator
  • minspeed : VirtualFixture::Damper
  • minSpeed : CarSim::CarExecutionUnit
  • minValue : APHUD::HUDField
  • minVertices : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • minVisibility : grass::GrassAbilityParameters
  • minVisibleDistance : ArtificialWorld::Model
  • minWidth : grass::GrassAbilityParameters
  • minX : APDYNAMICART::Limits
  • minY : APDYNAMICART::Limits
  • minZ : APDYNAMICART::Limits
  • mirror_object : behindO::MyCullCallback
  • mirror_plane_transf : behindO::Mirror
  • mirror_plane_vertices : behindO::Mirror
  • mNormal : WAVEFRONT::GeometryVertex
  • mode : behindO::HeadManipulator
  • model : APMenu::MenuItemText
  • model_name : Hci
  • modelFile : AP_LSystem::TurtleProperties , APMenu::MenuItemText
  • modelFileName : vrecko::EnvironmentObject
  • modelFlags : ArtificialWorld::Model
  • modelTransform : APMenu::MenuItemText
  • modelType : ArtificialWorld::Model , CacheInfo
  • mon_cor_position : ht::ScreenSetupSimple::ScreenSetupSimpleState , ht::SimpleSetupFunction
  • monitor_corner : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • monitor_orientation : ht::ScreenSetup::ScreenSetupState , ht::SetupFunction
  • monitor_position : ht::SetupFunction , ht::ScreenSetup::ScreenSetupState
  • moreDetailedVersion : grass::GrassDrawable
  • mouse_button : vreckoDP_base::KeyboardMouse
  • mouse_pos : navigation::KMTracker
  • mouse_position : vreckoDP_base::KeyboardMouse , base::MouseHand
  • mouse_scroll : navigation::KMTracker
  • mouse_sensitivity_avatar : navigation::KMTracker
  • mouse_sensitivity_hands : navigation::KMTracker
  • mouse_stand_button : vreckoDP_base::L3DMouse
  • mouseUpdateCounter : vreckoDP_base::KeyboardMouse
  • Movable : mv::CPoint , mv::CGesture
  • move : ChessPiece
  • move_direction : navigation::KMTracker
  • move_factor : boids::BoidsLogic
  • move_plane : navigation::KMTracker
  • move_step : navigation::KMTracker , ChessPiece
  • moveLock : APFFDEditor::EditorLogic
  • moveVerticesPosition : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • moving : navigation::KMTracker
  • movingObjectID
: APConnectEditor::Scale
, APConnectEditor::Rotation
, APCameraPath::Camera
, APConstrainedMovement::ConstrainedObjectMovement
, APEditorQAbilities::ObjectMovement
, APEditorQAbilities::SimpleObjectMovement
  • mPos : WAVEFRONT::GeometryVertex
  • mPost : vrecko::PyAbility
  • mProcessEvent : vrecko::PyAbility
  • mTexCoords : WavefrontObj
  • mTexel : WAVEFRONT::GeometryVertex
  • mTriCount : WavefrontObj
  • mUpdate : vrecko::PyAbility
  • mutex : vrecko::MTLock
  • mVertexCount : WavefrontObj
  • mVertices : WavefrontObj
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • name
: base::SystemInfo::MessageSIThreadCreated
, base::SystemInfo::SIThreadInfo
, vrecko::EnvironmentObject
, APRoomEdit::Tool
, APHUD::HUDField
, vrecko::Ability::ParameterStruct
, APHUD::HUDWindow
, APMenu::MenuItem
  • ncoeficient : APSpacePartitioning::SNCH_Object
  • Near : CloudSceneInfo
  • near_border : behindO::HeadManipulator
  • necessaryTime : APTextOutput::Console::Line
  • net_support : vrecko::EventDispatcher
  • neutralColor : grass::GrassAbilityParameters
  • new_cerr : vrecko::Logger
  • new_cout : vrecko::Logger
  • new_mouse_pos_ready : vreckoDP_base::KeyboardMouse
  • new_position : ChessBoard::Request
  • newHandPosition : APDYNAMICART::ToolMagicWand , MagicWandTool
  • newOrientation : MTCreatorTool
  • newPoint : AP_CableEditor::CableEditor
  • newPosition : MTCreatorTool
  • next_free_clipping_plane : behindO::CuttingPlane
  • next_waypoint : boids::BoidsLogic
  • next_waypoint_dist : boids::BoidsLogic
  • nextCarDist : CarSim::CarEnvirons
  • nextCarVel : CarSim::CarEnvirons
  • nextEdgeId : CarSim::JuncsEdge
  • nextFreeID : vrecko::Scene
  • nextJunc : CarSim::First3Juncs
  • nextJuncTurn : CarSim::CarControlUnit , CarSim::CarEnvirons
  • nextNextJunc : CarSim::First3Juncs
  • nic : BehindObstacleExp_wT::ExperimentRec , BehindObstacleExperiment::ExperimentRec
  • NO_HCI_handler : Hci
  • node
: VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • node2
: VirtualFixture::ProxiBorder
, VirtualFixture::Border
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::Sphere
  • nodeMask : ArtificialWorld::AnimationPoint , APObjectUtils::Animator::AnimationPoint
  • nodeMaskSet : ArtificialWorld::AnimationPoint
  • nodePtr : DynamicTreeIterator< _Type >
  • nodes_count : vrecko::ReaderWriter
  • nodeStart : DynamicTreeIterator< _Type >
  • nonlinear : behindO::MappingFunctions
  • norm
: APSpacePartitioning::PointShell_Object_Data_Geometry::V
, APSpacePartitioning::PointShell_Object_Data_Geometry::P
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
, APSpacePartitioning::PLOD
  • normal
: CarSim::CarState
, APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, APFFDEditor::GeometryLoaderBase::FaceBase
, APSpacePartitioning::GeometryLoaderBase::VertexBase
, APFFDEditor::GeometryLoaderBase::VertexBase
, Triangle
, APSpacePartitioning::GeometryLoaderBase::FaceBase
, grass::Vertex
, APSpacePartitioning::SNCH_Object::InternalPointStruct
, CarSim::Edge
  • notifications : vrecko::BaseClass
  • notificationsLock : vrecko::BaseClass
  • notificationTypes : vrecko::BaseClass::NOTIFICATION_DESCRIPTION
  • nowAutorotationTime : APDYNAMICART::Ctrl_PerlinLines
  • nullradius
: VirtualFixture::Plane
, VirtualFixture::Grid
, VirtualFixture::Cone
, VirtualFixture::Sphere
, VirtualFixture::AxisLock
, VirtualFixture::Cylinder
  • nullsize : VirtualFixture::Box
  • num_bytes_needed : packet_rec
  • num_of_markers : VirtualFixture::MarkerFactory , VirtualFixture::Trace
  • num_sensors : vreckoDP_base::fdtDataGlove
  • numberOfCPoints : APFFDEditor::EditorLogic
  • numLanes : CarSim::Edge
  • numOfClouds : CloudsProperties
  • numOfNonTermEdges : CarSim::RoadsState
  • numRuns : vrecko::Logger::TimingInfo
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • objAABox : APEditorQAbilities::ObjectMovement
  • objAABoxTrans : APEditorQAbilities::ObjectMovement
  • object : ode::DynamicScene::MessageODERequest
  • object1 : APEditorQAbilities::AbilityEditor
  • object1ID : APEditorQAbilities::AbilityEditor
  • object2 : APEditorQAbilities::AbilityEditor
  • object2ID : APEditorQAbilities::AbilityEditor
  • object_count : vrecko::OctTree::OctTreeNode
  • objectClass : SNCH_THREAD_START_INFO
  • objectEffect
: APEditorQAbilities::ObjectMovement
, APObjectUtils::ObjectEffectMan
, APObjectUtils::ObjectSelector
  • objectID
: APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
, APSpacePartitioning::PointShellVSVoxel_Object
, APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, APObjectUtils::ObjectEffectMan
, APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • objects : vrecko::Scene::EOIteratorHelper
  • objects_in_cell : vrecko::OctTree::OctTreeNode
  • objectSide : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • objectsToPreload : PreloaderHeuristic
  • objectWasMoved : APFFDEditor::EditorLogic
  • objFileDest : AP_CableEditor::CableEditor
  • objInt : vrecko::Scene::OBJ_INT_PRIO
  • objIntId : vrecko::SP_ObjectInterface
  • objIntPtr : vrecko::CollisionParams__ver1
  • offset : CarSim::CarEdgeData , CarSim::MessageEdgeOffset
  • old_camera_direction : behindO::MyCullCallback
  • old_cerr_buf : vrecko::Logger
  • old_cout : vrecko::Logger
  • old_cout_buf : vrecko::Logger
  • old_mouse_pos : navigation::KMTracker
  • olLock : LoadingConsole
  • once
: VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
  • openedFiles : vrecko::PersistentCache
  • optimalizationOfCP : APFFDEditor::Grid
  • optimOfCP : APFFDEditor::EditorLogic
  • optitrack_origin_position : ht::HeadTracking
  • optitrack_scale : ht::HeadTracking
  • optitrack_translate_mapping : ht::HeadTracking
  • order : APDYNAMICART::symmetry_axis
  • ordered : APSpacePartitioning::PointShell_Object_Data
  • orderedEdges : CarSim::Junction
  • orientation : base::Avatar , MTCreatorTool , DASample
  • origin : vreckoDP_base::LHeadTracker , VirtualFixture::NavSphere
  • origin_WIM_scale : behindO::WIM
  • originalColor : Icon
  • originalHandposition : MagicWandTool
  • originalIterations : APDYNAMICART::ToolMagicWand , MagicWandTool
  • originalStateSet : APObjectUtils::ObjectEffect
  • originalString : vrecko::EventDispatcher::StringWithHash
  • origMenuPos : APMenu::DynamicMenu
  • origViewLookAt : APMenu::DynamicMenu
  • origViewPos : APMenu::DynamicMenu
  • origViewUp : APMenu::DynamicMenu
  • oriString : MTCreatorTool
  • osgadapter_vector : vrecko::EnvironmentObject
  • osgGeode
: APEditorQAbilities::ObjectMovement::SnapBox
, APFFDEditor::Grid
, APGUI::ColorPicker
, APMenu::MenuItem
, APObjectUtils::ObjectEffect
, APObjectUtils::ConnectionViz
  • osgGeom : APFFDEditor::Grid::Edge
  • osgPointerTrail : APMenu::DynamicMenu
  • osgPointerTrailDrawable : APMenu::DynamicMenu
  • osgPointerTrailGeode : APMenu::DynamicMenu
  • osgPointerTrailTransform : APMenu::DynamicMenu
  • osgText : APMenu::MenuItemText
  • osgTransform
: APMenu::MenuItem
, APObjectUtils::ObjectEffect
, APEditorQAbilities::ObjectMovement::SnapBox
  • outerObject_map : vrecko::EventDispatcher
  • outFunc : vrecko::Logger::OutputNotificationFuncStored
  • outFuncs : vrecko::Logger
  • outInVec : CarSim::Edge
  • outPos : CarSim::Edge
  • outputPinsList : vrecko::BaseClass
  • outstandingCounters : vrecko::Logger
  • outstandingLines : LoadingConsole
  • outstandingTexts : vrecko::Logger
  • owner
: APEditorQAbilities::ObjectMovement::SnapBox
, ChessPiece
, base::hand
, behindO::MappingFunctions
, VirtualFixture::Avatar
, vrecko::ControllableAbility
, base::Rotate
, vrecko::IOPinBase
, APObjectUtils::ObjectEffectMan
, base::MTMatrixTransform
, behindO::AvatarManipulator
, base::Light
, APMenu::DynamicMenu
, behindO::WIM
, behindO::EyeManipulator
, boids::Boid
, APObjectUtils::ConnectionViz
, APConnectEditor::Cut
, navigation::KMTracker
, base::MouseHand
, APMenu::MenuItem
, BehindObstacleExperiment
, APEditorController::EditorController::ECPOINTERBUTTONINFO
, base::Avatar
, APObjectUtils::ObjectSelector
, behindO::CentreObjectManipulator
, APObjectUtils::UseToEvent
, APEditorController::EditorController
, vrecko::World::AvatarView
, behindO::HeadManipulator
, BehindObstacleExp_wT
, APObjectUtils::Animator
, behindO::Manipulator
, APObjectUtils::KeepOnScreen
, APObjectUtils::ObjectInfo
, APSpacePartitioning::SP_Object_Data_Base
, APObjectUtils::ObjectModif
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • p1 : APSpacePartitioning::ELOD
  • p1ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
  • p2 : APSpacePartitioning::ELOD
  • p2ID : APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
  • p_act : CloudVoxel
  • p_ext : CloudVoxel
  • p_hum : CloudVoxel
  • pAHeadManipulator : behindO::CentreObjectManipulator
  • pAHMDHeadManipulator : behindO::CentreObjectManipulator
  • pAManipulator : behindO::CentreObjectManipulator
  • param_format : Hci
  • parameter : ode::DynamicScene::MessageODERequest
  • parameters : vrecko::ReaderWriter::AbilityToInitialize
  • parameterString : vrecko::Ability
  • paramMult : MagicWandTool , APDYNAMICART::ToolMagicWand
  • paramRangeEnd : APDYNAMICART::ToolMagicWand , MagicWandTool
  • paramRangeStart : APDYNAMICART::ToolMagicWand , MagicWandTool
  • params
: vrecko::ScenePSThreadInfo
, CarSim::CarControlUnit
, APDYNAMICART::InitSettings
, grass::Grass
, grass::GrassDrawable
  • paramShift1 : APDYNAMICART::ToolMagicWand , MagicWandTool
  • paramShift2 : APDYNAMICART::ToolMagicWand , MagicWandTool
  • parent : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode , FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
  • parent_node : vrecko::OctTree::OctTreeNode
  • parentsTransform : APFFDEditor::EditorLogic
  • parsed : packet_rec
  • particlesEO : APDYNAMICART::PerlinLines
  • partitioningObjectInterfaces : vrecko::Scene
  • partitioningSceneInterfaces : vrecko::Scene
  • partJuncCardinality : CarSim::Junction
  • partThreadsInfo : vrecko::Scene
  • pass : CarSim::CarEnvirons , CarSim::Parameters
  • pastSamples : Filter::PosNoiseRemover
  • path : CarSim::Parameters
  • Path_ptr : APCameraPath::ControlPoint
  • PathCtrlPts : APCameraPath::Camera
  • pathIndex : APCameraMovement::ControlPoint
  • pathLength : APCameraMovement::ControlPoint
  • pathObject : APCameraMovement::CameraMovementEditor
  • pattern : APDYNAMICART::SectorInfo
  • pAvatarCopy : behindO::WIM
  • pAvatarManipulator : BehindObstacleExp_wT , BehindObstacleExperiment , behindO::WIM
  • pAvatarOwner : behindO::WIM
  • pBrakeLightMT : CarSim::Lights
  • pCameraPath : APCameraMovement::CameraMovementEditor
  • pCarPartsNodeCache : CarSim::RoadsState
  • pCenterObjectManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCEU : CarSim::Parameters
  • pChangeOfVisibility : BehindObstacleExp_wT , BehindObstacleExperiment
  • pChild : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • pCube1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCube2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCube3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlane : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlane2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlaneEO : BehindObstacleExp_wT , BehindObstacleExperiment
  • pCuttingPlaneEO2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pEditedObject : APFFDEditor::EditorLogic
  • pendingLine : vrecko::logger_streambuf
  • pEOAvatar : BehindObstacleExp_wT , BehindObstacleExperiment
  • persistentCache : vrecko::World
  • pEventDispatcher
: vreckoDP_base::KeyboardMouse
, vreckoDP_base::MicroScribe3D
, vreckoDP_base::NestOfBirds
, vreckoDP_base::OptiTrack
, vreckoDP_base::VRPN3DMouse
  • pfd_from : ChessBoard
  • pfd_to : ChessBoard
  • pFirstActivation : APConnectEditor::Cut
  • pFloor : BehindObstacleExp_wT , BehindObstacleExperiment
  • pFrontLightMT : CarSim::Lights
  • pGeometryPartsPath : CarSim::CarExecutionUnit
  • pGreenMT : CarSim::TLcolorsMT
  • pGrid : APFFDEditor::EditorLogic
  • pGroup : vrecko::World::SG_CHANGE
  • PHANToMDevice
: VirtualFixture::AxisLock
, VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Damper
, VirtualFixture::Drag
, VirtualFixture::Filter
, VirtualFixture::Grid
, VirtualFixture::Marker
, VirtualFixture::MarkerFactory
, VirtualFixture::NavSphere
, PHEffect
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Vibration
, VirtualFixture::VibrationLabel
, VirtualFixture::VibrationLabelActivator
  • pHeadManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • pHMDHeadManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • piece_location : ChessPiece
  • piece_type : ChessPiece
  • pieces_map : ChessBoard
  • pinName : vrecko::IOPinBase , APObjectUtils::ConnectionViz::Connection
  • pl : ThinHeap< _NodeClass, _keyType >::ThinHeapNode , APDYNAMICART::Ctrl_PerlinLines
  • planeD : APSpacePartitioning::SNCH_Object::OneTri
  • planeNormal : APSpacePartitioning::SNCH_Object::OneTri
  • planes : APEditorQAbilities::ObjectMovement
  • play : ChessBoard
  • player : VirtualFixture::Drag
  • pLeftBlinkerLightMT : CarSim::Lights
  • pLeftHand : BehindObstacleExp_wT , BehindObstacleExperiment
  • pLeftWheelsPosVec : CarSim::CarExecutionUnit
  • pLights : CarSim::CarExecutionUnit
  • pluginName : APEditorQAbilities::AbilityEditor::AllowedAbility
  • pManipulator : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMappingFunctions : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirror3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO2 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMirrorEO3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pMyCullCallback : behindO::Mirror
  • pNode : vrecko::World::SG_CHANGE
  • pobName : APDYNAMICART::PoB
  • pObstacle1 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle10 : BehindObstacleExp_wT
  • pObstacle11 : BehindObstacleExp_wT
  • pObstacle12 : BehindObstacleExp_wT
  • pObstacle13 : BehindObstacleExp_wT
  • pObstacle14 : BehindObstacleExp_wT
  • pObstacle15 : BehindObstacleExp_wT
  • pObstacle16 : BehindObstacleExp_wT
  • pObstacle17 : BehindObstacleExp_wT
  • pObstacle18 : BehindObstacleExp_wT
  • pObstacle19 : BehindObstacleExp_wT
  • pObstacle2 : BehindObstacleExperiment , BehindObstacleExp_wT
  • pObstacle20 : BehindObstacleExp_wT
  • pObstacle3 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle4 : BehindObstacleExp_wT , BehindObstacleExperiment
  • pObstacle5 : BehindObstacleExp_wT
  • pObstacle6 : BehindObstacleExp_wT
  • pObstacle7 : BehindObstacleExp_wT
  • pObstacle8 : BehindObstacleExp_wT
  • pObstacle9 : BehindObstacleExp_wT
  • point : APDYNAMICART::symmetry_axis
  • pointer : vrecko::EnvironmentObject::UserData
  • pointerID : APEditorController::AbilityMapper::BUTTON_MAPPING
  • PointerPosReqString : APDYNAMICART::ToolMagicWand , MagicWandTool
  • pointers : APEditorController::EditorController
  • pointerSelected : APMenu::DynamicMenu
  • pointIndex : APCameraMovement::CameraMovementEditor
  • points
: vrecko::CollisionPointInfo
, vrecko::CollisionInfo
, APObjectUtils::Animator
  • pointShellSize : APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
  • pointsTrans : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • pointType : APCameraMovement::CameraMovementEditor
  • polygonPoints : CarSim::RoadsState
  • polygons
: APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
  • polygonsCount : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • pom : navigation::AvatarInHand
  • pOrangeMT : CarSim::TLcolorsMT
  • port_fd : vreckoDP_base::fsPinchGlove , vreckoDP_base::LHeadTracker
  • port_fd_dual : vreckoDP_base::LHeadTracker
  • port_name : vrecko::Device
  • pos : APSpacePartitioning::SNCH_Object::InternalPointStruct
  • Pos : mv::CPoint
  • pos
: APSpacePartitioning::PointShell_Object_Data_Geometry::V
, APEditorController::EditorController::ECPOINTERINFO
, APFFDEditor::GeometryLoaderBase::VertexBase
, APMenu::MenuItem
, APSpacePartitioning::GeometryLoaderBase::VertexBase
, APSpacePartitioning::PointShell_SimpleNode
, vreckoDP_base::LHeadTracker
  • pos_diff : vreckoDP_base::LHeadTracker
  • position
: VirtualFixture::Log
, grass::Vertex
, DASample
, VirtualFixture::ProxiSphere
, VirtualFixture::Marker
, VirtualFixture::Plane
, VirtualFixture::ProxiCone
, VirtualFixture::Drag
, CarSim::Junction
, PhysXPlugin::Particle
, VirtualFixture::AxisLock
, APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
, SunLight
, APCameraMovement::ControlPoint
, base::Light
, vrecko::OctTree::OctTreeNode
, CarSim::PolygonPoint
, CacheInfo
, ArtificialWorld::Model
, ArtificialWorld::SubBlock
, CarSim::CarState
, Particle
, APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
, MTCreatorTool
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Grid
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCylinder
, VirtualFixture::Sphere
  • posRaw : APEditorController::EditorController::ECPOINTERINFO
  • posString : MTCreatorTool , APDYNAMICART::Ctrl_PerlinLines , MagicWandTool
  • posX
: APObjectUtils::KeepOnScreen
, APHUD::HUDField
, APHUD::HUDWindow
  • posY
: APHUD::HUDField
, APHUD::HUDWindow
, APObjectUtils::KeepOnScreen
  • pOT : vreckoDP_base::OptiTrack::info_struct
  • pOwner : vrecko::Ability
  • pParameterVector : base::ShowFDH , base::Rotate
  • pParent : APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
  • pReceiver : vrecko::EventDispatcher::EventStruct
  • predefinedShapes : AP_CableEditor::CableEditor
  • pRedMT : CarSim::TLcolorsMT
  • preferredObjectInterface : vrecko::CollisionParams__ver1
  • preferredSceneInterface : vrecko::CollisionParams__ver1
  • pRemover : CarSim::RoadsState
  • prevEdgeId : CarSim::JuncsEdge
  • previousObjectPosition : APFFDEditor::EditorLogic
  • prevPointerPos : APConstrainedMovement::ConstrainedObjectMovement
  • prevPos : APFFDEditor::Grid::ControlPoint
  • pRightBlinkerLightMT : CarSim::Lights
  • pRightHand : BehindObstacleExperiment , BehindObstacleExp_wT
  • priority : vrecko::Scene::OBJ_INT_PRIO
  • Priority : base::_THREAD_BASIC_INFORMATION
  • priority : vrecko::BaseClass , vrecko::Scene::SC_INT_PRIO
  • private_timer_map : vrecko::Scheduler
  • pRoadsState : CarSim::CarControlUnit
  • probabilityFactor : AP_LSystem::Rule
  • product_id : Hci
  • product_name : Hci
  • projection : vrecko::World::AvatarEye
  • projPointerPos : APMenu::DynamicMenu
  • properties : AP_LSystem::AbstractTurtle , CloudsManager
  • pScene : vrecko::World , BehindObstacleExp_wT
  • pSelectionBox : behindO::ChangeOfVisibility
  • pStateSet : vrecko::World::SG_CHANGE
  • pTempl : BehindObstacleExperiment , BehindObstacleExp_wT
  • pText : vrecko::World::SG_CHANGE
  • pTLcolorsMTvec : CarSim::TLsOnJuncManager
  • pTLcolorsVec : CarSim::TLsOnJuncManager
  • pTLcolumnModel : CarSim::RoadsState
  • pTLgreenIntervVec : CarSim::TLsOnJuncManager
  • pTLorangeModel : CarSim::RoadsState
  • ptr : APEditorQAbilities::PresentAbility
  • pushing
: VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Plane
  • pushingforce
: VirtualFixture::Cone
, VirtualFixture::Plane
, VirtualFixture::Cylinder
  • putAsideCars : CarSim::Edge
  • pVertexRelposition : APFFDEditor::GeometryLoader::Geometry
  • pVertexStartArray : APFFDEditor::GeometryLoader::Geometry
  • pWheelsVec : CarSim::CarExecutionUnit
  • pWiimote : vreckoDP_base::Wiimote
  • pWIM : BehindObstacleExperiment , BehindObstacleExp_wT
  • pWIMEO : BehindObstacleExperiment , BehindObstacleExp_wT
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • q : navigation::AvatarInHand
  • qc : navigation::AvatarInHand
  • qc_old : navigation::AvatarInHand
  • qd : navigation::AvatarInHand
  • qd_init : navigation::AvatarInHand
  • qd_old : navigation::AvatarInHand
  • qd_old2 : navigation::AvatarInHand
  • qshapeDraw : APMenu::MenuItem
  • quadraticAttenuation : base::Light
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • radius
: AP_LSystem::TurtleProperties
, AABoundingBox
, APSpacePartitioning::VLOD
, VirtualFixture::Plane
, VirtualFixture::ProxiCone
, APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, APSpacePartitioning::PointShell_SimpleNode
, VirtualFixture::Cylinder
, VirtualFixture::Sphere
, VirtualFixture::Trace
, VirtualFixture::NavSphere
  • radius1 : VirtualFixture::Cone
  • radius2 : VirtualFixture::Cone
  • radiusMultiplier : AP_LSystem::TurtleProperties
  • randomRun : APDYNAMICART::InitSettings
  • range : vrecko::Ability::ParameterStruct
  • rangeEnd : APDYNAMICART::Parameter
  • rangeStart : APDYNAMICART::Parameter
  • rank : ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • rayEnd : vrecko::CollisionParams__ver1
  • rayStart : vrecko::CollisionParams__ver1
  • read_len : vreckoDP_base::LHeadTracker
  • realPos : APFFDEditor::GeometryLoaderBase::VertexBase
  • rearOffset : CarSim::EdgesCar
  • rec_out : vreckoDP_base::LHeadTracker
  • received_event_map : vrecko::EventDispatcher
  • receiver
: APGUI::Interconnection
, Receiver
, vrecko::BaseClass::NOTIFICATION_DESCRIPTION
, vrecko::EventDispatcher::ICSBase
, vrecko::EventDispatcher::EventDefinitionStruct
  • receiver_backup : behindO::MappingFunctions
  • receiver_decomposition : vrecko::EventDispatcher
  • receiverPin : vrecko::EventDispatcher::ICSBase
  • recVelocityOnJunc : CarSim::CarControlUnit , CarSim::CarEnvirons
  • reference_point : base::Avatar
  • refillQueue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • refPoint1 : APMenu::MenuItem
  • refPoint2 : APMenu::MenuItem
  • refPoint3 : APMenu::MenuItem
  • registeredItemTypes : APMenu::DynamicMenu
  • reject_distance_for_BS : APSpacePartitioning::SNCH_Object
  • reject_distance_for_surfaces : APSpacePartitioning::SNCH_Object
  • relCall : vreckoDP_base::fsPinchGlove
  • relFunc : vreckoDP_base::fsPinchGlove
  • relPosInGrid : APFFDEditor::GeometryLoaderBase::VertexBase
  • remaining_tests : BehindObstacleExp_wT , BehindObstacleExperiment
  • render_cloud_tex_u1 : CloudParticle
  • render_cloud_tex_u2 : CloudParticle
  • render_cloud_tex_v1 : CloudParticle
  • render_cloud_tex_v2 : CloudParticle
  • renderCloudTexturePath : CloudsProperties
  • req_len : vreckoDP_base::LHeadTracker
  • request_interconnection_map : vrecko::EventDispatcher
  • requestInputPinsList : vrecko::BaseClass
  • requestOutputPinsList : vrecko::BaseClass
  • requiredDeletedEdges : APSpacePartitioning::ELOD
  • rest_time : boids::BoidsLogic
  • result : ConstantColorGen , GradientColorGen , ConstantColorGen
  • result_file : BehindObstacleExp_wT , BehindObstacleExperiment
  • ret_pos : vreckoDP_base::LHeadTracker
  • ret_rot : vreckoDP_base::LHeadTracker
  • ret_rotm : vreckoDP_base::LHeadTracker
  • ret_rotq : vreckoDP_base::LHeadTracker
  • right : FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode , ThinHeap< _NodeClass, _keyType >::ThinHeapNode
  • right_border : behindO::HeadManipulator
  • right_button : vreckoDP_base::L3DMouse
  • right_eye_off : ht::HeadTracking
  • right_hand
: base::Avatar
, VirtualFixture::Avatar
, navigation::KMTracker
  • right_leg : base::Avatar , VirtualFixture::Avatar
  • rightBlinkerPath : CarSim::GeometryPartsPath
  • rightContext : AP_LSystem::Rule
  • righthand_id : BehindObstacleExp_wT , BehindObstacleExperiment
  • rightHandEO : APDYNAMICART::DAEnvironment
  • rightHandEO_ID : VirtualFixture::Avatar , base::Avatar
  • rightHandPosition : APDYNAMICART::Ctrl_PerlinLines
  • rim_height : ht::ScreenSetup::ScreenSetupState , ht::SetupFunction
  • rim_width : ht::ScreenSetup::ScreenSetupState , ht::SetupFunction
  • road : CarSim::MessageRoadAndDir
  • roadId : CarSim::Edge
  • roads : CarSim::RoadsState
  • roadsEdges : CarSim::RoadsState
  • role : grass::GrassDrawable
  • root : APSpacePartitioning::SphereBVH_Object_Data
  • root_node : vrecko::OctTree
  • rootBlockUpdater : PreloaderHeuristic
  • rootNode : LoadingConsole , vrecko::Scene
  • rootSizeCollisions : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeLOD : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeMulti : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeSimple : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rootSizeSingle : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • rot : APEditorController::EditorController::ECPOINTERINFO , vreckoDP_base::LHeadTracker , Triangle
  • rot_diff : vreckoDP_base::LHeadTracker
  • rot_type : vreckoDP_base::LHeadTracker
  • rotating : APConstrainedMovement::ConstrainedObjectMovement
  • rotation
: ArtificialWorld::Model
, APObjectUtils::Animator::AnimationPoint
, ArtificialWorld::AnimationPoint
, ArtificialWorld::SubBlock
  • rotation_matrix : vrecko::EnvironmentObject
  • rotation_step : navigation::KMTracker
  • rotationSet : ArtificialWorld::AnimationPoint
  • rotq : vreckoDP_base::LHeadTracker
  • rotq_diff : vreckoDP_base::LHeadTracker
  • rotRaw : APEditorController::EditorController::ECPOINTERINFO
  • run : vrecko::vThread
  • RVect : mv::CGesture
  • rx_buf : vreckoDP_base::LHeadTracker
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • s_corner : ht::HeadTracking
  • s_height : ht::HeadTracking
  • s_width : ht::HeadTracking
  • samples : MTCreatorTool
  • sAnimationFile : APCameraPath::Camera
  • saveToFile : CloudsProperties
  • scale
: ArtificialWorld::AnimationPoint
, CloudsProperties
, APObjectUtils::Animator::AnimationPoint
, APObjectUtils::KeepOnScreen
, ArtificialWorld::Model
  • scale_vec : vrecko::EnvironmentObject
  • scaleSet : ArtificialWorld::AnimationPoint
  • scare_distance : boids::BoidsLogic
  • scene : vrecko::ScenePSThreadInfo
  • scene_mouse_position : base::MouseHand
  • scene_ptr : vrecko::EventDispatcher
  • sceneFile
: vrecko::BaseClass
, vrecko::EventDispatcher::REQUEST_Struct
, vrecko::EventDispatcher::EventDefinitionStruct
  • sceneInfo : CloudsManager
  • scInt : vrecko::Scene::SC_INT_PRIO
  • scIntId : vrecko::SP_SceneInterface
  • scIntPtr : vrecko::CollisionParams__ver1
  • score_map : behindO::CentreObjectManipulator
  • screen : ht::HeadTracking
  • screenHeight : CloudSceneInfo
  • screenWidth : CloudSceneInfo
  • sculptureSize : APDYNAMICART::Configuration
  • searchFinnished : PreloaderHeuristic
  • secCount : CarSim::TLsOnJuncManager
  • sectionsTiming : vrecko::Logger
  • sector : APDYNAMICART::SectorInfo
  • selected_object : base::hand , base::MouseHand
  • selectedCableBaseRadius : AP_CableEditor::CableEditor
  • selectedCableId : AP_CableEditor::CableEditor
  • selectedCablePtr : AP_CableEditor::CableEditor
  • selectedItem : APMenu::DynamicMenu
  • selectedObject : APConnectEditor::Cut
  • selectedObjectID : APCameraMovement::CameraMovementEditor
  • selectedPlanes : APEditorQAbilities::ObjectMovement
  • selection_point : behindO::ChangeOfVisibility
  • selObjectID : APConnectEditor::Cut , APObjectUtils::ObjectSelector
  • selPath : APEditorController::EditorController::ECPOINTERINFO
  • sender
: vrecko::EventDispatcher::ICS
, vrecko::EventDispatcher::EventDefinitionStruct
, APGUI::Interconnection
, ode::DynamicScene::MessageODERequest
  • sender_backup : behindO::MappingFunctions
  • sender_decomposition : vrecko::EventDispatcher
  • senderIdOrInputName : vrecko::EventDispatcher::EventStruct
  • senderString : vrecko::BaseClass , Receiver
  • senderStringWithOutputName : vrecko::OutputPin< _MessageType > , vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >
  • sendflag
: VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
  • sensor_count : vreckoDP_base::OptiTrack
  • sensor_offset
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • sensor_relative_pos
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::HMDHeadManipulator
, behindO::Manipulator
  • sensorNumber : MagicWandTool , MTCreatorTool
  • sensorScale : vreckoDP_base::OptiTrack
  • serial_number : Hci
  • server_address : vreckoDP_base::OptiTrack
  • SetNode : APFFDEditor::GeometryLoader::Geometry
  • settleIterations : APDYNAMICART::InitSettings
  • shadeMode : APLightsEditor::Editor , APLightsEditor::Lights
  • shadowedScene : vrecko::World
  • shadowEO : APMenu::DynamicMenu
  • shadowMode : APLightsEditor::Editor , APLightsEditor::Lights
  • shadowObject : APEditorQAbilities::ObjectMovement
  • shapeBox
: APEditorQAbilities::ObjectMovement::SnapBox
, APMenu::MenuItem
, APObjectUtils::ObjectEffect
  • shapeCone : APObjectUtils::ConnectionViz::Connection
  • shapeCurveGenerator : APDYNAMICART::Configuration
  • shapeDraw
: APEditorQAbilities::ObjectMovement::SnapBox
, APMenu::MenuItem
, APObjectUtils::ConnectionViz::Connection
, APObjectUtils::ObjectEffect
  • shapeDrawables : APObjectUtils::ObjectEffect
  • shapePoints : AP_CableEditor::Cable
  • shapeSection : APMenu::MenuItem
  • shapesFile : AP_CableEditor::CableEditor
  • shapeSphere : APObjectUtils::ObjectEffect
  • shiftLen2 : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • shiftVec : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • sibling : BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
  • side : AABoundingBox
  • sight_angle : boids::BoidsLogic
  • signName : APMenu::MenuItemText
  • signObject : APMenu::MenuItemText
  • signs : APMenu::DynamicMenu
  • signTransform : APMenu::MenuItemText
  • size
: APDYNAMICART::InitSettings
, APDYNAMICART::DATool
, Particle
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
, VirtualFixture::Box
, VirtualFixture::ProxiBox
  • sizeBirth : APDYNAMICART::ParticleSystemParameters
  • sizeDeath : APDYNAMICART::ParticleSystemParameters
  • sizeX : APHUD::HUDWindow
  • sizeY : APHUD::HUDWindow
  • skyboxCenterPosition : CloudsProperties
  • skyboxShow : CloudsProperties
  • skyboxSize : CloudsProperties
  • skyBoxTexturePathEast : CloudsProperties
  • skyBoxTexturePathNorth : CloudsProperties
  • skyBoxTexturePathSouth : CloudsProperties
  • skyBoxTexturePathTop : CloudsProperties
  • skyBoxTexturePathWest : CloudsProperties
  • slideMax : APTextOutput::Console
  • sliderDrawM : APMenu::MenuItemSlider
  • sliderDrawNM : APMenu::MenuItemSlider
  • sliderMovable : APMenu::MenuItemSlider
  • sliderNonmovable : APMenu::MenuItemSlider
  • small_distance : boids::BoidsLogic
  • smer : navigation::KMTracker
  • smer3d : navigation::KMTracker
  • snapBoxes : APEditorQAbilities::ObjectMovement
  • snapPoint : APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
  • sockfd : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • sockname : vreckoDP_base::NestOfBirds , vreckoDP_base::Ultratrak
  • soCuttingLoop : APConnectEditor::Cut
  • SOparent_mat : base::hand , base::MouseHand
  • SortAway : Cloud
  • sourceID : APConnectEditor::Optimalizer
  • space_scale : behindO::MappingFunctions
  • space_size : vrecko::OctTree
  • spBranchingFactor : APSpacePartitioning::PointShell_Object_Data
  • specialCase : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • speed2force : VirtualFixture::Damper
  • speedMax : APDYNAMICART::ParticleSystemParameters
  • speedMin : APDYNAMICART::ParticleSystemParameters
  • sphereBetweenPoints : AP_CableEditor::CableEditor
  • spheresRadius : APGUI::ColorPicker
  • SPoint : mv::CGesture
  • spotCutoff : base::Light
  • spotExponent : base::Light
  • square_size : ChessBoard
  • start : Sector , navigation::AvatarInHand
  • start_tick : BehindObstacleExp_wT , BehindObstacleExperiment
  • startDirection : CarSim::CarControlUnit
  • startEdge : CarSim::StartStopDestination
  • startOffset : CarSim::StartStopDestination
  • startPos : APFFDEditor::Grid::ControlPoint
  • startRoad : CarSim::CarControlUnit
  • startStopDestination : CarSim::Parameters
  • startTime : vrecko::Logger::TimingInfo
  • starttime_stamp : vrecko::Logger
  • startWindowHeight : APHUD::HUDDisplay
  • startWindowWidth : APHUD::HUDDisplay
  • state : vrecko::Scheduler
  • stateSet : APHUD::HUDDisplay , APObjectUtils::Animator
  • stateset_map : behindO::CuttingPlane
  • staticStrings : AP_LSystem::Rule
  • status : ChessBoard
  • step : base::Rotate
  • step_counter : vrecko::vThread
  • steps_before_disable_state : ode::ODEObject
  • stereoscopic : BehindObstacleExp_wT , BehindObstacleExperiment
  • stiffness
: VirtualFixture::AxisLock
, VirtualFixture::Box
, VirtualFixture::Cylinder
, VirtualFixture::Cone
, VirtualFixture::Sphere
, VirtualFixture::Grid
, VirtualFixture::NavSphere
, VirtualFixture::Plane
  • stopBeforeJuncOffset : CarSim::Edge
  • stopDirection : CarSim::CarControlUnit
  • stoped : CarSim::CarState
  • stopEdge : CarSim::StartStopDestination
  • stopOffset : CarSim::StartStopDestination
  • stopOrGoDecisionOffset : CarSim::Edge
  • stopped : navigation::KMTracker
  • stopRoad : CarSim::CarControlUnit
  • store_origin_flag : VirtualFixture::NavSphere
  • str : vrecko::Logger::OutstandingText , AP_LSystem::StaticString
  • strategy : APDYNAMICART::InitSettings
  • strictPredecessor : AP_LSystem::Rule
  • stringDamper : APDYNAMICART::SimulationParameters
  • stringSpring : APDYNAMICART::SimulationParameters
  • strName : vrecko::Logger::OutstandingCounter
  • strObjectIDReq : APObjectUtils::ObjectEffectMan
  • strOrientationEvent : APObjectUtils::ObjectInfo
  • strPositionEvent : APObjectUtils::ObjectInfo
  • subBlockType : ArtificialWorld::SubBlock
  • subspace_size : vrecko::OctTree::OctTreeNode
  • sun : CloudsProperties
  • sunColor : SunLight
  • sunID : APLightsEditor::Editor
  • sunShow : CloudsProperties
  • suspend_button : vreckoDP_base::L3DMouse
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • T_ID : vreckoDP_base::OptiTrack::info_struct
  • takeoff_time : boids::BoidsLogic
  • targetID : APConnectEditor::Optimalizer
  • targetName : APDYNAMICART::PoB
  • TebBaseAddress : base::_THREAD_BASIC_INFORMATION
  • temp_entity_map : vrecko::vThread
  • tempTransformMatrix : vrecko::EnvironmentObject
  • tenv : vreckoDP_base::LHeadTracker
  • test_counter : BehindObstacleExp_wT , BehindObstacleExperiment
  • test_Queue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • test_Subdivision_Queue : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • texCoordT : AP_LSystem::TurtleProperties
  • texRepeatingS : AP_LSystem::TurtleProperties
  • text
: APTextOutput::Console::Line
, LoadingConsole::Line
, APHUD::HUDField
  • text_geode : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_material : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_state : BehindObstacleExp_wT , BehindObstacleExperiment
  • text_string : vrecko::World::SG_CHANGE
  • textShift : APMenu::MenuItemText
  • texture_font : BehindObstacleExp_wT , BehindObstacleExperiment
  • textureFile : APDYNAMICART::ParticleSystemParameters
  • th_read : vrecko::vThread
  • theLock : vrecko::MTAutoLock
  • thisBinormals : AP_CableEditor::Cable
  • thisEoWrapper : AP_CableEditor::Cable
  • thisNormals : AP_CableEditor::Cable
  • thisOwnerPtr : APFFDEditor::GeometryLoaderBase
  • thisTangents : AP_CableEditor::Cable
  • thread_ptr : vrecko::Scheduler::TimerStruct
  • threadPtr : vrecko::DeviceManager::DT
  • threadsInfo : base::SystemInfo
  • threadsInit : base::SystemInfo
  • ticks : vreckoDP_base::fsPinchGlove
  • time : vrecko::Logger::OutstandingCounter , Filter::PosNoiseRemover::SAMPLE
  • TIMED_OUT_handler : Hci
  • timeDivision : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • timeForLoop : ArtificialWorld::SubBlockAnimation
  • timeFromLastBlinkStart : CarSim::CarExecutionUnit
  • timePerLoop : APObjectUtils::Animator
  • timer : vrecko::vThread , BehindObstacleExp_wT , BehindObstacleExperiment , behindO::CentreObjectManipulator , Hci , vreckoDP_base::KeyboardMouse
  • timer_board : BehindObstacleExp_wT , BehindObstacleExperiment
  • timer_map : vrecko::Scheduler
  • timer_updated : Hci
  • timestamp : CacheInfo
  • timeWaiting : CarSim::CarControlUnit
  • title : APDYNAMICART::Parameter
  • tlColors : CarSim::JuncsEdge
  • tlColorsCenterDist : CarSim::RoadsState
  • tlGreenInterv : CarSim::Edge
  • tlIndex : CarSim::TLsOnJuncManager
  • tnode
: VirtualFixture::Border
, VirtualFixture::Box
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::NavSphere
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCone
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiSphere
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • to : CarSim::Edge
  • to_center
: behindO::AvatarManipulator
, behindO::EyeManipulator
, behindO::HeadManipulator
, behindO::Manipulator
  • toolType : APDYNAMICART::DATool
  • top_border : behindO::HeadManipulator
  • topClipPlane : APDYNAMICART::PLControllerTool , APDYNAMICART::ToolSlice , SliceTool
  • toPointRight : CarSim::Edge
  • totalNodes : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • totalPathLength : APCameraMovement::ControlPoint
  • totalTime : vrecko::Logger::TimingInfo
  • tr_matrix : vreckoDP_base::LHeadTracker
  • tr_matrix2 : vreckoDP_base::LHeadTracker
  • tracker : vreckoDP_base::OptiTrack
  • traits : APDYNAMICART::HoopGeometry
  • trans_vec : vrecko::EnvironmentObject
  • transf : base::ShowFDH , base::ShowFDHModel , Triangle
  • transformMatrix : APFFDEditor::GeometryLoader::Geometry
  • translate : ode::CompositeObject , ode::ODEObject
  • translate_mapping : vreckoDP_base::LHeadTracker
  • translatedFileName : vrecko::PersistentCache::OpenedCacheFile
  • translateErrorTolerance : CloudsProperties
  • translation : APObjectUtils::Animator::AnimationPoint , ArtificialWorld::AnimationPoint
  • translationSet : ArtificialWorld::AnimationPoint
  • transp : BehindObstacleExp_wT , BehindObstacleExperiment
  • transparency
: VirtualFixture::Cone
, VirtualFixture::ProxiSphere
, VirtualFixture::Trace
, vrecko::EnvironmentObject
, VirtualFixture::ProxiBorder
, VirtualFixture::Cylinder
, VirtualFixture::Box
, VirtualFixture::ProxiCone
, VirtualFixture::NavSphere
, behindO::ChangeOfVisibility
, VirtualFixture::Border
, VirtualFixture::Plane
, VirtualFixture::ProxiBox
, VirtualFixture::ProxiCylinder
, VirtualFixture::Sphere
  • transparency2
: VirtualFixture::Cylinder
, VirtualFixture::Plane
, VirtualFixture::ProxiBorder
, VirtualFixture::Cone
, VirtualFixture::Border
, VirtualFixture::Sphere
, VirtualFixture::Trace
  • transparencyOfEditedObject : APFFDEditor::EditorLogic
  • transPointerPos : APMenu::DynamicMenu
  • transViewPos : APMenu::DynamicMenu
  • tree : DynTreeNode< _Type > , DynamicTreeIterator< _Type >
  • treeLOD : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeLODCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeMultiLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeMultiLevelCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeRoots : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • treeSimple : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSimpleCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSingleLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • treeSingleLevelCreated : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • triangle : Triangle
  • triangles : grass::Mesh
  • tropismAngle : AP_LSystem::TurtleProperties
  • tropismElasticity : AP_LSystem::TurtleProperties
  • tropismVector : AP_LSystem::TurtleProperties
  • two_handed : BehindObstacleExperiment , BehindObstacleExp_wT
  • twoNeighbours : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • twoTotal : APSpacePartitioning::SNCH_Object_Data::DebugStats
  • tx_buf : vreckoDP_base::LHeadTracker
  • type
: APRoomEdit::Tool
, PreloaderToLoadInfo
, AP_LSystem::Parameter
, vrecko::EnvironmentObject::UserData
, APGUI::Interconnection
, vrecko::EventDispatcher::EventDefinitionStruct
, CarSim::Edge
, APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
, APObjectUtils::ConnectionViz::Connection
, vrecko::EventDispatcher::ICSBase
, AP_LSystem::LSystemException
, Icon
, vrecko::CAINFO__VER1
, vrecko::World::SG_CHANGE
, ode::DynamicScene::MessageODERequest
, ChessBoard::Request
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • UniqueProcess : base::_CLIENT_ID
  • UniqueThread : base::_CLIENT_ID
  • unit : ht::HeadTracking
  • up_vector
: vrecko::World::AvatarView
, behindO::HMDHeadManipulator
, behindO::Manipulator
, behindO::AvatarManipulator
, behindO::MyCullCallback
, boids::Boid
, behindO::EyeManipulator
, behindO::HeadManipulator
  • updated : vrecko::Ability
  • updateMMap : vrecko::Scheduler
  • user_data : vrecko::EnvironmentObject
  • user_name : BehindObstacleExperiment , BehindObstacleExp_wT
  • userParam : vrecko::Logger::OutputNotificationFuncStored
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • v : CarSim::CarState , APSpacePartitioning::SNCH_Object::OneTri
  • v1 : Triangle3v , Triangle3
  • v1ID : APSpacePartitioning::PointShell_Object_Data_Geometry::E , APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v2 : Triangle3v , Triangle3
  • v2ID : APSpacePartitioning::PointShell_Object_Data_Geometry::E , APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v3 : Triangle3 , Triangle3v
  • v3ID : APSpacePartitioning::PointShell_Object_Data_Geometry::P
  • v_ : gmVector4 , gmVector2 , gmVector3
  • valid : APSpacePartitioning::VLOD , APSpacePartitioning::ELOD
  • value
: APDYNAMICART::Parameter
, AP_LSystem::Parameter
, APMenu::DynamicMenuSign
  • variables : AP_LSystem::Rule
  • vec : Filter::PosNoiseRemover::SAMPLE
  • vector
: APEditorController::AbilityMapper::MAPPING
, VirtualFixture::Cone
, VirtualFixture::Cylinder
, VirtualFixture::Grid
, VirtualFixture::Plane
, VirtualFixture::ProxiCylinder
  • vectorCounterPathWise : APCameraMovement::ControlPoint
  • vectorPathWise : APCameraMovement::ControlPoint
  • Vectors : mv::CGesture
  • vecTriMaxNegativeDistance : vrecko::CollisionPointInfo
  • vecTriMaxNegDist : APSpacePartitioning::SNCH_Object::LocalMinimumDistance
  • vel : CarSim::EdgesCar
  • velocity : PhysXPlugin::Particle
  • velocity_factor : boids::BoidsLogic
  • version : behindO::CentreObjectManipulator , Hci
  • vert
: base::ShowFDH
, base::ShowFDHModel
, navigation::KMTracker
  • vertAlign : APObjectUtils::KeepOnScreen
  • vertex : Triangle
  • vertex_count : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • vertex_size : APFFDEditor::GeometryLoaderBase , APSpacePartitioning::GeometryLoaderBase
  • vertices
: APFFDEditor::GeometryLoaderBase
, APSpacePartitioning::GeometryLoaderBase
, APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
, APSpacePartitioning::PointShell_Object_Data_LOD_Builder
, LoadingConsole
  • vibration : vreckoDP_base::Wiimote
  • vibration_flag : VirtualFixture::NavSphere
  • View_ptr : APCameraPath::ControlPoint
  • ViewCtrlPts : APCameraPath::Camera
  • viewer : APHUD::HUDDisplay , vrecko::World , LoadingConsole
  • viewHeight : LoadingConsole , APHUD::HUDDisplay , APTextOutput::Console
  • viewWidth : APHUD::HUDDisplay , APTextOutput::Console , LoadingConsole
  • vIndex : APSpacePartitioning::GeometryLoaderBase::FaceBase , APFFDEditor::GeometryLoaderBase::FaceBase
  • visibilityRange : grass::GrassAbilityParameters
  • visible
: VirtualFixture::Plane
, VirtualFixture::Border
, VirtualFixture::ProxiBox
, APSpacePartitioning::ELOD
, VirtualFixture::Sphere
, APSpacePartitioning::PLOD
, APHUD::HUDWindow
, VirtualFixture::ProxiCylinder
, VirtualFixture::ProxiBorder
, VirtualFixture::ProxiSphere
, VirtualFixture::Cylinder
, VirtualFixture::Box
, VirtualFixture::ProxiCone
, VirtualFixture::Cone
, VirtualFixture::Trace
, VirtualFixture::NavSphere
, APSpacePartitioning::VLOD
  • visibleMenuRoot : APMenu::DynamicMenu
  • visited : APFFDEditor::Grid::ControlPoint
  • visual_border_object : behindO::WIM
  • voidFuncPtr : vrecko::vThread
  • voxels : APSpacePartitioning::PointShell_Object_Data
  • voxelSize : APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
  • voxResolution : APSpacePartitioning::PointShell_Object_Data
  • vPrevious : CarSim::CarExecutionUnit
  • vrpnServerHandle : vreckoDP_base::VRPN3DMouse
  • vstart_tick : VirtualFixture::Vibration
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • wait : ChessBoard
  • waypoint : boids::BoidsLogic
  • waypoint_speed : boids::BoidsLogic
  • waypoints : boids::BoidsPlanner
  • WBishop : ChessBoard
  • wheelAngle : CarSim::CarState
  • wheelAngleOnJunc : CarSim::CarEnvirons
  • wheelDisplayAngleAroundNormal : CarSim::CarExecutionUnit
  • wheelR : CarSim::CarExecutionUnit
  • wheelRotateAngle : CarSim::CarExecutionUnit
  • wheelsInitMatrixVec : CarSim::CarExecutionUnit
  • white_out_pos : ChessBoard
  • width : CarSim::CarSize
  • widthFPR : CarSim::Edge
  • widthTPR : CarSim::Edge
  • wiimoteID : vreckoDP_base::Wiimote
  • WIM_center : behindO::WIM
  • WIM_commit : behindO::WIM
  • WIM_scale : behindO::WIM
  • WIM_size : behindO::WIM
  • windowDefaultColorA : APHUD::HUDDisplay
  • windowDefaultColorB : APHUD::HUDDisplay
  • windowDefaultColorG : APHUD::HUDDisplay
  • windowDefaultColorR : APHUD::HUDDisplay
  • windowTabHorizontal : APHUD::HUDDisplay
  • windowTabVertical : APHUD::HUDDisplay
  • wire_length
: ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
, ht::SimpleSetupFunction
  • wire_object_map : behindO::CuttingPlane , behindO::ChangeOfVisibility
  • wire_orientation
: ht::SetupFunction
, ht::ScreenSetup::ScreenSetupState
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SimpleSetupFunction
  • wire_position
: ht::ScreenSetup::ScreenSetupState
, ht::SimpleSetupFunction
, ht::ScreenSetupSimple::ScreenSetupSimpleState
, ht::SetupFunction
  • wireframe : behindO::ChangeOfVisibility
  • WKing : ChessBoard
  • WKnight : ChessBoard
  • wOriginalConsoleAttributes : vrecko::Logger
  • work_area_selection : behindO::WIM
  • WPawn : ChessBoard
  • WQueen : ChessBoard
  • wrapperGeode : AP_CableEditor::Cable
  • WRook : ChessBoard
  • WTime : mv::CGesture , mv::CPoint
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • x : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , angle_3D , Point3f , length_3D
  • x_hat1 : VirtualFixture::Filter
  • x_hat2 : VirtualFixture::Filter
  • x_hat_prev1 : VirtualFixture::Filter
  • x_hat_prev2 : VirtualFixture::Filter
  • x_sensitivity : behindO::HeadManipulator
  • x_sensitivity_delta : behindO::HeadManipulator
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • y : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , Point3f , angle_3D , length_3D
  • y_sensitivity : behindO::HeadManipulator
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • z : APSpacePartitioning::PointShell_Object_Data::PSpoint , Point3 , angle_3D , Point3f , length_3D
  • z_position : base::MouseHand
  • z_step : base::MouseHand
  • zeroLevelSize : APSpacePartitioning::PointShell_Object_Data_LOD_Builder
  • zooming : behindO::WIM
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Typedefs

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • AbilityMap : vrecko::AbilityDispatcher
  • AbInitVector : vrecko::ReaderWriter
  • AttributeMap : vrecko::BaseClass
  • Decomposition_vec : vrecko::EventDispatcher
  • DoublePair : Sector
  • DYNTREE_NODEALLOWED : DynamicTree< _Type >
  • DYNTREE_SUBTREEALLOWED : DynamicTree< _Type >
  • EI_Type : vrecko::EventDispatcher
  • EOMap : vrecko::Scene
  • EOVector : vrecko::Scene::EOIteratorHelper
  • func : APDYNAMICART::DAEnvironment
  • HookArray : APDYNAMICART::HookManager
  • LMD_HASH : APSpacePartitioning::SNCH_Object
  • LMD_STORE_MAP : APSpacePartitioning::SNCH_Object
  • LMDvector : APSpacePartitioning::SNCH_Object
  • Object_Pair : ode::DynamicScene
  • OutputNotificationFuncType : vrecko::Logger
  • ParameterVector : vrecko::Ability
  • PinList : vrecko::BaseClass
  • PosRot : APDYNAMICART::PoAState
  • PrivateTimerMap : vrecko::Scheduler
  • PROCESSING_METHOD : vrecko::InputPin< _MessageType > , vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
  • REQUEST_Map : vrecko::EventDispatcher
  • SectorInfoList : APDYNAMICART::SectorManager
  • StateMap : APDYNAMICART::PoAState
  • TimerMap : vrecko::Scheduler
  • TWO_TRIS : APSpacePartitioning::SNCH_Object
  • Vec3Ptr : APDYNAMICART::PerlinLines
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Enumerations

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • animate : APCameraPath::Camera
  • AnimationTypes : APObjectUtils::Animator
  • CandidatePlaneType : APEditorQAbilities::ObjectMovement
  • CAType : vrecko::CAINFO__VER1
  • ConnectionType : APObjectUtils::ConnectionViz::Connection
  • Corner : ht::ScreenSetup
  • CreationType : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • DataType : vrecko::Attribute
  • Direction : Sector
  • EffectType : APObjectUtils::ObjectEffect
  • FDNNodeType : vrecko::ReaderWriter
  • Flags : AP_LSystem::TurtleProperties
  • giModes : APLightsEditor::Lights
  • InterconnectionType : vrecko::EventDispatcher
  • InterpolationType : APObjectUtils::Animator
  • LoopType : APObjectUtils::Animator
  • NotificationTypes : vrecko::BaseClass
  • Plane_type : navigation::KMTracker
  • PlaneType : RegularPolygonSpline
  • ProjectionIntersectionResult : APSpacePartitioning::SNCH_Object
  • RangeType : vrecko::Range
  • ROLE : grass::GrassDrawable
  • SG_OPERATION_TYPE : vrecko::World
  • shadingModes : APLightsEditor::Lights
  • shadowModes : APLightsEditor::Lights
  • SRType : vrecko::EventDispatcher
  • state : APCameraPath::Camera
  • Type : AP_LSystem::Parameter
  • UserData_Type : vrecko::EnvironmentObject
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Enumerator

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • ABILITY : vrecko::EventDispatcher
  • AbilityMapper : vrecko::CAINFO__VER1
  • ACTIVATE_INPUT : vrecko::EventDispatcher
  • ADD_CHILD : vrecko::World
  • ADD_EOCHILD : vrecko::World
  • ANIM_1ST_VIEW : APCameraPath::Camera
  • ANIM_3RD_VIEW : APCameraPath::Camera
  • AnimAlpha : APObjectUtils::Animator
  • AnimNodeMask : APObjectUtils::Animator
  • AnimSRT : APObjectUtils::Animator

- b -

  • BiDi : APObjectUtils::Animator
  • BoundingBox : APObjectUtils::ObjectEffect
  • BoundingSphere : APObjectUtils::ObjectEffect
  • ByVoxels_MultiLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • ByVoxels_SingleLevel : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >

- c -

  • Collisions : APObjectUtils::ObjectEffect
  • Colorize : APObjectUtils::ObjectEffect
  • ColorizeOnTop : APObjectUtils::ObjectEffect
  • ConeIntersection : APSpacePartitioning::SNCH_Object

- d -

  • DEGREES_TO_RADIANS : AP_LSystem::TurtleProperties
  • DELETE_STATESET : vrecko::World
  • DETAILED : grass::GrassDrawable
  • DEVICE : vrecko::EventDispatcher
  • DoubleSided : APObjectUtils::ObjectEffect
  • DRAW_DEBUG_GEOMETRY : AP_LSystem::TurtleProperties
  • DRAW_PIPE_CAPS : AP_LSystem::TurtleProperties
  • DummyCATypeToDWORD : vrecko::CAINFO__VER1

- e -

  • ENVIRONMENTOBJECT : vrecko::EventDispatcher

- f -

  • FaceNormals : APObjectUtils::ObjectEffect
  • FDNAbility : vrecko::ReaderWriter
  • FDNAttribute : vrecko::ReaderWriter
  • FDNDevice : vrecko::ReaderWriter
  • FDNEnvironmentObject : vrecko::ReaderWriter
  • FDNEvent : vrecko::ReaderWriter
  • FDNFilter : vrecko::ReaderWriter
  • FDNReceiver : vrecko::ReaderWriter
  • FDNSimpleNode : vrecko::ReaderWriter
  • FDNUserData : vrecko::ReaderWriter
  • FORWARD_OUTPUT : vrecko::EventDispatcher
  • FULL : APLightsEditor::Lights

- g -

  • GOURAUD : APLightsEditor::Lights

- h -

  • HALF : APLightsEditor::Lights
  • Horizontal_PrioritySnap : APEditorQAbilities::ObjectMovement

- i -

  • Input : APObjectUtils::ConnectionViz::Connection
  • InputRequest : APObjectUtils::ConnectionViz::Connection
  • INTERMEDIATE : grass::GrassDrawable

- l -

  • LeftBottom : ht::ScreenSetup
  • LeftTop : ht::ScreenSetup
  • Linear : APObjectUtils::Animator
  • LOD_Hierarchy : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • LS_BYTE : AP_LSystem::Parameter
  • LS_DOUBLE : AP_LSystem::Parameter
  • LS_FLOAT : AP_LSystem::Parameter
  • LS_INT : AP_LSystem::Parameter
  • LS_UBYTE : AP_LSystem::Parameter
  • LS_UINT : AP_LSystem::Parameter

- m -

  • MINIMIZE_TWIST : AP_LSystem::TurtleProperties

- n -

  • NO : APLightsEditor::Lights
  • NoIntersection : APSpacePartitioning::SNCH_Object
  • NoLoop : APObjectUtils::Animator
  • None : APObjectUtils::ObjectEffect
  • NONE : APLightsEditor::Lights
  • NOTIFICATION_ALL : vrecko::BaseClass
  • NOTIFICATION_DELETE_CLASS : vrecko::BaseClass
  • NOTIFICATION_EO_REGISTERING : vrecko::BaseClass
  • NOTIFICATION_EO_UNREGISTERING : vrecko::BaseClass
  • NOTIFICATION_PROGRAM_TERMINATION : vrecko::BaseClass

- o -

  • OriginalTriangleIntersection : APSpacePartitioning::SNCH_Object
  • Other : APEditorQAbilities::ObjectMovement
  • OUTER_OBJECT : vrecko::EventDispatcher
  • Output : APObjectUtils::ConnectionViz::Connection
  • OutputRequest : APObjectUtils::ConnectionViz::Connection

- p -

  • PHONG : APLightsEditor::Lights
  • plane_xy : navigation::KMTracker
  • plane_xz : navigation::KMTracker
  • plane_yz : navigation::KMTracker
  • PointShell : APObjectUtils::ObjectEffect
  • PolygonNormals : APObjectUtils::ObjectEffect

- r -

  • RANGE_ENUMERATION : vrecko::Range
  • RANGE_INTERVAL : vrecko::Range
  • REMOVE_CHILD : vrecko::World
  • REMOVE_EOCHILD : vrecko::World
  • REQUEST : vrecko::EventDispatcher
  • RightBottom : ht::ScreenSetup
  • RightTop : ht::ScreenSetup

- s -

  • SCENE : vrecko::EventDispatcher
  • SD_FORWARD : Sector
  • SD_REVERSE : Sector
  • SEPARATE_GEOMETRY_FOR_TRANSLUCENT : AP_LSystem::TurtleProperties
  • SET_STATESET : vrecko::World
  • SET_TEXT : vrecko::World
  • SHADOW_MAP : APLightsEditor::Lights
  • Simple : APObjectUtils::Animator , APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • SimpleVREdit : vrecko::CAINFO__VER1
  • Sine : APObjectUtils::Animator
  • SNCH : APObjectUtils::ObjectEffect
  • SNCHFaceGroups : APObjectUtils::ObjectEffect
  • SOFT_SHADOW_MAP : APLightsEditor::Lights
  • SphereBVH : APObjectUtils::ObjectEffect
  • STATE_ANIMATING : APCameraPath::Camera
  • STATE_EDITING : APCameraPath::Camera
  • STATE_MOVING : APCameraPath::Camera

- t -

  • Test : APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
  • TOP_LEVEL : grass::GrassDrawable
  • Transparency : APObjectUtils::ObjectEffect
  • TransparencyOnTop : APObjectUtils::ObjectEffect
  • TYPE_BOOL : vrecko::Attribute
  • TYPE_DOUBLE : vrecko::Attribute
  • TYPE_DYNAMIC : vrecko::Attribute
  • TYPE_FLOAT : vrecko::Attribute
  • TYPE_INT : vrecko::Attribute
  • TYPE_LONG : vrecko::Attribute
  • TYPE_MATRIX : vrecko::Attribute
  • TYPE_QUAT : vrecko::Attribute
  • TYPE_STRING : vrecko::Attribute
  • TYPE_VEC2 : vrecko::Attribute
  • TYPE_VEC3 : vrecko::Attribute
  • TYPE_VEC4 : vrecko::Attribute

- u -

  • UD_BOOL : vrecko::EnvironmentObject
  • UD_DOUBLE : vrecko::EnvironmentObject
  • UD_FLOAT : vrecko::EnvironmentObject
  • UD_INT : vrecko::EnvironmentObject
  • UD_LONG_INT : vrecko::EnvironmentObject
  • UD_MATRIX : vrecko::EnvironmentObject
  • UD_POINTER : vrecko::EnvironmentObject
  • UD_QUAT : vrecko::EnvironmentObject
  • UD_STRING : vrecko::EnvironmentObject
  • UD_UNKNOWN : vrecko::EnvironmentObject
  • UD_USER : vrecko::EnvironmentObject
  • UD_VEC2 : vrecko::EnvironmentObject
  • UD_VEC3 : vrecko::EnvironmentObject
  • UD_VEC4 : vrecko::EnvironmentObject
  • UNKNOWN : vrecko::EventDispatcher
  • Unknown : vrecko::CAINFO__VER1
  • UNKNOWN : vrecko::World
  • USE_QUERIES : AP_LSystem::TurtleProperties

- v -

  • VertexNormals : APObjectUtils::ObjectEffect
  • VoxelGrid : APObjectUtils::ObjectEffect
  • VoxelGridCollisions : APObjectUtils::ObjectEffect

- w -

  • WORLD : vrecko::EventDispatcher

- x -

  • XY : RegularPolygonSpline
  • XZ : RegularPolygonSpline

- y -

  • YZ : RegularPolygonSpline
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: Class Members - Related Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Related Functions
  • c
  • d
  • e
  • f
  • h
  • l
  • m
  • o
  • p
  • s
  • t
  • w

- c -

  • Cloth : PhysXPlugin::ClothDrawable
  • cross : gmVector3

- d -

  • distance : gmVector2 , gmVector3 , gmVector4
  • distanceSquared : gmVector2 , gmVector3 , gmVector4
  • dot : gmVector4 , gmVector2 , gmVector3

- e -

  • EditorLogic : APFFDEditor::Grid

- f -

  • Fluid : PhysXPlugin::FluidDrawable

- h -

  • HierarchyThreadProc : APSpacePartitioning::SP_Object_Data_Base

- l -

  • lerp : gmVector2 , gmVector3 , gmVector4
  • line_distance : gmVector3

- m -

  • MenuItem : APMenu::DynamicMenu

- o -

  • operator!= : DynamicTreeIterator< _Type >
  • operator* : gmMatrix3 , gmMatrix4 , gmVector4 , gmMatrix4 , gmMatrix3 , gmVector2 , gmVector3
  • operator<< : AP_LSystem::ParseableString , gmMatrix3 , gmVector2 , gmVector3 , gmVector4 , gmMatrix4

- p -

  • plane_distance : gmVector3
  • plane_intersect : gmVector3
  • planesCompare : APEditorQAbilities::ObjectMovement

- s -

  • ScenePSThreadProc : vrecko::Scene

- t -

  • Terrain2D : APNature::Terrain2DSegment
  • TriangleCollector : grass::Mesh

- w -

  • World : vrecko::EnvironmentObject , vrecko::Logger
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123456]
o - include |
| o + base |
| | o * AP_base.h |
| | o * Avatar.h |
| | o * Display.h |
| | o * hand.h |
| | o * Light.h |
| | o * MouseHand.h |
| | o * MTMatrixTransform.h |
| | o * Rotate.h |
| | o * ShowFDH.h |
| | o * ShowFDHModel.h |
| | \ * SystemInfo.h |
| o + helpers |
| | o * BufFile.h |
| | o * DynamicArray.h |
| | o * DynamicTree.h |
| | o * Heaps.cpp |
| | o * Heaps.h |
| | o * HelperMacros.h |
| | o * StringHelpers.h |
| | \ * XercesXMLUtils.h |
| o + vrecko |
| | o * Ability.h |
| | o * Attribute.h |
| | o * AttributesDescription.h |
| | o * BaseClass.h |
| | o * BenchmarkWriter.h |
| | o * Device.h |
| | o * DeviceManager.h |
| | o * DynamicAttribute.h |
| | o * Enumeration.h |
| | o * EnvironmentObject.h |
| | o * EventDispatcher.h |
| | o * Interval.h |
| | o * IOPins.h |
| | o * Logger.h |
| | o * Message.h |
| | o * MTLock.h |
| | o * OctTree.h |
| | o * PersistentCache.h |
| | o * PluginManager.h |
| | o * PyAbility.h |
| | o * Range.h |
| | o * ReaderWriter.h |
| | o * Scene.h |
| | o * Scheduler.h |
| | o * SP_CommonDefs.h |
| | o * SP_ObjectInterface.h |
| | o * SP_SceneInterface.h |
| | o * StaticAttribute.h |
| | o * Timer.h |
| | o * Viewer.h |
| | o * vThread.h |
| | \ * World.h |
| o + vreckoAP |
| | o + ArtificialWorld |
| | | o * AP_ArtificialWorld.h |
| | | o * awHelper.h |
| | | o * BlockUpdater.h |
| | | o * Cache.h |
| | | o * model.h |
| | | o * ModelManager.h |
| | | o * Preloader.h |
| | | o * PreloaderHeuristic.h |
| | | o * subblock.h |
| | | o * subblock_animation.h |
| | | \ * WorldBuilder.h |
| | o + behindO |
| | | o * AP_behindO.h |
| | | o * AvatarManipulator.h |
| | | o * BehindObstacleExp_wT.h |
| | | o * BehindObstacleExperiment.h |
| | | o * CentreObjectManipulator.h |
| | | o * ChangeOfVisibility.h |
| | | o * ContactObjectManipulator.h |
| | | o * CreateShadowedScene.h |
| | | o * CuttingPlane.h |
| | | o * EyeManipulator.h |
| | | o * HeadManipulator.h |
| | | o * HMDHeadManipulator.h |
| | | o * Lens.h |
| | | o * Manipulator.h |
| | | o * MappingFunctions.h |
| | | o * Mirror.h |
| | | \ * WIM.h |
| | o + Boids |
| | | o * AP_boids.h |
| | | o * Boid.h |
| | | o * BoidsLogic.h |
| | | \ * BoidsPlanner.h |
| | o + CableEditor |
| | | o * AP_CableEditor.h |
| | | o * Cable.h |
| | | \ * CableEditor.h |
| | o + CameraMovement |
| | | o * AP_CameraMovement.h |
| | | o * CameraMovementEditor.h |
| | | \ * CameraPath.h |
| | o + CameraPath |
| | | o * AP_CameraPath.h |
| | | \ * Camera.h |
| | o + CarSim |
| | | o * AP_CarSim.h |
| | | o * AP_Filter.h |
| | | o * CarControlUnit.h |
| | | o * CarEnvirons.h |
| | | o * CarExecutionUnit.h |
| | | o * CarPartsNodeCache.h |
| | | o * CarState.h |
| | | o * CCUStructs.h |
| | | o * Edge.h |
| | | o * Junction.h |
| | | o * PolygonPoint.h |
| | | o * Remover.h |
| | | o * RoadsEdges.h |
| | | o * RoadsState.h |
| | | \ * TLsOnJuncManager.h |
| | o + ConnectEditor |
| | | o * AP_ConnectEditor.h |
| | | o * ConnectEditor.h |
| | | o * connecting_functions.h |
| | | o * Cut.h |
| | | o * erf.h |
| | | o * functions.h |
| | | o * icp_functions.h |
| | | o * normal.h |
| | | o * Optimalizer.h |
| | | o * PolygonState.h |
| | | o * Rotation.h |
| | | o * Scale.h |
| | | \ * SnapObject.h |
| | o + ConstrainedMovement |
| | | o * AP_ConstrainedMovement.h |
| | | o * ConstrainedObjectMovement.h |
| | | o * ConstraintArea.h |
| | | o * ConstraintDescription.h |
| | | o * ConstraintHierarchy.h |
| | | \ * PolygonUtils.h |
| | o + DynamicArt |
| | | o * AP_DynamicArt.h |
| | | o * Attractor.h |
| | | o * Brush.h |
| | | o * BrushStroke.h |
| | | o * ColorGenAdapter.h |
| | | o * ComputeStrategy.h |
| | | o * ComputeThread.h |
| | | o * Configuration.h |
| | | o * Controller.h |
| | | o * Ctrl_Attractor.h |
| | | o * Ctrl_FreeHandPainting.h |
| | | o * Ctrl_MotionVisualization.h |
| | | o * Ctrl_PerlinLines.h |
| | | o * Ctrl_PolyhedraSculptures.h |
| | | o * Ctrl_StringSculptures.h |
| | | o * DAEnvironment.h |
| | | o * DATool.h |
| | | o * DiameterGenAdapter.h |
| | | o * Hook.h |
| | | o * HookManager.h |
| | | o * Hoop.h |
| | | o * HoopShape.h |
| | | o * JuliaAttractor.h |
| | | o * Modes.h |
| | | o * MotionTrail.h |
| | | o * NullAttractor.h |
| | | o * OrdinaryAttractor.h |
| | | o * Parameters.h |
| | | o * ParticleSystem.h |
| | | o * Pattern.h |
| | | o * PatternGeode.h |
| | | o * PerlinLines.h |
| | | o * PerlinLinesTools.h |
| | | o * PhysXManager.h |
| | | o * PoA.h |
| | | o * PolyhedraSculpture.h |
| | | o * PS_Component.h |
| | | o * PS_emptyClass.h |
| | | o * PS_Face.h |
| | | o * PS_FacePlane.h |
| | | o * PS_FlatShape.h |
| | | o * PS_Layer.h |
| | | o * PS_Polyhedron.h |
| | | o * PS_Symmetry.h |
| | | o * RotationFrameGenAdapter.h |
| | | o * SectorColorGen.h |
| | | o * SectorManager.h |
| | | o * SimpleBox.h |
| | | o * SplineAdapter.h |
| | | o * TimeLineSpline.h |
| | | o * Timing.h |
| | | o * ToolBrush.h |
| | | o * ToolEraser.h |
| | | o * ToolHook.h |
| | | o * ToolMagicWand.h |
| | | o * ToolRotation.h |
| | | o * ToolSelector.h |
| | | o * ToolSlice.h |
| | | o * ToolTongs.h |
| | | \ * Utils.h |
| | o + EditorController |
| | | o * AbilityMapper.h |
| | | o * AP_EditorController.h |
| | | o * ControllableAbility.h |
| | | \ * EditorController.h |
| | o + EditorQAbilities |
| | | o * AbilityEditor.h |
| | | o * AnimatorEditor.h |
| | | o * AP_EditorQAbilities.h |
| | | o * AvatarMovement.h |
| | | o * ObjectAdd.h |
| | | o * ObjectDelete.h |
| | | o * ObjectMovement.h |
| | | o * SceneSave.h |
| | | o * SimpleObjectMovement.h |
| | | \ * UseTrigger.h |
| | o + FFDEditor |
| | | o * AP_FFDEditor.h |
| | | o * EditorLogic.h |
| | | o * GeometryLoader.h |
| | | o * GeometryLoaderBase.h |
| | | \ * Grid.h |
| | o + Filter |
| | | o * AP_Filter.h |
| | | o * Linear.h |
| | | \ * PosNoiseRemover.h |
| | o + games |
| | | o * AP_games.h |
| | | o * ChessBoard.h |
| | | \ * ChessPiece.h |
| | o + Garden |
| | | o * abstract0lsystem.h |
| | | o * abstractfile.h |
| | | o * abstractgenerator.h |
| | | o * abstractinterpret.h |
| | | o * abstractklsystem.h |
| | | o * abstractlsystem.h |
| | | o * abstractturtle.h |
| | | o * AP_Garden.h |
| | | o * configuration.h |
| | | o * d0lsystem.h |
| | | o * hermitpipe.h |
| | | o * jointedpipe.h |
| | | o * loftturtle.h |
| | | o * log.h |
| | | o * longstring.h |
| | | o * lsfile.h |
| | | o * lsgeode.h |
| | | o * lsobject.h |
| | | o * lsystem.h |
| | | o * lsystemexception.h |
| | | o * lsystemgenerator.h |
| | | o * movingturtle.h |
| | | o * par2lsystem.h |
| | | o * pard0lsystem.h |
| | | o * parseablestring.h |
| | | o * parstoch0lsystem.h |
| | | o * query.h |
| | | o * queryinterpret.h |
| | | o * queryturtle.h |
| | | o * randomindex.h |
| | | o * randomizer.h |
| | | o * rectangle.h |
| | | o * rule.h |
| | | o * staticstring.h |
| | | o * straightpipe.h |
| | | o * turtleinterpret.h |
| | | o * turtlestack.h |
| | | o * utils.h |
| | | \ * xmlfile.h |
| | o + GUI |
| | | o * AP_GUI.h |
| | | o * ColorPicker.h |
| | | o * GUI_Controller.h |
| | | o * GUI_item.h |
| | | o * GUI_Text.h |
| | | o * Icon.h |
| | | o * IconColour.h |
| | | o * ItemsGroup.h |
| | | o * Layout.h |
| | | o * Menu.h |
| | | \ * Slider.h |
| | o + HeadTracking |
| | | o * AP_HeadTracking.h |
| | | o * HeadTracking.h |
| | | o * htUtils.h |
| | | o * ScreenSetup.h |
| | | o * ScreenSetupSimple.h |
| | | \ * Solver.h |
| | o + HelloWorld |
| | | o * AP_HelloWorld.h |
| | | \ * MyAbility.h |
| | o + HUD |
| | | o * AP_HUD.h |
| | | \ * HUDDisplay.h |
| | o + InputConnector |
| | | o * AP_InputConnector.h |
| | | \ * InputConnector.h |
| | o + LightsEditor |
| | | o * AP_LightsEditor.h |
| | | o * Editor.h |
| | | o * Lights.h |
| | | \ * UniformUpdateCallback.h |
| | o + Menu |
| | | o * AP_Menu.h |
| | | o * DynamicMenu.h |
| | | o * DynamicMenu_XMLPart.h |
| | | o * osgQ_QSection.h |
| | | \ * osgQ_QShapeDrawable.h |
| | o + Nature |
| | | o + Clouds |
| | | | o * BoundingVol.h |
| | | | o * Cloud.h |
| | | | o * Cloud2DPlacement.h |
| | | | o * Clouds.h |
| | | | o * CloudsManager.h |
| | | | o * GenClouds.h |
| | | | o * math_aux.h |
| | | | o * OSGCloudWrap.h |
| | | | o * OSGskybox.h |
| | | | \ * Texture.h |
| | | o + Grass |
| | | | o * grass.h |
| | | | o * grass_cullcallback.h |
| | | | o * grass_drawable.h |
| | | | o * grass_mesh.h |
| | | | o * grass_parameters.h |
| | | | o * grass_shaders_source.h |
| | | | \ * grass_triangle_collector.h |
| | | o + Terrain |
| | | | o + Algorithms |
| | | | | o * MidpointDisplacementAlgorithm.h | Class containing methods responsible for generation of terrain based on midpoint displacement algorithm
| | | | | o * PerlinNoiseAlgorithm.h | Class containing methods responsible for generation of terrain based on Perlin noise algorithm
| | | | | o * RandomFaultsAlgorithm.h | Class containing methods responsible for generation of terrain based on random faults algorithm
| | | | | \ * TerrainAlgorithm.h | Class containing methods responsible for generation of terrain based on random faults algorithm
| | | | o + Properties |
| | | | | o * Default.h | Static class containing default constant values for all of the terrain properties
| | | | | o * Enumerations.h | Groups several enumerations from the Terrain ability
| | | | | o * GeneratedTerrainProperties.h | Static class containing terrain properties related to the algorithm generated terrain. All values are initialized to the their default values at launch
| | | | | o * HeightMapProperties.h | Static class containing all of the terrain properties related to terrain loaded from heightmap. All values are initialized to the their default values at launch
| | | | | o * MidpointDisplacementProperties.h | Static class containing all of the terrain properties related to the midpoint displacement algorithm. All values are initialized to the their default values at launch
| | | | | o * PerlinNoiseProperties.h | Static class containing all of the terrain properties related to the Perlin noise algorithm. All values are initialized to the their default values at launch
| | | | | o * RandomFaultsProperties.h | Static class containing all of the terrain properties related to the random faults algorithm. All values are initialized to the their default values at launch
| | | | | \ * TerrainProperties.h | Static class containing all of the common terrain properties which need to be accessed from multiple locations along with methods capable of loading it from XML file. All values are initialized to the their default values at launch
| | | | o * Terrain2D.h |
| | | | o * Terrain2DSegment.h |
| | | | o * TerrainAbility.h | Main Terrain class inherited from VRECKO Ability which takes care of the initialization, update and other most important processes
| | | | o * TerrainRandom.h | Static class which groups static methods related to (pseudo-)random number generation
| | | | \ * TerrainUtility.h | Static class which groups several mostly unrelated but highly useful static methods
| | | o + Weather |
| | | | \ * Weather.h |
| | | o * _AP_Atmospheric.h |
| | | \ * AP_Nature.h |
| | o + navigation |
| | | o * AP_navigation.h |
| | | o * AvatarInHand.h |
| | | \ * KMTracker.h |
| | o + ObjectUtils |
| | | o * Animator.h |
| | | o * AP_ObjectUtils.h |
| | | o * ConnectionViz.h |
| | | o * CopyProperties.h |
| | | o * KeepOnScreen.h |
| | | o * ObjectEffect.h |
| | | o * ObjectEffectMan.h |
| | | o * ObjectInfo.h |
| | | o * ObjectModif.h |
| | | o * ObjectSelector.h |
| | | \ * UseToEvent.h |
| | o + ODE |
| | | o * AP_ode.h |
| | | o * CappedCylinder.h |
| | | o * CompositeObject.h |
| | | o * Cube.h |
| | | o * DynamicScene.h |
| | | \ * Sphere.h |
| | o + RoomEdit |
| | | o * AP_RoomEdit.h |
| | | o * ColorBucket.h |
| | | o * CreateHole.h |
| | | o * Geometry.h |
| | | o * HoleRemove.h |
| | | o * PointAdd.h |
| | | o * PointMove.h |
| | | o * RealCmp.h |
| | | o * RoomEditor.h |
| | | o * RoomLoader.h |
| | | o * RoomSaver.h |
| | | o * Tool.h |
| | | o * WallAdd.h |
| | | o * WallGeometry.h |
| | | o * WallMovement.h |
| | | \ * WallRemove.h |
| | o + ShootingSimulation |
| | | o * AP_ShootingSimulation.h |
| | | \ * ShootingSimulation.h |
| | o + SpacePartitioning |
| | | o * AP_SpacePartitioning.h |
| | | o * GeometryLoaderBase.h |
| | | o * NoPartitioning_Scene.h |
| | | o * PointShell_Object_Data.h |
| | | o * PointShell_Object_Data_Geometry.h |
| | | o * PointShell_Object_Data_Geometry_Analyser.h |
| | | o * PointShell_Object_Data_LOD_Builder.h |
| | | o * PointShellVSVoxel_Object.h |
| | | o * SNCH_Object.h |
| | | o * SNCH_Object_Data.h |
| | | o * SP_Object_Data_Base.h |
| | | o * SphereBVH_Object.h |
| | | o * SphereBVH_Object_Data.h |
| | | o * SphereBVH_Scene.h |
| | | o * triangleCube.h |
| | | \ * VoxelGrid_Object_Data.h |
| | \ + TextOutput |
| | o * AP_TextOutput.h |
| | \ * Console.h |
| o + vreckoDP |
| | o + base |
| | | o * A3DBird.h |
| | | o * arm.h |
| | | o * classes.h |
| | | o * DP_base.h |
| | | o * fdtDataGlove.h |
| | | o * fsPinchGlove.h |
| | | o * hci.h |
| | | o * KeyboardMouse.h |
| | | o * L3DMouse.h |
| | | o * LHeadTracker.h |
| | | o * MicroScribe3D.h |
| | | o * NestOfBirds.h |
| | | o * OptiTrack.h |
| | | o * Ultratrak.h |
| | | o * VRPN3DMouse.h |
| | | \ * Wiimote.h |
| | o + Kinect |
| | | o * DP_Kinect.h |
| | | \ * Kinect.h |
| | \ + PHANToM |
| | o * DP_PHANToM.h |
| | o * PHANToM_compile.inc |
| | \ * PHANToM_Device.h |
| \ + vreckoUtils |
| o * HighlightCallback.h |
| o * Math.h |
| o * Menu.h |
| \ * Observer.h |
\ - src |
o + apps |
| \ + vreckoApp |
| o * LoadingConsole.cpp |
| o * LoadingConsole.h |
| o * Main.cpp |
| o * precompiled.cpp |
| \ * precompiled.h |
o + base |
| o * AP_base.cpp |
| o * Avatar.cpp |
| o * Display.cpp |
| o * hand.cpp |
| o * Light.cpp |
| o * MouseHand.cpp |
| o * MTMatrixTransform.cpp |
| o * precompiled.cpp |
| o * precompiled.h |
| o * Rotate.cpp |
| o * ShowFDH.cpp |
| o * ShowFDHModel.cpp |
| \ * SystemInfo.cpp |
o + helpers |
| o * BufFile.cpp |
| o * StringHelpers.cpp |
| \ * XercesXMLUtils.cpp |
o + vrecko |
| o * Ability.cpp |
| o * Arm.cpp |
| o * BaseClass.cpp |
| o * BenchmarkWriter.cpp |
| o * Device.cpp |
| o * DeviceManager.cpp |
| o * EnvironmentObject.cpp |
| o * EventDispatcher.cpp |
| o * IOPins.cpp |
| o * Logger.cpp |
| o * Message.cpp |
| o * MTLock.cpp |
| o * OctTree.cpp |
| o * PersistentCache.cpp |
| o * PluginManager.cpp |
| o * precompiled.cpp |
| o * precompiled.h |
| o * PyAbility.cpp |
| o * ReaderWriter.cpp |
| o * Scene.cpp |
| o * Scheduler.cpp |
| o * SP_CommonDefs.cpp |
| o * Timer.cpp |
| o * Viewer.cpp |
| o * vThread.cpp |
| \ * World.cpp |
o + vreckoAP |
| o + ArtificialWorld |
| | o * AP_ArtificialWorld.cpp |
| | o * BlockUpdater.cpp |
| | o * Cache.cpp |
| | o * model.cpp |
| | o * ModelManager.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * Preloader.cpp |
| | o * PreloaderHeuristic.cpp |
| | o * subblock.cpp |
| | \ * WorldBuilder.cpp |
| o + Boids |
| | o * AP_boids.cpp |
| | o * Boid.cpp |
| | o * BoidsLogic.cpp |
| | \ * BoidsPlanner.cpp |
| o + CableEditor |
| | o * AP_CableEditor.cpp |
| | o * Cable.cpp |
| | \ * CableEditor.cpp |
| o + CameraMovement |
| | o * AP_CameraMovement.cpp |
| | o * CameraMovementEditor.cpp |
| | \ * CameraPath.cpp |
| o + CameraPath |
| | o * AP_CameraPath.cpp |
| | \ * Camera.cpp |
| o + CarSim |
| | o * AP_CarSim.cpp |
| | o * AP_Filter.cpp |
| | o * CarControlUnit.cpp |
| | o * CarExecutionUnit.cpp |
| | o * CarPartsNodeCache.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * Remover.cpp |
| | o * RoadsState.cpp |
| | \ * TLsOnJuncManager.cpp |
| o + ConnectEditor |
| | o * AP_ConnectEditor.cpp |
| | o * ConnectEditor.cpp |
| | o * ConnectEditor_Connecting.cpp |
| | o * ConnectEditor_icp.cpp |
| | o * ConnectEditor_Morphing.cpp |
| | o * ConnectEditor_SnappingRegion.cpp |
| | o * connecting_functions.cpp |
| | o * Cut.cpp |
| | o * erf.cpp |
| | o * functions.cpp |
| | o * icp_functions.cpp |
| | o * normal.cpp |
| | o * Optimalizer.cpp |
| | o * PolygonState.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * Rotation.cpp |
| | o * Scale.cpp |
| | \ * SnapObject.cpp |
| o + ConstrainedMovement |
| | o * AP_ConstrainedMovement.cpp |
| | o * ConstrainedObjectMovement.cpp |
| | o * ConstraintArea.cpp |
| | o * ConstraintDescription.cpp |
| | o * ConstraintHierarchy.cpp |
| | \ * PolygonUtils.cpp |
| o + DynamicArt |
| | o * AP_DynamicArt.cpp |
| | o * Attractor.cpp |
| | o * Brush.cpp |
| | o * BrushStroke.cpp |
| | o * BrushStrokeControlPoint.cpp |
| | o * BrushStrokeControlPoint.h |
| | o * BrushStrokeTriangulator.cpp |
| | o * BrushStrokeTriangulator.h |
| | o * BufferedSpline.cpp |
| | o * BufferedSpline.h |
| | o * CatmullRomInterpolator.cpp |
| | o * CatmullRomInterpolator.h |
| | o * ColorGenAdapter.cpp |
| | o * ComputeThread.cpp |
| | o * ConstantColorGen.h |
| | o * Controller.cpp |
| | o * Ctrl_Attractor.cpp |
| | o * Ctrl_FreeHandPainting.cpp |
| | o * Ctrl_MotionVisualization.cpp |
| | o * Ctrl_PerlinLines.cpp |
| | o * Ctrl_PolyhedraSculptures.cpp |
| | o * Ctrl_StringSculptures.cpp |
| | o * CubicInterpolator.cpp |
| | o * CubicInterpolator.h |
| | o * DAEnvironment.cpp |
| | o * DATool.cpp |
| | o * DiameterGenAdapter.cpp |
| | o * Factories.h |
| | o * FilletSpline.cpp |
| | o * FilletSpline.h |
| | o * FrenetFrame.cpp |
| | o * FrenetFrame.h |
| | o * GradientColorGen.h |
| | o * GradientDiameterGen.h |
| | o * Hook.cpp |
| | o * HookManager.cpp |
| | o * Hoop.cpp |
| | o * HoopGeometry.cpp |
| | o * HoopGeometry.h |
| | o * HoopShape.cpp |
| | o * Icon.cpp |
| | o * Icon.h |
| | o * InterpolatedSpline.cpp |
| | o * InterpolatedSpline.h |
| | o * Interpolator.h |
| | o * JuliaAttractor.cpp |
| | o * LinearInterpolator.cpp |
| | o * LinearInterpolator.h |
| | o * MagicWandTool.cpp |
| | o * MagicWandTool.h |
| | o * Modes.cpp |
| | o * MotionTrail.cpp |
| | o * MTBrush.cpp |
| | o * MTBrush.h |
| | o * MTControlPoint.cpp |
| | o * MTControlPoint.h |
| | o * MTCreatorTool.cpp |
| | o * MTCreatorTool.h |
| | o * MTTriangulator.cpp |
| | o * MTTriangulator.h |
| | o * NullAttractor.cpp |
| | o * OrdinaryAttractor.cpp |
| | o * ParticleSystem.cpp |
| | o * Pattern.cpp |
| | o * PatternGeode.cpp |
| | o * PerlinLines.cpp |
| | o * PerlinLinesTools.cpp |
| | o * PhysXManager.cpp |
| | o * PhysXModule.cpp |
| | o * PhysXModule.h |
| | o * PoA.cpp |
| | o * PoB.cpp |
| | o * PoB.h |
| | o * PolyhedraSculpture.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * PS_Component.cpp |
| | o * PS_Face.cpp |
| | o * PS_FacePlane.cpp |
| | o * PS_FlatShape.cpp |
| | o * PS_Layer.cpp |
| | o * PS_Polyhedron.cpp |
| | o * PS_Symmetry.cpp |
| | o * RegularPolygonSpline.cpp |
| | o * RegularPolygonSpline.h |
| | o * RotationFrameGenAdapter.cpp |
| | o * SampledSpline.cpp |
| | o * SampledSpline.h |
| | o * SectorColorGen.cpp |
| | o * SectorManager.cpp |
| | o * ShapeFactory.cpp |
| | o * ShapeFactory.h |
| | o * ShapeGenerator.cpp |
| | o * ShapeGenerator.h |
| | o * SimpleBox.cpp |
| | o * SliceTool.cpp |
| | o * SliceTool.h |
| | o * SmoothedSpline.cpp |
| | o * SmoothedSpline.h |
| | o * SnapPoint.cpp |
| | o * SnapPoint.h |
| | o * SplineAdapter.cpp |
| | o * SweepSurfaceGeode.cpp |
| | o * SweepSurfaceGeode.h |
| | o * TimeLineSpline.cpp |
| | o * Timing.cpp |
| | o * ToolBrush.cpp |
| | o * ToolEraser.cpp |
| | o * ToolHook.cpp |
| | o * ToolMagicWand.cpp |
| | o * ToolRotation.cpp |
| | o * ToolSelector.cpp |
| | o * ToolSlice.cpp |
| | o * ToolTongs.cpp |
| | \ * Utils.cpp |
| o + EditorController |
| | o * AbilityMapper.cpp |
| | o * AP_EditorController.cpp |
| | o * ControllableAbility.cpp |
| | \ * EditorController.cpp |
| o + EditorQAbilities |
| | o * AbilityEditor.cpp |
| | o * AnimatorEditor.cpp |
| | o * AP_EditorQAbilities.cpp |
| | o * AvatarMovement.cpp |
| | o * ObjectAdd.cpp |
| | o * ObjectDelete.cpp |
| | o * ObjectMovement.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * SceneSave.cpp |
| | o * SimpleObjectMovement.cpp |
| | \ * UseTrigger.cpp |
| o + FFDEditor |
| | o * AP_FFDEditor.cpp |
| | o * EditorLogic.cpp |
| | o * GeometryLoader.cpp |
| | o * GeometryLoaderBase.cpp |
| | o * Grid.cpp |
| | o * precompiled.cpp |
| | \ * precompiled.h |
| o + Garden |
| | o * abstract0lsystem.cpp |
| | o * abstractgenerator.cpp |
| | o * abstractklsystem.cpp |
| | o * AP_Garden.cpp |
| | o * configuration.cpp |
| | o * d0lsystem.cpp |
| | o * hermitpipe.cpp |
| | o * jointedpipe.cpp |
| | o * loftturtle.cpp |
| | o * log.cpp |
| | o * longstring.cpp |
| | o * lsfile.cpp |
| | o * lsgeode.cpp |
| | o * lsobject.cpp |
| | o * lsystem.cpp |
| | o * lsystemgenerator.cpp |
| | o * movingturtle.cpp |
| | o * par2lsystem.cpp |
| | o * pard0lsystem.cpp |
| | o * parseablestring.cpp |
| | o * parstoch0lsystem.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * queryinterpret.cpp |
| | o * rectangle.cpp |
| | o * rule.cpp |
| | o * straightpipe.cpp |
| | o * turtleinterpret.cpp |
| | o * turtlestack.cpp |
| | o * utils.cpp |
| | \ * xmlfile.cpp |
| o + GUI |
| | o * AP_GUI.cpp |
| | o * ColorPicker.cpp |
| | o * GUI_Controller.cpp |
| | o * GUI_item.cpp |
| | o * GUI_Text.cpp |
| | o * Icon.cpp |
| | o * IconColour.cpp |
| | o * ItemsGroup.cpp |
| | o * Layout.cpp |
| | o * Menu.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | \ * Slider.cpp |
| o + HapticCollisionApp |
| | o * AP_HapticCollisionApp.cpp |
| | o * AP_HapticCollisionApp.h |
| | o * CollisionAppController.cpp |
| | \ * CollisionAppController.h |
| o + HeadTracking |
| | o * AP_HeadTracking.cpp |
| | o * HeadTracking.cpp |
| | o * htUtils.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * ScreenSetup.cpp |
| | o * ScreenSetupSimple.cpp |
| | \ * Solver.cpp |
| o + HelloWorld |
| | o * AP_HelloWorld.cpp |
| | \ * MyAbility.cpp |
| o + HUD |
| | o * AP_HUD.cpp |
| | \ * HUDDisplay.cpp |
| o + InputConnector |
| | o * AP_InputConnector.cpp |
| | o * InputConnector.cpp |
| | o * precompiled.cpp |
| | \ * precompiled.h |
| o + LightsEditor |
| | o * AP_LightsEditor.cpp |
| | o * Editor.cpp |
| | o * Lights.cpp |
| | \ * UniformUpdateCallback.cpp |
| o + Menu |
| | o * AP_Menu.cpp |
| | o * DynamicMenu.cpp |
| | o * DynamicMenu_XMLPart.cpp |
| | o * osgQ_QSection.cpp |
| | \ * osgQ_QShapeDrawable.cpp |
| o + Nature |
| | o + Clouds |
| | | o * Cloud.cpp |
| | | o * Cloud2DPlacement.cpp |
| | | o * Clouds.cpp |
| | | o * CloudsManager.cpp |
| | | o * GenClouds.cpp |
| | | o * math_aux.cpp |
| | | o * OSGskybox.cpp |
| | | \ * Texture.cpp |
| | o + Grass |
| | | o * grass.cpp |
| | | o * grass_drawable.cpp |
| | | o * grass_mesh.cpp |
| | | o * grass_parameters.cpp |
| | | \ * grass_triangle_collector.cpp |
| | o + Terrain |
| | | o + Algorithms |
| | | | o * MidpointDisplacementAlgorithm.cpp |
| | | | o * PerlinNoiseAlgorithm.cpp |
| | | | o * RandomFaultsAlgorithm.cpp |
| | | | \ * TerrainAlgorithm.cpp |
| | | o + Properties |
| | | | o * Default.cpp |
| | | | o * GeneratedTerrainProperties.cpp |
| | | | o * HeightMapProperties.cpp |
| | | | o * MidpointDisplacementProperties.cpp |
| | | | o * PerlinNoiseProperties.cpp |
| | | | o * RandomFaultsProperties.cpp |
| | | | \ * TerrainProperties.cpp |
| | | o * Terrain2D.cpp |
| | | o * Terrain2DSegment.cpp |
| | | o * TerrainAbility.cpp |
| | | o * TerrainRandom.cpp |
| | | \ * TerrainUtility.cpp |
| | o + Weather |
| | | \ * Weather.cpp |
| | o * _AP_Atmospheric.cpp |
| | o * _precompiled.cpp |
| | o * _precompiled.h |
| | \ * AP_Nature.cpp |
| o + navigation |
| | o * AP_navigation.cpp |
| | o * AvatarInHand.cpp |
| | o * KMTracker.cpp |
| | o * precompiled.cpp |
| | \ * precompiled.h |
| o + ObjectUtils |
| | o * Animator.cpp |
| | o * AP_ObjectUtils.cpp |
| | o * ConnectionViz.cpp |
| | o * CopyProperties.cpp |
| | o * KeepOnScreen.cpp |
| | o * ObjectEffect.cpp |
| | o * ObjectEffectMan.cpp |
| | o * ObjectInfo.cpp |
| | o * ObjectModif.cpp |
| | o * ObjectSelector.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | \ * UseToEvent.cpp |
| o + PhysX |
| | o + common code |
| | | o * MediaPath.cpp |
| | | o * MediaPath.h |
| | | o * ParticleFactory.cpp |
| | | o * ParticleFactory.h |
| | | o * Stream.cpp |
| | | o * Stream.h |
| | | o * wavefront.cpp |
| | | \ * wavefront.h |
| | o * AP_PhysX.cpp |
| | o * AP_PhysX.h |
| | o * BaseActor.cpp |
| | o * BaseActor.h |
| | o * BaseJoint.cpp |
| | o * BaseJoint.h |
| | o * BasePhysXObject.cpp |
| | o * BasePhysXObject.h |
| | o * Box.cpp |
| | o * Box.h |
| | o * Capsule.cpp |
| | o * Capsule.h |
| | o * Cloth.cpp |
| | o * Cloth.h |
| | o * ClothDrawable.h |
| | o * CoreActorDesc.cpp |
| | o * CoreActorDesc.h |
| | o * CylindricalJoint.h |
| | o * DistanceJoint.cpp |
| | o * DistanceJoint.h |
| | o * ErrorReporter.h |
| | o * FixedJoint.h |
| | o * Fluid.cpp |
| | o * Fluid.h |
| | o * FluidDrawable.h |
| | o * ForceField.cpp |
| | o * ForceField.h |
| | o * Helper.cpp |
| | o * Helper.h |
| | o * MaterialDesc.cpp |
| | o * MaterialDesc.h |
| | o * MaterialManager.cpp |
| | o * MaterialManager.h |
| | o * Particle.h |
| | o * PhysXObject.h |
| | o * PhysXScene.cpp |
| | o * PhysXScene.h |
| | o * PhysXVreckoMessages.cpp |
| | o * PhysXVreckoMessages.h |
| | o * Plane.cpp |
| | o * Plane.h |
| | o * PointInPlaneJoint.h |
| | o * PointOnLineJoint.h |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * PrismaticJoint.h |
| | o * PulleyJoint.cpp |
| | o * PulleyJoint.h |
| | o * RemoteDebugger.cpp |
| | o * RemoteDebugger.h |
| | o * RevoluteJoint.cpp |
| | o * RevoluteJoint.h |
| | o * Sphere.cpp |
| | o * Sphere.h |
| | o * SphericalJoint.cpp |
| | o * SphericalJoint.h |
| | o * UpdatablePhysXObject.cpp |
| | \ * UpdatablePhysXObject.h |
| o + ShootingSimulation |
| | o * AP_ShootingSimulation.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | \ * ShootingSimulation.cpp |
| o + SpacePartitioning |
| | o * AP_SpacePartitioning.cpp |
| | o * GeometryLoaderBase.cpp |
| | o * NoPartitioning_Scene.cpp |
| | o * PointShell_Object_Data.cpp |
| | o * PointShell_Object_Data_Geometry.cpp |
| | o * PointShell_Object_Data_Geometry_Analyser.cpp |
| | o * PointShell_Object_Data_LOD_Builder.cpp |
| | o * PointShellVSVoxel_Object.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * SNCH_Object.cpp |
| | o * SNCH_Object_Data.cpp |
| | o * SP_Object_Data_Base.cpp |
| | o * SphereBVH_Object.cpp |
| | o * SphereBVH_Object_Data.cpp |
| | o * SphereBVH_Scene.cpp |
| | o * triangleCube.cpp |
| | \ * VoxelGrid_Object_Data.cpp |
| o + TextOutput |
| | o * AP_TextOutput.cpp |
| | \ * Console.cpp |
| \ + VF |
| o * AP_VirtualFixture.cpp |
| o * AP_VirtualFixture.h |
| o * Auxiliary.cpp |
| o * Auxiliary.h |
| o * Avatar.cpp |
| o * Avatar.h |
| o * AxisLock.cpp |
| o * AxisLock.h |
| o * Border.cpp |
| o * Border.h |
| o * Box.cpp |
| o * Box.h |
| o * collection.cpp |
| o * collection.h |
| o * Cone.cpp |
| o * Cone.h |
| o * Cylinder.cpp |
| o * Cylinder.h |
| o * Damper.cpp |
| o * Damper.h |
| o * Drag.cpp |
| o * Drag.h |
| o * Filter.cpp |
| o * Filter.h |
| o * gesture.cpp |
| o * gesture.h |
| o * gm.h |
| o * gm_bool.h |
| o * gm_const.h |
| o * gm_mat3.cpp |
| o * gm_mat3.h |
| o * gm_mat4.cpp |
| o * gm_mat4.h |
| o * gm_utils.h |
| o * gm_vec2.h |
| o * gm_vec3.h |
| o * gm_vec4.h |
| o * Grid.cpp |
| o * Grid.h |
| o * Log.cpp |
| o * Log.h |
| o * Marker.cpp |
| o * Marker.h |
| o * MarkerFactory.cpp |
| o * MarkerFactory.h |
| o * mvect++.h |
| o * mvect.cpp |
| o * mvect.h |
| o * NavSphere.cpp |
| o * NavSphere.h |
| o * PHANToMAvatar.cpp |
| o * PHANToMAvatar.h |
| o * PHEffect.cpp |
| o * PHEffect.h |
| o * Plane.cpp |
| o * Plane.h |
| o * player.cpp |
| o * player.h |
| o * ProxiBorder.cpp |
| o * ProxiBorder.h |
| o * ProxiBox.cpp |
| o * ProxiBox.h |
| o * ProxiCone.cpp |
| o * ProxiCone.h |
| o * ProxiCylinder.cpp |
| o * ProxiCylinder.h |
| o * ProxiSphere.cpp |
| o * ProxiSphere.h |
| o * reader.cpp |
| o * reader.h |
| o * Sphere.cpp |
| o * Sphere.h |
| o * Trace.cpp |
| o * Trace.h |
| o * Vibration.cpp |
| o * Vibration.h |
| o * VibrationLabel.cpp |
| o * VibrationLabel.h |
| o * VibrationLabelActivator.cpp |
| \ * VibrationLabelActivator.h |
o + vreckoDP |
| o + base |
| | o * A3DBird.cpp |
| | o * Arm.cpp |
| | o * DP_base.cpp |
| | o * fdtDataGlove.cpp |
| | o * fsPinchGlove.cpp |
| | o * Hci.cpp |
| | o * KeyboardMouse.cpp |
| | o * L3DMouse.cpp |
| | o * LHeadTracker.cpp |
| | o * MicroScribe3D.cpp |
| | o * NestOfBirds.cpp |
| | o * OptiTrack.cpp |
| | o * precompiled.cpp |
| | o * precompiled.h |
| | o * Serial.cpp |
| | o * Timing.cpp |
| | o * Ultratrak.cpp |
| | o * VRPN3DMouse.cpp |
| | \ * Wiimote.cpp | Example using the wiiuse API
| o + Kinect |
| | o * DP_Kinect.cpp |
| | o * Kinect.cpp |
| | o * precompiled.cpp |
| | \ * precompiled.h |
| \ + PHANToM |
| o * AntiGravityFilter.cpp |
| o * AntiGravityFilter.h |
| o * CameraMovementFilter.cpp |
| o * CameraMovementFilter.h |
| o * ClampFilter.cpp |
| o * ClampFilter.h |
| o * CollisionFilterBase.cpp |
| o * CollisionFilterBase.h |
| o * CollisionPauseFilter.cpp |
| o * CollisionPauseFilter.h |
| o * DampingForceFilter.cpp |
| o * DampingForceFilter.h |
| o * DP_PHANToM.cpp |
| o * FadeFilter.cpp |
| o * FadeFilter.h |
| o * KalmanFilter.cpp |
| o * KalmanFilter.h |
| o * LoggingFilter.cpp |
| o * LoggingFilter.h |
| o * MultiplyFilter.cpp |
| o * MultiplyFilter.h |
| o * PHANToM_Device.cpp |
| o * PointShellVSVoxelFilter.cpp |
| o * PointShellVSVoxelFilter.h |
| o * precompiled.cpp |
| o * precompiled.h |
| o * SetForceFilter.cpp |
| o * SetForceFilter.h |
| o * SetObjectTransformFilter.cpp |
| o * SetObjectTransformFilter.h |
| o * SNCHForceFilter.cpp |
| o * SNCHForceFilter.h |
| o * VirtualCouplingEffectorFilter.cpp |
| o * VirtualCouplingEffectorFilter.h |
| o * VisualizeFilter.cpp |
| \ * VisualizeFilter.h |
\ + vreckoUtils |
o * HighlightCallback.cpp |
o * Math.cpp |
o * Menu.cpp |
o * Observer.cpp |
o * precompiled.cpp |
\ * precompiled.h |
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include Directory Reference

  • include
include Directory Reference

Directories

directory | base
directory | helpers
directory | vrecko
directory | vreckoAP
directory | vreckoDP
directory | vreckoUtils
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base Directory Reference

  • include
  • base
base Directory Reference

Files

file | AP_base.h [code]
file | Avatar.h [code]
file | Display.h [code]
file | hand.h [code]
file | Light.h [code]
file | MouseHand.h [code]
file | MTMatrixTransform.h [code]
file | Rotate.h [code]
file | ShowFDH.h [code]
file | ShowFDHModel.h [code]
file | SystemInfo.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/AP_base.h File Reference

  • File List
  • File Members
  • include
  • base
Macros | Functions
AP_base.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "Display.h"
#include "ShowFDH.h"
#include "ShowFDHModel.h"
#include "hand.h"
#include "Avatar.h"
#include "Rotate.h"
#include "MouseHand.h"
#include "SystemInfo.h"
#include "Light.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | getAbilityList (void)
Ability AP_EXPORT * | getAbilityInstance (const char *_name)
const char AP_EXPORT * | getAbilityDescription (const char *name)
void AP_EXPORT | setAbilitiesParameters (void)
const char AP_EXPORT * | getPluginDescription (void)
void AP_EXPORT | initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char AP_EXPORT* getAbilityDescription ( const char * name )
Ability AP_EXPORT* getAbilityInstance ( const char * _name )
const char AP_EXPORT** getAbilityList ( void )
const char AP_EXPORT* getPluginDescription ( void )
void AP_EXPORT initializeAttributesDescription ( )
void AP_EXPORT setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Avatar.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces | Macros
Avatar.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class base::Avatar

Namespaces

namespace base

Macros

#define ABATAR_H

Macro Definition Documentation

#define ABATAR_H
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Display.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
Display.h File Reference
#include <vrecko/Ability.h>
#include <osg/Geode>
#include <osgText/Text>
#include <osgText/Font>
#include <osg/BlendFunc>
#include <osg/Material>
#include <osg/StateSet>
#include <vector>

Go to the source code of this file.

Classes

class base::Display

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/hand.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
hand.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class base::hand

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Light.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
Light.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class base::Light

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/MouseHand.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
MouseHand.h File Reference
#include <string>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class base::MouseHand

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/MTMatrixTransform.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces | Macros
MTMatrixTransform.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/MTLock.h>
#include <vrecko/IOPins.h>
#include <osg/Group>

Go to the source code of this file.

Classes

class base::MTMatrixTransform

Namespaces

namespace base

Macros

#define MTMATRIXTRANSFORM_IMP_EXP __declspec(dllimport)

Macro Definition Documentation

#define MTMATRIXTRANSFORM_IMP_EXP __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Rotate.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
Rotate.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class base::Rotate

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/ShowFDH.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
ShowFDH.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class base::ShowFDH

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/ShowFDHModel.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces
ShowFDHModel.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class base::ShowFDHModel

Namespaces

namespace base
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h File Reference

  • File List
  • File Members
  • include
  • base
Classes | Namespaces | Macros
SystemInfo.h File Reference
#include <windows.h>
#include <vrecko/Ability.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>

Go to the source code of this file.

Classes

class | base::SystemInfo
class | base::SystemInfo::MessageSIThreadCreated
struct | base::SystemInfo::SIThreadInfo
struct | base::SystemInfo::SIThreadInit

Namespaces

namespace base

Macros

#define SI_UNKNOWN_THREAD_NAME "?"

Macro Definition Documentation

#define SI_UNKNOWN_THREAD_NAME "?"
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers Directory Reference

  • include
  • helpers
helpers Directory Reference

Files

file | BufFile.h [code]
file | DynamicArray.h [code]
file | DynamicTree.h [code]
file | Heaps.cpp
file | Heaps.h [code]
file | HelperMacros.h [code]
file | StringHelpers.h [code]
file | XercesXMLUtils.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/BufFile.h File Reference

  • File List
  • File Members
  • include
  • helpers
Classes | Namespaces | Macros | Functions
BufFile.h File Reference
#include <vrecko/Export>
#include <osg/Vec3>
#include "DynamicArray.h"
#include <tchar.h>

Go to the source code of this file.

Classes

class | vrecko::BufferedFile
class | vrecko::BufferedFileWrite

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | BUFFILE_INITBUFFERSIZE 65536
#define | BUFFILE_MINBUFFERSIZE 16384
#define | BUFFILE_MAXBUFFILESIZE 65536
#define | INVALID_SET_FILE_POINTER ((DWORD)-1)
#define | BUFFILE_BEHVF_UNICODE_START_HIDE 0x00000002
#define | BUFFILE_BEHVF_LOADFILETOMEM 0x00000001

Functions

bool vrecko::FileExists (const _TCHAR *pFileName)

Macro Definition Documentation

#define BUFFILE_BEHVF_LOADFILETOMEM 0x00000001
#define BUFFILE_BEHVF_UNICODE_START_HIDE 0x00000002
#define BUFFILE_INITBUFFERSIZE 65536
#define BUFFILE_MAXBUFFILESIZE 65536
#define BUFFILE_MINBUFFERSIZE 16384
#define INVALID_SET_FILE_POINTER ((DWORD)-1)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/DynamicArray.h File Reference

  • File List
  • File Members
  • include
  • helpers
Classes | Namespaces | Macros
DynamicArray.h File Reference
#include <new>

Go to the source code of this file.

Classes

class VK_NoStepInto_Namespace::DynamicArray< _Type >

Namespaces

namespace VK_NoStepInto_Namespace

Macros

#define DAINLINE inline

Macro Definition Documentation

#define DAINLINE inline
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/DynamicTree.h File Reference

  • File List
  • File Members
  • include
  • helpers
Classes | Macros
DynamicTree.h File Reference

Go to the source code of this file.

Classes

class | DynamicTree< _Type >
class | DynTreeNode< _Type >
class | DynamicTree< _Type >
class | DynamicTreeIterator< _Type >

Macros

#define | DTI_EXCLUDEROOT 0x00000001
#define | DTI_ONLYLEAVES 0x00000002
#define | DTI_ONELAYERTRAVERSAL 0x00000004

Macro Definition Documentation

#define DTI_EXCLUDEROOT 0x00000001
#define DTI_ONELAYERTRAVERSAL 0x00000004
#define DTI_ONLYLEAVES 0x00000002
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.cpp File Reference

  • File List
  • File Members
  • include
  • helpers
Heaps.cpp File Reference
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h File Reference

  • File List
  • File Members
  • include
  • helpers
Classes
Heaps.h File Reference
#include <stdio.h>
#include <limits.h>
#include "Heaps.cpp"

Go to the source code of this file.

Classes

class | GenericHeap< _NodeClass, _keyType >
class | GenericHeap< _NodeClass, _keyType >::GenericHeapNode
class | BinomialHeap< _NodeClass, _keyType >
class | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode
class | FibonacciHeap< _NodeClass, _keyType >
class | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
class | ThinHeap< _NodeClass, _keyType >
class | ThinHeap< _NodeClass, _keyType >::ThinHeapNode
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/HelperMacros.h File Reference

  • File List
  • File Members
  • include
  • helpers
Macros
HelperMacros.h File Reference
#include <vrecko/Logger.h>

Go to the source code of this file.

Macros

#define | BFAILGOTO(Function) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); goto FuncFailed; } }
#define | BFAILGOTO_TEXT(Function, TextFunc) { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } goto FuncFailed; } }
#define | BFAILRET(Function) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); return false; } }
#define | BFAILRET_TEXT(Function, TextFunc) { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } return false; } }
#define | SAFE_DELETE(p) { if(p) { delete (p); (p)=NULL; } }
#define | SAFE_FREE(p) { if(p) { free (p); (p)=NULL; } }

Macro Definition Documentation

#define BFAILGOTO ( Function ) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); goto FuncFailed; } }
#define BFAILGOTO_TEXT | ( | Function,
 |  | TextFunc
 | ) | { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } goto FuncFailed; } }
#define BFAILRET ( Function ) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); return false; } }
#define BFAILRET_TEXT | ( | Function,
 |  | TextFunc
 | ) | { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } return false; } }
#define SAFE_DELETE ( p ) { if(p) { delete (p); (p)=NULL; } }
#define SAFE_FREE ( p ) { if(p) { free (p); (p)=NULL; } }
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/StringHelpers.h File Reference

  • File List
  • File Members
  • include
  • helpers
Macros | Functions
StringHelpers.h File Reference

Go to the source code of this file.

Macros

#define HELPERS_IMP_EXP __declspec(dllimport)

Functions

HELPERS_IMP_EXP bool | isBeginningWith (const char *fullString, const char *beginString)
char * | uniCpy (char *str1, const char *str2)
WCHAR * | uniCpy (WCHAR *str1, const WCHAR *str2)
char * | uniNCpy (char *str1, const char *str2, size_t count)
WCHAR * | uniNCpy (WCHAR *str1, const WCHAR *str2, size_t count)
char * | uniCat (char *str1, const char *str2)
WCHAR * | uniCat (WCHAR *str1, const WCHAR *str2)
const char * | uniStr (const char *str1, const char *str2)
const WCHAR * | uniStr (const WCHAR *str1, const WCHAR *str2)
char * | uniStr (char *str1, const char *str2)
WCHAR * | uniStr (WCHAR *str1, const WCHAR *str2)
size_t | uniLen (const char *str1)
size_t | uniLen (const WCHAR *str1)
template<class _Type >
void | getFileNameFromPathFile (_Type *outFile, const _Type *inPath, const _Type *inFile)
template<class _Type >
void | getRelativePath (_Type *outPathFile, const _Type *inPath, const _Type *inPathFile)
template<class _Type >
void | getFilePath (_Type *outPath, const _Type *inFile)
template<class _Type >
void | getFileNameWithoutPath (_Type *outFile, const _Type *inFile)
template<class _Type >
void | getFileNameWithoutExt (_Type *outFile, const _Type *inFile)
template<class _Type >
void | getFileExtension (_Type *outExt, const _Type *inFile)

Macro Definition Documentation

#define HELPERS_IMP_EXP __declspec(dllimport)

Function Documentation

template<class _Type >
void getFileExtension | ( | _Type * | outExt,
 |  | const _Type * | inFile
 | ) |  |
template<class _Type >
void getFileNameFromPathFile | ( | _Type * | outFile,
 |  | const _Type * | inPath,
 |  | const _Type * | inFile
 | ) |  |
template<class _Type >
void getFileNameWithoutExt | ( | _Type * | outFile,
 |  | const _Type * | inFile
 | ) |  |
template<class _Type >
void getFileNameWithoutPath | ( | _Type * | outFile,
 |  | const _Type * | inFile
 | ) |  |
template<class _Type >
void getFilePath | ( | _Type * | outPath,
 |  | const _Type * | inFile
 | ) |  |
template<class _Type >
void getRelativePath | ( | _Type * | outPathFile,
 |  | const _Type * | inPath,
 |  | const _Type * | inPathFile
 | ) |  |
HELPERS_IMP_EXP bool isBeginningWith | ( | const char * | fullString,
 |  | const char * | beginString
 | ) |  |
char* uniCat | ( | char * | str1,
 |  | const char * | str2
 | ) |  |
inline
WCHAR* uniCat | ( | WCHAR * | str1,
 |  | const WCHAR * | str2
 | ) |  |
inline
char* uniCpy | ( | char * | str1,
 |  | const char * | str2
 | ) |  |
inline
WCHAR* uniCpy | ( | WCHAR * | str1,
 |  | const WCHAR * | str2
 | ) |  |
inline
size_t uniLen ( const char * str1 )
inline
size_t uniLen ( const WCHAR * str1 )
inline
char* uniNCpy | ( | char * | str1,
 |  | const char * | str2,
 |  | size_t | count
 | ) |  |
inline
WCHAR* uniNCpy | ( | WCHAR * | str1,
 |  | const WCHAR * | str2,
 |  | size_t | count
 | ) |  |
inline
const char* uniStr | ( | const char * | str1,
 |  | const char * | str2
 | ) |  |
inline
const WCHAR* uniStr | ( | const WCHAR * | str1,
 |  | const WCHAR * | str2
 | ) |  |
inline
char* uniStr | ( | char * | str1,
 |  | const char * | str2
 | ) |  |
inline
WCHAR* uniStr | ( | WCHAR * | str1,
 |  | const WCHAR * | str2
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/XercesXMLUtils.h File Reference

  • File List
  • File Members
  • include
  • helpers
Classes | Macros | Functions
XercesXMLUtils.h File Reference
#include <xercesc/dom/DOM.hpp>
#include <iostream>

Go to the source code of this file.

Classes

class StrX

Macros

#define | HELPERS_IMP_EXP __declspec(dllimport)
#define | XercesToStr(str) StrX(str).localForm()

Functions

HELPERS_IMP_EXP
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		findXMLNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *rootNode, const char *nodeName, bool bSearchSubTrees=false)
HELPERS_IMP_EXP char * | getNodeTextTrans (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)
XERCES_STD_QUALIFIER ostream & | operator<< (XERCES_STD_QUALIFIER ostream &target, const StrX &toDump)

Macro Definition Documentation

#define HELPERS_IMP_EXP __declspec(dllimport)
#define XercesToStr ( str ) StrX(str).localForm()

Function Documentation

HELPERS_IMP_EXP XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* findXMLNode | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | rootNode,
 |  | const char * | nodeName,
 |  | bool | bSearchSubTrees = false
 | ) |  |
HELPERS_IMP_EXP char* getNodeTextTrans ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
XERCES_STD_QUALIFIER ostream& operator<< | ( | XERCES_STD_QUALIFIER ostream & | target,
 |  | const StrX & | toDump
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko Directory Reference

  • include
  • vrecko
vrecko Directory Reference

Files

file | Ability.h [code]
file | Attribute.h [code]
file | AttributesDescription.h [code]
file | BaseClass.h [code]
file | BenchmarkWriter.h [code]
file | Device.h [code]
file | DeviceManager.h [code]
file | DynamicAttribute.h [code]
file | Enumeration.h [code]
file | EnvironmentObject.h [code]
file | EventDispatcher.h [code]
file | Interval.h [code]
file | IOPins.h [code]
file | Logger.h [code]
file | Message.h [code]
file | MTLock.h [code]
file | OctTree.h [code]
file | PersistentCache.h [code]
file | PluginManager.h [code]
file | PyAbility.h [code]
file | Range.h [code]
file | ReaderWriter.h [code]
file | Scene.h [code]
file | Scheduler.h [code]
file | SP_CommonDefs.h [code]
file | SP_ObjectInterface.h [code]
file | SP_SceneInterface.h [code]
file | StaticAttribute.h [code]
file | Timer.h [code]
file | Viewer.h [code]
file | vThread.h [code]
file | World.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Ability.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Variables
Ability.h File Reference
#include <osg/Vec3>
#include <vector>
#include <vrecko/BaseClass.h>
#include <vrecko/Message.h>
#include <vrecko/Scheduler.h>
#include <vrecko/MTLock.h>

Go to the source code of this file.

Classes

class | vrecko::Ability
struct | vrecko::Ability::ParameterStruct
class | vrecko::AbilityDispatcher
used for managing abilities in an EnvironmentObject and for distributing received messages to a relevant abilities More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Variables

class VRECKO_EXPORT | vrecko::EnvironmentObject
class VRECKO_EXPORT | vrecko::World

Detailed Description

Author
Jan Flasar, Ludek Pokluda, Lubos Markovic, Vit Kovalcik
Date
2002

Contains the Ability class, ancestor of all abilities present in the system.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Attribute.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros
Attribute.h File Reference
#include <string>

Go to the source code of this file.

Classes

class vrecko::Attribute

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define null 0

Macro Definition Documentation

#define null 0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/AttributesDescription.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
AttributesDescription.h File Reference
#include "Attribute.h"
#include "DynamicAttribute.h"
#include <string>
#include <list>
#include <map>

Go to the source code of this file.

Classes

class vrecko::AttributesDescription

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Variables
BaseClass.h File Reference
#include <vrecko/Export>
#include <vector>
#include <string>
#include <map>
#include <vrecko/MTLock.h>
#include <vrecko/Message.h>
#include <xercesc/util/XercesDefs.hpp>
#include <vrecko/Logger.h>

Go to the source code of this file.

Classes

class | vrecko::IOPinBase
Base class that defines the very basic method that every IO pin will have. More...
class | vrecko::InputPinBase
class | vrecko::OutputPinBase
class | vrecko::IORequestPinBase
class | vrecko::RequestInputPinBase
class | vrecko::RequestOutputPinBase
class | vrecko::BaseClass
struct | vrecko::BaseClass::NOTIFICATION_DESCRIPTION

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define EVENTDISPATCHER_PRIORITY -1000000

Variables

class VRECKO_EXPORT | vrecko::AutoPtrV
class VRECKO_EXPORT | vrecko::BaseClass

Detailed Description

Author
Jan Flasar
Date
2002

Contains the BaseClass class that servers as an ancestor to many Vrecko classes. Also contains IOPinBase and some basic derived classes that defines the basic IO pins system.

Macro Definition Documentation

#define EVENTDISPATCHER_PRIORITY -1000000
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/BenchmarkWriter.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
BenchmarkWriter.h File Reference
#include <winbase.h>

Go to the source code of this file.

Classes

class vrecko::BenchmarkWriter
Class to write any timings and other benchmark data into file. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Device.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros
Device.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/Export>
#include <vreckoDP/Export>
#include <string>
#include <unistd.h>

Go to the source code of this file.

Classes

class vrecko::Device

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define BASE_CALIBRATION_STRING "Sorry, no information."

Macro Definition Documentation

#define BASE_CALIBRATION_STRING "Sorry, no information."
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/DeviceManager.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
DeviceManager.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/Device.h>
#include <vrecko/vThread.h>
#include <map>
#include <vector>
#include <osgDB/DynamicLibrary>

Go to the source code of this file.

Classes

class | vrecko::DeviceManager
struct | vrecko::DeviceManager::DT

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/DynamicAttribute.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
DynamicAttribute.h File Reference
#include "Attribute.h"
#include <string>
#include <list>
#include <map>

Go to the source code of this file.

Classes

class vrecko::DynamicAttribute

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Enumeration.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Typedefs
Enumeration.h File Reference
#include "Range.h"
#include <stdarg.h>
#include <string>
#include <list>
#include <set>

Go to the source code of this file.

Classes

class vrecko::Enumeration< tval, tref >

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Typedefs

typedef Enumeration< int > | vrecko::IntEnumeration
used with integers More...
typedef Enumeration< long > | vrecko::LongEnumeration
used with longs More...
typedef Enumeration< float > | vrecko::FloatEnumeration
used with floats More...
typedef Enumeration< double > | vrecko::DoubleEnumeration
used with doubles More...
typedef Enumeration< string,
const string & > 		vrecko::StringEnumeration
used with strings More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/EnvironmentObject.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Variables
EnvironmentObject.h File Reference
#include <osg/Vec3>
#include <osg/Matrix>
#include <osg/MatrixTransform>
#include <vrecko/IOPins.h>
#include <vrecko/BaseClass.h>
#include <vrecko/Ability.h>
#include <vrecko/Message.h>
#include <vector>
#include <esg/Definitions.h>

Go to the source code of this file.

Classes

class | vrecko::EnvironmentObject
struct | vrecko::EnvironmentObject::UserData
Here are stored pointer to UserData and its type. More...

Namespaces

namespace | esg
namespace | osg
namespace | vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | SYSTEM_VISIBLE_OBJECT_TRAVERSAL_MASK 0x00000001
#define | RECEIVES_SHADOW_TRAVERSAL_MASK 0x20
#define | CASTS_SHADOW_TRAVERSAL_MASK 0x40
#define | SYSTEM_TRAVERSAL_MASK__MASK (RECEIVES_SHADOW_TRAVERSAL_MASK | CASTS_SHADOW_TRAVERSAL_MASK)

Variables

class VRECKO_EXPORT vrecko::Scene

Macro Definition Documentation

#define CASTS_SHADOW_TRAVERSAL_MASK 0x40
#define RECEIVES_SHADOW_TRAVERSAL_MASK 0x20
#define SYSTEM_TRAVERSAL_MASK__MASK (RECEIVES_SHADOW_TRAVERSAL_MASK | CASTS_SHADOW_TRAVERSAL_MASK)
#define SYSTEM_VISIBLE_OBJECT_TRAVERSAL_MASK 0x00000001
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
EventDispatcher.h File Reference
#include <vrecko/Export>
#include <vrecko/BaseClass.h>
#include <vrecko/DeviceManager.h>
#include <vrecko/MTLock.h>
#include <string>
#include <vector>
#include <map>
#include <pthread.h>

Go to the source code of this file.

Classes

class | vrecko::EventDispatcher
struct | vrecko::EventDispatcher::ICSBase
Struct that holds identification of receiver and interconnection type. More...
struct | vrecko::EventDispatcher::ICS
struct | vrecko::EventDispatcher::REQUEST_Struct
struct | vrecko::EventDispatcher::EventStruct
Struct contains received event. More...
struct | vrecko::EventDispatcher::StringWithHash
struct | vrecko::EventDispatcher::StringWithHashComparator
struct | vrecko::EventDispatcher::EventDefinitionStruct
Struct that defines an event. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Interval.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Typedefs
Interval.h File Reference
#include "Range.h"

Go to the source code of this file.

Classes

class vrecko::Interval< tval, tref >

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Typedefs

typedef Interval< int > | vrecko::IntInterval
typedef Interval< long > | vrecko::LongInterval
used with integers and strings More...
typedef Interval< float > | vrecko::FloatInterval
used with longs More...
typedef Interval< double > | vrecko::DoubleInterval
used with floats More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Variables
IOPins.h File Reference
#include <vrecko/Export>
#include <vrecko/Message.h>
#include <vrecko/BaseClass.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class | vrecko::InputPin< _MessageType >
class | vrecko::OutputPin< _MessageType >
class | vrecko::RequestInputPin< _MessageType, _ReturningMessageType >
class | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | DECLARE_INPUT(name, message_type)
#define | INIT_INPUT_EXTNAME(name, message_type, yourClassName, extName) addInputPin(input##name = new vrecko::InputPin<message_type>(this, extName, (vrecko::InputPin<message_type>::PROCESSING_METHOD)&yourClassName::onMessage##name));
#define | INIT_INPUT(name, message_type, yourClassName) INIT_INPUT_EXTNAME(name, message_type, yourClassName, #name)
#define | UNINIT_INPUT(name)
#define | METHOD_INPUT(name, message_type, yourClassName) void yourClassName::onMessage##name(message_type *message)
#define | DECLARE_OUTPUT(name, message_type) osg::ref_ptr<vrecko::OutputPin<message_type>> output##name;
#define | INIT_OUTPUT_EXTNAME(name, message_type, extName) addOutputPin(output##name = new vrecko::OutputPin<message_type>(this, extName));
#define | INIT_OUTPUT(name, message_type) INIT_OUTPUT_EXTNAME(name, message_type, #name)
#define | UNINIT_OUTPUT(name)
#define | DECLARE_REQUEST_INPUT(name, message_type, returning_message_type)
#define | INIT_REQUEST_INPUT_EXTNAME(name, message_type, returning_message_type, yourClassName, extName) addRequestInputPin(reqInput##name = new vrecko::RequestInputPin<message_type, returning_message_type>(this, extName, (vrecko::RequestInputPin<message_type, returning_message_type>::PROCESSING_METHOD)&yourClassName::onRequest##name));
#define | INIT_REQUEST_INPUT(name, message_type, returning_message_type, yourClassName) INIT_REQUEST_INPUT_EXTNAME(name, message_type, returning_message_type, yourClassName, #name)
#define | UNINIT_REQUEST_INPUT(name)
#define | METHOD_REQUEST_INPUT(name, message_type, returning_message_type, yourClassName) osg::ref_ptr<returning_message_type> yourClassName::onRequest##name(message_type *message)
#define | DECLARE_REQUEST_OUTPUT(name, message_type, returning_message_type) osg::ref_ptr<vrecko::RequestOutputPin<message_type, returning_message_type>> reqOutput##name;
#define | INIT_REQUEST_OUTPUT_EXTNAME(name, message_type, returning_message_type, extName) addRequestOutputPin(reqOutput##name = new vrecko::RequestOutputPin<message_type, returning_message_type>(this, extName));
#define | INIT_REQUEST_OUTPUT(name, message_type, returning_message_type) INIT_REQUEST_OUTPUT_EXTNAME(name, message_type, returning_message_type, #name)
#define | UNINIT_REQUEST_OUTPUT(name)

Variables

template class VRECKO_EXPORT | vrecko::OutputPin< MessageBool >
template class VRECKO_EXPORT | vrecko::InputPin< MessageBool >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageInt >
template class VRECKO_EXPORT | vrecko::InputPin< MessageInt >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageUnsignedInt >
template class VRECKO_EXPORT | vrecko::InputPin< MessageUnsignedInt >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageFloat >
template class VRECKO_EXPORT | vrecko::InputPin< MessageFloat >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageObjectID >
template class VRECKO_EXPORT | vrecko::InputPin< MessageObjectID >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageString >
template class VRECKO_EXPORT | vrecko::InputPin< MessageString >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageVec2 >
template class VRECKO_EXPORT | vrecko::InputPin< MessageVec2 >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageVec3 >
template class VRECKO_EXPORT | vrecko::InputPin< MessageVec3 >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageVec4 >
template class VRECKO_EXPORT | vrecko::InputPin< MessageVec4 >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageQuat >
template class VRECKO_EXPORT | vrecko::InputPin< MessageQuat >
template class VRECKO_EXPORT | vrecko::OutputPin< MessageMatrix >
template class VRECKO_EXPORT | vrecko::InputPin< MessageMatrix >

Macro Definition Documentation

#define DECLARE_INPUT | ( | name,
 |  | message_type
 | ) |
Value:
osg::ref_ptr<vrecko::InputPin<message_type>> input##name; \
void onMessage##name(message_type *message);
#define DECLARE_OUTPUT | ( | name,
 |  | message_type
 | ) | osg::ref_ptr<vrecko::OutputPin<message_type>> output##name;
#define DECLARE_REQUEST_INPUT | ( | name,
 |  | message_type,
 |  | returning_message_type
 | ) |
Value:
osg::ref_ptr<vrecko::RequestInputPin<message_type, returning_message_type>> reqInput##name; \
osg::ref_ptr<returning_message_type> onRequest##name(message_type *message);
#define DECLARE_REQUEST_OUTPUT | ( | name,
 |  | message_type,
 |  | returning_message_type
 | ) | osg::ref_ptr<vrecko::RequestOutputPin<message_type, returning_message_type>> reqOutput##name;
#define INIT_INPUT | ( | name,
 |  | message_type,
 |  | yourClassName
 | ) | INIT_INPUT_EXTNAME(name, message_type, yourClassName, #name)
#define INIT_INPUT_EXTNAME | ( | name,
 |  | message_type,
 |  | yourClassName,
 |  | extName
 | ) | addInputPin(input##name = new vrecko::InputPin<message_type>(this, extName, (vrecko::InputPin<message_type>::PROCESSING_METHOD)&yourClassName::onMessage##name));
#define INIT_OUTPUT | ( | name,
 |  | message_type
 | ) | INIT_OUTPUT_EXTNAME(name, message_type, #name)
#define INIT_OUTPUT_EXTNAME | ( | name,
 |  | message_type,
 |  | extName
 | ) | addOutputPin(output##name = new vrecko::OutputPin<message_type>(this, extName));
#define INIT_REQUEST_INPUT | ( | name,
 |  | message_type,
 |  | returning_message_type,
 |  | yourClassName
 | ) | INIT_REQUEST_INPUT_EXTNAME(name, message_type, returning_message_type, yourClassName, #name)
#define INIT_REQUEST_INPUT_EXTNAME | ( | name,
 |  | message_type,
 |  | returning_message_type,
 |  | yourClassName,
 |  | extName
 | ) | addRequestInputPin(reqInput##name = new vrecko::RequestInputPin<message_type, returning_message_type>(this, extName, (vrecko::RequestInputPin<message_type, returning_message_type>::PROCESSING_METHOD)&yourClassName::onRequest##name));
#define INIT_REQUEST_OUTPUT | ( | name,
 |  | message_type,
 |  | returning_message_type
 | ) | INIT_REQUEST_OUTPUT_EXTNAME(name, message_type, returning_message_type, #name)
#define INIT_REQUEST_OUTPUT_EXTNAME | ( | name,
 |  | message_type,
 |  | returning_message_type,
 |  | extName
 | ) | addRequestOutputPin(reqOutput##name = new vrecko::RequestOutputPin<message_type, returning_message_type>(this, extName));
#define METHOD_INPUT | ( | name,
 |  | message_type,
 |  | yourClassName
 | ) | void yourClassName::onMessage##name(message_type *message)
#define METHOD_REQUEST_INPUT | ( | name,
 |  | message_type,
 |  | returning_message_type,
 |  | yourClassName
 | ) | osg::ref_ptr<returning_message_type> yourClassName::onRequest##name(message_type *message)
#define UNINIT_INPUT ( name )
Value:
{ \
if (input##name) { \
removeInputPin(input##name); \
input##name = NULL; \
} \
}
#define UNINIT_OUTPUT ( name )
Value:
{ \
if (output##name) { \
removeOutputPin(output##name); \
output##name = NULL; \
} \
}
#define UNINIT_REQUEST_INPUT ( name )
Value:
{ \
if (reqInput##name) { \
removeRequestInputPin(reqInput##name); \
reqInput##name = NULL; \
} \
}
#define UNINIT_REQUEST_OUTPUT ( name )
Value:
{ \
if (reqOutput##name) { \
removeRequestOutputPin(reqOutput##name); \
reqOutput##name = NULL; \
} \
}
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Variables
Logger.h File Reference
#include <vrecko/Export>
#include <vrecko/Timer.h>
#include <vrecko/BenchmarkWriter.h>
#include <fstream>
#include <map>
#include <helpers/DynamicArray.h>
#include <string>
#include <vrecko/MTLock.h>
#include <windows.h>

Go to the source code of this file.

Classes

class | vrecko::Logger
class | vrecko::Logger::OutstandingText
class | vrecko::Logger::OutstandingCounter
struct | vrecko::Logger::OutputNotificationFuncStored
struct | vrecko::Logger::TimingInfo

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | LOGGER_OUTPUTTYPE_ERROR 0x00000001
#define | LOGGER_OUTPUTTYPE_WARNING 0x00000002
#define | LOGGER_OUTPUTTYPE_NOTICE 0x00000004
#define | LOGGER_OUTPUTTYPE_DEBUG 0x00000008
#define | LOGGER_OUTPUTTYPE_DEBUGFILE 0x00000010
#define | LOGGER_OUTPUTTYPE_DEBUGFLUSH 0x00000020
#define | LOGGER_OUTPUTTYPE_TIMINGSFILE 0x00000040
#define | LOGGER_OUTPUTTYPEMASK_ALL 0xFFFFFFFF
#define | LOGGER_OUTPUTTYPEMASK_NONE 0x00000000
#define | LOGGER_OUTPUTTYPEMASK_DEBUG LOGGER_OUTPUTTYPEMASK_ALL
#define | LOGGER_OUTPUTTYPEMASK_USER (LOGGER_OUTPUTTYPE_ERROR | LOGGER_OUTPUTTYPE_WARNING | LOGGER_OUTPUTTYPE_NOTICE)
#define | LOGGER_OUTPUTTYPEMASK_NORMAL LOGGER_OUTPUTTYPEMASK_USER
#define | LOGGER_OT_INTERNALMASK_SPECIALTYPES (LOGGER_OUTPUTTYPE_TIMINGSFILE)
#define | LOGGER_OT_INTERNALMASK_NORMALTYPES (0xFFFFFFFF ^ LOGGER_OT_INTERNALMASK_SPECIALTYPES)
#define | LOGGER_OUTPUTDEST_STDOUT 0x00000001
#define | LOGGER_OUTPUTDEST_FILE 0x00000002
#define | LOGGER_OUTPUTDEST_DEBUGSTRING 0x00000004
#define | LOGGER_OUTPUTDESTMASK_ALL 0xFFFFFFFF
#define | LOGGER_OUTPUTDESTMASK_NONE 0x00000000
#define | LOGGER_OUTPUTDESTMASK_NO_STDOUT (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_STDOUT)
#define | LOGGER_OUTPUTDESTMASK_NO_FILE (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_FILE)
#define | LOGGER_OUTPUTDESTMASK_NO_DEBUGSTRING (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_DEBUGSTRING)
#define | OUTPUTSTR(str) {}
#define | OUTPUTSTR2(str, p1) {}
#define | OUTPUTSTR3(str, p1, p2) {}
#define | OUTPUTSTR4(str, p1, p2, p3) {}
#define | OUTPUTSTR5(str, p1, p2, p3, p4) {}
#define | OUTPUTSTR6(str, p1, p2, p3, p4, p5) {}
#define | OUTPUTSTR7(str, p1, p2, p3, p4, p5, p6) {}
#define | STARTTIMING(sectionName)
#define | STOPTIMING(sectionName)

Variables

VRECKO_EXPORT Logger vrecko::logger

Macro Definition Documentation

#define LOGGER_OT_INTERNALMASK_NORMALTYPES (0xFFFFFFFF ^ LOGGER_OT_INTERNALMASK_SPECIALTYPES)
#define LOGGER_OT_INTERNALMASK_SPECIALTYPES (LOGGER_OUTPUTTYPE_TIMINGSFILE)
#define LOGGER_OUTPUTDEST_DEBUGSTRING 0x00000004
#define LOGGER_OUTPUTDEST_FILE 0x00000002
#define LOGGER_OUTPUTDEST_STDOUT 0x00000001
#define LOGGER_OUTPUTDESTMASK_ALL 0xFFFFFFFF
#define LOGGER_OUTPUTDESTMASK_NO_DEBUGSTRING (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_DEBUGSTRING)
#define LOGGER_OUTPUTDESTMASK_NO_FILE (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_FILE)
#define LOGGER_OUTPUTDESTMASK_NO_STDOUT (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_STDOUT)
#define LOGGER_OUTPUTDESTMASK_NONE 0x00000000
#define LOGGER_OUTPUTTYPE_DEBUG 0x00000008
#define LOGGER_OUTPUTTYPE_DEBUGFILE 0x00000010
#define LOGGER_OUTPUTTYPE_DEBUGFLUSH 0x00000020
#define LOGGER_OUTPUTTYPE_ERROR 0x00000001
#define LOGGER_OUTPUTTYPE_NOTICE 0x00000004
#define LOGGER_OUTPUTTYPE_TIMINGSFILE 0x00000040
#define LOGGER_OUTPUTTYPE_WARNING 0x00000002
#define LOGGER_OUTPUTTYPEMASK_ALL 0xFFFFFFFF
#define LOGGER_OUTPUTTYPEMASK_DEBUG LOGGER_OUTPUTTYPEMASK_ALL
#define LOGGER_OUTPUTTYPEMASK_NONE 0x00000000
#define LOGGER_OUTPUTTYPEMASK_NORMAL LOGGER_OUTPUTTYPEMASK_USER
#define LOGGER_OUTPUTTYPEMASK_USER (LOGGER_OUTPUTTYPE_ERROR | LOGGER_OUTPUTTYPE_WARNING | LOGGER_OUTPUTTYPE_NOTICE)
#define OUTPUTSTR ( str ) {}
#define OUTPUTSTR2 | ( | str,
 |  | p1
 | ) | {}
#define OUTPUTSTR3 | ( | str,
 |  | p1,
 |  | p2
 | ) | {}
#define OUTPUTSTR4 | ( | str,
 |  | p1,
 |  | p2,
 |  | p3
 | ) | {}
#define OUTPUTSTR5 | ( | str,
 |  | p1,
 |  | p2,
 |  | p3,
 |  | p4
 | ) | {}
#define OUTPUTSTR6 | ( | str,
 |  | p1,
 |  | p2,
 |  | p3,
 |  | p4,
 |  | p5
 | ) | {}
#define OUTPUTSTR7 | ( | str,
 |  | p1,
 |  | p2,
 |  | p3,
 |  | p4,
 |  | p5,
 |  | p6
 | ) | {}
#define STARTTIMING ( sectionName )
#define STOPTIMING ( sectionName )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Message.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Enumerations | Functions | Variables
Message.h File Reference
#include <osg/Referenced>
#include <osg/Timer>
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Quat>
#include <osg/Matrix>
#include <osg/Node>
#include <vrecko/Export>
#include <fstream>
#include <string>
#include <map>
#include <vector>
#include <xercesc/dom/DOMNode.hpp>

Go to the source code of this file.

Classes

class | vrecko::VreckoMessage
class | vrecko::MessageVoid
class | vrecko::MessageSensorTransformation

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | VRECKO_START_MESSAGE_BASE(messageName, dataType)
#define | VRECKO_START_MESSAGE_EXTENDED(messageName, dataType)
#define | VRECKO_END_MESSAGE };

Enumerations

enum vrecko::EventType { vrecko::NORMAL_EVENT, vrecko::PRIORITY_EVENT, vrecko::EXPRESS_EVENT }
Type of the event. More...

Functions

virtual bool | vrecko::setValueFromString (const char *valueAsString)
VRECKO_END_MESSAGE | vrecko::MessageString (const std::string &_data)
vrecko::MessageString (const char *_data)
virtual bool | vrecko::isEqualTo (VreckoMessage *otherMsg)
VRECKO_END_MESSAGE | vrecko::MessageVec2 (const osg::Vec2 &_data)
VRECKO_END_MESSAGE | vrecko::MessageVec3 (const osg::Vec3 &_data)
VRECKO_END_MESSAGE | vrecko::MessageVec4 (const osg::Vec4 &_data)
VRECKO_END_MESSAGE | vrecko::MessageQuat (const osg::Quat &_data)
VRECKO_END_MESSAGE | vrecko::MessageMatrix (const osg::Matrix &_data)
VRECKO_END_MESSAGE | vrecko::MessageNodeList (const std::vector< osg::Node * > &_data)
VRECKO_END_MESSAGE | vrecko::MessageNode (osg::Node *newNode)
vrecko::MessageXMLNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *newNode)

Variables

VRECKO_END_MESSAGE class
XERCES_CPP_NAMESPACE_QUALIFIER 		vrecko::DOMNode

Detailed Description

Author
Vit Kovalcik (previously Jan Flasar, Ludek Pokluda, but that was a DIFFERENT Message)
Date
2011

Macro Definition Documentation

#define VRECKO_END_MESSAGE };

Ending macro for message declaration/definition.

You have to start the definition with either VRECKO_START_MESSAGE_BASE or VRECKO_START_MESSAGE_EXTENDED.

#define VRECKO_START_MESSAGE_BASE | ( | messageName,
 |  | dataType
 | ) |
Value:
class messageName : public vrecko::VreckoMessage { \
public: \
messageName() {}; \
virtual const char* getMessageId() { return #messageName; } \
dataType data;

Macro for quick declaration/definition of new simple messages.

The messages are descendants of the vrecko::VreckoMessage. The new message have single variable, called data, which is of the specified type. The default constructor and getMessageId() methods are prepared automatically.

Don't forget to end the message block with the VRECKO_END_MESSAGE macro.

You can also use the VRECKO_START_MESSAGE_EXTENDED to make the definition even simpler.

#define VRECKO_START_MESSAGE_EXTENDED | ( | messageName,
 |  | dataType
 | ) |
Value:
VRECKO_START_MESSAGE_BASE(messageName, dataType) \
messageName(dataType newData) { data = newData; }; \
virtual bool isEqualTo(messageName *otherMsg) { return (data == (otherMsg)->data); }; \

Macro for quick declaration/definition of new simple messages.

This macro is similar to VRECKO_START_MESSAGE_BASE, but also adds another constructor to quickly initialize the message with a specified value and the isEqualTo() method (works for data types with defined operator == ).

Don't forget to end the message block with the VRECKO_END_MESSAGE macro.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Typedefs
MTLock.h File Reference
#include <map>

Go to the source code of this file.

Classes

class | vrecko::MTLock
Base class for multi-thread access to a single variable. More...
class | vrecko::MTAutoLock
class | vrecko::MTReadWriteLock
class | vrecko::MTReadWriteLockEx
class | vrecko::MTTwoPrioLimitedLock

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define MTLOCK_IMP_EXP __declspec(dllimport)

Typedefs

typedef MTLock vrecko::MTLockSingleProcess

Detailed Description

Author
Vit Kovalcik
Date
2011

Contains several classes for multi-thread locking.

Macro Definition Documentation

#define MTLOCK_IMP_EXP __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/OctTree.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
OctTree.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class | vrecko::OctTree
struct | vrecko::OctTree::OctTreeNode

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PersistentCache.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
PersistentCache.h File Reference
#include <vrecko/Export>
#include <vrecko/MTLock.h>
#include <helpers/DynamicArray.h>
#include <helpers/BufFile.h>
#include <osg/Node>

Go to the source code of this file.

Classes

class | vrecko::PersistentCache
Caching that persists multiple application sessions. More...
class | vrecko::PersistentCache::OpenedCacheFile

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Detailed Description

Author
Vit Kovalcik
Date
2011

File containing the PersistentCache class.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PluginManager.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
PluginManager.h File Reference
#include <vrecko/Export>
#include <vrecko/Ability.h>
#include <osgDB/DynamicLibrary>
#include <map>

Go to the source code of this file.

Classes

class vrecko::PluginManager
Simple class to load and manage the plugins. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PyAbility.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
PyAbility.h File Reference
#include <python/Python.h>
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class vrecko::PyAbility
Python ability. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Range.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
Range.h File Reference

Go to the source code of this file.

Classes

class vrecko::Range

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Typedefs | Variables
ReaderWriter.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/Export>
#include <vrecko/Ability.h>
#include <fstream>
#include <vector>
#include <map>
#include <string>
#include <osg/Vec2>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Group>
#include <osgDB/DynamicLibrary>
#include <xercesc/parsers/AbstractDOMParser.hpp>
#include <xercesc/dom/DOMErrorHandler.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/util/XMLString.hpp>
#include <helpers/XercesXMLUtils.h>
#include <iostream.h>

Go to the source code of this file.

Classes

class | vrecko::RWErrorHandler
class | vrecko::ReaderWriter
struct | vrecko::ReaderWriter::AbilityToInitialize
class | vrecko::XercesStr

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | CREATOR_FILENAME_ID_SIMPLE "_XMLCreatorFileName_"
#define | CREATOR_FILENAME_ID L ## "_XMLCreatorFileName_"
#define | strToXerces(str) XercesStr(str).unicodeForm()

Typedefs

typedef pthread_mutex * vrecko::VRECKOMutex

Variables

class VRECKO_EXPORT | vrecko::DeviceManager
class VRECKO_EXPORT | vrecko::EventDispatcher

Macro Definition Documentation

#define CREATOR_FILENAME_ID L ## "_XMLCreatorFileName_"
#define CREATOR_FILENAME_ID_SIMPLE "_XMLCreatorFileName_"
#define strToXerces ( str ) XercesStr(str).unicodeForm()
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Functions
Scene.h File Reference
#include <osg/Node>
#include <vrecko/BaseClass.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/MTLock.h>
#include <helpers/DynamicArray.h>
#include <vrecko/SP_CommonDefs.h>

Go to the source code of this file.

Classes

struct | vrecko::ScenePSThreadInfo
class | vrecko::Scene
class | vrecko::Scene::EOIteratorHelper
Class for iterating through all environment objects in non-main threads. More...
struct | vrecko::Scene::SC_INT_PRIO
struct | vrecko::Scene::OBJ_INT_PRIO

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | CNBB_F_FORCE_AABBOX 0x00000001
#define | CNBB_F_ONLY_LOCAL_TRANSFORM 0x00000002
#define | CNBB_F_NO_SELF_TRANSFORM 0x00000004
#define | EOIH_IF_START_BEGINNING 0x00000001
#define | EOIH_IF_START_CURRENT 0x00000002
#define | EOIH_IF_START_NEXT 0x00000004

Functions

DWORD WINAPI vrecko::ScenePSThreadProc (ScenePSThreadInfo *lpParameter)

Macro Definition Documentation

#define CNBB_F_FORCE_AABBOX 0x00000001

Forces the output box to be an AABox (the transformation will be the identity transform). Otherwise the resulting box will be an AABox, which must be transformed by the result transformation (which also includes scaling). If this flag is used, the [outTranform] parameter can be NULL.

#define CNBB_F_NO_SELF_TRANSFORM 0x00000004

Can only be used together with CNBB_F_ONLY_LOCAL_TRANSFORM. The transformation matrix of the object itself will be ignored

#define CNBB_F_ONLY_LOCAL_TRANSFORM 0x00000002

The parent transformations won't be taken into account.

#define EOIH_IF_START_BEGINNING 0x00000001

(Normal) Start from the beginning

#define EOIH_IF_START_CURRENT 0x00000002

Start from the object that the other iterator is processing. Calling getAndLockNextObject() will lock this object.

#define EOIH_IF_START_NEXT 0x00000004

Start from the object that is immediately after the one that the other iterator is processing.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Scheduler.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros
Scheduler.h File Reference
#include <vrecko/Export>
#include <vrecko/BaseClass.h>
#include <vrecko/vThread.h>
#include <map>
#include <vector>

Go to the source code of this file.

Classes

class | vrecko::Scheduler
struct | vrecko::Scheduler::TimerStruct
struct | vrecko::Scheduler::classcomp

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define FRAME_FREQUENCY -1.0

Macro Definition Documentation

#define FRAME_FREQUENCY -1.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_CommonDefs.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Macros | Typedefs
SP_CommonDefs.h File Reference
#include <helpers/DynamicArray.h>

Go to the source code of this file.

Classes

class | vrecko::CollisionPointInfo
class | vrecko::CollisionInfo
class | vrecko::CollisionParams__ver1
Parameters for the SP_SceneInterface::getCollisions() method. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | COLL_VRECKO_EXPORT __declspec(dllimport)
#define | PARTITIONING_INTERFACE_DEFAULT -1
#define | COLPOINT_FLAGS_INVALID 0x00000001
#define | COLPOINT_FLAGS_INTERSECTION_LINE 0x00000002
#define | COLPOINT_FLAGS_NEG_DIST_PRESENT 0x00000004
#define | COLPOINT_FLAGS_NORMALIZED 0x00000008
#define | COLPOINT_FLAGS_REPRESENTANTS__MASK 0x00000FF0
#define | COLPOINT_FLAGS_REPRESENTANTS__SHIFT 4
#define | COLPOINT_FLAGS_REPRESENTANTS__GET(x) ((x && COLPOINT_FLAGS_REPRESENTANTS__MASK) >> COLPOINT_FLAGS_REPRESENTANTS__SHIFT)
#define | COLLISION_FLAGS_RAYCASTING 0x00000001
Do not test collisions between objects, but between a ray and objects. More...
#define | COLLISION_FLAGS_NOCONTACTS 0x00000002
Contact points are not required. Use to speed up the tests. More...
#define | COLLISION_FLAGS_SINGLECONTACT 0x00000004
#define | COLLISION_FLAGS_ONLYSCENETESTS 0x00000008
#define | COLLISION_FLAGS_ALLOW_INTERSECTIONS 0x00000010
#define | COLLISION_FLAGS_ONLY_INTERSECTIONS 0x00000020
No collisions will be calculated, but only intersections. More...
#define | COLLISION_FLAGS_RUN_IN_BACKGROUND 0x00000040
#define | COLLISION_FLAGS_USE_MTMATRIXTRANSFORM 0x00000080
#define | COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES 0x00000100
#define | COLLISION_FLAGS_NO_CALCULATIONS 0x00000200
#define | COLLISION_FLAGS_PREFER_NO_CALCULATIONS 0x00000400
#define | COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800
Do not delete the old collision pairs in COLLISIONS_INFO_VECTOR. More...
#define | COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800
Do not delete the old collision pairs in COLLISIONS_INFO_VECTOR. More...
#define | COLLISION_FLAGSMASK_COMPARISON_FLAGS (COLLISION_FLAGS_RAYCASTING | COLLISION_FLAGS_ONLYSCENETESTS | COLLISION_FLAGS_ALLOW_INTERSECTIONS | COLLISION_FLAGS_ONLY_INTERSECTIONS | COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES)

Typedefs

typedef std::vector
< CollisionPointInfo > 		vrecko::COLLISION_POINTS_VECTOR
typedef DynamicArray
< CollisionInfo > 		vrecko::COLLISIONS_INFO_VECTOR
typedef CollisionParams__ver1 vrecko::CollisionParams

Macro Definition Documentation

#define COLL_VRECKO_EXPORT __declspec(dllimport)
#define COLLISION_FLAGS_ALLOW_INTERSECTIONS 0x00000010

The processing function is allowed to return some of the points in different form: Instead of calculating a single contact point for a triangle-triangle (or another) collision, it may return the intersection line. These lines then form intersection polyline.

#define COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES 0x00000100

The processing function is allowed to return some of the points in different form: If some parts of objects are found to be intersecting, the function may return negative distance, which means the largest intersecting distance found. Additional details may depend on the exact function.

#define COLLISION_FLAGS_NO_CALCULATIONS 0x00000200

Perform no collision calculations - only get the collisions that are already calculated (if any). This is possible only in a case when some other component is requesting collision calculations and is doing that on the background, so the thread with the results is ready at all times. WARNING: When using this flag, the running threads are searched only APPROXIMATELY... the selected thread might have slightly different parameters from those that were requested. (i.e. different distance cut-off, (dis)allowing intersections, etc.)

#define COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800

Do not delete the old collision pairs in COLLISIONS_INFO_VECTOR.

Prepared set of flags that are used in comparison (are two set of parameters the same? - Can we reuse the results?)

#define COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800

Do not delete the old collision pairs in COLLISIONS_INFO_VECTOR.

Prepared set of flags that are used in comparison (are two set of parameters the same? - Can we reuse the results?)

#define COLLISION_FLAGS_NOCONTACTS 0x00000002

Contact points are not required. Use to speed up the tests.

#define COLLISION_FLAGS_ONLY_INTERSECTIONS 0x00000020

No collisions will be calculated, but only intersections.

#define COLLISION_FLAGS_ONLYSCENETESTS 0x00000008

The precise object-object collision test (through SP_ObjectInterface) will not be executed. Only possible candidates selected by SP_SceneInterface are returned. NOTE: This also means that collision points won't be calculated.

#define COLLISION_FLAGS_PREFER_NO_CALCULATIONS 0x00000400

Similar to COLLISION_FLAGS_NO_CALCULATIONS, but if no thread performing the calculations is found, then the new calculations are made.

#define COLLISION_FLAGS_RAYCASTING 0x00000001

Do not test collisions between objects, but between a ray and objects.

#define COLLISION_FLAGS_RUN_IN_BACKGROUND 0x00000040

It is expected that the same collision test will be requested in a very near future many times (for example with the haptic collision detection). Therefore, if possible, start background thread(s) that search(es) the scene for potential collision and use the "local update" threads that try to maintain partially correct results.

#define COLLISION_FLAGS_SINGLECONTACT 0x00000004

Only one contact point is required (for each object-object collision) Use to speed up the tests.

#define COLLISION_FLAGS_USE_MTMATRIXTRANSFORM 0x00000080

FOR THE FIRST OBJECT ("LEFT" parameter) use position stored in MTMatrixTransform ability. Therefore it will be able to change the transformation many times per frame, without any possible collisions with the rendering thread.

#define COLLISION_FLAGSMASK_COMPARISON_FLAGS (COLLISION_FLAGS_RAYCASTING | COLLISION_FLAGS_ONLYSCENETESTS | COLLISION_FLAGS_ALLOW_INTERSECTIONS | COLLISION_FLAGS_ONLY_INTERSECTIONS | COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES)
#define COLPOINT_FLAGS_INTERSECTION_LINE 0x00000002

The points don't form a close collision pair, but are a part of the intersection polyline (form a sub-line) This can be only present if the processing function was called with COLLISION_FLAGS_ALLOW_INTERSECTIONS specified.

#define COLPOINT_FLAGS_INVALID 0x00000001

This flag marks the current point as INVALID (You should respect this flag everywhere!!!) For performance reasons, it is not deleted, but only marked using this flag.

#define COLPOINT_FLAGS_NEG_DIST_PRESENT 0x00000004

The [vecTriMaxNegativeDistance] variable contains a valid value.

#define COLPOINT_FLAGS_NORMALIZED 0x00000008

The point was transformed from collision space (i.e. voxel space or another) into a normalized space (max. collision = length 0, min. col. = length 1).

#define COLPOINT_FLAGS_REPRESENTANTS__GET ( x ) ((x && COLPOINT_FLAGS_REPRESENTANTS__MASK) >> COLPOINT_FLAGS_REPRESENTANTS__SHIFT)
#define COLPOINT_FLAGS_REPRESENTANTS__MASK 0x00000FF0
#define COLPOINT_FLAGS_REPRESENTANTS__SHIFT 4
#define PARTITIONING_INTERFACE_DEFAULT -1

Default object/scene partitioning interface.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_ObjectInterface.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
SP_ObjectInterface.h File Reference
#include <vrecko/Export>
#include <osg/Vec3>
#include <stddef.h>
#include <vrecko/SP_CommonDefs.h>

Go to the source code of this file.

Classes

class | vrecko::SP_Object_DataInterface
class | vrecko::SP_ObjectInterface

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_SceneInterface.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
SP_SceneInterface.h File Reference
#include <vrecko/EnvironmentObject.h>
#include <vrecko/SP_CommonDefs.h>

Go to the source code of this file.

Classes

class vrecko::SP_SceneInterface

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/StaticAttribute.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Typedefs
StaticAttribute.h File Reference
#include "Attribute.h"
#include "Range.h"
#include <string>
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Quat>

Go to the source code of this file.

Classes

class vrecko::StaticAttribute< type, tval, tref >

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Typedefs

typedef StaticAttribute
< Attribute::TYPE_BOOL, bool > 		vrecko::BoolAttribute
typedef StaticAttribute
< Attribute::TYPE_INT, int > 		vrecko::IntAttribute
booleans More...
typedef StaticAttribute
< Attribute::TYPE_LONG, long > 		vrecko::LongAttribute
integers More...
typedef StaticAttribute
< Attribute::TYPE_FLOAT, float > 		vrecko::FloatAttribute
longs More...
typedef StaticAttribute
< Attribute::TYPE_DOUBLE,
double > 		vrecko::DoubleAttribute
floats More...
typedef StaticAttribute
< Attribute::TYPE_STRING,
string, const string & > 		vrecko::StringAttribute
doubles More...
typedef StaticAttribute
< Attribute::TYPE_VEC2, Vec2,
const Vec2 & > 		vrecko::Vec2Attribute
strings More...
typedef StaticAttribute
< Attribute::TYPE_VEC3, Vec3,
const Vec3 & > 		vrecko::Vec3Attribute
2D vectors More...
typedef StaticAttribute
< Attribute::TYPE_VEC4, Vec4,
const Vec4 & > 		vrecko::Vec4Attribute
3D vectors More...
typedef StaticAttribute
< Attribute::TYPE_MATRIX,
Matrix, const Matrix & > 		vrecko::MatrixAttribute
4D vectors More...
typedef StaticAttribute
< Attribute::TYPE_QUAT, Quat,
const Quat & > 		vrecko::QuatAttribute
matrices More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Timer.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
Timer.h File Reference
#include <vrecko/Export>
#include <osg/Timer>

Go to the source code of this file.

Classes

class vrecko::Timer

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Viewer.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
Viewer.h File Reference
#include <vrecko/Export>
#include <osgViewer/ViewerBase>
#include <osgViewer/Viewer>
#include <osgViewer/CompositeViewer>

Go to the source code of this file.

Classes

class | vrecko::ViewerBase
Abstract VRECKO viewer class. More...
class | vrecko::Viewer
Child class for classic one screen viewer - used for QUAD_STEREO. More...
class | vrecko::CompositeViewer
Child class for more than one screen viewer. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/vThread.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces
vThread.h File Reference
#include <vrecko/BaseClass.h>
#include <unistd.h>
#include <map>
#include <vector>
#include <osg/Timer>

Go to the source code of this file.

Classes

class vrecko::vThread

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/World.h File Reference

  • File List
  • File Members
  • include
  • vrecko
Classes | Namespaces | Functions | Variables
World.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/vThread.h>
#include <vrecko/Scheduler.h>
#include <vrecko/Ability.h>
#include <vrecko/Viewer.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Group>
#include <osgText/Text>
#include <osgShadow/ShadowedScene>
#include <osgShadow/ShadowVolume>
#include <osgShadow/ShadowTexture>
#include <osgShadow/ShadowMap>
#include <osgShadow/SoftShadowMap>
#include <vrecko/Logger.h>
#include <vrecko/PersistentCache.h>

Go to the source code of this file.

Classes

class | vrecko::World
struct | vrecko::World::AvatarView
Struct for description of AvatarView. More...
struct | vrecko::World::AvatarEye
Struct AvatarEye - represents avatar eye's camera parameters. More...
struct | vrecko::World::SG_CHANGE
Struct that includes values of the operation parameters. More...

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Functions

VRECKO_EXPORT bool | vrecko::initXML ()
VRECKO_EXPORT bool | vrecko::doneXML ()
VRECKO_EXPORT const std::string & | vrecko::getSafeSceneFile (const std::string &sceneFile)
VRECKO_EXPORT unsigned long | vrecko::getNumSceneFiles ()
Returns the number of stored scene files. More...
VRECKO_EXPORT const std::string & | vrecko::getSafeSceneFile (unsigned long index)
Return an appropriate scene file ([index] can be from 0 to getNumSceneFiles()-1) More...
VRECKO_EXPORT const std::string & | vrecko::getSafeDefaultSceneFile ()
VRECKO_EXPORT void | vrecko::setDefaultSceneFile (const std::string &newDefaultSceneFile)

Variables

VRECKO_EXPORT World * vrecko::world = NULL
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP Directory Reference

  • include
  • vreckoAP
vreckoAP Directory Reference

Directories

directory | ArtificialWorld
directory | behindO
directory | Boids
directory | CableEditor
directory | CameraMovement
directory | CameraPath
directory | CarSim
directory | ConnectEditor
directory | ConstrainedMovement
directory | DynamicArt
directory | EditorController
directory | EditorQAbilities
directory | FFDEditor
directory | Filter
directory | games
directory | Garden
directory | GUI
directory | HeadTracking
directory | HelloWorld
directory | HUD
directory | InputConnector
directory | LightsEditor
directory | Menu
directory | Nature
directory | navigation
directory | ObjectUtils
directory | ODE
directory | RoomEdit
directory | ShootingSimulation
directory | SpacePartitioning
directory | TextOutput
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld Directory Reference

  • include
  • vreckoAP
  • ArtificialWorld
ArtificialWorld Directory Reference

Files

file | AP_ArtificialWorld.h [code]
file | awHelper.h [code]
file | BlockUpdater.h [code]
file | Cache.h [code]
file | model.h [code]
file | ModelManager.h [code]
file | Preloader.h [code]
file | PreloaderHeuristic.h [code]
file | subblock.h [code]
file | subblock_animation.h [code]
file | WorldBuilder.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/AP_ArtificialWorld.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Functions
AP_ArtificialWorld.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>

Go to the source code of this file.

Functions

const char AP_EXPORT ** | ArtificialWorld_getAbilityList (void)
Ability AP_EXPORT * | ArtificialWorld_getAbilityInstance (const char *_name)
const char AP_EXPORT * | ArtificialWorld_getAbilityDescription (const char *name)
void AP_EXPORT | ArtificialWorld_setAbilitiesParameters (void)
const char AP_EXPORT * | ArtificialWorld_getPluginDescription (void)
void AP_EXPORT | ArtificialWorld_initializeAttributesDescription ()

Function Documentation

const char AP_EXPORT* ArtificialWorld_getAbilityDescription ( const char * name )
Ability AP_EXPORT* ArtificialWorld_getAbilityInstance ( const char * _name )
const char AP_EXPORT** ArtificialWorld_getAbilityList ( void )
const char AP_EXPORT* ArtificialWorld_getPluginDescription ( void )
void AP_EXPORT ArtificialWorld_initializeAttributesDescription ( )
void AP_EXPORT ArtificialWorld_setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/awHelper.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Macros
awHelper.h File Reference

Go to the source code of this file.

Macros

#define AW_DEBUG_ONLY(anything) {}

Macro Definition Documentation

#define AW_DEBUG_ONLY ( anything ) {}
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/BlockUpdater.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Namespaces | Macros | Enumerations
BlockUpdater.h File Reference

Go to the source code of this file.

Classes

class | ArtificialWorld::BlockAttributes
Atributy bloku. More...
class | ArtificialWorld::BlockUpdater
Abilita, ktera se stara o aktualizaci jednoho bloku, zobrazuje a skryva jeho modely a podbloky. More...

Namespaces

namespace ArtificialWorld

Macros

#define SHOWVEC3(v) "(" << v.x() << ", " << v.y() << ", " << v.z() << ")"

Enumerations

enum ArtificialWorld::BlockAttributesSetEnum { ArtificialWorld::noneSet = 0, ArtificialWorld::centerDirSet = 1, ArtificialWorld::centerPointSet = 2, ArtificialWorld::bothSet = 3 }
Ktery z atributu bloku je nastaveny. More...

Macro Definition Documentation

#define SHOWVEC3 ( v ) "(" << v.x() << ", " << v.y() << ", " << v.z() << ")"
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Cache.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes
Cache.h File Reference
#include "ModelManager.h"
#include <vrecko/EnvironmentObject.h>
#include <map>
#include <list>
#include <string>
#include <vrecko/World.h>
#include <osg/Timer>
#include "model.h"
#include "Preloader.h"

Go to the source code of this file.

Classes

class | CacheInfo
Trida pro drzeni informaci o polozce v Cache. More...
class | Cache
Cache, sleduje deni v ModelManageru a reaguje na udalosti ziskani modelu, smazani modelu a pridani modelu v MM. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/model.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Namespaces | Enumerations
model.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vector>
#include <string>
#include <osgCal/CoreModel>
#include <osgCal/Model>
#include "awHelper.h"

Go to the source code of this file.

Classes

class | ArtificialWorld::Model
Uchovava informace o modelu. More...
class | ArtificialWorld::AnimatedModel
Uchovava informace o animovanem Cal3D modelu, stejne jako Model, navic cislo animace, ktera se ma spustit. More...

Namespaces

namespace ArtificialWorld

Enumerations

enum | ArtificialWorld::ModelType { ArtificialWorld::none, ArtificialWorld::geometry, ArtificialWorld::cal3D, ArtificialWorld::other }
typ modelu More...
enum | ArtificialWorld::ModelFlags { ArtificialWorld::NONE = 1, ArtificialWorld::NO_SUBBLOCKS = NONE << 1 }
flagy modelu More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes
ModelManager.h File Reference
#include <vector>
#include <map>
#include <osg/Notify>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Group>
#include <osg/ShadeModel>
#include <osg/CullFace>
#include <osg/StateSet>
#include <osgDB/Registry>
#include <osgDB/ReadFile>
#include <osgUtil/Optimizer>
#include <osgCal/CoreModel>
#include <osgCal/Model>

Go to the source code of this file.

Classes

struct | GeometryState
uchovava informace o statickem modelu, jeho data v pameti a pocet referenci (instanci modelu ve scene) More...
struct | AnimatedGeometryState
uchovava informace o animovanem Cal3D modelu, jeho data v pameti a pocet referenci More...
class | DeleteObserver
rozhrani pro objekty, ktere zajima udalost Delete More...
class | GetObserver
rozhrani pro objekty, ktere zajima udalost Get More...
class | AddObserver
rozhrani pro objekty, ktere zajima udalost Add More...
class | ModelManager
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Preloader.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes
Preloader.h File Reference
#include "PreloaderHeuristic.h"
#include <windows.h>
#include <process.h>
#include <osg/Timer>
#include <vrecko/MTLock.h>
#include "ModelManager.h"

Go to the source code of this file.

Classes

class Preloader
Nahrava pravdepodobne potrebne modely v blizke budoucnosti, modely jsou urceny podle pouzite heuristiky. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Functions
PreloaderHeuristic.h File Reference

Go to the source code of this file.

Classes

class | PreloaderLoadedInfo
class | PreloaderToLoadInfo
class | PreloaderHeuristic
Rozhrani pro heuristiky, ktere se maji pouzit v Preloaderu. More...
class | BasicPreloaderHeuristic

Functions

bool ComputePoint (double x, double y, double sizexy, double sizeuv, double anglecos, double side, osg::Vec2 lastPoint, osg::Vec2 *result)

Function Documentation

bool ComputePoint | ( | double | x,
 |  | double | y,
 |  | double | sizexy,
 |  | double | sizeuv,
 |  | double | anglecos,
 |  | double | side,
 |  | osg::Vec2 | lastPoint,
 |  | osg::Vec2 * | result
 | ) |  |

Vstup: vektor (x,y), velikost vektoru (x,y), velikost hledaneho vektoru (u,v), cosinus uhlu, ktery maji svirat vektory (x,y) a (u,v), polorovina, v niz ma lezet vypocteny bod (vzhledem k primce dane vektorem (x,y), 0 = ma lezet na primce, >0 = vpravo od primky (vektoru), <0 = vlevo od primky (vektoru)), vysledny hledany vektor

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Namespaces
subblock.h File Reference
#include <string>
#include "subblock_animation.h"

Go to the source code of this file.

Classes

class ArtificialWorld::SubBlock
Trida reprezentujici jeden blok ve scene. More...

Namespaces

namespace ArtificialWorld
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock_animation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Namespaces | Enumerations
subblock_animation.h File Reference
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Node>
#include <vector>
#include "awHelper.h"

Go to the source code of this file.

Classes

class | ArtificialWorld::AnimationPoint
Trida reprezentujici jeden bod animace a stav (pozice, rotace, zvetseni, alfa, maska) objektu v tomto bode. More...
class | ArtificialWorld::SubBlockAnimation
Trida reprezentujici animaci bloku. More...

Namespaces

namespace ArtificialWorld

Enumerations

enum | ArtificialWorld::AnimationType { ArtificialWorld::ScaleRotateTranslation = 1, ArtificialWorld::Alpha = 2, ArtificialWorld::NodeMask = 4 }
Typ animace bloku. More...
enum | ArtificialWorld::AnimationLoopType { ArtificialWorld::NoLoop, ArtificialWorld::Simple, ArtificialWorld::BiDirectional }
Typ opakovani animace. More...
enum | ArtificialWorld::AnimationInterpolationType { ArtificialWorld::Linear, ArtificialWorld::Sine }
Typ interpolace mezi jednotlivymi body animace. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/WorldBuilder.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Classes | Namespaces
WorldBuilder.h File Reference
#include "ModelManager.h"
#include "Cache.h"

Go to the source code of this file.

Classes

class ArtificialWorld::WorldBuilder
Trida, ktera vytvori hierarchicky svet ve scene. More...

Namespaces

namespace ArtificialWorld
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO Directory Reference

  • include
  • vreckoAP
  • behindO
behindO Directory Reference

Files

file | AP_behindO.h [code]
file | AvatarManipulator.h [code]
file | BehindObstacleExp_wT.h [code]
file | BehindObstacleExperiment.h [code]
file | CentreObjectManipulator.h [code]
file | ChangeOfVisibility.h [code]
file | ContactObjectManipulator.h [code]
file | CreateShadowedScene.h [code]
file | CuttingPlane.h [code]
file | EyeManipulator.h [code]
file | HeadManipulator.h [code]
file | HMDHeadManipulator.h [code]
file | Lens.h [code]
file | Manipulator.h [code]
file | MappingFunctions.h [code]
file | Mirror.h [code]
file | WIM.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/AP_behindO.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Macros | Functions
AP_behindO.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "Mirror.h"
#include "Lens.h"
#include "WIM.h"
#include "ChangeOfVisibility.h"
#include "CuttingPlane.h"
#include "Manipulator.h"
#include "HeadManipulator.h"
#include "HMDHeadManipulator.h"
#include "CentreObjectManipulator.h"
#include "ContactObjectManipulator.h"
#include "BehindObstacleExperiment.h"
#include "BehindObstacleExp_wT.h"
#include "AvatarManipulator.h"
#include "EyeManipulator.h"
#include "MappingFunctions.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | behindO_getAbilityList (void)
Ability AP_EXPORT * | behindO_getAbilityInstance (const char *_name)
const char AP_EXPORT * | behindO_getAbilityDescription (const char *name)
void AP_EXPORT | behindO_setAbilitiesParameters (void)
const char AP_EXPORT * | behindO_getPluginDescription (void)
void AP_EXPORT | behindO_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char AP_EXPORT* behindO_getAbilityDescription ( const char * name )
Ability AP_EXPORT* behindO_getAbilityInstance ( const char * _name )
const char AP_EXPORT** behindO_getAbilityList ( void )
const char AP_EXPORT* behindO_getPluginDescription ( void )
void AP_EXPORT behindO_initializeAttributesDescription ( )
void AP_EXPORT behindO_setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/AvatarManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
AvatarManipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Matrix>

Go to the source code of this file.

Classes

class behindO::AvatarManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExp_wT.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes
BehindObstacleExp_wT.h File Reference
#include <vrecko/Ability.h>
#include <osg/Geode>
#include <osgText/Text>
#include <osgText/Font>
#include <osg/BlendFunc>
#include <osg/Material>
#include <osg/StateSet>

Go to the source code of this file.

Classes

class | BehindObstacleExp_wT
struct | BehindObstacleExp_wT::ExperimentRec
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExperiment.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes
BehindObstacleExperiment.h File Reference
#include <vrecko/Ability.h>
#include <osg/Geode>
#include <osgText/Text>
#include <osgText/Font>
#include <osg/BlendFunc>
#include <osg/Material>
#include <osg/StateSet>

Go to the source code of this file.

Classes

class | BehindObstacleExperiment
struct | BehindObstacleExperiment::ExperimentRec
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CentreObjectManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
CentreObjectManipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Timer>

Go to the source code of this file.

Classes

class behindO::CentreObjectManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ChangeOfVisibility.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
ChangeOfVisibility.h File Reference
#include <vrecko/Ability.h>
#include <osg/MatrixTransform>

Go to the source code of this file.

Classes

class behindO::ChangeOfVisibility

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ContactObjectManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
ContactObjectManipulator.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class behindO::ContactObjectManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CreateShadowedScene.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Functions
CreateShadowedScene.h File Reference
#include <osg/Node>
#include <osg/Vec3>

Go to the source code of this file.

Functions

osg::Group * createShadowedScene (osg::Node *shadower, osg::Node *shadowed, const osg::Vec3 &lightPosition, float radius, unsigned int textureUnit=1)

Function Documentation

osg::Group* createShadowedScene | ( | osg::Node * | shadower,
 |  | osg::Node * | shadowed,
 |  | const osg::Vec3 & | lightPosition,
 |  | float | radius,
 |  | unsigned int | textureUnit = 1
 | ) |  |
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CuttingPlane.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
CuttingPlane.h File Reference
#include <vrecko/Ability.h>
#include <osg/ClipNode>
#include <osg/StateSet>

Go to the source code of this file.

Classes

class behindO::CuttingPlane

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/EyeManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
EyeManipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Matrix>

Go to the source code of this file.

Classes

class behindO::EyeManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HeadManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
HeadManipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Quat>
#include <osg/Matrix>

Go to the source code of this file.

Classes

class behindO::HeadManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HMDHeadManipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
HMDHeadManipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Quat>

Go to the source code of this file.

Classes

class behindO::HMDHeadManipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Lens.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
Lens.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class behindO::Lens

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Manipulator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
Manipulator.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Matrix>

Go to the source code of this file.

Classes

class behindO::Manipulator

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/MappingFunctions.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
MappingFunctions.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <osg/MatrixTransform>

Go to the source code of this file.

Classes

class behindO::MappingFunctions

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Mirror.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
Mirror.h File Reference
#include <vrecko/Ability.h>
#include <osg/MatrixTransform>
#include <osg/Geode>
#include <osg/Geometry>
#include <osgUtil/UpdateVisitor>
#include <osg/Texture2D>
#include <osg/Node>
#include <osgUtil/TransformCallback>
#include <osgUtil/RenderStage>
#include <osgUtil/SmoothingVisitor>
#include <osgUtil/CullVisitor>

Go to the source code of this file.

Classes

class | behindO::MyUpdateCallback
class | behindO::MyCullCallback
class | behindO::Mirror

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/WIM.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Classes | Namespaces
WIM.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <osg/MatrixTransform>
#include <esg/OSGAdapter.h>

Go to the source code of this file.

Classes

class | behindO::WIM
struct | behindO::WIM::ObjectCopy

Namespaces

namespace behindO
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids Directory Reference

  • include
  • vreckoAP
  • Boids
Boids Directory Reference

Files

file | AP_boids.h [code]
file | Boid.h [code]
file | BoidsLogic.h [code]
file | BoidsPlanner.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/AP_boids.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
Macros | Functions
AP_boids.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "Boid.h"
#include "BoidsLogic.h"
#include "BoidsPlanner.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | boids_getAbilityList (void)
Ability AP_EXPORT * | boids_getAbilityInstance (const char *_name)
const char AP_EXPORT * | boids_getAbilityDescription (const char *name)
const char AP_EXPORT * | boids_getPluginDescription (void)
void AP_EXPORT | boids_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char AP_EXPORT* boids_getAbilityDescription ( const char * name )
Ability AP_EXPORT* boids_getAbilityInstance ( const char * _name )
const char AP_EXPORT** boids_getAbilityList ( void )
const char AP_EXPORT* boids_getPluginDescription ( void )
void AP_EXPORT boids_initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/Boid.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
Classes | Namespaces
Boid.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class boids::Boid

Namespaces

namespace boids
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsLogic.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
Classes | Namespaces | Variables
BoidsLogic.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/IOPins.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <osg/Vec3>
#include <vector>

Go to the source code of this file.

Classes

class boids::BoidsLogic

Namespaces

namespace boids

Variables

const float boids::cycles_per_sec = 30.0f
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsPlanner.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
Classes | Namespaces
BoidsPlanner.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <osg/Vec3>
#include <vector>

Go to the source code of this file.

Classes

class boids::BoidsPlanner

Namespaces

namespace boids
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor Directory Reference

  • include
  • vreckoAP
  • CableEditor
CableEditor Directory Reference

Files

file | AP_CableEditor.h [code]
file | Cable.h [code]
file | CableEditor.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/AP_CableEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
Functions
AP_CableEditor.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | CableEditor_getPluginDescription ()
AP_EXPORT const char ** | CableEditor_getAbilityList ()
AP_EXPORT const char * | CableEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CableEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | CableEditor_setAbilitiesParameters ()
void AP_EXPORT | CableEditor_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* CableEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CableEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CableEditor_getAbilityList ( )
AP_EXPORT const char* CableEditor_getPluginDescription ( )
void AP_EXPORT CableEditor_initializeAttributesDescription ( )
AP_EXPORT void CableEditor_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/Cable.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
Classes | Namespaces | Macros
Cable.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/PluginManager.h>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Drawable>
#include <osg/ShapeDrawable>

Go to the source code of this file.

Classes

class AP_CableEditor::Cable

Namespaces

namespace AP_CableEditor

Macros

#define | SPHERE_RADIUS 2.0;
#define | INTERPOLATION_CATMULL_ROM_ITERATE 1
#define | INTERPOLATION_CATMULL_ROM_PER_SEGMENT 2

Macro Definition Documentation

#define INTERPOLATION_CATMULL_ROM_ITERATE 1
#define INTERPOLATION_CATMULL_ROM_PER_SEGMENT 2
#define SPHERE_RADIUS 2.0;
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/CableEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
Classes | Namespaces | Macros
CableEditor.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/PluginManager.h>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <osg/Group>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Shape>
#include <osg/ShapeDrawable>
#include <osg/Node>
#include <osgDB/WriteFile>
#include <iostream>
#include <sstream>
#include <vector>
#include <cmath>
#include <fstream>
#include <iomanip>
#include <vreckoAP/CableEditor/Cable.h>

Go to the source code of this file.

Classes

class AP_CableEditor::CableEditor

Namespaces

namespace AP_CableEditor

Macros

#define | CE_RADIUS_ADJUSTMENT 0.9
#define | CE_RADIUS_RANGE_FROM 0.0
#define | CE_RADIUS_RANGE_TO 2.0

Macro Definition Documentation

#define CE_RADIUS_ADJUSTMENT 0.9
#define CE_RADIUS_RANGE_FROM 0.0
#define CE_RADIUS_RANGE_TO 2.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement Directory Reference

  • include
  • vreckoAP
  • CameraMovement
CameraMovement Directory Reference

Files

file | AP_CameraMovement.h [code]
file | CameraMovementEditor.h [code]
file | CameraPath.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/AP_CameraMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
Functions
AP_CameraMovement.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | CameraMovement_getPluginDescription ()
AP_EXPORT const char ** | CameraMovement_getAbilityList ()
AP_EXPORT const char * | CameraMovement_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CameraMovement_getAbilityInstance (const char *pchName)
AP_EXPORT void | CameraMovement_setAbilitiesParameters ()
void AP_EXPORT | CameraMovement_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* CameraMovement_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CameraMovement_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CameraMovement_getAbilityList ( )
AP_EXPORT const char* CameraMovement_getPluginDescription ( )
void AP_EXPORT CameraMovement_initializeAttributesDescription ( )
AP_EXPORT void CameraMovement_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraMovementEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
Classes | Namespaces
CameraMovementEditor.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <osgDB/ReadFile>
#include <iostream>
#include <sstream>
#include "CameraPath.h"

Go to the source code of this file.

Classes

class APCameraMovement::CameraMovementEditor

Namespaces

namespace APCameraMovement
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraPath.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
Classes | Namespaces | Macros
CameraPath.h File Reference
#include <vrecko/ReaderWriter.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <osg/Group>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Shape>
#include <osg/ShapeDrawable>
#include <osg/PositionAttitudeTransform>
#include <osg/LineWidth>
#include <osg/LightModel>
#include <osg/ShadeModel>
#include <osg/PolygonMode>
#include <osg/Timer>
#include <vector>

Go to the source code of this file.

Classes

struct | APCameraMovement::ControlPoint
class | APCameraMovement::CameraPath

Namespaces

namespace APCameraMovement

Macros

#define | CONTROL_POINT_RADIUS 1.0
#define | CONTROL_POINT_COLOR osg::Vec4(1.0, 0.0, 0.0, 0.5)
#define | VECTOR_POINT_RADIUS 1.0
#define | VECTOR_POINT_COLOR osg::Vec4(0.0, 0.0, 1.0, 0.5)
#define | CONTROL_LINE_WIDTH 1.0
#define | CONTROL_LINE_COLOR osg::Vec4(0.0, 0.0, 1.0, 1.0)
#define | PATH_LINE_WIDTH 1.0
#define | PATH_LINE_COLOR osg::Vec4(1.0, 0.0, 0.0, 1.0)
#define | DEFAULT_VECPW osg::Vec3(CONTROL_POINT_RADIUS*3, 0.0, 0.0)
#define | DEFAULT_VECCPW osg::Vec3(-(CONTROL_POINT_RADIUS*3), 0.0, 0.0)
#define | DEFAULT_CDIR osg::Quat(0.0, 0.0, 0.0, 1.0)
#define | TOP_VECTOR osg::Vec3(0.0, 1.0, 0.0)
#define | DIR_VECTOR osg::Vec3(0.0, 0.0, 1.0)
#define | STEP 0.01
#define | MULT 6
#define | SPEED 2

Macro Definition Documentation

#define CONTROL_LINE_COLOR osg::Vec4(0.0, 0.0, 1.0, 1.0)
#define CONTROL_LINE_WIDTH 1.0
#define CONTROL_POINT_COLOR osg::Vec4(1.0, 0.0, 0.0, 0.5)
#define CONTROL_POINT_RADIUS 1.0
#define DEFAULT_CDIR osg::Quat(0.0, 0.0, 0.0, 1.0)
#define DEFAULT_VECCPW osg::Vec3(-(CONTROL_POINT_RADIUS*3), 0.0, 0.0)
#define DEFAULT_VECPW osg::Vec3(CONTROL_POINT_RADIUS*3, 0.0, 0.0)
#define DIR_VECTOR osg::Vec3(0.0, 0.0, 1.0)
#define MULT 6
#define PATH_LINE_COLOR osg::Vec4(1.0, 0.0, 0.0, 1.0)
#define PATH_LINE_WIDTH 1.0
#define SPEED 2
#define STEP 0.01
#define TOP_VECTOR osg::Vec3(0.0, 1.0, 0.0)
#define VECTOR_POINT_COLOR osg::Vec4(0.0, 0.0, 1.0, 0.5)
#define VECTOR_POINT_RADIUS 1.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath Directory Reference

  • include
  • vreckoAP
  • CameraPath
CameraPath Directory Reference

Files

file | AP_CameraPath.h [code]
file | Camera.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/AP_CameraPath.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraPath
Functions
AP_CameraPath.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | CameraPath_getPluginDescription ()
AP_EXPORT const char ** | CameraPath_getAbilityList ()
AP_EXPORT const char * | CameraPath_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CameraPath_getAbilityInstance (const char *pchName)
AP_EXPORT void | CameraPath_setAbilitiesParameters ()
void AP_EXPORT | CameraPath_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* CameraPath_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CameraPath_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CameraPath_getAbilityList ( )
AP_EXPORT const char* CameraPath_getPluginDescription ( )
void AP_EXPORT CameraPath_initializeAttributesDescription ( )
AP_EXPORT void CameraPath_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/Camera.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraPath
Classes | Namespaces | Macros | Typedefs | Functions
Camera.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/PluginManager.h>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <helpers/XercesXMLUtils.h>
#include <vrecko/ReaderWriter.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <osg/Group>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Shape>
#include <osg/ShapeDrawable>
#include <osg/Timer>
#include <iostream>
#include <fstream>
#include <sstream>
#include <vector>
#include <cmath>

Go to the source code of this file.

Classes

struct | APCameraPath::ControlPoint
class | APCameraPath::Camera

Namespaces

namespace APCameraPath

Macros

#define | SHOW_VIEW_LINE false
#define | PATH_POINT_RADIUS 0.5
#define | SHOW_LINES_WHILE_ANIMATING false
#define | ANIMATION_TIME 10
#define | DYNAMIC_SPEED false
#define | TRANSPARENCY 1.0
#define | AUTO_RUN false;

Typedefs

typedef unsigned int APCameraPath::_uint

Functions

float | APCameraPath::F1 (float t)
float | APCameraPath::F2 (float t)
float | APCameraPath::F3 (float t)
float | APCameraPath::F4 (float t)

Macro Definition Documentation

#define ANIMATION_TIME 10
#define AUTO_RUN false;
#define DYNAMIC_SPEED false
#define PATH_POINT_RADIUS 0.5
#define SHOW_LINES_WHILE_ANIMATING false
#define SHOW_VIEW_LINE false
#define TRANSPARENCY 1.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim Directory Reference

  • include
  • vreckoAP
  • CarSim
CarSim Directory Reference

Files

file | AP_CarSim.h [code]
file | AP_Filter.h [code]
file | CarControlUnit.h [code]
file | CarEnvirons.h [code]
file | CarExecutionUnit.h [code]
file | CarPartsNodeCache.h [code]
file | CarState.h [code]
file | CCUStructs.h [code]
file | Edge.h [code]
file | Junction.h [code]
file | PolygonPoint.h [code]
file | Remover.h [code]
file | RoadsEdges.h [code]
file | RoadsState.h [code]
file | TLsOnJuncManager.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/AP_CarSim.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Macros | Functions
AP_CarSim.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

AP_EXPORT const char ** | CarSim_getAbilityList (void)
AP_EXPORT vrecko::Ability * | CarSim_getAbilityInstance (const char *_name)
AP_EXPORT const char * | CarSim_getAbilityDescription (const char *name)
AP_EXPORT const char * | CarSim_getPluginDescription (void)
AP_EXPORT void | CarSim_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

AP_EXPORT const char* CarSim_getAbilityDescription ( const char * name )
AP_EXPORT vrecko::Ability* CarSim_getAbilityInstance ( const char * _name )
AP_EXPORT const char** CarSim_getAbilityList ( void )
AP_EXPORT const char* CarSim_getPluginDescription ( void )
AP_EXPORT void CarSim_initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/AP_Filter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
AP_Filter.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarControlUnit.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Functions
CarControlUnit.h File Reference
#include <vrecko/Ability.h>
#include <osg/Matrix>
#include "CCUStructs.h"
#include "CarState.h"
#include "CarEnvirons.h"

Go to the source code of this file.

Classes

class CarSim::CarControlUnit

Namespaces

namespace CarSim

Functions

float CarSim::getBrakeDist (const float carVel, const float desiredVel, const float carDecel, const float hillAcc)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarEnvirons.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
CarEnvirons.h File Reference

Go to the source code of this file.

Classes

struct CarSim::CarEnvirons

Namespaces

namespace CarSim

Macros

#define | CAR_LEFT_JUNCTION 1
#define | CAR_IN_JUNCTION 2
#define | CAR_ON_SHORT_EDGE_BEFORE_JUNC 3
#define | CAR_BEHIND_STOP_OR_GO_DECISION 4
#define | CAR_BEHIND_STOP_OR_GO_DECISION_AND_PUT_ASIDE_TO_ROAD_MARGIN 5
#define | CAR_IN_FRONT_OF_STOP_OR_GO_DECISION 6
#define | CAR_BEFORE_END 7
#define | NEXT_JUNC_TURN_LEFT 1
#define | NEXT_JUNC_TURN_RIGHT 2

Macro Definition Documentation

#define CAR_BEFORE_END 7
#define CAR_BEHIND_STOP_OR_GO_DECISION 4
#define CAR_BEHIND_STOP_OR_GO_DECISION_AND_PUT_ASIDE_TO_ROAD_MARGIN 5
#define CAR_IN_FRONT_OF_STOP_OR_GO_DECISION 6
#define CAR_IN_JUNCTION 2
#define CAR_LEFT_JUNCTION 1
#define CAR_ON_SHORT_EDGE_BEFORE_JUNC 3
#define NEXT_JUNC_TURN_LEFT 1
#define NEXT_JUNC_TURN_RIGHT 2
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarExecutionUnit.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
CarExecutionUnit.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/IOPins.h>
#include <vrecko/Message.h>
#include <osg/MatrixTransform>
#include "CarState.h"
#include "CCUStructs.h"

Go to the source code of this file.

Classes

struct | CarSim::Lights
struct | CarSim::GeometryPartsPath
class | CarSim::CarExecutionUnit

Namespaces

namespace CarSim

Macros

#define | FRONT_LIGHT 1
#define | BRAKE_LIGHT 2
#define | BLINK_LIGHT 3
#define | BLINK_LENGTH 1.0

Macro Definition Documentation

#define BLINK_LENGTH 1.0
#define BLINK_LIGHT 3
#define BRAKE_LIGHT 2
#define FRONT_LIGHT 1
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarPartsNodeCache.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
CarPartsNodeCache.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Message.h>
#include <vrecko/Ability.h>
#include <map>
#include <string>
#include <osg/Node>

Go to the source code of this file.

Classes

class CarSim::CarPartsNodeCache

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarState.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
CarState.h File Reference
#include <osg/Vec3>

Go to the source code of this file.

Classes

struct | CarSim::CarSize
struct | CarSim::CarState

Namespaces

namespace CarSim

Macros

#define | HILL_ACC_COEF 3.0
#define | AVERAGE_CAR_LENGTH 5.0
#define | MAX_CAR_WIDTH 3.0
#define | MAX_CAR_LENGTH 10.0
#define | AVERAGE_CAR_DEC -3.0
#define | WHEEL_ANGLE_CONST 3.0
#define | LIGHT_TURNED_ON 1
#define | LIGHT_TURNED_OFF 2
#define | LEFT_BLINKER_TURNED_ON 3
#define | RIGHT_BLINKER_TURNED_ON 4

Macro Definition Documentation

#define AVERAGE_CAR_DEC -3.0
#define AVERAGE_CAR_LENGTH 5.0
#define HILL_ACC_COEF 3.0
#define LEFT_BLINKER_TURNED_ON 3
#define LIGHT_TURNED_OFF 2
#define LIGHT_TURNED_ON 1
#define MAX_CAR_LENGTH 10.0
#define MAX_CAR_WIDTH 3.0
#define RIGHT_BLINKER_TURNED_ON 4
#define WHEEL_ANGLE_CONST 3.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
CCUStructs.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/Message.h>
#include <vector>
#include "CarEnvirons.h"
#include "CarState.h"

Go to the source code of this file.

Classes

struct | CarSim::StartStopDestination
struct | CarSim::Parameters
struct | CarSim::First3Juncs
struct | CarSim::CarEdgeData
class | CarSim::MessageRoadAndDir
class | CarSim::MessageCarEdge
class | CarSim::MessageCarEdgeData
class | CarSim::MessageEdgeOffset
class | CarSim::MessageVectorUnsignedInt
class | CarSim::MessageStartStopDestination
class | CarSim::MessageFirst3Juncs
class | CarSim::MessageCarSimParameters
class | CarSim::MessageCarEnvirons
class | CarSim::MessageCarStatePtr

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Edge.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
Edge.h File Reference
#include <queue>

Go to the source code of this file.

Classes

struct | CarSim::EdgesCar
struct | CarSim::Edge

Namespaces

namespace CarSim

Macros

#define | NORMAL_EDGE 1
#define | ULTRA_SHORT_EDGE 2
#define | ULTRA_SHORT_EDGE_WITHOUT_ANY_LANE 3
#define | SHORT_EDGE 4
#define | NORMAL_OR_SHORT_EDGE_WITHOUT_ANY_LANE 5
#define | TERMINATOR_EDGE 6
#define | TL_GREEN_INTERV_DEFAULT 6

Macro Definition Documentation

#define NORMAL_EDGE 1
#define NORMAL_OR_SHORT_EDGE_WITHOUT_ANY_LANE 5
#define SHORT_EDGE 4
#define TERMINATOR_EDGE 6
#define TL_GREEN_INTERV_DEFAULT 6
#define ULTRA_SHORT_EDGE 2
#define ULTRA_SHORT_EDGE_WITHOUT_ANY_LANE 3
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Junction.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
Junction.h File Reference
#include <map>

Go to the source code of this file.

Classes

struct | CarSim::InOutEdgesAttr
struct | CarSim::JuncsEdge
struct | CarSim::Junction

Namespaces

namespace CarSim

Macros

#define | CONTROL_SYSTEM_RIGHT_HAND 1
#define | CONTROL_SYSTEM_TRAFFIC_LIGHTS 2

Macro Definition Documentation

#define CONTROL_SYSTEM_RIGHT_HAND 1
#define CONTROL_SYSTEM_TRAFFIC_LIGHTS 2
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/PolygonPoint.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
PolygonPoint.h File Reference

Go to the source code of this file.

Classes

struct CarSim::PolygonPoint

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Remover.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
Remover.h File Reference
#include <vrecko/Ability.h>
#include <set>
#include <vrecko/IOPins.h>
#include <vrecko/Message.h>

Go to the source code of this file.

Classes

class CarSim::Remover

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsEdges.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
RoadsEdges.h File Reference

Go to the source code of this file.

Classes

struct CarSim::RoadsEdges

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsState.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces
RoadsState.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/IOPins.h>
#include <vrecko/Message.h>
#include "Junction.h"
#include "PolygonPoint.h"
#include "Edge.h"
#include "RoadsEdges.h"
#include "CarControlUnit.h"
#include <osg/Vec3>
#include <set>
#include <map>
#include <vector>

Go to the source code of this file.

Classes

class CarSim::RoadsState

Namespaces

namespace CarSim
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/TLsOnJuncManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Classes | Namespaces | Macros
TLsOnJuncManager.h File Reference
#include <vrecko/Ability.h>
#include <vector>
#include <osg/MatrixTransform>

Go to the source code of this file.

Classes

struct | CarSim::TLcolorsMT
class | CarSim::TLsOnJuncManager

Namespaces

namespace CarSim

Macros

#define | TL_RED_ORANGE 1
#define | TL_GREEN 2
#define | TL_ORANGE 3
#define | TL_RED 4

Macro Definition Documentation

#define TL_GREEN 2
#define TL_ORANGE 3
#define TL_RED 4
#define TL_RED_ORANGE 1
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor Directory Reference

  • include
  • vreckoAP
  • ConnectEditor
ConnectEditor Directory Reference

Files

file | AP_ConnectEditor.h [code]
file | ConnectEditor.h [code]
file | connecting_functions.h [code]
file | Cut.h [code]
file | erf.h [code]
file | functions.h [code]
file | icp_functions.h [code]
file | normal.h [code]
file | Optimalizer.h [code]
file | PolygonState.h [code]
file | Rotation.h [code]
file | Scale.h [code]
file | SnapObject.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/AP_ConnectEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Functions
AP_ConnectEditor.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>

Go to the source code of this file.

Functions

AP_EXPORT const char * | ConnectEditor_getPluginDescription ()
AP_EXPORT char ** | ConnectEditor_getAbilityList ()
AP_EXPORT const char * | ConnectEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | ConnectEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | ConnectEditor_setAbilitiesParameters ()
void AP_EXPORT | ConnectEditor_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* ConnectEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* ConnectEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT char** ConnectEditor_getAbilityList ( )
AP_EXPORT const char* ConnectEditor_getPluginDescription ( )
void AP_EXPORT ConnectEditor_initializeAttributesDescription ( )
AP_EXPORT void ConnectEditor_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/ConnectEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
ConnectEditor.h File Reference
#include <time.h>
#include "../EditorController/ControllableAbility.h"
#include "functions.h"
#include "SnapObject.h"
#include "normal.h"

Go to the source code of this file.

Classes

class APConnectEditor::ConnectEditor

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/connecting_functions.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Functions
connecting_functions.h File Reference

Go to the source code of this file.

Functions

float | weightFunction (float value)
double | weightFunctionNormalize (double value, double maxValue)
double | weightGaussFunction (double x)
double | F (double x)

Function Documentation

double F ( double x )
float weightFunction ( float value )
double weightFunctionNormalize | ( | double | value,
 |  | double | maxValue
 | ) |  |
double weightGaussFunction ( double x )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Cut.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
Cut.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <helpers/DynamicArray.h>
#include "SnapObject.h"

Go to the source code of this file.

Classes

class APConnectEditor::Cut

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/erf.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Functions
erf.h File Reference

Go to the source code of this file.

Functions

double | erf (double x)
double | erfc (double x)

Function Documentation

double erf ( double x )
double erfc ( double x )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/functions.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Functions
functions.h File Reference
#include <vrecko/EventDispatcher.h>
#include <osg/Geometry>

Go to the source code of this file.

Functions

osg::Geode * | getGeodeOf (osg::Node *eo)
osg::Geometry * | getGeometryOf (osg::Node *eo)
osg::Vec3Array * | getVerticesOf (osg::Node *eo)
osg::Vec3Array * | getNormalsOf (osg::Node *eo)
DrawElementsUShort * | getFacesOf (osg::Node *eo)
void | printMessageTime (string str, float time)
void | printMessage (string str)
void | printMessage (string str, float number)
void | printErrorMessage (string str)
bool | addLinesToScene (map< int, int > lines, Vec3Array *sourceVertices, Vec3Array *targetVertices, EnvironmentObject *eoParent)
bool | addLinesToScene (vector< int > lines, Vec3Array *vertices, EnvironmentObject *eoParent, int color, std::string name)
bool | addLinesToEo (vector< int > lines, Vec3Array *vertices, EnvironmentObject *eo, int color, std::string name)
bool | addMeshToScene (vector< int > boundaryLoop, EnvironmentObject *eoLoop)
bool | addMeshToScene (vector< int > boundaryLoop, EnvironmentObject *eoLoop, int color)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color, std::string name)
bool | addVerticesToScene (osg::Vec3Array *vertices, Group *parent)
bool | addPointToScene (osg::Vec3 point, osg::Group *parentEnvironmentObject)
bool | addPointToScene90 (osg::Vec3 point, osg::Group *parentEnvironmentObject)
float | matrixTrace3x3 (float matrix[3][3])
bool | getMatrixOfRotation (float q[7], float R[4][4])
bool | getMatrixOfRotation (float q[7], osg::Matrix &m)
void | matrixTranspose4x4 (float m[4][4], float mt[4][4])
void | quaternionNormalize (float q[7], float qNormalized[7])
float | quaternionLength (float q[7])
bool | getMergeMatrix (EnvironmentObject *targetEo, EnvironmentObject *sourceEo, osg::Matrix &matrix)
osg::Vec3 | findClosestPointOnLine (osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB)
osg::Vec3 | findClosestPointOnFace (osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB, osg::Vec3 pointC, bool &onFace)
float | p2pEuclideanDistance (osg::Vec3 point1, osg::Vec3 point2)
vector< int > | findClosestPoint (vector< int > snappingRegion, Vec3Array *points, vector< int > browsingSnappingRegion, Vec3Array *browsingPoints)
vector< int > | findClosestPointNorm (vector< int > boundarySnappingRegion, Vec3Array *boundaryPoints, Vec3Array *boundaryNormals, vector< int > browsingSnappingRegion, Vec3Array *browsingPoints, Vec3Array *browsingNormals)
bool | includeFace (unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *vertices)
bool | eraseFace (unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *faces)
osg::Vec3 | centerOfMass (osg::Vec3Array *points)
osg::Vec3 | centerOfMass (osg::Vec3Array *points, vector< int > area)
float | normalsVariance (osg::Vec3 n1, osg::Vec3 n2)

Function Documentation

bool addLinesToEo | ( | vector< int > | lines,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | eo,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addLinesToScene | ( | map< int, int > | lines,
 |  | Vec3Array * | sourceVertices,
 |  | Vec3Array * | targetVertices,
 |  | EnvironmentObject * | eoParent
 | ) |  |
bool addLinesToScene | ( | vector< int > | lines,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | eoParent,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | EnvironmentObject * | eoLoop
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | EnvironmentObject * | eoLoop,
 |  | int | color
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent,
 |  | int | color
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addPointToScene | ( | osg::Vec3 | point,
 |  | osg::Group * | parentEnvironmentObject
 | ) |  |
bool addPointToScene90 | ( | osg::Vec3 | point,
 |  | osg::Group * | parentEnvironmentObject
 | ) |  |
bool addVerticesToScene | ( | osg::Vec3Array * | vertices,
 |  | Group * | parent
 | ) |  |
osg::Vec3 centerOfMass ( osg::Vec3Array * points )
osg::Vec3 centerOfMass | ( | osg::Vec3Array * | points,
 |  | vector< int > | area
 | ) |  |
bool eraseFace | ( | unsigned long | pointA,
 |  | unsigned long | pointB,
 |  | unsigned long | pointC,
 |  | osg::DrawElementsUShort * | faces
 | ) |  |
vector<int> findClosestPoint | ( | vector< int > | snappingRegion,
 |  | Vec3Array * | points,
 |  | vector< int > | browsingSnappingRegion,
 |  | Vec3Array * | browsingPoints
 | ) |  |
vector<int> findClosestPointNorm | ( | vector< int > | boundarySnappingRegion,
 |  | Vec3Array * | boundaryPoints,
 |  | Vec3Array * | boundaryNormals,
 |  | vector< int > | browsingSnappingRegion,
 |  | Vec3Array * | browsingPoints,
 |  | Vec3Array * | browsingNormals
 | ) |  |
osg::Vec3 findClosestPointOnFace | ( | osg::Vec3 | point,
 |  | osg::Vec3 | pointA,
 |  | osg::Vec3 | pointB,
 |  | osg::Vec3 | pointC,
 |  | bool & | onFace
 | ) |  |
osg::Vec3 findClosestPointOnLine | ( | osg::Vec3 | point,
 |  | osg::Vec3 | pointA,
 |  | osg::Vec3 | pointB
 | ) |  |
DrawElementsUShort* getFacesOf ( osg::Node * eo )
osg::Geode* getGeodeOf ( osg::Node * eo )
osg::Geometry* getGeometryOf ( osg::Node * eo )
bool getMatrixOfRotation | ( | float | q[7],
 |  | float | R[4][4]
 | ) |  |
bool getMatrixOfRotation | ( | float | q[7],
 |  | osg::Matrix & | m
 | ) |  |
bool getMergeMatrix | ( | EnvironmentObject * | targetEo,
 |  | EnvironmentObject * | sourceEo,
 |  | osg::Matrix & | matrix
 | ) |  |
osg::Vec3Array* getNormalsOf ( osg::Node * eo )
osg::Vec3Array* getVerticesOf ( osg::Node * eo )
bool includeFace | ( | unsigned long | pointA,
 |  | unsigned long | pointB,
 |  | unsigned long | pointC,
 |  | osg::DrawElementsUShort * | vertices
 | ) |  |
float matrixTrace3x3 ( float matrix[3][3] )
void matrixTranspose4x4 | ( | float | m[4][4],
 |  | float | mt[4][4]
 | ) |  |
float normalsVariance | ( | osg::Vec3 | n1,
 |  | osg::Vec3 | n2
 | ) |  |
float p2pEuclideanDistance | ( | osg::Vec3 | point1,
 |  | osg::Vec3 | point2
 | ) |  |
void printErrorMessage ( string str )
void printMessage ( string str )
void printMessage | ( | string | str,
 |  | float | number
 | ) |  |
void printMessageTime | ( | string | str,
 |  | float | time
 | ) |  |
float quaternionLength ( float q[7] )
void quaternionNormalize | ( | float | q[7],
 |  | float | qNormalized[7]
 | ) |  |
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/icp_functions.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Macros | Functions
icp_functions.h File Reference
#include <stdlib.h>

Go to the source code of this file.

Macros

#define STDLIB_H

Functions

int | jacobi2 (int n, double *a[], double d[], double *v[])
void | Perpendiculars (const double x[3], double y[3], double z[3], double theta)

Macro Definition Documentation

#define STDLIB_H

Function Documentation

int jacobi2 | ( | int | n,
 |  | double * | a[],
 |  | double | d[],
 |  | double * | v[]
 | ) |  |
void Perpendiculars | ( | const double | x[3],
 |  | double | y[3],
 |  | double | z[3],
 |  | double | theta
 | ) |  |
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/normal.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Functions
normal.h File Reference
#include <vrecko/EnvironmentObject.h>
#include "functions.h"

Go to the source code of this file.

Functions

bool | recomputeNormals (EnvironmentObject *eo)
Vec3 | Vector (Vec3 a, Vec3 b)
Vec3 | Cross (Vec3 a, Vec3 b)
Vec3 | CalculateVector (Vec3 a, Vec3 b, Vec3 c)
float | getAngle (osg::Vec3 A, osg::Vec3 B, osg::Vec3 C)

Function Documentation

Vec3 CalculateVector | ( | Vec3 | a,
 |  | Vec3 | b,
 |  | Vec3 | c
 | ) |  |
Vec3 Cross | ( | Vec3 | a,
 |  | Vec3 | b
 | ) |  |
float getAngle | ( | osg::Vec3 | A,
 |  | osg::Vec3 | B,
 |  | osg::Vec3 | C
 | ) |  |
bool recomputeNormals ( EnvironmentObject * eo )
Vec3 Vector | ( | Vec3 | a,
 |  | Vec3 | b
 | ) |  |
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Optimalizer.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
Optimalizer.h File Reference
#include "../EditorController/ControllableAbility.h"
#include "functions.h"

Go to the source code of this file.

Classes

class APConnectEditor::Optimalizer

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/PolygonState.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
PolygonState.h File Reference
#include "../EditorController/ControllableAbility.h"

Go to the source code of this file.

Classes

class APConnectEditor::PolygonState

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Rotation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
Rotation.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APConnectEditor::Rotation

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Scale.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
Scale.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APConnectEditor::Scale

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/SnapObject.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Classes
SnapObject.h File Reference
#include <vrecko/EnvironmentObject.h>
#include "functions.h"

Go to the source code of this file.

Classes

class SnapObject
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement Directory Reference

  • include
  • vreckoAP
  • ConstrainedMovement
ConstrainedMovement Directory Reference

Files

file | AP_ConstrainedMovement.h [code]
file | ConstrainedObjectMovement.h [code]
file | ConstraintArea.h [code]
file | ConstraintDescription.h [code]
file | ConstraintHierarchy.h [code]
file | PolygonUtils.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/AP_ConstrainedMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Functions
AP_ConstrainedMovement.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | ConstrainedMovement_getPluginDescription ()
AP_EXPORT const char ** | ConstrainedMovement_getAbilityList ()
AP_EXPORT const char * | ConstrainedMovement_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | ConstrainedMovement_getAbilityInstance (const char *pchName)
AP_EXPORT void | ConstrainedMovement_setAbilitiesParameters ()
void AP_EXPORT | ConstrainedMovement_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* ConstrainedMovement_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* ConstrainedMovement_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** ConstrainedMovement_getAbilityList ( )
AP_EXPORT const char* ConstrainedMovement_getPluginDescription ( )
void AP_EXPORT ConstrainedMovement_initializeAttributesDescription ( )
AP_EXPORT void ConstrainedMovement_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Classes | Namespaces | Macros
ConstrainedObjectMovement.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <helpers/DynamicArray.h>
#include <osg/Group>
#include <osg/ShapeDrawable>
#include <osg/Geode>
#include "ConstraintHierarchy.h"

Go to the source code of this file.

Classes

class APConstrainedMovement::ConstrainedObjectMovement

Namespaces

namespace APConstrainedMovement

Macros

#define EPSILON 0.001

Macro Definition Documentation

#define EPSILON 0.001
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintArea.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Classes | Namespaces | Typedefs | Functions
ConstraintArea.h File Reference
#include <vrecko/Ability.h>
#include <vector>
#include <osg/Vec3>
#include <osg/Matrix>
#include "ConstraintHierarchy.h"

Go to the source code of this file.

Classes

class APConstrainedMovement::ConstraintArea

Namespaces

namespace APConstrainedMovement

Typedefs

typedef vector< osg::Vec3 > APConstrainedMovement::Vecs3

Functions

double APConstrainedMovement::vectorAngle (osg::Vec3 vector1, osg::Vec3 vector2)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintDescription.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Classes | Namespaces | Macros | Typedefs
ConstraintDescription.h File Reference
#include <vrecko/Ability.h>
#include <set>
#include <vector>
#include "ConstraintArea.h"
#include <osg/Matrix>

Go to the source code of this file.

Classes

class APConstrainedMovement::ConstraintDescription

Namespaces

namespace APConstrainedMovement

Macros

#define | CONSTRAINED_SNAPPING_DISTANCE 0.5
#define | MAX_CONSTRAINED_SNAPPING_DISTANCE 10.0
#define | CONSTRAINED_ROTATION_DISTANCE CONSTRAINED_SNAPPING_DISTANCE * 10

Typedefs

typedef vector< ConstraintArea * > | APConstrainedMovement::ConstraintAreas
typedef set< int > | APConstrainedMovement::EnvironmentObjectIDs

Macro Definition Documentation

#define CONSTRAINED_ROTATION_DISTANCE CONSTRAINED_SNAPPING_DISTANCE * 10
#define CONSTRAINED_SNAPPING_DISTANCE 0.5
#define MAX_CONSTRAINED_SNAPPING_DISTANCE 10.0
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintHierarchy.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Classes
ConstraintHierarchy.h File Reference
#include <helpers/XercesXMLUtils.h>
#include <vector>
#include <string>

Go to the source code of this file.

Classes

class ConstraintHierarchyMember
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/PolygonUtils.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
Namespaces | Functions
PolygonUtils.h File Reference
#include <vector>
#include <osg/Vec3>
#include <osg/Matrix>

Go to the source code of this file.

Namespaces

namespace APConstrainedMovement

Functions

float | APConstrainedMovement::area (osg::Vec3 &point1, osg::Vec3 &point2, osg::Vec3 &point3)
osg::Vec3 | APConstrainedMovement::centroid (Vecs3 polygon)
int | APConstrainedMovement::orientation (float x1, float y1, float x2, float y2, float px, float py)
bool | APConstrainedMovement::convexPolygon (Vecs3 polygon)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt Directory Reference

  • include
  • vreckoAP
  • DynamicArt
DynamicArt Directory Reference

Files

file | AP_DynamicArt.h [code]
file | Attractor.h [code]
file | Brush.h [code]
file | BrushStroke.h [code]
file | ColorGenAdapter.h [code]
file | ComputeStrategy.h [code]
file | ComputeThread.h [code]
file | Configuration.h [code]
file | Controller.h [code]
file | Ctrl_Attractor.h [code]
file | Ctrl_FreeHandPainting.h [code]
file | Ctrl_MotionVisualization.h [code]
file | Ctrl_PerlinLines.h [code]
file | Ctrl_PolyhedraSculptures.h [code]
file | Ctrl_StringSculptures.h [code]
file | DAEnvironment.h [code]
file | DATool.h [code]
file | DiameterGenAdapter.h [code]
file | Hook.h [code]
file | HookManager.h [code]
file | Hoop.h [code]
file | HoopShape.h [code]
file | JuliaAttractor.h [code]
file | Modes.h [code]
file | MotionTrail.h [code]
file | NullAttractor.h [code]
file | OrdinaryAttractor.h [code]
file | Parameters.h [code]
file | ParticleSystem.h [code]
file | Pattern.h [code]
file | PatternGeode.h [code]
file | PerlinLines.h [code]
file | PerlinLinesTools.h [code]
file | PhysXManager.h [code]
file | PoA.h [code]
file | PolyhedraSculpture.h [code]
file | PS_Component.h [code]
file | PS_emptyClass.h [code]
file | PS_Face.h [code]
file | PS_FacePlane.h [code]
file | PS_FlatShape.h [code]
file | PS_Layer.h [code]
file | PS_Polyhedron.h [code]
file | PS_Symmetry.h [code]
file | RotationFrameGenAdapter.h [code]
file | SectorColorGen.h [code]
file | SectorManager.h [code]
file | SimpleBox.h [code]
file | SplineAdapter.h [code]
file | TimeLineSpline.h [code]
file | Timing.h [code]
file | ToolBrush.h [code]
file | ToolEraser.h [code]
file | ToolHook.h [code]
file | ToolMagicWand.h [code]
file | ToolRotation.h [code]
file | ToolSelector.h [code]
file | ToolSlice.h [code]
file | ToolTongs.h [code]
file | Utils.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/AP_DynamicArt.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Macros | Functions
AP_DynamicArt.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "DAEnvironment.h"
#include "Ctrl_FreeHandPainting.h"
#include "Ctrl_MotionVisualization.h"
#include "Ctrl_Attractor.h"
#include "Ctrl_PerlinLines.h"
#include "ToolBrush.h"
#include "ToolTongs.h"
#include "ToolEraser.h"
#include "ToolMagicWand.h"
#include "ToolSlice.h"
#include "ToolSelector.h"
#include "ToolRotation.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | getAbilityList (void)
Ability AP_EXPORT * | getAbilityInstance (const char *_name)
void AP_EXPORT | initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

Ability AP_EXPORT* getAbilityInstance ( const char * _name )
const char AP_EXPORT** getAbilityList ( void )
void AP_EXPORT initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Attractor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs | Enumerations
Attractor.h File Reference
#include "poa.h"
#include "Parameters.h"
#include "Utils.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Attractor

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::vector< std::string > | APDYNAMICART::AttractorNames
typedef osg::ref_ptr< Attractor > | APDYNAMICART::AttractorPtr

Enumerations

enum APDYNAMICART::AttractorRenderingType { APDYNAMICART::ATT__RENDER_POINTS = 1, APDYNAMICART::ATT__RENDER_LINES, APDYNAMICART::ATT__RENDER_TRIANGLES }
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Brush.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Brush.h File Reference
#include "ColorGenAdapter.h"
#include "DiameterGenAdapter.h"
#include "SplineAdapter.h"
#include "RotationFrameGenAdapter.h"
#include <osg\Referenced>

Go to the source code of this file.

Classes

class APDYNAMICART::Brush
Encapsulate data and functionality of sweepSurface related factories and adapters. More...

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< Brush > APDYNAMICART::BrushPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/BrushStroke.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
BrushStroke.h File Reference
#include "PoA.h"
#include "ColorGen.h"
#include "SweepSurface.h"
#include "ColorGenAdapter.h"
#include "DiameterGenAdapter.h"
#include "SplineAdapter.h"
#include "InterpolatedSpline.h"
#include "Utils.h"
#include "Brush.h"
#include "TimeLineSpline.h"
#include <vreckoUtils\HighlightCallback.h>

Go to the source code of this file.

Classes

class APDYNAMICART::BrushStroke
Store data about and can render one brush stroke. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ColorGenAdapter.h File Reference
#include <osg\Referenced>
#include "Utils.h"
#include "ConstantColorGen.h"
#include "GradientColorGen.h"
#include "SectorColorGen.h"
#include "types.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::ColorGenAdapter
class | APDYNAMICART::ConstantColorAdapter
class | APDYNAMICART::GradientColorAdapter
class | APDYNAMICART::ColorGenFactory

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
ComputeStrategy.h File Reference
#include <osg\Vec3>
#include <string>
#include <vector>
#include <osg\Referenced>
#include "Parameters.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::IComputeStrategy
class | APDYNAMICART::NullStrategy
class | APDYNAMICART::LorenzStrategy
class | APDYNAMICART::Lorenz84Strategy
class | APDYNAMICART::PickoverStrategy
class | APDYNAMICART::RosslerStrategy
class | APDYNAMICART::PolynomialStrategy
class | APDYNAMICART::IkedaStrategy

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< IComputeStrategy > 		APDYNAMICART::IComputeStrategyPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeThread.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
ComputeThread.h File Reference
#include <OpenThreads/Thread>
#include "ComputeStrategy.h"
#include "Utils.h"
#include <random>

Go to the source code of this file.

Classes

struct | APDYNAMICART::InitSettings
class | APDYNAMICART::ComputeThread

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< ComputeThread > 		APDYNAMICART::ComputeThreadPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Configuration.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Configuration.h File Reference
#include "ShapeGenerator.h"

Go to the source code of this file.

Classes

struct APDYNAMICART::Configuration

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Controller.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Controller.h File Reference
#include "PoA.h"
#include "DATool.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Controller

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::vector< DATool * > APDYNAMICART::DATools
virtual PoA controller More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_Attractor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Ctrl_Attractor.h File Reference
#include "Controller.h"
#include "Attractor.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_Attractor

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_FreeHandPainting.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Macros | Enumerations
Ctrl_FreeHandPainting.h File Reference
#include "Controller.h"
#include "BrushStroke.h"
#include "ToolBrush.h"
#include "ToolTongs.h"
#include "ToolEraser.h"
#include "Brush.h"
#include "..\GUI\Slider.h"
#include "..\GUI\Icon.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_FreeHandPainting
controller of Brush Stroke PoA More...

Namespaces

namespace APDYNAMICART

Macros

#define PLAYBACK_LAG_DURATION 0.5;

Enumerations

enum APDYNAMICART::PlaybackType { APDYNAMICART::FHP__REAL_TIME = 1, APDYNAMICART::FHP__LAG_SKIP }

Macro Definition Documentation

#define PLAYBACK_LAG_DURATION 0.5;
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_MotionVisualization.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Ctrl_MotionVisualization.h File Reference
#include "Controller.h"
#include "Ctrl_FreeHandPainting.h"
#include "MotionTrail.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_MotionVisualization
controller of Motion Trail PoAs More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PerlinLines.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Ctrl_PerlinLines.h File Reference
#include "Controller.h"
#include "PerlinLines.h"
#include "PerlinLinesTools.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_PerlinLines

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Ctrl_PolyhedraSculptures.h File Reference
#include "Controller.h"
#include "Utils.h"
#include "PolyhedraSculpture.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_PolyhedraSculptures

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_StringSculptures.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Ctrl_StringSculptures.h File Reference
#include "Controller.h"
#include "Utils.h"
#include "Modes.h"
#include "Pattern.h"
#include "PatternGeode.h"
#include "ToolSelector.h"
#include "PhysXManager.h"
#include "ToolHook.h"
#include "DATool.h"
#include "ConstantDiameterGen.h"
#include "ToolBrush.h"

Go to the source code of this file.

Classes

class APDYNAMICART::Ctrl_StringSculptures

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DAEnvironment.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
DAEnvironment.h File Reference
#include <vector>
#include "DATool.h"
#include "ToolTongs.h"
#include "PoA.h"
#include "PoB.h"
#include "Controller.h"
#include "../../vreckoAP/LightsEditor/Lights.h"

Go to the source code of this file.

Classes

class APDYNAMICART::DAEnvironment
Dynamic Art Environment class - base class of Dynamic Art plugin. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DATool.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Enumerations
DATool.h File Reference
#include "PoA.h"
#include <vreckoUtils\Observer.h>

Go to the source code of this file.

Classes

class APDYNAMICART::DATool
Virtual class defining basis of all tools used in Dynamic Art. More...

Namespaces

namespace APDYNAMICART

Enumerations

enum APDYNAMICART::DAToolType {
APDYNAMICART::TOOL__BRUSH = 1, APDYNAMICART::TOOL__TONGS, APDYNAMICART::TOOL__ERASER, APDYNAMICART::TOOL__SLICE,
APDYNAMICART::TOOL__MAGICWAND, APDYNAMICART::TOOL__NEST, APDYNAMICART::TOOL__MAGNET, APDYNAMICART::TOOL__PERLIN_LINES_CONTROLLER,
APDYNAMICART::TOOL__SELECTOR, APDYNAMICART::TOOL__ROTATION, APDYNAMICART::TOOL__HOOK
}
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DiameterGenAdapter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
DiameterGenAdapter.h File Reference
#include <osg\Referenced>
#include "Utils.h"
#include "types.h"
#include "DiameterGen.h"
#include <xercesc\dom\DOMImplementation.hpp>
#include "ConstantDiameterGen.h"
#include "GradientDiameterGen.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::ConstantDiamAdapter
class | APDYNAMICART::GradientDiamAdapter
class | APDYNAMICART::DiameterGenFactory

Namespaces

namespace APDYNAMICART

Typedefs

typedef PoAAdapter< DiameterGen > APDYNAMICART::DiameterGenAdapter
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hook.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
Hook.h File Reference
#include "poa.h"
#include <vreckoUtils\HighlightCallback.h>
#include <vreckoUtils\Menu.h>
#include "PhysXManager.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::HookObject
class | APDYNAMICART::HoopTrackerCallback

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HookManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
HookManager.h File Reference
#include "Hook.h"

Go to the source code of this file.

Classes

class APDYNAMICART::HookManager
Hook Manager. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hoop.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Hoop.h File Reference
#include "poa.h"
#include "SweepSurface.h"
#include "SectorColorGen.h"
#include "ConstantDiameterGen.h"
#include "HoopShape.h"
#include <NxActor.h>
#include <vreckoUtils\HighlightCallback.h>

Go to the source code of this file.

Classes

class APDYNAMICART::Hoop

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< Hoop > APDYNAMICART::HoopPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Macros | Typedefs
HoopShape.h File Reference
#include <osg\Referenced>
#include <string>
#include <xercesc\util\XercesDefs.hpp>
#include "Spline.h"
#include "Utils.h"
#include "LinearInterpolator.h"
#include "InterpolatedSpline.h"
#include "SampledSpline.h"
#include "types.h"
#include "RegularPolygonSpline.h"
#include "CatmullRomInterpolator.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::HoopShape
class | APDYNAMICART::NullHoopShape
class | APDYNAMICART::Rectangle
class | APDYNAMICART::Ellipse
class | APDYNAMICART::RegularPolygon
class | APDYNAMICART::Line
class | APDYNAMICART::ElongatedCircle
class | APDYNAMICART::Painted
class | APDYNAMICART::ShapeFactory

Namespaces

namespace APDYNAMICART

Macros

#define META_HoopShapeObject(name, menuName)

Typedefs

typedef osg::ref_ptr< HoopShape > APDYNAMICART::HoopShapePtr

Macro Definition Documentation

#define META_HoopShapeObject | ( | name,
 |  | menuName
 | ) |
Value:
name(); \
name(const name& val); \
virtual void createMenu( MenuPtr parent ) const; \
virtual bool sliderChanged( const char* sliderID, float sliderPos ); \
virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode ); \
virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ); \
virtual osg::ref_ptr<HoopShape> clone() { return new name(*this); } \
virtual std::string getName() { return (menuName); }

Macro for HoopShape objects

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/JuliaAttractor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
JuliaAttractor.h File Reference
#include "Attractor.h"

Go to the source code of this file.

Classes

class APDYNAMICART::JuliaAttractor

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Modes.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Modes.h File Reference
#include <osg\Referenced>
#include <osg\ref_ptr>
#include "Controller.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::Mode
class | APDYNAMICART::Basic
class | APDYNAMICART::Advanced

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< Mode > APDYNAMICART::ModePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/MotionTrail.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
MotionTrail.h File Reference
#include "BrushStroke.h"

Go to the source code of this file.

Classes

class APDYNAMICART::MotionTrail

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/NullAttractor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
NullAttractor.h File Reference
#include "Attractor.h"

Go to the source code of this file.

Classes

class APDYNAMICART::NullAttractor

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/OrdinaryAttractor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
OrdinaryAttractor.h File Reference
#include "Attractor.h"
#include "ComputeStrategy.h"
#include "Utils.h"
#include "ComputeThread.h"

Go to the source code of this file.

Classes

class APDYNAMICART::OrdinaryAttractor

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Parameters.h File Reference
#include <string>

Go to the source code of this file.

Classes

struct | APDYNAMICART::Parameter
class | APDYNAMICART::IParameters
class | APDYNAMICART::NullParameters
class | APDYNAMICART::LorenzParameters
class | APDYNAMICART::Lorenz84Parameters
class | APDYNAMICART::JuliaParameters
class | APDYNAMICART::PickoverParameters
class | APDYNAMICART::RosslerParameters
class | APDYNAMICART::PolynomialParameters
class | APDYNAMICART::IkedaParameters

Namespaces

namespace APDYNAMICART

Typedefs

typedef struct
APDYNAMICART::Parameter 		APDYNAMICART::Parameter
typedef std::vector< Parameter > | APDYNAMICART::Parameters
typedef osg::ref_ptr< IParameters > | APDYNAMICART::IParametersPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ParticleSystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Functions
ParticleSystem.h File Reference

Go to the source code of this file.

Classes

struct APDYNAMICART::ParticleSystemParameters

Namespaces

namespace APDYNAMICART

Functions

void APDYNAMICART::createParticleSystem (osg::Group *emmitterParent, osg::Group *particleSystemParent, ParticleSystemParameters *params)
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
Pattern.h File Reference
#include "types.h"
#include "Utils.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::Pattern
class | APDYNAMICART::PatternBase
class | APDYNAMICART::PatternFactory
class | APDYNAMICART::NullPattern
class | APDYNAMICART::AcrossPattern
class | APDYNAMICART::CrissCrossPattern
class | APDYNAMICART::DoublePattern
class | APDYNAMICART::HyperbolicPattern
class | APDYNAMICART::TopPattern
class | APDYNAMICART::TopReversePattern
class | APDYNAMICART::StandardPattern
class | APDYNAMICART::SplitPattern
class | APDYNAMICART::SplitReversePattern

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< PatternBase > | APDYNAMICART::PatternPtr
typedef std::vector< PatternPtr > | APDYNAMICART::Patterns
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PatternGeode.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PatternGeode.h File Reference
#include <osg/Geode>
#include "Pattern.h"
#include <osg/NodeCallback>
#include <osg/LineWidth>
#include <osg/CopyOp>

Go to the source code of this file.

Classes

class APDYNAMICART::PatternsGeode

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PatternsGeode > 		APDYNAMICART::PatternGeodePtr
typedef std::vector
< PatternGeodePtr > 		APDYNAMICART::PatternGeodeList
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLines.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PerlinLines.h File Reference
#include "Controller.h"
#include "poa.h"
#include <osg/LineWidth>

Go to the source code of this file.

Classes

class APDYNAMICART::PerlinLines

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::vector
< osg::ref_ptr< osg::Sphere > > 		APDYNAMICART::Spheres
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLinesTools.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
PerlinLinesTools.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "SimpleBox.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::PLNestTool
class | APDYNAMICART::PLMagnetTool
class | APDYNAMICART::PLControllerTool

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PhysXManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
PhysXManager.h File Reference
#include <NxPhysics.h>
#include "SweepSurface.h"
#include "Utils.h"
#include "Hoop.h"
#include <Windows.h>
#include <ctime>
#include "DAEnvironment.h"

Go to the source code of this file.

Classes

struct | APDYNAMICART::SimulationParameters
class | APDYNAMICART::PhysXManager

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PoA.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs | Enumerations
PoA.h File Reference

Go to the source code of this file.

Classes

class APDYNAMICART::PoA
PoA (Piece of Art) More...

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< PoA > APDYNAMICART::ref_ptr_PoA
type: reference pointer to PoA More...

Enumerations

enum APDYNAMICART::PoAType {
APDYNAMICART::POA__DUMMY = -1, APDYNAMICART::POA__BRUSH_STROKE = 1, APDYNAMICART::POA__MOTION_TRAIL, APDYNAMICART::POA__CHAOTIC_ATTRACTOR,
APDYNAMICART::POA__PERLIN_LINE, APDYNAMICART::POA__STRING_SCULPTURES, APDYNAMICART::POA__POLYHEDRA_SCULPTURES
}
Types of PoA. More...
enum APDYNAMICART::PoAUpdateType {
APDYNAMICART::POA__UPDATE_NONE = 0, APDYNAMICART::POA__UPDATE_DELETE = 1, APDYNAMICART::POA__UPDATE_RENDER, APDYNAMICART::POA__UPDATE_COLOR_CHANGE,
APDYNAMICART::POA__UPDATE_DYNAMIC, APDYNAMICART::POA__MT_SAMPLING
}
Types of updates of PoA. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PolyhedraSculpture.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PolyhedraSculpture.h File Reference
#include "poa.h"
#include "PS_Layer.h"

Go to the source code of this file.

Classes

class APDYNAMICART::PolyhedraSculpture

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PolyhedraSculpture > 		APDYNAMICART::PolyhedraSculpturePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Component.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_Component.h File Reference
#include "PS_FlatShape.h"

Go to the source code of this file.

Classes

class APDYNAMICART::PS_Component

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PS_Component > 		APDYNAMICART::PS_ComponentPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_emptyClass.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_emptyClass.h File Reference

Go to the source code of this file.

Classes

class APDYNAMICART::PS_Layer

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< PS_Layer > APDYNAMICART::PS_LayerPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Face.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_Face.h File Reference
#include "PS_FlatShape.h"
#include <vreckoUtils\HighlightCallback.h>
#include "Utils.h"

Go to the source code of this file.

Classes

class APDYNAMICART::PS_Face

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< PS_Face > APDYNAMICART::PS_FacePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FacePlane.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_FacePlane.h File Reference
#include "PS_Face.h"

Go to the source code of this file.

Classes

class APDYNAMICART::PS_FacePlane

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PS_FacePlane > 		APDYNAMICART::PS_FacePlanePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FlatShape.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_FlatShape.h File Reference

Go to the source code of this file.

Classes

class APDYNAMICART::PS_FlatShape

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PS_FlatShape > 		APDYNAMICART::PS_FlatShapePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Layer.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
PS_Layer.h File Reference
#include "PS_Polyhedron.h"
#include "PS_Component.h"

Go to the source code of this file.

Classes

class APDYNAMICART::PS_Layer

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Polyhedron.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
PS_Polyhedron.h File Reference
#include <vreckoAP\DynamicArt\Utils.h>
#include "PS_FacePlane.h"
#include "PS_Face.h"
#include "PS_Component.h"
#include "PS_Symmetry.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::PS_Polyhedron
class | APDYNAMICART::PolyhedronFactory

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< PS_Polyhedron > 		APDYNAMICART::PS_PolyhedronPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Symmetry.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
PS_Symmetry.h File Reference
#include <osg/Geometry>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <fstream>

Go to the source code of this file.

Classes

struct | APDYNAMICART::symmetry_axis
struct | APDYNAMICART::symmetry_pair
class | APDYNAMICART::PS_Symmetry

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
RotationFrameGenAdapter.h File Reference
#include <osg\Referenced>
#include "Utils.h"
#include "RMFrame.h"
#include "HandFrame.h"
#include "AxisRotationFrame.h"
#include "types.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::RotationFrameAdapter
class | APDYNAMICART::RMFrameAdapter
class | APDYNAMICART::AxisFrameAdapter
class | APDYNAMICART::HandFrameAdapter
class | APDYNAMICART::RotationFrameFactory

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorColorGen.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Typedefs
SectorColorGen.h File Reference
#include "ColorGen.h"
#include <osg\BoundsChecking>
#include <osg\BufferObject>

Go to the source code of this file.

Classes

struct | Sector
class | SectorColorGen

Typedefs

typedef osg::ref_ptr< Sector > | SectorPtr
typedef std::vector< SectorPtr > | SectorArray
typedef osg::ref_ptr
< SectorColorGen > 		SectorColorGenPtr

Typedef Documentation

typedef std::vector<SectorPtr> SectorArray
typedef osg::ref_ptr<SectorColorGen> SectorColorGenPtr
typedef osg::ref_ptr<Sector> SectorPtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
SectorManager.h File Reference
#include "Pattern.h"
#include "Hoop.h"
#include "SectorColorGen.h"

Go to the source code of this file.

Classes

struct | APDYNAMICART::SectorInfo
class | APDYNAMICART::SectorManager
Sector Manager. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SimpleBox.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
SimpleBox.h File Reference
#include <osg/Geometry>
#include <osg/StateSet>
#include <osg/BlendEquation>
#include <osg/Depth>

Go to the source code of this file.

Classes

class APDYNAMICART::SimpleBox
Simple class for creating boxes. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
SplineAdapter.h File Reference
#include <osg\Referenced>
#include "Utils.h"
#include "types.h"
#include "Spline.h"
#include "RegularPolygonSpline.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::SplineAdapter
class | APDYNAMICART::RoundedSplineAdapter
class | APDYNAMICART::RectangularSplineAdapter
class | APDYNAMICART::WaveSplineAdapter
class | APDYNAMICART::SplineFactory

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/TimeLineSpline.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Macros | Typedefs
TimeLineSpline.h File Reference
#include "Spline.h"

Go to the source code of this file.

Classes

class TimeLineSpline

Macros

#define | TIMELINE__ZERO_TIME 0.0
#define | TIMELINE__FULLY_VISIBLE -1.0

Typedefs

typedef osg::ref_ptr
< TimeLineSpline > 		TimeLineSplinePtr

Macro Definition Documentation

#define TIMELINE__FULLY_VISIBLE -1.0
#define TIMELINE__ZERO_TIME 0.0

Typedef Documentation

typedef osg::ref_ptr<TimeLineSpline> TimeLineSplinePtr
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Timing.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Macros | Functions
Timing.h File Reference
#include <windows.h>

Go to the source code of this file.

Macros

#define NOMINMAX

Functions

float | getCurrentTime ()
float | getElapsedTime ()

Macro Definition Documentation

#define NOMINMAX

Function Documentation

float getCurrentTime ( )
float getElapsedTime ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolBrush.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
ToolBrush.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "SimpleBox.h"
#include "Brush.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolBrush
Brush tool. More...

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr< SimpleBox > | APDYNAMICART::ref_ptr_SimpleBox
typedef osg::ref_ptr< ToolBrush > | APDYNAMICART::ref_ptr_ToolBrush
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolEraser.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ToolEraser.h File Reference
#include "DATool.h"
#include "PoA.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolEraser

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolHook.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
ToolHook.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "Hoop.h"
#include "Hook.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolHook

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::pair< HoopPtr,
osg::ref_ptr< HookObject > > 		APDYNAMICART::Hook
Hook tool. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolMagicWand.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ToolMagicWand.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "OrdinaryAttractor.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolMagicWand

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolRotation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ToolRotation.h File Reference
#include "DATool.h"
#include "PoA.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolRotation
Rotation tool. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSelector.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs | Variables
ToolSelector.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "Hoop.h"
#include "SectorManager.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolSelector

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< ToolSelector > 		APDYNAMICART::ToolSelectorPtr

Variables

const unsigned int APDYNAMICART::NOT_FOUND = -1
Selector tool. More...
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSlice.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ToolSlice.h File Reference
#include "DATool.h"
#include "PoA.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolSlice

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolTongs.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces
ToolTongs.h File Reference
#include "DATool.h"
#include "PoA.h"

Go to the source code of this file.

Classes

class APDYNAMICART::ToolTongs

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Macros | Typedefs
Utils.h File Reference
#include <osg/io_utils>
#include "DATool.h"
#include "Spline.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::Stroke
class | APDYNAMICART::PoAAdapter< T >
class | APDYNAMICART::AdapterFactory< T >
class | APDYNAMICART::Utils
struct | APDYNAMICART::Limits
class | APDYNAMICART::colorGradient
class | APDYNAMICART::PoAState

Namespaces

namespace APDYNAMICART

Macros

#define | err(msg) std::cerr << __FUNCTION__<< " - " << msg << std::endl;
#define | dbgAtt(msg)
debug macro for Attractors module More...
#define | dbgPS(msg) std::cout << msg << std::endl;
debug macro for Polyhedra Sculptures module More...

Typedefs

typedef osg::ref_ptr
< osg::UIntArray > 		APDYNAMICART::UIntArrayPtr
typedef osg::ref_ptr
< osg::Vec3Array > 		APDYNAMICART::Vec3ArrayPtr
typedef osg::ref_ptr
< osg::Vec4Array > 		APDYNAMICART::Vec4ArrayPtr
typedef osg::ref_ptr< osg::Geode > APDYNAMICART::GeodePtr
typedef osg::ref_ptr
< osg::Geometry > 		APDYNAMICART::GeometryPtr
typedef osg::ref_ptr
< vreckoUtils::Menu > 		APDYNAMICART::MenuPtr
typedef osg::ref_ptr
< vreckoUtils::MenuRoot > 		APDYNAMICART::MenuRootPtr
typedef osg::ref_ptr
< vreckoUtils::IMenuComponent > 		APDYNAMICART::IMenuComponentPtr
typedef osg::ref_ptr
< std::vector< osg::Vec4 > > 		APDYNAMICART::ColorList

Macro Definition Documentation

#define dbgAtt ( msg )

debug macro for Attractors module

#define dbgPS ( msg ) std::cout << msg << std::endl;

debug macro for Polyhedra Sculptures module

#define err ( msg ) std::cerr << __FUNCTION__<< " - " << msg << std::endl;

Macros for errors and debugging

Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController Directory Reference

  • include
  • vreckoAP
  • EditorController
EditorController Directory Reference

Files

file | AbilityMapper.h [code]
file | AP_EditorController.h [code]
file | ControllableAbility.h [code]
file | EditorController.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
Classes | Namespaces
AbilityMapper.h File Reference
#include "ControllableAbility.h"
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class | APEditorController::AbilityMapper
struct | APEditorController::AbilityMapper::BUTTON_MAPPING
struct | APEditorController::AbilityMapper::MAPPING
class | APEditorController::AbilityMapper::MessageMapping

Namespaces

namespace APEditorController
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AP_EditorController.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
Functions
AP_EditorController.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
AP_EXPORT void | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
AP_EXPORT void initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
Classes | Namespaces | Macros | Typedefs
ControllableAbility.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/IOPins.h>
#include <osg/Quat>
#include <osg/Node>

Go to the source code of this file.

Classes

struct | vrecko::CABUTTONEVENT
class | vrecko::MessageCAButtonEvent
struct | vrecko::CAINFO__VER1
struct | vrecko::CAINFO__VER2
class | vrecko::ControllableAbility
class | vrecko::ControllableAbility::MessageCAINFO

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | EDITORCONTROLLER_IMP_EXP __declspec(dllimport)
#define | POINTERPOS_REQUEST_NAME "PointerPosition"
#define | POINTERROT_REQUEST_NAME "PointerRotation"
#define | POINTERPOS_RAW_REQUEST_NAME "PointerPositionRaw"
#define | POINTERROT_RAW_REQUEST_NAME "PointerRotationRaw"
#define | SELECTIONID_REQUEST_NAME "SelectionID"
#define | SELECTIONPATH_REQUEST_NAME "SelectionPath"
#define | CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS 0x00000001
#define | CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT 0x00000002
#define | CAINFO_FLAGS_ALL_ACTIVEPOINTER_BUTTONS 0x00000004
#define | CAINFO_FLAGS_ALL_OTHERPOINTER_BUTTONS 0x00000008
#define | CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUTPUTS 0x00000010
#define | CAINFO_FLAGS_NO_AUTO_DEACTIVATE 0x80000000
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT 0
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK 0x00000007
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE 0x00000000
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE 0x00000001
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW 0x00000002
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE 0x00000003
#define | CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW 0x00000004
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT 3
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR__MASK 0x00000038
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR_DONTCARE (CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR_SHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR_HIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCEHIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define | CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCESHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define | IS_CAINFO_VER(info, ver) ((info).dwSize >= sizeof(CAINFO__VER##ver))

Typedefs

typedef CAINFO__VER2 vrecko::CAINFO

Macro Definition Documentation

#define CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK 0x00000007
#define CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT 0
#define CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE 0x00000000
#define CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE 0x00000003
#define CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW 0x00000004
#define CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE 0x00000001
#define CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW 0x00000002
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR__MASK 0x00000038
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT 3
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR_DONTCARE (CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCEHIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCESHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR_HIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define CAINFO_AFLAGS_SELSHOW_OTHERPTR_SHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
#define CAINFO_FLAGS_ALL_ACTIVEPOINTER_BUTTONS 0x00000004

The ability wants to control all buttons belonging to the active pointer (hand). Every status change will be delivered to this ability and no other ability could be activated using these buttons.

#define CAINFO_FLAGS_ALL_OTHERPOINTER_BUTTONS 0x00000008

The ability wants to control all buttons belonging to the other pointers (hand[s]). Every status change will be delivered to this ability and no other ability could be activated using these buttons.

#define CAINFO_FLAGS_NO_AUTO_DEACTIVATE 0x80000000

The deactivate() function won't be called upon mouse button release. Useful if your ability is using menus.

#define CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUTPUTS 0x00000010

[POINTERPOS_REQUEST_NAME_RAW] and [POINTERROT_REQUEST_NAME_RAW] RequestOuputs will be created automatically. You can then use the requestPointerLocRaw() to get the position/rotation of the pointer in the current frame. The position/rotation will be the "raw" pos/rot, directly from the pointers, not including the view transformation.

#define CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS 0x00000001

[POINTERPOS_REQUEST_NAME] and [POINTERROT_REQUEST_NAME] RequestOuputs will be created automatically. You can then use the requestPointerLoc() to get the position/rotation of the pointer in the current frame. The position/rotation will be the "real" pos/rot, including the view transformation. To get the "raw" data use CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS_RAW.

#define CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT 0x00000002

[SELECTIONID_REQUEST_NAME] + [SELECTIONPATH_REQUEST_NAME] RequestOuputs will be created. You will have to specify it, if you need to retrieve currently selected object. You can then use the requestSelectionID() and/or requestSelectionPath() to get the selection in the current frame.

#define EDITORCONTROLLER_IMP_EXP __declspec(dllimport)
#define IS_CAINFO_VER | ( | info,
 |  | ver
 | ) | ((info).dwSize >= sizeof(CAINFO__VER##ver))

Is the given CAINFO instance AT LEAST version [ver]?

#define POINTERPOS_RAW_REQUEST_NAME "PointerPositionRaw"
#define POINTERPOS_REQUEST_NAME "PointerPosition"
#define POINTERROT_RAW_REQUEST_NAME "PointerRotationRaw"
#define POINTERROT_REQUEST_NAME "PointerRotation"
#define SELECTIONID_REQUEST_NAME "SelectionID"
#define SELECTIONPATH_REQUEST_NAME "SelectionPath"
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/EditorController.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
Classes | Namespaces
EditorController.h File Reference
#include <vrecko/Ability.h>
#include <osg/Quat>
#include "ControllableAbility.h"
#include "AbilityMapper.h"

Go to the source code of this file.

Classes

class | APEditorController::EditorController
class | APEditorController::EditorController::ECPOINTERBUTTONINFO
class | APEditorController::EditorController::ECPOINTERINFO

Namespaces

namespace APEditorController
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities Directory Reference

  • include
  • vreckoAP
  • EditorQAbilities
EditorQAbilities Directory Reference

Files

file | AbilityEditor.h [code]
file | AnimatorEditor.h [code]
file | AP_EditorQAbilities.h [code]
file | AvatarMovement.h [code]
file | ObjectAdd.h [code]
file | ObjectDelete.h [code]
file | ObjectMovement.h [code]
file | SceneSave.h [code]
file | SimpleObjectMovement.h [code]
file | UseTrigger.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AbilityEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
AbilityEditor.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <helpers/DynamicArray.h>
#include "../ObjectUtils/ConnectionViz.h"

Go to the source code of this file.

Classes

class | APEditorQAbilities::AbilityEditor
class | APEditorQAbilities::AbilityEditor::AllowedAbility

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AnimatorEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
AnimatorEditor.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include "../ObjectUtils/Animator.h"

Go to the source code of this file.

Classes

class APEditorQAbilities::AnimatorEditor

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AP_EditorQAbilities.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Functions
AP_EditorQAbilities.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
AP_EXPORT void | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
AP_EXPORT void initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AvatarMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
AvatarMovement.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/Ability.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class APEditorQAbilities::AvatarMovement

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectAdd.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
ObjectAdd.h File Reference
#include "../EditorController/ControllableAbility.h"

Go to the source code of this file.

Classes

class APEditorQAbilities::ObjectAdd

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectDelete.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
ObjectDelete.h File Reference
#include "../EditorController/ControllableAbility.h"

Go to the source code of this file.

Classes

class APEditorQAbilities::ObjectDelete

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
ObjectMovement.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <helpers/DynamicArray.h>
#include <osg/Group>
#include <osg/ShapeDrawable>
#include <osg/Geode>

Go to the source code of this file.

Classes

class | APEditorQAbilities::ObjectMovement
class | APEditorQAbilities::ObjectMovement::SnapBox
struct | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SceneSave.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
SceneSave.h File Reference
#include "../EditorController/ControllableAbility.h"

Go to the source code of this file.

Classes

class APEditorQAbilities::SceneSave

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SimpleObjectMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
SimpleObjectMovement.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APEditorQAbilities::SimpleObjectMovement

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/UseTrigger.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
UseTrigger.h File Reference
#include "../EditorController/ControllableAbility.h"
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APEditorQAbilities::UseTrigger

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor Directory Reference

  • include
  • vreckoAP
  • FFDEditor
FFDEditor Directory Reference

Files

file | AP_FFDEditor.h [code]
file | EditorLogic.h [code]
file | GeometryLoader.h [code]
file | GeometryLoaderBase.h [code]
file | Grid.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/AP_FFDEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Functions
AP_FFDEditor.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | FFDEditor_getPluginDescription ()
AP_EXPORT const char ** | FFDEditor_getAbilityList ()
AP_EXPORT const char * | FFDEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | FFDEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | FFDEditor_setAbilitiesParameters ()
void AP_EXPORT | FFDEditor_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* FFDEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* FFDEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** FFDEditor_getAbilityList ( )
AP_EXPORT const char* FFDEditor_getPluginDescription ( )
void AP_EXPORT FFDEditor_initializeAttributesDescription ( )
AP_EXPORT void FFDEditor_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/EditorLogic.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Classes | Namespaces
EditorLogic.h File Reference
#include <vrecko/Ability.h>
#include "GeometryLoader.h"
#include "Grid.h"
#include "../EditorController/ControllableAbility.h"

Go to the source code of this file.

Classes

class APFFDEditor::EditorLogic

Namespaces

namespace APFFDEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoader.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Classes | Namespaces
GeometryLoader.h File Reference
#include <vrecko/Ability.h>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APFFDEditor::GeometryLoader
struct | APFFDEditor::GeometryLoader::Geometry

Namespaces

namespace APFFDEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoaderBase.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Classes | Namespaces
GeometryLoaderBase.h File Reference
#include <vrecko/Ability.h>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APFFDEditor::GeometryLoaderBase
struct | APFFDEditor::GeometryLoaderBase::VertexBase
struct | APFFDEditor::GeometryLoaderBase::FaceBase

Namespaces

namespace APFFDEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/Grid.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Classes | Namespaces
Grid.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APFFDEditor::Grid
struct | APFFDEditor::Grid::ControlPoint
struct | APFFDEditor::Grid::Edge

Namespaces

namespace APFFDEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter Directory Reference

  • include
  • vreckoAP
  • Filter
Filter Directory Reference

Files

file | AP_Filter.h [code]
file | Linear.h [code]
file | PosNoiseRemover.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/AP_Filter.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
Macros | Functions
AP_Filter.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "Linear.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

AP_EXPORT const char ** | getAbilityList (void)
AP_EXPORT Ability * | getAbilityInstance (const char *_name)
AP_EXPORT const char * | getAbilityDescription (const char *name)
AP_EXPORT const char * | getPluginDescription (void)
AP_EXPORT void | initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * name )
AP_EXPORT Ability* getAbilityInstance ( const char * _name )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/Linear.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
Classes | Namespaces
Linear.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec2>
#include <osg/Vec4>

Go to the source code of this file.

Classes

class Filter::Linear

Namespaces

namespace Filter
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/PosNoiseRemover.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
Classes | Namespaces
PosNoiseRemover.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/IOPins.h>
#include <helpers/DynamicArray.h>

Go to the source code of this file.

Classes

class | Filter::PosNoiseRemover
struct | Filter::PosNoiseRemover::SAMPLE

Namespaces

namespace Filter
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games Directory Reference

  • include
  • vreckoAP
  • games
games Directory Reference

Files

file | AP_games.h [code]
file | ChessBoard.h [code]
file | ChessPiece.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/AP_games.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • games
Macros | Functions
AP_games.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "ChessBoard.h"
#include "ChessPiece.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | getAbilityList (void)
Ability AP_EXPORT * | getAbilityInstance (const char *_name)

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

Ability AP_EXPORT* getAbilityInstance ( const char * _name )
const char AP_EXPORT** getAbilityList ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessBoard.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • games
Classes
ChessBoard.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class | ChessBoard
struct | ChessBoard::Request
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessPiece.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • games
Classes
ChessPiece.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class ChessPiece
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden Directory Reference

  • include
  • vreckoAP
  • Garden
Garden Directory Reference

Files

file | abstract0lsystem.h [code]
file | abstractfile.h [code]
file | abstractgenerator.h [code]
file | abstractinterpret.h [code]
file | abstractklsystem.h [code]
file | abstractlsystem.h [code]
file | abstractturtle.h [code]
file | AP_Garden.h [code]
file | configuration.h [code]
file | d0lsystem.h [code]
file | hermitpipe.h [code]
file | jointedpipe.h [code]
file | loftturtle.h [code]
file | log.h [code]
file | longstring.h [code]
file | lsfile.h [code]
file | lsgeode.h [code]
file | lsobject.h [code]
file | lsystem.h [code]
file | lsystemexception.h [code]
file | lsystemgenerator.h [code]
file | movingturtle.h [code]
file | par2lsystem.h [code]
file | pard0lsystem.h [code]
file | parseablestring.h [code]
file | parstoch0lsystem.h [code]
file | query.h [code]
file | queryinterpret.h [code]
file | queryturtle.h [code]
file | randomindex.h [code]
file | randomizer.h [code]
file | rectangle.h [code]
file | rule.h [code]
file | staticstring.h [code]
file | straightpipe.h [code]
file | turtleinterpret.h [code]
file | turtlestack.h [code]
file | utils.h [code]
file | xmlfile.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstract0lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstract0lsystem.h File Reference
#include "lsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::Abstract0LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractfile.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstractfile.h File Reference
#include <string>
#include <vector>
#include <map>
#include "configuration.h"
#include "lsystemexception.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractFile

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractgenerator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstractgenerator.h File Reference
#include <string>
#include <boost/shared_ptr.hpp>
#include "parseablestring.h"
#include "abstractlsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractGenerator

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractinterpret.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstractinterpret.h File Reference
#include <vector>
#include "configuration.h"
#include "lsgeode.h"
#include "parseablestring.h"
#include "turtlestack.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractInterpret

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractklsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstractklsystem.h File Reference
#include "lsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractkLSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractlsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
abstractlsystem.h File Reference
#include "fparser/fparser.hh"
#include "longstring.h"
#include "abstractfile.h"
#include "configuration.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractLSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractturtle.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces | Enumerations | Functions
abstractturtle.h File Reference
#include "utils.h"
#include "lsgeode.h"
#include "randomizer.h"

Go to the source code of this file.

Classes

class AP_LSystem::AbstractTurtle

Namespaces

namespace AP_LSystem

Enumerations

enum AP_LSystem::InterpretErrorCodes {
AP_LSystem::LS_OK, AP_LSystem::LS_NOTIMPLEMENTED, AP_LSystem::LS_ERR_PAR_BADTYPE, AP_LSystem::LS_ERR_PAR_INVALIDCOUNT,
AP_LSystem::LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE, AP_LSystem::LS_ERR_STACK_UNKNOWN_TURTLE_TYPE, AP_LSystem::LS_ERR_STACK_NULL_LSGEODE
}

Functions

const osg::Vec3d | AP_LSystem::HeadVec (0.0, 1.0, 0.0)
Turtle head vector. More...
const osg::Vec3d | AP_LSystem::UpVec (1.0, 0.0, 0.0)
Turtle up vector. More...
const osg::Vec3d | AP_LSystem::LeftVec (0.0, 0.0, 1.0)
Turtle left vector. More...
const osg::Vec3d | AP_LSystem::Center (0.0, 0.0, 0.0)
Position of turtle. More...
const osg::Vec4d | AP_LSystem::White (1.0, 1.0, 1.0, 1.0)
White color. More...
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/AP_Garden.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Functions
AP_Garden.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | Garden_getPluginDescription ()
AP_EXPORT char ** | Garden_getAbilityList ()
AP_EXPORT const char * | Garden_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | Garden_getAbilityInstance (const char *pchName)
AP_EXPORT void | Garden_setAbilitiesParameters ()
void AP_EXPORT | Garden_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* Garden_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* Garden_getAbilityInstance ( const char * pchName )
AP_EXPORT char** Garden_getAbilityList ( )
AP_EXPORT const char* Garden_getPluginDescription ( )
void AP_EXPORT Garden_initializeAttributesDescription ( )
AP_EXPORT void Garden_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/configuration.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces | Enumerations
configuration.h File Reference
#include <sstream>
#include <map>
#include <boost/program_options.hpp>

Go to the source code of this file.

Classes

class AP_LSystem::Configuration

Namespaces

namespace AP_LSystem

Enumerations

enum AP_LSystem::LSystemCapabilities {
AP_LSystem::LS_0L = 0x00000001, AP_LSystem::LS_1LL = 0x00000002, AP_LSystem::LS_1LR = 0x00000004, AP_LSystem::LS_2L = 0x00000008,
AP_LSystem::LS_IL = 0x00000080, AP_LSystem::LS_DETERMINISTIC = 0x00000100, AP_LSystem::LS_STOCHASTIC = 0x00000200, AP_LSystem::LS_PARAMETRIC = 0x00010000
}
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/d0lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
d0lsystem.h File Reference
#include "abstract0lsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::D0LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/hermitpipe.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
hermitpipe.h File Reference
#include "straightpipe.h"

Go to the source code of this file.

Classes

class AP_LSystem::HermitPipe

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/jointedpipe.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
jointedpipe.h File Reference
#include "loftturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::JointedPipe

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/loftturtle.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
loftturtle.h File Reference
#include "movingturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::LoftTurtle

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/log.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
log.h File Reference
#include <string>
#include <sstream>
#include "windows.h"

Go to the source code of this file.

Classes

class AP_LSystem::Log

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/longstring.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
longstring.h File Reference
#include <string>
#include "utils.h"

Go to the source code of this file.

Classes

class AP_LSystem::LongString

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsfile.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
lsfile.h File Reference
#include <vector>
#include <map>
#include <string>
#include <osgDB/fstream>
#include <sstream>
#include "abstractfile.h"
#include "utils.h"
#include "lsystemexception.h"
#include "configuration.h"

Go to the source code of this file.

Classes

class AP_LSystem::LSFile

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsgeode.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces | Enumerations
lsgeode.h File Reference

Go to the source code of this file.

Classes

struct | AP_LSystem::TurtleProperties
class | AP_LSystem::LSGeode

Namespaces

namespace AP_LSystem

Enumerations

enum AP_LSystem::TurtleType {
AP_LSystem::LS_TURTLE_JOINTEDPIPE, AP_LSystem::LS_TURTLE_STRAIGHTPIPE, AP_LSystem::LS_TURTLE_HERMITPIPE, AP_LSystem::LS_TURTLE_OBJMODEL,
AP_LSystem::LS_TURTLE_RECTANGLE, AP_LSystem::LS_TURTLE_QUERY
}
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsobject.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
lsobject.h File Reference
#include "abstractgenerator.h"
#include "abstractinterpret.h"

Go to the source code of this file.

Classes

class AP_LSystem::LSObject

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
lsystem.h File Reference
#include "abstractlsystem.h"
#include "rule.h"
#include "longstring.h"

Go to the source code of this file.

Classes

class AP_LSystem::LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
lsystemexception.h File Reference
#include <exception>
#include <string>

Go to the source code of this file.

Classes

class | AP_LSystem::LSystemException
class | AP_LSystem::ParsingException
class | AP_LSystem::FileException
class | AP_LSystem::ConfigurationException

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemgenerator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
lsystemgenerator.h File Reference
#include "abstractgenerator.h"

Go to the source code of this file.

Classes

class AP_LSystem::LSystemGenerator

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/movingturtle.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
movingturtle.h File Reference
#include "abstractturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::MovingTurtle

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/par2lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
par2lsystem.h File Reference
#include "abstractklsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::Par2LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/pard0lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
pard0lsystem.h File Reference
#include "abstract0lsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::ParD0LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parseablestring.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces | Functions
parseablestring.h File Reference
#include <vector>
#include "utils.h"
#include "longstring.h"
#include <iostream>

Go to the source code of this file.

Classes

class AP_LSystem::ParseableString

Namespaces

namespace AP_LSystem

Functions

std::basic_ostream< char > & AP_LSystem::operator<< (std::basic_ostream< char > &os, const ParseableString ps)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parstoch0lsystem.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
parstoch0lsystem.h File Reference
#include "abstract0lsystem.h"

Go to the source code of this file.

Classes

class AP_LSystem::ParStoch0LSystem

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/query.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
query.h File Reference
#include "queryinterpret.h"

Go to the source code of this file.

Classes

class AP_LSystem::Query

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryinterpret.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
queryinterpret.h File Reference
#include "abstractinterpret.h"
#include "lsgeode.h"
#include "log.h"

Go to the source code of this file.

Classes

class AP_LSystem::QueryInterpret

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryturtle.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
queryturtle.h File Reference
#include "movingturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::QueryTurtle

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomindex.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
randomindex.h File Reference
#include <vector>
#include <cstdlib>
#include <ctime>
#include "configuration.h"

Go to the source code of this file.

Classes

class AP_LSystem::RandomIndex

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomizer.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
randomizer.h File Reference
#include <vector>
#include <cstdlib>
#include <ctime>
#include "configuration.h"

Go to the source code of this file.

Classes

class AP_LSystem::Randomizer

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rectangle.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
rectangle.h File Reference
#include "movingturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::Rectangle

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rule.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
rule.h File Reference
#include <vector>
#include "fparser/fparser.hh"
#include "staticstring.h"

Go to the source code of this file.

Classes

struct AP_LSystem::Rule

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/staticstring.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
staticstring.h File Reference
#include <string>
#include <cstring>
#include "utils.h"
#include "longstring.h"

Go to the source code of this file.

Classes

class AP_LSystem::StaticString

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/straightpipe.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
straightpipe.h File Reference
#include "loftturtle.h"

Go to the source code of this file.

Classes

class AP_LSystem::StraightPipe

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtleinterpret.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
turtleinterpret.h File Reference
#include "abstractinterpret.h"
#include "lsgeode.h"

Go to the source code of this file.

Classes

class AP_LSystem::TurtleInterpret

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtlestack.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
turtlestack.h File Reference
#include <stack>
#include "abstractturtle.h"
#include "lsgeode.h"

Go to the source code of this file.

Classes

class AP_LSystem::TurtleStack

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/utils.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
utils.h File Reference
#include <string>
#include <vector>

Go to the source code of this file.

Classes

class | AP_LSystem::StringUtils
struct | AP_LSystem::Parameter

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:49 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/xmlfile.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
Classes | Namespaces
xmlfile.h File Reference
#include "abstractfile.h"

Go to the source code of this file.

Classes

class AP_LSystem::XmlFile

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI Directory Reference

  • include
  • vreckoAP
  • GUI
GUI Directory Reference

Files

file | AP_GUI.h [code]
file | ColorPicker.h [code]
file | GUI_Controller.h [code]
file | GUI_item.h [code]
file | GUI_Text.h [code]
file | Icon.h [code]
file | IconColour.h [code]
file | ItemsGroup.h [code]
file | Layout.h [code]
file | Menu.h [code]
file | Slider.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/AP_GUI.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Functions
AP_GUI.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>
#include "Icon.h"
#include "IconColour.h"
#include "Slider.h"
#include "Menu.h"
#include "ColorPicker.h"
#include "GUI_Controller.h"

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ColorPicker.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros
ColorPicker.h File Reference
#include "GUI_item.h"

Go to the source code of this file.

Classes

class APGUI::ColorPicker
spatial HSL Color Picker More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Controller.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros | Typedefs
GUI_Controller.h File Reference
#include "GUI_item.h"
#include "Menu.h"
#include "Layout.h"
#include "ItemsGroup.h"

Go to the source code of this file.

Classes

class APGUI::GUI_Controller
GUI Controller class. More...

Namespaces

namespace APGUI

Macros

#define | GUI_EXPORT __declspec(dllimport)
#define | SENSOR_MAX_COUNT 20

Typedefs

typedef std::map< string,
osg::ref_ptr< Layout > > 		APGUI::LayoutMapType

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
#define SENSOR_MAX_COUNT 20
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_item.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Enumerations
GUI_item.h File Reference
#include "GUI_Text.h"
#include <osgText/Font3D>
#include <osgText/Text3D>

Go to the source code of this file.

Classes

class | APGUI::Interconnection
used to simplify deletion of created interconnections (especially in menu) More...
class | APGUI::GUI_Item
VRECKO GUI Item class. More...

Namespaces

namespace APGUI

Enumerations

enum | APGUI::GUI_ITEM_STATE { APGUI::GUI_ITEM_STATE_DEFAULT = 1, APGUI::GUI_ITEM_STATE_ACTIVE, APGUI::GUI_ITEM_STATE_DISABLED }
enum | APGUI::GUI_ACTION { APGUI::GUI_ACTION_MAIN = 1, APGUI::GUI_ACTION_CONTEXT }
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Text.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros
GUI_Text.h File Reference

Go to the source code of this file.

Classes

class APGUI::GUI_Text
Text. More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Icon.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros | Enumerations
Icon.h File Reference
#include "GUI_item.h"
#include "ItemsGroup.h"

Go to the source code of this file.

Classes

class APGUI::Icon
Icon. More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Enumerations

enum APGUI::IconType { APGUI::ICON__BUTTON = 1, APGUI::ICON__SWITCH, APGUI::ICON__MULTISWITCH }
types of Icon More...

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/IconColour.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros
IconColour.h File Reference
#include "Icon.h"

Go to the source code of this file.

Classes

class APGUI::IconColour
Color Icon. More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ItemsGroup.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces
ItemsGroup.h File Reference
#include "GUI_item.h"

Go to the source code of this file.

Classes

class APGUI::ItemsGroup
Group of GUI Items. More...

Namespaces

namespace APGUI
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Layout.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Typedefs
Layout.h File Reference
#include "GUI_item.h"

Go to the source code of this file.

Classes

class APGUI::Layout
GUI Layout class. More...

Namespaces

namespace APGUI

Typedefs

typedef std::map< unsigned
long, GUI_Item * > 		APGUI::GuiItemMapType
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Menu.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros
Menu.h File Reference
#include "GUI_item.h"

Go to the source code of this file.

Classes

class APGUI::Menu
Menu. More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Slider.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Classes | Namespaces | Macros
Slider.h File Reference
#include "GUI_item.h"

Go to the source code of this file.

Classes

class APGUI::Slider
Slider GUI item. More...

Namespaces

namespace APGUI

Macros

#define GUI_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define GUI_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking Directory Reference

  • include
  • vreckoAP
  • HeadTracking
HeadTracking Directory Reference

Files

file | AP_HeadTracking.h [code]
file | HeadTracking.h [code]
file | htUtils.h [code]
file | ScreenSetup.h [code]
file | ScreenSetupSimple.h [code]
file | Solver.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/AP_HeadTracking.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Functions
AP_HeadTracking.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT vrecko::Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT vrecko::Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/HeadTracking.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Macros
HeadTracking.h File Reference
#include <osg\Vec4>
#include <vrecko\Ability.h>
#include "htUtils.h"

Go to the source code of this file.

Classes

class ht::HeadTracking

Namespaces

namespace ht

Macros

#define __HEAD_TRACKING_H

Macro Definition Documentation

#define __HEAD_TRACKING_H
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/htUtils.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Macros
htUtils.h File Reference
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include "Vec2i"

Go to the source code of this file.

Classes

class ht::Screen
Defines position of screen in real world. More...

Namespaces

namespace ht

Macros

#define __HEAD_TRACKING_UTILS_H

Macro Definition Documentation

#define __HEAD_TRACKING_UTILS_H
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetup.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Macros
ScreenSetup.h File Reference
#include <string>
#include <osg\Vec3>
#include <osg\Quat>
#include <vrecko\Ability.h>
#include "Solver.h"

Go to the source code of this file.

Classes

class | ht::ScreenSetup
struct | ht::ScreenSetup::ScreenSetupState

Namespaces

namespace ht

Macros

#define __SCREEN_SETUP_H

Macro Definition Documentation

#define __SCREEN_SETUP_H
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetupSimple.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Macros
ScreenSetupSimple.h File Reference
#include <string>
#include <osg\Vec3>
#include <osg\Quat>
#include <vrecko\Ability.h>
#include "Solver.h"

Go to the source code of this file.

Classes

class | ht::ScreenSetupSimple
struct | ht::ScreenSetupSimple::ScreenSetupSimpleState

Namespaces

namespace ht

Macros

#define __SCREEN_SETUP_SIMPLE_H

Macro Definition Documentation

#define __SCREEN_SETUP_SIMPLE_H
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Macros | Typedefs | Functions
Solver.h File Reference
#include <osg/Vec2d>
#include <osg/Vec3d>
#include <osg/Quat>
#include <list>

Go to the source code of this file.

Classes

class | ht::Variable
class | ht::VariableVec3
class | ht::VariableVec2
class | ht::VariableFloat
class | ht::VariableQuat
class | ht::Function

Namespaces

namespace ht

Macros

#define __SOLVER_H

Typedefs

typedef std::list< Function * > | ht::ListOfFunctions
typedef std::list< Variable * > | ht::ListOfVariables

Functions

void ht::solve (ListOfFunctions &fcns, ListOfVariables &vars, double start_step=0.01, double next_step_scale=0.8, double min_step_size=1e-6)

Macro Definition Documentation

#define __SOLVER_H
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld Directory Reference

  • include
  • vreckoAP
  • HelloWorld
HelloWorld Directory Reference

Files

file | AP_HelloWorld.h [code]
file | MyAbility.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld/AP_HelloWorld.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HelloWorld
Macros | Functions
AP_HelloWorld.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Macros

#define AP_HELLOWORLD

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Macro Definition Documentation

#define AP_HELLOWORLD

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld/MyAbility.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HelloWorld
Classes | Namespaces
MyAbility.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APHelloWorld::MyAbility

Namespaces

namespace APHelloWorld
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD Directory Reference

  • include
  • vreckoAP
  • HUD
HUD Directory Reference

Files

file | AP_HUD.h [code]
file | HUDDisplay.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/AP_HUD.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HUD
Functions
AP_HUD.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • HUD
Classes | Namespaces | Macros
HUDDisplay.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Timer.h>
#include <osg/Geode>
#include <osgText/Text>
#include <osgText/Font>
#include <osg/BlendFunc>
#include <osg/Material>
#include <osg/StateSet>
#include <osg/Camera>
#include <string>

Go to the source code of this file.

Classes

struct | APHUD::HUDColorProfile
struct | APHUD::HUDField
struct | APHUD::HUDWindow
class | APHUD::HUDDisplay

Namespaces

namespace APHUD

Macros

#define HUD_EXPORT __declspec(dllimport)

Macro Definition Documentation

#define HUD_EXPORT __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector Directory Reference

  • include
  • vreckoAP
  • InputConnector
InputConnector Directory Reference

Files

file | AP_InputConnector.h [code]
file | InputConnector.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/AP_InputConnector.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • InputConnector
Functions
AP_InputConnector.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>
#include "InputConnector.h"

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/InputConnector.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • InputConnector
Classes | Namespaces | Macros | Typedefs
InputConnector.h File Reference

Go to the source code of this file.

Classes

struct | Receiver
class | APInputConnector::InputConnector
Input Connector class. More...

Namespaces

namespace APInputConnector

Macros

#define | INPUTCONNECTOR_EXPORT __declspec(dllimport)
#define | SENSOR_MAX_COUNT 20

Typedefs

typedef std::map< int, Receiver > ReceiversList

Macro Definition Documentation

#define INPUTCONNECTOR_EXPORT __declspec(dllimport)
#define SENSOR_MAX_COUNT 20

Typedef Documentation

typedef std::map<int, Receiver> ReceiversList
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor Directory Reference

  • include
  • vreckoAP
  • LightsEditor
LightsEditor Directory Reference

Files

file | AP_LightsEditor.h [code]
file | Editor.h [code]
file | Lights.h [code]
file | UniformUpdateCallback.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/AP_LightsEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Functions
AP_LightsEditor.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | LightsEditor_getPluginDescription ()
AP_EXPORT const char ** | LightsEditor_getAbilityList ()
AP_EXPORT const char * | LightsEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | LightsEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | LightsEditor_setAbilitiesParameters ()
void AP_EXPORT | LightsEditor_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* LightsEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* LightsEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** LightsEditor_getAbilityList ( )
AP_EXPORT const char* LightsEditor_getPluginDescription ( )
void AP_EXPORT LightsEditor_initializeAttributesDescription ( )
AP_EXPORT void LightsEditor_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Editor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Classes | Namespaces
Editor.h File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/PluginManager.h>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <osg/Light>
#include <osg/LightSource>
#include <osg/Material>
#include <osg/BlendFunc>
#include <osg/AlphaFunc>
#include <osg/PositionAttitudeTransform>
#include <osgDB/readFile>
#include <helpers/XercesXMLUtils.h>
#include <vrecko/ReaderWriter.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <osg/Group>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Shape>
#include <osg/ShapeDrawable>
#include <osg/Timer>
#include <iostream>
#include <sstream>
#include <vector>
#include <cmath>
#include <fstream>
#include <windows.h>
#include <vreckoAP/LightsEditor/Lights.h>

Go to the source code of this file.

Classes

struct | APLightsEditor::_Light
class | APLightsEditor::Editor

Namespaces

namespace APLightsEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Lights.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Classes | Namespaces
Lights.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/PluginManager.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <osg/LightSource>
#include <osg/Light>
#include <osg/LightModel>
#include <helpers/XercesXMLUtils.h>
#include <vrecko/ReaderWriter.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <osgShadow/ShadowMap>
#include <osgShadow/SoftShadowMap>
#include <osgShadow/ShadowTexture>
#include <osgShadow/LightSpacePerspectiveShadowMap>
#include <osg/CullFace>
#include <osg/BlendFunc>
#include <osg/AlphaFunc>
#include <osg/Geometry>
#include <osg/Texture2D>
#include <osgDB/readFile>
#include <osg/Depth>
#include <cmath>
#include <sstream>
#include <iostream>

Go to the source code of this file.

Classes

class APLightsEditor::Lights

Namespaces

namespace APLightsEditor
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/UniformUpdateCallback.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Classes
UniformUpdateCallback.h File Reference
#include <osg/Uniform>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class UniformUpdateCallback
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu Directory Reference

  • include
  • vreckoAP
  • Menu
Menu Directory Reference

Files

file | AP_Menu.h [code]
file | DynamicMenu.h [code]
file | DynamicMenu_XMLPart.h [code]
file | osgQ_QSection.h [code]
file | osgQ_QShapeDrawable.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/AP_Menu.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
Functions
AP_Menu.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
Classes | Namespaces | Macros | Enumerations
DynamicMenu.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>
#include <osg/ShapeDrawable>
#include <osgText/Text>
#include <helpers/DynamicArray.h>
#include <helpers/DynamicTree.h>
#include <vreckoAP/ObjectUtils/Animator.h>
#include <vreckoAP/Menu/osgQ_QSection.h>
#include <vreckoAP/Menu/osgQ_QShapeDrawable.h>

Go to the source code of this file.

Classes

class | APMenu::MenuItem
class | APMenu::MenuItemNull
class | APMenu::MenuItemText
class | APMenu::MenuItemSlider
class | APMenu::DynamicMenuSign
class | APMenu::DynamicMenu

Namespaces

namespace APMenu

Macros

#define | MI_F_SELECTED 0x00000001
#define | MI_F_EXPANDED 0x00000002

Enumerations

enum APMenu::MenuType { APMenu::RadialBoxes, APMenu::RadialSections, APMenu::Boxes, APMenu::Grid }

Macro Definition Documentation

#define MI_F_EXPANDED 0x00000002
#define MI_F_SELECTED 0x00000001
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu_XMLPart.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
Classes | Namespaces
DynamicMenu_XMLPart.h File Reference
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/parsers/AbstractDOMParser.hpp>
#include <xercesc/dom/DOMErrorHandler.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/dom/DOMLocator.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/dom/DOMImplementationRegistry.hpp>
#include <xercesc/dom/DOMImplementationLS.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/framework/MemBufInputSource.hpp>
#include <xercesc/framework/Wrapper4InputSource.hpp>
#include <iostream.h>

Go to the source code of this file.

Classes

class APMenu::MenuLoaderErrorHandler

Namespaces

namespace APMenu
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QSection.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
Classes | Namespaces
osgQ_QSection.h File Reference
#include <osg/Shape>

Go to the source code of this file.

Classes

class | osgQ::QShapeVisitor
class | osgQ::QConstShapeVisitor
class | osgQ::QSection

Namespaces

namespace osgQ
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QShapeDrawable.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
Classes | Namespaces
osgQ_QShapeDrawable.h File Reference
#include <osg/ShapeDrawable>
#include <osg/RenderInfo>

Go to the source code of this file.

Classes

class osgQ::QShapeDrawable

Namespaces

namespace osgQ
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature Directory Reference

  • include
  • vreckoAP
  • Nature
Nature Directory Reference

Directories

directory | Clouds
directory | Grass
directory | Terrain
directory | Weather

Files

file | _AP_Atmospheric.h [code]
file | AP_Nature.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds Directory Reference

  • include
  • vreckoAP
  • Nature
  • Clouds
Clouds Directory Reference

Files

file | BoundingVol.h [code]
file | Cloud.h [code]
file | Cloud2DPlacement.h [code]
file | Clouds.h [code]
file | CloudsManager.h [code]
file | GenClouds.h [code]
file | math_aux.h [code]
file | OSGCloudWrap.h [code]
file | OSGskybox.h [code]
file | Texture.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/BoundingVol.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes
BoundingVol.h File Reference
#include <osg/Vec3f>

Go to the source code of this file.

Classes

class AABoundingBox
Represents a bounding box (a sphere, actually) of the object which wraps the object in it. More...

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 (Clouds)
Todo:
getVertexN(), getVertexP() - examine the functionality
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes | Macros
Cloud.h File Reference
#include <osg/Vec4>
#include <osg/Geometry>
#include <osg/Texture2D>
#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
#include <set>
#include <cmath>
#include "BoundingVol.h"

Go to the source code of this file.

Classes

struct | CloudSceneInfo
struct | SunLight
struct | Particle
struct | CloudParticle
class | Cloud
class | Cloud::ParticleAwayComparison

Macros

#define PI 3.1415926535

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 - February 2011 (Clouds)

Macro Definition Documentation

#define PI 3.1415926535
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud2DPlacement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes
Cloud2DPlacement.h File Reference

Go to the source code of this file.

Classes

class PseudoRand2DPlacement
Represents a class which pseudo-randomly scatters the clouds over the sky in form of the grid (for now) More...

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 (Clouds)
Note
Noise1D is not being used, could be useful.
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Clouds.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes | Namespaces
Clouds.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec2>
#include <osg/Vec4>

Go to the source code of this file.

Classes

class APClouds::Clouds
Clouds ability - revised Atmospheric ability. More...

Namespaces

namespace APClouds

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), November 2010 - January 2011 (Clouds)
Todo:
Add more randomness to the cloud position - see Cloud2DPlacement class. Now that the clouds can overlay each other, it should be far easier to do.
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/CloudsManager.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes | Variables
CloudsManager.h File Reference
#include "cloud.h"
#include "Cloud2DPlacement.h"

Go to the source code of this file.

Classes

struct | CloudsProperties
Contains all the properties of the Clouds ability loaded from XML file. More...
class | CloudsManager
Manages all the clouds in the scene. More...

Variables

bool | g_Anisotropic_scattering
bool | g_MultipleForwardScattering
CloudsManager g_Clouds

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), November 2010 - February 2011 (Clouds)

Variable Documentation

bool g_Anisotropic_scattering
CloudsManager g_Clouds
bool g_MultipleForwardScattering
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/GenClouds.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes | Functions
GenClouds.h File Reference
#include "cloud.h"

Go to the source code of this file.

Classes

struct CloudVoxel
Represents a cloud voxel used for cloud generation. More...

Functions

void | InitCloudGrowth (int ellips_a, int ellips_b, int ellips_c)
bool | f_act (unsigned int i, unsigned int j, unsigned int k)
void | GrowthSimulation (int timeSteps)
float | weightedSum (unsigned int i, unsigned int j, unsigned int k)
void | CreateCloudFromVoxels (Cloud &cloud, const osg::Vec3f &cloudPos, float scale)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 (Clouds)

Function Documentation

void CreateCloudFromVoxels | ( | Cloud & | cloud,
 |  | const osg::Vec3f & | cloudPos,
 |  | float | scale
 | ) |  |

Converts the voxel space into the final cloud

Parameters
[in] | cloud | Instance of a cloud which is used to store the data from the voxel space
[in] | cloudPos | Position of the cloud in the scene
[in] | scale | Scale of the cloud
bool f_act | ( | unsigned int | i,
 |  | unsigned int | j,
 |  | unsigned int | k
 | ) |  |

Function computing the active value of the given cell as described in the thesis (p.3, formula 2.4)

Parameters
[in] | i | X-coordinate of the voxel in the cloud
[in] | j | Y-coordinate of the voxel in the cloud
[in] | k | Z-coordinate of the voxel in the cloud
void GrowthSimulation ( int timeSteps )

Simulates the growth of the cloud

Parameters
timeSteps Number of steps the generation process should take
void InitCloudGrowth | ( | int | ellips_a,
 |  | int | ellips_b,
 |  | int | ellips_c
 | ) |  |

Initializes the growth simulation of the cloud

Parameters
[in] | ellips_a | Size of the half-axis a of the ellipsoid
[in] | ellips_b | Size of the half-axis b of the ellipsoid
[in] | ellips_c | Size of the half-axis c of the ellipsoid
float weightedSum | ( | unsigned int | i,
 |  | unsigned int | j,
 |  | unsigned int | k
 | ) |  |

Computes the weighted sum of the cloud cell and cells related to it.

Parameters
[in] | i | X coordinate of the cloud cell in the voxel space
[in] | j | Y coordinate of the cloud cell in the voxel space
[in] | k | Z coordinate of the cloud cell in the voxel space
Returns
Weighted sum of the cloud cell and cells related to it.
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/math_aux.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Functions
math_aux.h File Reference
#include <osg/Vec4f>

Go to the source code of this file.

Functions

unsigned int | randGauss (unsigned int cislo, unsigned int n)
float | randFloat (void)
float | interpolationLinear (float a, float b, float t)
void | clampColor (osg::Vec4f &color, float maximum)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 - February 2011 (Clouds)

Function Documentation

void clampColor | ( | osg::Vec4f & | color,
 |  | float | maximum
 | ) |  |

Clamps the color in case some of its values are larger than the given maximum.

Parameters
color | Color to be clamped.
maximum | Threshold value; color channels larger than maximum will be clamped to it, smaller values will be preserved.
float interpolationLinear | ( | float | a,
 |  | float | b,
 |  | float | t
 | ) |  |

Linear interpolation of two values.

Parameters
a | The first value to interpolate.
b | The second value to interpolate.
t | Value on the interval. T = 0.0 returns as a result value A, T = 1.0 returns as a result value B
float randFloat ( void )

Returns a pseudo-random float value from the interval <0, 1.0)

Returns
Pseudo-random float value
unsigned int randGauss | ( | unsigned int | cislo,
 |  | unsigned int | n
 | ) |  |

Returns a pseudo-random unsigned integer value based on Gauss distribution

Parameters
[in] | number | Maximum value of the number
[in] | n | Number of iterations
Returns
Pseudo-random number based on Gauss distribution
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGCloudWrap.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Classes
OSGCloudWrap.h File Reference
#include "CloudsManager.h"

Go to the source code of this file.

Classes

class | CloudDataType
Inherited class from osg::Referenced. Stores information about the camera and can be referenced by osg::ref_ptr. More...
struct | AllCloudsUpdateCallBack
Structure containing camera data which is common for all of the clouds and overloaded callback method which is called once per frame. More...

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 - February 2011 (Clouds)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGskybox.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Functions
OSGskybox.h File Reference
#include <osg/Billboard>

Go to the source code of this file.

Functions

void | CreateSkyBox (osg::ref_ptr< osg::Geode > skyboxGeode, long x, long y, long z, long width, long height, long length)
void | CreateGround (osg::ref_ptr< osg::Geode > groundGeode, long x, long y, long z, long width, long length, long tileCount)
void | CreateSun (osg::ref_ptr< osg::Billboard > sunBillBoard, int x, int y, int z)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 (Clouds)

Function Documentation

void CreateGround | ( | osg::ref_ptr< osg::Geode > | groundGeode,
 |  | long | x,
 |  | long | y,
 |  | long | z,
 |  | long | width,
 |  | long | length,
 |  | long | tileCount
 | ) |  |

Creates a basic ground with texture

Parameters
[out] | groundGeode | Pointer to the osg::geode, where the ground should be stored
[in] | x | X coordinate of the center of the ground
[in] | y | Y coordinate of the ground (since the thickness is zero the parameter only determines the Y coordinate)
[in] | z | Z coordinate of the center of the ground
[in] | width | Width of the ground
[in] | length | Length of the ground
[in] | tileCount | Number of tiles in one coordinate
void CreateSkyBox | ( | osg::ref_ptr< osg::Geode > | skyboxGeode,
 |  | long | x,
 |  | long | y,
 |  | long | z,
 |  | long | width,
 |  | long | height,
 |  | long | length
 | ) |  |

Creates a skybox

Parameters
[out] | skyboxGeode | Pointer to the osg::geode, where the skybox should be stored
[in] | x | X coordinate of the center of the skybox
[in] | y | Y coordinate of the center of the skybox
[in] | z | Z coordinate of the center of the skybox
[in] | width | Width of the skybox
[in] | height | Height of the skybox
[in] | length | Length of the skybox
void CreateSun | ( | osg::ref_ptr< osg::Billboard > | sunBillBoard,
 |  | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

Creates a basic ground with texture

Parameters
[out] | sunBillBoard | Pointer to the osg::BillBoard, where the sun should be stored
[in] | x | X coordinate of the center of the sun
[in] | y | Y coordinate of the center of the sun
[in] | z | Z coordinate of the center of the sun
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Texture.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Functions
Texture.h File Reference
#include <osg/Texture2D>
#include <string>

Go to the source code of this file.

Functions

osg::ref_ptr< osg::Texture2D > LoadOSGTextureWithColorKey (char *fileName, bool alphaMap, bool computeColorAsRGBAverage, bool colorKey, const osg::Vec4ub &colorKeyValue=osg::Vec4ub(255, 0, 255, 0))

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 - February 2011 (Clouds)

Function Documentation

osg::ref_ptr<osg::Texture2D> LoadOSGTextureWithColorKey | ( | char * | fileName,
 |  | bool | alphaMap,
 |  | bool | computeColorAsRGBAverage,
 |  | bool | colorKey,
 |  | const osg::Vec4ub & | colorKeyValue = osg::Vec4ub(255, 0, 255, 0)
 | ) |  |

Loads an OSG Texture with additional parameters such as colorkey or possibility to load the texture as an alpha map. The pixel format of the texture has to be GL_RGB or GL_RGBA.

Parameters
[in] | fileName | Path to the file with the texture. All filetypes accepted by OSG are also permitted.
[in] | alphaMap | TRUE if the RGB values of the texture should be transformed to the greyscale so the texture could be used as an alpha map, FALSE otherwise - if the RGB values should not be modified.
[in] | computeColorAsRGBAverage | If the alphaMap is TRUE, this parameter determines whether the RGB values of the alpha map are computed as an average of their values (TRUE) or if they're set on full white (FALSE). If alphaMap is FALSE, this parameter has no influence at all.
[in] | colorKey | TRUE if the color key is used to make texture transparent, FALSE otherwise.
[in] | colorKeyValue | Value of the color key. If the colorKey parameter is TRUE, pixels with colorKeyValue are set to be fully transparent. If the colorKey is FALSE, this parameter has no influence and pixels are set to be fully opaque if the aphaMap is FALSE or their alpha value is computed from the RGB values if the alphaMap is TRUE. (optional parameter, default value = (255,0,255,0))
Returns
Loaded OSG texture with GL_RGBA pixel format.
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass Directory Reference

  • include
  • vreckoAP
  • Nature
  • Grass
Grass Directory Reference

Files

file | grass.h [code]
file | grass_cullcallback.h [code]
file | grass_drawable.h [code]
file | grass_mesh.h [code]
file | grass_parameters.h [code]
file | grass_shaders_source.h [code]
file | grass_triangle_collector.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass.h File Reference
#include "grass_cullcallback.h"
#include "grass_parameters.h"
#include "grass_drawable.h"
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <gl/gl.h>

Go to the source code of this file.

Classes

class grass::Grass

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_cullcallback.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass_cullcallback.h File Reference
#include <osgutil/CullVisitor>
#include "grass_drawable.h"
#include <osg/Drawable>

Go to the source code of this file.

Classes

class grass::GrassCullCallback

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_drawable.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass_drawable.h File Reference
#include <osg/Geometry>
#include <osg/Drawable>
#include <osg/Geode>
#include <osg/Vec3>
#include <vector>
#include <osg/matrix>
#include <osgutil/CullVisitor>
#include "grass_parameters.h"
#include "grass_mesh.h"

Go to the source code of this file.

Classes

class grass::GrassDrawable

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_mesh.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass_mesh.h File Reference
#include <osg/Geode>
#include <osg/Vec3>

Go to the source code of this file.

Classes

struct | grass::Vertex
struct | grass::Triangle
class | grass::Mesh

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_parameters.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass_parameters.h File Reference
#include <vrecko/ReaderWriter.h>
#include <gl/gl.h>
#include <vector>
#include <osg/Texture2D>

Go to the source code of this file.

Classes

struct grass::GrassAbilityParameters

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_shaders_source.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Variables
grass_shaders_source.h File Reference

Go to the source code of this file.

Variables

const char * | lowDetailVertexShaderSource
const char * | lowDetailFragmentShaderSource
const char * | detailedVertexShaderSource
const char * | detailedFragmentShaderSource

Variable Documentation

const char* detailedFragmentShaderSource
Initial value:
=
" uniform sampler2D texture; \n"
" uniform vec4 neutralColor; \n"
" void main( void ) \n"
" { \n"
" gl_FragColor = mix( neutralColor, \n"
" texture2D(texture, gl_TexCoord[0].xy), \n"
" gl_TexCoord[0].z \n"
" ); \n"
" } \n"
const char* detailedVertexShaderSource
const char* lowDetailFragmentShaderSource
Initial value:
=
" uniform sampler2D far_soil; \n"
" uniform sampler2D far_grass; \n"
" varying float angle; \n"
" varying float distance; \n"
" void main( void ) \n"
" { \n"
" vec4 soilColor = texture2D(far_soil, gl_TexCoord[0].st, -2.0); \n"
" vec4 grassColor = texture2D(far_grass, gl_TexCoord[0].st, -2.0); \n"
" gl_FragColor = mix(soilColor, grassColor, distance); \n"
" } \n"
const char* lowDetailVertexShaderSource
Initial value:
=
" varying float angle; \n"
" varying float distance; \n"
" uniform float maxVisibility; \n"
" uniform float minVisibility; \n"
" void main() \n"
" { \n"
" gl_Position = ftransform(); \n"
" angle = 1.0 - max(0.0, dot(vec3(0.0, 0.0, 1.0), gl_NormalMatrix * gl_Normal)); \n"
" distance = smoothstep(minVisibility, maxVisibility, \n"
" length(gl_ModelViewMatrix * gl_Vertex)); \n"
" gl_TexCoord[0].st = gl_MultiTexCoord0.st; \n"
" } \n"
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_triangle_collector.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
Classes | Namespaces
grass_triangle_collector.h File Reference
#include <osg/TriangleFunctor>
#include <osg/Vec3>
#include <map>
#include <vector>
#include "grass_mesh.h"

Go to the source code of this file.

Classes

class grass::TriangleCollector

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain Directory Reference

  • include
  • vreckoAP
  • Nature
  • Terrain
Terrain Directory Reference

Directories

directory | Algorithms
directory | Properties

Files

file | Terrain2D.h [code]
file | Terrain2DSegment.h [code]
file | TerrainAbility.h [code]
Main Terrain class inherited from VRECKO Ability which takes care of the initialization, update and other most important processes.
file | TerrainRandom.h [code]
Static class which groups static methods related to (pseudo-)random number generation.
file | TerrainUtility.h [code]
Static class which groups several mostly unrelated but highly useful static methods.
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms Directory Reference

  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Algorithms Directory Reference

Files

file | MidpointDisplacementAlgorithm.h [code]
Class containing methods responsible for generation of terrain based on midpoint displacement algorithm.
file | PerlinNoiseAlgorithm.h [code]
Class containing methods responsible for generation of terrain based on Perlin noise algorithm.
file | RandomFaultsAlgorithm.h [code]
Class containing methods responsible for generation of terrain based on random faults algorithm.
file | TerrainAlgorithm.h [code]
Class containing methods responsible for generation of terrain based on random faults algorithm.
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Classes | Namespaces
MidpointDisplacementAlgorithm.h File Reference

Class containing methods responsible for generation of terrain based on midpoint displacement algorithm. More...

#include "TerrainAlgorithm.h"
#include "../TerrainUtility.h"
#include <osg/Array>

Go to the source code of this file.

Classes

class APNature::MidpointDisplacementAlgorithm

Namespaces

namespace APNature

Detailed Description

Class containing methods responsible for generation of terrain based on midpoint displacement algorithm.

Author
Rastislav Tisovcik
Date
January 2012 - February 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Classes | Namespaces
PerlinNoiseAlgorithm.h File Reference

Class containing methods responsible for generation of terrain based on Perlin noise algorithm. More...

#include "TerrainAlgorithm.h"
#include "../TerrainUtility.h"
#include <osg/Array>

Go to the source code of this file.

Classes

class APNature::PerlinNoiseAlgorithm

Namespaces

namespace APNature

Detailed Description

Class containing methods responsible for generation of terrain based on Perlin noise algorithm.

Author
Rastislav Tisovcik
Date
February 2012 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Classes | Namespaces
RandomFaultsAlgorithm.h File Reference

Class containing methods responsible for generation of terrain based on random faults algorithm. More...

#include "TerrainAlgorithm.h"
#include "../TerrainUtility.h"
#include <osg/Array>

Go to the source code of this file.

Classes

class APNature::RandomFaultsAlgorithm

Namespaces

namespace APNature

Detailed Description

Class containing methods responsible for generation of terrain based on random faults algorithm.

Author
Rastislav Tisovcik
Date
January 2012, April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Classes | Namespaces
TerrainAlgorithm.h File Reference

Class containing methods responsible for generation of terrain based on random faults algorithm. More...

#include "../TerrainUtility.h"
#include <osg/Array>

Go to the source code of this file.

Classes

class APNature::TerrainAlgorithm

Namespaces

namespace APNature

Detailed Description

Class containing methods responsible for generation of terrain based on random faults algorithm.

Author
Rastislav Tisovcik
Date
January 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties Directory Reference

  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Properties Directory Reference

Files

file | Default.h [code]
Static class containing default constant values for all of the terrain properties.
file | Enumerations.h [code]
Groups several enumerations from the Terrain ability.
file | GeneratedTerrainProperties.h [code]
Static class containing terrain properties related to the algorithm generated terrain. All values are initialized to the their default values at launch.
file | HeightMapProperties.h [code]
Static class containing all of the terrain properties related to terrain loaded from heightmap. All values are initialized to the their default values at launch.
file | MidpointDisplacementProperties.h [code]
Static class containing all of the terrain properties related to the midpoint displacement algorithm. All values are initialized to the their default values at launch.
file | PerlinNoiseProperties.h [code]
Static class containing all of the terrain properties related to the Perlin noise algorithm. All values are initialized to the their default values at launch.
file | RandomFaultsProperties.h [code]
Static class containing all of the terrain properties related to the random faults algorithm. All values are initialized to the their default values at launch.
file | TerrainProperties.h [code]
Static class containing all of the common terrain properties which need to be accessed from multiple locations along with methods capable of loading it from XML file. All values are initialized to the their default values at launch.
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/Default.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
Default.h File Reference

Static class containing default constant values for all of the terrain properties. More...

#include <osg/Vec2>
#include <osg/Vec3f>
#include <string>
#include "Enumerations.h"

Go to the source code of this file.

Classes

class APNature::Default

Namespaces

namespace APNature

Detailed Description

Static class containing default constant values for all of the terrain properties.

Author
Rastislav Tisovcik
February 2012 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/Enumerations.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Namespaces | Enumerations
Enumerations.h File Reference

Groups several enumerations from the Terrain ability. More...

Go to the source code of this file.

Namespaces

namespace APNature

Enumerations

enum | APNature::TerrainAlignment { APNature::Left, APNature::Centre, APNature::Right }
enum | APNature::DataSourceType { APNature::None, APNature::Image, APNature::Algorithm }
enum | APNature::AlgorithmType { APNature::Displacement, APNature::Faults, APNature::PerlinNoise }
enum | APNature::InterpolationType { APNature::Linear, APNature::Cosine }
enum APNature::FileTypeExport {
APNature::MAX3DS, APNature::OBJ, APNature::IVE, APNature::OSG,
APNature::FLT, APNature::AC, APNature::FBX
}

Detailed Description

Groups several enumerations from the Terrain ability.

Author
Rastislav Tisovcik
Date
November 2011 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/GeneratedTerrainProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
GeneratedTerrainProperties.h File Reference

Static class containing terrain properties related to the algorithm generated terrain. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "TerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::GeneratedTerrainProperties

Namespaces

namespace APNature

Detailed Description

Static class containing terrain properties related to the algorithm generated terrain. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
January 2012 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/HeightMapProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
HeightMapProperties.h File Reference

Static class containing all of the terrain properties related to terrain loaded from heightmap. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "TerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::HeightMapProperties

Namespaces

namespace APNature

Detailed Description

Static class containing all of the terrain properties related to terrain loaded from heightmap. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
December 2011 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
MidpointDisplacementProperties.h File Reference

Static class containing all of the terrain properties related to the midpoint displacement algorithm. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "GeneratedTerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::MidpointDisplacementProperties

Namespaces

namespace APNature

Detailed Description

Static class containing all of the terrain properties related to the midpoint displacement algorithm. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
January 2012 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
PerlinNoiseProperties.h File Reference

Static class containing all of the terrain properties related to the Perlin noise algorithm. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "GeneratedTerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::PerlinNoiseProperties

Namespaces

namespace APNature

Detailed Description

Static class containing all of the terrain properties related to the Perlin noise algorithm. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
February 2012 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
RandomFaultsProperties.h File Reference

Static class containing all of the terrain properties related to the random faults algorithm. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "GeneratedTerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::RandomFaultsProperties

Namespaces

namespace APNature

Detailed Description

Static class containing all of the terrain properties related to the random faults algorithm. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
January 2012 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/TerrainProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Classes | Namespaces
TerrainProperties.h File Reference

Static class containing all of the common terrain properties which need to be accessed from multiple locations along with methods capable of loading it from XML file. All values are initialized to the their default values at launch. More...

#include <vrecko/ReaderWriter.h>
#include <osg/Vec2>
#include "Enumerations.h"

Go to the source code of this file.

Classes

class APNature::TerrainProperties

Namespaces

namespace APNature

Detailed Description

Static class containing all of the common terrain properties which need to be accessed from multiple locations along with methods capable of loading it from XML file. All values are initialized to the their default values at launch.

Author
Rastislav Tisovcik
Date
October 2011 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2D.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Classes | Namespaces
Terrain2D.h File Reference
#include <osg/Geode>
#include <osg/PositionAttitudeTransform>
#include <osg/ShapeDrawable>
#include "Terrain2DSegment.h"

Go to the source code of this file.

Classes

class APNature::Terrain2D
2D terrain based on height map which consists of multiple equally large segments. More...

Namespaces

namespace APNature
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2DSegment.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Classes | Namespaces
Terrain2DSegment.h File Reference
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Texture2D>
#include <osg/Array>
#include "Properties/TerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::Terrain2DSegment
Represents a single segment of a two-dimensional terrain which consists of a grid of NxN points (where N >= 2) in the XZ plane (in OSG coordinates) with the value in the Y axis representing height of the point. More...

Namespaces

namespace APNature

Detailed Description

Author
Rastislav Tisovcik
Date
October 2011 - January 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainAbility.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Classes | Namespaces
TerrainAbility.h File Reference

Main Terrain class inherited from VRECKO Ability which takes care of the initialization, update and other most important processes. More...

#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vreckoUtils/Menu.h>
#include <vreckoAP/GUI/Menu.h>
#include <vreckoAP/GUI/GUI_Controller.h>
#include "Terrain2D.h"

Go to the source code of this file.

Classes

class APNature::TerrainAbility

Namespaces

namespace APNature

Detailed Description

Main Terrain class inherited from VRECKO Ability which takes care of the initialization, update and other most important processes.

Author
Rastislav Tisovcik
Date
November 2011 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainRandom.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Classes | Namespaces
TerrainRandom.h File Reference

Static class which groups static methods related to (pseudo-)random number generation. More...

#include <osg/Vec3>
#include <iostream>
#include <string>
#include "Properties/TerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::TerrainRandom

Namespaces

namespace APNature

Detailed Description

Static class which groups static methods related to (pseudo-)random number generation.

Author
Rastislav Tisovcik
Date
January 2012 - March 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainUtility.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Classes | Namespaces
TerrainUtility.h File Reference

Static class which groups several mostly unrelated but highly useful static methods. More...

#include <osg/Vec3>
#include <iostream>
#include <string>
#include "Properties/TerrainProperties.h"

Go to the source code of this file.

Classes

class APNature::TerrainUtility

Namespaces

namespace APNature

Detailed Description

Static class which groups several mostly unrelated but highly useful static methods.

Author
Rastislav Tisovcik
Date
November 2011 - April 2012
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Weather Directory Reference

  • include
  • vreckoAP
  • Nature
  • Weather
Weather Directory Reference

Files

file Weather.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Weather/Weather.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Weather
Classes | Namespaces
Weather.h File Reference
#include <vrecko\Ability.h>
#include <osgParticle\PrecipitationEffect>
#include <osg\MatrixTransform>
#include <vreckoAP\Export>
#include <iostream>

Go to the source code of this file.

Classes

class APWeather::Weather

Namespaces

namespace APWeather
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/_AP_Atmospheric.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
Macros | Functions
_AP_Atmospheric.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

AP_EXPORT const char ** | Atmospheric_getAbilityList (void)
AP_EXPORT vrecko::Ability * | Atmospheric_getAbilityInstance (const char *_name)
AP_EXPORT const char * | Atmospheric_getAbilityDescription (const char *name)
AP_EXPORT const char * | Atmospheric_getPluginDescription (void)
AP_EXPORT void | Atmospheric_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

AP_EXPORT const char* Atmospheric_getAbilityDescription ( const char * name )
AP_EXPORT vrecko::Ability* Atmospheric_getAbilityInstance ( const char * _name )
AP_EXPORT const char** Atmospheric_getAbilityList ( void )
AP_EXPORT const char* Atmospheric_getPluginDescription ( void )
AP_EXPORT void Atmospheric_initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/AP_Nature.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
Functions
AP_Nature.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation Directory Reference

  • include
  • vreckoAP
  • navigation
navigation Directory Reference

Files

file | AP_navigation.h [code]
file | AvatarInHand.h [code]
file | KMTracker.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/AP_navigation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
Macros | Functions
AP_navigation.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "KMTracker.h"
#include "AvatarInHand.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | navigation_getAbilityList (void)
Ability AP_EXPORT * | navigation_getAbilityInstance (const char *_name)
void AP_EXPORT | navigation_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

Ability AP_EXPORT* navigation_getAbilityInstance ( const char * _name )
const char AP_EXPORT** navigation_getAbilityList ( void )
void AP_EXPORT navigation_initializeAttributesDescription ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/AvatarInHand.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
Classes | Namespaces
AvatarInHand.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/Scene.h>
#include <sys/time.h>
#include <time.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class navigation::AvatarInHand

Namespaces

namespace navigation
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/KMTracker.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
Classes | Namespaces
KMTracker.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <osg/Vec2>

Go to the source code of this file.

Classes

class navigation::KMTracker

Namespaces

namespace navigation
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils Directory Reference

  • include
  • vreckoAP
  • ObjectUtils
ObjectUtils Directory Reference

Files

file | Animator.h [code]
file | AP_ObjectUtils.h [code]
file | ConnectionViz.h [code]
file | CopyProperties.h [code]
file | KeepOnScreen.h [code]
file | ObjectEffect.h [code]
file | ObjectEffectMan.h [code]
file | ObjectInfo.h [code]
file | ObjectModif.h [code]
file | ObjectSelector.h [code]
file | UseToEvent.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/Animator.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces | Macros
Animator.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/IOPins.h>
#include <vrecko/Timer.h>
#include <helpers/DynamicArray.h>

Go to the source code of this file.

Classes

class | APObjectUtils::Animator
class | APObjectUtils::Animator::AnimationPoint

Namespaces

namespace APObjectUtils

Macros

#define ANIMATOR_IMP_EXP __declspec(dllimport)

Macro Definition Documentation

#define ANIMATOR_IMP_EXP __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/AP_ObjectUtils.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Functions
AP_ObjectUtils.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ConnectionViz.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces | Macros
ConnectionViz.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>
#include <osg/ShapeDrawable>
#include <helpers/DynamicArray.h>

Go to the source code of this file.

Classes

class | APObjectUtils::ConnectionViz
class | APObjectUtils::ConnectionViz::Connection

Namespaces

namespace APObjectUtils

Macros

#define CVC_F_DEFAULT 0x00000001

Macro Definition Documentation

#define CVC_F_DEFAULT 0x00000001
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/CopyProperties.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces | Macros
CopyProperties.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class APObjectUtils::CopyProperties

Namespaces

namespace APObjectUtils

Macros

#define | COPYPROP_GEOMETRY_COPY 0x00000001
#define | COPYPROP_GEOMETRY_REF 0x00000002
#define | COPYPROP_TRANSFORMATION 0x00000004

Macro Definition Documentation

#define COPYPROP_GEOMETRY_COPY 0x00000001
#define COPYPROP_GEOMETRY_REF 0x00000002
#define COPYPROP_TRANSFORMATION 0x00000004
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/KeepOnScreen.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces | Macros
KeepOnScreen.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class APObjectUtils::KeepOnScreen

Namespaces

namespace APObjectUtils

Macros

#define | HORIZ_ALIGN_OUTER -100000.0f
#define | VERT_ALIGN_OUTER -100000.0f

Macro Definition Documentation

#define HORIZ_ALIGN_OUTER -100000.0f
#define VERT_ALIGN_OUTER -100000.0f
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffect.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
ObjectEffect.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>
#include <osg/ShapeDrawable>
#include <helpers/DynamicArray.h>
#include <vrecko/SP_CommonDefs.h>

Go to the source code of this file.

Classes

class APObjectUtils::ObjectEffect

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffectMan.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
ObjectEffectMan.h File Reference
#include <vrecko/Ability.h>
#include "ObjectEffect.h"

Go to the source code of this file.

Classes

class APObjectUtils::ObjectEffectMan

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectInfo.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
ObjectInfo.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>

Go to the source code of this file.

Classes

class APObjectUtils::ObjectInfo

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectModif.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
ObjectModif.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>

Go to the source code of this file.

Classes

class APObjectUtils::ObjectModif

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectSelector.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
ObjectSelector.h File Reference
#include <vrecko/Ability.h>
#include <osg/Group>
#include "ObjectEffect.h"
#include <helpers/DynamicArray.h>

Go to the source code of this file.

Classes

class APObjectUtils::ObjectSelector

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/UseToEvent.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Classes | Namespaces
UseToEvent.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/BaseClass.h>
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class APObjectUtils::UseToEvent

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE Directory Reference

  • include
  • vreckoAP
  • ODE
ODE Directory Reference

Files

file | AP_ode.h [code]
file | CappedCylinder.h [code]
file | CompositeObject.h [code]
file | Cube.h [code]
file | DynamicScene.h [code]
file | Sphere.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/AP_ode.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Macros | Functions
AP_ode.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "DynamicScene.h"
#include "Sphere.h"
#include "Cube.h"
#include "CappedCylinder.h"
#include "CompositeObject.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | ode_getAbilityList (void)
Ability AP_EXPORT * | ode_getAbilityInstance (const char *_name)
const char AP_EXPORT * | ode_getAbilityDescription (const char *name)
void AP_EXPORT | ode_setAbilitiesParameters (void)
const char AP_EXPORT * | ode_getPluginDescription (void)
void AP_EXPORT | ode_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char AP_EXPORT* ode_getAbilityDescription ( const char * name )
Ability AP_EXPORT* ode_getAbilityInstance ( const char * _name )
const char AP_EXPORT** ode_getAbilityList ( void )
const char AP_EXPORT* ode_getPluginDescription ( void )
void AP_EXPORT ode_initializeAttributesDescription ( )
void AP_EXPORT ode_setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CappedCylinder.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Classes | Namespaces
CappedCylinder.h File Reference
#include <vrecko/Ability.h>
#include "DynamicScene.h"

Go to the source code of this file.

Classes

class ode::CappedCylinder

Namespaces

namespace ode
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CompositeObject.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Classes | Namespaces
CompositeObject.h File Reference
#include <vrecko/Ability.h>
#include "DynamicScene.h"

Go to the source code of this file.

Classes

class | ode::CompositeObject
struct | ode::CompositeObject::Data

Namespaces

namespace ode
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Cube.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Classes | Namespaces
Cube.h File Reference
#include <vrecko/Ability.h>
#include "DynamicScene.h"
#include <osg/Vec3>

Go to the source code of this file.

Classes

class ode::Cube

Namespaces

namespace ode
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/DynamicScene.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Classes | Namespaces
DynamicScene.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vreckoAP/Export>
#include <osg/Vec3>
#include <osg/Vec4>
#include <ode/ode.h>
#include <vector>
#include <map>
#include <string>

Go to the source code of this file.

Classes

struct | ode::ODEObject
class | ode::DynamicScene
class | ode::DynamicScene::MessageODERequest

Namespaces

namespace ode
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Sphere.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Classes | Namespaces
Sphere.h File Reference
#include <vrecko/Ability.h>
#include "DynamicScene.h"

Go to the source code of this file.

Classes

class ode::Sphere

Namespaces

namespace ode
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit Directory Reference

  • include
  • vreckoAP
  • RoomEdit
RoomEdit Directory Reference

Files

file | AP_RoomEdit.h [code]
file | ColorBucket.h [code]
file | CreateHole.h [code]
file | Geometry.h [code]
file | HoleRemove.h [code]
file | PointAdd.h [code]
file | PointMove.h [code]
file | RealCmp.h [code]
file | RoomEditor.h [code]
file | RoomLoader.h [code]
file | RoomSaver.h [code]
file | Tool.h [code]
file | WallAdd.h [code]
file | WallGeometry.h [code]
file | WallMovement.h [code]
file | WallRemove.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/AP_RoomEdit.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Functions
AP_RoomEdit.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | RoomEdit_getPluginDescription ()
AP_EXPORT char ** | RoomEdit_getAbilityList ()
AP_EXPORT const char * | RoomEdit_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | RoomEdit_getAbilityInstance (const char *pchName)
AP_EXPORT void | RoomEdit_setAbilitiesParameters ()
void AP_EXPORT | RoomEdit_initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* RoomEdit_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* RoomEdit_getAbilityInstance ( const char * pchName )
AP_EXPORT char** RoomEdit_getAbilityList ( )
AP_EXPORT const char* RoomEdit_getPluginDescription ( )
void AP_EXPORT RoomEdit_initializeAttributesDescription ( )
AP_EXPORT void RoomEdit_setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/ColorBucket.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
ColorBucket.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::ColorBucket

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/CreateHole.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces | Macros
CreateHole.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::CreateHole

Namespaces

namespace APRoomEdit

Macros

#define MIN_DISTANCE_FROM_EDGE 3.0

Macro Definition Documentation

#define MIN_DISTANCE_FROM_EDGE 3.0
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces | Macros | Enumerations
Geometry.h File Reference
#include <vrecko/Logger.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <osg/Geometry>
#include <vector>
#include <cmath>
#include <osg/ref_ptr>
#include <iostream>
#include "RealCmp.h"

Go to the source code of this file.

Classes

class | WGeometry::WG_Geometry
class | WGeometry::WG_Vertices
class | WGeometry::WG_Point
class | WGeometry::WG_Hole
class | WGeometry::WG_Wall

Namespaces

namespace WGeometry

Macros

#define | RE_DEFAULT_HEIGHT 20.0
#define | RE_DEFAULT_BOTTOM 0.0
#define | RE_DEFAULT_2_WIDTH 0.75
#define | RE_MIN_LENGTH 5.0
#define | RE_DEFAULT_COLOR osg::Vec3(1.0, 1.0, 1.0)
#define | RE_MIN_ANGLE(x, y) ((x)<(y) ? 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(x)) : 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(y)))
#define | RE_DEG_2_RAD_RATIO (180.0 / 3.141592653589793238)
#define | RE_WALL_ANGLES_COMPUTED 1
#define | RE_WALL_DRAWN 2

Enumerations

enum | WGeometry::PointType { WGeometry::WG_Q_POINT, WGeometry::WG_R_POINT }
enum | WGeometry::HoleType { WGeometry::ht_window, WGeometry::ht_door }

Macro Definition Documentation

#define RE_DEFAULT_2_WIDTH 0.75
#define RE_DEFAULT_BOTTOM 0.0
#define RE_DEFAULT_COLOR osg::Vec3(1.0, 1.0, 1.0)
#define RE_DEFAULT_HEIGHT 20.0
#define RE_DEG_2_RAD_RATIO (180.0 / 3.141592653589793238)
#define RE_MIN_ANGLE | ( | x,
 |  | y
 | ) | ((x)<(y) ? 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(x)) : 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(y)))
#define RE_MIN_LENGTH 5.0
#define RE_WALL_ANGLES_COMPUTED 1
#define RE_WALL_DRAWN 2
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/HoleRemove.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
HoleRemove.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::HoleRemove

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointAdd.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
PointAdd.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::PointAdd

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointMove.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
PointMove.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::PointMove

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RealCmp.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes
RealCmp.h File Reference
#include <sstream>
#include <string>
#include <iomanip>

Go to the source code of this file.

Classes

class RealCmp< T >
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomEditor.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
RoomEditor.h File Reference
#include <vrecko/ReaderWriter.h>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <osgDB/ReadFile>
#include <sstream>
#include <map>
#include <vector>
#include <string>
#include "WallGeometry.h"
#include "Tool.h"
#include "ColorBucket.h"
#include "RoomSaver.h"
#include "RoomLoader.h"
#include "WallRemove.h"
#include "PointMove.h"
#include "WallAdd.h"
#include "WallMovement.h"
#include "PointAdd.h"
#include "CreateHole.h"
#include "HoleRemove.h"

Go to the source code of this file.

Classes

class APRoomEdit::RoomEditor

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomLoader.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
RoomLoader.h File Reference
#include "Tool.h"
#include "Geometry.h"

Go to the source code of this file.

Classes

class APRoomEdit::RoomLoader

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomSaver.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
RoomSaver.h File Reference
#include "Tool.h"
#include "Geometry.h"

Go to the source code of this file.

Classes

class APRoomEdit::RoomSaver

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Tool.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces | Enumerations
Tool.h File Reference
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Logger.h>
#include <osg/Geometry>
#include <osg/Geode>
#include <osg/Vec3>
#include <osg/ref_ptr>
#include <vector>
#include <vrecko/ReaderWriter.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include "Geometry.h"

Go to the source code of this file.

Classes

class APRoomEdit::Tool

Namespaces

namespace APRoomEdit

Enumerations

enum APRoomEdit::ToolType {
APRoomEdit::NONE = 0, APRoomEdit::COLORBUCKET = 1, APRoomEdit::WALLREMOVE = 2, APRoomEdit::WALLADD = 3,
APRoomEdit::WALLMOVEMENT = 4, APRoomEdit::POINTMOVE = 5, APRoomEdit::SAVER = 6, APRoomEdit::LOADER = 7,
APRoomEdit::CREATEHOLE = 8, APRoomEdit::HOLEREMOVE = 9, APRoomEdit::NORMALSSWITCHER = 10, APRoomEdit::POINTADD = 11
}
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallAdd.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
WallAdd.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::WallAdd

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallGeometry.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
WallGeometry.h File Reference
#include <vrecko/ReaderWriter.h>
#include <vrecko/Ability.h>
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Logger.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <osgDB/ReadFile>
#include <osg/Geometry>
#include <osg/Geode>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/CullFace>
#include <osg/LightModel>
#include <sstream>
#include <vector>
#include <set>
#include <map>
#include "Geometry.h"
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::WallGeometry

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallMovement.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
WallMovement.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::WallMovement

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallRemove.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Classes | Namespaces
WallRemove.h File Reference
#include "Tool.h"

Go to the source code of this file.

Classes

class APRoomEdit::WallRemove

Namespaces

namespace APRoomEdit
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation Directory Reference

  • include
  • vreckoAP
  • ShootingSimulation
ShootingSimulation Directory Reference

Files

file | AP_ShootingSimulation.h [code]
file | ShootingSimulation.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation/AP_ShootingSimulation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ShootingSimulation
Functions
AP_ShootingSimulation.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
AP_EXPORT void | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
AP_EXPORT void initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation/ShootingSimulation.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • ShootingSimulation
Classes | Namespaces | Macros | Enumerations
ShootingSimulation.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <osgText/Font>

Go to the source code of this file.

Classes

class APShootingSimulation::ShootingSimulation

Namespaces

namespace APShootingSimulation

Macros

#define NUM_TARGETS 3

Enumerations

enum APShootingSimulation::GameStates {
APShootingSimulation::PREPARE_NEW_GAME, APShootingSimulation::PREPARE_NEXT_LEVEL, APShootingSimulation::WAITING_FOR_START, APShootingSimulation::COUNTDOWN,
APShootingSimulation::RUNNING_LEVEL
}
enum APShootingSimulation::MoveDirections {
APShootingSimulation::NO_MOVE, APShootingSimulation::MOVE_UP, APShootingSimulation::MOVE_DOWN, APShootingSimulation::MOVE_LEFT,
APShootingSimulation::MOVE_RIGHT
}

Macro Definition Documentation

#define NUM_TARGETS 3
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning Directory Reference

  • include
  • vreckoAP
  • SpacePartitioning
SpacePartitioning Directory Reference

Files

file | AP_SpacePartitioning.h [code]
file | GeometryLoaderBase.h [code]
file | NoPartitioning_Scene.h [code]
file | PointShell_Object_Data.h [code]
file | PointShell_Object_Data_Geometry.h [code]
file | PointShell_Object_Data_Geometry_Analyser.h [code]
file | PointShell_Object_Data_LOD_Builder.h [code]
file | PointShellVSVoxel_Object.h [code]
file | SNCH_Object.h [code]
file | SNCH_Object_Data.h [code]
file | SP_Object_Data_Base.h [code]
file | SphereBVH_Object.h [code]
file | SphereBVH_Object_Data.h [code]
file | SphereBVH_Scene.h [code]
file | triangleCube.h [code]
file | VoxelGrid_Object_Data.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/AP_SpacePartitioning.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Functions
AP_SpacePartitioning.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
AP_EXPORT void | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
AP_EXPORT void initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/GeometryLoaderBase.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
GeometryLoaderBase.h File Reference
#include <vrecko/Ability.h>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APSpacePartitioning::GeometryLoaderBase
struct | APSpacePartitioning::GeometryLoaderBase::VertexBase
struct | APSpacePartitioning::GeometryLoaderBase::FaceBase

Namespaces

namespace APSpacePartitioning

Macros

#define SPACEPARTITIONING_IMP_EXP __declspec(dllimport)

Macro Definition Documentation

#define SPACEPARTITIONING_IMP_EXP __declspec(dllimport)
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/NoPartitioning_Scene.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
NoPartitioning_Scene.h File Reference
#include <vrecko/SP_SceneInterface.h>
#include <vrecko/Ability.h>
#include <vrecko/Scene.h>
#include <vrecko/Timer.h>
#include <vreckoAP/HUD/HUDDisplay.h>

Go to the source code of this file.

Classes

class | APSpacePartitioning::NoPartitioning_Scene
struct | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
struct | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct

Namespaces

namespace APSpacePartitioning

Macros

#define SP_SCENE_INTERFACE_ID__NOPARTITIONING 1

Macro Definition Documentation

#define SP_SCENE_INTERFACE_ID__NOPARTITIONING 1
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
PointShell_Object_Data.h File Reference
#include <list>
#include <vector>
#include <stack>
#include <string>
#include "PointShell_Object_Data_LOD_Builder.h"
#include "GeometryLoaderBase.h"
#include "SP_Object_Data_Base.h"
#include <vrecko/Ability.h>
#include <vrecko/Scene.h>
#include <helpers/DynamicTree.h>
#include <helpers/BufFile.h>
#include <osg/BoundingBox>
#include <osg/PolygonMode>
#include <osg/StateSet>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/Material>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >
class | APSpacePartitioning::PointShell_SimpleNode
class | APSpacePartitioning::PointShell_Object_Data
struct | APSpacePartitioning::PointShell_Object_Data::PSpoint

Namespaces

namespace APSpacePartitioning

Macros

#define | FACE(x) ((FaceBase*)getFace(x))
#define | VERTEX(x) ((VertexBase*)getVertex(x))

Macro Definition Documentation

#define FACE ( x ) ((FaceBase*)getFace(x))
#define VERTEX ( x ) ((VertexBase*)getVertex(x))
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces
PointShell_Object_Data_Geometry.h File Reference

Go to the source code of this file.

Classes

class | APSpacePartitioning::PointShell_Object_Data_Geometry
struct | APSpacePartitioning::PointShell_Object_Data_Geometry::V
struct | APSpacePartitioning::PointShell_Object_Data_Geometry::E
struct | APSpacePartitioning::PointShell_Object_Data_Geometry::P

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
PointShell_Object_Data_Geometry_Analyser.h File Reference
#include "pointshell_object_data_geometry.h"

Go to the source code of this file.

Classes

class | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser
struct | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
struct | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
struct | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt

Namespaces

namespace APSpacePartitioning

Macros

#define FIELD_SIZE 200000

Macro Definition Documentation

#define FIELD_SIZE 200000
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces
PointShell_Object_Data_LOD_Builder.h File Reference
#include <list>
#include <vector>
#include <queue>
#include <helpers/DynamicTree.h>
#include "String"
#include "PointShell_Object_Data_Geometry_Analyser.h"

Go to the source code of this file.

Classes

class | APSpacePartitioning::mycomparisonMinMax
class | APSpacePartitioning::mycomparisonMaxMin
struct | APSpacePartitioning::VLOD
struct | APSpacePartitioning::ELOD
struct | APSpacePartitioning::PLOD
struct | APSpacePartitioning::int_3
class | APSpacePartitioning::PointShell_Object_Data_LOD_Builder

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
PointShellVSVoxel_Object.h File Reference
#include <vrecko/SP_ObjectInterface.h>
#include <vrecko/Ability.h>
#include <vreckoAP/HUD/HUDDisplay.h>

Go to the source code of this file.

Classes

class APSpacePartitioning::PointShellVSVoxel_Object

Namespaces

namespace APSpacePartitioning

Macros

#define SP_OBJECT_INTERFACE_ID__PS_VG 30

Macro Definition Documentation

#define SP_OBJECT_INTERFACE_ID__PS_VG 30
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
SNCH_Object.h File Reference
#include "SphereBVH_Object.h"
#include "SNCH_Object_Data.h"
#include <vrecko/SP_ObjectInterface.h>
#include <vrecko/MTLock.h>

Go to the source code of this file.

Classes

class | APSpacePartitioning::SNCH_Object
struct | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
class | APSpacePartitioning::SNCH_Object::LMDStore
struct | APSpacePartitioning::SNCH_Object::InternalPointStruct
class | APSpacePartitioning::SNCH_Object::OneTri

Namespaces

namespace APSpacePartitioning

Macros

#define | SNCH_LMD_F_INTERSECTION 0x00000001
#define | SNCH_LMD_F_NEGATIVE_DISTANCE 0x00000002
#define | SNCH_FLOAT_SMALL_NUM 0.00000001f
#define | SNCH_FLOAT_TOLERANCE SNCH_FLOAT_SMALL_NUM
#define | SP_OBJECT_INTERFACE_ID__SNCH 20

Macro Definition Documentation

#define SNCH_FLOAT_SMALL_NUM 0.00000001f
#define SNCH_FLOAT_TOLERANCE SNCH_FLOAT_SMALL_NUM
#define SNCH_LMD_F_INTERSECTION 0x00000001
#define SNCH_LMD_F_NEGATIVE_DISTANCE 0x00000002
#define SP_OBJECT_INTERFACE_ID__SNCH 20
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
SNCH_Object_Data.h File Reference
#include "SphereBVH_Object_Data.h"
#include <vrecko/Ability.h>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APSpacePartitioning::SNCH_Object_Data
struct | APSpacePartitioning::SNCH_Object_Data::VertexSNCH
struct | APSpacePartitioning::SNCH_Object_Data::FaceSNCH
struct | APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
struct | APSpacePartitioning::SNCH_Object_Data::DebugLevelStats
struct | APSpacePartitioning::SNCH_Object_Data::DebugStats

Namespaces

namespace APSpacePartitioning

Macros

#define | SNCH_FACE_DEGENERATED 0x00000001
#define | SNCH_EDGE_CONCAVE_BREAK 0x00000001
#define | FACESNCH_NO_GROUP 0xFFFFFFFF

Macro Definition Documentation

#define FACESNCH_NO_GROUP 0xFFFFFFFF
#define SNCH_EDGE_CONCAVE_BREAK 0x00000001
#define SNCH_FACE_DEGENERATED 0x00000001
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SP_Object_Data_Base.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces
SP_Object_Data_Base.h File Reference
#include <vrecko/SP_ObjectInterface.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class APSpacePartitioning::SP_Object_Data_Base

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
SphereBVH_Object.h File Reference
#include <vrecko/SP_ObjectInterface.h>
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class APSpacePartitioning::SphereBVH_Object

Namespaces

namespace APSpacePartitioning

Macros

#define SP_OBJECT_INTERFACE_ID__SPHEREBVH 10

Macro Definition Documentation

#define SP_OBJECT_INTERFACE_ID__SPHEREBVH 10
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces
SphereBVH_Object_Data.h File Reference
#include "GeometryLoaderBase.h"
#include "SP_Object_Data_Base.h"
#include <vrecko/Ability.h>
#include <osg/Node>
#include <osg/Geode>
#include <osg/Geometry>

Go to the source code of this file.

Classes

class | APSpacePartitioning::SphereBVH_Object_Data
struct | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Scene.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
SphereBVH_Scene.h File Reference
#include <vrecko/SP_SceneInterface.h>
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class APSpacePartitioning::SphereBVH_Scene

Namespaces

namespace APSpacePartitioning

Macros

#define SP_SCENE_INTERFACE_ID__SPHEREBVH 10

Macro Definition Documentation

#define SP_SCENE_INTERFACE_ID__SPHEREBVH 10
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/triangleCube.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Functions
triangleCube.h File Reference
#include <math.h>

Go to the source code of this file.

Classes

struct | Point3
struct | Triangle3

Functions

long | face_plane (Point3 p)
long | bevel_2d (Point3 p)
long | bevel_3d (Point3 p)
long | check_point (Point3 p1, Point3 p2, float alpha, long mask)
long | check_line (Point3 p1, Point3 p2, long outcode_diff)
long | point_triangle_intersection (Point3 p, Triangle3 t)
long | t_c_intersection (Triangle3 t)

Function Documentation

long bevel_2d ( Point3 p )
long bevel_3d ( Point3 p )
long check_line | ( | Point3 | p1,
 |  | Point3 | p2,
 |  | long | outcode_diff
 | ) |  |
long check_point | ( | Point3 | p1,
 |  | Point3 | p2,
 |  | float | alpha,
 |  | long | mask
 | ) |  |
long face_plane ( Point3 p )
long point_triangle_intersection | ( | Point3 | p,
 |  | Triangle3 | t
 | ) |  |
long t_c_intersection ( Triangle3 t )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces
VoxelGrid_Object_Data.h File Reference
#include "GeometryLoaderBase.h"
#include <vrecko/Ability.h>
#include <vrecko/SP_ObjectInterface.h>
#include <helpers/BufFile.h>
#include <osg/BoundingBox>

Go to the source code of this file.

Classes

class APSpacePartitioning::VoxelGrid_Object_Data

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput Directory Reference

  • include
  • vreckoAP
  • TextOutput
TextOutput Directory Reference

Files

file | AP_TextOutput.h [code]
file | Console.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/AP_TextOutput.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • TextOutput
Functions
AP_TextOutput.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/Console.h File Reference

  • File List
  • File Members
  • include
  • vreckoAP
  • TextOutput
Classes | Namespaces | Macros
Console.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Timer.h>
#include <osg/Geode>
#include <osgText/Text>
#include <osgText/Font>
#include <osg/BlendFunc>
#include <osg/Material>
#include <osg/StateSet>
#include <osg/Camera>
#include <vector>
#include "../ObjectUtils/Animator.h"

Go to the source code of this file.

Classes

class | APTextOutput::Console
class | APTextOutput::Console::Line

Namespaces

namespace APTextOutput

Macros

#define | CONSOLE_NO_ANIMATOR
#define | CONSOLE_WINDOW_DEPTH -1000.0f
#define | CONSOLE_BORDER_X_RATIO 0.3f
#define | CONSOLE_BORDER_Y_RATIO CONSOLE_BORDER_X_RATIO
#define | CONSOLE_LINE_SPACE_CHAR_RATIO 0.3f
#define | CONSOLE_FONT "fonts/arial.ttf"
#define | CONSOLE_CHAR_SIZE 15
#define | CONSOLE_TEXTCOLOR_NOTICE (osg::Vec4(1.0f, 1.0f, 1.0f, 1.0f))
#define | CONSOLE_TEXTCOLOR_WARNING (osg::Vec4(1.0f, 1.0f, 0.0f, 1.0f))
#define | CONSOLE_TEXTCOLOR_ERROR (osg::Vec4(1.0f, 0.5f, 0.5f, 1.0f))
#define | CONSOLE_TEXTCOLOR_DEBUG (osg::Vec4(0.3f, 1.0f, 0.3f, 1.0f))

Macro Definition Documentation

#define CONSOLE_BORDER_X_RATIO 0.3f
#define CONSOLE_BORDER_Y_RATIO CONSOLE_BORDER_X_RATIO
#define CONSOLE_CHAR_SIZE 15
#define CONSOLE_FONT "fonts/arial.ttf"
#define CONSOLE_LINE_SPACE_CHAR_RATIO 0.3f
#define CONSOLE_NO_ANIMATOR
#define CONSOLE_TEXTCOLOR_DEBUG (osg::Vec4(0.3f, 1.0f, 0.3f, 1.0f))
#define CONSOLE_TEXTCOLOR_ERROR (osg::Vec4(1.0f, 0.5f, 0.5f, 1.0f))
#define CONSOLE_TEXTCOLOR_NOTICE (osg::Vec4(1.0f, 1.0f, 1.0f, 1.0f))
#define CONSOLE_TEXTCOLOR_WARNING (osg::Vec4(1.0f, 1.0f, 0.0f, 1.0f))
#define CONSOLE_WINDOW_DEPTH -1000.0f
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP Directory Reference

  • include
  • vreckoDP
vreckoDP Directory Reference

Directories

directory | base
directory | Kinect
directory | PHANToM
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base Directory Reference

  • include
  • vreckoDP
  • base
base Directory Reference

Files

file | A3DBird.h [code]
file | arm.h [code]
file | classes.h [code]
file | DP_base.h [code]
file | fdtDataGlove.h [code]
file | fsPinchGlove.h [code]
file | hci.h [code]
file | KeyboardMouse.h [code]
file | L3DMouse.h [code]
file | LHeadTracker.h [code]
file | MicroScribe3D.h [code]
file | NestOfBirds.h [code]
file | OptiTrack.h [code]
file | Ultratrak.h [code]
file | VRPN3DMouse.h [code]
file | Wiimote.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/A3DBird.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces
A3DBird.h File Reference
#include <vrecko/Device.h>

Go to the source code of this file.

Classes

class vreckoDP_base::A3DBird

Namespaces

namespace vreckoDP_base
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/arm.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Macros | Typedefs | Functions | Variables
arm.h File Reference
#include "classes.h"
#include "hci.h"

Go to the source code of this file.

Classes

struct | length_3D
struct | angle_3D
class | Arm

Macros

#define | NUM_DOF 6
#define | QUICK_3DOF_POINTS 4
#define | STD_3DOF_POINTS 4
#define | NUM_TABLE_POS 4
#define | PARAM_BLOCK_SIZE 40
#define | EXT_PARAM_BLOCK_SIZE 10
#define | PI 3.1415926535898
#define | RIGHT_PEDAL 1
#define | LEFT_PEDAL 2
#define | BOTH_PEDALS 3
#define | BASE 0
#define | SHOULDER 1
#define | ELBOW 2
#define | FOREARM 3
#define | WRIST 4
#define | STYLUS 5

Typedefs

typedef float | length
typedef float | angle
typedef float | ratio
typedef float | matrix_4 [4][4]
typedef char * | length_units
typedef char * | angle_units
typedef char * | angle_format

Functions

arm_result | simple_NO_HCI (arm_result condition)
arm_result | simple_CANT_BEGIN (arm_result condition)
arm_result | simple_CANT_OPEN_PORT (arm_result condition)
arm_result | simple_TIMED_OUT (arm_result condition)
arm_result | simple_BAD_PORT (arm_result condition)
arm_result | simple_BAD_PACKET (arm_result condition)

Variables

char | INCHES []
char | MM []
char | DEGREES []
char | RADIANS []
char | XYZ_FIXED []
char | ZYX_FIXED []
char | YXZ_FIXED []
char | ZYX_EULER []
char | XYZ_EULER []
char | ZXY_EULER []

Macro Definition Documentation

#define BASE 0
#define BOTH_PEDALS 3
#define ELBOW 2
#define EXT_PARAM_BLOCK_SIZE 10
#define FOREARM 3
#define LEFT_PEDAL 2
#define NUM_DOF 6
#define NUM_TABLE_POS 4
#define PARAM_BLOCK_SIZE 40
#define PI 3.1415926535898
#define QUICK_3DOF_POINTS 4
#define RIGHT_PEDAL 1
#define SHOULDER 1
#define STD_3DOF_POINTS 4
#define STYLUS 5
#define WRIST 4

Typedef Documentation

typedef float angle
typedef char* angle_format
typedef char* angle_units
typedef float length
typedef char* length_units
typedef float matrix_4[4][4]
typedef float ratio

Function Documentation

arm_result simple_BAD_PACKET ( arm_result condition )
arm_result simple_BAD_PORT ( arm_result condition )
arm_result simple_CANT_BEGIN ( arm_result condition )
arm_result simple_CANT_OPEN_PORT ( arm_result condition )
arm_result simple_NO_HCI ( arm_result condition )
arm_result simple_TIMED_OUT ( arm_result condition )

Variable Documentation

char DEGREES[]
char INCHES[]
char MM[]
char RADIANS[]
char XYZ_EULER[]
char XYZ_FIXED[]
char YXZ_FIXED[]
char ZXY_EULER[]
char ZYX_EULER[]
char ZYX_FIXED[]
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/classes.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Macros | Typedefs
classes.h File Reference
#include <termio.h>

Go to the source code of this file.

Classes

class | Timing
class | Serial

Macros

#define | BAUD 38400
#define | BAUDCODE B38400
#define | dbg(what)
#define | dbgdf(what)
#define | dbgsf(what)
#define | MIN_TIMEOUT 100
#define | FRAME_BUF_SIZE 240

Typedefs

typedef char * | hci_result
typedef hci_result | arm_result
typedef unsigned char | byte

Macro Definition Documentation

#define BAUD 38400
#define BAUDCODE B38400
#define dbg ( what )
#define dbgdf ( what )
#define dbgsf ( what )
#define FRAME_BUF_SIZE 240
#define MIN_TIMEOUT 100

Typedef Documentation

typedef hci_result arm_result
typedef unsigned char byte
typedef char* hci_result
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/DP_base.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Macros | Functions
DP_base.h File Reference
#include <vrecko/Device.h>
#include <vreckoDP/Export>
#include "A3DBird.h"
#include "fdtDataGlove.h"
#include "fsPinchGlove.h"
#include "KeyboardMouse.h"
#include "LHeadTracker.h"
#include "L3DMouse.h"
#include "MicroScribe3D.h"
#include "NestOfBirds.h"
#include "Ultratrak.h"
#include "OptiTrack.h"
#include "VRPN3DMouse.h"
#include "Wiimote.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char DP_EXPORT ** | base_getDeviceList (void)
Device DP_EXPORT * | base_getDeviceInstance (const char *_name)
const char DP_EXPORT * | base_getDeviceDescription (const char *name)
void DP_EXPORT | base_setDevicesParameters (void)
const char DP_EXPORT * | base_getPluginDescription (void)

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char DP_EXPORT* base_getDeviceDescription ( const char * name )
Device DP_EXPORT* base_getDeviceInstance ( const char * _name )
const char DP_EXPORT** base_getDeviceList ( void )
const char DP_EXPORT* base_getPluginDescription ( void )
void DP_EXPORT base_setDevicesParameters ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fdtDataGlove.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces
fdtDataGlove.h File Reference
#include <vrecko/Device.h>
#include <map>

Go to the source code of this file.

Classes

class vreckoDP_base::fdtDataGlove

Namespaces

namespace vreckoDP_base
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fsPinchGlove.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros
fsPinchGlove.h File Reference
#include <map>
#include <iostream>
#include <vrecko/Device.h>
#include <vrecko/IOPins.h>

Go to the source code of this file.

Classes

struct | vreckoDP_base::dataT
class | vreckoDP_base::fsPinchGlove

Namespaces

namespace vreckoDP_base

Macros

#define | STARTBYTE (char)0x80 /* Start - hand data only */
#define | STARTTBYTE (char)0x81 /* Start - hand data & Time stamps */
#define | STARTXBYTE (char)0x82 /* Start - text or ACK */
#define | ENDBYTE (char)0x8F /* End of a message */
#define | CONNECTBYTE (char)0x87 /* Opent the connection */
#define | CLOSEBYTE (char)0x88 /* Close the connection */
#define | DEF_PGI_PORT 6666 /* Default TCP port */
#define | DEF_PGI_SERIAL "/dev/ttyS1" /* Default serial port */
#define | PGI_MAX_PACKET_LEN 14
#define | L_THUMB (int)0x0010
#define | L_INDEX (int)0x0008
#define | L_MIDDLE (int)0x0004
#define | L_RING (int)0x0002
#define | L_PINKIE (int)0x0001
#define | R_THUMB (int)0x0010
#define | R_INDEX (int)0x0008
#define | R_MIDDLE (int)0x0004
#define | R_RING (int)0x0002
#define | R_PINKIE (int)0x0001
#define | OK 1
#define | ERR -1
#define | YES 1
#define | NO 0
#define | if_ok(param) if( ( param ) == OK )
#define | if_notok(param) if( ( param ) != OK )
#define | if_err(param) if( ( param ) < 0 )
#define | if_null(param) if( ( param ) == NULL )
#define | if_nonull(param) if( ( param ) != NULL )

Macro Definition Documentation

#define CLOSEBYTE (char)0x88 /* Close the connection */
#define CONNECTBYTE (char)0x87 /* Opent the connection */
#define DEF_PGI_PORT 6666 /* Default TCP port */
#define DEF_PGI_SERIAL "/dev/ttyS1" /* Default serial port */
#define ENDBYTE (char)0x8F /* End of a message */
#define ERR -1
#define if_err ( param ) if( ( param ) < 0 )
#define if_nonull ( param ) if( ( param ) != NULL )
#define if_notok ( param ) if( ( param ) != OK )
#define if_null ( param ) if( ( param ) == NULL )
#define if_ok ( param ) if( ( param ) == OK )
#define L_INDEX (int)0x0008
#define L_MIDDLE (int)0x0004
#define L_PINKIE (int)0x0001
#define L_RING (int)0x0002
#define L_THUMB (int)0x0010
#define NO 0
#define OK 1
#define PGI_MAX_PACKET_LEN 14
#define R_INDEX (int)0x0008
#define R_MIDDLE (int)0x0004
#define R_PINKIE (int)0x0001
#define R_RING (int)0x0002
#define R_THUMB (int)0x0010
#define STARTBYTE (char)0x80 /* Start - hand data only */
#define STARTTBYTE (char)0x81 /* Start - hand data & Time stamps */
#define STARTXBYTE (char)0x82 /* Start - text or ACK */
#define YES 1
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/hci.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Macros | Variables
hci.h File Reference
#include "classes.h"

Go to the source code of this file.

Classes

struct | packet_rec
class | Hci

Macros

#define | HCI_CHECK_FGND 1
#define | HCI_CHECK_BGND 2
#define | HCI_CHECK_MOTION 3
#define | NUM_ENCODERS 7 /* Max # encoders supported by Immersion HCI */
#define | NUM_ANALOGS 8 /* Max # of A/D channels supported */
#define | NUM_BUTTONS 7 /* Max # of buttons supported */
#define | MAX_PACKET_SIZE 42
#define | MAX_CFG_SIZE 40
#define | MAX_STRING_SIZE 32
#define | CMD_BYTE(t, anlg, encd)
#define | CONFIG_MIN 0xC0 /* Minimum cmd byte for a config cmd */
#define | GET_PARAMS 0xC0
#define | GET_HOME_REF 0xC1
#define | HOME_POS 0xC2
#define | SET_HOME 0xC3
#define | SET_BAUD 0xC4
#define | END_SESSION 0xC5
#define | GET_MAXES 0xC6
#define | SET_PARAMS 0xC7
#define | GET_PROD_NAME 0xC8
#define | GET_PROD_ID 0xC9
#define | GET_MODEL_NAME 0xCA
#define | GET_SERNUM 0xCB
#define | GET_COMMENT 0xCC
#define | GET_PRM_FORMAT 0xCD
#define | GET_VERSION 0xCE
#define | REPORT_MOTION 0xCF
#define | SET_HOME_REF 0xD0
#define | RESTORE_FACTORY 0xD1
#define | INSERT_MARKER 0xD2
#define | GET_EXT_PARAMS 0xD3
#define | PACKET_MARKER 0x80
#define | CONFIG_BIT 0x40
#define | TIMER_BIT 0x20
#define | FUTURE_BIT 0x10
#define | ANALOG_BITS 0x0C
#define | ANALOG_HI_BIT 0x08
#define | ANALOG_LO_BIT 0x04
#define | ENCODER_BITS 0x03
#define | ENCODER_HI_BIT 0x02
#define | ENCODER_LO_BIT 0x01
#define | TIMEOUT_CHARS 2*MAX_PACKET_SIZE
#define | SIGNON_PAUSE 15
#define | END_PAUSE 15
#define | CFG_ARG_PAUSE 15
#define | RESTORE_PAUSE 2000
#define | PASSWD_OK 0xFF

Variables

char | BAD_PORT_NUM []
char | CANT_OPEN_PORT []
char | NO_HCI []
char | CANT_BEGIN []
char | NO_PACKET_YET []
char | TIMED_OUT []
char | BAD_PACKET []
char | BAD_PASSWORD []
char | SUCCESS []
char | TRY__AGAIN []
char | BAD_VERSION []
char | BAD_FORMAT []
byte cfg_args [MAX_CFG_SIZE]
int | num_cfg_args

Macro Definition Documentation

#define ANALOG_BITS 0x0C
#define ANALOG_HI_BIT 0x08
#define ANALOG_LO_BIT 0x04
#define CFG_ARG_PAUSE 15
#define CMD_BYTE | ( | t,
 |  | anlg,
 |  | encd
 | ) |
Value:
( (t ? TIMER_BIT : 0) \
| (anlg > 4 ? ANALOG_BITS : \
(anlg > 2 ? ANALOG_HI_BIT : \
(anlg ? ANALOG_LO_BIT : 0))) \
| (encd > 6 ? ENCODER_HI_BIT : \
(encd > 5 ? ENCODER_BITS : \
(encd ? ENCODER_LO_BIT : 0))) )
#define CONFIG_BIT 0x40
#define CONFIG_MIN 0xC0 /* Minimum cmd byte for a config cmd */
#define ENCODER_BITS 0x03
#define ENCODER_HI_BIT 0x02
#define ENCODER_LO_BIT 0x01
#define END_PAUSE 15
#define END_SESSION 0xC5
#define FUTURE_BIT 0x10
#define GET_COMMENT 0xCC
#define GET_EXT_PARAMS 0xD3
#define GET_HOME_REF 0xC1
#define GET_MAXES 0xC6
#define GET_MODEL_NAME 0xCA
#define GET_PARAMS 0xC0
#define GET_PRM_FORMAT 0xCD
#define GET_PROD_ID 0xC9
#define GET_PROD_NAME 0xC8
#define GET_SERNUM 0xCB
#define GET_VERSION 0xCE
#define HCI_CHECK_BGND 2
#define HCI_CHECK_FGND 1
#define HCI_CHECK_MOTION 3
#define HOME_POS 0xC2
#define INSERT_MARKER 0xD2
#define MAX_CFG_SIZE 40
#define MAX_PACKET_SIZE 42
#define MAX_STRING_SIZE 32
#define NUM_ANALOGS 8 /* Max # of A/D channels supported */
#define NUM_BUTTONS 7 /* Max # of buttons supported */
#define NUM_ENCODERS 7 /* Max # encoders supported by Immersion HCI */
#define PACKET_MARKER 0x80
#define PASSWD_OK 0xFF
#define REPORT_MOTION 0xCF
#define RESTORE_FACTORY 0xD1
#define RESTORE_PAUSE 2000
#define SET_BAUD 0xC4
#define SET_HOME 0xC3
#define SET_HOME_REF 0xD0
#define SET_PARAMS 0xC7
#define SIGNON_PAUSE 15
#define TIMEOUT_CHARS 2*MAX_PACKET_SIZE
#define TIMER_BIT 0x20

Variable Documentation

char BAD_FORMAT[]
char BAD_PACKET[]
char BAD_PASSWORD[]
char BAD_PORT_NUM[]
char BAD_VERSION[]
char CANT_BEGIN[]
char CANT_OPEN_PORT[]
byte cfg_args[MAX_CFG_SIZE]
char NO_HCI[]
char NO_PACKET_YET[]
int num_cfg_args
char SUCCESS[]
char TIMED_OUT[]
char TRY__AGAIN[]
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/KeyboardMouse.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces
KeyboardMouse.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <osgGA/GUIEventHandler>
#include <osg/Vec2>
#include <osg/Timer>

Go to the source code of this file.

Classes

class vreckoDP_base::KeyboardMouse

Namespaces

namespace vreckoDP_base
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/L3DMouse.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces
L3DMouse.h File Reference
#include "LHeadTracker.h"

Go to the source code of this file.

Classes

class vreckoDP_base::L3DMouse

Namespaces

namespace vreckoDP_base
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/LHeadTracker.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros | Enumerations
LHeadTracker.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Quat>
#include <setjmp.h>

Go to the source code of this file.

Classes

class vreckoDP_base::LHeadTracker

Namespaces

namespace vreckoDP_base

Macros

#define | HTI_CONNECTBYTE (char)0x87 /* Open the connection */
#define | HTI_CLOSEBYTE (char)0x88 /* Close the connection */
#define | HTD_COMMAND_LEN 2
#define | HTD_CMD_RESET "*R"
#define | HTD_CMD_DIAG "*\005"
#define | HTD_CMD_REPORT "*d"
#define | HTD_CMD_DEMAND "*D"
#define | HTD_PACKET_LEN 16
#define | HTI_MAX_NUM 1048575 /* max. returned positon */
#define | HTI_2MAX_NUM 2097150 /* 2*HTI_MAX_NUM */
#define | HTI_MIN_POS_DIFF 20 /* min. position difference */
#define | HTI_MIN_ROT_DIFF 80 /* min. rotation difference */
#define | HTI_POS_C 0.0005
#define | HTI_ROT_C 40.0
#define | SLAVE_MODE 1
#define | MASTER_MODE 2
#define | CMD_TYPE_SLAVE_XMITTER_TYPE 1
#define | CMD_TYPE_FILTER_POINT 7
#define | CMD_TYPE_RCVR_DIMENSIONS 8
#define | htd_flush(port_fd) ioctl( port_fd, TCFLSH, 2 )
#define | if_err(param) if( ( param ) < 0 )

Enumerations

enum | vreckoDP_base::htd_receiver_pos { vreckoDP_base::HTD_REC_POS_OUT = 0, vreckoDP_base::HTD_REC_POS_ACT, vreckoDP_base::HTD_REC_POS_FRI }
enum | vreckoDP_base::rotation_type { vreckoDP_base::QUATERNION = 0, vreckoDP_base::MATRIX, vreckoDP_base::ANGLES }

Macro Definition Documentation

#define CMD_TYPE_FILTER_POINT 7
#define CMD_TYPE_RCVR_DIMENSIONS 8
#define CMD_TYPE_SLAVE_XMITTER_TYPE 1
#define HTD_CMD_DEMAND "*D"
#define HTD_CMD_DIAG "*\005"
#define HTD_CMD_REPORT "*d"
#define HTD_CMD_RESET "*R"
#define HTD_COMMAND_LEN 2
#define htd_flush ( port_fd ) ioctl( port_fd, TCFLSH, 2 )
#define HTD_PACKET_LEN 16
#define HTI_2MAX_NUM 2097150 /* 2*HTI_MAX_NUM */
#define HTI_CLOSEBYTE (char)0x88 /* Close the connection */
#define HTI_CONNECTBYTE (char)0x87 /* Open the connection */
#define HTI_MAX_NUM 1048575 /* max. returned positon */
#define HTI_MIN_POS_DIFF 20 /* min. position difference */
#define HTI_MIN_ROT_DIFF 80 /* min. rotation difference */
#define HTI_POS_C 0.0005
#define HTI_ROT_C 40.0
#define if_err ( param ) if( ( param ) < 0 )
#define MASTER_MODE 2
#define SLAVE_MODE 1
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/MicroScribe3D.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces
MicroScribe3D.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Vec3>
#include <osg/Quat>
#include "classes.h"
#include "arm.h"

Go to the source code of this file.

Classes

class vreckoDP_base::MicroScribe3D

Namespaces

namespace vreckoDP_base
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/NestOfBirds.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros
NestOfBirds.h File Reference
#include <errno.h>
#include <fcntl.h>
#include <math.h>
#include <netdb.h>
#include <pthread.h>
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <netinet/in.h>
#include <sys/ioctl.h>
#include <sys/mman.h>
#include <sys/socket.h>
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/time.h>
#include <arpa/inet.h>
#include <sys/wait.h>
#include <strings.h>
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Quat>

Go to the source code of this file.

Classes

class vreckoDP_base::NestOfBirds

Namespaces

namespace vreckoDP_base

Macros

#define BUFSIZE 1000

Macro Definition Documentation

#define BUFSIZE 1000
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/OptiTrack.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros
OptiTrack.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Quat>
#include "vrpn_Connection.h"
#include "vrpn_Tracker.h"

Go to the source code of this file.

Classes

class | vreckoDP_base::OptiTrack
struct | vreckoDP_base::OptiTrack::info_struct

Namespaces

namespace vreckoDP_base

Macros

#define TRACKER_MAX_COUNT 12

Macro Definition Documentation

#define TRACKER_MAX_COUNT 12
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Ultratrak.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros
Ultratrak.h File Reference
#include <errno.h>
#include <fcntl.h>
#include <math.h>
#include <netdb.h>
#include <pthread.h>
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <netinet/in.h>
#include <sys/ioctl.h>
#include <sys/mman.h>
#include <sys/socket.h>
#include <sys/stat.h>
#include <sys/types.h>
#include <sys/time.h>
#include <arpa/inet.h>
#include <sys/wait.h>
#include <strings.h>
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Quat>

Go to the source code of this file.

Classes

class vreckoDP_base::Ultratrak

Namespaces

namespace vreckoDP_base

Macros

#define | POLHEMUS_PORT 5555
#define | POLHEMUS_PORT2 5555
#define | POLHEMUS_HEADER "Frame %3d FrameSize %3d HeaderSize %3d RecordSize %3d \r\n"
#define | BUFSIZE 1000

Macro Definition Documentation

#define BUFSIZE 1000
#define POLHEMUS_HEADER "Frame %3d FrameSize %3d HeaderSize %3d RecordSize %3d \r\n"
#define POLHEMUS_PORT 5555
#define POLHEMUS_PORT2 5555
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/VRPN3DMouse.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Enumerations | Variables
VRPN3DMouse.h File Reference
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <vrpn_Analog.h>
#include <vrpn_Button.h>

Go to the source code of this file.

Classes

class vreckoDP_base::VRPN3DMouse

Namespaces

namespace vreckoDP_base

Enumerations

enum vreckoDP_base::virtualKeyCode {
vreckoDP_base::V3DK_MENU =0, vreckoDP_base::V3DK_FIT, vreckoDP_base::V3DK_TOP, vreckoDP_base::V3DK_LEFT,
vreckoDP_base::V3DK_RIGHT, vreckoDP_base::V3DK_FRONT, vreckoDP_base::V3DK_BOTTOM, vreckoDP_base::V3DK_BACK,
vreckoDP_base::V3DK_CW, vreckoDP_base::V3DK_CCW, vreckoDP_base::V3DK_ISO1, vreckoDP_base::V3DK_ISO2,
vreckoDP_base::V3DK_1, vreckoDP_base::V3DK_2, vreckoDP_base::V3DK_3, vreckoDP_base::V3DK_4,
vreckoDP_base::V3DK_5, vreckoDP_base::V3DK_6, vreckoDP_base::V3DK_7, vreckoDP_base::V3DK_8,
vreckoDP_base::V3DK_9, vreckoDP_base::V3DK_10, vreckoDP_base::V3DK_ESC, vreckoDP_base::V3DK_ALT,
vreckoDP_base::V3DK_SHIFT, vreckoDP_base::V3DK_CTRL, vreckoDP_base::V3DK_ROTATE, vreckoDP_base::V3DK_PANZOOM,
vreckoDP_base::V3DK_DOMINANT, vreckoDP_base::V3DK_PLUS, vreckoDP_base::V3DK_MINUS
}

Variables

const std::string vreckoDP_base::virtualKey []
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Wiimote.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Classes | Namespaces | Macros
Wiimote.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <unistd.h>
#include <wiiuse.h>
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Vec3>
#include <osg/Quat>

Go to the source code of this file.

Classes

class vreckoDP_base::Wiimote

Namespaces

namespace vreckoDP_base

Macros

#define MAX_WIIMOTES 4

Macro Definition Documentation

#define MAX_WIIMOTES 4
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect Directory Reference

  • include
  • vreckoDP
  • Kinect
Kinect Directory Reference

Files

file | DP_Kinect.h [code]
file | Kinect.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect/DP_Kinect.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • Kinect
Macros | Functions
DP_Kinect.h File Reference
#include <vrecko/Device.h>
#include <vreckoDP/Export>

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char DP_EXPORT ** | getDeviceList (void)
vrecko::Device DP_EXPORT * | getDeviceInstance (const char *_name)
const char DP_EXPORT * | getDeviceDescription (const char *name)
void DP_EXPORT | setDevicesParameters (void)
const char DP_EXPORT * | getPluginDescription (void)

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char DP_EXPORT* getDeviceDescription ( const char * name )
vrecko::Device DP_EXPORT* getDeviceInstance ( const char * _name )
const char DP_EXPORT** getDeviceList ( void )
const char DP_EXPORT* getPluginDescription ( void )
void DP_EXPORT setDevicesParameters ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect/Kinect.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • Kinect
Classes | Namespaces | Macros
Kinect.h File Reference
#include <windows.h>
#include <vrecko/IOPins.h>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <NuiApi.h>
#include <NuiSkeleton.h>

Go to the source code of this file.

Classes

class vreckoDP_Kinect::Kinect

Namespaces

namespace vreckoDP_Kinect

Macros

#define WIN32_LEAN_AND_MEAN

Macro Definition Documentation

#define WIN32_LEAN_AND_MEAN

Kinect.h - device class

This class provides interface with Microsoft Kinect device

Author
Martin Bezdeka (marti.nosp@m.n.be.nosp@m.zdeka.nosp@m.@gma.nosp@m.il.co.nosp@m.m)
Date
$Id$
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM Directory Reference

  • include
  • vreckoDP
  • PHANToM
PHANToM Directory Reference

Files

file | DP_PHANToM.h [code]
file | PHANToM_compile.inc
file | PHANToM_Device.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM/DP_PHANToM.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • PHANToM
Macros | Functions
DP_PHANToM.h File Reference
#include <vrecko/Device.h>
#include <vreckoDP/Export>

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char DP_EXPORT ** | PHANToM_getDeviceList (void)
vrecko::Device DP_EXPORT * | PHANToM_getDeviceInstance (const char *_name)
const char DP_EXPORT * | PHANToM_getDeviceDescription (const char *name)
void DP_EXPORT | PHANToM_setDevicesParameters (void)
const char DP_EXPORT * | PHANToM_getPluginDescription (void)

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char DP_EXPORT* PHANToM_getDeviceDescription ( const char * name )
vrecko::Device DP_EXPORT* PHANToM_getDeviceInstance ( const char * _name )
const char DP_EXPORT** PHANToM_getDeviceList ( void )
const char DP_EXPORT* PHANToM_getPluginDescription ( void )
void DP_EXPORT PHANToM_setDevicesParameters ( void )
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM/PHANToM_compile.inc File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • PHANToM
PHANToM_compile.inc File Reference
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM/PHANToM_Device.h File Reference

  • File List
  • File Members
  • include
  • vreckoDP
  • PHANToM
PHANToM_Device.h File Reference
#include "PHANToM_compile.inc"

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils Directory Reference

  • include
  • vreckoUtils
vreckoUtils Directory Reference

Files

file | HighlightCallback.h [code]
file | Math.h [code]
file | Menu.h [code]
file | Observer.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/HighlightCallback.h File Reference

  • File List
  • File Members
  • include
  • vreckoUtils
Classes | Namespaces
HighlightCallback.h File Reference
#include <osg\NodeCallback>
#include <osg\Material>
#include "Export"

Go to the source code of this file.

Classes

class vreckoUtils::HighlightCallback

Namespaces

namespace vreckoUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Math.h File Reference

  • File List
  • File Members
  • include
  • vreckoUtils
Classes | Namespaces
Math.h File Reference
#include "Export"

Go to the source code of this file.

Classes

class vreckoUtils::Math

Namespaces

namespace vreckoUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h File Reference

  • File List
  • File Members
  • include
  • vreckoUtils
Classes | Namespaces | Typedefs
Menu.h File Reference
#include <vreckoUtils/Export>

Go to the source code of this file.

Classes

class | vreckoUtils::MenuCommon
class | vreckoUtils::IMenuComponent
class | vreckoUtils::MenuBase
class | vreckoUtils::MenuRoot
class | vreckoUtils::Menu
class | vreckoUtils::MenuItem
class | vreckoUtils::MenuSlider
class | vreckoUtils::MenuVisitor

Namespaces

namespace vreckoUtils

Typedefs

typedef std::vector
< osg::ref_ptr< IMenuComponent >
>::const_iterator 		vreckoUtils::IMenuComponentIter
typedef osg::ref_ptr< Menu > vreckoUtils::MenuPtr
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Observer.h File Reference

  • File List
  • File Members
  • include
  • vreckoUtils
Classes | Namespaces
Observer.h File Reference
#include "Export"
#include <vector>
#include <algorithm>

Go to the source code of this file.

Classes

class | vreckoUtils::Observer
class | vreckoUtils::Observable

Namespaces

namespace vreckoUtils
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src Directory Reference

  • src
src Directory Reference

Directories

directory | apps
directory | base
directory | helpers
directory | vrecko
directory | vreckoAP
directory | vreckoDP
directory | vreckoUtils
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps Directory Reference

  • src
  • apps
apps Directory Reference

Directories

directory vreckoApp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp Directory Reference

  • src
  • apps
  • vreckoApp
vreckoApp Directory Reference

Files

file | LoadingConsole.cpp
file | LoadingConsole.h [code]
file | Main.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.cpp File Reference

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
Macros | Functions
LoadingConsole.cpp File Reference
#include "LoadingConsole.h"
#include <vreckoAP/TextOutput/Console.h>

Macros

#define | CONSOLE_WINDOW_WIDTH_RATIO 0.95f
#define | CONSOLE_WINDOW_HEIGHT_RATIO 0.5f
#define | CONSOLE_WINDOW_HEIGHT_BORDER_RATIO ((1.0f - CONSOLE_WINDOW_WIDTH_RATIO) / 2.0f)
#define | LOADINGCONSOLE_TEXTCOLOR_NOTICE CONSOLE_TEXTCOLOR_NOTICE
#define | LOADINGCONSOLE_TEXTCOLOR_WARNING CONSOLE_TEXTCOLOR_WARNING
#define | LOADINGCONSOLE_TEXTCOLOR_ERROR CONSOLE_TEXTCOLOR_ERROR
#define | LOADINGCONSOLE_TEXTCOLOR_DEBUG CONSOLE_TEXTCOLOR_DEBUG
#define | LOADING_CONSOLE_REAL_LINE_HEIGHT_RATIO 0.85f

Functions

void loggerLoadingConsoleOutput (unsigned long dwOutputType, const char *outputLine, void *userParam)

Macro Definition Documentation

#define CONSOLE_WINDOW_HEIGHT_BORDER_RATIO ((1.0f - CONSOLE_WINDOW_WIDTH_RATIO) / 2.0f)
#define CONSOLE_WINDOW_HEIGHT_RATIO 0.5f
#define CONSOLE_WINDOW_WIDTH_RATIO 0.95f
#define LOADING_CONSOLE_REAL_LINE_HEIGHT_RATIO 0.85f
#define LOADINGCONSOLE_TEXTCOLOR_DEBUG CONSOLE_TEXTCOLOR_DEBUG
#define LOADINGCONSOLE_TEXTCOLOR_ERROR CONSOLE_TEXTCOLOR_ERROR
#define LOADINGCONSOLE_TEXTCOLOR_NOTICE CONSOLE_TEXTCOLOR_NOTICE
#define LOADINGCONSOLE_TEXTCOLOR_WARNING CONSOLE_TEXTCOLOR_WARNING

Function Documentation

void loggerLoadingConsoleOutput | ( | unsigned long | dwOutputType,
 |  | const char * | outputLine,
 |  | void * | userParam
 | ) |  |
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.h File Reference

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
Classes
LoadingConsole.h File Reference
#include "precompiled.h"

Go to the source code of this file.

Classes

class | LoadingConsole
class | LoadingConsole::Line
class | LoadingConsole::OutstandingLine
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/Main.cpp File Reference

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
Classes | Macros | Functions | Variables
Main.cpp File Reference
#include "precompiled.h"

Classes

class | MainObject
class | MainSceneUpdateCallback

Macros

#define | PLANE_X 30.0f
#define | PLANE_Y 30.0f
#define | PLANE_Z -0.5f
#define | MAIN_DEBUG_START_TIMING(section)
#define | MAIN_DEBUG_STOP_TIMING(section)

Functions

osg::ref_ptr< osg::Group > | pLoadingScreen (new osg::Group)
void | load_config (void)
void | loadVirtualEnvironment ()
void | cycleLoadingHourglass ()
void | displayStereoInfo (const osg::DisplaySettings *ds)
void | createBackgroundPlane ()
void | createLoadingScreen ()
int | getNumScreens ()
void | mainLoop ()
Main loop. More...
int | main (int argc, char **argv)

Variables

pthread_mutex_t * | loading_section_Mutex
std::string | scenario_name = "net_test.xml"
unsigned int | server_port = 60000
unsigned int | client_port = 60002
osg::ref_ptr< vrecko::ViewerBase > | viewer
osg::Projection * | projection_node = NULL
int | _height = 600
int | _width = 800
bool | _fullscreen = false
int | _stereo = 0
float | _screen_distance = 1.5
float | _eye_separation = 0.06
float | _screen_height = 0.26
float | _screen_width = 0.0
unsigned int | display_frequency = 50
unsigned int | antiAliasSamples = 1
osg::Vec4 | clearColour = osg::Vec4(0.23, 0.208, 0.2196, 1.0)
std::string | config_file = "vrecko.cfg"
std::string | ip_str = "147.251.50.174"
bool | net_flag = false
osg::ref_ptr
< osg::MatrixTransform > 		pTransformation
osg::ref_ptr< osgText::TextBase > | loading_description [3]
osg::ref_ptr
< osg::MatrixTransform > 		pMovingTransformation [2]
unsigned int | loading_state
MainObject * mainObject
std::vector< std::string > | VE_names
float | loading_position
std::string | loading_category
osg::Timer_t | last_tick
LoadingConsole * | loadingConsole = NULL

Macro Definition Documentation

#define MAIN_DEBUG_START_TIMING ( section )
#define MAIN_DEBUG_STOP_TIMING ( section )
#define PLANE_X 30.0f
#define PLANE_Y 30.0f
#define PLANE_Z -0.5f

Function Documentation

void createBackgroundPlane ( )
void createLoadingScreen ( )
void cycleLoadingHourglass ( )
void displayStereoInfo ( const osg::DisplaySettings * ds )
int getNumScreens ( )
void load_config ( void )
void loadVirtualEnvironment ( )
int main | ( | int | argc,
 |  | char ** | argv
 | ) |  |

< This code may explicilty throw an exception to signalize a problem. The exception will have meaningful description included.

void mainLoop ( )

Main loop.

osg::ref_ptr<osg::Group> pLoadingScreen ( new osg::Group )

Variable Documentation

float _eye_separation = 0.06
bool _fullscreen = false
int _height = 600
float _screen_distance = 1.5
float _screen_height = 0.26
float _screen_width = 0.0
int _stereo = 0
int _width = 800
unsigned int antiAliasSamples = 1
osg::Vec4 clearColour = osg::Vec4(0.23, 0.208, 0.2196, 1.0)
unsigned int client_port = 60002
std::string config_file = "vrecko.cfg"
unsigned int display_frequency = 50
std::string ip_str = "147.251.50.174"
osg::Timer_t last_tick
std::string loading_category
osg::ref_ptr<osgText::TextBase> loading_description[3]
float loading_position
pthread_mutex_t* loading_section_Mutex
unsigned int loading_state
LoadingConsole* loadingConsole = NULL
MainObject* mainObject
bool net_flag = false
osg::ref_ptr<osg::MatrixTransform> pMovingTransformation[2]
osg::Projection* projection_node = NULL
osg::ref_ptr<osg::MatrixTransform> pTransformation
std::string scenario_name = "net_test.xml"
unsigned int server_port = 60000
std::vector<std::string> VE_names
osg::ref_ptr<vrecko::ViewerBase> viewer
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/precompiled.h File Reference

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
precompiled.h File Reference
#include <osg/Material>
#include <osg/BlendFunc>
#include <osg/ShapeDrawable>
#include <osg/io_utils>
#include <osg/State>
#include <osg/Geometry>
#include <osg/PrimitiveSet>
#include <osgViewer/ViewerEventHandlers>
#include <osgViewer/api/Win32/GraphicsWindowWin32>
#include <osgText/Text3D>
#include <osgUtil/SmoothingVisitor>
#include <osg/ClipNode>
#include <osgDB/ReadFile>
#include <vrecko/World.h>
#include <vrecko/Viewer.h>
#include <vrecko/DeviceManager.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vreckoDP/base/KeyboardMouse.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <base/SystemInfo.h>
#include <errno.h>
#include <vrecko/vThread.h>
#include "LoadingConsole.h"

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base Directory Reference

  • src
  • base
base Directory Reference

Files

file | AP_base.cpp
file | Avatar.cpp
file | Display.cpp
file | hand.cpp
file | Light.cpp
file | MouseHand.cpp
file | MTMatrixTransform.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Rotate.cpp
file | ShowFDH.cpp
file | ShowFDHModel.cpp
file | SystemInfo.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/AP_base.cpp File Reference

  • File List
  • File Members
  • src
  • base
Functions | Variables
AP_base.cpp File Reference
#include "precompiled.h"
#include <string.h>
#include <base/AP_base.h>
#include <base/MTMatrixTransform.h>

Functions

const char * | getPluginDescription (void)
const char ** | getAbilityList (void)
const char * | getAbilityDescription (const char *name)
Ability * | getAbilityInstance (const char *_name)
void | setAbilitiesParameters (void)

Variables

const char * | plugin_name = { "base" }
const char * | ability_name []
const char * | ability_description []
Ability * _new_ability

Function Documentation

const char* getAbilityDescription ( const char * name )
Ability* getAbilityInstance ( const char * _name )
const char** getAbilityList ( void )
const char* getPluginDescription ( void )
void setAbilitiesParameters ( void )

Variable Documentation

Ability* _new_ability
const char* ability_description[]
Initial value:
= {
"Display any text message on board",
"Show FDH of the object",
"Show object that is contained in FDH",
"Simple hand - for object grabbing and manipulation",
"Avatar - base version of user's avatar",
"",
"",
"Automatically retrieves some system information and writes it to the log file",
"Light source...",
"Shows HSL doublecone for color choosing"
"Secondary matrix to transform the object. Used when it is necessary to update transformation several times per frame in a different thread(s). For example while calculating Phantom/Reachin collisions.",
""}
const char* ability_name[]
Initial value:
= {
"Display",
"ShowFDH",
"ShowFDHModel",
"hand",
"Avatar",
"Rotate",
"MouseHand",
"SystemInfo",
"Light",
"MTMatrixTransform",
NULL}
const char* plugin_name = { "base" }
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/Avatar.cpp File Reference

  • File List
  • File Members
  • src
  • base
Macros | Functions
Avatar.cpp File Reference
#include "precompiled.h"
#include <base/Avatar.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Scene.h>

Macros

#define AVATAR_DELTA_CALC 0.0001f

Functions

METHOD_INPUT (RotationKeepUp, MessageQuat, Avatar)
METHOD_INPUT (DebugOutputViewPosition, MessageVoid, Avatar)

Macro Definition Documentation

#define AVATAR_DELTA_CALC 0.0001f

Function Documentation

METHOD_INPUT | ( | RotationKeepUp | ,
 |  | MessageQuat | ,
 |  | Avatar |
 | ) |  |
METHOD_INPUT | ( | DebugOutputViewPosition | ,
 |  | MessageVoid | ,
 |  | Avatar |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/Display.cpp File Reference

  • File List
  • File Members
  • src
  • base
Display.cpp File Reference
#include "precompiled.h"
#include <base/Display.h>
#include <string>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <osg/Depth>
#include <osg/Projection>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/hand.cpp File Reference

  • File List
  • File Members
  • src
  • base
hand.cpp File Reference
#include "precompiled.h"
#include <base/hand.h>
#include <vrecko/Scene.h>
#include <osg/io_utils>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/Light.cpp File Reference

  • File List
  • File Members
  • src
  • base
Light.cpp File Reference
#include "precompiled.h"
#include <base/Light.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <osg/io_utils>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/MouseHand.cpp File Reference

  • File List
  • File Members
  • src
  • base
MouseHand.cpp File Reference
#include "precompiled.h"
#include <base/MouseHand.h>
#include <sstream>
#include <vrecko/Scene.h>
#include <vrecko/BaseClass.h>
#include <vrecko/EventDispatcher.h>
#include <osg/io_utils>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/MTMatrixTransform.cpp File Reference

  • File List
  • File Members
  • src
  • base
Namespaces | Functions
MTMatrixTransform.cpp File Reference
#include "precompiled.h"
#include <base/MTMatrixTransform.h>
#include "vrecko/EventDispatcher.h"

Namespaces

namespace base

Functions

base::METHOD_REQUEST_INPUT (SetMatrix, MessageMatrix, MessageVoid, MTMatrixTransform)
base::METHOD_REQUEST_INPUT (GetMatrix, MessageVoid, MessageMatrix, MTMatrixTransform)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • base
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/precompiled.h File Reference

  • File List
  • File Members
  • src
  • base
precompiled.h File Reference
#include <vrecko/BaseClass.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/Logger.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Material>
#include <osgText/Text>
#include <esg/Definitions.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/Rotate.cpp File Reference

  • File List
  • File Members
  • src
  • base
Rotate.cpp File Reference
#include "precompiled.h"
#include <base/Rotate.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/ShowFDH.cpp File Reference

  • File List
  • File Members
  • src
  • base
ShowFDH.cpp File Reference
#include "precompiled.h"
#include <base/ShowFDH.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Material>
#include <esg/Definitions.h>
#include <esg/spacesorting/FDH14Tree.h>
#include <esg/Shape.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/ShowFDHModel.cpp File Reference

  • File List
  • File Members
  • src
  • base
ShowFDHModel.cpp File Reference
#include "precompiled.h"
#include <base/ShowFDHModel.h>
#include <vrecko/Scene.h>
#include <osg/Material>
#include <esg/OSGAdapter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/SystemInfo.cpp File Reference

  • File List
  • File Members
  • src
  • base
Classes | Namespaces | Macros | Typedefs | Functions
SystemInfo.cpp File Reference
#include "precompiled.h"
#include <base/SystemInfo.h>
#include <helpers/XercesXMLUtils.h>
#include <tlhelp32.h>
#include <dbghelp.h>

Classes

struct | base::_CLIENT_ID
struct | base::_THREAD_BASIC_INFORMATION

Namespaces

namespace base

Macros

#define | SI_OUT(str) logger.debugLog("%s", str)
#define | STATUS_SUCCESS ((NTSTATUS)0x00000000L)
#define | ThreadBasicInformation 0
#define | ThreadQuerySetWin32StartAddress 9

Typedefs

typedef LONG | base::NTSTATUS
typedef LONG | base::KPRIORITY
typedef NTSTATUS(WINAPI * | base::pNtQIT )(HANDLE, LONG, PVOID, ULONG, PULONG)
typedef struct base::_CLIENT_ID | base::CLIENT_ID
typedef struct base::_CLIENT_ID * | base::PCLIENT_ID
typedef struct
base::_THREAD_BASIC_INFORMATION 		base::THREAD_BASIC_INFORMATION
typedef struct
base::_THREAD_BASIC_INFORMATION * 		base::PTHREAD_BASIC_INFORMATION

Functions

bool base::GetThreadInfo (HANDLE hThread, PDWORD pStartAddress, PDWORD pdwAffinity)

Macro Definition Documentation

#define SI_OUT ( str ) logger.debugLog("%s", str)
#define STATUS_SUCCESS ((NTSTATUS)0x00000000L)
#define ThreadBasicInformation 0
#define ThreadQuerySetWin32StartAddress 9
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/helpers Directory Reference

  • src
  • helpers
helpers Directory Reference

Files

file | BufFile.cpp
file | StringHelpers.cpp
file | XercesXMLUtils.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/helpers/BufFile.cpp File Reference

  • File List
  • File Members
  • src
  • helpers
Namespaces | Macros | Functions
BufFile.cpp File Reference
#include "precompiled.h"
#include <helpers/BufFile.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | BF_GET_FILE_SIZE
#define | BF_CLOSE_HANDLE
#define | BF_SET_FILE_POINTER(dwRet, dwNewFilePos)

Functions

bool vrecko::FileExists (const _TCHAR *pFileName)

Macro Definition Documentation

#define BF_CLOSE_HANDLE
Value:
{ \
::CloseHandle (hFile); \
hFile = INVALID_HANDLE_VALUE; \
}
#define BF_GET_FILE_SIZE
Value:
{ \
dwFileSize = ::GetFileSize (hFile, NULL); \
}
#define BF_SET_FILE_POINTER | ( | dwRet,
 |  | dwNewFilePos
 | ) |
Value:
{ \
dwRet = ::SetFilePointer (hFile, dwNewFilePos, NULL, FILE_BEGIN); \
}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/helpers/StringHelpers.cpp File Reference

  • File List
  • File Members
  • src
  • helpers
Functions
StringHelpers.cpp File Reference
#include "precompiled.h"
#include <helpers/StringHelpers.h>
#include <tchar.h>

Functions

HELPERS_IMP_EXP bool isBeginningWith (const char *fullString, const char *beginString)

Function Documentation

HELPERS_IMP_EXP bool isBeginningWith | ( | const char * | fullString,
 |  | const char * | beginString
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/helpers/XercesXMLUtils.cpp File Reference

  • File List
  • File Members
  • src
  • helpers
Functions
XercesXMLUtils.cpp File Reference
#include "precompiled.h"

Functions

HELPERS_IMP_EXP
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		findXMLNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *rootNode, const char *nodeName, bool bSearchSubTrees)
HELPERS_IMP_EXP char * getNodeTextTrans (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node)

Function Documentation

HELPERS_IMP_EXP XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* findXMLNode | ( | XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * | rootNode,
 |  | const char * | nodeName,
 |  | bool | bSearchSubTrees
 | ) |  |
HELPERS_IMP_EXP char* getNodeTextTrans ( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko Directory Reference

  • src
  • vrecko
vrecko Directory Reference

Files

file | Ability.cpp
file | Arm.cpp
file | BaseClass.cpp
file | BenchmarkWriter.cpp
file | Device.cpp
file | DeviceManager.cpp
file | EnvironmentObject.cpp
file | EventDispatcher.cpp
file | IOPins.cpp
file | Logger.cpp
file | Message.cpp
file | MTLock.cpp
file | OctTree.cpp
file | PersistentCache.cpp
file | PluginManager.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | PyAbility.cpp
file | ReaderWriter.cpp
file | Scene.cpp
file | Scheduler.cpp
file | SP_CommonDefs.cpp
file | Timer.cpp
file | Viewer.cpp
file | vThread.cpp
file | World.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Ability.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Ability.cpp File Reference
#include "precompiled.h"
#include <sstream>
#include <vrecko/Ability.h>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Arm.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Functions | Variables
Arm.cpp File Reference
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <vrecko/arm.h>
#include <vrecko/classes.h>

Functions

arm_result | simple_TIMED_OUT (arm_result condition)
arm_result | simple_BAD_PORT (arm_result condition)
arm_result | simple_BAD_PACKET (arm_result condition)
arm_result | simple_NO_HCI (arm_result condition)
arm_result | simple_CANT_BEGIN (arm_result condition)
arm_result | simple_CANT_OPEN_PORT (arm_result condition)

Variables

char | INCHES [7] = "inches"
char | MM [3] = "mm"
char | RADIANS [8] = "radians"
char | DEGREES [8] = "degrees"
char | XYZ_FIXED [10] = "xyz fixed"
char | ZYX_FIXED [10] = "zyx fixed"
char | YXZ_FIXED [10] = "yxz fixed"
char | ZYX_EULER [10] = "zyx Euler"
char | XYZ_EULER [10] = "xyz Euler"
char | ZXY_EULER [10] = "zxy Euler"

Function Documentation

arm_result simple_BAD_PACKET ( arm_result condition )
arm_result simple_BAD_PORT ( arm_result condition )
arm_result simple_CANT_BEGIN ( arm_result condition )
arm_result simple_CANT_OPEN_PORT ( arm_result condition )
arm_result simple_NO_HCI ( arm_result condition )
arm_result simple_TIMED_OUT ( arm_result condition )

Variable Documentation

char DEGREES[8] = "degrees"
char INCHES[7] = "inches"
char MM[3] = "mm"
char RADIANS[8] = "radians"
char XYZ_EULER[10] = "xyz Euler"
char XYZ_FIXED[10] = "xyz fixed"
char YXZ_FIXED[10] = "yxz fixed"
char ZXY_EULER[10] = "zxy Euler"
char ZYX_EULER[10] = "zyx Euler"
char ZYX_FIXED[10] = "zyx fixed"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/BaseClass.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Classes | Macros
BaseClass.cpp File Reference
#include "precompiled.h"
#include <vrecko/BaseClass.h>
#include <vrecko/Ability.h>
#include <vrecko/Device.h>
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <cstdarg>
#include <sstream>
#include <xercesc/util/XMLUniDefs.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/dom/DOMErrorHandler.hpp>
#include <xercesc/dom/DOMLocator.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/dom/DOMImplementationRegistry.hpp>
#include <xercesc/dom/DOMImplementationLS.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/framework/MemBufInputSource.hpp>
#include <xercesc/framework/Wrapper4InputSource.hpp>
#include <xercesc/util/XMLString.hpp>
#include <iostream.h>

Classes

class BCLoaderErrorHandler

Macros

#define | PIN_ADDITION(pin, list, pinClass, pinCheckMethod, ioType)
#define | PIN_REMOVAL(pin, list)

Macro Definition Documentation

#define PIN_ADDITION | ( | pin,
 |  | list,
 |  | pinClass,
 |  | pinCheckMethod,
 |  | ioType
 | ) |
Value:
{ \
if (pinCheckMethod(pin->getPinName().c_str())) \
logger.warningLog("Duplicate %s pin name detected (%s)", ioType, pin->getPinName().c_str()); \
list.push_back(osg::ref_ptr<pinClass>(pin)); \
}
#define PIN_REMOVAL | ( | pin,
 |  | list
 | ) |
Value:
{ \
if (pin) { \
for (auto itr = list.begin(); itr != list.end(); ++itr) { \
if ((*itr) == pin) { \
list.erase(itr); \
break; \
} \
} \
} \
}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/BenchmarkWriter.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces
BenchmarkWriter.cpp File Reference
#include "precompiled.h"
#include <vrecko/BenchmarkWriter.h>
#include "stdio.h"

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Device.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Device.cpp File Reference
#include "precompiled.h"
#include <sstream>
#include <stdlib.h>
#include <vrecko/Device.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/DeviceManager.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
DeviceManager.cpp File Reference
#include "precompiled.h"
#include <vrecko/DeviceManager.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/EnvironmentObject.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
EnvironmentObject.cpp File Reference
#include "precompiled.h"
#include <sstream>
#include <osgDB/Registry>
#include <osgDB/ReadFile>
#include <osg/Notify>
#include <osg/BoundingSphere>
#include <osgUtil/Optimizer>
#include <osgUtil/SmoothingVisitor>
#include <osg/PrimitiveSet>
#include <osg/Geode>
#include <osg/Group>
#include <osg/Geometry>
#include <osg/CopyOp>
#include <osg/PolygonMode>
#include <osg/ShadeModel>
#include <osg/LightModel>
#include <osg/CullFace>
#include <osg/StateSet>
#include <osg/State>
#include <osg/Material>
#include <osgUtil/TransformCallback>
#include <osg/Plane>
#include <esg/OSGAdapter.h>
#include <math.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>
#include <helpers/StringHelpers.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/EventDispatcher.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
EventDispatcher.cpp File Reference
#include "precompiled.h"
#include <vrecko/EventDispatcher.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <stdio.h>
#include <iostream>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/IOPins.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
IOPins.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Logger.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Classes | Namespaces | Macros
Logger.cpp File Reference
#include "precompiled.h"
#include <vrecko/Logger.h>
#include <stdarg.h>
#include <iostream>
#include <time.h>

Classes

class vrecko::logger_streambuf

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | MAX_OUTSTANDING_COUNTERS 100
#define | CONSOLE_ATTRIB_COLOR_BYTES (FOREGROUND_BLUE | FOREGROUND_GREEN | FOREGROUND_RED | FOREGROUND_INTENSITY | BACKGROUND_BLUE | BACKGROUND_GREEN | BACKGROUND_RED | BACKGROUND_INTENSITY)

Macro Definition Documentation

#define CONSOLE_ATTRIB_COLOR_BYTES (FOREGROUND_BLUE | FOREGROUND_GREEN | FOREGROUND_RED | FOREGROUND_INTENSITY | BACKGROUND_BLUE | BACKGROUND_GREEN | BACKGROUND_RED | BACKGROUND_INTENSITY)
#define MAX_OUTSTANDING_COUNTERS 100
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Message.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Message.cpp File Reference
#include "precompiled.h"
#include <vrecko/Message.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/MTLock.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces | Functions
MTLock.cpp File Reference
#include "precompiled.h"
#include <vrecko/MTLock.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Functions

bool | vrecko::Wait (int nObjects, HANDLE *pObjects, DWORD Timeout=INFINITE)
bool | vrecko::Wait1 (HANDLE hObj, DWORD Timeout=INFINITE)
bool | vrecko::Wait2 (HANDLE hObj1, HANDLE hObj2, DWORD Timeout=INFINITE)
bool | vrecko::Wait3 (HANDLE hObj1, HANDLE hObj2, HANDLE hObj3, DWORD Timeout=INFINITE)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/OctTree.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
OctTree.cpp File Reference
#include "precompiled.h"
#include <math.h>
#include <vrecko/OctTree.h>
#include <vrecko/EventDispatcher.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/PersistentCache.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces | Macros
PersistentCache.cpp File Reference
#include "precompiled.h"
#include <vrecko/Logger.h>
#include <vrecko/PersistentCache.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define PERSISTENT_CACHE_MODEL_NAME "Model"

Macro Definition Documentation

#define PERSISTENT_CACHE_MODEL_NAME "Model"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/PluginManager.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
PluginManager.cpp File Reference
#include "precompiled.h"
#include <vrecko/PluginManager.h>
#include <iostream>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vrecko
precompiled.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/PyAbility.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces
PyAbility.cpp File Reference
#include "precompiled.h"
#include <vrecko/PyAbility.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/ReaderWriter.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces | Macros | Functions | Variables
ReaderWriter.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scheduler.h>
#include <vrecko/BaseClass.h>
#include <vrecko/DeviceManager.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/PluginManager.h>
#include <helpers/XercesXMLUtils.h>
#include <helpers/StringHelpers.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Ability.h>
#include <vrecko/PyAbility.h>
#include <osg/Matrix>
#include <sstream>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/dom/DOMImplementationLS.hpp>
#include <xercesc/dom/DOMImplementationRegistry.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/dom/DOMException.hpp>
#include <xercesc/dom/DOMDocument.hpp>
#include <xercesc/dom/DOMNodeList.hpp>
#include <xercesc/dom/DOMError.hpp>
#include <xercesc/dom/DOMLocator.hpp>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/dom/DOMAttr.hpp>
#include <xercesc/util/XMLInteger.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <string.h>
#include <stdlib.h>
#include <ctype.h>
#include <fstream.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | MUTEX_LOCK(mutex) pthread_mutex_lock(mutex);
#define | MUTEX_UNLOCK(mutex) pthread_mutex_unlock(mutex);
#define | MERGE_FLAGS_ATTRIB_NAME L"MergeFlags"

Functions

osg::Vec4 | vrecko::base1 (1.0, 0.0, 0.0, 0.0)
osg::Vec4 | vrecko::base2 (0.0, 0.0,-1.0, 0.0)
osg::Vec4 | vrecko::base3 (0.0, 1.0, 0.0, 0.0)
osg::Vec4 | vrecko::baseR1 (-1.0, 0.0, 0.0, 0.0)
osg::Vec4 | vrecko::baseR2 (0.0, 0.0, 1.0, 0.0)
osg::Vec4 | vrecko::baseR3 (0.0,-1.0, 0.0, 0.0)
osg::Vec4 | vrecko::origin (0.0, 0.0, 0.0, 1.0)

Variables

char vrecko::trash [256]

Macro Definition Documentation

#define MERGE_FLAGS_ATTRIB_NAME L"MergeFlags"
#define MUTEX_LOCK ( mutex ) pthread_mutex_lock(mutex);
#define MUTEX_UNLOCK ( mutex ) pthread_mutex_unlock(mutex);
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Scene.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces | Macros | Functions
Scene.cpp File Reference
#include "precompiled.h"
#include <osg/Transform>
#include <osg/Notify>
#include <vrecko/Scene.h>
#include <vrecko/SP_SceneInterface.h>
#include <vrecko/SP_ObjectInterface.h>
#include <base/SystemInfo.h>
#include <esg/OSGAdapter.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define PART_THREAD_REQUEST_TIMEOUT 2000

Functions

DWORD WINAPI vrecko::ScenePSThreadProc (ScenePSThreadInfo *lpParameter)

Macro Definition Documentation

#define PART_THREAD_REQUEST_TIMEOUT 2000
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Scheduler.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Macros
Scheduler.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scheduler.h>
#include <vrecko/World.h>
#include <iostream.h>

Macros

#define SG_SAFETY

Macro Definition Documentation

#define SG_SAFETY
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/SP_CommonDefs.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces
SP_CommonDefs.cpp File Reference
#include "precompiled.h"
#include <vrecko/SP_CommonDefs.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Timer.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces
Timer.cpp File Reference
#include "precompiled.h"
#include <vrecko/Timer.h>
#include <windows.h>
#include <mmsystem.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/Viewer.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Viewer.cpp File Reference
#include "precompiled.h"
#include <vrecko/Viewer.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/vThread.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Functions
vThread.cpp File Reference
#include "precompiled.h"
#include <vrecko/vThread.h>
#include <iostream>
#include <sstream>
#include <errno.h>

Functions

void * | thread_main_func (void *arg)
void * | thread_main_func2 (void *arg)

Function Documentation

void* thread_main_func ( void * arg )
void* thread_main_func2 ( void * arg )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/World.cpp File Reference

  • File List
  • File Members
  • src
  • vrecko
Namespaces | Macros | Functions
World.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scene.h>
#include <vrecko/PersistentCache.h>
#include <vrecko/World.h>
#include <vrecko/Scheduler.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/PluginManager.h>
#include <cstdarg>
#include <stdlib.h>
#include <xercesc/util/XercesDefs.hpp>
#include <xercesc/dom/DOM.hpp>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define | MUTEX_LOCK(mutex) pthread_mutex_lock(mutex);
#define | MUTEX_UNLOCK(mutex) pthread_mutex_unlock(mutex);

Functions

VRECKO_EXPORT bool | vrecko::initXML ()
VRECKO_EXPORT bool | vrecko::doneXML ()
VRECKO_EXPORT const std::string & | vrecko::getSafeSceneFile (const std::string &sceneFile)
VRECKO_EXPORT unsigned long | vrecko::getNumSceneFiles ()
Returns the number of stored scene files. More...
VRECKO_EXPORT const std::string & | vrecko::getSafeSceneFile (unsigned long index)
Return an appropriate scene file ([index] can be from 0 to getNumSceneFiles()-1) More...
VRECKO_EXPORT const std::string & | vrecko::getSafeDefaultSceneFile ()
VRECKO_EXPORT void | vrecko::setDefaultSceneFile (const std::string &newDefaultSceneFile)

Macro Definition Documentation

#define MUTEX_LOCK ( mutex ) pthread_mutex_lock(mutex);
#define MUTEX_UNLOCK ( mutex ) pthread_mutex_unlock(mutex);
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP Directory Reference

  • src
  • vreckoAP
vreckoAP Directory Reference

Directories

directory | ArtificialWorld
directory | Boids
directory | CableEditor
directory | CameraMovement
directory | CameraPath
directory | CarSim
directory | ConnectEditor
directory | ConstrainedMovement
directory | DynamicArt
directory | EditorController
directory | EditorQAbilities
directory | FFDEditor
directory | Garden
directory | GUI
directory | HapticCollisionApp
directory | HeadTracking
directory | HelloWorld
directory | HUD
directory | InputConnector
directory | LightsEditor
directory | Menu
directory | Nature
directory | navigation
directory | ObjectUtils
directory | PhysX
directory | ShootingSimulation
directory | SpacePartitioning
directory | TextOutput
directory | VF
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld Directory Reference

  • src
  • vreckoAP
  • ArtificialWorld
ArtificialWorld Directory Reference

Files

file | AP_ArtificialWorld.cpp
file | BlockUpdater.cpp
file | Cache.cpp
file | model.cpp
file | ModelManager.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Preloader.cpp
file | PreloaderHeuristic.cpp
file | subblock.cpp
file | WorldBuilder.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/AP_ArtificialWorld.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions | Variables
AP_ArtificialWorld.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/AP_ArtificialWorld.h>

Functions

const char * | ArtificialWorld_getPluginDescription (void)
const char ** | ArtificialWorld_getAbilityList (void)
const char * | ArtificialWorld_getAbilityDescription (const char *name)
Ability * | ArtificialWorld_getAbilityInstance (const char *name)
void | ArtificialWorld_setAbilitiesParameters (void)

Variables

const char * | g_pArtificialWorldPluginName = { "ArtificialWorld" }
nazev pluginu More...
const char * | g_pArtificialWorldAbilityName [] = { "BlockUpdater", "WorldBuilder", "Cache", NULL }
nazvy abilit v plugunu More...
const char * | g_pArtificialWorldAbilityDescription [] = { "Update block of models", "Artificial World builder", "Model cache", "" }
popisy abilit v pluginu More...

Function Documentation

const char* ArtificialWorld_getAbilityDescription ( const char * name )
Ability* ArtificialWorld_getAbilityInstance ( const char * name )
const char** ArtificialWorld_getAbilityList ( void )
const char* ArtificialWorld_getPluginDescription ( void )
void ArtificialWorld_setAbilitiesParameters ( void )

Variable Documentation

const char* g_pArtificialWorldAbilityDescription[] = { "Update block of models", "Artificial World builder", "Model cache", "" }

popisy abilit v pluginu

const char* g_pArtificialWorldAbilityName[] = { "BlockUpdater", "WorldBuilder", "Cache", NULL }

nazvy abilit v plugunu

const char* g_pArtificialWorldPluginName = { "ArtificialWorld" }

nazev pluginu

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/BlockUpdater.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions
BlockUpdater.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/BlockUpdater.h>

Functions

void ShowModelSettings (Model *model)
zobrazi informace o modelu do konzole More...

Function Documentation

void ShowModelSettings ( Model * model )

zobrazi informace o modelu do konzole

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/Cache.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Cache.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/Cache.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/model.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
model.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/model.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/ModelManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions
ModelManager.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/ModelManager.h>

Functions

osg::ref_ptr< EnvironmentObject > LoadModelFromCoreModel (osg::ref_ptr< osgCal::CoreModel > coreModel, osg::ref_ptr< osgCal::BasicMeshAdder > meshAdder, int animationIndex, bool startAnimation)
ziska animovany model z CoreModelu ulozeneho v pameti, za pouziti daneho MeshAdderu, se zadanym indexem animace a pripadne animaci i spusti More...

Function Documentation

osg::ref_ptr<EnvironmentObject> LoadModelFromCoreModel | ( | osg::ref_ptr< osgCal::CoreModel > | coreModel,
 |  | osg::ref_ptr< osgCal::BasicMeshAdder > | meshAdder,
 |  | int | animationIndex,
 |  | bool | startAnimation
 | ) |  |

ziska animovany model z CoreModelu ulozeneho v pameti, za pouziti daneho MeshAdderu, se zadanym indexem animace a pripadne animaci i spusti

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
precompiled.h File Reference
#include <iostream>
#include <sstream>
#include <fstream>
#include <string.h>
#include <list>
#include <Windows.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Node>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <helpers/XercesXMLUtils.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/Logger.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <helpers/StringHelpers.h>
#include <vreckoAP/ObjectUtils/Animator.h>
#include <vreckoAP/ArtificialWorld/awHelper.h>
#include <vreckoAP/ArtificialWorld/subblock.h>
#include <vreckoAP/ArtificialWorld/model.h>
#include <vreckoAP/ArtificialWorld/BlockUpdater.h>
#include <vreckoAP/ArtificialWorld/Cache.h>
#include <vreckoAP/ArtificialWorld/WorldBuilder.h>
#include <vreckoAP/ArtificialWorld/ModelManager.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/Preloader.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions
Preloader.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/Preloader.h>

Functions

DWORD WINAPI LoadingFunction (LPVOID param)
funkce, ktera bezi ve smycce v jinem vlakne a stara se o nacitani dat modelu ze souboru More...

Function Documentation

DWORD WINAPI LoadingFunction ( LPVOID param )

funkce, ktera bezi ve smycce v jinem vlakne a stara se o nacitani dat modelu ze souboru

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/PreloaderHeuristic.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions
PreloaderHeuristic.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/PreloaderHeuristic.h>

Functions

bool | ComputePoint (double x, double y, double sizexy, double sizeuv, double anglecos, double side, osg::Vec2 lastPoint, osg::Vec2 *result)
bool | isVisible (SubBlock *block, osg::Vec3 *blockWorldPosition, osg::Vec3 *position)
zjisti, jestli je dany blok s danou pozici, viditelny z dane pozice More...
double | AngleCos (osg::Vec2 v1, osg::Vec2 v2)
vrati cosinus uhlu, ktery sviraji dva vektory More...
double | Side (osg::Vec2 point, osg::Vec2 lineVector, osg::Vec2 linePoint)

Function Documentation

double AngleCos | ( | osg::Vec2 | v1,
 |  | osg::Vec2 | v2
 | ) |  |

vrati cosinus uhlu, ktery sviraji dva vektory

bool ComputePoint | ( | double | x,
 |  | double | y,
 |  | double | sizexy,
 |  | double | sizeuv,
 |  | double | anglecos,
 |  | double | side,
 |  | osg::Vec2 | lastPoint,
 |  | osg::Vec2 * | result
 | ) |  |

Vstup: vektor (x,y), velikost vektoru (x,y), velikost hledaneho vektoru (u,v), cosinus uhlu, ktery maji svirat vektory (x,y) a (u,v), polorovina, v niz ma lezet vypocteny bod (vzhledem k primce dane vektorem (x,y), 0 = ma lezet na primce, >0 = vpravo od primky (vektoru), <0 = vlevo od primky (vektoru)), vysledny hledany vektor

bool isVisible | ( | SubBlock * | block,
 |  | osg::Vec3 * | blockWorldPosition,
 |  | osg::Vec3 * | position
 | ) |  |

zjisti, jestli je dany blok s danou pozici, viditelny z dane pozice

double Side | ( | osg::Vec2 | point,
 |  | osg::Vec2 | lineVector,
 |  | osg::Vec2 | linePoint
 | ) |  |

ziska cislo, ktere urcuje pozici bodu 'point' vzhledem k primce dane vektorem a bodem 0 = bod lezi na primce, >0 = bod lezi vpravo, <0 = bod lezi vlevo

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/subblock.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
subblock.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ArtificialWorld/subblock.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/WorldBuilder.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
Functions
WorldBuilder.cpp File Reference
#include "precompiled.h"

Functions

METHOD_REQUEST_INPUT (GetAndLockRootXMLNode, MessageVoid, MessageXMLNode, WorldBuilder)
METHOD_REQUEST_INPUT (UnlockRootXMLNode, MessageVoid, MessageVoid, WorldBuilder)

Function Documentation

METHOD_REQUEST_INPUT | ( | GetAndLockRootXMLNode | ,
 |  | MessageVoid | ,
 |  | MessageXMLNode | ,
 |  | WorldBuilder |
 | ) |  |
METHOD_REQUEST_INPUT | ( | UnlockRootXMLNode | ,
 |  | MessageVoid | ,
 |  | MessageVoid | ,
 |  | WorldBuilder |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids Directory Reference

  • src
  • vreckoAP
  • Boids
Boids Directory Reference

Files

file | AP_boids.cpp
file | Boid.cpp
file | BoidsLogic.cpp
file | BoidsPlanner.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/AP_boids.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Boids
Functions | Variables
AP_boids.cpp File Reference
#include <string.h>
#include <vreckoAP/Boids/AP_boids.h>

Functions

const char * | boids_getPluginDescription (void)
const char ** | boids_getAbilityList (void)
const char * | boids_getAbilityDescription (const char *name)
Ability * | boids_getAbilityInstance (const char *_name)

Variables

const char * | _boids_plugin_name = { "boids" }
const char * | _boids_ability_name []
const char * | _boids_ability_description []

Function Documentation

const char* boids_getAbilityDescription ( const char * name )
Ability* boids_getAbilityInstance ( const char * _name )
const char** boids_getAbilityList ( void )
const char* boids_getPluginDescription ( void )

Variable Documentation

const char* _boids_ability_description[]
Initial value:
= {
"Basic boid object",
"Boid controller",
"Boid waypoint planner",
""}
const char* _boids_ability_name[]
Initial value:
= {
"Boid",
"BoidsLogic",
"BoidsPlanner",
NULL}
const char* _boids_plugin_name = { "boids" }
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/Boid.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Boids
Boid.cpp File Reference
#include <vreckoAP/Boids/Boid.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Scene.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/BoidsLogic.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Boids
BoidsLogic.cpp File Reference
#include <vreckoAP/Boids/BoidsLogic.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Quat>
#include <stdlib.h>
#include <time.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Boids/BoidsPlanner.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Boids
Functions
BoidsPlanner.cpp File Reference
#include <vreckoAP/Boids/BoidsPlanner.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Quat>
#include <stdlib.h>
#include <time.h>
#include <sstream>

Functions

METHOD_INPUT (NextWaypoint, MessageBool, BoidsPlanner)

Function Documentation

METHOD_INPUT | ( | NextWaypoint | ,
 |  | MessageBool | ,
 |  | BoidsPlanner |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor Directory Reference

  • src
  • vreckoAP
  • CableEditor
CableEditor Directory Reference

Files

file | AP_CableEditor.cpp
file | Cable.cpp
file | CableEditor.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor/AP_CableEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CableEditor
Functions | Variables
AP_CableEditor.cpp File Reference
#include <vreckoAP/CableEditor/AP_CableEditor.h>
#include <vreckoAP/CableEditor/CableEditor.h>
#include <vreckoAP/CableEditor/Cable.h>

Functions

AP_EXPORT const char * | CableEditor_getPluginDescription ()
AP_EXPORT const char ** | CableEditor_getAbilityList ()
AP_EXPORT const char * | CableEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CableEditor_getAbilityInstance (const char *pchName)

Variables

const char * | g_pPluginName = {"CableEditor"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* CableEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CableEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CableEditor_getAbilityList ( )
AP_EXPORT const char* CableEditor_getPluginDescription ( )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability for creating and editing cables in the scene.",
"Base ability representing cable",
""
}
const char* g_pAbilityName[]
Initial value:
=
{
"CableEditor",
"Cable",
NULL
}
const char* g_pPluginName = {"CableEditor"}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor/Cable.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CableEditor
Namespaces
Cable.cpp File Reference
#include <vreckoAP/CableEditor/Cable.h>

Namespaces

namespace AP_CableEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CableEditor/CableEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CableEditor
Namespaces
CableEditor.cpp File Reference
#include <vreckoAP/CableEditor/CableEditor.h>

Namespaces

namespace AP_CableEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement Directory Reference

  • src
  • vreckoAP
  • CameraMovement
CameraMovement Directory Reference

Files

file | AP_CameraMovement.cpp
file | CameraMovementEditor.cpp
file | CameraPath.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/AP_CameraMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CameraMovement
Functions | Variables
AP_CameraMovement.cpp File Reference
#include <vreckoAP/CameraMovement/AP_CameraMovement.h>
#include <vreckoAP/CameraMovement/CameraPath.h>
#include <vreckoAP/CameraMovement/CameraMovementEditor.h>

Functions

AP_EXPORT const char * | CameraMovement_getPluginDescription ()
AP_EXPORT const char ** | CameraMovement_getAbilityList ()
AP_EXPORT const char * | CameraMovement_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CameraMovement_getAbilityInstance (const char *pchName)
AP_EXPORT void | CameraMovement_setAbilitiesParameters ()

Variables

const char * | g_pAPCameraMovementPluginName = {"CameraMovement"}
const char * | g_pAPCameraMovementAbilityName []
const char * | g_pAPCameraMovementAbilityDesc []

Function Documentation

AP_EXPORT const char* CameraMovement_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CameraMovement_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CameraMovement_getAbilityList ( )
AP_EXPORT const char* CameraMovement_getPluginDescription ( )
AP_EXPORT void CameraMovement_setAbilitiesParameters ( )

Variable Documentation

const char* g_pAPCameraMovementAbilityDesc[]
Initial value:
= {
"Describes path of camera movement.",
"Camera movement editor",
""
}
const char* g_pAPCameraMovementAbilityName[]
Initial value:
= {
"CameraPath",
"CameraMovementEditor",
NULL
}
const char* g_pAPCameraMovementPluginName = {"CameraMovement"}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/CameraMovementEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CameraMovement
Classes | Namespaces
CameraMovementEditor.cpp File Reference
#include <vreckoAP/CameraMovement/CameraMovementEditor.h>

Classes

struct APCameraMovement::MyReadCallback

Namespaces

namespace APCameraMovement
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraMovement/CameraPath.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CameraMovement
Namespaces | Macros
CameraPath.cpp File Reference
#include <vreckoAP/CameraMovement/CameraPath.h>

Namespaces

namespace APCameraMovement

Macros

#define | F1(t) ( 2*(t)*(t)*(t) - 3*(t)*(t) + 1)
#define | F2(t) (-2*(t)*(t)*(t) + 3*(t)*(t))
#define | F3(t) ( (t)*(t)*(t) - 2*(t)*(t) + (t))
#define | F4(t) ( (t)*(t)*(t) - (t)*(t))

Macro Definition Documentation

#define F1 ( t ) ( 2*(t)*(t)*(t) - 3*(t)*(t) + 1)
#define F2 ( t ) (-2*(t)*(t)*(t) + 3*(t)*(t))
#define F3 ( t ) ( (t)*(t)*(t) - 2*(t)*(t) + (t))
#define F4 ( t ) ( (t)*(t)*(t) - (t)*(t))
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraPath Directory Reference

  • src
  • vreckoAP
  • CameraPath
CameraPath Directory Reference

Files

file | AP_CameraPath.cpp
file | Camera.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraPath/AP_CameraPath.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CameraPath
Functions | Variables
AP_CameraPath.cpp File Reference
#include <vreckoAP/CameraPath/AP_CameraPath.h>
#include <vreckoAP/CameraPath/Camera.h>

Functions

AP_EXPORT const char * | CameraPath_getPluginDescription ()
AP_EXPORT const char ** | CameraPath_getAbilityList ()
AP_EXPORT const char * | CameraPath_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | CameraPath_getAbilityInstance (const char *pchName)
AP_EXPORT void | CameraPath_setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"CameraPath"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* CameraPath_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* CameraPath_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** CameraPath_getAbilityList ( )
AP_EXPORT const char* CameraPath_getPluginDescription ( )
AP_EXPORT void CameraPath_setAbilitiesParameters ( )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability for creating a camera path",
""
}
const char* g_pAbilityName[]
Initial value:
=
{
"Camera",
NULL
}
const char* g_pPluginName = {"CameraPath"}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CameraPath/Camera.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CameraPath
Namespaces
Camera.cpp File Reference
#include <vreckoAP/CameraPath/Camera.h>

Namespaces

namespace APCameraPath
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim Directory Reference

  • src
  • vreckoAP
  • CarSim
CarSim Directory Reference

Files

file | AP_CarSim.cpp
file | AP_Filter.cpp
file | CarControlUnit.cpp
file | CarExecutionUnit.cpp
file | CarPartsNodeCache.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Remover.cpp
file | RoadsState.cpp
file | TLsOnJuncManager.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/AP_CarSim.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
Functions | Variables
AP_CarSim.cpp File Reference
#include "precompiled.h"

Functions

const char * | CarSim_getPluginDescription (void)
const char ** | CarSim_getAbilityList (void)
const char * | CarSim_getAbilityDescription (const char *name)
Ability * | CarSim_getAbilityInstance (const char *_name)

Variables

const char * | _CarSim_plugin_name = { "CarSim" }
const char * | _CarSim_ability_name []
const char * | _CarSim_ability_description []
Ability * _new_ability

Function Documentation

const char* CarSim_getAbilityDescription ( const char * name )
Ability* CarSim_getAbilityInstance ( const char * _name )
const char** CarSim_getAbilityList ( void )
const char* CarSim_getPluginDescription ( void )

Variable Documentation

const char* _CarSim_ability_description[]
Initial value:
= {
"This unit receives the information about car's environs from RoadsState, "
"decides how the car should behave in next frames and gives orders to CarExecutionUnit.",
"This unit executes the orders from CarControlUnit (it moves the car in the scene).",
"This ability holds information about roads and cars on them and informs "
"CarControlUnit about the situation around the car.",
"This ability removes cars from the scene when they reach their finish.",
"This ability is used for caching of car parts geometry.",
"This ability manages traffic lights on a (small) junction.",
""}
const char* _CarSim_ability_name[]
Initial value:
= {
"CarControlUnit",
"CarExecutionUnit",
"RoadsState",
"Remover",
"CarPartsNodeCache",
"TLsOnJuncManager",
NULL}
const char* _CarSim_plugin_name = { "CarSim" }
Ability* _new_ability
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/AP_Filter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
AP_Filter.cpp File Reference
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarControlUnit.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
CarControlUnit.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/CarControlUnit.h>
#include <sstream>
#include <osg/Vec3>
#include <limits>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarExecutionUnit.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
Functions
CarExecutionUnit.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/CarExecutionUnit.h>

Functions

METHOD_REQUEST_INPUT (InGetCarState, MessageVoid, MessageCarStatePtr, CarExecutionUnit)
METHOD_REQUEST_INPUT (InGetCarLength, MessageVoid, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InAcc, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InWheelAngle, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InStop, MessageVoid, CarExecutionUnit)
METHOD_INPUT (InUpdate, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InInitNormal, MessageVec3, CarExecutionUnit)
METHOD_INPUT (InInitDirection, MessageVec3, CarExecutionUnit)
METHOD_INPUT (InInitPosition, MessageVec3, CarExecutionUnit)
METHOD_INPUT (InSetCarNormal, MessageVec3, CarExecutionUnit)
METHOD_INPUT (InPushCarInNormalDir, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InPushCarInDirectionCrossNormalDir, MessageFloat, CarExecutionUnit)
METHOD_INPUT (InSetBlinker, MessageUnsignedInt, CarExecutionUnit)
METHOD_INPUT (InShow, MessageVoid, CarExecutionUnit)
METHOD_INPUT (InHide, MessageVoid, CarExecutionUnit)

Function Documentation

METHOD_INPUT | ( | InAcc | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InWheelAngle | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InStop | ,
 |  | MessageVoid | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InUpdate | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InInitNormal | ,
 |  | MessageVec3 | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InInitDirection | ,
 |  | MessageVec3 | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InInitPosition | ,
 |  | MessageVec3 | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InSetCarNormal | ,
 |  | MessageVec3 | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InPushCarInNormalDir | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InPushCarInDirectionCrossNormalDir | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InSetBlinker | ,
 |  | MessageUnsignedInt | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InShow | ,
 |  | MessageVoid | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_INPUT | ( | InHide | ,
 |  | MessageVoid | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetCarState | ,
 |  | MessageVoid | ,
 |  | MessageCarStatePtr | ,
 |  | CarExecutionUnit |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetCarLength | ,
 |  | MessageVoid | ,
 |  | MessageFloat | ,
 |  | CarExecutionUnit |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/CarPartsNodeCache.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
Functions
CarPartsNodeCache.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/CarPartsNodeCache.h>

Functions

METHOD_REQUEST_INPUT (InGetCarPartNode, MessageString, MessageNode, CarPartsNodeCache)

Function Documentation

METHOD_REQUEST_INPUT | ( | InGetCarPartNode | ,
 |  | MessageString | ,
 |  | MessageNode | ,
 |  | CarPartsNodeCache |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
precompiled.h File Reference
#include <sstream>
#include <limits>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/Logger.h>
#include <osg/Material>
#include <osg/Geometry>
#include <osg/Geode>
#include <osg/Texture2D>
#include <osgDB/ReadFile>
#include <helpers/XercesXMLUtils.h>
#include <vreckoAP/CarSim/AP_CarSim.h>
#include <vreckoAP/CarSim/CarControlUnit.h>
#include <vreckoAP/CarSim/CarExecutionUnit.h>
#include <vreckoAP/CarSim/RoadsState.h>
#include <vreckoAP/CarSim/Remover.h>
#include <vreckoAP/CarSim/CarPartsNodeCache.h>
#include <vreckoAP/CarSim/TLsOnJuncManager.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/Remover.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
Functions
Remover.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/Remover.h>

Functions

METHOD_INPUT (InCarToRemove, MessageUnsignedInt, Remover)

Function Documentation

METHOD_INPUT | ( | InCarToRemove | ,
 |  | MessageUnsignedInt | ,
 |  | Remover |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/RoadsState.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
Macros | Functions
RoadsState.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/RoadsState.h>
#include <vreckoAP/CarSim/Remover.h>
#include <vreckoAP/CarSim/CarPartsNodeCache.h>
#include <vreckoAP/CarSim/CarExecutionUnit.h>
#include <vreckoAP/CarSim/TLsOnJuncManager.h>

Macros

#define | GENERAL_MAX_JUNC_SPEED 7.5
#define | HF_VECS_COEF 1.5
#define | BMW_LP 1
#define | BMW_WHITE_LP 2
#define | IVECO 3
#define | RS_LOAD_MODEL(variable, dataPartPath, errorNum)

Functions

METHOD_INPUT (InUnregCarForEdge, MessageCarEdge, RoadsState)
METHOD_INPUT (InAddForEdgeRegisteredCarToPutAsideCars, MessageCarEdge, RoadsState)
METHOD_REQUEST_INPUT (InGetReady, MessageVoid, MessageBool, RoadsState)
METHOD_REQUEST_INPUT (InGetDataPath, MessageVoid, MessageString, RoadsState)
METHOD_REQUEST_INPUT (InGetEdgeAbsPos, MessageEdgeOffset, MessageVec3, RoadsState)
METHOD_REQUEST_INPUT (InGetEdgeOutInVec, MessageUnsignedInt, MessageVec3, RoadsState)
METHOD_REQUEST_INPUT (InGetEdgeNormal, MessageUnsignedInt, MessageVec3, RoadsState)
METHOD_REQUEST_INPUT (InFindShortestPath, MessageStartStopDestination, MessageVectorUnsignedInt, RoadsState)
METHOD_REQUEST_INPUT (InCheckCarStopPosition, MessageCarEdgeData, MessageBool, RoadsState)
METHOD_REQUEST_INPUT (InGetStartOrStopEdgeFromRoadAndDirection, MessageRoadAndDir, MessageUnsignedInt, RoadsState)
METHOD_REQUEST_INPUT (InRegCarForEdge, MessageCarEdgeData, MessageBool, RoadsState)
METHOD_REQUEST_INPUT (InGetRecVelOnJunc, MessageFirst3Juncs, MessageFloat, RoadsState)
METHOD_REQUEST_INPUT (InGetTurnOnJunc, MessageFirst3Juncs, MessageUnsignedInt, RoadsState)
METHOD_REQUEST_INPUT (InIsCarFstPutAsideOnEdge, MessageCarEdge, MessageBool, RoadsState)
METHOD_REQUEST_INPUT (InRegisterPutAsideCarForEdge, MessageCarEdgeData, MessageBool, RoadsState)
METHOD_REQUEST_INPUT (InGetCarEnvirons, MessageCarSimParameters, MessageCarEnvirons, RoadsState)

Macro Definition Documentation

#define BMW_LP 1
#define BMW_WHITE_LP 2
#define GENERAL_MAX_JUNC_SPEED 7.5
#define HF_VECS_COEF 1.5
#define IVECO 3
#define RS_LOAD_MODEL | ( | variable,
 |  | dataPartPath,
 |  | errorNum
 | ) |
Value:
Node * variable = ((MessageNode*)world->getEventDispatcherPtr()->request(pCarPartsNodeCache, \
"InGetCarPartNode", new MessageString(dataPath + dataPartPath)).get())->data; \
if (!variable) { \
world->errorLog("Error %d: %s%s can't be found.", errorNum, dataPath.c_str(), dataPartPath); \
return; \
}

Function Documentation

METHOD_INPUT | ( | InUnregCarForEdge | ,
 |  | MessageCarEdge | ,
 |  | RoadsState |
 | ) |  |
METHOD_INPUT | ( | InAddForEdgeRegisteredCarToPutAsideCars | ,
 |  | MessageCarEdge | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetReady | ,
 |  | MessageVoid | ,
 |  | MessageBool | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetDataPath | ,
 |  | MessageVoid | ,
 |  | MessageString | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetEdgeAbsPos | ,
 |  | MessageEdgeOffset | ,
 |  | MessageVec3 | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetEdgeOutInVec | ,
 |  | MessageUnsignedInt | ,
 |  | MessageVec3 | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetEdgeNormal | ,
 |  | MessageUnsignedInt | ,
 |  | MessageVec3 | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InFindShortestPath | ,
 |  | MessageStartStopDestination | ,
 |  | MessageVectorUnsignedInt | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InCheckCarStopPosition | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetStartOrStopEdgeFromRoadAndDirection | ,
 |  | MessageRoadAndDir | ,
 |  | MessageUnsignedInt | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InRegCarForEdge | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetRecVelOnJunc | ,
 |  | MessageFirst3Juncs | ,
 |  | MessageFloat | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetTurnOnJunc | ,
 |  | MessageFirst3Juncs | ,
 |  | MessageUnsignedInt | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InIsCarFstPutAsideOnEdge | ,
 |  | MessageCarEdge | ,
 |  | MessageBool | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InRegisterPutAsideCarForEdge | ,
 |  | MessageCarEdgeData | ,
 |  | MessageBool | ,
 |  | RoadsState |
 | ) |  |
METHOD_REQUEST_INPUT | ( | InGetCarEnvirons | ,
 |  | MessageCarSimParameters | ,
 |  | MessageCarEnvirons | ,
 |  | RoadsState |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/TLsOnJuncManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
TLsOnJuncManager.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/CarSim/TLsOnJuncManager.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor Directory Reference

  • src
  • vreckoAP
  • ConnectEditor
ConnectEditor Directory Reference

Files

file | AP_ConnectEditor.cpp
file | ConnectEditor.cpp
file | ConnectEditor_Connecting.cpp
file | ConnectEditor_icp.cpp
file | ConnectEditor_Morphing.cpp
file | ConnectEditor_SnappingRegion.cpp
file | connecting_functions.cpp
file | Cut.cpp
file | erf.cpp
file | functions.cpp
file | icp_functions.cpp
file | normal.cpp
file | Optimalizer.cpp
file | PolygonState.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Rotation.cpp
file | Scale.cpp
file | SnapObject.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/AP_ConnectEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Functions | Variables
AP_ConnectEditor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/AP_ConnectEditor.h>
#include <vreckoAP/ConnectEditor/ConnectEditor.h>
#include <vreckoAP/ConnectEditor/Optimalizer.h>
#include <vreckoAP/ConnectEditor/Rotation.h>
#include <vreckoAP/ConnectEditor/Scale.h>
#include <vreckoAP/ConnectEditor/Cut.h>
#include <vreckoAP/ConnectEditor/PolygonState.h>

Functions

AP_EXPORT const char * | ConnectEditor_getPluginDescription ()
AP_EXPORT char ** | ConnectEditor_getAbilityList ()
AP_EXPORT const char * | ConnectEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | ConnectEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | ConnectEditor_setAbilitiesParameters ()

Variables

char * | g_pAPConnectEditorPluginName = {"ConnectEditor"}
char * | g_pAPConnectEditorAbilityName []
char * | g_pAPConnectEditorAbilityDesc []

Function Documentation

AP_EXPORT const char* ConnectEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* ConnectEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT char** ConnectEditor_getAbilityList ( )
AP_EXPORT const char* ConnectEditor_getPluginDescription ( )
AP_EXPORT void ConnectEditor_setAbilitiesParameters ( )

Variable Documentation

char* g_pAPConnectEditorAbilityDesc[]
Initial value:
= {
"Snap and connect objects",
"Remove unused or duplicit points",
"Rotating with object",
"Scaling with object",
"Cut ability to divide object into two parts",
"Set polygon state for renderer",
""
}
char* g_pAPConnectEditorAbilityName[]
Initial value:
= {
"SnapAndConnect",
"Optimalizer",
"Rotation"
"Scale"
"Cut",
"PolygonState",
""
}
char* g_pAPConnectEditorPluginName = {"ConnectEditor"}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
ConnectEditor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/ConnectEditor.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <helpers/XercesXMLUtils.h>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_Connecting.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces | Macros
ConnectEditor_Connecting.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/ConnectEditor.h>

Namespaces

namespace APConnectEditor

Macros

#define | USE_BIGGER_REGION
#define | ERASE_AREA
#define | UPDATE_DISPLAY_LIST_OF_BOTH_OBJECTS
#define | CONNECT_OBJECTS_BIGGER_LOOP
#define | REPAIR_LOOP_TO_LOOP_POSTION
#define | ADD_DIFERENCE_TO_FACE
#define | FILL_HOLES_ONE_TRIANGLE_REPLACED_BY_MANY
#define | MERGE_OBJECTS
#define | FILL_HOLES_SECOND_TYPE_SINGLE_LINES
#define | FIND_HOLES

Macro Definition Documentation

#define ADD_DIFERENCE_TO_FACE
#define CONNECT_OBJECTS_BIGGER_LOOP
#define ERASE_AREA
#define FILL_HOLES_ONE_TRIANGLE_REPLACED_BY_MANY
#define FILL_HOLES_SECOND_TYPE_SINGLE_LINES
#define FIND_HOLES
#define MERGE_OBJECTS
#define REPAIR_LOOP_TO_LOOP_POSTION
#define UPDATE_DISPLAY_LIST_OF_BOTH_OBJECTS
#define USE_BIGGER_REGION
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_icp.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces | Macros
ConnectEditor_icp.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/ConnectEditor.h>
#include <vreckoAP/ConnectEditor/icp_functions.h>

Namespaces

namespace APConnectEditor

Macros

#define | EPSILON 0.00001
#define | MAX_ITERATIONS 200

Macro Definition Documentation

#define EPSILON 0.00001
#define MAX_ITERATIONS 200
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_Morphing.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces | Macros
ConnectEditor_Morphing.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/ConnectEditor.h>
#include <vreckoAP/ConnectEditor/connecting_functions.h>

Namespaces

namespace APConnectEditor

Macros

#define | USE_BIGGER_REGION
#define | MORPH_MASTER_VERTICES
#define | MORPH_SLAVE_VERTICES
#define | MORPH_SECOND_ITERATION

Macro Definition Documentation

#define MORPH_MASTER_VERTICES
#define MORPH_SECOND_ITERATION
#define MORPH_SLAVE_VERTICES
#define USE_BIGGER_REGION
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/ConnectEditor_SnappingRegion.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
ConnectEditor_SnappingRegion.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/ConnectEditor.h>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/connecting_functions.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Macros | Functions
connecting_functions.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/connecting_functions.h>
#include <vreckoAP/ConnectEditor/erf.h>
#include <math.h>

Macros

#define | EPSILON 0.000000001
#define | PI 3.14159265
#define | parameterB 0
#define | parameterU 0.5
#define | parameterO 0.2

Functions

float | weightFunction (float value)
double | weightFunctionNormalize (double value, double maxValue)
double | weightGaussFunction (double x)
double | F (double x)

Macro Definition Documentation

#define EPSILON 0.000000001
#define parameterB 0
#define parameterO 0.2
#define parameterU 0.5
#define PI 3.14159265

Function Documentation

double F ( double x )
float weightFunction ( float value )
double weightFunctionNormalize | ( | double | value,
 |  | double | maxValue
 | ) |  |
double weightGaussFunction ( double x )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Cut.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Classes | Namespaces
Cut.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/Cut.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Scene.h>
#include <osgDB/ReadFile>
#include <sstream>
#include <osgGA/StateSetManipulator>
#include <osg/PolygonMode>
#include <osg/CullFace>

Classes

struct | APConnectEditor::MyReadCallback
class | APConnectEditor::EOLineSegmentIntersector

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/erf.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Macros | Functions
erf.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <math.h>

Macros

#define LOG_PI_OVER_2 0.572364942924700087071713675675 /* log_e(PI)/2 */

Functions

double | erf (double x)
double | erfc (double x)

Macro Definition Documentation

#define LOG_PI_OVER_2 0.572364942924700087071713675675 /* log_e(PI)/2 */

Function Documentation

double erf ( double x )
double erfc ( double x )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/functions.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Macros | Functions
functions.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/functions.h>

Macros

#define | EPSILON 0.00000001
#define | WEIGHT1 0.6
#define | WEIGHT2 0.3

Functions

osg::Geode * | getGeodeOf (osg::Node *eo)
osg::Geometry * | getGeometryOf (osg::Node *eo)
osg::Vec3Array * | getVerticesOf (osg::Node *eo)
osg::Vec3Array * | getNormalsOf (osg::Node *eo)
DrawElementsUShort * | getFacesOf (osg::Node *eo)
void | printMessageTime (string str, float time)
void | printMessage (string str)
void | printMessage (string str, float number)
void | printErrorMessage (string str)
vector< int > | findClosestPoint (vector< int > snappingRegion, Vec3Array *points, vector< int > browsingSnappingRegion, Vec3Array *browsingPoints)
vector< int > | findClosestPointNorm (vector< int > boundarySnappingRegion, Vec3Array *boundaryPoints, Vec3Array *boundaryNormals, vector< int > browsingSnappingRegion, Vec3Array *browsingPoints, Vec3Array *browsingNormals)
float | p2pEuclideanDistance (osg::Vec3 point1, osg::Vec3 point2)
osg::Vec3 | centerOfMass (osg::Vec3Array *points)
osg::Vec3 | centerOfMass (osg::Vec3Array *points, vector< int > area)
float | matrixTrace3x3 (float matrix[3][3])
bool | getMatrixOfRotation (float q[7], float R[4][4])
bool | getMatrixOfRotation (float q[7], osg::Matrix &m)
void | matrixTranspose4x4 (float m[4][4], float mt[4][4])
float | quaternionLength (float q[7])
void | quaternionNormalize (float q[7], float qNormalized[7])
bool | getMergeMatrix (EnvironmentObject *targetEo, EnvironmentObject *sourceEo, osg::Matrix &matrix)
bool | addLinesToScene (map< int, int > lines, Vec3Array *sourceVertices, Vec3Array *targetVertices, EnvironmentObject *eoParent)
bool | addLinesToScene (vector< int > lines, Vec3Array *vertices, EnvironmentObject *eoParent, int color, std::string name)
bool | addLinesToEo (vector< int > lines, Vec3Array *vertices, EnvironmentObject *eo, int color, std::string name)
bool | addMeshToScene (vector< int > boundaryLoop, EnvironmentObject *eoLoop)
bool | addMeshToScene (vector< int > boundaryLoop, EnvironmentObject *eoLoop, int color)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color)
bool | addMeshToScene (vector< int > boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color, std::string name)
bool | addVerticesToScene (osg::Vec3Array *vertices, Group *parent)
bool | addPointToScene (osg::Vec3 point, osg::Group *parentEnvironmentObject)
bool | addPointToScene90 (osg::Vec3 point, osg::Group *parentEnvironmentObject)
float | normalsVariance (osg::Vec3 n1, osg::Vec3 n2)
osg::Vec3 | findClosestPointOnFace (osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB, osg::Vec3 pointC, bool &onFace)
osg::Vec3 | findClosestPointOnLine (osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB)
bool | includeFace (unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *faces)
bool | eraseFace (unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *faces)

Macro Definition Documentation

#define EPSILON 0.00000001
#define WEIGHT1 0.6
#define WEIGHT2 0.3

Function Documentation

bool addLinesToEo | ( | vector< int > | lines,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | eo,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addLinesToScene | ( | map< int, int > | lines,
 |  | Vec3Array * | sourceVertices,
 |  | Vec3Array * | targetVertices,
 |  | EnvironmentObject * | eoParent
 | ) |  |
bool addLinesToScene | ( | vector< int > | lines,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | eoParent,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | EnvironmentObject * | eoLoop
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | EnvironmentObject * | eoLoop,
 |  | int | color
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent,
 |  | int | color
 | ) |  |
bool addMeshToScene | ( | vector< int > | boundaryLoop,
 |  | Vec3Array * | vertices,
 |  | EnvironmentObject * | parent,
 |  | int | color,
 |  | std::string | name
 | ) |  |
bool addPointToScene | ( | osg::Vec3 | point,
 |  | osg::Group * | parentEnvironmentObject
 | ) |  |
bool addPointToScene90 | ( | osg::Vec3 | point,
 |  | osg::Group * | parentEnvironmentObject
 | ) |  |
bool addVerticesToScene | ( | osg::Vec3Array * | vertices,
 |  | Group * | parent
 | ) |  |
osg::Vec3 centerOfMass ( osg::Vec3Array * points )
osg::Vec3 centerOfMass | ( | osg::Vec3Array * | points,
 |  | vector< int > | area
 | ) |  |
bool eraseFace | ( | unsigned long | pointA,
 |  | unsigned long | pointB,
 |  | unsigned long | pointC,
 |  | osg::DrawElementsUShort * | faces
 | ) |  |
vector<int> findClosestPoint | ( | vector< int > | snappingRegion,
 |  | Vec3Array * | points,
 |  | vector< int > | browsingSnappingRegion,
 |  | Vec3Array * | browsingPoints
 | ) |  |
vector<int> findClosestPointNorm | ( | vector< int > | boundarySnappingRegion,
 |  | Vec3Array * | boundaryPoints,
 |  | Vec3Array * | boundaryNormals,
 |  | vector< int > | browsingSnappingRegion,
 |  | Vec3Array * | browsingPoints,
 |  | Vec3Array * | browsingNormals
 | ) |  |
osg::Vec3 findClosestPointOnFace | ( | osg::Vec3 | point,
 |  | osg::Vec3 | pointA,
 |  | osg::Vec3 | pointB,
 |  | osg::Vec3 | pointC,
 |  | bool & | onFace
 | ) |  |
osg::Vec3 findClosestPointOnLine | ( | osg::Vec3 | point,
 |  | osg::Vec3 | pointA,
 |  | osg::Vec3 | pointB
 | ) |  |
DrawElementsUShort* getFacesOf ( osg::Node * eo )
osg::Geode* getGeodeOf ( osg::Node * eo )
osg::Geometry* getGeometryOf ( osg::Node * eo )
bool getMatrixOfRotation | ( | float | q[7],
 |  | float | R[4][4]
 | ) |  |
bool getMatrixOfRotation | ( | float | q[7],
 |  | osg::Matrix & | m
 | ) |  |
bool getMergeMatrix | ( | EnvironmentObject * | targetEo,
 |  | EnvironmentObject * | sourceEo,
 |  | osg::Matrix & | matrix
 | ) |  |
osg::Vec3Array* getNormalsOf ( osg::Node * eo )
osg::Vec3Array* getVerticesOf ( osg::Node * eo )
bool includeFace | ( | unsigned long | pointA,
 |  | unsigned long | pointB,
 |  | unsigned long | pointC,
 |  | osg::DrawElementsUShort * | faces
 | ) |  |
float matrixTrace3x3 ( float matrix[3][3] )
void matrixTranspose4x4 | ( | float | m[4][4],
 |  | float | mt[4][4]
 | ) |  |
float normalsVariance | ( | osg::Vec3 | n1,
 |  | osg::Vec3 | n2
 | ) |  |
float p2pEuclideanDistance | ( | osg::Vec3 | point1,
 |  | osg::Vec3 | point2
 | ) |  |
void printErrorMessage ( string str )
void printMessage ( string str )
void printMessage | ( | string | str,
 |  | float | number
 | ) |  |
void printMessageTime | ( | string | str,
 |  | float | time
 | ) |  |
float quaternionLength ( float q[7] )
void quaternionNormalize | ( | float | q[7],
 |  | float | qNormalized[7]
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/icp_functions.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Macros | Functions
icp_functions.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/icp_functions.h>
#include <math.h>

Macros

#define JACEPS 1.0e-7

Functions

int | jacobi2 (int n, double *a[], double d[], double *v[])
void | Perpendiculars (const double x[3], double y[3], double z[3], double theta)

Macro Definition Documentation

#define JACEPS 1.0e-7

Function Documentation

int jacobi2 | ( | int | n,
 |  | double * | a[],
 |  | double | d[],
 |  | double * | v[]
 | ) |  |
void Perpendiculars | ( | const double | x[3],
 |  | double | y[3],
 |  | double | z[3],
 |  | double | theta
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/normal.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Functions
normal.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/normal.h>
#include <math.h>

Functions

bool | recomputeNormals (EnvironmentObject *eo)
Vec3 | Vector (Vec3 a, Vec3 b)
Vec3 | Cross (Vec3 a, Vec3 b)
Vec3 | CalculateVector (Vec3 a, Vec3 b, Vec3 c)
float | getAngle (osg::Vec3 A, osg::Vec3 B, osg::Vec3 C)

Function Documentation

Vec3 CalculateVector | ( | Vec3 | a,
 |  | Vec3 | b,
 |  | Vec3 | c
 | ) |  |
Vec3 Cross | ( | Vec3 | a,
 |  | Vec3 | b
 | ) |  |
float getAngle | ( | osg::Vec3 | A,
 |  | osg::Vec3 | B,
 |  | osg::Vec3 | C
 | ) |  |
bool recomputeNormals ( EnvironmentObject * eo )
Vec3 Vector | ( | Vec3 | a,
 |  | Vec3 | b
 | ) |  |
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Optimalizer.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
Optimalizer.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scene.h>
#include <vreckoAP/ConnectEditor/Optimalizer.h>
#include <ctime>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/PolygonState.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
PolygonState.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/PolygonState.h>
#include <vrecko/EnvironmentObject.h>
#include <sstream>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <osgGA/StateSetManipulator>
#include <osg/PolygonMode>
#include <osg/CullFace>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
precompiled.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/PluginManager.h>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <helpers/DynamicArray.h>
#include <helpers/XercesXMLUtils.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <math.h>
#include <time.h>
#include <osg/PolygonMode>
#include <osgDB/ReadFile>
#include <osgGA/StateSetManipulator>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Rotation.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
Rotation.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/Rotation.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <helpers/XercesXMLUtils.h>
#include <vrecko/ReaderWriter.h>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/Scale.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Namespaces
Scale.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/Scale.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APConnectEditor
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/SnapObject.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
Macros
SnapObject.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ConnectEditor/SnapObject.h>
#include <vreckoAP/ConnectEditor/normal.h>
#include <vrecko/Scene.h>

Macros

#define | EPSILON 0.000001
#define | WEIGHT1 0.6
#define | WEIGHT2 0.3
#define | MAX_INT 256

Macro Definition Documentation

#define EPSILON 0.000001
#define MAX_INT 256
#define WEIGHT1 0.6
#define WEIGHT2 0.3
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement Directory Reference

  • src
  • vreckoAP
  • ConstrainedMovement
ConstrainedMovement Directory Reference

Files

file | AP_ConstrainedMovement.cpp
file | ConstrainedObjectMovement.cpp
file | ConstraintArea.cpp
file | ConstraintDescription.cpp
file | ConstraintHierarchy.cpp
file | PolygonUtils.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/AP_ConstrainedMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
Functions | Variables
AP_ConstrainedMovement.cpp File Reference
#include <vreckoAp/ConstrainedMovement/AP_ConstrainedMovement.h>
#include <vreckoAp/ConstrainedMovement/ConstrainedObjectMovement.h>
#include <vreckoAp/ConstrainedMovement/ConstraintDescription.h>

Functions

AP_EXPORT const char * | ConstrainedMovement_getPluginDescription ()
AP_EXPORT const char ** | ConstrainedMovement_getAbilityList ()
AP_EXPORT const char * | ConstrainedMovement_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | ConstrainedMovement_getAbilityInstance (const char *pchName)
AP_EXPORT void | ConstrainedMovement_setAbilitiesParameters ()

Variables

const char * | g_pAPConstrainedMovementPluginName = {"ConstrainedMovement"}
const char * | g_pAPConstrainedMovementAbilityName []
const char * | g_pAPConstrainedMovementAbilityDesc []

Function Documentation

AP_EXPORT const char* ConstrainedMovement_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* ConstrainedMovement_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** ConstrainedMovement_getAbilityList ( )
AP_EXPORT const char* ConstrainedMovement_getPluginDescription ( )
AP_EXPORT void ConstrainedMovement_setAbilitiesParameters ( )

Variable Documentation

const char* g_pAPConstrainedMovementAbilityDesc[]
Initial value:
= {
"EDITOR ABILITY to move an object around the scene according to the pointer's motion and using constraints.",
"Describes constraints of an object.",
""
}
const char* g_pAPConstrainedMovementAbilityName[]
Initial value:
= {
"ConstrainedObjectMovement",
"ConstraintDescription",
NULL
}
const char* g_pAPConstrainedMovementPluginName = {"ConstrainedMovement"}
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
Namespaces | Macros | Variables
ConstrainedObjectMovement.cpp File Reference
#include <vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.h>
#include <vreckoAP/ConstrainedMovement/ConstraintDescription.h>
#include <vreckoAP/ConstrainedMovement/PolygonUtils.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <helpers/DynamicArray.h>
#include <helpers/HelperMacros.h>
#include <osg/BlendEquation>
#include <osg/CullFace>
#include <osg/Depth>
#include <osg/PolygonOffset>
#include <osg/io_utils>

Namespaces

namespace APConstrainedMovement

Macros

#define | POINTER_ROTATION_MULTIPLIER 3
#define | OPACITY_MULTIPLIER 0.7

Variables

vector< int > APConstrainedMovement::watchedObjectIDs

Macro Definition Documentation

#define OPACITY_MULTIPLIER 0.7
#define POINTER_ROTATION_MULTIPLIER 3
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintArea.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
Namespaces | Macros | Functions
ConstraintArea.cpp File Reference
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <osg/Vec2f>
#include <vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.h>
#include <vreckoAP/ConstrainedMovement/ConstraintArea.h>

Namespaces

namespace APConstrainedMovement

Macros

#define TWOPI 6.283185307179586476925287

Functions

double | APConstrainedMovement::calcAngleSum (osg::Vec3 q, Vecs3 &p)
double | APConstrainedMovement::vectorAngle (osg::Vec3 vector1, osg::Vec3 vector2)

Macro Definition Documentation

#define TWOPI 6.283185307179586476925287
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintDescription.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
Namespaces | Macros
ConstraintDescription.cpp File Reference
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vreckoAP/ConstrainedMovement/ConstraintDescription.h>
#include <vreckoAP/ConstrainedMovement/ConstraintArea.h>
#include <vreckoAP/ConstrainedMovement/ConstraintHierarchy.h>
#include <vrecko/ReaderWriter.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/dom/DOMImplementationLS.hpp>
#include <xercesc/dom/DOMImplementationRegistry.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/dom/DOMException.hpp>
#include <xercesc/dom/DOMDocument.hpp>
#include <xercesc/dom/DOMNodeList.hpp>
#include <xercesc/dom/DOMError.hpp>
#include <xercesc/dom/DOMLocator.hpp>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/dom/DOMAttr.hpp>
#include <xercesc/util/XMLInteger.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>

Namespaces

namespace APConstrainedMovement

Macros

#define | DUAL_SPLITTING_ANGLE_THRESHOLD 0.7
#define | DUAL_SPLITTING_THRESHOLD 0.5

Macro Definition Documentation

#define DUAL_SPLITTING_ANGLE_THRESHOLD 0.7
#define DUAL_SPLITTING_THRESHOLD 0.5
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/ConstraintHierarchy.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
ConstraintHierarchy.cpp File Reference
#include <vreckoAP/ConstrainedMovement/ConstraintHierarchy.h>
#include <helpers/XercesXMLUtils.h>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/dom/DOMImplementation.hpp>
#include <xercesc/dom/DOMImplementationLS.hpp>
#include <xercesc/dom/DOMImplementationRegistry.hpp>
#include <xercesc/dom/DOMBuilder.hpp>
#include <xercesc/dom/DOMException.hpp>
#include <xercesc/dom/DOMDocument.hpp>
#include <xercesc/dom/DOMNodeList.hpp>
#include <xercesc/dom/DOMError.hpp>
#include <xercesc/dom/DOMLocator.hpp>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/dom/DOMAttr.hpp>
#include <xercesc/util/XMLInteger.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConstrainedMovement/PolygonUtils.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ConstrainedMovement
Namespaces | Macros | Functions
PolygonUtils.cpp File Reference
#include <vreckoAP/ConstrainedMovement/PolygonUtils.h>

Namespaces

namespace APConstrainedMovement

Macros

#define | COLLINEAR_ORIENTATION 0
#define | RIGHT_HAND_SIDE -1
#define | LEFT_HAND_SIDE +1

Functions

float | APConstrainedMovement::area (osg::Vec3 &point1, osg::Vec3 &point2, osg::Vec3 &point3)
osg::Vec3 | APConstrainedMovement::centroid (Vecs3 polygon)
int | APConstrainedMovement::orientation (float x1, float y1, float x2, float y2, float px, float py)
bool | APConstrainedMovement::convexPolygon (Vecs3 polygon)

Macro Definition Documentation

#define COLLINEAR_ORIENTATION 0
#define LEFT_HAND_SIDE +1
#define RIGHT_HAND_SIDE -1
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt Directory Reference

  • src
  • vreckoAP
  • DynamicArt
DynamicArt Directory Reference

Files

file | AP_DynamicArt.cpp
file | Attractor.cpp
file | Brush.cpp
file | BrushStroke.cpp
file | BrushStrokeControlPoint.cpp
file | BrushStrokeControlPoint.h [code]
file | BrushStrokeTriangulator.cpp
file | BrushStrokeTriangulator.h [code]
file | BufferedSpline.cpp
file | BufferedSpline.h [code]
file | CatmullRomInterpolator.cpp
file | CatmullRomInterpolator.h [code]
file | ColorGenAdapter.cpp
file | ComputeThread.cpp
file | ConstantColorGen.h [code]
file | Controller.cpp
file | Ctrl_Attractor.cpp
file | Ctrl_FreeHandPainting.cpp
file | Ctrl_MotionVisualization.cpp
file | Ctrl_PerlinLines.cpp
file | Ctrl_PolyhedraSculptures.cpp
file | Ctrl_StringSculptures.cpp
file | CubicInterpolator.cpp
file | CubicInterpolator.h [code]
file | DAEnvironment.cpp
file | DATool.cpp
file | DiameterGenAdapter.cpp
file | Factories.h [code]
file | FilletSpline.cpp
file | FilletSpline.h [code]
file | FrenetFrame.cpp
file | FrenetFrame.h [code]
file | GradientColorGen.h [code]
file | GradientDiameterGen.h [code]
file | Hook.cpp
file | HookManager.cpp
file | Hoop.cpp
file | HoopGeometry.cpp
file | HoopGeometry.h [code]
file | HoopShape.cpp
file | Icon.cpp
file | Icon.h [code]
file | InterpolatedSpline.cpp
file | InterpolatedSpline.h [code]
file | Interpolator.h [code]
file | JuliaAttractor.cpp
file | LinearInterpolator.cpp
file | LinearInterpolator.h [code]
file | MagicWandTool.cpp
file | MagicWandTool.h [code]
file | Modes.cpp
file | MotionTrail.cpp
file | MTBrush.cpp
file | MTBrush.h [code]
file | MTControlPoint.cpp
file | MTControlPoint.h [code]
file | MTCreatorTool.cpp
file | MTCreatorTool.h [code]
file | MTTriangulator.cpp
file | MTTriangulator.h [code]
file | NullAttractor.cpp
file | OrdinaryAttractor.cpp
file | ParticleSystem.cpp
file | Pattern.cpp
file | PatternGeode.cpp
file | PerlinLines.cpp
file | PerlinLinesTools.cpp
file | PhysXManager.cpp
file | PhysXModule.cpp
file | PhysXModule.h [code]
file | PoA.cpp
file | PoB.cpp
file | PoB.h [code]
file | PolyhedraSculpture.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | PS_Component.cpp
file | PS_Face.cpp
file | PS_FacePlane.cpp
file | PS_FlatShape.cpp
file | PS_Layer.cpp
file | PS_Polyhedron.cpp
file | PS_Symmetry.cpp
file | RegularPolygonSpline.cpp
file | RegularPolygonSpline.h [code]
file | RotationFrameGenAdapter.cpp
file | SampledSpline.cpp
file | SampledSpline.h [code]
file | SectorColorGen.cpp
file | SectorManager.cpp
file | ShapeFactory.cpp
file | ShapeFactory.h [code]
file | ShapeGenerator.cpp
file | ShapeGenerator.h [code]
file | SimpleBox.cpp
file | SliceTool.cpp
file | SliceTool.h [code]
file | SmoothedSpline.cpp
file | SmoothedSpline.h [code]
file | SnapPoint.cpp
file | SnapPoint.h [code]
file | SplineAdapter.cpp
file | SweepSurfaceGeode.cpp
file | SweepSurfaceGeode.h [code]
file | TimeLineSpline.cpp
file | Timing.cpp
file | ToolBrush.cpp
file | ToolEraser.cpp
file | ToolHook.cpp
file | ToolMagicWand.cpp
file | ToolRotation.cpp
file | ToolSelector.cpp
file | ToolSlice.cpp
file | ToolTongs.cpp
file | Utils.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/AP_DynamicArt.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Functions | Variables
AP_DynamicArt.cpp File Reference
#include "precompiled.h"
#include <string.h>
#include <vreckoAP/DynamicArt/AP_DynamicArt.h>
#include <vreckoAP/DynamicArt/Ctrl_StringSculptures.h>
#include <vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h>
#include <vreckoAP/DynamicArt/ToolHook.h>

Functions

const char ** | getAbilityList (void)
Ability * | getAbilityInstance (const char *_name)
void AP_EXPORT | initializeAttributesDescription ()

Variables

const char * | _DynamicArt_plugin_name = { "DynamicArt" }
const char * | _DynamicArt_ability_name []
Ability * _new_ability

Function Documentation

Ability* getAbilityInstance ( const char * _name )
const char** getAbilityList ( void )
void AP_EXPORT initializeAttributesDescription ( )

Variable Documentation

const char* _DynamicArt_ability_name[]
Initial value:
= {
"DAEnvironment",
"Ctrl_FreeHandPainting",
"Ctrl_MotionVisualization",
"Ctrl_Attractor",
"Ctrl_PerlinLines",
"Ctrl_StringSculptures",
"ToolBrush",
"ToolTongs",
"ToolEraser",
"ToolMagicWand",
"ToolSlice",
"ToolSelector",
"ToolRotation",
"ToolHook",
NULL}
const char* _DynamicArt_plugin_name = { "DynamicArt" }
Ability* _new_ability
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Attractor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Attractor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Attractor.h>
#include <vreckoAP/DynamicArt/OrdinaryAttractor.h>
#include <vreckoAP/DynamicArt/JuliaAttractor.h>
#include <vreckoAP/DynamicArt/NullAttractor.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Brush.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Brush.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Brush.h>
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStroke.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Macros | Functions
BrushStroke.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/BrushStroke.h>
#include <vreckoAP/DynamicArt/Controller.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include "spline.h"
#include "SampledSpline.h"
#include "RegularPolygonSpline.h"
#include "RMFrame.h"
#include "HandFrame.h"
#include "InterpolatedSpline.h"
#include "LinearInterpolator.h"
#include "CatmullRomInterpolator.h"
#include "SmoothedSpline.h"
#include "FilletSpline.h"
#include <vreckoAP/DynamicArt/DiameterGenAdapter.h>

Namespaces

namespace APDYNAMICART

Macros

#define UPDATE_CONTROL_POINTS_MIN_DISTANCE 0.125

Functions

APDYNAMICART::METHOD_INPUT (Colour, MessageVec4, BrushStroke)

Macro Definition Documentation

#define UPDATE_CONTROL_POINTS_MIN_DISTANCE 0.125
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
BrushStrokeControlPoint.cpp File Reference
#include "precompiled.h"
#include "BrushStrokeControlPoint.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Namespaces
BrushStrokeControlPoint.h File Reference
#include "SimpleBox.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::DAGizmo
Gizmo - graphical representation of something, e.g. Frenet frame. More...
class | APDYNAMICART::BrushStrokeControlPoint
Control point of Sweep Surface. More...

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeTriangulator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BrushStrokeTriangulator.cpp File Reference
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeTriangulator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BrushStrokeTriangulator.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BufferedSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BufferedSpline.cpp File Reference
#include "precompiled.h"
#include "BufferedSpline.h"
#include "Utils.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BufferedSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
BufferedSpline.h File Reference
#include "spline.h"

Go to the source code of this file.

Classes

class BufferedSpline

Typedefs

typedef osg::ref_ptr
< BufferedSpline > 		BufferedSplinePtr

Typedef Documentation

typedef osg::ref_ptr<BufferedSpline> BufferedSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CatmullRomInterpolator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
CatmullRomInterpolator.cpp File Reference
#include "precompiled.h"
#include "CatmullRomInterpolator.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CatmullRomInterpolator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
CatmullRomInterpolator.h File Reference
#include "Interpolator.h"

Go to the source code of this file.

Classes

class CatmullRomInterpolator
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ColorGenAdapter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ColorGenAdapter.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ColorGenAdapter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ComputeThread.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
ComputeThread.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ComputeThread.h>
#include <random>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ConstantColorGen.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
ConstantColorGen.h File Reference
#include "ColorGen.h"

Go to the source code of this file.

Classes

class ConstantColorGen
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Controller.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Controller.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Controller.h>
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_Attractor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Ctrl_Attractor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_Attractor.h>
#include <vreckoAP/DynamicArt/Attractor.h>
#include <vreckoAP/DynamicArt/ToolMagicWand.h>
#include <vreckoAP/DynamicArt/ToolSlice.h>
#include <vreckoAP/DynamicArt/ToolTongs.h>
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_FreeHandPainting.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Ctrl_FreeHandPainting.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_FreeHandPainting.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include "RegularPolygonSpline.h"
#include "SampledSpline.h"
#include "LinearInterpolator.h"
#include "InterpolatedSpline.h"
#include <iomanip>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_MotionVisualization.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Ctrl_MotionVisualization.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_MotionVisualization.h>
#include <vreckoAP/DynamicArt/MotionTrail.h>
#include "RegularPolygonSpline.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_PerlinLines.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
Ctrl_PerlinLines.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_PerlinLines.h>
#include <vreckoAP/DynamicArt/DATool.h>
#include <osg/BlendFunc>
#include <osg/Geometry>
#include <osg/LineWidth>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (Position_sensor_0, MessageVec3, Ctrl_PerlinLines)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Ctrl_PolyhedraSculptures.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h>
#include <vreckoAP/DynamicArt/PS_Polyhedron.h>
#include <vreckoAP/DynamicArt/PolyhedraSculpture.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Ctrl_StringSculptures.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Ctrl_StringSculptures.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Ctrl_StringSculptures.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include <vreckoAP/DynamicArt/Hoop.h>
#include <vreckoAP/DynamicArt/PatternGeode.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <vreckoAP/DynamicArt/DATool.h>
#include <vreckoUtils/Math.h>
#include <vreckoAP/DynamicArt/HookManager.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CubicInterpolator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
CubicInterpolator.cpp File Reference
#include "precompiled.h"
#include "CubicInterpolator.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CubicInterpolator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
CubicInterpolator.h File Reference
#include "interpolator.h"

Go to the source code of this file.

Classes

class CubicInterpolator
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DAEnvironment.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Macros | Functions | Variables
DAEnvironment.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <vreckoAP/DynamicArt/ParticleSystem.h>
#include <vreckoAP/DynamicArt/Ctrl_FreeHandPainting.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include <vreckoAP/GUI/GUI_item.h>
#include <vreckoAP/GUI/Icon.h>
#include <vreckoAP/DynamicArt/PS_FacePlane.h>

Namespaces

namespace APDYNAMICART

Macros

#define | dbgDE(msg)
#define | changeAutoRotationSpeedStep 0.05

Functions

APDYNAMICART::METHOD_INPUT (Autorotation, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (ChangeAutoRotationSpeed, MessageInt, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Colour, MessageVec4, DAEnvironment)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, DAEnvironment)
APDYNAMICART::METHOD_INPUT (DebugPurposeKey, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, DAEnvironment)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (SwitchGUIVisibility, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Import, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (MenuItemClicked, MessageString, DAEnvironment)
APDYNAMICART::METHOD_INPUT (ResetDAArea, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Sensor_0_position, MessageVec3, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Sensor_1_position, MessageVec3, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Sensor_0_orientation, MessageQuat, DAEnvironment)
APDYNAMICART::METHOD_INPUT (Sensor_1_orientation, MessageQuat, DAEnvironment)
APDYNAMICART::METHOD_INPUT (ScaleDAArea, MessageInt, DAEnvironment)
APDYNAMICART::METHOD_INPUT (SwitchTool, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (SwitchRenderingMethod, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (QuickLoad, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (QuickSave, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_REQUEST_INPUT (Sensor_1_actionMain, MessageBool, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_REQUEST_INPUT (Sensor_0_actionMain, MessageBool, MessageBool, DAEnvironment)
APDYNAMICART::METHOD_INPUT (ExternalDeactivation, MessageObjectID, DAEnvironment)

Variables

std::string APDYNAMICART::saveFileNameBase = "da_scene#"

Macro Definition Documentation

#define changeAutoRotationSpeedStep 0.05
#define dbgDE ( msg )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DATool.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
DATool.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/DATool.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/DiameterGenAdapter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
DiameterGenAdapter.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/DiameterGenAdapter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Factories.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
Factories.h File Reference
#include "LinearInterpolator.h"
#include "CatmullRomInterpolator.h"

Go to the source code of this file.

Classes

class InterpolatorFactory
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FilletSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Macros
FilletSpline.cpp File Reference
#include "precompiled.h"
#include "FilletSpline.h"
#include "CatmullRomInterpolator.h"

Macros

#define dbgFS(msg)

Macro Definition Documentation

#define dbgFS ( msg )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FilletSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
FilletSpline.h File Reference
#include "Spline.h"

Go to the source code of this file.

Classes

class FilletSpline

Typedefs

typedef osg::ref_ptr
< FilletSpline > 		FilletSplinePtr

Typedef Documentation

typedef osg::ref_ptr<FilletSpline> FilletSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FrenetFrame.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
FrenetFrame.cpp File Reference
#include "precompiled.h"
#include "FrenetFrame.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FrenetFrame.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
FrenetFrame.h File Reference
#include "rotationframegenerator.h"

Go to the source code of this file.

Classes

class FrenetFrame
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientColorGen.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
GradientColorGen.h File Reference
#include "ColorGen.h"

Go to the source code of this file.

Classes

class GradientColorGen
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientDiameterGen.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
GradientDiameterGen.h File Reference
#include "DiameterGen.h"

Go to the source code of this file.

Classes

class GradientDiameterGen
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Hook.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Hook.cpp File Reference
#include "precompiled.h"
#include <osg\NodeTrackerCallback>
#include <vreckoAP/DynamicArt/Hook.h>
#include <vreckoAP/DynamicArt/Utils.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HookManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
HookManager.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/HookManager.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Hoop.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
Hoop.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Hoop.h>
#include "SweepSurface.h"
#include "InterpolatedSpline.h"
#include "LinearInterpolator.h"
#include "RMFrame.h"
#include "ConstantDiameterGen.h"
#include "ConstantColorGen.h"
#include <vreckoAP/DynamicArt/SectorManager.h>
#include <vreckoAP/DynamicArt/Ctrl_StringSculptures.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (Colour, MessageVec4, Hoop)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
HoopGeometry.cpp File Reference
#include "precompiled.h"
#include "HoopGeometry.h"
#include "Utils.h"
#include <osg\Array>
#include "ConstantBrush.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
HoopGeometry.h File Reference
#include <osg\Group>
#include "ShapeGenerator.h"
#include "Utils.h"
#include "PatternGeode.h"

Go to the source code of this file.

Classes

struct | APDYNAMICART::Trait
class | APDYNAMICART::HoopGeometry

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::map< std::string,
Trait > 		APDYNAMICART::TraitMap
typedef osg::ref_ptr
< HoopGeometry > 		APDYNAMICART::HoopGeometryPtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopShape.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
HoopShape.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/HoopShape.h>
#include <vecmath\Math.h>
#include "CatmullRomInterpolator.h"

Namespaces

namespace APDYNAMICART

Functions

void init ()

Function Documentation

void init ( )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Icon.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Icon.cpp File Reference
#include "precompiled.h"
#include "Icon.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Icon.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Enumerations
Icon.h File Reference
#include "PoB.h"
#include "Icon.h"

Go to the source code of this file.

Classes

class Icon
Icon. More...

Enumerations

enum IconType { ICON__BUTTON = 1, ICON__SWITCH, ICON__MULTISWITCH }
types of Icon More...

Enumeration Type Documentation

enum IconType

types of Icon

Enumerator
ICON__BUTTON | after clicking, single action happens
ICON__SWITCH | switch, with two possible states.
ICON__MULTISWITCH | switch, with more possible states.
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/InterpolatedSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
InterpolatedSpline.cpp File Reference
#include "precompiled.h"
#include "InterpolatedSpline.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/InterpolatedSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
InterpolatedSpline.h File Reference
#include <osg\ref_ptr>
#include "Spline.h"
#include "Interpolator.h"

Go to the source code of this file.

Classes

class InterpolatedSpline

Typedefs

typedef osg::ref_ptr
< InterpolatedSpline > 		InterpolatedSplinePtr

Typedef Documentation

typedef osg::ref_ptr<InterpolatedSpline> InterpolatedSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Interpolator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
Interpolator.h File Reference
#include <osg\Referenced>
#include <osg\ref_ptr>
#include <vector>
#include "types.h"
#include <iostream>

Go to the source code of this file.

Classes

class | Interpolator
class | NullInterpolator

Typedefs

typedef osg::ref_ptr
< Interpolator > 		InterpolatorPtr

Typedef Documentation

typedef osg::ref_ptr<Interpolator> InterpolatorPtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/JuliaAttractor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
JuliaAttractor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/JuliaAttractor.h>
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/LinearInterpolator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
LinearInterpolator.cpp File Reference
#include "precompiled.h"
#include "LinearInterpolator.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/LinearInterpolator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
LinearInterpolator.h File Reference
#include "interpolator.h"

Go to the source code of this file.

Classes

class LinearInterpolator
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MagicWandTool.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MagicWandTool.cpp File Reference
#include "precompiled.h"
#include "MagicWandTool.h"
#include "DAEnvironment.h"
#include "Attractor.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MagicWandTool.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
MagicWandTool.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "Attractor.h"

Go to the source code of this file.

Classes

class MagicWandTool
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Modes.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Modes.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Modes.h>
#include "types.h"
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MotionTrail.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Variables
MotionTrail.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/MotionTrail.h>
#include <vreckoAP/DynamicArt/Controller.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART

Variables

APDYNAMICART::__pad0__
APDYNAMICART::colorGenAdapter
APDYNAMICART::diamGenAdapt
APDYNAMICART::crossSectionAdapter
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTBrush.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTBrush.cpp File Reference
#include "precompiled.h"
#include "MTBrush.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTBrush.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Enumerations
MTBrush.h File Reference

Go to the source code of this file.

Classes

class MTBrush
Store info about shape of cross-section of Motion trail. More...

Enumerations

enum | MTBrushShapeType { MTBRUSH_SHAPE_ROUND = 101, MTBRUSH_SHAPE_RECTANGE, MTBRUSH_SHAPE_ROUNDED_RECTANGE }
enum | MTBrushParameterType { MTBRUSH_PARAMETER_CONSTANT = 1, MTBRUSH_PARAMETER_GRADIENT, MTBRUSH_PARAMETER_SPEED_BASED, MTBRUSH_PARAMETER_CURVATURE_BASED }

Enumeration Type Documentation

enum MTBrushParameterType
Enumerator
MTBRUSH_PARAMETER_CONSTANT
MTBRUSH_PARAMETER_GRADIENT
MTBRUSH_PARAMETER_SPEED_BASED
MTBRUSH_PARAMETER_CURVATURE_BASED
enum MTBrushShapeType
Enumerator
MTBRUSH_SHAPE_ROUND
MTBRUSH_SHAPE_RECTANGE
MTBRUSH_SHAPE_ROUNDED_RECTANGE
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTControlPoint.cpp File Reference
#include "precompiled.h"
#include "MTControlPoint.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
MTControlPoint.h File Reference
#include "SimpleBox.h"

Go to the source code of this file.

Classes

class | DAGizmo
Gizmo - graphical representation of something, e.g. Frenet frame. More...
class | DAControlPoint
Control point of Motion trail. More...
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTCreatorTool.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Macros
MTCreatorTool.cpp File Reference
#include "precompiled.h"
#include "MTCreatorTool.h"
#include "DAEnvironment.h"

Macros

#define | absf(x) ((x)<0.0?-(x):(x))
#define | SHOW_VISUALS_SAMPLES 1
#define | VISUALS_SAMPLE_MIN_DISTANCE 0.05

Macro Definition Documentation

#define absf ( x ) ((x)<0.0?-(x):(x))
#define SHOW_VISUALS_SAMPLES 1
#define VISUALS_SAMPLE_MIN_DISTANCE 0.05
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTCreatorTool.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
MTCreatorTool.h File Reference
#include "DATool.h"
#include "PoA.h"
#include "SimpleBox.h"

Go to the source code of this file.

Classes

class MTCreatorTool
Motion trails creator tool. More...

Typedefs

typedef osg::ref_ptr< SimpleBox > ref_ptr_SimpleBox
typedef osg::ref_ptr
< MTCreatorTool > 		ref_ptr_MTCreatorTool

Typedef Documentation

typedef osg::ref_ptr<MTCreatorTool> ref_ptr_MTCreatorTool
typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTTriangulator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTTriangulator.cpp File Reference
#include "precompiled.h"
#include "MTTriangulator.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTTriangulator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
MTTriangulator.h File Reference
#include "MTControlPoint.h"
#include "MTBrush.h"

Go to the source code of this file.

Classes

class MotionTrailTriangulator

Typedefs

typedef osg::ref_ptr
< DAControlPoint > 		ref_ptr_DAControlPoint
typedef osg::ref_ptr< SimpleBox > ref_ptr_SimpleBox

Typedef Documentation

typedef osg::ref_ptr<DAControlPoint> ref_ptr_DAControlPoint
typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/NullAttractor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
NullAttractor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/NullAttractor.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/OrdinaryAttractor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
OrdinaryAttractor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/OrdinaryAttractor.h>
#include <osg\LineWidth>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ParticleSystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ParticleSystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ParticleSystem.h>

Namespaces

namespace APDYNAMICART

Functions

void APDYNAMICART::createParticleSystem (osg::Group *emmitterParent, osg::Group *particleSystemParent, ParticleSystemParameters *params)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Pattern.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Pattern.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Pattern.h>
#include <assert.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PatternGeode.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
PatternGeode.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PatternGeode.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLines.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PerlinLines.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PerlinLines.h>
#include <vreckoAP/DynamicArt/ParticleSystem.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <osg/BlendFunc>
#include <osg/Geometry>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PerlinLinesTools.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PerlinLinesTools.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PerlinLinesTools.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PhysXManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PhysXManager.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PhysXManager.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include "ConstantDiameterGen.h"
#include <vreckoAP/DynamicArt/Timing.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PhysXModule.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
PhysXModule.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PhysXModule.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
PhysXModule.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoA.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PoA.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PoA.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoB.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PoB.cpp File Reference
#include "precompiled.h"
#include "PoB.h"
#include "DAEnvironment.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoB.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Enumerations
PoB.h File Reference
#include <osg/Geometry>

Go to the source code of this file.

Classes

class APDYNAMICART::PoB
PoB (Piece of Behavior) More...

Namespaces

namespace APDYNAMICART

Enumerations

enum APDYNAMICART::PoBType { APDYNAMICART::POB__ICON = 1 }
types of PoB More...
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PolyhedraSculpture.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PolyhedraSculpture.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/PolyhedraSculpture.h>
#include <vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <helpers/StringHelpers.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Macros | Enumerations | Functions
precompiled.h File Reference
#include <Windows.h>
#include <osg/Point>
#include <osg/PointSprite>
#include <osg/Texture2D>
#include <osg/BlendFunc>
#include <osgDB/ReadFile>
#include <osgGA/StateSetManipulator>
#include <osgParticle/ParticleSystem>
#include <osgParticle/ParticleSystemUpdater>
#include <osgParticle/ModularEmitter>
#include <osgParticle/ModularProgram>
#include <osgParticle/AccelOperator>
#include <osgParticle/FluidFrictionOperator>
#include <osgDB/WriteFile>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/PolygonMode>
#include <osg/Depth>
#include <osg/ClipNode>
#include <osgUtil/SmoothingVisitor>
#include <vrecko/Ability.h>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include <vreckoAP/GUI/GUI_Controller.h>
#include <vreckoAP/GUI/Menu.h>
#include <vreckoUtils/Menu.h>
#include <fstream>
#include <iostream>
#include <sstream>
#include <vector>
#include <math.h>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/util/XMLString.hpp>

Go to the source code of this file.

Classes

class DASample

Macros

#define | NOMINMAX
#define | absf(x) (x<0.0?-x:x)
#define | MAX_NUMBER_OF_TRACKED_SENSORS 9
#define | MINIMAL_DISTANCE_BETWEEN_CONTROL_POINTS 0.05
#define | DYNAMICART_PATH (string) "data/DynamicArt/"
#define | AUTOSAVE_PATH (string) "data/DynamicArt/Autosave/"
#define | USER_PATH (string) "data/DynamicArt/UserData/"
#define | CURSORS_PATH (string) "data/DynamicArt/Models/Cursors/"
#define | TEMPLATES_PATH (string) "data/DynamicArt/Templates/"
#define | SYMMETRIES_PATH (string) "data/DynamicArt/Symmetries/"
#define | MENU_SELECTED_ITEM_COLOR osg::Vec3(0.75, 1.0, 0.75)
#define | MENU_NOTAVAILABLE_ITEM_COLOR osg::Vec4(0.35, 0.35, 0.35, 1.0)

Enumerations

enum BrushStrokeInterpolationType {
BrushStroke_Interpolation_NONE = 0, BrushStroke_Interpolation_LINEAR = 1, BrushStroke_Interpolation_CUBIC, BrushStroke_Interpolation_CATMULLROM,
BrushStroke_Interpolation_CIRCLE, BrushStroke_Interpolation_USER_PREDEFINED
}

Functions

string printColor (osg::Vec4 col)
Used in createMenuStructure functions. More...

Macro Definition Documentation

#define absf ( x ) (x<0.0?-x:x)
#define AUTOSAVE_PATH (string) "data/DynamicArt/Autosave/"
#define CURSORS_PATH (string) "data/DynamicArt/Models/Cursors/"
#define DYNAMICART_PATH (string) "data/DynamicArt/"
#define MAX_NUMBER_OF_TRACKED_SENSORS 9
#define MENU_NOTAVAILABLE_ITEM_COLOR osg::Vec4(0.35, 0.35, 0.35, 1.0)
#define MENU_SELECTED_ITEM_COLOR osg::Vec3(0.75, 1.0, 0.75)
#define MINIMAL_DISTANCE_BETWEEN_CONTROL_POINTS 0.05
#define NOMINMAX
#define SYMMETRIES_PATH (string) "data/DynamicArt/Symmetries/"
#define TEMPLATES_PATH (string) "data/DynamicArt/Templates/"
#define USER_PATH (string) "data/DynamicArt/UserData/"

Enumeration Type Documentation

enum BrushStrokeInterpolationType
Enumerator
BrushStroke_Interpolation_NONE
BrushStroke_Interpolation_LINEAR
BrushStroke_Interpolation_CUBIC
BrushStroke_Interpolation_CATMULLROM
BrushStroke_Interpolation_CIRCLE
BrushStroke_Interpolation_USER_PREDEFINED

Function Documentation

string printColor ( osg::Vec4 col )
inline

Used in createMenuStructure functions.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Component.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_Component.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\Utils.h>
#include <vreckoAP\DynamicArt\PS_Component.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Face.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_Face.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_Face.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_FacePlane.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_FacePlane.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_FacePlane.h>
#include <vreckoAP\DynamicArt\Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_FlatShape.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_FlatShape.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_FlatShape.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Layer.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_Layer.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_Layer.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Polyhedron.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_Polyhedron.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_Polyhedron.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PS_Symmetry.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
PS_Symmetry.cpp File Reference
#include "precompiled.h"
#include <vreckoAP\DynamicArt\PS_Symmetry.h>
#include <vreckoAP\DynamicArt\Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RegularPolygonSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
RegularPolygonSpline.cpp File Reference
#include "precompiled.h"
#include "RegularPolygonSpline.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RegularPolygonSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
RegularPolygonSpline.h File Reference
#include "Spline.h"
#include "Utils.h"
#include <osg\BoundsChecking>

Go to the source code of this file.

Classes

class RegularPolygonSpline

Typedefs

typedef osg::ref_ptr
< RegularPolygonSpline > 		RegularPolygonSplinePtr

Typedef Documentation

typedef osg::ref_ptr<RegularPolygonSpline> RegularPolygonSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RotationFrameGenAdapter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
RotationFrameGenAdapter.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/RotationFrameGenAdapter.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SampledSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SampledSpline.cpp File Reference
#include "precompiled.h"
#include "SampledSpline.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SampledSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
SampledSpline.h File Reference
#include "spline.h"

Go to the source code of this file.

Classes

class SampledSpline

Typedefs

typedef osg::ref_ptr
< SampledSpline > 		SampledSplinePtr

Typedef Documentation

typedef osg::ref_ptr<SampledSpline> SampledSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SectorColorGen.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SectorColorGen.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/SectorColorGen.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SectorManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SectorManager.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/SectorManager.h>
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeFactory.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ShapeFactory.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeFactory.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ShapeFactory.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
ShapeGenerator.cpp File Reference
#include "precompiled.h"
#include "ShapeGenerator.h"
#include "Utils.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
ShapeGenerator.h File Reference
#include <osg\Referenced>
#include <osg\Array>
#include "Utils.h"

Go to the source code of this file.

Classes

class | APDYNAMICART::IShapeGenerator
class | APDYNAMICART::ShapeFactory
class | APDYNAMICART::NullShapeGenerator
class | APDYNAMICART::LinearShapeGenerator

Namespaces

namespace APDYNAMICART

Typedefs

typedef osg::ref_ptr
< IShapeGenerator > 		APDYNAMICART::IShapeGeneratorPtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SimpleBox.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
SimpleBox.cpp File Reference
#include "precompiled.h"
#include <osg/Node>
#include <vreckoAP/DynamicArt/SimpleBox.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SliceTool.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SliceTool.cpp File Reference
#include "precompiled.h"
#include "SliceTool.h"
#include "DAEnvironment.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SliceTool.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes
SliceTool.h File Reference
#include "DATool.h"
#include "PoA.h"

Go to the source code of this file.

Classes

class SliceTool
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SmoothedSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Macros
SmoothedSpline.cpp File Reference
#include "precompiled.h"
#include "SmoothedSpline.h"

Macros

#define dbgSmS(msg)

Macro Definition Documentation

#define dbgSmS ( msg )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SmoothedSpline.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
SmoothedSpline.h File Reference
#include "Spline.h"

Go to the source code of this file.

Classes

class SmoothedSpline

Typedefs

typedef osg::ref_ptr
< SmoothedSpline > 		SmoothedSplinePtr

Typedef Documentation

typedef osg::ref_ptr<SmoothedSpline> SmoothedSplinePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SnapPoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
SnapPoint.cpp File Reference
#include "precompiled.h"
#include "SnapPoint.h"

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SnapPoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Namespaces | Typedefs
SnapPoint.h File Reference

Go to the source code of this file.

Classes

struct APDYNAMICART::SnapPoint

Namespaces

namespace APDYNAMICART

Typedefs

typedef std::vector< SnapPoint > APDYNAMICART::SnapPointArray
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SplineAdapter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SplineAdapter.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/SplineAdapter.h>
#include "SampledSpline.h"
#include "FilletSpline.h"
#include "InterpolatedSpline.h"
#include "CatmullRomInterpolator.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SweepSurfaceGeode.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SweepSurfaceGeode.cpp File Reference
#include "precompiled.h"
#include "SweepSurfaceGeode.h"
#include "ConstantColorGen.h"
#include "ConstantDiameterGen.h"
#include "utils.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SweepSurfaceGeode.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Classes | Typedefs
SweepSurfaceGeode.h File Reference
#include <osg\Geode>
#include "Spline.h"
#include "types.h"
#include "RotationFrameGenerator.h"
#include "ColorGen.h"
#include "DiameterGen.h"

Go to the source code of this file.

Classes

class SweepSurfaceGeode

Typedefs

typedef osg::ref_ptr
< SweepSurfaceGeode > 		SweepSurfaceGeodePtr

Typedef Documentation

typedef osg::ref_ptr<SweepSurfaceGeode> SweepSurfaceGeodePtr
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/TimeLineSpline.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Macros
TimeLineSpline.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/TimeLineSpline.h>
#include <vreckoAP/DynamicArt/Utils.h>

Macros

#define dbgSmS(msg)

Macro Definition Documentation

#define dbgSmS ( msg )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Timing.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Macros | Functions
Timing.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <windows.h>
#include "Nx.h"
#include <vreckoAP/DynamicArt/Timing.h>

Macros

#define NOMINMAX

Functions

float | getCurrentTime ()
float | getElapsedTime ()

Macro Definition Documentation

#define NOMINMAX

Function Documentation

float getCurrentTime ( )
float getElapsedTime ( )
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolBrush.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ToolBrush.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/BrushStroke.h>
#include <vreckoAP/DynamicArt/ToolBrush.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, ToolBrush)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, ToolBrush)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, ToolBrush)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolEraser.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
ToolEraser.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolEraser.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolHook.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ToolHook.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <vreckoAP/DynamicArt/ToolHook.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include <vreckoAP/DynamicArt/Hook.h>
#include <ConstantDiameterGen.h>
#include <vreckoAP/DynamicArt/HookManager.h>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, ToolHook)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, ToolHook)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, ToolHook)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolMagicWand.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ToolMagicWand.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolMagicWand.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <vreckoAP/DynamicArt/Attractor.h>
#include "types.h"

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, ToolMagicWand)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, ToolMagicWand)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, ToolMagicWand)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolRotation.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ToolRotation.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolRotation.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, ToolRotation)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, ToolRotation)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, ToolRotation)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolSelector.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces | Functions
ToolSelector.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolSelector.h>
#include <vreckoAP/DynamicArt/Utils.h>
#include <vecmath\Math.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART

Functions

APDYNAMICART::METHOD_INPUT (GUIItemClicked, MessageString, ToolSelector)
APDYNAMICART::METHOD_INPUT (CreateMenuStructure, MessageInt, ToolSelector)
APDYNAMICART::METHOD_INPUT (HidingMenu, MessageBool, ToolSelector)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolSlice.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
ToolSlice.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolSlice.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ToolTongs.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
ToolTongs.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/ToolTongs.h>
#include <vreckoAP/DynamicArt/DAEnvironment.h>
#include <vreckoAP/DynamicArt/Utils.h>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Utils.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Namespaces
Utils.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/DynamicArt/Utils.h>
#include <random>

Namespaces

namespace APDYNAMICART
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController Directory Reference

  • src
  • vreckoAP
  • EditorController
EditorController Directory Reference

Files

file | AbilityMapper.cpp
file | AP_EditorController.cpp
file | ControllableAbility.cpp
file | EditorController.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/AbilityMapper.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorController
Namespaces
AbilityMapper.cpp File Reference
#include <vreckoAP/EditorController/AbilityMapper.h>
#include <sstream>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APEditorController
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/AP_EditorController.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorController
Functions | Variables
AP_EditorController.cpp File Reference
#include <vreckoAP/EditorController/AP_EditorController.h>
#include <vreckoAP/EditorController/EditorController.h>
#include <vreckoAP/EditorController/AbilityMapper.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"EditorController"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Internal plugin for Scene Editor",
"EDITING ability to map other editing abilities onto finger presses.",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"EditorController",
"AbilityMapper",
NULL
}
const char* g_pPluginName = {"EditorController"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/ControllableAbility.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorController
Namespaces | Macros | Functions
ControllableAbility.cpp File Reference
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/PluginManager.h>

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.

Macros

#define CA_MENU_CLICKED "Menu_Clicked"

Functions

vrecko::METHOD_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt, ControllableAbility)
vrecko::METHOD_REQUEST_INPUT (GetInfo, MessageVoid, ControllableAbility::MessageCAINFO, ControllableAbility)

Macro Definition Documentation

#define CA_MENU_CLICKED "Menu_Clicked"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorController/EditorController.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorController
Namespaces | Macros | Functions
EditorController.cpp File Reference
#include <vreckoAP/EditorController/EditorController.h>
#include <iostream>
#include <sstream>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vrecko/PluginManager.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APEditorController

Macros

#define | BUTTON_MAPABILIES_ID 4
#define | ABILITYMAPPER_ID "AbilityMapper"
#define | FOR_ALL_POINTERS(pIndex) for (int pIndex = 1; pIndex <= maxPointers; pIndex++)
#define | FOR_ALL_BUTTONS(pIndex) for (int pIndex = 1; pIndex <= maxButtonsPerPointer; pIndex++)
#define | DECLARE_AND_CLIP_PID

Functions

APEditorController::METHOD_INPUT (AbilityMapping, AbilityMapper::MessageMapping, EditorController)
APEditorController::METHOD_REQUEST_INPUT (AbilityMapping, MessageVoid, AbilityMapper::MessageMapping, EditorController)
APEditorController::METHOD_REQUEST_INPUT (SelectionID, MessageInt, MessageObjectID, EditorController)
APEditorController::METHOD_REQUEST_INPUT (SelectionPath, MessageInt, MessageNodeList, EditorController)
APEditorController::METHOD_REQUEST_INPUT (PointerPos, MessageInt, MessageVec3, EditorController)
APEditorController::METHOD_REQUEST_INPUT (PointerPosRaw, MessageInt, MessageVec3, EditorController)
APEditorController::METHOD_REQUEST_INPUT (PointerRot, MessageInt, MessageQuat, EditorController)
APEditorController::METHOD_REQUEST_INPUT (PointerRotRaw, MessageInt, MessageQuat, EditorController)

Macro Definition Documentation

#define ABILITYMAPPER_ID "AbilityMapper"
#define BUTTON_MAPABILIES_ID 4
#define DECLARE_AND_CLIP_PID
Value:
int pID = (long int)message->data; \
if (pID <= 0) \
pID = 1; \
else if (pID > maxPointers) \
pID = maxPointers;
#define FOR_ALL_BUTTONS ( pIndex ) for (int pIndex = 1; pIndex <= maxButtonsPerPointer; pIndex++)
#define FOR_ALL_POINTERS ( pIndex ) for (int pIndex = 1; pIndex <= maxPointers; pIndex++)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities Directory Reference

  • src
  • vreckoAP
  • EditorQAbilities
EditorQAbilities Directory Reference

Files

file | AbilityEditor.cpp
file | AnimatorEditor.cpp
file | AP_EditorQAbilities.cpp
file | AvatarMovement.cpp
file | ObjectAdd.cpp
file | ObjectDelete.cpp
file | ObjectMovement.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | SceneSave.cpp
file | SimpleObjectMovement.cpp
file | UseTrigger.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AbilityEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Classes | Namespaces
AbilityEditor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/AbilityEditor.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/PluginManager.h>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <helpers/XercesXMLUtils.h>
#include <sstream>
#include <helpers/StringHelpers.h>

Classes

class APEditorQAbilities::PresentAbility

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AnimatorEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
AnimatorEditor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/AnimatorEditor.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <sstream>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/PluginManager.h>
#include <xercesc/dom/DOMNamedNodeMap.hpp>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AP_EditorQAbilities.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Functions | Variables
AP_EditorQAbilities.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/AP_EditorQAbilities.h>
#include <vreckoAP/EditorQAbilities/AvatarMovement.h>
#include <vreckoAP/EditorQAbilities/ObjectMovement.h>
#include <vreckoAP/EditorQAbilities/SimpleObjectMovement.h>
#include <vreckoAP/EditorQAbilities/AnimatorEditor.h>
#include <vreckoAP/EditorQAbilities/AbilityEditor.h>
#include <vreckoAP/EditorQAbilities/UseTrigger.h>
#include <vreckoAP/EditorQAbilities/ObjectAdd.h>
#include <vreckoAP/EditorQAbilities/ObjectDelete.h>
#include <vreckoAP/EditorQAbilities/SceneSave.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

char * | g_pPluginName = {"EditorQAbilities"}
char * | g_pAbilityName []
char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

char* g_pAbilityDesc[]
Initial value:
= {
"Internal plugin for Scene Editor",
"EDITOR ABILITY to move the avatar",
"EDITOR ABILITY to move an object around the scene according to the pointer's motion.",
"EDITOR ABILITY - Simple movement example. Moves an object around the scene according to the pointer's motion.",
"EDITOR ABILITY to editor the Animator abilities.",
"EDITOR ABILITY to add, remove or connect the abilities.",
"EDITOR ABILITY to activate the \"Use\" signal.",
"EDITOR ABILITY to add an object.",
"EDITOR ABILITY to delete an object.",
"EDITOR ABILITY to save the scene into a XML file.",
""
}
char* g_pAbilityName[]
Initial value:
= {
"EditorQAbilities",
"AvatarMovement",
"ObjectMovement",
"SimpleObjectMovement",
"AnimatorEditor",
"AbilityEditor",
"UseTrigger",
"ObjectAdd",
"ObjectDelete",
"SceneSave",
NULL
}
char* g_pPluginName = {"EditorQAbilities"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/AvatarMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
AvatarMovement.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/AvatarMovement.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <iostream>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectAdd.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces | Macros
ObjectAdd.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/ObjectAdd.h>
#include <sstream>
#include <helpers/HelperMacros.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include "dirent.h"

Namespaces

namespace APEditorQAbilities

Macros

#define | DECLARE_SEARCH_STRUCTS
#define | SEARCH_INIT(dirStr) { findDir = opendir(dirStr); if (findDir) findDirEnt = readdir(findDir); }
#define | SEARCH_START_OK (findDir && findDirEnt)
#define | SEARCH_FILENAME findDirEnt->d_name
#define | SEARCH_NEXT_FILE_OK (findDirEnt = readdir(findDir))
#define | SEARCH_DONE { closedir(findDir); }

Macro Definition Documentation

#define DECLARE_SEARCH_STRUCTS
Value:
DIR *findDir; \
struct dirent *findDirEnt;
#define SEARCH_DONE { closedir(findDir); }
#define SEARCH_FILENAME findDirEnt->d_name
#define SEARCH_INIT ( dirStr ) { findDir = opendir(dirStr); if (findDir) findDirEnt = readdir(findDir); }
#define SEARCH_NEXT_FILE_OK (findDirEnt = readdir(findDir))
#define SEARCH_START_OK (findDir && findDirEnt)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectDelete.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
ObjectDelete.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/ObjectDelete.h>
#include <vrecko/EnvironmentObject.h>
#include <sstream>
#include <vrecko/World.h>
#include <vrecko/Scene.h>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/ObjectMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces | Macros | Functions
ObjectMovement.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/ObjectMovement.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <osg/io_utils>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <helpers/DynamicArray.h>
#include <helpers/HelperMacros.h>
#include <helpers/XercesXMLUtils.h>
#include <osg/BlendEquation>
#include <osg/CullFace>
#include <osg/Depth>
#include <osg/PolygonOffset>
#include <vrecko/PluginManager.h>

Namespaces

namespace APEditorQAbilities

Macros

#define | HORIZONTAL_MAX_ANGLE (PI/180*10)
#define | COPLANAR_MAX_ANGLE HORIZONTAL_MAX_ANGLE
#define | SNAP_PLANE_REACH_RATIO 1.5
#define | SMALL_NUM 0.00000001
#define | CALC_MAXMIN2(elem, min_1, min_2, maxmin)
#define | ELEM_COMP_LIMIT 1.05f
#define | VALID_CORNER_VAL_CLOSENESS 0.97f
#define | MAX_SNAPPING_PLANES 3

Functions

int APEditorQAbilities::planesCompare (const ObjectMovement::CANDIDATEPLANE *elem1, const ObjectMovement::CANDIDATEPLANE *elem2)

Macro Definition Documentation

#define CALC_MAXMIN2 | ( | elem,
 |  | min_1,
 |  | min_2,
 |  | maxmin
 | ) |
Value:
{ \
if (elem->fMinU * elem->fMaxU <= 0.0f) { \
min_1 = 0.0f; \
} else { \
min_1 = (abs(elem->fMinU) < abs(elem->fMaxU)) ? abs(elem->fMinU) : abs(elem->fMaxU); \
} \
if (elem1->fMinV * elem1->fMaxV <= 0.0f) { \
min_2 = 0.0f; \
} else { \
min_2 = (abs(elem->fMinV) < abs(elem->fMaxV)) ? abs(elem->fMinV) : abs(elem->fMaxV); \
} \
maxmin = (min_1 > min_2) ? min_1 : min_2; \
}
#define COPLANAR_MAX_ANGLE HORIZONTAL_MAX_ANGLE
#define ELEM_COMP_LIMIT 1.05f
#define HORIZONTAL_MAX_ANGLE (PI/180*10)
#define MAX_SNAPPING_PLANES 3
#define SMALL_NUM 0.00000001
#define SNAP_PLANE_REACH_RATIO 1.5
#define VALID_CORNER_VAL_CLOSENESS 0.97f
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
precompiled.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/Message.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include <vreckoAP/EditorController/ControllableAbility.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <helpers/DynamicArray.h>
#include <helpers/HelperMacros.h>
#include <helpers/StringHelpers.h>
#include <helpers/XercesXMLUtils.h>
#include <iostream>
#include <sstream>
#include <vector>
#include <math.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/io_utils>
#include <osg/Geometry>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/CullFace>
#include <osg/LightModel>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/SceneSave.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
SceneSave.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/SceneSave.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <sstream>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/SimpleObjectMovement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
SimpleObjectMovement.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/SimpleObjectMovement.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <osg/io_utils>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <iostream>
#include <vrecko/EnvironmentObject.h>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/UseTrigger.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
Namespaces
UseTrigger.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/EditorQAbilities/UseTrigger.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APEditorQAbilities
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor Directory Reference

  • src
  • vreckoAP
  • FFDEditor
FFDEditor Directory Reference

Files

file | AP_FFDEditor.cpp
file | EditorLogic.cpp
file | GeometryLoader.cpp
file | GeometryLoaderBase.cpp
file | Grid.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/AP_FFDEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
Functions | Variables
AP_FFDEditor.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/FFDEditor/AP_FFDEditor.h>
#include <vreckoAP/FFDEditor/EditorLogic.h>

Functions

AP_EXPORT const char * | FFDEditor_getPluginDescription ()
AP_EXPORT const char ** | FFDEditor_getAbilityList ()
AP_EXPORT const char * | FFDEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | FFDEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | FFDEditor_setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"FFDEditor"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* FFDEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* FFDEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** FFDEditor_getAbilityList ( )
AP_EXPORT const char* FFDEditor_getPluginDescription ( )
AP_EXPORT void FFDEditor_setAbilitiesParameters ( )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability for creation free form deformation editor.",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"EditorLogic",
NULL
}
const char* g_pPluginName = {"FFDEditor"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/EditorLogic.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
Namespaces | Macros | Functions
EditorLogic.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/FFDEditor/EditorLogic.h>
#include <vreckoAP/FFDEditor/Grid.h>
#include <vreckoAP/FFDEditor/GeometryLoaderBase.h>
#include <osg/Group>
#include <iostream>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/PrimitiveSet>
#include <osg/LineWidth>
#include <osg/Geometry>
#include <osg/CopyOp>
#include <osg/PolygonMode>
#include <osg/ShadeModel>
#include <osg/CullFace>
#include <osg/StateSet>
#include <osg/State>
#include <vrecko/World.h>
#include <vrecko/EnvironmentObject.h>
#include <math.h>
#include <vrecko/ReaderWriter.h>
#include <sstream>
#include <vrecko/Scene.h>

Namespaces

namespace APFFDEditor

Macros

#define | CONTROLPOINT(x, y, z) (pGrid->controlPoints[x][y][z])
#define | EDGE(x) (pGrid->edges[x])

Functions

int | APFFDEditor::factorial (int num)
float | APFFDEditor::combNum (int x, int y)
bool | APFFDEditor::getParentsTransformMat (osg::Matrix &parentsTransform, vrecko::EnvironmentObject *object)

Macro Definition Documentation

#define CONTROLPOINT | ( | x,
 |  | y,
 |  | z
 | ) | (pGrid->controlPoints[x][y][z])
#define EDGE ( x ) (pGrid->edges[x])
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/GeometryLoader.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
Namespaces
GeometryLoader.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/FFDEditor/GeometryLoader.h>
#include <vrecko/Logger.h>
#include <osg/Group>
#include <osg/MatrixTransform>

Namespaces

namespace APFFDEditor
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/GeometryLoaderBase.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
Namespaces | Macros
GeometryLoaderBase.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/FFDEditor/GeometryLoaderBase.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Group>
#include <osg/PrimitiveSet>
#include <osg/MatrixTransform>
#include <vrecko/Logger.h>
#include <float.h>

Namespaces

namespace APFFDEditor

Macros

#define | FACE(x) ((FaceBase*)getFace(x))
#define | VERTEX(x) ((VertexBase*)getVertex(x))

Macro Definition Documentation

#define FACE ( x ) ((FaceBase*)getFace(x))
#define VERTEX ( x ) ((VertexBase*)getVertex(x))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/Grid.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
Namespaces | Macros | Functions
Grid.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/FFDEditor/Grid.h>
#include <iostream>
#include <stack>
#include <osg/BoundingSphere>
#include <osg/Matrix>
#include <osg/Group>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/LineWidth>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>

Namespaces

namespace APFFDEditor

Macros

#define | CONTROLPOINT(x, y, z) (controlPoints[x][y][z])
#define | EDGE(x) (edges[x])

Functions

bool APFFDEditor::getParentsTransform (osg::Matrix &parentsTransform, vrecko::EnvironmentObject *object)

Macro Definition Documentation

#define CONTROLPOINT | ( | x,
 |  | y,
 |  | z
 | ) | (controlPoints[x][y][z])
#define EDGE ( x ) (edges[x])
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
precompiled.h File Reference
#include <float.h>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Group>
#include <osg/Node>
#include <osg/PrimitiveSet>
#include <osg/Vec3>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/ReaderWriter.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden Directory Reference

  • src
  • vreckoAP
  • Garden
Garden Directory Reference

Files

file | abstract0lsystem.cpp
file | abstractgenerator.cpp
file | abstractklsystem.cpp
file | AP_Garden.cpp
file | configuration.cpp
file | d0lsystem.cpp
file | hermitpipe.cpp
file | jointedpipe.cpp
file | loftturtle.cpp
file | log.cpp
file | longstring.cpp
file | lsfile.cpp
file | lsgeode.cpp
file | lsobject.cpp
file | lsystem.cpp
file | lsystemgenerator.cpp
file | movingturtle.cpp
file | par2lsystem.cpp
file | pard0lsystem.cpp
file | parseablestring.cpp
file | parstoch0lsystem.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | queryinterpret.cpp
file | rectangle.cpp
file | rule.cpp
file | straightpipe.cpp
file | turtleinterpret.cpp
file | turtlestack.cpp
file | utils.cpp
file | xmlfile.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstract0lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
abstract0lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/abstract0lsystem.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstractgenerator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
abstractgenerator.cpp File Reference
#include "precompiled.h"
#include <fstream>
#include <sys/stat.h>
#include <errno.h>
#include <vreckoAP/Garden/abstractgenerator.h>
#include <vreckoAP/Garden/d0lsystem.h>
#include <vreckoAP/Garden/parstoch0lsystem.h>
#include <vreckoAP/Garden/par2lsystem.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/abstractklsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
abstractklsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/abstractklsystem.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/AP_Garden.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
Functions | Variables
AP_Garden.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/AP_Garden.h>
#include <vreckoAP/Garden/lsobject.h>

Functions

AP_EXPORT const char * | Garden_getPluginDescription ()
AP_EXPORT char ** | Garden_getAbilityList ()
AP_EXPORT const char * | Garden_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | Garden_getAbilityInstance (const char *pchName)
AP_EXPORT void | Garden_setAbilitiesParameters ()

Variables

char * | g_pAPGardenPluginName = {"Garden"}
char * | g_pAPGardenAbilityName []
char * | g_pAPGardenAbilityDesc []

Function Documentation

AP_EXPORT const char* Garden_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* Garden_getAbilityInstance ( const char * pchName )
AP_EXPORT char** Garden_getAbilityList ( )
AP_EXPORT const char* Garden_getPluginDescription ( )
AP_EXPORT void Garden_setAbilitiesParameters ( )

Variable Documentation

char* g_pAPGardenAbilityDesc[]
Initial value:
= {
"LSObject description",
""
}
char* g_pAPGardenAbilityName[]
Initial value:
= {
"LSObject",
NULL
}
char* g_pAPGardenPluginName = {"Garden"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/configuration.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
configuration.cpp File Reference
#include "precompiled.h"
#include <iostream>
#include <fstream>
#include <vreckoAP/Garden/configuration.h>
#include <vreckoAP/Garden/lsystemexception.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/d0lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
d0lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/d0lsystem.h>
#include <vreckoAP/Garden/log.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/hermitpipe.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
hermitpipe.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/hermitpipe.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/jointedpipe.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
jointedpipe.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/jointedpipe.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/loftturtle.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
loftturtle.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/loftturtle.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/log.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
log.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/log.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/longstring.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
longstring.cpp File Reference
#include "precompiled.h"
#include <cstdio>
#include <vreckoAP/Garden/longstring.h>
#include <vreckoAP/Garden/lsystemexception.h>
#include <vreckoAP/Garden/log.h>
#include "boost/lexical_cast.hpp"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsfile.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
lsfile.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/lsfile.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsgeode.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
lsgeode.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/lsgeode.h>
#include <vreckoAP/Garden/lsystemexception.h>
#include <vreckoAP/Garden/configuration.h>
#include <vreckoAP/Garden/abstractturtle.h>
#include <osg/Depth>
#include <osg/Multisample>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsobject.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
Namespaces
lsobject.cpp File Reference
#include "precompiled.h"
#include <exception>
#include <vreckoAP/Garden/lsobject.h>
#include <vreckoAP/Garden/configuration.h>
#include <vreckoAP/Garden/turtleinterpret.h>
#include <vreckoAP/Garden/lsystemgenerator.h>
#include <vreckoAP/Garden/log.h>
#include <vreckoAP/Garden/lsystemexception.h>

Namespaces

namespace AP_LSystem
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/lsystem.h>
#include <vreckoAP/Garden/configuration.h>
#include <vreckoAP/Garden/lsfile.h>
#include <vreckoAP/Garden/parstoch0lsystem.h>
#include <vreckoAP/Garden/par2lsystem.h>
#include <vreckoAP/Garden/abstractgenerator.h>
#include <vreckoAP/Garden/log.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/lsystemgenerator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
lsystemgenerator.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/lsystemgenerator.h>
#include <vreckoAP/Garden/parstoch0lsystem.h>
#include <vreckoAP/Garden/par2lsystem.h>
#include <vreckoAP/Garden/d0lsystem.h>
#include <vreckoAP/Garden/lsfile.h>
#include <vreckoAP/Garden/log.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/movingturtle.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
movingturtle.cpp File Reference
#include "precompiled.h"
#include <cmath>
#include <vreckoAP/Garden/movingturtle.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/par2lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
par2lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/par2lsystem.h>
#include <vreckoAP/Garden/randomindex.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/pard0lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
pard0lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/pard0lsystem.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/parseablestring.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
Namespaces | Functions
parseablestring.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/parseablestring.h>
#include <cstring>

Namespaces

namespace AP_LSystem

Functions

std::basic_ostream< char > & AP_LSystem::operator<< (std::basic_ostream< char > &os, const ParseableString ps)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/parstoch0lsystem.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
parstoch0lsystem.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/parstoch0lsystem.h>
#include <vreckoAP/Garden/randomindex.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
precompiled.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/queryinterpret.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
queryinterpret.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/queryinterpret.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/rectangle.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
rectangle.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/rectangle.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/rule.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
rule.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/rule.h>
#include "boost/lexical_cast.hpp"
#include <vreckoAP/Garden/lsystemexception.h>
#include <vreckoAP/Garden/longstring.h>
#include <vreckoAP/Garden/log.h>
#include <vreckoAP/Garden/randomizer.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/straightpipe.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
straightpipe.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/straightpipe.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/turtleinterpret.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
turtleinterpret.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/turtleinterpret.h>
#include <vreckoAP/Garden/configuration.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/turtlestack.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
turtlestack.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/turtlestack.h>
#include <vreckoAP/Garden/jointedpipe.h>
#include <vreckoAP/Garden/straightpipe.h>
#include <vreckoAP/Garden/rectangle.h>
#include <vreckoAP/Garden/queryturtle.h>
#include <vreckoAP/Garden/hermitpipe.h>
#include <vreckoAP/Garden/log.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/utils.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
utils.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/utils.h>
#include <fstream>
#include <sstream>
#include <algorithm>
#include <vreckoAP/Garden/lsystemexception.h>
#include "boost/lexical_cast.hpp"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/xmlfile.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
xmlfile.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/Garden/xmlfile.h>
#include <vreckoAP/Garden/configuration.h>
#include <vreckoAP/Garden/lsystemexception.h>
#include "boost/lexical_cast.hpp"
#include <vreckoAP/Garden/utils.h>
#include <sys/stat.h>
#include <errno.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI Directory Reference

  • src
  • vreckoAP
  • GUI
GUI Directory Reference

Files

file | AP_GUI.cpp
file | ColorPicker.cpp
file | GUI_Controller.cpp
file | GUI_item.cpp
file | GUI_Text.cpp
file | Icon.cpp
file | IconColour.cpp
file | ItemsGroup.cpp
file | Layout.cpp
file | Menu.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Slider.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/AP_GUI.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Functions | Variables
AP_GUI.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/AP_GUI.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pGUIPluginName = {"GUI"}
const char * | g_pGUIAbilityName []
const char * | g_pGUIAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pGUIAbilityDesc[]
Initial value:
= {
"Controls VRECKO GUI",
"Buttons, check-boxes and such items",
"Icon for color selection",
"Movable ball on a stick",
"Menu - with clickable items",
""
}
const char* g_pGUIAbilityName[]
Initial value:
= {
"Controller",
"Icon",
"IconColour",
"Slider",
"Menu",
"ColorPicker",
NULL
}
const char* g_pGUIPluginName = {"GUI"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/ColorPicker.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Macros | Functions
ColorPicker.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/ColorPicker.h>
#include <vreckoAP/GUI/GUI_Controller.h>
#include <vreckoAP/GUI/Icon.h>
#include <osg/CullFace>

Namespaces

namespace APGUI

Macros

#define | absf(x) (x<0.0?-x:x)
#define | ENOUGHT_SMALL_NUMBER 0.00001

Functions

APGUI::METHOD_INPUT (GUIItemClicked, MessageString, ColorPicker)
APGUI::METHOD_INPUT (ExternalDeactivation, MessageObjectID, ColorPicker)
APGUI::METHOD_REQUEST_INPUT (EvokeHSLColorPicker, MessageString, MessageBool, ColorPicker)

Macro Definition Documentation

#define absf ( x ) (x<0.0?-x:x)
#define ENOUGHT_SMALL_NUMBER 0.00001
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_Controller.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Macros | Functions
GUI_Controller.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/GUI_Controller.h>

Namespaces

namespace APGUI

Macros

#define | err(msg) std::cerr << __FUNCTION__<< " - " << msg << std::endl;
#define | dbgGUIC(msg)

Functions

APGUI::METHOD_REQUEST_INPUT (Sensor_0_mainClick, MessageBool, MessageBool, GUI_Controller)
APGUI::METHOD_REQUEST_INPUT (Sensor_1_mainClick, MessageBool, MessageBool, GUI_Controller)
APGUI::METHOD_REQUEST_INPUT (Sensor_0_contextClick, MessageBool, MessageBool, GUI_Controller)
APGUI::METHOD_REQUEST_INPUT (Sensor_1_contextClick, MessageBool, MessageBool, GUI_Controller)
APGUI::METHOD_INPUT (SwitchLayout, MessageString, GUI_Controller)

Macro Definition Documentation

#define dbgGUIC ( msg )
#define err ( msg ) std::cerr << __FUNCTION__<< " - " << msg << std::endl;

Macros for errors and debugging

Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_item.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Variables
GUI_item.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/GUI_item.h>
#include <vreckoAP/GUI/GUI_Controller.h>

Namespaces

namespace APGUI

Variables

osg::ref_ptr< osgText::Font3D > g_font3D = osgText::readFont3DFile("data/fonts/arial.ttf")

Variable Documentation

osg::ref_ptr<osgText::Font3D> g_font3D = osgText::readFont3DFile("data/fonts/arial.ttf")
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/GUI_Text.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces
GUI_Text.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/GUI_Text.h>

Namespaces

namespace APGUI
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Icon.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces
Icon.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/Icon.h>
#include <vreckoAP/GUI/GUI_Controller.h>
#include <osg/ShadeModel>
#include <osg/CullFace>
#include <osgUtil/Optimizer>

Namespaces

namespace APGUI
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/IconColour.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces
IconColour.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/IconColour.h>

Namespaces

namespace APGUI
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/ItemsGroup.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces
ItemsGroup.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/ItemsGroup.h>
#include <vreckoAP/GUI/Icon.h>

Namespaces

namespace APGUI
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Layout.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Macros
Layout.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/Layout.h>

Namespaces

namespace APGUI

Macros

#define SMALL_NUM 0.00000001

Macro Definition Documentation

#define SMALL_NUM 0.00000001
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Menu.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Functions
Menu.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/Menu.h>
#include <vreckoAP/GUI/GUI_Controller.h>

Namespaces

namespace APGUI

Functions

APGUI::METHOD_INPUT (HidingMenu, MessageBool, Menu)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
precompiled.h File Reference
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/PolygonMode>
#include <osg/Depth>
#include <osg/ClipNode>
#include <osgUtil/SmoothingVisitor>
#include <osg/Switch>
#include <osg/BlendFunc>
#include <vrecko/Ability.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include <fstream>
#include <iostream>
#include <sstream>
#include <vector>
#include <math.h>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/util/XMLString.hpp>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/Slider.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
Namespaces | Macros | Functions
Slider.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/GUI/Slider.h>

Namespaces

namespace APGUI

Macros

#define SMALL_NUM 0.00000001

Functions

APGUI::METHOD_INPUT (SliderValue, MessageFloat, Slider)

Macro Definition Documentation

#define SMALL_NUM 0.00000001
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp Directory Reference

  • src
  • vreckoAP
  • HapticCollisionApp
HapticCollisionApp Directory Reference

Files

file | AP_HapticCollisionApp.cpp
file | AP_HapticCollisionApp.h [code]
file | CollisionAppController.cpp
file | CollisionAppController.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/AP_HapticCollisionApp.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
Functions | Variables
AP_HapticCollisionApp.cpp File Reference
#include "AP_HapticCollisionApp.h"
#include "CollisionAppController.h"
#include <vreckoDP/PHANToM/PHANToM_Device.h>
#include <vrecko/Logger.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"HapticCollisionApp"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability helping to control the whole application",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"CollisionAppController",
NULL
}
const char* g_pPluginName = {"HapticCollisionApp"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/AP_HapticCollisionApp.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
Functions
AP_HapticCollisionApp.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <iostream>

Go to the source code of this file.

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()
void AP_EXPORT | initializeAttributesDescription ()

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( )
AP_EXPORT const char* getPluginDescription ( )
void AP_EXPORT initializeAttributesDescription ( )
AP_EXPORT void setAbilitiesParameters ( )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/CollisionAppController.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
CollisionAppController.cpp File Reference
#include "CollisionAppController.h"
#include <base/MTMatrixTransform.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/CollisionAppController.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
CollisionAppController.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking Directory Reference

  • src
  • vreckoAP
  • HeadTracking
HeadTracking Directory Reference

Files

file | AP_HeadTracking.cpp
file | HeadTracking.cpp
file | htUtils.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | ScreenSetup.cpp
file | ScreenSetupSimple.cpp
file | Solver.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/AP_HeadTracking.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Functions | Variables
AP_HeadTracking.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/HeadTracking/AP_HeadTracking.h>
#include <vreckoAP/HeadTracking/HeadTracking.h>
#include <vreckoAP/HeadTracking/ScreenSetup.h>
#include <vreckoAP/HeadTracking/ScreenSetupSimple.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT vrecko::Ability * | getAbilityInstance (const char *pchName)

Variables

const char * | g_pPluginName
const char * | g_pPluginDesc
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT vrecko::Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability to adjust camera according to user's position",
"Setups main monitor position",
"Setups main monitor position using simple setup",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"HeadTracking",
"ScreenSetup",
"ScreenSetupSimple",
NULL
}
const char* g_pPluginDesc
Initial value:
= {
"HeadTracking - updates camera position"
}
const char* g_pPluginName
Initial value:
= {
"HeadTracking"
}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/HeadTracking.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Namespaces | Functions
HeadTracking.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/HeadTracking/HeadTracking.h>
#include <osg/NodeVisitor>
#include <osg/Node>
#include <osg/Geode>

Namespaces

namespace ht

Functions

ht::METHOD_INPUT (Transformation, vrecko::MessageSensorTransformation, HeadTracking)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/htUtils.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Namespaces
htUtils.cpp File Reference
#include <vreckoAP/HeadTracking/htUtils.h>

Namespaces

namespace ht
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
precompiled.h File Reference
#include <osg/Vec3>
#include <osg/Matrixf>
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <vreckoAP/HeadTracking/Vec2i>
#include <vreckoAP/HeadTracking/Solver.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetup.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Functions
ScreenSetup.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/HeadTracking/ScreenSetup.h>
#include <iostream>
#include <sstream>
#include <fstream>

Classes

class ht::SetupFunction

Namespaces

namespace ht

Functions

ht::METHOD_INPUT (Position, vrecko::MessageSensorTransformation, ScreenSetup)
ht::METHOD_INPUT (Record, vrecko::MessageBool, ScreenSetup)
ht::METHOD_INPUT (NextCorner, vrecko::MessageBool, ScreenSetup)
ht::METHOD_INPUT (ShowPosition, vrecko::MessageBool, ScreenSetup)
ht::METHOD_INPUT (RunCalculation, vrecko::MessageBool, ScreenSetup)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/ScreenSetupSimple.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Classes | Namespaces | Functions
ScreenSetupSimple.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/HeadTracking/ScreenSetupSimple.h>
#include <iostream>
#include <sstream>
#include <fstream>

Classes

class ht::SimpleSetupFunction

Namespaces

namespace ht

Functions

ht::METHOD_INPUT (Position, vrecko::MessageSensorTransformation, ScreenSetupSimple)
ht::METHOD_INPUT (Record, vrecko::MessageBool, ScreenSetupSimple)
ht::METHOD_INPUT (ShowPosition, vrecko::MessageBool, ScreenSetupSimple)
ht::METHOD_INPUT (RunCalculation, vrecko::MessageBool, ScreenSetupSimple)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/Solver.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
Namespaces | Functions
Solver.cpp File Reference
#include <vreckoAP/HeadTracking/Solver.h>
#include <stdio.h>
#include <math.h>

Namespaces

namespace ht

Functions

double | ht::get_func_value (ListOfFunctions &fcns)
void | ht::der_approx (ListOfFunctions &fcns, Variable *var, int subvar, double step, double &first, double &second)
void | ht::solve (ListOfFunctions &fcns, ListOfVariables &vars, double start_step=0.01, double next_step_scale=0.8, double min_step_size=1e-6)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HelloWorld Directory Reference

  • src
  • vreckoAP
  • HelloWorld
HelloWorld Directory Reference

Files

file | AP_HelloWorld.cpp
file | MyAbility.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HelloWorld/AP_HelloWorld.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HelloWorld
Functions | Variables
AP_HelloWorld.cpp File Reference
#include <vreckoAP/HelloWorld/AP_HelloWorld.h>
#include <vreckoAP/HelloWorld/MyAbility.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"HelloWorld"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"World ability to create on-screen console for text output",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"MyAbility",
NULL
}
const char* g_pPluginName = {"HelloWorld"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HelloWorld/MyAbility.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HelloWorld
MyAbility.cpp File Reference
#include <vreckoAP/HelloWorld/MyAbility.h>
#include <vrecko\Logger.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HUD Directory Reference

  • src
  • vreckoAP
  • HUD
HUD Directory Reference

Files

file | AP_HUD.cpp
file | HUDDisplay.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HUD/AP_HUD.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HUD
Functions | Variables
AP_HUD.cpp File Reference
#include <vreckoAP/HUD/AP_HUD.h>
#include <vreckoAP/HUD/HUDDisplay.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"HUD"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"World ability to create on-screen HUD interface",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"HUDDisplay",
NULL
}
const char* g_pPluginName = {"HUD"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HUD/HUDDisplay.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • HUD
Namespaces
HUDDisplay.cpp File Reference
#include <vreckoAP/HUD/HUDDisplay.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <osg/Geometry>
#include <vrecko/PluginManager.h>
#include <osgUtil/Optimizer>
#include <osgDB/ReadFile>
#include <osgUtil/printVisitor>
#include <string.h>
#include <osg/Camera>
#include <osgViewer/Viewer>

Namespaces

namespace APHUD
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector Directory Reference

  • src
  • vreckoAP
  • InputConnector
InputConnector Directory Reference

Files

file | AP_InputConnector.cpp
file | InputConnector.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/AP_InputConnector.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • InputConnector
Functions | Variables
AP_InputConnector.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/InputConnector/AP_InputConnector.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pInputConnectorPluginName = {"InputConnector"}
const char * | g_pInputConnectorAbilityName []
const char * | g_pInputConnectorAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pInputConnectorAbilityDesc[]
Initial value:
= {
"Connects Input devices",
""
}
const char* g_pInputConnectorAbilityName[]
Initial value:
= {
"InputConnector",
NULL
}
const char* g_pInputConnectorPluginName = {"InputConnector"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/InputConnector.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • InputConnector
Namespaces | Macros | Functions
InputConnector.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/InputConnector/InputConnector.h>

Namespaces

namespace APInputConnector

Macros

#define err(msg) std::cerr << __FUNCTION__<< " - " << msg << std::endl;

Functions

APInputConnector::METHOD_REQUEST_INPUT (SensorTransformation, MessageInt, MessageSensorTransformation, InputConnector)
APInputConnector::METHOD_REQUEST_INPUT (SelectedObjectID, MessageInt, MessageObjectID, InputConnector)

Macro Definition Documentation

#define err ( msg ) std::cerr << __FUNCTION__<< " - " << msg << std::endl;

Macros for errors and debugging

Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • InputConnector
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • InputConnector
precompiled.h File Reference
#include <fstream>
#include <iostream>
#include <sstream>
#include <vector>
#include <math.h>
#include <vrecko/Ability.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Logger.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include <osgDB/ReadFile>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/dom/DOMWriter.hpp>
#include <xercesc/framework/LocalFileFormatTarget.hpp>
#include <xercesc/framework/StdOutFormatTarget.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <xercesc/util/XMLString.hpp>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor Directory Reference

  • src
  • vreckoAP
  • LightsEditor
LightsEditor Directory Reference

Files

file | AP_LightsEditor.cpp
file | Editor.cpp
file | Lights.cpp
file | UniformUpdateCallback.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/AP_LightsEditor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • LightsEditor
Functions | Variables
AP_LightsEditor.cpp File Reference
#include <vreckoAP/LightsEditor/AP_LightsEditor.h>
#include <vreckoAP/LightsEditor/Editor.h>
#include <vreckoAP/LightsEditor/Lights.h>

Functions

AP_EXPORT const char * | LightsEditor_getPluginDescription ()
AP_EXPORT const char ** | LightsEditor_getAbilityList ()
AP_EXPORT const char * | LightsEditor_getAbilityDescription (const char *strName)
AP_EXPORT Ability * | LightsEditor_getAbilityInstance (const char *pchName)
AP_EXPORT void | LightsEditor_setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"LightsEditor"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* LightsEditor_getAbilityDescription ( const char * strName )
AP_EXPORT Ability* LightsEditor_getAbilityInstance ( const char * pchName )
AP_EXPORT const char** LightsEditor_getAbilityList ( )
AP_EXPORT const char* LightsEditor_getPluginDescription ( )
AP_EXPORT void LightsEditor_setAbilitiesParameters ( )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Ability for creating lights in the scene",
"Base ability for creating and operating with lights",
""
}
const char* g_pAbilityName[]
Initial value:
=
{
"Editor",
"Lights",
NULL
}
const char* g_pPluginName = {"LightsEditor"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/Editor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • LightsEditor
Namespaces
Editor.cpp File Reference
#include <vreckoAP/LightsEditor/Editor.h>

Namespaces

namespace APLightsEditor
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/Lights.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • LightsEditor
Namespaces
Lights.cpp File Reference
#include <vreckoAP/LightsEditor/Lights.h>
#include <vreckoAP/LightsEditor/UniformUpdateCallback.h>
#include <osgDB/Registry>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <osgDB/FileUtils>
#include <osgShadow/ShadowMap>
#include <osgShadow/ShadowedScene>
#include <osg/PolygonOffset>
#include <osg/ComputeBoundsVisitor>
#include <vrecko/EnvironmentObject.h>

Namespaces

namespace APLightsEditor
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/LightsEditor/UniformUpdateCallback.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • LightsEditor
UniformUpdateCallback.cpp File Reference
#include <vreckoAP/LightsEditor/UniformUpdateCallback.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu Directory Reference

  • src
  • vreckoAP
  • Menu
Menu Directory Reference

Files

file | AP_Menu.cpp
file | DynamicMenu.cpp
file | DynamicMenu_XMLPart.cpp
file | osgQ_QSection.cpp
file | osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/AP_Menu.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Menu
Functions | Variables
AP_Menu.cpp File Reference
#include <vreckoAP/Menu/AP_Menu.h>
#include <vreckoAP/Menu/DynamicMenu.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"Menu"}
const char * | g_pAbilityName [] = {"DynamicMenu", NULL}
const char * | g_pAbilityDesc [] = {"Show dynamic menu", ""}

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[] = {"Show dynamic menu", ""}
const char* g_pAbilityName[] = {"DynamicMenu", NULL}
const char* g_pPluginName = {"Menu"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Menu
Namespaces | Macros | Functions
DynamicMenu.cpp File Reference
#include <vreckoAP/Menu/DynamicMenu.h>
#include <osgDB/ReadFile>
#include <osgUtil/Optimizer>
#include <osg/CullFace>
#include <osg/Depth>
#include <osg/ColorMask>
#include <osg/PositionAttitudeTransform>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <iostream>
#include <helpers/XercesXMLUtils.h>
#include <helpers/HelperMacros.h>
#include <math.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>

Namespaces

namespace APMenu

Macros

#define | MENUITEM_SUBSIZE_RATIO 0.8f
#define | MENUITEM_TEXT_FONT "./data/fonts/arial.ttf"
#define | MENUITEM_TEXT_CHARHEIGHT 0.3f
#define | MENU_RADIAL_MAXITEMS 8
#define | MENU_BOX_FIRST_X_OFFSET 0.1f
#define | MENUTIEM_BOX_INBETWEENDIST_X 0.08f
#define | MENUTIEM_BOX_INBETWEENDIST_Y 0.08f
#define | MENUTIEM_RADIALSECTION_INBETWEENDIST MENUTIEM_BOX_INBETWEENDIST_X
#define | MENU_GRID_X_OFFSET MENU_BOX_FIRST_X_OFFSET
#define | MENU_GRID_Y_OFFSET MENU_GRID_X_OFFSET
#define | PRINT_VEC(name, vec) std::cout << name << ": " << (vec).x() << ", " << (vec).y() << ", " << (vec).z() << std::endl;
#define | SEL_UPDATE_COLOR_COMPONENT(comp)
#define | MENUITEMSLIDER_SLIDER_SIZE_REL 0.8f
#define | MENUITEMSLIDER_SLIDER_X_CENTER_POS (0.0f)
#define | MENUITEMSLIDER_SLIDER_Y_CENTER_POS (-itemSize2 / 3.0f)
#define | MENUITEMSLIDER_SLIDER_Z_CENTER_POS (0.0f)
#define | MENUITEMSLIDER_SLIDER_X_HALF_LENGTH (itemSize / 20.0f)
#define | MENUITEMSLIDER_SLIDER_Y_HALF_LENGTH (itemSize2 / 8.0f)
#define | MENUITEMSLIDER_SLIDER_Z_HALF_LENGTH (itemSize2 / 10.f)
#define | MENUITEMSLIDER_SAFE_ADDITION 0.01f
#define | DM_CLICKEDSTRING_MAXSIZE 1000

Functions

APMenu::METHOD_REQUEST_INPUT (ActivePointerID, MessageInt, MessageInt, DynamicMenu)

Macro Definition Documentation

#define DM_CLICKEDSTRING_MAXSIZE 1000
#define MENU_BOX_FIRST_X_OFFSET 0.1f
#define MENU_GRID_X_OFFSET MENU_BOX_FIRST_X_OFFSET
#define MENU_GRID_Y_OFFSET MENU_GRID_X_OFFSET
#define MENU_RADIAL_MAXITEMS 8
#define MENUITEM_SUBSIZE_RATIO 0.8f
#define MENUITEM_TEXT_CHARHEIGHT 0.3f
#define MENUITEM_TEXT_FONT "./data/fonts/arial.ttf"
#define MENUITEMSLIDER_SAFE_ADDITION 0.01f
#define MENUITEMSLIDER_SLIDER_SIZE_REL 0.8f
#define MENUITEMSLIDER_SLIDER_X_CENTER_POS (0.0f)
#define MENUITEMSLIDER_SLIDER_X_HALF_LENGTH (itemSize / 20.0f)
#define MENUITEMSLIDER_SLIDER_Y_CENTER_POS (-itemSize2 / 3.0f)
#define MENUITEMSLIDER_SLIDER_Y_HALF_LENGTH (itemSize2 / 8.0f)
#define MENUITEMSLIDER_SLIDER_Z_CENTER_POS (0.0f)
#define MENUITEMSLIDER_SLIDER_Z_HALF_LENGTH (itemSize2 / 10.f)
#define MENUTIEM_BOX_INBETWEENDIST_X 0.08f
#define MENUTIEM_BOX_INBETWEENDIST_Y 0.08f
#define MENUTIEM_RADIALSECTION_INBETWEENDIST MENUTIEM_BOX_INBETWEENDIST_X
#define PRINT_VEC | ( | name,
 |  | vec
 | ) | std::cout << name << ": " << (vec).x() << ", " << (vec).y() << ", " << (vec).z() << std::endl;
#define SEL_UPDATE_COLOR_COMPONENT ( comp )
Value:
{ \
comp = comp * 0.7f; \
}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/DynamicMenu_XMLPart.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Menu
Namespaces
DynamicMenu_XMLPart.cpp File Reference
#include <vreckoAP/Menu/DynamicMenu.h>
#include <vreckoAP/Menu/DynamicMenu_XMLPart.h>
#include <helpers/XercesXMLUtils.h>

Namespaces

namespace APMenu
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QSection.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Menu
Namespaces
osgQ_QSection.cpp File Reference
#include <vreckoAP/Menu/osgQ_QSection.h>

Namespaces

namespace osgQ
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Menu/osgQ_QShapeDrawable.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Menu
Classes | Namespaces | Macros
osgQ_QShapeDrawable.cpp File Reference
#include <vreckoAP/Menu/osgQ_QShapeDrawable.h>
#include <vreckoAP/Menu/osgQ_QSection.h>
#include <osg/GL>
#include <iostream>

Classes

class | osgQ::QDrawShapeVisitor
class | osgQ::QComputeBoundShapeVisitor
class | osgQ::QPrimitiveShapeVisitor

Namespaces

namespace osgQ

Macros

#define | OUTX_DIR(angle)
#define | OUTY_DIR(angle)
#define | OUTX(angle) ((OUTX_DIR(angle)) * section.getOuterRadius())
#define | OUTY(angle) ((OUTY_DIR(angle)) * section.getOuterRadius())
#define | INX_DIR(angle) (-cos((angle)))
#define | INX(angle) (INX_DIR(angle) * section.getInnerRadius())
#define | INY_DIR(angle) (sin((angle)))
#define | INY(angle) (INY_DIR(angle) * section.getInnerRadius())

Macro Definition Documentation

#define INX ( angle ) (INX_DIR(angle) * section.getInnerRadius())
#define INX_DIR ( angle ) (-cos((angle)))
#define INY ( angle ) (INY_DIR(angle) * section.getInnerRadius())
#define INY_DIR ( angle ) (sin((angle)))
#define OUTX ( angle ) ((OUTX_DIR(angle)) * section.getOuterRadius())
#define OUTX_DIR ( angle )
Value:
(-cos( \
section.getAngleFrom() - section.getOuterAngleAddition() / 2.0f + ((angle) - section.getAngleFrom()) * inOutRatio \
))
#define OUTY ( angle ) ((OUTY_DIR(angle)) * section.getOuterRadius())
#define OUTY_DIR ( angle )
Value:
(sin( \
section.getAngleFrom() - section.getOuterAngleAddition() / 2.0f + ((angle) - section.getAngleFrom()) * inOutRatio \
))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature Directory Reference

  • src
  • vreckoAP
  • Nature
Nature Directory Reference

Directories

directory | Clouds
directory | Grass
directory | Terrain
directory | Weather

Files

file | _AP_Atmospheric.cpp
file | _precompiled.cpp
file | _precompiled.h [code]
file | AP_Nature.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds Directory Reference

  • src
  • vreckoAP
  • Nature
  • Clouds
Clouds Directory Reference

Files

file | Cloud.cpp
file | Cloud2DPlacement.cpp
file | Clouds.cpp
file | CloudsManager.cpp
file | GenClouds.cpp
file | math_aux.cpp
file | OSGskybox.cpp
file | Texture.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Cloud.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Cloud.cpp File Reference
#include <climits>
#include <cmath>
#include <cstdlib>
#include <gl/glut.h>
#include <gl/glext.h>
#include <osg/Math>
#include <vreckoAP/Nature/Clouds/Cloud.h>
#include <vreckoAP/Nature/Clouds/CloudsManager.h>
#include <vreckoAP/Nature/Clouds/math_aux.h>

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 - February 2011 (Clouds)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Cloud2DPlacement.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Cloud2DPlacement.cpp File Reference
#include <iostream>
#include <cstdlib>
#include <cmath>
#include <vreckoAP/Nature/Clouds/Cloud2DPlacement.h>

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 (Clouds)
Note
View Cloud2DPlacement.h
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Clouds.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Variables
Clouds.cpp File Reference
#include <vreckoAP/Nature/Clouds/Clouds.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <osg/Depth>
#include <osgDB/ReadFile>
#include <osg/BlendFunc>
#include <osg/AlphaFunc>
#include <osg/Geometry>
#include <sstream>
#include <vreckoAP/Nature/Clouds/Cloud.h>
#include <vreckoAP/Nature/Clouds/CloudsManager.h>
#include <vreckoAP/Nature/Clouds/OSGCloudWrap.h>
#include <vreckoAP/Nature/Clouds/OSGskybox.h>

Variables

osg::ref_ptr< CloudDataType > g_CloudData

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), November 2010 - January 2011 (Clouds)

Variable Documentation

osg::ref_ptr<CloudDataType> g_CloudData
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/CloudsManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Variables
CloudsManager.cpp File Reference
#include <cstdlib>
#include <iostream>
#include <fstream>
#include <sstream>
#include <string>
#include <cmath>
#include <vreckoAP/Nature/Clouds/CloudsManager.h>
#include <vreckoAP/Nature/Clouds/GenClouds.h>
#include <vreckoAP/Nature/Clouds/Texture.h>

Variables

bool | g_Anisotropic_scattering = true
bool | g_MultipleForwardScattering = true
CloudsManager g_Clouds

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), November 2010 - February 2011 (Clouds)

Variable Documentation

bool g_Anisotropic_scattering = true
CloudsManager g_Clouds
bool g_MultipleForwardScattering = true
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/GenClouds.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Macros | Functions | Variables
GenClouds.cpp File Reference
#include <iostream>
#include <cstdlib>
#include <vreckoAP/Nature/Clouds/GenClouds.h>
#include <vreckoAP/Nature/Clouds/math_aux.h>

Macros

#define | NX 100
#define | NY 100
#define | NZ 100

Functions

void | InitCloudGrowth (int ellips_a, int ellips_b, int ellips_c)
bool | f_act (unsigned int i, unsigned int j, unsigned int k)
void | GrowthSimulation (int timeSteps)
float | weightedSum (unsigned int i, unsigned int j, unsigned int k)
void | CreateCloudFromVoxels (Cloud &cloud, const osg::Vec3f &cloudPos, float scale)

Variables

CloudVoxel voxel_space [NX][NY][NZ]
int | ellipsoid_2a = 0
int | ellipsoid_2b = 0
int | ellipsoid_2c = 0

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 (Clouds)

Macro Definition Documentation

#define NX 100
#define NY 100
#define NZ 100

Function Documentation

void CreateCloudFromVoxels | ( | Cloud & | cloud,
 |  | const osg::Vec3f & | cloudPos,
 |  | float | scale
 | ) |  |

Converts the voxel space into the final cloud

Parameters
[in] | cloud | Instance of a cloud which is used to store the data from the voxel space
[in] | cloudPos | Position of the cloud in the scene
[in] | scale | Scale of the cloud
bool f_act | ( | unsigned int | i,
 |  | unsigned int | j,
 |  | unsigned int | k
 | ) |  |

Function computing the active value of the given cell as described in the thesis (p.3, formula 2.4)

Parameters
[in] | i | X-coordinate of the voxel in the cloud
[in] | j | Y-coordinate of the voxel in the cloud
[in] | k | Z-coordinate of the voxel in the cloud
void GrowthSimulation ( int timeSteps )

Simulates the growth of the cloud

Parameters
timeSteps Number of steps the generation process should take
void InitCloudGrowth | ( | int | ellips_a,
 |  | int | ellips_b,
 |  | int | ellips_c
 | ) |  |

Initializes the growth simulation of the cloud

Parameters
[in] | ellips_a | Size of the half-axis a of the ellipsoid
[in] | ellips_b | Size of the half-axis b of the ellipsoid
[in] | ellips_c | Size of the half-axis c of the ellipsoid
float weightedSum | ( | unsigned int | i,
 |  | unsigned int | j,
 |  | unsigned int | k
 | ) |  |

Computes the weighted sum of the cloud cell and cells related to it.

Parameters
[in] | i | X coordinate of the cloud cell in the voxel space
[in] | j | Y coordinate of the cloud cell in the voxel space
[in] | k | Z coordinate of the cloud cell in the voxel space
Returns
Weighted sum of the cloud cell and cells related to it.

Variable Documentation

int ellipsoid_2a = 0
int ellipsoid_2b = 0
int ellipsoid_2c = 0
CloudVoxel voxel_space[NX][NY][NZ]
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/math_aux.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Functions
math_aux.cpp File Reference
#include <cstdlib>
#include <vreckoAP/Nature/Clouds/math_aux.h>

Functions

unsigned int | randGauss (unsigned int number, unsigned int n)
float | randFloat (void)
float | interpolationLinear (float a, float b, float t)
void | clampColor (osg::Vec4f &color, float maximum)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 - February 2011 (Clouds)

Function Documentation

void clampColor | ( | osg::Vec4f & | color,
 |  | float | maximum
 | ) |  |

Clamps the color in case some of its values are larger than the given maximum.

Parameters
color | Color to be clamped.
maximum | Threshold value; color channels larger than maximum will be clamped to it, smaller values will be preserved.
float interpolationLinear | ( | float | a,
 |  | float | b,
 |  | float | t
 | ) |  |

Linear interpolation of two values.

Parameters
a | The first value to interpolate.
b | The second value to interpolate.
t | Value on the interval. T = 0.0 returns as a result value A, T = 1.0 returns as a result value B
float randFloat ( void )

Returns a pseudo-random float value from the interval <0, 1.0)

Returns
Pseudo-random float value
unsigned int randGauss | ( | unsigned int | cislo,
 |  | unsigned int | n
 | ) |  |

Returns a pseudo-random unsigned integer value based on Gauss distribution

Parameters
[in] | number | Maximum value of the number
[in] | n | Number of iterations
Returns
Pseudo-random number based on Gauss distribution
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/OSGskybox.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Functions
OSGskybox.cpp File Reference
#include <osg/AlphaFunc>
#include <osg/Texture2D>
#include <osgDB/ReadFile>
#include <osg/Geometry>
#include <osg/BlendFunc>
#include <iostream>
#include <vreckoAP/Nature/Clouds/CloudsManager.h>
#include <vreckoAP/Nature/Clouds/OSGskybox.h>

Functions

void | CreateSkyBox (osg::ref_ptr< osg::Geode > skyboxGeode, long x, long y, long z, long width, long height, long length)
void | CreateGround (osg::ref_ptr< osg::Geode > groundGeode, long x, long y, long z, long width, long length, long tileCount)
void | CreateSun (osg::ref_ptr< osg::Billboard > sunBillBoard, int x, int y, int z)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), December 2010 (Clouds)

Function Documentation

void CreateGround | ( | osg::ref_ptr< osg::Geode > | groundGeode,
 |  | long | x,
 |  | long | y,
 |  | long | z,
 |  | long | width,
 |  | long | length,
 |  | long | tileCount
 | ) |  |

Creates a basic ground with texture

Parameters
[out] | groundGeode | Pointer to the osg::geode, where the ground should be stored
[in] | x | X coordinate of the center of the ground
[in] | y | Y coordinate of the ground (since the thickness is zero the parameter only determines the Y coordinate)
[in] | z | Z coordinate of the center of the ground
[in] | width | Width of the ground
[in] | length | Length of the ground
[in] | tileCount | Number of tiles in one coordinate
void CreateSkyBox | ( | osg::ref_ptr< osg::Geode > | skyboxGeode,
 |  | long | x,
 |  | long | y,
 |  | long | z,
 |  | long | width,
 |  | long | height,
 |  | long | length
 | ) |  |

Creates a skybox

Parameters
[out] | skyboxGeode | Pointer to the osg::geode, where the skybox should be stored
[in] | x | X coordinate of the center of the skybox
[in] | y | Y coordinate of the center of the skybox
[in] | z | Z coordinate of the center of the skybox
[in] | width | Width of the skybox
[in] | height | Height of the skybox
[in] | length | Length of the skybox
void CreateSun | ( | osg::ref_ptr< osg::Billboard > | sunBillBoard,
 |  | int | x,
 |  | int | y,
 |  | int | z
 | ) |  |

Creates a basic ground with texture

Parameters
[out] | sunBillBoard | Pointer to the osg::BillBoard, where the sun should be stored
[in] | x | X coordinate of the center of the sun
[in] | y | Y coordinate of the center of the sun
[in] | z | Z coordinate of the center of the sun
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Clouds/Texture.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Clouds
Functions
Texture.cpp File Reference
#include <iostream>
#include <fstream>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <vreckoAP/Nature/Clouds/Texture.h>

Functions

osg::ref_ptr< osg::Texture2D > LoadOSGTextureWithColorKey (char *fileName, bool alphaMap, bool computeColorAsRGBAverage, bool colorKey, const osg::Vec4ub &colorKeyValue)

Detailed Description

Author
Jakub Kroupal (original Atmospheric plug-in)
Rastislav Tisovcik (revised Clouds ability)
Version
2.0
Date
2008 (Atmospheric), January 2011 - February 2011 (Clouds)

Function Documentation

osg::ref_ptr<osg::Texture2D> LoadOSGTextureWithColorKey | ( | char * | fileName,
 |  | bool | alphaMap,
 |  | bool | computeColorAsRGBAverage,
 |  | bool | colorKey,
 |  | const osg::Vec4ub & | colorKeyValue = osg::Vec4ub(255, 0, 255, 0)
 | ) |  |

Loads an OSG Texture with additional parameters such as colorkey or possibility to load the texture as an alpha map. The pixel format of the texture has to be GL_RGB or GL_RGBA.

Parameters
[in] | fileName | Path to the file with the texture. All filetypes accepted by OSG are also permitted.
[in] | alphaMap | TRUE if the RGB values of the texture should be transformed to the greyscale so the texture could be used as an alpha map, FALSE otherwise - if the RGB values should not be modified.
[in] | computeColorAsRGBAverage | If the alphaMap is TRUE, this parameter determines whether the RGB values of the alpha map are computed as an average of their values (TRUE) or if they're set on full white (FALSE). If alphaMap is FALSE, this parameter has no influence at all.
[in] | colorKey | TRUE if the color key is used to make texture transparent, FALSE otherwise.
[in] | colorKeyValue | Value of the color key. If the colorKey parameter is TRUE, pixels with colorKeyValue are set to be fully transparent. If the colorKey is FALSE, this parameter has no influence and pixels are set to be fully opaque if the aphaMap is FALSE or their alpha value is computed from the RGB values if the alphaMap is TRUE. (optional parameter, default value = (255,0,255,0))
Returns
Loaded OSG texture with GL_RGBA pixel format.
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass Directory Reference

  • src
  • vreckoAP
  • Nature
  • Grass
Grass Directory Reference

Files

file | grass.cpp
file | grass_drawable.cpp
file | grass_mesh.cpp
file | grass_parameters.cpp
file | grass_triangle_collector.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Grass
Namespaces
grass.cpp File Reference
#include <vreckoAP/Nature/Grass/grass.h>
#include <vreckoAP/Nature/Grass/grass_triangle_collector.h>
#include <osg/Group>
#include <osg/Geode>
#include <osg/Geometry>

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_drawable.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Grass
Namespaces | Variables
grass_drawable.cpp File Reference
#include <vreckoAP/Nature/Grass/grass_drawable.h>
#include <vreckoAP/Nature/Grass/grass_cullcallback.h>
#include <vreckoAP/Nature/Grass/grass_triangle_collector.h>
#include <osg/gl2extensions>
#include <vrecko/logger.h>

Namespaces

namespace grass

Variables

const float grass::maxLODdifference = 0.1f
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_mesh.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Grass
Namespaces
grass_mesh.cpp File Reference
#include <vreckoAP/Nature/Grass/grass_mesh.h>

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_parameters.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Grass
Namespaces
grass_parameters.cpp File Reference
#include <vreckoAP/Nature/Grass/grass_parameters.h>
#include <vreckoAP/Nature/Grass/grass_cullcallback.h>
#include <sstream>
#include <osgDB/readFile>
#include <vreckoAP/Nature/Grass/grass_shaders_source.h>

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Grass/grass_triangle_collector.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Grass
Namespaces
grass_triangle_collector.cpp File Reference
#include <vreckoAP/Nature/Grass/grass_triangle_collector.h>

Namespaces

namespace grass
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain Directory Reference

  • src
  • vreckoAP
  • Nature
  • Terrain
Terrain Directory Reference

Directories

directory | Algorithms
directory | Properties

Files

file | Terrain2D.cpp
file | Terrain2DSegment.cpp
file | TerrainAbility.cpp
file | TerrainRandom.cpp
file | TerrainUtility.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms Directory Reference

  • src
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
Algorithms Directory Reference

Files

file | MidpointDisplacementAlgorithm.cpp
file | PerlinNoiseAlgorithm.cpp
file | RandomFaultsAlgorithm.cpp
file | TerrainAlgorithm.cpp
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
MidpointDisplacementAlgorithm.cpp File Reference
#include <vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/TerrainRandom.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
PerlinNoiseAlgorithm.cpp File Reference
#include <vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.h>
#include <vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainRandom.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <osg/Image>
#include <osgDB/WriteFile>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
RandomFaultsAlgorithm.cpp File Reference
#include <vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.h>
#include <vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainRandom.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
TerrainAlgorithm.cpp File Reference
#include <vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties Directory Reference

  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Properties Directory Reference

Files

file | Default.cpp
file | GeneratedTerrainProperties.cpp
file | HeightMapProperties.cpp
file | MidpointDisplacementProperties.cpp
file | PerlinNoiseProperties.cpp
file | RandomFaultsProperties.cpp
file | TerrainProperties.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/Default.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Default.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/GeneratedTerrainProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
GeneratedTerrainProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/GeneratedTerrainProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/HeightMapProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
HeightMapProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/HeightMapProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
MidpointDisplacementProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
PerlinNoiseProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
RandomFaultsProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Properties/TerrainProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
  • Properties
TerrainProperties.cpp File Reference
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/TerrainProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/HeightMapProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/GeneratedTerrainProperties.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Terrain2D.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
Terrain2D.cpp File Reference
#include <osg/Geometry>
#include <osg/PositionAttitudeTransform>
#include <osg/Image>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <ostream>
#include <vreckoAP/Nature/Terrain/Terrain2D.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <vreckoAP/Nature/Terrain/TerrainRandom.h>
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
#include <vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.h>
#include <vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.h>
#include <vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/Terrain2DSegment.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
Terrain2DSegment.cpp File Reference
#include <osgDB/ReadFile>
#include <osg/Material>
#include <iostream>
#include <vreckoAP/Nature/Terrain/Terrain2DSegment.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainAbility.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
Functions
TerrainAbility.cpp File Reference
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <osg/ShapeDrawable>
#include <osg/Geometry>
#include <vreckoAP/Nature/Terrain/TerrainAbility.h>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
#include <vreckoAP/Nature/Terrain/Properties/Default.h>
#include <vreckoAP/Nature/Terrain/Properties/HeightMapProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
#include <vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h>
#include <sstream>

Functions

METHOD_INPUT (GUIItemClicked, MessageString, TerrainAbility)
METHOD_INPUT (CreateMenuStructure, MessageInt, TerrainAbility)
METHOD_INPUT (HidingMenu, MessageBool, TerrainAbility)

Function Documentation

METHOD_INPUT | ( | GUIItemClicked | ,
 |  | MessageString | ,
 |  | TerrainAbility |
 | ) |  |
METHOD_INPUT | ( | CreateMenuStructure | ,
 |  | MessageInt | ,
 |  | TerrainAbility |
 | ) |  |
METHOD_INPUT | ( | HidingMenu | ,
 |  | MessageBool | ,
 |  | TerrainAbility |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainRandom.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
TerrainRandom.cpp File Reference
#include <vreckoAP/Nature/Terrain/TerrainRandom.h>
#include <vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Terrain/TerrainUtility.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Terrain
TerrainUtility.cpp File Reference
#include <cctype>
#include <vreckoAP/Nature/Terrain/TerrainUtility.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Weather Directory Reference

  • src
  • vreckoAP
  • Nature
  • Weather
Weather Directory Reference

Files

file Weather.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/Weather/Weather.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
  • Weather
Weather.cpp File Reference
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include <vreckoAP/Nature/Weather/Weather.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/_AP_Atmospheric.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
Functions | Variables
_AP_Atmospheric.cpp File Reference
#include <cstring>
#include "AP_Atmospheric.h"
#include "Clouds/Clouds.h"

Functions

const char * | Atmospheric_getPluginDescription (void)
const char ** | Atmospheric_getAbilityList (void)
const char * | Clouds_getAbilityDescription (const char *name)
vrecko::Ability * | Atmospheric_getAbilityInstance (const char *_name)

Variables

const char * | _Atmospheric_plugin_name = { "Atmospheric" }
const char * | _Atmospheric_ability_name []
const char * | _Atmospheric_ability_description []

Function Documentation

vrecko::Ability* Atmospheric_getAbilityInstance ( const char * _name )
const char** Atmospheric_getAbilityList ( void )
const char* Atmospheric_getPluginDescription ( void )
const char* Clouds_getAbilityDescription ( const char * name )

Variable Documentation

const char* _Atmospheric_ability_description[]
Initial value:
= {
"Clouds rendering",
""}
const char* _Atmospheric_ability_name[]
Initial value:
= {
"Clouds",
NULL}
const char* _Atmospheric_plugin_name = { "Atmospheric" }
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/_precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
_precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/_precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
_precompiled.h File Reference
#include <iostream>
#include <fstream>
#include <sstream>
#include <string>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <osg/AlphaFunc>
#include <osg/Texture2D>
#include <osg/Geometry>
#include <osg/BlendFunc>
#include <osg/Depth>
#include <osg/Math>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include "AP_Atmospheric.h"
#include "Clouds/Clouds.h"
#include "Clouds/math_aux.h"
#include "Weather/Weather.h"

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/AP_Nature.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
Functions | Variables
AP_Nature.cpp File Reference
#include <vreckoAP/Nature/AP_Nature.h>
#include <vreckoAP/Nature/Clouds/Clouds.h>
#include <vreckoAP/Nature/Grass/grass.h>
#include <vreckoAP/Nature/Terrain/TerrainAbility.h>
#include <vreckoAP/Nature/Weather/Weather.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"Nature"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Clouds rendering",
"Creates grass on any surface",
"Nature-related ability capable of generation, loading, saving and display of complex terrain data based on the given attributes and restraints",
"Weather effects",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"Clouds",
"Grass",
"Terrain",
"Weather",
NULL
}
const char* g_pPluginName = {"Nature"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation Directory Reference

  • src
  • vreckoAP
  • navigation
navigation Directory Reference

Files

file | AP_navigation.cpp
file | AvatarInHand.cpp
file | KMTracker.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/AP_navigation.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
Functions | Variables
AP_navigation.cpp File Reference
#include "precompiled.h"
#include <string>
#include <vreckoAP/navigation/AP_navigation.h>

Functions

const char ** | navigation_getAbilityList (void)
Ability * | navigation_getAbilityInstance (const char *_name)

Variables

const char * | _navigation_plugin_name = { "navigation" }
const char * | _navigation_ability_name []
Ability * _new_ability

Function Documentation

Ability* navigation_getAbilityInstance ( const char * _name )
const char** navigation_getAbilityList ( void )

Variable Documentation

const char* _navigation_ability_name[]
Initial value:
= {
"KMTracker",
"AvatarInHand",
NULL
}
const char* _navigation_plugin_name = { "navigation" }
Ability* _new_ability
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/AvatarInHand.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
Macros
AvatarInHand.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/navigation/AvatarInHand.h>
#include <vrecko/Scene.h>
#include <osg/Matrix>
#include <osg/Quat>
#include <vrecko/ReaderWriter.h>
#include <vrecko/EventDispatcher.h>

Macros

#define | _EO_owner ((EnvironmentObject *) pOwner)
#define | ARM_LENGTH 6.0
#define | SPEED 0.20

Macro Definition Documentation

#define _EO_owner ((EnvironmentObject *) pOwner)
#define ARM_LENGTH 6.0
#define SPEED 0.20
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/KMTracker.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
KMTracker.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/navigation/KMTracker.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
precompiled.h File Reference
#include <esg/OSGAdapter.h>
#include <esg/PointEnv.h>
#include <esg/Shape.h>
#include <esg/spacesorting/FDH14Tree.h>
#include <stdlib.h>
#include <string>
#include <map>
#include <sstream>
#include <vector>
#include <time.h>
#include <sys/time.h>
#include <osg/Matrix>
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Node>
#include <osg/Quat>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Material>
#include <osg/Timer>
#include <osgUtil/CullVisitor>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Message.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/ReaderWriter.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils Directory Reference

  • src
  • vreckoAP
  • ObjectUtils
ObjectUtils Directory Reference

Files

file | Animator.cpp
file | AP_ObjectUtils.cpp
file | ConnectionViz.cpp
file | CopyProperties.cpp
file | KeepOnScreen.cpp
file | ObjectEffect.cpp
file | ObjectEffectMan.cpp
file | ObjectInfo.cpp
file | ObjectModif.cpp
file | ObjectSelector.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | UseToEvent.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/Animator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces | Macros
Animator.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <helpers/XercesXMLUtils.h>
#include <vreckoAP/ObjectUtils/KeepOnScreen.h>
#include <vreckoAP/ObjectUtils/Animator.h>
#include <math.h>
#include <vrecko/PluginManager.h>
#include <osg/BlendFunc>
#include <osg/BlendColor>

Namespaces

namespace APObjectUtils

Macros

#define | READ_XML_VECTOR(parentNode, name, function_set, pnt)
#define | READ_XML_QUAT(parentNode, name, function_set, pnt)
#define | READ_XML_FLOAT(parentNode, name, function_set)
#define | ASSERT_POINT_INDEX(pointIndex, return_value_if_error)

Macro Definition Documentation

#define ASSERT_POINT_INDEX | ( | pointIndex,
 |  | return_value_if_error
 | ) |
Value:
if (((pointIndex) < 0) || ((pointIndex) >= (int)points.dwNum)) { \
logger.errorLog("Animator: Specified pointIndex (%d) is out of bounds (0 .. %d)", pointIndex, (int)points.dwNum - 1); \
return (return_value_if_error); \
}
#define READ_XML_FLOAT | ( | parentNode,
 |  | name,
 |  | function_set
 | ) |
Value:
if (tmpNode = findXMLNode (parentNode, name)) { \
tmpStr = getNodeTextTrans(tmpNode); \
sscanf(tmpStr, "%f", &x); \
function_set(x); \
XERCES_CPP_NAMESPACE_QUALIFIER XMLString::release (&tmpStr); \
}
#define READ_XML_QUAT | ( | parentNode,
 |  | name,
 |  | function_set,
 |  | pnt
 | ) |
Value:
if (tmpNode = findXMLNode (parentNode, name)) { \
tmpStr = getNodeTextTrans(tmpNode); \
sscanf(tmpStr, "%f %f %f %f", &x, &y, &z, &w); \
function_set(pnt, osg::Quat(x, y, z, w)); \
XERCES_CPP_NAMESPACE_QUALIFIER XMLString::release (&tmpStr); \
}
#define READ_XML_VECTOR | ( | parentNode,
 |  | name,
 |  | function_set,
 |  | pnt
 | ) |
Value:
if (tmpNode = findXMLNode (parentNode, name)) { \
tmpStr = getNodeTextTrans(tmpNode); \
sscanf(tmpStr, "%f %f %f", &x, &y, &z); \
function_set(pnt, osg::Vec3(x, y, z)); \
XERCES_CPP_NAMESPACE_QUALIFIER XMLString::release (&tmpStr); \
}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/AP_ObjectUtils.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Functions | Variables
AP_ObjectUtils.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/AP_ObjectUtils.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <vreckoAP/ObjectUtils/ObjectSelector.h>
#include <vreckoAP/ObjectUtils/ObjectEffect.h>
#include <vreckoAP/ObjectUtils/ObjectEffectMan.h>
#include <vreckoAP/ObjectUtils/ObjectModif.h>
#include <vreckoAP/ObjectUtils/KeepOnScreen.h>
#include <vreckoAP/ObjectUtils/Animator.h>
#include <vreckoAP/ObjectUtils/ConnectionViz.h>
#include <vreckoAP/ObjectUtils/UseToEvent.h>
#include <vreckoAP/ObjectUtils/CopyProperties.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_PluginName = {"ObjectUtils"}
const char * | g_AbilityName []
const char * | g_AbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_AbilityDesc[]
Initial value:
= {
"Transfer object properties to other abilities.",
"Selects an object intersecting the cursor.",
"Renders an effect tied to an object.",
"Manages an ObjectEffect (mainly allows adding and removing the effect)",
"Allows changes of a given object attributes.",
"Fixes an object in the particular place on the screen.",
"Simple animations of a given object.",
"Visualizes an incoming or outgoing connection to/from the owner object.",
"Generates a Trigger output signal after receiving the Use input signal.",
"Copy some properties of another object, such as geometry (one time only) or transformation (each frame).",
""
}
const char* g_AbilityName[]
Initial value:
= {
"ObjectInfo",
"ObjectSelector",
"ObjectEffect",
"ObjectEffectMan",
"ObjectModif",
"KeepOnScreen",
"Animator",
"ConnectionViz",
"UseToEvent",
"CopyProperties",
NULL
}
const char* g_PluginName = {"ObjectUtils"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ConnectionViz.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces | Functions
ConnectionViz.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ConnectionViz.h>
#include <vrecko/EventDispatcher.h>
#include <helpers/HelperMacros.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <helpers/XercesXMLUtils.h>
#include <math.h>
#include <helpers/StringHelpers.h>

Namespaces

namespace APObjectUtils

Functions

void APObjectUtils::HSVtoRGB (float *r, float *g, float *b, float h, float s, float v)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/CopyProperties.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
CopyProperties.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/CopyProperties.h>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/KeepOnScreen.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
KeepOnScreen.cpp File Reference
#include "precompiled.h"
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <helpers/XercesXMLUtils.h>
#include <vreckoAP/ObjectUtils/KeepOnScreen.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectEffect.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces | Macros
ObjectEffect.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ObjectEffect.h>
#include <osg/Geode>
#include <osg/BlendEquation>
#include <osg/BlendFunc>
#include <osg/BlendColor>
#include <osg/Depth>
#include <osg/CullFace>
#include <osg/LightModel>
#include <osg/BoundingSphere>
#include <osg/PolygonOffset>
#include <vrecko/Scene.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/SP_SceneInterface.h>
#include <vrecko/ReaderWriter.h>
#include <helpers/XercesXMLUtils.h>
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <osg/ShadeModel>
#include <osg/LineWidth>
#include <vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h>
#include <vreckoAP/SpacePartitioning/SNCH_Object_Data.h>
#include <vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data.h>

Namespaces

namespace APObjectUtils

Macros

#define | DEFAULT_STATESET_VALUE (osg::StateAttribute::OVERRIDE | osg::StateAttribute::ON)
#define | SINGLE_TIME(x)
#define | VG_ADD_VERTEX(ix, iy, iz)
#define | VG_ADD_NORMALS(iter_var, ix, iy, iz)
#define | VG_ADD_FACE_AND_COLOR

Macro Definition Documentation

#define DEFAULT_STATESET_VALUE (osg::StateAttribute::OVERRIDE | osg::StateAttribute::ON)
#define SINGLE_TIME ( x )
Value:
{ \
static bool bIWasHere = false; \
if (!bIWasHere) { \
bIWasHere = true; \
(x); \
} \
}
#define VG_ADD_FACE_AND_COLOR
Value:
{ \
faces->push_back(vertices->size() - 4); \
faces->push_back(vertices->size() - 3); \
faces->push_back(vertices->size() - 2); \
\
faces->push_back(vertices->size() - 4); \
faces->push_back(vertices->size() - 2); \
faces->push_back(vertices->size() - 1); \
\
colors->push_back(color); \
colors->push_back(color); \
}
#define VG_ADD_NORMALS | ( | iter_var,
 |  | ix,
 |  | iy,
 |  | iz
 | ) |
Value:
{ \
for (iter_var = 0; iter_var < 4; iter_var++) \
normals->push_back(osg::Vec3(ix, iy, iz)); \
}
#define VG_ADD_VERTEX | ( | ix,
 |  | iy,
 |  | iz
 | ) |
Value:
{ \
vertices->push_back( \
osg::Vec3( \
bbox.xMin() + cellSize.x() * (ix), \
bbox.yMin() + cellSize.y() * (iy), \
bbox.zMin() + cellSize.z() * (iz) \
) \
); \
}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectEffectMan.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
ObjectEffectMan.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ObjectEffectMan.h>
#include <vrecko/Scene.h>
#include <vrecko/PluginManager.h>
#include <helpers/XercesXMLUtils.h>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectInfo.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
ObjectInfo.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ObjectInfo.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectModif.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
ObjectModif.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ObjectModif.h>
#include <vrecko/EventDispatcher.h>
#include <osg/Material>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/ObjectSelector.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Classes | Namespaces | Functions
ObjectSelector.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/ObjectSelector.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/PluginManager.h>
#include <osgDB/ReadFile>

Classes

struct | APObjectUtils::MyReadCallback
class | APObjectUtils::EOLineSegmentIntersector

Namespaces

namespace APObjectUtils

Functions

APObjectUtils::METHOD_REQUEST_INPUT (SelectionID, MessageVoid, MessageObjectID, ObjectSelector)
APObjectUtils::METHOD_REQUEST_INPUT (SelectionByPointerPos, MessageVec3, MessageObjectID, ObjectSelector)
APObjectUtils::METHOD_REQUEST_INPUT (SelectionByPointerPos_Path, MessageVec3, MessageNodeList, ObjectSelector)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
precompiled.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Scene.h>
#include <vrecko/PluginManager.h>
#include <helpers/DynamicArray.h>
#include <helpers/XercesXMLUtils.h>
#include <math.h>
#include <osg/BlendColor>
#include <osg/BlendFunc>
#include <osg/Geode>
#include <osg/Group>
#include <osg/ShapeDrawable>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/UseToEvent.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
Namespaces
UseToEvent.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/ObjectUtils/UseToEvent.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>

Namespaces

namespace APObjectUtils
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX Directory Reference

  • src
  • vreckoAP
  • PhysX
PhysX Directory Reference

Directories

directory common code

Files

file | AP_PhysX.cpp
file | AP_PhysX.h [code]
file | BaseActor.cpp
file | BaseActor.h [code]
file | BaseJoint.cpp
file | BaseJoint.h [code]
file | BasePhysXObject.cpp
file | BasePhysXObject.h [code]
file | Box.cpp
file | Box.h [code]
file | Capsule.cpp
file | Capsule.h [code]
file | Cloth.cpp
file | Cloth.h [code]
file | ClothDrawable.h [code]
file | CoreActorDesc.cpp
file | CoreActorDesc.h [code]
file | CylindricalJoint.h [code]
file | DistanceJoint.cpp
file | DistanceJoint.h [code]
file | ErrorReporter.h [code]
file | FixedJoint.h [code]
file | Fluid.cpp
file | Fluid.h [code]
file | FluidDrawable.h [code]
file | ForceField.cpp
file | ForceField.h [code]
file | Helper.cpp
file | Helper.h [code]
file | MaterialDesc.cpp
file | MaterialDesc.h [code]
file | MaterialManager.cpp
file | MaterialManager.h [code]
file | Particle.h [code]
file | PhysXObject.h [code]
file | PhysXScene.cpp
file | PhysXScene.h [code]
file | PhysXVreckoMessages.cpp
file | PhysXVreckoMessages.h [code]
file | Plane.cpp
file | Plane.h [code]
file | PointInPlaneJoint.h [code]
file | PointOnLineJoint.h [code]
file | precompiled.cpp
file | precompiled.h [code]
file | PrismaticJoint.h [code]
file | PulleyJoint.cpp
file | PulleyJoint.h [code]
file | RemoteDebugger.cpp
file | RemoteDebugger.h [code]
file | RevoluteJoint.cpp
file | RevoluteJoint.h [code]
file | Sphere.cpp
file | Sphere.h [code]
file | SphericalJoint.cpp
file | SphericalJoint.h [code]
file | UpdatablePhysXObject.cpp
file | UpdatablePhysXObject.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code Directory Reference

  • src
  • vreckoAP
  • PhysX
  • common code
common code Directory Reference

Files

file | MediaPath.cpp
file | MediaPath.h [code]
file | ParticleFactory.cpp
file | ParticleFactory.h [code]
file | Stream.cpp
file | Stream.h [code]
file | wavefront.cpp
file | wavefront.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/MediaPath.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
MediaPath.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <string.h>
#include <assert.h>
#include "MediaPath.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/MediaPath.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Functions
MediaPath.h File Reference

Go to the source code of this file.

Functions

char * | FindMediaFile (const char *fname, char *buff)
char * | GetTempFilePath (char *buff)

Function Documentation

char* FindMediaFile | ( | const char * | fname,
 |  | char * | buff
 | ) |  |
char* GetTempFilePath ( char * buff )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/ParticleFactory.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Functions
ParticleFactory.cpp File Reference
#include "precompiled.h"
#include "ParticleFactory.h"

Functions

void | CreateParticleAABB (NxParticleData &pd, unsigned maxParticlesTotal, unsigned maxParticles, bool append, NxBounds3 &aabb, const NxVec3 vel, float lifetime, float distance)
void | CreateParticleSphere (NxParticleData &pd, unsigned maxParticles, bool append, const NxVec3 &pos, const NxVec3 vel, float lifetime, float distance, unsigned sideNum)

Function Documentation

void CreateParticleAABB | ( | NxParticleData & | pd,
 |  | unsigned | maxParticlesTotal,
 |  | unsigned | maxParticles,
 |  | bool | append,
 |  | NxBounds3 & | aabb,
 |  | const NxVec3 | vel,
 |  | float | lifetime,
 |  | float | distance
 | ) |  |
void CreateParticleSphere | ( | NxParticleData & | pd,
 |  | unsigned | maxParticles,
 |  | bool | append,
 |  | const NxVec3 & | pos,
 |  | const NxVec3 | vel,
 |  | float | lifetime,
 |  | float | distance,
 |  | unsigned | sideNum
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/ParticleFactory.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Functions
ParticleFactory.h File Reference
#include "NxPhysics.h"

Go to the source code of this file.

Functions

void | CreateParticleAABB (NxParticleData &pd, unsigned maxParticlesTotal, unsigned maxParticles, bool append, NxBounds3 &aabb, const NxVec3 vel, float lifetime, float distance)
void | CreateParticleSphere (NxParticleData &pd, unsigned maxParticles, bool append, const NxVec3 &pos, const NxVec3 vel, float lifetime, float distance, unsigned sideNum)

Function Documentation

void CreateParticleAABB | ( | NxParticleData & | pd,
 |  | unsigned | maxParticlesTotal,
 |  | unsigned | maxParticles,
 |  | bool | append,
 |  | NxBounds3 & | aabb,
 |  | const NxVec3 | vel,
 |  | float | lifetime,
 |  | float | distance
 | ) |  |
void CreateParticleSphere | ( | NxParticleData & | pd,
 |  | unsigned | maxParticles,
 |  | bool | append,
 |  | const NxVec3 & | pos,
 |  | const NxVec3 | vel,
 |  | float | lifetime,
 |  | float | distance,
 |  | unsigned | sideNum
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Stream.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include "NxPhysics.h"
#include "Stream.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Classes
Stream.h File Reference
#include "NxStream.h"

Go to the source code of this file.

Classes

class | UserStream
class | MemoryWriteBuffer
class | MemoryReadBuffer
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Classes | Namespaces | Macros | Typedefs | Enumerations
wavefront.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <ctype.h>
#include "wavefront.h"
#include "MediaPath.h"
#include <vector>

Classes

class | WAVEFRONT::InPlaceParserInterface
class | WAVEFRONT::InPlaceParser
class | WAVEFRONT::GeometryVertex
class | WAVEFRONT::GeometryInterface
class | WAVEFRONT::OBJ
class | WAVEFRONT::BuildMesh

Namespaces

namespace WAVEFRONT

Macros

#define MAXARGS 512

Typedefs

typedef std::vector< int > | IntVector
typedef std::vector< float > | FloatVector

Enumerations

enum WAVEFRONT::SeparatorType { WAVEFRONT::ST_DATA, WAVEFRONT::ST_HARD, WAVEFRONT::ST_SOFT, WAVEFRONT::ST_EOS }

Macro Definition Documentation

#define MAXARGS 512

Typedef Documentation

typedef std::vector< float > FloatVector
typedef std::vector< int > IntVector
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Classes
wavefront.h File Reference

Go to the source code of this file.

Classes

class WavefrontObj
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/AP_PhysX.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Functions | Variables
AP_PhysX.cpp File Reference
#include "precompiled.h"
#include <string.h>
#include "AP_PhysX.h"

Functions

char ** | PhysX_getAbilityList (void)
Ability * | PhysX_getAbilityInstance (const char *cName)
std::string | PhysX_getPluginDescription (void)
std::string | PhysX_getAbilityDescription (std::string name)
void | PhysX_setAbilitiesParameters (void)

Variables

char * | _PhysX_plugin_name = { "PhysX" }
char * | _PhysX_ability_name []
char * | _PhysX_ability_description []
Ability * _new_ability

Function Documentation

std::string PhysX_getAbilityDescription ( std::string name )
Ability* PhysX_getAbilityInstance ( const char * cName )
char** PhysX_getAbilityList ( void )
std::string PhysX_getPluginDescription ( void )
void PhysX_setAbilitiesParameters ( void )

Variable Documentation

Ability* _new_ability
char* _PhysX_ability_description[]
Initial value:
= {
"PhysX scene",
"Visual Remote Debugger",
"Plane PhysX object",
"Box PhysX object",
"Sphere PhysX object",
"Capsule PhysX object",
"Revolute joint PhysX object",
"Fixed joint PhysX object",
"Spherical joint PhysX object",
"Prismatic joint PhysX object",
"Cylindrical joint PhysX object",
"Distance joint PhysX object",
"PointInPlane Joint PhysX Object",
"PointOnLine Joint PhysX Object",
"Pulley Joint PhysX Object"
"Fluid",
"Cloth",
""}
char* _PhysX_ability_name[]
Initial value:
= {
"PhysXScene",
"RemoteDebugger",
"Plane",
"Box",
"Sphere",
"Capsule",
"RevoluteJoint",
"FixedJoint",
"SphericalJoint",
"PrismaticJoint",
"CylindricalJoint",
"DistanceJoint",
"PointInPlaneJoint",
"PointOnLineJoint",
"PulleyJoint",
"Fluid",
"Cloth",
""}
char* _PhysX_plugin_name = { "PhysX" }
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/AP_PhysX.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Macros | Functions
AP_PhysX.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "RemoteDebugger.h"
#include "PhysXScene.h"
#include "Plane.h"
#include "Box.h"
#include "Sphere.h"
#include "Capsule.h"
#include "RevoluteJoint.h"
#include "FixedJoint.h"
#include "SphericalJoint.h"
#include "PrismaticJoint.h"
#include "CylindricalJoint.h"
#include "DistanceJoint.h"
#include "PointInPlaneJoint.h"
#include "PointOnLineJoint.h"
#include "PulleyJoint.h"
#include "Fluid.h"
#include "Cloth.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

char AP_EXPORT ** | PhysX_getAbilityList (void)
Ability AP_EXPORT * | PhysX_getAbilityInstance (const char *_name)
std::string AP_EXPORT | PhysX_getAbilityDescription (std::string name)
void AP_EXPORT | PhysX_setAbilitiesParameters (void)
std::string AP_EXPORT | PhysX_getPluginDescription (void)
void AP_EXPORT | PhysX_initializeAttributesDescription ()

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

std::string AP_EXPORT PhysX_getAbilityDescription ( std::string name )
Ability AP_EXPORT* PhysX_getAbilityInstance ( const char * _name )
char AP_EXPORT** PhysX_getAbilityList ( void )
std::string AP_EXPORT PhysX_getPluginDescription ( void )
void AP_EXPORT PhysX_initializeAttributesDescription ( )
void AP_EXPORT PhysX_setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseActor.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Functions
BaseActor.cpp File Reference
#include "precompiled.h"
#include "BaseActor.h"
#include "Helper.h"

Functions

METHOD_INPUT (ResetPosition, MessageBool, BaseActor)
METHOD_INPUT (MoveTo, MessageVec3, BaseActor)
METHOD_INPUT (RotateTo, MessageQuat, BaseActor)
METHOD_INPUT (DynamicActorOutputs, MessageBool, BaseActor)

Function Documentation

METHOD_INPUT | ( | ResetPosition | ,
 |  | MessageBool | ,
 |  | BaseActor |
 | ) |  |
METHOD_INPUT | ( | MoveTo | ,
 |  | MessageVec3 | ,
 |  | BaseActor |
 | ) |  |
METHOD_INPUT | ( | RotateTo | ,
 |  | MessageQuat | ,
 |  | BaseActor |
 | ) |  |
METHOD_INPUT | ( | DynamicActorOutputs | ,
 |  | MessageBool | ,
 |  | BaseActor |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseActor.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
BaseActor.h File Reference
#include "UpdatablePhysXObject.h"
#include "PhysXVreckoMessages.h"

Go to the source code of this file.

Classes

class PhysXPlugin::BaseActor

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseJoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
BaseJoint.cpp File Reference
#include "precompiled.h"
#include "BaseJoint.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
BaseJoint.h File Reference
#include "BasePhysXObject.h"
#include "PhysXVreckoMessages.h"

Go to the source code of this file.

Classes

class PhysXPlugin::BaseJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BasePhysXObject.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
BasePhysXObject.cpp File Reference
#include "precompiled.h"
#include "BasePhysXObject.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BasePhysXObject.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
BasePhysXObject.h File Reference
#include <vrecko/Scene.h>
#include <vrecko/Message.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Ability.h>
#include "NXU_helper.h"
#include "NxCooking.h"
#include "PhysXObject.h"
#include "PhysXVreckoMessages.h"
#include <string>

Go to the source code of this file.

Classes

class PhysXPlugin::BasePhysXObject

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Box.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Box.cpp File Reference
#include "precompiled.h"
#include "Box.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Box.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Box.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseActor.h"

Go to the source code of this file.

Classes

class PhysXPlugin::Box

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Capsule.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Capsule.cpp File Reference
#include "precompiled.h"
#include "Capsule.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Capsule.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Capsule.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseActor.h"

Go to the source code of this file.

Classes

class PhysXPlugin::Capsule

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Cloth.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Cloth.cpp File Reference
#include "precompiled.h"
#include "Cloth.h"
#include "common code/wavefront.h"
#include "common code/Stream.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Cloth.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Cloth.h File Reference
#include "UpdatablePhysXObject.h"
#include "ClothDrawable.h"
#include "CoreActorDesc.h"
#include <vector>

Go to the source code of this file.

Classes

class PhysXPlugin::Cloth

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ClothDrawable.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
ClothDrawable.h File Reference
#include <gl/glut.h>
#include <osg/Drawable>
#include <osg/Vec3>
#include "NxPhysics.h"
#include "Cloth.h"
#include "Helper.h"
#include <cloth/NxCloth.h>

Go to the source code of this file.

Classes

class PhysXPlugin::ClothDrawable

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CoreActorDesc.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
CoreActorDesc.cpp File Reference
#include "precompiled.h"
#include "CoreActorDesc.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CoreActorDesc.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
CoreActorDesc.h File Reference
#include "PhysXObject.h"
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class PhysXPlugin::CoreActorDesc

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CylindricalJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
CylindricalJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::CylindricalJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/DistanceJoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
DistanceJoint.cpp File Reference
#include "precompiled.h"
#include "DistanceJoint.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/DistanceJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
DistanceJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::DistanceJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ErrorReporter.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
ErrorReporter.h File Reference

Go to the source code of this file.

Classes

class PhysXPlugin::ErrorReporter

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FixedJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
FixedJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::FixedJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Fluid.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Fluid.cpp File Reference
#include "precompiled.h"
#include "Particle.h"
#include "Fluid.h"
#include "FluidDrawable.h"
#include "common code/ParticleFactory.h"
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Fluid.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Fluid.h File Reference
#include <fluids/NxFluid.h>
#include <fluids/NxFluidDesc.h>
#include "FluidDrawable.h"
#include "UpdatablePhysXObject.h"

Go to the source code of this file.

Classes

class PhysXPlugin::Fluid

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FluidDrawable.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
FluidDrawable.h File Reference
#include <gl/glut.h>
#include <osg/Drawable>
#include <osg/Vec3>
#include "NxPhysics.h"
#include "Fluid.h"
#include "Helper.h"
#include <fluids/NxParticleData.h>

Go to the source code of this file.

Classes

class PhysXPlugin::FluidDrawable

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ForceField.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
ForceField.cpp File Reference
#include <vrecko/Scene.h>
#include <vrecko/Message.h>
#include <vrecko/EventDispatcher.h>
#include <vreckoDB/ReaderWriter.h>
#include "NXU_helper.h"
#include "NxCooking.h"
#include "ForceField.h"
#include <sstream>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ForceField.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
ForceField.h File Reference
#include "BasePhysXObject.h"

Go to the source code of this file.

Classes

class PhysXPlugin::ForceField

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Helper.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Functions
Helper.cpp File Reference
#include "precompiled.h"

Functions

NxVec3 | ToNxVec3 (osg::Vec3 vec)
osg::Vec3 | ToosgVec3 (NxVec3 vec)
const char * | NXUFTtoa (NXU::NXU_FileType fileType)
osg::Quat | ToosgQuat (NxQuat quat)
NxQuat | ToNxQuat (osg::Quat quat)

Function Documentation

const char* NXUFTtoa ( NXU::NXU_FileType fileType )
NxQuat ToNxQuat ( osg::Quat quat )
NxVec3 ToNxVec3 ( osg::Vec3 vec )
osg::Quat ToosgQuat ( NxQuat quat )
osg::Vec3 ToosgVec3 ( NxVec3 vec )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Helper.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Functions
Helper.h File Reference
#include <osg/Vec3>
#include <osg/Quat>
#include "NXU_helper.h"

Go to the source code of this file.

Functions

NxVec3 | ToNxVec3 (osg::Vec3 vec)
osg::Vec3 | ToosgVec3 (NxVec3 vec)
NxQuat | ToNxQuat (osg::Quat)
osg::Quat | ToosgQuat (NxQuat quat)
const char * | NXUFTtoa (NXU::NXU_FileType fileType)

Function Documentation

const char* NXUFTtoa ( NXU::NXU_FileType fileType )
NxQuat ToNxQuat ( osg::Quat )
NxVec3 ToNxVec3 ( osg::Vec3 vec )
osg::Quat ToosgQuat ( NxQuat quat )
osg::Vec3 ToosgVec3 ( NxVec3 vec )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialDesc.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
MaterialDesc.cpp File Reference
#include "precompiled.h"
#include "MaterialDesc.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialDesc.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
MaterialDesc.h File Reference
#include "PhysXObject.h"
#include <vrecko/World.h>
#include <string>

Go to the source code of this file.

Classes

class vrecko::MaterialDesc

Namespaces

namespace vrecko
Second level of space paritioning queries - detailed searching inside object.
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialManager.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
MaterialManager.cpp File Reference
#include "precompiled.h"
#include "MaterialManager.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialManager.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
MaterialManager.h File Reference
#include "MaterialDesc.h"

Go to the source code of this file.

Classes

class PhysXPlugin::MaterialManager

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Particle.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Particle.h File Reference
#include <NxVec3.h>

Go to the source code of this file.

Classes

struct PhysXPlugin::Particle

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXObject.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PhysXObject.h File Reference
#include <osg/ShadeModel>
#include <osg/CullFace>
#include <osg/ShapeDrawable>
#include <osg/Geode>
#include <NxPhysics.h>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>

Go to the source code of this file.

Classes

class PhysXPlugin::PhysXObject

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXScene.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Functions
PhysXScene.cpp File Reference
#include "precompiled.h"
#include "PhysXScene.h"

Functions

METHOD_REQUEST_INPUT (RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool, PhysXScene)
METHOD_REQUEST_INPUT (PhysXScene, MessageVoid, MessageNxScenePtr, PhysXScene)
METHOD_REQUEST_INPUT (RegisterJointedActor, MessageNxActorWithName, MessageBool, PhysXScene)
METHOD_REQUEST_INPUT (GetJointedActor, MessageString, MessageNxActorPtr, PhysXScene)
METHOD_REQUEST_INPUT (Material, MessageString, MessageNxMaterialIndex, PhysXScene)

Function Documentation

METHOD_REQUEST_INPUT | ( | RegisterPhysXObject | ,
 |  | MessageUpdatablePhysXObjectPtr | ,
 |  | MessageBool | ,
 |  | PhysXScene |
 | ) |  |
METHOD_REQUEST_INPUT | ( | PhysXScene | ,
 |  | MessageVoid | ,
 |  | MessageNxScenePtr | ,
 |  | PhysXScene |
 | ) |  |
METHOD_REQUEST_INPUT | ( | RegisterJointedActor | ,
 |  | MessageNxActorWithName | ,
 |  | MessageBool | ,
 |  | PhysXScene |
 | ) |  |
METHOD_REQUEST_INPUT | ( | GetJointedActor | ,
 |  | MessageString | ,
 |  | MessageNxActorPtr | ,
 |  | PhysXScene |
 | ) |  |
METHOD_REQUEST_INPUT | ( | Material | ,
 |  | MessageString | ,
 |  | MessageNxMaterialIndex | ,
 |  | PhysXScene |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXScene.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PhysXScene.h File Reference
#include <Windows.h>
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include <vector>
#include <NxScene.h>
#include "PhysXObject.h"
#include "UpdatablePhysXObject.h"
#include "MaterialManager.h"
#include "PhysXVreckoMessages.h"

Go to the source code of this file.

Classes

class PhysXPlugin::PhysXScene

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXVreckoMessages.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PhysXVreckoMessages.cpp File Reference
#include "precompiled.h"
#include "PhysXVreckoMessages.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXVreckoMessages.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PhysXVreckoMessages.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/Message.h>
#include <NxScene.h>
#include <NxActor.h>
#include <NxMaterial.h>

Go to the source code of this file.

Classes

class PhysXPlugin::MessageNxActorWithName

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Plane.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Plane.cpp File Reference
#include "precompiled.h"
#include "Plane.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Plane.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Plane.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseActor.h"

Go to the source code of this file.

Classes

class PhysXPlugin::Plane

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointInPlaneJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PointInPlaneJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::PointInPlaneJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointOnLineJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PointOnLineJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::PointOnLineJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
precompiled.h File Reference
#include <string.h>
#include <sstream>
#include <vrecko/Scene.h>
#include <vrecko/Message.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/Matrix>
#include <osg/MatrixTransform>
#include "NXU_helper.h"
#include "NxCooking.h"
#include <xercesc/dom/DOMNode.hpp>
#include <xercesc/util/XMLString.hpp>
#include "Helper.h"

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PrismaticJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PrismaticJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::PrismaticJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PulleyJoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PulleyJoint.cpp File Reference
#include "precompiled.h"
#include "PulleyJoint.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PulleyJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
PulleyJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::PulleyJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RemoteDebugger.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
RemoteDebugger.cpp File Reference
#include "precompiled.h"
#include "RemoteDebugger.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RemoteDebugger.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
RemoteDebugger.h File Reference
#include "PhysXObject.h"

Go to the source code of this file.

Classes

class PhysXPlugin::RemoteDebugger

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RevoluteJoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
RevoluteJoint.cpp File Reference
#include "precompiled.h"
#include "RevoluteJoint.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RevoluteJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
RevoluteJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include <sstream>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::RevoluteJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Sphere.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Sphere.cpp File Reference
#include "precompiled.h"
#include "Sphere.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Sphere.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
Sphere.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include "BaseActor.h"

Go to the source code of this file.

Classes

class PhysXPlugin::Sphere

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/SphericalJoint.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
SphericalJoint.cpp File Reference
#include "precompiled.h"
#include "SphericalJoint.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/SphericalJoint.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
SphericalJoint.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec3>
#include <sstream>
#include "BaseJoint.h"

Go to the source code of this file.

Classes

class PhysXPlugin::SphericalJoint

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/UpdatablePhysXObject.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
UpdatablePhysXObject.cpp File Reference
#include "precompiled.h"
#include <typeinfo>
#include "UpdatablePhysXObject.h"
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/UpdatablePhysXObject.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Classes | Namespaces
UpdatablePhysXObject.h File Reference
#include "BasePhysXObject.h"

Go to the source code of this file.

Classes

class PhysXPlugin::UpdatablePhysXObject

Namespaces

namespace PhysXPlugin
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation Directory Reference

  • src
  • vreckoAP
  • ShootingSimulation
ShootingSimulation Directory Reference

Files

file | AP_ShootingSimulation.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | ShootingSimulation.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/AP_ShootingSimulation.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ShootingSimulation
Functions | Variables
AP_ShootingSimulation.cpp File Reference
#include <vreckoAP/ShootingSimulation/AP_ShootingSimulation.h>
#include <vreckoAP/ShootingSimulation/ShootingSimulation.h>

Functions

const char * | getPluginDescription ()
const char ** | getAbilityList ()
const char * | getAbilityDescription (const char *strName)
Ability * | getAbilityInstance (const char *pchName)
void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

const char* getAbilityDescription ( const char * strName )
Ability* getAbilityInstance ( const char * pchName )
const char** getAbilityList ( void )
const char* getPluginDescription ( void )
void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
=
{
"3D shooting simulation game.",
""
}
const char* g_pAbilityName[]
Initial value:
=
{
"ShootingSimulation",
NULL
}
const char* g_pPluginName
Initial value:
=
{
"ShootingSimulation"
}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ShootingSimulation
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ShootingSimulation
precompiled.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/Message.h>
#include <vrecko/PluginManager.h>
#include <vrecko/ReaderWriter.h>
#include "../EditorController/ControllableAbility.h"
#include "../ObjectUtils/ObjectInfo.h"
#include <helpers/DynamicArray.h>
#include <helpers/HelperMacros.h>
#include <helpers/StringHelpers.h>
#include <helpers/XercesXMLUtils.h>
#include <iostream>
#include <sstream>
#include <vector>
#include <math.h>
#include <osg/Vec3>
#include <osg/Quat>
#include <osg/io_utils>
#include <osg/Geometry>
#include <osg/Geode>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/CullFace>
#include <osg/LightModel>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/parsers/XercesDOMParser.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/sax/HandlerBase.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/util/PlatformUtils.hpp>
#include <osg/BlendColor>
#include <osg/BlendFunc>
#include <osg/Group>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/ShootingSimulation.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • ShootingSimulation
Classes | Functions
ShootingSimulation.cpp File Reference
#include <vreckoAP/ShootingSimulation/ShootingSimulation.h>
#include <osgDB/ReadFile>
#include <string>
#include <time.h>

Classes

struct | MyReadCallback
class | EOLineSegmentIntersector

Functions

METHOD_INPUT (Start, MessageBool, ShootingSimulation)
METHOD_INPUT (Mouse, MessageVec2, ShootingSimulation)
METHOD_INPUT (Trigger, MessageBool, ShootingSimulation)
METHOD_INPUT (Sensor_Transformation, MessageSensorTransformation, ShootingSimulation)

Function Documentation

METHOD_INPUT | ( | Start | ,
 |  | MessageBool | ,
 |  | ShootingSimulation |
 | ) |  |
METHOD_INPUT | ( | Mouse | ,
 |  | MessageVec2 | ,
 |  | ShootingSimulation |
 | ) |  |
METHOD_INPUT | ( | Trigger | ,
 |  | MessageBool | ,
 |  | ShootingSimulation |
 | ) |  |
METHOD_INPUT | ( | Sensor_Transformation | ,
 |  | MessageSensorTransformation | ,
 |  | ShootingSimulation |
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning Directory Reference

  • src
  • vreckoAP
  • SpacePartitioning
SpacePartitioning Directory Reference

Files

file | AP_SpacePartitioning.cpp
file | GeometryLoaderBase.cpp
file | NoPartitioning_Scene.cpp
file | PointShell_Object_Data.cpp
file | PointShell_Object_Data_Geometry.cpp
file | PointShell_Object_Data_Geometry_Analyser.cpp
file | PointShell_Object_Data_LOD_Builder.cpp
file | PointShellVSVoxel_Object.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | SNCH_Object.cpp
file | SNCH_Object_Data.cpp
file | SP_Object_Data_Base.cpp
file | SphereBVH_Object.cpp
file | SphereBVH_Object_Data.cpp
file | SphereBVH_Scene.cpp
file | triangleCube.cpp
file | VoxelGrid_Object_Data.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/AP_SpacePartitioning.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Functions | Variables
AP_SpacePartitioning.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/AP_SpacePartitioning.h>
#include <vreckoAP/SpacePartitioning/SphereBVH_Scene.h>
#include <vreckoAP/SpacePartitioning/SphereBVH_Object.h>
#include <vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h>
#include <vreckoAP/SpacePartitioning/SNCH_Object.h>
#include <vreckoAP/SpacePartitioning/SNCH_Object_Data.h>
#include <vreckoAP/SpacePartitioning/NoPartitioning_Scene.h>
#include <vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data.h>
#include <vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"SpacePartitioning"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"Space-sorting of the scene with sphere hierarchy.",
"Space-sorting of the object with sphere hierarchy.",
"Container for bounding sphere hierarchy for the object.",
"Space-sorting of the object with SNC hierarchy.",
"Container for bounding SNC hierarchy for the object.",
"Simple implementation of SP_ScenePartitioning for scene.",
"Container for the voxel grid structure.",
"Container for the point shell data structure.",
"PointsShell vs. VoxelGrid collision detection.",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"SphereBVH_Scene",
"SphereBVH_Object",
"SphereBVH_Object_Data",
"SNCH_Object",
"SNCH_Object_Data",
"NoPartitioning_Scene",
"VoxelGrid_Object_Data",
"PointShell_Object_Data",
"PointShellVSVoxel_Object",
NULL
}
const char* g_pPluginName = {"SpacePartitioning"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/GeometryLoaderBase.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros
GeometryLoaderBase.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/GeometryLoaderBase.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Group>
#include <osg/PrimitiveSet>
#include <osg/MatrixTransform>
#include <vrecko/Logger.h>
#include <float.h>

Namespaces

namespace APSpacePartitioning

Macros

#define | FACE(x) ((FaceBase*)getFace(x))
#define | VERTEX(x) ((VertexBase*)getVertex(x))

Macro Definition Documentation

#define FACE ( x ) ((FaceBase*)getFace(x))
#define VERTEX ( x ) ((VertexBase*)getVertex(x))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/NoPartitioning_Scene.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces
NoPartitioning_Scene.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/NoPartitioning_Scene.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data.h>
#include <vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h>
#include <vrecko/Scene.h>
#include <vrecko/SP_ObjectInterface.h>
#include <queue>

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros
PointShell_Object_Data.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h>
#include "String"
#include <vrecko/Scene.h>
#include <vrecko/PersistentCache.h>
#include <osgDB/ReadFile>
#include <osg/Geometry>
#include <osg/math>
#include <cfloat>
#include <time.h>
#include <string>
#include <deque>
#include <queue>

Namespaces

namespace APSpacePartitioning

Macros

#define CURRENT_CACHED_DATA_VERSION 1

Macro Definition Documentation

#define CURRENT_CACHED_DATA_VERSION 1
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros
PointShell_Object_Data_Geometry.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h>

Namespaces

namespace APSpacePartitioning

Macros

#define UNDEF INT_MAX

Macro Definition Documentation

#define UNDEF INT_MAX
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros
PointShell_Object_Data_Geometry_Analyser.cpp File Reference
#include "precompiled.h"
#include <cmath>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h>

Namespaces

namespace APSpacePartitioning

Macros

#define UNDEF INT_MAX

Macro Definition Documentation

#define UNDEF INT_MAX
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros
PointShell_Object_Data_LOD_Builder.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h>
#include <deque>
#include <math.h>
#include <iostream>
#include <list>
#include <queue>
#include <sstream>

Namespaces

namespace APSpacePartitioning

Macros

#define UNDEF INT_MAX

Macro Definition Documentation

#define UNDEF INT_MAX
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Macros
PointShellVSVoxel_Object.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h>
#include <vreckoAP/SpacePartitioning/PointShell_Object_Data.h>
#include <vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h>
#include <vrecko/Scene.h>
#include "base/MTMatrixTransform.h"
#include <helpers/DynamicTree.h>
#include <queue>
#include <windows.h>
#include <iostream>
#include <string>
#include <time.h>
#include <boost/lexical_cast.hpp>

Macros

#define NORMAL_EPSILON 0.0001

Macro Definition Documentation

#define NORMAL_EPSILON 0.0001
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
precompiled.h File Reference
#include <float.h>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Group>
#include <osg/Node>
#include <osg/PrimitiveSet>
#include <osg/Vec3>
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <vrecko/ReaderWriter.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SNCH_Object.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Classes | Macros
SNCH_Object.cpp File Reference
#include "precompiled.h"
#include <helpers/DynamicArray.h>
#include <helpers/Heaps.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include "base/MTMatrixTransform.h"
#include <vreckoAP/SpacePartitioning/SNCH_Object.h>
#include <vrecko/EnvironmentObject.h>
#include <math.h>

Classes

struct SNCH_THREAD_START_INFO

Macros

#define | _USE_MATH_DEFINES
#define | FACE(obj, x) ((SNCH_Object_Data::FaceSNCH*)obj->getFace(x))
#define | VERTEX(obj, x) ((SNCH_Object_Data::VertexSNCH*)obj->getVertex(x))
#define | VERTEX_REPRESENTANT(obj, x) (VERTEX(obj, VERTEX(obj, (x))->dwRepresentant))
#define | NODE(x) ((SNCH_Object_Data::STNodeSNCH*)(x))
#define | SMALL_NUM 0.00000001f
#define | LOG_START_TIMING(blockName) {}
#define | LOG_STOP_TIMING(blockName) {}
#define | LOG_WRITECOUNTER(name, value) {}
#define | USE_OUR_ALGORITHM
#define | PRECISE_DISTANCE_CALC
#define | LOCALSEARCH_USE_CACHE
#define | LOCALSEARCH_CACHE_USE_HASH
#define | USE_DISTANCE_LIMIT_FOR_PAIRS
#define | LOCAL_SEARCH_INSIDE_GLOBAL
#define | USE_MORE_SAFE_DEGEN_TEST
#define | ASSURE_FACES_SIZE(minSize)
#define | SURFACE_BREAK_TEST(r, dataX, p, m, n, instruction)
#define | LS_EDGE_NO_EDGE -1
#define | LS_EDGE_ALL_EDGES -2
#define | TEST_PAIR_FLAGS_INTERSECTIONS_ONLY 0x00000001
#define | CALC_PAIR_FLAGS (bAct_IntersectionsOnly ? TEST_PAIR_FLAGS_INTERSECTIONS_ONLY : 0)
#define | PAIR_EXISTS (pairs.dwNum)
#define | INSERT_PAIR(x, y, tempVec, tempFloat, tempL, tempR, tempC)
#define | RETRIEVE_PAIR { pairs.dwNum--; }
#define | ACT_PAIR (pairs[pairs.dwNum])
#define | DELETE_ACT_PAIR
#define | ASSURE_TEMPD { if (FLT_MAX == tempD) { tempD = (center2 - center1).length(); } }
#define | ASSURE_RADIITOGETHER { if (FLT_MAX == radiiTogether) { radiiTogether = pSTNode1->radius * rad1mul + pSTNode2->radius * rad2mul; } }
#define | ASSURE_MINSPHEREDIST { if (FLT_MAX == minSphereDist) { ASSURE_TEMPD; ASSURE_RADIITOGETHER; minSphereDist = tempD - radiiTogether; } }
#define | TPPS_F_VALID 0x01
#define | TPPS_F_PROJ_BACKWARDS 0x02
#define | TPPS_F_PROJ_ZERO 0x04
#define | HALF_LINE_APPROXIMATION_NUMBER 100000.0f
#define | p0Normal points0->planeNormal
#define | p1Normal points1->planeNormal
#define | IF_DIST__TEST_AND_SAVE(dist2, newCloseFeature0, newCloseFeature1, debugText)
#define | IF_DIST_END
#define | TMP_VE_PROJ_RES_0_EXCEEDED 0x1
#define | TMP_VE_PROJ_RES_1_EXCEEDED 0x2
#define | CALC_D(m, n, o, p) (((m).x() - (n).x()) * ((o).x() - (p).x()) + ((m).y() - (n).y()) * ((o).y() - (p).y()) + ((m).z() - (n).z()) * ((o).z() - (p).z()))
#define | XX1 (actTri->v[i % 3].pos)
#define | XX2 (actTri->v[(i + 1) % 3].pos)
#define | XX3 (otherTri->v[j % 3].pos)
#define | XX4 (otherTri->v[(j + 1) % 3].pos)

Macro Definition Documentation

#define _USE_MATH_DEFINES
#define ACT_PAIR (pairs[pairs.dwNum])
#define ASSURE_FACES_SIZE ( minSize )
Value:
{ \
if ((minSize) > (int)faces.dwNum) { \
faces.PrepareNext((minSize) - (int)faces.dwNum); \
faces.dwNum = (minSize); \
} \
}
#define ASSURE_MINSPHEREDIST { if (FLT_MAX == minSphereDist) { ASSURE_TEMPD; ASSURE_RADIITOGETHER; minSphereDist = tempD - radiiTogether; } }
#define ASSURE_RADIITOGETHER { if (FLT_MAX == radiiTogether) { radiiTogether = pSTNode1->radius * rad1mul + pSTNode2->radius * rad2mul; } }
#define ASSURE_TEMPD { if (FLT_MAX == tempD) { tempD = (center2 - center1).length(); } }
#define CALC_D | ( | m,
 |  | n,
 |  | o,
 |  | p
 | ) | (((m).x() - (n).x()) * ((o).x() - (p).x()) + ((m).y() - (n).y()) * ((o).y() - (p).y()) + ((m).z() - (n).z()) * ((o).z() - (p).z()))
#define CALC_PAIR_FLAGS (bAct_IntersectionsOnly ? TEST_PAIR_FLAGS_INTERSECTIONS_ONLY : 0)
#define DELETE_ACT_PAIR
#define FACE | ( | obj,
 |  | x
 | ) | ((SNCH_Object_Data::FaceSNCH*)obj->getFace(x))
#define HALF_LINE_APPROXIMATION_NUMBER 100000.0f
#define IF_DIST__TEST_AND_SAVE | ( | dist2,
 |  | newCloseFeature0,
 |  | newCloseFeature1,
 |  | debugText
 | ) |
Value:
{ \
if ((dist2) < minDist2) { \
minDist2 = (dist2); \
*closeFeature0 = (newCloseFeature0); \
*closeFeature1 = (newCloseFeature1); \
if (outPoint1Trans) {
#define IF_DIST_END
Value:
} \
} \
}
#define INSERT_PAIR | ( | x,
 |  | y,
 |  | tempVec,
 |  | tempFloat,
 |  | tempL,
 |  | tempR,
 |  | tempC
 | ) |
Value:
{ \
pairs.PrepareNext(1); \
pairs[pairs.dwNum].dwFlags = CALC_PAIR_FLAGS; \
pairs[pairs.dwNum].node1 = x; \
pairs[pairs.dwNum].node2 = y; \
pairs.dwNum++; \
}
#define LOCAL_SEARCH_INSIDE_GLOBAL
#define LOCALSEARCH_CACHE_USE_HASH
#define LOCALSEARCH_USE_CACHE
#define LOG_START_TIMING ( blockName ) {}
#define LOG_STOP_TIMING ( blockName ) {}
#define LOG_WRITECOUNTER | ( | name,
 |  | value
 | ) | {}
#define LS_EDGE_ALL_EDGES -2
#define LS_EDGE_NO_EDGE -1
#define NODE ( x ) ((SNCH_Object_Data::STNodeSNCH*)(x))
#define p0Normal points0->planeNormal
#define p1Normal points1->planeNormal
#define PAIR_EXISTS (pairs.dwNum)
#define PRECISE_DISTANCE_CALC
#define RETRIEVE_PAIR { pairs.dwNum--; }
#define SMALL_NUM 0.00000001f
#define SURFACE_BREAK_TEST | ( | r,
 |  | dataX,
 |  | p,
 |  | m,
 |  | n,
 |  | instruction
 | ) |
#define TEST_PAIR_FLAGS_INTERSECTIONS_ONLY 0x00000001
#define TMP_VE_PROJ_RES_0_EXCEEDED 0x1
#define TMP_VE_PROJ_RES_1_EXCEEDED 0x2
#define TPPS_F_PROJ_BACKWARDS 0x02
#define TPPS_F_PROJ_ZERO 0x04
#define TPPS_F_VALID 0x01
#define USE_DISTANCE_LIMIT_FOR_PAIRS
#define USE_MORE_SAFE_DEGEN_TEST
#define USE_OUR_ALGORITHM
#define VERTEX | ( | obj,
 |  | x
 | ) | ((SNCH_Object_Data::VertexSNCH*)obj->getVertex(x))
#define VERTEX_REPRESENTANT | ( | obj,
 |  | x
 | ) | (VERTEX(obj, VERTEX(obj, (x))->dwRepresentant))
#define XX1 (actTri->v[i % 3].pos)
#define XX2 (actTri->v[(i + 1) % 3].pos)
#define XX3 (otherTri->v[j % 3].pos)
#define XX4 (otherTri->v[(j + 1) % 3].pos)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SNCH_Object_Data.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros | Functions
SNCH_Object_Data.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/SNCH_Object_Data.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <osg/Group>
#include <osg/PrimitiveSet>
#include <float.h>

Namespaces

namespace APSpacePartitioning

Macros

#define | FACE(x) ((FaceSNCH*)getFace(x))
#define | VERTEX(x) ((VertexSNCH*)getVertex(x))
#define | VERTEX_REPRESENTANT(x) (VERTEX(VERTEX(x)->dwRepresentant))
#define | NODE(x) ((STNodeSNCH*)(x))
#define | SMALL_NUM 0.00000001f
#define | SURFACE_SMALL_NUM 0.00000001f
#define | SNCH_GROUPS_METHOD 3
#define | GROUPS_MAX_NORMAL_DIFFERENCE (PI * 0.0f / 180.0f)
#define | REVERSE_VERTEX_INDEX(vi, vertSize) (((unsigned long)verts[vi] - (unsigned long)vertices) / vertSize)

Functions

int __cdecl APSpacePartitioning::vertPtrSort (const SNCH_Object_Data::VertexSNCH **elem1, const SNCH_Object_Data::VertexSNCH **elem2)

Macro Definition Documentation

#define FACE ( x ) ((FaceSNCH*)getFace(x))
#define GROUPS_MAX_NORMAL_DIFFERENCE (PI * 0.0f / 180.0f)
#define NODE ( x ) ((STNodeSNCH*)(x))
#define REVERSE_VERTEX_INDEX | ( | vi,
 |  | vertSize
 | ) | (((unsigned long)verts[vi] - (unsigned long)vertices) / vertSize)
#define SMALL_NUM 0.00000001f
#define SNCH_GROUPS_METHOD 3
#define SURFACE_SMALL_NUM 0.00000001f
#define VERTEX ( x ) ((VertexSNCH*)getVertex(x))
#define VERTEX_REPRESENTANT ( x ) (VERTEX(VERTEX(x)->dwRepresentant))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SP_Object_Data_Base.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Functions
SP_Object_Data_Base.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/SP_Object_Data_Base.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/Logger.h>
#include <helpers/StringHelpers.h>
#include "base/SystemInfo.h"

Namespaces

namespace APSpacePartitioning

Functions

DWORD WINAPI APSpacePartitioning::HierarchyThreadProc (SP_Object_Data_Base *lpParameter)
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Object.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
SphereBVH_Object.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/SphereBVH_Object.h>
#include <vrecko/Scene.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces | Macros | Functions
SphereBVH_Object_Data.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>
#include <osg/Group>
#include <vrecko/Logger.h>
#include <float.h>

Namespaces

namespace APSpacePartitioning

Macros

#define | FACE(x) ((FaceBase*)getFace(x))
#define | VERTEX(x) ((VertexBase*)getVertex(x))
#define | NODE(x) ((STNodeSphere*)(x))
#define | PRECISE_SPHERES
#define | SBVH_PERSISTENT_CACHE_BASE_VERSION 1

Functions

int | APSpacePartitioning::compareX (const void *elem1, const void *elem2)
int | APSpacePartitioning::compareY (const void *elem1, const void *elem2)
int | APSpacePartitioning::compareZ (const void *elem1, const void *elem2)

Macro Definition Documentation

#define FACE ( x ) ((FaceBase*)getFace(x))
#define NODE ( x ) ((STNodeSphere*)(x))
#define PRECISE_SPHERES
#define SBVH_PERSISTENT_CACHE_BASE_VERSION 1
#define VERTEX ( x ) ((VertexBase*)getVertex(x))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/SphereBVH_Scene.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Namespaces
SphereBVH_Scene.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/SphereBVH_Scene.h>
#include <vrecko/Scene.h>

Namespaces

namespace APSpacePartitioning
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/triangleCube.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Classes | Macros | Functions
triangleCube.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/triangleCube.h>
#include <math.h>

Classes

struct | Point3f
struct | Triangle3v

Macros

#define | EPS 10e-5
#define | SIGN3(A)
#define | CROSS(A, B, C)
#define | SUB(A, B, C)
#define | LERP(A, B, C) ((B)+(A)*((C)-(B)))
#define | MIN3(a, b, c) ((((a)<(b))&&((a)<(c))) ? (a) : (((b)<(c)) ? (b) : (c)))
#define | MAX3(a, b, c) ((((a)>(b))&&((a)>(c))) ? (a) : (((b)>(c)) ? (b) : (c)))
#define | INSIDE 0
#define | OUTSIDE 1

Functions

long | face_plane (Point3 p)
long | bevel_2d (Point3 p)
long | bevel_3d (Point3 p)
long | check_point (Point3 p1, Point3 p2, float alpha, long mask)
long | check_line (Point3 p1, Point3 p2, long outcode_diff)
long | point_triangle_intersection (Point3 p, Triangle3 t)
long | t_c_intersection (Triangle3 t)

Macro Definition Documentation

#define CROSS | ( | A,
 |  | B,
 |  | C
 | ) |
Value:
{ \
(C).x = (A).y * (B).z - (A).z * (B).y; \
(C).y = -(A).x * (B).z + (A).z * (B).x; \
(C).z = (A).x * (B).y - (A).y * (B).x; \
}
#define EPS 10e-5
#define INSIDE 0
#define LERP | ( | A,
 |  | B,
 |  | C
 | ) | ((B)+(A)*((C)-(B)))
#define MAX3 | ( | a,
 |  | b,
 |  | c
 | ) | ((((a)>(b))&&((a)>(c))) ? (a) : (((b)>(c)) ? (b) : (c)))
#define MIN3 | ( | a,
 |  | b,
 |  | c
 | ) | ((((a)<(b))&&((a)<(c))) ? (a) : (((b)<(c)) ? (b) : (c)))
#define OUTSIDE 1
#define SIGN3 ( A )
Value:
(((A).x < EPS) ? 4 : 0 | ((A).x > -EPS) ? 32 : 0 | \
((A).y < EPS) ? 2 : 0 | ((A).y > -EPS) ? 16 : 0 | \
((A).z < EPS) ? 1 : 0 | ((A).z > -EPS) ? 8 : 0)
#define SUB | ( | A,
 |  | B,
 |  | C
 | ) |
Value:
{ \
(C).x = (A).x - (B).x; \
(C).y = (A).y - (B).y; \
(C).z = (A).z - (B).z; \
}

Function Documentation

long bevel_2d ( Point3 p )
long bevel_3d ( Point3 p )
long check_line | ( | Point3 | p1,
 |  | Point3 | p2,
 |  | long | outcode_diff
 | ) |  |
long check_point | ( | Point3 | p1,
 |  | Point3 | p2,
 |  | float | alpha,
 |  | long | mask
 | ) |  |
long face_plane ( Point3 p )
long point_triangle_intersection | ( | Point3 | p,
 |  | Triangle3 | t
 | ) |  |
long t_c_intersection ( Triangle3 t )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
Classes | Namespaces | Macros
VoxelGrid_Object_Data.cpp File Reference
#include "precompiled.h"
#include <vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h>
#include <vreckoAP/SpacePartitioning/GeometryLoaderBase.h>
#include <vrecko/Scene.h>
#include <vrecko/ReaderWriter.h>
#include <osg/Geometry>
#include <osgDB/ReadFile>
#include <osgDB/WriteFile>
#include <vreckoAP/SpacePartitioning/triangleCube.h>

Classes

struct APSpacePartitioning::VGReadCallback

Namespaces

namespace APSpacePartitioning

Macros

#define | FACE(x) ((FaceBase*)getFace(x))
#define | VERTEX(x) ((VertexBase*)getVertex(x))
#define | CURRENT_CACHED_DATA_VERSION 3
#define | SHOW_PROGRESS(pass, numPasses)

Macro Definition Documentation

#define CURRENT_CACHED_DATA_VERSION 3
#define FACE ( x ) ((FaceBase*)getFace(x))
#define SHOW_PROGRESS | ( | pass,
 |  | numPasses
 | ) |
Value:
{ \
curTickD = osg::Timer::instance()->tick(); \
if (osg::Timer::instance()->delta_s(lastTickD, curTickD) > 1.0) { \
float remS = osg::Timer::instance()->delta_s(startTimeD, curTickD); \
float fpass = (float)pass; \
float fnumPasses = (float)numPasses; \
float timeSpend = osg::Timer::instance()->delta_s(startTimeD, curTickD); \
float remIterations = fnumPasses - fpass; \
float timeperIteration = fpass / timeSpend; \
float remTime = remIterations / timeperIteration ; \
float remTimeH = (int)remTime / 3600; \
float remTimeM = ((int)remTime % 3600) / 60; \
float remTimeS = ((int)remTime % 60 );\
logger.debugLog("Done: %d/%d (%.1f%%) est. rem. time: %.0f h %.0f m %.0f s",pass, numPasses, ((100.0f*fpass)/fnumPasses) ,remTimeH, remTimeM, remTimeS); \
lastTickD = curTickD; \
} \
}
#define VERTEX ( x ) ((VertexBase*)getVertex(x))
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/TextOutput Directory Reference

  • src
  • vreckoAP
  • TextOutput
TextOutput Directory Reference

Files

file | AP_TextOutput.cpp
file | Console.cpp
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/TextOutput/AP_TextOutput.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • TextOutput
Functions | Variables
AP_TextOutput.cpp File Reference
#include <vreckoAP/TextOutput/AP_TextOutput.h>
#include <vreckoAP/TextOutput/Console.h>

Functions

AP_EXPORT const char * | getPluginDescription ()
AP_EXPORT const char ** | getAbilityList ()
AP_EXPORT const char * | getAbilityDescription (const char *strName)
AP_EXPORT Ability * | getAbilityInstance (const char *pchName)
AP_EXPORT void | setAbilitiesParameters ()

Variables

const char * | g_pPluginName = {"TextOutput"}
const char * | g_pAbilityName []
const char * | g_pAbilityDesc []

Function Documentation

AP_EXPORT const char* getAbilityDescription ( const char * strName )
AP_EXPORT Ability* getAbilityInstance ( const char * pchName )
AP_EXPORT const char** getAbilityList ( void )
AP_EXPORT const char* getPluginDescription ( void )
AP_EXPORT void setAbilitiesParameters ( void )

Variable Documentation

const char* g_pAbilityDesc[]
Initial value:
= {
"World ability to create on-screen console for text output",
""
}
const char* g_pAbilityName[]
Initial value:
= {
"Console",
NULL
}
const char* g_pPluginName = {"TextOutput"}
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/TextOutput/Console.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • TextOutput
Namespaces | Macros | Functions
Console.cpp File Reference
#include <vreckoAP/TextOutput/Console.h>
#include <vrecko/World.h>
#include <vrecko/Scene.h>
#include <osg/Geometry>
#include <vrecko/PluginManager.h>

Namespaces

namespace APTextOutput

Macros

#define | CONSOLE_WINDOW_WIDTH_RATIO 0.9f
#define | CONSOLE_WINDOW_HEIGHT_RATIO 0.2f
#define | CONSOLE_WINDOW_HEIGHT_ADD 50.0f
#define | AWAY_PER_LINE_TIME 0.4f
#define | AWAY_PER_CHAR_TIME 0.03f
#define | CONSOLE_SHOW_TIME 0.4f
#define | CONSOLE_AWAY_TIME 1.0f
#define | CON_MAX_LINE 10000

Functions

void APTextOutput::loggerGraphicConsoleOutput (unsigned long dwOutputType, const char *outputLine, void *userParam)
APTextOutput::METHOD_REQUEST_INPUT (Add, MessageString, MessageVoid, Console)

Macro Definition Documentation

#define AWAY_PER_CHAR_TIME 0.03f
#define AWAY_PER_LINE_TIME 0.4f
#define CON_MAX_LINE 10000
#define CONSOLE_AWAY_TIME 1.0f
#define CONSOLE_SHOW_TIME 0.4f
#define CONSOLE_WINDOW_HEIGHT_ADD 50.0f
#define CONSOLE_WINDOW_HEIGHT_RATIO 0.2f
#define CONSOLE_WINDOW_WIDTH_RATIO 0.9f
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF Directory Reference

  • src
  • vreckoAP
  • VF
VF Directory Reference

Files

file | AP_VirtualFixture.cpp
file | AP_VirtualFixture.h [code]
file | Auxiliary.cpp
file | Auxiliary.h [code]
file | Avatar.cpp
file | Avatar.h [code]
file | AxisLock.cpp
file | AxisLock.h [code]
file | Border.cpp
file | Border.h [code]
file | Box.cpp
file | Box.h [code]
file | collection.cpp
file | collection.h [code]
file | Cone.cpp
file | Cone.h [code]
file | Cylinder.cpp
file | Cylinder.h [code]
file | Damper.cpp
file | Damper.h [code]
file | Drag.cpp
file | Drag.h [code]
file | Filter.cpp
file | Filter.h [code]
file | gesture.cpp
file | gesture.h [code]
file | gm.h [code]
file | gm_bool.h [code]
file | gm_const.h [code]
file | gm_mat3.cpp
file | gm_mat3.h [code]
file | gm_mat4.cpp
file | gm_mat4.h [code]
file | gm_utils.h [code]
file | gm_vec2.h [code]
file | gm_vec3.h [code]
file | gm_vec4.h [code]
file | Grid.cpp
file | Grid.h [code]
file | Log.cpp
file | Log.h [code]
file | Marker.cpp
file | Marker.h [code]
file | MarkerFactory.cpp
file | MarkerFactory.h [code]
file | mvect++.h [code]
file | mvect.cpp
file | mvect.h [code]
file | NavSphere.cpp
file | NavSphere.h [code]
file | PHANToMAvatar.cpp
file | PHANToMAvatar.h [code]
file | PHEffect.cpp
file | PHEffect.h [code]
file | Plane.cpp
file | Plane.h [code]
file | player.cpp
file | player.h [code]
file | ProxiBorder.cpp
file | ProxiBorder.h [code]
file | ProxiBox.cpp
file | ProxiBox.h [code]
file | ProxiCone.cpp
file | ProxiCone.h [code]
file | ProxiCylinder.cpp
file | ProxiCylinder.h [code]
file | ProxiSphere.cpp
file | ProxiSphere.h [code]
file | reader.cpp
file | reader.h [code]
file | Sphere.cpp
file | Sphere.h [code]
file | Trace.cpp
file | Trace.h [code]
file | Vibration.cpp
file | Vibration.h [code]
file | VibrationLabel.cpp
file | VibrationLabel.h [code]
file | VibrationLabelActivator.cpp
file | VibrationLabelActivator.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AP_VirtualFixture.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions | Variables
AP_VirtualFixture.cpp File Reference
#include <string.h>
#include "AP_VirtualFixture.h"

Functions

std::string | VirtualFixture_getPluginDescription (void)
const char ** | VirtualFixture_getAbilityList (void)
const char * | VirtualFixture_getAbilityDescription (const char *name)
Ability * | VirtualFixture_getAbilityInstance (const char *_name)
void | VirtualFixture_setAbilitiesParameters (void)

Variables

const char * | _VirtualFixture_plugin_name = { "VirtualFixture" }
const char * | _VirtualFixture_ability_name []
const char * | _VirtualFixture_ability_description []
Ability * _new_ability

Function Documentation

const char* VirtualFixture_getAbilityDescription ( const char * name )
Ability* VirtualFixture_getAbilityInstance ( const char * _name )
const char** VirtualFixture_getAbilityList ( void )
std::string VirtualFixture_getPluginDescription ( void )
void VirtualFixture_setAbilitiesParameters ( void )

Variable Documentation

Ability* _new_ability
const char* _VirtualFixture_ability_description[]
Initial value:
= {
"Avatar - we use advanced avatar -> with eye_position setting",
"AxisLock - Virtual Fixture to lock phantom to one or more axis (X,Y,Z)",
"Box - Box shape (attract phantom to center)",
"Border - if PHANToM workspace border is hit warn user by vibrations",
"Cone - Virtual Fixture to attract phantom to specific vector (cone shape)",
"Cylinder - Virtual Fixture to attract phantom to specific vector",
"Damper - compute viscose force (if force vector was set)",
"Drag - interface to mvect++ library => moving phantom along vector (gestures, collection of gestures)",
"Filter - filter force vector (reduce vibrations)",
"Grid - Virtual Fixture for emphasize grid in space",
"Log - event base logging ability",
"Marker - Marker in 3d Scene ... user can add a marker on place he likes",
"MarkerFactory - Marker management is provided by this object",
"NavSphere - Cast ray to the scene and when hit object it will vibrate (data from VibrationLabel)",
"",
"ProxiBox - Emit signal when entered",
"ProxiBorder - Emit signal when entered (border of working space of phantom)",
"ProxiCylinder - Emit signal when entered",
"ProxiSphere - Emit signal when entered",
"Sphere - Virtual Fixture to attract phantom to specific position",
"Trace - show num_of_elements of markers -> can be used to make trace of phantom. Instead of MakerFactory it automatically hold defined number of elements and add new only if now close to previous one",
"Vibration - produce vibration of selected (frequency, amplitude, direction, time) (activated by Event)",
"VibrationLabel - data store, describe vibration of object (frequency, amplitude, direction)",
"VibrationLabelActivator - check phantom if is collision with object with VibrationLabel, if so vibrate",
""
}
const char* _VirtualFixture_ability_name[]
Initial value:
= {
"Avatar",
"AxisLock",
"Box",
"Border",
"Cone",
"Cylinder",
"Damper",
"Drag",
"Filter",
"Grid",
"Log",
"Marker",
"MarkerFactory",
"NavSphere",
"Plane",
"ProxiBox",
"ProxiBorder",
"ProxiCylinder",
"ProxiSphere",
"Sphere",
"Trace",
"Vibration",
"VibrationLabel",
"VibrationLabelActivator",
NULL}
const char* _VirtualFixture_plugin_name = { "VirtualFixture" }
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AP_VirtualFixture.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Macros | Functions
AP_VirtualFixture.h File Reference
#include <vrecko/Ability.h>
#include <vreckoAP/Export>
#include "Auxiliary.h"
#include "Avatar.h"
#include "AxisLock.h"
#include "Box.h"
#include "Border.h"
#include "Cone.h"
#include "Cylinder.h"
#include "Damper.h"
#include "Drag.h"
#include "Filter.h"
#include "Grid.h"
#include "Log.h"
#include "Marker.h"
#include "MarkerFactory.h"
#include "NavSphere.h"
#include "Plane.h"
#include "ProxiBox.h"
#include "ProxiBorder.h"
#include "ProxiCylinder.h"
#include "ProxiSphere.h"
#include "Sphere.h"
#include "Trace.h"
#include "Vibration.h"
#include "VibrationLabel.h"
#include "VibrationLabelActivator.h"

Go to the source code of this file.

Macros

#define | INSTANCE
#define | LIST

Functions

const char AP_EXPORT ** | VirtualFixture_getAbilityList (void)
Ability AP_EXPORT * | VirtualFixture_getAbilityInstance (const char *_name)
const char *AP_EXPORT | VirtualFixture_getAbilityDescription (const char *name)
void AP_EXPORT | VirtualFixture_setAbilitiesParameters (void)
const char *AP_EXPORT | VirtualFixture_getPluginDescription (void)

Macro Definition Documentation

#define INSTANCE
#define LIST

Function Documentation

const char* AP_EXPORT VirtualFixture_getAbilityDescription ( const char * name )
Ability AP_EXPORT* VirtualFixture_getAbilityInstance ( const char * _name )
const char AP_EXPORT** VirtualFixture_getAbilityList ( void )
const char* AP_EXPORT VirtualFixture_getPluginDescription ( void )
void AP_EXPORT VirtualFixture_setAbilitiesParameters ( void )
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Auxiliary.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Macros | Functions | Variables
Auxiliary.cpp File Reference
#include "Auxiliary.h"
#include <math.h>
#include <osg/Timer>

Macros

#define VF_AUXILIARY_CPP

Functions

osg::Vec3 | ControlActualPositionReturnCleanPosition (osg::Vec3 Actual)
bool | ControlActualPosition (osg::Vec3 Actual)
osg::Vec3 | Vibrate (float frequency, float amplitude, osg::Vec3 direction)
osg::Vec3 | ForceTransformFunction (float maxforce, osg::Vec3 force)
float | SmoothEnding (float t)

Variables

osg::Timer timer

Macro Definition Documentation

#define VF_AUXILIARY_CPP

Function Documentation

bool ControlActualPosition ( osg::Vec3 Actual )
osg::Vec3 ControlActualPositionReturnCleanPosition ( osg::Vec3 Actual )
osg::Vec3 ForceTransformFunction | ( | float | maxforce,
 |  | osg::Vec3 | force
 | ) |  |
float SmoothEnding ( float t )
osg::Vec3 Vibrate | ( | float | frequency,
 |  | float | amplitude,
 |  | osg::Vec3 | direction
 | ) |  |

Variable Documentation

osg::Timer timer
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Auxiliary.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Namespaces | Macros | Functions | Variables
Auxiliary.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Timer>
#include <osg/Vec3>

Go to the source code of this file.

Namespaces

namespace VirtualFixture

Macros

#define | MAXFORCE 7.0
#define | SMOOTHING_RADIUS 0.05
#define | MINF 0.1
#define | MULTIPLIER 1.0
#define | ADDITIONX 0.0
#define | ADDITIONY 0.0
#define | ADDITIONZ 0.0
#define | WSXMIN -0.24 * MULTIPLIER + ADDITIONX
#define | WSXMAX 0.24 * MULTIPLIER + ADDITIONX
#define | WSYMIN -0.10 * MULTIPLIER + ADDITIONY
#define | WSYMAX 0.39 * MULTIPLIER + ADDITIONY
#define | WSZMIN -0.12 * MULTIPLIER + ADDITIONZ
#define | WSZMAX 0.16 * MULTIPLIER + ADDITIONZ
#define | ZEROXDISTANCE 0 * MULTIPLIER + ADDITIONX
#define | ZEROYDISTANCE 0.14 * MULTIPLIER + ADDITIONY
#define | ZEROZDISTANCE -0.13 * MULTIPLIER + ADDITIONZ
#define | MINBORDERRADIUS 0.13 * MULTIPLIER
#define | MAXBORDERRADIUS 0.24 * MULTIPLIER

Functions

osg::Vec3 | VirtualFixture::ControlActualPositionReturnCleanPosition (osg::Vec3 Actual)
bool | VirtualFixture::ControlActualPosition (osg::Vec3 Actual)
osg::Vec3 | VirtualFixture::Vibrate (float frequency, float amplitude, osg::Vec3 direction)
osg::Vec3 | VirtualFixture::ForceTransformFunction (float maxforce, osg::Vec3 force)
float | VirtualFixture::SmoothEnding (float t)

Variables

osg::Timer VirtualFixture::timer

Macro Definition Documentation

#define ADDITIONX 0.0
#define ADDITIONY 0.0
#define ADDITIONZ 0.0
#define MAXBORDERRADIUS 0.24 * MULTIPLIER
#define MAXFORCE 7.0
#define MINBORDERRADIUS 0.13 * MULTIPLIER
#define MINF 0.1
#define MULTIPLIER 1.0
#define SMOOTHING_RADIUS 0.05
#define WSXMAX 0.24 * MULTIPLIER + ADDITIONX
#define WSXMIN -0.24 * MULTIPLIER + ADDITIONX
#define WSYMAX 0.39 * MULTIPLIER + ADDITIONY
#define WSYMIN -0.10 * MULTIPLIER + ADDITIONY
#define WSZMAX 0.16 * MULTIPLIER + ADDITIONZ
#define WSZMIN -0.12 * MULTIPLIER + ADDITIONZ
#define ZEROXDISTANCE 0 * MULTIPLIER + ADDITIONX
#define ZEROYDISTANCE 0.14 * MULTIPLIER + ADDITIONY
#define ZEROZDISTANCE -0.13 * MULTIPLIER + ADDITIONZ
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Avatar.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions | Variables
Avatar.cpp File Reference
#include "Avatar.h"
#include <sstream>
#include <vreckoDB/ReaderWriter.h>
#include <vrecko/Scene.h>

Functions

osg::Vec3 | tmpEyePosition (0.0, 0.0, 14.0)
osg::Vec3 | tmpLookAtCenter (0.0, 0.0, 0.0)
osg::Vec3 | tmpUpVector (0.0, 1.0, 0.0)

Variables

float tmpFloat [3]

Function Documentation

osg::Vec3 tmpEyePosition | ( | 0. | 0,
 |  | 0. | 0,
 |  | 14. | 0
 | ) |  |
osg::Vec3 tmpLookAtCenter | ( | 0. | 0,
 |  | 0. | 0,
 |  | 0. | 0
 | ) |  |
osg::Vec3 tmpUpVector | ( | 0. | 0,
 |  | 1. | 0,
 |  | 0. | 0
 | ) |  |

Variable Documentation

float tmpFloat[3]
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Avatar.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Avatar.h File Reference
#include <vrecko/Ability.h>
#include <vrecko/EnvironmentObject.h>
#include <vrecko/World.h>

Go to the source code of this file.

Classes

class VirtualFixture::Avatar

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AxisLock.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
AxisLock.cpp File Reference
#include "AxisLock.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <osg/io_utils>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AxisLock.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
AxisLock.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::AxisLock

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Border.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Macros
Border.cpp File Reference
#include "Border.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <osg/CullFace>
#include <stdlib.h>

Macros

#define BORDER_CENTER 0.25

Macro Definition Documentation

#define BORDER_CENTER 0.25
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Border.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Border.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>
#include "Auxiliary.h"

Go to the source code of this file.

Classes

class VirtualFixture::Border

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Box.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Box.cpp File Reference
#include "Box.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Box.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Box.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Box

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/collection.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
collection.cpp File Reference
#include "collection.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/collection.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
collection.h File Reference
#include "gesture.h"
#include "mvect.h"
#include "gm.h"
#include <vector>

Go to the source code of this file.

Classes

class mv::CCollection

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cone.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Macros
Cone.cpp File Reference
#include "Cone.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <osg/CullFace>
#include <stdlib.h>

Macros

#define CONE_CENTER 0.25

Macro Definition Documentation

#define CONE_CENTER 0.25
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cone.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Cone.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Cone

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cylinder.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Cylinder.cpp File Reference
#include "Cylinder.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <osg/CullFace>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cylinder.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Cylinder.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Cylinder

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Damper.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Damper.cpp File Reference
#include "Damper.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Damper.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Damper.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::Damper

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Drag.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Macros | Variables
Drag.cpp File Reference
#include "Drag.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
#include <string.h>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
#include <xercesc/dom/DOMAttr.hpp>
#include <sstream>
#include <map>
#include "mvect++.h"
#include <osg/Timer>

Macros

#define | vmsg(s) if (verbose) cout << s;
#define | DIFF2FORCEMULTIPLIER 1

Variables

int | verbose =0
osg::Timer | ptimer
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		node
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		node2
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		node3
XERCES_CPP_NAMESPACE_QUALIFIER
DOMNode * 		node4
float | tempFloat [5]
map< string, CGesture * > | gestures
string | tmpName
CGesture * tmpGesture
CMVect * tmpMVect
string | tempString
bool | tempBool
char | tempChar

Macro Definition Documentation

#define DIFF2FORCEMULTIPLIER 1
#define vmsg ( s ) if (verbose) cout << s;

Variable Documentation

map<string, CGesture*> gestures
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* node
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node2
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node3
XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node4
osg::Timer ptimer
bool tempBool
char tempChar
float tempFloat[5]
string tempString
CGesture* tmpGesture
CMVect* tmpMVect
string tmpName
int verbose =0
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Drag.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Drag.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include "mvect++.h"
#include <string>

Go to the source code of this file.

Classes

class VirtualFixture::Drag

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Filter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Filter.cpp File Reference
#include "Filter.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Filter.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces | Macros
Filter.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::Filter

Namespaces

namespace VirtualFixture

Macros

#define | BASEK1 (0.9)
#define | BASEK2 (0.1)

Macro Definition Documentation

#define BASEK1 (0.9)
#define BASEK2 (0.1)
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gesture.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Namespaces
gesture.cpp File Reference
#include "gesture.h"

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gesture.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
gesture.h File Reference
#include <vector>
#include "mvect.h"

Go to the source code of this file.

Classes

class mv::CGesture

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm.h File Reference
#include <gm_bool.h>
#include <gm_const.h>
#include <gm_utils.h>
#include <gm_vec2.h>
#include <gm_vec3.h>
#include <gm_vec4.h>
#include <gm_mat3.h>
#include <gm_mat4.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_bool.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_bool.h File Reference

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_const.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Variables
gm_const.h File Reference

Go to the source code of this file.

Variables

double const | gm2PI = 6.28318530717958623200
double const | gmDEGTORAD = 0.01745329251994329547
double const | gmE = 2.71828182845904553488
double const | gmEEXPPI = 23.14069263277927390732
double const | gmGOLDEN = 1.61803398874989490253
double const | gmINVPI = 0.31830988618379069122
double const | gmLN10 = 2.30258509299404590109
double const | gmLN2 = 0.69314718055994528623
double const | gmLOG10E = 0.43429448190325187218
double const | gmLOG2E = 1.44269504088896338700
double const | gmPI = 3.14159265358979323846
double const | gmPIDIV2 = 1.57079632679489655800
double const | gmPIDIV4 = 0.78539816339744827900
double const | gmRADTODEG = 57.29577951308232286465
double const | gmSQRT2 = 1.41421356237309514547
double const | gmSQRT2PI = 2.50662827463100024161
double const | gmSQRT3 = 1.73205080756887719318
double const | gmSQRT10 = 3.16227766016837952279
double const | gmSQRTE = 1.64872127070012819416
double const | gmSQRTHALF = 0.70710678118654757274
double const | gmSQRTLN2 = 0.83255461115769768821
double const | gmSQRTPI = 1.77245385090551588192
double const | gmEPSILON = 1.0e-10
double const | gmGOOGOL = 1.0e50

Variable Documentation

double const gm2PI = 6.28318530717958623200
double const gmDEGTORAD = 0.01745329251994329547
double const gmE = 2.71828182845904553488
double const gmEEXPPI = 23.14069263277927390732
double const gmEPSILON = 1.0e-10
double const gmGOLDEN = 1.61803398874989490253
double const gmGOOGOL = 1.0e50
double const gmINVPI = 0.31830988618379069122
double const gmLN10 = 2.30258509299404590109
double const gmLN2 = 0.69314718055994528623
double const gmLOG10E = 0.43429448190325187218
double const gmLOG2E = 1.44269504088896338700
double const gmPI = 3.14159265358979323846
double const gmPIDIV2 = 1.57079632679489655800
double const gmPIDIV4 = 0.78539816339744827900
double const gmRADTODEG = 57.29577951308232286465
double const gmSQRT10 = 3.16227766016837952279
double const gmSQRT2 = 1.41421356237309514547
double const gmSQRT2PI = 2.50662827463100024161
double const gmSQRT3 = 1.73205080756887719318
double const gmSQRTE = 1.64872127070012819416
double const gmSQRTHALF = 0.70710678118654757274
double const gmSQRTLN2 = 0.83255461115769768821
double const gmSQRTPI = 1.77245385090551588192
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat3.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions
gm_mat3.cpp File Reference
#include "gm_mat3.h"
#include "gm_vec2.h"
#include "gm_vec3.h"

Functions

double | RCD (const gmMatrix3 &A, const gmMatrix3 &B, int i, int j)
double | MINOR (const gmMatrix3 &M, int r0, int r1, int c0, int c1)
gmMatrix3 | operator* (double d, const gmMatrix3 &M)
gmVector3 | operator* (const gmVector3 &v, const gmMatrix3 &M)
ostream & | operator<< (ostream &os, const gmMatrix3 &M)

Function Documentation

double MINOR | ( | const gmMatrix3 & | M,
 |  | int | r0,
 |  | int | r1,
 |  | int | c0,
 |  | int | c1
 | ) |  |
inline
gmMatrix3 operator* | ( | double | d,
 |  | const gmMatrix3 & | M
 | ) |  |
gmVector3 operator* | ( | const gmVector3 & | v,
 |  | const gmMatrix3 & | M
 | ) |  |
ostream& operator<< | ( | ostream & | os,
 |  | const gmMatrix3 & | M
 | ) |  |
inline
double RCD | ( | const gmMatrix3 & | A,
 |  | const gmMatrix3 & | B,
 |  | int | i,
 |  | int | j
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat3.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes
gm_mat3.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <gm_utils.h>

Go to the source code of this file.

Classes

class gmMatrix3
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat4.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions
gm_mat4.cpp File Reference
#include "gm_mat4.h"
#include "gm_vec3.h"
#include "gm_vec4.h"

Functions

double | RCD (const gmMatrix4 &A, const gmMatrix4 &B, int i, int j)
double | MINOR (const gmMatrix4 &M, int r0, int r1, int r2, int c0, int c1, int c2)
gmMatrix4 | operator* (double d, const gmMatrix4 &M)
gmVector4 | operator* (const gmVector4 &v, const gmMatrix4 &M)
ostream & | operator<< (ostream &os, const gmMatrix4 &M)

Function Documentation

double MINOR | ( | const gmMatrix4 & | M,
 |  | int | r0,
 |  | int | r1,
 |  | int | r2,
 |  | int | c0,
 |  | int | c1,
 |  | int | c2
 | ) |  |
inline
gmMatrix4 operator* | ( | double | d,
 |  | const gmMatrix4 & | M
 | ) |  |
gmVector4 operator* | ( | const gmVector4 & | v,
 |  | const gmMatrix4 & | M
 | ) |  |
ostream& operator<< | ( | ostream & | os,
 |  | const gmMatrix4 & | M
 | ) |  |
inline
double RCD | ( | const gmMatrix4 & | A,
 |  | const gmMatrix4 & | B,
 |  | int | i,
 |  | int | j
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat4.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes
gm_mat4.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <gm_utils.h>

Go to the source code of this file.

Classes

class gmMatrix4
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_utils.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions
gm_utils.h File Reference
#include <iostream>
#include <math.h>
#include <gm_bool.h>
#include <gm_const.h>

Go to the source code of this file.

Functions

double | gmAbs (double f)
double | gmCeil (double f)
double | gmCube (double f)
double | gmDegrees (double f)
double | gmFloor (double f)
double | gmInv (double f)
bool | gmIsZero (double f)
double | gmRadians (double f)
double | gmRound (double f)
double | gmSign (double f)
double | gmSmooth (double f)
double | gmSqr (double f)
double | gmTrunc (double f)
double | gmZSign (double f)
bool | gmFuzEQ (double f, double g)
bool | gmFuzGEQ (double f, double g)
bool | gmFuzLEQ (double f, double g)
double | gmMax (double f, double g)
double | gmMin (double f, double g)
void | gmSwap (double &f, double &g)
void | gmSwap (int &i, int &j)
void | gmClamp (double &f, double l, double h)
double | gmLerp (double f, double l, double h)
double | gmMax (double f, double g, double h)
double | gmMin (double f, double g, double h)
double | gmSlide (double f, double l, double h)

Function Documentation

double gmAbs ( double f )
inline
double gmCeil ( double f )
inline
void gmClamp | ( | double & | f,
 |  | double | l,
 |  | double | h
 | ) |  |
inline
double gmCube ( double f )
inline
double gmDegrees ( double f )
inline
double gmFloor ( double f )
inline
bool gmFuzEQ | ( | double | f,
 |  | double | g
 | ) |  |
inline
bool gmFuzGEQ | ( | double | f,
 |  | double | g
 | ) |  |
inline
bool gmFuzLEQ | ( | double | f,
 |  | double | g
 | ) |  |
inline
double gmInv ( double f )
inline
bool gmIsZero ( double f )
inline
double gmLerp | ( | double | f,
 |  | double | l,
 |  | double | h
 | ) |  |
inline
double gmMax | ( | double | f,
 |  | double | g
 | ) |  |
inline
double gmMax | ( | double | f,
 |  | double | g,
 |  | double | h
 | ) |  |
inline
double gmMin | ( | double | f,
 |  | double | g
 | ) |  |
inline
double gmMin | ( | double | f,
 |  | double | g,
 |  | double | h
 | ) |  |
inline
double gmRadians ( double f )
inline
double gmRound ( double f )
inline
double gmSign ( double f )
inline
double gmSlide | ( | double | f,
 |  | double | l,
 |  | double | h
 | ) |  |
inline
double gmSmooth ( double f )
inline
double gmSqr ( double f )
inline
void gmSwap | ( | double & | f,
 |  | double & | g
 | ) |  |
inline
void gmSwap | ( | int & | i,
 |  | int & | j
 | ) |  |
inline
double gmTrunc ( double f )
inline
double gmZSign ( double f )
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec2.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Functions
gm_vec2.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <gm_utils.h>

Go to the source code of this file.

Classes

class gmVector2

Functions

gmVector2 | operator* (double c, const gmVector2 &v)
double | distance (const gmVector2 &v1, const gmVector2 &v2)
double | distanceSquared (const gmVector2 &v1, const gmVector2 &v2)
double | dot (const gmVector2 &v1, const gmVector2 &v2)
gmVector2 | lerp (double f, const gmVector2 &v1, const gmVector2 &v2)
ostream & | operator<< (ostream &os, const gmVector2 &v)

Function Documentation

double distance | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
inline
double distanceSquared | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
inline
double dot | ( | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
inline
gmVector2 lerp | ( | double | f,
 |  | const gmVector2 & | v1,
 |  | const gmVector2 & | v2
 | ) |  |
inline
gmVector2 operator* | ( | double | c,
 |  | const gmVector2 & | v
 | ) |  |
inline
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector2 & | v
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec3.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Functions
gm_vec3.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <gm_utils.h>
#include <iostream>

Go to the source code of this file.

Classes

class gmVector3

Functions

gmVector3 | operator* (double c, const gmVector3 &v)
gmVector3 | cross (const gmVector3 &v1, const gmVector3 &v2)
double | distance (const gmVector3 &v1, const gmVector3 &v2)
double | distanceSquared (const gmVector3 &v1, const gmVector3 &v2)
double | dot (const gmVector3 &v1, const gmVector3 &v2)
gmVector3 | lerp (double f, const gmVector3 &v1, const gmVector3 &v2)
double | plane_intersect (const gmVector3 &p, const gmVector3 &v, const gmVector3 &plane_p, const gmVector3 &plane_norm)
double | line_distance (const gmVector3 &p1, const gmVector3 &v1, const gmVector3 &p2, const gmVector3 &v2)
double | plane_distance (const gmVector3 &p, const gmVector3 &plane_p, const gmVector3 &plane_norm)
ostream & | operator<< (ostream &os, const gmVector3 &v)

Function Documentation

gmVector3 cross | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
inline
double distance | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
inline
double distanceSquared | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
inline
double dot | ( | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
inline
gmVector3 lerp | ( | double | f,
 |  | const gmVector3 & | v1,
 |  | const gmVector3 & | v2
 | ) |  |
inline
double line_distance | ( | const gmVector3 & | p1,
 |  | const gmVector3 & | v1,
 |  | const gmVector3 & | p2,
 |  | const gmVector3 & | v2
 | ) |  |
inline
gmVector3 operator* | ( | double | c,
 |  | const gmVector3 & | v
 | ) |  |
inline
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector3 & | v
 | ) |  |
inline
double plane_distance | ( | const gmVector3 & | p,
 |  | const gmVector3 & | plane_p,
 |  | const gmVector3 & | plane_norm
 | ) |  |
inline
double plane_intersect | ( | const gmVector3 & | p,
 |  | const gmVector3 & | v,
 |  | const gmVector3 & | plane_p,
 |  | const gmVector3 & | plane_norm
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec4.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Functions
gm_vec4.h File Reference
#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <gm_utils.h>

Go to the source code of this file.

Classes

class gmVector4

Functions

gmVector4 | operator* (double c, const gmVector4 &v)
double | distance (const gmVector4 &v1, const gmVector4 &v2)
double | distanceSquared (const gmVector4 &v1, const gmVector4 &v2)
double | dot (const gmVector4 &v1, const gmVector4 &v2)
gmVector4 | lerp (double f, const gmVector4 &v1, const gmVector4 &v2)
ostream & | operator<< (ostream &os, const gmVector4 &v)

Function Documentation

double distance | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
inline
double distanceSquared | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
inline
double dot | ( | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
inline
gmVector4 lerp | ( | double | f,
 |  | const gmVector4 & | v1,
 |  | const gmVector4 & | v2
 | ) |  |
inline
gmVector4 operator* | ( | double | c,
 |  | const gmVector4 & | v
 | ) |  |
inline
ostream& operator<< | ( | ostream & | os,
 |  | const gmVector4 & | v
 | ) |  |
inline
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Grid.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Functions
Grid.cpp File Reference
#include "Grid.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>

Functions

double compute_modulated_ratio (double a, double b)

Function Documentation

double compute_modulated_ratio | ( | double | a,
 |  | double | b
 | ) |  |
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Grid.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Grid.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::Grid

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Log.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Log.cpp File Reference
#include "Log.h"
#include <string>
#include <vrecko/World.h>
#include <vreckoDB/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Log.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Log.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class VirtualFixture::Log

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Marker.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Marker.cpp File Reference
#include "Marker.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Marker.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Marker.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::Marker

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/MarkerFactory.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
MarkerFactory.cpp File Reference
#include "MarkerFactory.h"
#include "Auxiliary.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
#include <vector>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/MarkerFactory.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
MarkerFactory.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include "Auxiliary.h"
#include "Marker.h"

Go to the source code of this file.

Classes

class VirtualFixture::MarkerFactory

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect++.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
mvect++.h File Reference
#include "mvect.h"
#include "gesture.h"
#include "player.h"
#include "reader.h"
#include "collection.h"
#include "gm.h"

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Namespaces
mvect.cpp File Reference
#include "mvect.h"

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
mvect.h File Reference
#include "gm.h"

Go to the source code of this file.

Classes

struct | mv::CPoint
class | mv::CMVect

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/NavSphere.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Variables
NavSphere.cpp File Reference
#include <vrecko/Ability.h>
#include <vrecko/BaseClass.h>
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <osg/CullFace>
#include <stdlib.h>
#include "NavSphere.h"

Variables

osg::Vec3 | ray_position = osg::Vec3(0,0,0)
osg::Vec3 | ray_direction = osg::Vec3(0,0,10)
EnvironmentObject * hittedobject
Ability * tmpability

Variable Documentation

EnvironmentObject* hittedobject
osg::Vec3 ray_direction = osg::Vec3(0,0,10)
osg::Vec3 ray_position = osg::Vec3(0,0,0)
Ability* tmpability
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/NavSphere.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
NavSphere.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include "Auxiliary.h"
#include "VibrationLabel.h"
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::NavSphere

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Functions | Variables
PHANToMAvatar.cpp File Reference
#include "PHANToMAvatar.h"
#include <vreckoDB/ReaderWriter.h>
#include <vrecko/Scene.h>
#include <vrecko/PHANToM.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <ph_lib_data_structs.h>
#include <esg/spacesorting/FDH14Tree.h>
#include <esg/OSGPolygon.h>
#include <osg/Geode>
#include <osg/Geometry>
#include <osg/Material>
#include <esg/OSGAdapter.h>

Classes

struct Triangle

Functions

double pointToTriangleDistance (osg::Vec3 P1, osg::Vec3 P2, osg::Vec3 P3, osg::Vec3 P0)

Variables

CPhantomRec * pCPhRec
EnvironmentObject * pVPosModel

Function Documentation

double pointToTriangleDistance | ( | osg::Vec3 | P1,
 |  | osg::Vec3 | P2,
 |  | osg::Vec3 | P3,
 |  | osg::Vec3 | P0
 | ) |  |

Variable Documentation

CPhantomRec* pCPhRec
EnvironmentObject* pVPosModel
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes
PHANToMAvatar.h File Reference
#include <vrecko/Ability.h>

Go to the source code of this file.

Classes

class PHANToMAvatar
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Macros
PHEffect.cpp File Reference
#include "PHEffect.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>

Classes

class | filter1
class | filter2

Macros

#define | SPEED2FORCE 2
#define | MATERIALCOUNTERMAX 25

Macro Definition Documentation

#define MATERIALCOUNTERMAX 25
#define SPEED2FORCE 2
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes
PHEffect.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class PHEffect
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Plane.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Plane.cpp File Reference
#include "Plane.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <osg/CullFace>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Plane.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Plane.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Plane

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/player.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Namespaces | Macros | Functions | Variables
player.cpp File Reference
#include "player.h"
#include <osg/Timer>

Namespaces

namespace mv

Macros

#define | diff2force 180.0
#define | spheresize 0.05
#define | type 0
#define | MAXDIST 0.05
#define | HOLDFORCE 1.0

Functions

double | mv::ActTtoP (double t, double v0, double v1, double l)
double | mv::PtoActT (double p, double v0, double v1, double l)

Variables

osg::Timer timer

Macro Definition Documentation

#define diff2force 180.0
#define HOLDFORCE 1.0
#define MAXDIST 0.05
#define spheresize 0.05
#define type 0

Variable Documentation

osg::Timer timer
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/player.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces | Macros | Functions
player.h File Reference
#include "collection.h"
#include <vector>

Go to the source code of this file.

Classes

class mv::CPlayer

Namespaces

namespace mv

Macros

#define DEFAULT_FREQ 5000

Functions

double | mv::ActTtoP (double t, double v0, double v1, double l)
double | mv::PtoActT (double p, double v0, double v1, double l)

Macro Definition Documentation

#define DEFAULT_FREQ 5000
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBorder.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiBorder.cpp File Reference
#include "ProxiBorder.h"
#include "Auxiliary.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBorder.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
ProxiBorder.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>
#include "Auxiliary.h"

Go to the source code of this file.

Classes

class VirtualFixture::ProxiBorder

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBox.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiBox.cpp File Reference
#include "ProxiBox.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBox.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
ProxiBox.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::ProxiBox

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCone.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiCone.cpp File Reference
#include "ProxiCone.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCone.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
ProxiCone.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::ProxiCone

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCylinder.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiCylinder.cpp File Reference
#include "ProxiCylinder.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCylinder.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
ProxiCylinder.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::ProxiCylinder

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiSphere.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiSphere.cpp File Reference
#include "ProxiSphere.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiSphere.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
ProxiSphere.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::ProxiSphere

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/reader.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
reader.cpp File Reference
#include "reader.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/reader.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
reader.h File Reference
#include "collection.h"
#include "gesture.h"
#include "mvect.h"

Go to the source code of this file.

Classes

class mv::Reader

Namespaces

namespace mv
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Sphere.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Sphere.cpp File Reference
#include "Sphere.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Sphere.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Sphere.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Sphere

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:50 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Trace.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Trace.cpp File Reference
#include "Trace.h"
#include "Auxiliary.h"
#include <vrecko/Scene.h>
#include <vrecko/World.h>
#include <vrecko/EventDispatcher.h>
#include <vreckoDB/ReaderWriter.h>
#include <osg/ShapeDrawable>
#include <osg/StateSet>
#include <osg/Material>
#include <osg/Quat>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Trace.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
Trace.h File Reference
#include <vrecko/Ability.h>
#include <osg/Vec4>
#include <osg/Geode>
#include <osg/MatrixTransform>
#include <osg/Group>

Go to the source code of this file.

Classes

class VirtualFixture::Trace

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Vibration.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Variables
Vibration.cpp File Reference
#include "Vibration.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
#include <osg/Timer>
#include "Auxiliary.h"

Variables

osg::Timer vtimer

Variable Documentation

osg::Timer vtimer
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Vibration.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces | Variables
Vibration.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include <osg/Timer>
#include "Auxiliary.h"

Go to the source code of this file.

Classes

class VirtualFixture::Vibration

Namespaces

namespace VirtualFixture

Variables

osg::Timer VirtualFixture::vtimer
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabel.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
VibrationLabel.cpp File Reference
#include "VibrationLabel.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabel.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
VibrationLabel.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>

Go to the source code of this file.

Classes

class VirtualFixture::VibrationLabel

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabelActivator.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
VibrationLabelActivator.cpp File Reference
#include "VibrationLabelActivator.h"
#include "Auxiliary.h"
#include <vrecko/Scene.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/DeviceManager.h>
#include <vreckoDB/ReaderWriter.h>
#include <stdlib.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabelActivator.h File Reference

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Classes | Namespaces
VibrationLabelActivator.h File Reference
#include <vrecko/Ability.h>
#include <vreckoDP/base/PHANToM.h>
#include "Auxiliary.h"
#include "VibrationLabel.h"

Go to the source code of this file.

Classes

class VirtualFixture::VibrationLabelActivator

Namespaces

namespace VirtualFixture
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP Directory Reference

  • src
  • vreckoDP
vreckoDP Directory Reference

Directories

directory | base
directory | Kinect
directory | PHANToM
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base Directory Reference

  • src
  • vreckoDP
  • base
base Directory Reference

Files

file | A3DBird.cpp
file | Arm.cpp
file | DP_base.cpp
file | fdtDataGlove.cpp
file | fsPinchGlove.cpp
file | Hci.cpp
file | KeyboardMouse.cpp
file | L3DMouse.cpp
file | LHeadTracker.cpp
file | MicroScribe3D.cpp
file | NestOfBirds.cpp
file | OptiTrack.cpp
file | precompiled.cpp
file | precompiled.h [code]
file | Serial.cpp
file | Timing.cpp
file | Ultratrak.cpp
file | VRPN3DMouse.cpp
file | Wiimote.cpp
Example using the wiiuse API.
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/A3DBird.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
A3DBird.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Arm.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Functions | Variables
Arm.cpp File Reference
#include "precompiled.h"

Functions

arm_result | simple_TIMED_OUT (arm_result condition)
arm_result | simple_BAD_PORT (arm_result condition)
arm_result | simple_BAD_PACKET (arm_result condition)
arm_result | simple_NO_HCI (arm_result condition)
arm_result | simple_CANT_BEGIN (arm_result condition)
arm_result | simple_CANT_OPEN_PORT (arm_result condition)

Variables

char | INCHES [7] = "inches"
char | MM [3] = "mm"
char | RADIANS [8] = "radians"
char | DEGREES [8] = "degrees"
char | XYZ_FIXED [10] = "xyz fixed"
char | ZYX_FIXED [10] = "zyx fixed"
char | YXZ_FIXED [10] = "yxz fixed"
char | ZYX_EULER [10] = "zyx Euler"
char | XYZ_EULER [10] = "xyz Euler"
char | ZXY_EULER [10] = "zxy Euler"

Function Documentation

arm_result simple_BAD_PACKET ( arm_result condition )
arm_result simple_BAD_PORT ( arm_result condition )
arm_result simple_CANT_BEGIN ( arm_result condition )
arm_result simple_CANT_OPEN_PORT ( arm_result condition )
arm_result simple_NO_HCI ( arm_result condition )
arm_result simple_TIMED_OUT ( arm_result condition )

Variable Documentation

char DEGREES[8] = "degrees"
char INCHES[7] = "inches"
char MM[3] = "mm"
char RADIANS[8] = "radians"
char XYZ_EULER[10] = "xyz Euler"
char XYZ_FIXED[10] = "xyz fixed"
char YXZ_FIXED[10] = "yxz fixed"
char ZXY_EULER[10] = "zxy Euler"
char ZYX_EULER[10] = "zyx Euler"
char ZYX_FIXED[10] = "zyx fixed"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/DP_base.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Functions | Variables
DP_base.cpp File Reference
#include "precompiled.h"
#include <string>
#include <vreckoDP/base/DP_base.h>

Functions

const char * | base_getPluginDescription (void)
const char DP_EXPORT ** | base_getDeviceList (void)
const char DP_EXPORT * | base_getDeviceDescription (const char *name)
Device DP_EXPORT * | base_getDeviceInstance (const char *_name)
void DP_EXPORT | base_setDevicesParameters (void)

Variables

const char * | _base_plugin_name = { "base" }
const char * | _base_device_name []
const char * | _base_device_description []
Device * _new_device

Function Documentation

const char DP_EXPORT* base_getDeviceDescription ( const char * name )
Device DP_EXPORT* base_getDeviceInstance ( const char * _name )
const char DP_EXPORT** base_getDeviceList ( void )
const char* base_getPluginDescription ( void )
void DP_EXPORT base_setDevicesParameters ( void )

Variable Documentation

const char* _base_device_description[]
Initial value:
= {
"A3DBird",
"fdtDataGlove",
"fsPinchGlove",
"KeyboardMouse",
"LHeadTracker",
"L3DMouse",
"MicroScribe3D",
"NestOfBirds",
"Ultratrak",
"OptiTrack",
"VRPN3DMouse",
"Wiimote",
""}
const char* _base_device_name[]
Initial value:
= {
"A3DBird",
"fdtDataGlove",
"fsPinchGlove",
"KeyboardMouse",
"LHeadTracker",
"L3DMouse",
"MicroScribe3D",
"NestOfBirds",
"Ultratrak",
"OptiTrack",
"VRPN3DMouse",
"Wiimote",
NULL}
const char* _base_plugin_name = { "base" }
Device* _new_device
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/fdtDataGlove.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
fdtDataGlove.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/fsPinchGlove.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
fsPinchGlove.cpp File Reference
#include "precompiled.h"
#include <unistd.h>
#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>
#include <netdb.h>
#include <errno.h>
#include <signal.h>
#include <setjmp.h>
#include <stdio.h>
#include <sys/time.h>
#include <time.h>
#include <ctype.h>
#include <fcntl.h>
#include <sys/file.h>
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <termios.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Hci.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Variables
Hci.cpp File Reference
#include "precompiled.h"

Variables

byte cfg_args [MAX_CFG_SIZE]
int | num_cfg_args
char | SIGNON_STR [5] = "IMMC"
char | BEGIN_STR [6] = "BEGIN"
char | SUCCESS [8] = "Success"
char | NO_PACKET_YET [32] = "Current packet not yet complete"
char | TRY__AGAIN [29] = "Try this HCI operation again"
char | TIMED_OUT [29] = "Timed out waiting for packet"
char | BAD_PORT_NUM [25] = "Port number out of range"
char | BAD_PACKET [17] = "Corrupted packet"
char | NO_HCI [19] = "Unable to find HCI"
char | CANT_BEGIN [34] = "Found HCI but can't begin session"
char | CANT_OPEN_PORT [27] = "Unable to open serial port"
char | BAD_PASSWORD [40] = "Password rejected during config command"
char | BAD_VERSION [47] = "Firmware version does not support this feature"
char | BAD_FORMAT [34] = "Unknown firmware parameter format"
Timing tim
Serial ser

Variable Documentation

char BAD_FORMAT[34] = "Unknown firmware parameter format"
char BAD_PACKET[17] = "Corrupted packet"
char BAD_PASSWORD[40] = "Password rejected during config command"
char BAD_PORT_NUM[25] = "Port number out of range"
char BAD_VERSION[47] = "Firmware version does not support this feature"
char BEGIN_STR[6] = "BEGIN"
char CANT_BEGIN[34] = "Found HCI but can't begin session"
char CANT_OPEN_PORT[27] = "Unable to open serial port"
byte cfg_args[MAX_CFG_SIZE]
char NO_HCI[19] = "Unable to find HCI"
char NO_PACKET_YET[32] = "Current packet not yet complete"
int num_cfg_args
Serial ser
char SIGNON_STR[5] = "IMMC"
char SUCCESS[8] = "Success"
Timing tim
char TIMED_OUT[29] = "Timed out waiting for packet"
char TRY__AGAIN[29] = "Try this HCI operation again"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/KeyboardMouse.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
KeyboardMouse.cpp File Reference
#include "precompiled.h"
#include <vreckoDP/base/KeyboardMouse.h>
#include <vrecko/Viewer.h>
#include <osgGA/GUIEventAdapter>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/L3DMouse.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
L3DMouse.cpp File Reference
#include "precompiled.h"
#include <vreckoDP/base/L3DMouse.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/LHeadTracker.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Macros
LHeadTracker.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <ctype.h>
#include <unistd.h>
#include <sys/file.h>
#include <sys/ioctl.h>
#include <termios.h>
#include <fcntl.h>
#include <errno.h>
#include <signal.h>
#include <setjmp.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <vreckoDP/base/LHeadTracker.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>

Macros

#define NUM_PORTS 4

Macro Definition Documentation

#define NUM_PORTS 4
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/MicroScribe3D.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
MicroScribe3D.cpp File Reference
#include "precompiled.h"
#include <osg/Vec4>
#include <osg/Quat>
#include <stdio.h>
#include <string>
#include <vreckoDP/base/MicroScribe3D.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/NestOfBirds.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
NestOfBirds.cpp File Reference
#include "precompiled.h"
#include <osg/Vec4>
#include <osg/Matrix>
#include <osg/Notify>
#include <osg/io_utils>
#include <sstream>
#include <vreckoDP/base/NestOfBirds.h>
#include <vrecko/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/OptiTrack.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Functions
OptiTrack.cpp File Reference
#include "precompiled.h"
#include <osg/Notify>
#include <osg/io_utils>
#include <iostream>
#include <sstream>
#include <vreckoDP/base/OptiTrack.h>
#include <vrecko/ReaderWriter.h>

Functions

void VRPN_CALLBACK handle_tracker (void *, const vrpn_TRACKERCB t)

Function Documentation

void VRPN_CALLBACK handle_tracker | ( | void * | p,
 |  | const vrpn_TRACKERCB | t
 | ) |  |
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
precompiled.h File Reference
#include <termio.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <map>
#include <string>
#include <algorithm>
#include <osg/io_utils>
#include <osg/Matrix>
#include <osg/Notify>
#include <osg/Quat>
#include <osg/Timer>
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osgGA/GUIEventAdapter>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Scene.h>
#include <vreckoDP/base/Ultratrak.h>
#include <vreckoDP/base/A3DBird.h>
#include <vreckoDP/base/arm.h>
#include <vreckoDP/base/classes.h>
#include <vreckoDP/base/fdtDataGlove.h>
#include <vreckoDP/base/fsPinchGlove.h>
#include <vreckoDP/base/hci.h>
#include <windows.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Serial.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Macros
Serial.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <vreckoDP/base/classes.h>
#include <termio.h>
#include <unistd.h>
#include <fcntl.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/time.h>

Macros

#define | OFLAGS
#define | LFLAGS
#define | IFLAGS

Macro Definition Documentation

#define IFLAGS
Value:
(IGNBRK | BRKINT | IGNPAR | PARMRK | INPCK | INLCR \
| ICRNL | IGNCR | IUCLC | ISTRIP | IXON \
| IXOFF)
#define LFLAGS
Value:
(ICANON | ISIG | XCASE | ECHO | ECHOE | ECHOK \
| ECHONL | NOFLSH)
#define OFLAGS
Value:
(OPOST | OLCUC | ONLCR | OCRNL | ONOCR \
| ONLRET | OFILL | OFDEL)
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Timing.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Macros
Timing.cpp File Reference
#include "precompiled.h"
#include <stdio.h>
#include <vreckoDP/base/classes.h>
#include <unistd.h>
#include <sys/time.h>

Macros

#define TOMS(what) unsigned (what.tv_sec*1000 + what.tv_usec/1000)

Macro Definition Documentation

#define TOMS ( what ) unsigned (what.tv_sec*1000 + what.tv_usec/1000)
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Ultratrak.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Variables
Ultratrak.cpp File Reference
#include "precompiled.h"

Variables

struct timeval | timeout
fd_set | readfds
int | nfound

Variable Documentation

int nfound
fd_set readfds
struct timeval timeout
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/VRPN3DMouse.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
VRPN3DMouse.cpp File Reference
#include "precompiled.h"
#include <vreckoDP/base/VRPN3DMouse.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/Wiimote.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • base
Macros | Variables
Wiimote.cpp File Reference

Example using the wiiuse API. More...

#include "precompiled.h"
#include <osg/Notify>
#include <osg/io_utils>
#include <sstream>
#include <vreckoDP/base/Wiimote.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/MTLock.h>

Macros

#define | NUM_WII_DEVICES 2
#define | SEND_EVENT(name, msg)
#define | SEND_BUTTON(msg) SEND_EVENT("Button", msg)

Variables

MTLock wiiSendersLock
std::vector< std::string > wiiSenderStrings

Detailed Description

Example using the wiiuse API.

This file is an example of how to use the wiiuse library.

Macro Definition Documentation

#define NUM_WII_DEVICES 2
#define SEND_BUTTON ( msg ) SEND_EVENT("Button", msg)
#define SEND_EVENT | ( | name,
 |  | msg
 | ) |
Value:
{ \
sender = fakeSenderString; \
sender += "#"; \
sender += name; \
world->getEventDispatcherPtr()->reportEvent(sender, msg); \
}

Variable Documentation

MTLock wiiSendersLock
std::vector<std::string> wiiSenderStrings
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect Directory Reference

  • src
  • vreckoDP
  • Kinect
Kinect Directory Reference

Files

file | DP_Kinect.cpp
file | Kinect.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/DP_Kinect.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • Kinect
Functions | Variables
DP_Kinect.cpp File Reference
#include "precompiled.h"
#include <string>
#include <vreckoDP/Kinect/DP_Kinect.h>
#include <vreckoDP/Kinect/Kinect.h>

Functions

const char * | getPluginDescription (void)
const char DP_EXPORT ** | getDeviceList (void)
const char DP_EXPORT * | getDeviceDescription (const char *name)
Device DP_EXPORT * | getDeviceInstance (const char *_name)
void DP_EXPORT | setDevicesParameters (void)

Variables

const char * | _plugin_name = { "Kinect" }
const char * | _device_name []
const char * | _device_description []

Function Documentation

const char DP_EXPORT* getDeviceDescription ( const char * name )
Device DP_EXPORT* getDeviceInstance ( const char * _name )
const char DP_EXPORT** getDeviceList ( void )
const char* getPluginDescription ( void )
void DP_EXPORT setDevicesParameters ( void )

Variable Documentation

const char* _device_description[]
Initial value:
= {
"Kinect",
""}
const char* _device_name[]
Initial value:
= {
"Kinect",
NULL}
const char* _plugin_name = { "Kinect" }
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/Kinect.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • Kinect
Kinect.cpp File Reference
#include "precompiled.h"
#include <vreckoDP/Kinect/Kinect.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • Kinect
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • Kinect
precompiled.h File Reference
#include <termio.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <map>
#include <string>
#include <osg/io_utils>
#include <osg/Matrix>
#include <osg/Notify>
#include <osg/Quat>
#include <osg/Timer>
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osgGA/GUIEventAdapter>
#include <vrecko/Device.h>
#include <vrecko/EventDispatcher.h>
#include <vrecko/ReaderWriter.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM Directory Reference

  • src
  • vreckoDP
  • PHANToM
PHANToM Directory Reference

Files

file | AntiGravityFilter.cpp
file | AntiGravityFilter.h [code]
file | CameraMovementFilter.cpp
file | CameraMovementFilter.h [code]
file | ClampFilter.cpp
file | ClampFilter.h [code]
file | CollisionFilterBase.cpp
file | CollisionFilterBase.h [code]
file | CollisionPauseFilter.cpp
file | CollisionPauseFilter.h [code]
file | DampingForceFilter.cpp
file | DampingForceFilter.h [code]
file | DP_PHANToM.cpp
file | FadeFilter.cpp
file | FadeFilter.h [code]
file | KalmanFilter.cpp
file | KalmanFilter.h [code]
file | LoggingFilter.cpp
file | LoggingFilter.h [code]
file | MultiplyFilter.cpp
file | MultiplyFilter.h [code]
file | PHANToM_Device.cpp
file | PointShellVSVoxelFilter.cpp
file | PointShellVSVoxelFilter.h [code]
file | precompiled.cpp
file | precompiled.h [code]
file | SetForceFilter.cpp
file | SetForceFilter.h [code]
file | SetObjectTransformFilter.cpp
file | SetObjectTransformFilter.h [code]
file | SNCHForceFilter.cpp
file | SNCHForceFilter.h [code]
file | VirtualCouplingEffectorFilter.cpp
file | VirtualCouplingEffectorFilter.h [code]
file | VisualizeFilter.cpp
file | VisualizeFilter.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/AntiGravityFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
AntiGravityFilter.cpp File Reference
#include "precompiled.h"
#include "AntiGravityFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/AntiGravityFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
AntiGravityFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CameraMovementFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CameraMovementFilter.cpp File Reference
#include "precompiled.h"
#include "CameraMovementFilter.h"
#include <vreckoDP/PHANToM/PHANToM_Device.h>
#include <vreckoDP/base/KeyboardMouse.h>
#include <osg/Timer>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CameraMovementFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CameraMovementFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/ClampFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
ClampFilter.cpp File Reference
#include "precompiled.h"
#include "ClampFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/ClampFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
ClampFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionFilterBase.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionFilterBase.cpp File Reference
#include "precompiled.h"
#include "CollisionFilterBase.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionFilterBase.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionFilterBase.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionPauseFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionPauseFilter.cpp File Reference
#include "precompiled.h"
#include "CollisionPauseFilter.h"
#include "VirtualCouplingEffectorFilter.h"
#include <vreckoDP/PHANToM/PHANToM_Device.h>
#include <vreckoDP/base/KeyboardMouse.h>
#include <osg/Timer>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionPauseFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionPauseFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/DampingForceFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
DampingForceFilter.cpp File Reference
#include "precompiled.h"
#include "DampingForceFilter.h"
#include <vreckoDP/base/KeyboardMouse.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/DampingForceFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
DampingForceFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/DP_PHANToM.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
Functions | Variables
DP_PHANToM.cpp File Reference
#include "precompiled.h"
#include <vreckoDP/PHANToM/PHANToM_Device.h>
#include <string>

Functions

const char * | PHANToM_getPluginDescription (void)
const char DP_EXPORT ** | PHANToM_getDeviceList (void)
const char DP_EXPORT * | PHANToM_getDeviceDescription (const char *name)
Device DP_EXPORT * | PHANToM_getDeviceInstance (const char *_name)
void DP_EXPORT | PHANToM_setDevicesParameters (void)

Variables

const char * | _plugin_name = { "PHANToM" }
const char * | _device_name []
const char * | _device_description []
Device * _new_device

Function Documentation

const char DP_EXPORT* PHANToM_getDeviceDescription ( const char * name )
Device DP_EXPORT* PHANToM_getDeviceInstance ( const char * _name )
const char DP_EXPORT** PHANToM_getDeviceList ( void )
const char* PHANToM_getPluginDescription ( void )
void DP_EXPORT PHANToM_setDevicesParameters ( void )

Variable Documentation

const char* _device_description[]
Initial value:
= {
""}
const char* _device_name[]
Initial value:
= {
NULL}
Device* _new_device
const char* _plugin_name = { "PHANToM" }
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/FadeFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
FadeFilter.cpp File Reference
#include "precompiled.h"
#include "FadeFilter.h"
#include <osg/Timer>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/FadeFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
FadeFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/KalmanFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
KalmanFilter.cpp File Reference
#include "precompiled.h"
#include "KalmanFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/KalmanFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
KalmanFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/LoggingFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
LoggingFilter.cpp File Reference
#include "precompiled.h"
#include "LoggingFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/LoggingFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
LoggingFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/MultiplyFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
MultiplyFilter.cpp File Reference
#include "precompiled.h"
#include "MultiplyFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/MultiplyFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
MultiplyFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/PHANToM_Device.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
PHANToM_Device.cpp File Reference
#include "precompiled.h"
#include "SNCHForceFilter.h"
#include "DampingForceFilter.h"
#include "SetObjectTransformFilter.h"
#include "VirtualCouplingEffectorFilter.h"
#include "ClampFilter.h"
#include "SetForceFilter.h"
#include "VisualizeFilter.h"
#include "KalmanFilter.h"
#include "PointShellVSVoxelFilter.h"
#include "MultiplyFilter.h"
#include "AntiGravityFilter.h"
#include "CameraMovementFilter.h"
#include "CollisionPauseFilter.h"
#include "FadeFilter.h"
#include "LoggingFilter.h"
#include "../../vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h"
#include <vrecko/Scene.h>
#include <xercesc/dom/DOMNamedNodeMap.hpp>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/PointShellVSVoxelFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
PointShellVSVoxelFilter.cpp File Reference
#include "precompiled.h"
#include "PointShellVSVoxelFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/PointShellVSVoxelFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
PointShellVSVoxelFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
precompiled.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>
#include <termio.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <map>
#include <string>
#include <osg/Matrix>
#include <osg/Quat>
#include <osg/Vec3>
#include <vrecko/Device.h>
#include <vrecko/Logger.h>
#include <vrecko/SP_SceneInterface.h>
#include <vrecko/ReaderWriter.h>
#include <vrecko/Scene.h>
#include <base/SystemInfo.h>
#include <base/MTMatrixTransform.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetForceFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetForceFilter.cpp File Reference
#include "precompiled.h"
#include "SetForceFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetForceFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetForceFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetObjectTransformFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetObjectTransformFilter.cpp File Reference
#include "precompiled.h"
#include "SetObjectTransformFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetObjectTransformFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetObjectTransformFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SNCHForceFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SNCHForceFilter.cpp File Reference
#include "precompiled.h"
#include "SNCHForceFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SNCHForceFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SNCHForceFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VirtualCouplingEffectorFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VirtualCouplingEffectorFilter.cpp File Reference
#include "precompiled.h"
#include "VirtualCouplingEffectorFilter.h"
#include <vreckoDP/base/KeyboardMouse.h>
#include <vrecko/SP_ObjectInterface.h>
#include <vrecko/PluginManager.h>
#include "../../vreckoAP/SpacePartitioning/SNCH_Object_Data.h"
#include "../../vreckoAP/SpacePartitioning/PointShell_Object_Data.h"
#include "../../vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VirtualCouplingEffectorFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VirtualCouplingEffectorFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VisualizeFilter.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VisualizeFilter.cpp File Reference
#include "precompiled.h"
#include "VisualizeFilter.h"
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VisualizeFilter.h File Reference

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VisualizeFilter.h File Reference
#include <vreckoDP/PHANToM/PHANToM_Device.h>

Go to the source code of this file.

Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils Directory Reference

  • src
  • vreckoUtils
vreckoUtils Directory Reference

Files

file | HighlightCallback.cpp
file | Math.cpp
file | Menu.cpp
file | Observer.cpp
file | precompiled.cpp
file | precompiled.h [code]
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/HighlightCallback.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
Namespaces
HighlightCallback.cpp File Reference
#include "precompiled.h"
#include <vreckoUtils/HighlightCallback.h>

Namespaces

namespace vreckoUtils
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Math.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
Namespaces
Math.cpp File Reference
#include "precompiled.h"
#include <vreckoUtils/Math.h>

Namespaces

namespace vreckoUtils
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Menu.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
Menu.cpp File Reference
#include "precompiled.h"
#include <vreckoUtils/Menu.h>
Generated on Sun Feb 17 2013 23:29:52 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/Observer.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
Observer.cpp File Reference
#include "precompiled.h"
#include <vreckoUtils/Observer.h>
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/precompiled.cpp File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
precompiled.cpp File Reference
#include "precompiled.h"
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/precompiled.h File Reference

  • File List
  • File Members
  • src
  • vreckoUtils
Macros
precompiled.h File Reference
#include <osg/Vec2>
#include <osg/Vec3>
#include <osg/Vec4>
#include <osg/Node>
#include <osg/Matrix>
#include <osg/Quat>
#include <osg/MatrixTransform>
#include <osg/Timer>
#include <osg/Notify>
#include <osg/Group>
#include <osgDB/DynamicLibrary>
#include <osgText/Text>
#include <osgViewer/Viewer>
#include <esg/Definitions.h>
#include <esg/OSGAdapter.h>
#include <stdio.h>
#include <vector>
#include <string>
#include <fstream>
#include <sstream>
#include <set>
#include <list>
#include <map>
#include <time.h>
#include <windows.h>
#include <xercesc/util/XercesDefs.hpp>
#include <xercesc/dom/DOM.hpp>
#include <xercesc/util/XMLString.hpp>
#include <xercesc/parsers/AbstractDOMParser.hpp>
#include <helpers/StringHelpers.h>
#include <iostream>

Go to the source code of this file.

Macros

#define WIN32_LEAN_AND_MEAN

Macro Definition Documentation

#define WIN32_LEAN_AND_MEAN
Generated on Sun Feb 17 2013 23:29:51 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- _ -

  • __HEAD_TRACKING_H : HeadTracking.h
  • __HEAD_TRACKING_UTILS_H : htUtils.h
  • __SCREEN_SETUP_H : ScreenSetup.h
  • __SCREEN_SETUP_SIMPLE_H : ScreenSetupSimple.h
  • __SOLVER_H : Solver.h
  • _Atmospheric_ability_description : _AP_Atmospheric.cpp
  • _Atmospheric_ability_name : _AP_Atmospheric.cpp
  • _Atmospheric_plugin_name : _AP_Atmospheric.cpp
  • _base_device_description : DP_base.cpp
  • _base_device_name : DP_base.cpp
  • _base_plugin_name : DP_base.cpp
  • _boids_ability_description : AP_boids.cpp
  • _boids_ability_name : AP_boids.cpp
  • _boids_plugin_name : AP_boids.cpp
  • _CarSim_ability_description : AP_CarSim.cpp
  • _CarSim_ability_name : AP_CarSim.cpp
  • _CarSim_plugin_name : AP_CarSim.cpp
  • _device_description : DP_Kinect.cpp , DP_PHANToM.cpp
  • _device_name : DP_Kinect.cpp , DP_PHANToM.cpp
  • _DynamicArt_ability_name : AP_DynamicArt.cpp
  • _DynamicArt_plugin_name : AP_DynamicArt.cpp
  • _EO_owner : AvatarInHand.cpp
  • _eye_separation : Main.cpp
  • _fullscreen : Main.cpp
  • _height : Main.cpp
  • _navigation_ability_name : AP_navigation.cpp
  • _navigation_plugin_name : AP_navigation.cpp
  • _new_ability : AP_VirtualFixture.cpp , AP_DynamicArt.cpp , AP_navigation.cpp , AP_PhysX.cpp , AP_CarSim.cpp , AP_base.cpp
  • _new_device : DP_base.cpp , DP_PHANToM.cpp
  • _PhysX_ability_description : AP_PhysX.cpp
  • _PhysX_ability_name : AP_PhysX.cpp
  • _PhysX_plugin_name : AP_PhysX.cpp
  • _plugin_name : DP_PHANToM.cpp , DP_Kinect.cpp
  • _screen_distance : Main.cpp
  • _screen_height : Main.cpp
  • _screen_width : Main.cpp
  • _stereo : Main.cpp
  • _USE_MATH_DEFINES : SNCH_Object.cpp
  • _VirtualFixture_ability_description : AP_VirtualFixture.cpp
  • _VirtualFixture_ability_name : AP_VirtualFixture.cpp
  • _VirtualFixture_plugin_name : AP_VirtualFixture.cpp
  • _width : Main.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- a -

  • ABATAR_H : Avatar.h
  • ability_description : AP_base.cpp
  • ability_name : AP_base.cpp
  • ABILITYMAPPER_ID : EditorController.cpp
  • absf : MTCreatorTool.cpp , precompiled.h , ColorPicker.cpp
  • ACT_PAIR : SNCH_Object.cpp
  • ADD_DIFERENCE_TO_FACE : ConnectEditor_Connecting.cpp
  • ADDITIONX : Auxiliary.h
  • ADDITIONY : Auxiliary.h
  • ADDITIONZ : Auxiliary.h
  • addLinesToEo() : functions.h , functions.cpp
  • addLinesToScene() : functions.h , functions.cpp , functions.h
  • addMeshToScene() : functions.h , functions.cpp
  • addPointToScene() : functions.h , functions.cpp
  • addPointToScene90() : functions.cpp , functions.h
  • addVerticesToScene() : functions.h , functions.cpp
  • ANALOG_BITS : hci.h
  • ANALOG_HI_BIT : hci.h
  • ANALOG_LO_BIT : hci.h
  • angle : arm.h
  • angle_format : arm.h
  • angle_units : arm.h
  • AngleCos() : PreloaderHeuristic.cpp
  • ANIMATION_TIME : Camera.h
  • ANIMATOR_IMP_EXP : Animator.h
  • antiAliasSamples : Main.cpp
  • AP_HELLOWORLD : AP_HelloWorld.h
  • ARM_LENGTH : AvatarInHand.cpp
  • arm_result : classes.h
  • ArtificialWorld_getAbilityDescription() : AP_ArtificialWorld.h , AP_ArtificialWorld.cpp
  • ArtificialWorld_getAbilityInstance() : AP_ArtificialWorld.h , AP_ArtificialWorld.cpp
  • ArtificialWorld_getAbilityList() : AP_ArtificialWorld.h , AP_ArtificialWorld.cpp
  • ArtificialWorld_getPluginDescription() : AP_ArtificialWorld.cpp , AP_ArtificialWorld.h
  • ArtificialWorld_initializeAttributesDescription() : AP_ArtificialWorld.h
  • ArtificialWorld_setAbilitiesParameters() : AP_ArtificialWorld.cpp , AP_ArtificialWorld.h
  • ASSERT_POINT_INDEX : Animator.cpp
  • ASSURE_FACES_SIZE : SNCH_Object.cpp
  • ASSURE_MINSPHEREDIST : SNCH_Object.cpp
  • ASSURE_RADIITOGETHER : SNCH_Object.cpp
  • ASSURE_TEMPD : SNCH_Object.cpp
  • Atmospheric_getAbilityDescription() : _AP_Atmospheric.h
  • Atmospheric_getAbilityInstance() : _AP_Atmospheric.cpp , _AP_Atmospheric.h
  • Atmospheric_getAbilityList() : _AP_Atmospheric.cpp , _AP_Atmospheric.h
  • Atmospheric_getPluginDescription() : _AP_Atmospheric.cpp , _AP_Atmospheric.h
  • Atmospheric_initializeAttributesDescription() : _AP_Atmospheric.h
  • AUTO_RUN : Camera.h
  • AUTOSAVE_PATH : precompiled.h
  • AVATAR_DELTA_CALC : Avatar.cpp
  • AVERAGE_CAR_DEC : CarState.h
  • AVERAGE_CAR_LENGTH : CarState.h
  • AW_DEBUG_ONLY : awHelper.h
  • AWAY_PER_CHAR_TIME : Console.cpp
  • AWAY_PER_LINE_TIME : Console.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- b -

  • BAD_FORMAT : hci.h , Hci.cpp
  • BAD_PACKET : Hci.cpp , hci.h
  • BAD_PASSWORD : hci.h , Hci.cpp
  • BAD_PORT_NUM : Hci.cpp , hci.h
  • BAD_VERSION : hci.h , Hci.cpp
  • BASE : arm.h
  • BASE_CALIBRATION_STRING : Device.h
  • base_getDeviceDescription() : DP_base.h , DP_base.cpp
  • base_getDeviceInstance() : DP_base.cpp , DP_base.h
  • base_getDeviceList() : DP_base.h , DP_base.cpp
  • base_getPluginDescription() : DP_base.h , DP_base.cpp
  • base_setDevicesParameters() : DP_base.h , DP_base.cpp
  • BASEK1 : Filter.h
  • BASEK2 : Filter.h
  • BAUD : classes.h
  • BAUDCODE : classes.h
  • BEGIN_STR : Hci.cpp
  • behindO_getAbilityDescription() : AP_behindO.h
  • behindO_getAbilityInstance() : AP_behindO.h
  • behindO_getAbilityList() : AP_behindO.h
  • behindO_getPluginDescription() : AP_behindO.h
  • behindO_initializeAttributesDescription() : AP_behindO.h
  • behindO_setAbilitiesParameters() : AP_behindO.h
  • bevel_2d() : triangleCube.h , triangleCube.cpp
  • bevel_3d() : triangleCube.h , triangleCube.cpp
  • BF_CLOSE_HANDLE : BufFile.cpp
  • BF_GET_FILE_SIZE : BufFile.cpp
  • BF_SET_FILE_POINTER : BufFile.cpp
  • BFAILGOTO : HelperMacros.h
  • BFAILGOTO_TEXT : HelperMacros.h
  • BFAILRET : HelperMacros.h
  • BFAILRET_TEXT : HelperMacros.h
  • BLINK_LENGTH : CarExecutionUnit.h
  • BLINK_LIGHT : CarExecutionUnit.h
  • BMW_LP : RoadsState.cpp
  • BMW_WHITE_LP : RoadsState.cpp
  • boids_getAbilityDescription() : AP_boids.h , AP_boids.cpp
  • boids_getAbilityInstance() : AP_boids.cpp , AP_boids.h
  • boids_getAbilityList() : AP_boids.h , AP_boids.cpp
  • boids_getPluginDescription() : AP_boids.h , AP_boids.cpp
  • boids_initializeAttributesDescription() : AP_boids.h
  • BORDER_CENTER : Border.cpp
  • BOTH_PEDALS : arm.h
  • BRAKE_LIGHT : CarExecutionUnit.h
  • BrushStroke_Interpolation_CATMULLROM : precompiled.h
  • BrushStroke_Interpolation_CIRCLE : precompiled.h
  • BrushStroke_Interpolation_CUBIC : precompiled.h
  • BrushStroke_Interpolation_LINEAR : precompiled.h
  • BrushStroke_Interpolation_NONE : precompiled.h
  • BrushStroke_Interpolation_USER_PREDEFINED : precompiled.h
  • BrushStrokeInterpolationType : precompiled.h
  • BufferedSplinePtr : BufferedSpline.h
  • BUFFILE_BEHVF_LOADFILETOMEM : BufFile.h
  • BUFFILE_BEHVF_UNICODE_START_HIDE : BufFile.h
  • BUFFILE_INITBUFFERSIZE : BufFile.h
  • BUFFILE_MAXBUFFILESIZE : BufFile.h
  • BUFFILE_MINBUFFERSIZE : BufFile.h
  • BUFSIZE : NestOfBirds.h , Ultratrak.h
  • BUTTON_MAPABILIES_ID : EditorController.cpp
  • byte : classes.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- c -

  • CA_MENU_CLICKED : ControllableAbility.cpp
  • CableEditor_getAbilityDescription() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_getAbilityInstance() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_getAbilityList() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_getPluginDescription() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_initializeAttributesDescription() : AP_CableEditor.h
  • CableEditor_setAbilitiesParameters() : AP_CableEditor.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR__MASK : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_DONTCARE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCEHIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCESHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_HIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_SHOW : ControllableAbility.h
  • CAINFO_FLAGS_ALL_ACTIVEPOINTER_BUTTONS : ControllableAbility.h
  • CAINFO_FLAGS_ALL_OTHERPOINTER_BUTTONS : ControllableAbility.h
  • CAINFO_FLAGS_NO_AUTO_DEACTIVATE : ControllableAbility.h
  • CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUTPUTS : ControllableAbility.h
  • CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS : ControllableAbility.h
  • CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT : ControllableAbility.h
  • CALC_D : SNCH_Object.cpp
  • CALC_MAXMIN2 : ObjectMovement.cpp
  • CALC_PAIR_FLAGS : SNCH_Object.cpp
  • CalculateVector() : normal.h , normal.cpp
  • CameraMovement_getAbilityDescription() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_getAbilityInstance() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_getAbilityList() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_getPluginDescription() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_initializeAttributesDescription() : AP_CameraMovement.h
  • CameraMovement_setAbilitiesParameters() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraPath_getAbilityDescription() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getAbilityInstance() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getAbilityList() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getPluginDescription() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_initializeAttributesDescription() : AP_CameraPath.h
  • CameraPath_setAbilitiesParameters() : AP_CameraPath.h , AP_CameraPath.cpp
  • CANT_BEGIN : hci.h , Hci.cpp
  • CANT_OPEN_PORT : hci.h , Hci.cpp
  • CAR_BEFORE_END : CarEnvirons.h
  • CAR_BEHIND_STOP_OR_GO_DECISION : CarEnvirons.h
  • CAR_BEHIND_STOP_OR_GO_DECISION_AND_PUT_ASIDE_TO_ROAD_MARGIN : CarEnvirons.h
  • CAR_IN_FRONT_OF_STOP_OR_GO_DECISION : CarEnvirons.h
  • CAR_IN_JUNCTION : CarEnvirons.h
  • CAR_LEFT_JUNCTION : CarEnvirons.h
  • CAR_ON_SHORT_EDGE_BEFORE_JUNC : CarEnvirons.h
  • CarSim_getAbilityDescription() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getAbilityInstance() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getAbilityList() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getPluginDescription() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_initializeAttributesDescription() : AP_CarSim.h
  • CASTS_SHADOW_TRAVERSAL_MASK : EnvironmentObject.h
  • CE_RADIUS_ADJUSTMENT : CableEditor.h
  • CE_RADIUS_RANGE_FROM : CableEditor.h
  • CE_RADIUS_RANGE_TO : CableEditor.h
  • centerOfMass() : functions.h , functions.cpp
  • CFG_ARG_PAUSE : hci.h
  • cfg_args : hci.h , Hci.cpp
  • changeAutoRotationSpeedStep : DAEnvironment.cpp
  • check_line() : triangleCube.h , triangleCube.cpp
  • check_point() : triangleCube.h , triangleCube.cpp
  • clampColor() : math_aux.h , math_aux.cpp
  • clearColour : Main.cpp
  • client_port : Main.cpp
  • CLOSEBYTE : fsPinchGlove.h
  • Clouds_getAbilityDescription() : _AP_Atmospheric.cpp
  • CMD_BYTE : hci.h
  • CMD_TYPE_FILTER_POINT : LHeadTracker.h
  • CMD_TYPE_RCVR_DIMENSIONS : LHeadTracker.h
  • CMD_TYPE_SLAVE_XMITTER_TYPE : LHeadTracker.h
  • CNBB_F_FORCE_AABBOX : Scene.h
  • CNBB_F_NO_SELF_TRANSFORM : Scene.h
  • CNBB_F_ONLY_LOCAL_TRANSFORM : Scene.h
  • COLL_VRECKO_EXPORT : SP_CommonDefs.h
  • COLLINEAR_ORIENTATION : PolygonUtils.cpp
  • COLLISION_FLAGS_ALLOW_INTERSECTIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES : SP_CommonDefs.h
  • COLLISION_FLAGS_NO_CALCULATIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_NO_OLD_COLLISION_DELETION : SP_CommonDefs.h
  • COLLISION_FLAGS_NOCONTACTS : SP_CommonDefs.h
  • COLLISION_FLAGS_ONLY_INTERSECTIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_ONLYSCENETESTS : SP_CommonDefs.h
  • COLLISION_FLAGS_PREFER_NO_CALCULATIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_RAYCASTING : SP_CommonDefs.h
  • COLLISION_FLAGS_RUN_IN_BACKGROUND : SP_CommonDefs.h
  • COLLISION_FLAGS_SINGLECONTACT : SP_CommonDefs.h
  • COLLISION_FLAGS_USE_MTMATRIXTRANSFORM : SP_CommonDefs.h
  • COLLISION_FLAGSMASK_COMPARISON_FLAGS : SP_CommonDefs.h
  • COLPOINT_FLAGS_INTERSECTION_LINE : SP_CommonDefs.h
  • COLPOINT_FLAGS_INVALID : SP_CommonDefs.h
  • COLPOINT_FLAGS_NEG_DIST_PRESENT : SP_CommonDefs.h
  • COLPOINT_FLAGS_NORMALIZED : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__GET : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__MASK : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__SHIFT : SP_CommonDefs.h
  • compute_modulated_ratio() : Grid.cpp
  • ComputePoint() : PreloaderHeuristic.h , PreloaderHeuristic.cpp
  • CON_MAX_LINE : Console.cpp
  • CONE_CENTER : Cone.cpp
  • CONFIG_BIT : hci.h
  • config_file : Main.cpp
  • CONFIG_MIN : hci.h
  • CONNECT_OBJECTS_BIGGER_LOOP : ConnectEditor_Connecting.cpp
  • CONNECTBYTE : fsPinchGlove.h
  • ConnectEditor_getAbilityDescription() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • ConnectEditor_getAbilityInstance() : AP_ConnectEditor.cpp , AP_ConnectEditor.h
  • ConnectEditor_getAbilityList() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • ConnectEditor_getPluginDescription() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • ConnectEditor_initializeAttributesDescription() : AP_ConnectEditor.h
  • ConnectEditor_setAbilitiesParameters() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • CONSOLE_ATTRIB_COLOR_BYTES : Logger.cpp
  • CONSOLE_AWAY_TIME : Console.cpp
  • CONSOLE_BORDER_X_RATIO : Console.h
  • CONSOLE_BORDER_Y_RATIO : Console.h
  • CONSOLE_CHAR_SIZE : Console.h
  • CONSOLE_FONT : Console.h
  • CONSOLE_LINE_SPACE_CHAR_RATIO : Console.h
  • CONSOLE_NO_ANIMATOR : Console.h
  • CONSOLE_SHOW_TIME : Console.cpp
  • CONSOLE_TEXTCOLOR_DEBUG : Console.h
  • CONSOLE_TEXTCOLOR_ERROR : Console.h
  • CONSOLE_TEXTCOLOR_NOTICE : Console.h
  • CONSOLE_TEXTCOLOR_WARNING : Console.h
  • CONSOLE_WINDOW_DEPTH : Console.h
  • CONSOLE_WINDOW_HEIGHT_ADD : Console.cpp
  • CONSOLE_WINDOW_HEIGHT_BORDER_RATIO : LoadingConsole.cpp
  • CONSOLE_WINDOW_HEIGHT_RATIO : LoadingConsole.cpp , Console.cpp
  • CONSOLE_WINDOW_WIDTH_RATIO : LoadingConsole.cpp , Console.cpp
  • CONSTRAINED_ROTATION_DISTANCE : ConstraintDescription.h
  • CONSTRAINED_SNAPPING_DISTANCE : ConstraintDescription.h
  • ConstrainedMovement_getAbilityDescription() : AP_ConstrainedMovement.h , AP_ConstrainedMovement.cpp
  • ConstrainedMovement_getAbilityInstance() : AP_ConstrainedMovement.h , AP_ConstrainedMovement.cpp
  • ConstrainedMovement_getAbilityList() : AP_ConstrainedMovement.h , AP_ConstrainedMovement.cpp
  • ConstrainedMovement_getPluginDescription() : AP_ConstrainedMovement.h , AP_ConstrainedMovement.cpp
  • ConstrainedMovement_initializeAttributesDescription() : AP_ConstrainedMovement.h
  • ConstrainedMovement_setAbilitiesParameters() : AP_ConstrainedMovement.cpp , AP_ConstrainedMovement.h
  • CONTROL_LINE_COLOR : CameraPath.h
  • CONTROL_LINE_WIDTH : CameraPath.h
  • CONTROL_POINT_COLOR : CameraPath.h
  • CONTROL_POINT_RADIUS : CameraPath.h
  • CONTROL_SYSTEM_RIGHT_HAND : Junction.h
  • CONTROL_SYSTEM_TRAFFIC_LIGHTS : Junction.h
  • ControlActualPosition() : Auxiliary.cpp
  • ControlActualPositionReturnCleanPosition() : Auxiliary.cpp
  • CONTROLPOINT : EditorLogic.cpp , Grid.cpp
  • COPLANAR_MAX_ANGLE : ObjectMovement.cpp
  • COPYPROP_GEOMETRY_COPY : CopyProperties.h
  • COPYPROP_GEOMETRY_REF : CopyProperties.h
  • COPYPROP_TRANSFORMATION : CopyProperties.h
  • createBackgroundPlane() : Main.cpp
  • CreateCloudFromVoxels() : GenClouds.h , GenClouds.cpp
  • CreateGround() : OSGskybox.cpp , OSGskybox.h
  • createLoadingScreen() : Main.cpp
  • CreateParticleAABB() : ParticleFactory.cpp , ParticleFactory.h
  • CreateParticleSphere() : ParticleFactory.h , ParticleFactory.cpp
  • createShadowedScene() : CreateShadowedScene.h
  • CreateSkyBox() : OSGskybox.h , OSGskybox.cpp
  • CreateSun() : OSGskybox.cpp , OSGskybox.h
  • CREATOR_FILENAME_ID : ReaderWriter.h
  • CREATOR_FILENAME_ID_SIMPLE : ReaderWriter.h
  • cross() : gm_vec3.h
  • CROSS : triangleCube.cpp
  • Cross() : normal.cpp , normal.h
  • CURRENT_CACHED_DATA_VERSION : PointShell_Object_Data.cpp , VoxelGrid_Object_Data.cpp
  • CURSORS_PATH : precompiled.h
  • CVC_F_DEFAULT : ConnectionViz.h
  • cycleLoadingHourglass() : Main.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- d -

  • DAINLINE : DynamicArray.h
  • dbg : classes.h
  • dbgAtt : Utils.h
  • dbgDE : DAEnvironment.cpp
  • dbgdf : classes.h
  • dbgFS : FilletSpline.cpp
  • dbgGUIC : GUI_Controller.cpp
  • dbgPS : Utils.h
  • dbgsf : classes.h
  • dbgSmS : SmoothedSpline.cpp , TimeLineSpline.cpp
  • DECLARE_AND_CLIP_PID : EditorController.cpp
  • DECLARE_INPUT : IOPins.h
  • DECLARE_OUTPUT : IOPins.h
  • DECLARE_REQUEST_INPUT : IOPins.h
  • DECLARE_REQUEST_OUTPUT : IOPins.h
  • DECLARE_SEARCH_STRUCTS : ObjectAdd.cpp
  • DEF_PGI_PORT : fsPinchGlove.h
  • DEF_PGI_SERIAL : fsPinchGlove.h
  • DEFAULT_CDIR : CameraPath.h
  • DEFAULT_FREQ : player.h
  • DEFAULT_STATESET_VALUE : ObjectEffect.cpp
  • DEFAULT_VECCPW : CameraPath.h
  • DEFAULT_VECPW : CameraPath.h
  • DEGREES : arm.h , Arm.cpp
  • DELETE_ACT_PAIR : SNCH_Object.cpp
  • detailedFragmentShaderSource : grass_shaders_source.h
  • detailedVertexShaderSource : grass_shaders_source.h
  • diff2force : player.cpp
  • DIFF2FORCEMULTIPLIER : Drag.cpp
  • DIR_VECTOR : CameraPath.h
  • display_frequency : Main.cpp
  • displayStereoInfo() : Main.cpp
  • distance() : gm_vec4.h , gm_vec3.h , gm_vec2.h
  • distanceSquared() : gm_vec3.h , gm_vec2.h , gm_vec4.h
  • DM_CLICKEDSTRING_MAXSIZE : DynamicMenu.cpp
  • dot() : gm_vec2.h , gm_vec4.h , gm_vec3.h
  • DTI_EXCLUDEROOT : DynamicTree.h
  • DTI_ONELAYERTRAVERSAL : DynamicTree.h
  • DTI_ONLYLEAVES : DynamicTree.h
  • DUAL_SPLITTING_ANGLE_THRESHOLD : ConstraintDescription.cpp
  • DUAL_SPLITTING_THRESHOLD : ConstraintDescription.cpp
  • DYNAMIC_SPEED : Camera.h
  • DYNAMICART_PATH : precompiled.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- e -

  • EDGE : EditorLogic.cpp , Grid.cpp
  • EDITORCONTROLLER_IMP_EXP : ControllableAbility.h
  • ELBOW : arm.h
  • ELEM_COMP_LIMIT : ObjectMovement.cpp
  • ellipsoid_2a : GenClouds.cpp
  • ellipsoid_2b : GenClouds.cpp
  • ellipsoid_2c : GenClouds.cpp
  • ENCODER_BITS : hci.h
  • ENCODER_HI_BIT : hci.h
  • ENCODER_LO_BIT : hci.h
  • END_PAUSE : hci.h
  • END_SESSION : hci.h
  • ENDBYTE : fsPinchGlove.h
  • ENOUGHT_SMALL_NUMBER : ColorPicker.cpp
  • EOIH_IF_START_BEGINNING : Scene.h
  • EOIH_IF_START_CURRENT : Scene.h
  • EOIH_IF_START_NEXT : Scene.h
  • EPS : triangleCube.cpp
  • EPSILON : functions.cpp , ConstrainedObjectMovement.h , ConnectEditor_icp.cpp , connecting_functions.cpp , SnapObject.cpp
  • ERASE_AREA : ConnectEditor_Connecting.cpp
  • eraseFace() : functions.h , functions.cpp
  • erf() : erf.cpp , erf.h
  • erfc() : erf.cpp , erf.h
  • ERR : fsPinchGlove.h
  • err : GUI_Controller.cpp , Utils.h , InputConnector.cpp
  • EVENTDISPATCHER_PRIORITY : BaseClass.h
  • EXT_PARAM_BLOCK_SIZE : arm.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- f -

  • F() : connecting_functions.h , connecting_functions.cpp
  • F1 : CameraPath.cpp
  • F2 : CameraPath.cpp
  • F3 : CameraPath.cpp
  • F4 : CameraPath.cpp
  • f_act() : GenClouds.cpp , GenClouds.h
  • FACE : PointShell_Object_Data.h , GeometryLoaderBase.cpp , SNCH_Object.cpp , SNCH_Object_Data.cpp , SphereBVH_Object_Data.cpp , VoxelGrid_Object_Data.cpp
  • face_plane() : triangleCube.h , triangleCube.cpp
  • FACESNCH_NO_GROUP : SNCH_Object_Data.h
  • FFDEditor_getAbilityDescription() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_getAbilityInstance() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_getAbilityList() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_getPluginDescription() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_initializeAttributesDescription() : AP_FFDEditor.h
  • FFDEditor_setAbilitiesParameters() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FIELD_SIZE : PointShell_Object_Data_Geometry_Analyser.h
  • FILL_HOLES_ONE_TRIANGLE_REPLACED_BY_MANY : ConnectEditor_Connecting.cpp
  • FILL_HOLES_SECOND_TYPE_SINGLE_LINES : ConnectEditor_Connecting.cpp
  • FilletSplinePtr : FilletSpline.h
  • FIND_HOLES : ConnectEditor_Connecting.cpp
  • findClosestPoint() : functions.cpp , functions.h
  • findClosestPointNorm() : functions.h , functions.cpp
  • findClosestPointOnFace() : functions.h , functions.cpp
  • findClosestPointOnLine() : functions.cpp , functions.h
  • FindMediaFile() : MediaPath.h
  • findXMLNode() : XercesXMLUtils.cpp , XercesXMLUtils.h
  • FloatVector : wavefront.cpp
  • FOR_ALL_BUTTONS : EditorController.cpp
  • FOR_ALL_POINTERS : EditorController.cpp
  • ForceTransformFunction() : Auxiliary.cpp
  • FOREARM : arm.h
  • FRAME_BUF_SIZE : classes.h
  • FRAME_FREQUENCY : Scheduler.h
  • FRONT_LIGHT : CarExecutionUnit.h
  • FUTURE_BIT : hci.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- g -

  • g_AbilityDesc : AP_ObjectUtils.cpp
  • g_AbilityName : AP_ObjectUtils.cpp
  • g_Anisotropic_scattering : CloudsManager.cpp , CloudsManager.h
  • g_CloudData : Clouds.cpp
  • g_Clouds : CloudsManager.h , CloudsManager.cpp
  • g_font3D : GUI_item.cpp
  • g_MultipleForwardScattering : CloudsManager.h , CloudsManager.cpp
  • g_pAbilityDesc : AP_HapticCollisionApp.cpp , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_LightsEditor.cpp , AP_Menu.cpp , AP_CableEditor.cpp , AP_Nature.cpp , AP_ShootingSimulation.cpp , AP_CameraPath.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_FFDEditor.cpp
  • g_pAbilityName : AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_LightsEditor.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_CableEditor.cpp , AP_CameraPath.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_FFDEditor.cpp , AP_HapticCollisionApp.cpp
  • g_pAPCameraMovementAbilityDesc : AP_CameraMovement.cpp
  • g_pAPCameraMovementAbilityName : AP_CameraMovement.cpp
  • g_pAPCameraMovementPluginName : AP_CameraMovement.cpp
  • g_pAPConnectEditorAbilityDesc : AP_ConnectEditor.cpp
  • g_pAPConnectEditorAbilityName : AP_ConnectEditor.cpp
  • g_pAPConnectEditorPluginName : AP_ConnectEditor.cpp
  • g_pAPConstrainedMovementAbilityDesc : AP_ConstrainedMovement.cpp
  • g_pAPConstrainedMovementAbilityName : AP_ConstrainedMovement.cpp
  • g_pAPConstrainedMovementPluginName : AP_ConstrainedMovement.cpp
  • g_pAPGardenAbilityDesc : AP_Garden.cpp
  • g_pAPGardenAbilityName : AP_Garden.cpp
  • g_pAPGardenPluginName : AP_Garden.cpp
  • g_pArtificialWorldAbilityDescription : AP_ArtificialWorld.cpp
  • g_pArtificialWorldAbilityName : AP_ArtificialWorld.cpp
  • g_pArtificialWorldPluginName : AP_ArtificialWorld.cpp
  • g_pGUIAbilityDesc : AP_GUI.cpp
  • g_pGUIAbilityName : AP_GUI.cpp
  • g_pGUIPluginName : AP_GUI.cpp
  • g_pInputConnectorAbilityDesc : AP_InputConnector.cpp
  • g_pInputConnectorAbilityName : AP_InputConnector.cpp
  • g_pInputConnectorPluginName : AP_InputConnector.cpp
  • g_PluginName : AP_ObjectUtils.cpp
  • g_pPluginDesc : AP_HeadTracking.cpp
  • g_pPluginName : AP_CableEditor.cpp , AP_CameraPath.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_FFDEditor.cpp , AP_HapticCollisionApp.cpp , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_LightsEditor.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp
  • Garden_getAbilityDescription() : AP_Garden.h , AP_Garden.cpp
  • Garden_getAbilityInstance() : AP_Garden.h , AP_Garden.cpp
  • Garden_getAbilityList() : AP_Garden.h , AP_Garden.cpp
  • Garden_getPluginDescription() : AP_Garden.h , AP_Garden.cpp
  • Garden_initializeAttributesDescription() : AP_Garden.h
  • Garden_setAbilitiesParameters() : AP_Garden.h , AP_Garden.cpp
  • GENERAL_MAX_JUNC_SPEED : RoadsState.cpp
  • gestures : Drag.cpp
  • GET_COMMENT : hci.h
  • GET_EXT_PARAMS : hci.h
  • GET_HOME_REF : hci.h
  • GET_MAXES : hci.h
  • GET_MODEL_NAME : hci.h
  • GET_PARAMS : hci.h
  • GET_PRM_FORMAT : hci.h
  • GET_PROD_ID : hci.h
  • GET_PROD_NAME : hci.h
  • GET_SERNUM : hci.h
  • GET_VERSION : hci.h
  • getAbilityDescription() : AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_base.h , AP_EditorController.h , AP_EditorQAbilities.h , AP_Filter.h , AP_GUI.h , AP_HeadTracking.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_base.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp
  • getAbilityInstance() : AP_base.h , AP_DynamicArt.h , AP_EditorController.h , AP_EditorQAbilities.h , AP_Filter.h , AP_games.h , AP_GUI.h , AP_HeadTracking.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_base.cpp , AP_DynamicArt.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp
  • getAbilityList() : AP_ShootingSimulation.cpp , AP_HapticCollisionApp.h , AP_EditorController.cpp , AP_SpacePartitioning.h , AP_HeadTracking.h , AP_EditorQAbilities.h , AP_base.h , AP_DynamicArt.h , AP_EditorController.h , AP_Filter.h , AP_games.h , AP_GUI.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_TextOutput.h , AP_base.cpp , AP_DynamicArt.cpp , AP_EditorQAbilities.cpp , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp
  • getAngle() : normal.h , normal.cpp
  • getCurrentTime() : Timing.h , Timing.cpp
  • getDeviceDescription() : DP_Kinect.h , DP_Kinect.cpp
  • getDeviceInstance() : DP_Kinect.h , DP_Kinect.cpp
  • getDeviceList() : DP_Kinect.h , DP_Kinect.cpp
  • getElapsedTime() : Timing.h , Timing.cpp
  • getFacesOf() : functions.h , functions.cpp
  • getFileExtension() : StringHelpers.h
  • getFileNameFromPathFile() : StringHelpers.h
  • getFileNameWithoutExt() : StringHelpers.h
  • getFileNameWithoutPath() : StringHelpers.h
  • getFilePath() : StringHelpers.h
  • getGeodeOf() : functions.h , functions.cpp
  • getGeometryOf() : functions.h , functions.cpp
  • getMatrixOfRotation() : functions.cpp , functions.h , functions.cpp
  • getMergeMatrix() : functions.h , functions.cpp
  • getNodeTextTrans() : XercesXMLUtils.h , XercesXMLUtils.cpp
  • getNormalsOf() : functions.h , functions.cpp
  • getNumScreens() : Main.cpp
  • getPluginDescription() : AP_Filter.h , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HUD.cpp , AP_ObjectUtils.cpp , AP_SpacePartitioning.cpp , DP_Kinect.cpp , AP_TextOutput.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_HUD.h , AP_InputConnector.cpp , AP_HelloWorld.cpp , AP_ObjectUtils.h , AP_EditorQAbilities.cpp , AP_SpacePartitioning.h , AP_GUI.cpp , DP_Kinect.h , AP_EditorController.cpp , AP_Nature.h , AP_Menu.h , AP_EditorQAbilities.h , AP_ShootingSimulation.cpp , AP_EditorController.h , AP_HeadTracking.cpp , AP_HelloWorld.h , AP_base.h , AP_GUI.h , AP_HeadTracking.h , AP_InputConnector.h , AP_ShootingSimulation.h , AP_TextOutput.h , AP_base.cpp
  • getRelativePath() : StringHelpers.h
  • GetTempFilePath() : MediaPath.h
  • getVerticesOf() : functions.cpp , functions.h
  • gm2PI : gm_const.h
  • gmAbs() : gm_utils.h
  • gmCeil() : gm_utils.h
  • gmClamp() : gm_utils.h
  • gmCube() : gm_utils.h
  • gmDegrees() : gm_utils.h
  • gmDEGTORAD : gm_const.h
  • gmE : gm_const.h
  • gmEEXPPI : gm_const.h
  • gmEPSILON : gm_const.h
  • gmFloor() : gm_utils.h
  • gmFuzEQ() : gm_utils.h
  • gmFuzGEQ() : gm_utils.h
  • gmFuzLEQ() : gm_utils.h
  • gmGOLDEN : gm_const.h
  • gmGOOGOL : gm_const.h
  • gmInv() : gm_utils.h
  • gmINVPI : gm_const.h
  • gmIsZero() : gm_utils.h
  • gmLerp() : gm_utils.h
  • gmLN10 : gm_const.h
  • gmLN2 : gm_const.h
  • gmLOG10E : gm_const.h
  • gmLOG2E : gm_const.h
  • gmMax() : gm_utils.h
  • gmMin() : gm_utils.h
  • gmPI : gm_const.h
  • gmPIDIV2 : gm_const.h
  • gmPIDIV4 : gm_const.h
  • gmRadians() : gm_utils.h
  • gmRADTODEG : gm_const.h
  • gmRound() : gm_utils.h
  • gmSign() : gm_utils.h
  • gmSlide() : gm_utils.h
  • gmSmooth() : gm_utils.h
  • gmSqr() : gm_utils.h
  • gmSQRT10 : gm_const.h
  • gmSQRT2 : gm_const.h
  • gmSQRT2PI : gm_const.h
  • gmSQRT3 : gm_const.h
  • gmSQRTE : gm_const.h
  • gmSQRTHALF : gm_const.h
  • gmSQRTLN2 : gm_const.h
  • gmSQRTPI : gm_const.h
  • gmSwap() : gm_utils.h
  • gmTrunc() : gm_utils.h
  • gmZSign() : gm_utils.h
  • GROUPS_MAX_NORMAL_DIFFERENCE : SNCH_Object_Data.cpp
  • GrowthSimulation() : GenClouds.h , GenClouds.cpp
  • GUI_EXPORT : Icon.h , Menu.h , GUI_Text.h , GUI_Controller.h , ColorPicker.h , Slider.h , IconColour.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- h -

  • HALF_LINE_APPROXIMATION_NUMBER : SNCH_Object.cpp
  • handle_tracker() : OptiTrack.cpp
  • HCI_CHECK_BGND : hci.h
  • HCI_CHECK_FGND : hci.h
  • HCI_CHECK_MOTION : hci.h
  • hci_result : classes.h
  • HELPERS_IMP_EXP : XercesXMLUtils.h , StringHelpers.h
  • HF_VECS_COEF : RoadsState.cpp
  • HILL_ACC_COEF : CarState.h
  • hittedobject : NavSphere.cpp
  • HOLDFORCE : player.cpp
  • HOME_POS : hci.h
  • HORIZ_ALIGN_OUTER : KeepOnScreen.h
  • HORIZONTAL_MAX_ANGLE : ObjectMovement.cpp
  • HTD_CMD_DEMAND : LHeadTracker.h
  • HTD_CMD_DIAG : LHeadTracker.h
  • HTD_CMD_REPORT : LHeadTracker.h
  • HTD_CMD_RESET : LHeadTracker.h
  • HTD_COMMAND_LEN : LHeadTracker.h
  • htd_flush : LHeadTracker.h
  • HTD_PACKET_LEN : LHeadTracker.h
  • HTI_2MAX_NUM : LHeadTracker.h
  • HTI_CLOSEBYTE : LHeadTracker.h
  • HTI_CONNECTBYTE : LHeadTracker.h
  • HTI_MAX_NUM : LHeadTracker.h
  • HTI_MIN_POS_DIFF : LHeadTracker.h
  • HTI_MIN_ROT_DIFF : LHeadTracker.h
  • HTI_POS_C : LHeadTracker.h
  • HTI_ROT_C : LHeadTracker.h
  • HUD_EXPORT : HUDDisplay.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- i -

  • ICON__BUTTON : Icon.h
  • ICON__MULTISWITCH : Icon.h
  • ICON__SWITCH : Icon.h
  • IconType : Icon.h
  • IF_DIST__TEST_AND_SAVE : SNCH_Object.cpp
  • IF_DIST_END : SNCH_Object.cpp
  • if_err : LHeadTracker.h , fsPinchGlove.h
  • if_nonull : fsPinchGlove.h
  • if_notok : fsPinchGlove.h
  • if_null : fsPinchGlove.h
  • if_ok : fsPinchGlove.h
  • IFLAGS : Serial.cpp
  • INCHES : Arm.cpp , arm.h , Arm.cpp
  • includeFace() : functions.h , functions.cpp
  • init() : HoopShape.cpp
  • INIT_INPUT : IOPins.h
  • INIT_INPUT_EXTNAME : IOPins.h
  • INIT_OUTPUT : IOPins.h
  • INIT_OUTPUT_EXTNAME : IOPins.h
  • INIT_REQUEST_INPUT : IOPins.h
  • INIT_REQUEST_INPUT_EXTNAME : IOPins.h
  • INIT_REQUEST_OUTPUT : IOPins.h
  • INIT_REQUEST_OUTPUT_EXTNAME : IOPins.h
  • InitCloudGrowth() : GenClouds.h , GenClouds.cpp
  • initializeAttributesDescription() : AP_EditorController.h , AP_EditorQAbilities.h , AP_Filter.h , AP_GUI.h , AP_HeadTracking.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_HapticCollisionApp.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_DynamicArt.cpp , AP_base.h , AP_DynamicArt.h
  • INPUTCONNECTOR_EXPORT : InputConnector.h
  • INSERT_MARKER : hci.h
  • INSERT_PAIR : SNCH_Object.cpp
  • INSIDE : triangleCube.cpp
  • INSTANCE : AP_CarSim.h , DP_PHANToM.h , AP_PhysX.h , AP_VirtualFixture.h , AP_navigation.h , AP_games.h , DP_Kinect.h , AP_boids.h , AP_behindO.h , AP_ode.h , AP_base.h , DP_base.h , _AP_Atmospheric.h , AP_DynamicArt.h , AP_Filter.h
  • InterpolatedSplinePtr : InterpolatedSpline.h
  • INTERPOLATION_CATMULL_ROM_ITERATE : Cable.h
  • INTERPOLATION_CATMULL_ROM_PER_SEGMENT : Cable.h
  • interpolationLinear() : math_aux.cpp , math_aux.h
  • InterpolatorPtr : Interpolator.h
  • IntVector : wavefront.cpp
  • INVALID_SET_FILE_POINTER : BufFile.h
  • INX : osgQ_QShapeDrawable.cpp
  • INX_DIR : osgQ_QShapeDrawable.cpp
  • INY : osgQ_QShapeDrawable.cpp
  • INY_DIR : osgQ_QShapeDrawable.cpp
  • ip_str : Main.cpp
  • IS_CAINFO_VER : ControllableAbility.h
  • isBeginningWith() : StringHelpers.h , StringHelpers.cpp
  • isVisible() : PreloaderHeuristic.cpp
  • IVECO : RoadsState.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- j -

  • JACEPS : icp_functions.cpp
  • jacobi2() : icp_functions.cpp , icp_functions.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- l -

  • L_INDEX : fsPinchGlove.h
  • L_MIDDLE : fsPinchGlove.h
  • L_PINKIE : fsPinchGlove.h
  • L_RING : fsPinchGlove.h
  • L_THUMB : fsPinchGlove.h
  • last_tick : Main.cpp
  • LEFT_BLINKER_TURNED_ON : CarState.h
  • LEFT_HAND_SIDE : PolygonUtils.cpp
  • LEFT_PEDAL : arm.h
  • length : arm.h
  • length_units : arm.h
  • lerp() : gm_vec2.h , gm_vec3.h , gm_vec4.h
  • LERP : triangleCube.cpp
  • LFLAGS : Serial.cpp
  • LIGHT_TURNED_OFF : CarState.h
  • LIGHT_TURNED_ON : CarState.h
  • LightsEditor_getAbilityDescription() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getAbilityInstance() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getAbilityList() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getPluginDescription() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_initializeAttributesDescription() : AP_LightsEditor.h
  • LightsEditor_setAbilitiesParameters() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • line_distance() : gm_vec3.h
  • LIST : AP_behindO.h , AP_boids.h , AP_CarSim.h , AP_DynamicArt.h , AP_Filter.h , AP_games.h , _AP_Atmospheric.h , AP_navigation.h , AP_ode.h , DP_base.h , DP_Kinect.h , DP_PHANToM.h , AP_PhysX.h , AP_VirtualFixture.h , AP_base.h
  • load_config() : Main.cpp
  • loading_category : Main.cpp
  • LOADING_CONSOLE_REAL_LINE_HEIGHT_RATIO : LoadingConsole.cpp
  • loading_description : Main.cpp
  • loading_position : Main.cpp
  • loading_section_Mutex : Main.cpp
  • loading_state : Main.cpp
  • loadingConsole : Main.cpp
  • LOADINGCONSOLE_TEXTCOLOR_DEBUG : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_ERROR : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_NOTICE : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_WARNING : LoadingConsole.cpp
  • LoadingFunction() : Preloader.cpp
  • LoadModelFromCoreModel() : ModelManager.cpp
  • LoadOSGTextureWithColorKey() : Texture.h , Texture.cpp
  • loadVirtualEnvironment() : Main.cpp
  • LOCAL_SEARCH_INSIDE_GLOBAL : SNCH_Object.cpp
  • LOCALSEARCH_CACHE_USE_HASH : SNCH_Object.cpp
  • LOCALSEARCH_USE_CACHE : SNCH_Object.cpp
  • LOG_PI_OVER_2 : erf.cpp
  • LOG_START_TIMING : SNCH_Object.cpp
  • LOG_STOP_TIMING : SNCH_Object.cpp
  • LOG_WRITECOUNTER : SNCH_Object.cpp
  • LOGGER_OT_INTERNALMASK_NORMALTYPES : Logger.h
  • LOGGER_OT_INTERNALMASK_SPECIALTYPES : Logger.h
  • LOGGER_OUTPUTDEST_DEBUGSTRING : Logger.h
  • LOGGER_OUTPUTDEST_FILE : Logger.h
  • LOGGER_OUTPUTDEST_STDOUT : Logger.h
  • LOGGER_OUTPUTDESTMASK_ALL : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_DEBUGSTRING : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_FILE : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_STDOUT : Logger.h
  • LOGGER_OUTPUTDESTMASK_NONE : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUG : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUGFILE : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUGFLUSH : Logger.h
  • LOGGER_OUTPUTTYPE_ERROR : Logger.h
  • LOGGER_OUTPUTTYPE_NOTICE : Logger.h
  • LOGGER_OUTPUTTYPE_TIMINGSFILE : Logger.h
  • LOGGER_OUTPUTTYPE_WARNING : Logger.h
  • LOGGER_OUTPUTTYPEMASK_ALL : Logger.h
  • LOGGER_OUTPUTTYPEMASK_DEBUG : Logger.h
  • LOGGER_OUTPUTTYPEMASK_NONE : Logger.h
  • LOGGER_OUTPUTTYPEMASK_NORMAL : Logger.h
  • LOGGER_OUTPUTTYPEMASK_USER : Logger.h
  • loggerLoadingConsoleOutput() : LoadingConsole.cpp
  • lowDetailFragmentShaderSource : grass_shaders_source.h
  • lowDetailVertexShaderSource : grass_shaders_source.h
  • LS_EDGE_ALL_EDGES : SNCH_Object.cpp
  • LS_EDGE_NO_EDGE : SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- m -

  • main() : Main.cpp
  • MAIN_DEBUG_START_TIMING : Main.cpp
  • MAIN_DEBUG_STOP_TIMING : Main.cpp
  • mainLoop() : Main.cpp
  • mainObject : Main.cpp
  • MASTER_MODE : LHeadTracker.h
  • MATERIALCOUNTERMAX : PHEffect.cpp
  • matrix_4 : arm.h
  • matrixTrace3x3() : functions.h , functions.cpp
  • matrixTranspose4x4() : functions.h , functions.cpp
  • MAX3 : triangleCube.cpp
  • MAX_CAR_LENGTH : CarState.h
  • MAX_CAR_WIDTH : CarState.h
  • MAX_CFG_SIZE : hci.h
  • MAX_CONSTRAINED_SNAPPING_DISTANCE : ConstraintDescription.h
  • MAX_INT : SnapObject.cpp
  • MAX_ITERATIONS : ConnectEditor_icp.cpp
  • MAX_NUMBER_OF_TRACKED_SENSORS : precompiled.h
  • MAX_OUTSTANDING_COUNTERS : Logger.cpp
  • MAX_PACKET_SIZE : hci.h
  • MAX_SNAPPING_PLANES : ObjectMovement.cpp
  • MAX_STRING_SIZE : hci.h
  • MAX_WIIMOTES : Wiimote.h
  • MAXARGS : wavefront.cpp
  • MAXBORDERRADIUS : Auxiliary.h
  • MAXDIST : player.cpp
  • MAXFORCE : Auxiliary.h
  • MENU_BOX_FIRST_X_OFFSET : DynamicMenu.cpp
  • MENU_GRID_X_OFFSET : DynamicMenu.cpp
  • MENU_GRID_Y_OFFSET : DynamicMenu.cpp
  • MENU_NOTAVAILABLE_ITEM_COLOR : precompiled.h
  • MENU_RADIAL_MAXITEMS : DynamicMenu.cpp
  • MENU_SELECTED_ITEM_COLOR : precompiled.h
  • MENUITEM_SUBSIZE_RATIO : DynamicMenu.cpp
  • MENUITEM_TEXT_CHARHEIGHT : DynamicMenu.cpp
  • MENUITEM_TEXT_FONT : DynamicMenu.cpp
  • MENUITEMSLIDER_SAFE_ADDITION : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_SIZE_REL : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_X_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_X_HALF_LENGTH : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Y_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Y_HALF_LENGTH : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Z_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Z_HALF_LENGTH : DynamicMenu.cpp
  • MENUTIEM_BOX_INBETWEENDIST_X : DynamicMenu.cpp
  • MENUTIEM_BOX_INBETWEENDIST_Y : DynamicMenu.cpp
  • MENUTIEM_RADIALSECTION_INBETWEENDIST : DynamicMenu.cpp
  • MERGE_FLAGS_ATTRIB_NAME : ReaderWriter.cpp
  • MERGE_OBJECTS : ConnectEditor_Connecting.cpp
  • META_HoopShapeObject : HoopShape.h
  • METHOD_INPUT() : CarExecutionUnit.cpp , Remover.cpp , RoadsState.cpp , TerrainAbility.cpp , BaseActor.cpp , ShootingSimulation.cpp , IOPins.h , Avatar.cpp , BoidsPlanner.cpp , CarExecutionUnit.cpp
  • METHOD_REQUEST_INPUT() : WorldBuilder.cpp , PhysXScene.cpp , CarExecutionUnit.cpp , PhysXScene.cpp , RoadsState.cpp , PhysXScene.cpp , IOPins.h , RoadsState.cpp , WorldBuilder.cpp , RoadsState.cpp , CarExecutionUnit.cpp , CarPartsNodeCache.cpp , RoadsState.cpp , PhysXScene.cpp , RoadsState.cpp
  • MI_F_EXPANDED : DynamicMenu.h
  • MI_F_SELECTED : DynamicMenu.h
  • MIN3 : triangleCube.cpp
  • MIN_DISTANCE_FROM_EDGE : CreateHole.h
  • MIN_TIMEOUT : classes.h
  • MINBORDERRADIUS : Auxiliary.h
  • MINF : Auxiliary.h
  • MINIMAL_DISTANCE_BETWEEN_CONTROL_POINTS : precompiled.h
  • MINOR() : gm_mat4.cpp , gm_mat3.cpp
  • MM : arm.h , Arm.cpp
  • MORPH_MASTER_VERTICES : ConnectEditor_Morphing.cpp
  • MORPH_SECOND_ITERATION : ConnectEditor_Morphing.cpp
  • MORPH_SLAVE_VERTICES : ConnectEditor_Morphing.cpp
  • MTBRUSH_PARAMETER_CONSTANT : MTBrush.h
  • MTBRUSH_PARAMETER_CURVATURE_BASED : MTBrush.h
  • MTBRUSH_PARAMETER_GRADIENT : MTBrush.h
  • MTBRUSH_PARAMETER_SPEED_BASED : MTBrush.h
  • MTBRUSH_SHAPE_RECTANGE : MTBrush.h
  • MTBRUSH_SHAPE_ROUND : MTBrush.h
  • MTBRUSH_SHAPE_ROUNDED_RECTANGE : MTBrush.h
  • MTBrushParameterType : MTBrush.h
  • MTBrushShapeType : MTBrush.h
  • MTLOCK_IMP_EXP : MTLock.h
  • MTMATRIXTRANSFORM_IMP_EXP : MTMatrixTransform.h
  • MULT : CameraPath.h
  • MULTIPLIER : Auxiliary.h
  • MUTEX_LOCK : ReaderWriter.cpp , World.cpp
  • MUTEX_UNLOCK : World.cpp , ReaderWriter.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- n -

  • navigation_getAbilityInstance() : AP_navigation.h , AP_navigation.cpp
  • navigation_getAbilityList() : AP_navigation.cpp , AP_navigation.h
  • navigation_initializeAttributesDescription() : AP_navigation.h
  • net_flag : Main.cpp
  • NEXT_JUNC_TURN_LEFT : CarEnvirons.h
  • NEXT_JUNC_TURN_RIGHT : CarEnvirons.h
  • nfound : Ultratrak.cpp
  • NO : fsPinchGlove.h
  • NO_HCI : hci.h , Hci.cpp
  • NO_PACKET_YET : hci.h , Hci.cpp
  • NODE : SNCH_Object.cpp , SNCH_Object_Data.cpp , SphereBVH_Object_Data.cpp
  • node : Drag.cpp
  • node2 : Drag.cpp
  • node3 : Drag.cpp
  • node4 : Drag.cpp
  • NOMINMAX : Timing.h , precompiled.h , Timing.cpp
  • NORMAL_EDGE : Edge.h
  • NORMAL_EPSILON : PointShellVSVoxel_Object.cpp
  • NORMAL_OR_SHORT_EDGE_WITHOUT_ANY_LANE : Edge.h
  • normalsVariance() : functions.h , functions.cpp
  • null : Attribute.h
  • NUM_ANALOGS : hci.h
  • NUM_BUTTONS : hci.h
  • num_cfg_args : hci.h , Hci.cpp
  • NUM_DOF : arm.h
  • NUM_ENCODERS : hci.h
  • NUM_PORTS : LHeadTracker.cpp
  • NUM_TABLE_POS : arm.h
  • NUM_TARGETS : ShootingSimulation.h
  • NUM_WII_DEVICES : Wiimote.cpp
  • NX : GenClouds.cpp
  • NXUFTtoa() : Helper.cpp , Helper.h
  • NY : GenClouds.cpp
  • NZ : GenClouds.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- o -

  • ode_getAbilityDescription() : AP_ode.h
  • ode_getAbilityInstance() : AP_ode.h
  • ode_getAbilityList() : AP_ode.h
  • ode_getPluginDescription() : AP_ode.h
  • ode_initializeAttributesDescription() : AP_ode.h
  • ode_setAbilitiesParameters() : AP_ode.h
  • OFLAGS : Serial.cpp
  • OK : fsPinchGlove.h
  • OPACITY_MULTIPLIER : ConstrainedObjectMovement.cpp
  • operator*() : gm_vec4.h , gm_mat3.cpp , gm_mat4.cpp , gm_vec2.h , gm_vec3.h
  • operator<<() : XercesXMLUtils.h , gm_mat3.cpp , gm_mat4.cpp , gm_vec2.h , gm_vec3.h , gm_vec4.h
  • OUTPUTSTR : Logger.h
  • OUTPUTSTR2 : Logger.h
  • OUTPUTSTR3 : Logger.h
  • OUTPUTSTR4 : Logger.h
  • OUTPUTSTR5 : Logger.h
  • OUTPUTSTR6 : Logger.h
  • OUTPUTSTR7 : Logger.h
  • OUTSIDE : triangleCube.cpp
  • OUTX : osgQ_QShapeDrawable.cpp
  • OUTX_DIR : osgQ_QShapeDrawable.cpp
  • OUTY : osgQ_QShapeDrawable.cpp
  • OUTY_DIR : osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- p -

  • p0Normal : SNCH_Object.cpp
  • p1Normal : SNCH_Object.cpp
  • p2pEuclideanDistance() : functions.cpp , functions.h
  • PACKET_MARKER : hci.h
  • PAIR_EXISTS : SNCH_Object.cpp
  • PARAM_BLOCK_SIZE : arm.h
  • parameterB : connecting_functions.cpp
  • parameterO : connecting_functions.cpp
  • parameterU : connecting_functions.cpp
  • PART_THREAD_REQUEST_TIMEOUT : Scene.cpp
  • PARTITIONING_INTERFACE_DEFAULT : SP_CommonDefs.h
  • PASSWD_OK : hci.h
  • PATH_LINE_COLOR : CameraPath.h
  • PATH_LINE_WIDTH : CameraPath.h
  • PATH_POINT_RADIUS : Camera.h
  • pCPhRec : PHANToMAvatar.cpp
  • Perpendiculars() : icp_functions.h , icp_functions.cpp
  • PERSISTENT_CACHE_MODEL_NAME : PersistentCache.cpp
  • PGI_MAX_PACKET_LEN : fsPinchGlove.h
  • PHANToM_getDeviceDescription() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_getDeviceInstance() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_getDeviceList() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_getPluginDescription() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_setDevicesParameters() : DP_PHANToM.h , DP_PHANToM.cpp
  • PhysX_getAbilityDescription() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_getAbilityInstance() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_getAbilityList() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_getPluginDescription() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_initializeAttributesDescription() : AP_PhysX.h
  • PhysX_setAbilitiesParameters() : AP_PhysX.cpp , AP_PhysX.h
  • PI : Cloud.h , arm.h , connecting_functions.cpp
  • PIN_ADDITION : BaseClass.cpp
  • PIN_REMOVAL : BaseClass.cpp
  • plane_distance() : gm_vec3.h
  • plane_intersect() : gm_vec3.h
  • PLANE_X : Main.cpp
  • PLANE_Y : Main.cpp
  • PLANE_Z : Main.cpp
  • PLAYBACK_LAG_DURATION : Ctrl_FreeHandPainting.h
  • pLoadingScreen() : Main.cpp
  • plugin_name : AP_base.cpp
  • pMovingTransformation : Main.cpp
  • point_triangle_intersection() : triangleCube.h , triangleCube.cpp
  • POINTER_ROTATION_MULTIPLIER : ConstrainedObjectMovement.cpp
  • POINTERPOS_RAW_REQUEST_NAME : ControllableAbility.h
  • POINTERPOS_REQUEST_NAME : ControllableAbility.h
  • POINTERROT_RAW_REQUEST_NAME : ControllableAbility.h
  • POINTERROT_REQUEST_NAME : ControllableAbility.h
  • pointToTriangleDistance() : PHANToMAvatar.cpp
  • POLHEMUS_HEADER : Ultratrak.h
  • POLHEMUS_PORT : Ultratrak.h
  • POLHEMUS_PORT2 : Ultratrak.h
  • PRECISE_DISTANCE_CALC : SNCH_Object.cpp
  • PRECISE_SPHERES : SphereBVH_Object_Data.cpp
  • PRINT_VEC : DynamicMenu.cpp
  • printColor() : precompiled.h
  • printErrorMessage() : functions.h , functions.cpp
  • printMessage() : functions.h , functions.cpp , functions.h , functions.cpp
  • printMessageTime() : functions.h , functions.cpp
  • projection_node : Main.cpp
  • ptimer : Drag.cpp
  • pTransformation : Main.cpp
  • pVPosModel : PHANToMAvatar.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- q -

  • quaternionLength() : functions.h , functions.cpp
  • quaternionNormalize() : functions.cpp , functions.h
  • QUICK_3DOF_POINTS : arm.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- r -

  • R_INDEX : fsPinchGlove.h
  • R_MIDDLE : fsPinchGlove.h
  • R_PINKIE : fsPinchGlove.h
  • R_RING : fsPinchGlove.h
  • R_THUMB : fsPinchGlove.h
  • RADIANS : Arm.cpp , arm.h , Arm.cpp
  • randFloat() : math_aux.h , math_aux.cpp
  • randGauss() : math_aux.h , math_aux.cpp
  • ratio : arm.h
  • ray_direction : NavSphere.cpp
  • ray_position : NavSphere.cpp
  • RCD() : gm_mat3.cpp , gm_mat4.cpp
  • RE_DEFAULT_2_WIDTH : Geometry.h
  • RE_DEFAULT_BOTTOM : Geometry.h
  • RE_DEFAULT_COLOR : Geometry.h
  • RE_DEFAULT_HEIGHT : Geometry.h
  • RE_DEG_2_RAD_RATIO : Geometry.h
  • RE_MIN_ANGLE : Geometry.h
  • RE_MIN_LENGTH : Geometry.h
  • RE_WALL_ANGLES_COMPUTED : Geometry.h
  • RE_WALL_DRAWN : Geometry.h
  • READ_XML_FLOAT : Animator.cpp
  • READ_XML_QUAT : Animator.cpp
  • READ_XML_VECTOR : Animator.cpp
  • readfds : Ultratrak.cpp
  • ReceiversList : InputConnector.h
  • RECEIVES_SHADOW_TRAVERSAL_MASK : EnvironmentObject.h
  • recomputeNormals() : normal.h , normal.cpp
  • ref_ptr_DAControlPoint : MTTriangulator.h
  • ref_ptr_MTCreatorTool : MTCreatorTool.h
  • ref_ptr_SimpleBox : MTCreatorTool.h , MTTriangulator.h
  • RegularPolygonSplinePtr : RegularPolygonSpline.h
  • REPAIR_LOOP_TO_LOOP_POSTION : ConnectEditor_Connecting.cpp
  • REPORT_MOTION : hci.h
  • RESTORE_FACTORY : hci.h
  • RESTORE_PAUSE : hci.h
  • RETRIEVE_PAIR : SNCH_Object.cpp
  • REVERSE_VERTEX_INDEX : SNCH_Object_Data.cpp
  • RIGHT_BLINKER_TURNED_ON : CarState.h
  • RIGHT_HAND_SIDE : PolygonUtils.cpp
  • RIGHT_PEDAL : arm.h
  • RoomEdit_getAbilityDescription() : AP_RoomEdit.h
  • RoomEdit_getAbilityInstance() : AP_RoomEdit.h
  • RoomEdit_getAbilityList() : AP_RoomEdit.h
  • RoomEdit_getPluginDescription() : AP_RoomEdit.h
  • RoomEdit_initializeAttributesDescription() : AP_RoomEdit.h
  • RoomEdit_setAbilitiesParameters() : AP_RoomEdit.h
  • RS_LOAD_MODEL : RoadsState.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- s -

  • SAFE_DELETE : HelperMacros.h
  • SAFE_FREE : HelperMacros.h
  • SampledSplinePtr : SampledSpline.h
  • SBVH_PERSISTENT_CACHE_BASE_VERSION : SphereBVH_Object_Data.cpp
  • scenario_name : Main.cpp
  • SEARCH_DONE : ObjectAdd.cpp
  • SEARCH_FILENAME : ObjectAdd.cpp
  • SEARCH_INIT : ObjectAdd.cpp
  • SEARCH_NEXT_FILE_OK : ObjectAdd.cpp
  • SEARCH_START_OK : ObjectAdd.cpp
  • SectorArray : SectorColorGen.h
  • SectorColorGenPtr : SectorColorGen.h
  • SectorPtr : SectorColorGen.h
  • SEL_UPDATE_COLOR_COMPONENT : DynamicMenu.cpp
  • SELECTIONID_REQUEST_NAME : ControllableAbility.h
  • SELECTIONPATH_REQUEST_NAME : ControllableAbility.h
  • SEND_BUTTON : Wiimote.cpp
  • SEND_EVENT : Wiimote.cpp
  • SENSOR_MAX_COUNT : GUI_Controller.h , InputConnector.h
  • ser : Hci.cpp
  • server_port : Main.cpp
  • SET_BAUD : hci.h
  • SET_HOME : hci.h
  • SET_HOME_REF : hci.h
  • SET_PARAMS : hci.h
  • setAbilitiesParameters() : AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_base.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_base.h , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_EditorController.h , AP_EditorQAbilities.h , AP_GUI.h , AP_HeadTracking.h
  • setDevicesParameters() : DP_Kinect.h , DP_Kinect.cpp
  • SG_SAFETY : Scheduler.cpp
  • SHORT_EDGE : Edge.h
  • SHOULDER : arm.h
  • SHOW_LINES_WHILE_ANIMATING : Camera.h
  • SHOW_PROGRESS : VoxelGrid_Object_Data.cpp
  • SHOW_VIEW_LINE : Camera.h
  • SHOW_VISUALS_SAMPLES : MTCreatorTool.cpp
  • ShowModelSettings() : BlockUpdater.cpp
  • SHOWVEC3 : BlockUpdater.h
  • SI_OUT : SystemInfo.cpp
  • SI_UNKNOWN_THREAD_NAME : SystemInfo.h
  • Side() : PreloaderHeuristic.cpp
  • SIGN3 : triangleCube.cpp
  • SIGNON_PAUSE : hci.h
  • SIGNON_STR : Hci.cpp
  • simple_BAD_PACKET() : Arm.cpp , arm.h , Arm.cpp
  • simple_BAD_PORT() : arm.h , Arm.cpp
  • simple_CANT_BEGIN() : Arm.cpp , arm.h
  • simple_CANT_OPEN_PORT() : arm.h , Arm.cpp
  • simple_NO_HCI() : arm.h , Arm.cpp
  • simple_TIMED_OUT() : arm.h , Arm.cpp
  • SINGLE_TIME : ObjectEffect.cpp
  • SLAVE_MODE : LHeadTracker.h
  • SMALL_NUM : ObjectMovement.cpp , Layout.cpp , SNCH_Object.cpp , SNCH_Object_Data.cpp , Slider.cpp
  • SmoothedSplinePtr : SmoothedSpline.h
  • SmoothEnding() : Auxiliary.cpp
  • SMOOTHING_RADIUS : Auxiliary.h
  • SNAP_PLANE_REACH_RATIO : ObjectMovement.cpp
  • SNCH_EDGE_CONCAVE_BREAK : SNCH_Object_Data.h
  • SNCH_FACE_DEGENERATED : SNCH_Object_Data.h
  • SNCH_FLOAT_SMALL_NUM : SNCH_Object.h
  • SNCH_FLOAT_TOLERANCE : SNCH_Object.h
  • SNCH_GROUPS_METHOD : SNCH_Object_Data.cpp
  • SNCH_LMD_F_INTERSECTION : SNCH_Object.h
  • SNCH_LMD_F_NEGATIVE_DISTANCE : SNCH_Object.h
  • SP_OBJECT_INTERFACE_ID__PS_VG : PointShellVSVoxel_Object.h
  • SP_OBJECT_INTERFACE_ID__SNCH : SNCH_Object.h
  • SP_OBJECT_INTERFACE_ID__SPHEREBVH : SphereBVH_Object.h
  • SP_SCENE_INTERFACE_ID__NOPARTITIONING : NoPartitioning_Scene.h
  • SP_SCENE_INTERFACE_ID__SPHEREBVH : SphereBVH_Scene.h
  • SPACEPARTITIONING_IMP_EXP : GeometryLoaderBase.h
  • SPEED : CameraPath.h , AvatarInHand.cpp
  • SPEED2FORCE : PHEffect.cpp
  • SPHERE_RADIUS : Cable.h
  • spheresize : player.cpp
  • STARTBYTE : fsPinchGlove.h
  • STARTTBYTE : fsPinchGlove.h
  • STARTTIMING : Logger.h
  • STARTXBYTE : fsPinchGlove.h
  • STATUS_SUCCESS : SystemInfo.cpp
  • STD_3DOF_POINTS : arm.h
  • STDLIB_H : icp_functions.h
  • STEP : CameraPath.h
  • STOPTIMING : Logger.h
  • strToXerces : ReaderWriter.h
  • STYLUS : arm.h
  • SUB : triangleCube.cpp
  • SUCCESS : Hci.cpp , hci.h
  • SURFACE_BREAK_TEST : SNCH_Object.cpp
  • SURFACE_SMALL_NUM : SNCH_Object_Data.cpp
  • SweepSurfaceGeodePtr : SweepSurfaceGeode.h
  • SYMMETRIES_PATH : precompiled.h
  • SYSTEM_TRAVERSAL_MASK__MASK : EnvironmentObject.h
  • SYSTEM_VISIBLE_OBJECT_TRAVERSAL_MASK : EnvironmentObject.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- t -

  • t_c_intersection() : triangleCube.h , triangleCube.cpp
  • tempBool : Drag.cpp
  • tempChar : Drag.cpp
  • tempFloat : Drag.cpp
  • TEMPLATES_PATH : precompiled.h
  • tempString : Drag.cpp
  • TERMINATOR_EDGE : Edge.h
  • TEST_PAIR_FLAGS_INTERSECTIONS_ONLY : SNCH_Object.cpp
  • thread_main_func() : vThread.cpp
  • thread_main_func2() : vThread.cpp
  • ThreadBasicInformation : SystemInfo.cpp
  • ThreadQuerySetWin32StartAddress : SystemInfo.cpp
  • tim : Hci.cpp
  • TIMED_OUT : Hci.cpp , hci.h
  • TIMELINE__FULLY_VISIBLE : TimeLineSpline.h
  • TIMELINE__ZERO_TIME : TimeLineSpline.h
  • TimeLineSplinePtr : TimeLineSpline.h
  • timeout : Ultratrak.cpp
  • TIMEOUT_CHARS : hci.h
  • timer : Auxiliary.cpp , player.cpp
  • TIMER_BIT : hci.h
  • TL_GREEN : TLsOnJuncManager.h
  • TL_GREEN_INTERV_DEFAULT : Edge.h
  • TL_ORANGE : TLsOnJuncManager.h
  • TL_RED : TLsOnJuncManager.h
  • TL_RED_ORANGE : TLsOnJuncManager.h
  • TMP_VE_PROJ_RES_0_EXCEEDED : SNCH_Object.cpp
  • TMP_VE_PROJ_RES_1_EXCEEDED : SNCH_Object.cpp
  • tmpability : NavSphere.cpp
  • tmpEyePosition() : Avatar.cpp
  • tmpFloat : Avatar.cpp
  • tmpGesture : Drag.cpp
  • tmpLookAtCenter() : Avatar.cpp
  • tmpMVect : Drag.cpp
  • tmpName : Drag.cpp
  • tmpUpVector() : Avatar.cpp
  • TOMS : Timing.cpp
  • ToNxQuat() : Helper.h , Helper.cpp
  • ToNxVec3() : Helper.h , Helper.cpp
  • ToosgQuat() : Helper.cpp , Helper.h
  • ToosgVec3() : Helper.h , Helper.cpp
  • TOP_VECTOR : CameraPath.h
  • TPPS_F_PROJ_BACKWARDS : SNCH_Object.cpp
  • TPPS_F_PROJ_ZERO : SNCH_Object.cpp
  • TPPS_F_VALID : SNCH_Object.cpp
  • TRACKER_MAX_COUNT : OptiTrack.h
  • TRANSPARENCY : Camera.h
  • TRY__AGAIN : Hci.cpp , hci.h
  • TWOPI : ConstraintArea.cpp
  • type : player.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- u -

  • ULTRA_SHORT_EDGE : Edge.h
  • ULTRA_SHORT_EDGE_WITHOUT_ANY_LANE : Edge.h
  • UNDEF : PointShell_Object_Data_Geometry_Analyser.cpp , PointShell_Object_Data_LOD_Builder.cpp , PointShell_Object_Data_Geometry.cpp
  • uniCat() : StringHelpers.h
  • uniCpy() : StringHelpers.h
  • uniLen() : StringHelpers.h
  • uniNCpy() : StringHelpers.h
  • UNINIT_INPUT : IOPins.h
  • UNINIT_OUTPUT : IOPins.h
  • UNINIT_REQUEST_INPUT : IOPins.h
  • UNINIT_REQUEST_OUTPUT : IOPins.h
  • uniStr() : StringHelpers.h
  • UPDATE_CONTROL_POINTS_MIN_DISTANCE : BrushStroke.cpp
  • UPDATE_DISPLAY_LIST_OF_BOTH_OBJECTS : ConnectEditor_Connecting.cpp
  • USE_BIGGER_REGION : ConnectEditor_Morphing.cpp , ConnectEditor_Connecting.cpp
  • USE_DISTANCE_LIMIT_FOR_PAIRS : SNCH_Object.cpp
  • USE_MORE_SAFE_DEGEN_TEST : SNCH_Object.cpp
  • USE_OUR_ALGORITHM : SNCH_Object.cpp
  • USER_PATH : precompiled.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- v -

  • VALID_CORNER_VAL_CLOSENESS : ObjectMovement.cpp
  • VE_names : Main.cpp
  • Vector() : normal.cpp , normal.h
  • VECTOR_POINT_COLOR : CameraPath.h
  • VECTOR_POINT_RADIUS : CameraPath.h
  • verbose : Drag.cpp
  • VERT_ALIGN_OUTER : KeepOnScreen.h
  • VERTEX : PointShell_Object_Data.h , GeometryLoaderBase.cpp , SNCH_Object.cpp , SNCH_Object_Data.cpp , SphereBVH_Object_Data.cpp , VoxelGrid_Object_Data.cpp
  • VERTEX_REPRESENTANT : SNCH_Object.cpp , SNCH_Object_Data.cpp
  • VF_AUXILIARY_CPP : Auxiliary.cpp
  • VG_ADD_FACE_AND_COLOR : ObjectEffect.cpp
  • VG_ADD_NORMALS : ObjectEffect.cpp
  • VG_ADD_VERTEX : ObjectEffect.cpp
  • Vibrate() : Auxiliary.cpp
  • viewer : Main.cpp
  • VirtualFixture_getAbilityDescription() : AP_VirtualFixture.cpp , AP_VirtualFixture.h
  • VirtualFixture_getAbilityInstance() : AP_VirtualFixture.h , AP_VirtualFixture.cpp
  • VirtualFixture_getAbilityList() : AP_VirtualFixture.h , AP_VirtualFixture.cpp
  • VirtualFixture_getPluginDescription() : AP_VirtualFixture.h , AP_VirtualFixture.cpp
  • VirtualFixture_setAbilitiesParameters() : AP_VirtualFixture.cpp , AP_VirtualFixture.h
  • VISUALS_SAMPLE_MIN_DISTANCE : MTCreatorTool.cpp
  • vmsg : Drag.cpp
  • voxel_space : GenClouds.cpp
  • VRECKO_END_MESSAGE : Message.h
  • VRECKO_START_MESSAGE_BASE : Message.h
  • VRECKO_START_MESSAGE_EXTENDED : Message.h
  • vtimer : Vibration.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- w -

  • WEIGHT1 : functions.cpp , SnapObject.cpp
  • WEIGHT2 : SnapObject.cpp , functions.cpp
  • weightedSum() : GenClouds.h , GenClouds.cpp
  • weightFunction() : connecting_functions.cpp , connecting_functions.h
  • weightFunctionNormalize() : connecting_functions.h , connecting_functions.cpp
  • weightGaussFunction() : connecting_functions.h , connecting_functions.cpp
  • WHEEL_ANGLE_CONST : CarState.h
  • wiiSendersLock : Wiimote.cpp
  • wiiSenderStrings : Wiimote.cpp
  • WIN32_LEAN_AND_MEAN : Kinect.h , precompiled.h
  • WRIST : arm.h
  • WSXMAX : Auxiliary.h
  • WSXMIN : Auxiliary.h
  • WSYMAX : Auxiliary.h
  • WSYMIN : Auxiliary.h
  • WSZMAX : Auxiliary.h
  • WSZMIN : Auxiliary.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- x -

  • XercesToStr : XercesXMLUtils.h
  • XX1 : SNCH_Object.cpp
  • XX2 : SNCH_Object.cpp
  • XX3 : SNCH_Object.cpp
  • XX4 : SNCH_Object.cpp
  • XYZ_EULER : Arm.cpp , arm.h
  • XYZ_FIXED : Arm.cpp , arm.h , Arm.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- y -

  • YES : fsPinchGlove.h
  • YXZ_FIXED : Arm.cpp , arm.h
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
Here is a list of all file members with links to the files they belong to:

- z -

  • ZEROXDISTANCE : Auxiliary.h
  • ZEROYDISTANCE : Auxiliary.h
  • ZEROZDISTANCE : Auxiliary.h
  • ZXY_EULER : arm.h , Arm.cpp
  • ZYX_EULER : Arm.cpp , arm.h
  • ZYX_FIXED : Arm.cpp , arm.h , Arm.cpp
Generated on Sun Feb 17 2013 23:30:17 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • addLinesToEo() : functions.h , functions.cpp
  • addLinesToScene() : functions.h , functions.cpp , functions.h , functions.cpp
  • addMeshToScene() : functions.h , functions.cpp , functions.h , functions.cpp , functions.h , functions.cpp
  • addPointToScene() : functions.h , functions.cpp
  • addPointToScene90() : functions.h , functions.cpp
  • addVerticesToScene() : functions.h , functions.cpp
  • AngleCos() : PreloaderHeuristic.cpp
  • ArtificialWorld_getAbilityDescription() : AP_ArtificialWorld.h , AP_ArtificialWorld.cpp
  • ArtificialWorld_getAbilityInstance() : AP_ArtificialWorld.cpp , AP_ArtificialWorld.h
  • ArtificialWorld_getAbilityList() : AP_ArtificialWorld.cpp , AP_ArtificialWorld.h
  • ArtificialWorld_getPluginDescription() : AP_ArtificialWorld.cpp , AP_ArtificialWorld.h
  • ArtificialWorld_initializeAttributesDescription() : AP_ArtificialWorld.h
  • ArtificialWorld_setAbilitiesParameters() : AP_ArtificialWorld.h , AP_ArtificialWorld.cpp
  • Atmospheric_getAbilityDescription() : _AP_Atmospheric.h
  • Atmospheric_getAbilityInstance() : _AP_Atmospheric.cpp , _AP_Atmospheric.h
  • Atmospheric_getAbilityList() : _AP_Atmospheric.cpp , _AP_Atmospheric.h
  • Atmospheric_getPluginDescription() : _AP_Atmospheric.h , _AP_Atmospheric.cpp
  • Atmospheric_initializeAttributesDescription() : _AP_Atmospheric.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • base_getDeviceDescription() : DP_base.h , DP_base.cpp
  • base_getDeviceInstance() : DP_base.cpp , DP_base.h
  • base_getDeviceList() : DP_base.h , DP_base.cpp
  • base_getPluginDescription() : DP_base.cpp , DP_base.h
  • base_setDevicesParameters() : DP_base.h , DP_base.cpp
  • behindO_getAbilityDescription() : AP_behindO.h
  • behindO_getAbilityInstance() : AP_behindO.h
  • behindO_getAbilityList() : AP_behindO.h
  • behindO_getPluginDescription() : AP_behindO.h
  • behindO_initializeAttributesDescription() : AP_behindO.h
  • behindO_setAbilitiesParameters() : AP_behindO.h
  • bevel_2d() : triangleCube.h , triangleCube.cpp
  • bevel_3d() : triangleCube.cpp , triangleCube.h
  • boids_getAbilityDescription() : AP_boids.h , AP_boids.cpp
  • boids_getAbilityInstance() : AP_boids.h , AP_boids.cpp
  • boids_getAbilityList() : AP_boids.cpp , AP_boids.h
  • boids_getPluginDescription() : AP_boids.cpp , AP_boids.h
  • boids_initializeAttributesDescription() : AP_boids.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CableEditor_getAbilityDescription() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_getAbilityInstance() : AP_CableEditor.cpp , AP_CableEditor.h
  • CableEditor_getAbilityList() : AP_CableEditor.h , AP_CableEditor.cpp
  • CableEditor_getPluginDescription() : AP_CableEditor.cpp , AP_CableEditor.h
  • CableEditor_initializeAttributesDescription() : AP_CableEditor.h
  • CableEditor_setAbilitiesParameters() : AP_CableEditor.h
  • CalculateVector() : normal.h , normal.cpp
  • CameraMovement_getAbilityDescription() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_getAbilityInstance() : AP_CameraMovement.cpp , AP_CameraMovement.h
  • CameraMovement_getAbilityList() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_getPluginDescription() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraMovement_initializeAttributesDescription() : AP_CameraMovement.h
  • CameraMovement_setAbilitiesParameters() : AP_CameraMovement.h , AP_CameraMovement.cpp
  • CameraPath_getAbilityDescription() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getAbilityInstance() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getAbilityList() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_getPluginDescription() : AP_CameraPath.h , AP_CameraPath.cpp
  • CameraPath_initializeAttributesDescription() : AP_CameraPath.h
  • CameraPath_setAbilitiesParameters() : AP_CameraPath.h , AP_CameraPath.cpp
  • CarSim_getAbilityDescription() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getAbilityInstance() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getAbilityList() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_getPluginDescription() : AP_CarSim.h , AP_CarSim.cpp
  • CarSim_initializeAttributesDescription() : AP_CarSim.h
  • centerOfMass() : functions.h , functions.cpp
  • check_line() : triangleCube.h , triangleCube.cpp
  • check_point() : triangleCube.h , triangleCube.cpp
  • clampColor() : math_aux.h , math_aux.cpp
  • Clouds_getAbilityDescription() : _AP_Atmospheric.cpp
  • compute_modulated_ratio() : Grid.cpp
  • ComputePoint() : PreloaderHeuristic.h , PreloaderHeuristic.cpp
  • ConnectEditor_getAbilityDescription() : AP_ConnectEditor.cpp , AP_ConnectEditor.h
  • ConnectEditor_getAbilityInstance() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • ConnectEditor_getAbilityList() : AP_ConnectEditor.cpp , AP_ConnectEditor.h
  • ConnectEditor_getPluginDescription() : AP_ConnectEditor.h , AP_ConnectEditor.cpp
  • ConnectEditor_initializeAttributesDescription() : AP_ConnectEditor.h
  • ConnectEditor_setAbilitiesParameters() : AP_ConnectEditor.cpp , AP_ConnectEditor.h
  • ConstrainedMovement_getAbilityDescription() : AP_ConstrainedMovement.h , AP_ConstrainedMovement.cpp
  • ConstrainedMovement_getAbilityInstance() : AP_ConstrainedMovement.cpp , AP_ConstrainedMovement.h
  • ConstrainedMovement_getAbilityList() : AP_ConstrainedMovement.cpp , AP_ConstrainedMovement.h
  • ConstrainedMovement_getPluginDescription() : AP_ConstrainedMovement.cpp , AP_ConstrainedMovement.h
  • ConstrainedMovement_initializeAttributesDescription() : AP_ConstrainedMovement.h
  • ConstrainedMovement_setAbilitiesParameters() : AP_ConstrainedMovement.cpp , AP_ConstrainedMovement.h
  • ControlActualPosition() : Auxiliary.cpp
  • ControlActualPositionReturnCleanPosition() : Auxiliary.cpp
  • createBackgroundPlane() : Main.cpp
  • CreateCloudFromVoxels() : GenClouds.cpp , GenClouds.h
  • CreateGround() : OSGskybox.cpp , OSGskybox.h
  • createLoadingScreen() : Main.cpp
  • CreateParticleAABB() : ParticleFactory.cpp , ParticleFactory.h
  • CreateParticleSphere() : ParticleFactory.cpp , ParticleFactory.h
  • createShadowedScene() : CreateShadowedScene.h
  • CreateSkyBox() : OSGskybox.h , OSGskybox.cpp
  • CreateSun() : OSGskybox.h , OSGskybox.cpp
  • cross() : gm_vec3.h
  • Cross() : normal.h , normal.cpp
  • cycleLoadingHourglass() : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • displayStereoInfo() : Main.cpp
  • distance() : gm_vec2.h , gm_vec4.h , gm_vec3.h
  • distanceSquared() : gm_vec4.h , gm_vec2.h , gm_vec3.h
  • dot() : gm_vec4.h , gm_vec3.h , gm_vec2.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • eraseFace() : functions.h , functions.cpp
  • erf() : erf.cpp , erf.h
  • erfc() : erf.cpp , erf.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • F() : connecting_functions.h , connecting_functions.cpp
  • f_act() : GenClouds.cpp , GenClouds.h
  • face_plane() : triangleCube.h , triangleCube.cpp
  • FFDEditor_getAbilityDescription() : AP_FFDEditor.cpp , AP_FFDEditor.h
  • FFDEditor_getAbilityInstance() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_getAbilityList() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_getPluginDescription() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • FFDEditor_initializeAttributesDescription() : AP_FFDEditor.h
  • FFDEditor_setAbilitiesParameters() : AP_FFDEditor.h , AP_FFDEditor.cpp
  • findClosestPoint() : functions.h , functions.cpp
  • findClosestPointNorm() : functions.cpp , functions.h
  • findClosestPointOnFace() : functions.h , functions.cpp
  • findClosestPointOnLine() : functions.cpp , functions.h
  • FindMediaFile() : MediaPath.h
  • findXMLNode() : XercesXMLUtils.h , XercesXMLUtils.cpp
  • ForceTransformFunction() : Auxiliary.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • Garden_getAbilityDescription() : AP_Garden.h , AP_Garden.cpp
  • Garden_getAbilityInstance() : AP_Garden.cpp , AP_Garden.h
  • Garden_getAbilityList() : AP_Garden.h , AP_Garden.cpp
  • Garden_getPluginDescription() : AP_Garden.cpp , AP_Garden.h
  • Garden_initializeAttributesDescription() : AP_Garden.h
  • Garden_setAbilitiesParameters() : AP_Garden.h , AP_Garden.cpp
  • getAbilityDescription() : AP_GUI.h , AP_HapticCollisionApp.h , AP_HeadTracking.cpp , AP_HeadTracking.h , AP_HelloWorld.cpp , AP_HUD.cpp , AP_HelloWorld.h , AP_InputConnector.cpp , AP_Menu.cpp , AP_HUD.h , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_InputConnector.h , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_Menu.h , AP_TextOutput.cpp , AP_Nature.h , AP_ObjectUtils.h , AP_base.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_EditorController.h , AP_TextOutput.h , AP_base.cpp , AP_EditorQAbilities.h , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_Filter.h , AP_GUI.cpp , AP_HapticCollisionApp.cpp
  • getAbilityInstance() : AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_base.h , AP_DynamicArt.h , AP_EditorController.h , AP_EditorQAbilities.h , AP_Filter.h , AP_games.h , AP_GUI.h , AP_HeadTracking.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_base.cpp , AP_DynamicArt.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp
  • getAbilityList() : AP_base.h , AP_DynamicArt.h , AP_EditorController.h , AP_EditorQAbilities.h , AP_Filter.h , AP_games.h , AP_GUI.h , AP_HeadTracking.h , AP_HelloWorld.h , AP_HUD.h , AP_InputConnector.h , AP_Menu.h , AP_Nature.h , AP_ObjectUtils.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.h , AP_base.cpp , AP_DynamicArt.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HapticCollisionApp.h , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_InputConnector.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp
  • getAngle() : normal.h , normal.cpp
  • getCurrentTime() : Timing.h , Timing.cpp
  • getDeviceDescription() : DP_Kinect.h , DP_Kinect.cpp
  • getDeviceInstance() : DP_Kinect.h , DP_Kinect.cpp
  • getDeviceList() : DP_Kinect.h , DP_Kinect.cpp
  • getElapsedTime() : Timing.h , Timing.cpp
  • getFacesOf() : functions.h , functions.cpp
  • getFileExtension() : StringHelpers.h
  • getFileNameFromPathFile() : StringHelpers.h
  • getFileNameWithoutExt() : StringHelpers.h
  • getFileNameWithoutPath() : StringHelpers.h
  • getFilePath() : StringHelpers.h
  • getGeodeOf() : functions.h , functions.cpp
  • getGeometryOf() : functions.h , functions.cpp
  • getMatrixOfRotation() : functions.h , functions.cpp , functions.h
  • getMergeMatrix() : functions.h , functions.cpp
  • getNodeTextTrans() : XercesXMLUtils.h , XercesXMLUtils.cpp
  • getNormalsOf() : functions.h , functions.cpp
  • getNumScreens() : Main.cpp
  • getPluginDescription() : AP_HUD.h , AP_EditorQAbilities.cpp , AP_EditorController.cpp , AP_ObjectUtils.h , AP_HeadTracking.cpp , AP_HeadTracking.h , AP_Menu.h , AP_base.h , AP_EditorController.h , AP_Filter.h , AP_HelloWorld.h , AP_TextOutput.h , AP_ShootingSimulation.h , AP_SpacePartitioning.h , AP_TextOutput.cpp , DP_Kinect.h , AP_base.cpp , AP_GUI.cpp , AP_HelloWorld.cpp , AP_Nature.h , AP_Menu.cpp , AP_InputConnector.cpp , AP_Nature.cpp , AP_HapticCollisionApp.h , AP_InputConnector.h , AP_SpacePartitioning.cpp , AP_GUI.h , AP_EditorQAbilities.h , AP_ShootingSimulation.cpp , AP_HUD.cpp , DP_Kinect.cpp , AP_HapticCollisionApp.cpp , AP_ObjectUtils.cpp
  • getRelativePath() : StringHelpers.h
  • GetTempFilePath() : MediaPath.h
  • getVerticesOf() : functions.cpp , functions.h
  • gmAbs() : gm_utils.h
  • gmCeil() : gm_utils.h
  • gmClamp() : gm_utils.h
  • gmCube() : gm_utils.h
  • gmDegrees() : gm_utils.h
  • gmFloor() : gm_utils.h
  • gmFuzEQ() : gm_utils.h
  • gmFuzGEQ() : gm_utils.h
  • gmFuzLEQ() : gm_utils.h
  • gmInv() : gm_utils.h
  • gmIsZero() : gm_utils.h
  • gmLerp() : gm_utils.h
  • gmMax() : gm_utils.h
  • gmMin() : gm_utils.h
  • gmRadians() : gm_utils.h
  • gmRound() : gm_utils.h
  • gmSign() : gm_utils.h
  • gmSlide() : gm_utils.h
  • gmSmooth() : gm_utils.h
  • gmSqr() : gm_utils.h
  • gmSwap() : gm_utils.h
  • gmTrunc() : gm_utils.h
  • gmZSign() : gm_utils.h
  • GrowthSimulation() : GenClouds.cpp , GenClouds.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- h -

  • handle_tracker() : OptiTrack.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • includeFace() : functions.h , functions.cpp
  • init() : HoopShape.cpp
  • InitCloudGrowth() : GenClouds.h , GenClouds.cpp
  • initializeAttributesDescription() : AP_EditorController.h , AP_HapticCollisionApp.h , AP_DynamicArt.cpp , AP_TextOutput.h , AP_Menu.h , AP_ShootingSimulation.h , AP_Nature.h , AP_EditorQAbilities.h , AP_ObjectUtils.h , AP_InputConnector.h , AP_HUD.h , AP_HelloWorld.h , AP_Filter.h , AP_SpacePartitioning.h , AP_GUI.h , AP_base.h , AP_HeadTracking.h , AP_DynamicArt.h
  • interpolationLinear() : math_aux.cpp , math_aux.h
  • isBeginningWith() : StringHelpers.cpp , StringHelpers.h
  • isVisible() : PreloaderHeuristic.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- j -

  • jacobi2() : icp_functions.h , icp_functions.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • lerp() : gm_vec2.h , gm_vec3.h , gm_vec4.h
  • LightsEditor_getAbilityDescription() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getAbilityInstance() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getAbilityList() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_getPluginDescription() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • LightsEditor_initializeAttributesDescription() : AP_LightsEditor.h
  • LightsEditor_setAbilitiesParameters() : AP_LightsEditor.h , AP_LightsEditor.cpp
  • line_distance() : gm_vec3.h
  • load_config() : Main.cpp
  • LoadingFunction() : Preloader.cpp
  • LoadModelFromCoreModel() : ModelManager.cpp
  • LoadOSGTextureWithColorKey() : Texture.h , Texture.cpp
  • loadVirtualEnvironment() : Main.cpp
  • loggerLoadingConsoleOutput() : LoadingConsole.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • main() : Main.cpp
  • mainLoop() : Main.cpp
  • matrixTrace3x3() : functions.cpp , functions.h
  • matrixTranspose4x4() : functions.h , functions.cpp
  • METHOD_INPUT() : Avatar.cpp , CarExecutionUnit.cpp , BaseActor.cpp , ShootingSimulation.cpp , CarExecutionUnit.cpp , ShootingSimulation.cpp , BoidsPlanner.cpp , CarExecutionUnit.cpp , ShootingSimulation.cpp , CarExecutionUnit.cpp , Remover.cpp , CarExecutionUnit.cpp , RoadsState.cpp , CarExecutionUnit.cpp , TerrainAbility.cpp , Avatar.cpp , CarExecutionUnit.cpp , TerrainAbility.cpp , BaseActor.cpp , CarExecutionUnit.cpp , BaseActor.cpp
  • METHOD_REQUEST_INPUT() : WorldBuilder.cpp , CarExecutionUnit.cpp , PhysXScene.cpp , CarPartsNodeCache.cpp , RoadsState.cpp , CarExecutionUnit.cpp , RoadsState.cpp , PhysXScene.cpp , WorldBuilder.cpp , PhysXScene.cpp , RoadsState.cpp , PhysXScene.cpp , RoadsState.cpp , PhysXScene.cpp , RoadsState.cpp
  • MINOR() : gm_mat4.cpp , gm_mat3.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • navigation_getAbilityInstance() : AP_navigation.h , AP_navigation.cpp
  • navigation_getAbilityList() : AP_navigation.cpp , AP_navigation.h
  • navigation_initializeAttributesDescription() : AP_navigation.h
  • normalsVariance() : functions.h , functions.cpp
  • NXUFTtoa() : Helper.h , Helper.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • ode_getAbilityDescription() : AP_ode.h
  • ode_getAbilityInstance() : AP_ode.h
  • ode_getAbilityList() : AP_ode.h
  • ode_getPluginDescription() : AP_ode.h
  • ode_initializeAttributesDescription() : AP_ode.h
  • ode_setAbilitiesParameters() : AP_ode.h
  • operator*() : gm_mat3.cpp , gm_mat4.cpp , gm_vec2.h , gm_vec3.h , gm_vec4.h , gm_mat3.cpp
  • operator<<() : gm_mat4.cpp , gm_vec2.h , gm_vec3.h , XercesXMLUtils.h , gm_vec4.h , gm_mat3.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • p2pEuclideanDistance() : functions.h , functions.cpp
  • Perpendiculars() : icp_functions.cpp , icp_functions.h
  • PHANToM_getDeviceDescription() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_getDeviceInstance() : DP_PHANToM.cpp , DP_PHANToM.h
  • PHANToM_getDeviceList() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_getPluginDescription() : DP_PHANToM.h , DP_PHANToM.cpp
  • PHANToM_setDevicesParameters() : DP_PHANToM.h , DP_PHANToM.cpp
  • PhysX_getAbilityDescription() : AP_PhysX.h , AP_PhysX.cpp
  • PhysX_getAbilityInstance() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_getAbilityList() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_getPluginDescription() : AP_PhysX.cpp , AP_PhysX.h
  • PhysX_initializeAttributesDescription() : AP_PhysX.h
  • PhysX_setAbilitiesParameters() : AP_PhysX.cpp , AP_PhysX.h
  • plane_distance() : gm_vec3.h
  • plane_intersect() : gm_vec3.h
  • pLoadingScreen() : Main.cpp
  • point_triangle_intersection() : triangleCube.cpp , triangleCube.h
  • pointToTriangleDistance() : PHANToMAvatar.cpp
  • printColor() : precompiled.h
  • printErrorMessage() : functions.h , functions.cpp
  • printMessage() : functions.cpp , functions.h
  • printMessageTime() : functions.h , functions.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- q -

  • quaternionLength() : functions.h , functions.cpp
  • quaternionNormalize() : functions.h , functions.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • randFloat() : math_aux.h , math_aux.cpp
  • randGauss() : math_aux.cpp , math_aux.h
  • RCD() : gm_mat3.cpp , gm_mat4.cpp
  • recomputeNormals() : normal.cpp , normal.h
  • RoomEdit_getAbilityDescription() : AP_RoomEdit.h
  • RoomEdit_getAbilityInstance() : AP_RoomEdit.h
  • RoomEdit_getAbilityList() : AP_RoomEdit.h
  • RoomEdit_getPluginDescription() : AP_RoomEdit.h
  • RoomEdit_initializeAttributesDescription() : AP_RoomEdit.h
  • RoomEdit_setAbilitiesParameters() : AP_RoomEdit.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • setAbilitiesParameters() : AP_base.h , AP_EditorController.h , AP_GUI.h , AP_InputConnector.h , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_Menu.h , AP_GUI.cpp , AP_HapticCollisionApp.cpp , AP_HeadTracking.h , AP_Nature.h , AP_HapticCollisionApp.h , AP_HelloWorld.cpp , AP_ObjectUtils.h , AP_HUD.cpp , AP_InputConnector.cpp , AP_EditorQAbilities.h , AP_HelloWorld.h , AP_ShootingSimulation.h , AP_Menu.cpp , AP_Nature.cpp , AP_SpacePartitioning.h , AP_ObjectUtils.cpp , AP_ShootingSimulation.cpp , AP_TextOutput.cpp , AP_HUD.h , AP_TextOutput.h , AP_SpacePartitioning.cpp , AP_base.cpp
  • setDevicesParameters() : DP_Kinect.cpp , DP_Kinect.h
  • ShowModelSettings() : BlockUpdater.cpp
  • Side() : PreloaderHeuristic.cpp
  • simple_BAD_PACKET() : arm.h , Arm.cpp
  • simple_BAD_PORT() : Arm.cpp , arm.h , Arm.cpp
  • simple_CANT_BEGIN() : Arm.cpp , arm.h
  • simple_CANT_OPEN_PORT() : Arm.cpp , arm.h
  • simple_NO_HCI() : Arm.cpp , arm.h , Arm.cpp
  • simple_TIMED_OUT() : arm.h , Arm.cpp
  • SmoothEnding() : Auxiliary.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • t_c_intersection() : triangleCube.h , triangleCube.cpp
  • thread_main_func() : vThread.cpp
  • thread_main_func2() : vThread.cpp
  • tmpEyePosition() : Avatar.cpp
  • tmpLookAtCenter() : Avatar.cpp
  • tmpUpVector() : Avatar.cpp
  • ToNxQuat() : Helper.cpp , Helper.h
  • ToNxVec3() : Helper.cpp , Helper.h
  • ToosgQuat() : Helper.h , Helper.cpp
  • ToosgVec3() : Helper.cpp , Helper.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • uniCat() : StringHelpers.h
  • uniCpy() : StringHelpers.h
  • uniLen() : StringHelpers.h
  • uniNCpy() : StringHelpers.h
  • uniStr() : StringHelpers.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • Vector() : normal.h , normal.cpp
  • Vibrate() : Auxiliary.cpp
  • VirtualFixture_getAbilityDescription() : AP_VirtualFixture.cpp , AP_VirtualFixture.h
  • VirtualFixture_getAbilityInstance() : AP_VirtualFixture.cpp , AP_VirtualFixture.h
  • VirtualFixture_getAbilityList() : AP_VirtualFixture.cpp , AP_VirtualFixture.h
  • VirtualFixture_getPluginDescription() : AP_VirtualFixture.h , AP_VirtualFixture.cpp
  • VirtualFixture_setAbilitiesParameters() : AP_VirtualFixture.h , AP_VirtualFixture.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • weightedSum() : GenClouds.h , GenClouds.cpp
  • weightFunction() : connecting_functions.cpp , connecting_functions.h
  • weightFunctionNormalize() : connecting_functions.h , connecting_functions.cpp
  • weightGaussFunction() : connecting_functions.cpp , connecting_functions.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- _ -

  • _Atmospheric_ability_description : _AP_Atmospheric.cpp
  • _Atmospheric_ability_name : _AP_Atmospheric.cpp
  • _Atmospheric_plugin_name : _AP_Atmospheric.cpp
  • _base_device_description : DP_base.cpp
  • _base_device_name : DP_base.cpp
  • _base_plugin_name : DP_base.cpp
  • _boids_ability_description : AP_boids.cpp
  • _boids_ability_name : AP_boids.cpp
  • _boids_plugin_name : AP_boids.cpp
  • _CarSim_ability_description : AP_CarSim.cpp
  • _CarSim_ability_name : AP_CarSim.cpp
  • _CarSim_plugin_name : AP_CarSim.cpp
  • _device_description : DP_Kinect.cpp , DP_PHANToM.cpp
  • _device_name : DP_PHANToM.cpp , DP_Kinect.cpp
  • _DynamicArt_ability_name : AP_DynamicArt.cpp
  • _DynamicArt_plugin_name : AP_DynamicArt.cpp
  • _eye_separation : Main.cpp
  • _fullscreen : Main.cpp
  • _height : Main.cpp
  • _navigation_ability_name : AP_navigation.cpp
  • _navigation_plugin_name : AP_navigation.cpp
  • _new_ability : AP_navigation.cpp , AP_base.cpp , AP_CarSim.cpp , AP_DynamicArt.cpp , AP_PhysX.cpp , AP_VirtualFixture.cpp
  • _new_device : DP_PHANToM.cpp , DP_base.cpp
  • _PhysX_ability_description : AP_PhysX.cpp
  • _PhysX_ability_name : AP_PhysX.cpp
  • _PhysX_plugin_name : AP_PhysX.cpp
  • _plugin_name : DP_PHANToM.cpp , DP_Kinect.cpp
  • _screen_distance : Main.cpp
  • _screen_height : Main.cpp
  • _screen_width : Main.cpp
  • _stereo : Main.cpp
  • _VirtualFixture_ability_description : AP_VirtualFixture.cpp
  • _VirtualFixture_ability_name : AP_VirtualFixture.cpp
  • _VirtualFixture_plugin_name : AP_VirtualFixture.cpp
  • _width : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- a -

  • ability_description : AP_base.cpp
  • ability_name : AP_base.cpp
  • antiAliasSamples : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- b -

  • BAD_FORMAT : hci.h , Hci.cpp
  • BAD_PACKET : Hci.cpp , hci.h
  • BAD_PASSWORD : hci.h , Hci.cpp
  • BAD_PORT_NUM : Hci.cpp , hci.h
  • BAD_VERSION : hci.h , Hci.cpp
  • BEGIN_STR : Hci.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- c -

  • CANT_BEGIN : hci.h , Hci.cpp
  • CANT_OPEN_PORT : Hci.cpp , hci.h
  • cfg_args : hci.h , Hci.cpp
  • clearColour : Main.cpp
  • client_port : Main.cpp
  • config_file : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- d -

  • DEGREES : arm.h , Arm.cpp
  • detailedFragmentShaderSource : grass_shaders_source.h
  • detailedVertexShaderSource : grass_shaders_source.h
  • display_frequency : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- e -

  • ellipsoid_2a : GenClouds.cpp
  • ellipsoid_2b : GenClouds.cpp
  • ellipsoid_2c : GenClouds.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- g -

  • g_AbilityDesc : AP_ObjectUtils.cpp
  • g_AbilityName : AP_ObjectUtils.cpp
  • g_Anisotropic_scattering : CloudsManager.cpp , CloudsManager.h
  • g_CloudData : Clouds.cpp
  • g_Clouds : CloudsManager.h , CloudsManager.cpp
  • g_font3D : GUI_item.cpp
  • g_MultipleForwardScattering : CloudsManager.h , CloudsManager.cpp
  • g_pAbilityDesc : AP_HapticCollisionApp.cpp , AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_LightsEditor.cpp , AP_Menu.cpp , AP_CableEditor.cpp , AP_Nature.cpp , AP_ShootingSimulation.cpp , AP_CameraPath.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_FFDEditor.cpp
  • g_pAbilityName : AP_HeadTracking.cpp , AP_HelloWorld.cpp , AP_HUD.cpp , AP_LightsEditor.cpp , AP_Menu.cpp , AP_Nature.cpp , AP_ShootingSimulation.cpp , AP_SpacePartitioning.cpp , AP_TextOutput.cpp , AP_CableEditor.cpp , AP_CameraPath.cpp , AP_EditorController.cpp , AP_EditorQAbilities.cpp , AP_FFDEditor.cpp , AP_HapticCollisionApp.cpp
  • g_pAPCameraMovementAbilityDesc : AP_CameraMovement.cpp
  • g_pAPCameraMovementAbilityName : AP_CameraMovement.cpp
  • g_pAPCameraMovementPluginName : AP_CameraMovement.cpp
  • g_pAPConnectEditorAbilityDesc : AP_ConnectEditor.cpp
  • g_pAPConnectEditorAbilityName : AP_ConnectEditor.cpp
  • g_pAPConnectEditorPluginName : AP_ConnectEditor.cpp
  • g_pAPConstrainedMovementAbilityDesc : AP_ConstrainedMovement.cpp
  • g_pAPConstrainedMovementAbilityName : AP_ConstrainedMovement.cpp
  • g_pAPConstrainedMovementPluginName : AP_ConstrainedMovement.cpp
  • g_pAPGardenAbilityDesc : AP_Garden.cpp
  • g_pAPGardenAbilityName : AP_Garden.cpp
  • g_pAPGardenPluginName : AP_Garden.cpp
  • g_pArtificialWorldAbilityDescription : AP_ArtificialWorld.cpp
  • g_pArtificialWorldAbilityName : AP_ArtificialWorld.cpp
  • g_pArtificialWorldPluginName : AP_ArtificialWorld.cpp
  • g_pGUIAbilityDesc : AP_GUI.cpp
  • g_pGUIAbilityName : AP_GUI.cpp
  • g_pGUIPluginName : AP_GUI.cpp
  • g_pInputConnectorAbilityDesc : AP_InputConnector.cpp
  • g_pInputConnectorAbilityName : AP_InputConnector.cpp
  • g_pInputConnectorPluginName : AP_InputConnector.cpp
  • g_PluginName : AP_ObjectUtils.cpp
  • g_pPluginDesc : AP_HeadTracking.cpp
  • g_pPluginName : AP_TextOutput.cpp , AP_CableEditor.cpp , AP_CameraPath.cpp , AP_ShootingSimulation.cpp , AP_Menu.cpp , AP_LightsEditor.cpp , AP_EditorController.cpp , AP_FFDEditor.cpp , AP_HapticCollisionApp.cpp , AP_HeadTracking.cpp , AP_SpacePartitioning.cpp , AP_HUD.cpp , AP_Nature.cpp , AP_HelloWorld.cpp , AP_EditorQAbilities.cpp
  • gestures : Drag.cpp
  • gm2PI : gm_const.h
  • gmDEGTORAD : gm_const.h
  • gmE : gm_const.h
  • gmEEXPPI : gm_const.h
  • gmEPSILON : gm_const.h
  • gmGOLDEN : gm_const.h
  • gmGOOGOL : gm_const.h
  • gmINVPI : gm_const.h
  • gmLN10 : gm_const.h
  • gmLN2 : gm_const.h
  • gmLOG10E : gm_const.h
  • gmLOG2E : gm_const.h
  • gmPI : gm_const.h
  • gmPIDIV2 : gm_const.h
  • gmPIDIV4 : gm_const.h
  • gmRADTODEG : gm_const.h
  • gmSQRT10 : gm_const.h
  • gmSQRT2 : gm_const.h
  • gmSQRT2PI : gm_const.h
  • gmSQRT3 : gm_const.h
  • gmSQRTE : gm_const.h
  • gmSQRTHALF : gm_const.h
  • gmSQRTLN2 : gm_const.h
  • gmSQRTPI : gm_const.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- h -

  • hittedobject : NavSphere.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- i -

  • INCHES : arm.h , Arm.cpp
  • ip_str : Main.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- l -

  • last_tick : Main.cpp
  • loading_category : Main.cpp
  • loading_description : Main.cpp
  • loading_position : Main.cpp
  • loading_section_Mutex : Main.cpp
  • loading_state : Main.cpp
  • loadingConsole : Main.cpp
  • lowDetailFragmentShaderSource : grass_shaders_source.h
  • lowDetailVertexShaderSource : grass_shaders_source.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- m -

  • mainObject : Main.cpp
  • MM : Arm.cpp , arm.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- n -

  • net_flag : Main.cpp
  • nfound : Ultratrak.cpp
  • NO_HCI : Hci.cpp , hci.h
  • NO_PACKET_YET : hci.h , Hci.cpp
  • node : Drag.cpp
  • node2 : Drag.cpp
  • node3 : Drag.cpp
  • node4 : Drag.cpp
  • num_cfg_args : Hci.cpp , hci.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- p -

  • pCPhRec : PHANToMAvatar.cpp
  • plugin_name : AP_base.cpp
  • pMovingTransformation : Main.cpp
  • projection_node : Main.cpp
  • ptimer : Drag.cpp
  • pTransformation : Main.cpp
  • pVPosModel : PHANToMAvatar.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- r -

  • RADIANS : arm.h , Arm.cpp
  • ray_direction : NavSphere.cpp
  • ray_position : NavSphere.cpp
  • readfds : Ultratrak.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- s -

  • scenario_name : Main.cpp
  • ser : Hci.cpp
  • server_port : Main.cpp
  • SIGNON_STR : Hci.cpp
  • SUCCESS : hci.h , Hci.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- t -

  • tempBool : Drag.cpp
  • tempChar : Drag.cpp
  • tempFloat : Drag.cpp
  • tempString : Drag.cpp
  • tim : Hci.cpp
  • TIMED_OUT : hci.h , Hci.cpp
  • timeout : Ultratrak.cpp
  • timer : Auxiliary.cpp , player.cpp
  • tmpability : NavSphere.cpp
  • tmpFloat : Avatar.cpp
  • tmpGesture : Drag.cpp
  • tmpMVect : Drag.cpp
  • tmpName : Drag.cpp
  • TRY__AGAIN : hci.h , Hci.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- v -

  • VE_names : Main.cpp
  • verbose : Drag.cpp
  • viewer : Main.cpp
  • voxel_space : GenClouds.cpp
  • vtimer : Vibration.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- w -

  • wiiSendersLock : Wiimote.cpp
  • wiiSenderStrings : Wiimote.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- x -

  • XYZ_EULER : arm.h , Arm.cpp
  • XYZ_FIXED : arm.h , Arm.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- y -

  • YXZ_FIXED : arm.h , Arm.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • v
  • w
  • x
  • y
  • z

- z -

  • ZXY_EULER : arm.h , Arm.cpp
  • ZYX_EULER : arm.h , Arm.cpp
  • ZYX_FIXED : Arm.cpp , arm.h , Arm.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • angle : arm.h
  • angle_format : arm.h
  • angle_units : arm.h
  • arm_result : classes.h
  • BufferedSplinePtr : BufferedSpline.h
  • byte : classes.h
  • FilletSplinePtr : FilletSpline.h
  • FloatVector : wavefront.cpp
  • hci_result : classes.h
  • InterpolatedSplinePtr : InterpolatedSpline.h
  • InterpolatorPtr : Interpolator.h
  • IntVector : wavefront.cpp
  • length : arm.h
  • length_units : arm.h
  • matrix_4 : arm.h
  • ratio : arm.h
  • ReceiversList : InputConnector.h
  • ref_ptr_DAControlPoint : MTTriangulator.h
  • ref_ptr_MTCreatorTool : MTCreatorTool.h
  • ref_ptr_SimpleBox : MTCreatorTool.h , MTTriangulator.h
  • RegularPolygonSplinePtr : RegularPolygonSpline.h
  • SampledSplinePtr : SampledSpline.h
  • SectorArray : SectorColorGen.h
  • SectorColorGenPtr : SectorColorGen.h
  • SectorPtr : SectorColorGen.h
  • SmoothedSplinePtr : SmoothedSpline.h
  • SweepSurfaceGeodePtr : SweepSurfaceGeode.h
  • TimeLineSplinePtr : TimeLineSpline.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • BrushStrokeInterpolationType : precompiled.h
  • IconType : Icon.h
  • MTBrushParameterType : MTBrush.h
  • MTBrushShapeType : MTBrush.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • BrushStroke_Interpolation_CATMULLROM : precompiled.h
  • BrushStroke_Interpolation_CIRCLE : precompiled.h
  • BrushStroke_Interpolation_CUBIC : precompiled.h
  • BrushStroke_Interpolation_LINEAR : precompiled.h
  • BrushStroke_Interpolation_NONE : precompiled.h
  • BrushStroke_Interpolation_USER_PREDEFINED : precompiled.h
  • ICON__BUTTON : Icon.h
  • ICON__MULTISWITCH : Icon.h
  • ICON__SWITCH : Icon.h
  • MTBRUSH_PARAMETER_CONSTANT : MTBrush.h
  • MTBRUSH_PARAMETER_CURVATURE_BASED : MTBrush.h
  • MTBRUSH_PARAMETER_GRADIENT : MTBrush.h
  • MTBRUSH_PARAMETER_SPEED_BASED : MTBrush.h
  • MTBRUSH_SHAPE_RECTANGE : MTBrush.h
  • MTBRUSH_SHAPE_ROUND : MTBrush.h
  • MTBRUSH_SHAPE_ROUNDED_RECTANGE : MTBrush.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- _ -

  • __HEAD_TRACKING_H : HeadTracking.h
  • __HEAD_TRACKING_UTILS_H : htUtils.h
  • __SCREEN_SETUP_H : ScreenSetup.h
  • __SCREEN_SETUP_SIMPLE_H : ScreenSetupSimple.h
  • __SOLVER_H : Solver.h
  • _EO_owner : AvatarInHand.cpp
  • _USE_MATH_DEFINES : SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • ABATAR_H : Avatar.h
  • ABILITYMAPPER_ID : EditorController.cpp
  • absf : precompiled.h , ColorPicker.cpp , MTCreatorTool.cpp
  • ACT_PAIR : SNCH_Object.cpp
  • ADD_DIFERENCE_TO_FACE : ConnectEditor_Connecting.cpp
  • ADDITIONX : Auxiliary.h
  • ADDITIONY : Auxiliary.h
  • ADDITIONZ : Auxiliary.h
  • ANALOG_BITS : hci.h
  • ANALOG_HI_BIT : hci.h
  • ANALOG_LO_BIT : hci.h
  • ANIMATION_TIME : Camera.h
  • ANIMATOR_IMP_EXP : Animator.h
  • AP_HELLOWORLD : AP_HelloWorld.h
  • ARM_LENGTH : AvatarInHand.cpp
  • ASSERT_POINT_INDEX : Animator.cpp
  • ASSURE_FACES_SIZE : SNCH_Object.cpp
  • ASSURE_MINSPHEREDIST : SNCH_Object.cpp
  • ASSURE_RADIITOGETHER : SNCH_Object.cpp
  • ASSURE_TEMPD : SNCH_Object.cpp
  • AUTO_RUN : Camera.h
  • AUTOSAVE_PATH : precompiled.h
  • AVATAR_DELTA_CALC : Avatar.cpp
  • AVERAGE_CAR_DEC : CarState.h
  • AVERAGE_CAR_LENGTH : CarState.h
  • AW_DEBUG_ONLY : awHelper.h
  • AWAY_PER_CHAR_TIME : Console.cpp
  • AWAY_PER_LINE_TIME : Console.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • BASE : arm.h
  • BASE_CALIBRATION_STRING : Device.h
  • BASEK1 : Filter.h
  • BASEK2 : Filter.h
  • BAUD : classes.h
  • BAUDCODE : classes.h
  • BF_CLOSE_HANDLE : BufFile.cpp
  • BF_GET_FILE_SIZE : BufFile.cpp
  • BF_SET_FILE_POINTER : BufFile.cpp
  • BFAILGOTO : HelperMacros.h
  • BFAILGOTO_TEXT : HelperMacros.h
  • BFAILRET : HelperMacros.h
  • BFAILRET_TEXT : HelperMacros.h
  • BLINK_LENGTH : CarExecutionUnit.h
  • BLINK_LIGHT : CarExecutionUnit.h
  • BMW_LP : RoadsState.cpp
  • BMW_WHITE_LP : RoadsState.cpp
  • BORDER_CENTER : Border.cpp
  • BOTH_PEDALS : arm.h
  • BRAKE_LIGHT : CarExecutionUnit.h
  • BUFFILE_BEHVF_LOADFILETOMEM : BufFile.h
  • BUFFILE_BEHVF_UNICODE_START_HIDE : BufFile.h
  • BUFFILE_INITBUFFERSIZE : BufFile.h
  • BUFFILE_MAXBUFFILESIZE : BufFile.h
  • BUFFILE_MINBUFFERSIZE : BufFile.h
  • BUFSIZE : NestOfBirds.h , Ultratrak.h
  • BUTTON_MAPABILIES_ID : EditorController.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • CA_MENU_CLICKED : ControllableAbility.cpp
  • CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR__MASK : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_DONTCARE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCEHIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCESHOW : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_HIDE : ControllableAbility.h
  • CAINFO_AFLAGS_SELSHOW_OTHERPTR_SHOW : ControllableAbility.h
  • CAINFO_FLAGS_ALL_ACTIVEPOINTER_BUTTONS : ControllableAbility.h
  • CAINFO_FLAGS_ALL_OTHERPOINTER_BUTTONS : ControllableAbility.h
  • CAINFO_FLAGS_NO_AUTO_DEACTIVATE : ControllableAbility.h
  • CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUTPUTS : ControllableAbility.h
  • CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS : ControllableAbility.h
  • CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT : ControllableAbility.h
  • CALC_D : SNCH_Object.cpp
  • CALC_MAXMIN2 : ObjectMovement.cpp
  • CALC_PAIR_FLAGS : SNCH_Object.cpp
  • CAR_BEFORE_END : CarEnvirons.h
  • CAR_BEHIND_STOP_OR_GO_DECISION : CarEnvirons.h
  • CAR_BEHIND_STOP_OR_GO_DECISION_AND_PUT_ASIDE_TO_ROAD_MARGIN : CarEnvirons.h
  • CAR_IN_FRONT_OF_STOP_OR_GO_DECISION : CarEnvirons.h
  • CAR_IN_JUNCTION : CarEnvirons.h
  • CAR_LEFT_JUNCTION : CarEnvirons.h
  • CAR_ON_SHORT_EDGE_BEFORE_JUNC : CarEnvirons.h
  • CASTS_SHADOW_TRAVERSAL_MASK : EnvironmentObject.h
  • CE_RADIUS_ADJUSTMENT : CableEditor.h
  • CE_RADIUS_RANGE_FROM : CableEditor.h
  • CE_RADIUS_RANGE_TO : CableEditor.h
  • CFG_ARG_PAUSE : hci.h
  • changeAutoRotationSpeedStep : DAEnvironment.cpp
  • CLOSEBYTE : fsPinchGlove.h
  • CMD_BYTE : hci.h
  • CMD_TYPE_FILTER_POINT : LHeadTracker.h
  • CMD_TYPE_RCVR_DIMENSIONS : LHeadTracker.h
  • CMD_TYPE_SLAVE_XMITTER_TYPE : LHeadTracker.h
  • CNBB_F_FORCE_AABBOX : Scene.h
  • CNBB_F_NO_SELF_TRANSFORM : Scene.h
  • CNBB_F_ONLY_LOCAL_TRANSFORM : Scene.h
  • COLL_VRECKO_EXPORT : SP_CommonDefs.h
  • COLLINEAR_ORIENTATION : PolygonUtils.cpp
  • COLLISION_FLAGS_ALLOW_INTERSECTIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES : SP_CommonDefs.h
  • COLLISION_FLAGS_NO_CALCULATIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_NO_OLD_COLLISION_DELETION : SP_CommonDefs.h
  • COLLISION_FLAGS_NOCONTACTS : SP_CommonDefs.h
  • COLLISION_FLAGS_ONLY_INTERSECTIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_ONLYSCENETESTS : SP_CommonDefs.h
  • COLLISION_FLAGS_PREFER_NO_CALCULATIONS : SP_CommonDefs.h
  • COLLISION_FLAGS_RAYCASTING : SP_CommonDefs.h
  • COLLISION_FLAGS_RUN_IN_BACKGROUND : SP_CommonDefs.h
  • COLLISION_FLAGS_SINGLECONTACT : SP_CommonDefs.h
  • COLLISION_FLAGS_USE_MTMATRIXTRANSFORM : SP_CommonDefs.h
  • COLLISION_FLAGSMASK_COMPARISON_FLAGS : SP_CommonDefs.h
  • COLPOINT_FLAGS_INTERSECTION_LINE : SP_CommonDefs.h
  • COLPOINT_FLAGS_INVALID : SP_CommonDefs.h
  • COLPOINT_FLAGS_NEG_DIST_PRESENT : SP_CommonDefs.h
  • COLPOINT_FLAGS_NORMALIZED : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__GET : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__MASK : SP_CommonDefs.h
  • COLPOINT_FLAGS_REPRESENTANTS__SHIFT : SP_CommonDefs.h
  • CON_MAX_LINE : Console.cpp
  • CONE_CENTER : Cone.cpp
  • CONFIG_BIT : hci.h
  • CONFIG_MIN : hci.h
  • CONNECT_OBJECTS_BIGGER_LOOP : ConnectEditor_Connecting.cpp
  • CONNECTBYTE : fsPinchGlove.h
  • CONSOLE_ATTRIB_COLOR_BYTES : Logger.cpp
  • CONSOLE_AWAY_TIME : Console.cpp
  • CONSOLE_BORDER_X_RATIO : Console.h
  • CONSOLE_BORDER_Y_RATIO : Console.h
  • CONSOLE_CHAR_SIZE : Console.h
  • CONSOLE_FONT : Console.h
  • CONSOLE_LINE_SPACE_CHAR_RATIO : Console.h
  • CONSOLE_NO_ANIMATOR : Console.h
  • CONSOLE_SHOW_TIME : Console.cpp
  • CONSOLE_TEXTCOLOR_DEBUG : Console.h
  • CONSOLE_TEXTCOLOR_ERROR : Console.h
  • CONSOLE_TEXTCOLOR_NOTICE : Console.h
  • CONSOLE_TEXTCOLOR_WARNING : Console.h
  • CONSOLE_WINDOW_DEPTH : Console.h
  • CONSOLE_WINDOW_HEIGHT_ADD : Console.cpp
  • CONSOLE_WINDOW_HEIGHT_BORDER_RATIO : LoadingConsole.cpp
  • CONSOLE_WINDOW_HEIGHT_RATIO : Console.cpp , LoadingConsole.cpp
  • CONSOLE_WINDOW_WIDTH_RATIO : Console.cpp , LoadingConsole.cpp
  • CONSTRAINED_ROTATION_DISTANCE : ConstraintDescription.h
  • CONSTRAINED_SNAPPING_DISTANCE : ConstraintDescription.h
  • CONTROL_LINE_COLOR : CameraPath.h
  • CONTROL_LINE_WIDTH : CameraPath.h
  • CONTROL_POINT_COLOR : CameraPath.h
  • CONTROL_POINT_RADIUS : CameraPath.h
  • CONTROL_SYSTEM_RIGHT_HAND : Junction.h
  • CONTROL_SYSTEM_TRAFFIC_LIGHTS : Junction.h
  • CONTROLPOINT : Grid.cpp , EditorLogic.cpp
  • COPLANAR_MAX_ANGLE : ObjectMovement.cpp
  • COPYPROP_GEOMETRY_COPY : CopyProperties.h
  • COPYPROP_GEOMETRY_REF : CopyProperties.h
  • COPYPROP_TRANSFORMATION : CopyProperties.h
  • CREATOR_FILENAME_ID : ReaderWriter.h
  • CREATOR_FILENAME_ID_SIMPLE : ReaderWriter.h
  • CROSS : triangleCube.cpp
  • CURRENT_CACHED_DATA_VERSION : VoxelGrid_Object_Data.cpp , PointShell_Object_Data.cpp
  • CURSORS_PATH : precompiled.h
  • CVC_F_DEFAULT : ConnectionViz.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • DAINLINE : DynamicArray.h
  • dbg : classes.h
  • dbgAtt : Utils.h
  • dbgDE : DAEnvironment.cpp
  • dbgdf : classes.h
  • dbgFS : FilletSpline.cpp
  • dbgGUIC : GUI_Controller.cpp
  • dbgPS : Utils.h
  • dbgsf : classes.h
  • dbgSmS : SmoothedSpline.cpp , TimeLineSpline.cpp
  • DECLARE_AND_CLIP_PID : EditorController.cpp
  • DECLARE_INPUT : IOPins.h
  • DECLARE_OUTPUT : IOPins.h
  • DECLARE_REQUEST_INPUT : IOPins.h
  • DECLARE_REQUEST_OUTPUT : IOPins.h
  • DECLARE_SEARCH_STRUCTS : ObjectAdd.cpp
  • DEF_PGI_PORT : fsPinchGlove.h
  • DEF_PGI_SERIAL : fsPinchGlove.h
  • DEFAULT_CDIR : CameraPath.h
  • DEFAULT_FREQ : player.h
  • DEFAULT_STATESET_VALUE : ObjectEffect.cpp
  • DEFAULT_VECCPW : CameraPath.h
  • DEFAULT_VECPW : CameraPath.h
  • DELETE_ACT_PAIR : SNCH_Object.cpp
  • diff2force : player.cpp
  • DIFF2FORCEMULTIPLIER : Drag.cpp
  • DIR_VECTOR : CameraPath.h
  • DM_CLICKEDSTRING_MAXSIZE : DynamicMenu.cpp
  • DTI_EXCLUDEROOT : DynamicTree.h
  • DTI_ONELAYERTRAVERSAL : DynamicTree.h
  • DTI_ONLYLEAVES : DynamicTree.h
  • DUAL_SPLITTING_ANGLE_THRESHOLD : ConstraintDescription.cpp
  • DUAL_SPLITTING_THRESHOLD : ConstraintDescription.cpp
  • DYNAMIC_SPEED : Camera.h
  • DYNAMICART_PATH : precompiled.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • EDGE : EditorLogic.cpp , Grid.cpp
  • EDITORCONTROLLER_IMP_EXP : ControllableAbility.h
  • ELBOW : arm.h
  • ELEM_COMP_LIMIT : ObjectMovement.cpp
  • ENCODER_BITS : hci.h
  • ENCODER_HI_BIT : hci.h
  • ENCODER_LO_BIT : hci.h
  • END_PAUSE : hci.h
  • END_SESSION : hci.h
  • ENDBYTE : fsPinchGlove.h
  • ENOUGHT_SMALL_NUMBER : ColorPicker.cpp
  • EOIH_IF_START_BEGINNING : Scene.h
  • EOIH_IF_START_CURRENT : Scene.h
  • EOIH_IF_START_NEXT : Scene.h
  • EPS : triangleCube.cpp
  • EPSILON : connecting_functions.cpp , ConstrainedObjectMovement.h , SnapObject.cpp , ConnectEditor_icp.cpp , functions.cpp
  • ERASE_AREA : ConnectEditor_Connecting.cpp
  • ERR : fsPinchGlove.h
  • err : Utils.h , InputConnector.cpp , GUI_Controller.cpp
  • EVENTDISPATCHER_PRIORITY : BaseClass.h
  • EXT_PARAM_BLOCK_SIZE : arm.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • F1 : CameraPath.cpp
  • F2 : CameraPath.cpp
  • F3 : CameraPath.cpp
  • F4 : CameraPath.cpp
  • FACE : SNCH_Object.cpp , SNCH_Object_Data.cpp , PointShell_Object_Data.h , SphereBVH_Object_Data.cpp , VoxelGrid_Object_Data.cpp , GeometryLoaderBase.cpp
  • FACESNCH_NO_GROUP : SNCH_Object_Data.h
  • FIELD_SIZE : PointShell_Object_Data_Geometry_Analyser.h
  • FILL_HOLES_ONE_TRIANGLE_REPLACED_BY_MANY : ConnectEditor_Connecting.cpp
  • FILL_HOLES_SECOND_TYPE_SINGLE_LINES : ConnectEditor_Connecting.cpp
  • FIND_HOLES : ConnectEditor_Connecting.cpp
  • FOR_ALL_BUTTONS : EditorController.cpp
  • FOR_ALL_POINTERS : EditorController.cpp
  • FOREARM : arm.h
  • FRAME_BUF_SIZE : classes.h
  • FRAME_FREQUENCY : Scheduler.h
  • FRONT_LIGHT : CarExecutionUnit.h
  • FUTURE_BIT : hci.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • GENERAL_MAX_JUNC_SPEED : RoadsState.cpp
  • GET_COMMENT : hci.h
  • GET_EXT_PARAMS : hci.h
  • GET_HOME_REF : hci.h
  • GET_MAXES : hci.h
  • GET_MODEL_NAME : hci.h
  • GET_PARAMS : hci.h
  • GET_PRM_FORMAT : hci.h
  • GET_PROD_ID : hci.h
  • GET_PROD_NAME : hci.h
  • GET_SERNUM : hci.h
  • GET_VERSION : hci.h
  • GROUPS_MAX_NORMAL_DIFFERENCE : SNCH_Object_Data.cpp
  • GUI_EXPORT : Slider.h , GUI_Text.h , IconColour.h , Menu.h , ColorPicker.h , Icon.h , GUI_Controller.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • HALF_LINE_APPROXIMATION_NUMBER : SNCH_Object.cpp
  • HCI_CHECK_BGND : hci.h
  • HCI_CHECK_FGND : hci.h
  • HCI_CHECK_MOTION : hci.h
  • HELPERS_IMP_EXP : StringHelpers.h , XercesXMLUtils.h
  • HF_VECS_COEF : RoadsState.cpp
  • HILL_ACC_COEF : CarState.h
  • HOLDFORCE : player.cpp
  • HOME_POS : hci.h
  • HORIZ_ALIGN_OUTER : KeepOnScreen.h
  • HORIZONTAL_MAX_ANGLE : ObjectMovement.cpp
  • HTD_CMD_DEMAND : LHeadTracker.h
  • HTD_CMD_DIAG : LHeadTracker.h
  • HTD_CMD_REPORT : LHeadTracker.h
  • HTD_CMD_RESET : LHeadTracker.h
  • HTD_COMMAND_LEN : LHeadTracker.h
  • htd_flush : LHeadTracker.h
  • HTD_PACKET_LEN : LHeadTracker.h
  • HTI_2MAX_NUM : LHeadTracker.h
  • HTI_CLOSEBYTE : LHeadTracker.h
  • HTI_CONNECTBYTE : LHeadTracker.h
  • HTI_MAX_NUM : LHeadTracker.h
  • HTI_MIN_POS_DIFF : LHeadTracker.h
  • HTI_MIN_ROT_DIFF : LHeadTracker.h
  • HTI_POS_C : LHeadTracker.h
  • HTI_ROT_C : LHeadTracker.h
  • HUD_EXPORT : HUDDisplay.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • IF_DIST__TEST_AND_SAVE : SNCH_Object.cpp
  • IF_DIST_END : SNCH_Object.cpp
  • if_err : LHeadTracker.h , fsPinchGlove.h
  • if_nonull : fsPinchGlove.h
  • if_notok : fsPinchGlove.h
  • if_null : fsPinchGlove.h
  • if_ok : fsPinchGlove.h
  • IFLAGS : Serial.cpp
  • INIT_INPUT : IOPins.h
  • INIT_INPUT_EXTNAME : IOPins.h
  • INIT_OUTPUT : IOPins.h
  • INIT_OUTPUT_EXTNAME : IOPins.h
  • INIT_REQUEST_INPUT : IOPins.h
  • INIT_REQUEST_INPUT_EXTNAME : IOPins.h
  • INIT_REQUEST_OUTPUT : IOPins.h
  • INIT_REQUEST_OUTPUT_EXTNAME : IOPins.h
  • INPUTCONNECTOR_EXPORT : InputConnector.h
  • INSERT_MARKER : hci.h
  • INSERT_PAIR : SNCH_Object.cpp
  • INSIDE : triangleCube.cpp
  • INSTANCE : DP_base.h , DP_Kinect.h , AP_behindO.h , DP_PHANToM.h , AP_VirtualFixture.h , AP_ode.h , AP_Filter.h , AP_base.h , AP_PhysX.h , AP_boids.h , AP_navigation.h , _AP_Atmospheric.h , AP_CarSim.h , AP_DynamicArt.h , AP_games.h
  • INTERPOLATION_CATMULL_ROM_ITERATE : Cable.h
  • INTERPOLATION_CATMULL_ROM_PER_SEGMENT : Cable.h
  • INVALID_SET_FILE_POINTER : BufFile.h
  • INX : osgQ_QShapeDrawable.cpp
  • INX_DIR : osgQ_QShapeDrawable.cpp
  • INY : osgQ_QShapeDrawable.cpp
  • INY_DIR : osgQ_QShapeDrawable.cpp
  • IS_CAINFO_VER : ControllableAbility.h
  • IVECO : RoadsState.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- j -

  • JACEPS : icp_functions.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • L_INDEX : fsPinchGlove.h
  • L_MIDDLE : fsPinchGlove.h
  • L_PINKIE : fsPinchGlove.h
  • L_RING : fsPinchGlove.h
  • L_THUMB : fsPinchGlove.h
  • LEFT_BLINKER_TURNED_ON : CarState.h
  • LEFT_HAND_SIDE : PolygonUtils.cpp
  • LEFT_PEDAL : arm.h
  • LERP : triangleCube.cpp
  • LFLAGS : Serial.cpp
  • LIGHT_TURNED_OFF : CarState.h
  • LIGHT_TURNED_ON : CarState.h
  • LIST : AP_CarSim.h , AP_DynamicArt.h , AP_Filter.h , AP_games.h , _AP_Atmospheric.h , AP_navigation.h , AP_ode.h , DP_base.h , DP_Kinect.h , DP_PHANToM.h , AP_base.h , AP_PhysX.h , AP_VirtualFixture.h , AP_behindO.h , AP_boids.h
  • LOADING_CONSOLE_REAL_LINE_HEIGHT_RATIO : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_DEBUG : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_ERROR : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_NOTICE : LoadingConsole.cpp
  • LOADINGCONSOLE_TEXTCOLOR_WARNING : LoadingConsole.cpp
  • LOCAL_SEARCH_INSIDE_GLOBAL : SNCH_Object.cpp
  • LOCALSEARCH_CACHE_USE_HASH : SNCH_Object.cpp
  • LOCALSEARCH_USE_CACHE : SNCH_Object.cpp
  • LOG_PI_OVER_2 : erf.cpp
  • LOG_START_TIMING : SNCH_Object.cpp
  • LOG_STOP_TIMING : SNCH_Object.cpp
  • LOG_WRITECOUNTER : SNCH_Object.cpp
  • LOGGER_OT_INTERNALMASK_NORMALTYPES : Logger.h
  • LOGGER_OT_INTERNALMASK_SPECIALTYPES : Logger.h
  • LOGGER_OUTPUTDEST_DEBUGSTRING : Logger.h
  • LOGGER_OUTPUTDEST_FILE : Logger.h
  • LOGGER_OUTPUTDEST_STDOUT : Logger.h
  • LOGGER_OUTPUTDESTMASK_ALL : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_DEBUGSTRING : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_FILE : Logger.h
  • LOGGER_OUTPUTDESTMASK_NO_STDOUT : Logger.h
  • LOGGER_OUTPUTDESTMASK_NONE : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUG : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUGFILE : Logger.h
  • LOGGER_OUTPUTTYPE_DEBUGFLUSH : Logger.h
  • LOGGER_OUTPUTTYPE_ERROR : Logger.h
  • LOGGER_OUTPUTTYPE_NOTICE : Logger.h
  • LOGGER_OUTPUTTYPE_TIMINGSFILE : Logger.h
  • LOGGER_OUTPUTTYPE_WARNING : Logger.h
  • LOGGER_OUTPUTTYPEMASK_ALL : Logger.h
  • LOGGER_OUTPUTTYPEMASK_DEBUG : Logger.h
  • LOGGER_OUTPUTTYPEMASK_NONE : Logger.h
  • LOGGER_OUTPUTTYPEMASK_NORMAL : Logger.h
  • LOGGER_OUTPUTTYPEMASK_USER : Logger.h
  • LS_EDGE_ALL_EDGES : SNCH_Object.cpp
  • LS_EDGE_NO_EDGE : SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • MAIN_DEBUG_START_TIMING : Main.cpp
  • MAIN_DEBUG_STOP_TIMING : Main.cpp
  • MASTER_MODE : LHeadTracker.h
  • MATERIALCOUNTERMAX : PHEffect.cpp
  • MAX3 : triangleCube.cpp
  • MAX_CAR_LENGTH : CarState.h
  • MAX_CAR_WIDTH : CarState.h
  • MAX_CFG_SIZE : hci.h
  • MAX_CONSTRAINED_SNAPPING_DISTANCE : ConstraintDescription.h
  • MAX_INT : SnapObject.cpp
  • MAX_ITERATIONS : ConnectEditor_icp.cpp
  • MAX_NUMBER_OF_TRACKED_SENSORS : precompiled.h
  • MAX_OUTSTANDING_COUNTERS : Logger.cpp
  • MAX_PACKET_SIZE : hci.h
  • MAX_SNAPPING_PLANES : ObjectMovement.cpp
  • MAX_STRING_SIZE : hci.h
  • MAX_WIIMOTES : Wiimote.h
  • MAXARGS : wavefront.cpp
  • MAXBORDERRADIUS : Auxiliary.h
  • MAXDIST : player.cpp
  • MAXFORCE : Auxiliary.h
  • MENU_BOX_FIRST_X_OFFSET : DynamicMenu.cpp
  • MENU_GRID_X_OFFSET : DynamicMenu.cpp
  • MENU_GRID_Y_OFFSET : DynamicMenu.cpp
  • MENU_NOTAVAILABLE_ITEM_COLOR : precompiled.h
  • MENU_RADIAL_MAXITEMS : DynamicMenu.cpp
  • MENU_SELECTED_ITEM_COLOR : precompiled.h
  • MENUITEM_SUBSIZE_RATIO : DynamicMenu.cpp
  • MENUITEM_TEXT_CHARHEIGHT : DynamicMenu.cpp
  • MENUITEM_TEXT_FONT : DynamicMenu.cpp
  • MENUITEMSLIDER_SAFE_ADDITION : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_SIZE_REL : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_X_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_X_HALF_LENGTH : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Y_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Y_HALF_LENGTH : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Z_CENTER_POS : DynamicMenu.cpp
  • MENUITEMSLIDER_SLIDER_Z_HALF_LENGTH : DynamicMenu.cpp
  • MENUTIEM_BOX_INBETWEENDIST_X : DynamicMenu.cpp
  • MENUTIEM_BOX_INBETWEENDIST_Y : DynamicMenu.cpp
  • MENUTIEM_RADIALSECTION_INBETWEENDIST : DynamicMenu.cpp
  • MERGE_FLAGS_ATTRIB_NAME : ReaderWriter.cpp
  • MERGE_OBJECTS : ConnectEditor_Connecting.cpp
  • META_HoopShapeObject : HoopShape.h
  • METHOD_INPUT : IOPins.h
  • METHOD_REQUEST_INPUT : IOPins.h
  • MI_F_EXPANDED : DynamicMenu.h
  • MI_F_SELECTED : DynamicMenu.h
  • MIN3 : triangleCube.cpp
  • MIN_DISTANCE_FROM_EDGE : CreateHole.h
  • MIN_TIMEOUT : classes.h
  • MINBORDERRADIUS : Auxiliary.h
  • MINF : Auxiliary.h
  • MINIMAL_DISTANCE_BETWEEN_CONTROL_POINTS : precompiled.h
  • MORPH_MASTER_VERTICES : ConnectEditor_Morphing.cpp
  • MORPH_SECOND_ITERATION : ConnectEditor_Morphing.cpp
  • MORPH_SLAVE_VERTICES : ConnectEditor_Morphing.cpp
  • MTLOCK_IMP_EXP : MTLock.h
  • MTMATRIXTRANSFORM_IMP_EXP : MTMatrixTransform.h
  • MULT : CameraPath.h
  • MULTIPLIER : Auxiliary.h
  • MUTEX_LOCK : World.cpp , ReaderWriter.cpp
  • MUTEX_UNLOCK : ReaderWriter.cpp , World.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • NEXT_JUNC_TURN_LEFT : CarEnvirons.h
  • NEXT_JUNC_TURN_RIGHT : CarEnvirons.h
  • NO : fsPinchGlove.h
  • NODE : SNCH_Object.cpp , SNCH_Object_Data.cpp , SphereBVH_Object_Data.cpp
  • NOMINMAX : precompiled.h , Timing.cpp , Timing.h
  • NORMAL_EDGE : Edge.h
  • NORMAL_EPSILON : PointShellVSVoxel_Object.cpp
  • NORMAL_OR_SHORT_EDGE_WITHOUT_ANY_LANE : Edge.h
  • null : Attribute.h
  • NUM_ANALOGS : hci.h
  • NUM_BUTTONS : hci.h
  • NUM_DOF : arm.h
  • NUM_ENCODERS : hci.h
  • NUM_PORTS : LHeadTracker.cpp
  • NUM_TABLE_POS : arm.h
  • NUM_TARGETS : ShootingSimulation.h
  • NUM_WII_DEVICES : Wiimote.cpp
  • NX : GenClouds.cpp
  • NY : GenClouds.cpp
  • NZ : GenClouds.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • OFLAGS : Serial.cpp
  • OK : fsPinchGlove.h
  • OPACITY_MULTIPLIER : ConstrainedObjectMovement.cpp
  • OUTPUTSTR : Logger.h
  • OUTPUTSTR2 : Logger.h
  • OUTPUTSTR3 : Logger.h
  • OUTPUTSTR4 : Logger.h
  • OUTPUTSTR5 : Logger.h
  • OUTPUTSTR6 : Logger.h
  • OUTPUTSTR7 : Logger.h
  • OUTSIDE : triangleCube.cpp
  • OUTX : osgQ_QShapeDrawable.cpp
  • OUTX_DIR : osgQ_QShapeDrawable.cpp
  • OUTY : osgQ_QShapeDrawable.cpp
  • OUTY_DIR : osgQ_QShapeDrawable.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • p0Normal : SNCH_Object.cpp
  • p1Normal : SNCH_Object.cpp
  • PACKET_MARKER : hci.h
  • PAIR_EXISTS : SNCH_Object.cpp
  • PARAM_BLOCK_SIZE : arm.h
  • parameterB : connecting_functions.cpp
  • parameterO : connecting_functions.cpp
  • parameterU : connecting_functions.cpp
  • PART_THREAD_REQUEST_TIMEOUT : Scene.cpp
  • PARTITIONING_INTERFACE_DEFAULT : SP_CommonDefs.h
  • PASSWD_OK : hci.h
  • PATH_LINE_COLOR : CameraPath.h
  • PATH_LINE_WIDTH : CameraPath.h
  • PATH_POINT_RADIUS : Camera.h
  • PERSISTENT_CACHE_MODEL_NAME : PersistentCache.cpp
  • PGI_MAX_PACKET_LEN : fsPinchGlove.h
  • PI : Cloud.h , arm.h , connecting_functions.cpp
  • PIN_ADDITION : BaseClass.cpp
  • PIN_REMOVAL : BaseClass.cpp
  • PLANE_X : Main.cpp
  • PLANE_Y : Main.cpp
  • PLANE_Z : Main.cpp
  • PLAYBACK_LAG_DURATION : Ctrl_FreeHandPainting.h
  • POINTER_ROTATION_MULTIPLIER : ConstrainedObjectMovement.cpp
  • POINTERPOS_RAW_REQUEST_NAME : ControllableAbility.h
  • POINTERPOS_REQUEST_NAME : ControllableAbility.h
  • POINTERROT_RAW_REQUEST_NAME : ControllableAbility.h
  • POINTERROT_REQUEST_NAME : ControllableAbility.h
  • POLHEMUS_HEADER : Ultratrak.h
  • POLHEMUS_PORT : Ultratrak.h
  • POLHEMUS_PORT2 : Ultratrak.h
  • PRECISE_DISTANCE_CALC : SNCH_Object.cpp
  • PRECISE_SPHERES : SphereBVH_Object_Data.cpp
  • PRINT_VEC : DynamicMenu.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- q -

  • QUICK_3DOF_POINTS : arm.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • R_INDEX : fsPinchGlove.h
  • R_MIDDLE : fsPinchGlove.h
  • R_PINKIE : fsPinchGlove.h
  • R_RING : fsPinchGlove.h
  • R_THUMB : fsPinchGlove.h
  • RE_DEFAULT_2_WIDTH : Geometry.h
  • RE_DEFAULT_BOTTOM : Geometry.h
  • RE_DEFAULT_COLOR : Geometry.h
  • RE_DEFAULT_HEIGHT : Geometry.h
  • RE_DEG_2_RAD_RATIO : Geometry.h
  • RE_MIN_ANGLE : Geometry.h
  • RE_MIN_LENGTH : Geometry.h
  • RE_WALL_ANGLES_COMPUTED : Geometry.h
  • RE_WALL_DRAWN : Geometry.h
  • READ_XML_FLOAT : Animator.cpp
  • READ_XML_QUAT : Animator.cpp
  • READ_XML_VECTOR : Animator.cpp
  • RECEIVES_SHADOW_TRAVERSAL_MASK : EnvironmentObject.h
  • REPAIR_LOOP_TO_LOOP_POSTION : ConnectEditor_Connecting.cpp
  • REPORT_MOTION : hci.h
  • RESTORE_FACTORY : hci.h
  • RESTORE_PAUSE : hci.h
  • RETRIEVE_PAIR : SNCH_Object.cpp
  • REVERSE_VERTEX_INDEX : SNCH_Object_Data.cpp
  • RIGHT_BLINKER_TURNED_ON : CarState.h
  • RIGHT_HAND_SIDE : PolygonUtils.cpp
  • RIGHT_PEDAL : arm.h
  • RS_LOAD_MODEL : RoadsState.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • SAFE_DELETE : HelperMacros.h
  • SAFE_FREE : HelperMacros.h
  • SBVH_PERSISTENT_CACHE_BASE_VERSION : SphereBVH_Object_Data.cpp
  • SEARCH_DONE : ObjectAdd.cpp
  • SEARCH_FILENAME : ObjectAdd.cpp
  • SEARCH_INIT : ObjectAdd.cpp
  • SEARCH_NEXT_FILE_OK : ObjectAdd.cpp
  • SEARCH_START_OK : ObjectAdd.cpp
  • SEL_UPDATE_COLOR_COMPONENT : DynamicMenu.cpp
  • SELECTIONID_REQUEST_NAME : ControllableAbility.h
  • SELECTIONPATH_REQUEST_NAME : ControllableAbility.h
  • SEND_BUTTON : Wiimote.cpp
  • SEND_EVENT : Wiimote.cpp
  • SENSOR_MAX_COUNT : GUI_Controller.h , InputConnector.h
  • SET_BAUD : hci.h
  • SET_HOME : hci.h
  • SET_HOME_REF : hci.h
  • SET_PARAMS : hci.h
  • SG_SAFETY : Scheduler.cpp
  • SHORT_EDGE : Edge.h
  • SHOULDER : arm.h
  • SHOW_LINES_WHILE_ANIMATING : Camera.h
  • SHOW_PROGRESS : VoxelGrid_Object_Data.cpp
  • SHOW_VIEW_LINE : Camera.h
  • SHOW_VISUALS_SAMPLES : MTCreatorTool.cpp
  • SHOWVEC3 : BlockUpdater.h
  • SI_OUT : SystemInfo.cpp
  • SI_UNKNOWN_THREAD_NAME : SystemInfo.h
  • SIGN3 : triangleCube.cpp
  • SIGNON_PAUSE : hci.h
  • SINGLE_TIME : ObjectEffect.cpp
  • SLAVE_MODE : LHeadTracker.h
  • SMALL_NUM : ObjectMovement.cpp , Layout.cpp , Slider.cpp , SNCH_Object.cpp , SNCH_Object_Data.cpp
  • SMOOTHING_RADIUS : Auxiliary.h
  • SNAP_PLANE_REACH_RATIO : ObjectMovement.cpp
  • SNCH_EDGE_CONCAVE_BREAK : SNCH_Object_Data.h
  • SNCH_FACE_DEGENERATED : SNCH_Object_Data.h
  • SNCH_FLOAT_SMALL_NUM : SNCH_Object.h
  • SNCH_FLOAT_TOLERANCE : SNCH_Object.h
  • SNCH_GROUPS_METHOD : SNCH_Object_Data.cpp
  • SNCH_LMD_F_INTERSECTION : SNCH_Object.h
  • SNCH_LMD_F_NEGATIVE_DISTANCE : SNCH_Object.h
  • SP_OBJECT_INTERFACE_ID__PS_VG : PointShellVSVoxel_Object.h
  • SP_OBJECT_INTERFACE_ID__SNCH : SNCH_Object.h
  • SP_OBJECT_INTERFACE_ID__SPHEREBVH : SphereBVH_Object.h
  • SP_SCENE_INTERFACE_ID__NOPARTITIONING : NoPartitioning_Scene.h
  • SP_SCENE_INTERFACE_ID__SPHEREBVH : SphereBVH_Scene.h
  • SPACEPARTITIONING_IMP_EXP : GeometryLoaderBase.h
  • SPEED : CameraPath.h , AvatarInHand.cpp
  • SPEED2FORCE : PHEffect.cpp
  • SPHERE_RADIUS : Cable.h
  • spheresize : player.cpp
  • STARTBYTE : fsPinchGlove.h
  • STARTTBYTE : fsPinchGlove.h
  • STARTTIMING : Logger.h
  • STARTXBYTE : fsPinchGlove.h
  • STATUS_SUCCESS : SystemInfo.cpp
  • STD_3DOF_POINTS : arm.h
  • STDLIB_H : icp_functions.h
  • STEP : CameraPath.h
  • STOPTIMING : Logger.h
  • strToXerces : ReaderWriter.h
  • STYLUS : arm.h
  • SUB : triangleCube.cpp
  • SURFACE_BREAK_TEST : SNCH_Object.cpp
  • SURFACE_SMALL_NUM : SNCH_Object_Data.cpp
  • SYMMETRIES_PATH : precompiled.h
  • SYSTEM_TRAVERSAL_MASK__MASK : EnvironmentObject.h
  • SYSTEM_VISIBLE_OBJECT_TRAVERSAL_MASK : EnvironmentObject.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • TEMPLATES_PATH : precompiled.h
  • TERMINATOR_EDGE : Edge.h
  • TEST_PAIR_FLAGS_INTERSECTIONS_ONLY : SNCH_Object.cpp
  • ThreadBasicInformation : SystemInfo.cpp
  • ThreadQuerySetWin32StartAddress : SystemInfo.cpp
  • TIMELINE__FULLY_VISIBLE : TimeLineSpline.h
  • TIMELINE__ZERO_TIME : TimeLineSpline.h
  • TIMEOUT_CHARS : hci.h
  • TIMER_BIT : hci.h
  • TL_GREEN : TLsOnJuncManager.h
  • TL_GREEN_INTERV_DEFAULT : Edge.h
  • TL_ORANGE : TLsOnJuncManager.h
  • TL_RED : TLsOnJuncManager.h
  • TL_RED_ORANGE : TLsOnJuncManager.h
  • TMP_VE_PROJ_RES_0_EXCEEDED : SNCH_Object.cpp
  • TMP_VE_PROJ_RES_1_EXCEEDED : SNCH_Object.cpp
  • TOMS : Timing.cpp
  • TOP_VECTOR : CameraPath.h
  • TPPS_F_PROJ_BACKWARDS : SNCH_Object.cpp
  • TPPS_F_PROJ_ZERO : SNCH_Object.cpp
  • TPPS_F_VALID : SNCH_Object.cpp
  • TRACKER_MAX_COUNT : OptiTrack.h
  • TRANSPARENCY : Camera.h
  • TWOPI : ConstraintArea.cpp
  • type : player.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • ULTRA_SHORT_EDGE : Edge.h
  • ULTRA_SHORT_EDGE_WITHOUT_ANY_LANE : Edge.h
  • UNDEF : PointShell_Object_Data_Geometry_Analyser.cpp , PointShell_Object_Data_LOD_Builder.cpp , PointShell_Object_Data_Geometry.cpp
  • UNINIT_INPUT : IOPins.h
  • UNINIT_OUTPUT : IOPins.h
  • UNINIT_REQUEST_INPUT : IOPins.h
  • UNINIT_REQUEST_OUTPUT : IOPins.h
  • UPDATE_CONTROL_POINTS_MIN_DISTANCE : BrushStroke.cpp
  • UPDATE_DISPLAY_LIST_OF_BOTH_OBJECTS : ConnectEditor_Connecting.cpp
  • USE_BIGGER_REGION : ConnectEditor_Morphing.cpp , ConnectEditor_Connecting.cpp
  • USE_DISTANCE_LIMIT_FOR_PAIRS : SNCH_Object.cpp
  • USE_MORE_SAFE_DEGEN_TEST : SNCH_Object.cpp
  • USE_OUR_ALGORITHM : SNCH_Object.cpp
  • USER_PATH : precompiled.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • VALID_CORNER_VAL_CLOSENESS : ObjectMovement.cpp
  • VECTOR_POINT_COLOR : CameraPath.h
  • VECTOR_POINT_RADIUS : CameraPath.h
  • VERT_ALIGN_OUTER : KeepOnScreen.h
  • VERTEX : SNCH_Object.cpp , SNCH_Object_Data.cpp , PointShell_Object_Data.h , SphereBVH_Object_Data.cpp , VoxelGrid_Object_Data.cpp , GeometryLoaderBase.cpp
  • VERTEX_REPRESENTANT : SNCH_Object_Data.cpp , SNCH_Object.cpp
  • VF_AUXILIARY_CPP : Auxiliary.cpp
  • VG_ADD_FACE_AND_COLOR : ObjectEffect.cpp
  • VG_ADD_NORMALS : ObjectEffect.cpp
  • VG_ADD_VERTEX : ObjectEffect.cpp
  • VISUALS_SAMPLE_MIN_DISTANCE : MTCreatorTool.cpp
  • vmsg : Drag.cpp
  • VRECKO_END_MESSAGE : Message.h
  • VRECKO_START_MESSAGE_BASE : Message.h
  • VRECKO_START_MESSAGE_EXTENDED : Message.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • WEIGHT1 : functions.cpp , SnapObject.cpp
  • WEIGHT2 : SnapObject.cpp , functions.cpp
  • WHEEL_ANGLE_CONST : CarState.h
  • WIN32_LEAN_AND_MEAN : Kinect.h , precompiled.h
  • WRIST : arm.h
  • WSXMAX : Auxiliary.h
  • WSXMIN : Auxiliary.h
  • WSYMAX : Auxiliary.h
  • WSYMIN : Auxiliary.h
  • WSZMAX : Auxiliary.h
  • WSZMIN : Auxiliary.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • XercesToStr : XercesXMLUtils.h
  • XX1 : SNCH_Object.cpp
  • XX2 : SNCH_Object.cpp
  • XX3 : SNCH_Object.cpp
  • XX4 : SNCH_Object.cpp
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • YES : fsPinchGlove.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: File Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • ZEROXDISTANCE : Auxiliary.h
  • ZEROYDISTANCE : Auxiliary.h
  • ZEROZDISTANCE : Auxiliary.h
Generated on Sun Feb 17 2013 23:30:18 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/_AP_Atmospheric.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
_AP_Atmospheric.h
Go to the documentation of this file.
1
9 #include <vrecko/Ability.h>
10
11 #include <vreckoAP/Export>
12
13 #define INSTANCE
14 #define LIST
15
16 extern "C" AP_EXPORT const char **Atmospheric_getAbilityList(void);
17 extern "C" AP_EXPORT vrecko::Ability *Atmospheric_getAbilityInstance(const char *_name);
18 extern "C" AP_EXPORT const char *Atmospheric_getAbilityDescription(const char * name);
19 extern "C" AP_EXPORT const char *Atmospheric_getPluginDescription(void);
20 extern "C" AP_EXPORT void Atmospheric_initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Nature/_precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • Nature
_precompiled.h
Go to the documentation of this file.
1 #include <iostream>
2 #include <fstream>
3 #include <sstream>
4 #include <string>
5 #include <cstdlib>
6 #include <cmath>
7 #include <climits>
8
9 #include <osg/AlphaFunc>
10 #include <osg/Texture2D>
11 #include <osg/Geometry>
12 #include <osg/BlendFunc>
13 #include <osg/Depth>
14 #include <osg/Math>
15
16 #include <osgDB/ReadFile>
17 #include <osgDB/WriteFile>
18
19 #include <vrecko/World.h>
20 #include <vrecko/Scene.h>
21 #include <vrecko/ReaderWriter.h>
22 #include <vrecko/EventDispatcher.h>
23 #include <vrecko/EnvironmentObject.h>
24
25 #include "AP_Atmospheric.h"
26 #include "Clouds/Clouds.h"
27 #include "Clouds/math_aux.h"
28 #include "Weather/Weather.h"
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/A3DBird.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
A3DBird.h
Go to the documentation of this file.
1 /***************************************************************************
2 a3dbird.h - description
3 -------------------
4 begin : Mon Jun 3 2002
5 copyright : (C) 2002 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef A3DBIRD_H
19 #define A3DBIRD_H
20
21 #include <vrecko/Device.h>
22
23 namespace vreckoDP_base {
24
25 class DP_EXPORT A3DBird : public vrecko::Device {
26 public:
27 A3DBird(char *port);
28 ~A3DBird();
29 };
30
31 }
32
33 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/AP_ArtificialWorld.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
AP_ArtificialWorld.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoAP/Export>
3
4
5
6 extern "C" const char AP_EXPORT **ArtificialWorld_getAbilityList(void);
7 extern "C" Ability AP_EXPORT *ArtificialWorld_getAbilityInstance(const char *_name);
8 extern "C" const char AP_EXPORT *ArtificialWorld_getAbilityDescription(const char *name);
9 extern "C" void AP_EXPORT ArtificialWorld_setAbilitiesParameters(void);
10 extern "C" const char AP_EXPORT *ArtificialWorld_getPluginDescription(void);
11 extern "C" void AP_EXPORT ArtificialWorld_initializeAttributesDescription() {}
12
13
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/AP_CableEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
AP_CableEditor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vreckoAP/Export>
5 #include <iostream>
6
7 using namespace vrecko;
8
9 #pragma warning(disable:4190)
10 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
11
12 // several functions for maintaining abilities
13 extern "C" AP_EXPORT const char *CableEditor_getPluginDescription(); // returns description of this plugin
14 extern "C" AP_EXPORT const char **CableEditor_getAbilityList(); // returns pointer to the ability name list
15 extern "C" AP_EXPORT const char *CableEditor_getAbilityDescription(const char *strName); // returns description of specified ability
16 extern "C" AP_EXPORT Ability *CableEditor_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
17 extern "C" AP_EXPORT void CableEditor_setAbilitiesParameters() {} // sets parameters info for BusinessProcess abilities
18 extern "C" void AP_EXPORT CableEditor_initializeAttributesDescription() {}
19
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/AP_CameraMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
AP_CameraMovement.h
Go to the documentation of this file.
1 #ifndef AP_CAMERAMOVEMENT
2 #define AP_CAMERAMOVEMENT
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *CameraMovement_getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **CameraMovement_getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *CameraMovement_getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *CameraMovement_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void CameraMovement_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT CameraMovement_initializeAttributesDescription() {}
20
21 #endif
22
23
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/AP_CameraPath.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraPath
AP_CameraPath.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vreckoAP/Export>
5 #include <iostream>
6
7 using namespace vrecko;
8
9 #pragma warning(disable:4190)
10 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
11
12 // several functions for maintaining abilities
13 extern "C" AP_EXPORT const char *CameraPath_getPluginDescription(); // returns description of this plugin
14 extern "C" AP_EXPORT const char **CameraPath_getAbilityList(); // returns pointer to the ability name list
15 extern "C" AP_EXPORT const char *CameraPath_getAbilityDescription(const char *strName); // returns description of specified ability
16 extern "C" AP_EXPORT Ability *CameraPath_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
17 extern "C" AP_EXPORT void CameraPath_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
18 extern "C" void AP_EXPORT CameraPath_initializeAttributesDescription() {}
19
20
21
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/AP_CarSim.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
AP_CarSim.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 extern "C" AP_EXPORT const char **CarSim_getAbilityList(void);
9 extern "C" AP_EXPORT vrecko::Ability *CarSim_getAbilityInstance(const char *_name);
10 extern "C" AP_EXPORT const char *CarSim_getAbilityDescription(const char * name);
11 extern "C" AP_EXPORT const char *CarSim_getPluginDescription(void);
12 extern "C" AP_EXPORT void CarSim_initializeAttributesDescription() {}
13
14
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/AP_ConnectEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
AP_ConnectEditor.h
Go to the documentation of this file.
1 #ifndef AP_CONNECT_EDITOR
2 #define AP_CONNECT_EDITOR
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 //#include <iostream>
7
8 using namespace std;
9 using namespace vrecko;
10
11 #pragma warning(disable:4190)
12 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
13
14 // several functions for maintaining abilities
15 extern "C" AP_EXPORT const char *ConnectEditor_getPluginDescription(); // returns description of this plugin
16 extern "C" AP_EXPORT char **ConnectEditor_getAbilityList(); // returns pointer to the ability name list
17 extern "C" AP_EXPORT const char *ConnectEditor_getAbilityDescription(const char *strName); // returns description of specified ability
18 extern "C" AP_EXPORT Ability *ConnectEditor_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
19 extern "C" AP_EXPORT void ConnectEditor_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
20 extern "C" void AP_EXPORT ConnectEditor_initializeAttributesDescription() {}
21
22 #endif //AP_CONNECT_EDITOR
23
24
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/AP_ConstrainedMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
AP_ConstrainedMovement.h
Go to the documentation of this file.
1 #ifndef AP_CONSTRAINEDMOVEMENT
2 #define AP_CONSTRAINEDMOVEMENT
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *ConstrainedMovement_getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **ConstrainedMovement_getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *ConstrainedMovement_getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *ConstrainedMovement_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void ConstrainedMovement_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT ConstrainedMovement_initializeAttributesDescription() {}
20
21 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/AP_DynamicArt.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
AP_DynamicArt.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 #include "DAEnvironment.h"
9 #include "Ctrl_FreeHandPainting.h"
10 #include "Ctrl_MotionVisualization.h"
11 #include "Ctrl_Attractor.h"
12 #include "Ctrl_PerlinLines.h"
13 #include "ToolBrush.h"
14 #include "ToolTongs.h"
15 #include "ToolEraser.h"
16 #include "ToolMagicWand.h"
17 #include "ToolSlice.h"
18 #include "ToolSelector.h"
19 #include "ToolRotation.h"
20
21
45 extern "C" const char AP_EXPORT **getAbilityList(void);
46
47 extern "C" Ability AP_EXPORT *getAbilityInstance(const char *_name);
48
49 extern "C" void AP_EXPORT initializeAttributesDescription();
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AP_EditorController.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
AP_EditorController.h
Go to the documentation of this file.
1 #ifndef AP_EDITORCONTROLLER
2 #define AP_EDITORCONTROLLER
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace std;
9 using namespace vrecko;
10
11 // several functions for maintaining abilities
12 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
13 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
14 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
15 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
16 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
17 extern "C" AP_EXPORT void initializeAttributesDescription() {}
18
19 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AP_EditorQAbilities.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
AP_EditorQAbilities.h
Go to the documentation of this file.
1 #ifndef AP_EDITORQABILITIES
2 #define AP_EDITORQABILITIES
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8
9 using namespace std;
10 using namespace vrecko;
11
12 // several functions for maintaining abilities
13 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
14 extern "C" AP_EXPORT char **getAbilityList(); // returns pointer to the ability name list
15 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
16 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
17 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
18 extern "C" AP_EXPORT void initializeAttributesDescription() {}
19
20 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/AP_FFDEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
AP_FFDEditor.h
Go to the documentation of this file.
1 #ifndef AP_FFDEDITOR
2 #define AP_FFDEDITOR
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *FFDEditor_getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **FFDEditor_getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *FFDEditor_getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *FFDEditor_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void FFDEditor_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT FFDEditor_initializeAttributesDescription() {}
20
21 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/AP_GUI.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
AP_GUI.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vreckoAP/Export>
5 #include <iostream>
6
7 #include "Icon.h"
8 #include "IconColour.h"
9 #include "Slider.h"
10 #include "Menu.h"
11 #include "ColorPicker.h"
12 #include "GUI_Controller.h"
13
14
15 using namespace vrecko;
16
17 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
18 #pragma warning(disable:4190)
19
20
21 // several functions for maintaining abilities
22 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plug-in
23 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
24 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
25 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
26 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
27 extern "C" void AP_EXPORT initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/AP_Garden.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
AP_Garden.h
Go to the documentation of this file.
1 #ifndef AP_GARDEN_H_
2 #define AP_GARDEN_H_
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
30 #pragma warning(disable:4190)
31 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
32
33 // several functions for maintaining abilities
34 extern "C" AP_EXPORT const char *Garden_getPluginDescription(); // returns description of this plugin
35 extern "C" AP_EXPORT char **Garden_getAbilityList(); // returns pointer to the ability name list
36 extern "C" AP_EXPORT const char *Garden_getAbilityDescription(const char *strName); // returns description of specified ability
37 extern "C" AP_EXPORT Ability *Garden_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
38 extern "C" AP_EXPORT void Garden_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
39 extern "C" void AP_EXPORT Garden_initializeAttributesDescription() {}
40
41 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/AP_HUD.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HUD
AP_HUD.h
Go to the documentation of this file.
1 #ifndef AP_HUD
2 #define AP_HUD
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
32 #pragma warning(disable:4190)
33 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
34
35 // several functions for maintaining abilities
36 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
37 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
38 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
39 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
40 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
41 extern "C" void AP_EXPORT initializeAttributesDescription() {}
42
43 #endif
44
45
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/AP_HapticCollisionApp.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
AP_HapticCollisionApp.h
Go to the documentation of this file.
1 #ifndef AP_HAPTICCOLLISIONAPP
2 #define AP_HAPTICCOLLISIONAPP
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT initializeAttributesDescription() {}
20
21 #endif
22
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/AP_HeadTracking.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
AP_HeadTracking.h
Go to the documentation of this file.
1 #ifndef AP_HEADTRACKING
2 #define AP_HEADTRACKING
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 //#include <iostream>
7
8 #pragma warning(disable:4190)
9 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
10
11 // several functions for maintaining abilities
12 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
13 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
14 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
15 extern "C" AP_EXPORT vrecko::Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
16 extern "C" AP_EXPORT void setAbilitiesParameters() {}
17 extern "C" void AP_EXPORT initializeAttributesDescription() {}
18
19 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld/AP_HelloWorld.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HelloWorld
AP_HelloWorld.h
Go to the documentation of this file.
1 #ifndef AP_HELLOWORLD //TODO: AP_{YourPluginName}
2 #define AP_HELLOWORLD //TODO: AP_{YourPluginName}
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT initializeAttributesDescription() {}
20
21 #endif
22
23
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/AP_InputConnector.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • InputConnector
AP_InputConnector.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vreckoAP/Export>
5 #include <iostream>
6
7
8 #include "InputConnector.h"
9
10 using namespace vrecko;
11
12 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
13 #pragma warning(disable:4190)
14
15
16 // several functions for maintaining abilities
17 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plug-in
18 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
19 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
20 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
21 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
22 extern "C" void AP_EXPORT initializeAttributesDescription() {}
23
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/AP_LightsEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
AP_LightsEditor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vreckoAP/Export>
5 #include <iostream>
6
7 using namespace vrecko;
8
9 #pragma warning(disable:4190)
10 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
11
12 // several functions for maintaining abilities
13 extern "C" AP_EXPORT const char *LightsEditor_getPluginDescription(); // returns description of this plugin
14 extern "C" AP_EXPORT const char **LightsEditor_getAbilityList(); // returns pointer to the ability name list
15 extern "C" AP_EXPORT const char *LightsEditor_getAbilityDescription(const char *strName); // returns description of specified ability
16 extern "C" AP_EXPORT Ability *LightsEditor_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
17 extern "C" AP_EXPORT void LightsEditor_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
18 extern "C" void AP_EXPORT LightsEditor_initializeAttributesDescription() {}
19
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/AP_Menu.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
AP_Menu.h
Go to the documentation of this file.
1 #ifndef AP_MENU
2 #define AP_MENU
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT initializeAttributesDescription() {}
20
21 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/AP_Nature.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
AP_Nature.h
Go to the documentation of this file.
1 #ifndef AP_NATURE
2 #define AP_NATURE
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 // Disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
9 #pragma warning(disable:4190)
10
11 // Disable warning regarding full namespace-like specification of enumerations as in C# (TerrainAlignment::Centre)
12 //#pragma warning(disable:4482)
13
14 using namespace vrecko;
15
16 // Several functions for maintaining abilities
17 extern "C" AP_EXPORT const char *getPluginDescription(); // Returns a description of this plugin
18 extern "C" AP_EXPORT const char **getAbilityList(); // Returns a pointer to the ability name list
19 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // Returns a description of specified ability
20 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // Returns an instance of the specified ability
21 extern "C" AP_EXPORT void setAbilitiesParameters(); // Sets parameters info for BusinessProcess abilities
22 extern "C" void AP_EXPORT initializeAttributesDescription() {}
23
24 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/AP_ObjectUtils.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
AP_ObjectUtils.h
Go to the documentation of this file.
1 #ifndef AP_OBJECTUTILS
2 #define AP_OBJECTUTILS
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT initializeAttributesDescription() {}
20
21 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/AP_PhysX.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
AP_PhysX.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "RemoteDebugger.h"
10 #include "PhysXScene.h"
11
12 #include "Plane.h"
13 #include "Box.h"
14 #include "Sphere.h"
15 #include "Capsule.h"
16
17
18 #include "RevoluteJoint.h"
19 #include "FixedJoint.h"
20 #include "SphericalJoint.h"
21 #include "PrismaticJoint.h"
22 #include "CylindricalJoint.h"
23 #include "DistanceJoint.h"
24 #include "PointInPlaneJoint.h"
25 #include "PointOnLineJoint.h"
26 #include "PulleyJoint.h"
27
28 #include "Fluid.h"
29 #include "Cloth.h"
30
31
32
33 #pragma warning(disable: 4190)
34 //warning C4190: '' has C-linkage specified, but returns UDT 'std::basic_string<_Elem,_Traits,_Ax>' which is incompatible with C
35
36
37 extern "C" char AP_EXPORT **PhysX_getAbilityList(void);
38 extern "C" Ability AP_EXPORT *PhysX_getAbilityInstance(const char *_name);
39 extern "C" std::string AP_EXPORT PhysX_getAbilityDescription(std::string name);
40 extern "C" void AP_EXPORT PhysX_setAbilitiesParameters(void);
41 extern "C" std::string AP_EXPORT PhysX_getPluginDescription(void);
42 extern "C" void AP_EXPORT PhysX_initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/AP_RoomEdit.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
AP_RoomEdit.h
Go to the documentation of this file.
1 #ifndef AP_ROOMEDIT
2 #define AP_ROOMEDIT
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *RoomEdit_getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT char **RoomEdit_getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *RoomEdit_getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *RoomEdit_getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void RoomEdit_setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT RoomEdit_initializeAttributesDescription() {}
20
21 #endif
22
23
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation/AP_ShootingSimulation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ShootingSimulation
AP_ShootingSimulation.h
Go to the documentation of this file.
1 #ifndef AP_SHOOTINGSIMULATION
2 #define AP_SHOOTINGSIMULATION
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" AP_EXPORT void initializeAttributesDescription() {}
20
21 #endif
22
23
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/AP_SpacePartitioning.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
AP_SpacePartitioning.h
Go to the documentation of this file.
1
2
3 #ifndef AP_SPACEPARTITIONING
4 #define AP_SPACEPARTITIONING
5
6 #include <vrecko/Ability.h>
7 #include <vreckoAP/Export>
8 #include <iostream>
9
28 using namespace std;
29 using namespace vrecko;
30
31 // several functions for maintaining abilities
32 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
33 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
34 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
35 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
36 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
37 extern "C" AP_EXPORT void initializeAttributesDescription() {}
38
39 #endif
40
41
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/AP_TextOutput.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • TextOutput
AP_TextOutput.h
Go to the documentation of this file.
1 #ifndef AP_TEXTOUTPUT
2 #define AP_TEXTOUTPUT
3
4 #include <vrecko/Ability.h>
5 #include <vreckoAP/Export>
6 #include <iostream>
7
8 using namespace vrecko;
9
10 #pragma warning(disable:4190)
11 // disable warning that tells us that using 'extern "C"' and 'string' at the same time is weird
12
13 // several functions for maintaining abilities
14 extern "C" AP_EXPORT const char *getPluginDescription(); // returns description of this plugin
15 extern "C" AP_EXPORT const char **getAbilityList(); // returns pointer to the ability name list
16 extern "C" AP_EXPORT const char *getAbilityDescription(const char *strName); // returns description of specified ability
17 extern "C" AP_EXPORT Ability *getAbilityInstance(const char* pchName); // returns an instance of the specified ability
18 extern "C" AP_EXPORT void setAbilitiesParameters(); // sets parameters info for BusinessProcess abilities
19 extern "C" void AP_EXPORT initializeAttributesDescription() {}
20
21 #endif
22
23
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AP_VirtualFixture.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
AP_VirtualFixture.h
Go to the documentation of this file.
1 #ifndef VF_AP
2 #define VF_AP
3
4 #include <vrecko/Ability.h>
5
6 #include <vreckoAP/Export>
7
8 #define INSTANCE
9 #define LIST
10
11 // ------------------------------
12 #include "Auxiliary.h"
13 #include "Avatar.h"
14 #include "AxisLock.h"
15 #include "Box.h"
16 #include "Border.h"
17 #include "Cone.h"
18 #include "Cylinder.h"
19 #include "Damper.h"
20 #include "Drag.h"
21 #include "Filter.h"
22 #include "Grid.h"
23 #include "Log.h"
24 #include "Marker.h"
25 #include "MarkerFactory.h"
26 #include "NavSphere.h"
27 #include "Plane.h"
28 #include "ProxiBox.h"
29 #include "ProxiBorder.h"
30 #include "ProxiCylinder.h"
31 #include "ProxiSphere.h"
32 #include "Sphere.h"
33 #include "Trace.h"
34 #include "Vibration.h"
35 #include "VibrationLabel.h"
36 #include "VibrationLabelActivator.h"
37 // ------------------------------
38
39
40 extern "C" const char AP_EXPORT **VirtualFixture_getAbilityList(void);
41 extern "C" Ability AP_EXPORT *VirtualFixture_getAbilityInstance(const char *_name);
42 extern "C" const char * AP_EXPORT VirtualFixture_getAbilityDescription(const char * name);
43 extern "C" void AP_EXPORT VirtualFixture_setAbilitiesParameters(void);
44 extern "C" const char * AP_EXPORT VirtualFixture_getPluginDescription(void);
45
46 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/AP_base.h Source File

  • File List
  • File Members
  • include
  • base
AP_base.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "Display.h"
10 #include "ShowFDH.h"
11 #ifndef WIN32
12 #include "ShowFDHModel.h"
13 #endif
14 #include "hand.h"
15 #include "Avatar.h"
16 #include "Rotate.h"
17 #include "MouseHand.h"
18 #include "SystemInfo.h"
19 #include "Light.h"
20
21 // ------------------------------
22
23
24 extern "C" const char AP_EXPORT **getAbilityList(void);
25 extern "C" Ability AP_EXPORT *getAbilityInstance(const char *_name);
26 extern "C" const char AP_EXPORT *getAbilityDescription(const char *name);
27 extern "C" void AP_EXPORT setAbilitiesParameters(void);
28 extern "C" const char AP_EXPORT *getPluginDescription(void);
29 extern "C" void AP_EXPORT initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/AP_behindO.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
AP_behindO.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "Mirror.h"
10 #include "Lens.h"
11 #include "WIM.h"
12 #include "ChangeOfVisibility.h"
13 #include "CuttingPlane.h"
14 #include "Manipulator.h"
15 #include "HeadManipulator.h"
16 #include "HMDHeadManipulator.h"
17 #include "CentreObjectManipulator.h"
18 #include "ContactObjectManipulator.h"
19 #include "BehindObstacleExperiment.h"
20 #include "BehindObstacleExp_wT.h"
21 #include "AvatarManipulator.h"
22 #include "EyeManipulator.h"
23 #include "MappingFunctions.h"
24
25 // ------------------------------
26
27
28 extern "C" const char AP_EXPORT **behindO_getAbilityList(void);
29 extern "C" Ability AP_EXPORT *behindO_getAbilityInstance(const char *_name);
30 extern "C" const char AP_EXPORT *behindO_getAbilityDescription(const char *name);
31 extern "C" void AP_EXPORT behindO_setAbilitiesParameters(void);
32 extern "C" const char AP_EXPORT *behindO_getPluginDescription(void);
33 extern "C" void AP_EXPORT behindO_initializeAttributesDescription() {}
34
35 //$Id: AP_behindO.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/AP_boids.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
AP_boids.h
Go to the documentation of this file.
1 /*
2 Boids - virtualny krdel (roj, hejno) vtakov, ryb, hmyzu ...
3 Michal Pancik, 172460
4 Laborator interakci cloveka s pocitacem
5 2008
6
7 Problematiku boidov rozpracoval Craig W. Reynolds
8 - http://www.red3d.com/cwr/
9 Uzitocne vysvetlenie a pseudokod napisal Conrad Parker
10 - http://www.metadecks.org/~conrad/boids/pseudocode.html
11 */
12
13 #include <vrecko/Ability.h>
14 #include <vreckoAP/Export>
15
16 #define INSTANCE
17 #define LIST
18
19 // ------------------------------
20 #include "Boid.h"
21 #include "BoidsLogic.h"
22 #include "BoidsPlanner.h"
23 // ------------------------------
24
25 extern "C" const char AP_EXPORT **boids_getAbilityList(void);
26 extern "C" Ability AP_EXPORT *boids_getAbilityInstance(const char *_name);
27 extern "C" const char AP_EXPORT *boids_getAbilityDescription(const char *name);
28 extern "C" const char AP_EXPORT *boids_getPluginDescription(void);
29 extern "C" void AP_EXPORT boids_initializeAttributesDescription() {}
30
31
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/AP_games.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • games
AP_games.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "ChessBoard.h"
10 #include "ChessPiece.h"
11 // ------------------------------
12
13
14 extern "C" const char AP_EXPORT **getAbilityList(void);
15
16 extern "C" Ability AP_EXPORT *getAbilityInstance(const char *_name);
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/AP_navigation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
AP_navigation.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "KMTracker.h"
10 #include "AvatarInHand.h"
11 // ------------------------------
12
13
14 extern "C" const char AP_EXPORT **navigation_getAbilityList (void);
15
16 extern "C" Ability AP_EXPORT * navigation_getAbilityInstance (const char *_name);
17 extern "C" void AP_EXPORT navigation_initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/AP_ode.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
AP_ode.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "DynamicScene.h"
10 #include "Sphere.h"
11 #include "Cube.h"
12 #include "CappedCylinder.h"
13 #include "CompositeObject.h"
14 // ------------------------------
15
16 extern "C" const char AP_EXPORT **ode_getAbilityList(void);
17 extern "C" Ability AP_EXPORT *ode_getAbilityInstance(const char *_name);
18 extern "C" const char AP_EXPORT *ode_getAbilityDescription(const char *name);
19 extern "C" void AP_EXPORT ode_setAbilitiesParameters(void);
20 extern "C" const char AP_EXPORT *ode_getPluginDescription(void);
21 extern "C" void AP_EXPORT ode_initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Ability.h Source File

  • File List
  • File Members
  • include
  • vrecko
Ability.h
Go to the documentation of this file.
1
12 #ifndef ABILITY_H
13 #define ABILITY_H
14
15 #include <osg/Vec3>
16
17 #include <vector>
18
19 #include <vrecko/BaseClass.h>
20
21 #include <vrecko/Message.h>
22 #include <vrecko/Scheduler.h>
23
24 #include <vrecko/MTLock.h>
25
26
27 //#include <xercesc/parsers/AbstractDOMParser.hpp>
28 //--------------------
29
30 namespace vrecko {
31
32
33 class VRECKO_EXPORT EnvironmentObject;
34 class VRECKO_EXPORT World;
35
37 class VRECKO_EXPORT Ability: public BaseClass {
38 protected:
39 // Ability() { pOwner = NULL; }; // no default constructor -> force to create Ability with a name
40
58 Ability(const char* theAbilityName);
59
60 //Ability(const char* abName, const char *plName) {abilityName = abName; pluginName = plName;}
62 public:
63 virtual ~Ability();
64
70 const std::string &getName() const {return abilityName;}
79 void setPluginName(const char *pName);
80
82 const std::string &getPluginName(void) const {return pluginName;}
83
94 const std::string &getID(void) const {return abilityID;}
95
112 void setID(const char *pID);
113
114 virtual void clean(void) {};
115
125 void setOwner(BaseClass *owner) { pOwner = owner;}
126
135 BaseClass *getOwner(void) {return pOwner;}
136
138 // virtual std::string getAcceptableMessages(void) {return std::string("");}
139
140 // VYHODIT -----------------------------------
142 typedef struct {
143 std::string name;
144 std::string description;
145 // IO_Type type;
146 std::string range;
147 } ParameterStruct;
148
150 typedef std::vector<ParameterStruct> ParameterVector;
151
153 virtual ParameterVector *getParameterVector(void) {return NULL;}
154 // VYHODIT -----------------------------------
155
157 // void setUpdateFlag(bool state) {updated = state;}
158
160
165 bool isUpdated(void);
166
167
168
176 virtual const std::string &getSenderString(void);
177
178 protected:
180 BaseClass *pOwner;
181
184 std::vector<std::string> parameterString;
186
188 bool updated;
189
190 private:
192 std::string pluginName;
193
196 std::string abilityName;
197
201 std::string abilityID;
202
203 // last parent's senderString
204 std::string lastParentSenderString;
205 };
206
207
221 class AbilityDispatcher: public BaseClass {
222 public:
223 AbilityDispatcher();
224 ~AbilityDispatcher();
225
228 void addAbility(Ability *pAbility);
230 void removeAbility(Ability *pAbility);
231 void removeAllAbilities();
233 Ability *getAbility(const std::string &ab_id);
235 typedef std::map<std::string, Ability*> AbilityMap;
236 AbilityMap &getAbilityMap(void) {return ability_name_map;}
237
238 // Ability *getAppropriateAbility(const std::string &message_ID);
239 Ability *getAbilityWithInput(const std::string &input_name);
240 Ability *getAbilityWithOutput(const std::string &output_name);
241
242 protected:
243
245 std::map<std::string, Ability*> ability_map;
247 AbilityMap ability_name_map;
248
249 MTLock mainLock;
250 };
251
252 }
253
254
255 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AbilityEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
AbilityEditor.h
Go to the documentation of this file.
1 #ifndef ABILITYEDITOR_H
2 #define ABILITYEDITOR_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7 #include <helpers/DynamicArray.h>
8 #include "../ObjectUtils/ConnectionViz.h"
9
10
11 namespace APEditorQAbilities {
12
13 class AbilityEditor: public vrecko::ControllableAbility {
14 public:
15 AbilityEditor();
16 virtual ~AbilityEditor() { deactivate(); };
17 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
18
19 protected:
20
21 class AllowedAbility {
22 public:
23 std::string abilityName;
24 std::string pluginName;
25
26 // auxiliary variables for the menu creation
27 bool bProcessed;
28 };
29
30 DynamicArray<AllowedAbility> allowedAbilities;
31
32 unsigned long object1ID, object2ID;
33 vrecko::EnvironmentObject *object1, *object2;
34 // these variables are reliable only in the menuItemClicked() and subsequent functions
35
36 APObjectUtils::ConnectionViz *conViz;
37
38 virtual void fillDefaultInfo();
39 virtual bool activate();
40 virtual void deactivate();
41 virtual void processButtonRelease(vrecko::CABUTTONEVENT* eventData);
42 virtual void menuItemClicked(const char* itemID);
43
44 bool createConnectionViz();
45 void destroyConnectionViz();
46
47 bool executeAddAbility(int iIndex);
48 bool executeDeleteAbility(const char *abilityID);
49 bool executeAddConnection(const char *connectionMenuString);
50 bool executeDeleteConnection(const char *connectionMenuString);
51 };
52
53 }
54
55 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/AbilityMapper.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
AbilityMapper.h
Go to the documentation of this file.
1 #ifndef ABILITY_MAPPER_H
2 #define ABILITY_MAPPER_H
3
4 #include "ControllableAbility.h"
5 #include <vrecko/EnvironmentObject.h>
6
7 using namespace vrecko;
8
9 namespace APEditorController {
10
11 class AbilityMapper: public ControllableAbility {
12 public:
13
14 struct BUTTON_MAPPING {
15 int pointerID;
16 int buttonID;
17 std::string mappedAbility;
18 };
19
20 struct MAPPING {
21 std::vector<BUTTON_MAPPING> vector;
22 MAPPING & operator=(const MAPPING &rhs) {
23 vector.assign(rhs.vector.begin(), rhs.vector.end());
24 return *this;
25 }
26 };
27
28 class MessageMapping : public VreckoMessage {
29 public:
30 virtual const char* getMessageId() { return "MessageMapping"; }
31 MAPPING data;
32 };
33
34 AbilityMapper();
35 virtual ~AbilityMapper();
36
37 // virtual void processEvent(const std::string &strInputName, void *pValue);
38
39 protected:
40 MAPPING mapping;
41
42 virtual void createInterface();
43
44 virtual void fillDefaultInfo();
45 virtual bool activate();
46 virtual void menuItemClicked(const char* itemID);
47
48 void sendNewMapping();
49
50 DECLARE_INPUT(Mapping, MessageMapping);
51 DECLARE_OUTPUT(Mapping, MessageMapping);
52 };
53
54 }
55
56
57 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/Animator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
Animator.h
Go to the documentation of this file.
1 #ifndef ANIMATOR_H
2 #define ANIMATOR_H
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/IOPins.h>
6 #include <vrecko/Timer.h>
7 #include <helpers/DynamicArray.h>
8
9 using namespace vrecko;
10
11 namespace APObjectUtils
12 {
13
14
15 #ifndef ANIMATOR_IMP_EXP
16 #ifdef AP_OBJECTUTILS_EXPORTS
17 #define ANIMATOR_IMP_EXP __declspec(dllexport)
18 #else
19 #define ANIMATOR_IMP_EXP __declspec(dllimport)
20 #endif
21 #endif
22
23
24 class ANIMATOR_IMP_EXP Animator: public Ability
25 {
26 public:
27
28 class AnimationPoint {
29 public:
30 AnimationPoint();
31
32 osg::Vec3 translation;
33 osg::Quat rotation;
34 osg::Vec3 scale;
35
36 float fAlpha;
37
38 osg::Node::NodeMask nodeMask;
39 };
40
41 static Animator* getAnimatorOnObject(vrecko::EnvironmentObject *object);
42 // Returns an animator if there is one.
43
44 static Animator* addAnimatorToObject(vrecko::EnvironmentObject *object, bool bReuseOldIfPossible = true);
45 // Creates an Animator ability and assignes it to the object.
46 // If the object already had an ability of this type, it will be returned
47 // and no new ability will be created.
48
49
50 // Which properties are being animated?
51 enum AnimationTypes {
52 AnimSRT = 1, // Scaling + Rotation + Translation
53 AnimAlpha = 2, // Transparency
54 AnimNodeMask = 4 // Node mask
55 // (The mask is interpolated: The masks of the nearest animation points are ORed)
56 };
57 enum LoopType {
58 NoLoop, // No looping
59 Simple, // Simple looping
60 BiDi // Bi-directional looping (ping-pong)
61 };
62 enum InterpolationType {
63 Linear, // linear interpolation
64 Sine // sine interpolation with soft start and finish
65 };
66
67 Animator();
68 virtual ~Animator();
69
70 virtual void preInitialize();
71 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
72 virtual void update();
73 // virtual void processEvent(const std::string &strInputName, void *pValue);
74 virtual void clean();
75
76 bool removeAnimation();
77
78 bool isAnimating() { return bAnimating; };
79
80 bool stopAnimation();
81 bool startAnimation();
82
83 bool animateToPoint(int pointIndex);
84
85 /* Stops the animation and sets to position to the specified one.
86 Allowed values are from 0.0f to "animationPointsNumber - 1" where 0.0f = start,
87 "animationPointsNumber - 1" = end */
88 bool resetToPos(float fPos);
89
90
91 bool setAnimationPointsNumber(unsigned int number);
92 inline unsigned int getAnimationPointsNumber() { return points.dwNum; }
93
94 bool setEnabledAnimations(unsigned long dwAnimations);
95 // the [dwAnimations] is a combination of Animator::AnimationTypes
96 inline unsigned long getEnabledAnimations() { return enabledAnimations; }
97 // the [dwAnimations] is a combination of Animator::AnimationTypes
98
99 bool setTranslation(int pointIndex, const osg::Vec3 &trans);
100 osg::Vec3 &getTranslation(int pointIndex);
101
102 bool setRotation(int pointIndex, const osg::Quat &rot);
103 inline osg::Quat &getRotation(int pointIndex);
104
105 bool setScale(int pointIndex, const osg::Vec3 &scale);
106 osg::Vec3 &getScale(int pointIndex);
107
108 bool setAlpha(int pointIndex, float alpha); // 0.0 to 1.0
109 float getAlpha(int pointIndex);
110
111 bool setNodeMask(int pointIndex, osg::Node::NodeMask nodeMask);
112 osg::Node::NodeMask getNodeMask(int pointIndex);
113
114 bool setTimePerLoop(float timeInS) { timePerLoop = timeInS; return true; };
115 inline float getTimePerLoop() { return timePerLoop; }
116
117 bool setLoopType(LoopType newType) { loopType = newType; return true; };
118 inline LoopType getLoopType() { return loopType; };
119
120 bool setInterpolationType(InterpolationType newType) { interpolationType = newType; return true; };
121 inline InterpolationType getInterpolationType() { return interpolationType; };
122
123 bool setTransformationFromMatrix(int startPointIndex, int endPointIndex, const osg::Matrix &matrix);
124
125 /* Returns the tranformation matrix belonging to the specified _actual_ position.
126 Allowed values are from 0.0f to "animationPointsNumber - 1" where 0.0f = start,
127 "animationPointsNumber - 1" = end */
128 bool getAnimMatrix(float fActPos, osg::Matrix &outMatrix);
129
130 protected:
131 EnvironmentObject *owner;
132
133 unsigned int enabledAnimations;
134 LoopType loopType;
135 InterpolationType interpolationType;
136
137 DynamicArray<AnimationPoint> points;
138
139 osg::ref_ptr<osg::StateSet> stateSet;
140
141 /* osg::Vec3 translationFrom, translationTo;
142 osg::Vec3 rotationAxisStart, rotationAxisDirFrom, rotationAxisDirTo;
143 float rotationAngleFrom, rotationAngleTo;
144 osg::Matrix cachedRotationTransformation1, cachedRotationTransformation2;
145 // Cached transformations to transform TO and FROM rotation axis start.
146
147 osg::Vec3 scaleFrom, scaleTo;
148 // osg::Quat scaleOrientation;
149 */
150
151 float timePerLoop; // time in seconds
152
153 bool bAnimating;
154 float fActTime; // MAIN CONTROL of the animation (0.0 to "animationPointsNumber - 1" for one loop)
155 int iActDir; // current direction of the animation (1 or -1)
156
157 osg::Timer_t lastTimerTick;
158
159 float convertActTimeToActPos();
160 // Returns a number (0.0 <= number <= (animationPointsNumber - 1))
161 // Includes any ease in or out, dumping or whatever will be available.
162 float convertActPosToNormPos(float fActPos, int *outPoint1, int *outPoint2);
163 // Returns normalized position (0.0 <= "normPos" <= 1.0) along with
164 // the boundary points (1 and 2)
165
166 bool updateActTime();
167 bool updateAnimation(float fActPos);
168
169 bool calcAnimMatrix(float fNormPos, int iPoint1, int iPoint2, osg::Matrix &outMatrix);
170 // 0.0f <= [fNormPos] <= 1.0
171
172 DECLARE_INPUT(Trigger, MessageVoid);
173 DECLARE_INPUT(AnimateToPoint, MessageInt);
174
175 DECLARE_OUTPUT(AnimationEnded, MessageBool);
176 };
177
178 }
179
180
181 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AnimatorEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
AnimatorEditor.h
Go to the documentation of this file.
1 #ifndef ANIMATOREDITOR_H
2 #define ANIMATOREDITOR_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7 #include "../ObjectUtils/Animator.h"
8
9 using namespace vrecko;
10
11 namespace APEditorQAbilities {
12
13
14 class AnimatorEditor: public ControllableAbility {
15 public:
16 AnimatorEditor();
17 virtual ~AnimatorEditor() {};
18
19 protected:
20 virtual void fillDefaultInfo();
21 virtual bool activate();
22 virtual void menuItemClicked(const char* itemID);
23
24 /* Returns the Animator ability associated to the object or creates one if the ability
25 doesn't exist yet. */
26 APObjectUtils::Animator *GetAnim(bool bCreateIfNotExists = false);
27 };
28
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/AntiGravityFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
AntiGravityFilter.h
Go to the documentation of this file.
1 #ifndef ANTIGRAVITY_FILTER_H
2 #define ANTIGRAVITY_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 class AntiGravityForceFilter : public PHANToMFilter {
11 public:
12 AntiGravityForceFilter();
13
14 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
15
16 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
17
18 protected:
19 };
20
21 }
22
23 #endif
24
25
26 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Attractor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Attractor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "poa.h"
4 #include "Parameters.h"
5 #include "Utils.h"
6
7 namespace APDYNAMICART
8 {
9
18 typedef enum AttractorRenderingType {
19 ATT__RENDER_POINTS = 1,
20 ATT__RENDER_LINES,
21 ATT__RENDER_TRIANGLES,
22 //ATT__RENDER_SURFACE,
23 };
24 class Attractor;
25
26 typedef std::vector<std::string> AttractorNames;
27 typedef osg::ref_ptr<Attractor> AttractorPtr;
28
29 class Attractor : public PoA
30 {
31 public:
33 virtual std::string createMenuStructure( void ) const { return std::string(); };
34 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode ) { return 0; };
35 virtual void GUIItemClicked( const char* itemID ) {};
36 virtual void GUISliderChanged( const char* sliderID, float sliderPos ) {};
37 virtual void pointed( bool pointed ) {};
38 //virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ) {};
39 virtual void setColor( osg::Vec4 newColour ) {};
40 virtual void update() {};
41
43 static AttractorPtr createInstance( std::string attName, Controller* controller );
44 static AttractorNames getAvailableAttractors();
45
47 void generate();
48 virtual void init() {};
49 virtual void compute() = 0;
50
52 Parameters& getParameters() { return _params; };
53
54 protected:
56 Parameters _params;
57 float _size;
59 Attractor(Controller* controller) : PoA(controller) {};
60
62 void setSliderParameter( const char* sliderID, float sliderPos );
63 bool valueChanged( float sliderPos );
64 IMenuComponentPtr createParameterSubMenu() const;
65 };
66
67 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Attribute.h Source File

  • File List
  • File Members
  • include
  • vrecko
Attribute.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _ATTRIBUTE_H_
15 #define _ATTRIBUTE_H_
16
17 // STL includes
18 #include <string>
19
20 // namespaces used
21 using namespace std;
22
23 // VRECKO namespace
24 namespace vrecko
25 {
26
27 // null definition
28 #define null 0
29
39 class Attribute
40 {
41 public:
42
52 enum DataType
53 {
54 TYPE_BOOL,
55 TYPE_INT,
56 TYPE_LONG,
57 TYPE_FLOAT,
58 TYPE_DOUBLE,
59 TYPE_STRING,
60 TYPE_VEC2,
61 TYPE_VEC3,
62 TYPE_VEC4,
63 TYPE_MATRIX,
64 TYPE_QUAT,
65 TYPE_DYNAMIC
66 };
67
73 inline const string& getName() const
74 {
75 return strName;
76 }
77
83 inline DataType getDataType() const
84 {
85 return dataType;
86 }
87
93 inline const string& getDescription() const
94 {
95 return strDescription;
96 }
97
103 inline bool isStatic() const
104 {
105 return (getDataType() != TYPE_DYNAMIC);
106 }
107
113 inline bool isDynamic() const
114 {
115 return (getDataType() == TYPE_DYNAMIC);
116 }
117
118 protected:
119
127 Attribute(const string& strName, DataType dataType, const string& strDescription)
128 {
129 // initialize all the attributes
130 this->strName = strName;
131 this->dataType = dataType;
132 this->strDescription = strDescription;
133 }
134
140 Attribute(const Attribute& attribute)
141 {
142 *this = attribute;
143 }
144
145 private:
146
147 // general attribute attributes
148 string strName;
149 DataType dataType;
150 string strDescription;
151 };
152
153 // end of vrecko namespace
154 }
155
156 // end header definitions
157 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/AttributesDescription.h Source File

  • File List
  • File Members
  • include
  • vrecko
AttributesDescription.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _ATTRIBUTES_DESCRIPTION_H_
15 #define _ATTRIBUTES_DESCRIPTION_H_
16
17 // attributes description includes
18 #include "Attribute.h"
19 #include "DynamicAttribute.h"
20
21 // STL includes
22 #include <string>
23 #include <list>
24 #include <map>
25
26 // namespaces used
27 using namespace std;
28
29 // VRECKO namespace
30 namespace vrecko
31 {
32
44 class AttributesDescription
45 {
46 public:
47
51 ~AttributesDescription()
52 {
53 // prepare the internal iterator
54 attributesListIter = attributesList.begin();
55
56 // while the iterator is not at the end
57 while (attributesListIter != attributesList.end())
58 {
59 // if the pointer is not null
60 if (*attributesListIter != null)
61 {
62 // delete the data and null the pointer
63 delete *attributesListIter;
64 *attributesListIter = null;
65 }
66
67 // increment the iterator
68 attributesListIter++;
69 }
70 }
71
84 bool addAttribute(Attribute* pAttribute)
85 {
86 // if the name already exists, or the attribute is dynamic and has no sub-attributes
87 if (containsAttribute(pAttribute->getName()) || (pAttribute->isDynamic()
88 && ((DynamicAttribute*) pAttribute)->attributesCount() == 0))
89 {
90 // delete the data and null the pointer
91 delete pAttribute;
92 pAttribute = null;
93
94 return false;
95 }
96
97 // insert the attribute into both containers
98 attributesList.push_back(pAttribute);
99 attributesMap[pAttribute->getName()] = pAttribute;
100
101 return true;
102 }
103
109 inline bool hasAnyAttributes() const
110 {
111 return !attributesList.empty();
112 }
113
119 inline unsigned int attributesCount() const
120 {
121 return attributesList.size();
122 }
123
131 inline bool containsAttribute(const string& strName) const
132 {
133 return (attributesMap.find(strName) != attributesMap.end());
134 }
135
143 inline const Attribute* getAttributePtr(const string& strName) const
144 {
145 return attributesMap.find(strName)->second;
146 }
147
151 inline void startIteration()
152 {
153 attributesListIter = attributesList.begin();
154 }
155
167 inline bool hasNextAttribute() const
168 {
169 return (attributesListIter != attributesList.end());
170 }
171
183 inline const Attribute* nextAttributePtr()
184 {
185 return *attributesListIter++;
186 }
187
188 private:
189
190 // containers
191 list<Attribute*> attributesList;
192 map<string, const Attribute*> attributesMap;
193
194 // internal list iterator
195 list<Attribute*>::iterator attributesListIter;
196 };
197
198 // end of vrecko namespace
199 }
200
201 // end header definitions
202 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Auxiliary.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Auxiliary.h
Go to the documentation of this file.
1 #ifndef VF_AUXILIARY_H
2 #define VF_AUXILIARY_H
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Timer>
7
8 #include <osg/Vec3>
9
10 using namespace vrecko;
11 using namespace vreckoDP_base;
12 namespace VirtualFixture{
13
14 //Where is stored MAXFORCE in VRECKO?
15 #define MAXFORCE 7.0
16 #define SMOOTHING_RADIUS 0.05
17
18 #define MINF 0.1
19
20 //#define MULTIPLIER 50.0 //Flasik magic constant
21 //#define ADDITIONX 0.0 //Flasik magic constant
22 //#define ADDITIONY -3.0 //Flasik magic constant
23 //#define ADDITIONZ -1.0 //Flasik magic constant
24 #define MULTIPLIER 1.0
25 #define ADDITIONX 0.0
26 #define ADDITIONY 0.0
27 #define ADDITIONZ 0.0
28
29
30 #define WSXMIN -0.24 * MULTIPLIER + ADDITIONX
31 #define WSXMAX 0.24 * MULTIPLIER + ADDITIONX
32 #define WSYMIN -0.10 * MULTIPLIER + ADDITIONY
33 #define WSYMAX 0.39 * MULTIPLIER + ADDITIONY
34 #define WSZMIN -0.12 * MULTIPLIER + ADDITIONZ
35 #define WSZMAX 0.16 * MULTIPLIER + ADDITIONZ
36
37 #define ZEROXDISTANCE 0 * MULTIPLIER + ADDITIONX
38 #define ZEROYDISTANCE 0.14 * MULTIPLIER + ADDITIONY
39 #define ZEROZDISTANCE -0.13 * MULTIPLIER + ADDITIONZ
40 #define MINBORDERRADIUS 0.13 * MULTIPLIER
41 #define MAXBORDERRADIUS 0.24 * MULTIPLIER
42
43 extern osg::Timer timer; //declaration of timer
44
45 extern "C" osg::Vec3 ControlActualPositionReturnCleanPosition(osg::Vec3 Actual); //this function check if phantom position is not close to workspace edge -> return closest point on edge
46
47 extern "C" bool ControlActualPosition(osg::Vec3 Actual); //this function check if phantom position is not close to workspace edge -> return true if inside, false if beyond border
48
49 //vibration generator
50 extern "C" osg::Vec3 Vibrate(float frequency, float amplitude, osg::Vec3 direction); //update vector so it will produce vibration movement with proper direction and amplitude with preset frequency
51
52 //Transform function from computed force (from any algorythm) to (0,maxf) by special function (logarithmic)
53 extern "C" osg::Vec3 ForceTransformFunction(float maxforce, osg::Vec3 force); //transform function (linear) to log(f);result in (0,maxforce)
54
55 //this function is called by cylinder etc., it will check if t param is in (0,1) and return 1 if in,
56 //close (defined by SMOOTHING_RADIUS) to value 0, or 1 it will produce some smooth increase/decrease (for better connection of two fixtures)
57 extern "C" float SmoothEnding(float t); //t is "time" param on vector
58 }
59 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/AvatarInHand.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
AvatarInHand.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vrecko/Scene.h>
3 #ifndef WIN32
4 #include <sys/time.h>
5 #endif
6 #include <time.h>
7
8 #include <vrecko/EnvironmentObject.h>
9 #include <vrecko/World.h>
10
11 using namespace vrecko;
12
13 namespace navigation {
14 class AvatarInHand: public Ability {
15 public:
16 AvatarInHand();
17 ~AvatarInHand(){};
18
19 // ------ BaseClass functions ------------------------
20 void postInitialize(void);
21
23 // void receiveEvent(const std::string &input_name, void *value);
24 void processEvent(const std::string &input_name, VreckoMessage *message);
25
26 // ---------------------------------------------------
27
28 void initialize(void);
29 void update(void);
30 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
31 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
32
33
34 std::string getAcceptableMessages(void) {return "";}
35 protected:
36 EnvironmentObject *eo;
37 osg::Vec3 _actual_position, _last_position;
38 World::AvatarView *av;
39 osg::Vec3 avatar_position;
40 osg::Vec3 avatar_look_at;
41 osg::Vec3 avatar_up_vector;
42 osg::Vec3 _actual_left_hand_position, _actual_right_hand_position, _actual_head_position;
43 osg::Quat _actual_left_hand_orientation, _actual_right_hand_orientation, _actual_head_orientation;
44 osg::Vec3 grab_position;
45
46 osg::Quat* qc;
47 osg::Quat* qc_old; // Quaternion of control
48 osg::Quat* qd_old2;
49 osg::Quat* qd;
50 osg::Quat* qd_old; // Quat of display
51 osg::Quat* qd_init;
52 osg::Quat q;
53
54
55 double angle;
56 bool absolut;
57 bool pom;
58 bool fly;
59 bool start;
60 osg::Vec3 av_pos;
61 string mesg;
62 bool immersive;
63 float const_d;
64
65 DECLARE_OUTPUT(Position, MessageVec3);
66 DECLARE_OUTPUT(Orientation, MessageQuat);
67 };
68 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/AvatarManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
AvatarManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Vec3>
4 #include <osg/Quat>
5 #include <osg/Matrix>
6
7
8 using namespace vrecko;
9
10 namespace behindO {
11
12 class AvatarManipulator: public Ability {
13 public:
14 AvatarManipulator();
15 ~AvatarManipulator() {};
16
17 // ------ BaseClass functions ------------------------
19 void processEvent(const std::string &input_name, void *value);
20 // ---------------------------------------------------
21
22 void preInitialize(void);
23 void update(void);
24
25 std::string getAcceptableMessages(void) {return "boolean|state";} // true/false, 0/1
26
27 protected:
28 //osg::Vec3 grab_position, actual_position, last_position, center_rotation;
29
30 //osg::Vec3 avatar_eye, avatar_center, avatar_up_vector;
31
32 int control;
33 bool _first;
34
35 osg::Vec3 sensor_relative_pos, initial_sensor_pos, last_sensor_pos;
36 osg::Quat last_sensor_orientation;
37 float eye_distance_scale_factor;
38 osg::Vec3 head_center, eye_position, up_vector, look_at_center, to_center;
39
40 osg::Vec3 EO_owner_grab_pos, avatar_grab_pos;
41 osg::Matrix EO_owner_grab_rot, avatar_grab_transform, avatar_grab_inverse_transform, avatar_grab_rotation, avatar_grab_inverse_rotation;
42 osg::Matrix EO_owner_grab_Wrot;
43
44 bool active;
45
46 EnvironmentObject *owner;
47 };
48
49 }
50
51 //$Id: AvatarManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/AvatarMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
AvatarMovement.h
Go to the documentation of this file.
1 #ifndef AVATARMOVEMENT_H
2 #define AVATARMOVEMENT_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include <vrecko/Ability.h>
6 #include <vrecko/World.h>
7 //#include <vrecko/EnvironmentObject.h>
8
9 using namespace vrecko;
10
11 namespace APEditorQAbilities {
12
13 class AvatarMovement: public ControllableAbility {
14 public:
15 AvatarMovement();
16 virtual ~AvatarMovement();
17
18 void update(void);
19
20 protected:
21 virtual void fillDefaultInfo();
22
23 virtual bool activate();
24 virtual void deactivate();
25
26 osg::Vec3 lastRelPointerPos; // last pointer position relative to AvatarView
27 osg::Quat lastRelPointerRot; // ... and last pointer rotation
28
29 bool bFirstUpdate;
30 };
31
32 }
33
34
35 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/AxisLock.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
AxisLock.h
Go to the documentation of this file.
1 #ifndef VF_AXISLOCK
2 #define VF_AXISLOCK
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7 using namespace vrecko;
8 using namespace vreckoDP_base;
9 namespace VirtualFixture{
10
11 class AxisLock: public PHANToMFilter {
12 public:
13 AxisLock();
14 ~AxisLock() {};
15
17 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
18 void processEvent(const std::string &input_name, void *value);
19
20 void preInitialize(void);
21 void postInitialize(void);
22 void update(void);
23
24 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
26
27 protected:
28 PHANToM *PHANToMDevice;
29 bool all_on;
30 bool active; //VF switcher
31 bool locked; //if true -> locked
32 osg::Vec3 position; //position of starting point
33 float nullradius; //radius close to centre, where attractive field is NOT applied
34 float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
35 string defstring; //definition of lock (what axis will be locked)
36 };
37
38 };
39 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseActor.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
BaseActor.h
Go to the documentation of this file.
1 #ifndef BaseActor_h
2 #define BaseActor_h
3
4 #include "UpdatablePhysXObject.h"
5 #include "PhysXVreckoMessages.h"
6
7 using namespace vrecko;
8 using namespace vrecko;
9
10 namespace PhysXPlugin
11 {
12 class BaseActor : public UpdatablePhysXObject
13 {
14 private:
15 osg::Quat _firstRotation;
16 osg::Vec3 _firstPosition;
17
18 bool BDynamicActorOutputs() const { return _bDynamicActorOutputs; }
19 void BDynamicActorOutputs(bool val);
20 void UpdateDynamicActorOutputs();
21 public:
22 BaseActor(const char* abName): UpdatablePhysXObject(abName),_bDynamicActorOutputs(false)
23 {
24 _move_step_limit = -1.0;
25 }
26 virtual ~BaseActor();
27
28 virtual void Create();
29
30 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
31 virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
32
33 virtual void postInitialize();
34
35
36 // virtual void processEvent(const std::string& input_name, void * value);
37 protected:
38 bool _bDynamicActorOutputs;
39 NxActorDesc _actorDesc;
40 NxBodyDesc _bodyDesc;
41 std::string _MaterialName;
42
43 NxMaterialIndex _MaterialIndex;
44 NxActor* _pPO;
45
46 float _move_step_limit;
47
48 void UpdateEnvironmentObject();
49
50 DECLARE_INPUT(ResetPosition, MessageBool);
51 DECLARE_INPUT(MoveTo, MessageVec3);
52 DECLARE_INPUT(RotateTo, MessageQuat);
53 DECLARE_INPUT(DynamicActorOutputs, MessageBool);
54
55 DECLARE_OUTPUT(LinearMomentum, MessageVec3);
56 DECLARE_OUTPUT(AngularMomentum, MessageVec3);
57 DECLARE_OUTPUT(LinearVelocity, MessageVec3);
58 DECLARE_OUTPUT(AngularVelocity, MessageVec3);
59
60 DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex);
61 DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool);
62 };
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/BaseClass.h Source File

  • File List
  • File Members
  • include
  • vrecko
BaseClass.h
Go to the documentation of this file.
1
13 #ifndef BASECLASS_H
14 #define BASECLASS_H
15
16 #include <vrecko/Export>
17
18 #include <vector>
19 #include <string>
20 #include <map>
21
22 #include <vrecko/MTLock.h>
23 #include <vrecko/Message.h>
24
25 //#include <osg/Timer>
26
27 //#include <xercesc/parsers/AbstractDOMParser.hpp>
28 //#include <xercesc/dom/DOMDocument.hpp>
29
30 #include <xercesc/util/XercesDefs.hpp>
31
32 #include <vrecko/Logger.h>
33
34 XERCES_CPP_NAMESPACE_BEGIN
35 class DOMNode;
36 class DOMDocument;
37 XERCES_CPP_NAMESPACE_END
38
39
40 namespace vrecko {
41
42 class VRECKO_EXPORT AutoPtrV;
43 class VRECKO_EXPORT World;
44 class VRECKO_EXPORT BaseClass;
45
46 #define EVENTDISPATCHER_PRIORITY -1000000
47
60 class IOPinBase : public osg::Referenced {
61 public:
69 std::string& getPinName() { return pinName; };
70
80 virtual VreckoMessage* createCompatibleMessage() = 0;
81 protected:
82 std::string pinName;
83 BaseClass *owner;
84 };
85
86
87 class InputPinBase : public IOPinBase {
88 public:
95 virtual void processMessage(VreckoMessage *message) = 0;
96 };
97
98 class OutputPinBase : public IOPinBase {
99 };
100
101
102 class IORequestPinBase : public IOPinBase {
103 public:
109 virtual VreckoMessage* createReturningCompatibleMessage() = 0;
110 };
111
112 class RequestInputPinBase : public IORequestPinBase {
113 public:
120 virtual osg::ref_ptr<VreckoMessage> processRequest(VreckoMessage *message) = 0;
121 };
122
123 class RequestOutputPinBase : public IORequestPinBase {
124 };
125
126
129 class VRECKO_EXPORT BaseClass {
130 protected:
132 typedef std::map<std::string, int> AttributeMap;
133 AttributeMap attribute;
134 MTReadWriteLock attributeLock;
135
136 public:
153 BaseClass(const char* startingSenderString);
154
161 BaseClass(BaseClass &bc);
162
170 virtual ~BaseClass();
171
190 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
191
201 virtual bool initializeFromString(const char *xmlString);
202
203
210 virtual void update(void) {};
211
220 virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) {return NULL;}
221
222 // /// Types of an input/output and parameter.
223 // OBSOLETE after the message revolution in summer 2011.
224 //
225 // typedef enum {
226 // UNKNOWN = 0,
227 // BOOL,
228 // INT,
229 // UINT,
230 // LONG_INT,
231 // ULONG,
232 // FLOAT,
233 // DOUBLE,
234 // STRING,
235 // MESSAGE,
236 // VEC2,
237 // VEC3,
238 // VEC4,
239 // MATRIX,
240 // QUAT,
241 // POINTER,
242 // VEC3ARRAY // = std::vector<osg::Vec3>
243 // } IO_Type;
244 //
245 // /// The struct for description of input.
246 // typedef struct {
247 // /// Name of the input.
248 // std::string name;
249 // /// Type of the input.
250 // IO_Type type;
251 // /// Possible value for the input.
253 // } INPUT_DESCRIPTION;
254 //
255 // /// The struct for description of output.
256 // typedef struct {
257 // /// Name of the output.
258 // std::string name;
259 // /// Type of the output.
260 // IO_Type type;
261 // /// Possible value for the output.
262 // //std::vector<std::string> value;
263 // /// Is it required?
264 // bool required;
265 // } OUTPUT_DESCRIPTION;
266 //
267 // /** Return vector with description of all inputs for the object. */
268 // inline std::vector<INPUT_DESCRIPTION> &getInput(void) {return input;}
269 // /** Return type of the input. */
270 // IO_Type getInputType(const std::string &name);
271 // /** Return vector with description of all outputs for the object. */
272 // inline std::vector<OUTPUT_DESCRIPTION> &getOutput(void) {return output;}
273 // /** Return type of the output. */
274 // IO_Type getOutputType(const std::string &name);
275 //
282 bool inputPresent(const std::string &name);
283
290 bool outputPresent(const std::string &name);
291
292 // /* Returns true if the given request input is present */
293 // bool requestInputPresent(const std::string &name);
294 // /* Returns true if the given request output is present */
295 // bool requestOutputPresent(const std::string &name);
296 //
297 // /* Return string of IO_Type. */
298 // static std::string getIO_TypeString(IO_Type type);
299 //
300 // /* Add a input to the existing list of the inputs. */
301 // void addInput(const char *name, IO_Type type);
302 // /* Remove the input from the list of inputs. */
303 // void removeInput(const char *name);
304 //
305 // /* Older way. Add a output to the existing list of the outputs. */
306 // void addOutput(const char *name, IO_Type type);
307 // /* Older way. Remove the output from the list of outputs. */
308 // void removeOutput(const char *name);
309 //
310 // /* Return type of the input. */
311 // VreckoMessage* getRequestInputType(const std::string &name);
312 // /* Return type of the output. */
313 // VreckoMessage* getRequestOutputType(const std::string &name);
314 // /* Add a input to the existing list of the inputs. */
315 // void addRequestInput(const char *name, IO_Type type);
316 // /* Remove the request input from the list of inputs. */
317 // void removeRequestInput(const char *name);
318 // /* Add a output to the existing list of the outputs. */
319 // void addRequestOutput(const char *name, IO_Type type);
320 // /* Remove the request output from the list of outputs. */
321 // void removeRequestOutput(const char *name);
322
339 void addInputPin(InputPinBase *pin);
340
351 void removeInputPin(InputPinBase *pin);
352
363 void addOutputPin(OutputPinBase *pin);
364
375 void removeOutputPin(OutputPinBase *pin);
376
377
388 void addRequestInputPin(RequestInputPinBase *pin);
389
400 void removeRequestInputPin(RequestInputPinBase *pin);
401
412 void addRequestOutputPin(RequestOutputPinBase *pin);
423 void removeRequestOutputPin(RequestOutputPinBase *pin);
424
425 enum NotificationTypes {
426 // bit flags
427 NOTIFICATION_DELETE_CLASS = 1,
429 NOTIFICATION_EO_REGISTERING = 2,
434 NOTIFICATION_EO_UNREGISTERING = 4,
439 NOTIFICATION_PROGRAM_TERMINATION = 8,
444 NOTIFICATION_ALL = 0xFFFFFFFF
445 };
446
456 bool addNotification(BaseClass *receiver, unsigned long notificationTypes);
457
474 bool removeNotification(BaseClass *receiver, unsigned long notificationTypes = NOTIFICATION_ALL);
475
492 virtual void processEvent(const std::string& input_name, VreckoMessage *pMessage);
493
509 virtual VreckoMessage *processRequest(const std::string& request_input_name, VreckoMessage *pMessage);
510
516 virtual const std::string &getSenderString(void) {return senderString;}
517
526 void reportError(const std::string &error);
527
528 /* Sets pointer to the World. */
529 // OBSOLETE: Simply use the [vrecko::world] variable from World.h
530 // inline void setWorldPtr(World *ptr) { /* pWorld = ptr; */ static bool bAlreadyWritten = false; if (!bAlreadyWritten) { logger.debugLog("setWorldPtr() is obsolete, there is now a global \"vrecko::world\" variable holding pointer to World (include World.h to use it)"); bAlreadyWritten = true; } }
531
532 /* Gets pointer to the World. */
533 // OBSOLETE: Simply use the [vrecko::world] variable from World.h
534 // inline World *getWorldPtr() const { static bool bAlreadyWritten = false; if (!bAlreadyWritten) { logger.debugLog("getWorldPtr() is becoming obsolete, there is now a global \"vrecko::world\" variable holding pointer to World (include World.h to use it)"); bAlreadyWritten = true; } return world; }
535
555 inline void setPriority(long int pr) {priority = pr;}
556
564 inline long int getPriority(void) const {return priority;}
565
575 inline void setAttribute(const std::string &attr_name, int attr_value) { attributeLock.lockWrite(); attribute[attr_name] = attr_value; attributeLock.unlockWrite(); }
576
585 inline int getAttribute(const std::string &attr_name) { attributeLock.lockRead(); int i = attribute[attr_name]; attributeLock.unlockRead(); return i; }
586
595 inline int getAttribute(const char* attr_name) { return getAttribute(std::string(attr_name));}
596
605 void deleteAttribute(const std::string &attr_name);
606
607
616 void setSceneFile(const std::string &sceneFileName);
617
628 inline const std::string &getSceneFile() const { return *sceneFile; }
629
630
631
637 virtual void preInitialize(void) {};
638
644 virtual void postInitialize(void) {};
645
654 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) {return true;}
655
664 virtual bool loadXMLParameters(const char *xmlString);
665
672 InputPinBase* getInputPin(const char *strName);
673
680 OutputPinBase* getOutputPin(const char *strName);
681
688 RequestInputPinBase* getRequestInputPin(const char *strName);
689
690
697 RequestOutputPinBase* getRequestOutputPin(const char *strName);
698
699
700 protected:
702 std::string senderString;
703
705 struct NOTIFICATION_DESCRIPTION {
706 BaseClass *receiver;
707 unsigned long notificationTypes;
708 };
709
711 MTLock notificationsLock;
713 std::vector<NOTIFICATION_DESCRIPTION> notifications;
714
715
716 // /// Pointer to the World.
717 // World *pWorld; OBSOLETE, use [world] from World.h
718
725 long int priority;
726
731 const std::string * sceneFile;
732
733 typedef std::vector<osg::ref_ptr<IOPinBase>> PinList;
734
735
738 PinList inputPinsList;
739
742 PinList outputPinsList; // we know that all of them are of type OutputPinBase
743
746 PinList requestInputPinsList;
747
750 PinList requestOutputPinsList;
751
754 bool sendNotifications(unsigned long notificationType, void *notificationData);
755
766 virtual int processNotification(BaseClass *sender, unsigned long notificationType,
767 void *notificationData) { return 0; }
768
776 inline IOPinBase* findPinInList(const char *strName, PinList* pinList) {
777 for (auto itr = pinList->begin(); itr != pinList->end(); ++itr) {
778 if ((*itr)->getPinName() == strName)
779 return (*itr);
780 }
781 return NULL;
782 }
783 };
784
785 }
786
787 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BaseJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
BaseJoint.h
Go to the documentation of this file.
1 #ifndef BaseJoint_h
2 #define BaseJoint_h
3
4
5 #include "BasePhysXObject.h"
6 #include "PhysXVreckoMessages.h"
7
8
9 using namespace vrecko;
10
11 namespace PhysXPlugin
12 {
13 class BaseJoint : public BasePhysXObject
14 {
15 private:
16 std::string _strGetJointedActor;
17 public:
18 BaseJoint(const char * abName, NxJointDesc *descripter):BasePhysXObject(abName)
19 {
20 _pBaseDescripter = descripter;
21 }
22 virtual ~BaseJoint(){}
23
24 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
25 virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
26
27
28
29 virtual void Create();
30
31 protected:
32 // globalAnchor, globalAxis, that sets the members localAnchor, localAxis, localNormal
33 // by transforming the passed world space vector into actor1 resp.
34 // actor2's local space. The actor pointers must already be set!
35 // [PhysX help]
36 NxVec3 _globalAnchor, _globalAxis;
37 std::string _ID[2];
38
39 NxJointDesc* _pBaseDescripter;
40
41 DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr);
42 };
43 }
44
45 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/BasePhysXObject.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
BasePhysXObject.h
Go to the documentation of this file.
1 #ifndef AbstractCollection_h
2 #define AbstractCollection_h
3
4 #include <vrecko/Scene.h>
5 #include <vrecko/Message.h>
6 #include <vrecko/EventDispatcher.h>
7 #include <vrecko/ReaderWriter.h>
8
9 #include <vrecko/Ability.h>
10
11 #include "NXU_helper.h"
12 #include "NxCooking.h"
13 #include "PhysXObject.h"
14 #include "PhysXVreckoMessages.h"
15
16
17 #include <string>
18
19 using namespace vrecko;
20
21 namespace PhysXPlugin
22 {
23 class BasePhysXObject : public PhysXObject
24 {
25 public:
26 BasePhysXObject(const char* abName): PhysXObject(abName){}
27
28 // tyto metody musi byt volany ve zdedenych tridach
29 // pretezujte metodu BeforeInitialization a AfterInitialization
30 virtual void preInitialize();
31 virtual void postInitialize(void);
32
33 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
34
35 protected:
36 std::string _strScene;
37 NxScene* _pScene;
38
39 virtual void Create() = 0;
40
41 DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr);
42 };
43 }
44
45 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExp_wT.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
BehindObstacleExp_wT.h
Go to the documentation of this file.
1 #ifndef BEHINDOBSTACLE_WT_H
2 #define BEHINDOBSTACLE_WT_H
3
4 #include <vrecko/Ability.h>
5
6 #include <osg/Geode>
7 #include <osgText/Text>
8 #include <osgText/Font>
9 #include <osg/BlendFunc>
10 #include <osg/Material>
11 #include <osg/StateSet>
12
13
14 using namespace vrecko;
15
16
17 class BehindObstacleExp_wT: public Ability {
18 public:
19 BehindObstacleExp_wT();
20 ~BehindObstacleExp_wT();
21
22 void preInitialize(void);
23 void postInitialize(void);
24
25 void processEvent(const std::string &input_name, void *value);
26
27 void update(void);
28
29 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
30 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
31
32 protected:
33 void createScenes(void);
34 void setScene(int scene_id);
35 void initScene(int scene_id);
36 void setAllBindingForMethod(int method_id);
37 int checkLocation(int scene_id);
38 void resetView(void);
39
40 std::string getInfoString(void);
41
42
43 osg::Timer timer;
44 osg::Timer_t start_tick, end_tick;
45 int current_state, internal_state, test_counter;
46 bool first_enter;
47 std::ofstream result_file;
48 std::string user_name;
49 bool stereoscopic, two_handed, large_projection, dynamics_used;
50 int current_method, last_method, grasp_count;
51
52 typedef struct {
53 int nic;
54 } ExperimentRec;
55
56 std::map<std::string, ExperimentRec> experiment_map;
57 std::string method_desc[20];
58
59 // textual information
60 osgText::Text *experiment_description, *timer_board, *remaining_tests, *method_board;
61 osg::Geode *text_geode;
62 osg::Material *text_material;
63 osg::StateSet *text_state;
64 osgText::Font *texture_font;
65 int font_size;
66 osg::BlendFunc *transp;
67 EnvironmentObject *pCube1, *pCube2, *pCube3, *pObstacle1, *pObstacle2, *pObstacle3, *pObstacle4, *pFloor;
68 EnvironmentObject *pObstacle5, *pObstacle6, *pObstacle7, *pObstacle8;
69 EnvironmentObject *pObstacle9, *pObstacle10, *pObstacle11, *pObstacle12;
70 EnvironmentObject *pObstacle13, *pObstacle14, *pObstacle15, *pObstacle16;
71 EnvironmentObject *pObstacle17, *pObstacle18, *pObstacle19, *pObstacle20;
72 Scene *pScene;
73
74 EnvironmentObject *pEOAvatar, *owner, *pLeftHand, *pRightHand, *pWIMEO, *pCuttingPlaneEO, *pCuttingPlaneEO2;
75 EnvironmentObject *pMirrorEO1, *pMirrorEO2, *pMirrorEO3;
76 long int lefthand_id, righthand_id;
77 Ability *pHMDHeadManipulator, *pHeadManipulator, *pManipulator, *pCenterObjectManipulator;
78 Ability *pCuttingPlane, *pCuttingPlane2, *pChangeOfVisibility, *pMirror1, *pMirror2, *pMirror3, *pWIM, *pAvatarManipulator, *pMappingFunctions[2];
79 osg::MatrixTransform *pTempl[3];
80 osg::Vec3 final_object_position[3];
81 osg::Matrix final_object_rotation[3];
82 };
83
84
85 #endif
86
87 //$Id: BehindObstacleExp_wT.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/BehindObstacleExperiment.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
BehindObstacleExperiment.h
Go to the documentation of this file.
1 #ifndef BEHINDOBSTACLE_H
2 #define BEHINDOBSTACLE_H
3
4 #include <vrecko/Ability.h>
5
6 #include <osg/Geode>
7 #include <osgText/Text>
8 #include <osgText/Font>
9 #include <osg/BlendFunc>
10 #include <osg/Material>
11 #include <osg/StateSet>
12
13
14 using namespace vrecko;
15
16
17 class BehindObstacleExperiment: public Ability {
18 public:
19 BehindObstacleExperiment();
20 ~BehindObstacleExperiment();
21
22 void preInitialize(void);
23 void postInitialize(void);
24
25 void processEvent(const std::string &input_name, void *value);
26
27 void update(void);
28
29 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
30 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
31
32 protected:
33 void createScenes(void);
34 void setScene(int scene_id);
35 void initScene(int scene_id);
36 void setAllBindingForMethod(int method_id);
37 int checkLocation(int scene_id);
38 void resetView(void);
39
40 std::string getInfoString(void);
41
42
43 osg::Timer timer;
44 osg::Timer_t start_tick, end_tick;
45 int current_state, internal_state, test_counter;
46 bool first_enter;
47 std::ofstream result_file;
48 std::string user_name;
49 bool stereoscopic, two_handed, large_projection, dynamics_used;
50 int current_method, last_method, grasp_count;
51
52 typedef struct {
53 int nic;
54 } ExperimentRec;
55
56 std::map<std::string, ExperimentRec> experiment_map;
57 std::string method_desc[20];
58
59 // textual information
60 osgText::Text *experiment_description, *timer_board, *remaining_tests, *method_board;
61 osg::Geode *text_geode;
62 osg::Material *text_material;
63 osg::StateSet *text_state;
64 osgText::Font *texture_font;
65 int font_size;
66 osg::BlendFunc *transp;
67 EnvironmentObject *pCube1, *pCube2, *pCube3, *pObstacle1, *pObstacle2, *pObstacle3, *pObstacle4, *pFloor;
68 EnvironmentObject *pEOAvatar, *owner, *pLeftHand, *pRightHand, *pWIMEO, *pCuttingPlaneEO, *pCuttingPlaneEO2;
69 EnvironmentObject *pMirrorEO1, *pMirrorEO2, *pMirrorEO3;
70 long int lefthand_id, righthand_id;
71 Ability *pHMDHeadManipulator, *pHeadManipulator, *pManipulator, *pCenterObjectManipulator;
72 Ability *pCuttingPlane, *pCuttingPlane2, *pChangeOfVisibility, *pMirror1, *pMirror2, *pMirror3, *pWIM, *pAvatarManipulator, *pMappingFunctions[2];
73 osg::MatrixTransform *pTempl[3];
74 osg::Vec3 final_object_position[3];
75 osg::Matrix final_object_rotation[3];
76 };
77
78 #endif
79
80
81 //$Id: BehindObstacleExperiment.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/BenchmarkWriter.h Source File

  • File List
  • File Members
  • include
  • vrecko
BenchmarkWriter.h
Go to the documentation of this file.
1 #ifndef BENCHMARKWRITER_H
2 #define BENCHMARKWRITER_H
3
4 #include <winbase.h>
5
6 namespace vrecko {
7
25 class BenchmarkWriter {
26 public:
27 BenchmarkWriter();
28 ~BenchmarkWriter();
29
31 void setWriting(bool bValue);
32
33 inline bool writingAllowed() { return bWriting; };
34
35 // PHASE 1
37 bool openFile(const char * pFileName = NULL);
38
39 bool isOpened() { return bOpenMain; };
40
41 // PHASE 2
42 bool writeInfoStart();
43
45 bool writeInfoLine(const char* pText, ...);
46
47 bool writeInfoEnd();
48
49 // PHASE 3
50 bool writeSettingsStart();
51
53 bool writeParam(const char* pName, const char* pValue);
54
56 bool writeParam(const char* pName, float fValue);
57
58 bool writeSettingsEnd();
59
60 // PHASE 4
61 bool writeDataStart();
62
63 // PHASE 5
64 bool writeFrameStart(unsigned int dwTime);
65
67 bool writeCounter(const char* pName, float fValue);
68
69 bool writeFrameEnd();
70
71 // PHASE 6
72 bool writeMiscStatsStart();
73 bool writeRunTime(unsigned int dwTime);
74 bool writeFramesRendered(unsigned int dwNum);
75 bool writeMiscStatsEnd();
76
77 // PHASE 7
78 bool writeDataEnd();
79
80 // PHASE 8
81 bool closeFile();
82
83 protected:
84 FILE *file;
85
86 bool bWriting;
87
88 // which sections are opened:
89 bool bOpenMain;
90 bool bOpenInfo;
91 bool bOpenSettings;
92 bool bOpenData;
93 bool bOpenFrame;
94 bool bOpenMiscStats;
95
96 };
97
98 };
99
100 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/BlockUpdater.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
BlockUpdater.h
Go to the documentation of this file.
1 #ifndef _BLOCKUPDATER
2 #define _BLOCKUPDATER 1
3
4 /*
5 #include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7 #include <vrecko/World.h>
8 #include "../ObjectUtils/Animator.h"
9 #include <vector>
10 #include <list>
11 #include <string>
12 #include <time.h>
13 #include "model.h"
14 #include "subblock.h"
15 #include "ModelManager.h"
16 #include <iostream>
17 #include <sstream>
18 #include <fstream>
19
20 #include <xercesc/parsers/XercesDOMParser.hpp>
21 #include <xercesc/dom/DOM.hpp>
22 #include <xercesc/sax/HandlerBase.hpp>
23 #include <xercesc/util/XMLString.hpp>
24 #include <xercesc/util/PlatformUtils.hpp>
25
26 #include <xercesc/dom/DOMWriter.hpp>
27 #include <xercesc/framework/StdOutFormatTarget.hpp>
28 #include <xercesc/framework/LocalFileFormatTarget.hpp>
29 */
30
31 using namespace vrecko;
32 using namespace std;
33 using namespace xercesc_2_7;
34
35 #define SHOWVEC3(v) "(" << v.x() << ", " << v.y() << ", " << v.z() << ")"
36
37 namespace ArtificialWorld
38 {
40 enum BlockAttributesSetEnum {
42 noneSet = 0,
44 centerDirSet = 1,
46 centerPointSet = 2,
48 bothSet = 3
49 };
50
52 class BlockAttributes{
53 public:
54 BlockAttributes(){
55 set = BlockAttributesSetEnum::noneSet;
56 objectCenterDir = osg::Vec3(0.0f, 0.0f, 0.0f);
57 objectCenterPoint = osg::Vec3(0.0f, 0.0f, 0.0f);
58 };
59
61 void SetObjectCenterDir(osg::Vec3 newCenterDir){
62 objectCenterDir = newCenterDir;
63 if(set == BlockAttributesSetEnum::noneSet)
64 set = BlockAttributesSetEnum::centerDirSet;
65 else if(set == BlockAttributesSetEnum::centerPointSet)
66 set = BlockAttributesSetEnum::bothSet;
67 };
68
70 void SetObjectCenterPoint(osg::Vec3 newCenterPoint){
71 objectCenterPoint = newCenterPoint;
72 if(set == BlockAttributesSetEnum::noneSet)
73 set = BlockAttributesSetEnum::centerPointSet;
74 else if(set == BlockAttributesSetEnum::centerDirSet)
75 set = BlockAttributesSetEnum::bothSet;
76 };
77
79 osg::Vec3 GetObjectCenterDir(void){return objectCenterDir;};
81 osg::Vec3 GetObjectCenterPoint(void){return objectCenterPoint;};
83 BlockAttributesSetEnum WhatIsSet(void){return set;};
84
85 private:
87 osg::Vec3 objectCenterDir;
89 osg::Vec3 objectCenterPoint;
91 BlockAttributesSetEnum set;
92 };
93
95 class BlockUpdater: public Ability
96 {
97 public:
98 BlockUpdater();
99 ~BlockUpdater();
100
102 virtual void update(void);
104 virtual void preInitialize(void);
106 virtual void postInitialize(void);
107
109 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
111 bool LoadXMLParametersFromFile(string filename);
112
114 void SetParentEO(EnvironmentObject *newParentEO);
115
117 void Hide();
119 void Show();
121 void HideSubBlocks();
123 void ShowSubBlocks();
125 bool IsVisible();
126
128 string GetBlockType(void){ return myBlockType; };
130 vector<SubBlock*> GetSubBlocks(void){ return subBlocks; };
132 vector<BlockUpdater*> GetSubBlocksUpdaters(void){ return subBlocksUpdaters; };
134 vector<Model*> GetModels(void){ return models; };
136 osg::Vec4 GetBoundingSphere(void){ return boundingSphere; };
138 osg::Vec3* GetBoundingBox(void){ return boundingBox; };
140 BlockAttributes* GetAttributes(void){ return attributes; };
142 list<Model*> getVisibleModels(osg::Vec3 position);
143
144 XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* getDOMDocument() { return xmlDocument; }
145
146 private:
148 void init(void);
149
151 void updatescene(unsigned long distance);
153 void updatescene(osg::Vec3 position);
154
156 void UpdateModels(unsigned long distance);
158 void UpdateSubBlocks();
159
160
161 // QCHANGE: od nacteni se v pameti udrzuje parser a nacteny XML document.
162 // Tato abilita to nepotrebuje, ale je to pro budouci rozsiritelnost a pro moznost dotazu z jinych abilit,
163 // ktere treba budou zpracovavat XML tagy, ktere BlockUpdater ignoruje (napriklad CarSim, ktery potrebuje nacist
164 // informace o silnicich)
165 XERCES_CPP_NAMESPACE_QUALIFIER XercesDOMParser* xmlParser;
166 XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* xmlDocument;
167
168
170 list<Model*> currentlyVisibleModels;
172 vector<SubBlock*> subBlocks;
174 vector<BlockUpdater*> subBlocksUpdaters;
175
177 osg::Vec3 lastViewerPosition;
179 EnvironmentObject *owner;
181 EnvironmentObject *parentEO;
182
184 vector<Model*> models;
185
187 list<Model*> getVisibleModels(unsigned long distance);
188
190 void RemoveLoadedModels(list<Model*> *toRemove);
191
193 void AddModels(list<Model*> *toAdd);
194
196 bool isNoSubblocks;
197
199 string myBlockType;
201 osg::Vec4 boundingSphere;
203 osg::Vec3 boundingBox[2];
205 BlockAttributes* attributes;
206
207 public:
209 osg::Vec3 GetCurrentWorldPosition(void){ return owner->getWorldPosition(); };
211 };
212 }
213 #endif
214
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/Boid.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
Boid.h
Go to the documentation of this file.
1 /*
2 Boids - virtualny krdel (roj, hejno) vtakov, ryb, hmyzu ...
3 Michal Pancik, 172460
4 Laborator interakci cloveka s pocitacem
5 2008
6
7 Problematiku boidov rozpracoval Craig W. Reynolds
8 - http://www.red3d.com/cwr/
9 Uzitocne vysvetlenie a pseudokod napisal Conrad Parker
10 - http://www.metadecks.org/~conrad/boids/pseudocode.html
11 */
12
13 #ifndef BOID_H
14 #define BOID_H
15
16 #include <vrecko/Ability.h>
17 #include <vrecko/EnvironmentObject.h>
18 #include <vrecko/World.h>
19
20 using namespace vrecko;
21
22 namespace boids {
23
24 class Boid: public Ability {
25 public:
26 Boid();
27 ~Boid();
28
29 // void processEvent(const std::string &input_name, void *value);
30 void preInitialize(void);
31 void postInitialize(void);
32 void update(void);
33
34 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
35 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
36
37 protected:
38 EnvironmentObject *owner;
39 osg::Vec3 up_vector;
40
41 DECLARE_INPUT(Position, MessageVec3);
42 DECLARE_INPUT(Velocity, MessageVec3);
43 };
44
45 }
46
47 #endif
48
49
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsLogic.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
BoidsLogic.h
Go to the documentation of this file.
1 /*
2 Boids - virtualny krdel (roj, hejno) vtakov, ryb, hmyzu ...
3 Michal Pancik, 172460
4 Laborator interakci cloveka s pocitacem
5 2008
6
7 Problematiku boidov rozpracoval Craig W. Reynolds
8 - http://www.red3d.com/cwr/
9 Uzitocne vysvetlenie a pseudokod napisal Conrad Parker
10 - http://www.metadecks.org/~conrad/boids/pseudocode.html
11 */
12
13 #include <vrecko/Ability.h>
14 #include <vrecko/IOPins.h>
15 #include <vrecko/EnvironmentObject.h>
16 #include <vrecko/World.h>
17 #include <osg/Vec3>
18 #include <vector>
19
20 using namespace vrecko;
21
22 namespace boids {
23
24 const float cycles_per_sec = 30.0f;
25
26 class BoidsLogic: public Ability {
27 public:
28 BoidsLogic();
29 ~BoidsLogic() {};
30
31 void preInitialize(void);
32 void postInitialize(void);
33 // void processEvent(const std::string &input_name, void *value);
34 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
35 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
36 void update(void);
37
38 protected:
39 bool rule0_in_sight(int other_boid, int boid);
40 osg::Vec3 rule1_centre_of_mass(int boid);
41 osg::Vec3 rule2_away_from_others(int boid);
42 osg::Vec3 rule3_match_velocity(int boid);
43 osg::Vec3 rule4_bound_position(int boid);
44 osg::Vec3 rule5_fly_to_waypoint(int boid);
45 osg::Vec3 rule6_fly_from_danger(int boid);
46 void limit_speed(int boid);
47 bool rest_on_land(int boid);
48
49 std::vector<osg::Vec3> boids_position;
50 std::vector<osg::Vec3> boids_velocity;
51 std::vector<float> boids_rest_time;
52 std::vector<string> boids_position_output;
53 std::vector<string> boids_velocity_output;
54
55 int boids_count;
56 osg::Vec3 max_bound;
57 osg::Vec3 min_bound;
58 osg::Vec3 bound_velocity;
59 float move_factor;
60 float small_distance;
61 float velocity_factor;
62 float max_speed;
63 float waypoint_speed;
64 float next_waypoint_dist;
65 bool next_waypoint;
66 osg::Vec3 waypoint;
67 float scare_distance;
68 float danger_factor;
69 osg::Vec3 danger;
70 float land_level;
71 float takeoff_time;
72 float rest_time;
73 float sight_angle;
74
75 std::string mesg;
76
77 DECLARE_INPUT(Waypoint, MessageVec3);
78 DECLARE_INPUT(Danger, MessageVec3);
79 DECLARE_OUTPUT(NextWaypoint, MessageBool);
80 };
81
82 }
83
84
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Boids/BoidsPlanner.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Boids
BoidsPlanner.h
Go to the documentation of this file.
1 /*
2 Boids - virtualny krdel (roj, hejno) vtakov, ryb, hmyzu ...
3 Michal Pancik, 172460
4 Laborator interakci cloveka s pocitacem
5 2008
6
7 Problematiku boidov rozpracoval Craig W. Reynolds
8 - http://www.red3d.com/cwr/
9 Uzitocne vysvetlenie a pseudokod napisal Conrad Parker
10 - http://www.metadecks.org/~conrad/boids/pseudocode.html
11 */
12
13 #include <vrecko/Ability.h>
14 #include <vrecko/EnvironmentObject.h>
15 #include <vrecko/World.h>
16 #include <osg/Vec3>
17 #include <vector>
18
19 using namespace vrecko;
20
21 namespace boids {
22
23 class BoidsPlanner: public Ability {
24 public:
25 BoidsPlanner();
26 ~BoidsPlanner() {};
27
28 void preInitialize(void);
29 void postInitialize(void);
30 // void processEvent(const std::string &input_name, void *value);
31 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
32 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
33 void update(void);
34
35 protected:
36 std::vector<osg::Vec3> waypoints;
37 int current_waypoint;
38
39 std::string mesg;
40
41 DECLARE_INPUT(NextWaypoint, MessageBool);
42 DECLARE_OUTPUT(Waypoint, MessageVec3);
43 };
44
45 }
46
47
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Border.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Border.h
Go to the documentation of this file.
1 //module for PHANToM work space border signalization
2 //when border is reached, PHANToM will vibrate
3
4 #ifndef VF_BORDER
5 #define VF_BORDER
6
7
8 #include <vrecko/Ability.h>
9 #include <vreckoDP/base/PHANToM.h>
10 #include <osg/Vec4>
11 #include <osg/Geode>
12 #include <osg/MatrixTransform>
13 #include <osg/Group>
14
15 #include "Auxiliary.h"
16
17
18 using namespace vrecko;
19 using namespace vreckoDP_base;
20 namespace VirtualFixture{
21
22 class Border: public PHANToMFilter {
23 public:
24 Border();
25 ~Border() {};
26
28 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
29 void processEvent(const std::string &input_name, void *value);
30
31 void preInitialize(void);
32 void postInitialize(void);
33 void update(void);
34
35 void display(void); //show or hide VF_cylinder object
36
37 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
38 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
39
40 protected:
41 PHANToM *PHANToMDevice;
42 bool all_on;
43 bool active; //VF switcher
44
45 bool visible; //if geometric representation will be visible
46 osg::MatrixTransform *tnode; //transform node pointer
47 osg::Group *gnode; //group pointer
48 osg::Geode *node; //geometry node pointer (for bouning cylinder)
49 osg::Geode *node2; //geometry node2 pointer (for center cylinder)
50 osg::Vec4 color; //color of border sphere (radius1)
51 osg::Vec4 color2; //color of inner sphere (radius2)
52 float transparency; //border sphere transparency
53 float transparency2; //inner sphere transparency
54
55 osg::Vec3 direction; //direction of vibration
56 float frequency; //frequency of warning vibration
57 float amplitude; //base amplitude of vibration
58 };
59
60 };
61 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/BoundingVol.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
BoundingVol.h
Go to the documentation of this file.
1
11 #ifndef _VRECKO_CLOUDS_BOUNDINGVOL_H
12 #define _VRECKO_CLOUDS_BOUNDINGVOL_H
13
14 #include <osg/Vec3f>
15
20 class AABoundingBox
21 {
22
23 public:
24 // Attributes
25 osg::Vec3f min; // min x, y, z values of the object.
26 osg::Vec3f max; // max x, y, z values of the object.
27 float radius,
28 side,
29 halfside;
30 };
31
32 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Brush.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Brush.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "ColorGenAdapter.h"
4 #include "DiameterGenAdapter.h"
5 #include "SplineAdapter.h"
6 #include "RotationFrameGenAdapter.h"
7
8 #include <osg\Referenced>
9
10 XERCES_CPP_NAMESPACE_USE
11
12 using namespace vrecko;
13
14 namespace APDYNAMICART
15 {
16
17
19
23 class Brush : public osg::Referenced
24 {
25 public:
26
27 Brush( string colorAdapterName, string diameterAdapterName, string crossSectionAdapterName, string rotationFrameAdapterName );
28
29 //copy constructor - deep copy of Brush have to be done
30 Brush( const Brush& orig);
31
32 ~Brush() { };
33
34 osg::ref_ptr<ColorGenAdapter> getColorGenAdapter() { return _colorGenFactory.getAdapter(_colorGenAdapterName); }
35 osg::ref_ptr<DiameterGenAdapter> getDiameterGenAdapter() { return _diamGenFactory.getAdapter(_diamGenAdapterName); }
36 osg::ref_ptr<SplineAdapter> getCrossSectionAdapter() { return _crossSectionFactory.getAdapter(_crossSectionAdapterName); }
37 osg::ref_ptr<RotationFrameAdapter> getRotationFrameAdapter() { return _rotationFrameFactory.getAdapter(_rotationFrameAdapterName); }
38
39 inline string getCrossSectionAdapterName() const { return _crossSectionAdapterName; }
40 inline string getRotationFrameAdapterName() const { return _rotationFrameAdapterName; }
41
42 inline double getSmoothness() const { return _smoothness; }
43
44 ColorGenFactory* getColorGenFactory() { return &_colorGenFactory; }
45
46 inline int getCrossSectionInterpolationSteps() const { return _crossSectionInterpolationSteps; }
47 inline int getInterpolationSteps() const { return _interpolationSteps; }
48
49 double getDiameter();
50 bool sliderChanged( const char* sliderID, float sliderPos );
51 bool guiItemClicked( const char* itemID );
52 bool setDiameterAdapter( string name );
53 bool setColorAdapter( string name );
54 bool setCrossSectionAdapter( string name );
55 bool setRotationFrameAdapter( string name );
56
57 void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ParametersNode );
58 void createMenu( MenuPtr menu, bool colorMenu = true );
59 void load( DOMNode* ParametersNode );
60 void setDiameter( float sliderPos );
61
62 inline void setInterpolationSteps( int steps ) { _interpolationSteps = steps; }
63 void setCrossSectionInterpolationSteps( int steps );
64 inline void setSmoothness(double val) { _smoothness = val; }
65
66
67
68 protected:
69
70 // interpolation of leading spline
71 int _interpolationSteps;
72
73 // interpolation of cross-section curve
74 int _crossSectionInterpolationSteps;
75
76 //smoothing of leading spline
77 double _smoothness;
78
80 string _colorGenAdapterName;
81
83 string _diamGenAdapterName;
84
86 string _crossSectionAdapterName;
87
89 string _rotationFrameAdapterName;
90
91
92
94 ColorGenFactory _colorGenFactory;
95 DiameterGenFactory _diamGenFactory;
96 SplineFactory _crossSectionFactory;
97 RotationFrameFactory _rotationFrameFactory;
98
99 };
100
101 typedef osg::ref_ptr<Brush> BrushPtr;
102
103 }
104
105
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/BrushStroke.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
BrushStroke.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "PoA.h"
4 #include "ColorGen.h"
5 #include "SweepSurface.h"
6 #include "ColorGenAdapter.h"
7 #include "DiameterGenAdapter.h"
8 #include "SplineAdapter.h"
9 #include "InterpolatedSpline.h"
10 #include "Utils.h"
11 #include "Brush.h"
12 #include "TimeLineSpline.h"
13 #include <vreckoUtils\HighlightCallback.h>
14
15
16 using namespace vrecko;
17
18 namespace APDYNAMICART
19 {
20
21
22
24
38 class BrushStroke : public PoA, public Stroke
39 {
40 public:
41
42 //TODO ask Martin - what about pointers, referenced pointers, references, ... here?
43 BrushStroke( Controller* contr, BrushPtr brush );
44 ~BrushStroke();
45
46
47 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
48
50 void exportToFile(std::string file);
51
52 double getDuration();
53
54 inline double getRealStartTime() { return _StartTime; }
55 inline double getComputedStartTime() { return _computedStrokeStartTime; }
56
58 virtual Vec3ArrayPtr getPositionSamples() const { return this->_samplesPositions; }
59 virtual Vec4ArrayPtr getOrientationSamples() const { return this->_samplesOrientations; }
60 virtual osg::ref_ptr<osg::DoubleArray> getTimeStamps() const { return this->_samplesTimeStamps; }
61 virtual SplinePtr getLeadingSpline() const { return _leadingSpline; }
62
63 void GUIItemClicked(const char* itemID);
64
65 void GUISliderChanged(const char* sliderID, float sliderPos);
66
67 // probably for importing data in some older format
68 void importControlPoints( std::vector<osg::Vec3> * samples, std::vector<osg::Vec4> * colours, double diameter, int usize );
69
70 int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* BrushStrokeNode);
71
72 void playback( double playbackTime );
73
74 void pointed(bool pointed);
75
76
78 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
79
80 //sets
81
82 void setLeadingSpline(InterpolatedSplinePtr val) { _leadingSpline = val; }
83 void setCrossSectionInterpolation(int interpol);
84 void setCrossSectionType(int type);
85 void setInterpolationSteps(int interpol);
86 void setSmoothness(double smooth);
87
88 void setComputedTime(double newTime) { _computedStrokeStartTime = newTime; }
89
91 void switchRenderingMethod();
92
93 void update(void);
94
96 void visualizeControlPoints(bool show);
97
98 DECLARE_INPUT(Colour, MessageVec4);
99 protected:
100
102 Vec3ArrayPtr _samplesPositions;
103
105
106 Vec4ArrayPtr _samplesOrientations;
107
109 DoubleArrayPtr _samplesTimeStamps;
110
112 TimeLineSplinePtr _timeLineDecorator;
113
114
116 double _StartTime;
117
119 double _computedStrokeStartTime;
120
122 SplinePtr _leadingSpline;
123
124 SplinePtr _leadingSplineInterpolated;
125 SplinePtr _leadingSplineTilting;
126
128 osg::Vec3 _lastValidSamplePosition;
129
131 SweepSurfaceGeodePtr _sweepSurface;
132
134 vreckoUtils::HighlightCallback* _highLightcallback;
135
137 BrushPtr _brush;
138
140 int _strokeTime;
141
142 //for direct evocation of color picker
143 DECLARE_REQUEST_OUTPUT(EvokeHSLColorPicker, MessageString, MessageBool);
144 };
145
146 }
147
148
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeControlPoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BrushStrokeControlPoint.h
Go to the documentation of this file.
1 #pragma once
2 #include "SimpleBox.h"
3
4
5 namespace APDYNAMICART
6 {
7
9
12 class DAGizmo : public osg::Referenced
13 {
14 public:
15 DAGizmo(osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius);
16 ~DAGizmo();
17
18 osg::ref_ptr <SimpleBox> getNormal() { return this->normal; }
19 osg::ref_ptr <SimpleBox> getBinormal() { return this->binormal; }
20
21 bool isVisible() { return this->visibility; }
22 void hide();
23 void show();
24
25 private:
26 osg::Group *visualsOwner;
27
28 bool visibility;
29
30 //for visualizing Frenet frame
31 osg::ref_ptr <SimpleBox> tangent;
32 osg::ref_ptr <SimpleBox> normal;
33 osg::ref_ptr <SimpleBox> binormal;
34
35 };
36
37
39
47 class BrushStrokeControlPoint : public osg::Referenced
48 {
49 public:
50
59 BrushStrokeControlPoint(DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient);
60 ~BrushStrokeControlPoint();
61
62 //not used
63 //create new SimpleBox, make it visible
64 //void createVisualBox(osg::Vec3 size=osg::Vec3(VISUALS_WIDTH, VISUALS_WIDTH, VISUALS_WIDTH), bool movable=true, osg::Vec4 colour = osg::Vec4(1.0, 1.0, 1.0, 1.0));
65
66 //gets
67 inline osg::Vec3 getBinormal() { return this->binormal; }
68 inline double getCurvature() { return this->curvature; }
69 inline double getDiameter() { return this->diameter; }
70 inline osg::Vec3 getNormal() { return this->normal; }
71 inline osg::Quat getOrientation() { return this->orientation; }
72 inline osg::Vec3 getPosition() { return this->position; }
73 inline double getPriority() { return this->priority; }
74 inline double getSegmentLength() { return this->segmentLength; }
75 inline double getSpeed() { return this->speed; }
76 inline osg::Vec3 getTangent() { return this->tangent; }
77 inline double getTorsion() { return this->torsion; }
78 inline osg::Quat getTriangulationAngle() { return this->triangulationAngle; }
79 inline double getTvalue() { return this->tvalue; }
80 inline DAControlPointType getType() { return this->type; }
81 inline osg::Group * getVisualOwner() {return this->visualsOwner; }
82 string getPositionString();
83
84 bool isSampled();
85
86
87 //sets
88 void setCharacteristics(osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion);
89 void setDiameter( double diam ) {this->diameter = diam; }
90 inline void setNormal(osg::Vec3 nrml) {this->normal = nrml; }
91 inline void setBinormal(osg::Vec3 binrml) {this->binormal = binrml; }
92 void setPosition(osg::Vec3 pos);
93 void setPosition(osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z);
94 inline void setPriority(double prior) {this->priority = prior; }
95 void setRotationFrame(osg::Vec3 normal, osg::Vec3 binormal, osg::Vec3 tangent);
96 inline void setSegmentLength(double length) { this->segmentLength = length; }
97 inline double setSpeed(double spee) { this->speed = spee; }
98 inline void setTangent(osg::Vec3 tngt) { this->tangent = tngt; }
99 inline void setTriangulationAngle(osg::Quat angle) { this->triangulationAngle = angle; }
100 inline void setTvalue(double tval) {this->tvalue = tval; }
101 inline void setVisibleVisualBox(bool vis);
102
104 void showGizmo(bool show);
105
106
108 bool frenetFremeComputed;
109
110 private:
111
112 //type of this point
113 DAControlPointType type;
114
119 double tvalue;
120
121 osg::Vec3 position;
122
123 //not used
124 //TODO remove if not-used
125 osg::Quat orientation;
126
127 //Computed characteristics
128 osg::Vec3 tangent;
129 osg::Vec3 normal;
130 osg::Vec3 binormal;
131
133 double curvature;
135 double torsion;
136
146 double speed;
147
149 /*
150 * at first is the same as speed
151 * when some points are added or remove, this parameter must be recalculated
152 */
153 double segmentLength;
154
156
160 double priority;
161
162 // computed in triangulator during compute vertices
163 // used later during compute normals
164 osg::Quat triangulationAngle;
165
166 //visuals related variables
167 osg::Group *visualsOwner;
168 bool visibleVisualBox;
169
170 osg::ref_ptr <SimpleBox> visualBox;
171
172 osg::ref_ptr<DAGizmo> gizmo; //graphical gizmo
173 double diameter;
174
175
176 };
177
178 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BrushStrokeTriangulator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BrushStrokeTriangulator.h
Go to the documentation of this file.
1 // #pragma once
2 //
3 // #include "BrushStrokeControlPoint.h"
4 //
5 // namespace APDYNAMICART
6 // {
7 //
8 // typedef osg::ref_ptr<BrushStrokeControlPoint> ref_ptr_DAControlPoint;
9 // typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox;
10 //
11 // class BrushStrokeTriangulator : public osg::Geode
12 // {
13 // public:
14 // BrushStrokeTriangulator(osg::ref_ptr<Brush> br);
15 // ~BrushStrokeTriangulator();
16 //
17 // //TODO only for test - move back to private
18 // //Catmull-Rom interpolation
19 // osg::Vec3 catmullRomInterpolation(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
20 //
21 // bool computeVertices( std::vector<ref_ptr_DAControlPoint>* controlPoints );
22 // bool computeColours( std::vector<ref_ptr_DAControlPoint>* controlPoints );
23 // //derivation of Catmull-Rom interpolation
24 // osg::Vec3 derivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
25 //
26 // //second derivation of Catmull-Rom interpolation
27 // osg::Vec3 doubleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
28 //
29 // inline bool getHighLighting() { return this->isHighlighted; }
30 //
31 // /// Generate points of cross section in given point, correctly rotated
32 // bool generateCrosssectionVertices(BrushStrokeControlPoint *cpoint);
33 //
34 // /// Change colour of stroke
35 // /*
36 // * used for highlighting - when user point on Brush Stroke
37 // */
38 // osg::Vec4 highlightColour(osg::Vec4 col);
39 //
40 // /// Interpolate set of Vec3 points
41 // /*
42 // * \param controlPoints - set of points to be interpolated
43 // * \param interpolatedPoints - set of interpolated points.
44 // * \param type - type of interpolation - linear, Catmull-Rom, Circle, ...
45 // * \param closed - will be resulting curve closed?
46 // * \param p_steps - number of interpolation steps between two control points
47 // */
48 // void interpolateVec3(std::vector<osg::Vec3>* controlPoints, std::vector<osg::Vec3>* interpolatedPoints, BrushStrokeInterpolationType type, bool closed, int p_steps);
49 //
50 // /// Create set of interpolated points from set of control points
51 // /*
52 // * if (length optimization == false)
53 // * p_steps = number of interpolated points between two control points
54 // * else
55 // * p_steps is recomputed, based on length of segment
56 // */
57 // void interpolate(std::vector<ref_ptr_DAControlPoint>* controlPoints, std::vector<osg::Vec3>* interpolatedPoints, std::vector<double>* tvalues = NULL, int p_steps = 0, bool lengthOptimization = false, bool closed = false);
58 //
59 // void interpolateCrossSection() { interpolateCrossSection(brush, CrossSectionInterpolatedPoints, CrossSectinInterpolatedNormals); };
60 //
61 // void interpolateCrossSection(Brush *brush, std::vector<osg::Vec3> *interpolatedPoints, std::vector<osg::Vec3> *interpolatedNormals);
62 //
63 // void setHighLighting(bool high) { this->isHighlighted = high; }
64 //
65 //
66 // /**
67 // *
68 // * Complete triangulation of Brush Stroke
69 // * successively calls the necessary function for generation of points, normals, colors, triangle strips
70 // *
71 // * should be called only when geometry of brush stroke has changed completely.
72 // * If only one aspect of triangulation have changed (colors, e.g.,), call only "compute..." function.
73 // *
74 // * \param controlPoints set of (possibly interpolated) control points
75 // */
76 // void triangulate(std::vector<ref_ptr_DAControlPoint>* controlPoints);
77 //
78 // //third derivation ...
79 // osg::Vec3 tripleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
80 //
81 //
82 // private:
83 // BrushStrokeTriangulationType triangulationType;
84 // BrushStrokeInterpolationType interpolationType;
85 //
86 // osg::ref_ptr<osg::Geometry> geometry; ///< all geometry of this triangulation
87 // osg::ref_ptr<osg::Vec3Array> vertices; ///< vertices of surface = triangle mesh
88 // osg::ref_ptr<osg::Vec3Array> normals; ///< normals of surface
89 // osg::ref_ptr<osg::Vec4Array> colours; ///< colours of surface
90 //
91 // bool isHighlighted;
92 //
93 //
94 //
95 // //Tube
96 // osg::ref_ptr<Brush> brush;
97 //
98 // std::vector<osg::Vec3> *CrossSectionInterpolatedPoints; ///< points defining shape of cross-section (can be interpolated)
99 // std::vector<osg::Vec3> *CrossSectinInterpolatedNormals; ///< points defining shape of cross-section (can be interpolated)
100 //
101 //
102 // /*
103 // *
104 // * Called trom triangulate() function
105 // * Compute normal for each vertex of triangulation
106 // * \warning Must be called after CompouteVertices() function
107 // * \todo some check if vertices are already computed?
108 // *
109 // * \param controlPoints set of control points
110 // * \return successfulness of creation
111 // */
112 // bool computeNormals( std::vector<ref_ptr_DAControlPoint>* controlPoints );
113 //
114 // /// Computes one particular point between given points
115 // osg::Vec3 interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0 = osg::Vec3(0.0, 0.0, 0.0), osg::Vec3 point3 = osg::Vec3(0.0, 0.0, 0.0));
116 // bool generatePrimitiveSets( std::vector<ref_ptr_DAControlPoint>* controlPoints );
117 //
118 // bool generateCapsVertices( std::vector<ref_ptr_DAControlPoint>* controlPoints);
119 //
120 // /*
121 // *
122 // *
123 // *
124 // * \param
125 // * \return
126 // */
127 // bool generateCrosssectionNormals( BrushStrokeControlPoint *cpoint );
128 // void computeDiameters( std::vector<ref_ptr_DAControlPoint>* controlPoints );
129 // void generateCapColors( osg::Vec4 startColor, osg::Vec4 endColor );
130 // std::vector<ref_ptr_SimpleBox>* shapes; //for visualization
131 //
132 // };
133 //
134 // }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/BufFile.h Source File

  • File List
  • File Members
  • include
  • helpers
BufFile.h
Go to the documentation of this file.
1 // Created by Vit Kovalcik (vit@pastel.cz)
2
3 // Buffered file (for sequential access)
4 // Supports ASCII and simple variant of UTF-16 files (double byte characters only)
5
6 #ifndef BUFFILE_H
7 #define BUFFILE_H
8
9 #include <vrecko/Export>
10
11 #include <osg/Vec3>
12
13 #include "DynamicArray.h"
14 #include <tchar.h>
15
16
17 #define BUFFILE_INITBUFFERSIZE 65536
18 #define BUFFILE_MINBUFFERSIZE 16384
19
20 #define BUFFILE_MAXBUFFILESIZE 65536
21 // Kdyz se otevre soubor a zjisti se, ze je mensi nez tato konstanta
22 // tak se vytvori mensi buffer
23
24 #ifndef INVALID_SET_FILE_POINTER
25 #define INVALID_SET_FILE_POINTER ((DWORD)-1)
26 #endif
27
28
29 #define BUFFILE_BEHVF_UNICODE_START_HIDE 0x00000002
30 #define BUFFILE_BEHVF_LOADFILETOMEM 0x00000001
31 // Nacte na zacatku cely soubor do pameti, soubor zavre a dale se s nim uz nepracuje.
32 // Tento flag ma efekt jen pri otevreni souboru funkci
33 // bool Init (LPCSTR lpFileName);
34 // Druha funkce
35 // bool Init (HANDLE hFile, bool bCallSPF);
36 // tento flag zrusi
37
38
39 namespace vrecko {
40
41
42 bool FileExists (const _TCHAR *pFileName);
43
44
45 class VRECKO_EXPORT BufferedFile {
46 public:
47 BufferedFile (void);
48 ~BufferedFile (void);
49
50 bool setBehaviour (DWORD dwBehvFlags);
51 // kombinace BUFFILE_BEHVF_*
52 // Tuto funkci lze zavolat jen pred funkci Init.
53
54 bool init (_TCHAR* lpFileName);
55
56 bool init (HANDLE hFile, bool bCallSPF);
57 // hFile is handle to the opened file
58 // bCallSFP = true => call setFilePointer in destructor
59 // to set file pointer to the right position
60
61 HANDLE getHandle() { return hFile; };
62
63 LPBYTE lpBuffer;
64 DWORD dwPos;
65 inline DWORD getFilePos (void) const;
66 void close (void);
67 // After this function, the behaviour of other functions is
68 // undefined until calling Init.
69
70 bool setFilePos (DWORD dwNewFilePos);
71 // true = OK, false = failed
72 // Pokud je specifikovan flag BUFFILE_BEHVF_UNICODE_START_HIDE, tak
73 // se automaticky zmeni pozice mensi nez [dwZeroPos] na [dwZeroPos].
74 inline DWORD getMaxPos (void) const;
75 inline DWORD getBufSize (void) const;
76 inline DWORD getFileSize (void) const;
77 void setBufSize (DWORD dwNewSize);
78
79 bool preReadBytes (DWORD dwNumOfBytes);
80 // this function makes sure, that there are at least <dwNumOfBytes> bytes in buffer
81
82 inline bool readBytes (LPVOID lpDest, DWORD dwBytesToRead);
83 // This function will fail, if it doesn't read all the data.
84
85 inline bool readBytes (LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead) {
86 /* Optimization, which doesn't speed things up very much, so it was turned off
87
88 if (dwMaxPos - dwPos >= dwBytesToRead) {
89 memcpy (lpDest, (LPBYTE)lpBuffer + dwPos, dwBytesToRead);
90 if (lpdwBytesRead)
91 *lpdwBytesRead = dwBytesToRead;
92 dwPos += dwBytesToRead;
93 return true;
94 } else*/
95 return readBytesCore(lpDest, dwBytesToRead, lpdwBytesRead);
96 }
97 // ReadBytes cannot 'fail', but can read zero bytes.
98 // This function will return true, if it read exactly so many bytes as you specified
99 // or will return false, if it read less bytes (due to eof or error).
100 // lpdwBytesRead can be NULL in case you don't need this value
101
102 inline BYTE readByte (void);
103 // Reads byte WITHOUT error checking
104
105 bool readWCharTrans (WCHAR *wChar);
106 // Supports ASCII and UTF-16. (Automatic conversion)
107
108 inline bool readBool (bool *pData) { return readBytes (pData, 1); };
109 inline bool readByte (BYTE *pData) { return readBytes (pData, 1); };
110 inline bool readWORD (WORD *pData) { return readBytes (pData, 2); };
111 inline bool readDWORD (DWORD *pData) { return readBytes (pData, 4); };
112 inline bool readLONG (LONG *pData) { return readBytes (pData, sizeof (LONG)); };
113 inline bool readFloat (float *pData) { return readBytes (pData, 4); };
114 inline bool readVec3f (osg::Vec3f *v) { return readBytes(&v->x(), 4) && readBytes(&v->y(), 4) && readBytes(&v->z(), 4); };
115 inline bool readInt (int *pData) { return readBytes (pData, 4); };
116 inline bool readPOINT (POINT *pData) { return readBytes (pData, sizeof (POINT)); };
117 inline bool readInt64 (__int64 *pData) { return readBytes (pData, 8); };
118 inline bool readRECT (RECT *pData) { return readBytes (pData, sizeof (RECT)); };
119 inline bool readStr (CHAR *pData);
120
121 #ifdef UNICODE
122 inline bool tReadLine(_TCHAR* tBuffer, PDWORD pdwCharSize) { return readLineW(tBuffer, pdwCharSize); }
123 #else
124 inline bool tReadLine(_TCHAR* tBuffer, PDWORD pdwCharSize) { return readLine(tBuffer, pdwCharSize); }
125 #endif
126
127
128 bool readLine (PSTR pBuffer, PDWORD pdwCharSize);
129 // Reads line to CHAR buffer;
130 // Is is assumed, that file is in ASCII (not UTF-16)
131 // dwSize is size of buffer (in characters = 2 bytes) at the start and number of characters read
132 // after the function ends.
133 // pdwCharSize includes terminating character
134 // If dwSize is not enough to hold whole line, function will return false.
135
136 bool readLineW (PWSTR pBuffer, PDWORD pdwCharSize);
137 // Reads line to WCHAR buffer.
138 // dwSize is size of buffer (in characters = 2 bytes) at the start and number of characters read
139 // after the function ends.
140 // pdwCharSize includes terminating character
141 // If dwSize is not enough to hold whole line, function will return false.
142
143 inline bool isEOF (void) { return (getFilePos () >= getFileSize ()); }
144
145 protected:
146 HANDLE hFile;
147
148 DWORD dwFilePos;
149 DWORD dwMaxPos;
150 DWORD dwBufSize;
151 DWORD dwFileSize;
152
153 bool bCloseFile;
154 // Should the file be closed in destructor?
155 bool bCallSFP;
156
157 DWORD dwBehvFlags; // kombinace BUFFILE_BEHVF_*
158
159 bool bFileIsUTF;
160 // je soubor ve formatu UTF? (jinak je normalne v ASCII)
161 bool bReversedWChar;
162 // jsou byte ve WCHARu v souboru v obracenem poradi?
163
164 DWORD dwZeroPos;
165 // Pouziva se pouze, kdyz je specifikovan flag BUFFILE_BEHVF_UNICODE_START_HIDE.
166 // Nulova pozice. UNICODE soubory tady budou mit "2",
167 // protoze v prvnich dvou bytech jsou ridici znaky, ktere nechceme cist.
168
169 bool readBytesCore(LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead);
170
171 void UNICODECheck (void);
172 };
173
174
175 class BufferedFileWrite {
176 public:
177 BufferedFileWrite (void);
178 ~BufferedFileWrite (void);
179
180 bool init (TCHAR *lpFileName);
181
182 HANDLE getHandle() { return hFile; };
183
184 inline bool write (LPVOID lpBuffer, DWORD dwSize); // sadly this has to be inline due to compilation errors (bugs?) in PointShellGeneric_Object_Data<_NodeType> template
185
186 inline bool writeByte (BYTE bData) { return write (&bData, 1); };
187 inline bool writeBool (bool bData) { return write (&bData, 1); };
188 inline bool writeWORD (WORD wData) { return write (&wData, 2); };
189 inline bool writeLONG (LONG lData) { return write (&lData, sizeof (LONG)); };
190 inline bool writeDWORD (DWORD dwData) { return write (&dwData, 4); };
191 inline bool writeFloat (float fData) { return write (&fData, 4); };
192 inline bool writeVec3f (osg::Vec3f *v) { return write(&v->x(), 4) && write(&v->y(), 4) && write(&v->z(), 4); };
193 inline bool writeInt (int iData) { return write (&iData, 4); };
194 inline bool writePOINT (POINT *pnt) { return write (pnt, sizeof (POINT)); };
195 inline bool writeInt64 (__int64 iData) { return write (&iData, 8); };
196 inline bool writeRECT (RECT *rData) { return write (&rData, sizeof (RECT)); };
197 inline bool writeStr (PSTR pData) { return write (pData, (DWORD)strlen (pData) + 1); };
198 bool writeFormattedString (TCHAR *pFormat, ...);
199
200 bool flush (void);
201 bool close (void);
202
203 protected:
204 HANDLE hFile;
205 DynamicArray<BYTE> buffer;
206
207 DWORD dwBufMaxSize;
208 };
209
210
211 inline DWORD BufferedFile::getFilePos (void) const
212 {
213 return dwFilePos + dwPos;
214 }
215
216
217 inline DWORD BufferedFile::getMaxPos (void) const
218 {
219 return dwMaxPos;
220 }
221
222
223 inline DWORD BufferedFile::getBufSize (void) const
224 {
225 return dwBufSize;
226 }
227
228
229 inline DWORD BufferedFile::getFileSize (void) const
230 {
231 return dwFileSize;
232 }
233
234
235 inline bool BufferedFile::readBytes (LPVOID lpDest, DWORD dwBytesToRead)
236 {
237 DWORD dw;
238 if (!readBytes (lpDest, dwBytesToRead, &dw))
239 return false;
240 return (dw == dwBytesToRead);
241 }
242
243
244 inline BYTE BufferedFile::readByte (void)
245 {
246 if (dwPos >= dwMaxPos) {
247 if (!preReadBytes (1))
248 return 0x00;
249
250 if (dwMaxPos)
251 return lpBuffer[dwPos++];
252 return 0x00;
253 }
254 return lpBuffer[dwPos++];
255 }
256
257
258 bool BufferedFile::readStr (CHAR *pData)
259 {
260 while (readByte ((PBYTE)pData)) {
261 if (0x00 == *pData)
262 return true;
263 pData++;
264 }
265
266 return false;
267 }
268
269
270 bool BufferedFileWrite::write (LPVOID lpBuffer, DWORD dwSize)
271 {
272 if (!dwSize)
273 return true;
274
275 while (dwSize) {
276 DWORD dwTmp = dwSize;
277 if (dwSize > (dwBufMaxSize - buffer.dwNum))
278 dwTmp = (dwBufMaxSize - buffer.dwNum);
279
280 memcpy (buffer.lpBuffer + buffer.dwNum, lpBuffer, dwTmp);
281 buffer.dwNum += dwTmp;
282 dwSize -= dwTmp;
283 lpBuffer = (LPVOID)((LPBYTE)lpBuffer + dwTmp);
284
285 if (buffer.dwNum >= dwBufMaxSize) {
286 DWORD dwWritten;
287 if (FALSE == ::WriteFile (hFile, buffer.lpBuffer, buffer.dwNum, &dwWritten, NULL))
288 return false;
289 buffer.dwNum = 0;
290 }
291 }
292
293 return true;
294 }
295
296
297 }; // namespace vrecko
298
299
300 #endif // BUFFILE_H
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/BufferedSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
BufferedSpline.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "spline.h"
4
5 class BufferedSpline : public Spline
6 {
7 public:
9 BufferedSpline();
10 BufferedSpline(const Vec3ArrayPtr sampleArray);
11
13 META_DAObject(BufferedSpline, "Buffered Spline")
14
15 virtual Vec3ArrayPtr getPoints();
16 virtual bool isClosed() { return false; }
17
19 inline void setVertexArray(const Vec3ArrayPtr array);
20 inline Vec3ArrayPtr getVertexArray() const { return _array; }
21
22 protected:
23 Vec3ArrayPtr _array;
24 double _minDistance;
25 bool _closed;
26 unsigned int _lastIndex;
27 };
28
29 inline void BufferedSpline::setVertexArray( const Vec3ArrayPtr array )
30 {
31 if(array.valid()) {
32 _dirty = true;
33 _array = array;
34 _lastIndex = 0;
35 }
36 }
37
38 typedef osg::ref_ptr<BufferedSpline> BufferedSplinePtr;
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CCUStructs.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CCUStructs.h
Go to the documentation of this file.
1 #ifndef CCU_STRUCTS
2 #define CCU_STRUCTS
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/Message.h>
6 #include <vector>
7
8 #include "CarEnvirons.h"
9 #include "CarState.h"
10
11
12 namespace CarSim {
13 struct StartStopDestination {
14 unsigned int startEdge;
15 unsigned int stopEdge;
16 // offset urcuje relativne pozici na hrane v ramci useku OUT->IN (mezi 0 a 1),
17 // v XML je pro prehlednost mezi 0 a 100 (v procentech)
18 float startOffset;
19 float stopOffset;
20 };
21
22 // zde jsou ulozeny dalsi parametry CCU, jsou zasilany
23 // stavu silnic RoadsState, aby CCU ziskala informace o okoli auta
24 struct Parameters {
25 // id auta (id environment objectu, ktery vlastni tuto CCU)
26 unsigned int carId;
27 // ukazatel na CEU od CCU
28 vrecko::Ability *pCEU;
29 // (OBSOLETE: ukazatel na) vektor, ktery obsahuje cestu auta v podobe posloupnosti id
30 // krizovatek;
31 // 0. id je id krizovatky, do niz patri puvodni krizovatka from hrany,
32 // na ktere vozidlo zacina;
33 // posledni id je id krizovatky, jez obsahuje krizovatku to hrany,
34 // na niz auto konci;
35 // (OBSOLETE: v destruktoru CCU se musi uvolnit pamet, kam ukazuje tento ukazatel)
36 std::vector<unsigned int> path;
37 // mala krizovatka, ze ktere auto jede, je vyjadrena indexem
38 // v ceste path (na zacatku tedy index 0)
39 unsigned int lastJuncInPath;
40 // zde je ulozena hrana, na ktere auto zacina a offset (umisteni)
41 // auta na teto hrane; dale tu pak je ulozena hrana, na ktere auto
42 // zastavi a opet offset na ni;
43 StartStopDestination startStopDestination;
44 // popisuje vztah mezi pozici auta a pristi krizovatkou, hodnoty jsou
45 // popsany makry (viz CarEnvirons)
46 unsigned int carNextJuncRel;
47 // index hrany, na ktere je auto;
48 // slouzi ke snadnejsimu prirazeni normal autu pri prujezdu auta krizovatkou
49 unsigned int carEdgeId;
50
51
52 // zda ma auto povoleni jet do velke kriz. - viz CarEnvirons
53 bool pass;
54 };
55
56 // 1. 3 kriz. v ceste auta
57 struct First3Juncs {
58 unsigned int lastJunc;
59 unsigned int nextJunc;
60 unsigned int nextNextJunc;
61 };
62
63 // tato struktura slouzi k registraci auta u hrany (hrana a offset potom
64 // urcuji pocatecni pozici auta) a k overeni, zda je cilova pozice povolena
65 // (hrana a offset urcuji cilovou pozici auta, carId zustava nevyuzito)
66 struct CarEdgeData {
67 // id auta
68 unsigned int carId;
69 // id hrany
70 unsigned int edgeId;
71 // offset na ni (mezi 0 a 1)
72 float offset;
73 // delka auta
74 float carLength;
75 };
76
77
78
79
80 class MessageRoadAndDir : public vrecko::VreckoMessage {
81 public:
82 MessageRoadAndDir() {}
83 MessageRoadAndDir(unsigned int newRoad, bool newDir) { road = newRoad; direction = newDir; }
84
85 virtual const char* getMessageId() { return "MessageRoadAndDir"; }
86
87 unsigned int road;
88 bool direction;
89 };
90
91
92 class MessageCarEdge : public vrecko::VreckoMessage {
93 public:
94 MessageCarEdge() {}
95 MessageCarEdge(unsigned int newCar, unsigned int newEdge) { car = newCar; edge = newEdge; }
96
97 virtual const char* getMessageId() { return "MessageCarEdge"; }
98
99 unsigned int car;
100 unsigned int edge;
101 };
102
103
104 class MessageCarEdgeData : public vrecko::VreckoMessage {
105 public:
106 MessageCarEdgeData() {}
107
108 virtual const char* getMessageId() { return "MessageCarEdgeData"; }
109
110 CarEdgeData data;
111 };
112
113
114
115 class MessageEdgeOffset : public vrecko::VreckoMessage {
116 public:
117 MessageEdgeOffset() {}
118 MessageEdgeOffset(unsigned int theEdge, float theOffset) { edge = theEdge; offset = theOffset; }
119
120 virtual const char* getMessageId() { return "MessageEdgeOffset"; }
121
122 unsigned int edge;
123 float offset;
124 };
125
126
127 class MessageVectorUnsignedInt : public vrecko::VreckoMessage {
128 public:
129 MessageVectorUnsignedInt() {}
130
131 virtual const char* getMessageId() { return "MessageVectorUnsignedInt"; }
132
133 std::vector<unsigned int> data;
134 };
135
136
137 class MessageStartStopDestination : public vrecko::VreckoMessage {
138 public:
139 MessageStartStopDestination() {}
140 MessageStartStopDestination(StartStopDestination &dataToCopy) { data = dataToCopy; }
141
142 virtual const char* getMessageId() { return "MessageStartStopDestination"; }
143
144 StartStopDestination data;
145 };
146
147
148 class MessageFirst3Juncs : public vrecko::VreckoMessage {
149 public:
150 MessageFirst3Juncs() {}
151
152 virtual const char* getMessageId() { return "MessageFirst3Juncs"; }
153
154 First3Juncs data;
155 };
156
157
158 class MessageCarSimParameters : public vrecko::VreckoMessage {
159 public:
160 MessageCarSimParameters() {}
161 MessageCarSimParameters(Parameters &paramsToCopy) { data = paramsToCopy; }
162
163 virtual const char* getMessageId() { return "MessageCarSimParameters"; }
164
165 Parameters data;
166 };
167
168
169 class MessageCarEnvirons : public vrecko::VreckoMessage {
170 public:
171 MessageCarEnvirons() {}
172
173 virtual const char* getMessageId() { return "MessageCarEnvirons"; }
174
175 CarEnvirons data;
176 };
177
178 class MessageCarStatePtr : public vrecko::VreckoMessage {
179 public:
180 MessageCarStatePtr() {}
181 MessageCarStatePtr(CarState *csToPointAt) { data = csToPointAt; }
182
183 virtual const char* getMessageId() { return "MessageCarStatePtr"; }
184
185 CarState *data;
186 };
187
188 }
189
190 #endif
191
192
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/Cable.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
Cable.h
Go to the documentation of this file.
1
2 #ifndef CABLE_H
3 #define CABLE_H
4
5 //VRECKO
6
7 //#include <vrecko/World.h> //includovan ve Scene.h
8 #include <vrecko/Ability.h> //incudovane v World.h
9 #include <vrecko/PluginManager.h>
10
11 #include <vreckoAP/EditorController/ControllableAbility.h>
12
13 #include <vrecko/EnvironmentObject.h>
14 #include <vrecko/Scene.h> //chyba pri includu musi byt includovan na konci !!! jinak nelze najit EnvironmentObject
15
16 //OSG
17 #include <osg/Geode>
18 #include <osg/Geometry>
19 #include <osg/Drawable>
20 #include <osg/ShapeDrawable>
21
22
23 using namespace vrecko;
24
25 namespace AP_CableEditor {
26
27 #define SPHERE_RADIUS 2.0;
28
29 #define INTERPOLATION_CATMULL_ROM_ITERATE 1 //iterativni vyhlazovani - vzdy se puli interval (algoritmus se provede n-krat)
30 #define INTERPOLATION_CATMULL_ROM_PER_SEGMENT 2 //nastaveni pevneho poctu bodu na segment (mezi 2 kontrolnimi body bude n interpolovanych)
31
32
33 class Cable : public Ability {
34
35 protected:
36
37 //urcuje jestli doslo ke zmene kabelu a je potreba prekreslit obalku
38 bool controlPointsChange;
39
40 //promena urcijici, jestli se kabel nachazi v editacnim modu
41 bool isUpdateState;
42
43 //polomer kabelu
44 float cableRadius;
45 float controlSpheresRadiusAdjust;
46
47 //urcuje natoceni zakladni roviny pro RMF - umoznuje otacet tvarem kabelu kolem jeho osy
48 //v radianech
49 float basePlaneRotation;
50
51 //barva kabelu
52 osg::Vec4f cableColor;
53 osg::Vec4f controlSpheresColor;
54
55 //vektor kontrolnich bodu
56 //slouzi jako vstup pro interpolacni funkci
57 osg::ref_ptr<osg::Vec3Array> controlPoints;
58
59 //Tangenty, Normaly a Binormaly interpolovanych bodu
60 osg::ref_ptr<osg::Vec3Array> thisTangents;
61 osg::ref_ptr<osg::Vec3Array> thisNormals;
62 osg::ref_ptr<osg::Vec3Array> thisBinormals;
63
64 //vektor bodu pro vykresleni interpolovane krivky
65 //slouzi jako vstup pro obalovaci funkci
66 osg::ref_ptr<osg::Vec3Array> interpolatedPoints;
67
68 //pole urcuje tvar kabelu
69 osg::ref_ptr<osg::Vec3Array> shapePoints;
70
71 //vektors kontrolnich kouli
72 std::vector<vrecko::EnvironmentObject *> *controlSpheres;
73
74 //ukazatel na editacni linku
75 EnvironmentObject *cableControlLine;
76
77
78 //Obalujici EnvironmentObject teto ability
79 //sem se bude vkladat veskera geometrie (krom Kontrolnich kouli)
80 EnvironmentObject *thisEoWrapper;
81
82 //ulozeni posledni transformace obalky kabelu - pro testovani zmeny polohy, otoceni....
83 osg::ref_ptr<osg::MatrixTransform> lastWrapperTransformation;
84
85 osg::ref_ptr<osg::Geode> wrapperGeode;
86
87 unsigned int interpolationsNum;
88 unsigned int interpolationType;
89
90 string cableID;
91
92 //--------- DEBUG --------
93
94 //ukazatel na EO kontrolnich vektoru (tangenta, normala, binormala) ke kazdemu interpolovanemu bodu
95 //pro funkci visualizeVectors
96 EnvironmentObject *controlVectors;
97
98 //------------------------
99
100
101 //_____________________________________________________ Funkce _________________________________________________________________________________
102
103 //Upravi polohu kontrolnich kouli podle zadane matice
104 void updateSpheresPosition();
105
106 //Provede reakci na smazani kontrolni koule a na ukonceni VRECKa
107 virtual int processNotification(BaseClass *sender, unsigned long notificationType,
108 void *notificationData);
109
110 //Visualizace kontrolnich bodu - Vytvori na bodech z vektoru kontrolnich bodu koule
111 //podle polohy se nastavuje poloha kontrolnich bodu viz updateControlPoints()
112 void createSpheres();
113
114 //Vymaze vsechny kontrolni koule objektu ze sceny
115 void clearSpheres();
116
117 //aktualizuje kontrolni body na zaklade polohy kontrolnich kouli
118 //Pozor!!! - pokud byl pridan kontrolni bod a nebyla pro nej vytvorena koule, pak tento bod v aktualizovanych kontrolnich bodech nebude
119 // - stejne tak pokud byla smazana koule nektereho bodu, pak tento bod v poli nebude
120 void updateControlPoints();
121
122
123 public:
124 Cable();
125 virtual ~Cable();
126
127 virtual void preInitialize();
128 virtual void postInitialize();
129
130 void setCableID( string ID) { this->cableID = ID; }
131 string getCableID() {return this->cableID; }
132
133 void setShape( osg::ref_ptr<osg::Vec3Array> points ){ shapePoints = points; }
134 osg::ref_ptr<osg::Vec3Array> getShape(){ return shapePoints; }
135
136 void setInterpolation(unsigned int type, unsigned int num) { this->interpolationType = type; this->interpolationsNum = num; }
137 void getInterpolation(unsigned int *type, unsigned int *num) { *type = this->interpolationType; *num = this->interpolationsNum; }
138
139 void setRadius(float radius){ this->cableRadius = radius; }
140 float getRadius() { return this->cableRadius; }
141
142 //upraveni polomeru kontrolnich kouli (cableRadius + controlSpheresRadiusAdjust)
143 void setControlSpheresRadiusAdjust(float radius) { this->controlSpheresRadiusAdjust = radius; }
144 float getControlSpheresRadiusAdjust() { return this->controlSpheresRadiusAdjust; }
145
146 //upravi polomer kouli podle polomeru kabelu
147 void updateControlSpheresRadius();
148
149 void setCableColor( osg::Vec4f color ) { this->cableColor = color; }
150 osg::Vec4f getCableColor() { return this->cableColor; }
151
152 void setControlSpheresColor( osg::Vec4f color ) { this->controlSpheresColor = color; }
153 osg::Vec4f ControlSpheresColor() { return this->controlSpheresColor; }
154
155 //nastavuje/ziskava uhel pootoceni obalky v radianech (otoceni normaly a binormaly zakladni roviny pro RMF)
156 void setShapeRotate( float angle ) { this->basePlaneRotation = angle; }
157 float getShapeRotate() { return this->basePlaneRotation; }
158
159 //Nastaveni obalky kterou bude tato abilita spravovat - Musi byt nastaveno pri vytvareni ability !"
160 void setEoWrapper (EnvironmentObject *wrapper){ if(wrapper != NULL) thisEoWrapper = wrapper; }
161 EnvironmentObject *getEoWrapper() { return this->thisEoWrapper; }
162
163
164 //Vrati obalku kabelu jako Geode objekt
165 osg::Node *getCableWrapperNode() { return thisEoWrapper->getChild(0); }
166
167 void setControlPoints(osg::ref_ptr<osg::Vec3Array> points) { controlPoints = points; }
168 osg::ref_ptr<osg::Vec3Array> getControlPoints() { return controlPoints; }
169 osg::ref_ptr<osg::Vec3Array> getIntepolatedPoints() { return interpolatedPoints; }
170
171 void addControlPoint(osg::Vec3f position) { controlPoints->push_back(position); }
172
173 //vlozi bod na konkretni pozici v poli - pred prvek urceny v "position"
174 void addControlPoint(unsigned int position, osg::Vec3f point);
175
176 //vlozi bod mezi 2 nejblizsi body - predpoklada ze bod lezi (alespon priblizne) na primce dane 2 kontrolnimi body
177 void addControlPointBetweenLine(osg::Vec3f position);
178
179 //Interpolacni funkce vezme 4 body (p0,p1,p2,p3) a parametr "t" [0.0f, 1.0f] urcujici polohu bodu mezi body p1 a p2
180 osg::Vec3f getInterpolatedPoint(osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, double t = 0.5) const;
181
182
183 //vytvori kouli na zadanych souradnicich a vlozi ji do sceny vraci ukazatel na vytvoreny Environment object
184 EnvironmentObject *createSphere(osg::Vec3f center, float radius = 0.25){
185 return createSphere(center, this->cableColor, radius);
186 }
187
188 EnvironmentObject *createSphere(osg::Vec3f center, osg::Vec4f color, float radius = 0.25);
189
190 //interpoluje kontrolni body a nastavi je abilite
191 void interpolate();
192
193 //interpoluje kontrolni body Catmull-Rom algoritmem
194 //kazdy segment mezi 2 body rozdeli na pointsPerSegment interpolovanych bodu
195 // neprovadi kontrolu uhlu mezi kontrolnimi body (zhustovani bodu u ostrych uhlu)
196 // pointsPerSegment - pocet interpolovanych bodu mezi 2 kontrolnimi body
197 // inputPoints - pole bodu pro interpolaci. Musi byt >= 4
198 osg::ref_ptr<osg::Vec3Array> interpolateCatPerSegment(osg::ref_ptr<osg::Vec3Array> inputPoints, unsigned int pointsPerSegment) const;
199
200 //interpoluje zadane body pulenim intervalu
201 //vraci pole interpolovanych bodu
202 // inputPoints - pole kontrolnich bodu pro interpolaci. Musi byt >= 4
203 // numIterations - pocet iteraci
204 osg::ref_ptr<osg::Vec3Array> interpolateCatIterate(osg::ref_ptr<osg::Vec3Array> inputPoints, unsigned int numIterations) const;
205
206 //obali interpolovane body a udela z ni kabel
207 //parametr shapePoints - body urcujici tvar kabelu
208 void wrapCable();
209
210 //vypina nebo zapina aktualizaci kabelu
211 void setUpdate(bool state);
212
213 //vraci stav ve kterem se momentalne nachazi kabel (editacni rezim)
214 bool getUpdate() { return isUpdateState; }
215
216 //provadi update polohy kontrolnich bodu a obalky
217 virtual void update();
218
219 //Ke kazdemu bodu v poli ( !!krome prvniho a posledniho!! ) "points" vypocita jeho tangentu, normalu a binormalu a vrati v polich
220 //v pripade uspechu vraci 0
221 //jinak vraci cislo != 0 a obsah poli tangents, normals, binormals je nedefinovany
222 int computeRMF(osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals);
223
224 //vypocita polohu bodu tvaru v danem bode
225 //jako prvni parametr bere pole vektoru/bodu urcujici tvar protazeni
226 //dale pak bod ve kterem se na natoceni pocitat, jeho tangentu, normalu a binormalu
227 //vraci pole prepocetnych vektoru/bodu (otocenych do roviny dane normalou a binormalou)
228 osg::Vec3Array *transformVectors(osg::Vec3Array *vectors, osg::Vec3f point, osg::Vec3f tangent, osg::Vec3f normal, osg::Vec3f binormal, float scale = 1);
229
230
231 //Obali kabel a vrati jeho obalku jako jeden geode
232 //shapeVectors -> pole vektoru/body udavajiciho tvar kabelu musi byt definovana v rovine YZ
233 //points -> pole bodu pro obaleni: wrapFrom urcuje index prvniho bodu, wrapNum urcuje kolik bodu se bude obalovat - vzdy ale bez posledniho bodu v poli
234 //tangents, normals, binormals -> pole tangent/normal/binormal prislusejicich k bodum v poli "points" musi platit points->size() == tangents/normals/binormals->size() !!
235 //wrapFrom -> urcuje index od ktereho bodu se bude obalovat
236 //wrapNum -> urcuje kolik bodu se bude obalovat 0 znamena vsechny body v poli, pokud wrapNum < points->size() pouzije se points->size()
237 // Pozn: Vzdy se obaluje o 1 bod mene nez je urceno/obsazeno poli - pokud se maji obali vsechny body je treba posledni bod zduplikovat vcetne jeho tangenty/normaly/binormaly
238 osg::ref_ptr<osg::Geode> wrap(osg::Vec3Array *shapeVectors, osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals,
239 float scale = 1, unsigned int wrapFrom = 1, unsigned int wrapNum = 0);
240
241 //debugovaci fce:
242
243 void visualizeVectors(osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals);
244
245 };
246 }
247
248 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CableEditor/CableEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CableEditor
CableEditor.h
Go to the documentation of this file.
1 #ifndef _EDITOR_H_
2 #define _EDITOR_H_
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/PluginManager.h>
7 #include <vrecko/World.h>
8 #include <vrecko/EnvironmentObject.h>
9 #include <vrecko/Scene.h>
10
11 #include <vrecko/ReaderWriter.h>
12 #include <helpers/XercesXMLUtils.h>
13 #include <xercesc/parsers/XercesDOMParser.hpp>
14
15 #include <osg/Group>
16 #include <osg/Geode>
17 #include <osg/Geometry>
18 #include <osg/Shape>
19 #include <osg/ShapeDrawable>
20 #include <osg/Node>
21
22 #include <osgDB/WriteFile>
23
24 #include <iostream>
25 #include <sstream>
26 #include <vector>
27 #include <cmath>
28 #include <fstream>
29 #include <iomanip>
30 //#include <limits>
31
32 #include <vreckoAP/CableEditor/Cable.h>
33
34 using namespace vrecko;
35
36 namespace AP_CableEditor {
37
38 #define CE_RADIUS_ADJUSTMENT 0.9
39 #define CE_RADIUS_RANGE_FROM 0.0
40 #define CE_RADIUS_RANGE_TO 2.0
41
42 class CableEditor: public vrecko::ControllableAbility
43 {
44 public:
45 CableEditor();
46 virtual ~CableEditor();
47 virtual void update(void);
48
49 //otestuje pole cablePointers a vrati true pokud objekt je kabelem
50 bool isCable(unsigned int pEoID);
51
52 //vytvori kruznici v ose YZ (rotace kolem X)
53 osg::ref_ptr<osg::Vec3Array> createCircle(unsigned int steps);
54
55 protected:
56 //slouzi k nastaveni ID kabelu - pouze informacni ucely
57 unsigned int cableID;
58 unsigned int selectedCableId;
59 bool isSelectedCable;
60
61 //urcuje jestli jsme ve stavu kdy se body pridavaji pouze kliknutim leveho tlacitka mysi
62 bool isAddingPointState;
63
64 //urcuje jestli mazeme koule klikanim
65 bool isDeletingSphereState;
66
67 //priznak jestli vkladame bod mezi 2 existujici body - zapina vypocet polohy v update()
68 bool isInsertBetweenState;
69
70 //urcuje kam se bude vkladat novy bod - nastavuje se v update a vklada se v processButtonRelease
71 unsigned int insertIndex;
72 osg::Vec3f newPoint;
73
74 //ukazatel na prave aktivni abilitu kabelu (v dobe aktivace - pokud byl vybran kabel)
75 Cable *selectedCablePtr;
76
77 //zakladni polomer kabelu pro jemnejsi nastaveni polomeru (pricita se "jemnejsi" hodnota) a nastavuje zpatky kabelu
78 float selectedCableBaseRadius;
79
80 //Pokud jsme ve stavu vkladani kontrolniho bodu mezi 2 body obsahuje kouli znazornujici polohu nove vkladaneho bodu
81 EnvironmentObject *sphereBetweenPoints;
82
83 //Umisteni souboru pro ukladani/nacitani kabelu
84 std::string cablesFile;
85 std::string shapesFile;
86 std::string objFileDest;
87
88 std::vector<osg::ref_ptr<osg::Vec3Array>> loadedShapes;
89 std::vector<osg::ref_ptr<osg::Vec3Array>> predefinedShapes;
90
91 std::list<EnvironmentObject *> cablePointers;
92
93
94 // ------------------------------ Funkce -----------------------------------------
95
96 void Init();
97 void preInit();
98
99 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
100
101 virtual void fillDefaultInfo();
102 virtual bool activate();
103 virtual void deactivate();
104 virtual void menuItemClicked(const char* itemID);
105 virtual void menuSliderChanged(const char* sliderID, float sliderPos);
106 virtual void processButtonRelease(CABUTTONEVENT* eventData);
107
108 bool makeMenu();
109
110 //k zadanemu EnvironmentObjectu vrati jeho abilitu pokud je to platny EO - test pole cablePointers
111 Cable *getCableAbility(unsigned int EoId, bool notify = false);
112
113 //Vytvori "obalku" (prazdny EnvironentObject) a abilitu Cable, kterou priradi tomuto objektu
114 EnvironmentObject *createEoAbility( bool addToWorld = true );
115
116 //Nacte tvary ze souboru do pole loadedShapes z umisteni definovanem v XML souboru
117 void loadShapes();
118
119 //Nacte kabely ze souboru definovanem v XML a vlozi je do sceny
120 //nesmi byt volano driv nez je nastaven ukazatel na svet
121 void loadCables();
122
123 //Ulozi kabel do souboru definovanem v XML (soubor prida na konec, neprepisuje)
124 void saveCable( std::ofstream &outputFile, Cable *cable );
125
126 //zapise do souboru s kabely informace jak spravne definovat kabely (soubor prepise)
127 void writeInfo( std::ofstream &outputFile );
128
129 //reakce na smazani kabelu - odebrani ze seznamu kabelu
130 virtual int processNotification(BaseClass *sender, unsigned long notificationType,
131 void *notificationData);
132 };
133 }
134
135 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Cache.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Cache.h
Go to the documentation of this file.
1 #ifndef _CACHE
2 #define _CACHE 1
3
4 #include "ModelManager.h"
5 #include <vrecko/EnvironmentObject.h>
6 #include <map>
7 #include <list>
8 #include <string>
9 #include <vrecko/World.h>
10 #include <osg/Timer>
11 #include "model.h"
12 #include "Preloader.h"
13
14 using namespace vrecko;
15 using namespace ArtificialWorld;
16
18 class CacheInfo{
19 public:
20 CacheInfo(){};
21 CacheInfo(osg::ref_ptr<EnvironmentObject> _eo, osg::Vec3 _position, osg::Timer_t _timestamp, ModelType _modelType){
22 eo = _eo.get();
23 position = _position;
24 timestamp = _timestamp;
25 modelType = _modelType;
26 };
27
28 ~CacheInfo(){
29 eo = NULL;
30 };
31
32 bool operator==(const CacheInfo &ci2) const{
33 return (eo == ci2.eo);
34 };
35
36 bool operator!=(const CacheInfo &ci2) const{
37 return !(*this == ci2);
38 }
40 osg::ref_ptr<EnvironmentObject> eo;
42 osg::Vec3 position;
44 osg::Timer_t timestamp;
46 ModelType modelType;
47 };
48
50 class Cache : public GetObserver, public DeleteObserver, public AddObserver, public Ability
51 {
52 public:
53 Cache(): Ability("Cache"){ lastUpdateTime = updateTimer.tick(); };
54 ~Cache(void);
55
56 void initialize(void);
57
58 void init(bool useTime, unsigned long time, bool useDistance, unsigned long distance, unsigned long update_time){
59 cacheTimeEnabled = useTime;
60 holding_time = time;
61 cacheDistanceEnabled = useDistance;
62 holding_distance = distance;
63 update_time_ms = update_time;
64 preloader = NULL;
65 usePreloader = false;
66 }
67
69 void update(void);
70
72 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
73
80 void GetUpdate(string modelFilename, int num, ModelType modelType);
81
83 void DeleteUpdate(osg::ref_ptr<EnvironmentObject> deletingObject, int num, ModelType modelType);
84
86 void AddUpdate(string modelFilename, ModelType modelType);
87
89 void CreatePreloader(BlockUpdater *rootBlockUpdater)
90 {
91 if(preloader != NULL)
92 {
93 DeletePreloader();
94 }
95
96 preloader = new Preloader(rootBlockUpdater);
97 preloader->Start();
98 usePreloader = true;
99 };
100
102 void DeletePreloader(void)
103 {
104 if(preloader != NULL)
105 {
106 if(preloader->Running())
107 {
108 preloader->Stop();
109 }
110 delete preloader;
111 preloader = NULL;
112 usePreloader = false;
113 }
114 }
115
116 private:
118 map<string, CacheInfo*> searchDataNamed;
120 list<CacheInfo> data;
121
123 unsigned long holding_distance;
125 unsigned long holding_time;
127 unsigned long update_time_ms;
129 bool cacheTimeEnabled;
131 bool cacheDistanceEnabled;
133 bool usePreloader;
135 Preloader *preloader;
136
138 osg::Timer updateTimer;
140 osg::Timer_t lastUpdateTime;
141 };
142 #endif
143
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraPath/Camera.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraPath
Camera.h
Go to the documentation of this file.
1 #ifndef _CAMERA_H_
2 #define _CAMERA_H_
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/PluginManager.h>
7 #include <vrecko/World.h>
8 #include <vrecko/EnvironmentObject.h>
9 #include <vrecko/Scene.h>
10
11 //XML parameters
12 #include <helpers/XercesXMLUtils.h>
13 #include <vrecko/ReaderWriter.h>
14 #include <xercesc/parsers/XercesDOMParser.hpp>
15
16 #include <osg/Group>
17 #include <osg/Geode>
18 #include <osg/Geometry>
19 #include <osg/Shape>
20 #include <osg/ShapeDrawable>
21 #include <osg/Timer>
22
23 #include <iostream>
24 #include <fstream>
25 #include <sstream>
26 #include <vector>
27 #include <cmath>
28
29 namespace APCameraPath {
30
31 #define SHOW_VIEW_LINE false
32 #define PATH_POINT_RADIUS 0.5
33
34 #define SHOW_LINES_WHILE_ANIMATING false
35
36 #define ANIMATION_TIME 10 //s
37 #define DYNAMIC_SPEED false
38 #define TRANSPARENCY 1.0 //0.0 is invisible, 1.0 is non-transparent
39
40 #define AUTO_RUN false;
41
42
43 typedef unsigned int _uint;
44
45 struct ControlPoint
46 {
47 vrecko::EnvironmentObject* Path_ptr;
48 vrecko::EnvironmentObject* View_ptr;
49 };
50
51 class Camera: public vrecko::ControllableAbility
52 {
53 public:
54 Camera();
55 virtual ~Camera() {};
56 void update(void);
57 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL) { bool bRet = ControllableAbility::initialize(); Init(); UpdatePath(); return bRet; };
58
59 protected:
60
61 enum state
62 {
63 STATE_EDITING,
64 STATE_ANIMATING,
65 STATE_MOVING
66 } m_eState;
67 enum animate
68 {
69 ANIM_1ST_VIEW,
70 ANIM_3RD_VIEW
71 } m_eAnimate;
72
73 vrecko::World::AvatarView avView; //Used for storing actual view position before animation
74
75 vrecko::EnvironmentObject* m_pEOPathLine; //EO for path curve
76 vrecko::EnvironmentObject* m_pEOPathPoints; //EO for path control points
77 vrecko::EnvironmentObject* m_pEOViewLine; //EO for view curve
78 vrecko::EnvironmentObject* m_pEOCursor; //EO for 3D pointers
79 vrecko::EnvironmentObject* m_pEOCamera; //EO for Camera model for 3rd person view
80
81 bool bStartAnimation;
82 bool b3rdCamera;
83
84 unsigned int m_numOfViewPts;
85
86 std::vector<ControlPoint> m_ControlPoints;
87
88 std::vector<osg::Vec3> m_ActPathLine; //Used for storing actual path line for animating
89 std::vector<osg::Vec3> m_ActViewLine; //------------||--------- view line -----||------
90
91 //XML Parameters
92 float fPointRadius;
93 bool bShowViewLine;
94 bool bShowLinesWhileAnim;
95 int iSpeed;
96 float fTransparency;
97 float fAnimationTime;
98 string sAnimationFile;
99 bool bAnimationFile;
100 bool bAutoRun;
101 bool bDynamicSpeed;
102
103 virtual void fillDefaultInfo();
104 virtual bool activate();
105 virtual void deactivate();
106 virtual void menuItemClicked(const char* itemID);
107 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
108
109 std::vector<osg::Vec3> PathCtrlPts;
110 std::vector<osg::Vec3> ViewCtrlPts;
111
113 // FUNCTIONS
115
118 void ComputePath(std::vector<ControlPoint> &ControlPoints, osg::Vec3Array* Path, osg::Vec3Array* View);
122 void ComputeSpline(const std::vector<osg::Vec3> &PointList, osg::Vec3Array* arrayToStorePoints,
123 bool bDynamicSpeed, const std::vector<double>* LengthsOfParts);
127 std::vector<double> ArcLength(osg::Vec3Array* PointList, int PointsOnPart = 100);
128
129 void DrawSpline(vrecko::EnvironmentObject* pCurveOwner, osg::Vec3Array* PointSet, osg::Vec4 colorOfLine);
133 void CreateCurs2ViewPts();
137 void DrawVecCursor(vrecko::EnvironmentObject* pCursorOwner, double dVecLength,
138 const osg::Matrix &rotationMatrix, osg::Vec3 &position);
142 vrecko::EnvironmentObject* DrawPoint(osg::Vec3 position, float pointRadius, osg::Vec4 pointColor);
146 void UpdatePath();
150 void InitAnimation(osg::Vec3Array* path, osg::Vec3Array* view);
151 void Animate();
155 osg::Matrix Orient2Vec(osg::Vec3 Vector);
159 bool makeMenu();
163 bool makeMovementMenu();
167 bool FindPoint(double dDistance, osg::Vec3Array* PointList, osg::Vec3Array* newControlPoints);
171 void Clear();
172
173 void Init();
175 void AddPathPoint(osg::Vec3 position);
176 void AddViewPoint(osg::Vec3 position);
177 void DeletePoint(unsigned long ID);
178
179 void start1stAnimation();
181 void SaveAnimation(const char* FileName);
182 bool LoadAnimation(const char* FileName,std::vector<osg::Vec3> &newPathControlPoints,
183 std::vector<osg::Vec3> &newViewControlPoints);
185
186 //----------------------------------------------------------------------
187 // Simple Object Movement Part
188 //----------------------------------------------------------------------
189
190 osg::Vec3 firstPointerPos; // pointer position when activate
191 osg::Vec3 firstObjectPos; // object position when activated
192 unsigned long movingObjectID; // ID of the object that is being handled. If this is 0, the ability is not activated
193 bool bFirstUpdate;
194
195 void issueRequests(bool bStopIfNoSelection);
196 bool objectTransformationFromPointer(vrecko::EnvironmentObject *eo, osg::Matrix *outTrans);
197 void UpdateMove();
198 bool ActivateMove();
199 void DeactivateMove();
200 };
201
203 //Catmull-rom splines
204 inline float F1(float t) { return (2*pow(t,2)-pow(t,3)-t); }
205 inline float F2(float t) { return (3*pow(t,3)-(5*pow(t,2))+2); }
206 inline float F3(float t) { return (4*pow(t,2)-(3*pow(t,3))+t); }
207 inline float F4(float t) { return (pow(t,3)-pow(t,2)); }
209 }
210
211 #endif
212
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraMovementEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
CameraMovementEditor.h
Go to the documentation of this file.
1 #ifndef _CAMERA_MOVEMENT_EDITOR_H
2 #define _CAMERA_MOVEMENT_EDITOR_H
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/Ability.h>
7 #include <vrecko/EnvironmentObject.h>
8 #include <vrecko/Scene.h>
9 #include <vrecko/EventDispatcher.h>
10 #include <vrecko/Logger.h>
11
12 #include <osgDB/ReadFile>
13
14 #include <iostream>
15 #include <sstream>
16
17 #include "CameraPath.h"
18
19 using namespace vrecko;
20
21 namespace APCameraMovement {
22
23 class CameraMovementEditor : public ControllableAbility {
24 public:
25 CameraMovementEditor();
26 virtual ~CameraMovementEditor() {};
27
28 void update(void);
29
30 private:
31 enum Action {
32 NONE = 0,
33 SELECT = 1,
34 ADD = 2,
35 REMOVE = 3,
36 MOVE = 4,
37 ROTATE = 5,
38 ANIMATE = 6
39 };
40
41 protected:
42 virtual void fillDefaultInfo();
43
44 virtual bool activate();
45 virtual void deactivate();
46
47 unsigned long selectedObjectID; // ID of the object that is being handled. If this is 0, the ability is not activated
48
49 void issueRequests(bool bStopIfNoSelection);
50
51 bool setIntersection(osg::Vec3& position, vrecko::Scene* scenePtr);
52 osgUtil::LineSegmentIntersector::Intersection intersection;
53
54 Action action;
55 EnvironmentObject* pathObject;
56 CameraPath* pCameraPath;
57
58 bool viewMenu();
59 virtual void menuItemClicked(const char* itemID);
60
61 bool menuShowed;
62 bool bFirstUpdate;
63
64 unsigned int pointIndex;
65 unsigned int pointType;
66
67 osg::Vec3 firstPointerPos;
68 osg::Vec3 firstObjectPos;
69 osg::Vec3 firstObjectPosCo;
70
71 };
72
73 }
74
75 #endif
76
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CameraMovementFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CameraMovementFilter.h
Go to the documentation of this file.
1 #ifndef CAMERAMOVEMENT_FILTER_H
2 #define CAMERAMOVEMENT_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 #include "FadeFilter.h"
9
10 namespace vreckoDP_PHANToM {
11
12 /* PHANToM filter to move camera by pressing the button on the Phantom device and moving with it */
13 class CameraMovementForceFilter : public FadeForceFilter {
14 public:
15 CameraMovementForceFilter();
16
17 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
18
19 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
20
21 protected:
22 osg::Vec3f origAvatarPos;
23 osg::Quat origAvatarRot;
24
25 osg::Vec3f origToolPos;
26 osg::Quat origToolRot;
27
28 bool bMovementStarted;
29
30 void startCameraMovement(PHANToMSTATE &pState);
31 void endCameraMovement();
32
33 // void phantomToOSG(osg::Vec3f &pos, osg::Quat &rot);
34 // Transforms coordinate axes from Phantom coordinate system to the OSG (OpenGL) one
35 };
36
37 }
38
39 #endif
40
41
42 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CameraMovement/CameraPath.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CameraMovement
CameraPath.h
Go to the documentation of this file.
1 #ifndef _CAMERA_PATH_H
2 #define _CAMERA_PATH_H
3
4 #include <vrecko/ReaderWriter.h>
5
6 #include <vrecko/Ability.h>
7 #include <vrecko/EnvironmentObject.h>
8 #include <vrecko/Scene.h>
9 #include <vrecko/EventDispatcher.h>
10 #include <vrecko/Logger.h>
11
12 #include <helpers/XercesXMLUtils.h>
13 #include <xercesc/parsers/XercesDOMParser.hpp>
14 #include <xercesc/dom/DOM.hpp>
15 #include <xercesc/sax/HandlerBase.hpp>
16 #include <xercesc/util/XMLString.hpp>
17 #include <xercesc/util/PlatformUtils.hpp>
18
19 #include <osg/Group>
20 #include <osg/Geode>
21 #include <osg/Geometry>
22 #include <osg/Shape>
23 #include <osg/ShapeDrawable>
24 #include <osg/PositionAttitudeTransform>
25 #include <osg/LineWidth>
26 #include <osg/LightModel>
27 #include <osg/ShadeModel>
28 #include <osg/PolygonMode>
29
30 #include <osg/Timer>
31 #include <vector>
32
33 using namespace vrecko;
34 using namespace vrecko;
35
36 namespace APCameraMovement {
37
38 #define CONTROL_POINT_RADIUS 1.0
39 #define CONTROL_POINT_COLOR osg::Vec4(1.0, 0.0, 0.0, 0.5)
40
41 #define VECTOR_POINT_RADIUS 1.0
42 #define VECTOR_POINT_COLOR osg::Vec4(0.0, 0.0, 1.0, 0.5)
43
44 #define CONTROL_LINE_WIDTH 1.0
45 #define CONTROL_LINE_COLOR osg::Vec4(0.0, 0.0, 1.0, 1.0)
46
47 #define PATH_LINE_WIDTH 1.0
48 #define PATH_LINE_COLOR osg::Vec4(1.0, 0.0, 0.0, 1.0)
49
50 #define DEFAULT_VECPW osg::Vec3(CONTROL_POINT_RADIUS*3, 0.0, 0.0)
51 #define DEFAULT_VECCPW osg::Vec3(-(CONTROL_POINT_RADIUS*3), 0.0, 0.0)
52 #define DEFAULT_CDIR osg::Quat(0.0, 0.0, 0.0, 1.0)
53
54 #define TOP_VECTOR osg::Vec3(0.0, 1.0, 0.0)
55 #define DIR_VECTOR osg::Vec3(0.0, 0.0, 1.0)
56
57 #define STEP 0.01
58 #define MULT 6
59 #define SPEED 2
60
61 struct ControlPoint {
62 osg::Vec3 position;
63 osg::Vec3 vectorPathWise;
64 osg::Vec3 vectorCounterPathWise;
65 osg::Quat cameraRotation;
66
67 double totalPathLength; // total length from first to this point
68 double pathLength; // length of the curve [i-1;i]
69 unsigned int pathIndex; // index where the curve [i-1;i] ends
70 };
71
72 class CameraPath : public Ability {
73 public:
74 CameraPath();
75 ~CameraPath();
76
77 // called as the first initialization method, before loadXMLParameters
78 virtual void preInitialize();
79
80 // called as the last initialization method, after loadXMLParameters
81 virtual void postInitialize();
82
83 // loads XML parameters from given node
84 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
85
86 // processes an event
87 // void processEvent(const std::string &strInputName, void *pValue);
88
89 // ability update method
90 virtual void update();
91
92 // visualisies the path incl. points
93 void draw();
94
95 void setDirty(bool d) { dirty = d; }
96 std::vector<ControlPoint>* getControlPoints() { return &controlPoints; }
97
98 void addPoint(osg::Vec3 pos, osg::Vec3 vecPW = DEFAULT_VECPW, osg::Vec3 vecCPW = DEFAULT_VECCPW, osg::Quat cDir = DEFAULT_CDIR) {
99 ControlPoint p;
100 p.position = pos;
101 p.vectorPathWise = vecPW;
102 p.vectorCounterPathWise = vecCPW;
103 p.cameraRotation = cDir;
104 controlPoints.push_back(p);
105 }
106
107 inline bool animating() { return isAnimating; }
108
109 bool startAnimation();
110 bool stopAnimation();
111 bool updateActTime();
112 float convertActTimeToActPos();
113 bool updateAnimation(float fActPos);
114
115 private:
116
117 // control points defining the path
118 std::vector<ControlPoint> controlPoints;
119
120 // the path vertices to be drawn as line strip
121 std::vector<osg::Vec3> pathPoints;
122
123 // pointer to parent enviroment object
124 EnvironmentObject* pEOOwner;
125
126 bool dirty;
127 bool isAnimating;
128 osg::Timer_t lastTimerTick;
129
130 // actual position of camera when animating (relative distance on the curve)
131 float fActTime;
132
133 // computes the path
134 void computePath();
135
136 // pointer to avatar view
137 World::AvatarView *avView;
138
139
140
141
142 // parameters corresponding to macros above
143 float controlPointRadius; // sphere radius of a main control point
144 osg::Vec4 controlPointColor; // color of a main control point
145
146 float vectorPointRadius; // sphere radius of a point defining a vector
147 osg::Vec4 vectorPointColor; // color of a point defining a vector
148
149 float controlLineWidth; // width of a line showing the vectors
150 osg::Vec4 controlLineColor; // color of a line showing the vectors
151
152 float pathLineWidth; // width of a line showing the path
153 osg::Vec4 pathLineColor; // color of a line showing the path
154
155 float speed; // speed of the camera (float per second)
156 float step; // a step of one ferguson curve (how many pieces there are between two control points)
157
158 bool freeLook; // defines whether user can rotate with camera while moving
159
160
161 DECLARE_INPUT(Trigger, MessageVoid);
162 };
163
164 }
165
166 #endif
167
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CappedCylinder.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
CappedCylinder.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include "DynamicScene.h"
3
4 using namespace vrecko;
5
6 namespace ode {
7
8 class CappedCylinder: public Ability {
9 public:
10 CappedCylinder();
11 ~CappedCylinder() {};
12
13 void postInitialize(void);
14 void update(void);
15
16 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
17 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
18
19 protected:
20 double _radius;
21 double _length;
22 int _direction;
23 double _density;
24
25 DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid);
26 };
27
28 }
29
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Capsule.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Capsule.h
Go to the documentation of this file.
1 #ifndef Capsule_h
2 #define Capsule_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseActor.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14
15 class Capsule : public BaseActor
16 {
17 public:
18 Capsule():BaseActor("PhysX Capsule"){}
19 ~Capsule(){}
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23 protected:
24 void Create();
25
26 NxCapsuleShapeDesc _capsuleDesc;
27 };
28
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarControlUnit.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CarControlUnit.h
Go to the documentation of this file.
1 #ifndef CAR_CONTROL_UNIT
2 #define CAR_CONTROL_UNIT
3
4 #include <vrecko/Ability.h>
5 #include <osg/Matrix>
6 #include "CCUStructs.h"
7 #include "CarState.h"
8 #include "CarEnvirons.h"
9
10 namespace CarSim {
11 class CarControlUnit: public vrecko::Ability {
12 public:
13 CarControlUnit();
14 // tento konstruktor bude slouzit k nastaveni generovanych aut
15 CarControlUnit(const unsigned int startRoad,const unsigned int stopRoad,
16 const bool startDirection,const bool stopDirection,
17 const float startEdge,const float stopEdge,
18 const float startOffset,const float stopOffset,
19 const float recVelOnFstJunc,const unsigned int fstJuncTurn,
20 Ability *const pRoadsState,Ability *const pCEU,const std::vector<unsigned int> *const pPath);
21 ~CarControlUnit();
22
23 void preInitialize(void);
24 void update(void);
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 protected:
28 Parameters params;
29 // I. jestlize neni auto odsunuto (pozna se to z params.carNextJuncRel), bude zde
30 // cas, po ktery auto stoji pred (tesne) bodem stopBeforeJunc a ceka az
31 // dostane povoleni jet krizovatkou; jestlize se ten cas nepocita, bude obsahovat -1.0,
32 // jinak hodnotu >=0.0;
33 // II. jestlize auto bylo na hrane odsunuto a
34 // a) bylo odsunuto nejdriv (1. ze vsech aut, ktere jsou nyni
35 // odsunuty na hrane), bude zde cas, ktery uplynul od posledniho pokusu dostat
36 // se z kraje vozovky zpatky do ni nebo od doby, kdy se auto stalo prvnim (nejdrive)
37 // odsunutym autem na hrane
38 // b) nebylo odsunuto nejdriv, bude obsahovat hodnotu -1.0
39 // III. ve zbylych pripadech -1.0
40 float timeWaiting;
41
42 // rika, zda bylo auto nastaveno rucne (false) nebo vygenerovano (true)
43 const bool gen;
44
45 // jestlize je true, nastala chyba v inicializaci, takze se odregistruje
46 // aktualizovani CCU
47 bool errorOccuredInInit;
48 // rika, zda byla provedena inicializace v metode update()
49 bool initBool;
50
51 // z XML souboru se vyextrahuje silnice (id pro Road - ulozi se
52 // v promenne startRoad) pres uzel StartRoad a jeji smer (true - "forward"
53 // nebo false - "backward" - ulozi se v promenne startDirection) pres uzel startDirection,
54 // ktere uruji hranu, na ktere auto zacina;
55 unsigned int startRoad;
56 bool startDirection;
57 // obdobne je tomu s stopRoad a stopDirection, ktere urcuji,
58 // na ktere hrane auto zastavuje
59 unsigned int stopRoad;
60 bool stopDirection;
61
62 // doporucena rychlost na pristi krizovatce od RoadsState (ulozi se zde,
63 // aby se v kazdem snimku nemusela pocitat znovu v RoadsState);
64 // jestlize je < 0, neobsahuje aktualni data
65 float recVelocityOnJunc;
66
67 // ukazatel na abilitu RoadsState
68 Ability *pRoadsState;
69
70 // cas zjisteny v minulem snimku
71 osg::Timer_t lastTick;
72
73 /*// slouzi ke zjisteni prumerneho poctu aktualizaci jednotky
74 // CCU 1. generovaneho auta za sekundu v 1. minute
75 bool isFPSmeasured;
76 float totalTime;
77 unsigned int count;*/
78
79 // rika, zda auto bude na pristi krizovatce zatacet doleva nebo doprava
80 unsigned int nextJuncTurn;
81
82 // metody, ktere provedou inicializaci v ramci metody update()
83 // (slouzi jen pro negenerovana auta)
84 void init();
85 void initPositionAndDirection();
86 // metoda, ktera zkontroluje vstupni XML parametry
87 void checkInputXMLParameters();
88 // metoda, ktera urci pres RoadsState nejkratsi cestu pro auto
89 void computeShortestPath();
90 // metoda, ktera vypocita optimalni rychlost prujezdu 1. kriz. v ceste
91 void computeRecVelOnFstJunc();
92 // metoda urci, jakym smerem (viz nextJuncTurn) se auto vyda na prvni
93 // krizovatce
94 void figureOutFirstJuncTurn();
95
96 // metoda, ktera ukonci aktualizovani auta, u Removera prihlasi toto auto
97 void quitAfterError();
98
99 // vrati pocet sekund, ktere ubehly od posledniho updatu
100 float getTimeFromLastUpdate();
101
102 // metoda nastavi blinkry pres jednotku CEU podle nextJuncTurn,
103 // pokud jeste nejsou ve spravnem stavu
104 // (jestlize auto zataci doleva, zapne se levy blinkr, pokud jeste neni zapnuty;
105 // jestlize doprava, tak pravy blinkr (pokud neni zapnuty) a jestlize auto jede rovne,
106 // vypnou se blikry (pokud jeste nejsou vypnute));
107 // aktualni stav blinkru urcuje druhy parametr blinkLightState;
108 // jestlize je parametr isEmergency true, nenastavuji se blinkry podle
109 // nextJuncTurn, ale jestli jeste vsechny neblikaji, tak zacnou;
110 void setBlinkers(Ability *const pCEU,const unsigned int blinkLightState,
111 const bool isEmergency);
112
113 };
114
115 // tato metoda vypocita vzdalenost, po kterou musi auto brzdit, aby
116 // se jeho aktualni rychlost snizila na pozadovanou rychlost
117 // (jestlize je pozadovana rychlost vetsi nez aktualni, vrati se 0.0);
118 // parametry:
119 // carVel - aktualni rychlost auta
120 // desiredVel - pozadovana rychlost
121 // carDecel - zpomaleni, kterym bude auto brzdit
122 // hillAcc - prirustek zrychleni diky naklonu vozovky
123 // (pred krizovatkou budou zatim vsechna auta brzdit se zpomalenim AVERAGE_CAR_DEC;
124 // maximalni zpomaleni bude vyuzito v budoucnu pri krizovych situacich)
125 float getBrakeDist(const float carVel,const float desiredVel,
126 const float carDecel,const float hillAcc);
127 }
128
129 #endif
130
131
132
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarEnvirons.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CarEnvirons.h
Go to the documentation of this file.
1 #ifndef CAR_ENVIRONS
2 #define CAR_ENVIRONS
3
4 // tato makra popisuji vztah mezi pozici auta a pristi krizovatkou:
5 #define CAR_LEFT_JUNCTION 1
6 #define CAR_IN_JUNCTION 2
7 // auto je na kratke hrane mezi body OUT a IN
8 #define CAR_ON_SHORT_EDGE_BEFORE_JUNC 3
9 //#define CAR_FINAL_DESTINATION_REACHED 7
10 // auto je na normalni hrane za bodem stopOrGoDecision (mezi body OUT a IN
11 // a neni odstaveno mimo hranu)
12 #define CAR_BEHIND_STOP_OR_GO_DECISION 4
13 // to same, ale auto je odstaveno mimo hranu; (auto je docasne
14 // ze hrany odsunuto, kdyz stoji pred bodem stopBeforeJunc hrany prilis dlouho
15 // a nejspis tedy brani prujezdu ostatnich aut
16 #define CAR_BEHIND_STOP_OR_GO_DECISION_AND_PUT_ASIDE_TO_ROAD_MARGIN 5
17 // auto je na normalni hrane pred bodem stopOrGoDecision (mezi body OUT a IN)
18 #define CAR_IN_FRONT_OF_STOP_OR_GO_DECISION 6
19 // auto je pred cilem na konecne hrane
20 #define CAR_BEFORE_END 7
21 // Pozn.: kdyz je neco pred necim, znamena to, ze to je od toho smerem
22 // od bodu IN hrany k bodu OUT hrany; za je opacnym smerem
23
24 // auto bude na pristi krizovatce zatacet doleva (viz nextJuncTurn)
25 #define NEXT_JUNC_TURN_LEFT 1
26 // to same doprava
27 #define NEXT_JUNC_TURN_RIGHT 2
28
29 namespace CarSim {
30 struct CarEnvirons {
31 // popisuje vztah mezi pozici auta a pristi krizovatkou, hodnoty jsou
32 // popsany makry
33 unsigned int carNextJuncRel;
34
35 // jestlize je auto za bodem stopOrGoDecision na normalni (nekoncove) hrane,
36 // nabyva hodnotu true, kdyz auto muze jet pristi velkou
37 // krizovatkou); v opacnem pripade je false
38 bool pass;
39
40 // jestlize auto neni na krizovatce, je zde vzdalenost k pristimu
41 // vyznamnemu bodu v ceste auta (cil, bod IN nebo stopBeforeJunc):
42
43 // I. jestlize je auto na normalni hrane mezi body Out a In,
44 // je zde vzdalenost k bodu stopBeforeJunc (v nekterych pripadech
45 // musi auto zacit brzdit jeste pred bodem stopOrGoDecision,
46 // aby melo v bode stopBeforeJunc 0-ovou rychlost (aby zastavilo));
47 // to, ze je auto uz za bodem stopBeforeJunc, je vyjadreno znaminkem - pred
48 // touto vzdalenosti
49 // II. jestlize je auto na konecne hrane, je zde vzdalenost k cily
50 // (jestlize auto prejelo cil, vzdalenost je zaporna);
51 // III. jestlize je auto na kratke hrane, je zde vzdalenost k bodu IN;
52 // (jinak obsahuje -1)
53 float distToNextPoint;
54 // jestlize auto prave vstoupilo do krizovatky, je uvedeno zatoceni kol tak,
55 // aby vozidlo plynule projelo krizovatkou a vjelo do spravne odbocky -
56 // - do vystupni hrany na krizovatce
57 float wheelAngleOnJunc;
58 // jestlize auto opousti malou krizovatku u bodu Out, je
59 // zde doporucena rychlost auta na pristi krizovatce
60 float recVelocityOnJunc;
61 // hrana, na ktere se v aktualnim snimku nachazi auto
62 unsigned int carEdgeId;
63 // jestlize je auto na normalni hrane mezi body OUT a IN,
64 // je zde vzdalenost k nasledujicimu autu na hrane; jestlize auto neni
65 // na normalni hrane nebo zadne nasledujici auto neni, obsahuje
66 // nejvetsi zaporne cislo typu float (pri nizkem fps se muze stat, ze
67 // je tato vzdalenost zaporna - auto nabouralo nasledujici auto)
68 float nextCarDist;
69 // rychlost dalsiho auta (jestlize zadne nebude, bude 0)
70 float nextCarVel;
71 // rika, zda auto bude na pristi krizovatce zatacet doleva (NEXT_JUNC_TURN_LEFT,
72 // uhel angleInXZ mezi vstupni a vystupni hranou na pristi krizovatce
73 // je v intervalu (6/5 PI, 2*PI)),
74 // zatacet doprava (NEXT_JUNC_TURN_RIGHT, uhel angleInXZ je v intervalu (0,4/5 PI)
75 // nebo pojede rovne (0, uhel v intervalu [4/5 PI, 6/5 PI]);
76 // uhel mezi vstupni a vystupni hranou v jedne silnici neni 0, ale 2*PI-0.001 -
77 // viz angleInXZ v InOutEdgeAttr v Junction.h);
78 // nastavi se, kdyz auto vyjizdi ze krizovatky
79 unsigned int nextJuncTurn;
80 };
81 }
82
83 #endif
84
85
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarExecutionUnit.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CarExecutionUnit.h
Go to the documentation of this file.
1 #ifndef CAR_EXECUTION_UNIT
2 #define CAR_EXECUTION_UNIT
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/IOPins.h>
6 #include <vrecko/Message.h>
7 #include <osg/MatrixTransform>
8 #include "CarState.h"
9 #include "CCUStructs.h"
10
11 // typy svetel:
12 #define FRONT_LIGHT 1
13 #define BRAKE_LIGHT 2
14 #define BLINK_LIGHT 3
15
16 // cas v s od zacatku bliknuti do zacatku pristiho bliknuti blinkeru
17 #define BLINK_LENGTH 1.0
18
19 namespace CarSim {
20 // zde budou ulozeny ukazatele na transformace svetel
21 struct Lights {
22 osg::MatrixTransform* pFrontLightMT;
23 osg::MatrixTransform* pBrakeLightMT;
24 osg::MatrixTransform* pLeftBlinkerLightMT;
25 osg::MatrixTransform* pRightBlinkerLightMT;
26 };
27
28 // pro ulozeni cest k souborum s casmi geometrie auta (bude mit vyznam
29 // pouze u negenerovanych aut)
30 struct GeometryPartsPath {
31 std::string carWithoutWheelsPath;
32 std::vector<std::string> leftWheelsPathVec;
33 std::string frontLightsPath;
34 std::string brakeLightsPath;
35 std::string leftBlinkerPath;
36 std::string rightBlinkerPath;
37 };
38
39 class CarExecutionUnit: public vrecko::Ability {
40 public:
41 CarExecutionUnit();
42 // tento konstruktor bude slouzit k nastaveni generovanych aut
43 CarExecutionUnit(const CarSize &carSize,
44 const float maxSpeed,const float minSpeed, const float maxAcc,
45 const float minAcc,const float maxDispWheelAngle,std::vector<osg::MatrixTransform*> *const pWheelsVec,
46 const float wheelR,Lights *const pLights,const osg::Vec3 &carDirection,const osg::Vec3 &carNormal,
47 const osg::Vec3 &carPositionOnRoad,vrecko::EnvironmentObject *const pFutureCarEOownerToSet);
48 ~CarExecutionUnit();
49
50 void preInitialize(void);
51 void update(void);
52
53 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
54 protected:
55 CarState carState;
56 float vPrevious;
57
58 float maxSpeed;
59 float minSpeed;
60 // maximalni uhel zobrazovaneho zatoceni kol
61 float maxDispWheelAngle;
62
63 // aby zobrazene natoceni kol melo vetsi setrvacnost a nesekalo se tolik,
64 // budou se zobrazena kola natacet (kolem normaly auta) o uhel,
65 // ktery je vazenym prumerem skutecneho
66 // natoceni kol v tomto snimku a dosavadniho natoceni kol pro zobrazeni;
67 // natoceni kol pro zobrazeni bude mit (0.25/lastFrameLength)*vetsi vahu nez skutecne natoceni kol;
68 // kde t je cas, ktery trval posledni snimek, takze cim pomalejsi
69 // simulace bude, tim mensi bude setrvacnost
70
71 // jestlize je vetsi nez maxDispWheelAngle, bude maxDispWheelAngle
72 // jestlize je mensi nez -maxDispWheelAngle, bude -maxDispWheelAngle
73 // (velke uhly by nepusobily prirozene);
74 float wheelDisplayAngleAroundNormal;
75
76 // uhel natoceni kol podle osy normala^smer auta, bude vzdy v rozmezi [0,2PI)
77 float wheelRotateAngle;
78
79 // polomer kola, pro jednoduchost bude uvazovat, ze ji budou mit vsechna kola stejnou
80 float wheelR;
81
82 // v tomto odkazovanem vektoru budou ukazatele na transformace s koly auta
83 // (postupuje se zleva doprava a odpredu dozadu)
84 std::vector<osg::MatrixTransform*> *const pWheelsVec;
85 // matice kol, ktera urcuji jejich pocatecni rozestaveni
86 // (v ramci lokalniho souradneho systemu auta)
87 std::vector<osg::Matrix> wheelsInitMatrixVec;
88
89 // zde jsou ukazatale na transforamce svetel auta, prvni jsou predni svetla,
90 // pak brzdova svetla a nakonec blinkry - nejdriv levy, pak pravy
91 Lights *const pLights;
92
93 // stavy svetel
94 unsigned int frontLightState;
95 unsigned int brakeLightState;
96
97 // faze blinkeru;
98 // uplynuly cas od zacatku posledniho bliknuti blinkru;
99 // jestlize jsou blinkry ve stavu LIGHT_TURNED_OFF, muze obsahovat
100 // hodnotu z drivejsi doby, kdy byl jeste nejaky blinkr zapnuty
101 float timeFromLastBlinkStart;
102
103 // zda vzniklo auto pomoci generatoru
104 const bool isGenCar;
105
106 // zde budou ulozeny cesty k souborum s castmi geometrie auta (bude mit
107 // vyznam jen u negenerovanych aut)
108 GeometryPartsPath *const pGeometryPartsPath;
109
110 // pozice levych kol relativne vzhledem ke stredu auta (odpredu dozadu,
111 // ma vyznam pouze u generovanych aut)
112 std::vector<osg::Vec3> *const pLeftWheelsPosVec;
113
114 // tato metoda otestuje korektnost vstupnich parametru
115 // z XML souboru
116 void checkXMLparameters();
117
118 // metoda nastavi smer auta, natoci podle nej EO auta a urci docasnou
119 // normalu auta (metoda pocita s tim, ze pocatecni spravna normala
120 // jeste nebyla urcena)
121 void initDirection(const osg::Vec3 &dir);
122
123 // metoda nastavi normalu auta, natoci podle ni EO auta
124 // (metoda pocita s tim, ze pocatecni smer auta uz byl urcen)
125 void initNormal(const osg::Vec3 &normal);
126
127 // vypocita novy stav auta (aktualizuje hodnoty v carState a hodnoty
128 // s tim spojene)
129 void computeCarState(const float lastFrameLength);
130
131 // metoda prepne svetlo (predni, brzdove nebo blinkry) do pozadovaneho stavu
132 void switchLight(const unsigned int lightType,const unsigned int lightState);
133
134 // metoda, ktera zjisti, v jake fazi se nachazi zapnuty blinkr (levy nebo pravy
135 // nebo oboje); jestlize ma nejaky blinkr svitit a doposud byl zhasnuty,
136 // rozsviti ho a naopak jestlize ma byt nejaky blinkr zhasnuty a doposud svitil,
137 // zhasne ho; blinkry by nemely byt ve stavu LIGHT_TURNED_OFF, sice metoda nic
138 // zavazneho neudela, ale neni to prilis optimalni;
139 // faze blinkeru jsou dve - zapnuto (timeFromLastBlinkStart in [0,0.5*BLINK_LENGTH],
140 // vypnuto (timeFromLastBlinkStart in (0.5*BLINK_LENGTH,BLINK_LENGTH) )
141 void blink(const float lastFrameLength);
142
143 // jestlize auto nevzniklo generovanim, nacte tato metoda geometrie casti auta
144 // ze souboru (auto bez kol, kolo, svetla)
145 void loadGeometryParts();
146
147
148 DECLARE_INPUT(InAcc, vrecko::MessageFloat);
149 DECLARE_INPUT(InWheelAngle, vrecko::MessageFloat);
150 DECLARE_INPUT(InStop, vrecko::MessageVoid);
151 DECLARE_INPUT(InUpdate, vrecko::MessageFloat);
152 DECLARE_INPUT(InInitNormal, vrecko::MessageVec3);
153 DECLARE_INPUT(InInitDirection, vrecko::MessageVec3);
154 DECLARE_INPUT(InInitPosition, vrecko::MessageVec3);
155 DECLARE_INPUT(InSetCarNormal, vrecko::MessageVec3);
156 DECLARE_INPUT(InPushCarInNormalDir, vrecko::MessageFloat);
157 DECLARE_INPUT(InPushCarInDirectionCrossNormalDir, vrecko::MessageFloat);
158 DECLARE_INPUT(InSetBlinker, vrecko::MessageUnsignedInt);
159 DECLARE_INPUT(InShow, vrecko::MessageVoid);
160 DECLARE_INPUT(InHide, vrecko::MessageVoid);
161
162
163 DECLARE_REQUEST_INPUT(InGetCarState, vrecko::MessageVoid, MessageCarStatePtr);
164 DECLARE_REQUEST_INPUT(InGetCarLength, vrecko::MessageVoid, vrecko::MessageFloat);
165
166 };
167
168 }
169
170 #endif
171
172
173
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarPartsNodeCache.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CarPartsNodeCache.h
Go to the documentation of this file.
1 #ifndef CAR_PARTS_NODE_CACHE
2 #define CAR_PARTS_NODE_CACHE
3
4 #include <vrecko/IOPins.h>
5 #include <vrecko/Message.h>
6 #include <vrecko/Ability.h>
7 #include <map>
8 #include <string>
9 #include <osg/Node>
10
11 namespace CarSim {
12 // abilita, ktera zjisti, zda-li se nejaky soubor s geometrii casti auta
13 // uz drive nenacetl; jestlize ano, vrati se pouze ukazatel na
14 // nacteny Node
15 class CarPartsNodeCache: public vrecko::Ability {
16 public:
17 CarPartsNodeCache();
18 ~CarPartsNodeCache();
19 // void *processRequest(const std::string &input_name, void *value);
20 protected:
21 // (delete ukazatel_na_Node nejde zavolat, protoze destruktor je protected
22 // -> pouzivam ref_ptr)
23 std::map<std::string,osg::ref_ptr<osg::Node>> carPartsPathNodeMap;
24
25 DECLARE_REQUEST_INPUT(InGetCarPartNode, vrecko::MessageString, vrecko::MessageNode);
26 };
27
28 }
29
30 #endif
31
32
33
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/AP_Filter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
AP_Filter.h
Go to the documentation of this file.
1 //#include <vrecko/Ability.h>
2 //
3 //#include <vreckoAP/Export>
4 //
5 //#define INSTANCE
6 //#define LIST
7 //
9 //#include "Linear.h"
11 //
12 //
13 //extern "C" AP_EXPORT const char **Filter_getAbilityList(void);
14 //extern "C" AP_EXPORT Ability *Filter_getAbilityInstance(const char *_name);
15 //extern "C" AP_EXPORT const char *Filter_getAbilityDescription(const char * name);
16 //extern "C" AP_EXPORT const char *Filter_getPluginDescription(void);
17 //extern "C" AP_EXPORT void Filter_initializeAttributesDescription() {}
18 //
19 //
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/CarState.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
CarState.h
Go to the documentation of this file.
1 #ifndef CAR_STATE
2 #define CAR_STATE
3
4 // tento koeficient urcuje, jak moc bude kopec auto zrychlovat
5 // nebo zpomalovat
6 #define HILL_ACC_COEF 3.0
7
8 // prumerna delka auta
9 #define AVERAGE_CAR_LENGTH 5.0
10 // maximalni sirka auta, mela by byt asi polovina prumerne delky auta
11 #define MAX_CAR_WIDTH 3.0
12
13 #define MAX_CAR_LENGTH 10.0
14
15 // prumerne zpomaleni aut za normalni situace;
16 // auto bude zpomalovat vzdy zpomalenim AVERAGE_CAR_DEC, aby se nestavalo, ze by auto
17 // se slabsim brzdami nabouralo do auta se silnejsim brzdami (maximalni
18 // zpomaleni bude pouzito mozna v budoucnu u krizovych situaci); minAcc
19 // bude muset byt u aut aspon 2*AVERAGE_CAR_DEC (a mene); auto bude vzdy zrychlovat
20 // polovinou maximalni miry zrychleni, maximalni mira zrychleni bude
21 // pouzita v budoucnu u predjizdeni
22 #define AVERAGE_CAR_DEC -3.0
23
24 // konstanta k prevodu uhlu otoceni smeru auta na uhel natoceni kol
25 #define WHEEL_ANGLE_CONST 3.0
26
27 // stavy svetel:
28 // pro vsechna svetla:
29 #define LIGHT_TURNED_ON 1
30 // vypnuti svetla (nebo nastaveni pocatecniho stavu svetla)
31 #define LIGHT_TURNED_OFF 2
32 // pouze pro blinkry:
33 #define LEFT_BLINKER_TURNED_ON 3
34 #define RIGHT_BLINKER_TURNED_ON 4
35
36 #include <osg/Vec3>
37
38 namespace CarSim {
39
40 struct CarSize {
41 float height;
42 float length;
43 float width;
44 };
45
46 struct CarState {
47 //zrychleni, ktere by vozidlo melo na rovne vozovce
48 float acc;
49 // rychlost auta
50 float v;
51 // natoceni kol (podle osy normaly auta),
52 // zaporne znaci zatoceni doprava, kladne doleva
53 float wheelAngle;
54 // pozice ve stredu auta
55 osg::Vec3 position;
56 // pozice auta v jeho spodni casti (stred spodni steny
57 // kvadru, ktery obklopuje auto)
58 osg::Vec3 bottomCarPosition;
59 // smer auta
60 osg::Vec3 direction;
61 // normala auta nebo take vyskovy vektor auta
62 osg::Vec3 normal;
63 // maximalni mozne zrychleni auta
64 float maxAcc;
65 // maximalni mozne zpomaleni auta
66 float minAcc;
67 // zda auto stoji (zda se zatahla rucni brzda)
68 bool stoped;
69 // velikost auta
70 CarSize carSize;
71 // draha urazena v poslednim snimku auta
72 float distFromLastFrame;
73 // stav blinkru (bude ho potrebovat CCU)
74 unsigned int blinkLightState;
75 };
76
77 }
78
79 #endif
80
81
82
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CatmullRomInterpolator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
CatmullRomInterpolator.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Interpolator.h"
4
5 class CatmullRomInterpolator : public Interpolator
6 {
7 public:
9 META_DAObject(CatmullRomInterpolator, "Catmull-Rom Interpolator")
10
11 virtual Vec3ArrayPtr interpolate( const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed);
12
14 osg::Vec3 interpolatePoint( const double& t, const osg::Vec3& p0, const osg::Vec3& p1, const osg::Vec3& p2, const osg::Vec3& p3 );
15 };
16
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CentreObjectManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
CentreObjectManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Timer>
4
5 using namespace vrecko;
6
7 namespace behindO {
8
9 class CentreObjectManipulator: public Ability {
10 public:
11 CentreObjectManipulator();
12 ~CentreObjectManipulator() {};
13
14 void processEvent(const std::string &input_name, void *value);
15
16 void postInitialize(void);
17
18 void update(void);
19
20 protected:
21 EnvironmentObject *focus_area;
22 EnvironmentObject *focusing_marker, *located_object;
23 int control;
24 std::map<double, EnvironmentObject*> score_map;
25 // 1 - only ray, 2 - extent, ray
26 unsigned int version;
27 osg::Timer timer;
28 osg::Timer_t last_tick;
29
30 EnvironmentObject* owner;
31 Ability *pAHMDHeadManipulator, *pAHeadManipulator, *pAManipulator;
32 };
33
34 }
35
36 //$Id: CentreObjectManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ChangeOfVisibility.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
ChangeOfVisibility.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/MatrixTransform>
4
5 using namespace vrecko;
6
7 namespace behindO {
8
9 class ChangeOfVisibility: public Ability {
10 public:
11 ChangeOfVisibility();
12 ~ChangeOfVisibility() {};
13
14 // ------ BaseClass functions ------------------------
16 void processEvent(const std::string &input_name, void *value);
17 // ---------------------------------------------------
18
19 void update(void);
20
21 protected:
22 int control;
23 std::vector<EnvironmentObject *> wire_object_map;
24
25 bool continuous_selection, wireframe;
26 float transparency;
27 osg::Vec3 selection_point[2], box_size;
28
29 osg::MatrixTransform *pSelectionBox;
30 EnvironmentObject *border_object;
31
32 void createBorder(void);
33 };
34
35 }
36
37 //$Id: ChangeOfVisibility.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessBoard.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • games
ChessBoard.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vrecko/EnvironmentObject.h>
4
5
6 using namespace vrecko;
7
8
9 class ChessBoard: public Ability {
10 public:
11 ChessBoard();
12 ~ChessBoard() {};
13
15 void processEvent(const std::string &input_name, void *value);
16
17 void update(void);
18
19 std::string getAcceptableMessages(void) {return "ChessMove|AddChessPiece|MoveDone";}
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22
23 typedef struct {
24 std::string type, location;
25 osg::Vec3 new_position;
26 } Request;
27
28 protected:
29 FILE *chess_pipe;
30 bool status, play, color; // color - 0=black, 1=white
31 unsigned int wait;
32 bool generate_board;
33 float square_size;
34 osg::Vec3 a1pos;
35
36 // pointers to geometries of chesspieces
37 osg::Node *WRook, *WKnight, *WBishop, *WQueen, *WKing, *WPawn;
38 osg::Node *BRook, *BKnight, *BBishop, *BQueen, *BKing, *BPawn;
39
40 std::map<std::string, long int> pieces_map; // [location, EObject ID]
41
42 int pfd_to[2], pfd_from[2]; // Pipe file descriptors
43 osg::Vec3 white_out_pos, black_out_pos;
44
45 bool _first;
46 };
47
48
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/games/ChessPiece.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • games
ChessPiece.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 using namespace vrecko;
4
5
6 class ChessPiece: public Ability {
7 public:
8 ChessPiece();
9 ~ChessPiece() {};
10
12 void processEvent(const std::string &input_name, void *value);
13
14 void update(void);
15
16 void preInitialize() {owner = (EnvironmentObject*)pOwner;}
17
18 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
19
20 std::string getAcceptableMessages(void) {return "ChessMove";}
21
22 // -------------------
23 void setType(std::string _type) {piece_type = _type;}
24 void setLocation(std::string _location) {piece_location = _location;}
25
26 protected:
27
28 std::string piece_type, piece_location;
29
30 long int chessboard_id;
31 unsigned int move;
32 osg::Vec3 final_position, actual_position, move_step;
33 EnvironmentObject* owner;
34 };
35
36
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/ClampFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
ClampFilter.h
Go to the documentation of this file.
1 #ifndef CLAMP_FILTER_H
2 #define CLAMP_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to limit the force size. */
11 class ClampFilter : public PHANToMFilter {
12 public:
13 ClampFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 float fMaxForce;
21 float fMaxTorque;
22 };
23
24 }
25
26 #endif
27
28
29 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Cloth.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Cloth.h
Go to the documentation of this file.
1 #ifndef Cloth_h
2 #define Cloth_h
3
4 #include "UpdatablePhysXObject.h"
5 #include "ClothDrawable.h"
6 #include "CoreActorDesc.h"
7
8 #include <vector>
9
10 using namespace vrecko;
11
12 namespace PhysXPlugin
13 {
14 class Cloth: public UpdatablePhysXObject
15 {
16 private:
17 public:
18 Cloth():UpdatablePhysXObject("Cloth")
19 {
20 _scale.x = 1.0f;
21 _scale.y = 1.0f;
22 _scale.z = 1.0f;
23
24 _offset.x = 0.0f;
25 _offset.y = 0.0f;
26 _offset.z = 0.0f;
27 }
28
29 virtual ~Cloth(){}
30
31 virtual void Create();
32
33 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
34
35
36 protected:
37 ClothDrawable* _pClothDrawable;
38
39 NxCloth* _pCloth;
40 NxClothMesh* _pClothMesh;
41 NxMeshData _meshData;
42 NxClothDesc _clothDesc;
43 NxClothMeshDesc _clothMeshDesc;
44
45 CoreActorDesc _coreActorDesc;
46
47 NxVec3 _scale;
48 NxVec3 _offset;
49
50 std::vector<unsigned long> _attachment_ids;
51
52 std::string _fileName;
53
54 virtual void UpdateEnvironmentObject();
55 };
56 }
57
58 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ClothDrawable.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
ClothDrawable.h
Go to the documentation of this file.
1 #ifndef ClothDrawable_h
2 #define ClothDrawable_h
3
4 #include <gl/glut.h>
5 #include <osg/Drawable>
6 #include <osg/Vec3>
7 #include "NxPhysics.h"
8 #include "Cloth.h"
9 #include "Helper.h"
10 #include <cloth/NxCloth.h>
11
12
13 using namespace vrecko;
14
15 namespace PhysXPlugin
16 {
17 class ClothDrawable : public osg::Drawable
18 {
19 friend class Cloth;
20 private:
21
22 NxCloth* _pCloth;
23 NxMeshData _meshData;
24
25
26 protected:
27
28
29
30 void PCloth(NxCloth* val) { _pCloth = val; }
31
32 ClothDrawable& operator = (const ClothDrawable&) { return *this;}
33
34
35
36
37 public:
38 ClothDrawable()
39 {
40 this->setSupportsDisplayList(false);
41 }
42
43 ClothDrawable (NxCloth* pCloth)
44 {
45 glEnableClientState(GL_VERTEX_ARRAY);
46 glEnableClientState(GL_NORMAL_ARRAY);
47 _pCloth = pCloth;
48 _meshData = _pCloth->getMeshData();
49 this->setSupportsDisplayList(false);
50 dirtyBound();
51 }
52
53 virtual ~ClothDrawable(){}
54
55
56 ClothDrawable(const ClothDrawable& drawable,const osg::CopyOp& copyop=osg::CopyOp::SHALLOW_COPY):
57 Drawable(drawable,copyop)
58 {}
59
60 virtual osg::Object* cloneType() const { return new ClothDrawable(); }
61
62 virtual osg::Object* clone(const osg::CopyOp& copyop) const { return new ClothDrawable(*this,copyop); }
63
64
65 // test purpose only. Predelat na dynamicky VBO
66 virtual void drawImplementation(osg::RenderInfo& renderInfo) const
67 {
68
69 glVertexPointer(3, GL_FLOAT, 0, _meshData.verticesPosBegin);
70 glNormalPointer(GL_FLOAT, 0, _meshData.verticesNormalBegin);
71
72 glDrawElements(GL_TRIANGLES, *_meshData.numIndicesPtr, GL_UNSIGNED_INT, _meshData.indicesBegin);
73 }
74
75 virtual void Update()
76 {
77 dirtyBound();
78 }
79
80
81
82
83
84 virtual bool isSameKindAs(const osg::Object* obj)const {return dynamic_cast<const ClothDrawable*>(obj)!=NULL;}
85 virtual const char* libaryName() const {return "PhysX";} //pak zmenit
86 virtual const char* className() const {return "ClothDrawable";}
87
88
89
90 virtual osg::BoundingBox computeBound() const
91 {
92 NxBounds3 Nxbbox;
93 _pCloth->getWorldBounds(Nxbbox);
94
95 osg::BoundingBox bbox;
96 bbox.expandBy(ToosgVec3(Nxbbox.min));
97 bbox.expandBy(ToosgVec3(Nxbbox.max));
98
99 return bbox;
100 }
101
102 };
103 }
104
105 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud2DPlacement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Cloud2DPlacement.h
Go to the documentation of this file.
1
11 #ifndef _VRECKO_CLOUDS_CLOUD2DPLACEMENT_H
12 #define _VRECKO_CLOUDS_CLOUD2DPLACEMENT_H
13
20 class PseudoRand2DPlacement
21 {
22 public:
23
24 // Attributes
25 int gridUnitSizeX, gridUnitSizeY, gridUnitSizeZ,
26 gridUnitHalfSizeX, gridUnitHalfSizeZ;
27
28 // Constructor
29 PseudoRand2DPlacement() : gridUnitSizeX(0), gridUnitSizeY(0), gridUnitSizeZ(0),
30 gridUnitHalfSizeX(0), gridUnitHalfSizeZ(0) {}
31
32 // Methods
33
40 void SetGridUnitSizeXYZ(int x, int y, int z);
41
52 void GetRandPosition(int gridX, int gridY, int gridZ, int *posX, int *posY, int *posZ, int radius = 0) const;
53
60 float Noise1D(int x, int y) const;
61 };
62
63 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Cloud.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Cloud.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_CLOUD_H
10 #define _VRECKO_CLOUDS_CLOUD_H
11
12 #include <osg/Vec4>
13 #include <osg/Geometry>
14 #include <osg/Texture2D>
15
16 #include <iostream>
17 #include <vector>
18 #include <algorithm>
19 #include <queue>
20 #include <set>
21 #include <cmath>
22
23 #include "BoundingVol.h"
24
25 #ifndef PI
26 #define PI 3.1415926535
27 #endif
28
32 struct CloudSceneInfo
33 {
34 int screenWidth, screenHeight;
35 double Fovy, Aspect, Near, Far;
36 };
37
41 struct SunLight
42 {
43 osg::Vec4f ambientLight,
44 sunColor;
45 osg::Vec3f position;
46 };
47
51 struct Particle
52 {
53 float size;
54 osg::Vec3f position;
55 osg::Vec4f color;
56 };
57
61 struct CloudParticle : public Particle
62 {
63 float distToCam;
64 float render_cloud_tex_u1, render_cloud_tex_v1,
65 render_cloud_tex_u2, render_cloud_tex_v2;
66 };
67
71 class Cloud
72 {
73 public:
74 AABoundingBox boundingBox; // Bounding box (sphere, actually) of the cloud
75 std::vector<CloudParticle> cloudParticle; // Contains all of the cloud's particles
76 private:
77
78 float distToCam;
79 bool screenImpostor; // Indicates whether the camera is in the cloud and impostor is rendered on the whole screen
80
81 osg::ref_ptr<osg::Geometry> cloudGeometry; // Cloud geometry itself, contains all of the particles and is connected to the scene graph
82 osg::ref_ptr<osg::StateSet> cloudState; // State of the cloud
83
84 osg::Vec3f center; // Contains position of the center of the cloud (a vector used as a point in 3D)
85 osg::Vec3f last_cam;
86 osg::Vec3f right, up;
87
88 static osg::Vec3f cameraPosition, cameraView, cameraUp; // Current camera data
89 static osg::Matrix viewMatrix; // Curent view matrix
90
91 static osg::ref_ptr<osg::Texture2D> cloudParticleTexture; // Texture with cloud particles
92
93 // Lighting related attributes
94 static const int SplatBufferSize;
95 static float Albedo;
96 static float Extinction;
97 static float Alpha;
98 static SunLight sunLight;
99 static unsigned int lightTexture;
100
101 // Priority queue and cloud update related attributes
102 static std::priority_queue<Cloud *, std::vector<Cloud *> > cloudQueue;
103 static std::vector<Cloud*> cloudVector;
104 static std::set<Cloud*> inQueueSet;
105 static unsigned int maxUpdatesParFrame;
106 static float translateErrorTolerance;
107
108 static CloudSceneInfo sceneInfo; // Contains the information about the scene and projection - view struct CloudSceneInfo
109
110 public:
111 Cloud() { screenImpostor = false; }
112
116 void CalculateBoundingBox(void);
117
122 void ComputeUpRightVectors();
123
128 void LightCloud(void);
129
133 void RegularUpdate();
134
140 void InitCloudGeometry(osg::ref_ptr<osg::Geometry> cloudGeometry);
141
145 void UpdateCloudLotRocScale();
146
150 void UpdateCloudColor();
151
155 void UpdateCloud();
156
160 void Delete(void);
161
162 // Set methods
163 static void SetSunLight(SunLight& sun) { sunLight = sun; }
164 void SetLastCam(osg::Vec3f last_cam) { this->last_cam = last_cam; }
165
166 // Static methods
167
172 static void GenerateLightTexture(void);
173
177 static void DestroyLightTexture(void);
178
185 static bool AddToQueue(Cloud* cloudToUpdate);
186
190 static void RealizeQueue(void);
191
192 static void SetTranslateErrorTolerance(float tolerance) { translateErrorTolerance = abs(cos(tolerance/180*3.1415926f)); }
193 static void SetMaxCloudUpdates(unsigned int max) { maxUpdatesParFrame = max; }
194 static void SetSceneInfo(const CloudSceneInfo& info) { sceneInfo = info; }
195
196 static void SetCloudParticleTexture(osg::ref_ptr<osg::Texture2D> newCloudParticleTexture) { cloudParticleTexture = newCloudParticleTexture; }
197
205 static void SetCamera(const osg::Vec3f& newCameraPosition, const osg::Vec3f& newCameraView, const osg::Vec3f& newCameraUp);
206 static void SetViewMatrix(const osg::Matrix& newViewMatrix) { viewMatrix = newViewMatrix; }
207
208 public:
209 // Functors
210 class ParticleAwayComparison
211 {
212 public:
213 bool operator () (CloudParticle particle1, CloudParticle particle2)
214 {
215 return particle1.distToCam < particle2.distToCam;
216 }
217 } SortAway;
218 };
219
220 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Clouds.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Clouds.h
Go to the documentation of this file.
1
12 #ifndef _VRECKO_CLOUDS_CLOUDS_H
13 #define _VRECKO_CLOUDS_CLOUDS_H
14
15 #include <vrecko/Ability.h>
16
17 #include <osg/Vec2>
18 #include <osg/Vec4>
19
20 namespace APClouds {
21
26 class Clouds : public vrecko::Ability {
27 public:
31 Clouds();
32
36 virtual ~Clouds();
37
41 virtual void preInitialize(void);
42
46 virtual void postInitialize(void);
47
53 virtual void processEvent(const std::string &input_name, void *value);
54
59 virtual void update();
60
66 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
67
73 virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
74
75 protected:
79 void AddSkybox();
80
84 void AddGround();
85
89 void AddSun();
90 };
91
92 }
93
94 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/CloudsManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
CloudsManager.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_CLOUDSMANAGER_H
10 #define _VRECKO_CLOUDS_CLOUDSMANAGER_H
11
12 #include "cloud.h"
13 #include "Cloud2DPlacement.h"
14
15 extern bool g_Anisotropic_scattering;
16 extern bool g_MultipleForwardScattering;
17
22 struct CloudsProperties
23 {
24 // Contains the sun properties
25 SunLight sun;
26 bool sunShow;
27
28 // Number of clouds in the scene
29 unsigned int numOfClouds;
30
31 // Scale of the clouds
32 float scale;
33
34 // CloudGrowth - half-axis of the ellipsoid from which the cloud is generated (all three coordinates)
35 // CloudGrowthRand - pseudo random numbers from the interval <0, CloudGrowthRand - 1> are added to the CloudGrowth
36 // to increase the randomness
37 // GrowthSimulationSteps - number of simulation steps
38 // GrowthSimulationStepsRand - pseudo random number from the interval <0, GrowthSimulationStepsRand - 1> is added
39 // to the GrowthSimulationSteps to increase the randomness
40 unsigned int CloudGrowth[3], CloudGrowthRand[3],
41 GrowthSimulationSteps, GrowthSimulationStepsRand;
42
43
44 // Position of the block in which the clouds are located
45 int CloudFlatAreaPosition[3];
46 // Dimensions of the block in which the clouds are located
47 unsigned int CloudFlatAreaSize[3];
48
49 // Path to the cloud texture
50 std::string renderCloudTexturePath;
51
52 // maxCloudUpdatesParFrame - maximum number of clouds updated in one frame
53 // translateErrorTolerance - error tolerance
54 unsigned int maxCloudUpdatesParFrame;
55 float translateErrorTolerance;
56
57 // loadFromFile - Indicates if the scene is loaded from files and not generated from parameters
58 // saveToFile - Indicates if the scene is saved to files afterwards
59 bool loadFromFile, saveToFile;
60
61 // Skybox properties
62 bool skyboxShow; // Indicates if the skybox should be used
63 long skyboxSize; // Length of the skybox cube edge
64 long skyboxCenterPosition[3];
65 std::string skyBoxTexturePathTop;
66 std::string skyBoxTexturePathNorth;
67 std::string skyBoxTexturePathSouth;
68 std::string skyBoxTexturePathWest;
69 std::string skyBoxTexturePathEast;
70
71 // Ground properties
72 bool groundShow;
73 long groundCenterPosition[3];
74 std::string groundTexturePath;
75 };
76
81 class CloudsManager
82 {
83 public:
84 std::vector<Cloud> clouds;
85
86 CloudsProperties properties;
87 CloudSceneInfo sceneInfo;
88 PseudoRand2DPlacement flatLayer;
89 public:
90 CloudsManager() {}
91 ~CloudsManager() { this->Delete(); }
92
96 void LoadAndInitiate(void);
97
103 void SetUVCoords(bool singleTexture = false);
104
112 void Update(const osg::Vec3f& cameraPosition, const osg::Vec3f& cameraView, const osg::Vec3f& cameraUp);
113
119 int SaveToFile(void);
120
128 int LoadFromFile(void);
129
133 void Delete(void);
134 };
135
136 extern CloudsManager g_Clouds;
137
138 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HapticCollisionApp/CollisionAppController.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • HapticCollisionApp
CollisionAppController.h
Go to the documentation of this file.
1 #include <vreckoDP/PHANToM/PHANToM_Device.h>
2
3
4 #ifdef COMPILE_PHANTOM_DEVICE
5
6
7 #include <vrecko/Ability.h>
8 #include <vrecko/EnvironmentObject.h>
9
10
11 using namespace vrecko;
12
13 namespace APHapticCollisionApp {
14
15 class CollisionAppController: public Ability {
16 public:
17 CollisionAppController();
18 ~CollisionAppController();
19
20 virtual void preInitialize();
21 virtual void postInitialize();
22 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
23 virtual void update(void);
24 virtual void *processRequest(const std::string &name, void *data);
25 void processObjectSwitch(bool bRelease);
26 // [bRelease] == true -> we should release the currently held objects
27 protected:
28 void checkOrCreateStructsForObject(unsigned int objectID);
29
30 void simpleAbilityAddAndInit( EnvironmentObject * obj, vrecko::Ability * pAbility);
31
32 // Automatically creates (if desired)
33 // - MTMatrixTransform
34 // - PointShell
35 // - SNCH
36
37 bool bAutoCreatePS; // Create PointShell automatically for grabbed objects
38 bool bAutoCreateSNCH; // Create SNCH hierarchy automatically for grabbed objects
39
40 bool bGhosting; // Create shadow objects to show real phantom position (in addition to the simulated position)
41
42 bool graspNewObjectUsingCollisions(vreckoDP_PHANToM::PHANTOM_HELD_OBJECTS_ARRAY *heldObjects, osg::Matrix* heldObjInverseTransform);
43 // Resolves collisions, updates [heldObjects] if necessary and returns "true" if any changes
44 // has been performed.
45
46 bool graspNewObjectUsingDistances(vreckoDP_PHANToM::PHANTOM_HELD_OBJECTS_ARRAY *heldObjects, osg::Matrix* heldObjInverseTransform);
47 // Checks for any nearby graspable objects and updates [heldObjects].
48 // Returns "true" if any changes ahve been performed.
49 };
50
51 }
52
53 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionFilterBase.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionFilterBase.h
Go to the documentation of this file.
1 #ifndef COLLISION_FILTER_BASE_H
2 #define COLLISION_FILTER_BASE_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8
9 #if 0
10 #define PH_LOG_WRITECOUNTER(name, value) logger.writeBMCounter(name, value)
11 #else
12 #define PH_LOG_WRITECOUNTER(name, value) {}
13 #endif
14
15
16
17 namespace vreckoDP_PHANToM {
18
19
20 class CollisionFilterBase : public PHANToMFilter {
21 public:
22 CollisionFilterBase(const char* abName);
23 ~CollisionFilterBase() {};
24
25 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
26
27 enum ForceCalcType {
28 // Probably in the order of complexity. The first ones may not support all features
29 // (such as negative distances, torque, multiple objects handling etc.)
30
31 // This group is basically obsolete - no support for negative distances, torque or object sub-transforms (i.e. multiple held objects)
32 SimpleAverage, // average the forces
33 WeightedAverage, // average the forces, but give priority to the stronger ones
34 LargestOnly, // ONLY the largest force
35 SumAndClip, // Sum all the forces, clip to the largest one
36 // Methods below add support for negative distances and torque (which is calculated even for multiple objects),
37 // ignoring the held objects in intra-collision
38 SumNoClip, // Sum the forces, no clipping
39 SumByVoxels, // [NOT WORKING YET] (Similar to SumNoClip) Assume that the forces are generated using a VoxelGrid
40 // -> i.e. get the size of the VoxelGrid cell and calculate each force using this information
41 Envelope, // Create an envelope of the contact forces and use it to calculate the final one
42 };
43
44 bool collisionsToForce(ForceCalcType calcType, CollisionParams *params, COLLISIONS_INFO_VECTOR *colInfo, osg::Vec3 *force, osg::Vec3 *torque, bool *bIntersection);
45 // Converts collision pairs into the force and torque.
46
47 protected:
48 struct ForceCalcParams {
49 public:
50 float maxDistance;
51 float maxSingleForce;
52 float maxTotalForce;
53
54 float forceScale;
55 float torqueScale;
56 };
57
58 bool clusterizeContacts(COLLISIONS_INFO_VECTOR *colInfo);
59 string convertInt(int number);
60
61 ForceCalcParams forceCalcParams;
62 };
63
64
65 }
66
67 #endif
68
69 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/CollisionPauseFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
CollisionPauseFilter.h
Go to the documentation of this file.
1 #ifndef COLLISIONPAUSE_FILTER_H
2 #define COLLISIONPAUSE_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 class CollisionPauseFilter : public PHANToMFilter{
11
12 public:
13 CollisionPauseFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 bool paused;
21
22 void pause();
23 void unpause();
24 };
25 }
26
27
28
29 #endif
30 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/ColorBucket.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
ColorBucket.h
Go to the documentation of this file.
1 #ifndef _COLOR_BUCKET_H
2 #define _COLOR_BUCKET_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 // tool to change color of the wall
9 class ColorBucket : public Tool {
10 public:
11 ColorBucket(osg::Vec3 color) {
12 this->color = color;
13 type = COLORBUCKET;
14 }
15
16 virtual ~ColorBucket() {
17 }
18
19 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
20 WG_Wall* curWall,
21 WG_Point* curPoint,
22 PointType type,
23 vrecko::EnvironmentObject* pEOOwner,
24 std::vector<osg::ref_ptr<WG_Wall> >* walls,
25 std::vector<osg::ref_ptr<WG_Point> >* points,
26 osg::Geode* pOSGGeode,
27 osg::Vec3Array* pOSGVertexArray) {
28
29 if (curWall == NULL)
30 return;
31
32 curWall->setColor(color, type);
33 setDirty(true);
34 }
35
36 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
37 if (findXMLNode(pParametersNode, "Color")) {
38 ReaderWriter::getVec3Value(color, pParametersNode, "Color");
39 if (findXMLNode(pParametersNode, "Name")) {
40 ReaderWriter::getStringValue(name, pParametersNode, "Name");
41 } else {
42 name = "ColorBucket";
43 }
44 }
45 else
46 return false;
47 return true;
48 }
49
50 private:
51 osg::Vec3 color;
52 };
53
54 }
55
56 #endif
57
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ColorGenAdapter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ColorGenAdapter.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Referenced>
3 #include "Utils.h"
4 #include "ConstantColorGen.h"
5 #include "GradientColorGen.h"
6 #include "SectorColorGen.h"
7 #include "types.h"
8
9 namespace APDYNAMICART
10 {
11
14 class ColorGenAdapter : public PoAAdapter<ColorGen>
15 {
16 public:
17 ColorGenAdapter() : _colorIndex(0) {}
18 virtual void setColor(const osg::Vec4& color) {}
19 virtual osg::Vec4 getColor() { return osg::Vec4(0.0, 1.0, 0.0, 1.0); }
20
21 int getColorIndex() const { return _colorIndex; }
22 void setColorIndex(int val) { _colorIndex = val; }
23
24 protected:
25 int _colorIndex;
26
27 };
28
30 class ConstantColorAdapter : public ColorGenAdapter
31 {
32 public:
33 ConstantColorAdapter() : _colorGen(new ConstantColorGen) {}
34 ConstantColorAdapter(const osg::Vec4& color)
35 : _colorGen(new ConstantColorGen(color)) {}
36
37 META_DAObject(ConstantColorAdapter, "Constant")
38
39 virtual void createMenu(MenuPtr menu);
40 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
41 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
42 virtual void setColor( const osg::Vec4& color ) { _colorGen->setColorValue(color); }
43 virtual ColorGenPtr getObject() { return _colorGen; }
44
45 virtual osg::Vec4 getColor() { return _colorGen->getColorValue(); }
46
47 protected:
48 osg::ref_ptr<ConstantColorGen> _colorGen;
49 };
50
51
53 class GradientColorAdapter : public ColorGenAdapter
54 {
55 public:
56 GradientColorAdapter() : _colorGen(new GradientColorGen) {}
57 GradientColorAdapter(const osg::Vec4& color1, const osg::Vec4& color2)
58 : _colorGen(new GradientColorGen(color1, color2)) {}
59
60 META_DAObject(GradientColorAdapter, "Gradient")
61
62 virtual void createMenu(MenuPtr menu);
63 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
64 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
65 virtual ColorGenPtr getObject() { return _colorGen; }
66
67 virtual void setColor( const osg::Vec4& color );
68 virtual osg::Vec4 getColor() { return _colorGen->getColorStart(); }
69
70 protected:
71 osg::ref_ptr<GradientColorGen> _colorGen;
72 };
73
74 //NOTE: Disabled due to revision in SectorColorGen class
75
77 //class SectorColorAdapter : public ColorGenAdapter
78 //{
79 //public:
80 // SectorColorAdapter() : _colorGen(new SectorColorGen) {}
81 //
82 // META_DAObject(SectorColorAdapter, "Sector coloring")
83 //
84 // virtual ColorGenPtr getObject() { return _colorGen; }
85 // virtual void setColor( const osg::Vec4& color ) { _colorGen->setDefaultColor(color); }
86 // virtual osg::Vec4 getColor() { return _colorGen->getDefaultColor(); }
87 // virtual void createMenu( MenuPtr menu );
88 // virtual bool sliderChanged( const char* sliderID, float sliderPos );
89 //
90 //protected:
91 // osg::ref_ptr<SectorColorGen> _colorGen;
92 //};
93
96 class ColorGenFactory : public AdapterFactory<ColorGenAdapter>
97 {
98 public:
99 ColorGenFactory()
100 {
101 _adapters.push_back(new ConstantColorAdapter);
102 _adapters.push_back(new GradientColorAdapter);
103 //_adapters.push_back(new SectorColorAdapter);
104 }
105
106 ColorGenFactory( const ColorGenFactory& orig )
107 {
108 //TODO some more generic approach here would be nice
109 // but how to do it?
110
111
112 std::vector<osg::ref_ptr<ColorGenAdapter>> origAdapters = orig.getSupportedAdapters();
113
114 _adapters.push_back(new ConstantColorAdapter(origAdapters[0]->getColor()));
115
116 ColorGen *tmpGen = (origAdapters[1]->getObject()).get();
117 GradientColorGen *tmpGrdGen = dynamic_cast< GradientColorGen *>(tmpGen);
118 _adapters.push_back(new GradientColorAdapter(tmpGrdGen->getColorStart(), tmpGrdGen->getColorEnd()));
119 }
120 };
121
122 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ColorPicker.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
ColorPicker.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4
5 # ifdef GUI_LIBRARY
6 # define GUI_EXPORT __declspec(dllexport)
7 # else
8 # define GUI_EXPORT __declspec(dllimport)
9 #endif
10
11
12
13 namespace APGUI
14 {
15
17
25 class GUI_EXPORT ColorPicker: public GUI_Item
26 {
27 public:
28 ColorPicker();
29 ~ColorPicker();
30
31 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
32
34 bool createVisuals();
35
36 void pointed(bool pointed) { }
37
39
43 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed);
44
45 void setState(GUI_ITEM_STATE newState);
46
47 void update(void);
48
49
50
51
52 protected:
53
55 bool _isActive;
56
58 bool _alwaysInMiddle;
59
60 //visuals
61 float _pickerHeight, _pickerRadius, spheresRadius;
62 osg::Geode* osgGeode;
63
64 //handSphere
65 float handSphereRadius;
66 osg::ShapeDrawable* handShapeDraw;
67 osg::Sphere* handShapeSphere;
68
69 Interconnection* _temporaryInterconnection;
70
71 int _icontoDeactivate;
72
73
74 void createColorSphere(osg::Vec3* pos, float radius, osg::Vec4* colour);
75
77 void evoke();
78 void RGBtoHSL(osg::Vec4* p_source, osg::Vec3* target);
79 void HSLtoPos(osg::Vec3* p_hsl, osg::Vec3* p_pos);
80 void PostoHSL(osg::Vec3* p_pos, osg::Vec3* p_hsl);
81 void HSLtoRGB(osg::Vec3* source, osg::Vec4* target);
82
83
84 osg::Vec3 limitPosition( osg::Vec3 handPosition);
85 bool linesIntersection(osg::Vec3* p_point1, osg::Vec3* p_orientation1, osg::Vec3* p_point2, osg::Vec3* p_orientation2, osg::Vec3* result);
86
88 void revoke();
89
90
91 //for direct evocation of color picker - by key, for example
92 DECLARE_INPUT(Evoke, MessageBool);
93
94 //evoke command from GUI (Icon, e.g.)
95 DECLARE_INPUT(GUIItemClicked, MessageString);
96
97 //direct selection of color - not used at all?
98 DECLARE_INPUT(Select, MessageBool);
99
100 // color picker activated by icon - when color is picked, color picker should set icon to default state
101 DECLARE_INPUT(ExternalDeactivation, MessageObjectID);
102
103 //request for color picker evocation - picked color will be send to given receiver
104 DECLARE_REQUEST_INPUT(EvokeHSLColorPicker, MessageString, MessageBool);
105
106 //selected colour
107 DECLARE_OUTPUT(Colour, MessageVec4);
108
109 //request for hand position - called repeatedly during update()
110 DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3);
111
112
113
114 };
115
116 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/CompositeObject.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
CompositeObject.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include "DynamicScene.h"
3
4 using namespace vrecko;
5
6
7 namespace ode {
8
9 class CompositeObject: public Ability {
10 public:
11 CompositeObject();
12 ~CompositeObject() {};
13
14 void postInitialize(void);
15 void update(void);
16
17 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
18 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
19
20 protected:
21 typedef struct {
22 int _type; // 1 - Cube, 2 - Sphere, 3 - CappedCylinder
23 osg::Vec3 _size;
24 double _radius;
25 double _length;
26 int _direction;
27 double _density;
28 osg::Vec3 _translate;
29 } Data;
30
31 osg::Vec3 translate;
32
33 std::vector<Data *> _data;
34
35 DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid);
36 };
37
38 }
39
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeStrategy.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ComputeStrategy.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Vec3>
3 #include <string>
4 #include <vector>
5 #include <osg\Referenced>
6
7 #include "Parameters.h"
8
9 namespace APDYNAMICART
10 {
12 //Interface
14
15 class IComputeStrategy : public osg::Referenced
16 {
17 public:
18 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params ) = 0;
19 virtual double getDefaultSize() = 0;
20 virtual ~IComputeStrategy() {};
21
22 virtual std::string const AttractorName() = 0;
23 };
24
25 typedef osg::ref_ptr<IComputeStrategy> IComputeStrategyPtr;
26
28 //Strategy classes
30
31 class NullStrategy : public IComputeStrategy
32 {
33 std::string const AttractorName() { return "Null"; }
34
35 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
36 {
37 return osg::Vec3();
38 }
39
40 virtual double getDefaultSize()
41 {
42 return 0.0;
43 }
44 };
45
46 class LorenzStrategy : public IComputeStrategy
47 {
48 std::string const AttractorName() { return "Lorenz"; }
49
50 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
51 {
52 return osg::Vec3(x + params[0].value * params[3].value * (y - x),
53 y + params[3].value * (params[1].value * x - y - z*x),
54 z + params[3].value * (x*y - params[2].value * z));
55 }
56
57 virtual double getDefaultSize()
58 {
59 return 0.5;
60 }
61 };
62
63 class Lorenz84Strategy : public IComputeStrategy
64 {
65 std::string const AttractorName() { return "Lorenz84"; }
66
67 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
68 {
69 return osg::Vec3(x + params[4].value * (-params[0].value*x -y*y - z*z + params[0].value * params[2].value),
70 y + params[4].value * (-y + x*y -params[1].value*x*z + params[3].value),
71 z + params[4].value * (-z + params[1].value*x*y +x*z));
72 }
73
74 virtual double getDefaultSize()
75 {
76 return 1.5;
77 }
78
79 };
80
81 class PickoverStrategy : public IComputeStrategy
82 {
83 std::string const AttractorName() { return "Pickover"; }
84
85 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
86 {
87 return osg::Vec3(sin(params[0].value * y) - z * cos(params[1].value * x),
88 z * sin(params[2].value * x) - cos(params[3].value * y),
89 /*params[4].value * */ sin(x));
90 }
91
92 virtual double getDefaultSize()
93 {
94 return 5.0;
95 }
96
97 };
98
99 class RosslerStrategy : public IComputeStrategy
100 {
101 std::string const AttractorName() { return "Rossler"; }
102
103 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
104 {
105 return osg::Vec3(x - params[3].value * (y + z),
106 y + params[3].value * (params[1].value + (x*y) - (params[2].value*y)),
107 z + params[3].value * (x + (params[0].value*z)));
108 }
109
110 virtual double getDefaultSize()
111 {
112 return 0.1;
113 }
114
115 };
116
117 class PolynomialStrategy : public IComputeStrategy
118 {
119 std::string const AttractorName() { return "Polynomial"; }
120
121 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
122 {
123 return osg::Vec3(params[0].value + y - y*z,
124 params[1].value + z - x*z,
125 params[2].value + x - x*y);
126 }
127
128 virtual double getDefaultSize()
129 {
130 return 1.0;
131 }
132
133 };
134
135 class IkedaStrategy : public IComputeStrategy
136 {
137 std::string const AttractorName() { return "Ikeda"; }
138
139 virtual osg::Vec3 getNextPoint( double x, double y, double z, const Parameters& params )
140 {
141 return osg::Vec3(params[0].value + params[1].value * (x * cos(z) - y * sin(z)),
142 params[1].value * (x * sin(z) + y * cos(z)),
143 params[2].value - params[3].value / (1 + x * x + y * y));
144 }
145
146 virtual double getDefaultSize()
147 {
148 return 2.5;
149 }
150
151 };
152 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ComputeThread.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ComputeThread.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <OpenThreads/Thread>
4 #include "ComputeStrategy.h"
5 #include "Utils.h"
6 #include <random>
7
8 namespace APDYNAMICART
9 {
10
11 struct InitSettings
12 {
13 IComputeStrategyPtr strategy;
14 Parameters params;
15 float size;
16 int settleIterations;
17 int iterationCount;
18 int interpolationSteps;
19 bool randomRun;
20 };
21
22 class ComputeThread : public OpenThreads::Thread, public osg::Referenced
23 {
24
25 public:
27 ComputeThread();
28 virtual void run();
29
30 bool isTooSmall( int i, int iter );
31
32 virtual int cancel();
33
35 void init(const InitSettings& settings);
36 bool getData(osg::Vec3Array* points, osg::Vec4Array* colors, Limits& limits, Parameters& params);
37 void addPoint( osg::Vec3 point );
38 void setColor( osg::Vec4 color, int index );
39 void interpolatePoints();
40
41 protected:
42 bool _dirty;
43 bool _done;
44
45 OpenThreads::Mutex _mutex;
46 Vec3ArrayPtr _points;
47 Vec4ArrayPtr _colors;
48 Limits _lim;
49 InitSettings _conf;
50 static std::tr1::mt19937 eng;
51 osg::Vec3 _initPoint;
52 private:
53 bool isDiverging( osg::Vec3 &point );
54 void createRandomParameters();
55 void computeColors();
56 void computePoints();
57 };
58
59 typedef osg::ref_ptr<ComputeThread> ComputeThreadPtr;
60
61 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cone.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Cone.h
Go to the documentation of this file.
1 #ifndef VF_CONE
2 #define VF_CONE
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Vec4>
7 #include <osg/Geode>
8 #include <osg/MatrixTransform>
9 #include <osg/Group>
10
11 using namespace vrecko;
12 using namespace vreckoDP_base;
13 namespace VirtualFixture{
14
15 class Cone: public PHANToMFilter {
16 public:
17 Cone();
18 ~Cone() {};
19
21 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
22 void processEvent(const std::string &input_name, void *value);
23
24 void preInitialize(void);
25 void postInitialize(void);
26 void update(void);
27
28 void display(void); //show or hide VF_cylinder object
29
30
31 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
32 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
33
34 protected:
35 PHANToM *PHANToMDevice;
36 bool all_on;
37 bool active; //VF switcher
38
39 bool visible; //if geometric representation will be visible
40 osg::MatrixTransform *tnode; //transform node pointer
41 osg::Group *gnode; //group pointer
42 osg::Geode *node; //geometry node pointer (for bouning cylinder)
43 osg::Geode *node2; //geometry node2 pointer (for center cylinder)
44 osg::Vec4 color; //color of border sphere (radius)
45 osg::Vec4 color2; //color of inner sphere (nullradius)
46 float transparency; //border sphere transparency
47 float transparency2;//inner sphere transparency
48
49 osg::Vec3 position; //position of starting point
50 osg::Vec3 vector; //vector on cone axis (from bottom to top)
51 float radius1; //cone radius1 (maximum range of attractive field) at start of cone
52 float radius2; //cone radius2 (maximum range of attractive field) at end of cone
53 float nullradius; //radius close to centre axis, where attractive field is NOT applied
54 float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
55 float pushingforce; //pushing force along the vector
56 bool pushing; //if true push PHANToM along the vector
57 };
58 };
59
60 #endif
61
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/ConnectEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
ConnectEditor.h
Go to the documentation of this file.
1 #ifndef CONNECT_EDITOR_H
2 #define CONNECT_EDITOR_H
3
4 #include <time.h>
5 #include "../EditorController/ControllableAbility.h"
6 #include "functions.h"
7 #include "SnapObject.h"
8 #include "normal.h"
9
10 //#define TIME //print time of functions - for optimalization
11
12
13
14 using namespace vrecko;
15
16 namespace APConnectEditor {
17
18 //class Snap;
19
20 class ConnectEditor: public ControllableAbility
21 {
22 private:
23
24 bool isOptimalized; // at first computation with snapping optimalize objects
25
27 //variables used for XML paramaters
28 bool bApplyConnecting; //connecting
29 bool bApplySnapping; //snapping by icp algorithm
30 bool bNotApplyScaling; //use scaling in icp or not
31
32 SnapObject *target, *source;
33
34
35
36
37
38
39 public:
40 ConnectEditor();
41 virtual ~ConnectEditor() { deactivate(); }
42 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
43
44
45
46 protected:
47 virtual void fillDefaultInfo();
48 virtual bool activate();
49 virtual void deactivate();
50 virtual void processButtonRelease(vrecko::CABUTTONEVENT* eventData); //call method - snap || merge || ...
51 //virtual void menuItemClicked(const char* itemID); //zatim neni potreba snad pozdeji jestli bude potreba dynamickeho menu
52
53
54
56 //My functions
57 bool init();
58 bool snap();
59
60
61
63 //My functions
64 private:
65
66 //function make one ICP iteration and transform object - use translation, scaling and rotation transformation
67 bool icp();//does not apply on object but only on matrix - smaller error to deform mesh
68
69 //transformation - || 0-3 - quaternion of rotation || 4-6 - translation || 7 - scaling
70 void icp_iteration(osg::Vec3Array* targetPoints, osg::Vec3Array* sourcePoints, vector<int> targetSnappingRegion, vector<int> closestPoints, float transformation[8]);
71
72 //start icp - compute only translation and scale
73 void icp_scale(osg::Vec3Array* targetPoints, osg::Vec3Array* sourcePoints, vector<int> targetSnappingRegion, vector<int> sourceSnappingRegion, float transformation[8]);
74 void icp_translate(osg::Vec3Array* targetPoints, osg::Vec3Array* sourcePoints, vector<int> targetSnappingRegion, vector<int> sourceSnappingRegion, float transformation[8]);
75
76 //compute error for icp
77 float computeError(osg::Vec3Array* targetPoints, osg::Vec3Array* sourcePoints, vector<int> targetSnappingRegion, vector<int> closestPoints);
78
79 //get snapping region - find informations and call getSnapRegion with this informations
80 vector<int> getSnappingRegion(SnapObject *browsingObject, SnapObject *colisionObject);
81
82 bool morphObjects();
83 bool connectObjects();
84 void optimalizeEraseLoop(vector<int> &eraseLoop);
85
86 bool testPreConditions();
87
88 };
89
90
91
92
93 } //end APConnectEditor
94
95 #endif //CONNECT_EDITOR_H
96
97
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ConnectionViz.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ConnectionViz.h
Go to the documentation of this file.
1 #ifndef CONNECTIONVIZ_H
2 #define CONNECTIONVIZ_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6 #include <osg/ShapeDrawable>
7 #include <helpers/DynamicArray.h>
8
9 using namespace vrecko;
10
11 namespace APObjectUtils
12 {
13 // Flags for ConnectionViz::Connection::dwFlags and ConnectionViz::createConnection() method
14 #define CVC_F_DEFAULT 0x00000001
15 // Signalizes a default connection
16
17
18 class ConnectionViz: public Ability {
19 public:
20 ConnectionViz();
21 virtual ~ConnectionViz();
22
23 virtual void preInitialize();
24 virtual void postInitialize();
25 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
26 virtual void update();
27 virtual void clean();
28
29 protected:
30 EnvironmentObject *owner;
31
32 bool bOnlyOutput; // show only output connetions
33 bool bColorize; // use nice(?) colors to display the connections
34
35 class Connection {
36 public:
37 Ability *ability;
38
39 enum ConnectionType { Input, Output, InputRequest, OutputRequest };
40 ConnectionType type;
41
42 unsigned long dwFlags; // a combination of CVC_F_*
43
44 std::string pinName; // name of the output/input/request pin
45
46 bool bUsedInUpdate; // auxiliary variable used when updating
47
48 osg::ref_ptr<osg::Cone> shapeCone;
49 osg::ref_ptr<osg::ShapeDrawable> shapeDraw;
50 };
51
52 osg::ref_ptr<EnvironmentObject> graphicObject;
53 osg::ref_ptr<osg::Geode> osgGeode;
54
55 DynamicArray<Connection> cons;
56 /* Creates the specified connection and returns its index (to the [cons] array).
57 It will return -1 in the case of an error.
58 May reuese some of the unused connection, which has [bUsedInUpdate] set to false.
59 The [bUsedInUpdate] will be set to true in this method for the returned connection.
60 [dwFlags] is a combination of CVC_F_* */
61 int createConnection(Connection::ConnectionType cType, const char *sender, const char *receiver, unsigned int dwFlags);
62 void deleteConnection(int iIndex);
63
64 /* Creates the main objects if not created before. */
65 bool createMainObject();
66 };
67
68 }
69
70
71 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/TextOutput/Console.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • TextOutput
Console.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vrecko/EnvironmentObject.h>
3 #include <vrecko/Timer.h>
4
5 #include <osg/Geode>
6 #include <osgText/Text>
7 #include <osgText/Font>
8 #include <osg/BlendFunc>
9 #include <osg/Material>
10 #include <osg/StateSet>
11 #include <osg/Camera>
12
13 #include <vector>
14
15 #define CONSOLE_NO_ANIMATOR
16
17 #include "../ObjectUtils/Animator.h"
18
19
20 // These constants might be also used in the LoadingConsole(.cpp)
21 #define CONSOLE_WINDOW_DEPTH -1000.0f
22
23 #define CONSOLE_BORDER_X_RATIO 0.3f
24 #define CONSOLE_BORDER_Y_RATIO CONSOLE_BORDER_X_RATIO
25 #define CONSOLE_LINE_SPACE_CHAR_RATIO 0.3f
26
27 #define CONSOLE_FONT "fonts/arial.ttf"
28 #define CONSOLE_CHAR_SIZE 15
29
30 #define CONSOLE_TEXTCOLOR_NOTICE (osg::Vec4(1.0f, 1.0f, 1.0f, 1.0f))
31 #define CONSOLE_TEXTCOLOR_WARNING (osg::Vec4(1.0f, 1.0f, 0.0f, 1.0f))
32 #define CONSOLE_TEXTCOLOR_ERROR (osg::Vec4(1.0f, 0.5f, 0.5f, 1.0f))
33 #define CONSOLE_TEXTCOLOR_DEBUG (osg::Vec4(0.3f, 1.0f, 0.3f, 1.0f))
34
35
36
37 using namespace vrecko;
38
39 namespace APTextOutput {
40
41 class Console: public Ability {
42 public:
43 Console();
44 ~Console();
45
46 virtual void preInitialize();
47 virtual void postInitialize();
48 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
49 virtual void update(void);
50
51 void addLine(const char *line, const osg::Vec4 &color = *((osg::Vec4*)NULL));
52
53 protected:
54 class Line {
55 public:
56 osg::ref_ptr<osgText::Text> text;
57 osg::Timer_t logTime; // from osg::Timer::instance()->tick()
58 osg::Timer_t necessaryTime; // time necessary to read (after that it will scroll away)
59 };
60
61 std::vector<Line> lines;
62
63 int viewWidth, viewHeight;
64 int borderXSize, borderYSize, lineSpace;
65 float slideMax;
66
67 osg::Timer_t menuAwayTime; // when we should animate the menu away? (0 = already is away)
68
69 bool bNewItemAdded; // was the new item added (informative variable for te update() method)
70
71 osg::ref_ptr<vrecko::EnvironmentObject> eo;
72 APObjectUtils::Animator *animator;
73 osg::ref_ptr<osg::Camera> camera;
74 osg::ref_ptr<osg::Geode> geode;
75 osg::ref_ptr<osg::Geometry> geom;
76
77 DECLARE_REQUEST_INPUT(Add, MessageString, MessageVoid);
78 };
79
80 }
81
82
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ConstantColorGen.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ConstantColorGen.h
Go to the documentation of this file.
1 #pragma once
2 #include "ColorGen.h"
3
4 class ConstantColorGen : public ColorGen
5 {
6 public:
7 ConstantColorGen() : _color(osg::Vec4(1,1,1,1)) {};
8 ConstantColorGen(const osg::Vec4& color) : _color(color) {};
9
10 META_DAObject(ConstantColorGen, "Constant Brush")
11
12
13 virtual Vec4ArrayPtr getColors( unsigned int leadSplineSize, unsigned int crossSectionSize )
14 {
15 _dirty = false;
16
17 Vec4ArrayPtr result = new osg::Vec4Array;
18 unsigned int arraySize = leadSplineSize * crossSectionSize;
19 result->reserve(arraySize);
20 result->assign(arraySize, _color);
21
22 return result;
23 }
24
25 inline osg::Vec4 getColorValue() const { return _color; }
26 inline void setColorValue(const osg::Vec4& val) { _dirty = true; _color = val; }
27
28 protected:
29 osg::Vec4 _color;
30 };
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstrainedObjectMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
ConstrainedObjectMovement.h
Go to the documentation of this file.
1 #ifndef CONSTRAINED_OBJECT_MOVEMENT_H
2 #define CONSTRAINED_OBJECT_MOVEMENT_H
3
4
5 #include <vreckoAP/EditorController/ControllableAbility.h>
6
7 #include <vrecko/Ability.h>
8 #include <vrecko/EnvironmentObject.h>
9 #include <helpers/DynamicArray.h>
10 #include <osg/Group>
11 #include <osg/ShapeDrawable>
12 #include <osg/Geode>
13 #include "ConstraintHierarchy.h"
14
15 using namespace vrecko;
16
17 namespace APConstrainedMovement {
18
19 #define EPSILON 0.001
20
22 class ConstrainedObjectMovement: public ControllableAbility {
23 public:
24 ConstrainedObjectMovement();
25 virtual ~ConstrainedObjectMovement();
26
27 virtual void update(void);
28
29 protected:
30 ConstraintHierarchyMember *constraintHierarchyRoot;
31
32 virtual CAINFO* createInfo();
33 virtual void fillDefaultInfo();
34
35 virtual bool activate();
36 virtual void deactivate();
37
38 virtual void processButtonPress(CABUTTONEVENT* eventData);
39 virtual void processButtonRelease(CABUTTONEVENT* eventData);
40
41 bool rotating; // Specifier whether the ability is being used for rotation or translation
42
43 osg::Vec3 prevPointerPos; // Pointer position during last update
44
45 osg::Vec3 firstPointerPos; // Pointer position when activated
46 osg::Quat firstPointerRot; // Pointer rotation when activated
47
48 osg::Vec3 firstObjectPos; // Object position when activated
49 osg::Quat firstObjectRot; // Object rotation when activated
50
51 unsigned long movingObjectID; // ID of the object being moved; if this is 0, the ability is inactive
52
53 float firstTransparency; // Object transparency when activated
54
55 bool bFirstUpdate;
56
57
58
59 void issueRequests(bool bStopIfNoSelection);
60
61
62 bool objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans, osg::Vec3 *outTranslationVector);
63 // FIRST PART of the tranformation calculations. From the pointer position/rotation the new object
64 // position/rotation is calculated. The matrix is only calculated and stored in [outTrans].
65 // The transformation will be applied afterwards, after another calculations or adjustments.
66
67 bool applyConstrainedSnapping(EnvironmentObject *eo, osg::Matrix *inoutTrans, osg::Vec3 *inoutTranslationVector);
68 // Another PART of the transformation calculation. [inoutTrans] is already calculated.
69 // This method may adjust the transformtion matrix to snap the object to other scene objects.
70
71
72
74 void readWatchedObjectIDs();
75
76 void writeObjectPosition(int id, ofstream &stream);
77 void writeObjectRotation(int id, ofstream &stream);
78 void writeObjectFullMatrix(int id, ofstream &stream);
79 void writeObjectPositionsAndRotations();
80
81 void compareObjectPosition(int id, ifstream &stream, double &linearDifference, double &quadraticDifference);
82 void compareObjectRotation(int id, ifstream &stream, double &linearDifference, double &quadraticDifference);
83 void compareObjectPositionsAndRotations();
84
85 void loadObjectFullMatrix(int id, ifstream &stream);
86 void loadObjectPositionsAndRotations();
87 };
88
89 }
90
91
92 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintArea.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
ConstraintArea.h
Go to the documentation of this file.
1 #ifndef CONSTRAINT_AREA_H
2 #define CONSTRAINT_AREA_H
3
4 #include <vrecko/Ability.h>
5 #include <vector>
6 #include <osg/Vec3>
7 #include <osg/Matrix>
8 #include "ConstraintHierarchy.h"
9
10 using namespace vrecko;
11
12 namespace APConstrainedMovement {
13 typedef vector<osg::Vec3> Vecs3;
14
15 double vectorAngle(osg::Vec3 vector1, osg::Vec3 vector2);
16
18 class ConstraintArea {
19 private:
20 osg::Vec3 normalVector; // Local coordinates of normal vector
21 osg::Vec3 normalVectorWorld; // World coordinates of normal vector
22 Vecs3 boundingPoints; // Local coordinates of bounding points
23 Vecs3 boundingPointsWorld; // World coordinates of bounding points
24 string areaClassString; // Name of the area class
25 string restrictorString; // Name of the area restrictor
26
27 ConstraintHierarchyMember *cachedConstraintHierarchyMember; // Cached area class
28 public:
29 ConstraintArea();
30 virtual ~ConstraintArea();
31
32 ConstraintHierarchyMember *getAreaClass(ConstraintHierarchyMember *constraintHierarchyRoot);
33
34 inline string getAreaClassString() {return areaClassString;};
35 inline void setAreaClassString(string str) {areaClassString = str;
36 cachedConstraintHierarchyMember = NULL;};
37 inline string getRestrictorString() {return restrictorString;};
38 inline void setRestrictorString(string str) {restrictorString = str;};
39
40 void addBoundingPoint(osg::Vec3 &coords);
41 inline Vecs3 getBoundingPoints() {return boundingPoints;};
42 inline Vecs3 getBoundingPointsWorld() {return boundingPointsWorld;};
43
44 void shift(osg::Vec3 shiftVector);
45
46 void setNormalVector(osg::Vec3 &normalVector);
47 inline osg::Vec3 getNormalVector() {return normalVector;};
48 inline osg::Vec3 getNormalVectorWorld() {return normalVectorWorld;};
49
50 void setWorldTransformationFromObject(EnvironmentObject *eo);
51 void applyTransformation(osg::Matrix transformationMatrix);
52
53 void writeInfo();
54
55 bool liesWithinArea(ConstraintArea *area);
56 double ConstraintArea::distanceFactorToArea(ConstraintArea *area);
57
58 bool getPlaneDistanceFrom(ConstraintArea *area, double &distance);
59 protected:
60 };
61
62 }
63
64 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintDescription.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
ConstraintDescription.h
Go to the documentation of this file.
1 #ifndef CONSTRAINT_DESCRIPTION_H
2 #define CONSTRAINT_DESCRIPTION_H
3
4 #include <vrecko/Ability.h>
5 #include <set>
6 #include <vector>
7 #include "ConstraintArea.h"
8
9 #include <osg/Matrix>
10
11 using namespace vrecko;
12
13 namespace APConstrainedMovement {
14 // Maximum distance for object snapping
15 #define CONSTRAINED_SNAPPING_DISTANCE 0.5
16 #define MAX_CONSTRAINED_SNAPPING_DISTANCE 10.0
17
18 // Maximum distance for object rotation
19 #define CONSTRAINED_ROTATION_DISTANCE CONSTRAINED_SNAPPING_DISTANCE * 10
20
21 typedef vector<ConstraintArea*> ConstraintAreas;
22 typedef set<int> EnvironmentObjectIDs;
23
25 class ConstraintDescription: public Ability {
26 private:
27 ConstraintAreas offerAreas;
28 ConstraintAreas bindingAreas;
29 ConstraintAreas dualAreas;
30 bool justMoving;
31 bool wasTested;
32
33 int constraintParentID;
34 EnvironmentObjectIDs constrainedChildrenIDs;
35 EnvironmentObjectIDs constrainedDualPartnerIDs;
36 EnvironmentObjectIDs freshDualPartnerIDs;
37
38 int boundAreaCount;
39 osg::Vec3 boundAreaNormal;
40 public:
41 ConstraintDescription();
42 virtual ~ConstraintDescription();
43
44 bool loadXMLFile(const char *xmlFile);
45 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
46
47 inline ConstraintAreas getOfferAreas() {return offerAreas;};
48 inline ConstraintAreas getBindingAreas() {return bindingAreas;};
49 inline ConstraintAreas getDualAreas() {return dualAreas;};
50
51 inline bool getJustMoving() {return justMoving;};
52 inline void setJustMoving(bool justMoving) {this->justMoving = justMoving;};
53
54 inline bool getWasTested() {return wasTested;};
55 inline void setWasTested(bool wasTested) {this->wasTested = wasTested;};
56
57 inline int getConstraintParentID() {return constraintParentID;};
58 inline EnvironmentObjectIDs getConstrainedChildrenIDs() {return constrainedChildrenIDs;};
59 inline EnvironmentObjectIDs getConstrainedDualPartnerIDs() {return constrainedDualPartnerIDs;};
60 inline EnvironmentObjectIDs getFreshDualPartnerIDs() {return freshDualPartnerIDs;};
61 inline void clearFreshDualPartnerIDs() {freshDualPartnerIDs.clear();};
62
63 void addConstrainedChildID(int id);
64 void removeConstrainedChildID(int id);
65 void addConstrainedDualPartnerID(int id, bool addAsFresh);
66 void removeConstrainedDualPartnerID(int id);
67 void freeFromConstraintParent();
68 void shiftAllConstrainedObjects(EnvironmentObject* eo, const osg::Matrix& transformationMatrix);
69 void processDualSplitting(EnvironmentObject* eo, osg::Vec3 splittingDirection);
70
71 bool isConstraintParentOf(EnvironmentObject *eo);
72
73 inline int getBoundAreaCount() {return boundAreaCount;};
74 inline osg::Vec3 getBoundAreaNormal() {return boundAreaNormal;};
75 inline void setBoundAreaCount(int boundAreaCount) {this->boundAreaCount = boundAreaCount;};
76 inline void setBoundAreaNormal(osg::Vec3 boundAreaNormal) {this->boundAreaNormal = boundAreaNormal;};
77
78 void writeInfo();
79 protected:
80 };
81
82 }
83
84 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/ConstraintHierarchy.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
ConstraintHierarchy.h
Go to the documentation of this file.
1 #ifndef CONSTRAINT_HIERARCHY_H
2 #define CONSTRAINT_HIERARCHY_H
3
4 #include <helpers/XercesXMLUtils.h>
5 #include <vector>
6 #include <string>
7
8 using namespace std;
9
10
12 class ConstraintHierarchyMember {
13 private:
14 string areaClassString; // Name of the constraint area class
15
16 vector<ConstraintHierarchyMember*> hierarchyChildren; // Children of this hierarchy node
17 public:
18 ConstraintHierarchyMember();
19 virtual ~ConstraintHierarchyMember();
20
21 inline string getAreaClassString() {return areaClassString;};
22 inline void setAreaClassString(string areaClassString) {this->areaClassString = areaClassString;};
23
24 bool loadXMLFile(const char *xmlFile);
25 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
26
27 void write(int level = 0);
28
29 ConstraintHierarchyMember* findHierarchyMember(string areaClassStringLookingFor);
30 bool isHierarchyAncestorOf(ConstraintHierarchyMember* hierarchyMember);
31 protected:
32 };
33
34
35 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/ContactObjectManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
ContactObjectManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 using namespace vrecko;
4
5 namespace behindO {
6
7 class ContactObjectManipulator: public Ability {
8 public:
9 ContactObjectManipulator();
10 ~ContactObjectManipulator() {};
11
12 void update(void);
13
14 protected:
15 };
16
17 }
18
19 //$Id: ContactObjectManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/ControllableAbility.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
ControllableAbility.h
Go to the documentation of this file.
1 #ifndef CONTROLLABLEABILITY_H
2 #define CONTROLLABLEABILITY_H
3
4 /*
5
6 I/O CHANGES:
7
8 16 Feb 2008
9 It is possible to obtain full scene graph path for the selected object (requestSelectionPath())
10 24 Aug 2007
11 Instead of overriding the createInfo() method, you have to override the fillDefaultInfo().
12 */
13
14
15 #include <vrecko/Ability.h>
16 #include <vrecko/IOPins.h>
17 #include <osg/Quat>
18 #include <osg/Node>
19
20
21 namespace vrecko {
22
23
24 #ifndef ANIMATOR_IMP_EXP
25 #ifdef AP_EDITORCONTROLLER_EXPORTS
26 #define EDITORCONTROLLER_IMP_EXP __declspec(dllexport)
27 #else
28 #define EDITORCONTROLLER_IMP_EXP __declspec(dllimport)
29 #endif
30 #endif
31
32
33
34 #define POINTERPOS_REQUEST_NAME "PointerPosition"
35 #define POINTERROT_REQUEST_NAME "PointerRotation"
36 #define POINTERPOS_RAW_REQUEST_NAME "PointerPositionRaw"
37 #define POINTERROT_RAW_REQUEST_NAME "PointerRotationRaw"
38 #define SELECTIONID_REQUEST_NAME "SelectionID"
39 #define SELECTIONPATH_REQUEST_NAME "SelectionPath"
40 // Returns the same "std::vector<osg::Node*>" as
41 // ObjectUtils/ObjectSelector/"SelectionByPointerPos_Path" request
42
43 #pragma pack(push, 1)
44 struct CABUTTONEVENT {
45 /* Size of the structure. Newer versions could have additional information
46 attached at the end. */
47 unsigned long dwSize;
48 /* ID of the pointer assigned to the button */
49 int iPointerID;
50 /* ID of the button that generated the event */
51 int iButtonID;
52 /* New state of the button (pressed = true, not pressed = false) */
53 bool bState;
54 };
55
56 class MessageCAButtonEvent : public VreckoMessage {
57 public:
58 virtual const char* getMessageId() { return "MessageCAButtonEvent"; }
59 CABUTTONEVENT data;
60 };
61
62 // Constants for CAINFO::dwFlags:
68 #define CAINFO_FLAGS_POINTERLOC_REQUESTOUTPUTS 0x00000001
69
73 #define CAINFO_FLAGS_SELECTIONID_REQUESTOUTPUT 0x00000002
74
77 #define CAINFO_FLAGS_ALL_ACTIVEPOINTER_BUTTONS 0x00000004
78
81 #define CAINFO_FLAGS_ALL_OTHERPOINTER_BUTTONS 0x00000008
82
86 #define CAINFO_FLAGS_POINTERLOC_RAW_REQUESTOUTPUTS 0x00000010
87
89 #define CAINFO_FLAGS_NO_AUTO_DEACTIVATE 0x80000000
90
91
92 // Constants for CAINFO::dwActiveFlags:
93 /* Constants to set the preference... Should the selection be visible or not?
94 We have to determine the visibility of the selection of the active pointer (ACTPTR)
95 and other pointers (OTHERPTR).
96 The preference could be DONTCARE, FORCESHOW, SHOW, HIDE and FORCEHIDE.
97 Multiple abilities can be active at the same time, so the preferences could be conflicting.
98 The SHOW/HIDE are suggestions, FORCESHOW/FORCEHIDE are stronger suggestions
99 (a single active ability returning FORCESHOW will override any number of FORCEHIDEs) */
100 #define CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT 0
101 #define CAINFO_AFLAGS_SELSHOW_ACTPTR__MASK 0x00000007
102 #define CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE 0x00000000
103 #define CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE 0x00000001 // Side note: The flags are sorted by their priorities
104 #define CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW 0x00000002 // (The EditorController::SelectionVisibilityUpdate() expects it to be so, so don't change the numbers)
105 #define CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE 0x00000003
106 #define CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW 0x00000004
107 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT 3
108 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR__MASK 0x00000038
109 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR_DONTCARE (CAINFO_AFLAGS_SELSHOW_ACTPTR_DONTCARE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
110 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR_SHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_SHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
111 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR_HIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_HIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
112 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCEHIDE (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCEHIDE >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
113 #define CAINFO_AFLAGS_SELSHOW_OTHERPTR_FORCESHOW (CAINFO_AFLAGS_SELSHOW_ACTPTR_FORCESHOW >> CAINFO_AFLAGS_SELSHOW_ACTPTR__SHIFT << CAINFO_AFLAGS_SELSHOW_OTHERPTR__SHIFT)
114
115 struct CAINFO__VER1 {
117 unsigned long dwSize;
119 enum CAType {
121 Unknown = 0,
133 SimpleVREdit = 1,
136 AbilityMapper = 2,
138 DummyCATypeToDWORD = 0xFFFFFFFF,
139 };
140 CAType type;
142 unsigned long dwFlags;
143 };
144
145 struct CAINFO__VER2 : public CAINFO__VER1 {
149 unsigned long dwActiveFlags;
150 };
151
152 typedef CAINFO__VER2 CAINFO;
153
155 #define IS_CAINFO_VER(info, ver) \
156 ((info).dwSize >= sizeof(CAINFO__VER##ver))
157
158
159 #pragma pack(pop)
160
161 class EDITORCONTROLLER_IMP_EXP ControllableAbility : public Ability {
162 public:
163
164 class MessageCAINFO : public VreckoMessage {
165 public:
166 virtual const char* getMessageId() { return "MessageCAINFO"; }
167 CAINFO data;
168 };
169
170 ControllableAbility(const char *abilityName);
171 virtual ~ControllableAbility();
172
176 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
177
180 virtual void update() {}
181
182 // Called mostly by the VRECKO to handle a received event
183 // CAN be overridden, but it HAS TO CALL the ancestor's method
184 // (if the event is not fully processed by your method)
185 // virtual void processEvent(const std::string &strInputName, void *pValue);
186
188 virtual bool isActive();
189
190 protected:
191 EnvironmentObject *owner;
192
193 int activePointerID;
194
195 int lastEventButtonID;
196
204 osg::Vec3 actPointerPos;
205
214 osg::Vec3 actPointerPosRaw;
215
224 osg::Quat actPointerRot;
225
230 osg::Quat actPointerRotRaw;
231
236 unsigned long actSelectedObjectID;
237
246 std::vector<osg::Node*> *actSelectedPath;
247
250 int actPosInPath;
251
252
253
259 virtual void createInterface();
260
265 virtual void destroyInterface();
266
271 virtual void processButtonPress(CABUTTONEVENT* eventData) {}
272
277 virtual void processButtonRelease(CABUTTONEVENT* eventData) {}
278
281 virtual int processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData);
282
288 virtual bool activate() { return true; }
289
294 virtual void deactivate();
295
323 virtual CAINFO* createInfo();
324
325 CAINFO defaultInfo; // the base info, that will be used in createInfo() method.
326
333 virtual void fillDefaultInfo() = 0;
334
339 bool requestPointerLoc(bool bCancelIfNotActive = true);
340
345 bool requestPointerLocRaw(bool bCancelIfNotActive = true);
346
352 bool requestSelectionID(bool bCancelIfNotActive = true);
353
359 bool requestSelectionPath(bool bCancelIfNotActive = true);
360
362 Ability *menu;
363 bool bMenuVisible; // "cached" value, which may be updated in an isMenuCreated() call
364 inline bool isMenuCreated() { return (menu != NULL); }
365
367 bool isMenuVisible();
368
370 virtual bool createMenu(const char *menuString, bool bForceCreate = true);
371 virtual void destroyMenu();
372 virtual bool showMenu();
373 virtual bool hideMenu();
374
377 virtual void processMenuButtonPress(CABUTTONEVENT* eventData);
378
381 virtual void processMenuButtonRelease(CABUTTONEVENT* eventData);
382
383
388 virtual void menuItemClicked(const char* itemID) {};
389
391 virtual void menuSliderChanged(const char* sliderID, float sliderPos) {};
392
393 DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent);
394 DECLARE_INPUT(Menu_Clicked, MessageString);
395
396 DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt);
397 DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO);
398
399 DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3);
400 DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat);
401
402 DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3);
403 DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat);
404
405 DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID);
406 DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList);
407
408 private:
412 virtual void preInitialize() { };
413
417 virtual void postInitialize() {}
418
422 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) { return true; }
423
424 };
425
426 }
427
428 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Controller.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Controller.h
Go to the documentation of this file.
1 #ifndef _DA_CONTROLLER_H
2 #define _DA_CONTROLLER_H
3
4
5 #include "PoA.h"
6 #include "DATool.h"
7
8 using namespace vrecko;
9
10 namespace APDYNAMICART
11 {
12
13
14 class DAEnvironment;
15
17
29 typedef std::vector<DATool*> DATools;
30
31 class Controller : public Ability, public osg::Referenced
32 {
33 public:
34
44 Controller(const char* controllerID, const char* description, PoAType type);
45 ~Controller();
46
48
57 virtual void activateTool() = 0;
58
59
61 /*
62 * - clear all PoA objects
63 * - reset tools setting
64 *
65 */
66 virtual void clear() = 0;
67
68 void clearAllPoAs();
69
71
76 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const = 0;
77
79
83 virtual void deactivateTool() = 0;
84
86
89 virtual void debugKeyPressed() = 0;
90
91 const char* getDescription(void) const { return _description; }
92
94 const PoAType getType(void) const { return _type; }
95
96 static const PoAType getType(std::string type);
97
99 const char* getPoAsName(void) const { return this->_poasName; }
100
102 float getDaareaScale() const { return _artArea->getScale().x(); }
103
105
108 virtual void guiItemClicked(const char* itemID) = 0;
109
110 virtual void initialize(DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL) = 0;
111
113 inline bool isEmpty() { return _poas->empty(); }
114
116 virtual void load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList) = 0;
117
118
120
124 virtual void guiSliderChanged(const char* sliderID, float sliderPos) = 0;
125
131 void preInitialize();
132 void postInitialize();
133
135 void removePoA(PoA* toRemove);
136
137
139 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) = 0;
140
141 //TODO REMOVE
143
149 //virtual void setDAEnvironment(DAEnvironment* p_dae) { this->_daEnvironment = p_dae; }
150
151
152 virtual DAToolType getNextToolType();
153
155
162 virtual void switchTools(DAToolType newType);
163
165
168 virtual void turnOn() = 0;
169
171
174 virtual void turnOff(void) = 0;
175
177 /*
178 * check all PoAs and do something (e.g. delete PoA) if needed
179 *
180 */
181 virtual void update() = 0;
182 std::vector<ref_ptr_PoA>* getPoAs() { return this->_poas; }
183 virtual void setColour( osg::Vec4 newColour );
184
185 virtual void switchGUIVisibility() = 0;
186
187 protected:
189 void initTools();
190
192 const char* _description;
193
195 const PoAType _type;
196
199 const char* _poasName;
200
202 EnvironmentObject* _artArea;
203
205 DAEnvironment* _daEnvironment;
206
208 std::vector<ref_ptr_PoA>* _poas;
209
211 DATool* _actualTool;
212
214 DATools _tools;
215
216 };
217
218 //not used ?
219 //typedef osg::ref_ptr<Controller> ref_ptr_Controller;
220
221 }
222 #endif // _DA_CONTROLLER_H
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/CopyProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
CopyProperties.h
Go to the documentation of this file.
1 #ifndef COPYPROPERTIES_H
2 #define COPYPROPERTIES_H
3
4 #include <vrecko/Ability.h>
5
6 using namespace vrecko;
7
8 namespace APObjectUtils
9 {
10
11 // Defines for CopyProperties::dwCopiedProperties / setProperties() / getProperties()
12 #define COPYPROP_GEOMETRY_COPY 0x00000001
13 // Copy geometry from the original EO.
14 #define COPYPROP_GEOMETRY_REF 0x00000002
15 // Use the original geometry (usage by reference pointer)
16 #define COPYPROP_TRANSFORMATION 0x00000004
17 // Copy the original object's transformation EVERY FRAME.
18
19
20 class CopyProperties: public Ability
21 {
22 public:
23 CopyProperties();
24 //virtual ~CopyProperties();
25
26 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 virtual void update();
28
29 protected:
30 unsigned long dwCopyEO;
31 // id of the original object
32 unsigned int dwCopiedProperties;
33 // Combination of COPYPROP_*
34
35 void setProperties(unsigned int dwNewCopiedProperties);
36 // Combination of COPYPROP_*
37 unsigned int getProperties(void) { return dwCopiedProperties; }
38 // Combination of COPYPROP_*
39
40 };
41
42 }
43
44 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CoreActorDesc.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
CoreActorDesc.h
Go to the documentation of this file.
1 #ifndef CoreActorDesc_h
2 #define CoreActorDesc_h
3
4 #include "PhysXObject.h"
5 #include <vrecko/World.h>
6
7 using namespace vrecko;
8
9 namespace PhysXPlugin
10 {
11 class CoreActorDesc
12 {
13 private:
14 bool _create;
15
16 NxActor* _pActor;
17 NxActorDesc _actorDesc;
18 NxBodyDesc _bodyDesc;
19
20 NxReal _impulseThreshold;
21 NxReal _penetrationDepth;
22 NxReal _maxDeformationDistance;
23
24 public:
25 CoreActorDesc():_create(false){}
26 bool loadXMLParameters( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode );
27
28 void Create(NxScene* pScene, NxCloth* pCloth);
29 };
30 }
31
32 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/CreateHole.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
CreateHole.h
Go to the documentation of this file.
1 #ifndef _CREATE_HOLE_H
2 #define _CREATE_HOLE_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 // tool to create new hole in the curWall, either door or window
9 // (given by the xml parameter)
10 class CreateHole : public Tool {
11 public:
12 CreateHole(void) {type=CREATEHOLE;}
13 ~CreateHole(void) {}
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
16 std::string mode = "";
17 if (findXMLNode(pParametersNode, "Mode")) {
18 ReaderWriter::getStringValue(mode, pParametersNode, "Mode");
19 name = mode;
20 }
21
22 if (findXMLNode(pParametersNode, "YValue")) {
23 y = ReaderWriter::getFloatValue(pParametersNode, "YValue");
24 }
25 else {
26 y = RE_DEFAULT_HEIGHT / 2;
27 }
28
29 if (findXMLNode(pParametersNode, "Height")) {
30 height = ReaderWriter::getFloatValue(pParametersNode, "Height");
31 }
32 else {
33 height = RE_DEFAULT_HEIGHT / 3;
34 }
35
36 if (findXMLNode(pParametersNode, "Width")) {
37 width = ReaderWriter::getFloatValue(pParametersNode, "Width");
38 }
39 else {
40 width = RE_DEFAULT_HEIGHT / 3;
41 }
42
43 htype = (mode == "door" ? ht_door : ht_window);
44 return true;
45 }
46
47 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
48 WG_Wall* curWall,
49 WG_Point* curPoint,
50 PointType type,
51 vrecko::EnvironmentObject* pEOOwner,
52 std::vector<osg::ref_ptr<WG_Wall> >* walls,
53 std::vector<osg::ref_ptr<WG_Point> >* points,
54 osg::Geode* pOSGGeode,
55 osg::Vec3Array* pOSGVertexArray) {
56
57 if (curWall != NULL) {
58 osg::Vec2 iPoint = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z());
59 osg::Vec2 iNormal = curWall->getVector(WG_Q_POINT);
60
61 osg::Vec2 curNormal(-curWall->getVector(WG_Q_POINT).y(),curWall->getVector(WG_Q_POINT).x());
62
63 osg::Vec2 crossPoint;
64 WG_Geometry::getCrossingPoint(crossPoint, curWall->getPoint(WG_Q_POINT)->getPosition(), curNormal, iPoint, iNormal, false);
65
66 osg::Vec2 Q_cross = curWall->getPoint(WG_Q_POINT)->getPosition() - crossPoint;
67 float candPosition = Q_cross.length();
68
69 bool canAdd = true;
70
71 // test closeness to the edges
72 #define MIN_DISTANCE_FROM_EDGE 3.0
73 if ((candPosition - width/2 < MIN_DISTANCE_FROM_EDGE) ||
74 (candPosition + width/2 > ((curWall->getPoint(WG_Q_POINT)->getPosition() - curWall->getPoint(WG_R_POINT)->getPosition()).length() - MIN_DISTANCE_FROM_EDGE)))
75 canAdd = false;
76
77
78 // test if there is already another hole too close to the point where the user
79 // wants to place new one
80 for (unsigned int i=0; i<curWall->getHoles()->size();i++) {
81 if (candPosition < curWall->getHoles()->at(i).getPosition()) {
82 if ((candPosition + width/2) > (curWall->getHoles()->at(i).getPosition() - curWall->getHoles()->at(i).getWidth()/2 - 1.0)) {
83 canAdd = false;
84 break;
85 }
86 }
87 else {
88 if ((candPosition - width/2) < (curWall->getHoles()->at(i).getPosition() + curWall->getHoles()->at(i).getWidth()/2 + 1.0)) {
89 canAdd = false;
90 break;
91 }
92 }
93 }
94
95 if (!canAdd)
96 logger.warningLog("Too close to another hole or edge");
97 else {
98 WG_Hole hole(candPosition, y, height, width, htype);
99 int i = 0;
100 while(i < (int)curWall->getHoles()->size()) {
101 if ((*curWall->getHoles())[i].getPosition() > candPosition)
102 break;
103 ++i;
104 }
105 curWall->getHoles()->insert(curWall->getHoles()->begin() + i, hole);
106 curWall->computeAttrVertices();
107 }
108 }
109 setDirty(true);
110 }
111
112 private:
113 HoleType htype;
114 float y;
115 float height;
116 float width;
117
118 };
119
120 }
121
122 #endif
123
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CreateShadowedScene.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
CreateShadowedScene.h
Go to the documentation of this file.
1 #ifndef CREATESHADOWEDSCENE_H
2 #define CREATESHADOWEDSCENE_H
3
4 #include <osg/Node>
5 #include <osg/Vec3>
6
7 // function to create a lightsource which contain a shadower and showed subgraph,
8 // the showadowed subgrph has a cull callback to fire off a pre render to texture
9 // of the shadowed subgraph.
10 extern osg::Group* createShadowedScene(osg::Node* shadower,osg::Node* shadowed,const osg::Vec3& lightPosition,float radius,unsigned int textureUnit=1);
11
12 #endif
13
14 //$Id: CreateShadowedScene.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_Attractor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_Attractor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Controller.h"
4 #include "Attractor.h"
5
6 using namespace vrecko;
7
8 namespace APDYNAMICART
9 {
10
19 class Ctrl_Attractor: public Controller
20 {
21 public:
23 Ctrl_Attractor();
24
26 void activateTool();
27 void clear();
28 void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
29 void createColorSubMenu( std::ostringstream& menuSS, Attractor* att ) const;
30 ref_ptr_PoA createPoA();
31 void deactivateTool();
32 void debugKeyPressed() {};
33 void initialize(DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
34 void load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList);
35 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode);
36 void update();
37 void guiItemClicked(const char* itemID);
38 void guiSliderChanged(const char* sliderID, float sliderPos) {};
39
40 void switchGUIVisibility() { cerr << "Not implemented, yet." << endl; };
41
42 void turnOn();
43 void turnOff();
44
45 private:
46 std::string _attType;
47
48 void postInitialize();
49
51 Attractor* getAtt(UINT index = 0) const;
52 IMenuComponentPtr createAttractorsTypeSubMenu() const;
53 };
54
55 inline Attractor* Ctrl_Attractor::getAtt(UINT index) const
56 {
57 return (Attractor*)_poas->at(index).get();
58 }
59
60 }
61 // $Id: Ctrl_Attractor.h 436 2012-10-12 08:57:42Z xchmeli1 $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_FreeHandPainting.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_FreeHandPainting.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Controller.h"
4 #include "BrushStroke.h"
5
6 #include "ToolBrush.h"
7 #include "ToolTongs.h"
8 #include "ToolEraser.h"
9 #include "Brush.h"
10
11 #include "..\GUI\Slider.h"
12 #include "..\GUI\Icon.h"
13
14 using namespace vrecko;
15
16 namespace APDYNAMICART
17 {
18
19 #define PLAYBACK_LAG_DURATION 0.5;
20
21 typedef enum PlaybackType {
22 FHP__REAL_TIME = 1,
23 FHP__LAG_SKIP,
24 //FHP__FIXED
25 };
26
28
37 class Ctrl_FreeHandPainting: public Controller
38 {
39 public:
40
41 Ctrl_FreeHandPainting();
42 Ctrl_FreeHandPainting(const char* abName, const char* contextName, PoAType type);
43 ~Ctrl_FreeHandPainting();
44
45 void activateTool();
46
47 void clear();
48
49 void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
50
52
57 osg::ref_ptr<PoA> createPoA();
58
59 void deactivateTool();
60
61 void debugKeyPressed();
62
63 DAToolType getNextToolType();
64
66
72 double getPaintingDuration();
73
74 void guiItemClicked(const char* itemID);
75
76 void guiSliderChanged(const char* sliderID, float sliderPos);
77
79 /*
80 * Called from DAEnvironment, where some other items are loaded from same file.
81 * \param fileName file to import
82 * \return code error. 0 means everything went good
83 */
84 int importScene( const string& fileName );
85
86 void initialize(DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
87
88 void load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList);
89
90 void processEvent(const std::string &input_name, void *value);
91
92 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode);
93
94 void setColour( osg::Vec4 newColour );
95
96 void switchGUIVisibility();
97
98 void switchTools(DAToolType newType);
99
100 void turnOn();
101
102 void turnOff();
103
104 void update();
105
106
107
108
109
110 protected:
111
113 bool _firstTimeUpdate;
114
116 // when new stroke is created, copy of brush is created and associated to stroke
117 BrushPtr _brush;
118
120 bool _showControlPoints;
121
122 //Tools
123 // osg::ref_ptr<ToolBrush> can NOT be used here, because of VRECKO
124 // VRECKO memory management collides with osg ref-pointers memory management
125 // particularly in deleting abilities.
126 ToolBrush* _toolBrush;
127
129 ToolTongs* _toolTongs;
130
132 ToolEraser* _toolEraser;
133
134 //Time-line
136 bool _playbackActive;
137
139 PlaybackType _playbackType;
140
142 double _playbackTime;
143
145 time_t _lastPlaybackTime;
146
147 time_t _nowTime;
148
150 APGUI::Slider *_playbackSlider;
151 APGUI::Icon *_playbackIcon;
152
153
154 //Menu
155 APGUI::Menu *_menuAbility;
156
157 inline std::string getShowControlPointsString() const;
158
159 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
160
161 void preInitialize();
162
163 void postInitialize();
164 void playback( double _playbackTime );
165 string getPlaybackTimeText();
166 void recomputeStrokesTimes();
167 };
168
169 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_MotionVisualization.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_MotionVisualization.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Controller.h"
4 #include "Ctrl_FreeHandPainting.h"
5 #include "MotionTrail.h"
6
7
8 using namespace vrecko;
9
10 namespace APDYNAMICART
11 {
12
14
25 class Ctrl_MotionVisualization: public Ctrl_FreeHandPainting
26 {
27 public:
28
29 Ctrl_MotionVisualization();
30 ~Ctrl_MotionVisualization();
31
32 void activateTool();
33
34 void clear();
35
36 std::string createMenuStructure(void) const;
37
39
44 osg::ref_ptr<PoA> createPoA();
45
46 void deactivateTool();
47
48 void initialize(DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
49
50 //
51 // void debugKeyPressed();
52 //
53 // DAToolType getNextToolType();
54 //
55 //
56 // void guiItemClicked(const char* itemID) { cerr << "Not implemented." << endl; }
57 //
58 // /**
59 // * not used
60 // */
61 // //inline std::string getTrackingTrailsString() const;
62 //
63 // ///Import scene from Modeller plug-in
64 // /*
65 // * Called from DAEnvironment, where some other items are loaded from same file.
66 // * \param fileName file to import
67 // * \return code error. 0 means everything went good
68 // */
69 // int importScene( const string& fileName );
70 //
71 // void load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList);
72 //
73
74 //
75 // void menuItemClicked(const char* itemID);
76 //
77 void guiSliderChanged(const char* sliderID, float sliderPos);
78 //
79 //
80 // void processEvent(const std::string &input_name, void *value);
81 //
82 // void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode);
83 //
84
85
86
87 void setSensorCount(int newCount);
88
89 void switchGUIVisibility();
90
91 void switchTools(DAToolType newType);
92
93 void turnOn();
94
95 void turnOff();
96 //
97 // void update();
98
99
100
101 protected:
102
103 //Tracking
104 int _sensorCount;
105
106
107 //Tools
108 // osg::ref_ptr<ToolBrush> can NOT be used here, because of VRECKO
109 // VRECKO memory management collides with osg ref-pointers memory management
110 // particularly in deleting abilities.
111 ToolBrush* _toolBrushes[MAX_NUMBER_OF_TRACKED_SENSORS];
112
113
114 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
115 void preInitialize();
116
117 void postInitialize();
118
119
121 void turnOnTool(DAToolType type);
122
124 void turnOffTool(DAToolType type);
125
126 void update();
127
128
129 DECLARE_OUTPUT(SetSensorsCount, MessageInt);
130 };
131
132 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PerlinLines.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_PerlinLines.h
Go to the documentation of this file.
1 #ifndef _CTRL_PERLINELINES_H
2 #define _CTRL_PERLINELINES_H
3
4 #include "Controller.h"
5 #include "PerlinLines.h"
6 #include "PerlinLinesTools.h"
7
8 using namespace vrecko;
9
10 namespace APDYNAMICART
11 {
12
13 class Ctrl_PerlinLines: public Controller
14 {
15 public:
17 Ctrl_PerlinLines();
18
20 void activateTool();
21
22 void setParameters();
23
24 void clear();
25
26 void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
27
28 ref_ptr_PoA createPoA(int count, double x, double y, double z);
29
30 ref_ptr_PoA createMag(osg::Vec3 coords);
31
32 DAToolType getNextToolType();
33
34 double random(double min,double max) { return min + (max-min)*(double)rand()/(double)RAND_MAX;}
35
36 void deactivateTool();
37
38 void debugKeyPressed() { }
39
40 void initialize(DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
41
42 void load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList);
43
44 void guiItemClicked(const char* itemID);
45
46 void guiSliderChanged(const char* sliderID, float sliderPos);
47
48 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode);
49
50 void switchGUIVisibility() { cerr << "Not implemented, yet." << endl; };
51
52 //void processEvent(const std::string &input_name, void *value);
53
54 void update();
55
56 void turnOn();
57
58 //void setParameters();
59
60 void turnOff();
61
62 double autoRotationStep;
63
64 osg::Timer_t lastAutorotationTime, nowAutorotationTime;
65
66 void switchTools(DAToolType newType);
67
68 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
69
70 private:
71 PLNestTool* nest;
72 PLMagnetTool* magnet;
73 PLControllerTool* controller;
74 protected:
75 std::vector<PerlinLines*> pl;
76 u_int _speed, _interpolationCount, _length;
77 string posString;
78 float _red, _green, _blue;
79 double _magnetSize, _boundingSize;
80 bool bounding, boundingVisible, magnetCreated, boundingCreated;
81 EnvironmentObject* magnetEO;
82
83 osg::Vec3 rightHandPosition;
84
85 void postInitialize();
86
87 DECLARE_INPUT(Position_sensor_0, MessageVec3);
88 };
89
90 }
91 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_PolyhedraSculptures.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_PolyhedraSculptures.h
Go to the documentation of this file.
1
9 #pragma once
10
11 #include "Controller.h"
12 #include "Utils.h"
13 #include "PolyhedraSculpture.h"
14
15 using namespace vrecko;
16
17 namespace APDYNAMICART
18 {
19
20 class Ctrl_PolyhedraSculptures : public Controller
21 {
22 public:
24 virtual void activateTool();
25 virtual void clear();
26 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
27 void CreatePoA( const string& polyhedronName );
28 virtual void deactivateTool();
29 virtual void debugKeyPressed() {}
30 virtual void guiItemClicked( const char* itemID );
31 virtual void guiSliderChanged( const char* sliderID, float sliderPos );
32
33 virtual void initialize( DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL );
34 virtual void load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList );
35 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode );
36 virtual void switchTools( DAToolType newType );
37 virtual void setColour( osg::Vec4 newColour ) { err("Not implemented, yet.") }
38 virtual void switchGUIVisibility() { err("Not implemented, yet.") };
39 virtual void turnOn();
40 virtual void turnOff( void );
41
42 //called each frame
43 virtual void update();
44
46 Ctrl_PolyhedraSculptures();
47 ~Ctrl_PolyhedraSculptures();
48
49
50
54 protected:
55
56 bool isThereaSculpture;
57
58 osg::ref_ptr<PolyhedraSculpture> _sculpture;
59
61 MenuPtr createNewPolyhedraMenu() const;
62
63
64
65 };
66
67
68 }
69 // $Id$
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Ctrl_StringSculptures.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Ctrl_StringSculptures.h
Go to the documentation of this file.
1
9 #pragma once
10
11 #include "Controller.h"
12 #include "Utils.h"
13 #include "Modes.h"
14 #include "Pattern.h"
15 #include "PatternGeode.h"
16 #include "ToolSelector.h"
17 #include "PhysXManager.h"
18 #include "ToolHook.h"
19 #include "DATool.h"
20 #include "ConstantDiameterGen.h"
21 #include "ToolBrush.h"
22
23 using namespace vrecko;
24
25 namespace APDYNAMICART
26 {
27
28 class Ctrl_StringSculptures : public Controller, public vreckoUtils::Observer
29 {
30 public:
32 virtual void activateTool();
33 virtual void clear();
34 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
35 virtual void deactivateTool();
36 virtual void debugKeyPressed() {}
37 virtual void guiItemClicked( const char* itemID );
38 virtual void initialize( DAEnvironment* p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL );
39 virtual void load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList* poaNodeList );
40 virtual void guiSliderChanged( const char* sliderID, float sliderPos );
41 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode );
42 virtual void switchTools( DAToolType newType );
43 virtual void setColour( osg::Vec4 newColour ) { _defaultColor = newColour; }
44 virtual void switchGUIVisibility() { err("Not implemented, yet.") };
45 virtual void turnOn();
46 virtual void turnOff( void );
47 virtual void update();
48
50 virtual void notify( vreckoUtils::Observable* object, void* userData );
51
53 Ctrl_StringSculptures();
54 ~Ctrl_StringSculptures();
55
57 PoA* createPoA( const string& name );
58 void updateScene();
59
60 protected:
62 void setSectorEditing(bool enable);
63 void setShowAxis(bool enable);
64 void checkPoADeleteRequest( HoopPtr hoop );
65 void checkHookDeleteRequest();
66 inline HoopPtr asHoop( PoA* poa);
67 void startSimulation();
68 void disableAutorotation();
69 void stopSimulation();
70 void updatePoAs();
71 void disableTools();
72 void setPatternColor( float newValue, unsigned int index );
73
75 ModePtr _basic;
76 ModePtr _advanced;
77 ModePtr _mode;
78
80 PatternGeodePtr _patternsGeode;
81 PatternPtr _defaultPattern;
82
84 unsigned int _lineCount;
85 osg::ref_ptr<Hoop> _poa;
86 osg::Vec4 _defaultColor;
87 osg::Vec4 _patternColor;
88 std::vector<Vec3ArrayPtr> _finalArrays;
89 osg::ref_ptr<LinearInterpolator> _interpolator;
90 PoAState _hoopsState;
91 osg::ref_ptr<osg::Material> _patternMaterial;
92
94 ToolHook* _toolHook;
95 ToolBrush* _toolBrush;
96
98 bool _closedPattern; //NOTE: Just temporary
99 bool _simulation;
100 bool _dirtyScene;
101 int _lineWidth;
102 GeodePtr _geode;
103
105 PhysXManager* _physXManager;
106 osg::ref_ptr<ConstantDiameterGen> _ropeRadius;
107 };
108
109 HoopPtr Ctrl_StringSculptures::asHoop( PoA* poa )
110 {
111 HoopPtr hoop = dynamic_cast< Hoop*>(poa);
112 if(hoop.valid())
113 return hoop;
114
115 return NULL;
116 }
117
118 }
119 // $Id$
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Cube.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Cube.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include "DynamicScene.h"
3
4 #include <osg/Vec3>
5
6 using namespace vrecko;
7
8
9 namespace ode {
10
11 class Cube: public Ability {
12 public:
13 Cube();
14 ~Cube() {};
15
16 void postInitialize(void);
17 void update(void);
18
19 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
20 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
21
22 protected:
23 osg::Vec3 _size;
24 double _density;
25
26 DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid);
27 };
28
29 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/CubicInterpolator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
CubicInterpolator.h
Go to the documentation of this file.
1 #pragma once
2 #include "interpolator.h"
3 class CubicInterpolator :
4 public Interpolator
5 {
6 public:
7 CubicInterpolator(void);
8 ~CubicInterpolator(void);
9 };
10
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Cut.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Cut.h
Go to the documentation of this file.
1 #ifndef CUT_H
2 #define CUT_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include <helpers/DynamicArray.h>
6 #include "SnapObject.h"
7
8 using namespace vrecko;
9
10 //DERIVED FROM ObjectSelector.h
11 namespace APConnectEditor
12 {
13 //class Cut: public Ability
14 class Cut: public ControllableAbility
15 {
16 public:
17 Cut();
18 virtual ~Cut();
19
20 virtual void update();
21
22 protected:
23 virtual void fillDefaultInfo();
24 virtual bool activate();
25 virtual void deactivate();
26
27 void issueRequests(bool bStopIfNoSelection);
28 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
29 void menuItemClicked(const char* itemID);
30
31 bool closeLoop();
32 void showCuttingLoop();
33 void showCloseCuttingLoop();
34 void createNewCuttingLoop();
35 void cutObject();
36 bool addNewPartObject(set<int> partSet, bool move);
37 void optimalizeCuttingLoop();
38 void resetCuttingLoop();
39 void processPoint(osg::Vec3 point);
40
41
42 bool isMenu;
43 SnapObject * selectedObject;
44 vector<int> cuttingLoop;
45 SnapObject * soCuttingLoop;
46 bool pFirstActivation;
47 int lastAddedPoint;
48 EnvironmentObject *owner;
49 unsigned long freeID;
50
51 osg::Vec3 lastPosition, lastSelTest;
52
53 unsigned long selObjectID;
54 DynamicArray<int> intersectedObjects;
55
56 void resolveSelection();
57 EnvironmentObject* resolveIntersections(osg::Vec3 &position, std::vector<osg::Node*> **nodePath = NULL);
58 // [nodePath] can be NULL if not necessary.
59 };
60
61 }// end of namespace APSnap
62
63
64 #endif //CUT_H
65
66
67
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/CuttingPlane.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
CuttingPlane.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/ClipNode>
4 #include <osg/StateSet>
5
6 using namespace vrecko;
7
8 namespace behindO {
9
10 class CuttingPlane: public Ability {
11 public:
12 CuttingPlane();
13 ~CuttingPlane() {};
14
15 // ------ BaseClass functions ------------------------
17 void processEvent(const std::string &input_name, void *value);
18 // ---------------------------------------------------
19
20 void update(void);
21
22 protected:
23 int control;
24
25 std::vector<EnvironmentObject *> wire_object_map;
26 EnvironmentObject *cutting_object;
27 osg::ClipNode *clipnode, *clipnodeSS;
28 std::map<osg::Node *, osg::StateSet *> stateset_map;
29 osg::MatrixTransform *cutting_plane_transformation;
30
31 bool _first;
32
33 static int next_free_clipping_plane;
34 };
35
36 }
37
38 //$Id: CuttingPlane.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Cylinder.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Cylinder.h
Go to the documentation of this file.
1 #ifndef VF_CYLINDER
2 #define VF_CYLINDER
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Vec4>
7 #include <osg/Geode>
8 #include <osg/MatrixTransform>
9 #include <osg/Group>
10
11
12 using namespace vrecko;
13 using namespace vreckoDP_base;
14 namespace VirtualFixture{
15
16 class Cylinder: public PHANToMFilter {
17 public:
18 Cylinder();
19 ~Cylinder() {};
20
22 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
23 void processEvent(const std::string &input_name, void *value);
24
25 void preInitialize(void);
26 void postInitialize(void);
27 void update(void);
28
29 void display(void); //show or hide VF_cylinder object
30
31 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
32 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
33
34 protected:
35 PHANToM *PHANToMDevice;
36 bool all_on;
37 bool active; //VF switcher
38 bool visible; //if geometry of VF vill be shown on screen
39 osg::MatrixTransform *tnode; //transform node pointer
40 osg::Group *gnode; //group pointer
41 osg::Geode *node; //geometry node pointer (for bouning cylinder)
42 osg::Geode *node2; //geometry node2 pointer (for center cylinder)
43 float transparency; //transparency of VF geometry (interval (0,1), 1 = invisible)
44 float transparency2; //transparency of VF geometry (interval (0,1), 1 = invisible) inner cylinder
45 osg::Vec4 color; //VF color (of whole geometry)
46 osg::Vec4 color2; //VF color2 (of center)
47 osg::Vec3 position; //position of starting point
48 osg::Vec3 vector; //vector on cylinder axis (from bottom to top)
49 float radius; //cylinder radius (maximum range of attractive field)
50 float nullradius; //radius close to centre, where attractive field is NOT applied
51 float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
52 float pushingforce; //pushing force along the vector
53 bool pushing; //if true push PHANToM along the vector
54 };
55 };
56
57 #endif
58
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/CylindricalJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
CylindricalJoint.h
Go to the documentation of this file.
1 #ifndef CylindricalJoint_h
2 #define CylindricalJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class CylindricalJoint : public BaseJoint
15 {
16 public:
17 CylindricalJoint():BaseJoint("CylindricalJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
21 {
22 BaseJoint::loadXMLParameters(parametersNode);
23 return true;
24 }
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
26 {
27 return BaseJoint::getXMLParameters(domdocument);
28 }
29
30 protected:
31 NxCylindricalJointDesc _descripter;
32
33 };
34 }
35
36 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DAEnvironment.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
DAEnvironment.h
Go to the documentation of this file.
1 #pragma once
2
3
4 XERCES_CPP_NAMESPACE_USE
5
6 #include <vector>
7
8
9 #include "DATool.h"
10 //#include "ToolBrush.h"
11 #include "ToolTongs.h"
12
13
14 #include "PoA.h"
15 #include "PoB.h"
16
17 #include "Controller.h"
18
19 #include "../../vreckoAP/LightsEditor/Lights.h"
20
21
22
23
24 using namespace vrecko;
25
26 namespace APDYNAMICART
27 {
28
29
31
49 class DAEnvironment: public Ability {
50
51 public:
52
53 DAEnvironment();
54 ~DAEnvironment();
55
57
62 //void addPoB(PoB* newPoB, bool movable);
63
64 void enableGUI( bool enable );
65
67
70 Controller* getController(PoAType type);
71
72 //TODO ? move this to private ?
74 osg::ref_ptr<EnvironmentObject> rightHandEO;
75
76 //TODO ? move this to private ?
78 osg::ref_ptr<EnvironmentObject> leftHandEO;
79
80 //returns time elapsed from beginning of painting
81 double getElapsedArtTime();
82
83 osg::Vec3 getLeftHandPosition() const { return this->LHPosition; }
84 osg::Quat getLeftHandOrientation() const { return this->LHOrientation; }
85 osg::Vec3 getRightHandPosition() const { return this->RHPosition; }
86 osg::Quat getRightHandOrientation() const { return this->RHOrientation; }
87
88 bool getObjectSelectionActiveRight() const { return _objectSelectionActiveRight; }
89 void setObjectSelectionbyRightHand(bool val) { _objectSelectionActiveRight = val; }
90
91 bool getAutoRotationActive() const { return _autoRotationActive; }
92 void setAutoRotationActive(bool val) { _autoRotationActive = val; }
93
94 static DAEnvironment *getInstance() { return _selfPointer; }
95 double getLoadedArtTime() const { return _loadedArtTime; }
96
97 //obsloleted - replaced by GUI color picker
99
105 //void chooseColorbyColorChooser(ref_ptr_PoA rp_poa);
106
112 void listDirectory(const string& dirpath, const string& mask, std::vector<string>* fileNames);
113
114 void preInitialize();
115 void postInitialize();
116
117 void CreateMenuAbilities();
118
119 //obsoleted - replaced by METHOD_INPUTS..,
120 //void processEvent(const std::string &input_name, void *value);
121
128 typedef bool (*func)(const string& id, void* value, void* userData);
129
130 void setUpCustomProcessEventCallback(bool (*func)(const std::string &input_name, void *value, void* userData), void* userData) {
131 _callback = func;
132 _userData = userData;
133 }
134
135
136 void update();
137
138 //obsoleted - replaced by METHOD....
143 //void* processRequest(const std::string &strInputName, void *pValue);
144
145 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
146 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
147
148
149
150 private:
151
153
157 static DAEnvironment * _selfPointer;
158
160 bool _audienceMode;
161
163
170 std::vector<Controller* > _controllers;
171
172 //TODO could there be referenced pointer?
173 Controller* _actualController;
174
175
176 // Tracker attributes
177 osg::Vec3 RHPosition;
178 osg::Vec3 RHUntransPos;
179 osg::Quat RHOrientation;
180
181 osg::Vec3 LHPosition;
182 osg::Quat LHOrientation;
183
184 osg::Vec3 OldLHPosition;
185 osg::Quat OldLHOrientation;
186
187
188 //DA area attributes
189
191 /*
192 * Owner of this ability
193 *
194 * Contains:
195 * - all PoA objects.
196 * - some PoB objects.
197 * - abilities:
198 * - _controllers
199 * - tools
200 *
201 */
202 EnvironmentObject* _DAArea;
203
204 osg::Quat DAAreaOrientation;
205 osg::Vec3 DAAreaPosition;
206 osg::Vec3 DAAreaScale;
207
209 osg::ref_ptr<EnvironmentObject> templateObject;
210
211
212 // Selection by pointing
214 unsigned int lastSelectedID_Left;
215 unsigned int lastSelectedID_Right;
216
218 bool objectPointedRight;
219 bool objectPointedLeft;
220
223 ref_ptr_PoA lastSelectedPoA_Left;
224
226 ref_ptr_PoA lastSelectedPoA_Right;
227
228
229
230 // Rendering
231 bool wireframeRendering;
232
233
234 //Scaling
235 osg::Vec3 OldScalePosition;
236 osg::Vec3 OldStepScalePosition; // step-wise scaling
237 osg::Vec3 OldScalePositionTrans; // transformed
238
239 double DAAScaleStep;
240 double minDAAScale;
241 double maxDAAScale; // max Scale Factor
242 double maxHandMovement; // scope of movement of hand
243
244 //Auto-rotation
245 double autoRotationStep;
246 double ARDefaultAngle;
247 osg::Timer_t lastAutorotationTime, nowAutorotationTime;
248
249 int _icontoDeactivate;
250
251
252 //User settings
253 bool _castShadows;
254 bool _DAAreaManipulationActive;
255 //bool IndirectDAAreaManipulationActive; ///< not used anymore?? (rotation using some kind of gizmo. Enables more precise rotations and rotation around one of basic axes - X,Y,Z )
256 bool _autoRotationActive;
257 bool _globalAxisAutoRotation;
258 bool _scaleChangeActive; // scaling by moving hand
259 bool _colorChooserActive;
260
261
263
267 bool _objectSelectionActiveRight;
268 bool _objectSelectionActiveRight_old;
269
270 // see _objectSelectionActiveRight
271 bool _objectSelectionActiveLeft;
272 bool _objectSelectionActiveLeft_old;
273
275 bool _isMainMenuActive;
276
278 bool _isPoAMenuActive;
279
280 int stepScaleChangeActive;
281
282
283 //Auto-save
284 time_t _autosaveStartTime, _autosaveDeltaTime;
285 int _autoSaveTime;
286 int _lastSaveTime;
287 char _retezec[100];
288
290 osg::Vec3 displacementDistance;
291 osg::Vec3 displacementStep;
292 int defaultDisplaceAnimTime;
293 int displaceAnimTime;
294
295 //Menu
296 std::vector<std::string>* fileList;
297
298 time_t _artWorkStartTime;
299 double _loadedArtTime;
300
301
303
305 bool addController(std::string name, DOMNode* parameters);
306
308 void clear();
309
310
312 std::string DAEnvironment::createMenuStructure();
313
315 //void evokeColourChooser();
316
317 //gets
321 inline std::string getAutoRotationString() const;
322
326 inline std::string getCastShadowString() const;
327
331 std::string getNewFileName(const std::vector<std::string>* fileList);
335 inline std::string getRenderingMethodString() const;
336
340 inline std::string getSwitchModeString() const;
341
342
344 /*
345 *
346 * \param fileName file to import
347 * \return code error. 0 means everything went good
348 */
349 int importScene( const string& fileName );
350
352
355 void guiItemClicked( const char* itemID, const int sensorNumber);
356
358
362 void guiSliderChanged(const char* sliderID, float sliderPos);
363
365 double rescaleDAArea(double dist, double oldValue, double minValue, double maxValue);
366
368 void ResetDAArea();
369
371
384 int loadDAScene(const string& fileName);
385
387
392 int loadTemplate(const string& fileName);
393
395
399 void saveDAScene(const string& filePath, const string& fileName);
400
402
409 void selectObject(bool rightHand, unsigned long selectedID);
410
412 void showInfo() const;
413
415 void switchContext(PoAType newContext);
416
418 void switchModes();
419
421
424 void switchRenderingMethod();
425
429 bool customProcessEvent(const string& input_name, void* value, void* userData, bool (*func)(const string& input_name, void* value, void* userData));
430
431 func _callback;
432 void* _userData;
433 bool firstTimeUpdate;
434
435 void scaleDAArea();
436 void daAreaManipulation();
437 void objectSelection();
438
439 unsigned int checkSelectedObject(int sensorNumber);
440
441 //Menu
442 APGUI::Menu *mainMenuAbility;
443
444
445 // see INIT_INPUT macros for commentary of these...
446
447 //TODO change these to Sensor_position ??
448 DECLARE_INPUT(Sensor_0_position, MessageVec3);
449 DECLARE_INPUT(Sensor_1_position, MessageVec3);
450 DECLARE_INPUT(Sensor_0_orientation, MessageQuat);
451 DECLARE_INPUT(Sensor_1_orientation, MessageQuat);
452
453 DECLARE_REQUEST_INPUT(Sensor_0_actionMain, MessageBool, MessageBool);
454 DECLARE_REQUEST_INPUT(Sensor_1_actionMain, MessageBool, MessageBool);
455
456 //obsoleted
457 //DECLARE_REQUEST_INPUT(PointerPosition, MessageInt, MessageVec3);
458 //DECLARE_REQUEST_INPUT(PointerOrientation, MessageInt, MessageQuat);
459
460 DECLARE_INPUT(ResetDAArea, MessageBool);
461 DECLARE_INPUT(ScaleDAArea, MessageInt);
462 DECLARE_INPUT(ChangeAutoRotationSpeed, MessageInt);
463
464 DECLARE_INPUT(SwitchTool, MessageBool);
465
466 DECLARE_INPUT(Colour, MessageVec4);
467
468 DECLARE_INPUT(SwitchRenderingMethod, MessageBool);
469 DECLARE_INPUT(QuickLoad, MessageBool);
470 DECLARE_INPUT(QuickSave, MessageBool);
471 DECLARE_INPUT(Autorotation, MessageBool);
472 DECLARE_INPUT(DebugPurposeKey, MessageBool);
473 DECLARE_INPUT(Import, MessageBool);
474
475 DECLARE_INPUT(MenuItemClicked, MessageString);
476 DECLARE_INPUT(GUIItemClicked, MessageString);
477 DECLARE_INPUT(CreateMenuStructure, MessageInt);
478 DECLARE_INPUT(HidingMenu, MessageBool);
479 DECLARE_INPUT(ExternalDeactivation, MessageObjectID);
480 DECLARE_INPUT(SwitchGUIVisibility, MessageBool);
481
482 DECLARE_OUTPUT(MenuStructure, MessageString);
483 DECLARE_OUTPUT(SwitchLayout, MessageString);
484
485
486 // asking about what object is actually selected - Input Connector should answer
487 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
488
489
490
491 };
492
493 }
494
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DATool.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
DATool.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "PoA.h"
4 #include <vreckoUtils\Observer.h>
5
6 using namespace vrecko;
7
8 namespace APDYNAMICART
9 {
10
11 // DATool type enumeration
12 typedef enum DAToolType {
13 TOOL__BRUSH = 1,
14 TOOL__TONGS,
15 TOOL__ERASER,
16 TOOL__SLICE,
17 TOOL__MAGICWAND,
18 TOOL__NEST,
19 TOOL__MAGNET,
20 TOOL__PERLIN_LINES_CONTROLLER,
21 TOOL__SELECTOR,
22 TOOL__ROTATION,
23 TOOL__HOOK
24 };
25
27
34 class DATool : public Ability, public vreckoUtils::Observable, public osg::Referenced {
35 public:
36
37 DATool(const char* abilityName);
38 ~DATool();
39
40
42 /*
43 * Called when user want to use tool - paint with brush, deform with magnet, ...
44 * Called from appropriate controller, when "UseTool" event is evoked
45 *
46 * \param _poa PoA object that tool will work with
47 */
48 virtual void activate() = 0;
49
50
52 /*
53 *
54 * \param parent Parent EO - usually left or right virtual hand
55 * \param fileName file with geometry of cursor (.3ds, .obj, ...)
56 *
57 */
58 void createCursor(EnvironmentObject* parent, string fileName);
59
60
61
63 /*
64 * Called when user want to stop using tool
65 *
66 */
67 virtual void deactivate() = 0;
68
69
70 EnvironmentObject* getCursor() {return this->_cursor; }
71 DAToolType getType() {return toolType; }
72
73 osg::Vec3* getSize() {return this->size; }
74
75 bool isActive() { return this->active; }
76
78 void setSize(osg::Vec3 p_size);
79
81 void setPoA(osg::ref_ptr<PoA> newPoa) { this->_poa = newPoa; }
82
84 /*
85 * Called when user switch from another tool to this tool.
86 * if necessary, add new interconnections - "running" tool will receive events... e.g. about position and orientation of hand.
87 * Show visual cursor of tool, if exists.
88 *
89 */
90 virtual void turnOn() = 0;
91
93 /*
94 * Called when user switch from this tool to another tool.
95 * Delete existing interconnections - "stoped" tool doesn't need to receive any events
96 * Hide visual cursor, if exists
97 *
98 */
99 virtual void turnOff() = 0;
100
101
102 protected:
103
105 DAToolType toolType;
106
107 DAEnvironment* _daEnvironment;
108 EnvironmentObject* _daArea;
109
111 bool active;
112
113 osg::ref_ptr<PoA> _poa;
114
116
120 osg::ref_ptr<EnvironmentObject> _cursor;
121
123 osg::Vec3 *size;
124
125 };
126
127 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect/DP_Kinect.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • Kinect
DP_Kinect.h
Go to the documentation of this file.
1 #include <vrecko/Device.h>
2
3 #include <vreckoDP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8
9
10 extern "C" const char DP_EXPORT **getDeviceList(void);
11 extern "C" vrecko::Device DP_EXPORT *getDeviceInstance(const char *_name);
12 extern "C" const char DP_EXPORT *getDeviceDescription(const char *name);
13 extern "C" void DP_EXPORT setDevicesParameters(void);
14 extern "C" const char DP_EXPORT *getPluginDescription(void);
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM/DP_PHANToM.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • PHANToM
DP_PHANToM.h
Go to the documentation of this file.
1 #include <vrecko/Device.h>
2
3 #include <vreckoDP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8
9 extern "C" const char DP_EXPORT **PHANToM_getDeviceList(void);
10 extern "C" vrecko::Device DP_EXPORT *PHANToM_getDeviceInstance(const char *_name);
11 extern "C" const char DP_EXPORT *PHANToM_getDeviceDescription(const char *name);
12 extern "C" void DP_EXPORT PHANToM_setDevicesParameters(void);
13 extern "C" const char DP_EXPORT *PHANToM_getPluginDescription(void);
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/DP_base.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
DP_base.h
Go to the documentation of this file.
1 #include <vrecko/Device.h>
2
3 #include <vreckoDP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "A3DBird.h"
10 #include "fdtDataGlove.h"
11 #include "fsPinchGlove.h"
12 #include "KeyboardMouse.h"
13 #include "LHeadTracker.h"
14 #include "L3DMouse.h"
15 #include "MicroScribe3D.h"
16 #include "NestOfBirds.h"
17 #include "Ultratrak.h"
18 #include "OptiTrack.h"
19 #include "VRPN3DMouse.h"
20 #include "Wiimote.h"
21 // ------------------------------
22
23
24 extern "C" const char DP_EXPORT **base_getDeviceList(void);
25 extern "C" Device DP_EXPORT *base_getDeviceInstance(const char *_name);
26 extern "C" const char DP_EXPORT *base_getDeviceDescription(const char *name);
27 extern "C" void DP_EXPORT base_setDevicesParameters(void);
28 extern "C" const char DP_EXPORT *base_getPluginDescription(void);
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Damper.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Damper.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4 using namespace vrecko;
5 using namespace vreckoDP_base;
6 namespace VirtualFixture{
7
8 class Damper: public PHANToMFilter {
9 public:
10 Damper();
11 ~Damper() {};
12
14 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
15 void processEvent(const std::string &input_name, void *value);
16
17 void preInitialize(void);
18 void postInitialize(void);
19 void update(void);
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 protected:
25 PHANToM *PHANToMDevice;
26 bool all_on;
27 bool active; //if true, attractive field will be active
28 float minspeed; //if velocity is less then minspeed damper will be inactive
29 float speed2force; //damping coeficient
30 };
31
32 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/DampingForceFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
DampingForceFilter.h
Go to the documentation of this file.
1 #ifndef DAMPING_FORCE_FILTER_H
2 #define DAMPING_FORCE_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 class DampingForceFilter : public PHANToMFilter {
11 public:
12 DampingForceFilter();
13
14 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
15
16 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
17
18 void setAverageCount(int iNewAverageCount);
19
20 protected:
21 float fMaxChangePerStep;
22 // Maximum 3D distance between two points defined by successive force vectors.
23 // If the distance is larger, the new force will be shifted to be closer to the older one.
24 int iAverageCount;
25 // How many previous samples should be averaged? (1 = same as no averaging)
26
27 struct PrevData {
28 public:
29 osg::Vec3 pos;
30 osg::Vec3 force;
31 };
32
33 DynamicArray<PrevData> prevData;
34 // osg::Vec3 lastForceResult;
35
36 float fDampingLin, fDampingVel, fDampingAcc;
37 };
38
39 }
40
41 #endif
42
43 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/Default.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Default.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_DEFAULT_H
10 #define VRECKO_NATURE_TERRAIN_DEFAULT_H
11
12 #include <osg/Vec2>
13 #include <osg/Vec3f>
14 #include <string>
15
16 #include "Enumerations.h"
17
18 namespace APNature
19 {
20 static class Default
21 {
22 public:
23
24 // Common attributes
25 // =================
26 static const osg::Vec3f Position;
27 static const TerrainAlignment AlignmentX, AlignmentY;
28
29 static const osg::Vec2f FieldSize;
30 static const float HeightMin, HeightMax;
31
32 // DataSource attributes
33 // =====================
34 static const DataSourceType DataSourceType;
35 static const int SegmentSize;
36
37 // Algorithm-type specific attributes
38 // ==================================
39 static const AlgorithmType AlgorithmType;
40 static const int ResolutionX, ResolutionY;
41
42 static const int RandomSeed;
43
44 // Random faults algorithm
45 static const int Iterations;
46 static const float FaultValueMin, FaultValueMax;
47
48 // Midpoint displacement
49 static const float FractalDimension;
50 static const float CornerValueFrom, CornerValueTo;
51
52 // Perlin noise algorithm
53 static const float Persistence;
54 static const int OctaveCount;
55 static const InterpolationType Interpolation;
56
57 // Image-type specific attributes
58 static const std::string HeightMapPath;
59
60 // Other attributes
61 // ================
62 static const osg::Vec3f TerrainViewScale;
63 static const std::string HeightMapSearchPath;
64 static const std::string ExportPathRoot;
65 static const std::string FileFormats[];
66
67 } Default;
68
69 }
70
71 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Device.h Source File

  • File List
  • File Members
  • include
  • vrecko
Device.h
Go to the documentation of this file.
1 /***************************************************************************
2 device.h - description
3 -------------------
4 begin : May 2002
5 copyright : (C) 2002 by Jan Flasar, Ludek Pokluda
6 email : flasar|xpokluda@fi.muni.cz
7 ***************************************************************************/
8
9 #ifndef DEVICE_H
10 #define DEVICE_H
11
12 #include <vrecko/BaseClass.h>
13 #include <vrecko/Export>
14 #include <vreckoDP/Export>
15
16 #include <string>
17 #ifndef WIN32
18 #include <unistd.h>
19 #endif
20
21 #define BASE_CALIBRATION_STRING "Sorry, no information."
22
23
24 namespace vrecko {
25
27 class VRECKO_EXPORT Device: public BaseClass {
28 public:
29 //Device() {}; -> no default constructor -> forcing to create a device with a name
30 Device(const char* startingDeviceName, const char *pname = "");
31 virtual ~Device() {};
32
34 inline int getID(void) {return id;}
35
37 void setID(int new_id);
38
40 inline const std::string &getDeviceType(void) {return device_type;}
41
43 void setPortName(const char *pname) {port_name = pname;}
44
46 inline const char *getPortName(void) {return port_name.c_str();}
47
49 virtual int openDevice(void) = 0;
50
52 virtual int closeDevice(void) = 0;
53
55 virtual int calibrateDevice(void) {return 0;}
56
58 virtual const std::string getCalibrationString(void) {return BASE_CALIBRATION_STRING;}
59
61 virtual void update(void) = 0;
62
63 protected:
65 int id;
67 std::string device_type;
69 std::string port_name;
70 };
71
72 }
73
74 #endif
75
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/DeviceManager.h Source File

  • File List
  • File Members
  • include
  • vrecko
DeviceManager.h
Go to the documentation of this file.
1 /***************************************************************************
2 devicemanager.h - description
3 -------------------
4 begin : March 2003
5 copyright : (C) 2003 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9
10 #ifndef DEVICEMANAGER_H
11 #define DEVICEMANAGER_H
12
13 #include <vrecko/BaseClass.h>
14 #include <vrecko/Device.h>
15 #include <vrecko/vThread.h>
16
17 #include <map>
18 #include <vector>
19
20 #include <osgDB/DynamicLibrary>
21
22
23 namespace vrecko {
24
26 class VRECKO_EXPORT DeviceManager : public BaseClass {
27 public:
28 DeviceManager();
29 ~DeviceManager();
30
33 int requestForDevice(const std::string &plugin_name, const std::string &device_type, const char *port, float frequency);
34
37 bool requestForDevice(const std::string &plugin_name, const std::string &device_type, const char *port, int id, float frequency);
38
40 Device* getDevicePtr(int device_id);
41
43 Device* getDevicePtrByType(const std::string &device_type);
44
46 struct DT {
47 Device *devicePtr;
48 vThread *threadPtr;
49 };
50
52 std::map<int, DT> &getDeviceMap(void) {return device_map;}
53
54 static vrecko::Device *getDeviceInstance(const std::string &plugin_name, const std::string &device_type);
55
56 protected:
58 std::map<int, DT> device_map;
59
61 bool connectDevice(const std::string &plugin_name, const std::string &device_type, const char *port, Device **device_ptr);
62
63 static std::map<std::string, osgDB::DynamicLibrary *> _dl_map;
64
65 };
66
67 }
68
69 #endif
70
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/DiameterGenAdapter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
DiameterGenAdapter.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Referenced>
3 #include "Utils.h"
4 #include "types.h"
5 #include "DiameterGen.h"
6 #include <xercesc\dom\DOMImplementation.hpp>
7 #include "ConstantDiameterGen.h"
8 #include "GradientDiameterGen.h"
9
10 namespace APDYNAMICART
11 {
12
13 typedef PoAAdapter<DiameterGen> DiameterGenAdapter;
14
16 class ConstantDiamAdapter : public DiameterGenAdapter
17 {
18 public:
19 ConstantDiamAdapter() : _diamGen(new ConstantDiameterGen(0.3)) {}
20 ConstantDiamAdapter(double val): _diamGen(new ConstantDiameterGen(val)) {}
21
22 META_DAObject(ConstantDiamAdapter, "Constant")
23
24 virtual osg::ref_ptr<DiameterGen> getObject() { return _diamGen; }
25 virtual void createMenu( MenuPtr menu );
26 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
27 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
28 virtual bool sliderChanged( const char* sliderID, float sliderPos );
29
30 protected:
31 osg::ref_ptr<ConstantDiameterGen> _diamGen;
32 };
33
35 class GradientDiamAdapter : public DiameterGenAdapter
36 {
37 public:
38 GradientDiamAdapter() : _diamGen(new GradientDiameterGen) {}
39 GradientDiamAdapter(double diam1, double diam2) : _diamGen(new GradientDiameterGen(diam1, diam2)) {}
40 META_DAObject(GradientDiamAdapter, "Gradient")
41
42 virtual osg::ref_ptr<DiameterGen> getObject() { return _diamGen; }
43 virtual void createMenu( MenuPtr menu );
44 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
45 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
46 virtual bool sliderChanged( const char* sliderID, float sliderPos );
47
48 protected:
49 osg::ref_ptr<GradientDiameterGen> _diamGen;
50
51 };
52
54 class DiameterGenFactory : public AdapterFactory<DiameterGenAdapter>
55 {
56 public:
57 DiameterGenFactory()
58 {
59 _adapters.push_back(new ConstantDiamAdapter);
60 _adapters.push_back(new GradientDiamAdapter);
61 }
62
63 DiameterGenFactory( const DiameterGenFactory& orig )
64 {
65
66 std::vector<osg::ref_ptr<DiameterGenAdapter>> origAdapters = orig.getSupportedAdapters();
67
68 DiameterGen *tmpGen = (origAdapters[0]->getObject()).get();
69 ConstantDiameterGen *tmpCDGen = dynamic_cast<ConstantDiameterGen *>(tmpGen);
70 _adapters.push_back(new ConstantDiamAdapter(tmpCDGen->getDiameterValue()));
71
72 tmpGen = (origAdapters[1]->getObject()).get();
73 GradientDiameterGen *tmpGDGen = dynamic_cast< GradientDiameterGen *>(tmpGen);
74 _adapters.push_back(new GradientDiamAdapter(tmpGDGen->getDiameterStart(), tmpGDGen->getDiameterEnd()) );
75 }
76 };
77
78
79
80 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Display.h Source File

  • File List
  • File Members
  • include
  • base
Display.h
Go to the documentation of this file.
1 #ifndef DISPLAY_H
2 #define DISPLAY_H
3
4 #include <vrecko/Ability.h>
5
6 #include <osg/Geode>
7 #include <osgText/Text>
8 #include <osgText/Font>
9 #include <osg/BlendFunc>
10 #include <osg/Material>
11 #include <osg/StateSet>
12
13 #include <vector>
14
15 using namespace vrecko;
16
17 namespace base {
18
19 class Display: public Ability {
20 public:
21 Display();
22 ~Display() {};
23
24 void initialize(void) {};
25 void update(void);
26
27 // TODO MESSAGE_REVOLUTION - the Display ability seems to be OBSOLETE anyway
28 // std::string getAcceptableMessages(void) {return "Text";}
29 // Message *getMessage(void) {return NULL;}
30
31 protected:
32 osgText::Text **_display_line;
33 std::vector<std::string> _text_history;
34 osg::Geode *_text_geode;
35 osg::Material *_text_material;
36 osg::StateSet *_text_state;
37 osgText::Font *_texture_font;
38 osgText::Font *_polygon_font;
39 int _font_size;
40 osg::BlendFunc *_transp;
41
42 float _start_x, _start_y;
43 float _line_height;
44 int _line_count;
45
46 bool _first;
47 };
48
49 }
50
51 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/DistanceJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
DistanceJoint.h
Go to the documentation of this file.
1 #ifndef DistanceJoint_h
2 #define DistanceJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class DistanceJoint : public BaseJoint
15 {
16 public:
17 DistanceJoint():BaseJoint("DistanceJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
21 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument);
22
23 protected:
24 NxDistanceJointDesc _descripter;
25
26 };
27 }
28
29 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Drag.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Drag.h
Go to the documentation of this file.
1 #ifndef VF_DRAG
2 #define VF_DRAG
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7 #include "mvect++.h"
8
9 #include <string>
10
11 using namespace vrecko;
12 using namespace vreckoDP_base;
13 using namespace mv;
14
15 namespace VirtualFixture{
16
17 class Drag: public PHANToMFilter {
18 public:
19 Drag();
20 ~Drag() {};
21
23 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
24 void processEvent(const std::string &input_name, void *value);
25 void dispatchEvent(const std::string &pInputName, void *pValue);
26 void dispatchMessage(Message* pMessage);
27
28 void preInitialize(void);
29 void postInitialize(void);
30 void update(void);
31
32 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
33 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
34
35 void displayAllGestures(void);
36
37 protected:
38 PHANToM *PHANToMDevice;
39 bool all_on;
40 bool active; //VF switcher
41 bool force; //switch in mvect++ lib (if force is returned or position)
42 osg::Vec3 position; //position of starting point
43 // float nullradius; //radius close to centre, where attractive field is NOT applied
44 // float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
45
46 CPlayer *player; //pointer to instance of player (is only one in system)
47 };
48
49 };
50 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/DynamicArray.h Source File

  • File List
  • File Members
  • include
  • helpers
DynamicArray.h
Go to the documentation of this file.
1 #ifndef DYNAMICARRAY_H
2 #define DYNAMICARRAY_H
3
4 // dynamically allocated array
5
6 #include <new>
7
8 #ifdef _DEBUG
9 #define DAINLINE
10 #else
11 #define DAINLINE inline
12 #endif
13
14 namespace VK_NoStepInto_Namespace {
15
16 template <class _Type>
17 class DynamicArray {
18 protected:
19 unsigned long dwAllocBy;
20 unsigned long dwAlloc; // number of items allocated
21 unsigned long dwInited; // number of items initialized
22
23 // this should be true: dwNum <= dwInited <= dwAlloc
24
25 bool InitItems (unsigned long dwStartIndex, unsigned long dwNumStructs);
26
27 public:
28 _Type *lpBuffer;
29 unsigned long dwNum; // number of fields used
30 DAINLINE unsigned long GetAllocated();
31
32 DynamicArray (void);
33 DynamicArray (unsigned long _dwAllocBy);
34 DynamicArray (DynamicArray<_Type> &src);
35 ~DynamicArray (void);
36
37 DAINLINE const unsigned int size() const { return dwNum; };
38 // to achieve greater similarity with std::vector
39
40 DAINLINE void push_back(const _Type& elem) { AddItem(elem); }
41
42 bool FreeArray (void);
43
44 bool Truncate (void);
45 // Lowers size of allocated memory to exact number of allocated items.
46
47 bool PrepareNext (unsigned long _dwNum);
48
49 bool Delete (unsigned long dwStartIndex, unsigned long dwNumStructs);
50
51 DAINLINE bool DeleteAll(void);
52 inline bool clear(void) { DeleteAll(); };
53 // to achieve greater similarity with std::vector
54
55 DAINLINE bool DeleteUnnecessary (void);
56
57 bool Insert (unsigned long dwStartIndex, unsigned long dwNumStructs);
58
59 bool CopyFrom (DynamicArray<_Type> *src);
60 // Deletes everything and copies items from given array.
61 // If the parameter is NULL, it only destroys everything.
62
63 bool Swap (unsigned long dwIndex1, unsigned long dwIndex2);
64
65 DAINLINE bool AddItem (const _Type& newItem);
66 // Add item at the end of the array
67
68 DAINLINE _Type &Last (void);
69
70 DAINLINE _Type &Act (void);
71 DAINLINE unsigned long &ActDWORD (void);
72 DAINLINE int &ActInt (void);
73
74 DAINLINE _Type &Get(unsigned long index) { return (*this)[index]; }
75 DAINLINE const _Type &Get(unsigned long index) const { return (*this)[index]; }
76
77 DAINLINE bool StoreByte (unsigned char bData);
78 // !!! WARNING !!! Can be only used in arrays, which have size of item = 1 byte !!!
79 // It also calls PrepareNext.
80 DAINLINE bool StoreDWORD (unsigned long dwData);
81 // !!! WARNING !!! Can be only used in arrays, which have size of item = 1, 2 or 4 bytes !!!
82 // It also calls PrepareNext.
83
84 DAINLINE unsigned char ReadByte (void);
85 // !!! WARNING !!! Can be only used in arrays, which have size of item = 1 byte !!!
86 DAINLINE unsigned long ReadDWORD (void);
87 // !!! WARNING !!! Can be only used in arrays, which have size of item = 1, 2 or 4 bytes !!!
88
89 DAINLINE _Type &operator[](unsigned long dw);
90 DAINLINE const _Type &operator[](unsigned long dw) const;
91
92 DAINLINE _Type &at(unsigned long dw) { return lpBuffer[dw]; };
93 DAINLINE const _Type &at(unsigned long dw) const { return lpBuffer[dw]; };
94 };
95
96 template <class _Type>
97 DynamicArray<_Type>::DynamicArray (void)
98 {
99 dwAllocBy = 1;
100
101 dwNum = 0;
102 dwInited = 0;
103
104 lpBuffer = NULL;
105 dwAlloc = 0;
106 }
107
108
109 template <class _Type>
110 DynamicArray<_Type>::DynamicArray (DynamicArray<_Type> &src)
111 {
112 dwAllocBy = src.dwAllocBy;
113
114 dwNum = 0;
115 dwInited = 0;
116
117 lpBuffer = NULL;
118 dwAlloc = 0;
119
120 CopyFrom (&src);
121 }
122
123
124 template <class _Type>
125 DynamicArray<_Type>::DynamicArray (unsigned long _dwAllocBy)
126 {
127 dwAllocBy = _dwAllocBy;
128
129 dwNum = 0;
130 dwInited = 0;
131
132 lpBuffer = NULL;
133 dwAlloc = 0;
134 }
135
136
137 template <class _Type>
138 DynamicArray<_Type>::~DynamicArray (void)
139 {
140 FreeArray ();
141 }
142
143 template <class _Type>
144 unsigned long DynamicArray<_Type>::GetAllocated()
145 {
146 return dwAlloc;
147 }
148
149 template <class _Type>
150 bool DynamicArray<_Type>::FreeArray (void)
151 {
152 if (!DeleteAll ())
153 return false;
154
155 if (lpBuffer) {
156 free (lpBuffer);
157 lpBuffer = NULL;
158 }
159 dwAlloc = dwNum = dwInited = 0;
160
161 return true;
162 }
163
164
165 template <class _Type>
166 bool DynamicArray<_Type>::Truncate (void)
167 {
168 unsigned long dw = dwAlloc - dwNum;
169
170 if (!dw)
171 return true;
172
173 if (!Delete (dwNum, dw))
174 return false;
175
176 void *tmpMem;
177
178 tmpMem = (_Type*)malloc (dwNum * sizeof (_Type));
179 if (!tmpMem && dwNum)
180 return false;
181 memcpy (tmpMem, lpBuffer, dwNum * sizeof (_Type));
182 free (lpBuffer);
183 lpBuffer = (_Type*)tmpMem;
184 dwAlloc = dwNum;
185 dwInited = dwNum;
186
187 return true;
188 }
189
190
191 template <class _Type>
192 bool DynamicArray<_Type>::PrepareNext (unsigned long _dwNum)
193 {
194 unsigned long dw;
195 unsigned long dwNN = dwNum + _dwNum;
196
197 if (dwNN <= dwInited)
198 return true;
199
200 if (dwNN > dwAlloc) {
201
202 void *tmpMem;
203 unsigned long dwLAlloc = dwAlloc;
204
205 #if 0
206 dw = ((dwNN + dwAllocBy - 1) / dwAllocBy) * dwAllocBy;
207 #else
208 dw = dwNN + dwAllocBy - 1;
209 dw = dw - (dw % dwAllocBy);
210 #endif
211
212
213 tmpMem = (_Type*)malloc (dw * sizeof (_Type));
214 if (!tmpMem)
215 return false;
216
217 if (lpBuffer) {
218 memcpy (tmpMem, lpBuffer, dwInited * sizeof (_Type));
219 free (lpBuffer);
220 }
221
222 dwAlloc = dw;
223
224 lpBuffer = (_Type*)tmpMem;
225
226 }
227
228 if (!InitItems (dwInited, dwNN - dwInited))
229 return false;
230 dwInited = dwNN;
231
232 return true;
233 }
234
235
236 template <class _Type>
237 bool DynamicArray<_Type>::InitItems (unsigned long dwStartIndex, unsigned long dwNumStructs)
238 {
239 unsigned long dw;
240
241 for (dw = dwStartIndex; dw < dwStartIndex + dwNumStructs; dw++) {
242 new ((void*)(lpBuffer + dw)) _Type;
243 }
244
245 return true;
246 }
247
248
249 template <class _Type>
250 bool DynamicArray<_Type>::Delete (unsigned long dwStartIndex, unsigned long dwNumStructs)
251 {
252 if ((dwStartIndex >= dwAlloc) || (dwStartIndex >= dwInited) || (!dwNumStructs))
253 return true;
254
255 unsigned long dw;
256
257 if (dwStartIndex + dwNumStructs > dwInited)
258 dwNumStructs = dwInited - dwStartIndex;
259
260 for (dw = dwStartIndex; dw < dwStartIndex + dwNumStructs; dw++)
261 ((_Type*)(lpBuffer + dw))->~_Type ();
262
263
264 memcpy (lpBuffer + dwStartIndex, lpBuffer + dwStartIndex + dwNumStructs, (dwInited - dwNumStructs - dwStartIndex) * sizeof (_Type));
265
266 dwInited -= dwNumStructs;
267
268 if (dwStartIndex < dwNum) {
269 if (dwStartIndex + dwNumStructs < dwNum)
270 dwNum -= dwNumStructs;
271 else
272 dwNum = dwStartIndex;
273 }
274
275 return true;
276 }
277
278
279 template <class _Type>
280 DAINLINE bool DynamicArray<_Type>::DeleteAll (void)
281 {
282 return Delete (0, dwAlloc);
283 }
284
285
286 template <class _Type>
287 DAINLINE bool DynamicArray<_Type>::DeleteUnnecessary (void)
288 {
289 if (dwInited <= dwNum)
290 return true;
291
292 return Delete (dwNum, dwInited - dwNum);
293 }
294
295
296 template <class _Type>
297 bool DynamicArray<_Type>::Insert (unsigned long dwStartIndex, unsigned long dwNumStructs)
298 {
299 if (!dwNumStructs)
300 return true;
301
302 if (!PrepareNext (dwNumStructs))
303 return false;
304
305 if (dwStartIndex >= dwNum) {
306 dwNum += dwNumStructs;
307 return true;
308 }
309
310 _Type *tmpObjs = NULL;
311 if (!(tmpObjs = (_Type*)malloc (dwNumStructs * sizeof (_Type))))
312 return false;
313 memcpy (tmpObjs, lpBuffer + dwNum, dwNumStructs * sizeof (_Type));
314
315 unsigned long dw;
316 for (dw = dwNum + dwNumStructs - 1; dw >= dwStartIndex + dwNumStructs; dw--)
317 lpBuffer[dw] = lpBuffer[dw - dwNumStructs];
318 dwNum += dwNumStructs;
319
320 memcpy (lpBuffer + dwStartIndex, tmpObjs, dwNumStructs * sizeof (_Type));
321 free (tmpObjs);
322
323 return true;
324 }
325
326
327 template <class _Type>
328 bool DynamicArray<_Type>::CopyFrom (DynamicArray<_Type> *src)
329 {
330 FreeArray ();
331 if (!src)
332 return true;
333
334 lpBuffer = (_Type*)malloc (src->dwNum * sizeof (_Type));
335 if (!lpBuffer)
336 return false;
337
338 dwNum = dwAlloc = dwInited = src->dwNum;
339
340 unsigned long dw;
341 for (dw = 0; dw < src->dwNum; dw++) {
342 new ((void*)(lpBuffer + dw)) _Type (src->lpBuffer[dw]);
343 }
344
345 return true;
346 }
347
348
349 template <class _Type>
350 bool DynamicArray<_Type>::Swap (unsigned long dwIndex1, unsigned long dwIndex2)
351 {
352 if (dwIndex1 == dwIndex2)
353 return true;
354
355 if ((dwIndex1 >= dwInited) || (dwIndex2 >= dwInited))
356 return false;
357
358 _Type tmp;
359
360 memcpy (&tmp, lpBuffer + dwIndex1, sizeof (_Type));
361 memcpy (lpBuffer + dwIndex1, lpBuffer + dwIndex2, sizeof (_Type));
362 memcpy (lpBuffer + dwIndex2, &tmp, sizeof (_Type));
363
364 return true;
365 }
366
367
368 template <class _Type>
369 bool DynamicArray<_Type>::AddItem (const _Type& newItem)
370 {
371 if (!PrepareNext (1))
372 return false;
373 lpBuffer[dwNum++] = newItem;
374 return true;
375 }
376
377
378 template <class _Type>
379 DAINLINE _Type &DynamicArray<_Type>::operator[](unsigned long dw)
380 {
381 #ifdef _DEBUG
382 #ifdef WIN32
383 if (dw >= dwAlloc)
384 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwAlloc\n");
385 if (dw >= dwInited)
386 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwInited\n");
387 #endif
388 #endif
389 return lpBuffer[dw];
390 }
391
392
393 template <class _Type>
394 DAINLINE const _Type &DynamicArray<_Type>::operator[](unsigned long dw) const
395 {
396 #ifdef _DEBUG
397 #ifdef WIN32
398 if (dw >= dwAlloc)
399 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwAlloc\n");
400 if (dw >= dwInited)
401 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwInited\n");
402 #endif
403 #endif
404 return lpBuffer[dw];
405 }
406
407
408 template <class _Type>
409 DAINLINE _Type &DynamicArray<_Type>::Last (void)
410 {
411 #ifdef _DEBUG
412 #ifdef WIN32
413 unsigned long dw = dwNum - 1;
414 if (dw >= dwAlloc)
415 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwAlloc\n");
416 if (dw >= dwInited)
417 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwInited\n");
418 #endif
419 #endif
420
421 return (lpBuffer[dwNum - 1]);
422 }
423
424
425 template <class _Type>
426 DAINLINE _Type &DynamicArray<_Type>::Act (void)
427 {
428 #ifdef _DEBUG
429 #ifdef WIN32
430 unsigned long dw = dwNum;
431 if (dw >= dwAlloc)
432 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwAlloc\n");
433 if (dw >= dwInited)
434 OutputDebugStringA ("ERROR: DynArray: index error: dw >= dwInited\n");
435 #endif
436 #endif
437
438 return (lpBuffer[dwNum]);
439 }
440
441 template <class _Type>
442 DAINLINE unsigned long &DynamicArray<_Type>::ActDWORD (void)
443 {
444 return (*((unsigned long*)(lpBuffer + dwNum)));
445 }
446
447 template <class _Type>
448 DAINLINE int &DynamicArray<_Type>::ActInt (void)
449 {
450 return (*((int*)(lpBuffer + dwNum)));
451 }
452
453 template <class _Type>
454 DAINLINE bool DynamicArray<_Type>::StoreByte (unsigned char bData)
455 {
456 if (sizeof (_Type) != 1)
457 return false;
458
459 if (!PrepareNext (1))
460 return false;
461
462 *((unsigned char*)(lpBuffer + dwNum)) = bData;
463 dwNum++;
464
465 return true;
466 }
467
468 template <class _Type>
469 DAINLINE bool DynamicArray<_Type>::StoreDWORD (unsigned long dwData)
470 {
471 if ((4 % sizeof (_Type)) != 0)
472 return false;
473 if (!PrepareNext (4 / sizeof (_Type)))
474 return false;
475
476 *((unsigned long*)(lpBuffer + dwNum)) = dwData;
477 dwNum += 4 / sizeof (_Type);
478
479 return true;
480 }
481
482 template <class _Type>
483 DAINLINE unsigned char DynamicArray<_Type>::ReadByte (void)
484 {
485 return *((unsigned char*)(lpBuffer + (dwNum++)));
486 }
487
488 template <class _Type>
489 DAINLINE unsigned long DynamicArray<_Type>::ReadDWORD (void)
490 {
491 unsigned long dw = *((unsigned long*)(lpBuffer + dwNum));
492 dwNum += 4 / sizeof (_Type);
493
494 return dw;
495 }
496
497
498 } // VK_NoStepInto_Namespace
499
500
501 using VK_NoStepInto_Namespace::DynamicArray;
502
503
504 #endif // DYNAMICARRAY_H
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Configuration.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Configuration.h
Go to the documentation of this file.
1 #pragma once
2 #include "ShapeGenerator.h"
3
4 namespace APDYNAMICART
5 {
6
7 struct Configuration
8 {
9
10 Configuration* get()
11 {
12 static Configuration conf;
13 return &conf;
14 }
15
17 float sculptureSize;
18 IShapeGeneratorPtr shapeCurveGenerator;
19 IShapeGeneratorPtr crossSectionGenerator;
20
21
22 };
23
24 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Utils.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Utils.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg/io_utils>
4 #include "DATool.h"
5 #include "Spline.h"
6
7 namespace APDYNAMICART
8 {
11 class Utils;
12
14 typedef osg::ref_ptr<osg::UIntArray> UIntArrayPtr;
15 typedef osg::ref_ptr<osg::Vec3Array> Vec3ArrayPtr;
16 typedef osg::ref_ptr<osg::Vec4Array> Vec4ArrayPtr;
17 typedef osg::ref_ptr<osg::Geode> GeodePtr;
18 typedef osg::ref_ptr<osg::Geometry> GeometryPtr;
19
20 typedef osg::ref_ptr<vreckoUtils::Menu> MenuPtr;
21 typedef osg::ref_ptr<vreckoUtils::MenuRoot> MenuRootPtr;
22 typedef osg::ref_ptr<vreckoUtils::IMenuComponent> IMenuComponentPtr;
23
25 #define err(msg) \
26 std::cerr << __FUNCTION__<< " - " << msg << std::endl;
27
29 #if 0
30 #define dbgAtt(msg) \
31 std::cout << msg << std::endl;
32 #else
33 #define dbgAtt(msg)
34 #endif
35
37 #if 1
38 #define dbgPS(msg) \
39 std::cout << msg << std::endl;
40 #else
41 #define dbgPS(msg)
42 #endif
43
45 class Stroke
46 {
47 public:
48 virtual Vec3ArrayPtr getPositionSamples() const = 0;
49
50 //TODO ask Martin - what about this
51 virtual Vec4ArrayPtr getOrientationSamples() const = 0;
52
53 virtual osg::ref_ptr<osg::DoubleArray> getTimeStamps() const = 0;
54 virtual SplinePtr getLeadingSpline() const = 0;
55 };
56
58 template <class T>
59 class PoAAdapter : public osg::Referenced
60 {
61 public:
63 virtual void createMenu(osg::ref_ptr<vreckoUtils::Menu> menu) {}
64
66 virtual osg::ref_ptr<T> getObject() = 0;
67
68 virtual bool itemClicked(const char* itemID) { return false; }
69
71 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode ) { return 0; }
72
74 virtual void pointed( bool pointed ) {}
75
77 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode) {}
78
79
80 virtual bool sliderChanged(const char* sliderID, float sliderPos) { return false; }
81 virtual void update() {}
82
83 virtual std::string classDescription() const = 0;
84
85 virtual std::string className() const = 0;
86 protected:
87 virtual ~PoAAdapter() {};
88 };
89
91 template <class T>
92 class AdapterFactory
93 {
94 public:
96 const std::vector<osg::ref_ptr<T> >& getSupportedAdapters() const { return _adapters; }
97
99 osg::ref_ptr<T> getAdapter(const std::string& className)
100 {
101 for (u_int i = 0; i < this->_adapters.size(); ++i)
102 {
103 if (this->_adapters[i]->className() == className)
104 return this->_adapters[i];
105 }
106 return NULL;
107 }
108
109 protected:
110 std::vector<osg::ref_ptr<T> > _adapters;
111 };
112
114 class Utils
115 {
116 public:
117 static void interpolateVec3(osg::Vec3Array* controlPoints, osg::Vec3Array* interpolatedPoints, int p_steps);
118 static osg::Vec3 interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0, osg::Vec3 point3);
119 static bool isValueInsideRange( double value, double rangeStart, double rangeEnd );
120
121 inline static DATool* createDATool( const std::string& toolName, vrecko::BaseClass* owner) {
122 return static_cast< DATool*>(world->createAbility("DynamicArt", toolName, owner));
123 }
124
125 inline static void disableShaders(osg::StateSet* stateSet) {
126 stateSet->setAttributeAndModes(new osg::Program());
127 }
128 static void setLayout(const std::string& name);
129
130
131 // functions for splitting a string by defined delimiter
132 static std::vector<std::string> &splitString(const std::string &s, char delim, std::vector<std::string> &elems) {
133 std::stringstream ss(s);
134 std::string item;
135 while(std::getline(ss, item, delim)) {
136 elems.push_back(item);
137 }
138 return elems;
139 }
140
141 static std::vector<std::string> splitString(const std::string &s, char delim) {
142 std::vector<std::string> elems;
143 splitString(s, delim, elems);
144 return elems;
145 }
146
147 static string convertInt(int number)
148 {
149 stringstream ss;//create a stringstream
150 ss << number;//add number to the stream
151 return ss.str();//return a string with the contents of the stream
152 }
153
154 static int convertString(string number)
155 {
156 istringstream is(number);
157 int num;
158 is >> num;
159 return num;
160 }
161
162
163 private:
164 Utils() {};
165 };
166
168 struct Limits
169 {
170 double minX, minY, minZ;
171 double maxX, maxY, maxZ;
172
173 inline void reset() {
174 minX = minY = minZ = INT_MAX;
175 maxX = maxY = maxZ = INT_MIN;
176 }
177
178 inline void adjustLimits( const osg::Vec3& point ) {
179 double x = point._v[0]; double y = point._v[1]; double z = point._v[2];
180
181 if(x < minX) minX = x; if(x > maxX) maxX = x; //X-axis
182 if(y < minY) minY = y; if(y > maxY) maxY = y; //Y-axis
183 if(z < minZ) minZ = z; if(z > maxZ) maxZ = z; //Z-axis
184 }
185
186 inline double getVolume() {
187 return (maxX - minX) * (maxY - minY) * (maxZ - minZ);
188 }
189 };
190
191 typedef osg::ref_ptr<std::vector<osg::Vec4>> ColorList;
192
199 class colorGradient
200 {
201 public:
202 osg::Vec4 getColor(double val);
203 void addColor(osg::Vec4 color) { _colors.push_back(color); }
204
205 private:
206
207 //TODO value range can be defined here somehow
208 std::vector<osg::Vec4> _colors;
209
210 };
211
213 class PoAState
214 {
215 public:
216 void saveState(ref_ptr_PoA poa) {
217 _stateMap[poa] = PosRot(poa->getPosition(), poa->getRotation().getRotate());
218 }
219 void removeState(ref_ptr_PoA poa) {
220 auto it = _stateMap.find(poa);
221 if(it == _stateMap.end()) { err("State of given PoA wasn't found!"); return; }
222 _stateMap.erase(it);
223 }
224
225 void restoreAllPoAStates() {
226 for(auto it = _stateMap.begin(); it != _stateMap.end(); ++it)
227 {
228 if(it->first.valid()) {
229 it->first->setPosition(it->second.first);
230 it->first->setRotation(it->second.second);
231 }
232 }
233 }
234
235 protected:
236 typedef std::pair<osg::Vec3, osg::Quat> PosRot;
237 typedef std::map<ref_ptr_PoA, PosRot> StateMap;
238
239 StateMap _stateMap;
240 };
241
242
243 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/DynamicAttribute.h Source File

  • File List
  • File Members
  • include
  • vrecko
DynamicAttribute.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _DYNAMIC_ATTRIBUTE_H_
15 #define _DYNAMIC_ATTRIBUTE_H_
16
17 // attributes description includes
18 #include "Attribute.h"
19
20 // STL includes
21 #include <string>
22 #include <list>
23 #include <map>
24
25 // namespaces used
26 using namespace std;
27
28 // VRECKO namespace
29 namespace vrecko
30 {
31
42 class DynamicAttribute : public Attribute
43 {
44 public:
45
54 DynamicAttribute(const string& strName, const string& strDescription,
55 unsigned int minInstancesCount = 0, unsigned int maxInstancesCount = 10)
56 : Attribute(strName, Attribute::TYPE_DYNAMIC, strDescription)
57 {
58 // initialize instances range
59 this->minInstancesCount = minInstancesCount;
60 this->maxInstancesCount = maxInstancesCount;
61 }
62
66 ~DynamicAttribute()
67 {
68 // prepare the internal iterator
69 attributesListIter = attributesList.begin();
70
71 // while the iterator is not at the end
72 while (attributesListIter != attributesList.end())
73 {
74 // if the pointer is not null
75 if (*attributesListIter != null)
76 {
77 // delete the data and null the pointer
78 delete *attributesListIter;
79 *attributesListIter = null;
80 }
81
82 // increment the iterator
83 attributesListIter++;
84 }
85 }
86
92 inline unsigned int getMinInstancesCount() const
93 {
94 return minInstancesCount;
95 }
96
102 inline unsigned int getMaxInstancesCount() const
103 {
104 return maxInstancesCount;
105 }
106
119 bool addAttribute(Attribute* pAttribute)
120 {
121 // if the name already exists or the attribute is dynamic
122 if (containsAttribute(pAttribute->getName()) || pAttribute->isDynamic())
123 {
124 // delete the data and null the pointer
125 delete pAttribute;
126 pAttribute = null;
127
128 return false;
129 }
130
131 // insert the attribute into both containers
132 attributesList.push_back(pAttribute);
133 attributesMap[pAttribute->getName()] = pAttribute;
134
135 return true;
136 }
137
143 inline unsigned int attributesCount() const
144 {
145 return attributesList.size();
146 }
147
155 inline bool containsAttribute(const string& strName) const
156 {
157 return (attributesMap.find(strName) != attributesMap.end());
158 }
159
167 inline const Attribute* getAttributePtr(const string& strName) const
168 {
169 return attributesMap.find(strName)->second;
170 }
171
175 inline void startIteration()
176 {
177 attributesListIter = attributesList.begin();
178 }
179
191 inline bool hasNextAttribute() const
192 {
193 return (attributesListIter != attributesList.end());
194 }
195
207 inline const Attribute* nextAttributePtr()
208 {
209 return *attributesListIter++;
210 }
211
212 private:
213
214 // instances range
215 unsigned int minInstancesCount;
216 unsigned int maxInstancesCount;
217
218 // containers
219 list<Attribute*> attributesList;
220 map<string, const Attribute*> attributesMap;
221
222 // internal list iterator
223 list<Attribute*>::iterator attributesListIter;
224 };
225
226 // end of vrecko namespace
227 }
228
229 // end header definitions
230 #endif
231
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
DynamicMenu.h
Go to the documentation of this file.
1 #ifndef DYNAMICMENU_H
2 #define DYNAMICMENU_H
3
4 #include <vrecko/Ability.h>
5
6 #include <osg/Group>
7 #include <osg/ShapeDrawable>
8 #include <osgText/Text>
9
10 #include <helpers/DynamicArray.h>
11 #include <helpers/DynamicTree.h>
12 //#include <xercesc/dom/DOMErrorHandler.hpp>
13
14 #include <vreckoAP/ObjectUtils/Animator.h>
15
16 #include <vreckoAP/Menu/osgQ_QSection.h>
17 #include <vreckoAP/Menu/osgQ_QShapeDrawable.h>
18
19
20 using namespace vrecko;
21
22
23 namespace APMenu
24 {
25 class DynamicMenu;
26
27 // Constants for MenuItem::dwFlags (retreived and set by MenuItem::GetFlags() and MenuItem::SetFlags())
28 #define MI_F_SELECTED 0x00000001
29 // The item is selected
30 #define MI_F_EXPANDED 0x00000002
31 // The item is expanded
32
33
34 /* Internal structure of a single MenuItem
35
36
37 mainTransform
38 |
39 \- osgTransform
40 | |
41 | \- osgGeode
42 | | |
43 | | \- shapeBox OR shapeSection
44 | | | | |
45 | | | \- shapeDraw \- qshapeDraw
46 | | |
47 | | \- osgText ( <- only for MenuItemText and descendats)
48 | |
49 | \- modelTransform ( <- only for MenuItemText and descendats)
50 | |
51 | \- model ( <- only for MenuItemText and descendats)
52 |
53 \- childMenuObject
54
55
56
57 */
58
59
60 class MenuItem : public DynTreeNode<MenuItem>, public BaseClass {
61 public:
62 MenuItem(DynamicMenu *_owner);
63 virtual MenuItem* createNewItem(DynamicMenu* _owner) = 0;
64 virtual ~MenuItem();
65 // Note that every child of this class should call Destroy() in its destructor.
66
67 virtual void destroy();
68 // Here should be all the code required to destroy the graphics & input/outputs etc.
69 // (including call to parent's Destroy())
70
71 virtual bool loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* node);
72
73 // The name can be empty. In such case the item will not send events upon selection.
74 inline void setName(const char* newName);
75 inline const std::string& getName() { return name; }
76
77 bool setFlags(unsigned long dwNewFlags, bool bForceUpdate = false);
78 // Combination of MI_F_*
79 inline unsigned long getFlags() { return dwFlags; }
80
81 virtual bool invalidate(bool bIncludeSubItems = false);
82 // This method is called if anything changing the graphical representation has been changed.
83 // This method will discard (= DESTROY COMPLETELY) old grapical representation.
84 // If the item was visible, create new graphics and show it.
85
86 bool isPointed(osg::Vec3 *projPointerPos);
87 // Is intersected by the pointer, so it should be selected?
88 // [projPointerPos] is a pointer position projected onto thwe menu plane.
89
90 virtual bool canBeClicked() { return true; }
91 inline bool isVisible() { return bIsVisible; };
92 inline bool isGraphicsCreated() { return bGraphicsCreated; };
93 virtual bool show(unsigned long _dwItemIndex, unsigned long _dwNumItems,
94 osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3);
95 // This method should not need to be overriden.
96 virtual void hide(bool bIncludeSubItems = false);
97 // This method should not need to be overriden.
98
99 virtual bool pointerButtonDown() { return true; };
100 // Called when the user clicks presses the pointer button on the item (and the item has no children)
101 virtual bool pointerButtonUp() { return true; };
102 // Called when the user clicks releases the pointer (and the item has no children).
103 // Is only called if the pointerButtonDown() was called previously.
104 virtual bool pointerMove(osg::Vec3 *projPointerPos) { return true; };
105 // Called when the user moves the pointer over the item with an EXCEPTION:
106 // If user puses the pointer button down on AN ITEM, then before the pointer button gets released
107 // this particular ITEM will get all the pointerMove()'s even if the user is pointin outside the item boundaries.
108 // (Similiar behaviour as for components in Borland Delphi and possibly in other Windows development GUIs)
109 virtual bool clicked() { return true; };
110 // Called when the user clicks [pointer button down + up + confirmation animation] on the item (and the item has no children).
111
112 virtual void getClickedString(char *outClickedEventString, size_t bufferSize) { sprintf_s(outClickedEventString, bufferSize, "%s", name.c_str()); }
113 // The method should return a string, that is later sent by DynamicMenu to its "clicked" output.
114 // This is usually a name of the item, but could be something more complex, such as "name;value" in case
115 // of a slider. The string can be "" in whick case the Menu will NOT send any event.
116
117 virtual bool setAndPlayConfirmationEffect();
118 // This method has two alternative behaviours.
119 // It may return "false"
120 // and do nothing else. The DynamicMenu will take action and executes a command
121 // belonging to this item. (executes clicked() method etc.)
122 // It may return "true"
123 // in which case the menu item should set up and play confirmation effect
124 // (an animation if it would like) and after playing IT HAVE TO REPORT EVENT
125 // "ConfirmAnimationEnded" with BOOL value "true" to the DynamicMenu ability.
126 // (The Animator ability is designed to report the "AnimationEnded" event
127 // which exactly suits :) )
128 virtual bool resetConfirmationEffect();
129 // Called after the effect was played (or maybe even in the middle of it!)
130 // This method should reset the menu item to the original position.
131
132 inline bool isExpanded() { return (lpChild && lpChild->isVisible()); }
133 inline bool canBeExpanded() { return (NULL != lpChild); }
134
135 vrecko::EnvironmentObject* getChildMenuObject() { return childMenuObject.get(); }
136
137 protected:
138 DynamicMenu *owner;
139 int pos; // position in the current menu level
140 bool bIsVisible, bGraphicsCreated;
141
142 unsigned long dwFlags;
143 // combination of MI_F_*
144
145 // following variables are initialized every time the MenuItem::Show() is called:
146 // MenuItem::show() parameters:
147 unsigned long dwItemIndex, dwNumItems;
148 osg::Vec3 refPoint1, refPoint2, refPoint3;
149 // cached variables, retreived from [owner]
150 float itemSize, itemSize2;
151
152 osg::Vec4 color;
153
154 std::string name; // item name
155 // (can be empty, in which case the item will not send events upon selection)
156
157 osg::ref_ptr<osg::MatrixTransform> mainTransform;
158 // osg::ref_ptr<vrecko::EnvironmentObject> mainTransform;
159 osg::ref_ptr<vrecko::EnvironmentObject> childMenuObject;
160 // osg::ref_ptr<osg::MatrixTransform> osgTransform;
161 osg::ref_ptr<vrecko::EnvironmentObject> osgTransform;
162 osg::ref_ptr<osg::Geode> osgGeode;
163 APObjectUtils::Animator* childMenuAnimator;
164
165 bool bConfirmationEndedConnectionCreated;
166 // Was the "ConfirmationEnded" interconnection already created?
167
168 osg::ref_ptr<osg::Box> shapeBox;
169 osg::ref_ptr<osg::ShapeDrawable> shapeDraw;
170
171 osg::ref_ptr<osgQ::QSection> shapeSection;
172 osg::ref_ptr<osgQ::QShapeDrawable> qshapeDraw;
173
174 bool createGraphics();
175 bool destroyGraphics();
176
177 float menuRadial_CalcItemAngle(int _iItemIndex);
178 // the [_iItemIndex] can be even negative or too large
179
180 unsigned long menuBoxes_CalcItemDisplayIndex();
181
182 virtual bool createGraphicsCore();
183 // Creates new graphics according to the owner->GetType().
184 // The graphics need not to be set according to the flags.
185 // The SetFlags() (thus SetFlagsCore()) will be called afterwards.
186 virtual bool destroyGraphicsCore();
187 virtual bool showGraphicsAtPoint();
188 virtual bool hideGraphics();
189 virtual bool setFlagsCore(unsigned long dwOldFlags, unsigned long dwNewFlags);
190 // Updates the graphics to include the flags (MI_F_SELECTED especially)
191 virtual const osg::BoundingBox& getInnerBoundingBox() = 0;
192 // Get the bounding box of the inner contents
193
194 virtual bool addInputOutputs();
195 // This function is called after setting the name of the item.
196 // It should call addOutput() to create an output to signalize
197 // clicking on the item (or its changes).
198 // Outputs and inputs mut have exactly the same name as is stored in [name]
199 virtual bool removeInputOutputs();
200 // This function should call removeOutput() / removeInput()
201 // to destroy previously created inputs and outputs.
202
203 virtual int processNotification(BaseClass *sender, unsigned long notificationType,
204 void *notificationData);
205 };
206
207
208 class MenuItemNull : public MenuItem {
209 public:
210 MenuItemNull(DynamicMenu* _owner) : MenuItem(_owner) { name = "null"; }
211 virtual MenuItem* createNewItem(DynamicMenu* _owner) { return new MenuItemNull(_owner); }
212
213 virtual bool canBeClicked() { return false; }
214
215 protected:
216 osg::BoundingBox bbox;
217
218 virtual bool createGraphicsCore() { return true; }
219 virtual bool destroyGraphicsCore() { return true; }
220 virtual bool showGraphicsAtPoint() { return true; }
221 virtual bool hideGraphics() { return true; }
222 virtual const osg::BoundingBox& getInnerBoundingBox() { return bbox; }
223 };
224
225
226 class MenuItemText : public MenuItem {
227 public:
228 MenuItemText(DynamicMenu *_owner);
229 virtual ~MenuItemText();
230 virtual MenuItem* createNewItem(DynamicMenu* _owner) { return new MenuItemText(_owner); }
231
232 virtual void destroy();
233
234 virtual bool loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* node);
235
236 virtual bool clicked();
237
238 virtual const std::string& getCaption() { return caption; }
239 virtual bool setCaption(const char* newCaption);
240
241 virtual const std::string& getModelFile() { return modelFile; }
242 virtual bool setModelFile(const char* newModelFile);
243
244 void setSignName(const char* name);
245
246 protected:
247 std::string caption;
248
249 std::string modelFile;
250 osg::ref_ptr<osg::Node> model;
251 osg::ref_ptr<osg::MatrixTransform> modelTransform;
252
253 osg::ref_ptr<osgText::Text> osgText;
254
255 osg::Vec2 textShift;
256 // this variable must be set before initialization of graphics
257
258 std::string signName; // name of the sign from the menu's repository
259 osg::ref_ptr<osg::Node> signObject; // sign that is currently loaded
260 osg::ref_ptr<osg::PositionAttitudeTransform> signTransform;
261
262 virtual bool createGraphicsCore();
263 virtual bool destroyGraphicsCore();
264 virtual bool showGraphicsAtPoint();
265 virtual const osg::BoundingBox& getInnerBoundingBox();
266
267 bool getTextBoundingBox(osg::BoundingBox *outBox);
268
269 osg::BoundingBox boundingBox;
270
271 virtual bool addInputOutputs();
272 virtual bool removeInputOutputs();
273
274 virtual bool createModel();
275 virtual void destroyModel();
276 virtual void repositionModel();
277 // Scales and translates the model according the space of the item left
278 // around the text (if any)
279
280 virtual void updateText();
281
282 DECLARE_OUTPUT(Clicked, MessageBool);
283 };
284
285
286 class MenuItemSlider : public MenuItemText {
287 public:
288 MenuItemSlider(DynamicMenu *_owner);
289 virtual ~MenuItemSlider();
290
291 virtual MenuItem* createNewItem(DynamicMenu* _owner) { return new MenuItemSlider(_owner); }
292
293 virtual void destroy();
294
295 virtual bool loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* node);
296
297 virtual bool canBeClicked() { return false; }
298 virtual bool clicked() { return true; }
299
300 virtual void getClickedString(char *outClickedEventString, size_t bufferSize);
301
302 virtual bool pointerButtonDown();
303 virtual bool pointerButtonUp();
304 virtual bool pointerMove(osg::Vec3 *projPointerPos);
305
306 virtual float getSliderPos01() { return fSliderPos01; }
307 virtual bool setSliderPos01(float fNewSliderPos01, bool bSendEvent = true);
308
309 virtual float getSliderPosXY();
310 virtual bool setSliderPosXY(float fNewSliderPos, bool bSendEvent = true) { return setSliderPos01((fNewSliderPos - fSliderFromX) / (fSliderToY - fSliderFromX), bSendEvent); }
311
312 protected:
313 float fSliderPos01; // range: 0.0 to 1.0
314 bool bSliding; // is pointer dragged by the mouse movement?
315
316 float fSliderFromX, fSliderToY;
317 bool bIntegerOnlySlider; // return integers or floats?
318
319 osg::ref_ptr<osg::Cylinder> sliderNonmovable;
320 osg::ref_ptr<osg::ShapeDrawable> sliderDrawNM;
321 osg::ref_ptr<osg::Box> sliderMovable;
322 osg::ref_ptr<osg::ShapeDrawable> sliderDrawM;
323
324 virtual bool createGraphicsCore();
325 virtual bool destroyGraphicsCore();
326 virtual bool showGraphicsAtPoint();
327 virtual const osg::BoundingBox& getInnerBoundingBox();
328
329 virtual bool addInputOutputs();
330 virtual bool removeInputOutputs();
331
332 bool updateSliderGraphicPos();
333
334 float getPointerSliderPos01(bool *bIsOutside);
335 // Calculates the position of the pointer (TransPointerPos) on the slider.
336 // This method will return a number from 0.0 to 1.0 - even when the mouse pointer is far outside,
337 // the position will be clipped to this interval, however the [bIsOutside] will be set to "true".
338 // [bIsOutside] can be NULL.
339
340 virtual void updateText();
341
342 DECLARE_OUTPUT(Slide, MessageFloat);
343 };
344
345
346 enum MenuType {RadialBoxes, RadialSections, Boxes, Grid};
347
348
349 class DynamicMenuSign {
350 public:
351 std::string value;
352 osg::ref_ptr<osg::Node> geometry;
353 };
354
355
356 class DynamicMenu: public Ability
357 {
358 friend class MenuItem;
359 public:
360 //
361 // constructors / destructors
362 //
363 DynamicMenu();
364 virtual ~DynamicMenu();
365
366
367 DynamicTree<MenuItem> itemTree;
368
369 EnvironmentObject* getOwner() { return owner; };
370 EnvironmentObject* getMainObject() { return mainObject.get(); };
371
372 // EnvironmentObject* getInputOuputEO();
373 // Get the EO used
374
375
376 //
377 // methods inherited from VRECKO
378 //
380 virtual void preInitialize();
382 virtual void postInitialize();
384 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
386 virtual void update();
387
388 // virtual void processEvent(const std::string &strInputName, void *pValue);
389 // virtual void *processRequest(const std::string &strInputName, void *pValue);
390
391
392 // Sets the new menu items
393 bool setMenuString(const char *newMenuString);
394
395 bool addMenuItem(MenuItem *parentItem, MenuItem *itemToAdd);
396 bool insertMenuItem(MenuItem *parentItem, MenuItem *prevSibling, MenuItem *itemToAdd);
397
398 // Delete MenuItem including its children ("delete [...];" is called too)
399 bool deleteMenuItem(MenuItem *item);
400
401 bool registerNewItemType(MenuItem *itemTemplate);
402
403 MenuType getMenuType() { return menuType; }
404
405 inline void setAttribute(const std::string &name, float value) { attributes[name] = value; }
406 inline float getAttribute(const std::string &name) { return attributes[name]; }
407
408 void setSign(const std::string &name, const std::string &value);
409 osg::Node* getSignObject(const std::string &name);
410
411 inline bool isMainButtonPressed() { return bMainButtonPressed; }
412 inline bool isSelectionLocked() { return isMainButtonPressed() || selectedItem; }
413
414 bool showMenu(osg::Vec3 *_menuPos);
415 void hideMenu();
416
417 inline osg::Vec3& getProjPointerPos() { return projPointerPos; }
418 inline osg::Vec3& getLastPointerPos() { return lastPointerPos; }
419
420 void sendToClickedOutput(char *eventValue);
421 // This is for use by MenuItem-s.
422 // [eventValue] can be NULL
423 // The [eventValue] will be copied (new memory will be created) and sent away
424
425 protected:
426 EnvironmentObject *owner;
427
428 std::string baseDirectory;
429 // Base menu directory (from where are signs searched for instance).
430 // Is determined automatically from the .xml menu file path, but can be
431 // overridden in this file.
432
433 int activePointerID;
434
435 osg::Vec3 origMenuPos, origViewPos, origViewUp, origViewLookAt;
436 // The position of the menu.
437 // osg::Vec3 lastViewPos, lastViewDir;
438 // View position and direction from the last ViewMoved() call to detect whether a change occured.
439 osg::Vec3 autoMoveShift;
440 // If "AutoMoveWithView" attribute is not 0, then this vector is
441 // the difference between the current view position and the menu position.
442 // (It have to be rotated)
443 osg::ref_ptr<EnvironmentObject> mainObject;
444 osg::ref_ptr<EnvironmentObject> shadowEO, dispEO;
445 // [mainObject] is the main object containing all menu items
446 // [shadowEO] is inserted into the scene with its child being [mainObject].
447 // It's rendered after all other objects (excluding [shadowEO]) to prepare the Z-buffer
448 // [dispEO] is inserted into the scene with its child also being [mainObject].
449 // It's rendred after [shadowEO] to fially render the geometry.
450 osg::Matrix inverseTransformMatrix;
451 // Matrix inverse to the transform matrix of the mainObject.
452 // It's calculated in UpdateMainObjectTransformation().
453
454 osg::Vec3 lastPointerPos;
455 // last pointer position
456 osg::Vec3 lastViewPos;
457 // last view position
458 osg::Vec3 transPointerPos;
459 // pointer position transformed into object coordinates
460 osg::Vec3 projPointerPos;
461 // pointer position projected to the menu plane (X-Y)
462 osg::Vec3 transViewPos;
463 // view position transformed into object coordinates
464
465 bool bMainButtonPressed;
466 // the current state of the main button
467 bool bAllowSelectOnRelease;
468 // If true, the user will select an item with the button release even if the
469 // selection is not locked. (Useful after the start of the menu caused by
470 // a button press).
471
472 // std::string strPointerPosReq, strClickedOutput;
473
474 DynamicArray<MenuItem*> registeredItemTypes;
475
476 // osg::Node * loaded_model;
477
478 std::string menuString;
479 // may be either XML string describing the menu ('... <menu> ... </menu> ...') or
480 // a .xml file name preceded by an asterisk ('*C:\mymenu.xml')
481
482 std::map<std::string, float> attributes;
483 // Some common attributes are:
484 // ItemSize (> 0.0) ... the size of an item (also dependent on the MenuType)
485 // ItemSize2 (> 0.0) ... "second size" of an item (on Y coordinate usually)
486 // AutoExpand (0 / 1) ... expand the menu items after selecting by pointer?
487 // AutoRotateToView (0 / 1) ... rotate automatically (like a billboard)
488 // AutoMoveWithView (0 / 1) ... move automatically so it remains on the same screen position
489 // AutoSameDistance (0 / 1) ... the menu will maintain the same distance from the viewer
490 // (useful if AutoRotate is specified, but AutoMove is not)
491 // AlwaysOnTop (0 / 1) ... the menu will be on top of any other graphics
492 // ForceMenuDistance
493 // 0.0 or less - no forced distance, the menu will be displayed where the user will request
494 // more than 0.0 - the menu will be displayed in the direction of user click, but with the specified distance
495 // MenuScale ... scales the whole menu component
496
497
498 std::map<std::string, DynamicMenuSign*> signs;
499 // Graphical signs
500
501 MenuType menuType;
502
503 MenuItem *pointerSelected;
504 // an item that is selected by the pointer
505 MenuItem *visibleMenuRoot;
506 // root of the visible part of the menu (the root item itself is not visible)
507
508 MenuItem *selectedItem;
509 // the KEY variable. It determines whether the menu is in "normal" state (selectedItem = NULL) or
510 // the menu item has been already selected and the final confirmation effect is being played
511 // (selectedItem != NULL). In the latter case, the menu is irresponsive to the user acions.
512
513 // Variables for the temporary cylinder directing from the menu center to the pointer
514 osg::ref_ptr<osg::MatrixTransform> osgPointerTrailTransform;
515 osg::ref_ptr<osg::Geode> osgPointerTrailGeode;
516 osg::ref_ptr<osg::Cylinder> osgPointerTrail;
517 osg::ref_ptr<osg::ShapeDrawable> osgPointerTrailDrawable;
518
519 bool mainButtonPressed();
520 bool mainButtonReleased();
521
522 bool showChildMenu(MenuItem* parentItem, bool bSetNewRoot);
523 void hideChildMenu(MenuItem* parentItem = NULL, bool bIncludeSubMenus = true);
524 bool isVisible();
525
526 bool showMainMenuObject();
527 void hideMainMenuObject();
528
529 void updatePointerPosition();
530
531 void updateMainObjectTransformation();
532
533 void updateInverseCalc();
534
535 bool pointerMoved(osg::Vec3 *pointerPos);
536 bool viewMoved();
537 bool pointerViewMovedHelper();
538
539 bool createMenuFromString();
540 bool createMenuFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* paramNode);
541
542 bool loadMenuStructureFromNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* paramNode);
543 bool loadSignsFromXML(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* attribsNode);
544 bool loadAttributes(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* attribsNode);
545 bool loadMenuItems(MenuItem *parentItem, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* parentNode);
546 void destroyMenuStructure();
547
548 bool createMainObjects();
549 void destroyMainObjects();
550
551 bool createPointerTrail();
552 void destroyPointerTrail();
553 void showPointerTrail();
554 void hidePointerTrail();
555
556 bool pointerUnselectItem(bool bLeaveSelectedIfLocked = true);
557 // [bLeaveSelectedIfLocked] will cause the item to remain selected
558 // if the menu button is down (so the menu item is "locked")
559 bool pointerSelectItem(MenuItem *item);
560 bool solvePointerSelection();
561 // Search for the menu item that is selected
562 MenuItem* getPointedItemRecursive(MenuItem *parent, int *depth);
563 // Retreive the pointed MenuItem with the maximum depth.
564 // [depth] is the depth of the parent item at the call of the function
565 // and depth of the pointed item at the finish of the function.
566 // (The [parent] won't be tested)
567
568 bool expandItem(MenuItem *item);
569 bool collapseItem(MenuItem *item);
570 bool collapseSiblings(MenuItem *item);
571
572 void itemClicked(MenuItem *item);
573
574 void confirmAnimationEnded();
575
576 void resetBaseValues();
577 void initStandardSignSet();
578 void changeToStructureOccured();
579
580
581 bool unselectItem();
582 // Unselects a selected item (if there is any). Also stops its effect if it is being played
583 // and resets is position back to normal.
584
585
586 int menuGrid_columnsCached, menuGrid_rowsCached;
587 // If either of the values is equal to -1, then the values will
588 // be recalculated in the menuGrid_getSize() method. Otherwise the
589 // method just returns the cached values.
590 void menuGrid_getSize(int *columns, int *rows);
591 // This method will return both values greater than 0 in every case.
592
593 DECLARE_INPUT(Create, MessageString);
594 DECLARE_INPUT(ButtonPress, MessageBool);
595 DECLARE_INPUT(ConfirmAnimationEnded, MessageBool);
596
597 DECLARE_OUTPUT(Clicked, MessageString);
598 DECLARE_OUTPUT(HidingMenu, MessageBool);
599
600 DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt);
601
602 DECLARE_REQUEST_OUTPUT(PointerPosition, MessageInt, MessageVec3);
603 };
604
605 }
606
607
608
609 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/DynamicMenu_XMLPart.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
DynamicMenu_XMLPart.h
Go to the documentation of this file.
1 #include <xercesc/framework/LocalFileFormatTarget.hpp>
2 #include <xercesc/parsers/AbstractDOMParser.hpp>
3 #include <xercesc/dom/DOMErrorHandler.hpp>
4 #include <xercesc/util/XMLString.hpp>
5 #include <xercesc/dom/DOMLocator.hpp>
6 #include <xercesc/util/XMLString.hpp>
7 #include <xercesc/dom/DOMImplementation.hpp>
8 #include <xercesc/dom/DOMImplementationRegistry.hpp>
9 #include <xercesc/dom/DOMImplementationLS.hpp>
10 #include <xercesc/dom/DOMBuilder.hpp>
11 #include <xercesc/framework/MemBufInputSource.hpp>
12 #include <xercesc/framework/Wrapper4InputSource.hpp>
13
14 #if defined(XERCES_NEW_IOSTREAMS)
15 #include <iostream>
16 #else
17 #include <iostream.h>
18 #endif
19
20
21 namespace APMenu
22 {
23
24
25 // ---------------------------------------------------------------------------
26 // Simple error handler deriviative to install on parser
27 // ---------------------------------------------------------------------------
28 class MenuLoaderErrorHandler : public XERCES_CPP_NAMESPACE_QUALIFIER DOMErrorHandler
29 {
30 public:
31 MenuLoaderErrorHandler();
32 ~MenuLoaderErrorHandler();
33
34 // Getter methods
35 bool getSawErrors() const;
36
37 // Implementation of the DOM ErrorHandler interface
38 bool handleError(const XERCES_CPP_NAMESPACE_QUALIFIER DOMError& domError);
39 void resetErrors();
40
41 private :
42 // Unimplemented constructors and operators
43 MenuLoaderErrorHandler(const MenuLoaderErrorHandler&);
44 void operator=(const MenuLoaderErrorHandler&);
45
46
47 // -----------------------------------------------------------------------
48 // Private data members
49 //
50 // fSawErrors
51 // This is set if we get any errors, and is queryable via a getter
52 // method. Its used by the main code to suppress output if there are
53 // errors.
54 // -----------------------------------------------------------------------
55 bool fSawErrors;
56 };
57
58 inline bool MenuLoaderErrorHandler::getSawErrors() const {
59 return fSawErrors;
60 }
61
62
63 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/DynamicScene.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
DynamicScene.h
Go to the documentation of this file.
1 #ifndef DYNAMICSCENE_H
2 #define DYNAMICSCENE_H
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/EnvironmentObject.h>
6 #include <vreckoAP/Export>
7
8 #include <osg/Vec3>
9 #include <osg/Vec4>
10
11 #include <ode/ode.h>
12
13 #include <vector>
14 #include <map>
15 #include <string>
16
17 using namespace vrecko;
18
19
20 namespace ode {
21
22 typedef struct {
23 dBodyID body; // the body
24 std::vector<dGeomID*> geom; // geometries representing this body
25 std::vector<double *> geom_translate;
26 double translate[3];
27 bool enable;
28 unsigned steps_before_disable_state;
29 } ODEObject;
30
31
32 class AP_EXPORT DynamicScene: public Ability {
33 public:
34
35 class MessageODERequest : public VreckoMessage {
36 public:
37 virtual const char* getMessageId() { return "ODERequest"; }
38
39 EnvironmentObject *sender;
40 std::string type;
41 double parameter[20]; // parameters - size, density, relative position and orientation
42 std::multimap<std::string, double*> object;
43 };
44
45 /* typedef struct {
46 std::string type;
47 double parameter[20]; // parameters - size, density, relative position and orientation
48 std::multimap<std::string, double*> object;
49 } Request;*/
50
51
52 DynamicScene();
53 ~DynamicScene();
54
55 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
56
58 // void processEvent(const std::string &input_name, void *value);
59
60 void update(void);
61
62 // std::string getAcceptableMessages(void) {return "ODE";}
63
64 // XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
65
66 void setEnableFlag(vrecko::EnvironmentObject *_eobject, bool _new_state);
67 void enableAllObjects(void);
68
69 void setForceToDynamicObject(vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz);
70 void setTorqueToDynamicObject(vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz);
71 void setForce(vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv);
72 void setTorque(vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv);
73
74 void setLinearVel(vrecko::EnvironmentObject *_eobject, osg::Vec3 _lv);
75 void setAngularVel(vrecko::EnvironmentObject *_eobject, osg::Vec3 _av);
76
77
78 dWorldID _world;
79 dSpaceID _space;
80 dJointGroupID _contact_group;
81
82 typedef std::pair <std::string, double*> Object_Pair;
83
84 protected:
85 osg::Vec3 _gravity;
86 double _CFM;
87 double _ERP;
88 osg::Vec4 _plane;
89 // double _step; // OBSOLETE: Incorrect setting
90
91 std::map<vrecko::EnvironmentObject *, ODEObject *> _scene_objects;
92 std::vector<dGeomID> _objects_dGeomID;
93
94 //MyObject obj[20];
95 std::vector<ODEObject *> _dynamic_object;
96
97 osg::Vec3 _retv;
98 osg::Quat _retq;
99
100 std::map<vrecko::EnvironmentObject *, bool> _enabled_objects;
101
102 void updateLocationInDynamic(void);
103 void updateLocationInNonDynamic(void);
104
105 void disableThreshold(void);
106
107 DECLARE_REQUEST_INPUT(ODE, MessageODERequest, MessageVoid);
108 };
109
110 }
111
112 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/DynamicTree.h Source File

  • File List
  • File Members
  • include
  • helpers
DynamicTree.h
Go to the documentation of this file.
1 #ifndef DYNAMICTREE_H
2 #define DYNAMICTREE_H
3
4
5 template <class _Type>
6 class DynamicTree;
7
8
9 template <class _Type>
10 class DynTreeNode {
11 public:
12 // LPVOID lpUserData;
13 _Type *lpParent, *lpChild, *lpNext, *lpPrev; // pointers to the nearest objects
14 DynamicTree<_Type> *tree; // pointer to the owner tree
15
16 unsigned long GetDepth(); // = get number of lpParent->lpParent->lpParent->... (0 for the root)
17 };
18
19
20 // In fact, it is not tree but it can be multiple trees (forest).
21 template <class _Type>
22 class DynamicTree {
23 public:
24
25 typedef bool (*DYNTREE_NODEALLOWED) (DynTreeNode<_Type>* node);
26 typedef bool (*DYNTREE_SUBTREEALLOWED) (DynTreeNode<_Type>* node);
27
28 DynamicTree (void);
29 virtual ~DynamicTree (void);
30
31 inline unsigned long GetCount (void) { return dwCount; };
32
33 bool AddNode (_Type *lpParent, _Type *lpNode);
34 // !! The node will be inserted BEFORE any other children of the parent node !!
35 // [lpParent] == NULL => this will be the root node (or sibling to the root node)
36 bool AddNodeLast (_Type *lpParent, _Type *lpNode);
37 // !! The node will be inserted AFTER any other children of the parent node !!
38 // This function is slower than AddNode().
39 // [lpParent] == NULL => this will be the root node (or sibling to the root node)
40 bool InsertNode (_Type *lpParent, _Type *lpPrevSibling, _Type *lpNode);
41 // The node will be inserted AFTER the [lpPrevSibling]
42 // [lpParent] == NULL => this will be the root node (or sibling to the root node)
43 // [lpPrevSibling] == NULL => insert as a first child
44 bool DeleteNode (_Type *lpNode, bool bCallDelete = false);
45 // Deletes also subtree.
46 // If lpNode is NULL whole tree will be deleted.
47
48 inline _Type* GetRoot (void) { return lpRoot; }
49
50 bool Clear (bool bCallDelete = false);
51
52 protected:
53 _Type *lpRoot;
54 unsigned long dwCount;
55 };
56
57
58
59 // These flags are mostly mutualy exclusive:
60 #define DTI_EXCLUDEROOT 0x00000001 // root will be excluded from traversing
61 #define DTI_ONLYLEAVES 0x00000002 // traverse only leaves
62 #define DTI_ONELAYERTRAVERSAL 0x00000004
63 // Can not be specified together with DTI_ONLYLEAVES
64 // if DTI_EXCLUDEROOT is also specified:
65 // traverse root's nearest children
66 // if DTI_EXCLUDEROOT is NOT specified:
67 // traverse root and it's siblings
68
69
70 template <class _Type>
71 class DynamicTreeIterator { // depth-first style iterating through the tree
72 public:
73 DynamicTreeIterator (void) { cbNodeAllowed = NULL; cbSubTreeAllowed = NULL; bStarting = false; Reset (); }
74 inline void Reset (void) { nodePtr = (_Type*)0; tree = NULL; }
75
76 void SetNodeAllowedCallback (typename DynamicTree<_Type>::DYNTREE_NODEALLOWED cb) { cbNodeAllowed = cb; };
77 void SetSubTreeAllowedCallback (typename DynamicTree<_Type>::DYNTREE_SUBTREEALLOWED cb) { cbSubTreeAllowed = cb; };
78
79 /* [dwFlags] is combination of DTI_*
80 [lpTravStart] is starting node to traverse form
81 (it will be something like temporary root).
82 WARNING: lpTravStart can be NULL ONLY IF SetTree is called before. */
83 void Start (_Type *lpTravStart, unsigned long dwFlags);
84 inline bool IsFinished (void) { return (0 == nodePtr); }
85
86 inline bool operator== (
87 const DynamicTreeIterator<_Type>& iter)
88 {
89 return (nodePtr == iter.nodePtr);
90 };
91 inline friend bool operator!= (
92 const DynamicTreeIterator<_Type>& iter1,
93 const DynamicTreeIterator<_Type>& iter2)
94 {
95 return (iter1.nodePtr != iter2.nodePtr);
96 };
97 DynamicTreeIterator<_Type>& operator++ (void);
98 DynamicTreeIterator<_Type> operator++ (int);
99
100 _Type* GetNode (void) { return (nodePtr); };
101
102 // This is only necessary when starting from the NULL object.
103 void SetTree (DynamicTree<_Type> *_tree) { tree = _tree; };
104
105 // DynTreeNode& operator* (void) { return (*nodePtr); };
106 // DynTreeNode& operator-> (void) { return (*nodePtr); };
107
108 protected:
109 DynamicTree<_Type> *tree;
110 _Type *nodePtr;
111 _Type *nodeStart;
112 unsigned long dwFlags;
113 typename DynamicTree<_Type>::DYNTREE_NODEALLOWED cbNodeAllowed;
114 typename DynamicTree<_Type>::DYNTREE_SUBTREEALLOWED cbSubTreeAllowed;
115 bool bStarting; // The first node is to be found
116
117 inline bool IsNodeAllowed (_Type *node)
118 {
119 if ((dwFlags & DTI_EXCLUDEROOT) && (node == nodeStart))
120 return false;
121 if ((dwFlags & DTI_ONLYLEAVES) && (node->lpChild))
122 return false;
123 if (!cbNodeAllowed)
124 return true;
125 return cbNodeAllowed (node);
126 };
127
128 inline bool IsSubTreeAllowed (_Type *node)
129 {
130 if (!cbSubTreeAllowed)
131 return true;
132 return cbSubTreeAllowed (node);
133 };
134 };
135
136
137 template <class _Type>
138 unsigned long DynTreeNode<_Type>::GetDepth()
139 {
140 _Type *tmp = lpParent;
141 unsigned long dw = 0;
142 while (tmp) {
143 tmp = tmp->lpParent;
144 dw++;
145 }
146 return dw;
147 }
148
149
150 template <class _Type>
151 DynamicTree<_Type>::DynamicTree (void)
152 {
153 lpRoot = NULL;
154 dwCount = 0;
155 }
156
157 template <class _Type>
158 DynamicTree<_Type>::~DynamicTree (void)
159 {
160 DeleteNode (NULL);
161 }
162
163
164 template <class _Type>
165 bool DynamicTree<_Type>::AddNode (_Type *lpParent, _Type *lpNode)
166 {
167 lpNode->tree = this;
168
169 lpNode->lpParent = lpParent;
170 lpNode->lpChild = NULL;
171 lpNode->lpPrev = NULL;
172
173 if (lpParent) {
174 lpNode->lpNext = lpParent->lpChild;
175 if (lpParent->lpChild)
176 lpParent->lpChild->lpPrev = lpNode;
177 lpParent->lpChild = lpNode;
178 } else {
179 lpNode->lpNext = lpRoot;
180 if (lpRoot)
181 lpRoot->lpPrev = lpNode;
182 lpRoot = lpNode;
183 }
184
185 dwCount++;
186 return true;
187 }
188
189
190 template <class _Type>
191 bool DynamicTree<_Type>::AddNodeLast (_Type *lpParent, _Type *lpNode)
192 {
193 lpNode->tree = this;
194
195 lpNode->lpParent = lpParent;
196 lpNode->lpChild = NULL;
197 lpNode->lpPrev = NULL;
198 lpNode->lpNext = NULL;
199
200 if (lpParent) {
201 if (!lpParent->lpChild) {
202 lpParent->lpChild = lpNode;
203 } else {
204 _Type *child = lpParent->lpChild;
205 while (child->lpNext)
206 child = child->lpNext;
207 child->lpNext = lpNode;
208 lpNode->lpPrev = child;
209 }
210 } else {
211 if (!lpRoot) {
212 lpRoot = lpNode;
213 } else {
214 _Type *child = lpRoot;
215 while (child->lpNext)
216 child = child->lpNext;
217 child->lpNext = lpNode;
218 lpNode->lpPrev = child;
219 }
220 }
221
222 dwCount++;
223 return true;
224 }
225
226
227 template <class _Type>
228 bool DynamicTree<_Type>::InsertNode (_Type *lpParent, _Type *lpPrevSibling, _Type *lpNode)
229 {
230 if (NULL == lpPrevSibling)
231 return AddNode (lpParent, lpNode);
232
233 lpNode->tree = this;
234
235 lpNode->lpParent = lpParent;
236 lpNode->lpChild = NULL;
237 lpNode->lpPrev = lpPrevSibling;
238 lpNode->lpNext = lpPrevSibling->lpNext;
239 if (lpPrevSibling->lpNext)
240 lpPrevSibling->lpNext->lpPrev = lpNode;
241 lpPrevSibling->lpNext = lpNode;
242
243 dwCount++;
244 return true;
245 }
246
247
248 template <class _Type>
249 bool DynamicTree<_Type>::DeleteNode (_Type *lpNode, bool bCallDelete)
250 {
251 if (lpNode) {
252 if (lpNode->lpParent) {
253 if (lpNode->lpParent->lpChild == lpNode)
254 lpNode->lpParent->lpChild = lpNode->lpNext;
255 }
256
257 while (lpNode->lpChild) {
258 if (!DeleteNode (lpNode->lpChild, bCallDelete))
259 return false;
260 }
261
262 if (lpNode->lpPrev)
263 lpNode->lpPrev->lpNext = lpNode->lpNext;
264
265 if (lpNode->lpNext)
266 lpNode->lpNext->lpPrev = lpNode->lpPrev;
267
268 if (lpNode == lpRoot)
269 lpRoot = lpNode->lpNext;
270
271 lpNode->tree = NULL;
272
273 if (bCallDelete)
274 delete lpNode;
275
276 dwCount--;
277 } else {
278 while (lpRoot) {
279 if (!DeleteNode (lpRoot, bCallDelete))
280 return false;
281 }
282
283 lpRoot = NULL;
284 }
285
286 return true;
287 }
288
289
290 template <class _Type>
291 bool DynamicTree<_Type>::Clear (bool bCallDelete)
292 {
293 return DeleteNode (NULL, bCallDelete);
294 }
295
296
297 template <class _Type>
298 void DynamicTreeIterator<_Type>::Start (_Type *_lpTravStart, unsigned long _dwFlags)
299 {
300 nodeStart = _lpTravStart;
301 dwFlags = _dwFlags;
302 nodePtr = NULL;
303
304 bStarting = true;
305
306 if (_lpTravStart) {
307 if (dwFlags & DTI_EXCLUDEROOT)
308 nodePtr = nodeStart->lpChild;
309 else if (nodeStart)
310 nodePtr = nodeStart;
311 } else {
312 if (tree)
313 nodePtr = tree->GetRoot ();
314 }
315
316 ++*this;
317
318 bStarting = false;
319 }
320
321
322 template <class _Type>
323 DynamicTreeIterator<_Type>& DynamicTreeIterator<_Type>::operator++ (void)
324 {
325 if (!bStarting && !nodePtr)
326 return *this;
327
328 if (dwFlags & DTI_ONELAYERTRAVERSAL) {
329 if (!bStarting)
330 nodePtr = nodePtr->lpNext;
331
332 while (nodePtr && !IsNodeAllowed (nodePtr))
333 nodePtr = nodePtr->lpNext;
334
335 return *this;
336 }
337
338 unsigned long dwState = 1;
339
340 while (true) {
341 if (!bStarting) {
342 if (nodePtr->lpChild && IsSubTreeAllowed (nodePtr))
343 nodePtr = nodePtr->lpChild;
344 else {
345 while (nodePtr && !nodePtr->lpNext) {
346 if (nodePtr == nodeStart) {
347 nodePtr = NULL;
348 break;
349 }
350 nodePtr = nodePtr->lpParent;
351 }
352 if (nodePtr == nodeStart) {
353 nodePtr = NULL;
354 break;
355 }
356 if (nodePtr)
357 nodePtr = nodePtr->lpNext;
358 }
359 }
360
361 if (!nodePtr)
362 break;
363
364 if (IsNodeAllowed (nodePtr))
365 break;
366
367 bStarting = false;
368 }
369
370 return *this;
371 }
372
373
374 template <class _Type>
375 DynamicTreeIterator<_Type> DynamicTreeIterator<_Type>::operator++ (int)
376 {
377 DynamicTreeIterator<_Type> *tmp = this;
378 ++*this;
379 return (*tmp);
380 }
381
382
383 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Edge.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Edge.h
Go to the documentation of this file.
1 #ifndef EDGE
2 #define EDGE
3 // kazda hrana ma komplementarni hranu (pouze s prohozenymi krizovatkami
4 // fromJunction, toJunction); jestlize ma hrana numLanes 0, je nesjizdna
5 // (auta na ni nemuze jet z bodu Out do In)
6
7 // hrany jsou vetsinou normalni, vyjimky tvori nasledujici pripady
8 #define NORMAL_EDGE 1
9 // ultrakratka (nebo take velmi kratka) hrana - ma nejaky pruh a splnuje nejmene
10 // 1 z podminek:
11 // 1. vzdalenost mezi from a to hrany je <= nez 1.5*prumerna delka auta
12 // 2. bod OUT vychazi az za bod IN (bod In vychazi blize krizovatce fromJunction
13 // nez bod Out)
14 // 3. pro komplementarni hranu plati predchozi podminka
15 #define ULTRA_SHORT_EDGE 2
16 // ultrakratka hrana bez pruhu
17 #define ULTRA_SHORT_EDGE_WITHOUT_ANY_LANE 3
18 // kratka hrana – hrana se povazuje za kratkou, pokud neni velmi kratka, ma
19 // nejmene jeden pruh a splnuje alespon jedno z tvrzeni:
20 // a) teoreticky existuje auto (s maximalni moznou delkou, ktere by u bodu Out
21 // vyjelo maximalni moznou rychlosti prujezdu krizovatkou), ktere na ni nemuze
22 // zastavit, aniz by ohrozilo provoz na krizovatce pred nim nebo za nim;
23 // jinymi slovy vzdalenost mezi OUT a IN <= 3*prumerna delka auta + 0.4 (rezerva)
24 // (mezi autem, ktere stoji na normalni hrane a bodem IN
25 // ci bodem OUT by mela byt vzdy vzdalenost aspon 0.5 * prumerna delka auta)
26 // b) hrana ma komplementarni kratkou hranu
27 #define SHORT_EDGE 4
28 // normalni nebo kratka hrana bez pruhu
29 #define NORMAL_OR_SHORT_EDGE_WITHOUT_ANY_LANE 5
30 // program ACG vynechava silnice na kraji mesta pri vytvareni jejich XML reprezentace;
31 // kolem stredu nekterych krizovatek tak vznikaji prazdna mista, ktera jsou zaplnena
32 // specialnimi hranami - terminatory
33 #define TERMINATOR_EDGE 6
34
35 // defaultni hodnota pro tlGreenInterv
36 #define TL_GREEN_INTERV_DEFAULT 6
37
38 #include <queue>
39
40 namespace CarSim {
41 // u normalni hrany budou uchovany nektere informace o autu,
42 // jestlize na ni bude mezi body OUT a IN:
43 struct EdgesCar {
44 // offset predni casti auta (predniho narazniku) na hrane
45 float headOffset;
46 // offset zadni casti auta (zadniho narazniku) na hrane
47 float rearOffset;
48 // id dalsiho auta (0 - neplatne id - za autem se
49 // zadne dalsi auto nevyskytuje)
50 unsigned int frontCarId;
51 // id predchoziho auta (0 - neplatne id - pred autem se
52 // zadne predchozu auto nevyskytuje)
53 unsigned int backCarId;
54 // rychlost tohoto auta
55 float vel;
56 };
57
58 // informace o hrane
59 struct Edge {
60 // id silnice (Road z XML souboru), ke ktere tato hrana patri
61 unsigned int roadId;
62 // smer hrany v ramci silnice (Road v XML souboru),
63 // true urcuje normalni smer dopredu (pravou stranu silnice),
64 // false znaci opacny smer v silnici (levou stranu silnice)
65 bool direction;
66 // id zakladni krizovatky (puvodni krizovatka z XML souboru),
67 // ze ktere hrana vychazi
68 unsigned int from;
69 // id zakladni krizovatky, do ktere hrana vstupuje
70 unsigned int to;
71 // id krajniho bodu (PolygonPoint), ktery urcuje tvar
72 // hrany, tento bod je u krizovatky from
73 unsigned int fromPointRight;
74 // to stejne, akorat tento bod je u krizovatky to
75 unsigned int toPointRight;
76 // pocet pruhu na hrane (v silnici v jednom smeru)
77 unsigned int numLanes;
78 // delka hrany
79 float length;
80 // IN je bod, kde auto vstupuje do krizovatky a kde auto zacne zatacet
81 // (pouze pro kratke a normalni hrany, u ostatnich hran je [0,0,0])
82 osg::Vec3 inPos;
83 // bod, ve kterem auto prestane zatacet (kde auto vyjizdi ze krizovtky)
84 // (pouze pro kratke a normalni hrany, u ostatnich hran je [0,0,0])
85 osg::Vec3 outPos;
86 // vektor z bodu OUT do bodu IN, jedna se o smer, jakym v idealnim pripade
87 // pojede hranou auto;
88 // (pouze pro kratke a normalni hrany, u ostatnich hran je [0,0,0])
89 osg::Vec3 outInVec;
90 // normala teto hrany (uz je znormalizovana)
91 osg::Vec3 normal;
92 // offset (ne v procentech, ale in (0,1)), ktery urcuje bod mezi body Out a In, kde auto
93 // zastavi svym prednim naraznikem, jestlize se rozhodne zastavit pred dalsi krizovatkou;
94 // ten bod se nachazi 0.5*(prumerna delka auta) pred bodem IN hrany;
95 // mezi posledni stojicim autem na hrane a bodem IN se nechava prostor dlouhy
96 // 0.5*(prumerna delka auta), aby auto neohrozilo provoz u nasledujici kriz.
97 // (pouze pro normalni hrany, u ostatnich hran je 0)
98 float stopBeforeJuncOffset;
99 // offset (ne v procentech, ale in (0,1)), ktery urcuje bod mezi body OUT a IN, ktery
100 // kdyz auto prejede svym prednim naraznikem, rozhodne se, jestli projede dalsi
101 // krizovatkou hned nebo bude brzdit k bodu stopBeforeJunc (aby dalo nejakemu autu prednost);
102 // tato pozice se nachazi 2.0*(prumerna delka auta) pred bodem IN hrany;
103 // (pouze pro normalni hrany, u ostatnich hran je 0)
104 float stopOrGoDecisionOffset;
105 // typ hrany - hodnoty viz vyse
106 unsigned int type;
107 // sirka hrany u bodu toPointRight;
108 // (pouze pro kratke a normalni hrany, u ostatnich hran je 0)
109 float widthTPR;
110 // sirka hrany u bodu fromPointRight;
111 // (pouze pro kratke a normalni hrany, u ostatnich hran je 0)
112 float widthFPR;
113 // offset, ktery urcuje bod, za kterym (smerem k bodu IN) se musi nachazet zadni cast
114 // auta na startu a v cili; ten bod je vzdalen 0.5*prumerna delka auta
115 // od bodu OUT a ocita se za timto bodem (smerem k IN);
116 // (ma smysl pouze pro normalni hrany - auto musi zacinat a koncit na normalni hrane)
117 float lowBoundForStartStopPosOffset;
118 // jestlize hrana je normalni, jsou zde pro kazde auto (klic - id auta) na teto hrane
119 // mezi OUT a IN ulozeny informace ve strukture EdgesCar
120 std::map<unsigned int,EdgesCar> edgesCars;
121 // id 1. auta na hrane mezi body OUT a IN;
122 // (0 - neplatne id - na hrane jeste zadne auto neni);
123 // (opet pouze pro normalni hrany)
124 unsigned int fstCarId;
125 // id posledniho auta na hrane mezi body OUT a IN;
126 // (0 - neplatne id - na hrane jeste zadne auto neni);
127 // (opet pouze pro normalni hrany)
128 unsigned int lastCarId;
129
130 // ma vyznam pouze u kratke hrany - jsou tam id aut, ktera pres ni pojedou
131 // (z Out do In) ve sve pristi velke krizovatce, jsou posledni na normalni hrane
132 // a jsou blizko dalsi krizovatky (tak, ze ostatni auta, ktera pojedou
133 // pres cast te kratke hrany za bodem In, zvazuji, zda jim daji prednost);
134 // mapovana hodnota obsahuje true, jestlize auto na normalni hrane stoji
135 std::map<unsigned int,bool> incomingCars;
136
137 // u normalnich hran zde je fronta s id odsunutych/odskocenych aut
138 // (byla docasne odsunuta, protoze branila prujezdu ostatnich aut
139 // - stala pred bodem stopBeforeJunc hrany prilis dlouho);
140 // prvni auto (vpredu fronty) bylo nejdrive odsunuto, posledni auto zase nejpozdeji
141 // ze vsech aktualne odsunutych aut na hrane
142 std::queue<unsigned int> putAsideCars;
143
144 // pocet sekund, po ktere ma na semaforu u puvodni krizovatky to pro tuto hranu svitit
145 // zelena (pokud puvodni krizovatka to ani ji nadrazena mala krizovatka (pokud se sloucila
146 // do vetsi krizovatky) nejsou rizeny pomoci semaforu, nebude tato hodnota pouzita; tato hodnota
147 // se nacita z XML konfiguracniho souboru, pokud v nem neni uvedena, pouzije se defaultni hodnota
148 // - viz nahore)
149 unsigned int tlGreenInterv;
150 };
151 }
152
153 #endif
154
155
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Editor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Editor.h
Go to the documentation of this file.
1 #ifndef _EDITOR_H_
2 #define _EDITOR_H_
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/PluginManager.h>
7 #include <vrecko/World.h>
8 #include <vrecko/EnvironmentObject.h>
9 #include <vrecko/Scene.h>
10 #include <osg/Light>
11 #include <osg/LightSource>
12 #include <osg/Material>
13 #include <osg/BlendFunc>
14 #include <osg/AlphaFunc>
15 #include <osg/PositionAttitudeTransform>
16
17 #include <osgDB/readFile>
18 //XML parameters
19 #include <helpers/XercesXMLUtils.h>
20 #include <vrecko/ReaderWriter.h>
21 #include <xercesc/parsers/XercesDOMParser.hpp>
22
23 #include <osg/Group>
24 #include <osg/Geode>
25 #include <osg/Geometry>
26 #include <osg/Shape>
27 #include <osg/ShapeDrawable>
28 #include <osg/Timer>
29
30 #include <iostream>
31 #include <sstream>
32 #include <vector>
33 #include <cmath>
34 #include <fstream>
35
36 #include <windows.h>
37
38 #include <vreckoAP/LightsEditor/Lights.h>
39
40 using namespace vrecko;
41
42 namespace APLightsEditor {
43
44 struct _Light
45 {
46 _Light(EnvironmentObject* eoPtr, int lightID, EnvironmentObject* eoSpotPtr = NULL)
47 {
48 _lightID = lightID;
49 _eoPtr = eoPtr;
50 _eoSpotPtr = eoSpotPtr;
51
52 _eoPtr->setNodeMask(_eoPtr->getNodeMask() & ~0x40);
53
54 if(eoSpotPtr)
55 _eoSpotPtr->setNodeMask(_eoPtr->getNodeMask() & ~0x40);
56 }
57
58 int _lightID;
59 EnvironmentObject* _eoPtr;
60 EnvironmentObject* _eoSpotPtr;
61 };
62
63 class Editor: public vrecko::ControllableAbility
64 {
65 public:
66 Editor();
67 virtual ~Editor();
68 void update(void);
69 protected:
70 Lights* lightManager;
71 std::vector<_Light> lightMarker;
72 int actLightID;
73 int sunID;
74 Lights::shadingModes shadeMode;
75 Lights::shadowModes shadowMode;
76 Lights::giModes giMode;
77
78 bool makeMenu();
79 void saveToXML(const char* FileName);
80 EnvironmentObject* DrawPoint(osg::Vec3 position, float pointRadius, osg::Vec4 pointColor);
81 virtual void fillDefaultInfo();
82 virtual bool activate();
83 virtual void deactivate();
84 virtual void menuItemClicked(const char* itemID);
85 virtual void menuSliderChanged(const char* sliderID, float sliderPos);
86 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode = NULL);
87
88 };
89 }
90
91 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorController/EditorController.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorController
EditorController.h
Go to the documentation of this file.
1 #ifndef EDITORCONTROLLER_H
2 #define EDITORCONTROLLER_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Quat>
6 #include "ControllableAbility.h"
7 #include "AbilityMapper.h"
8
9
10 using namespace vrecko;
11
12 namespace APEditorController
13 {
14
15 class EditorController: public Ability {
16 public:
17 static const int maxPointers = 2;
18 static const int maxButtonsPerPointer = 4;
19
20 EditorController();
21 ~EditorController();
22
23 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
24
25 virtual void update();
26
27
28 protected:
29 class ECPOINTERBUTTONINFO {
30 public:
31 ECPOINTERBUTTONINFO() { bState = false; cachedInfo = NULL; }
32 ~ECPOINTERBUTTONINFO() { setMappedAbility(NULL); };
33
34 void setOwner(EditorController *_owner) { owner = _owner; }
35
36 bool bState; // current state (pressed or released)
37
39 bool setMappedAbility(const char *strID);
40
41 std::string& getMappedAbilityID() { return mappedAbilityID; }
42 CAINFO* getMappedAbilityInfo(bool bForceRefresh);
43
44 protected:
45 EditorController *owner;
46 std::string mappedAbilityID;
47 CAINFO *cachedInfo;
48 };
49
50 class ECPOINTERINFO {
51 public:
52 ECPOINTERINFO() { actSelection = 0; lastButtonPressed = 0; selPath = NULL; }
53 ~ECPOINTERINFO() { if (selPath) { delete selPath; selPath = NULL; } }
54
55 osg::Vec3 pos, posRaw;
56 osg::Quat rot, rotRaw;
57
58 unsigned long actSelection;
59 std::vector<osg::Node*> *selPath;
62
63 int lastButtonPressed;
64
65 ECPOINTERBUTTONINFO buttons[maxButtonsPerPointer + 1];
68 };
69
70 EnvironmentObject *owner;
71
72 // std::string strSelectionID, strP1Selection, strP2Selection;
73 // std::string strP1Visible, strP2Visible;
74 // std::string strSelectionReq;
75
76 std::string activeAbilityName; // the name of the active ability
77 // "" if no ability is active
78 int activeAbilityPointerID, activeAbilityButtonID; // which pointer and button activated the ability
79
80 osg::Vec3 actViewPosition;
81 // actual view position
82 ECPOINTERINFO pointers[maxPointers + 1];
83 // Pointer 0 is only a filler, so it is not necessary to "shift" indexes
84
85 Ability *abilityMapper;
86 // automatically created editing ability to map other abilities to the buttons
87 // std::string strAbilityMapping;
88
89 bool createAbilityMapper();
90 void removeAbilityMapper();
91 void setAbilityMapping(AbilityMapper::MAPPING *newMapping);
92 AbilityMapper::MessageMapping *compileAbilityMapping();
93 // retrieves current mapping and sends it to the AbilityMapped
94
95 unsigned long actSelection;
96
97 void setNewSelection(unsigned long newSelection);
98
99 void pointerPosUpdate(int pointerID, const osg::Vec3 &newPos, bool bRaw = false);
100
101 void pointerRotUpdate(int pointerID, const osg::Quat &newRot, bool bRaw = false);
102
103 void pointerBtnUpdate(int poinerID, int buttonID, bool newState);
104 void sendPointerBtnToRelevantOutputs(int pointerID, int buttonID);
105
106 void pointerSelUpdate(int pointerID, unsigned long newSelection);
107 void sendPointerSelectionEvent(int pointerID, unsigned long newSelection);
108
109 void abilityActivationTest();
110 // Returns whether an ability is active.
111 // AND: If the ability is internally marked as "active" and the real state
112 // is different, then the internal state is also changed.
113
114 void selectionVisibilityUpdate();
115 // Checks active abilities and sets the correct visibility
116 // of selection of each pointer.
117
118 virtual int processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData);
119
120
121 DECLARE_INPUT(Pointer1Pos, MessageVec3);
122 DECLARE_INPUT(Pointer1Rot, MessageQuat);
123 DECLARE_INPUT(Pointer1PosRaw, MessageVec3);
124 DECLARE_INPUT(Pointer1RotRaw, MessageQuat);
125 DECLARE_INPUT(Pointer1Btn1, MessageBool);
126 DECLARE_INPUT(Pointer1Btn2, MessageBool);
127 DECLARE_INPUT(Pointer1Btn3, MessageBool);
128 DECLARE_INPUT(Pointer1Btn4, MessageBool);
129
130
131 DECLARE_INPUT(Pointer2Pos, MessageVec3);
132 DECLARE_INPUT(Pointer2Rot, MessageQuat);
133 DECLARE_INPUT(Pointer2PosRaw, MessageVec3);
134 DECLARE_INPUT(Pointer2RotRaw, MessageQuat);
135 DECLARE_INPUT(Pointer2Btn1, MessageBool);
136 DECLARE_INPUT(Pointer2Btn2, MessageBool);
137 DECLARE_INPUT(Pointer2Btn3, MessageBool);
138 DECLARE_INPUT(Pointer2Btn4, MessageBool);
139
140 DECLARE_OUTPUT(SelectionID, MessageObjectID);
141 DECLARE_OUTPUT(Pointer1Selection, MessageObjectID);
142 DECLARE_OUTPUT(Pointer1Visible, MessageBool);
143 DECLARE_OUTPUT(Pointer2Selection, MessageObjectID);
144 DECLARE_OUTPUT(Pointer2Visible, MessageBool);
145
146 // for setting/getting the mapping from the AbilityMapper
147
148 DECLARE_INPUT(AbilityMapping, AbilityMapper::MessageMapping);
149 DECLARE_OUTPUT(AbilityMapping, AbilityMapper::MessageMapping);
150 DECLARE_REQUEST_INPUT(AbilityMapping, MessageVoid, AbilityMapper::MessageMapping);
151
152
153 DECLARE_REQUEST_OUTPUT(SelectionByPointerPos_Path, MessageVec3, MessageNodeList);
154
155 DECLARE_REQUEST_INPUT(SelectionID, MessageInt, MessageObjectID);
156 DECLARE_REQUEST_INPUT(SelectionPath, MessageInt, MessageNodeList);
157 DECLARE_REQUEST_INPUT(PointerPos, MessageInt, MessageVec3);
158 DECLARE_REQUEST_INPUT(PointerRot, MessageInt, MessageQuat);
159 DECLARE_REQUEST_INPUT(PointerPosRaw, MessageInt, MessageVec3);
160 DECLARE_REQUEST_INPUT(PointerRotRaw, MessageInt, MessageQuat);
161 };
162
163 }
164
165 #endif
166
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/EditorLogic.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
EditorLogic.h
Go to the documentation of this file.
1 #ifndef APFFDEDITOR_H
2 #define APFFDEDITOR_H
3
4 #include <vrecko/Ability.h>
5 #include "GeometryLoader.h"
6 #include "Grid.h"
7 #include "../EditorController/ControllableAbility.h"
8
9 using namespace vrecko;
10
11 namespace APFFDEditor {
12
13 class EditorLogic: public vrecko::ControllableAbility , public GeometryLoader{
14 public:
15 EditorLogic();
16 ~EditorLogic() {destroyGeometry(); if (pGrid) pGrid->~Grid();};
17
18 void update(void);
19 //void processEvent(const std::string &input_name, void *value) ;
20 void postInitialize(void);
21 /*void preInitialize(void); */
22 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *);
23 //XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode) ;
24 protected:
25
26 virtual void fillDefaultInfo();
27 virtual bool activate();
28 virtual void menuItemClicked(const char* itemID);
29 virtual void menuSliderChanged(const char* sliderID, float sliderPos);
30 void CPscale(float scale);
31 bool isThisControlPoint(long ID);
32 int moveLock;
33
34 float CPsize;
35 float transparencyOfEditedObject;
36 float optimOfCP;
37 osg::Vec3 previousObjectPosition;
38
39
40 vrecko::EnvironmentObject * pEditedObject;
41 Grid *pGrid;
42 bool gridChanged;
43 bool objectWasMoved;
44 osg::Vec3 numberOfCPoints;
45 //main function of deformation using positions grid control points and relative positions of verticies in geometry
46 void updateObjectGeometry(void);
47
48 //in this function set relative position verticies of object in grid
49 void setAtributesForDeformation(void);
50 void resetGeometry(void);
51 //void showBoundary(unsigned short value);
52 //unsigned short boundary;
53 //osg::ref_ptr<osg::Geode> boundaryGeode;
54
55 osg::Matrix *parentsTransform ;
56 osg::Matrix *inverseParentsTransform ;
57
58 };
59
60 }
61 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Enumeration.h Source File

  • File List
  • File Members
  • include
  • vrecko
Enumeration.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _ENUMERATION_H_
15 #define _ENUMERATION_H_
16
17 // attributes description includes
18 #include "Range.h"
19
20 // variable arguments count includes
21 #include <stdarg.h>
22
23 // STL includes
24 #include <string>
25 #include <list>
26 #include <set>
27
28 // namespaces used
29 using namespace std;
30
31 // VRECKO namespace
32 namespace vrecko
33 {
34
53 template <class tval, class tref = tval>
54 class Enumeration : public Range
55 {
56 public:
57
64 Enumeration(unsigned int valuesCount, ...)
65 : Range(Range::RANGE_ENUMERATION)
66 {
67 // initialize argument pointer
68 va_list argumentPtr;
69 va_start(argumentPtr, valuesCount);
70
71 // loop through all the arguments
72 for (unsigned int i = 1; i < valuesCount; i++)
73 {
74 // insert the value into both containers
75 valuesList.push_back(va_arg(argumentPtr, tref));
76 valuesSet.insert(valuesList.back());
77 }
78
79 // perform cleanup
80 va_end(argumentPtr);
81 }
82
88 inline unsigned int valuesCount() const
89 {
90 return valuesList.size();
91 }
92
100 inline bool containsValue(tref value) const
101 {
102 return (valuesSet.find(value) != valuesSet.end());
103 }
104
108 inline void startIteration()
109 {
110 valuesListIter = valuesList.begin();
111 }
112
124 inline bool hasNextValue() const
125 {
126 return (valuesListIter != valuesList.end());
127 }
128
140 inline tref nextValue()
141 {
142 return *valuesListIter++;
143 }
144
145 private:
146
147 // containers
148 list<tval> valuesList;
149 set<tref> valuesSet;
150
151 // internal list iterator
152 typename list<tval>::iterator valuesListIter;
153 };
154
158 typedef Enumeration<int> IntEnumeration;
159 typedef Enumeration<long> LongEnumeration;
160 typedef Enumeration<float> FloatEnumeration;
161 typedef Enumeration<double> DoubleEnumeration;
162
166 typedef Enumeration<string, const string&> StringEnumeration;
167
168 // end of vrecko namespace
169 }
170
171 // end header definitions
172 #endif
173
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/Enumerations.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
Enumerations.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_ENUMERATIONS_H
10 #define VRECKO_NATURE_TERRAIN_ENUMERATIONS_H
11
12 namespace APNature
13 {
19 enum TerrainAlignment
20 {
21 Left, Centre, Right
22 };
23
29 enum DataSourceType
30 {
31 None, Image, Algorithm
32 };
33
39 enum AlgorithmType
40 {
41 Displacement, Faults, PerlinNoise
42 };
43
49 enum InterpolationType
50 {
51 Linear, Cosine
52 };
53
59 enum FileTypeExport
60 {
61 MAX3DS, OBJ, IVE, OSG, FLT, AC, FBX
62 };
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/EnvironmentObject.h Source File

  • File List
  • File Members
  • include
  • vrecko
EnvironmentObject.h
Go to the documentation of this file.
1 /***************************************************************************
2 EnvironmentObject.h - description
3 -------------------
4 begin : May 2002
5 copyright : (C) 2002 by Jan Flasar, Ludek Pokluda, Lubosek Markovic
6 email : flasar|xpokluda|markovic@fi.muni.cz
7 ***************************************************************************/
8
9
10 #ifndef ENVIRONMENTOBJECT_H
11 #define ENVIRONMENTOBJECT_H
12
13 #include <osg/Vec3>
14 #include <osg/Matrix>
15 #include <osg/MatrixTransform>
16 #include <vrecko/IOPins.h>
17 #include <vrecko/BaseClass.h>
18 #include <vrecko/Ability.h>
19 #include <vrecko/Message.h>
20
21 //#include <esg/OSGAdapter.h>
22
23 #include <vector>
24
25 #include <esg/Definitions.h>
26
27 #define SYSTEM_VISIBLE_OBJECT_TRAVERSAL_MASK 0x00000001
28 #define RECEIVES_SHADOW_TRAVERSAL_MASK 0x20
29 #define CASTS_SHADOW_TRAVERSAL_MASK 0x40
30 #define SYSTEM_TRAVERSAL_MASK__MASK (RECEIVES_SHADOW_TRAVERSAL_MASK | CASTS_SHADOW_TRAVERSAL_MASK)
31
32
33 namespace esg {
34 class OSGAdapter;
35 }
36
37 namespace osg {
38 class Geometry;
39 class Geode;
40 }
41
42
43 namespace vrecko {
44
45
46 class VRECKO_EXPORT Scene;
47
48 class VRECKO_EXPORT EnvironmentObject: public BaseClass, public osg::MatrixTransform {
49 friend class World;
50 public:
51 EnvironmentObject();
52 ~EnvironmentObject();
53 EnvironmentObject(EnvironmentObject &eo);
54
55 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
56
67 void setID(unsigned long new_id);
68
69
75 inline const unsigned long getID() const {return id;}
76
86 void setName(const std::string &n) {name = n;}
87
88
96 inline const std::string &getName(void) const {return name;}
97
98
115 bool loadGeometry(const char *filename, bool bOutputErrors = true);
116
117
126 bool setGeometry(osg::Geode *new_geomtetry, long int k = 1, long int l = 100000);
127
136 void setModelFileName(const std::string mfn) {modelFileName = mfn;}
137
138
144 inline const std::string &getModelFileName(void) const {return modelFileName;}
145
160 bool addAbility(Ability *ability, bool bCreateNewIdIfColliding = true);
161
171 bool removeAbility(Ability *pAbility);
172
182 bool removeAbility(const std::string &ability_id);
183
184
190 bool removeAllAbilities() { ability_dispatcher.removeAllAbilities(); return true; }
191
192
199 inline Ability *getAbility(const std::string &ab_id) { return ability_dispatcher.getAbility(ab_id); }
200
201
212 Ability *getAbility(const std::string &pluginName, const std::string &abilityName);
213
215 inline Ability *getAbilityWithInput(const std::string &input_name) {return ability_dispatcher.getAbilityWithInput(input_name);}
216
218 inline Ability *getAbilityWithOutput(const std::string &output_name) {return ability_dispatcher.getAbilityWithOutput(output_name);}
219
220
230 std::map<std::string, Ability*> &getAbilityMap(void) {return ability_dispatcher.getAbilityMap();}
231
232
246 osg::Matrix &getWorldTransformation(void);
247
248
257 osg::Vec3 getWorldPosition(void);
258
259
268 osg::Matrix getWorldRotation(void);
269
271 void setIdentityTransformation(void);
272
274 void setPosition( const osg::Vec3 & coords );
275
277 void setPosition( float x, float y, float z );
278
280 osg::Vec3 &getPosition();
281
283 void setRotation(float angle, float x, float y, float z);
284
286 void setRotation(const osg::Vec3 & angles);
287
289 void setRotation(const osg::Matrix & new_matrix);
290
292 void setRotation(const osg::Quat & quat);
293
295 osg::Matrix &getRotation(void) {return rotation_matrix;}
296
298 void setScale(const osg::Vec3 &new_scale);
299
301 void setScale(float x, float y, float z);
302
304 osg::Vec3& getScale(void) {return scale_vec;}
305
315 void setOSGAdapter(std::vector<esg::OSGAdapter *> new_osga) {osgadapter_vector = new_osga;}
316
325 std::vector<esg::OSGAdapter *>* getOSGAdapter(void) {return &osgadapter_vector;}
326
341 EnvironmentObject* getParentEO(void);
342
344
359 bool addEOChild(EnvironmentObject *new_EO);
360
370 bool removeEOChild(EnvironmentObject *new_EO);
371
372
374 typedef enum {
375 UD_UNKNOWN = 0,
376 UD_BOOL,
377 UD_INT,
378 UD_LONG_INT,
379 UD_FLOAT,
380 UD_DOUBLE,
381 UD_STRING,
382 UD_VEC2,
383 UD_VEC3,
384 UD_VEC4,
385 UD_MATRIX,
386 UD_QUAT,
387 UD_POINTER,
388 UD_USER
389 } UserData_Type;
390
391 /* // This struct is used to define user type UserData and functions for load and save.
392 typedef struct {
393 // Return the XML-DOMNode with parameters.
394 virtual DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) {return NULL;}
395 // This virtual function serves to load XML-parameters.
396 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) {return false;}
397 } UserDataStruct;
398 */
400 typedef struct {
401 void *pointer;
402 UserData_Type type;
403 } UserData;
404
417 void addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype);
418
428 bool removeUserData(const std::string &label);
429
440 UserData *getUserData(const std::string &label);
441
451 std::map<std::string, UserData *> getUserDataMap(void) {return user_data;}
452
461 void setTransparency(float transp);
462
464 inline float getTransparency(void) {return transparency;}
465
467 inline void show() {bVisible = true; updateNodeMask();}
468
470 inline void hide() {bVisible = false; updateNodeMask();}
471
473 inline bool isVisible() { return bVisible;}
474
476 inline bool isCollisionFree() {return bCollisionFree;}
477
479 void setCastShadows(bool cast);
480
481 protected:
483 unsigned long id;
484
486 std::string name;
487
489 std::string modelFileName;
490
492 AbilityDispatcher ability_dispatcher;
493
494 // Temporary transform matrix variable, so it doesn't need to be allocated
495 // every time the getWorldTransformation() is called and then copied to the caller
496 osg::Matrix tempTransformMatrix;
497
499 osg::Vec3 trans_vec;
500
502 osg::Matrix rotation_matrix;
503
505 osg::Vec3 scale_vec;
506
508 float transparency;
509
510 // Visibility of object
511 bool bVisible;
512
513 // True equals that the object is not able to collision to any onther objects
514 bool bCollisionFree;
515
517 std::vector<esg::OSGAdapter *> osgadapter_vector;
518
520 std::map<std::string, UserData *> user_data;
521
523 void updateNodeMask();
524
526 void createCollisionHierarchy(osg::Node *pNode);
527
530 void fixGeometryMirroring(const osg::Node *node);
531
533 void fixGeometryHelper(const osg::Node *node, bool bMirrored);
534
536 void fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored);
537
543 DECLARE_INPUT(Position, MessageVec3);
544
545 DECLARE_INPUT(Orientation, MessageQuat);
546 DECLARE_INPUT(Location, MessageMatrix);
547 DECLARE_INPUT(RelativePosition, MessageVec3);
548 DECLARE_INPUT(RelativeOrientation, MessageQuat);
549 DECLARE_INPUT(RelativeLocation, MessageMatrix);
550 };
551
552 }
553
554 #endif
555
556
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ErrorReporter.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
ErrorReporter.h
Go to the documentation of this file.
1 #ifndef ErrorReporter_h
2 #define ErrorReporter_h
3
4 namespace PhysXPlugin
5 {
6 class ErrorReporter: public NxUserOutputStream
7 {
8 void reportError (NxErrorCode code, const char *message, const char* file, int line)
9 {
10 std::cerr<<file<<": "<<message<<std::endl;
11 }
12
13 NxAssertResponse reportAssertViolation (const char *message, const char *file,int line)
14 {
15 std::cerr<<file<<": "<<message<<std::endl;
16 return NX_AR_CONTINUE;
17 }
18
19 void print (const char *message)
20 {
21 std::cerr<<message<<std::endl;
22 }
23
24 };
25 }
26
27
28 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/EventDispatcher.h Source File

  • File List
  • File Members
  • include
  • vrecko
EventDispatcher.h
Go to the documentation of this file.
1 /***************************************************************************
2 EventDispatcher.h - description
3 -------------------
4 begin : Jul 2003
5 copyright : (C) 2003 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9
10 #ifndef EVENTDISPATCHER_H
11 #define EVENTDISPATCHER_H
12
13 #include <vrecko/Export>
14 #include <vrecko/BaseClass.h>
15 #include <vrecko/DeviceManager.h>
16 #include <vrecko/MTLock.h>
17
18 #include <string>
19 #include <vector>
20 #include <map>
21
22 #ifdef WIN32
23 #include <windows.h>
24 #else
25 #include <pthread.h>
26 #endif
27
28 namespace vrecko {
29
30
32 class VRECKO_EXPORT EventDispatcher: public BaseClass {
33 public:
34 EventDispatcher();
35 ~EventDispatcher();
36 EventDispatcher(EventDispatcher &ed);
37
39 enum InterconnectionType {
40 FORWARD_OUTPUT = 1,
41 ACTIVATE_INPUT,
42 REQUEST
43 };
44
46 enum SRType {
47 UNKNOWN = 0,
48 ENVIRONMENTOBJECT,
49 ABILITY,
50 DEVICE,
51 SCENE,
52 WORLD,
53 OUTER_OBJECT
54 };
55
56
58 VRECKO_EXPORT struct ICSBase {
59 friend EventDispatcher;
60 public:
61 ICSBase() { _receiver_ptr = NULL; }
62
63 inline void setReceiverPtrDirty() { _receiver_ptr = NULL; }
64
69 BaseClass* getReceiverPtr() { if (_receiver_ptr) return _receiver_ptr; else return getReceiverPtrCore(); }
70
71 std::string receiver;
72 std::string receiverPin;
73
74 InterconnectionType type;
75
76 protected:
78 BaseClass *_receiver_ptr;
79
80 VRECKO_EXPORT BaseClass* getReceiverPtrCore();
81 };
82
83
84 VRECKO_EXPORT struct ICS : public ICSBase{
85 public:
86 //TODO - vyresit lepe?
87 std::string sender;
88
93 osg::ref_ptr<VreckoMessage> conditionalMessage;
94
95 osg::ref_ptr<VreckoMessage> activationMessage;
96 };
97
98 VRECKO_EXPORT struct REQUEST_Struct : public ICSBase {
99 public:
100 const std::string *sceneFile; // a file that this connection will be saved to.
101 // It is a pointer to a shared memory pool, so don't deallocate it.
102 // BTW it's a _variable pointer_ to a _constant string_
103 };
104
106 VRECKO_EXPORT struct EventStruct {
107 EventType eventType;
108 BaseClass *pReceiver;
109 std::string senderIdOrInputName;
110 // Depending on [pReceiver] this member semantics will change.
111 // If [pReceiver] is NULL, then [senderIdOrInputName] will hold the full sender string with the output name
112 // If [pReceiver] is not NULL, then [senderIdOrInputName] will hold the input name of the requested "pin" on the receiver side.
113 osg::ref_ptr<VreckoMessage> message;
114 };
115
116 VRECKO_EXPORT struct StringWithHash {
117 StringWithHash() {};
118 StringWithHash(const std::string &str) { originalString = str; hashValue = calculateHash(originalString.c_str()); }
119 StringWithHash(const StringWithHash& src) { originalString = src.originalString; hashValue = src.hashValue; };
120
121 std::string originalString;
122 unsigned int hashValue;
123
124 unsigned int calculateHash(const char* str) {
125 // From: http://www.partow.net/programming/hashfunctions/ (JSHash)
126 // Simple use another method if this one isn't working well.
127 unsigned int hash = 1315423911;
128
129 int i = 0;
130 while (str[i]) {
131 hash ^= ((hash << 5) + str[i] + (hash >> 2));
132 ++i;
133 }
134
135 return hash;
136 }
137 };
138
139 VRECKO_EXPORT struct StringWithHashComparator {
140 bool operator()(const StringWithHash &a, StringWithHash const &b) {
141 if (a.hashValue != b.hashValue)
142 return (a.hashValue < b.hashValue);
143 return (a.originalString < b.originalString);
144 }
145 };
146
156 typedef std::multimap<StringWithHash, ICS *, StringWithHashComparator> EI_Type;
157
159 typedef std::map<StringWithHash, REQUEST_Struct, StringWithHashComparator> REQUEST_Map;
160
161 #ifdef WIN32
162 void setMainThreadId(DWORD dwID) { hMainThreadId = dwID; }
163 #else
164 void setMainThreadId(pthread_t ptID) { hMainThreadId = ptID; }
165 #endif
166
174 bool insertEventInterconnection(const std::string &sender, const std::string &receiver, InterconnectionType type = FORWARD_OUTPUT, const std::string &sceneFile = *((std::string*)NULL));
175
178 bool deleteEventInterconnection(const std::string &sender, const std::string &receiver, InterconnectionType type = FORWARD_OUTPUT);
179
183 void dirtyInterconnectionsForObject(BaseClass *object, bool bProcessEvents = true, bool bProcessRequests = true);
184
185
190 inline bool reportEvent(const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType = EXPRESS_EVENT) {
191 return reportEventCore(NULL, senderAndOutputString, pMessage, eType);
192 }
193
197 inline bool reportEvent(BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType = EXPRESS_EVENT) {
198 return reportEventCore(receiver_ptr, input_name, pMessage, eType);
199 }
200
202 osg::ref_ptr<VreckoMessage> request(const std::string &req_sender, VreckoMessage *pMessage);
203
205 osg::ref_ptr<VreckoMessage> request(BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage);
206
207
212 void update(void);
213
215 void setScenePtr(Scene *ptr) {scene_ptr = ptr;}
216
217 /* Sets pointer of the World. ... REDUNDANT: Already present in the BaseClass*/
218 // void setWorldPtr(World *ptr) {pWorld = ptr;}
219
224 bool addOuterObject(const std::string &object_id, BaseClass *pOObject);
225
227 bool removeOuterObject(const std::string &object_id);
228
230 bool removeOuterObject(BaseClass *pOObject);
231
232 inline EI_Type &getEventInterconnectionMap() { return event_interconnection_map; }
233 inline REQUEST_Map &getRequestInterconnectionMap() { return request_interconnection_map; }
234 inline REQUEST_Map &getDefaultRequestInterconnectionMap() { return default_request_interconnection_map; }
235
237 typedef struct {
238 std::string sender;
239 std::string receiver;
240 InterconnectionType type;
241 const std::string *sceneFile;
242 // a file that this connection will be saved to. Pointer to a shared memory.
243 // BTW it's a _variable pointer_ to a _constant string_
244 } EventDefinitionStruct;
245
247 std::vector<EventDefinitionStruct> &getEventsVector(void) {return eventsVector;}
248
249 // ----- Net support
250
251 /* OBSOLETE - never really used in real life, but may be reimplemented again if necessary (it was made obsolete after the new message implementation
252
253 typedef struct NetEventStruct {
254 NetEventStruct() {message_event_image = NULL;}
255 ~NetEventStruct() {if (message_event_image) free(message_event_image);}
256
257 std::string sender;
258 BaseClass::IO_Type type;
259 long int int_event;
260 double double_event;
261 double field_event[16];
262 std::string string_event; // used also for Message ID
263 void *message_event_image;
264 long int message_image_size;
265 };
266
267 bool sendNetEvents(void);
268
269 bool reportNetEvents(std::vector<NetEventStruct> *ne_vector);
270 */
272 void setNetSupport(bool status);
273
290 bool parseSR(const std::string &sr, bool isSender, BaseClass **pEntity, SRType *pSRType, std::string *pIOName, osg::ref_ptr<VreckoMessage> *pRefMessage, bool isRequest = false, bool noErrorOuptut = false);
291
293 int getProcessedEventsCounter() { return iProcessedEventsCounter; }
294
296 void resetProcessedEventsCounter() { iProcessedEventsCounter = 0; }
297
298 protected:
300 std::vector<EventDefinitionStruct> eventsVector;
302 EI_Type event_interconnection_map;
304 std::vector<EventStruct*> incoming_events[2];
305 int bgListId; // background list Id (index)
306 bool bAllowForegroundListQueing;
307 // Allow messages to be queued into the foreground list (with locking!)
308 // Such messages will be guaranteed to be processed in the current frame.
309 // WARNING: Only change this variable inside a locked block (see [mainLock])
310
312 std::map<std::string, void*> received_event_map;
313
314 typedef std::vector<std::string> Decomposition_vec;
316 std::map<std::string, Decomposition_vec> sender_decomposition;
317
319 std::map<std::string, Decomposition_vec> receiver_decomposition;
320
321 REQUEST_Map request_interconnection_map;
322 REQUEST_Map default_request_interconnection_map;
323
325 Scene *scene_ptr;
326
327 // World *pWorld;
328
330 std::map<std::string, BaseClass *> outerObject_map;
331
332 int iProcessedEventsCounter;
333
334
336 bool net_support;
337 // std::vector<NetEventStruct> *net_events;
338 // void (*reportNetEventsToServer)(std::vector<NetEventStruct> *);
339
340 #ifdef WIN32
341 DWORD hMainThreadId;
342 #else
343 pthread_t hMainThreadId;
344 #endif
345 MTLock mainLock;
347 bool isInMainThread();
348
349 /* Processes pending batch of message.
350 *
351 * Typically called once per frame (in the EventDispatcher::update() ), to process all the messages,
352 * which were accumulated over the last frame.
353 * This is only relevant for messages with a lower priority then EXPRESS, as the EXPRESS messages
354 * are usually processed immediately (except EXPRESS message from other-than-main threads, which
355 * are converted into lower priority messages and processed here).
356 */
357 void processBatchOfEvents(std::vector<EventStruct*> *ref_incoming_events, bool bTurnOffForegroundQueing);
358
359 /* Main low-level method, which handles processing of a single event.
360 *
361 * Note that it is different from BaseClass::processEvent().
362 */
363 void processEvent(EventStruct *pES);
364
365 /* Main low-level method, which handles attempts to send an event.
366 *
367 * Decides the time of actual processing of the event. Either postpones the processing or diretly calls the EventDispatcher::processEvent().
368 */
369 bool reportEventCore(BaseClass *receiver_ptr, const std::string &sender, VreckoMessage *pMessage, EventType eType);
370
372 void debugPrintInterconnectionMap(EI_Type *map);
373
375 void debugPrintRequestMap(REQUEST_Map *map);
376
377
383 bool checkInterconnection(const std::string &sender, const std::string &receiver, bool bRequest);
384 // Great for debug, but can be turned off.
385 // Checks interconnection for any problems (missing sender/receiver), incorrect output/input types
386 };
387
388 }
389
390 #endif
391
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/EyeManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
EyeManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Vec3>
4 #include <osg/Quat>
5 #include <osg/Matrix>
6
7
8 using namespace vrecko;
9
10 namespace behindO {
11
12 class EyeManipulator: public Ability {
13 public:
14 EyeManipulator();
15 ~EyeManipulator() {};
16
17 // ------ BaseClass functions ------------------------
19 void processEvent(const std::string &input_name, void *value);
20 // ---------------------------------------------------
21
22 void preInitialize(void);
23 void update(void);
24
25 std::string getAcceptableMessages(void) {return "boolean|state";} // true/false, 0/1
26
27 protected:
28 //osg::Vec3 grab_position, actual_position, last_position, center_rotation;
29
30 //osg::Vec3 avatar_eye, avatar_center, avatar_up_vector;
31
32 int control;
33 bool _first;
34
35 osg::Vec3 sensor_relative_pos, initial_sensor_pos, last_sensor_pos;
36 osg::Quat last_sensor_orientation;
37 float eye_distance_scale_factor;
38 osg::Vec3 head_center, eye_position, up_vector, look_at_center, to_center;
39
40 osg::Vec3 EO_owner_grab_pos, avatar_grab_pos;
41 osg::Matrix EO_owner_grab_rot, avatar_grab_transform, avatar_grab_inverse_transform, avatar_grab_rotation, avatar_grab_inverse_rotation;
42 osg::Matrix EO_owner_grab_Wrot;
43
44 bool active;
45
46 EnvironmentObject *owner;
47 };
48
49 }
50
51 //$Id: EyeManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoaderBase.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
GeometryLoaderBase.h
Go to the documentation of this file.
1 #ifndef GEOMETRY_LOADER_BASE_H
2 #define GEOMETRY_LOADER_BASE_H
3
4
5 // THIS IS A DERIVATE of the original GeometryLoaderBase from the Phantom library (also in Vrecko solution)...
6 // try to use THAT ONE as a reference.
7
8
9
10 #include <vrecko/Ability.h>
11 #include <osg/Node>
12 #include <osg/Geode>
13 #include <osg/Geometry>
14
15 using namespace vrecko;
16
17 namespace APFFDEditor {
18
19 /*
20 Basic class to load geometry from OpenSceneGraph node
21 */
22
23 class GeometryLoaderBase {
24 public:
25 GeometryLoaderBase();
26 ~GeometryLoaderBase();
27 // NOTE: Don't forget to call destroyGeometry() in your destructor.
28
29 // The idea:
30 // This class contains the basic loading routines.
31 // Descendant classes can create their descendant versions of _VertexBase_ and _FaceBase_ classes
32 // but in that case it is IMPORTANT to also override methods that take care of allocation
33 // and returns the correct size of the used structure!
34 // You have to also call destroyGeometry() in your destructor (of the GeometryLoaderBase descendant).
35
36 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node);
37
38 struct VertexBase {
39 osg::Vec3 pos;
40 osg::Vec3 realPos;
41 osg::Vec3 normal;
42 osg::Vec3 relPosInGrid;
43 };
44 virtual unsigned long getVertexStructureSize() { return sizeof(VertexBase); }
45 virtual void allocateVertexArray(unsigned long numVertices) { vertices = new VertexBase[numVertices]; vertex_size = getVertexStructureSize(); }
46 virtual void deallocateVertexArray() { if (vertices) { delete[] ((VertexBase*)vertices); } }
47
48 struct FaceBase {
49 unsigned long vIndex[3]; // vertex indices (ordered clockwise)
50 osg::Vec3 min; // minimum coordinate (used for sorting)
51 osg::Vec3 normal;
52 // int index_to_geometry;
53 };
54 virtual unsigned long getFaceStructureSize() { return sizeof(FaceBase); }
55 virtual void allocateFaceArray(unsigned long numFaces) { faces = new FaceBase[numFaces]; face_size = getFaceStructureSize(); }
56 virtual void deallocateFaceArray() { if (faces) { delete[] ((FaceBase*)faces); }}
57
58 inline void* getFace(unsigned long index) { return (void*)(((unsigned char*)faces) + index * face_size); }
59 inline void* getVertex(unsigned long index) { return (void*)(((unsigned char*)vertices) + index * vertex_size); }
60
61 inline unsigned long getFaceCount() { return face_count; }
62 inline unsigned long getVertexCount() { return vertex_count; }
63
64 void debugWriteNormals();
65
66 protected:
67 void *faces;
68 unsigned long face_count;
69 unsigned long face_size; // cached number from getFaceStructureSize()
70
71 void *vertices;
72 unsigned long vertex_count;
73 unsigned long vertex_size; // cached number from getVertexStructureSize()
74
75 bool bRecalculateNormals;
77 vrecko::EnvironmentObject *thisOwnerPtr;
78
81 bool getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount);
82
83 // Fills the buffers with vertices and faces loaded from a given OSG node.
84 virtual bool loadGeometry(osg::Node *pNode);
85 bool loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos);
86 inline osg::Vec3 * getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array * pNormArray, osg::IndexArray * pNormIndices, unsigned long index);
87
88 // Iterates throught all the faces and sorts vIndex-es clockwise
89 void sortVerticesClockwise();
90
91 // Deallocates loaded faces/vertices
92 virtual void destroyGeometry();
93
94 // Ignores the old normals and creates new ones.
95 void recalculateNormals();
96
97
98 };
99
100 inline osg::Vec3 * GeometryLoaderBase::getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array * pNormArray, osg::IndexArray * pNormIndices, unsigned long index) {
101 if (osg::Geometry::BIND_OFF == normalBinding)
102 return ((osg::Vec3*)NULL);
103
104 if (pNormIndices) {
105 switch (pNormIndices->getDataType()) {
106 case osg::Array::ByteArrayType:
107 index = *(((char*)pNormIndices->getDataPointer()) + index);
108 break;
109 case osg::Array::ShortArrayType:
110 index = *(((short*)pNormIndices->getDataPointer()) + index);
111 break;
112 case osg::Array::IntArrayType:
113 index = *(((int*)pNormIndices->getDataPointer()) + index);
114 break;
115 case osg::Array::UByteArrayType:
116 index = *(((unsigned char*)pNormIndices->getDataPointer()) + index);
117 break;
118 case osg::Array::UShortArrayType:
119 index = *(((unsigned short*)pNormIndices->getDataPointer()) + index);
120 break;
121 case osg::Array::UIntArrayType:
122 index = *(((unsigned int*)pNormIndices->getDataPointer()) + index);
123 break;
124 default:
125
126 return (osg::Vec3*)NULL;
127 }
128 }
129
130 return ((osg::Vec3*)pNormArray->getDataPointer()) + index;
131 }
132
133 }
134
135 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Factories.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Factories.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "LinearInterpolator.h"
4 #include "CatmullRomInterpolator.h"
5
6 class InterpolatorFactory
7 {
8 public:
9 static std::vector<std::string> getSupportedInterpolators()
10 {
11 std::vector<std::string> interpolators;
12 interpolators.push_back("LinearInterpolator");
13 interpolators.push_back("CatmullRomInterpolator");
14
15 return interpolators;
16 }
17
18 static InterpolatorPtr get(const std::string& name)
19 {
20 if(name == "LinearInterpolator")
21 return new LinearInterpolator;
22 else if(name == "CatmullRomInterpolator")
23 return new CatmullRomInterpolator;
24 else
25 return new NullInterpolator;
26 }
27 };
28
29 //class BrushFactory
30 //{
31 // static std::vector<std::string> getSupportedBrushes()
32 // {
33 // std::vector<std::string> brushes;
34 // brushes.push_back("ConstantBrush");
35 // brushes.push_back("GradientBrush");
36 //
37 // return brushes;
38 // }
39 //
40 // static ColorGenPtr get(const std::string& name)
41 // {
42 // if(name == "GradientBrush")
43 // return new GradientBrush;
44 // else /*(name == "ConstantBrush")*/
45 // return new ConstantBrush; //NOTE: Constant brush is also a default brush (like null object)
46 // }
47 //};
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/FadeFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
FadeFilter.h
Go to the documentation of this file.
1 #ifndef FADE_FILTER_H
2 #define FADE_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to fade-in or fade-out the forces and keep them at zero level in the meantime.
11 Can be used alone to fade in the force on the start of the program,
12 or as a base class from which other filter is inherited. */
13 class FadeForceFilter : public PHANToMFilter {
14 public:
15 FadeForceFilter(const char* abName = "FadeFilter");
16
17 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
18 virtual void postInitialize(void);
19
20 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
21
22 protected:
23 // Parameters loaded from the Parameters element:
24 double defaultFadeTimeInSecs;
25 bool bFadeInFromStart;
26
27 enum FadeState {
28 Normal, // nothing is done
29 FadingOut, // fading out
30 Lowered, // forces are at zero level
31 FadingIn // fading in
32 };
33
34 FadeState fadeState;
35 double fadeTimeInSecs;
36 osg::Timer_t fadeTimeInTicks;
37 osg::Timer_t fadeStart; // [in Timer tick units]
38
39
40 void startFade(bool bFadeIn, double newFadeTimeInSecs = -1);
41 // If [bFadeIn] is "false", we are fading out.
42 // This method will also take in account any previous fade that might be currently in progress.
43 // If [fadeTimeInSecs] is negative, the [defaultFadeTimeInSecs] will be used.
44
45 inline float currentFadeFactor(osg::Timer_t currentTick) { // returns 0.0 - 1.0
46 checkFadingForEnd(currentTick);
47
48 if (fadeState == Normal)
49 return 1.0f;
50 if (fadeState == Lowered)
51 return 0.0f;
52
53 if (fadeState == FadingIn)
54 return (float)(currentTick - fadeStart) / (float)fadeTimeInTicks;
55
56 // => this must be a fade-out
57 return 1.0f - ((float)(currentTick - fadeStart) / (float)fadeTimeInTicks);
58 }
59
60 inline void checkFadingForEnd(osg::Timer_t currentTick) {
61 if ((fadeState == Normal) || (fadeState == Lowered))
62 return; // all OK
63
64 if (currentTick > fadeStart + fadeTimeInTicks) {
65 // fading passed the end -> stop fading
66 if (fadeState == FadingIn)
67 fadeState = Normal;
68 else
69 fadeState = Lowered;
70 }
71 }
72 };
73
74 }
75
76 #endif
77
78
79 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FilletSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
FilletSpline.h
Go to the documentation of this file.
1 #pragma once
2 #include "Spline.h"
3
4
13 class FilletSpline : public SplineDecorator
14 {
15
16 public:
17 FilletSpline(double filletRadius, unsigned int filletSteps, SplinePtr decoratedSpline);
18
20 META_DAObjectDecorator(_decoratedSpline, FilletSpline, "Fillet Spline")
21
22 virtual Vec3ArrayPtr getPoints();
23
24 protected:
25
26 // radius of rounding
27 double _filletRadius;
28
29 // number of interpolated points
30 unsigned int _filletSteps;
31
32
33 void generateAllFilletPoints( Vec3ArrayPtr result, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3 );
34
35 void getFilletPoints(osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, osg::Vec3& f1, osg::Vec3& f2);
36 };
37
38 typedef osg::ref_ptr<FilletSpline> FilletSplinePtr;
39
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/AP_Filter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
AP_Filter.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vreckoAP/Export>
4
5 #define INSTANCE
6 #define LIST
7
8 // ------------------------------
9 #include "Linear.h"
10 // ------------------------------
11
12
13 extern "C" AP_EXPORT const char **getAbilityList(void);
14 extern "C" AP_EXPORT Ability *getAbilityInstance(const char *_name);
15 extern "C" AP_EXPORT const char *getAbilityDescription(const char * name);
16 extern "C" AP_EXPORT const char *getPluginDescription(void);
17 extern "C" AP_EXPORT void initializeAttributesDescription() {}
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Filter.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Filter.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4 //newfilter
5 #define BASEK1 (0.9)
6 #define BASEK2 (0.1)
7 //oldfilter
8 //#define DEFAULTBASEK1 (0.154882 * 2000.0)
9 //#define DEFAULTBASEK2 (0.141881 * 2000.0)
10
11
12 using namespace vrecko;
13 using namespace vreckoDP_base;
14 namespace VirtualFixture{
15
16
17
18 class Filter: public PHANToMFilter {
19 public:
20 Filter();
21 ~Filter() {};
22
23 void Filter_Initialize(void); //inicializacni funkce
24 void Filter_Update(void); //pri zmene frekvence
25 void Filter_SetX_hat1(osg::Vec3 nx); //nastavuje inicialni hodnotu 1. vnitrni promenne
26 void Filter_SetX_hat2(osg::Vec3 nx); //nastavuje inicialni hodnotu 2. vnitrni promenne
27 void Filter_Mesurement(osg::Vec3 z); //mereni
28 void Filter_Prediction(void); //predikcni krok
29 osg::Vec3 Filter_GetPosition(void); //vraci hodnotu pozice (vystup filtru)
30 osg::Vec3 Filter_GetVelocity(void); //vraci hodnotu rychlosti
32 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
33 void processEvent(const std::string &input_name, void *value);
34
35 void preInitialize(void);
36 void postInitialize(void);
37 void update(void);
38
39 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
40 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
41
42 protected:
43 PHANToM *PHANToMDevice;
44 bool all_on;
45 bool active; //if true, filter will be active
46 unsigned int freq; //frequncy of phantom thread
47 float k1; //kalmanuv zisk (1.radek)
48 float k2; //kalmanuv zisk (2.radek)
49 osg::Vec3 x_hat1; //odhad x po mereni
50 osg::Vec3 x_hat2; //minuly odhad (pro urceni rychlosti)
51 osg::Vec3 x_hat_prev1; //odhad x pred merenim
52 osg::Vec3 x_hat_prev2; //odhad x pred merenim
53 osg::Vec3 inovation; //rozdil odhadu a mereni
54 };
55
56 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FixedJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
FixedJoint.h
Go to the documentation of this file.
1 #ifndef FixedJoint_h
2 #define FixedJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class FixedJoint : public BaseJoint
15 {
16 public:
17 FixedJoint():BaseJoint("FixedJoint", &_descripter){}
18
19 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
20 {
21 BaseJoint::loadXMLParameters(parametersNode);
22 return true;
23 }
24 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
25 {
26 return BaseJoint::getXMLParameters(domdocument);
27 }
28
29
30 protected:
31 NxFixedJointDesc _descripter;
32
33 };
34 }
35
36 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Fluid.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Fluid.h
Go to the documentation of this file.
1 #ifndef Fluid_h
2 #define Fluid_h
3
4 #include <fluids/NxFluid.h>
5 #include <fluids/NxFluidDesc.h>
6
7
8 #include "FluidDrawable.h"
9 #include "UpdatablePhysXObject.h"
10
11
12 namespace PhysXPlugin
13 {
14
15 class Fluid : public UpdatablePhysXObject
16 {
17 public:
18 Fluid():UpdatablePhysXObject("Fluid"){}
19 virtual ~Fluid(){}
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22
23
24
25 void BeforeInitialization();
26
27
28 protected:
29
30 void Create();
31 void UpdateEnvironmentObject();
32
33
34
35 FluidDrawable* _pFluidDrawable;
36 NxFluid* _pFluid;
37 NxParticleData _Particles;
38 NxFluidDesc _fluidDesc;
39 };
40
41 }
42
43
44 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/FluidDrawable.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
FluidDrawable.h
Go to the documentation of this file.
1 #ifndef FluidDrawable_h
2 #define FluidDrawable_h
3
4 #include <gl/glut.h>
5 #include <osg/Drawable>
6 #include <osg/Vec3>
7 #include "NxPhysics.h"
8 #include "Fluid.h"
9 #include "Helper.h"
10 #include <fluids/NxParticleData.h>
11
12
13 using namespace vrecko;
14
15 namespace PhysXPlugin
16 {
17 class FluidDrawable : public osg::Drawable
18 {
19 friend class Fluid;
20 private:
21
22 NxFluid* _pFluid;
23 NxParticleData _Particles;
24
25
26 protected:
27 FluidDrawable& operator = (const FluidDrawable&) { return *this;}
28
29
30
31
32 public:
33 FluidDrawable ()
34 {
35 this->setSupportsDisplayList(false);
36 }
37
38 FluidDrawable (NxFluid* pFluid)
39 {
40 _pFluid = pFluid;
41 _Particles = _pFluid->getParticlesWriteData();
42 this->setSupportsDisplayList(false);
43 dirtyBound();
44 }
45
46 virtual ~FluidDrawable(){}
47
48
49 FluidDrawable(const FluidDrawable& drawable,const osg::CopyOp& copyop=osg::CopyOp::SHALLOW_COPY):
50 Drawable(drawable,copyop)
51 {}
52
53 virtual osg::Object* cloneType() const { return new FluidDrawable(); }
54
55 virtual osg::Object* clone(const osg::CopyOp& copyop) const { return new FluidDrawable(*this,copyop); }
56
57
58 // test purpose only.
59 // predelat na dynamicky VBO
60 virtual void drawImplementation(osg::RenderInfo& renderInfo) const
61 {
62 glDisable(GL_LIGHTING);
63 glPointSize(5.0f);
64 glColor3f(1,0,0);
65 glEnableClientState(GL_VERTEX_ARRAY);
66
67 glVertexPointer(3, GL_FLOAT, _Particles.bufferPosByteStride, _Particles.bufferPos);
68 glDrawArrays(GL_POINTS, 0, *_Particles.numParticlesPtr);
69
70 glDisableClientState(GL_VERTEX_ARRAY);
71 glEnable(GL_LIGHTING);
72 }
73
74 virtual void Update()
75 {
76 assert(_pFluid->getParticlesWriteData().numParticlesPtr);
77 assert(*_pFluid->getParticlesWriteData().numParticlesPtr!=0);
78
79 dirtyBound();
80 }
81
82
83
84
85
86 virtual bool isSameKindAs(const osg::Object* obj)const {return dynamic_cast<const FluidDrawable*>(obj)!=NULL;}
87 virtual const char* libaryName() const {return "PhysX";} //pak zmenit
88 virtual const char* className() const {return "FluidDrawable";}
89
90
91
92 virtual osg::BoundingBox computeBound() const
93 {
94 NxBounds3 Nxbbox;
95 _pFluid->getWorldBounds(Nxbbox);
96
97 osg::BoundingBox bbox;
98 bbox.expandBy(ToosgVec3(Nxbbox.min));
99 bbox.expandBy(ToosgVec3(Nxbbox.max));
100
101 return bbox;
102 }
103
104 };
105 }
106
107 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/ForceField.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
ForceField.h
Go to the documentation of this file.
1 #ifndef BaseForceField_h
2 #define BaseForceField_h
3
4 #include "BasePhysXObject.h"
5
6 namespace PhysXPlugin
7 {
8
9 class ForceField : public BasePhysXObject
10 {
11 public:
12 ForceField();
13 virtual ~ForceField(){}
14
15 std::string getAcceptableMessages(void) {return "PhysXForceField";}
16
17 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
18 //virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
19 protected:
20
21 void Create();
22
23 NxForceFieldDesc _forceFieldDesc;
24 NxForceFieldLinearKernelDesc _forceFieldLinearKernelDesc;
25 };
26
27 }
28
29 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/FrenetFrame.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
FrenetFrame.h
Go to the documentation of this file.
1 #pragma once
2 #include "rotationframegenerator.h"
3 class FrenetFrame :
4 public RotationFrameGenerator
5 {
6 public:
7 FrenetFrame(void);
8 ~FrenetFrame(void);
9 };
10
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Controller.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
GUI_Controller.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4 #include "Menu.h"
5 #include "Layout.h"
6 #include "ItemsGroup.h"
7
8 # ifdef GUI_LIBRARY
9 # define GUI_EXPORT __declspec(dllexport)
10 # else
11 # define GUI_EXPORT __declspec(dllimport)
12 #endif
13
14 //FIXME solve somehow nicer... ask Martin - he will know some elegant solution, for sure
15 // if needed, this can be increased to any value
16 // see also 'OptiTrack.h' and 'InputConnector.h', some limitations is also there
17 // Kinect uses 20 sensors
18
19 // Is it really necessary to work with all tracked sensors in GUI controller ??
20 #define SENSOR_MAX_COUNT 20
21
22
23
24 using namespace vrecko;
25
26 namespace APGUI
27 {
28 typedef std::map<string, osg::ref_ptr<Layout>> LayoutMapType;
29
30
32
41 class GUI_EXPORT GUI_Controller : public Ability
42 {
43 public:
44
45 GUI_Controller();
46 ~GUI_Controller();
47
48
50 void enableGUI( bool enable );
51
53
57 ItemsGroup *getorCreateGroup( string groupName );
58
59 GUI_Item *getItembyName( string itemName );
60
61 string getLayoutString() { return _actualLayout->getName(); }
62
63 // Is called after all Environment Objects and abilities defined in XML are created (their constructors were called}
64 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
65
67
74 void registerPointableGuiItem( const unsigned int ID, GUI_Item* item);
75
76 void registerGlobalGuiItem( const int sensor, GUI_Item* item);
77
79 void reset();
80
82
87 void setMenuShown(const int sensor, Menu *shownMenu);
88
89
90 //TODO are both functions necessary?
91 bool setLayout(string name);
92
93 //TODO are both functions necessary?
94 bool switchLayout(string name);
95
96
97
98 void update();
99
100
101
102 void unregisterGlobalGuiItem( const int sensor, GUI_Item* item);
103
105
111 void unregisterPointableGuiItem( const unsigned int ID );
112
113 protected:
114
116
119 bool _disabled;
120
122
126 int _maxNunberofInputDevices;
127
129
133 int *_pointedIndexes;
134
135 // flag, used in update to post-post initialize some things, that can't be initialized earlier
136 bool _firstTimeUpdate;
137
139 GUI_Item **_pointedAbilities;
140
142 GUI_Item **_pressedAbilities;
143
145 std::vector<GUI_Item *> *_globalAbilities;
146
147 // array of lastly shown menus, indicating if there is menu shown for each sensor, or not ~ NULL value
148 Menu **_shownMenus;
149
151 osg::Vec3 *_actualPositions;
152
153
154 osg::Vec4 _colourActive;
155
156 osg::Vec4 _colourDefault;
157
158 osg::Vec4 _colourHovered;
159
160 osg::Vec4 _colourPressed;
161
162 osg::Vec4 _colourDisabled;
163
164
166
172 LayoutMapType _layouts;
173
174 //std::vector<osg::ref_ptr<Layout>> _layouts;
175
177
180 Layout * _actualLayout;
181
182
184 float _toolTipTime;
185
187 osg::Timer _timer;
188
190 osg::Timer_t *_pointedTime;
191
193 bool *_toolTipShown;
194
195
197
204 GuiItemMapType _itemsMap;
205
207 std::vector<osg::ref_ptr<ItemsGroup>> _groups;
208
210
219 void pointObjectByID( int sensor_number, unsigned long selectedID );
220
221
222 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed );
223 bool processContextClick( const int sensorNumber, const bool value );
224
225 // obsoleted - remove
226 //void processPosition( int sensor_num, osg::Vec3 pos );
227
228
229 // Buttons clicks (from Input Controller preferably)
230 DECLARE_REQUEST_INPUT(Sensor_0_mainClick, MessageBool, MessageBool);
231 DECLARE_REQUEST_INPUT(Sensor_1_mainClick, MessageBool, MessageBool);
232 DECLARE_REQUEST_INPUT(Sensor_0_contextClick, MessageBool, MessageBool);
233 DECLARE_REQUEST_INPUT(Sensor_1_contextClick, MessageBool, MessageBool);
234
235 // asking about what object is actually selected - Input Connector should answer
236 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
237
238
239 // from other parts of vrecko
240 DECLARE_INPUT(SwitchLayout, MessageString);
241
242
243
244
245
246 int _debugButtonPressed;
247 int _debugButtonReleased;
248 unsigned int _selectionaccumulator;
249 };
250
251 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_Text.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
GUI_Text.h
Go to the documentation of this file.
1 #pragma once
2
3 using namespace vrecko;
4
5
6 # ifdef GUI_LIBRARY
7 # define GUI_EXPORT __declspec(dllexport)
8 # else
9 # define GUI_EXPORT __declspec(dllimport)
10 #endif
11
12
13 namespace APGUI
14 {
15
16
18
26 class GUI_EXPORT GUI_Text : public osg::Geode
27 {
28 public:
29
30 GUI_Text();
31 ~GUI_Text();
32
33 void setText( const std::string& content, const osg::Vec3& pos, float size, osg::Vec4& color = osg::Vec4(0.0, 0.0, 0.0, 1.0));
34 void setText( const std::string& content );
35
36 void show();
37 void hide();
38
39 protected:
40 static osg::ref_ptr<osgText::Font> _font; //Shared among instances
41 osg::ref_ptr<osgText::Text> _text;
42
43 };
44
45 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/GUI_item.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
GUI_item.h
Go to the documentation of this file.
1 #pragma once
2
3 //#include "precompiled.h"
4 #include "GUI_Text.h"
5
6 #include <osgText/Font3D>
7 #include <osgText/Text3D>
8
9 using namespace vrecko;
10
11 namespace APGUI
12 {
13
14 typedef enum GUI_ITEM_STATE {
15 GUI_ITEM_STATE_DEFAULT = 1, // default state
16 GUI_ITEM_STATE_ACTIVE, // active - used in ICON:SWITCH class, when icon represents active state - e.g. auto-rotate
17 GUI_ITEM_STATE_DISABLED, // item is temporary disabled - it is visible, but it is 'grayed' and can't be pointed nor clicked
18 };
19
20 typedef enum GUI_ACTION {
21 GUI_ACTION_MAIN = 1,
22 GUI_ACTION_CONTEXT,
23 };
24
26 class Interconnection
27 {
28 public:
29 Interconnection(const string typ, const string sen, const string rec) { type = typ; sender = sen; receiver = rec; }
30
31 string type;
32 string sender;
33 string receiver;
34 };
35
36 class GUI_Controller;
37
38
39
40
42
54 class GUI_Item : public Ability
55 {
56 public:
57
58 GUI_Item(const char* abName);
59 ~GUI_Item();
60
61 string getGUIItemName() { return _name; }
62
64
71 virtual void pointed(bool pointed) = 0;
72
74 //TODO should this be virtual?
75 virtual void setState(GUI_ITEM_STATE newState) = 0;
76
78
85 virtual bool processAction( const int sensorNumber, const APGUI::GUI_ACTION action, const bool pressed) = 0;
86
88 inline bool isDefaultStateActive() { return _defaultStateActive; }
89
90 inline void show() { _parent->show(); }
91
92 inline void hide() { _parent->hide(); }
93
94 void hideTooltip();
95
96 void showTooltip();
97
99 //virtual void switchModels() = 0;
100
101
102
103 //void setLabel( const std::string& content, const osg::Vec3& pos, float size, osg::Vec4& color );
104
105
106 //for testing
107 //osgText::Text3D* createText3D( const osg::Vec3& pos, const std::string& content, float size, float depth );
108
109 virtual void setColours( osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled );
110
111
112 protected:
113
115
118 string _name;
119
121 string _receiver;
122
124 GUI_ITEM_STATE _state;
125
127 //FIXME if GUI_controller is implemented as singleton, this can be removed
128 GUI_Controller *_controller;
129
130 // Group for texts - label, tooltip, whatever
131 osg::Group *_texts;
132
134 osg::ref_ptr<GUI_Text> _label;
135
137 osg::ref_ptr<GUI_Text> _toolTip;
138
140 EnvironmentObject *_parent;
141
143 // used in Menu
144 int _sensorNumber;
145
147 osg::ref_ptr<osg::MatrixTransform> _itemTransform;
148
150 int _pointedCounter;
151
153 bool _pressed;
154
156 // e.g. one of tools and one color should be
157 bool _defaultStateActive;
158
159
160 // colors of items in different states
161
162 osg::Vec4 _colourActive;
163
164 osg::Vec4 _colourDefault;
165
166 osg::Vec4 _colourHovered;
167
168 osg::Vec4 _colourPressed;
169
170 osg::Vec4 _colourDisabled;
171
173 // for simplify deletion of interconnection during destructor
174 std::vector<Interconnection *> _interconnections;
175
176
177 // Create new structures, add to scene graph
178 osgText::Text* GUI_Item::createLabel();
179
180
182 bool initialize(bool pointable = true, int sensor = -1);
183
184 };
185
186 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/configuration.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
configuration.h
Go to the documentation of this file.
1 #ifndef CONFIGURATION_H_
2 #define CONFIGURATION_H_
3
4 #include <sstream>
5 #include <map>
6 #include <boost/program_options.hpp>
7
8 using namespace boost::program_options;
9 using std::vector;
10 using std::string;
11
12 namespace AP_LSystem {
13
17 enum LSystemCapabilities
18 {
19 LS_0L = 0x00000001,
20 LS_1LL = 0x00000002,
21 LS_1LR = 0x00000004,
22 LS_2L = 0x00000008,
23 LS_IL = 0x00000080,
24 LS_DETERMINISTIC = 0x00000100,
25 LS_STOCHASTIC = 0x00000200,
26 LS_PARAMETRIC = 0x00010000,
27 };
28
34 class Configuration
35 {
36 private:
37 static Configuration* config;
38
39 options_description description;
40 variables_map globalProperties;
41 std::vector<variables_map> lsystemProperties;
42 std::map<std::string, int> lsystemNameMap;
43
47 Configuration();
48
52 ~Configuration();
53 public:
59 bool loadCfgFile(string filename);
60
65 void setProperty(const string & prop);
66
72 void setProperty(const string & lsystemID, const string & prop);
73
80 void setProperty(const string & lsystemID, const string & prop, const string & value);
81
87 const int getLSystemIndex( const string & lsystemID );
88
93 const int getLSystemCount();
94
100 const variable_value * getProperty(const string & prop);
101
108 const variable_value * getProperty(const string & lsystemID, const string & prop);
109
110
117 const variable_value * getProperty(const unsigned int lsystemIndex, const string & prop);
118
123 static Configuration * get();
124
128 const void writeAll( std::basic_ostream<char> &, const string & );
129 };
130 }
131
132 #endif
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/utils.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
utils.h
Go to the documentation of this file.
1 #ifndef UTILS_H_
2 #define UTILS_H_
3
4 #include <string>
5 #include <vector>
6
7 namespace AP_LSystem {
11 class StringUtils
12 {
13 public:
17 static void uncommentLine(std::string &);
18
22 static std::string & eraseWhiteSpaces(std::string &);
23
27 static std::string processLine(std::fstream * , std::stringstream & );
28
32 static int processVector( std::string str, std::vector<double> & v );
33 };
34
38 struct Parameter
39 {
43 enum Type
44 {
45 LS_BYTE = 1,
46 LS_UBYTE,
47 LS_INT,
48 LS_UINT,
49 LS_FLOAT,
50 LS_DOUBLE
51 };
52
53 Parameter( void * value, Type type ):value(value),type(type){}
54
55 void * value;
56 Type type;
57 };
58 }
59
60 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/GenClouds.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
GenClouds.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_GENCLOUDS_H
10 #define _VRECKO_CLOUDS_GENCLOUDS_H
11
12 #include "cloud.h"
13
18 struct CloudVoxel
19 {
20 bool act, hum, cld;
21 float p_ext, p_act, p_hum;
22 };
23
30 void InitCloudGrowth(int ellips_a, int ellips_b, int ellips_c);
31
38 bool f_act(unsigned int i, unsigned int j, unsigned int k);
39
44 void GrowthSimulation(int timeSteps);
45
53 float weightedSum(unsigned int i, unsigned int j, unsigned int k);
54
61 void CreateCloudFromVoxels(Cloud& cloud, const osg::Vec3f& cloudPos, float scale);
62
63 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/GeneratedTerrainProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
GeneratedTerrainProperties.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_GENERATEDTERRAINPROPERTIES_H
11 #define VRECKO_NATURE_TERRAIN_GENERATEDTERRAINPROPERTIES_H
12
13 #include <vrecko/ReaderWriter.h>
14 #include <osg/Vec2>
15
16 #include "TerrainProperties.h"
17
18 namespace APNature
19 {
20 static class GeneratedTerrainProperties : public TerrainProperties
21 {
22 protected:
23
24 // Algorithm-type specific attributes
25 // ==================================
26 static AlgorithmType _algorithmType;
27
28 static int _randomSeed;
29
30 public:
31
32 // Algorithm-type specific methods
33 // ###############################
34
38 static inline AlgorithmType Algorithm() { return _algorithmType; }
39 static inline void Algorithm(AlgorithmType algorithmType) { _algorithmType = algorithmType; }
40
44 static inline int RandomSeed() { return _randomSeed; }
45 static inline void RandomSeed(int randomSeed) { _randomSeed = randomSeed; }
46
51 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
52
53 protected:
54
59 static void ParseRandomSeedString(const std::string& input);
60
61 } GeneratedTerrainProperties;
62
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Geometry.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Geometry.h
Go to the documentation of this file.
1 #ifndef _Geometry_H
2 #define _Geometry_H
3
4 #include <vrecko/Logger.h>
5
6 #include <helpers/XercesXMLUtils.h>
7 #include <xercesc/parsers/XercesDOMParser.hpp>
8 #include <xercesc/dom/DOM.hpp>
9 #include <xercesc/sax/HandlerBase.hpp>
10 #include <xercesc/util/XMLString.hpp>
11 #include <xercesc/util/PlatformUtils.hpp>
12
13 #include <osg/Geometry>
14 #include <vector>
15 #include <cmath>
16 #include <osg/ref_ptr>
17 #include <iostream>
18 #include "RealCmp.h"
19
20 #define RE_DEFAULT_HEIGHT 20.0
21 #define RE_DEFAULT_BOTTOM 0.0
22 #define RE_DEFAULT_2_WIDTH 0.75
23 #define RE_MIN_LENGTH 5.0
24 #define RE_DEFAULT_COLOR osg::Vec3(1.0, 1.0, 1.0)
25 #define RE_MIN_ANGLE(x,y) ((x)<(y) ? 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(x)) : 2*(RE_DEG_2_RAD_RATIO)*asin((RE_DEFAULT_2_WIDTH)/(y)))
26
27 #define RE_DEG_2_RAD_RATIO (180.0 / 3.141592653589793238)
28
29 #define RE_WALL_ANGLES_COMPUTED 1
30 #define RE_WALL_DRAWN 2
31
32 using namespace vrecko;
33
34 namespace WGeometry
35 {
36 enum PointType {
37 WG_Q_POINT,
38 WG_R_POINT
39 };
40
42 // class with helpful geometric methods
43 class WG_Geometry {
44 public:
45 WG_Geometry() {}
46 ~WG_Geometry() {}
47
48 static bool getCrossingPoint(osg::Vec2& destPoint, osg::Vec2 pPoint, osg::Vec2 pNormal, osg::Vec2 rPoint, osg::Vec2 rNormal, bool justStroke) {
49 float d1, d2, div;
50 float resultX, resultY;
51 float param, tparam;
52
53 d1 = -1*(pPoint.x() * pNormal.x() + pPoint.y() * pNormal.y());
54 d2 = -1*(rPoint.x() * rNormal.x() + rPoint.y() * rNormal.y());
55 div = (rNormal.x() * pNormal.y() - pNormal.x() * rNormal.y());
56
57 bool result = false;
58
59 if (!RealCmp<float>::compareEQ(div, 0.0f)) { // are not parallel
60 resultX = (d1 * rNormal.y() - d2 * pNormal.y()) / div;
61 if (RealCmp<float>::compareEQ(pNormal.y(), 0.0f)) {
62 resultY = (-d2 - rNormal.x() * resultX) / rNormal.y();
63 }
64 else {
65 resultY = (-d1 - pNormal.x() * resultX) / pNormal.y();
66 }
67
68 if (RealCmp<float>::compareEQ(pNormal.x(), 0.0f))
69 param = (resultX - pPoint.x()) / pNormal.y();
70 else
71 param = (resultY - pPoint.y()) / (-pNormal.x());
72
73 if (RealCmp<float>::compareEQ(rNormal.x(), 0.0f))
74 tparam = (resultX - rPoint.x()) / rNormal.y();
75 else
76 tparam = (resultY - rPoint.y()) / (-rNormal.x());
77
78 destPoint = osg::Vec2(resultX, resultY);
79 if (justStroke)
80 result = ((param > 0.000009) && (param < 0.999999) && (tparam > 0.000009) && (tparam < 0.999999));
81 else
82 result = true;
83 }
84
85 return result;
86 }
87
88 static bool barycentricTest(osg::Vec2 P, osg::Vec2 A, osg::Vec2 B, osg::Vec2 C) {
89 // Compute vectors
90 osg::Vec2 v0 = C - A,
91 v1 = B - A,
92 v2 = P - A;
93
94 // Compute dot products
95 float dot00 = v0 * v0,
96 dot01 = v0 * v1,
97 dot02 = v0 * v2,
98 dot11 = v1 * v1,
99 dot12 = v1 * v2;
100
101 // Compute barycentric coordinates
102 float invDenom = 1 / (dot00 * dot11 - dot01 * dot01),
103 u = (dot11 * dot02 - dot01 * dot12) * invDenom,
104 v = (dot00 * dot12 - dot01 * dot02) * invDenom;
105
106 // Check if point is in triangle
107 return (u >= 0) && (v >= 0) && (u + v <= 1);
108 }
109
110
111 static float getAngle(osg::Vec2& vector) {
112
113 float angle, toSum = 0;
114 if (RealCmp<float>::compareEQ(vector.x(), 0.0f)) {
115 if (vector.y() >= 0) {
116 angle = 90;
117 }
118 else {
119 angle = 270;
120 }
121 }
122 else if(RealCmp<float>::compareEQ(vector.y(), 0.0f)) {
123 if (vector.x() >= 0) {
124 angle = 0;
125 }
126 else {
127 angle = 180;
128 }
129 }
130 else {
131 if ((vector.x() > 0) && (vector.y() > 0)) {
132 toSum = 0;
133 }
134 else if ((vector.x() < 0) && (vector.y() > 0)) {
135 toSum = 180;
136 }
137 else if ((vector.x() < 0) && (vector.y() < 0)) {
138 toSum = 180;
139 }
140 else {
141 toSum = 360;
142 }
143 angle = ((atan(vector.y() / vector.x())*RE_DEG_2_RAD_RATIO) + toSum);
144 }
145 return angle;
146 }
147 };
148
149 class WG_Wall;
150
152 // class which just stores some vertices (used in WGWall)
153 class WG_Vertices {
154 public:
155 WG_Vertices() { validVertices = false; }
156 virtual ~WG_Vertices() {}
157
159 // setters and getters
160 void setTopCWVertex(osg::Vec3 P) { topCWVertex = P; }
161 osg::Vec3 getTopCWVertex() { return topCWVertex; }
162
163 void setTopCCWVertex(osg::Vec3 P) { topCCWVertex = P; }
164 osg::Vec3 getTopCCWVertex() { return topCCWVertex; }
165
166 void setBottomCWVertex(osg::Vec3 P) { bottomCWVertex = P; }
167 osg::Vec3 getBottomCWVertex() { return bottomCWVertex; }
168
169 void setBottomCCWVertex(osg::Vec3 P) { bottomCCWVertex = P; }
170 osg::Vec3 getBottomCCWVertex() { return bottomCCWVertex; }
171
172 void setNormalCWVertex(osg::Vec2 P) { normalCWVertex = P; }
173 osg::Vec2 getNormalCWVertex() { return normalCWVertex; }
174
175 void setNormalCCWVertex(osg::Vec2 P) { normalCCWVertex = P; }
176 osg::Vec2 getNormalCCWVertex() { return normalCCWVertex; }
177
178 void setValidVertices(bool valid) { validVertices = valid; }
179 bool areValidVertices() { return validVertices; }
180
181 private:
182 osg::Vec3 topCWVertex;
183 osg::Vec3 topCCWVertex;
184 osg::Vec3 bottomCWVertex;
185 osg::Vec3 bottomCCWVertex;
186
187 osg::Vec2 normalCWVertex;
188 osg::Vec2 normalCCWVertex;
189
190 bool validVertices;
191 };
192
193
195 // class representin a point of a wall
196 class WG_Point : public osg::Referenced {
197 public:
198 WG_Point(osg::Vec2 position, float height = RE_DEFAULT_HEIGHT) { this->position = position; this->height = height; }
199 virtual ~WG_Point() { plusVertices.clear(); plusNormals.clear(); plusColors.clear(); }
200
202 // setters and getters
203 void setPosition(osg::Vec2 position) {
204 this->position = position;
205 }
206 osg::Vec2 getPosition() { return position; }
207
208 float getHeight() { return height; }
209
210 void addWall(WG_Wall* wall, PointType connectionPointType, bool compute = true);
211 void removeWall(WG_Wall* wall);
212 std::vector<std::pair<osg::ref_ptr<WG_Wall>, PointType> >* getWalls() { return &walls; }
213
214 void setId(unsigned int i) { id = i; }
215 unsigned int getId() { return id; }
216
217 void setIndexTop(unsigned int i) { indexTop = i; }
218 unsigned int getIndexTop() { return indexTop; }
219
220 void setIndexBottom(unsigned int i) { indexBottom = i; }
221 unsigned int getIndexBottom() { return indexBottom; }
222
223 std::vector<osg::Vec3>* getPlusVertices() { return &plusVertices; }
224 std::vector<osg::Vec3>* getPlusNormals() { return &plusNormals; }
225 std::vector<osg::Vec3>* getPlusColors() { return &plusColors; }
226
228 // returns wall neighbours from the attribute walls
229 bool getWallNeighbours(WG_Wall* wall, std::pair<osg::ref_ptr<WG_Wall>, PointType>& wallCW, std::pair<osg::ref_ptr<WG_Wall>, PointType>& wallCCW);
230
231 private:
232 osg::Vec2 position;
233 float height;
234
235 unsigned int id; // = index to array of points in WallGeometry Ability
236
237 std::vector<std::pair<osg::ref_ptr<WG_Wall>, PointType> > walls; // walls connected to the point
238
239 unsigned int indexTop;
240 unsigned int indexBottom;
241
242 std::vector<osg::Vec3> plusVertices; // used when drawing walls
243 std::vector<osg::Vec3> plusNormals;
244 std::vector<osg::Vec3> plusColors;
245 };
246
247 enum HoleType {
248 ht_window,
249 ht_door
250 };
251
252
254 // class representin a hole in the wall
255 class WG_Hole {
256 public:
257 WG_Hole(float position, float y, float height, float width, HoleType type) {
258 this->position = position;
259 this->y = y;
260 this->height = height;
261 this->width = width;
262 this->type = type;
263 }
264 ~WG_Hole() {}
265
267 // setters and getters
268 void setPosition(float position) { this->position = position; }
269 float getPosition() { return position; }
270
271 void setY(float y) { this->y = y; }
272 float getY() { return y; }
273
274 void setHeight(float height) { this->height = height; }
275 float getHeight() { return height; }
276
277 void setWidth(float width) { this->width = width; }
278 float getWidth() { return width; }
279
280 void setType(HoleType type) { this->type = type; }
281 HoleType getType() { return type; }
282
283 WG_Vertices* getQVertices() { return &qVertices; }
284 WG_Vertices* getRVertices() { return &rVertices; }
285
286 private:
287 float position; // distance from Q
288 float y;
289
290 float height;
291 float width;
292 HoleType type;
293 WG_Vertices qVertices;
294 WG_Vertices rVertices;
295 };
296
297
299 // important class representing a wall
300 class WG_Wall : public osg::Referenced {
301 public:
302 WG_Wall(WG_Point* qPoint, WG_Point* rPoint, bool compute = true) {
303 flag = 0; q = qPoint; r = rPoint;
304 qAttr.color = RE_DEFAULT_COLOR;
305 rAttr.color = RE_DEFAULT_COLOR;
306 computeAttrVectorsAndAngles();
307
308 qPoint->addWall(this, WG_Q_POINT, compute);
309 rPoint->addWall(this, WG_R_POINT, compute);
310
311 if (compute)
312 computeAttrVertices();
313 }
314 virtual ~WG_Wall() {}
315
317 // setters and getters
318 void setPoints(WG_Point* qPoint, WG_Point* rPoint) {
319 q->removeWall(this); r->removeWall(this);
320 q = qPoint; r = rPoint;
321 computeAttrVectorsAndAngles();
322 q->addWall(this, WG_Q_POINT);
323 r->addWall(this, WG_R_POINT);
324 computeAttrVertices();
325 }
326
327 void setPoint(WG_Point* point, PointType type) {
328 if (type==WG_Q_POINT) {
329 q->removeWall(this);
330 q = point;
331 computeAttrVectorsAndAngles();
332 q->addWall(this, WG_Q_POINT);
333 }
334 else {
335 r->removeWall(this);
336 r = point;
337 computeAttrVectorsAndAngles();
338 r->addWall(this, WG_R_POINT);
339 }
340 computeAttrVertices();
341 }
342
343 WG_Point* getPoint(PointType type) { return (type==WG_Q_POINT ? q.get() : r.get()); }
344 osg::ref_ptr<WG_Point> getPointRef(PointType type) { return (type==WG_Q_POINT ? q : r); }
345
346 osg::Vec2 getVector(PointType type) { return (type==WG_Q_POINT ? qAttr.vector : rAttr.vector); }
347 float getAngle(PointType type) { return (type==WG_Q_POINT ? qAttr.angle : rAttr.angle); }
348 WG_Vertices* getVertices(PointType type) { return (type==WG_Q_POINT ? &(qAttr.vertices) : &(rAttr.vertices)); }
349
350 void setColor(osg::Vec3 color, PointType type) { type==WG_Q_POINT ? qAttr.color = color : rAttr.color = color; }
351 osg::Vec3 getColor(PointType type) { return (type==WG_Q_POINT ? qAttr.color : rAttr.color); }
352
353 void setId(unsigned int i) { id = i; }
354 unsigned int getId() { return id; }
355
356 void setFlag(int flag) { this->flag = flag; }
357 int getFlag() { return flag; }
358
359 void setTopNormal(osg::Vec3 n) { topNormal = n; }
360 osg::Vec3 getTopNormal() { return topNormal; }
361
362 void setBottomNormal(osg::Vec3 n) { bottomNormal = n; }
363 osg::Vec3 getBottomNormal() { return bottomNormal; }
364
365 void setFaceNormal(osg::Vec3 n, PointType type) { (type==WG_Q_POINT ? qrNormal = n : rqNormal = n); }
366 osg::Vec3 getFaceNormal(PointType type) { return (type==WG_Q_POINT ? qrNormal : rqNormal); }
367
368 std::vector<WG_Hole>* getHoles() { return &holes; }
369
371 // computes both angles an vectors
372 void computeAttrVectorsAndAngles();
373 bool areAnglesComputed() { return flag & RE_WALL_ANGLES_COMPUTED; }
374
376 // computes vertices and normals for vertexArray and normalArray
377 void computeAttrVertices(PointType type);
378 void computeAttrVertices() { computeAttrVertices(WG_Q_POINT); computeAttrVertices(WG_R_POINT); computeAttrNormals(); computeHoleVertices(); }
379
380 bool computeAttrNormals();
381 void computeHoleVertices();
382
383 private:
384 struct PointRelatedAttr {
385 osg::Vec2 vector; // started from the point
386 float angle; // CCW angle of the vector
387
388 WG_Vertices vertices;
389 osg::Vec3 color; // color of the quad that has front face with vector going left to right
390 };
391
392 osg::ref_ptr<WG_Point> q;
393 PointRelatedAttr qAttr;
394
395 osg::ref_ptr<WG_Point> r;
396 PointRelatedAttr rAttr;
397
398 int flag;
399 unsigned int id;
400
401 osg::Vec3 topNormal;
402 osg::Vec3 bottomNormal;
403 osg::Vec3 qrNormal;
404 osg::Vec3 rqNormal;
405
406 std::vector<WG_Hole> holes;
407
409 // sets vector P2 - P1 and angle into corresponding attributes
410 void setVectorAndAngle(WG_Point* P1, WG_Point* P2, PointRelatedAttr* attr);
411
413 // computes normal from 3 points that form a triangle (half of a quad)
414 osg::Vec3 computeNormal(osg::Vec3 V1, osg::Vec3 V2, osg::Vec3 V3) {
415 osg::Vec3 A = V1 - V2;
416 osg::Vec3 B = V3 - V2;
417 osg::Vec3 normal = osg::Vec3((A.y() * B.z() - A.z() * B.y()), (A.z() * B.x() - A.x() * B.z()), (A.x() * B.y() - A.y() * B.x()));
418 normal.normalize();
419 return normal;
420 }
421
422 };
423
424
425 }
426
427 #endif
428
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/GeometryLoader.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
GeometryLoader.h
Go to the documentation of this file.
1 #ifndef GEOMETRY_LOADER_H
2 #define GEOMETRY_LOADER_H
3 #include <vrecko/Ability.h>
4 #include <osg/Node>
5 #include <osg/Geode>
6 #include <osg/Geometry>
7
8 using namespace vrecko;
9
10 /*
11 This class load vertexarrays from osg node into structure
12 */
13
14 namespace APFFDEditor {
15
16 class GeometryLoader {
17 public:
18 GeometryLoader();
19 ~GeometryLoader();
20 struct Geometry {
21 osg::Geometry * SetNode;
22 //osg::Vec3Array* pVertexArray;
23 osg::Vec3Array* pVertexStartArray;
24 osg::Vec3* pVertexRelposition;
25 osg::Matrix transformMatrix;
26 };
27 inline Geometry* getGeometry(unsigned long index){if (geometryArray) return (&geometryArray[index]); else return NULL;}
28 virtual bool loadGeometry(osg::Node *pNode);
29 unsigned long getGeometriesCount(void){return geometries_count;}
30 protected:
31
32 inline void allocateGeometryArray(int count) {
33 geometryArray = new Geometry[count]; geometries_count = count;
34 }
35 inline void deallocateGeometryArray() { if (geometryArray) { delete[] (geometryArray); } }
36 Geometry *geometryArray;
37 bool loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &geometry_pos);
38 bool getOSGInitCounts(osg::Node *pNode, unsigned long &pGeometriesCount);
39 virtual void destroyGeometry();
40 unsigned long geometries_count;
41
42 };
43
44 }
45
46 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientColorGen.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
GradientColorGen.h
Go to the documentation of this file.
1 #pragma once
2 #include "ColorGen.h"
3
4 class GradientColorGen : public ColorGen
5 {
6 public:
7 GradientColorGen() : _colorStart(osg::Vec4(1,1,1,1)), _colorEnd(osg::Vec4(1,1,1,1)) {}
8 GradientColorGen(const osg::Vec4& colorStart, const osg::Vec4& colorEnd)
9 : _colorStart(colorStart), _colorEnd(colorEnd) {}
10
11 META_DAObject(GradientColorGen, "Gradient Brush")
12
13
14 virtual Vec4ArrayPtr getColors( unsigned int leadSplineSize, unsigned int crossSectionSize )
15 {
16 _dirty = false;
17
18 Vec4ArrayPtr result = new osg::Vec4Array;
19 unsigned int arraySize = leadSplineSize * crossSectionSize;
20 result->reserve(arraySize);
21
22 osg::Vec4 gradientStep = (_colorEnd - _colorStart) / (double)leadSplineSize;
23 osg::Vec4 actualColor;
24
25 for (unsigned int i = 0; i < leadSplineSize; i++)
26 {
27 actualColor = _colorStart + gradientStep * i;
28 for (unsigned int j = 0; j < crossSectionSize; j++)
29 {
30 result->push_back(actualColor);
31 }
32 }
33 return result;
34 }
35
36 inline osg::Vec4 getColorEnd() const { return _colorEnd; }
37 inline void setColorEnd(osg::Vec4 val) { _dirty = true; _colorEnd = val; }
38
39 inline osg::Vec4 getColorStart() const { return _colorStart; }
40 inline void setColorStart(osg::Vec4 val) { _dirty = true; _colorStart = val; }
41
42 protected:
43 osg::Vec4 _colorStart;
44 osg::Vec4 _colorEnd;
45 };
46
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/GradientDiameterGen.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
GradientDiameterGen.h
Go to the documentation of this file.
1 #pragma once
2 #include "DiameterGen.h"
3
4 class GradientDiameterGen : public DiameterGen
5 {
6 public:
7 GradientDiameterGen() : _diameterStart(1.0), _diameterEnd(1.0) {};
8 GradientDiameterGen(double diameterStart, double diameterEnd)
9 : _diameterStart(diameterStart), _diameterEnd(diameterEnd) {};
10
11 META_DAObject(GradientDiameterGen, "Gradient Diameter")
12
13
14 virtual DoubleArrayPtr getDiameters( unsigned int arraySize )
15 {
16 _dirty = false;
17
18 DoubleArrayPtr result = new osg::DoubleArray;
19 result->reserve(arraySize);
20 double diameterStep = (_diameterEnd - _diameterStart) / arraySize;
21
22 for (unsigned int i = 0; i < arraySize; i++)
23 result->push_back(_diameterStart + diameterStep * i);
24
25 return result;
26 }
27
28 inline double getDiameterEnd() const { return _diameterEnd; }
29 inline void setDiameterEnd(double val) { _dirty = true; _diameterEnd = val; }
30
31 inline double getDiameterStart() const { return _diameterStart; }
32 inline void setDiameterStart(double val) { _dirty = true; _diameterStart = val; }
33
34 protected:
35 double _diameterStart;
36 double _diameterEnd;
37
38 };
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HMDHeadManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
HMDHeadManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Quat>
4
5 using namespace vrecko;
6
7 namespace behindO {
8
9 class HMDHeadManipulator: public Ability {
10 public:
11 HMDHeadManipulator();
12 ~HMDHeadManipulator() {};
13
14 // ------ BaseClass functions ------------------------
16 void processEvent(const std::string &input_name, void *value);
17 // ---------------------------------------------------
18
19 void preInitialize(void);
20 void update(void);
21
22 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
23 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
24
25 protected:
26 osg::Vec3 sensor_relative_pos, initial_sensor_pos, last_sensor_pos;
27 osg::Quat last_sensor_orientation;
28 float eye_distance_scale_factor;
29 osg::Vec3 head_center, eye_position, up_vector;
30
31 bool active;
32 };
33
34 }
35
36 //$Id: HMDHeadManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HUD/HUDDisplay.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HUD
HUDDisplay.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vrecko/EnvironmentObject.h>
5 #include <vrecko/Timer.h>
6
7 #include <osg/Geode>
8 #include <osgText/Text>
9 #include <osgText/Font>
10 #include <osg/BlendFunc>
11 #include <osg/Material>
12 #include <osg/StateSet>
13 #include <osg/Camera>
14 #include <string>
15
16 # ifdef HUD_LIBRARY
17 #define HUD_EXPORT __declspec(dllexport)
18 # else
19 # define HUD_EXPORT __declspec(dllimport)
20 #endif
21
22 using namespace vrecko;
23
24 namespace APHUD {
28 struct HUDColorProfile{
29 osg::Vec4f backgroundColor;
30 osg::Vec4f fontColor;
31 osg::Vec4f gradientStartColor;
32 osg::Vec4f gradientEndColor;
33 };
34
38 struct HUDField{
39 osg::ref_ptr<osgText::Text> text;
40 osg::ref_ptr<osg::Geometry> geometry;
41 osg::Vec4f color;
42 string name;
43 string actual_string;
44 int posX, posY;
45 bool animated;
46 float actualValue;
47 float maxValue;
48 float minValue;
49 osg::Vec4f colorMin;
50 osg::Vec4f colorMax;
51 };
52
56 struct HUDWindow {
57 osg::ref_ptr<osg::Geometry> geometry;
58 string name;
59 int sizeX, sizeY, posX, posY;
60 osg::Vec4f color;
61 bool visible;
62 list<HUDField> fields;
63 };
64
65
66 class HUD_EXPORT HUDDisplay: public Ability {
67 public:
68 HUDDisplay();
69 ~HUDDisplay(){};
70
71 virtual void preInitialize();
72 virtual void postInitialize();
73 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
74 virtual void update(void);
75
76 bool addWindow(string plugin_name);
77 bool updateWindowColor(string plugin_name, osg::Vec4f color);
78 bool addField(string field_name, string plugin_name);
79 bool updateFieldTextColor(string field_name, string plugin_name, osg::Vec4f color);
81 bool setFieldAsAnimated(string field_name, string plugin_name, bool value);
82 bool updateGradient(string field_name, string plugin_name, osg::Vec4f startColor, osg::Vec4f endColor);
83 bool updateValuesRange(string field_name, string plugin_name, float minValue, float maxValue);
85 bool removeWindow(string plugin_name);
86 bool removeField(string field_name,string plugin_name);
87 bool clearValue(string field_name, string plugin_name);
88 bool updateText(string text, string field_name ,string plugin_name);
89 bool updateValue(float value, string field_name ,string plugin_name);
91 bool setColorProfileforWindow(string plugin_name,int colorprofile);
96 float getActualValue(string field_name, string plugin_name );
97 bool hudWindowExist(string plugin_name);
98 bool hudFieldExist(string field_name, string plugin_name );
100 protected:
101 list<HUDWindow>::iterator getHUDWindow(string plugin_name);
102 list<HUDField>::iterator getHUDField(string field_name, string plugin_name);
104 bool correctName(string name);
111 osg::ref_ptr<osg::Camera> camera;
112 osg::ref_ptr<vrecko::EnvironmentObject> eo;
113 osg::ref_ptr<osg::Geode> geode;
114 osg::ref_ptr<osg::StateSet> stateSet;
115 vrecko::ViewerBase* viewer;
117 bool setValue(string text, string field_name ,string plugin_name);
119 void updateAllWindowsPositions();
120 void updateAllWindows();
121 void updateWindowSizeX(string plugin_name);
122 void updateWindow(string plugin_name);
124 void updateFieldsPosition(string plugin_name);
125 void updateFields(string plugin_name);
126 void updateField(string field_name, string plugin_name);
127 void updateAllFields();
128 void updateAllFieldsPosition();
129 void removeAllFields(string plugin_name);
131 list<HUDWindow> hudWindows;
133 int viewWidth;
134 int viewHeight;
137 int windowDefaultColorR;
138 int windowDefaultColorG;
139 int windowDefaultColorB;
140 int windowDefaultColorA;
142 int windowTabVertical;
143 int windowTabHorizontal;
144 int startWindowWidth;
145 int startWindowHeight;
147 int HUDDepthWindow;
148 int HUDDepthField;
149 int HUDDepthFieldBackground;
151 int HUDDivision;
153 int fieldDefaultColorR;
154 int fieldDefaultColorG;
155 int fieldDefaultColorB;
156 int fieldDefaultColorA;
158 int fieldTabVertical;
159 int fieldTabHorizontal;
160 int fieldSizeVertical;
162 int definedcolorprofiles;
163 HUDColorProfile cProfiles[10];
164 };
165
166 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/HeadManipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
HeadManipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Quat>
4 #include <osg/Matrix>
5
6 using namespace vrecko;
7
8 namespace behindO {
9
10 class HeadManipulator: public Ability {
11 public:
12 HeadManipulator();
13 ~HeadManipulator() {};
14
15 // ------ BaseClass functions ------------------------
17 void processEvent(const std::string &input_name, void *value);
18 // ---------------------------------------------------
19
20 void preInitialize(void);
21 void update(void);
22
23 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
24 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
25
26 protected:
27 //osg::Vec3 initial_sensor_pos;
28 //float scale_eye_distance_factor;
29 //osg::Vec3 head_center, eye_position;
30
31 osg::Vec3 sensor_relative_pos, initial_sensor_pos, last_sensor_pos;
32 osg::Quat initial_sensor_orientation, last_sensor_orientation;
33 float eye_distance_scale_factor;
34 //osg::Vec3 head_center, eye_position, up_vector;
35 float left_border, right_border, top_border, bottom_border, near_border, far_border;
36 // osg::Vec3 avatar_grab_pos;
37 // osg::Matrix avatar_grab_rot, avatar_grab_transf;
38
39 osg::Vec3 head_center, eye_position, up_vector, look_at_center, to_center;
40
41 osg::Vec3 avatar_grab_pos;
42 osg::Matrix avatar_grab_transform, avatar_grab_inverse_transform, avatar_grab_rotation, avatar_grab_inverse_rotation;
43
44 EnvironmentObject *owner;
45 bool active;
46
47 osg::Vec3 difference_sensor_pos, initial_sensor_x_orientation;
48 osg::Quat difference_sensor_orientation[2];
49
50 float x_sensitivity, y_sensitivity, x_sensitivity_delta, delta_z;
51 float minimal_distance;
52
53 // mode : 0 - standard, 1 - dynamic change of sensitivity, 2 - Stretch HM, 3 - Stretch HM (controled with orientation x, y + z_pos)
54 int mode;
55 };
56
57 }
58
59 //$Id: HeadManipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/HeadTracking.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
HeadTracking.h
Go to the documentation of this file.
1 #pragma once
2 #ifndef __HEAD_TRACKING_H
3 #define __HEAD_TRACKING_H
4
5 #include <osg\Vec4>
6 #include <vrecko\Ability.h>
7
8 #include "htUtils.h"
9
10 namespace ht
11 {
12
13 class HeadTracking: public vrecko::Ability
14 {
15 public:
16 HeadTracking();
17 virtual ~HeadTracking();
18
19 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
20
21 virtual void update();
22
23 DECLARE_INPUT(Transformation, vrecko::MessageSensorTransformation);
24
25 protected:
26 // Scene parameters
27 float unit;
28
29 // Screen parameters
30 ht::Screen screen;
31 osg::Vec3 s_corner, s_width, s_height;
32
33 // Sensor parameters
34 osg::Vec3 head_pos;
35 osg::Quat head_orientation;
36 int head_sensor_number;
37 osg::Vec3 left_eye_off;
38 osg::Vec3 right_eye_off;
39
40 // Optitrack parameters
41 float optitrack_scale;
42 osg::Vec3 optitrack_origin_position;
43 osg::Vec3 optitrack_translate_mapping;
44 float head_tracking_scale;
45 osg::Vec3 head_tracking_origin_position;
46 osg::Vec3 head_tracking_translate_mapping;
47
48 // Other variables
49 osg::Vec4 last_avatar_pos;
50
51 DECLARE_OUTPUT(MoveAvatar, vrecko::MessageVec3);
52 };
53
54 }
55
56 #endif // __HEAD_TRACKING_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/Heaps.h Source File

  • File List
  • File Members
  • include
  • helpers
Heaps.h
Go to the documentation of this file.
1 #ifndef HEAPS_H
2 #define HEAPS_H
3
4 #include <stdio.h>
5 #include <limits.h>
6
7 // Poznamky:
8 // - Rozsahlejsi porovnani hald je v souboru Heaps_info_CZ.doc
9 // - Plati, ze v rodici je ulozena mensi hodnota nez v detech (nebo si jsou
10 // hodnoty rovny).
11 // (existuji i implementace, ktere pracuji obracene)
12 // - Pri ruseni haldy se nedealokuji prvky.
13 // - Funkce hald Merge a Union vymazou uzly v druhe halde
14 // ( - presunou je do te, ktera zbude).
15 // - Uzivatel nesmi pouzit INT_MIN nebo nizsi pro hodnotu key
16 // v kteremkoliv uzlu (je to specialni hodnota
17 // pouzita ve funkcich Delete jako "zaporne nekonecno")
18
19 class GenericHeapNode;
20
21 // _NodeClass musi byt odvozena z GenericHeapNode
22 template <class _NodeClass, class _keyType>
23 class GenericHeap {
24 public:
25
26 class GenericHeapNode {
27 public:
28 _keyType key;
29 };
30
31 virtual void Insert (_NodeClass *node) = 0;
32 virtual _NodeClass* ExtractMin (void) = 0;
33 virtual void DecreaseKey (_NodeClass *node, _keyType value) = 0;
34 virtual _NodeClass* GetMin (void) = 0;
35 // Tato funkce se od ExtractMin lisi tim, z
36 // prvek z haldy nevymaze
37 virtual _NodeClass* Delete (_NodeClass *node) = 0;
38 // POZOR - Navratova hodnota nemusi byt stejna,
39 // jako vstupni
40
41 virtual bool IsEmpty() = 0;
42
43 protected:
44 };
45
46
47
48 class BinomialHeapNode;
49
50 // _NodeClass musi byt odvozena z BinomialHeapNode
51 template <class _NodeClass, class _keyType>
52 class BinomialHeap : public GenericHeap<_NodeClass, _keyType> {
53 public:
54
55 class BinomialHeapNode : public GenericHeapNode {
56 public:
57 BinomialHeapNode *parent;
58 BinomialHeapNode *child;
59 BinomialHeapNode *sibling;
60 int degree;
61
62 virtual void Swap (void *node);
63 // prohodi obsah tohoto uzlu se specifikovanym
64 // (obsah se tady rovna [key]; parent, child, sibling
65 // a degree musi zustat na miste)
66 };
67
68 BinomialHeap (void);
69 ~BinomialHeap (void);
70
71 virtual void Insert (_NodeClass *node);
72 virtual _NodeClass* ExtractMin (void);
73 virtual void DecreaseKey (_NodeClass *node, _keyType value);
74 // snizi hodnotu klice na hodnotu [value]
75 virtual _NodeClass* GetMin (void);
76 virtual _NodeClass* Delete (_NodeClass *node);
77
78 virtual void Union (BinomialHeap<_NodeClass, _keyType> *heap);
79
80 virtual void FreeAllNodes();
81
82 virtual bool IsEmpty() { return (head == NULL); }
83
84 protected:
85 _NodeClass *head;
86
87 inline void Link (_NodeClass *root1, _NodeClass *root2) {
88 // Pripoji prvni strom "pod" druhy
89 root1->parent = root2;
90 root1->sibling = root2->child;
91 root2->child = root1;
92 root2->degree++;
93 }
94 void Merge (BinomialHeap<_NodeClass, _keyType> *heap);
95 // Spoji dve haldy tak, aby stromy byly vysledne setrideny
96 // podle velikosti.
97
98 void FreeNodeSimple(_NodeClass *node);
99 // Uvolni z pameti uzel a jeho potomky
100 };
101
102
103 template <class _NodeClass, class _keyType>
104 void BinomialHeap<_NodeClass, _keyType>::BinomialHeapNode::Swap (void *node)
105 {
106 _keyType tmp = ((BinomialHeap::BinomialHeapNode*)node)->key;
107 ((BinomialHeap::BinomialHeapNode*)node)->key = key;
108 key = tmp;
109 }
110
111
112 // _NodeClass musi byt odvozena z FibonacciHeapNode
113 template <class _NodeClass, class _keyType>
114 class FibonacciHeap : public GenericHeap<_NodeClass, _keyType> {
115 public:
116 class FibonacciHeapNode : public GenericHeapNode {
117 public:
118 FibonacciHeapNode *parent;
119 FibonacciHeapNode *left;
120 FibonacciHeapNode *right;
121 FibonacciHeapNode *child;
122
123 int degree : ((sizeof(int) * 8) - 1);
124 unsigned int mark : 1;
125 // nebo jenom:
126 // int degree;
127 // bool mark;
128 };
129
130 FibonacciHeap (void);
131 ~FibonacciHeap (void);
132
133 virtual void Insert (_NodeClass *node);
134 virtual _NodeClass* ExtractMin (void);
135 virtual void DecreaseKey (_NodeClass *node, _keyType value);
136 virtual _NodeClass* GetMin (void);
137 virtual _NodeClass* Delete (_NodeClass *node);
138
139 virtual void Union (FibonacciHeap<_NodeClass, _keyType> *heap);
140
141 virtual void FreeAllNodes();
142
143 virtual bool IsEmpty() { return (head == NULL); }
144
145 protected:
146 _NodeClass *head;
147 _NodeClass *min;
148
149 void Consolidate (void);
150 void Link (_NodeClass *child, _NodeClass *parent);
151 virtual void Cut (_NodeClass *node1, _NodeClass *node2);
152 virtual void CascadingCut (_NodeClass *node);
153
154 void FreeNodeSimple(_NodeClass *node);
155 // Uvolni z pameti uzel a jeho potomky
156 };
157
158
159 // _NodeClass musi byt odvozena z ThinHeapNode
160 template <class _NodeClass, class _keyType>
161 class ThinHeap : public GenericHeap<_NodeClass, _keyType> {
162 public:
163
164 class ThinHeapNode : public GenericHeapNode {
165 public:
166 ThinHeapNode *pl;
167 // ukazatel na leveho sourozence nebo na otce
168 // (v pripade nejlevejsiho sourozence)
169 // V pripade seznamu korenu je v prvnim korenu
170 // ukazatel na posledni a opacne (cyklicky spojovy seznam)
171 ThinHeapNode *right;
172 ThinHeapNode *child;
173
174 int rank;
175 // Viz popis struktury "thin heap".
176 // POZOR - moje modifikace: Koren zde ma ulozeno
177 // "[skutecny rank] - INT_MIN". Porovnanim proti
178 // nule se da lehce poznat, ze je to koren
179 };
180
181 ThinHeap (void);
182
183 virtual void Insert (_NodeClass *node);
184 virtual _NodeClass* ExtractMin (void);
185 virtual void DecreaseKey (_NodeClass *node, _keyType value);
186 virtual _NodeClass* GetMin (void);
187 virtual _NodeClass* Delete (_NodeClass *node);
188
189 virtual void Union (ThinHeap<_NodeClass, _keyType> *heap);
190
191 virtual bool IsEmpty() { return (head == NULL); }
192
193 protected:
194 _NodeClass *head;
195 _NodeClass *min;
196
197 void Consolidate (void);
198 void Link (_NodeClass *child, _NodeClass *parent);
199
200 virtual void RepairViolations (_NodeClass *node);
201 };
202
203
204 #include "Heaps.cpp"
205
206 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/HeightMapProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
HeightMapProperties.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_HEIGHTMAPPROPERTIES_H
11 #define VRECKO_NATURE_TERRAIN_HEIGHTMAPPROPERTIES_H
12
13 #include <vrecko/ReaderWriter.h>
14 #include <osg/Vec2>
15
16 #include "TerrainProperties.h"
17
18 namespace APNature
19 {
20 static class HeightMapProperties : public TerrainProperties
21 {
22 protected:
23
24 // Image-type specific attributes
25 static std::string _heightMapPath;
26
27 public:
28
32 static inline const std::string& HeightMapPath() { return _heightMapPath; }
33 static inline void HeightMapPath(const std::string& heightMapPath) { _heightMapPath = heightMapPath; }
34
39 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
40
41 } HeightMapProperties;
42
43 }
44
45 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Helper.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Helper.h
Go to the documentation of this file.
1 #ifndef Helper_h
2 #define Helper_h
3 #include <osg/Vec3>
4 #include <osg/Quat>
5
6 #include "NXU_helper.h"
7
8 NxVec3 ToNxVec3(osg::Vec3 vec);
9 osg::Vec3 ToosgVec3(NxVec3 vec);
10
11 NxQuat ToNxQuat(osg::Quat);
12 osg::Quat ToosgQuat(NxQuat quat);
13
14 const char* NXUFTtoa(NXU::NXU_FileType fileType);
15
16 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/HelperMacros.h Source File

  • File List
  • File Members
  • include
  • helpers
HelperMacros.h
Go to the documentation of this file.
1 #ifndef HELPER_MACROS_H
2 #define HELPER_MACROS_H
3
4 #include <vrecko/Logger.h>
5
6 // Macros for error handling:
7 //
8
9 #define BFAILGOTO(Function) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); goto FuncFailed; } }
10 #define BFAILGOTO_TEXT(Function, TextFunc) { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } goto FuncFailed; } }
11 #define BFAILRET(Function) { if (!(Function)) { OUTPUTSTR3("\n%s(%d): An error occured!", __FILE__, __LINE__); return false; } }
12 #define BFAILRET_TEXT(Function, TextFunc) { if (!(Function)) { { OUTPUTSTR3("\n%s(%d): Following error occured:", __FILE__, __LINE__); TextFunc; } return false; } }
13
14
15 #ifndef SAFE_DELETE
16 #define SAFE_DELETE(p) { if(p) { delete (p); (p)=NULL; } }
17 #endif
18
19 #ifndef SAFE_FREE
20 #define SAFE_FREE(p) { if(p) { free (p); (p)=NULL; } }
21 #endif
22
23
24 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/HighlightCallback.h Source File

  • File List
  • File Members
  • include
  • vreckoUtils
HighlightCallback.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\NodeCallback>
4 #include <osg\Material>
5 #include "Export"
6
7 namespace vreckoUtils
8 {
9
11 class VRECKO_UTILS_EXPORT HighlightCallback : public osg::NodeCallback
12 {
13
14 public:
15 HighlightCallback(double increment)
16 : _dirty(false), _highlighted(false) { setIncrementValue(increment); }
17
18 virtual void operator()(osg::Node* node, osg::NodeVisitor* nv);
19
21 inline double getIncrementValue() const { return _increment; }
22 inline void setIncrementValue(double val) { _increment = val; _incrementVec = osg::Vec4(val, val, val, 0); }
23 inline bool getHighlighted() const { return _highlighted; }
24 inline void setHighlighting(bool val) { if(val != _highlighted) _dirty = !_dirty; _highlighted = val; }
25 inline void switchHighlighting() { setHighlighting(!getHighlighted()); }
26
27 protected:
28 bool _highlighted;
29 bool _dirty;
30 double _increment;
31 osg::Vec4 _incrementVec;
32 osg::ref_ptr<osg::Vec4Array> _origColors;
33 };
34
35 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/HoleRemove.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
HoleRemove.h
Go to the documentation of this file.
1 #ifndef _HOLE_REMOVE_H
2 #define _HOLE_REMOVE_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 // tool for removing holes from curWall
9 class HoleRemove : public Tool {
10 public:
11 HoleRemove(void) {type=HOLEREMOVE;}
12 virtual ~HoleRemove(void) {}
13
14 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
15 WG_Wall* curWall,
16 WG_Point* curPoint,
17 PointType type,
18 vrecko::EnvironmentObject* pEOOwner,
19 std::vector<osg::ref_ptr<WG_Wall> >* walls,
20 std::vector<osg::ref_ptr<WG_Point> >* points,
21 osg::Geode* pOSGGeode,
22 osg::Vec3Array* pOSGVertexArray) {
23
24 if (curWall != NULL) {
25
26 osg::Vec2 iPoint = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z());
27 osg::Vec2 vector = iPoint - curWall->getPoint(WG_Q_POINT)->getPosition();
28 float length = vector.length();
29 float minLength = curWall->getVector(WG_Q_POINT).length(), curLength = 0.0;
30 unsigned int delIndex = curWall->getHoles()->size();
31
32 // find the nearest hole
33 for (unsigned int i = 0; i < curWall->getHoles()->size(); i++) {
34 curLength = abs(length - curWall->getHoles()->at(i).getPosition());
35 if (curLength < minLength) {
36 minLength = curLength;
37 delIndex = i;
38 }
39 }
40
41 // if any hole found then remove it
42 if (delIndex < curWall->getHoles()->size()) {
43 curWall->getHoles()->erase(curWall->getHoles()->begin()+delIndex);
44 }
45
46 }
47 setDirty(true);
48 }
49 };
50
51 }
52
53 #endif
54
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hook.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Hook.h
Go to the documentation of this file.
1
8 #pragma once
9
10 #include "poa.h"
11
12 #include <vreckoUtils\HighlightCallback.h>
13 #include <vreckoUtils\Menu.h>
14 #include "PhysXManager.h"
15
16 namespace APDYNAMICART
17 {
18
19 class HookObject : public PoA
20 {
21 public:
22 HookObject(Controller* contr, Hoop* hoop, const osg::Vec3& position, double width);
23
25 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
26 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
27 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
28 virtual void GUIItemClicked( const char* itemID );
29 virtual void GUISliderChanged( const char* sliderID, float sliderPos ) {};
30 virtual void pointed( bool pointed ) { _highlight->setHighlighting(pointed); }
31 virtual void setColor( osg::Vec4 newColour ) {};
32 virtual void update() {};
33
35 Hoop* getParentHoop() const { return _hoop.get(); }
36
37 protected:
38 Controller* _contr;
39 osg::observer_ptr<Hoop> _hoop;
40 osg::ref_ptr<vreckoUtils::HighlightCallback> _highlight;
41 };
42
43 class HoopTrackerCallback : public osg::NodeCallback
44 {
45 public:
46 HoopTrackerCallback(PoA* poa, const osg::Vec3& offset, double scale) {
47 _poa = poa;
48 _offset = offset;
49 _scale = scale;
50 }
51
52 virtual void operator()(osg::Node* node, osg::NodeVisitor* nv) {
53 update(node, nv);
54 traverse(node, nv);
55 }
56
57 protected:
58 void update( osg::Node* node, osg::NodeVisitor* nv ) {
59 if(!_poa.valid()) return;
60 //if(PhysXManager::get()->isRunning()) return;
61
62 osg::MatrixTransform* hook = dynamic_cast<osg::MatrixTransform*>(node);
63 if(!hook) return;
64
65 osg::Quat inv_rot = _poa->getMatrix().getRotate().inverse();
66 osg::Quat inv_DA_rot = PhysXManager::getDAMatrix().getRotate().inverse();
67 hook->setMatrix(osg::Matrix::scale(osg::Vec3(_scale, _scale, _scale)) *
68 osg::Matrix::rotate(inv_DA_rot) *
69 osg::Matrix::rotate(inv_rot) *
70 osg::Matrix::translate(_offset) *
71 _poa->getMatrix());
72 }
73
74 osg::observer_ptr<PoA> _poa;
75 osg::Vec3 _offset;
76 double _scale;
77 };
78
79 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HookManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
HookManager.h
Go to the documentation of this file.
1 #pragma once
2 #include "Hook.h"
3
4 namespace APDYNAMICART
5 {
6
8
11 class HookManager
12 {
13 public:
14 static HookManager* get()
15 {
16 static HookManager manager;
17 return &manager;
18 }
19
20 void init(EnvironmentObject* parent);
21 void addHook(HookObject* hookObject);
22 void removeHook(unsigned int index);
23 void removeHook(HookObject* hookObject);
24 void removeAllHooks();
25 void removeHooksOnHoop(Hoop* hoop);
26
27 typedef std::vector< osg::ref_ptr<HookObject> > HookArray;
28 const HookArray& getHooks() const { return _hooks; }
29
31 void load( HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
32 void save( HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
33
34 protected:
35 HookManager(); //Protected constructor, so no one can create instance of this class
36 HookArray _hooks;
37 EnvironmentObject* _parent;
38 };
39 }
40
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Hoop.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Hoop.h
Go to the documentation of this file.
1
8 #pragma once
9
10 #include "poa.h"
11 #include "SweepSurface.h"
12 #include "SectorColorGen.h"
13 #include "ConstantDiameterGen.h"
14 #include "HoopShape.h"
15 #include <NxActor.h>
16 #include <vreckoUtils\HighlightCallback.h>
17
18 namespace APDYNAMICART
19 {
20
21 class Hoop : public PoA, public Stroke
22 {
23 public:
24 Hoop(Controller* controller, HoopShapePtr shape);
25
27 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
28 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
29 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
30 virtual void GUIItemClicked( const char* itemID );
31 virtual void GUISliderChanged( const char* sliderID, float sliderPos );
32 virtual void pointed( bool pointed ) { _highlight->setHighlighting(pointed); }
33 virtual void setColor( osg::Vec4 newColour );
34 virtual void update();
35
37 Vec3ArrayPtr getSnapPointArray();
38 osg::Vec4 getColor();
39
40 SweepSurfaceGeodePtr getSweepSurface() const { return _sweepSurface; }
41 SectorColorGenPtr getSectorMarker() const { return _sectorMarker; }
42 ColorGenPtr getCachedColorGenerator() const { return _colorGen; }
43
44 double getDiameter() const { return _diameterGenerator->getDiameterValue(); }
45 void setDiameter(double val) { _diameterGenerator->setDiameterValue(val); }
46
47 HoopShapePtr getShape() const { return _shape; }
48 void setShape(HoopShapePtr val) { _shape = val; _sweepSurface->setLeadingSpline(_shape->getLeadingSpline()); }
49
50 NxActor* getActor() const { return _actor; }
51 void setActor(NxActor* val) { _actor = val; }
52
54 void showAxis() { _axis->setAllChildrenOn(); }
55 void hideAxis() { _axis->setAllChildrenOff(); }
56
58 virtual Vec3ArrayPtr getPositionSamples() const;
59 virtual Vec4ArrayPtr getOrientationSamples() const;
60 virtual osg::ref_ptr<osg::DoubleArray> getTimeStamps() const;
61 virtual SplinePtr getLeadingSpline() const;
62
64 void createActor();
65 void deleteActor();
66 void updateActor();
67
68 protected:
69 Controller* _contr;
70 SweepSurfaceGeodePtr _sweepSurface;
71 NxActor* _actor;
72 osg::Matrix _currentRotation;
73 osg::Vec3 _currentTransform;
74 Vec3ArrayPtr _snapPointArray;
75
76 RegularPolygonSplinePtr _crossSectionSpline;
77 HoopShapePtr _shape;
78 osg::ref_ptr<osg::Switch> _axis;
79
80 SectorColorGenPtr _sectorMarker;
81 ColorGenPtr _colorGen;
82 osg::ref_ptr<ConstantDiameterGen> _diameterGenerator;
83
84 osg::ref_ptr<vreckoUtils::HighlightCallback> _highlight;
85
86 //Stroke variables
87 Vec3ArrayPtr _points;
88 Vec4ArrayPtr _orientations;
89 DoubleArrayPtr _timeStamps;
90
91 //For changing hoop's color
92 DECLARE_REQUEST_OUTPUT(EvokeHSLColorPicker, MessageString, MessageBool);
93 DECLARE_INPUT(Colour, MessageVec4);
94
95 };
96
97 typedef osg::ref_ptr<Hoop> HoopPtr;
98
99 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/HoopGeometry.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
HoopGeometry.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\Group>
4 #include "ShapeGenerator.h"
5 #include "Utils.h"
6 #include "PatternGeode.h"
7
8 namespace APDYNAMICART
9 {
10
11 struct Trait
12 {
13 double min, max, mean;
14 };
15
16 typedef std::map<std::string, Trait> TraitMap;
17
18 class HoopGeometry : public osg::Group
19 {
20 public:
21 HoopGeometry(IShapeGeneratorPtr crossSection, IShapeGeneratorPtr shapeCurve);
22
23 void createGeometry(osg::Vec3Array* crossSectionFixPoints, osg::Vec3Array* shapeCurveFixPoints);
24
26 inline const IShapeGeneratorPtr getCrossSectionGenerator() const;
27 inline const IShapeGeneratorPtr getShapeCurveGenerator() const;
28
29 inline void setCrossSectionGenerator(IShapeGeneratorPtr crossSectionGen);
30 inline void setShapeCurveGenerator(IShapeGeneratorPtr shapeCurveGen);
31
32 protected:
33 IShapeGeneratorPtr _crossSection;
34 IShapeGeneratorPtr _shapeCurve;
35 BrushStrokeTriangulatorPtr _bst;
36 BrushPtr _brush;
37 TraitMap traits;
38 };
39
41 const IShapeGeneratorPtr HoopGeometry::getCrossSectionGenerator() const {
42 return _crossSection;
43 }
44
45 const IShapeGeneratorPtr HoopGeometry::getShapeCurveGenerator() const {
46 return _shapeCurve;
47 }
48
49 void HoopGeometry::setCrossSectionGenerator(IShapeGeneratorPtr crossSectionGen) {
50 if(crossSectionGen.valid())
51 _crossSection = crossSectionGen;
52 }
53
54 void HoopGeometry::setShapeCurveGenerator(IShapeGeneratorPtr shapeCurveGen) {
55 if(shapeCurveGen.valid())
56 _shapeCurve = shapeCurveGen;
57 }
58
60 typedef osg::ref_ptr<HoopGeometry> HoopGeometryPtr;
61
62 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/HoopShape.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
HoopShape.h
Go to the documentation of this file.
1
7 #pragma once
8 #include <osg\Referenced>
9 #include <string>
10 #include <xercesc\util\XercesDefs.hpp>
11 #include "Spline.h"
12 #include "Utils.h"
13 #include "LinearInterpolator.h"
14 #include "InterpolatedSpline.h"
15 #include "SampledSpline.h"
16 #include "types.h"
17 #include "RegularPolygonSpline.h"
18 #include "CatmullRomInterpolator.h"
19 #include "SampledSpline.h"
20
21 namespace APDYNAMICART
22 {
24 #define META_HoopShapeObject(name, menuName) \
25 name(); \
26 name(const name& val); \
27 virtual void createMenu( MenuPtr parent ) const; \
28 virtual bool sliderChanged( const char* sliderID, float sliderPos ); \
29 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode ); \
30 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ); \
31 virtual osg::ref_ptr<HoopShape> clone() { return new name(*this); } \
32 virtual std::string getName() { return (menuName); }
33
35 class HoopShape : public osg::Referenced
36 {
37 public:
38 HoopShape() : _dirty(false), _spline(NULL) {};
39
40 //Virtual methods
41 virtual SplinePtr getLeadingSpline() { return _spline; }
42 virtual void setLeadingSpline(SplinePtr val) { _spline = val; _dirty = true; }
43 virtual void createMenu( MenuPtr parent ) const {};
44 virtual bool itemClicked( const char* itemID ) { return false; };
45 virtual bool sliderChanged( const char* sliderID, float sliderPos ) { return false; };
46 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode ) = 0;
47 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ) = 0;
48
49 //Dirty object
50 virtual void dirty(bool enable = true) { _dirty = enable; }
51 virtual bool isDirty() { return _dirty; }
52
53 //Copy
54 virtual osg::ref_ptr<HoopShape> clone() = 0;
55
56 //Name
57 virtual std::string getName() = 0;
58
59 protected:
60 bool _dirty;
61 SplinePtr _spline;
62 virtual ~HoopShape() {};
63 };
64
65 typedef osg::ref_ptr<HoopShape> HoopShapePtr;
66
67 class NullHoopShape : public HoopShape
68 {
69 public:
70 virtual HoopShapePtr clone() { return new NullHoopShape; }
71 virtual std::string getName() { return "NullHoopShape"; }
72 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode ) {
73 err("Loading null object!"); return 1;
74 }
75 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ) {
76 err("Saving null object!");
77 }
78 };
79
80 class Rectangle : public HoopShape
81 {
82 public:
83 META_HoopShapeObject(Rectangle, "Rectangle");
84
85 protected:
86 void init();
87 void updateSamplePoints();
88
89 double _width;
90 double _height;
91 double _scale;
92 Vec3ArrayPtr _samplePoints;
93 };
94
95 class Ellipse : public HoopShape
96 {
97 public:
98 META_HoopShapeObject(Ellipse, "Ellipse");
99
100 protected:
101 void init();
102 void updateSamplePoints();
103
104 double _a;
105 double _b;
106 Vec3ArrayPtr _samplePoints;
107 unsigned int _detail;
108 };
109
110 class RegularPolygon : public HoopShape
111 {
112 public:
113 META_HoopShapeObject(RegularPolygon, "Regular polygon");
114
115 protected:
116 RegularPolygonSplinePtr _rps;
117 double _scale;
118
119 };
120
121 class Line : public HoopShape
122 {
123 public:
124 META_HoopShapeObject(Line, "Rod");
125
126 protected:
127 void init();
128 void updateSamplePoints();
129
130 double _length;
131 SampledSplinePtr _sampledSpline;
132 Vec3ArrayPtr _array;
133 };
134
135 class ElongatedCircle : public HoopShape
136 {
137 public:
138 META_HoopShapeObject(ElongatedCircle, "Elongated Circle");
139
140 protected:
141 void init();
142 void updateSamplePoints();
143 void createCircleSide( double step);
144
145 double _radius;
146 Vec3ArrayPtr _samplePoints;
147 unsigned int _detail;
148 double _distance;
149 };
150
151 class Painted : public HoopShape
152 {
153 public:
154 META_HoopShapeObject(Painted, "Painted");
155 virtual bool itemClicked( const char* itemID );
156 void setPointArray(Vec3ArrayPtr array) {
157 _points = array;
158 _sampledSpline->setVertexArray(_points);
159 }
160 protected:
161 Vec3ArrayPtr _points;
162 SampledSplinePtr _sampledSpline;
163 };
164
166 class ShapeFactory
167 {
168 public:
169 static std::vector<std::string> getAvaiableHoopShapes() {
170 std::vector<std::string> shapes;
171 shapes.push_back("Ellipse");
172 shapes.push_back("Rectangle");
173 shapes.push_back("Rod");
174 shapes.push_back("Regular polygon");
175 shapes.push_back("Elongated Circle");
176 return shapes;
177 }
178 static HoopShapePtr getHoopShape(const std::string& name) {
179 if(name == "Ellipse")
180 return new Ellipse;
181 else if(name == "Rectangle")
182 return new Rectangle;
183 else if(name == "Regular polygon")
184 return new RegularPolygon;
185 else if(name == "Rod")
186 return new Line;
187 else if(name == "Elongated Circle")
188 return new ElongatedCircle;
189 else if(name == "Painted")
190 return new Painted;
191 else
192 return new NullHoopShape;
193 }
194 };
195
196 }
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/IOPins.h Source File

  • File List
  • File Members
  • include
  • vrecko
IOPins.h
Go to the documentation of this file.
1 #ifndef IOPINS_H
2 #define IOPINS_H
3
4 #include <vrecko/Export>
5 #include <vrecko/Message.h>
6 #include <vrecko/BaseClass.h>
7 #include <vrecko/World.h>
8
9 namespace vrecko {
10
11 class BaseClass;
12 class Ability;
13 class EnvironmentObject;
14
15
16 template <class _MessageType>
17 class InputPin : public InputPinBase {
18 public:
19 typedef void (BaseClass::*PROCESSING_METHOD) (_MessageType *message);
20
21 InputPin(BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing) { coreInit(_owner, _inputName, _methodForProcessing); }
22 ~InputPin() {
23 }
24
25 virtual VreckoMessage* createCompatibleMessage() { return new _MessageType; }
26
27 virtual void processMessage(VreckoMessage *message) { if (methodForProcessing) { (owner->*methodForProcessing)((_MessageType*)message); } }
28
29 protected:
30 void coreInit(BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing) {
31 owner = _owner;
32 pinName = _inputName;
33 methodForProcessing = _methodForProcessing;
34 }
35
36 PROCESSING_METHOD methodForProcessing;
37 };
38
39
40 template <class _MessageType>
41 class OutputPin : public OutputPinBase {
42 public:
43 OutputPin(BaseClass *_owner, const char *_outputName) {
44 owner = _owner;
45 pinName = _outputName;
46 }
47
48 ~OutputPin() {
49 }
50
51 virtual VreckoMessage* createCompatibleMessage() { return new _MessageType; }
52
53 inline bool send(_MessageType *messageToBeSent, EventType eventType = EXPRESS_EVENT) {
54 if (senderStringWithOutputName.empty()) {
55 // first-time initialization (caching the result)
56 senderStringWithOutputName = owner->getSenderString() + "#" + pinName;
57 }
58 return world->getEventDispatcherPtr()->reportEvent(senderStringWithOutputName, messageToBeSent, eventType);
59 }
60
61 protected:
62 std::string senderStringWithOutputName; // initialized after the first call to send()
63 };
64
65
66
67
68 template <class _MessageType, class _ReturningMessageType>
69 class RequestInputPin : public RequestInputPinBase {
70 public:
71 typedef osg::ref_ptr<_ReturningMessageType> (BaseClass::*PROCESSING_METHOD) (_MessageType *message);
72
73 RequestInputPin(BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing) { coreInit(_owner, _requestInputName, _methodForProcessing); }
74
75 ~RequestInputPin() {
76 }
77
78 virtual VreckoMessage* createCompatibleMessage() { return new _MessageType; }
79 virtual VreckoMessage* createReturningCompatibleMessage() { return new _ReturningMessageType; }
80
81 virtual osg::ref_ptr<VreckoMessage> processRequest(VreckoMessage *message) { return (!methodForProcessing) ? NULL : (owner->*methodForProcessing)((_MessageType*)message); }
82 // inline const PROCESSING_METHOD getMethodForProcessing() const { return methodForProcessing; }
83
84 protected:
85 void coreInit(BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing) {
86 owner = _owner;
87 pinName = _requestInputName;
88 methodForProcessing = _methodForProcessing;
89 }
90
91 PROCESSING_METHOD methodForProcessing;
92 };
93
94
95
96
97 template <class _MessageType, class _ReturningMessageType>
98 class RequestOutputPin : public RequestOutputPinBase {
99 public:
100 RequestOutputPin(BaseClass *_owner, const char *_requestOutputName) {
101 owner = _owner;
102 pinName = _requestOutputName;
103 }
104
105 ~RequestOutputPin() {
106 }
107
108 virtual VreckoMessage* createCompatibleMessage() { return new _MessageType; }
109 virtual VreckoMessage* createReturningCompatibleMessage() { return new _ReturningMessageType; }
110
111 inline osg::ref_ptr<_ReturningMessageType> request(_MessageType *messageToBeSent) {
112 if (senderStringWithOutputName.empty()) {
113 // first-time initialization (caching the result)
114 senderStringWithOutputName = owner->getSenderString() + "#" + pinName;
115 }
116 return (_ReturningMessageType*)(world->getEventDispatcherPtr()->request(senderStringWithOutputName, messageToBeSent).get());
117 }
118
119 protected:
120 std::string senderStringWithOutputName; // initialized after the first call to send()
121 };
122
123
124
125
126 // Explicit instantiation of pins for usual messages.
127 // This is not necessary and also it increases the size of vrecko.lib, but other
128 // do not need to compile it, just overtake the compiled form from the vrecko.lib library.
129 // (I hope I did this right as I don't know how to verify it.)
130 template class VRECKO_EXPORT OutputPin<MessageBool>;
131 template class VRECKO_EXPORT InputPin<MessageBool>;
132
133 template class VRECKO_EXPORT OutputPin<MessageInt>;
134 template class VRECKO_EXPORT InputPin<MessageInt>;
135
136 template class VRECKO_EXPORT OutputPin<MessageUnsignedInt>;
137 template class VRECKO_EXPORT InputPin<MessageUnsignedInt>;
138
139 template class VRECKO_EXPORT OutputPin<MessageFloat>;
140 template class VRECKO_EXPORT InputPin<MessageFloat>;
141
142 template class VRECKO_EXPORT OutputPin<MessageObjectID>;
143 template class VRECKO_EXPORT InputPin<MessageObjectID>;
144
145 template class VRECKO_EXPORT OutputPin<MessageString>;
146 template class VRECKO_EXPORT InputPin<MessageString>;
147
148 template class VRECKO_EXPORT OutputPin<MessageVec2>;
149 template class VRECKO_EXPORT InputPin<MessageVec2>;
150
151 template class VRECKO_EXPORT OutputPin<MessageVec3>;
152 template class VRECKO_EXPORT InputPin<MessageVec3>;
153
154 template class VRECKO_EXPORT OutputPin<MessageVec4>;
155 template class VRECKO_EXPORT InputPin<MessageVec4>;
156
157 template class VRECKO_EXPORT OutputPin<MessageQuat>;
158 template class VRECKO_EXPORT InputPin<MessageQuat>;
159
160 template class VRECKO_EXPORT OutputPin<MessageMatrix>;
161 template class VRECKO_EXPORT InputPin<MessageMatrix>;
162
163
164
165
166
167 // Macros for single-line definition
168 // DELARE_INPUT should be in the header file (.h)
169 #define DECLARE_INPUT(name, message_type) \
170 osg::ref_ptr<vrecko::InputPin<message_type>> input##name; \
171 void onMessage##name(message_type *message);
172
173 // INIT_INPUT should come in the .cpp file
174 #define INIT_INPUT_EXTNAME(name, message_type, yourClassName, extName) \
175 addInputPin(input##name = new vrecko::InputPin<message_type>(this, extName, (vrecko::InputPin<message_type>::PROCESSING_METHOD)&yourClassName::onMessage##name));
176 // TODO: In newer compilers, this _might_ be solvable without "yourClassname" AND also without "message_type"
177 // by using something like
178 // (decltype(input##name)::PROCESSING_METHOD)&decltype(*this)::onMessage##name
179 // It fails in VC2010, because decltype(*this) infers a class type of Class& and not Class as we need.
180 // We need an rvalue reference for "this", but it doesn't seem to be supported as of yet (May 2011).
181 // See this table:
182 // http://blogs.msdn.com/b/vcblog/archive/2010/04/06/c-0x-core-language-features-in-vc10-the-table.aspx
183 // Solution to exactly this problem is already in the working paper of C++0x (from March 2010)
184 // http://en.wikipedia.org/wiki/Decltype (search for "decltype(v)::value_type" )
185 #define INIT_INPUT(name, message_type, yourClassName) \
186 INIT_INPUT_EXTNAME(name, message_type, yourClassName, #name)
187
188 #define UNINIT_INPUT(name) \
189 { \
190 if (input##name) { \
191 removeInputPin(input##name); \
192 input##name = NULL; \
193 } \
194 }
195
196 #define METHOD_INPUT(name, message_type, yourClassName) \
197 void yourClassName::onMessage##name(message_type *message)
198
199
200
201
202 #define DECLARE_OUTPUT(name, message_type) \
203 osg::ref_ptr<vrecko::OutputPin<message_type>> output##name;
204
205 #define INIT_OUTPUT_EXTNAME(name, message_type, extName) \
206 addOutputPin(output##name = new vrecko::OutputPin<message_type>(this, extName));
207
208 #define INIT_OUTPUT(name, message_type) INIT_OUTPUT_EXTNAME(name, message_type, #name)
209
210 #define UNINIT_OUTPUT(name) \
211 { \
212 if (output##name) { \
213 removeOutputPin(output##name); \
214 output##name = NULL; \
215 } \
216 }
217
218
219
220
221 #define DECLARE_REQUEST_INPUT(name, message_type, returning_message_type) \
222 osg::ref_ptr<vrecko::RequestInputPin<message_type, returning_message_type>> reqInput##name; \
223 osg::ref_ptr<returning_message_type> onRequest##name(message_type *message);
224
225 #define INIT_REQUEST_INPUT_EXTNAME(name, message_type, returning_message_type, yourClassName, extName) \
226 addRequestInputPin(reqInput##name = new vrecko::RequestInputPin<message_type, returning_message_type>(this, extName, (vrecko::RequestInputPin<message_type, returning_message_type>::PROCESSING_METHOD)&yourClassName::onRequest##name));
227
228 #define INIT_REQUEST_INPUT(name, message_type, returning_message_type, yourClassName) \
229 INIT_REQUEST_INPUT_EXTNAME(name, message_type, returning_message_type, yourClassName, #name)
230
231 #define UNINIT_REQUEST_INPUT(name) \
232 { \
233 if (reqInput##name) { \
234 removeRequestInputPin(reqInput##name); \
235 reqInput##name = NULL; \
236 } \
237 }
238
239 #define METHOD_REQUEST_INPUT(name, message_type, returning_message_type, yourClassName) \
240 osg::ref_ptr<returning_message_type> yourClassName::onRequest##name(message_type *message)
241
242
243
244 #define DECLARE_REQUEST_OUTPUT(name, message_type, returning_message_type) \
245 osg::ref_ptr<vrecko::RequestOutputPin<message_type, returning_message_type>> reqOutput##name;
246
247 #define INIT_REQUEST_OUTPUT_EXTNAME(name, message_type, returning_message_type, extName) \
248 addRequestOutputPin(reqOutput##name = new vrecko::RequestOutputPin<message_type, returning_message_type>(this, extName));
249
250 #define INIT_REQUEST_OUTPUT(name, message_type, returning_message_type) \
251 INIT_REQUEST_OUTPUT_EXTNAME(name, message_type, returning_message_type, #name)
252
253 #define UNINIT_REQUEST_OUTPUT(name) \
254 { \
255 if (reqOutput##name) { \
256 removeRequestOutputPin(reqOutput##name); \
257 reqOutput##name = NULL; \
258 } \
259 }
260
261
262 };
263
264 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/IconColour.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
IconColour.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Icon.h"
4
5 # ifdef GUI_LIBRARY
6 # define GUI_EXPORT __declspec(dllexport)
7 # else
8 # define GUI_EXPORT __declspec(dllimport)
9 #endif
10
11
12
13 using namespace vrecko;
14
15 namespace APGUI
16 {
17
19
27 class GUI_EXPORT IconColour : public Icon
28 {
29 public:
30
31 IconColour();
32 ~IconColour();
33
42 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
43
45 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed);
46
47
48
49 protected:
50
51 osg::Vec4 _colour;
52
53 DECLARE_OUTPUT(Colour, MessageVec4);
54
55 };
56
57 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/InputConnector/InputConnector.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • InputConnector
InputConnector.h
Go to the documentation of this file.
1 #pragma once
2
3
4
5 # ifdef INPUTCONNECTOR_LIBRARY
6 # define INPUTCONNECTOR_EXPORT __declspec(dllexport)
7 # else
8 # define INPUTCONNECTOR_EXPORT __declspec(dllimport)
9 #endif
10
11
12 using namespace vrecko;
13
14 typedef struct
15 {
16 Ability * receiver;
17 string senderString;
18 string inputPin;
19 }Receiver;
20
21
22 typedef std::map<int, Receiver> ReceiversList;
23
24
25 namespace APInputConnector
26 {
27
28 // if needed, this can be increased to any value
29 // see also 'OptiTrack.h' and 'GUI_Controller.h', some limitations is also there
30 // Kinect uses 20 points
31 #define SENSOR_MAX_COUNT 20
32
33
35
45 class INPUTCONNECTOR_EXPORT InputConnector : public Ability
46 {
47 public:
48
49 InputConnector();
50 ~InputConnector();
51
52
53 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
54
55 // New way of processing incoming events can't be used here
56 // because inputPins aren't known at compile time and therefore relevant methods can't be defined
58 virtual void processEvent(const std::string &input_name, VreckoMessage *value);
59
60 void processAction( int sensorNumber, VreckoMessage * value, const std::string & input_name );
61
62 void ProcessOrientation( int sensorNumber, VreckoMessage * value, const std::string & input_name );
63
64 void processSensorTransformation( int sensorNumber, VreckoMessage * value, const std::string & input_name );
65
67 static int parseSensorNumber( const std::string &input_name );
68
70 static std::string parseEventName( const std::string &input_name );
71
72 void update();
73
74
75
76
77
78 protected:
79
80
81 osg::Vec3 _lastKnownPositions[SENSOR_MAX_COUNT];
82 osg::Quat _lastKnownOrientations[SENSOR_MAX_COUNT];
83 unsigned int _lastKnownPointedObjects[SENSOR_MAX_COUNT];
84 osg::Vec3 _lastCheckedPositions[SENSOR_MAX_COUNT];
85
86 //key - action string, value - type string
87 std::map<string, string> _actionMap;
88
89 //key - action, value - map of all receivers with non-zero priority
90 std::map<string, ReceiversList *> _outputMappingsWithPriorities;
91
93
100 bool parseInputDevice( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode );
101
103
111 bool parseInputMappingPair( string deviceID, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode );
112
113 bool parseSenderReceiver(std::string sr, bool isSender, BaseClass **pEntity, bool bNoErrorOutput);
114
116
124 std::vector<XERCES_CPP_NAMESPACE_QUALIFIER DOMNode*> *getChildNodesbyName( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* parentNode, const string childNodeName );
125 bool parseReceiverAbility( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * ChainPairNode );
126 bool parseOutputMappingPair( vrecko::Ability * receiverAbility, std::string receiverString, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode );
127 bool processChainofResponsibility( ReceiversList *receivers, MessageBool * value );
128
129 // for backward compatibility only
130 DECLARE_OUTPUT(Sensor_0_position, MessageVec3);
131 DECLARE_OUTPUT(Sensor_0_orientation, MessageQuat);
132
133 DECLARE_OUTPUT(Sensor_1_position, MessageVec3);
134 DECLARE_OUTPUT(Sensor_1_orientation, MessageQuat);
135
136
137 // for answering request about actual position and orientation
138 DECLARE_REQUEST_INPUT(SensorPosition, MessageInt, MessageVec3);
139 DECLARE_REQUEST_INPUT(SensorOrientation, MessageInt, MessageQuat);
140 DECLARE_REQUEST_INPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
141
142 // dedicated for communication with dynamic menu ability - beware of DIFFERENT ID NUMBERING
143 DECLARE_REQUEST_INPUT(MenuSensorPosition, MessageInt, MessageVec3);
144
145 //for answering about actually pointed objects - used by GUI, DAEnvironment, e.g.
146 DECLARE_REQUEST_INPUT(SelectedObjectID, MessageInt, MessageObjectID);
147
148 //to find what object is selected
149 DECLARE_REQUEST_OUTPUT(SelectionByPointerPos, MessageVec3, MessageObjectID);
150
151 //not used at all
152 //bool parseTriggerString( const string *fullActionString, string *action, bool *value );
153 };
154
155 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/InterpolatedSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
InterpolatedSpline.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\ref_ptr>
4
5 #include "Spline.h"
6 #include "Interpolator.h"
7
8 class InterpolatedSpline : public SplineDecorator
9 {
10
11 public:
12 InterpolatedSpline( SplinePtr decoratedSpline );
13 InterpolatedSpline( InterpolatorPtr interpolator, unsigned int interpolationSteps, SplinePtr decoratedSpline );
14
16 META_DAObjectDecorator(_decoratedSpline, InterpolatedSpline, "Interpolated Spline")
17
18 virtual Vec3ArrayPtr getPoints();
19
21 inline void setInterpolator(InterpolatorPtr interpolator);
22 inline InterpolatorPtr getInterpolator() { return _interpolator; }
23
24 inline int getInterpolationSteps() const { return _interpolationSteps; }
25 inline void setInterpolationSteps(int val);
26
27 protected:
28 InterpolatorPtr _interpolator;
29 unsigned int _interpolationSteps;
30 };
31
32 void InterpolatedSpline::setInterpolator( InterpolatorPtr interpolator )
33 {
34 dirty();
35 _interpolator = interpolator;
36 }
37
38 void InterpolatedSpline::setInterpolationSteps( int val )
39 {
40 dirty();
41 _interpolationSteps = val;
42 }
43
44 typedef osg::ref_ptr<InterpolatedSpline> InterpolatedSplinePtr;
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Interpolator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Interpolator.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Referenced>
3 #include <osg\ref_ptr>
4 #include <vector>
5 #include "types.h"
6 #include <iostream>
7
8 class Interpolator : public osg::Referenced
9 {
10 public:
11 virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed) = 0;
12
13 virtual std::string classDescription() const = 0;
14 virtual std::string className() const = 0;
15
16 protected:
17 virtual ~Interpolator() {};
18 };
19
20 typedef osg::ref_ptr<Interpolator> InterpolatorPtr;
21
22 class NullInterpolator : public Interpolator
23 {
24 virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)
25 {
26 std::cerr << "NullInterpolator used!" << std::endl;
27 return new osg::Vec3Array;
28 }
29 };
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Interval.h Source File

  • File List
  • File Members
  • include
  • vrecko
Interval.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _INTERVAL_H_
15 #define _INTERVAL_H_
16
17 // attributes description includes
18 #include "Range.h"
19
20 // VRECKO namespace
21 namespace vrecko
22 {
23
41 template <class tval, class tref = tval>
42 class Interval : public Range
43 {
44 public:
45
52 Interval(tref lowerBound, tref upperBound) : Range(Range::RANGE_INTERVAL)
53 {
54 // set both bounds to desired values
55 this->lowerBound = lowerBound;
56 this->upperBound = upperBound;
57
58 // implicitly set inclusive bounds
59 lowerInclusive = true;
60 upperInclusive = true;
61 }
62
71 Interval(tref lowerBound, tref upperBound, bool lowerInclusive,
72 bool upperInclusive) : Range(Range::RANGE_INTERVAL)
73 {
74 // set both bounds to desired values
75 this->lowerBound = lowerBound;
76 this->upperBound = upperBound;
77
78 // set flags for both bounds
79 this->lowerInclusive = lowerInclusive;
80 this->upperInclusive = upperInclusive;
81 }
82
88 inline tref getLowerBound() const
89 {
90 return lowerBound;
91 }
92
98 inline tref getUpperBound() const
99 {
100 return upperBound;
101 }
102
108 inline bool isLowerInclusive() const
109 {
110 return lowerInclusive;
111 }
112
118 inline bool isUpperInclusive() const
119 {
120 return upperInclusive;
121 }
122
130 bool includesValue(tref value) const
131 {
132 // both bounds are inclusive
133 if (isLowerInclusive() && isUpperInclusive())
134 {
135 return (value >= getLowerBound() && value <= getUpperBound());
136 }
137
138 // lower bound is not inclusive and the upper bound is inclusive
139 if (!isLowerInclusive() && isUpperInclusive())
140 {
141 return (value > getLowerBound() && value <= getUpperBound());
142 }
143
144 // lower bound is not inclusive and the upper bound is inclusive
145 if (isLowerInclusive() && !isUpperInclusive())
146 {
147 return (value >= getLowerBound() && value < getUpperBound());
148 }
149
150 // both bounds are not inclusive
151 return (value > getLowerBound() && value < getUpperBound());
152 }
153
154 private:
155
156 // bounds
157 tval lowerBound;
158 tval upperBound;
159
160 // flags
161 bool lowerInclusive;
162 bool upperInclusive;
163 };
164
168 typedef Interval<int> IntInterval;
169 typedef Interval<long> LongInterval;
170 typedef Interval<float> FloatInterval;
171 typedef Interval<double> DoubleInterval;
172
173 // end of vrecko namespace
174 }
175
176 // end header definitions
177 #endif
178
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/ItemsGroup.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
ItemsGroup.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4 using namespace vrecko;
5
6 namespace APGUI
7 {
8
9
11
23 class ItemsGroup : public osg::Referenced
24 {
25 public:
26
27 ItemsGroup( string name);
28 ~ItemsGroup();
29
30
32 inline string getName() {return _name; }
33
35 void addItem( GUI_Item* newItem );
36
37 void reset();
38
39 // given member's state is set to 'true'
40 // all other members states are set to 'false'
41 void setActiveMember( GUI_Item* activeItem );
42
43 protected:
44
45 string _name;
46
47 std::vector<GUI_Item *> _members;
48
49 };
50
51 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/JuliaAttractor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
JuliaAttractor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Attractor.h"
4
5 namespace APDYNAMICART
6 {
7
8 class JuliaAttractor : public Attractor
9 {
10
11 public:
13 JuliaAttractor(IParametersPtr parameters, Controller* controller);
14
16 virtual void compute();
17
18 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
19
20 virtual void GUIItemClicked( const char* itemID );
21
22 virtual void GUISliderChanged( const char* sliderID, float sliderPos );
23
24 virtual void postInitialize();
25
26 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
27
28 virtual void update();
29
30
31 private:
32 osg::ref_ptr<osg::Geode> _quadGeode;
33 osg::ref_ptr<osg::Uniform> _uMu, _uLight, _uEye, _uEpsilon, _uColor, _uMaxIterations;
34 osg::Vec4 _eye, _lookAt, _up;
35 osg::Vec3 _N, _T, _B, _light;
36 float alpha, beta;
37 int _count;
38 int _stereoEnabled;
39 osg::Vec3 _LHPosition;
40 osg::Vec3 _color;
41 osg::Vec2 _translate;
42 float _zoom;
43 osg::Matrix curRotation, lastRotation;
44 float _stereoMove;
45 float _size;
46
48 void calculateView();
49 bool getAlphaBeta();
50 void updateColorArray( osg::Geometry* geometry );
51 void createQuad();
52 void initShaders();
53 bool getCameraViewAsLookAt( osg::Vec3& eye, osg::Vec3& lookAt, osg::Vec3& up );
54 IMenuComponentPtr createColorSubMenu() const;
55 //void setColor(const osg::Vec3& color);
56 //void setColor(USHORT index, float value);
57 //const osg::Vec3& getColor() const;
58 };
59
60 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Junction.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Junction.h
Go to the documentation of this file.
1 #ifndef JUNCTION
2 #define JUNCTION
3
4 #include <map>
5
6 // rika, jakym zpusobem je na krizovatce rizen provoz
7 #define CONTROL_SYSTEM_RIGHT_HAND 1
8 #define CONTROL_SYSTEM_TRAFFIC_LIGHTS 2
9
10 namespace CarSim {
11 // struktura, ve ktere jsou ulozeny atributy pro dvojici vstupni a vystupni
12 // hrany (ale vzdy kratke nebo normalni) krizovatky, ktera je nedilci -
13 // neexistuje nejaka krizovatka na vyssi urovni, ktera by ji obsahovala
14 struct InOutEdgesAttr {
15 // - uhel otoceni vektoru stred krizovatky to vstupni hrany -> stred jeji from
16 // krizovatky do vektoru stred krizovatky from vystupi hrany -> stred jeji
17 // to krizovatky (vzdy v xz) podle osy y (od uhlu je navic odecteno vzdy 0.001,
18 // aby uhel mezi vstupni a vystupni hranou v jedne silnici nebyl 0, ale 2*PI-0.001,
19 // vysledny uhel bude vzdy v intervalu [0,2*PI))
20 float angleInXZ;
21 // - bod predelu mezi 2 HF kubikami, ktere slouzi pro modelovani prujezdu
22 // auta z vstupni hrany do vystupni
23 osg::Vec3 hfCubicsBorder;
24 // - vektor pro ten bod (je normalizovany)
25 osg::Vec3 hfCubicsBorderVec;
26 // posledni dve polozky obsahuji pouze implicitni hodnoty, jestlize
27 // uhel otoceni (dale alfa) z C(stred kriz.)->IN vstupni hrany (v xz) do C->OUT
28 // vystupni hrany (v xz) podle osy y
29 // je <= nez 120 stupnu (pak je prujezd modelovan pouze pomoci jedne
30 // HF kubiky bez predelu - z bodu IN do bodu OUT)
31
32 // pozn.: bod predelu a prislusny vektor (a i ostatni parametry u HF kubik)
33 // maji vzdy nulovou y-souradnici (HF kubiky slouzi pouze k modelovani prujezdu
34 // auta krizovatkou v rovine xz)
35 };
36
37 // tato struktura slouzi k ulozeni informaci o hrane, ktera je u krizovatky
38 // (vstupuje do ni, vystupuje z ni nebo je jeji soucasti)
39 struct JuncsEdge {
40 // id pristi hrany (hrany kolem hrany jsou usporadany proti
41 // smeru hodinovych rucicek)
42 unsigned int nextEdgeId;
43 // id minule hrany
44 unsigned int prevEdgeId;
45 // rika, zda je hrana zamcena (zamceno -> >0, odemceno -> =0);
46 // udava take, kolikrat byla zamcena hrana (jednim autem);
47 // to je potreba ukladat,
48 // protoze jestlize auto pojede pres cyklus kratkych hran, muze se stat, ze
49 // auto pres nejakou hranu pojede vickrat, pak je treba neodemcit hrany, ktere
50 // uz auto (v ramci velke krizovatky) prejelo, ale pres ktere auto jeste pojede
51 // (v ramci velke krizovatky); proto se pri zamceni bude
52 // inkrementovat lockCount (pri odemykani dekrementovat);
53 // hrana se odemce, kdyz po jejim odemykani je lockCount 0
54 unsigned int lockCount;
55 // uhel, ktery svira osa x s hranou (vektorem tvorenym stredy krizovatek from,
56 // to hrany, pricemz prvni je tato krizovatka (ktera vlastni atribut orderedEdges)
57 // nebo dilci krizovatka, ktera je jeji soucasti) v xz;
58 // aby se odlisily hrany, ktere jsou ve stejne silnici, bude k vstupnim hranam
59 // pripocten uhel 0.001
60 float angle;
61 // barvy, ktere sviti na semaforu na konci normalni vstupujici hrany u krizovatky (pouze pro vstupujici
62 // normalni hrany a krizovatky, ktere jsou rizeny semafory; v ostatnich pripadech
63 // obsahuje nedefinovano - 0; barvy jsou popsany v TLsOnJuncManager.h)
64 unsigned int tlColors;
65 };
66
67
68 struct Junction {
69 unsigned int id;
70 osg::Vec3 position;
71 // zde jsou indexy na hrany, ktere do teto krizovatky vstupuji a vystupuji;
72 // slouzi k detekci prechodu auta pres hranice hran v krizovatce a k zamykani
73 // hran; hrany jsou usporadany proti smeru hodinovych rucicek
74 // (podle pravidla prave ruky s osou (0,1,0)
75 std::map<unsigned int,JuncsEdge> orderedEdges;
76
77 // tato mapa ma smysl pouze u nedilcich hran (viz InOutEdgesAttr);
78 // 1. klic je vstupni hrana, 2. klic vystupni hrana,
79 // zde bude pro kazdou dvojici vstupnich a vystupnich hran (ale pouze
80 // normalnich a kratkych) ulozena struktura InOutEdgesAttrMap
81
82 // tyto atributy se vypocitaji pred vlastni simulaci -> je to rychlejsi
83 std::map<unsigned int, std::map<unsigned int,InOutEdgesAttr>> inOutEdgesAttrMap;
84
85 // jestlize je toto nova krizovatka, ktera vznikla z nekolika dilcich,
86 // nasledujici promenna obsahuje pocet tech dilcich krizovatek,
87 // jinak bude obsahovat - 1 (vznikla z jedne krizovatky)
88 unsigned int partJuncCardinality;
89 // jestlize tato krizovatka se sloucila do vetsi,
90 // obsahuje id teto krizovatky, jinak 0
91 unsigned int complexJunc;
92
93 // id posledniho auta, ktere ve svem poslednim snimku u krizovatky
94 // odemklo hranu;
95 // jestlize nebyla v poslednim snimku zadneho auta odemcena hrana,
96 // obsahuje 0 (neplatne id)
97 unsigned int carIdUnlockedEdge;
98
99 // rika, jakym zpusobem je na krizovatce nebo puvodni krizovatce rizen provoz;
100 // pokud se tato krizovatka sloucila z puvodnich krizovatek, z nichz alespon na jedne
101 // je provoz rizen semafory, je take rizena semafory;
102 // pokud je provoz rizen semafory, je tato krizovatka soucasti velke krizovatky,
103 // ktera se sklada pouze z jedne male krizovatky, ktera je rizena semafory a
104 // ktera propojuje 3-4 silnice, v nichz jsou alespon 2 normalni hrany, ktere smeruji
105 // do te male (velke) krizovatky
106 unsigned int controlSystem;
107
108 // vstupni hrana, kterou chce vjet (vjelo) do male krizovatky posledni
109 // auto, ktere si u ni zamklo nejake hrany (zvysilo pocet zamceni);
110 // (pokud se jedna o puvodni a nemalou krizovatku nebo si u krizovatky jeste
111 // zadne auto zadnou hranu nezamklo, obsahuje nedefinovano - max. hodnotu)
112 unsigned int lastCarInEdge;
113
114 // to stejne ale pro vystupni hranu
115 unsigned int lastCarOutEdge;
116 };
117
118 }
119
120 #endif
121
122
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/navigation/KMTracker.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • navigation
KMTracker.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vrecko/EnvironmentObject.h>
4 #include <vrecko/World.h>
5 #include <osg/Vec2>
6
7 using namespace vrecko;
8
9 namespace navigation {
10
11 class KMTracker: public Ability {
12 public:
13 KMTracker();
14 ~KMTracker() {};
15 void preInitialize(void);
16 void postInitialize(void);
17
18 void processEvent(const std::string &input_name, VreckoMessage *message);
19 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
20 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
21
22 void update(void);
23
24 protected:
25 osg::Vec3 _actual_position, _last_position;
26 World::AvatarView *av;
27 osg::Vec3 avatar_position;
28 osg::Vec3 avatar_look_at;
29 osg::Vec3 avatar_up_vector;
30 osg::Vec3 smer3d, move_direction;
31
32 osg::Vec3 hand_position_left;
33 osg::Vec3 hand_position_right;
34 osg::Quat hand_orientation_left;
35 osg::Quat hand_orientation_right;
36 osg::Vec4 direction;
37
38 osg::Vec2 smer; // delta 2D smer pohybu
39 double vert, horiz; // rotace Avatara
40
41 osg::Vec2 mouse_pos;
42 osg::Vec2 old_mouse_pos;
43
44 // TODO not used at all??? remove?
45 //bool mouse_button_left;
46 //bool mouse_button_right;
47 //bool mouse_button_middle;
48 int mouse_scroll;
49
50 osg::Vec2 mouse_sensitivity_avatar;
51 osg::Vec2 mouse_sensitivity_hands;
52 float move_step;
53 float rotation_step;
54
55 typedef enum {
56 plane_xz = 0,
57 plane_xy,
58 plane_yz
59 }Plane_type;
60
61 Plane_type move_plane; // rovina, ve ktere se pohybuje ruka
62 bool moving, stopped;
63 bool _avatarMovement; // Avatar/Gloves switch
64 bool right_hand; // right/left hand switch
65 bool alwaysSendOrientationWithPosition; //kdyz se posila pozice, posle se i orientace (ikdyz se nezmenila)
66 //vice odpovida zarizeni optitrack, ktere posila pozici i orientaci zaroven
67
68
69
70 int i;
71 std::string mesg;
72
73 World *owner;
74
75
76 void KMTracker::sendSensorInfo( bool rightHand );
77
78
79
80 DECLARE_OUTPUT(Orientation, MessageQuat);
81 DECLARE_OUTPUT(Move, MessageVec3);
82 DECLARE_OUTPUT(MoveLocal, MessageVec3);
83
84 DECLARE_OUTPUT(PositionRight, MessageVec3);
85 DECLARE_OUTPUT(PositionLeft, MessageVec3);
86 DECLARE_OUTPUT(OrientationRight, MessageQuat);
87 DECLARE_OUTPUT(OrientationLeft, MessageQuat);
88
89 DECLARE_OUTPUT(ButtonLeft, MessageBool);
90 DECLARE_OUTPUT(ButtonRight, MessageBool);
91
92 DECLARE_OUTPUT(LH_ButtonLeft, MessageBool);
93 DECLARE_OUTPUT(LH_ButtonRight, MessageBool);
94
95 DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation);
96
97 };
98 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/KalmanFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
KalmanFilter.h
Go to the documentation of this file.
1 #ifndef KALMAN_FILTER_H
2 #define KALMAN_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 //#include "kalman/ekfilter.hpp"
9
10 namespace vreckoDP_PHANToM {
11
12 // TODO: NOT READY
13
14 /* PHANToM filter to reduce noise and generally limit high frequency changes. */
15 class KalmanFilter : public PHANToMFilter {
16 public:
17 // typedef Kalman::EKFilter<float, 0, false, false, false> PhantomFilter;
18
19 KalmanFilter();
20
21 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
22
23 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
24
25 protected:
26 // PhantomFilter filter;
27 };
28
29 }
30
31 #endif
32
33
34 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/KeepOnScreen.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
KeepOnScreen.h
Go to the documentation of this file.
1 #ifndef KEEPONSCREEN_H
2 #define KEEPONSCREEN_H
3
4 #include <vrecko/Ability.h>
5
6 using namespace vrecko;
7
8 namespace APObjectUtils
9 {
10
11 #define HORIZ_ALIGN_OUTER -100000.0f
12 // Means "Align to the outer edge of the bounding box"
13 #define VERT_ALIGN_OUTER -100000.0f
14 // Means "Align to the outer edge of the bounding box"
15
16
17 /* Parameters can be specified in the following way:
18
19 <Ability Priority="-100">
20 // It's NECESARY to lower the priority so camera movements are
21 // performed BEFORE calculating the proper position of the dependend objects
22
23 <Name>KeepOnScreen</Name>
24 <PluginName>ObjectUtils</PluginName>
25
26
27 <Parameters>
28 <Position>1.0 1.0</Position>
29 // Alignment point ON THE SCREEN.
30 // First number: -1.0 ... 1.0 is for left to right edge
31 // Second number: -1.0 ... 1.0 is for bottom to top edge
32
33 <HorizAlign>outer</HorizAlign>
34 // Alignment point ON THE BOUNDING BOX of the object
35 // Can be either number (-1.0 ... 1.0 for left to right edge of the BB)
36 // or the word "outer", which means the other edge (is taken
37 // automatically according to the <Position> settings)
38
39 <VertAlign>outer</VertAlign>
40 // Same as <Horizalign>, but for bottom to top edges
41
42 <Scale>0.1</Scale>
43 // Scaling of the object. The scale is set for an object in distance 1.0.
44 // Should the object be in any other distance from the camera, the scaling
45 // is automatically adjusted to maintain same size.
46
47 <Depth>1.0</Depth>
48 // Depth from the viewer. If lower than near plane, than the object
49 // is shifted away from the viewer and placed on the near plane.
50 // (Efectivelly - you could set it to 0 and let the system place the object
51 // as near as possible. UNFORTUNATELY, due to some problem, the near planes
52 // are sometimes changed from frame to frame and the object could be chopped
53 // in two.)
54
55
56 <RelativeToBoundingBox>false</RelativeToBoundingBox>
57 // ("true" is the default value)
58 // If "false" then vertAlign/horizAlign values are absolute shifts and not
59 // multiplications relative to the bounding box.
60
61 <DontRotate>true</DontRotate>
62 // ("false" is the default value)
63 // If "true" then the object will be kept static relatively to the camera.
64
65 </Parameters>
66
67
68 </Ability>
69
70 */
71
72
73
74 class KeepOnScreen: public Ability
75 {
76 public:
77 KeepOnScreen();
78 virtual ~KeepOnScreen();
79
80 virtual void preInitialize();
81 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
82 virtual void update();
83 virtual void clean();
84 protected:
85 EnvironmentObject *owner;
86
87 float posX, posY; // 2D position on the screen
88 float depth; // similar to z-depth (may not be 100 % precise)
89
90 bool bRelativeToBoundingBox;
91 // Is the alignment relative to the bounding box OR to is it only shift relative to
92 // the object's center?
93
94 float horizAlign; // alignment of the object's bounding box OR left/right shift.
95 // (-1.0 means to the left, 0.0 is center, 1.0 is to the right)
96 // HORIZ_ALIGN_OUTER means "outer edge" of the bounding box
97 float vertAlign; // alignment of the object's bounding box OR top/bottom.
98 // (-1.0 means to the bottom, 0.0 is center, 1.0 is to the top)
99 // VERT_ALIGN_OUTER means "outer edge" of the bounding box
100 float scale; // Scaling (1.0 = no scaling)
101 bool bDontRotate; // true => keep original rotation, so the object is not static
102 // relative to camera
103
104 };
105
106 }
107
108 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/KeyboardMouse.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
KeyboardMouse.h
Go to the documentation of this file.
1 /***************************************************************************
2 KeyboardMouse.h - description
3 -------------------
4 begin : April 2004
5 copyright : (C) 2004 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU L General Public License as published by*
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef KEYBOARDMOUSE_H
19 #define KEYBOARDMOUSE_H
20
21 #include <vrecko/IOPins.h>
22 #include <vrecko/Device.h>
23 #include <vrecko/EventDispatcher.h>
24
25 #include <osgGA/GUIEventHandler>
26 //#include <osgProducer/EventAdapter>
27 #include <osg/Vec2>
28 #include <osg/Timer>
29
30
31 using namespace vrecko;
32
33 namespace vreckoDP_base {
34
36 class DP_EXPORT KeyboardMouse : public vrecko::Device, public osgGA::GUIEventHandler {
37 public:
38 KeyboardMouse();
39 ~KeyboardMouse();
40
41 virtual int openDevice(void);
42 int closeDevice(void);
43 int calibrateDevice(void) {return 0;}
44
45 bool isKeyDown(int keyCode) { return keydown_map[keyCode]; };
46
47 void update(void);
48
49 virtual bool handle(const osgGA::GUIEventAdapter& ea,osgGA::GUIActionAdapter&);
50 virtual void accept(osgGA::GUIEventHandlerVisitor& v) { v.visit(*this); };
51
52 // --- KeyboardMouseCallback functions (V.K.: "callbacks"? Really?)
53 void mouseScroll( osgGA::GUIEventAdapter::ScrollingMotion );
54 void mouseMotion( const osgGA::GUIEventAdapter& ea, osgGA::GUIActionAdapter& aa);
55 void passiveMouseMotion( const osgGA::GUIEventAdapter& ea, osgGA::GUIActionAdapter& aa, float mx, float my);
56 void buttonPress( const osgGA::GUIEventAdapter& ea, osgGA::GUIActionAdapter& aa, float mx, float my, unsigned int mb);
57 void doubleButtonPress( const osgGA::GUIEventAdapter& ea, osgGA::GUIActionAdapter& aa, float mx, float my, unsigned int mb);
58 void buttonRelease( const osgGA::GUIEventAdapter& ea, osgGA::GUIActionAdapter& aa, float mx, float my, unsigned int mb);
59 void keyPress( int );
60 void keyRelease( int );
61 void specialKeyPress( int );
62 void specialKeyRelease( int );
63 void shutdown() {}
64 bool idle() { return false; }
65
66 protected:
67 unsigned int mouse_button;
68 osg::Vec2 mouse_position;
69 std::map<int, osg::Timer_t> autorepeat_map;
70
71 std::map<int, bool> keydown_map;
72 osg::Timer timer;
73 bool new_mouse_pos_ready;
74
75 int mouseUpdateCounter; // helper counter, so we can ignore first few frames after start or after switching form another app (and reset the mouse pos appropriately)
76
77 EventDispatcher *pEventDispatcher;
78
79 bool sendMousePosIfReady(); // if a new position data are ready, it will send the event and resets the data
80 bool keyToString(int key, std::string *str);
81
82 DECLARE_OUTPUT(Key, MessageString);
83 DECLARE_OUTPUT(MousePosition, MessageVec2);
84 DECLARE_OUTPUT(MouseButton, MessageString);
85 DECLARE_OUTPUT(MouseDoubleButton, MessageString);
86 DECLARE_OUTPUT(MouseScroll, MessageString);
87 };
88
89 }
90
91 #endif
92
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/Kinect/Kinect.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • Kinect
Kinect.h
Go to the documentation of this file.
1
10 #pragma once
11
12 #ifndef WIN32_LEAN_AND_MEAN
13 #define WIN32_LEAN_AND_MEAN
14 #endif
15 #include <windows.h>
16
17 #include <vrecko/IOPins.h>
18 #include <vrecko/Device.h>
19 #include <vrecko/EventDispatcher.h>
20
21 #include <NuiApi.h>
22 #include <NuiSkeleton.h>
23
24 namespace vreckoDP_Kinect {
25
26 class DP_EXPORT Kinect : public vrecko::Device
27 {
28 public:
29 Kinect();
31 virtual int openDevice(void);
32 int closeDevice(void);
33 void update(void);
34 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
35
36 void getSkeleton();
37 static DWORD WINAPI KinectThread(LPVOID pParam);
38 void sendSkeletonPositions(NUI_SKELETON_DATA * pSkel);
39 void sendPosition(vrecko::OutputPin<vrecko::MessageVec3>* outputPin, int index, NUI_SKELETON_DATA * pSkel );
40
41 // InputConnector uses this kind of events
42 void sendSensorTransformation(int sensorNumber, int SkeletonIndex, NUI_SKELETON_DATA * pSkel);
43
44 protected:
45 HANDLE _hNextSkeletonEvent;
46
47
48 //XML parameters
49 float _scale;
50 bool _smoothing;
51 osg::Vec3 _worldOrigin;
52 bool _inputConnector;
53 int* _inputConnectorMappings;
54
55 // thread handling
56 HANDLE _hThNuiProcess;
57 HANDLE _hEvNuiProcessStop;
58
59 DECLARE_OUTPUT(HipCenterPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HIP_CENTER
60 DECLARE_OUTPUT(SpinePosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_SPINE
61 DECLARE_OUTPUT(ShoulderCenterPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_SHOULDER_CENTER
62 DECLARE_OUTPUT(HeadPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HEAD
63 DECLARE_OUTPUT(ShoulderLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_SHOULDER_LEFT
64 DECLARE_OUTPUT(ElbowLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_ELBOW_LEFT
65 DECLARE_OUTPUT(WristLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_WRIST_LEFT
66 DECLARE_OUTPUT(HandLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HAND_LEFT
67 DECLARE_OUTPUT(ShoulderRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_SHOULDER_RIGHT
68 DECLARE_OUTPUT(ElbowRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_ELBOW_RIGHT
69 DECLARE_OUTPUT(WristRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_WRIST_RIGHT
70 DECLARE_OUTPUT(HandRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HAND_RIGHT
71 DECLARE_OUTPUT(HipLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HIP_LEFT
72 DECLARE_OUTPUT(KneeLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_KNEE_LEFT
73 DECLARE_OUTPUT(AnkleLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_ANKLE_LEFT
74 DECLARE_OUTPUT(FootLeftPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_FOOT_LEFT
75 DECLARE_OUTPUT(HipRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_HIP_RIGHT
76 DECLARE_OUTPUT(KneeRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_KNEE_RIGHT
77 DECLARE_OUTPUT(AnkleRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_ANKLE_RIGHT
78 DECLARE_OUTPUT(FootRightPosition, vrecko::MessageVec3); //NUI_SKELETON_POSITION_FOOT_RIGHT
79
80 DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation); //data about one point
81 };
82 }
83
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/L3DMouse.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
L3DMouse.h
Go to the documentation of this file.
1 /***************************************************************************
2 l3dmouse.h - description
3 -------------------
4 begin : Mon Jun 3 2002
5 copyright : (C) 2002 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef L3DMOUSE_H
19 #define L3DMOUSE_H
20
21 #include "LHeadTracker.h"
22
23 namespace vreckoDP_base {
24
25 class DP_EXPORT L3DMouse : public LHeadTracker {
26 public:
27 L3DMouse();
28 L3DMouse(const char *port);
29 ~L3DMouse();
30
31 virtual int openDevice(void);
32 int closeDevice(void);
33
34 void update(void);
35
36 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
37 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
38
39 bool getLButton(void) { return left_button;};
40 bool getMButton(void) { return middle_button;};
41 bool getRButton(void) { return right_button;};
42 bool getSButton(void) { return suspend_button;};
43
44 protected:
45 bool left_button, middle_button, right_button, suspend_button, mouse_stand_button;
46
47 int scanDevice(void);
48 int getRecData(long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet);
49
50 char button[5];
51
52 DECLARE_OUTPUT(Button_Left, vrecko::MessageBool);
53 DECLARE_OUTPUT(Button_Middle, vrecko::MessageBool);
54 DECLARE_OUTPUT(Button_Right, vrecko::MessageBool);
55 DECLARE_OUTPUT(Button_Suspend, vrecko::MessageBool);
56 DECLARE_OUTPUT(Button_Mouse_stand, vrecko::MessageBool);
57 };
58
59 }
60
61 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/LHeadTracker.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
LHeadTracker.h
Go to the documentation of this file.
1 /***************************************************************************
2 lheadtracker.h - description
3 -------------------
4 begin : Mon Jun 3 2002
5 copyright : (C) 2002 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef LHEADTRACKER_H
19 #define LHEADTRACKER_H
20
21 #include <vrecko/IOPins.h>
22 #include <vrecko/Device.h>
23 #include <osg/Vec3>
24 #include <osg/Vec4>
25 #include <osg/Matrix>
26 #include <osg/Quat>
27 #include <setjmp.h>
28
29 #if defined(WIN32)
30 #include <windows.h>
31 #endif
32
33
34 namespace vreckoDP_base {
35
36 #define HTI_CONNECTBYTE (char)0x87 /* Open the connection */
37 #define HTI_CLOSEBYTE (char)0x88 /* Close the connection */
38
39 //#define HTI_DEF_PORT 7777 /* Default TCP port */
40 //#define HTI_DEF_SERIAL "/dev/ttyC0" /* Default serial port */
41
42 #define HTD_COMMAND_LEN 2
43 #define HTD_CMD_RESET "*R"
44 #define HTD_CMD_DIAG "*\005"
45 #define HTD_CMD_REPORT "*d"
46 #define HTD_CMD_DEMAND "*D"
47
48 #define HTD_PACKET_LEN 16
49
50 #define HTI_MAX_NUM 1048575 /* max. returned positon */
51 #define HTI_2MAX_NUM 2097150 /* 2*HTI_MAX_NUM */
52 #define HTI_MIN_POS_DIFF 20 /* min. position difference */
53 #define HTI_MIN_ROT_DIFF 80 /* min. rotation difference */
54 #define HTI_POS_C 0.0005
55 #define HTI_ROT_C 40.0
56
57 // class level defines
58 #define SLAVE_MODE 1
59 #define MASTER_MODE 2
60
61 // command type defines
62 #define CMD_TYPE_SLAVE_XMITTER_TYPE 1 // slave transmitter type
63 #define CMD_TYPE_FILTER_POINT 7 // filter point count
64 #define CMD_TYPE_RCVR_DIMENSIONS 8 // set receiver dimensions
65
66 #define htd_flush( port_fd ) ioctl( port_fd, TCFLSH, 2 )
67 #define if_err( param ) if( ( param ) < 0 )
68
69
70 typedef enum {
71 HTD_REC_POS_OUT = 0, /* receiver out of active area */
72 HTD_REC_POS_ACT, /* receiver in active area */
73 HTD_REC_POS_FRI /* receiver in fringe area */
74 } htd_receiver_pos;
75
76 typedef enum {
77 QUATERNION = 0,
78 MATRIX,
79 ANGLES //EULERS_ANGLES ???
80 } rotation_type;
81
82
83 class DP_EXPORT LHeadTracker : public vrecko::Device {
84 public:
85 LHeadTracker();
86 LHeadTracker(const char *port_name);
87 LHeadTracker(const char *port_name1, const char *port_name2);
88 ~LHeadTracker();
89
90 virtual int openDevice(void);
91 int closeDevice(void);
92
93 void update(void);
94
95 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
96 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
97
98 int getRotate(float *p_rotate);
99 osg::Vec3 &getRotate(void);
100 void setRotationType(rotation_type _type) {rot_type = _type;};
101 osg::Vec3 &getRotateA(void);
102 osg::Matrix &getRotateM(void);
103 osg::Quat &getRotateQ(void);
104 int getTranslate(float *p_trans);
105 osg::Vec3 &getTranslate(void);
106 void printPos(void);
107
108 void setInitialPosition(osg::Vec4 &_pos);
109 void setInitialRotation(osg::Vec4 &_rot);
110 void setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2);
111 void setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2);
112
113 void demandReport(void);
114 void setBaseT( osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig );
115 void setBaseR( osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig );
116 void resetBase( osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig );
117 void setSlaveTransmitterType(unsigned char transmitter_type);
118
119 protected:
120 int port_fd, port_fd_dual, _port_fd;
121 std::string _port_name_dual;
122 int actual_p; // 0 | 1 | ...
123
124 int scanDevice(void);
125 #if defined(WIN32)
126 HANDLE hCom, hCom_dual, _hCom; // handle for COM port
127 HANDLE hComxx;
128
129 bool openPort(const char *pcCommPort, HANDLE *temp_hCom);
130 #else
131 bool openPort(const char *_pname, int *temp_port_fd);
132 #endif
133 bool scanDeviceX(void);
134
135 int diagnostic(void);
136 int getRecData(long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet);
137 void delay(int msec);
138 int lhtRead(char *buf, int n);
139 void reset(void);
140 int singleReport(char *reply);
141 void printBuffer(const char *buf, int length);
142
143 osg::Vec4 getEuler(osg::Matrix& _mat);
144
145 // private:
146 bool rec_out[2]; /* receiver out of active area */
147 osg::Vec4 pos[2], rot[2];
148 osg::Vec3 ret_pos, ret_rot;
149 osg::Quat rotq[2], rotq_diff[2];
150 rotation_type rot_type;
151 osg::Matrix ret_rotm;
152 osg::Quat ret_rotq;
153 osg::Vec4 base1, base2, base3, origin; /* HT coordinate system */
154
155 char tx_buf[HTD_COMMAND_LEN]; /* tx buffer */
156 char rx_buf[2*HTD_PACKET_LEN]; /* rx buffer */
157 int req_len, read_len;
158
159 long int absX[2], absY[2], absZ[2]; /* absolute values of position */
160 long int absPI[2], absYA[2], absRO[2]; /* absolute values of rotation */
161 osg::Vec4 pos_diff[2]; /* initial_position - first_relative_postion */
162 osg::Vec4 rot_diff[2]; /* -- '' -- rotation */
163
164 long int last_absPI[2], last_absYA[2], last_absRO[2]; /* last absolute rotation */
165 osg::Vec4 last_rot[2]; /* last rotation */
166
167 osg::Matrix tr_matrix, tr_matrix2; /* transformation matrix for relative position evaluation */
168
169 bool first_report[2]; /* first report from active area */
170
171 osg::Vec4 get_rel_pos( long int x, long int y, long int z );
172 bool checkDiff(const long int &x, const long int &y, const long int &z,
173 const long int &n_pi, const long int &n_ya, const long int &n_ro);
174
175 jmp_buf tenv;
176
177 osg::Vec3 translate_mapping;
178
179 DECLARE_OUTPUT(Position, vrecko::MessageVec3);
180 DECLARE_OUTPUT(Orientation, vrecko::MessageQuat);
181 };
182
183 }
184
185 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Layout.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Layout.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4
5 using namespace vrecko;
6
7
8 namespace APGUI
9 {
10
11 typedef std::map<unsigned long, GUI_Item *> GuiItemMapType;
12
13
15
25 class Layout : public osg::Referenced
26 {
27 public:
28
29 Layout();
30 ~Layout();
31
33 void addItem(GUI_Item *);
34
36 void removeItem(GUI_Item *);
37
39 string getName() { return _name; }
40
42 void show();
43
45 void hide();
46
48
55 bool loadfromXMLnode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
56
57 bool initialize(string name, std::vector<string> *items);
58
60
67 void actualize(GuiItemMapType *map);
68
69
70 protected:
71
73 std::string _name;
74
76 std::vector<string> _itemsNames;
77
79 std::vector<GUI_Item *> _items;
80
81
82
83 };
84
85 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Lens.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Lens.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 using namespace vrecko;
4
5 namespace behindO {
6
7 class Lens: public Ability {
8 public:
9 Lens();
10 ~Lens() {};
11
12 void update(void);
13
14 protected:
15 };
16
17 }
18
19 //$Id: Lens.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Light.h Source File

  • File List
  • File Members
  • include
  • base
Light.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vrecko/EnvironmentObject.h>
4
5 using namespace vrecko;
6
7 namespace base {
8
9 class Light: public Ability {
10 public:
11 Light();
12 ~Light() {};
13
14 void postInitialize(void);
15
16 void update(void);
17
18 void preInitialize();
19 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
20
21 protected:
22 osg::Group* lightGroup;
23 osg::Light* light;
24
25 int lightNumber;
26 osg::Vec3 position, direction;
27 osg::Vec4 ambient, diffuse;
28 float spotCutoff, spotExponent;
29 float constantAttenuation, linearAttenuation, quadraticAttenuation;
30
31 EnvironmentObject *owner;
32
33 DECLARE_INPUT(Enable, MessageBool);
34 };
35
36 }
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/Lights.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
Lights.h
Go to the documentation of this file.
1 #pragma once
2
3 //VRECKO
4 #include <vrecko/Ability.h>
5 #include <vrecko/PluginManager.h>
6 #include <vrecko/World.h>
7 #include <vrecko/Scene.h>
8
9 //Lights
10 #include <osg/LightSource>
11 #include <osg/Light>
12 #include <osg/LightModel>
13
14 //XML
15 #include <helpers/XercesXMLUtils.h>
16 #include <vrecko/ReaderWriter.h>
17 #include <xercesc/parsers/XercesDOMParser.hpp>
18
19 //Shadows
20 #include <osgShadow/ShadowMap>
21 #include <osgShadow/SoftShadowMap>
22 #include <osgShadow/ShadowTexture>
23 #include <osgShadow/LightSpacePerspectiveShadowMap>
24 #include <osg/CullFace>
25
26 //Billboarding
27 #include <osg/BlendFunc>
28 #include <osg/AlphaFunc>
29 #include <osg/Geometry>
30 #include <osg/Texture2D>
31 #include <osgDB/readFile>
32 #include <osg/Depth>
33
34 #include <cmath>
35 #include <sstream>
36 #include <iostream>
37
38
39 namespace APLightsEditor
40 {
41
42 class Lights : public vrecko::Ability
43 {
44 private:
45 osg::ref_ptr<osg::Group> lightGroup;
46 //Shadow techniques
47 osg::ref_ptr<osgShadow::ShadowMap> sm;
48 osg::ref_ptr<osgShadow::SoftShadowMap> ssm;
49 //osg::ref_ptr<osgShadow::ShadowTexture> lispSM;
50
51 osg::ref_ptr<osg::ClearNode> clearColor;
52 osg::ref_ptr<osg::LightModel> lightModel;
53 osg::ref_ptr<osg::StateSet> lightSS;
54 std::vector<osg::Node*> flares;
55 unsigned int maxLights;
56 int shadowLightID;
57 int sunID;
58 osg::Vec4 sunDate; //saved as osg::Vec4(day,month,year,hour*60+minute)
59
60 osg::ref_ptr<osg::Uniform> maximum;
61
62 //global illumination variables
63 osg::ref_ptr<osg::Camera> ndCamera;
64 osg::ref_ptr<osg::Camera> ndCameraBack;
65 osg::ref_ptr<osg::Camera> doCamera;
66 osg::ref_ptr<osg::Camera> bounceCamera;
67 osg::ref_ptr<osg::Camera> blurXCamera;
68 osg::ref_ptr<osg::Camera> blurYCamera;
69 osg::ref_ptr<osg::StateSet> ndSS;
70 osg::ref_ptr<osg::StateSet> ndBSS;
71 osg::ref_ptr<osg::StateSet> doSS;
72 osg::ref_ptr<osg::StateSet> bounceSS;
73 osg::ref_ptr<osg::StateSet> blurXSS;
74 osg::ref_ptr<osg::StateSet> blurYSS;
75 osg::Vec2 giTextureSize;
76 osg::Vec2 viewportSize;
77
78 std::string envMapPath;
80 //Sun computation
81 void clamp(double clampValue, double& number);
82 double computeSunSunriseOrSunset(int day, int month, int year, bool sunrise);
83 public:
140 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
141
142 enum shadowModes
143 {
144 NONE,
145 SHADOW_MAP,
146 SOFT_SHADOW_MAP
147
148 } shadowMode;
149
150 enum shadingModes
151 {
152 GOURAUD,
153 PHONG
154
155 } shadeMode;
156
157 enum giModes
158 {
159 FULL,
160 HALF,
161 NO
162
163 } giMode;
164
165 virtual void preInitialize();
166 virtual void postInitialize();
167
168 //Constructor, destructor
169 Lights(void);
170 ~Lights(void);
174 void InitializeGI();
184 int add(osg::Vec4 position = osg::Vec4(0,0,0,1),
185 osg::Vec3 direction = osg::Vec3(0,0,-1),
186 float spotCutOff = 180,
187 float spotExp = 0);
194 int add(osg::LightSource* lightSource);
199 int addSun(int day, int month, int year, int hour, int minute, osg::Vec4* sunPosition = NULL);
204 bool remove(int lightNum);
208 bool removeAll();
212 int size();
216 osg::Light* at(int lightNum);
220 osg::LightSource* getLightSource(int lightNum);
224 osg::Light* getLight(int lightNum);
229 bool setLightVisibility(int lightNum, bool on);
234 bool setActiveShadowLight(int lightNum);
238 void enableShadows(bool OnOrOff);
243 void setMode(shadowModes shadowMode, shadingModes shadingMode, giModes giMode);
247 bool isShadowsEnabled();
251 void setClearColor(osg::Vec4 color);
255 osg::Vec4& getClearColor();
259 int getCurrentShadowLightID();
264 shadowModes getCurrentShadowMode() { return shadowMode; }
269 shadingModes getCurrectShadingMode() { return shadeMode; }
274 giModes getCurrentGIMode() { return giMode; }
278 void setGlobalAmbient(osg::Vec4 color);
282 const osg::Vec4 getGlobalAmbient() { return lightModel->getAmbientIntensity(); }
286 int getDOSampleCount();
290 float getDORadius();
294 int getBounceSampleCount();
298 float getBounceRadius();
302 int getBlurSize();
306 void setDOSampleCount(int count);
310 void setDORadius(float radius);
314 void setBounceSampleCount(int count);
318 void setBounceRadius(float radius);
322 void setBlurSize(int size);
326 void createFlare(int lightNum);
330 const osg::Vec4& getSunDate() { return sunDate; }
334 osgShadow::ShadowTechnique* getShadowTechnique();
338 std::vector<osg::Node*>& getFlares() { return flares; }
342 osg::Texture2D* createBuffer(osg::Vec2 textureSize, osg::Texture::FilterMode filter,
343 osg::Texture::WrapMode wrap, GLint internalFormat, GLenum sourceFormat);
347 void setUpCamera(osg::ref_ptr<osg::Camera> camera, osg::Vec2 textureSize, osg::ref_ptr<osg::StateSet> camSS,
348 osg::ref_ptr<osg::Shader> vert, osg::ref_ptr<osg::Shader> frag);
349
350 };
351 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/Linear.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
Linear.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Vec2>
4 #include <osg/Vec4>
5
6 using namespace vrecko;
7
8 namespace Filter {
9
10 class Linear: public Ability {
11 public:
12 Linear();
13 ~Linear() {};
14
15 void preInitialize(void);
16 void processEvent(const std::string &input_name, void *value);
17
18 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
19 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
20
21 protected:
22 float coef1;
23 osg::Vec2 coef2;
24 osg::Vec3 coef3;
25 osg::Vec4 coef4;
26 };
27
28 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/LinearInterpolator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
LinearInterpolator.h
Go to the documentation of this file.
1 #pragma once
2 #include "interpolator.h"
3 class LinearInterpolator : public Interpolator
4 {
5 public:
7 META_DAObject(LinearInterpolator, "Linear Interpolator")
8
9 virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed);
10
11 private:
12 osg::Vec3 interpolatePoint( double t, const osg::Vec3& point1, const osg::Vec3& point2 );
13 };
14
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/LoadingConsole.h Source File

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
LoadingConsole.h
Go to the documentation of this file.
1 #ifndef LOADINGCONSOLE_H
2 #define LOADINGCONSOLE_H
3
4 #include "precompiled.h"
5
6
7 /* The loading console is used while loading, so it must not be a descendant of the Ability class
8 and should not use the [world] pointer or anything similar. */
9
10 class LoadingConsole {
11 public:
12 LoadingConsole();
13 ~LoadingConsole();
14
15 bool create(vrecko::ViewerBase *_viewer, osg::Group *_rootNode);
16 void destroy();
17
18 // Can be called from any thread, just puts the line into the array of waiting (outstanding) lines
19 void addLine(unsigned long dwOutputType, const char *outputLine);
20
21 // Processes any outstanding lines, creates graphics etc.
22 void update();
23
24 protected:
25 class Line {
26 public:
27 Line(osgText::Text *_text) { text = _text; };
28 osg::ref_ptr<osgText::Text> text;
29 };
30
31 class OutstandingLine {
32 public:
33 OutstandingLine(unsigned long _dwType, const char *_line) : line(_line), dwType(_dwType) {};
34 std::string line;
35 unsigned long dwType;
36 };
37
38 std::vector<Line> lines;
39
40 MTLock olLock;
41 std::vector<OutstandingLine> outstandingLines; // USE [olLock] before accessing this array
42
43
44 vrecko::ViewerBase *viewer; // these are NOT our data, do not destroy it
45 osg::Group *rootNode; // these are NOT our data, do not destroy it
46
47
48 int viewWidth, viewHeight;
49 int borderXSize, borderYSize, lineSpace, lineHeight;
50
51 osg::ref_ptr<osg::Vec3Array> vertices;
52
53 osg::ref_ptr<osg::ClipNode> mainNode;
54 osg::ref_ptr<osg::Camera> camera;
55 osg::ref_ptr<osg::Geode> geode;
56 osg::ref_ptr<osg::Geometry> geom;
57 };
58
59
60 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Logger.h Source File

  • File List
  • File Members
  • include
  • vrecko
Logger.h
Go to the documentation of this file.
1 #ifndef LOGGER_H
2 #define LOGGER_H
3
4 #include <vrecko/Export>
5 #include <vrecko/Timer.h>
6 #include <vrecko/BenchmarkWriter.h>
7 #include <fstream>
8 #include <map>
9 #include <helpers/DynamicArray.h>
10 #include <string>
11 #include <vrecko/MTLock.h>
12
13 #include <windows.h>
14
15 namespace vrecko {
16
17 class logger_streambuf;
18
19
20 // Flags for Logger::dwAllowedOutput etc.
21 #define LOGGER_OUTPUTTYPE_ERROR 0x00000001
22 // Error message
23 #define LOGGER_OUTPUTTYPE_WARNING 0x00000002
24 // Warning
25 #define LOGGER_OUTPUTTYPE_NOTICE 0x00000004
26 // Simple notice
27 #define LOGGER_OUTPUTTYPE_DEBUG 0x00000008
28 // Debug message - won't be shown in normal user setup
29 #define LOGGER_OUTPUTTYPE_DEBUGFILE 0x00000010
30 // Debug message outputted only into the log file
31 #define LOGGER_OUTPUTTYPE_DEBUGFLUSH 0x00000020
32 // Debug message that is processed immediately, even in non-main thread.
33 // Otherwise the message is handed over to the main thread and processed there.
34 #define LOGGER_OUTPUTTYPE_TIMINGSFILE 0x00000040
35 // Special constant to output times into the timings file (which is xml-based)
36
37 #define LOGGER_OUTPUTTYPEMASK_ALL 0xFFFFFFFF
38 #define LOGGER_OUTPUTTYPEMASK_NONE 0x00000000
39 #define LOGGER_OUTPUTTYPEMASK_DEBUG LOGGER_OUTPUTTYPEMASK_ALL
40 #define LOGGER_OUTPUTTYPEMASK_USER (LOGGER_OUTPUTTYPE_ERROR | LOGGER_OUTPUTTYPE_WARNING | LOGGER_OUTPUTTYPE_NOTICE)
41 #define LOGGER_OUTPUTTYPEMASK_NORMAL LOGGER_OUTPUTTYPEMASK_USER
42
43 #define LOGGER_OT_INTERNALMASK_SPECIALTYPES (LOGGER_OUTPUTTYPE_TIMINGSFILE)
44 #define LOGGER_OT_INTERNALMASK_NORMALTYPES (0xFFFFFFFF ^ LOGGER_OT_INTERNALMASK_SPECIALTYPES)
45
46
47 // Constants for Logger:dwOutputDest etc.
48 #define LOGGER_OUTPUTDEST_STDOUT 0x00000001 // text console
49 #define LOGGER_OUTPUTDEST_FILE 0x00000002 // log file
50 #define LOGGER_OUTPUTDEST_DEBUGSTRING 0x00000004 // i.e. using OutputDebugString() to print it on VisutalStudio console.
51
52 #define LOGGER_OUTPUTDESTMASK_ALL 0xFFFFFFFF // all output destinations
53 #define LOGGER_OUTPUTDESTMASK_NONE 0x00000000
54 #define LOGGER_OUTPUTDESTMASK_NO_STDOUT (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_STDOUT)
55 #define LOGGER_OUTPUTDESTMASK_NO_FILE (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_FILE)
56 #define LOGGER_OUTPUTDESTMASK_NO_DEBUGSTRING (LOGGER_OUTPUTDESTMASK_ALL ^ LOGGER_OUTPUTDEST_DEBUGSTRING)
57
58
59
60
61 class VRECKO_EXPORT Logger {
62 friend class World;
63 public:
64 Logger();
65 ~Logger();
66
67 bool init();
68 // The initialization must be done from the main thread, because Logger will remember its ID
69 // and notices from other threads will be postponed and processed in the main thread.
70
71 void done();
72
73 void update();
74 // Should be called sometimes (ex. once/twice per frame) to process any possible outstanding texts.
75
76 void noticeLog(const char *notice = "", ...);
77 void vnoticeLog(const char *notice, va_list args);
78 // void noticeLog(int level, const char *notice = "", ...);
79 // void vnoticeLog(int level, const char *notice, va_list args);
80 void warningLog(const char *warning = "", ...);
81 void vwarningLog(const char *warning, va_list args);
82 // void warningLog(int level, const char *warning = "", ...);
83 // void vwarningLog(int level, const char *warning, va_list args);
84 void errorLog(const char *error = "", ...);
85 void verrorLog(const char *error, va_list args);
86 // void errorLog(int level, const char *error = "", ...);
87 // void verrorLog(int level, const char *error, va_list args);
88 void debugLog(const char *debugText = "", ...);
89 void vdebugLog(const char *debugText, va_list args);
90 // The (v)debugFileLog() functions only write info to the file
91 void debugFileLog(const char *debugText = "", ...);
92 void vdebugFileLog(const char *debugText, va_list args);
93
94 void debugFlush(const char *debugText = "", ...);
95 void vdebugFlush(const char *debugText, va_list args);
96 // Causes the text to be outputted immediately, even in a non-main thread
97
98 inline unsigned long getAllowedOutput() { return dwAllowedOutput; }
99 inline void setAllowedOutput(unsigned long dwNewOutput) { dwAllowedOutput = dwNewOutput; }
100 // [dwNewOutput] is a combination of LOGGER_OUTPUTTYPE_*.
101 // It is possible to use one of LOGGER_OUTPUTTYPEMASK_* to initialize one of the default behaviours.
102
103 inline unsigned long getOutputDest() { return dwOutputDest; }
104 inline void setOutputDest(unsigned long dwNewOutputDest) { dwOutputDest = dwNewOutputDest; }
105 // [dwNewOutputDest] is a combination of LOGGER_OUTPUTDEST_*
106
107 void startTiming(std::string sectionName);
108 void stopTiming(std::string sectionName, DWORD dwOutputType = LOGGER_OUTPUTTYPE_DEBUG);
109 // LOGGER_OUTPUTTYPE_TIMINGSFILE can be used to output the value into the xml-based
110 // timings file.
111
112 void writeBMCounter(const char *pName, float fValue);
113 // Writes out a counter value to the xml-based timings file.
114 //
115 // BEWARE! If this method is used in a NON-MAIN thread it's not a problem,
116 // but counters are cached and written into file in main thread.
117 // To prevent overflowing there is a LIMIT on number of waiting counter writes.
118
119 inline osg::Timer_t tick() { return vrecko::Timer::instance()->tick(); };
120
121 typedef void (*OutputNotificationFuncType)(unsigned long dwOutputType, const char *outputLine, void* userParam);
122
123 bool registerOutputNotification(OutputNotificationFuncType aFunc, void* userParam);
124 bool unregisterOutputNotification(OutputNotificationFuncType aFunc);
125
126 protected:
127 std::ofstream log_file;
128 osg::Timer_t starttime_stamp;
129
130 DWORD dwMainThreadId;
131 // Used to determine whether the current call to one of the ...log() methods
132 // should output the message directly or pospone it to be processed
133 // in a different (main) thread.
134
135 MTLock generalLock;
136
137 BenchmarkWriter bm;
138
139 class OutstandingText {
140 public:
141 unsigned long dwOutputType;
142 std::string str;
143 };
144 DynamicArray<OutstandingText> outstandingTexts;
145
146 class OutstandingCounter {
147 public:
148 unsigned int time; // ms
149 std::string strName;
150 float fValue;
151 };
152 DynamicArray<OutstandingCounter> outstandingCounters[2];
153 // two arrays: One is processed in the main thread and written to the file
154 // and the other can be filled by other threads.
155 int countersActiveIndex;
156 // Index of the array that is being WRITTEN to.
157 MTLock countersActiveLock;
158
159 void addOutstandingText(unsigned long dwOutputType, const char *buffer);
160 // This method expects that the caller has already locked the [generalLock]
161 void processOutstandingTexts();
162 // This method expects that the caller has already locked the [generalLock]
163
164 void writeBMCounterLowLevel(unsigned int time, const char *pName, float fValue);
165 // This method expects that the caller has already locked the necessary lock(s)
166
167 void processOutstandingCounters();
168 // Flushes outstanding counters into file.
169 // Can be called only from the main thread.
170
171
172 void processTextMain(unsigned long dwOutputType, const char *buffer);
173 // This method expects that the caller has already locked the [generalLock]
174
175 bool openBenchmarkFile();
176 // This function does nothing if the file is already opened (and returns true).
177 // Otherwise returns false if an error occur.
178 // NOTE: The method assumes the benchmarkFile lock is already taken,
179
180
181 struct OutputNotificationFuncStored {
182 OutputNotificationFuncType outFunc;
183 void *userParam;
184 };
185
186
187 struct TimingInfo {
188 TimingInfo() { startTime = 0; totalTime = 0; numRuns = 0; }
189
190 osg::Timer_t startTime;
191
192 // for statistics across multiple timings
193 osg::Timer_t totalTime;
194 int numRuns;
195 };
196
197 std::map<std::string, TimingInfo, std::less<std::string> > sectionsTiming;
198 DynamicArray<OutputNotificationFuncStored> outFuncs;
199
200 logger_streambuf *new_cout, *new_cerr;
201 std::streambuf *old_cout_buf, *old_cerr_buf;
202 std::ostream *old_cout;
203
204 unsigned long dwAllowedOutput;
205 // combination of LOGGER_OUTPUTTYPE_*
206
207 unsigned long dwOutputDest;
208 // combination of LOGGER_OUTPUTDEST_*
209
210 HANDLE hOriginalStdHandle;
211 // Handle of the original stdout to allow us to change colors
212 WORD wOriginalConsoleAttributes;
213 // we will be changing the color of console output, so here is the original color to restore it
214
215 void textLog(unsigned long dwOutputType, const char *text = "", ...);
216 void vtextLog(unsigned long dwOutputType, const char *text, va_list args);
217 // [dwOutputType] is one of LOGGER_OUTPUTTYPE_
218 };
219
220 extern VRECKO_EXPORT Logger logger;
221
222
223 #ifdef _DEBUG
224 #define OUTPUTSTR(str) logger.debugLog(str);
225 #define OUTPUTSTR2(str, p1) logger.debugLog((str), (p1));
226 #define OUTPUTSTR3(str, p1, p2) logger.debugLog((str), (p1), (p2));
227 #define OUTPUTSTR4(str, p1, p2, p3) logger.debugLog((str), (p1), (p2), (p3));
228 #define OUTPUTSTR5(str, p1, p2, p3, p4) logger.debugLog((str), (p1), (p2), (p3), (p4));
229 #define OUTPUTSTR6(str, p1, p2, p3, p4, p5) logger.debugLog((str), (p1), (p2), (p3), (p4), (p5));
230 #define OUTPUTSTR7(str, p1, p2, p3, p4, p5, p6) logger.debugLog((str), (p1), (p2), (p3), (p4), (p5), (p6));
231
232 #define STARTTIMING(sectionName) logger.startTiming(sectionName);
233 #define STOPTIMING(sectionName) logger.stopTiming(sectionName);
234 #else
235 #define OUTPUTSTR(str) {}
236 #define OUTPUTSTR2(str, p1) {}
237 #define OUTPUTSTR3(str, p1, p2) {}
238 #define OUTPUTSTR4(str, p1, p2, p3) {}
239 #define OUTPUTSTR5(str, p1, p2, p3, p4) {}
240 #define OUTPUTSTR6(str, p1, p2, p3, p4, p5) {}
241 #define OUTPUTSTR7(str, p1, p2, p3, p4, p5, p6) {}
242
243 #define STARTTIMING(sectionName)
244 #define STOPTIMING(sectionName)
245 #endif
246
247
248 };
249
250 #endif
251
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/LoggingFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
LoggingFilter.h
Go to the documentation of this file.
1 #ifndef LOGGING_FILTER_H
2 #define LOGGING_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to limit the force size. */
11 class LoggingFilter : public PHANToMFilter {
12 public:
13 LoggingFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 std::string logPrefix;
21 };
22
23 }
24
25 #endif
26
27
28 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTBrush.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTBrush.h
Go to the documentation of this file.
1 #ifndef _MT_BRUSH_H
2 #define _MT_BRUSH_H
3
4
5 using namespace vrecko;
6
7
8 typedef enum MTBrushShapeType {
9 MTBRUSH_SHAPE_ROUND = 101,
10 MTBRUSH_SHAPE_RECTANGE,
11 MTBRUSH_SHAPE_ROUNDED_RECTANGE,
12 };
13
14 typedef enum MTBrushParameterType {
15 MTBRUSH_PARAMETER_CONSTANT = 1,
16 MTBRUSH_PARAMETER_GRADIENT,
17 MTBRUSH_PARAMETER_SPEED_BASED,
18 MTBRUSH_PARAMETER_CURVATURE_BASED,
19 };
20
21
23 /*
24 * contains
25 * - list of points
26 * - map of colours
27 * - map of diameters
28 *
29 */
30 class MTBrush : public osg::Referenced
31 {
32 public:
33
34 MTBrush();
35 ~MTBrush();
36
37 //gets
38 osg::Vec4 getColour(double value = 0.0);
39 std::map<double, osg::Vec4> *getColoursMap() {return this->colours; }
40 inline MTBrushParameterType getColouringType() { return this->colouringType; }
41
42 inline MTBrushParameterType getcrossSectionType() { return this->crossSectionType; }
43 inline std::vector<osg::Vec3> *getCrosssPoints() { return this->crosssPoints; }
44
45 double getDiameter(double value = 0.0);
46 std::map<double, double> *getDiameters() {return this->diameters; }
47
48 inline int getInterpolationSteps() { return this->interpolationSteps; }
49 inline int getCrossSectionInterpolationSteps() { return this->interpolationSteps_crossSection; }
50 inline PoAInterpolationType getCrossSectionInterpolationType() { return this->CrossSectioninterpolationType; }
51
52 inline double getMinSpeed() { return this->minSpeed; }
53 inline double getMaxSpeed() { return this->maxSpeed; }
54
55 //sets
56 void setColour(osg::Vec4 colour, double value = 0.0);
57 void setColourType(MTBrushParameterType type) { this->colouringType = type; }
58 void setCrossSectionType(MTBrushParameterType type) { this->crossSectionType = type; }
59 void setCrossSectionShape(MTBrushShapeType sh);
60 void setDiameter(double diam, double value = 0.0);
61 inline void setInterpolationSteps(int interpol) {this->interpolationSteps = interpol; }
62 inline void setSpeeds(double min, double max) { this->minSpeed = min; this->maxSpeed = max; }
63
64
65
66 private:
67
68 //cross-section
69 MTBrushParameterType crossSectionType;
70 std::map<double, double> *diameters;
71
72 std::vector<osg::Vec3> *crosssPoints;
73 int interpolationSteps_crossSection;
74 PoAInterpolationType CrossSectioninterpolationType;
75
76 //colours
77 MTBrushParameterType colouringType;
78 std::map<double, osg::Vec4> *colours;
79
80 //characteristics
81 double minSpeed;
82 double maxSpeed;
83
84 int interpolationSteps;
85
86 };
87
88 #endif // _MT_BRUSH_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTControlPoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTControlPoint.h
Go to the documentation of this file.
1 #ifndef _DA_CONTROL_POINT_H
2 #define _DA_CONTROL_POINT_H
3
4
5 #include "SimpleBox.h"
6
8
11 class DAGizmo : public osg::Referenced
12 {
13 public:
14 DAGizmo(osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius);
15 ~DAGizmo();
16
17 osg::ref_ptr <SimpleBox> getNormal() { return this->normal; }
18 osg::ref_ptr <SimpleBox> getBinormal() { return this->binormal; }
19
20 bool isVisible() { return this->visibility; }
21 void hide();
22 void show();
23
24 private:
25 osg::Group *visualsOwner;
26
27 bool visibility;
28
29 //for visualizing Frenet frame
30 osg::ref_ptr <SimpleBox> tangent;
31 osg::ref_ptr <SimpleBox> normal;
32 osg::ref_ptr <SimpleBox> binormal;
33
34 };
35
36
38
46 class DAControlPoint : public osg::Referenced
47 {
48 public:
49
50 DAControlPoint(DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient);
51 ~DAControlPoint();
52
53 //not used
54 //create new SimpleBox, make it visible
55 //void createVisualBox(osg::Vec3 size=osg::Vec3(VISUALS_WIDTH, VISUALS_WIDTH, VISUALS_WIDTH), bool movable=true, osg::Vec4 colour = osg::Vec4(1.0, 1.0, 1.0, 1.0));
56
57 //gets
58 inline osg::Vec3 getBinormal() { return this->binormal; }
59 inline double getCurvature() { return this->curvature; }
60 inline osg::Vec3 getNormal() { return this->normal; }
61 inline osg::Quat getOrientation() { return this->orientation; }
62 inline osg::Vec3 getPosition() { return this->position; }
63 inline double getPriority() { return this->priority; }
64 inline double getSegmentLength() { return this->segmentLength; }
65 inline double getSpeed() { return this->speed; }
66 inline osg::Vec3 getTangent() { return this->tangent; }
67 inline double getTorsion() { return this->torsion; }
68 inline double getTvalue() { return this->tvalue; }
69 inline DAControlPointType getType() { return this->type; }
70 inline osg::Group * getVisualOwner() {return this->visualsOwner; }
71 string getPositionString();
72
73 //sets
74 void setCharacteristics(osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion);
75 inline void setNormal(osg::Vec3 nrml) {this->normal = nrml; }
76 inline void setBinormal(osg::Vec3 binrml) {this->binormal = binrml; }
77 void setPosition(osg::Vec3 pos);
78 void setPosition(osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z);
79 inline void setPriority(double prior) {this->priority = prior; }
80 inline void setSegmentLength(double length) { this->segmentLength = length; }
81 inline double setSpeed(double spee) { this->speed = spee; }
82 inline void setTangent(osg::Vec3 tngt) { this->tangent = tngt; }
83 inline void setTvalue(double tval) {this->tvalue = tval; }
84 inline void setVisibleVisualBox(bool vis);
85
87 void showGizmo(bool show);
88
89
91 bool frenetFremeComputed;
92
93 private:
94
95 //type of this point
96 DAControlPointType type;
97
102 double tvalue;
103
104 osg::Vec3 position;
105
106 //not used
107 //TODO remove if not-used
108 osg::Quat orientation;
109
110 //Computed characteristics
111 osg::Vec3 tangent;
112 osg::Vec3 normal;
113 osg::Vec3 binormal;
114
116 double curvature;
118 double torsion;
119
129 double speed;
130
132 /*
133 * at first is the same as speed
134 * when some points are added or remove, this parameter must be recalculated
135 */
136 double segmentLength;
137
139
143 double priority;
144
145
146 //visuals related variables
147 osg::Group *visualsOwner;
148 bool visibleVisualBox;
149
150 osg::ref_ptr <SimpleBox> visualBox;
151
152 osg::ref_ptr<DAGizmo> gizmo; //graphical gizmo
153
154
155
156 };
157
158
159 #endif //_DA_CONTROL_POINT_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTCreatorTool.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTCreatorTool.h
Go to the documentation of this file.
1 #ifndef _DYNAMIC_ART_CREATOR_TOOL_H
2 #define _DYNAMIC_ART_CREATOR_TOOL_H
3
4 #include "DATool.h"
5 #include "PoA.h"
6 #include "SimpleBox.h"
7
8 class DAEnvironment;
9
10 typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox;
11
13
17 class MTCreatorTool : public DATool
18 {
19 public:
20
21 MTCreatorTool(int sensorNumber);
22 ~MTCreatorTool();
23
24 void activate();
25 void deactivate();
26
28 std::vector<DASample>* getSamples();
29
30 void postInitialize(void);
31
32 void processEvent(const std::string &input_name, void *value);
33
34 void turnOn();
35
36 void turnOff();
37
38 void update();
39
40
41
42 protected:
43
44 int sensorNumber;
45 string posString;
46 string oriString;
47
48 EnvironmentObject* DAArea;
49
50 osg::Vec3 position;
51 osg::Quat orientation;
52
53 osg::Vec3 DAAposition;
54 osg::Quat DAAOrientation;
55 osg::Vec3 DAAScale;
56
57 bool newPosition;
58 bool newOrientation;
59
60 std::vector<DASample>* samples;
61
62 };
63
64
65 typedef osg::ref_ptr<MTCreatorTool> ref_ptr_MTCreatorTool;
66
67 #endif // _DYNAMIC_ART_CREATOR_TOOL_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/MTLock.h Source File

  • File List
  • File Members
  • include
  • vrecko
MTLock.h
Go to the documentation of this file.
1
9 #ifndef MTLOCK_H
10 #define MTLOCK_H
11
12
13 #ifdef WIN32
14 #include <windows.h>
15
16 //#define USE_CRITICAL_SECTIONS
17 // Critical sections are faster, but cannot be used to synchronize activity
18 // across different processes/DLLs.
19 #endif
20
21 #include <map>
22
23
24 namespace vrecko {
25
26
27 #ifdef VRECKO_LIBRARY
28 #define MTLOCK_IMP_EXP __declspec(dllexport)
29 #else
30 #define MTLOCK_IMP_EXP __declspec(dllimport)
31 #endif
32
33
34
35 #if 0
36
37
38 // "COPTex" version.
39 // As fast as a critical section, but can be used for inter-process synchronization.
40 // http://www.microsoft.com/msj/0198/win32textfigs.htm#fig2
41 class MTLOCK_IMP_EXP MTLock {
42 public:
43 MTLock();
44 ~MTLock();
45
46 bool lock();
47 void unlock();
48
49 protected:
50
51 void SetSpinCount(DWORD dwSpinCount);
52 BOOL TryEnter();
53
54 typedef struct {
55 volatile DWORD m_dwSpinCount;
56 volatile long m_lLockCount;
57 volatile DWORD m_dwThreadId;
58 volatile long m_lRecurseCount;
59 } SHAREDINFO, *PSHAREDINFO;
60
61 BOOL m_fUniprocessorHost;
62 HANDLE m_hevt;
63 HANDLE m_hfm;
64 volatile PSHAREDINFO m_pSharedInfo;
65
66 BOOL CommonConstructor(PVOID pszName, BOOL fUnicode, DWORD dwSpinCount);
67 };
68
69 typedef MTLock MTLockSingleProcess;
70
71 #else
72
73
86 class MTLOCK_IMP_EXP MTLock {
87 public:
88 MTLock();
89 ~MTLock();
90
91 bool lock();
92 void unlock();
93
95 HANDLE getHandle() const { return mutex; }
96
97 protected:
98
99 #ifdef WIN32
100 HANDLE mutex;
101 #else
102 pthread_mutex_t *mutex;
103 #endif
104 };
105
106
108 class MTLOCK_IMP_EXP MTAutoLock {
109 public:
110 MTAutoLock(MTLock *lockToLock) { theLock = lockToLock; lockToLock->lock(); };
111 ~MTAutoLock() { theLock->unlock(); }
112 protected:
113 MTLock* theLock;
114 };
115
116 #ifdef WIN32
117
118 class MTLOCK_IMP_EXP MTLockSingleProcess {
119 public:
120 MTLockSingleProcess();
121 ~MTLockSingleProcess();
122
123 bool lock();
124 void unlock();
125
126 protected:
127 CRITICAL_SECTION criticalSection;
128 };
129 #else
130 typedef MTLock MTLockSingleProcess;
131 #endif
132
133
134 #endif
135
136
159 class MTLOCK_IMP_EXP MTReadWriteLock
160 {
161 protected:
162 HANDLE m_Access;
163 int m_Readers;
164 HANDLE m_WriterMutex;
165 HANDLE m_CanRead;
166 HANDLE m_CanWrite;
167
168 public:
169 MTReadWriteLock();
170 ~MTReadWriteLock();
171
172 bool lockRead( DWORD Timeout = INFINITE );
173 bool lockWrite( DWORD Timeout = INFINITE );
174 void unlockRead( DWORD Timeout = INFINITE );
175 void unlockWrite( DWORD Timeout = INFINITE );
176 };
177
178
195 class MTLOCK_IMP_EXP MTReadWriteLockEx {
196 struct KThreadInfo {
197 int ReadCount;
198 int WriteCount;
199
200 bool IsReader() { return ReadCount > 0; };
201 bool IsWriter() { return WriteCount > 0; };
202 };
203
204 typedef std::map<DWORD, KThreadInfo> KThreadMap;
205 KThreadMap m_Threads;
206
207 // Number of reader threads;
208 // Note: writer threads are not reader threads, even if they have read locks
209 int m_TotalReaderThreads;
210 int m_TotalWriterThreads; // current writer + waiting writers
211
212 HANDLE m_Access;
213 HANDLE m_WriterMutex;
214 HANDLE m_CanRead;
215 HANDLE m_CanWrite;
216
217 void incReaders()
218 {
219 ++m_TotalReaderThreads;
220 ResetEvent(m_CanWrite);
221 };
222
223 void decReaders()
224 {
225 if (--m_TotalReaderThreads == 0)
226 SetEvent(m_CanWrite);
227 };
228
229 void incWriters()
230 {
231 ++m_TotalWriterThreads;
232 ResetEvent(m_CanRead);
233 };
234
235 void decWriters()
236 {
237 if (--m_TotalWriterThreads == 0)
238 SetEvent(m_CanRead);
239 };
240
241 public:
242 MTReadWriteLockEx();
243 ~MTReadWriteLockEx();
244
245 bool lockRead( DWORD Timeout = INFINITE );
246 bool lockWrite( DWORD Timeout = INFINITE );
247 void unlockRead( DWORD Timeout = INFINITE );
248 void unlockWrite( DWORD Timeout = INFINITE );
249
250 };
251
252
253 // Design by Vit Kovalcik.
254 // Lock with two priorities. The higher one will not starve.
255 // Only a single thread can acquire the lock (i.e. no simultaneous high + low threads).
256 // WARNING - LIMITATION: The high priority part can be used only in a single thread.
257 // Usage in two or more threads will result in an unexpected behaviour.
258 class MTLOCK_IMP_EXP MTTwoPrioLimitedLock {
259 protected:
260 HANDLE m_AllowLowPrio;
261 HANDLE m_Access;
262 HANDLE m_WritersMutex;
263 public:
264 MTTwoPrioLimitedLock();
265 ~MTTwoPrioLimitedLock();
266
267 // WARNING: lockHigh()/unlockHigh() sequence can be used only in one thread (at the same time)
268 bool lockHigh();
269 void unlockHigh();
270
271 bool lockLow();
272 void unlockLow();
273 };
274
275
276 };
277
278 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/MTMatrixTransform.h Source File

  • File List
  • File Members
  • include
  • base
MTMatrixTransform.h
Go to the documentation of this file.
1 #ifndef MTMATRIXTRANSFORM_H
2 #define MTMATRIXTRANSFORM_H
3
4
5 // MTMatrixTransform = Multi-threaded Matrix Transform
6 // This ability stores a copy of the transformation matrix that is present
7 // in every EnvironmentObject. The copy of matrix present in the ability
8 // is possible to update from any thread and as often as necessary (hundreds/thousands
9 // timer per frame).
10 // The changes are automatically transferred to the main matrix once per frame.
11
12
13 #include <vrecko/Ability.h>
14 #include <vrecko/MTLock.h>
15 #include <vrecko/IOPins.h>
16 #include <osg/Group>
17
18
19 using namespace vrecko;
20
21
22 namespace base
23 {
24
25 #ifdef AP_BASE_EXPORTS
26 #define MTMATRIXTRANSFORM_IMP_EXP __declspec(dllexport)
27 #else
28 #define MTMATRIXTRANSFORM_IMP_EXP __declspec(dllimport)
29 #endif
30
31
32 class MTMATRIXTRANSFORM_IMP_EXP MTMatrixTransform: public Ability
33 {
34 public:
35 MTMatrixTransform();
36 virtual ~MTMatrixTransform();
37
38 virtual void preInitialize();
39 virtual void update();
40 // Runs once per frame (LATE in the frame) and synchronizes main object transformation
41 // with the local matrix copy.
42
43 bool getMatrix(osg::Matrix *pMatrix);
44 void setMatrix(osg::Matrix *newMatrix);
45
46 bool getWorldTransformation(osg::Matrix *pMatrix);
47 // calculates the world transformation using the stored matrix (instead of the object main transformation)
48
49 protected:
50 EnvironmentObject *owner;
51 osg::Matrix matrix;
52 bool bRetrieved; // matrix already retrieved from the owner object?
53 bool bUpdated; // a call to local setMatrix() occured, so we should update
54 // the main object transformation at the end of the frame?
55
56 MTReadWriteLockEx generalLock;
57
58 DECLARE_REQUEST_INPUT(SetMatrix, MessageMatrix, MessageVoid);
59 DECLARE_REQUEST_INPUT(GetMatrix, MessageVoid, MessageMatrix);
60 };
61 }
62
63 #endif
64
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MTTriangulator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MTTriangulator.h
Go to the documentation of this file.
1 #ifndef _DA_TRIANGULATROR_H
2 #define _DA_TRIANGULATROR_H
3
4 #include "MTControlPoint.h"
5 #include "MTBrush.h"
6
7 typedef osg::ref_ptr<DAControlPoint> ref_ptr_DAControlPoint;
8 typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox;
9
10 class MotionTrailTriangulator : public osg::Geode
11 {
12 public:
13 MotionTrailTriangulator(osg::ref_ptr<MTBrush> br);
14 ~MotionTrailTriangulator();
15
17 void interpolateVec3(std::vector<osg::Vec3>* controlPoints, std::vector<osg::Vec3>* interpolatedPoints, PoAInterpolationType type, bool closed, int p_steps);
18
20 /*
21 * used for highlighting - when user point on Motion trail
22 */
23 osg::Vec4 highlightColour(osg::Vec4 col);
24
26 /*
27 * if (length optimization == false)
28 * p_steps = number of interpolated points between two control points
29 * else
30 * p_steps is recomputed, based on length of segment
31 */
32 void interpolate(std::vector<ref_ptr_DAControlPoint>* controlPoints, std::vector<osg::Vec3>* interpolatedPoints, std::vector<double>* tvalues = NULL, int p_steps = 0, bool lengthOptimization = false, bool closed = false);
33
34 void interpolateCrossSection() { interpolateCrossSection(brush, interpolatedCrosssPoints, interpolatedCrosssNormals); };
35
36 void interpolateCrossSection(MTBrush *brush, std::vector<osg::Vec3> *interpolatedPoints, std::vector<osg::Vec3> *interpolatedNormals);
37
38 inline bool getHighLighting() { return this->isHighlighted; }
39
40 void setHighLighting(bool high) { this->isHighlighted = high; }
41
42 void setUseFrenetFrame(bool frenet) { this->useFrenetFrame = frenet; }
43
44 void triangulate(std::vector<ref_ptr_DAControlPoint>* controlPoints);
45
46 //TODO only for test - move back to private
47 //Catmull-Rom interpolation
48 osg::Vec3 catmullRomInterpolation(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
49
50 //derivation of Catmull-Rom interpolation
51 osg::Vec3 derivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
52
53 //second derivation of Catmull-Rom interpolation
54 osg::Vec3 doubleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
55
56 //third derivation ...
57 osg::Vec3 tripleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
58
59
60 private:
61 PoATriangulationType triangulationType;
62 PoAInterpolationType interpolationType;
63
64 osg::ref_ptr<osg::Geometry> geometry;
65 osg::ref_ptr<osg::Vec3Array> vertices;
66 osg::ref_ptr<osg::Vec3Array> normals;
67 osg::ref_ptr<osg::Vec4Array> colours;
68
69 bool isHighlighted;
70
71
72
73 //Tube
74 osg::ref_ptr<MTBrush> brush;
75 bool closedCrossSection;
76 bool interpolatedCrossSection;
77
78 //TODO - useless - remove?
79 bool useFrenetFrame;
80
81 std::vector<osg::Vec3> *interpolatedCrosssPoints;
82 std::vector<osg::Vec3> *interpolatedCrosssNormals;
83
84
86 bool createCrossSection(DAControlPoint *point, double diameter, osg::Vec3Array *crossSection, osg::Vec3Array *normals);
87
89 osg::Vec3 interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0 = osg::Vec3(0.0, 0.0, 0.0), osg::Vec3 point3 = osg::Vec3(0.0, 0.0, 0.0));
90
91 std::vector<ref_ptr_SimpleBox>* shapes; //for visualization
92
93 };
94
95
96 #endif // _DA_TRIANGULATROR_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/MagicWandTool.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
MagicWandTool.h
Go to the documentation of this file.
1 #ifndef _DYNAMIC_ART_MAGICWAND_TOOL_H
2 #define _DYNAMIC_ART_MAGICWAND_TOOL_H
3
4 #include "DATool.h"
5 #include "PoA.h"
6 #include "Attractor.h"
7
8 class DAEnvironment;
9 class Controller;
10
11
12 class MagicWandTool : public DATool
13 {
14 public:
15
16 MagicWandTool(Controller* contr);
17 ~MagicWandTool();
18
23 void activate();
24
25 void deactivate();
26
27 void postInitialize(void);
28
29 void processEvent(const std::string &input_name, void *value);
30
31 void turnOn();
32
33 void turnOff();
34
35
36
37 protected:
38 int sensorNumber;
39 std::string posString;
40 std::string PointerPosReqString;
41
42 osg::ref_ptr<Attractor> attractor;
43
44 bool dominantAxis;
45
46 osg::Vec3 originalHandposition;
47 osg::Vec3 newHandPosition;
48
49 double handMoveMin;
50 double handMoveMax;
51
52 osg::Vec3 paramRangeStart;
53 osg::Vec3 paramRangeEnd;
54 osg::Vec3 initialParamValue;
55 osg::Vec3 paramShift1;
56 osg::Vec3 paramShift2;
57 osg::Vec3 paramMult;
58
59 int indexX;
60 int indexY;
61 int indexZ;
62
63 Controller* controller;
64 int originalIterations;
65 int lastDominantAxis;
66
67
68 };
69
70
71 #endif // _DYNAMIC_ART_MAGICWAND_TOOL_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Manipulator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Manipulator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/Vec3>
4 #include <osg/Quat>
5 #include <osg/Matrix>
6
7
8 using namespace vrecko;
9
10 namespace behindO {
11
12 class Manipulator: public Ability {
13 public:
14 Manipulator();
15 ~Manipulator() {};
16
17 // ------ BaseClass functions ------------------------
19 void processEvent(const std::string &input_name, void *value);
20 // ---------------------------------------------------
21
22 void preInitialize(void);
23 void update(void);
24
25 std::string getAcceptableMessages(void) {return "boolean|state";} // true/false, 0/1
26
27 protected:
28 //osg::Vec3 grab_position, actual_position, last_position, center_rotation;
29
30 //osg::Vec3 avatar_eye, avatar_center, avatar_up_vector;
31
32 int control;
33 bool _first;
34
35 osg::Vec3 sensor_relative_pos, initial_sensor_pos, last_sensor_pos;
36 osg::Quat last_sensor_orientation;
37 float eye_distance_scale_factor;
38 osg::Vec3 head_center, eye_position, up_vector, look_at_center, to_center;
39
40 osg::Vec3 EO_owner_grab_pos, avatar_grab_pos;
41 osg::Matrix EO_owner_grab_rot, avatar_grab_transform, avatar_grab_inverse_transform, avatar_grab_rotation, avatar_grab_inverse_rotation;
42 osg::Matrix EO_owner_grab_Wrot;
43
44 bool active;
45
46 EnvironmentObject *owner;
47 };
48
49 }
50
51 //$Id: Manipulator.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/MappingFunctions.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
MappingFunctions.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vrecko/EnvironmentObject.h>
3
4 #include <osg/MatrixTransform>
5
6 using namespace vrecko;
7
8 namespace behindO {
9
10 class MappingFunctions: public Ability {
11 public:
12 MappingFunctions();
13 ~MappingFunctions() {};
14
15 void processEvent(const std::string &input_name, void *value);
16 void postInitialize(void);
17
18 void update(void);
19
20 protected:
21 std::vector<std::string> sender_backup, receiver_backup;
22
23 EnvironmentObject *owner;
24
25 double space_scale;
26 bool nonlinear;
27 /*
28 int control;
29 std::vector<EnvironmentObject *> wire_object_map;
30
31 bool continuous_selection, wireframe;
32 float transparency;
33 osg::Vec3 selection_point[2], box_size;
34
35 osg::MatrixTransform *pSelectionBox;
36 EnvironmentObject *border_object;
37
38 void createBorder(void);
39 */
40 };
41
42 }
43
44 //$Id: MappingFunctions.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Marker.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Marker.h
Go to the documentation of this file.
1 #ifndef VF_MARKER
2 #define VF_MARKER
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7 using namespace vrecko;
8 using namespace vreckoDP_base;
9 namespace VirtualFixture{
10
11 class Marker: public PHANToMFilter {
12 public:
13 Marker();
14 Marker(int newid, osg::Vec3 newposition);
15 Marker(int newid, osg::Vec3 newposition, std::string newlabel, std::string newdescribtion);
16 ~Marker() {};
17
19 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
20 void processEvent(const std::string &input_name, void *value);
21
22 void preInitialize(void);
23 void postInitialize(void);
24 void update(void);
25
26 void setPosition(osg::Vec3 newposition) {position = newposition;};
27 osg::Vec3 getPosition() {return position;};
28 void setId(int newid) {id = newid;};
29 int getId() {return id;};
30 void setLabel(std::string newlabel) {label = newlabel;};
31 std::string getLabel() {return label;};
32 void setDescribtion(std::string newdescribtion) {describtion = newdescribtion;};
33 std::string getDescribtion() {return describtion;};
34
35 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
36 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
37
38
39 protected:
40 PHANToM *PHANToMDevice;
41 bool all_on;
42
43 bool active; //if true, it will be active
44
45 osg::Vec3 position; //?? is it necessary ?? we have position from OSG tree
46 int id; //marker id .. will be added automatically
47 std::string label; //for selection menu
48 std::string describtion; //longer that label
49
50 };
51
52 };
53 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/MarkerFactory.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
MarkerFactory.h
Go to the documentation of this file.
1 #ifndef VF_MARKER_FACTORY
2 #define VF_MARKER_FACTORY
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7
8 #include "Auxiliary.h"
9 #include "Marker.h"
10
11 using namespace vrecko;
12 using namespace vreckoDP_base;
13 namespace VirtualFixture{
14
15 class MarkerFactory: public PHANToMFilter {
16 public:
17 MarkerFactory();
18 ~MarkerFactory() {};
19
21 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
22 void processEvent(const std::string &input_name, void *value);
23
24 void preInitialize(void);
25 void postInitialize(void);
26 void update(void);
27
28 int addMarker(); //return id of new marker
29 void removeAllMarkers(); //remove all markers from scene and free memory
30
31
32 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
33 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
34
35 protected:
36 PHANToM *PHANToMDevice;
37 bool all_on;
38 bool active; //if true, it will be active
39
40 int num_of_markers; //amount of markers
41 vector<Marker> markers; //data store for markers
42 osg::Vec3 act_position; //actual position of device
43
44 };
45
46 };
47
48 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialDesc.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
MaterialDesc.h
Go to the documentation of this file.
1 #ifndef MaterialDesc_h
2 #define MaterialDesc_h
3
4 #include "PhysXObject.h"
5 #include <vrecko/World.h>
6 #include <string>
7
8 using namespace vrecko;
9 namespace vrecko
10 {
11 class MaterialDesc
12 {
13 private:
14 NxMaterialDesc _materialDesc;
15 NxMaterialIndex _matIndex;
16 std::string _name;
17
18 public:
19 NxMaterialIndex MatIndex() const { return _matIndex; }
20 std::string Name() const { return _name; }
21 void Create(NxScene* pScene);
22 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
23 };
24 }
25
26
27 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/MaterialManager.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
MaterialManager.h
Go to the documentation of this file.
1 #ifndef MaterialManager_h
2 #define MaterialManager_h
3
4 #include "MaterialDesc.h"
5
6 using namespace vrecko;
7
8 namespace PhysXPlugin
9 {
10 class MaterialManager
11 {
12 private:
13 std::map<std::string, MaterialDesc> _MaterialMap;
14
15 public:
16 bool loadXMLMaterial(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
17 void Create(NxScene* pScene);
18
19 NxMaterialIndex indexByName(const std::string &);
20 };
21 }
22
23
24 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Math.h Source File

  • File List
  • File Members
  • include
  • vreckoUtils
Math.h
Go to the documentation of this file.
1 /*
2 * VRECKO - Virtual reality engine
3 *
4 * This library is free software; you can redistribute it and/or
5 * modify it under the terms of the GNU Lesser General Public
6 * License version 2.1, as published by the Free Software Foundation.
7 *
8 * This library is distributed in the hope that it will be useful,
9 * but WITHOUT ANY WARRANTY; without even the implied warranty of
10 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
11 * Lesser General Public License for more details.
12 *
13 * Copyright (c) 2012 Martin Bezdeka <mbezdeka@mail.muni.cz>
14 *
15 */
16 #pragma once
17 #include "Export"
18
19 namespace vreckoUtils
20 {
21
22 class VRECKO_UTILS_EXPORT Math
23 {
24 public:
26 static int gcd(int a, int b);
28 static int lcm(int a, int b);
29 };
30
31 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/MediaPath.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
MediaPath.h
Go to the documentation of this file.
1 #ifndef __MEDIA_PATH__
2 #define __MEDIA_PATH__
3
4 /*
5 This function locates the media associated with the sample in a non platform specific way.
6
7 For example it searches the Samples\Media directory on the PC (assuming the exe is in the bin directory or
8 or project directory after a compile). This helps prevent duplicate resources for samples.
9
10 On the XBox360 the game specific drive alias is added to the path(ie d:\).
11
12 On PS3 no change is made.
13
14 fname - File name of media file
15 buff - buffer to put media path in
16 return - buff.
17 */
18 char* FindMediaFile(const char *fname,char *buff);
19
20 char* GetTempFilePath(char *buff);
21
22 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Message.h Source File

  • File List
  • File Members
  • include
  • vrecko
Message.h
Go to the documentation of this file.
1
9 #ifndef MESSAGE_H
10 #define MESSAGE_H
11
12
13 //#include <vrecko/BaseClass.h>
14 #include <osg/Referenced>
15 #include <osg/Timer>
16 #include <osg/Vec2>
17 #include <osg/Vec3>
18 #include <osg/Vec4>
19 #include <osg/Quat>
20 #include <osg/Matrix>
21 #include <osg/Node>
22
23 #include <vrecko/Export>
24
25 #include <fstream>
26
27 #include <string>
28 #include <map>
29 #include <vector>
30
31 #include <xercesc/dom/DOMNode.hpp>
32 //#include <xercesc/util/XercesDefs.hpp>
33 //#include <helpers/XercesXMLUtils.h>
34
35
36 namespace vrecko {
37
38 class VRECKO_EXPORT EnvironmentObject;
39 class VRECKO_EXPORT Scene;
40
41
43 enum EventType {
44 NORMAL_EVENT,
45 PRIORITY_EVENT,
46 EXPRESS_EVENT
47 };
48
49 /*
50 class VRECKO_EXPORT Message: public BaseClass {
51
52 friend class Scene;
53
54 public:
55 Message();
56 Message(std::string message_id, EnvironmentObject *_new_sender_ptr);
57 Message(void *image_ptr, Scene *scene_ptr);
58 virtual ~Message();
59
60 typedef struct {
61 void *data_ptr;
62 long int data_size;
63 } MessageData;
64
65 typedef std::map<std::string, MessageData> DataMap;
66
67 void setID(const std::string &message_id) {id = message_id;}
68 inline const std::string &getID(void) const {return id;}
69
70 void setSenderCompetenceLevel(int _new_sender_competence_level)
71 {_sender_competence_level = _new_sender_competence_level;}
72 int getSenderCompetenceLevel(void) {return _sender_competence_level;}
73
74 long int getTimeStamp(void) {return _time_stamp;}
75 EnvironmentObject *getSenderPtr(void) {return _sender_ptr;}
76 const std::string getIncludedData(void) {return _included_data;}
77 // inline int getApplyTo(void) {return _apply_to;}
78
79 void setSpecifiedObjectID(long int _nso) {_specified_object_ID = _nso;}
80 inline long int getSpecifiedObjectID(void) {return _specified_object_ID;}
81
82 void addData(const std::string &_dt, void *_ptr, long int size);
83 bool getDataMessageStruct(const std::string &dt, MessageData &msg_data);
84 void *getDataPtr(const std::string &dt);
85 bool getDataPtr(const std::string &dt, void **data_ptr);
86 bool dataPresent(const std::string &dt);
87 inline bool isEmpty() {return (_data.size() == 0);}
88
89 bool setImage(void *image_ptr, Scene *scene_ptr);
90 void *getImage(long int &size);
91
92 //
93 const DataMap::iterator getFirstIterator() {return _data.begin();}
94 const DataMap::iterator getNextIterator(DataMap::iterator &itr) {
95 itr++;
96 if (itr != _data.end()) return itr;
97 else return *((DataMap::iterator*)NULL);
98 }
99
100 void update(void) {};
101
102 protected:
103 std::string id;
104 osg::Timer_t _time_stamp;
105 osg::Timer _timer;
106 EnvironmentObject *_sender_ptr;
107 int _sender_competence_level;
108 std::string _included_data; // deprecated
109 // int _apply_to;
110 DataMap _data;
111 long int _specified_object_ID;
112
113 void setTimeStamp(osg::Timer_t _new_ts) {_time_stamp = _new_ts;}
114
115 };
116 */
117
118
119 /* The base message class, all other messages are derived from this one. */
120 class VreckoMessage : public osg::Referenced {
121 public:
122 VreckoMessage() {};
123 virtual ~VreckoMessage() {}; // the destructor should be virtual (see http://blogs.msdn.com/b/oldnewthing/archive/2004/05/07/127826.aspx )
124
126 virtual const char* getMessageId() { return "VreckoMessage"; }
127
135 virtual bool setValueFromString(const char *valueAsString) { return false; };
136
144 virtual bool isEqualTo(VreckoMessage *otherMsg) { return false; };
145
146 protected:
147 };
148
149
150 class MessageVoid : public VreckoMessage {
151 public:
152 virtual const char* getMessageId() { return "MessageVoid"; }
153
154 MessageVoid() {};
155
156 virtual bool setValueFromString(const char *valueAsString) { return true; };
157 virtual bool isEqualTo(VreckoMessage *otherMsg) { return true; };
158 };
159
160
161 class MessageSensorTransformation : public VreckoMessage
162 {
163 public:
164 MessageSensorTransformation() { }
165 MessageSensorTransformation(int number, osg::Vec3 &position, osg::Quat &orientation) { _sensorNumber = number; _sensorPosition = position; _sensorOrientation = orientation; }
166
167 int _sensorNumber;
168 osg::Vec3 _sensorPosition;
169 osg::Quat _sensorOrientation;
170 };
171
172
173
184 #define VRECKO_START_MESSAGE_BASE(messageName, dataType) \
185 class messageName : public vrecko::VreckoMessage { \
186 public: \
187 messageName() {}; \
188 virtual const char* getMessageId() { return #messageName; } \
189 dataType data;
190
191
200 #define VRECKO_START_MESSAGE_EXTENDED(messageName, dataType) \
201 VRECKO_START_MESSAGE_BASE(messageName, dataType) \
202 messageName(dataType newData) { data = newData; }; \
203 virtual bool isEqualTo(messageName *otherMsg) { return (data == (otherMsg)->data); }; \
204
205
211 #define VRECKO_END_MESSAGE \
212 };
213
214
215
216
217
218
219
235 VRECKO_START_MESSAGE_EXTENDED(MessageBool, bool)
236 virtual bool setValueFromString(const char *valueAsString) { data = (atoi(valueAsString) > 0); return true; };
237 VRECKO_END_MESSAGE
238
239
240 VRECKO_START_MESSAGE_EXTENDED(MessageInt, int)
241 virtual bool setValueFromString(const char *valueAsString) { data = atoi(valueAsString); return true; };
242 VRECKO_END_MESSAGE
243
244
245 VRECKO_START_MESSAGE_EXTENDED(MessageUnsignedInt, unsigned int)
246 virtual bool setValueFromString(const char *valueAsString) { data = (unsigned int)atol(valueAsString); return true; };
247 VRECKO_END_MESSAGE
248
249
250 VRECKO_START_MESSAGE_EXTENDED(MessageFloat, float)
251 virtual bool setValueFromString(const char *valueAsString) { data = atof(valueAsString); return true; };
252 VRECKO_END_MESSAGE
253
254
255 VRECKO_START_MESSAGE_EXTENDED(MessageObjectID, unsigned long)
256 virtual bool setValueFromString(const char *valueAsString) { data = atol(valueAsString); return true; };
257 VRECKO_END_MESSAGE
258
259
260 VRECKO_START_MESSAGE_BASE(MessageString, std::string)
261 MessageString(const std::string &_data) { data = _data; };
262 MessageString(const char *_data) { data = _data; };
263 virtual bool setValueFromString(const char *valueAsString) { data = valueAsString; return true; };
264 virtual bool isEqualTo(VreckoMessage *otherMsg) { return !data.compare(((MessageString*)otherMsg)->data); };
265 VRECKO_END_MESSAGE
266
267
268 VRECKO_START_MESSAGE_BASE(MessageVec2, osg::Vec2)
269 MessageVec2(const osg::Vec2 &_data) { data = _data; };
270 virtual bool setValueFromString(const char *valueAsString) { return (2 == sscanf_s(valueAsString, "%f %f", &data.x(), &data.y())); };
271 virtual bool isEqualTo(VreckoMessage *otherMsg) { return (data == ((MessageVec2*)otherMsg)->data); };
272 VRECKO_END_MESSAGE
273
274
275 VRECKO_START_MESSAGE_BASE(MessageVec3, osg::Vec3)
276 MessageVec3(const osg::Vec3 &_data) { data = _data; };
277 virtual bool setValueFromString(const char *valueAsString) { return (3 == sscanf_s(valueAsString, "%f %f %f", &data.x(), &data.y(), &data.z())); };
278 virtual bool isEqualTo(VreckoMessage *otherMsg) { return (data == ((MessageVec3*)otherMsg)->data); };
279 VRECKO_END_MESSAGE
280
281
282 VRECKO_START_MESSAGE_BASE(MessageVec4, osg::Vec4)
283 MessageVec4(const osg::Vec4 &_data) { data = _data; };
284 virtual bool setValueFromString(const char *valueAsString) { return (4 == sscanf_s(valueAsString, "%f %f %f %f", &data.x(), &data.y(), &data.z(), &data.w())); };
285 virtual bool isEqualTo(VreckoMessage *otherMsg) { return (data == ((MessageVec4*)otherMsg)->data); };
286 VRECKO_END_MESSAGE
287
288
289 VRECKO_START_MESSAGE_BASE(MessageQuat, osg::Quat)
290 MessageQuat(const osg::Quat &_data) { data = _data; };
291 virtual bool setValueFromString(const char *valueAsString) { return (4 == sscanf_s(valueAsString, "%f %f %f %f", &data.x(), &data.y(), &data.z(), &data.w())); };
292 virtual bool isEqualTo(VreckoMessage *otherMsg) { return (data == ((MessageQuat*)otherMsg)->data); };
293 VRECKO_END_MESSAGE
294
295
296 VRECKO_START_MESSAGE_BASE(MessageMatrix, osg::Matrix)
297 MessageMatrix(const osg::Matrix &_data) { data = _data; };
298 virtual bool setValueFromString(const char *valueAsString) { return (16 == sscanf_s(valueAsString, "%f %f %f %f %f %f %f %f %f %f %f %f %f %f %f %f",
299 &data(0, 0), &data(0, 1), &data(0, 2), &data(0, 3),
300 &data(1, 0), &data(1, 1), &data(1, 2), &data(1, 3),
301 &data(2, 0), &data(2, 1), &data(2, 2), &data(2, 3),
302 &data(3, 0), &data(3, 1), &data(3, 2), &data(3, 3)
303 )); };
304 virtual bool isEqualTo(VreckoMessage *otherMsg) { return (data == ((MessageMatrix*)otherMsg)->data); };
305 VRECKO_END_MESSAGE
306
307
308 VRECKO_START_MESSAGE_BASE(MessageNodeList, std::vector<osg::Node*>)
309 MessageNodeList(const std::vector<osg::Node*> &_data) { data = _data; };
310 VRECKO_END_MESSAGE
311
312
313 VRECKO_START_MESSAGE_BASE(MessageNode, osg::ref_ptr<osg::Node>)
314 MessageNode(osg::Node * newNode) { data = newNode; };
315 VRECKO_END_MESSAGE
316
317 class XERCES_CPP_NAMESPACE_QUALIFIER DOMNode;
318
319 VRECKO_START_MESSAGE_BASE(MessageXMLNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *)
320 MessageXMLNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * newNode) { data = newNode; };
321 VRECKO_END_MESSAGE
322
323 }
324
325
326 #endif // MESSAGE_H
327
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/MicroScribe3D.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
MicroScribe3D.h
Go to the documentation of this file.
1
2 #ifndef MICROSCRIBE3D_H
3 #define MICROSCRIBE3D_H
4
5 #include <vrecko/IOPins.h>
6 #include <vrecko/Device.h>
7 #include <vrecko/EventDispatcher.h>
8
9 #include <osg/Vec3>
10 #include <osg/Quat>
11
12 #include "classes.h"
13 #include "arm.h"
14
15 namespace vreckoDP_base {
16
17
18 class DP_EXPORT MicroScribe3D : public vrecko::Device {
19 public:
20 MicroScribe3D();
21 MicroScribe3D(const char *port_name);
22 ~MicroScribe3D();
23
24 virtual int openDevice(void);
25 int closeDevice(void);
26
27 void update(void);
28
29 int getButt() { return butt; };
30 private:
31 Arm arm;
32 arm_result armRes;
33
34 osg::Vec3 pos, normal;
35 osg::Quat orient;
36 int butt;
37
38 void dispatch();
39
40 protected:
41 vrecko::EventDispatcher *pEventDispatcher;
42
43 DECLARE_OUTPUT(Buttons, vrecko::MessageInt);
44 DECLARE_OUTPUT(Position, vrecko::MessageVec3);
45 DECLARE_OUTPUT(Normal, vrecko::MessageVec3);
46 DECLARE_OUTPUT(Orientation, vrecko::MessageQuat);
47 };
48
49 }
50
51 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/MidpointDisplacementAlgorithm.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
MidpointDisplacementAlgorithm.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_MIDPOINTDISPLACEMENTALGORITHM_H
10 #define VRECKO_NATURE_TERRAIN_MIDPOINTDISPLACEMENTALGORITHM_H
11
12 #include "TerrainAlgorithm.h"
13 #include "../TerrainUtility.h"
14 #include <osg/Array>
15
16 namespace APNature
17 {
18 class MidpointDisplacementAlgorithm : public TerrainAlgorithm
19 {
20
21 public:
22
23 static const int InitialLevel;
24
32 MidpointDisplacementAlgorithm(int width, int height, float cornerValueFrom, float cornerValueTo);
33
40 void RandomizeSurfaceCorners(float cornerValueFrom, float cornerValueTo);
41
53 float* GenerateSurfaceByMidpointDisplacement(int x1, int y1, int x2, int y2, int level);
54
55 private:
56
57 float ComputePseudoRandomError(int x1, int y1, int x2, int y2, int level);
58
59 };
60 }
61
62 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/MidpointDisplacementProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
MidpointDisplacementProperties.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_MIDPOINTDISPLACEMENTPROPERTIES_H
11 #define VRECKO_NATURE_TERRAIN_MIDPOINTDISPLACEMENTPROPERTIES_H
12
13 #include <vrecko/ReaderWriter.h>
14 #include <osg/Vec2>
15
16 #include "GeneratedTerrainProperties.h"
17
18 namespace APNature
19 {
20 static class MidpointDisplacementProperties : public GeneratedTerrainProperties
21 {
22 private:
23
24 // Midpoint displacement
25 static float _fractalDimension;
26 static float _cornerValueFrom, _cornerValueTo;
27
28 public:
29
30 // Midpoint displacement specific methods
31 // ######################################
32
38 static inline float FractalDimension() { return _fractalDimension; }
39 static inline void FractalDimension(float fractalDimension) { _fractalDimension = (fractalDimension > 3.0f ? 3.0f :
40 (fractalDimension < 2.0f ? 2.0f : fractalDimension) ); }
41
48 static void CornerValueRange(float cornerValueFrom, float cornerValueTo);
49
50 static inline float CornerValueFrom() { return _cornerValueFrom; }
51 static inline float CornerValueTo() { return _cornerValueTo; }
52
53 // Derived properties
54 // ##################
55
61 static inline float HurstExponent() { return 3 - _fractalDimension; }
62
68 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
69
70 } MidpointDisplacementProperties;
71
72 }
73
74 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/Mirror.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
Mirror.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <osg/MatrixTransform>
4 #include <osg/Geode>
5 #include <osg/Geometry>
6 #include <osgUtil/UpdateVisitor>
7 #include <osg/Texture2D>
8
9 #include <osg/Node>
10
11 #include <osgUtil/TransformCallback>
12 #include <osgUtil/RenderStage>
13 #include <osgUtil/SmoothingVisitor>
14 #include <osgUtil/CullVisitor>
15
16
17 using namespace vrecko;
18
19 namespace behindO {
20
21 class MyUpdateCallback : public osg::NodeCallback
22 {
23 public:
24
25 MyUpdateCallback(osg::Node* subgraph):
26 _subgraph(subgraph) {}
27
28 virtual void operator()(osg::Node* node, osg::NodeVisitor* nv)
29 {
30 // traverse the subgraph to update any nodes.
31 if (_subgraph.valid()) _subgraph->accept(*nv);
32
33 // must traverse the Node's subgraph
34 traverse(node,nv);
35 }
36
37 osg::ref_ptr<osg::Node> _subgraph;
38 };
39
40 class MyCullCallback : public osg::NodeCallback
41 {
42 public:
43
44 MyCullCallback(osg::Node* subgraph,osg::Texture2D* texture):
45 _subgraph(subgraph),
46 _texture(texture),
47 _localState(new osg::StateSet),
48 frame(true),
49 dir(true) {}
50
51 MyCullCallback(osg::Node* subgraph,osg::Image* image):
52 _subgraph(subgraph),
53 _image(image),
54 _localState(new osg::StateSet),
55 frame(true),
56 dir(true) {}
57
58 virtual void operator()(osg::Node* node, osg::NodeVisitor* nv)
59 {
60 if (frame) {
61 osgUtil::CullVisitor* cullVisitor = dynamic_cast<osgUtil::CullVisitor*>(nv);
62 if (cullVisitor && (_texture.valid()|| _image.valid()) && _subgraph.valid()) {
63 doPreRender(*node,*cullVisitor);
64
65 // must traverse the subgraph
66 traverse(node,nv);
67 } else {
68 // must traverse the subgraph
69 traverse(node,nv);
70 }
71 }
72
73 frame = !frame;
74 }
75
76 void doPreRender(osg::Node& node, osgUtil::CullVisitor& cv);
77
78 osg::ref_ptr<osg::Node> _subgraph;
79 osg::ref_ptr<osg::Texture2D> _texture;
80 osg::ref_ptr<osg::Image> _image;
81 osg::ref_ptr<osg::StateSet> _localState;
82 bool frame;
83
84 osg::Vec3 camera_position, camera_direction, camera_center, old_camera_direction;
85 osg::Vec3 up_vector;
86 EnvironmentObject *mirror_object;
87 bool dir;
88 };
89
90
91
92 class Mirror: public Ability {
93 public:
94 Mirror();
95 ~Mirror() {};
96
97 void preInitialize(void);
98 void update(void);
99
100 protected:
101 osg::Geode *_geode;
102 osg::Geometry *_geom;
103 osgUtil::UpdateVisitor *_updateVisitor;
104 osg::Texture2D* _texture;
105 osg::MatrixTransform *_parent, *mirror_plane_transf;
106
107 osg::Vec3 _mirror_normal, _eye_position, _center_position;
108
109 bool _first;
110
111 osg::Vec3Array* mirror_plane_vertices;
112 MyCullCallback *pMyCullCallback;
113
114 // osg::Light* light;
115
116 };
117
118 }
119
120 //$Id: Mirror.h 189 2011-07-12 08:31:31Z xchmeli1 $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/ModelManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
ModelManager.h
Go to the documentation of this file.
1 #ifndef _MODELMANAGER
2 #define _MODELMANAGER 1
3
4 #include <vector>
5 #include <map>
6
7 #include <osg/Notify>
8 #include <osg/Node>
9 #include <osg/Geode>
10 #include <osg/Group>
11 #include <osg/ShadeModel>
12 #include <osg/CullFace>
13 #include <osg/StateSet>
14
15 #include <osgDB/Registry>
16 #include <osgDB/ReadFile>
17 #include <osgUtil/Optimizer>
18
19 #include <osgCal/CoreModel>
20 #include <osgCal/Model>
21
22
23 using namespace vrecko;
24 using namespace ArtificialWorld;
25
27 struct GeometryState{
28 public:
29 GeometryState(){geometry = NULL; count = 0;};
30 GeometryState(EnvironmentObject *eo){geometry = eo; count=1;};
32 osg::ref_ptr<EnvironmentObject> GetGeometry(){return geometry.get();};
34 void RemoveGeometry(){geometry = NULL;};
36 int Count(){return count;};
38 void AddReference(){count++;};
40 void RemoveReference()
41 {
42 count--;
43 if(count < 0)
44 count = 0;
45 };
46 private:
48 osg::ref_ptr<EnvironmentObject> geometry;
50 int count;
51 };
52
54 struct AnimatedGeometryState{
55 public:
56 AnimatedGeometryState(){ coreModel = NULL; count = 0;};
57 AnimatedGeometryState(osgCal::CoreModel *cm){ coreModel = cm; count = 1;};
59 osg::ref_ptr<osgCal::CoreModel> GetAnimatedGeometry(){ return coreModel.get();};
61 void RemoveGeometry(){ coreModel = NULL;};
63 int Count(){ return count;};
65 void AddReference(){ count++;};
67 void RemoveReference()
68 {
69 count--;
70 if(count < 0)
71 count = 0;
72 };
73 private:
75 osg::ref_ptr<osgCal::CoreModel> coreModel;
77 int count;
78 };
79
81 class DeleteObserver{
82 public:
83 DeleteObserver(){};
86 virtual void DeleteUpdate(osg::ref_ptr<EnvironmentObject> deletingObject, int num, ModelType modelType) = 0;
87 };
88
90 class GetObserver{
91 public:
92 GetObserver(){};
95 virtual void GetUpdate(string modelFilename, int num, ModelType modelType) = 0;
96 };
97
99 class AddObserver{
100 public:
101 AddObserver(){};
104 virtual void AddUpdate(string modelFilename, ModelType modelType) = 0;
105 };
106
110 class ModelManager{
111 private:
112 //zajemci o udalosti mazani, ziskani a pridani
113 static vector<DeleteObserver*> delObservers;
114 static vector<GetObserver*> getObservers;
115 static vector<AddObserver*> addObservers;
116
117 public:
119 static osg::ref_ptr<EnvironmentObject> GetModelGeometry(string modelFilename);
121 static void DeleteModelGeometry(osg::ref_ptr<EnvironmentObject> *ptr);
122
124 static bool ContainsModelGeometry(string modelFilename);
126 static bool ContainsAnimatedModelGeometry(string modelFilename);
128 static bool ContainsModelGeometry(string modelFilename, ModelType modelType);
129
131 static osg::ref_ptr<EnvironmentObject> GetAnimatedModelGeometry(string modelFilename, int animationIndex, bool startAnimation);
133 static void DeleteAnimatedModelGeometry(osg::ref_ptr<EnvironmentObject> *ptr);
135 static void DeleteModelGeometry(osg::ref_ptr<EnvironmentObject> *ptr, ModelType modelType);
136
138 static void AddModelGeometry(string modelFilename, osg::ref_ptr<EnvironmentObject> newGeometry);
139
141 static void AddDeleteObserver(DeleteObserver* newObserver);
143 static void AddGetObserver(GetObserver* newObserver);
145 static void AddAddObserver(AddObserver *newObserver);
147 static void RemoveDeleteObserver(DeleteObserver* observer);
149 static void RemoveGetObserver(GetObserver* observer);
151 static void RemoveAddObserver(AddObserver *observer);
152
153 private:
154
156 static map<string, GeometryState> geoms;
158 static map<string, AnimatedGeometryState> animGeoms;
159
161 static void DeleteNotify(osg::ref_ptr<EnvironmentObject> deletingObject, int remaining_count, ModelType modelType);
162 static void GetNotify(string modelFilename, int existing_count, ModelType modelType);
163 static void AddNotify(string modelFilename, ModelType modelType);
164
165 // Pomocna funkce pro nacitani animovane geometrie. Je tu jen pro to, aby sla zachytavat vyjimka.
166 // V GetAnimatedModelGeometry() to neslo kvuli chybe C2712
167 // (Cannot use __try in functions that require object unwinding)
168 static bool SubLoadAnimatedGeometry(osgCal::CoreModel &coreModel, std::string &modelFilename, osgCal::MeshParameters &meshParameters);
169 };
170
171 #endif
172
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Modes.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Modes.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\Referenced>
4 #include <osg\ref_ptr>
5 #include "Controller.h"
6
7 namespace APDYNAMICART
8 {
9
10 class Mode : public osg::Referenced
11 {
12 public:
13 virtual void setLayout() = 0;
14 protected:
15 virtual ~Mode() {};
16 };
17
19 typedef osg::ref_ptr<Mode> ModePtr;
20
22 class Basic : public Mode
23 {
24 Controller* _controller;
25 public:
26 Basic(Controller* controller) { _controller = controller; }
27
28 virtual void setLayout();
29 };
30
31 class Advanced : public Mode
32 {
33 Controller* _controller;
34 public:
35 Advanced(Controller* controller) { _controller = controller; }
36
37 virtual void setLayout();
38 };
39
40 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/MotionTrail.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
MotionTrail.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "BrushStroke.h"
4
5 using namespace vrecko;
6
7 namespace APDYNAMICART
8 {
9
10
12
17 class MotionTrail : public BrushStroke
18 {
19 public:
20
21 MotionTrail(Controller* contr, ColorGenAdapter* colorGenAdapter, DiameterGenAdapter* diamGenAdapt, SplineAdapter* crossSectionAdapter);
22 ~MotionTrail();
23
24 // /// Add control point to this MotionTrail - at last position in vector of control points
25 // /**
26 // *
27 // * \param pos position of new point
28 // * \param list list of control points to witch new point will be added
29 // * \param type of point - sampled, interpolated or temporary
30 // * \param tvalue interpolation value
31 // * \return ref. pointer to new control point
32 // */
33 // ref_ptr_DAControlPoint addControlPoint(osg::Vec3 pos, std::vector<ref_ptr_DAControlPoint>* list, DAControlPointType type, double tvalue = 0.0);
34 //
35 // /// Add control point to this MotionTrail - at last position in vector of control points
36 // ref_ptr_DAControlPoint addControlPoint(DASample *sample, std::vector<ref_ptr_DAControlPoint>* list, DAControlPointType type, double mutliplicator = 1.0);
37 //
38 // /// Add control point - create new object as a copy of the one given
39 // ref_ptr_DAControlPoint addControlPoint(DAControlPoint *point, std::vector<ref_ptr_DAControlPoint>* list);
40 //
41 //
42 // std::string createMenuStructure(void) const;
43 //
44 // /// export the current state of the motion trail to a file
45 // /**
46 // * \todo use osg function to write Node to file
47 // */
48 // void exportToFile(std::string file);
49 //
50 // void importControlPoints( const std::vector<osg::Vec3> *importedSamples, const std::vector<osg::Vec4> *importedColours );
51 //
52 // //gets
53 // inline std::vector<ref_ptr_DAControlPoint>* getControlPoints() { return this->controlPoints; }
54 // inline osg::Vec4 getColour(double value = 0.0) const { return this->brush->getColour(value); }
55 // inline MTBrushParameterType getColouringType() const { return this->brush->getColouringType(); }
56 // inline MTBrushParameterType getCrossSectionType() const { return this->brush->getcrossSectionType(); }
57 // inline double getDiameter(double value = 0.0) const {return this->brush->getDiameter(value); }
58 // inline int getInterpolation() const { return this->brush->getInterpolationSteps(); }
59 // inline std::vector<DASample>* getSamples() const {return this->samples; }
60 // inline double getSmoothness() const { return this->smoothness; }
61 //
62 // int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* MotionTrailNode);
63 //
64 // void menuItemClicked(const char* itemID);
65 //
66 // void menuSliderChanged(const char* sliderID, float sliderPos);
67 //
68 // void pointed(bool pointed);
69 //
70 // void preInicialize();
71 //
72 // /// Create new set of control points from samples based on chosen parameters.
73 // /*
74 // * "the liver of a poodle" of Motion trail.
75 // *
76 // * phase 0 - clear old data
77 // * phase 1 - create control points from "all" samples
78 // * phase 2 - compute rotation frame for each control points
79 // * phase 3 - compute local characteristics of all control points
80 // * phase 4 - smoothing - reduce number of control points
81 // * phase 5 - interpolate - compute additional points between existing point to create smoother triangulation
82 // * phase 6 - (re)compute rotation frames and characteristics of control points
83 // * phase 7 - triangulate
84 // *
85 // */
86 // bool recreateControlPoints(int startingPhase = -1);
87 //
88 //
89 // /// Save PoA as one node to .xml file
90 // void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
91 //
92 // //sets
93 // void setColor(osg::Vec4 newColour);
94 // void setColourType(int type);
95 // void setColourType(MTBrushParameterType type);
96 //
97 // void setCrossSectionInterpolation(int interpol);
98 // void setCrossSectionType(int type);
99 // void setCrossSectionType(MTBrushParameterType type);
100 // void setCrossSectionShape(int shape);
101 // /*
102 // * Set new diameter value at given interpolation value
103 // *
104 // * \param dia new diameter value
105 // * \param value of interpolation across curve - 0.0 means at curve start, 1.0 means at curve end
106 // */
107 // void setDiameter(double dia, double value = 0.0);
108 //
109 // void setInterpolation(int interpol);
110 // void setSmoothness(double smooth);
111 // void setUpdating(MotionTrailUpdateType p_type);
112 //
113 // /// Create triangle mesh from control points
114 // void triangulate();
115 //
116 // void stopSampling();
117 //
118 // /// Switch between polygon = FILL and wireframe = LINE modes
119 // void switchRenderingMethod();
120 //
121 // void update(void);
122 //
123 // /// Switch on or off showing box-likes visualization of control points of MotionTrail
124 // void visualizeControlPoints(bool show);
125 //
126 //
127 //protected:
128 //
129 // /// All samples tracked during creation of MotionTrail
130 // /**
131 // * used for compute control points, local and global characteristics
132 // */
133 // std::vector<DASample>* samples;
134 //
135 // /// All control points of MotionTrail
136 // std::vector<ref_ptr_DAControlPoint>* controlPoints;
137 //
138 // /// Type of rotation frame
139 // RotationFrameType frame;
140 //
141 // /// Type of update
142 // MotionTrailUpdateType updatingType;
143 //
144 // //computing control points from samples
145 // unsigned int lastAnalyzedSample; ///< index of last already analyzed sampe
146 // unsigned int lastControlPointsWithChars; ///< with computed characteristics
147 // double segmentLength; ///< accumulated length of actual computed segment
148 //
149 // osg::ref_ptr<osg::Group> boxesGroup; ///< mainly for debug - group of all SimpleBoxes of this MotionTrail
150 //
151 // //Global Characteristics
152 // double length; ///< sum of length of all segments
153 //
154 // ///\todo - redefined in Brush (for triangulation)
155 // double minSpeed;
156 // double maxSpeed;
157 // double meanSpeed;
158 //
159 // double minCurvature;
160 // double maxCurvature;
161 // double meanCurvature;
162 //
163 // double minTorsion;
164 // double maxTorsion;
165 // double meanTorsion;
166 //
167 //
168 // osg::ref_ptr<MTBrush> brush;
169 //
170 // double smoothness;
171 // osg::ref_ptr<MotionTrailTriangulator> triangulator;
172 //
173 // bool visibleControlPointsGizmo;
174 //
175 // double awaitingColorChangeValue; ///< value of new color (choosed by Color Chooser)
176 //
177 // //Private functions
178 //
179 // ///computes global and local (at each control point) characteristics of MotionTrail
180 // /**
181 // * for all, or only specified range of control points, given characteristics are recomputed and store into points.
182 // * In different stages of Motion trail life-cycle, different characteristics are necessary or useless
183 // * to speed-up, what characteristics will be computed is specified by parameters.
184 // *
185 // * \param cpoints list of control points
186 // * \param[in] first index of first point to be analyzed
187 // * \param[in] count number points to be analyzed
188 // * \param[in] compute characteristics only from sampled points
189 // * \param[in] lengths - compute also lengths of segments
190 // * \param[in] speeds - compute also speed of movement in control points
191 // * \param[in] priorities - compute also priorities of control points
192 // * \param[in] globalChars - compute also global characteristics of MotionTrail
193 // * TODO CRITICAL - rethink, rewrite whole function - uses phases from recreateControlPoints()
194 // */
195 // void computeFrenetFrame(std::vector<ref_ptr_DAControlPoint>* cpoints, int first, int count, bool onlySampled, bool lengths, bool speeds, bool priorities, bool globalChars);
196 //
197 //
198 // ///Global characteristics computation
199 // /**
200 // * min, max, mean value of speed, curvature and torsion\
201 // */
202 // void computeGlobalCharacteristics();
203 //
204 // /// evaluate priority of each control point
205 // /// based on segment length and curvature and torsion of poit
206 // void computeControlPointsPriorities();
207 //
208 // /// compute speed of all control points
209 // /*
210 // * based on segments lengths
211 // * speed of SAMPLED points is calculated only ONCE and did not change even when some points are deleted or new interpolated points are added.
212 // *
213 // * \param onlySampled - compute speed only at SAMPLED points (there are probably no other points)
214 // */
215 // void computeControlPointsSpeeds(bool onlySampled);
216 //
217 // /// computes Frenet Frame for given control point, store data into given point
218 // void computePointCharacteristics(DAControlPoint *point, DAControlPoint *prevPoint, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3);
219 //
220 // /// computes Frenet Frame for given INTERPOLATED control point
221 // void computeInterpolatedPointCharacteristics(DAControlPoint *point, DAControlPoint *spoint0, DAControlPoint *spoint1, DAControlPoint *spoint2, DAControlPoint *spoint3);
222 //
223 //
224 // /// computes Rotation Minimizing Frame for all points
225 // /**
226 // *
227 // * for more details, see paper at:
228 // * http://portal.acm.org/citation.cfm?id=1330513&dl=ACM&coll=DL&CFID=12922836&CFTOKEN=38716133
229 // * especialy, page 7
230 // *
231 // * \param controlPoints set of control points to compute with
232 // */
233 // void computeRMF(std::vector<ref_ptr_DAControlPoint>* controlPoints);
234 //
235 //
236 // /// Compute segment lengths of actual set of control points
237 // /**
238 // * this is necessary for computation of speed and also for better interpolation of control points.
239 // */
240 // void computeSegmentLengths(std::vector<ref_ptr_DAControlPoint>* controlPoints, std::vector<osg::Vec3> *interpolatedPoints, int interpolationSteps);
241 //
242 // /// Remove some control points and thus smooth and simplify spine curve of trail
243 // /*
244 // *
245 // *
246 // */
247 // void optimizeControlPoints(std::vector<ref_ptr_DAControlPoint>** controlPoints, double smoothness);
248 //
249 //
250 // /// Return distance between two samples
251 // inline double sampleDistance(DASample *s1, DASample *s2);
252
253 };
254
255 }
256
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/MouseHand.h Source File

  • File List
  • File Members
  • include
  • base
MouseHand.h
Go to the documentation of this file.
1 #ifndef MOUSEHAND_H
2 #define MOUSEHAND_H
3
4 #include <string>
5
6 #include <vrecko/Ability.h>
7
8 #include <vrecko/EnvironmentObject.h>
9
10 using namespace vrecko;
11
12 namespace base {
13
14 class MouseHand: public Ability {
15 public:
16 static const std::string GRAB_EVENT;
17 static const std::string GRAB_RELEASE_EVENT;
18 static const std::string BRICK_MOVE_EVENT;
19
20 MouseHand();
21 ~MouseHand() {};
22
23 // ------ BaseClass functions ------------------------
25 void processEvent(const std::string &input_name, void *value);
26 // ---------------------------------------------------
27
28 void update(void);
29
30 void preInitialize() {owner = (EnvironmentObject*)pOwner;}
31
32 protected:
33 osg::Vec3 _grab_position, _actual_position, _last_position;
34 osg::Matrix _grab_rotation, _actual_rotation, _last_rotation;
35 osg::Matrix _parent_rotation, _parent_inverse_rotation;
36 bool _first;
37 bool dyn_version;
38
39 EnvironmentObject *selected_object;
40 Ability *ab_with_input_Use;
41 bool manipulate;
42
43 osg::Vec3 _last_positions[200];
44 int _current_pos;
45 osg::Matrix _grab_rotation2;
46 osg::Vec3 _grab_position2;
47 osg::Vec3 force;
48 bool first;
49
50 osg::Vec2 mouse_position;
51 osg::Vec3 scene_mouse_position;
52 float z_position, z_step;
53
54 // new
55 osg::Matrix grab_transform, current_transform, last_transform;
56 osg::Matrix grab_transform_SO, SOparent_mat;
57
58 EnvironmentObject *owner;
59
60
61 DECLARE_INPUT(Grab, MessageBool);
62 DECLARE_INPUT(Position, MessageVec2);
63 DECLARE_INPUT(ZChange, MessageFloat);
64
65 DECLARE_OUTPUT(Grab, MessageObjectID);
66 DECLARE_OUTPUT(GrabRelease, MessageObjectID);
67 DECLARE_OUTPUT(BrickMove, MessageObjectID);
68 };
69
70 }
71
72 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/MultiplyFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
MultiplyFilter.h
Go to the documentation of this file.
1 #ifndef MULTIPLY_FILTER_H
2 #define MULTIPLY_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to multiply the forces (torque is often too small to feel). */
11 class MultiplyForceFilter : public PHANToMFilter {
12 public:
13 MultiplyForceFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 float fMulForce;
21 float fMulTorque;
22 };
23
24 }
25
26 #endif
27
28
29 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HelloWorld/MyAbility.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HelloWorld
MyAbility.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vrecko/EnvironmentObject.h>
5
6 namespace APHelloWorld
7 {
8
9 class MyAbility: public vrecko::Ability
10 {
11 public:
12 MyAbility();
13 ~MyAbility();
14
15 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
16 virtual void update(void);
17 };
18
19 }
20
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/NavSphere.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
NavSphere.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4 #include "Auxiliary.h"
5 #include "VibrationLabel.h"
6
7 #include <osg/Vec4>
8 #include <osg/Geode>
9 #include <osg/MatrixTransform>
10 #include <osg/Group>
11
12
13 using namespace vrecko;
14 using namespace vreckoDP_base;
15 namespace VirtualFixture{
16
17 class NavSphere: public PHANToMFilter {
18 public:
19 NavSphere();
20 ~NavSphere() {};
21
23 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
24 void processEvent(const std::string &input_name, void *value);
25
26 void preInitialize(void);
27 void postInitialize(void);
28 void update(void);
29
30 void display(void); //show or hide VF geometry
31
32 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
33 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
34
35 protected:
36 PHANToM *PHANToMDevice;
37 bool all_on;
38 bool active; //if true, attractive field will be active
39 bool visible; //if geometric representation will be visible
40
41 float radius; //radius of navigation sphere -> close to 0 for 6DOF NS, for 3DOF NS should be bigger
42 float stiffness; //sphere boundary force
43 bool store_origin_flag; //when NS is activated or reactivated we have to store its center position
44 osg::Vec3 origin; //the point where NavSphere were activated ...
45 int attenuationtype; //for choosing different attenuation types (0 - none, 1 - linear, 2 ...)
46 float attenuationparam; //parameter of attenuation
47
48 osg::Vec3 actpos; //actual position of PHANToM device
49 osg::Vec3 actdir; //actual direction of PHANToM stylus (vector)
50 bool vibration_flag; //if object hitted by ray -> true .. then vibrate
51 float amplitude; //vibration of actual hitted object
52 float frequency; //vibration of actual hitted object
53 osg::Vec3 direction; //vibration of actual hitted object
54 // osg::Quat actori; //actual orientation of PHANToM stylus (quaternion)
55 osg::MatrixTransform *tnode; //transform node pointer
56 osg::Group *gnode; //group pointer
57 osg::Geode *node; //geometry node pointer (ray)
58 osg::Geometry *geom;
59 osg::Vec4 color; //ray color
60 float transparency; //ray transparency
61
62 };
63
64 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/NestOfBirds.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
NestOfBirds.h
Go to the documentation of this file.
1 /***************************************************************************
2 NestOfBirds.h - description
3 -------------------
4 begin : October 2003
5 copyright : (C) 2003 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU L General Public License as published by*
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef NEST_OF_BIRDS_H
19 #define NEST_OF_BIRDS_H
20
21 #ifdef WIN32
22 #include <string>
23 #include <windows.h>
24 #else
25
26
27 #include <errno.h>
28 #include <fcntl.h>
29 #include <math.h>
30 #include <netdb.h>
31 #include <pthread.h>
32 #include <stdio.h>
33 #include <stdlib.h>
34 #include <unistd.h>
35 #include <netinet/in.h>
36 #include <sys/ioctl.h>
37 #include <sys/mman.h>
38 #include <sys/socket.h>
39 #include <sys/stat.h>
40 #include <sys/types.h>
41 #include <sys/time.h>
42 #include <arpa/inet.h>
43 #include <sys/wait.h>
44 #include <strings.h>
45
46 #endif
47
48 #include <vrecko/IOPins.h>
49 #include <vrecko/Device.h>
50 #include <vrecko/EventDispatcher.h>
51
52 #include <osg/Vec3>
53 #include <osg/Vec4>
54 #include <osg/Matrix>
55 #include <osg/Quat>
56
57
58 #define BUFSIZE 1000
59
60
61 namespace vreckoDP_base {
62
63
64
65 class DP_EXPORT NestOfBirds : public vrecko::Device {
66 public:
67 NestOfBirds();
68 NestOfBirds(const char* _port_number);
69 ~NestOfBirds();
70
71 virtual int openDevice(void);
72 int closeDevice(void);
73
74 void update(void);
75
76 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
77 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
78
79 int getRotate(float *p_rotate);
80 osg::Vec3 &getRotate(void);
81 osg::Vec3 &getRotateA(void);
82 osg::Matrix &getRotateM(void);
83 osg::Quat &getRotateQ(void);
84 int getTranslate(float *p_trans);
85 osg::Vec3 &getTranslate(void);
86
87 void setInitialPosition(osg::Vec4 &_pos);
88 void setInitialRotation(osg::Vec4 &_rot);
89 void setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2);
90 void setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2);
91
92 void setOriginPosition(float _nx, float _ny, float _nz) {_origin_pos.set(_nx, _ny, _nz);}
93 osg::Vec3 getOriginPosition(void) {return _origin_pos;}
94 void setTranslateMapping(float _nx, float _ny, float _nz) {_trans_mapp.set(_nx, _ny, _nz);}
95 osg::Vec3 getTranslateMapping(void) {return _trans_mapp;}
96
97 protected:
98 std::string _hostname;
99 int scanDevice(void); // Vrati -1 pokud nastala chyba nebo momentalne zadna zprava neprisla
100 int _port; // �slo portu
101 char _buf[BUFSIZE]; // Pij�ac�buffer
102 #ifdef WIN32
103 WORD _wVersionRequested; // = MAKEWORD(1,1); // �slo verze
104 WSADATA _data; // Struktura s info. o knihovn� std::string _text; // Odes�an a pij�an text
105 hostent *_host; // Vzd�en po�ta�
106 sockaddr_in _serverSock; // Vzd�en "konec potrub�
107 sockaddr_in _other; // Odes�atel dat
108 SOCKET _mySocket; // Soket
109 int _addrlen; // D�ka adresy serveru
110 bool openSocket(void); //char *pcCommPort, HANDLE *temp_hCom);
111
112 #else
113 int sockfd;
114 struct sockaddr_in sockname;
115 bool openSocket(void); //char *_port_name, int *temp_port_fd);
116 #endif
117 int length;
118 bool scanDeviceX(void);
119
120
121 osg::Vec3 _translate[4], _ret_translate[4];
122 osg::Quat _rotate[4], _ret_rotate[4];
123
124 osg::Vec3 _origin_pos, _trans_mapp;
125
126 vrecko::EventDispatcher *pEventDispatcher;
127
128 DECLARE_OUTPUT(Position_sensor_0, vrecko::MessageVec3);
129 DECLARE_OUTPUT(Orientation_sensor_0, vrecko::MessageQuat);
130 DECLARE_OUTPUT(Position_sensor_1, vrecko::MessageVec3);
131 DECLARE_OUTPUT(Orientation_sensor_1, vrecko::MessageQuat);
132 DECLARE_OUTPUT(Position_sensor_2, vrecko::MessageVec3);
133 DECLARE_OUTPUT(Orientation_sensor_2, vrecko::MessageQuat);
134 DECLARE_OUTPUT(Position_sensor_3, vrecko::MessageVec3);
135 DECLARE_OUTPUT(Orientation_sensor_3, vrecko::MessageQuat);
136 };
137
138 }
139
140 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/NoPartitioning_Scene.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
NoPartitioning_Scene.h
Go to the documentation of this file.
1 #ifndef NOPARTITIONING_SCENE
2 #define NOPARTITIONING_SCENE
3
4 #include <vrecko/SP_SceneInterface.h>
5 #include <vrecko/Ability.h>
6 #include <vrecko/Scene.h>
7 #include <vrecko/Timer.h>
8
9 #include <vreckoAP/HUD/HUDDisplay.h>
10
11 using namespace vrecko;
12
13 namespace APSpacePartitioning {
14
15
16 #define SP_SCENE_INTERFACE_ID__NOPARTITIONING 1
17
26 class NoPartitioning_Scene: public SP_SceneInterface, public Ability {
27 public:
28 NoPartitioning_Scene();
29 ~NoPartitioning_Scene();
30
31 virtual void preInitialize(void);
32 virtual void update();
33 virtual bool performCompleteTest(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long limitToEO1, unsigned long limitToEO2);
34 virtual bool performUpdate(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long limitToEO1, unsigned long limitToEO2);
36 protected:
37
41 struct CollisionStructObject{
42 long objectID;
43 int voxelSize;
44 float boundingSphereRadius;
45 osg::Vec3f boundingSpherePosition;
46 osg::Vec3f position;
47 float timeDivision;
48 };
49
54 struct CollisionStruct{
55 long objectID;
56 int pointShellSize;
57 float boundingSphereRadius;
58 osg::Vec3f boundingSpherePosition;
59 osg::Vec3f position;
60 list<CollisionStructObject> collisionObjects;
61 };
62
63 CollisionStruct collisionField[20];
64 __int64 ctrTimeLast, ctrTimeNew, computeTimeLast,computeTimeNew, freq;
74 virtual bool findCollisionsWithObject(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long testedObject, unsigned long limitToEO2, float time, vrecko::Scene::EOIteratorHelper *iterator = NULL);
75 virtual bool singleCollisionTest(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long obj1ID, unsigned long obj2ID, float time);
76 virtual void fillCollisionLists(CollisionParams * params);
77 virtual inline bool isIntersection(osg::Vec3f pos1, osg::Vec3f pos2, float radius1, float radius2);
78 virtual inline void updateBoundingBox(osg::Node *pNode);
80 LARGE_INTEGER detectiontime1, detectiontime2, looptime1, looptime2, fr;
81 APHUD::HUDDisplay *hud;
82 bool hudInitialized ;
83 };
84
85 }
86
87
88
89 #endif
90
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/NullAttractor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
NullAttractor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Attractor.h"
4
5 namespace APDYNAMICART
6 {
7
8 class NullAttractor : public Attractor
9 {
10 public:
11 NullAttractor( Controller* controller );
12 virtual void compute();
13
14 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const { };
15
16 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode ) {}
17 };
18
19 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGCloudWrap.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
OSGCloudWrap.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_OSGCLOUDWRAP_H
10 #define _VRECKO_CLOUDS_OSGCLOUDWRAP_H
11
12 //#include <osg/Drawable>
13
14 #include "CloudsManager.h"
15
20 class CloudDataType : public osg::Referenced
21 {
22 private:
23 // Attributes storing information from the osg::Camera
24 osg::Vec3f cameraPos, cameraView, cameraUp;
25 public:
26
34 void setCameraData(const osg::Vec3f& cameraPos, const osg::Vec3f& cameraView, const osg::Vec3f& cameraUp)
35 {
36 this->cameraPos = cameraPos;
37 this->cameraView = cameraView;
38 this->cameraUp = cameraUp;
39 }
40
45 osg::Vec3f getCameraPos(void) { return osg::Vec3f(cameraPos.x(), cameraPos.y(), cameraPos.z()); }
50 osg::Vec3f getCameraView(void) { return osg::Vec3f(cameraView.x(), cameraView.y(), cameraView.z()); }
55 osg::Vec3f getCameraUp(void) { return osg::Vec3f(cameraUp.x(), cameraUp.y(), cameraUp.z()); }
56 };
57
63 struct AllCloudsUpdateCallBack : public osg::Camera::DrawCallback
64 {
65 // Attributes
66 osg::ref_ptr<CloudDataType> cloudData;
67
68 // Methods
69 AllCloudsUpdateCallBack() {}
70 AllCloudsUpdateCallBack(osg::ref_ptr<CloudDataType> data) : cloudData(data) {}
71 AllCloudsUpdateCallBack(const AllCloudsUpdateCallBack&, const osg::CopyOp&) {}
72
73 META_Object(osgCloud, AllCloudsUpdateCallBack)
74
75 virtual void operator() (const osg::Camera& camera) const
76 {
77 if(!cloudData.get())
78 {
79 std::cout << "AllCloudsUpdateCallback dynamic_cast error" << std::endl;
80 //exit(2);
81 return;
82 }
83
84 // Pass the current view matrix to the clouds
85 Cloud::SetViewMatrix(camera.getViewMatrix());
86
87 // Call cloud manager update
88 g_Clouds.Update(cloudData->getCameraPos(), cloudData->getCameraView(), cloudData->getCameraUp());
89 }
90 };
91
92 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/OSGskybox.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
OSGskybox.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_OSGSKYBOX_H
10 #define _VRECKO_CLOUDS_OSGSKYBOX_H
11
12 #include <osg/Billboard>
13
24 void CreateSkyBox(osg::ref_ptr<osg::Geode> skyboxGeode, long x, long y, long z, long width, long height, long length);
25
36 void CreateGround(osg::ref_ptr<osg::Geode> groundGeode, long x, long y, long z, long width, long length, long tileCount);
37
45 void CreateSun(osg::ref_ptr<osg::Billboard> sunBillBoard, int x, int y, int z);
46
47 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectAdd.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
ObjectAdd.h
Go to the documentation of this file.
1 #ifndef OBJECTADD_H
2 #define OBJECTADD_H
3
4 #include "../EditorController/ControllableAbility.h"
5
6 namespace APEditorQAbilities {
7 class ObjectAdd: public vrecko::ControllableAbility {
8 public:
9 ObjectAdd();
10 virtual ~ObjectAdd() { deactivate(); };
11
12 protected:
13 virtual void fillDefaultInfo();
14 virtual bool activate();
15 virtual void menuItemClicked(const char* itemID);
16
17 bool showMenuWithObjects(const char* pDirectory);
18 bool createNewObject(const char* pFileName);
19 };
20 }
21
22 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectDelete.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
ObjectDelete.h
Go to the documentation of this file.
1 #ifndef OBJECTDELETE_H
2 #define OBJECTDELETE_H
3
4 #include "../EditorController/ControllableAbility.h"
5
6 namespace APEditorQAbilities {
7 class ObjectDelete: public vrecko::ControllableAbility {
8 public:
9 ObjectDelete() : ControllableAbility("ObjectDelete") {};
10 virtual ~ObjectDelete() { deactivate(); };
11
12 protected:
13 virtual void fillDefaultInfo();
14 virtual bool activate();
15 virtual void menuItemClicked(const char* itemID);
16 };
17 }
18
19
20 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffect.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ObjectEffect.h
Go to the documentation of this file.
1 #ifndef OBJECTEFFECT_H
2 #define OBJECTEFFECT_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6 #include <osg/ShapeDrawable>
7 #include <helpers/DynamicArray.h>
8 #include <vrecko/SP_CommonDefs.h>
9
10 using namespace vrecko;
11
12 namespace APObjectUtils
13 {
14
15 class ObjectEffect: public Ability
16 {
17 public:
18
19 enum EffectType {
20 None,
21 // Nothing is displayed
22 BoundingSphere,
23 // Displays bounding sphere of the object
24 BoundingBox,
25 // Displays bounding box of the object
26 Transparency,
27 // Changes the object to be transparent. The transparency value is retrieved from alpha part of the [color]
28 // The COLOR values are IGNORED.
29 // Alternatively, you can use "Colorize", which includes the color values.
30 Colorize,
31 // Changes the object material to specified color.
32 // THIS INCLUDES TRANSPARENCY AS WELL.
33 // Alternatively, you can use "Transparency", which ignores the color values.
34 Collisions,
35 // Displays collision pairs.
36 // Requires that there is a collision detection registered
37 // in the Scene through Scene::addPartitioningSceneInterface().
38 // If also PartitioningObjectInterface was registered, it will be used automatically.
39 SphereBVH,
40 // Displays a layer of spher ebounding volumes. (The layer index can be changed.)
41 // REQUIRES that current object has either SphereBVH_Object_Data or SNCH_Object_Data ability
42 SNCH,
43 // Displays SNCH cones.
44 // REQUIRES that current object has either SNCH_Object_Data ability
45 SNCHFaceGroups,
46 VertexNormals,
47 // Displays vertex normals.
48 // REQUIRES that current object has either SphereBVH_Object_Data or SNCH_Object_Data ability
49 FaceNormals,
50 // Displays face normals.
51 // REQUIRES that current object has either SphereBVH_Object_Data or SNCH_Object_Data ability
52 TransparencyOnTop,
53 // Similar to "Transparency" effect, but this time the object is also rendered on top of other objects.
54 // The COLOR values are IGNORED.
55 // Alternatively, you can use "ColorizeOnTop", which includes the color values.
56 ColorizeOnTop,
57 // Similar to "Colorize", but object is rendered on top of other objects.
58 // THIS INCLUDES TRANSPARENCY AS WELL.
59 // Alternatively, you can use "TransparencyOnTop", which ignores the color values.
60 VoxelGrid,
61 // Visualize the voxel grid.
62 // REQUIRES that the owner object has the VoxelGrid_Object_Data ability
63 VoxelGridCollisions,
64 // Visualize the voxel grid.
65 // REQUIRES that the owner object has the VoxelGrid_Object_Data ability
66 PointShell,
67 // Visualize the point shell.
68 // REQUIRES that the owner object has the PointShell_Object_Data ability
69 DoubleSided,
70 // Turns on the double-sided rendering
71 PolygonNormals,
72 // displays the normals of faces
73 // require to Pointshell_Object_Data
74 };
75
76 ObjectEffect();
77 virtual ~ObjectEffect();
78
80 virtual void preInitialize();
82 virtual void postInitialize();
84 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
86 virtual void update();
88 // virtual void processEvent(const std::string &strInputName, void *pValue);
90 virtual void clean();
91
92 void setEffectType(EffectType newType);
93 EffectType getEffectType(void) { return effectType; }
94
95 bool isEffectCreated() { return bEffectCreated; }
96
97 protected:
98 EffectType effectType;
99
100 bool bEffectCreated;
101
102 int iDistanceFieldValue; // used for a DistanceField/Voxel Grid Show
103
104 osg::Vec4 color;
105 int iLevelMin, iLevelMax;
106 // used for SphereBVH/SNCH/PointShell: Min and Max level o hierarchy to display
107 // The level numbering starts from 0 (root, min. level).
108 // Either variable can be -1, which means the lowest (iLevelMin)
109 // or the highest (iLevelMax) level.
110 inline int getLevelMin() { return iLevelMin; }
111 inline int getLevelMax() { return iLevelMax; }
112 void setLevelMinMax(int newLevelMin, int newLevelMax);
113
114 float fRadius;
115 // used for PointShell: Point radius for visualization
116
117 bool bShowLeafInLevelNotReached;
118 // SphereBVH/SNCH: Render leaf nodes, if a level was selected, which has not been
119 // reached in the current subtree
120 bool bCollisions_NoCalculation;
121 // Collisions: Perform no calculations and only use the data that is
122 // available if anyone else is performing any calculations in the bakcground.
123
124 osg::ref_ptr<EnvironmentObject> graphicObject;
125 osg::ref_ptr<osg::Geode> osgGeode;
126 osg::ref_ptr<osg::MatrixTransform> osgTransform;
127 osg::ref_ptr<osg::Sphere> shapeSphere;
128 osg::ref_ptr<osg::Box> shapeBox;
129 osg::ref_ptr<osg::ShapeDrawable> shapeDraw;
130
131 std::vector<osg::ref_ptr<osg::ShapeDrawable>> shapeDrawables;
132
133 osg::ref_ptr<osg::StateSet> originalStateSet;
134 // StateSet of the owner object before the effect was applied.
135 // This StateSet will be restored when the effect is destroyed.
136
137 COLLISIONS_INFO_VECTOR *colInfo;
138 // For displaying colisions
139
140 void createEffect();
141 bool createEffect_SphereHierarchy_ProcessLevel(
142 vrecko::Ability *dataAbility, void *node, int iCurrentLevel);
143 // helper function for creating SphereBVH/SNCH hierarchy
144 bool createEffect_PointShellHierarchy_ProcessLevel( vrecko::Ability *dataAbility, void *node, int iCurrentLevel, bool draw);
145 // helper function for creating PointShell hierarchy
146 bool draw_Effect_PointShellHierarchy_Node(vrecko::Ability *dataAbility, void *node, int iCurrentLevel);
147 // draws Nodes from pointshell
148 bool createEffect_Lines(vrecko::Ability *dataAbility);
149 // For Collisions effect, the [dataAbility] is not used (might be NULL)
150 bool createEffect_Reconstruction(vrecko::Ability *dataAbility);
151 // For SNCHFaceGroups where original objects are recreated entirely from the SNCH_Object_Data ability
152 bool createEffect_VoxelGrid(vrecko::Ability *dataAbility);
153 // For the VoxelGrid effect
154 void destroyEffect();
155
156 void HSVtoRGB (float *r, float *g, float *b, float h, float s, float v);
157 // Ranges are from 0.0 to 1.0
158
159 DECLARE_INPUT(ShiftLevels, MessageInt);
160 };
161
162 }
163
164
165 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectEffectMan.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ObjectEffectMan.h
Go to the documentation of this file.
1 #ifndef OBJECTEFFECTMAN_H
2 #define OBJECTEFFECTMAN_H
3
4 #include <vrecko/Ability.h>
5 #include "ObjectEffect.h"
6
7 using namespace vrecko;
8
9 namespace APObjectUtils
10 {
11 class ObjectEffectMan: public Ability
12 {
13 public:
14
15 ObjectEffectMan();
16 virtual ~ObjectEffectMan();
17
19 virtual void preInitialize();
21 virtual void postInitialize();
23 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
25 virtual void update();
27 // virtual void processEvent(const std::string &strInputName, void *pValue);
29 virtual void clean();
30
31 void SetState(unsigned long newObjectID, bool bNewVisible);
32
33 protected:
34 EnvironmentObject *owner;
35
36 unsigned long objectID; // currently chosen object
37 bool bVisible; // should the effect be visible?
38 ObjectEffect *objectEffect;
39
40 // XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *effectParamNode;
41
42 std::string strObjectIDReq;
43
44 bool createObjectEffect(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pEffectParametersNode);
45 void deleteObjectEffect();
46
47 virtual int processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData);
48
49 DECLARE_INPUT(ObjectID, MessageObjectID);
50 DECLARE_INPUT(Visible, MessageBool);
51 };
52
53 }
54
55
56 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectInfo.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ObjectInfo.h
Go to the documentation of this file.
1 #ifndef OBJECTINFO_H
2 #define OBJECTINFO_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6
7
8 using namespace vrecko;
9
10
11 namespace APObjectUtils
12 {
13 class ObjectInfo: public Ability
14 {
15 public:
16 ObjectInfo();
17 virtual ~ObjectInfo();
18
19 virtual void preInitialize();
20 virtual void update();
21
22 protected:
23 EnvironmentObject *owner;
24 std::string strPositionEvent, strOrientationEvent;
25
26 DECLARE_OUTPUT(Position, MessageVec3);
27 DECLARE_OUTPUT(Orientation, MessageQuat);
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectModif.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ObjectModif.h
Go to the documentation of this file.
1 #ifndef OBJECTMODIF_H
2 #define OBJECTMODIF_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6
7
8 using namespace vrecko;
9
10
11 namespace APObjectUtils
12 {
13 class ObjectModif: public Ability
14 {
15 public:
16 ObjectModif();
17 virtual ~ObjectModif();
18
20 virtual void preInitialize();
22 virtual void postInitialize();
24 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
26 virtual void update();
28 // virtual void processEvent(const std::string &strInputName, void *pValue);
29
30 protected:
31 EnvironmentObject *owner;
32
33 EnvironmentObject* getSelectedObject();
34
35 DECLARE_INPUT(RandomColor, MessageBool);
36 DECLARE_REQUEST_OUTPUT(SelectionID, MessageVoid, MessageObjectID);
37 };
38 }
39
40 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/ObjectMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
ObjectMovement.h
Go to the documentation of this file.
1 #ifndef OBJECT_MOVEMENT_H
2 #define OBJECT_MOVEMENT_H
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/Ability.h>
7 #include <vrecko/EnvironmentObject.h>
8 #include <helpers/DynamicArray.h>
9 #include <osg/Group>
10 #include <osg/ShapeDrawable>
11 #include <osg/Geode>
12
13 using namespace vrecko;
14
15 namespace APEditorQAbilities {
16
17 class ObjectMovement: public ControllableAbility {
18 public:
19 ObjectMovement();
20 virtual ~ObjectMovement() {};
21
22 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
23
24 virtual void update(void);
25
26 protected:
27 virtual CAINFO* createInfo();
28 virtual void fillDefaultInfo();
29
30 bool bApplySnapping;
31 bool bIgnoreRotation;
32
33 virtual bool activate();
34 virtual void deactivate();
35
36 osg::Vec3 firstPointerPos; // pointer position when activated
37 osg::Quat firstPointerRot; // pointer rotation when activated
38
39 osg::Vec3 firstObjectPos; // object position when activated
40 osg::Quat firstObjectRot; // object rotation when activated
41
42 unsigned long movingObjectID; // If this is 0, the ability is not activated
43
44 bool bFirstUpdate;
45
46 class SnapBox {
47 public:
48 SnapBox() : color(0.0f, 1.0f, 0.0f, 0.4f) { owner = NULL; };
49 ~SnapBox() { Done(); };
50
51 void setOwner(ObjectMovement *_owner) { owner = _owner; }
52
53 void updateShape(const osg::Vec3 &center, const osg::Vec3 &halfLengths, const osg::Matrix &transform);
54 // set new dimensions and position.
55
56 bool show();
57 bool hide();
58
59 protected:
60 bool Init();
61 void Done();
62 osg::ref_ptr<EnvironmentObject> graphicObject;
63 osg::ref_ptr<osg::Geode> osgGeode;
64 osg::ref_ptr<osg::MatrixTransform> osgTransform;
65 osg::ref_ptr<osg::Box> shapeBox;
66 osg::ref_ptr<osg::ShapeDrawable> shapeDraw;
67
68 osg::Vec4 color;
69
70 ObjectMovement* owner;
71 };
72 DynamicArray<SnapBox> snapBoxes;
73 // A few boxes that are used to display active snapping planes.
74
75
76 bool objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans);
77 // FIRST PART of the tranformation calculations. From the pointer position/rotation the new object
78 // position/rotation is calculated. The matrix is only calculated and stored in [outTrans].
79 // The transformation will be applied afterwards, after another calculations or adjustments.
80 bool applySnapping(EnvironmentObject *eo, osg::Matrix *inoutTrans);
81 // Another PART of the transformation calculation. [inoutTrans] is already calculated.
82 // This method may adjust the transformtion matrix to snap the object to ... well, anything
83 // in considers good for a snap.
84 // The snapping options will be probably adjustable by the user in runtime.
85 // Returns "true" if any snapping occured.
86
87 enum CandidatePlaneType {
88 Other = 0,
89 // non-specified type
90 Horizontal_PrioritySnap,
91 // Horizontal plane with some nice properties.
92 // Usually something like:
93 // - on the upper side of the object used for snapping
94 // - located under the object to be snapped
95 };
96
97
98 struct CANDIDATEPLANE {
99 bool bIgnore;
100 // Don't consider this plane in further calculations.
101 // (Plane deletion would cause unnecessary memory movements.)
102
103 unsigned long objectID; // ID of the object this plane belongs to
104 unsigned long objectSide; // 0..5 - which side was used to generate this plane
105
106 osg::Vec3 center; // center of the plane
107 osg::Vec3 normal; // (normalized) normal pointing towards the original object center
108
109 osg::Vec3 halfRect1, halfRect2;
110 // Vectors that define box around the center point.
111 // The box equals to the bounding box of the object that "created" this plane
112
113 osg::Vec3 shiftVec;
114 float shiftLen2; // length squared (cached)
115
116 osg::Vec3 snapPoint; // snapping point
117 float hR1SnapMul, hR2SnapMul; // snapPoint = center + halfRect1 * hR1SnapMul + halfRect2 * hR2SnapMul
118
119 float fMinU, fMaxU, fMinV, fMaxV;
120
121 float fObjProjectionArea; // Size of the projected BBox of the object-to-be-snapped
122
123 CandidatePlaneType type;
124 };
125
126 //friend int planesCompare (const void * elem1, const void * elem2);
127 friend int planesCompare (const ObjectMovement::CANDIDATEPLANE * elem1, const ObjectMovement::CANDIDATEPLANE * elem2 );
128
129 osg::BoundingBox objAABox; // BB of the object-to-be-snapped
130 osg::Matrix objAABoxTrans; // and its transformation
131
132 osg::ref_ptr<EnvironmentObject> shadowObject;
133 // temporary object that is used to visualize an imaginary position (i.e. not-snapped)
134 Ability *objectEffect;
135 // An effect that is used on shadowObject
136
137
138 DynamicArray<CANDIDATEPLANE> planes;
139 DynamicArray<DWORD> selectedPlanes; // the actually selected snapping planes
140
141
142 bool addSnappingPlane(
143 unsigned long objectID, unsigned long objectSide,
144 osg::Vec3 &center, osg::Vec3 &normal,
145 osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 shiftVec, float shiftLen2, osg::Vec3 &snapPoint,
146 float halfRect1SnapMul, float halfRect2SnapMul,
147 float fMinU, float fMaxU, float fMinV, float fMaxV,
148 CandidatePlaneType type);
149 bool isPlaneCompatibleWithSelectedSet(int iPlaneIndex);
150 // Is the "plane[iPlaneIndex]" plane compatible with the previously selected ones?
151 // I.e. the object can be snapped to all of them <=> they are not coplanar etc.
152 // Note that plane with the [iPlaneIndex] is not compatible if it was already selected.
153 bool calcFinalShiftFromSelectedSet(osg::Vec3 &outShift, int additionalPlane = -1);
154 // From the set of selected planes calculates the final shift of the object.
155 // Returns false if the intersection of the planes is too far.
156 // You can specify additional plane in [addionalPlane] (index to [planes]; -1 for no plane)
157 bool intersect2Planes(osg::Vec3 &p1p, osg::Vec3 &p1normal, osg::Vec3 &p2p, osg::Vec3 &p2normal,
158 osg::Vec3 &outLineStart, osg::Vec3 &outLineDir);
159 // the 3D intersect of two planes
160 // Input: two planes [p1p + p1normal] and [p2p + p2normal]
161 // Output: the intersection line (when it exists)
162 // Return: true = everything ok
163 // false = the planes are parallel (either no intersection or the whole plane)
164 bool intersectLinePlane(osg::Vec3 &lineStart, osg::Vec3 &lineDir, osg::Vec3 &planePoint,
165 osg::Vec3 &planeNormal, osg::Vec3 &outPoint);
166 // Intersection of a line and a plane.
167 // If "true" is returned [outPoint] will hold the intersection point.
168 bool projectPointOnPlaneUV(osg::Vec3 &point, osg::Vec3 &planePoint, osg::Vec3 &planeNormal,
169 osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 *outProjectedPoint,
170 float *outDist, float *outU, float *outV);
171 // The plane is defined by [planePoint + planeNormal], the [halfVec1] and [halfVec2]
172 // are perpendicular vectors in this plane.
173 // Output is:
174 // [outProjectedPoint], [outDist], [outU], [outV]
175 // Where this should hold true:
176 // outProjectedPoint = planePoint + halfVec1 * outU + halfVec2 * outV
177 //
178 // Any of the output pointers can be NULL in case the caller doesn't need that value.
179 // Optimization hint: If you don't need [outU] and [outV] then set them to NULL
180 // to omit those calculations entirely and increase speed significantly.
181 };
182
183
184 }
185
186
187 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/ObjectSelector.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
ObjectSelector.h
Go to the documentation of this file.
1 #ifndef OBJECTSELECTOR_H
2 #define OBJECTSELECTOR_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6 #include "ObjectEffect.h"
7 #include <helpers/DynamicArray.h>
8
9 using namespace vrecko;
10
11 namespace APObjectUtils
12 {
13 class ObjectSelector: public Ability
14 {
15 public:
16 ObjectSelector();
17 virtual ~ObjectSelector();
18
20 virtual void preInitialize();
22 virtual void postInitialize();
24 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
26 virtual void update();
28 // virtual void processEvent(const std::string &strInputName, void *pValue);
29
30 // virtual void *processRequest(const std::string&, void *);
31
32 protected:
33 EnvironmentObject *owner;
34 // std::string strSelectionIDEvent;
35
36 ObjectEffect *objectEffect;
37
38 osg::Vec3 lastPosition, lastSelTest;
39
40 unsigned long selObjectID;
41 DynamicArray<int> intersectedObjects;
42
43 void resolveSelection();
44 EnvironmentObject* resolveIntersections(osg::Vec3 &position, std::vector<osg::Node*> *nodePath = NULL);
45 // [nodePath] can be NULL if not necessary.
46
47 DECLARE_INPUT(PointerPosition, MessageVec3);
48 DECLARE_OUTPUT(SelectionID, MessageObjectID);
49 DECLARE_REQUEST_INPUT(SelectionID, MessageVoid, MessageObjectID);
50 DECLARE_REQUEST_INPUT(SelectionByPointerPos, MessageVec3, MessageObjectID);
51 DECLARE_REQUEST_INPUT(SelectionByPointerPos_Path, MessageVec3, MessageNodeList);
52 };
53
54 }
55
56
57 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Observer.h Source File

  • File List
  • File Members
  • include
  • vreckoUtils
Observer.h
Go to the documentation of this file.
1 #pragma once
2 #include "Export"
3 #include <vector>
4 #include <algorithm>
5
6 namespace vreckoUtils
7 {
8
10 class Observable;
11
12 class VRECKO_UTILS_EXPORT Observer
13 {
14 public:
15 virtual void notify(Observable* object, void* userData) = 0;
16 protected:
17 Observer() {};
18 };
19
20 class VRECKO_UTILS_EXPORT Observable
21 {
22 public:
23 void addObserver(Observer* observer) {
24 _observers.push_back(observer);
25 }
26 void removeObserver(Observer* observer) {
27 auto it = std::find(_observers.begin(), _observers.end(), observer);
28 if(it != _observers.end()) _observers.erase(it);
29 }
30 void notifyObservers(void* userData = NULL) {
31 for(auto it = _observers.begin(); it != _observers.end(); ++it)
32 (*it)->notify(this, userData);
33 }
34
35 protected:
36 Observable() {};
37 std::vector<Observer*> _observers;
38 };
39
40 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/OctTree.h Source File

  • File List
  • File Members
  • include
  • vrecko
OctTree.h
Go to the documentation of this file.
1 /***************************************************************************
2 octtree.h - description
3 -------------------
4 begin : Jun 2002
5 copyright : (C) 2002 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9
10 #ifndef OCTTREE_H
11 #define OCTTREE_H
12
13 #include <vrecko/BaseClass.h>
14 #include <vrecko/EnvironmentObject.h>
15
16 namespace vrecko {
17
18
19 class VRECKO_EXPORT OctTree: public BaseClass {
20 public:
21 OctTree();
22 OctTree(double _new_cell_size, double _new_space_size);
23 ~OctTree();
24
25 void addObject(EnvironmentObject *_object);
26 void removeObject(EnvironmentObject *_object);
27 EnvironmentObject **getObjectNeighbourhood(EnvironmentObject *_object, int &_object_count);
28 void objectChanged(EnvironmentObject *_object);
29
30 /* typedef struct OctTreeNode;
31 typedef struct {
32 OctTreeNode *parent_node;
33 EnvironmentObject **objects_in_cell;
34 long int object_count;
35 osg::Vec3 position;
36 } OctTreeCell;
37 */
38 typedef struct OctTreeNode{
39 OctTreeNode *parent_node;
40 OctTreeNode *(child_nodes[8]);
41 //OctTreeCell *(cell_nodes[8]);
42 double subspace_size;
43 osg::Vec3 position;
44 long int object_count;
45 EnvironmentObject **objects_in_cell;
46 bool isCell;
47 };
48
49 protected:
50 double cell_size;
51 double space_size;
52 OctTreeNode *root_node;
53
54 OctTreeNode *addToNode(int _node_id, OctTreeNode *_parent, EnvironmentObject *_object);
55 OctTreeNode *addToCell(int _node_id, OctTreeNode *_parent, EnvironmentObject *_object);
56 void delFromNode(OctTreeNode *_node, EnvironmentObject *_object);
57
59 void delFromCell(OctTreeNode *_node, EnvironmentObject *_object);
60
61 bool isObjectInNode(OctTreeNode *_node, EnvironmentObject *_object);
62 bool isObjectInCell(OctTreeNode *_node, EnvironmentObject *_object);
63 OctTreeNode *findObject(EnvironmentObject *_object);
64 OctTreeNode *findObjectInNode(int _node_id, OctTreeNode *_node, EnvironmentObject *_object);
65 };
66
67 }
68
69 #endif
70
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/OptiTrack.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
OptiTrack.h
Go to the documentation of this file.
1 #ifndef OPTITRACK_H
2 #define OPTITRACK_H
3
4 #ifdef WIN32
5 #include <string>
6 #include <windows.h>
7 #endif
8
9 #include <vrecko/IOPins.h>
10 #include <vrecko/Device.h>
11 #include <vrecko/EventDispatcher.h>
12
13 #include <osg/Vec3>
14 #include <osg/Vec4>
15 #include <osg/Matrix>
16 #include <osg/Quat>
17
18 #include "vrpn_Connection.h" // Missing this file? Get the latest VRPN distro at
19 #include "vrpn_Tracker.h" // ftp://ftp.cs.unc.edu/pub/packages/GRIP/vrpn
20
21 #define TRACKER_MAX_COUNT 12
22
23 namespace vreckoDP_base {
24
25 class DP_EXPORT OptiTrack : public vrecko::Device {
26 public:
27 OptiTrack();
28 OptiTrack(const char* _port_number);
29 ~OptiTrack();
30
31 virtual int openDevice(void);
32 int closeDevice(void);
33
34 void preInitialize();
35 void postInitialize();
36 //void processEvent(const std::string &input_name, void *value);
37
38 void update(void);
39
40 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
41 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
42
43 void sendEvent(int sid, osg::Vec3 *p, osg::Quat *o);
44
45 inline float getSensorScale() { return sensorScale; }
46 inline osg::Vec3* getOriginPosition() { return &_origin_pos; }
47 inline osg::Vec3* getTranslateMapping() { return &_trans_mapp; }
48
49 typedef struct {
50 int T_ID;
51 OptiTrack *pOT;
52 } info_struct;
53
54 protected:
55 std::string _hostname;
56 int _port;
57 vrpn_Connection *connection;
58 char connectionName[128];
59 vrpn_Tracker_Remote *tracker[TRACKER_MAX_COUNT];
60 info_struct *is[TRACKER_MAX_COUNT];
61
62 //void VRPN_CALLBACK handle_tracker0(void *, const vrpn_TRACKERCB t);
63
64 osg::Vec3 _origin_pos, _trans_mapp;
65 float sensorScale;
66 unsigned int sensor_count;
67 bool deprecated_version;
68 std::string server_address;
69
70 vrecko::EventDispatcher *pEventDispatcher;
71
72 void addSensor(int i);
73
74 DECLARE_INPUT(SetSensorCount, vrecko::MessageInt);
75 DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation);
76 };
77
78 }
79
80 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Optimalizer.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Optimalizer.h
Go to the documentation of this file.
1 #ifndef OPTIMALIZER_H
2 #define OPTIMALIZER_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include "functions.h"
6
7
8 using namespace vrecko;
9
10 namespace APConnectEditor {
11
12
13 class Optimalizer: public ControllableAbility {
14 public:
15 Optimalizer();
16 virtual ~Optimalizer() { deactivate(); }
17
18
19
20 protected:
21 unsigned long targetID, sourceID;
22
23 vrecko::EnvironmentObject *_source, *_target;
24
25
26 virtual void fillDefaultInfo();
27 virtual bool activate();
28 virtual void deactivate();
29 virtual void processButtonRelease(vrecko::CABUTTONEVENT* eventData); //call method - snap || merge || ...
30 //virtual void menuItemClicked(const char* itemID);
31
32 bool optimalizeAndSave(); //optimalize object and save it in current file
33
34 //get geometry of object and call optimalize geometry
35 void optimalizeObject(EnvironmentObject* eo);
36
37 //remove unused vertices and delete duplicit vertices
38 void optimalizeGeometry(osg::Geometry* geometry);
39
40 };
41
42 }
43
44 #endif //OPTIMALIZER_H
45
46
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/OrdinaryAttractor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
OrdinaryAttractor.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Attractor.h"
4 #include "ComputeStrategy.h"
5 #include "Utils.h"
6 #include "ComputeThread.h"
7
8 namespace APDYNAMICART
9 {
10
11 class OrdinaryAttractor : public Attractor
12 {
13 IComputeStrategyPtr _strategy;
14 int _settleIterations;
15 Limits _lim;
16 int _iterationCount;
17 AttractorRenderingType _renderingType;
18 ComputeThreadPtr _thread;
19 GeometryPtr _geometry;
20 GeodePtr _bbGeode;
21 int _interpolationSteps;
22 bool _randomRun;
23 osg::Vec4 _color;
24 osg::ref_ptr<osg::Material> _material;
25
26 public:
27
29 OrdinaryAttractor(IComputeStrategyPtr computeStrategy, IParametersPtr parameters, Controller* controller);
30
31 bool colorChanged( const char* sliderID, float sliderPos );
32
33 virtual void compute();
34
35 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
36
37 int getIterationCount();
38
39 virtual void GUIItemClicked( const char* itemID );
40
41 virtual void GUISliderChanged( const char* sliderID, float sliderPos );
42
43 virtual void init();
44
45 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
46
47 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
48
49 virtual void update();
50
51
52
53 private:
55 void updateGeometry();
56 void switchTransparency();
57 void switchUpdating();
58 void setRenderingType( AttractorRenderingType renderingType );
59 void setTransparency(osg::StateSet* stateSet, bool enable);
60 void createDrawableObject();
61 //void drawSpheres();
62 void createOrUpdateBoundingBox( const Limits& lim );
63 osg::PrimitiveSet* createPrimitiveSet( int size );
64 IMenuComponentPtr createViewSubMenu() const;
65 IMenuComponentPtr createIterationSubMenu() const;
66 IMenuComponentPtr createColorSubMenu() const;
67 };
68
69 inline void OrdinaryAttractor::setRenderingType( AttractorRenderingType renderingType )
70 {
71 _renderingType = renderingType;
72 generate();
73 }
74
75 inline int OrdinaryAttractor::getIterationCount()
76 {
77 return _iterationCount;
78 }
79
80 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/PHANToM/PHANToM_Device.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • PHANToM
PHANToM_Device.h
Go to the documentation of this file.
1 #ifndef PHANTOM_H
2 #define PHANTOM_H
3
4
5 #ifndef COMPILE_PHANTOM_DEVICE
6 #include "PHANToM_compile.inc"
7 #endif
8
9
10 #ifdef COMPILE_PHANTOM_DEVICE
11
12 #include <vrecko/IOPins.h>
13 #include <vrecko/Ability.h>
14 #include <vrecko/Device.h>
15 #include <vrecko/EventDispatcher.h>
16 #include <vrecko/MTLock.h>
17 #include <helpers/DynamicArray.h>
18
19 #include <HD/hd.h>
20 #include <HDU/hduVector.h>
21 #include <HDU/hduError.h>
22
23 #include <osg/Matrix>
24
25 namespace vreckoDP_PHANToM {
26
27 class DP_EXPORT PHANToMFilter;
28
29 typedef struct {
30 osg::Vec3 position;
31 osg::Matrix orientation;
32 osg::Vec3 velocity;
33 osg::Vec3 acceleration;
34 HDint nCurrentButtons;
35 HDint nLastButtons;
36
37 // If Phantom is relative to the camera, then the following variables hold different values than the [position] and [orientation]
38 // (the untransformed ones)
39 osg::Vec3 absolutePosition;
40 osg::Matrix absoluteOrientation;
41 } PHANToMSTATE;
42
43
44 struct PHANTOM_HELD_OBJECT {
45 unsigned long objectID;
46 osg::Matrix transform; // sub-transform of this particular object from the center of gravity/rotation (of the whole group of held objects)
47
48 PHANTOM_HELD_OBJECT & operator= (const PHANTOM_HELD_OBJECT & other) {
49 objectID = other.objectID;
50 transform = other.transform;
51 return *this;
52 }
53
54 };
55
56 typedef DynamicArray<PHANTOM_HELD_OBJECT> PHANTOM_HELD_OBJECTS_ARRAY;
57
58
59 class DP_EXPORT PHANToM : public vrecko::Device {
60 public:
61 PHANToM(void);
62 // PHANToM(int freq);
63 ~PHANToM();
64
65 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *);
66
67 virtual void preInitialize(void);
68 virtual void postInitialize(void);
69
70 void processEvent(const std::string &input_name, void *value);
71
72 virtual int openDevice(void);
73 int closeDevice(void);
74 int calibrateDevice(void);
75
76 void update(void);
77
78 // filters
79 void addFilter(PHANToMFilter* newFilter);
80 // filter is added to the correct position using its priority.
81 // If there is already a filter with the same priority, it will be added after that.
82
83 void removeFilter(unsigned int);
84 void removeFilter(PHANToMFilter*);
85 // std::vector<PHANToMFilter*> &getAdditionalFilterVector(void) {return filter;}
86 void applyFilters(PHANToMSTATE &pState, osg::Vec3 &temp_force, osg::Vec3 &temp_torque);
87
88 void resetFilters(void);
89 // All filter will return to the initial state - useful for example after grabbing a new object
90 // WARNING: The caller must acquire call acquireMainLock()/releaseMainLock() (i.e. filters don't have to - it's already done)
91
92 bool isForceApplied() { return !bDontApplyForce; }
93
94 inline void acquireMainLock() { filterVectorLock.lock(); }
95 inline void releaseMainLock() { filterVectorLock.unlock(); }
96
97 void setHeldObjects(PHANTOM_HELD_OBJECTS_ARRAY * newHeldObjects);
98 // [newHeldObjects] might be NULL, the object list is copied, so the caller may deallocate the memory.
99 // WARNING: Whoever calls this must also call acquireMainLock()/releaseMainLock(),
100 // i.e. filters doesn't need to lock it, but callers from outside the Phantom thread MUST OBTAIN THE LOCK !
101 // WARNING 2: Inside the lock, the resetFilters() SHOULD ALSO BE CALLED !
102
103 PHANTOM_HELD_OBJECTS_ARRAY * getHeldObjects(bool *bIsDefault = NULL);
104 // WARNING: Whoever calls this must also call acquireMainLock()/releaseMainLock(),
105 // i.e. filters doesn't need to lock it, but callers from outside the Phantom thread MUST OBTAIN THE LOCK
106 // WARNING 2: Only the pointer is returned, so you have to process the returned information (or copy it elsewhere)
107 // BEFORE releasing the lock.
108 // if [bIsDefault] is not NULL, it will receive whether the returned array are the default held objects or not.
109
110 inline PHANTOM_HELD_OBJECTS_ARRAY * getDefaultHeldObjects(void) { return &defaultHeldObjects; }
111 // And again:
112 // WARNING: Whoever calls this must also call acquireMainLock()/releaseMainLock(),
113 // i.e. filters doesn't need to lock it, but callers from outside the Phantom thread MUST OBTAIN THE LOCK
114 // WARNING 2: Only the pointer is returned, so you have to process the returned information (or copy it elsewhere)
115 // BEFORE releasing the lock.
116
117 // For shared use in filters, should be used after setting/getting the held objects
118 // inside the same acquireMainLock()/releaseMainLock() sequence
119 inline const osg::Matrix &getHeldObjectsTransform() const { return heldObjectsTransform; }
120 inline void setHeldObjectsTransform(osg::Matrix const &newTransform) { heldObjectsTransform = newTransform; }
121 // The transformation should not include the scaling, just rotation and translation
122
123 void setLastPhantomTrans(osg::Matrix &newMat);
124 // Set the last phantom transformation.
125 // For use in methods outside of this class. Will use the [lastPhantomTransLock] automatically.
126 void getLastPhantomTrans(osg::Matrix *outMat);
127 // Get the last phantom transformation.
128 // For use in methods outside of this class. Will use the [lastPhantomTransLock] automatically.
129
130
131 void setCollisionOccurred(bool bNewValue) { bCollisionOccurred = bNewValue; }
132 bool getCollisionOccurred() { return bCollisionOccurred; }
133
134
135 float workspace_scale;
136 bool bRelativeToCamera;
137 float fCameraOffset;
138 bool bVisualizeAxes; // requires objects with IDs 999804, 999805 and 999806
139
140 vrecko::MTLock avatarDataLock;
141 bool avatarPosModifiedByUs; // [avatarDataLock] must be used before accessing the variable
142 // were the variables below modified by this class or Phantom filters?
143 // i.e. should we set the avatar pos on the next update instead of reading it.
144 osg::Vec3 avatarPos; // [avatarDataLock] must be used before accessing the variable
145 osg::Vec3 avatarLookAt; // normalized. [avatarDataLock] must be used before accessing the variable
146 osg::Vec3 avatarUp; // normalized. [avatarDataLock] must be used before accessing the variable
147
148 bool bInitializeHeldObjectsTransform;
149 // Initial condition, because the Device is created BEFORE the Scene creation.
150 // Therefore the objects' transformations have to be queried in the first update() or similarly.
151
152 bool stopMotion(bool state);
153 bool bStopMotion;
154
155 protected:
156 HHD hHD;
157 HDSchedulerHandle hHSCallback;
158 osg::Vec3 position, velocity;
159 osg::Matrix orientation, transform;
160 bool button_state;
161 vrecko::EventDispatcher *pEventDispatcher;
162 bool last_button_state;
163
164 bool bDeviceOpened;
165
166 bool bDontApplyForce;
167 // A "debug" switch to disable the force.
168 // The force is still calculated, but the results are thrown away.
169
170 // additional filters
171 std::vector<PHANToMFilter*> filters;
172 vrecko::MTLock filterVectorLock;
173
174 osg::Matrix heldObjectsTransform;
175 // The transformation should not include the scaling, just rotation and translation
176 PHANTOM_HELD_OBJECTS_ARRAY heldObjects;
177 PHANTOM_HELD_OBJECTS_ARRAY defaultHeldObjects;
178 // (Operated by setHeldObjects()/getHeldObjects())
179 // The list of objects which the user holds in their hand AND
180 // the list of objects which are used as a backup when the user "doesn't hold" anything (so typically we can display a hand)
181
182
183 bool bCollisionOccurred; // has collision occurred _in this frame_
184
185
186 vrecko::MTLock lastPhantomTransLock;
187 osg::Matrix lastPhantomTrans;
188 // Last phantom transformation, use the [lastPhantomTransLock] for access or getLastPhantomTrans() method.
189 // For use in the methods outside this class, filters receive the position/rotation automatically.
190
191
192 void readHeldObjectsFromXML( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * tmpNode, PHANTOM_HELD_OBJECTS_ARRAY* defaultHeldObjects );
193
194 virtual int processNotification(BaseClass *sender, unsigned long notificationType,
195 void *notificationData);
196
197 DECLARE_OUTPUT(Position, vrecko::MessageVec3);
198 DECLARE_OUTPUT(Orientation, vrecko::MessageQuat);
199 DECLARE_OUTPUT(Button, vrecko::MessageBool);
200 };
201
202
203 class DP_EXPORT PHANToMFilter : public vrecko::Ability {
204 public:
205 PHANToMFilter(const char* abName) : Ability(abName), filter_enabled(true), bIsAfterReset(true), bActiveAfterReset(true), resetTime(0) {};
206 //~PHANToMFilter() {}; -> no default constructor -> force to name the Ability
207
208 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque) {};
209
210 void enableFilter(void) {filter_enabled = true;}
211 void disableFilter(void) {filter_enabled = false;}
212 bool isFilterEnabled(void) {return filter_enabled;}
213
214 inline bool isAfterReset(void) { return bIsAfterReset; }
215 inline void setIsAfterReset(bool bNewAfterReset) { bIsAfterReset = bNewAfterReset; if (bNewAfterReset) { resetTime = osg::Timer::instance()->tick(); } }
216 inline osg::Timer_t getResetTime() { return resetTime; }
217
218 inline bool isActiveFirstTime() { return bActiveAfterReset; }
219 inline void setActiveAfterReset(bool bNewActiveAfterReset) { bActiveAfterReset = bNewActiveAfterReset; }
220
221 // inline int getFilterPriority() { return iFilterPriority; }
222 // void setFilterPriorty(int newPriority) { iFilterPriority = newPriority; } // Note: This will NOT reorder the filters (i.e. it must be done before adding the filter to the phantom filter "stack")
223
224 protected:
225 bool filter_enabled;
226 bool bIsAfterReset;
227 // Is this the FIRST time the filter would be applied (if the [bActiveAfterReset] is "true")?
228 // (Managed automatically by the PHANToM device plugin through our setIsAfterReset() method.)
229 // Use isAfterReset() to get the value.
230 bool bActiveAfterReset;
231 // Is the filter executed in the first run?
232 // (Managed automatically by the PHANToM device plugin through our setActiveAfterReset() method.)
233 // Use isActiveFirstTime() to get the value.
234 osg::Timer_t resetTime;
235 // int iFilterPriority;
236 // The default priority is 0.
237 };
238
239 }
240
241 #endif //COMPILE_PHANTOM_DEVICE
242
243 #endif //PHANTOM_H
244
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHANToMAvatar.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
PHANToMAvatar.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 using namespace vrecko;
4 using namespace vreckoDP_base;
5
6 class PHANToMAvatar: public Ability {
7 public:
8 PHANToMAvatar();
9 ~PHANToMAvatar() {};
10
11 // ------ BaseClass functions ------------------------
13 void processEvent(const std::string &input_name, void *value);
14 // ---------------------------------------------------
15
16 void preInitialize(void);
17 void postInitialize(void);
18 void update(void);
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
21 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
22
23 protected:
24 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/PHEffect.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
PHEffect.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4 using namespace vrecko;
5 using namespace vreckoDP_base;
6
7 class PHEffect: public Ability {
8 public:
9 PHEffect();
10 ~PHEffect() {};
11
12 // ------ BaseClass functions ------------------------
14 void processEvent(const std::string &input_name, void *value);
15 // ---------------------------------------------------
16
17 void preInitialize(void);
18 void postInitialize(void);
19 void update(void);
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 protected:
25 PHANToM *PHANToMDevice;
26 bool all_on;
27 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Component.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_Component.h
Go to the documentation of this file.
1
8 #pragma once
9 #include "PS_FlatShape.h"
10
11 namespace APDYNAMICART
12 {
13
14 class PS_Component : public PS_FlatShape
15 {
16 public:
17 PS_Component();
18
19 };
20
21 typedef osg::ref_ptr<PS_Component> PS_ComponentPtr;
22
23 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Face.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_Face.h
Go to the documentation of this file.
1
8 #pragma once
9 #include "PS_FlatShape.h"
10 #include <vreckoUtils\HighlightCallback.h>
11 #include "Utils.h"
12
13 namespace APDYNAMICART
14 {
15
16 class PS_Face : public PS_FlatShape
17 {
18 public:
19 PS_Face(osg::ref_ptr<osg::Vec3Array> vertices);
20 void updateColors(osg::Vec4 color);
21
22 void pointed( bool pointed ) { dbgPS(__FUNCTION__); /*_highlight->setHighlighting(pointed); */ }
23
24
25 protected:
26 osg::ref_ptr<osg::Vec3Array> _vertices;
27
28 osg::ref_ptr<osg::Geometry> _geometry;
29
30 osg::ref_ptr<vreckoUtils::HighlightCallback> _highlight;
31 };
32
33 typedef osg::ref_ptr<PS_Face> PS_FacePtr;
34
35 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FacePlane.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_FacePlane.h
Go to the documentation of this file.
1
8 #pragma once
9 #include "PS_Face.h"
10
11 namespace APDYNAMICART
12 {
13
14 class PS_FacePlane : public EnvironmentObject
15 {
16 public:
17 PS_FacePlane(double distance, osg::Quat rot);
18 void pointed();
19 void setFace( PS_FacePtr face );
20
21
22 private:
23 bool _active;
24
25 PS_FacePtr _face;
26 osg::Vec3 _position;
27 osg::Quat _orientation;
28
29 };
30
31 typedef osg::ref_ptr<PS_FacePlane> PS_FacePlanePtr;
32
33 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_FlatShape.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_FlatShape.h
Go to the documentation of this file.
1
8 #pragma once
9
10 namespace APDYNAMICART
11 {
12
13 class PS_FlatShape : public osg::Geode
14 {
15 public:
16
17
18 private:
19
20
21 };
22
23 typedef osg::ref_ptr<PS_FlatShape> PS_FlatShapePtr;
24
25 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Layer.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_Layer.h
Go to the documentation of this file.
1
8 #pragma once
9 #include "PS_Polyhedron.h"
10 #include "PS_Component.h"
11
12 namespace APDYNAMICART
13 {
14
15 class PS_Layer : public osg::Referenced
16 {
17 public:
18 PS_Layer(osg::Group* group, const std::string& polyhedronName);
19
20 void activate();
21
22 void deactivate();
23
24 double getOpacity() const { return _opacity; }
25
26 void setOpacity(double val) { _opacity = val; }
27
28
29 protected:
30
32 double _opacity;
33
35 PS_PolyhedronPtr _polyhedron;
36
38 PS_ComponentPtr _component;
39
40 osg::ref_ptr<osg::MatrixTransform> _visuals;
41
42 };
43
44 typedef osg::ref_ptr<PS_Layer> PS_LayerPtr;
45
46 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Polyhedron.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_Polyhedron.h
Go to the documentation of this file.
1
8 #pragma once
9
10 #include <vreckoAP\DynamicArt\Utils.h>
11 #include "PS_FacePlane.h"
12 #include "PS_Face.h"
13 #include "PS_Component.h"
14 #include "PS_Symmetry.h"
15
16 namespace APDYNAMICART
17 {
18
19 class PS_Polyhedron : public osg::Referenced
20 {
21 public:
22 PS_Polyhedron(const string& name);
23
24 int initialize(std::string name, osg::ref_ptr<osg::MatrixTransform> layerNode);
25
26 //load symmetries and face of polyhedron from XML files
27 int loadfromXML( std::string fileName );
28
29 void createFacePlanes();
30 void setComponent( PS_ComponentPtr compo );
31 private:
32
33 // pointer to parent scene graph node
34 osg::ref_ptr<osg::MatrixTransform> _layerNode;
35
36 // pointer to face definition
37 PS_FacePtr _face;
38
39 // pointer to component definition - probably not needed at all, just for convinient
40 PS_ComponentPtr _component;
41
42 // list of all face planes
43 std::vector<PS_FacePlanePtr> _facePlanes;
44
45 // structure holding all symmetries of polyhedron
46 PS_Symmetry* _poly_symmetry;
47
48 // distance of face-planes from center of polyhedron
49 double _facePlaneDistance;
50
51
52 };
53
54 typedef osg::ref_ptr<PS_Polyhedron> PS_PolyhedronPtr;
55
56
57
58
59
60
61
62
64 class PolyhedronFactory
65 {
66 public:
67 static std::vector<std::string> getAvaiablePolyhedronNames()
68 {
69 std::vector<std::string> polyhedronNames;
70 polyhedronNames.push_back("Tetrahedron");
71 polyhedronNames.push_back("Hexahedron");
72 polyhedronNames.push_back("Dodecahedron");
73 return polyhedronNames;
74 }
75
76 static PS_PolyhedronPtr getPolyhedron(const std::string& name)
77 {
78 dbgPS(__FUNCTION__);
79
80 if (isValidName(name))
81 {
82 return new PS_Polyhedron(name);
83 }
84 else
85 {
86 err("Polyhedron: '" << name << " is not defined.");
87 return NULL;
88 }
89 }
90
91 static bool isValidName(const std::string& name)
92 {
93 std::vector<std::string> names = getAvaiablePolyhedronNames();
94 for (u_int i = 0; i < names.size(); ++i)
95 {
96 if (names.at(i) == name)
97 {
98 return true;
99 }
100 }
101
102 return false;
103 }
104 };
105 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_Symmetry.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_Symmetry.h
Go to the documentation of this file.
1
8 #pragma once
9
10
11 #include <osg/Geometry>
12
13 #include <xercesc/parsers/XercesDOMParser.hpp>
14 #include <xercesc/dom/DOM.hpp>
15 #include <xercesc/sax/HandlerBase.hpp>
16 #include <xercesc/util/XMLString.hpp>
17 #include <xercesc/util/PlatformUtils.hpp>
18
19 #include <xercesc/dom/DOMWriter.hpp>
20 #include <xercesc/framework/StdOutFormatTarget.hpp>
21 #include <xercesc/framework/LocalFileFormatTarget.hpp>
22
23 #include <fstream>
24
25 XERCES_CPP_NAMESPACE_USE
26
27 namespace APDYNAMICART
28 {
29
30
31 struct symmetry_axis
32 {
33 int order;
34 osg::Vec3 point;
35 };
36
37 struct symmetry_pair
38 {
39 int face; //index of face
40 int axis; //axis of axis
41 };
42
43
44 class PS_Symmetry {
45
46 public:
47
49 void makeInstances(std::vector<osg::Vec3>* points);
50
52 std::vector<osg::Quat>* makeRotations();
53
54
55 //load symmetry template from file
56 int load(std::string fileName);
57
58 int getNumberofFaces() {return n_faces;}
59
60 std::vector<symmetry_axis *>* getAxes() {return axes;}
61
62
63 private:
64 std::vector<symmetry_axis *>* axes;
65 std::vector<symmetry_pair *>* pairs;
66 int n_faces; //number of faces created by symmetries
67
68
69 //load all axes of given symmetry group
70 int loadAxes(std::string fileName);
71
72
73 };
74
75
76
77 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PS_emptyClass.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PS_emptyClass.h
Go to the documentation of this file.
1
8 #pragma once
9
10 namespace APDYNAMICART
11 {
12
13 class PS_Layer : public osg::Referenced
14 {
15 public:
16
17
18 private:
19
20
21 };
22
23 typedef osg::ref_ptr<PS_Layer> PS_LayerPtr;
24
25 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Parameters.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Parameters.h
Go to the documentation of this file.
1 #pragma once
2 #include <string>
3
4 namespace APDYNAMICART
5 {
6
8 typedef struct Parameter
9 {
10 Parameter(double rangeStart, double rangeEnd, double value, std::string title = "", bool canBeRandom = true)
11 : rangeStart(rangeStart), rangeEnd(rangeEnd), value(value), title(title), canBeRandom(canBeRandom) {}
12
13 std::string title;
14 double rangeStart;
15 double rangeEnd;
16 double value;
17 bool canBeRandom;
18
19 } Parameter;
20
21 typedef std::vector<Parameter> Parameters;
22
24 //Interface
26
27 class IParameters : public osg::Referenced
28 {
29 public:
30 virtual Parameters getParameters() = 0;
31 virtual ~IParameters() {};
32 };
33
34 typedef osg::ref_ptr<IParameters> IParametersPtr;
35
36 class NullParameters : public IParameters
37 {
38 virtual Parameters getParameters()
39 {
40 return Parameters();
41 }
42 };
43
44 class LorenzParameters : public IParameters
45 {
46 virtual Parameters getParameters()
47 {
48 Parameters params;
49 params.reserve(4);
50 params.push_back(Parameter(0.0, 20.0, 11.23, "a"));
51 params.push_back(Parameter(0.0, 20.0, 6.25, "b"));
52 params.push_back(Parameter(0.0, 20.0, 2.35, "c"));
53 params.push_back(Parameter(0.0, 0.5, 0.14, "dT"));
54 return params;
55 }
56 };
57
58 class Lorenz84Parameters : public IParameters
59 {
60 virtual Parameters getParameters()
61 {
62 Parameters params;
63 params.reserve(5);
64 params.push_back(Parameter(0.0, 10.0, 1.01, "a"));
65 params.push_back(Parameter(0.0, 10.0, 0.827, "b"));
66 params.push_back(Parameter(0.0, 10.0, 2.853, "f"));
67 params.push_back(Parameter(0.0, 10.0, 0.302, "g"));
68 params.push_back(Parameter(0.0, 0.5, 0.286, "dT"));
69 return params;
70 }
71 };
72
73 class JuliaParameters : public IParameters
74 {
75 virtual Parameters getParameters()
76 {
77 Parameters params;
78 params.reserve(6);
79 params.push_back(Parameter(-1.0, 1.0, 0.0, "Cx"));
80 params.push_back(Parameter(-1.0, 1.0, 0.0, "Cy"));
81 params.push_back(Parameter(-1.0, 1.0, 0.0, "Dx"));
82 params.push_back(Parameter(-1.0, 1.0, 0.0, "Dy"));
83 params.push_back(Parameter(0.2, 80.0, 3.0, "Epsilon", false));
84 params.push_back(Parameter(1, 12.0, 8.0, "Max iteration", false));
85
86 return params;
87 }
88 };
89
90 class PickoverParameters : public IParameters
91 {
92 virtual Parameters getParameters()
93 {
94 Parameters params;
95 params.reserve(4);
96 //params.push_back(Parameter(-1.7, 2.24, 1.5, "a"));
97 //params.push_back(Parameter(-1.7, 2.24, 0.7, "b"));
98 //params.push_back(Parameter(-1.7, 2.24, -0.5, "c"));
99 //params.push_back(Parameter(-1.7, 2.24, -1.0, "d"));
100
101 params.push_back(Parameter(-1.7, 2.24, 1.0, "a"));
102 params.push_back(Parameter(-1.7, 2.24, 1.8, "b"));
103 params.push_back(Parameter(-1.7, 2.24, 0.71, "c"));
104 params.push_back(Parameter(-1.7, 2.24, 1.51, "d"));
105
106 return params;
107 }
108 };
109
110 class RosslerParameters : public IParameters
111 {
112 virtual Parameters getParameters()
113 {
114 Parameters params;
115 params.reserve(4);
116 params.push_back(Parameter(0.0, 10.0, 0.238, "a"));
117 params.push_back(Parameter(0.0, 10.0, 0.684, "b"));
118 params.push_back(Parameter(0.0, 10.0, 5.7, "c"));
119 params.push_back(Parameter(0.0, 0.5, 0.11, "d"));
120
121 return params;
122 }
123 };
124
125 class PolynomialParameters : public IParameters
126 {
127 virtual Parameters getParameters()
128 {
129 Parameters params;
130 params.reserve(3);
131 params.push_back(Parameter(0.0, 2.0, 1.1, "a"));
132 params.push_back(Parameter(0.0, 2.0, 0.3, "b"));
133 params.push_back(Parameter(0.0, 2.0, 1.60, "c"));
134 return params;
135 }
136 };
137
138 class IkedaParameters : public IParameters
139 {
140 virtual Parameters getParameters()
141 {
142 Parameters params;
143 params.reserve(4);
144 params.push_back(Parameter(0.0, 2.0, 0.55, "a"));
145 params.push_back(Parameter(0.0, 2.0, 0.97, "b"));
146 params.push_back(Parameter(0.0, 10.0, 7.74, "c"));
147 params.push_back(Parameter(0.0, 10.0, 7.28, "d"));
148 return params;
149 }
150 };
151
152 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Particle.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Particle.h
Go to the documentation of this file.
1 #ifndef Particle_h
2 #define Particle_h
3
4 #include <NxVec3.h>
5
6
7 using namespace vrecko;
8
9 namespace PhysXPlugin
10 {
11 struct Particle
12 {
13 NxVec3 position;
14 NxVec3 velocity;
15 NxReal density;
16 NxReal lifetime;
17 NxU32 id;
18 NxVec3 collisionNormal;
19 };
20 }
21
22
23 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/ParticleFactory.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
ParticleFactory.h
Go to the documentation of this file.
1 // ===============================================================================
2 // AGEIA PHYSX SDK SAMPLE PROGRAMS
3 // PARTICLE FLUID
4 //
5 // Written by Simon Schirm 09-12-06
6 // ===============================================================================
7
8 #ifndef PARTICLE_FACTORY_H
9 #define PARTICLE_FACTORY_H
10
11 #include "NxPhysics.h"
12
13 void CreateParticleAABB(NxParticleData& pd, unsigned maxParticlesTotal, unsigned maxParticles, bool append, NxBounds3& aabb, const NxVec3 vel, float lifetime, float distance);
14 void CreateParticleSphere(NxParticleData& pd, unsigned maxParticles, bool append, const NxVec3& pos, const NxVec3 vel, float lifetime, float distance, unsigned sideNum);
15
16
17 #endif
18
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ParticleSystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ParticleSystem.h
Go to the documentation of this file.
1 #ifndef _DA_PARTICLE_SYSTEM_H
2 #define _DA_PARTICLE_SYSTEM_H
3
4
5
6 using namespace vrecko;
7
8 namespace APDYNAMICART
9 {
10
11
12 struct ParticleSystemParameters
13 {
14 double lifeTime;
15 double gravity;
16 double BirthRateMin, BirthRateMax;
17 double sizeBirth, sizeDeath;
18 double speedMin, speedMax;
19 double dispersion;
20
21 string textureFile;
22
23 };
24
33 void createParticleSystem( osg::Group* emmitterParent, osg::Group* particleSystemParent, ParticleSystemParameters *params );
34
35
36 }
37 #endif // _DA_PARTICLE_SYSTEM_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Pattern.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Pattern.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "types.h"
4 #include "Utils.h"
5
6 namespace APDYNAMICART
7 {
8
10 class Pattern : public osg::Referenced
11 {
12 public:
13 virtual Vec3ArrayPtr generate(Vec3ArrayPtr left, Vec3ArrayPtr right) = 0;
14 virtual std::string getName() = 0;
15 };
16
18 class PatternBase : public Pattern
19 {
20 public:
21 PatternBase() : _array(NULL) {};
22
23 virtual Vec3ArrayPtr generate(Vec3ArrayPtr left, Vec3ArrayPtr right)
24 {
25 if(!_array.valid()) _array = new osg::Vec3Array;
26
27 if(left->size() != right->size()) {
28 err("Different size left/right array. Aborting generation"); return _array;
29 }
30
31 return compute(left, right);
32 }
33
34 virtual std::string getName() = 0;
35
37 Vec3ArrayPtr getVertexArray() const { return _array; }
38 void setVertexArray(Vec3ArrayPtr val) { _array = val; }
39
40 protected:
41 Vec3ArrayPtr _array;
42 virtual ~PatternBase() {};
43 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right ) = 0;
44 };
45
47 typedef osg::ref_ptr<PatternBase> PatternPtr;
48 typedef std::vector<PatternPtr> Patterns;
49
51 class PatternFactory
52 {
53 public:
54 static std::vector<std::string> getAvaiablePatterns();
55 static PatternPtr getPattern(const std::string& name);
56 };
57
59 class NullPattern : public PatternBase
60 {
61 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right)
62 {
63 dbg("PatternBase::generate() called on null object.");
64 return new osg::Vec3Array;
65 }
66
67 virtual std::string getName() {
68 return "NullPattern";
69 }
70 };
71
72 class AcrossPattern : public PatternBase
73 {
74 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
75 virtual std::string getName() {
76 return "Across";
77 }
78 };
79
80 class CrissCrossPattern : public PatternBase
81 {
82 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
83 virtual std::string getName() {
84 return "Criss-cross";
85 }
86 };
87
88 class DoublePattern : public PatternBase
89 {
90 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
91 virtual std::string getName() {
92 return "Double";
93 }
94 };
95
96 class HyperbolicPattern : public PatternBase
97 {
98 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
99 virtual std::string getName() {
100 return "Hyperbolic";
101 }
102 };
103
104 class TopPattern : public PatternBase
105 {
106 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
107 virtual std::string getName() {
108 return "Top";
109 }
110 };
111
112 class TopReversePattern : public PatternBase
113 {
114 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
115 virtual std::string getName() {
116 return "Top-Reverse";
117 }
118 };
119
120 class StandardPattern : public PatternBase
121 {
122 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
123 virtual std::string getName() {
124 return "Standard";
125 }
126 };
127
128 class SplitPattern : public PatternBase
129 {
130 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
131 virtual std::string getName() {
132 return "Split";
133 }
134 };
135
136 class SplitReversePattern : public PatternBase
137 {
138 virtual Vec3ArrayPtr compute( Vec3ArrayPtr left, Vec3ArrayPtr right);
139 virtual std::string getName() {
140 return "Split-Reverse";
141 }
142 };
143
144 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PatternGeode.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PatternGeode.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg/Geode>
4 #include "Pattern.h"
5 #include <osg/NodeCallback>
6 #include <osg/LineWidth>
7 #include <osg/CopyOp>
8
9 namespace APDYNAMICART
10 {
11
12 class PatternsGeode : public osg::Geode
13 {
14
15 public:
17 PatternsGeode();
18 PatternsGeode(const PatternsGeode&,const osg::CopyOp& copyop=osg::CopyOp::SHALLOW_COPY);
19
20 META_Node(APDYNAMICART, PatternsGeode);
21
23 float getStringLineWidth() const { return _stringWidth; }
24 Vec3ArrayPtr getPatternsPointsArray() const { return _patternsPoints; }
25
27 inline void setVertexArray(Vec3ArrayPtr points);
28 inline void setStringLineWidth(float val);
29
30 void updateGeometry();
31
32 private:
34 Vec3ArrayPtr _patternsPoints;
35 GeometryPtr _geometry;
36 float _stringWidth;
37
39 void createDrawableObject();
40
42 virtual ~PatternsGeode() {};
43 };
44
45 typedef osg::ref_ptr<PatternsGeode> PatternGeodePtr;
46 typedef std::vector<PatternGeodePtr> PatternGeodeList;
47
49 inline void PatternsGeode::setVertexArray( Vec3ArrayPtr points )
50 {
51 if(points.valid()) {
52 _patternsPoints = points;
53 return;
54 }
55
56 err("Non valid pattern pointer used!");
57 }
58
59 void PatternsGeode::setStringLineWidth( float val )
60 {
61 _stringWidth = val;
62 ((osg::LineWidth*)_geometry->getOrCreateStateSet()->getAttribute(osg::StateAttribute::LINEWIDTH))->setWidth(val);
63 }
64
65 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLines.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PerlinLines.h
Go to the documentation of this file.
1 #ifndef _PERLINELINES_H
2 #define _PERLINELINES_H
3
4 #include "Controller.h"
5 #include "poa.h"
6 #include <osg/LineWidth>
7
8
9 using namespace vrecko;
10
11 namespace APDYNAMICART
12 {
13
14
15
16 typedef std::vector<osg::ref_ptr<osg::Sphere> > Spheres;
17
18
19 class PerlinLines : public PoA
20 {
21 public:
22 PerlinLines(Controller* contr, int numberOfLines, double x, double y, double z);
23 ~PerlinLines();
24
25 int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode) { return 0; }
26
27 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode) {}
28
29 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
30
31 void GUIItemClicked(const char* itemID);
32
33 void GUISliderChanged(const char* sliderID, float sliderPos);
34
35 void pointed(bool pointed);
36
37 void setColor(osg::Vec4 newColour) {}
38
39 void update();
40
41 void draw();
42
43 void setLineParameters(int count);
44
45 void setLinesParameters();
46
47 double perlinNoise(osg::Vec3 temp);
48
49 double smooth(osg::Vec3 temp, double sx, double sy, double sz);
50
51 double interpolate(double a, double b, double c);
52
53 void interpolateVec3(osg::Vec3Array* controlPoints, osg::Vec3Array* interpolatedPoints, int p_steps);
54
55 osg::Vec3 interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0 = osg::Vec3(0.0, 0.0, 0.0), osg::Vec3 point3 = osg::Vec3(0.0, 0.0, 0.0));
56
57 double random(double min,double max) { return min + (max-min)*(double)rand()/(double)RAND_MAX;}
58
59
60 void setMagnet(osg::Vec3 coordinates, float magnetSize){_magnetUsed = true; _magnetCoords = coordinates; this->_magnetSize = magnetSize;};
61
62 void createMagnet(EnvironmentObject* daarea, bool first){daarea->addEOChild(magnetEO); daarea->addEOChild(particlesEO);if (first) _magnetCreated = true; else _magnetCreated = false;};
63
64 void updateMagnetPosition(osg::Vec3 vektor, float size) ;
65
66 void unsetMagnet() {_magnetUsed = false; _magnetON = false;};
67
68
69 void setBounding(float boundingSize, bool first) {_boundingUsed = true; this->_boundingSize = boundingSize;if (first) _boundingCreated = true; else _boundingCreated = false;};
70
71 void setBoundingVisible() {if(_boundingVisible) _boundingVisible = false; else _boundingVisible = true;};
72
73 void unsetBounding() {_boundingUsed = false;};
74
75
76 void recalculateColorInterpolation();
77
78 void setColor(osg::Vec3 color){_red = color.x(); _green = color.y(); _blue = color.z();};
79
80
81 void setSpeed(int speed) {changedSpeed = 101-speed;};
82
83 int getSpeed(){return this->_speed;};
84
85 void setInterpolationCount(int interpolationCount) {changedInterpolation = 5 + interpolationCount; _somethingChaned = true;};
86
87 int getInterpolationCount() {return this->_interpolationCount;};
88
89 void setLength(int length) {changedLength = 4 + length; _somethingChaned = true;};
90
91 void setColor(float r, float g, float b) {_red = r; _green = g; _blue = b; _somethingChaned = true;}
92
93
94 void setController(osg::Vec3 vektor);
95
96 void unsetController(){_controllerUsed = false;};
97
98 void updateControllerPosition(osg::Vec3 vektor) {if (_request) _controllerCoords = vektor;};
99
100 int getLength(){return this->_length;};
101
102 void pause(){if (_paused) _paused = false; else _paused = true;};
103
104
105
106
107 protected:
108 typedef osg::ref_ptr<osg::Vec3Array> Vec3Ptr;
109
110 osg::ref_ptr<osg::Geode> _lineGeode, _boxGeode;
111 std::vector<osg::ref_ptr<osg::Geometry>> _lineGeometry;
112 osg::ref_ptr<osg::Vec4Array> _linesColorArray, _boxColorArray;
113 osg::ref_ptr<osg::Vec4Array> _newLinesColorArray;
114 osg::ref_ptr<osg::StateSet> _OSGState, _boxOSGState;
115 osg::ref_ptr<osg::LineWidth> _linewidth;
116 osg::ref_ptr<osg::Material> _linesMaterial, _boxMaterial;
117 std::vector<Vec3Ptr> _lines;
118 std::vector<Vec3Ptr> _interpolatedLines;
119 Vec3Ptr gradient;
120 int _p[512];
121 float _magnetSize, _boundingSize;
122 u_int _speed, _trigger, _interpolationCount, _length;
123 osg::Vec3 _magnetCoords, _unusedMagnetCoords, _controllerCoords;
124 bool _somethingChaned, _request, _pointed, _paused, _magnetUsed, _magnetON, _controllerUsed, _boundingUsed, _boundingVisible;
125 bool _magnetCreated, _boundingCreated;
126 u_int changedSpeed, changedInterpolation, changedLength;
127 float _red, _green, _blue, _changedRed, _changedGreen, _changedBlue;
128 EnvironmentObject* magnetEO;
129 EnvironmentObject* particlesEO;
130 EnvironmentObject* _daArea;
131 bool firstTimeUpdate;
132
133 osg::ref_ptr<osg::Geode> magnetGeode;
134 osg::ref_ptr<osg::StateSet> magnetStateSet;
135 osg::ref_ptr<osg::Material> magnetMaterial;
136 };
137
138 }
139 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PerlinLinesTools.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PerlinLinesTools.h
Go to the documentation of this file.
1 #ifndef _DYNAMIC_ART_PERLIN_LINES_TOOLS_H
2 #define _DYNAMIC_ART_PERLIN_LINES_TOOLS_H
3
4 #include "DATool.h"
5 #include "PoA.h"
6 #include "SimpleBox.h"
7
8 namespace APDYNAMICART
9 {
10
11
12 class PLNestTool : public DATool
13 {
14 public:
15 PLNestTool();
16
17 ~PLNestTool() {};
18
19 void activate() {};
20
21 void deactivate() {};
22
23 void postInitialize(void);
24
25 void turnOn() {if(_cursor) _cursor->show();};
26
27 void turnOff() {if (_cursor) _cursor->hide();};
28
29 void update() {};
30
31 protected:
32 EnvironmentObject* DAArea;
33 osg::ClipNode* clipNode;
34 };
35
36
37 class PLMagnetTool : public DATool
38 {
39 public:
40 PLMagnetTool();
41
42 ~PLMagnetTool() {};
43
44 void activate() {};
45
46 void deactivate() {};
47
48 void postInitialize(void);
49
50 void turnOn() {if(_cursor) _cursor->show();};
51
52 void turnOff() {if (_cursor) _cursor->hide();};
53
54 void update() {};
55
56 protected:
57 EnvironmentObject* DAArea;
58 osg::ClipNode* clipNode;
59 };
60
61
62 class PLControllerTool : public DATool
63 {
64 public:
65 PLControllerTool();
66
67 ~PLControllerTool(){};
68
69 void activate() {};
70
71 void deactivate() {};
72
73 void postInitialize(void);
74
75 void turnOn() {if(_cursor) _cursor->show();};
76
77 void turnOff() {if (_cursor) _cursor->hide();};
78
79 void update() {};
80
81 protected:
82 EnvironmentObject* DAArea;
83 osg::ClipNode* clipNode;
84 osg::ClipPlane* lowClipPlane;
85 osg::ClipPlane* topClipPlane;
86 };
87
88
89 }
90 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/PerlinNoiseAlgorithm.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
PerlinNoiseAlgorithm.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_PERLINNOISE_H
10 #define VRECKO_NATURE_TERRAIN_PERLINNOISE_H
11
12 #include "TerrainAlgorithm.h"
13 #include "../TerrainUtility.h"
14 #include <osg/Array>
15
16 namespace APNature
17 {
18 class PerlinNoiseAlgorithm : public TerrainAlgorithm
19 {
20 private:
21
22 int _permutationTable[514];
23 osg::ref_ptr<osg::Vec2Array> _gradientsTable;
24
25 public:
26
32 PerlinNoiseAlgorithm(int width, int height);
33
44 float GetNoise(float x, float y);
45
52 float* GenerateNoiseTexture(float frequencyX, float frequencyY);
53
66 float* GenerateCloudsTexture(std::size_t octaveCount, float persistence);
67
68 private:
69
76 void InitTables();
77
84 static inline float EaseCurve(float t) { return (t * t) * (3.0f - 2.0f * t); }
85
98 inline osg::Vec2 GetGradient(int x, int y) {
99 return (*_gradientsTable)[ this->_permutationTable[ this->_permutationTable[ x ] + y ] ]; }
100
112 static inline float InterpolationLinear(float from, float to, float x) { return from + x * (to - from); }
113
125 static inline float InterpolationCosine(float from, float to, float x) { return from +
126 ((1.0f - cos(x * (float) osg::PI)) * 0.5f) * (to - from); }
127 };
128
129 }
130
131 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/PerlinNoiseProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
PerlinNoiseProperties.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_PERLINNOISEPROPERTIES_H
11 #define VRECKO_NATURE_TERRAIN_PERLINNOISEPROPERTIES_H
12
13 #include <vrecko/ReaderWriter.h>
14 #include <osg/Vec2>
15
16 #include "GeneratedTerrainProperties.h"
17
18 namespace APNature
19 {
20 static class PerlinNoiseProperties : public GeneratedTerrainProperties
21 {
22 private:
23
24 // Perlin noise algorithm
25 static float _persistence;
26 static int _octaveCount;
27 static InterpolationType _interpolation;
28
29 public:
30
31 // Perlin noise specific methods
32 // #############################
33
37 static inline float Persistence() { return _persistence; }
38 static inline void Persistence(float persistence) { _persistence = persistence; }
39
43 static inline int OctaveCount() { return _octaveCount; }
44 static inline void OctaveCount(int octaveCount) { _octaveCount = (octaveCount >= 1 ? octaveCount : 1); }
45
49 static inline InterpolationType Interpolation() { return _interpolation; }
50 static inline void Interpolation(InterpolationType interpolation) { _interpolation = interpolation; }
51
57 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
58
59 protected:
60
65 static void ParseInterpolationString(const std::string& input);
66
67 } PerlinNoiseProperties;
68
69 }
70
71 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PersistentCache.h Source File

  • File List
  • File Members
  • include
  • vrecko
PersistentCache.h
Go to the documentation of this file.
1
10 #ifndef PERSISTENT_CACHE_H
11 #define PERSISTENT_CACHE_H
12
13 #include <vrecko/Export>
14 #include <vrecko/MTLock.h>
15 #include <helpers/DynamicArray.h>
16 #include <helpers/BufFile.h>
17
18 #include <osg/Node>
19
20
21
22 namespace vrecko {
23
24
25 class EnvironmentObject;
26
27
55 class VRECKO_EXPORT PersistentCache {
56 public:
57
58 class OpenedCacheFile {
59 friend PersistentCache;
60 public:
61 OpenedCacheFile();
62 ~OpenedCacheFile();
63
64 inline const std::string& getTranslatedFileName() { return translatedFileName; }
65 inline const std::string& getCachedFileName() { return cachedFileName; }
66
67 protected:
69 std::string translatedFileName;
70
72 std::string cachedFileName;
73
75 int iReaders, iWaitingWriters, iWriters;
76 };
77
78
79 PersistentCache();
80 ~PersistentCache();
81
83 void setEnable(bool bNewEnableCache);
84
86 inline bool getEnable() { return bEnableCache; }
87
88 const char* getCacheDir() { return cacheDir; }
89
94 osg::Node* loadModel(const char *relatedFileName, vrecko::EnvironmentObject *obj);
95
100 bool saveModel(const char *relatedFileName, osg::Node *node, vrecko::EnvironmentObject *obj);
101
108 inline bool openCacheFileForReading(const char *dataName, const char *relatedFileName, unsigned long version,
109 OpenedCacheFile** cacheData, vrecko::BufferedFile **bfile, unsigned long ulWaitTimeout = 0)
110 { return internalOpenReadWrite(dataName, relatedFileName, version, cacheData, bfile, NULL, ulWaitTimeout); }
111
113 void closeCacheFile(OpenedCacheFile* cacheData, vrecko::BufferedFile *bfile);
114
120 inline bool openCacheFileForWriting(const char *dataName, const char *relatedFileName, unsigned long version,
121 OpenedCacheFile** cacheData, vrecko::BufferedFileWrite **bfile, unsigned long ulWaitTimeout = 0)
122 { return internalOpenReadWrite(dataName, relatedFileName, version, cacheData, NULL, bfile, ulWaitTimeout); }
123
125 void closeCacheFile(OpenedCacheFile* cacheData, vrecko::BufferedFileWrite *bfile);
126
127
128 protected:
129
130 bool bEnableCache;
131
134 DynamicArray<OpenedCacheFile*> openedFiles;
135
138 MTLock filesLock;
139
141 CHAR baseDir[1000];
142
144 CHAR cacheDir[1000];
145
150 void translateName(char *outTranslatedName, const char *inDataName, const char *inRelatedFileName);
151
152
153
154 //bool isInCache(const char *dataName, const char *relatedFileName, char *outFullCachedFileName = NULL);
155 // Check whether a specified file/data is in the cache.
156 // The REAL file MUST exist - its time stamp is taken into account when checking the validity
157 // of the cached version (if the cached version is stored on the disk).
158
170 int internalFindAndLock(const char *originalFileName, const char *translatedFileName, unsigned long version,
171 const char* desiredExtension, bool bReading, unsigned long ulWaitTimeout);
172
173 bool internalOpenReadWrite(const char *dataName, const char *relatedFileName, unsigned long version,
174 OpenedCacheFile** cacheData, vrecko::BufferedFile **bfile, vrecko::BufferedFileWrite **bfileWrite, unsigned long ulWaitTimeout);
175
181 void internalDecrementReaderWriter(OpenedCacheFile* cacheData, bool bReading);
182
186 bool testVersionIsAtLeast(const char *fileName, int minVersion);
187
193 void constructModelDataName(char *outDataName, vrecko::EnvironmentObject* obj);
194 };
195
196
197 }; // namespace vrecko
198
199 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Box.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Box.h
Go to the documentation of this file.
1 #ifndef Box_h
2 #define Box_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseActor.h"
8
9
10 using namespace vrecko;
11
12
13 namespace PhysXPlugin
14 {
15 class Box : public BaseActor
16 {
17 public:
18 Box();
19 ~Box();
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 protected:
25 virtual void Create();
26
27 NxBoxShapeDesc _boxDesc;
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Plane.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Plane.h
Go to the documentation of this file.
1 #ifndef Plane_h
2 #define Plane_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseActor.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14
15 class Plane : public BaseActor
16 {
17 public:
18 Plane();
19 ~Plane(){};
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23 protected:
24 void Create();
25
26 NxPlaneShapeDesc _planeDesc;
27 };
28
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PhysXManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PhysXManager.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <NxPhysics.h>
4 #include "SweepSurface.h"
5 #include "Utils.h"
6 #include "Hoop.h"
7 #include <Windows.h>
8 #include <ctime>
9 #include "DAEnvironment.h"
10
11 #pragma comment(lib, "PhysXLoader.lib")
12
13 namespace APDYNAMICART
14 {
15
16 struct SimulationParameters
17 {
18 double detailCoef;
19 double hoopDensity;
20 double stringSpring;
21 double stringDamper;
22
23 SimulationParameters() :
24 detailCoef(0.70),
25 hoopDensity(900),
26 stringSpring(0),
27 stringDamper(0)
28 {}
29 };
30
31 class PhysXManager
32 {
33
34 public:
35 static PhysXManager* get()
36 {
37 static PhysXManager manager;
38 return &manager;
39 }
40
42 static inline NxQuat toNxQuat( const osg::Quat& qRot );
43 static inline NxVec3 toNxVec3( const osg::Vec3& point );
44 static inline osg::Vec3 toOsgVec3( const NxVec3& point);
45 static inline osg::Quat toOsgQuat( const NxQuat& qRot);
46 static inline osg::Matrix getDAMatrix();
47
48
49 void releasePhysics();
50 bool init();
51 bool createScene();
52 void getPhysicsResult();
53 void startPhysics();
54 NxActor* addHoopActorToScene( Hoop* hoop, NxVec3 linearVelocity = NxVec3(0.2,0.0,-1.0) );
55 void setStringJoints(HoopPtr first, HoopPtr second, Vec3ArrayPtr points);
56 void setActorPosition(HoopPtr hoop);
57 void setActorOrientation(HoopPtr hoop);
58 void addForceToHoop(HoopPtr hoop, const osg::Vec3& direction);
59 void resetScene();
60 void releaseHoopActor(HoopPtr hoop);
61 void releaseHoopJoints();
62 void createRope(HoopPtr hoop, const osg::Vec3& pos, double segHeight, double radius, unsigned int segments);
63 const std::vector<NxActor*>& getRopeActors() const;
64 SimulationParameters& getSimualtionParameters() { return _parameters; }
65
66 bool isRunning() const { return _simulationRunning; }
67 void setSimulationRun(bool val) { _simulationRunning = val; }
68
69 protected:
70 PhysXManager();
71
72 inline NxVec3 transformToLocalCoord( Hoop* hoop, const osg::Vec3& point );
73 NxSphericalJoint* createRopeSphericalJoint(NxActor* a0, NxActor* a1, const NxVec3& globalAnchor, const NxVec3& globalAxis);
74 NxActor* createCapsule(const NxVec3& pos, const NxReal height, const NxReal radius);
75
76 NxPhysicsSDK* _physicsSDK;
77 NxScene* _scene;
78 float _deltaTime;
79 bool _simulationRunning;
80 NxVec3 _linearVelocity;
81 SimulationParameters _parameters;
82
83 std::vector<NxJoint*> _joints;
84 std::vector<NxActor*> _ropeSegs;
85 std::vector<NxSphericalJoint*> _ropeLinks;
86 };
87
88 NxQuat PhysXManager::toNxQuat( const osg::Quat &qRot )
89 {
90 NxQuat result;
91 result.x=qRot.x();
92 result.y=qRot.y();
93 result.z=qRot.z();
94 result.w=qRot.w();
95
96 return result;
97 }
98
99 NxVec3 PhysXManager::toNxVec3( const osg::Vec3& point )
100 {
101 return point._v;
102 }
103
104 osg::Vec3 PhysXManager::toOsgVec3( const NxVec3& point )
105 {
106 return osg::Vec3(point.x, point.y, point.z);
107 }
108
109 osg::Quat PhysXManager::toOsgQuat( const NxQuat& qRot )
110 {
111 return osg::Quat(qRot.x, qRot.y, qRot.z, qRot.w);
112 }
113
114 inline NxVec3 PhysXManager::transformToLocalCoord( Hoop* hoop, const osg::Vec3& point )
115 {
116 osg::Vec3 localPoint = hoop->getMatrix().getRotate().inverse() * (point - hoop->getPosition());
117 return toNxVec3(localPoint);
118 }
119
120 osg::Matrix PhysXManager::getDAMatrix()
121 {
122 EnvironmentObject* eo = (EnvironmentObject*)(DAEnvironment::getInstance()->getOwner());
123 return eo->getMatrix();
124 }
125
126 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PhysXModule.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
PhysXModule.h
Go to the documentation of this file.
1 #pragma once
2
3 #ifdef USE_PHYSX
4
5 #include <NxPhysics.h>
6 #include "SweepSurfaceGeode.h"
7 #include <osg\PositionAttitudeTransform>
8 #include "Utils.h"
9 #include "Hoop.h"
10
11 #pragma comment(lib, "PhysXLoader.lib")
12
13 namespace APDYNAMICART
14 {
15
16 class PhysXModule
17 {
18
19 public:
20 PhysXModule();
21 ~PhysXModule();
22
23 void releasePhysics();
24 bool init();
25 bool createScene();
26 void getPhysicsResult();
27 void startPhysics();
28 void renderActors();
29 NxActor** getActors();
30 int getNumActors();
31 bool addHoopActorToScene(HoopPtr hoop, EnvironmentObject* eo);
32 void setStringJoints(HoopPtr first, HoopPtr second, Vec3ArrayPtr points);
33 void setSphericalJoint(const osg::Vec3& point, HoopPtr hoop);
34 void resetScene();
35 void releaseActor(HoopPtr hoop);
36 protected:
38 inline NxQuat toNxQuat( const osg::Quat &qRot );
39 inline NxVec3 toNxVec3( const osg::Vec3& point );
40 inline NxVec3 transformToLocalCoord( NxActor* actor, const NxVec3& point );
41
42 NxPhysicsSDK* _physicsSDK;
43 NxScene* _scene;
44 NxReal _timeStep;
45 //std::vector<NxActor*> _actors;
46 std::vector<NxJoint*> _joints;
47
48 std::map<HoopPtr, NxActor*> _actors;
49 };
50
51 NxQuat PhysXModule::toNxQuat( const osg::Quat &qRot )
52 {
53 NxQuat result;
54 result.x=qRot.x();
55 result.y=qRot.y();
56 result.z=qRot.z();
57 result.w=qRot.w();
58
59 return result;
60 }
61
62 NxVec3 PhysXModule::toNxVec3( const osg::Vec3& point )
63 {
64 return point._v;
65 }
66
67 NxVec3 PhysXModule::transformToLocalCoord( NxActor* actor, const NxVec3& point )
68 {
69 NxMat33 mat;
70 actor->getGlobalPose().M.getInverse(mat);
71 return mat * (point - actor->getGlobalPosition());
72 }
73
74 }
75 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXObject.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PhysXObject.h
Go to the documentation of this file.
1 #ifndef PhysXObject_h
2 #define PhysXObject_h
3
4 #include <osg/ShadeModel>
5 #include <osg/CullFace>
6 #include <osg/ShapeDrawable>
7 #include <osg/Geode>
8
9 #include <NxPhysics.h>
10 #include <vrecko/Ability.h>
11 #include <vrecko/EnvironmentObject.h>
12
13 using namespace vrecko;
14
15 namespace PhysXPlugin
16 {
17 class PhysXObject: public Ability
18 {
19 PhysXObject() : Ability("PhysXObject_Generic") {}
20 public:
21 PhysXObject(const char* abName):Ability(abName){}
22 virtual ~PhysXObject(){}
23
24 // metoda musi byt volana po nacteni xml ve vsech zdedenych tridach
25 // pretezujte metodu BeforeInitialization
26 virtual void preInitialize()
27 {
28 BeforeInitialization();
29 //_pPO = NULL;
30 _pPhysicsSDK = NULL;
31 _pPhysicsSDK = NxCreatePhysicsSDK(NX_PHYSICS_SDK_VERSION);
32 }
33
34 // metoda musi byt volana po nacteni xml ve vsech zdedenych tridach
35 // pretezujte metodu AfterInitialization
36 virtual void postInitialize()
37 {
38 AfterInitialization();
39 }
40
41 virtual void BeforeInitialization(){}
42 virtual void AfterInitialization(){}
43
44
45
46
47
48 protected:
49
50 bool addUserDrawable(osg::Drawable *userDrawable)
51 {
52 osg::Geode* main_geode = new osg::Geode;
53 main_geode->setName("userDrawable: "+userDrawable->getName());
54
55 // z EnvironmentObject nastaveni state a cull mode
56 osg::StateSet* stateset2 = new osg::StateSet;
57 osg::ShadeModel* shademodel = new osg::ShadeModel;
58 shademodel->setMode(osg::ShadeModel::SMOOTH);
59 stateset2->setAttributeAndModes(shademodel,osg::StateAttribute::OVERRIDE|osg::StateAttribute::ON);
60 osg::CullFace *modelCullFace = new osg::CullFace();
61 modelCullFace->setMode(osg::CullFace::BACK);
62 stateset2->setAttributeAndModes(modelCullFace, osg::StateAttribute::ON);
63 main_geode->setStateSet(stateset2);
64
65 main_geode->addDrawable(userDrawable/*new osg::ShapeDrawable(new osg::Box(osg::Vec3(0.0, 0.0, 0.0), 1.0, 0.05, 1.0), 0)*/);
66
67 vrecko::EnvironmentObject * pEO = (EnvironmentObject*) pOwner;
68 return pEO->setGeometry(main_geode);
69 }
70
71 NxPhysicsSDK * _pPhysicsSDK;
72 };
73 }
74
75 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXScene.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PhysXScene.h
Go to the documentation of this file.
1 #ifndef PhysXScene_h
2 #define PhysXScene_h
3
4 #ifndef LINUX
5 #include <Windows.h>
6 #else
7 #endif
8 #include <vrecko/Ability.h>
9 #include <vreckoAP/Export>
10
11 #include <vector>
12 #include <NxScene.h>
13
14
15 #include "PhysXObject.h"
16 #include "UpdatablePhysXObject.h"
17 #include "MaterialManager.h"
18 #include "PhysXVreckoMessages.h"
19
20
21 using namespace vrecko;
22
23 namespace PhysXPlugin
24 {
25 class AP_EXPORT PhysXScene : public PhysXObject
26 {
27 private:
28 #ifndef LINUX
29 __int64 _gLastTime;
30 #else
31 struct timeval lasttv;
32 #endif
33
34 NxReal UpdateTime();
35
36 void StartPhysics();
37
38 void GetPhysicsResults();
39
40
41
42 std::string _sName;
43 std::string _simulationType;
44 NxSceneDesc _SceneDesc;
45
46 NxScene* _pScene;
47
48
49 MaterialManager _materialManager;
50 std::map<std::string, NxActor*> _JointedActorMap;
51 typedef std::map<std::string, NxActor*>::iterator TJointedActorMapIter;
52
53 std::vector<UpdatablePhysXObject*> _UPOHandler;
54 public:
55
56
57
58 PhysXScene();
59 virtual ~PhysXScene(){}
60
61
62 void preInitialize();
63 void postInitialize();
64
65
66 // virtual void* processRequest(const std::string& input_name, void *value);
67
68
69 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
70
71 void update(void);
72
73 DECLARE_REQUEST_INPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool);
74 DECLARE_REQUEST_INPUT(PhysXScene, MessageVoid, MessageNxScenePtr);
75 DECLARE_REQUEST_INPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool);
76 DECLARE_REQUEST_INPUT(GetJointedActor, MessageString, MessageNxActorPtr);
77 DECLARE_REQUEST_INPUT(Material, MessageString, MessageNxMaterialIndex);
78 };
79 }
80
81 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PhysXVreckoMessages.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PhysXVreckoMessages.h
Go to the documentation of this file.
1 #ifndef PHYSXVRECKOMESSAGES_H
2 #define PHYSXVRECKOMESSAGES_H
3
4
5 #include <vrecko/Ability.h>
6 #include <vrecko/Message.h>
7
8 #include <NxScene.h>
9 #include <NxActor.h>
10 #include <NxMaterial.h>
11
12
13 namespace PhysXPlugin
14 {
15
16 VRECKO_START_MESSAGE_EXTENDED(MessageNxScenePtr, NxScene*)
17 VRECKO_END_MESSAGE
18
19
20 VRECKO_START_MESSAGE_EXTENDED(MessageNxActorPtr, NxActor*)
21 VRECKO_END_MESSAGE
22
23
24 class MessageNxActorWithName : public vrecko::VreckoMessage {
25 public:
26 MessageNxActorWithName() {};
27 MessageNxActorWithName(NxActor* actor, const char *name) { _actor = actor; _name = name; }
28 virtual const char* getMessageId() { return "MessageNxActorWithName"; }
29
30 NxActor* _actor;
31 std::string _name;
32 };
33
34
35 class UpdatablePhysXObject;
36
37 VRECKO_START_MESSAGE_EXTENDED(MessageUpdatablePhysXObjectPtr, UpdatablePhysXObject*)
38 VRECKO_END_MESSAGE
39
40
41 VRECKO_START_MESSAGE_EXTENDED(MessageNxMaterialIndex, NxMaterialIndex)
42 VRECKO_END_MESSAGE
43
44
45
46
47
48 }
49
50
51
52 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PluginManager.h Source File

  • File List
  • File Members
  • include
  • vrecko
PluginManager.h
Go to the documentation of this file.
1 #ifndef PLUGIN_MANAGER_H
2 #define PLUGIN_MANAGER_H
3
4 #include <vrecko/Export>
5 #include <vrecko/Ability.h>
6
7 #include <osgDB/DynamicLibrary>
8
9 #include <map>
10
11 namespace vrecko {
12
21 class VRECKO_EXPORT PluginManager {
22 public:
23 PluginManager() {};
24 ~PluginManager() {};
25
26 static vrecko::Ability *getAbilityInstance(const std::string& plugin_name, const std::string& ability_name);
27 static void *getFuncPtr(std::string dl_name, std::string func_name);
28
29 protected:
30 static std::map<std::string, osgDB::DynamicLibrary *> _dl_map;
31 };
32
33 }
34
35 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PoA.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PoA.h
Go to the documentation of this file.
1 #pragma once
2
3 using namespace vrecko;
4
5 namespace APDYNAMICART
6 {
7
8
9 class DAEnvironment;
10 class Controller;
11
13 typedef enum PoAType {
14 POA__DUMMY = -1,
15 POA__BRUSH_STROKE = 1,
16 POA__MOTION_TRAIL,
17 POA__CHAOTIC_ATTRACTOR,
18 POA__PERLIN_LINE,
19 POA__STRING_SCULPTURES,
20 POA__POLYHEDRA_SCULPTURES,
21 };
22
24
29 typedef enum PoAUpdateType {
30 POA__UPDATE_NONE = 0,
31 POA__UPDATE_DELETE = 1,
32 POA__UPDATE_RENDER,
33 POA__UPDATE_COLOR_CHANGE,
34 POA__UPDATE_DYNAMIC,
35 POA__MT_SAMPLING,
36
37 //EDIT add your new update type(s) here, if necessary
38 };
39
40
42
50 class PoA : public EnvironmentObject
51 {
52 public:
53
54 PoA( Controller* contr);
55 ~PoA();
56
58
63 //virtual std::string createMenuStructure(void) const = 0;
64
66
71 virtual void createMenuStructure(osg::ref_ptr<vreckoUtils::MenuBase> parentMenu) const = 0;
72
77 //virtual void exportMesh();
78
79 PoAUpdateType getUpdateFlag() { return this->_updateFlag; }
80
82 virtual osg::Vec3 getLeftHandPosition() const;
83
85 virtual osg::Quat getLeftHandOrientation() const;
86
88 virtual osg::Vec3 getRightHandPosition() const;
89
91 virtual osg::Quat getRightHandOrientation() const;
92
94
103 virtual int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode) = 0;
104
106
109 virtual void GUIItemClicked(const char* itemID) = 0;
110
112
116 virtual void GUISliderChanged(const char* sliderID, float sliderPos) = 0;
117
119 /*
120 * PoA may change color or something...
121 *
122 * \param pointed is true when user points on PoA and false when user "unpoint" PoA
123 *
124 */
125 virtual void pointed(bool pointed) = 0;
126
128 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode) = 0;
129
131 void setUpdateFlag(PoAUpdateType newType);
132
134 virtual void update() = 0;
135
136 DECLARE_INPUT(Colour, MessageVec4);
137
138 protected:
139
140 //TODO make it const ?? probably not
142 DAEnvironment* _daEnvironment;
143
145 const Controller* _controller;
146
148 PoAUpdateType _updateFlag;
149
150 };
151
153 typedef osg::ref_ptr<PoA> ref_ptr_PoA;
154
155 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/PoB.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
PoB.h
Go to the documentation of this file.
1 #ifndef _DA_POB_H
2 #define _DA_POB_H
3
4
5 #include <osg/Geometry>
6
7
8 using namespace vrecko;
9
10 namespace APDYNAMICART
11 {
12
14 typedef enum PoBType {
15 //TODO remove...
16 POB__ICON = 1,
17 };
18
19
20
22
30 class PoB : public Ability
31 {
32 public:
33
34 PoB(const char* abName);
35 ~PoB();
36
37
39 virtual void clicked() = 0;
40
41 /*
42 * \return name of this PoB
43 */
44 string getpobName() { return this->pobName; }
45
46 /*
47 * \return target of this PoB
48 */
49 string getTarget() { return this->targetName; }
50
52
61 virtual int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoBNode) = 0;
62
64 /*
65 *
66 * When pointed, Icon can switch it geometry (e.g. change color) as visual feedback to user
67 *
68 * TODO bug - when user point to PoB with both hand simultaneously
69 *
70 * \param pointed is true when user points on PoB and false when user "unpoint" PoB
71 *
72 */
73 virtual void pointed(bool pointed) = 0;
74
76 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoBNode) = 0;
77
78
80 /*
81 * solve dynamics - get data from source, compute, send data to target
82 *
83 */
84 virtual void update() = 0;
85
86
87 protected:
88
90 string pobName;
91
93 std::string targetName;
94
95 };
96
97
98 }
99 #endif // _DA_POB_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointAdd.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
PointAdd.h
Go to the documentation of this file.
1 #ifndef _POINT_ADD_H
2 #define _POINT_ADD_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 // tool that splits a wall into two walls
9 class PointAdd : public Tool {
10 public:
11 PointAdd(void) {type=POINTADD;}
12 virtual ~PointAdd(void) {}
13
14 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {
15 if (curWall != NULL) {
16 WG_Wall* newWall;
17 WG_Point* newPoint;
18
19 osg::Vec2 iPoint = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z());
20 osg::Vec2 iNormal = curWall->getVector(WG_Q_POINT);
21
22 osg::Vec2 curNormal(-curWall->getVector(WG_Q_POINT).y(),curWall->getVector(WG_Q_POINT).x());
23
24 osg::Vec2 crossPoint;
25 WG_Geometry::getCrossingPoint(crossPoint, curWall->getPoint(WG_Q_POINT)->getPosition(), curNormal, iPoint, iNormal, false);
26
27 WG_Point* Q = curWall->getPoint(WG_Q_POINT);
28 WG_Point* R = curWall->getPoint(WG_R_POINT);
29
30 osg::Vec2 qVec = Q->getPosition() - crossPoint;
31 osg::Vec2 rVec = R->getPosition() - crossPoint;
32
33 osg::Vec2 mpVector;
34
35 if ((qVec.length() < RE_MIN_LENGTH) || (rVec.length() < RE_MIN_LENGTH)) {
36 logger.warningLog("Cannot split selected wall. Too close to the edge.");
37 }
38 else {
39 newPoint = new WG_Point(crossPoint);
40 newPoint->setId(points->size());
41 points->push_back(newPoint);
42 curWall->setPoint(newPoint, WG_R_POINT);
43 newWall = new WG_Wall(newPoint, R);
44 newWall->setId(walls->size());
45 walls->push_back(newWall);
46 }
47 }
48
49 setDirty(true);
50 }
51 };
52
53 }
54
55 #endif
56
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointInPlaneJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PointInPlaneJoint.h
Go to the documentation of this file.
1 #ifndef PointInPlaneJoint_h
2 #define PointInPlaneJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class PointInPlaneJoint : public BaseJoint
15 {
16 public:
17 PointInPlaneJoint():BaseJoint("PointInPlaneJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
21 {
22 BaseJoint::loadXMLParameters(parametersNode);
23 return true;
24 }
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
26 {
27 return BaseJoint::getXMLParameters(domdocument);
28 }
29
30
31 protected:
32 NxPointInPlaneJointDesc _descripter;
33
34 };
35 }
36
37 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/PointMove.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
PointMove.h
Go to the documentation of this file.
1 #ifndef _POINT_MOVE_H
2 #define _POINT_MOVE_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 // tool that moves with individualpoints of walls
9 // group means that with the point will be moving all connected walls
10 // simple means that just the selected one
11 class PointMove : public Tool {
12 public:
13 PointMove() {type=POINTMOVE;simple=true;}
14 virtual ~PointMove() {}
15
16 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
17 std::string mode = "";
18 if (findXMLNode(pParametersNode, "Mode")) {
19 ReaderWriter::getStringValue(mode, pParametersNode, "Mode");
20 name = mode;
21 }
22 simple = (mode == "simple");
23 return true;
24 }
25
26 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {
27 if (simple && (curWall != NULL) && (curPoint->getWalls()->size()>1)) {
28 PointType Type;
29 if (curWall->getPoint(WG_Q_POINT) == curPoint) {
30 Type = WG_Q_POINT;
31 }
32 else {
33 Type = WG_R_POINT;
34 }
35 osg::Vec2 tempVector = curWall->getVector(Type);
36 if (tempVector.length() <= (RE_MIN_LENGTH + 2.5*RE_DEFAULT_2_WIDTH)) {
37 movingPoint = curPoint;
38 }
39 else {
40 tempVector.normalize();
41 tempVector *= (2.5*RE_DEFAULT_2_WIDTH);
42 movingPoint = new WG_Point(curPoint->getPosition() + tempVector);
43 curWall->setPoint(movingPoint, Type);
44 movingPoint->setId(points->size());
45 points->push_back(movingPoint);
46 }
47 }
48 else
49 movingPoint = curPoint;
50
51 setDirty(true);
52 }
53
54 virtual void update(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray, osg::Vec3& movingVector) {
55 osg::Vec2 tempPosition = movingPoint->getPosition() + osg::Vec2(movingVector.x(), movingVector.z());
56
57 WG_Wall* wall;
58 osg::Vec2 vector, position;
59 osg::Vec2 curVec, minVec = osg::Vec2(10000.0, 10000.0);
60
61 bool oneWall = (movingPoint->getWalls()->size()==1);
62
63 if (oneWall) {
64 wall = movingPoint->getWalls()->at(0).first.get();
65 if (wall->getPoint(WG_Q_POINT) == movingPoint) {
66 position = wall->getPoint(WG_R_POINT)->getPosition();
67 vector = wall->getVector(WG_R_POINT);
68 }
69 else {
70 position = wall->getPoint(WG_Q_POINT)->getPosition();
71 vector = wall->getVector(WG_Q_POINT);
72 }
73 vector.set(-vector.y(), vector.x());
74 }
75
76 WG_Wall* resWall;
77 for (unsigned int i=0; i<walls->size(); i++) {
78 WG_Wall* wallI = walls->at(i).get();
79 resWall = NULL;
80 osg::Vec2 crossPoint;
81 if (oneWall) {
82 // tests length of the selected wall
83 osg::Vec2 tvector = wallI->getVector(WG_Q_POINT);
84 tvector.set(-tvector.y(), tvector.x());
85 osg::Vec2 tposition = wallI->getPoint(WG_Q_POINT)->getPosition();
86
87 if (WG_Geometry::getCrossingPoint(crossPoint, position, vector, tposition, tvector, true)) {
88 curVec = position - crossPoint;
89 if (curVec.length() < minVec.length()) {
90 minVec = curVec;
91 resWall = wallI;
92 }
93 }
94
95 if (resWall != NULL) {
96 tempPosition = (minVec - position)*(-1);
97 }
98 }
99 else {
100 // test if there is another wall in the way of point
101 bool skip = false;
102 for (unsigned int j=0; j<movingPoint->getWalls()->size(); j++) {
103 skip = (wallI == movingPoint->getWalls()->at(j).first.get());
104 if (skip)
105 break;
106 }
107 if (!skip) {
108 WG_Vertices* qV = wallI->getVertices(WG_Q_POINT);
109 WG_Vertices* rV = wallI->getVertices(WG_R_POINT);
110 bool b1 = WG_Geometry::barycentricTest(tempPosition,
111 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
112 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
113 osg::Vec2(rV->getBottomCCWVertex().x(), rV->getBottomCCWVertex().z()));
114 bool b2 = WG_Geometry::barycentricTest(tempPosition,
115 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
116 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
117 osg::Vec2(rV->getBottomCWVertex().x(), rV->getBottomCWVertex().z()));
118 if (b1 || b2)
119 return;
120 }
121 }
122 }
123
124 // tests length and angles of all walls and their neighbours on both sides of the walls
125 for (unsigned int k=0; k<movingPoint->getWalls()->size(); k++) {
126 WG_Wall* wallK = movingPoint->getWalls()->at(k).first.get();
127 PointType ptype = movingPoint->getWalls()->at(k).second;
128 PointType opptype = (ptype == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
129
130 osg::Vec2 length = wallK->getPoint(opptype)->getPosition() - tempPosition;
131 if (length.length() < RE_MIN_LENGTH)
132 return;
133
134 float angleCW, angleCCW, angle, angleCompare, angleMin;
135 osg::Vec2 v;
136 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCW;
137 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCCW;
138 if (wallK->getPoint(ptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
139 angleCW = wallCW.first->getAngle(wallCW.second);
140 angleCCW = wallCCW.first->getAngle(wallCCW.second);
141 v = wallK->getPoint(opptype)->getPosition() - tempPosition;
142 angle = WG_Geometry::getAngle(v);
143 angleCompare = angleCCW - angle;
144 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
145 wallCCW.first->getVector(WG_Q_POINT).length());
146 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
147 return;
148 angleCompare = angle - angleCW;
149 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
150 wallCW.first->getVector(WG_Q_POINT).length());
151 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
152 return;
153 }
154
155 if (wallK->getPoint(opptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
156 angleCW = wallCW.first->getAngle(wallCW.second);
157 angleCCW = wallCCW.first->getAngle(wallCCW.second);
158 v = tempPosition - wallK->getPoint(opptype)->getPosition();
159 angle = WG_Geometry::getAngle(v);
160 angleCompare = angleCCW - angle;
161 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
162 wallCCW.first->getVector(WG_Q_POINT).length());
163 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
164 return;
165 angleCompare = angle - angleCW;
166 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
167 wallCW.first->getVector(WG_Q_POINT).length());
168 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
169 return;
170 }
171 }
172
173
174 // after setting new position, it is needed to recompute vertices
175 movingPoint->setPosition(tempPosition);
176 for (unsigned int l=0; l<movingPoint->getWalls()->size(); l++) {
177 PointType typeL = (movingPoint->getWalls()->at(l).second == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
178 WG_Wall* wallL = movingPoint->getWalls()->at(l).first.get();
179 wallL->computeAttrVectorsAndAngles();
180 wallL->computeAttrVertices();
181 for (unsigned int m=0; m<wallL->getPoint(typeL)->getWalls()->size(); m++)
182 wallL->getPoint(typeL)->getWalls()->at(m).first->computeAttrVertices();
183 }
184 setDirty(true);
185 }
186
187 virtual void terminate(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {
188
189 // aplies snapping
190 if (movingPoint->getWalls()->size()==1) {
191 WG_Wall* crossedWall = NULL;
192 WG_Wall* mpWall = movingPoint->getWalls()->at(0).first.get();
193 osg::Vec2 vertexCW;
194 osg::Vec2 vertexCCW;
195 mpWall->computeAttrVertices();
196 if (WG_Q_POINT == movingPoint->getWalls()->at(0).second) {
197 vertexCW = mpWall->getVertices(WG_Q_POINT)->getNormalCWVertex();
198 vertexCCW = mpWall->getVertices(WG_Q_POINT)->getNormalCCWVertex();
199 }
200 else {
201 vertexCW = mpWall->getVertices(WG_R_POINT)->getNormalCWVertex();
202 vertexCCW = mpWall->getVertices(WG_R_POINT)->getNormalCCWVertex();
203 }
204
205 for (unsigned int i=0; i<walls->size(); i++) {
206 WG_Wall* wallI = walls->at(i).get();
207 WG_Vertices* qV = wallI->getVertices(WG_Q_POINT);
208 WG_Vertices* rV = wallI->getVertices(WG_R_POINT);
209 bool b1 = WG_Geometry::barycentricTest(movingPoint->getPosition(),
210 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
211 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
212 osg::Vec2(rV->getBottomCCWVertex().x(), rV->getBottomCCWVertex().z()));
213 bool b2 = WG_Geometry::barycentricTest(movingPoint->getPosition(),
214 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
215 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
216 osg::Vec2(rV->getBottomCWVertex().x(), rV->getBottomCWVertex().z()));
217 if (b1 || b2) {
218 if (wallI != mpWall) {
219 crossedWall = wallI;
220 i=walls->size();
221 }
222 }
223 }
224
225 if (crossedWall != NULL) {
226 WG_Point* resQ = crossedWall->getPoint(WG_Q_POINT);
227 osg::Vec2 resQvector = crossedWall->getVector(WG_Q_POINT);
228 WG_Point* resR = crossedWall->getPoint(WG_R_POINT);
229 WG_Wall* newWall = NULL;
230
231 osg::Vec2 crossPoint;
232
233 osg::Vec2 mpNormal = osg::Vec2(-mpWall->getVector(WG_Q_POINT).y(), mpWall->getVector(WG_Q_POINT).x());
234 osg::Vec2 qNormal = osg::Vec2(-resQvector.y(), resQvector.x());
235
236 if (WG_Geometry::getCrossingPoint(crossPoint, movingPoint->getPosition(), mpNormal, resQ->getPosition(), qNormal, false)) {
237 osg::Vec2 resQvec = resQ->getPosition() - crossPoint;
238 osg::Vec2 resRvec = resR->getPosition() - crossPoint;
239 if (resQvec.length() < resRvec.length()) {
240 if (resQvec.length() < RE_MIN_LENGTH) {
241 mpWall->setPoint(resQ, movingPoint->getWalls()->at(0).second);
242 }
243 else {
244 movingPoint->setPosition(crossPoint);
245 newWall = new WG_Wall(resR, movingPoint);
246 newWall->setId(walls->size());
247 walls->push_back(newWall);
248 crossedWall->setPoint(movingPoint, WG_R_POINT);
249 }
250 }
251 else {
252 if (resRvec.length() < RE_MIN_LENGTH) {
253 mpWall->setPoint(resR, movingPoint->getWalls()->at(0).second);
254 }
255 else {
256 movingPoint->setPosition(crossPoint);
257 newWall = new WG_Wall(resR, movingPoint);
258 newWall->setId(walls->size());
259 walls->push_back(newWall);
260 crossedWall->setPoint(movingPoint, WG_R_POINT);
261 }
262 }
263 crossedWall->computeAttrVectorsAndAngles();
264 mpWall->computeAttrVectorsAndAngles();
265 crossedWall->computeAttrVertices();
266 mpWall->computeAttrVertices();
267 if (newWall) {
268 newWall->computeAttrVertices();
269 newWall->computeAttrVertices();
270 }
271 }
272 else
273 logger.warningLog("Cannot merge the walls.");
274 }
275 }
276
277 setDirty(true);
278 }
279
280 private:
281 bool simple;
282 WG_Point* movingPoint;
283 };
284
285 }
286
287 #endif
288
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PointOnLineJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PointOnLineJoint.h
Go to the documentation of this file.
1 #ifndef PointOnLineJoint_h
2 #define PointOnLineJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class PointOnLineJoint : public BaseJoint
15 {
16 public:
17 PointOnLineJoint():BaseJoint("PointOnLineJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
21 {
22 BaseJoint::loadXMLParameters(parametersNode);
23 return true;
24 }
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
26 {
27 return BaseJoint::getXMLParameters(domdocument);
28 }
29
30
31 protected:
32 NxPointOnLineJointDesc _descripter;
33
34 };
35 }
36
37 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
PointShell_Object_Data.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_OBJECT_DATA_H
2 #define POINTSHELL_OBJECT_DATA_H
3
4 #include <list>
5 #include <vector>
6 #include <stack>
7 #include <string>
8
9 #include "PointShell_Object_Data_LOD_Builder.h"
10
11 #include "GeometryLoaderBase.h"
12 #include "SP_Object_Data_Base.h"
13 #include <vrecko/Ability.h>
14 #include <vrecko/Scene.h>
15 #include <helpers/DynamicTree.h>
16 #include <helpers/BufFile.h>
17
18 #include <osg/BoundingBox>
19 #include <osg/PolygonMode>
20 #include <osg/StateSet>
21 #include <osg/Geode>
22 #include <osg/ShapeDrawable>
23 #include <osg/Material>
24 #include <osg/Geometry>
25
26
27 #define FACE(x) ((FaceBase*)getFace(x))
28 #define VERTEX(x) ((VertexBase*)getVertex(x))
29
30 namespace APSpacePartitioning {
31
32 template <class _NodeType>
33 class PointShellGeneric_Object_Data: public GeometryLoaderBase, public SP_Object_Data_Base {
34 public:
35
36 /*
37 * enumeration list of supported pointshell creatin lists
38 */
39 enum CreationType {
40 LOD_Hierarchy,
41 Simple,
42 ByVoxels_SingleLevel,
43 ByVoxels_MultiLevel,
44 Test
45 };
46
47 CreationType creationType;
49 PointShellGeneric_Object_Data(const char *abName);
50 ~PointShellGeneric_Object_Data();
51
52 virtual bool isHierarchyCreated() { return bCreated;}
56 vector<pair<osg::Vec3f,osg::Vec3f>> getPolygons(){
57 vector<pair<osg::Vec3f,osg::Vec3f>> out;
58 for (int p = 0 ; p < polygonsCount; p++) {
59 out.push_back(make_pair(polygons[p].first,polygons[p].second));
60 }
61 return out;
62 }
66 vector<pair<osg::Vec3f,float>> getDrawSpheres(){
67 vector<pair<osg::Vec3f,float>> out;
68 PointShell_SimpleNode* child = treeLOD.GetRoot()->lpChild;
69 while (child->lpNext){
70 out.push_back(make_pair(child->pos,child->radius));
71 child = child->lpNext;
72 }
73 return out;
74 }
75
76 virtual int getPolygonsCount(){return getFaceCount();}
78 virtual void destroyPointShells();
79 virtual void destroyPointShell(CreationType type);
84 int getPointShellSize(){
85 if (creationType == LOD_Hierarchy) {
86 return treeLOD.GetCount();
87 } else if (creationType == Simple){
88 return treeSimple.GetCount();
89 } else if (creationType == ByVoxels_SingleLevel){
90 return treeSingleLevel.GetCount();
91 } else if (creationType == ByVoxels_MultiLevel){
92 return treeMultiLevel.GetCount();
93 }
94 return NULL;
95 }
99 _NodeType* getRoot(){
100 if (creationType == LOD_Hierarchy) {
101 return treeLOD.GetRoot();
102 } else if (creationType == Simple){
103 return treeSimple.GetRoot();
104 } else if (creationType == ByVoxels_SingleLevel){
105 return treeSingleLevel.GetRoot();
106 } else if (creationType == ByVoxels_MultiLevel){
107 return treeMultiLevel.GetRoot();
108 }
109 return NULL;
110
111 }
112
113 /*
114 * returns the top node (Root) of the tree by requested CreationType
115 */
116 _NodeType* getRoot(CreationType type) {
117 if (type == Simple) {
118 return treeSimple.GetRoot();
119 } else if (type == LOD_Hierarchy) {
120 return treeLOD.GetRoot();
121 } else if (type == ByVoxels_SingleLevel){
122 return treeSingleLevel.GetRoot();
123 } else if (type == ByVoxels_MultiLevel){
124 return treeMultiLevel.GetRoot();
125 }
126 return NULL;
127 }
128 float maxDist;
129 osg::Vec3f maxDistVect;
131 int getCollisions(int id){getNodeWithIDFromTree( treeCollisions.getRoot(), id);}
133 protected:
134 pair<osg::Vec3f,osg::Vec3f>* polygons;
135 int polygonsCount;
137 DynamicTree<_NodeType> treeSimple;
138 DynamicTree<_NodeType> treeLOD;
139 DynamicTree<_NodeType> treeSingleLevel;
140 DynamicTree<_NodeType> treeMultiLevel;
142 bool treeLODCreated;
143 bool treeSimpleCreated;
144 bool treeSingleLevelCreated;
145 bool treeMultiLevelCreated;
147 int rootSizeLOD;
148 int rootSizeSimple;
149 int rootSizeMulti;
150 int rootSizeSingle;
151 int rootSizeCollisions;
153 bool bCreated;
155 void buildLODTree();
157 bool loadTreeFromFile(vrecko::BufferedFile *bfile,DynamicTree<_NodeType>* t );
158 bool loadNodeFromFileRec(_NodeType *node, vrecko::BufferedFile *bfile, DynamicTree<_NodeType>* t ); // recursive load
159
160 bool saveTreeToFile(vrecko::BufferedFileWrite *bfile,DynamicTree<_NodeType>* t );
161 bool saveNodeToFileRec(_NodeType *node, vrecko::BufferedFileWrite *bfile); // recursive save
162
163 //for testing purposes
164 bool savePointShellCollisions();
165
166 bool ready(){
167 treeSimpleCreated = (treeSimple.GetCount() > 0);
168 treeLODCreated = (treeLOD.GetCount() > 0);
169 treeSingleLevelCreated = (treeSingleLevel.GetCount() > 0);
170 treeMultiLevelCreated = (treeMultiLevel.GetCount() > 0);
171
172 if (creationType == LOD_Hierarchy) {
173 bCreated = treeLODCreated;
174 } else if ( creationType == Simple){
175 bCreated = treeSimpleCreated;
176 } else if ( creationType == ByVoxels_SingleLevel) {
177 bCreated = treeSingleLevelCreated;
178 } else if ( creationType == ByVoxels_MultiLevel) {
179 bCreated = treeMultiLevelCreated;
180 }
181
182 return bCreated;
183 }
184 virtual bool coreHierarchyCreation(void);
185 };
186
187
188 class PointShell_SimpleNode : public DynTreeNode<PointShell_SimpleNode> {
189 public:
190 osg::Vec3 pos;
191 osg::Vec3 iNorm; // inward normal (opposite of the usual normal!)
192 float radius;
193 int id;
194 int collisions;
195
196 bool loadDataFromFile(vrecko::BufferedFile *bfile) {
197 return
198 bfile->readFloat(&pos.x()) &&
199 bfile->readFloat(&pos.y()) &&
200 bfile->readFloat(&pos.z()) &&
201 bfile->readFloat(&iNorm.x()) &&
202 bfile->readFloat(&iNorm.y()) &&
203 bfile->readFloat(&iNorm.z()) &&
204 bfile->readFloat(&radius) &&
205 bfile->readInt(&id) &&
206 bfile->readInt(&collisions);
207 }
208
209 bool saveDataToFile(vrecko::BufferedFileWrite *bfile) {
210 return
211 bfile->writeFloat(pos.x()) &&
212 bfile->writeFloat(pos.y()) &&
213 bfile->writeFloat(pos.z()) &&
214 bfile->writeFloat(iNorm.x()) &&
215 bfile->writeFloat(iNorm.y()) &&
216 bfile->writeFloat(iNorm.z()) &&
217 bfile->writeFloat(radius) &&
218 bfile->writeInt(id) &&
219 bfile->writeInt(collisions);
220 }
221 };
222
223
224 class PointShell_Object_Data: public PointShellGeneric_Object_Data<PointShell_SimpleNode> {
225 public:
226 PointShell_Object_Data();
227 ~PointShell_Object_Data();
228
229 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
230
231 float fMaxDistance;
232 float getMaximumDistance();
233 int getPointShellRootSize();
234 osg::Vec3f getMaximumDistanceVector();
235
236 osg::Vec4f PointShell_Object_Data::getColor(int collisions){
237 float percentage = (float)collisions/(float)collisionsMax;
238 if (collisionsMax == 0) collisionsMax++;
239 //(log(x+1)*1.4)^0.5 where x = 0 to 1
240 float c = (float)collisions/(float)collisionsMax;
241 // c (x) is now 0 to 1
242 float cR = pow(log(c+1)*1.4,0.5);
243 osg::Vec4f color;
244 float red = min(cR/0.5f,1.0f);
245 float green = min((1-cR)/0.5f,1.0);
246 float blue = 0;
247 color.set(red,green,blue,1.0);
248 return color;
249 }
250
251 protected:
252 void createSimple(); // simple hierarchy creation (onlu vertices are taken)
253 void createLODHierarchy(); // LOD hierarchyh based on LOD Progressive Mesh decimation
254 void createSingleLevel(double minx, double miny, double minz, double velm); // unknown
255 void createMultiLevel(double minx, double miny, double minz, double velm); // unknown
256
257 // comutation of Bounding boxes for hierarchy
258 void computeBBoxSheresRadius(DynamicTree<PointShell_SimpleNode>* tree);
259 void computeBBoxShereRadius(PointShell_SimpleNode* node);
260
261 //createds a LOD Tree from given lodbuilder
262 void buildLODTree(PointShell_Object_Data_LOD_Builder* lod_builder);
263 //inserting a point into a tree as a child of p.
264 void insertPointsInLODTree(PointShell_Object_Data_LOD_Builder* lod_builder,PointShell_SimpleNode* p,int id);
265
266 // save a subdivided mesh to file to not compute again
267 bool loadSubDivisionMeshFromFile(vrecko::BufferedFile *bfile);
268 // load a subdivided mesh
269 bool saveSubDivisionMeshToFile(vrecko::BufferedFileWrite *bfile);
270
271 int voxResolution; // resolution of the voxel grid used when creating the PointShell SingleLevel/MultiLevel
272 int spBranchingFactor; // Controls the creation of different PointShell hierarchy levels.
273 // Size of the n-th level is "spBranchingFactor ^ n"
274
275 // lod parameters
276 float lodEdgeImporatnce;
277 float lodEdgeDistanceImportance;
278 float lodVertexImporatnce;
279 int lodZeroLevelSize;
280 bool lodMovableVertices;
281 float lodPercentageZeroLevelSize;
282 int lodMaxLevels;
283 int lodMinimumVertices;
284
285 // stored collisions amounth
286 int collisionsTotal;
287 int collisionsMax;
288
289 struct PSpoint {
290 double x,y,z;
291 double a,b,c;
292 };
293
294 vector<PSpoint> voxels;
295 vector<PSpoint> ordered;
296 vector< vector<PSpoint> > levels;
297
298 inline double distance_sqr(PSpoint *voxel1, PSpoint *voxel2) {
299 return (pow(voxel2->x - voxel1->x, 2) + pow(voxel2->y - voxel1->y, 2) + pow(voxel2->z - voxel1->z, 2));
300 }
301
302 inline double distance(PSpoint *voxel1, PSpoint *voxel2) {
303 return (sqrt(distance_sqr(voxel1, voxel2)));
304 }
305
306 bool constructPointShellCacheDataName(char *pOutDataName);
307 bool constructPointShellCacheDataName(char *pOutDataName, CreationType type);
308 bool constructPointShellSubdividedMeshDataName(char *pOutDataName);
309
310 bool loadFromCache(const char *pModelFileName); // -> depending on the options there can be many caches for a single model
311 bool saveToCache(const char *pModelFileName);
312
313 virtual bool coreHierarchyCreation(void);
314
315 // saving pointshell collisions
316 bool savePointShellCollisions();
317 PointShell_SimpleNode* getNodeWithIDFromTree(PointShell_SimpleNode* topNode, int ID);
318
319 void getCollisionsFromTree(PointShell_SimpleNode* node);
320
321 };
322
323
324 template <class _NodeType>
325 PointShellGeneric_Object_Data<_NodeType>::PointShellGeneric_Object_Data(const char *abName) : GeometryLoaderBase(), SP_Object_Data_Base(abName) {
326 bCreated = false;
327 }
328
329
330 template <class _NodeType>
331 PointShellGeneric_Object_Data<_NodeType>::~PointShellGeneric_Object_Data() {
332 destroyPointShells();
333 delete [] polygons;
334 }
335
336
337 template <class _NodeType>
338 bool PointShellGeneric_Object_Data<_NodeType>::coreHierarchyCreation(void) {
339
340 if (!pOwner)
341 return false;
342
343 destroyPointShell(Simple);
344
345 if (!loadGeometry((EnvironmentObject*)pOwner)) {
346 logger.warningLog("PointShell generation aborted - no geometry found (Obj ID: %d).", ((EnvironmentObject*)pOwner)->getID());
347 return false;
348 }
349
350
351 PointShell_SimpleNode* node;
352
353 node = new PointShell_SimpleNode(); // empty root
354 treeSimple.AddNode(NULL, node);
355
356 for (unsigned long dw = 0; dw < getVertexCount(); dw++) {
357 // transfer vertices into the PointShell structure
358 node = new PointShell_SimpleNode();
359 node->pos = ((VertexBase*)getVertex(dw))->pos;
360 node->iNorm = -((VertexBase*)getVertex(dw))->normal;
361 treeSimple.AddNode(treeSimple.GetRoot(), node);
362 }
363
364 //computation of maximum distance in object
365 //and storing a maximum distance of vector.
366 osg::Vec3f v1, v2;
367 for (int s = 0; s < (int)getVertexCount();s++){
368 v1 = ((VertexBase*)getVertex(s))->pos;
369 for (int e = 0;e < (int)getVertexCount();e++){
370 v2 = ((VertexBase*)getVertex(e))->pos;
371 if (maxDist < (v1-v2).length2()){
372 maxDist = (v1-v2).length2();
373 maxDistVect.set((v1-v2).x(),(v1-v2).y(),(v1-v2).z());
374 }
375 }
376 }
377 maxDist = sqrt(maxDist);
378
379 bCreated = true;
380
381 return true;
382 }
383
384
385 template <class _NodeType>
386 void PointShellGeneric_Object_Data<_NodeType>::destroyPointShells() {
387 treeSimple.Clear(true);
388 treeLOD.Clear(true);
389 treeSingleLevel.Clear(true);
390 treeMultiLevel.Clear(true);
391
392 bCreated = false;
393 }
394
395 template <class _NodeType>
396 void PointShellGeneric_Object_Data<_NodeType>::destroyPointShell(CreationType type) {
397 if (type == Simple) {
398 treeSimple.Clear(true);
399 } else if (type == LOD_Hierarchy){
400 treeLOD.Clear(true);
401 } else if (type == ByVoxels_SingleLevel) {
402 treeSingleLevel.Clear(true);
403 } else if (type == ByVoxels_MultiLevel) {
404 treeMultiLevel.Clear(true);
405 }
406
407 bCreated = false;
408 }
409
410
411 template <class _NodeType>
412 bool PointShellGeneric_Object_Data<_NodeType>::loadTreeFromFile(vrecko::BufferedFile *bfile, DynamicTree<_NodeType>* t ) {
413 int i;
414
415 t->Clear(true);
416
417 if (!bfile->readInt(&i) || (i != 1)) // version
418 return false;
419
420 bool b;
421 if (!bfile->readBool(&b))
422 return false;
423
424 if (!b) // -> not even a root node, we are done here
425 return true;
426
427 t->AddNode(NULL, new PointShell_SimpleNode()); // simple root node
428
429 if (!loadNodeFromFileRec(t->GetRoot(), bfile,t))
430 return false;
431
432 return true;
433 }
434
435
436 template <class _NodeType>
437 bool PointShellGeneric_Object_Data<_NodeType>::loadNodeFromFileRec(_NodeType *node, vrecko::BufferedFile *bfile, DynamicTree<_NodeType>* t) {
438
439 if (!node->loadDataFromFile(bfile))
440 return false;
441
442 _NodeType *child;
443 bool b;
444 while (true) {
445 bfile->readBool(&b);
446 if (!b) // no more children
447 break;
448
449 child = new PointShell_SimpleNode();
450 if (!(t->AddNode(node, child)))
451 return false;
452
453 if (!loadNodeFromFileRec(child, bfile,t))
454 return false;
455
456 }
457
458 return true;
459 }
460
461
462 template <class _NodeType>
463 bool PointShellGeneric_Object_Data<_NodeType>::saveTreeToFile(vrecko::BufferedFileWrite *bfile, DynamicTree<_NodeType>* t) {
464 bfile->writeInt(1); // version
465
466 if (!(t->GetRoot())) {
467 bfile->writeBool(false);
468 } else {
469 bfile->writeBool(true);
470 if (!saveNodeToFileRec(t->GetRoot(), bfile))
471 return false;
472 }
473
474 return true;
475 }
476
477
478 template <class _NodeType>
479 bool PointShellGeneric_Object_Data<_NodeType>::saveNodeToFileRec(_NodeType *node, vrecko::BufferedFileWrite *bfile) {
480 if (!node->saveDataToFile(bfile))
481 return false;
482
483 _NodeType *child = node->lpChild;
484 while (child) {
485 bfile->writeBool(true); // i.e. next child exists
486 saveNodeToFileRec(child, bfile);
487 child = child->lpNext;
488 }
489 bfile->writeBool(false); // i.e. there is no next child
490
491 return true;
492 }
493
494 } // namespace APSpacePartitioning
495
496
497 #endif
498
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
PointShell_Object_Data_Geometry.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_OBJECT_DATA_GEOMETRY_H
2 #define POINTSHELL_OBJECT_DATA_GEOMETRY_H
3
4 namespace APSpacePartitioning {
5
6 class PointShell_Object_Data_Geometry {
7
8 public :
9
10 struct V{
11 osg::Vec3f pos; // position of vertex
12 osg::Vec3f norm; // real normal of a vertex
13 };
14
15 struct E{
16 int v1ID;
17 int v2ID;
18 };
19
20 struct P{
21 int v1ID;
22 int v2ID;
23 int v3ID;
24 osg::Vec3f norm;
25 };
26
27 PointShell_Object_Data_Geometry(){};
28 virtual ~PointShell_Object_Data_Geometry(){};
29
30 virtual void setVerticesCount(int count) = 0;
31 virtual void setPolygonsCount(int count) = 0;
32 virtual void setEdgesCount(int count) = 0;
33
34 virtual void writeVertex(int seqnum,osg::Vec3f pos, osg::Vec3f norm) = 0; // writes a new vertex into a mesh
35 virtual void writeVertex(int seqnum,osg::Vec3f pos) = 0; // writes a new vertex into a mesh
36 virtual void writeEdge(int seqnum,int vertexPos1, int vertexPos2) = 0; // writes an edge into a mesh
37 virtual void writePolygon(int seqnum, int v1, int v2, int v3) = 0; // writes a new polygon in a mesh
38
39 virtual vector<PointShell_Object_Data_Geometry::V> getVertices() = 0; // returns all vertices of geometry
40 virtual vector<PointShell_Object_Data_Geometry::E> getEdges() = 0; // returns all edges of geometry
41 virtual vector<PointShell_Object_Data_Geometry::P> getPolygons() = 0; // returns all polygons of geometry
42
43 virtual PointShell_Object_Data_Geometry::V getVertex(int seqnum) = 0; // returns a vertex
44
45 };
46 }
47 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_Geometry_Analyser.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
PointShell_Object_Data_Geometry_Analyser.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_OBJECT_DATA_GEOMETRY_ANALYSER_H
2 #define POINTSHELL_OBJECT_DATA_GEOMETRY_ANALYSER_H
3
4 #include "pointshell_object_data_geometry.h"
5
6 namespace APSpacePartitioning {
7
8 class PointShell_Object_Data_Geometry_Analyser : public PointShell_Object_Data_Geometry{
9
10 public :
11
12 struct VExt: public PointShell_Object_Data_Geometry::V{
13 osg::Vec3f comNorm; //normal used for computaions
14 int id; // ID of this vertex // used only for outPut
15 list<int> polygons;
16 list<int> edges;
17 };
18
19 struct EExt : public PointShell_Object_Data_Geometry::E{
20 float length;
21 int p1ID;
22 int p2ID;
23 };
24
25 struct PExt : public PointShell_Object_Data_Geometry::P{
26 float size;
27 int e1ID;
28 int e2ID;
29 int e3ID;
30 osg::Vec3f norm;
31 };
32
33 PointShell_Object_Data_Geometry_Analyser();
34 ~PointShell_Object_Data_Geometry_Analyser(){};
35
36 void setVerticesCount(int count);
37 void setPolygonsCount(int count);
38 void setEdgesCount(int count);
39
40 void writeVertex(int seqnum,osg::Vec3f pos, osg::Vec3f norm); // writes a new vertex into a mesh
41 void writeVertex(int seqnum,osg::Vec3f pos); // writes a new vertex into a mesh
42 void writeEdge(int seqnum,int vertexPos1, int vertexPos2); // writes an edge into a mesh
43 void writeEdge(int seqnum,int vertexPos1, int vertexPos2, int polygonPos1, int polygonPos2); // writes an edge in to a mesh
44 void writePolygon(int seqnum, int v1, int v2, int v3); // writes a new polygon in a mesh
45
46 void finishStructureBuild();
47
48 vector<PointShell_Object_Data_Geometry::V> getVertices(); // returns all vertices of geometry
49 vector<PointShell_Object_Data_Geometry::E> getEdges(); // returns all edges of geometry
50 vector<PointShell_Object_Data_Geometry::P> getPolygons(); // returns all polygons of geometry
51
52 PointShell_Object_Data_Geometry::V getVertex(int seqnum); // returns a vertex at position seqnum
53
54 float getMaxDistance(); // returns maximum distance in object. Computed by vertices.
55 osg::Vec3f getMaxDistanceVector(); // returns maximum distance vector. Computed by vertices.
56
57 protected:
58 #define FIELD_SIZE 200000
59 VExt vertices[FIELD_SIZE];
60 EExt edges[3*FIELD_SIZE - 2];
61 PExt polygons[2*FIELD_SIZE -2];
62 int iVerticesCount;
63 int iEdgesCount;
64 int iPolygonsCount;
65
66 float maxDistance;
67 int maxDistanceV1;
68 int maxDistanceV2;
69
70 void calculateEdgesLength(); // calculates length of ALL edges
71 void calculateEdgeLength(int edge); // calculate length of required edge
72
73 void calculateNormalOfPolygons(); // calcluates normals of ALL polygons
74 void calculateNormalOfPolygon(int seqnum); // calculate normal of required polygon
75
76 void calculateVerticesNormals(); // calculate normals of vertices
77 void calculateVertexNormal(int seqnum); // calculate normals of vertex
78
79 void cleanVertexEdges(); // cleans vertex edges from duplicities
80
81 void handleEdges(int polygon); // for a polygon the new edges are created or the polygons edges ID's are set
82 vector<int> getEdges(int polygon);
83 };
84 }
85 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShell_Object_Data_LOD_Builder.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
PointShell_Object_Data_LOD_Builder.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_OBJECT_DATA_LOD_BUILDER_H
2 #define POINTSHELL_OBJECT_DATA_LOD_BUILDER_H
3
4 #include <list>
5 #include <vector>
6 #include <queue>
7 #include <helpers/DynamicTree.h>
8 #include "String"
9 #include "PointShell_Object_Data_Geometry_Analyser.h"
10
11 namespace APSpacePartitioning {
12
13 class mycomparisonMinMax
14 {
15 public:
16 mycomparisonMinMax(){}
17
18 bool operator() (const std::pair<float,int>& first, const std::pair<float,int>& second) const{
19 if (first.first >= second.first){
20 return true;
21 } else {
22 return false;
23 }
24 }
25 };
26
27 class mycomparisonMaxMin
28 {
29 public:
30 mycomparisonMaxMin(){}
31
32 bool operator() (const std::pair<float,int>& first, const std::pair<float,int>& second) const{
33 if (first.first >= second.first){
34 return false;
35 } else {
36 return true;
37 }
38 }
39 };
40
41 struct VLOD : public PointShell_Object_Data_Geometry::V{
42 osg::Vec3f comPos; // position of a vertex used for coputation
43 osg::Vec3f comNorm; //normal used for computaions
44 int level; // level of vertice in a tree
45 int ancestor; // ancestor of a vertice in a tree
46 list<int> edges; // list of edges that has this vertex
47 list<int> childs; // list of childs in a tree
48 int id; // ID of this vertex // used only for outPut
49 float radius; // computation of bounding spheres
50 bool leaf; // points wheather this vertex is a leaf or not in a tree
51 float importance; // computed as an avarage deviation of angles of normals of polygons to normal of point.
52 bool visible; // false - the vertex has already been removed due to reduction
53 bool valid; // false means that the vertex may not be removed // special conditions
54 };
55
56 struct ELOD : public PointShell_Object_Data_Geometry::E{
57 float importance; // imporatnce of this edge
58 float dist; // length of a edge
59 float cost; // cost of a vertice
60 int id;
61 int p1,p2; // polygons adjacent to this edge
62 bool valid; // used to set edge as imporatnt or unable to remove. Edges with valid set to false will not be romoved or reduced.
63 bool visible; // used for checking if we are not lookng during a reduction to already reduced edges. Removed.
64 list<int> requiredDeletedEdges; // list of pairs of edges that al least one has to be removed from a queue before reduction of this is allowed
65 bool edgeCostRecompute; // TRUE declares that the edge may be recomputed.
66 };
67
68 struct PLOD : public PointShell_Object_Data_Geometry::P{
69 osg::Vec3f norm; // normal of this polygon
70 int e1,e2,e3; // edges of this polygon
71 bool visible; // used for checking wheather this polygon has already been removed or not.
72 int id;
73 };
74
75 // just for internal use
76 struct int_3{
77 int i1;
78 int i2;
79 int i3;
80 };
81
82 class PointShell_Object_Data_LOD_Builder : public PointShell_Object_Data_Geometry{
83 public:
84 PointShell_Object_Data_LOD_Builder();
85 ~PointShell_Object_Data_LOD_Builder();
86 void Clear();
87 // outbound communication
88 string getStatusResult(); // return in words the status after reduction.
89 int getZeroLevelSize(); // send a real zero level Size -- after computing it from percentage or by setting it.
90 int getPolygonsCount(){return iPolygonsCount;}; // returns polygons count
91
92 // inbound communication
93 void setVerticesCount(int count); // sets the total count of a vertices in mesh
94 void setPolygonsCount(int count); // sets the total count of polygons in a mesh
95 void setEdgesCount(int count); // sets the total count of edges in a mesh
96 void setParameters(float lodEI, float lodEDI, float lodVI); // sets the imporatnce of 3 paramaters, lodEI - EdgeImporantce, lodEDI - EdgeDistance Imporatnce, lodVI - Vertex Imporatnce
97 void setMovableVertices(bool value); // sets wheater the new vertices should move or not after reduction
98 void setLevelZeroSize(int size,float percentage); // sets the size of a 0 level size.
99 void setFileName(string name); // sets the filename of a mesh which will be loaded.
100 void setMaxLevels(int levels); // sets maximal levels for a pointshell hierarchy
101 void setMaxChildrens(int maxChild); // sets maximum children per vertex
102 void setMinimumVertices(int minimum); //sets minimum of vertices that pointshell has to have
103
104 // writing mesh into
105 void writeVertex(int seqnum,osg::Vec3f pos, osg::Vec3f norm); // writes a new vertex into a mesh
106 void writeVertex(int seqnum,osg::Vec3f pos); // writes a new vertex into a mesh
107 void writeEdge(int seqnum, int vertexPos1, int vertexPos2); // writes en edge into a mesh at selected position
108 void writeEdge(int seqnum, int vertexPos1, int vertexPos2, int polygon1, int polygon2); // writes en edge int oa mesh at selected position with additional parametres
109 void writePolygon(int seqnum, int v1, int v2, int v3); // writes a new polygon in a mesh
110
111 // commands to print out statuses
112 void printOutQueue(); // prints out the whole queue at a actual state
113 void printOutStatus(); // prints out the status in a short version
114 void printOutVerbouseStatus(); // prints out the status in short version and all vertices,edges and polygons
115
116 // commands for actions
117 void computeRadiusOfBoundingSpheres(); // computing distance for each verex to its child (!for all childs of childs ... )
118 void mergeLevels(); // merging levels in a tree
119 void finishStructureBuild(); // finish creation of a reduction structure. Prepares for building the ReductionLevelStructure
120 int subdivideMesh(); // subdivide mesh structure
121 int buildReductionLevelStructure(); // builds queue, reduce queue, sets level of vertices and sets leafes and childs. Returns specialCase
122
123 // for actual build of a LOD Tree
124 int getMaxLvl(); //returns maximal Lvl found in a vertices
125 vector<VLOD> getLvlVertices(int lvl); // returns all vertices with rewuired level
126 vector<VLOD> getVertices(int seqNum); // returns all childs of a required vertice
127 vector<VLOD> getRoots(); // used for output. Returns all vertices with level 0
128
129 //for actual output
130 vector<PointShell_Object_Data_Geometry::V> getVertices(); // returns all vertices of geometry
131 vector<PointShell_Object_Data_Geometry::E> getEdges(); // returns all edges of geometry
132 vector<PointShell_Object_Data_Geometry::P> getPolygons(); // returns all polygons of geometry
133
134 PointShell_Object_Data_Geometry::V getVertex(int seqnum); // returns a vertex
135
136 protected:
137 static const bool bDebug = false; // for debug only
138
139 int specialCase; // spiecial case shows the error code of this class
140 bool moveVerticesPosition; // showing wheather calculate new position of vertex after reduction or use the one that has not been removed.
141 bool refillQueue; // used to find out wheather refill the queue or not
142 string filename; // File name of a reducted model // DEVEL not required for runtime version
143 int zeroLevelSize; // set the minimal amount of edges required on a 0 level of hierarchy
144 int maxLevels; //maximum depth of a tree
145 int maxChildrens; //maximum childrens per vertex
146 int minVertices; //minimum vertices that object has to have
147
148 float maxDistance; // maximal distance from edges in model.
149 float lodEdgeImporatnce; // importance of an edge importnace in global cost of edge
150 float lodEdgeDistanceImporatnce; // importance of an edge length in global cost of edge
151 float lodVertexImporatnce; // imporatnce of an vertex inpormtance in global cost of edge
152
153 // definition of a size of fields for edges, vertices and polygons.
154 // note that for size of vertex of X you need an size of polygons of 2X - 2 and for edges 3X-2 !
155 VLOD* vertices;
156 int iVerticesCount;
157 ELOD* edges;
158 int iEdgesCount;
159 PLOD* polygons;
160 int iPolygonsCount;
161
162 // queue of edges waiting to be reduced and for subdivision.
163 priority_queue< pair<float,int>, vector<pair<float,int>>, mycomparisonMinMax > test_Queue;
164 priority_queue< pair<float,int>, vector<pair<float,int>>, mycomparisonMaxMin > test_Subdivision_Queue;
165
166 // saving roots of a tree
167 vector<int> treeRoots;
168
169 // creation of a geometry
170 void handleEdges(int polygon); // for a polygon the new edges are created or the polygons edges ID's are set
171 int_3 getEdges(int polygon); // returns edges of a polygon by checking edges whether they already exists // Chcecking is on basis of checking vertices
172
173 //calulations and setting values on their basis
174 void calculateEdgesLength(); // calculates length of ALL edges
175 void calculateEdgeLength(int edge); // calculate length of required edge
176 void calculateEdgesImportance(); // calculate imporatnce of ALL edges
177 void calculateEdgeImportance(int seqnum); // calculate impratnce of required edges
178 void calculateEdgesCost(); // calculate cost of ALL edges
179 void calculateEdgeCost(int seqnum); // calculate cost of required edge
180 void calculateNormalOfPolygons(); // calcluates normals of ALL polygons
181 void calculateNormalOfPolygon(int seqnum); // calculate normal of required polygon
182 void calculateVerticesNormalAndImporatance(); // calculates normal and Imporatnce of ALL vertices
183 void calculateVertexNormalAndImportance(int seqnum); // calculate imporatance of required vertex
184 void calculateNewVertexPosition(int vertexToSet, int vt[3]); // calculates a new postition for vertexToSet from list of vertices
185
186 // cleaning functions
187 void cleanVertexEdges(); // cleaning vertex edges from dualities and sorting it
188 inline void removeRequiredEdges(int edge); // removes list of required edges to remove first
189
190 // setting a parameters for edges,vertices and polygons
191 inline void setVertexVisible(int vertex, bool visibility); // sets the visibility for the vertex
192 inline void setPolygonVisible(int polygon, bool visibility); // sets the visibility fot the polygon
193 inline void setEdgeVisible(int edge, bool visibility); // sets the visibility fot the edge
194 inline void addRequiredEdge(int edge, int reqEdge);
195 void setValidEdges();
196 inline void setValidEdge(int edge);
197 void setValidVertices();
198 inline void setValidVertex(int vertex, bool value);
199
200 // math
201 inline float getAngle(osg::Vec3f vec1,osg::Vec3f vec2); // returns the angle of two normals/vectors
202 list<int> getSame(int* a, int* b); // returns pair that represents values that are in both fields
203 bool equalArrays(int a1[],int a2[],int size); // returs wheather the two arrays are same by content
204
205 // deciding whather the edge may be reduces by looking at prerequisites
206 bool legalToRemoveEdge(int edge);
207
208 //detection functions
209 inline bool polygonHaveVertex(int polygon, int vertex); // does the polygon has this vertex vertices?
210 inline bool polygonHaveVertices(int polygon, int v1 , int v2); // does the polygon has this vertex?
211 bool have2Polygons2OrMoreVetrticesSame(int p1,int p2); // does 2 polygons have 2 same vetices?
212 inline bool edgesEqualByVertices(int e1, int e2); // are the edges equal by vertices?
213 inline int getSameEdge(int p1,int p2); // returns the same edge of 2 poolygons
214 list<int> getSameEdges(int p1,int p2); // returns a pair of same 2 edges of both polygons
215 bool polygonsEqualsByVertices(int p1, int p2); // are the polygons equal by vertices?
216 inline int getThirdVertex(int polygon, int v1, int v2); //returns third vertex of polygon
217 inline pair<int,int> getOkAndChangeEdges(int polygon, int v1, int edge); // returns edge with v1 that is not edge as first and edge without v1 as second
218
219 // output supporting functions
220 void computeVertexLevels(); // computes levels of vertices
221 void addVerticesLeafsAndChilds(); // prepares the vertice for output add leafs data and childs data!
222
223 // computation of edge properities
224 inline float edgeCost(int edge);
225
226 //returning inline functions
227 inline float edgeLength(int edge); // returns the lenght of edge
228 inline float edgeImportance(int edge); // returns the importance of edge
229 inline float vertexImportance(int vertex); // return the importance of vertex
230
231 // printing functions
232 void printOutList(string log, list<int> edgesList); // prints out the given list
233 void printOutEdge(string log, int edge); // prints out the requested edge
234 void printOutVertex(string log, int vertex); // prints out the requested vertex
235 void printOutPolygon(string log, int polygon); // prints out the requested polygon
236
237 //supporting output functions
238 string intToStr(int number); // int to String
239 string floatToTimeString(float time); // convert time in float (seconds) to String
240
241 // Main Functions
242 void buildQueue(bool verbouse); // builds a queue from data found from edges,
243 int reduceFront(int); // reduce the queue. MAIN LOOP!
244
245 };
246
247 //end of namespace
248 }
249
250 //end of definition POINTSHELL_OBJECT_DATA_LOD_BUILDER_H
251 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/PointShellVSVoxel_Object.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
PointShellVSVoxel_Object.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_VS_VOXEL_OBJECT_H
2 #define POINTSHELL_VS_VOXEL_OBJECT_H
3
4 #include <vrecko/SP_ObjectInterface.h>
5 #include <vrecko/Ability.h>
6
7 #include <vreckoAP/HUD/HUDDisplay.h>
8
9 using namespace vrecko;
10
11 namespace APSpacePartitioning {
12
13
14 #define SP_OBJECT_INTERFACE_ID__PS_VG 30
15
16
17 class PointShellVSVoxel_Object: public SP_ObjectInterface, public Ability {
18 public:
19 PointShellVSVoxel_Object();
20 ~PointShellVSVoxel_Object();
21
22 virtual void preInitialize(void);
23
24 // true - testing mode, false - not testing mode
25 bool bTestComputation;
26 //__int64 freq;
27 bool setTestComputation(bool state){
28 bTestComputation = state;
29 logger.debugLog("PS vs Voxel test mode set to: %s",bTestComputation?"true":"false");
30 return bTestComputation;
31 };
32 bool getCollisions(CollisionParams * params, COLLISION_POINTS_VECTOR ** colPoints, unsigned long obj1ID, unsigned long obj2ID,float time);
33
34 protected:
35 bool getObjectTransformation(EnvironmentObject *pObj, CollisionParams *params, osg::Matrix *outMat);
36
37 LARGE_INTEGER collisiontime1, collisiontime2, looptime1, looptime2, fr;
38 APHUD::HUDDisplay *hud;
39 int objectID;
40 bool hudInitialized ;
41 };
42
43 }
44
45
46
47
48 #endif
49
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/PointShellVSVoxelFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
PointShellVSVoxelFilter.h
Go to the documentation of this file.
1 #ifndef POINTSHELL_VS_VOXEL_FORCE_FILTER
2 #define POINTSHELL_VS_VOXEL_FORCE_FILTER
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 #include "CollisionFilterBase.h"
9
10 namespace vreckoDP_PHANToM {
11
12
13 class PointShellVSVoxelFilter : public CollisionFilterBase {
14 public:
15 PointShellVSVoxelFilter();
16 ~PointShellVSVoxelFilter();
17
18 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
19
20 void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
21
22 protected:
23 };
24
25
26 }
27
28 #endif
29
30 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/PolygonPoint.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
PolygonPoint.h
Go to the documentation of this file.
1 #ifndef POLYGON_POINT
2 #define POLYGON_POINT
3
4 namespace CarSim {
5 // tato struktura urcuje krajni bod (bod polygonu), ktery urcuje
6 // tvar hrany nebo silnice
7 struct PolygonPoint {
8 unsigned int id;
9 // id krizovatky, ke ktere ten bod patri
10 unsigned int junctionId;
11 osg::Vec3 position;
12 };
13 }
14
15 #endif
16
17
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/PolygonState.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
PolygonState.h
Go to the documentation of this file.
1 #ifndef POLYGONSTATE_H
2 #define POLYGONSTATE_H
3
4 #include "../EditorController/ControllableAbility.h"
5
6 namespace APConnectEditor
7 {
8 class PolygonState: public vrecko::ControllableAbility {
9 public:
10 PolygonState() : ControllableAbility("PolygonState") {};
11 virtual ~PolygonState() { deactivate(); };
12
13 protected:
14 virtual void fillDefaultInfo();
15 virtual bool activate();
16 virtual void menuItemClicked(const char* itemID);
17 };
18 }
19
20
21 #endif //POLYGONSTATE_H
22
23
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConstrainedMovement/PolygonUtils.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConstrainedMovement
PolygonUtils.h
Go to the documentation of this file.
1 #ifndef POLYGON_UTILS_H
2 #define POLYGON_UTILS_H
3
4 #include <vector>
5 #include <osg/Vec3>
6 #include <osg/Matrix>
7
8 using namespace std;
9
10 namespace APConstrainedMovement {
11 typedef vector<osg::Vec3> Vecs3;
12
13 // Calculate the area of a triangle
14 float area(osg::Vec3 &point1, osg::Vec3 &point2, osg::Vec3 &point3);
15
16 // Calculate the centroid of a polygon
17 osg::Vec3 centroid(Vecs3 polygon);
18
19 // Calculate the orientation
20 int orientation(float x1, float y1, float x2, float y2, float px, float py);
21
22 // Check whether a polygon is convex
23 bool convexPolygon(Vecs3 polygon);
24 }
25
26 #endif
27
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/PolyhedraSculpture.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
PolyhedraSculpture.h
Go to the documentation of this file.
1
8 #pragma once
9
10 #include "poa.h"
11
12
13 #include "PS_Layer.h"
14
15
16 namespace APDYNAMICART
17 {
18
19 class PolyhedraSculpture : public PoA
20 {
21 public:
22 PolyhedraSculpture(Controller* controller, const string& polyhedronName);
23
24 void addLayer( const string& polyhedronName );
25 void addAndSwitchLayer( const string& polyhedronName );
26
28 virtual void createMenuStructure( osg::ref_ptr<vreckoUtils::MenuBase> parentMenu ) const;
29 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
30 virtual void save( XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
31 virtual void GUIItemClicked( const char* itemID );
32 virtual void GUISliderChanged( const char* sliderID, float sliderPos );
33
34 virtual void pointed( bool pointed ) { dbgPS(__FUNCTION__); /*_highlight->setHighlighting(pointed); */ }
35
36 virtual void update();
37 void switchToLayer( unsigned int number );
42 protected:
43 Controller* _contr;
44
46 PS_LayerPtr _activeLayer;
47
49 std::vector<PS_LayerPtr> _layers;
50
52 MenuPtr createNewShowHideMenu() const;
53
54
55 };
56
57 typedef osg::ref_ptr<PolyhedraSculpture> PolyhedraSculpturePtr;
58
59 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Filter/PosNoiseRemover.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Filter
PosNoiseRemover.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vrecko/IOPins.h>
3 #include <helpers/DynamicArray.h>
4
5 namespace Filter {
6
7 class PosNoiseRemover: public vrecko::Ability {
8 public:
9 PosNoiseRemover();
10 ~PosNoiseRemover() {};
11
12 void preInitialize(void);
13 void processEvent(const std::string &input_name, void *value);
14
15 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
16 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
17
18 protected:
19
20 // std::string out3String;
21
22 struct SAMPLE {
23 osg::Vec3 vec;
24 osg::Timer_t time;
25 };
26
27 DynamicArray<SAMPLE> pastSamples;
28
29 bool bOn; // is filtering on or off?
30
31 osg::Vec3 lastInput, lastResult;
32
33 int iCorrectedSamplesCounter;
34 // Number of corrected samples IN ROW
35
36 float fTolerance;
37 // Maximum distance between two samples. The value is time-normalized,
38 // so it stores the distance per second.
39 int iMaxPastSamples;
40 // Currently, only the values 1 or 2 are supported.
41 // 1: If the new sample is too far from the last one, the system will always output the last value
42 // 2: If too far, the system will output value according to the [bExtrapolateCorrectValue] variable
43 int iMaxCorrectedSamplesInRow;
44 // Maximum of corrected samples IN ROW. If exceeded, we will clear the internal data
45 // and expect that samples are correct (and there was a mistake to correct them)
46 bool bCompareExtrapolatedValue;
47 // True: Will compare the new value with the extrapolated one from the last two samples.
48 bool bExtrapolateCorrectValue;
49 // True: If error, extrapolate the correct value.
50 // False: If error, use the last sample.
51
52
53 DECLARE_INPUT(In3, vrecko::MessageVec3);
54 DECLARE_OUTPUT(Out3, vrecko::MessageVec3);
55 };
56
57 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/Preloader.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
Preloader.h
Go to the documentation of this file.
1 #ifndef _PRELOADER
2 #define _PRELOADER 1
3
4 #include "PreloaderHeuristic.h"
5 #include <windows.h>
6 #include <process.h>
7 #include <osg/Timer>
8 #include <vrecko/MTLock.h>
9 #include "ModelManager.h"
10
11 using namespace vrecko;
12 using namespace ArtificialWorld;
13
15 class Preloader {
16 private:
18 PreloaderHeuristic *heuristic;
20 HANDLE loadingThreadHandle;
22 DWORD loadingThreadId;
23
25 double heuristicUpdateInterval;
27 double heuristicRunInterval;
28
30 bool running;
32 osg::Timer timer;
34 osg::Timer_t lastHeuristicRun;
36 osg::Timer_t lastHeuristicUpdate;
38 bool exitLoadingFunction;
40 MTLock *lock;
42 bool loadingFunctionFinnished;
44 BlockUpdater *rootBlockUpdater;
46 bool objectLoaded;
47
48 public:
49 Preloader(BlockUpdater* _rootBlockUpdater){
50 heuristic = new BasicPreloaderHeuristic();
51 rootBlockUpdater = _rootBlockUpdater;
52
53 heuristic->SetWorldRoot(rootBlockUpdater);
54
55 lastHeuristicRun = timer.tick();
56 lastHeuristicUpdate = timer.tick();
57 //provadej update heuristiky kazdou vterinu
58 heuristicUpdateInterval = 1000;
59 //spust dalsi heuristiku ihned po skonceni predchozi
60 heuristicRunInterval = 0;
61 exitLoadingFunction = false;
62 running = false;
63 lock = new MTLock();
64 };
65
66 ~Preloader(void){
67 if(lock != NULL){
68 delete lock;
69 lock = NULL;
70 }
71 };
72
74 list<PreloaderToLoadInfo*> loadingQueue;
76 list<PreloaderLoadedInfo*> loadedObjects;
77
79 bool ExitLoadingFunction(void){ return exitLoadingFunction; };
80
82 void LoadingFunctionFinnished(void)
83 {
84 loadingFunctionFinnished = true;
85 };
86
87
89 MTLock* GetLock(void){ return lock; };
91 bool Running(void){ return running; };
92
94 void Update(void);
96 void Start(void);
98 void Stop(void);
99 };
100
101
102 #endif
103
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/PreloaderHeuristic.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
PreloaderHeuristic.h
Go to the documentation of this file.
1 #ifndef _PRELOADERHEUR
2 #define _PRELOADERHEUR 1
3
4
5 using namespace vrecko;
6 using namespace ArtificialWorld;
7
8 bool ComputePoint(double x, double y, double sizexy, double sizeuv, double anglecos, double side, osg::Vec2 lastPoint, osg::Vec2 *result);
9
10 class PreloaderLoadedInfo{
11 public:
12 osg::ref_ptr<EnvironmentObject> geometry;
13 string filename;
14 };
15
16 class PreloaderToLoadInfo{
17 public:
18 string filename;
19 ModelType type;
20 };
21
23 class PreloaderHeuristic{
24 protected:
25 //updater korenoveho bloku sceny
26 BlockUpdater *rootBlockUpdater;
27 //objekty, ktere se maji nacist, ziskane touto heuristikou
28 list<PreloaderToLoadInfo*> objectsToPreload;
29 //vyhledavani objektu bylo ukonceno
30 bool searchFinnished;
31 public:
32
33 ~PreloaderHeuristic(){ };
35 void SetWorldRoot(BlockUpdater *_rootBlockUpdater){
36 rootBlockUpdater = _rootBlockUpdater;
37 };
39 virtual list<PreloaderToLoadInfo*> GetObjectsToPreload(void){return objectsToPreload;};
41 virtual void Update(void){};
43 virtual bool SearchFinnished(void){ return searchFinnished; };
45 virtual void Restart(void){ searchFinnished = false; objectsToPreload.clear(); };
46 };
47
53 class BasicPreloaderHeuristic: public PreloaderHeuristic{
54 private:
56 int numOfPoints;
58 double vecXYAverageSize;
60 double vecXYAverageAngleCos;
62 double vecXYSide;
63
65 double vecXZAverageSize;
67 double vecXZAverageAngleCos;
69 double vecXZSide;
70
71 //posledni nalezeny vektor
72 osg::Vec3 lastVector;
73 //posledni nalezeny bod
74 osg::Vec3 lastPoint;
75
77 int requiredPoints;
79 int numOfPointsToGet;
81 int maxCountOfModels;
82
84 double minPositionDistance;
85
87 bool computeNextPointXY(osg::Vec2 *result);
89 bool computeNextPointXZ(osg::Vec2 *result);
91 bool computeNextPoint(osg::Vec3 *result);
92
93 public:
94 BasicPreloaderHeuristic(){
95 numOfPoints = 0;
96 vecXYAverageAngleCos = 1.0f;
97 vecXYAverageSize = 0.0f;
98 vecXYSide = 0.0f;
99 vecXZAverageAngleCos = 1.0f;
100 vecXZAverageSize = 0.0f;
101 vecXZSide = 0.0f;
102 //je treba ziskat 30 pozic
103 requiredPoints = 30;
104 //odhadni 10 kroku dopredu
105 numOfPointsToGet = 10;
106 //minimalni zmena predpokladane pozice pro provadeni prednacitani
107 minPositionDistance = 10;
108 //maximalni pocet prednacitanych modelu
109 maxCountOfModels = 15;
110 rootBlockUpdater = NULL;
111 searchFinnished = false;
112 };
114 void Update(void);
116 void Restart(void)
117 {
118 searchFinnished = false;
119 objectsToPreload.clear();
120 numOfPoints = 0;
121 };
122 };
123
124 #endif
125
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PrismaticJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PrismaticJoint.h
Go to the documentation of this file.
1 #ifndef PrismaticJoint_h
2 #define PrismaticJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class PrismaticJoint : public BaseJoint
15 {
16 public:
17 PrismaticJoint():BaseJoint("PrismaticJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
21 {
22 BaseJoint::loadXMLParameters(parametersNode);
23 return true;
24 }
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
26 {
27 return BaseJoint::getXMLParameters(domdocument);
28 }
29
30
31 protected:
32 NxPrismaticJointDesc _descripter;
33
34 };
35 }
36
37 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBorder.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiBorder.h
Go to the documentation of this file.
1 #ifndef VF_PROXIBORDER
2 #define VF_PROXIBORDER
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Vec4>
7 #include <osg/Geode>
8 #include <osg/MatrixTransform>
9 #include <osg/Group>
10
11 #include "Auxiliary.h"
12
13 using namespace vrecko;
14 using namespace vreckoDP_base;
15 namespace VirtualFixture{
16
17 class ProxiBorder: public Ability {
18 public:
19 ProxiBorder();
20 ~ProxiBorder() {};
21
23 void processEvent(const std::string &input_name, void *value);
24
25 void preInitialize(void);
26 void postInitialize(void);
27 void update(void);
28 void display(void); //show/hide object
29
30 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
31 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
32
33 protected:
34 PHANToM *PHANToMDevice;
35 bool all_on;
36 bool active; //if true, attractive field will be active
37
38 bool visible; //if geometric representation will be visible
39 osg::MatrixTransform *tnode; //transform node pointer
40 osg::Group *gnode; //group pointer
41 osg::Geode *node; //geometry node pointer (for outer sphere)
42 osg::Geode *node2; //geometry node pointer (for inner sphere)
43 osg::Vec4 color; //color of outer sphere (radius)
44 float transparency; //outer sphere transparency
45 osg::Vec4 color2; //color of inner sphere (radius)
46 float transparency2; //inner sphere transparency
47
48 bool once; //if true then if sphere is entered, one signal is send till sphere is not leaved and reentered (then send next signal)
49 bool justonce; //send only one signal when entered at first ...reentering doesn't reset it, it send just one signal at all
50 bool sendflag; //set true if signal was send
51 };
52
53 };
54 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiBox.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiBox.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3 #include <osg/Vec4>
4 #include <osg/Geode>
5 #include <osg/MatrixTransform>
6 #include <osg/Group>
7
8
9 using namespace vrecko;
10 using namespace vreckoDP_base;
11 namespace VirtualFixture{
12
13 class ProxiBox: public Ability {
14 public:
15 ProxiBox();
16 ~ProxiBox() {};
17
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24 void display(void); //show/hide object
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
28
29 protected:
30 PHANToM *PHANToMDevice;
31 bool all_on;
32 bool active; //if true, attractive field will be active
33
34 bool visible; //if geometric representation will be visible
35 osg::MatrixTransform *tnode; //transform node pointer
36 osg::Group *gnode; //group pointer
37 osg::Geode *node; //geometry node pointer (for bouning cylinder)
38 osg::Vec4 color; //color of border sphere (radius)
39 float transparency; //border sphere transparency
40
41 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
42 osg::Vec3 size; //size of box (width, height, lenght), position is in center, so left,bottom, corner is in position - size/2
43
44 bool once; //if true then if box is entered, one signal is send till box is not leaved and reentered (then send next signal)
45 bool justonce; //send only one signal when entered at first ...reentering doesn't reset it, it send just one signal at all
46 bool sendflag; //set true if signal was send
47 };
48
49 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCone.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiCone.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3 #include <osg/Vec4>
4 #include <osg/Geode>
5 #include <osg/MatrixTransform>
6 #include <osg/Group>
7
8
9 using namespace vrecko;
10 using namespace vreckoDP_base;
11 namespace VirtualFixture{
12
13 class ProxiCone: public Ability {
14 public:
15 ProxiCone();
16 ~ProxiCone() {};
17
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24 void display(void); //show/hide object
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
28
29 protected:
30 PHANToM *PHANToMDevice;
31 bool all_on;
32 bool active; //if true, attractive field will be active
33
34 bool visible; //if geometric representation will be visible
35 osg::MatrixTransform *tnode; //transform node pointer
36 osg::Group *gnode; //group pointer
37 osg::Geode *node; //geometry node pointer (for bouning cylinder)
38 osg::Vec4 color; //color of border sphere (radius)
39 float transparency; //border sphere transparency
40
41 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
42 float radius; //radius of attractive field
43
44 bool once; //if true then if sphere is entered, one signal is send till sphere is not leaved and reentered (then send next signal)
45 bool justonce; //send only one signal when entered at first ...reentering doesn't reset it, it send just one signal at all
46 bool sendflag; //set true if signal was send
47 };
48
49 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiCylinder.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiCylinder.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3 #include <osg/Vec4>
4 #include <osg/Geode>
5 #include <osg/MatrixTransform>
6 #include <osg/Group>
7
8
9 using namespace vrecko;
10 using namespace vreckoDP_base;
11 namespace VirtualFixture{
12
13 class ProxiCylinder: public Ability {
14 public:
15 ProxiCylinder();
16 ~ProxiCylinder() {};
17
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24 void display(void); //show/hide object
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
28
29 protected:
30 PHANToM *PHANToMDevice;
31 bool all_on;
32 bool active; //if true, attractive field will be active
33
34 bool visible; //if geometric representation will be visible
35 osg::MatrixTransform *tnode; //transform node pointer
36 osg::Group *gnode; //group pointer
37 osg::Geode *node; //geometry node pointer (for bouning cylinder)
38 osg::Vec4 color; //color of border sphere (radius)
39 float transparency; //border sphere transparency
40
41 osg::Vec3 vector; //vector on cylinder axis (from bottom to top)
42 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
43 float radius; //radius of attractive field
44
45 bool once; //if true then if sphere is entered, one signal is send till sphere is not leaved and reentered (then send next signal)
46 bool justonce; //send only one signal when entered at first ...reentering doesn't reset it, it send just one signal at all
47 bool sendflag; //set true if signal was send
48 };
49
50 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/ProxiSphere.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
ProxiSphere.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3 #include <osg/Vec4>
4 #include <osg/Geode>
5 #include <osg/MatrixTransform>
6 #include <osg/Group>
7
8
9 using namespace vrecko;
10 using namespace vreckoDP_base;
11 namespace VirtualFixture{
12
13 class ProxiSphere: public Ability {
14 public:
15 ProxiSphere();
16 ~ProxiSphere() {};
17
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24 void display(void); //show/hide object
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
27 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
28
29 protected:
30 PHANToM *PHANToMDevice;
31 bool all_on;
32 bool active; //if true, attractive field will be active
33
34 bool visible; //if geometric representation will be visible
35 osg::MatrixTransform *tnode; //transform node pointer
36 osg::Group *gnode; //group pointer
37 osg::Geode *node; //geometry node pointer (for bouning cylinder)
38 osg::Vec4 color; //color of border sphere (radius)
39 float transparency; //border sphere transparency
40
41 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
42 float radius; //radius of attractive field
43
44 bool once; //if true then if sphere is entered, one signal is send till sphere is not leaved and reentered (then send next signal)
45 bool justonce; //send only one signal when entered at first ...reentering doesn't reset it, it send just one signal at all
46 bool sendflag; //set true if signal was send
47 };
48
49 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/PulleyJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
PulleyJoint.h
Go to the documentation of this file.
1 #ifndef PulleyJoint_h
2 #define PulleyJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseJoint.h"
8
9 using namespace vrecko;
10
11
12 namespace PhysXPlugin
13 {
14 class PulleyJoint : public BaseJoint
15 {
16 public:
17 PulleyJoint():BaseJoint("PulleyJoint", &_descripter){}
18
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
21
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument);
23
24
25 protected:
26 NxPulleyJointDesc _descripter;
27
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/PyAbility.h Source File

  • File List
  • File Members
  • include
  • vrecko
PyAbility.h
Go to the documentation of this file.
1 /*************************************************/
2 /* PyAbility.h - embed Python in C++ */
3 /* Jan Sonnekt - Feb 06 */
4 /*************************************************/
5 #ifndef VreckoPyAbility_H
6 #define VreckoPyAbility_H
7
8 /* <Python must be included before stdlib.h >*/
9 #ifdef WIN32
10 #include <Python.h>
11 #else
12 #include <python/Python.h>
13 #endif
14 #include <vrecko/Ability.h>
15
16 /* includes form vrecko::Ability */
17
18 namespace vrecko {
19
30 class PyAbility : public vrecko::Ability {
31 public:
32 PyAbility();
33 ~PyAbility();
34 void update(void);
35 void processEvent (const std::string&, void *) {}
36 void preInitialize(void) {}
37 void postInitialize(void);
38 void setCallBacks(PyObject* update, PyObject* processEvent, PyObject *post);
39
40 protected:
41 static PyObject *mUpdate;
42 static PyObject *mProcessEvent;
43 static PyObject *mPost;
44
45 std::string id_string;
46 static unsigned long int counter;
47 };
48
49 }
50 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/RandomFaultsAlgorithm.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
RandomFaultsAlgorithm.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_RANDOMFAULTS_H
10 #define VRECKO_NATURE_TERRAIN_RANDOMFAULTS_H
11
12 #include "TerrainAlgorithm.h"
13 #include "../TerrainUtility.h"
14 #include <osg/Array>
15
16 namespace APNature
17 {
18 class RandomFaultsAlgorithm : public TerrainAlgorithm
19 {
20 public:
21
27 RandomFaultsAlgorithm(int width, int height);
28
39 float* GenerateSurfaceByRandomFaults(int iterations, float faultValueMin, float faultValueMax);
40
41 private:
42
43 };
44 }
45
46 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/RandomFaultsProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
RandomFaultsProperties.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_RANDOMFAULTSPROPERTIES_H
11 #define VRECKO_NATURE_TERRAIN_RANDOMFAULTSPROPERTIES_H
12
13 #include <vrecko/ReaderWriter.h>
14 #include <osg/Vec2>
15
16 #include "GeneratedTerrainProperties.h"
17
18 namespace APNature
19 {
20 static class RandomFaultsProperties : public GeneratedTerrainProperties
21 {
22 private:
23
24 // Random faults algorithm
25 static int _iterations;
26 static float _faultValueMin, _faultValueMax;
27
28 public:
29
30 // Random faults specific methods
31 // ##############################
32
36 static inline int Iterations() { return _iterations; }
37 static inline void Iterations(int iterations) { _iterations = (iterations >= 0 ? iterations : 0); }
38
46 static void FaultValueRange(float faultValueMin, float faultValueMax);
47
48 static inline float FaultValueMin() { return _faultValueMin; }
49 static inline float FaultValueMax() { return _faultValueMax; }
50
56 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
57
58 } RandomFaultsProperties;
59 }
60
61 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Range.h Source File

  • File List
  • File Members
  • include
  • vrecko
Range.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _RANGE_H_
15 #define _RANGE_H_
16
17 // VRECKO namespace
18 namespace vrecko
19 {
20
30 class Range
31 {
32 public:
33
37 enum RangeType
38 {
39 RANGE_INTERVAL,
40 RANGE_ENUMERATION
41 };
42
48 inline bool isInterval() const
49 {
50 return (rangeType == RANGE_INTERVAL);
51 }
52
58 inline bool isEnumeration() const
59 {
60 return (rangeType == RANGE_ENUMERATION);
61 }
62
63 protected:
64
70 Range(RangeType rangeType)
71 {
72 this->rangeType = rangeType;
73 }
74
80 Range(const Range& range)
81 {
82 *this = range;
83 }
84
85 private:
86
87 RangeType rangeType;
88 };
89
90 // end of vrecko namespace
91 }
92
93 // end header definitions
94 #endif
95
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/ReaderWriter.h Source File

  • File List
  • File Members
  • include
  • vrecko
ReaderWriter.h
Go to the documentation of this file.
1 #ifndef READERWRITER_H
2 #define READERWRITER_H
3
4 #include <vrecko/BaseClass.h>
5 #include <vrecko/Export>
6 #include <vrecko/Ability.h>
7
8
9 #include <fstream>
10 #include <vector>
11 #include <map>
12 #include <string>
13
14 #include <osg/Vec2>
15 #include <osg/Vec4>
16 #include <osg/Matrix>
17 #include <osg/Group>
18 #include <osgDB/DynamicLibrary>
19
20 #ifdef WIN32
21 #include <windows.h>
22 #endif
23
24 // xercesc includes
25 #include <xercesc/parsers/AbstractDOMParser.hpp>
26 #include <xercesc/dom/DOMErrorHandler.hpp>
27 #include <xercesc/dom/DOMBuilder.hpp>
28 #include <xercesc/util/XMLString.hpp>
29 #include <helpers/XercesXMLUtils.h>
30 #if defined(XERCES_NEW_IOSTREAMS)
31 #include <iostream>
32 #else
33 #include <iostream.h>
34 #endif
35
36 //--------------------
37
38 #define CREATOR_FILENAME_ID_SIMPLE "_XMLCreatorFileName_"
39 #define CREATOR_FILENAME_ID L ## "_XMLCreatorFileName_"
40 // XML attribute name that hold the filename of the creator the respective element
41
42
43 namespace vrecko {
44 class VRECKO_EXPORT World;
45 class VRECKO_EXPORT Scene;
46 class VRECKO_EXPORT EnvironmentObject;
47 class VRECKO_EXPORT DeviceManager;
48 class VRECKO_EXPORT EventDispatcher;
49 }
50
51 namespace vrecko {
52
53 // Xercesc classes ---------------------------------------------------------------
54
55 // ---------------------------------------------------------------------------
56 // Simple error handler deriviative to install on parser
57 // ---------------------------------------------------------------------------
58 class RWErrorHandler : public XERCES_CPP_NAMESPACE_QUALIFIER DOMErrorHandler
59 {
60 public:
61 RWErrorHandler();
62 ~RWErrorHandler();
63
64 // Getter methods
65 bool getSawErrors() const;
66
67 // Implementation of the DOM ErrorHandler interface
68 bool handleError(const XERCES_CPP_NAMESPACE_QUALIFIER DOMError& domError);
69 void resetErrors();
70
71 private :
72 // Unimplemented constructors and operators
73 RWErrorHandler(const RWErrorHandler&);
74 void operator=(const RWErrorHandler&);
75
76
77 // -----------------------------------------------------------------------
78 // Private data members
79 //
80 // fSawErrors
81 // This is set if we get any errors, and is queryable via a getter
82 // method. Its used by the main code to suppress output if there are
83 // errors.
84 // -----------------------------------------------------------------------
85 bool fSawErrors;
86 };
87
88
89
90 inline bool RWErrorHandler::getSawErrors() const {
91 return fSawErrors;
92 }
93 // ----------------------------------------------------------------------------------
94
95
96 #ifdef WIN32
97 typedef HANDLE VRECKOMutex;
98 #else
99 typedef pthread_mutex* VRECKOMutex;
100 #endif
101
102
104 class VRECKO_EXPORT ReaderWriter {
105 protected:
106 struct AbilityToInitialize {
107 public:
108 AbilityToInitialize(Ability* _ab, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *_params) { ability = _ab; parameters = _params; };
109 Ability *ability;
110 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters;
111 };
112
115 typedef std::vector<AbilityToInitialize> AbInitVector;
116
117 public:
118 ReaderWriter() {};
119 ~ReaderWriter() {};
120
125 bool loadMultipleFiles(std::vector<std::string> &files, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex);
126
128 bool loadOld(const char *configName, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex);
129
138 int save(const char *configName, const char *originalSceneFile, float *savingPosition, std::string *savingCategory, VRECKOMutex save_Mutex);
139
140
145 static XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *findNodeByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int level = 1);
146
147 /* Find a node within children of the specified node. */
148 static XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *findChildByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh* xChChildNodeName, int level = 1);
149
152 static void getStringValue(std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const std::string &failReturn = "", int level = 1);
153
156 static const XMLCh* getStringValueXCh(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, const XMLCh* childNodeName);
157
160 static bool getBoolValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, bool failReturn = false, int level = 1);
161
164 static int getIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int failReturn = 0, int level = 1);
165
168 static long int getLongIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, long int failReturn = 0, int level = 1);
169
172 static float getFloatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, float failReturn = 0.0, int level = 1);
173
176 static double getDoubleValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, double failReturn = 0.0, int level = 1);
177
180 static void getVec2Value(osg::Vec2 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec2 &failReturn = osg::Vec2(0.0, 0.0), int level = 1);
181
184 static void getVec3Value(osg::Vec3 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec3 &failReturn = osg::Vec3(0.0, 0.0, 0.0), int level = 1);
185
188 static void getVec4Value(osg::Vec4 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec4 &failReturn = osg::Vec4(0.0, 0.0, 0.0, 0.0), int level = 1);
189
192 static void getMatrixValue(osg::Matrix &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Matrix &failReturn = osg::Matrix::identity(), int level = 1);
193
196 static void getQuatValue(osg::Quat &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Quat &failReturn = osg::Quat(), int level = 1);
197
205 static bool getAttribStringValue(std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &attribName, const std::string &failReturn = "");
206
207
209 static XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *createElement(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, const std::string &elementName);
210
212 static XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *appendElementAndStringValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, const std::string &value);
213
215 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndBoolValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, bool value);
216
218 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, int value);
219
221 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndLongIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, long int value);
222
224 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndFloatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, float value);
225
227 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndDoubleValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, double value);
228
230 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndVec2Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec2 value);
231
233 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndVec3Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec3 value);
234
236 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndVec4Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec4 value);
237
239 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndMatrixValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Matrix value);
240
242 static XERCES_CPP_NAMESPACE_QUALIFIER DOMElement *appendElementAndQuatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Quat value);
243
244 protected:
246 bool loadVirtualEnvironment(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *veNode);
248 bool loadScene(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *sceneNode, AbInitVector &abilitiesToInitialize);
250 bool loadDevice(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode);
252 bool loadAbilities(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, bool bLoadingWorldAbility, AbInitVector &abilitiesToInitialize);
254 vrecko::EnvironmentObject *loadEnvironmentObject(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, osg::Group *parentSceneNode);
256 bool loadEvent(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eventNode);
257
259 void saveEnvironmentObject(const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, vrecko::EnvironmentObject *pEO);
261 void saveChildren(const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, vrecko::EnvironmentObject *pEO);
262
267 void analyzeXMLTree(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode);
268
270 unsigned int getNodeCountByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode, const std::string &nodeName);
271
276 XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * createParser();
277
282 void releaseParser(XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder * parser);
283
287 XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *loadXMLDocument(const char *configName, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser);
288
292 bool findRealFile(char *outputFileWithPath, const char* inputFile, const char* currentDir, std::vector<std::string> *requiredBy = NULL, bool bOutputErrors = true);
293
295 void removeUnnecessaryWhitespace(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode);
296
298 bool saveXMLDocument(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDoc, const char *strPath);
299
303 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mergeFiles(std::vector<std::string> &files, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser);
304
306 bool processNodeToMergeRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainNode,
307 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *secNode, const XMLCh *xChConfigFile);
308
310 bool removeAttribRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *attribName);
311
312
313 enum FDNNodeType {
314 FDNSimpleNode = 0,
315 // for any generic node, that
316 // 1) We don't know
317 // OR
318 // 2) Either cannot have any siblings of the same name
319 // OR
320 // Can have siblings of the same name, but is not distinguishable
321 // (So if we will find existing node with the same name, we can take it as a duplicate)
322 FDNFilter,
323 // This is a case of Phantom (Device) filters.
324 FDNAbility,
325 FDNDevice,
326 FDNEnvironmentObject,
327 FDNAttribute,
328 FDNUserData,
329 FDNEvent,
330 FDNReceiver, // this is Event/Receiver
331 // FDNParameters,
332 };
333
335 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *findDuplicateNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainParentNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *origNode);
336
340 bool getNodeIdentification(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, FDNNodeType nodeType, XMLCh *strId1, XMLCh *strId2);
341
343 bool addCreatorInfoRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *xChConfigFile);
344
347 void addSceneFileInfoIfPossible(vrecko::BaseClass *bc, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node);
348
349
350 /* enum {
351 NONE = 0,
352 SCENE,
353 ENVIRONMENTOBJECT,
354 ABILITY
355 };*/
356
357 std::string _cfg_file, _cfg_path;
358 // std::map<std::string, osgDB::DynamicLibrary *> mapDL;
359 // osgDB::DynamicLibrary *pDL;
360 // std::vector<vrecko::EnvironmentObject *> _parent_EO;
361 // std::ifstream _fr;
362
363 vrecko::DeviceManager *device_manager_local;
364 vrecko::EventDispatcher *event_dispatcher_local;
365 vrecko::EnvironmentObject *_eobject;
366
367 unsigned int nodes_count, act_node;
368
370 bool incrementActNode();
371
372 #ifdef WIN32
373 HANDLE loadsave_Mutex;
374 #else
375 pthread_mutex_t *loadsave_Mutex;
376 #endif
377 float *loadsave_position;
378 std::string *loadsave_category;
379
380 private:
381 const char* xmlFile;
382 XERCES_CPP_NAMESPACE_QUALIFIER AbstractDOMParser::ValSchemes valScheme;
383 bool doNamespaces;
384 bool doSchema;
385 bool schemaFullChecking;
386 bool errorOccurred;
387 bool recognizeNEL;
388 char localeStr[64];
389
390
391 };
392
393 // ---------------------------------------------------------------------------
394 // This is a simple class that lets us do easy (though not terribly efficient)
395 // trancoding of char* data to XMLCh data.
396 // ---------------------------------------------------------------------------
397 class XercesStr
398 {
399 public :
400 // -----------------------------------------------------------------------
401 // Constructors and Destructor
402 // -----------------------------------------------------------------------
403 XercesStr(const char* const toTranscode)
404 {
405 // Call the private transcoding method
406 fUnicodeForm = XERCES_CPP_NAMESPACE_QUALIFIER XMLString::transcode(toTranscode);
407 }
408
409 ~XercesStr()
410 {
411 XERCES_CPP_NAMESPACE_QUALIFIER XMLString::release(&fUnicodeForm);
412 }
413
414
415 // -----------------------------------------------------------------------
416 // Getter methods
417 // -----------------------------------------------------------------------
418 const XMLCh* unicodeForm() const
419 {
420 return fUnicodeForm;
421 }
422
423 private :
424 // -----------------------------------------------------------------------
425 // Private data members
426 //
427 // fUnicodeForm
428 // This is the Unicode XMLCh format of the string.
429 // -----------------------------------------------------------------------
430 XMLCh* fUnicodeForm;
431 };
432
433 #define strToXerces(str) XercesStr(str).unicodeForm()
434
435
436
437 }
438
439 #endif
440
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RealCmp.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
RealCmp.h
Go to the documentation of this file.
1 #ifndef REAL_CMP_H
2 #define REAL_CMP_H
3
4 #include <sstream>
5 #include <string>
6 #include <iomanip>
7
8 /*adtmag.com*/
9 template <class T>
10 class RealCmp
11 {
12 enum FloatCmp {
13 FC_LT,
14 FC_GT,
15 FC_EQ
16 };
17
18 public:
19 static FloatCmp comparator(T a, T b) {
20 std::string s, n;
21 int exp1, exp2;
22
23 s = toString(a);
24 n = s.substr(s.rfind("e")+1);
25 exp1 = atof(n.c_str());
26
27 s = toString(b);
28 n = s.substr(s.rfind("e")+1);
29 exp2 = atof(n.c_str());
30
31 FloatCmp result;
32 if ((exp1 + 6) < exp2){
33 result = FC_LT;
34 }
35 else if (exp1 > (exp2 + 6)) {
36 result = FC_GT;
37 }
38 else if ((abs(a-b) / (b==0.0 ? 1.0 : abs(b))) < 0.00001/*std::numeric_limits<float>::epsilon()*/) {
39 result = FC_EQ;
40 }
41 else if (a < b) {
42 result = FC_LT;
43 }
44 else if (a > b) {
45 result = FC_GT;
46 }
47
48 return result;
49 }
50
51 static inline bool compareLT(T a, T b) { return (comparator(a, b) == FC_LT); }
52
53 static inline bool compareGT(T a, T b) { return (comparator(a, b) == FC_GT); }
54
55 static inline bool compareEQ(T a, T b) { return (comparator(a, b) == FC_EQ); }
56
57 static inline bool compareLTEQ(T a, T b) { return ((comparator(a, b) == FC_LT) || (comparator(a, b) == FC_EQ)); }
58
59 static inline bool compareGTEQ(T a, T b) { return ((comparator(a, b) == FC_GT) || (comparator(a, b) == FC_EQ)); }
60
61 private:
62 static std::string toString(T number) {
63 std::stringstream sstr;
64 sstr << std::scientific << number;
65 return sstr.str();
66 }
67
68 };
69
70 #endif
71
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/RegularPolygonSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
RegularPolygonSpline.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "Spline.h"
4 #include "Utils.h"
5 #include <osg\BoundsChecking>
6
7 static const double PI_SQUARED = 6.28318530717958647692;
8
9 class RegularPolygonSpline : public Spline
10 {
11 public:
12 enum PlaneType
13 {
14 XY,
15 XZ,
16 YZ
17 };
18
19 RegularPolygonSpline();
20 RegularPolygonSpline(double radius, unsigned int segmentCount, double rotationShiftInDegress = 0.0, PlaneType plane = XY);
21
23 META_DAObject(RegularPolygonSpline, "Regular Polygon Spline")
24
25 virtual Vec3ArrayPtr getPoints();
26 virtual bool isClosed() { return true; }
27
29 double getRadius() const { return _radius; }
30 inline void setRadius(double val);
31
32 unsigned int getSegmentCount() const { return _segmentCount; }
33 inline void setSegmentCount(unsigned int val);
34
35 RegularPolygonSpline::PlaneType getPlane() const { return _plane; }
36 inline void setPlane(RegularPolygonSpline::PlaneType val);
37
38 double getRotationShift() const { return _rotationInDegress; }
39 inline void setRotationShift(double val);
40
41 protected:
42 unsigned int _segmentCount;
43 double _invSegmentCount;
44 double _radius;
45 PlaneType _plane;
46 double _rotationInDegress;
47 double _shift;
48 };
49
50 typedef osg::ref_ptr<RegularPolygonSpline> RegularPolygonSplinePtr;
51
52 void RegularPolygonSpline::setRadius( double val )
53 {
54 _radius = osg::clampAbove(val, 0.0);
55 _dirty = true;
56 }
57
58 void RegularPolygonSpline::setSegmentCount( unsigned int val )
59 {
60 _segmentCount = val;
61 osg::clampGEQUAL<unsigned int>(_segmentCount, 3, "segmentCount");
62 _invSegmentCount = PI_SQUARED / _segmentCount;
63
64 _dirty = true;
65 }
66
67 void RegularPolygonSpline::setPlane(RegularPolygonSpline::PlaneType val)
68 {
69 _plane = val;
70 _dirty = true;
71 }
72
73 void RegularPolygonSpline::setRotationShift(double val)
74 {
75 _rotationInDegress = val;
76 _shift = osg::DegreesToRadians(_rotationInDegress);
77 _dirty = true;
78 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RemoteDebugger.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
RemoteDebugger.h
Go to the documentation of this file.
1 #ifndef RemoteDebugger_h
2 #define RemoteDebugger_h
3
4 #include "PhysXObject.h"
5
6 using namespace vrecko;
7
8 namespace PhysXPlugin
9 {
10 class RemoteDebugger:public PhysXObject
11 {
12 private:
13 std::string _host;
14 unsigned int _port;
15 protected:
16 NxRemoteDebugger* _pRemoteDebugger;
17 public:
18 RemoteDebugger():PhysXObject("RemoteDebugger"){}
19 virtual ~RemoteDebugger();
20
21 virtual void postInitialize();
22
23 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * node);
24 virtual XERCES_CPP_NAMESPACE_QUALIFIER DOMNode * getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode);
25 };
26 }
27
28
29 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/Remover.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
Remover.h
Go to the documentation of this file.
1 #ifndef REMOVER
2 #define REMOVER
3
4 #include <vrecko/Ability.h>
5 #include <set>
6 #include <vrecko/IOPins.h>
7 #include <vrecko/Message.h>
8
9 namespace CarSim {
10 // abilita, ktera bude mazat EnvironmentObjecty aut po jejich dojeti do cile
11 class Remover: public vrecko::Ability {
12 public:
13 Remover();
14 ~Remover() {};
15
16 void preInitialize(void);
17
18 // EO aut, ktera se prihlasila (pres processEvent), se smazou v teto metode
19 void update(void);
20 void processEvent(const std::string &input_name, void *value);
21
22 protected:
23 // mnozina id environment objectu aut, ktera dojela do cile a
24 // ktera maji byt smazany
25 std::set<unsigned int> carsToRemove;
26
27 DECLARE_INPUT(InCarToRemove, vrecko::MessageUnsignedInt);
28 };
29 }
30
31 #endif
32
33
34
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/RevoluteJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
RevoluteJoint.h
Go to the documentation of this file.
1 #ifndef RevoluteJoint_h
2 #define RevoluteJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include <sstream>
8 #include "BaseJoint.h"
9
10 using namespace vrecko;
11
12
13 namespace PhysXPlugin
14 {
15 class RevoluteJoint : public BaseJoint
16 {
17 public:
18 RevoluteJoint():BaseJoint("RevoluteJoint", &_descripter){}
19
20 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
21 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument)
22 {
23 return BaseJoint::getXMLParameters(domdocument);
24 }
25
26 protected:
27 NxRevoluteJointDesc _descripter;
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsEdges.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
RoadsEdges.h
Go to the documentation of this file.
1 #ifndef ROADS_EDGES
2 #define ROADS_EDGES
3
4 namespace CarSim {
5 // struktura, ve ktere budou zaznamenany hrany silnice v obou smerech
6 struct RoadsEdges {
7 // id hrany silnice ve smeru dopredu (hrany na prave strane silnice)
8 unsigned int forwardEdgeId;
9 // id hrany silnice v opacnem smeru (na leve strane silnice)
10 unsigned int backEdgeId;
11 };
12 }
13
14 #endif
15
16
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/RoadsState.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
RoadsState.h
Go to the documentation of this file.
1 #ifndef ROADS_STATE
2 #define ROADS_STATE
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/ReaderWriter.h>
6 #include <vrecko/IOPins.h>
7 #include <vrecko/Message.h>
8
9 #include "Junction.h"
10 #include "PolygonPoint.h"
11 #include "Edge.h"
12 #include "RoadsEdges.h"
13 #include "CarControlUnit.h"
14
15 #include <osg/Vec3>
16 #include <set>
17 #include <map>
18 #include <vector>
19
20 namespace CarSim {
21
22 using namespace vrecko;
23
24 class RoadsState: public vrecko::Ability {
25 public:
26 // bude jenom 1 RoadsState, takze by nektere metody a atributy
27 // mohly byt static, pro jednoduchost ale zatim budou vsechny metody
28 // a atributy bez static, takze se budou vzdy vztahovat k instanci
29 // RoadsState a ne k samotne tride
30 RoadsState();
31 ~RoadsState() {};
32 void preInitialize(void);
33 void processEvent(const std::string &input_name, void *value);
34 void *processRequest(const std::string &input_name, void *value);
35
36 virtual void update(void);
37
38 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
39 protected:
40 // cesta k adresari, kde jsou ulozeny modely aut a textura silnice
41 std::string dataPath;
42 // jestlize je true, nektere krizovatky uvedene u from, to a fromPointRight,
43 // toPointRight u hran zadanych v XML souboru neexistuji.
44 // Tato promenna se kontroluje pri prijeti requestu a v pripade, ze je "true"
45 // -> posle se NULL CCU -> ktera pak zrusi sve aktualizovani,
46 // aby se uz neposilala zadosti roadsState
47 bool invalidRefToJuncOrPolygPoint;
48
49 // roads, junctions a polygonPoints jsou indexovany pomoci klicu,
50 // ktere se vyskytuji jako id ve vstupnim XML souboru - zacinaji tedy
51 // od 1 a v rozsahu pro klic se mohou vyskytovat diry;
52 // indexy pro edges jsou generovany az pri behu programu - jsou indexovany
53 // od 0 a v rozsahu pro index se nevyskytuji diry;
54 // graf silnic - implementovan pomoci seznamu (mnoziny) nasledniku;
55 // prvni unsigned int slouzi pro ID krizovatky (uzlu),
56 // druhe znaci ID nasledniku (krizovatek) a posledni je ID hran
57 // k temto naslednikum;
58 // budou zde pouze hrany, na kterych auta jezdi z bodu OUT do IN
59 // - tedy pouze normalni nebo kratke s aspon 1 pruhem (jestlize je hrana
60 // prilis uzka na to, aby na ni mohlo jezdit auto -> ma 0 pruhu)
61 std::map<unsigned int, std::map<unsigned int,unsigned int> > roads;
62 std::map<unsigned int,Junction> junctions;
63 // id krizovatky s nejvetsi hodnotou
64 unsigned int maxJuncId;
65 // id polygonPointu s nejvetsi hodnotou
66 unsigned int maxPolygonPointId;
67 std::map<unsigned int,PolygonPoint> polygonPoints;
68 std::vector<Edge> edges;
69
70 // pocet neterminalnich hran v edges (ze zacatku jsou
71 // v edges neterminalni hrany, pak same terminalni)
72 unsigned int numOfNonTermEdges;
73
74 // zde budou ulozeno, ktere hrany patri k jakym silnicim;
75 // klic je id silnice (budou zde vsechny silnice nactene
76 // z XML souboru
77 std::map<unsigned int,RoadsEdges> roadsEdges;
78
79 // ukazatel na abilitu, ktera bude mazat auta
80 Ability *pRemover;
81
82 // ukazatel na abilitu, ktera bude cachovat casti geometrie aut, aby
83 // se stejne soubory nemusely nacitat vicekrat
84 Ability *pCarPartsNodeCache;
85
86 // model sloupu semaforu,
87 osg::Node *pTLcolumnModel;
88 // model oranzoveho svetla semaforu,
89 osg::Node *pTLorangeModel;
90 // vzdalenost mezi stredy barevnych svetel na semaforu
91 float tlColorsCenterDist;
92
93
94 // loaded from params, should be used when the roads will be loaded:
95 bool bDrawRoads;
96 int iNumGenCars;
97 bool bGenShortestPaths;
98
99 bool bAttemptToLoadRoadsFromArtificalWorld; // will be used when road are not specified in the Parameters node
100
101
102 // tato metoda nacte ze vstupniho XML souboru krizovatky (Junction),
103 // body urcujici tvary silnic (PolygonPoint) a silnice (Road) pomoci
104 // nasledujicich tri fci
105 void loadJuncPolyRoad(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode const *const pRoadNetNode);
106 // tato metoda nacte krizovatku z atributu uzlu Junction
107 void loadJunction(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes);
108 // tato metoda nacte bod pro tvar silnice z atributu uzlu PolygonPoint
109 void loadPolygonPoint(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes);
110 // tato metoda nacte silnici (Road) z atributu uzlu Road a ulozi ji pomoci
111 // dvou hran protichudnych smeru (po teto metode je tedy v edges vzdy hrana se
112 // sudym indexem komplementarni s hranou s tim indexem + 1)
113 void loadRoad(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes);
114
115 // tato metoda vytvori polygon pro kazdou hranu a ulozi je pod 1 EnvironmentObject
116 // do sceny (vykreslene polygony maji body from, fromPointRight, toPointRight, to)
117 void addEdgesAsEO() ;
118 // tato metoda overi, zda krizovatky uvedene u from, to a fromPointRight,
119 // toPointRight u hran zadanych v XML souboru skutecne existuji
120 void checkEdgesFromToAndTheirPolygonPoints();
121
122 // metoda, ktera najde nejkratsi cestu ze startovni hrany s offsetem na ni
123 // do koncove hrany s prislusnym offsetem;
124 // vysledek bude ulozen do vektoru, na ktery ukazuje prvni ukazatel,
125 // cesta je ulozena v podobe indexu krizovatek na ceste do mapy junctions
126 void findShortestPath(std::vector<unsigned int> *const pResultPath,
127 const StartStopDestination *const pStartStopDestination);
128
129 // metoda, ktera najde ze startovni hrany nahodne dlouhou cestu (rand(30)+1,
130 // delka cesty tu je v poctu hran na ni), ktera nemusi byt nejkratsi;
131 // bude se predpokladat, ze auto na hrane startEdge muze zacit (pro auto uz byla
132 // zavolana metoda regCarForEdge);
133 // posledni hrana bude normalni (pujde na ni zastavit);
134 // vysledek bude ulozen do vektoru, na ktery ukazuje ukazatel,
135 // cesta je ulozena v podobe indexu krizovatek na ceste do mapy junctions;
136 // slouzi pro rychlejsi nalezeni cest u generovanych aut;
137 // pozn.: pocita se s tim, ze byl inicializovan generator nahodnych cisel srand();
138 // pri generovani cesty se metoda bude snazit vybirat dalsi krizovatky po startovni hrane
139 // tak, aby se auto prilis casto neotacelo o 180
140 // (na krizovatkach to v realu neni prilis obvykle)
141 void findPath(std::vector<unsigned int> *const pResultPath,const unsigned int startEdge);
142
143 // tato fce vypocita pomoci indexu hrany a relativni pozici na ni
144 // mezi body OUT a IN
145 // absolutni pozici ve svete, ta se ulozi to 1. parametru;
146 // offset je v procentech
147 void getAbsPos(osg::Vec3 &resultPos,const unsigned int edge,
148 const float offset);
149
150 // tato metoda vypocita u vsech neterminalnich hran atributy: body IN a OUT,
151 // outInVec, widthTPR, widthFPR, type a dalsi
152 void computeEdgesAttributes();
153
154 // tato metoda pred zapocetim simulace prida ke kazde krizovatce
155 // indexy na neterminalni hrany, ktere do ni vstupuji a vystupuji;
156 // budou slouzit k detekci prechodu auta pres hranice hran
157 // krizovatky u ktere je auto
158 void computeJunctionsEdges();
159
160 /*// tato fce vypocte prusecik usecky a roviny, ktere jsou k sobe kolme;
161 // usecka je zadana pomoci bodu a vektoru (u usecky vektor definuje
162 // jeji delku), rovina je definovana pomoci bodu a vektorem usecky;
163 // jestlize prusecik puvodni primky a usecky neexistuje, vrati se NULL
164 const osg::Vec3 *const interPointOfAbscissaAndPerpendicularPlane
165 (const osg::Vec3 &abscissaPoint,const osg::Vec3 &abscissaVec,const osg::Vec3 &planePoint);*/
166
167 // tato fce vypocte prusecik (1. parametr) primky a roviny, ktere jsou k sobe kolme;
168 // primka je zadana pomoci bodu a vektoru, rovina je definovana pomoci bodu a vektorem primky;
169 // jestlize je lineVec (0,0,0), bude vypsana chyba a vraceny prusecik bude (0,0,0)
170 void interPointOfLineAndPerpendicularPlane(osg::Vec3 &inter,const osg::Vec3 &linePoint,
171 const osg::Vec3 &lineVec,const osg::Vec3 &planePoint);
172
173 // vypocita vzdalenost mezi primkou (zadana bodem a vektorem) a bodem v prostoru
174 const float distFromPointToLine(const osg::Vec3 &linePoint,
175 const osg::Vec3 &lineVec,const osg::Vec3 &point);
176
177 void herFerDeriv(osg::Vec3 &result,const float d,const osg::Vec3 &P1,
178 const osg::Vec3 &P4,const osg::Vec3 &R1,const osg::Vec3 &R4);
179
180 /*// tato metoda vypocita pozici Hermite/Fergussonovy kubiky (danou body
181 // P1, P4 a vektory R1 a R4) v bode d, vysledek ulozi do result
182 void herFer(osg::Vec3 &result,const float d,const osg::Vec3 &P1,
183 const osg::Vec3 &P4,const osg::Vec3 &R1,const osg::Vec3 &R4);*/
184
185 // tato funkce zjisti, zda bod point lezi v poloprostoru zadanym vektorem
186 // halfSpacePoint a bodem halfSpaceVec
187 bool pointInHalfSpace(const osg::Vec3 &point,const osg::Vec3 &halfSpacePoint,
188 const osg::Vec3 &halfSpaceVec);
189
190 // jestlize je auto v okoli stredu krizovatky, urci se na ktere hrane je,
191 // ta se pak vrati v prvnim parametru;
192 // 2. parametr je index hrany, na ktere bylo auto v minulem snimku
193 // 3. parametr je spodni pozice auta,
194 // 4. parametr je index krizovatky, u ktere je auto (sloucene, nikdy dilci)
195 // 5. parametr je id vystupni hrany u te krizovatky
196 void getCarEdgeId(unsigned int &carEdgeId,const unsigned int lastCarEdgeId,
197 const osg::Vec3 &bottomCarPosition,const unsigned int juncId,
198 const unsigned int outEdgeId);
199
200 // v prvnim parametru vrati vzdalenost bodu point od roviny
201 // dane bodem (planePoint) a vektorem (planeNormal)
202 void distPointToPlane(float &dist,const osg::Vec3 &point,
203 const osg::Vec3 &planePoint,const osg::Vec3 &planeNormal);
204
205 // tato metoda vypocte ve 2D prunik 2 ruznobeznych primek
206 // (jsou dany bodem a vektorem), vysledek je ulozen do result;
207 // jestlize jsou primky rovnobezne, zapise se chybova hlaska a vrati
208 // se (0,0,0)
209 void linesInter2D(osg::Vec2 &result,const osg::Vec2 &line1Point,
210 const osg::Vec2 &line1Vec,const osg::Vec2 &line2Point,
211 const osg::Vec2 &line2Vec);
212
213 // metoda najde u krizovatek pary samostatnych polygonPointu
214 // (samostatnych ve smyslu jejich vyskytu u hran krizovatky), ktere jsou vedle
215 // sebe (1. je vzdy na vstupni, 2. na vystupni hrane) a zavola metodu, ktera
216 // z tech 2 polygonPointu a stredu krizovatky udela terminator;
217 // terminatory se pridavaji, aby auto pri prejeti kolem tech
218 // samostatnych polygonPointu nevyselo jenom tak ve vzduchu (aby se autu
219 // mohla snadno davat normala podle hrany pod nim, aby se jednoduse urcilo,
220 // kde auto je)
221 void findJuncsSinglePolyPoints();
222
223 // tato metoda vytvori z 1. a 2. sam. polygonPointu a stredu kriz. juncId
224 // terminator (viz findJuncsSinglePolyPoints); terminator se take zacleni
225 // mezi hrany fstEdgeId (lezi na ni 1. polygonPoint, je to vzdy vstupni
226 // hrana) a sndEdgeId (lezi na ni 2. polygonPoint, je to vzdy vystupni hrana)
227 // v orderedEdges krizovatky juncId
228 void addTerminatorEdges(unsigned int fstSinglePolyPoint,
229 unsigned int sndSinglePolyPoint,unsigned int fstEdgeId,
230 unsigned int sndEdgeId,const unsigned int juncId);
231
232 // mezi nekterymi krizovatkami se mohou vyskytnout hrany, ktere jsou
233 // ultrakratke (viz Edge.h);
234 // neni vhodne uvazovat prujezd pres tuto ultrakratkou hranu
235 // z bodu OUT a IN, protoze by pak auto muselo na takove hrane prudce zatacet;
236 // proto krizovatky, mezi nimiz jsou ultrakratke hrany,
237 // spojuji do jedne nove krizovatky;
238 // ta ma vstupni a vystupni hrany stejne jako neultrakratke vstupni a vystupni
239 // hrany dilcich krizovatek;
240 // v edges jsou odkazy na stare krizovatky; v roads se odstrani stare krizovatky
241 // a daji nove
242 void mergeCloseJunctions();
243
244 // prida hranu s id edgeId jako EnvironmentObject do sceny (s geometrii ctyruhelnika)
245 void addEdgeAsEO(const unsigned int edgeId);
246
247 // tato metoda usporada hrany u krizovatek ulozenych ve vektoru orderedEdgesIds
248 void orderJunctionsEdges();
249
250 // tato metoda vypocita u krizovatek atributy pro dvojice vstupnich a vystupnich
251 // (ovsem vzdy kratkych nebo normalnich) hran, viz junction.h; predpoklada se,
252 // ze hrany u krizovatek jsou uz usporadane
253 void computeJuncInOutEdgesAttr();
254
255 // jestlize auto skoncilo svoji cestu -> smaze se jeho id u koncove (normalni) hrany;
256 // tato metoda smaze id na auto u dane hrany; nemuze se stat, ze by
257 // se id auta u hrany nenaslo -> proto tuto moznost netestuji
258 void unregCarForEdge(const unsigned int carId,const unsigned int edgeId);
259
260 // odregistuje posledni auto na zadane normalni hrane
261 void unregLastCarForEdge(const unsigned int edgeId);
262
263 // zaregistruje auto u startovni (normalni) hrany
264 // (parametry jsou - id auta, id startovni hrany, offset pozice stredu auta na ni,
265 // delka auta a zda bylo auto vygenerovano);
266 // pridani auta do hrany, kde uz nejaka auta jsou, bude mit
267 // linearni slozitost - to ale nebude moc vadit, protoze to nebude moc caste
268 // (auto se zaregistuje u hrany pouze na zacatku sveho zivotniho cyklu);
269 // jestlize vse probehlo v poradku, vrati true;
270 // jestlize se vyskytla chyba (auto je moc blizko jinemu autu, ktere uz
271 // na hrane je; predni cast auta je za bodem stopBeforeJunc nebo je prilis blizko
272 // autu u from kriz. hrany), vrati false;
273 // jestlize je showErrors false, budou potlaceny chybove vystupy (napriklad pri
274 // generovani aut)
275 bool regCarForEdge(const unsigned int carId,const unsigned int startEdgeId,
276 const float startOffset,const float carLength,const bool showErrors);
277
278 // zaregistruje auto s offsetem (urcujicim umisteni stredu auta na hrane), delkou
279 // a rychlosti u normalni hrany jako prvni
280 void regFstCarForEdge(const unsigned int carId,const unsigned int edgeId,
281 const float offset,const float carLength,const float vel);
282
283 // zjisti, zda je auto zaregistrovano u hrany
284 bool isCarRegForEdge(const unsigned int carId,const unsigned int edgeId);
285
286 // metoda, ktera aktualizuje informace o autu u normalni hrany
287 // (auto musi byt zaregistrovano u normalni hrany)
288 void updateCarForEdge(const unsigned int carId,const unsigned int edgeId,
289 const float headOffset,const float rearOffset,const float vel);
290
291 // metoda, ktera vrati vzdalenost mezi autem, jehoz id je dano parametrem
292 // (auto musi byt zaregistrovano u hrany s id edgeId), a autem nasledujicim
293 // (smerem ke konci hrany) a rychlost tohoto nasledujiciho auta;
294 // pozadovane hodnoty jsou vraceny v prvnich dvou parametrech;
295 // Pozn.: Jestlize nasledujici auta neexistuje, jsou vracene hodnoty 0
296 void getNextCarDistAndVel(float &nextCarDist,float &nextCarVel,
297 const unsigned int carId,const unsigned int edgeId);
298
299 // tato metoda overi, zda je cilova pozice na koncove (normalni) hrane pro auto
300 // povolena (vrati true) nebo zakazana (false);
301 // jestlize auto chce skoncit svou predni casti pred bodem stopBeforeJunc
302 // hrany a zaroven svou zadni casti za bodem, ktery urcuje lowBoundForStartStopPosOffset
303 // u hrany (auto by melo byt schopno po vyjezdu ze krizovatky zabrzdit tak, aby v cili
304 // melo temer nulovou rychlost), ma auto povoleni tu skoncit;
305
306 // Pozn.: Auto bude moci skoncit tam, kde zacalo.
307
308 // parametry jsou:
309 // stopEdgeId - id koncove hrany
310 // stopOffset - relativni pozice mezi Out a In (in (0,1))
311 // carLength - delka auta
312 bool isCarStopPositionRight(const unsigned int stopEdgeId,const float stopOffset,
313 const float carLength);
314
315 // metoda, ktera vrati, zda je na zacatku normalni hrany edgeId dostatek
316 // mista pro skupinu aut (ktere na ni chteji vjet), kterych je carCount a ve ktere ma
317 // prvni auto (vzhledem ke smeru hrany) delku fstCarInGroupLength a vsechna ostatni
318 // v ni maximalni moznou delku
319 bool isFreeSpaceForCarGroupOnEdge(const unsigned int edgeId,const float fstCarInGroupLength,unsigned int carCount);
320
321 // pokud krizovatka je
322 // bez pridavneho jmena velka, je mala - jedna se bud o krizovatku sloucenou z puvodnich
323 // krizovatek pres velmikratke hrany nebo puvodni krizovatku, ktera neni sloucena s jinymi
324 // pres velmi kratke hrany;
325 // ve starsim kodu muze znamenat krizovatka take proste puvodni krizovatku
326 // (TODO oprav starsi komentare, aby neplatilo?);
327 // velka krizovatka vznika spojenim krizovatek pres kratke hrany nebo se jedna o krizovatku,
328 // kolem ktere neni zadna kratka hrana;
329 // nijak se pred simulaci nevypocitavaji (narozdil od malych krizovatek sloucenych pres
330 // velmikratke (ultrakratke) hrany);
331 // pri prujezdu malymi krizovatkami bude auto porad zatacet;
332 // ve velke kriz. bude zatacet pouze v oblastech malych kriz.;
333
334 // hrany k zamceni se oproti klasickym hranam lisi v nasledujicich bodech:
335 // a) normalni vstupni hranu do male nebo velke krizovatky tvori pouze cast za bodem In,
336 // obdobne normalni vystupni hranu z male ci velke krizovatky predstavuje cast pred
337 // bodem Out
338 // b) jestlize auto jede (pojede) po cele delce kratke hrany, pocita se dvakrat;
339 // je rozdelena na dve u bodu OUT, jedna cast patri ke krizovatce from (nebo te,
340 // do niz se sloucila), druha cast ke krizovatce to (nebo te, do niz se sloucila);
341 // c) pokud neni receno jinak, jsou hrany mezi pro auto vstupni a vystupni hranou do/z
342 // male krizovatky brany jako jedna hrana - sloucena hrana (sklada se z dilcich hran);
343 // pozn.: pokud se ve spojitosti s nejakou hranou budu zminovat o zamykani, odemykani
344 // a podobne, bude ta hrana hrana k zamceni
345 // pozn.: sloucena hrana se povazuje za odemcenou, jestlize jsou vsechny jeji dilci
346 // hrany odemcene
347
348 // auto se rozhoduje, zda vjede do velke krizovatky
349 // u bodu stopOrGoDecision vstupni normalni hrany;
350 // auto pojede, jestlize:
351 // I. je posledni auto na vstupni hrane
352 // II. a) jsou vsechny hrany mezi hranou, na ktere auto je
353 // a nejblizsi normalni vystupni (pro auto) hranou (vcetne) odemcene nebo
354 // b) pokud je nejaka z vyse zminenych hran zamcena na nejake male krizovatce,
355 // musi jet na te male krizovatce stejnou cestou jako posledni auto,
356 // ktere si u ni zamklo nejake hrany (ta hrana u te male krizovatky muze
357 // byt zamcena, jelikoz uvedena auta v ni pojedou zhruba stejnou rychlosti, kdyz
358 // v ni pojedou stejnou cestou - takze si nebudou zavazet)
359 // III. jestlize je velka krizovatka rizena semafory (v tom pripade se velka krizovatka
360 // sklada pouze z jedne male) na vstupni normalni hrane sviti autu zelena; v opacnem
361 // pripade na vsech malych krizovatkach v te velke muze jet podle pravidla prave ruky
362 // IV. na te vystupni hrane je pro auto dostatek mista;
363 // jen pro velkou krizovatku nerizenou semafory:
364 // jestlize auto na nektere male krizovatce (ve velke krizovatce) muze jet
365 // podle pravidla prave ruky pouze diky deadlocku, musi byt na vystupni
366 // normalni hrane z te velke krizovatky dost mista pro auto s maximalni moznou
367 // delkou (+ rezerva). (dve auta chteji jet na stejnou vystupni normalni hranu; jedno by
368 // mohlo jet pouze diky uvaznuti, druhe by to zvladlo i bez nej; pak prvni auto
369 // musi vyrazit pozdeji nez druhe bez ohledu na jejich delky);
370 // pokud autu zatim nebyl zamitnut vjezd do velke krizovatky a v ceste auta pres
371 // velkou krizovatku je zamcena nejaka hrana, na zacatku vystupni normalni hrany
372 // musi byt za vyse pozadovanym mistem pro auto navic misto pro tolik aut
373 // s maximalni moznou delkou, kolikrat je ta vystupni normalni hrana zamcena
374 // V. jen pro velkou krizovatku nerizenou semafory:
375 // jestlize auto na nektere male krizovatce (ve velke krizovatce) muze jet
376 // podle pravidla prave ruky pouze diky deadlocku, nesmi byt v poslednim snimku
377 // nejakeho auta na zadne te male krizovatce byt odemcena hrana (ve snimku po
378 // odemceni hrany musi mit prednost auta, ktera mohou jet bez uvaznuti, pred
379 // vozidly, ktera to zvladnou jenom s nim)
380
381 // jestlize auto muze jet (splnuje postupne vsechny predchozi podminky),
382 // zamcou se vsechny zminene hrany (jestlize auto pojede pres
383 // nejake hrany vicekrat, take se tim autem vicekrat zamcou; vicenasobne (2x a vic)
384 // zamceni hrany muze byt zpusobene take tim, ze nejaka hrana z tech hran, pres
385 // ktere auto pojede ve velke krizovatce, jiz byla zamcena),
386 // u malych krizovatek, pres ktere auto pojede, se nastavi cesta, kudy jelo posledni
387 // auto, ktere u nich zamcelo nejakou hranu a vrati se true, v opacnem pripade se
388 // vrati false
389
390 // Pozn.: Jestlize by se zamykala treba jen pristi hrana (ne vsechny najednou),
391 // hrozilo by, ze se auto svym stredem v dolni podstave ocitne na jim
392 // nezamcene hrane.
393
394 // parametry:
395 // pPath - ukazatel na vektor, kde jsou ulozeny vsechny krizovatky (jejich id)
396 // v ceste auta
397 // lastJuncInPath - mala krizovatka, ze ktere auto jede, je vyjadrena indexem
398 // v ceste path (na zacatku tedy index 0)
399 // isLastCar - rika, zda auto je posledni na vstupni hrane
400 // isStopedCar - rika, zda auto stoji pred velkou krizovatkou (bude se hodit pri
401 // reseni deadlocku v metode rightHandRule (slouzi pro zjisteni, zda auto muze
402 // jet na nejake male krizovatce v te velke podle PPR))
403 // carLength - delka auta (slouzi ke zjisteni, zda je na vystupni normalni
404 // hrane pro auto dostatek mista)
405 // carId - id auta (potrebne pro metodu rightHandRule)
406 bool lockJuncsEdgesForNewCar(const std::vector<unsigned int> *const pPath,
407 const unsigned int lastJuncInPath,const bool isLastCar,const bool isStopedCar,
408 const float carLength,const unsigned int carId);
409
410 // najde pro auto (s id == carId) sekvenci kratkych hran (pres ktere auto pojede
411 // v pristi velke krizovatce z Out do In), ktera zacina pristi vystupni hranou
412 // (roads[(*pPath)[lastJuncInPath+1]][(*pPath)[lastJuncInPath+2]]);
413 // u vsech techto hran metoda zaznamena, ze pres ne auto pojede (z Out do In) ve
414 // sve pristi velke krizovatce, je na normalni hrane posledni a je blizko
415 // dalsi krizovatky (tak, ze ostatni auta, ktera pojedou pres casti tech kratkych
416 // hran za jejich body In, zvazuji, zda mu daji prednost)
417
418 // parametry:
419 // pPath - ukazatel na vektor, kde jsou ulozeny vsechny krizovatky
420 // v ceste auta
421 // lastJuncInPath - mala krizovatka, ze ktere auto jede, je vyjadrena indexem
422 // v ceste path (na zacatku tedy index 0)
423 // carId - id auta
424 void regIncomingCarToShortEdges(const std::vector<unsigned int> *const pPath,
425 const unsigned int lastJuncInPath,const unsigned int carId);
426
427 // najde pro auto (s id == carId) sekvenci kratkych hran (pres ktere
428 // auto pojede v pristi velke krizovatce z Out do In), ktera zacina
429 // pristi vystupni hranou
430 // (roads[(*pPath)[lastJuncInPath+1]][(*pPath)[lastJuncInPath+2]]);
431 // u vsech techto hran metoda zaznamena, ze auto je na normalni hrane
432 // posledni a stoji
433
434 // parametry:
435 // pPath - ukazatel na vektor, kde jsou ulozeny vsechny krizovatky
436 // v ceste auta
437 // lastJuncInPath - mala krizovatka, ze ktere auto jede, je vyjadrena indexem
438 // v ceste path (na zacatku tedy index 0)
439 // carId - id auta
440 void setStopedIncomingCarToShortEdges(const std::vector<unsigned int> *const pPath,
441 const unsigned int lastJuncInPath,const unsigned int carId);
442
443 // tato metoda resi pravidlo prave ruky, auto vjizdi do male krizovatky
444 // pres vstupni hranu inEdge;
445
446 // auto ma povoleni jet podle pravidla prave ruky, jestlize:
447 // I. pro vsechny jeji normalni a kratke vstupni hrany, pres ktere auto chce jet a
448 // se kterymi svira hrana, pres kterou chce vjet vozidlo do krizovatky, uhel mensi
449 // nez 135°, plati:
450 // a) pro normalni hranu: posledni auto je pred bodem, ktery je vzdalenost d
451 // pred bodem stopOrGoDecision (tedy krome tohoto auta samotneho - auto si
452 // nebude davat prednost samo sobe - to by se mohlo stat, kdyz by auto jelo
453 // pres cyklus kratkych hran a nebylo by to osetrene - i s timto autem by se
454 // pocitalo);
455 // (d je vzdalenost toho auta potrebna ke zpomaleni na 0-ovou rychlost +
456 // 2*prumerna delka auta)
457 // b) pro kratkou hranu: neexistuje zadne auto, ktere pres ni pojede (z Out do In)
458 // ve sve pristi velke krizovatce, je posledni na normalni hrane a nachazi se tak
459 // blizko dalsi krizovatky, ze mu toto vozidlo musi dat prednost
460 // (toto auto se nepocita -> auto nebude davat prednost samo sobe - to by
461 // se mohlo stat, kdyz by auto jelo pres cyklus kratkych hran a i toto
462 // auto by se pocitalo)
463 // II. vozidlo stoji na hrane jako posledni a na krizovatce jsou uvazla auta
464 // (nastal deadlock)
465
466 // jestlize auto to povoleni ma, vrati se true, v opacnem pripade false
467
468 // parametry:
469 // withDeadlock - rika zda auto ma povoleni jet podle prave ruky pouze
470 // diky uvaznuti (deadlock)
471 // inEdge - vstupni hrana pro auto do male krizovatky
472 // outEdge - vystupni hrana pro auto z male krizovatky
473 // juncId - id male krizovatky
474 // isCarLastStoped - rika, zda auto, pro ktere se zjistuje PPR,
475 // stoji pred velkou krizovatkou jako posledni auto na hrane,
476 // bude se hodit pri reseni deadlocku
477 // carId - id auta
478 bool rightHandRule(bool &withDeadlock,const unsigned int inEdge,const unsigned int outEdge,
479 const unsigned int juncId,const bool isCarLastStoped,const unsigned int carId);
480
481 // Tato metoda odemyka (ne vzdy uplne odemce) minulou hranu k zamceni -
482 // dekrementuje u ni lockCount, viz lockCount u JuncsEdge.
483
484 // Jestlize je auto na vystupni hrane a doslo k preskoceni prilis uzke sloucene hrany
485 // (to se muze stavat pri nizkem fps), bude odemykana ta sloucena i vstupni hrana.
486
487 // Pozn.: Auto muze byt poprve na sloucene hrane, i kdyz neni na jeji prvni dilci
488 // hrane po vstupni hrane.
489
490 // Metoda predpoklada, ze je volana pouze tehdy, jestlize doslo k prechodu pres hranu k zamceni.
491
492 // Sloucena hrana se povazuje za odemcenou, jestlize jsou vsechny jeji dilci hrany odemcene.
493
494 // parametry:
495 // edgeId - aktualni hrana, na ktere je auto;
496 // lastJuncId - minula krizovatka, bude urcovat vstupni hranu do krizovatky,
497 // u ktere je auto
498 // nextJuncId - id male krizovatky, u ktere je auto
499 // nextNextJuncId - id male kriz. po ni
500 // mergedEdgeSkiped - rika, zda doslo k preskoceni prilis uzke sloucene hrany
501 // carId - id auta
502 void decreaseLockCountForPrevEdge(const unsigned int edgeId,
503 const unsigned int lastJuncId,const unsigned int nextJuncId,
504 const unsigned int nextNextJuncId,const bool mergedEdgeSkiped,
505 const unsigned int carId);
506
507 // tato metoda vypocita doporucenou rychlost na krizovatce s id juncId
508 // pro auto, ktere jede ze vstupni hrany inEdge do vystupni hrany outEdge
509 void computeRecVelocityOnJunc(float &recVel,const unsigned int juncId,
510 const unsigned int inEdge,const unsigned int outEdge);
511
512 // metoda urci typ zatoceni (doleva, doprava, rovne) na krizovatce juncId,
513 // na ktere auto jede ze vtupni hrany inEdge na vystupni hranu outEdge,
514 // vysledek vrati v prvnim parametru
515 void getTurnOnJunc(unsigned int &turnOnJunc,const unsigned int juncId,
516 const unsigned int inEdge,const unsigned int outEdge);
517
518 // metoda, ktera na zacatku simulace nahodne vygeneruje auta,
519 // bude jich numOfGenCars; parametr genShortestPath urcuje, zda vygenerovane cesty
520 // maji byt nejkratsi (ze startovni do koncove hrany)
521 void generateCars(const unsigned int numOfGenCars,const bool genShortestPath);
522
523 // pro debugovani umisti na bod malou zelenou krychlicku
524 void showPoint(const osg::Vec3 &point);
525
526 // rika, zda u male krizovatky juncId vznikl deadlock (uvzaznuti), vznikl jestlize:
527 // a) jsou vsechny vstupni a vystupni hrany krizovatky odemcene
528 // b) na zadne vstupni normalni hrane neni auto, ktere je na ni posledni
529 // a ktere jede (nestoji)
530 // c) na zacatky vsech vystupnich normalnich hran se vejde auto
531 // s maximalni moznou delkou (ke ktere je pripoctena mala rezerva)
532 // (auto libovolne delky, ktere ceka pouze na to, az se pro nej na vystupni hrane
533 // uvolni misto, musi projet krizovatku drive nez vozidlo, ktere pres ni muze
534 // jet pouze diky uvaznuti) nebo na nich musi prvni auto stat
535 // d) pro zadnou kratkou vstupni hranu neexistuje auto, ktere pres ni pojede (z Out
536 // do In) ve sve pristi velke krizovatce, je na normalni hrane posledni, nachazi se
537 // blizko dalsi krizovatky (tak, ze auta u krizovatky juncId zvazuji, zda mu nedaji
538 // prednost) a ktere jede (nestoji)
539 // e) v poslednim snimku nedoslo k odemceni hrany u krizovatky (pokud se na
540 // krizovatce nebo v jeji tesne blizkosti neco deje, neni zablokovana)
541
542 // Pozn.: ma vyznam pouze pro male krizovatky ve velkych krizovatkach, ktere nejsou
543 // rizeny semafory; jestlize je velka krizovatka rizena semafory, je vzdy tvorena pouze
544 // jednou malou krizovatkou, na ktere nemuze vzniknout deadlock
545 bool isDeadlock(const unsigned int juncId);
546
547 // tato metoda nacte ze vstupniho XML souboru z elementu TLparameters
548 // cesty k souborum s geometriemi (modely) casti semaforu, ktere nasledne take nacte,
549 // dale take nacte vzdalenost mezi stredy barevnych svetel semaforu
550 void loadTLparameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *const pTLparametersNode);
551
552 // metoda, ktera vytvori semafory na krizovatkach, ktere jsou rizeny semafory
553 void createTrafficLights(void);
554
555 // zkontroluje, zda krizovatka (mala) s id juncId splnuje kriteria pro krizovatku se semafory
556 // (pro jednoduchost se mala krizovatka, ktera je rizena semafory, vyskytuje ve
557 // velke krizovatce vzdy sama a propojuje 3-4 silnice, v nichz jsou alespon 2 normalni
558 // hrany, ktere smeruji do krizovatky a alespon 1 normalni hrana, ktera smeruje ze krizovatky);
559 // kriteria jsou splnena -> vrati true, jinak false
560 bool isValidJuncWithTLs(unsigned int juncId);
561
562 DECLARE_INPUT(InUnregCarForEdge, MessageCarEdge);
563 DECLARE_INPUT(InAddForEdgeRegisteredCarToPutAsideCars, MessageCarEdge);
564
565 DECLARE_REQUEST_INPUT(InGetReady, MessageVoid, MessageBool);
566 DECLARE_REQUEST_INPUT(InGetDataPath, MessageVoid, MessageString);
567 DECLARE_REQUEST_INPUT(InGetEdgeAbsPos, MessageEdgeOffset, MessageVec3);
568 DECLARE_REQUEST_INPUT(InGetEdgeOutInVec, MessageUnsignedInt, MessageVec3);
569 DECLARE_REQUEST_INPUT(InGetEdgeNormal, MessageUnsignedInt, MessageVec3);
570 DECLARE_REQUEST_INPUT(InFindShortestPath, MessageStartStopDestination, MessageVectorUnsignedInt);
571 DECLARE_REQUEST_INPUT(InCheckCarStopPosition, MessageCarEdgeData, MessageBool);
572 DECLARE_REQUEST_INPUT(InGetStartOrStopEdgeFromRoadAndDirection, MessageRoadAndDir, MessageUnsignedInt);
573 DECLARE_REQUEST_INPUT(InRegCarForEdge, MessageCarEdgeData, MessageBool);
574 DECLARE_REQUEST_INPUT(InGetRecVelOnJunc, MessageFirst3Juncs, MessageFloat);
575 DECLARE_REQUEST_INPUT(InGetTurnOnJunc, MessageFirst3Juncs, MessageUnsignedInt);
576 DECLARE_REQUEST_INPUT(InIsCarFstPutAsideOnEdge, MessageCarEdge, MessageBool);
577 DECLARE_REQUEST_INPUT(InRegisterPutAsideCarForEdge, MessageCarEdgeData, MessageBool);
578 DECLARE_REQUEST_INPUT(InGetCarEnvirons, MessageCarSimParameters, MessageCarEnvirons);
579 };
580
581 }
582
583 #endif
584
585
586
587
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomEditor.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
RoomEditor.h
Go to the documentation of this file.
1 #ifndef _ROOM_EDITOR_H
2 #define _ROOM_EDITOR_H
3
4 #include <vrecko/ReaderWriter.h>
5
6 #include <vreckoAP/EditorController/ControllableAbility.h>
7
8 #include <vrecko/Ability.h>
9 #include <vrecko/EnvironmentObject.h>
10 #include <vrecko/Scene.h>
11 #include <vrecko/EventDispatcher.h>
12 #include <vrecko/Logger.h>
13
14 #include <osgDB/ReadFile>
15
16 #include <sstream>
17 #include <map>
18 #include <vector>
19 #include <string>
20
21 #include "WallGeometry.h"
22 #include "Tool.h"
23 #include "ColorBucket.h"
24 #include "RoomSaver.h"
25 #include "RoomLoader.h"
26 #include "WallRemove.h"
27 #include "PointMove.h"
28 #include "WallAdd.h"
29 #include "WallMovement.h"
30 #include "PointAdd.h"
31 #include "CreateHole.h"
32 #include "HoleRemove.h"
33
34 using namespace vrecko;
35 using namespace vrecko;
36
37 namespace APRoomEdit {
38
39 class RoomEditor: public ControllableAbility {
40 public:
41 RoomEditor();
42 virtual ~RoomEditor();
43
44 virtual void update(void);
45
46 void setIntersection(osg::Vec3& position, vrecko::Scene* scenePtr);
47 inline osgUtil::LineSegmentIntersector::Intersection getIntersection() { return intersection; }
48
49 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
50 protected:
51 virtual void fillDefaultInfo();
52
53 virtual bool activate();
54 virtual void deactivate();
55
56 void issueRequests(bool bStopIfNoSelection);
57
58 virtual void processButtonPress(CABUTTONEVENT* eventData);
59 virtual void processButtonRelease(CABUTTONEVENT* eventData);
60
61 void RoomEditor::menuItemClicked(const char* itemID);
62
63 bool showToolMenu();
64
65 private:
66 // intersection information of selected object
67 osgUtil::LineSegmentIntersector::Intersection intersection;
68
69 bool toolChange;
70 bool menuShown;
71 bool bFirstUpdate;
72
73 Tool* tool;
74 std::map<std::string, std::map<std::string, Tool *> > tools;
75
76 unsigned long selectedObjectId;
77 WallGeometry* pWallGeometry;
78
79 osg::Vec3 firstPointerPos;
80
81 bool hasMoreThanOneTool() { return ((tools.size() > 1) || ((tools.size() == 1) && ((*tools.begin()).second.size() > 1))); }
82 };
83
84 }
85
86
87
88 #endif
89
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomLoader.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
RoomLoader.h
Go to the documentation of this file.
1 #ifndef _ROOM_LOADER_H
2 #define _ROOM_LOADER_H
3
4 #include "Tool.h"
5 #include "Geometry.h"
6
7 namespace APRoomEdit {
8
9 // tool to load room from xml
10 class RoomLoader : public Tool {
11 public:
12 RoomLoader(std::string f) {filename = f; type=LOADER; useEG=true;}
13 virtual ~RoomLoader() {}
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
16 if (findXMLNode(pParametersNode, "FileName")) {
17 ReaderWriter::getStringValue(filename, pParametersNode, "FileName");
18 name = filename;
19 if (findXMLNode(pParametersNode, "UseEmbeddedGeometry")) {
20 useEG = ReaderWriter::getBoolValue(pParametersNode, "UseEmbeddedGeometry");
21 }
22 }
23 else
24 return false;
25 return true;
26 }
27
28 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
29 WG_Wall* curWall,
30 WG_Point* curPoint,
31 PointType type,
32 vrecko::EnvironmentObject* pEOOwner,
33 std::vector<osg::ref_ptr<WG_Wall> >* walls,
34 std::vector<osg::ref_ptr<WG_Point> >* points,
35 osg::Geode* pOSGGeode,
36 osg::Vec3Array* pOSGVertexArray) {
37
38 //verify if given file exists
39 std::ifstream file(filename.c_str());
40 if(!file) {
41 logger.errorLog("RoomEdit Plugin: ERROR in loading scene - file: '%s' doesn't exists", filename.c_str());
42 return;
43 }
44
45 file.close();
46
47 // Notify user
48 vrecko::logger.noticeLog("RoomEdit Plugin: Loading model from %s", filename.c_str());
49 std::vector<osg::ref_ptr<WG_Point> > tempPoints;
50
51 // Create XML parser and parse the input file
52 XercesDOMParser* Parser = new XercesDOMParser();
53 const char* F;
54 F = (filename.c_str());
55 Parser->parse(F);
56 XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document = Parser->getDocument();
57
58 // Get root
59 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* RootNode = Document->getDocumentElement();
60
61 //XMLCh tempStr[100];
62
63
64 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* wallGeometryNode = findXMLNode(RootNode, "WallGeometry");
65
66
67 int id;
68 osg::Vec2 position;
69 float height = RE_DEFAULT_HEIGHT;
70 WG_Point* tempPoint;
71 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* pointsNodes = findXMLNode(RootNode, "Points");
72 int pointSize = ReaderWriter::getIntValue(pointsNodes, "PointsCount");
73 tempPoints.resize(pointSize);
74
75 // Go through all Points
76 for (int i = 1; i < pointSize+1; i++) {
77 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* pointNode = pointsNodes->getChildNodes()->item(i);
78 id = ReaderWriter::getIntValue(pointNode, "Id");
79 height = ReaderWriter::getFloatValue(pointNode, "Height");
80 ReaderWriter::getVec2Value(position, pointNode, "Position");
81
82 std::cout << id << ": " << height << ", " << position.x() << ", " << position.y() << std::endl;
83
84 tempPoint = new WG_Point(position, height);
85 tempPoint->setId(id);
86 tempPoints[id] = tempPoint;
87 }
88
89
90 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* wallsNodes = findXMLNode(RootNode, "Walls");
91 int wallSize = ReaderWriter::getIntValue(wallsNodes, "WallsCount");
92
93 if (wallSize) {
94 points->clear();
95 for (unsigned int a=0; a<tempPoints.size(); a++)
96 points->push_back(tempPoints.at(a));
97 tempPoints.clear();
98 }
99 else {
100 vrecko::logger.warningLog("No walls included. Model will not be changed.");
101 tempPoints.clear();
102 return;
103 }
104
105 walls->clear();
106
107 int qId, rId;
108 WG_Wall* tempWall;
109 osg::Vec3 tempVec3;
110 osg::Vec2 tempVec2;
111 // Go through all Points
112 for (int j = 1; j < wallSize+1; j++) {
113 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* wallNode = wallsNodes->getChildNodes()->item(j);
114 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* qNode = findXMLNode(wallNode, "QPoint");
115 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* rNode = findXMLNode(wallNode, "RPoint");
116 qId = ReaderWriter::getIntValue(qNode, "Id");
117 rId = ReaderWriter::getIntValue(rNode, "Id");
118
119 cout<< "loaded ids "<< j <<": " << qId << ", " << rId << endl;
120
121 tempWall = new WG_Wall(points->at(qId).get(), points->at(rId).get(), false);
122
123 ReaderWriter::getVec3Value(tempVec3, qNode, "Color");
124 tempWall->setColor(tempVec3, WG_Q_POINT);
125
126 ReaderWriter::getVec3Value(tempVec3, rNode, "Color");
127 tempWall->setColor(tempVec3, WG_R_POINT);
128
129 if (useEG) {
130 ReaderWriter::getVec3Value(tempVec3, qNode, "tCWV");
131 tempWall->getVertices(WG_Q_POINT)->setTopCWVertex(tempVec3);
132
133 ReaderWriter::getVec3Value(tempVec3, qNode, "tCCWV");
134 tempWall->getVertices(WG_Q_POINT)->setTopCCWVertex(tempVec3);
135
136 ReaderWriter::getVec3Value(tempVec3, qNode, "bCWV");
137 tempWall->getVertices(WG_Q_POINT)->setBottomCWVertex(tempVec3);
138
139 ReaderWriter::getVec3Value(tempVec3, qNode, "bCCWV");
140 tempWall->getVertices(WG_Q_POINT)->setBottomCCWVertex(tempVec3);
141
142 ReaderWriter::getVec2Value(tempVec2, qNode, "nCWV");
143 tempWall->getVertices(WG_Q_POINT)->setNormalCWVertex(tempVec2);
144
145 ReaderWriter::getVec2Value(tempVec2, qNode, "nCCWV");
146 tempWall->getVertices(WG_Q_POINT)->setNormalCCWVertex(tempVec2);
147
148 ReaderWriter::getVec3Value(tempVec3, rNode, "tCWV");
149 tempWall->getVertices(WG_R_POINT)->setTopCWVertex(tempVec3);
150
151 ReaderWriter::getVec3Value(tempVec3, rNode, "tCCWV");
152 tempWall->getVertices(WG_R_POINT)->setTopCCWVertex(tempVec3);
153
154 ReaderWriter::getVec3Value(tempVec3, rNode, "bCWV");
155 tempWall->getVertices(WG_R_POINT)->setBottomCWVertex(tempVec3);
156
157 ReaderWriter::getVec3Value(tempVec3, rNode, "bCCWV");
158 tempWall->getVertices(WG_R_POINT)->setBottomCCWVertex(tempVec3);
159
160 ReaderWriter::getVec2Value(tempVec2, rNode, "nCWV");
161 tempWall->getVertices(WG_R_POINT)->setNormalCWVertex(tempVec2);
162
163 ReaderWriter::getVec2Value(tempVec2, rNode, "nCCWV");
164 tempWall->getVertices(WG_R_POINT)->setNormalCCWVertex(tempVec2);
165
166 ReaderWriter::getVec3Value(tempVec3, wallNode, "topNormal");
167 tempWall->setTopNormal(tempVec3);
168
169 ReaderWriter::getVec3Value(tempVec3, wallNode, "bottomNormal");
170 tempWall->setBottomNormal(tempVec3);
171
172 ReaderWriter::getVec3Value(tempVec3, wallNode, "qrNormal");
173 tempWall->setFaceNormal(tempVec3, WG_Q_POINT);
174
175 ReaderWriter::getVec3Value(tempVec3, wallNode, "rqNormal");
176 tempWall->setFaceNormal(tempVec3, WG_R_POINT);
177 }
178
179
180 walls->push_back(tempWall);
181 }
182
183 if (useEG)
184 for (unsigned int k=0; k<walls->size(); k++) {
185 walls->at(k)->setFlag(RE_WALL_DRAWN);
186 }
187 else
188 for (unsigned int k=0; k<walls->size(); k++) {
189 if (!(walls->at(k)->getFlag() & RE_WALL_DRAWN)) {
190 walls->at(k)->computeAttrVertices();
191 }
192 }
193
194 delete Parser;
195
196 setDirty(true);
197 }
198
199 private:
200 std::string filename;
201 bool useEG;
202 };
203
204 }
205
206 #endif
207
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/RoomSaver.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
RoomSaver.h
Go to the documentation of this file.
1 #ifndef _ROOM_SAVER_H
2 #define _ROOM_SAVER_H
3
4 #include "Tool.h"
5 #include "Geometry.h"
6
7 namespace APRoomEdit {
8
9 // tool tosave room into xml
10 class RoomSaver : public Tool {
11 public:
12 RoomSaver(std::string f) {filename = f; type=SAVER; useEG=true;}
13 virtual ~RoomSaver() {}
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
16 if (findXMLNode(pParametersNode, "FileName")) {
17 ReaderWriter::getStringValue(filename, pParametersNode, "FileName");
18 name = filename;
19 if (findXMLNode(pParametersNode, "UseEmbeddedGeometry")) {
20 useEG = ReaderWriter::getBoolValue(pParametersNode, "UseEmbeddedGeometry");
21 }
22 }
23 else
24 return false;
25 return true;
26 }
27
28 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
29 WG_Wall* curWall,
30 WG_Point* curPoint,
31 PointType type,
32 vrecko::EnvironmentObject* pEOOwner,
33 std::vector<osg::ref_ptr<WG_Wall> >* walls,
34 std::vector<osg::ref_ptr<WG_Point> >* points,
35 osg::Geode* pOSGGeode,
36 osg::Vec3Array* pOSGVertexArray) {
37
38 vrecko::logger.noticeLog("RoomEdit Plugin: saving model to file %s", filename.c_str());
39
40 // Init document tree
41 XMLCh tempStr[100];
42 char tempChar[99];
43 XMLString::transcode("Range", tempStr, 99);
44 XERCES_CPP_NAMESPACE_QUALIFIER DOMText* TextNode;
45 DOMImplementation* Impl = DOMImplementationRegistry::getDOMImplementation(tempStr);
46
47 // Create root node: VreckoRoomEditModel
48 XMLString::transcode("VreckoRoomEditModel", tempStr, 99);
49 XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document = Impl->createDocument(0, tempStr, 0);
50 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Root = Document->getDocumentElement();
51
52 //Create node: WallGeometry
53 XMLString::transcode("WallGeometry", tempStr, 99);
54 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* WallGeometry = Document->createElement(tempStr);
55 Root->appendChild(WallGeometry);
56
57 //Create node: Points
58 XMLString::transcode("Points", tempStr, 99);
59 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Points = Document->createElement(tempStr);
60 Root->appendChild(Points);
61
62
63 // Create node: PointsCount
64 XMLString::transcode("PointsCount", tempStr, 99);
65 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* PointsCount = Document->createElement(tempStr);
66 Points->appendChild(PointsCount);
67 sprintf(tempChar, "%d", points->size());
68 XMLString::transcode(tempChar, tempStr, 99);
69 TextNode = Document->createTextNode(tempStr);
70 PointsCount->appendChild(TextNode);
71
72 for (unsigned int i = 0; i < points->size(); i++) {
73 // Get point
74 WG_Point* CurrentPoint = points->at(i).get();
75 // Create node: Point
76 XMLString::transcode("Point", tempStr, 99);
77 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Point = Document->createElement(tempStr);
78 Points->appendChild(Point);
79
80 // Create node: Position, height, id
81 XMLString::transcode("Position", tempStr, 99);
82 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Position = Document->createElement(tempStr);
83 Point->appendChild(Position);
84 sprintf(tempChar, "%f %f", CurrentPoint->getPosition().x(), CurrentPoint->getPosition().y());
85 XMLString::transcode(tempChar, tempStr, 99);
86 TextNode = Document->createTextNode(tempStr);
87 Position->appendChild(TextNode);
88
89 XMLString::transcode("Height", tempStr, 99);
90 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Height = Document->createElement(tempStr);
91 Point->appendChild(Height);
92 sprintf(tempChar, "%f", CurrentPoint->getHeight());
93 XMLString::transcode(tempChar, tempStr, 99);
94 TextNode = Document->createTextNode(tempStr);
95 Height->appendChild(TextNode);
96
97 XMLString::transcode("Id", tempStr, 99);
98 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Id = Document->createElement(tempStr);
99 Point->appendChild(Id);
100 sprintf(tempChar, "%d", CurrentPoint->getId());
101 XMLString::transcode(tempChar, tempStr, 99);
102 TextNode = Document->createTextNode(tempStr);
103 Id->appendChild(TextNode);
104 }
105
106 //Create node: Walls
107 XMLString::transcode("Walls", tempStr, 99);
108 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Walls = Document->createElement(tempStr);
109 Root->appendChild(Walls);
110
111 // Create node: WallsCount
112 XMLString::transcode("WallsCount", tempStr, 99);
113 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* WallsCount = Document->createElement(tempStr);
114 Walls->appendChild(WallsCount);
115 sprintf(tempChar, "%d", walls->size());
116 XMLString::transcode(tempChar, tempStr, 99);
117 TextNode = Document->createTextNode(tempStr);
118 WallsCount->appendChild(TextNode);
119
120 for (unsigned int j = 0; j < walls->size(); j++) {
121 WG_Wall* currentWall = walls->at(j).get();
122 WG_Point* Q = currentWall->getPoint(WG_Q_POINT);
123 WG_Point* R = currentWall->getPoint(WG_R_POINT);
124 // Create node: Wall
125 XMLString::transcode("Wall", tempStr, 99);
126 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* Wall = Document->createElement(tempStr);
127 Walls->appendChild(Wall);
128
129 // Create node: QPoint, RPoint
130 XMLString::transcode("QPoint", tempStr, 99);
131 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QPoint = Document->createElement(tempStr);
132 Wall->appendChild(QPoint);
133
134 // Create node: Q attributes
135 // Id
136 XMLString::transcode("Id", tempStr, 99);
137 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QId = Document->createElement(tempStr);
138 QPoint->appendChild(QId);
139 sprintf(tempChar, "%d", Q->getId());
140 XMLString::transcode(tempChar, tempStr, 99);
141 TextNode = Document->createTextNode(tempStr);
142 QId->appendChild(TextNode);
143
144 // Color
145 XMLString::transcode("Color", tempStr, 99);
146 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QColor = Document->createElement(tempStr);
147 QPoint->appendChild(QColor);
148 sprintf(tempChar, "%f %f %f", currentWall->getColor(WG_Q_POINT).x(), currentWall->getColor(WG_Q_POINT).y(), currentWall->getColor(WG_Q_POINT).z());
149 XMLString::transcode(tempChar, tempStr, 99);
150 TextNode = Document->createTextNode(tempStr);
151 QColor->appendChild(TextNode);
152
153 if (useEG) {
154 // tCWV
155 XMLString::transcode("tCWV", tempStr, 99);
156 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QtCWV = Document->createElement(tempStr);
157 QPoint->appendChild(QtCWV);
158 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_Q_POINT)->getTopCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getTopCWVertex().y(), currentWall->getVertices(WG_Q_POINT)->getTopCWVertex().z());
159 XMLString::transcode(tempChar, tempStr, 99);
160 TextNode = Document->createTextNode(tempStr);
161 QtCWV->appendChild(TextNode);
162
163 // tCCWV
164 XMLString::transcode("tCCWV", tempStr, 99);
165 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QtCCWV = Document->createElement(tempStr);
166 QPoint->appendChild(QtCCWV);
167 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_Q_POINT)->getTopCCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getTopCCWVertex().y(), currentWall->getVertices(WG_Q_POINT)->getTopCCWVertex().z());
168 XMLString::transcode(tempChar, tempStr, 99);
169 TextNode = Document->createTextNode(tempStr);
170 QtCCWV->appendChild(TextNode);
171
172 // bCWV
173 XMLString::transcode("bCWV", tempStr, 99);
174 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QbCWV = Document->createElement(tempStr);
175 QPoint->appendChild(QbCWV);
176 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_Q_POINT)->getBottomCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getBottomCWVertex().y(), currentWall->getVertices(WG_Q_POINT)->getBottomCWVertex().z());
177 XMLString::transcode(tempChar, tempStr, 99);
178 TextNode = Document->createTextNode(tempStr);
179 QbCWV->appendChild(TextNode);
180
181 // bCCWV
182 XMLString::transcode("bCCWV", tempStr, 99);
183 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QbCCWV = Document->createElement(tempStr);
184 QPoint->appendChild(QbCCWV);
185 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_Q_POINT)->getBottomCCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getBottomCCWVertex().y(), currentWall->getVertices(WG_Q_POINT)->getBottomCCWVertex().z());
186 XMLString::transcode(tempChar, tempStr, 99);
187 TextNode = Document->createTextNode(tempStr);
188 QbCCWV->appendChild(TextNode);
189
190
191 // nCWV
192 XMLString::transcode("nCWV", tempStr, 99);
193 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QnCWV = Document->createElement(tempStr);
194 QPoint->appendChild(QnCWV);
195 sprintf(tempChar, "%f %f", currentWall->getVertices(WG_Q_POINT)->getNormalCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getNormalCWVertex().y());
196 XMLString::transcode(tempChar, tempStr, 99);
197 TextNode = Document->createTextNode(tempStr);
198 QnCWV->appendChild(TextNode);
199
200 // nCCWV
201 XMLString::transcode("nCCWV", tempStr, 99);
202 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* QnCCWV = Document->createElement(tempStr);
203 QPoint->appendChild(QnCCWV);
204 sprintf(tempChar, "%f %f", currentWall->getVertices(WG_Q_POINT)->getNormalCCWVertex().x(), currentWall->getVertices(WG_Q_POINT)->getNormalCCWVertex().y());
205 XMLString::transcode(tempChar, tempStr, 99);
206 TextNode = Document->createTextNode(tempStr);
207 QnCCWV->appendChild(TextNode);
208 }
209
210
211
212
213 XMLString::transcode("RPoint", tempStr, 99);
214 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RPoint = Document->createElement(tempStr);
215 Wall->appendChild(RPoint);
216
217 // Create node: R attributes
218 // Id
219 XMLString::transcode("Id", tempStr, 99);
220 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RId = Document->createElement(tempStr);
221 RPoint->appendChild(RId);
222 sprintf(tempChar, "%d", R->getId());
223 XMLString::transcode(tempChar, tempStr, 99);
224 TextNode = Document->createTextNode(tempStr);
225 RId->appendChild(TextNode);
226
227 // Color
228 XMLString::transcode("Color", tempStr, 99);
229 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RColor = Document->createElement(tempStr);
230 RPoint->appendChild(RColor);
231 sprintf(tempChar, "%f %f %f", currentWall->getColor(WG_R_POINT).x(), currentWall->getColor(WG_R_POINT).y(), currentWall->getColor(WG_R_POINT).z());
232 XMLString::transcode(tempChar, tempStr, 99);
233 TextNode = Document->createTextNode(tempStr);
234 RColor->appendChild(TextNode);
235
236 if (useEG) {
237 // tCWV
238 XMLString::transcode("tCWV", tempStr, 99);
239 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RtCWV = Document->createElement(tempStr);
240 RPoint->appendChild(RtCWV);
241 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_R_POINT)->getTopCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getTopCWVertex().y(), currentWall->getVertices(WG_R_POINT)->getTopCWVertex().z());
242 XMLString::transcode(tempChar, tempStr, 99);
243 TextNode = Document->createTextNode(tempStr);
244 RtCWV->appendChild(TextNode);
245
246 // tCCWV
247 XMLString::transcode("tCCWV", tempStr, 99);
248 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RtCCWV = Document->createElement(tempStr);
249 RPoint->appendChild(RtCCWV);
250 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_R_POINT)->getTopCCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getTopCCWVertex().y(), currentWall->getVertices(WG_R_POINT)->getTopCCWVertex().z());
251 XMLString::transcode(tempChar, tempStr, 99);
252 TextNode = Document->createTextNode(tempStr);
253 RtCCWV->appendChild(TextNode);
254
255 // bCWV
256 XMLString::transcode("bCWV", tempStr, 99);
257 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RbCWV = Document->createElement(tempStr);
258 RPoint->appendChild(RbCWV);
259 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_R_POINT)->getBottomCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getBottomCWVertex().y(), currentWall->getVertices(WG_R_POINT)->getBottomCWVertex().z());
260 XMLString::transcode(tempChar, tempStr, 99);
261 TextNode = Document->createTextNode(tempStr);
262 RbCWV->appendChild(TextNode);
263
264 // bCCWV
265 XMLString::transcode("bCCWV", tempStr, 99);
266 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RbCCWV = Document->createElement(tempStr);
267 RPoint->appendChild(RbCCWV);
268 sprintf(tempChar, "%f %f %f", currentWall->getVertices(WG_R_POINT)->getBottomCCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getBottomCCWVertex().y(), currentWall->getVertices(WG_R_POINT)->getBottomCCWVertex().z());
269 XMLString::transcode(tempChar, tempStr, 99);
270 TextNode = Document->createTextNode(tempStr);
271 RbCCWV->appendChild(TextNode);
272
273 // nCWV
274 XMLString::transcode("nCWV", tempStr, 99);
275 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RnCWV = Document->createElement(tempStr);
276 RPoint->appendChild(RnCWV);
277 sprintf(tempChar, "%f %f", currentWall->getVertices(WG_R_POINT)->getNormalCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getNormalCWVertex().y());
278 XMLString::transcode(tempChar, tempStr, 99);
279 TextNode = Document->createTextNode(tempStr);
280 RnCWV->appendChild(TextNode);
281
282 // nCCWV
283 XMLString::transcode("nCCWV", tempStr, 99);
284 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* RnCCWV = Document->createElement(tempStr);
285 RPoint->appendChild(RnCCWV);
286 sprintf(tempChar, "%f %f", currentWall->getVertices(WG_R_POINT)->getNormalCCWVertex().x(), currentWall->getVertices(WG_R_POINT)->getNormalCCWVertex().y());
287 XMLString::transcode(tempChar, tempStr, 99);
288 TextNode = Document->createTextNode(tempStr);
289 RnCCWV->appendChild(TextNode);
290 }
291
292
293 if (useEG) {
294 // Create node: topNormal, bottomNormal, qrNormal, rqNormal
295 XMLString::transcode("topNormal", tempStr, 99);
296 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* topNormal = Document->createElement(tempStr);
297 Wall->appendChild(topNormal);
298 sprintf(tempChar, "%f %f %f", currentWall->getTopNormal().x(), currentWall->getTopNormal().y(), currentWall->getTopNormal().z());
299 XMLString::transcode(tempChar, tempStr, 99);
300 TextNode = Document->createTextNode(tempStr);
301 topNormal->appendChild(TextNode);
302
303 XMLString::transcode("bottomNormal", tempStr, 99);
304 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* bottomNormal = Document->createElement(tempStr);
305 Wall->appendChild(bottomNormal);
306 sprintf(tempChar, "%f %f %f", currentWall->getBottomNormal().x(), currentWall->getBottomNormal().y(), currentWall->getBottomNormal().z());
307 XMLString::transcode(tempChar, tempStr, 99);
308 TextNode = Document->createTextNode(tempStr);
309 bottomNormal->appendChild(TextNode);
310
311 XMLString::transcode("qrNormal", tempStr, 99);
312 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* qrNormal = Document->createElement(tempStr);
313 Wall->appendChild(qrNormal);
314 sprintf(tempChar, "%f %f %f", currentWall->getFaceNormal(WG_Q_POINT).x(), currentWall->getFaceNormal(WG_Q_POINT).y(), currentWall->getFaceNormal(WG_Q_POINT).z());
315 XMLString::transcode(tempChar, tempStr, 99);
316 TextNode = Document->createTextNode(tempStr);
317 qrNormal->appendChild(TextNode);
318
319 XMLString::transcode("rqNormal", tempStr, 99);
320 XERCES_CPP_NAMESPACE_QUALIFIER DOMElement* rqNormal = Document->createElement(tempStr);
321 Wall->appendChild(rqNormal);
322 sprintf(tempChar, "%f %f %f", currentWall->getFaceNormal(WG_R_POINT).x(), currentWall->getFaceNormal(WG_R_POINT).y(), currentWall->getFaceNormal(WG_R_POINT).z());
323 XMLString::transcode(tempChar, tempStr, 99);
324 TextNode = Document->createTextNode(tempStr);
325 rqNormal->appendChild(TextNode);
326 }
327
328 }
329
330 // Serialize and write
331 DOMWriter* Serializer = ((DOMImplementationLS*)Impl)->createDOMWriter();
332 const char* F;
333 F = (filename.c_str());
334 XMLFormatTarget *MyFormTarget = new LocalFileFormatTarget(F);
335 Serializer->writeNode(MyFormTarget, *Document);
336
337 // std::cout << "done. " << std::endl;
338
339 // Release resources
340 Serializer->release();
341 Document->release();
342 delete MyFormTarget;
343 }
344
345 private:
346 std::string filename;
347 bool useEG;
348 };
349
350 }
351
352 #endif
353
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Rotate.h Source File

  • File List
  • File Members
  • include
  • base
Rotate.h
Go to the documentation of this file.
1 #ifndef ROTATE_H
2 #define ROTATE_H
3
4 #include <vrecko/Ability.h>
5
6 #include <vrecko/EnvironmentObject.h>
7
8
9 using namespace vrecko;
10
11 namespace base {
12
13 class Rotate: public Ability {
14 public:
15 Rotate();
16 ~Rotate() {};
17
18 void preInitialize(void);
19 void update(void);
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 ParameterVector *getParameterVector(void) {return pParameterVector;}
25 static ParameterVector *pParameterVector;
26
27 protected:
28 float angle, step;
29 EnvironmentObject *owner;
30 };
31
32 }
33
34 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Rotation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Rotation.h
Go to the documentation of this file.
1 #ifndef ROTATION_H
2 #define ROTATION_H
3
4 #include "../EditorController/ControllableAbility.h"
5 //#include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7
8 using namespace vrecko;
9
10 namespace APConnectEditor {
11
12 class Rotation: public ControllableAbility {
13 public:
14 Rotation();
15 virtual ~Rotation() {};
16
17 void update(void);
18
19 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
20
21 protected:
22 virtual void fillDefaultInfo();
23 virtual bool activate();
24 virtual void deactivate();
25
26 bool bLocalRotation;
27
28 osg::Vec3 firstPointerPos; // pointer position when activated
29 osg::Vec3 eyePos;
30 osg::Vec3 lastPointerPos; // pointer position when activated
31
32 osg::Matrix firstObjectMatrix;
33
34 unsigned long movingObjectID; // ID of the object that is being handled. If this is 0, the ability is not activated
35
36
37
38 void issueRequests(bool bStopIfNoSelection);
39
40 bool objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans);
41 // FIRST PART of the tranformation calculations. From the pointer position/rotation the new object
42 // position/rotation is calculated. The matrix is only calculated and stored in [outTrans].
43 // The transformation will be applied afterwards, after another calculations or adjustments.
44 };
45
46 }
47
48 #endif //ROTATION_H
49
50
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/RotationFrameGenAdapter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
RotationFrameGenAdapter.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Referenced>
3 #include "Utils.h"
4 #include "RMFrame.h"
5 #include "HandFrame.h"
6 #include "AxisRotationFrame.h"
7 #include "types.h"
8
9 namespace APDYNAMICART
10 {
11
14 class RotationFrameAdapter : public PoAAdapter<RotationFrameGenerator>
15 {
16 public:
17 RotationFrameAdapter() {}
18
19 protected:
20
21
22 };
23
25 class RMFrameAdapter : public RotationFrameAdapter
26 {
27 public:
28 RMFrameAdapter() : _rotationFrameGen(new RMFrame) {}
29
30 META_DAObject(RMFrameAdapter, "Automatic")
31
32 virtual void createMenu(MenuPtr menu);
33 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
34 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
35
36 virtual RotationFrameGeneratorPtr getObject() { return _rotationFrameGen; }
37
38
39 protected:
40 osg::ref_ptr<RMFrame> _rotationFrameGen;
41 };
42
44 class AxisFrameAdapter : public RotationFrameAdapter
45 {
46 public:
47 AxisFrameAdapter() : _rotationFrameGen(new AxisRotationFrame) {}
48
49 META_DAObject(AxisFrameAdapter, "Tangent aligned")
50
51 virtual void createMenu(MenuPtr menu);
52 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
53 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
54
55 virtual RotationFrameGeneratorPtr getObject() { return _rotationFrameGen; }
56
57
58 protected:
59 osg::ref_ptr<AxisRotationFrame> _rotationFrameGen;
60 };
61
62
64 class HandFrameAdapter : public RotationFrameAdapter
65 {
66 public:
67 HandFrameAdapter() : _rotationFrameGen(new HandFrame) {}
68
69 META_DAObject(HandFrameAdapter , "Manual")
70
71 virtual void createMenu(MenuPtr menu);
72 virtual int load( XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode );
73 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode);
74
75 virtual RotationFrameGeneratorPtr getObject() { return _rotationFrameGen; }
76
77
78 protected:
79 osg::ref_ptr<HandFrame> _rotationFrameGen;
80 };
81
82
83 class RotationFrameFactory : public AdapterFactory<RotationFrameAdapter>
84 {
85 public:
86 RotationFrameFactory()
87 {
88 _adapters.push_back(new RMFrameAdapter);
89 _adapters.push_back(new AxisFrameAdapter());
90 _adapters.push_back(new HandFrameAdapter());
91
92 }
93
94 RotationFrameFactory( const RotationFrameFactory& orig )
95 {
96
97 std::vector<osg::ref_ptr<RotationFrameAdapter>> origAdapters = orig.getSupportedAdapters();
98
99 _adapters.push_back(new RMFrameAdapter());
100 _adapters.push_back(new AxisFrameAdapter());
101 _adapters.push_back(new HandFrameAdapter());
102
103 }
104 };
105
106 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SNCH_Object.h
Go to the documentation of this file.
1
2 #ifndef SNCH_OBJECT_H
3 #define SNCH_OBJECT_H
4
5 #include "SphereBVH_Object.h"
6 #include "SNCH_Object_Data.h"
7
8 #include <vrecko/SP_ObjectInterface.h>
9 #include <vrecko/MTLock.h>
10
11 using namespace vrecko;
12
13 namespace APSpacePartitioning {
14
15 // Flags for SNCH_Object::LocalMinimumDistance::dwFlags
16 #define SNCH_LMD_F_INTERSECTION 0x00000001
17 // The returned points don't mean points of collision, but it is a part of the intersection polyline
18 #define SNCH_LMD_F_NEGATIVE_DISTANCE 0x00000002
19 // The LMD points define negative distance, which (usually?) means largest intersection distance
20 // in a local neigbourhood (and not smallest distance between surfaces).
21 // This can arise only in localSearch and it depends on firstly finding the intersection.
22
23
24 /*
25
26 // Flags for SNCH_Object::LocalMinimumDistance::closeFeatures and other
27
28 Not implemented (yet?)
29
30 #define SNCH_CF_VERTEX1 0x01
31 #define SNCH_CF_VERTEX2 0x02
32 #define SNCH_CF_VERTEX3 0x04
33 #define SNCH_CF_EDGE1 0x08
34 #define SNCH_CF_EDGE2 0x10
35 #define SNCH_CF_EDGE3 0x20
36
37 */
38
39 #define SNCH_FLOAT_SMALL_NUM 0.00000001f
40 //#define SNCH_FLOAT_TOLERANCE 0.001f
41 #define SNCH_FLOAT_TOLERANCE SNCH_FLOAT_SMALL_NUM
42
43
44
45 #define SP_OBJECT_INTERFACE_ID__SNCH 20
46
47
48 class SNCH_Object: public SphereBVH_Object {
49 public:
50 //
51 // constructors / destructors
52 //
53 SNCH_Object();
54 ~SNCH_Object();
55
56 virtual void preInitialize(void);
57
58 float getForce(void);
59
60 void setNCoeficient(double nc) {ncoeficient = nc;}
61 double getNCoeficient(void) {return ncoeficient;}
62 void setMaxForce(double mforce) {max_force = mforce;}
63 double getMaxForce(void) {return max_force;}
64
65 virtual bool getCollisions(CollisionParams * params, COLLISION_POINTS_VECTOR ** colPoints,
66 unsigned long obj1ID, unsigned long obj2ID);
67 // overriden method from SP_ObjectInterface
68
69 typedef struct LocalMinimumDistance {
70 unsigned long dwFlags; // Combination of SNCH_LMD_F_*
71 unsigned long faces[2]; // indices of faces that are colliding
72 osg::Vec3 pointsTrans[2];
73 // Points transformed into world space. Exact meaning depends on [dwFlags].
74 // It is either a possible-future-contact points pair or an intersection line.
75 unsigned short closeFeatures[2];
76 // The vertices and/or edges which are the closest one to the contact points.
77 // Can have of of the values:
78 // 0, 1, 2 - index of the respective vertex
79 // 3, 4, 5 - index of the respective edge + 3
80 // 0xFF - if all of the vertices are too far
81 osg::Vec3 vecTriMaxNegDist;
82 // Used only if [dwFlags] contains SNCH_LMD_F_NEGATIVE_DISTANCE.
83 };
84 typedef std::vector<LocalMinimumDistance> LMDvector;
85
86 class LMDStore {
87 public:
88 LMDStore() { active_LMD = 0; bLMDValid[0] = bLMDValid[1] = false; }
89
90 unsigned char active_LMD;
91 // Which of the LMDs vector is used for local updates (strictly 0 or 1).
92 // The other is for background calculation of global update.
93 bool bLMDValid[2];
94 // Is a particular LMD vector valid? (i.e. Have the initial calculations already ended?)
95 LMDvector LMDs[2];
96
97 // add a timestamp? (TODO?)
98
99 MTLock LMDswitch;
100 // TODO: This might create too many critical sections/mutexes.
101 // (one for each collision pair)
102 // It's a critical section/mutex to protect switching [active_LMD] to the other vector.
103 };
104
105 protected:
106 double ncoeficient, max_force;
107
108 typedef __int64 LMD_HASH; // May need some adjustments for Linux or non-MSVC compilers. (Now it has to be at least 64 bits long.)
109 typedef Sgi::hash_map<LMD_HASH, LMDStore*> LMD_STORE_MAP;
110 LMD_STORE_MAP lmd_store;
111 // DON'T ACCESS THIS DIRECTLY !!! It has to have a multithread access protection.
112 // USE the getLMDStore() method.
113 // The KEY of this hash_map is composed of two object IDs.
114 // Use calcLMDHash() method to calculate it.
115 MTLock lmd_store_access;
116 inline LMD_HASH calcLMDHash(unsigned long int id1, unsigned long int id2)
117 { return (((LMD_HASH)id1) << 32) + (LMD_HASH)id2; }
118
119 LMDStore* getLMDStore(LMD_HASH hash);
120 // Gets a LMDStore for the given hash. Creates one if it doesn't exist.
121
122
123 double reject_distance_for_surfaces, reject_distance_for_BS;
124 double angle_tolerance; // LOD - plane detection (convex, concave surface)
125
126 void globalSearch(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds,
127 CollisionParams *params);
128 void localSearch(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds,
129 CollisionParams *params, int lmdIndex, int dbgWriterGLIndex = 0);
130 bool testNodeNorec(SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1,
131 SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2,
132 LMDStore *lmds, CollisionParams * params);
133 // no-recursion
134
135 bool getObjectsTransformations(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, CollisionParams *params,
136 osg::Matrix *transf1, osg::Matrix *transf2);
137
138
139 struct InternalPointStruct {
140 osg::Vec3 pos;
141 osg::Vec3 normal;
142 };
143 class OneTri {
144 public:
145 OneTri() { reset(); };
146 inline void reset() { planeNormal.x() = FLT_MAX; planeD = FLT_MAX; };
147
148 inline void calcNormal() {
149 if (planeNormal.x() == FLT_MAX) {
150 planeNormal = (v[1].pos - v[0].pos) ^ (v[2].pos - v[0].pos);
151 float len = planeNormal.length();
152
153 bZeroNormal = true;
154 if (len >= SNCH_FLOAT_SMALL_NUM) {
155 bZeroNormal = false;
156 planeNormal /= len;
157 }
158 }
159 }
160
161 inline void calcD() {
162 if (planeD == FLT_MAX)
163 planeD = -(v[0].pos.x() * planeNormal.x() + v[0].pos.y() * planeNormal.y() + v[0].pos.z() * planeNormal.z());
164 }
165
166 InternalPointStruct v[3];
167
168 bool bZeroNormal; // if the [planeNormal] is zero, this will be set to "true".
169 osg::Vec3 planeNormal;
170 float planeD;
171 };
172 typedef OneTri TWO_TRIS[2];
173
174 typedef enum {
175 NoIntersection, // no intersection between the triangle cone and the other triangle
176 OriginalTriangleIntersection, // intersection between the triangles
177 ConeIntersection // intersection between the triangle cone and the other triangle
178 } ProjectionIntersectionResult;
179
180 ProjectionIntersectionResult triProjectionIntersection(
181 OneTri *points0,
182 OneTri *points1,
183 osg::Vec3 *outIntersectionPoint0 = NULL,
184 osg::Vec3 *outIntersectionPoint1 = NULL,
185
186 bool bPerformPretests = true
187 );
188 // WARNING: This function is optimized and so it expects that it will be called twice
189 // for two triangles (with reversed parameters).
190 // This is due to some test at the beginning of the function.
191 //
192 // The idea:
193 // Project vertices on [tri1] using the normals into the plane specified by [tri2].
194 // Then the 2D triangles are tested for intersection.
195 // If triangles lie on the same plane, they are intersecting in theory, but we will take
196 // it as non-intersecting triangles with distance = 0.
197 // [outIntersectionPoint0] and [outIntersectionPoint1] are filled only if the original triangles intersect.
198
199
200 bool triIntersects(OneTri *points0, OneTri *points1, osg::Vec3 *outPoint0Trans = NULL, osg::Vec3 *outPoint1Trans = NULL,
201 osg::Vec3 *outPoint0Tri0Cross = NULL, osg::Vec3 *outPoint1Tri0Cross = NULL, bool *bOutPointsTriCrossValid = NULL);
202 // Returns if both triangles intersects in 3D space.
203 // ASSUMES that the triangles DOES NOT lie on the same plane (this should be checked by the triProjectionIntersection() method)
204 // (SIDE NOTE: The method returns "false" if triangles are coplanar. This would be also OK for us
205 // if they were on the same plane, so basically no assumption needed)
206 // Therefore this method conculdes that if the triangles lie on the planes with
207 // the same or opposite normal, then the triangles don't intersect.
208 // If the triangles intersect, it can also return the middle point of intersection
209 // [outPoint0Tri0Cross], [outPoint0Tri1Cross] are only calculated and outputted if requested.
210 // They represetns the points in space where [tri1] intersects the plane defined by [tri2].
211
212 float triDistance(OneTri *points0, OneTri *points1, osg::Vec3 *outPoint1Trans = NULL, osg::Vec3 *outPoint2Trans = NULL,
213 unsigned short *closeFeature0 = NULL, unsigned short *closeFeature1 = NULL);
214 // Calculates the triangle distance in 3D space.
215 // NOTE that it ASSUMES that the triangles DON'T INTERSECT. This should have been resolved before.
216 // Can calculate points here the distance was achieved.
217 // The points are already transformed into the world space.
218
219 bool old_getTriLMD(
220 SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1, osg::Vec3 *center1,
221 SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2, osg::Vec3 *center2,
222 osg::Vec3 point[2][7], unsigned long *index1, unsigned long *index2);
223 // Getting the LMDs using the old algorithm.
224 // [pSTNode1/2] and [center1/2] may be NULL - in that case the cones won't be used.
225 // (Only the distance between those 7x7 points.)
226
227 };
228
229
230 }
231
232 #endif
233
234
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SNCH_Object_Data.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SNCH_Object_Data.h
Go to the documentation of this file.
1 #ifndef SNCH_OBJECT_DATA_H
2 #define SNCH_OBJECT_DATA_H
3
4 #include "SphereBVH_Object_Data.h"
5 #include <vrecko/Ability.h>
6 #include <osg/Node>
7 #include <osg/Geode>
8 #include <osg/Geometry>
9
10 using namespace vrecko;
11
12 namespace APSpacePartitioning {
13
14 // Flags for SNCH_Object_Data::FaceSNCH::dwSNCHFlags:
15 #define SNCH_FACE_DEGENERATED 0x00000001
16 // The triangle is degenerated. In our context it might mean not only that
17 // two points have the same coordinates, but also that triangle has surface
18 // of size 0.
19
20
21 // Flags for SNCH_Object_Data::FaceSNCH::edgeFlags:
22 #define SNCH_EDGE_CONCAVE_BREAK 0x00000001
23 // The edge forms a concave seam or the edge is a terminating one (belongs to only a single triangle)
24
25
26 // Id for no face group
27 #define FACESNCH_NO_GROUP 0xFFFFFFFF
28 // SNCH_Object_Data::createFaceGroups() method performs optimizations based on the fact,
29 // that FACESNCH_NO_GROUP is last unsigned int value... so DON'T CHANGE IT
30
31
32 class SNCH_Object_Data: public SphereBVH_Object_Data {
33 public:
34 //
35 // constructors / destructors
36 //
37 SNCH_Object_Data();
38 ~SNCH_Object_Data();
39
40 virtual bool isHierarchyCreated() { return bSNCHierarchyCreated; }
41
42 struct VertexSNCH : public VertexBase {
43 std::vector<unsigned long> faces;
44 // ONLY for representants!
45 // A list of faces containing this vertex, sorted CLOCKWISE.
46 osg::Vec3 averageNormal;
47 unsigned long dwRepresentant;
48 // if several vertices lie on the same position, one of the vertices
49 // is chosen as a representant and all of the vertices are pointing
50 // to the selected vertex. ONLY that vertex will have correct information
51 // in the [faces] array.
52 // The representant itself and any vertex that is not sharing position with other vertex,
53 // are pointing to itself (being its own representant).
54 };
55 virtual unsigned long getVertexStructureSize() { return sizeof(VertexSNCH); }
56 virtual void allocateVertexArray(unsigned long numVertices) { vertices = new VertexSNCH[numVertices]; vertex_size = getVertexStructureSize(); }
57 virtual void deallocateVertexArray() { if (vertices) { delete[] ((VertexSNCH*)vertices); } }
58 virtual bool saveVerticesToFile(vrecko::BufferedFileWrite *bfile);
59 virtual bool loadVerticesFromFile(vrecko::BufferedFile *bfile);
60
61 inline VertexSNCH* getSNCHVertex(unsigned long index) { return (VertexSNCH*)getVertex(index); }
62
63 struct FaceSNCH : public FaceBase {
64 unsigned long dwSNCHFlags; // combination of SNCH_FACE_*
65 unsigned long fIndex[3]; // neighbouring faces (0xFFFFFFFF if none)
66 unsigned long edgeFlags[3]; // combination of SNCH_EDGE_*
67
68 unsigned long dwGroup;
69 // Id of a group that contains given face. (FACESNCH_NO_GROUP is for "no group", though this will not be used in any face.)
70 };
71 virtual unsigned long getFaceStructureSize() { return sizeof(FaceSNCH); }
72 virtual void allocateFaceArray(unsigned long numFaces) { faces = new FaceSNCH[numFaces]; face_size = getFaceStructureSize(); }
73 virtual void deallocateFaceArray() { if (faces) { delete[] ((FaceSNCH*)faces); }}
74 virtual bool saveFacesToFile(vrecko::BufferedFileWrite *bfile);
75 virtual bool loadFacesFromFile(vrecko::BufferedFile *bfile);
76
77 inline FaceSNCH* getSNCHFace(unsigned long index) { return (FaceSNCH*)getFace(index); }
78
79
80 struct STNodeSNCH : public STNodeSphere {
81 osg::Vec3 cone_axis;
82 float half_spread_angle; // radians perhaps?
83
84 // NOTE: face_index variable from STNodeSphere is also used here FOR NON-LEAF NODES.
85 // It represents the "best" triangle, that will be used for quick answer if the subsequent
86 // tree tests were assumed unnecessary.
87 };
88 virtual void* allocateSTNode() { return new STNodeSNCH; }
89 virtual unsigned long getSTNodeStructureSize() { return sizeof(STNodeSNCH); }
90 virtual bool saveTreeNodeToFile(void* node, vrecko::BufferedFileWrite *bfile);
91 virtual bool loadTreeNodeFromFile(void* node, vrecko::BufferedFile *bfile);
92
93 // typedef std::map<osg::Vec3, osg::Vec3> NormalsMap;
94
95 protected:
96
97 bool bSNCHierarchyCreated;
98
99 // NormalsMap edge_normal;
100
101 // virtual void createTreeFromGeometry(osg::Node *pNode);
102
103 bool calculateGeometryProperties(void);
104 // Calculates the triangle flags etc.
105 // (= which triangle is degenerated, ...)
106
107 bool generateVertexNeighbourhood(void);
108 // Iterates through all the vertices and generates a list of triangles in the neigbourhood
109 // of each vertex.
110 // Also fills out correct info into [dwRepresentant] and [averageNormal] vertex variables.
111
112 bool createEdgeGroups(void);
113 // Considers all edges and searches for concave breaks.
114
115 bool createFaceGroups(void);
116 // Assigns a group to every triangle based on some criteria.
117 // _PROBABLY_ mostly: similarity with nearby vertices.
118 // Neighbouring vertices with similar normal will be in the same group.
119 // ASSUMES that the face normals are normalized.
120
121 bool computeSNCH(void *pSTNode);
122
123 void calcSubtreeTriangleRepresentant(void *pNode, osg::Vec3 *axis, unsigned long *triangle, float *bestValue = NULL);
124 // Which triangle best represents the given subtree?
125 // [bestValue] is a temporary variable to help with the calculation. Must be NULL at start.
126
127 struct DebugLevelStats {
128 DebugLevelStats() : cntNodes(0), cntAngle(0.0f), cntRadius(0.0f) {};
129
130 int cntNodes;
131 float cntAngle;
132 float cntRadius;
133 };
134
135 struct DebugStats {
136 DebugStats() : totalNodes(0), twoTotal(0), twoNeighbours(0) {};
137
138 int totalNodes;
139 int twoTotal;
140 int twoNeighbours;
141 DynamicArray<DebugLevelStats> levels;
142 };
143
144 void writeDebugStatistics();
145
146 void wdsInfoRec(void *pSTNode, int level, DebugStats *ds);
147
148
149 virtual bool constructCacheDataName(char *pOutDataName, int* version);
150 virtual bool loadDataFromPersistentCache_Init();
151
152
153 virtual bool coreHierarchyCreation(void);
154 };
155
156 }
157
158 #endif
159
160
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SNCHForceFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SNCHForceFilter.h
Go to the documentation of this file.
1 #ifndef SNCH_FORCE_FILTER
2 #define SNCH_FORCE_FILTER
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 #include "CollisionFilterBase.h"
9
10
11 namespace vreckoDP_PHANToM {
12
13 // Flags for SNCHForceFilter::dwThreadForceFlags:
14 #define SNCH_FILTER_FFLAGS_INTERSECTION 0x00000001
15
16
17
18 class SNCHForceFilter : public CollisionFilterBase {
19 friend DWORD WINAPI SNCHForceFilterThreadProc(SNCHForceFilter *filter);
20 public:
21 SNCHForceFilter();
22 ~SNCHForceFilter();
23
24 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
25
26 void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
27
28 void localUpdateAndForceCalculation(bool bRunningInThread);
29 // [bRunningInThread] means "run until filter::bTerminateThread is true
30
31
32 protected:
33 float (*getLMDs)(void);
34 osg::Vec3 tempForce;
35
36 HANDLE hThreadHandle;
37
38 bool bTerminateThread;
39
40 osg::Matrix originalScale;
41
42 MTLockSingleProcess threadLock;
43 osg::Vec3 threadForce;
44 // Force calculated in the separate thread.
45 // Reading and setting this variable must be protected by [threadLock]
46 osg::Vec3 threadTorque;
47 // Torque calculated in the separate thread.
48 // Reading and setting this variable must be protected by [threadLock]
49 unsigned int dwThreadForceFlags;
50 // Force flags - a combination of SNCH_FILTER_FFLAGS_*
51 // Reading and setting this variable should be protected by [threadLock]
52
53 unsigned int threadCounter;
54 // just a debug counter to see number of changes.
55 unsigned int threadLMDCounter;
56 // debug: Number of LMDs
57 unsigned int threadGlobalUpdatesCounter;
58 // debug: Number of global updates;
59
60
61 //float maxDistance;
62 float maxSearchingDistance;
63 //float maxSingleForce;
64 //float maxTotalForce; // only for FORCE_CALCULATION_TYPE == 3
65 };
66
67 }
68
69 #endif
70
71 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_CommonDefs.h Source File

  • File List
  • File Members
  • include
  • vrecko
SP_CommonDefs.h
Go to the documentation of this file.
1 #ifndef SP_COMMONDEFS
2 #define SP_COMMONDEFS
3
4 #include <helpers/DynamicArray.h>
5
6 namespace vrecko {
7
8
9 //#define DEBUG_COLLISIONS
10
11
12 #ifdef VRECKO_LIBRARY
13 #define COLL_VRECKO_EXPORT __declspec(dllexport)
14 #else
15 #define COLL_VRECKO_EXPORT __declspec(dllimport)
16 #endif /* VRECKO_LIBRARY */
17
18
19 class SP_SceneInterface;
20 class SP_ObjectInterface;
21
22
23
25 #define PARTITIONING_INTERFACE_DEFAULT -1
26
27
28
29 // Flags for COLLISION_POINT_INFO::dwFlags
30
31
34 #define COLPOINT_FLAGS_INVALID 0x00000001
35
38 #define COLPOINT_FLAGS_INTERSECTION_LINE 0x00000002
39
41 #define COLPOINT_FLAGS_NEG_DIST_PRESENT 0x00000004
42
45 #define COLPOINT_FLAGS_NORMALIZED 0x00000008
46
47 // MASK and SHIFT of the number of point pairs that this one represents.
48 // You can use COLPOINT_FLAGS_REPRESENTANTS__GET to retrieve it.
49 #define COLPOINT_FLAGS_REPRESENTANTS__MASK 0x00000FF0
50 #define COLPOINT_FLAGS_REPRESENTANTS__SHIFT 4
51 #define COLPOINT_FLAGS_REPRESENTANTS__GET(x) ((x && COLPOINT_FLAGS_REPRESENTANTS__MASK) >> COLPOINT_FLAGS_REPRESENTANTS__SHIFT)
52
53
54 class CollisionPointInfo {
55 public:
56 unsigned long dwFlags;
57
60 osg::Vec3 points[2];
61
62
64 osg::Vec3 vecTriMaxNegativeDistance;
65
66
67 #ifdef DEBUG_COLLISIONS
68 unsigned long faceIndices[2];
69 #endif
70 };
71 typedef std::vector<CollisionPointInfo> COLLISION_POINTS_VECTOR;
72
73
74 class CollisionInfo {
75 public:
76 CollisionInfo() { eoID[0] = 0; eoID[1] = 0; points = NULL; }
77
78 ~CollisionInfo() { if (points) delete points; }
79 unsigned long eoID[2];
80 COLLISION_POINTS_VECTOR * points;
81 };
82 typedef DynamicArray<CollisionInfo> COLLISIONS_INFO_VECTOR;
83
84
86 #define COLLISION_FLAGS_RAYCASTING 0x00000001
87
89 #define COLLISION_FLAGS_NOCONTACTS 0x00000002
90
93 #define COLLISION_FLAGS_SINGLECONTACT 0x00000004
94
98 #define COLLISION_FLAGS_ONLYSCENETESTS 0x00000008
99
103 #define COLLISION_FLAGS_ALLOW_INTERSECTIONS 0x00000010
104
106 #define COLLISION_FLAGS_ONLY_INTERSECTIONS 0x00000020
107
112 #define COLLISION_FLAGS_RUN_IN_BACKGROUND 0x00000040
113
117 #define COLLISION_FLAGS_USE_MTMATRIXTRANSFORM 0x00000080
118
123 #define COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES 0x00000100
124
131 #define COLLISION_FLAGS_NO_CALCULATIONS 0x00000200
132
135 #define COLLISION_FLAGS_PREFER_NO_CALCULATIONS 0x00000400
136
138 #define COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800
139
141 #define COLLISION_FLAGS_NO_OLD_COLLISION_DELETION 0x00000800
142 // Do not delete the old collision pairs in COLLISIONS_INFO_VECTOR
143 #define COLLISION_FLAGSMASK_COMPARISON_FLAGS (COLLISION_FLAGS_RAYCASTING | COLLISION_FLAGS_ONLYSCENETESTS | COLLISION_FLAGS_ALLOW_INTERSECTIONS | COLLISION_FLAGS_ONLY_INTERSECTIONS | COLLISION_FLAGS_ALLOW_NEGATIVE_DISTANCES)
144
145
147 class COLL_VRECKO_EXPORT CollisionParams__ver1 {
148 public:
149 CollisionParams__ver1() : dwFlags(0),
150 preferredSceneInterface(PARTITIONING_INTERFACE_DEFAULT),
151 preferredObjectInterface(PARTITIONING_INTERFACE_DEFAULT),
152 maxCollisionDistance(0.0f),
153 debugGlobalUpdatesCounter(0),
154 bgThreadAffinityMask(0xFFFFFFFF),
155 objIntPtr(NULL)
156 { dwStructureVersion = 1; }
157
158 virtual bool isSame(const CollisionParams__ver1 * other) const;
159
160 unsigned long dwStructureVersion;
161
162 int preferredSceneInterface;
163 int preferredObjectInterface;
164
167 unsigned long dwFlags;
168
173 float maxCollisionDistance;
174
177 osg::Vec3 rayStart, rayEnd;
178
180 DynamicArray<unsigned long> ignoredObjects;
181
186 unsigned int bgThreadAffinityMask;
187
188 unsigned long debugGlobalUpdatesCounter;
189
190 SP_SceneInterface* scIntPtr;
191 SP_ObjectInterface* objIntPtr;
192 };
193
194 typedef CollisionParams__ver1 CollisionParams;
195
196
197 }
198
199
200 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SP_Object_Data_Base.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SP_Object_Data_Base.h
Go to the documentation of this file.
1 #ifndef SP_OBJECT_DATA_BASE_H
2 #define SP_OBJECT_DATA_BASE_H
3
4 #include <vrecko/SP_ObjectInterface.h>
5 #include <vrecko/EnvironmentObject.h>
6
7
8 namespace APSpacePartitioning {
9
10 class SP_Object_Data_Base: public vrecko::SP_Object_DataInterface, public vrecko::Ability {
11 friend DWORD WINAPI HierarchyThreadProc(SP_Object_Data_Base *lpParameter);
12 public:
13 SP_Object_Data_Base(const char *abName);
14 ~SP_Object_Data_Base() { destroyThread(); };
15
16 virtual void preInitialize();
17 virtual void update();
18
19 protected:
20 vrecko::EnvironmentObject *owner;
21
22 HANDLE hHierarchyCreationThread;
23 bool bThreadShouldTerminate; // signal from the outside that the thread should finish as quickly as possible
24
25 virtual bool startThreadedHierarchyCreation();
26 // initializes a thread and runs the hierarchy creation
27 // Descendants should not need to override this method.
28
29 virtual void destroyThread();
30
31 virtual bool coreHierarchyCreation() { return false; };
32 // Method that is executed in the separate thread (maybe in the main one) to create the actual hierarchy.
33 // Descendants will need to override this method.
34 // The method should watch the [bThreadShouldTerminate] variable and exit quickly if it becomes "true".
35 };
36
37 }
38
39
40 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_ObjectInterface.h Source File

  • File List
  • File Members
  • include
  • vrecko
SP_ObjectInterface.h
Go to the documentation of this file.
1
2 #ifndef SP_OBJECTINTERFACE_H
3 #define SP_OBJECTINTERFACE_H
4
5 #include <vrecko/Export>
6
7 #include <osg/Vec3>
8 #include <stddef.h> // only for NULL definition
9 #include <vrecko/SP_CommonDefs.h>
10
11 namespace vrecko {
12
13 class SP_Object_DataInterface {
14 public:
15 SP_Object_DataInterface() {};
16 ~SP_Object_DataInterface() {};
17
18 virtual bool isHierarchyCreated() { return false; }
19
20 protected:
21 };
22
23 class SP_ObjectInterface {
24 public:
25 SP_ObjectInterface() {};
26 ~SP_ObjectInterface() {};
27
29 inline int getId() { return objIntId; };
30 // usually one of the SP_OBJECT_INTERFACE_ID__* constants
31
40 virtual bool getCollisions(CollisionParams * params, COLLISION_POINTS_VECTOR ** colPoints, unsigned long obj1ID, unsigned long obj2ID, float time) { return false; }
41
42 // virtual bool getCollision(SP_Object_DataInterface& object_data1, SP_Object_DataInterface& object_data2) {return false;}
43 // virtual bool getRayIntersection(SP_Object_DataInterface& object_data, osg::Vec3& intersection_point) {return false;}
44 // virtual bool getSeparation(SP_Object_DataInterface& object_data1, SP_Object_DataInterface& object_data2, double& sep_distance, osg::Vec3* point_on_object1 = NULL, osg::Vec3* point_on_object2 = NULL) {return false;}
45 // virtual bool getExtentInAxis(SP_Object_DataInterface& object_data, osg::Vec3 axis) {return false;}
46
47 protected:
48 int objIntId;
49 };
50
51 }
52
53 #endif
54
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/SP_SceneInterface.h Source File

  • File List
  • File Members
  • include
  • vrecko
SP_SceneInterface.h
Go to the documentation of this file.
1
2 #ifndef SP_SCENEINTERFACE_H
3 #define SP_SCENEINTERFACE_H
4
5 #include <vrecko/EnvironmentObject.h>
6 #include <vrecko/SP_CommonDefs.h>
7
8 namespace vrecko {
9
10 class SP_SceneInterface {
11 public:
12 SP_SceneInterface() {};
13 ~SP_SceneInterface() {};
14
15 inline int getId() { return scIntId; };
16
21 virtual bool performCompleteTest(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long limitToEO1, unsigned long limitToEO2) {
22 return false;
23 };
24
27 virtual bool performUpdate(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long limitToEO1, unsigned long limitToEO2) {
28 return false;
29 }
30
31 protected:
32 int scIntId; // system-wide unique id. Must be greater than zero.
33 };
34
35 }
36
37 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SampledSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SampledSpline.h
Go to the documentation of this file.
1 #pragma once
2 #include "spline.h"
3
4 class SampledSpline : public Spline
5 {
6 public:
8 SampledSpline();
9 SampledSpline(double minSampleDistance, bool closed, const Vec3ArrayPtr sampleArray);
10
12 META_DAObject(SampledSpline, "Sampled Spline");
13
14 virtual Vec3ArrayPtr getPoints();
15 virtual bool isClosed() { return _closed; }
16
18 inline void setVertexArray(const Vec3ArrayPtr array);
19 inline Vec3ArrayPtr getVertexArray() const { return _array; }
20
21 inline double getMinimalSampleDistance() const { return _minDistance; }
22 inline void setMinimalSampleDistance(double val);
23
24 inline void setClosed(bool val);
25
26 protected:
27 Vec3ArrayPtr _array;
28 double _minDistance;
29 bool _closed;
30 };
31
32 inline void SampledSpline::setVertexArray( const Vec3ArrayPtr array )
33 {
34 if(array.valid()) {
35 _dirty = true;
36 _array = array;
37 }
38 }
39
40 inline void SampledSpline::setMinimalSampleDistance( double val )
41 {
42 _dirty = true;
43 _minDistance = val;
44 }
45
46 inline void SampledSpline::setClosed( bool val )
47 {
48 _dirty = true;
49 _closed = val;
50 }
51
52 typedef osg::ref_ptr<SampledSpline> SampledSplinePtr;
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/Scale.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
Scale.h
Go to the documentation of this file.
1 #ifndef SCALE_H
2 #define SCALE_H
3
4 #include "../EditorController/ControllableAbility.h"
5 //#include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7
8 using namespace vrecko;
9
10 namespace APConnectEditor {
11
12 class Scale: public ControllableAbility {
13 public:
14 Scale();
15 virtual ~Scale() {};
16
17 void update(void);
18
19 protected:
20 virtual void fillDefaultInfo();
21 virtual bool activate();
22 virtual void deactivate();
23
24 osg::Vec3 firstPointerPos; // pointer position when activated
25 osg::Vec3 eyePos;
26
27 osg::Matrix firstObjectMatrix;
28
29 unsigned long movingObjectID; // ID of the object that is being handled. If this is 0, the ability is not activated
30
31
32
33 bool bFirstUpdate;
34
35 void issueRequests(bool bStopIfNoSelection);
36
37 bool objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans);
38 // FIRST PART of the tranformation calculations. From the pointer position/rotation the new object
39 // position/rotation is calculated. The matrix is only calculated and stored in [outTrans].
40 // The transformation will be applied afterwards, after another calculations or adjustments.
41 };
42
43 }
44
45 #endif //SCALE_H
46
47
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Scene.h Source File

  • File List
  • File Members
  • include
  • vrecko
Scene.h
Go to the documentation of this file.
1 /***************************************************************************
2 Scene.h - description
3 -------------------
4 begin : May 2002
5 copyright : (C) 2002 by Jan Flasar, Ludek Pokluda
6 email : flasar|xpokluda@fi.muni.cz
7 ***************************************************************************/
8
9 #ifndef SCENE_H
10 #define SCENE_H
11
12 #include <osg/Node>
13
14 #include <vrecko/BaseClass.h>
15 #include <vrecko/EnvironmentObject.h>
16
17 #include <vrecko/World.h>
18 #include <vrecko/MTLock.h>
19
20 #include <helpers/DynamicArray.h>
21 #include <vrecko/SP_CommonDefs.h>
22
23 namespace vrecko {
24
25 class SP_SceneInterface;
26 class SP_ObjectInterface;
27
28
29 // Flags for CalcNodeBBox:
30
36 #define CNBB_F_FORCE_AABBOX 0x00000001
37
39 #define CNBB_F_ONLY_LOCAL_TRANSFORM 0x00000002
40
43 #define CNBB_F_NO_SELF_TRANSFORM 0x00000004
44
45
46
47
48 // Flags for Scene::EOIteratorHelper::initIterationFrom()
49
51 #define EOIH_IF_START_BEGINNING 0x00000001
52
55 #define EOIH_IF_START_CURRENT 0x00000002
56
58 #define EOIH_IF_START_NEXT 0x00000004
59
60
61
62
63 struct ScenePSThreadInfo {
64 // This structure is both stored and passed to the thread as a parameter,
65 // therefore we must pass also the pointer to this class.
66 Scene *scene;
67 HANDLE hThreadHandle;
68
70 bool bTerminateThread;
71
72
75 osg::Timer_t lastRequest;
76
77 CollisionParams params;
78 unsigned long limitToEO1, limitToEO2;
79 };
80
81
82
83 DWORD WINAPI ScenePSThreadProc(ScenePSThreadInfo *lpParameter);
84
85
86 class VRECKO_EXPORT Scene: public BaseClass, public osg::MatrixTransform {
87 public:
88
89
110 class VRECKO_EXPORT EOIteratorHelper: public BaseClass {
111
112
113 public:
114 EOIteratorHelper();
115 ~EOIteratorHelper();
116
119 bool initIteration();
120
125 bool initIterationFrom(Scene::EOIteratorHelper *sourceHelper, unsigned long dwInitFlags = EOIH_IF_START_BEGINNING);
126
130 void endIteration();
131
145 bool getAndLockNextObject(EnvironmentObject **outObject);
146
148 bool releaseObject(void);
149
150 protected:
151 bool bInited;
152
153 MTLock generalLock;
154
155 typedef DynamicArray<EnvironmentObject*> EOVector;
156 EOVector objects;
157
161 int currentObjectIndex;
162
164 bool bObjectLocked;
165
166
167
168 HANDLE hCollisionEvent1, hCollisionEvent2;
169 bool bCollisionOccured_EventExpected;
170
171
172 virtual int processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData);
173 };
174
175 Scene();
176 ~Scene();
177 // Scene(const Scene& s);
178
181 void prepareForTermination();
182
184 void setDescription(const std::string &desc) {description = desc;}
185
187 const std::string &getDescription(void) {return description;}
188
189 void update(void);
190
192 osg::MatrixTransform *getRoot() {return rootNode;}
193
195 osg::MatrixTransform *getEORoot() {return eoRootNode;}
196
198 unsigned long getFreeID(unsigned long req_id);
199
201 int addEnvironmentObject(EnvironmentObject *environment_object, osg::Group *parentNode);
202
204 inline int addEnvironmentObject(EnvironmentObject *environment_object ) { return addEnvironmentObject(environment_object, eoRootNode); }
205
207 bool removeEnvironmentObject( unsigned long id );
208
210 EnvironmentObject * getEnvironmentObject( unsigned long id, bool bReportErrorIfNotFound = true );
211
215 bool registerEnvironmentObject(EnvironmentObject *environment_object);
216
219 bool unregisterEnvironmentObject(EnvironmentObject *environment_object);
220
223 bool unregisterEnvironmentObject(unsigned long id);
224
225 typedef Sgi::hash_map<unsigned long, EnvironmentObject *> EOMap;
226
228 inline EOMap &getEOMap(void) {return environment_objects_map;}
229
231 inline void lockEOMapForRead(void) { eoMapLock.lockRead(); }
232
234 inline void unlockEOMapForRead(void) { eoMapLock.unlockRead(); }
235
237 inline void lockEOMapForWrite(void) { eoMapLock.lockWrite(); }
238
240 inline void unlockEOMapForWrite(void) { eoMapLock.unlockWrite(); }
241
242
244 inline bool isLoaded(void) { return _bIsLoaded; }
245
246
247 inline void setIsLoaded(bool bNewValue) { _bIsLoaded = bNewValue; }
248
249
252 EnvironmentObject *getCollisionObject(EnvironmentObject *eobject);
255 EnvironmentObject **getCollisionObjects(EnvironmentObject *eobject, int &size);
258 EnvironmentObject **getCollisionObjects(esg::OSGAdapter *pOSGAdapter, const osg::Matrix &transf, int &size);
259
265 EnvironmentObject *getRayIntersection(const osg::Vec3 &origin, const osg::Vec3 &dir);
266
272 EnvironmentObject *getRayIntersection(const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point);
273
279 bool getRayIntersection(EnvironmentObject *eobject, const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point);
280
283 void getObjectExtent(EnvironmentObject *eobject, const osg::Vec3 &dir, float &min, float &max);
284
287 bool separation(esg::Matrix4 *trMat1, std::vector<esg::OSGAdapter *> object1, esg::Matrix4 *trMat2, std::vector<esg::OSGAdapter *> object2, unsigned d1 = UINT_MAX, unsigned d2 = UINT_MAX);
288
289
290
291
298 bool calcNodeBBox(osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed = NULL, unsigned long dwFlags = 0, osg::Node *subTreeToIgnore = NULL);
299
310 bool getCollisions(CollisionParams * params, COLLISIONS_INFO_VECTOR ** collisions, unsigned long limitToEO1 = 0, unsigned long limitToEO2 = 0);
311
312 /* INTERNAL USAGE - set/get scene partitioning interface for scene operations.
313 You should probably use Scene::getCollisions(). */
314 bool addPartitioningSceneInterface(SP_SceneInterface *newInterface, int priority = 0);
315 void removePartitioningSceneInterface(SP_SceneInterface *anInterface);
316 SP_SceneInterface* getPartitioningSceneInterface(int id = PARTITIONING_INTERFACE_DEFAULT);
317
318 /* INTERNAL USAGE - set/get scene partitioning interface for object operations
319 You should probably use Scene::getCollisions(). */
320 bool addPartitioningObjectInterface(SP_ObjectInterface *newInterface, int priority = 0);
321 void removePartitioningObjectInterface(SP_ObjectInterface *anInterface);
322 SP_ObjectInterface* getPartitioningObjectInterface(int id = PARTITIONING_INTERFACE_DEFAULT);
323
324
326 void logHierarchy(const osg::Node *topNode, const char *note = NULL);
327
328
329 protected:
331 std::string description;
332
333 MTReadWriteLock eoMapLock;
334
336 EOMap environment_objects_map;
338 osg::MatrixTransform *rootNode;
340 osg::MatrixTransform *eoRootNode;
341
342 unsigned long nextFreeID;
343
345 bool _bIsLoaded;
346
347
348 struct SC_INT_PRIO {
349 SP_SceneInterface* scInt;
350 int priority;
351 };
352 DynamicArray<SC_INT_PRIO> partitioningSceneInterfaces;
353
354 struct OBJ_INT_PRIO {
355 SP_ObjectInterface* objInt;
356 int priority;
357 };
358 DynamicArray<OBJ_INT_PRIO> partitioningObjectInterfaces;
359
363 std::vector<ScenePSThreadInfo*> partThreadsInfo;
364
366 int lastUpdatePartThrIndex;
367
368 bool calcNodeBBoxHelper(osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed, unsigned long dwFlags, osg::Node *nodeToStopTraversalAt, osg::Node *subTreeToIgnore);
369
370 friend DWORD WINAPI ScenePSThreadProc(ScenePSThreadInfo *lpParameter);
371
372 void logHierarchyHelper(int level, const osg::Node *node);
373 void logHierarchyDrawableHelper(int level, const osg::Drawable *dw);
374 };
375
376 }
377
378 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SceneSave.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
SceneSave.h
Go to the documentation of this file.
1 #ifndef SCENESAVE_H
2 #define SCENESAVE_H
3
4 #include "../EditorController/ControllableAbility.h"
5
6 namespace APEditorQAbilities {
7 class SceneSave: public vrecko::ControllableAbility {
8 public:
9 SceneSave() : ControllableAbility("SceneSave") {};
10 virtual ~SceneSave() { deactivate(); };
11
12 protected:
13 virtual void fillDefaultInfo();
14 virtual bool activate();
15 virtual void menuItemClicked(const char* itemID);
16 };
17 }
18
19 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Scheduler.h Source File

  • File List
  • File Members
  • include
  • vrecko
Scheduler.h
Go to the documentation of this file.
1 /***************************************************************************
2 Scheduler.h - description
3 -------------------
4 begin : February 2004
5 copyright : (C) 2004 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 #ifndef SCHEDULER_H
10 #define SCHEDULER_H
11
12 #include <vrecko/Export>
13 #include <vrecko/BaseClass.h>
14 #include <vrecko/vThread.h>
15
16 #include <map>
17 #include <vector>
18
19
20 namespace vrecko {
21
22 #define FRAME_FREQUENCY -1.0
23
24 class World;
25
27 class VRECKO_EXPORT Scheduler {
28 public:
29 Scheduler();
30 ~Scheduler();
31 Scheduler(Scheduler &s);
32
33 void update(void);
34
35 void start(void);
36 void stop(void);
37
38
53 void addEntity(BaseClass *ent, float frequency = FRAME_FREQUENCY);
54
71 void addEntity(BaseClass *ent, const std::string &private_timer_name, float frequency = FRAME_FREQUENCY);
72
74 void removeEntity(BaseClass *ent);
75
77 bool isEntityPresent(BaseClass *ent);
78
80 bool getState() {return state;}
81
83 void resetObjectUpdatesCounter() { iObjectUpdatesCounter = 0; }
84
86 int getObjectUpdatesCounter() { return iObjectUpdatesCounter; }
87
88 protected:
89 typedef struct {
90 float frequency;
91 vThread *thread_ptr;
92 osg::Timer_t last_tick;
93 std::vector<BaseClass*> entity_vector;
94 } TimerStruct;
95 typedef std::map<float, TimerStruct > TimerMap;
96 TimerMap timer_map;
97 typedef std::map<std::string, TimerStruct > PrivateTimerMap;
98 PrivateTimerMap private_timer_map;
99 bool state;
100
101 int iObjectUpdatesCounter;
102
103 struct classcomp {
104 bool operator() (const long int &lhs, const long int &rhs) const {return lhs > rhs;}
105 };
106
110 std::multimap<long int, BaseClass*, classcomp> updateMMap;
111
112 };
113
114 }
115
116 #endif
117
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetup.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
ScreenSetup.h
Go to the documentation of this file.
1 #pragma once
2 #ifndef __SCREEN_SETUP_H
3 #define __SCREEN_SETUP_H
4
5 #include <string>
6
7 #include <osg\Vec3>
8 #include <osg\Quat>
9 #include <vrecko\Ability.h>
10
11 #include "Solver.h"
12
13 namespace ht
14 {
15
16 class ScreenSetup: public vrecko::Ability
17 {
18 public:
19 enum Corner
20 {
21 LeftBottom,
22 RightBottom,
23 LeftTop,
24 RightTop
25 };
26
27 struct ScreenSetupState
28 {
29 VariableVec3 *monitor_position;
30 VariableQuat *monitor_orientation;
31
32 double rim_width;
33 double rim_height;
34 osg::Vec2d monitor_corner;
35
36 VariableVec3 *sensor_offset;
37
38 osg::Vec3d wire_position;
39 osg::Quat wire_orientation;
40 double wire_length;
41 };
42
43 private:
44 // Parameters
45 float wire_length; // Length of measuring wire
46 float rim_width, rim_height; // Width and height of monitor rim (which is measured)
47
48 // Sensor identification and position
49 osg::Vec3 sensor_position;
50 osg::Quat sensor_orientation;
51 int sensor_number;
52
53 // Initial values of variables of numerical calculation and its parameters
54 float num_cal_start_step;
55 float num_cal_step_scale;
56 float num_cal_min_step_size;
57
58 // Calculated variables
59 VariableVec3 monitor_position;
60 VariableQuat monitor_orientation;
61 VariableVec3 sensor_offset;
62
63 // Numerical calculation
64 ScreenSetupState current_state;
65 Corner current_corner;
66 ListOfFunctions functions;
67 ListOfVariables variables;
68
69 // Output file name
70 std::string output_file_name;
71
72 protected:
73 virtual ~ScreenSetup();
74
75 void SaveSetup();
76
77 public:
78 ScreenSetup();
79 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
80
81 DECLARE_INPUT(Position, vrecko::MessageSensorTransformation);
82 DECLARE_INPUT(Record, vrecko::MessageBool);
83 DECLARE_INPUT(NextCorner, vrecko::MessageBool);
84 DECLARE_INPUT(ShowPosition, vrecko::MessageBool);
85 DECLARE_INPUT(RunCalculation, vrecko::MessageBool);
86 };
87
88 }
89
90 #endif // __SCREEN_SETUP_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/ScreenSetupSimple.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
ScreenSetupSimple.h
Go to the documentation of this file.
1 #pragma once
2 #ifndef __SCREEN_SETUP_SIMPLE_H
3 #define __SCREEN_SETUP_SIMPLE_H
4
5 #include <string>
6
7 #include <osg\Vec3>
8 #include <osg\Quat>
9 #include <vrecko\Ability.h>
10
11 #include "Solver.h"
12
13 namespace ht
14 {
15
16 class ScreenSetupSimple: public vrecko::Ability
17 {
18 public:
19 struct ScreenSetupSimpleState
20 {
21 VariableVec3 *mon_cor_position;
22
23 VariableVec3 *sensor_offset;
24
25 osg::Vec3d wire_position;
26 osg::Quat wire_orientation;
27 double wire_length;
28 };
29
30 private:
31 // Parameters
32 float wire_length; // Length of measuring wire
33
34 // Sensor identification and position
35 osg::Vec3 sensor_position;
36 osg::Quat sensor_orientation;
37 int sensor_number;
38
39 // Initial values of variables of numerical calculation and its parameters
40 float num_cal_start_step;
41 float num_cal_step_scale;
42 float num_cal_min_step_size;
43
44 // Calculated variables
45 VariableVec3 mon_cor_position;
46 VariableVec3 sensor_offset;
47
48 // Numerical calculation
49 ScreenSetupSimpleState current_state;
50 ListOfFunctions functions;
51 ListOfVariables variables;
52
53 // Output file name
54 std::string output_file_name;
55
56 protected:
57 virtual ~ScreenSetupSimple();
58
59 void SaveSetup();
60
61 public:
62 ScreenSetupSimple();
63 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
64
65 DECLARE_INPUT(Position, vrecko::MessageSensorTransformation);
66 DECLARE_INPUT(Record, vrecko::MessageBool);
67 DECLARE_INPUT(ShowPosition, vrecko::MessageBool);
68 DECLARE_INPUT(RunCalculation, vrecko::MessageBool);
69 };
70
71 }
72
73 #endif // __SCREEN_SETUP_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorColorGen.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
SectorColorGen.h
Go to the documentation of this file.
1 #pragma once
2 #include "ColorGen.h"
3 #include <osg\BoundsChecking>
4 #include <osg\BufferObject>
5
6
7
8 struct Sector : public osg::Referenced
9 {
10 enum Direction
11 {
12 SD_REVERSE,
13 SD_FORWARD
14 };
15
16 const unsigned int ID;
17 double start;
18 double end;
19 osg::Vec4 color;
20 Direction direction;
21
23 Sector() : ID(counter++) { set(0.0, 0.0, osg::Vec4(1,0,0,1)); }
24 Sector(double start, double end, const osg::Vec4& color, Direction direction = SD_FORWARD) : ID(counter++)
25 { set(start, end, color, direction); }
26
28 typedef std::pair<double, double> DoublePair;
29 DoublePair getSectorRange(unsigned int arraySize) { return DoublePair(start * arraySize, end * arraySize); }
30
31 void set(double start, double end, const osg::Vec4& color, Direction direction = SD_FORWARD) {
32 this->start = osg::clampBetween(start, 0.0, 1.0);
33 this->end = osg::clampBetween(end, 0.0, 1.0);
34 this->color = color;
35 this->direction = direction;
36 }
37
38 protected:
39 static unsigned int counter;
40 virtual ~Sector() {};
41 };
42
43 typedef osg::ref_ptr<Sector> SectorPtr;
44 typedef std::vector<SectorPtr> SectorArray;
45
46 class SectorColorGen : public ColorGen
47 {
48 public:
49 SectorColorGen(const osg::Vec4& defaultColor)
50 : _defaultColor(defaultColor) { _dirty = true; };
51
52 META_DAObject(SectorColorGen, "Sector Color");
53
55 virtual Vec4ArrayPtr getColors( unsigned int leadSplineSize, unsigned int crossSectionSize )
56 {
57 _dirty = false;
58
59 Vec4ArrayPtr result = new osg::Vec4Array;
60 unsigned int arraySize = leadSplineSize * crossSectionSize;
61
62 result->reserve(arraySize);
63 result->assign(arraySize, _defaultColor);
64
65 for (auto it = _sectors.begin(); it != _sectors.end(); ++it)
66 {
67 unsigned int sectorStart = int((*it)->start * leadSplineSize) * crossSectionSize;
68 unsigned int sectorEnd = int((*it)->end * leadSplineSize) * crossSectionSize;
69
70 if(sectorStart == sectorEnd) continue;
71
72 if(sectorEnd < sectorStart) sectorEnd += arraySize;
73
74 double step = 1.0 / (sectorEnd - sectorStart);
75 double counter = (*it)->direction == Sector::SD_FORWARD ? 0.0 : 1.0;
76
77 for (unsigned int i = sectorStart; i < sectorEnd; ++i)
78 {
79 (*result)[i % arraySize] = osg::Vec4(counter, 1.0 - counter, 0, 1.0);
80 counter += (*it)->direction == Sector::SD_FORWARD ? step : -step;
81 }
82 }
83
84 return result;
85 }
86
87 const osg::Vec4& getDefaultColor() const { return _defaultColor; }
88 void setDefaultColor(osg::Vec4 val) { _dirty = true; _defaultColor = val; }
89
91 void addSector(SectorPtr sector) { _dirty = true; _sectors.push_back(sector); }
92 void setSector(unsigned int i, SectorPtr val) { _dirty = true; _sectors[i] = val; }
93 const SectorPtr getSector(unsigned int i) { return _sectors[i]; }
94 int getNumSectors() { return _sectors.size(); }
95 void removeSectors(unsigned int i, int numSectorsToRemove = 1) {
96 _dirty = true;
97 osg::clampLEQUAL(i, _sectors.size(), "i");
98 _sectors.erase(_sectors.begin() + i, _sectors.begin() + i + numSectorsToRemove);
99 }
100
101 protected:
102 SectorArray _sectors;
103 osg::Vec4 _defaultColor;
104
105 };
106
107 typedef osg::ref_ptr<SectorColorGen> SectorColorGenPtr;
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SectorManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
SectorManager.h
Go to the documentation of this file.
1 #pragma once
2 #include "Pattern.h"
3 #include "Hoop.h"
4 #include "SectorColorGen.h"
5
6 namespace APDYNAMICART
7 {
8
9 struct SectorInfo
10 {
11 SectorPtr sector;
12 HoopPtr hoop;
13 PatternPtr pattern;
14
15 SectorInfo(SectorPtr sector, PatternPtr pattern, HoopPtr hoop)
16 : sector(sector), pattern(pattern), hoop(hoop) {};
17 };
18
20
23 class SectorManager
24 {
25 public:
26 static SectorManager* getInstance()
27 {
28 static SectorManager manager;
29 return &manager;
30 }
31
32 void addSector(SectorPtr sector, HoopPtr hoop);
33 void removeSector(unsigned int index);
34 void setDefaultPattern(PatternPtr pattern);
35 void removeAllSectorsOnHoop( HoopPtr hoop );
36
38 SectorPtr getSector(unsigned int index);
39 HoopPtr getHoop(unsigned int index);
40 PatternPtr getPattern(unsigned int index);
41 unsigned int getNumSectors();
42
44 typedef std::vector<SectorInfo> SectorInfoList;
45 const SectorInfoList& getSectorInfoList() const { return _sectorInfoList; }
46 SectorInfoList& getSectorInfoList() { return _sectorInfoList; }
47
49 void load( HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* PoANode );
50 void save( HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* poaNode );
51
52 protected:
53 SectorManager(); //Protected constructor, so no one can create instance of this class
54 std::vector<SectorInfo> _sectorInfoList;
55 std::string _defaultPatternName;
56 };
57 }
58
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetForceFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetForceFilter.h
Go to the documentation of this file.
1 #ifndef SETFORCE_FILTER_H
2 #define SETFORCE_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to limit the force size. */
11 class SetForceFilter : public PHANToMFilter {
12 public:
13 SetForceFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 osg::Vec3 setForce;
21 osg::Vec3 setTorque;
22 };
23
24 }
25
26 #endif
27
28
29 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/SetObjectTransformFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
SetObjectTransformFilter.h
Go to the documentation of this file.
1 #ifndef SET_OBJECT_MATRIX_FILTER_H
2 #define SET_OBJECT_MATRIX_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to get the current Phantom position and set an object position accordingly
11 using MTMatrixTransform ability. The force is unchanged.*/
12 class SetObjectTransformFilter : public PHANToMFilter {
13 public:
14 SetObjectTransformFilter();
15
16 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
17
18 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
19
20 protected:
21 osg::Matrix originalScale;
22 osg::Vec3 offsetFromCenter; // Offset of the phantom reference point
23
24 osg::Matrix cachedMatrix;
25 };
26
27 }
28
29 #endif
30
31 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeFactory.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ShapeFactory.h
Go to the documentation of this file.
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/ShapeGenerator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
ShapeGenerator.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\Referenced>
4 #include <osg\Array>
5 #include "Utils.h"
6
7 namespace APDYNAMICART
8 {
9
11 class IShapeGenerator : public osg::Referenced
12 {
13 public:
14 virtual Vec3ArrayPtr generate(Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints) = 0;
15 protected:
16 virtual ~IShapeGenerator() {};
17 };
18
20 typedef osg::ref_ptr<IShapeGenerator> IShapeGeneratorPtr;
21
23 class ShapeFactory
24 {
25 public:
26 static IShapeGeneratorPtr getShapeGenerator(const std::string& name);
27 };
28
30 class NullShapeGenerator : public IShapeGenerator
31 {
32 public:
33 virtual Vec3ArrayPtr generate( Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints );
34 };
35
36 class LinearShapeGenerator : public IShapeGenerator
37 {
38 public:
39 virtual Vec3ArrayPtr generate( Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints );
40 };
41
42 }
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ShootingSimulation/ShootingSimulation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ShootingSimulation
ShootingSimulation.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <vrecko/Ability.h>
4 #include <vrecko/EnvironmentObject.h>
5 #include <vrecko/EventDispatcher.h>
6 #include <vrecko/Logger.h>
7 #include <vrecko/Message.h>
8 #include <vrecko/Scene.h>
9 #include <vrecko/World.h>
10
11 #include <osgText/Font>
12
13 using namespace vrecko;
14
15 namespace APShootingSimulation
16 {
17
21 enum GameStates {
22 PREPARE_NEW_GAME, // before starting a new game => after initializing of the app or after the last level
23 PREPARE_NEXT_LEVEL, // prepare state for next level
24 WAITING_FOR_START, // waiting for pressing 'start' button
25 COUNTDOWN, // after pressing 'start' button
26 RUNNING_LEVEL // during playing levels
27 };
28
32 enum MoveDirections {
33 NO_MOVE,
34 MOVE_UP,
35 MOVE_DOWN,
36 MOVE_LEFT,
37 MOVE_RIGHT
38 };
39
51 class ShootingSimulation: public vrecko::Ability
52 {
53 public:
54
58 ShootingSimulation();
59 virtual ~ShootingSimulation() {};
60
64 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
65
69 virtual void update(void);
70
78 osg::ref_ptr<vrecko::EnvironmentObject> resolveIntersections(osg::Vec3 &vector,
79 osg::Vec3 &position,
80 std::vector<osg::Node*> **nodePath = NULL);
81
82 protected:
83
91 bool addObject(osg::ref_ptr<vrecko::EnvironmentObject> &obj, const std::string& geoPath);
92
96 void setCrosshairPos();
97
103 void moveTarget(osg::Vec3 currentTargetPos);
104
108 void testAndHandleHit();
109
111 DECLARE_INPUT(Start, MessageBool);
112 DECLARE_INPUT(Mouse, MessageVec2);
113 DECLARE_INPUT(Trigger, MessageBool);
114 DECLARE_INPUT(Sensor_Transformation, MessageSensorTransformation);
115
116 private:
117 // string of start buttons for 'startText'
118 static const std::string START_BUTTONS;
119
120 // paths to models
121 static const std::string PATH_WALL;
122 static const std::string PATH_CROSSHAIR;
123 static const std::string PATH_TARGET;
124
125 #define NUM_TARGETS 3
126 static const std::string PATH_TARGET_DAMAGED[];
127
128 // Environment objects
129 osg::ref_ptr<vrecko::EnvironmentObject> wall;
130 osg::ref_ptr<vrecko::EnvironmentObject> target;
131 osg::ref_ptr<vrecko::EnvironmentObject> crosshair;
132 osg::ref_ptr<vrecko::EnvironmentObject> damagedTargets[NUM_TARGETS];
133
134 // index of damagedTarget currently in use
135 unsigned int dmgTargetIndex;
136 // current start position of the target
137 unsigned int targetPosIndex;
138
139 // osg vectors for aiming
140 osg::Vec2 _mouse2DVector;
141 osg::Vec3 _aimVector;
142 osg::Vec3 _standingPosition;
143 osg::Vec3 _opti3DVector0;
144 osg::Vec3 _opti3DVector1;
145
146 static const float CROSSHAIR_DIFF;
147 static const float DEFAULT_Z_GRID;
148 float screenZGrid;
149
150 // target appearance setup
151 static const int NUM_TARGETS_POS;
152 static const float X_TARGETS[];
153 static const float Y_TARGETS[];
154
155 static const float MIN_X;
156 static const float MAX_X;
157 static const float MIN_Y;
158 static const float MAX_Y;
159
160 static const float TARGET_INITIAL_SPEED;
161 static const float TARGET_SPEED_INCREASE_VALUE;
162 float _targetSpeed;
163
164 // state of game
165 GameStates gameState;
166 // current target move direction
167 MoveDirections moveDirection;
168 unsigned int level;
169 static const int MAX_LEVEL;
170
171 // score variables
172 std::string scoreString;
173 int score;
174
175 // text variables
176 osg::ref_ptr<osgText::Text> startText;
177 osg::ref_ptr<osg::Geode> startTextGeode;
178 osg::ref_ptr<osgText::Text> scoreText;
179 osg::ref_ptr<osg::Geode> scoreTextGeode;
180 osg::ref_ptr<osgText::Font> textFont;
181
182 // timing
183 std::string timeString;
184 int timeToEnd;
185 static const int STARTING_TIME;
186
187 osg::Timer_t beginningTime;
188 osg::Timer_t currentTime;
189 osg::Timer_t startOfMove;
190 osg::Timer_t previousTick;
191
192 double movingTime;
193 static const double MOVE_UP_SPEED;
194 static const double MOVE_DOWN_SPEED;
195 };
196
197 }
198
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/ShowFDH.h Source File

  • File List
  • File Members
  • include
  • base
ShowFDH.h
Go to the documentation of this file.
1 #ifndef SHOWFDH_H
2 #define SHOWFDH_H
3
4 #include <vrecko/Ability.h>
5
6 #include <vrecko/EnvironmentObject.h>
7
8 #include <osg/Geode>
9 #include <osg/Geometry>
10
11
12 using namespace vrecko;
13
14 namespace base {
15
16 class ShowFDH: public Ability {
17 public:
18 ShowFDH();
19 ~ShowFDH() {};
20
21 void initialize(void);
22 void update(void);
23
24 void setMaxLevel(long int _new_max) {maxLevel = _new_max;}
25
26 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
27 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
28
29 ParameterVector *getParameterVector(void) {return pParameterVector;}
30 static ParameterVector *pParameterVector;
31
32 protected:
33 osg::Geode *_fdh_geode;
34 osg::Geometry **_fdh_geom;
35 osg::MatrixTransform *transf;
36 float *vert;
37 long int maxLevel;
38 };
39
40 }
41
42 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/ShowFDHModel.h Source File

  • File List
  • File Members
  • include
  • base
ShowFDHModel.h
Go to the documentation of this file.
1 #ifndef SHOWFDHMODEL_H
2 #define SHOWFDHMODEL_H
3
4 #include <vrecko/Ability.h>
5
6 #include <vrecko/EnvironmentObject.h>
7
8 #include <osg/Geode>
9 #include <osg/Geometry>
10
11
12 using namespace vrecko;
13
14 namespace base {
15
16 class ShowFDHModel: public Ability {
17 public:
18 ShowFDHModel();
19 ~ShowFDHModel() {};
20
21 void initialize(void);
22 void update(void);
23
24 protected:
25 osg::Geode *_fdh_geode;
26 osg::Geometry **_fdh_geom;
27 osg::MatrixTransform *transf;
28 double *vert;
29
30 bool _first;
31 };
32
33 }
34
35 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SimpleBox.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
SimpleBox.h
Go to the documentation of this file.
1 #ifndef _SimpleBox_H
2 #define _SimpleBox_H
3
4 #include <osg/Geometry>
5 #include <osg/StateSet>
6 #include <osg/BlendEquation>
7 #include <osg/Depth>
8
9 using namespace vrecko;
10
11 namespace APDYNAMICART
12 {
13
14 static int simpleBoxCounter = 0;
15
17
20 class SimpleBox : public EnvironmentObject
21 {
22
23 public:
31 SimpleBox(osg::Vec3 position, osg::Vec3 size, bool movable=true, osg::Vec4 colour = osg::Vec4(1.0, 1.0, 1.0, 1.0));
32 ~SimpleBox();
33
34
35 void setColour (osg::Vec4 colour);
36 void setHeight (double posY, double height);
37
39 void set(osg::Vec3 point1, osg::Vec3 point2);
40
41 private:
42 osg::ref_ptr<osg::ShapeDrawable> shapeDraw;
43 osg::ref_ptr<osg::Box> shapeBox;
44
45
46 };
47
48
49 }
50 #endif // _SimpleBox_H
51
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/SimpleObjectMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
SimpleObjectMovement.h
Go to the documentation of this file.
1 #ifndef SIMPLE_OBJECT_MOVEMENT_H
2 #define SIMPLE_OBJECT_MOVEMENT_H
3
4 #include <vreckoAP/EditorController/ControllableAbility.h>
5
6 #include <vrecko/Ability.h>
7 #include <vrecko/EnvironmentObject.h>
8
9 using namespace vrecko;
10
11 namespace APEditorQAbilities {
12
13 class SimpleObjectMovement: public ControllableAbility {
14 public:
15 SimpleObjectMovement();
16 virtual ~SimpleObjectMovement() {};
17
18 void update(void);
19
20 protected:
21 virtual void fillDefaultInfo();
22
23 virtual bool activate();
24 virtual void deactivate();
25
26 osg::Vec3 firstPointerPos; // pointer position when activated
27
28 osg::Vec3 firstObjectPos; // object position when activated
29
30 unsigned long movingObjectID; // ID of the object that is being handled. If this is 0, the ability is not activated
31
32 bool bFirstUpdate;
33
34 void issueRequests(bool bStopIfNoSelection);
35
36 bool objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans);
37 // FIRST PART of the tranformation calculations. From the pointer position/rotation the new object
38 // position/rotation is calculated. The matrix is only calculated and stored in [outTrans].
39 // The transformation will be applied afterwards, after another calculations or adjustments.
40 };
41
42 }
43
44 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SliceTool.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SliceTool.h
Go to the documentation of this file.
1 #ifndef _DYNAMIC_ART_SLICE_TOOL_H
2 #define _DYNAMIC_ART_SLICE_TOOL_H
3
4 #include "DATool.h"
5 #include "PoA.h"
6
7 class DAEnvironment;
8
9
10
11 class SliceTool : public DATool
12 {
13 public:
14
15 SliceTool();
16 ~SliceTool();
17
22 void activate();
23
24 void deactivate();
25
26 void postInitialize(void);
27
28 //void processEvent(const std::string &input_name, void *value);
29
30 void turnOn();
31
32 void turnOff();
33
34
35
36 protected:
37 //int sensorNumber; ///< number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)
38 //std::string posString; ///< "SensorXPosition" where X is sensor number
39 //std::string oriString; ///< "SensorXOrientation" where X is sensor number
40 //std::string PointerPosReqString; ///< request for (initial) position string
41 //std::string PointerOriReqString; ///< request for (initial) orientation string
42
43 EnvironmentObject* DAArea;
44 // DAEnvironment* daEnvironment; ///< DAEnvironment
45 //osg::ref_ptr<PoA> poa; ///< actual poa, if there is some
46
47 //osg::Vec3 originalHandposition;
48 //osg::Quat originalHandOrientation;
49 //osg::Vec3 originalLocalHandposition;
50 //osg::Vec3 localHandDiffVec; //movement of hand in local coords.
51
52 //osg::Vec3 newHandPosition;
53 //osg::Quat newHandOrientation;
54
55 //osg::Vec3 originalPoAPosition; // PoA coords are always local
56 //osg::Quat originalPoAOrientation;
57 //osg::Vec3 originalPoAScale;
58
59 //osg::Vec3 DAAposition;
60 //osg::Quat DAAOrientation;
61 //osg::Vec3 DAAScale;
62
63 //bool innterconnectionsAdded; ///< to avoid repeated calling of addInterconn...()
64
65 //bool clipping; //is clipping active
66 osg::ClipNode* clipNode;
67 osg::ClipPlane* lowClipPlane;
68 osg::ClipPlane* topClipPlane;
69
70 };
71
72
73 #endif // _DYNAMIC_ART_SLICE_TOOL_H
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Slider.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Slider.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4
5 using namespace vrecko;
6
7 # ifdef GUI_LIBRARY
8 # define GUI_EXPORT __declspec(dllexport)
9 # else
10 # define GUI_EXPORT __declspec(dllimport)
11 #endif
12
13 namespace APGUI
14 {
15
17
26 class GUI_EXPORT Slider : public GUI_Item
27 {
28 public:
29
30 Slider();
31 ~Slider();
32
33 bool createModels(string geometryType);
34
46 bool initialize(string name, string receiver, string label, string tooltip, osg::Vec3 position = osg::Vec3() );
47
56 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
57
58 osg::ref_ptr<GUI_Text> getText() { return _text; }
59
60 inline double getValue() { return _oldValue; }
61
63 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed);
64
66 virtual void pointed(bool pointed);
67
68 void setColours( osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled );
69
70 void setSliderParameters( double width, double heigh, double minValue, double MaxValue, double step );
71
72 void setState(GUI_ITEM_STATE newState);
73
74 void setValue( double value );
75
76 void update();
77
78
79 protected:
80
82 int _sensorNumber;
83
84 double _oldValue;
85 double _minimumValue;
86 double _maximumValue;
87 double _step;
88
89 // Visuals
90
92 double _width;
93 double _height;
94
95 // static part of slider
96 osg::ref_ptr<osg::Switch> _staticModel;
97
98 // movable part of slider
99 osg::ref_ptr<osg::MatrixTransform> _movableTransform;
100 osg::ref_ptr<osg::Switch> _movableModel;
101
102 // text of slider
103 osg::ref_ptr<GUI_Text> _text;
104
105
106 void createGeometry();
107 void setAndSendValue( double value );
108
109 void sendValue( double value );
110
112 void switchVisuals();
113
114 void updateSlider( osg::Vec3 handPosition );
115
116 osg::Vec3 transformHandPosition( osg::Vec3 &handPosition );
117
118
119 int Slider::intersectSegmentandPlane( osg::Vec3 point0, osg::Vec3 point1, osg::Vec3 planeNormal, osg::Vec3 planePoint, osg::Vec3 *resultPoint );
120
121
123 bool postInitialize(string name, string receiver, string label, string tooltip, osg::Vec3 position );
124
125 DECLARE_INPUT(SliderValue, MessageFloat);
126
127 DECLARE_OUTPUT(GUIItemClicked, MessageString);
128
129 DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3);
130
131 void processInputPosition( int sensor_num, osg::Vec3 pos );
132
133 };
134
135 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SmoothedSpline.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SmoothedSpline.h
Go to the documentation of this file.
1 #pragma once
2 #include "Spline.h"
3
4 class SmoothedSpline : public SplineDecorator
5 {
6
7 public:
8 SmoothedSpline(double smoothFactor, SplinePtr decoratedSpline);
9
11 META_DAObjectDecorator(_decoratedSpline, SmoothedSpline, "Smoothed Spline")
12
13 virtual Vec3ArrayPtr getPoints();
14
15 protected:
16
17 //the bigger number, the smoother curve (curve with less points)
18 double _smoothFactor;
19 };
20
21 typedef osg::ref_ptr<SmoothedSpline> SmoothedSplinePtr;
22
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/SnapObject.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
SnapObject.h
Go to the documentation of this file.
1 #ifndef SNAPOBJECT_H
2 #define SNAPOBJECT_H
3
4 #include <vrecko/EnvironmentObject.h>
5 #include "functions.h"
6
7
8
9 class SnapObject
10 {
11 public:
12 SnapObject();
13 SnapObject(int id);
14 SnapObject(int id, vrecko::EnvironmentObject *eo);
15 ~SnapObject();
16
17 private:
18 unsigned long ID;
19 vrecko::EnvironmentObject *eo;
20
21
23 //temporary variables for computing
24
25 bool graph_dirty; //if there is need to update graph set this value to true
26 vector<map<int, int>> * graph; //graph of object - edges
27
28 bool simpleGraph_dirty;
29 vector<set<int>> * simpleGraph; //simple graph without count of edges
30
31
32 bool maxDistance_dirty; //if there is need to compute this distance
33 float maxDistance; //max geodesic distance targetMaxDistance from boundary loop
34
35 bool snappingRegion_dirty;
36 vector<int> snappingRegion; //snaping region
37 vector<float> * snappingRegionValues; //distance of aech point in snapping region to the boundary loop
38
39 bool boundaryLoop_dirty;
40 vector<vector<int>> * boundaryLoop; //closest point to boundary loop
41 vector<osg::Vec3> boundaryLoopCentroids;
42 unsigned long choosenBoundaryLoop;
43
44 bool closestPoint_dirty;
45 vector<int> closestPoint; //closest point to boundary loop
46
47 public:
48 void setId(unsigned long ID);
49 unsigned long getId();
50
51 void setEo(vrecko::EnvironmentObject* eo);
52 vrecko::EnvironmentObject* getEo();
53
54 void setDirtyGraph(bool dirty);
55 bool getDirtyGraph();
56
57 void setDirtyMaxDistance(bool dirty);
58 bool getDirtyMaxDistance();
59
60 void setDirtySnappingRegion(bool dirty);
61 bool getDirtySnappingRegion();
62
63 void setDirtyBoundaryLoop(bool dirty);
64 bool getDirtyBoundaryLoop();
65
66 void setDirtyClosestPoint(bool dirty);
67 bool getDirtyClosestPoint();
68
69 void setDirtyAll(bool dirty);
70
71 void setChoosenBoundaryLoop(unsigned long position);
72 unsigned long getChoosenBoundaryLoop();
73
74
75
77 //FUNCTIONS
78 public:
79 //get geode of node graf
80 osg::Geode* getGeode();
81 osg::Geode* getGeodeOf(osg::Node *eo);
82
83 //get geometry of node graf
84 osg::Geometry* getGeometry();
85
86 //get vertices
87 osg::Vec3Array* getVertices();
88
89 //get colors
90 osg::Vec4Array* getColors();
91
92 //get normals
93 osg::Vec3Array* getNormals();
94
95 //get faces
96 osg::DrawElementsUShort* getFaces();
97
98 //get primitive set - store count of point and definition
99 osg::PrimitiveSet* getPrimitiveSet();
100
101
102 //get boundary loop of object
103 vector<vector<int>> * getBoundaryLoops();
104 vector<vector<int>> * findBoundaryLoops();
105 vector<int> getBoundaryLoop();
106 vector<osg::Vec3> getBoundaryLoopCentroids();
107 bool chooseBoundaryLoop(SnapObject *object); //choose chich loop of each object we will use
108
109
110 //getGraph
111 vector<map<int, int>> * getGraph();
112 vector<map<int, int>> * createGraph();
113
114 vector<set<int>> * getSimpleGraph();
115 vector<set<int>> * createSimpleGraph();
116
117 vector<int> getSnapRegion();
118
119 vector<int> getClosestPoint(SnapObject *object);
120 vector<int> findClosestPoint(SnapObject *object);
121
122 vector<int> getClosestSnappingRegionPoints(SnapObject *object);
123 vector<int> findClosestSnappingRegionPoints(SnapObject *object);
124
125
126 //getSnappingRegion
127 //optimalization - combine findMaxDistance and getSnappingRegion
128 vector<int> getSnappingRegion();
129 vector<float> * getSnappingRegionValues();
130 float getMaxDistance();
131 vector<int> getSnapRegionWithDistanceSet();
132
133
134 //shortest path
135 vector<int> findShortestPath(int pointA, int pointB);
136
137 void updateDisplayList();
138 void deleteFromScene();
139 void recomputeNormal();
140
141 bool erasePoints(vector<int> &boundaryLoopToErase, vector<int> &eraseLoop);
142 bool erasePointsAndAllFaces(vector<int> &boundaryLoopToErase, vector<int> &eraseLoop);
143 bool mergeObject(SnapObject *object);
144
145 int findClosestPoint(osg::Vec3 point);
146
147 //get part of object - we have seed and boundary loop
148 set<int> getPartOfObject(int seed, set<int> cuttingLoopSet);
149
150 //return true if object is suitable for processing
151 bool SnapObject::isSuitable();
152
153
154 void optimalizeLoop(vector<int> &loop);
155
156 };
157
158 #endif // SNAPOBJECT_H
159
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SnapPoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SnapPoint.h
Go to the documentation of this file.
1 #pragma once
2
3 namespace APDYNAMICART
4 {
5
6 struct SnapPoint
7 {
8 public:
9 SnapPoint(osg::Vec3 center) : _center(center) {};
10
11 osg::Vec3 _center;
12 };
13
14 typedef std::vector<SnapPoint> SnapPointArray;
15 }
16
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/Solver.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
Solver.h
Go to the documentation of this file.
1 #pragma once
2 #ifndef __SOLVER_H
3 #define __SOLVER_H
4
5 #include <osg/Vec2d>
6 #include <osg/Vec3d>
7 #include <osg/Quat>
8
9 #include <list>
10
11 namespace ht
12 {
13
14 /*************************************************************
15 ** Variable - base class to all variables providing
16 ** numerical calculation of their partial derivatives
17 ** To calculate parital derivative of a function, set
18 ** delta to value of step 'h' of numerical approximation
19 ** using function SetDelta. GetValueInFunction should now
20 ** return value of this variable after adding the delta.
21 ** To add delta to the variable itself, call AddDelta.
22 *************************************************************/
23 class Variable
24 {
25 public:
26 virtual ~Variable() {};
27
28 virtual int GetVariablesCount() = 0; // Returns number of derivable subvariables
29 virtual void SetDelta(int variable, double delta) = 0; // Variable starts behaving like "var + delta" in functions, but its value itself does not change
30 virtual void AddDelta(int variable, double delta) = 0; // Adds delta to variable
31 virtual void ResetDelta() = 0; // Resets delta to zero
32
33 // VariableType GetValue(); // Returns value of the variable
34 // VariableType GetValueInFunction(); // Returns value of the variable in function
35 };
36
37 class VariableVec3: public Variable
38 {
39 private:
40 osg::Vec3d _value;
41 osg::Vec3d _delta;
42 public:
43 VariableVec3(): _value(0.0, 0.0, 0.0), _delta(0.0, 0.0, 0.0) {}
44 VariableVec3(const VariableVec3 &v): _value(v._value), _delta(v._delta) {}
45
46 VariableVec3& operator =(const VariableVec3 &v)
47 { _value = v._value; _delta = v._delta; return *this; }
48
49 virtual int GetVariablesCount() override
50 { return 3; }
51 virtual void SetDelta(int variable, double delta) override
52 {
53 switch (variable)
54 {
55 case 0: _delta = osg::Vec3d(delta, 0.0, 0.0); break;
56 case 1: _delta = osg::Vec3d(0.0, delta, 0.0); break;
57 case 2: _delta = osg::Vec3d(0.0, 0.0, delta); break;
58 }
59 }
60 virtual void AddDelta(int variable, double delta) override
61 {
62 switch (variable)
63 {
64 case 0: _value += osg::Vec3d(delta, 0.0, 0.0); break;
65 case 1: _value += osg::Vec3d(0.0, delta, 0.0); break;
66 case 2: _value += osg::Vec3d(0.0, 0.0, delta); break;
67 }
68 }
69 virtual void ResetDelta() override
70 {
71 _delta = osg::Vec3d(0.0, 0.0, 0.0);
72 }
73
74 void SetValue(osg::Vec3d v) { _value = v; }
75 osg::Vec3d GetValue() { return _value; }
76 osg::Vec3d GetValueInFunction() { return _value + _delta; }
77 };
78
79 class VariableVec2: public Variable
80 {
81 private:
82 osg::Vec2d _value;
83 osg::Vec2d _delta;
84 public:
85 VariableVec2(): _value(0.0, 0.0), _delta(0.0, 0.0) {}
86 VariableVec2(const VariableVec2 &v): _value(v._value), _delta(v._delta) {}
87
88 VariableVec2& operator =(const VariableVec2 &v)
89 { _value = v._value; _delta = v._delta; return *this; }
90
91 virtual int GetVariablesCount() override
92 { return 2; }
93 virtual void SetDelta(int variable, double delta) override
94 {
95 switch (variable)
96 {
97 case 0: _delta = osg::Vec2d(delta, 0.0); break;
98 case 1: _delta = osg::Vec2d(0.0, delta); break;
99 }
100 }
101 virtual void AddDelta(int variable, double delta) override
102 {
103 switch (variable)
104 {
105 case 0: _value += osg::Vec2d(delta, 0.0); break;
106 case 1: _value += osg::Vec2d(0.0, delta); break;
107 }
108 }
109 virtual void ResetDelta() override
110 {
111 _delta = osg::Vec2d(0.0, 0.0);
112 }
113
114 void SetValue(osg::Vec2d v) { _value = v; }
115 osg::Vec2d GetValue() { return _value; }
116 osg::Vec2d GetValueInFunction() { return _value + _delta; }
117 };
118
119 class VariableFloat: public Variable
120 {
121 private:
122 double _value;
123 double _delta;
124 public:
125 VariableFloat(): _value(0.0), _delta(0.0) {}
126 VariableFloat(const VariableFloat &f): _value(f._value), _delta(f._delta) {}
127
128 VariableFloat& operator =(const VariableFloat &f)
129 { _value = f._value; _delta = f._delta; return *this; }
130
131 virtual int GetVariablesCount() override
132 { return 1; }
133 virtual void SetDelta(int variable, double delta) override
134 {
135 switch (variable)
136 {
137 case 0: _delta = delta; break;
138 }
139 }
140 virtual void AddDelta(int variable, double delta) override
141 {
142 switch (variable)
143 {
144 case 0: _value += delta; break;
145 }
146 }
147 virtual void ResetDelta() override
148 {
149 _delta = 0.0;
150 }
151
152 void SetValue(double v) { _value = v; }
153 double GetValue() { return _value; }
154 double GetValueInFunction() { return _value + _delta; }
155 };
156
157 class VariableQuat: public Variable
158 {
159 private:
160 osg::Quat _value;
161 osg::Quat _delta;
162 public:
163 VariableQuat(): _value(0.0, osg::Vec3d(1.0, 0.0, 0.0)), _delta(0.0, osg::Vec3d(1.0, 0.0, 0.0)) {}
164 VariableQuat(const VariableQuat &v): _value(v._value), _delta(v._delta) {}
165
166 VariableQuat& operator =(const VariableQuat &v)
167 { _value = v._value; _delta = v._delta; return *this; }
168
169 virtual int GetVariablesCount() override
170 { return 3; }
171 virtual void SetDelta(int variable, double delta) override
172 {
173 switch (variable)
174 {
175 case 0: _delta = osg::Quat(delta, osg::Vec3d(1.0, 0.0, 0.0)); break;
176 case 1: _delta = osg::Quat(delta, osg::Vec3d(0.0, 1.0, 0.0)); break;
177 case 2: _delta = osg::Quat(delta, osg::Vec3d(0.0, 0.0, 1.0)); break;
178 }
179 }
180 virtual void AddDelta(int variable, double delta) override
181 {
182 switch (variable)
183 {
184 case 0: _value = _value * osg::Quat(delta, osg::Vec3d(1.0, 0.0, 0.0)); _value /= _value.length(); break;
185 case 1: _value = _value * osg::Quat(delta, osg::Vec3d(0.0, 1.0, 0.0)); _value /= _value.length(); break;
186 case 2: _value = _value * osg::Quat(delta, osg::Vec3d(0.0, 0.0, 1.0)); _value /= _value.length(); break;
187 }
188 }
189 virtual void ResetDelta() override
190 {
191 _delta = osg::Quat(0.0, osg::Vec3d(1.0, 0.0, 0.0));
192 }
193
194 void SetValue(osg::Quat v) { _value = v; }
195 osg::Quat GetValue() { return _value; }
196 osg::Quat GetValueInFunction() { return _value * _delta; }
197 };
198
199 /*********************************************
200 ** Function - base class for any function.
201 ** The most important method is Evaluate,
202 ** which returns value of the Function
203 ** (including valud of delta).
204 *********************************************/
205 class Function
206 {
207 protected:
208 // Returns distance of point v from line (l1,l2)
209 double _dist_line(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)
210 {
211 // According to WolframAlpha, distance of point 'v' from line 'l1 l2' is
212 // d = |(v-l1)cross(v-l2)| / |l1-l2|
213 double denom = (l1-l2).length();
214 double numer = ((v-l1) ^ (v-l2)).length();
215 if (denom < 1e-9) return (v-l2).length();
216 if (numer < 1e-9) return 0.00;
217 return numer / denom;
218 }
219 double _dist_line2(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2)
220 {
221 return _dist_line(v, l1, l2) * _dist_line(v, l1, l2);
222 }
223 public:
224 virtual double Evaluate() = 0;
225 };
226
227 typedef std::list<Function *> ListOfFunctions;
228 typedef std::list<Variable *> ListOfVariables;
229
230 // Finds a minimum of the sum of functions in list of functions 'fcns'
231 // changing value of variables in list 'vars'
232 void solve(ListOfFunctions &fcns, ListOfVariables &vars, double start_step = 0.01, double next_step_scale = 0.8, double min_step_size = 1e-6);
233
234 }
235
236 #endif // __SOLVER_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/GeometryLoaderBase.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
GeometryLoaderBase.h
Go to the documentation of this file.
1 #ifndef GEOMETRY_LOADER_BASE_H
2 #define GEOMETRY_LOADER_BASE_H
3
4
5
6 #include <vrecko/Ability.h>
7 #include <osg/Node>
8 #include <osg/Geode>
9 #include <osg/Geometry>
10
11 using namespace vrecko;
12
13 namespace APSpacePartitioning {
14
15 #ifdef AP_SPACEPARTITIONING_EXPORTS
16 #define SPACEPARTITIONING_IMP_EXP __declspec(dllexport)
17 #else
18 #define SPACEPARTITIONING_IMP_EXP __declspec(dllimport)
19 #endif
20
21
32 class SPACEPARTITIONING_IMP_EXP GeometryLoaderBase {
33 public:
34 GeometryLoaderBase();
38 ~GeometryLoaderBase();
39
40 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node);
41
45 virtual bool loadGeometry(osg::Node *pNode);
46
50 struct VertexBase {
51 osg::Vec3 pos;
52 osg::Vec3 normal;
53 };
54 virtual unsigned long getVertexStructureSize() { return sizeof(VertexBase); }
55 virtual void allocateVertexArray(unsigned long numVertices) { vertices = new VertexBase[numVertices]; vertex_size = getVertexStructureSize(); }
56 virtual void deallocateVertexArray() { if (vertices) { delete[] ((VertexBase*)vertices); } }
57 virtual bool saveVerticesToFile(vrecko::BufferedFileWrite *bfile);
58 virtual bool loadVerticesFromFile(vrecko::BufferedFile *bfile);
63 struct FaceBase {
64 unsigned long vIndex[3];
65 osg::Vec3 min;
66 osg::Vec3 normal;
67 };
68
69 virtual unsigned long getFaceStructureSize() { return sizeof(FaceBase); }
70 virtual void allocateFaceArray(unsigned long numFaces) { faces = new FaceBase[numFaces]; face_size = getFaceStructureSize(); }
71 virtual void deallocateFaceArray() { if (faces) { delete[] ((FaceBase*)faces); }}
72 virtual bool saveFacesToFile(vrecko::BufferedFileWrite *bfile);
73 virtual bool loadFacesFromFile(vrecko::BufferedFile *bfile);
75 inline void* getFace(unsigned long index) { return (void*)(((unsigned char*)faces) + index * face_size); }
76 inline void* getVertex(unsigned long index) { return (void*)(((unsigned char*)vertices) + index * vertex_size); }
78 inline unsigned long getFaceCount() { return face_count; }
79 inline unsigned long getVertexCount() { return vertex_count; }
81 void debugWriteNormals();
83 protected:
84 void *faces;
85 unsigned long face_count;
86 unsigned long face_size;
88 void *vertices;
89 unsigned long vertex_count;
90 unsigned long vertex_size;
92 bool bRecalculateNormals;
94 bool getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount);
96 bool loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos);
98 void sortVerticesClockwise();
99 virtual void destroyGeometry();
100 void recalculateNormals();
102 /*
103 * returns a normal by ID
104 */
105 inline osg::Vec3 * getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array * pNormArray, osg::IndexArray * pNormIndices, unsigned long index) {
106 if (osg::Geometry::BIND_OFF == normalBinding)
107 return ((osg::Vec3*)NULL);
108
109 if (pNormIndices) {
110 switch (pNormIndices->getDataType()) {
111 case osg::Array::ByteArrayType:
112 index = *(((char*)pNormIndices->getDataPointer()) + index);
113 break;
114 case osg::Array::ShortArrayType:
115 index = *(((short*)pNormIndices->getDataPointer()) + index);
116 break;
117 case osg::Array::IntArrayType:
118 index = *(((int*)pNormIndices->getDataPointer()) + index);
119 break;
120 case osg::Array::UByteArrayType:
121 index = *(((unsigned char*)pNormIndices->getDataPointer()) + index);
122 break;
123 case osg::Array::UShortArrayType:
124 index = *(((unsigned short*)pNormIndices->getDataPointer()) + index);
125 break;
126 case osg::Array::UIntArrayType:
127 index = *(((unsigned int*)pNormIndices->getDataPointer()) + index);
128 break;
129 default:
130 logger.debugLog("GeometryLoaderBase error: Unsupported data type for normals array");
131 return (osg::Vec3*)NULL;
132 }
133 }
134 return ((osg::Vec3*)pNormArray->getDataPointer()) + index;
135 }
136 };
137
138 }
139
140 #endif
141
142
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SphereBVH_Object.h
Go to the documentation of this file.
1
2 #ifndef SPHEREBVH_OBJECT_H
3 #define SPHEREBVH_OBJECT_H
4
5 #include <vrecko/SP_ObjectInterface.h>
6 #include <vrecko/Ability.h>
7
8 using namespace vrecko;
9
10 namespace APSpacePartitioning {
11
12
13 #define SP_OBJECT_INTERFACE_ID__SPHEREBVH 10
14
15 class SphereBVH_Object: public SP_ObjectInterface, public Ability {
16 public:
17 //
18 // constructors / destructors
19 //
20 SphereBVH_Object();
21 ~SphereBVH_Object();
22
23 virtual void preInitialize(void);
24
25
26 bool getCollisions(CollisionParams * params, COLLISION_POINTS_VECTOR ** colPoints,
27 unsigned long obj1ID, unsigned long obj2ID);
28
29 protected:
30 };
31
32 }
33
34 #endif
35
36
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Object_Data.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SphereBVH_Object_Data.h
Go to the documentation of this file.
1 #ifndef SPHEREBVH_OBJECT_DATA_H
2 #define SPHEREBVH_OBJECT_DATA_H
3
4 #include "GeometryLoaderBase.h"
5 #include "SP_Object_Data_Base.h"
6 #include <vrecko/Ability.h>
7 #include <osg/Node>
8 #include <osg/Geode>
9 #include <osg/Geometry>
10
11 using namespace vrecko;
12
13 namespace APSpacePartitioning {
14
15 class SphereBVH_Object_Data: public GeometryLoaderBase, public SP_Object_Data_Base {
16 public:
17 //
18 // constructors / destructors
19 //
20 SphereBVH_Object_Data();
21 SphereBVH_Object_Data(const char* abName);
22 ~SphereBVH_Object_Data();
23
24 virtual bool isHierarchyCreated() { return bSphereBVHierarchyCreated; }
25
26
27 struct STNodeSphere {
28 void *pParent; // pointer to STNode (or descendant class)
29 osg::Vec3 center;
30 float radius;
31 void *pChild[2]; // pointers to STNodes (or descendant classes)
32 unsigned long int face_index;
33 // Used only in leaves.
34 // NOTE: Descendants, such as SNCH_Object_Data, will use it also in non-leaf nodes.
35 };
36 virtual void* allocateSTNode() { return new STNodeSphere; }
37 virtual unsigned long getSTNodeStructureSize() { return sizeof(STNodeSphere); }
38 virtual bool saveTreeNodeToFile(void* node, vrecko::BufferedFileWrite *bfile);
39 // WARNING: pParent is not saved. pChild[X] is not saved directly, but only a boolean value is saved (true if a child is present)
40 virtual bool loadTreeNodeFromFile(void* node, vrecko::BufferedFile *bfile);
41 // WARNING: pChild[X] will be only 1 or 0
42
43 void *getRootPtr(void) {return root;}
44 virtual bool destroyHierarchy(STNodeSphere *subTreeToDestroy = NULL);
45
46 protected:
47 bool bSphereBVHierarchyCreated;
48
49 void *root; // pointer to STNode or its descendant class
50
51 virtual bool constructCacheDataName(char *pOutDataName, int* version);
52 // should be overridden in descendants to supply different name
53
54 virtual bool saveDataToPersistentCache_Init();
55 // This function call isHierarchyCreated() and in case of getting "false" as an answer IT DOES NOTHING.
56 // So it can be safely called several times during the initialization - it only saves the data at the end.
57 virtual bool saveDataToPersistentCache_WriteData(vrecko::BufferedFileWrite *bfile);
58 virtual bool saveDataToPC_SaveTreeNode(vrecko::BufferedFileWrite *bfile, STNodeSphere* node);
59
60 virtual bool loadDataFromPersistentCache_Init();
61 // returns "true" in case of success, otherwise the data have to be regenerated
62 virtual bool loadDataFromPersistentCache_ReadData(vrecko::BufferedFile *bfile);
63 virtual bool loadDataFromPC_LoadTreeNode(vrecko::BufferedFile *bfile, STNodeSphere** ptrToStoreNode);
64
65 virtual bool createTreeFromGeometry(osg::Node *pNode);
66 bool constructTree(void *pSTNode, unsigned long left_pos, unsigned long right_pos, int last_sort);
67
68 virtual int processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData);
69
70 virtual bool coreHierarchyCreation(void);
71 };
72
73 }
74
75 #endif
76
77
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/SphereBVH_Scene.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
SphereBVH_Scene.h
Go to the documentation of this file.
1
2 #ifndef SPHEREBVH_SCENE_H
3 #define SPHEREBVH_SCENE_H
4
5 #include <vrecko/SP_SceneInterface.h>
6 #include <vrecko/Ability.h>
7
8 using namespace vrecko;
9
10 namespace APSpacePartitioning {
11
12
13 #define SP_SCENE_INTERFACE_ID__SPHEREBVH 10
14
15
16
17 class SphereBVH_Scene: public SP_SceneInterface, public Ability {
18 public:
19 //
20 // constructors / destructors
21 //
22 SphereBVH_Scene() : SP_SceneInterface(), Ability("SphereBVH_Scene") { scIntId = SP_SCENE_INTERFACE_ID__SPHEREBVH; };
23 ~SphereBVH_Scene() {};
24
25 virtual void preInitialize(void);
26
27
28 //
29 // methods related to space partitioning queries in the Scene
30 //
32
33
34 protected:
35 };
36
37 }
38
39 #endif
40
41
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/SphericalJoint.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
SphericalJoint.h
Go to the documentation of this file.
1 #ifndef SphericalJoint_h
2 #define SphericalJoint_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include <sstream>
8 #include "BaseJoint.h"
9
10 using namespace vrecko;
11
12
13 namespace PhysXPlugin
14 {
15 class SphericalJoint : public BaseJoint
16 {
17 public:
18 SphericalJoint():BaseJoint("SphericalJoint", &_descripter){}
19
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * domdocument);
23
24
25 protected:
26 NxSphericalJointDesc _descripter;
27
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/SplineAdapter.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
SplineAdapter.h
Go to the documentation of this file.
1 #pragma once
2 #include <osg\Referenced>
3 #include "Utils.h"
4
5 #include "types.h"
6 #include "Spline.h"
7 #include "RegularPolygonSpline.h"
8
9 namespace APDYNAMICART
10 {
11
13 class SplineAdapter : public PoAAdapter<Spline>
14 {
15 public:
16
17 //There will be, probably, some methods for:
18 // setting "smoothness" of cross-section ?
19 protected:
20
21
22 };
23
24
26 class RoundedSplineAdapter : public SplineAdapter
27 {
28 public:
29 RoundedSplineAdapter(double diameter, int segmentCount) : _spline(new RegularPolygonSpline(diameter, segmentCount)) {}
30
31
32 META_DAObject(RoundedSplineAdapter, "Rounded");
33
34 virtual void createMenu(MenuPtr menu);
35 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode);
36 virtual osg::ref_ptr<Spline> getObject() { return _spline; }
37 virtual bool sliderChanged( const char* sliderID, float sliderPos );
38
39 protected:
40 osg::ref_ptr<Spline> _spline;
41 };
42
43
45 class RectangularSplineAdapter : public SplineAdapter
46 {
47 public:
48 RectangularSplineAdapter(double width, double height);
49
50
51 META_DAObject(RectangularSplineAdapter, "Flat");
52
53 virtual void createMenu(MenuPtr menu);
54 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode);
55 virtual osg::ref_ptr<Spline> getObject() { return _spline; }
56 void init();
57
58 protected:
59 osg::ref_ptr<Spline> _spline;
60 };
61
62
64 class WaveSplineAdapter : public SplineAdapter
65 {
66 public:
67 WaveSplineAdapter();
68
69
70 META_DAObject(WaveSplineAdapter, "Wave");
71
72 virtual void createMenu(MenuPtr menu);
73 virtual void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* ParametersNode);
74 virtual osg::ref_ptr<Spline> getObject() { return _spline; }
75 void init();
76
77 protected:
78 osg::ref_ptr<Spline> _spline;
79 };
80
81
82
84 class SplineFactory : public AdapterFactory<SplineAdapter>
85 {
86 public:
87 SplineFactory()
88 {
89 _adapters.push_back(new RoundedSplineAdapter(0.5, 16));
90 _adapters.push_back(new RectangularSplineAdapter(1.0, 0.25));
91
92 //this would not work... two adapters of same kind can't be added to factory
93 //_adapters.push_back(new RectangularSplineAdapter(0.5, 0.25));
94
95 _adapters.push_back(new WaveSplineAdapter);
96
97 }
98
99 //copy constructor
100 SplineFactory( const SplineFactory& orig )
101 {
102 std::vector<osg::ref_ptr<SplineAdapter>> origAdapters = orig.getSupportedAdapters();
103
104 //rounded
105 Spline *tmpGen = (origAdapters[0]->getObject()).get();
106 RegularPolygonSpline *tmpSpline = dynamic_cast< RegularPolygonSpline *>(tmpGen);
107 _adapters.push_back(new RoundedSplineAdapter(tmpSpline->getRadius(), tmpSpline->getSegmentCount()));
108
109 //TODO...
110 _adapters.push_back(new RectangularSplineAdapter(1.0, 0.25));
111 _adapters.push_back(new WaveSplineAdapter);
112 }
113 };
114
115
116 }
117
118
119
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/StaticAttribute.h Source File

  • File List
  • File Members
  • include
  • vrecko
StaticAttribute.h
Go to the documentation of this file.
1
13 // header definitions
14 #ifndef _STATIC_ATTRIBUTE_H_
15 #define _STATIC_ATTRIBUTE_H_
16
17 // attributes description includes
18 #include "Attribute.h"
19 #include "Range.h"
20
21 // STL includes
22 #include <string>
23
24 // OSG includes
25 #include <osg/Vec2>
26 #include <osg/Vec3>
27 #include <osg/Vec4>
28 #include <osg/Matrix>
29 #include <osg/Quat>
30
31 // namespaces used
32 using namespace std;
33 using namespace osg;
34
35 // VRECKO namespace
36 namespace vrecko
37 {
38
64 template <Attribute::DataType type, class tval, class tref = tval>
65 class StaticAttribute : public Attribute
66 {
67 public:
68
83 StaticAttribute(const string& strName, const string& strDescription, tref defaultValue,
84 Range* pRange = null) : Attribute(strName, type, strDescription)
85 {
86 // initialize both attributes
87 this->defaultValue = defaultValue;
88 this->pRange = pRange;
89 }
90
94 ~StaticAttribute()
95 {
96 // if the range pointer is not null
97 if (pRange != null)
98 {
99 // delete and null the pointer
100 delete pRange;
101 pRange = null;
102 }
103 }
104
110 inline tref getDefaultValue() const
111 {
112 return defaultValue;
113 }
114
120 inline const Range* getRangePtr() const
121 {
122 return pRange;
123 }
124
130 inline bool hasRange() const
131 {
132 return (getRangePtr() != null);
133 }
134
135 private:
136
137 // specialized attribute attributes
138 tval defaultValue;
139 Range* pRange;
140 };
141
145 typedef StaticAttribute<Attribute::TYPE_BOOL, bool> BoolAttribute;
146 typedef StaticAttribute<Attribute::TYPE_INT, int> IntAttribute;
147 typedef StaticAttribute<Attribute::TYPE_LONG, long> LongAttribute;
148 typedef StaticAttribute<Attribute::TYPE_FLOAT, float> FloatAttribute;
149 typedef StaticAttribute<Attribute::TYPE_DOUBLE, double> DoubleAttribute;
150
154 typedef StaticAttribute<Attribute::TYPE_STRING, string, const string&>
155 StringAttribute;
156 typedef StaticAttribute<Attribute::TYPE_VEC2, Vec2, const Vec2&>
157 Vec2Attribute;
158 typedef StaticAttribute<Attribute::TYPE_VEC3, Vec3, const Vec3&>
159 Vec3Attribute;
160 typedef StaticAttribute<Attribute::TYPE_VEC4, Vec4, const Vec4&>
161 Vec4Attribute;
162 typedef StaticAttribute<Attribute::TYPE_MATRIX, Matrix, const Matrix&>
163 MatrixAttribute;
164 typedef StaticAttribute<Attribute::TYPE_QUAT, Quat, const Quat&>
165 QuatAttribute;
166
167 // end of vrecko namespace
168 }
169
170 // end header definitions
171 #endif
172
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/Stream.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
Stream.h
Go to the documentation of this file.
1 #ifndef STREAM_H
2 #define STREAM_H
3
4 #include "NxStream.h"
5
6 class UserStream : public NxStream
7 {
8 public:
9 UserStream(const char* filename, bool load);
10 virtual ~UserStream();
11
12 virtual NxU8 readByte() const;
13 virtual NxU16 readWord() const;
14 virtual NxU32 readDword() const;
15 virtual float readFloat() const;
16 virtual double readDouble() const;
17 virtual void readBuffer(void* buffer, NxU32 size) const;
18
19 virtual NxStream& storeByte(NxU8 b);
20 virtual NxStream& storeWord(NxU16 w);
21 virtual NxStream& storeDword(NxU32 d);
22 virtual NxStream& storeFloat(NxReal f);
23 virtual NxStream& storeDouble(NxF64 f);
24 virtual NxStream& storeBuffer(const void* buffer, NxU32 size);
25
26 FILE* fp;
27 };
28
29 class MemoryWriteBuffer : public NxStream
30 {
31 public:
32 MemoryWriteBuffer();
33 virtual ~MemoryWriteBuffer();
34 void clear();
35
36 virtual NxU8 readByte() const { NX_ASSERT(0); return 0; }
37 virtual NxU16 readWord() const { NX_ASSERT(0); return 0; }
38 virtual NxU32 readDword() const { NX_ASSERT(0); return 0; }
39 virtual float readFloat() const { NX_ASSERT(0); return 0.0f;}
40 virtual double readDouble() const { NX_ASSERT(0); return 0.0; }
41 virtual void readBuffer(void* buffer, NxU32 size) const { NX_ASSERT(0); }
42
43 virtual NxStream& storeByte(NxU8 b);
44 virtual NxStream& storeWord(NxU16 w);
45 virtual NxStream& storeDword(NxU32 d);
46 virtual NxStream& storeFloat(NxReal f);
47 virtual NxStream& storeDouble(NxF64 f);
48 virtual NxStream& storeBuffer(const void* buffer, NxU32 size);
49
50 NxU32 currentSize;
51 NxU32 maxSize;
52 NxU8* data;
53 };
54
55 class MemoryReadBuffer : public NxStream
56 {
57 public:
58 MemoryReadBuffer(const NxU8* data);
59 virtual ~MemoryReadBuffer();
60
61 virtual NxU8 readByte() const;
62 virtual NxU16 readWord() const;
63 virtual NxU32 readDword() const;
64 virtual float readFloat() const;
65 virtual double readDouble() const;
66 virtual void readBuffer(void* buffer, NxU32 size) const;
67
68 virtual NxStream& storeByte(NxU8 b) { NX_ASSERT(0); return *this; }
69 virtual NxStream& storeWord(NxU16 w) { NX_ASSERT(0); return *this; }
70 virtual NxStream& storeDword(NxU32 d) { NX_ASSERT(0); return *this; }
71 virtual NxStream& storeFloat(NxReal f) { NX_ASSERT(0); return *this; }
72 virtual NxStream& storeDouble(NxF64 f) { NX_ASSERT(0); return *this; }
73 virtual NxStream& storeBuffer(const void* buffer, NxU32 size) { NX_ASSERT(0); return *this; }
74
75 mutable const NxU8* buffer;
76 };
77
78 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/StringHelpers.h Source File

  • File List
  • File Members
  • include
  • helpers
StringHelpers.h
Go to the documentation of this file.
1 #ifndef STRINGHELPERSH_H
2 #define STRINGHELPERSH_H
3
4 #ifndef HELPERS_IMP_EXP
5 #ifdef VRECKO_LIBRARY
6 #define HELPERS_IMP_EXP __declspec(dllexport)
7 #else
8 #define HELPERS_IMP_EXP __declspec(dllimport)
9 #endif
10 #endif
11
12
13 #if defined(__linux__)
14 #ifndef _itoa
15 #define _itoa itoa
16 HELPERS_IMP_EXP char *strrev(char *str);
17 HELPERS_IMP_EXP char* itoa(int value, char* str, int radix);
18 #endif
19 #endif
20
21 /* Is a string beginning with another specified string? */
22 HELPERS_IMP_EXP bool isBeginningWith(const char *fullString, const char *beginString);
23
24
25
26 inline char* uniCpy(char* str1, const char* str2) { return strcpy(str1, str2); }
27 inline WCHAR* uniCpy(WCHAR* str1, const WCHAR* str2) { return wcscpy(str1, str2); }
28 inline char* uniNCpy(char* str1, const char* str2, size_t count) { return strncpy(str1, str2, count); }
29 inline WCHAR* uniNCpy(WCHAR* str1, const WCHAR* str2, size_t count) { return wcsncpy(str1, str2, count); }
30 inline char* uniCat(char* str1, const char* str2) { return strcat(str1, str2); }
31 inline WCHAR* uniCat(WCHAR* str1, const WCHAR* str2) { return wcscat(str1, str2); }
32 inline const char* uniStr(const char* str1, const char* str2) { return strstr(str1, str2); }
33 inline const WCHAR* uniStr(const WCHAR* str1, const WCHAR* str2) { return wcsstr(str1, str2); }
34 inline char* uniStr(char* str1, const char* str2) { return strstr(str1, str2); }
35 inline WCHAR* uniStr(WCHAR* str1, const WCHAR* str2) { return wcsstr(str1, str2); }
36 inline size_t uniLen(const char* str1) { return strlen(str1); }
37 inline size_t uniLen(const WCHAR* str1) { return wcslen(str1); }
38
39
40
41 template <class _Type>
42 void getFileNameFromPathFile(_Type* outFile, const _Type* inPath, const _Type* inFile)
43 // Adds together the path and the file name (containing absolute, relative or no path) using common rules.
44 {
45 int i;
46 _Type backslashStr[2] = {'\\', 0x00};
47 _Type colonStr[2] = {':', 0x00};
48
49 if ((inFile[0] == '\\') || (inFile[0] == '/')) {
50 // root directory (but might be on non-current disk)
51 uniCpy(outFile, inPath);
52 i = (int)uniLen(outFile) - 1;
53 while (i >= 0) {
54 if (outFile[i] == ':')
55 break;
56 --i;
57 }
58 outFile[i + 1] = 0;
59
60 uniCat(outFile, inFile);
61 } else if (uniStr(inFile, colonStr)) {
62 // full path including the disk
63 uniCpy(outFile, inFile);
64 } else {
65 uniCpy(outFile, inPath);
66 i = (int)uniLen(outFile);
67 if ((i > 0) && (outFile[i - 1] != '\\') && (outFile[i - 1] != '/'))
68 uniCat(outFile, backslashStr);
69 uniCat(outFile, inFile);
70 }
71 }
72
73
74 template <class _Type>
75 void getRelativePath(_Type *outPathFile, const _Type *inPath, const _Type *inPathFile)
76 // Adjusts the [inPathFile] to be a path relative to [inPath]
77 {
78 int i;
79
80 _Type tmpInPath[1000];
81 strcpy (tmpInPath, inPath);
82 i = uniLen(tmpInPath);
83 if ((i <= 0) || ((tmpInPath[i - 1] != '\\') && (tmpInPath[i - 1] != '/'))) {
84 // we require terminating backslash at the end of the input path
85 tmpInPath[i] = '\\';
86 tmpInPath[i + 1] = 0x00;
87 }
88
89 _Type tmpPath[1000];
90 getFileNameFromPathFile(tmpPath, inPath, inPathFile);
91
92 int inPos = 0;
93 while ((tmpInPath[inPos] != 0x00) && (tolower(tmpInPath[inPos]) == tolower(tmpPath[inPos]))) {
94 // find the first difference or the end of either string
95 ++inPos;
96 }
97
98 if (tmpInPath[inPos] == 0x00) {
99 // in-path ended first (or both paths ended). The specified directory/file is in the (sub)directory of the in-path.
100 if (tmpPath[inPos] == 0x00) {
101 // Path with the specified directory/file ended too.
102 // This means the user gave us exactly the main directory (with backslash at the end).
103 outPathFile[0] = '.';
104 outPathFile[1] = 0x00;
105 return;
106 }
107
108 uniCpy(outPathFile, tmpPath + inPos);
109 return;
110 }
111
112
113 // => The specified path lies outside the [inPath] directory.
114 int outPos = 0;
115 i = inPos;
116 while (tmpInPath[i] != 0x00) {
117 if ((tmpInPath[i] == '\\') || (tmpInPath[i] == '/')) {
118 outPathFile[outPos] = '.';
119 outPathFile[outPos + 1] = '.';
120 outPathFile[outPos + 2] = '\\';
121 outPos += 3;
122 }
123 ++i;
124 }
125
126 while ((inPos >= 0) && (tmpPath[inPos - 1] != '\\') && (tmpPath[inPos - 1] != '/')) {
127 // find the beginning of the current directory
128 --inPos;
129 }
130
131 uniCpy(outPathFile + outPos, tmpPath + inPos);
132 }
133
134
135 /*template <class _Type>
136 void getRelativePath(_Type* outPath, _Type* inPath, const _Type* basePath) {
137 if (inPath != uniStr(inPath, basePath)) {
138 uniCpy(outPath, inPath);
139 } else {
140 outPath[0] = 0;
141
142 int i = (int)uniLen(basePath);
143 int i2 = (int)uniLen(inPath);
144 if ((i2 > i) && (basePath[i] == '\\')) {
145 uniNCpy(outPath, inPath + i + 1, i2 - i - 1);
146 outPath[i2 - i - 1] = 0;
147 } else {
148 uniNCpy(outPath, inPath + i, i2 - i);
149 outPath[i2 - i] = 0;
150 }
151 }
152 }*/
153
154
155
156 template <class _Type>
157 void getFilePath(_Type* outPath, const _Type* inFile)
158 // Will include the terminating '\\' (or will be completely empty)
159 {
160 int i = (int)uniLen(inFile) - 1;
161 while (i >= 0) {
162 if ((inFile[i] == '\\') || (inFile[i] == '/')) {
163 uniNCpy(outPath, inFile, i + 1);
164 outPath[i + 1] = 0;
165 return;
166 }
167 --i;
168 }
169
170 outPath[0] = 0;
171 }
172
173 template <class _Type>
174 void getFileNameWithoutPath(_Type* outFile, const _Type* inFile) {
175 int i = (int)uniLen(inFile) - 1;
176 while (i >= 0) {
177 if ((inFile[i] == '\\') || (inFile[i] == '/')) {
178 uniNCpy(outFile, inFile + i + 1, uniLen(inFile) - i - 1);
179 outFile[uniLen(inFile) - i - 1] = 0;
180 return;
181 }
182 --i;
183 }
184 uniCpy(outFile, inFile);
185 }
186
187
188 template <class _Type>
189 void getFileNameWithoutExt(_Type* outFile, const _Type* inFile)
190 // Will NOT include the "."
191 {
192 int i = (int)uniLen(inFile) - 1;
193 while (i >= 0) {
194 if ((inFile[i] == '\\') || (inFile[i] == '/'))
195 // expecting '.', but found '\\' -> there was no extension
196 break;
197
198 if (inFile[i] == '.') {
199 uniNCpy(outFile, inFile, i);
200 outFile[i] = 0;
201 return;
202 }
203 --i;
204 }
205
206 // no extension
207 uniCpy(outFile, inFile);
208 }
209
210
211 template <class _Type>
212 void getFileExtension(_Type* outExt, const _Type* inFile)
213 // Will NOT include the "."
214 {
215 int i = (int)uniLen(inFile) - 1;
216 while (i >= 0) {
217 if ((inFile[i] == '\\') || (inFile[i] == '/'))
218 // expected '.', but found '\\' -> there was no extension
219 break;
220
221 if (inFile[i] == '.') {
222 uniNCpy(outExt, inFile + i + 1, uniLen(inFile) - i - 1);
223 outExt[uniLen(inFile) - i - 1] = 0;
224 return;
225 }
226 --i;
227 }
228
229 // no extension
230 outExt[0] = 0;
231 }
232
233
234 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/SweepSurfaceGeode.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
SweepSurfaceGeode.h
Go to the documentation of this file.
1 #pragma once
2
3 #include <osg\Geode>
4
5 #include "Spline.h"
6 #include "types.h"
7 #include "RotationFrameGenerator.h"
8 #include "ColorGen.h"
9 #include "DiameterGen.h"
10
11 class SweepSurfaceGeode : public osg::Geode
12 {
13 public:
14 SweepSurfaceGeode();
15 SweepSurfaceGeode(const SweepSurfaceGeode&,const osg::CopyOp& copyop=osg::CopyOp::SHALLOW_COPY);
16
17 META_Node(APDYNAMICART, SweepSurfaceGeode);
18
20 virtual void traverse(osg::NodeVisitor& nv);
21
23 inline SplinePtr getLeadingSpline() const { return _leadSpline; }
24 inline SplinePtr getLeadingSpline() { return _leadSpline; }
25 inline void setLeadingSpline(SplinePtr val);
26
27 inline ColorGenPtr getColorGenerator() const { return _colorGen; }
28 inline ColorGenPtr getColorGenerator() { return _colorGen; }
29 inline void setColorGenerator(ColorGenPtr val);
30
31 inline DiameterGenPtr getDiameterGenerator() const { return _diameterGen; }
32 inline DiameterGenPtr getDiameterGenerator() { return _diameterGen; }
33 inline void setDiameterGenerator(DiameterGenPtr val);
34
35 inline SplinePtr getCrossSectionSpline() const { return _crossSectionSpline; }
36 inline SplinePtr getCrossSectionSpline() { return _crossSectionSpline; }
37 inline void setCrossSectionSpline(SplinePtr val);
38
39 inline RotationFrameGeneratorPtr getRFGenerator() const { return _rfGenerator; }
40 inline RotationFrameGeneratorPtr getRFGenerator() { return _rfGenerator; }
41 inline void setRFGenerator(RotationFrameGeneratorPtr val);
42
43 inline const Vec3ArrayPtr getCrossSectionArray() const { return _crossSectionArray; }
44 inline const Vec3ArrayPtr getLeadSplineArray() const { return _leadSplineArray; }
45
46 protected:
47 SplinePtr _leadSpline;
48 SplinePtr _crossSectionSpline;
49 ColorGenPtr _colorGen;
50 DiameterGenPtr _diameterGen;
51 osg::ref_ptr<osg::Geometry> _geometry;
52 RotationFrameGeneratorPtr _rfGenerator;
53 Vec3ArrayPtr _leadSplineArray;
54 Vec3ArrayPtr _crossSectionArray;
55
56
57 std::vector<osg::Quat> _rotationAngles; //NOTE: This is just temporary!!! It will be solved better
58 RotationFrameArray _rfArray;
59 DoubleArrayPtr _diameters;
60 void updateGeometry();
61 void createDrawableObject();
62 void updateVertexArray();
63 void updateNormalArray();
64 void updatePrimitiveSet();
65 void showDebugNormals();
66 Vec3ArrayPtr compute2DNormals();
67 inline osg::Vec3 compute2DNormal( const osg::Vec3& p1, const osg::Vec3& p2);
68 void updateColorArray();
69 };
70
72 void SweepSurfaceGeode::setCrossSectionSpline( SplinePtr val )
73 {
74 if(val.valid()) {
75 _crossSectionSpline = val;
76 _crossSectionSpline->dirty();
77 }
78 }
79
80 void SweepSurfaceGeode::setLeadingSpline( SplinePtr val )
81 {
82 if(val.valid()) {
83 _leadSpline = val;
84 _leadSpline->dirty();
85 }
86 }
87
88 void SweepSurfaceGeode::setRFGenerator( RotationFrameGeneratorPtr val )
89 {
90 if(val.valid()) {
91 _rfGenerator = val;
92 _rfGenerator->dirty();
93 }
94 }
95
96 void SweepSurfaceGeode::setColorGenerator( ColorGenPtr val )
97 {
98 if(val.valid()) {
99 _colorGen = val;
100 _colorGen->dirty();
101 }
102 }
103
104 void SweepSurfaceGeode::setDiameterGenerator( DiameterGenPtr val )
105 {
106 if(val.valid()) {
107 _diameterGen = val;
108 _diameterGen->dirty();
109 }
110 }
111
112 typedef osg::ref_ptr<SweepSurfaceGeode> SweepSurfaceGeodePtr;
113
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/SystemInfo.h Source File

  • File List
  • File Members
  • include
  • base
SystemInfo.h
Go to the documentation of this file.
1 #ifndef SYSTEMINFO_H
2 #define SYSTEMINFO_H
3
4 // An ability to periodically check various information
5 // and write them to the debug log.
6
7 #include <windows.h>
8
9 #include <vrecko/Ability.h>
10 #include <vrecko/World.h>
11 #include <vrecko/EventDispatcher.h>
12
13
14 namespace base {
15
16 #define SI_UNKNOWN_THREAD_NAME "?"
17
18 class SystemInfo: public vrecko::Ability {
19 public:
20
21 class MessageSIThreadCreated : public vrecko::VreckoMessage {
22 public:
23 virtual const char* getMessageId() { return "MessageSIThreadCreated"; }
24
25 MessageSIThreadCreated() {};
26 MessageSIThreadCreated(DWORD _dwThreadId, const char *_name) { dwThreadId = _dwThreadId; name = _name; }
27 virtual bool setValueFromString(const char *valueAsString) { return false; }
28 virtual bool isEqualTo(VreckoMessage *otherMsg) { return false; }
29
30 DWORD dwThreadId;
31 std::string name;
32 };
33
34 SystemInfo();
35 ~SystemInfo();
36
37 virtual void preInitialize();
38 virtual void postInitialize();
39
40 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
41 //XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
42
43 virtual void update();
44
45 static bool TryToSendThreadCreatedEvent(DWORD dwThreadId, const char *pName) {
46 SystemInfo *siInst = (SystemInfo*)vrecko::world->getAbility("base::SystemInfo");
47 if (!siInst)
48 siInst = (SystemInfo*)vrecko::world->getAbility("SystemInfo");
49 if (!siInst)
50 return false;
51
52 return vrecko::world->getEventDispatcherPtr()->reportEvent(siInst, "ThreadCreated", new MessageSIThreadCreated(dwThreadId, pName));
53 }
54
55 protected:
56 DWORD dwLastTick;
57
58 bool bWritePeriodicInfo;
59
60 bool initThread(DWORD dwThreadId, std::string &threadName);
61
62 struct SIThreadInfo {
63 // statistical information about a thread
64 public:
65 SIThreadInfo() : bThreadInitialized(false), bTimeInitialized(false), name(SI_UNKNOWN_THREAD_NAME) {};
66
67 std::string name;
68
69 bool bThreadInitialized; // are the thread values initialized (affinity etc.)
70
71 bool bTimeInitialized; // are the time values initialized?
72 DWORD dwLastUserTime; // ms
73 DWORD dwLastKernelTime; // ms
74 };
75
76 struct SIThreadInit {
77 // structure used to initialize a thread
78 public:
79 DWORD dwAffinity;
80 };
81
82 std::map<DWORD, SIThreadInfo> threadsInfo; // stats
83
84 std::map<std::string, SIThreadInit> threadsInit; // initialization values
85
86 DECLARE_INPUT(ThreadCreated, MessageSIThreadCreated);
87 };
88
89 }
90
91
92 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/CarSim/TLsOnJuncManager.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • CarSim
TLsOnJuncManager.h
Go to the documentation of this file.
1 #ifndef TLS_ON_JUNC_MANAGER
2 #define TLS_ON_JUNC_MANAGER
3
4 #include <vrecko/Ability.h>
5
6 #include <vector>
7
8 #include <osg/MatrixTransform>
9
10 // TL znamena traffic lights ve smyslu jeden semafor
11 // TLs znamena traffic lights ve smyslu vice semaforu
12
13 // nasledujici makra slouzi pro popis (vyjadreni) barev, ktere sviti na jednom semaforu:
14 #define TL_RED_ORANGE 1
15 #define TL_GREEN 2
16 #define TL_ORANGE 3
17 #define TL_RED 4
18
19 namespace CarSim {
20 // zde budou ulozeny ukazatele na transformace barevnych svetel na jednom semaforu
21 struct TLcolorsMT {
22 // ref_ptr pouzivam misto ukazatele proto, aby se pri aktualizaci teto ability nekdy
23 // (na konci simulace) nestalo, ze by ukazatel na MT ukazoval do pameti, kde by ten MT
24 // byl jiz odstranen (nesjpis by to fungovalo i s normalnimi ukazateli, jelikoz na konci
25 // simulace jsou nejdrive zastaveny vsechny aktualizace u Scheduleru a az
26 // potom jsou mazany ability a EnvironmentObjecty; ovsem pro jistotu radeji pouzivam ref_ptr)
27 osg::ref_ptr<osg::MatrixTransform> pRedMT;
28 osg::ref_ptr<osg::MatrixTransform> pOrangeMT;
29 osg::ref_ptr<osg::MatrixTransform> pGreenMT;
30 };
31
32 // abilita, ktera na male krizovatce meni svetla na semaforech (pro jednoduchost se mala
33 // krizovatka, ktera je rizena semafory, vyskytuje ve velke krizovatce vzdy
34 // sama a propojuje 3-4 silnice, v nichz jsou alespon 2 normalni hrany, ktere
35 // smeruji do krizovatky)
36 class TLsOnJuncManager: public vrecko::Ability {
37 public:
38 TLsOnJuncManager();
39 TLsOnJuncManager(std::vector<TLcolorsMT> *const pTLcolorsMTvec,
40 const std::vector<unsigned int*const> *const pTLcolorsVec,
41 const std::vector<unsigned int> *const pTLgreenIntervVec);
42 ~TLsOnJuncManager();
43
44 void preInitialize(void);
45
46 void update(void);
47 //void *processRequest(const std::string &input_name, void *value);
48 protected:
49 // vektor, ve kterem budou pro obsluhu semaforu u krizovatky ulozeny ukazatele na
50 // transformace jednotlivych barev (zelena, oranzova, cervena) pro kazdy semafor
51 // na konci kazde vstupni normalni hrany krizovatky (semafory budou usporadany
52 // proti smeru hodinovych rucicek kolem krizovatky);
53 // pozn.: spravne by asi mela byt kazda transformace zapouzdrena ve svem
54 // EnvironmentObjectu, takze by se k ni nemelo dat pristupovat primo; pro zvyseni
55 // rychlosti ovsem porusuji toto zapouzdreni;
56 std::vector<TLcolorsMT> *const pTLcolorsMTvec;
57
58 // vektor, ve kterem budou pro obsluhu semaforu u krizovatky ulozeny ukazatele na
59 // barvy (ciselne vyjadrene), ktere budou svitit na semaforech
60 // na koncich vstupnich normalnich hran (barvy budou usporadany proti smeru hodinovych
61 // rucicek kolem krizovatky podle semaforu, na kterych se budou vyskytovat);
62 // pozn.: opet spravne by asi mela byt barva semaforu vzdy zapouzdrena u hrany krizovatky
63 // (JuncsEdge) v RoadsState; pro zvyseni rychlosti ovsem porusuji toto zapouzdreni;
64 // pozn.: zrejme se nemuze stat, ze by pri aktualizaci teto ability nekdy (na konci simulace)
65 // ukazatel na barvu ukazoval do pameti, kde by ta barva byla jiz odstranena
66 // (protoze jsou na konci simulace nejdrive zastaveny vsechny aktualizace u Scheduleru a az
67 // potom jsou mazany ability a EnvironmentObjecty)
68 const std::vector<unsigned int*const> *const pTLcolorsVec;
69
70 // vektor s casovymi intervaly, po ktere bude na semaforech kolem krizovatky svitit
71 // zelena (opet budou usporadany proti smeru hodinovych
72 // rucicek kolem krizovatky podle semaforu)
73 const std::vector<unsigned int> *const pTLgreenIntervVec;
74
75 // index do vyse uvedenych vektoru, bude oznacovat semafor, ktery nasleduje
76 // za semaforem, na kterem naposledy zhasnula oranzova a rozsvitila se cervena
77 // (pokud zadny takovy semafor jeste nebyl, bude obsahovat 0 - tedy oznacovat
78 // (ukazovat na) 1. semafor v tech vektorech)
79 unsigned int tlIndex;
80
81 // casove rozvrzeni sviceni barev na semaforech u krizovatky (osa x je casova osa):
82 // 1. semafor |u|ggggggggggggg|o|rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr|
83 // 2. semafor |rrrrrrrrrrrrrrrrrrr|u|gggggggggggggg|o|rrrrrrrrrrrrrrrrrr|
84 // 3. semafor |rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr|u|gggggggggggggg|
85 // ...
86 // | tlIndex == 0 | tlIndex == 1 | tlIndex == 2 |
87
88 // popis zkratek:
89 // u - na semaforu sviti cervena a oranzova soucasne
90 // g - na semaforu sviti zelena
91 // o - na semaforu sviti oranzova
92 // r - na semaforu sviti cervena
93
94 // doba, po kterou bude na semaforu svitit oranzova nebo oranzova a cervena soucasne
95 // nebo na vsech semaforech cervena, bude vzdy stejna - dejme tomu 2 s
96
97 // pocet sekund, ktery ubehl od posledni zmeny tlIndexu
98 unsigned int secCount;
99
100 // metoda, ktera na zacatku simulace na vsech semaforech rozsviti cervenou
101 void initColorsOnTLs(void);
102
103 // tato metoda prepne barvy, ktere sviti na semaforu, na ktery ukazuje tlIndex
104 // (nejprve z r na u, pak z u na g, pak z g na o a nakonec z o na r
105 void switchColorsOnTL(void);
106
107 };
108
109 }
110
111 #endif
112
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2D.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Terrain2D.h
Go to the documentation of this file.
1
11 #ifndef VRECKO_NATURE_TERRAIN_TERRAIN2D_H
12 #define VRECKO_NATURE_TERRAIN_TERRAIN2D_H
13
14 #include <osg/Geode>
15 #include <osg/PositionAttitudeTransform>
16 #include <osg/ShapeDrawable>
17
18 #include "Terrain2DSegment.h"
19
20 namespace APNature
21 {
26 class Terrain2D
27 {
28 private:
29 Terrain2DSegment *_terrainSegments; // Two-dimensional array of terrain segments from which the terrain blocks
30 // which is mapped into one dimension for higher clarity
31 osg::ref_ptr<osg::Group> _terrainGroup; // Group node containing PAT group node.
32 osg::ref_ptr<osg::PositionAttitudeTransform> _PATGroup; // Group node in which the whole terrain block is located.
33
34 public:
40 Terrain2D(void);
41
45 ~Terrain2D(void);
46
51 osg::ref_ptr<osg::Group> GetTerrainGroup() const { return _terrainGroup; }
52
59 const osg::Vec3f& GetPoint(int x, int y) const;
60
67 void SetPoint(int x, int y, const osg::Vec3f& point);
68
75 float GetPointHeight(int x, int y) const;
76
83 void SetPointHeight(int x, int y, float height);
84
90 bool ImportFromHeightMap(const std::string& path);
91
98 void GenerateByRandomFaultsAlgorithm(int iterations, float faultValueMin, float faultValueMax);
99
106 void GenerateByMidpointDisplacementAlgorithm(float cornerValueFrom, float cornerValueTo);
107
113 void GenerateByPerlinNoiseAlgorithm(float persistence, int octaveCount);
114
119 void Flatten(float height);
120
125 void Export(FileTypeExport fileType);
126
131 void Preprocessing();
132
136 void Postprocessing();
137
138 private:
139
143 void AllocateSegments();
144
148 void AllocateSegmentPoints();
149
153 void Release();
154
158 void InitializeNeighbours();
159
165 void InitializeSegmentPositions();
166
170 void ComputeNormals();
171
175 void AddSegmentGeodesToTerrainGroup();
176
183 static inline unsigned int SegmentIndex(int x, int y) { return y * TerrainProperties::ResolutionX() + x;}
184 };
185 }
186
187 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Terrain2DSegment.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
Terrain2DSegment.h
Go to the documentation of this file.
1
8 #ifndef VRECKO_NATURE_TERRAIN_TERRAIN2DSEGMENT_H
9 #define VRECKO_NATURE_TERRAIN_TERRAIN2DSEGMENT_H
10
11 #include <osg/Geode>
12 #include <osg/Geometry>
13 #include <osg/Texture2D>
14 #include <osg/Array>
15
16 #include "Properties/TerrainProperties.h"
17
18 namespace APNature
19 {
25 class Terrain2DSegment
26 {
27 private:
28 osg::Vec2f _segmentPosition; // Position of the terrain segment - located in the NW corner of the segment.
29 int _width, _height; // Exact number of vertices in the given dimensions (width = west<->east; height = north<->south)
30
31 osg::ref_ptr<osg::Vec3Array> _pointPositions; // Positions of the points of the segment
32 osg::ref_ptr<osg::Vec3Array> _pointNormals; // Normals of the points of the segment
33 osg::ref_ptr<osg::Vec4Array> _pointColors; // Colors of the points of the segment
34 osg::ref_ptr<osg::Geode> _terrainSegmentGeode; // OSG geode containing the whole terrain segment
35
36 // Segment neighbours
37 // Pointers to the adjacent segments // -X -Y north +X -Y
38 Terrain2DSegment *_north; // | |
39 Terrain2DSegment *_south; // west east
40 Terrain2DSegment *_west; // | |
41 Terrain2DSegment *_east; // -X +Y south +X +Y
42
43 public:
44
48 Terrain2DSegment();
49
53 ~Terrain2DSegment(void) {}
54
59 inline int Width() const { return this->_width; }
60
65 inline int Height() const { return this->_height; }
66
67 // Neighbours
68 inline const Terrain2DSegment* GetNeighbourNorth() const { return this->_north; }
69 inline const Terrain2DSegment* GetNeighbourSouthh() const { return this->_south; }
70 inline const Terrain2DSegment* GetNeighbourWest() const { return this->_west; }
71 inline const Terrain2DSegment* GetNeighbourEast() const { return this->_east; }
72
73 inline bool IsNeighbourNorth() const { return this->_north != NULL; }
74 inline bool IsNeighbourSouth() const { return this->_south != NULL; }
75 inline bool IsNeighbourWest() const { return this->_west != NULL; }
76 inline bool IsNeighbourEast() const { return this->_east != NULL; }
77
82 inline osg::ref_ptr<osg::Geode> GetTerrainSegmentGeode() const { return this->_terrainSegmentGeode; }
83
90 inline const osg::Vec3f& GetPoint(int x, int y) const { return (*_pointPositions)[PointIndex(x, y)]; }
91
98 inline void SetPoint(int x, int y, const osg::Vec3f& point) { (*_pointPositions)[PointIndex(x, y)] = point; }
99
105 void SetSegmentPosition(const osg::Vec2f& position);
106
110 void InitializeGeode();
111
116 void Flatten(float height);
117
118 private:
119
120 // Declare Terrain2D friendly class so that it can handle memory allocation of the segment
121 // and some other private matters of the class
122 friend class Terrain2D;
123
130 inline unsigned int PointIndex(int x, int y) const { return y * this->_width + x;}
131
132 inline void SetNeighbourNorth(Terrain2DSegment *north) { this->_north = north; }
133 inline void SetNeighbourSouth(Terrain2DSegment *south) { this->_south = south; }
134 inline void SetNeighbourWest(Terrain2DSegment *west) { this->_west = west; }
135 inline void SetNeighbourEast(Terrain2DSegment *east) { this->_east = east; }
136
140 void AllocatePoints();
141
145 void AllocatePointPositions();
146
150 void AllocatePointNormals();
151
156 void ComputePointPositions();
157
161 void ComputePointNormals();
162 };
163 }
164
165 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainAbility.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
TerrainAbility.h
Go to the documentation of this file.
1
10 #ifndef VRECKO_NATURE_TERRAIN_TERRAINABILITY_H
11 #define VRECKO_NATURE_TERRAIN_TERRAINABILITY_H
12
13 #include <vrecko/Ability.h>
14 #include <vrecko/EnvironmentObject.h>
15
16 #ifdef PI
17 #undef PI
18 #endif
19
20 #include <vreckoUtils/Menu.h>
21
22 #include <vreckoAP/GUI/Menu.h>
23 #include <vreckoAP/GUI/GUI_Controller.h>
24
25 #include "Terrain2D.h"
26
27 namespace APNature
28 {
29
30 class TerrainAbility : public vrecko::Ability
31 {
32 private:
33 Terrain2D *_terrain;
34 osg::Vec3 _terrainViewScale;
35
36 APGUI::Menu *_menuAbility;
37 APGUI::GUI_Controller *_guiController;
38
39 std::vector<std::string> _fileNames;
40
41 // Root menu items
42 osg::ref_ptr<vreckoUtils::MenuRoot> _menuRootLayoutEmpty;
43 osg::ref_ptr<vreckoUtils::MenuRoot> _menuRootLayoutTerrain;
44
45 osg::ref_ptr<vreckoUtils::Menu> _menuMainLayoutEmpty;
46 osg::ref_ptr<vreckoUtils::Menu> _menuMainLayoutTerrain;
47
48 // Main menu items
49 osg::ref_ptr<vreckoUtils::Menu> _menuDimensions;
50 osg::ref_ptr<vreckoUtils::Menu> _menuView;
51 osg::ref_ptr<vreckoUtils::Menu> _menuRandomFaults;
52 osg::ref_ptr<vreckoUtils::Menu> _menuMidpointDisplacement;
53 osg::ref_ptr<vreckoUtils::Menu> _menuPerlinNoise;
54 osg::ref_ptr<vreckoUtils::Menu> _menuHeightMap;
55 osg::ref_ptr<vreckoUtils::Menu> _menuExportTo;
56
57 // Additional buttons
58 osg::ref_ptr<vreckoUtils::MenuItem> _itemExport;
59 osg::ref_ptr<vreckoUtils::MenuItem> _itemDelete;
60
61 // BLACK MAGIC FOLLOWS
62 // Message and request declarations
63 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
64
65 // Menu inputs/outputs
66 DECLARE_INPUT(GUIItemClicked, MessageString);
67 DECLARE_INPUT(CreateMenuStructure, MessageInt);
68 DECLARE_INPUT(HidingMenu, MessageBool);
69 DECLARE_OUTPUT(MenuStructure, MessageString);
70 // BLACK MAGIC ENDS
71
72 public:
73 TerrainAbility();
74 ~TerrainAbility() {}
75
80 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
81
85 virtual void update();
86
92 void InitializeMenu();
93
97 void BuildMenuLayouts();
98
103 std::string CreateMenuStructure();
104
109 void GuiItemClicked(const char* itemID);
110
116 void MenuSliderChanged(const char* sliderID, float sliderPos);
117
118 };
119 }
120
121 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Algorithms/TerrainAlgorithm.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Algorithms
TerrainAlgorithm.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_TERRAINALGORITHM_H
10 #define VRECKO_NATURE_TERRAIN_TERRAINALGORITHM_H
11
12 #include "../TerrainUtility.h"
13 #include <osg/Array>
14
15 namespace APNature
16 {
17 class TerrainAlgorithm
18 {
19 protected:
20
21 float *_terrain;
22 int _width, _height;
23
24 public:
25
31 // TODO: Add TerrainSurface and make TerrainAlgorithm abstract by inheriting from TerrainSurface. (?)
32 TerrainAlgorithm(int width, int height);
33
34 ~TerrainAlgorithm();
35
42 inline unsigned int PointIndex(int x, int y) const { return y * this->_width + x;}
43
48 float GetLowestValue() const;
49
54 float GetHighestValue() const;
55
56 protected:
57
64 float* Allocate(int width, int height);
65
69 void Release();
70
74 void Zero();
75
80 void Flatten(float height);
81
88 inline float GetPointHeight(int x, int y) const { return this->_terrain[PointIndex(x, y)]; }
89
96 inline void SetPointHeight(int x, int y, float height) { this->_terrain[PointIndex(x, y)] = height;}
97
98 };
99 }
100
101 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/Properties/TerrainProperties.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
  • Properties
TerrainProperties.h
Go to the documentation of this file.
1
11 #ifndef VRECKO_NATURE_TERRAIN_TERRAINPROPERTIES_H
12 #define VRECKO_NATURE_TERRAIN_TERRAINPROPERTIES_H
13
14 #include <vrecko/ReaderWriter.h>
15 #include <osg/Vec2>
16
17 #include "Enumerations.h"
18
19 namespace APNature
20 {
21 static class TerrainProperties
22 {
23 protected:
24
25 // Common attributes
26 // =================
27 static TerrainAlignment _alignmentX, _alignmentY;
28
29 static osg::Vec2f _fieldSize;
30 static float _heightMin, _heightMax;
31
32 static int _segmentSize;
33 static int _resolutionX, _resolutionY;
34
35 static DataSourceType _dataSourceType;
36
37 public:
38
39 // Common methods
40 // ##############
41
45 static inline TerrainAlignment AlignmentX() { return _alignmentX; }
46 static inline void AlignmentX(TerrainAlignment alignmentX) { _alignmentX = alignmentX; }
47
51 static inline TerrainAlignment AlignmentY() { return _alignmentY; }
52 static inline void AlignmentY(TerrainAlignment alignmentY) { _alignmentY = alignmentY; }
53
57 static inline osg::Vec2f FieldSize() { return _fieldSize; }
58 static void FieldSize(osg::Vec2f fieldSize);
59
67 static void HeightRange(float heightMin, float heightMax);
68
69 static inline float HeightMin() { return _heightMin; }
70 static inline float HeightMax() { return _heightMax; }
71
77 static inline int SegmentSize() { return _segmentSize; }
78 static inline void SegmentSize(int segmentSize) { _segmentSize = (segmentSize >= 2 ? segmentSize : 2); }
79
83 static inline int ResolutionX() { return _resolutionX; }
84 static inline void ResolutionX(int resolutionX) { _resolutionX = (resolutionX >= 1 ? resolutionX : 1); }
85
89 static inline int ResolutionY() { return _resolutionY; }
90 static inline void ResolutionY(int resolutionY) { _resolutionY = (resolutionY >= 1 ? resolutionY : 1); }
91
92 // DataSource-related methods
93 // ##########################
94
98 static inline DataSourceType SourceType() { return _dataSourceType; }
99 static inline void SourceType(DataSourceType dataSourceType) { _dataSourceType = dataSourceType; }
100
101
102 // Derived properties
103 // ##################
104
108 static inline int VerticesX() { return _segmentSize * _resolutionX; }
112 static inline int VerticesY() { return _segmentSize * _resolutionY; }
113
117 static inline float SizeX() { return (VerticesX() - 1) * _fieldSize.x(); }
121 static inline float SizeY() { return (VerticesY() - 1) * _fieldSize.y(); }
122
123
124 // Methods
125 // #######
126
131 static void LoadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node);
132
137 static void LoadDataSourceNodeParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
138
139 protected:
140
146 static TerrainAlignment ParseAlignmentString(const std::string& input);
147
148 } TerrainProperties;
149
150 }
151
152 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainRandom.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
TerrainRandom.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_TERRAINRANDOM_H
10 #define VRECKO_NATURE_TERRAIN_TERRAINRANDOM_H
11
12 #include <osg/Vec3>
13 #include <iostream>
14 #include <string>
15
16 #include "Properties/TerrainProperties.h"
17
18 namespace APNature
19 {
20 class TerrainRandom
21 {
22 public:
23
31 static inline float GetRandomFloatUniform(float from, float to) { return from > to ? TerrainRandom::GetRandomFloatUniform(to, from) :
32 from + (((rand() % RAND_MAX) * (to - from)) / RAND_MAX); }
33
44 static float GetRandomFloatGaussian(float mean, float standardDeviation);
45
58 static float GetRandomFloatGaussianBasedOnPointDistance(int x1, int y1, int x2, int y2);
59
69 /*static inline float GetModifiedVariance(unsigned int iteration, float variance, float hurstExponent)
70 {
71 return (1.0f * variance / pow(2.0f, 2 * hurstExponent * (iteration + 1)));
72 }*/
73
74 private:
75
76 static float _PreGeneratedGaussian;
77 static bool _PreGeneratedGaussianExists;
78 };
79 }
80
81 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Terrain/TerrainUtility.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Terrain
TerrainUtility.h
Go to the documentation of this file.
1
9 #ifndef VRECKO_NATURE_TERRAIN_TERRAINUTILITY_H
10 #define VRECKO_NATURE_TERRAIN_TERRAINUTILITY_H
11
12 #include <osg/Vec3>
13 #include <iostream>
14 #include <string>
15
16 #include "Properties/TerrainProperties.h"
17
18 namespace APNature
19 {
20 class TerrainUtility
21 {
22 public:
23
28 static void Info(const std::string& message);
29
34 static void Error(const std::string& message);
35
41 static inline void SetPointHeight(osg::Vec3& point, float height) { point.set(point.x(), height, point.z()); }
42
48 static std::string LowerCase(const std::string& input);
49
55 static std::string UpperCase(const std::string& input);
56
66 static int GreatestCommonDivisor(int x, int y);
67
76 static inline float LinearMapping(float fromMin, float fromMax, float fromX, float toMin, float toMax)
77 {
78 return toMin + (((toMax - toMin) * (fromX - fromMin)) / (fromMax - fromMin));
79 }
80
89 static void ListDirectory(const std::string& dirpath, const std::string& mask, std::vector<std::string>* fileNames);
90 };
91 }
92
93 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/Texture.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
Texture.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_TEXTURE_H
10 #define _VRECKO_CLOUDS_TEXTURE_H
11
12 #include <osg/Texture2D>
13
14 #include <string>
15
33 osg::ref_ptr<osg::Texture2D> LoadOSGTextureWithColorKey(char *fileName, bool alphaMap, bool computeColorAsRGBAverage, bool colorKey, const osg::Vec4ub& colorKeyValue = osg::Vec4ub(255,0,255,0));
34
35 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/TimeLineSpline.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
TimeLineSpline.h
Go to the documentation of this file.
1 #pragma once
2 #include "Spline.h"
3
4
5 #define TIMELINE__ZERO_TIME 0.0
6 #define TIMELINE__FULLY_VISIBLE -1.0
7
16 class TimeLineSpline : public SplineDecorator
17 {
18
19 public:
20 TimeLineSpline(DoubleArrayPtr timeStamps, SplinePtr decoratedSpline);
21
23 META_DAObjectDecorator(_decoratedSpline, TimeLineSpline, "Time line Spline")
24
25 virtual Vec3ArrayPtr getPoints();
26
27 void setTime(double time);
28
29
30
31 protected:
32
33 // time (in seconds) of spline
34 double _time;
35
36 // pointer to array with timestamps
37 DoubleArrayPtr _timeStamps;
38 };
39
40 typedef osg::ref_ptr<TimeLineSpline> TimeLineSplinePtr;
41
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Timer.h Source File

  • File List
  • File Members
  • include
  • vrecko
Timer.h
Go to the documentation of this file.
1 #ifndef VRECKO_TIMER_H
2 #define VRECKO_TIMER_H
3
4 // More reliable (and slightly less precise) version of a timer than that from the OSG.
5 // ------------------------------------------------------------------------------------
6 // Uses timeGetTime() function instead of QueryPerformanceCounter().
7 // Calculates time with 1 ms precision and works correctly even on multicore multiprocessor
8 // machines unlike QPC, which can jump back and forth randomly. The jumps we experienced
9 // were usually in the range of 50 ms, but much higher values were also reported
10 // on the internet forums.
11
12
13 #include <vrecko/Export>
14 #include <osg/Timer>
15
16 namespace vrecko {
17
18 /* Could be derived from osg::Timer IF the tick() method was virtual :(
19
20 Therefore it was directly copied from osg::Timer and changed a bit.
21 The interface is identical to osg::Timer (at least in OSG 2.4.0). */
22
23
24 class VRECKO_EXPORT Timer {
25 public:
26
27 Timer();
28 ~Timer();
29
30 static Timer* instance();
31
33 osg::Timer_t tick() const;
34
36 void setStartTick() { _startTick = tick(); }
37 void setStartTick(osg::Timer_t t) { _startTick = t; }
38 osg::Timer_t getStartTick() const { return _startTick; }
39
41 inline double time_s() const { return delta_s(_startTick, tick()); }
42
44 inline double time_m() const { return delta_m(_startTick, tick()); }
45
47 inline double time_u() const { return delta_u(_startTick, tick()); }
48
50 inline double time_n() const { return delta_n(_startTick, tick()); }
51
53 inline double delta_s( osg::Timer_t t1, osg::Timer_t t2 ) const { return (double)(t2 - t1)*_secsPerTick; }
54
56 inline double delta_m( osg::Timer_t t1, osg::Timer_t t2 ) const { return delta_s(t1,t2)*1e3; }
57
59 inline double delta_u( osg::Timer_t t1, osg::Timer_t t2 ) const { return delta_s(t1,t2)*1e6; }
60
62 inline double delta_n( osg::Timer_t t1, osg::Timer_t t2 ) const { return delta_s(t1,t2)*1e9; }
63
65 inline double getSecondsPerTick() const { return _secsPerTick; }
66
67 protected :
68 osg::Timer_t _startTick;
69 double _secsPerTick;
70 };
71
72
73 };
74
75 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/Timing.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
Timing.h
Go to the documentation of this file.
1 #pragma once
2
3 #define NOMINMAX
4 #include <windows.h>
5
6 float getCurrentTime();
7 float getElapsedTime();
8
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/Tool.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
Tool.h
Go to the documentation of this file.
1 #ifndef _TOOL_H
2 #define _TOOL_H
3
4 #include <vrecko/EventDispatcher.h>
5
6 #include <vrecko/EnvironmentObject.h>
7 #include <vrecko/Logger.h>
8 #include <osg/Geometry>
9 #include <osg/Geode>
10 #include <osg/Vec3>
11 #include <osg/ref_ptr>
12 #include <vector>
13
14 #include <vrecko/ReaderWriter.h>
15
16 #include <xercesc/parsers/XercesDOMParser.hpp>
17 #include <xercesc/dom/DOM.hpp>
18 #include <xercesc/dom/DOMImplementation.hpp>
19 #include <xercesc/sax/HandlerBase.hpp>
20 #include <xercesc/util/XMLString.hpp>
21 #include <xercesc/util/PlatformUtils.hpp>
22
23 #include <xercesc/dom/DOMWriter.hpp>
24 #include <xercesc/framework/StdOutFormatTarget.hpp>
25 #include <xercesc/framework/LocalFileFormatTarget.hpp>
26
27 #include "Geometry.h"
28
29 XERCES_CPP_NAMESPACE_USE
30 using namespace vrecko;
31 using namespace vrecko;
32 using namespace WGeometry;
33
34 namespace APRoomEdit {
35
36 // Tool type enumeration
37 typedef enum ToolType {
38 NONE = 0,
39 COLORBUCKET = 1,
40 WALLREMOVE = 2,
41 WALLADD = 3,
42 WALLMOVEMENT = 4,
43 POINTMOVE = 5,
44 SAVER = 6,
45 LOADER = 7,
46 CREATEHOLE = 8,
47 HOLEREMOVE = 9,
48 NORMALSSWITCHER = 10,
49 POINTADD = 11
50 };
51
52 class Tool {
53 public:
54 Tool() {type = NONE; dirty=false; }
55 virtual ~Tool() {}
56
57 ToolType getType() {return type;}
58 string getName() {return name;}
59 void setName(string n) {name = n;}
60 bool isDirty() {return dirty;}
61 void setDirty(bool d) {dirty=d;}
62
63 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {}
64 virtual void update(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray, osg::Vec3& movingVector) {}
65 virtual void terminate(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {}
66 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) { return true; }
67
68 protected:
69 ToolType type;
70 bool dirty;
71 std::string name;
72 };
73 }
74
75 #endif
76
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolBrush.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolBrush.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5 #include "SimpleBox.h"
6 #include "Brush.h"
7
8 namespace APDYNAMICART
9 {
10
11 class DAEnvironment;
12
13 typedef osg::ref_ptr<SimpleBox> ref_ptr_SimpleBox;
14
16
19 class ToolBrush : public DATool
20 {
21 public:
22
23 ToolBrush();
24 ~ToolBrush();
25
26 void activate();
27 void deactivate();
28
29 void CreateMenuAbilities();
30
31 std::string createMenuStructure();
32
33
34 void initialize( int newSensorNumber, BrushPtr brush, osg::Vec4 color );
35
37
41 void menuSliderChanged(const char* sliderID, float sliderPos);
42
43 inline void setSensorNumber( const int sensorNum ) { _sensorNumber = sensorNum; }
44
45 void storeSample( osg::Vec3 position, osg::Quat orientation);
46
47 void turnOn();
48
49 void turnOff();
50
51 void update();
52
53
54 protected:
55
56 int _sensorNumber;
57
58 osg::ref_ptr<Brush> _brush;
59
60 osg::Vec3 _DAAposition;
61 osg::Quat _DAAOrientation;
62 osg::Vec3 _DAAScale;
63 osg::Vec3 _lastValidPosition;
64
65 APGUI::Menu *_MenuAbility;
66 APGUI::GUI_Controller *_guiController;
67
68 osg::Timer_t _strokeStartTime;
69
71
74 void guiItemClicked(const char* itemID);
75
76
77 DECLARE_INPUT(GUIItemClicked, MessageString);
78 DECLARE_INPUT(CreateMenuStructure, MessageInt);
79 DECLARE_INPUT(HidingMenu, MessageBool);
80 DECLARE_OUTPUT(MenuStructure, MessageString);
81
82 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
83
84 };
85
86
87 typedef osg::ref_ptr<ToolBrush> ref_ptr_ToolBrush;
88
89 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolEraser.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolEraser.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5
6
7 namespace APDYNAMICART
8 {
9
10
11 class DAEnvironment;
12
13
17 class ToolEraser : public DATool
18 {
19 public:
20
21 ToolEraser();
22 ~ToolEraser();
23
28 void activate();
29
30 void deactivate();
31
32 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
33
34 //void processEvent(const std::string &input_name, void *value);
35
36 // TODO if addController event works as I wish, this function will not be needed
37 void setDAEnvironment(DAEnvironment* p_dae) { _daEnvironment = p_dae; }
38
39 void turnOn();
40
41 void turnOff();
42
43
44
45 protected:
46 int _sensorNumber;
47 std::string _PointerPosReqString;
48 std::string _PointerOriReqString;
49
50 DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3);
51
52 // asking about what object is actually selected - Input Connector should answer
53 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
54
55 };
56
57 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolHook.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolHook.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5 #include "Hoop.h"
6 #include "Hook.h"
7
8 namespace APDYNAMICART
9 {
10
12
15 typedef std::pair<HoopPtr, osg::ref_ptr<HookObject> > Hook;
16
17 class ToolHook : public DATool
18 {
19 public:
20 ToolHook();
21
23 virtual void activate();
24 virtual void deactivate();
25 virtual void turnOn();
26 virtual void turnOff();
27 virtual void update();
28 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL );
29
31 float getRopeRadius() const { return _ropeRadius; }
32
34 std::string createMenuStructure();
35 void guiItemClicked(const char* itemID);
36 void menuSliderChanged(const char* sliderID, float sliderPos);
37
38 protected:
40 PoA* getSelectedPoA();
41 osg::Vec3 getCursorPosition();
42 void initMenu();
43
44 osg::Vec3 _DAAposition;
45 osg::Quat _DAAOrientation;
46 osg::Vec3 _DAAScale;
47 HoopPtr _poa;
48 osg::Vec3 _hookPosition;
49 float _ropeRadius;
50
51 APGUI::Menu* _menuAbility;
52 APGUI::GUI_Controller* _guiController;
53 osg::Vec3 _axis;
54
58 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
59 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
61 DECLARE_INPUT(GUIItemClicked, MessageString);
62 DECLARE_INPUT(CreateMenuStructure, MessageInt);
63 DECLARE_INPUT(HidingMenu, MessageBool);
64 DECLARE_OUTPUT(MenuStructure, MessageString);
65 };
66
67 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolMagicWand.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolMagicWand.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5 #include "OrdinaryAttractor.h"
6
7 namespace APDYNAMICART
8 {
9
10 class DAEnvironment;
11 class Controller;
12
13
14 class ToolMagicWand : public DATool
15 {
16 public:
17
18 ToolMagicWand();
19
20 virtual void activate();
21
22 void createMenuAbilities();
23
24 std::string createMenuStructure();
25
26 PoA* getSelectedPoA();
27
28 virtual void deactivate();
29 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
30 virtual void turnOn();
31 virtual void turnOff();
32 virtual void update();
33
34
35 protected:
36 int _sensorNumber;
37 std::string PointerPosReqString;
38
39 osg::ref_ptr<OrdinaryAttractor> attractor;
40
41 bool dominantAxis;
42
43 APGUI::Menu *_MenuAbility;
44 APGUI::GUI_Controller *_guiController;
45
46 osg::Vec3 _originalHandposition;
47 osg::Vec3 newHandPosition;
48
49 double handMoveMin;
50 double handMoveMax;
51
52 osg::Vec3 paramRangeStart;
53 osg::Vec3 paramRangeEnd;
54 osg::Vec3 initialParamValue;
55 osg::Vec3 paramShift1;
56 osg::Vec3 paramShift2;
57 osg::Vec3 paramMult;
58
59 int indexX;
60 int indexY;
61 int indexZ;
62
63 Controller* controller;
64 int originalIterations;
65 int _lastDominantAxis;
66
67 void changeAttractor(osg::Vec3 newHandPosition);
68 void setValuesXYZ( double newValueX, double newValueY, double newValueZ );
69
70 //for context menu functionality
71 DECLARE_INPUT(GUIItemClicked, MessageString);
72 DECLARE_INPUT(CreateMenuStructure, MessageInt);
73 DECLARE_INPUT(HidingMenu, MessageBool);
74
76
79 void guiItemClicked(const char* itemID);
80
82
86 void menuSliderChanged(const char* sliderID, float sliderPos);
87
88 DECLARE_OUTPUT(MenuStructure, MessageString);
89
90 //for positition of hand
91 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
92
93
94 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
95 int _precision;
96 osg::Vec3 _lastHandPosition;
97 };
98
99 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolRotation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolRotation.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5
6 namespace APDYNAMICART
7 {
8
10
14 class ToolRotation : public DATool
15 {
16 public:
17 ToolRotation();
18
20 virtual void activate();
21 virtual void deactivate();
22 virtual void turnOn();
23 virtual void turnOff();
24 virtual void update();
25
26 osg::Vec3 getCursorPosition();
27
28 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL );
29
31 std::string createMenuStructure();
32 void guiItemClicked(const char* itemID);
33 void menuSliderChanged(const char* sliderID, float sliderPos);
34
35 protected:
37 PoA* getSelectedPoA();
38 void initMenu();
39
40 osg::Vec3 _DAAposition;
41 osg::Quat _DAAOrientation;
42 osg::Vec3 _DAAScale;
43 osg::ref_ptr<PoA> _poa;
44 osg::Vec3 _initCurPos;
45
46 APGUI::Menu* _menuAbility;
47 APGUI::GUI_Controller* _guiController;
48 osg::Vec3 _baseAxis;
49
53 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
54 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
56 DECLARE_INPUT(GUIItemClicked, MessageString);
57 DECLARE_INPUT(CreateMenuStructure, MessageInt);
58 DECLARE_INPUT(HidingMenu, MessageBool);
59 DECLARE_OUTPUT(MenuStructure, MessageString);
60 };
61
62 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSelector.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolSelector.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5 #include "Hoop.h"
6 #include "SectorManager.h"
7
8 namespace APDYNAMICART
9 {
10
12
17 const unsigned int NOT_FOUND = -1;
18
19 class ToolSelector : public DATool
20 {
21 public:
22 ToolSelector();
23
25 virtual void activate();
26 virtual void deactivate();
27 virtual void turnOn();
28 virtual void turnOff();
29 virtual void update();
30 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL );
31
33 std::string createMenuStructure();
34 void guiItemClicked(const char* itemID);
35 void menuSliderChanged(const char* sliderID, float sliderPos);
36
37 protected:
39 PoA* getSelectedPoA();
40 void resetValues();
41 int getNearestIndex();
42 int getSectorNumber();
43 void initMenu();
44
46 osg::Vec3 _DAAposition;
47 osg::Quat _DAAOrientation;
48 osg::Vec3 _DAAScale;
49
50 HoopPtr _hoop;
51 Vec3ArrayPtr _snapPointArray;
52 double _selectStart;
53 double _selectEnd;
54 double _lastEnd;
55 unsigned int _sectorIndex;
56 unsigned int _arraySize;
57 bool _overZero;
58 int _sectorNumber;
59 SectorManager* _sectorManager;
60 APGUI::Menu* _menuAbility;
61 APGUI::GUI_Controller* _guiController;
62
66 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
67 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
69 DECLARE_INPUT(GUIItemClicked, MessageString);
70 DECLARE_INPUT(CreateMenuStructure, MessageInt);
71 DECLARE_INPUT(HidingMenu, MessageBool);
72 DECLARE_OUTPUT(MenuStructure, MessageString);
73 };
74
75 typedef osg::ref_ptr<ToolSelector> ToolSelectorPtr;
76
77 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolSlice.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolSlice.h
Go to the documentation of this file.
1 #ifndef _DYNAMIC_ART_SLICE_TOOL_H
2 #define _DYNAMIC_ART_SLICE_TOOL_H
3
4 #include "DATool.h"
5 #include "PoA.h"
6
7
8 namespace APDYNAMICART
9 {
10
11 class DAEnvironment;
12
13 class ToolSlice : public DATool
14 {
15 public:
16
17 ToolSlice();
23 virtual void activate();
24 virtual void deactivate();
25 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
26 virtual void turnOn();
27 virtual void turnOff();
28
29 protected:
30 //int sensorNumber; ///< number of optitrack sensor (trackable in TrackingTools). Usually 0 (right hand)
31 //std::string posString; ///< "SensorXPosition" where X is sensor number
32 //std::string oriString; ///< "SensorXOrientation" where X is sensor number
33 //std::string PointerPosReqString; ///< request for (initial) position string
34 //std::string PointerOriReqString; ///< request for (initial) orientation string
35 //DAEnvironment* daEnvironment; ///< DAEnvironment
36 //osg::ref_ptr<PoA> poa; ///< actual poa, if there is some
37
38 //osg::Vec3 originalHandposition;
39 //osg::Quat originalHandOrientation;
40 //osg::Vec3 originalLocalHandposition;
41 //osg::Vec3 localHandDiffVec; //movement of hand in local coords.
42
43 //osg::Vec3 newHandPosition;
44 //osg::Quat newHandOrientation;
45
46 //osg::Vec3 originalPoAPosition; // PoA coords are always local
47 //osg::Quat originalPoAOrientation;
48 //osg::Vec3 originalPoAScale;
49
50 //osg::Vec3 DAAposition;
51 //osg::Quat DAAOrientation;
52 //osg::Vec3 DAAScale;
53
54 //bool clipping; //is clipping active
55 osg::ClipNode* clipNode;
56 osg::ClipPlane* lowClipPlane;
57 osg::ClipPlane* topClipPlane;
58 };
59
60 }
61 #endif // _DYNAMIC_ART_SLICE_TOOL_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/DynamicArt/ToolTongs.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • DynamicArt
ToolTongs.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "DATool.h"
4 #include "PoA.h"
5
6
7 namespace APDYNAMICART
8 {
9
10
11 class DAEnvironment;
12
13
17 class ToolTongs : public DATool
18 {
19 public:
20
21 ToolTongs();
22 ~ToolTongs();
23
28 void activate();
29
30 void deactivate();
31
32 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
33
34 //void processEvent(const std::string &input_name, void *value);
35
36 // TODO if addController event works as I wish, this function will not be needed
37 void setDAEnvironment(DAEnvironment* p_dae) { this->_daEnvironment = p_dae; }
38
39 void turnOn();
40
41 void turnOff();
42
43 void update();
44
45
46 protected:
47 int _sensorNumber;
48 std::string _posString;
49 std::string _oriString;
50
51 osg::Vec3 _originalHandposition;
52 osg::Quat _originalLocalHandOrientation;
53 osg::Vec3 _originalLocalHandposition;
54 osg::Vec3 _localHandDiffVec; //movement of hand in local coords.
55
56 osg::Vec3 _newHandPosition;
57 osg::Quat _newHandOrientation;
58
59 osg::Vec3 _originalPoAPosition; // PoA coords are always local
60 osg::Quat _originalPoAOrientation;
61 osg::Vec3 _originalPoAScale;
62
63 osg::Vec3 _daAreaPosition;
64 osg::Quat _daAreaOrientation;
65 osg::Vec3 _daAreaScale;
66
67
68 DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation);
69
70 // asking about what object is actually selected - Input Connector should answer
71 DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID);
72
73 };
74
75 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Trace.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Trace.h
Go to the documentation of this file.
1 #ifndef VF_TRACE
2 #define VF_TRACE
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec4>
6 #include <osg/Geode>
7 #include <osg/MatrixTransform>
8 #include <osg/Group>
9
10 using namespace vrecko;
11 namespace VirtualFixture{
12
13 class Trace: public Ability {
14 public:
15 Trace();
16 ~Trace() {};
17
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24
25 void display(void);
26
27 void addMarker(osg::Vec3 position); //add new marker
28 void removeAllMarkers(); //remove all markers from scene and free memory
29
30
31 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
32 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
33
34 protected:
35 bool active; //if true, it will be active
36
37 bool visible; //if geometric representation will be visible
38 osg::MatrixTransform *tnode; //transform node pointer
39 osg::Group *gnode; //group pointer -> top node in OSG subtree -> container for all markers
40 osg::Geode *node; //geometry node pointer -> for adding new marker
41 osg::Vec4 color; //color of first marker
42 osg::Vec4 color2; //color of first marker
43
44 float transparency; //first marker transparency
45 float transparency2; //first marker transparency
46
47 float radius; //marker radius -> for geometry
48 float mindistance; //minimal distance to new marker (to avoid all markers at the same location)
49
50 int num_of_markers; //amount of markers
51 osg::Vec3 latestpos; //position of lastest marker
52
53
54 };
55
56 };
57
58 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Ultratrak.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Ultratrak.h
Go to the documentation of this file.
1 /***************************************************************************
2 ultratrak.h - description
3 -------------------
4 begin : February 2003
5 copyright : (C) 2003 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef ULTRATRAK_H
19 #define ULTRATRAK_H
20
21 #ifdef WIN32
22 #include <string>
23 #include <windows.h>
24 #else
25 #define POLHEMUS_PORT 5555
26 #define POLHEMUS_PORT2 5555
27 #define POLHEMUS_HEADER "Frame %3d FrameSize %3d HeaderSize %3d RecordSize %3d \r\n"
28
29
30 #include <errno.h>
31 #include <fcntl.h>
32 #include <math.h>
33 #include <netdb.h>
34 #include <pthread.h>
35 #include <stdio.h>
36 #include <stdlib.h>
37 #include <unistd.h>
38 #include <netinet/in.h>
39 #include <sys/ioctl.h>
40 #include <sys/mman.h>
41 #include <sys/socket.h>
42 #include <sys/stat.h>
43 #include <sys/types.h>
44 #include <sys/time.h>
45 #include <arpa/inet.h>
46 #include <sys/wait.h>
47 #include <strings.h>
48
49 #endif
50
51 #include <vrecko/IOPins.h>
52 #include <vrecko/Device.h>
53 #include <osg/Vec3>
54 #include <osg/Vec4>
55 #include <osg/Matrix>
56 #include <osg/Quat>
57
58
59 #define BUFSIZE 1000
60
61
62 namespace vreckoDP_base {
63
64
65
66 class DP_EXPORT Ultratrak : public vrecko::Device {
67 public:
68 Ultratrak() : Device("Ultratrak") {};
69 Ultratrak(const char* _port_number);
70 ~Ultratrak();
71
72 virtual int openDevice(void);
73 int closeDevice(void);
74
75 void update(void);
76
77 int getRotate(float *p_rotate);
78 osg::Vec3 &getRotate(void);
79 osg::Vec3 &getRotateA(void);
80 osg::Matrix &getRotateM(void);
81 osg::Quat &getRotateQ(void);
82 int getTranslate(float *p_trans);
83 osg::Vec3 &getTranslate(void);
84
85 void setInitialPosition(osg::Vec4 &_pos);
86 void setInitialRotation(osg::Vec4 &_rot);
87 void setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2);
88 void setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2);
89
90 void setOriginPosition(float _nx, float _ny, float _nz) {_origin_pos.set(_nx, _ny, _nz);}
91 void setTranslateMapping(float _nx, float _ny, float _nz) {_trans_mapp.set(_nx, _ny, _nz);}
92
93 protected:
94 std::string _hostname;
95 int scanDevice(void);
96 int _port; // Èíslo portu
97 char _buf[BUFSIZE]; // Pøijímací buffer
98 #ifdef WIN32
99 WORD _wVersionRequested; // = MAKEWORD(1,1); // Èíslo verze
100 WSADATA _data; // Struktura s info. o knihovnì
101 std::string _text; // Odesílaný a pøijímaný text
102 hostent *_host; // Vzdálený poèítaè
103 sockaddr_in _serverSock; // Vzdálený "konec potrubí"
104 sockaddr_in _other; // Odesílatel dat
105 SOCKET _mySocket; // Soket
106 // int _port; // Èíslo portu
107 //char _buf[BUFSIZE]; // Pøijímací buffer
108 int _size; // Poèet pøijatých a odeslaných bytù
109 int _addrlen; // Délka adresy serveru
110 bool openSocket(void); //char *pcCommPort, HANDLE *temp_hCom);
111
112 #else
113 int sockfd;
114 struct sockaddr_in sockname;
115 int length;
116 bool openSocket(void); //char *_port_name, int *temp_port_fd);
117 #endif
118 bool scanDeviceX(void);
119
120
121 osg::Vec3 _translate[4], _ret_translate[4];
122 osg::Quat _rotate[4], _ret_rotate[4];
123
124 osg::Vec3 _origin_pos, _trans_mapp;
125
126 DECLARE_OUTPUT(Position_sensor_0, vrecko::MessageVec3);
127 DECLARE_OUTPUT(Orientation_sensor_0, vrecko::MessageQuat);
128 DECLARE_OUTPUT(Position_sensor_1, vrecko::MessageVec3);
129 DECLARE_OUTPUT(Orientation_sensor_1, vrecko::MessageQuat);
130 DECLARE_OUTPUT(Position_sensor_2, vrecko::MessageVec3);
131 DECLARE_OUTPUT(Orientation_sensor_2, vrecko::MessageQuat);
132 DECLARE_OUTPUT(Position_sensor_3, vrecko::MessageVec3);
133 DECLARE_OUTPUT(Orientation_sensor_3, vrecko::MessageQuat);
134 };
135
136 }
137
138 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/LightsEditor/UniformUpdateCallback.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • LightsEditor
UniformUpdateCallback.h
Go to the documentation of this file.
1 #include <osg/Uniform>
2
3 #include <vrecko/World.h>
4 #include <vrecko/Scene.h>
5
6 #include <vrecko/EnvironmentObject.h>
7
8
9 class UniformUpdateCallback : public osg::Uniform::Callback
10 {
11 private:
12
13 osg::ref_ptr<osg::Camera> camera;
14
15 private:
16 // Updates viewport size
17 void updateViewport(osg::Uniform* un) const;
18 // Updates position of far clipping plane vertices
19 void updateFarPlane(osg::Uniform* un) const;
20 // Updates camera position
21 void updateCameraPos(osg::Uniform* un) const;
22
23 void updateViewMatrix(osg::Uniform* un) const;
24 void updateViewMatrixInverse(osg::Uniform* un) const;
25
26 public:
27 // Takes care of updating uniforms for shaders
28 UniformUpdateCallback(osg::Camera* _camera)
29 : osg::Uniform::Callback(), camera(_camera){
30 }
31
32 // Calls appropriate function according to uniform name
33 virtual void operator() ( osg::Uniform* un, osg::NodeVisitor* nv )
34 {
35 const std::string& uniformName = un->getName();
36
37 if ( uniformName == "viewport" ) {
38 updateViewport(un);
39 }
40 else if ( uniformName == "farPlaneVertices" ) {
41 updateFarPlane(un);
42 }
43 else if ( uniformName == "cameraPos" ) {
44 updateCameraPos(un);
45 }
46 else if ( uniformName == "viewMatrix" ) {
47 updateViewMatrix(un);
48 }
49 else if ( uniformName == "viewMatrixInverse" ) {
50 updateViewMatrixInverse(un);
51 }
52 }
53 };
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/UpdatablePhysXObject.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
UpdatablePhysXObject.h
Go to the documentation of this file.
1 #ifndef UpdatablePhysXObject_h
2 #define UpdatablePhysXObject_h
3
4 #include "BasePhysXObject.h"
5
6 using namespace vrecko;
7
8 namespace PhysXPlugin
9 {
10 class UpdatablePhysXObject : public BasePhysXObject
11 {
12 protected:
13 std::string _strRegisterPhysXObject;
14 public:
15 UpdatablePhysXObject(const char* abName):BasePhysXObject(abName){}
16 virtual ~UpdatablePhysXObject(){}
17
18 // tato metoda a preInitialize musi byt volany ve zdedenych tridach
19 // pretezujte metodu BeforeInitialization a AfterInitialization
20 void postInitialize();
21
22
23 virtual void RegisterUpatablePO();
24
25 virtual void UpdateEnvironmentObject()=0;
26
27 DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool);
28 };
29 }
30
31 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ObjectUtils/UseToEvent.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ObjectUtils
UseToEvent.h
Go to the documentation of this file.
1 #ifndef USETOEVENT_H
2 #define USETOEVENT_H
3
4 #include <vrecko/IOPins.h>
5 #include <vrecko/BaseClass.h>
6 #include <vrecko/Ability.h>
7
8 using namespace vrecko;
9
10 namespace APObjectUtils
11 {
12
13 class UseToEvent: public vrecko::Ability
14 {
15 public:
16 UseToEvent();
17 virtual ~UseToEvent();
18
19 protected:
20 vrecko::EnvironmentObject *owner;
21
22 DECLARE_INPUT(Use, MessageBool);
23 DECLARE_OUTPUT(Trigger, MessageBool);
24 };
25
26 }
27
28 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/EditorQAbilities/UseTrigger.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • EditorQAbilities
UseTrigger.h
Go to the documentation of this file.
1 #ifndef USETRIGGER_H
2 #define USETRIGGER_H
3
4 #include "../EditorController/ControllableAbility.h"
5 #include <vrecko/Ability.h>
6 #include <vrecko/EnvironmentObject.h>
7
8 using namespace vrecko;
9
10 namespace APEditorQAbilities {
11
12 class UseTrigger: public ControllableAbility {
13 public:
14 UseTrigger();
15 virtual ~UseTrigger() {};
16
17 protected:
18 virtual void fillDefaultInfo();
19 virtual bool activate();
20 virtual void deactivate();
21
22 bool SendUseSignal(bool bParameter);
23 /* Send a signal to every ability of the selected object that
24 has the "Use" input of type BOOL. */
25 };
26
27 }
28
29 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Box.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Box.h
Go to the documentation of this file.
1 #ifndef VF_BOX
2 #define VF_BOX
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Vec4>
7 #include <osg/Geode>
8 #include <osg/MatrixTransform>
9 #include <osg/Group>
10
11
12 using namespace vrecko;
13 using namespace vreckoDP_base;
14 namespace VirtualFixture{
15
16 class Box: public PHANToMFilter {
17 public:
18 Box();
19 ~Box() {};
20
22 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
23 void processEvent(const std::string &input_name, void *value);
24
25 void preInitialize(void);
26 void postInitialize(void);
27 void update(void);
28 void display(void); //show/hide object
29
30 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
31 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
32
33 protected:
34 PHANToM *PHANToMDevice;
35 bool all_on;
36 bool active; //if true, attractive field will be active
37
38 bool visible; //if geometric representation will be visible
39 osg::MatrixTransform *tnode; //transform node pointer
40 osg::Group *gnode; //group pointer
41 osg::Geode *node; //geometry node pointer (for bounding cylinder)
42 osg::Vec4 color; //color of border sphere (radius)
43 float transparency; //border sphere transparency
44
45 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
46 osg::Vec3 size; //size of box (width, height, lenght), position is in center, so left,bottom, corner is in position - size/2
47 osg::Vec3 nullsize; //size of box (width, height, lenght), position is in center, so left,bottom, corner is in position - size/2 ; close to center where attractive force is NOT applied
48 float stiffness; //force divided by meter
49 };
50
51 };
52
53 #endif
54
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Plane.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Plane.h
Go to the documentation of this file.
1 #ifndef VF_PLANE
2 #define VF_PLANE
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6 #include <osg/Vec4>
7 #include <osg/Geode>
8 #include <osg/MatrixTransform>
9 #include <osg/Group>
10
11
12 using namespace vrecko;
13 using namespace vreckoDP_base;
14 namespace VirtualFixture{
15
16 class Plane: public PHANToMFilter {
17 public:
18 Plane();
19 ~Plane() {};
20
22 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
23 void processEvent(const std::string &input_name, void *value);
24
25 void preInitialize(void);
26 void postInitialize(void);
27 void update(void);
28
29 void display(void); //show or hide VF_cylinder object
30
31 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
32 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
33
34 protected:
35 PHANToM *PHANToMDevice;
36 bool all_on;
37 bool active; //VF switcher
38 bool visible; //if geometry of VF vill be shown on screen
39 osg::MatrixTransform *tnode; //transform node pointer
40 osg::Group *gnode; //group pointer
41 osg::Geode *node; //geometry node pointer (for bouning cylinder)
42 osg::Geode *node2; //geometry node2 pointer (for center cylinder)
43 float transparency; //transparency of VF geometry (interval (0,1), 1 = invisible)
44 float transparency2; //transparency of VF geometry (interval (0,1), 1 = invisible) inner cylinder
45 osg::Vec4 color; //VF color (of whole geometry)
46 osg::Vec4 color2; //VF color2 (of center)
47 osg::Vec3 position; //position of starting point
48 osg::Vec3 vector; //vector on cylinder axis (from bottom to top)
49 float radius; //cylinder radius (maximum range of attractive field)
50 float nullradius; //radius close to centre, where attractive field is NOT applied
51 float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
52 float pushingforce; //pushing force along the vector
53 bool pushing; //if true push PHANToM along the vector
54 };
55 };
56
57 #endif
58
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/VRPN3DMouse.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
VRPN3DMouse.h
Go to the documentation of this file.
1
11 #pragma once
12
13 #include <vrecko/IOPins.h>
14 #include <vrecko/Device.h>
15 #include <vrecko/EventDispatcher.h>
16
18 #include <vrpn_Analog.h> //for 6DOF analog sensor
19 #include <vrpn_Button.h> //For buttons on the 3D mouse
20
21 namespace vreckoDP_base {
22
23 const std::string virtualKey[] =
24 {
25 "Menu", "Fit", "Top", "Left", "Right", "Front", "Bottom",
26 "Back", "CW", "CCW", "ISO1", "ISO2", "1", "2", "3", "4", "5",
27 "6", "7", "8", "9", "10", "Esc", "Alt", "Shift", "Ctrl", "Rotate",
28 "Panzoom", "Dominant", "Plus", "Minus"
29 };
30
31 enum virtualKeyCode
32 {
33 V3DK_MENU=0, V3DK_FIT,
34 V3DK_TOP, V3DK_LEFT, V3DK_RIGHT, V3DK_FRONT, V3DK_BOTTOM, V3DK_BACK,
35 V3DK_CW, V3DK_CCW,
36 V3DK_ISO1, V3DK_ISO2,
37 V3DK_1, V3DK_2, V3DK_3, V3DK_4, V3DK_5, V3DK_6, V3DK_7, V3DK_8, V3DK_9, V3DK_10,
38 V3DK_ESC, V3DK_ALT, V3DK_SHIFT, V3DK_CTRL,
39 V3DK_ROTATE, V3DK_PANZOOM, V3DK_DOMINANT,
40 V3DK_PLUS, V3DK_MINUS
41 };
42
43 class DP_EXPORT VRPN3DMouse : public vrecko::Device
44 {
45 public:
46 VRPN3DMouse();
48 virtual int openDevice(void);
49 int closeDevice(void);
50 void processEvent(const std::string &input_name, void *value);
51 void update(void);
52 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
53
55 void VRPN3DMouse::sendAnalogEvent(osg::Vec3 *p, osg::Vec3 *o);
56 void VRPN3DMouse::sendButtonEvent(u_int key, u_int state);
57
58 protected:
59 vrecko::EventDispatcher *pEventDispatcher;
60 vrpn_Analog_Remote* ana;
61 vrpn_Button_Remote* but;
62 HANDLE vrpnServerHandle;
63 osg::Vec3 _originPos, _curMove;
64 osg::Quat _originRot, _curRotate;
65 float _speedFactor;
66 float _rotateRatio;
67
68 bool _speedControl;
69 bool _axisControl;
70 bool _rotateControl;
71
73 static void VRPN_CALLBACK handle_analog(void *userdata, vrpn_ANALOGCB b);
74 static void VRPN_CALLBACK handle_button(void *userdata, vrpn_BUTTONCB b);
75
76 DECLARE_OUTPUT(Button, vrecko::MessageString);
77 DECLARE_OUTPUT(Position, vrecko::MessageVec3);
78 DECLARE_OUTPUT(Move, vrecko::MessageVec3);
79 DECLARE_OUTPUT(Rotation, vrecko::MessageQuat);
80 DECLARE_OUTPUT(Orientation, vrecko::MessageQuat);
81 };
82 }
83
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Vibration.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Vibration.h
Go to the documentation of this file.
1 #ifndef VF_VIBRATION
2 #define VF_VIBRATION
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7 #include <osg/Timer>
8 #include "Auxiliary.h"
9
10 using namespace vrecko;
11 using namespace vreckoDP_base;
12 namespace VirtualFixture{
13
14 extern osg::Timer vtimer; //declare timer for vibration (it's not the same as in auxiliary.cpp !!!!)
15
16 class Vibration: public PHANToMFilter {
17 public:
18 Vibration();
19 ~Vibration() {};
20
22 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
23 void processEvent(const std::string &input_name, void *value);
24
25 void preInitialize(void);
26 void postInitialize(void);
27 void update(void);
28
29 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
30 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
31
32 bool active; //if true, it will be active
33
34 float frequency; //frequency of vibration
35 float amplitude; //amplitude of vibration
36 osg::Vec3 direction; //direction of vibration -> if freq > 20 hz, direction is indistinguisable!!!
37 float duration; //how long will vibration last
38
39 osg::Timer_t vstart_tick; //when vibration was started
40
41 protected:
42 PHANToM *PHANToMDevice;
43 bool all_on;
44 };
45
46 };
47 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabel.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
VibrationLabel.h
Go to the documentation of this file.
1 #ifndef VF_VIBRATIONLABEL
2 #define VF_VIBRATIONLABEL
3
4 #include <vrecko/Ability.h>
5 #include <vreckoDP/base/PHANToM.h>
6
7 using namespace vrecko;
8 using namespace vreckoDP_base;
9 namespace VirtualFixture{
10
11 class VibrationLabel: public PHANToMFilter {
12 public:
13 VibrationLabel();
14 ~VibrationLabel() {};
15
17 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
18 void processEvent(const std::string &input_name, void *value);
19
20 void preInitialize(void);
21 void postInitialize(void);
22 void update(void);
23
24 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
26
27 bool active; //if true, it will be active
28
29 float frequency; //frequency of vibration
30 float amplitude; //amplitude of vivration
31 osg::Vec3 direction; //direction of vibration -> if freq > 20 hz, direction is indistinguisable!!!
32
33 protected:
34 PHANToM *PHANToMDevice;
35 bool all_on;
36 };
37
38 };
39 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/VibrationLabelActivator.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
VibrationLabelActivator.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4
5 #include "Auxiliary.h"
6 #include "VibrationLabel.h"
7
8 using namespace vrecko;
9 using namespace vreckoDP_base;
10 namespace VirtualFixture{
11
12 class VibrationLabelActivator: public PHANToMFilter {
13 public:
14 VibrationLabelActivator();
15 ~VibrationLabelActivator() {};
16
18 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
19 void processEvent(const std::string &input_name, void *value);
20
21 void preInitialize(void);
22 void postInitialize(void);
23 void update(void);
24
25 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
26 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
27
28 protected:
29 PHANToM *PHANToMDevice;
30 bool all_on;
31 bool active; //if true, it will be active
32
33 };
34
35 };
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/Viewer.h Source File

  • File List
  • File Members
  • include
  • vrecko
Viewer.h
Go to the documentation of this file.
1
11 #pragma once
12
13 #include <vrecko/Export>
14
15 #include <osgViewer/ViewerBase>
16 #include <osgViewer/Viewer>
17 #include <osgViewer/CompositeViewer>
18
19 namespace vrecko
20 {
22 //TODO: Make this class as a osgViewer::ViewerBase child class
23 class VRECKO_EXPORT ViewerBase : public osg::Referenced
24 {
25 public:
26 virtual osgViewer::ViewerBase* getViewer() = 0;
27
29 virtual void addView(osgViewer::View* view) = 0;
30
36 virtual void setDisplaySettings(osg::DisplaySettings* ds1, osg::DisplaySettings* ds2 = NULL) = 0;
37
39 virtual void setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f) = 0;
40
42 virtual void addEventHandler(osgGA::GUIEventHandler* eventHandler) = 0;
43
45 virtual void setSceneData(osg::Node* node) = 0;
46
48 virtual void camera_setViewMatrixAsLookAt(const osg::Vec3d& eye,const osg::Vec3d& center,const osg::Vec3d& up) = 0;
49
51 virtual void setLight(osg::Light* light) = 0;
52
54 virtual osg::Light* getLight() = 0;
55
57 virtual osg::Camera* getCamera(int screenNum = 0) = 0;
58
60 virtual int getStereoMode() = 0;
61
63 bool done() {
64 return getViewer()->done();
65 }
66
68 void realize() {
69 getViewer()->realize();
70 }
71
72 void setThreadingModel(osgViewer::ViewerBase::ThreadingModel threadingModel) {
73 getViewer()->setThreadingModel(threadingModel);
74 }
75
76 void getWindows(osgViewer::ViewerBase::Windows& windows, bool onlyValid=true) {
77 getViewer()->getWindows(windows, onlyValid);
78 }
79
80 void getCameras(osgViewer::ViewerBase::Cameras& cameras, bool onlyActive=true) {
81 getViewer()->getCameras(cameras, onlyActive);
82 }
83
84 void getContexts(osgViewer::ViewerBase::Contexts& contexts, bool onlyValid=true) {
85 getViewer()->getContexts(contexts, onlyValid);
86 }
87
88 void frame(double simulationTime=USE_REFERENCE_TIME) {
89 getViewer()->frame(simulationTime);
90 }
91 };
92
94 class VRECKO_EXPORT Viewer : public ViewerBase
95 {
96 private:
97 int m_stereo;
98 osg::ref_ptr<osgViewer::Viewer> viewer;
99
100 public:
101 Viewer(int stereoMode);
102
103 virtual osgViewer::ViewerBase* getViewer() { return viewer; }
104
106 virtual void addView(osgViewer::View* view) {
107 throw new std::exception("Not supported in this viewer.");
108 }
109
110 virtual void setDisplaySettings(osg::DisplaySettings* ds1, osg::DisplaySettings* ds2 = NULL) {
111 viewer->setDisplaySettings(ds1);
112 }
113
114 virtual void setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f) {
115 viewer->setFusionDistance(mode, value);
116 }
117
118 virtual void addEventHandler(osgGA::GUIEventHandler* eventHandler) {
119 viewer->addEventHandler(eventHandler);
120 }
121
122 virtual void setSceneData(osg::Node* node) {
123 viewer->setSceneData(node);
124 }
125
126 virtual void camera_setViewMatrixAsLookAt(const osg::Vec3d& eye,const osg::Vec3d& center,const osg::Vec3d& up) {
127 viewer->getCamera()->setViewMatrixAsLookAt(eye, center, up);
128 }
129
130 virtual void setLight(osg::Light* light) {
131 viewer->setLight(light);
132 }
133
134 virtual osg::Light* getLight() {
135 return viewer->getLight();
136 }
137
138 virtual osg::Camera* getCamera(int screenNum = 0) {
139 return viewer->getCamera();
140 }
141
142 virtual int getStereoMode() {
143 return m_stereo;
144 }
145
146 };
147
149
150 class VRECKO_EXPORT CompositeViewer : public ViewerBase
151 {
152 private:
153 int m_stereo;
154 osg::ref_ptr<osgViewer::CompositeViewer> viewer;
155
156 public:
157 CompositeViewer(int stereoMode);
158
159 virtual osgViewer::ViewerBase* getViewer() { return viewer; }
160
161 virtual void addView(osgViewer::View* view) {
162 viewer->addView(view);
163 }
164
165 virtual void setDisplaySettings(osg::DisplaySettings* ds1, osg::DisplaySettings* ds2 = NULL) {
166 viewer->getView(0)->setDisplaySettings(ds1);
167 if(m_stereo == 5 && ds2) viewer->getView(1)->setDisplaySettings(ds2);
168 }
169
170 virtual void setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f) {
171 viewer->getView(0)->setFusionDistance(mode, value);
172 if(m_stereo == 5) viewer->getView(1)->setFusionDistance(mode, value);
173 }
174
175 virtual void addEventHandler(osgGA::GUIEventHandler* eventHandler) {
176 viewer->getView(0)->addEventHandler(eventHandler);
177 }
178
179 virtual void setSceneData(osg::Node* node) {
180 viewer->getView(0)->setSceneData(node);
181 if(m_stereo == 5) viewer->getView(1)->setSceneData(node);
182 }
183
184 virtual void camera_setViewMatrixAsLookAt(const osg::Vec3d& eye,const osg::Vec3d& center,const osg::Vec3d& up) {
185 viewer->getView(0)->getCamera()->setViewMatrixAsLookAt(eye, center, up);
186 if(m_stereo == 5) viewer->getView(1)->getCamera()->setViewMatrixAsLookAt(eye, center, up);
187 }
188
189 virtual void setLight(osg::Light* light) {
190 viewer->getView(0)->setLight(light);
191 if(m_stereo == 5) viewer->getView(1)->setLight(light);
192 }
193
194 virtual osg::Light* getLight() {
195 return viewer->getView(0)->getLight();
196 }
197
198 virtual osg::Camera* getCamera(int screenNum = 0) {
199 return viewer->getView(screenNum)->getCamera();
200 }
201
202 virtual int getStereoMode() {
203 return m_stereo;
204 }
205
206 };
207
208 };
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VirtualCouplingEffectorFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VirtualCouplingEffectorFilter.h
Go to the documentation of this file.
1 #ifndef VIRTUAL_COUPLING_EFFECTOR_FILTER_H
2 #define VIRTUAL_COUPLING_EFFECTOR_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10
11 //#define PHANTOM_VCEF_MAX_DERIVATIVE 2
12 // 0: position
13 // 1st: velocity
14 // 2nd: acceleration
15
16
17 /* PHANToM filter to perform the virtual coupling -> drag the phantom handle to the object */
18 class VirtualCouplingEffectorFilter : public PHANToMFilter {
19 public:
20 VirtualCouplingEffectorFilter();
21
22 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
23 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
24 protected:
25
26 template<class _Type, int _MaxData> class OldDataStorage {
27 public:
28 _Type data[_MaxData];
29 // 0 = current
30 // 1 = 1-frame old data
31 // 2 = 2-frames old data
32 // etc.
33
34 inline void getMaxData() { return _MaxData; }
35
36 inline _Type &getValue() { return data[0]; }
37 inline const _Type &getValue() const { return data[0]; }
38
39 inline _Type getVelocity() { return (data[0] - data[1]); }
40 inline _Type getAccel() { return (data[0] - 2 * data[1] + data[2]); }
41
42 inline void fillWithSingleValue(_Type& newData) {
43 for (int i = 0; i < _MaxData; ++i)
44 data[i] = newData;
45 }
46
47 inline void addNew(_Type& newData) {
48 for (int i = _MaxData - 1; i > 1; --i)
49 data[i] = data[i - 1];
50 data[0] = newData;
51 }
52
53
54 };
55
56 template<class _Type, int _MaxData> class StorageWithDamping : public OldDataStorage<_Type, _MaxData> {
57 public:
58 StorageWithDamping(float _springDamping, float _velocityDamping) : OldDataStorage() {
59 springDamping = _springDamping;
60 velocityDamping = _velocityDamping;
61 }
62
63 void dampAndStoreValue(_Type *value) {
64 *value = (*value * springDamping + getVelocity() * velocityDamping);
65 addNew(*value);
66 }
67
68 void setDamping(float newSpringDamping, float newVelocityDamping) {
69 springDamping = newSpringDamping;
70 velocityDamping = newVelocityDamping;
71 }
72
73 float getSpringDamping() { return springDamping; }
74 float getVelocityDamping() { return velocityDamping; }
75
76 protected:
77 float springDamping;
78 float velocityDamping;
79 };
80
81 unsigned int realPhantomPosObjectID; // secondary (optional) object, that shows the real phantom position
82
83 DynamicArray<osg::Matrix> originalScales; // original scaling of the held objects (TODO - probably not necessary, remove)
84 // osg::Matrix cachedPreTransform; // scaling and center shifting at once - TODO
85
86 osg::Vec3 offsetFromCenter; // Offset of the phantom reference point
87
88 OldDataStorage<osg::Vec3, 4> lastRealPos;
89 OldDataStorage<osg::Vec3, 4> lastVirtualPos;
90 // RealPos and VirtualPos are shifted from the "Phantom".pPosition by [offsetFromCenter] * "rotation"
91
92 OldDataStorage<osg::Quat, 4> lastRealRot;
93 OldDataStorage<osg::Quat, 4> lastVirtualRot;
94
95 void inverseQuadraticScale(osg::Vec3 *valueToRescale, float inputMaxLength, float outputMaxLength);
96 // Recalculates linear interpolation to inverse quadratic
97 // If the input vector is longer than [inputMaxLength], it will be shortened.
98 // If it is smaller, it will be rescaled.
99
100 void linearScale(osg::Vec3 *valueToRescale, float inputMaxLength, float outputMaxLength);
101 // If the input vector is longer than [inputMaxLength], it will be shortened.
102 // If it is smaller, it will be rescaled.
103
104 void forceScale(osg::Vec3 *valueToRescale, float inputMaxLength, float outputMaxLength);
105
106 float virtToolWeight;
107
108 // dynamic parameters
109 osg::Vec3 virtToolLinMomentum; // (kg?) . (distance unit) / SECOND (not millisecond)
110 osg::Vec3 virtToolAngMomentum;
111
112 // fixed parameters, can be changed in the config file
113 float fSpringLinDamping;
114 float fSpringLinFriction;
115 float fSpringAngDamping;
116 float fSpringAngFriction;
117
118 float fDragLinForceTool; // Translational force that drags to tool to the user pos
119 float fDragLinDistTool; // ... and distance
120 float fDragLinForceUser; // Translational force that drags user to the tool pos
121 float fDragLinDistUser; // ... and distance
122
123 float fDragAngForceTool; // Rotational force force that drags to tool to the user pos
124 float fDragAngForceUser; // Translational force that drags user to the tool pos
125
126 float fMaxLinDistTool; // maximum distance, that the virtual tool is allowed to move in one haptic frame
127 // (1/1000 s OR LONGER if the processing takes too long)
128 float fMaxAngDistTool; // maximum distance, that the virtual tool is allowed to rotate in one haptic frame
129
130 float fDistanceToReset; // Distance between two (haptic) frames that will cause the forces to be reseted
131
132 float fNoMoveTime; // [in s] Time after Reset in which the moved object remain motionless and the user is dragged to its position
133
134 bool bPauseIfColStructsAreNotReady;
135 // If the virtual coupling detects that the held object(s) contain structures that are still being created (in different thread)
136 // the simulation will fix the held object(s) and disable any movement.
137 // NOTE: It only supports certain collision structures, support for other structures have to be added into this Ability.
138
139 // Used for sticky materials
140 int computeCollisionThroughtLastXFrame;
141 int collisionsFrontPosition;
142 bool collisionsFront[5000];
143 bool collisionsOccuredLastXFrame(int X);
144 void pushCollisionToFront(bool value);
145
146 bool bStickyObjectsEnabled;
147 float fStickyObjectsDistance;
148
149 // Used for damping
150 struct dampingValues {
151 osg::Vec3f force;
152 float fRotAngle;
153 };
154
155 int iDampingValuesX;
156 int iDampingEndValuesX;
157 dampingValues dampingField[5000];
158 int iDampingValuesFieldPosition;
159 void getAvarageLastXDampingValues(osg::Vec3f *force, float *angle);
160 float getAvarageLastXDampingValuesRotAngle(int count);
161 void pushValuesToDamping(osg::Vec3f force, float fRotAngle);
162
163 };
164
165 }
166
167 #endif
168
169 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/VisualizeFilter.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
VisualizeFilter.h
Go to the documentation of this file.
1 #ifndef VISUALIZE_FILTER_H
2 #define VISUALIZE_FILTER_H
3
4 #include <vreckoDP/PHANToM/PHANToM_Device.h>
5
6 #ifdef COMPILE_PHANTOM_DEVICE
7
8 namespace vreckoDP_PHANToM {
9
10 /* PHANToM filter to display the force/torque. */
11 class VisualizeFilter : public PHANToMFilter {
12 public:
13 VisualizeFilter();
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters);
16
17 virtual void apply(PHANToMSTATE &pState, osg::Vec3 &force, osg::Vec3 &torque);
18
19 protected:
20 unsigned long forceObject, torqueObject;
21
22 float forceScale, torqueScale;
23
24 void updateObjectTransform(unsigned long objectID, osg::Vec3 &start, osg::Vec3 &dir, float fScale);
25 };
26
27 }
28
29 #endif
30
31
32 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/VoxelGrid_Object_Data.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
VoxelGrid_Object_Data.h
Go to the documentation of this file.
1 #ifndef VOXELGRID_OBJECT_DATA_H
2 #define VOXELGRID_OBJECT_DATA_H
3
4 #include "GeometryLoaderBase.h"
5 #include <vrecko/Ability.h>
6 #include <vrecko/SP_ObjectInterface.h>
7
8 #include <helpers/BufFile.h>
9
10 #include <osg/BoundingBox>
11
12
13 namespace APSpacePartitioning {
14
15 class VoxelGrid_Object_Data: public vrecko::SP_Object_DataInterface, public GeometryLoaderBase, public vrecko::Ability {
16 public:
17 VoxelGrid_Object_Data();
18 ~VoxelGrid_Object_Data();
19
20 virtual void preInitialize();
21 virtual void postInitialize();
22 virtual void update();
23
24 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node);
25
26 virtual bool isHierarchyCreated() { return bGridCreated && bGridFilled; }
27
28 virtual bool createHierarchy(void);
29
30 inline unsigned long getXDFDim() { return dFXDim; }
31 inline unsigned long getYDFDim() { return dFYDim; }
32 inline unsigned long getZDFDim() { return dFZDim; }
33
34
35 inline osg::BoundingBox& getBBoxDF() {return bboxDF;}
36 inline float getDistanceFieldValue(int x, int y, int z){
37 if (x >= dFXDim || y >= dFYDim || z >= dFZDim || x < 0 || y < 0 || z < 0) {
38 return 0;
39 }
40 return distanceField[ x * (dFYDim * dFZDim) + y * dFZDim + z];
41 }
42
43 inline int getDistanceFieldValueEffect(unsigned long x, unsigned long y, unsigned long z, int level){
44 if (getDistanceFieldValue( x, y, z) > level){
45 return 0;
46 } else {
47 return 1;
48 }
49 }
50
51 inline float getDistanceTempFieldValue(int x, int y, int z){
52 if (x >= dFXDim || y >= dFYDim || z >= dFZDim || x < 0 || y < 0 || z < 0) {
53 return 0;
54 }
55 return distanceFieldTemp[ x * (dFYDim * dFZDim) + y * dFZDim + z];
56 }
57
58 inline float getRequestedCellSize() {return dRequestedCellLength;}
59 inline osg::Vec3& getBBoxDFSize() {return bboxSizeDF;}
60
61 void VoxelGrid_Object_Data::increaseVoxelValueCollisions(int x, int y, int z){
62 distanceFieldCollsions[ x * (dFYDim * dFZDim) + y * dFZDim + z]++;
63 }
64 void VoxelGrid_Object_Data::setVoxelValueCollisions(int x, int y, int z, int value){
65 distanceFieldCollsions[ x * (dFYDim * dFZDim) + y * dFZDim + z] = value;
66 }
67 int VoxelGrid_Object_Data::getCollisions(int x, int y, int z){
68 return distanceFieldCollsions[ x * (dFYDim * dFZDim) + y * dFZDim + z];
69 }
70
71 osg::Vec4f returnColorOfVoxel(int x, int y, int z){
72 // function : (4 + log(x*10))/6.5 where x = 0 to 1 (viz. wolfram alpha)
73 // gathering information around is necessary to suppress the hich frequencies in a voxel grid of collisions.
74 // high frequencies generated unreadable represenation for human (high frequencies were visible and mid range lost)
75 /*
76 * used grid for filtration :
77 *
78 * |1|1|1| |1|1|1| |1|1|1|
79 * |1|1|1| |1|4|1| |1|1|1|
80 * |1|1|1| |1|1|1| |1|1|1|
81 */
82 float collisionsDetected = 0;
83 if (x > 0 && y > 0 && z > 0 && x < dFXDim && y < dFYDim && z < dFZDim){
84 int c = 0;
85 for (int xT = x-1; xT < x+2; xT++){
86 for (int yT = y-1; yT < y+2; yT++){
87 for (int zT = z-1; zT < z+2; zT++){
88 c += getCollisions(xT,yT,zT);
89 }
90 }
91 }
92 c += getCollisions(x,y,z) * 3;
93 collisionsDetected = (float)c / 30.0;
94 } else {
95 collisionsDetected = (float)getCollisions(x,y,z);
96 }
97
98 float percentage = collisionsDetected/(float)iMaxCollisionsFromLoadedVoxel;
99 float red = (4.0 + log(percentage*10))/6.5;
100 float green = 1.0 - red;
101 return osg::Vec4f(red,green,0.0,0.5);
102 };
103
104 protected:
105 bool bGridCreated;
106 bool bGridFilled;
107 bool bCollisionCreated;
108
109 int iMaxCollisionsFromLoadedVoxel;
110
111 int dFXDim, dFYDim, dFZDim; // dimesntion of the distanceField
112
113 double dRequestedCellLength;
114 int iDilatation;
115 int iDilatationStrategy; // can be 0, 1, 2 - meaning 6, 18 or 26-around
116 int iGenType; // 0 is Dilatation. 1 is Precise
117
118 float* distanceField;
119 float* distanceFieldTemp;
120 int* distanceFieldCollsions;
121
122 osg::BoundingBox bboxDF;
123 osg::Vec3f bboxSizeDF;
124
125 bool createDistanceFieldGrid();
126 void destroyDistanceFieldGrid();
127
128 bool createDistanceFieldTempGrid();
129 void destroyDistanceFieldTempGrid();
130
131 bool createDistanceFieldGridCollision();
132 void destroyDistanceFieldGridCollision();
133
134 inline void setDistanceFieldValue(unsigned long x, unsigned long y, unsigned long z, float newValue){
135 distanceField[ x * (dFYDim * dFZDim) + y * dFZDim + z] = newValue;
136 }
137
138 inline void setDistanceFieldTempValue(unsigned long x, unsigned long y, unsigned long z, float newValue){
139 distanceFieldTemp[ x * (dFYDim * dFZDim) + y * dFZDim + z] = newValue;
140 }
141
142 bool constructCacheDataName(char *pOutDataName);
143
144 bool loadFromCache(const char *pModelFileName);
145 bool saveToCache(const char *pModelFileName);
146
147 bool loadGridFromFile(vrecko::BufferedFile *bfile);
148 bool saveGridToFile(vrecko::BufferedFileWrite *bfile);
149
150 // storing a collisions
151 bool saveCollisions();
152 bool saveCollisionsToFile(vrecko::BufferedFileWrite *bfile);
153
154 bool loadCollisions();
155 bool loadCollisionsFromFile(vrecko::BufferedFile *bfile);
156
157 bool updateDataInformation(char* data, char* file);
158
159 };
160
161 } // namespace APSpacePartitioning
162
163
164 #endif
165
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/behindO/WIM.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • behindO
WIM.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vrecko/EnvironmentObject.h>
3
4 #include <osg/MatrixTransform>
5
6 #include <esg/OSGAdapter.h>
7
8 using namespace vrecko;
9
10 namespace behindO {
11
12 class WIM: public Ability {
13 public:
14 WIM();
15 ~WIM() {};
16
17 // ------ BaseClass functions ------------------------
19 void processEvent(const std::string &input_name, void *value);
20 // ---------------------------------------------------
21
22 void postInitialize(void);
23 void update(void);
24
25 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
26 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
27
28 std::string getAcceptableMessages(void) {return "boolean|state";} // true/false, 0/1
29 Message *getMessage(void) {return NULL;}
30
31 protected:
32 int control, zooming;
33 typedef struct {
34 EnvironmentObject *copy;
35 osg::Vec3 last_position;
36 osg::Matrix last_rotation;
37 } ObjectCopy;
38
39 std::map<EnvironmentObject *, ObjectCopy> copies_map;
40 EnvironmentObject *border_object, *copies_root;
41 osg::MatrixTransform *visual_border_object;
42 osg::Vec3 WIM_size, WIM_center;
43 float WIM_scale, origin_WIM_scale;
44 bool WIM_commit; // 0=during/1=after operation
45
46 bool avatar_copy, work_area_selection;
47 esg::BVH *border_bvh;
48 Ability *pAvatarManipulator;
49
50 EnvironmentObject *owner, *pAvatarCopy, *pAvatarOwner;
51 };
52
53 }
54
55 //$Id: WIM.h 1 2010-10-27 12:01:29Z xbezdeka $
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallAdd.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
WallAdd.h
Go to the documentation of this file.
1 #ifndef _WALL_ADD_H
2 #define _WALL_ADD_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8
9 // tool that adds new wall into room
10 class WallAdd : public Tool {
11 public:
12 WallAdd() {type=WALLADD;}
13 virtual ~WallAdd() {}
14
15 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
16 if (findXMLNode(pParametersNode, "Name")) {
17 ReaderWriter::getStringValue(name, pParametersNode, "Name");
18 } else {
19 name = "WallAdd";
20 }
21 return true;
22 }
23
24
25 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray) {
26 insideWalls = false;
27 movingPoint = NULL;
28 startingPoint = NULL;
29
30 if (curWall != NULL) {
31 bool splitted = false;
32 WG_Wall* newWall;
33
34 osg::Vec2 iPoint = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z());
35 osg::Vec2 iNormal = curWall->getVector(WG_Q_POINT);
36
37 osg::Vec2 curNormal(-curWall->getVector(WG_Q_POINT).y(),curWall->getVector(WG_Q_POINT).x());
38
39 osg::Vec2 crossPoint;
40 WG_Geometry::getCrossingPoint(crossPoint, curWall->getPoint(WG_Q_POINT)->getPosition(), curNormal, iPoint, iNormal, false);
41
42 WG_Point* Q = curWall->getPoint(WG_Q_POINT);
43 WG_Point* R = curWall->getPoint(WG_R_POINT);
44
45 osg::Vec2 qVec = Q->getPosition() - crossPoint;
46 osg::Vec2 rVec = R->getPosition() - crossPoint;
47
48 osg::Vec2 mpVector;
49
50 if ((qVec.length() < RE_MIN_LENGTH) && (rVec.length() < RE_MIN_LENGTH)) {
51 if (qVec.length() < rVec.length()) {
52 startingPoint = Q;
53 }
54 else {
55 startingPoint = R;
56 }
57 }
58 else if (qVec.length() < RE_MIN_LENGTH) {
59 startingPoint = Q;
60 }
61 else if (rVec.length() < RE_MIN_LENGTH) {
62 startingPoint = R;
63 }
64 else {
65 bool isWall;
66 osg::Vec2 dummy, normalI, mpNormal;
67 mpVector = -osg::Vec2(curWall->getFaceNormal(type).x(), curWall->getFaceNormal(type).z());
68 mpVector.normalize();
69 mpVector *= (RE_MIN_LENGTH*1.5);
70 mpNormal = osg::Vec2(-mpVector.y(), mpVector.x());
71
72 for (unsigned int i=0; i<walls->size(); i++) {
73 normalI = osg::Vec2(-walls->at(i)->getVector(WG_Q_POINT).y(),walls->at(i)->getVector(WG_Q_POINT).x());
74 if (WG_Geometry::getCrossingPoint(dummy,crossPoint, mpNormal, walls->at(i)->getPoint(WG_Q_POINT)->getPosition(), normalI, true)) {
75 isWall = true;
76 break;
77 }
78 }
79
80 if (isWall) {
81 logger.warningLog("Cannot add wall. Not enough space for a new one. (A wall obstructs.)");
82 return;
83 }
84
85 startingPoint = new WG_Point(crossPoint);
86 startingPoint->setId(points->size());
87 points->push_back(startingPoint);
88 curWall->setPoint(startingPoint, WG_R_POINT);
89 newWall = new WG_Wall(startingPoint, R);
90 newWall->setId(walls->size());
91 walls->push_back(newWall);
92 splitted = true;
93 }
94
95 if (startingPoint->getWalls()->size() > 1) {
96 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCW;
97 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCCW;
98 startingPoint->getWallNeighbours(curWall, wallCW, wallCCW);
99
100 float angle = 0;
101 float angle2 = 0;
102 osg::Vec2 vector(0.0,0.0);
103 if (!splitted) {
104 osg::Vec2 vec1, vec2;
105 if (((type == WG_Q_POINT) && (Q == startingPoint))
106 || ((type == WG_R_POINT) && (R == startingPoint))) {
107 vec1 = wallCCW.first->getVector(wallCCW.second);
108 vec1.normalize();
109 vec2 = curWall->getVector(type);
110 vec2.normalize();
111 mpVector = vec1 + vec2;
112 angle2 = curWall->getAngle(type);
113 angle = wallCCW.first->getAngle(wallCCW.second);
114 vector = curWall->getVector(type);
115 }
116 else {
117 vec1 = wallCW.first->getVector(wallCW.second);
118 vec1.normalize();
119 vec2 = curWall->getVector((type == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT));
120 vec2.normalize();
121 mpVector = vec1 + vec2;
122 angle2 = wallCW.first->getAngle(wallCW.second);
123 angle = curWall->getAngle((type == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT));
124 vector = wallCW.first->getVector(wallCW.second);
125 }
126 }
127
128 float angleCompare = angle - angle2;
129 if (angleCompare < 0)
130 angleCompare += 360;
131 if (angleCompare > 180.0f)
132 mpVector *= (-1);
133
134 mpVector.normalize();
135 mpVector *= (RE_MIN_LENGTH*1.5);
136
137 float mpAngle = WG_Geometry::getAngle(mpVector);
138 angleCompare = angle - mpAngle;
139 if (angleCompare < 0)
140 angleCompare += 360;
141 if ((!splitted) && (angleCompare < RE_MIN_ANGLE(mpVector.length(), vector.length()))) {
142 logger.warningLog("Cannot add wall. Not enough space for a new one. (Too small angle.)");
143 }
144 else {
145 movingPoint = new WG_Point(startingPoint->getPosition() + mpVector);
146 movingPoint->setId(points->size());
147 points->push_back(movingPoint);
148 newWall = new WG_Wall(startingPoint, movingPoint);
149 newWall->setId(walls->size());
150 walls->push_back(newWall);
151 }
152 }
153 else {
154 mpVector = osg::Vec2(intersection->getLocalIntersectNormal().x(), intersection->getLocalIntersectNormal().z());
155 mpVector.normalize();
156 mpVector *= (RE_MIN_LENGTH*1.5);
157 movingPoint = new WG_Point(startingPoint->getPosition() + mpVector);
158 movingPoint->setId(points->size());
159 points->push_back(movingPoint);
160 newWall = new WG_Wall(startingPoint, movingPoint);
161 newWall->setId(walls->size());
162 walls->push_back(newWall);
163 }
164 }
165
166 setDirty(true);
167 }
168
169 private:
170 WG_Point* startingPoint;
171 WG_Point* movingPoint;
172 bool insideWalls;
173 };
174
175 }
176
177 #endif
178
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallGeometry.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
WallGeometry.h
Go to the documentation of this file.
1 #ifndef _WALL_GEOMETRY_H
2 #define _WALL_GEOMETRY_H
3
4 #include <vrecko/ReaderWriter.h>
5
6 #include <vrecko/Ability.h>
7 #include <vrecko/Scene.h>
8 #include <vrecko/EnvironmentObject.h>
9 #include <vrecko/Logger.h>
10
11 #include <helpers/XercesXMLUtils.h>
12 #include <xercesc/parsers/XercesDOMParser.hpp>
13 #include <xercesc/dom/DOM.hpp>
14 #include <xercesc/sax/HandlerBase.hpp>
15 #include <xercesc/util/XMLString.hpp>
16 #include <xercesc/util/PlatformUtils.hpp>
17
18 #include <osgDB/ReadFile>
19
20 #include <osg/Geometry>
21 #include <osg/Geode>
22 #include <osg/StateSet>
23 #include <osg/Material>
24 #include <osg/CullFace>
25 #include <osg/LightModel>
26 #include <vrecko/Scene.h>
27
28 #include <sstream>
29 #include <vector>
30 #include <set>
31 #include <map>
32
33 #include "Geometry.h"
34 #include "Tool.h"
35
36 using namespace vrecko;
37 using namespace vrecko;
38 using namespace WGeometry;
39
40 namespace APRoomEdit {
41
42 class WallGeometry: public Ability {
43 private:
44 // pointer to parent enviroment object
45 EnvironmentObject* pEOOwner;
46
47 // pointer to a geode of the room
48 osg::Geode* pOSGGeode;
49
50 // pointer to vertex array
51 osg::Vec3Array* pOSGVertexArray;
52
53 // source filename
54 string filename;
55
56 // array of walls to be drawn
57 std::vector<osg::ref_ptr<WG_Wall> > walls;
58
59 // array of points
60 std::vector<osg::ref_ptr<WG_Point> > points;
61
62 // key is the lowest index of the quad value is wall or point that contains the quad
63 // the index is returned by the LineSegmentIntersection.indexList.at(0)
64 std::map<unsigned int, WG_Wall*> wallMap;
65 std::map<unsigned int, WG_Point*> pointMap;
66
67 bool dirty;
68
69 // info for tools
70 WG_Wall* selectedWall;
71 WG_Point* selectedPoint;
72 PointType selectedType;
73
74 // creates additional quads if there are two walls connected to the point
75 void setCorner(WG_Point* P, WG_Wall* wall, WG_Vertices* vertices, PointType type, PointType opType,
76 osg::Vec3& TCWV, osg::Vec3& TCCWV, osg::Vec3& BCWV, osg::Vec3& BCCWV);
77
78 public:
79 // constructor
80 WallGeometry();
81
82 // destructor
83 virtual ~WallGeometry();
84
85 // called as the first initialization method, before loadXMLParameters
86 virtual void preInitialize();
87
88 // called as the last initialization method, after loadXMLParameters
89 virtual void postInitialize();
90
91 // loads XML parameters from given node
92 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
93
94 inline osg::Geode* getGeode() { return pOSGGeode; }
95
96 void createDefaultRoom();
97
98 void setDirty() { dirty = true; }
99
100 void draw();
101
102 WG_Wall* getWall(osgUtil::LineSegmentIntersector::Intersection* intersection) {
103 unsigned int index = intersection->indexList.at(0);
104 return (wallMap.find(index) != wallMap.end() ? wallMap[index] : NULL);
105 }
106
107 WG_Point* getPoint(osgUtil::LineSegmentIntersector::Intersection* intersection) {
108 unsigned int index = intersection->indexList.at(0);
109 WG_Wall* wall = getWall(intersection);
110 WG_Point* point = NULL;
111 osg::Vec2 vectorQ, vectorR;
112 if (wall != NULL) {
113 vectorQ = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z()) - wall->getPoint(WG_Q_POINT)->getPosition();
114 vectorR = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z()) - wall->getPoint(WG_R_POINT)->getPosition();
115 point = (vectorQ.length() < vectorR.length() ? wall->getPoint(WG_Q_POINT) : wall->getPoint(WG_R_POINT));
116 }
117 else
118 point = (pointMap.find(index) != pointMap.end() ? pointMap[index] : NULL);
119
120 return point;
121 }
122
123 void activateTool(Tool* tool, osgUtil::LineSegmentIntersector::Intersection* intersection) {
124 if ((tool == NULL) || (tool->getType() == NONE))
125 return;
126
127 selectedWall = getWall(intersection);
128 selectedPoint = getPoint(intersection);
129
130 if (selectedWall != NULL) {
131 osg::Vec2 tempVector = osg::Vec2(intersection->getLocalIntersectPoint().x(), intersection->getLocalIntersectPoint().z());
132
133 WG_Point* tempPoint = selectedWall->getPoint(WG_Q_POINT);
134 tempVector = tempVector - tempPoint->getPosition();
135
136 float angle = WG_Geometry::getAngle(tempVector);
137 angle = angle - selectedWall->getAngle(WG_Q_POINT);
138 if (angle < 0)
139 angle += 360.0f;
140
141 selectedType = (angle > 180 ? WG_R_POINT : WG_Q_POINT);
142 }
143
144 tool->init(intersection, selectedWall, selectedPoint, selectedType, pEOOwner, &walls, &points, pOSGGeode, pOSGVertexArray);
145
146 if (tool->isDirty()) {
147 setDirty();
148 tool->setDirty(false);
149 }
150 }
151
152
153 void deactivateTool(Tool* tool, osgUtil::LineSegmentIntersector::Intersection* intersection) {
154 if ((tool == NULL) || (tool->getType() == NONE))
155 return;
156
157 tool->terminate(intersection, selectedWall, selectedPoint, selectedType, pEOOwner, &walls, &points, pOSGGeode, pOSGVertexArray);
158
159 if (tool->isDirty()) {
160 setDirty();
161 tool->setDirty(false);
162 }
163 }
164
165 void updateTool(Tool* tool, osgUtil::LineSegmentIntersector::Intersection* intersection, osg::Vec3 movingVector) {
166 if ((tool == NULL) || (tool->getType() == NONE))
167 return;
168
169 tool->update(intersection, selectedWall, selectedPoint, selectedType, pEOOwner, &walls, &points, pOSGGeode, pOSGVertexArray, movingVector);
170
171 if (tool->isDirty()) {
172 setDirty();
173 tool->setDirty(false);
174 }
175 }
176 };
177
178 }
179
180 #endif
181
182
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallMovement.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
WallMovement.h
Go to the documentation of this file.
1 #ifndef _WALL_MOVEMENT_H
2 #define _WALL_MOVEMENT_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 class WallMovement : public Tool {
9 public:
10 WallMovement(void) {type=WALLMOVEMENT;}
11 virtual ~WallMovement(void) {}
12
13 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
14 if (findXMLNode(pParametersNode, "Name")) {
15 ReaderWriter::getStringValue(name, pParametersNode, "Name");
16 } else {
17 name = "WallMovement";
18 }
19 return true;
20 }
21
22
23 virtual void update(osgUtil::LineSegmentIntersector::Intersection* intersection, WG_Wall* curWall, WG_Point* curPoint, PointType type, vrecko::EnvironmentObject* pEOOwner, std::vector<osg::ref_ptr<WG_Wall> >* walls, std::vector<osg::ref_ptr<WG_Point> >* points, osg::Geode* pOSGGeode, osg::Vec3Array* pOSGVertexArray, osg::Vec3& movingVector) {
24
25 if (curWall != NULL) {
26 osg::Vec2 wallNormal = osg::Vec2(curWall->getFaceNormal(type).x(), curWall->getFaceNormal(type).z());
27 float scalar = wallNormal.x() * movingVector.x() + wallNormal.y() * movingVector.z();
28 wallNormal.normalize();
29 wallNormal *= scalar;
30
31 WG_Point* Q = curWall->getPoint(WG_Q_POINT);
32 WG_Point* R = curWall->getPoint(WG_R_POINT);
33
34 osg::Vec2 posQ = Q->getPosition() + wallNormal;
35 osg::Vec2 posR = R->getPosition() + wallNormal;
36
37
38 for (unsigned int i=0; i<walls->size(); i++) {
39 WG_Wall* wallI = walls->at(i).get();
40
41 bool skipQ = false;
42 bool skipR = false;
43 for (unsigned int j=0; j<Q->getWalls()->size(); j++) {
44 skipQ = (wallI == Q->getWalls()->at(j).first.get());
45 if (skipQ)
46 break;
47 }
48 for (unsigned int j=0; j<R->getWalls()->size(); j++) {
49 skipR = (wallI == R->getWalls()->at(j).first.get());
50 if (skipR)
51 break;
52 }
53 WG_Vertices* qV = wallI->getVertices(WG_Q_POINT);
54 WG_Vertices* rV = wallI->getVertices(WG_R_POINT);
55 if (!skipQ) {
56 bool b1 = WG_Geometry::barycentricTest(posQ,
57 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
58 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
59 osg::Vec2(rV->getBottomCCWVertex().x(), rV->getBottomCCWVertex().z()));
60 bool b2 = WG_Geometry::barycentricTest(posQ,
61 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
62 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
63 osg::Vec2(rV->getBottomCWVertex().x(), rV->getBottomCWVertex().z()));
64 if (b1 || b2)
65 return;
66 }
67 if (!skipR) {
68 bool b3 = WG_Geometry::barycentricTest(posR,
69 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
70 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
71 osg::Vec2(rV->getBottomCCWVertex().x(), rV->getBottomCCWVertex().z()));
72 bool b4 = WG_Geometry::barycentricTest(posR,
73 osg::Vec2(qV->getBottomCCWVertex().x(), qV->getBottomCCWVertex().z()),
74 osg::Vec2(qV->getBottomCWVertex().x(), qV->getBottomCWVertex().z()),
75 osg::Vec2(rV->getBottomCWVertex().x(), rV->getBottomCWVertex().z()));
76 if (b3 || b4)
77 return;
78 }
79 }
80
81
82
83 for (unsigned int k=0; k<Q->getWalls()->size(); k++) {
84 WG_Wall* wallK = Q->getWalls()->at(k).first.get();
85 PointType ptype = Q->getWalls()->at(k).second;
86 PointType opptype = (ptype == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
87
88 osg::Vec2 length = wallK->getPoint(opptype)->getPosition() - posQ;
89 if (length.length() < RE_MIN_LENGTH)
90 return;
91
92 float angleCW, angleCCW, angle, angleCompare, angleMin;
93 osg::Vec2 v;
94 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCW;
95 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCCW;
96 if (wallK->getPoint(ptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
97 angleCW = wallCW.first->getAngle(wallCW.second);
98 angleCCW = wallCCW.first->getAngle(wallCCW.second);
99 v = wallK->getPoint(opptype)->getPosition() - posQ;
100 angle = WG_Geometry::getAngle(v);
101 angleCompare = angleCCW - angle;
102 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
103 wallCCW.first->getVector(WG_Q_POINT).length());
104 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
105 return;
106 angleCompare = angle - angleCW;
107 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
108 wallCW.first->getVector(WG_Q_POINT).length());
109 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
110 return;
111 }
112
113 if (wallK->getPoint(opptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
114 angleCW = wallCW.first->getAngle(wallCW.second);
115 angleCCW = wallCCW.first->getAngle(wallCCW.second);
116 v = posQ - wallK->getPoint(opptype)->getPosition();
117 angle = WG_Geometry::getAngle(v);
118 angleCompare = angleCCW - angle;
119 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
120 wallCCW.first->getVector(WG_Q_POINT).length());
121 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
122 return;
123 angleCompare = angle - angleCW;
124 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
125 wallCW.first->getVector(WG_Q_POINT).length());
126 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
127 return;
128 }
129 }
130
131
132 for (unsigned int k=0; k<R->getWalls()->size(); k++) {
133 WG_Wall* wallK = R->getWalls()->at(k).first.get();
134 PointType ptype = R->getWalls()->at(k).second;
135 PointType opptype = (ptype == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
136
137 osg::Vec2 length = wallK->getPoint(opptype)->getPosition() - posR;
138 if (length.length() < RE_MIN_LENGTH)
139 return;
140
141 float angleCW, angleCCW, angle, angleCompare, angleMin;
142 osg::Vec2 v;
143 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCW;
144 std::pair<osg::ref_ptr<WG_Wall>, PointType> wallCCW;
145 if (wallK->getPoint(ptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
146 angleCW = wallCW.first->getAngle(wallCW.second);
147 angleCCW = wallCCW.first->getAngle(wallCCW.second);
148 v = wallK->getPoint(opptype)->getPosition() - posR;
149 angle = WG_Geometry::getAngle(v);
150 angleCompare = angleCCW - angle;
151 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
152 wallCCW.first->getVector(WG_Q_POINT).length());
153 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
154 return;
155 angleCompare = angle - angleCW;
156 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
157 wallCW.first->getVector(WG_Q_POINT).length());
158 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
159 return;
160 }
161
162 if (wallK->getPoint(opptype)->getWallNeighbours(wallK, wallCW, wallCCW)) {
163 angleCW = wallCW.first->getAngle(wallCW.second);
164 angleCCW = wallCCW.first->getAngle(wallCCW.second);
165 v = posR - wallK->getPoint(opptype)->getPosition();
166 angle = WG_Geometry::getAngle(v);
167 angleCompare = angleCCW - angle;
168 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
169 wallCCW.first->getVector(WG_Q_POINT).length());
170 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
171 return;
172 angleCompare = angle - angleCW;
173 angleMin = 5+RE_MIN_ANGLE(wallK->getVector(WG_Q_POINT).length(),
174 wallCW.first->getVector(WG_Q_POINT).length());
175 if ((angleCompare < angleMin) && (angleCompare > - angleMin))
176 return;
177 }
178 }
179
180
181 Q->setPosition(posQ);
182 R->setPosition(posR);
183 for (unsigned int l=0; l<Q->getWalls()->size(); l++) {
184 PointType typeL = (Q->getWalls()->at(l).second == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
185 WG_Wall* wallL = Q->getWalls()->at(l).first.get();
186 wallL->computeAttrVectorsAndAngles();
187 wallL->computeAttrVertices();
188 for (unsigned int m=0; m<wallL->getPoint(typeL)->getWalls()->size(); m++)
189 wallL->getPoint(typeL)->getWalls()->at(m).first->computeAttrVertices();
190 }
191 for (unsigned int l=0; l<R->getWalls()->size(); l++) {
192 PointType typeL = (R->getWalls()->at(l).second == WG_Q_POINT ? WG_R_POINT : WG_Q_POINT);
193 WG_Wall* wallL = R->getWalls()->at(l).first.get();
194 wallL->computeAttrVectorsAndAngles();
195 wallL->computeAttrVertices();
196 for (unsigned int m=0; m<wallL->getPoint(typeL)->getWalls()->size(); m++)
197 wallL->getPoint(typeL)->getWalls()->at(m).first->computeAttrVertices();
198 }
199 curWall->computeAttrVertices();
200 setDirty(true);
201 }
202 }
203
204 };
205
206 }
207
208 #endif
209
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/RoomEdit/WallRemove.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • RoomEdit
WallRemove.h
Go to the documentation of this file.
1 #ifndef _WALL_REMOVE_H
2 #define _WALL_REMOVE_H
3
4 #include "Tool.h"
5
6 namespace APRoomEdit {
7
8 class WallRemove : public Tool {
9 public:
10 WallRemove() {type = WALLREMOVE;}
11 virtual ~WallRemove() {}
12
13 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) {
14 if (findXMLNode(pParametersNode, "Name")) {
15 ReaderWriter::getStringValue(name, pParametersNode, "Name");
16 } else {
17 name = "WallRemove";
18 }
19 return true;
20 }
21
22
23 virtual void init(osgUtil::LineSegmentIntersector::Intersection* intersection,
24 WG_Wall* curWall,
25 WG_Point* curPoint,
26 PointType type,
27 vrecko::EnvironmentObject* pEOOwner,
28 std::vector<osg::ref_ptr<WG_Wall> >* walls,
29 std::vector<osg::ref_ptr<WG_Point> >* points,
30 osg::Geode* pOSGGeode,
31 osg::Vec3Array* pOSGVertexArray) {
32
33 if (curWall == NULL)
34 return;
35
36 if (walls->size() == 1) {
37 logger.warningLog("Impossible to destroy last and the only one wall.");
38 return;
39 }
40
41 WG_Point* Q = curWall->getPoint(WG_Q_POINT);
42 WG_Point* R = curWall->getPoint(WG_R_POINT);
43
44 if (Q->getWalls()->size() == 1) {
45 points->erase(points->begin()+Q->getId());
46 if (Q->getId() < R->getId())
47 R->setId(R->getId()-1);
48 }
49 else {
50 Q->removeWall(curWall);
51 }
52
53 if (R->getWalls()->size() == 1) {
54 points->erase(points->begin()+R->getId());
55 }
56 else {
57 R->removeWall(curWall);
58 }
59
60 walls->erase(walls->begin()+curWall->getId());
61
62 unsigned int i;
63 for (i=0; i<points->size(); i++) {
64 points->at(i)->setId(i);
65 }
66 for (i=0; i<walls->size(); i++) {
67 walls->at(i)->setId(i);
68 }
69
70 setDirty(true);
71 }
72 };
73
74 }
75
76 #endif
77
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Weather/Weather.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Weather
Weather.h
Go to the documentation of this file.
1 #pragma once
2 #include <vrecko\Ability.h>
3 #include <osgParticle\PrecipitationEffect>
4 #include <osg\MatrixTransform>
5 #include <vreckoAP\Export>
6 #include <iostream>
7
8 namespace APWeather
9 {
10 class AP_EXPORT Weather : public vrecko::Ability
11 {
12 public:
13 Weather();
14 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters = NULL);
15
16 bool addToScene();
17 bool removeFromScene();
18 inline osgParticle::PrecipitationEffect* getEffect() { return _effect; }
19
20 protected:
21 osg::ref_ptr<osgParticle::PrecipitationEffect> _effect;
22 osg::ref_ptr<osg::MatrixTransform> _transformNode;
23 };
24 }
25
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/Wiimote.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
Wiimote.h
Go to the documentation of this file.
1 #ifndef WIIMOTE_H
2 #define WIIMOTE_H
3
4 #include <stdio.h>
5 #include <stdlib.h>
6
7 #ifndef WIN32
8 #include <unistd.h>
9 #endif
10
11 #include <wiiuse.h>
12
13
14 #define MAX_WIIMOTES 4
15
16 #include <vrecko/IOPins.h>
17 #include <vrecko/Device.h>
18 #include <vrecko/EventDispatcher.h>
19
20 #include <osg/Vec3>
21 #include <osg/Quat>
22
23 namespace vreckoDP_base {
24
25 class DP_EXPORT Wiimote : public vrecko::Device {
26 public:
27 Wiimote();
28 ~Wiimote();
29
30 virtual int openDevice(void);
31 int closeDevice(void);
32
33 void update(void);
34
35 virtual bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode = NULL);
36 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
37
38 //void sendEvent(int currentWiimoteID, char sid, osg::Vec3 *p, osg::Quat *o);
39
40 // ---
41 void handle_event(int currentWiimoteID, struct wiimote_t* wm);
42 void handle_read(struct wiimote_t* wm, byte* data, unsigned short len);
43 void handle_ctrl_status(struct wiimote_t* wm);
44 void handle_disconnect(wiimote* wm);
45 void test(struct wiimote_t* wm, byte* data, unsigned short len);
46
47 protected:
48 static bool is_initialized;
49 bool main_wiimote;
50 unsigned int wiimoteID;
51 static bool disabled;
52 static bool check_failed;
53 static wiimote** pWiimote;
54 bool vibration;
55
56 //vrecko::EventDispatcher *pEventDispatcher;
57
58 DECLARE_INPUT(Vibration, vrecko::MessageBool);
59 DECLARE_OUTPUT(Button, vrecko::MessageString);
60 DECLARE_OUTPUT(Orientation, vrecko::MessageVec3);
61 };
62
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/World.h Source File

  • File List
  • File Members
  • include
  • vrecko
World.h
Go to the documentation of this file.
1 /***************************************************************************
2 World.h - description
3 -------------------
4 begin : Jun 2004
5 copyright : (C) 2004 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 #ifndef WORLD_H
10 #define WORLD_H
11
12
13
39 #include <vrecko/BaseClass.h>
40 #include <vrecko/vThread.h>
41 #include <vrecko/Scheduler.h>
42 #include <vrecko/Ability.h>
43 #include <vrecko/Viewer.h>
44 #include <vrecko/EventDispatcher.h>
45
46 #include <osg/Group>
47 #include <osgText/Text>
48
49
50 //---------------------------------------------------------------
51 //Shadows
52 //---------------------------------------------------------------
53 #include <osgShadow/ShadowedScene>
54 #include <osgShadow/ShadowVolume>
55 #include <osgShadow/ShadowTexture>
56 #include <osgShadow/ShadowMap>
57 #include <osgShadow/SoftShadowMap>
58 //---------------------------------------------------------------
59 //Shadows
60 //---------------------------------------------------------------
61
62 #include <vrecko/Logger.h> // at jde kdekoliv pouzivat globalni promenna [logger] (resp. vrecko::logger)
63 #include <vrecko/PersistentCache.h>
64
65
66 namespace vrecko {
67
68 class VRECKO_EXPORT Scene;
69 class VRECKO_EXPORT DeviceManager;
70 class VRECKO_EXPORT EventDispatcher;
71
72 class VRECKO_EXPORT World: public BaseClass, public osg::Group {
73 public:
74 World();
75 ~World();
76 World(const World &w);
77
78 void setViewerPtr(ViewerBase *pV);
79 ViewerBase *getViewerPtr() { return pViewer; };
80 osg::Camera *getCamera(void) {return (pViewer ? pViewer->getCamera(0) : NULL);}
81
82 //---------------------------------------------------------------
83 //Shadows
84 //---------------------------------------------------------------
85 osg::ref_ptr<osgShadow::ShadowedScene> shadowedScene;
86 osgShadow::ShadowedScene* getShadowedScenePtr() { return shadowedScene.get(); }
87 osg::LightSource* getShadowedSceneLight() { return mainLightSource.get(); }
88 //---------------------------------------------------------------
89 //Shadows
90 //---------------------------------------------------------------
91
93 void setDescription(const std::string &desc) {description = desc;}
95 inline const std::string &getDescription(void) const {return description;}
96
98 void setScenePtr(Scene *nScene);
100 Scene *getScenePtr(void) {return pScene;}
101
103 typedef struct AvatarView {
105 std::string ID;
107 BaseClass *owner;
109 osg::Vec3 eye_position;
111 osg::Vec3 look_at_center;
113 osg::Vec3 up_vector;
114 };
115
117 AvatarView *getActualAvatarView(void) {return avatar_view_vector[0];}
119 void setActualAvatarView(AvatarView *av) {avatar_view_vector.insert(avatar_view_vector.begin(), av);}
121 bool removeAvatarView(AvatarView *av);
122
124 struct AvatarEye
125 {
127 osg::Vec3 eye_offset;
129 osg::Matrix projection;
130 };
131
132 class
133 {
134 private:
135 std::vector<AvatarEye> _eyes;
136
137 public:
138 void CreateEyes(int count) { _eyes.resize(count); }
139 void DestroyEyes() { _eyes.clear(); }
140
141 int GetCount() { return _eyes.size(); }
142
143 AvatarEye *Get(int eye_index)
144 { return ((eye_index >= 0) && (eye_index < GetCount())) ? (&(_eyes[eye_index])) : 0; }
145 } AvatarEyes;
146
147
148
149
150
152 typedef enum {
153 UNKNOWN,
154 ADD_CHILD,
155 ADD_EOCHILD,
156 REMOVE_CHILD,
157 REMOVE_EOCHILD,
158 SET_STATESET,
159 DELETE_STATESET,
160 SET_TEXT
161 } SG_OPERATION_TYPE;
162
164 typedef struct {
165 osg::Node *pNode;
166 osg::Group *pGroup;
167 osg::StateSet *pStateSet;
168 osgText::Text *pText;
169 std::string text_string;
170 SG_OPERATION_TYPE type;
171 } SG_CHANGE;
172
173
174 // You can set [owner] to NULL, which means "world".
175 vrecko::Ability* createAbility(const std::string& plugin_name, const std::string& ability_name, BaseClass* _owner, const char* _overridingID = NULL);
176
177
179 void setDeviceManagerPtr(DeviceManager *ptr) {pDeviceManager = ptr;}
181 DeviceManager* getDeviceManagerPtr() {return pDeviceManager;}
182
184 void setEventDispatcherPtr(EventDispatcher *ptr) {pEventDispatcher = ptr;}
186 EventDispatcher* getEventDispatcherPtr() {return pEventDispatcher;}
187
189 void setSchedulerPtr(Scheduler *sched) {pScheduler = sched;}
191 inline Scheduler* getSchedulerPtr() {return pScheduler;}
192
193 inline PersistentCache* getPersistentCache() { return persistentCache; }
194
196 bool getTerminationFlag() {return termination_flag;}
197
199 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
200
201 // ----- LogFile functions
202 // void textLog(const char *text = "", ...);
203 void noticeLog(const char *notice = "", ...);
204 // void noticeLog(int level, const char *notice = "", ...);
205 void warningLog(const char *warning = "", ...);
206 // void warningLog(int level, const char *warning = "", ...);
207 void errorLog(const char *error = "", ...);
208 // void errorLog(int level, const char *error = "", ...);
209 void debugLog(const char *debugText = "", ...);
210 // The debugFileLog() function only writes info to the file
211 void debugFileLog(const char *debugText = "", ...);
212
213 // functions for handling abilities
215 bool addAbility(Ability *pAbility) {ability_dispatcher->addAbility(pAbility); return true;}
217 bool removeAbility(Ability *pAbility) {ability_dispatcher->removeAbility(pAbility); return true;}
218 bool removeAbility(const std::string &ability_id);
220 Ability *getAbility(const std::string &ab_id) {return ability_dispatcher->getAbility(ab_id);}
222 //Ability *getAppropriateAbility(const std::string &message_ID) {return ability_dispatcher->getAppropriateAbility(message_ID);}
224 //Ability *getAbilityWithInput(const std::string &input_name) {return ability_dispatcher->getAbilityWithInput(input_name);}
226 //Ability *getAbilityWithOutput(const std::string &output_name) {return ability_dispatcher->getAbilityWithOutput(output_name);}
228 std::map<std::string, Ability*> &getAbilityMap(void) {return ability_dispatcher->getAbilityMap();}
229
230
231
232 // Heavily used methods from EventDispatcher are inlined here, so we do not need to write "world->getEventDispatcher()->reportEvent",
233 // but just "world->reportEvent"
234 inline bool reportEvent(const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType = EXPRESS_EVENT) {
235 return getEventDispatcherPtr()->reportEvent(senderAndOutputString, pMessage, eType);
236 }
237 inline bool reportEvent(BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType = EXPRESS_EVENT) {
238 return getEventDispatcherPtr()->reportEvent(receiver_ptr, input_name, pMessage, eType);
239 }
240 inline osg::ref_ptr<VreckoMessage> request(const std::string &req_sender, VreckoMessage *pMessage) {
241 return getEventDispatcherPtr()->request(req_sender, pMessage);
242 }
243 inline osg::ref_ptr<VreckoMessage> request(BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage) {
244 return getEventDispatcherPtr()->request(receiver_ptr, request_name, pMessage);
245 }
246
247
248
249
250 inline unsigned long getFrameID() { return frameID; }
251 inline void incrementFrameID() { ++frameID; }
252
253 inline bool getShowTimeWarnings() { return bShowTimeWarnings; };
254 inline void setShowTimeWarnings(bool bNewValue) { bShowTimeWarnings = bNewValue; };
255
256 inline unsigned long getTimeWarningsTime() { return ulTimeWarningsTime; };
257 inline void setTimeWarningsTime(unsigned long ulNewValue) { ulTimeWarningsTime = ulNewValue; };
258
259 void SendTerminationNotifications() { sendNotifications(BaseClass::NOTIFICATION_PROGRAM_TERMINATION, NULL); };
260
261 /*
262 * Method saves arguments and its count from main class to be accessible for objects
263 */
264 void setArgumens(int &count, char **arguments);
265
266 /*
267 * Method returns number of arguments with which the program started
268 */
269 int getNumberOfArguments();
270
271 /*
272 * Method returns the field of arguments with which the program started
273 */
274 char ** getArguments();
275
276 protected:
278 std::string description;
280 Scene *pScene;
282 std::vector<AvatarView *> avatar_view_vector;
283
284 // ???
285 ViewerBase *viewer;
286
287 //NEW shadows and light;
288 osg::ref_ptr<osg::LightSource> mainLightSource;
289
291 AbilityDispatcher *ability_dispatcher;
292
293 // Data cache that is persistent throughout multiple app runs.
294 PersistentCache *persistentCache;
295
296 private:
297 //saved arguments from command
298 int arguments_count;
299 char **arguments;
300
301 // Pointer to the viewer
302 ViewerBase *pViewer;
303
305 DeviceManager *pDeviceManager;
306
308 EventDispatcher *pEventDispatcher;
309
311 Scheduler *pScheduler;
312
314 bool termination_flag;
315
316 // Current frame ID (will be different for each frame)
317 unsigned long frameID;
318
319 // Will display warnings like "Processing a MESSAGE took a long time (... ms)"
320 bool bShowTimeWarnings;
321 unsigned long ulTimeWarningsTime; // in ms. An event will need to take at least this time for the warning to be displayed.
322 };
323
324 VRECKO_EXPORT bool initXML();
325 VRECKO_EXPORT bool doneXML();
326
327
331 VRECKO_EXPORT const std::string& getSafeSceneFile(const std::string &sceneFile);
332
334 VRECKO_EXPORT unsigned long getNumSceneFiles();
335
337 VRECKO_EXPORT const std::string& getSafeSceneFile(unsigned long index);
338
341 VRECKO_EXPORT const std::string& getSafeDefaultSceneFile();
342
345 VRECKO_EXPORT void setDefaultSceneFile(const std::string &newDefaultSceneFile);
346
347
348 }
349
350 #endif
351
352
353 namespace vrecko {
354 extern VRECKO_EXPORT World *world;
355 };
356
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/WorldBuilder.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
WorldBuilder.h
Go to the documentation of this file.
1 #include "ModelManager.h"
2 #include "Cache.h"
3
4 using namespace vrecko;
5
6 namespace ArtificialWorld
7 {
9 class WorldBuilder: public Ability
10 {
11 public:
12 WorldBuilder();
13 ~WorldBuilder(){};
14
15 void initialize(void) {};
16 void update(void) {};
17
19 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
21 void postInitialize(void);
23 unsigned long GetRootObjectID(void){return rootEOID;};
24
25 private:
27 string worldfile;
29 bool useTimeCache, useDistanceCache, usePreloading;
31 unsigned long cacheTime, cacheDistance, cacheUpdateTime;
32 //World::AvatarView* av;
34 unsigned long rootEOID;
36 osg::Vec3 defaultAvatarPosition; // If the values are FLT_MAX, the position is invalid
37
38 bool bRootXMLLocked;
39
43 DECLARE_REQUEST_INPUT(GetAndLockRootXMLNode, MessageVoid, MessageXMLNode);
45 DECLARE_REQUEST_INPUT(UnlockRootXMLNode, MessageVoid, MessageVoid);
46 };
47 }
48
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/helpers/XercesXMLUtils.h Source File

  • File List
  • File Members
  • include
  • helpers
XercesXMLUtils.h
Go to the documentation of this file.
1 #ifndef XERCESXMLUTILS_H
2 #define XERCESXMLUTILS_H
3
4 #include <xercesc/dom/DOM.hpp>
5 #include <iostream>
6
7 #ifndef HELPERS_IMP_EXP
8 #ifdef VRECKO_LIBRARY
9 #define HELPERS_IMP_EXP __declspec(dllexport)
10 #else
11 #define HELPERS_IMP_EXP __declspec(dllimport)
12 #endif
13 #endif
14
15
16 HELPERS_IMP_EXP XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* findXMLNode (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* rootNode, const char* nodeName, bool bSearchSubTrees = false);
17 // Doesn't search the [rootNode]!
18 HELPERS_IMP_EXP char* getNodeTextTrans (XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* node);
19 // It's the callers responsibility to release the pointer (use XMLString::release()).
20
21
22 // ---------------------------------------------------------------------------
23 // Class from XERCES examples:
24 // ----
25 // This is a simple class that lets us do easy (though not terribly efficient)
26 // trancoding of XMLCh data to local code page for display.
27 // ---------------------------------------------------------------------------
28 class HELPERS_IMP_EXP StrX
29 {
30 public :
31 StrX(const XMLCh* const toTranscode) {
32 // Call the private transcoding method
33 fLocalForm = XERCES_CPP_NAMESPACE_QUALIFIER XMLString::transcode(toTranscode);
34 }
35
36 ~StrX() {
37 XERCES_CPP_NAMESPACE_QUALIFIER XMLString::release(&fLocalForm);
38 }
39
40 // Getter methods
41 const char* localForm() const {
42 return fLocalForm;
43 }
44
45 private :
46 // -----------------------------------------------------------------------
47 // Private data members
48 //
49 // fLocalForm
50 // This is the local code page form of the string.
51 // -----------------------------------------------------------------------
52 char* fLocalForm;
53 };
54
55 #define XercesToStr(str) StrX(str).localForm()
56
57 inline XERCES_STD_QUALIFIER ostream& operator<<(XERCES_STD_QUALIFIER ostream& target, const StrX& toDump)
58 {
59 target << toDump.localForm();
60 return target;
61 }
62
63
64 #endif
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstract0lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstract0lsystem.h
Go to the documentation of this file.
1 #ifndef ABSTRACT0LSYSTEM_H_
2 #define ABSTRACT0LSYSTEM_H_
3
4 #include "lsystem.h"
5
6 namespace AP_LSystem {
10 class Abstract0LSystem : public LSystem
11 {
12 protected:
19 virtual void processPredecessor( Rule & rule, string * str, string::iterator & pos);
20
27 virtual void processRuleSuccessor( Rule & rule, string * str, string::iterator & pos);
28
35 virtual void processHomomorphismSuccessor( Rule & rule, string * str, string::iterator & pos);
36 public:
37 Abstract0LSystem( AbstractFile * );
38 Abstract0LSystem( const Abstract0LSystem & );
39
40 };
41 }
42 #endif // ABSTRACT0LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractfile.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractfile.h
Go to the documentation of this file.
1 #ifndef ABSTRACTFILE_H_
2 #define ABSTRACTFILE_H_
3
4 #include <string>
5 #include <vector>
6 #include <map>
7 #include "configuration.h"
8 #include "lsystemexception.h"
9
10 using std::string;
11
12 namespace AP_LSystem {
16 class AbstractFile
17 {
18 protected:
19 unsigned int m_Type;
20 string m_Name;
21 string m_Axiom;
22
23 std::vector<string> m_Rules;
24 std::vector<string> m_Homomorphisms;
25 std::vector<string> m_Subsytems;
26
41 void addType( std::string & type )
42 {
43 if(type == "0L")
44 {
45 m_Type |= LS_0L;
46 }
47 else if(type == "1LL")
48 {
49 m_Type |= LS_1LL;
50 }
51 else if(type == "1LR")
52 {
53 m_Type |= LS_1LR;
54 }
55 else if(type == "2L")
56 {
57 m_Type |= LS_2L;
58 }
59 else if(type == "IL")
60 {
61 m_Type |= LS_IL;
62 }
63 else if(type == "DETERMINISTIC")
64 {
65 m_Type |= LS_DETERMINISTIC;
66 }
67 else if(type == "STOCHASTIC")
68 {
69 m_Type |= LS_STOCHASTIC;
70 }
71 else if(type == "PARAMETRIC")
72 {
73 m_Type |= LS_PARAMETRIC;
74 }
75 else
76 {
77 throw ParsingException("unknown lsystem type");
78 }
79 }
80 public:
84 AbstractFile(): m_Type(0){}
85
90 virtual void open( std::string & filename) = 0;
91
97 void substitute(std::map<string, string> & pairs)
98 {
99 unsigned int i;
100 std::vector<string>::iterator rule;
101 std::map<std::string,std::string>::iterator subst;
102
103 // substitute occurences in m_Axiom
104 for(subst = pairs.begin(); subst != pairs.end(); subst++)
105 {
106 i=0;
107 while((i = m_Axiom.find(subst->first,i))&&(i != std::string::npos))
108 {
109 m_Axiom.replace(i,subst->first.length(),subst->second);
110 i += subst->second.length();
111 }
112 }
113
114 // substitute occurences in m_Rules
115 for(rule = m_Rules.begin();rule != m_Rules.end(); rule++)
116 {
117 for(subst = pairs.begin(); subst != pairs.end(); subst++)
118 {
119 i=0;
120 while((i = rule->find(subst->first,i))&&(i != std::string::npos))
121 {
122 rule->replace(i,subst->first.length(),subst->second);
123 i += subst->second.length();
124 }
125 }
126 }
127
128 for(rule = m_Homomorphisms.begin();rule != m_Homomorphisms.end(); rule++)
129 {
130 for(subst = pairs.begin(); subst != pairs.end(); subst++)
131 {
132 i=0;
133 while((i = rule->find(subst->first,i))&&(i != std::string::npos))
134 {
135 rule->replace(i,subst->first.length(),subst->second);
136 i += subst->second.length();
137 }
138 }
139 }
140 }
141
146 virtual std::vector<string> * getHomomorphisms()
147 {
148 return &m_Homomorphisms;
149 }
150
155 virtual std::vector<string> * getRules()
156 {
157 return &m_Rules;
158 }
159
164 virtual std::vector<string> * getSubsystems()
165 {
166 return &m_Subsytems;
167 }
168
173 std::string & getAxiom()
174 {
175 return m_Axiom;
176 }
177
182 unsigned int type()
183 {
184 return m_Type;
185 }
186
191 std::string & name()
192 {
193 return m_Name;
194 }
195 };
196 }
197
198 #endif // ABSTRACTFILE_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractgenerator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractgenerator.h
Go to the documentation of this file.
1 #ifndef ABSTRACTGENERATOR_H_
2 #define ABSTRACTGENERATOR_H_
3
4 #include <string>
5 #include <boost/shared_ptr.hpp>
6 #include "parseablestring.h"
7 #include "abstractlsystem.h"
8
9
10 namespace AP_LSystem {
11
17 class AbstractGenerator
18 {
19 protected:
20 ParseableString * m_Word;
21 boost::shared_ptr<AbstractLSystem> m_MainLSystem;
22
23 public:
27 AbstractGenerator( void ) : m_Word(NULL) {}
28
32 AbstractGenerator( const AbstractGenerator & c )
33 {
34 m_Word = new ParseableString(*c.m_Word);
35 m_MainLSystem = c.m_MainLSystem->clone();
36 }
37
41 AbstractGenerator & operator=( const AbstractGenerator & c )
42 {
43 m_Word = new ParseableString(*c.m_Word);
44 m_MainLSystem = c.m_MainLSystem->clone();
45
46 return *this;
47 }
48
52 ~AbstractGenerator(void)
53 {
54 if(m_Word)
55 delete m_Word;
56 }
57
62 virtual void loadFile( std::string & filename ) = 0;
63
67 virtual void nextIteration() = 0;
68
73 virtual ParseableString * getWord() = 0;
74
78 virtual void saveWordToFile( std::string & );
79
83 virtual void loadWordFromFile( std::string & );
84
91 static boost::shared_ptr<AbstractLSystem> createLSystem( AbstractFile * file );
92 };
93 }
94
95 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractinterpret.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractinterpret.h
Go to the documentation of this file.
1 #ifndef ABSTRACTINTERPRET_H_
2 #define ABSTRACTINTERPRET_H_
3
4 #include <vector>
5
6 #include "configuration.h"
7 #include "lsgeode.h"
8 #include "parseablestring.h"
9 #include "turtlestack.h"
10
11 using std::vector;
12 using std::string;
13
14 namespace AP_LSystem {
15 class AbstractInterpret
16 {
17 protected:
21 vector< LSGeode *> m_Geodes;
22 osg::Group * m_Owner;
23 TurtleStack m_Turtles;
24 public:
25 AbstractInterpret( )
26 {
27 m_Owner = NULL;
28 Randomizer::init();
29 }
30
37 int switchGeode( std::vector<Parameter> & p )
38 {
39 switch( p.size() )
40 {
41 case 0:
42 m_Turtles.pop();
43 break;
44 case 1:
45 if (p[0].type != Parameter::LS_UBYTE)
46 return LS_ERR_PAR_BADTYPE;
47 m_Turtles.push( m_Geodes[*(static_cast<unsigned char*>(p[0].value))] );
48 break;
49 default:
50 return LS_ERR_PAR_INVALIDCOUNT;
51 }
52
53 return LS_OK;
54 }
55
59 void createGeodes()
60 {
61 unsigned int count = Configuration::get()->getLSystemCount();
62 LSGeode * pGeode;
63 for( unsigned int i = 0; i < count; i++)
64 {
65 pGeode = new LSGeode( i );
66
67 if( m_Owner )
68 {
69 m_Owner->addChild( (osg::Group *)pGeode );
70 }
71 else
72 {
73 vrecko::logger.warningLog( "No parent node. LSGeode not added!" );
74 }
75
76 m_Geodes.push_back( pGeode );
77 }
78 vrecko::logger.debugLog( "%d LSGeodes successfuly created and binded with scene graph.", count );
79 }
80
86 static const char * errorText( int error )
87 {
88 switch( error )
89 {
90 case LS_OK:
91 return "OK. No error.";
92 case LS_NOTIMPLEMENTED:
93 return "Method is not defined";
94 case LS_ERR_PAR_BADTYPE:
95 return "Bad type of module parameter";
96 case LS_ERR_PAR_INVALIDCOUNT:
97 return "Invalid number of parameters";
98 case LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE:
99 return "Negative value of step distance";
100 case LS_ERR_STACK_UNKNOWN_TURTLE_TYPE:
101 return "Unknown turtle type";
102 case LS_ERR_STACK_NULL_LSGEODE:
103 return "NULL geode";
104 default:
105 return "Unknown error code";
106 }
107 }
108
114 virtual int parse( ParseableString * word ) = 0;
115 };
116 }
117
118 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractklsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractklsystem.h
Go to the documentation of this file.
1 #ifndef ABSTRACTKLSYSTEM_H_
2 #define ABSTRACTKLSYSTEM_H_
3
4 #include "lsystem.h"
5
6 namespace AP_LSystem {
7
11 class AbstractkLSystem : public LSystem
12 {
13 protected:
14
15 public:
19 AbstractkLSystem( AbstractFile * );
20 };
21 }
22 #endif // ABSTRACTKLSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractlsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractlsystem.h
Go to the documentation of this file.
1 #ifndef ABSTRACTLSYSTEM_H_
2 #define ABSTRACTLSYSTEM_H_
3
4 #include "fparser/fparser.hh"
5 #include "longstring.h"
6 #include "abstractfile.h"
7 #include "configuration.h"
8
9
10 namespace AP_LSystem {
11 class LongString;
12
17 class AbstractLSystem
18 {
19 protected:
20 std::string m_Name;
21 unsigned int m_Iteration;
22
26 virtual void addRule( std::string * ) = 0;
27
31 virtual void addHomomorphism( std::string * ) = 0;
32
36 virtual void setAxiom( std::string & ) = 0;
37 public:
38 AbstractLSystem(): m_Name(""), m_Iteration(0) {}
39 AbstractLSystem( const AbstractLSystem & c):m_Name(c.m_Name), m_Iteration(c.m_Iteration) {}
40
44 virtual boost::shared_ptr<AbstractLSystem> clone() const = 0;
45
49 AbstractLSystem & operator=(const AbstractLSystem & c )
50 {
51 m_Name = c.m_Name;
52 m_Iteration = c.m_Iteration;
53 return *this;
54 }
55
60 virtual bool nextIteration() = 0;
61
66 virtual LongString * translate( ) = 0;
67
72 virtual void loadFromFile ( AbstractFile * file ) = 0;
73
78 unsigned int getIteration() const {return m_Iteration;}
79 };
80 }
81
82 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/abstractturtle.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
abstractturtle.h
Go to the documentation of this file.
1 #ifndef ABSTRACTTURTLE_H_
2 #define ABSTRACTTURTLE_H_
3
4 #include "utils.h"
5 #include "lsgeode.h"
6 #include "randomizer.h"
7
8 namespace AP_LSystem {
9
14 enum InterpretErrorCodes
15 {
16 LS_OK,
17 LS_NOTIMPLEMENTED,
18 LS_ERR_PAR_BADTYPE,
19 LS_ERR_PAR_INVALIDCOUNT,
20 LS_ERR_DRAWFORWARD_NEGATIVEDISTANCE,
21 LS_ERR_STACK_UNKNOWN_TURTLE_TYPE,
22 LS_ERR_STACK_NULL_LSGEODE,
23 };
24
25 const osg::Vec3d HeadVec(0.0,1.0,0.0);
26 const osg::Vec3d UpVec(1.0,0.0,0.0);
27 const osg::Vec3d LeftVec(0.0,0.0,1.0);
28 const osg::Vec3d Center(0.0,0.0,0.0);
29
30 const osg::Vec4d White(1.0,1.0,1.0,1.0);
31
35 class AbstractTurtle
36 {
37 protected:
38 TurtleProperties properties;
39 LSGeode * geode;
40
41 public:
42 //****************************************************************
43 //** OTHER **
44 //****************************************************************
49 virtual int initialize() { return 0;}
50
55 virtual int finalize() { return 0;}
56
62 virtual int resetValues() { return 0;} // TODO
63
68 inline TurtleProperties & getProperties()
69 {
70 return properties;
71 }
72
77 virtual void setProperties( TurtleProperties p )
78 {
79 properties = p;
80 }
81
87 virtual void inheritProperties( TurtleProperties p )
88 {
89 // inherit matrix
90 properties.matrix = p.matrix;
91 }
92
98 inline void bindGeode( LSGeode * geode )
99 {
100 this->geode = geode;
101 }
102
107 inline LSGeode * getGeode( )
108 {
109 return geode;
110 }
111
116 inline osg::Matrixd getMatrix()
117 {
118 return properties.matrix;
119 }
120
121 //****************************************************************
122 //** DEBUG **
123 //****************************************************************
124
130 virtual void drawFrame( osg::Matrixd & matrix, osg::Vec4d * color = NULL ) = 0;
131
138 virtual void drawVector( const osg::Vec3d & vector, osg::Matrixd & matrix, osg::Vec4d & color)
139 {
140 double s = properties.debugGeometryScale;
141 double l = vector.length();
142 osg::Cylinder * cylinder = new osg::Cylinder(vector * s * (l/2.0f) * matrix,s * 0.01f,s * l);
143 osg::Cone * cone = new osg::Cone(vector * s * ( l + 0.03f ) * matrix, s * 0.03f,s * 0.15f);
144
145 osg::Matrixd m = osg::Matrixd::rotate( LeftVec, vector ) * matrix;
146 cylinder->setRotation( m.getRotate() );
147 cone->setRotation( m.getRotate() );
148
149 osg::ShapeDrawable * shape;
150 shape = new osg::ShapeDrawable(cylinder);
151 shape->setColor( color );
152 geode->addDrawable( shape );
153
154 shape = new osg::ShapeDrawable(cone);
155 // shape->setColor( color );
156 geode->addDrawable( shape );
157 }
158
159 //****************************************************************
160 //** ROTATION **
161 //****************************************************************
167 inline double toRad( double angle )
168 {
169 if( properties.flags & TurtleProperties::DEGREES_TO_RADIANS )
170 return osg::DegreesToRadians( angle );
171 else
172 return angle;
173 }
174
180 inline double rand( double angle )
181 {
182 if( properties.angleVariance )
183 angle *= Randomizer::get( properties.angleVariance );
184 return angle;
185 }
186
194 virtual int turnLeft(std::vector<Parameter> & p) = 0;
195
203 virtual int turnRight(std::vector<Parameter> & p) = 0;
204
212 virtual int pitchDown(std::vector<Parameter> & p) = 0;
213
221 virtual int pitchUp(std::vector<Parameter> & p) = 0;
222
230 virtual int rollLeft(std::vector<Parameter> & p) = 0;
231
239 virtual int rollRight(std::vector<Parameter> & p) = 0;
240
245 virtual int turnArround() = 0;
246
252 virtual int rollArround() = 0;
253
258 virtual int rollUntilHorizontal() = 0;
259
265 virtual int randomTurnPitchRoll(std::vector<Parameter>& p)= 0;
266
267 //****************************************************************
268 //** CHANGE PROPERTIES **
269 //****************************************************************
277 virtual int multiplyLength(std::vector<Parameter> & p) = 0;
278
286 virtual int multiplyRadius(std::vector<Parameter> & p) = 0;
287
295 virtual int multiplyAngle(std::vector<Parameter> & p) = 0;
296
304 virtual int multiplyTropismElasticity(std::vector<Parameter> & p)= 0;
305
313 virtual int multiplyGravitropismElasticity(std::vector<Parameter> & p)= 0;
314
315 //****************************************************************
316 //** MOVEMENT **
317 //****************************************************************
325 virtual int drawForward(std::vector<Parameter> & p) = 0;
326
331 virtual int drawForwardHalf() = 0;
332
340 virtual int moveForward(std::vector<Parameter> & p) = 0;
341
346 virtual int moveForwardHalf() = 0;
347
348 };
349 }
350
351 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/apps/vreckoApp/precompiled.h Source File

  • File List
  • File Members
  • src
  • apps
  • vreckoApp
precompiled.h
Go to the documentation of this file.
1 //OSG headers
2 #include <osg/Material>
3 #include <osg/BlendFunc>
4 #include <osg/ShapeDrawable>
5 #include <osg/io_utils>
6 #include <osg/State>
7 #include <osg/Geometry>
8 #include <osg/PrimitiveSet>
9 #include <osgViewer/ViewerEventHandlers>
10 #include <osgViewer/api/Win32/GraphicsWindowWin32>
11 #include <osgText/Text3D>
12 #include <osgUtil/SmoothingVisitor>
13 #include <osg/ClipNode>
14 #include <osgDB/ReadFile>
15
16 //VRECKO header
17 #include <vrecko/World.h>
18 #include <vrecko/Viewer.h>
19 #include <vrecko/DeviceManager.h>
20 #include <vrecko/EventDispatcher.h>
21 #include <vrecko/ReaderWriter.h>
22 #include <vreckoDP/base/KeyboardMouse.h>
23 #include <vrecko/EnvironmentObject.h>
24 #include <vrecko/Scene.h>
25 #include <base/SystemInfo.h>
26
27
28 #ifndef WIN32
29 #include <errno.h>
30 #endif
31
32 // Mutex for loading section
33 #include <vrecko/vThread.h>
34
35 #include "LoadingConsole.h"
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/arm.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
arm.h
Go to the documentation of this file.
1 /***************************************************
2 * - - - - - - - IMMERSION CORP. - - - - - - - *
3 * *
4 * Platform-independent software series *
5 * Copyright (c) 1993 *
6 ***************************************************
7 * ARM.H | SDK1-2a | January 1996
8 *
9 * Immersion Corp. Software Developer's Kit
10 * Definitions and prototypes for the Immersion Corp. MicroScribe
11 * Not for use with the Probe or Personal Digitizer
12 * Requires HCI firmware version MSCR1-1C or later
13 */
14
15 #ifndef arm_h
16 #define arm_h
17
18 #include "classes.h"
19 #include "hci.h"
20
21 /*-----------*/
22 /* Constants */
23 /*-----------*/
24
25 #define NUM_DOF 6
26
27 /* # linkage points that can be calc'd from only 3 joint angles */
28 #define QUICK_3DOF_POINTS 4
29 #define STD_3DOF_POINTS 4
30
31 /* # discrete positions of table rotation (option included with some models) */
32 #define NUM_TABLE_POS 4
33
34 /* # of bytes in HCI parameter block, plus extra room */
35 #define PARAM_BLOCK_SIZE 40
36 #define EXT_PARAM_BLOCK_SIZE 10
37
38 #ifndef PI
39 #define PI 3.1415926535898
40 #endif
41
42 #define RIGHT_PEDAL 1
43 #define LEFT_PEDAL 2
44 #define BOTH_PEDALS 3
45
46 /*------------*/
47 /* Data Types */
48 /*------------*/
49
50 /* Datatypes for physical quantities:
51 * Future implementations may have a different implementation
52 * of these types
53 */
54
55 typedef float length;
56 typedef float angle;
57 typedef float ratio;
58 typedef float matrix_4[4][4];
59
60 /* General 3D spatial coordinate data type */
61 typedef struct
62 {
63 length x;
64 length y;
65 length z;
66 } length_3D;
67
68 /* General 3D angular coordinate data type */
69 typedef struct
70 {
71 angle x;
72 angle y;
73 angle z;
74 } angle_3D;
75
76
77 /* Strings as enumerated types.
78 * Variables of these types will point to one of several global
79 * string constants. This means you can compare these variables
80 * to the global string pointers, just as you would compare a regular
81 * enumerated type to a set of enumerated constants. You can also
82 * directly print these labels, since they are actually strings.
83 */
84 typedef char* length_units;
85 typedef char* angle_units;
86 typedef char* angle_format;
87
88 /* Constants for length_units variables */
89 extern char INCHES[];
90 extern char MM[];
91
92 /* Constants for angle_units variables */
93 extern char DEGREES[];
94 extern char RADIANS[];
95
96 /* Constants for angle_format variables */
97 extern char XYZ_FIXED[];
98 extern char ZYX_FIXED[];
99 extern char YXZ_FIXED[];
100 extern char ZYX_EULER[];
101 extern char XYZ_EULER[];
102 extern char ZXY_EULER[];
103
104
105 /* Record containing all Arm data
106 * Declare one of these structs for each Arm in use.
107 * Each arm_rec must be init'ed with arm_init() before use.
108 * Example references: (assuming 'arm' is declared as a arm_rec)
109 * arm.stylus_tip.x - x coord of stylus tip (stylus is last joint of arm)
110 * arm.stylus_dir.y - the y-axis angle of stylus orientation
111 * arm.joint_deg[ELBOW] - joint angle #2 (elbow) in degrees
112 */
113 class Arm
114 {
115 private:
116 /*--------------------------------------
117 * Fields for direct use by programmers:
118 * These fields will be maintained and used consistently in future releases
119 * If a field's units are not specified, then they are user-settable
120 * as inches/mm or radians/degrees
121 */
122 /* Fundamental 6DOF quantities */
123 length_3D stylus_tip; /* Coordinates of stylus tip */
124 angle_3D stylus_dir; /* Direction (roll,pitch,yaw) of stylus */
125
126 /* Transformation matrix representing stylus 6DOF coordinates
127 * 4-by-4 matrix, arm.T[0][0] through arm.T[3][3] */
128 matrix_4 T;
129
130 /* Series of linkage endpoints */
131 length_3D endpoint [NUM_DOF]; /* also includes stylus tip */
132
133 /* Joint angles */
134 angle joint_rad [NUM_DOF]; /* radians */
135 angle joint_deg [NUM_DOF]; /* degrees */
136
137
138 /*------------------------------
139 * Units and orientation format:
140 * READ-ONLY. Use functions provided to set these.
141 */
142 /* Unit conversion and data format specifiers: */
143 length_units len_units; /* inches/mm for xyz coordinates */
144 angle_units ang_units; /* radians/degrees for stylus angles */
145 angle_format ang_format; /* xyz_fixed/zyx_fixed ... for stylus angles */
146
147
148 /*-----------------------------------------------
149 * Fields describing internal physical structure:
150 * These may change with refinements to the Arm and calibration
151 * techniques.
152 */
153 length D[NUM_DOF]; /* Offsets between joint axes */
154 length A[NUM_DOF]; /* Offsets between joint axes */
155 angle ALPHA[NUM_DOF]; /* Skew angles between joint axes */
156
157 angle BETA; /* the beta angle in T23 */
158
159
160 /*----------------------------
161 * Internal working variables:
162 * These are used internally for efficient calculation and are subject to
163 * change.
164 */
165 /* Pre-computed conversion factors */
166 ratio JOINT_RADIANS_FACTOR[NUM_DOF]; /* Factors to multiply by
167 encoder counts in order to get angles in radians */
168 ratio JOINT_DEGREES_FACTOR[NUM_DOF]; /* Factors to multiply by
169 encoder counts in order to get angles in degrees */
170
171 /* Intermediate matrix products */
172 matrix_4 M[NUM_DOF];
173
174 /* Trigonometric quantities: */
175 ratio cs[NUM_DOF]; /* cosines of all angles */
176 ratio sn[NUM_DOF]; /* sines of all angles */
177 ratio csALPHA[NUM_DOF]; /* cs & sn of ALPHA const's */
178 ratio snALPHA[NUM_DOF];
179
180 /*---------------------------
181 * Internal status variables:
182 * Do not access directly. Use functions provided to manipulate these.
183 */
184 /* Fields requested in subsequent reports */
185 int timer_report; /* Flag telling whether to report timer */
186 int anlg_reports; /* # of analog values to report */
187
188 /* Number of points needed in next endpoint calculation */
189 int num_points;
190
191 /* Calculation function to execute after getting next packet */
192 // void (*packet_calc_fn)();
193 char packet_calc_fn;
194
195 /*----------------
196 * Low-level data:
197 */
198 byte param_block[PARAM_BLOCK_SIZE];
199 int p_block_size;
200
201 byte ext_param_block[EXT_PARAM_BLOCK_SIZE];
202 int ext_p_block_size;
203
204 float pt2ptdist; /* distance between points in AutoPlotPoint() */
205 float lastX, lastY, lastZ; /* last point taken */
206
207 float D5Point; /* standard stylus length with standard point tip */
208
209 public:
210 Hci hci;
211
212 /*---------------*/
213 /* Home Position */
214 /*---------------*/
215 arm_result homePos();
216
217 /*---------------------*/
218 /* Essential Functions */
219 /*---------------------*/
220
221 length_3D getStylusTip();
222 angle_3D getStylusDir();
223 float getT(int, int);
224 int getButt();
225
226 /* Initialization required once for each arm_rec */
227 void init();
228
229 /* Communications */
230 arm_result connect(const char* port);
231 void disconnect();
232
233 /* Point Gathering Functions for Digitizing
234 All use 'foreground' arm_stylus_3DOF_update() function */
235 /*int GetPoint();
236 int AutoPlotPoint(float DistanceSetting);
237 void AutoPlotPointUndo(float newX, float newY, float newZ);*/
238
239 /* Tip Change Functions for Standard Point Tip, Standard Ball Tip, or
240 Custom Tip */
241 /*void PointTip();
242 void BallTip();
243 void CustomTip(float delta);*/
244
245 /* Getting data using simplest 'foreground' method
246 * (Host waits idly for response to come back) */
247 /* Stylus coordinates */
248 arm_result stylus6DOFupdate();
249 arm_result stylus3DOFupdate();
250 /* Joint angles ONLY */
251 arm_result joint_update3();
252 arm_result joint_update6();
253 /* All Arm data */
254 arm_result full_update();
255
256
257 /*------------------------------*/
258 /* More advanced data reporting */
259 /*------------------------------*/
260
261 /* Getting data using 'background' method
262 * Host can do other processing while waiting for response */
263 /* Checking for incoming 'background' data */
264 arm_result checkBckg();
265 /* Stylus coordinates */
266 void stylus6DOFbckg();
267 void stylus3DOFbckg();
268 /* Joint angles ONLY */
269 void jointBckg3();
270 void jointBckg6();
271 /* All Arm data */
272 void fullBckg();
273
274
275 /* Getting data using 'motion-sensing' method
276 * Data is automatically reported whenever the Arm moves sufficiently
277 * or a button is pressed. */
278 /* Checking for incoming 'motion-sensing' data */
279 arm_result check_motion();
280 /* Canceling motion-sensing mode */
281 void end_motion();
282 /* Stylus coordinates */
283 void stylus6DOFmotion(int motion_thresh,
284 int packet_delay, int btns_active);
285 void stylus3DOFmotion(int motion_thresh,
286 int packet_delay, int btns_active);
287 /* Joint angles ONLY */
288 /*void joint_motion3(int motion_thresh,
289 int packet_delay, int btns_active);
290 void joint_motion6(int motion_thresh,
291 int packet_delay, int btns_active);*/
292 /* All Arm data */
293 /*void full_motion(int motion_thresh,
294 int packet_delay, int btns_active);*/
295
296
297
298 /*---------------------------*/
299 /* Setting Modes and Options */
300 /*---------------------------*/
301
302 /* Selecting units & data formats
303 * Units default to inches & degrees, unless these functions are used */
304 /*void arm_length_units(length_units units);
305 void arm_angle_units(angle_units units);
306 void arm_angle_format(angle_format format);*/
307
308 /* Requesting timer & analog data
309 * Default is not to report timer or analog data,
310 * unless these functions are used */
311 /*void arm_report_timer();
312 void arm_skip_timer();
313 void arm_report_analog(int analog_reports);
314 void arm_skip_analog();*/
315
316
317 void installSimple();
318
319 /*-------------*/
320 /* Calculation */
321 /*-------------*/
322 void calcStylus6DOF();
323 void calcStylus3DOF();
324 void calcTrig();
325 void calcJoints();
326 void calcFull();
327 void calcNothing();
328
329
330 /*---------------------*/
331 /* Calculation Helpers */
332 /*---------------------*/
333 void calcT();
334 void calcM();
335 void calcStylusDir();
336 void mul4x4(matrix_4 M1, matrix_4 M2, matrix_4 X);
337 void identity4x4(matrix_4 M);
338 void assign4x4(matrix_4 to, matrix_4 from);
339
340
341 /*-----------------*/
342 /* Parameter Block */
343 /*-----------------*/
344 arm_result convertParams();
345 arm_result convertExtParams();
346 int paramsDH0_5();
347 void calcParams();
348
349
350
351
352 /*-------------------------------------*/
353 /* Low-level functions used internally */
354 /*-------------------------------------*/
355
356 arm_result getConstants();
357 void startMotion(int num_encoders, int motion_thresh,
358 int packet_delay, int btns_active);
359 };
360
361 /*-------------------------------*/
362 /* Simple example error handlers */
363 /*-------------------------------*/
364 arm_result simple_NO_HCI(arm_result condition);
365 arm_result simple_CANT_BEGIN(arm_result condition);
366 arm_result simple_CANT_OPEN_PORT(arm_result condition);
367 arm_result simple_TIMED_OUT(arm_result condition);
368 arm_result simple_BAD_PORT(arm_result condition);
369 arm_result simple_BAD_PACKET(arm_result condition);
370
371
372 /*-------------------------*/
373 /* Macros & Easy reference */
374 /*-------------------------*/
375
376 /* Joint angle references
377 * Use these in any ...[NUM_DOF] array to refer to a specific joint */
378 #define BASE 0
379 #define SHOULDER 1
380 #define ELBOW 2
381 #define FOREARM 3
382 #define WRIST 4
383 #define STYLUS 5
384
385
386 #endif /* arm_h */
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/awHelper.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
awHelper.h
Go to the documentation of this file.
1 #ifndef AWHELPER_H
2 #define AWHELPER_H
3
4 #pragma warning(disable:4482)
5 // V celem projektu je pouzite nestandardni rozsireni, ktere pak haze tuto hlasku:
6 // warning C4482: nonstandard extension used: enum 'ArtificialWorld::AnimationLoopType' used in qualified name
7
8 //#define AW_DEBUG_ONLY(anything) {anything;}
9 #define AW_DEBUG_ONLY(anything) {}
10
11 #endif
12
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/base/precompiled.h Source File

  • File List
  • File Members
  • src
  • base
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <vrecko/BaseClass.h>
12 #include <vrecko/Ability.h>
13 #include <vrecko/EnvironmentObject.h>
14 #include <vrecko/EventDispatcher.h>
15 #include <vrecko/Scene.h>
16 #include <vrecko/World.h>
17 #include <vrecko/Logger.h>
18
19 #include <vrecko/ReaderWriter.h>
20
21 #include <osg/Geode>
22 #include <osg/Geometry>
23 #include <osg/Material>
24
25 #include <osgText/Text>
26
27 #include <esg/Definitions.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
AABoundingBox Member List

This is the complete list of members for AABoundingBox, including all inherited members.

halfside | AABoundingBox
max | AABoundingBox
min | AABoundingBox
radius | AABoundingBox
side | AABoundingBox
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_CableEditor
  • Cable
AP_CableEditor::Cable Member List

This is the complete list of members for AP_CableEditor::Cable, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addControlPoint(osg::Vec3f position) | AP_CableEditor::Cable | inline
addControlPoint(unsigned int position, osg::Vec3f point) | AP_CableEditor::Cable |
addControlPointBetweenLine(osg::Vec3f position) | AP_CableEditor::Cable |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
basePlaneRotation | AP_CableEditor::Cable | protected
Cable() | AP_CableEditor::Cable |
cableColor | AP_CableEditor::Cable | protected
cableControlLine | AP_CableEditor::Cable | protected
cableID | AP_CableEditor::Cable | protected
cableRadius | AP_CableEditor::Cable | protected
clean(void) | vrecko::Ability | inlinevirtual
clearSpheres() | AP_CableEditor::Cable | protected
computeRMF(osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals) | AP_CableEditor::Cable |
controlPoints | AP_CableEditor::Cable | protected
controlPointsChange | AP_CableEditor::Cable | protected
controlSpheres | AP_CableEditor::Cable | protected
ControlSpheresColor() | AP_CableEditor::Cable | inline
controlSpheresColor | AP_CableEditor::Cable | protected
controlSpheresRadiusAdjust | AP_CableEditor::Cable | protected
controlVectors | AP_CableEditor::Cable | protected
createSphere(osg::Vec3f center, float radius=0.25) | AP_CableEditor::Cable | inline
createSphere(osg::Vec3f center, osg::Vec4f color, float radius=0.25) | AP_CableEditor::Cable |
createSpheres() | AP_CableEditor::Cable | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCableColor() | AP_CableEditor::Cable | inline
getCableID() | AP_CableEditor::Cable | inline
getCableWrapperNode() | AP_CableEditor::Cable | inline
getControlPoints() | AP_CableEditor::Cable | inline
getControlSpheresRadiusAdjust() | AP_CableEditor::Cable | inline
getEoWrapper() | AP_CableEditor::Cable | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getIntepolatedPoints() | AP_CableEditor::Cable | inline
getInterpolatedPoint(osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, double t=0.5) const | AP_CableEditor::Cable |
getInterpolation(unsigned int *type, unsigned int *num) | AP_CableEditor::Cable | inline
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRadius() | AP_CableEditor::Cable | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getShape() | AP_CableEditor::Cable | inline
getShapeRotate() | AP_CableEditor::Cable | inline
getUpdate() | AP_CableEditor::Cable | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
interpolate() | AP_CableEditor::Cable |
interpolateCatIterate(osg::ref_ptr< osg::Vec3Array > inputPoints, unsigned int numIterations) const | AP_CableEditor::Cable |
interpolateCatPerSegment(osg::ref_ptr< osg::Vec3Array > inputPoints, unsigned int pointsPerSegment) const | AP_CableEditor::Cable |
interpolatedPoints | AP_CableEditor::Cable | protected
interpolationsNum | AP_CableEditor::Cable | protected
interpolationType | AP_CableEditor::Cable | protected
isUpdated(void) | vrecko::Ability |
isUpdateState | AP_CableEditor::Cable | protected
lastWrapperTransformation | AP_CableEditor::Cable | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | AP_CableEditor::Cable | virtual
pOwner | vrecko::Ability | protected
preInitialize() | AP_CableEditor::Cable | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | AP_CableEditor::Cable | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCableColor(osg::Vec4f color) | AP_CableEditor::Cable | inline
setCableID(string ID) | AP_CableEditor::Cable | inline
setControlPoints(osg::ref_ptr< osg::Vec3Array > points) | AP_CableEditor::Cable | inline
setControlSpheresColor(osg::Vec4f color) | AP_CableEditor::Cable | inline
setControlSpheresRadiusAdjust(float radius) | AP_CableEditor::Cable | inline
setEoWrapper(EnvironmentObject *wrapper) | AP_CableEditor::Cable | inline
setID(const char *pID) | vrecko::Ability |
setInterpolation(unsigned int type, unsigned int num) | AP_CableEditor::Cable | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setRadius(float radius) | AP_CableEditor::Cable | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setShape(osg::ref_ptr< osg::Vec3Array > points) | AP_CableEditor::Cable | inline
setShapeRotate(float angle) | AP_CableEditor::Cable | inline
setUpdate(bool state) | AP_CableEditor::Cable |
shapePoints | AP_CableEditor::Cable | protected
thisBinormals | AP_CableEditor::Cable | protected
thisEoWrapper | AP_CableEditor::Cable | protected
thisNormals | AP_CableEditor::Cable | protected
thisTangents | AP_CableEditor::Cable | protected
transformVectors(osg::Vec3Array *vectors, osg::Vec3f point, osg::Vec3f tangent, osg::Vec3f normal, osg::Vec3f binormal, float scale=1) | AP_CableEditor::Cable |
update() | AP_CableEditor::Cable | virtual
updateControlPoints() | AP_CableEditor::Cable | protected
updateControlSpheresRadius() | AP_CableEditor::Cable |
updated | vrecko::Ability | protected
updateSpheresPosition() | AP_CableEditor::Cable | protected
visualizeVectors(osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals) | AP_CableEditor::Cable |
wrap(osg::Vec3Array *shapeVectors, osg::Vec3Array *points, osg::Vec3Array *tangents, osg::Vec3Array *normals, osg::Vec3Array *binormals, float scale=1, unsigned int wrapFrom=1, unsigned int wrapNum=0) | AP_CableEditor::Cable |
wrapCable() | AP_CableEditor::Cable |
wrapperGeode | AP_CableEditor::Cable | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Cable() | AP_CableEditor::Cable | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_CableEditor
  • CableEditor
AP_CableEditor::CableEditor Member List

This is the complete list of members for AP_CableEditor::CableEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | AP_CableEditor::CableEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
CableEditor() | AP_CableEditor::CableEditor |
cableID | AP_CableEditor::CableEditor | protected
cablePointers | AP_CableEditor::CableEditor | protected
cablesFile | AP_CableEditor::CableEditor | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createCircle(unsigned int steps) | AP_CableEditor::CableEditor |
createEoAbility(bool addToWorld=true) | AP_CableEditor::CableEditor | protected
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | AP_CableEditor::CableEditor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | AP_CableEditor::CableEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCableAbility(unsigned int EoId, bool notify=false) | AP_CableEditor::CableEditor | protected
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
Init() | AP_CableEditor::CableEditor | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | AP_CableEditor::CableEditor | protectedvirtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
insertIndex | AP_CableEditor::CableEditor | protected
isActive() | vrecko::ControllableAbility | virtual
isAddingPointState | AP_CableEditor::CableEditor | protected
isCable(unsigned int pEoID) | AP_CableEditor::CableEditor |
isDeletingSphereState | AP_CableEditor::CableEditor | protected
isInsertBetweenState | AP_CableEditor::CableEditor | protected
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isSelectedCable | AP_CableEditor::CableEditor | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
loadCables() | AP_CableEditor::CableEditor | protected
loadedShapes | AP_CableEditor::CableEditor | protected
loadShapes() | AP_CableEditor::CableEditor | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
makeMenu() | AP_CableEditor::CableEditor | protected
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | AP_CableEditor::CableEditor | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | AP_CableEditor::CableEditor | protectedvirtual
newPoint | AP_CableEditor::CableEditor | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objFileDest | AP_CableEditor::CableEditor | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
predefinedShapes | AP_CableEditor::CableEditor | protected
preInit() | AP_CableEditor::CableEditor | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | AP_CableEditor::CableEditor | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | AP_CableEditor::CableEditor | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveCable(std::ofstream &outputFile, Cable *cable) | AP_CableEditor::CableEditor | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectedCableBaseRadius | AP_CableEditor::CableEditor | protected
selectedCableId | AP_CableEditor::CableEditor | protected
selectedCablePtr | AP_CableEditor::CableEditor | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shapesFile | AP_CableEditor::CableEditor | protected
showMenu() | vrecko::ControllableAbility | protectedvirtual
sphereBetweenPoints | AP_CableEditor::CableEditor | protected
update(void) | AP_CableEditor::CableEditor | virtual
updated | vrecko::Ability | protected
writeInfo(std::ofstream &outputFile) | AP_CableEditor::CableEditor | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CableEditor() | AP_CableEditor::CableEditor | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Abstract0LSystem
AP_LSystem::Abstract0LSystem Member List

This is the complete list of members for AP_LSystem::Abstract0LSystem, including all inherited members.

Abstract0LSystem(AbstractFile *) | AP_LSystem::Abstract0LSystem |
Abstract0LSystem(const Abstract0LSystem &) | AP_LSystem::Abstract0LSystem |
AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const =0 | AP_LSystem::AbstractLSystem | pure virtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processPredecessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processRuleSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::LSystem | protectedvirtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractFile
AP_LSystem::AbstractFile Member List

This is the complete list of members for AP_LSystem::AbstractFile, including all inherited members.

AbstractFile() | AP_LSystem::AbstractFile | inline
addType(std::string &type) | AP_LSystem::AbstractFile | inlineprotected
getAxiom() | AP_LSystem::AbstractFile | inline
getHomomorphisms() | AP_LSystem::AbstractFile | inlinevirtual
getRules() | AP_LSystem::AbstractFile | inlinevirtual
getSubsystems() | AP_LSystem::AbstractFile | inlinevirtual
m_Axiom | AP_LSystem::AbstractFile | protected
m_Homomorphisms | AP_LSystem::AbstractFile | protected
m_Name | AP_LSystem::AbstractFile | protected
m_Rules | AP_LSystem::AbstractFile | protected
m_Subsytems | AP_LSystem::AbstractFile | protected
m_Type | AP_LSystem::AbstractFile | protected
name() | AP_LSystem::AbstractFile | inline
open(std::string &filename)=0 | AP_LSystem::AbstractFile | pure virtual
substitute(std::map< string, string > &pairs) | AP_LSystem::AbstractFile | inline
type() | AP_LSystem::AbstractFile | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractGenerator
AP_LSystem::AbstractGenerator Member List

This is the complete list of members for AP_LSystem::AbstractGenerator, including all inherited members.

AbstractGenerator(void) | AP_LSystem::AbstractGenerator | inline
AbstractGenerator(const AbstractGenerator &c) | AP_LSystem::AbstractGenerator | inline
createLSystem(AbstractFile *file) | AP_LSystem::AbstractGenerator | static
getWord()=0 | AP_LSystem::AbstractGenerator | pure virtual
loadFile(std::string &filename)=0 | AP_LSystem::AbstractGenerator | pure virtual
loadWordFromFile(std::string &) | AP_LSystem::AbstractGenerator | virtual
m_MainLSystem | AP_LSystem::AbstractGenerator | protected
m_Word | AP_LSystem::AbstractGenerator | protected
nextIteration()=0 | AP_LSystem::AbstractGenerator | pure virtual
operator=(const AbstractGenerator &c) | AP_LSystem::AbstractGenerator | inline
saveWordToFile(std::string &) | AP_LSystem::AbstractGenerator | virtual
~AbstractGenerator(void) | AP_LSystem::AbstractGenerator | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractInterpret
AP_LSystem::AbstractInterpret Member List

This is the complete list of members for AP_LSystem::AbstractInterpret, including all inherited members.

AbstractInterpret() | AP_LSystem::AbstractInterpret | inline
createGeodes() | AP_LSystem::AbstractInterpret | inline
errorText(int error) | AP_LSystem::AbstractInterpret | inlinestatic
m_Geodes | AP_LSystem::AbstractInterpret | protected
m_Owner | AP_LSystem::AbstractInterpret | protected
m_Turtles | AP_LSystem::AbstractInterpret | protected
parse(ParseableString *word)=0 | AP_LSystem::AbstractInterpret | pure virtual
switchGeode(std::vector< Parameter > &p) | AP_LSystem::AbstractInterpret | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractLSystem
AP_LSystem::AbstractLSystem Member List

This is the complete list of members for AP_LSystem::AbstractLSystem, including all inherited members.

AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *)=0 | AP_LSystem::AbstractLSystem | protectedpure virtual
addRule(std::string *)=0 | AP_LSystem::AbstractLSystem | protectedpure virtual
clone() const =0 | AP_LSystem::AbstractLSystem | pure virtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
loadFromFile(AbstractFile *file)=0 | AP_LSystem::AbstractLSystem | pure virtual
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
nextIteration()=0 | AP_LSystem::AbstractLSystem | pure virtual
operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
setAxiom(std::string &)=0 | AP_LSystem::AbstractLSystem | protectedpure virtual
translate()=0 | AP_LSystem::AbstractLSystem | pure virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractTurtle
AP_LSystem::AbstractTurtle Member List

This is the complete list of members for AP_LSystem::AbstractTurtle, including all inherited members.

bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
drawForward(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
drawForwardHalf()=0 | AP_LSystem::AbstractTurtle | pure virtual
drawFrame(osg::Matrixd &matrix, osg::Vec4d *color=NULL)=0 | AP_LSystem::AbstractTurtle | pure virtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::AbstractTurtle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::AbstractTurtle | inlinevirtual
moveForward(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
moveForwardHalf()=0 | AP_LSystem::AbstractTurtle | pure virtual
multiplyAngle(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
multiplyLength(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
multiplyRadius(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
multiplyTropismElasticity(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
pitchDown(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
pitchUp(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround()=0 | AP_LSystem::AbstractTurtle | pure virtual
rollLeft(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
rollRight(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
rollUntilHorizontal()=0 | AP_LSystem::AbstractTurtle | pure virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround()=0 | AP_LSystem::AbstractTurtle | pure virtual
turnLeft(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
turnRight(std::vector< Parameter > &p)=0 | AP_LSystem::AbstractTurtle | pure virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • AbstractkLSystem
AP_LSystem::AbstractkLSystem Member List

This is the complete list of members for AP_LSystem::AbstractkLSystem, including all inherited members.

AbstractkLSystem(AbstractFile *) | AP_LSystem::AbstractkLSystem |
AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const =0 | AP_LSystem::AbstractLSystem | pure virtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
processPredecessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
processRuleSuccessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::LSystem | protectedvirtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Configuration
AP_LSystem::Configuration Member List

This is the complete list of members for AP_LSystem::Configuration, including all inherited members.

get() | AP_LSystem::Configuration | static
getLSystemCount() | AP_LSystem::Configuration |
getLSystemIndex(const string &lsystemID) | AP_LSystem::Configuration |
getProperty(const string &prop) | AP_LSystem::Configuration |
getProperty(const string &lsystemID, const string &prop) | AP_LSystem::Configuration |
getProperty(const unsigned int lsystemIndex, const string &prop) | AP_LSystem::Configuration |
loadCfgFile(string filename) | AP_LSystem::Configuration |
setProperty(const string &prop) | AP_LSystem::Configuration |
setProperty(const string &lsystemID, const string &prop) | AP_LSystem::Configuration |
setProperty(const string &lsystemID, const string &prop, const string &value) | AP_LSystem::Configuration |
writeAll(std::basic_ostream< char > &, const string &) | AP_LSystem::Configuration |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ConfigurationException
AP_LSystem::ConfigurationException Member List

This is the complete list of members for AP_LSystem::ConfigurationException, including all inherited members.

appendType() | AP_LSystem::ConfigurationException | inlinevirtual
ConfigurationException() | AP_LSystem::ConfigurationException | inline
ConfigurationException(const char *description) | AP_LSystem::ConfigurationException | inline
ConfigurationException(std::string description) | AP_LSystem::ConfigurationException | inline
LSystemException() | AP_LSystem::LSystemException | inline
LSystemException(const char *description) | AP_LSystem::LSystemException | inline
message | AP_LSystem::LSystemException |
type | AP_LSystem::LSystemException |
what() const | AP_LSystem::LSystemException | inlinevirtual
~LSystemException() | AP_LSystem::LSystemException | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • D0LSystem
AP_LSystem::D0LSystem Member List

This is the complete list of members for AP_LSystem::D0LSystem, including all inherited members.

AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
capabilities | AP_LSystem::D0LSystem | protectedstatic
clone() const | AP_LSystem::D0LSystem | inlinevirtual
D0LSystem(AbstractFile *) | AP_LSystem::D0LSystem |
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
isCapable(unsigned int type) | AP_LSystem::D0LSystem | inlinestatic
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &, string *, string::iterator &) | AP_LSystem::D0LSystem | protectedvirtual
processPredecessor(Rule &, string *, string::iterator &) | AP_LSystem::D0LSystem | protectedvirtual
processRuleSuccessor(Rule &, string *, string::iterator &) | AP_LSystem::D0LSystem | protectedvirtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::LSystem | protectedvirtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::D0LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • FileException
AP_LSystem::FileException Member List

This is the complete list of members for AP_LSystem::FileException, including all inherited members.

appendType() | AP_LSystem::FileException | inlinevirtual
FileException() | AP_LSystem::FileException | inline
FileException(const char *description) | AP_LSystem::FileException | inline
FileException(std::string description) | AP_LSystem::FileException | inline
LSystemException() | AP_LSystem::LSystemException | inline
LSystemException(const char *description) | AP_LSystem::LSystemException | inline
message | AP_LSystem::LSystemException |
type | AP_LSystem::LSystemException |
what() const | AP_LSystem::LSystemException | inlinevirtual
~LSystemException() | AP_LSystem::LSystemException | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • HermitPipe
AP_LSystem::HermitPipe Member List

This is the complete list of members for AP_LSystem::HermitPipe, including all inherited members.

addContourLoftGeometry() | AP_LSystem::LoftTurtle | protectedvirtual
adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
createCircleContour() | AP_LSystem::LoftTurtle | inlineprotected
createLoftGeometryOpening() | AP_LSystem::LoftTurtle | protectedvirtual
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double dist) | AP_LSystem::HermitPipe | virtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::HermitPipe | virtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
HermitPipe(void) | AP_LSystem::HermitPipe | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::HermitPipe | virtual
insideStep() | AP_LSystem::StraightPipe | virtual
LoftTurtle(void) | AP_LSystem::LoftTurtle |
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::StraightPipe | virtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
StraightPipe(void) | AP_LSystem::StraightPipe | inline
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~HermitPipe(void) | AP_LSystem::HermitPipe | inline
~LoftTurtle(void) | AP_LSystem::LoftTurtle |
~StraightPipe(void) | AP_LSystem::StraightPipe | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • JointedPipe
AP_LSystem::JointedPipe Member List

This is the complete list of members for AP_LSystem::JointedPipe, including all inherited members.

addContourLoftGeometry() | AP_LSystem::LoftTurtle | protectedvirtual
adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
createCircleContour() | AP_LSystem::LoftTurtle | inlineprotected
createLoftGeometryOpening() | AP_LSystem::LoftTurtle | protectedvirtual
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double dist) | AP_LSystem::LoftTurtle | inlineprotectedvirtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::AbstractTurtle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::JointedPipe | virtual
insideStep() | AP_LSystem::LoftTurtle | inlineprotectedvirtual
JointedPipe(void) | AP_LSystem::JointedPipe |
LoftTurtle(void) | AP_LSystem::LoftTurtle |
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::JointedPipe | virtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::JointedPipe | virtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~JointedPipe(void) | AP_LSystem::JointedPipe |
~LoftTurtle(void) | AP_LSystem::LoftTurtle |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSFile
AP_LSystem::LSFile Member List

This is the complete list of members for AP_LSystem::LSFile, including all inherited members.

AbstractFile() | AP_LSystem::AbstractFile | inline
addType(std::string &type) | AP_LSystem::AbstractFile | inlineprotected
getAxiom() | AP_LSystem::AbstractFile | inline
getHomomorphisms() | AP_LSystem::AbstractFile | inlinevirtual
getRules() | AP_LSystem::AbstractFile | inlinevirtual
getSubsystems() | AP_LSystem::AbstractFile | inlinevirtual
LSFile() | AP_LSystem::LSFile |
m_Axiom | AP_LSystem::AbstractFile | protected
m_Homomorphisms | AP_LSystem::AbstractFile | protected
m_Name | AP_LSystem::AbstractFile | protected
m_Rules | AP_LSystem::AbstractFile | protected
m_Subsytems | AP_LSystem::AbstractFile | protected
m_Type | AP_LSystem::AbstractFile | protected
name() | AP_LSystem::AbstractFile | inline
open(string &filename) | AP_LSystem::LSFile | virtual
AP_LSystem::AbstractFile::open(std::string &filename)=0 | AP_LSystem::AbstractFile | pure virtual
substitute(std::map< string, string > &pairs) | AP_LSystem::AbstractFile | inline
type() | AP_LSystem::AbstractFile | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSGeode
AP_LSystem::LSGeode Member List

This is the complete list of members for AP_LSystem::LSGeode, including all inherited members.

getDefaultTurtleProperties() | AP_LSystem::LSGeode
getTurtleType() | AP_LSystem::LSGeode
LSGeode(unsigned int index) | AP_LSystem::LSGeode
setDefaultTurtleProperties(TurtleProperties &p) | AP_LSystem::LSGeode
setDefaultTurtleProperties(int index) | AP_LSystem::LSGeode
setTurtleType(const std::string &type) | AP_LSystem::LSGeode
setTurtleType(TurtleType type) | AP_LSystem::LSGeode
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSObject
AP_LSystem::LSObject Member List

This is the complete list of members for AP_LSystem::LSObject, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | AP_LSystem::LSObject | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
LSObject() | AP_LSystem::LSObject |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | AP_LSystem::LSObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | AP_LSystem::LSObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~LSObject() | AP_LSystem::LSObject | virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystem
AP_LSystem::LSystem Member List

This is the complete list of members for AP_LSystem::LSystem, including all inherited members.

AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const =0 | AP_LSystem::AbstractLSystem | pure virtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
processPredecessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
processRuleSuccessor(Rule &, string *, string::iterator &)=0 | AP_LSystem::LSystem | protectedpure virtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::LSystem | protectedvirtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystemException
AP_LSystem::LSystemException Member List

This is the complete list of members for AP_LSystem::LSystemException, including all inherited members.

appendType() | AP_LSystem::LSystemException | inlinevirtual
LSystemException() | AP_LSystem::LSystemException | inline
LSystemException(const char *description) | AP_LSystem::LSystemException | inline
message | AP_LSystem::LSystemException |
type | AP_LSystem::LSystemException |
what() const | AP_LSystem::LSystemException | inlinevirtual
~LSystemException() | AP_LSystem::LSystemException | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LSystemGenerator
AP_LSystem::LSystemGenerator Member List

This is the complete list of members for AP_LSystem::LSystemGenerator, including all inherited members.

AbstractGenerator(void) | AP_LSystem::AbstractGenerator | inline
AbstractGenerator(const AbstractGenerator &c) | AP_LSystem::AbstractGenerator | inline
createLSystem(AbstractFile *file) | AP_LSystem::AbstractGenerator | static
getWord() | AP_LSystem::LSystemGenerator | virtual
loadFile(std::string &filename) | AP_LSystem::LSystemGenerator | virtual
loadWordFromFile(std::string &) | AP_LSystem::AbstractGenerator | virtual
LSystemGenerator(void) | AP_LSystem::LSystemGenerator |
m_MainLSystem | AP_LSystem::AbstractGenerator | protected
m_Word | AP_LSystem::AbstractGenerator | protected
nextIteration() | AP_LSystem::LSystemGenerator | virtual
operator=(const AbstractGenerator &c) | AP_LSystem::AbstractGenerator | inline
saveWordToFile(std::string &) | AP_LSystem::AbstractGenerator | virtual
~AbstractGenerator(void) | AP_LSystem::AbstractGenerator | inline
~LSystemGenerator(void) | AP_LSystem::LSystemGenerator |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LoftTurtle
AP_LSystem::LoftTurtle Member List

This is the complete list of members for AP_LSystem::LoftTurtle, including all inherited members.

addContourLoftGeometry() | AP_LSystem::LoftTurtle | protectedvirtual
adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
createCircleContour() | AP_LSystem::LoftTurtle | inlineprotected
createLoftGeometryOpening() | AP_LSystem::LoftTurtle | protectedvirtual
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double dist) | AP_LSystem::LoftTurtle | inlineprotectedvirtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::AbstractTurtle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::AbstractTurtle | inlinevirtual
insideStep() | AP_LSystem::LoftTurtle | inlineprotectedvirtual
LoftTurtle(void) | AP_LSystem::LoftTurtle |
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~LoftTurtle(void) | AP_LSystem::LoftTurtle |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Log
AP_LSystem::Log Member List

This is the complete list of members for AP_LSystem::Log, including all inherited members.

get() | AP_LSystem::Log | inlinestatic
getModuleCounter() const | AP_LSystem::Log | inline
getQueryCounter() const | AP_LSystem::Log | inline
getRewritingCounter() const | AP_LSystem::Log | inline
getTurtleCounter() const | AP_LSystem::Log | inline
incModuleCounter() | AP_LSystem::Log | inline
incQueryCounter() | AP_LSystem::Log | inline
incRewritingCounter() | AP_LSystem::Log | inline
incTurtleCounter() | AP_LSystem::Log | inline
write(std::string str) | AP_LSystem::Log | inline
write(int i) | AP_LSystem::Log | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • LongString
AP_LSystem::LongString Member List

This is the complete list of members for AP_LSystem::LongString, including all inherited members.

append(T par) | AP_LSystem::LongString | inline
append(const char ch) | AP_LSystem::LongString |
append(const char *data, int length) | AP_LSystem::LongString |
append(LongString *ls) | AP_LSystem::LongString |
convertFromString(std::string *str, unsigned int &=ZERO, const char= '\0') | AP_LSystem::LongString |
findMatchingLeftBracket(int pos) | AP_LSystem::LongString |
findMatchingRightBracket(int pos) | AP_LSystem::LongString |
getData() | AP_LSystem::LongString |
getData(unsigned int &pos, unsigned int &length, char delimiter) | AP_LSystem::LongString |
getParameters(unsigned int &pos, T *pParams, int &paramsCnt) | AP_LSystem::LongString | inline
getSymbol(unsigned int &pos) | AP_LSystem::LongString |
length() const | AP_LSystem::LongString | inline
LongString(unsigned int length=1048576) | AP_LSystem::LongString |
LongString(const LongString &c) | AP_LSystem::LongString |
matchLeft(char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL) | AP_LSystem::LongString |
matchRight(char ch, int pos, const std::string *ignore=NULL, const std::string *consider=NULL) | AP_LSystem::LongString |
operator=(const LongString &c) | AP_LSystem::LongString |
operator[](unsigned int i) const | AP_LSystem::LongString | inline
peekSymbol(int &pos, bool direction) | AP_LSystem::LongString |
toString() | AP_LSystem::LongString |
~LongString() | AP_LSystem::LongString |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • MovingTurtle
AP_LSystem::MovingTurtle Member List

This is the complete list of members for AP_LSystem::MovingTurtle, including all inherited members.

adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double) | AP_LSystem::MovingTurtle | protectedvirtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::AbstractTurtle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::AbstractTurtle | inlinevirtual
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Par2LSystem
AP_LSystem::Par2LSystem Member List

This is the complete list of members for AP_LSystem::Par2LSystem, including all inherited members.

AbstractkLSystem(AbstractFile *) | AP_LSystem::AbstractkLSystem |
AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const | AP_LSystem::Par2LSystem | inlinevirtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
isCapable(unsigned int type) | AP_LSystem::Par2LSystem | inlinestatic
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
Par2LSystem(AbstractFile *) | AP_LSystem::Par2LSystem |
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &, string *, string::iterator &) | AP_LSystem::Par2LSystem | virtual
processPredecessor(Rule &, string *, string::iterator &) | AP_LSystem::Par2LSystem | virtual
processRuleSuccessor(Rule &, string *, string::iterator &) | AP_LSystem::Par2LSystem | virtual
selectRule(multimap< char, Rule >::iterator &, multimap< char, Rule >::iterator &, LongString *, unsigned int &, double *) | AP_LSystem::Par2LSystem | virtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParD0LSystem
AP_LSystem::ParD0LSystem Member List

This is the complete list of members for AP_LSystem::ParD0LSystem, including all inherited members.

Abstract0LSystem(AbstractFile *) | AP_LSystem::Abstract0LSystem |
Abstract0LSystem(const Abstract0LSystem &) | AP_LSystem::Abstract0LSystem |
AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const =0 | AP_LSystem::AbstractLSystem | pure virtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
isCapable(unsigned int type) | AP_LSystem::ParD0LSystem | inlinestatic
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
ParD0LSystem(AbstractFile *) | AP_LSystem::ParD0LSystem |
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processPredecessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processRuleSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::LSystem | protectedvirtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParStoch0LSystem
AP_LSystem::ParStoch0LSystem Member List

This is the complete list of members for AP_LSystem::ParStoch0LSystem, including all inherited members.

Abstract0LSystem(AbstractFile *) | AP_LSystem::Abstract0LSystem |
Abstract0LSystem(const Abstract0LSystem &) | AP_LSystem::Abstract0LSystem |
AbstractLSystem() | AP_LSystem::AbstractLSystem | inline
AbstractLSystem(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
addHomomorphism(std::string *) | AP_LSystem::LSystem | protectedvirtual
addRule(std::string *) | AP_LSystem::LSystem | protectedvirtual
clone() const | AP_LSystem::ParStoch0LSystem | inlinevirtual
generateSuccessor(LongString *word, multimap< char, Rule >::iterator &rule, double *params) | AP_LSystem::LSystem | protectedvirtual
getIteration() const | AP_LSystem::AbstractLSystem | inline
isCapable(unsigned int type) | AP_LSystem::ParStoch0LSystem | inlinestatic
loadFromFile(AbstractFile *file) | AP_LSystem::LSystem | virtual
LSystem(AbstractFile *) | AP_LSystem::LSystem |
LSystem(const LSystem &) | AP_LSystem::LSystem |
m_Homomorphisms | AP_LSystem::LSystem | protected
m_Ignore | AP_LSystem::LSystem | protected
m_Iteration | AP_LSystem::AbstractLSystem | protected
m_Name | AP_LSystem::AbstractLSystem | protected
m_Rules | AP_LSystem::LSystem | protected
m_SubSystemsFilenames | AP_LSystem::LSystem | protected
m_SubSystemsWords | AP_LSystem::LSystem | protected
m_Word | AP_LSystem::LSystem | protected
nextIteration() | AP_LSystem::LSystem | protectedvirtual
operator=(const ParStoch0LSystem &) | AP_LSystem::ParStoch0LSystem |
AP_LSystem::Abstract0LSystem::operator=(const LSystem &) | AP_LSystem::LSystem |
AP_LSystem::AbstractLSystem::operator=(const AbstractLSystem &c) | AP_LSystem::AbstractLSystem | inline
ParStoch0LSystem(AbstractFile *) | AP_LSystem::ParStoch0LSystem |
ParStoch0LSystem(const ParStoch0LSystem &) | AP_LSystem::ParStoch0LSystem |
processCutSymbol() | AP_LSystem::LSystem | virtual
processHomomorphismSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processPredecessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
processRuleSuccessor(Rule &rule, string *str, string::iterator &pos) | AP_LSystem::Abstract0LSystem | protectedvirtual
selectRule(multimap< char, Rule >::iterator &begin, multimap< char, Rule >::iterator &end, LongString *word, unsigned int &pos, double *parameters) | AP_LSystem::ParStoch0LSystem | virtual
setAxiom(std::string &) | AP_LSystem::LSystem | protectedvirtual
transcribe(multimap< char, Rule > &rules) | AP_LSystem::LSystem | protectedvirtual
transcribeSubSystems() | AP_LSystem::LSystem | virtual
translate() | AP_LSystem::LSystem | virtual
wordLength() | AP_LSystem::LSystem | inline
~LSystem() | AP_LSystem::LSystem |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParseableString
AP_LSystem::ParseableString Member List

This is the complete list of members for AP_LSystem::ParseableString, including all inherited members.

eof() | AP_LSystem::ParseableString | inline
m_Length | AP_LSystem::ParseableString | protected
m_Str | AP_LSystem::ParseableString | protected
next(std::vector< Parameter > &parameters) | AP_LSystem::ParseableString |
operator<<(std::basic_ostream< char > &os, const ParseableString ps) | AP_LSystem::ParseableString | friend
operator=(const ParseableString &) | AP_LSystem::ParseableString |
ParseableString(LongString *string) | AP_LSystem::ParseableString |
ParseableString(char *string, unsigned int length) | AP_LSystem::ParseableString |
ParseableString(const ParseableString &) | AP_LSystem::ParseableString |
reset() | AP_LSystem::ParseableString | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • ParsingException
AP_LSystem::ParsingException Member List

This is the complete list of members for AP_LSystem::ParsingException, including all inherited members.

appendType() | AP_LSystem::ParsingException | inlinevirtual
LSystemException() | AP_LSystem::LSystemException | inline
LSystemException(const char *description) | AP_LSystem::LSystemException | inline
message | AP_LSystem::LSystemException |
ParsingException() | AP_LSystem::ParsingException | inline
ParsingException(const char *description) | AP_LSystem::ParsingException | inline
ParsingException(std::string description) | AP_LSystem::ParsingException | inline
type | AP_LSystem::LSystemException |
what() const | AP_LSystem::LSystemException | inlinevirtual
~LSystemException() | AP_LSystem::LSystemException | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Query
AP_LSystem::Query Member List

This is the complete list of members for AP_LSystem::Query, including all inherited members.

headingX(const double *) | AP_LSystem::Query | inlinestatic
headingY(const double *) | AP_LSystem::Query | inlinestatic
headingZ(const double *) | AP_LSystem::Query | inlinestatic
leftX(const double *) | AP_LSystem::Query | inlinestatic
leftY(const double *) | AP_LSystem::Query | inlinestatic
leftZ(const double *) | AP_LSystem::Query | inlinestatic
positionX(const double *) | AP_LSystem::Query | inlinestatic
positionY(const double *) | AP_LSystem::Query | inlinestatic
positionZ(const double *) | AP_LSystem::Query | inlinestatic
upX(const double *) | AP_LSystem::Query | inlinestatic
upY(const double *) | AP_LSystem::Query | inlinestatic
upZ(const double *) | AP_LSystem::Query | inlinestatic
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • QueryInterpret
AP_LSystem::QueryInterpret Member List

This is the complete list of members for AP_LSystem::QueryInterpret, including all inherited members.

AbstractInterpret() | AP_LSystem::AbstractInterpret | inline
bindWord(LongString *str) | AP_LSystem::QueryInterpret | inline
createGeodes() | AP_LSystem::AbstractInterpret | inline
errorText(int error) | AP_LSystem::AbstractInterpret | inlinestatic
get() | AP_LSystem::QueryInterpret | inlinestatic
headingX() | AP_LSystem::QueryInterpret | inline
headingY() | AP_LSystem::QueryInterpret | inline
headingZ() | AP_LSystem::QueryInterpret | inline
leftX() | AP_LSystem::QueryInterpret | inline
leftY() | AP_LSystem::QueryInterpret | inline
leftZ() | AP_LSystem::QueryInterpret | inline
m_Geodes | AP_LSystem::AbstractInterpret | protected
m_Owner | AP_LSystem::AbstractInterpret | protected
m_Turtles | AP_LSystem::AbstractInterpret | protected
positionX() | AP_LSystem::QueryInterpret | inline
positionY() | AP_LSystem::QueryInterpret | inline
positionZ() | AP_LSystem::QueryInterpret | inline
switchGeode(std::vector< Parameter > &p) | AP_LSystem::AbstractInterpret | inline
upX() | AP_LSystem::QueryInterpret | inline
upY() | AP_LSystem::QueryInterpret | inline
upZ() | AP_LSystem::QueryInterpret | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • QueryTurtle
AP_LSystem::QueryTurtle Member List

This is the complete list of members for AP_LSystem::QueryTurtle, including all inherited members.

adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double) | AP_LSystem::MovingTurtle | protectedvirtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::QueryTurtle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::QueryTurtle | inlinevirtual
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
properties | AP_LSystem::AbstractTurtle | protected
QueryTurtle(void) | AP_LSystem::QueryTurtle | inline
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~QueryTurtle(void) | AP_LSystem::QueryTurtle | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • RandomIndex
AP_LSystem::RandomIndex Member List

This is the complete list of members for AP_LSystem::RandomIndex, including all inherited members.

addProbability(double p) | AP_LSystem::RandomIndex | inline
getRandomIndex() | AP_LSystem::RandomIndex | inline
init() | AP_LSystem::RandomIndex | inlinestatic
RandomIndex() | AP_LSystem::RandomIndex | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Randomizer
AP_LSystem::Randomizer Member List

This is the complete list of members for AP_LSystem::Randomizer, including all inherited members.

get(unsigned int maxPercents) | AP_LSystem::Randomizer | inlinestatic
get(const double *max) | AP_LSystem::Randomizer | inlinestatic
init() | AP_LSystem::Randomizer | inlinestatic
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Rectangle
AP_LSystem::Rectangle Member List

This is the complete list of members for AP_LSystem::Rectangle, including all inherited members.

adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double dist) | AP_LSystem::Rectangle | virtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::Rectangle | inlinevirtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::Rectangle | inlinevirtual
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
Rectangle(void) | AP_LSystem::Rectangle | inline
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~Rectangle(void) | AP_LSystem::Rectangle | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StaticString
AP_LSystem::StaticString Member List

This is the complete list of members for AP_LSystem::StaticString, including all inherited members.

length | AP_LSystem::StaticString |
operator=(const StaticString &c) | AP_LSystem::StaticString | inline
StaticString(const char *str, int length) | AP_LSystem::StaticString | inline
StaticString(LongString *str) | AP_LSystem::StaticString | inline
StaticString(char ch) | AP_LSystem::StaticString | inline
StaticString(std::string str) | AP_LSystem::StaticString | inline
StaticString(const StaticString &c) | AP_LSystem::StaticString | inline
str | AP_LSystem::StaticString |
toString() | AP_LSystem::StaticString | inline
~StaticString() | AP_LSystem::StaticString | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StraightPipe
AP_LSystem::StraightPipe Member List

This is the complete list of members for AP_LSystem::StraightPipe, including all inherited members.

addContourLoftGeometry() | AP_LSystem::LoftTurtle | protectedvirtual
adjustMatrices() | AP_LSystem::MovingTurtle | protectedvirtual
bindGeode(LSGeode *geode) | AP_LSystem::AbstractTurtle | inline
createCircleContour() | AP_LSystem::LoftTurtle | inlineprotected
createLoftGeometryOpening() | AP_LSystem::LoftTurtle | protectedvirtual
doStep(double dist) | AP_LSystem::MovingTurtle | protectedvirtual
drawForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
drawForwardHalf() | AP_LSystem::MovingTurtle | virtual
drawFrame(osg::Matrixd &, osg::Vec4d *=NULL) | AP_LSystem::MovingTurtle | protectedvirtual
drawStep(double dist) | AP_LSystem::LoftTurtle | inlineprotectedvirtual
drawVector(const osg::Vec3d &vector, osg::Matrixd &matrix, osg::Vec4d &color) | AP_LSystem::AbstractTurtle | inlinevirtual
finalize() | AP_LSystem::StraightPipe | virtual
geode | AP_LSystem::AbstractTurtle | protected
getGeode() | AP_LSystem::AbstractTurtle | inline
getMatrix() | AP_LSystem::AbstractTurtle | inline
getProperties() | AP_LSystem::AbstractTurtle | inline
inheritProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
initialize() | AP_LSystem::StraightPipe | virtual
insideStep() | AP_LSystem::StraightPipe | virtual
LoftTurtle(void) | AP_LSystem::LoftTurtle |
makeRotate(osg::Quat &) | AP_LSystem::MovingTurtle | protectedvirtual
moveForward(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
moveForwardHalf() | AP_LSystem::MovingTurtle | virtual
multiplyAngle(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyGravitropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyLength(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyRadius(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
multiplyTropismElasticity(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchDown(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
pitchUp(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
postRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
postStep() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preRotate() | AP_LSystem::MovingTurtle | inlineprotectedvirtual
preStep() | AP_LSystem::StraightPipe | virtual
properties | AP_LSystem::AbstractTurtle | protected
rand(double angle) | AP_LSystem::AbstractTurtle | inline
randomTurnPitchRoll(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
resetValues() | AP_LSystem::AbstractTurtle | inlinevirtual
rollArround() | AP_LSystem::MovingTurtle | virtual
rollLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
rollUntilHorizontal() | AP_LSystem::MovingTurtle | virtual
setProperties(TurtleProperties p) | AP_LSystem::AbstractTurtle | inlinevirtual
StraightPipe(void) | AP_LSystem::StraightPipe | inline
toRad(double angle) | AP_LSystem::AbstractTurtle | inline
turnArround() | AP_LSystem::MovingTurtle | virtual
turnLeft(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
turnRight(std::vector< Parameter > &p) | AP_LSystem::MovingTurtle | virtual
~LoftTurtle(void) | AP_LSystem::LoftTurtle |
~StraightPipe(void) | AP_LSystem::StraightPipe | inline
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • StringUtils
AP_LSystem::StringUtils Member List

This is the complete list of members for AP_LSystem::StringUtils, including all inherited members.

eraseWhiteSpaces(std::string &) | AP_LSystem::StringUtils | static
processLine(std::fstream *, std::stringstream &) | AP_LSystem::StringUtils | static
processVector(std::string str, std::vector< double > &v) | AP_LSystem::StringUtils | static
uncommentLine(std::string &) | AP_LSystem::StringUtils | static
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleInterpret
AP_LSystem::TurtleInterpret Member List

This is the complete list of members for AP_LSystem::TurtleInterpret, including all inherited members.

AbstractInterpret() | AP_LSystem::AbstractInterpret | inline
createGeodes() | AP_LSystem::AbstractInterpret | inline
errorText(int error) | AP_LSystem::AbstractInterpret | inlinestatic
m_Geodes | AP_LSystem::AbstractInterpret | protected
m_Owner | AP_LSystem::AbstractInterpret | protected
m_Turtles | AP_LSystem::AbstractInterpret | protected
parse(ParseableString *word) | AP_LSystem::TurtleInterpret | virtual
switchGeode(std::vector< Parameter > &p) | AP_LSystem::AbstractInterpret | inline
TurtleInterpret(osg::Group *owner) | AP_LSystem::TurtleInterpret |
~TurtleInterpret(void) | AP_LSystem::TurtleInterpret |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleStack
AP_LSystem::TurtleStack Member List

This is the complete list of members for AP_LSystem::TurtleStack, including all inherited members.

clear() | AP_LSystem::TurtleStack
pop() | AP_LSystem::TurtleStack
push() | AP_LSystem::TurtleStack
push(LSGeode *geode) | AP_LSystem::TurtleStack
top() | AP_LSystem::TurtleStack
TurtleStack(void) | AP_LSystem::TurtleStack
~TurtleStack(void) | AP_LSystem::TurtleStack
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • XmlFile
AP_LSystem::XmlFile Member List

This is the complete list of members for AP_LSystem::XmlFile, including all inherited members.

AbstractFile() | AP_LSystem::AbstractFile | inline
addType(std::string &type) | AP_LSystem::AbstractFile | inlineprotected
getAxiom() | AP_LSystem::AbstractFile | inline
getHomomorphisms() | AP_LSystem::AbstractFile | inlinevirtual
getRules() | AP_LSystem::AbstractFile | inlinevirtual
getSubsystems() | AP_LSystem::AbstractFile | inlinevirtual
m_Axiom | AP_LSystem::AbstractFile | protected
m_Homomorphisms | AP_LSystem::AbstractFile | protected
m_Name | AP_LSystem::AbstractFile | protected
m_Rules | AP_LSystem::AbstractFile | protected
m_Subsytems | AP_LSystem::AbstractFile | protected
m_Type | AP_LSystem::AbstractFile | protected
name() | AP_LSystem::AbstractFile | inline
open(std::string &filename) | AP_LSystem::XmlFile | virtual
substitute(std::map< string, string > &pairs) | AP_LSystem::AbstractFile | inline
type() | AP_LSystem::AbstractFile | inline
XmlFile() | AP_LSystem::XmlFile |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • CameraMovementEditor
APCameraMovement::CameraMovementEditor Member List

This is the complete list of members for APCameraMovement::CameraMovementEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
action | APCameraMovement::CameraMovementEditor | protected
activate() | APCameraMovement::CameraMovementEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APCameraMovement::CameraMovementEditor | protected
bMenuVisible | vrecko::ControllableAbility | protected
CameraMovementEditor() | APCameraMovement::CameraMovementEditor |
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APCameraMovement::CameraMovementEditor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APCameraMovement::CameraMovementEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectPos | APCameraMovement::CameraMovementEditor | protected
firstObjectPosCo | APCameraMovement::CameraMovementEditor | protected
firstPointerPos | APCameraMovement::CameraMovementEditor | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
intersection | APCameraMovement::CameraMovementEditor | protected
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APCameraMovement::CameraMovementEditor | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APCameraMovement::CameraMovementEditor | protectedvirtual
menuShowed | APCameraMovement::CameraMovementEditor | protected
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pathObject | APCameraMovement::CameraMovementEditor | protected
pCameraPath | APCameraMovement::CameraMovementEditor | protected
PinList typedef | vrecko::BaseClass | protected
pointIndex | APCameraMovement::CameraMovementEditor | protected
pointType | APCameraMovement::CameraMovementEditor | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectedObjectID | APCameraMovement::CameraMovementEditor | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setIntersection(osg::Vec3 &position, vrecko::Scene *scenePtr) | APCameraMovement::CameraMovementEditor | protected
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update(void) | APCameraMovement::CameraMovementEditor | virtual
updated | vrecko::Ability | protected
viewMenu() | APCameraMovement::CameraMovementEditor | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CameraMovementEditor() | APCameraMovement::CameraMovementEditor | inlinevirtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • CameraPath
APCameraMovement::CameraPath Member List

This is the complete list of members for APCameraMovement::CameraPath, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addPoint(osg::Vec3 pos, osg::Vec3 vecPW=DEFAULT_VECPW, osg::Vec3 vecCPW=DEFAULT_VECCPW, osg::Quat cDir=DEFAULT_CDIR) | APCameraMovement::CameraPath | inline
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
animating() | APCameraMovement::CameraPath | inline
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
CameraPath() | APCameraMovement::CameraPath |
clean(void) | vrecko::Ability | inlinevirtual
convertActTimeToActPos() | APCameraMovement::CameraPath |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
draw() | APCameraMovement::CameraPath |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getControlPoints() | APCameraMovement::CameraPath | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APCameraMovement::CameraPath | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APCameraMovement::CameraPath | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APCameraMovement::CameraPath | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDirty(bool d) | APCameraMovement::CameraPath | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
startAnimation() | APCameraMovement::CameraPath |
stopAnimation() | APCameraMovement::CameraPath |
update() | APCameraMovement::CameraPath | virtual
updateActTime() | APCameraMovement::CameraPath |
updateAnimation(float fActPos) | APCameraMovement::CameraPath |
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CameraPath() | APCameraMovement::CameraPath |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraPath
  • Camera
APCameraPath::Camera Member List

This is the complete list of members for APCameraPath::Camera, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APCameraPath::Camera | protectedvirtual
ActivateMove() | APCameraPath::Camera | protected
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
AddPathPoint(osg::Vec3 position) | APCameraPath::Camera | protected
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
AddViewPoint(osg::Vec3 position) | APCameraPath::Camera | protected
ANIM_1ST_VIEW enum value | APCameraPath::Camera | protected
ANIM_3RD_VIEW enum value | APCameraPath::Camera | protected
animate enum name | APCameraPath::Camera | protected
Animate() | APCameraPath::Camera | protected
ArcLength(osg::Vec3Array *PointList, int PointsOnPart=100) | APCameraPath::Camera | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avView | APCameraPath::Camera | protected
b3rdCamera | APCameraPath::Camera | protected
bAnimationFile | APCameraPath::Camera | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bAutoRun | APCameraPath::Camera | protected
bDynamicSpeed | APCameraPath::Camera | protected
bFirstUpdate | APCameraPath::Camera | protected
bMenuVisible | vrecko::ControllableAbility | protected
bShowLinesWhileAnim | APCameraPath::Camera | protected
bShowViewLine | APCameraPath::Camera | protected
bStartAnimation | APCameraPath::Camera | protected
Camera() | APCameraPath::Camera |
clean(void) | vrecko::Ability | inlinevirtual
Clear() | APCameraPath::Camera | protected
ComputePath(std::vector< ControlPoint > &ControlPoints, osg::Vec3Array *Path, osg::Vec3Array *View) | APCameraPath::Camera | protected
ComputeSpline(const std::vector< osg::Vec3 > &PointList, osg::Vec3Array *arrayToStorePoints, bool bDynamicSpeed, const std::vector< double > *LengthsOfParts) | APCameraPath::Camera | protected
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
CreateCurs2ViewPts() | APCameraPath::Camera | protected
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APCameraPath::Camera | protectedvirtual
DeactivateMove() | APCameraPath::Camera | protected
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
DeletePoint(unsigned long ID) | APCameraPath::Camera | protected
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
DrawPoint(osg::Vec3 position, float pointRadius, osg::Vec4 pointColor) | APCameraPath::Camera | protected
DrawSpline(vrecko::EnvironmentObject *pCurveOwner, osg::Vec3Array *PointSet, osg::Vec4 colorOfLine) | APCameraPath::Camera | protected
DrawVecCursor(vrecko::EnvironmentObject *pCursorOwner, double dVecLength, const osg::Matrix &rotationMatrix, osg::Vec3 &position) | APCameraPath::Camera | protected
fAnimationTime | APCameraPath::Camera | protected
fillDefaultInfo() | APCameraPath::Camera | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
FindPoint(double dDistance, osg::Vec3Array *PointList, osg::Vec3Array *newControlPoints) | APCameraPath::Camera | protected
firstObjectPos | APCameraPath::Camera | protected
firstPointerPos | APCameraPath::Camera | protected
fPointRadius | APCameraPath::Camera | protected
fTransparency | APCameraPath::Camera | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
Init() | APCameraPath::Camera | protected
InitAnimation(osg::Vec3Array *path, osg::Vec3Array *view) | APCameraPath::Camera | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APCameraPath::Camera | inlinevirtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
iSpeed | APCameraPath::Camera | protected
issueRequests(bool bStopIfNoSelection) | APCameraPath::Camera | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
LoadAnimation(const char *FileName, std::vector< osg::Vec3 > &newPathControlPoints, std::vector< osg::Vec3 > &newViewControlPoints) | APCameraPath::Camera | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APCameraPath::Camera | protectedvirtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
m_ActPathLine | APCameraPath::Camera | protected
m_ActViewLine | APCameraPath::Camera | protected
m_ControlPoints | APCameraPath::Camera | protected
m_eAnimate | APCameraPath::Camera | protected
m_eState | APCameraPath::Camera | protected
m_numOfViewPts | APCameraPath::Camera | protected
m_pEOCamera | APCameraPath::Camera | protected
m_pEOCursor | APCameraPath::Camera | protected
m_pEOPathLine | APCameraPath::Camera | protected
m_pEOPathPoints | APCameraPath::Camera | protected
m_pEOViewLine | APCameraPath::Camera | protected
makeMenu() | APCameraPath::Camera | protected
makeMovementMenu() | APCameraPath::Camera | protected
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APCameraPath::Camera | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APCameraPath::Camera | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectTransformationFromPointer(vrecko::EnvironmentObject *eo, osg::Matrix *outTrans) | APCameraPath::Camera | protected
Orient2Vec(osg::Vec3 Vector) | APCameraPath::Camera | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PathCtrlPts | APCameraPath::Camera | protected
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
sAnimationFile | APCameraPath::Camera | protected
SaveAnimation(const char *FileName) | APCameraPath::Camera | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
start1stAnimation() | APCameraPath::Camera | protected
state enum name | APCameraPath::Camera | protected
STATE_ANIMATING enum value | APCameraPath::Camera | protected
STATE_EDITING enum value | APCameraPath::Camera | protected
STATE_MOVING enum value | APCameraPath::Camera | protected
update(void) | APCameraPath::Camera | virtual
updated | vrecko::Ability | protected
UpdateMove() | APCameraPath::Camera | protected
UpdatePath() | APCameraPath::Camera | protected
ViewCtrlPts | APCameraPath::Camera | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Camera() | APCameraPath::Camera | inlinevirtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APClouds
  • Clouds
APClouds::Clouds Member List

This is the complete list of members for APClouds::Clouds, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
AddGround() | APClouds::Clouds | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
AddSkybox() | APClouds::Clouds | protected
AddSun() | APClouds::Clouds | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
Clouds() | APClouds::Clouds |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APClouds::Clouds | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | APClouds::Clouds | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APClouds::Clouds | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | APClouds::Clouds | virtual
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | APClouds::Clouds | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APClouds::Clouds | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Clouds() | APClouds::Clouds | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • ConnectEditor
APConnectEditor::ConnectEditor Member List

This is the complete list of members for APConnectEditor::ConnectEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::ConnectEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ConnectEditor() | APConnectEditor::ConnectEditor |
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APConnectEditor::ConnectEditor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APConnectEditor::ConnectEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
init() | APConnectEditor::ConnectEditor | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APConnectEditor::ConnectEditor | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(vrecko::CABUTTONEVENT *eventData) | APConnectEditor::ConnectEditor | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
snap() | APConnectEditor::ConnectEditor | protected
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ConnectEditor() | APConnectEditor::ConnectEditor | inlinevirtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Cut
APConnectEditor::Cut Member List

This is the complete list of members for APConnectEditor::Cut, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::Cut | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNewPartObject(set< int > partSet, bool move) | APConnectEditor::Cut | protected
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
closeLoop() | APConnectEditor::Cut | protected
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
createNewCuttingLoop() | APConnectEditor::Cut | protected
Cut() | APConnectEditor::Cut |
cutObject() | APConnectEditor::Cut | protected
cuttingLoop | APConnectEditor::Cut | protected
deactivate() | APConnectEditor::Cut | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APConnectEditor::Cut | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
freeID | APConnectEditor::Cut | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
intersectedObjects | APConnectEditor::Cut | protected
isActive() | vrecko::ControllableAbility | virtual
isMenu | APConnectEditor::Cut | protected
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APConnectEditor::Cut | protected
isUpdated(void) | vrecko::Ability |
lastAddedPoint | APConnectEditor::Cut | protected
lastEventButtonID | vrecko::ControllableAbility | protected
lastPosition | APConnectEditor::Cut | protected
lastSelTest | APConnectEditor::Cut | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APConnectEditor::Cut | protectedvirtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APConnectEditor::Cut | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
optimalizeCuttingLoop() | APConnectEditor::Cut | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APConnectEditor::Cut | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pFirstActivation | APConnectEditor::Cut | protected
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processPoint(osg::Vec3 point) | APConnectEditor::Cut | protected
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
resetCuttingLoop() | APConnectEditor::Cut | protected
resolveIntersections(osg::Vec3 &position, std::vector< osg::Node * > **nodePath=NULL) | APConnectEditor::Cut | protected
resolveSelection() | APConnectEditor::Cut | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectedObject | APConnectEditor::Cut | protected
selObjectID | APConnectEditor::Cut | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showCloseCuttingLoop() | APConnectEditor::Cut | protected
showCuttingLoop() | APConnectEditor::Cut | protected
showMenu() | vrecko::ControllableAbility | protectedvirtual
soCuttingLoop | APConnectEditor::Cut | protected
update() | APConnectEditor::Cut | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~Cut() | APConnectEditor::Cut | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • EOLineSegmentIntersector
APConnectEditor::EOLineSegmentIntersector Member List

This is the complete list of members for APConnectEditor::EOLineSegmentIntersector, including all inherited members.

enter(const osg::Node &node) | APConnectEditor::EOLineSegmentIntersector | virtual
EOLineSegmentIntersector(const osg::Vec3d &start, const osg::Vec3d &end) | APConnectEditor::EOLineSegmentIntersector | inline
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Optimalizer
APConnectEditor::Optimalizer Member List

This is the complete list of members for APConnectEditor::Optimalizer, including all inherited members.

_source | APConnectEditor::Optimalizer | protected
_target | APConnectEditor::Optimalizer | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::Optimalizer | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APConnectEditor::Optimalizer | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APConnectEditor::Optimalizer | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
optimalizeAndSave() | APConnectEditor::Optimalizer | protected
optimalizeGeometry(osg::Geometry *geometry) | APConnectEditor::Optimalizer | protected
optimalizeObject(EnvironmentObject *eo) | APConnectEditor::Optimalizer | protected
Optimalizer() | APConnectEditor::Optimalizer |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(vrecko::CABUTTONEVENT *eventData) | APConnectEditor::Optimalizer | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
sourceID | APConnectEditor::Optimalizer | protected
targetID | APConnectEditor::Optimalizer | protected
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~Optimalizer() | APConnectEditor::Optimalizer | inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • PolygonState
APConnectEditor::PolygonState Member List

This is the complete list of members for APConnectEditor::PolygonState, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::PolygonState | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APConnectEditor::PolygonState | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APConnectEditor::PolygonState | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PolygonState() | APConnectEditor::PolygonState | inline
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~PolygonState() | APConnectEditor::PolygonState | inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Rotation
APConnectEditor::Rotation Member List

This is the complete list of members for APConnectEditor::Rotation, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::Rotation | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bLocalRotation | APConnectEditor::Rotation | protected
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APConnectEditor::Rotation | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
eyePos | APConnectEditor::Rotation | protected
fillDefaultInfo() | APConnectEditor::Rotation | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectMatrix | APConnectEditor::Rotation | protected
firstPointerPos | APConnectEditor::Rotation | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APConnectEditor::Rotation | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
lastPointerPos | APConnectEditor::Rotation | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APConnectEditor::Rotation | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APConnectEditor::Rotation | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans) | APConnectEditor::Rotation | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
Rotation() | APConnectEditor::Rotation |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update(void) | APConnectEditor::Rotation | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~Rotation() | APConnectEditor::Rotation | inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • Scale
APConnectEditor::Scale Member List

This is the complete list of members for APConnectEditor::Scale, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConnectEditor::Scale | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APConnectEditor::Scale | protected
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APConnectEditor::Scale | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
eyePos | APConnectEditor::Scale | protected
fillDefaultInfo() | APConnectEditor::Scale | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectMatrix | APConnectEditor::Scale | protected
firstPointerPos | APConnectEditor::Scale | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APConnectEditor::Scale | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APConnectEditor::Scale | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans) | APConnectEditor::Scale | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
Scale() | APConnectEditor::Scale |
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update(void) | APConnectEditor::Scale | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~Scale() | APConnectEditor::Scale | inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstrainedObjectMovement
APConstrainedMovement::ConstrainedObjectMovement Member List

This is the complete list of members for APConstrainedMovement::ConstrainedObjectMovement, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
applyConstrainedSnapping(EnvironmentObject *eo, osg::Matrix *inoutTrans, osg::Vec3 *inoutTranslationVector) | APConstrainedMovement::ConstrainedObjectMovement | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APConstrainedMovement::ConstrainedObjectMovement | protected
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
compareObjectPosition(int id, ifstream &stream, double &linearDifference, double &quadraticDifference) | APConstrainedMovement::ConstrainedObjectMovement | protected
compareObjectPositionsAndRotations() | APConstrainedMovement::ConstrainedObjectMovement | protected
compareObjectRotation(int id, ifstream &stream, double &linearDifference, double &quadraticDifference) | APConstrainedMovement::ConstrainedObjectMovement | protected
ConstrainedObjectMovement() | APConstrainedMovement::ConstrainedObjectMovement |
constraintHierarchyRoot | APConstrainedMovement::ConstrainedObjectMovement | protected
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectPos | APConstrainedMovement::ConstrainedObjectMovement | protected
firstObjectRot | APConstrainedMovement::ConstrainedObjectMovement | protected
firstPointerPos | APConstrainedMovement::ConstrainedObjectMovement | protected
firstPointerRot | APConstrainedMovement::ConstrainedObjectMovement | protected
firstTransparency | APConstrainedMovement::ConstrainedObjectMovement | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APConstrainedMovement::ConstrainedObjectMovement | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
loadObjectFullMatrix(int id, ifstream &stream) | APConstrainedMovement::ConstrainedObjectMovement | protected
loadObjectPositionsAndRotations() | APConstrainedMovement::ConstrainedObjectMovement | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APConstrainedMovement::ConstrainedObjectMovement | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans, osg::Vec3 *outTranslationVector) | APConstrainedMovement::ConstrainedObjectMovement | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
prevPointerPos | APConstrainedMovement::ConstrainedObjectMovement | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | APConstrainedMovement::ConstrainedObjectMovement | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
readWatchedObjectIDs() | APConstrainedMovement::ConstrainedObjectMovement | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
rotating | APConstrainedMovement::ConstrainedObjectMovement | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update(void) | APConstrainedMovement::ConstrainedObjectMovement | virtual
updated | vrecko::Ability | protected
writeObjectFullMatrix(int id, ofstream &stream) | APConstrainedMovement::ConstrainedObjectMovement | protected
writeObjectPosition(int id, ofstream &stream) | APConstrainedMovement::ConstrainedObjectMovement | protected
writeObjectPositionsAndRotations() | APConstrainedMovement::ConstrainedObjectMovement | protected
writeObjectRotation(int id, ofstream &stream) | APConstrainedMovement::ConstrainedObjectMovement | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ConstrainedObjectMovement() | APConstrainedMovement::ConstrainedObjectMovement | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstraintArea
APConstrainedMovement::ConstraintArea Member List

This is the complete list of members for APConstrainedMovement::ConstraintArea, including all inherited members.

addBoundingPoint(osg::Vec3 &coords) | APConstrainedMovement::ConstraintArea |
applyTransformation(osg::Matrix transformationMatrix) | APConstrainedMovement::ConstraintArea |
ConstraintArea() | APConstrainedMovement::ConstraintArea |
ConstraintArea::distanceFactorToArea(ConstraintArea *area) | APConstrainedMovement::ConstraintArea |
getAreaClass(ConstraintHierarchyMember *constraintHierarchyRoot) | APConstrainedMovement::ConstraintArea |
getAreaClassString() | APConstrainedMovement::ConstraintArea | inline
getBoundingPoints() | APConstrainedMovement::ConstraintArea | inline
getBoundingPointsWorld() | APConstrainedMovement::ConstraintArea | inline
getNormalVector() | APConstrainedMovement::ConstraintArea | inline
getNormalVectorWorld() | APConstrainedMovement::ConstraintArea | inline
getPlaneDistanceFrom(ConstraintArea *area, double &distance) | APConstrainedMovement::ConstraintArea |
getRestrictorString() | APConstrainedMovement::ConstraintArea | inline
liesWithinArea(ConstraintArea *area) | APConstrainedMovement::ConstraintArea |
setAreaClassString(string str) | APConstrainedMovement::ConstraintArea | inline
setNormalVector(osg::Vec3 &normalVector) | APConstrainedMovement::ConstraintArea |
setRestrictorString(string str) | APConstrainedMovement::ConstraintArea | inline
setWorldTransformationFromObject(EnvironmentObject *eo) | APConstrainedMovement::ConstraintArea |
shift(osg::Vec3 shiftVector) | APConstrainedMovement::ConstraintArea |
writeInfo() | APConstrainedMovement::ConstraintArea |
~ConstraintArea() | APConstrainedMovement::ConstraintArea | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConstrainedMovement
  • ConstraintDescription
APConstrainedMovement::ConstraintDescription Member List

This is the complete list of members for APConstrainedMovement::ConstraintDescription, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addConstrainedChildID(int id) | APConstrainedMovement::ConstraintDescription |
addConstrainedDualPartnerID(int id, bool addAsFresh) | APConstrainedMovement::ConstraintDescription |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clearFreshDualPartnerIDs() | APConstrainedMovement::ConstraintDescription | inline
ConstraintDescription() | APConstrainedMovement::ConstraintDescription |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
freeFromConstraintParent() | APConstrainedMovement::ConstraintDescription |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getBindingAreas() | APConstrainedMovement::ConstraintDescription | inline
getBoundAreaCount() | APConstrainedMovement::ConstraintDescription | inline
getBoundAreaNormal() | APConstrainedMovement::ConstraintDescription | inline
getConstrainedChildrenIDs() | APConstrainedMovement::ConstraintDescription | inline
getConstrainedDualPartnerIDs() | APConstrainedMovement::ConstraintDescription | inline
getConstraintParentID() | APConstrainedMovement::ConstraintDescription | inline
getDualAreas() | APConstrainedMovement::ConstraintDescription | inline
getFreshDualPartnerIDs() | APConstrainedMovement::ConstraintDescription | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getJustMoving() | APConstrainedMovement::ConstraintDescription | inline
getName() const | vrecko::Ability | inline
getOfferAreas() | APConstrainedMovement::ConstraintDescription | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getWasTested() | APConstrainedMovement::ConstraintDescription | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isConstraintParentOf(EnvironmentObject *eo) | APConstrainedMovement::ConstraintDescription |
isUpdated(void) | vrecko::Ability |
loadXMLFile(const char *xmlFile) | APConstrainedMovement::ConstraintDescription |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APConstrainedMovement::ConstraintDescription | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processDualSplitting(EnvironmentObject *eo, osg::Vec3 splittingDirection) | APConstrainedMovement::ConstraintDescription |
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeConstrainedChildID(int id) | APConstrainedMovement::ConstraintDescription |
removeConstrainedDualPartnerID(int id) | APConstrainedMovement::ConstraintDescription |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBoundAreaCount(int boundAreaCount) | APConstrainedMovement::ConstraintDescription | inline
setBoundAreaNormal(osg::Vec3 boundAreaNormal) | APConstrainedMovement::ConstraintDescription | inline
setID(const char *pID) | vrecko::Ability |
setJustMoving(bool justMoving) | APConstrainedMovement::ConstraintDescription | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setWasTested(bool wasTested) | APConstrainedMovement::ConstraintDescription | inline
shiftAllConstrainedObjects(EnvironmentObject *eo, const osg::Matrix &transformationMatrix) | APConstrainedMovement::ConstraintDescription |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
writeInfo() | APConstrainedMovement::ConstraintDescription |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ConstraintDescription() | APConstrainedMovement::ConstraintDescription | virtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AcrossPattern
APDYNAMICART::AcrossPattern Member List

This is the complete list of members for APDYNAMICART::AcrossPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AdapterFactory
APDYNAMICART::AdapterFactory< T > Member List

This is the complete list of members for APDYNAMICART::AdapterFactory< T >, including all inherited members.

_adapters | APDYNAMICART::AdapterFactory< T > | protected
getAdapter(const std::string &className) | APDYNAMICART::AdapterFactory< T > | inline
getSupportedAdapters() const | APDYNAMICART::AdapterFactory< T > | inline
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Advanced
APDYNAMICART::Advanced Member List

This is the complete list of members for APDYNAMICART::Advanced, including all inherited members.

Advanced(Controller *controller) | APDYNAMICART::Advanced | inline
setLayout() | APDYNAMICART::Advanced | virtual
~Mode() | APDYNAMICART::Mode | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Attractor
APDYNAMICART::Attractor Member List

This is the complete list of members for APDYNAMICART::Attractor, including all inherited members.

_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_params | APDYNAMICART::Attractor | protected
_size | APDYNAMICART::Attractor | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
Attractor(Controller *controller) | APDYNAMICART::Attractor | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
compute()=0 | APDYNAMICART::Attractor | pure virtual
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createInstance(std::string attName, Controller *controller) | APDYNAMICART::Attractor | static
createMenuStructure(void) const | APDYNAMICART::Attractor | inlinevirtual
APDYNAMICART::PoA::createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0 | APDYNAMICART::PoA | pure virtual
createParameterSubMenu() const | APDYNAMICART::Attractor | protected
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
generate() | APDYNAMICART::Attractor |
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getAvailableAttractors() | APDYNAMICART::Attractor | static
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParameters() | APDYNAMICART::Attractor | inline
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::Attractor | inlinevirtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | inlinevirtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
init() | APDYNAMICART::Attractor | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::Attractor | inlinevirtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::Attractor | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::PoA | pure virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::Attractor | inlinevirtual
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSliderParameter(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | protected
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::Attractor | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
valueChanged(float sliderPos) | APDYNAMICART::Attractor | protected
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • AxisFrameAdapter
APDYNAMICART::AxisFrameAdapter Member List

This is the complete list of members for APDYNAMICART::AxisFrameAdapter, including all inherited members.

_rotationFrameGen | APDYNAMICART::AxisFrameAdapter | protected
AxisFrameAdapter() | APDYNAMICART::AxisFrameAdapter | inline
classDescription() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
getObject() | APDYNAMICART::AxisFrameAdapter | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::AxisFrameAdapter | virtual
META_DAObject(AxisFrameAdapter,"Tangent aligned") virtual void createMenu(MenuPtr menu) | APDYNAMICART::AxisFrameAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
RotationFrameAdapter() | APDYNAMICART::RotationFrameAdapter | inline
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::AxisFrameAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Basic
APDYNAMICART::Basic Member List

This is the complete list of members for APDYNAMICART::Basic, including all inherited members.

Basic(Controller *controller) | APDYNAMICART::Basic | inline
setLayout() | APDYNAMICART::Basic | virtual
~Mode() | APDYNAMICART::Mode | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Brush
APDYNAMICART::Brush Member List

This is the complete list of members for APDYNAMICART::Brush, including all inherited members.

_colorGenAdapterName | APDYNAMICART::Brush | protected
_colorGenFactory | APDYNAMICART::Brush | protected
_crossSectionAdapterName | APDYNAMICART::Brush | protected
_crossSectionFactory | APDYNAMICART::Brush | protected
_crossSectionInterpolationSteps | APDYNAMICART::Brush | protected
_diamGenAdapterName | APDYNAMICART::Brush | protected
_diamGenFactory | APDYNAMICART::Brush | protected
_interpolationSteps | APDYNAMICART::Brush | protected
_rotationFrameAdapterName | APDYNAMICART::Brush | protected
_rotationFrameFactory | APDYNAMICART::Brush | protected
_smoothness | APDYNAMICART::Brush | protected
Brush(string colorAdapterName, string diameterAdapterName, string crossSectionAdapterName, string rotationFrameAdapterName) | APDYNAMICART::Brush |
Brush(const Brush &orig) | APDYNAMICART::Brush |
createMenu(MenuPtr menu, bool colorMenu=true) | APDYNAMICART::Brush |
getColorGenAdapter() | APDYNAMICART::Brush | inline
getColorGenFactory() | APDYNAMICART::Brush | inline
getCrossSectionAdapter() | APDYNAMICART::Brush | inline
getCrossSectionAdapterName() const | APDYNAMICART::Brush | inline
getCrossSectionInterpolationSteps() const | APDYNAMICART::Brush | inline
getDiameter() | APDYNAMICART::Brush |
getDiameterGenAdapter() | APDYNAMICART::Brush | inline
getInterpolationSteps() const | APDYNAMICART::Brush | inline
getRotationFrameAdapter() | APDYNAMICART::Brush | inline
getRotationFrameAdapterName() const | APDYNAMICART::Brush | inline
getSmoothness() const | APDYNAMICART::Brush | inline
guiItemClicked(const char *itemID) | APDYNAMICART::Brush |
load(DOMNode *ParametersNode) | APDYNAMICART::Brush |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::Brush |
setColorAdapter(string name) | APDYNAMICART::Brush |
setCrossSectionAdapter(string name) | APDYNAMICART::Brush |
setCrossSectionInterpolationSteps(int steps) | APDYNAMICART::Brush |
setDiameter(float sliderPos) | APDYNAMICART::Brush |
setDiameterAdapter(string name) | APDYNAMICART::Brush |
setInterpolationSteps(int steps) | APDYNAMICART::Brush | inline
setRotationFrameAdapter(string name) | APDYNAMICART::Brush |
setSmoothness(double val) | APDYNAMICART::Brush | inline
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Brush |
~Brush() | APDYNAMICART::Brush | inline
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • BrushStroke
APDYNAMICART::BrushStroke Member List

This is the complete list of members for APDYNAMICART::BrushStroke, including all inherited members.

_brush | APDYNAMICART::BrushStroke | protected
_computedStrokeStartTime | APDYNAMICART::BrushStroke | protected
_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_highLightcallback | APDYNAMICART::BrushStroke | protected
_lastValidSamplePosition | APDYNAMICART::BrushStroke | protected
_leadingSpline | APDYNAMICART::BrushStroke | protected
_leadingSplineInterpolated | APDYNAMICART::BrushStroke | protected
_leadingSplineTilting | APDYNAMICART::BrushStroke | protected
_samplesOrientations | APDYNAMICART::BrushStroke | protected
_samplesPositions | APDYNAMICART::BrushStroke | protected
_samplesTimeStamps | APDYNAMICART::BrushStroke | protected
_StartTime | APDYNAMICART::BrushStroke | protected
_strokeTime | APDYNAMICART::BrushStroke | protected
_sweepSurface | APDYNAMICART::BrushStroke | protected
_timeLineDecorator | APDYNAMICART::BrushStroke | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
BrushStroke(Controller *contr, BrushPtr brush) | APDYNAMICART::BrushStroke |
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::BrushStroke | virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::BrushStroke |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_REQUEST_OUTPUT(EvokeHSLColorPicker, MessageString, MessageBool) | APDYNAMICART::BrushStroke | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
exportToFile(std::string file) | APDYNAMICART::BrushStroke |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getComputedStartTime() | APDYNAMICART::BrushStroke | inline
getDuration() | APDYNAMICART::BrushStroke |
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeadingSpline() const | APDYNAMICART::BrushStroke | inlinevirtual
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOrientationSamples() const | APDYNAMICART::BrushStroke | inlinevirtual
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPositionSamples() const | APDYNAMICART::BrushStroke | inlinevirtual
getPriority(void) const | vrecko::BaseClass | inline
getRealStartTime() | APDYNAMICART::BrushStroke | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTimeStamps() const | APDYNAMICART::BrushStroke | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::BrushStroke | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::BrushStroke | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
importControlPoints(std::vector< osg::Vec3 > *samples, std::vector< osg::Vec4 > *colours, double diameter, int usize) | APDYNAMICART::BrushStroke |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *BrushStrokeNode) | APDYNAMICART::BrushStroke | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
playback(double playbackTime) | APDYNAMICART::BrushStroke |
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::BrushStroke | virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::BrushStroke | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setComputedTime(double newTime) | APDYNAMICART::BrushStroke | inline
setCrossSectionInterpolation(int interpol) | APDYNAMICART::BrushStroke |
setCrossSectionType(int type) | APDYNAMICART::BrushStroke |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setInterpolationSteps(int interpol) | APDYNAMICART::BrushStroke |
setLeadingSpline(InterpolatedSplinePtr val) | APDYNAMICART::BrushStroke | inline
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSmoothness(double smooth) | APDYNAMICART::BrushStroke |
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
switchRenderingMethod() | APDYNAMICART::BrushStroke |
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update(void) | APDYNAMICART::BrushStroke | virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
visualizeControlPoints(bool show) | APDYNAMICART::BrushStroke |
~BaseClass() | vrecko::BaseClass | virtual
~BrushStroke() | APDYNAMICART::BrushStroke |
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • BrushStrokeControlPoint
APDYNAMICART::BrushStrokeControlPoint Member List

This is the complete list of members for APDYNAMICART::BrushStrokeControlPoint, including all inherited members.

BrushStrokeControlPoint(DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient) | APDYNAMICART::BrushStrokeControlPoint |
frenetFremeComputed | APDYNAMICART::BrushStrokeControlPoint |
getBinormal() | APDYNAMICART::BrushStrokeControlPoint | inline
getCurvature() | APDYNAMICART::BrushStrokeControlPoint | inline
getDiameter() | APDYNAMICART::BrushStrokeControlPoint | inline
getNormal() | APDYNAMICART::BrushStrokeControlPoint | inline
getOrientation() | APDYNAMICART::BrushStrokeControlPoint | inline
getPosition() | APDYNAMICART::BrushStrokeControlPoint | inline
getPositionString() | APDYNAMICART::BrushStrokeControlPoint |
getPriority() | APDYNAMICART::BrushStrokeControlPoint | inline
getSegmentLength() | APDYNAMICART::BrushStrokeControlPoint | inline
getSpeed() | APDYNAMICART::BrushStrokeControlPoint | inline
getTangent() | APDYNAMICART::BrushStrokeControlPoint | inline
getTorsion() | APDYNAMICART::BrushStrokeControlPoint | inline
getTriangulationAngle() | APDYNAMICART::BrushStrokeControlPoint | inline
getTvalue() | APDYNAMICART::BrushStrokeControlPoint | inline
getType() | APDYNAMICART::BrushStrokeControlPoint | inline
getVisualOwner() | APDYNAMICART::BrushStrokeControlPoint | inline
isSampled() | APDYNAMICART::BrushStrokeControlPoint |
setBinormal(osg::Vec3 binrml) | APDYNAMICART::BrushStrokeControlPoint | inline
setCharacteristics(osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion) | APDYNAMICART::BrushStrokeControlPoint |
setDiameter(double diam) | APDYNAMICART::BrushStrokeControlPoint | inline
setNormal(osg::Vec3 nrml) | APDYNAMICART::BrushStrokeControlPoint | inline
setPosition(osg::Vec3 pos) | APDYNAMICART::BrushStrokeControlPoint |
setPosition(osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z) | APDYNAMICART::BrushStrokeControlPoint |
setPriority(double prior) | APDYNAMICART::BrushStrokeControlPoint | inline
setRotationFrame(osg::Vec3 normal, osg::Vec3 binormal, osg::Vec3 tangent) | APDYNAMICART::BrushStrokeControlPoint |
setSegmentLength(double length) | APDYNAMICART::BrushStrokeControlPoint | inline
setSpeed(double spee) | APDYNAMICART::BrushStrokeControlPoint | inline
setTangent(osg::Vec3 tngt) | APDYNAMICART::BrushStrokeControlPoint | inline
setTriangulationAngle(osg::Quat angle) | APDYNAMICART::BrushStrokeControlPoint | inline
setTvalue(double tval) | APDYNAMICART::BrushStrokeControlPoint | inline
setVisibleVisualBox(bool vis) | APDYNAMICART::BrushStrokeControlPoint | inline
showGizmo(bool show) | APDYNAMICART::BrushStrokeControlPoint |
~BrushStrokeControlPoint() | APDYNAMICART::BrushStrokeControlPoint |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ColorGenAdapter
APDYNAMICART::ColorGenAdapter Member List

This is the complete list of members for APDYNAMICART::ColorGenAdapter, including all inherited members.

_colorIndex | APDYNAMICART::ColorGenAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
ColorGenAdapter() | APDYNAMICART::ColorGenAdapter | inline
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
getColor() | APDYNAMICART::ColorGenAdapter | inlinevirtual
getColorIndex() const | APDYNAMICART::ColorGenAdapter | inline
getObject()=0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
pointed(bool pointed) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
setColor(const osg::Vec4 &color) | APDYNAMICART::ColorGenAdapter | inlinevirtual
setColorIndex(int val) | APDYNAMICART::ColorGenAdapter | inline
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< ColorGen > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ColorGenFactory
APDYNAMICART::ColorGenFactory Member List

This is the complete list of members for APDYNAMICART::ColorGenFactory, including all inherited members.

_adapters | APDYNAMICART::AdapterFactory< ColorGenAdapter > | protected
ColorGenFactory() | APDYNAMICART::ColorGenFactory | inline
ColorGenFactory(const ColorGenFactory &orig) | APDYNAMICART::ColorGenFactory | inline
getAdapter(const std::string &className) | APDYNAMICART::AdapterFactory< ColorGenAdapter > | inline
getSupportedAdapters() const | APDYNAMICART::AdapterFactory< ColorGenAdapter > | inline
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ComputeThread
APDYNAMICART::ComputeThread Member List

This is the complete list of members for APDYNAMICART::ComputeThread, including all inherited members.

_colors | APDYNAMICART::ComputeThread | protected
_conf | APDYNAMICART::ComputeThread | protected
_dirty | APDYNAMICART::ComputeThread | protected
_done | APDYNAMICART::ComputeThread | protected
_initPoint | APDYNAMICART::ComputeThread | protected
_lim | APDYNAMICART::ComputeThread | protected
_mutex | APDYNAMICART::ComputeThread | protected
_points | APDYNAMICART::ComputeThread | protected
addPoint(osg::Vec3 point) | APDYNAMICART::ComputeThread |
cancel() | APDYNAMICART::ComputeThread | virtual
ComputeThread() | APDYNAMICART::ComputeThread |
eng | APDYNAMICART::ComputeThread | protectedstatic
getData(osg::Vec3Array *points, osg::Vec4Array *colors, Limits &limits, Parameters &params) | APDYNAMICART::ComputeThread |
init(const InitSettings &settings) | APDYNAMICART::ComputeThread |
interpolatePoints() | APDYNAMICART::ComputeThread |
isTooSmall(int i, int iter) | APDYNAMICART::ComputeThread |
run() | APDYNAMICART::ComputeThread | virtual
setColor(osg::Vec4 color, int index) | APDYNAMICART::ComputeThread |
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ConstantColorAdapter
APDYNAMICART::ConstantColorAdapter Member List

This is the complete list of members for APDYNAMICART::ConstantColorAdapter, including all inherited members.

_colorGen | APDYNAMICART::ConstantColorAdapter | protected
_colorIndex | APDYNAMICART::ColorGenAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
ColorGenAdapter() | APDYNAMICART::ColorGenAdapter | inline
ConstantColorAdapter() | APDYNAMICART::ConstantColorAdapter | inline
ConstantColorAdapter(const osg::Vec4 &color) | APDYNAMICART::ConstantColorAdapter | inline
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
getColor() | APDYNAMICART::ConstantColorAdapter | inlinevirtual
getColorIndex() const | APDYNAMICART::ColorGenAdapter | inline
getObject() | APDYNAMICART::ConstantColorAdapter | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::ConstantColorAdapter | virtual
META_DAObject(ConstantColorAdapter,"Constant") virtual void createMenu(MenuPtr menu) | APDYNAMICART::ConstantColorAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::ConstantColorAdapter | virtual
setColor(const osg::Vec4 &color) | APDYNAMICART::ConstantColorAdapter | inlinevirtual
setColorIndex(int val) | APDYNAMICART::ColorGenAdapter | inline
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< ColorGen > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ConstantDiamAdapter
APDYNAMICART::ConstantDiamAdapter Member List

This is the complete list of members for APDYNAMICART::ConstantDiamAdapter, including all inherited members.

_diamGen | APDYNAMICART::ConstantDiamAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
ConstantDiamAdapter() | APDYNAMICART::ConstantDiamAdapter | inline
ConstantDiamAdapter(double val) | APDYNAMICART::ConstantDiamAdapter | inline
createMenu(MenuPtr menu) | APDYNAMICART::ConstantDiamAdapter | virtual
APDYNAMICART::PoAAdapter::createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
getObject()=0 | APDYNAMICART::PoAAdapter< T > | pure virtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::ConstantDiamAdapter | virtual
META_DAObject(ConstantDiamAdapter,"Constant") virtual osg | APDYNAMICART::ConstantDiamAdapter | inline
pointed(bool pointed) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::ConstantDiamAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ConstantDiamAdapter | virtual
update() | APDYNAMICART::PoAAdapter< T > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< T > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Controller
APDYNAMICART::Controller Member List

This is the complete list of members for APDYNAMICART::Controller, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_tools | APDYNAMICART::Controller | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool()=0 | APDYNAMICART::Controller | pure virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clear()=0 | APDYNAMICART::Controller | pure virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0 | APDYNAMICART::Controller | pure virtual
deactivateTool()=0 | APDYNAMICART::Controller | pure virtual
debugKeyPressed()=0 | APDYNAMICART::Controller | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Controller | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID)=0 | APDYNAMICART::Controller | pure virtual
guiSliderChanged(const char *sliderID, float sliderPos)=0 | APDYNAMICART::Controller | pure virtual
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL)=0 | APDYNAMICART::Controller | pure virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList)=0 | APDYNAMICART::Controller | pure virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APDYNAMICART::Controller | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Controller | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode)=0 | APDYNAMICART::Controller | pure virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Controller | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchGUIVisibility()=0 | APDYNAMICART::Controller | pure virtual
switchTools(DAToolType newType) | APDYNAMICART::Controller | virtual
turnOff(void)=0 | APDYNAMICART::Controller | pure virtual
turnOn()=0 | APDYNAMICART::Controller | pure virtual
update()=0 | APDYNAMICART::Controller | pure virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • CrissCrossPattern
APDYNAMICART::CrissCrossPattern Member List

This is the complete list of members for APDYNAMICART::CrissCrossPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_Attractor
APDYNAMICART::Ctrl_Attractor Member List

This is the complete list of members for APDYNAMICART::Ctrl_Attractor, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_tools | APDYNAMICART::Controller | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_Attractor | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_Attractor | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createColorSubMenu(std::ostringstream &menuSS, Attractor *att) const | APDYNAMICART::Ctrl_Attractor |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_Attractor | virtual
createPoA() | APDYNAMICART::Ctrl_Attractor |
Ctrl_Attractor() | APDYNAMICART::Ctrl_Attractor |
deactivateTool() | APDYNAMICART::Ctrl_Attractor | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_Attractor | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Controller | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_Attractor | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_Attractor | inlinevirtual
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_Attractor | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_Attractor | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Controller | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_Attractor | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Controller | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchGUIVisibility() | APDYNAMICART::Ctrl_Attractor | inlinevirtual
switchTools(DAToolType newType) | APDYNAMICART::Controller | virtual
turnOff() | APDYNAMICART::Ctrl_Attractor | virtual
turnOn() | APDYNAMICART::Ctrl_Attractor | virtual
update() | APDYNAMICART::Ctrl_Attractor | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_FreeHandPainting
APDYNAMICART::Ctrl_FreeHandPainting Member List

This is the complete list of members for APDYNAMICART::Ctrl_FreeHandPainting, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_brush | APDYNAMICART::Ctrl_FreeHandPainting | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_firstTimeUpdate | APDYNAMICART::Ctrl_FreeHandPainting | protected
_lastPlaybackTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_menuAbility | APDYNAMICART::Ctrl_FreeHandPainting | protected
_nowTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackActive | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackIcon | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackSlider | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackType | APDYNAMICART::Ctrl_FreeHandPainting | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_showControlPoints | APDYNAMICART::Ctrl_FreeHandPainting | protected
_toolBrush | APDYNAMICART::Ctrl_FreeHandPainting | protected
_toolEraser | APDYNAMICART::Ctrl_FreeHandPainting | protected
_tools | APDYNAMICART::Controller | protected
_toolTongs | APDYNAMICART::Ctrl_FreeHandPainting | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_FreeHandPainting | virtual
createPoA() | APDYNAMICART::Ctrl_FreeHandPainting |
Ctrl_FreeHandPainting() | APDYNAMICART::Ctrl_FreeHandPainting |
Ctrl_FreeHandPainting(const char *abName, const char *contextName, PoAType type) | APDYNAMICART::Ctrl_FreeHandPainting |
deactivateTool() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getPaintingDuration() | APDYNAMICART::Ctrl_FreeHandPainting |
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPlaybackTimeText() | APDYNAMICART::Ctrl_FreeHandPainting | protected
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getShowControlPointsString() const | APDYNAMICART::Ctrl_FreeHandPainting | inlineprotected
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
importScene(const string &fileName) | APDYNAMICART::Ctrl_FreeHandPainting |
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APDYNAMICART::Ctrl_FreeHandPainting | protectedvirtual
APDYNAMICART::Controller::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
playback(double _playbackTime) | APDYNAMICART::Ctrl_FreeHandPainting | protected
postInitialize() | APDYNAMICART::Ctrl_FreeHandPainting | protectedvirtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Ctrl_FreeHandPainting | protectedvirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | APDYNAMICART::Ctrl_FreeHandPainting |
APDYNAMICART::Controller::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
recomputeStrokesTimes() | APDYNAMICART::Ctrl_FreeHandPainting | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchGUIVisibility() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
switchTools(DAToolType newType) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
turnOff() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
turnOn() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
update() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
~Ctrl_FreeHandPainting() | APDYNAMICART::Ctrl_FreeHandPainting |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_MotionVisualization
APDYNAMICART::Ctrl_MotionVisualization Member List

This is the complete list of members for APDYNAMICART::Ctrl_MotionVisualization, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_brush | APDYNAMICART::Ctrl_FreeHandPainting | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_firstTimeUpdate | APDYNAMICART::Ctrl_FreeHandPainting | protected
_lastPlaybackTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_menuAbility | APDYNAMICART::Ctrl_FreeHandPainting | protected
_nowTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackActive | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackIcon | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackSlider | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackTime | APDYNAMICART::Ctrl_FreeHandPainting | protected
_playbackType | APDYNAMICART::Ctrl_FreeHandPainting | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_sensorCount | APDYNAMICART::Ctrl_MotionVisualization | protected
_showControlPoints | APDYNAMICART::Ctrl_FreeHandPainting | protected
_toolBrush | APDYNAMICART::Ctrl_FreeHandPainting | protected
_toolBrushes | APDYNAMICART::Ctrl_MotionVisualization | protected
_toolEraser | APDYNAMICART::Ctrl_FreeHandPainting | protected
_tools | APDYNAMICART::Controller | protected
_toolTongs | APDYNAMICART::Ctrl_FreeHandPainting | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_MotionVisualization | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_MotionVisualization | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMenuStructure(void) const | APDYNAMICART::Ctrl_MotionVisualization |
APDYNAMICART::Ctrl_FreeHandPainting::createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_FreeHandPainting | virtual
createPoA() | APDYNAMICART::Ctrl_MotionVisualization |
Ctrl_FreeHandPainting() | APDYNAMICART::Ctrl_FreeHandPainting |
Ctrl_FreeHandPainting(const char *abName, const char *contextName, PoAType type) | APDYNAMICART::Ctrl_FreeHandPainting |
Ctrl_MotionVisualization() | APDYNAMICART::Ctrl_MotionVisualization |
deactivateTool() | APDYNAMICART::Ctrl_MotionVisualization | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
DECLARE_OUTPUT(SetSensorsCount, MessageInt) | APDYNAMICART::Ctrl_MotionVisualization | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Ctrl_FreeHandPainting | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getPaintingDuration() | APDYNAMICART::Ctrl_FreeHandPainting |
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPlaybackTimeText() | APDYNAMICART::Ctrl_FreeHandPainting | protected
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getShowControlPointsString() const | APDYNAMICART::Ctrl_FreeHandPainting | inlineprotected
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_MotionVisualization | virtual
importScene(const string &fileName) | APDYNAMICART::Ctrl_FreeHandPainting |
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_MotionVisualization | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APDYNAMICART::Ctrl_MotionVisualization | protectedvirtual
APDYNAMICART::Controller::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
playback(double _playbackTime) | APDYNAMICART::Ctrl_FreeHandPainting | protected
postInitialize() | APDYNAMICART::Ctrl_MotionVisualization | protectedvirtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Ctrl_MotionVisualization | protectedvirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | APDYNAMICART::Ctrl_FreeHandPainting |
APDYNAMICART::Controller::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
recomputeStrokesTimes() | APDYNAMICART::Ctrl_FreeHandPainting | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Ctrl_FreeHandPainting | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSensorCount(int newCount) | APDYNAMICART::Ctrl_MotionVisualization |
switchGUIVisibility() | APDYNAMICART::Ctrl_MotionVisualization | virtual
switchTools(DAToolType newType) | APDYNAMICART::Ctrl_MotionVisualization | virtual
turnOff() | APDYNAMICART::Ctrl_MotionVisualization | virtual
turnOffTool(DAToolType type) | APDYNAMICART::Ctrl_MotionVisualization | protected
turnOn() | APDYNAMICART::Ctrl_MotionVisualization | virtual
turnOnTool(DAToolType type) | APDYNAMICART::Ctrl_MotionVisualization | protected
update() | APDYNAMICART::Ctrl_MotionVisualization | protectedvirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
~Ctrl_FreeHandPainting() | APDYNAMICART::Ctrl_FreeHandPainting |
~Ctrl_MotionVisualization() | APDYNAMICART::Ctrl_MotionVisualization |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_PerlinLines
APDYNAMICART::Ctrl_PerlinLines Member List

This is the complete list of members for APDYNAMICART::Ctrl_PerlinLines, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_blue | APDYNAMICART::Ctrl_PerlinLines | protected
_boundingSize | APDYNAMICART::Ctrl_PerlinLines | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_green | APDYNAMICART::Ctrl_PerlinLines | protected
_interpolationCount | APDYNAMICART::Ctrl_PerlinLines | protected
_length | APDYNAMICART::Ctrl_PerlinLines | protected
_magnetSize | APDYNAMICART::Ctrl_PerlinLines | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_red | APDYNAMICART::Ctrl_PerlinLines | protected
_speed | APDYNAMICART::Ctrl_PerlinLines | protected
_tools | APDYNAMICART::Controller | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_PerlinLines | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
autoRotationStep | APDYNAMICART::Ctrl_PerlinLines |
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bounding | APDYNAMICART::Ctrl_PerlinLines | protected
boundingCreated | APDYNAMICART::Ctrl_PerlinLines | protected
boundingVisible | APDYNAMICART::Ctrl_PerlinLines | protected
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_PerlinLines | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMag(osg::Vec3 coords) | APDYNAMICART::Ctrl_PerlinLines |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_PerlinLines | virtual
createPoA(int count, double x, double y, double z) | APDYNAMICART::Ctrl_PerlinLines |
Ctrl_PerlinLines() | APDYNAMICART::Ctrl_PerlinLines |
deactivateTool() | APDYNAMICART::Ctrl_PerlinLines | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_PerlinLines | inlinevirtual
DECLARE_INPUT(Position_sensor_0, MessageVec3) | APDYNAMICART::Ctrl_PerlinLines | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Ctrl_PerlinLines | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_PerlinLines | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_PerlinLines | virtual
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_PerlinLines | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
lastAutorotationTime | APDYNAMICART::Ctrl_PerlinLines |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_PerlinLines | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APDYNAMICART::Ctrl_PerlinLines | virtual
APDYNAMICART::Controller::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
magnetCreated | APDYNAMICART::Ctrl_PerlinLines | protected
magnetEO | APDYNAMICART::Ctrl_PerlinLines | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
nowAutorotationTime | APDYNAMICART::Ctrl_PerlinLines |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pl | APDYNAMICART::Ctrl_PerlinLines | protected
posString | APDYNAMICART::Ctrl_PerlinLines | protected
postInitialize() | APDYNAMICART::Ctrl_PerlinLines | protectedvirtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Controller | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
random(double min, double max) | APDYNAMICART::Ctrl_PerlinLines | inline
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rightHandPosition | APDYNAMICART::Ctrl_PerlinLines | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_PerlinLines | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Controller | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setParameters() | APDYNAMICART::Ctrl_PerlinLines |
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchGUIVisibility() | APDYNAMICART::Ctrl_PerlinLines | inlinevirtual
switchTools(DAToolType newType) | APDYNAMICART::Ctrl_PerlinLines | virtual
turnOff() | APDYNAMICART::Ctrl_PerlinLines | virtual
turnOn() | APDYNAMICART::Ctrl_PerlinLines | virtual
update() | APDYNAMICART::Ctrl_PerlinLines | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_PolyhedraSculptures
APDYNAMICART::Ctrl_PolyhedraSculptures Member List

This is the complete list of members for APDYNAMICART::Ctrl_PolyhedraSculptures, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_artArea | APDYNAMICART::Controller | protected
_daEnvironment | APDYNAMICART::Controller | protected
_description | APDYNAMICART::Controller | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_sculpture | APDYNAMICART::Ctrl_PolyhedraSculptures | protected
_tools | APDYNAMICART::Controller | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
createNewPolyhedraMenu() const | APDYNAMICART::Ctrl_PolyhedraSculptures | protected
CreatePoA(const string &polyhedronName) | APDYNAMICART::Ctrl_PolyhedraSculptures |
Ctrl_PolyhedraSculptures() | APDYNAMICART::Ctrl_PolyhedraSculptures |
deactivateTool() | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_PolyhedraSculptures | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Controller | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isThereaSculpture | APDYNAMICART::Ctrl_PolyhedraSculptures | protected
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APDYNAMICART::Controller | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Controller | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Ctrl_PolyhedraSculptures | inlinevirtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchGUIVisibility() | APDYNAMICART::Ctrl_PolyhedraSculptures | inlinevirtual
switchTools(DAToolType newType) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
turnOff(void) | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
turnOn() | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
update() | APDYNAMICART::Ctrl_PolyhedraSculptures | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
~Ctrl_PolyhedraSculptures() | APDYNAMICART::Ctrl_PolyhedraSculptures |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ctrl_StringSculptures
APDYNAMICART::Ctrl_StringSculptures Member List

This is the complete list of members for APDYNAMICART::Ctrl_StringSculptures, including all inherited members.

_actualTool | APDYNAMICART::Controller | protected
_advanced | APDYNAMICART::Ctrl_StringSculptures | protected
_artArea | APDYNAMICART::Controller | protected
_basic | APDYNAMICART::Ctrl_StringSculptures | protected
_closedPattern | APDYNAMICART::Ctrl_StringSculptures | protected
_daEnvironment | APDYNAMICART::Controller | protected
_defaultColor | APDYNAMICART::Ctrl_StringSculptures | protected
_defaultPattern | APDYNAMICART::Ctrl_StringSculptures | protected
_description | APDYNAMICART::Controller | protected
_dirtyScene | APDYNAMICART::Ctrl_StringSculptures | protected
_finalArrays | APDYNAMICART::Ctrl_StringSculptures | protected
_geode | APDYNAMICART::Ctrl_StringSculptures | protected
_hoopsState | APDYNAMICART::Ctrl_StringSculptures | protected
_interpolator | APDYNAMICART::Ctrl_StringSculptures | protected
_lineCount | APDYNAMICART::Ctrl_StringSculptures | protected
_lineWidth | APDYNAMICART::Ctrl_StringSculptures | protected
_mode | APDYNAMICART::Ctrl_StringSculptures | protected
_patternColor | APDYNAMICART::Ctrl_StringSculptures | protected
_patternMaterial | APDYNAMICART::Ctrl_StringSculptures | protected
_patternsGeode | APDYNAMICART::Ctrl_StringSculptures | protected
_physXManager | APDYNAMICART::Ctrl_StringSculptures | protected
_poa | APDYNAMICART::Ctrl_StringSculptures | protected
_poas | APDYNAMICART::Controller | protected
_poasName | APDYNAMICART::Controller | protected
_ropeRadius | APDYNAMICART::Ctrl_StringSculptures | protected
_simulation | APDYNAMICART::Ctrl_StringSculptures | protected
_toolBrush | APDYNAMICART::Ctrl_StringSculptures | protected
_toolHook | APDYNAMICART::Ctrl_StringSculptures | protected
_tools | APDYNAMICART::Controller | protected
_type | APDYNAMICART::Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool() | APDYNAMICART::Ctrl_StringSculptures | virtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
asHoop(PoA *poa) | APDYNAMICART::Ctrl_StringSculptures | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
checkHookDeleteRequest() | APDYNAMICART::Ctrl_StringSculptures | protected
checkPoADeleteRequest(HoopPtr hoop) | APDYNAMICART::Ctrl_StringSculptures | protected
clean(void) | vrecko::Ability | inlinevirtual
clear() | APDYNAMICART::Ctrl_StringSculptures | virtual
clearAllPoAs() | APDYNAMICART::Controller |
Controller(const char *controllerID, const char *description, PoAType type) | APDYNAMICART::Controller |
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Ctrl_StringSculptures | virtual
createPoA(const string &name) | APDYNAMICART::Ctrl_StringSculptures |
Ctrl_StringSculptures() | APDYNAMICART::Ctrl_StringSculptures |
deactivateTool() | APDYNAMICART::Ctrl_StringSculptures | virtual
debugKeyPressed() | APDYNAMICART::Ctrl_StringSculptures | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
disableAutorotation() | APDYNAMICART::Ctrl_StringSculptures | protected
disableTools() | APDYNAMICART::Ctrl_StringSculptures | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDaareaScale() const | APDYNAMICART::Controller | inline
getDescription(void) const | APDYNAMICART::Controller | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextToolType() | APDYNAMICART::Controller | virtual
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoAs() | APDYNAMICART::Controller | inline
getPoAsName(void) const | APDYNAMICART::Controller | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getType(void) const | APDYNAMICART::Controller | inline
getType(std::string type) | APDYNAMICART::Controller | static
guiItemClicked(const char *itemID) | APDYNAMICART::Ctrl_StringSculptures | virtual
guiSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Ctrl_StringSculptures | virtual
initialize(DAEnvironment *p_dae, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::Ctrl_StringSculptures | virtual
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initTools() | APDYNAMICART::Controller | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEmpty() | APDYNAMICART::Controller | inline
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNodeList *poaNodeList) | APDYNAMICART::Ctrl_StringSculptures | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notify(vreckoUtils::Observable *object, void *userData) | APDYNAMICART::Ctrl_StringSculptures | virtual
Observer() | vreckoUtils::Observer | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APDYNAMICART::Controller | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::Controller | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePoA(PoA *toRemove) | APDYNAMICART::Controller |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *controllerNode) | APDYNAMICART::Ctrl_StringSculptures | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColour(osg::Vec4 newColour) | APDYNAMICART::Ctrl_StringSculptures | inlinevirtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPatternColor(float newValue, unsigned int index) | APDYNAMICART::Ctrl_StringSculptures | protected
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSectorEditing(bool enable) | APDYNAMICART::Ctrl_StringSculptures | protected
setShowAxis(bool enable) | APDYNAMICART::Ctrl_StringSculptures | protected
startSimulation() | APDYNAMICART::Ctrl_StringSculptures | protected
stopSimulation() | APDYNAMICART::Ctrl_StringSculptures | protected
switchGUIVisibility() | APDYNAMICART::Ctrl_StringSculptures | inlinevirtual
switchTools(DAToolType newType) | APDYNAMICART::Ctrl_StringSculptures | virtual
turnOff(void) | APDYNAMICART::Ctrl_StringSculptures | virtual
turnOn() | APDYNAMICART::Ctrl_StringSculptures | virtual
update() | APDYNAMICART::Ctrl_StringSculptures | virtual
updated | vrecko::Ability | protected
updatePoAs() | APDYNAMICART::Ctrl_StringSculptures | protected
updateScene() | APDYNAMICART::Ctrl_StringSculptures |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Controller() | APDYNAMICART::Controller |
~Ctrl_StringSculptures() | APDYNAMICART::Ctrl_StringSculptures |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DAEnvironment
APDYNAMICART::DAEnvironment Member List

This is the complete list of members for APDYNAMICART::DAEnvironment, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
CreateMenuAbilities() | APDYNAMICART::DAEnvironment |
DAEnvironment() | APDYNAMICART::DAEnvironment |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
enableGUI(bool enable) | APDYNAMICART::DAEnvironment |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
func typedef | APDYNAMICART::DAEnvironment |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getAutoRotationActive() const | APDYNAMICART::DAEnvironment | inline
getController(PoAType type) | APDYNAMICART::DAEnvironment |
getElapsedArtTime() | APDYNAMICART::DAEnvironment |
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getInstance() | APDYNAMICART::DAEnvironment | inlinestatic
getLeftHandOrientation() const | APDYNAMICART::DAEnvironment | inline
getLeftHandPosition() const | APDYNAMICART::DAEnvironment | inline
getLoadedArtTime() const | APDYNAMICART::DAEnvironment | inline
getName() const | vrecko::Ability | inline
getObjectSelectionActiveRight() const | APDYNAMICART::DAEnvironment | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::DAEnvironment | inline
getRightHandPosition() const | APDYNAMICART::DAEnvironment | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
leftHandEO | APDYNAMICART::DAEnvironment |
listDirectory(const string &dirpath, const string &mask, std::vector< string > *fileNames) | APDYNAMICART::DAEnvironment |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APDYNAMICART::DAEnvironment | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APDYNAMICART::DAEnvironment | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APDYNAMICART::DAEnvironment | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rightHandEO | APDYNAMICART::DAEnvironment |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | APDYNAMICART::DAEnvironment | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setAutoRotationActive(bool val) | APDYNAMICART::DAEnvironment | inline
setID(const char *pID) | vrecko::Ability |
setObjectSelectionbyRightHand(bool val) | APDYNAMICART::DAEnvironment | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setUpCustomProcessEventCallback(bool(*func)(const std::string &input_name, void *value, void *userData), void *userData) | APDYNAMICART::DAEnvironment | inline
update() | APDYNAMICART::DAEnvironment | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DAEnvironment() | APDYNAMICART::DAEnvironment |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DAGizmo
APDYNAMICART::DAGizmo Member List

This is the complete list of members for APDYNAMICART::DAGizmo, including all inherited members.

DAGizmo(osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius) | APDYNAMICART::DAGizmo |
getBinormal() | APDYNAMICART::DAGizmo | inline
getNormal() | APDYNAMICART::DAGizmo | inline
hide() | APDYNAMICART::DAGizmo |
isVisible() | APDYNAMICART::DAGizmo | inline
show() | APDYNAMICART::DAGizmo |
~DAGizmo() | APDYNAMICART::DAGizmo |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DATool
APDYNAMICART::DATool Member List

This is the complete list of members for APDYNAMICART::DATool, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate()=0 | APDYNAMICART::DATool | pure virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate()=0 | APDYNAMICART::DATool | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
toolType | APDYNAMICART::DATool | protected
turnOff()=0 | APDYNAMICART::DATool | pure virtual
turnOn()=0 | APDYNAMICART::DATool | pure virtual
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DiameterGenFactory
APDYNAMICART::DiameterGenFactory Member List

This is the complete list of members for APDYNAMICART::DiameterGenFactory, including all inherited members.

_adapters | APDYNAMICART::AdapterFactory< DiameterGenAdapter > | protected
DiameterGenFactory() | APDYNAMICART::DiameterGenFactory | inline
DiameterGenFactory(const DiameterGenFactory &orig) | APDYNAMICART::DiameterGenFactory | inline
getAdapter(const std::string &className) | APDYNAMICART::AdapterFactory< DiameterGenAdapter > | inline
getSupportedAdapters() const | APDYNAMICART::AdapterFactory< DiameterGenAdapter > | inline
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • DoublePattern
APDYNAMICART::DoublePattern Member List

This is the complete list of members for APDYNAMICART::DoublePattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Ellipse
APDYNAMICART::Ellipse Member List

This is the complete list of members for APDYNAMICART::Ellipse, including all inherited members.

_a | APDYNAMICART::Ellipse | protected
_b | APDYNAMICART::Ellipse | protected
_detail | APDYNAMICART::Ellipse | protected
_dirty | APDYNAMICART::HoopShape | protected
_samplePoints | APDYNAMICART::Ellipse | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
init() | APDYNAMICART::Ellipse | protected
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(Ellipse,"Ellipse") | APDYNAMICART::Ellipse |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
updateSamplePoints() | APDYNAMICART::Ellipse | protected
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ElongatedCircle
APDYNAMICART::ElongatedCircle Member List

This is the complete list of members for APDYNAMICART::ElongatedCircle, including all inherited members.

_detail | APDYNAMICART::ElongatedCircle | protected
_dirty | APDYNAMICART::HoopShape | protected
_distance | APDYNAMICART::ElongatedCircle | protected
_radius | APDYNAMICART::ElongatedCircle | protected
_samplePoints | APDYNAMICART::ElongatedCircle | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createCircleSide(double step) | APDYNAMICART::ElongatedCircle | protected
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
init() | APDYNAMICART::ElongatedCircle | protected
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(ElongatedCircle,"Elongated Circle") | APDYNAMICART::ElongatedCircle |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
updateSamplePoints() | APDYNAMICART::ElongatedCircle | protected
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • GradientColorAdapter
APDYNAMICART::GradientColorAdapter Member List

This is the complete list of members for APDYNAMICART::GradientColorAdapter, including all inherited members.

_colorGen | APDYNAMICART::GradientColorAdapter | protected
_colorIndex | APDYNAMICART::ColorGenAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< ColorGen > | pure virtual
ColorGenAdapter() | APDYNAMICART::ColorGenAdapter | inline
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
getColor() | APDYNAMICART::GradientColorAdapter | inlinevirtual
getColorIndex() const | APDYNAMICART::ColorGenAdapter | inline
getObject() | APDYNAMICART::GradientColorAdapter | inlinevirtual
GradientColorAdapter() | APDYNAMICART::GradientColorAdapter | inline
GradientColorAdapter(const osg::Vec4 &color1, const osg::Vec4 &color2) | APDYNAMICART::GradientColorAdapter | inline
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::GradientColorAdapter | virtual
META_DAObject(GradientColorAdapter,"Gradient") virtual void createMenu(MenuPtr menu) | APDYNAMICART::GradientColorAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::GradientColorAdapter | virtual
setColor(const osg::Vec4 &color) | APDYNAMICART::GradientColorAdapter | virtual
setColorIndex(int val) | APDYNAMICART::ColorGenAdapter | inline
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< ColorGen > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< ColorGen > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • GradientDiamAdapter
APDYNAMICART::GradientDiamAdapter Member List

This is the complete list of members for APDYNAMICART::GradientDiamAdapter, including all inherited members.

_diamGen | APDYNAMICART::GradientDiamAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
createMenu(MenuPtr menu) | APDYNAMICART::GradientDiamAdapter | virtual
APDYNAMICART::PoAAdapter::createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
getObject()=0 | APDYNAMICART::PoAAdapter< T > | pure virtual
GradientDiamAdapter() | APDYNAMICART::GradientDiamAdapter | inline
GradientDiamAdapter(double diam1, double diam2) | APDYNAMICART::GradientDiamAdapter | inline
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::GradientDiamAdapter | virtual
META_DAObject(GradientDiamAdapter,"Gradient") virtual osg | APDYNAMICART::GradientDiamAdapter | inline
pointed(bool pointed) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::GradientDiamAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::GradientDiamAdapter | virtual
update() | APDYNAMICART::PoAAdapter< T > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< T > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:58 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HandFrameAdapter
APDYNAMICART::HandFrameAdapter Member List

This is the complete list of members for APDYNAMICART::HandFrameAdapter, including all inherited members.

_rotationFrameGen | APDYNAMICART::HandFrameAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
getObject() | APDYNAMICART::HandFrameAdapter | inlinevirtual
HandFrameAdapter() | APDYNAMICART::HandFrameAdapter | inline
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::HandFrameAdapter | virtual
META_DAObject(HandFrameAdapter,"Manual") virtual void createMenu(MenuPtr menu) | APDYNAMICART::HandFrameAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
RotationFrameAdapter() | APDYNAMICART::RotationFrameAdapter | inline
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::HandFrameAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HookManager
APDYNAMICART::HookManager Member List

This is the complete list of members for APDYNAMICART::HookManager, including all inherited members.

_hooks | APDYNAMICART::HookManager | protected
_parent | APDYNAMICART::HookManager | protected
addHook(HookObject *hookObject) | APDYNAMICART::HookManager |
get() | APDYNAMICART::HookManager | inlinestatic
getHooks() const | APDYNAMICART::HookManager | inline
HookArray typedef | APDYNAMICART::HookManager |
HookManager() | APDYNAMICART::HookManager | protected
init(EnvironmentObject *parent) | APDYNAMICART::HookManager |
load(HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::HookManager |
removeAllHooks() | APDYNAMICART::HookManager |
removeHook(unsigned int index) | APDYNAMICART::HookManager |
removeHook(HookObject *hookObject) | APDYNAMICART::HookManager |
removeHooksOnHoop(Hoop *hoop) | APDYNAMICART::HookManager |
save(HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::HookManager |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HookObject
APDYNAMICART::HookObject Member List

This is the complete list of members for APDYNAMICART::HookObject, including all inherited members.

_contr | APDYNAMICART::HookObject | protected
_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_highlight | APDYNAMICART::HookObject | protected
_hoop | APDYNAMICART::HookObject | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::HookObject | virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getParentHoop() const | APDYNAMICART::HookObject | inline
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::HookObject | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HookObject | inlinevirtual
hide() | vrecko::EnvironmentObject | inline
HookObject(Controller *contr, Hoop *hoop, const osg::Vec3 &position, double width) | APDYNAMICART::HookObject |
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::HookObject | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::HookObject | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::HookObject | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::HookObject | inlinevirtual
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::HookObject | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Hoop
APDYNAMICART::Hoop Member List

This is the complete list of members for APDYNAMICART::Hoop, including all inherited members.

_actor | APDYNAMICART::Hoop | protected
_axis | APDYNAMICART::Hoop | protected
_colorGen | APDYNAMICART::Hoop | protected
_contr | APDYNAMICART::Hoop | protected
_controller | APDYNAMICART::PoA | protected
_crossSectionSpline | APDYNAMICART::Hoop | protected
_currentRotation | APDYNAMICART::Hoop | protected
_currentTransform | APDYNAMICART::Hoop | protected
_daEnvironment | APDYNAMICART::PoA | protected
_diameterGenerator | APDYNAMICART::Hoop | protected
_highlight | APDYNAMICART::Hoop | protected
_orientations | APDYNAMICART::Hoop | protected
_points | APDYNAMICART::Hoop | protected
_sectorMarker | APDYNAMICART::Hoop | protected
_shape | APDYNAMICART::Hoop | protected
_snapPointArray | APDYNAMICART::Hoop | protected
_sweepSurface | APDYNAMICART::Hoop | protected
_timeStamps | APDYNAMICART::Hoop | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createActor() | APDYNAMICART::Hoop |
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::Hoop | virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::Hoop | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_REQUEST_OUTPUT(EvokeHSLColorPicker, MessageString, MessageBool) | APDYNAMICART::Hoop | protected
deleteActor() | APDYNAMICART::Hoop |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getActor() const | APDYNAMICART::Hoop | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCachedColorGenerator() const | APDYNAMICART::Hoop | inline
getColor() | APDYNAMICART::Hoop |
getDiameter() const | APDYNAMICART::Hoop | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeadingSpline() const | APDYNAMICART::Hoop | virtual
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOrientationSamples() const | APDYNAMICART::Hoop | virtual
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPositionSamples() const | APDYNAMICART::Hoop | virtual
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSectorMarker() const | APDYNAMICART::Hoop | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getShape() const | APDYNAMICART::Hoop | inline
getSnapPointArray() | APDYNAMICART::Hoop |
getSweepSurface() const | APDYNAMICART::Hoop | inline
getTimeStamps() const | APDYNAMICART::Hoop | virtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::Hoop | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Hoop | virtual
hide() | vrecko::EnvironmentObject | inline
hideAxis() | APDYNAMICART::Hoop | inline
Hoop(Controller *controller, HoopShapePtr shape) | APDYNAMICART::Hoop |
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::Hoop | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::Hoop | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::Hoop | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setActor(NxActor *val) | APDYNAMICART::Hoop | inline
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::Hoop | virtual
setDiameter(double val) | APDYNAMICART::Hoop | inline
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setShape(HoopShapePtr val) | APDYNAMICART::Hoop | inline
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
showAxis() | APDYNAMICART::Hoop | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::Hoop | virtual
updateActor() | APDYNAMICART::Hoop |
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopGeometry
APDYNAMICART::HoopGeometry Member List

This is the complete list of members for APDYNAMICART::HoopGeometry, including all inherited members.

_brush | APDYNAMICART::HoopGeometry | protected
_bst | APDYNAMICART::HoopGeometry | protected
_crossSection | APDYNAMICART::HoopGeometry | protected
_shapeCurve | APDYNAMICART::HoopGeometry | protected
createGeometry(osg::Vec3Array *crossSectionFixPoints, osg::Vec3Array *shapeCurveFixPoints) | APDYNAMICART::HoopGeometry |
getCrossSectionGenerator() const | APDYNAMICART::HoopGeometry | inline
getShapeCurveGenerator() const | APDYNAMICART::HoopGeometry | inline
HoopGeometry(IShapeGeneratorPtr crossSection, IShapeGeneratorPtr shapeCurve) | APDYNAMICART::HoopGeometry |
setCrossSectionGenerator(IShapeGeneratorPtr crossSectionGen) | APDYNAMICART::HoopGeometry | inline
setShapeCurveGenerator(IShapeGeneratorPtr shapeCurveGen) | APDYNAMICART::HoopGeometry | inline
traits | APDYNAMICART::HoopGeometry | protected
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopShape
APDYNAMICART::HoopShape Member List

This is the complete list of members for APDYNAMICART::HoopShape, including all inherited members.

_dirty | APDYNAMICART::HoopShape | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HoopTrackerCallback
APDYNAMICART::HoopTrackerCallback Member List

This is the complete list of members for APDYNAMICART::HoopTrackerCallback, including all inherited members.

_offset | APDYNAMICART::HoopTrackerCallback | protected
_poa | APDYNAMICART::HoopTrackerCallback | protected
_scale | APDYNAMICART::HoopTrackerCallback | protected
HoopTrackerCallback(PoA *poa, const osg::Vec3 &offset, double scale) | APDYNAMICART::HoopTrackerCallback | inline
operator()(osg::Node *node, osg::NodeVisitor *nv) | APDYNAMICART::HoopTrackerCallback | inlinevirtual
update(osg::Node *node, osg::NodeVisitor *nv) | APDYNAMICART::HoopTrackerCallback | inlineprotected
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • HyperbolicPattern
APDYNAMICART::HyperbolicPattern Member List

This is the complete list of members for APDYNAMICART::HyperbolicPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IComputeStrategy
APDYNAMICART::IComputeStrategy Member List

This is the complete list of members for APDYNAMICART::IComputeStrategy, including all inherited members.

AttractorName()=0 | APDYNAMICART::IComputeStrategy | pure virtual
getDefaultSize()=0 | APDYNAMICART::IComputeStrategy | pure virtual
getNextPoint(double x, double y, double z, const Parameters &params)=0 | APDYNAMICART::IComputeStrategy | pure virtual
~IComputeStrategy() | APDYNAMICART::IComputeStrategy | inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IParameters
APDYNAMICART::IParameters Member List

This is the complete list of members for APDYNAMICART::IParameters, including all inherited members.

getParameters()=0 | APDYNAMICART::IParameters | pure virtual
~IParameters() | APDYNAMICART::IParameters | inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IShapeGenerator
APDYNAMICART::IShapeGenerator Member List

This is the complete list of members for APDYNAMICART::IShapeGenerator, including all inherited members.

generate(Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints)=0 | APDYNAMICART::IShapeGenerator | pure virtual
~IShapeGenerator() | APDYNAMICART::IShapeGenerator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IkedaParameters
APDYNAMICART::IkedaParameters Member List

This is the complete list of members for APDYNAMICART::IkedaParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • IkedaStrategy
APDYNAMICART::IkedaStrategy Member List

This is the complete list of members for APDYNAMICART::IkedaStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • JuliaAttractor
APDYNAMICART::JuliaAttractor Member List

This is the complete list of members for APDYNAMICART::JuliaAttractor, including all inherited members.

_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_params | APDYNAMICART::Attractor | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
Attractor(Controller *controller) | APDYNAMICART::Attractor | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
compute() | APDYNAMICART::JuliaAttractor | virtual
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createInstance(std::string attName, Controller *controller) | APDYNAMICART::Attractor | static
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::JuliaAttractor | virtual
APDYNAMICART::Attractor::createMenuStructure(void) const | APDYNAMICART::Attractor | inlinevirtual
createParameterSubMenu() const | APDYNAMICART::Attractor | protected
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
generate() | APDYNAMICART::Attractor |
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getAvailableAttractors() | APDYNAMICART::Attractor | static
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParameters() | APDYNAMICART::Attractor | inline
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::JuliaAttractor | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::JuliaAttractor | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
init() | APDYNAMICART::Attractor | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
JuliaAttractor(IParametersPtr parameters, Controller *controller) | APDYNAMICART::JuliaAttractor |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::Attractor | inlinevirtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::Attractor | inlinevirtual
postInitialize() | APDYNAMICART::JuliaAttractor | virtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::JuliaAttractor | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::Attractor | inlinevirtual
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSliderParameter(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | protected
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::JuliaAttractor | virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
valueChanged(float sliderPos) | APDYNAMICART::Attractor | protected
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • JuliaParameters
APDYNAMICART::JuliaParameters Member List

This is the complete list of members for APDYNAMICART::JuliaParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Line
APDYNAMICART::Line Member List

This is the complete list of members for APDYNAMICART::Line, including all inherited members.

_array | APDYNAMICART::Line | protected
_dirty | APDYNAMICART::HoopShape | protected
_length | APDYNAMICART::Line | protected
_sampledSpline | APDYNAMICART::Line | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
init() | APDYNAMICART::Line | protected
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(Line,"Rod") | APDYNAMICART::Line |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
updateSamplePoints() | APDYNAMICART::Line | protected
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LinearShapeGenerator
APDYNAMICART::LinearShapeGenerator Member List

This is the complete list of members for APDYNAMICART::LinearShapeGenerator, including all inherited members.

generate(Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints) | APDYNAMICART::LinearShapeGenerator | virtual
~IShapeGenerator() | APDYNAMICART::IShapeGenerator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Lorenz84Parameters
APDYNAMICART::Lorenz84Parameters Member List

This is the complete list of members for APDYNAMICART::Lorenz84Parameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Lorenz84Strategy
APDYNAMICART::Lorenz84Strategy Member List

This is the complete list of members for APDYNAMICART::Lorenz84Strategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LorenzParameters
APDYNAMICART::LorenzParameters Member List

This is the complete list of members for APDYNAMICART::LorenzParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • LorenzStrategy
APDYNAMICART::LorenzStrategy Member List

This is the complete list of members for APDYNAMICART::LorenzStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Mode
APDYNAMICART::Mode Member List

This is the complete list of members for APDYNAMICART::Mode, including all inherited members.

setLayout()=0 | APDYNAMICART::Mode | pure virtual
~Mode() | APDYNAMICART::Mode | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • MotionTrail
APDYNAMICART::MotionTrail Member List

This is the complete list of members for APDYNAMICART::MotionTrail, including all inherited members.

_brush | APDYNAMICART::BrushStroke | protected
_computedStrokeStartTime | APDYNAMICART::BrushStroke | protected
_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_highLightcallback | APDYNAMICART::BrushStroke | protected
_lastValidSamplePosition | APDYNAMICART::BrushStroke | protected
_leadingSpline | APDYNAMICART::BrushStroke | protected
_leadingSplineInterpolated | APDYNAMICART::BrushStroke | protected
_leadingSplineTilting | APDYNAMICART::BrushStroke | protected
_samplesOrientations | APDYNAMICART::BrushStroke | protected
_samplesPositions | APDYNAMICART::BrushStroke | protected
_samplesTimeStamps | APDYNAMICART::BrushStroke | protected
_StartTime | APDYNAMICART::BrushStroke | protected
_strokeTime | APDYNAMICART::BrushStroke | protected
_sweepSurface | APDYNAMICART::BrushStroke | protected
_timeLineDecorator | APDYNAMICART::BrushStroke | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
BrushStroke(Controller *contr, BrushPtr brush) | APDYNAMICART::BrushStroke |
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::BrushStroke | virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::BrushStroke |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_REQUEST_OUTPUT(EvokeHSLColorPicker, MessageString, MessageBool) | APDYNAMICART::BrushStroke | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
exportToFile(std::string file) | APDYNAMICART::BrushStroke |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getComputedStartTime() | APDYNAMICART::BrushStroke | inline
getDuration() | APDYNAMICART::BrushStroke |
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeadingSpline() const | APDYNAMICART::BrushStroke | inlinevirtual
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOrientationSamples() const | APDYNAMICART::BrushStroke | inlinevirtual
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPositionSamples() const | APDYNAMICART::BrushStroke | inlinevirtual
getPriority(void) const | vrecko::BaseClass | inline
getRealStartTime() | APDYNAMICART::BrushStroke | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTimeStamps() const | APDYNAMICART::BrushStroke | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::BrushStroke | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::BrushStroke | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
importControlPoints(std::vector< osg::Vec3 > *samples, std::vector< osg::Vec4 > *colours, double diameter, int usize) | APDYNAMICART::BrushStroke |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *BrushStrokeNode) | APDYNAMICART::BrushStroke | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
MotionTrail(Controller *contr, ColorGenAdapter *colorGenAdapter, DiameterGenAdapter *diamGenAdapt, SplineAdapter *crossSectionAdapter) | APDYNAMICART::MotionTrail |
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
playback(double playbackTime) | APDYNAMICART::BrushStroke |
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::BrushStroke | virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::BrushStroke | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setComputedTime(double newTime) | APDYNAMICART::BrushStroke | inline
setCrossSectionInterpolation(int interpol) | APDYNAMICART::BrushStroke |
setCrossSectionType(int type) | APDYNAMICART::BrushStroke |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setInterpolationSteps(int interpol) | APDYNAMICART::BrushStroke |
setLeadingSpline(InterpolatedSplinePtr val) | APDYNAMICART::BrushStroke | inline
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSmoothness(double smooth) | APDYNAMICART::BrushStroke |
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
switchRenderingMethod() | APDYNAMICART::BrushStroke |
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update(void) | APDYNAMICART::BrushStroke | virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
visualizeControlPoints(bool show) | APDYNAMICART::BrushStroke |
~BaseClass() | vrecko::BaseClass | virtual
~BrushStroke() | APDYNAMICART::BrushStroke |
~EnvironmentObject() | vrecko::EnvironmentObject |
~MotionTrail() | APDYNAMICART::MotionTrail |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullAttractor
APDYNAMICART::NullAttractor Member List

This is the complete list of members for APDYNAMICART::NullAttractor, including all inherited members.

_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_params | APDYNAMICART::Attractor | protected
_size | APDYNAMICART::Attractor | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
Attractor(Controller *controller) | APDYNAMICART::Attractor | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
compute() | APDYNAMICART::NullAttractor | virtual
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createInstance(std::string attName, Controller *controller) | APDYNAMICART::Attractor | static
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::NullAttractor | inlinevirtual
APDYNAMICART::Attractor::createMenuStructure(void) const | APDYNAMICART::Attractor | inlinevirtual
createParameterSubMenu() const | APDYNAMICART::Attractor | protected
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
generate() | APDYNAMICART::Attractor |
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getAvailableAttractors() | APDYNAMICART::Attractor | static
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParameters() | APDYNAMICART::Attractor | inline
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::Attractor | inlinevirtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | inlinevirtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
init() | APDYNAMICART::Attractor | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::Attractor | inlinevirtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
NullAttractor(Controller *controller) | APDYNAMICART::NullAttractor |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::Attractor | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::NullAttractor | inlinevirtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::Attractor | inlinevirtual
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSliderParameter(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | protected
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::Attractor | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
valueChanged(float sliderPos) | APDYNAMICART::Attractor | protected
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullHoopShape
APDYNAMICART::NullHoopShape Member List

This is the complete list of members for APDYNAMICART::NullHoopShape, including all inherited members.

_dirty | APDYNAMICART::HoopShape | protected
_spline | APDYNAMICART::HoopShape | protected
clone() | APDYNAMICART::NullHoopShape | inlinevirtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName() | APDYNAMICART::NullHoopShape | inlinevirtual
HoopShape() | APDYNAMICART::HoopShape | inline
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::NullHoopShape | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::NullHoopShape | inlinevirtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullParameters
APDYNAMICART::NullParameters Member List

This is the complete list of members for APDYNAMICART::NullParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullPattern
APDYNAMICART::NullPattern Member List

This is the complete list of members for APDYNAMICART::NullPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullShapeGenerator
APDYNAMICART::NullShapeGenerator Member List

This is the complete list of members for APDYNAMICART::NullShapeGenerator, including all inherited members.

generate(Vec3ArrayPtr inputPoints, u_int numberOfOutputPoints) | APDYNAMICART::NullShapeGenerator | virtual
~IShapeGenerator() | APDYNAMICART::IShapeGenerator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • NullStrategy
APDYNAMICART::NullStrategy Member List

This is the complete list of members for APDYNAMICART::NullStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • OrdinaryAttractor
APDYNAMICART::OrdinaryAttractor Member List

This is the complete list of members for APDYNAMICART::OrdinaryAttractor, including all inherited members.

_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_params | APDYNAMICART::Attractor | protected
_size | APDYNAMICART::Attractor | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
Attractor(Controller *controller) | APDYNAMICART::Attractor | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
colorChanged(const char *sliderID, float sliderPos) | APDYNAMICART::OrdinaryAttractor |
compute() | APDYNAMICART::OrdinaryAttractor | virtual
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createInstance(std::string attName, Controller *controller) | APDYNAMICART::Attractor | static
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::OrdinaryAttractor | virtual
APDYNAMICART::Attractor::createMenuStructure(void) const | APDYNAMICART::Attractor | inlinevirtual
createParameterSubMenu() const | APDYNAMICART::Attractor | protected
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
generate() | APDYNAMICART::Attractor |
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getAvailableAttractors() | APDYNAMICART::Attractor | static
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getIterationCount() | APDYNAMICART::OrdinaryAttractor | inline
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParameters() | APDYNAMICART::Attractor | inline
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::OrdinaryAttractor | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::OrdinaryAttractor | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
init() | APDYNAMICART::OrdinaryAttractor | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::OrdinaryAttractor | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
OrdinaryAttractor(IComputeStrategyPtr computeStrategy, IParametersPtr parameters, Controller *controller) | APDYNAMICART::OrdinaryAttractor |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::Attractor | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::OrdinaryAttractor | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::Attractor | inlinevirtual
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSliderParameter(const char *sliderID, float sliderPos) | APDYNAMICART::Attractor | protected
APDYNAMICART::Attractor::setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::OrdinaryAttractor | virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
valueChanged(float sliderPos) | APDYNAMICART::Attractor | protected
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLControllerTool
APDYNAMICART::PLControllerTool Member List

This is the complete list of members for APDYNAMICART::PLControllerTool, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::PLControllerTool | inlinevirtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clipNode | APDYNAMICART::PLControllerTool | protected
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DAArea | APDYNAMICART::PLControllerTool | protected
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::PLControllerTool | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lowClipPlane | APDYNAMICART::PLControllerTool | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PLControllerTool() | APDYNAMICART::PLControllerTool |
postInitialize(void) | APDYNAMICART::PLControllerTool | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
toolType | APDYNAMICART::DATool | protected
topClipPlane | APDYNAMICART::PLControllerTool | protected
turnOff() | APDYNAMICART::PLControllerTool | inlinevirtual
turnOn() | APDYNAMICART::PLControllerTool | inlinevirtual
update() | APDYNAMICART::PLControllerTool | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~PLControllerTool() | APDYNAMICART::PLControllerTool | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLMagnetTool
APDYNAMICART::PLMagnetTool Member List

This is the complete list of members for APDYNAMICART::PLMagnetTool, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::PLMagnetTool | inlinevirtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clipNode | APDYNAMICART::PLMagnetTool | protected
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DAArea | APDYNAMICART::PLMagnetTool | protected
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::PLMagnetTool | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PLMagnetTool() | APDYNAMICART::PLMagnetTool |
postInitialize(void) | APDYNAMICART::PLMagnetTool | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::PLMagnetTool | inlinevirtual
turnOn() | APDYNAMICART::PLMagnetTool | inlinevirtual
update() | APDYNAMICART::PLMagnetTool | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~PLMagnetTool() | APDYNAMICART::PLMagnetTool | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PLNestTool
APDYNAMICART::PLNestTool Member List

This is the complete list of members for APDYNAMICART::PLNestTool, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::PLNestTool | inlinevirtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clipNode | APDYNAMICART::PLNestTool | protected
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DAArea | APDYNAMICART::PLNestTool | protected
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::PLNestTool | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PLNestTool() | APDYNAMICART::PLNestTool |
postInitialize(void) | APDYNAMICART::PLNestTool | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::PLNestTool | inlinevirtual
turnOn() | APDYNAMICART::PLNestTool | inlinevirtual
update() | APDYNAMICART::PLNestTool | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~PLNestTool() | APDYNAMICART::PLNestTool | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Component
APDYNAMICART::PS_Component Member List

This is the complete list of members for APDYNAMICART::PS_Component, including all inherited members.

PS_Component() APDYNAMICART::PS_Component
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Face
APDYNAMICART::PS_Face Member List

This is the complete list of members for APDYNAMICART::PS_Face, including all inherited members.

_geometry | APDYNAMICART::PS_Face | protected
_highlight | APDYNAMICART::PS_Face | protected
_vertices | APDYNAMICART::PS_Face | protected
pointed(bool pointed) | APDYNAMICART::PS_Face | inline
PS_Face(osg::ref_ptr< osg::Vec3Array > vertices) | APDYNAMICART::PS_Face |
updateColors(osg::Vec4 color) | APDYNAMICART::PS_Face |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_FacePlane
APDYNAMICART::PS_FacePlane Member List

This is the complete list of members for APDYNAMICART::PS_FacePlane, including all inherited members.

ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
pointed() | APDYNAMICART::PS_FacePlane |
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
PS_FacePlane(double distance, osg::Quat rot) | APDYNAMICART::PS_FacePlane |
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setFace(PS_FacePtr face) | APDYNAMICART::PS_FacePlane |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update(void) | vrecko::BaseClass | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Layer
APDYNAMICART::PS_Layer Member List

This is the complete list of members for APDYNAMICART::PS_Layer, including all inherited members.

_component | APDYNAMICART::PS_Layer | protected
_opacity | APDYNAMICART::PS_Layer | protected
_polyhedron | APDYNAMICART::PS_Layer | protected
_visuals | APDYNAMICART::PS_Layer | protected
activate() | APDYNAMICART::PS_Layer |
deactivate() | APDYNAMICART::PS_Layer |
getOpacity() const | APDYNAMICART::PS_Layer | inline
PS_Layer(osg::Group *group, const std::string &polyhedronName) | APDYNAMICART::PS_Layer |
setOpacity(double val) | APDYNAMICART::PS_Layer | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Polyhedron
APDYNAMICART::PS_Polyhedron Member List

This is the complete list of members for APDYNAMICART::PS_Polyhedron, including all inherited members.

createFacePlanes() | APDYNAMICART::PS_Polyhedron
initialize(std::string name, osg::ref_ptr< osg::MatrixTransform > layerNode) | APDYNAMICART::PS_Polyhedron
loadfromXML(std::string fileName) | APDYNAMICART::PS_Polyhedron
PS_Polyhedron(const string &name) | APDYNAMICART::PS_Polyhedron
setComponent(PS_ComponentPtr compo) | APDYNAMICART::PS_Polyhedron
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PS_Symmetry
APDYNAMICART::PS_Symmetry Member List

This is the complete list of members for APDYNAMICART::PS_Symmetry, including all inherited members.

getAxes() | APDYNAMICART::PS_Symmetry | inline
getNumberofFaces() | APDYNAMICART::PS_Symmetry | inline
load(std::string fileName) | APDYNAMICART::PS_Symmetry |
makeInstances(std::vector< osg::Vec3 > *points) | APDYNAMICART::PS_Symmetry |
makeRotations() | APDYNAMICART::PS_Symmetry |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Painted
APDYNAMICART::Painted Member List

This is the complete list of members for APDYNAMICART::Painted, including all inherited members.

_dirty | APDYNAMICART::HoopShape | protected
_points | APDYNAMICART::Painted | protected
_sampledSpline | APDYNAMICART::Painted | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::Painted | virtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(Painted,"Painted") | APDYNAMICART::Painted |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
setPointArray(Vec3ArrayPtr array) | APDYNAMICART::Painted | inline
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Pattern
APDYNAMICART::Pattern Member List

This is the complete list of members for APDYNAMICART::Pattern, including all inherited members.

generate(Vec3ArrayPtr left, Vec3ArrayPtr right)=0 | APDYNAMICART::Pattern | pure virtual
getName()=0 | APDYNAMICART::Pattern | pure virtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternBase
APDYNAMICART::PatternBase Member List

This is the complete list of members for APDYNAMICART::PatternBase, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
compute(Vec3ArrayPtr left, Vec3ArrayPtr right)=0 | APDYNAMICART::PatternBase | protectedpure virtual
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getName()=0 | APDYNAMICART::PatternBase | pure virtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternFactory
APDYNAMICART::PatternFactory Member List

This is the complete list of members for APDYNAMICART::PatternFactory, including all inherited members.

getAvaiablePatterns() | APDYNAMICART::PatternFactory | static
getPattern(const std::string &name) | APDYNAMICART::PatternFactory | static
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PatternsGeode
APDYNAMICART::PatternsGeode Member List

This is the complete list of members for APDYNAMICART::PatternsGeode, including all inherited members.

getPatternsPointsArray() const | APDYNAMICART::PatternsGeode | inline
getStringLineWidth() const | APDYNAMICART::PatternsGeode | inline
META_Node(APDYNAMICART, PatternsGeode) | APDYNAMICART::PatternsGeode |
PatternsGeode() | APDYNAMICART::PatternsGeode |
PatternsGeode(const PatternsGeode &, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY) | APDYNAMICART::PatternsGeode |
setStringLineWidth(float val) | APDYNAMICART::PatternsGeode | inline
setVertexArray(Vec3ArrayPtr points) | APDYNAMICART::PatternsGeode | inline
updateGeometry() | APDYNAMICART::PatternsGeode |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PerlinLines
APDYNAMICART::PerlinLines Member List

This is the complete list of members for APDYNAMICART::PerlinLines, including all inherited members.

_blue | APDYNAMICART::PerlinLines | protected
_boundingCreated | APDYNAMICART::PerlinLines | protected
_boundingSize | APDYNAMICART::PerlinLines | protected
_boundingUsed | APDYNAMICART::PerlinLines | protected
_boundingVisible | APDYNAMICART::PerlinLines | protected
_boxColorArray | APDYNAMICART::PerlinLines | protected
_boxGeode | APDYNAMICART::PerlinLines | protected
_boxMaterial | APDYNAMICART::PerlinLines | protected
_boxOSGState | APDYNAMICART::PerlinLines | protected
_changedBlue | APDYNAMICART::PerlinLines | protected
_changedGreen | APDYNAMICART::PerlinLines | protected
_changedRed | APDYNAMICART::PerlinLines | protected
_controller | APDYNAMICART::PoA | protected
_controllerCoords | APDYNAMICART::PerlinLines | protected
_controllerUsed | APDYNAMICART::PerlinLines | protected
_daArea | APDYNAMICART::PerlinLines | protected
_daEnvironment | APDYNAMICART::PoA | protected
_green | APDYNAMICART::PerlinLines | protected
_interpolatedLines | APDYNAMICART::PerlinLines | protected
_interpolationCount | APDYNAMICART::PerlinLines | protected
_length | APDYNAMICART::PerlinLines | protected
_lineGeode | APDYNAMICART::PerlinLines | protected
_lineGeometry | APDYNAMICART::PerlinLines | protected
_lines | APDYNAMICART::PerlinLines | protected
_linesColorArray | APDYNAMICART::PerlinLines | protected
_linesMaterial | APDYNAMICART::PerlinLines | protected
_linewidth | APDYNAMICART::PerlinLines | protected
_magnetCoords | APDYNAMICART::PerlinLines | protected
_magnetCreated | APDYNAMICART::PerlinLines | protected
_magnetON | APDYNAMICART::PerlinLines | protected
_magnetSize | APDYNAMICART::PerlinLines | protected
_magnetUsed | APDYNAMICART::PerlinLines | protected
_newLinesColorArray | APDYNAMICART::PerlinLines | protected
_OSGState | APDYNAMICART::PerlinLines | protected
_p | APDYNAMICART::PerlinLines | protected
_paused | APDYNAMICART::PerlinLines | protected
_pointed | APDYNAMICART::PerlinLines | protected
_red | APDYNAMICART::PerlinLines | protected
_request | APDYNAMICART::PerlinLines | protected
_somethingChaned | APDYNAMICART::PerlinLines | protected
_speed | APDYNAMICART::PerlinLines | protected
_trigger | APDYNAMICART::PerlinLines | protected
_unusedMagnetCoords | APDYNAMICART::PerlinLines | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
changedInterpolation | APDYNAMICART::PerlinLines | protected
changedLength | APDYNAMICART::PerlinLines | protected
changedSpeed | APDYNAMICART::PerlinLines | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMagnet(EnvironmentObject *daarea, bool first) | APDYNAMICART::PerlinLines | inline
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::PerlinLines | virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
draw() | APDYNAMICART::PerlinLines |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstTimeUpdate | APDYNAMICART::PerlinLines | protected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getInterpolationCount() | APDYNAMICART::PerlinLines | inline
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getLength() | APDYNAMICART::PerlinLines | inline
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getSpeed() | APDYNAMICART::PerlinLines | inline
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
gradient | APDYNAMICART::PerlinLines | protected
GUIItemClicked(const char *itemID) | APDYNAMICART::PerlinLines | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PerlinLines | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
interpolate(double a, double b, double c) | APDYNAMICART::PerlinLines |
interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0=osg::Vec3(0.0, 0.0, 0.0), osg::Vec3 point3=osg::Vec3(0.0, 0.0, 0.0)) | APDYNAMICART::PerlinLines |
interpolateVec3(osg::Vec3Array *controlPoints, osg::Vec3Array *interpolatedPoints, int p_steps) | APDYNAMICART::PerlinLines |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::PerlinLines | inlinevirtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
magnetEO | APDYNAMICART::PerlinLines | protected
magnetGeode | APDYNAMICART::PerlinLines | protected
magnetMaterial | APDYNAMICART::PerlinLines | protected
magnetStateSet | APDYNAMICART::PerlinLines | protected
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
particlesEO | APDYNAMICART::PerlinLines | protected
pause() | APDYNAMICART::PerlinLines | inline
PerlinLines(Controller *contr, int numberOfLines, double x, double y, double z) | APDYNAMICART::PerlinLines |
perlinNoise(osg::Vec3 temp) | APDYNAMICART::PerlinLines |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::PerlinLines | virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
random(double min, double max) | APDYNAMICART::PerlinLines | inline
recalculateColorInterpolation() | APDYNAMICART::PerlinLines |
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PerlinLines | inlinevirtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBounding(float boundingSize, bool first) | APDYNAMICART::PerlinLines | inline
setBoundingVisible() | APDYNAMICART::PerlinLines | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColor(osg::Vec4 newColour) | APDYNAMICART::PerlinLines | inline
setColor(osg::Vec3 color) | APDYNAMICART::PerlinLines | inline
setColor(float r, float g, float b) | APDYNAMICART::PerlinLines | inline
setController(osg::Vec3 vektor) | APDYNAMICART::PerlinLines |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setInterpolationCount(int interpolationCount) | APDYNAMICART::PerlinLines | inline
setLength(int length) | APDYNAMICART::PerlinLines | inline
setLineParameters(int count) | APDYNAMICART::PerlinLines |
setLinesParameters() | APDYNAMICART::PerlinLines |
setMagnet(osg::Vec3 coordinates, float magnetSize) | APDYNAMICART::PerlinLines | inline
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSpeed(int speed) | APDYNAMICART::PerlinLines | inline
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
smooth(osg::Vec3 temp, double sx, double sy, double sz) | APDYNAMICART::PerlinLines |
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
unsetBounding() | APDYNAMICART::PerlinLines | inline
unsetController() | APDYNAMICART::PerlinLines | inline
unsetMagnet() | APDYNAMICART::PerlinLines | inline
update() | APDYNAMICART::PerlinLines | virtual
updateControllerPosition(osg::Vec3 vektor) | APDYNAMICART::PerlinLines | inline
updateMagnetPosition(osg::Vec3 vektor, float size) | APDYNAMICART::PerlinLines |
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
Vec3Ptr typedef | APDYNAMICART::PerlinLines | protected
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PerlinLines() | APDYNAMICART::PerlinLines |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PhysXManager
APDYNAMICART::PhysXManager Member List

This is the complete list of members for APDYNAMICART::PhysXManager, including all inherited members.

_deltaTime | APDYNAMICART::PhysXManager | protected
_joints | APDYNAMICART::PhysXManager | protected
_linearVelocity | APDYNAMICART::PhysXManager | protected
_parameters | APDYNAMICART::PhysXManager | protected
_physicsSDK | APDYNAMICART::PhysXManager | protected
_ropeLinks | APDYNAMICART::PhysXManager | protected
_ropeSegs | APDYNAMICART::PhysXManager | protected
_scene | APDYNAMICART::PhysXManager | protected
_simulationRunning | APDYNAMICART::PhysXManager | protected
addForceToHoop(HoopPtr hoop, const osg::Vec3 &direction) | APDYNAMICART::PhysXManager |
addHoopActorToScene(Hoop *hoop, NxVec3 linearVelocity=NxVec3(0.2, 0.0,-1.0)) | APDYNAMICART::PhysXManager |
createCapsule(const NxVec3 &pos, const NxReal height, const NxReal radius) | APDYNAMICART::PhysXManager | protected
createRope(HoopPtr hoop, const osg::Vec3 &pos, double segHeight, double radius, unsigned int segments) | APDYNAMICART::PhysXManager |
createRopeSphericalJoint(NxActor *a0, NxActor *a1, const NxVec3 &globalAnchor, const NxVec3 &globalAxis) | APDYNAMICART::PhysXManager | protected
createScene() | APDYNAMICART::PhysXManager |
get() | APDYNAMICART::PhysXManager | inlinestatic
getDAMatrix() | APDYNAMICART::PhysXManager | inlinestatic
getPhysicsResult() | APDYNAMICART::PhysXManager |
getRopeActors() const | APDYNAMICART::PhysXManager |
getSimualtionParameters() | APDYNAMICART::PhysXManager | inline
init() | APDYNAMICART::PhysXManager |
isRunning() const | APDYNAMICART::PhysXManager | inline
PhysXManager() | APDYNAMICART::PhysXManager | protected
releaseHoopActor(HoopPtr hoop) | APDYNAMICART::PhysXManager |
releaseHoopJoints() | APDYNAMICART::PhysXManager |
releasePhysics() | APDYNAMICART::PhysXManager |
resetScene() | APDYNAMICART::PhysXManager |
setActorOrientation(HoopPtr hoop) | APDYNAMICART::PhysXManager |
setActorPosition(HoopPtr hoop) | APDYNAMICART::PhysXManager |
setSimulationRun(bool val) | APDYNAMICART::PhysXManager | inline
setStringJoints(HoopPtr first, HoopPtr second, Vec3ArrayPtr points) | APDYNAMICART::PhysXManager |
startPhysics() | APDYNAMICART::PhysXManager |
toNxQuat(const osg::Quat &qRot) | APDYNAMICART::PhysXManager | inlinestatic
toNxVec3(const osg::Vec3 &point) | APDYNAMICART::PhysXManager | inlinestatic
toOsgQuat(const NxQuat &qRot) | APDYNAMICART::PhysXManager | inlinestatic
toOsgVec3(const NxVec3 &point) | APDYNAMICART::PhysXManager | inlinestatic
transformToLocalCoord(Hoop *hoop, const osg::Vec3 &point) | APDYNAMICART::PhysXManager | inlineprotected
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PickoverParameters
APDYNAMICART::PickoverParameters Member List

This is the complete list of members for APDYNAMICART::PickoverParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PickoverStrategy
APDYNAMICART::PickoverStrategy Member List

This is the complete list of members for APDYNAMICART::PickoverStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoA
APDYNAMICART::PoA Member List

This is the complete list of members for APDYNAMICART::PoA, including all inherited members.

_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const =0 | APDYNAMICART::PoA | pure virtual
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID)=0 | APDYNAMICART::PoA | pure virtual
GUISliderChanged(const char *sliderID, float sliderPos)=0 | APDYNAMICART::PoA | pure virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::PoA | pure virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed)=0 | APDYNAMICART::PoA | pure virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::PoA | pure virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update()=0 | APDYNAMICART::PoA | pure virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoAAdapter
APDYNAMICART::PoAAdapter< T > Member List

This is the complete list of members for APDYNAMICART::PoAAdapter< T >, including all inherited members.

classDescription() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< T > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
getObject()=0 | APDYNAMICART::PoAAdapter< T > | pure virtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
pointed(bool pointed) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< T > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< T > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< T > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoAState
APDYNAMICART::PoAState Member List

This is the complete list of members for APDYNAMICART::PoAState, including all inherited members.

_stateMap | APDYNAMICART::PoAState | protected
PosRot typedef | APDYNAMICART::PoAState | protected
removeState(ref_ptr_PoA poa) | APDYNAMICART::PoAState | inline
restoreAllPoAStates() | APDYNAMICART::PoAState | inline
saveState(ref_ptr_PoA poa) | APDYNAMICART::PoAState | inline
StateMap typedef | APDYNAMICART::PoAState | protected
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PoB
APDYNAMICART::PoB Member List

This is the complete list of members for APDYNAMICART::PoB, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clicked()=0 | APDYNAMICART::PoB | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getpobName() | APDYNAMICART::PoB | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getTarget() | APDYNAMICART::PoB | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoBNode)=0 | APDYNAMICART::PoB | pure virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PoB(const char *abName) | APDYNAMICART::PoB |
pobName | APDYNAMICART::PoB | protected
pointed(bool pointed)=0 | APDYNAMICART::PoB | pure virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoBNode)=0 | APDYNAMICART::PoB | pure virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
targetName | APDYNAMICART::PoB | protected
update()=0 | APDYNAMICART::PoB | pure virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PoB() | APDYNAMICART::PoB |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolyhedraSculpture
APDYNAMICART::PolyhedraSculpture Member List

This is the complete list of members for APDYNAMICART::PolyhedraSculpture, including all inherited members.

_activeLayer | APDYNAMICART::PolyhedraSculpture | protected
_contr | APDYNAMICART::PolyhedraSculpture | protected
_controller | APDYNAMICART::PoA | protected
_daEnvironment | APDYNAMICART::PoA | protected
_layers | APDYNAMICART::PolyhedraSculpture | protected
_updateFlag | APDYNAMICART::PoA | protected
ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addAndSwitchLayer(const string &polyhedronName) | APDYNAMICART::PolyhedraSculpture |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addLayer(const string &polyhedronName) | APDYNAMICART::PolyhedraSculpture |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
createMenuStructure(osg::ref_ptr< vreckoUtils::MenuBase > parentMenu) const | APDYNAMICART::PolyhedraSculpture | virtual
createNewShowHideMenu() const | APDYNAMICART::PolyhedraSculpture | protected
DECLARE_INPUT(Colour, MessageVec4) | APDYNAMICART::PoA |
vrecko::EnvironmentObject::DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
vrecko::EnvironmentObject::DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLeftHandOrientation() const | APDYNAMICART::PoA | virtual
getLeftHandPosition() const | APDYNAMICART::PoA | virtual
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRightHandOrientation() const | APDYNAMICART::PoA | virtual
getRightHandPosition() const | APDYNAMICART::PoA | virtual
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUpdateFlag() | APDYNAMICART::PoA | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
GUIItemClicked(const char *itemID) | APDYNAMICART::PolyhedraSculpture | virtual
GUISliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PolyhedraSculpture | virtual
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::PolyhedraSculpture | virtual
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
PoA(Controller *contr) | APDYNAMICART::PoA |
pointed(bool pointed) | APDYNAMICART::PolyhedraSculpture | inlinevirtual
PolyhedraSculpture(Controller *controller, const string &polyhedronName) | APDYNAMICART::PolyhedraSculpture |
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PolyhedraSculpture | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
setUpdateFlag(PoAUpdateType newType) | APDYNAMICART::PoA |
show() | vrecko::EnvironmentObject | inline
switchToLayer(unsigned int number) | APDYNAMICART::PolyhedraSculpture |
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update() | APDYNAMICART::PolyhedraSculpture | virtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~PoA() | APDYNAMICART::PoA |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolyhedronFactory
APDYNAMICART::PolyhedronFactory Member List

This is the complete list of members for APDYNAMICART::PolyhedronFactory, including all inherited members.

getAvaiablePolyhedronNames() | APDYNAMICART::PolyhedronFactory | inlinestatic
getPolyhedron(const std::string &name) | APDYNAMICART::PolyhedronFactory | inlinestatic
isValidName(const std::string &name) | APDYNAMICART::PolyhedronFactory | inlinestatic
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolynomialParameters
APDYNAMICART::PolynomialParameters Member List

This is the complete list of members for APDYNAMICART::PolynomialParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • PolynomialStrategy
APDYNAMICART::PolynomialStrategy Member List

This is the complete list of members for APDYNAMICART::PolynomialStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RMFrameAdapter
APDYNAMICART::RMFrameAdapter Member List

This is the complete list of members for APDYNAMICART::RMFrameAdapter, including all inherited members.

_rotationFrameGen | APDYNAMICART::RMFrameAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
getObject() | APDYNAMICART::RMFrameAdapter | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::RMFrameAdapter | virtual
META_DAObject(RMFrameAdapter,"Automatic") virtual void createMenu(MenuPtr menu) | APDYNAMICART::RMFrameAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
RMFrameAdapter() | APDYNAMICART::RMFrameAdapter | inline
RotationFrameAdapter() | APDYNAMICART::RotationFrameAdapter | inline
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::RMFrameAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Rectangle
APDYNAMICART::Rectangle Member List

This is the complete list of members for APDYNAMICART::Rectangle, including all inherited members.

_dirty | APDYNAMICART::HoopShape | protected
_height | APDYNAMICART::Rectangle | protected
_samplePoints | APDYNAMICART::Rectangle | protected
_scale | APDYNAMICART::Rectangle | protected
_spline | APDYNAMICART::HoopShape | protected
_width | APDYNAMICART::Rectangle | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
init() | APDYNAMICART::Rectangle | protected
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(Rectangle,"Rectangle") | APDYNAMICART::Rectangle |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
updateSamplePoints() | APDYNAMICART::Rectangle | protected
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RectangularSplineAdapter
APDYNAMICART::RectangularSplineAdapter Member List

This is the complete list of members for APDYNAMICART::RectangularSplineAdapter, including all inherited members.

_spline | APDYNAMICART::RectangularSplineAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
createMenu(MenuPtr menu) | APDYNAMICART::RectangularSplineAdapter | virtual
APDYNAMICART::SplineAdapter::createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
getObject() | APDYNAMICART::RectangularSplineAdapter | inlinevirtual
init() | APDYNAMICART::RectangularSplineAdapter |
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
META_DAObject(RectangularSplineAdapter,"Flat") | APDYNAMICART::RectangularSplineAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
RectangularSplineAdapter(double width, double height) | APDYNAMICART::RectangularSplineAdapter |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::RectangularSplineAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< Spline > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RegularPolygon
APDYNAMICART::RegularPolygon Member List

This is the complete list of members for APDYNAMICART::RegularPolygon, including all inherited members.

_dirty | APDYNAMICART::HoopShape | protected
_rps | APDYNAMICART::RegularPolygon | protected
_scale | APDYNAMICART::RegularPolygon | protected
_spline | APDYNAMICART::HoopShape | protected
clone()=0 | APDYNAMICART::HoopShape | pure virtual
createMenu(MenuPtr parent) const | APDYNAMICART::HoopShape | inlinevirtual
dirty(bool enable=true) | APDYNAMICART::HoopShape | inlinevirtual
getLeadingSpline() | APDYNAMICART::HoopShape | inlinevirtual
getName()=0 | APDYNAMICART::HoopShape | pure virtual
HoopShape() | APDYNAMICART::HoopShape | inline
isDirty() | APDYNAMICART::HoopShape | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::HoopShape | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode)=0 | APDYNAMICART::HoopShape | pure virtual
META_HoopShapeObject(RegularPolygon,"Regular polygon") | APDYNAMICART::RegularPolygon |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode)=0 | APDYNAMICART::HoopShape | pure virtual
setLeadingSpline(SplinePtr val) | APDYNAMICART::HoopShape | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::HoopShape | inlinevirtual
~HoopShape() | APDYNAMICART::HoopShape | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RosslerParameters
APDYNAMICART::RosslerParameters Member List

This is the complete list of members for APDYNAMICART::RosslerParameters, including all inherited members.

~IParameters() APDYNAMICART::IParameters inlinevirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RosslerStrategy
APDYNAMICART::RosslerStrategy Member List

This is the complete list of members for APDYNAMICART::RosslerStrategy, including all inherited members.

~IComputeStrategy() APDYNAMICART::IComputeStrategy inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RotationFrameAdapter
APDYNAMICART::RotationFrameAdapter Member List

This is the complete list of members for APDYNAMICART::RotationFrameAdapter, including all inherited members.

classDescription() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
getObject()=0 | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | pure virtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
pointed(bool pointed) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
RotationFrameAdapter() | APDYNAMICART::RotationFrameAdapter | inline
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< RotationFrameGenerator > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RotationFrameFactory
APDYNAMICART::RotationFrameFactory Member List

This is the complete list of members for APDYNAMICART::RotationFrameFactory, including all inherited members.

_adapters | APDYNAMICART::AdapterFactory< RotationFrameAdapter > | protected
getAdapter(const std::string &className) | APDYNAMICART::AdapterFactory< RotationFrameAdapter > | inline
getSupportedAdapters() const | APDYNAMICART::AdapterFactory< RotationFrameAdapter > | inline
RotationFrameFactory() | APDYNAMICART::RotationFrameFactory | inline
RotationFrameFactory(const RotationFrameFactory &orig) | APDYNAMICART::RotationFrameFactory | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • RoundedSplineAdapter
APDYNAMICART::RoundedSplineAdapter Member List

This is the complete list of members for APDYNAMICART::RoundedSplineAdapter, including all inherited members.

_spline | APDYNAMICART::RoundedSplineAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
createMenu(MenuPtr menu) | APDYNAMICART::RoundedSplineAdapter | virtual
APDYNAMICART::SplineAdapter::createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
getObject() | APDYNAMICART::RoundedSplineAdapter | inlinevirtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
META_DAObject(RoundedSplineAdapter,"Rounded") | APDYNAMICART::RoundedSplineAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
RoundedSplineAdapter(double diameter, int segmentCount) | APDYNAMICART::RoundedSplineAdapter | inline
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::RoundedSplineAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::RoundedSplineAdapter | virtual
update() | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< Spline > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SectorManager
APDYNAMICART::SectorManager Member List

This is the complete list of members for APDYNAMICART::SectorManager, including all inherited members.

_defaultPatternName | APDYNAMICART::SectorManager | protected
_sectorInfoList | APDYNAMICART::SectorManager | protected
addSector(SectorPtr sector, HoopPtr hoop) | APDYNAMICART::SectorManager |
getHoop(unsigned int index) | APDYNAMICART::SectorManager |
getInstance() | APDYNAMICART::SectorManager | inlinestatic
getNumSectors() | APDYNAMICART::SectorManager |
getPattern(unsigned int index) | APDYNAMICART::SectorManager |
getSector(unsigned int index) | APDYNAMICART::SectorManager |
getSectorInfoList() const | APDYNAMICART::SectorManager | inline
getSectorInfoList() | APDYNAMICART::SectorManager | inline
load(HoopPtr hoop, int sectorsCount, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *PoANode) | APDYNAMICART::SectorManager |
removeAllSectorsOnHoop(HoopPtr hoop) | APDYNAMICART::SectorManager |
removeSector(unsigned int index) | APDYNAMICART::SectorManager |
save(HoopPtr hoop, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::SectorManager |
SectorInfoList typedef | APDYNAMICART::SectorManager |
SectorManager() | APDYNAMICART::SectorManager | protected
setDefaultPattern(PatternPtr pattern) | APDYNAMICART::SectorManager |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ShapeFactory
APDYNAMICART::ShapeFactory Member List

This is the complete list of members for APDYNAMICART::ShapeFactory, including all inherited members.

getAvaiableHoopShapes() | APDYNAMICART::ShapeFactory | inlinestatic
getHoopShape(const std::string &name) | APDYNAMICART::ShapeFactory | inlinestatic
getShapeGenerator(const std::string &name) | APDYNAMICART::ShapeFactory | static
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SimpleBox
APDYNAMICART::SimpleBox Member List

This is the complete list of members for APDYNAMICART::SimpleBox, including all inherited members.

ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
set(osg::Vec3 point1, osg::Vec3 point2) | APDYNAMICART::SimpleBox |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setColour(osg::Vec4 colour) | APDYNAMICART::SimpleBox |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setHeight(double posY, double height) | APDYNAMICART::SimpleBox |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
show() | vrecko::EnvironmentObject | inline
SimpleBox(osg::Vec3 position, osg::Vec3 size, bool movable=true, osg::Vec4 colour=osg::Vec4(1.0, 1.0, 1.0, 1.0)) | APDYNAMICART::SimpleBox |
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update(void) | vrecko::BaseClass | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
~SimpleBox() | APDYNAMICART::SimpleBox |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplineAdapter
APDYNAMICART::SplineAdapter Member List

This is the complete list of members for APDYNAMICART::SplineAdapter, including all inherited members.

classDescription() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
getObject()=0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
pointed(bool pointed) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *poaNode) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
~PoAAdapter() | APDYNAMICART::PoAAdapter< Spline > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplineFactory
APDYNAMICART::SplineFactory Member List

This is the complete list of members for APDYNAMICART::SplineFactory, including all inherited members.

_adapters | APDYNAMICART::AdapterFactory< SplineAdapter > | protected
getAdapter(const std::string &className) | APDYNAMICART::AdapterFactory< SplineAdapter > | inline
getSupportedAdapters() const | APDYNAMICART::AdapterFactory< SplineAdapter > | inline
SplineFactory() | APDYNAMICART::SplineFactory | inline
SplineFactory(const SplineFactory &orig) | APDYNAMICART::SplineFactory | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplitPattern
APDYNAMICART::SplitPattern Member List

This is the complete list of members for APDYNAMICART::SplitPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SplitReversePattern
APDYNAMICART::SplitReversePattern Member List

This is the complete list of members for APDYNAMICART::SplitReversePattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • StandardPattern
APDYNAMICART::StandardPattern Member List

This is the complete list of members for APDYNAMICART::StandardPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Stroke
APDYNAMICART::Stroke Member List

This is the complete list of members for APDYNAMICART::Stroke, including all inherited members.

getLeadingSpline() const =0 | APDYNAMICART::Stroke | pure virtual
getOrientationSamples() const =0 | APDYNAMICART::Stroke | pure virtual
getPositionSamples() const =0 | APDYNAMICART::Stroke | pure virtual
getTimeStamps() const =0 | APDYNAMICART::Stroke | pure virtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolBrush
APDYNAMICART::ToolBrush Member List

This is the complete list of members for APDYNAMICART::ToolBrush, including all inherited members.

_brush | APDYNAMICART::ToolBrush | protected
_cursor | APDYNAMICART::DATool | protected
_DAAOrientation | APDYNAMICART::ToolBrush | protected
_DAAposition | APDYNAMICART::ToolBrush | protected
_daArea | APDYNAMICART::DATool | protected
_DAAScale | APDYNAMICART::ToolBrush | protected
_daEnvironment | APDYNAMICART::DATool | protected
_guiController | APDYNAMICART::ToolBrush | protected
_lastValidPosition | APDYNAMICART::ToolBrush | protected
_MenuAbility | APDYNAMICART::ToolBrush | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
_sensorNumber | APDYNAMICART::ToolBrush | protected
_strokeStartTime | APDYNAMICART::ToolBrush | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolBrush | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
CreateMenuAbilities() | APDYNAMICART::ToolBrush |
createMenuStructure() | APDYNAMICART::ToolBrush |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolBrush | virtual
DECLARE_INPUT(GUIItemClicked, MessageString) | APDYNAMICART::ToolBrush | protected
DECLARE_INPUT(CreateMenuStructure, MessageInt) | APDYNAMICART::ToolBrush | protected
DECLARE_INPUT(HidingMenu, MessageBool) | APDYNAMICART::ToolBrush | protected
DECLARE_OUTPUT(MenuStructure, MessageString) | APDYNAMICART::ToolBrush | protected
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolBrush | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
guiItemClicked(const char *itemID) | APDYNAMICART::ToolBrush | protected
initialize(int newSensorNumber, BrushPtr brush, osg::Vec4 color) | APDYNAMICART::ToolBrush |
APDYNAMICART::DATool::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ToolBrush |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSensorNumber(const int sensorNum) | APDYNAMICART::ToolBrush | inline
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
storeSample(osg::Vec3 position, osg::Quat orientation) | APDYNAMICART::ToolBrush |
ToolBrush() | APDYNAMICART::ToolBrush |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolBrush | virtual
turnOn() | APDYNAMICART::ToolBrush | virtual
update() | APDYNAMICART::ToolBrush | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~ToolBrush() | APDYNAMICART::ToolBrush |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolEraser
APDYNAMICART::ToolEraser Member List

This is the complete list of members for APDYNAMICART::ToolEraser, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
_PointerOriReqString | APDYNAMICART::ToolEraser | protected
_PointerPosReqString | APDYNAMICART::ToolEraser | protected
_sensorNumber | APDYNAMICART::ToolEraser | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolEraser | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolEraser | virtual
DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3) | APDYNAMICART::ToolEraser | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolEraser | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolEraser | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDAEnvironment(DAEnvironment *p_dae) | APDYNAMICART::ToolEraser | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolEraser() | APDYNAMICART::ToolEraser |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolEraser | virtual
turnOn() | APDYNAMICART::ToolEraser | virtual
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~ToolEraser() | APDYNAMICART::ToolEraser |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolHook
APDYNAMICART::ToolHook Member List

This is the complete list of members for APDYNAMICART::ToolHook, including all inherited members.

_axis | APDYNAMICART::ToolHook | protected
_cursor | APDYNAMICART::DATool | protected
_DAAOrientation | APDYNAMICART::ToolHook | protected
_DAAposition | APDYNAMICART::ToolHook | protected
_daArea | APDYNAMICART::DATool | protected
_DAAScale | APDYNAMICART::ToolHook | protected
_daEnvironment | APDYNAMICART::DATool | protected
_guiController | APDYNAMICART::ToolHook | protected
_hookPosition | APDYNAMICART::ToolHook | protected
_menuAbility | APDYNAMICART::ToolHook | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::ToolHook | protected
_ropeRadius | APDYNAMICART::ToolHook | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolHook | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
createMenuStructure() | APDYNAMICART::ToolHook |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolHook | virtual
DECLARE_INPUT(GUIItemClicked, MessageString) | APDYNAMICART::ToolHook | protected
DECLARE_INPUT(CreateMenuStructure, MessageInt) | APDYNAMICART::ToolHook | protected
DECLARE_INPUT(HidingMenu, MessageBool) | APDYNAMICART::ToolHook | protected
DECLARE_OUTPUT(MenuStructure, MessageString) | APDYNAMICART::ToolHook | protected
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolHook | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolHook | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getCursorPosition() | APDYNAMICART::ToolHook | protected
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRopeRadius() const | APDYNAMICART::ToolHook | inline
getSceneFile() const | vrecko::BaseClass | inline
getSelectedPoA() | APDYNAMICART::ToolHook | protected
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
guiItemClicked(const char *itemID) | APDYNAMICART::ToolHook |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolHook | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initMenu() | APDYNAMICART::ToolHook | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ToolHook |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolHook() | APDYNAMICART::ToolHook |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolHook | virtual
turnOn() | APDYNAMICART::ToolHook | virtual
update() | APDYNAMICART::ToolHook | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolMagicWand
APDYNAMICART::ToolMagicWand Member List

This is the complete list of members for APDYNAMICART::ToolMagicWand, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_guiController | APDYNAMICART::ToolMagicWand | protected
_lastDominantAxis | APDYNAMICART::ToolMagicWand | protected
_lastHandPosition | APDYNAMICART::ToolMagicWand | protected
_MenuAbility | APDYNAMICART::ToolMagicWand | protected
_observers | vreckoUtils::Observable | protected
_originalHandposition | APDYNAMICART::ToolMagicWand | protected
_poa | APDYNAMICART::DATool | protected
_precision | APDYNAMICART::ToolMagicWand | protected
_sensorNumber | APDYNAMICART::ToolMagicWand | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolMagicWand | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attractor | APDYNAMICART::ToolMagicWand | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
changeAttractor(osg::Vec3 newHandPosition) | APDYNAMICART::ToolMagicWand | protected
clean(void) | vrecko::Ability | inlinevirtual
controller | APDYNAMICART::ToolMagicWand | protected
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
createMenuAbilities() | APDYNAMICART::ToolMagicWand |
createMenuStructure() | APDYNAMICART::ToolMagicWand |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolMagicWand | virtual
DECLARE_INPUT(GUIItemClicked, MessageString) | APDYNAMICART::ToolMagicWand | protected
DECLARE_INPUT(CreateMenuStructure, MessageInt) | APDYNAMICART::ToolMagicWand | protected
DECLARE_INPUT(HidingMenu, MessageBool) | APDYNAMICART::ToolMagicWand | protected
DECLARE_OUTPUT(MenuStructure, MessageString) | APDYNAMICART::ToolMagicWand | protected
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolMagicWand | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolMagicWand | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dominantAxis | APDYNAMICART::ToolMagicWand | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSelectedPoA() | APDYNAMICART::ToolMagicWand |
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
guiItemClicked(const char *itemID) | APDYNAMICART::ToolMagicWand | protected
handMoveMax | APDYNAMICART::ToolMagicWand | protected
handMoveMin | APDYNAMICART::ToolMagicWand | protected
indexX | APDYNAMICART::ToolMagicWand | protected
indexY | APDYNAMICART::ToolMagicWand | protected
indexZ | APDYNAMICART::ToolMagicWand | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolMagicWand | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initialParamValue | APDYNAMICART::ToolMagicWand | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ToolMagicWand | protected
newHandPosition | APDYNAMICART::ToolMagicWand | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
originalIterations | APDYNAMICART::ToolMagicWand | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
paramMult | APDYNAMICART::ToolMagicWand | protected
paramRangeEnd | APDYNAMICART::ToolMagicWand | protected
paramRangeStart | APDYNAMICART::ToolMagicWand | protected
paramShift1 | APDYNAMICART::ToolMagicWand | protected
paramShift2 | APDYNAMICART::ToolMagicWand | protected
PinList typedef | vrecko::BaseClass | protected
PointerPosReqString | APDYNAMICART::ToolMagicWand | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
setValuesXYZ(double newValueX, double newValueY, double newValueZ) | APDYNAMICART::ToolMagicWand | protected
size | APDYNAMICART::DATool | protected
ToolMagicWand() | APDYNAMICART::ToolMagicWand |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolMagicWand | virtual
turnOn() | APDYNAMICART::ToolMagicWand | virtual
update() | APDYNAMICART::ToolMagicWand | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolRotation
APDYNAMICART::ToolRotation Member List

This is the complete list of members for APDYNAMICART::ToolRotation, including all inherited members.

_baseAxis | APDYNAMICART::ToolRotation | protected
_cursor | APDYNAMICART::DATool | protected
_DAAOrientation | APDYNAMICART::ToolRotation | protected
_DAAposition | APDYNAMICART::ToolRotation | protected
_daArea | APDYNAMICART::DATool | protected
_DAAScale | APDYNAMICART::ToolRotation | protected
_daEnvironment | APDYNAMICART::DATool | protected
_guiController | APDYNAMICART::ToolRotation | protected
_initCurPos | APDYNAMICART::ToolRotation | protected
_menuAbility | APDYNAMICART::ToolRotation | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::ToolRotation | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolRotation | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
createMenuStructure() | APDYNAMICART::ToolRotation |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolRotation | virtual
DECLARE_INPUT(GUIItemClicked, MessageString) | APDYNAMICART::ToolRotation | protected
DECLARE_INPUT(CreateMenuStructure, MessageInt) | APDYNAMICART::ToolRotation | protected
DECLARE_INPUT(HidingMenu, MessageBool) | APDYNAMICART::ToolRotation | protected
DECLARE_OUTPUT(MenuStructure, MessageString) | APDYNAMICART::ToolRotation | protected
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolRotation | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolRotation | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getCursorPosition() | APDYNAMICART::ToolRotation |
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSelectedPoA() | APDYNAMICART::ToolRotation | protected
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
guiItemClicked(const char *itemID) | APDYNAMICART::ToolRotation |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolRotation | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initMenu() | APDYNAMICART::ToolRotation | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ToolRotation |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolRotation() | APDYNAMICART::ToolRotation |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolRotation | virtual
turnOn() | APDYNAMICART::ToolRotation | virtual
update() | APDYNAMICART::ToolRotation | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolSelector
APDYNAMICART::ToolSelector Member List

This is the complete list of members for APDYNAMICART::ToolSelector, including all inherited members.

_arraySize | APDYNAMICART::ToolSelector | protected
_cursor | APDYNAMICART::DATool | protected
_DAAOrientation | APDYNAMICART::ToolSelector | protected
_DAAposition | APDYNAMICART::ToolSelector | protected
_daArea | APDYNAMICART::DATool | protected
_DAAScale | APDYNAMICART::ToolSelector | protected
_daEnvironment | APDYNAMICART::DATool | protected
_guiController | APDYNAMICART::ToolSelector | protected
_hoop | APDYNAMICART::ToolSelector | protected
_lastEnd | APDYNAMICART::ToolSelector | protected
_menuAbility | APDYNAMICART::ToolSelector | protected
_observers | vreckoUtils::Observable | protected
_overZero | APDYNAMICART::ToolSelector | protected
_poa | APDYNAMICART::DATool | protected
_sectorIndex | APDYNAMICART::ToolSelector | protected
_sectorManager | APDYNAMICART::ToolSelector | protected
_sectorNumber | APDYNAMICART::ToolSelector | protected
_selectEnd | APDYNAMICART::ToolSelector | protected
_selectStart | APDYNAMICART::ToolSelector | protected
_snapPointArray | APDYNAMICART::ToolSelector | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolSelector | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
createMenuStructure() | APDYNAMICART::ToolSelector |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolSelector | virtual
DECLARE_INPUT(GUIItemClicked, MessageString) | APDYNAMICART::ToolSelector | protected
DECLARE_INPUT(CreateMenuStructure, MessageInt) | APDYNAMICART::ToolSelector | protected
DECLARE_INPUT(HidingMenu, MessageBool) | APDYNAMICART::ToolSelector | protected
DECLARE_OUTPUT(MenuStructure, MessageString) | APDYNAMICART::ToolSelector | protected
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolSelector | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolSelector | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNearestIndex() | APDYNAMICART::ToolSelector | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSectorNumber() | APDYNAMICART::ToolSelector | protected
getSelectedPoA() | APDYNAMICART::ToolSelector | protected
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
guiItemClicked(const char *itemID) | APDYNAMICART::ToolSelector |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolSelector | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initMenu() | APDYNAMICART::ToolSelector | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuSliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::ToolSelector |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetValues() | APDYNAMICART::ToolSelector | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolSelector() | APDYNAMICART::ToolSelector |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolSelector | virtual
turnOn() | APDYNAMICART::ToolSelector | virtual
update() | APDYNAMICART::ToolSelector | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolSlice
APDYNAMICART::ToolSlice Member List

This is the complete list of members for APDYNAMICART::ToolSlice, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daEnvironment | APDYNAMICART::DATool | protected
_observers | vreckoUtils::Observable | protected
_poa | APDYNAMICART::DATool | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolSlice | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clipNode | APDYNAMICART::ToolSlice | protected
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolSlice | virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolSlice | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lowClipPlane | APDYNAMICART::ToolSlice | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolSlice() | APDYNAMICART::ToolSlice |
toolType | APDYNAMICART::DATool | protected
topClipPlane | APDYNAMICART::ToolSlice | protected
turnOff() | APDYNAMICART::ToolSlice | virtual
turnOn() | APDYNAMICART::ToolSlice | virtual
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ToolTongs
APDYNAMICART::ToolTongs Member List

This is the complete list of members for APDYNAMICART::ToolTongs, including all inherited members.

_cursor | APDYNAMICART::DATool | protected
_daArea | APDYNAMICART::DATool | protected
_daAreaOrientation | APDYNAMICART::ToolTongs | protected
_daAreaPosition | APDYNAMICART::ToolTongs | protected
_daAreaScale | APDYNAMICART::ToolTongs | protected
_daEnvironment | APDYNAMICART::DATool | protected
_localHandDiffVec | APDYNAMICART::ToolTongs | protected
_newHandOrientation | APDYNAMICART::ToolTongs | protected
_newHandPosition | APDYNAMICART::ToolTongs | protected
_observers | vreckoUtils::Observable | protected
_originalHandposition | APDYNAMICART::ToolTongs | protected
_originalLocalHandOrientation | APDYNAMICART::ToolTongs | protected
_originalLocalHandposition | APDYNAMICART::ToolTongs | protected
_originalPoAOrientation | APDYNAMICART::ToolTongs | protected
_originalPoAPosition | APDYNAMICART::ToolTongs | protected
_originalPoAScale | APDYNAMICART::ToolTongs | protected
_oriString | APDYNAMICART::ToolTongs | protected
_poa | APDYNAMICART::DATool | protected
_posString | APDYNAMICART::ToolTongs | protected
_sensorNumber | APDYNAMICART::ToolTongs | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APDYNAMICART::ToolTongs | virtual
active | APDYNAMICART::DATool | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObserver(Observer *observer) | vreckoUtils::Observable | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createCursor(EnvironmentObject *parent, string fileName) | APDYNAMICART::DATool |
DATool(const char *abilityName) | APDYNAMICART::DATool |
deactivate() | APDYNAMICART::ToolTongs | virtual
DECLARE_REQUEST_OUTPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APDYNAMICART::ToolTongs | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APDYNAMICART::ToolTongs | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCursor() | APDYNAMICART::DATool | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSize() | APDYNAMICART::DATool | inline
getType() | APDYNAMICART::DATool | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APDYNAMICART::ToolTongs | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | APDYNAMICART::DATool | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDAEnvironment(DAEnvironment *p_dae) | APDYNAMICART::ToolTongs | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPoA(osg::ref_ptr< PoA > newPoa) | APDYNAMICART::DATool | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSize(osg::Vec3 p_size) | APDYNAMICART::DATool |
size | APDYNAMICART::DATool | protected
ToolTongs() | APDYNAMICART::ToolTongs |
toolType | APDYNAMICART::DATool | protected
turnOff() | APDYNAMICART::ToolTongs | virtual
turnOn() | APDYNAMICART::ToolTongs | virtual
update() | APDYNAMICART::ToolTongs | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DATool() | APDYNAMICART::DATool |
~ToolTongs() | APDYNAMICART::ToolTongs |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • TopPattern
APDYNAMICART::TopPattern Member List

This is the complete list of members for APDYNAMICART::TopPattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • TopReversePattern
APDYNAMICART::TopReversePattern Member List

This is the complete list of members for APDYNAMICART::TopReversePattern, including all inherited members.

_array | APDYNAMICART::PatternBase | protected
generate(Vec3ArrayPtr left, Vec3ArrayPtr right) | APDYNAMICART::PatternBase | inlinevirtual
getVertexArray() const | APDYNAMICART::PatternBase | inline
PatternBase() | APDYNAMICART::PatternBase | inline
setVertexArray(Vec3ArrayPtr val) | APDYNAMICART::PatternBase | inline
~PatternBase() | APDYNAMICART::PatternBase | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Utils
APDYNAMICART::Utils Member List

This is the complete list of members for APDYNAMICART::Utils, including all inherited members.

convertInt(int number) | APDYNAMICART::Utils | inlinestatic
convertString(string number) | APDYNAMICART::Utils | inlinestatic
createDATool(const std::string &toolName, vrecko::BaseClass *owner) | APDYNAMICART::Utils | inlinestatic
disableShaders(osg::StateSet *stateSet) | APDYNAMICART::Utils | inlinestatic
interpolatePoint(double t, osg::Vec3 point1, osg::Vec3 point2, osg::Vec3 point0, osg::Vec3 point3) | APDYNAMICART::Utils | static
interpolateVec3(osg::Vec3Array *controlPoints, osg::Vec3Array *interpolatedPoints, int p_steps) | APDYNAMICART::Utils | static
isValueInsideRange(double value, double rangeStart, double rangeEnd) | APDYNAMICART::Utils | static
setLayout(const std::string &name) | APDYNAMICART::Utils | static
splitString(const std::string &s, char delim, std::vector< std::string > &elems) | APDYNAMICART::Utils | inlinestatic
splitString(const std::string &s, char delim) | APDYNAMICART::Utils | inlinestatic
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • WaveSplineAdapter
APDYNAMICART::WaveSplineAdapter Member List

This is the complete list of members for APDYNAMICART::WaveSplineAdapter, including all inherited members.

_spline | APDYNAMICART::WaveSplineAdapter | protected
classDescription() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
className() const =0 | APDYNAMICART::PoAAdapter< Spline > | pure virtual
createMenu(MenuPtr menu) | APDYNAMICART::WaveSplineAdapter | virtual
APDYNAMICART::SplineAdapter::createMenu(osg::ref_ptr< vreckoUtils::Menu > menu) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
getObject() | APDYNAMICART::WaveSplineAdapter | inlinevirtual
init() | APDYNAMICART::WaveSplineAdapter |
itemClicked(const char *itemID) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
META_DAObject(WaveSplineAdapter,"Wave") | APDYNAMICART::WaveSplineAdapter |
pointed(bool pointed) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ParametersNode) | APDYNAMICART::WaveSplineAdapter | virtual
sliderChanged(const char *sliderID, float sliderPos) | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
update() | APDYNAMICART::PoAAdapter< Spline > | inlinevirtual
WaveSplineAdapter() | APDYNAMICART::WaveSplineAdapter |
~PoAAdapter() | APDYNAMICART::PoAAdapter< Spline > | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • colorGradient
APDYNAMICART::colorGradient Member List

This is the complete list of members for APDYNAMICART::colorGradient, including all inherited members.

addColor(osg::Vec4 color) | APDYNAMICART::colorGradient | inline
getColor(double val) | APDYNAMICART::colorGradient |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
APEditorController::AbilityMapper Member List

This is the complete list of members for APEditorController::AbilityMapper, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
AbilityMapper() | APEditorController::AbilityMapper |
activate() | APEditorController::AbilityMapper | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | APEditorController::AbilityMapper | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(Mapping, MessageMapping) | APEditorController::AbilityMapper | protected
vrecko::ControllableAbility::DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
vrecko::ControllableAbility::DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_OUTPUT(Mapping, MessageMapping) | APEditorController::AbilityMapper | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorController::AbilityMapper | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mapping | APEditorController::AbilityMapper | protected
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorController::AbilityMapper | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNewMapping() | APEditorController::AbilityMapper | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AbilityMapper() | APEditorController::AbilityMapper | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • MessageMapping
APEditorController::AbilityMapper::MessageMapping Member List

This is the complete list of members for APEditorController::AbilityMapper::MessageMapping, including all inherited members.

data | APEditorController::AbilityMapper::MessageMapping |
getMessageId() | APEditorController::AbilityMapper::MessageMapping | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
APEditorController::EditorController Member List

This is the complete list of members for APEditorController::EditorController, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
abilityActivationTest() | APEditorController::EditorController | protected
abilityMapper | APEditorController::EditorController | protected
activeAbilityButtonID | APEditorController::EditorController | protected
activeAbilityName | APEditorController::EditorController | protected
activeAbilityPointerID | APEditorController::EditorController | protected
actSelection | APEditorController::EditorController | protected
actViewPosition | APEditorController::EditorController | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
compileAbilityMapping() | APEditorController::EditorController | protected
createAbilityMapper() | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Pos, MessageVec3) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Rot, MessageQuat) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1PosRaw, MessageVec3) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1RotRaw, MessageQuat) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Btn1, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Btn2, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Btn3, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer1Btn4, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Pos, MessageVec3) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Rot, MessageQuat) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2PosRaw, MessageVec3) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2RotRaw, MessageQuat) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Btn1, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Btn2, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Btn3, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(Pointer2Btn4, MessageBool) | APEditorController::EditorController | protected
DECLARE_INPUT(AbilityMapping, AbilityMapper::MessageMapping) | APEditorController::EditorController | protected
DECLARE_OUTPUT(SelectionID, MessageObjectID) | APEditorController::EditorController | protected
DECLARE_OUTPUT(Pointer1Selection, MessageObjectID) | APEditorController::EditorController | protected
DECLARE_OUTPUT(Pointer1Visible, MessageBool) | APEditorController::EditorController | protected
DECLARE_OUTPUT(Pointer2Selection, MessageObjectID) | APEditorController::EditorController | protected
DECLARE_OUTPUT(Pointer2Visible, MessageBool) | APEditorController::EditorController | protected
DECLARE_OUTPUT(AbilityMapping, AbilityMapper::MessageMapping) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(AbilityMapping, MessageVoid, AbilityMapper::MessageMapping) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(SelectionID, MessageInt, MessageObjectID) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(SelectionPath, MessageInt, MessageNodeList) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(PointerPos, MessageInt, MessageVec3) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(PointerRot, MessageInt, MessageQuat) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(PointerPosRaw, MessageInt, MessageVec3) | APEditorController::EditorController | protected
DECLARE_REQUEST_INPUT(PointerRotRaw, MessageInt, MessageQuat) | APEditorController::EditorController | protected
DECLARE_REQUEST_OUTPUT(SelectionByPointerPos_Path, MessageVec3, MessageNodeList) | APEditorController::EditorController | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EditorController() | APEditorController::EditorController |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APEditorController::EditorController | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
maxButtonsPerPointer | APEditorController::EditorController | static
maxPointers | APEditorController::EditorController | static
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APEditorController::EditorController | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointerBtnUpdate(int poinerID, int buttonID, bool newState) | APEditorController::EditorController | protected
pointerPosUpdate(int pointerID, const osg::Vec3 &newPos, bool bRaw=false) | APEditorController::EditorController | protected
pointerRotUpdate(int pointerID, const osg::Quat &newRot, bool bRaw=false) | APEditorController::EditorController | protected
pointers | APEditorController::EditorController | protected
pointerSelUpdate(int pointerID, unsigned long newSelection) | APEditorController::EditorController | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APEditorController::EditorController | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbilityMapper() | APEditorController::EditorController | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectionVisibilityUpdate() | APEditorController::EditorController | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sendPointerBtnToRelevantOutputs(int pointerID, int buttonID) | APEditorController::EditorController | protected
sendPointerSelectionEvent(int pointerID, unsigned long newSelection) | APEditorController::EditorController | protected
setAbilityMapping(AbilityMapper::MAPPING *newMapping) | APEditorController::EditorController | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setNewSelection(unsigned long newSelection) | APEditorController::EditorController | protected
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APEditorController::EditorController | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~EditorController() | APEditorController::EditorController |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
  • ECPOINTERBUTTONINFO
APEditorController::EditorController::ECPOINTERBUTTONINFO Member List

This is the complete list of members for APEditorController::EditorController::ECPOINTERBUTTONINFO, including all inherited members.

bState | APEditorController::EditorController::ECPOINTERBUTTONINFO |
cachedInfo | APEditorController::EditorController::ECPOINTERBUTTONINFO | protected
ECPOINTERBUTTONINFO() | APEditorController::EditorController::ECPOINTERBUTTONINFO | inline
getMappedAbilityID() | APEditorController::EditorController::ECPOINTERBUTTONINFO | inline
getMappedAbilityInfo(bool bForceRefresh) | APEditorController::EditorController::ECPOINTERBUTTONINFO |
mappedAbilityID | APEditorController::EditorController::ECPOINTERBUTTONINFO | protected
owner | APEditorController::EditorController::ECPOINTERBUTTONINFO | protected
setMappedAbility(const char *strID) | APEditorController::EditorController::ECPOINTERBUTTONINFO |
setOwner(EditorController *_owner) | APEditorController::EditorController::ECPOINTERBUTTONINFO | inline
~ECPOINTERBUTTONINFO() | APEditorController::EditorController::ECPOINTERBUTTONINFO | inline
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • EditorController
  • ECPOINTERINFO
APEditorController::EditorController::ECPOINTERINFO Member List

This is the complete list of members for APEditorController::EditorController::ECPOINTERINFO, including all inherited members.

actSelection | APEditorController::EditorController::ECPOINTERINFO |
buttons | APEditorController::EditorController::ECPOINTERINFO |
ECPOINTERINFO() | APEditorController::EditorController::ECPOINTERINFO | inline
lastButtonPressed | APEditorController::EditorController::ECPOINTERINFO |
pos | APEditorController::EditorController::ECPOINTERINFO |
posRaw | APEditorController::EditorController::ECPOINTERINFO |
rot | APEditorController::EditorController::ECPOINTERINFO |
rotRaw | APEditorController::EditorController::ECPOINTERINFO |
selPath | APEditorController::EditorController::ECPOINTERINFO |
~ECPOINTERINFO() | APEditorController::EditorController::ECPOINTERINFO | inline
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AbilityEditor
APEditorQAbilities::AbilityEditor Member List

This is the complete list of members for APEditorQAbilities::AbilityEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
AbilityEditor() | APEditorQAbilities::AbilityEditor |
activate() | APEditorQAbilities::AbilityEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allowedAbilities | APEditorQAbilities::AbilityEditor | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
conViz | APEditorQAbilities::AbilityEditor | protected
createConnectionViz() | APEditorQAbilities::AbilityEditor | protected
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APEditorQAbilities::AbilityEditor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyConnectionViz() | APEditorQAbilities::AbilityEditor | protected
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
executeAddAbility(int iIndex) | APEditorQAbilities::AbilityEditor | protected
executeAddConnection(const char *connectionMenuString) | APEditorQAbilities::AbilityEditor | protected
executeDeleteAbility(const char *abilityID) | APEditorQAbilities::AbilityEditor | protected
executeDeleteConnection(const char *connectionMenuString) | APEditorQAbilities::AbilityEditor | protected
fillDefaultInfo() | APEditorQAbilities::AbilityEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APEditorQAbilities::AbilityEditor | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorQAbilities::AbilityEditor | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
object1 | APEditorQAbilities::AbilityEditor | protected
object1ID | APEditorQAbilities::AbilityEditor | protected
object2 | APEditorQAbilities::AbilityEditor | protected
object2ID | APEditorQAbilities::AbilityEditor | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(vrecko::CABUTTONEVENT *eventData) | APEditorQAbilities::AbilityEditor | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AbilityEditor() | APEditorQAbilities::AbilityEditor | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AbilityEditor
  • AllowedAbility
APEditorQAbilities::AbilityEditor::AllowedAbility Member List

This is the complete list of members for APEditorQAbilities::AbilityEditor::AllowedAbility, including all inherited members.

abilityName | APEditorQAbilities::AbilityEditor::AllowedAbility
bProcessed | APEditorQAbilities::AbilityEditor::AllowedAbility
pluginName | APEditorQAbilities::AbilityEditor::AllowedAbility
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AnimatorEditor
APEditorQAbilities::AnimatorEditor Member List

This is the complete list of members for APEditorQAbilities::AnimatorEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::AnimatorEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
AnimatorEditor() | APEditorQAbilities::AnimatorEditor |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::AnimatorEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
GetAnim(bool bCreateIfNotExists=false) | APEditorQAbilities::AnimatorEditor | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorQAbilities::AnimatorEditor | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AnimatorEditor() | APEditorQAbilities::AnimatorEditor | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • AvatarMovement
APEditorQAbilities::AvatarMovement Member List

This is the complete list of members for APEditorQAbilities::AvatarMovement, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::AvatarMovement | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
AvatarMovement() | APEditorQAbilities::AvatarMovement |
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APEditorQAbilities::AvatarMovement | protected
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APEditorQAbilities::AvatarMovement | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::AvatarMovement | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
lastRelPointerPos | APEditorQAbilities::AvatarMovement | protected
lastRelPointerRot | APEditorQAbilities::AvatarMovement | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update(void) | APEditorQAbilities::AvatarMovement | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AvatarMovement() | APEditorQAbilities::AvatarMovement | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectAdd
APEditorQAbilities::ObjectAdd Member List

This is the complete list of members for APEditorQAbilities::ObjectAdd, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::ObjectAdd | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
createNewObject(const char *pFileName) | APEditorQAbilities::ObjectAdd | protected
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::ObjectAdd | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorQAbilities::ObjectAdd | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ObjectAdd() | APEditorQAbilities::ObjectAdd |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
showMenuWithObjects(const char *pDirectory) | APEditorQAbilities::ObjectAdd | protected
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~ObjectAdd() | APEditorQAbilities::ObjectAdd | inlinevirtual
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectDelete
APEditorQAbilities::ObjectDelete Member List

This is the complete list of members for APEditorQAbilities::ObjectDelete, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::ObjectDelete | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::ObjectDelete | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorQAbilities::ObjectDelete | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ObjectDelete() | APEditorQAbilities::ObjectDelete | inline
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~ObjectDelete() | APEditorQAbilities::ObjectDelete | inlinevirtual
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
APEditorQAbilities::ObjectMovement Member List

This is the complete list of members for APEditorQAbilities::ObjectMovement, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::ObjectMovement | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addSnappingPlane(unsigned long objectID, unsigned long objectSide, osg::Vec3 &center, osg::Vec3 &normal, osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 shiftVec, float shiftLen2, osg::Vec3 &snapPoint, float halfRect1SnapMul, float halfRect2SnapMul, float fMinU, float fMaxU, float fMinV, float fMaxV, CandidatePlaneType type) | APEditorQAbilities::ObjectMovement | protected
applySnapping(EnvironmentObject *eo, osg::Matrix *inoutTrans) | APEditorQAbilities::ObjectMovement | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
bApplySnapping | APEditorQAbilities::ObjectMovement | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APEditorQAbilities::ObjectMovement | protected
bIgnoreRotation | APEditorQAbilities::ObjectMovement | protected
bMenuVisible | vrecko::ControllableAbility | protected
calcFinalShiftFromSelectedSet(osg::Vec3 &outShift, int additionalPlane=-1) | APEditorQAbilities::ObjectMovement | protected
CandidatePlaneType enum name | APEditorQAbilities::ObjectMovement | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | APEditorQAbilities::ObjectMovement | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APEditorQAbilities::ObjectMovement | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::ObjectMovement | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectPos | APEditorQAbilities::ObjectMovement | protected
firstObjectRot | APEditorQAbilities::ObjectMovement | protected
firstPointerPos | APEditorQAbilities::ObjectMovement | protected
firstPointerRot | APEditorQAbilities::ObjectMovement | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
Horizontal_PrioritySnap enum value | APEditorQAbilities::ObjectMovement | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APEditorQAbilities::ObjectMovement | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
intersect2Planes(osg::Vec3 &p1p, osg::Vec3 &p1normal, osg::Vec3 &p2p, osg::Vec3 &p2normal, osg::Vec3 &outLineStart, osg::Vec3 &outLineDir) | APEditorQAbilities::ObjectMovement | protected
intersectLinePlane(osg::Vec3 &lineStart, osg::Vec3 &lineDir, osg::Vec3 &planePoint, osg::Vec3 &planeNormal, osg::Vec3 &outPoint) | APEditorQAbilities::ObjectMovement | protected
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isPlaneCompatibleWithSelectedSet(int iPlaneIndex) | APEditorQAbilities::ObjectMovement | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APEditorQAbilities::ObjectMovement | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objAABox | APEditorQAbilities::ObjectMovement | protected
objAABoxTrans | APEditorQAbilities::ObjectMovement | protected
objectEffect | APEditorQAbilities::ObjectMovement | protected
ObjectMovement() | APEditorQAbilities::ObjectMovement |
objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans) | APEditorQAbilities::ObjectMovement | protected
Other enum value | APEditorQAbilities::ObjectMovement | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
planes | APEditorQAbilities::ObjectMovement | protected
planesCompare(const ObjectMovement::CANDIDATEPLANE *elem1, const ObjectMovement::CANDIDATEPLANE *elem2) | APEditorQAbilities::ObjectMovement | friend
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
projectPointOnPlaneUV(osg::Vec3 &point, osg::Vec3 &planePoint, osg::Vec3 &planeNormal, osg::Vec3 &halfVec1, osg::Vec3 &halfVec2, osg::Vec3 *outProjectedPoint, float *outDist, float *outU, float *outV) | APEditorQAbilities::ObjectMovement | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectedPlanes | APEditorQAbilities::ObjectMovement | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shadowObject | APEditorQAbilities::ObjectMovement | protected
showMenu() | vrecko::ControllableAbility | protectedvirtual
snapBoxes | APEditorQAbilities::ObjectMovement | protected
update(void) | APEditorQAbilities::ObjectMovement | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~ObjectMovement() | APEditorQAbilities::ObjectMovement | inlinevirtual
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
  • SnapBox
APEditorQAbilities::ObjectMovement::SnapBox Member List

This is the complete list of members for APEditorQAbilities::ObjectMovement::SnapBox, including all inherited members.

color | APEditorQAbilities::ObjectMovement::SnapBox | protected
Done() | APEditorQAbilities::ObjectMovement::SnapBox | protected
graphicObject | APEditorQAbilities::ObjectMovement::SnapBox | protected
hide() | APEditorQAbilities::ObjectMovement::SnapBox |
Init() | APEditorQAbilities::ObjectMovement::SnapBox | protected
osgGeode | APEditorQAbilities::ObjectMovement::SnapBox | protected
osgTransform | APEditorQAbilities::ObjectMovement::SnapBox | protected
owner | APEditorQAbilities::ObjectMovement::SnapBox | protected
setOwner(ObjectMovement *_owner) | APEditorQAbilities::ObjectMovement::SnapBox | inline
shapeBox | APEditorQAbilities::ObjectMovement::SnapBox | protected
shapeDraw | APEditorQAbilities::ObjectMovement::SnapBox | protected
show() | APEditorQAbilities::ObjectMovement::SnapBox |
SnapBox() | APEditorQAbilities::ObjectMovement::SnapBox | inline
updateShape(const osg::Vec3 &center, const osg::Vec3 &halfLengths, const osg::Matrix &transform) | APEditorQAbilities::ObjectMovement::SnapBox |
~SnapBox() | APEditorQAbilities::ObjectMovement::SnapBox | inline
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • PresentAbility
APEditorQAbilities::PresentAbility Member List

This is the complete list of members for APEditorQAbilities::PresentAbility, including all inherited members.

bExisting | APEditorQAbilities::PresentAbility
ptr | APEditorQAbilities::PresentAbility
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • SceneSave
APEditorQAbilities::SceneSave Member List

This is the complete list of members for APEditorQAbilities::SceneSave, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::SceneSave | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::SceneSave | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APEditorQAbilities::SceneSave | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
SceneSave() | APEditorQAbilities::SceneSave | inline
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~SceneSave() | APEditorQAbilities::SceneSave | inlinevirtual
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • SimpleObjectMovement
APEditorQAbilities::SimpleObjectMovement Member List

This is the complete list of members for APEditorQAbilities::SimpleObjectMovement, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::SimpleObjectMovement | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bFirstUpdate | APEditorQAbilities::SimpleObjectMovement | protected
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APEditorQAbilities::SimpleObjectMovement | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::SimpleObjectMovement | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
firstObjectPos | APEditorQAbilities::SimpleObjectMovement | protected
firstPointerPos | APEditorQAbilities::SimpleObjectMovement | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APEditorQAbilities::SimpleObjectMovement | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
movingObjectID | APEditorQAbilities::SimpleObjectMovement | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectTransformationFromPointer(EnvironmentObject *eo, osg::Matrix *outTrans) | APEditorQAbilities::SimpleObjectMovement | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
SimpleObjectMovement() | APEditorQAbilities::SimpleObjectMovement |
update(void) | APEditorQAbilities::SimpleObjectMovement | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~SimpleObjectMovement() | APEditorQAbilities::SimpleObjectMovement | inlinevirtual
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • UseTrigger
APEditorQAbilities::UseTrigger Member List

This is the complete list of members for APEditorQAbilities::UseTrigger, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APEditorQAbilities::UseTrigger | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APEditorQAbilities::UseTrigger | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APEditorQAbilities::UseTrigger | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
SendUseSignal(bool bParameter) | APEditorQAbilities::UseTrigger | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
UseTrigger() | APEditorQAbilities::UseTrigger |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~UseTrigger() | APEditorQAbilities::UseTrigger | inlinevirtual
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • EditorLogic
APFFDEditor::EditorLogic Member List

This is the complete list of members for APFFDEditor::EditorLogic, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APFFDEditor::EditorLogic | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateGeometryArray(int count) | APFFDEditor::GeometryLoader | inlineprotected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
CPscale(float scale) | APFFDEditor::EditorLogic | protected
CPsize | APFFDEditor::EditorLogic | protected
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
deallocateGeometryArray() | APFFDEditor::GeometryLoader | inlineprotected
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyGeometry() | APFFDEditor::GeometryLoader | protectedvirtual
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
EditorLogic() | APFFDEditor::EditorLogic |
fillDefaultInfo() | APFFDEditor::EditorLogic | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
geometries_count | APFFDEditor::GeometryLoader | protected
geometryArray | APFFDEditor::GeometryLoader | protected
GeometryLoader() | APFFDEditor::GeometryLoader |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGeometriesCount(void) | APFFDEditor::GeometryLoader | inline
getGeometry(unsigned long index) | APFFDEditor::GeometryLoader | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOSGInitCounts(osg::Node *pNode, unsigned long &pGeometriesCount) | APFFDEditor::GeometryLoader | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
gridChanged | APFFDEditor::EditorLogic | protected
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
inverseParentsTransform | APFFDEditor::EditorLogic | protected
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isThisControlPoint(long ID) | APFFDEditor::EditorLogic | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
loadGeometry(osg::Node *pNode) | APFFDEditor::GeometryLoader | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &geometry_pos) | APFFDEditor::GeometryLoader | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | APFFDEditor::EditorLogic | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APFFDEditor::EditorLogic | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | APFFDEditor::EditorLogic | protectedvirtual
moveLock | APFFDEditor::EditorLogic | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
numberOfCPoints | APFFDEditor::EditorLogic | protected
objectWasMoved | APFFDEditor::EditorLogic | protected
optimOfCP | APFFDEditor::EditorLogic | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
parentsTransform | APFFDEditor::EditorLogic | protected
pEditedObject | APFFDEditor::EditorLogic | protected
pGrid | APFFDEditor::EditorLogic | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | APFFDEditor::EditorLogic | virtual
pOwner | vrecko::Ability | protected
previousObjectPosition | APFFDEditor::EditorLogic | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
resetGeometry(void) | APFFDEditor::EditorLogic | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAtributesForDeformation(void) | APFFDEditor::EditorLogic | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
transparencyOfEditedObject | APFFDEditor::EditorLogic | protected
update(void) | APFFDEditor::EditorLogic | virtual
updated | vrecko::Ability | protected
updateObjectGeometry(void) | APFFDEditor::EditorLogic | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~EditorLogic() | APFFDEditor::EditorLogic | inline
~GeometryLoader() | APFFDEditor::GeometryLoader |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoader
APFFDEditor::GeometryLoader Member List

This is the complete list of members for APFFDEditor::GeometryLoader, including all inherited members.

allocateGeometryArray(int count) | APFFDEditor::GeometryLoader | inlineprotected
deallocateGeometryArray() | APFFDEditor::GeometryLoader | inlineprotected
destroyGeometry() | APFFDEditor::GeometryLoader | protectedvirtual
geometries_count | APFFDEditor::GeometryLoader | protected
geometryArray | APFFDEditor::GeometryLoader | protected
GeometryLoader() | APFFDEditor::GeometryLoader |
getGeometriesCount(void) | APFFDEditor::GeometryLoader | inline
getGeometry(unsigned long index) | APFFDEditor::GeometryLoader | inline
getOSGInitCounts(osg::Node *pNode, unsigned long &pGeometriesCount) | APFFDEditor::GeometryLoader | protected
loadGeometry(osg::Node *pNode) | APFFDEditor::GeometryLoader | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &geometry_pos) | APFFDEditor::GeometryLoader | protected
~GeometryLoader() | APFFDEditor::GeometryLoader |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
APFFDEditor::GeometryLoaderBase Member List

This is the complete list of members for APFFDEditor::GeometryLoaderBase, including all inherited members.

allocateFaceArray(unsigned long numFaces) | APFFDEditor::GeometryLoaderBase | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APFFDEditor::GeometryLoaderBase | inlinevirtual
bRecalculateNormals | APFFDEditor::GeometryLoaderBase | protected
deallocateFaceArray() | APFFDEditor::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APFFDEditor::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APFFDEditor::GeometryLoaderBase |
destroyGeometry() | APFFDEditor::GeometryLoaderBase | protectedvirtual
face_count | APFFDEditor::GeometryLoaderBase | protected
face_size | APFFDEditor::GeometryLoaderBase | protected
faces | APFFDEditor::GeometryLoaderBase | protected
GeometryLoaderBase() | APFFDEditor::GeometryLoaderBase |
getFace(unsigned long index) | APFFDEditor::GeometryLoaderBase | inline
getFaceCount() | APFFDEditor::GeometryLoaderBase | inline
getFaceStructureSize() | APFFDEditor::GeometryLoaderBase | inlinevirtual
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APFFDEditor::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APFFDEditor::GeometryLoaderBase | protected
getVertex(unsigned long index) | APFFDEditor::GeometryLoaderBase | inline
getVertexCount() | APFFDEditor::GeometryLoaderBase | inline
getVertexStructureSize() | APFFDEditor::GeometryLoaderBase | inlinevirtual
loadGeometry(osg::Node *pNode) | APFFDEditor::GeometryLoaderBase | protectedvirtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APFFDEditor::GeometryLoaderBase | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APFFDEditor::GeometryLoaderBase | virtual
recalculateNormals() | APFFDEditor::GeometryLoaderBase | protected
sortVerticesClockwise() | APFFDEditor::GeometryLoaderBase | protected
thisOwnerPtr | APFFDEditor::GeometryLoaderBase | protected
vertex_count | APFFDEditor::GeometryLoaderBase | protected
vertex_size | APFFDEditor::GeometryLoaderBase | protected
vertices | APFFDEditor::GeometryLoaderBase | protected
~GeometryLoaderBase() | APFFDEditor::GeometryLoaderBase |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
APFFDEditor::Grid Member List

This is the complete list of members for APFFDEditor::Grid, including all inherited members.

allocateControlPointArray() | APFFDEditor::Grid | inlineprotected
allocateEdgeArray() | APFFDEditor::Grid | inlineprotected
controlPoint_count | APFFDEditor::Grid | protected
controlPoints | APFFDEditor::Grid | protected
countOfCP | APFFDEditor::Grid | protected
CPscaling | APFFDEditor::Grid | protected
createGrid(vrecko::EnvironmentObject *object) | APFFDEditor::Grid |
deallocateControlPointArray() | APFFDEditor::Grid | inlineprotected
deallocateEdgeArray() | APFFDEditor::Grid | inlineprotected
destroyGeometry() | APFFDEditor::Grid | protectedvirtual
edge_count | APFFDEditor::Grid | protected
edges | APFFDEditor::Grid | protected
EditorLogic class | APFFDEditor::Grid | friend
getCountOfControlPoints(void) | APFFDEditor::Grid | inline
Grid() | APFFDEditor::Grid |
gridWasCreated | APFFDEditor::Grid | protected
optimalizationOfCP | APFFDEditor::Grid | protected
osgGeode | APFFDEditor::Grid | protected
setCountOfControlPoints(osg::Vec3 pom) | APFFDEditor::Grid | inline
setOptimalizationOfCP(unsigned int value) | APFFDEditor::Grid | inline
updateGrid(void) | APFFDEditor::Grid |
~Grid() | APFFDEditor::Grid |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • ColorPicker
APGUI::ColorPicker Member List

This is the complete list of members for APGUI::ColorPicker, including all inherited members.

_alwaysInMiddle | APGUI::ColorPicker | protected
_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_icontoDeactivate | APGUI::ColorPicker | protected
_interconnections | APGUI::GUI_Item | protected
_isActive | APGUI::ColorPicker | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_name | APGUI::GUI_Item | protected
_parent | APGUI::GUI_Item | protected
_pickerHeight | APGUI::ColorPicker | protected
_pickerRadius | APGUI::ColorPicker | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::GUI_Item | protected
_state | APGUI::GUI_Item | protected
_temporaryInterconnection | APGUI::ColorPicker | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
ColorPicker() | APGUI::ColorPicker |
createColorSphere(osg::Vec3 *pos, float radius, osg::Vec4 *colour) | APGUI::ColorPicker | protected
createVisuals() | APGUI::ColorPicker |
DECLARE_INPUT(Evoke, MessageBool) | APGUI::ColorPicker | protected
DECLARE_INPUT(GUIItemClicked, MessageString) | APGUI::ColorPicker | protected
DECLARE_INPUT(Select, MessageBool) | APGUI::ColorPicker | protected
DECLARE_INPUT(ExternalDeactivation, MessageObjectID) | APGUI::ColorPicker | protected
DECLARE_OUTPUT(Colour, MessageVec4) | APGUI::ColorPicker | protected
DECLARE_REQUEST_INPUT(EvokeHSLColorPicker, MessageString, MessageBool) | APGUI::ColorPicker | protected
DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3) | APGUI::ColorPicker | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
evoke() | APGUI::ColorPicker | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
handShapeDraw | APGUI::ColorPicker | protected
handShapeSphere | APGUI::ColorPicker | protected
handSphereRadius | APGUI::ColorPicker | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
HSLtoPos(osg::Vec3 *p_hsl, osg::Vec3 *p_pos) | APGUI::ColorPicker | protected
HSLtoRGB(osg::Vec3 *source, osg::Vec4 *target) | APGUI::ColorPicker | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::ColorPicker | virtual
APGUI::GUI_Item::initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
limitPosition(osg::Vec3 handPosition) | APGUI::ColorPicker | protected
linesIntersection(osg::Vec3 *p_point1, osg::Vec3 *p_orientation1, osg::Vec3 *p_point2, osg::Vec3 *p_orientation2, osg::Vec3 *result) | APGUI::ColorPicker | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APGUI::ColorPicker | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed) | APGUI::ColorPicker | inlinevirtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
PostoHSL(osg::Vec3 *p_pos, osg::Vec3 *p_hsl) | APGUI::ColorPicker | protected
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::ColorPicker | virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
revoke() | APGUI::ColorPicker | protected
RGBtoHSL(osg::Vec4 *p_source, osg::Vec3 *target) | APGUI::ColorPicker | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::GUI_Item | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setState(GUI_ITEM_STATE newState) | APGUI::ColorPicker | virtual
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
spheresRadius | APGUI::ColorPicker | protected
update(void) | APGUI::ColorPicker | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ColorPicker() | APGUI::ColorPicker |
~GUI_Item() | APGUI::GUI_Item |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Controller
APGUI::GUI_Controller Member List

This is the complete list of members for APGUI::GUI_Controller, including all inherited members.

_actualLayout | APGUI::GUI_Controller | protected
_actualPositions | APGUI::GUI_Controller | protected
_colourActive | APGUI::GUI_Controller | protected
_colourDefault | APGUI::GUI_Controller | protected
_colourDisabled | APGUI::GUI_Controller | protected
_colourHovered | APGUI::GUI_Controller | protected
_colourPressed | APGUI::GUI_Controller | protected
_debugButtonPressed | APGUI::GUI_Controller | protected
_debugButtonReleased | APGUI::GUI_Controller | protected
_disabled | APGUI::GUI_Controller | protected
_firstTimeUpdate | APGUI::GUI_Controller | protected
_globalAbilities | APGUI::GUI_Controller | protected
_groups | APGUI::GUI_Controller | protected
_itemsMap | APGUI::GUI_Controller | protected
_layouts | APGUI::GUI_Controller | protected
_maxNunberofInputDevices | APGUI::GUI_Controller | protected
_pointedAbilities | APGUI::GUI_Controller | protected
_pointedIndexes | APGUI::GUI_Controller | protected
_pointedTime | APGUI::GUI_Controller | protected
_pressedAbilities | APGUI::GUI_Controller | protected
_selectionaccumulator | APGUI::GUI_Controller | protected
_shownMenus | APGUI::GUI_Controller | protected
_timer | APGUI::GUI_Controller | protected
_toolTipShown | APGUI::GUI_Controller | protected
_toolTipTime | APGUI::GUI_Controller | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(SwitchLayout, MessageString) | APGUI::GUI_Controller | protected
DECLARE_REQUEST_INPUT(Sensor_0_mainClick, MessageBool, MessageBool) | APGUI::GUI_Controller | protected
DECLARE_REQUEST_INPUT(Sensor_1_mainClick, MessageBool, MessageBool) | APGUI::GUI_Controller | protected
DECLARE_REQUEST_INPUT(Sensor_0_contextClick, MessageBool, MessageBool) | APGUI::GUI_Controller | protected
DECLARE_REQUEST_INPUT(Sensor_1_contextClick, MessageBool, MessageBool) | APGUI::GUI_Controller | protected
DECLARE_REQUEST_OUTPUT(SelectedObjectID, MessageInt, MessageObjectID) | APGUI::GUI_Controller | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
enableGUI(bool enable) | APGUI::GUI_Controller |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getItembyName(string itemName) | APGUI::GUI_Controller |
getLayoutString() | APGUI::GUI_Controller | inline
getName() const | vrecko::Ability | inline
getorCreateGroup(string groupName) | APGUI::GUI_Controller |
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Controller() | APGUI::GUI_Controller |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::GUI_Controller | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointObjectByID(int sensor_number, unsigned long selectedID) | APGUI::GUI_Controller | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::GUI_Controller | protected
processContextClick(const int sensorNumber, const bool value) | APGUI::GUI_Controller | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
registerGlobalGuiItem(const int sensor, GUI_Item *item) | APGUI::GUI_Controller |
registerPointableGuiItem(const unsigned int ID, GUI_Item *item) | APGUI::GUI_Controller |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
reset() | APGUI::GUI_Controller |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setLayout(string name) | APGUI::GUI_Controller |
setMenuShown(const int sensor, Menu *shownMenu) | APGUI::GUI_Controller |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchLayout(string name) | APGUI::GUI_Controller |
unregisterGlobalGuiItem(const int sensor, GUI_Item *item) | APGUI::GUI_Controller |
unregisterPointableGuiItem(const unsigned int ID) | APGUI::GUI_Controller |
update() | APGUI::GUI_Controller | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Controller() | APGUI::GUI_Controller |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Item
APGUI::GUI_Item Member List

This is the complete list of members for APGUI::GUI_Item, including all inherited members.

_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_interconnections | APGUI::GUI_Item | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_name | APGUI::GUI_Item | protected
_parent | APGUI::GUI_Item | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::GUI_Item | protected
_state | APGUI::GUI_Item | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed)=0 | APGUI::GUI_Item | pure virtual
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const APGUI::GUI_ACTION action, const bool pressed)=0 | APGUI::GUI_Item | pure virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::GUI_Item | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setState(GUI_ITEM_STATE newState)=0 | APGUI::GUI_Item | pure virtual
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Item() | APGUI::GUI_Item |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • GUI_Text
APGUI::GUI_Text Member List

This is the complete list of members for APGUI::GUI_Text, including all inherited members.

_font | APGUI::GUI_Text | protectedstatic
_text | APGUI::GUI_Text | protected
GUI_Text() | APGUI::GUI_Text |
hide() | APGUI::GUI_Text |
setText(const std::string &content, const osg::Vec3 &pos, float size, osg::Vec4 &color=osg::Vec4(0.0, 0.0, 0.0, 1.0)) | APGUI::GUI_Text |
setText(const std::string &content) | APGUI::GUI_Text |
show() | APGUI::GUI_Text |
~GUI_Text() | APGUI::GUI_Text |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Icon
APGUI::Icon Member List

This is the complete list of members for APGUI::Icon, including all inherited members.

_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_externalDeactivation | APGUI::Icon | protected
_group | APGUI::Icon | protected
_initialScale | APGUI::Icon | protected
_interconnections | APGUI::GUI_Item | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_models | APGUI::Icon | protected
_name | APGUI::GUI_Item | protected
_parent | APGUI::GUI_Item | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::GUI_Item | protected
_state | APGUI::GUI_Item | protected
_switchActive_CoreChange | APGUI::Icon | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
_type | APGUI::Icon | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createModels(string basicModelString, string hullModelString) | APGUI::Icon | protected
DECLARE_OUTPUT(GUIItemClicked, MessageString) | APGUI::Icon | protected
DECLARE_OUTPUT(ExternalDeactivation, MessageObjectID) | APGUI::Icon | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
Icon() | APGUI::Icon |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::Icon | virtual
initialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position=osg::Vec3()) | APGUI::Icon |
APGUI::GUI_Item::initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed) | APGUI::Icon | virtual
postInitialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position) | APGUI::Icon | protected
APGUI::GUI_Item::postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::Icon | virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::GUI_Item | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPartColour(string partName, osg::Vec4 newColour) | APGUI::Icon |
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setState(GUI_ITEM_STATE newState) | APGUI::Icon | virtual
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
switchVisuals() | APGUI::Icon | protected
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Item() | APGUI::GUI_Item |
~Icon() | APGUI::Icon |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • IconColour
APGUI::IconColour Member List

This is the complete list of members for APGUI::IconColour, including all inherited members.

_colour | APGUI::IconColour | protected
_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_externalDeactivation | APGUI::Icon | protected
_group | APGUI::Icon | protected
_initialScale | APGUI::Icon | protected
_interconnections | APGUI::GUI_Item | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_models | APGUI::Icon | protected
_name | APGUI::GUI_Item | protected
_parent | APGUI::GUI_Item | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::GUI_Item | protected
_state | APGUI::GUI_Item | protected
_switchActive_CoreChange | APGUI::Icon | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
_type | APGUI::Icon | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createModels(string basicModelString, string hullModelString) | APGUI::Icon | protected
DECLARE_OUTPUT(Colour, MessageVec4) | APGUI::IconColour | protected
APGUI::Icon::DECLARE_OUTPUT(GUIItemClicked, MessageString) | APGUI::Icon | protected
APGUI::Icon::DECLARE_OUTPUT(ExternalDeactivation, MessageObjectID) | APGUI::Icon | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
Icon() | APGUI::Icon |
IconColour() | APGUI::IconColour |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::IconColour | virtual
APGUI::Icon::initialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position=osg::Vec3()) | APGUI::Icon |
APGUI::GUI_Item::initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed) | APGUI::Icon | virtual
postInitialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position) | APGUI::Icon | protected
APGUI::GUI_Item::postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::IconColour | virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::GUI_Item | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPartColour(string partName, osg::Vec4 newColour) | APGUI::Icon |
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setState(GUI_ITEM_STATE newState) | APGUI::Icon | virtual
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
switchVisuals() | APGUI::Icon | protected
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Item() | APGUI::GUI_Item |
~Icon() | APGUI::Icon |
~IconColour() | APGUI::IconColour |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Interconnection
APGUI::Interconnection Member List

This is the complete list of members for APGUI::Interconnection, including all inherited members.

Interconnection(const string typ, const string sen, const string rec) | APGUI::Interconnection | inline
receiver | APGUI::Interconnection |
sender | APGUI::Interconnection |
type | APGUI::Interconnection |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • ItemsGroup
APGUI::ItemsGroup Member List

This is the complete list of members for APGUI::ItemsGroup, including all inherited members.

_members | APGUI::ItemsGroup | protected
_name | APGUI::ItemsGroup | protected
addItem(GUI_Item *newItem) | APGUI::ItemsGroup |
getName() | APGUI::ItemsGroup | inline
ItemsGroup(string name) | APGUI::ItemsGroup |
reset() | APGUI::ItemsGroup |
setActiveMember(GUI_Item *activeItem) | APGUI::ItemsGroup |
~ItemsGroup() | APGUI::ItemsGroup |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Layout
APGUI::Layout Member List

This is the complete list of members for APGUI::Layout, including all inherited members.

_items | APGUI::Layout | protected
_itemsNames | APGUI::Layout | protected
_name | APGUI::Layout | protected
actualize(GuiItemMapType *map) | APGUI::Layout |
addItem(GUI_Item *) | APGUI::Layout |
getName() | APGUI::Layout | inline
hide() | APGUI::Layout |
initialize(string name, std::vector< string > *items) | APGUI::Layout |
Layout() | APGUI::Layout |
loadfromXMLnode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APGUI::Layout |
removeItem(GUI_Item *) | APGUI::Layout |
show() | APGUI::Layout |
~Layout() | APGUI::Layout |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Menu
APGUI::Menu Member List

This is the complete list of members for APGUI::Menu, including all inherited members.

_activeSensor | APGUI::Menu | protected
_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_dynamicMenuAbility | APGUI::Menu | protected
_interconnections | APGUI::GUI_Item | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_name | APGUI::GUI_Item | protected
_opened | APGUI::Menu | protected
_parent | APGUI::GUI_Item | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::GUI_Item | protected
_state | APGUI::GUI_Item | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(HidingMenu, MessageBool) | APGUI::Menu | protected
DECLARE_OUTPUT(CreateMenuStructure, MessageInt) | APGUI::Menu | protected
DECLARE_OUTPUT(ButtonPress, MessageBool) | APGUI::Menu | protected
DECLARE_REQUEST_OUTPUT(ActivePointerID, MessageInt, MessageInt) | APGUI::Menu | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::Menu | virtual
initialize(string name, string receiver, int sensor, string label="", string tooltip="", bool pointable=true) | APGUI::Menu |
APGUI::GUI_Item::initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
Menu() | APGUI::Menu |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed) | APGUI::Menu | inlinevirtual
postInitialize(string name, string receiver, int sensorNumber, string label, string tooltip) | APGUI::Menu | protected
APGUI::GUI_Item::postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::Menu | virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::GUI_Item | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setState(GUI_ITEM_STATE newState) | APGUI::Menu | virtual
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Item() | APGUI::GUI_Item |
~Menu() | APGUI::Menu |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APGUI
  • Slider
APGUI::Slider Member List

This is the complete list of members for APGUI::Slider, including all inherited members.

_colourActive | APGUI::GUI_Item | protected
_colourDefault | APGUI::GUI_Item | protected
_colourDisabled | APGUI::GUI_Item | protected
_colourHovered | APGUI::GUI_Item | protected
_colourPressed | APGUI::GUI_Item | protected
_controller | APGUI::GUI_Item | protected
_defaultStateActive | APGUI::GUI_Item | protected
_height | APGUI::Slider | protected
_interconnections | APGUI::GUI_Item | protected
_itemTransform | APGUI::GUI_Item | protected
_label | APGUI::GUI_Item | protected
_maximumValue | APGUI::Slider | protected
_minimumValue | APGUI::Slider | protected
_movableModel | APGUI::Slider | protected
_movableTransform | APGUI::Slider | protected
_name | APGUI::GUI_Item | protected
_oldValue | APGUI::Slider | protected
_parent | APGUI::GUI_Item | protected
_pointedCounter | APGUI::GUI_Item | protected
_pressed | APGUI::GUI_Item | protected
_receiver | APGUI::GUI_Item | protected
_sensorNumber | APGUI::Slider | protected
_state | APGUI::GUI_Item | protected
_staticModel | APGUI::Slider | protected
_step | APGUI::Slider | protected
_text | APGUI::Slider | protected
_texts | APGUI::GUI_Item | protected
_toolTip | APGUI::GUI_Item | protected
_width | APGUI::Slider | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createGeometry() | APGUI::Slider | protected
createModels(string geometryType) | APGUI::Slider |
DECLARE_INPUT(SliderValue, MessageFloat) | APGUI::Slider | protected
DECLARE_OUTPUT(GUIItemClicked, MessageString) | APGUI::Slider | protected
DECLARE_REQUEST_OUTPUT(SensorPosition, MessageInt, MessageVec3) | APGUI::Slider | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGUIItemName() | APGUI::GUI_Item | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getText() | APGUI::Slider | inline
getValue() | APGUI::Slider | inline
GUI_Item(const char *abName) | APGUI::GUI_Item |
GUI_Item::createLabel() | APGUI::GUI_Item | protected
hide() | APGUI::GUI_Item | inline
hideTooltip() | APGUI::GUI_Item |
initialize(string name, string receiver, string label, string tooltip, osg::Vec3 position=osg::Vec3()) | APGUI::Slider |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APGUI::Slider | virtual
APGUI::GUI_Item::initialize(bool pointable=true, int sensor=-1) | APGUI::GUI_Item | protected
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isDefaultStateActive() | APGUI::GUI_Item | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointed(bool pointed) | APGUI::Slider | virtual
postInitialize(string name, string receiver, string label, string tooltip, osg::Vec3 position) | APGUI::Slider | protected
APGUI::GUI_Item::postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(const int sensorNumber, const GUI_ACTION action, const bool pressed) | APGUI::Slider | virtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processInputPosition(int sensor_num, osg::Vec3 pos) | APGUI::Slider | protected
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sendValue(double value) | APGUI::Slider | protected
setAndSendValue(double value) | APGUI::Slider | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColours(osg::Vec4 colourActive, osg::Vec4 colourDefault, osg::Vec4 colourHovered, osg::Vec4 colourPressed, osg::Vec4 colourDisabled) | APGUI::Slider | virtual
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSliderParameters(double width, double heigh, double minValue, double MaxValue, double step) | APGUI::Slider |
setState(GUI_ITEM_STATE newState) | APGUI::Slider | virtual
setValue(double value) | APGUI::Slider |
show() | APGUI::GUI_Item | inline
showTooltip() | APGUI::GUI_Item |
Slider() | APGUI::Slider |
Slider::intersectSegmentandPlane(osg::Vec3 point0, osg::Vec3 point1, osg::Vec3 planeNormal, osg::Vec3 planePoint, osg::Vec3 *resultPoint) | APGUI::Slider | protected
switchVisuals() | APGUI::Slider | protected
transformHandPosition(osg::Vec3 &handPosition) | APGUI::Slider | protected
update() | APGUI::Slider | virtual
updated | vrecko::Ability | protected
updateSlider(osg::Vec3 handPosition) | APGUI::Slider | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GUI_Item() | APGUI::GUI_Item |
~Slider() | APGUI::Slider |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDDisplay
APHUD::HUDDisplay Member List

This is the complete list of members for APHUD::HUDDisplay, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addField(string field_name, string plugin_name) | APHUD::HUDDisplay |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addWindow(string plugin_name) | APHUD::HUDDisplay |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
camera | APHUD::HUDDisplay | protected
clean(void) | vrecko::Ability | inlinevirtual
clearValue(string field_name, string plugin_name) | APHUD::HUDDisplay |
correctName(string name) | APHUD::HUDDisplay | protected
cProfiles | APHUD::HUDDisplay | protected
definedcolorprofiles | APHUD::HUDDisplay | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
eo | APHUD::HUDDisplay | protected
fieldDefaultColorA | APHUD::HUDDisplay | protected
fieldDefaultColorB | APHUD::HUDDisplay | protected
fieldDefaultColorG | APHUD::HUDDisplay | protected
fieldDefaultColorR | APHUD::HUDDisplay | protected
fieldSizeVertical | APHUD::HUDDisplay | protected
fieldTabHorizontal | APHUD::HUDDisplay | protected
fieldTabVertical | APHUD::HUDDisplay | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
geode | APHUD::HUDDisplay | protected
getActualValue(string field_name, string plugin_name) | APHUD::HUDDisplay |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getHUDField(string field_name, string plugin_name) | APHUD::HUDDisplay | protected
getHUDWindow(string plugin_name) | APHUD::HUDDisplay | protected
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
HUDDepthField | APHUD::HUDDisplay | protected
HUDDepthFieldBackground | APHUD::HUDDisplay | protected
HUDDepthWindow | APHUD::HUDDisplay | protected
HUDDisplay() | APHUD::HUDDisplay |
HUDDivision | APHUD::HUDDisplay | protected
hudFieldExist(string field_name, string plugin_name) | APHUD::HUDDisplay |
hudWindowExist(string plugin_name) | APHUD::HUDDisplay |
hudWindows | APHUD::HUDDisplay | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APHUD::HUDDisplay | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APHUD::HUDDisplay | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APHUD::HUDDisplay | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAllFields(string plugin_name) | APHUD::HUDDisplay | protected
removeField(string field_name, string plugin_name) | APHUD::HUDDisplay |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeWindow(string plugin_name) | APHUD::HUDDisplay |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setColorProfileforWindow(string plugin_name, int colorprofile) | APHUD::HUDDisplay |
setFieldAsAnimated(string field_name, string plugin_name, bool value) | APHUD::HUDDisplay |
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setValue(string text, string field_name, string plugin_name) | APHUD::HUDDisplay | protected
startWindowHeight | APHUD::HUDDisplay | protected
startWindowWidth | APHUD::HUDDisplay | protected
stateSet | APHUD::HUDDisplay | protected
update(void) | APHUD::HUDDisplay | virtual
updateAllFields() | APHUD::HUDDisplay | protected
updateAllFieldsPosition() | APHUD::HUDDisplay | protected
updateAllWindows() | APHUD::HUDDisplay | protected
updateAllWindowsPositions() | APHUD::HUDDisplay | protected
updated | vrecko::Ability | protected
updateField(string field_name, string plugin_name) | APHUD::HUDDisplay | protected
updateFields(string plugin_name) | APHUD::HUDDisplay | protected
updateFieldsPosition(string plugin_name) | APHUD::HUDDisplay | protected
updateFieldTextColor(string field_name, string plugin_name, osg::Vec4f color) | APHUD::HUDDisplay |
updateGradient(string field_name, string plugin_name, osg::Vec4f startColor, osg::Vec4f endColor) | APHUD::HUDDisplay |
updateText(string text, string field_name, string plugin_name) | APHUD::HUDDisplay |
updateValue(float value, string field_name, string plugin_name) | APHUD::HUDDisplay |
updateValuesRange(string field_name, string plugin_name, float minValue, float maxValue) | APHUD::HUDDisplay |
updateWindow(string plugin_name) | APHUD::HUDDisplay | protected
updateWindowColor(string plugin_name, osg::Vec4f color) | APHUD::HUDDisplay |
updateWindowSizeX(string plugin_name) | APHUD::HUDDisplay | protected
viewer | APHUD::HUDDisplay | protected
viewHeight | APHUD::HUDDisplay | protected
viewWidth | APHUD::HUDDisplay | protected
windowDefaultColorA | APHUD::HUDDisplay | protected
windowDefaultColorB | APHUD::HUDDisplay | protected
windowDefaultColorG | APHUD::HUDDisplay | protected
windowDefaultColorR | APHUD::HUDDisplay | protected
windowTabHorizontal | APHUD::HUDDisplay | protected
windowTabVertical | APHUD::HUDDisplay | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~HUDDisplay() | APHUD::HUDDisplay | inline
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHelloWorld
  • MyAbility
APHelloWorld::MyAbility Member List

This is the complete list of members for APHelloWorld::MyAbility, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APHelloWorld::MyAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
MyAbility() | APHelloWorld::MyAbility |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | APHelloWorld::MyAbility | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~MyAbility() | APHelloWorld::MyAbility |
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APInputConnector
  • InputConnector
APInputConnector::InputConnector Member List

This is the complete list of members for APInputConnector::InputConnector, including all inherited members.

_actionMap | APInputConnector::InputConnector | protected
_lastCheckedPositions | APInputConnector::InputConnector | protected
_lastKnownOrientations | APInputConnector::InputConnector | protected
_lastKnownPointedObjects | APInputConnector::InputConnector | protected
_lastKnownPositions | APInputConnector::InputConnector | protected
_outputMappingsWithPriorities | APInputConnector::InputConnector | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_OUTPUT(Sensor_0_position, MessageVec3) | APInputConnector::InputConnector | protected
DECLARE_OUTPUT(Sensor_0_orientation, MessageQuat) | APInputConnector::InputConnector | protected
DECLARE_OUTPUT(Sensor_1_position, MessageVec3) | APInputConnector::InputConnector | protected
DECLARE_OUTPUT(Sensor_1_orientation, MessageQuat) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_INPUT(SensorPosition, MessageInt, MessageVec3) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_INPUT(SensorOrientation, MessageInt, MessageQuat) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_INPUT(SensorTransformation, MessageInt, MessageSensorTransformation) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_INPUT(MenuSensorPosition, MessageInt, MessageVec3) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_INPUT(SelectedObjectID, MessageInt, MessageObjectID) | APInputConnector::InputConnector | protected
DECLARE_REQUEST_OUTPUT(SelectionByPointerPos, MessageVec3, MessageObjectID) | APInputConnector::InputConnector | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getChildNodesbyName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, const string childNodeName) | APInputConnector::InputConnector | protected
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | APInputConnector::InputConnector | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
InputConnector() | APInputConnector::InputConnector |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
parseEventName(const std::string &input_name) | APInputConnector::InputConnector | static
parseInputDevice(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode) | APInputConnector::InputConnector | protected
parseInputMappingPair(string deviceID, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode) | APInputConnector::InputConnector | protected
parseOutputMappingPair(vrecko::Ability *receiverAbility, std::string receiverString, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pairNode) | APInputConnector::InputConnector | protected
parseReceiverAbility(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *ChainPairNode) | APInputConnector::InputConnector | protected
parseSenderReceiver(std::string sr, bool isSender, BaseClass **pEntity, bool bNoErrorOutput) | APInputConnector::InputConnector | protected
parseSensorNumber(const std::string &input_name) | APInputConnector::InputConnector | static
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processAction(int sensorNumber, VreckoMessage *value, const std::string &input_name) | APInputConnector::InputConnector |
processChainofResponsibility(ReceiversList *receivers, MessageBool *value) | APInputConnector::InputConnector | protected
processEvent(const std::string &input_name, VreckoMessage *value) | APInputConnector::InputConnector | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
ProcessOrientation(int sensorNumber, VreckoMessage *value, const std::string &input_name) | APInputConnector::InputConnector |
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processSensorTransformation(int sensorNumber, VreckoMessage *value, const std::string &input_name) | APInputConnector::InputConnector |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APInputConnector::InputConnector | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~InputConnector() | APInputConnector::InputConnector |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • Editor
APLightsEditor::Editor Member List

This is the complete list of members for APLightsEditor::Editor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APLightsEditor::Editor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actLightID | APLightsEditor::Editor | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APLightsEditor::Editor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
DrawPoint(osg::Vec3 position, float pointRadius, osg::Vec4 pointColor) | APLightsEditor::Editor | protected
Editor() | APLightsEditor::Editor |
fillDefaultInfo() | APLightsEditor::Editor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
giMode | APLightsEditor::Editor | protected
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode=NULL) | APLightsEditor::Editor | protectedvirtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
lightManager | APLightsEditor::Editor | protected
lightMarker | APLightsEditor::Editor | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
makeMenu() | APLightsEditor::Editor | protected
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | APLightsEditor::Editor | protectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | APLightsEditor::Editor | protectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveToXML(const char *FileName) | APLightsEditor::Editor | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shadeMode | APLightsEditor::Editor | protected
shadowMode | APLightsEditor::Editor | protected
showMenu() | vrecko::ControllableAbility | protectedvirtual
sunID | APLightsEditor::Editor | protected
update(void) | APLightsEditor::Editor | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~Editor() | APLightsEditor::Editor | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • Lights
APLightsEditor::Lights Member List

This is the complete list of members for APLightsEditor::Lights, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
add(osg::Vec4 position=osg::Vec4(0, 0, 0, 1), osg::Vec3 direction=osg::Vec3(0, 0,-1), float spotCutOff=180, float spotExp=0) | APLightsEditor::Lights |
add(osg::LightSource *lightSource) | APLightsEditor::Lights |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addSun(int day, int month, int year, int hour, int minute, osg::Vec4 *sunPosition=NULL) | APLightsEditor::Lights |
at(int lightNum) | APLightsEditor::Lights |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createBuffer(osg::Vec2 textureSize, osg::Texture::FilterMode filter, osg::Texture::WrapMode wrap, GLint internalFormat, GLenum sourceFormat) | APLightsEditor::Lights |
createFlare(int lightNum) | APLightsEditor::Lights |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
enableShadows(bool OnOrOff) | APLightsEditor::Lights |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
FULL enum value | APLightsEditor::Lights |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getBlurSize() | APLightsEditor::Lights |
getBounceRadius() | APLightsEditor::Lights |
getBounceSampleCount() | APLightsEditor::Lights |
getClearColor() | APLightsEditor::Lights |
getCurrectShadingMode() | APLightsEditor::Lights | inline
getCurrentGIMode() | APLightsEditor::Lights | inline
getCurrentShadowLightID() | APLightsEditor::Lights |
getCurrentShadowMode() | APLightsEditor::Lights | inline
getDORadius() | APLightsEditor::Lights |
getDOSampleCount() | APLightsEditor::Lights |
getFlares() | APLightsEditor::Lights | inline
getGlobalAmbient() | APLightsEditor::Lights | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLight(int lightNum) | APLightsEditor::Lights |
getLightSource(int lightNum) | APLightsEditor::Lights |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getShadowTechnique() | APLightsEditor::Lights |
getSunDate() | APLightsEditor::Lights | inline
giMode | APLightsEditor::Lights |
giModes enum name | APLightsEditor::Lights |
GOURAUD enum value | APLightsEditor::Lights |
HALF enum value | APLightsEditor::Lights |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
InitializeGI() | APLightsEditor::Lights |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isShadowsEnabled() | APLightsEditor::Lights |
isUpdated(void) | vrecko::Ability |
Lights(void) | APLightsEditor::Lights |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APLightsEditor::Lights | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NO enum value | APLightsEditor::Lights |
NONE enum value | APLightsEditor::Lights |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHONG enum value | APLightsEditor::Lights |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APLightsEditor::Lights | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APLightsEditor::Lights | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
remove(int lightNum) | APLightsEditor::Lights |
removeAll() | APLightsEditor::Lights |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setActiveShadowLight(int lightNum) | APLightsEditor::Lights |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBlurSize(int size) | APLightsEditor::Lights |
setBounceRadius(float radius) | APLightsEditor::Lights |
setBounceSampleCount(int count) | APLightsEditor::Lights |
setClearColor(osg::Vec4 color) | APLightsEditor::Lights |
setDORadius(float radius) | APLightsEditor::Lights |
setDOSampleCount(int count) | APLightsEditor::Lights |
setGlobalAmbient(osg::Vec4 color) | APLightsEditor::Lights |
setID(const char *pID) | vrecko::Ability |
setLightVisibility(int lightNum, bool on) | APLightsEditor::Lights |
setMode(shadowModes shadowMode, shadingModes shadingMode, giModes giMode) | APLightsEditor::Lights |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setUpCamera(osg::ref_ptr< osg::Camera > camera, osg::Vec2 textureSize, osg::ref_ptr< osg::StateSet > camSS, osg::ref_ptr< osg::Shader > vert, osg::ref_ptr< osg::Shader > frag) | APLightsEditor::Lights |
shadeMode | APLightsEditor::Lights |
shadingModes enum name | APLightsEditor::Lights |
SHADOW_MAP enum value | APLightsEditor::Lights |
shadowMode | APLightsEditor::Lights |
shadowModes enum name | APLightsEditor::Lights |
size() | APLightsEditor::Lights |
SOFT_SHADOW_MAP enum value | APLightsEditor::Lights |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Lights(void) | APLightsEditor::Lights |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • DynamicMenu
APMenu::DynamicMenu Member List

This is the complete list of members for APMenu::DynamicMenu, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activePointerID | APMenu::DynamicMenu | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addMenuItem(MenuItem *parentItem, MenuItem *itemToAdd) | APMenu::DynamicMenu |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
attributes | APMenu::DynamicMenu | protected
autoMoveShift | APMenu::DynamicMenu | protected
bAllowSelectOnRelease | APMenu::DynamicMenu | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
baseDirectory | APMenu::DynamicMenu | protected
bMainButtonPressed | APMenu::DynamicMenu | protected
changeToStructureOccured() | APMenu::DynamicMenu | protected
clean(void) | vrecko::Ability | inlinevirtual
collapseItem(MenuItem *item) | APMenu::DynamicMenu | protected
collapseSiblings(MenuItem *item) | APMenu::DynamicMenu | protected
confirmAnimationEnded() | APMenu::DynamicMenu | protected
createMainObjects() | APMenu::DynamicMenu | protected
createMenuFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *paramNode) | APMenu::DynamicMenu | protected
createMenuFromString() | APMenu::DynamicMenu | protected
createPointerTrail() | APMenu::DynamicMenu | protected
DECLARE_INPUT(Create, MessageString) | APMenu::DynamicMenu | protected
DECLARE_INPUT(ButtonPress, MessageBool) | APMenu::DynamicMenu | protected
DECLARE_INPUT(ConfirmAnimationEnded, MessageBool) | APMenu::DynamicMenu | protected
DECLARE_OUTPUT(Clicked, MessageString) | APMenu::DynamicMenu | protected
DECLARE_OUTPUT(HidingMenu, MessageBool) | APMenu::DynamicMenu | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | APMenu::DynamicMenu | protected
DECLARE_REQUEST_OUTPUT(PointerPosition, MessageInt, MessageVec3) | APMenu::DynamicMenu | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
deleteMenuItem(MenuItem *item) | APMenu::DynamicMenu |
destroyMainObjects() | APMenu::DynamicMenu | protected
destroyMenuStructure() | APMenu::DynamicMenu | protected
destroyPointerTrail() | APMenu::DynamicMenu | protected
dispEO | APMenu::DynamicMenu | protected
DynamicMenu() | APMenu::DynamicMenu |
expandItem(MenuItem *item) | APMenu::DynamicMenu | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &name) | APMenu::DynamicMenu | inline
vrecko::Ability::getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLastPointerPos() | APMenu::DynamicMenu | inline
getMainObject() | APMenu::DynamicMenu | inline
getMenuType() | APMenu::DynamicMenu | inline
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner() | APMenu::DynamicMenu | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPointedItemRecursive(MenuItem *parent, int *depth) | APMenu::DynamicMenu | protected
getPriority(void) const | vrecko::BaseClass | inline
getProjPointerPos() | APMenu::DynamicMenu | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSignObject(const std::string &name) | APMenu::DynamicMenu |
hideChildMenu(MenuItem *parentItem=NULL, bool bIncludeSubMenus=true) | APMenu::DynamicMenu | protected
hideMainMenuObject() | APMenu::DynamicMenu | protected
hideMenu() | APMenu::DynamicMenu |
hidePointerTrail() | APMenu::DynamicMenu | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initStandardSignSet() | APMenu::DynamicMenu | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
insertMenuItem(MenuItem *parentItem, MenuItem *prevSibling, MenuItem *itemToAdd) | APMenu::DynamicMenu |
inverseTransformMatrix | APMenu::DynamicMenu | protected
isMainButtonPressed() | APMenu::DynamicMenu | inline
isSelectionLocked() | APMenu::DynamicMenu | inline
isUpdated(void) | vrecko::Ability |
isVisible() | APMenu::DynamicMenu | protected
itemClicked(MenuItem *item) | APMenu::DynamicMenu | protected
itemTree | APMenu::DynamicMenu |
lastPointerPos | APMenu::DynamicMenu | protected
lastViewPos | APMenu::DynamicMenu | protected
loadAttributes(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *attribsNode) | APMenu::DynamicMenu | protected
loadMenuItems(MenuItem *parentItem, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode) | APMenu::DynamicMenu | protected
loadMenuStructureFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *paramNode) | APMenu::DynamicMenu | protected
loadSignsFromXML(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *attribsNode) | APMenu::DynamicMenu | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APMenu::DynamicMenu | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mainButtonPressed() | APMenu::DynamicMenu | protected
mainButtonReleased() | APMenu::DynamicMenu | protected
mainObject | APMenu::DynamicMenu | protected
menuGrid_columnsCached | APMenu::DynamicMenu | protected
menuGrid_getSize(int *columns, int *rows) | APMenu::DynamicMenu | protected
menuGrid_rowsCached | APMenu::DynamicMenu | protected
MenuItem class | APMenu::DynamicMenu | friend
menuString | APMenu::DynamicMenu | protected
menuType | APMenu::DynamicMenu | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
origMenuPos | APMenu::DynamicMenu | protected
origViewLookAt | APMenu::DynamicMenu | protected
origViewPos | APMenu::DynamicMenu | protected
origViewUp | APMenu::DynamicMenu | protected
osgPointerTrail | APMenu::DynamicMenu | protected
osgPointerTrailDrawable | APMenu::DynamicMenu | protected
osgPointerTrailGeode | APMenu::DynamicMenu | protected
osgPointerTrailTransform | APMenu::DynamicMenu | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APMenu::DynamicMenu | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pointerMoved(osg::Vec3 *pointerPos) | APMenu::DynamicMenu | protected
pointerSelected | APMenu::DynamicMenu | protected
pointerSelectItem(MenuItem *item) | APMenu::DynamicMenu | protected
pointerUnselectItem(bool bLeaveSelectedIfLocked=true) | APMenu::DynamicMenu | protected
pointerViewMovedHelper() | APMenu::DynamicMenu | protected
postInitialize() | APMenu::DynamicMenu | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APMenu::DynamicMenu | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
projPointerPos | APMenu::DynamicMenu | protected
registeredItemTypes | APMenu::DynamicMenu | protected
registerNewItemType(MenuItem *itemTemplate) | APMenu::DynamicMenu |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetBaseValues() | APMenu::DynamicMenu | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selectedItem | APMenu::DynamicMenu | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sendToClickedOutput(char *eventValue) | APMenu::DynamicMenu |
setAttribute(const std::string &name, float value) | APMenu::DynamicMenu | inline
vrecko::Ability::setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setMenuString(const char *newMenuString) | APMenu::DynamicMenu |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSign(const std::string &name, const std::string &value) | APMenu::DynamicMenu |
shadowEO | APMenu::DynamicMenu | protected
showChildMenu(MenuItem *parentItem, bool bSetNewRoot) | APMenu::DynamicMenu | protected
showMainMenuObject() | APMenu::DynamicMenu | protected
showMenu(osg::Vec3 *_menuPos) | APMenu::DynamicMenu |
showPointerTrail() | APMenu::DynamicMenu | protected
signs | APMenu::DynamicMenu | protected
solvePointerSelection() | APMenu::DynamicMenu | protected
transPointerPos | APMenu::DynamicMenu | protected
transViewPos | APMenu::DynamicMenu | protected
unselectItem() | APMenu::DynamicMenu | protected
update() | APMenu::DynamicMenu | virtual
updated | vrecko::Ability | protected
updateInverseCalc() | APMenu::DynamicMenu | protected
updateMainObjectTransformation() | APMenu::DynamicMenu | protected
updatePointerPosition() | APMenu::DynamicMenu | protected
viewMoved() | APMenu::DynamicMenu | protected
visibleMenuRoot | APMenu::DynamicMenu | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DynamicMenu() | APMenu::DynamicMenu | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • DynamicMenuSign
APMenu::DynamicMenuSign Member List

This is the complete list of members for APMenu::DynamicMenuSign, including all inherited members.

geometry | APMenu::DynamicMenuSign
value | APMenu::DynamicMenuSign
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItem
APMenu::MenuItem Member List

This is the complete list of members for APMenu::MenuItem, including all inherited members.

addInputOutputs() | APMenu::MenuItem | protectedvirtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bConfirmationEndedConnectionCreated | APMenu::MenuItem | protected
bGraphicsCreated | APMenu::MenuItem | protected
bIsVisible | APMenu::MenuItem | protected
canBeClicked() | APMenu::MenuItem | inlinevirtual
canBeExpanded() | APMenu::MenuItem | inline
childMenuAnimator | APMenu::MenuItem | protected
childMenuObject | APMenu::MenuItem | protected
clicked() | APMenu::MenuItem | inlinevirtual
color | APMenu::MenuItem | protected
createGraphics() | APMenu::MenuItem | protected
createGraphicsCore() | APMenu::MenuItem | protectedvirtual
createNewItem(DynamicMenu *_owner)=0 | APMenu::MenuItem | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroy() | APMenu::MenuItem | virtual
destroyGraphics() | APMenu::MenuItem | protected
destroyGraphicsCore() | APMenu::MenuItem | protectedvirtual
dwFlags | APMenu::MenuItem | protected
dwItemIndex | APMenu::MenuItem | protected
dwNumItems | APMenu::MenuItem | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getChildMenuObject() | APMenu::MenuItem | inline
getClickedString(char *outClickedEventString, size_t bufferSize) | APMenu::MenuItem | inlinevirtual
GetDepth() | DynTreeNode< MenuItem > |
getFlags() | APMenu::MenuItem | inline
getInnerBoundingBox()=0 | APMenu::MenuItem | protectedpure virtual
getInputPin(const char *strName) | vrecko::BaseClass |
getName() | APMenu::MenuItem | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
hide(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
hideGraphics() | APMenu::MenuItem | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
invalidate(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
isExpanded() | APMenu::MenuItem | inline
isGraphicsCreated() | APMenu::MenuItem | inline
isPointed(osg::Vec3 *projPointerPos) | APMenu::MenuItem |
isVisible() | APMenu::MenuItem | inline
itemSize | APMenu::MenuItem | protected
itemSize2 | APMenu::MenuItem | protected
loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APMenu::MenuItem | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lpChild | DynTreeNode< MenuItem > |
lpNext | DynTreeNode< MenuItem > |
lpParent | DynTreeNode< MenuItem > |
lpPrev | DynTreeNode< MenuItem > |
mainTransform | APMenu::MenuItem | protected
menuBoxes_CalcItemDisplayIndex() | APMenu::MenuItem | protected
MenuItem(DynamicMenu *_owner) | APMenu::MenuItem |
menuRadial_CalcItemAngle(int _iItemIndex) | APMenu::MenuItem | protected
name | APMenu::MenuItem | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APMenu::MenuItem | protected
osgTransform | APMenu::MenuItem | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APMenu::MenuItem | protected
PinList typedef | vrecko::BaseClass | protected
pointerButtonDown() | APMenu::MenuItem | inlinevirtual
pointerButtonUp() | APMenu::MenuItem | inlinevirtual
pointerMove(osg::Vec3 *projPointerPos) | APMenu::MenuItem | inlinevirtual
pos | APMenu::MenuItem | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APMenu::MenuItem | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
qshapeDraw | APMenu::MenuItem | protected
refPoint1 | APMenu::MenuItem | protected
refPoint2 | APMenu::MenuItem | protected
refPoint3 | APMenu::MenuItem | protected
removeInputOutputs() | APMenu::MenuItem | protectedvirtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetConfirmationEffect() | APMenu::MenuItem | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAndPlayConfirmationEffect() | APMenu::MenuItem | virtual
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setFlags(unsigned long dwNewFlags, bool bForceUpdate=false) | APMenu::MenuItem |
setFlagsCore(unsigned long dwOldFlags, unsigned long dwNewFlags) | APMenu::MenuItem | protectedvirtual
setName(const char *newName) | APMenu::MenuItem | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shapeBox | APMenu::MenuItem | protected
shapeDraw | APMenu::MenuItem | protected
shapeSection | APMenu::MenuItem | protected
show(unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3) | APMenu::MenuItem | virtual
showGraphicsAtPoint() | APMenu::MenuItem | protectedvirtual
tree | DynTreeNode< MenuItem > |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~MenuItem() | APMenu::MenuItem | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemNull
APMenu::MenuItemNull Member List

This is the complete list of members for APMenu::MenuItemNull, including all inherited members.

addInputOutputs() | APMenu::MenuItem | protectedvirtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bbox | APMenu::MenuItemNull | protected
bConfirmationEndedConnectionCreated | APMenu::MenuItem | protected
bGraphicsCreated | APMenu::MenuItem | protected
bIsVisible | APMenu::MenuItem | protected
canBeClicked() | APMenu::MenuItemNull | inlinevirtual
canBeExpanded() | APMenu::MenuItem | inline
childMenuAnimator | APMenu::MenuItem | protected
childMenuObject | APMenu::MenuItem | protected
clicked() | APMenu::MenuItem | inlinevirtual
color | APMenu::MenuItem | protected
createGraphics() | APMenu::MenuItem | protected
createGraphicsCore() | APMenu::MenuItemNull | inlineprotectedvirtual
createNewItem(DynamicMenu *_owner) | APMenu::MenuItemNull | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroy() | APMenu::MenuItem | virtual
destroyGraphics() | APMenu::MenuItem | protected
destroyGraphicsCore() | APMenu::MenuItemNull | inlineprotectedvirtual
dwFlags | APMenu::MenuItem | protected
dwItemIndex | APMenu::MenuItem | protected
dwNumItems | APMenu::MenuItem | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getChildMenuObject() | APMenu::MenuItem | inline
getClickedString(char *outClickedEventString, size_t bufferSize) | APMenu::MenuItem | inlinevirtual
GetDepth() | DynTreeNode< MenuItem > |
getFlags() | APMenu::MenuItem | inline
getInnerBoundingBox() | APMenu::MenuItemNull | inlineprotectedvirtual
getInputPin(const char *strName) | vrecko::BaseClass |
getName() | APMenu::MenuItem | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
hide(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
hideGraphics() | APMenu::MenuItemNull | inlineprotectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
invalidate(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
isExpanded() | APMenu::MenuItem | inline
isGraphicsCreated() | APMenu::MenuItem | inline
isPointed(osg::Vec3 *projPointerPos) | APMenu::MenuItem |
isVisible() | APMenu::MenuItem | inline
itemSize | APMenu::MenuItem | protected
itemSize2 | APMenu::MenuItem | protected
loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APMenu::MenuItem | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lpChild | DynTreeNode< MenuItem > |
lpNext | DynTreeNode< MenuItem > |
lpParent | DynTreeNode< MenuItem > |
lpPrev | DynTreeNode< MenuItem > |
mainTransform | APMenu::MenuItem | protected
menuBoxes_CalcItemDisplayIndex() | APMenu::MenuItem | protected
MenuItem(DynamicMenu *_owner) | APMenu::MenuItem |
MenuItemNull(DynamicMenu *_owner) | APMenu::MenuItemNull | inline
menuRadial_CalcItemAngle(int _iItemIndex) | APMenu::MenuItem | protected
name | APMenu::MenuItem | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APMenu::MenuItem | protected
osgTransform | APMenu::MenuItem | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APMenu::MenuItem | protected
PinList typedef | vrecko::BaseClass | protected
pointerButtonDown() | APMenu::MenuItem | inlinevirtual
pointerButtonUp() | APMenu::MenuItem | inlinevirtual
pointerMove(osg::Vec3 *projPointerPos) | APMenu::MenuItem | inlinevirtual
pos | APMenu::MenuItem | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APMenu::MenuItem | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
qshapeDraw | APMenu::MenuItem | protected
refPoint1 | APMenu::MenuItem | protected
refPoint2 | APMenu::MenuItem | protected
refPoint3 | APMenu::MenuItem | protected
removeInputOutputs() | APMenu::MenuItem | protectedvirtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetConfirmationEffect() | APMenu::MenuItem | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAndPlayConfirmationEffect() | APMenu::MenuItem | virtual
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setFlags(unsigned long dwNewFlags, bool bForceUpdate=false) | APMenu::MenuItem |
setFlagsCore(unsigned long dwOldFlags, unsigned long dwNewFlags) | APMenu::MenuItem | protectedvirtual
setName(const char *newName) | APMenu::MenuItem | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shapeBox | APMenu::MenuItem | protected
shapeDraw | APMenu::MenuItem | protected
shapeSection | APMenu::MenuItem | protected
show(unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3) | APMenu::MenuItem | virtual
showGraphicsAtPoint() | APMenu::MenuItemNull | inlineprotectedvirtual
tree | DynTreeNode< MenuItem > |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~MenuItem() | APMenu::MenuItem | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemSlider
APMenu::MenuItemSlider Member List

This is the complete list of members for APMenu::MenuItemSlider, including all inherited members.

addInputOutputs() | APMenu::MenuItemSlider | protectedvirtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bConfirmationEndedConnectionCreated | APMenu::MenuItem | protected
bGraphicsCreated | APMenu::MenuItem | protected
bIntegerOnlySlider | APMenu::MenuItemSlider | protected
bIsVisible | APMenu::MenuItem | protected
boundingBox | APMenu::MenuItemText | protected
bSliding | APMenu::MenuItemSlider | protected
canBeClicked() | APMenu::MenuItemSlider | inlinevirtual
canBeExpanded() | APMenu::MenuItem | inline
caption | APMenu::MenuItemText | protected
childMenuAnimator | APMenu::MenuItem | protected
childMenuObject | APMenu::MenuItem | protected
clicked() | APMenu::MenuItemSlider | inlinevirtual
color | APMenu::MenuItem | protected
createGraphics() | APMenu::MenuItem | protected
createGraphicsCore() | APMenu::MenuItemSlider | protectedvirtual
createModel() | APMenu::MenuItemText | protectedvirtual
createNewItem(DynamicMenu *_owner) | APMenu::MenuItemSlider | inlinevirtual
DECLARE_OUTPUT(Slide, MessageFloat) | APMenu::MenuItemSlider | protected
APMenu::MenuItemText::DECLARE_OUTPUT(Clicked, MessageBool) | APMenu::MenuItemText | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroy() | APMenu::MenuItemSlider | virtual
destroyGraphics() | APMenu::MenuItem | protected
destroyGraphicsCore() | APMenu::MenuItemSlider | protectedvirtual
destroyModel() | APMenu::MenuItemText | protectedvirtual
dwFlags | APMenu::MenuItem | protected
dwItemIndex | APMenu::MenuItem | protected
dwNumItems | APMenu::MenuItem | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fSliderFromX | APMenu::MenuItemSlider | protected
fSliderPos01 | APMenu::MenuItemSlider | protected
fSliderToY | APMenu::MenuItemSlider | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCaption() | APMenu::MenuItemText | inlinevirtual
getChildMenuObject() | APMenu::MenuItem | inline
getClickedString(char *outClickedEventString, size_t bufferSize) | APMenu::MenuItemSlider | virtual
GetDepth() | DynTreeNode< MenuItem > |
getFlags() | APMenu::MenuItem | inline
getInnerBoundingBox() | APMenu::MenuItemSlider | protectedvirtual
getInputPin(const char *strName) | vrecko::BaseClass |
getModelFile() | APMenu::MenuItemText | inlinevirtual
getName() | APMenu::MenuItem | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPointerSliderPos01(bool *bIsOutside) | APMenu::MenuItemSlider | protected
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getSliderPos01() | APMenu::MenuItemSlider | inlinevirtual
getSliderPosXY() | APMenu::MenuItemSlider | virtual
getTextBoundingBox(osg::BoundingBox *outBox) | APMenu::MenuItemText | protected
hide(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
hideGraphics() | APMenu::MenuItem | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
invalidate(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
isExpanded() | APMenu::MenuItem | inline
isGraphicsCreated() | APMenu::MenuItem | inline
isPointed(osg::Vec3 *projPointerPos) | APMenu::MenuItem |
isVisible() | APMenu::MenuItem | inline
itemSize | APMenu::MenuItem | protected
itemSize2 | APMenu::MenuItem | protected
loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APMenu::MenuItemSlider | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lpChild | DynTreeNode< MenuItem > |
lpNext | DynTreeNode< MenuItem > |
lpParent | DynTreeNode< MenuItem > |
lpPrev | DynTreeNode< MenuItem > |
mainTransform | APMenu::MenuItem | protected
menuBoxes_CalcItemDisplayIndex() | APMenu::MenuItem | protected
MenuItem(DynamicMenu *_owner) | APMenu::MenuItem |
MenuItemSlider(DynamicMenu *_owner) | APMenu::MenuItemSlider |
MenuItemText(DynamicMenu *_owner) | APMenu::MenuItemText |
menuRadial_CalcItemAngle(int _iItemIndex) | APMenu::MenuItem | protected
model | APMenu::MenuItemText | protected
modelFile | APMenu::MenuItemText | protected
modelTransform | APMenu::MenuItemText | protected
name | APMenu::MenuItem | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APMenu::MenuItem | protected
osgText | APMenu::MenuItemText | protected
osgTransform | APMenu::MenuItem | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APMenu::MenuItem | protected
PinList typedef | vrecko::BaseClass | protected
pointerButtonDown() | APMenu::MenuItemSlider | virtual
pointerButtonUp() | APMenu::MenuItemSlider | virtual
pointerMove(osg::Vec3 *projPointerPos) | APMenu::MenuItemSlider | virtual
pos | APMenu::MenuItem | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APMenu::MenuItem | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
qshapeDraw | APMenu::MenuItem | protected
refPoint1 | APMenu::MenuItem | protected
refPoint2 | APMenu::MenuItem | protected
refPoint3 | APMenu::MenuItem | protected
removeInputOutputs() | APMenu::MenuItemSlider | protectedvirtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
repositionModel() | APMenu::MenuItemText | protectedvirtual
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetConfirmationEffect() | APMenu::MenuItem | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAndPlayConfirmationEffect() | APMenu::MenuItem | virtual
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCaption(const char *newCaption) | APMenu::MenuItemText | virtual
setFlags(unsigned long dwNewFlags, bool bForceUpdate=false) | APMenu::MenuItem |
setFlagsCore(unsigned long dwOldFlags, unsigned long dwNewFlags) | APMenu::MenuItem | protectedvirtual
setModelFile(const char *newModelFile) | APMenu::MenuItemText | virtual
setName(const char *newName) | APMenu::MenuItem | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSignName(const char *name) | APMenu::MenuItemText |
setSliderPos01(float fNewSliderPos01, bool bSendEvent=true) | APMenu::MenuItemSlider | virtual
setSliderPosXY(float fNewSliderPos, bool bSendEvent=true) | APMenu::MenuItemSlider | inlinevirtual
shapeBox | APMenu::MenuItem | protected
shapeDraw | APMenu::MenuItem | protected
shapeSection | APMenu::MenuItem | protected
show(unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3) | APMenu::MenuItem | virtual
showGraphicsAtPoint() | APMenu::MenuItemSlider | protectedvirtual
signName | APMenu::MenuItemText | protected
signObject | APMenu::MenuItemText | protected
signTransform | APMenu::MenuItemText | protected
sliderDrawM | APMenu::MenuItemSlider | protected
sliderDrawNM | APMenu::MenuItemSlider | protected
sliderMovable | APMenu::MenuItemSlider | protected
sliderNonmovable | APMenu::MenuItemSlider | protected
textShift | APMenu::MenuItemText | protected
tree | DynTreeNode< MenuItem > |
update(void) | vrecko::BaseClass | inlinevirtual
updateSliderGraphicPos() | APMenu::MenuItemSlider | protected
updateText() | APMenu::MenuItemSlider | protectedvirtual
~BaseClass() | vrecko::BaseClass | virtual
~MenuItem() | APMenu::MenuItem | virtual
~MenuItemSlider() | APMenu::MenuItemSlider | virtual
~MenuItemText() | APMenu::MenuItemText | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuItemText
APMenu::MenuItemText Member List

This is the complete list of members for APMenu::MenuItemText, including all inherited members.

addInputOutputs() | APMenu::MenuItemText | protectedvirtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bConfirmationEndedConnectionCreated | APMenu::MenuItem | protected
bGraphicsCreated | APMenu::MenuItem | protected
bIsVisible | APMenu::MenuItem | protected
boundingBox | APMenu::MenuItemText | protected
canBeClicked() | APMenu::MenuItem | inlinevirtual
canBeExpanded() | APMenu::MenuItem | inline
caption | APMenu::MenuItemText | protected
childMenuAnimator | APMenu::MenuItem | protected
childMenuObject | APMenu::MenuItem | protected
clicked() | APMenu::MenuItemText | virtual
color | APMenu::MenuItem | protected
createGraphics() | APMenu::MenuItem | protected
createGraphicsCore() | APMenu::MenuItemText | protectedvirtual
createModel() | APMenu::MenuItemText | protectedvirtual
createNewItem(DynamicMenu *_owner) | APMenu::MenuItemText | inlinevirtual
DECLARE_OUTPUT(Clicked, MessageBool) | APMenu::MenuItemText | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroy() | APMenu::MenuItemText | virtual
destroyGraphics() | APMenu::MenuItem | protected
destroyGraphicsCore() | APMenu::MenuItemText | protectedvirtual
destroyModel() | APMenu::MenuItemText | protectedvirtual
dwFlags | APMenu::MenuItem | protected
dwItemIndex | APMenu::MenuItem | protected
dwNumItems | APMenu::MenuItem | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCaption() | APMenu::MenuItemText | inlinevirtual
getChildMenuObject() | APMenu::MenuItem | inline
getClickedString(char *outClickedEventString, size_t bufferSize) | APMenu::MenuItem | inlinevirtual
GetDepth() | DynTreeNode< MenuItem > |
getFlags() | APMenu::MenuItem | inline
getInnerBoundingBox() | APMenu::MenuItemText | protectedvirtual
getInputPin(const char *strName) | vrecko::BaseClass |
getModelFile() | APMenu::MenuItemText | inlinevirtual
getName() | APMenu::MenuItem | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTextBoundingBox(osg::BoundingBox *outBox) | APMenu::MenuItemText | protected
hide(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
hideGraphics() | APMenu::MenuItem | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
invalidate(bool bIncludeSubItems=false) | APMenu::MenuItem | virtual
isExpanded() | APMenu::MenuItem | inline
isGraphicsCreated() | APMenu::MenuItem | inline
isPointed(osg::Vec3 *projPointerPos) | APMenu::MenuItem |
isVisible() | APMenu::MenuItem | inline
itemSize | APMenu::MenuItem | protected
itemSize2 | APMenu::MenuItem | protected
loadParametersFromNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APMenu::MenuItemText | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lpChild | DynTreeNode< MenuItem > |
lpNext | DynTreeNode< MenuItem > |
lpParent | DynTreeNode< MenuItem > |
lpPrev | DynTreeNode< MenuItem > |
mainTransform | APMenu::MenuItem | protected
menuBoxes_CalcItemDisplayIndex() | APMenu::MenuItem | protected
MenuItem(DynamicMenu *_owner) | APMenu::MenuItem |
MenuItemText(DynamicMenu *_owner) | APMenu::MenuItemText |
menuRadial_CalcItemAngle(int _iItemIndex) | APMenu::MenuItem | protected
model | APMenu::MenuItemText | protected
modelFile | APMenu::MenuItemText | protected
modelTransform | APMenu::MenuItemText | protected
name | APMenu::MenuItem | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APMenu::MenuItem | protected
osgText | APMenu::MenuItemText | protected
osgTransform | APMenu::MenuItem | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APMenu::MenuItem | protected
PinList typedef | vrecko::BaseClass | protected
pointerButtonDown() | APMenu::MenuItem | inlinevirtual
pointerButtonUp() | APMenu::MenuItem | inlinevirtual
pointerMove(osg::Vec3 *projPointerPos) | APMenu::MenuItem | inlinevirtual
pos | APMenu::MenuItem | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APMenu::MenuItem | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
qshapeDraw | APMenu::MenuItem | protected
refPoint1 | APMenu::MenuItem | protected
refPoint2 | APMenu::MenuItem | protected
refPoint3 | APMenu::MenuItem | protected
removeInputOutputs() | APMenu::MenuItemText | protectedvirtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
repositionModel() | APMenu::MenuItemText | protectedvirtual
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetConfirmationEffect() | APMenu::MenuItem | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAndPlayConfirmationEffect() | APMenu::MenuItem | virtual
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCaption(const char *newCaption) | APMenu::MenuItemText | virtual
setFlags(unsigned long dwNewFlags, bool bForceUpdate=false) | APMenu::MenuItem |
setFlagsCore(unsigned long dwOldFlags, unsigned long dwNewFlags) | APMenu::MenuItem | protectedvirtual
setModelFile(const char *newModelFile) | APMenu::MenuItemText | virtual
setName(const char *newName) | APMenu::MenuItem | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSignName(const char *name) | APMenu::MenuItemText |
shapeBox | APMenu::MenuItem | protected
shapeDraw | APMenu::MenuItem | protected
shapeSection | APMenu::MenuItem | protected
show(unsigned long _dwItemIndex, unsigned long _dwNumItems, osg::Vec3 *_refPoint1, osg::Vec3 *_refPoint2, osg::Vec3 *_refPoint3) | APMenu::MenuItem | virtual
showGraphicsAtPoint() | APMenu::MenuItemText | protectedvirtual
signName | APMenu::MenuItemText | protected
signObject | APMenu::MenuItemText | protected
signTransform | APMenu::MenuItemText | protected
textShift | APMenu::MenuItemText | protected
tree | DynTreeNode< MenuItem > |
update(void) | vrecko::BaseClass | inlinevirtual
updateText() | APMenu::MenuItemText | protectedvirtual
~BaseClass() | vrecko::BaseClass | virtual
~MenuItem() | APMenu::MenuItem | virtual
~MenuItemText() | APMenu::MenuItemText | virtual
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APMenu
  • MenuLoaderErrorHandler
APMenu::MenuLoaderErrorHandler Member List

This is the complete list of members for APMenu::MenuLoaderErrorHandler, including all inherited members.

getSawErrors() const | APMenu::MenuLoaderErrorHandler | inline
handleError(const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError) | APMenu::MenuLoaderErrorHandler |
MenuLoaderErrorHandler() | APMenu::MenuLoaderErrorHandler |
resetErrors() | APMenu::MenuLoaderErrorHandler |
~MenuLoaderErrorHandler() | APMenu::MenuLoaderErrorHandler |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • MidpointDisplacementAlgorithm
APNature::MidpointDisplacementAlgorithm Member List

This is the complete list of members for APNature::MidpointDisplacementAlgorithm, including all inherited members.

_height | APNature::TerrainAlgorithm | protected
_terrain | APNature::TerrainAlgorithm | protected
_width | APNature::TerrainAlgorithm | protected
Allocate(int width, int height) | APNature::TerrainAlgorithm | protected
Flatten(float height) | APNature::TerrainAlgorithm | protected
GenerateSurfaceByMidpointDisplacement(int x1, int y1, int x2, int y2, int level) | APNature::MidpointDisplacementAlgorithm |
GetHighestValue() const | APNature::TerrainAlgorithm |
GetLowestValue() const | APNature::TerrainAlgorithm |
GetPointHeight(int x, int y) const | APNature::TerrainAlgorithm | inlineprotected
InitialLevel | APNature::MidpointDisplacementAlgorithm | static
MidpointDisplacementAlgorithm(int width, int height, float cornerValueFrom, float cornerValueTo) | APNature::MidpointDisplacementAlgorithm |
PointIndex(int x, int y) const | APNature::TerrainAlgorithm | inline
RandomizeSurfaceCorners(float cornerValueFrom, float cornerValueTo) | APNature::MidpointDisplacementAlgorithm |
Release() | APNature::TerrainAlgorithm | protected
SetPointHeight(int x, int y, float height) | APNature::TerrainAlgorithm | inlineprotected
TerrainAlgorithm(int width, int height) | APNature::TerrainAlgorithm |
Zero() | APNature::TerrainAlgorithm | protected
~TerrainAlgorithm() | APNature::TerrainAlgorithm |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • PerlinNoiseAlgorithm
APNature::PerlinNoiseAlgorithm Member List

This is the complete list of members for APNature::PerlinNoiseAlgorithm, including all inherited members.

_height | APNature::TerrainAlgorithm | protected
_terrain | APNature::TerrainAlgorithm | protected
_width | APNature::TerrainAlgorithm | protected
Allocate(int width, int height) | APNature::TerrainAlgorithm | protected
Flatten(float height) | APNature::TerrainAlgorithm | protected
GenerateCloudsTexture(std::size_t octaveCount, float persistence) | APNature::PerlinNoiseAlgorithm |
GenerateNoiseTexture(float frequencyX, float frequencyY) | APNature::PerlinNoiseAlgorithm |
GetHighestValue() const | APNature::TerrainAlgorithm |
GetLowestValue() const | APNature::TerrainAlgorithm |
GetNoise(float x, float y) | APNature::PerlinNoiseAlgorithm |
GetPointHeight(int x, int y) const | APNature::TerrainAlgorithm | inlineprotected
PerlinNoiseAlgorithm(int width, int height) | APNature::PerlinNoiseAlgorithm |
PointIndex(int x, int y) const | APNature::TerrainAlgorithm | inline
Release() | APNature::TerrainAlgorithm | protected
SetPointHeight(int x, int y, float height) | APNature::TerrainAlgorithm | inlineprotected
TerrainAlgorithm(int width, int height) | APNature::TerrainAlgorithm |
Zero() | APNature::TerrainAlgorithm | protected
~TerrainAlgorithm() | APNature::TerrainAlgorithm |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • RandomFaultsAlgorithm
APNature::RandomFaultsAlgorithm Member List

This is the complete list of members for APNature::RandomFaultsAlgorithm, including all inherited members.

_height | APNature::TerrainAlgorithm | protected
_terrain | APNature::TerrainAlgorithm | protected
_width | APNature::TerrainAlgorithm | protected
Allocate(int width, int height) | APNature::TerrainAlgorithm | protected
Flatten(float height) | APNature::TerrainAlgorithm | protected
GenerateSurfaceByRandomFaults(int iterations, float faultValueMin, float faultValueMax) | APNature::RandomFaultsAlgorithm |
GetHighestValue() const | APNature::TerrainAlgorithm |
GetLowestValue() const | APNature::TerrainAlgorithm |
GetPointHeight(int x, int y) const | APNature::TerrainAlgorithm | inlineprotected
PointIndex(int x, int y) const | APNature::TerrainAlgorithm | inline
RandomFaultsAlgorithm(int width, int height) | APNature::RandomFaultsAlgorithm |
Release() | APNature::TerrainAlgorithm | protected
SetPointHeight(int x, int y, float height) | APNature::TerrainAlgorithm | inlineprotected
TerrainAlgorithm(int width, int height) | APNature::TerrainAlgorithm |
Zero() | APNature::TerrainAlgorithm | protected
~TerrainAlgorithm() | APNature::TerrainAlgorithm |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • Terrain2D
APNature::Terrain2D Member List

This is the complete list of members for APNature::Terrain2D, including all inherited members.

Export(FileTypeExport fileType) | APNature::Terrain2D |
Flatten(float height) | APNature::Terrain2D |
GenerateByMidpointDisplacementAlgorithm(float cornerValueFrom, float cornerValueTo) | APNature::Terrain2D |
GenerateByPerlinNoiseAlgorithm(float persistence, int octaveCount) | APNature::Terrain2D |
GenerateByRandomFaultsAlgorithm(int iterations, float faultValueMin, float faultValueMax) | APNature::Terrain2D |
GetPoint(int x, int y) const | APNature::Terrain2D |
GetPointHeight(int x, int y) const | APNature::Terrain2D |
GetTerrainGroup() const | APNature::Terrain2D | inline
ImportFromHeightMap(const std::string &path) | APNature::Terrain2D |
Postprocessing() | APNature::Terrain2D |
Preprocessing() | APNature::Terrain2D |
SetPoint(int x, int y, const osg::Vec3f &point) | APNature::Terrain2D |
SetPointHeight(int x, int y, float height) | APNature::Terrain2D |
Terrain2D(void) | APNature::Terrain2D |
~Terrain2D(void) | APNature::Terrain2D |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • Terrain2DSegment
APNature::Terrain2DSegment Member List

This is the complete list of members for APNature::Terrain2DSegment, including all inherited members.

Flatten(float height) | APNature::Terrain2DSegment |
GetNeighbourEast() const | APNature::Terrain2DSegment | inline
GetNeighbourNorth() const | APNature::Terrain2DSegment | inline
GetNeighbourSouthh() const | APNature::Terrain2DSegment | inline
GetNeighbourWest() const | APNature::Terrain2DSegment | inline
GetPoint(int x, int y) const | APNature::Terrain2DSegment | inline
GetTerrainSegmentGeode() const | APNature::Terrain2DSegment | inline
Height() const | APNature::Terrain2DSegment | inline
InitializeGeode() | APNature::Terrain2DSegment |
IsNeighbourEast() const | APNature::Terrain2DSegment | inline
IsNeighbourNorth() const | APNature::Terrain2DSegment | inline
IsNeighbourSouth() const | APNature::Terrain2DSegment | inline
IsNeighbourWest() const | APNature::Terrain2DSegment | inline
SetPoint(int x, int y, const osg::Vec3f &point) | APNature::Terrain2DSegment | inline
SetSegmentPosition(const osg::Vec2f &position) | APNature::Terrain2DSegment |
Terrain2D class | APNature::Terrain2DSegment | friend
Terrain2DSegment() | APNature::Terrain2DSegment |
Width() const | APNature::Terrain2DSegment | inline
~Terrain2DSegment(void) | APNature::Terrain2DSegment | inline
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainAbility
APNature::TerrainAbility Member List

This is the complete list of members for APNature::TerrainAbility, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BuildMenuLayouts() | APNature::TerrainAbility |
clean(void) | vrecko::Ability | inlinevirtual
CreateMenuStructure() | APNature::TerrainAbility |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GuiItemClicked(const char *itemID) | APNature::TerrainAbility |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APNature::TerrainAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
InitializeMenu() | APNature::TerrainAbility |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
MenuSliderChanged(const char *sliderID, float sliderPos) | APNature::TerrainAbility |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
TerrainAbility() | APNature::TerrainAbility |
update() | APNature::TerrainAbility | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~TerrainAbility() | APNature::TerrainAbility | inline
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainAlgorithm
APNature::TerrainAlgorithm Member List

This is the complete list of members for APNature::TerrainAlgorithm, including all inherited members.

_height | APNature::TerrainAlgorithm | protected
_terrain | APNature::TerrainAlgorithm | protected
_width | APNature::TerrainAlgorithm | protected
Allocate(int width, int height) | APNature::TerrainAlgorithm | protected
Flatten(float height) | APNature::TerrainAlgorithm | protected
GetHighestValue() const | APNature::TerrainAlgorithm |
GetLowestValue() const | APNature::TerrainAlgorithm |
GetPointHeight(int x, int y) const | APNature::TerrainAlgorithm | inlineprotected
PointIndex(int x, int y) const | APNature::TerrainAlgorithm | inline
Release() | APNature::TerrainAlgorithm | protected
SetPointHeight(int x, int y, float height) | APNature::TerrainAlgorithm | inlineprotected
TerrainAlgorithm(int width, int height) | APNature::TerrainAlgorithm |
Zero() | APNature::TerrainAlgorithm | protected
~TerrainAlgorithm() | APNature::TerrainAlgorithm |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainRandom
APNature::TerrainRandom Member List

This is the complete list of members for APNature::TerrainRandom, including all inherited members.

GetRandomFloatGaussian(float mean, float standardDeviation) | APNature::TerrainRandom | static
GetRandomFloatGaussianBasedOnPointDistance(int x1, int y1, int x2, int y2) | APNature::TerrainRandom | static
GetRandomFloatUniform(float from, float to) | APNature::TerrainRandom | inlinestatic
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APNature
  • TerrainUtility
APNature::TerrainUtility Member List

This is the complete list of members for APNature::TerrainUtility, including all inherited members.

Error(const std::string &message) | APNature::TerrainUtility | static
GreatestCommonDivisor(int x, int y) | APNature::TerrainUtility | static
Info(const std::string &message) | APNature::TerrainUtility | static
LinearMapping(float fromMin, float fromMax, float fromX, float toMin, float toMax) | APNature::TerrainUtility | inlinestatic
ListDirectory(const std::string &dirpath, const std::string &mask, std::vector< std::string > *fileNames) | APNature::TerrainUtility | static
LowerCase(const std::string &input) | APNature::TerrainUtility | static
SetPointHeight(osg::Vec3 &point, float height) | APNature::TerrainUtility | inlinestatic
UpperCase(const std::string &input) | APNature::TerrainUtility | static
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • Animator
APObjectUtils::Animator Member List

This is the complete list of members for APObjectUtils::Animator, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addAnimatorToObject(vrecko::EnvironmentObject *object, bool bReuseOldIfPossible=true) | APObjectUtils::Animator | static
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
AnimAlpha enum value | APObjectUtils::Animator |
animateToPoint(int pointIndex) | APObjectUtils::Animator |
AnimationTypes enum name | APObjectUtils::Animator |
Animator() | APObjectUtils::Animator |
AnimNodeMask enum value | APObjectUtils::Animator |
AnimSRT enum value | APObjectUtils::Animator |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
bAnimating | APObjectUtils::Animator | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BiDi enum value | APObjectUtils::Animator |
calcAnimMatrix(float fNormPos, int iPoint1, int iPoint2, osg::Matrix &outMatrix) | APObjectUtils::Animator | protected
clean() | APObjectUtils::Animator | virtual
convertActPosToNormPos(float fActPos, int *outPoint1, int *outPoint2) | APObjectUtils::Animator | protected
convertActTimeToActPos() | APObjectUtils::Animator | protected
DECLARE_INPUT(Trigger, MessageVoid) | APObjectUtils::Animator | protected
DECLARE_INPUT(AnimateToPoint, MessageInt) | APObjectUtils::Animator | protected
DECLARE_OUTPUT(AnimationEnded, MessageBool) | APObjectUtils::Animator | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
enabledAnimations | APObjectUtils::Animator | protected
fActTime | APObjectUtils::Animator | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAlpha(int pointIndex) | APObjectUtils::Animator |
getAnimationPointsNumber() | APObjectUtils::Animator | inline
getAnimatorOnObject(vrecko::EnvironmentObject *object) | APObjectUtils::Animator | static
getAnimMatrix(float fActPos, osg::Matrix &outMatrix) | APObjectUtils::Animator |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getEnabledAnimations() | APObjectUtils::Animator | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getInterpolationType() | APObjectUtils::Animator | inline
getLoopType() | APObjectUtils::Animator | inline
getName() const | vrecko::Ability | inline
getNodeMask(int pointIndex) | APObjectUtils::Animator |
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotation(int pointIndex) | APObjectUtils::Animator | inline
getScale(int pointIndex) | APObjectUtils::Animator |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getTimePerLoop() | APObjectUtils::Animator | inline
getTranslation(int pointIndex) | APObjectUtils::Animator |
iActDir | APObjectUtils::Animator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
InterpolationType enum name | APObjectUtils::Animator |
interpolationType | APObjectUtils::Animator | protected
isAnimating() | APObjectUtils::Animator | inline
isUpdated(void) | vrecko::Ability |
lastTimerTick | APObjectUtils::Animator | protected
Linear enum value | APObjectUtils::Animator |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::Animator | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
loopType | APObjectUtils::Animator | protected
LoopType enum name | APObjectUtils::Animator |
NoLoop enum value | APObjectUtils::Animator |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::Animator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
points | APObjectUtils::Animator | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::Animator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAnimation() | APObjectUtils::Animator |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetToPos(float fPos) | APObjectUtils::Animator |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAlpha(int pointIndex, float alpha) | APObjectUtils::Animator |
setAnimationPointsNumber(unsigned int number) | APObjectUtils::Animator |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setEnabledAnimations(unsigned long dwAnimations) | APObjectUtils::Animator |
setID(const char *pID) | vrecko::Ability |
setInterpolationType(InterpolationType newType) | APObjectUtils::Animator | inline
setLoopType(LoopType newType) | APObjectUtils::Animator | inline
setNodeMask(int pointIndex, osg::Node::NodeMask nodeMask) | APObjectUtils::Animator |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(int pointIndex, const osg::Quat &rot) | APObjectUtils::Animator |
setScale(int pointIndex, const osg::Vec3 &scale) | APObjectUtils::Animator |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTimePerLoop(float timeInS) | APObjectUtils::Animator | inline
setTransformationFromMatrix(int startPointIndex, int endPointIndex, const osg::Matrix &matrix) | APObjectUtils::Animator |
setTranslation(int pointIndex, const osg::Vec3 &trans) | APObjectUtils::Animator |
Simple enum value | APObjectUtils::Animator |
Sine enum value | APObjectUtils::Animator |
startAnimation() | APObjectUtils::Animator |
stateSet | APObjectUtils::Animator | protected
stopAnimation() | APObjectUtils::Animator |
timePerLoop | APObjectUtils::Animator | protected
update() | APObjectUtils::Animator | virtual
updateActTime() | APObjectUtils::Animator | protected
updateAnimation(float fActPos) | APObjectUtils::Animator | protected
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~Animator() | APObjectUtils::Animator | virtual
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • Animator
  • AnimationPoint
APObjectUtils::Animator::AnimationPoint Member List

This is the complete list of members for APObjectUtils::Animator::AnimationPoint, including all inherited members.

AnimationPoint() | APObjectUtils::Animator::AnimationPoint
fAlpha | APObjectUtils::Animator::AnimationPoint
nodeMask | APObjectUtils::Animator::AnimationPoint
rotation | APObjectUtils::Animator::AnimationPoint
scale | APObjectUtils::Animator::AnimationPoint
translation | APObjectUtils::Animator::AnimationPoint
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ConnectionViz
APObjectUtils::ConnectionViz Member List

This is the complete list of members for APObjectUtils::ConnectionViz, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bColorize | APObjectUtils::ConnectionViz | protected
bOnlyOutput | APObjectUtils::ConnectionViz | protected
clean() | APObjectUtils::ConnectionViz | virtual
ConnectionViz() | APObjectUtils::ConnectionViz |
cons | APObjectUtils::ConnectionViz | protected
createConnection(Connection::ConnectionType cType, const char *sender, const char *receiver, unsigned int dwFlags) | APObjectUtils::ConnectionViz | protected
createMainObject() | APObjectUtils::ConnectionViz | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
deleteConnection(int iIndex) | APObjectUtils::ConnectionViz | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
graphicObject | APObjectUtils::ConnectionViz | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::ConnectionViz | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgGeode | APObjectUtils::ConnectionViz | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::ConnectionViz | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APObjectUtils::ConnectionViz | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ConnectionViz | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APObjectUtils::ConnectionViz | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ConnectionViz() | APObjectUtils::ConnectionViz | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ConnectionViz
  • Connection
APObjectUtils::ConnectionViz::Connection Member List

This is the complete list of members for APObjectUtils::ConnectionViz::Connection, including all inherited members.

ability | APObjectUtils::ConnectionViz::Connection
bUsedInUpdate | APObjectUtils::ConnectionViz::Connection
ConnectionType enum name | APObjectUtils::ConnectionViz::Connection
dwFlags | APObjectUtils::ConnectionViz::Connection
Input enum value | APObjectUtils::ConnectionViz::Connection
InputRequest enum value | APObjectUtils::ConnectionViz::Connection
Output enum value | APObjectUtils::ConnectionViz::Connection
OutputRequest enum value | APObjectUtils::ConnectionViz::Connection
pinName | APObjectUtils::ConnectionViz::Connection
shapeCone | APObjectUtils::ConnectionViz::Connection
shapeDraw | APObjectUtils::ConnectionViz::Connection
type | APObjectUtils::ConnectionViz::Connection
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • CopyProperties
APObjectUtils::CopyProperties Member List

This is the complete list of members for APObjectUtils::CopyProperties, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
CopyProperties() | APObjectUtils::CopyProperties |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dwCopiedProperties | APObjectUtils::CopyProperties | protected
dwCopyEO | APObjectUtils::CopyProperties | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getProperties(void) | APObjectUtils::CopyProperties | inlineprotected
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::CopyProperties | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setProperties(unsigned int dwNewCopiedProperties) | APObjectUtils::CopyProperties | protected
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APObjectUtils::CopyProperties | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • EOLineSegmentIntersector
APObjectUtils::EOLineSegmentIntersector Member List

This is the complete list of members for APObjectUtils::EOLineSegmentIntersector, including all inherited members.

enter(const osg::Node &node) | APObjectUtils::EOLineSegmentIntersector | virtual
EOLineSegmentIntersector(const osg::Vec3d &start, const osg::Vec3d &end) | APObjectUtils::EOLineSegmentIntersector | inline
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • KeepOnScreen
APObjectUtils::KeepOnScreen Member List

This is the complete list of members for APObjectUtils::KeepOnScreen, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bDontRotate | APObjectUtils::KeepOnScreen | protected
bRelativeToBoundingBox | APObjectUtils::KeepOnScreen | protected
clean() | APObjectUtils::KeepOnScreen | virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
depth | APObjectUtils::KeepOnScreen | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
horizAlign | APObjectUtils::KeepOnScreen | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
KeepOnScreen() | APObjectUtils::KeepOnScreen |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::KeepOnScreen | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::KeepOnScreen | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
posX | APObjectUtils::KeepOnScreen | protected
posY | APObjectUtils::KeepOnScreen | protected
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::KeepOnScreen | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale | APObjectUtils::KeepOnScreen | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APObjectUtils::KeepOnScreen | virtual
updated | vrecko::Ability | protected
vertAlign | APObjectUtils::KeepOnScreen | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~KeepOnScreen() | APObjectUtils::KeepOnScreen | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectEffect
APObjectUtils::ObjectEffect Member List

This is the complete list of members for APObjectUtils::ObjectEffect, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisions_NoCalculation | APObjectUtils::ObjectEffect | protected
bEffectCreated | APObjectUtils::ObjectEffect | protected
BoundingBox enum value | APObjectUtils::ObjectEffect |
BoundingSphere enum value | APObjectUtils::ObjectEffect |
bShowLeafInLevelNotReached | APObjectUtils::ObjectEffect | protected
clean() | APObjectUtils::ObjectEffect | virtual
colInfo | APObjectUtils::ObjectEffect | protected
Collisions enum value | APObjectUtils::ObjectEffect |
color | APObjectUtils::ObjectEffect | protected
Colorize enum value | APObjectUtils::ObjectEffect |
ColorizeOnTop enum value | APObjectUtils::ObjectEffect |
createEffect() | APObjectUtils::ObjectEffect | protected
createEffect_Lines(vrecko::Ability *dataAbility) | APObjectUtils::ObjectEffect | protected
createEffect_PointShellHierarchy_ProcessLevel(vrecko::Ability *dataAbility, void *node, int iCurrentLevel, bool draw) | APObjectUtils::ObjectEffect | protected
createEffect_Reconstruction(vrecko::Ability *dataAbility) | APObjectUtils::ObjectEffect | protected
createEffect_SphereHierarchy_ProcessLevel(vrecko::Ability *dataAbility, void *node, int iCurrentLevel) | APObjectUtils::ObjectEffect | protected
createEffect_VoxelGrid(vrecko::Ability *dataAbility) | APObjectUtils::ObjectEffect | protected
DECLARE_INPUT(ShiftLevels, MessageInt) | APObjectUtils::ObjectEffect | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyEffect() | APObjectUtils::ObjectEffect | protected
DoubleSided enum value | APObjectUtils::ObjectEffect |
draw_Effect_PointShellHierarchy_Node(vrecko::Ability *dataAbility, void *node, int iCurrentLevel) | APObjectUtils::ObjectEffect | protected
effectType | APObjectUtils::ObjectEffect | protected
EffectType enum name | APObjectUtils::ObjectEffect |
FaceNormals enum value | APObjectUtils::ObjectEffect |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fRadius | APObjectUtils::ObjectEffect | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getEffectType(void) | APObjectUtils::ObjectEffect | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLevelMax() | APObjectUtils::ObjectEffect | inlineprotected
getLevelMin() | APObjectUtils::ObjectEffect | inlineprotected
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
graphicObject | APObjectUtils::ObjectEffect | protected
HSVtoRGB(float *r, float *g, float *b, float h, float s, float v) | APObjectUtils::ObjectEffect | protected
iDistanceFieldValue | APObjectUtils::ObjectEffect | protected
iLevelMax | APObjectUtils::ObjectEffect | protected
iLevelMin | APObjectUtils::ObjectEffect | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isEffectCreated() | APObjectUtils::ObjectEffect | inline
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::ObjectEffect | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
None enum value | APObjectUtils::ObjectEffect |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ObjectEffect() | APObjectUtils::ObjectEffect |
originalStateSet | APObjectUtils::ObjectEffect | protected
osgGeode | APObjectUtils::ObjectEffect | protected
osgTransform | APObjectUtils::ObjectEffect | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PointShell enum value | APObjectUtils::ObjectEffect |
PolygonNormals enum value | APObjectUtils::ObjectEffect |
postInitialize() | APObjectUtils::ObjectEffect | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ObjectEffect | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setEffectType(EffectType newType) | APObjectUtils::ObjectEffect |
setID(const char *pID) | vrecko::Ability |
setLevelMinMax(int newLevelMin, int newLevelMax) | APObjectUtils::ObjectEffect | protected
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shapeBox | APObjectUtils::ObjectEffect | protected
shapeDraw | APObjectUtils::ObjectEffect | protected
shapeDrawables | APObjectUtils::ObjectEffect | protected
shapeSphere | APObjectUtils::ObjectEffect | protected
SNCH enum value | APObjectUtils::ObjectEffect |
SNCHFaceGroups enum value | APObjectUtils::ObjectEffect |
SphereBVH enum value | APObjectUtils::ObjectEffect |
Transparency enum value | APObjectUtils::ObjectEffect |
TransparencyOnTop enum value | APObjectUtils::ObjectEffect |
update() | APObjectUtils::ObjectEffect | virtual
updated | vrecko::Ability | protected
VertexNormals enum value | APObjectUtils::ObjectEffect |
VoxelGrid enum value | APObjectUtils::ObjectEffect |
VoxelGridCollisions enum value | APObjectUtils::ObjectEffect |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ObjectEffect() | APObjectUtils::ObjectEffect | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectEffectMan
APObjectUtils::ObjectEffectMan Member List

This is the complete list of members for APObjectUtils::ObjectEffectMan, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bVisible | APObjectUtils::ObjectEffectMan | protected
clean() | APObjectUtils::ObjectEffectMan | virtual
createObjectEffect(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pEffectParametersNode) | APObjectUtils::ObjectEffectMan | protected
DECLARE_INPUT(ObjectID, MessageObjectID) | APObjectUtils::ObjectEffectMan | protected
DECLARE_INPUT(Visible, MessageBool) | APObjectUtils::ObjectEffectMan | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
deleteObjectEffect() | APObjectUtils::ObjectEffectMan | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::ObjectEffectMan | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectEffect | APObjectUtils::ObjectEffectMan | protected
ObjectEffectMan() | APObjectUtils::ObjectEffectMan |
objectID | APObjectUtils::ObjectEffectMan | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::ObjectEffectMan | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APObjectUtils::ObjectEffectMan | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ObjectEffectMan | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APObjectUtils::ObjectEffectMan | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SetState(unsigned long newObjectID, bool bNewVisible) | APObjectUtils::ObjectEffectMan |
strObjectIDReq | APObjectUtils::ObjectEffectMan | protected
update() | APObjectUtils::ObjectEffectMan | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ObjectEffectMan() | APObjectUtils::ObjectEffectMan | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectInfo
APObjectUtils::ObjectInfo Member List

This is the complete list of members for APObjectUtils::ObjectInfo, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_OUTPUT(Position, MessageVec3) | APObjectUtils::ObjectInfo | protected
DECLARE_OUTPUT(Orientation, MessageQuat) | APObjectUtils::ObjectInfo | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ObjectInfo() | APObjectUtils::ObjectInfo |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::ObjectInfo | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ObjectInfo | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
strOrientationEvent | APObjectUtils::ObjectInfo | protected
strPositionEvent | APObjectUtils::ObjectInfo | protected
update() | APObjectUtils::ObjectInfo | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ObjectInfo() | APObjectUtils::ObjectInfo | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectModif
APObjectUtils::ObjectModif Member List

This is the complete list of members for APObjectUtils::ObjectModif, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(RandomColor, MessageBool) | APObjectUtils::ObjectModif | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageVoid, MessageObjectID) | APObjectUtils::ObjectModif | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSelectedObject() | APObjectUtils::ObjectModif | protected
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::ObjectModif | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ObjectModif() | APObjectUtils::ObjectModif |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::ObjectModif | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APObjectUtils::ObjectModif | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ObjectModif | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APObjectUtils::ObjectModif | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ObjectModif() | APObjectUtils::ObjectModif | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • ObjectSelector
APObjectUtils::ObjectSelector Member List

This is the complete list of members for APObjectUtils::ObjectSelector, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(PointerPosition, MessageVec3) | APObjectUtils::ObjectSelector | protected
DECLARE_OUTPUT(SelectionID, MessageObjectID) | APObjectUtils::ObjectSelector | protected
DECLARE_REQUEST_INPUT(SelectionID, MessageVoid, MessageObjectID) | APObjectUtils::ObjectSelector | protected
DECLARE_REQUEST_INPUT(SelectionByPointerPos, MessageVec3, MessageObjectID) | APObjectUtils::ObjectSelector | protected
DECLARE_REQUEST_INPUT(SelectionByPointerPos_Path, MessageVec3, MessageNodeList) | APObjectUtils::ObjectSelector | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
intersectedObjects | APObjectUtils::ObjectSelector | protected
isUpdated(void) | vrecko::Ability |
lastPosition | APObjectUtils::ObjectSelector | protected
lastSelTest | APObjectUtils::ObjectSelector | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APObjectUtils::ObjectSelector | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectEffect | APObjectUtils::ObjectSelector | protected
ObjectSelector() | APObjectUtils::ObjectSelector |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::ObjectSelector | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APObjectUtils::ObjectSelector | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APObjectUtils::ObjectSelector | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resolveIntersections(osg::Vec3 &position, std::vector< osg::Node * > *nodePath=NULL) | APObjectUtils::ObjectSelector | protected
resolveSelection() | APObjectUtils::ObjectSelector | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selObjectID | APObjectUtils::ObjectSelector | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | APObjectUtils::ObjectSelector | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ObjectSelector() | APObjectUtils::ObjectSelector | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • UseToEvent
APObjectUtils::UseToEvent Member List

This is the complete list of members for APObjectUtils::UseToEvent, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(Use, MessageBool) | APObjectUtils::UseToEvent | protected
DECLARE_OUTPUT(Trigger, MessageBool) | APObjectUtils::UseToEvent | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APObjectUtils::UseToEvent | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UseToEvent() | APObjectUtils::UseToEvent |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~UseToEvent() | APObjectUtils::UseToEvent | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • ColorBucket
APRoomEdit::ColorBucket Member List

This is the complete list of members for APRoomEdit::ColorBucket, including all inherited members.

ColorBucket(osg::Vec3 color) | APRoomEdit::ColorBucket | inline
dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::ColorBucket | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::ColorBucket | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~ColorBucket() | APRoomEdit::ColorBucket | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • CreateHole
APRoomEdit::CreateHole Member List

This is the complete list of members for APRoomEdit::CreateHole, including all inherited members.

CreateHole(void) | APRoomEdit::CreateHole | inline
dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::CreateHole | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::CreateHole | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~CreateHole(void) | APRoomEdit::CreateHole | inline
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • HoleRemove
APRoomEdit::HoleRemove Member List

This is the complete list of members for APRoomEdit::HoleRemove, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
HoleRemove(void) | APRoomEdit::HoleRemove | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::HoleRemove | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::Tool | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~HoleRemove(void) | APRoomEdit::HoleRemove | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • PointAdd
APRoomEdit::PointAdd Member List

This is the complete list of members for APRoomEdit::PointAdd, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::PointAdd | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::Tool | inlinevirtual
name | APRoomEdit::Tool | protected
PointAdd(void) | APRoomEdit::PointAdd | inline
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~PointAdd(void) | APRoomEdit::PointAdd | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • PointMove
APRoomEdit::PointMove Member List

This is the complete list of members for APRoomEdit::PointMove, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::PointMove | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::PointMove | inlinevirtual
name | APRoomEdit::Tool | protected
PointMove() | APRoomEdit::PointMove | inline
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::PointMove | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::PointMove | inlinevirtual
~PointMove() | APRoomEdit::PointMove | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomEditor
APRoomEdit::RoomEditor Member List

This is the complete list of members for APRoomEdit::RoomEditor, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | APRoomEdit::RoomEditor | protectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | APRoomEdit::RoomEditor | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo() | APRoomEdit::RoomEditor | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getIntersection() | APRoomEdit::RoomEditor | inline
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APRoomEdit::RoomEditor | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
issueRequests(bool bStopIfNoSelection) | APRoomEdit::RoomEditor | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | APRoomEdit::RoomEditor | protectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | APRoomEdit::RoomEditor | protectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
RoomEditor() | APRoomEdit::RoomEditor |
RoomEditor::menuItemClicked(const char *itemID) | APRoomEdit::RoomEditor | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setIntersection(osg::Vec3 &position, vrecko::Scene *scenePtr) | APRoomEdit::RoomEditor |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
showToolMenu() | APRoomEdit::RoomEditor | protected
update(void) | APRoomEdit::RoomEditor | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
~RoomEditor() | APRoomEdit::RoomEditor | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomLoader
APRoomEdit::RoomLoader Member List

This is the complete list of members for APRoomEdit::RoomLoader, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::RoomLoader | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::RoomLoader | inlinevirtual
name | APRoomEdit::Tool | protected
RoomLoader(std::string f) | APRoomEdit::RoomLoader | inline
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~RoomLoader() | APRoomEdit::RoomLoader | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • RoomSaver
APRoomEdit::RoomSaver Member List

This is the complete list of members for APRoomEdit::RoomSaver, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::RoomSaver | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::RoomSaver | inlinevirtual
name | APRoomEdit::Tool | protected
RoomSaver(std::string f) | APRoomEdit::RoomSaver | inline
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~RoomSaver() | APRoomEdit::RoomSaver | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • Tool
APRoomEdit::Tool Member List

This is the complete list of members for APRoomEdit::Tool, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::Tool | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
~Tool() | APRoomEdit::Tool | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallAdd
APRoomEdit::WallAdd Member List

This is the complete list of members for APRoomEdit::WallAdd, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::WallAdd | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::WallAdd | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
WallAdd() | APRoomEdit::WallAdd | inline
~Tool() | APRoomEdit::Tool | inlinevirtual
~WallAdd() | APRoomEdit::WallAdd | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallGeometry
APRoomEdit::WallGeometry Member List

This is the complete list of members for APRoomEdit::WallGeometry, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activateTool(Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection) | APRoomEdit::WallGeometry | inline
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
createDefaultRoom() | APRoomEdit::WallGeometry |
deactivateTool(Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection) | APRoomEdit::WallGeometry | inline
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
draw() | APRoomEdit::WallGeometry |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getGeode() | APRoomEdit::WallGeometry | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPoint(osgUtil::LineSegmentIntersector::Intersection *intersection) | APRoomEdit::WallGeometry | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getWall(osgUtil::LineSegmentIntersector::Intersection *intersection) | APRoomEdit::WallGeometry | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::WallGeometry | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APRoomEdit::WallGeometry | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APRoomEdit::WallGeometry | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDirty() | APRoomEdit::WallGeometry | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
updateTool(Tool *tool, osgUtil::LineSegmentIntersector::Intersection *intersection, osg::Vec3 movingVector) | APRoomEdit::WallGeometry | inline
WallGeometry() | APRoomEdit::WallGeometry |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~WallGeometry() | APRoomEdit::WallGeometry | virtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallMovement
APRoomEdit::WallMovement Member List

This is the complete list of members for APRoomEdit::WallMovement, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::WallMovement | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::WallMovement | inlinevirtual
WallMovement(void) | APRoomEdit::WallMovement | inline
~Tool() | APRoomEdit::Tool | inlinevirtual
~WallMovement(void) | APRoomEdit::WallMovement | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APRoomEdit
  • WallRemove
APRoomEdit::WallRemove Member List

This is the complete list of members for APRoomEdit::WallRemove, including all inherited members.

dirty | APRoomEdit::Tool | protected
getName() | APRoomEdit::Tool | inline
getType() | APRoomEdit::Tool | inline
init(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::WallRemove | inlinevirtual
isDirty() | APRoomEdit::Tool | inline
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APRoomEdit::WallRemove | inlinevirtual
name | APRoomEdit::Tool | protected
setDirty(bool d) | APRoomEdit::Tool | inline
setName(string n) | APRoomEdit::Tool | inline
terminate(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray) | APRoomEdit::Tool | inlinevirtual
Tool() | APRoomEdit::Tool | inline
type | APRoomEdit::Tool | protected
update(osgUtil::LineSegmentIntersector::Intersection *intersection, WG_Wall *curWall, WG_Point *curPoint, PointType type, vrecko::EnvironmentObject *pEOOwner, std::vector< osg::ref_ptr< WG_Wall > > *walls, std::vector< osg::ref_ptr< WG_Point > > *points, osg::Geode *pOSGGeode, osg::Vec3Array *pOSGVertexArray, osg::Vec3 &movingVector) | APRoomEdit::Tool | inlinevirtual
WallRemove() | APRoomEdit::WallRemove | inline
~Tool() | APRoomEdit::Tool | inlinevirtual
~WallRemove() | APRoomEdit::WallRemove | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APShootingSimulation
  • ShootingSimulation
APShootingSimulation::ShootingSimulation Member List

This is the complete list of members for APShootingSimulation::ShootingSimulation, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObject(osg::ref_ptr< vrecko::EnvironmentObject > &obj, const std::string &geoPath) | APShootingSimulation::ShootingSimulation | inlineprotected
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(Start, MessageBool) | APShootingSimulation::ShootingSimulation | protected
DECLARE_INPUT(Mouse, MessageVec2) | APShootingSimulation::ShootingSimulation | protected
DECLARE_INPUT(Trigger, MessageBool) | APShootingSimulation::ShootingSimulation | protected
DECLARE_INPUT(Sensor_Transformation, MessageSensorTransformation) | APShootingSimulation::ShootingSimulation | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APShootingSimulation::ShootingSimulation | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
moveTarget(osg::Vec3 currentTargetPos) | APShootingSimulation::ShootingSimulation | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resolveIntersections(osg::Vec3 &vector, osg::Vec3 &position, std::vector< osg::Node * > **nodePath=NULL) | APShootingSimulation::ShootingSimulation |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCrosshairPos() | APShootingSimulation::ShootingSimulation | protected
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
ShootingSimulation() | APShootingSimulation::ShootingSimulation |
testAndHandleHit() | APShootingSimulation::ShootingSimulation | protected
update(void) | APShootingSimulation::ShootingSimulation | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ShootingSimulation() | APShootingSimulation::ShootingSimulation | inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
APSpacePartitioning::GeometryLoaderBase Member List

This is the complete list of members for APSpacePartitioning::GeometryLoaderBase, including all inherited members.

allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
deallocateFaceArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APSpacePartitioning::GeometryLoaderBase | virtual
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
APSpacePartitioning::NoPartitioning_Scene Member List

This is the complete list of members for APSpacePartitioning::NoPartitioning_Scene, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
collisionField | APSpacePartitioning::NoPartitioning_Scene | protected
computeTimeLast | APSpacePartitioning::NoPartitioning_Scene | protected
computeTimeNew | APSpacePartitioning::NoPartitioning_Scene | protected
ctrTimeLast | APSpacePartitioning::NoPartitioning_Scene | protected
ctrTimeNew | APSpacePartitioning::NoPartitioning_Scene | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
detectiontime1 | APSpacePartitioning::NoPartitioning_Scene | protected
detectiontime2 | APSpacePartitioning::NoPartitioning_Scene | protected
fillCollisionLists(CollisionParams *params) | APSpacePartitioning::NoPartitioning_Scene | protectedvirtual
findCollisionsWithObject(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long testedObject, unsigned long limitToEO2, float time, vrecko::Scene::EOIteratorHelper *iterator=NULL) | APSpacePartitioning::NoPartitioning_Scene | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fr | APSpacePartitioning::NoPartitioning_Scene | protected
freq | APSpacePartitioning::NoPartitioning_Scene | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getId() | vrecko::SP_SceneInterface | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hud | APSpacePartitioning::NoPartitioning_Scene | protected
hudInitialized | APSpacePartitioning::NoPartitioning_Scene | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isIntersection(osg::Vec3f pos1, osg::Vec3f pos2, float radius1, float radius2) | APSpacePartitioning::NoPartitioning_Scene | inlineprotectedvirtual
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
looptime1 | APSpacePartitioning::NoPartitioning_Scene | protected
looptime2 | APSpacePartitioning::NoPartitioning_Scene | protected
NoPartitioning_Scene() | APSpacePartitioning::NoPartitioning_Scene |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
performCompleteTest(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | APSpacePartitioning::NoPartitioning_Scene | virtual
performUpdate(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | APSpacePartitioning::NoPartitioning_Scene | virtual
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APSpacePartitioning::NoPartitioning_Scene | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
scIntId | vrecko::SP_SceneInterface | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
singleCollisionTest(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long obj1ID, unsigned long obj2ID, float time) | APSpacePartitioning::NoPartitioning_Scene | protectedvirtual
SP_SceneInterface() | vrecko::SP_SceneInterface | inline
update() | APSpacePartitioning::NoPartitioning_Scene | virtual
updateBoundingBox(osg::Node *pNode) | APSpacePartitioning::NoPartitioning_Scene | inlineprotectedvirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~NoPartitioning_Scene() | APSpacePartitioning::NoPartitioning_Scene |
~SP_SceneInterface() | vrecko::SP_SceneInterface | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data
APSpacePartitioning::PointShell_Object_Data Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCreated | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
bThreadShouldTerminate | APSpacePartitioning::SP_Object_Data_Base | protected
buildLODTree(PointShell_Object_Data_LOD_Builder *lod_builder) | APSpacePartitioning::PointShell_Object_Data | protected
PointShellGeneric_Object_Data< PointShell_SimpleNode >::buildLODTree() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
ByVoxels_MultiLevel enum value | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
ByVoxels_SingleLevel enum value | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
clean(void) | vrecko::Ability | inlinevirtual
collisionsMax | APSpacePartitioning::PointShell_Object_Data | protected
collisionsTotal | APSpacePartitioning::PointShell_Object_Data | protected
computeBBoxShereRadius(PointShell_SimpleNode *node) | APSpacePartitioning::PointShell_Object_Data | protected
computeBBoxSheresRadius(DynamicTree< PointShell_SimpleNode > *tree) | APSpacePartitioning::PointShell_Object_Data | protected
constructPointShellCacheDataName(char *pOutDataName) | APSpacePartitioning::PointShell_Object_Data | protected
constructPointShellCacheDataName(char *pOutDataName, CreationType type) | APSpacePartitioning::PointShell_Object_Data | protected
constructPointShellSubdividedMeshDataName(char *pOutDataName) | APSpacePartitioning::PointShell_Object_Data | protected
coreHierarchyCreation(void) | APSpacePartitioning::PointShell_Object_Data | protectedvirtual
createLODHierarchy() | APSpacePartitioning::PointShell_Object_Data | protected
createMultiLevel(double minx, double miny, double minz, double velm) | APSpacePartitioning::PointShell_Object_Data | protected
createSimple() | APSpacePartitioning::PointShell_Object_Data | protected
createSingleLevel(double minx, double miny, double minz, double velm) | APSpacePartitioning::PointShell_Object_Data | protected
CreationType enum name | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
creationType | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
deallocateFaceArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
destroyPointShell(CreationType type) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | virtual
destroyPointShells() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | virtual
destroyThread() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
distance(PSpoint *voxel1, PSpoint *voxel2) | APSpacePartitioning::PointShell_Object_Data | inlineprotected
distance_sqr(PSpoint *voxel1, PSpoint *voxel2) | APSpacePartitioning::PointShell_Object_Data | inlineprotected
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fMaxDistance | APSpacePartitioning::PointShell_Object_Data |
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisions(int id) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getCollisionsFromTree(PointShell_SimpleNode *node) | APSpacePartitioning::PointShell_Object_Data | protected
getDrawSpheres() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getMaximumDistance() | APSpacePartitioning::PointShell_Object_Data |
getMaximumDistanceVector() | APSpacePartitioning::PointShell_Object_Data |
getName() const | vrecko::Ability | inline
getNodeWithIDFromTree(PointShell_SimpleNode *topNode, int ID) | APSpacePartitioning::PointShell_Object_Data | protected
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPointShellRootSize() | APSpacePartitioning::PointShell_Object_Data |
getPointShellSize() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getPolygons() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getPolygonsCount() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inlinevirtual
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRoot() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getRoot(CreationType type) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
hHierarchyCreationThread | APSpacePartitioning::SP_Object_Data_Base | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
insertPointsInLODTree(PointShell_Object_Data_LOD_Builder *lod_builder, PointShell_SimpleNode *p, int id) | APSpacePartitioning::PointShell_Object_Data | protected
isHierarchyCreated() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inlinevirtual
isUpdated(void) | vrecko::Ability |
levels | APSpacePartitioning::PointShell_Object_Data | protected
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadFromCache(const char *pModelFileName) | APSpacePartitioning::PointShell_Object_Data | protected
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadNodeFromFileRec(PointShell_SimpleNode *node, vrecko::BufferedFile *bfile, DynamicTree< PointShell_SimpleNode > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
loadSubDivisionMeshFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::PointShell_Object_Data | protected
loadTreeFromFile(vrecko::BufferedFile *bfile, DynamicTree< PointShell_SimpleNode > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APSpacePartitioning::PointShell_Object_Data | virtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
LOD_Hierarchy enum value | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
lodEdgeDistanceImportance | APSpacePartitioning::PointShell_Object_Data | protected
lodEdgeImporatnce | APSpacePartitioning::PointShell_Object_Data | protected
lodMaxLevels | APSpacePartitioning::PointShell_Object_Data | protected
lodMinimumVertices | APSpacePartitioning::PointShell_Object_Data | protected
lodMovableVertices | APSpacePartitioning::PointShell_Object_Data | protected
lodPercentageZeroLevelSize | APSpacePartitioning::PointShell_Object_Data | protected
lodVertexImporatnce | APSpacePartitioning::PointShell_Object_Data | protected
lodZeroLevelSize | APSpacePartitioning::PointShell_Object_Data | protected
maxDist | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
maxDistVect | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
ordered | APSpacePartitioning::PointShell_Object_Data | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APSpacePartitioning::SP_Object_Data_Base | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PointShell_Object_Data() | APSpacePartitioning::PointShell_Object_Data |
PointShell_Object_Data::getColor(int collisions) | APSpacePartitioning::PointShell_Object_Data | inline
PointShellGeneric_Object_Data(const char *abName) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
polygons | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
polygonsCount | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::SP_Object_Data_Base | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ready() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | inlineprotected
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rootSizeCollisions | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
rootSizeLOD | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
rootSizeMulti | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
rootSizeSimple | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
rootSizeSingle | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveNodeToFileRec(PointShell_SimpleNode *node, vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
savePointShellCollisions() | APSpacePartitioning::PointShell_Object_Data | protected
saveSubDivisionMeshToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::PointShell_Object_Data | protected
saveToCache(const char *pModelFileName) | APSpacePartitioning::PointShell_Object_Data | protected
saveTreeToFile(vrecko::BufferedFileWrite *bfile, DynamicTree< PointShell_SimpleNode > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
Simple enum value | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
SP_Object_Data_Base(const char *abName) | APSpacePartitioning::SP_Object_Data_Base |
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
spBranchingFactor | APSpacePartitioning::PointShell_Object_Data | protected
startThreadedHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
Test enum value | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
treeLOD | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeLODCreated | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeMultiLevel | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeMultiLevelCreated | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeSimple | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeSimpleCreated | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeSingleLevel | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
treeSingleLevelCreated | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > | protected
update() | APSpacePartitioning::SP_Object_Data_Base | virtual
updated | vrecko::Ability | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
voxels | APSpacePartitioning::PointShell_Object_Data | protected
voxResolution | APSpacePartitioning::PointShell_Object_Data | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
~PointShell_Object_Data() | APSpacePartitioning::PointShell_Object_Data |
~PointShellGeneric_Object_Data() | APSpacePartitioning::PointShellGeneric_Object_Data< PointShell_SimpleNode > |
~SP_Object_Data_Base() | APSpacePartitioning::SP_Object_Data_Base | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
APSpacePartitioning::PointShell_Object_Data_Geometry Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry, including all inherited members.

getEdges()=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
getPolygons()=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
getVertex(int seqnum)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
getVertices()=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inline
setEdgesCount(int count)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
setPolygonsCount(int count)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
setVerticesCount(int count)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
writeEdge(int seqnum, int vertexPos1, int vertexPos2)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
writePolygon(int seqnum, int v1, int v2, int v3)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
writeVertex(int seqnum, osg::Vec3f pos, osg::Vec3f norm)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
writeVertex(int seqnum, osg::Vec3f pos)=0 | APSpacePartitioning::PointShell_Object_Data_Geometry | pure virtual
~PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inlinevirtual
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser, including all inherited members.

calculateEdgeLength(int edge) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
calculateEdgesLength() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
calculateNormalOfPolygon(int seqnum) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
calculateNormalOfPolygons() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
calculateVertexNormal(int seqnum) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
calculateVerticesNormals() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
cleanVertexEdges() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
edges | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
finishStructureBuild() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
getEdges() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
getEdges(int polygon) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
getMaxDistance() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
getMaxDistanceVector() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
getPolygons() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
getVertex(int seqnum) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
getVertices() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
handleEdges(int polygon) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
iEdgesCount | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
iPolygonsCount | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
iVerticesCount | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
maxDistance | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
maxDistanceV1 | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
maxDistanceV2 | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inline
PointShell_Object_Data_Geometry_Analyser() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
polygons | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
setEdgesCount(int count) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
setPolygonsCount(int count) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
setVerticesCount(int count) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
vertices | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | protected
writeEdge(int seqnum, int vertexPos1, int vertexPos2) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
writeEdge(int seqnum, int vertexPos1, int vertexPos2, int polygonPos1, int polygonPos2) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser |
writePolygon(int seqnum, int v1, int v2, int v3) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
writeVertex(int seqnum, osg::Vec3f pos, osg::Vec3f norm) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
writeVertex(int seqnum, osg::Vec3f pos) | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | virtual
~PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inlinevirtual
~PointShell_Object_Data_Geometry_Analyser() | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_LOD_Builder
APSpacePartitioning::PointShell_Object_Data_LOD_Builder Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_LOD_Builder, including all inherited members.

addRequiredEdge(int edge, int reqEdge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
addVerticesLeafsAndChilds() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
bDebug | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protectedstatic
buildQueue(bool verbouse) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
buildReductionLevelStructure() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
calculateEdgeCost(int seqnum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateEdgeImportance(int seqnum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateEdgeLength(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateEdgesCost() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateEdgesImportance() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateEdgesLength() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateNewVertexPosition(int vertexToSet, int vt[3]) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateNormalOfPolygon(int seqnum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateNormalOfPolygons() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateVertexNormalAndImportance(int seqnum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
calculateVerticesNormalAndImporatance() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
cleanVertexEdges() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
Clear() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
computeRadiusOfBoundingSpheres() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
computeVertexLevels() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
edgeCost(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
edgeImportance(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
edgeLength(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
edges | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
edgesEqualByVertices(int e1, int e2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
equalArrays(int a1[], int a2[], int size) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
filename | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
finishStructureBuild() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
floatToTimeString(float time) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
getAngle(osg::Vec3f vec1, osg::Vec3f vec2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
getEdges() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
getEdges(int polygon) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
getLvlVertices(int lvl) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
getMaxLvl() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
getOkAndChangeEdges(int polygon, int v1, int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
getPolygons() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
getPolygonsCount() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inline
getRoots() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
getSame(int *a, int *b) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
getSameEdge(int p1, int p2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
getSameEdges(int p1, int p2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
getStatusResult() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
getThirdVertex(int polygon, int v1, int v2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
getVertex(int seqnum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
getVertices(int seqNum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
getVertices() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
getZeroLevelSize() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
handleEdges(int polygon) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
have2Polygons2OrMoreVetrticesSame(int p1, int p2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
iEdgesCount | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
intToStr(int number) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
iPolygonsCount | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
iVerticesCount | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
legalToRemoveEdge(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
lodEdgeDistanceImporatnce | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
lodEdgeImporatnce | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
lodVertexImporatnce | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
maxChildrens | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
maxDistance | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
maxLevels | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
mergeLevels() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
minVertices | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
moveVerticesPosition | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inline
PointShell_Object_Data_LOD_Builder() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
polygonHaveVertex(int polygon, int vertex) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
polygonHaveVertices(int polygon, int v1, int v2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
polygons | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
polygonsEqualsByVertices(int p1, int p2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
printOutEdge(string log, int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
printOutList(string log, list< int > edgesList) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
printOutPolygon(string log, int polygon) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
printOutQueue() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
printOutStatus() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
printOutVerbouseStatus() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
printOutVertex(string log, int vertex) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
reduceFront(int) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
refillQueue | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
removeRequiredEdges(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setEdgesCount(int count) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
setEdgeVisible(int edge, bool visibility) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setFileName(string name) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setLevelZeroSize(int size, float percentage) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setMaxChildrens(int maxChild) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setMaxLevels(int levels) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setMinimumVertices(int minimum) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setMovableVertices(bool value) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setParameters(float lodEI, float lodEDI, float lodVI) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
setPolygonsCount(int count) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
setPolygonVisible(int polygon, bool visibility) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setValidEdge(int edge) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setValidEdges() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
setValidVertex(int vertex, bool value) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setValidVertices() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
setVertexVisible(int vertex, bool visibility) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
setVerticesCount(int count) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
specialCase | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
subdivideMesh() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
test_Queue | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
test_Subdivision_Queue | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
treeRoots | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
vertexImportance(int vertex) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | inlineprotected
vertices | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
writeEdge(int seqnum, int vertexPos1, int vertexPos2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
writeEdge(int seqnum, int vertexPos1, int vertexPos2, int polygon1, int polygon2) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
writePolygon(int seqnum, int v1, int v2, int v3) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
writeVertex(int seqnum, osg::Vec3f pos, osg::Vec3f norm) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
writeVertex(int seqnum, osg::Vec3f pos) | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | virtual
zeroLevelSize | APSpacePartitioning::PointShell_Object_Data_LOD_Builder | protected
~PointShell_Object_Data_Geometry() | APSpacePartitioning::PointShell_Object_Data_Geometry | inlinevirtual
~PointShell_Object_Data_LOD_Builder() | APSpacePartitioning::PointShell_Object_Data_LOD_Builder |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_SimpleNode
APSpacePartitioning::PointShell_SimpleNode Member List

This is the complete list of members for APSpacePartitioning::PointShell_SimpleNode, including all inherited members.

collisions | APSpacePartitioning::PointShell_SimpleNode |
GetDepth() | DynTreeNode< PointShell_SimpleNode > |
id | APSpacePartitioning::PointShell_SimpleNode |
iNorm | APSpacePartitioning::PointShell_SimpleNode |
loadDataFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::PointShell_SimpleNode | inline
lpChild | DynTreeNode< PointShell_SimpleNode > |
lpNext | DynTreeNode< PointShell_SimpleNode > |
lpParent | DynTreeNode< PointShell_SimpleNode > |
lpPrev | DynTreeNode< PointShell_SimpleNode > |
pos | APSpacePartitioning::PointShell_SimpleNode |
radius | APSpacePartitioning::PointShell_SimpleNode |
saveDataToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::PointShell_SimpleNode | inline
tree | DynTreeNode< PointShell_SimpleNode > |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShellGeneric_Object_Data
APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > Member List

This is the complete list of members for APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType >, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCreated | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
bThreadShouldTerminate | APSpacePartitioning::SP_Object_Data_Base | protected
buildLODTree() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
ByVoxels_MultiLevel enum value | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
ByVoxels_SingleLevel enum value | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
clean(void) | vrecko::Ability | inlinevirtual
coreHierarchyCreation(void) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protectedvirtual
creationType | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
CreationType enum name | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
deallocateFaceArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
destroyPointShell(CreationType type) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | virtual
destroyPointShells() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | virtual
destroyThread() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisions(int id) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getDrawSpheres() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPointShellSize() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getPolygons() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getPolygonsCount() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inlinevirtual
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRoot() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getRoot(CreationType type) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
hHierarchyCreationThread | APSpacePartitioning::SP_Object_Data_Base | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isHierarchyCreated() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inlinevirtual
isUpdated(void) | vrecko::Ability |
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadNodeFromFileRec(_NodeType *node, vrecko::BufferedFile *bfile, DynamicTree< _NodeType > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
loadTreeFromFile(vrecko::BufferedFile *bfile, DynamicTree< _NodeType > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
APSpacePartitioning::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APSpacePartitioning::GeometryLoaderBase | virtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
LOD_Hierarchy enum value | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
maxDist | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
maxDistVect | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APSpacePartitioning::SP_Object_Data_Base | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PointShellGeneric_Object_Data(const char *abName) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
polygons | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
polygonsCount | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::SP_Object_Data_Base | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ready() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | inlineprotected
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rootSizeCollisions | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
rootSizeLOD | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
rootSizeMulti | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
rootSizeSimple | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
rootSizeSingle | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveNodeToFileRec(_NodeType *node, vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
savePointShellCollisions() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
saveTreeToFile(vrecko::BufferedFileWrite *bfile, DynamicTree< _NodeType > *t) | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
Simple enum value | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
SP_Object_Data_Base(const char *abName) | APSpacePartitioning::SP_Object_Data_Base |
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
startThreadedHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
Test enum value | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
treeLOD | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeLODCreated | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeMultiLevel | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeMultiLevelCreated | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeSimple | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeSimpleCreated | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeSingleLevel | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
treeSingleLevelCreated | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > | protected
update() | APSpacePartitioning::SP_Object_Data_Base | virtual
updated | vrecko::Ability | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
~PointShellGeneric_Object_Data() | APSpacePartitioning::PointShellGeneric_Object_Data< _NodeType > |
~SP_Object_Data_Base() | APSpacePartitioning::SP_Object_Data_Base | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShellVSVoxel_Object
APSpacePartitioning::PointShellVSVoxel_Object Member List

This is the complete list of members for APSpacePartitioning::PointShellVSVoxel_Object, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bTestComputation | APSpacePartitioning::PointShellVSVoxel_Object |
clean(void) | vrecko::Ability | inlinevirtual
collisiontime1 | APSpacePartitioning::PointShellVSVoxel_Object | protected
collisiontime2 | APSpacePartitioning::PointShellVSVoxel_Object | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fr | APSpacePartitioning::PointShellVSVoxel_Object | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time) | APSpacePartitioning::PointShellVSVoxel_Object | virtual
getID(void) const | vrecko::Ability | inline
getId() | vrecko::SP_ObjectInterface | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getObjectTransformation(EnvironmentObject *pObj, CollisionParams *params, osg::Matrix *outMat) | APSpacePartitioning::PointShellVSVoxel_Object | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hud | APSpacePartitioning::PointShellVSVoxel_Object | protected
hudInitialized | APSpacePartitioning::PointShellVSVoxel_Object | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
looptime1 | APSpacePartitioning::PointShellVSVoxel_Object | protected
looptime2 | APSpacePartitioning::PointShellVSVoxel_Object | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectID | APSpacePartitioning::PointShellVSVoxel_Object | protected
objIntId | vrecko::SP_ObjectInterface | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
PointShellVSVoxel_Object() | APSpacePartitioning::PointShellVSVoxel_Object |
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APSpacePartitioning::PointShellVSVoxel_Object | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTestComputation(bool state) | APSpacePartitioning::PointShellVSVoxel_Object | inline
SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PointShellVSVoxel_Object() | APSpacePartitioning::PointShellVSVoxel_Object |
~SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
APSpacePartitioning::SNCH_Object Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
angle_tolerance | APSpacePartitioning::SNCH_Object | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calcLMDHash(unsigned long int id1, unsigned long int id2) | APSpacePartitioning::SNCH_Object | inlineprotected
clean(void) | vrecko::Ability | inlinevirtual
ConeIntersection enum value | APSpacePartitioning::SNCH_Object | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID) | APSpacePartitioning::SNCH_Object | virtual
vrecko::SP_ObjectInterface::getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time) | vrecko::SP_ObjectInterface | inlinevirtual
getForce(void) | APSpacePartitioning::SNCH_Object |
getId() | vrecko::SP_ObjectInterface | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLMDStore(LMD_HASH hash) | APSpacePartitioning::SNCH_Object | protected
getMaxForce(void) | APSpacePartitioning::SNCH_Object | inline
getName() const | vrecko::Ability | inline
getNCoeficient(void) | APSpacePartitioning::SNCH_Object | inline
getObjectsTransformations(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, CollisionParams *params, osg::Matrix *transf1, osg::Matrix *transf2) | APSpacePartitioning::SNCH_Object | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
globalSearch(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds, CollisionParams *params) | APSpacePartitioning::SNCH_Object | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
LMD_HASH typedef | APSpacePartitioning::SNCH_Object | protected
lmd_store | APSpacePartitioning::SNCH_Object | protected
lmd_store_access | APSpacePartitioning::SNCH_Object | protected
LMD_STORE_MAP typedef | APSpacePartitioning::SNCH_Object | protected
LMDvector typedef | APSpacePartitioning::SNCH_Object |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
localSearch(SNCH_Object_Data *pOData1, SNCH_Object_Data *pOData2, LMDStore *lmds, CollisionParams *params, int lmdIndex, int dbgWriterGLIndex=0) | APSpacePartitioning::SNCH_Object | protected
max_force | APSpacePartitioning::SNCH_Object | protected
ncoeficient | APSpacePartitioning::SNCH_Object | protected
NoIntersection enum value | APSpacePartitioning::SNCH_Object | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objIntId | vrecko::SP_ObjectInterface | protected
old_getTriLMD(SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1, osg::Vec3 *center1, SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2, osg::Vec3 *center2, osg::Vec3 point[2][7], unsigned long *index1, unsigned long *index2) | APSpacePartitioning::SNCH_Object | protected
OriginalTriangleIntersection enum value | APSpacePartitioning::SNCH_Object | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APSpacePartitioning::SNCH_Object | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProjectionIntersectionResult enum name | APSpacePartitioning::SNCH_Object | protected
reject_distance_for_BS | APSpacePartitioning::SNCH_Object | protected
reject_distance_for_surfaces | APSpacePartitioning::SNCH_Object | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setMaxForce(double mforce) | APSpacePartitioning::SNCH_Object | inline
setNCoeficient(double nc) | APSpacePartitioning::SNCH_Object | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SNCH_Object() | APSpacePartitioning::SNCH_Object |
SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
SphereBVH_Object() | APSpacePartitioning::SphereBVH_Object |
testNodeNorec(SNCH_Object_Data::STNodeSNCH *pSTNode1, SNCH_Object_Data *pOData1, osg::Matrix *transf1, SNCH_Object_Data::STNodeSNCH *pSTNode2, SNCH_Object_Data *pOData2, osg::Matrix *transf2, LMDStore *lmds, CollisionParams *params) | APSpacePartitioning::SNCH_Object | protected
triDistance(OneTri *points0, OneTri *points1, osg::Vec3 *outPoint1Trans=NULL, osg::Vec3 *outPoint2Trans=NULL, unsigned short *closeFeature0=NULL, unsigned short *closeFeature1=NULL) | APSpacePartitioning::SNCH_Object | protected
triIntersects(OneTri *points0, OneTri *points1, osg::Vec3 *outPoint0Trans=NULL, osg::Vec3 *outPoint1Trans=NULL, osg::Vec3 *outPoint0Tri0Cross=NULL, osg::Vec3 *outPoint1Tri0Cross=NULL, bool *bOutPointsTriCrossValid=NULL) | APSpacePartitioning::SNCH_Object | protected
triProjectionIntersection(OneTri *points0, OneTri *points1, osg::Vec3 *outIntersectionPoint0=NULL, osg::Vec3 *outIntersectionPoint1=NULL, bool bPerformPretests=true) | APSpacePartitioning::SNCH_Object | protected
TWO_TRIS typedef | APSpacePartitioning::SNCH_Object | protected
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~SNCH_Object() | APSpacePartitioning::SNCH_Object |
~SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
~SphereBVH_Object() | APSpacePartitioning::SphereBVH_Object |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • LMDStore
APSpacePartitioning::SNCH_Object::LMDStore Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object::LMDStore, including all inherited members.

active_LMD | APSpacePartitioning::SNCH_Object::LMDStore |
bLMDValid | APSpacePartitioning::SNCH_Object::LMDStore |
LMDs | APSpacePartitioning::SNCH_Object::LMDStore |
LMDStore() | APSpacePartitioning::SNCH_Object::LMDStore | inline
LMDswitch | APSpacePartitioning::SNCH_Object::LMDStore |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • OneTri
APSpacePartitioning::SNCH_Object::OneTri Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object::OneTri, including all inherited members.

bZeroNormal | APSpacePartitioning::SNCH_Object::OneTri |
calcD() | APSpacePartitioning::SNCH_Object::OneTri | inline
calcNormal() | APSpacePartitioning::SNCH_Object::OneTri | inline
OneTri() | APSpacePartitioning::SNCH_Object::OneTri | inline
planeD | APSpacePartitioning::SNCH_Object::OneTri |
planeNormal | APSpacePartitioning::SNCH_Object::OneTri |
reset() | APSpacePartitioning::SNCH_Object::OneTri | inline
v | APSpacePartitioning::SNCH_Object::OneTri |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
APSpacePartitioning::SNCH_Object_Data Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
allocateSTNode() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
bSNCHierarchyCreated | APSpacePartitioning::SNCH_Object_Data | protected
bSphereBVHierarchyCreated | APSpacePartitioning::SphereBVH_Object_Data | protected
bThreadShouldTerminate | APSpacePartitioning::SP_Object_Data_Base | protected
calcSubtreeTriangleRepresentant(void *pNode, osg::Vec3 *axis, unsigned long *triangle, float *bestValue=NULL) | APSpacePartitioning::SNCH_Object_Data | protected
calculateGeometryProperties(void) | APSpacePartitioning::SNCH_Object_Data | protected
clean(void) | vrecko::Ability | inlinevirtual
computeSNCH(void *pSTNode) | APSpacePartitioning::SNCH_Object_Data | protected
constructCacheDataName(char *pOutDataName, int *version) | APSpacePartitioning::SNCH_Object_Data | protectedvirtual
constructTree(void *pSTNode, unsigned long left_pos, unsigned long right_pos, int last_sort) | APSpacePartitioning::SphereBVH_Object_Data | protected
coreHierarchyCreation(void) | APSpacePartitioning::SNCH_Object_Data | protectedvirtual
createEdgeGroups(void) | APSpacePartitioning::SNCH_Object_Data | protected
createFaceGroups(void) | APSpacePartitioning::SNCH_Object_Data | protected
createTreeFromGeometry(osg::Node *pNode) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
deallocateFaceArray() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
destroyHierarchy(STNodeSphere *subTreeToDestroy=NULL) | APSpacePartitioning::SphereBVH_Object_Data | virtual
destroyThread() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
generateVertexNeighbourhood(void) | APSpacePartitioning::SNCH_Object_Data | protected
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRootPtr(void) | APSpacePartitioning::SphereBVH_Object_Data | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSNCHFace(unsigned long index) | APSpacePartitioning::SNCH_Object_Data | inline
getSNCHVertex(unsigned long index) | APSpacePartitioning::SNCH_Object_Data | inline
getSTNodeStructureSize() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
hHierarchyCreationThread | APSpacePartitioning::SP_Object_Data_Base | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isHierarchyCreated() | APSpacePartitioning::SNCH_Object_Data | inlinevirtual
isUpdated(void) | vrecko::Ability |
loadDataFromPC_LoadTreeNode(vrecko::BufferedFile *bfile, STNodeSphere **ptrToStoreNode) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
loadDataFromPersistentCache_Init() | APSpacePartitioning::SNCH_Object_Data | protectedvirtual
loadDataFromPersistentCache_ReadData(vrecko::BufferedFile *bfile) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadTreeNodeFromFile(void *node, vrecko::BufferedFile *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
APSpacePartitioning::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APSpacePartitioning::GeometryLoaderBase | virtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APSpacePartitioning::SP_Object_Data_Base | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::SP_Object_Data_Base | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
root | APSpacePartitioning::SphereBVH_Object_Data | protected
saveDataToPC_SaveTreeNode(vrecko::BufferedFileWrite *bfile, STNodeSphere *node) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveDataToPersistentCache_Init() | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveDataToPersistentCache_WriteData(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
saveTreeNodeToFile(void *node, vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SNCH_Object_Data | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SNCH_Object_Data() | APSpacePartitioning::SNCH_Object_Data |
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
SP_Object_Data_Base(const char *abName) | APSpacePartitioning::SP_Object_Data_Base |
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
SphereBVH_Object_Data() | APSpacePartitioning::SphereBVH_Object_Data |
SphereBVH_Object_Data(const char *abName) | APSpacePartitioning::SphereBVH_Object_Data |
startThreadedHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
update() | APSpacePartitioning::SP_Object_Data_Base | virtual
updated | vrecko::Ability | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
wdsInfoRec(void *pSTNode, int level, DebugStats *ds) | APSpacePartitioning::SNCH_Object_Data | protected
writeDebugStatistics() | APSpacePartitioning::SNCH_Object_Data | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
~SNCH_Object_Data() | APSpacePartitioning::SNCH_Object_Data |
~SP_Object_Data_Base() | APSpacePartitioning::SP_Object_Data_Base | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
~SphereBVH_Object_Data() | APSpacePartitioning::SphereBVH_Object_Data |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SP_Object_Data_Base
APSpacePartitioning::SP_Object_Data_Base Member List

This is the complete list of members for APSpacePartitioning::SP_Object_Data_Base, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bThreadShouldTerminate | APSpacePartitioning::SP_Object_Data_Base | protected
clean(void) | vrecko::Ability | inlinevirtual
coreHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | inlineprotectedvirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyThread() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hHierarchyCreationThread | APSpacePartitioning::SP_Object_Data_Base | protected
HierarchyThreadProc(SP_Object_Data_Base *lpParameter) | APSpacePartitioning::SP_Object_Data_Base | friend
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isHierarchyCreated() | vrecko::SP_Object_DataInterface | inlinevirtual
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APSpacePartitioning::SP_Object_Data_Base | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::SP_Object_Data_Base | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SP_Object_Data_Base(const char *abName) | APSpacePartitioning::SP_Object_Data_Base |
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
startThreadedHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
update() | APSpacePartitioning::SP_Object_Data_Base | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~SP_Object_Data_Base() | APSpacePartitioning::SP_Object_Data_Base | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object
APSpacePartitioning::SphereBVH_Object Member List

This is the complete list of members for APSpacePartitioning::SphereBVH_Object, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID) | APSpacePartitioning::SphereBVH_Object |
vrecko::SP_ObjectInterface::getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time) | vrecko::SP_ObjectInterface | inlinevirtual
getId() | vrecko::SP_ObjectInterface | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objIntId | vrecko::SP_ObjectInterface | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APSpacePartitioning::SphereBVH_Object | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
SphereBVH_Object() | APSpacePartitioning::SphereBVH_Object |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
~SphereBVH_Object() | APSpacePartitioning::SphereBVH_Object |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object_Data
APSpacePartitioning::SphereBVH_Object_Data Member List

This is the complete list of members for APSpacePartitioning::SphereBVH_Object_Data, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
allocateSTNode() | APSpacePartitioning::SphereBVH_Object_Data | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
bSphereBVHierarchyCreated | APSpacePartitioning::SphereBVH_Object_Data | protected
bThreadShouldTerminate | APSpacePartitioning::SP_Object_Data_Base | protected
clean(void) | vrecko::Ability | inlinevirtual
constructCacheDataName(char *pOutDataName, int *version) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
constructTree(void *pSTNode, unsigned long left_pos, unsigned long right_pos, int last_sort) | APSpacePartitioning::SphereBVH_Object_Data | protected
coreHierarchyCreation(void) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
createTreeFromGeometry(osg::Node *pNode) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
deallocateFaceArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
destroyHierarchy(STNodeSphere *subTreeToDestroy=NULL) | APSpacePartitioning::SphereBVH_Object_Data | virtual
destroyThread() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRootPtr(void) | APSpacePartitioning::SphereBVH_Object_Data | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getSTNodeStructureSize() | APSpacePartitioning::SphereBVH_Object_Data | inlinevirtual
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
hHierarchyCreationThread | APSpacePartitioning::SP_Object_Data_Base | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isHierarchyCreated() | APSpacePartitioning::SphereBVH_Object_Data | inlinevirtual
isUpdated(void) | vrecko::Ability |
loadDataFromPC_LoadTreeNode(vrecko::BufferedFile *bfile, STNodeSphere **ptrToStoreNode) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
loadDataFromPersistentCache_Init() | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
loadDataFromPersistentCache_ReadData(vrecko::BufferedFile *bfile) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadTreeNodeFromFile(void *node, vrecko::BufferedFile *bfile) | APSpacePartitioning::SphereBVH_Object_Data | virtual
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
APSpacePartitioning::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APSpacePartitioning::GeometryLoaderBase | virtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
APSpacePartitioning::SP_Object_Data_Base::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | APSpacePartitioning::SP_Object_Data_Base | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::SP_Object_Data_Base | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
root | APSpacePartitioning::SphereBVH_Object_Data | protected
saveDataToPC_SaveTreeNode(vrecko::BufferedFileWrite *bfile, STNodeSphere *node) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveDataToPersistentCache_Init() | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveDataToPersistentCache_WriteData(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SphereBVH_Object_Data | protectedvirtual
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveTreeNodeToFile(void *node, vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::SphereBVH_Object_Data | virtual
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
SP_Object_Data_Base(const char *abName) | APSpacePartitioning::SP_Object_Data_Base |
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
SphereBVH_Object_Data() | APSpacePartitioning::SphereBVH_Object_Data |
SphereBVH_Object_Data(const char *abName) | APSpacePartitioning::SphereBVH_Object_Data |
startThreadedHierarchyCreation() | APSpacePartitioning::SP_Object_Data_Base | protectedvirtual
update() | APSpacePartitioning::SP_Object_Data_Base | virtual
updated | vrecko::Ability | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
~SP_Object_Data_Base() | APSpacePartitioning::SP_Object_Data_Base | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
~SphereBVH_Object_Data() | APSpacePartitioning::SphereBVH_Object_Data |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Scene
APSpacePartitioning::SphereBVH_Scene Member List

This is the complete list of members for APSpacePartitioning::SphereBVH_Scene, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getId() | vrecko::SP_SceneInterface | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
performCompleteTest(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | vrecko::SP_SceneInterface | inlinevirtual
performUpdate(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | vrecko::SP_SceneInterface | inlinevirtual
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | APSpacePartitioning::SphereBVH_Scene | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
scIntId | vrecko::SP_SceneInterface | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SP_SceneInterface() | vrecko::SP_SceneInterface | inline
SphereBVH_Scene() | APSpacePartitioning::SphereBVH_Scene | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~SP_SceneInterface() | vrecko::SP_SceneInterface | inline
~SphereBVH_Scene() | APSpacePartitioning::SphereBVH_Scene | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VoxelGrid_Object_Data
APSpacePartitioning::VoxelGrid_Object_Data Member List

This is the complete list of members for APSpacePartitioning::VoxelGrid_Object_Data, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
allocateFaceArray(unsigned long numFaces) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
allocateVertexArray(unsigned long numVertices) | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bboxDF | APSpacePartitioning::VoxelGrid_Object_Data | protected
bboxSizeDF | APSpacePartitioning::VoxelGrid_Object_Data | protected
bCollisionCreated | APSpacePartitioning::VoxelGrid_Object_Data | protected
bGridCreated | APSpacePartitioning::VoxelGrid_Object_Data | protected
bGridFilled | APSpacePartitioning::VoxelGrid_Object_Data | protected
bRecalculateNormals | APSpacePartitioning::GeometryLoaderBase | protected
clean(void) | vrecko::Ability | inlinevirtual
constructCacheDataName(char *pOutDataName) | APSpacePartitioning::VoxelGrid_Object_Data | protected
createDistanceFieldGrid() | APSpacePartitioning::VoxelGrid_Object_Data | protected
createDistanceFieldGridCollision() | APSpacePartitioning::VoxelGrid_Object_Data | protected
createDistanceFieldTempGrid() | APSpacePartitioning::VoxelGrid_Object_Data | protected
createHierarchy(void) | APSpacePartitioning::VoxelGrid_Object_Data | virtual
deallocateFaceArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
deallocateVertexArray() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
debugWriteNormals() | APSpacePartitioning::GeometryLoaderBase |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyDistanceFieldGrid() | APSpacePartitioning::VoxelGrid_Object_Data | protected
destroyDistanceFieldGridCollision() | APSpacePartitioning::VoxelGrid_Object_Data | protected
destroyDistanceFieldTempGrid() | APSpacePartitioning::VoxelGrid_Object_Data | protected
destroyGeometry() | APSpacePartitioning::GeometryLoaderBase | protectedvirtual
dFXDim | APSpacePartitioning::VoxelGrid_Object_Data | protected
dFYDim | APSpacePartitioning::VoxelGrid_Object_Data | protected
dFZDim | APSpacePartitioning::VoxelGrid_Object_Data | protected
distanceField | APSpacePartitioning::VoxelGrid_Object_Data | protected
distanceFieldCollsions | APSpacePartitioning::VoxelGrid_Object_Data | protected
distanceFieldTemp | APSpacePartitioning::VoxelGrid_Object_Data | protected
dRequestedCellLength | APSpacePartitioning::VoxelGrid_Object_Data | protected
face_count | APSpacePartitioning::GeometryLoaderBase | protected
face_size | APSpacePartitioning::GeometryLoaderBase | protected
faces | APSpacePartitioning::GeometryLoaderBase | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getBBoxDF() | APSpacePartitioning::VoxelGrid_Object_Data | inline
getBBoxDFSize() | APSpacePartitioning::VoxelGrid_Object_Data | inline
getDistanceFieldValue(int x, int y, int z) | APSpacePartitioning::VoxelGrid_Object_Data | inline
getDistanceFieldValueEffect(unsigned long x, unsigned long y, unsigned long z, int level) | APSpacePartitioning::VoxelGrid_Object_Data | inline
getDistanceTempFieldValue(int x, int y, int z) | APSpacePartitioning::VoxelGrid_Object_Data | inline
getFace(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getFaceCount() | APSpacePartitioning::GeometryLoaderBase | inline
getFaceStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNormalByIndex(osg::Geometry::AttributeBinding normalBinding, osg::Vec3Array *pNormArray, osg::IndexArray *pNormIndices, unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inlineprotected
getOSGInitCounts(osg::Node *pNode, unsigned long &pVertexCount, unsigned long &pPrimitiveCount) | APSpacePartitioning::GeometryLoaderBase | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestedCellSize() | APSpacePartitioning::VoxelGrid_Object_Data | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getVertex(unsigned long index) | APSpacePartitioning::GeometryLoaderBase | inline
getVertexCount() | APSpacePartitioning::GeometryLoaderBase | inline
getVertexStructureSize() | APSpacePartitioning::GeometryLoaderBase | inlinevirtual
getXDFDim() | APSpacePartitioning::VoxelGrid_Object_Data | inline
getYDFDim() | APSpacePartitioning::VoxelGrid_Object_Data | inline
getZDFDim() | APSpacePartitioning::VoxelGrid_Object_Data | inline
iDilatation | APSpacePartitioning::VoxelGrid_Object_Data | protected
iDilatationStrategy | APSpacePartitioning::VoxelGrid_Object_Data | protected
iGenType | APSpacePartitioning::VoxelGrid_Object_Data | protected
iMaxCollisionsFromLoadedVoxel | APSpacePartitioning::VoxelGrid_Object_Data | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isHierarchyCreated() | APSpacePartitioning::VoxelGrid_Object_Data | inlinevirtual
isUpdated(void) | vrecko::Ability |
loadCollisions() | APSpacePartitioning::VoxelGrid_Object_Data | protected
loadCollisionsFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::VoxelGrid_Object_Data | protected
loadFacesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadFromCache(const char *pModelFileName) | APSpacePartitioning::VoxelGrid_Object_Data | protected
loadGeometry(osg::Node *pNode) | APSpacePartitioning::GeometryLoaderBase | virtual
loadGeometryHelper(osg::Node *pNode, osg::Matrix &transform, unsigned long &vertex_pos, unsigned long &face_pos) | APSpacePartitioning::GeometryLoaderBase | protected
loadGridFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::VoxelGrid_Object_Data | protected
loadVerticesFromFile(vrecko::BufferedFile *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | APSpacePartitioning::VoxelGrid_Object_Data | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APSpacePartitioning::VoxelGrid_Object_Data | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APSpacePartitioning::VoxelGrid_Object_Data | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
recalculateNormals() | APSpacePartitioning::GeometryLoaderBase | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
returnColorOfVoxel(int x, int y, int z) | APSpacePartitioning::VoxelGrid_Object_Data | inline
saveCollisions() | APSpacePartitioning::VoxelGrid_Object_Data | protected
saveCollisionsToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::VoxelGrid_Object_Data | protected
saveFacesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveGridToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::VoxelGrid_Object_Data | protected
saveToCache(const char *pModelFileName) | APSpacePartitioning::VoxelGrid_Object_Data | protected
saveVerticesToFile(vrecko::BufferedFileWrite *bfile) | APSpacePartitioning::GeometryLoaderBase | virtual
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDistanceFieldTempValue(unsigned long x, unsigned long y, unsigned long z, float newValue) | APSpacePartitioning::VoxelGrid_Object_Data | inlineprotected
setDistanceFieldValue(unsigned long x, unsigned long y, unsigned long z, float newValue) | APSpacePartitioning::VoxelGrid_Object_Data | inlineprotected
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
sortVerticesClockwise() | APSpacePartitioning::GeometryLoaderBase | protected
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
update() | APSpacePartitioning::VoxelGrid_Object_Data | virtual
updated | vrecko::Ability | protected
updateDataInformation(char *data, char *file) | APSpacePartitioning::VoxelGrid_Object_Data | protected
vertex_count | APSpacePartitioning::GeometryLoaderBase | protected
vertex_size | APSpacePartitioning::GeometryLoaderBase | protected
vertices | APSpacePartitioning::GeometryLoaderBase | protected
VoxelGrid_Object_Data() | APSpacePartitioning::VoxelGrid_Object_Data |
VoxelGrid_Object_Data::getCollisions(int x, int y, int z) | APSpacePartitioning::VoxelGrid_Object_Data | inline
VoxelGrid_Object_Data::increaseVoxelValueCollisions(int x, int y, int z) | APSpacePartitioning::VoxelGrid_Object_Data | inline
VoxelGrid_Object_Data::setVoxelValueCollisions(int x, int y, int z, int value) | APSpacePartitioning::VoxelGrid_Object_Data | inline
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~GeometryLoaderBase() | APSpacePartitioning::GeometryLoaderBase |
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
~VoxelGrid_Object_Data() | APSpacePartitioning::VoxelGrid_Object_Data |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • mycomparisonMaxMin
APSpacePartitioning::mycomparisonMaxMin Member List

This is the complete list of members for APSpacePartitioning::mycomparisonMaxMin, including all inherited members.

mycomparisonMaxMin() | APSpacePartitioning::mycomparisonMaxMin | inline
operator()(const std::pair< float, int > &first, const std::pair< float, int > &second) const | APSpacePartitioning::mycomparisonMaxMin | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • mycomparisonMinMax
APSpacePartitioning::mycomparisonMinMax Member List

This is the complete list of members for APSpacePartitioning::mycomparisonMinMax, including all inherited members.

mycomparisonMinMax() | APSpacePartitioning::mycomparisonMinMax | inline
operator()(const std::pair< float, int > &first, const std::pair< float, int > &second) const | APSpacePartitioning::mycomparisonMinMax | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APTextOutput
  • Console
APTextOutput::Console Member List

This is the complete list of members for APTextOutput::Console, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addLine(const char *line, const osg::Vec4 &color=*((osg::Vec4 *) NULL)) | APTextOutput::Console |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
animator | APTextOutput::Console | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bNewItemAdded | APTextOutput::Console | protected
borderXSize | APTextOutput::Console | protected
borderYSize | APTextOutput::Console | protected
camera | APTextOutput::Console | protected
clean(void) | vrecko::Ability | inlinevirtual
Console() | APTextOutput::Console |
DECLARE_REQUEST_INPUT(Add, MessageString, MessageVoid) | APTextOutput::Console | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
eo | APTextOutput::Console | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
geode | APTextOutput::Console | protected
geom | APTextOutput::Console | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
lines | APTextOutput::Console | protected
lineSpace | APTextOutput::Console | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | APTextOutput::Console | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menuAwayTime | APTextOutput::Console | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | APTextOutput::Console | virtual
pOwner | vrecko::Ability | protected
preInitialize() | APTextOutput::Console | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
slideMax | APTextOutput::Console | protected
update(void) | APTextOutput::Console | virtual
updated | vrecko::Ability | protected
viewHeight | APTextOutput::Console | protected
viewWidth | APTextOutput::Console | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Console() | APTextOutput::Console |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APTextOutput
  • Console
  • Line
APTextOutput::Console::Line Member List

This is the complete list of members for APTextOutput::Console::Line, including all inherited members.

logTime | APTextOutput::Console::Line
necessaryTime | APTextOutput::Console::Line
text | APTextOutput::Console::Line
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APWeather
  • Weather
APWeather::Weather Member List

This is the complete list of members for APWeather::Weather, including all inherited members.

_effect | APWeather::Weather | protected
_transformNode | APWeather::Weather | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addToScene() | APWeather::Weather |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getEffect() | APWeather::Weather | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | APWeather::Weather | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeFromScene() | APWeather::Weather |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
Weather() | APWeather::Weather |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
AddObserver Member List

This is the complete list of members for AddObserver, including all inherited members.

AddObserver() | AddObserver | inline
AddUpdate(string modelFilename, ModelType modelType)=0 | AddObserver | pure virtual
Generated on Sun Feb 17 2013 23:29:53 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Arm Member List

This is the complete list of members for Arm, including all inherited members.

assign4x4(matrix_4 to, matrix_4 from) | Arm
calcFull() | Arm
calcJoints() | Arm
calcM() | Arm
calcNothing() | Arm
calcParams() | Arm
calcStylus3DOF() | Arm
calcStylus6DOF() | Arm
calcStylusDir() | Arm
calcT() | Arm
calcTrig() | Arm
check_motion() | Arm
checkBckg() | Arm
connect(const char *port) | Arm
convertExtParams() | Arm
convertParams() | Arm
disconnect() | Arm
end_motion() | Arm
full_update() | Arm
fullBckg() | Arm
getButt() | Arm
getConstants() | Arm
getStylusDir() | Arm
getStylusTip() | Arm
getT(int, int) | Arm
hci | Arm
homePos() | Arm
identity4x4(matrix_4 M) | Arm
init() | Arm
installSimple() | Arm
joint_update3() | Arm
joint_update6() | Arm
jointBckg3() | Arm
jointBckg6() | Arm
mul4x4(matrix_4 M1, matrix_4 M2, matrix_4 X) | Arm
paramsDH0_5() | Arm
startMotion(int num_encoders, int motion_thresh, int packet_delay, int btns_active) | Arm
stylus3DOFbckg() | Arm
stylus3DOFmotion(int motion_thresh, int packet_delay, int btns_active) | Arm
stylus3DOFupdate() | Arm
stylus6DOFbckg() | Arm
stylus6DOFmotion(int motion_thresh, int packet_delay, int btns_active) | Arm
stylus6DOFupdate() | Arm
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • AnimatedModel
ArtificialWorld::AnimatedModel Member List

This is the complete list of members for ArtificialWorld::AnimatedModel, including all inherited members.

AnimatedModel(void) | ArtificialWorld::AnimatedModel | inline
fileName | ArtificialWorld::Model | protected
Geometry | ArtificialWorld::Model |
GetAnimationIndex(void) | ArtificialWorld::AnimatedModel | inline
GetFileName(void) | ArtificialWorld::Model | inline
GetMaxVisibleDistance(void) | ArtificialWorld::Model | inline
GetMinVisibleDistance(void) | ArtificialWorld::Model | inline
GetModelFlags(void) | ArtificialWorld::Model | inline
GetModelType(void) | ArtificialWorld::Model | inline
GetPosition(void) | ArtificialWorld::Model | inline
GetRotation(void) | ArtificialWorld::Model | inline
GetScale(void) | ArtificialWorld::Model | inline
hasMaxDistance | ArtificialWorld::Model | protected
HasMaxVisibleDistance(void) | ArtificialWorld::Model | inline
hasMinDistance | ArtificialWorld::Model | protected
HasMinVisibleDistance(void) | ArtificialWorld::Model | inline
hasPositionSet | ArtificialWorld::Model | protected
HasPositionSet(void) | ArtificialWorld::Model | inline
maxVisibleDistance | ArtificialWorld::Model | protected
minVisibleDistance | ArtificialWorld::Model | protected
Model(void) | ArtificialWorld::Model |
modelFlags | ArtificialWorld::Model | protected
modelType | ArtificialWorld::Model | protected
position | ArtificialWorld::Model | protected
rotation | ArtificialWorld::Model | protected
scale | ArtificialWorld::Model | protected
SetAnimationIndex(int index) | ArtificialWorld::AnimatedModel | inline
SetFileName(string fname) | ArtificialWorld::Model | inline
SetFileName(char *fname) | ArtificialWorld::Model | inline
SetMaxVisibleDistance(unsigned long maxDist) | ArtificialWorld::Model | inline
SetMinVisibleDistance(unsigned long minDist) | ArtificialWorld::Model | inline
SetModelFlags(ModelFlags flags) | ArtificialWorld::Model | inline
SetModelType(ModelType mtype) | ArtificialWorld::Model | inline
SetPosition(osg::Vec3 pos) | ArtificialWorld::Model | inline
SetRotation(osg::Quat rot) | ArtificialWorld::Model | inline
SetScale(osg::Vec3 sc) | ArtificialWorld::Model | inline
~Model(void) | ArtificialWorld::Model | inlinevirtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • AnimationPoint
ArtificialWorld::AnimationPoint Member List

This is the complete list of members for ArtificialWorld::AnimationPoint, including all inherited members.

alpha | ArtificialWorld::AnimationPoint |
alphaSet | ArtificialWorld::AnimationPoint |
AnimationPoint() | ArtificialWorld::AnimationPoint | inline
AnimationPoint(osg::Vec3 trans, osg::Quat rot, osg::Vec3 scal, float alfa, osg::Node::NodeMask nmask) | ArtificialWorld::AnimationPoint | inline
nodeMask | ArtificialWorld::AnimationPoint |
nodeMaskSet | ArtificialWorld::AnimationPoint |
rotation | ArtificialWorld::AnimationPoint |
rotationSet | ArtificialWorld::AnimationPoint |
scale | ArtificialWorld::AnimationPoint |
scaleSet | ArtificialWorld::AnimationPoint |
translation | ArtificialWorld::AnimationPoint |
translationSet | ArtificialWorld::AnimationPoint |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • BlockAttributes
ArtificialWorld::BlockAttributes Member List

This is the complete list of members for ArtificialWorld::BlockAttributes, including all inherited members.

BlockAttributes() | ArtificialWorld::BlockAttributes | inline
GetObjectCenterDir(void) | ArtificialWorld::BlockAttributes | inline
GetObjectCenterPoint(void) | ArtificialWorld::BlockAttributes | inline
SetObjectCenterDir(osg::Vec3 newCenterDir) | ArtificialWorld::BlockAttributes | inline
SetObjectCenterPoint(osg::Vec3 newCenterPoint) | ArtificialWorld::BlockAttributes | inline
WhatIsSet(void) | ArtificialWorld::BlockAttributes | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • BlockUpdater
ArtificialWorld::BlockUpdater Member List

This is the complete list of members for ArtificialWorld::BlockUpdater, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BlockUpdater() | ArtificialWorld::BlockUpdater |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
GetAttributes(void) | ArtificialWorld::BlockUpdater | inline
GetBlockType(void) | ArtificialWorld::BlockUpdater | inline
GetBoundingBox(void) | ArtificialWorld::BlockUpdater | inline
GetBoundingSphere(void) | ArtificialWorld::BlockUpdater | inline
GetCurrentWorldPosition(void) | ArtificialWorld::BlockUpdater | inline
getDOMDocument() | ArtificialWorld::BlockUpdater | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
GetModels(void) | ArtificialWorld::BlockUpdater | inline
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GetSubBlocks(void) | ArtificialWorld::BlockUpdater | inline
GetSubBlocksUpdaters(void) | ArtificialWorld::BlockUpdater | inline
getVisibleModels(osg::Vec3 position) | ArtificialWorld::BlockUpdater |
Hide() | ArtificialWorld::BlockUpdater |
HideSubBlocks() | ArtificialWorld::BlockUpdater |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
IsVisible() | ArtificialWorld::BlockUpdater |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ArtificialWorld::BlockUpdater | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
LoadXMLParametersFromFile(string filename) | ArtificialWorld::BlockUpdater |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ArtificialWorld::BlockUpdater | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | ArtificialWorld::BlockUpdater | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
SetParentEO(EnvironmentObject *newParentEO) | ArtificialWorld::BlockUpdater |
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
Show() | ArtificialWorld::BlockUpdater |
ShowSubBlocks() | ArtificialWorld::BlockUpdater |
update(void) | ArtificialWorld::BlockUpdater | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BlockUpdater() | ArtificialWorld::BlockUpdater |
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • Model
ArtificialWorld::Model Member List

This is the complete list of members for ArtificialWorld::Model, including all inherited members.

fileName | ArtificialWorld::Model | protected
Geometry | ArtificialWorld::Model |
GetFileName(void) | ArtificialWorld::Model | inline
GetMaxVisibleDistance(void) | ArtificialWorld::Model | inline
GetMinVisibleDistance(void) | ArtificialWorld::Model | inline
GetModelFlags(void) | ArtificialWorld::Model | inline
GetModelType(void) | ArtificialWorld::Model | inline
GetPosition(void) | ArtificialWorld::Model | inline
GetRotation(void) | ArtificialWorld::Model | inline
GetScale(void) | ArtificialWorld::Model | inline
hasMaxDistance | ArtificialWorld::Model | protected
HasMaxVisibleDistance(void) | ArtificialWorld::Model | inline
hasMinDistance | ArtificialWorld::Model | protected
HasMinVisibleDistance(void) | ArtificialWorld::Model | inline
HasPositionSet(void) | ArtificialWorld::Model | inline
hasPositionSet | ArtificialWorld::Model | protected
maxVisibleDistance | ArtificialWorld::Model | protected
minVisibleDistance | ArtificialWorld::Model | protected
Model(void) | ArtificialWorld::Model |
modelFlags | ArtificialWorld::Model | protected
modelType | ArtificialWorld::Model | protected
position | ArtificialWorld::Model | protected
rotation | ArtificialWorld::Model | protected
scale | ArtificialWorld::Model | protected
SetFileName(string fname) | ArtificialWorld::Model | inline
SetFileName(char *fname) | ArtificialWorld::Model | inline
SetMaxVisibleDistance(unsigned long maxDist) | ArtificialWorld::Model | inline
SetMinVisibleDistance(unsigned long minDist) | ArtificialWorld::Model | inline
SetModelFlags(ModelFlags flags) | ArtificialWorld::Model | inline
SetModelType(ModelType mtype) | ArtificialWorld::Model | inline
SetPosition(osg::Vec3 pos) | ArtificialWorld::Model | inline
SetRotation(osg::Quat rot) | ArtificialWorld::Model | inline
SetScale(osg::Vec3 sc) | ArtificialWorld::Model | inline
~Model(void) | ArtificialWorld::Model | inlinevirtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • SubBlock
ArtificialWorld::SubBlock Member List

This is the complete list of members for ArtificialWorld::SubBlock, including all inherited members.

animation | ArtificialWorld::SubBlock | protected
DeleteAnimation(void) | ArtificialWorld::SubBlock | inline
filename | ArtificialWorld::SubBlock | protected
GetAnimation(void) | ArtificialWorld::SubBlock | inline
GetFileName(void) | ArtificialWorld::SubBlock | inline
GetMaxVisibleDistance(void) | ArtificialWorld::SubBlock | inline
GetPosition(void) | ArtificialWorld::SubBlock | inline
GetRotation(void) | ArtificialWorld::SubBlock | inline
GetSubBlockType(void) | ArtificialWorld::SubBlock | inline
hasAnimation | ArtificialWorld::SubBlock | protected
HasAnimation(void) | ArtificialWorld::SubBlock | inline
HasMaxVisibleDistance(void) | ArtificialWorld::SubBlock | inline
hasMaxVisibleDistance | ArtificialWorld::SubBlock | protected
maxVisibleDistance | ArtificialWorld::SubBlock | protected
position | ArtificialWorld::SubBlock | protected
rotation | ArtificialWorld::SubBlock | protected
SetAnimation(void) | ArtificialWorld::SubBlock | inline
SetFileName(string fname) | ArtificialWorld::SubBlock | inline
SetMaxVisibleDistance(unsigned long dist) | ArtificialWorld::SubBlock | inline
SetPosition(osg::Vec3 pos) | ArtificialWorld::SubBlock | inline
SetRotation(osg::Quat rot) | ArtificialWorld::SubBlock | inline
SetSubBlockType(string sbType) | ArtificialWorld::SubBlock | inline
SubBlock(void) | ArtificialWorld::SubBlock |
subBlockType | ArtificialWorld::SubBlock | protected
~SubBlock(void) | ArtificialWorld::SubBlock | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • SubBlockAnimation
ArtificialWorld::SubBlockAnimation Member List

This is the complete list of members for ArtificialWorld::SubBlockAnimation, including all inherited members.

AddAnimationPoint(AnimationPoint newPoint) | ArtificialWorld::SubBlockAnimation | inline
animationPoints | ArtificialWorld::SubBlockAnimation | protected
animationType | ArtificialWorld::SubBlockAnimation | protected
ClearAnimation(void) | ArtificialWorld::SubBlockAnimation | inline
ClearAnimationPoints(void) | ArtificialWorld::SubBlockAnimation | inline
GetAnimationPoint(int index) | ArtificialWorld::SubBlockAnimation | inline
GetAnimationType(void) | ArtificialWorld::SubBlockAnimation | inline
GetInterpolation(void) | ArtificialWorld::SubBlockAnimation | inline
GetLoopType(void) | ArtificialWorld::SubBlockAnimation | inline
GetTimePerLoop(void) | ArtificialWorld::SubBlockAnimation | inline
interpolation | ArtificialWorld::SubBlockAnimation | protected
looping | ArtificialWorld::SubBlockAnimation | protected
NumberOfAnimantionPoints(void) | ArtificialWorld::SubBlockAnimation | inline
SetAnimationType(unsigned int newType) | ArtificialWorld::SubBlockAnimation | inline
SetInterpolation(AnimationInterpolationType newInterpolation) | ArtificialWorld::SubBlockAnimation | inline
SetLoopType(AnimationLoopType newLoop) | ArtificialWorld::SubBlockAnimation | inline
SetTimePerLoop(int time) | ArtificialWorld::SubBlockAnimation | inline
SubBlockAnimation() | ArtificialWorld::SubBlockAnimation | inline
timeForLoop | ArtificialWorld::SubBlockAnimation | protected
~SubBlockAnimation() | ArtificialWorld::SubBlockAnimation | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ArtificialWorld
  • WorldBuilder
ArtificialWorld::WorldBuilder Member List

This is the complete list of members for ArtificialWorld::WorldBuilder, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
GetRootObjectID(void) | ArtificialWorld::WorldBuilder | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(void) | ArtificialWorld::WorldBuilder | inline
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | ArtificialWorld::WorldBuilder | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ArtificialWorld::WorldBuilder | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | ArtificialWorld::WorldBuilder | inlinevirtual
updated | vrecko::Ability | protected
WorldBuilder() | ArtificialWorld::WorldBuilder |
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~WorldBuilder() | ArtificialWorld::WorldBuilder | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BCLoaderErrorHandler Member List

This is the complete list of members for BCLoaderErrorHandler, including all inherited members.

BCLoaderErrorHandler() | BCLoaderErrorHandler |
getSawErrors() const | BCLoaderErrorHandler | inline
handleError(const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError) | BCLoaderErrorHandler |
resetErrors() | BCLoaderErrorHandler |
~BCLoaderErrorHandler() | BCLoaderErrorHandler |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BasicPreloaderHeuristic Member List

This is the complete list of members for BasicPreloaderHeuristic, including all inherited members.

BasicPreloaderHeuristic() | BasicPreloaderHeuristic | inline
GetObjectsToPreload(void) | PreloaderHeuristic | inlinevirtual
objectsToPreload | PreloaderHeuristic | protected
Restart(void) | BasicPreloaderHeuristic | inlinevirtual
rootBlockUpdater | PreloaderHeuristic | protected
SearchFinnished(void) | PreloaderHeuristic | inlinevirtual
searchFinnished | PreloaderHeuristic | protected
SetWorldRoot(BlockUpdater *_rootBlockUpdater) | PreloaderHeuristic | inline
Update(void) | BasicPreloaderHeuristic | virtual
~PreloaderHeuristic() | PreloaderHeuristic | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BehindObstacleExp_wT Member List

This is the complete list of members for BehindObstacleExp_wT, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BehindObstacleExp_wT() | BehindObstacleExp_wT |
checkLocation(int scene_id) | BehindObstacleExp_wT | protected
clean(void) | vrecko::Ability | inlinevirtual
createScenes(void) | BehindObstacleExp_wT | protected
current_method | BehindObstacleExp_wT | protected
current_state | BehindObstacleExp_wT | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dynamics_used | BehindObstacleExp_wT | protected
end_tick | BehindObstacleExp_wT | protected
experiment_description | BehindObstacleExp_wT | protected
experiment_map | BehindObstacleExp_wT | protected
final_object_position | BehindObstacleExp_wT | protected
final_object_rotation | BehindObstacleExp_wT | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first_enter | BehindObstacleExp_wT | protected
font_size | BehindObstacleExp_wT | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInfoString(void) | BehindObstacleExp_wT | protected
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
grasp_count | BehindObstacleExp_wT | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initScene(int scene_id) | BehindObstacleExp_wT | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
internal_state | BehindObstacleExp_wT | protected
isUpdated(void) | vrecko::Ability |
large_projection | BehindObstacleExp_wT | protected
last_method | BehindObstacleExp_wT | protected
lefthand_id | BehindObstacleExp_wT | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | BehindObstacleExp_wT | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
method_board | BehindObstacleExp_wT | protected
method_desc | BehindObstacleExp_wT | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | BehindObstacleExp_wT | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pAvatarManipulator | BehindObstacleExp_wT | protected
pCenterObjectManipulator | BehindObstacleExp_wT | protected
pChangeOfVisibility | BehindObstacleExp_wT | protected
pCube1 | BehindObstacleExp_wT | protected
pCube2 | BehindObstacleExp_wT | protected
pCube3 | BehindObstacleExp_wT | protected
pCuttingPlane | BehindObstacleExp_wT | protected
pCuttingPlane2 | BehindObstacleExp_wT | protected
pCuttingPlaneEO | BehindObstacleExp_wT | protected
pCuttingPlaneEO2 | BehindObstacleExp_wT | protected
pEOAvatar | BehindObstacleExp_wT | protected
pFloor | BehindObstacleExp_wT | protected
pHeadManipulator | BehindObstacleExp_wT | protected
pHMDHeadManipulator | BehindObstacleExp_wT | protected
PinList typedef | vrecko::BaseClass | protected
pLeftHand | BehindObstacleExp_wT | protected
pManipulator | BehindObstacleExp_wT | protected
pMappingFunctions | BehindObstacleExp_wT | protected
pMirror1 | BehindObstacleExp_wT | protected
pMirror2 | BehindObstacleExp_wT | protected
pMirror3 | BehindObstacleExp_wT | protected
pMirrorEO1 | BehindObstacleExp_wT | protected
pMirrorEO2 | BehindObstacleExp_wT | protected
pMirrorEO3 | BehindObstacleExp_wT | protected
pObstacle1 | BehindObstacleExp_wT | protected
pObstacle10 | BehindObstacleExp_wT | protected
pObstacle11 | BehindObstacleExp_wT | protected
pObstacle12 | BehindObstacleExp_wT | protected
pObstacle13 | BehindObstacleExp_wT | protected
pObstacle14 | BehindObstacleExp_wT | protected
pObstacle15 | BehindObstacleExp_wT | protected
pObstacle16 | BehindObstacleExp_wT | protected
pObstacle17 | BehindObstacleExp_wT | protected
pObstacle18 | BehindObstacleExp_wT | protected
pObstacle19 | BehindObstacleExp_wT | protected
pObstacle2 | BehindObstacleExp_wT | protected
pObstacle20 | BehindObstacleExp_wT | protected
pObstacle3 | BehindObstacleExp_wT | protected
pObstacle4 | BehindObstacleExp_wT | protected
pObstacle5 | BehindObstacleExp_wT | protected
pObstacle6 | BehindObstacleExp_wT | protected
pObstacle7 | BehindObstacleExp_wT | protected
pObstacle8 | BehindObstacleExp_wT | protected
pObstacle9 | BehindObstacleExp_wT | protected
postInitialize(void) | BehindObstacleExp_wT | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | BehindObstacleExp_wT | virtual
pRightHand | BehindObstacleExp_wT | protected
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | BehindObstacleExp_wT |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pScene | BehindObstacleExp_wT | protected
pTempl | BehindObstacleExp_wT | protected
pWIM | BehindObstacleExp_wT | protected
pWIMEO | BehindObstacleExp_wT | protected
remaining_tests | BehindObstacleExp_wT | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetView(void) | BehindObstacleExp_wT | protected
result_file | BehindObstacleExp_wT | protected
righthand_id | BehindObstacleExp_wT | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | BehindObstacleExp_wT | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAllBindingForMethod(int method_id) | BehindObstacleExp_wT | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setScene(int scene_id) | BehindObstacleExp_wT | protected
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
start_tick | BehindObstacleExp_wT | protected
stereoscopic | BehindObstacleExp_wT | protected
test_counter | BehindObstacleExp_wT | protected
text_geode | BehindObstacleExp_wT | protected
text_material | BehindObstacleExp_wT | protected
text_state | BehindObstacleExp_wT | protected
texture_font | BehindObstacleExp_wT | protected
timer | BehindObstacleExp_wT | protected
timer_board | BehindObstacleExp_wT | protected
transp | BehindObstacleExp_wT | protected
two_handed | BehindObstacleExp_wT | protected
update(void) | BehindObstacleExp_wT | virtual
updated | vrecko::Ability | protected
user_name | BehindObstacleExp_wT | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BehindObstacleExp_wT() | BehindObstacleExp_wT |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BehindObstacleExperiment Member List

This is the complete list of members for BehindObstacleExperiment, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BehindObstacleExperiment() | BehindObstacleExperiment |
checkLocation(int scene_id) | BehindObstacleExperiment | protected
clean(void) | vrecko::Ability | inlinevirtual
createScenes(void) | BehindObstacleExperiment | protected
current_method | BehindObstacleExperiment | protected
current_state | BehindObstacleExperiment | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dynamics_used | BehindObstacleExperiment | protected
end_tick | BehindObstacleExperiment | protected
experiment_description | BehindObstacleExperiment | protected
experiment_map | BehindObstacleExperiment | protected
final_object_position | BehindObstacleExperiment | protected
final_object_rotation | BehindObstacleExperiment | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first_enter | BehindObstacleExperiment | protected
font_size | BehindObstacleExperiment | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInfoString(void) | BehindObstacleExperiment | protected
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
grasp_count | BehindObstacleExperiment | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initScene(int scene_id) | BehindObstacleExperiment | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
internal_state | BehindObstacleExperiment | protected
isUpdated(void) | vrecko::Ability |
large_projection | BehindObstacleExperiment | protected
last_method | BehindObstacleExperiment | protected
lefthand_id | BehindObstacleExperiment | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | BehindObstacleExperiment | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
method_board | BehindObstacleExperiment | protected
method_desc | BehindObstacleExperiment | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | BehindObstacleExperiment | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pAvatarManipulator | BehindObstacleExperiment | protected
pCenterObjectManipulator | BehindObstacleExperiment | protected
pChangeOfVisibility | BehindObstacleExperiment | protected
pCube1 | BehindObstacleExperiment | protected
pCube2 | BehindObstacleExperiment | protected
pCube3 | BehindObstacleExperiment | protected
pCuttingPlane | BehindObstacleExperiment | protected
pCuttingPlane2 | BehindObstacleExperiment | protected
pCuttingPlaneEO | BehindObstacleExperiment | protected
pCuttingPlaneEO2 | BehindObstacleExperiment | protected
pEOAvatar | BehindObstacleExperiment | protected
pFloor | BehindObstacleExperiment | protected
pHeadManipulator | BehindObstacleExperiment | protected
pHMDHeadManipulator | BehindObstacleExperiment | protected
PinList typedef | vrecko::BaseClass | protected
pLeftHand | BehindObstacleExperiment | protected
pManipulator | BehindObstacleExperiment | protected
pMappingFunctions | BehindObstacleExperiment | protected
pMirror1 | BehindObstacleExperiment | protected
pMirror2 | BehindObstacleExperiment | protected
pMirror3 | BehindObstacleExperiment | protected
pMirrorEO1 | BehindObstacleExperiment | protected
pMirrorEO2 | BehindObstacleExperiment | protected
pMirrorEO3 | BehindObstacleExperiment | protected
pObstacle1 | BehindObstacleExperiment | protected
pObstacle2 | BehindObstacleExperiment | protected
pObstacle3 | BehindObstacleExperiment | protected
pObstacle4 | BehindObstacleExperiment | protected
postInitialize(void) | BehindObstacleExperiment | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | BehindObstacleExperiment | virtual
pRightHand | BehindObstacleExperiment | protected
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | BehindObstacleExperiment |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pTempl | BehindObstacleExperiment | protected
pWIM | BehindObstacleExperiment | protected
pWIMEO | BehindObstacleExperiment | protected
remaining_tests | BehindObstacleExperiment | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetView(void) | BehindObstacleExperiment | protected
result_file | BehindObstacleExperiment | protected
righthand_id | BehindObstacleExperiment | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | BehindObstacleExperiment | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAllBindingForMethod(int method_id) | BehindObstacleExperiment | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setScene(int scene_id) | BehindObstacleExperiment | protected
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
start_tick | BehindObstacleExperiment | protected
stereoscopic | BehindObstacleExperiment | protected
test_counter | BehindObstacleExperiment | protected
text_geode | BehindObstacleExperiment | protected
text_material | BehindObstacleExperiment | protected
text_state | BehindObstacleExperiment | protected
texture_font | BehindObstacleExperiment | protected
timer | BehindObstacleExperiment | protected
timer_board | BehindObstacleExperiment | protected
transp | BehindObstacleExperiment | protected
two_handed | BehindObstacleExperiment | protected
update(void) | BehindObstacleExperiment | virtual
updated | vrecko::Ability | protected
user_name | BehindObstacleExperiment | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BehindObstacleExperiment() | BehindObstacleExperiment |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BinomialHeap< _NodeClass, _keyType > Member List

This is the complete list of members for BinomialHeap< _NodeClass, _keyType >, including all inherited members.

BinomialHeap(void) | BinomialHeap< _NodeClass, _keyType > |
DecreaseKey(_NodeClass *node, _keyType value) | BinomialHeap< _NodeClass, _keyType > | virtual
Delete(_NodeClass *node) | BinomialHeap< _NodeClass, _keyType > | virtual
ExtractMin(void) | BinomialHeap< _NodeClass, _keyType > | virtual
FreeAllNodes() | BinomialHeap< _NodeClass, _keyType > | virtual
FreeNodeSimple(_NodeClass *node) | BinomialHeap< _NodeClass, _keyType > | protected
GetMin(void) | BinomialHeap< _NodeClass, _keyType > | virtual
head | BinomialHeap< _NodeClass, _keyType > | protected
Insert(_NodeClass *node) | BinomialHeap< _NodeClass, _keyType > | virtual
IsEmpty() | BinomialHeap< _NodeClass, _keyType > | inlinevirtual
Link(_NodeClass *root1, _NodeClass *root2) | BinomialHeap< _NodeClass, _keyType > | inlineprotected
Merge(BinomialHeap< _NodeClass, _keyType > *heap) | BinomialHeap< _NodeClass, _keyType > | protected
Union(BinomialHeap< _NodeClass, _keyType > *heap) | BinomialHeap< _NodeClass, _keyType > | virtual
~BinomialHeap(void) | BinomialHeap< _NodeClass, _keyType > |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BinomialHeap
  • BinomialHeapNode
BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode Member List

This is the complete list of members for BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode, including all inherited members.

child | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode |
degree | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode |
key | GenericHeap< _NodeClass, _keyType >::GenericHeapNode |
parent | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode |
sibling | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode |
Swap(void *node) | BinomialHeap< _NodeClass, _keyType >::BinomialHeapNode | virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
BufferedSpline Member List

This is the complete list of members for BufferedSpline, including all inherited members.

_array | BufferedSpline | protected
_closed | BufferedSpline | protected
_lastIndex | BufferedSpline | protected
_minDistance | BufferedSpline | protected
BufferedSpline() | BufferedSpline |
BufferedSpline(const Vec3ArrayPtr sampleArray) | BufferedSpline |
getVertexArray() const | BufferedSpline | inline
isClosed() | BufferedSpline | inlinevirtual
META_DAObject(BufferedSpline,"Buffered Spline") virtual Vec3ArrayPtr getPoints() | BufferedSpline |
setVertexArray(const Vec3ArrayPtr array) | BufferedSpline | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Cache Member List

This is the complete list of members for Cache, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
AddObserver() | AddObserver | inline
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
AddUpdate(string modelFilename, ModelType modelType) | Cache | virtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
Cache() | Cache | inline
clean(void) | vrecko::Ability | inlinevirtual
CreatePreloader(BlockUpdater *rootBlockUpdater) | Cache | inline
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
DeleteObserver() | DeleteObserver | inline
DeletePreloader(void) | Cache | inline
DeleteUpdate(osg::ref_ptr< EnvironmentObject > deletingObject, int num, ModelType modelType) | Cache | virtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
GetObserver() | GetObserver | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GetUpdate(string modelFilename, int num, ModelType modelType) | Cache | virtual
init(bool useTime, unsigned long time, bool useDistance, unsigned long distance, unsigned long update_time) | Cache | inline
initialize(void) | Cache |
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | Cache | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | Cache | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Cache(void) | Cache |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CacheInfo Member List

This is the complete list of members for CacheInfo, including all inherited members.

CacheInfo() | CacheInfo | inline
CacheInfo(osg::ref_ptr< EnvironmentObject > _eo, osg::Vec3 _position, osg::Timer_t _timestamp, ModelType _modelType) | CacheInfo | inline
eo | CacheInfo |
modelType | CacheInfo |
operator!=(const CacheInfo &ci2) const | CacheInfo | inline
operator==(const CacheInfo &ci2) const | CacheInfo | inline
position | CacheInfo |
timestamp | CacheInfo |
~CacheInfo() | CacheInfo | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarControlUnit
CarSim::CarControlUnit Member List

This is the complete list of members for CarSim::CarControlUnit, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
CarControlUnit() | CarSim::CarControlUnit |
CarControlUnit(const unsigned int startRoad, const unsigned int stopRoad, const bool startDirection, const bool stopDirection, const float startEdge, const float stopEdge, const float startOffset, const float stopOffset, const float recVelOnFstJunc, const unsigned int fstJuncTurn, Ability *const pRoadsState, Ability *const pCEU, const std::vector< unsigned int > *const pPath) | CarSim::CarControlUnit |
checkInputXMLParameters() | CarSim::CarControlUnit | protected
clean(void) | vrecko::Ability | inlinevirtual
computeRecVelOnFstJunc() | CarSim::CarControlUnit | protected
computeShortestPath() | CarSim::CarControlUnit | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
errorOccuredInInit | CarSim::CarControlUnit | protected
figureOutFirstJuncTurn() | CarSim::CarControlUnit | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
gen | CarSim::CarControlUnit | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getTimeFromLastUpdate() | CarSim::CarControlUnit | protected
init() | CarSim::CarControlUnit | protected
initBool | CarSim::CarControlUnit | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initPositionAndDirection() | CarSim::CarControlUnit | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
lastTick | CarSim::CarControlUnit | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | CarSim::CarControlUnit | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
nextJuncTurn | CarSim::CarControlUnit | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
params | CarSim::CarControlUnit | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | CarSim::CarControlUnit | virtual
priority | vrecko::BaseClass | protected
pRoadsState | CarSim::CarControlUnit | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
quitAfterError() | CarSim::CarControlUnit | protected
recVelocityOnJunc | CarSim::CarControlUnit | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBlinkers(Ability *const pCEU, const unsigned int blinkLightState, const bool isEmergency) | CarSim::CarControlUnit | protected
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
startDirection | CarSim::CarControlUnit | protected
startRoad | CarSim::CarControlUnit | protected
stopDirection | CarSim::CarControlUnit | protected
stopRoad | CarSim::CarControlUnit | protected
timeWaiting | CarSim::CarControlUnit | protected
update(void) | CarSim::CarControlUnit | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CarControlUnit() | CarSim::CarControlUnit |
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarExecutionUnit
CarSim::CarExecutionUnit Member List

This is the complete list of members for CarSim::CarExecutionUnit, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
blink(const float lastFrameLength) | CarSim::CarExecutionUnit | protected
brakeLightState | CarSim::CarExecutionUnit | protected
CarExecutionUnit() | CarSim::CarExecutionUnit |
CarExecutionUnit(const CarSize &carSize, const float maxSpeed, const float minSpeed, const float maxAcc, const float minAcc, const float maxDispWheelAngle, std::vector< osg::MatrixTransform * > *const pWheelsVec, const float wheelR, Lights *const pLights, const osg::Vec3 &carDirection, const osg::Vec3 &carNormal, const osg::Vec3 &carPositionOnRoad, vrecko::EnvironmentObject *const pFutureCarEOownerToSet) | CarSim::CarExecutionUnit |
carState | CarSim::CarExecutionUnit | protected
checkXMLparameters() | CarSim::CarExecutionUnit | protected
clean(void) | vrecko::Ability | inlinevirtual
computeCarState(const float lastFrameLength) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InAcc, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InWheelAngle, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InStop, vrecko::MessageVoid) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InUpdate, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InInitNormal, vrecko::MessageVec3) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InInitDirection, vrecko::MessageVec3) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InInitPosition, vrecko::MessageVec3) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InSetCarNormal, vrecko::MessageVec3) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InPushCarInNormalDir, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InPushCarInDirectionCrossNormalDir, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InSetBlinker, vrecko::MessageUnsignedInt) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InShow, vrecko::MessageVoid) | CarSim::CarExecutionUnit | protected
DECLARE_INPUT(InHide, vrecko::MessageVoid) | CarSim::CarExecutionUnit | protected
DECLARE_REQUEST_INPUT(InGetCarState, vrecko::MessageVoid, MessageCarStatePtr) | CarSim::CarExecutionUnit | protected
DECLARE_REQUEST_INPUT(InGetCarLength, vrecko::MessageVoid, vrecko::MessageFloat) | CarSim::CarExecutionUnit | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
frontLightState | CarSim::CarExecutionUnit | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initDirection(const osg::Vec3 &dir) | CarSim::CarExecutionUnit | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initNormal(const osg::Vec3 &normal) | CarSim::CarExecutionUnit | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isGenCar | CarSim::CarExecutionUnit | protected
isUpdated(void) | vrecko::Ability |
loadGeometryParts() | CarSim::CarExecutionUnit | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | CarSim::CarExecutionUnit | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
maxDispWheelAngle | CarSim::CarExecutionUnit | protected
maxSpeed | CarSim::CarExecutionUnit | protected
minSpeed | CarSim::CarExecutionUnit | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pGeometryPartsPath | CarSim::CarExecutionUnit | protected
PinList typedef | vrecko::BaseClass | protected
pLeftWheelsPosVec | CarSim::CarExecutionUnit | protected
pLights | CarSim::CarExecutionUnit | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | CarSim::CarExecutionUnit | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pWheelsVec | CarSim::CarExecutionUnit | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchLight(const unsigned int lightType, const unsigned int lightState) | CarSim::CarExecutionUnit | protected
timeFromLastBlinkStart | CarSim::CarExecutionUnit | protected
update(void) | CarSim::CarExecutionUnit | virtual
updated | vrecko::Ability | protected
vPrevious | CarSim::CarExecutionUnit | protected
wheelDisplayAngleAroundNormal | CarSim::CarExecutionUnit | protected
wheelR | CarSim::CarExecutionUnit | protected
wheelRotateAngle | CarSim::CarExecutionUnit | protected
wheelsInitMatrixVec | CarSim::CarExecutionUnit | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CarExecutionUnit() | CarSim::CarExecutionUnit |
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarPartsNodeCache
CarSim::CarPartsNodeCache Member List

This is the complete list of members for CarSim::CarPartsNodeCache, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
CarPartsNodeCache() | CarSim::CarPartsNodeCache |
carPartsPathNodeMap | CarSim::CarPartsNodeCache | protected
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_INPUT(InGetCarPartNode, vrecko::MessageString, vrecko::MessageNode) | CarSim::CarPartsNodeCache | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CarPartsNodeCache() | CarSim::CarPartsNodeCache |
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEdge
CarSim::MessageCarEdge Member List

This is the complete list of members for CarSim::MessageCarEdge, including all inherited members.

car | CarSim::MessageCarEdge |
edge | CarSim::MessageCarEdge |
getMessageId() | CarSim::MessageCarEdge | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageCarEdge() | CarSim::MessageCarEdge | inline
MessageCarEdge(unsigned int newCar, unsigned int newEdge) | CarSim::MessageCarEdge | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEdgeData
CarSim::MessageCarEdgeData Member List

This is the complete list of members for CarSim::MessageCarEdgeData, including all inherited members.

data | CarSim::MessageCarEdgeData |
getMessageId() | CarSim::MessageCarEdgeData | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageCarEdgeData() | CarSim::MessageCarEdgeData | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarEnvirons
CarSim::MessageCarEnvirons Member List

This is the complete list of members for CarSim::MessageCarEnvirons, including all inherited members.

data | CarSim::MessageCarEnvirons |
getMessageId() | CarSim::MessageCarEnvirons | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageCarEnvirons() | CarSim::MessageCarEnvirons | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarSimParameters
CarSim::MessageCarSimParameters Member List

This is the complete list of members for CarSim::MessageCarSimParameters, including all inherited members.

data | CarSim::MessageCarSimParameters |
getMessageId() | CarSim::MessageCarSimParameters | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageCarSimParameters() | CarSim::MessageCarSimParameters | inline
MessageCarSimParameters(Parameters &paramsToCopy) | CarSim::MessageCarSimParameters | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageCarStatePtr
CarSim::MessageCarStatePtr Member List

This is the complete list of members for CarSim::MessageCarStatePtr, including all inherited members.

data | CarSim::MessageCarStatePtr |
getMessageId() | CarSim::MessageCarStatePtr | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageCarStatePtr() | CarSim::MessageCarStatePtr | inline
MessageCarStatePtr(CarState *csToPointAt) | CarSim::MessageCarStatePtr | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageEdgeOffset
CarSim::MessageEdgeOffset Member List

This is the complete list of members for CarSim::MessageEdgeOffset, including all inherited members.

edge | CarSim::MessageEdgeOffset |
getMessageId() | CarSim::MessageEdgeOffset | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageEdgeOffset() | CarSim::MessageEdgeOffset | inline
MessageEdgeOffset(unsigned int theEdge, float theOffset) | CarSim::MessageEdgeOffset | inline
offset | CarSim::MessageEdgeOffset |
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageFirst3Juncs
CarSim::MessageFirst3Juncs Member List

This is the complete list of members for CarSim::MessageFirst3Juncs, including all inherited members.

data | CarSim::MessageFirst3Juncs |
getMessageId() | CarSim::MessageFirst3Juncs | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageFirst3Juncs() | CarSim::MessageFirst3Juncs | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageRoadAndDir
CarSim::MessageRoadAndDir Member List

This is the complete list of members for CarSim::MessageRoadAndDir, including all inherited members.

direction | CarSim::MessageRoadAndDir |
getMessageId() | CarSim::MessageRoadAndDir | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageRoadAndDir() | CarSim::MessageRoadAndDir | inline
MessageRoadAndDir(unsigned int newRoad, bool newDir) | CarSim::MessageRoadAndDir | inline
road | CarSim::MessageRoadAndDir |
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageStartStopDestination
CarSim::MessageStartStopDestination Member List

This is the complete list of members for CarSim::MessageStartStopDestination, including all inherited members.

data | CarSim::MessageStartStopDestination |
getMessageId() | CarSim::MessageStartStopDestination | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageStartStopDestination() | CarSim::MessageStartStopDestination | inline
MessageStartStopDestination(StartStopDestination &dataToCopy) | CarSim::MessageStartStopDestination | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • MessageVectorUnsignedInt
CarSim::MessageVectorUnsignedInt Member List

This is the complete list of members for CarSim::MessageVectorUnsignedInt, including all inherited members.

data | CarSim::MessageVectorUnsignedInt |
getMessageId() | CarSim::MessageVectorUnsignedInt | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageVectorUnsignedInt() | CarSim::MessageVectorUnsignedInt | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Remover
CarSim::Remover Member List

This is the complete list of members for CarSim::Remover, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
carsToRemove | CarSim::Remover | protected
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(InCarToRemove, vrecko::MessageUnsignedInt) | CarSim::Remover | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | CarSim::Remover | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | CarSim::Remover |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
Remover() | CarSim::Remover |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | CarSim::Remover | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Remover() | CarSim::Remover | inline
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • RoadsState
CarSim::RoadsState Member List

This is the complete list of members for CarSim::RoadsState, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addEdgeAsEO(const unsigned int edgeId) | CarSim::RoadsState | protected
addEdgesAsEO() | CarSim::RoadsState | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addTerminatorEdges(unsigned int fstSinglePolyPoint, unsigned int sndSinglePolyPoint, unsigned int fstEdgeId, unsigned int sndEdgeId, const unsigned int juncId) | CarSim::RoadsState | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bAttemptToLoadRoadsFromArtificalWorld | CarSim::RoadsState | protected
bDrawRoads | CarSim::RoadsState | protected
bGenShortestPaths | CarSim::RoadsState | protected
checkEdgesFromToAndTheirPolygonPoints() | CarSim::RoadsState | protected
clean(void) | vrecko::Ability | inlinevirtual
computeEdgesAttributes() | CarSim::RoadsState | protected
computeJuncInOutEdgesAttr() | CarSim::RoadsState | protected
computeJunctionsEdges() | CarSim::RoadsState | protected
computeRecVelocityOnJunc(float &recVel, const unsigned int juncId, const unsigned int inEdge, const unsigned int outEdge) | CarSim::RoadsState | protected
createTrafficLights(void) | CarSim::RoadsState | protected
dataPath | CarSim::RoadsState | protected
DECLARE_INPUT(InUnregCarForEdge, MessageCarEdge) | CarSim::RoadsState | protected
DECLARE_INPUT(InAddForEdgeRegisteredCarToPutAsideCars, MessageCarEdge) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetReady, MessageVoid, MessageBool) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetDataPath, MessageVoid, MessageString) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetEdgeAbsPos, MessageEdgeOffset, MessageVec3) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetEdgeOutInVec, MessageUnsignedInt, MessageVec3) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetEdgeNormal, MessageUnsignedInt, MessageVec3) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InFindShortestPath, MessageStartStopDestination, MessageVectorUnsignedInt) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InCheckCarStopPosition, MessageCarEdgeData, MessageBool) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetStartOrStopEdgeFromRoadAndDirection, MessageRoadAndDir, MessageUnsignedInt) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InRegCarForEdge, MessageCarEdgeData, MessageBool) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetRecVelOnJunc, MessageFirst3Juncs, MessageFloat) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetTurnOnJunc, MessageFirst3Juncs, MessageUnsignedInt) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InIsCarFstPutAsideOnEdge, MessageCarEdge, MessageBool) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InRegisterPutAsideCarForEdge, MessageCarEdgeData, MessageBool) | CarSim::RoadsState | protected
DECLARE_REQUEST_INPUT(InGetCarEnvirons, MessageCarSimParameters, MessageCarEnvirons) | CarSim::RoadsState | protected
decreaseLockCountForPrevEdge(const unsigned int edgeId, const unsigned int lastJuncId, const unsigned int nextJuncId, const unsigned int nextNextJuncId, const bool mergedEdgeSkiped, const unsigned int carId) | CarSim::RoadsState | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
distFromPointToLine(const osg::Vec3 &linePoint, const osg::Vec3 &lineVec, const osg::Vec3 &point) | CarSim::RoadsState | protected
distPointToPlane(float &dist, const osg::Vec3 &point, const osg::Vec3 &planePoint, const osg::Vec3 &planeNormal) | CarSim::RoadsState | protected
edges | CarSim::RoadsState | protected
findJuncsSinglePolyPoints() | CarSim::RoadsState | protected
findPath(std::vector< unsigned int > *const pResultPath, const unsigned int startEdge) | CarSim::RoadsState | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
findShortestPath(std::vector< unsigned int > *const pResultPath, const StartStopDestination *const pStartStopDestination) | CarSim::RoadsState | protected
generateCars(const unsigned int numOfGenCars, const bool genShortestPath) | CarSim::RoadsState | protected
getAbsPos(osg::Vec3 &resultPos, const unsigned int edge, const float offset) | CarSim::RoadsState | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCarEdgeId(unsigned int &carEdgeId, const unsigned int lastCarEdgeId, const osg::Vec3 &bottomCarPosition, const unsigned int juncId, const unsigned int outEdgeId) | CarSim::RoadsState | protected
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getNextCarDistAndVel(float &nextCarDist, float &nextCarVel, const unsigned int carId, const unsigned int edgeId) | CarSim::RoadsState | protected
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getTurnOnJunc(unsigned int &turnOnJunc, const unsigned int juncId, const unsigned int inEdge, const unsigned int outEdge) | CarSim::RoadsState | protected
herFerDeriv(osg::Vec3 &result, const float d, const osg::Vec3 &P1, const osg::Vec3 &P4, const osg::Vec3 &R1, const osg::Vec3 &R4) | CarSim::RoadsState | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
interPointOfLineAndPerpendicularPlane(osg::Vec3 &inter, const osg::Vec3 &linePoint, const osg::Vec3 &lineVec, const osg::Vec3 &planePoint) | CarSim::RoadsState | protected
iNumGenCars | CarSim::RoadsState | protected
invalidRefToJuncOrPolygPoint | CarSim::RoadsState | protected
isCarRegForEdge(const unsigned int carId, const unsigned int edgeId) | CarSim::RoadsState | protected
isCarStopPositionRight(const unsigned int stopEdgeId, const float stopOffset, const float carLength) | CarSim::RoadsState | protected
isDeadlock(const unsigned int juncId) | CarSim::RoadsState | protected
isFreeSpaceForCarGroupOnEdge(const unsigned int edgeId, const float fstCarInGroupLength, unsigned int carCount) | CarSim::RoadsState | protected
isUpdated(void) | vrecko::Ability |
isValidJuncWithTLs(unsigned int juncId) | CarSim::RoadsState | protected
junctions | CarSim::RoadsState | protected
linesInter2D(osg::Vec2 &result, const osg::Vec2 &line1Point, const osg::Vec2 &line1Vec, const osg::Vec2 &line2Point, const osg::Vec2 &line2Vec) | CarSim::RoadsState | protected
loadJuncPolyRoad(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode const *const pRoadNetNode) | CarSim::RoadsState | protected
loadJunction(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes) | CarSim::RoadsState | protected
loadPolygonPoint(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes) | CarSim::RoadsState | protected
loadRoad(XERCES_CPP_NAMESPACE_QUALIFIER DOMNamedNodeMap const *const pAttributes) | CarSim::RoadsState | protected
loadTLparameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *const pTLparametersNode) | CarSim::RoadsState | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | CarSim::RoadsState | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lockJuncsEdgesForNewCar(const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const bool isLastCar, const bool isStopedCar, const float carLength, const unsigned int carId) | CarSim::RoadsState | protected
maxJuncId | CarSim::RoadsState | protected
maxPolygonPointId | CarSim::RoadsState | protected
mergeCloseJunctions() | CarSim::RoadsState | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
numOfNonTermEdges | CarSim::RoadsState | protected
orderJunctionsEdges() | CarSim::RoadsState | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pCarPartsNodeCache | CarSim::RoadsState | protected
PinList typedef | vrecko::BaseClass | protected
pointInHalfSpace(const osg::Vec3 &point, const osg::Vec3 &halfSpacePoint, const osg::Vec3 &halfSpaceVec) | CarSim::RoadsState | protected
polygonPoints | CarSim::RoadsState | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | CarSim::RoadsState | virtual
pRemover | CarSim::RoadsState | protected
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | CarSim::RoadsState |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &input_name, void *value) | CarSim::RoadsState |
vrecko::Ability::processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pTLcolumnModel | CarSim::RoadsState | protected
pTLorangeModel | CarSim::RoadsState | protected
regCarForEdge(const unsigned int carId, const unsigned int startEdgeId, const float startOffset, const float carLength, const bool showErrors) | CarSim::RoadsState | protected
regFstCarForEdge(const unsigned int carId, const unsigned int edgeId, const float offset, const float carLength, const float vel) | CarSim::RoadsState | protected
regIncomingCarToShortEdges(const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const unsigned int carId) | CarSim::RoadsState | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rightHandRule(bool &withDeadlock, const unsigned int inEdge, const unsigned int outEdge, const unsigned int juncId, const bool isCarLastStoped, const unsigned int carId) | CarSim::RoadsState | protected
roads | CarSim::RoadsState | protected
roadsEdges | CarSim::RoadsState | protected
RoadsState() | CarSim::RoadsState |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setStopedIncomingCarToShortEdges(const std::vector< unsigned int > *const pPath, const unsigned int lastJuncInPath, const unsigned int carId) | CarSim::RoadsState | protected
showPoint(const osg::Vec3 &point) | CarSim::RoadsState | protected
tlColorsCenterDist | CarSim::RoadsState | protected
unregCarForEdge(const unsigned int carId, const unsigned int edgeId) | CarSim::RoadsState | protected
unregLastCarForEdge(const unsigned int edgeId) | CarSim::RoadsState | protected
update(void) | CarSim::RoadsState | virtual
updateCarForEdge(const unsigned int carId, const unsigned int edgeId, const float headOffset, const float rearOffset, const float vel) | CarSim::RoadsState | protected
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~RoadsState() | CarSim::RoadsState | inline
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • TLsOnJuncManager
CarSim::TLsOnJuncManager Member List

This is the complete list of members for CarSim::TLsOnJuncManager, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initColorsOnTLs(void) | CarSim::TLsOnJuncManager | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | CarSim::TLsOnJuncManager | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pTLcolorsMTvec | CarSim::TLsOnJuncManager | protected
pTLcolorsVec | CarSim::TLsOnJuncManager | protected
pTLgreenIntervVec | CarSim::TLsOnJuncManager | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
secCount | CarSim::TLsOnJuncManager | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
switchColorsOnTL(void) | CarSim::TLsOnJuncManager | protected
tlIndex | CarSim::TLsOnJuncManager | protected
TLsOnJuncManager() | CarSim::TLsOnJuncManager |
TLsOnJuncManager(std::vector< TLcolorsMT > *const pTLcolorsMTvec, const std::vector< unsigned int *const > *const pTLcolorsVec, const std::vector< unsigned int > *const pTLgreenIntervVec) | CarSim::TLsOnJuncManager |
update(void) | CarSim::TLsOnJuncManager | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~TLsOnJuncManager() | CarSim::TLsOnJuncManager |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CatmullRomInterpolator Member List

This is the complete list of members for CatmullRomInterpolator, including all inherited members.

classDescription() const =0 | Interpolator | pure virtual
className() const =0 | Interpolator | pure virtual
closed | CatmullRomInterpolator |
interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0 | Interpolator | pure virtual
interpolatePoint(const double &t, const osg::Vec3 &p0, const osg::Vec3 &p1, const osg::Vec3 &p2, const osg::Vec3 &p3) | CatmullRomInterpolator |
interpolationSteps | CatmullRomInterpolator |
META_DAObject(CatmullRomInterpolator,"Catmull-Rom Interpolator") virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array | CatmullRomInterpolator |
~Interpolator() | Interpolator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ChessBoard Member List

This is the complete list of members for ChessBoard, including all inherited members.

_first | ChessBoard | protected
a1pos | ChessBoard | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BBishop | ChessBoard | protected
BKing | ChessBoard | protected
BKnight | ChessBoard | protected
black_out_pos | ChessBoard | protected
BPawn | ChessBoard | protected
BQueen | ChessBoard | protected
BRook | ChessBoard | protected
chess_pipe | ChessBoard | protected
ChessBoard() | ChessBoard |
clean(void) | vrecko::Ability | inlinevirtual
color | ChessBoard | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
generate_board | ChessBoard | protected
getAcceptableMessages(void) | ChessBoard | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ChessBoard | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pfd_from | ChessBoard | protected
pfd_to | ChessBoard | protected
pieces_map | ChessBoard | protected
PinList typedef | vrecko::BaseClass | protected
play | ChessBoard | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | ChessBoard |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
square_size | ChessBoard | protected
status | ChessBoard | protected
update(void) | ChessBoard | virtual
updated | vrecko::Ability | protected
wait | ChessBoard | protected
WBishop | ChessBoard | protected
white_out_pos | ChessBoard | protected
WKing | ChessBoard | protected
WKnight | ChessBoard | protected
WPawn | ChessBoard | protected
WQueen | ChessBoard | protected
WRook | ChessBoard | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ChessBoard() | ChessBoard | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ChessPiece Member List

This is the complete list of members for ChessPiece, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
actual_position | ChessPiece | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
chessboard_id | ChessPiece | protected
ChessPiece() | ChessPiece |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
final_position | ChessPiece | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAcceptableMessages(void) | ChessPiece | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ChessPiece | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
move | ChessPiece | protected
move_step | ChessPiece | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | ChessPiece | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
piece_location | ChessPiece | protected
piece_type | ChessPiece | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | ChessPiece | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | ChessPiece |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setLocation(std::string _location) | ChessPiece | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setType(std::string _type) | ChessPiece | inline
update(void) | ChessPiece | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ChessPiece() | ChessPiece | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Cloud Member List

This is the complete list of members for Cloud, including all inherited members.

AddToQueue(Cloud *cloudToUpdate) | Cloud | static
boundingBox | Cloud |
CalculateBoundingBox(void) | Cloud |
Cloud() | Cloud | inline
cloudParticle | Cloud |
ComputeUpRightVectors() | Cloud |
Delete(void) | Cloud |
DestroyLightTexture(void) | Cloud | static
GenerateLightTexture(void) | Cloud | static
InitCloudGeometry(osg::ref_ptr< osg::Geometry > cloudGeometry) | Cloud |
LightCloud(void) | Cloud |
RealizeQueue(void) | Cloud | static
RegularUpdate() | Cloud |
SetCamera(const osg::Vec3f &newCameraPosition, const osg::Vec3f &newCameraView, const osg::Vec3f &newCameraUp) | Cloud | static
SetCloudParticleTexture(osg::ref_ptr< osg::Texture2D > newCloudParticleTexture) | Cloud | inlinestatic
SetLastCam(osg::Vec3f last_cam) | Cloud | inline
SetMaxCloudUpdates(unsigned int max) | Cloud | inlinestatic
SetSceneInfo(const CloudSceneInfo &info) | Cloud | inlinestatic
SetSunLight(SunLight &sun) | Cloud | inlinestatic
SetTranslateErrorTolerance(float tolerance) | Cloud | inlinestatic
SetViewMatrix(const osg::Matrix &newViewMatrix) | Cloud | inlinestatic
SortAway | Cloud |
UpdateCloud() | Cloud |
UpdateCloudColor() | Cloud |
UpdateCloudLotRocScale() | Cloud |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Cloud
  • ParticleAwayComparison
Cloud::ParticleAwayComparison Member List

This is the complete list of members for Cloud::ParticleAwayComparison, including all inherited members.

operator()(CloudParticle particle1, CloudParticle particle2) Cloud::ParticleAwayComparison inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudDataType Member List

This is the complete list of members for CloudDataType, including all inherited members.

getCameraPos(void) | CloudDataType | inline
getCameraUp(void) | CloudDataType | inline
getCameraView(void) | CloudDataType | inline
setCameraData(const osg::Vec3f &cameraPos, const osg::Vec3f &cameraView, const osg::Vec3f &cameraUp) | CloudDataType | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudsManager Member List

This is the complete list of members for CloudsManager, including all inherited members.

clouds | CloudsManager |
CloudsManager() | CloudsManager | inline
Delete(void) | CloudsManager |
flatLayer | CloudsManager |
LoadAndInitiate(void) | CloudsManager |
LoadFromFile(void) | CloudsManager |
properties | CloudsManager |
SaveToFile(void) | CloudsManager |
sceneInfo | CloudsManager |
SetUVCoords(bool singleTexture=false) | CloudsManager |
Update(const osg::Vec3f &cameraPosition, const osg::Vec3f &cameraView, const osg::Vec3f &cameraUp) | CloudsManager |
~CloudsManager() | CloudsManager | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ConstantColorGen Member List

This is the complete list of members for ConstantColorGen, including all inherited members.

_color | ConstantColorGen | protected
_dirty | ConstantColorGen |
arraySize | ConstantColorGen |
assign(arraySize, _color) | ConstantColorGen |
ConstantColorGen() | ConstantColorGen | inline
ConstantColorGen(const osg::Vec4 &color) | ConstantColorGen | inline
getColorValue() const | ConstantColorGen | inline
META_DAObject(ConstantColorGen,"Constant Brush") virtual Vec4ArrayPtr getColors(unsigned int leadSplineSize | ConstantColorGen |
reserve(arraySize) | ConstantColorGen |
result | ConstantColorGen |
result | ConstantColorGen |
setColorValue(const osg::Vec4 &val) | ConstantColorGen | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ConstraintHierarchyMember Member List

This is the complete list of members for ConstraintHierarchyMember, including all inherited members.

ConstraintHierarchyMember() | ConstraintHierarchyMember |
findHierarchyMember(string areaClassStringLookingFor) | ConstraintHierarchyMember |
getAreaClassString() | ConstraintHierarchyMember | inline
isHierarchyAncestorOf(ConstraintHierarchyMember *hierarchyMember) | ConstraintHierarchyMember |
loadXMLFile(const char *xmlFile) | ConstraintHierarchyMember |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | ConstraintHierarchyMember |
setAreaClassString(string areaClassString) | ConstraintHierarchyMember | inline
write(int level=0) | ConstraintHierarchyMember |
~ConstraintHierarchyMember() | ConstraintHierarchyMember | virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CubicInterpolator Member List

This is the complete list of members for CubicInterpolator, including all inherited members.

classDescription() const =0 | Interpolator | pure virtual
className() const =0 | Interpolator | pure virtual
CubicInterpolator(void) | CubicInterpolator |
interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0 | Interpolator | pure virtual
~CubicInterpolator(void) | CubicInterpolator |
~Interpolator() | Interpolator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DAControlPoint Member List

This is the complete list of members for DAControlPoint, including all inherited members.

DAControlPoint(DAControlPointType p_type, osg::Group *p_EOOwner, osg::Vec3 point, osg::Quat orient) | DAControlPoint |
frenetFremeComputed | DAControlPoint |
getBinormal() | DAControlPoint | inline
getCurvature() | DAControlPoint | inline
getNormal() | DAControlPoint | inline
getOrientation() | DAControlPoint | inline
getPosition() | DAControlPoint | inline
getPositionString() | DAControlPoint |
getPriority() | DAControlPoint | inline
getSegmentLength() | DAControlPoint | inline
getSpeed() | DAControlPoint | inline
getTangent() | DAControlPoint | inline
getTorsion() | DAControlPoint | inline
getTvalue() | DAControlPoint | inline
getType() | DAControlPoint | inline
getVisualOwner() | DAControlPoint | inline
setBinormal(osg::Vec3 binrml) | DAControlPoint | inline
setCharacteristics(osg::Vec3 tan, osg::Vec3 norm, osg::Vec3 binorm, double curvature, double torsion) | DAControlPoint |
setNormal(osg::Vec3 nrml) | DAControlPoint | inline
setPosition(osg::Vec3 pos) | DAControlPoint |
setPosition(osg::Vec3f::value_type x, osg::Vec3f::value_type y, osg::Vec3f::value_type z) | DAControlPoint |
setPriority(double prior) | DAControlPoint | inline
setSegmentLength(double length) | DAControlPoint | inline
setSpeed(double spee) | DAControlPoint | inline
setTangent(osg::Vec3 tngt) | DAControlPoint | inline
setTvalue(double tval) | DAControlPoint | inline
setVisibleVisualBox(bool vis) | DAControlPoint | inline
showGizmo(bool show) | DAControlPoint |
~DAControlPoint() | DAControlPoint |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DAGizmo Member List

This is the complete list of members for DAGizmo, including all inherited members.

DAGizmo(osg::Group *p_EOOwner, osg::Vec3 position, osg::Vec3 tangent, osg::Vec3 normal, osg::Vec3 binormal, double radius) | DAGizmo |
getBinormal() | DAGizmo | inline
getNormal() | DAGizmo | inline
hide() | DAGizmo |
isVisible() | DAGizmo | inline
show() | DAGizmo |
~DAGizmo() | DAGizmo |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DASample Member List

This is the complete list of members for DASample, including all inherited members.

DASample() | DASample | inline
DASample(osg::Vec3 p_pos, osg::Quat p_orient) | DASample | inline
orientation | DASample |
position | DASample |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DeleteObserver Member List

This is the complete list of members for DeleteObserver, including all inherited members.

DeleteObserver() | DeleteObserver | inline
DeleteUpdate(osg::ref_ptr< EnvironmentObject > deletingObject, int num, ModelType modelType)=0 | DeleteObserver | pure virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DynTreeNode< _Type > Member List

This is the complete list of members for DynTreeNode< _Type >, including all inherited members.

GetDepth() | DynTreeNode< _Type >
lpChild | DynTreeNode< _Type >
lpNext | DynTreeNode< _Type >
lpParent | DynTreeNode< _Type >
lpPrev | DynTreeNode< _Type >
tree | DynTreeNode< _Type >
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DynamicTree< _Type > Member List

This is the complete list of members for DynamicTree< _Type >, including all inherited members.

AddNode(_Type *lpParent, _Type *lpNode) | DynamicTree< _Type > |
AddNodeLast(_Type *lpParent, _Type *lpNode) | DynamicTree< _Type > |
Clear(bool bCallDelete=false) | DynamicTree< _Type > |
DeleteNode(_Type *lpNode, bool bCallDelete=false) | DynamicTree< _Type > |
dwCount | DynamicTree< _Type > | protected
DynamicTree(void) | DynamicTree< _Type > |
DYNTREE_NODEALLOWED typedef | DynamicTree< _Type > |
DYNTREE_SUBTREEALLOWED typedef | DynamicTree< _Type > |
GetCount(void) | DynamicTree< _Type > | inline
GetRoot(void) | DynamicTree< _Type > | inline
InsertNode(_Type *lpParent, _Type *lpPrevSibling, _Type *lpNode) | DynamicTree< _Type > |
lpRoot | DynamicTree< _Type > | protected
~DynamicTree(void) | DynamicTree< _Type > | virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
DynamicTreeIterator< _Type > Member List

This is the complete list of members for DynamicTreeIterator< _Type >, including all inherited members.

bStarting | DynamicTreeIterator< _Type > | protected
cbNodeAllowed | DynamicTreeIterator< _Type > | protected
cbSubTreeAllowed | DynamicTreeIterator< _Type > | protected
dwFlags | DynamicTreeIterator< _Type > | protected
DynamicTreeIterator(void) | DynamicTreeIterator< _Type > | inline
GetNode(void) | DynamicTreeIterator< _Type > | inline
IsFinished(void) | DynamicTreeIterator< _Type > | inline
IsNodeAllowed(_Type *node) | DynamicTreeIterator< _Type > | inlineprotected
IsSubTreeAllowed(_Type *node) | DynamicTreeIterator< _Type > | inlineprotected
nodePtr | DynamicTreeIterator< _Type > | protected
nodeStart | DynamicTreeIterator< _Type > | protected
operator!=(const DynamicTreeIterator< _Type > &iter1, const DynamicTreeIterator< _Type > &iter2) | DynamicTreeIterator< _Type > | friend
operator++(void) | DynamicTreeIterator< _Type > |
operator++(int) | DynamicTreeIterator< _Type > |
operator==(const DynamicTreeIterator< _Type > &iter) | DynamicTreeIterator< _Type > | inline
Reset(void) | DynamicTreeIterator< _Type > | inline
SetNodeAllowedCallback(typename DynamicTree< _Type >::DYNTREE_NODEALLOWED cb) | DynamicTreeIterator< _Type > | inline
SetSubTreeAllowedCallback(typename DynamicTree< _Type >::DYNTREE_SUBTREEALLOWED cb) | DynamicTreeIterator< _Type > | inline
SetTree(DynamicTree< _Type > *_tree) | DynamicTreeIterator< _Type > | inline
Start(_Type *lpTravStart, unsigned long dwFlags) | DynamicTreeIterator< _Type > |
tree | DynamicTreeIterator< _Type > | protected
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
EOLineSegmentIntersector Member List

This is the complete list of members for EOLineSegmentIntersector, including all inherited members.

enter(const osg::Node &node) | EOLineSegmentIntersector | virtual
EOLineSegmentIntersector(const osg::Vec3d &start, const osg::Vec3d &end) | EOLineSegmentIntersector | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
FibonacciHeap< _NodeClass, _keyType > Member List

This is the complete list of members for FibonacciHeap< _NodeClass, _keyType >, including all inherited members.

CascadingCut(_NodeClass *node) | FibonacciHeap< _NodeClass, _keyType > | protectedvirtual
Consolidate(void) | FibonacciHeap< _NodeClass, _keyType > | protected
Cut(_NodeClass *node1, _NodeClass *node2) | FibonacciHeap< _NodeClass, _keyType > | protectedvirtual
DecreaseKey(_NodeClass *node, _keyType value) | FibonacciHeap< _NodeClass, _keyType > | virtual
Delete(_NodeClass *node) | FibonacciHeap< _NodeClass, _keyType > | virtual
ExtractMin(void) | FibonacciHeap< _NodeClass, _keyType > | virtual
FibonacciHeap(void) | FibonacciHeap< _NodeClass, _keyType > |
FreeAllNodes() | FibonacciHeap< _NodeClass, _keyType > | virtual
FreeNodeSimple(_NodeClass *node) | FibonacciHeap< _NodeClass, _keyType > | protected
GetMin(void) | FibonacciHeap< _NodeClass, _keyType > | virtual
head | FibonacciHeap< _NodeClass, _keyType > | protected
Insert(_NodeClass *node) | FibonacciHeap< _NodeClass, _keyType > | virtual
IsEmpty() | FibonacciHeap< _NodeClass, _keyType > | inlinevirtual
Link(_NodeClass *child, _NodeClass *parent) | FibonacciHeap< _NodeClass, _keyType > | protected
min | FibonacciHeap< _NodeClass, _keyType > | protected
Union(FibonacciHeap< _NodeClass, _keyType > *heap) | FibonacciHeap< _NodeClass, _keyType > | virtual
~FibonacciHeap(void) | FibonacciHeap< _NodeClass, _keyType > |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • FibonacciHeap
  • FibonacciHeapNode
FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode Member List

This is the complete list of members for FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode, including all inherited members.

child | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
degree | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
key | GenericHeap< _NodeClass, _keyType >::GenericHeapNode
left | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
mark | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
parent | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
right | FibonacciHeap< _NodeClass, _keyType >::FibonacciHeapNode
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
FilletSpline Member List

This is the complete list of members for FilletSpline, including all inherited members.

_filletRadius | FilletSpline | protected
_filletSteps | FilletSpline | protected
FilletSpline(double filletRadius, unsigned int filletSteps, SplinePtr decoratedSpline) | FilletSpline |
generateAllFilletPoints(Vec3ArrayPtr result, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3) | FilletSpline | protected
getFilletPoints(osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3, osg::Vec3 &f1, osg::Vec3 &f2) | FilletSpline | protected
META_DAObjectDecorator(_decoratedSpline, FilletSpline,"Fillet Spline") virtual Vec3ArrayPtr getPoints() | FilletSpline |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • Linear
Filter::Linear Member List

This is the complete list of members for Filter::Linear, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
coef1 | Filter::Linear | protected
coef2 | Filter::Linear | protected
coef3 | Filter::Linear | protected
coef4 | Filter::Linear | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
Linear() | Filter::Linear |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | Filter::Linear | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | Filter::Linear | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | Filter::Linear |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | Filter::Linear | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Linear() | Filter::Linear | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • PosNoiseRemover
Filter::PosNoiseRemover Member List

This is the complete list of members for Filter::PosNoiseRemover, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCompareExtrapolatedValue | Filter::PosNoiseRemover | protected
bExtrapolateCorrectValue | Filter::PosNoiseRemover | protected
bOn | Filter::PosNoiseRemover | protected
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(In3, vrecko::MessageVec3) | Filter::PosNoiseRemover | protected
DECLARE_OUTPUT(Out3, vrecko::MessageVec3) | Filter::PosNoiseRemover | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fTolerance | Filter::PosNoiseRemover | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
iCorrectedSamplesCounter | Filter::PosNoiseRemover | protected
iMaxCorrectedSamplesInRow | Filter::PosNoiseRemover | protected
iMaxPastSamples | Filter::PosNoiseRemover | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
lastInput | Filter::PosNoiseRemover | protected
lastResult | Filter::PosNoiseRemover | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | Filter::PosNoiseRemover | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pastSamples | Filter::PosNoiseRemover | protected
PinList typedef | vrecko::BaseClass | protected
PosNoiseRemover() | Filter::PosNoiseRemover |
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | Filter::PosNoiseRemover | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | Filter::PosNoiseRemover |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | Filter::PosNoiseRemover | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PosNoiseRemover() | Filter::PosNoiseRemover | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
FrenetFrame Member List

This is the complete list of members for FrenetFrame, including all inherited members.

FrenetFrame(void) | FrenetFrame
~FrenetFrame(void) | FrenetFrame
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
GenericHeap< _NodeClass, _keyType > Member List

This is the complete list of members for GenericHeap< _NodeClass, _keyType >, including all inherited members.

DecreaseKey(_NodeClass *node, _keyType value)=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
Delete(_NodeClass *node)=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
ExtractMin(void)=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
GetMin(void)=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
Insert(_NodeClass *node)=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
IsEmpty()=0 | GenericHeap< _NodeClass, _keyType > | pure virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • GenericHeap
  • GenericHeapNode
GenericHeap< _NodeClass, _keyType >::GenericHeapNode Member List

This is the complete list of members for GenericHeap< _NodeClass, _keyType >::GenericHeapNode, including all inherited members.

key GenericHeap< _NodeClass, _keyType >::GenericHeapNode
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
GetObserver Member List

This is the complete list of members for GetObserver, including all inherited members.

GetObserver() | GetObserver | inline
GetUpdate(string modelFilename, int num, ModelType modelType)=0 | GetObserver | pure virtual
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
GradientColorGen Member List

This is the complete list of members for GradientColorGen, including all inherited members.

_colorEnd | GradientColorGen | protected
_colorStart | GradientColorGen | protected
actualColor | GradientColorGen |
arraySize | GradientColorGen |
crossSectionSize | GradientColorGen |
for(unsigned int i=0;i< leadSplineSize;i++) | GradientColorGen | inline
getColorEnd() const | GradientColorGen | inline
getColorStart() const | GradientColorGen | inline
GradientColorGen() | GradientColorGen | inline
GradientColorGen(const osg::Vec4 &colorStart, const osg::Vec4 &colorEnd) | GradientColorGen | inline
gradientStep | GradientColorGen |
META_DAObject(GradientColorGen,"Gradient Brush") virtual Vec4ArrayPtr getColors(unsigned int leadSplineSize | GradientColorGen |
reserve(arraySize) | GradientColorGen |
result | GradientColorGen |
result | GradientColorGen |
setColorEnd(osg::Vec4 val) | GradientColorGen | inline
setColorStart(osg::Vec4 val) | GradientColorGen | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
GradientDiameterGen Member List

This is the complete list of members for GradientDiameterGen, including all inherited members.

_diameterEnd | GradientDiameterGen | protected
_diameterStart | GradientDiameterGen | protected
getDiameterEnd() const | GradientDiameterGen | inline
getDiameterStart() const | GradientDiameterGen | inline
GradientDiameterGen() | GradientDiameterGen | inline
GradientDiameterGen(double diameterStart, double diameterEnd) | GradientDiameterGen | inline
META_DAObject(GradientDiameterGen,"Gradient Diameter") virtual DoubleArrayPtr getDiameters(unsigned int arraySize) | GradientDiameterGen | inline
setDiameterEnd(double val) | GradientDiameterGen | inline
setDiameterStart(double val) | GradientDiameterGen | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Hci Member List

This is the complete list of members for Hci, including all inherited members.

analog | Hci
analog_updated | Hci
autosynch() | Hci
BAD_FORMAT_handler | Hci
BAD_PACKET_handler | Hci
BAD_PASSWORD_handler | Hci
BAD_PORT_handler | Hci
BAD_VERSION_handler | Hci
begin() | Hci
buildPacket(int checkTYpe) | Hci
button | Hci
button_supported | Hci
buttons | Hci
CANT_BEGIN_handler | Hci
CANT_OPEN_handler | Hci
checkPacket(int checkType) | Hci
clearPacket() | Hci
comment | Hci
comParams(const char *port) | Hci
connect() | Hci
default_handler | Hci
disconnect() | Hci
encoder | Hci
encoder_updated | Hci
end() | Hci
error(hci_result condition) | Hci
fastTimeout() | Hci
getExtParams(byte *block, int *block_size) | Hci
getMaxes() | Hci
getParams(byte *block, int *block_size) | Hci
getStrings() | Hci
goHomePos() | Hci
init(const char *port) | Hci
invalidateFields() | Hci
max_analog | Hci
max_encoder | Hci
max_timer | Hci
model_name | Hci
NO_HCI_handler | Hci
param_format | Hci
parseCfgPacket() | Hci
parsePacket() | Hci
product_id | Hci
product_name | Hci
readBlock(byte *block, int *bytes_read) | Hci
readString(char *str) | Hci
serial_number | Hci
simpleCfgCmd(byte cmnd) | Hci
simpleString(hci_result condition) | Hci
slowTimeout() | Hci
stdCmd(int timer_flag, int analog_reports, int encoder_reports) | Hci
stringCmd(byte cmnd) | Hci
TIMED_OUT_handler | Hci
timer | Hci
timer_updated | Hci
version | Hci
waitPacket() | Hci
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Icon Member List

This is the complete list of members for Icon, including all inherited members.

clicked() | Icon |
colorablePartName | Icon | protected
defaultState | Icon | protected
Icon() | Icon |
load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *IconNode) | Icon |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | Icon |
originalColor | Icon | protected
pointed(bool pointed) | Icon |
postInitialize() | Icon |
save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *IconNode) | Icon |
setColorofPart(std::string partName, osg::Vec4 *newColor) | Icon |
type | Icon | protected
update() | Icon | virtual
~Icon() | Icon |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
InterpolatedSpline Member List

This is the complete list of members for InterpolatedSpline, including all inherited members.

_interpolationSteps | InterpolatedSpline | protected
_interpolator | InterpolatedSpline | protected
getInterpolationSteps() const | InterpolatedSpline | inline
getInterpolator() | InterpolatedSpline | inline
InterpolatedSpline(SplinePtr decoratedSpline) | InterpolatedSpline |
InterpolatedSpline(InterpolatorPtr interpolator, unsigned int interpolationSteps, SplinePtr decoratedSpline) | InterpolatedSpline |
META_DAObjectDecorator(_decoratedSpline, InterpolatedSpline,"Interpolated Spline") virtual Vec3ArrayPtr getPoints() | InterpolatedSpline |
setInterpolationSteps(int val) | InterpolatedSpline | inline
setInterpolator(InterpolatorPtr interpolator) | InterpolatedSpline | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Interpolator Member List

This is the complete list of members for Interpolator, including all inherited members.

classDescription() const =0 | Interpolator | pure virtual
className() const =0 | Interpolator | pure virtual
interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0 | Interpolator | pure virtual
~Interpolator() | Interpolator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
InterpolatorFactory Member List

This is the complete list of members for InterpolatorFactory, including all inherited members.

get(const std::string &name) | InterpolatorFactory | inlinestatic
getSupportedInterpolators() | InterpolatorFactory | inlinestatic
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
LinearInterpolator Member List

This is the complete list of members for LinearInterpolator, including all inherited members.

classDescription() const =0 | Interpolator | pure virtual
className() const =0 | Interpolator | pure virtual
closed | LinearInterpolator |
interpolate(const Vec3ArrayPtr array, unsigned int interpolationSteps, bool closed)=0 | Interpolator | pure virtual
interpolationSteps | LinearInterpolator |
META_DAObject(LinearInterpolator,"Linear Interpolator") virtual Vec3ArrayPtr interpolate(const Vec3ArrayPtr array | LinearInterpolator |
~Interpolator() | Interpolator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
LoadingConsole Member List

This is the complete list of members for LoadingConsole, including all inherited members.

addLine(unsigned long dwOutputType, const char *outputLine) | LoadingConsole |
borderXSize | LoadingConsole | protected
borderYSize | LoadingConsole | protected
camera | LoadingConsole | protected
create(vrecko::ViewerBase *_viewer, osg::Group *_rootNode) | LoadingConsole |
destroy() | LoadingConsole |
geode | LoadingConsole | protected
geom | LoadingConsole | protected
lineHeight | LoadingConsole | protected
lines | LoadingConsole | protected
lineSpace | LoadingConsole | protected
LoadingConsole() | LoadingConsole |
mainNode | LoadingConsole | protected
olLock | LoadingConsole | protected
outstandingLines | LoadingConsole | protected
rootNode | LoadingConsole | protected
update() | LoadingConsole |
vertices | LoadingConsole | protected
viewer | LoadingConsole | protected
viewHeight | LoadingConsole | protected
viewWidth | LoadingConsole | protected
~LoadingConsole() | LoadingConsole |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LoadingConsole
  • Line
LoadingConsole::Line Member List

This is the complete list of members for LoadingConsole::Line, including all inherited members.

Line(osgText::Text *_text) | LoadingConsole::Line | inline
text | LoadingConsole::Line |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LoadingConsole
  • OutstandingLine
LoadingConsole::OutstandingLine Member List

This is the complete list of members for LoadingConsole::OutstandingLine, including all inherited members.

dwType | LoadingConsole::OutstandingLine |
line | LoadingConsole::OutstandingLine |
OutstandingLine(unsigned long _dwType, const char *_line) | LoadingConsole::OutstandingLine | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MTBrush Member List

This is the complete list of members for MTBrush, including all inherited members.

getColour(double value=0.0) | MTBrush |
getColouringType() | MTBrush | inline
getColoursMap() | MTBrush | inline
getCrossSectionInterpolationSteps() | MTBrush | inline
getCrossSectionInterpolationType() | MTBrush | inline
getcrossSectionType() | MTBrush | inline
getCrosssPoints() | MTBrush | inline
getDiameter(double value=0.0) | MTBrush |
getDiameters() | MTBrush | inline
getInterpolationSteps() | MTBrush | inline
getMaxSpeed() | MTBrush | inline
getMinSpeed() | MTBrush | inline
MTBrush() | MTBrush |
setColour(osg::Vec4 colour, double value=0.0) | MTBrush |
setColourType(MTBrushParameterType type) | MTBrush | inline
setCrossSectionShape(MTBrushShapeType sh) | MTBrush |
setCrossSectionType(MTBrushParameterType type) | MTBrush | inline
setDiameter(double diam, double value=0.0) | MTBrush |
setInterpolationSteps(int interpol) | MTBrush | inline
setSpeeds(double min, double max) | MTBrush | inline
~MTBrush() | MTBrush |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MTCreatorTool Member List

This is the complete list of members for MTCreatorTool, including all inherited members.

activate() | MTCreatorTool |
DAAOrientation | MTCreatorTool | protected
DAAposition | MTCreatorTool | protected
DAArea | MTCreatorTool | protected
DAAScale | MTCreatorTool | protected
deactivate() | MTCreatorTool |
getSamples() | MTCreatorTool |
MTCreatorTool(int sensorNumber) | MTCreatorTool |
newOrientation | MTCreatorTool | protected
newPosition | MTCreatorTool | protected
orientation | MTCreatorTool | protected
oriString | MTCreatorTool | protected
position | MTCreatorTool | protected
posString | MTCreatorTool | protected
postInitialize(void) | MTCreatorTool |
processEvent(const std::string &input_name, void *value) | MTCreatorTool |
samples | MTCreatorTool | protected
sensorNumber | MTCreatorTool | protected
turnOff() | MTCreatorTool |
turnOn() | MTCreatorTool |
update() | MTCreatorTool |
~MTCreatorTool() | MTCreatorTool |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MagicWandTool Member List

This is the complete list of members for MagicWandTool, including all inherited members.

activate() | MagicWandTool |
attractor | MagicWandTool | protected
controller | MagicWandTool | protected
deactivate() | MagicWandTool |
dominantAxis | MagicWandTool | protected
handMoveMax | MagicWandTool | protected
handMoveMin | MagicWandTool | protected
indexX | MagicWandTool | protected
indexY | MagicWandTool | protected
indexZ | MagicWandTool | protected
initialParamValue | MagicWandTool | protected
lastDominantAxis | MagicWandTool | protected
MagicWandTool(Controller *contr) | MagicWandTool |
newHandPosition | MagicWandTool | protected
originalHandposition | MagicWandTool | protected
originalIterations | MagicWandTool | protected
paramMult | MagicWandTool | protected
paramRangeEnd | MagicWandTool | protected
paramRangeStart | MagicWandTool | protected
paramShift1 | MagicWandTool | protected
paramShift2 | MagicWandTool | protected
PointerPosReqString | MagicWandTool | protected
posString | MagicWandTool | protected
postInitialize(void) | MagicWandTool |
processEvent(const std::string &input_name, void *value) | MagicWandTool |
sensorNumber | MagicWandTool | protected
turnOff() | MagicWandTool |
turnOn() | MagicWandTool |
~MagicWandTool() | MagicWandTool |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MainObject Member List

This is the complete list of members for MainObject, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
done | MainObject | protected
exit(void) | MainObject | inline
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputExit | MainObject |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
inputProjection | MainObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
MainObject() | MainObject | inline
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
onMessageExit(MessageBool *message) | MainObject | inline
onMessageProjection(MessageMatrix *message) | MainObject | inline
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~MainObject() | MainObject | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MainSceneUpdateCallback Member List

This is the complete list of members for MainSceneUpdateCallback, including all inherited members.

MainSceneUpdateCallback() | MainSceneUpdateCallback | inline
operator()(osg::Node *node, osg::NodeVisitor *nv) | MainSceneUpdateCallback | inlinevirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MemoryReadBuffer Member List

This is the complete list of members for MemoryReadBuffer, including all inherited members.

buffer | MemoryReadBuffer | mutable
MemoryReadBuffer(const NxU8 *data) | MemoryReadBuffer |
readBuffer(void *buffer, NxU32 size) const | MemoryReadBuffer | virtual
readByte() const | MemoryReadBuffer | virtual
readDouble() const | MemoryReadBuffer | virtual
readDword() const | MemoryReadBuffer | virtual
readFloat() const | MemoryReadBuffer | virtual
readWord() const | MemoryReadBuffer | virtual
storeBuffer(const void *buffer, NxU32 size) | MemoryReadBuffer | inlinevirtual
storeByte(NxU8 b) | MemoryReadBuffer | inlinevirtual
storeDouble(NxF64 f) | MemoryReadBuffer | inlinevirtual
storeDword(NxU32 d) | MemoryReadBuffer | inlinevirtual
storeFloat(NxReal f) | MemoryReadBuffer | inlinevirtual
storeWord(NxU16 w) | MemoryReadBuffer | inlinevirtual
~MemoryReadBuffer() | MemoryReadBuffer | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MemoryWriteBuffer Member List

This is the complete list of members for MemoryWriteBuffer, including all inherited members.

clear() | MemoryWriteBuffer |
currentSize | MemoryWriteBuffer |
data | MemoryWriteBuffer |
maxSize | MemoryWriteBuffer |
MemoryWriteBuffer() | MemoryWriteBuffer |
readBuffer(void *buffer, NxU32 size) const | MemoryWriteBuffer | inlinevirtual
readByte() const | MemoryWriteBuffer | inlinevirtual
readDouble() const | MemoryWriteBuffer | inlinevirtual
readDword() const | MemoryWriteBuffer | inlinevirtual
readFloat() const | MemoryWriteBuffer | inlinevirtual
readWord() const | MemoryWriteBuffer | inlinevirtual
storeBuffer(const void *buffer, NxU32 size) | MemoryWriteBuffer | virtual
storeByte(NxU8 b) | MemoryWriteBuffer | virtual
storeDouble(NxF64 f) | MemoryWriteBuffer | virtual
storeDword(NxU32 d) | MemoryWriteBuffer | virtual
storeFloat(NxReal f) | MemoryWriteBuffer | virtual
storeWord(NxU16 w) | MemoryWriteBuffer | virtual
~MemoryWriteBuffer() | MemoryWriteBuffer | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ModelManager Member List

This is the complete list of members for ModelManager, including all inherited members.

AddAddObserver(AddObserver *newObserver) | ModelManager | static
AddDeleteObserver(DeleteObserver *newObserver) | ModelManager | static
AddGetObserver(GetObserver *newObserver) | ModelManager | static
AddModelGeometry(string modelFilename, osg::ref_ptr< EnvironmentObject > newGeometry) | ModelManager | static
ContainsAnimatedModelGeometry(string modelFilename) | ModelManager | static
ContainsModelGeometry(string modelFilename) | ModelManager | static
ContainsModelGeometry(string modelFilename, ModelType modelType) | ModelManager | static
DeleteAnimatedModelGeometry(osg::ref_ptr< EnvironmentObject > *ptr) | ModelManager | static
DeleteModelGeometry(osg::ref_ptr< EnvironmentObject > *ptr) | ModelManager | static
DeleteModelGeometry(osg::ref_ptr< EnvironmentObject > *ptr, ModelType modelType) | ModelManager | static
GetAnimatedModelGeometry(string modelFilename, int animationIndex, bool startAnimation) | ModelManager | static
GetModelGeometry(string modelFilename) | ModelManager | static
RemoveAddObserver(AddObserver *observer) | ModelManager | static
RemoveDeleteObserver(DeleteObserver *observer) | ModelManager | static
RemoveGetObserver(GetObserver *observer) | ModelManager | static
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MotionTrailTriangulator Member List

This is the complete list of members for MotionTrailTriangulator, including all inherited members.

catmullRomInterpolation(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3) | MotionTrailTriangulator |
derivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3) | MotionTrailTriangulator |
doubleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3) | MotionTrailTriangulator |
getHighLighting() | MotionTrailTriangulator | inline
highlightColour(osg::Vec4 col) | MotionTrailTriangulator |
interpolate(std::vector< ref_ptr_DAControlPoint > *controlPoints, std::vector< osg::Vec3 > *interpolatedPoints, std::vector< double > *tvalues=NULL, int p_steps=0, bool lengthOptimization=false, bool closed=false) | MotionTrailTriangulator |
interpolateCrossSection() | MotionTrailTriangulator | inline
interpolateCrossSection(MTBrush *brush, std::vector< osg::Vec3 > *interpolatedPoints, std::vector< osg::Vec3 > *interpolatedNormals) | MotionTrailTriangulator |
interpolateVec3(std::vector< osg::Vec3 > *controlPoints, std::vector< osg::Vec3 > *interpolatedPoints, PoAInterpolationType type, bool closed, int p_steps) | MotionTrailTriangulator |
MotionTrailTriangulator(osg::ref_ptr< MTBrush > br) | MotionTrailTriangulator |
setHighLighting(bool high) | MotionTrailTriangulator | inline
setUseFrenetFrame(bool frenet) | MotionTrailTriangulator | inline
triangulate(std::vector< ref_ptr_DAControlPoint > *controlPoints) | MotionTrailTriangulator |
tripleDerivedCRI(double t, osg::Vec3 p0, osg::Vec3 p1, osg::Vec3 p2, osg::Vec3 p3) | MotionTrailTriangulator |
~MotionTrailTriangulator() | MotionTrailTriangulator |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
NullInterpolator Member List

This is the complete list of members for NullInterpolator, including all inherited members.

classDescription() const =0 | Interpolator | pure virtual
className() const =0 | Interpolator | pure virtual
~Interpolator() | Interpolator | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PHANToMAvatar Member List

This is the complete list of members for PHANToMAvatar, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PHANToMAvatar |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | PHANToMAvatar | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMAvatar() | PHANToMAvatar |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PHANToMAvatar | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | PHANToMAvatar | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | PHANToMAvatar |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | PHANToMAvatar | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PHANToMAvatar() | PHANToMAvatar | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PHEffect Member List

This is the complete list of members for PHEffect, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | PHEffect | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PHEffect |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | PHEffect | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | PHEffect | protected
PHEffect() | PHEffect |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PHEffect | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | PHEffect | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | PHEffect |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | PHEffect | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PHEffect() | PHEffect | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BaseActor
PhysXPlugin::BaseActor Member List

This is the complete list of members for PhysXPlugin::BaseActor, including all inherited members.

_actorDesc | PhysXPlugin::BaseActor | protected
_bDynamicActorOutputs | PhysXPlugin::BaseActor | protected
_bodyDesc | PhysXPlugin::BaseActor | protected
_MaterialIndex | PhysXPlugin::BaseActor | protected
_MaterialName | PhysXPlugin::BaseActor | protected
_move_step_limit | PhysXPlugin::BaseActor | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pPO | PhysXPlugin::BaseActor | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseActor(const char *abName) | PhysXPlugin::BaseActor | inline
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseActor | virtual
DECLARE_INPUT(ResetPosition, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(MoveTo, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(RotateTo, MessageQuat) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(DynamicActorOutputs, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::BaseActor | protected
PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::BaseActor | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::BaseActor | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::BaseActor | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::BaseActor | inlineprotectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseActor() | PhysXPlugin::BaseActor | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BaseJoint
PhysXPlugin::BaseJoint Member List

This is the complete list of members for PhysXPlugin::BaseJoint, including all inherited members.

_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::BaseJoint | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::BaseJoint | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • BasePhysXObject
PhysXPlugin::BasePhysXObject Member List

This is the complete list of members for PhysXPlugin::BasePhysXObject, including all inherited members.

_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create()=0 | PhysXPlugin::BasePhysXObject | protectedpure virtual
DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::BasePhysXObject | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Box
PhysXPlugin::Box Member List

This is the complete list of members for PhysXPlugin::Box, including all inherited members.

_actorDesc | PhysXPlugin::BaseActor | protected
_bDynamicActorOutputs | PhysXPlugin::BaseActor | protected
_bodyDesc | PhysXPlugin::BaseActor | protected
_boxDesc | PhysXPlugin::Box | protected
_MaterialIndex | PhysXPlugin::BaseActor | protected
_MaterialName | PhysXPlugin::BaseActor | protected
_move_step_limit | PhysXPlugin::BaseActor | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pPO | PhysXPlugin::BaseActor | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseActor(const char *abName) | PhysXPlugin::BaseActor | inline
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
Box() | PhysXPlugin::Box |
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::Box | protectedvirtual
DECLARE_INPUT(ResetPosition, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(MoveTo, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(RotateTo, MessageQuat) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(DynamicActorOutputs, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::BaseActor | protected
PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::Box | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Box | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::BaseActor | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::BaseActor | inlineprotectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseActor() | PhysXPlugin::BaseActor | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Box() | PhysXPlugin::Box |
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Capsule
PhysXPlugin::Capsule Member List

This is the complete list of members for PhysXPlugin::Capsule, including all inherited members.

_actorDesc | PhysXPlugin::BaseActor | protected
_bDynamicActorOutputs | PhysXPlugin::BaseActor | protected
_bodyDesc | PhysXPlugin::BaseActor | protected
_capsuleDesc | PhysXPlugin::Capsule | protected
_MaterialIndex | PhysXPlugin::BaseActor | protected
_MaterialName | PhysXPlugin::BaseActor | protected
_move_step_limit | PhysXPlugin::BaseActor | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pPO | PhysXPlugin::BaseActor | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseActor(const char *abName) | PhysXPlugin::BaseActor | inline
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
Capsule() | PhysXPlugin::Capsule | inline
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::Capsule | protectedvirtual
DECLARE_INPUT(ResetPosition, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(MoveTo, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(RotateTo, MessageQuat) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(DynamicActorOutputs, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::BaseActor | protected
PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::Capsule | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Capsule | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::BaseActor | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::BaseActor | inlineprotectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseActor() | PhysXPlugin::BaseActor | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Capsule() | PhysXPlugin::Capsule | inline
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Cloth
PhysXPlugin::Cloth Member List

This is the complete list of members for PhysXPlugin::Cloth, including all inherited members.

_attachment_ids | PhysXPlugin::Cloth | protected
_clothDesc | PhysXPlugin::Cloth | protected
_clothMeshDesc | PhysXPlugin::Cloth | protected
_coreActorDesc | PhysXPlugin::Cloth | protected
_fileName | PhysXPlugin::Cloth | protected
_meshData | PhysXPlugin::Cloth | protected
_offset | PhysXPlugin::Cloth | protected
_pCloth | PhysXPlugin::Cloth | protected
_pClothDrawable | PhysXPlugin::Cloth | protected
_pClothMesh | PhysXPlugin::Cloth | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_scale | PhysXPlugin::Cloth | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Cloth() | PhysXPlugin::Cloth | inline
Create() | PhysXPlugin::Cloth | virtual
DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Cloth | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::UpdatablePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::Cloth | protectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Cloth() | PhysXPlugin::Cloth | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ClothDrawable
PhysXPlugin::ClothDrawable Member List

This is the complete list of members for PhysXPlugin::ClothDrawable, including all inherited members.

className() const | PhysXPlugin::ClothDrawable | inlinevirtual
clone(const osg::CopyOp &copyop) const | PhysXPlugin::ClothDrawable | inlinevirtual
cloneType() const | PhysXPlugin::ClothDrawable | inlinevirtual
Cloth class | PhysXPlugin::ClothDrawable | friend
ClothDrawable() | PhysXPlugin::ClothDrawable | inline
ClothDrawable(NxCloth *pCloth) | PhysXPlugin::ClothDrawable | inline
ClothDrawable(const ClothDrawable &drawable, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY) | PhysXPlugin::ClothDrawable | inline
computeBound() const | PhysXPlugin::ClothDrawable | inlinevirtual
drawImplementation(osg::RenderInfo &renderInfo) const | PhysXPlugin::ClothDrawable | inlinevirtual
isSameKindAs(const osg::Object *obj) const | PhysXPlugin::ClothDrawable | inlinevirtual
libaryName() const | PhysXPlugin::ClothDrawable | inlinevirtual
operator=(const ClothDrawable &) | PhysXPlugin::ClothDrawable | inlineprotected
PCloth(NxCloth *val) | PhysXPlugin::ClothDrawable | inlineprotected
Update() | PhysXPlugin::ClothDrawable | inlinevirtual
~ClothDrawable() | PhysXPlugin::ClothDrawable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • CoreActorDesc
PhysXPlugin::CoreActorDesc Member List

This is the complete list of members for PhysXPlugin::CoreActorDesc, including all inherited members.

CoreActorDesc() | PhysXPlugin::CoreActorDesc | inline
Create(NxScene *pScene, NxCloth *pCloth) | PhysXPlugin::CoreActorDesc |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::CoreActorDesc |
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • CylindricalJoint
PhysXPlugin::CylindricalJoint Member List

This is the complete list of members for PhysXPlugin::CylindricalJoint, including all inherited members.

_descripter | PhysXPlugin::CylindricalJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
CylindricalJoint() | PhysXPlugin::CylindricalJoint | inline
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::CylindricalJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::CylindricalJoint | inlinevirtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • DistanceJoint
PhysXPlugin::DistanceJoint Member List

This is the complete list of members for PhysXPlugin::DistanceJoint, including all inherited members.

_descripter | PhysXPlugin::DistanceJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
DistanceJoint() | PhysXPlugin::DistanceJoint | inline
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::DistanceJoint | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::DistanceJoint | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ErrorReporter
PhysXPlugin::ErrorReporter Member List

This is the complete list of members for PhysXPlugin::ErrorReporter, including all inherited members.

Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • FixedJoint
PhysXPlugin::FixedJoint Member List

This is the complete list of members for PhysXPlugin::FixedJoint, including all inherited members.

_descripter | PhysXPlugin::FixedJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
FixedJoint() | PhysXPlugin::FixedJoint | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::FixedJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::FixedJoint | inlinevirtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Fluid
PhysXPlugin::Fluid Member List

This is the complete list of members for PhysXPlugin::Fluid, including all inherited members.

_fluidDesc | PhysXPlugin::Fluid | protected
_Particles | PhysXPlugin::Fluid | protected
_pFluid | PhysXPlugin::Fluid | protected
_pFluidDrawable | PhysXPlugin::Fluid | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::Fluid | virtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::Fluid | protectedvirtual
DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
Fluid() | PhysXPlugin::Fluid | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Fluid | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::UpdatablePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::Fluid | protectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Fluid() | PhysXPlugin::Fluid | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • FluidDrawable
PhysXPlugin::FluidDrawable Member List

This is the complete list of members for PhysXPlugin::FluidDrawable, including all inherited members.

className() const | PhysXPlugin::FluidDrawable | inlinevirtual
clone(const osg::CopyOp &copyop) const | PhysXPlugin::FluidDrawable | inlinevirtual
cloneType() const | PhysXPlugin::FluidDrawable | inlinevirtual
computeBound() const | PhysXPlugin::FluidDrawable | inlinevirtual
drawImplementation(osg::RenderInfo &renderInfo) const | PhysXPlugin::FluidDrawable | inlinevirtual
Fluid class | PhysXPlugin::FluidDrawable | friend
FluidDrawable() | PhysXPlugin::FluidDrawable | inline
FluidDrawable(NxFluid *pFluid) | PhysXPlugin::FluidDrawable | inline
FluidDrawable(const FluidDrawable &drawable, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY) | PhysXPlugin::FluidDrawable | inline
isSameKindAs(const osg::Object *obj) const | PhysXPlugin::FluidDrawable | inlinevirtual
libaryName() const | PhysXPlugin::FluidDrawable | inlinevirtual
operator=(const FluidDrawable &) | PhysXPlugin::FluidDrawable | inlineprotected
Update() | PhysXPlugin::FluidDrawable | inlinevirtual
~FluidDrawable() | PhysXPlugin::FluidDrawable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • ForceField
PhysXPlugin::ForceField Member List

This is the complete list of members for PhysXPlugin::ForceField, including all inherited members.

_forceFieldDesc | PhysXPlugin::ForceField | protected
_forceFieldLinearKernelDesc | PhysXPlugin::ForceField | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::ForceField | protectedvirtual
DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
ForceField() | PhysXPlugin::ForceField |
getAcceptableMessages(void) | PhysXPlugin::ForceField | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::ForceField | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ForceField() | PhysXPlugin::ForceField | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • MaterialManager
PhysXPlugin::MaterialManager Member List

This is the complete list of members for PhysXPlugin::MaterialManager, including all inherited members.

Create(NxScene *pScene) | PhysXPlugin::MaterialManager
indexByName(const std::string &) | PhysXPlugin::MaterialManager
loadXMLMaterial(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | PhysXPlugin::MaterialManager
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • MessageNxActorWithName
PhysXPlugin::MessageNxActorWithName Member List

This is the complete list of members for PhysXPlugin::MessageNxActorWithName, including all inherited members.

_actor | PhysXPlugin::MessageNxActorWithName |
_name | PhysXPlugin::MessageNxActorWithName |
getMessageId() | PhysXPlugin::MessageNxActorWithName | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageNxActorWithName() | PhysXPlugin::MessageNxActorWithName | inline
MessageNxActorWithName(NxActor *actor, const char *name) | PhysXPlugin::MessageNxActorWithName | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PhysXObject
PhysXPlugin::PhysXObject Member List

This is the complete list of members for PhysXPlugin::PhysXObject, including all inherited members.

_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::PhysXObject | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::PhysXObject | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PhysXScene
PhysXPlugin::PhysXScene Member List

This is the complete list of members for PhysXPlugin::PhysXScene, including all inherited members.

_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_INPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::PhysXScene |
DECLARE_REQUEST_INPUT(PhysXScene, MessageVoid, MessageNxScenePtr) | PhysXPlugin::PhysXScene |
DECLARE_REQUEST_INPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::PhysXScene |
DECLARE_REQUEST_INPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::PhysXScene |
DECLARE_REQUEST_INPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::PhysXScene |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | PhysXPlugin::PhysXScene | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PhysXScene() | PhysXPlugin::PhysXScene |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::PhysXScene | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::PhysXScene | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | PhysXPlugin::PhysXScene | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~PhysXScene() | PhysXPlugin::PhysXScene | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Plane
PhysXPlugin::Plane Member List

This is the complete list of members for PhysXPlugin::Plane, including all inherited members.

_actorDesc | PhysXPlugin::BaseActor | protected
_bDynamicActorOutputs | PhysXPlugin::BaseActor | protected
_bodyDesc | PhysXPlugin::BaseActor | protected
_MaterialIndex | PhysXPlugin::BaseActor | protected
_MaterialName | PhysXPlugin::BaseActor | protected
_move_step_limit | PhysXPlugin::BaseActor | protected
_planeDesc | PhysXPlugin::Plane | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pPO | PhysXPlugin::BaseActor | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseActor(const char *abName) | PhysXPlugin::BaseActor | inline
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::Plane | protectedvirtual
DECLARE_INPUT(ResetPosition, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(MoveTo, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(RotateTo, MessageQuat) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(DynamicActorOutputs, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::BaseActor | protected
PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::Plane | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Plane | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
Plane() | PhysXPlugin::Plane |
postInitialize() | PhysXPlugin::BaseActor | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::BaseActor | inlineprotectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseActor() | PhysXPlugin::BaseActor | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~Plane() | PhysXPlugin::Plane | inline
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PointInPlaneJoint
PhysXPlugin::PointInPlaneJoint Member List

This is the complete list of members for PhysXPlugin::PointInPlaneJoint, including all inherited members.

_descripter | PhysXPlugin::PointInPlaneJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::PointInPlaneJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::PointInPlaneJoint | inlinevirtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
PointInPlaneJoint() | PhysXPlugin::PointInPlaneJoint | inline
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PointOnLineJoint
PhysXPlugin::PointOnLineJoint Member List

This is the complete list of members for PhysXPlugin::PointOnLineJoint, including all inherited members.

_descripter | PhysXPlugin::PointOnLineJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::PointOnLineJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::PointOnLineJoint | inlinevirtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
PointOnLineJoint() | PhysXPlugin::PointOnLineJoint | inline
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PrismaticJoint
PhysXPlugin::PrismaticJoint Member List

This is the complete list of members for PhysXPlugin::PrismaticJoint, including all inherited members.

_descripter | PhysXPlugin::PrismaticJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::PrismaticJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::PrismaticJoint | inlinevirtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
PrismaticJoint() | PhysXPlugin::PrismaticJoint | inline
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • PulleyJoint
PhysXPlugin::PulleyJoint Member List

This is the complete list of members for PhysXPlugin::PulleyJoint, including all inherited members.

_descripter | PhysXPlugin::PulleyJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::PulleyJoint | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::PulleyJoint | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
PulleyJoint() | PhysXPlugin::PulleyJoint | inline
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • RemoteDebugger
PhysXPlugin::RemoteDebugger Member List

This is the complete list of members for PhysXPlugin::RemoteDebugger, including all inherited members.

_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pRemoteDebugger | PhysXPlugin::RemoteDebugger | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode) | PhysXPlugin::RemoteDebugger | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | PhysXPlugin::RemoteDebugger | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::RemoteDebugger | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::PhysXObject | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RemoteDebugger() | PhysXPlugin::RemoteDebugger | inline
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~RemoteDebugger() | PhysXPlugin::RemoteDebugger | virtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • RevoluteJoint
PhysXPlugin::RevoluteJoint Member List

This is the complete list of members for PhysXPlugin::RevoluteJoint, including all inherited members.

_descripter | PhysXPlugin::RevoluteJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::RevoluteJoint | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::RevoluteJoint | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
RevoluteJoint() | PhysXPlugin::RevoluteJoint | inline
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Sphere
PhysXPlugin::Sphere Member List

This is the complete list of members for PhysXPlugin::Sphere, including all inherited members.

_actorDesc | PhysXPlugin::BaseActor | protected
_bDynamicActorOutputs | PhysXPlugin::BaseActor | protected
_bodyDesc | PhysXPlugin::BaseActor | protected
_MaterialIndex | PhysXPlugin::BaseActor | protected
_MaterialName | PhysXPlugin::BaseActor | protected
_move_step_limit | PhysXPlugin::BaseActor | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pPO | PhysXPlugin::BaseActor | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_sphereDesc | PhysXPlugin::Sphere | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseActor(const char *abName) | PhysXPlugin::BaseActor | inline
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::Sphere | protectedvirtual
DECLARE_INPUT(ResetPosition, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(MoveTo, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(RotateTo, MessageQuat) | PhysXPlugin::BaseActor | protected
DECLARE_INPUT(DynamicActorOutputs, MessageBool) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularMomentum, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(LinearVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_OUTPUT(AngularVelocity, MessageVec3) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(Material, MessageString, MessageNxMaterialIndex) | PhysXPlugin::BaseActor | protected
DECLARE_REQUEST_OUTPUT(RegisterJointedActor, MessageNxActorWithName, MessageBool) | PhysXPlugin::BaseActor | protected
PhysXPlugin::UpdatablePhysXObject::DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | PhysXPlugin::Sphere | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::Sphere | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::BaseActor | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
Sphere() | PhysXPlugin::Sphere |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject() | PhysXPlugin::BaseActor | inlineprotectedvirtual
~Ability() | vrecko::Ability | virtual
~BaseActor() | PhysXPlugin::BaseActor | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~Sphere() | PhysXPlugin::Sphere |
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • SphericalJoint
PhysXPlugin::SphericalJoint Member List

This is the complete list of members for PhysXPlugin::SphericalJoint, including all inherited members.

_descripter | PhysXPlugin::SphericalJoint | protected
_globalAnchor | PhysXPlugin::BaseJoint | protected
_globalAxis | PhysXPlugin::BaseJoint | protected
_ID | PhysXPlugin::BaseJoint | protected
_pBaseDescripter | PhysXPlugin::BaseJoint | protected
_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BaseJoint(const char *abName, NxJointDesc *descripter) | PhysXPlugin::BaseJoint | inline
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create() | PhysXPlugin::BaseJoint | virtual
DECLARE_REQUEST_OUTPUT(GetJointedActor, MessageString, MessageNxActorPtr) | PhysXPlugin::BaseJoint | protected
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *domdocument) | PhysXPlugin::SphericalJoint | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::SphericalJoint | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | PhysXPlugin::BasePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SphericalJoint() | PhysXPlugin::SphericalJoint | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BaseJoint() | PhysXPlugin::BaseJoint | inlinevirtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • UpdatablePhysXObject
PhysXPlugin::UpdatablePhysXObject Member List

This is the complete list of members for PhysXPlugin::UpdatablePhysXObject, including all inherited members.

_pPhysicsSDK | PhysXPlugin::PhysXObject | protected
_pScene | PhysXPlugin::BasePhysXObject | protected
_strRegisterPhysXObject | PhysXPlugin::UpdatablePhysXObject | protected
_strScene | PhysXPlugin::BasePhysXObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserDrawable(osg::Drawable *userDrawable) | PhysXPlugin::PhysXObject | inlineprotected
AfterInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BasePhysXObject(const char *abName) | PhysXPlugin::BasePhysXObject | inline
BeforeInitialization() | PhysXPlugin::PhysXObject | inlinevirtual
clean(void) | vrecko::Ability | inlinevirtual
Create()=0 | PhysXPlugin::BasePhysXObject | protectedpure virtual
DECLARE_REQUEST_OUTPUT(RegisterPhysXObject, MessageUpdatablePhysXObjectPtr, MessageBool) | PhysXPlugin::UpdatablePhysXObject |
PhysXPlugin::BasePhysXObject::DECLARE_REQUEST_OUTPUT(PhysXScene, MessageString, MessageNxScenePtr) | PhysXPlugin::BasePhysXObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | PhysXPlugin::BasePhysXObject | virtual
PhysXPlugin::PhysXObject::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PhysXObject(const char *abName) | PhysXPlugin::PhysXObject | inline
PinList typedef | vrecko::BaseClass | protected
postInitialize() | PhysXPlugin::UpdatablePhysXObject | virtual
pOwner | vrecko::Ability | protected
preInitialize() | PhysXPlugin::BasePhysXObject | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
RegisterUpatablePO() | PhysXPlugin::UpdatablePhysXObject | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
UpdatablePhysXObject(const char *abName) | PhysXPlugin::UpdatablePhysXObject | inline
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
UpdateEnvironmentObject()=0 | PhysXPlugin::UpdatablePhysXObject | pure virtual
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PhysXObject() | PhysXPlugin::PhysXObject | inlinevirtual
~UpdatablePhysXObject() | PhysXPlugin::UpdatablePhysXObject | inlinevirtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Preloader Member List

This is the complete list of members for Preloader, including all inherited members.

ExitLoadingFunction(void) | Preloader | inline
GetLock(void) | Preloader | inline
loadedObjects | Preloader |
LoadingFunctionFinnished(void) | Preloader | inline
loadingQueue | Preloader |
Preloader(BlockUpdater *_rootBlockUpdater) | Preloader | inline
Running(void) | Preloader | inline
Start(void) | Preloader |
Stop(void) | Preloader |
Update(void) | Preloader |
~Preloader(void) | Preloader | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PreloaderHeuristic Member List

This is the complete list of members for PreloaderHeuristic, including all inherited members.

GetObjectsToPreload(void) | PreloaderHeuristic | inlinevirtual
objectsToPreload | PreloaderHeuristic | protected
Restart(void) | PreloaderHeuristic | inlinevirtual
rootBlockUpdater | PreloaderHeuristic | protected
searchFinnished | PreloaderHeuristic | protected
SearchFinnished(void) | PreloaderHeuristic | inlinevirtual
SetWorldRoot(BlockUpdater *_rootBlockUpdater) | PreloaderHeuristic | inline
Update(void) | PreloaderHeuristic | inlinevirtual
~PreloaderHeuristic() | PreloaderHeuristic | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PreloaderLoadedInfo Member List

This is the complete list of members for PreloaderLoadedInfo, including all inherited members.

filename | PreloaderLoadedInfo
geometry | PreloaderLoadedInfo
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PreloaderToLoadInfo Member List

This is the complete list of members for PreloaderToLoadInfo, including all inherited members.

filename | PreloaderToLoadInfo
type | PreloaderToLoadInfo
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
PseudoRand2DPlacement Member List

This is the complete list of members for PseudoRand2DPlacement, including all inherited members.

GetRandPosition(int gridX, int gridY, int gridZ, int *posX, int *posY, int *posZ, int radius=0) const | PseudoRand2DPlacement |
gridUnitHalfSizeX | PseudoRand2DPlacement |
gridUnitHalfSizeZ | PseudoRand2DPlacement |
gridUnitSizeX | PseudoRand2DPlacement |
gridUnitSizeY | PseudoRand2DPlacement |
gridUnitSizeZ | PseudoRand2DPlacement |
Noise1D(int x, int y) const | PseudoRand2DPlacement |
PseudoRand2DPlacement() | PseudoRand2DPlacement | inline
SetGridUnitSizeXYZ(int x, int y, int z) | PseudoRand2DPlacement |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
RealCmp< T > Member List

This is the complete list of members for RealCmp< T >, including all inherited members.

comparator(T a, T b) | RealCmp< T > | inlinestatic
compareEQ(T a, T b) | RealCmp< T > | inlinestatic
compareGT(T a, T b) | RealCmp< T > | inlinestatic
compareGTEQ(T a, T b) | RealCmp< T > | inlinestatic
compareLT(T a, T b) | RealCmp< T > | inlinestatic
compareLTEQ(T a, T b) | RealCmp< T > | inlinestatic
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
RegularPolygonSpline Member List

This is the complete list of members for RegularPolygonSpline, including all inherited members.

_invSegmentCount | RegularPolygonSpline | protected
_plane | RegularPolygonSpline | protected
_radius | RegularPolygonSpline | protected
_rotationInDegress | RegularPolygonSpline | protected
_segmentCount | RegularPolygonSpline | protected
_shift | RegularPolygonSpline | protected
getPlane() const | RegularPolygonSpline | inline
getRadius() const | RegularPolygonSpline | inline
getRotationShift() const | RegularPolygonSpline | inline
getSegmentCount() const | RegularPolygonSpline | inline
isClosed() | RegularPolygonSpline | inlinevirtual
META_DAObject(RegularPolygonSpline,"Regular Polygon Spline") virtual Vec3ArrayPtr getPoints() | RegularPolygonSpline |
PlaneType enum name | RegularPolygonSpline |
RegularPolygonSpline() | RegularPolygonSpline |
RegularPolygonSpline(double radius, unsigned int segmentCount, double rotationShiftInDegress=0.0, PlaneType plane=XY) | RegularPolygonSpline |
setPlane(RegularPolygonSpline::PlaneType val) | RegularPolygonSpline | inline
setRadius(double val) | RegularPolygonSpline | inline
setRotationShift(double val) | RegularPolygonSpline | inline
setSegmentCount(unsigned int val) | RegularPolygonSpline | inline
XY enum value | RegularPolygonSpline |
XZ enum value | RegularPolygonSpline |
YZ enum value | RegularPolygonSpline |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SampledSpline Member List

This is the complete list of members for SampledSpline, including all inherited members.

_array | SampledSpline | protected
_closed | SampledSpline | protected
_minDistance | SampledSpline | protected
getMinimalSampleDistance() const | SampledSpline | inline
getPoints() | SampledSpline | virtual
getVertexArray() const | SampledSpline | inline
isClosed() | SampledSpline | inlinevirtual
META_DAObject(SampledSpline,"Sampled Spline") | SampledSpline |
SampledSpline() | SampledSpline |
SampledSpline(double minSampleDistance, bool closed, const Vec3ArrayPtr sampleArray) | SampledSpline |
setClosed(bool val) | SampledSpline | inline
setMinimalSampleDistance(double val) | SampledSpline | inline
setVertexArray(const Vec3ArrayPtr array) | SampledSpline | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SectorColorGen Member List

This is the complete list of members for SectorColorGen, including all inherited members.

_defaultColor | SectorColorGen | protected
_sectors | SectorColorGen | protected
addSector(SectorPtr sector) | SectorColorGen | inline
getColors(unsigned int leadSplineSize, unsigned int crossSectionSize) | SectorColorGen | inlinevirtual
getDefaultColor() const | SectorColorGen | inline
getNumSectors() | SectorColorGen | inline
getSector(unsigned int i) | SectorColorGen | inline
META_DAObject(SectorColorGen,"Sector Color") | SectorColorGen |
removeSectors(unsigned int i, int numSectorsToRemove=1) | SectorColorGen | inline
SectorColorGen(const osg::Vec4 &defaultColor) | SectorColorGen | inline
setDefaultColor(osg::Vec4 val) | SectorColorGen | inline
setSector(unsigned int i, SectorPtr val) | SectorColorGen | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Serial Member List

This is the complete list of members for Serial, including all inherited members.

closeSerial() | Serial
flushSerial() | Serial
openSerial(char *) | Serial
readBytes(char *, const int, const int) | Serial
readChar() | Serial
writeChar(const char) | Serial
writeString(char *) | Serial
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SliceTool Member List

This is the complete list of members for SliceTool, including all inherited members.

activate() | SliceTool |
clipNode | SliceTool | protected
DAArea | SliceTool | protected
deactivate() | SliceTool |
lowClipPlane | SliceTool | protected
postInitialize(void) | SliceTool |
SliceTool() | SliceTool |
topClipPlane | SliceTool | protected
turnOff() | SliceTool |
turnOn() | SliceTool |
~SliceTool() | SliceTool |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SmoothedSpline Member List

This is the complete list of members for SmoothedSpline, including all inherited members.

_smoothFactor | SmoothedSpline | protected
META_DAObjectDecorator(_decoratedSpline, SmoothedSpline,"Smoothed Spline") virtual Vec3ArrayPtr getPoints() | SmoothedSpline |
SmoothedSpline(double smoothFactor, SplinePtr decoratedSpline) | SmoothedSpline |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SnapObject Member List

This is the complete list of members for SnapObject, including all inherited members.

chooseBoundaryLoop(SnapObject *object) | SnapObject
createGraph() | SnapObject
createSimpleGraph() | SnapObject
deleteFromScene() | SnapObject
erasePoints(vector< int > &boundaryLoopToErase, vector< int > &eraseLoop) | SnapObject
erasePointsAndAllFaces(vector< int > &boundaryLoopToErase, vector< int > &eraseLoop) | SnapObject
findBoundaryLoops() | SnapObject
findClosestPoint(SnapObject *object) | SnapObject
findClosestPoint(osg::Vec3 point) | SnapObject
findClosestSnappingRegionPoints(SnapObject *object) | SnapObject
findShortestPath(int pointA, int pointB) | SnapObject
getBoundaryLoop() | SnapObject
getBoundaryLoopCentroids() | SnapObject
getBoundaryLoops() | SnapObject
getChoosenBoundaryLoop() | SnapObject
getClosestPoint(SnapObject *object) | SnapObject
getClosestSnappingRegionPoints(SnapObject *object) | SnapObject
getColors() | SnapObject
getDirtyBoundaryLoop() | SnapObject
getDirtyClosestPoint() | SnapObject
getDirtyGraph() | SnapObject
getDirtyMaxDistance() | SnapObject
getDirtySnappingRegion() | SnapObject
getEo() | SnapObject
getFaces() | SnapObject
getGeode() | SnapObject
getGeodeOf(osg::Node *eo) | SnapObject
getGeometry() | SnapObject
getGraph() | SnapObject
getId() | SnapObject
getMaxDistance() | SnapObject
getNormals() | SnapObject
getPartOfObject(int seed, set< int > cuttingLoopSet) | SnapObject
getPrimitiveSet() | SnapObject
getSimpleGraph() | SnapObject
getSnappingRegion() | SnapObject
getSnappingRegionValues() | SnapObject
getSnapRegion() | SnapObject
getSnapRegionWithDistanceSet() | SnapObject
getVertices() | SnapObject
isSuitable() | SnapObject
mergeObject(SnapObject *object) | SnapObject
optimalizeLoop(vector< int > &loop) | SnapObject
recomputeNormal() | SnapObject
setChoosenBoundaryLoop(unsigned long position) | SnapObject
setDirtyAll(bool dirty) | SnapObject
setDirtyBoundaryLoop(bool dirty) | SnapObject
setDirtyClosestPoint(bool dirty) | SnapObject
setDirtyGraph(bool dirty) | SnapObject
setDirtyMaxDistance(bool dirty) | SnapObject
setDirtySnappingRegion(bool dirty) | SnapObject
setEo(vrecko::EnvironmentObject *eo) | SnapObject
setId(unsigned long ID) | SnapObject
SnapObject() | SnapObject
SnapObject(int id) | SnapObject
SnapObject(int id, vrecko::EnvironmentObject *eo) | SnapObject
updateDisplayList() | SnapObject
~SnapObject() | SnapObject
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
StrX Member List

This is the complete list of members for StrX, including all inherited members.

localForm() const | StrX | inline
StrX(const XMLCh *const toTranscode) | StrX | inline
~StrX() | StrX | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SweepSurfaceGeode Member List

This is the complete list of members for SweepSurfaceGeode, including all inherited members.

_colorGen | SweepSurfaceGeode | protected
_crossSectionArray | SweepSurfaceGeode | protected
_crossSectionSpline | SweepSurfaceGeode | protected
_diameterGen | SweepSurfaceGeode | protected
_diameters | SweepSurfaceGeode | protected
_geometry | SweepSurfaceGeode | protected
_leadSpline | SweepSurfaceGeode | protected
_leadSplineArray | SweepSurfaceGeode | protected
_rfArray | SweepSurfaceGeode | protected
_rfGenerator | SweepSurfaceGeode | protected
_rotationAngles | SweepSurfaceGeode | protected
compute2DNormal(const osg::Vec3 &p1, const osg::Vec3 &p2) | SweepSurfaceGeode | inlineprotected
compute2DNormals() | SweepSurfaceGeode | protected
createDrawableObject() | SweepSurfaceGeode | protected
getColorGenerator() const | SweepSurfaceGeode | inline
getColorGenerator() | SweepSurfaceGeode | inline
getCrossSectionArray() const | SweepSurfaceGeode | inline
getCrossSectionSpline() const | SweepSurfaceGeode | inline
getCrossSectionSpline() | SweepSurfaceGeode | inline
getDiameterGenerator() const | SweepSurfaceGeode | inline
getDiameterGenerator() | SweepSurfaceGeode | inline
getLeadingSpline() const | SweepSurfaceGeode | inline
getLeadingSpline() | SweepSurfaceGeode | inline
getLeadSplineArray() const | SweepSurfaceGeode | inline
getRFGenerator() const | SweepSurfaceGeode | inline
getRFGenerator() | SweepSurfaceGeode | inline
META_Node(APDYNAMICART, SweepSurfaceGeode) | SweepSurfaceGeode |
setColorGenerator(ColorGenPtr val) | SweepSurfaceGeode | inline
setCrossSectionSpline(SplinePtr val) | SweepSurfaceGeode | inline
setDiameterGenerator(DiameterGenPtr val) | SweepSurfaceGeode | inline
setLeadingSpline(SplinePtr val) | SweepSurfaceGeode | inline
setRFGenerator(RotationFrameGeneratorPtr val) | SweepSurfaceGeode | inline
showDebugNormals() | SweepSurfaceGeode | protected
SweepSurfaceGeode() | SweepSurfaceGeode |
SweepSurfaceGeode(const SweepSurfaceGeode &, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY) | SweepSurfaceGeode |
traverse(osg::NodeVisitor &nv) | SweepSurfaceGeode | virtual
updateColorArray() | SweepSurfaceGeode | protected
updateGeometry() | SweepSurfaceGeode | protected
updateNormalArray() | SweepSurfaceGeode | protected
updatePrimitiveSet() | SweepSurfaceGeode | protected
updateVertexArray() | SweepSurfaceGeode | protected
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
ThinHeap< _NodeClass, _keyType > Member List

This is the complete list of members for ThinHeap< _NodeClass, _keyType >, including all inherited members.

Consolidate(void) | ThinHeap< _NodeClass, _keyType > | protected
DecreaseKey(_NodeClass *node, _keyType value) | ThinHeap< _NodeClass, _keyType > | virtual
Delete(_NodeClass *node) | ThinHeap< _NodeClass, _keyType > | virtual
ExtractMin(void) | ThinHeap< _NodeClass, _keyType > | virtual
GetMin(void) | ThinHeap< _NodeClass, _keyType > | virtual
head | ThinHeap< _NodeClass, _keyType > | protected
Insert(_NodeClass *node) | ThinHeap< _NodeClass, _keyType > | virtual
IsEmpty() | ThinHeap< _NodeClass, _keyType > | inlinevirtual
Link(_NodeClass *child, _NodeClass *parent) | ThinHeap< _NodeClass, _keyType > | protected
min | ThinHeap< _NodeClass, _keyType > | protected
RepairViolations(_NodeClass *node) | ThinHeap< _NodeClass, _keyType > | protectedvirtual
ThinHeap(void) | ThinHeap< _NodeClass, _keyType > |
Union(ThinHeap< _NodeClass, _keyType > *heap) | ThinHeap< _NodeClass, _keyType > | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ThinHeap
  • ThinHeapNode
ThinHeap< _NodeClass, _keyType >::ThinHeapNode Member List

This is the complete list of members for ThinHeap< _NodeClass, _keyType >::ThinHeapNode, including all inherited members.

child | ThinHeap< _NodeClass, _keyType >::ThinHeapNode
pl | ThinHeap< _NodeClass, _keyType >::ThinHeapNode
rank | ThinHeap< _NodeClass, _keyType >::ThinHeapNode
right | ThinHeap< _NodeClass, _keyType >::ThinHeapNode
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
TimeLineSpline Member List

This is the complete list of members for TimeLineSpline, including all inherited members.

_time | TimeLineSpline | protected
_timeStamps | TimeLineSpline | protected
META_DAObjectDecorator(_decoratedSpline, TimeLineSpline,"Time line Spline") virtual Vec3ArrayPtr getPoints() | TimeLineSpline |
setTime(double time) | TimeLineSpline |
TimeLineSpline(DoubleArrayPtr timeStamps, SplinePtr decoratedSpline) | TimeLineSpline |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Timing Member List

This is the complete list of members for Timing, including all inherited members.

pause(const unsigned int) | Timing |
setTimeout(const int t_ms) | Timing | inline
start() | Timing |
timedOut() | Timing |
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
UniformUpdateCallback Member List

This is the complete list of members for UniformUpdateCallback, including all inherited members.

operator()(osg::Uniform *un, osg::NodeVisitor *nv) | UniformUpdateCallback | inlinevirtual
UniformUpdateCallback(osg::Camera *_camera) | UniformUpdateCallback | inline
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
UserStream Member List

This is the complete list of members for UserStream, including all inherited members.

fp | UserStream |
readBuffer(void *buffer, NxU32 size) const | UserStream | virtual
readByte() const | UserStream | virtual
readDouble() const | UserStream | virtual
readDword() const | UserStream | virtual
readFloat() const | UserStream | virtual
readWord() const | UserStream | virtual
storeBuffer(const void *buffer, NxU32 size) | UserStream | virtual
storeByte(NxU8 b) | UserStream | virtual
storeDouble(NxF64 f) | UserStream | virtual
storeDword(NxU32 d) | UserStream | virtual
storeFloat(NxReal f) | UserStream | virtual
storeWord(NxU16 w) | UserStream | virtual
UserStream(const char *filename, bool load) | UserStream |
~UserStream() | UserStream | virtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VK_NoStepInto_Namespace
  • DynamicArray
VK_NoStepInto_Namespace::DynamicArray< _Type > Member List

This is the complete list of members for VK_NoStepInto_Namespace::DynamicArray< _Type >, including all inherited members.

Act(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
ActDWORD(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
ActInt(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
AddItem(const _Type &newItem) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
at(unsigned long dw) | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
at(unsigned long dw) const | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
clear(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
CopyFrom(DynamicArray< _Type > *src) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Delete(unsigned long dwStartIndex, unsigned long dwNumStructs) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
DeleteAll(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
DeleteUnnecessary(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
dwAlloc | VK_NoStepInto_Namespace::DynamicArray< _Type > | protected
dwAllocBy | VK_NoStepInto_Namespace::DynamicArray< _Type > | protected
dwInited | VK_NoStepInto_Namespace::DynamicArray< _Type > | protected
dwNum | VK_NoStepInto_Namespace::DynamicArray< _Type > |
DynamicArray(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
DynamicArray(unsigned long _dwAllocBy) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
DynamicArray(DynamicArray< _Type > &src) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
FreeArray(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Get(unsigned long index) | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
Get(unsigned long index) const | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
GetAllocated() | VK_NoStepInto_Namespace::DynamicArray< _Type > |
InitItems(unsigned long dwStartIndex, unsigned long dwNumStructs) | VK_NoStepInto_Namespace::DynamicArray< _Type > | protected
Insert(unsigned long dwStartIndex, unsigned long dwNumStructs) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Last(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
lpBuffer | VK_NoStepInto_Namespace::DynamicArray< _Type > |
operator[](unsigned long dw) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
operator[](unsigned long dw) const | VK_NoStepInto_Namespace::DynamicArray< _Type > |
PrepareNext(unsigned long _dwNum) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
push_back(const _Type &elem) | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
ReadByte(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
ReadDWORD(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
size() const | VK_NoStepInto_Namespace::DynamicArray< _Type > | inline
StoreByte(unsigned char bData) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
StoreDWORD(unsigned long dwData) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Swap(unsigned long dwIndex1, unsigned long dwIndex2) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Truncate(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
~DynamicArray(void) | VK_NoStepInto_Namespace::DynamicArray< _Type > |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Avatar
VirtualFixture::Avatar Member List

This is the complete list of members for VirtualFixture::Avatar, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
Avatar() | VirtualFixture::Avatar |
avatar_view | VirtualFixture::Avatar | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
free_move_EO | VirtualFixture::Avatar | protected
freeMoveEO_ID | VirtualFixture::Avatar | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Avatar |
head | VirtualFixture::Avatar | protected
headEO_ID | VirtualFixture::Avatar | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
left_hand | VirtualFixture::Avatar | protected
left_leg | VirtualFixture::Avatar | protected
leftHandEO_ID | VirtualFixture::Avatar | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Avatar | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | VirtualFixture::Avatar | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | VirtualFixture::Avatar | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::Avatar | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::Avatar |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
right_hand | VirtualFixture::Avatar | protected
right_leg | VirtualFixture::Avatar | protected
rightHandEO_ID | VirtualFixture::Avatar | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | VirtualFixture::Avatar | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~Avatar() | VirtualFixture::Avatar | inline
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • AxisLock
VirtualFixture::AxisLock Member List

This is the complete list of members for VirtualFixture::AxisLock, including all inherited members.

active | VirtualFixture::AxisLock | protected
all_on | VirtualFixture::AxisLock | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::AxisLock |
AxisLock() | VirtualFixture::AxisLock |
defstring | VirtualFixture::AxisLock | protected
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::AxisLock |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::AxisLock |
locked | VirtualFixture::AxisLock | protected
nullradius | VirtualFixture::AxisLock | protected
PHANToMDevice | VirtualFixture::AxisLock | protected
position | VirtualFixture::AxisLock | protected
postInitialize(void) | VirtualFixture::AxisLock |
preInitialize(void) | VirtualFixture::AxisLock |
processEvent(const std::string &input_name, void *value) | VirtualFixture::AxisLock |
stiffness | VirtualFixture::AxisLock | protected
update(void) | VirtualFixture::AxisLock |
~AxisLock() | VirtualFixture::AxisLock | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Border
VirtualFixture::Border Member List

This is the complete list of members for VirtualFixture::Border, including all inherited members.

active | VirtualFixture::Border | protected
all_on | VirtualFixture::Border | protected
amplitude | VirtualFixture::Border | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Border |
Border() | VirtualFixture::Border |
color | VirtualFixture::Border | protected
color2 | VirtualFixture::Border | protected
direction | VirtualFixture::Border | protected
display(void) | VirtualFixture::Border |
frequency | VirtualFixture::Border | protected
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Border |
gnode | VirtualFixture::Border | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Border |
node | VirtualFixture::Border | protected
node2 | VirtualFixture::Border | protected
PHANToMDevice | VirtualFixture::Border | protected
postInitialize(void) | VirtualFixture::Border |
preInitialize(void) | VirtualFixture::Border |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Border |
tnode | VirtualFixture::Border | protected
transparency | VirtualFixture::Border | protected
transparency2 | VirtualFixture::Border | protected
update(void) | VirtualFixture::Border |
visible | VirtualFixture::Border | protected
~Border() | VirtualFixture::Border | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Box
VirtualFixture::Box Member List

This is the complete list of members for VirtualFixture::Box, including all inherited members.

active | VirtualFixture::Box | protected
all_on | VirtualFixture::Box | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Box |
Box() | VirtualFixture::Box |
color | VirtualFixture::Box | protected
display(void) | VirtualFixture::Box |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Box |
gnode | VirtualFixture::Box | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Box |
node | VirtualFixture::Box | protected
nullsize | VirtualFixture::Box | protected
PHANToMDevice | VirtualFixture::Box | protected
position | VirtualFixture::Box | protected
postInitialize(void) | VirtualFixture::Box |
preInitialize(void) | VirtualFixture::Box |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Box |
size | VirtualFixture::Box | protected
stiffness | VirtualFixture::Box | protected
tnode | VirtualFixture::Box | protected
transparency | VirtualFixture::Box | protected
update(void) | VirtualFixture::Box |
visible | VirtualFixture::Box | protected
~Box() | VirtualFixture::Box | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Cone
VirtualFixture::Cone Member List

This is the complete list of members for VirtualFixture::Cone, including all inherited members.

active | VirtualFixture::Cone | protected
all_on | VirtualFixture::Cone | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Cone |
color | VirtualFixture::Cone | protected
color2 | VirtualFixture::Cone | protected
Cone() | VirtualFixture::Cone |
display(void) | VirtualFixture::Cone |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Cone |
gnode | VirtualFixture::Cone | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Cone |
node | VirtualFixture::Cone | protected
node2 | VirtualFixture::Cone | protected
nullradius | VirtualFixture::Cone | protected
PHANToMDevice | VirtualFixture::Cone | protected
position | VirtualFixture::Cone | protected
postInitialize(void) | VirtualFixture::Cone |
preInitialize(void) | VirtualFixture::Cone |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Cone |
pushing | VirtualFixture::Cone | protected
pushingforce | VirtualFixture::Cone | protected
radius1 | VirtualFixture::Cone | protected
radius2 | VirtualFixture::Cone | protected
stiffness | VirtualFixture::Cone | protected
tnode | VirtualFixture::Cone | protected
transparency | VirtualFixture::Cone | protected
transparency2 | VirtualFixture::Cone | protected
update(void) | VirtualFixture::Cone |
vector | VirtualFixture::Cone | protected
visible | VirtualFixture::Cone | protected
~Cone() | VirtualFixture::Cone | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Cylinder
VirtualFixture::Cylinder Member List

This is the complete list of members for VirtualFixture::Cylinder, including all inherited members.

active | VirtualFixture::Cylinder | protected
all_on | VirtualFixture::Cylinder | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Cylinder |
color | VirtualFixture::Cylinder | protected
color2 | VirtualFixture::Cylinder | protected
Cylinder() | VirtualFixture::Cylinder |
display(void) | VirtualFixture::Cylinder |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Cylinder |
gnode | VirtualFixture::Cylinder | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Cylinder |
node | VirtualFixture::Cylinder | protected
node2 | VirtualFixture::Cylinder | protected
nullradius | VirtualFixture::Cylinder | protected
PHANToMDevice | VirtualFixture::Cylinder | protected
position | VirtualFixture::Cylinder | protected
postInitialize(void) | VirtualFixture::Cylinder |
preInitialize(void) | VirtualFixture::Cylinder |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Cylinder |
pushing | VirtualFixture::Cylinder | protected
pushingforce | VirtualFixture::Cylinder | protected
radius | VirtualFixture::Cylinder | protected
stiffness | VirtualFixture::Cylinder | protected
tnode | VirtualFixture::Cylinder | protected
transparency | VirtualFixture::Cylinder | protected
transparency2 | VirtualFixture::Cylinder | protected
update(void) | VirtualFixture::Cylinder |
vector | VirtualFixture::Cylinder | protected
visible | VirtualFixture::Cylinder | protected
~Cylinder() | VirtualFixture::Cylinder | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Damper
VirtualFixture::Damper Member List

This is the complete list of members for VirtualFixture::Damper, including all inherited members.

active | VirtualFixture::Damper | protected
all_on | VirtualFixture::Damper | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Damper |
Damper() | VirtualFixture::Damper |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Damper |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Damper |
minspeed | VirtualFixture::Damper | protected
PHANToMDevice | VirtualFixture::Damper | protected
postInitialize(void) | VirtualFixture::Damper |
preInitialize(void) | VirtualFixture::Damper |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Damper |
speed2force | VirtualFixture::Damper | protected
update(void) | VirtualFixture::Damper |
~Damper() | VirtualFixture::Damper | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Drag
VirtualFixture::Drag Member List

This is the complete list of members for VirtualFixture::Drag, including all inherited members.

active | VirtualFixture::Drag | protected
all_on | VirtualFixture::Drag | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Drag |
dispatchEvent(const std::string &pInputName, void *pValue) | VirtualFixture::Drag |
dispatchMessage(Message *pMessage) | VirtualFixture::Drag |
displayAllGestures(void) | VirtualFixture::Drag |
Drag() | VirtualFixture::Drag |
force | VirtualFixture::Drag | protected
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Drag |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Drag |
PHANToMDevice | VirtualFixture::Drag | protected
player | VirtualFixture::Drag | protected
position | VirtualFixture::Drag | protected
postInitialize(void) | VirtualFixture::Drag |
preInitialize(void) | VirtualFixture::Drag |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Drag |
update(void) | VirtualFixture::Drag |
~Drag() | VirtualFixture::Drag | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Filter
VirtualFixture::Filter Member List

This is the complete list of members for VirtualFixture::Filter, including all inherited members.

active | VirtualFixture::Filter | protected
all_on | VirtualFixture::Filter | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Filter |
Filter() | VirtualFixture::Filter |
Filter_GetPosition(void) | VirtualFixture::Filter |
Filter_GetVelocity(void) | VirtualFixture::Filter |
Filter_Initialize(void) | VirtualFixture::Filter |
Filter_Mesurement(osg::Vec3 z) | VirtualFixture::Filter |
Filter_Prediction(void) | VirtualFixture::Filter |
Filter_SetX_hat1(osg::Vec3 nx) | VirtualFixture::Filter |
Filter_SetX_hat2(osg::Vec3 nx) | VirtualFixture::Filter |
Filter_Update(void) | VirtualFixture::Filter |
freq | VirtualFixture::Filter | protected
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Filter |
inovation | VirtualFixture::Filter | protected
k1 | VirtualFixture::Filter | protected
k2 | VirtualFixture::Filter | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Filter |
PHANToMDevice | VirtualFixture::Filter | protected
postInitialize(void) | VirtualFixture::Filter |
preInitialize(void) | VirtualFixture::Filter |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Filter |
update(void) | VirtualFixture::Filter |
x_hat1 | VirtualFixture::Filter | protected
x_hat2 | VirtualFixture::Filter | protected
x_hat_prev1 | VirtualFixture::Filter | protected
x_hat_prev2 | VirtualFixture::Filter | protected
~Filter() | VirtualFixture::Filter | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Grid
VirtualFixture::Grid Member List

This is the complete list of members for VirtualFixture::Grid, including all inherited members.

active | VirtualFixture::Grid | protected
all_on | VirtualFixture::Grid | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Grid |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Grid |
gravity | VirtualFixture::Grid | protected
gravity_on | VirtualFixture::Grid | protected
Grid() | VirtualFixture::Grid |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Grid |
nullradius | VirtualFixture::Grid | protected
PHANToMDevice | VirtualFixture::Grid | protected
position | VirtualFixture::Grid | protected
postInitialize(void) | VirtualFixture::Grid |
preInitialize(void) | VirtualFixture::Grid |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Grid |
stiffness | VirtualFixture::Grid | protected
update(void) | VirtualFixture::Grid |
vector | VirtualFixture::Grid | protected
~Grid() | VirtualFixture::Grid | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Log
VirtualFixture::Log Member List

This is the complete list of members for VirtualFixture::Log, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Log |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Log | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
Log() | VirtualFixture::Log |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
position | VirtualFixture::Log | protected
postInitialize(void) | VirtualFixture::Log | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::Log | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::Log |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | VirtualFixture::Log | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Log() | VirtualFixture::Log | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Marker
VirtualFixture::Marker Member List

This is the complete list of members for VirtualFixture::Marker, including all inherited members.

active | VirtualFixture::Marker | protected
all_on | VirtualFixture::Marker | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Marker |
describtion | VirtualFixture::Marker | protected
getDescribtion() | VirtualFixture::Marker | inline
getId() | VirtualFixture::Marker | inline
getLabel() | VirtualFixture::Marker | inline
getPosition() | VirtualFixture::Marker | inline
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Marker |
id | VirtualFixture::Marker | protected
label | VirtualFixture::Marker | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Marker |
Marker() | VirtualFixture::Marker |
Marker(int newid, osg::Vec3 newposition) | VirtualFixture::Marker |
Marker(int newid, osg::Vec3 newposition, std::string newlabel, std::string newdescribtion) | VirtualFixture::Marker |
PHANToMDevice | VirtualFixture::Marker | protected
position | VirtualFixture::Marker | protected
postInitialize(void) | VirtualFixture::Marker |
preInitialize(void) | VirtualFixture::Marker |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Marker |
setDescribtion(std::string newdescribtion) | VirtualFixture::Marker | inline
setId(int newid) | VirtualFixture::Marker | inline
setLabel(std::string newlabel) | VirtualFixture::Marker | inline
setPosition(osg::Vec3 newposition) | VirtualFixture::Marker | inline
update(void) | VirtualFixture::Marker |
~Marker() | VirtualFixture::Marker | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • MarkerFactory
VirtualFixture::MarkerFactory Member List

This is the complete list of members for VirtualFixture::MarkerFactory, including all inherited members.

act_position | VirtualFixture::MarkerFactory | protected
active | VirtualFixture::MarkerFactory | protected
addMarker() | VirtualFixture::MarkerFactory |
all_on | VirtualFixture::MarkerFactory | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::MarkerFactory |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::MarkerFactory |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::MarkerFactory |
MarkerFactory() | VirtualFixture::MarkerFactory |
markers | VirtualFixture::MarkerFactory | protected
num_of_markers | VirtualFixture::MarkerFactory | protected
PHANToMDevice | VirtualFixture::MarkerFactory | protected
postInitialize(void) | VirtualFixture::MarkerFactory |
preInitialize(void) | VirtualFixture::MarkerFactory |
processEvent(const std::string &input_name, void *value) | VirtualFixture::MarkerFactory |
removeAllMarkers() | VirtualFixture::MarkerFactory |
update(void) | VirtualFixture::MarkerFactory |
~MarkerFactory() | VirtualFixture::MarkerFactory | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • NavSphere
VirtualFixture::NavSphere Member List

This is the complete list of members for VirtualFixture::NavSphere, including all inherited members.

actdir | VirtualFixture::NavSphere | protected
active | VirtualFixture::NavSphere | protected
actpos | VirtualFixture::NavSphere | protected
all_on | VirtualFixture::NavSphere | protected
amplitude | VirtualFixture::NavSphere | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::NavSphere |
attenuationparam | VirtualFixture::NavSphere | protected
attenuationtype | VirtualFixture::NavSphere | protected
color | VirtualFixture::NavSphere | protected
direction | VirtualFixture::NavSphere | protected
display(void) | VirtualFixture::NavSphere |
frequency | VirtualFixture::NavSphere | protected
geom | VirtualFixture::NavSphere | protected
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::NavSphere |
gnode | VirtualFixture::NavSphere | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::NavSphere |
NavSphere() | VirtualFixture::NavSphere |
node | VirtualFixture::NavSphere | protected
origin | VirtualFixture::NavSphere | protected
PHANToMDevice | VirtualFixture::NavSphere | protected
postInitialize(void) | VirtualFixture::NavSphere |
preInitialize(void) | VirtualFixture::NavSphere |
processEvent(const std::string &input_name, void *value) | VirtualFixture::NavSphere |
radius | VirtualFixture::NavSphere | protected
stiffness | VirtualFixture::NavSphere | protected
store_origin_flag | VirtualFixture::NavSphere | protected
tnode | VirtualFixture::NavSphere | protected
transparency | VirtualFixture::NavSphere | protected
update(void) | VirtualFixture::NavSphere |
vibration_flag | VirtualFixture::NavSphere | protected
visible | VirtualFixture::NavSphere | protected
~NavSphere() | VirtualFixture::NavSphere | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Plane
VirtualFixture::Plane Member List

This is the complete list of members for VirtualFixture::Plane, including all inherited members.

active | VirtualFixture::Plane | protected
all_on | VirtualFixture::Plane | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Plane |
color | VirtualFixture::Plane | protected
color2 | VirtualFixture::Plane | protected
display(void) | VirtualFixture::Plane |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Plane |
gnode | VirtualFixture::Plane | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Plane |
node | VirtualFixture::Plane | protected
node2 | VirtualFixture::Plane | protected
nullradius | VirtualFixture::Plane | protected
PHANToMDevice | VirtualFixture::Plane | protected
Plane() | VirtualFixture::Plane |
position | VirtualFixture::Plane | protected
postInitialize(void) | VirtualFixture::Plane |
preInitialize(void) | VirtualFixture::Plane |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Plane |
pushing | VirtualFixture::Plane | protected
pushingforce | VirtualFixture::Plane | protected
radius | VirtualFixture::Plane | protected
stiffness | VirtualFixture::Plane | protected
tnode | VirtualFixture::Plane | protected
transparency | VirtualFixture::Plane | protected
transparency2 | VirtualFixture::Plane | protected
update(void) | VirtualFixture::Plane |
vector | VirtualFixture::Plane | protected
visible | VirtualFixture::Plane | protected
~Plane() | VirtualFixture::Plane | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiBorder
VirtualFixture::ProxiBorder Member List

This is the complete list of members for VirtualFixture::ProxiBorder, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::ProxiBorder | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | VirtualFixture::ProxiBorder | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::ProxiBorder | protected
color2 | VirtualFixture::ProxiBorder | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::ProxiBorder |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::ProxiBorder |
gnode | VirtualFixture::ProxiBorder | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
justonce | VirtualFixture::ProxiBorder | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::ProxiBorder | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
node | VirtualFixture::ProxiBorder | protected
node2 | VirtualFixture::ProxiBorder | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
once | VirtualFixture::ProxiBorder | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | VirtualFixture::ProxiBorder | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | VirtualFixture::ProxiBorder | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::ProxiBorder | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::ProxiBorder |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProxiBorder() | VirtualFixture::ProxiBorder |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendflag | VirtualFixture::ProxiBorder | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tnode | VirtualFixture::ProxiBorder | protected
transparency | VirtualFixture::ProxiBorder | protected
transparency2 | VirtualFixture::ProxiBorder | protected
update(void) | VirtualFixture::ProxiBorder | virtual
updated | vrecko::Ability | protected
visible | VirtualFixture::ProxiBorder | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ProxiBorder() | VirtualFixture::ProxiBorder | inline
Generated on Sun Feb 17 2013 23:30:11 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiBox
VirtualFixture::ProxiBox Member List

This is the complete list of members for VirtualFixture::ProxiBox, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::ProxiBox | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | VirtualFixture::ProxiBox | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::ProxiBox | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::ProxiBox |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::ProxiBox |
gnode | VirtualFixture::ProxiBox | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
justonce | VirtualFixture::ProxiBox | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::ProxiBox | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
node | VirtualFixture::ProxiBox | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
once | VirtualFixture::ProxiBox | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | VirtualFixture::ProxiBox | protected
PinList typedef | vrecko::BaseClass | protected
position | VirtualFixture::ProxiBox | protected
postInitialize(void) | VirtualFixture::ProxiBox | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::ProxiBox | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::ProxiBox |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProxiBox() | VirtualFixture::ProxiBox |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendflag | VirtualFixture::ProxiBox | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
size | VirtualFixture::ProxiBox | protected
tnode | VirtualFixture::ProxiBox | protected
transparency | VirtualFixture::ProxiBox | protected
update(void) | VirtualFixture::ProxiBox | virtual
updated | vrecko::Ability | protected
visible | VirtualFixture::ProxiBox | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ProxiBox() | VirtualFixture::ProxiBox | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiCone
VirtualFixture::ProxiCone Member List

This is the complete list of members for VirtualFixture::ProxiCone, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::ProxiCone | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | VirtualFixture::ProxiCone | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::ProxiCone | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::ProxiCone |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::ProxiCone |
gnode | VirtualFixture::ProxiCone | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
justonce | VirtualFixture::ProxiCone | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::ProxiCone | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
node | VirtualFixture::ProxiCone | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
once | VirtualFixture::ProxiCone | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | VirtualFixture::ProxiCone | protected
PinList typedef | vrecko::BaseClass | protected
position | VirtualFixture::ProxiCone | protected
postInitialize(void) | VirtualFixture::ProxiCone | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::ProxiCone | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::ProxiCone |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProxiCone() | VirtualFixture::ProxiCone |
radius | VirtualFixture::ProxiCone | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendflag | VirtualFixture::ProxiCone | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tnode | VirtualFixture::ProxiCone | protected
transparency | VirtualFixture::ProxiCone | protected
update(void) | VirtualFixture::ProxiCone | virtual
updated | vrecko::Ability | protected
visible | VirtualFixture::ProxiCone | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ProxiCone() | VirtualFixture::ProxiCone | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiCylinder
VirtualFixture::ProxiCylinder Member List

This is the complete list of members for VirtualFixture::ProxiCylinder, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::ProxiCylinder | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | VirtualFixture::ProxiCylinder | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::ProxiCylinder | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::ProxiCylinder |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::ProxiCylinder |
gnode | VirtualFixture::ProxiCylinder | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
justonce | VirtualFixture::ProxiCylinder | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::ProxiCylinder | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
node | VirtualFixture::ProxiCylinder | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
once | VirtualFixture::ProxiCylinder | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | VirtualFixture::ProxiCylinder | protected
PinList typedef | vrecko::BaseClass | protected
position | VirtualFixture::ProxiCylinder | protected
postInitialize(void) | VirtualFixture::ProxiCylinder | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::ProxiCylinder | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::ProxiCylinder |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProxiCylinder() | VirtualFixture::ProxiCylinder |
radius | VirtualFixture::ProxiCylinder | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendflag | VirtualFixture::ProxiCylinder | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tnode | VirtualFixture::ProxiCylinder | protected
transparency | VirtualFixture::ProxiCylinder | protected
update(void) | VirtualFixture::ProxiCylinder | virtual
updated | vrecko::Ability | protected
vector | VirtualFixture::ProxiCylinder | protected
visible | VirtualFixture::ProxiCylinder | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ProxiCylinder() | VirtualFixture::ProxiCylinder | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • ProxiSphere
VirtualFixture::ProxiSphere Member List

This is the complete list of members for VirtualFixture::ProxiSphere, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::ProxiSphere | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
all_on | VirtualFixture::ProxiSphere | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::ProxiSphere | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::ProxiSphere |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::ProxiSphere |
gnode | VirtualFixture::ProxiSphere | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
justonce | VirtualFixture::ProxiSphere | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::ProxiSphere | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
node | VirtualFixture::ProxiSphere | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
once | VirtualFixture::ProxiSphere | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PHANToMDevice | VirtualFixture::ProxiSphere | protected
PinList typedef | vrecko::BaseClass | protected
position | VirtualFixture::ProxiSphere | protected
postInitialize(void) | VirtualFixture::ProxiSphere | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::ProxiSphere | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::ProxiSphere |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
ProxiSphere() | VirtualFixture::ProxiSphere |
radius | VirtualFixture::ProxiSphere | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendflag | VirtualFixture::ProxiSphere | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tnode | VirtualFixture::ProxiSphere | protected
transparency | VirtualFixture::ProxiSphere | protected
update(void) | VirtualFixture::ProxiSphere | virtual
updated | vrecko::Ability | protected
visible | VirtualFixture::ProxiSphere | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ProxiSphere() | VirtualFixture::ProxiSphere | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Sphere
VirtualFixture::Sphere Member List

This is the complete list of members for VirtualFixture::Sphere, including all inherited members.

active | VirtualFixture::Sphere | protected
all_on | VirtualFixture::Sphere | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Sphere |
color | VirtualFixture::Sphere | protected
color2 | VirtualFixture::Sphere | protected
display(void) | VirtualFixture::Sphere |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Sphere |
gnode | VirtualFixture::Sphere | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Sphere |
node | VirtualFixture::Sphere | protected
node2 | VirtualFixture::Sphere | protected
nullradius | VirtualFixture::Sphere | protected
PHANToMDevice | VirtualFixture::Sphere | protected
position | VirtualFixture::Sphere | protected
postInitialize(void) | VirtualFixture::Sphere |
preInitialize(void) | VirtualFixture::Sphere |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Sphere |
radius | VirtualFixture::Sphere | protected
Sphere() | VirtualFixture::Sphere |
stiffness | VirtualFixture::Sphere | protected
tnode | VirtualFixture::Sphere | protected
transparency | VirtualFixture::Sphere | protected
transparency2 | VirtualFixture::Sphere | protected
update(void) | VirtualFixture::Sphere |
visible | VirtualFixture::Sphere | protected
~Sphere() | VirtualFixture::Sphere | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Trace
VirtualFixture::Trace Member List

This is the complete list of members for VirtualFixture::Trace, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | VirtualFixture::Trace | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addMarker(osg::Vec3 position) | VirtualFixture::Trace |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
color | VirtualFixture::Trace | protected
color2 | VirtualFixture::Trace | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
display(void) | VirtualFixture::Trace |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Trace |
gnode | VirtualFixture::Trace | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
latestpos | VirtualFixture::Trace | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Trace | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mindistance | VirtualFixture::Trace | protected
node | VirtualFixture::Trace | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
num_of_markers | VirtualFixture::Trace | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | VirtualFixture::Trace | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | VirtualFixture::Trace | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | VirtualFixture::Trace |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
radius | VirtualFixture::Trace | protected
removeAllMarkers() | VirtualFixture::Trace |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tnode | VirtualFixture::Trace | protected
Trace() | VirtualFixture::Trace |
transparency | VirtualFixture::Trace | protected
transparency2 | VirtualFixture::Trace | protected
update(void) | VirtualFixture::Trace | virtual
updated | vrecko::Ability | protected
visible | VirtualFixture::Trace | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Trace() | VirtualFixture::Trace | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • Vibration
VirtualFixture::Vibration Member List

This is the complete list of members for VirtualFixture::Vibration, including all inherited members.

active | VirtualFixture::Vibration |
all_on | VirtualFixture::Vibration | protected
amplitude | VirtualFixture::Vibration |
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::Vibration |
direction | VirtualFixture::Vibration |
duration | VirtualFixture::Vibration |
frequency | VirtualFixture::Vibration |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::Vibration |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::Vibration |
PHANToMDevice | VirtualFixture::Vibration | protected
postInitialize(void) | VirtualFixture::Vibration |
preInitialize(void) | VirtualFixture::Vibration |
processEvent(const std::string &input_name, void *value) | VirtualFixture::Vibration |
update(void) | VirtualFixture::Vibration |
Vibration() | VirtualFixture::Vibration |
vstart_tick | VirtualFixture::Vibration |
~Vibration() | VirtualFixture::Vibration | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • VibrationLabel
VirtualFixture::VibrationLabel Member List

This is the complete list of members for VirtualFixture::VibrationLabel, including all inherited members.

active | VirtualFixture::VibrationLabel |
all_on | VirtualFixture::VibrationLabel | protected
amplitude | VirtualFixture::VibrationLabel |
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::VibrationLabel |
direction | VirtualFixture::VibrationLabel |
frequency | VirtualFixture::VibrationLabel |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::VibrationLabel |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::VibrationLabel |
PHANToMDevice | VirtualFixture::VibrationLabel | protected
postInitialize(void) | VirtualFixture::VibrationLabel |
preInitialize(void) | VirtualFixture::VibrationLabel |
processEvent(const std::string &input_name, void *value) | VirtualFixture::VibrationLabel |
update(void) | VirtualFixture::VibrationLabel |
VibrationLabel() | VirtualFixture::VibrationLabel |
~VibrationLabel() | VirtualFixture::VibrationLabel | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • VirtualFixture
  • VibrationLabelActivator
VirtualFixture::VibrationLabelActivator Member List

This is the complete list of members for VirtualFixture::VibrationLabelActivator, including all inherited members.

active | VirtualFixture::VibrationLabelActivator | protected
all_on | VirtualFixture::VibrationLabelActivator | protected
apply(PHANToM *pPHANToM, osg::Vec3 &force) | VirtualFixture::VibrationLabelActivator |
getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | VirtualFixture::VibrationLabelActivator |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | VirtualFixture::VibrationLabelActivator |
PHANToMDevice | VirtualFixture::VibrationLabelActivator | protected
postInitialize(void) | VirtualFixture::VibrationLabelActivator |
preInitialize(void) | VirtualFixture::VibrationLabelActivator |
processEvent(const std::string &input_name, void *value) | VirtualFixture::VibrationLabelActivator |
update(void) | VirtualFixture::VibrationLabelActivator |
VibrationLabelActivator() | VirtualFixture::VibrationLabelActivator |
~VibrationLabelActivator() | VirtualFixture::VibrationLabelActivator | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • BuildMesh
WAVEFRONT::BuildMesh Member List

This is the complete list of members for WAVEFRONT::BuildMesh, including all inherited members.

GetIndex(const float *p, const float *texCoord) | WAVEFRONT::BuildMesh | inline
GetIndices(void) const | WAVEFRONT::BuildMesh | inline
GetTexCoords(void) const | WAVEFRONT::BuildMesh | inline
GetVertices(void) const | WAVEFRONT::BuildMesh | inline
NodeTriangle(const GeometryVertex *v1, const GeometryVertex *v2, const GeometryVertex *v3, bool textured) | WAVEFRONT::BuildMesh | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • GeometryInterface
WAVEFRONT::GeometryInterface Member List

This is the complete list of members for WAVEFRONT::GeometryInterface, including all inherited members.

NodeTriangle(const GeometryVertex *v1, const GeometryVertex *v2, const GeometryVertex *v3, bool textured) WAVEFRONT::GeometryInterface inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • GeometryVertex
WAVEFRONT::GeometryVertex Member List

This is the complete list of members for WAVEFRONT::GeometryVertex, including all inherited members.

mNormal | WAVEFRONT::GeometryVertex
mPos | WAVEFRONT::GeometryVertex
mTexel | WAVEFRONT::GeometryVertex
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • InPlaceParser
WAVEFRONT::InPlaceParser Member List

This is the complete list of members for WAVEFRONT::InPlaceParser, including all inherited members.

ClearHardSeparator(char c) | WAVEFRONT::InPlaceParser | inline
DefaultSymbols(void) | WAVEFRONT::InPlaceParser |
EOS(char c) | WAVEFRONT::InPlaceParser | inline
GetArglist(char *source, int &count) | WAVEFRONT::InPlaceParser |
Init(void) | WAVEFRONT::InPlaceParser | inline
InPlaceParser(void) | WAVEFRONT::InPlaceParser | inline
InPlaceParser(char *data, int len) | WAVEFRONT::InPlaceParser | inline
InPlaceParser(const char *fname) | WAVEFRONT::InPlaceParser | inline
Parse(InPlaceParserInterface *callback) | WAVEFRONT::InPlaceParser |
ProcessLine(int lineno, char *line, InPlaceParserInterface *callback) | WAVEFRONT::InPlaceParser |
SetCommentSymbol(char c) | WAVEFRONT::InPlaceParser | inline
SetFile(const char *fname) | WAVEFRONT::InPlaceParser |
SetHard(char c) | WAVEFRONT::InPlaceParser | inline
SetHardSeparator(char c) | WAVEFRONT::InPlaceParser | inline
SetQuoteChar(char c) | WAVEFRONT::InPlaceParser | inline
SetSourceData(char *data, int len) | WAVEFRONT::InPlaceParser | inline
~InPlaceParser(void) | WAVEFRONT::InPlaceParser |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • InPlaceParserInterface
WAVEFRONT::InPlaceParserInterface Member List

This is the complete list of members for WAVEFRONT::InPlaceParserInterface, including all inherited members.

ParseLine(int lineno, int argc, const char **argv)=0 WAVEFRONT::InPlaceParserInterface pure virtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WAVEFRONT
  • OBJ
WAVEFRONT::OBJ Member List

This is the complete list of members for WAVEFRONT::OBJ, including all inherited members.

LoadMesh(const char *fname, GeometryInterface *callback, bool textured) | WAVEFRONT::OBJ |
ParseLine(int lineno, int argc, const char **argv) | WAVEFRONT::OBJ | virtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Geometry
WGeometry::WG_Geometry Member List

This is the complete list of members for WGeometry::WG_Geometry, including all inherited members.

barycentricTest(osg::Vec2 P, osg::Vec2 A, osg::Vec2 B, osg::Vec2 C) | WGeometry::WG_Geometry | inlinestatic
getAngle(osg::Vec2 &vector) | WGeometry::WG_Geometry | inlinestatic
getCrossingPoint(osg::Vec2 &destPoint, osg::Vec2 pPoint, osg::Vec2 pNormal, osg::Vec2 rPoint, osg::Vec2 rNormal, bool justStroke) | WGeometry::WG_Geometry | inlinestatic
WG_Geometry() | WGeometry::WG_Geometry | inline
~WG_Geometry() | WGeometry::WG_Geometry | inline
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Hole
WGeometry::WG_Hole Member List

This is the complete list of members for WGeometry::WG_Hole, including all inherited members.

getHeight() | WGeometry::WG_Hole | inline
getPosition() | WGeometry::WG_Hole | inline
getQVertices() | WGeometry::WG_Hole | inline
getRVertices() | WGeometry::WG_Hole | inline
getType() | WGeometry::WG_Hole | inline
getWidth() | WGeometry::WG_Hole | inline
getY() | WGeometry::WG_Hole | inline
setHeight(float height) | WGeometry::WG_Hole | inline
setPosition(float position) | WGeometry::WG_Hole | inline
setType(HoleType type) | WGeometry::WG_Hole | inline
setWidth(float width) | WGeometry::WG_Hole | inline
setY(float y) | WGeometry::WG_Hole | inline
WG_Hole(float position, float y, float height, float width, HoleType type) | WGeometry::WG_Hole | inline
~WG_Hole() | WGeometry::WG_Hole | inline
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Point
WGeometry::WG_Point Member List

This is the complete list of members for WGeometry::WG_Point, including all inherited members.

addWall(WG_Wall *wall, PointType connectionPointType, bool compute=true) | WGeometry::WG_Point |
getHeight() | WGeometry::WG_Point | inline
getId() | WGeometry::WG_Point | inline
getIndexBottom() | WGeometry::WG_Point | inline
getIndexTop() | WGeometry::WG_Point | inline
getPlusColors() | WGeometry::WG_Point | inline
getPlusNormals() | WGeometry::WG_Point | inline
getPlusVertices() | WGeometry::WG_Point | inline
getPosition() | WGeometry::WG_Point | inline
getWallNeighbours(WG_Wall *wall, std::pair< osg::ref_ptr< WG_Wall >, PointType > &wallCW, std::pair< osg::ref_ptr< WG_Wall >, PointType > &wallCCW) | WGeometry::WG_Point |
getWalls() | WGeometry::WG_Point | inline
removeWall(WG_Wall *wall) | WGeometry::WG_Point |
setId(unsigned int i) | WGeometry::WG_Point | inline
setIndexBottom(unsigned int i) | WGeometry::WG_Point | inline
setIndexTop(unsigned int i) | WGeometry::WG_Point | inline
setPosition(osg::Vec2 position) | WGeometry::WG_Point | inline
WG_Point(osg::Vec2 position, float height=RE_DEFAULT_HEIGHT) | WGeometry::WG_Point | inline
~WG_Point() | WGeometry::WG_Point | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Vertices
WGeometry::WG_Vertices Member List

This is the complete list of members for WGeometry::WG_Vertices, including all inherited members.

areValidVertices() | WGeometry::WG_Vertices | inline
getBottomCCWVertex() | WGeometry::WG_Vertices | inline
getBottomCWVertex() | WGeometry::WG_Vertices | inline
getNormalCCWVertex() | WGeometry::WG_Vertices | inline
getNormalCWVertex() | WGeometry::WG_Vertices | inline
getTopCCWVertex() | WGeometry::WG_Vertices | inline
getTopCWVertex() | WGeometry::WG_Vertices | inline
setBottomCCWVertex(osg::Vec3 P) | WGeometry::WG_Vertices | inline
setBottomCWVertex(osg::Vec3 P) | WGeometry::WG_Vertices | inline
setNormalCCWVertex(osg::Vec2 P) | WGeometry::WG_Vertices | inline
setNormalCWVertex(osg::Vec2 P) | WGeometry::WG_Vertices | inline
setTopCCWVertex(osg::Vec3 P) | WGeometry::WG_Vertices | inline
setTopCWVertex(osg::Vec3 P) | WGeometry::WG_Vertices | inline
setValidVertices(bool valid) | WGeometry::WG_Vertices | inline
WG_Vertices() | WGeometry::WG_Vertices | inline
~WG_Vertices() | WGeometry::WG_Vertices | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WGeometry
  • WG_Wall
WGeometry::WG_Wall Member List

This is the complete list of members for WGeometry::WG_Wall, including all inherited members.

areAnglesComputed() | WGeometry::WG_Wall | inline
computeAttrNormals() | WGeometry::WG_Wall |
computeAttrVectorsAndAngles() | WGeometry::WG_Wall |
computeAttrVertices(PointType type) | WGeometry::WG_Wall |
computeAttrVertices() | WGeometry::WG_Wall | inline
computeHoleVertices() | WGeometry::WG_Wall |
getAngle(PointType type) | WGeometry::WG_Wall | inline
getBottomNormal() | WGeometry::WG_Wall | inline
getColor(PointType type) | WGeometry::WG_Wall | inline
getFaceNormal(PointType type) | WGeometry::WG_Wall | inline
getFlag() | WGeometry::WG_Wall | inline
getHoles() | WGeometry::WG_Wall | inline
getId() | WGeometry::WG_Wall | inline
getPoint(PointType type) | WGeometry::WG_Wall | inline
getPointRef(PointType type) | WGeometry::WG_Wall | inline
getTopNormal() | WGeometry::WG_Wall | inline
getVector(PointType type) | WGeometry::WG_Wall | inline
getVertices(PointType type) | WGeometry::WG_Wall | inline
setBottomNormal(osg::Vec3 n) | WGeometry::WG_Wall | inline
setColor(osg::Vec3 color, PointType type) | WGeometry::WG_Wall | inline
setFaceNormal(osg::Vec3 n, PointType type) | WGeometry::WG_Wall | inline
setFlag(int flag) | WGeometry::WG_Wall | inline
setId(unsigned int i) | WGeometry::WG_Wall | inline
setPoint(WG_Point *point, PointType type) | WGeometry::WG_Wall | inline
setPoints(WG_Point *qPoint, WG_Point *rPoint) | WGeometry::WG_Wall | inline
setTopNormal(osg::Vec3 n) | WGeometry::WG_Wall | inline
WG_Wall(WG_Point *qPoint, WG_Point *rPoint, bool compute=true) | WGeometry::WG_Wall | inline
~WG_Wall() | WGeometry::WG_Wall | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
WavefrontObj Member List

This is the complete list of members for WavefrontObj, including all inherited members.

loadObj(const char *fname, bool textured) | WavefrontObj
mIndices | WavefrontObj
mTexCoords | WavefrontObj
mTriCount | WavefrontObj
mVertexCount | WavefrontObj
mVertices | WavefrontObj
WavefrontObj(void) | WavefrontObj
~WavefrontObj(void) | WavefrontObj
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Avatar
base::Avatar Member List

This is the complete list of members for base::Avatar, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
Avatar() | base::Avatar |
avatar_view | base::Avatar | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
cursor_shift | base::Avatar | protected
DECLARE_INPUT(FreeMovement, MessageBool) | base::Avatar | protected
DECLARE_INPUT(Move, MessageVec3) | base::Avatar | protected
DECLARE_INPUT(MoveLocal, MessageVec3) | base::Avatar | protected
DECLARE_INPUT(Rotation, MessageQuat) | base::Avatar | protected
DECLARE_INPUT(RotationKeepUp, MessageQuat) | base::Avatar | protected
DECLARE_INPUT(Position, MessageVec3) | base::Avatar | protected
DECLARE_INPUT(Orientation, MessageQuat) | base::Avatar | protected
DECLARE_INPUT(OrientationKeepUp, MessageQuat) | base::Avatar | protected
DECLARE_INPUT(DebugOutputViewPosition, MessageVoid) | base::Avatar | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
free_move_EO | base::Avatar | protected
freeMoveEO_ID | base::Avatar | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
gravity_mode | base::Avatar | protected
head | base::Avatar | protected
headEO_ID | base::Avatar | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
left_hand | base::Avatar | protected
left_leg | base::Avatar | protected
leftHandEO_ID | base::Avatar | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | base::Avatar | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
orientation | base::Avatar | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::Avatar | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | base::Avatar | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | base::Avatar | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
reference_point | base::Avatar | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
right_hand | base::Avatar | protected
right_leg | base::Avatar | protected
rightHandEO_ID | base::Avatar | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | base::Avatar | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOrientationKeepUp(osg::Quat *newOrientation) | base::Avatar | protected
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | base::Avatar | virtual
updated | vrecko::Ability | protected
updatePosRot(bool bUpdatePos, bool bUpdateRot, osg::Vec3 *position, osg::Quat *orientation) | base::Avatar | protected
~Ability() | vrecko::Ability | virtual
~Avatar() | base::Avatar |
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Display
base::Display Member List

This is the complete list of members for base::Display, including all inherited members.

_display_line | base::Display | protected
_first | base::Display | protected
_font_size | base::Display | protected
_line_count | base::Display | protected
_line_height | base::Display | protected
_polygon_font | base::Display | protected
_start_x | base::Display | protected
_start_y | base::Display | protected
_text_geode | base::Display | protected
_text_history | base::Display | protected
_text_material | base::Display | protected
_text_state | base::Display | protected
_texture_font | base::Display | protected
_transp | base::Display | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Display() | base::Display |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(void) | base::Display | inline
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | base::Display | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Display() | base::Display | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Light
base::Light Member List

This is the complete list of members for base::Light, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
ambient | base::Light | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
constantAttenuation | base::Light | protected
DECLARE_INPUT(Enable, MessageBool) | base::Light | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
diffuse | base::Light | protected
direction | base::Light | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
light | base::Light | protected
Light() | base::Light |
lightGroup | base::Light | protected
lightNumber | base::Light | protected
linearAttenuation | base::Light | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | base::Light | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::Light | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
position | base::Light | protected
postInitialize(void) | base::Light | virtual
pOwner | vrecko::Ability | protected
preInitialize() | base::Light | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
quadraticAttenuation | base::Light | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
spotCutoff | base::Light | protected
spotExponent | base::Light | protected
update(void) | base::Light | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Light() | base::Light | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • MTMatrixTransform
base::MTMatrixTransform Member List

This is the complete list of members for base::MTMatrixTransform, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bRetrieved | base::MTMatrixTransform | protected
bUpdated | base::MTMatrixTransform | protected
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_INPUT(SetMatrix, MessageMatrix, MessageVoid) | base::MTMatrixTransform | protected
DECLARE_REQUEST_INPUT(GetMatrix, MessageVoid, MessageMatrix) | base::MTMatrixTransform | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
generalLock | base::MTMatrixTransform | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getMatrix(osg::Matrix *pMatrix) | base::MTMatrixTransform |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
getWorldTransformation(osg::Matrix *pMatrix) | base::MTMatrixTransform |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
matrix | base::MTMatrixTransform | protected
MTMatrixTransform() | base::MTMatrixTransform |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::MTMatrixTransform | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | base::MTMatrixTransform | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setMatrix(osg::Matrix *newMatrix) | base::MTMatrixTransform |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update() | base::MTMatrixTransform | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~MTMatrixTransform() | base::MTMatrixTransform | virtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • MouseHand
base::MouseHand Member List

This is the complete list of members for base::MouseHand, including all inherited members.

_actual_position | base::MouseHand | protected
_actual_rotation | base::MouseHand | protected
_current_pos | base::MouseHand | protected
_first | base::MouseHand | protected
_grab_position | base::MouseHand | protected
_grab_position2 | base::MouseHand | protected
_grab_rotation | base::MouseHand | protected
_grab_rotation2 | base::MouseHand | protected
_last_position | base::MouseHand | protected
_last_positions | base::MouseHand | protected
_last_rotation | base::MouseHand | protected
_parent_inverse_rotation | base::MouseHand | protected
_parent_rotation | base::MouseHand | protected
ab_with_input_Use | base::MouseHand | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BRICK_MOVE_EVENT | base::MouseHand | static
clean(void) | vrecko::Ability | inlinevirtual
current_transform | base::MouseHand | protected
DECLARE_INPUT(Grab, MessageBool) | base::MouseHand | protected
DECLARE_INPUT(Position, MessageVec2) | base::MouseHand | protected
DECLARE_INPUT(ZChange, MessageFloat) | base::MouseHand | protected
DECLARE_OUTPUT(Grab, MessageObjectID) | base::MouseHand | protected
DECLARE_OUTPUT(GrabRelease, MessageObjectID) | base::MouseHand | protected
DECLARE_OUTPUT(BrickMove, MessageObjectID) | base::MouseHand | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dyn_version | base::MouseHand | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first | base::MouseHand | protected
force | base::MouseHand | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
GRAB_EVENT | base::MouseHand | static
GRAB_RELEASE_EVENT | base::MouseHand | static
grab_transform | base::MouseHand | protected
grab_transform_SO | base::MouseHand | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_transform | base::MouseHand | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
manipulate | base::MouseHand | protected
mouse_position | base::MouseHand | protected
MouseHand() | base::MouseHand |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::MouseHand | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | base::MouseHand | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | base::MouseHand |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scene_mouse_position | base::MouseHand | protected
sceneFile | vrecko::BaseClass | protected
selected_object | base::MouseHand | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SOparent_mat | base::MouseHand | protected
update(void) | base::MouseHand | virtual
updated | vrecko::Ability | protected
z_position | base::MouseHand | protected
z_step | base::MouseHand | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~MouseHand() | base::MouseHand | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • Rotate
base::Rotate Member List

This is the complete list of members for base::Rotate, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
angle | base::Rotate | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | base::Rotate | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | base::Rotate | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::Rotate | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
pParameterVector | base::Rotate | static
preInitialize(void) | base::Rotate | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
Rotate() | base::Rotate |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | base::Rotate | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
step | base::Rotate | protected
update(void) | base::Rotate | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Rotate() | base::Rotate | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • ShowFDH
base::ShowFDH Member List

This is the complete list of members for base::ShowFDH, including all inherited members.

_fdh_geode | base::ShowFDH | protected
_fdh_geom | base::ShowFDH | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | base::ShowFDH | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(void) | base::ShowFDH |
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | base::ShowFDH | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
maxLevel | base::ShowFDH | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
pParameterVector | base::ShowFDH | static
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | base::ShowFDH | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setMaxLevel(long int _new_max) | base::ShowFDH | inline
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
ShowFDH() | base::ShowFDH |
transf | base::ShowFDH | protected
update(void) | base::ShowFDH | virtual
updated | vrecko::Ability | protected
vert | base::ShowFDH | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ShowFDH() | base::ShowFDH | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • ShowFDHModel
base::ShowFDHModel Member List

This is the complete list of members for base::ShowFDHModel, including all inherited members.

_fdh_geode | base::ShowFDHModel | protected
_fdh_geom | base::ShowFDHModel | protected
_first | base::ShowFDHModel | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(void) | base::ShowFDHModel |
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
ShowFDHModel() | base::ShowFDHModel |
transf | base::ShowFDHModel | protected
update(void) | base::ShowFDHModel | virtual
updated | vrecko::Ability | protected
vert | base::ShowFDHModel | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ShowFDHModel() | base::ShowFDHModel | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
base::SystemInfo Member List

This is the complete list of members for base::SystemInfo, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bWritePeriodicInfo | base::SystemInfo | protected
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(ThreadCreated, MessageSIThreadCreated) | base::SystemInfo | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dwLastTick | base::SystemInfo | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initThread(DWORD dwThreadId, std::string &threadName) | base::SystemInfo | protected
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | base::SystemInfo | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize() | base::SystemInfo | virtual
pOwner | vrecko::Ability | protected
preInitialize() | base::SystemInfo | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SystemInfo() | base::SystemInfo |
threadsInfo | base::SystemInfo | protected
threadsInit | base::SystemInfo | protected
TryToSendThreadCreatedEvent(DWORD dwThreadId, const char *pName) | base::SystemInfo | inlinestatic
update() | base::SystemInfo | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~SystemInfo() | base::SystemInfo |
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • MessageSIThreadCreated
base::SystemInfo::MessageSIThreadCreated Member List

This is the complete list of members for base::SystemInfo::MessageSIThreadCreated, including all inherited members.

dwThreadId | base::SystemInfo::MessageSIThreadCreated |
getMessageId() | base::SystemInfo::MessageSIThreadCreated | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | base::SystemInfo::MessageSIThreadCreated | inlinevirtual
vrecko::VreckoMessage::isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageSIThreadCreated() | base::SystemInfo::MessageSIThreadCreated | inline
MessageSIThreadCreated(DWORD _dwThreadId, const char *_name) | base::SystemInfo::MessageSIThreadCreated | inline
name | base::SystemInfo::MessageSIThreadCreated |
setValueFromString(const char *valueAsString) | base::SystemInfo::MessageSIThreadCreated | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • hand
base::hand Member List

This is the complete list of members for base::hand, including all inherited members.

_actual_position | base::hand | protected
_actual_rotation | base::hand | protected
_current_pos | base::hand | protected
_first | base::hand | protected
_grab_position | base::hand | protected
_grab_position2 | base::hand | protected
_grab_rotation | base::hand | protected
_grab_rotation2 | base::hand | protected
_last_position | base::hand | protected
_last_positions | base::hand | protected
_last_rotation | base::hand | protected
_parent_inverse_rotation | base::hand | protected
_parent_rotation | base::hand | protected
ab_with_input_Use | base::hand | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
current_transform | base::hand | protected
DECLARE_INPUT(Grab, MessageBool) | base::hand | protected
DECLARE_OUTPUT(RelativeLocation, MessageMatrix) | base::hand | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
dyn_version | base::hand | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first | base::hand | protected
force | base::hand | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
grab_transform | base::hand | protected
grab_transform_SO | base::hand | protected
hand() | base::hand |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_transform | base::hand | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
manipulate | base::hand | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | base::hand | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize() | base::hand | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selected_object | base::hand | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
SOparent_mat | base::hand | protected
update(void) | base::hand | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~hand() | base::hand | inline
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • AvatarManipulator
behindO::AvatarManipulator Member List

This is the complete list of members for behindO::AvatarManipulator, including all inherited members.

_first | behindO::AvatarManipulator | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
active | behindO::AvatarManipulator | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_grab_inverse_rotation | behindO::AvatarManipulator | protected
avatar_grab_inverse_transform | behindO::AvatarManipulator | protected
avatar_grab_pos | behindO::AvatarManipulator | protected
avatar_grab_rotation | behindO::AvatarManipulator | protected
avatar_grab_transform | behindO::AvatarManipulator | protected
AvatarManipulator() | behindO::AvatarManipulator |
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
control | behindO::AvatarManipulator | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EO_owner_grab_pos | behindO::AvatarManipulator | protected
EO_owner_grab_rot | behindO::AvatarManipulator | protected
EO_owner_grab_Wrot | behindO::AvatarManipulator | protected
eye_distance_scale_factor | behindO::AvatarManipulator | protected
eye_position | behindO::AvatarManipulator | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAcceptableMessages(void) | behindO::AvatarManipulator | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_center | behindO::AvatarManipulator | protected
initial_sensor_pos | behindO::AvatarManipulator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_sensor_orientation | behindO::AvatarManipulator | protected
last_sensor_pos | behindO::AvatarManipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
look_at_center | behindO::AvatarManipulator | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::AvatarManipulator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::AvatarManipulator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::AvatarManipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_relative_pos | behindO::AvatarManipulator | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
to_center | behindO::AvatarManipulator | protected
up_vector | behindO::AvatarManipulator | protected
update(void) | behindO::AvatarManipulator | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AvatarManipulator() | behindO::AvatarManipulator | inline
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • CentreObjectManipulator
behindO::CentreObjectManipulator Member List

This is the complete list of members for behindO::CentreObjectManipulator, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
CentreObjectManipulator() | behindO::CentreObjectManipulator |
clean(void) | vrecko::Ability | inlinevirtual
control | behindO::CentreObjectManipulator | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
focus_area | behindO::CentreObjectManipulator | protected
focusing_marker | behindO::CentreObjectManipulator | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_tick | behindO::CentreObjectManipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
located_object | behindO::CentreObjectManipulator | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::CentreObjectManipulator | protected
pAHeadManipulator | behindO::CentreObjectManipulator | protected
pAHMDHeadManipulator | behindO::CentreObjectManipulator | protected
pAManipulator | behindO::CentreObjectManipulator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | behindO::CentreObjectManipulator | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::CentreObjectManipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
score_map | behindO::CentreObjectManipulator | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
timer | behindO::CentreObjectManipulator | protected
update(void) | behindO::CentreObjectManipulator | virtual
updated | vrecko::Ability | protected
version | behindO::CentreObjectManipulator | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CentreObjectManipulator() | behindO::CentreObjectManipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • ChangeOfVisibility
behindO::ChangeOfVisibility Member List

This is the complete list of members for behindO::ChangeOfVisibility, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
border_object | behindO::ChangeOfVisibility | protected
box_size | behindO::ChangeOfVisibility | protected
ChangeOfVisibility() | behindO::ChangeOfVisibility |
clean(void) | vrecko::Ability | inlinevirtual
continuous_selection | behindO::ChangeOfVisibility | protected
control | behindO::ChangeOfVisibility | protected
createBorder(void) | behindO::ChangeOfVisibility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::ChangeOfVisibility |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pSelectionBox | behindO::ChangeOfVisibility | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
selection_point | behindO::ChangeOfVisibility | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
transparency | behindO::ChangeOfVisibility | protected
update(void) | behindO::ChangeOfVisibility | virtual
updated | vrecko::Ability | protected
wire_object_map | behindO::ChangeOfVisibility | protected
wireframe | behindO::ChangeOfVisibility | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ChangeOfVisibility() | behindO::ChangeOfVisibility | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • ContactObjectManipulator
behindO::ContactObjectManipulator Member List

This is the complete list of members for behindO::ContactObjectManipulator, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
ContactObjectManipulator() | behindO::ContactObjectManipulator |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | behindO::ContactObjectManipulator | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ContactObjectManipulator() | behindO::ContactObjectManipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • CuttingPlane
behindO::CuttingPlane Member List

This is the complete list of members for behindO::CuttingPlane, including all inherited members.

_first | behindO::CuttingPlane | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
clipnode | behindO::CuttingPlane | protected
clipnodeSS | behindO::CuttingPlane | protected
control | behindO::CuttingPlane | protected
cutting_object | behindO::CuttingPlane | protected
cutting_plane_transformation | behindO::CuttingPlane | protected
CuttingPlane() | behindO::CuttingPlane |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
next_free_clipping_plane | behindO::CuttingPlane | protectedstatic
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::CuttingPlane |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
stateset_map | behindO::CuttingPlane | protected
update(void) | behindO::CuttingPlane | virtual
updated | vrecko::Ability | protected
wire_object_map | behindO::CuttingPlane | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CuttingPlane() | behindO::CuttingPlane | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • EyeManipulator
behindO::EyeManipulator Member List

This is the complete list of members for behindO::EyeManipulator, including all inherited members.

_first | behindO::EyeManipulator | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
active | behindO::EyeManipulator | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_grab_inverse_rotation | behindO::EyeManipulator | protected
avatar_grab_inverse_transform | behindO::EyeManipulator | protected
avatar_grab_pos | behindO::EyeManipulator | protected
avatar_grab_rotation | behindO::EyeManipulator | protected
avatar_grab_transform | behindO::EyeManipulator | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
control | behindO::EyeManipulator | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EO_owner_grab_pos | behindO::EyeManipulator | protected
EO_owner_grab_rot | behindO::EyeManipulator | protected
EO_owner_grab_Wrot | behindO::EyeManipulator | protected
eye_distance_scale_factor | behindO::EyeManipulator | protected
eye_position | behindO::EyeManipulator | protected
EyeManipulator() | behindO::EyeManipulator |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAcceptableMessages(void) | behindO::EyeManipulator | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_center | behindO::EyeManipulator | protected
initial_sensor_pos | behindO::EyeManipulator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_sensor_orientation | behindO::EyeManipulator | protected
last_sensor_pos | behindO::EyeManipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
look_at_center | behindO::EyeManipulator | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::EyeManipulator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::EyeManipulator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::EyeManipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_relative_pos | behindO::EyeManipulator | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
to_center | behindO::EyeManipulator | protected
up_vector | behindO::EyeManipulator | protected
update(void) | behindO::EyeManipulator | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~EyeManipulator() | behindO::EyeManipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • HMDHeadManipulator
behindO::HMDHeadManipulator Member List

This is the complete list of members for behindO::HMDHeadManipulator, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | behindO::HMDHeadManipulator | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
eye_distance_scale_factor | behindO::HMDHeadManipulator | protected
eye_position | behindO::HMDHeadManipulator | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_center | behindO::HMDHeadManipulator | protected
HMDHeadManipulator() | behindO::HMDHeadManipulator |
initial_sensor_pos | behindO::HMDHeadManipulator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_sensor_orientation | behindO::HMDHeadManipulator | protected
last_sensor_pos | behindO::HMDHeadManipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | behindO::HMDHeadManipulator | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::HMDHeadManipulator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::HMDHeadManipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | behindO::HMDHeadManipulator | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_relative_pos | behindO::HMDHeadManipulator | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
up_vector | behindO::HMDHeadManipulator | protected
update(void) | behindO::HMDHeadManipulator | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~HMDHeadManipulator() | behindO::HMDHeadManipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • HeadManipulator
behindO::HeadManipulator Member List

This is the complete list of members for behindO::HeadManipulator, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
active | behindO::HeadManipulator | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_grab_inverse_rotation | behindO::HeadManipulator | protected
avatar_grab_inverse_transform | behindO::HeadManipulator | protected
avatar_grab_pos | behindO::HeadManipulator | protected
avatar_grab_rotation | behindO::HeadManipulator | protected
avatar_grab_transform | behindO::HeadManipulator | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bottom_border | behindO::HeadManipulator | protected
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
delta_z | behindO::HeadManipulator | protected
difference_sensor_orientation | behindO::HeadManipulator | protected
difference_sensor_pos | behindO::HeadManipulator | protected
eye_distance_scale_factor | behindO::HeadManipulator | protected
eye_position | behindO::HeadManipulator | protected
far_border | behindO::HeadManipulator | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_center | behindO::HeadManipulator | protected
HeadManipulator() | behindO::HeadManipulator |
initial_sensor_orientation | behindO::HeadManipulator | protected
initial_sensor_pos | behindO::HeadManipulator | protected
initial_sensor_x_orientation | behindO::HeadManipulator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_sensor_orientation | behindO::HeadManipulator | protected
last_sensor_pos | behindO::HeadManipulator | protected
left_border | behindO::HeadManipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | behindO::HeadManipulator | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
look_at_center | behindO::HeadManipulator | protected
minimal_distance | behindO::HeadManipulator | protected
mode | behindO::HeadManipulator | protected
near_border | behindO::HeadManipulator | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::HeadManipulator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::HeadManipulator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::HeadManipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
right_border | behindO::HeadManipulator | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | behindO::HeadManipulator | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_relative_pos | behindO::HeadManipulator | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
to_center | behindO::HeadManipulator | protected
top_border | behindO::HeadManipulator | protected
up_vector | behindO::HeadManipulator | protected
update(void) | behindO::HeadManipulator | virtual
updated | vrecko::Ability | protected
x_sensitivity | behindO::HeadManipulator | protected
x_sensitivity_delta | behindO::HeadManipulator | protected
y_sensitivity | behindO::HeadManipulator | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~HeadManipulator() | behindO::HeadManipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Lens
behindO::Lens Member List

This is the complete list of members for behindO::Lens, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
Lens() | behindO::Lens |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | behindO::Lens | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Lens() | behindO::Lens | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Manipulator
behindO::Manipulator Member List

This is the complete list of members for behindO::Manipulator, including all inherited members.

_first | behindO::Manipulator | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
active | behindO::Manipulator | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_grab_inverse_rotation | behindO::Manipulator | protected
avatar_grab_inverse_transform | behindO::Manipulator | protected
avatar_grab_pos | behindO::Manipulator | protected
avatar_grab_rotation | behindO::Manipulator | protected
avatar_grab_transform | behindO::Manipulator | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
control | behindO::Manipulator | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EO_owner_grab_pos | behindO::Manipulator | protected
EO_owner_grab_rot | behindO::Manipulator | protected
EO_owner_grab_Wrot | behindO::Manipulator | protected
eye_distance_scale_factor | behindO::Manipulator | protected
eye_position | behindO::Manipulator | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAcceptableMessages(void) | behindO::Manipulator | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_center | behindO::Manipulator | protected
initial_sensor_pos | behindO::Manipulator | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_sensor_orientation | behindO::Manipulator | protected
last_sensor_pos | behindO::Manipulator | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
look_at_center | behindO::Manipulator | protected
Manipulator() | behindO::Manipulator |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::Manipulator | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::Manipulator | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::Manipulator |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_relative_pos | behindO::Manipulator | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
to_center | behindO::Manipulator | protected
up_vector | behindO::Manipulator | protected
update(void) | behindO::Manipulator | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Manipulator() | behindO::Manipulator | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MappingFunctions
behindO::MappingFunctions Member List

This is the complete list of members for behindO::MappingFunctions, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
MappingFunctions() | behindO::MappingFunctions |
nonlinear | behindO::MappingFunctions | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::MappingFunctions | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | behindO::MappingFunctions | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::MappingFunctions |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
receiver_backup | behindO::MappingFunctions | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
sender_backup | behindO::MappingFunctions | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
space_scale | behindO::MappingFunctions | protected
update(void) | behindO::MappingFunctions | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~MappingFunctions() | behindO::MappingFunctions | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • Mirror
behindO::Mirror Member List

This is the complete list of members for behindO::Mirror, including all inherited members.

_center_position | behindO::Mirror | protected
_eye_position | behindO::Mirror | protected
_first | behindO::Mirror | protected
_geode | behindO::Mirror | protected
_geom | behindO::Mirror | protected
_mirror_normal | behindO::Mirror | protected
_parent | behindO::Mirror | protected
_texture | behindO::Mirror | protected
_updateVisitor | behindO::Mirror | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
Mirror() | behindO::Mirror |
mirror_plane_transf | behindO::Mirror | protected
mirror_plane_vertices | behindO::Mirror | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pMyCullCallback | behindO::Mirror | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | behindO::Mirror | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | behindO::Mirror | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Mirror() | behindO::Mirror | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MyCullCallback
behindO::MyCullCallback Member List

This is the complete list of members for behindO::MyCullCallback, including all inherited members.

_image | behindO::MyCullCallback |
_localState | behindO::MyCullCallback |
_subgraph | behindO::MyCullCallback |
_texture | behindO::MyCullCallback |
camera_center | behindO::MyCullCallback |
camera_direction | behindO::MyCullCallback |
camera_position | behindO::MyCullCallback |
dir | behindO::MyCullCallback |
doPreRender(osg::Node &node, osgUtil::CullVisitor &cv) | behindO::MyCullCallback |
frame | behindO::MyCullCallback |
mirror_object | behindO::MyCullCallback |
MyCullCallback(osg::Node *subgraph, osg::Texture2D *texture) | behindO::MyCullCallback | inline
MyCullCallback(osg::Node *subgraph, osg::Image *image) | behindO::MyCullCallback | inline
old_camera_direction | behindO::MyCullCallback |
operator()(osg::Node *node, osg::NodeVisitor *nv) | behindO::MyCullCallback | inlinevirtual
up_vector | behindO::MyCullCallback |
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • MyUpdateCallback
behindO::MyUpdateCallback Member List

This is the complete list of members for behindO::MyUpdateCallback, including all inherited members.

_subgraph | behindO::MyUpdateCallback |
MyUpdateCallback(osg::Node *subgraph) | behindO::MyUpdateCallback | inline
operator()(osg::Node *node, osg::NodeVisitor *nv) | behindO::MyUpdateCallback | inlinevirtual
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • WIM
behindO::WIM Member List

This is the complete list of members for behindO::WIM, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_copy | behindO::WIM | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
border_bvh | behindO::WIM | protected
border_object | behindO::WIM | protected
clean(void) | vrecko::Ability | inlinevirtual
control | behindO::WIM | protected
copies_map | behindO::WIM | protected
copies_root | behindO::WIM | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAcceptableMessages(void) | behindO::WIM | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getMessage(void) | behindO::WIM | inline
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | behindO::WIM | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
origin_WIM_scale | behindO::WIM | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | behindO::WIM | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
pAvatarCopy | behindO::WIM | protected
pAvatarManipulator | behindO::WIM | protected
pAvatarOwner | behindO::WIM | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | behindO::WIM | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | behindO::WIM |
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | behindO::WIM | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | behindO::WIM | virtual
updated | vrecko::Ability | protected
visual_border_object | behindO::WIM | protected
WIM() | behindO::WIM |
WIM_center | behindO::WIM | protected
WIM_commit | behindO::WIM | protected
WIM_scale | behindO::WIM | protected
WIM_size | behindO::WIM | protected
work_area_selection | behindO::WIM | protected
zooming | behindO::WIM | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~WIM() | behindO::WIM | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • Boid
boids::Boid Member List

This is the complete list of members for boids::Boid, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
Boid() | boids::Boid |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(Position, MessageVec3) | boids::Boid | protected
DECLARE_INPUT(Velocity, MessageVec3) | boids::Boid | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | boids::Boid | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | boids::Boid | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | boids::Boid | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | boids::Boid | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | boids::Boid | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
up_vector | boids::Boid | protected
update(void) | boids::Boid | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Boid() | boids::Boid |
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • BoidsLogic
boids::BoidsLogic Member List

This is the complete list of members for boids::BoidsLogic, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
boids_count | boids::BoidsLogic | protected
boids_position | boids::BoidsLogic | protected
boids_position_output | boids::BoidsLogic | protected
boids_rest_time | boids::BoidsLogic | protected
boids_velocity | boids::BoidsLogic | protected
boids_velocity_output | boids::BoidsLogic | protected
BoidsLogic() | boids::BoidsLogic |
bound_velocity | boids::BoidsLogic | protected
clean(void) | vrecko::Ability | inlinevirtual
danger | boids::BoidsLogic | protected
danger_factor | boids::BoidsLogic | protected
DECLARE_INPUT(Waypoint, MessageVec3) | boids::BoidsLogic | protected
DECLARE_INPUT(Danger, MessageVec3) | boids::BoidsLogic | protected
DECLARE_OUTPUT(NextWaypoint, MessageBool) | boids::BoidsLogic | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
land_level | boids::BoidsLogic | protected
limit_speed(int boid) | boids::BoidsLogic | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | boids::BoidsLogic | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
max_bound | boids::BoidsLogic | protected
max_speed | boids::BoidsLogic | protected
mesg | boids::BoidsLogic | protected
min_bound | boids::BoidsLogic | protected
move_factor | boids::BoidsLogic | protected
next_waypoint | boids::BoidsLogic | protected
next_waypoint_dist | boids::BoidsLogic | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | boids::BoidsLogic | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | boids::BoidsLogic | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rest_on_land(int boid) | boids::BoidsLogic | protected
rest_time | boids::BoidsLogic | protected
rule0_in_sight(int other_boid, int boid) | boids::BoidsLogic | protected
rule1_centre_of_mass(int boid) | boids::BoidsLogic | protected
rule2_away_from_others(int boid) | boids::BoidsLogic | protected
rule3_match_velocity(int boid) | boids::BoidsLogic | protected
rule4_bound_position(int boid) | boids::BoidsLogic | protected
rule5_fly_to_waypoint(int boid) | boids::BoidsLogic | protected
rule6_fly_from_danger(int boid) | boids::BoidsLogic | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | boids::BoidsLogic | virtual
scare_distance | boids::BoidsLogic | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
sight_angle | boids::BoidsLogic | protected
small_distance | boids::BoidsLogic | protected
takeoff_time | boids::BoidsLogic | protected
update(void) | boids::BoidsLogic | virtual
updated | vrecko::Ability | protected
velocity_factor | boids::BoidsLogic | protected
waypoint | boids::BoidsLogic | protected
waypoint_speed | boids::BoidsLogic | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BoidsLogic() | boids::BoidsLogic | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • boids
  • BoidsPlanner
boids::BoidsPlanner Member List

This is the complete list of members for boids::BoidsPlanner, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
BoidsPlanner() | boids::BoidsPlanner |
clean(void) | vrecko::Ability | inlinevirtual
current_waypoint | boids::BoidsPlanner | protected
DECLARE_INPUT(NextWaypoint, MessageBool) | boids::BoidsPlanner | protected
DECLARE_OUTPUT(Waypoint, MessageVec3) | boids::BoidsPlanner | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | boids::BoidsPlanner | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mesg | boids::BoidsPlanner | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | boids::BoidsPlanner | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | boids::BoidsPlanner | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | boids::BoidsPlanner | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | boids::BoidsPlanner | virtual
updated | vrecko::Ability | protected
waypoints | boids::BoidsPlanner | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~BoidsPlanner() | boids::BoidsPlanner | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/classes.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
classes.h
Go to the documentation of this file.
1 /***************************************************
2 * - - - - - - - IMMERSION CORP. - - - - - - - *
3 * *
4 * IBM PC/Compatibles software series *
5 * Copyright (c) 1993 *
6 ***************************************************
7 * DRIVE.H | SDK1-2 | November 1995
8 *
9 * Immersion Corp. Software Developer's Kit
10 * Definitions and prototypes for serial communications functions
11 * for the Immersion Corp. MicroScribe-3D
12 * Not for use with the Probe or Personal Digitizer
13 * Requires HCI firmware version MSCR1-1C or later
14 */
15
16 #ifndef F__CLASSES_H
17 #define F__CLASSES_H
18
19 #define BAUD 38400
20 #ifdef WIN32
21 #define BAUDCODE CBR_38400
22 #else
23 #define BAUDCODE B38400
24 #endif //WIN32
25
26 #ifdef _DEBUG
27 #define DEBUG
28 #endif
29
30 #ifdef DEBUG
31 #define dbg(what) puts(what);
32 #define dbgdf(what) printf("--%d\n", what);
33 #define dbgsf(what) printf("--%s\n", what);
34 #else
35 #define dbg(what)
36 #define dbgdf(what)
37 #define dbgsf(what)
38 #endif
39
40
41
42 #ifdef WIN32
43 #include <windows.h>
44 #else // else
45 #include <termio.h>
46 #endif
47
48 /* Public constants */
49 #define MIN_TIMEOUT 100
50 #define FRAME_BUF_SIZE 240
51
52
53
54
55 /* Use hci_result as if it were an enumerated type. Compare variables of
56 * this type to the string constants declared below. An hci_result is
57 * actually a string, so it can be directly printed as well.
58 */
59 typedef char* hci_result;
60 typedef hci_result arm_result;
61
62 /* Shorthand for a byte */
63 typedef unsigned char byte;
64
65 /* Timing functions */
66 class Timing
67 {
68 private:
69 long int timeout;
70 unsigned long int stop;
71
72 public:
73 void pause(const unsigned int);
74 void setTimeout(const int t_ms) { timeout = t_ms; };
75 void start();
76 char timedOut();
77 };
78
79
80
81
82
83
84 // *************************** Serial *************************
85
86 class Serial
87 {
88 private:
89 #ifdef WIN32
90 OVERLAPPED ol;
91 void *portRef;
92 #else
93 struct termio oldSetup;
94 int portRef;
95 #endif
96 char frameBuffer[FRAME_BUF_SIZE];
97 int frameHead; /* chars come in here */
98 int frameTail; /* chars are read out here */
99
100 public:
101 /* Configuring serial ports */
102 char openSerial(char*);
103 void closeSerial();
104 void flushSerial();
105
106 /* Reading/writing serial data */
107 int readChar();
108 int readBytes(char*, const int, const int);
109 char writeChar(const char);
110 int writeString(char*);
111 };
112
113 #endif
114
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
filter1 Member List

This is the complete list of members for filter1, including all inherited members.

apply(PHANToM *pPHANToM, osg::Vec3 &force) | filter1 | inline
filter1() | filter1 | inline
~filter1() | filter1 | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
filter2 Member List

This is the complete list of members for filter2, including all inherited members.

apply(PHANToM *pPHANToM, osg::Vec3 &force) | filter2 | inline
filter2() | filter2 | inline
flag | filter2 | protected
~filter2() | filter2 | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
gmMatrix3 Member List

This is the complete list of members for gmMatrix3, including all inherited members.

adjoint() const | gmMatrix3 |
arb_rotate(gmVector3 &, double) | gmMatrix3 | static
assign(double, double, double, double, double, double, double, double, double) | gmMatrix3 |
copyTo(float[3][3]) const | gmMatrix3 | inline
copyTo(double[3][3]) const | gmMatrix3 | inline
determinant() const | gmMatrix3 |
gmMatrix3() | gmMatrix3 |
gmMatrix3(const gmMatrix3 &) | gmMatrix3 |
gmMatrix3(double, double, double, double, double, double, double, double, double) | gmMatrix3 |
identity() | gmMatrix3 | static
inverse() const | gmMatrix3 |
isSingular() const | gmMatrix3 |
m_ | gmMatrix3 | protected
operator!=(const gmMatrix3 &) const | gmMatrix3 |
operator*(const gmMatrix3 &) const | gmMatrix3 |
operator*(double) const | gmMatrix3 |
operator*(double, const gmMatrix3 &) | gmMatrix3 | friend
operator*(const gmVector3 &) const | gmMatrix3 |
operator*(const gmVector3 &, const gmMatrix3 &) | gmMatrix3 | friend
operator*=(const gmMatrix3 &) | gmMatrix3 |
operator*=(double) | gmMatrix3 |
operator+(const gmMatrix3 &) const | gmMatrix3 |
operator+=(const gmMatrix3 &) | gmMatrix3 |
operator-(const gmMatrix3 &) const | gmMatrix3 |
operator-() const | gmMatrix3 |
operator-=(const gmMatrix3 &) | gmMatrix3 |
operator/(double) const | gmMatrix3 |
operator/=(double) | gmMatrix3 |
operator<<(ostream &, const gmMatrix3 &) | gmMatrix3 | friend
operator=(const gmMatrix3 &) | gmMatrix3 |
operator==(const gmMatrix3 &) const | gmMatrix3 |
operator[](int) | gmMatrix3 | inline
operator[](int) const | gmMatrix3 | inline
rotate(double) | gmMatrix3 | static
scale(double, double) | gmMatrix3 | static
transform(const gmVector2 &) const | gmMatrix3 |
translate(double, double) | gmMatrix3 | static
transpose() const | gmMatrix3 |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
gmMatrix4 Member List

This is the complete list of members for gmMatrix4, including all inherited members.

adjoint() const | gmMatrix4 |
arb_rotate(gmVector3 &, double) | gmMatrix4 | static
assign(double, double, double, double, double, double, double, double, double, double, double, double, double, double, double, double) | gmMatrix4 |
betaSplineBasis(double, double) | gmMatrix4 | static
bezierBasis() | gmMatrix4 | static
bsplineBasis() | gmMatrix4 | static
cardinalBasis(double) | gmMatrix4 | static
catmullromBasis() | gmMatrix4 | static
copyTo(float[4][4]) const | gmMatrix4 | inline
copyTo(double[4][4]) const | gmMatrix4 | inline
determinant() const | gmMatrix4 |
gmMatrix4() | gmMatrix4 |
gmMatrix4(const gmMatrix4 &) | gmMatrix4 |
gmMatrix4(double, double, double, double, double, double, double, double, double, double, double, double, double, double, double, double) | gmMatrix4 |
hermiteBasis() | gmMatrix4 | static
identity() | gmMatrix4 | static
inverse() const | gmMatrix4 |
isSingular() const | gmMatrix4 |
m_ | gmMatrix4 | protected
mixed_mult(gmVector3 &, const double &) | gmMatrix4 |
operator!=(const gmMatrix4 &) const | gmMatrix4 |
operator*(const gmMatrix4 &) const | gmMatrix4 |
operator*(double) const | gmMatrix4 |
operator*(double, const gmMatrix4 &) | gmMatrix4 | friend
operator*(const gmVector4 &) const | gmMatrix4 |
operator*(const gmVector4 &, const gmMatrix4 &) | gmMatrix4 | friend
operator*=(const gmMatrix4 &) | gmMatrix4 |
operator*=(double) | gmMatrix4 |
operator+(const gmMatrix4 &) const | gmMatrix4 |
operator+=(const gmMatrix4 &) | gmMatrix4 |
operator-(const gmMatrix4 &) const | gmMatrix4 |
operator-() const | gmMatrix4 |
operator-=(const gmMatrix4 &) | gmMatrix4 |
operator/(double) const | gmMatrix4 |
operator/=(double) | gmMatrix4 |
operator<<(ostream &, const gmMatrix4 &) | gmMatrix4 | friend
operator=(const gmMatrix4 &) | gmMatrix4 |
operator==(const gmMatrix4 &) const | gmMatrix4 |
operator[](int) | gmMatrix4 | inline
operator[](int) const | gmMatrix4 | inline
rotate(double, const gmVector3 &axis) | gmMatrix4 | static
scale(double, double, double) | gmMatrix4 | static
tauBasis(double, double) | gmMatrix4 | static
tensedBSplineBasis(double) | gmMatrix4 | static
transform(const gmVector3 &) const | gmMatrix4 |
translate(double, double, double) | gmMatrix4 | static
transpose() const | gmMatrix4 |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
gmVector2 Member List

This is the complete list of members for gmVector2, including all inherited members.

assign(double, double) | gmVector2 | inline
clamp(double, double) | gmVector2 | inline
copyTo(float[2]) const | gmVector2 | inline
copyTo(double[2]) const | gmVector2 | inline
distance(const gmVector2 &, const gmVector2 &) | gmVector2 | friend
distanceSquared(const gmVector2 &, const gmVector2 &) | gmVector2 | friend
dot(const gmVector2 &, const gmVector2 &) | gmVector2 | friend
gmVector2() | gmVector2 | inline
gmVector2(const gmVector2 &) | gmVector2 | inline
gmVector2(double, double) | gmVector2 | inline
length() const | gmVector2 | inline
lengthSquared() const | gmVector2 | inline
lerp(double, const gmVector2 &, const gmVector2 &) | gmVector2 | friend
normalize() | gmVector2 | inline
operator!=(const gmVector2 &) const | gmVector2 | inline
operator*(double) const | gmVector2 | inline
operator*(double, const gmVector2 &) | gmVector2 | friend
operator*=(double) | gmVector2 | inline
operator+(const gmVector2 &) const | gmVector2 | inline
operator+=(const gmVector2 &) | gmVector2 | inline
operator-(const gmVector2 &) const | gmVector2 | inline
operator-() const | gmVector2 | inline
operator-=(const gmVector2 &) | gmVector2 | inline
operator/(double) const | gmVector2 | inline
operator/=(double) | gmVector2 | inline
operator<<(ostream &, const gmVector2 &) | gmVector2 | friend
operator=(const gmVector2 &) | gmVector2 | inline
operator==(const gmVector2 &) const | gmVector2 | inline
operator[](int) | gmVector2 | inline
operator[](int) const | gmVector2 | inline
v_ | gmVector2 | protected
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
gmVector3 Member List

This is the complete list of members for gmVector3, including all inherited members.

assign(double, double, double) | gmVector3 | inline
clamp(double, double) | gmVector3 | inline
copyTo(float[3]) const | gmVector3 | inline
copyTo(double[3]) const | gmVector3 | inline
cross(const gmVector3 &, const gmVector3 &) | gmVector3 | friend
distance(const gmVector3 &, const gmVector3 &) | gmVector3 | friend
distanceSquared(const gmVector3 &, const gmVector3 &) | gmVector3 | friend
dot(const gmVector3 &, const gmVector3 &) | gmVector3 | friend
double2float(const double *v) | gmVector3 | inline
float2double(const float *v) | gmVector3 | inline
gmVector3() | gmVector3 | inline
gmVector3(const gmVector3 &) | gmVector3 | inline
gmVector3(double, double, double) | gmVector3 | inline
isZero() | gmVector3 | inline
length() const | gmVector3 | inline
lengthSquared() const | gmVector3 | inline
lerp(double, const gmVector3 &, const gmVector3 &) | gmVector3 | friend
line_distance(const gmVector3 &, const gmVector3 &, const gmVector3 &, const gmVector3 &) | gmVector3 | friend
normalize() | gmVector3 | inline
operator!=(const gmVector3 &) const | gmVector3 | inline
operator*(double) const | gmVector3 | inline
operator*(double, const gmVector3 &) | gmVector3 | friend
operator*=(double) | gmVector3 | inline
operator+(const gmVector3 &) const | gmVector3 | inline
operator+=(const gmVector3 &) | gmVector3 | inline
operator-(const gmVector3 &) const | gmVector3 | inline
operator-() const | gmVector3 | inline
operator-=(const gmVector3 &) | gmVector3 | inline
operator/(double) const | gmVector3 | inline
operator/=(double) | gmVector3 | inline
operator<<(ostream &, const gmVector3 &) | gmVector3 | friend
operator=(const gmVector3 &) | gmVector3 | inline
operator==(const gmVector3 &) const | gmVector3 | inline
operator[](int) | gmVector3 | inline
operator[](int) const | gmVector3 | inline
plane_distance(const gmVector3 &, const gmVector3 &, const gmVector3 &) | gmVector3 | friend
plane_intersect(const gmVector3 &, const gmVector3 &, const gmVector3 &, const gmVector3 &) | gmVector3 | friend
v_ | gmVector3 | protected
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
gmVector4 Member List

This is the complete list of members for gmVector4, including all inherited members.

assign(double, double, double, double) | gmVector4 | inline
clamp(double, double) | gmVector4 | inline
copyTo(float[4]) const | gmVector4 | inline
copyTo(double[4]) const | gmVector4 | inline
distance(const gmVector4 &, const gmVector4 &) | gmVector4 | friend
distanceSquared(const gmVector4 &, const gmVector4 &) | gmVector4 | friend
dot(const gmVector4 &, const gmVector4 &) | gmVector4 | friend
gmVector4() | gmVector4 | inline
gmVector4(const gmVector4 &) | gmVector4 | inline
gmVector4(double, double, double, double) | gmVector4 | inline
length() const | gmVector4 | inline
lengthSquared() const | gmVector4 | inline
lerp(double, const gmVector4 &, const gmVector4 &) | gmVector4 | friend
normalize() | gmVector4 | inline
operator!=(const gmVector4 &) const | gmVector4 | inline
operator*(double) const | gmVector4 | inline
operator*(double, const gmVector4 &) | gmVector4 | friend
operator*=(double) | gmVector4 | inline
operator+(const gmVector4 &) const | gmVector4 | inline
operator+=(const gmVector4 &) | gmVector4 | inline
operator-(const gmVector4 &) const | gmVector4 | inline
operator-() const | gmVector4 | inline
operator-=(const gmVector4 &) | gmVector4 | inline
operator/(double) const | gmVector4 | inline
operator/=(double) | gmVector4 | inline
operator<<(ostream &, const gmVector4 &) | gmVector4 | friend
operator=(const gmVector4 &) | gmVector4 | inline
operator==(const gmVector4 &) const | gmVector4 | inline
operator[](int) | gmVector4 | inline
operator[](int) const | gmVector4 | inline
v_ | gmVector4 | protected
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Grass
grass::Grass Member List

This is the complete list of members for grass::Grass, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
CoatWithGrass(Group *pGroup) | grass::Grass | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
Grass() | grass::Grass | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | grass::Grass | inlinevirtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
params | grass::Grass | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | grass::Grass | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *d) | grass::Grass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | grass::Grass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Grass() | grass::Grass | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassCullCallback
grass::GrassCullCallback Member List

This is the complete list of members for grass::GrassCullCallback, including all inherited members.

Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassDrawable
grass::GrassDrawable Member List

This is the complete list of members for grass::GrassDrawable, including all inherited members.

className() const | grass::GrassDrawable | inlinevirtual
clone(const CopyOp &copyop) const | grass::GrassDrawable | inlinevirtual
cloneType() const | grass::GrassDrawable | inlinevirtual
DETAILED enum value | grass::GrassDrawable |
displayListValid | grass::GrassDrawable | mutableprotected
distanceFromEye | grass::GrassDrawable | protected
drawImplementation(RenderInfo &renderInfo) const | grass::GrassDrawable | virtual
EnsureDetailedVersionIsReady() | grass::GrassDrawable | protected
grassDisplayList | grass::GrassDrawable | mutableprotected
GrassDrawable(Geode &g, GrassAbilityParameters *parameters) | grass::GrassDrawable |
GrassDrawable(Mesh *newMesh, GrassAbilityParameters *parameters) | grass::GrassDrawable |
GrassDrawable(const GrassDrawable &gd, const CopyOp &copyop=CopyOp::SHALLOW_COPY) | grass::GrassDrawable |
INTERMEDIATE enum value | grass::GrassDrawable |
isSameKindAs(const Object *obj) const | grass::GrassDrawable | inlinevirtual
libraryName() const | grass::GrassDrawable | inlinevirtual
LOD | grass::GrassDrawable | protected
ManageCulling(osgUtil::CullVisitor *cv, RenderInfo *renderInfo) | grass::GrassDrawable |
mesh | grass::GrassDrawable | protected
moreDetailedVersion | grass::GrassDrawable | protected
params | grass::GrassDrawable | protected
PrepareDisplayList(osg::RenderInfo &renderInfo) const | grass::GrassDrawable | protected
role | grass::GrassDrawable | protected
ROLE enum name | grass::GrassDrawable |
TOP_LEVEL enum value | grass::GrassDrawable |
~GrassDrawable() | grass::GrassDrawable | virtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Mesh
grass::Mesh Member List

This is the complete list of members for grass::Mesh, including all inherited members.

Divide() const | grass::Mesh |
GetBound() const | grass::Mesh | inline
Mesh(const float nMaxGrassHeight) | grass::Mesh | inline
TriangleCollector class | grass::Mesh | friend
triangles | grass::Mesh |
~Mesh() | grass::Mesh | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • TriangleCollector
grass::TriangleCollector Member List

This is the complete list of members for grass::TriangleCollector, including all inherited members.

GetMesh(const Geode &geode, const float maxGrassHeight) | grass::TriangleCollector | static
operator()(const osg::Vec3 v1, const osg::Vec3 v2, const osg::Vec3 v3, bool treatVertexDataAsTemporary) | grass::TriangleCollector |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Function
ht::Function Member List

This is the complete list of members for ht::Function, including all inherited members.

_dist_line(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
_dist_line2(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
Evaluate()=0 | ht::Function | pure virtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • HeadTracking
ht::HeadTracking Member List

This is the complete list of members for ht::HeadTracking, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(Transformation, vrecko::MessageSensorTransformation) | ht::HeadTracking |
DECLARE_OUTPUT(MoveAvatar, vrecko::MessageVec3) | ht::HeadTracking | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
head_orientation | ht::HeadTracking | protected
head_pos | ht::HeadTracking | protected
head_sensor_number | ht::HeadTracking | protected
head_tracking_origin_position | ht::HeadTracking | protected
head_tracking_scale | ht::HeadTracking | protected
head_tracking_translate_mapping | ht::HeadTracking | protected
HeadTracking() | ht::HeadTracking |
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | ht::HeadTracking | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
last_avatar_pos | ht::HeadTracking | protected
left_eye_off | ht::HeadTracking | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
optitrack_origin_position | ht::HeadTracking | protected
optitrack_scale | ht::HeadTracking | protected
optitrack_translate_mapping | ht::HeadTracking | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
right_eye_off | ht::HeadTracking | protected
s_corner | ht::HeadTracking | protected
s_height | ht::HeadTracking | protected
s_width | ht::HeadTracking | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
screen | ht::HeadTracking | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
unit | ht::HeadTracking | protected
update() | ht::HeadTracking | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~HeadTracking() | ht::HeadTracking | virtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Screen
ht::Screen Member List

This is the complete list of members for ht::Screen, including all inherited members.

GetMatrix() const | ht::Screen | inline
GetMatrixInv() const | ht::Screen | inline
IsValid() const | ht::Screen | inline
Screen() | ht::Screen |
SetScreen(osg::Vec3 corner, osg::Vec3 width, osg::Vec3 height) | ht::Screen |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetup
ht::ScreenSetup Member List

This is the complete list of members for ht::ScreenSetup, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
Corner enum name | ht::ScreenSetup |
DECLARE_INPUT(Position, vrecko::MessageSensorTransformation) | ht::ScreenSetup |
DECLARE_INPUT(Record, vrecko::MessageBool) | ht::ScreenSetup |
DECLARE_INPUT(NextCorner, vrecko::MessageBool) | ht::ScreenSetup |
DECLARE_INPUT(ShowPosition, vrecko::MessageBool) | ht::ScreenSetup |
DECLARE_INPUT(RunCalculation, vrecko::MessageBool) | ht::ScreenSetup |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | ht::ScreenSetup | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
LeftBottom enum value | ht::ScreenSetup |
LeftTop enum value | ht::ScreenSetup |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
RightBottom enum value | ht::ScreenSetup |
RightTop enum value | ht::ScreenSetup |
SaveSetup() | ht::ScreenSetup | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
ScreenSetup() | ht::ScreenSetup |
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ScreenSetup() | ht::ScreenSetup | protectedvirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetupSimple
ht::ScreenSetupSimple Member List

This is the complete list of members for ht::ScreenSetupSimple, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_INPUT(Position, vrecko::MessageSensorTransformation) | ht::ScreenSetupSimple |
DECLARE_INPUT(Record, vrecko::MessageBool) | ht::ScreenSetupSimple |
DECLARE_INPUT(ShowPosition, vrecko::MessageBool) | ht::ScreenSetupSimple |
DECLARE_INPUT(RunCalculation, vrecko::MessageBool) | ht::ScreenSetupSimple |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | ht::ScreenSetupSimple | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
SaveSetup() | ht::ScreenSetupSimple | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
ScreenSetupSimple() | ht::ScreenSetupSimple |
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ScreenSetupSimple() | ht::ScreenSetupSimple | protectedvirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • SetupFunction
ht::SetupFunction Member List

This is the complete list of members for ht::SetupFunction, including all inherited members.

_dist_line(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
_dist_line2(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
Evaluate() override | ht::SetupFunction | inlinevirtual
monitor_corner | ht::SetupFunction |
monitor_orientation | ht::SetupFunction |
monitor_position | ht::SetupFunction |
rim_height | ht::SetupFunction |
rim_width | ht::SetupFunction |
sensor_offset | ht::SetupFunction |
SetupFunction(const ScreenSetup::ScreenSetupState &st) | ht::SetupFunction | inline
wire_length | ht::SetupFunction |
wire_orientation | ht::SetupFunction |
wire_position | ht::SetupFunction |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • SimpleSetupFunction
ht::SimpleSetupFunction Member List

This is the complete list of members for ht::SimpleSetupFunction, including all inherited members.

_dist_line(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
_dist_line2(osg::Vec3d v, osg::Vec3d l1, osg::Vec3d l2) | ht::Function | inlineprotected
Evaluate() override | ht::SimpleSetupFunction | inlinevirtual
mon_cor_position | ht::SimpleSetupFunction |
sensor_offset | ht::SimpleSetupFunction |
SimpleSetupFunction(const ScreenSetupSimple::ScreenSetupSimpleState &st) | ht::SimpleSetupFunction | inline
wire_length | ht::SimpleSetupFunction |
wire_orientation | ht::SimpleSetupFunction |
wire_position | ht::SimpleSetupFunction |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • Variable
ht::Variable Member List

This is the complete list of members for ht::Variable, including all inherited members.

AddDelta(int variable, double delta)=0 | ht::Variable | pure virtual
GetVariablesCount()=0 | ht::Variable | pure virtual
ResetDelta()=0 | ht::Variable | pure virtual
SetDelta(int variable, double delta)=0 | ht::Variable | pure virtual
~Variable() | ht::Variable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableFloat
ht::VariableFloat Member List

This is the complete list of members for ht::VariableFloat, including all inherited members.

AddDelta(int variable, double delta) override | ht::VariableFloat | inlinevirtual
GetValue() | ht::VariableFloat | inline
GetValueInFunction() | ht::VariableFloat | inline
GetVariablesCount() override | ht::VariableFloat | inlinevirtual
operator=(const VariableFloat &f) | ht::VariableFloat | inline
ResetDelta() override | ht::VariableFloat | inlinevirtual
SetDelta(int variable, double delta) override | ht::VariableFloat | inlinevirtual
SetValue(double v) | ht::VariableFloat | inline
VariableFloat() | ht::VariableFloat | inline
VariableFloat(const VariableFloat &f) | ht::VariableFloat | inline
~Variable() | ht::Variable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableQuat
ht::VariableQuat Member List

This is the complete list of members for ht::VariableQuat, including all inherited members.

AddDelta(int variable, double delta) override | ht::VariableQuat | inlinevirtual
GetValue() | ht::VariableQuat | inline
GetValueInFunction() | ht::VariableQuat | inline
GetVariablesCount() override | ht::VariableQuat | inlinevirtual
operator=(const VariableQuat &v) | ht::VariableQuat | inline
ResetDelta() override | ht::VariableQuat | inlinevirtual
SetDelta(int variable, double delta) override | ht::VariableQuat | inlinevirtual
SetValue(osg::Quat v) | ht::VariableQuat | inline
VariableQuat() | ht::VariableQuat | inline
VariableQuat(const VariableQuat &v) | ht::VariableQuat | inline
~Variable() | ht::Variable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableVec2
ht::VariableVec2 Member List

This is the complete list of members for ht::VariableVec2, including all inherited members.

AddDelta(int variable, double delta) override | ht::VariableVec2 | inlinevirtual
GetValue() | ht::VariableVec2 | inline
GetValueInFunction() | ht::VariableVec2 | inline
GetVariablesCount() override | ht::VariableVec2 | inlinevirtual
operator=(const VariableVec2 &v) | ht::VariableVec2 | inline
ResetDelta() override | ht::VariableVec2 | inlinevirtual
SetDelta(int variable, double delta) override | ht::VariableVec2 | inlinevirtual
SetValue(osg::Vec2d v) | ht::VariableVec2 | inline
VariableVec2() | ht::VariableVec2 | inline
VariableVec2(const VariableVec2 &v) | ht::VariableVec2 | inline
~Variable() | ht::Variable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • VariableVec3
ht::VariableVec3 Member List

This is the complete list of members for ht::VariableVec3, including all inherited members.

AddDelta(int variable, double delta) override | ht::VariableVec3 | inlinevirtual
GetValue() | ht::VariableVec3 | inline
GetValueInFunction() | ht::VariableVec3 | inline
GetVariablesCount() override | ht::VariableVec3 | inlinevirtual
operator=(const VariableVec3 &v) | ht::VariableVec3 | inline
ResetDelta() override | ht::VariableVec3 | inlinevirtual
SetDelta(int variable, double delta) override | ht::VariableVec3 | inlinevirtual
SetValue(osg::Vec3d v) | ht::VariableVec3 | inline
VariableVec3() | ht::VariableVec3 | inline
VariableVec3(const VariableVec3 &v) | ht::VariableVec3 | inline
~Variable() | ht::Variable | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CCollection
mv::CCollection Member List

This is the complete list of members for mv::CCollection, including all inherited members.

CCollection() | mv::CCollection
glist | mv::CCollection
~CCollection() | mv::CCollection
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CGesture
mv::CGesture Member List

This is the complete list of members for mv::CGesture, including all inherited members.

addVectOnEnd(CMVect *newmvect) | mv::CGesture |
CGesture() | mv::CGesture |
CGesture(const CGesture &othergesture) | mv::CGesture |
delAllVect() | mv::CGesture |
delVectOnEnd() | mv::CGesture |
getMovable() | mv::CGesture | inline
getSPoint() | mv::CGesture | inline
getWTime() | mv::CGesture | inline
Movable | mv::CGesture |
RVect | mv::CGesture |
setMovable(bool val) | mv::CGesture | inline
setSPoint(gmVector3 newpoint) | mv::CGesture | inline
setWTime(double newwtime) | mv::CGesture | inline
SPoint | mv::CGesture |
Vectors | mv::CGesture |
WTime | mv::CGesture |
~CGesture() | mv::CGesture |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CMVect
mv::CMVect Member List

This is the complete list of members for mv::CMVect, including all inherited members.

CMVect(gmVector3 newvect, double newv0=1, double newv1=1, bool newonce=false) | mv::CMVect |
CMVect(double nx=0, double ny=0, double nz=0, double newv0=1, double newv1=1, bool newonce=false) | mv::CMVect |
CMVect(CMVect &OtherVector) | mv::CMVect |
Eval(double p) | mv::CMVect |
getOnce() | mv::CMVect | inline
getV0() | mv::CMVect | inline
getV1() | mv::CMVect | inline
getVect() | mv::CMVect | inline
Length() | mv::CMVect | inline
setOnce(bool newonce) | mv::CMVect | inline
setV0(double newv0) | mv::CMVect | inline
setV1(double newv1) | mv::CMVect | inline
setVect(gmVector3 newvect) | mv::CMVect | inline
~CMVect() | mv::CMVect |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CPlayer
mv::CPlayer Member List

This is the complete list of members for mv::CPlayer, including all inherited members.

ActCollection | mv::CPlayer |
addGesture(CGesture *newgesture) | mv::CPlayer |
ComputeForce(gmVector3 DevicePos, gmVector3 DeviceVel, gmVector3 Pos) | mv::CPlayer |
ControlPosition(gmVector3 Pos) | mv::CPlayer |
CPlayer() | mv::CPlayer |
delAllGestures() | mv::CPlayer |
delGesture() | mv::CPlayer |
getActGesture() | mv::CPlayer | inline
getActPos() | mv::CPlayer | inline
getActT() | mv::CPlayer | inline
getActVect() | mv::CPlayer | inline
getActVel() | mv::CPlayer | inline
getAll() | mv::CPlayer | inline
getDirection() | mv::CPlayer | inline
getForce() | mv::CPlayer | inline
getLoop() | mv::CPlayer | inline
getPause() | mv::CPlayer | inline
getPlay() | mv::CPlayer | inline
i | mv::CPlayer |
setAll(bool val) | mv::CPlayer | inline
setDirection(bool val) | mv::CPlayer | inline
setForce(bool val) | mv::CPlayer | inline
setLoop(bool val) | mv::CPlayer | inline
setPause(bool val) | mv::CPlayer | inline
setPlay(bool val) | mv::CPlayer | inline
Step() | mv::CPlayer |
Step(gmVector3 DevicePos, gmVector3 DeviceVel) | mv::CPlayer |
Step_backward(gmVector3 &r, double &wtime, bool &rflag, double &p, double &v0, double &v1, double &l) | mv::CPlayer |
Step_forward(gmVector3 &r, double &wtime, bool &rflag, double &p, double &v0, double &v1, double &l) | mv::CPlayer |
~CPlayer() | mv::CPlayer |
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • Reader
mv::Reader Member List

This is the complete list of members for mv::Reader, including all inherited members.

Load(const char *filename) | mv::Reader
Reader() | mv::Reader
Reader(const char *filename) | mv::Reader
Save(const char *filename) | mv::Reader
~Reader() | mv::Reader
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • navigation
  • AvatarInHand
navigation::AvatarInHand Member List

This is the complete list of members for navigation::AvatarInHand, including all inherited members.

_actual_head_orientation | navigation::AvatarInHand | protected
_actual_head_position | navigation::AvatarInHand | protected
_actual_left_hand_orientation | navigation::AvatarInHand | protected
_actual_left_hand_position | navigation::AvatarInHand | protected
_actual_position | navigation::AvatarInHand | protected
_actual_right_hand_orientation | navigation::AvatarInHand | protected
_actual_right_hand_position | navigation::AvatarInHand | protected
_last_position | navigation::AvatarInHand | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
absolut | navigation::AvatarInHand | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
angle | navigation::AvatarInHand | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
av | navigation::AvatarInHand | protected
av_pos | navigation::AvatarInHand | protected
avatar_look_at | navigation::AvatarInHand | protected
avatar_position | navigation::AvatarInHand | protected
avatar_up_vector | navigation::AvatarInHand | protected
AvatarInHand() | navigation::AvatarInHand |
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
const_d | navigation::AvatarInHand | protected
DECLARE_OUTPUT(Position, MessageVec3) | navigation::AvatarInHand | protected
DECLARE_OUTPUT(Orientation, MessageQuat) | navigation::AvatarInHand | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
eo | navigation::AvatarInHand | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fly | navigation::AvatarInHand | protected
getAcceptableMessages(void) | navigation::AvatarInHand | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
grab_position | navigation::AvatarInHand | protected
immersive | navigation::AvatarInHand | protected
initialize(void) | navigation::AvatarInHand |
vrecko::Ability::initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | navigation::AvatarInHand | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mesg | navigation::AvatarInHand | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pom | navigation::AvatarInHand | protected
postInitialize(void) | navigation::AvatarInHand | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *message) | navigation::AvatarInHand | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
q | navigation::AvatarInHand | protected
qc | navigation::AvatarInHand | protected
qc_old | navigation::AvatarInHand | protected
qd | navigation::AvatarInHand | protected
qd_init | navigation::AvatarInHand | protected
qd_old | navigation::AvatarInHand | protected
qd_old2 | navigation::AvatarInHand | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | navigation::AvatarInHand | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
start | navigation::AvatarInHand | protected
update(void) | navigation::AvatarInHand | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~AvatarInHand() | navigation::AvatarInHand | inline
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • navigation
  • KMTracker
navigation::KMTracker Member List

This is the complete list of members for navigation::KMTracker, including all inherited members.

_actual_position | navigation::KMTracker | protected
_avatarMovement | navigation::KMTracker | protected
_last_position | navigation::KMTracker | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
alwaysSendOrientationWithPosition | navigation::KMTracker | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
av | navigation::KMTracker | protected
avatar_look_at | navigation::KMTracker | protected
avatar_position | navigation::KMTracker | protected
avatar_up_vector | navigation::KMTracker | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_OUTPUT(Orientation, MessageQuat) | navigation::KMTracker | protected
DECLARE_OUTPUT(Move, MessageVec3) | navigation::KMTracker | protected
DECLARE_OUTPUT(MoveLocal, MessageVec3) | navigation::KMTracker | protected
DECLARE_OUTPUT(PositionRight, MessageVec3) | navigation::KMTracker | protected
DECLARE_OUTPUT(PositionLeft, MessageVec3) | navigation::KMTracker | protected
DECLARE_OUTPUT(OrientationRight, MessageQuat) | navigation::KMTracker | protected
DECLARE_OUTPUT(OrientationLeft, MessageQuat) | navigation::KMTracker | protected
DECLARE_OUTPUT(ButtonLeft, MessageBool) | navigation::KMTracker | protected
DECLARE_OUTPUT(ButtonRight, MessageBool) | navigation::KMTracker | protected
DECLARE_OUTPUT(LH_ButtonLeft, MessageBool) | navigation::KMTracker | protected
DECLARE_OUTPUT(LH_ButtonRight, MessageBool) | navigation::KMTracker | protected
DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation) | navigation::KMTracker | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
direction | navigation::KMTracker | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hand_orientation_left | navigation::KMTracker | protected
hand_orientation_right | navigation::KMTracker | protected
hand_position_left | navigation::KMTracker | protected
hand_position_right | navigation::KMTracker | protected
horiz | navigation::KMTracker | protected
i | navigation::KMTracker | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
KMTracker() | navigation::KMTracker |
KMTracker::sendSensorInfo(bool rightHand) | navigation::KMTracker | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | navigation::KMTracker | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mesg | navigation::KMTracker | protected
mouse_pos | navigation::KMTracker | protected
mouse_scroll | navigation::KMTracker | protected
mouse_sensitivity_avatar | navigation::KMTracker | protected
mouse_sensitivity_hands | navigation::KMTracker | protected
move_direction | navigation::KMTracker | protected
move_plane | navigation::KMTracker | protected
move_step | navigation::KMTracker | protected
moving | navigation::KMTracker | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
old_mouse_pos | navigation::KMTracker | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | navigation::KMTracker | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
Plane_type enum name | navigation::KMTracker | protected
plane_xy enum value | navigation::KMTracker | protected
plane_xz enum value | navigation::KMTracker | protected
plane_yz enum value | navigation::KMTracker | protected
postInitialize(void) | navigation::KMTracker | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | navigation::KMTracker | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *message) | navigation::KMTracker | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
right_hand | navigation::KMTracker | protected
rotation_step | navigation::KMTracker | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | navigation::KMTracker | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
smer | navigation::KMTracker | protected
smer3d | navigation::KMTracker | protected
stopped | navigation::KMTracker | protected
update(void) | navigation::KMTracker | virtual
updated | vrecko::Ability | protected
vert | navigation::KMTracker | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~KMTracker() | navigation::KMTracker | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CappedCylinder
ode::CappedCylinder Member List

This is the complete list of members for ode::CappedCylinder, including all inherited members.

_density | ode::CappedCylinder | protected
_direction | ode::CappedCylinder | protected
_length | ode::CappedCylinder | protected
_radius | ode::CappedCylinder | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
CappedCylinder() | ode::CappedCylinder |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid) | ode::CappedCylinder | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ode::CappedCylinder | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ode::CappedCylinder | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | ode::CappedCylinder | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | ode::CappedCylinder | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CappedCylinder() | ode::CappedCylinder | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CompositeObject
ode::CompositeObject Member List

This is the complete list of members for ode::CompositeObject, including all inherited members.

_data | ode::CompositeObject | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
CompositeObject() | ode::CompositeObject |
DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid) | ode::CompositeObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ode::CompositeObject | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ode::CompositeObject | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | ode::CompositeObject | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
translate | ode::CompositeObject | protected
update(void) | ode::CompositeObject | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~CompositeObject() | ode::CompositeObject | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • Cube
ode::Cube Member List

This is the complete list of members for ode::Cube, including all inherited members.

_density | ode::Cube | protected
_size | ode::Cube | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
Cube() | ode::Cube |
DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid) | ode::Cube | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ode::Cube | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ode::Cube | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | ode::Cube | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | ode::Cube | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Cube() | ode::Cube | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • DynamicScene
ode::DynamicScene Member List

This is the complete list of members for ode::DynamicScene, including all inherited members.

_CFM | ode::DynamicScene | protected
_contact_group | ode::DynamicScene |
_dynamic_object | ode::DynamicScene | protected
_enabled_objects | ode::DynamicScene | protected
_ERP | ode::DynamicScene | protected
_gravity | ode::DynamicScene | protected
_objects_dGeomID | ode::DynamicScene | protected
_plane | ode::DynamicScene | protected
_retq | ode::DynamicScene | protected
_retv | ode::DynamicScene | protected
_scene_objects | ode::DynamicScene | protected
_space | ode::DynamicScene |
_world | ode::DynamicScene |
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_INPUT(ODE, MessageODERequest, MessageVoid) | ode::DynamicScene | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
disableThreshold(void) | ode::DynamicScene | protected
DynamicScene() | ode::DynamicScene |
enableAllObjects(void) | ode::DynamicScene |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | ode::DynamicScene | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
Object_Pair typedef | ode::DynamicScene |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAngularVel(vrecko::EnvironmentObject *_eobject, osg::Vec3 _av) | ode::DynamicScene |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setEnableFlag(vrecko::EnvironmentObject *_eobject, bool _new_state) | ode::DynamicScene |
setForce(vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv) | ode::DynamicScene |
setForceToDynamicObject(vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz) | ode::DynamicScene |
setID(const char *pID) | vrecko::Ability |
setLinearVel(vrecko::EnvironmentObject *_eobject, osg::Vec3 _lv) | ode::DynamicScene |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTorque(vrecko::EnvironmentObject *_eobject, osg::Vec3 _fv) | ode::DynamicScene |
setTorqueToDynamicObject(vrecko::EnvironmentObject *_eobject, float _fx, float _fy, float _fz) | ode::DynamicScene |
update(void) | ode::DynamicScene | virtual
updated | vrecko::Ability | protected
updateLocationInDynamic(void) | ode::DynamicScene | protected
updateLocationInNonDynamic(void) | ode::DynamicScene | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~DynamicScene() | ode::DynamicScene |
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • DynamicScene
  • MessageODERequest
ode::DynamicScene::MessageODERequest Member List

This is the complete list of members for ode::DynamicScene::MessageODERequest, including all inherited members.

getMessageId() | ode::DynamicScene::MessageODERequest | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
object | ode::DynamicScene::MessageODERequest |
parameter | ode::DynamicScene::MessageODERequest |
sender | ode::DynamicScene::MessageODERequest |
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
type | ode::DynamicScene::MessageODERequest |
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • Sphere
ode::Sphere Member List

This is the complete list of members for ode::Sphere, including all inherited members.

_density | ode::Sphere | protected
_radius | ode::Sphere | protected
Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid) | ode::Sphere | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | ode::Sphere | virtual
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | ode::Sphere | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | ode::Sphere | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
Sphere() | ode::Sphere |
update(void) | ode::Sphere | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Sphere() | ode::Sphere | inline
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QComputeBoundShapeVisitor
osgQ::QComputeBoundShapeVisitor Member List

This is the complete list of members for osgQ::QComputeBoundShapeVisitor, including all inherited members.

_bb | osgQ::QComputeBoundShapeVisitor |
apply(const QSection &) | osgQ::QComputeBoundShapeVisitor | virtual
QComputeBoundShapeVisitor(BoundingBox &bb) | osgQ::QComputeBoundShapeVisitor | inline
QConstShapeVisitor() | osgQ::QConstShapeVisitor | inline
~QConstShapeVisitor() | osgQ::QConstShapeVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QConstShapeVisitor
osgQ::QConstShapeVisitor Member List

This is the complete list of members for osgQ::QConstShapeVisitor, including all inherited members.

apply(const QSection &) | osgQ::QConstShapeVisitor | inlinevirtual
QConstShapeVisitor() | osgQ::QConstShapeVisitor | inline
~QConstShapeVisitor() | osgQ::QConstShapeVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QDrawShapeVisitor
osgQ::QDrawShapeVisitor Member List

This is the complete list of members for osgQ::QDrawShapeVisitor, including all inherited members.

_hints | osgQ::QDrawShapeVisitor |
_state | osgQ::QDrawShapeVisitor |
apply(const QSection &) | osgQ::QDrawShapeVisitor | virtual
QConstShapeVisitor() | osgQ::QConstShapeVisitor | inline
QDrawShapeVisitor(State &state, const TessellationHints *hints) | osgQ::QDrawShapeVisitor | inline
~QConstShapeVisitor() | osgQ::QConstShapeVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QPrimitiveShapeVisitor
osgQ::QPrimitiveShapeVisitor Member List

This is the complete list of members for osgQ::QPrimitiveShapeVisitor, including all inherited members.

_functor | osgQ::QPrimitiveShapeVisitor |
_hints | osgQ::QPrimitiveShapeVisitor |
apply(const QSection &) | osgQ::QPrimitiveShapeVisitor | virtual
QConstShapeVisitor() | osgQ::QConstShapeVisitor | inline
QPrimitiveShapeVisitor(PrimitiveFunctor &functor, const TessellationHints *hints) | osgQ::QPrimitiveShapeVisitor | inline
~QConstShapeVisitor() | osgQ::QConstShapeVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QSection
osgQ::QSection Member List

This is the complete list of members for osgQ::QSection, including all inherited members.

_angleFrom | osgQ::QSection | protected
_angleTo | osgQ::QSection | protected
_center | osgQ::QSection | protected
_height | osgQ::QSection | protected
_innerRadius | osgQ::QSection | protected
_outerAngleAddition | osgQ::QSection | protected
_outerRadius | osgQ::QSection | protected
_rotation | osgQ::QSection | protected
accept(osg::ShapeVisitor &sv) | osgQ::QSection | inlinevirtual
accept(osg::ConstShapeVisitor &csv) const | osgQ::QSection | inlinevirtual
className() const | osgQ::QSection | inlinevirtual
clone(const osg::CopyOp &copyop) const | osgQ::QSection | inlinevirtual
cloneType() const | osgQ::QSection | inlinevirtual
computeNumberOfSegments() const | osgQ::QSection | inline
computeRotationMatrix() const | osgQ::QSection | inline
getAngleFrom() const | osgQ::QSection | inline
getAngleTo() const | osgQ::QSection | inline
getCenter() const | osgQ::QSection | inline
getHeight() const | osgQ::QSection | inline
getInnerRadius() const | osgQ::QSection | inline
getOuterAngleAddition() const | osgQ::QSection | inline
getOuterRadius() const | osgQ::QSection | inline
getRotation() const | osgQ::QSection | inline
isSameKindAs(const osg::Object *obj) const | osgQ::QSection | inlinevirtual
libraryName() const | osgQ::QSection | inlinevirtual
QSection() | osgQ::QSection | inline
QSection(const osg::Vec3 &center, float innerRadius, float outerRadius, float angleFrom, float angleTo, float outerAngleAddition, float height) | osgQ::QSection | inline
QSection(const QSection &qsection, const osg::CopyOp &copyop=osg::CopyOp::SHALLOW_COPY) | osgQ::QSection | inline
set(const osg::Vec3 &center, float outerRadius, float innerRadius, float angleFrom, float angleTo, float outerAngleAddition, float height) | osgQ::QSection | inline
setAngleFrom(float angleFrom) | osgQ::QSection | inline
setAngleTo(float angleTo) | osgQ::QSection | inline
setCenter(const osg::Vec3 &center) | osgQ::QSection | inline
setHeight(float height) | osgQ::QSection | inline
setInnerRadius(float innerRadius) | osgQ::QSection | inline
setOuterAngleAddition(float outerAngleAddition) | osgQ::QSection | inline
setOuterRadius(float outerRadius) | osgQ::QSection | inline
setRotation(const osg::Quat &quat) | osgQ::QSection | inline
valid() const | osgQ::QSection | inline
zeroRotation() const | osgQ::QSection | inline
~QSection() | osgQ::QSection | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QShapeDrawable
osgQ::QShapeDrawable Member List

This is the complete list of members for osgQ::QShapeDrawable, including all inherited members.

accept(osg::PrimitiveFunctor &pf) const | osgQ::QShapeDrawable | virtual
computeBound() const | osgQ::QShapeDrawable | virtual
drawImplementation(osg::RenderInfo &renderInfo) const | osgQ::QShapeDrawable | virtual
QShapeDrawable(osg::Shape *shape, osg::TessellationHints *hints=0) | osgQ::QShapeDrawable | inline
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • osgQ
  • QShapeVisitor
osgQ::QShapeVisitor Member List

This is the complete list of members for osgQ::QShapeVisitor, including all inherited members.

apply(const QSection &) | osgQ::QShapeVisitor | inlinevirtual
QShapeVisitor() | osgQ::QShapeVisitor | inline
~QShapeVisitor() | osgQ::QShapeVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Ability
vrecko::Ability Member List

This is the complete list of members for vrecko::Ability, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • AbilityDispatcher
vrecko::AbilityDispatcher Member List

This is the complete list of members for vrecko::AbilityDispatcher, including all inherited members.

ability_map | vrecko::AbilityDispatcher | protected
ability_name_map | vrecko::AbilityDispatcher | protected
AbilityDispatcher() | vrecko::AbilityDispatcher |
AbilityMap typedef | vrecko::AbilityDispatcher |
addAbility(Ability *pAbility) | vrecko::AbilityDispatcher |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAbility(const std::string &ab_id) | vrecko::AbilityDispatcher |
getAbilityMap(void) | vrecko::AbilityDispatcher | inline
getAbilityWithInput(const std::string &input_name) | vrecko::AbilityDispatcher |
getAbilityWithOutput(const std::string &output_name) | vrecko::AbilityDispatcher |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mainLock | vrecko::AbilityDispatcher | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::AbilityDispatcher |
removeAllAbilities() | vrecko::AbilityDispatcher |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
~AbilityDispatcher() | vrecko::AbilityDispatcher |
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Attribute
vrecko::Attribute Member List

This is the complete list of members for vrecko::Attribute, including all inherited members.

Attribute(const string &strName, DataType dataType, const string &strDescription) | vrecko::Attribute | inlineprotected
Attribute(const Attribute &attribute) | vrecko::Attribute | inlineprotected
DataType enum name | vrecko::Attribute |
getDataType() const | vrecko::Attribute | inline
getDescription() const | vrecko::Attribute | inline
getName() const | vrecko::Attribute | inline
isDynamic() const | vrecko::Attribute | inline
isStatic() const | vrecko::Attribute | inline
TYPE_BOOL enum value | vrecko::Attribute |
TYPE_DOUBLE enum value | vrecko::Attribute |
TYPE_DYNAMIC enum value | vrecko::Attribute |
TYPE_FLOAT enum value | vrecko::Attribute |
TYPE_INT enum value | vrecko::Attribute |
TYPE_LONG enum value | vrecko::Attribute |
TYPE_MATRIX enum value | vrecko::Attribute |
TYPE_QUAT enum value | vrecko::Attribute |
TYPE_STRING enum value | vrecko::Attribute |
TYPE_VEC2 enum value | vrecko::Attribute |
TYPE_VEC3 enum value | vrecko::Attribute |
TYPE_VEC4 enum value | vrecko::Attribute |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • AttributesDescription
vrecko::AttributesDescription Member List

This is the complete list of members for vrecko::AttributesDescription, including all inherited members.

addAttribute(Attribute *pAttribute) | vrecko::AttributesDescription | inline
attributesCount() const | vrecko::AttributesDescription | inline
containsAttribute(const string &strName) const | vrecko::AttributesDescription | inline
getAttributePtr(const string &strName) const | vrecko::AttributesDescription | inline
hasAnyAttributes() const | vrecko::AttributesDescription | inline
hasNextAttribute() const | vrecko::AttributesDescription | inline
nextAttributePtr() | vrecko::AttributesDescription | inline
startIteration() | vrecko::AttributesDescription | inline
~AttributesDescription() | vrecko::AttributesDescription | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BaseClass
vrecko::BaseClass Member List

This is the complete list of members for vrecko::BaseClass, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BenchmarkWriter
vrecko::BenchmarkWriter Member List

This is the complete list of members for vrecko::BenchmarkWriter, including all inherited members.

BenchmarkWriter() | vrecko::BenchmarkWriter |
bOpenData | vrecko::BenchmarkWriter | protected
bOpenFrame | vrecko::BenchmarkWriter | protected
bOpenInfo | vrecko::BenchmarkWriter | protected
bOpenMain | vrecko::BenchmarkWriter | protected
bOpenMiscStats | vrecko::BenchmarkWriter | protected
bOpenSettings | vrecko::BenchmarkWriter | protected
bWriting | vrecko::BenchmarkWriter | protected
closeFile() | vrecko::BenchmarkWriter |
file | vrecko::BenchmarkWriter | protected
isOpened() | vrecko::BenchmarkWriter | inline
openFile(const char *pFileName=NULL) | vrecko::BenchmarkWriter |
setWriting(bool bValue) | vrecko::BenchmarkWriter |
writeCounter(const char *pName, float fValue) | vrecko::BenchmarkWriter |
writeDataEnd() | vrecko::BenchmarkWriter |
writeDataStart() | vrecko::BenchmarkWriter |
writeFrameEnd() | vrecko::BenchmarkWriter |
writeFramesRendered(unsigned int dwNum) | vrecko::BenchmarkWriter |
writeFrameStart(unsigned int dwTime) | vrecko::BenchmarkWriter |
writeInfoEnd() | vrecko::BenchmarkWriter |
writeInfoLine(const char *pText,...) | vrecko::BenchmarkWriter |
writeInfoStart() | vrecko::BenchmarkWriter |
writeMiscStatsEnd() | vrecko::BenchmarkWriter |
writeMiscStatsStart() | vrecko::BenchmarkWriter |
writeParam(const char *pName, const char *pValue) | vrecko::BenchmarkWriter |
writeParam(const char *pName, float fValue) | vrecko::BenchmarkWriter |
writeRunTime(unsigned int dwTime) | vrecko::BenchmarkWriter |
writeSettingsEnd() | vrecko::BenchmarkWriter |
writeSettingsStart() | vrecko::BenchmarkWriter |
writingAllowed() | vrecko::BenchmarkWriter | inline
~BenchmarkWriter() | vrecko::BenchmarkWriter |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BufferedFile
vrecko::BufferedFile Member List

This is the complete list of members for vrecko::BufferedFile, including all inherited members.

bCallSFP | vrecko::BufferedFile | protected
bCloseFile | vrecko::BufferedFile | protected
bFileIsUTF | vrecko::BufferedFile | protected
bReversedWChar | vrecko::BufferedFile | protected
BufferedFile(void) | vrecko::BufferedFile |
close(void) | vrecko::BufferedFile |
dwBehvFlags | vrecko::BufferedFile | protected
dwBufSize | vrecko::BufferedFile | protected
dwFilePos | vrecko::BufferedFile | protected
dwFileSize | vrecko::BufferedFile | protected
dwMaxPos | vrecko::BufferedFile | protected
dwPos | vrecko::BufferedFile |
dwZeroPos | vrecko::BufferedFile | protected
getBufSize(void) const | vrecko::BufferedFile | inline
getFilePos(void) const | vrecko::BufferedFile | inline
getFileSize(void) const | vrecko::BufferedFile | inline
getHandle() | vrecko::BufferedFile | inline
getMaxPos(void) const | vrecko::BufferedFile | inline
hFile | vrecko::BufferedFile | protected
init(_TCHAR *lpFileName) | vrecko::BufferedFile |
init(HANDLE hFile, bool bCallSPF) | vrecko::BufferedFile |
isEOF(void) | vrecko::BufferedFile | inline
lpBuffer | vrecko::BufferedFile |
preReadBytes(DWORD dwNumOfBytes) | vrecko::BufferedFile |
readBool(bool *pData) | vrecko::BufferedFile | inline
readByte(void) | vrecko::BufferedFile | inline
readByte(BYTE *pData) | vrecko::BufferedFile | inline
readBytes(LPVOID lpDest, DWORD dwBytesToRead) | vrecko::BufferedFile | inline
readBytes(LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead) | vrecko::BufferedFile | inline
readBytesCore(LPVOID lpDest, DWORD dwBytesToRead, LPDWORD lpdwBytesRead) | vrecko::BufferedFile | protected
readDWORD(DWORD *pData) | vrecko::BufferedFile | inline
readFloat(float *pData) | vrecko::BufferedFile | inline
readInt(int *pData) | vrecko::BufferedFile | inline
readInt64(__int64 *pData) | vrecko::BufferedFile | inline
readLine(PSTR pBuffer, PDWORD pdwCharSize) | vrecko::BufferedFile |
readLineW(PWSTR pBuffer, PDWORD pdwCharSize) | vrecko::BufferedFile |
readLONG(LONG *pData) | vrecko::BufferedFile | inline
readPOINT(POINT *pData) | vrecko::BufferedFile | inline
readRECT(RECT *pData) | vrecko::BufferedFile | inline
readStr(CHAR *pData) | vrecko::BufferedFile | inline
readVec3f(osg::Vec3f *v) | vrecko::BufferedFile | inline
readWCharTrans(WCHAR *wChar) | vrecko::BufferedFile |
readWORD(WORD *pData) | vrecko::BufferedFile | inline
setBehaviour(DWORD dwBehvFlags) | vrecko::BufferedFile |
setBufSize(DWORD dwNewSize) | vrecko::BufferedFile |
setFilePos(DWORD dwNewFilePos) | vrecko::BufferedFile |
tReadLine(_TCHAR *tBuffer, PDWORD pdwCharSize) | vrecko::BufferedFile | inline
UNICODECheck(void) | vrecko::BufferedFile | protected
~BufferedFile(void) | vrecko::BufferedFile |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BufferedFileWrite
vrecko::BufferedFileWrite Member List

This is the complete list of members for vrecko::BufferedFileWrite, including all inherited members.

buffer | vrecko::BufferedFileWrite | protected
BufferedFileWrite(void) | vrecko::BufferedFileWrite |
close(void) | vrecko::BufferedFileWrite |
dwBufMaxSize | vrecko::BufferedFileWrite | protected
flush(void) | vrecko::BufferedFileWrite |
getHandle() | vrecko::BufferedFileWrite | inline
hFile | vrecko::BufferedFileWrite | protected
init(TCHAR *lpFileName) | vrecko::BufferedFileWrite |
write(LPVOID lpBuffer, DWORD dwSize) | vrecko::BufferedFileWrite | inline
writeBool(bool bData) | vrecko::BufferedFileWrite | inline
writeByte(BYTE bData) | vrecko::BufferedFileWrite | inline
writeDWORD(DWORD dwData) | vrecko::BufferedFileWrite | inline
writeFloat(float fData) | vrecko::BufferedFileWrite | inline
writeFormattedString(TCHAR *pFormat,...) | vrecko::BufferedFileWrite |
writeInt(int iData) | vrecko::BufferedFileWrite | inline
writeInt64(__int64 iData) | vrecko::BufferedFileWrite | inline
writeLONG(LONG lData) | vrecko::BufferedFileWrite | inline
writePOINT(POINT *pnt) | vrecko::BufferedFileWrite | inline
writeRECT(RECT *rData) | vrecko::BufferedFileWrite | inline
writeStr(PSTR pData) | vrecko::BufferedFileWrite | inline
writeVec3f(osg::Vec3f *v) | vrecko::BufferedFileWrite | inline
writeWORD(WORD wData) | vrecko::BufferedFileWrite | inline
~BufferedFileWrite(void) | vrecko::BufferedFileWrite |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionInfo
vrecko::CollisionInfo Member List

This is the complete list of members for vrecko::CollisionInfo, including all inherited members.

CollisionInfo() | vrecko::CollisionInfo | inline
eoID | vrecko::CollisionInfo |
points | vrecko::CollisionInfo |
~CollisionInfo() | vrecko::CollisionInfo | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionParams__ver1
vrecko::CollisionParams__ver1 Member List

This is the complete list of members for vrecko::CollisionParams__ver1, including all inherited members.

bgThreadAffinityMask | vrecko::CollisionParams__ver1 |
CollisionParams__ver1() | vrecko::CollisionParams__ver1 | inline
debugGlobalUpdatesCounter | vrecko::CollisionParams__ver1 |
dwFlags | vrecko::CollisionParams__ver1 |
dwStructureVersion | vrecko::CollisionParams__ver1 |
ignoredObjects | vrecko::CollisionParams__ver1 |
isSame(const CollisionParams__ver1 *other) const | vrecko::CollisionParams__ver1 | virtual
maxCollisionDistance | vrecko::CollisionParams__ver1 |
objIntPtr | vrecko::CollisionParams__ver1 |
preferredObjectInterface | vrecko::CollisionParams__ver1 |
preferredSceneInterface | vrecko::CollisionParams__ver1 |
rayEnd | vrecko::CollisionParams__ver1 |
rayStart | vrecko::CollisionParams__ver1 |
scIntPtr | vrecko::CollisionParams__ver1 |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CollisionPointInfo
vrecko::CollisionPointInfo Member List

This is the complete list of members for vrecko::CollisionPointInfo, including all inherited members.

dwFlags | vrecko::CollisionPointInfo
points | vrecko::CollisionPointInfo
vecTriMaxNegativeDistance | vrecko::CollisionPointInfo
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CompositeViewer
vrecko::CompositeViewer Member List

This is the complete list of members for vrecko::CompositeViewer, including all inherited members.

addEventHandler(osgGA::GUIEventHandler *eventHandler) | vrecko::CompositeViewer | inlinevirtual
addView(osgViewer::View *view) | vrecko::CompositeViewer | inlinevirtual
camera_setViewMatrixAsLookAt(const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up) | vrecko::CompositeViewer | inlinevirtual
CompositeViewer(int stereoMode) | vrecko::CompositeViewer |
done() | vrecko::ViewerBase | inline
frame(double simulationTime=USE_REFERENCE_TIME) | vrecko::ViewerBase | inline
getCamera(int screenNum=0) | vrecko::CompositeViewer | inlinevirtual
getCameras(osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true) | vrecko::ViewerBase | inline
getContexts(osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true) | vrecko::ViewerBase | inline
getLight() | vrecko::CompositeViewer | inlinevirtual
getStereoMode() | vrecko::CompositeViewer | inlinevirtual
getViewer() | vrecko::CompositeViewer | inlinevirtual
getWindows(osgViewer::ViewerBase::Windows &windows, bool onlyValid=true) | vrecko::ViewerBase | inline
realize() | vrecko::ViewerBase | inline
setDisplaySettings(osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL) | vrecko::CompositeViewer | inlinevirtual
setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f) | vrecko::CompositeViewer | inlinevirtual
setLight(osg::Light *light) | vrecko::CompositeViewer | inlinevirtual
setSceneData(osg::Node *node) | vrecko::CompositeViewer | inlinevirtual
setThreadingModel(osgViewer::ViewerBase::ThreadingModel threadingModel) | vrecko::ViewerBase | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ControllableAbility
vrecko::ControllableAbility Member List

This is the complete list of members for vrecko::ControllableAbility, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
activate() | vrecko::ControllableAbility | inlineprotectedvirtual
activePointerID | vrecko::ControllableAbility | protected
actPointerPos | vrecko::ControllableAbility | protected
actPointerPosRaw | vrecko::ControllableAbility | protected
actPointerRot | vrecko::ControllableAbility | protected
actPointerRotRaw | vrecko::ControllableAbility | protected
actPosInPath | vrecko::ControllableAbility | protected
actSelectedObjectID | vrecko::ControllableAbility | protected
actSelectedPath | vrecko::ControllableAbility | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bMenuVisible | vrecko::ControllableAbility | protected
clean(void) | vrecko::Ability | inlinevirtual
ControllableAbility(const char *abilityName) | vrecko::ControllableAbility |
createInfo() | vrecko::ControllableAbility | protectedvirtual
createInterface() | vrecko::ControllableAbility | protectedvirtual
createMenu(const char *menuString, bool bForceCreate=true) | vrecko::ControllableAbility | protectedvirtual
deactivate() | vrecko::ControllableAbility | protectedvirtual
DECLARE_INPUT(ButtonStateChange, MessageCAButtonEvent) | vrecko::ControllableAbility | protected
DECLARE_INPUT(Menu_Clicked, MessageString) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(ActivePointerID, MessageInt, MessageInt) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_INPUT(GetInfo, MessageVoid, MessageCAINFO) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPos, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRot, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerPosRaw, MessageInt, MessageVec3) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(PointerRotRaw, MessageInt, MessageQuat) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionID, MessageInt, MessageObjectID) | vrecko::ControllableAbility | protected
DECLARE_REQUEST_OUTPUT(SelectionPath, MessageInt, MessageNodeList) | vrecko::ControllableAbility | protected
defaultInfo | vrecko::ControllableAbility | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
destroyInterface() | vrecko::ControllableAbility | protectedvirtual
destroyMenu() | vrecko::ControllableAbility | protectedvirtual
fillDefaultInfo()=0 | vrecko::ControllableAbility | protectedpure virtual
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
hideMenu() | vrecko::ControllableAbility | protectedvirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::ControllableAbility | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isActive() | vrecko::ControllableAbility | virtual
isMenuCreated() | vrecko::ControllableAbility | inlineprotected
isMenuVisible() | vrecko::ControllableAbility | protected
isUpdated(void) | vrecko::Ability |
lastEventButtonID | vrecko::ControllableAbility | protected
vrecko::Ability::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
menu | vrecko::ControllableAbility | protected
menuItemClicked(const char *itemID) | vrecko::ControllableAbility | inlineprotectedvirtual
menuSliderChanged(const char *sliderID, float sliderPos) | vrecko::ControllableAbility | inlineprotectedvirtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
owner | vrecko::ControllableAbility | protected
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
pOwner | vrecko::Ability | protected
priority | vrecko::BaseClass | protected
processButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | inlineprotectedvirtual
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processMenuButtonPress(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processMenuButtonRelease(CABUTTONEVENT *eventData) | vrecko::ControllableAbility | protectedvirtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::ControllableAbility | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
requestPointerLoc(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestPointerLocRaw(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionID(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
requestSelectionPath(bool bCancelIfNotActive=true) | vrecko::ControllableAbility | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
showMenu() | vrecko::ControllableAbility | protectedvirtual
update() | vrecko::ControllableAbility | inlinevirtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~ControllableAbility() | vrecko::ControllableAbility | virtual
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ControllableAbility
  • MessageCAINFO
vrecko::ControllableAbility::MessageCAINFO Member List

This is the complete list of members for vrecko::ControllableAbility::MessageCAINFO, including all inherited members.

data | vrecko::ControllableAbility::MessageCAINFO |
getMessageId() | vrecko::ControllableAbility::MessageCAINFO | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Device
vrecko::Device Member List

This is the complete list of members for vrecko::Device, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void)=0 | vrecko::Device | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void)=0 | vrecko::Device | pure virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void)=0 | vrecko::Device | pure virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DeviceManager
vrecko::DeviceManager Member List

This is the complete list of members for vrecko::DeviceManager, including all inherited members.

_dl_map | vrecko::DeviceManager | protectedstatic
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
connectDevice(const std::string &plugin_name, const std::string &device_type, const char *port, Device **device_ptr) | vrecko::DeviceManager | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
device_map | vrecko::DeviceManager | protected
DeviceManager() | vrecko::DeviceManager |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDeviceInstance(const std::string &plugin_name, const std::string &device_type) | vrecko::DeviceManager | static
getDeviceMap(void) | vrecko::DeviceManager | inline
getDevicePtr(int device_id) | vrecko::DeviceManager |
getDevicePtrByType(const std::string &device_type) | vrecko::DeviceManager |
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestForDevice(const std::string &plugin_name, const std::string &device_type, const char *port, float frequency) | vrecko::DeviceManager |
requestForDevice(const std::string &plugin_name, const std::string &device_type, const char *port, int id, float frequency) | vrecko::DeviceManager |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~DeviceManager() | vrecko::DeviceManager |
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DynamicAttribute
vrecko::DynamicAttribute Member List

This is the complete list of members for vrecko::DynamicAttribute, including all inherited members.

addAttribute(Attribute *pAttribute) | vrecko::DynamicAttribute | inline
Attribute(const string &strName, DataType dataType, const string &strDescription) | vrecko::Attribute | inlineprotected
Attribute(const Attribute &attribute) | vrecko::Attribute | inlineprotected
attributesCount() const | vrecko::DynamicAttribute | inline
containsAttribute(const string &strName) const | vrecko::DynamicAttribute | inline
DataType enum name | vrecko::Attribute |
DynamicAttribute(const string &strName, const string &strDescription, unsigned int minInstancesCount=0, unsigned int maxInstancesCount=10) | vrecko::DynamicAttribute | inline
getAttributePtr(const string &strName) const | vrecko::DynamicAttribute | inline
getDataType() const | vrecko::Attribute | inline
getDescription() const | vrecko::Attribute | inline
getMaxInstancesCount() const | vrecko::DynamicAttribute | inline
getMinInstancesCount() const | vrecko::DynamicAttribute | inline
getName() const | vrecko::Attribute | inline
hasNextAttribute() const | vrecko::DynamicAttribute | inline
isDynamic() const | vrecko::Attribute | inline
isStatic() const | vrecko::Attribute | inline
nextAttributePtr() | vrecko::DynamicAttribute | inline
startIteration() | vrecko::DynamicAttribute | inline
TYPE_BOOL enum value | vrecko::Attribute |
TYPE_DOUBLE enum value | vrecko::Attribute |
TYPE_DYNAMIC enum value | vrecko::Attribute |
TYPE_FLOAT enum value | vrecko::Attribute |
TYPE_INT enum value | vrecko::Attribute |
TYPE_LONG enum value | vrecko::Attribute |
TYPE_MATRIX enum value | vrecko::Attribute |
TYPE_QUAT enum value | vrecko::Attribute |
TYPE_STRING enum value | vrecko::Attribute |
TYPE_VEC2 enum value | vrecko::Attribute |
TYPE_VEC3 enum value | vrecko::Attribute |
TYPE_VEC4 enum value | vrecko::Attribute |
~DynamicAttribute() | vrecko::DynamicAttribute | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Enumeration
vrecko::Enumeration< tval, tref > Member List

This is the complete list of members for vrecko::Enumeration< tval, tref >, including all inherited members.

containsValue(tref value) const | vrecko::Enumeration< tval, tref > | inline
Enumeration(unsigned int valuesCount,...) | vrecko::Enumeration< tval, tref > | inline
hasNextValue() const | vrecko::Enumeration< tval, tref > | inline
isEnumeration() const | vrecko::Range | inline
isInterval() const | vrecko::Range | inline
nextValue() | vrecko::Enumeration< tval, tref > | inline
Range(RangeType rangeType) | vrecko::Range | inlineprotected
Range(const Range &range) | vrecko::Range | inlineprotected
RANGE_ENUMERATION enum value | vrecko::Range |
RANGE_INTERVAL enum value | vrecko::Range |
RangeType enum name | vrecko::Range |
startIteration() | vrecko::Enumeration< tval, tref > | inline
valuesCount() const | vrecko::Enumeration< tval, tref > | inline
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EnvironmentObject
vrecko::EnvironmentObject Member List

This is the complete list of members for vrecko::EnvironmentObject, including all inherited members.

ability_dispatcher | vrecko::EnvironmentObject | protected
addAbility(Ability *ability, bool bCreateNewIdIfColliding=true) | vrecko::EnvironmentObject |
addEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addUserData(const std::string &nlabel, void *npointer, UserData_Type ntype) | vrecko::EnvironmentObject |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionFree | vrecko::EnvironmentObject | protected
bVisible | vrecko::EnvironmentObject | protected
createCollisionHierarchy(osg::Node *pNode) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Position, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Orientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(Location, MessageMatrix) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativePosition, MessageVec3) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeOrientation, MessageQuat) | vrecko::EnvironmentObject | protected
DECLARE_INPUT(RelativeLocation, MessageMatrix) | vrecko::EnvironmentObject | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
EnvironmentObject() | vrecko::EnvironmentObject |
EnvironmentObject(EnvironmentObject &eo) | vrecko::EnvironmentObject |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fixGeometryDrawableHelper(const osg::Drawable *draw, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryHelper(const osg::Node *node, bool bMirrored) | vrecko::EnvironmentObject | protected
fixGeometryMirroring(const osg::Node *node) | vrecko::EnvironmentObject | protected
getAbility(const std::string &ab_id) | vrecko::EnvironmentObject | inline
getAbility(const std::string &pluginName, const std::string &abilityName) | vrecko::EnvironmentObject |
getAbilityMap(void) | vrecko::EnvironmentObject | inline
getAbilityWithInput(const std::string &input_name) | vrecko::EnvironmentObject | inline
getAbilityWithOutput(const std::string &output_name) | vrecko::EnvironmentObject | inline
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID() const | vrecko::EnvironmentObject | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getModelFileName(void) const | vrecko::EnvironmentObject | inline
getName(void) const | vrecko::EnvironmentObject | inline
getOSGAdapter(void) | vrecko::EnvironmentObject | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getParentEO(void) | vrecko::EnvironmentObject |
getPosition() | vrecko::EnvironmentObject |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotation(void) | vrecko::EnvironmentObject | inline
getScale(void) | vrecko::EnvironmentObject | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTransparency(void) | vrecko::EnvironmentObject | inline
getUserData(const std::string &label) | vrecko::EnvironmentObject |
getUserDataMap(void) | vrecko::EnvironmentObject | inline
getWorldPosition(void) | vrecko::EnvironmentObject |
getWorldRotation(void) | vrecko::EnvironmentObject |
getWorldTransformation(void) | vrecko::EnvironmentObject |
hide() | vrecko::EnvironmentObject | inline
id | vrecko::EnvironmentObject | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::EnvironmentObject | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isCollisionFree() | vrecko::EnvironmentObject | inline
isVisible() | vrecko::EnvironmentObject | inline
loadGeometry(const char *filename, bool bOutputErrors=true) | vrecko::EnvironmentObject |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
modelFileName | vrecko::EnvironmentObject | protected
name | vrecko::EnvironmentObject | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
osgadapter_vector | vrecko::EnvironmentObject | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeAbility(Ability *pAbility) | vrecko::EnvironmentObject |
removeAbility(const std::string &ability_id) | vrecko::EnvironmentObject |
removeAllAbilities() | vrecko::EnvironmentObject | inline
removeEOChild(EnvironmentObject *new_EO) | vrecko::EnvironmentObject |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
removeUserData(const std::string &label) | vrecko::EnvironmentObject |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rotation_matrix | vrecko::EnvironmentObject | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scale_vec | vrecko::EnvironmentObject | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCastShadows(bool cast) | vrecko::EnvironmentObject |
setGeometry(osg::Geode *new_geomtetry, long int k=1, long int l=100000) | vrecko::EnvironmentObject |
setID(unsigned long new_id) | vrecko::EnvironmentObject |
setIdentityTransformation(void) | vrecko::EnvironmentObject |
setModelFileName(const std::string mfn) | vrecko::EnvironmentObject | inline
setName(const std::string &n) | vrecko::EnvironmentObject | inline
setOSGAdapter(std::vector< esg::OSGAdapter * > new_osga) | vrecko::EnvironmentObject | inline
setPosition(const osg::Vec3 &coords) | vrecko::EnvironmentObject |
setPosition(float x, float y, float z) | vrecko::EnvironmentObject |
setPriority(long int pr) | vrecko::BaseClass | inline
setRotation(float angle, float x, float y, float z) | vrecko::EnvironmentObject |
setRotation(const osg::Vec3 &angles) | vrecko::EnvironmentObject |
setRotation(const osg::Matrix &new_matrix) | vrecko::EnvironmentObject |
setRotation(const osg::Quat &quat) | vrecko::EnvironmentObject |
setScale(const osg::Vec3 &new_scale) | vrecko::EnvironmentObject |
setScale(float x, float y, float z) | vrecko::EnvironmentObject |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTransparency(float transp) | vrecko::EnvironmentObject |
show() | vrecko::EnvironmentObject | inline
tempTransformMatrix | vrecko::EnvironmentObject | protected
trans_vec | vrecko::EnvironmentObject | protected
transparency | vrecko::EnvironmentObject | protected
UD_BOOL enum value | vrecko::EnvironmentObject |
UD_DOUBLE enum value | vrecko::EnvironmentObject |
UD_FLOAT enum value | vrecko::EnvironmentObject |
UD_INT enum value | vrecko::EnvironmentObject |
UD_LONG_INT enum value | vrecko::EnvironmentObject |
UD_MATRIX enum value | vrecko::EnvironmentObject |
UD_POINTER enum value | vrecko::EnvironmentObject |
UD_QUAT enum value | vrecko::EnvironmentObject |
UD_STRING enum value | vrecko::EnvironmentObject |
UD_UNKNOWN enum value | vrecko::EnvironmentObject |
UD_USER enum value | vrecko::EnvironmentObject |
UD_VEC2 enum value | vrecko::EnvironmentObject |
UD_VEC3 enum value | vrecko::EnvironmentObject |
UD_VEC4 enum value | vrecko::EnvironmentObject |
update(void) | vrecko::BaseClass | inlinevirtual
updateNodeMask() | vrecko::EnvironmentObject | protected
user_data | vrecko::EnvironmentObject | protected
UserData_Type enum name | vrecko::EnvironmentObject |
World class | vrecko::EnvironmentObject | friend
~BaseClass() | vrecko::BaseClass | virtual
~EnvironmentObject() | vrecko::EnvironmentObject |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
vrecko::EventDispatcher Member List

This is the complete list of members for vrecko::EventDispatcher, including all inherited members.

ABILITY enum value | vrecko::EventDispatcher |
ACTIVATE_INPUT enum value | vrecko::EventDispatcher |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOuterObject(const std::string &object_id, BaseClass *pOObject) | vrecko::EventDispatcher |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
bAllowForegroundListQueing | vrecko::EventDispatcher | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bgListId | vrecko::EventDispatcher | protected
checkInterconnection(const std::string &sender, const std::string &receiver, bool bRequest) | vrecko::EventDispatcher | protected
debugPrintInterconnectionMap(EI_Type *map) | vrecko::EventDispatcher | protected
debugPrintRequestMap(REQUEST_Map *map) | vrecko::EventDispatcher | protected
Decomposition_vec typedef | vrecko::EventDispatcher | protected
default_request_interconnection_map | vrecko::EventDispatcher | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
deleteEventInterconnection(const std::string &sender, const std::string &receiver, InterconnectionType type=FORWARD_OUTPUT) | vrecko::EventDispatcher |
DEVICE enum value | vrecko::EventDispatcher |
dirtyInterconnectionsForObject(BaseClass *object, bool bProcessEvents=true, bool bProcessRequests=true) | vrecko::EventDispatcher |
EI_Type typedef | vrecko::EventDispatcher |
ENVIRONMENTOBJECT enum value | vrecko::EventDispatcher |
event_interconnection_map | vrecko::EventDispatcher | protected
EventDispatcher() | vrecko::EventDispatcher |
EventDispatcher(EventDispatcher &ed) | vrecko::EventDispatcher |
eventsVector | vrecko::EventDispatcher | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
FORWARD_OUTPUT enum value | vrecko::EventDispatcher |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getDefaultRequestInterconnectionMap() | vrecko::EventDispatcher | inline
getEventInterconnectionMap() | vrecko::EventDispatcher | inline
getEventsVector(void) | vrecko::EventDispatcher | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getProcessedEventsCounter() | vrecko::EventDispatcher | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestInterconnectionMap() | vrecko::EventDispatcher | inline
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
hMainThreadId | vrecko::EventDispatcher | protected
incoming_events | vrecko::EventDispatcher | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
insertEventInterconnection(const std::string &sender, const std::string &receiver, InterconnectionType type=FORWARD_OUTPUT, const std::string &sceneFile=*((std::string *) NULL)) | vrecko::EventDispatcher |
InterconnectionType enum name | vrecko::EventDispatcher |
iProcessedEventsCounter | vrecko::EventDispatcher | protected
isInMainThread() | vrecko::EventDispatcher | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mainLock | vrecko::EventDispatcher | protected
net_support | vrecko::EventDispatcher | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
OUTER_OBJECT enum value | vrecko::EventDispatcher |
outerObject_map | vrecko::EventDispatcher | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parseSR(const std::string &sr, bool isSender, BaseClass **pEntity, SRType *pSRType, std::string *pIOName, osg::ref_ptr< VreckoMessage > *pRefMessage, bool isRequest=false, bool noErrorOuptut=false) | vrecko::EventDispatcher |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processBatchOfEvents(std::vector< EventStruct * > *ref_incoming_events, bool bTurnOffForegroundQueing) | vrecko::EventDispatcher | protected
processEvent(EventStruct *pES) | vrecko::EventDispatcher | protected
vrecko::BaseClass::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
received_event_map | vrecko::EventDispatcher | protected
receiver_decomposition | vrecko::EventDispatcher | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOuterObject(const std::string &object_id) | vrecko::EventDispatcher |
removeOuterObject(BaseClass *pOObject) | vrecko::EventDispatcher |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
reportEvent(const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT) | vrecko::EventDispatcher | inline
reportEvent(BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT) | vrecko::EventDispatcher | inline
reportEventCore(BaseClass *receiver_ptr, const std::string &sender, VreckoMessage *pMessage, EventType eType) | vrecko::EventDispatcher | protected
request(const std::string &req_sender, VreckoMessage *pMessage) | vrecko::EventDispatcher |
request(BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage) | vrecko::EventDispatcher |
REQUEST enum value | vrecko::EventDispatcher |
request_interconnection_map | vrecko::EventDispatcher | protected
REQUEST_Map typedef | vrecko::EventDispatcher |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
resetProcessedEventsCounter() | vrecko::EventDispatcher | inline
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
SCENE enum value | vrecko::EventDispatcher |
scene_ptr | vrecko::EventDispatcher | protected
sceneFile | vrecko::BaseClass | protected
sender_decomposition | vrecko::EventDispatcher | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setMainThreadId(pthread_t ptID) | vrecko::EventDispatcher | inline
setNetSupport(bool status) | vrecko::EventDispatcher |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setScenePtr(Scene *ptr) | vrecko::EventDispatcher | inline
SRType enum name | vrecko::EventDispatcher |
UNKNOWN enum value | vrecko::EventDispatcher |
update(void) | vrecko::EventDispatcher | virtual
WORLD enum value | vrecko::EventDispatcher |
~BaseClass() | vrecko::BaseClass | virtual
~EventDispatcher() | vrecko::EventDispatcher |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • IOPinBase
vrecko::IOPinBase Member List

This is the complete list of members for vrecko::IOPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • IORequestPinBase
vrecko::IORequestPinBase Member List

This is the complete list of members for vrecko::IORequestPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
createReturningCompatibleMessage()=0 | vrecko::IORequestPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • InputPin
vrecko::InputPin< _MessageType > Member List

This is the complete list of members for vrecko::InputPin< _MessageType >, including all inherited members.

coreInit(BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing) | vrecko::InputPin< _MessageType > | inlineprotected
createCompatibleMessage() | vrecko::InputPin< _MessageType > | inlinevirtual
getPinName() | vrecko::IOPinBase | inline
InputPin(BaseClass *_owner, const char *_inputName, PROCESSING_METHOD _methodForProcessing) | vrecko::InputPin< _MessageType > | inline
methodForProcessing | vrecko::InputPin< _MessageType > | protected
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
PROCESSING_METHOD typedef | vrecko::InputPin< _MessageType > |
processMessage(VreckoMessage *message) | vrecko::InputPin< _MessageType > | inlinevirtual
~InputPin() | vrecko::InputPin< _MessageType > | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • InputPinBase
vrecko::InputPinBase Member List

This is the complete list of members for vrecko::InputPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
processMessage(VreckoMessage *message)=0 | vrecko::InputPinBase | pure virtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Interval
vrecko::Interval< tval, tref > Member List

This is the complete list of members for vrecko::Interval< tval, tref >, including all inherited members.

getLowerBound() const | vrecko::Interval< tval, tref > | inline
getUpperBound() const | vrecko::Interval< tval, tref > | inline
includesValue(tref value) const | vrecko::Interval< tval, tref > | inline
Interval(tref lowerBound, tref upperBound) | vrecko::Interval< tval, tref > | inline
Interval(tref lowerBound, tref upperBound, bool lowerInclusive, bool upperInclusive) | vrecko::Interval< tval, tref > | inline
isEnumeration() const | vrecko::Range | inline
isInterval() const | vrecko::Range | inline
isLowerInclusive() const | vrecko::Interval< tval, tref > | inline
isUpperInclusive() const | vrecko::Interval< tval, tref > | inline
Range(RangeType rangeType) | vrecko::Range | inlineprotected
Range(const Range &range) | vrecko::Range | inlineprotected
RANGE_ENUMERATION enum value | vrecko::Range |
RANGE_INTERVAL enum value | vrecko::Range |
RangeType enum name | vrecko::Range |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
vrecko::Logger Member List

This is the complete list of members for vrecko::Logger, including all inherited members.

addOutstandingText(unsigned long dwOutputType, const char *buffer) | vrecko::Logger | protected
bm | vrecko::Logger | protected
countersActiveIndex | vrecko::Logger | protected
countersActiveLock | vrecko::Logger | protected
debugFileLog(const char *debugText="",...) | vrecko::Logger |
debugFlush(const char *debugText="",...) | vrecko::Logger |
debugLog(const char *debugText="",...) | vrecko::Logger |
done() | vrecko::Logger |
dwAllowedOutput | vrecko::Logger | protected
dwMainThreadId | vrecko::Logger | protected
dwOutputDest | vrecko::Logger | protected
errorLog(const char *error="",...) | vrecko::Logger |
generalLock | vrecko::Logger | protected
getAllowedOutput() | vrecko::Logger | inline
getOutputDest() | vrecko::Logger | inline
hOriginalStdHandle | vrecko::Logger | protected
init() | vrecko::Logger |
log_file | vrecko::Logger | protected
Logger() | vrecko::Logger |
new_cerr | vrecko::Logger | protected
new_cout | vrecko::Logger | protected
noticeLog(const char *notice="",...) | vrecko::Logger |
old_cerr_buf | vrecko::Logger | protected
old_cout | vrecko::Logger | protected
old_cout_buf | vrecko::Logger | protected
openBenchmarkFile() | vrecko::Logger | protected
outFuncs | vrecko::Logger | protected
OutputNotificationFuncType typedef | vrecko::Logger |
outstandingCounters | vrecko::Logger | protected
outstandingTexts | vrecko::Logger | protected
processOutstandingCounters() | vrecko::Logger | protected
processOutstandingTexts() | vrecko::Logger | protected
processTextMain(unsigned long dwOutputType, const char *buffer) | vrecko::Logger | protected
registerOutputNotification(OutputNotificationFuncType aFunc, void *userParam) | vrecko::Logger |
sectionsTiming | vrecko::Logger | protected
setAllowedOutput(unsigned long dwNewOutput) | vrecko::Logger | inline
setOutputDest(unsigned long dwNewOutputDest) | vrecko::Logger | inline
starttime_stamp | vrecko::Logger | protected
startTiming(std::string sectionName) | vrecko::Logger |
stopTiming(std::string sectionName, DWORD dwOutputType=LOGGER_OUTPUTTYPE_DEBUG) | vrecko::Logger |
textLog(unsigned long dwOutputType, const char *text="",...) | vrecko::Logger | protected
tick() | vrecko::Logger | inline
unregisterOutputNotification(OutputNotificationFuncType aFunc) | vrecko::Logger |
update() | vrecko::Logger |
vdebugFileLog(const char *debugText, va_list args) | vrecko::Logger |
vdebugFlush(const char *debugText, va_list args) | vrecko::Logger |
vdebugLog(const char *debugText, va_list args) | vrecko::Logger |
verrorLog(const char *error, va_list args) | vrecko::Logger |
vnoticeLog(const char *notice, va_list args) | vrecko::Logger |
vtextLog(unsigned long dwOutputType, const char *text, va_list args) | vrecko::Logger | protected
vwarningLog(const char *warning, va_list args) | vrecko::Logger |
warningLog(const char *warning="",...) | vrecko::Logger |
wOriginalConsoleAttributes | vrecko::Logger | protected
World class | vrecko::Logger | friend
writeBMCounter(const char *pName, float fValue) | vrecko::Logger |
writeBMCounterLowLevel(unsigned int time, const char *pName, float fValue) | vrecko::Logger | protected
~Logger() | vrecko::Logger |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutstandingCounter
vrecko::Logger::OutstandingCounter Member List

This is the complete list of members for vrecko::Logger::OutstandingCounter, including all inherited members.

fValue | vrecko::Logger::OutstandingCounter
strName | vrecko::Logger::OutstandingCounter
time | vrecko::Logger::OutstandingCounter
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutstandingText
vrecko::Logger::OutstandingText Member List

This is the complete list of members for vrecko::Logger::OutstandingText, including all inherited members.

dwOutputType | vrecko::Logger::OutstandingText
str | vrecko::Logger::OutstandingText
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTAutoLock
vrecko::MTAutoLock Member List

This is the complete list of members for vrecko::MTAutoLock, including all inherited members.

MTAutoLock(MTLock *lockToLock) | vrecko::MTAutoLock | inline
theLock | vrecko::MTAutoLock | protected
~MTAutoLock() | vrecko::MTAutoLock | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTLock
vrecko::MTLock Member List

This is the complete list of members for vrecko::MTLock, including all inherited members.

getHandle() const | vrecko::MTLock | inline
lock() | vrecko::MTLock |
MTLock() | vrecko::MTLock |
mutex | vrecko::MTLock | protected
unlock() | vrecko::MTLock |
~MTLock() | vrecko::MTLock |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTReadWriteLock
vrecko::MTReadWriteLock Member List

This is the complete list of members for vrecko::MTReadWriteLock, including all inherited members.

lockRead(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLock |
lockWrite(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLock |
m_Access | vrecko::MTReadWriteLock | protected
m_CanRead | vrecko::MTReadWriteLock | protected
m_CanWrite | vrecko::MTReadWriteLock | protected
m_Readers | vrecko::MTReadWriteLock | protected
m_WriterMutex | vrecko::MTReadWriteLock | protected
MTReadWriteLock() | vrecko::MTReadWriteLock |
unlockRead(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLock |
unlockWrite(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLock |
~MTReadWriteLock() | vrecko::MTReadWriteLock |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTReadWriteLockEx
vrecko::MTReadWriteLockEx Member List

This is the complete list of members for vrecko::MTReadWriteLockEx, including all inherited members.

lockRead(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLockEx
lockWrite(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLockEx
MTReadWriteLockEx() | vrecko::MTReadWriteLockEx
unlockRead(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLockEx
unlockWrite(DWORD Timeout=INFINITE) | vrecko::MTReadWriteLockEx
~MTReadWriteLockEx() | vrecko::MTReadWriteLockEx
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MTTwoPrioLimitedLock
vrecko::MTTwoPrioLimitedLock Member List

This is the complete list of members for vrecko::MTTwoPrioLimitedLock, including all inherited members.

lockHigh() | vrecko::MTTwoPrioLimitedLock |
lockLow() | vrecko::MTTwoPrioLimitedLock |
m_Access | vrecko::MTTwoPrioLimitedLock | protected
m_AllowLowPrio | vrecko::MTTwoPrioLimitedLock | protected
m_WritersMutex | vrecko::MTTwoPrioLimitedLock | protected
MTTwoPrioLimitedLock() | vrecko::MTTwoPrioLimitedLock |
unlockHigh() | vrecko::MTTwoPrioLimitedLock |
unlockLow() | vrecko::MTTwoPrioLimitedLock |
~MTTwoPrioLimitedLock() | vrecko::MTTwoPrioLimitedLock |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MaterialDesc
vrecko::MaterialDesc Member List

This is the complete list of members for vrecko::MaterialDesc, including all inherited members.

Create(NxScene *pScene) | vrecko::MaterialDesc |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vrecko::MaterialDesc |
MatIndex() const | vrecko::MaterialDesc | inline
Name() const | vrecko::MaterialDesc | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageCAButtonEvent
vrecko::MessageCAButtonEvent Member List

This is the complete list of members for vrecko::MessageCAButtonEvent, including all inherited members.

data | vrecko::MessageCAButtonEvent |
getMessageId() | vrecko::MessageCAButtonEvent | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageSensorTransformation
vrecko::MessageSensorTransformation Member List

This is the complete list of members for vrecko::MessageSensorTransformation, including all inherited members.

_sensorNumber | vrecko::MessageSensorTransformation |
_sensorOrientation | vrecko::MessageSensorTransformation |
_sensorPosition | vrecko::MessageSensorTransformation |
getMessageId() | vrecko::VreckoMessage | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
MessageSensorTransformation() | vrecko::MessageSensorTransformation | inline
MessageSensorTransformation(int number, osg::Vec3 &position, osg::Quat &orientation) | vrecko::MessageSensorTransformation | inline
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • MessageVoid
vrecko::MessageVoid Member List

This is the complete list of members for vrecko::MessageVoid, including all inherited members.

getMessageId() | vrecko::MessageVoid | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::MessageVoid | inlinevirtual
MessageVoid() | vrecko::MessageVoid | inline
setValueFromString(const char *valueAsString) | vrecko::MessageVoid | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OctTree
vrecko::OctTree Member List

This is the complete list of members for vrecko::OctTree, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addObject(EnvironmentObject *_object) | vrecko::OctTree |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addToCell(int _node_id, OctTreeNode *_parent, EnvironmentObject *_object) | vrecko::OctTree | protected
addToNode(int _node_id, OctTreeNode *_parent, EnvironmentObject *_object) | vrecko::OctTree | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
cell_size | vrecko::OctTree | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
delFromCell(OctTreeNode *_node, EnvironmentObject *_object) | vrecko::OctTree | protected
delFromNode(OctTreeNode *_node, EnvironmentObject *_object) | vrecko::OctTree | protected
findObject(EnvironmentObject *_object) | vrecko::OctTree | protected
findObjectInNode(int _node_id, OctTreeNode *_node, EnvironmentObject *_object) | vrecko::OctTree | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getObjectNeighbourhood(EnvironmentObject *_object, int &_object_count) | vrecko::OctTree |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isObjectInCell(OctTreeNode *_node, EnvironmentObject *_object) | vrecko::OctTree | protected
isObjectInNode(OctTreeNode *_node, EnvironmentObject *_object) | vrecko::OctTree | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objectChanged(EnvironmentObject *_object) | vrecko::OctTree |
OctTree() | vrecko::OctTree |
OctTree(double _new_cell_size, double _new_space_size) | vrecko::OctTree |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeObject(EnvironmentObject *_object) | vrecko::OctTree |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
root_node | vrecko::OctTree | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
space_size | vrecko::OctTree | protected
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~OctTree() | vrecko::OctTree |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OutputPin
vrecko::OutputPin< _MessageType > Member List

This is the complete list of members for vrecko::OutputPin< _MessageType >, including all inherited members.

createCompatibleMessage() | vrecko::OutputPin< _MessageType > | inlinevirtual
getPinName() | vrecko::IOPinBase | inline
OutputPin(BaseClass *_owner, const char *_outputName) | vrecko::OutputPin< _MessageType > | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
send(_MessageType *messageToBeSent, EventType eventType=EXPRESS_EVENT) | vrecko::OutputPin< _MessageType > | inline
senderStringWithOutputName | vrecko::OutputPin< _MessageType > | protected
~OutputPin() | vrecko::OutputPin< _MessageType > | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OutputPinBase
vrecko::OutputPinBase Member List

This is the complete list of members for vrecko::OutputPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PersistentCache
vrecko::PersistentCache Member List

This is the complete list of members for vrecko::PersistentCache, including all inherited members.

baseDir | vrecko::PersistentCache | protected
bEnableCache | vrecko::PersistentCache | protected
cacheDir | vrecko::PersistentCache | protected
closeCacheFile(OpenedCacheFile *cacheData, vrecko::BufferedFile *bfile) | vrecko::PersistentCache |
closeCacheFile(OpenedCacheFile *cacheData, vrecko::BufferedFileWrite *bfile) | vrecko::PersistentCache |
constructModelDataName(char *outDataName, vrecko::EnvironmentObject *obj) | vrecko::PersistentCache | protected
filesLock | vrecko::PersistentCache | protected
getCacheDir() | vrecko::PersistentCache | inline
getEnable() | vrecko::PersistentCache | inline
internalDecrementReaderWriter(OpenedCacheFile *cacheData, bool bReading) | vrecko::PersistentCache | protected
internalFindAndLock(const char *originalFileName, const char *translatedFileName, unsigned long version, const char *desiredExtension, bool bReading, unsigned long ulWaitTimeout) | vrecko::PersistentCache | protected
internalOpenReadWrite(const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFile **bfile, vrecko::BufferedFileWrite **bfileWrite, unsigned long ulWaitTimeout) | vrecko::PersistentCache | protected
loadModel(const char *relatedFileName, vrecko::EnvironmentObject *obj) | vrecko::PersistentCache |
openCacheFileForReading(const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFile **bfile, unsigned long ulWaitTimeout=0) | vrecko::PersistentCache | inline
openCacheFileForWriting(const char *dataName, const char *relatedFileName, unsigned long version, OpenedCacheFile **cacheData, vrecko::BufferedFileWrite **bfile, unsigned long ulWaitTimeout=0) | vrecko::PersistentCache | inline
openedFiles | vrecko::PersistentCache | protected
PersistentCache() | vrecko::PersistentCache |
saveModel(const char *relatedFileName, osg::Node *node, vrecko::EnvironmentObject *obj) | vrecko::PersistentCache |
setEnable(bool bNewEnableCache) | vrecko::PersistentCache |
testVersionIsAtLeast(const char *fileName, int minVersion) | vrecko::PersistentCache | protected
translateName(char *outTranslatedName, const char *inDataName, const char *inRelatedFileName) | vrecko::PersistentCache | protected
~PersistentCache() | vrecko::PersistentCache |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PersistentCache
  • OpenedCacheFile
vrecko::PersistentCache::OpenedCacheFile Member List

This is the complete list of members for vrecko::PersistentCache::OpenedCacheFile, including all inherited members.

cachedFileName | vrecko::PersistentCache::OpenedCacheFile | protected
getCachedFileName() | vrecko::PersistentCache::OpenedCacheFile | inline
getTranslatedFileName() | vrecko::PersistentCache::OpenedCacheFile | inline
iReaders | vrecko::PersistentCache::OpenedCacheFile | protected
iWaitingWriters | vrecko::PersistentCache::OpenedCacheFile | protected
iWriters | vrecko::PersistentCache::OpenedCacheFile | protected
OpenedCacheFile() | vrecko::PersistentCache::OpenedCacheFile |
translatedFileName | vrecko::PersistentCache::OpenedCacheFile | protected
~OpenedCacheFile() | vrecko::PersistentCache::OpenedCacheFile |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PluginManager
vrecko::PluginManager Member List

This is the complete list of members for vrecko::PluginManager, including all inherited members.

_dl_map | vrecko::PluginManager | protectedstatic
getAbilityInstance(const std::string &plugin_name, const std::string &ability_name) | vrecko::PluginManager | static
getFuncPtr(std::string dl_name, std::string func_name) | vrecko::PluginManager | static
PluginManager() | vrecko::PluginManager | inline
~PluginManager() | vrecko::PluginManager | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • PyAbility
vrecko::PyAbility Member List

This is the complete list of members for vrecko::PyAbility, including all inherited members.

Ability(const char *theAbilityName) | vrecko::Ability | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
clean(void) | vrecko::Ability | inlinevirtual
counter | vrecko::PyAbility | protectedstatic
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getID(void) const | vrecko::Ability | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getName() const | vrecko::Ability | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getOwner(void) | vrecko::Ability | inline
getParameterVector(void) | vrecko::Ability | inlinevirtual
getPluginName(void) const | vrecko::Ability | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::Ability | virtual
id_string | vrecko::PyAbility | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isUpdated(void) | vrecko::Ability |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mPost | vrecko::PyAbility | protectedstatic
mProcessEvent | vrecko::PyAbility | protectedstatic
mUpdate | vrecko::PyAbility | protectedstatic
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
parameterString | vrecko::Ability | protected
ParameterVector typedef | vrecko::Ability |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::PyAbility | virtual
pOwner | vrecko::Ability | protected
preInitialize(void) | vrecko::PyAbility | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &, void *) | vrecko::PyAbility | inline
vrecko::Ability::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
PyAbility() | vrecko::PyAbility |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setCallBacks(PyObject *update, PyObject *processEvent, PyObject *post) | vrecko::PyAbility |
setID(const char *pID) | vrecko::Ability |
setOwner(BaseClass *owner) | vrecko::Ability | inline
setPluginName(const char *pName) | vrecko::Ability |
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::PyAbility | virtual
updated | vrecko::Ability | protected
~Ability() | vrecko::Ability | virtual
~BaseClass() | vrecko::BaseClass | virtual
~PyAbility() | vrecko::PyAbility |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RWErrorHandler
vrecko::RWErrorHandler Member List

This is the complete list of members for vrecko::RWErrorHandler, including all inherited members.

getSawErrors() const | vrecko::RWErrorHandler | inline
handleError(const XERCES_CPP_NAMESPACE_QUALIFIER DOMError &domError) | vrecko::RWErrorHandler |
resetErrors() | vrecko::RWErrorHandler |
RWErrorHandler() | vrecko::RWErrorHandler |
~RWErrorHandler() | vrecko::RWErrorHandler |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Range
vrecko::Range Member List

This is the complete list of members for vrecko::Range, including all inherited members.

isEnumeration() const | vrecko::Range | inline
isInterval() const | vrecko::Range | inline
Range(RangeType rangeType) | vrecko::Range | inlineprotected
Range(const Range &range) | vrecko::Range | inlineprotected
RANGE_ENUMERATION enum value | vrecko::Range |
RANGE_INTERVAL enum value | vrecko::Range |
RangeType enum name | vrecko::Range |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ReaderWriter
vrecko::ReaderWriter Member List

This is the complete list of members for vrecko::ReaderWriter, including all inherited members.

_cfg_file | vrecko::ReaderWriter | protected
_cfg_path | vrecko::ReaderWriter | protected
_eobject | vrecko::ReaderWriter | protected
AbInitVector typedef | vrecko::ReaderWriter | protected
act_node | vrecko::ReaderWriter | protected
addCreatorInfoRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *xChConfigFile) | vrecko::ReaderWriter | protected
addSceneFileInfoIfPossible(vrecko::BaseClass *bc, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node) | vrecko::ReaderWriter | protected
analyzeXMLTree(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode) | vrecko::ReaderWriter | protected
appendElementAndBoolValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, bool value) | vrecko::ReaderWriter | static
appendElementAndDoubleValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, double value) | vrecko::ReaderWriter | static
appendElementAndFloatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, float value) | vrecko::ReaderWriter | static
appendElementAndIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, int value) | vrecko::ReaderWriter | static
appendElementAndLongIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, long int value) | vrecko::ReaderWriter | static
appendElementAndMatrixValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Matrix value) | vrecko::ReaderWriter | static
appendElementAndQuatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Quat value) | vrecko::ReaderWriter | static
appendElementAndStringValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, const std::string &value) | vrecko::ReaderWriter | static
appendElementAndVec2Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec2 value) | vrecko::ReaderWriter | static
appendElementAndVec3Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec3 value) | vrecko::ReaderWriter | static
appendElementAndVec4Value(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParentNode, const std::string &elementName, osg::Vec4 value) | vrecko::ReaderWriter | static
createElement(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, const std::string &elementName) | vrecko::ReaderWriter | static
createParser() | vrecko::ReaderWriter | protected
device_manager_local | vrecko::ReaderWriter | protected
event_dispatcher_local | vrecko::ReaderWriter | protected
FDNAbility enum value | vrecko::ReaderWriter | protected
FDNAttribute enum value | vrecko::ReaderWriter | protected
FDNDevice enum value | vrecko::ReaderWriter | protected
FDNEnvironmentObject enum value | vrecko::ReaderWriter | protected
FDNEvent enum value | vrecko::ReaderWriter | protected
FDNFilter enum value | vrecko::ReaderWriter | protected
FDNNodeType enum name | vrecko::ReaderWriter | protected
FDNReceiver enum value | vrecko::ReaderWriter | protected
FDNSimpleNode enum value | vrecko::ReaderWriter | protected
FDNUserData enum value | vrecko::ReaderWriter | protected
findChildByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *xChChildNodeName, int level=1) | vrecko::ReaderWriter | static
findDuplicateNode(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainParentNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *origNode) | vrecko::ReaderWriter | protected
findNodeByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int level=1) | vrecko::ReaderWriter | static
findRealFile(char *outputFileWithPath, const char *inputFile, const char *currentDir, std::vector< std::string > *requiredBy=NULL, bool bOutputErrors=true) | vrecko::ReaderWriter | protected
getAttribStringValue(std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &attribName, const std::string &failReturn="") | vrecko::ReaderWriter | static
getBoolValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, bool failReturn=false, int level=1) | vrecko::ReaderWriter | static
getDoubleValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, double failReturn=0.0, int level=1) | vrecko::ReaderWriter | static
getFloatValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, float failReturn=0.0, int level=1) | vrecko::ReaderWriter | static
getIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, int failReturn=0, int level=1) | vrecko::ReaderWriter | static
getLongIntValue(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, long int failReturn=0, int level=1) | vrecko::ReaderWriter | static
getMatrixValue(osg::Matrix &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Matrix &failReturn=osg::Matrix::identity(), int level=1) | vrecko::ReaderWriter | static
getNodeCountByName(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode, const std::string &nodeName) | vrecko::ReaderWriter | protected
getNodeIdentification(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, FDNNodeType nodeType, XMLCh *strId1, XMLCh *strId2) | vrecko::ReaderWriter | protected
getQuatValue(osg::Quat &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Quat &failReturn=osg::Quat(), int level=1) | vrecko::ReaderWriter | static
getStringValue(std::string &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const std::string &failReturn="", int level=1) | vrecko::ReaderWriter | static
getStringValueXCh(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, const XMLCh *childNodeName) | vrecko::ReaderWriter | static
getVec2Value(osg::Vec2 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec2 &failReturn=osg::Vec2(0.0, 0.0), int level=1) | vrecko::ReaderWriter | static
getVec3Value(osg::Vec3 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec3 &failReturn=osg::Vec3(0.0, 0.0, 0.0), int level=1) | vrecko::ReaderWriter | static
getVec4Value(osg::Vec4 &returnValue, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const std::string &nodeName, const osg::Vec4 &failReturn=osg::Vec4(0.0, 0.0, 0.0, 0.0), int level=1) | vrecko::ReaderWriter | static
incrementActNode() | vrecko::ReaderWriter | protected
loadAbilities(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, bool bLoadingWorldAbility, AbInitVector &abilitiesToInitialize) | vrecko::ReaderWriter | protected
loadDevice(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *deviceNode) | vrecko::ReaderWriter | protected
loadEnvironmentObject(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, osg::Group *parentSceneNode) | vrecko::ReaderWriter | protected
loadEvent(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eventNode) | vrecko::ReaderWriter | protected
loadMultipleFiles(std::vector< std::string > &files, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex) | vrecko::ReaderWriter |
loadOld(const char *configName, float *loadingPosition, std::string *loadingCategory, VRECKOMutex load_Mutex) | vrecko::ReaderWriter |
loadsave_category | vrecko::ReaderWriter | protected
loadsave_Mutex | vrecko::ReaderWriter | protected
loadsave_position | vrecko::ReaderWriter | protected
loadScene(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *sceneNode, AbInitVector &abilitiesToInitialize) | vrecko::ReaderWriter | protected
loadVirtualEnvironment(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *veNode) | vrecko::ReaderWriter | protected
loadXMLDocument(const char *configName, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser) | vrecko::ReaderWriter | protected
mergeFiles(std::vector< std::string > &files, XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser) | vrecko::ReaderWriter | protected
nodes_count | vrecko::ReaderWriter | protected
processNodeToMergeRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *mainNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *secNode, const XMLCh *xChConfigFile) | vrecko::ReaderWriter | protected
ReaderWriter() | vrecko::ReaderWriter | inline
releaseParser(XERCES_CPP_NAMESPACE_QUALIFIER DOMBuilder *parser) | vrecko::ReaderWriter | protected
removeAttribRecursive(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *node, const XMLCh *attribName) | vrecko::ReaderWriter | protected
removeUnnecessaryWhitespace(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pNode) | vrecko::ReaderWriter | protected
save(const char *configName, const char *originalSceneFile, float *savingPosition, std::string *savingCategory, VRECKOMutex save_Mutex) | vrecko::ReaderWriter |
saveChildren(const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *eoNode, vrecko::EnvironmentObject *pEO) | vrecko::ReaderWriter | protected
saveEnvironmentObject(const char *originalSceneFile, XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDocNode, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parentNode, vrecko::EnvironmentObject *pEO) | vrecko::ReaderWriter | protected
saveXMLDocument(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *pDoc, const char *strPath) | vrecko::ReaderWriter | protected
~ReaderWriter() | vrecko::ReaderWriter | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestInputPin
vrecko::RequestInputPin< _MessageType, _ReturningMessageType > Member List

This is the complete list of members for vrecko::RequestInputPin< _MessageType, _ReturningMessageType >, including all inherited members.

coreInit(BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing) | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inlineprotected
createCompatibleMessage() | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inlinevirtual
createReturningCompatibleMessage() | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inlinevirtual
getPinName() | vrecko::IOPinBase | inline
methodForProcessing | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | protected
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
PROCESSING_METHOD typedef | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > |
processRequest(VreckoMessage *message) | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inlinevirtual
RequestInputPin(BaseClass *_owner, const char *_requestInputName, PROCESSING_METHOD _methodForProcessing) | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inline
~RequestInputPin() | vrecko::RequestInputPin< _MessageType, _ReturningMessageType > | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestInputPinBase
vrecko::RequestInputPinBase Member List

This is the complete list of members for vrecko::RequestInputPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
createReturningCompatibleMessage()=0 | vrecko::IORequestPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
processRequest(VreckoMessage *message)=0 | vrecko::RequestInputPinBase | pure virtual
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestOutputPin
vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > Member List

This is the complete list of members for vrecko::RequestOutputPin< _MessageType, _ReturningMessageType >, including all inherited members.

createCompatibleMessage() | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | inlinevirtual
createReturningCompatibleMessage() | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | inlinevirtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
request(_MessageType *messageToBeSent) | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | inline
RequestOutputPin(BaseClass *_owner, const char *_requestOutputName) | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | inline
senderStringWithOutputName | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | protected
~RequestOutputPin() | vrecko::RequestOutputPin< _MessageType, _ReturningMessageType > | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • RequestOutputPinBase
vrecko::RequestOutputPinBase Member List

This is the complete list of members for vrecko::RequestOutputPinBase, including all inherited members.

createCompatibleMessage()=0 | vrecko::IOPinBase | pure virtual
createReturningCompatibleMessage()=0 | vrecko::IORequestPinBase | pure virtual
getPinName() | vrecko::IOPinBase | inline
owner | vrecko::IOPinBase | protected
pinName | vrecko::IOPinBase | protected
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_Object_DataInterface
vrecko::SP_Object_DataInterface Member List

This is the complete list of members for vrecko::SP_Object_DataInterface, including all inherited members.

isHierarchyCreated() | vrecko::SP_Object_DataInterface | inlinevirtual
SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
~SP_Object_DataInterface() | vrecko::SP_Object_DataInterface | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_ObjectInterface
vrecko::SP_ObjectInterface Member List

This is the complete list of members for vrecko::SP_ObjectInterface, including all inherited members.

getCollisions(CollisionParams *params, COLLISION_POINTS_VECTOR **colPoints, unsigned long obj1ID, unsigned long obj2ID, float time) | vrecko::SP_ObjectInterface | inlinevirtual
getId() | vrecko::SP_ObjectInterface | inline
objIntId | vrecko::SP_ObjectInterface | protected
SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
~SP_ObjectInterface() | vrecko::SP_ObjectInterface | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • SP_SceneInterface
vrecko::SP_SceneInterface Member List

This is the complete list of members for vrecko::SP_SceneInterface, including all inherited members.

getId() | vrecko::SP_SceneInterface | inline
performCompleteTest(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | vrecko::SP_SceneInterface | inlinevirtual
performUpdate(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1, unsigned long limitToEO2) | vrecko::SP_SceneInterface | inlinevirtual
scIntId | vrecko::SP_SceneInterface | protected
SP_SceneInterface() | vrecko::SP_SceneInterface | inline
~SP_SceneInterface() | vrecko::SP_SceneInterface | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
vrecko::Scene Member List

This is the complete list of members for vrecko::Scene, including all inherited members.

_bIsLoaded | vrecko::Scene | protected
addEnvironmentObject(EnvironmentObject *environment_object, osg::Group *parentNode) | vrecko::Scene |
addEnvironmentObject(EnvironmentObject *environment_object) | vrecko::Scene | inline
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addPartitioningObjectInterface(SP_ObjectInterface *newInterface, int priority=0) | vrecko::Scene |
addPartitioningSceneInterface(SP_SceneInterface *newInterface, int priority=0) | vrecko::Scene |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calcNodeBBox(osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed=NULL, unsigned long dwFlags=0, osg::Node *subTreeToIgnore=NULL) | vrecko::Scene |
calcNodeBBoxHelper(osg::Node *node, osg::BoundingBox *outBox, osg::Matrix *outTransform, bool *bTransformUsed, unsigned long dwFlags, osg::Node *nodeToStopTraversalAt, osg::Node *subTreeToIgnore) | vrecko::Scene | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
description | vrecko::Scene | protected
environment_objects_map | vrecko::Scene | protected
EOMap typedef | vrecko::Scene |
eoMapLock | vrecko::Scene | protected
eoRootNode | vrecko::Scene | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCollisionObject(EnvironmentObject *eobject) | vrecko::Scene |
getCollisionObjects(EnvironmentObject *eobject, int &size) | vrecko::Scene |
getCollisionObjects(esg::OSGAdapter *pOSGAdapter, const osg::Matrix &transf, int &size) | vrecko::Scene |
getCollisions(CollisionParams *params, COLLISIONS_INFO_VECTOR **collisions, unsigned long limitToEO1=0, unsigned long limitToEO2=0) | vrecko::Scene |
getDescription(void) | vrecko::Scene | inline
getEnvironmentObject(unsigned long id, bool bReportErrorIfNotFound=true) | vrecko::Scene |
getEOMap(void) | vrecko::Scene | inline
getEORoot() | vrecko::Scene | inline
getFreeID(unsigned long req_id) | vrecko::Scene |
getInputPin(const char *strName) | vrecko::BaseClass |
getObjectExtent(EnvironmentObject *eobject, const osg::Vec3 &dir, float &min, float &max) | vrecko::Scene |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPartitioningObjectInterface(int id=PARTITIONING_INTERFACE_DEFAULT) | vrecko::Scene |
getPartitioningSceneInterface(int id=PARTITIONING_INTERFACE_DEFAULT) | vrecko::Scene |
getPriority(void) const | vrecko::BaseClass | inline
getRayIntersection(const osg::Vec3 &origin, const osg::Vec3 &dir) | vrecko::Scene |
getRayIntersection(const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point) | vrecko::Scene |
getRayIntersection(EnvironmentObject *eobject, const osg::Vec3 &origin, const osg::Vec3 &dir, osg::Vec3 &intersection_point) | vrecko::Scene |
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRoot() | vrecko::Scene | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isLoaded(void) | vrecko::Scene | inline
lastUpdatePartThrIndex | vrecko::Scene | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
lockEOMapForRead(void) | vrecko::Scene | inline
lockEOMapForWrite(void) | vrecko::Scene | inline
logHierarchy(const osg::Node *topNode, const char *note=NULL) | vrecko::Scene |
logHierarchyDrawableHelper(int level, const osg::Drawable *dw) | vrecko::Scene | protected
logHierarchyHelper(int level, const osg::Node *node) | vrecko::Scene | protected
nextFreeID | vrecko::Scene | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
partitioningObjectInterfaces | vrecko::Scene | protected
partitioningSceneInterfaces | vrecko::Scene | protected
partThreadsInfo | vrecko::Scene | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
prepareForTermination() | vrecko::Scene |
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
registerEnvironmentObject(EnvironmentObject *environment_object) | vrecko::Scene |
removeEnvironmentObject(unsigned long id) | vrecko::Scene |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removePartitioningObjectInterface(SP_ObjectInterface *anInterface) | vrecko::Scene |
removePartitioningSceneInterface(SP_SceneInterface *anInterface) | vrecko::Scene |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
rootNode | vrecko::Scene | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
Scene() | vrecko::Scene |
sceneFile | vrecko::BaseClass | protected
ScenePSThreadProc(ScenePSThreadInfo *lpParameter) | vrecko::Scene | friend
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
separation(esg::Matrix4 *trMat1, std::vector< esg::OSGAdapter * > object1, esg::Matrix4 *trMat2, std::vector< esg::OSGAdapter * > object2, unsigned d1=UINT_MAX, unsigned d2=UINT_MAX) | vrecko::Scene |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDescription(const std::string &desc) | vrecko::Scene | inline
setIsLoaded(bool bNewValue) | vrecko::Scene | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
unlockEOMapForRead(void) | vrecko::Scene | inline
unlockEOMapForWrite(void) | vrecko::Scene | inline
unregisterEnvironmentObject(EnvironmentObject *environment_object) | vrecko::Scene |
unregisterEnvironmentObject(unsigned long id) | vrecko::Scene |
update(void) | vrecko::Scene | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Scene() | vrecko::Scene |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • EOIteratorHelper
vrecko::Scene::EOIteratorHelper Member List

This is the complete list of members for vrecko::Scene::EOIteratorHelper, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bCollisionOccured_EventExpected | vrecko::Scene::EOIteratorHelper | protected
bInited | vrecko::Scene::EOIteratorHelper | protected
bObjectLocked | vrecko::Scene::EOIteratorHelper | protected
currentObjectIndex | vrecko::Scene::EOIteratorHelper | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
endIteration() | vrecko::Scene::EOIteratorHelper |
EOIteratorHelper() | vrecko::Scene::EOIteratorHelper |
EOVector typedef | vrecko::Scene::EOIteratorHelper | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
generalLock | vrecko::Scene::EOIteratorHelper | protected
getAndLockNextObject(EnvironmentObject **outObject) | vrecko::Scene::EOIteratorHelper |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
hCollisionEvent1 | vrecko::Scene::EOIteratorHelper | protected
hCollisionEvent2 | vrecko::Scene::EOIteratorHelper | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initIteration() | vrecko::Scene::EOIteratorHelper |
initIterationFrom(Scene::EOIteratorHelper *sourceHelper, unsigned long dwInitFlags=EOIH_IF_START_BEGINNING) | vrecko::Scene::EOIteratorHelper |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
objects | vrecko::Scene::EOIteratorHelper | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::Scene::EOIteratorHelper | protectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
releaseObject(void) | vrecko::Scene::EOIteratorHelper |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vrecko::BaseClass | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~EOIteratorHelper() | vrecko::Scene::EOIteratorHelper |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
vrecko::Scheduler Member List

This is the complete list of members for vrecko::Scheduler, including all inherited members.

addEntity(BaseClass *ent, float frequency=FRAME_FREQUENCY) | vrecko::Scheduler |
addEntity(BaseClass *ent, const std::string &private_timer_name, float frequency=FRAME_FREQUENCY) | vrecko::Scheduler |
getObjectUpdatesCounter() | vrecko::Scheduler | inline
getState() | vrecko::Scheduler | inline
iObjectUpdatesCounter | vrecko::Scheduler | protected
isEntityPresent(BaseClass *ent) | vrecko::Scheduler |
private_timer_map | vrecko::Scheduler | protected
PrivateTimerMap typedef | vrecko::Scheduler | protected
removeEntity(BaseClass *ent) | vrecko::Scheduler |
resetObjectUpdatesCounter() | vrecko::Scheduler | inline
Scheduler() | vrecko::Scheduler |
Scheduler(Scheduler &s) | vrecko::Scheduler |
start(void) | vrecko::Scheduler |
state | vrecko::Scheduler | protected
stop(void) | vrecko::Scheduler |
timer_map | vrecko::Scheduler | protected
TimerMap typedef | vrecko::Scheduler | protected
update(void) | vrecko::Scheduler |
updateMMap | vrecko::Scheduler | protected
~Scheduler() | vrecko::Scheduler |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • StaticAttribute
vrecko::StaticAttribute< type, tval, tref > Member List

This is the complete list of members for vrecko::StaticAttribute< type, tval, tref >, including all inherited members.

Attribute(const string &strName, DataType dataType, const string &strDescription) | vrecko::Attribute | inlineprotected
Attribute(const Attribute &attribute) | vrecko::Attribute | inlineprotected
DataType enum name | vrecko::Attribute |
getDataType() const | vrecko::Attribute | inline
getDefaultValue() const | vrecko::StaticAttribute< type, tval, tref > | inline
getDescription() const | vrecko::Attribute | inline
getName() const | vrecko::Attribute | inline
getRangePtr() const | vrecko::StaticAttribute< type, tval, tref > | inline
hasRange() const | vrecko::StaticAttribute< type, tval, tref > | inline
isDynamic() const | vrecko::Attribute | inline
isStatic() const | vrecko::Attribute | inline
StaticAttribute(const string &strName, const string &strDescription, tref defaultValue, Range *pRange=null) | vrecko::StaticAttribute< type, tval, tref > | inline
TYPE_BOOL enum value | vrecko::Attribute |
TYPE_DOUBLE enum value | vrecko::Attribute |
TYPE_DYNAMIC enum value | vrecko::Attribute |
TYPE_FLOAT enum value | vrecko::Attribute |
TYPE_INT enum value | vrecko::Attribute |
TYPE_LONG enum value | vrecko::Attribute |
TYPE_MATRIX enum value | vrecko::Attribute |
TYPE_QUAT enum value | vrecko::Attribute |
TYPE_STRING enum value | vrecko::Attribute |
TYPE_VEC2 enum value | vrecko::Attribute |
TYPE_VEC3 enum value | vrecko::Attribute |
TYPE_VEC4 enum value | vrecko::Attribute |
~StaticAttribute() | vrecko::StaticAttribute< type, tval, tref > | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Timer
vrecko::Timer Member List

This is the complete list of members for vrecko::Timer, including all inherited members.

_secsPerTick | vrecko::Timer | protected
_startTick | vrecko::Timer | protected
delta_m(osg::Timer_t t1, osg::Timer_t t2) const | vrecko::Timer | inline
delta_n(osg::Timer_t t1, osg::Timer_t t2) const | vrecko::Timer | inline
delta_s(osg::Timer_t t1, osg::Timer_t t2) const | vrecko::Timer | inline
delta_u(osg::Timer_t t1, osg::Timer_t t2) const | vrecko::Timer | inline
getSecondsPerTick() const | vrecko::Timer | inline
getStartTick() const | vrecko::Timer | inline
instance() | vrecko::Timer | static
setStartTick() | vrecko::Timer | inline
setStartTick(osg::Timer_t t) | vrecko::Timer | inline
tick() const | vrecko::Timer |
time_m() const | vrecko::Timer | inline
time_n() const | vrecko::Timer | inline
time_s() const | vrecko::Timer | inline
time_u() const | vrecko::Timer | inline
Timer() | vrecko::Timer |
~Timer() | vrecko::Timer |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Viewer
vrecko::Viewer Member List

This is the complete list of members for vrecko::Viewer, including all inherited members.

addEventHandler(osgGA::GUIEventHandler *eventHandler) | vrecko::Viewer | inlinevirtual
addView(osgViewer::View *view) | vrecko::Viewer | inlinevirtual
camera_setViewMatrixAsLookAt(const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up) | vrecko::Viewer | inlinevirtual
done() | vrecko::ViewerBase | inline
frame(double simulationTime=USE_REFERENCE_TIME) | vrecko::ViewerBase | inline
getCamera(int screenNum=0) | vrecko::Viewer | inlinevirtual
getCameras(osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true) | vrecko::ViewerBase | inline
getContexts(osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true) | vrecko::ViewerBase | inline
getLight() | vrecko::Viewer | inlinevirtual
getStereoMode() | vrecko::Viewer | inlinevirtual
getViewer() | vrecko::Viewer | inlinevirtual
getWindows(osgViewer::ViewerBase::Windows &windows, bool onlyValid=true) | vrecko::ViewerBase | inline
realize() | vrecko::ViewerBase | inline
setDisplaySettings(osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL) | vrecko::Viewer | inlinevirtual
setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f) | vrecko::Viewer | inlinevirtual
setLight(osg::Light *light) | vrecko::Viewer | inlinevirtual
setSceneData(osg::Node *node) | vrecko::Viewer | inlinevirtual
setThreadingModel(osgViewer::ViewerBase::ThreadingModel threadingModel) | vrecko::ViewerBase | inline
Viewer(int stereoMode) | vrecko::Viewer |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ViewerBase
vrecko::ViewerBase Member List

This is the complete list of members for vrecko::ViewerBase, including all inherited members.

addEventHandler(osgGA::GUIEventHandler *eventHandler)=0 | vrecko::ViewerBase | pure virtual
addView(osgViewer::View *view)=0 | vrecko::ViewerBase | pure virtual
camera_setViewMatrixAsLookAt(const osg::Vec3d &eye, const osg::Vec3d &center, const osg::Vec3d &up)=0 | vrecko::ViewerBase | pure virtual
done() | vrecko::ViewerBase | inline
frame(double simulationTime=USE_REFERENCE_TIME) | vrecko::ViewerBase | inline
getCamera(int screenNum=0)=0 | vrecko::ViewerBase | pure virtual
getCameras(osgViewer::ViewerBase::Cameras &cameras, bool onlyActive=true) | vrecko::ViewerBase | inline
getContexts(osgViewer::ViewerBase::Contexts &contexts, bool onlyValid=true) | vrecko::ViewerBase | inline
getLight()=0 | vrecko::ViewerBase | pure virtual
getStereoMode()=0 | vrecko::ViewerBase | pure virtual
getViewer()=0 | vrecko::ViewerBase | pure virtual
getWindows(osgViewer::ViewerBase::Windows &windows, bool onlyValid=true) | vrecko::ViewerBase | inline
realize() | vrecko::ViewerBase | inline
setDisplaySettings(osg::DisplaySettings *ds1, osg::DisplaySettings *ds2=NULL)=0 | vrecko::ViewerBase | pure virtual
setFusionDistance(osgUtil::SceneView::FusionDistanceMode mode, float value=1.0f)=0 | vrecko::ViewerBase | pure virtual
setLight(osg::Light *light)=0 | vrecko::ViewerBase | pure virtual
setSceneData(osg::Node *node)=0 | vrecko::ViewerBase | pure virtual
setThreadingModel(osgViewer::ViewerBase::ThreadingModel threadingModel) | vrecko::ViewerBase | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • VreckoMessage
vrecko::VreckoMessage Member List

This is the complete list of members for vrecko::VreckoMessage, including all inherited members.

getMessageId() | vrecko::VreckoMessage | inlinevirtual
isEqualTo(VreckoMessage *otherMsg) | vrecko::VreckoMessage | inlinevirtual
setValueFromString(const char *valueAsString) | vrecko::VreckoMessage | inlinevirtual
VreckoMessage() | vrecko::VreckoMessage | inline
~VreckoMessage() | vrecko::VreckoMessage | inlinevirtual
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
vrecko::World Member List

This is the complete list of members for vrecko::World, including all inherited members.

ability_dispatcher | vrecko::World | protected
ADD_CHILD enum value | vrecko::World |
ADD_EOCHILD enum value | vrecko::World |
addAbility(Ability *pAbility) | vrecko::World | inline
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
avatar_view_vector | vrecko::World | protected
AvatarEyes | vrecko::World |
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
createAbility(const std::string &plugin_name, const std::string &ability_name, BaseClass *_owner, const char *_overridingID=NULL) | vrecko::World |
debugFileLog(const char *debugText="",...) | vrecko::World |
debugLog(const char *debugText="",...) | vrecko::World |
DELETE_STATESET enum value | vrecko::World |
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
description | vrecko::World | protected
errorLog(const char *error="",...) | vrecko::World |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAbility(const std::string &ab_id) | vrecko::World | inline
getAbilityMap(void) | vrecko::World | inline
getActualAvatarView(void) | vrecko::World | inline
getArguments() | vrecko::World |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCamera(void) | vrecko::World | inline
getDescription(void) const | vrecko::World | inline
getDeviceManagerPtr() | vrecko::World | inline
getEventDispatcherPtr() | vrecko::World | inline
getFrameID() | vrecko::World | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getNumberOfArguments() | vrecko::World |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPersistentCache() | vrecko::World | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getScenePtr(void) | vrecko::World | inline
getSchedulerPtr() | vrecko::World | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getShadowedSceneLight() | vrecko::World | inline
getShadowedScenePtr() | vrecko::World | inline
getShowTimeWarnings() | vrecko::World | inline
getTerminationFlag() | vrecko::World | inline
getTimeWarningsTime() | vrecko::World | inline
getViewerPtr() | vrecko::World | inline
incrementFrameID() | vrecko::World | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | vrecko::World | virtual
vrecko::BaseClass::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mainLightSource | vrecko::World | protected
noticeLog(const char *notice="",...) | vrecko::World |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
persistentCache | vrecko::World | protected
PinList typedef | vrecko::BaseClass | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pScene | vrecko::World | protected
REMOVE_CHILD enum value | vrecko::World |
REMOVE_EOCHILD enum value | vrecko::World |
removeAbility(Ability *pAbility) | vrecko::World | inline
removeAbility(const std::string &ability_id) | vrecko::World |
removeAvatarView(AvatarView *av) | vrecko::World |
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
reportEvent(const std::string &senderAndOutputString, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT) | vrecko::World | inline
reportEvent(BaseClass *receiver_ptr, const std::string &input_name, VreckoMessage *pMessage, EventType eType=EXPRESS_EVENT) | vrecko::World | inline
request(const std::string &req_sender, VreckoMessage *pMessage) | vrecko::World | inline
request(BaseClass *receiver_ptr, const std::string &request_name, VreckoMessage *pMessage) | vrecko::World | inline
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
SendTerminationNotifications() | vrecko::World | inline
SET_STATESET enum value | vrecko::World |
SET_TEXT enum value | vrecko::World |
setActualAvatarView(AvatarView *av) | vrecko::World | inline
setArgumens(int &count, char **arguments) | vrecko::World |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setDescription(const std::string &desc) | vrecko::World | inline
setDeviceManagerPtr(DeviceManager *ptr) | vrecko::World | inline
setEventDispatcherPtr(EventDispatcher *ptr) | vrecko::World | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setScenePtr(Scene *nScene) | vrecko::World |
setSchedulerPtr(Scheduler *sched) | vrecko::World | inline
setShowTimeWarnings(bool bNewValue) | vrecko::World | inline
setTimeWarningsTime(unsigned long ulNewValue) | vrecko::World | inline
setViewerPtr(ViewerBase *pV) | vrecko::World |
SG_OPERATION_TYPE enum name | vrecko::World |
shadowedScene | vrecko::World |
UNKNOWN enum value | vrecko::World |
update(void) | vrecko::BaseClass | inlinevirtual
viewer | vrecko::World | protected
warningLog(const char *warning="",...) | vrecko::World |
World() | vrecko::World |
World(const World &w) | vrecko::World |
~BaseClass() | vrecko::BaseClass | virtual
~World() | vrecko::World |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • XercesStr
vrecko::XercesStr Member List

This is the complete list of members for vrecko::XercesStr, including all inherited members.

unicodeForm() const | vrecko::XercesStr | inline
XercesStr(const char *const toTranscode) | vrecko::XercesStr | inline
~XercesStr() | vrecko::XercesStr | inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • logger_streambuf
vrecko::logger_streambuf Member List

This is the complete list of members for vrecko::logger_streambuf, including all inherited members.

logger_streambuf(Logger *loggerPtr, bool forErrors) | vrecko::logger_streambuf | inline
overflow(int c=EOF) | vrecko::logger_streambuf | inlineprotectedvirtual
pendingLine | vrecko::logger_streambuf | protected
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • vThread
vrecko::vThread Member List

This is the complete list of members for vrecko::vThread, including all inherited members.

addEntity(BaseClass *ent) | vrecko::vThread |
createMutex() | vrecko::vThread | static
destroyMutex(pthread_mutex_t *mutex) | vrecko::vThread | static
done | vrecko::vThread | protected
entity_vector | vrecko::vThread | protected
frequency | vrecko::vThread | protected
getDelay(osg::Timer_t last_t, float freq) | vrecko::vThread | static
getDelay(void) | vrecko::vThread | inline
getDone(void) | vrecko::vThread | inline
getEntityPtr(int pos) | vrecko::vThread | inline
getEntityVec(void) | vrecko::vThread | inline
getFrequency(void) | vrecko::vThread | inline
getFuncPtr | vrecko::vThread | inline
getLastTick(void) | vrecko::vThread | inline
getMutex(void) | vrecko::vThread | inline
getRun(void) | vrecko::vThread | inline
getStepCounter(void) | vrecko::vThread | inline
getTimerPtr(void) | vrecko::vThread | inlinestatic
hvT_Mutex | vrecko::vThread | protected
last_tick | vrecko::vThread |
removeEntity(BaseClass *ent) | vrecko::vThread |
reportError(const std::string &error) | vrecko::vThread |
reportError(char *error) | vrecko::vThread | inline
run | vrecko::vThread | protected
start(void) | vrecko::vThread | inline
step_counter | vrecko::vThread | protected
stop(void) | vrecko::vThread | inline
syncEntityVector(void) | vrecko::vThread |
temp_entity_map | vrecko::vThread | protected
th_read | vrecko::vThread | protected
timer | vrecko::vThread | protectedstatic
voidFuncPtr | vrecko::vThread | protected
vThread(BaseClass *ent_ptr, float freq) | vrecko::vThread |
vThread(std::vector< BaseClass * > ent_vec, float freq) | vrecko::vThread |
vThread(void(*funcPtr)(void), float freq) | vrecko::vThread |
vThread(void(*funcPtr)(void), unsigned int step, float freq) | vrecko::vThread |
~vThread() | vrecko::vThread |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_Kinect
  • Kinect
vreckoDP_Kinect::Kinect Member List

This is the complete list of members for vreckoDP_Kinect::Kinect, including all inherited members.

_hEvNuiProcessStop | vreckoDP_Kinect::Kinect | protected
_hNextSkeletonEvent | vreckoDP_Kinect::Kinect | protected
_hThNuiProcess | vreckoDP_Kinect::Kinect | protected
_inputConnector | vreckoDP_Kinect::Kinect | protected
_inputConnectorMappings | vreckoDP_Kinect::Kinect | protected
_scale | vreckoDP_Kinect::Kinect | protected
_smoothing | vreckoDP_Kinect::Kinect | protected
_worldOrigin | vreckoDP_Kinect::Kinect | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_Kinect::Kinect | virtual
DECLARE_OUTPUT(HipCenterPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(SpinePosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(ShoulderCenterPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(HeadPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(ShoulderLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(ElbowLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(WristLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(HandLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(ShoulderRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(ElbowRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(WristRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(HandRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(HipLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(KneeLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(AnkleLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(FootLeftPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(HipRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(KneeRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(AnkleRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(FootRightPosition, vrecko::MessageVec3) | vreckoDP_Kinect::Kinect | protected
DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation) | vreckoDP_Kinect::Kinect | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getSkeleton() | vreckoDP_Kinect::Kinect |
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
Kinect() | vreckoDP_Kinect::Kinect |
KinectThread(LPVOID pParam) | vreckoDP_Kinect::Kinect | static
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_Kinect::Kinect | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_Kinect::Kinect | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sendPosition(vrecko::OutputPin< vrecko::MessageVec3 > *outputPin, int index, NUI_SKELETON_DATA *pSkel) | vreckoDP_Kinect::Kinect |
sendSensorTransformation(int sensorNumber, int SkeletonIndex, NUI_SKELETON_DATA *pSkel) | vreckoDP_Kinect::Kinect |
sendSkeletonPositions(NUI_SKELETON_DATA *pSkel) | vreckoDP_Kinect::Kinect |
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vreckoDP_Kinect::Kinect | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • A3DBird
vreckoDP_base::A3DBird Member List

This is the complete list of members for vreckoDP_base::A3DBird, including all inherited members.

A3DBird(char *port) | vreckoDP_base::A3DBird |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void)=0 | vrecko::Device | pure virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void)=0 | vrecko::Device | pure virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void)=0 | vrecko::Device | pure virtual
~A3DBird() | vreckoDP_base::A3DBird |
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • KeyboardMouse
vreckoDP_base::KeyboardMouse Member List

This is the complete list of members for vreckoDP_base::KeyboardMouse, including all inherited members.

accept(osgGA::GUIEventHandlerVisitor &v) | vreckoDP_base::KeyboardMouse | inlinevirtual
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
autorepeat_map | vreckoDP_base::KeyboardMouse | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
buttonPress(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb) | vreckoDP_base::KeyboardMouse |
buttonRelease(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb) | vreckoDP_base::KeyboardMouse |
calibrateDevice(void) | vreckoDP_base::KeyboardMouse | inlinevirtual
closeDevice(void) | vreckoDP_base::KeyboardMouse | virtual
DECLARE_OUTPUT(Key, MessageString) | vreckoDP_base::KeyboardMouse | protected
DECLARE_OUTPUT(MousePosition, MessageVec2) | vreckoDP_base::KeyboardMouse | protected
DECLARE_OUTPUT(MouseButton, MessageString) | vreckoDP_base::KeyboardMouse | protected
DECLARE_OUTPUT(MouseDoubleButton, MessageString) | vreckoDP_base::KeyboardMouse | protected
DECLARE_OUTPUT(MouseScroll, MessageString) | vreckoDP_base::KeyboardMouse | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
doubleButtonPress(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my, unsigned int mb) | vreckoDP_base::KeyboardMouse |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
handle(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &) | vreckoDP_base::KeyboardMouse | virtual
id | vrecko::Device | protected
idle() | vreckoDP_base::KeyboardMouse | inline
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
isKeyDown(int keyCode) | vreckoDP_base::KeyboardMouse | inline
KeyboardMouse() | vreckoDP_base::KeyboardMouse |
keydown_map | vreckoDP_base::KeyboardMouse | protected
keyPress(int) | vreckoDP_base::KeyboardMouse |
keyRelease(int) | vreckoDP_base::KeyboardMouse |
keyToString(int key, std::string *str) | vreckoDP_base::KeyboardMouse | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
mouse_button | vreckoDP_base::KeyboardMouse | protected
mouse_position | vreckoDP_base::KeyboardMouse | protected
mouseMotion(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa) | vreckoDP_base::KeyboardMouse |
mouseScroll(osgGA::GUIEventAdapter::ScrollingMotion) | vreckoDP_base::KeyboardMouse |
mouseUpdateCounter | vreckoDP_base::KeyboardMouse | protected
new_mouse_pos_ready | vreckoDP_base::KeyboardMouse | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::KeyboardMouse | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
passiveMouseMotion(const osgGA::GUIEventAdapter &ea, osgGA::GUIActionAdapter &aa, float mx, float my) | vreckoDP_base::KeyboardMouse |
pEventDispatcher | vreckoDP_base::KeyboardMouse | protected
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendMousePosIfReady() | vreckoDP_base::KeyboardMouse | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
shutdown() | vreckoDP_base::KeyboardMouse | inline
specialKeyPress(int) | vreckoDP_base::KeyboardMouse |
specialKeyRelease(int) | vreckoDP_base::KeyboardMouse |
timer | vreckoDP_base::KeyboardMouse | protected
update(void) | vreckoDP_base::KeyboardMouse | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~KeyboardMouse() | vreckoDP_base::KeyboardMouse |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • L3DMouse
vreckoDP_base::L3DMouse Member List

This is the complete list of members for vreckoDP_base::L3DMouse, including all inherited members.

_port_fd | vreckoDP_base::LHeadTracker | protected
_port_name_dual | vreckoDP_base::LHeadTracker | protected
absPI | vreckoDP_base::LHeadTracker | protected
absRO | vreckoDP_base::LHeadTracker | protected
absX | vreckoDP_base::LHeadTracker | protected
absY | vreckoDP_base::LHeadTracker | protected
absYA | vreckoDP_base::LHeadTracker | protected
absZ | vreckoDP_base::LHeadTracker | protected
actual_p | vreckoDP_base::LHeadTracker | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
base1 | vreckoDP_base::LHeadTracker | protected
base2 | vreckoDP_base::LHeadTracker | protected
base3 | vreckoDP_base::LHeadTracker | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
button | vreckoDP_base::L3DMouse | protected
calibrateDevice(void) | vrecko::Device | inlinevirtual
checkDiff(const long int &x, const long int &y, const long int &z, const long int &n_pi, const long int &n_ya, const long int &n_ro) | vreckoDP_base::LHeadTracker | protected
closeDevice(void) | vreckoDP_base::L3DMouse | virtual
DECLARE_OUTPUT(Button_Left, vrecko::MessageBool) | vreckoDP_base::L3DMouse | protected
DECLARE_OUTPUT(Button_Middle, vrecko::MessageBool) | vreckoDP_base::L3DMouse | protected
DECLARE_OUTPUT(Button_Right, vrecko::MessageBool) | vreckoDP_base::L3DMouse | protected
DECLARE_OUTPUT(Button_Suspend, vrecko::MessageBool) | vreckoDP_base::L3DMouse | protected
DECLARE_OUTPUT(Button_Mouse_stand, vrecko::MessageBool) | vreckoDP_base::L3DMouse | protected
vreckoDP_base::LHeadTracker::DECLARE_OUTPUT(Position, vrecko::MessageVec3) | vreckoDP_base::LHeadTracker | protected
vreckoDP_base::LHeadTracker::DECLARE_OUTPUT(Orientation, vrecko::MessageQuat) | vreckoDP_base::LHeadTracker | protected
delay(int msec) | vreckoDP_base::LHeadTracker | inlineprotected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
demandReport(void) | vreckoDP_base::LHeadTracker |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
diagnostic(void) | vreckoDP_base::LHeadTracker | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first_report | vreckoDP_base::LHeadTracker | protected
get_rel_pos(long int x, long int y, long int z) | vreckoDP_base::LHeadTracker | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getEuler(osg::Matrix &_mat) | vreckoDP_base::LHeadTracker | protected
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getLButton(void) | vreckoDP_base::L3DMouse | inline
getMButton(void) | vreckoDP_base::L3DMouse | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRButton(void) | vreckoDP_base::L3DMouse | inline
getRecData(long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet) | vreckoDP_base::L3DMouse | protected
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotate(float *p_rotate) | vreckoDP_base::LHeadTracker |
getRotate(void) | vreckoDP_base::LHeadTracker |
getRotateA(void) | vreckoDP_base::LHeadTracker |
getRotateM(void) | vreckoDP_base::LHeadTracker |
getRotateQ(void) | vreckoDP_base::LHeadTracker |
getSButton(void) | vreckoDP_base::L3DMouse | inline
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTranslate(float *p_trans) | vreckoDP_base::LHeadTracker |
getTranslate(void) | vreckoDP_base::LHeadTracker |
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
L3DMouse() | vreckoDP_base::L3DMouse |
L3DMouse(const char *port) | vreckoDP_base::L3DMouse |
last_absPI | vreckoDP_base::LHeadTracker | protected
last_absRO | vreckoDP_base::LHeadTracker | protected
last_absYA | vreckoDP_base::LHeadTracker | protected
last_rot | vreckoDP_base::LHeadTracker | protected
left_button | vreckoDP_base::L3DMouse | protected
LHeadTracker() | vreckoDP_base::LHeadTracker |
LHeadTracker(const char *port_name) | vreckoDP_base::LHeadTracker |
LHeadTracker(const char *port_name1, const char *port_name2) | vreckoDP_base::LHeadTracker |
lhtRead(char *buf, int n) | vreckoDP_base::LHeadTracker | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_base::L3DMouse | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
middle_button | vreckoDP_base::L3DMouse | protected
mouse_stand_button | vreckoDP_base::L3DMouse | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::L3DMouse | virtual
openPort(const char *_pname, int *temp_port_fd) | vreckoDP_base::LHeadTracker | protected
origin | vreckoDP_base::LHeadTracker | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_fd | vreckoDP_base::LHeadTracker | protected
port_fd_dual | vreckoDP_base::LHeadTracker | protected
port_name | vrecko::Device | protected
pos | vreckoDP_base::LHeadTracker | protected
pos_diff | vreckoDP_base::LHeadTracker | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
printBuffer(const char *buf, int length) | vreckoDP_base::LHeadTracker | protected
printPos(void) | vreckoDP_base::LHeadTracker |
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
read_len | vreckoDP_base::LHeadTracker | protected
rec_out | vreckoDP_base::LHeadTracker | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
req_len | vreckoDP_base::LHeadTracker | protected
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
reset(void) | vreckoDP_base::LHeadTracker | protected
resetBase(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
ret_pos | vreckoDP_base::LHeadTracker | protected
ret_rot | vreckoDP_base::LHeadTracker | protected
ret_rotm | vreckoDP_base::LHeadTracker | protected
ret_rotq | vreckoDP_base::LHeadTracker | protected
right_button | vreckoDP_base::L3DMouse | protected
rot | vreckoDP_base::LHeadTracker | protected
rot_diff | vreckoDP_base::LHeadTracker | protected
rot_type | vreckoDP_base::LHeadTracker | protected
rotq | vreckoDP_base::LHeadTracker | protected
rotq_diff | vreckoDP_base::LHeadTracker | protected
rx_buf | vreckoDP_base::LHeadTracker | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vreckoDP_base::L3DMouse | virtual
scanDevice(void) | vreckoDP_base::L3DMouse | protected
scanDeviceX(void) | vreckoDP_base::LHeadTracker | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBaseR(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
setBaseT(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
setID(int new_id) | vrecko::Device |
setInitialPosition(osg::Vec4 &_pos) | vreckoDP_base::LHeadTracker |
setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2) | vreckoDP_base::LHeadTracker |
setInitialRotation(osg::Vec4 &_rot) | vreckoDP_base::LHeadTracker |
setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2) | vreckoDP_base::LHeadTracker |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setRotationType(rotation_type _type) | vreckoDP_base::LHeadTracker | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSlaveTransmitterType(unsigned char transmitter_type) | vreckoDP_base::LHeadTracker |
singleReport(char *reply) | vreckoDP_base::LHeadTracker | protected
suspend_button | vreckoDP_base::L3DMouse | protected
tenv | vreckoDP_base::LHeadTracker | protected
tr_matrix | vreckoDP_base::LHeadTracker | protected
tr_matrix2 | vreckoDP_base::LHeadTracker | protected
translate_mapping | vreckoDP_base::LHeadTracker | protected
tx_buf | vreckoDP_base::LHeadTracker | protected
update(void) | vreckoDP_base::L3DMouse | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~L3DMouse() | vreckoDP_base::L3DMouse |
~LHeadTracker() | vreckoDP_base::LHeadTracker |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • LHeadTracker
vreckoDP_base::LHeadTracker Member List

This is the complete list of members for vreckoDP_base::LHeadTracker, including all inherited members.

_port_fd | vreckoDP_base::LHeadTracker | protected
_port_name_dual | vreckoDP_base::LHeadTracker | protected
absPI | vreckoDP_base::LHeadTracker | protected
absRO | vreckoDP_base::LHeadTracker | protected
absX | vreckoDP_base::LHeadTracker | protected
absY | vreckoDP_base::LHeadTracker | protected
absYA | vreckoDP_base::LHeadTracker | protected
absZ | vreckoDP_base::LHeadTracker | protected
actual_p | vreckoDP_base::LHeadTracker | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
base1 | vreckoDP_base::LHeadTracker | protected
base2 | vreckoDP_base::LHeadTracker | protected
base3 | vreckoDP_base::LHeadTracker | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
checkDiff(const long int &x, const long int &y, const long int &z, const long int &n_pi, const long int &n_ya, const long int &n_ro) | vreckoDP_base::LHeadTracker | protected
closeDevice(void) | vreckoDP_base::LHeadTracker | virtual
DECLARE_OUTPUT(Position, vrecko::MessageVec3) | vreckoDP_base::LHeadTracker | protected
DECLARE_OUTPUT(Orientation, vrecko::MessageQuat) | vreckoDP_base::LHeadTracker | protected
delay(int msec) | vreckoDP_base::LHeadTracker | inlineprotected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
demandReport(void) | vreckoDP_base::LHeadTracker |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
diagnostic(void) | vreckoDP_base::LHeadTracker | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
first_report | vreckoDP_base::LHeadTracker | protected
get_rel_pos(long int x, long int y, long int z) | vreckoDP_base::LHeadTracker | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getEuler(osg::Matrix &_mat) | vreckoDP_base::LHeadTracker | protected
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRecData(long int *x, long int *y, long int *z, long int *pi, long int *ya, long int *ro, char *packet) | vreckoDP_base::LHeadTracker | protected
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotate(float *p_rotate) | vreckoDP_base::LHeadTracker |
getRotate(void) | vreckoDP_base::LHeadTracker |
getRotateA(void) | vreckoDP_base::LHeadTracker |
getRotateM(void) | vreckoDP_base::LHeadTracker |
getRotateQ(void) | vreckoDP_base::LHeadTracker |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTranslate(float *p_trans) | vreckoDP_base::LHeadTracker |
getTranslate(void) | vreckoDP_base::LHeadTracker |
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
last_absPI | vreckoDP_base::LHeadTracker | protected
last_absRO | vreckoDP_base::LHeadTracker | protected
last_absYA | vreckoDP_base::LHeadTracker | protected
last_rot | vreckoDP_base::LHeadTracker | protected
LHeadTracker() | vreckoDP_base::LHeadTracker |
LHeadTracker(const char *port_name) | vreckoDP_base::LHeadTracker |
LHeadTracker(const char *port_name1, const char *port_name2) | vreckoDP_base::LHeadTracker |
lhtRead(char *buf, int n) | vreckoDP_base::LHeadTracker | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_base::LHeadTracker | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::LHeadTracker | virtual
openPort(const char *_pname, int *temp_port_fd) | vreckoDP_base::LHeadTracker | protected
origin | vreckoDP_base::LHeadTracker | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_fd | vreckoDP_base::LHeadTracker | protected
port_fd_dual | vreckoDP_base::LHeadTracker | protected
port_name | vrecko::Device | protected
pos | vreckoDP_base::LHeadTracker | protected
pos_diff | vreckoDP_base::LHeadTracker | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
printBuffer(const char *buf, int length) | vreckoDP_base::LHeadTracker | protected
printPos(void) | vreckoDP_base::LHeadTracker |
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
read_len | vreckoDP_base::LHeadTracker | protected
rec_out | vreckoDP_base::LHeadTracker | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
req_len | vreckoDP_base::LHeadTracker | protected
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
reset(void) | vreckoDP_base::LHeadTracker | protected
resetBase(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
ret_pos | vreckoDP_base::LHeadTracker | protected
ret_rot | vreckoDP_base::LHeadTracker | protected
ret_rotm | vreckoDP_base::LHeadTracker | protected
ret_rotq | vreckoDP_base::LHeadTracker | protected
rot | vreckoDP_base::LHeadTracker | protected
rot_diff | vreckoDP_base::LHeadTracker | protected
rot_type | vreckoDP_base::LHeadTracker | protected
rotq | vreckoDP_base::LHeadTracker | protected
rotq_diff | vreckoDP_base::LHeadTracker | protected
rx_buf | vreckoDP_base::LHeadTracker | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vreckoDP_base::LHeadTracker | virtual
scanDevice(void) | vreckoDP_base::LHeadTracker | protected
scanDeviceX(void) | vreckoDP_base::LHeadTracker | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setBaseR(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
setBaseT(osg::Vec4 b1, osg::Vec4 b2, osg::Vec4 b3, osg::Vec4 orig) | vreckoDP_base::LHeadTracker |
setID(int new_id) | vrecko::Device |
setInitialPosition(osg::Vec4 &_pos) | vreckoDP_base::LHeadTracker |
setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2) | vreckoDP_base::LHeadTracker |
setInitialRotation(osg::Vec4 &_rot) | vreckoDP_base::LHeadTracker |
setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2) | vreckoDP_base::LHeadTracker |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setRotationType(rotation_type _type) | vreckoDP_base::LHeadTracker | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSlaveTransmitterType(unsigned char transmitter_type) | vreckoDP_base::LHeadTracker |
singleReport(char *reply) | vreckoDP_base::LHeadTracker | protected
tenv | vreckoDP_base::LHeadTracker | protected
tr_matrix | vreckoDP_base::LHeadTracker | protected
tr_matrix2 | vreckoDP_base::LHeadTracker | protected
translate_mapping | vreckoDP_base::LHeadTracker | protected
tx_buf | vreckoDP_base::LHeadTracker | protected
update(void) | vreckoDP_base::LHeadTracker | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~LHeadTracker() | vreckoDP_base::LHeadTracker |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • MicroScribe3D
vreckoDP_base::MicroScribe3D Member List

This is the complete list of members for vreckoDP_base::MicroScribe3D, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_base::MicroScribe3D | virtual
DECLARE_OUTPUT(Buttons, vrecko::MessageInt) | vreckoDP_base::MicroScribe3D | protected
DECLARE_OUTPUT(Position, vrecko::MessageVec3) | vreckoDP_base::MicroScribe3D | protected
DECLARE_OUTPUT(Normal, vrecko::MessageVec3) | vreckoDP_base::MicroScribe3D | protected
DECLARE_OUTPUT(Orientation, vrecko::MessageQuat) | vreckoDP_base::MicroScribe3D | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getButt() | vreckoDP_base::MicroScribe3D | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
MicroScribe3D() | vreckoDP_base::MicroScribe3D |
MicroScribe3D(const char *port_name) | vreckoDP_base::MicroScribe3D |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::MicroScribe3D | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
pEventDispatcher | vreckoDP_base::MicroScribe3D | protected
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vreckoDP_base::MicroScribe3D | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~MicroScribe3D() | vreckoDP_base::MicroScribe3D |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • NestOfBirds
vreckoDP_base::NestOfBirds Member List

This is the complete list of members for vreckoDP_base::NestOfBirds, including all inherited members.

_buf | vreckoDP_base::NestOfBirds | protected
_hostname | vreckoDP_base::NestOfBirds | protected
_origin_pos | vreckoDP_base::NestOfBirds | protected
_port | vreckoDP_base::NestOfBirds | protected
_ret_rotate | vreckoDP_base::NestOfBirds | protected
_ret_translate | vreckoDP_base::NestOfBirds | protected
_rotate | vreckoDP_base::NestOfBirds | protected
_trans_mapp | vreckoDP_base::NestOfBirds | protected
_translate | vreckoDP_base::NestOfBirds | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_base::NestOfBirds | virtual
DECLARE_OUTPUT(Position_sensor_0, vrecko::MessageVec3) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Orientation_sensor_0, vrecko::MessageQuat) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Position_sensor_1, vrecko::MessageVec3) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Orientation_sensor_1, vrecko::MessageQuat) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Position_sensor_2, vrecko::MessageVec3) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Orientation_sensor_2, vrecko::MessageQuat) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Position_sensor_3, vrecko::MessageVec3) | vreckoDP_base::NestOfBirds | protected
DECLARE_OUTPUT(Orientation_sensor_3, vrecko::MessageQuat) | vreckoDP_base::NestOfBirds | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOriginPosition(void) | vreckoDP_base::NestOfBirds | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotate(float *p_rotate) | vreckoDP_base::NestOfBirds |
getRotate(void) | vreckoDP_base::NestOfBirds |
getRotateA(void) | vreckoDP_base::NestOfBirds |
getRotateM(void) | vreckoDP_base::NestOfBirds |
getRotateQ(void) | vreckoDP_base::NestOfBirds |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTranslate(float *p_trans) | vreckoDP_base::NestOfBirds |
getTranslate(void) | vreckoDP_base::NestOfBirds |
getTranslateMapping(void) | vreckoDP_base::NestOfBirds | inline
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
length | vreckoDP_base::NestOfBirds | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_base::NestOfBirds | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NestOfBirds() | vreckoDP_base::NestOfBirds |
NestOfBirds(const char *_port_number) | vreckoDP_base::NestOfBirds |
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::NestOfBirds | virtual
openSocket(void) | vreckoDP_base::NestOfBirds | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
pEventDispatcher | vreckoDP_base::NestOfBirds | protected
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vreckoDP_base::NestOfBirds | virtual
scanDevice(void) | vreckoDP_base::NestOfBirds | protected
scanDeviceX(void) | vreckoDP_base::NestOfBirds | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setInitialPosition(osg::Vec4 &_pos) | vreckoDP_base::NestOfBirds |
setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2) | vreckoDP_base::NestOfBirds |
setInitialRotation(osg::Vec4 &_rot) | vreckoDP_base::NestOfBirds |
setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2) | vreckoDP_base::NestOfBirds |
setOriginPosition(float _nx, float _ny, float _nz) | vreckoDP_base::NestOfBirds | inline
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTranslateMapping(float _nx, float _ny, float _nz) | vreckoDP_base::NestOfBirds | inline
sockfd | vreckoDP_base::NestOfBirds | protected
sockname | vreckoDP_base::NestOfBirds | protected
update(void) | vreckoDP_base::NestOfBirds | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~NestOfBirds() | vreckoDP_base::NestOfBirds |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • OptiTrack
vreckoDP_base::OptiTrack Member List

This is the complete list of members for vreckoDP_base::OptiTrack, including all inherited members.

_hostname | vreckoDP_base::OptiTrack | protected
_origin_pos | vreckoDP_base::OptiTrack | protected
_port | vreckoDP_base::OptiTrack | protected
_trans_mapp | vreckoDP_base::OptiTrack | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
addSensor(int i) | vreckoDP_base::OptiTrack | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_base::OptiTrack | virtual
connection | vreckoDP_base::OptiTrack | protected
connectionName | vreckoDP_base::OptiTrack | protected
DECLARE_INPUT(SetSensorCount, vrecko::MessageInt) | vreckoDP_base::OptiTrack | protected
DECLARE_OUTPUT(Sensor_Transformation, vrecko::MessageSensorTransformation) | vreckoDP_base::OptiTrack | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
deprecated_version | vreckoDP_base::OptiTrack | protected
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOriginPosition() | vreckoDP_base::OptiTrack | inline
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getSensorScale() | vreckoDP_base::OptiTrack | inline
getTranslateMapping() | vreckoDP_base::OptiTrack | inline
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
is | vreckoDP_base::OptiTrack | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_base::OptiTrack | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::OptiTrack | virtual
OptiTrack() | vreckoDP_base::OptiTrack |
OptiTrack(const char *_port_number) | vreckoDP_base::OptiTrack |
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
pEventDispatcher | vreckoDP_base::OptiTrack | protected
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize() | vreckoDP_base::OptiTrack | virtual
preInitialize() | vreckoDP_base::OptiTrack | virtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vreckoDP_base::OptiTrack | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendEvent(int sid, osg::Vec3 *p, osg::Quat *o) | vreckoDP_base::OptiTrack |
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
sensor_count | vreckoDP_base::OptiTrack | protected
sensorScale | vreckoDP_base::OptiTrack | protected
server_address | vreckoDP_base::OptiTrack | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
tracker | vreckoDP_base::OptiTrack | protected
update(void) | vreckoDP_base::OptiTrack | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~OptiTrack() | vreckoDP_base::OptiTrack |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • Ultratrak
vreckoDP_base::Ultratrak Member List

This is the complete list of members for vreckoDP_base::Ultratrak, including all inherited members.

_buf | vreckoDP_base::Ultratrak | protected
_hostname | vreckoDP_base::Ultratrak | protected
_origin_pos | vreckoDP_base::Ultratrak | protected
_port | vreckoDP_base::Ultratrak | protected
_ret_rotate | vreckoDP_base::Ultratrak | protected
_ret_translate | vreckoDP_base::Ultratrak | protected
_rotate | vreckoDP_base::Ultratrak | protected
_trans_mapp | vreckoDP_base::Ultratrak | protected
_translate | vreckoDP_base::Ultratrak | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_base::Ultratrak | virtual
DECLARE_OUTPUT(Position_sensor_0, vrecko::MessageVec3) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Orientation_sensor_0, vrecko::MessageQuat) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Position_sensor_1, vrecko::MessageVec3) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Orientation_sensor_1, vrecko::MessageQuat) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Position_sensor_2, vrecko::MessageVec3) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Orientation_sensor_2, vrecko::MessageQuat) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Position_sensor_3, vrecko::MessageVec3) | vreckoDP_base::Ultratrak | protected
DECLARE_OUTPUT(Orientation_sensor_3, vrecko::MessageQuat) | vreckoDP_base::Ultratrak | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotate(float *p_rotate) | vreckoDP_base::Ultratrak |
getRotate(void) | vreckoDP_base::Ultratrak |
getRotateA(void) | vreckoDP_base::Ultratrak |
getRotateM(void) | vreckoDP_base::Ultratrak |
getRotateQ(void) | vreckoDP_base::Ultratrak |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getTranslate(float *p_trans) | vreckoDP_base::Ultratrak |
getTranslate(void) | vreckoDP_base::Ultratrak |
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
length | vreckoDP_base::Ultratrak | protected
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::Ultratrak | virtual
openSocket(void) | vreckoDP_base::Ultratrak | protected
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scanDevice(void) | vreckoDP_base::Ultratrak | protected
scanDeviceX(void) | vreckoDP_base::Ultratrak | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setInitialPosition(osg::Vec4 &_pos) | vreckoDP_base::Ultratrak |
setInitialPosition(osg::Vec4 &_pos1, osg::Vec4 &_pos2) | vreckoDP_base::Ultratrak |
setInitialRotation(osg::Vec4 &_rot) | vreckoDP_base::Ultratrak |
setInitialRotation(osg::Vec4 &_rot1, osg::Vec4 &_rot2) | vreckoDP_base::Ultratrak |
setOriginPosition(float _nx, float _ny, float _nz) | vreckoDP_base::Ultratrak | inline
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setTranslateMapping(float _nx, float _ny, float _nz) | vreckoDP_base::Ultratrak | inline
sockfd | vreckoDP_base::Ultratrak | protected
sockname | vreckoDP_base::Ultratrak | protected
Ultratrak() | vreckoDP_base::Ultratrak | inline
Ultratrak(const char *_port_number) | vreckoDP_base::Ultratrak |
update(void) | vreckoDP_base::Ultratrak | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~Ultratrak() | vreckoDP_base::Ultratrak |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • VRPN3DMouse
vreckoDP_base::VRPN3DMouse Member List

This is the complete list of members for vreckoDP_base::VRPN3DMouse, including all inherited members.

_axisControl | vreckoDP_base::VRPN3DMouse | protected
_curMove | vreckoDP_base::VRPN3DMouse | protected
_curRotate | vreckoDP_base::VRPN3DMouse | protected
_originPos | vreckoDP_base::VRPN3DMouse | protected
_originRot | vreckoDP_base::VRPN3DMouse | protected
_rotateControl | vreckoDP_base::VRPN3DMouse | protected
_rotateRatio | vreckoDP_base::VRPN3DMouse | protected
_speedControl | vreckoDP_base::VRPN3DMouse | protected
_speedFactor | vreckoDP_base::VRPN3DMouse | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
ana | vreckoDP_base::VRPN3DMouse | protected
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
but | vreckoDP_base::VRPN3DMouse | protected
calibrateDevice(void) | vrecko::Device | inlinevirtual
closeDevice(void) | vreckoDP_base::VRPN3DMouse | virtual
DECLARE_OUTPUT(Button, vrecko::MessageString) | vreckoDP_base::VRPN3DMouse | protected
DECLARE_OUTPUT(Position, vrecko::MessageVec3) | vreckoDP_base::VRPN3DMouse | protected
DECLARE_OUTPUT(Move, vrecko::MessageVec3) | vreckoDP_base::VRPN3DMouse | protected
DECLARE_OUTPUT(Rotation, vrecko::MessageQuat) | vreckoDP_base::VRPN3DMouse | protected
DECLARE_OUTPUT(Orientation, vrecko::MessageQuat) | vreckoDP_base::VRPN3DMouse | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
handle_analog(void *userdata, vrpn_ANALOGCB b) | vreckoDP_base::VRPN3DMouse | protectedstatic
handle_button(void *userdata, vrpn_BUTTONCB b) | vreckoDP_base::VRPN3DMouse | protectedstatic
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode) | vreckoDP_base::VRPN3DMouse | virtual
vrecko::Device::loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::VRPN3DMouse | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
pEventDispatcher | vreckoDP_base::VRPN3DMouse | protected
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, void *value) | vreckoDP_base::VRPN3DMouse |
vrecko::Device::processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
update(void) | vreckoDP_base::VRPN3DMouse | virtual
VRPN3DMouse() | vreckoDP_base::VRPN3DMouse |
VRPN3DMouse::sendAnalogEvent(osg::Vec3 *p, osg::Vec3 *o) | vreckoDP_base::VRPN3DMouse |
VRPN3DMouse::sendButtonEvent(u_int key, u_int state) | vreckoDP_base::VRPN3DMouse |
vrpnServerHandle | vreckoDP_base::VRPN3DMouse | protected
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • Wiimote
vreckoDP_base::Wiimote Member List

This is the complete list of members for vreckoDP_base::Wiimote, including all inherited members.

addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vrecko::Device | inlinevirtual
check_failed | vreckoDP_base::Wiimote | protectedstatic
closeDevice(void) | vreckoDP_base::Wiimote | virtual
DECLARE_INPUT(Vibration, vrecko::MessageBool) | vreckoDP_base::Wiimote | protected
DECLARE_OUTPUT(Button, vrecko::MessageString) | vreckoDP_base::Wiimote | protected
DECLARE_OUTPUT(Orientation, vrecko::MessageVec3) | vreckoDP_base::Wiimote | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
disabled | vreckoDP_base::Wiimote | protectedstatic
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
handle_ctrl_status(struct wiimote_t *wm) | vreckoDP_base::Wiimote |
handle_disconnect(wiimote *wm) | vreckoDP_base::Wiimote |
handle_event(int currentWiimoteID, struct wiimote_t *wm) | vreckoDP_base::Wiimote |
handle_read(struct wiimote_t *wm, byte *data, unsigned short len) | vreckoDP_base::Wiimote |
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode=NULL) | vreckoDP_base::Wiimote | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
is_initialized | vreckoDP_base::Wiimote | protectedstatic
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
main_wiimote | vreckoDP_base::Wiimote | protected
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::Wiimote | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
pWiimote | vreckoDP_base::Wiimote | protectedstatic
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vreckoDP_base::Wiimote | virtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
test(struct wiimote_t *wm, byte *data, unsigned short len) | vreckoDP_base::Wiimote |
update(void) | vreckoDP_base::Wiimote | virtual
vibration | vreckoDP_base::Wiimote | protected
Wiimote() | vreckoDP_base::Wiimote |
wiimoteID | vreckoDP_base::Wiimote | protected
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~Wiimote() | vreckoDP_base::Wiimote |
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • fdtDataGlove
vreckoDP_base::fdtDataGlove Member List

This is the complete list of members for vreckoDP_base::fdtDataGlove, including all inherited members.

_last_signal | vreckoDP_base::fdtDataGlove | protected
_signal_type_table | vreckoDP_base::fdtDataGlove | protected
actual_sensor_values | vreckoDP_base::fdtDataGlove | protected
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
calibrateDevice(void) | vreckoDP_base::fdtDataGlove | virtual
closeDevice(void) | vreckoDP_base::fdtDataGlove | virtual
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
fdtDataGlove() | vreckoDP_base::fdtDataGlove |
fdtDataGlove(char *port) | vreckoDP_base::fdtDataGlove |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
finger_direction | vreckoDP_base::fdtDataGlove | protected
freeze_finger_sensor | vreckoDP_base::fdtDataGlove | protected
freeze_rotation | vreckoDP_base::fdtDataGlove | protected
freezeFingerSensor(int id_FS, bool new_freezeFS) | vreckoDP_base::fdtDataGlove |
freezeRotation(bool new_freezeR) | vreckoDP_base::fdtDataGlove | inline
getActualValue(float *p_actual_value) | vreckoDP_base::fdtDataGlove |
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getCalibrationString(void) | vrecko::Device | inlinevirtual
getDeviceType(void) | vrecko::Device | inline
getFingerDirection(int id_finger, float *p_finger_direction) | vreckoDP_base::fdtDataGlove |
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getRotate(float *p_rotate) | vreckoDP_base::fdtDataGlove |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
getSignal(void) | vreckoDP_base::fdtDataGlove |
hand_type | vreckoDP_base::fdtDataGlove | protected
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
num_sensors | vreckoDP_base::fdtDataGlove | protected
openDevice(void) | vreckoDP_base::fdtDataGlove | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
PinList typedef | vrecko::BaseClass | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
scanDevice(void) | vreckoDP_base::fdtDataGlove | protected
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
setSignalType(int _signal_id, int _type) | vreckoDP_base::fdtDataGlove | inline
update(void) | vreckoDP_base::fdtDataGlove | inlinevirtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~fdtDataGlove() | vreckoDP_base::fdtDataGlove |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • fsPinchGlove
vreckoDP_base::fsPinchGlove Member List

This is the complete list of members for vreckoDP_base::fsPinchGlove, including all inherited members.

_active_contact | vreckoDP_base::fsPinchGlove | protected
_contact_count | vreckoDP_base::fsPinchGlove | protected
_current_type | vreckoDP_base::fsPinchGlove | protected
_signal | vreckoDP_base::fsPinchGlove | protected
_signal_backup | vreckoDP_base::fsPinchGlove | protected
_signal_count | vreckoDP_base::fsPinchGlove | protected
_signal_transf_table | vreckoDP_base::fsPinchGlove | protected
_signal_type_table | vreckoDP_base::fsPinchGlove | protected
activateGesture(int t1, int t2=0, int t3=0, int t4=0, int t5=0) | vreckoDP_base::fsPinchGlove |
addInputPin(InputPinBase *pin) | vrecko::BaseClass |
addNotification(BaseClass *receiver, unsigned long notificationTypes) | vrecko::BaseClass |
addOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
addRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
addRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
attribute | vrecko::BaseClass | protected
attributeLock | vrecko::BaseClass | protected
AttributeMap typedef | vrecko::BaseClass | protected
BaseClass(const char *startingSenderString) | vrecko::BaseClass |
BaseClass(BaseClass &bc) | vrecko::BaseClass |
bufx | vreckoDP_base::fsPinchGlove | protected
bufxe | vreckoDP_base::fsPinchGlove | protected
calibrateDevice(void) | vrecko::Device | inlinevirtual
callbacks | vreckoDP_base::fsPinchGlove | protected
checkBox(void) | vreckoDP_base::fsPinchGlove | protected
checkConnection(void) | vreckoDP_base::fsPinchGlove | protected
checkGesture(void) | vreckoDP_base::fsPinchGlove |
closeDevice(void) | vreckoDP_base::fsPinchGlove | virtual
deactivateGesture(int t1, int t2=0, int t3=0, int t4=0, int t5=0) | vreckoDP_base::fsPinchGlove |
delay(int msec) | vreckoDP_base::fsPinchGlove | protected
deleteAttribute(const std::string &attr_name) | vrecko::BaseClass |
Device(const char *startingDeviceName, const char *pname="") | vrecko::Device |
device_type | vrecko::Device | protected
disableTS(void) | vreckoDP_base::fsPinchGlove |
enableTS(void) | vreckoDP_base::fsPinchGlove |
findPinInList(const char *strName, PinList *pinList) | vrecko::BaseClass | inlineprotected
fsPinchGlove() | vreckoDP_base::fsPinchGlove |
fsPinchGlove(const char *port_name) | vreckoDP_base::fsPinchGlove |
gestureOn | vreckoDP_base::fsPinchGlove | protected
getAttribute(const std::string &attr_name) | vrecko::BaseClass | inline
getAttribute(const char *attr_name) | vrecko::BaseClass | inline
getByte(char *buf) | vreckoDP_base::fsPinchGlove | protected
getCalibrationString(void) | vrecko::Device | inlinevirtual
getData(char *buf, int len, int *time_st) | vreckoDP_base::fsPinchGlove | protected
getDeviceType(void) | vrecko::Device | inline
getGesture(void) | vreckoDP_base::fsPinchGlove |
getID(void) | vrecko::Device | inline
getInputPin(const char *strName) | vrecko::BaseClass |
getOutputPin(const char *strName) | vrecko::BaseClass |
getPacket(char *buf) | vreckoDP_base::fsPinchGlove | protected
getPortName(void) | vrecko::Device | inline
getPriority(void) const | vrecko::BaseClass | inline
getRequestInputPin(const char *strName) | vrecko::BaseClass |
getRequestOutputPin(const char *strName) | vrecko::BaseClass |
getSceneFile() const | vrecko::BaseClass | inline
getSenderString(void) | vrecko::BaseClass | inlinevirtual
id | vrecko::Device | protected
initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parameters=NULL) | vrecko::BaseClass | virtual
initializeFromString(const char *xmlString) | vrecko::BaseClass | virtual
initPort(char *port) | vreckoDP_base::fsPinchGlove |
inputPinsList | vrecko::BaseClass | protected
inputPresent(const std::string &name) | vrecko::BaseClass |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *) | vrecko::BaseClass | inlinevirtual
loadXMLParameters(const char *xmlString) | vrecko::BaseClass | virtual
NOTIFICATION_ALL enum value | vrecko::BaseClass |
NOTIFICATION_DELETE_CLASS enum value | vrecko::BaseClass |
NOTIFICATION_EO_REGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_EO_UNREGISTERING enum value | vrecko::BaseClass |
NOTIFICATION_PROGRAM_TERMINATION enum value | vrecko::BaseClass |
notifications | vrecko::BaseClass | protected
notificationsLock | vrecko::BaseClass | protected
NotificationTypes enum name | vrecko::BaseClass |
openDevice(void) | vreckoDP_base::fsPinchGlove | virtual
outputPinsList | vrecko::BaseClass | protected
outputPresent(const std::string &name) | vrecko::BaseClass |
pgd_close(void) | vreckoDP_base::fsPinchGlove | protected
pgdComm(const char buf[2], char *reply) | vreckoDP_base::fsPinchGlove | protected
pgdRead(char *buf, int n) | vreckoDP_base::fsPinchGlove | protected
PinList typedef | vrecko::BaseClass | protected
port_fd | vreckoDP_base::fsPinchGlove | protected
port_name | vrecko::Device | protected
postInitialize(void) | vrecko::BaseClass | inlinevirtual
preInitialize(void) | vrecko::BaseClass | inlinevirtual
printBuf(const char *buf, int length) | vreckoDP_base::fsPinchGlove | protected
printConf(void) | vreckoDP_base::fsPinchGlove |
printGests(void) | vreckoDP_base::fsPinchGlove |
priority | vrecko::BaseClass | protected
processEvent(const std::string &input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
processNotification(BaseClass *sender, unsigned long notificationType, void *notificationData) | vrecko::BaseClass | inlineprotectedvirtual
processRequest(const std::string &request_input_name, VreckoMessage *pMessage) | vrecko::BaseClass | virtual
relCall | vreckoDP_base::fsPinchGlove | protected
relFunc | vreckoDP_base::fsPinchGlove | protected
removeInputPin(InputPinBase *pin) | vrecko::BaseClass |
removeNotification(BaseClass *receiver, unsigned long notificationTypes=NOTIFICATION_ALL) | vrecko::BaseClass |
removeOutputPin(OutputPinBase *pin) | vrecko::BaseClass |
removeRequestInputPin(RequestInputPinBase *pin) | vrecko::BaseClass |
removeRequestOutputPin(RequestOutputPinBase *pin) | vrecko::BaseClass |
reportError(const std::string &error) | vrecko::BaseClass |
requestInputPinsList | vrecko::BaseClass | protected
requestOutputPinsList | vrecko::BaseClass | protected
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | vrecko::BaseClass | inlinevirtual
sceneFile | vrecko::BaseClass | protected
senderString | vrecko::BaseClass | protected
sendNotifications(unsigned long notificationType, void *notificationData) | vrecko::BaseClass | protected
setAttribute(const std::string &attr_name, int attr_value) | vrecko::BaseClass | inline
setGestureFunc(int(*func)(void *), void *g_object, int t1, int t2=0, int t3=0, int t4=0, int t5=0) | vreckoDP_base::fsPinchGlove |
setID(int new_id) | vrecko::Device |
setPortName(const char *pname) | vrecko::Device | inline
setPriority(long int pr) | vrecko::BaseClass | inline
setReleaseFunc(int(*func)(void *), void *data) | vreckoDP_base::fsPinchGlove |
setSceneFile(const std::string &sceneFileName) | vrecko::BaseClass |
ticks | vreckoDP_base::fsPinchGlove | protected
update(void) | vreckoDP_base::fsPinchGlove | virtual
~BaseClass() | vrecko::BaseClass | virtual
~Device() | vrecko::Device | inlinevirtual
~fsPinchGlove() | vreckoDP_base::fsPinchGlove |
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • HighlightCallback
vreckoUtils::HighlightCallback Member List

This is the complete list of members for vreckoUtils::HighlightCallback, including all inherited members.

_dirty | vreckoUtils::HighlightCallback | protected
_highlighted | vreckoUtils::HighlightCallback | protected
_increment | vreckoUtils::HighlightCallback | protected
_incrementVec | vreckoUtils::HighlightCallback | protected
_origColors | vreckoUtils::HighlightCallback | protected
getHighlighted() const | vreckoUtils::HighlightCallback | inline
getIncrementValue() const | vreckoUtils::HighlightCallback | inline
HighlightCallback(double increment) | vreckoUtils::HighlightCallback | inline
operator()(osg::Node *node, osg::NodeVisitor *nv) | vreckoUtils::HighlightCallback | virtual
setHighlighting(bool val) | vreckoUtils::HighlightCallback | inline
setIncrementValue(double val) | vreckoUtils::HighlightCallback | inline
switchHighlighting() | vreckoUtils::HighlightCallback | inline
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • IMenuComponent
vreckoUtils::IMenuComponent Member List

This is the complete list of members for vreckoUtils::IMenuComponent, including all inherited members.

accept(MenuVisitor &visitor)=0 | vreckoUtils::IMenuComponent | pure virtual
getCaption()=0 | vreckoUtils::IMenuComponent | pure virtual
getName()=0 | vreckoUtils::IMenuComponent | pure virtual
toXMLString()=0 | vreckoUtils::IMenuComponent | pure virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Math
vreckoUtils::Math Member List

This is the complete list of members for vreckoUtils::Math, including all inherited members.

gcd(int a, int b) | vreckoUtils::Math | static
lcm(int a, int b) | vreckoUtils::Math | static
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Menu
vreckoUtils::Menu Member List

This is the complete list of members for vreckoUtils::Menu, including all inherited members.

_items | vreckoUtils::MenuBase | protected
_menuCaption | vreckoUtils::Menu | protected
_menuName | vreckoUtils::Menu | protected
accept(MenuVisitor &visitor) | vreckoUtils::Menu | virtual
addChild(osg::ref_ptr< IMenuComponent > menuComponent) | vreckoUtils::MenuBase | inline
getCaption() | vreckoUtils::Menu | inlinevirtual
getChild(u_int index) | vreckoUtils::MenuBase | inline
getName() | vreckoUtils::Menu | inlinevirtual
Menu(string name="", string caption="") | vreckoUtils::Menu | inline
removeChild(int index) | vreckoUtils::MenuBase | inline
toXMLString() | vreckoUtils::Menu | virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuBase
vreckoUtils::MenuBase Member List

This is the complete list of members for vreckoUtils::MenuBase, including all inherited members.

_items | vreckoUtils::MenuBase | protected
accept(MenuVisitor &visitor)=0 | vreckoUtils::IMenuComponent | pure virtual
addChild(osg::ref_ptr< IMenuComponent > menuComponent) | vreckoUtils::MenuBase | inline
getCaption()=0 | vreckoUtils::IMenuComponent | pure virtual
getChild(u_int index) | vreckoUtils::MenuBase | inline
getName()=0 | vreckoUtils::IMenuComponent | pure virtual
removeChild(int index) | vreckoUtils::MenuBase | inline
toXMLString()=0 | vreckoUtils::IMenuComponent | pure virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuCommon
vreckoUtils::MenuCommon Member List

This is the complete list of members for vreckoUtils::MenuCommon, including all inherited members.

createMenuItem(std::ostringstream &menuSS, const char *itemName, const char *caption, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f)) | vreckoUtils::MenuCommon | static
createMenuSlider(std::ostringstream &menuSS, const char *itemName, const char *caption, double sliderFrom, double sliderTo, bool integerOnly, double sliderPos, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f)) | vreckoUtils::MenuCommon | static
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuItem
vreckoUtils::MenuItem Member List

This is the complete list of members for vreckoUtils::MenuItem, including all inherited members.

_color | vreckoUtils::MenuItem | protected
_itemCaption | vreckoUtils::MenuItem | protected
_itemName | vreckoUtils::MenuItem | protected
accept(MenuVisitor &visitor) | vreckoUtils::MenuItem | virtual
getCaption() | vreckoUtils::MenuItem | inlinevirtual
getName() | vreckoUtils::MenuItem | inlinevirtual
MenuItem(string name, string caption, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f)) | vreckoUtils::MenuItem | inline
MenuItem(string name, string caption, osg::Vec4 color) | vreckoUtils::MenuItem | inline
toXMLString() | vreckoUtils::MenuItem | virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuRoot
vreckoUtils::MenuRoot Member List

This is the complete list of members for vreckoUtils::MenuRoot, including all inherited members.

_attributes | vreckoUtils::MenuRoot | protected
_items | vreckoUtils::MenuBase | protected
accept(MenuVisitor &visitor) | vreckoUtils::MenuRoot | virtual
addAttribute(const std::string &name, double value) | vreckoUtils::MenuRoot | inline
addChild(osg::ref_ptr< IMenuComponent > menuComponent) | vreckoUtils::MenuBase | inline
getCaption() | vreckoUtils::MenuRoot | inlinevirtual
getChild(u_int index) | vreckoUtils::MenuBase | inline
getName() | vreckoUtils::MenuRoot | inlinevirtual
MenuRoot() | vreckoUtils::MenuRoot | inline
removeAttribute(const std::string &name) | vreckoUtils::MenuRoot | inline
removeChild(int index) | vreckoUtils::MenuBase | inline
toXMLString() | vreckoUtils::MenuRoot | virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuSlider
vreckoUtils::MenuSlider Member List

This is the complete list of members for vreckoUtils::MenuSlider, including all inherited members.

_color | vreckoUtils::MenuSlider | protected
_from | vreckoUtils::MenuSlider | protected
_onlyInt | vreckoUtils::MenuSlider | protected
_sliderCaption | vreckoUtils::MenuSlider | protected
_sliderName | vreckoUtils::MenuSlider | protected
_to | vreckoUtils::MenuSlider | protected
_value | vreckoUtils::MenuSlider | protected
accept(MenuVisitor &visitor) | vreckoUtils::MenuSlider | virtual
getCaption() | vreckoUtils::MenuSlider | inlinevirtual
getName() | vreckoUtils::MenuSlider | inlinevirtual
getValue() const | vreckoUtils::MenuSlider | inline
MenuSlider(string name, string caption, double from, double to, double value, bool onlyInt, osg::Vec3 color=osg::Vec3(0.9f, 0.8f, 0.8f)) | vreckoUtils::MenuSlider | inline
setValue(double val) | vreckoUtils::MenuSlider | inline
toXMLString() | vreckoUtils::MenuSlider | virtual
~IMenuComponent() | vreckoUtils::IMenuComponent | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • MenuVisitor
vreckoUtils::MenuVisitor Member List

This is the complete list of members for vreckoUtils::MenuVisitor, including all inherited members.

apply(IMenuComponent &) | vreckoUtils::MenuVisitor | inlinevirtual
apply(Menu &) | vreckoUtils::MenuVisitor | inlinevirtual
apply(MenuRoot &) | vreckoUtils::MenuVisitor | inlinevirtual
apply(MenuItem &) | vreckoUtils::MenuVisitor | inlinevirtual
apply(MenuSlider &) | vreckoUtils::MenuVisitor | inlinevirtual
MenuVisitor() | vreckoUtils::MenuVisitor | inline
~MenuVisitor() | vreckoUtils::MenuVisitor | inlinevirtual
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Observable
vreckoUtils::Observable Member List

This is the complete list of members for vreckoUtils::Observable, including all inherited members.

_observers | vreckoUtils::Observable | protected
addObserver(Observer *observer) | vreckoUtils::Observable | inline
notifyObservers(void *userData=NULL) | vreckoUtils::Observable | inline
Observable() | vreckoUtils::Observable | inlineprotected
removeObserver(Observer *observer) | vreckoUtils::Observable | inline
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoUtils
  • Observer
vreckoUtils::Observer Member List

This is the complete list of members for vreckoUtils::Observer, including all inherited members.

notify(Observable *object, void *userData)=0 | vreckoUtils::Observer | pure virtual
Observer() | vreckoUtils::Observer | inlineprotected
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/collection.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
collection.h
Go to the documentation of this file.
1 /* collection - list of lists (list of gestures + actual list)
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.2 22.11.2002
4 */
5
6 /*
7 * collection - smart gesture list
8 * - with transformation ability -> rotate gesture, scale gesture
9 */
10
11 #ifndef _COLLECTION_
12 #define _COLLECTION_
13
14 #include "gesture.h"
15 #include "mvect.h"
16 #include "gm.h"
17 #include <vector>
18
19 namespace mv{
20 class CCollection{
21 public:
22 std::vector <CGesture> glist;
23 public:
24 CCollection();
25 ~CCollection();
26 };
27
28 }
29
30 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/connecting_functions.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
connecting_functions.h
Go to the documentation of this file.
1 #ifndef CONNECTING_FUNCTIONS_H
2 #define CONNECTING_FUNCTIONS_H
3
4
5 float weightFunction(float value);
6
7 double weightFunctionNormalize(double value, double maxValue);
8
9 double weightGaussFunction(double x);
10
11 double F(double x);
12
13
14 #endif //CONNECTING_FUNCTIONS_H
15
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/d0lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
d0lsystem.h
Go to the documentation of this file.
1 #ifndef D0LSYSTEM_H_
2 #define D0LSYSTEM_H_
3
4 #include "abstract0lsystem.h"
5
6 namespace AP_LSystem {
7 class D0LSystem : public LSystem
8 {
9 protected:
10 static const unsigned int capabilities = LS_0L | LS_DETERMINISTIC;
11
12 virtual void processPredecessor( Rule &, string *, string::iterator & );
13 virtual void processRuleSuccessor( Rule &, string *, string::iterator &);
14 virtual void processHomomorphismSuccessor( Rule &, string *, string::iterator &);
15
22 virtual bool transcribe(multimap<char, Rule> & rules);
23 public:
24 D0LSystem( AbstractFile * );
25
32 static bool isCapable( unsigned int type )
33 {
34 if( ( type & capabilities ) == type )
35 return true;
36 else
37 return false;
38 }
39
43 boost::shared_ptr<AbstractLSystem> clone() const
44 {
45 return boost::shared_ptr<AbstractLSystem>( new D0LSystem(*this) );
46 }
47 };
48 }
49
50 #endif // D0LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/erf.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
erf.h
Go to the documentation of this file.
1 //%Header {
2 /*****************************************************************************
3 *
4 * File: src/MushRuby/missing/erf.c (ruby)
5 *
6 * This file has been taken the ruby distribution and may have been modified.
7 * For more information on the original see http://www.ruby-lang.org/.
8 *
9 * This file may contain original work and modifications by Andy Southgate.
10 * In regard to these the author and his employer (Mushware Limited)
11 * irrevocably waive all of their copyright rights vested in this particular
12 * version of this file to the furthest extent permitted. The author and
13 * Mushware Limited also irrevocably waive any and all of their intellectual
14 * property rights arising from said file and its modification and/or additions
15 * that would otherwise restrict the rights of any party to use and/or
16 * distribute the use of, the techniques and methods used herein. A written
17 * waiver can be obtained via http://www.mushware.com/. This waiver does not
18 * affect the rights of the original author or authors.
19 *
20 * This software carries NO WARRANTY of any kind from Andy Southgate or
21 * Mushware Limited.
22 *
23 ****************************************************************************/
24
25 double erf(double x);
26
27 double erfc(double x);
28
29 static double p_gamma(double a, double x, double loggamma_a);
30
31 static double q_gamma(double a, double x, double loggamma_a);
32
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fdtDataGlove.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
fdtDataGlove.h
Go to the documentation of this file.
1 /***************************************************************************
2 fdtdataglove.h - description
3 -------------------
4 begin : Mon Jun 3 2002
5 copyright : (C) 2002 by Jan Flasar, Ludek Pokluda
6 email : flasar|xpokluda|markovic@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef FDTDATAGLOVE_H
19 #define FDTDATAGLOVE_H
20
21 #include <vrecko/Device.h>
22
23 #include <map>
24
25
26 namespace vreckoDP_base {
27
28 class DP_EXPORT fdtDataGlove: public vrecko::Device {
29 public:
30 fdtDataGlove();
31 fdtDataGlove(char *port);
32 ~fdtDataGlove();
33
34 virtual int openDevice(void);
35 int closeDevice(void);
36 int calibrateDevice(void);
37
38 void update(void) {scanDevice();}
39 int *getSignal(void);
40
41 int getActualValue(float *p_actual_value);
42 void freezeRotation(bool new_freezeR);
43 void freezeFingerSensor(int id_FS, bool new_freezeFS);
44 int getFingerDirection(int id_finger, float *p_finger_direction);
45 int getRotate(float *p_rotate);
46
47 void setSignalType(int _signal_id, int _type) {_signal_type_table[_signal_id] = _type;}
48
49 protected:
50 char *hand_type;
51 int num_sensors;
52 bool freeze_rotation, freeze_finger_sensor[1+18];
53 float finger_direction[5][6];
54 float *actual_sensor_values;
55
56 std::map<int, int> _signal_type_table;
57 int _last_signal;
58
59 int scanDevice(void);
60 };
61
62 }
63
64 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/fsPinchGlove.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
fsPinchGlove.h
Go to the documentation of this file.
1 /***************************************************************************
2 fspinchglove.h - description
3 -------------------
4 begin : Mon Jun 3 2002
5 copyright : (C) 2002 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9 /***************************************************************************
10 * *
11 * This program is free software; you can redistribute it and/or modify *
12 * it under the terms of the GNU General Public License as published by *
13 * the Free Software Foundation; either version 2 of the License, or *
14 * (at your option) any later version. *
15 * *
16 ***************************************************************************/
17
18 #ifndef FSPINCHGLOVE_H
19 #define FSPINCHGLOVE_H
20
21 #include <map>
22 #include <iostream>
23
24 #if defined(WIN32)
25 #include <windows.h>
26 #endif
27
28 #include <vrecko/Device.h>
29 #include <vrecko/IOPins.h>
30
31 namespace vreckoDP_base {
32
33
34 #define STARTBYTE (char)0x80 /* Start - hand data only */
35 #define STARTTBYTE (char)0x81 /* Start - hand data & Time stamps */
36 #define STARTXBYTE (char)0x82 /* Start - text or ACK */
37 #define ENDBYTE (char)0x8F /* End of a message */
38
39 #define CONNECTBYTE (char)0x87 /* Opent the connection */
40 #define CLOSEBYTE (char)0x88 /* Close the connection */
41 #define DEF_PGI_PORT 6666 /* Default TCP port */
42 #define DEF_PGI_SERIAL "/dev/ttyS1" /* Default serial port */
43
44 #define PGI_MAX_PACKET_LEN 14
45
46 /* gesture masks */
47 /*#define L_THUMB (int)0x1000
48 #define L_INDEX (int)0x0800
49 #define L_MIDDLE (int)0x0400
50 #define L_RING (int)0x0200
51 #define L_PINKIE (int)0x0100*/
52
53 #define L_THUMB (int)0x0010
54 #define L_INDEX (int)0x0008
55 #define L_MIDDLE (int)0x0004
56 #define L_RING (int)0x0002
57 #define L_PINKIE (int)0x0001
58
59 #define R_THUMB (int)0x0010
60 #define R_INDEX (int)0x0008
61 #define R_MIDDLE (int)0x0004
62 #define R_RING (int)0x0002
63 #define R_PINKIE (int)0x0001
64
65 #define OK 1
66 #define ERR -1
67 #define YES 1
68 #define NO 0
69
70 #define if_ok( param ) if( ( param ) == OK )
71 #define if_notok( param) if( ( param ) != OK )
72 #define if_err( param ) if( ( param ) < 0 )
73 #define if_null( param ) if( ( param ) == NULL )
74 #define if_nonull( param ) if( ( param ) != NULL )
75
76 typedef struct {
77 int (*callback) (void*);
78 void *data;
79 } dataT;
80
81
82 class DP_EXPORT fsPinchGlove : public vrecko::Device {
83 public:
84 fsPinchGlove();
85 fsPinchGlove(const char *port_name);
86 ~fsPinchGlove();
87
88 virtual int openDevice(void);
89 int closeDevice(void);
90
91 void update(void);
92
93 int initPort(char *port);
94 int *getGesture(void);
95 void setGestureFunc(int (*func) (void*), void *g_object, int t1,
96 int t2 = 0, int t3 = 0, int t4 = 0, int t5 = 0);
97 int activateGesture(int t1, int t2 = 0, int t3 = 0, int t4 = 0, int t5 = 0);
98 int deactivateGesture(int t1, int t2 = 0, int t3 = 0, int t4 = 0, int t5 = 0);
99 int checkGesture(void);
100
101 int disableTS(void);
102 int enableTS(void);
103 void setReleaseFunc(int (*func) (void*), void *data);
104 void printConf(void);
105 void printGests(void);
106
107 protected:
108 int port_fd;
109 bool gestureOn;
110 std::map<std::string, dataT*> callbacks;
111 std::map<std::string, int> _signal_transf_table;
112 std::map<std::string, int> _signal_type_table;
113 int _current_type, _signal_backup;
114 dataT relCall;
115 char bufx[2*PGI_MAX_PACKET_LEN];
116 char bufxe[5][3];
117 std::map<std::string, int> _active_contact;
118 int _contact_count;
119 float ticks;
120 int (*relFunc) (void);
121
122 int _signal[10], _signal_count;
123
124 int checkBox(void);
125 void pgd_close(void);
126 int getByte(char *buf);
127 int getPacket(char *buf);
128 int pgdRead(char *buf, int n);
129 int pgdComm(const char buf[2], char *reply);
130
131
132 int getData( char *buf, int len, int *time_st );
133 int checkConnection(void);
134 void printBuf( const char *buf, int length );
135 void delay(int msec);
136
137 private:
138 void invNulls(char *buf, int length);
139 void swapBytes( int &num );
140 int getTicks();
141 int setToVersion1();
142
143 #if defined(WIN32)
144 HANDLE hCom; // handle for COM port
145 #endif
146
147 DECLARE_OUTPUT(Contact, vrecko::MessageString);
148 };
149
150 }
151
152 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/functions.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
functions.h
Go to the documentation of this file.
1 #ifndef FUNCTIONS_H
2 #define FUNCTIONS_H
3
4 //#include <vrecko/EnvironmentObject.h>
5 //#include <vrecko/PluginManager.h>
6 #include <vrecko/EventDispatcher.h>
7 //#include <osgDB/ReadFile>
8 #include <osg/Geometry>
9
10 using namespace osg;
11 using namespace vrecko;
12
13
15 //GET DATA OF ENVIRONMENT OBJECT
16
17 //*******************
18 //get geode of node graf
19 osg::Geode* getGeodeOf(osg::Node *eo);
20
21 //*******************
22 //get geometry of node graf
23 osg::Geometry* getGeometryOf(osg::Node *eo);
24
25 //*******************
26 //get vertices
27 osg::Vec3Array* getVerticesOf(osg::Node *eo);
28
29 //*******************
30 //get normals
31 osg::Vec3Array* getNormalsOf(osg::Node *eo);
32
33 //*******************
34 //get faces
35 DrawElementsUShort* getFacesOf(osg::Node *eo);
36
37
38
39
40
42 //PRINT MESSAGES
43
44 //print message and time
45 void printMessageTime(string str, float time);
46
47 //print text message only
48 void printMessage(string str);
49
50 //print text message and number
51 void printMessage(string str, float number);
52
53 //print error text message only
54 void printErrorMessage(string str);
55
56
57
58
59
61 //ADD OBJECT TO SCENE
62 //to show some object like cut or debugging
63
64 //add lines into scene
65 bool addLinesToScene(map<int, int> lines, Vec3Array *sourceVertices, Vec3Array *targetVertices, EnvironmentObject *eoParent);
66
67 //add lines to scene
68 bool addLinesToScene(vector<int> lines, Vec3Array *vertices, EnvironmentObject *eoParent, int color, std::string name);
69
70 //add lines to environment object
71 bool addLinesToEo(vector<int> lines, Vec3Array *vertices, EnvironmentObject *eo, int color, std::string name);
72
73 //add object created from specified points of given object
74 bool addMeshToScene(vector<int> boundaryLoop, EnvironmentObject *eoLoop);
75 bool addMeshToScene(vector<int> boundaryLoop, EnvironmentObject *eoLoop, int color);
76 bool addMeshToScene(vector<int> boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent);
77 bool addMeshToScene(vector<int> boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color);
78 bool addMeshToScene(vector<int> boundaryLoop, Vec3Array *vertices, EnvironmentObject *parent, int color, std::string name);
79
80 //add object to scene created from given points
81 bool addVerticesToScene(osg::Vec3Array* vertices, Group *parent);
82
83 //bool addPointToScene(osg::Vec3 point, EnvironmentObject *parentEnvironmentObject);
84 bool addPointToScene(osg::Vec3 point, osg::Group *parentEnvironmentObject);
85
86 //the same functiuon but rotation 90 added
87 bool addPointToScene90(osg::Vec3 point, osg::Group *parentEnvironmentObject);
88
89
90
91
92
93
95 //MATRIX, QUATERNION AND OTHER MATH FUNCTIONS
96
97 //udela trace(stopu) od matice
98 float matrixTrace3x3(float matrix[3][3]);
99
100 //we get matrix of rotation from 4 koeficients of quaternion of rotaion
101 bool getMatrixOfRotation(float q[7], float R[4][4]);
102
103 //we get matrix of rotation from 4 koeficients of quaternion of rotaion - to osg::Matrix
104 bool getMatrixOfRotation(float q[7], osg::Matrix &m);
105
106 //transpose matrix of size 4x4
107 void matrixTranspose4x4(float m[4][4], float mt[4][4]);
108
109 //Normalize quaternion
110 void quaternionNormalize(float q[7], float qNormalized[7]);
111
112 //Length of quaternion - used for normalizing quaternion
113 float quaternionLength(float q[7]);
114
115 //get matrix of source and target object and combine them to apply on target/source object to get same position in case of merge (matrix is id)
116 bool getMergeMatrix(EnvironmentObject *targetEo, EnvironmentObject *sourceEo, osg::Matrix& matrix);
117
118
119
120
121
122
123
125 //DISTANCE AND CLOSEST POINT
126
127 //find out closest point to given point on line
128 osg::Vec3 findClosestPointOnLine(osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB);
129
130 //euclidean distance of point and face construct of triangles threre points abc
131 osg::Vec3 findClosestPointOnFace(osg::Vec3 point, osg::Vec3 pointA, osg::Vec3 pointB, osg::Vec3 pointC, bool &onFace);
132
133 //euclidean distance of two points
134 float p2pEuclideanDistance(osg::Vec3 point1, osg::Vec3 point2);
135
136 //find closest point - snapping region to snapping region
137 vector<int> findClosestPoint(vector<int> snappingRegion, Vec3Array *points, vector<int> browsingSnappingRegion, Vec3Array *browsingPoints);
138 vector<int> findClosestPointNorm(vector<int> boundarySnappingRegion, Vec3Array *boundaryPoints, Vec3Array *boundaryNormals, vector<int> browsingSnappingRegion, Vec3Array *browsingPoints, Vec3Array *browsingNormals);
139
140
141
142
143
144
146 //OTHER FUNCTIONS
147
148 //find out if face is in faces
149 bool includeFace(unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *vertices);
150
151 //erase face from faces
152 bool eraseFace(unsigned long pointA, unsigned long pointB, unsigned long pointC, osg::DrawElementsUShort *faces);
153
154 //get center of mass of given points
155 osg::Vec3 centerOfMass(osg::Vec3Array* points);
156
157 //center of mass of given area of given points
158 osg::Vec3 centerOfMass(osg::Vec3Array* points, vector<int> area);
159
160 //normals variance
161 float normalsVariance(osg::Vec3 n1, osg::Vec3 n2);
162
163
164
165 #endif
166
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gesture.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gesture.h
Go to the documentation of this file.
1 /* gesture - list of mvectors
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.2 22.11.2002
4 */
5
6
7 /*
8 * SPoint - starting position of gesture
9 * RVect - relative vector (it's used for translation to SPoint position
10 */
11
12
13 #ifndef _GESTURE_
14 #define _GESTURE_
15
16 #include <vector>
17
18 #include "mvect.h"
19
20 namespace mv{
21
22 class CGesture{
23 public:
24 CMVect RVect; //relative vector
25 std::vector<CMVect *> Vectors;
26 //std::vector<Point *> Points;
27 // CPoint SPoint; //starting position of gesture
28 gmVector3 SPoint; //starting position of gesture
29 bool Movable; //if SPoint is not absolute = TRUE;
30 double WTime; //wait time (in seconds) before gesture is played (if in forward direction)
31 public:
32
33
34 CGesture();
35 CGesture(const CGesture &othergesture);
36 ~CGesture();
37
38 void addVectOnEnd(CMVect *newmvect);
39 void delVectOnEnd();
40 void delAllVect();
41
42 void setSPoint(gmVector3 newpoint) {SPoint = newpoint;};
43 gmVector3 getSPoint() {return SPoint;};
44
45 void setMovable(bool val) {Movable = val;};
46 bool getMovable() {return Movable;};
47
48 void setWTime(double newwtime) {WTime = newwtime;};
49 double getWTime() {return WTime;};
50 };
51
52 }
53
54 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm.h
Go to the documentation of this file.
1 // gm.h - library header
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_H
12 #define GM_H
13
14 #include <gm_bool.h>
15 #include <gm_const.h>
16 #include <gm_utils.h>
17 #include <gm_vec2.h>
18 #include <gm_vec3.h>
19 #include <gm_vec4.h>
20 #include <gm_mat3.h>
21 #include <gm_mat4.h>
22
23 #endif
24
25
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_bool.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_bool.h
Go to the documentation of this file.
1 // bool.h - boolean type
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_BOOL_H
12 #define GM_BOOL_H
13
14
15 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_const.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_const.h
Go to the documentation of this file.
1 // gmConst.h - graphics math constants
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_CONST_H
12 #define GM_CONST_H
13
14 // USEFUL CONSTANTS
15
16 double const gm2PI = 6.28318530717958623200;
17 double const gmDEGTORAD = 0.01745329251994329547;
18 double const gmE = 2.71828182845904553488;
19 double const gmEEXPPI = 23.14069263277927390732;
20 double const gmGOLDEN = 1.61803398874989490253;
21 double const gmINVPI = 0.31830988618379069122;
22 double const gmLN10 = 2.30258509299404590109;
23 double const gmLN2 = 0.69314718055994528623;
24 double const gmLOG10E = 0.43429448190325187218;
25 double const gmLOG2E = 1.44269504088896338700;
26 double const gmPI = 3.14159265358979323846;
27 double const gmPIDIV2 = 1.57079632679489655800;
28 double const gmPIDIV4 = 0.78539816339744827900;
29 double const gmRADTODEG = 57.29577951308232286465;
30 double const gmSQRT2 = 1.41421356237309514547;
31 double const gmSQRT2PI = 2.50662827463100024161;
32 double const gmSQRT3 = 1.73205080756887719318;
33 double const gmSQRT10 = 3.16227766016837952279;
34 double const gmSQRTE = 1.64872127070012819416;
35 double const gmSQRTHALF = 0.70710678118654757274;
36 double const gmSQRTLN2 = 0.83255461115769768821;
37 double const gmSQRTPI = 1.77245385090551588192;
38 double const gmEPSILON = 1.0e-10;
39 double const gmGOOGOL = 1.0e50;
40
41 #endif
42
43
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat3.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_mat3.h
Go to the documentation of this file.
1 // gmMatrix3.h - 3x3 element matrix class
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_MATRIX3_H
12 #define GM_MATRIX3_H
13
14 #include <stdio.h>
15 #include <stdlib.h>
16 #include <assert.h>
17 #include <gm_utils.h>
18
19 using namespace std;
20
21 class gmVector2;
22 class gmVector3;
23
24 class gmMatrix3 {
25
26 protected:
27 double m_[3][3];
28
29 public:
30 gmMatrix3();
31 gmMatrix3(const gmMatrix3&);
32 gmMatrix3(double, double, double,
33 double, double, double,
34 double, double, double);
35
36 // array access
37
38 double* operator [](int);
39 const double* operator [](int) const;
40
41 // assignment
42
43 gmMatrix3& assign(double, double, double,
44 double, double, double,
45 double, double, double);
46 gmMatrix3& operator =(const gmMatrix3&);
47
48 // operators
49
50 gmMatrix3& operator +=(const gmMatrix3&);
51 gmMatrix3& operator -=(const gmMatrix3&);
52 gmMatrix3& operator *=(const gmMatrix3&);
53 gmMatrix3& operator *=(double);
54 gmMatrix3& operator /=(double);
55
56 gmMatrix3 operator +(const gmMatrix3&) const;
57 gmMatrix3 operator -(const gmMatrix3&) const;
58 gmMatrix3 operator -() const;
59 gmMatrix3 operator *(const gmMatrix3&) const;
60 gmMatrix3 operator *(double) const;
61 gmMatrix3 operator /(double) const;
62
63 friend gmMatrix3 operator *(double, const gmMatrix3&);
64
65 bool operator ==(const gmMatrix3&) const;
66 bool operator !=(const gmMatrix3&) const;
67
68 gmVector3 operator *(const gmVector3&) const;
69
70 friend gmVector3 operator *(const gmVector3&, const gmMatrix3&);
71
72 // output
73
74 friend ostream & operator << ( ostream &, const gmMatrix3&);
75
76 // operations
77
78 gmMatrix3 inverse() const;
79 gmMatrix3 transpose() const;
80 gmMatrix3 adjoint() const;
81
82 double determinant() const;
83 bool isSingular() const;
84
85 gmVector2 transform(const gmVector2&) const;
86
87 void copyTo(float [3][3]) const;
88 void copyTo(double [3][3]) const;
89
90 // transformation matrices
91
92 static gmMatrix3 identity();
93 static gmMatrix3 scale(double, double);
94 static gmMatrix3 translate(double, double);
95 static gmMatrix3 rotate(double);
96 static gmMatrix3 arb_rotate(gmVector3&, double); // arbitrary axis rotation matrix
97 };
98
99 // ARRAY ACCESS
100
101 inline double* gmMatrix3::operator [](int i)
102 {
103 assert(i == 0 || i == 1 || i == 2 || i == 3);
104 return &m_[i][0];
105 }
106
107 inline const double* gmMatrix3::operator [](int i) const
108 {
109 assert(i == 0 || i == 1 || i == 2 || i == 3);
110 return &m_[i][0];
111 }
112
113 inline void gmMatrix3::copyTo(float f[3][3]) const
114 {
115 f[0][0] = m_[0][0]; f[0][1] = m_[0][1]; f[0][2] = m_[0][2];
116 f[1][0] = m_[1][0]; f[1][1] = m_[1][1]; f[1][2] = m_[1][2];
117 f[2][0] = m_[2][0]; f[2][1] = m_[2][1]; f[2][2] = m_[2][2];
118 }
119
120 inline void gmMatrix3::copyTo(double f[3][3]) const
121 {
122 f[0][0] = m_[0][0]; f[0][1] = m_[0][1]; f[0][2] = m_[0][2];
123 f[1][0] = m_[1][0]; f[1][1] = m_[1][1]; f[1][2] = m_[1][2];
124 f[2][0] = m_[2][0]; f[2][1] = m_[2][1]; f[2][2] = m_[2][2];
125 }
126
127 #endif
128
129
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_mat4.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_mat4.h
Go to the documentation of this file.
1 // gmMatrix4.h - 4x4 element matrix class
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_MATRIX4_H
12 #define GM_MATRIX4_H
13
14 #include <stdio.h>
15 #include <stdlib.h>
16 #include <assert.h>
17 #include <gm_utils.h>
18
19 using namespace std;
20
21 class gmVector3;
22 class gmVector4;
23
24 class gmMatrix4 {
25
26 protected:
27 double m_[4][4];
28
29 public:
30 gmMatrix4();
31 gmMatrix4(const gmMatrix4&);
32 gmMatrix4(double, double, double, double,
33 double, double, double, double,
34 double, double, double, double,
35 double, double, double, double);
36
37 // array access
38
39 double* operator [](int);
40 const double* operator [](int) const;
41
42 // assignment
43
44 gmMatrix4& assign(double, double, double, double,
45 double, double, double, double,
46 double, double, double, double,
47 double, double, double, double);
48 gmMatrix4& operator =(const gmMatrix4&);
49
50 // operators
51
52 gmMatrix4& operator +=(const gmMatrix4&);
53 gmMatrix4& operator -=(const gmMatrix4&);
54 gmMatrix4& operator *=(const gmMatrix4&);
55 gmMatrix4& operator *=(double);
56 gmMatrix4& operator /=(double);
57
58 gmMatrix4 operator +(const gmMatrix4&) const;
59 gmMatrix4 operator -(const gmMatrix4&) const;
60 gmMatrix4 operator -() const;
61 gmMatrix4 operator *(const gmMatrix4&) const;
62 gmMatrix4 operator *(double) const;
63 gmMatrix4 operator /(double) const;
64
65 friend gmMatrix4 operator *(double, const gmMatrix4&);
66
67 bool operator ==(const gmMatrix4&) const;
68 bool operator !=(const gmMatrix4&) const;
69
70 gmVector4 operator *(const gmVector4&) const;
71
72 friend gmVector4 operator *(const gmVector4&, const gmMatrix4&);
73
74 // mixed multiplying: vector3 = matrix4x4 * vector3 (double is for missing
75 // fourth vector element).
76 gmVector3 mixed_mult(gmVector3&, const double&);
77
78 // output
79
80 friend ostream & operator << (ostream &, const gmMatrix4&);
81
82 // operations
83
84 gmMatrix4 inverse() const;
85 gmMatrix4 transpose() const;
86 gmMatrix4 adjoint() const;
87
88 double determinant() const;
89 bool isSingular() const;
90
91 gmVector3 transform(const gmVector3&) const;
92
93 void copyTo(float [4][4]) const;
94 void copyTo(double [4][4]) const;
95
96 // transformation matrices
97
98 static gmMatrix4 identity();
99 static gmMatrix4 rotate(double, const gmVector3& axis);
100 static gmMatrix4 scale(double, double, double);
101 static gmMatrix4 translate(double, double, double);
102 static gmMatrix4 arb_rotate(gmVector3&, double); // arbitrary axis rotation matrix
103
104 // cubic basis matrices
105
106 static gmMatrix4 bezierBasis();
107 static gmMatrix4 bsplineBasis();
108 static gmMatrix4 catmullromBasis();
109 static gmMatrix4 hermiteBasis();
110
111 static gmMatrix4 tensedBSplineBasis(double);
112 static gmMatrix4 cardinalBasis(double);
113 static gmMatrix4 tauBasis(double, double);
114 static gmMatrix4 betaSplineBasis(double, double);
115
116 };
117
118 // ARRAY ACCESS
119
120 inline double* gmMatrix4::operator [](int i)
121 {
122 assert(i == 0 || i == 1 || i == 2 || i == 3);
123 return &m_[i][0];
124 }
125
126 inline const double* gmMatrix4::operator [](int i) const
127 {
128 assert(i == 0 || i == 1 || i == 2 || i == 3);
129 return &m_[i][0];
130 }
131
132 inline void gmMatrix4::copyTo(float f[4][4]) const
133 {
134 f[0][0] = m_[0][0]; f[0][1] = m_[0][1];
135 f[0][2] = m_[0][2]; f[0][3] = m_[0][3];
136 f[1][0] = m_[1][0]; f[1][1] = m_[1][1];
137 f[1][2] = m_[1][2]; f[1][3] = m_[1][3];
138 f[2][0] = m_[2][0]; f[2][1] = m_[2][1];
139 f[2][2] = m_[2][2]; f[2][3] = m_[2][3];
140 f[3][0] = m_[3][0]; f[3][1] = m_[3][1];
141 f[3][2] = m_[3][2]; f[3][3] = m_[3][3];
142 }
143
144 inline void gmMatrix4::copyTo(double f[4][4]) const
145 {
146 f[0][0] = m_[0][0]; f[0][1] = m_[0][1];
147 f[0][2] = m_[0][2]; f[0][3] = m_[0][3];
148 f[1][0] = m_[1][0]; f[1][1] = m_[1][1];
149 f[1][2] = m_[1][2]; f[1][3] = m_[1][3];
150 f[2][0] = m_[2][0]; f[2][1] = m_[2][1];
151 f[2][2] = m_[2][2]; f[2][3] = m_[2][3];
152 f[3][0] = m_[3][0]; f[3][1] = m_[3][1];
153 f[3][2] = m_[3][2]; f[3][3] = m_[3][3];
154 }
155
156 #endif // GMMATRIX4_H
157
158
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_utils.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_utils.h
Go to the documentation of this file.
1 // gmUtils.h - graphics math utility functions
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_UTILS_H
12 #define GM_UTILS_H
13
14 #ifdef WIN32
15 #pragma warning( disable : 4244 )
16 #endif
17
18 #include <iostream>
19 #include <math.h>
20 #include <gm_bool.h>
21 #include <gm_const.h>
22
23 // ONE-ARGUMENT UTILITY FUNCTIONS
24
25 inline double gmAbs(double f)
26 {
27 return (f >= 0) ? f : -f;
28 }
29
30 inline double gmCeil(double f)
31 {
32 return (f == int(f)) ? f : (f > 0) ? double(int(f) + 1) : double(int(f));
33 }
34
35 inline double gmCube(double f)
36 {
37 return f * f * f;
38 }
39
40 inline double gmDegrees(double f)
41 {
42 return f * gmRADTODEG;
43 }
44
45 inline double gmFloor(double f)
46 {
47 return (f == int(f)) ? f : (f > 0) ? double(int(f)) : double(int(f) - 1);
48 }
49
50 inline double gmInv(double f)
51 {
52 return 1.0 / f;
53 }
54
55 inline bool gmIsZero(double f)
56 {
57 return (gmAbs(f) < gmEPSILON);
58 }
59
60 inline double gmRadians(double f)
61 {
62 return f * gmDEGTORAD;
63 }
64
65 inline double gmRound(double f)
66 {
67 return (f >= 0) ? double(int(f + 0.5)) : double(- int(0.5 - f));
68 }
69
70 inline double gmSign(double f)
71 {
72 return (f < 0) ? -1.0 : 1.0;
73 }
74
75 inline double gmSmooth(double f)
76 {
77 return (3.0 - 2.0 * f) * f * f;
78 }
79
80 inline double gmSqr(double f)
81 {
82 return f * f;
83 }
84
85 inline double gmTrunc(double f)
86 {
87 return double(int(f));
88 }
89
90 inline double gmZSign(double f)
91 {
92 return (f > 0) ? 1.0 : (f < 0) ? -1.0 : 0.0;
93 }
94
95 // TWO-ARGUMENT UTILITY FUNCTIONS
96
97 inline bool gmFuzEQ(double f, double g)
98 {
99 return (f <= g) ? (f >= g - gmEPSILON) : (f <= g + gmEPSILON);
100 }
101
102 inline bool gmFuzGEQ(double f, double g)
103 {
104 return (f >= g - gmEPSILON);
105 }
106
107 inline bool gmFuzLEQ(double f, double g)
108 {
109 return (f <= g + gmEPSILON);
110 }
111
112 inline double gmMax(double f, double g)
113 {
114 return (f > g) ? f : g;
115 }
116
117 inline double gmMin(double f, double g)
118 {
119 return (f < g) ? f : g;
120 }
121
122 inline void gmSwap(double& f, double& g)
123 {
124 double gmTmp = f; f = g; g = gmTmp;
125 }
126
127 inline void gmSwap(int& i, int& j)
128 {
129 int gmTmp = i; i = j; j = gmTmp;
130 }
131
132 // MULTI-ARGUMENT UTILITY FUNCTIONS
133
134 inline void gmClamp(double &f, double l, double h)
135 {
136 if(f < l) f = l;
137 if(f > h) f = h;
138 }
139
140 inline double gmLerp(double f, double l, double h)
141 {
142 return l + ((h - l) * f );
143 }
144
145 inline double gmMax(double f, double g, double h)
146 {
147 return (f > g) ? gmMax(f, h) : gmMax(g, h);
148 }
149
150 inline double gmMin(double f, double g, double h)
151 {
152 return (f < g) ? gmMin(f, h) : gmMin(g, h);
153 }
154
155 inline double gmSlide(double f, double l, double h)
156 {
157 return (f < 0) ? l : (f > 1) ? h : gmLerp(gmSmooth(f), l, h);
158 }
159
160 #endif
161
162
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec2.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_vec2.h
Go to the documentation of this file.
1 // gmVector2.h - 2 element vector class
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_VECTOR2_H
12 #define GM_VECTOR2_H
13
14 #include <stdio.h>
15 #include <stdlib.h>
16 #include <assert.h>
17 #include <gm_utils.h>
18
19 using namespace std;
20
21 class gmVector2 {
22
23 protected:
24 double v_[2];
25
26 public:
27 gmVector2();
28 gmVector2(const gmVector2&);
29 gmVector2(double, double);
30
31 // array access
32
33 double& operator [](int);
34 const double& operator [](int) const;
35
36 // assignment
37
38 gmVector2& assign(double, double);
39 gmVector2& operator =(const gmVector2&);
40
41 // math operators
42
43 gmVector2& operator +=(const gmVector2&);
44 gmVector2& operator -=(const gmVector2&);
45 gmVector2& operator *=(double);
46 gmVector2& operator /=(double);
47
48 gmVector2 operator +(const gmVector2&) const;
49 gmVector2 operator -(const gmVector2&) const;
50 gmVector2 operator -() const;
51 gmVector2 operator *(double) const;
52 gmVector2 operator /(double) const;
53
54 friend gmVector2 operator *(double, const gmVector2&);
55
56 bool operator ==(const gmVector2&) const;
57 bool operator !=(const gmVector2&) const;
58
59 // operations
60
61 gmVector2& clamp(double, double);
62 double length() const;
63 double lengthSquared() const;
64 gmVector2& normalize();
65
66 void copyTo(float [2]) const;
67 void copyTo(double [2]) const;
68
69 friend double distance(const gmVector2&, const gmVector2&);
70 friend double distanceSquared(const gmVector2&, const gmVector2&);
71 friend double dot(const gmVector2&, const gmVector2&);
72 friend gmVector2 lerp(double, const gmVector2&, const gmVector2&);
73
74 // output
75
76 friend ostream& operator << ( ostream &, const gmVector2 & );
77 };
78
79 // CONSTRUCTORS
80
81 inline gmVector2::gmVector2()
82 {
83 v_[0] = v_[1] = 0;
84 }
85
86 inline gmVector2::gmVector2(const gmVector2& v)
87 {
88 v_[0] = v.v_[0]; v_[1] = v.v_[1];
89 }
90
91 inline gmVector2::gmVector2(double x, double y)
92 {
93 v_[0] = x; v_[1] = y;
94 }
95
96 // ARRAY ACCESS
97
98 inline double& gmVector2::operator [](int i)
99 {
100 assert(i == 0 || i == 1);
101 return v_[i];
102 }
103
104 inline const double& gmVector2::operator [](int i) const
105 {
106 assert(i == 0 || i == 1);
107 return v_[i];
108 }
109
110 // ASSIGNMENT
111
112 inline gmVector2& gmVector2::assign(double x, double y)
113 {
114 v_[0] = x; v_[1] = y;
115 return *this;
116 }
117
118 inline gmVector2& gmVector2::operator =(const gmVector2& v)
119 {
120 v_[0] = v[0]; v_[1] = v[1];
121 return *this;
122 }
123
124 // MATH OPERATORS
125
126 inline gmVector2& gmVector2::operator +=(const gmVector2& v)
127 {
128 v_[0] += v[0]; v_[1] += v[1];
129 return *this;
130 }
131
132 inline gmVector2& gmVector2::operator -=(const gmVector2& v)
133 {
134 v_[0] -= v[0]; v_[1] -= v[1];
135 return *this;
136 }
137
138 inline gmVector2& gmVector2::operator *=(double c)
139 {
140 v_[0] *= c; v_[1] *= c;
141 return *this;
142 }
143
144 inline gmVector2& gmVector2::operator /=(double c)
145 {
146 assert(!gmIsZero(c));
147 v_[0] /= c; v_[1] /= c;
148 return *this;
149 }
150
151 inline gmVector2 gmVector2::operator +(const gmVector2& v) const
152 {
153 return gmVector2(v_[0] + v[0], v_[1] + v[1]);
154 }
155
156 inline gmVector2 gmVector2::operator -(const gmVector2& v) const
157 {
158 return gmVector2(v_[0] - v[0], v_[1] - v[1]);
159 }
160
161 inline gmVector2 gmVector2::operator -() const
162 {
163 return gmVector2(-v_[0], -v_[1]);
164 }
165
166 inline gmVector2 gmVector2::operator *(double c) const
167 {
168 return gmVector2(v_[0] * c, v_[1] * c);
169 }
170
171 inline gmVector2 gmVector2::operator /(double c) const
172 {
173 assert(!gmIsZero(c));
174 return gmVector2(v_[0] / c, v_[1] / c);
175 }
176
177 inline gmVector2 operator *(double c, const gmVector2& v)
178 {
179 return gmVector2(c * v[0], c * v[1]);
180 }
181
182 inline bool gmVector2::operator ==(const gmVector2& v) const
183 {
184 return (gmFuzEQ(v_[0], v[0]) && gmFuzEQ(v_[1], v[1]));
185 }
186
187 inline bool gmVector2::operator !=(const gmVector2& v) const
188 {
189 return (!(*this == v));
190 }
191
192 // OPERATIONS
193
194 inline gmVector2& gmVector2::clamp(double lo, double hi)
195 {
196 gmClamp(v_[0], lo, hi); gmClamp(v_[1], lo, hi);
197 return *this;
198 }
199
200 inline double gmVector2::length() const
201 {
202 return sqrt(gmSqr(v_[0]) + gmSqr(v_[1]));
203 }
204
205 inline double gmVector2::lengthSquared() const
206 {
207 return gmSqr(v_[0]) + gmSqr(v_[1]);
208 }
209
210 inline gmVector2& gmVector2::normalize()
211 {
212 double len = length();
213 assert(!gmIsZero(len));
214 *this /= len;
215 return *this;
216 }
217
218 inline void gmVector2::copyTo(float f[2]) const
219 {
220 f[0] = v_[0]; f[1] = v_[1];
221 }
222
223 inline void gmVector2::copyTo(double f[2]) const
224 {
225 f[0] = v_[0]; f[1] = v_[1];
226 }
227
228 inline double distance(const gmVector2& v1, const gmVector2& v2)
229 {
230 return sqrt(gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]));
231 }
232
233 inline double distanceSquared(const gmVector2& v1, const gmVector2& v2)
234 {
235 return gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]);
236 }
237
238 inline double dot(const gmVector2& v1, const gmVector2& v2)
239 {
240 return v1[0] * v2[0] + v1[1] * v2[1];
241 }
242
243 inline gmVector2 lerp(double f, const gmVector2& v1, const gmVector2& v2)
244 {
245 return v1 + ((v2 - v1) * f);
246 }
247
248 // OUTPUT
249
250 inline ostream& operator<< ( ostream& os, const gmVector2& v)
251 {
252 os << "< " << v[0] << " " << v[1] << " >";
253 return os;
254 }
255
256 #endif
257
258
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec3.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_vec3.h
Go to the documentation of this file.
1 // gmVector3.h - 3 element vector class
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_VECTOR3_H
12 #define GM_VECTOR3_H
13
14 #include <stdio.h>
15 #include <stdlib.h>
16 #include <assert.h>
17 #include <gm_utils.h>
18 #include <iostream>
19
20 using namespace std;
21
22 class gmVector3 {
23
24 protected:
25 double v_[3];
26
27 public:
28 gmVector3();
29 gmVector3(const gmVector3&);
30 gmVector3(double, double, double);
31
32 // array access
33
34 double& operator [](int);
35 const double& operator [](int) const;
36
37 // assignment
38
39 gmVector3& assign(double, double, double);
40 gmVector3& operator =(const gmVector3&);
41
42 // math operators
43
44 gmVector3& operator +=(const gmVector3&);
45 gmVector3& operator -=(const gmVector3&);
46 gmVector3& operator *=(double);
47 gmVector3& operator /=(double);
48
49 gmVector3 operator +(const gmVector3&) const;
50 gmVector3 operator -(const gmVector3&) const;
51 gmVector3 operator -() const;
52 gmVector3 operator *(double) const;
53 gmVector3 operator /(double) const;
54
55 friend gmVector3 operator *(double, const gmVector3&);
56
57 bool operator ==(const gmVector3&) const;
58 bool operator !=(const gmVector3&) const;
59
60 // operations
61
62 gmVector3& clamp(double, double);
63 double length() const;
64 double lengthSquared() const;
65 gmVector3& normalize();
66 bool isZero();
67
68 void copyTo(float [3]) const;
69 void copyTo(double [3]) const;
70 void float2double(const float *v);
71 void double2float(const double *v);
72
73 friend gmVector3 cross(const gmVector3&, const gmVector3&);
74 friend double distance(const gmVector3&, const gmVector3&);
75 friend double distanceSquared(const gmVector3&, const gmVector3&);
76 friend double dot(const gmVector3&, const gmVector3&);
77 friend gmVector3 lerp(double, const gmVector3&, const gmVector3&);
78
79 // useful functions
80
81 friend double plane_intersect(const gmVector3&, const gmVector3&,
82 const gmVector3&, const gmVector3&);
83 friend double line_distance(const gmVector3&, const gmVector3&,
84 const gmVector3&, const gmVector3&);
85 friend double plane_distance(const gmVector3&, const gmVector3&, const gmVector3&);
86
87 // todo
88 //
89 //friend cos_angle();
90 //friend angle(); // return angle of two vectors
91
92 // output
93
94 friend ostream & operator << ( ostream &, const gmVector3 & );
95 };
96
97 // CONSTRUCTORS
98
99 inline gmVector3::gmVector3()
100 {
101 v_[0] = v_[1] = v_[2] = 0;
102 }
103
104 inline gmVector3::gmVector3(const gmVector3& v)
105 {
106 v_[0] = v.v_[0]; v_[1] = v.v_[1]; v_[2] = v.v_[2];
107 }
108
109 inline gmVector3::gmVector3(double x, double y, double z)
110 {
111 v_[0] = x; v_[1] = y; v_[2] = z;
112 }
113
114 // ARRAY ACCESS
115
116 inline double& gmVector3::operator [](int i)
117 {
118 assert(i == 0 || i == 1 || i == 2);
119 return v_[i];
120 }
121
122 inline const double& gmVector3::operator [](int i) const
123 {
124 assert(i == 0 || i == 1 || i == 2);
125 return v_[i];
126 }
127
128 // ASSIGNMENT
129
130 inline gmVector3& gmVector3::assign(double x, double y, double z)
131 {
132 v_[0] = x; v_[1] = y; v_[2] = z;
133 return *this;
134 }
135
136 inline gmVector3& gmVector3::operator =(const gmVector3& v)
137 {
138 v_[0] = v[0]; v_[1] = v[1]; v_[2] = v[2];
139 return *this;
140 }
141
142 // MATH OPERATORS
143
144 inline gmVector3& gmVector3::operator +=(const gmVector3& v)
145 {
146 v_[0] += v[0]; v_[1] += v[1]; v_[2] += v[2];
147 return *this;
148 }
149
150 inline gmVector3& gmVector3::operator -=(const gmVector3& v)
151 {
152 v_[0] -= v[0]; v_[1] -= v[1]; v_[2] -= v[2];
153 return *this;
154 }
155
156 inline gmVector3& gmVector3::operator *=(double c)
157 {
158 v_[0] *= c; v_[1] *= c; v_[2] *= c;
159 return *this;
160 }
161
162 inline gmVector3& gmVector3::operator /=(double c)
163 {
164 assert(!gmIsZero(c));
165 v_[0] /= c; v_[1] /= c; v_[2] /= c;
166 return *this;
167 }
168
169 inline gmVector3 gmVector3::operator +(const gmVector3& v) const
170 {
171 return gmVector3(v_[0] + v[0], v_[1] + v[1], v_[2] + v[2]);
172 }
173
174 inline gmVector3 gmVector3::operator -(const gmVector3& v) const
175 {
176 return gmVector3(v_[0] - v[0], v_[1] - v[1], v_[2] - v[2]);
177 }
178
179 inline gmVector3 gmVector3::operator -() const
180 {
181 return gmVector3(-v_[0], -v_[1], -v_[2]);
182 }
183
184 inline gmVector3 gmVector3::operator *(double c) const
185 {
186 return gmVector3(v_[0] * c, v_[1] * c, v_[2] * c);
187 }
188
189 inline gmVector3 gmVector3::operator /(double c) const
190 {
191 assert(!gmIsZero(c));
192 return gmVector3(v_[0] / c, v_[1] / c, v_[2] / c);
193 }
194
195 inline gmVector3 operator *(double c, const gmVector3& v)
196 {
197 return gmVector3(c * v[0], c * v[1], c * v[2]);
198 }
199
200 inline bool gmVector3::operator ==(const gmVector3& v) const
201 {
202 return
203 (gmFuzEQ(v_[0], v[0]) && gmFuzEQ(v_[1], v[1]) && gmFuzEQ(v_[2], v[2]));
204 }
205
206 inline bool gmVector3::operator !=(const gmVector3& v) const
207 {
208 return (!(*this == v));
209 }
210
211 // OPERATIONS
212
213 inline gmVector3& gmVector3::clamp(double lo, double hi)
214 {
215 gmClamp(v_[0], lo, hi); gmClamp(v_[1], lo, hi); gmClamp(v_[2], lo, hi);
216 return *this;
217 }
218
219 inline double gmVector3::length() const
220 {
221 return sqrt(gmSqr(v_[0]) + gmSqr(v_[1]) + gmSqr(v_[2]));
222 }
223
224 inline double gmVector3::lengthSquared() const
225 {
226 return gmSqr(v_[0]) + gmSqr(v_[1]) + gmSqr(v_[2]);
227 }
228
229 inline gmVector3& gmVector3::normalize()
230 {
231 double len = length();
232 //assert(!gmIsZero(len));
233 if (!gmIsZero(len)) *this /= len;
234 return *this;
235 }
236
237 inline bool gmVector3::isZero()
238 {
239 return (gmIsZero(v_[0]) && gmIsZero(v_[1]) && gmIsZero(v_[2]));
240 }
241
242 inline void gmVector3::copyTo(float f[3]) const
243 {
244 f[0] = v_[0]; f[1] = v_[1]; f[2] = v_[2];
245 }
246
247 inline void gmVector3::copyTo(double f[3]) const
248 {
249 f[0] = v_[0]; f[1] = v_[1]; f[2] = v_[2];
250 }
251
252 inline void gmVector3::float2double(const float *v)
253 {
254 v_[0] = (double) v[0];
255 v_[1] = (double) v[1];
256 v_[2] = (double) v[2];
257 }
258
259 inline void gmVector3::double2float(const double *v)
260 {
261 // fit it to gl_lib!!!
262 //
263 // X(dest) = (float) X(v);
264 // Y(dest) = (float) Y(v);
265 // Z(dest) = (float) Z(v);
266 //
267 // return dest;
268 }
269
270 inline gmVector3 cross(const gmVector3& v1, const gmVector3& v2)
271 {
272 return gmVector3(v1[1] * v2[2] - v1[2] * v2[1],
273 v1[2] * v2[0] - v1[0] * v2[2],
274 v1[0] * v2[1] - v1[1] * v2[0]);
275 }
276
277 inline double distance(const gmVector3& v1, const gmVector3& v2)
278 {
279 return
280 sqrt(gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]) + gmSqr(v1[2] - v2[2]));
281 }
282
283 inline double distanceSquared(const gmVector3& v1, const gmVector3& v2)
284 {
285 return gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]) + gmSqr(v1[2] - v2[2]);
286 }
287
288 inline double dot(const gmVector3& v1, const gmVector3& v2)
289 {
290 return v1[0] * v2[0] + v1[1] * v2[1] + v1[2] * v2[2];
291 }
292
293 inline gmVector3 lerp(double f, const gmVector3& v1, const gmVector3& v2)
294 {
295 return v1 + ((v2 - v1) * f);
296 }
297
298 // intersection of line given with point "p" and vector "v" and plane given
299 // with point "plane_p" and normal "plane_norm". This function returns "k" so,
300 // that INTERSECTION = p + k * v
301 inline double plane_intersect(const gmVector3& p, const gmVector3& v,
302 const gmVector3& plane_p, const gmVector3& plane_norm)
303 {
304 double d;
305
306 d = dot(plane_norm, v);
307
308 if (d == 0) // "plane_norm" and "v" are mutually parallel
309 return gmGOOGOL;
310
311 gmVector3 tmp(plane_p);
312 tmp -= p;
313
314 return dot(plane_norm, tmp) / d;
315 }
316
317 inline double line_distance(const gmVector3& p1, const gmVector3& v1,
318 const gmVector3& p2, const gmVector3& v2)
319 {
320 gmVector3 norm = cross(v1, v2);
321
322 return plane_intersect(p1, norm, p2, norm);
323 }
324
325 // this function return "K" so that INTERSECTION = p + K * plane_norm =>
326 // we get an intersection "I" on the plane and from the vector | IK | we will
327 // determine distance of the point "p" to a plane.
328 inline double plane_distance(const gmVector3& p, const gmVector3& plane_p,
329 const gmVector3& plane_norm)
330 {
331 return plane_intersect(p, plane_norm, plane_p, plane_norm);
332 }
333
334 // OUTPUT
335
336 inline ostream & operator << ( ostream& os, const gmVector3& v)
337 {
338 os << "< " << v[0] << " " << v[1] << " " << v[2] << " >";
339 return os;
340 }
341
342 #endif
343
344
345
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/gm_vec4.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
gm_vec4.h
Go to the documentation of this file.
1 // gmVector4.h - 4 element vector class
2 //
3 // libgm++: Graphics Math Library
4 // Ferdi Scheepers and Stephen F May
5 // 15 June 1994
6 // ----------------------------------
7 // modified: October 2002
8 // Pavel Kolcarek, kolcarek@fi.muni.cz
9 //
10
11 #ifndef GM_VECTOR4_H
12 #define GM_VECTOR4_H
13
14 #include <stdio.h>
15 #include <stdlib.h>
16 #include <assert.h>
17 #include <gm_utils.h>
18
19 class gmVector4 {
20
21 protected:
22 double v_[4];
23
24 public:
25 gmVector4();
26 gmVector4(const gmVector4&);
27 gmVector4(double, double, double, double);
28
29 // array access
30
31 double& operator [](int);
32 const double& operator [](int) const;
33
34 // assignment
35
36 gmVector4& assign(double, double, double, double);
37 gmVector4& operator =(const gmVector4&);
38
39 // math operators
40
41 gmVector4& operator +=(const gmVector4&);
42 gmVector4& operator -=(const gmVector4&);
43 gmVector4& operator *=(double);
44 gmVector4& operator /=(double);
45
46 gmVector4 operator +(const gmVector4&) const;
47 gmVector4 operator -(const gmVector4&) const;
48 gmVector4 operator -() const;
49 gmVector4 operator *(double) const;
50 gmVector4 operator /(double) const;
51
52 friend gmVector4 operator *(double, const gmVector4&);
53
54 bool operator ==(const gmVector4&) const;
55 bool operator !=(const gmVector4&) const;
56
57 // operations
58
59 gmVector4& clamp(double, double);
60 double length() const;
61 double lengthSquared() const;
62 gmVector4& normalize();
63
64 void copyTo(float [4]) const;
65 void copyTo(double [4]) const;
66
67 friend double distance(const gmVector4&, const gmVector4&);
68 friend double distanceSquared(const gmVector4&, const gmVector4&);
69 friend double dot(const gmVector4&, const gmVector4&);
70 friend gmVector4 lerp(double, const gmVector4&, const gmVector4&);
71
72 // output
73
74 friend ostream & operator << ( ostream &, const gmVector4 & );
75 };
76
77 // CONSTRUCTORS
78
79 inline gmVector4::gmVector4()
80 {
81 v_[0] = v_[1] = v_[2] = v_[3] = 0;
82 }
83
84 inline gmVector4::gmVector4(const gmVector4& v)
85 {
86 v_[0] = v.v_[0]; v_[1] = v.v_[1]; v_[2] = v.v_[2]; v_[3] = v.v_[3];
87 }
88
89 inline gmVector4::gmVector4(double x, double y, double z, double a)
90 {
91 v_[0] = x; v_[1] = y; v_[2] = z; v_[3] = a;
92 }
93
94 // ARRAY ACCESS
95
96 inline double& gmVector4::operator [](int i)
97 {
98 assert(i == 0 || i == 1 || i == 2 || i == 3);
99 return v_[i];
100 }
101
102 inline const double& gmVector4::operator [](int i) const
103 {
104 assert(i == 0 || i == 1 || i == 2 || i == 3);
105 return v_[i];
106 }
107
108 // ASSIGNMENT
109
110 inline gmVector4& gmVector4::assign(double x, double y, double z, double a)
111 {
112 v_[0] = x; v_[1] = y; v_[2] = z; v_[3] = a;
113 return *this;
114 }
115
116 inline gmVector4& gmVector4::operator =(const gmVector4& v)
117 {
118 v_[0] = v[0]; v_[1] = v[1]; v_[2] = v[2]; v_[3] = v[3];
119 return *this;
120 }
121
122 // MATH OPERATORS
123
124 inline gmVector4& gmVector4::operator +=(const gmVector4& v)
125 {
126 v_[0] += v[0]; v_[1] += v[1]; v_[2] += v[2]; v_[3] += v[3];
127 return *this;
128 }
129
130 inline gmVector4& gmVector4::operator -=(const gmVector4& v)
131 {
132 v_[0] -= v[0]; v_[1] -= v[1]; v_[2] -= v[2]; v_[3] -= v[3];
133 return *this;
134 }
135
136 inline gmVector4& gmVector4::operator *=(double c)
137 {
138 v_[0] *= c; v_[1] *= c; v_[2] *= c; v_[3] *= c;
139 return *this;
140 }
141
142 inline gmVector4& gmVector4::operator /=(double c)
143 {
144 assert(!gmIsZero(c));
145 v_[0] /= c; v_[1] /= c; v_[2] /= c; v_[3] /= c;
146 return *this;
147 }
148
149 inline gmVector4 gmVector4::operator +(const gmVector4& v) const
150 {
151 return gmVector4(v_[0] + v[0], v_[1] + v[1], v_[2] + v[2], v_[3] + v[3]);
152 }
153
154 inline gmVector4 gmVector4::operator -(const gmVector4& v) const
155 {
156 return gmVector4(v_[0] - v[0], v_[1] - v[1], v_[2] - v[2], v_[3] - v[3]);
157 }
158
159 inline gmVector4 gmVector4::operator -() const
160 {
161 return gmVector4(-v_[0], -v_[1], -v_[2], -v_[3]);
162 }
163
164 inline gmVector4 gmVector4::operator *(double c) const
165 {
166 return gmVector4(v_[0] * c, v_[1] * c, v_[2] * c, v_[3] * c);
167 }
168
169 inline gmVector4 gmVector4::operator /(double c) const
170 {
171 assert(!gmIsZero(c));
172 return gmVector4(v_[0] / c, v_[1] / c, v_[2] / c, v_[3] / c);
173 }
174
175 inline gmVector4 operator *(double c, const gmVector4& v)
176 {
177 return gmVector4(c * v[0], c * v[1], c * v[2], c * v[3]);
178 }
179
180 inline bool gmVector4::operator ==(const gmVector4& v) const
181 {
182 return (gmFuzEQ(v_[0], v[0]) && gmFuzEQ(v_[1], v[1]) &&
183 gmFuzEQ(v_[2], v[2]) && gmFuzEQ(v_[3], v[3]));
184 }
185
186 inline bool gmVector4::operator !=(const gmVector4& v) const
187 {
188 return (!(*this == v));
189 }
190
191 // OPERATIONS
192
193 inline gmVector4& gmVector4::clamp(double lo, double hi)
194 {
195 gmClamp(v_[0], lo, hi); gmClamp(v_[1], lo, hi);
196 gmClamp(v_[2], lo, hi); gmClamp(v_[3], lo, hi);
197 return *this;
198 }
199
200 inline double gmVector4::length() const
201 {
202 return sqrt(gmSqr(v_[0]) + gmSqr(v_[1]) + gmSqr(v_[2]) + gmSqr(v_[3]));
203 }
204
205 inline double gmVector4::lengthSquared() const
206 {
207 return gmSqr(v_[0]) + gmSqr(v_[1]) + gmSqr(v_[2]) + gmSqr(v_[3]);
208 }
209
210 inline gmVector4& gmVector4::normalize()
211 {
212 double len = length();
213 assert(!gmIsZero(len));
214 *this /= len;
215 return *this;
216 }
217
218 inline void gmVector4::copyTo(float f[4]) const
219 {
220 f[0] = v_[0]; f[1] = v_[1]; f[2] = v_[2]; f[3] = v_[3];
221 }
222
223 inline void gmVector4::copyTo(double f[4]) const
224 {
225 f[0] = v_[0]; f[1] = v_[1]; f[2] = v_[2]; f[3] = v_[3];
226 }
227
228 inline double distance(const gmVector4& v1, const gmVector4& v2)
229 {
230 return sqrt(gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]) +
231 gmSqr(v1[2] - v2[2]) + gmSqr(v1[3] - v2[3]));
232 }
233
234 inline double distanceSquared(const gmVector4& v1, const gmVector4& v2)
235 {
236 return gmSqr(v1[0] - v2[0]) + gmSqr(v1[1] - v2[1]) +
237 gmSqr(v1[2] - v2[2]) + gmSqr(v1[3] - v2[3]);
238 }
239
240 inline double dot(const gmVector4& v1, const gmVector4& v2)
241 {
242 return v1[0] * v2[0] + v1[1] * v2[1] + v1[2] * v2[2] + v1[3] * v2[3];
243 }
244
245 inline gmVector4 lerp(double f, const gmVector4& v1, const gmVector4& v2)
246 {
247 return v1 + ((v2 - v1) * f);
248 }
249
250 // OUTPUT
251
252 inline ostream & operator << ( ostream& os, const gmVector4& v)
253 {
254 os << "< " << v[0] << " " << v[1] << " " << v[2] << " " << v[3] << " >";
255 return os;
256 }
257
258 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass.h
Go to the documentation of this file.
1 #ifndef _GRASS_GRASS_H
2 #define _GRASS_GRASS_H
3
4 #include "grass_cullcallback.h"
5 #include "grass_parameters.h"
6 #include "grass_drawable.h"
7
8 #include <vrecko/Ability.h>
9 //#include <osg/TriangleFunctor>
10 #include <vrecko/EnvironmentObject.h>
11 //#include <osg/Vec3>
12
13 #include <gl/gl.h>
14
15 using namespace vrecko;
16 using namespace osg;
17
18 namespace grass
19 {
20
21
22
23 // Ability which covers nearly any object with grass-like coat.
24 class Grass : public vrecko::Ability
25 {
26 protected:
27 // create a grass-like mesh for all geometry in given Group
28 void CoatWithGrass(Group * pGroup);
29
30 // creates a grass Geometry for given Geode
31 //GrassDrawable * CreateGrassGeometry(const Geode * pGeode);
32
33 // holds all parameters of this ability
34 ref_ptr<GrassAbilityParameters> params;
35 public:
36 Grass() : Ability("Grass") {params = new GrassAbilityParameters;}
37
38 virtual ~Grass() {}
39 void update(void) {}
40 void postInitialize(void);
41 // std::string getAcceptableMessages(void) {return std::string("");}
42 // vrecko::Message *getMessage(void) {return NULL;}
43
44 // for loading of parameters, we can use method LoadParameters of structure GrassAbilityParameters
45 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode)
46 { return params->loadXMLParameters(parametersNode); }
47
48 // for saving parameters, we can use appropriate method of struct GrassAbilityParameters
49 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument * d)
50 { return params->saveXMLParameters(d); }
51 };
52
53
54
55
56 }; // end of namespace grass
57
58 #endif // _GRASS_GRASS_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_cullcallback.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_cullcallback.h
Go to the documentation of this file.
1 #ifndef GRASS_CULL_CALLBACK_H
2 #define GRASS_CULL_CALLBACK_H
3
4 #include <osgutil/CullVisitor>
5 using osgUtil::CullVisitor;
6
7 #include "grass_drawable.h"
8 #include <osg/Drawable>
9 using namespace osg;
10
11
12
13 namespace grass
14 {
15
16
17
18 // custom cullcallback for this class - sometimes we also need the cullvisitor to traverse
19 // the more detailed version of this piece of grass which is quite specific need, so we need
20 // to define our own CullCallback which will manage this all for us.
21 class GrassCullCallback : public Drawable::CullCallback
22 {
23 virtual bool cull(NodeVisitor* nv, Drawable* drawable, RenderInfo* renderInfo) const
24 {
25 GrassDrawable * gd = dynamic_cast< GrassDrawable *>(drawable);
26 CullVisitor * cv = dynamic_cast<CullVisitor *>(nv);
27 if(gd && cv)
28 gd->ManageCulling(cv, renderInfo);
29 return false;
30 }
31 };
32
33
34
35
36
37 }; // end of namespace grass
38
39
40 #endif // GRASS_CULL_CALLBACK_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_drawable.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_drawable.h
Go to the documentation of this file.
1 #ifndef _GRASS_GEOMETRY_H
2 #define _GRASS_GEOMETRY_H
3
4 #include <osg/Geometry>
5 #include <osg/Drawable>
6 #include <osg/Geode>
7 #include <osg/Vec3>
8 #include <vector>
9 #include <osg/matrix>
10
11 #include <osgutil/CullVisitor>
12
13 #include "grass_parameters.h"
14 #include "grass_mesh.h"
15
16
17 using namespace osg;
18
19 namespace grass
20 {
21
22
23
24
25 // Extends class Drawable. Adds some grass-ability-specific stuff like private
26 // display list or a pointer to a more detailed version of this Drawable.
27 class GrassDrawable : public Drawable
28 {
29 public:
30 // This extended cosntructor collects all triangles of given Geode and creates
31 // a grass-like mesh from them, so the original mesh of given Geode is covered with grass
32 GrassDrawable(Geode & g, GrassAbilityParameters * parameters);
33
34 // Default constructor creates emplty Drawable
35 GrassDrawable(Mesh * newMesh, GrassAbilityParameters * parameters);
36
37 // we will need to manage something prior to destroying this object
38 virtual ~GrassDrawable();
39
40 // some necessary stuff
41 GrassDrawable(const GrassDrawable& gd, const CopyOp& copyop = CopyOp::SHALLOW_COPY);
42 virtual Object* cloneType() const { return new GrassDrawable(*this); }
43 virtual Object* clone(const CopyOp& copyop) const { return new GrassDrawable(*this, copyop); }
44 virtual bool isSameKindAs(const Object* obj) const { return dynamic_cast<const GrassDrawable*>(obj) != NULL; }
45 virtual const char* libraryName() const { return "grass"; }
46 virtual const char* className() const { return "GrassDrawable"; }
47
48 // custom method which manages drawing of this object
49 virtual void drawImplementation(RenderInfo& renderInfo) const;
50
51 // this method is called by our friend - our private CullCallback and determines
52 // whether to draw this drawable or whether to draw its more detailed version etc.
53 void ManageCulling(osgUtil::CullVisitor * cv, RenderInfo* renderInfo);
54
55 // role of the object of this class
56 enum ROLE
57 {
58 TOP_LEVEL, // constins the original geometry - is drawn always (if visible, of course)
59 INTERMEDIATE, // is only an intermediate node in something like a oct-tree - constains nothing to draw
60 DETAILED // contains individual grass leaves - is drawn only if is close enough to eye
61 };
62
63 protected:
64 // holds level of detail (depends on distance from the center of the mesh to the eye point)
65 float LOD;
66
67 // distance form eye (to the center of the mesh)
68 float distanceFromEye;
69
70 // true if displaylist ready for drawing
71 mutable bool displayListValid;
72
73 // prepares displaylist according to the role of the object
74 void PrepareDisplayList(osg::RenderInfo & renderInfo) const;
75
76 // set of parameters of parent ability
77 ref_ptr<GrassAbilityParameters> params;
78
79 // specifies the meaning of this object
80 ROLE role;
81
82 // A kind of a private subtree - it is used during processing cullcallback of this Geometry.
83 // If is this geometry too close to eye, this tree is traversed to collect visible geometry
84 // in it and this parent low-detail geometry is not used.
85 // Otherwise (if eye is far away) only this parent geometry is used or drawing.
86 std::vector<ref_ptr<GrassDrawable>> moreDetailedVersion;
87
88 // display list containing the geometry of this Drawable. SetUseDisplayList is set to false for this object,
89 // so it manages its drawing itself every frame. And it uses this display list for it.
90 mutable GLuint grassDisplayList;
91
92 // mesh of this Drawable
93 ref_ptr<Mesh> mesh;
94
95 // ensures that more detailed version of this piece of grass is ready for drawing
96 void EnsureDetailedVersionIsReady();
97 };
98
99
100
101
102
103
104
105
106
107 }; // end of namespace grass
108
109
110
111 #endif _GRASS_GEOMETRY_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_mesh.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_mesh.h
Go to the documentation of this file.
1 #ifndef GRASS_MESH_H
2 #define GRASS_MESH_H
3
4 #include <osg/Geode>
5 #include <osg/Vec3>
6
7 using namespace osg;
8
9 namespace grass
10 {
11
12
13
14
15 // vertex with its normal
16 struct Vertex
17 {
18 Vec3 position, normal;
19 Vertex() {}
20 Vertex(Vec3 nPosition) : position(nPosition), normal(0,0,0) {}
21 Vertex(Vec3 nPosition, Vec3 nNormal) : position(nPosition), normal(nNormal) {}
22
23 // moves this vertex between two specified vertices
24 // and sets its normal to average of normals of two specified vertices
25 void IsAverageOf(const Vertex & a, const Vertex & b)
26 {
27 this->position = (a.position + b.position) * 0.5f;
28 this->normal = (a.normal + b.normal) * 0.5f;
29 }
30 };
31
32
33
34 // three triangle's vertices and its area and center
35 struct Triangle
36 {
37 public:
38 Vertex *A, *B, *C;
39 float area;
40 Vec3 center;
41
42 private:
43 Vertex GetPointAt(const float a, const float b, const float c) const
44 {
45 return Vertex( A->position*a + B->position*b + C->position*c,
46 A->normal*a + B->normal*b + C->normal*c );
47 }
48 public:
49 // default constructor
50 Triangle() {}
51
52 // constructor that gets pointers to its three vertices
53 // and computer the area and center itself
54 Triangle(Vertex * nA, Vertex * nB, Vertex * nC) : A(nA), B(nB), C(nC)
55 {
56 center = (A->position+B->position+C->position) * 0.33333f;
57 area = ( (A->position-B->position) ^ (A->position-C->position) ).length() * 0.5f;
58 }
59
60 // returns random point (with its normal) lying on this triangle.
61 Vertex GetRandomPoint() const
62 {
63 // select an order of vertices while getting their coefficients
64 const int point = rand() % 6;
65 const float a = rand() / float(RAND_MAX*1.2f);
66 const float b = (1.0f - a) * rand() / float(RAND_MAX);
67 const float c = 1.0f - a - b;
68 switch(point)
69 {
70 case 0: return GetPointAt(a,b,c);
71 case 1: return GetPointAt(a,c,b);
72 case 2: return GetPointAt(b,c,a);
73 case 3: return GetPointAt(b,a,c);
74 case 4: return GetPointAt(c,a,b);
75 default: return GetPointAt(c,b,a);
76 }
77 }
78 };
79
80
81
82
83 // mesh containing info about vertices, normals and triangles
84 class Mesh : public osg::Referenced
85 {
86 private:
87 // maximal height of the grass
88 float maxGrassHeight;
89
90 // triangles of this subtree (used in all meshes of this subtree)
91 Triangle * triangleBuffer;
92 unsigned int numOfTriangles;
93
94 // vertices of triangles stored in vector 'triangleBuffer'
95 Vertex * vertices;
96 unsigned int numOfVertices;
97
98 // boundingbox of this mesh
99 BoundingBox boundingBox;
100
101 // computes boundingbox
102 void ComputeBoundingBox();
103
104 public:
105 // pointers to triangles used in this single mesh
106 std::vector<Triangle*> triangles;
107
108 // creates empty mesh
109 Mesh(const float nMaxGrassHeight)
110 : maxGrassHeight(nMaxGrassHeight), Referenced()
111 {
112 triangleBuffer = 0;
113 numOfTriangles = 0;
114 vertices = 0;
115 numOfVertices = 0;
116 }
117
118 virtual ~Mesh()
119 {
120 if(vertices)
121 delete [] vertices;
122 if(triangleBuffer)
123 delete [] triangleBuffer;
124 }
125
126 // returns the bounding box of this mesh
127 BoundingBox GetBound() const {return boundingBox;}
128
129 // Divides this mesh into at least two and at most eight smaller meshes.
130 // Returns a vector with pointers to those new meshes. The original mesh is preserved.
131 std::vector<Mesh *> Divide() const;
132
133 friend class TriangleCollector;
134 };
135
136
137
138
139
140 }; // end of namespace grass
141
142 #endif // GRASS_MESH_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_parameters.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_parameters.h
Go to the documentation of this file.
1 #ifndef GRASS_PARAMETERS_H
2 #define GRASS_PARAMETERS_H
3
4 #include <vrecko/ReaderWriter.h>
5 #include <gl/gl.h>
6 #include <vector>
7 #include <osg/Texture2D>
8
9 namespace grass
10 {
11
12 // predeclaration
13 class GrassCullCallback;
14
15
16 // holds parameters of the Grass ability.
17 struct GrassAbilityParameters : osg::Referenced
18 {
19 private:
20 // copying of this object is not wanted
21 GrassAbilityParameters(const GrassAbilityParameters &) {}
22
23 // returns the half of width of "ideal" grass blade at y-position (bottom: y = 0.0f, top: y = 1.0f)
24 inline float GrassBladeProfile(float y)
25 { return 0.5f * (0.5f + y*y*(9.3f - y*(19.6f - 9.8f*y))); } // :)
26
27 // creates a set of grassBlades within given context
28 void CreateGrassBlades();
29
30 // internal method which prepares both statesets
31 void PrepareStateSets();
32
33 // texture used for texturing blades of grass, far grass, and far soil
34 osg::ref_ptr<osg::Texture2D> bladeTexture, farSoilTexture, farGrassTexture;
35
36 public:
37 // ensures that grass-blades are prepared
38 void EnsureGrassBladesArePrepared()
39 {
40 if(grassBlades.size() == 0)
41 CreateGrassBlades();
42 }
43
44 // only deletes display lists
45 virtual ~GrassAbilityParameters()
46 {
47 for(int i = grassBlades.size(); i--; )
48 glDeleteLists(grassBlades[i], 1);
49 }
50
51 // prepares everything for rendering grass
52 void Init();
53
54 // only sets default values
55 GrassAbilityParameters();
56
57 // use this method to read parameters from xml file
58 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
59
60 // use this to save parameters
61 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
62
63 // denstity of the grass (number of blades per unit area)
64 float density;
65
66 // range of random height, width and bend variance of blades
67 float minHeight, maxHeight, minWidth, maxWidth, minBend, maxBend;
68
69 // number of fractions of each grass blade. (low number means noticeably 'broken' blades,
70 // but also a faster rendering) Optimum for good look depends also on bend intensity.
71 // Nearly straight blades don't need to be divided into many pieces, while twisted ones need
72 // a lot of pieces to look well. The minFractions value is applied to the straightest blades
73 // and maxFractions to the most twisted ones. Others between them use adequate mix of those two values.
74 int minFractions, maxFractions;
75
76 // maximal size of a tringle which is covered with grass. Bigger triangles are divided
77 // first and then covered. This rule should avoid need of drawind huge triangles covered with
78 // grass which is in fact not visible at some far places of the triangle. Every smaller triangle
79 // obtained by dividing bigger ones is a part of sometihng like an oct-tree, so the visibility
80 // of its grass-cover can be determined quite efficiently.
81 float maxArea;
82
83 // maximal distance from grass blade to draw the grass blade
84 float maxVisibility, minVisibility;
85
86 // maximal difference between last LOD and current LOD to recreate a displaylist
87 float maxLODdifference;
88
89 // one divided by the difference between max and min Visibility
90 float invVisibilityRange, visibilityRange;
91
92 // a set of different grassBlades
93 std::vector<GLuint> grassBlades;
94
95 // two different statesets - one for low detail version of grass,
96 // the other for detailed version of grass.
97 osg::ref_ptr<osg::StateSet> lowDetailGrassStateSet;
98 osg::ref_ptr<osg::StateSet> detailedGrassStateSet;
99
100 // color used for far blades
101 osg::Vec4 neutralColor;
102
103 // CullCallback for GrassGeometry
104 osg::ref_ptr<GrassCullCallback> grassCullCallback;
105 };
106
107
108
109
110 }; // end of namespace grass
111
112 #endif // GRASS_PARAMETERS_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_shaders_source.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_shaders_source.h
Go to the documentation of this file.
1 #ifndef GRASS_SHADERS_SOURCE_H
2 #define GRASS_SHADERS_SOURCE_H
3
4
5 const char * lowDetailVertexShaderSource =
6 " varying float angle; \n"
7 " varying float distance; \n"
8 " uniform float maxVisibility; \n"
9 " uniform float minVisibility; \n"
10 " void main() \n"
11 " { \n"
12 " gl_Position = ftransform(); \n"
13 " angle = 1.0 - max(0.0, dot(vec3(0.0, 0.0, 1.0), gl_NormalMatrix * gl_Normal)); \n"
14 " distance = smoothstep(minVisibility, maxVisibility, \n"
15 " length(gl_ModelViewMatrix * gl_Vertex)); \n"
16 " gl_TexCoord[0].st = gl_MultiTexCoord0.st; \n"
17 " } \n";
18
19
20 const char * lowDetailFragmentShaderSource =
21 " uniform sampler2D far_soil; \n"
22 " uniform sampler2D far_grass; \n"
23 " varying float angle; \n"
24 " varying float distance; \n"
25 " void main( void ) \n"
26 " { \n"
27 " vec4 soilColor = texture2D(far_soil, gl_TexCoord[0].st, -2.0); \n"
28 " vec4 grassColor = texture2D(far_grass, gl_TexCoord[0].st, -2.0); \n"
29 " gl_FragColor = mix(soilColor, grassColor, distance); \n"
30 " } \n";
31
32
33
34 const char * detailedVertexShaderSource =
35 " // uniforms \n"
36 " uniform float osg_FrameTime; \n"
37 " uniform float maxVisibility; \n"
38 " uniform float minVisibility; \n"
39 " \n"
40 " // constants \n"
41 " const vec4 swingConstants1 = vec4(-10.45201, 6.78566, 3.45622, -8.12345); \n"
42 " const vec4 swingConstants2 = vec4(0.37698, 2.67035, 0.47124, 1.69646); \n"
43 " const vec4 swingConstants3 = vec4(0.05457, 0.08145, 0.14247, 0.05442); \n"
44 " \n"
45 " // attributes \n"
46 " attribute mat3 bladeSpaceBase; // (up, orientation, side) \n"
47 " attribute vec4 look; // (width, height, topColor, bottomColor) \n"
48 " attribute vec4 position; // (x, y, z, bend) \n"
49 " \n"
50 " \n"
51 " void main( void ) \n"
52 " { \n"
53 " // compute swing phase of the blade \n"
54 " vec4 swingvec = sin((osg_FrameTime + position.x + position.y + position.z) \n"
55 " * swingConstants1 + swingConstants2); \n"
56 " float bend = position.w + dot(swingvec, swingConstants3); \n"
57 " \n"
58 " // ensure bend is not zero (we will divide by it) \n"
59 " if(bend == 0.0) \n"
60 " bend = 0.00001; \n"
61 " \n"
62 " // compute the angle of the blade \n"
63 " float angle = bend * gl_Vertex.y; \n"
64 " \n"
65 " vec3 bladePoint; \n"
66 " \n"
67 " // normalize previous results and add the width of blade in current point \n"
68 " bladePoint.xy = vec2(sin(angle), 1.0-cos(angle)) * (look.y / bend); \n"
69 " bladePoint.z = look.x * gl_Vertex.x; \n"
70 " \n"
71 " vec4 tempPosition = vec4(position.xyz, 1.0); \n"
72 " \n"
73 " // compute the distance to the root of the blade \n"
74 " float distance = length(gl_ModelViewMatrix * tempPosition); \n"
75 " \n"
76 " // compute scale of the whole blade \n"
77 " float scale = (1.0 - smoothstep(minVisibility, maxVisibility, distance)); \n"
78 " \n"
79 " // compute the position of this point of the blade \n"
80 " tempPosition.xyz += bladeSpaceBase * (bladePoint * scale); \n"
81 " gl_Position = gl_ModelViewProjectionMatrix * tempPosition; \n"
82 " \n"
83 " // forward texture coordinates to fragment shader \n"
84 " gl_TexCoord[0].y = gl_Vertex.y; \n"
85 " gl_TexCoord[0].x = sign(gl_Vertex.x)*0.49 + 0.5; \n"
86 " gl_TexCoord[0].z = scale; \n"
87 " } \n";
88
89
90 const char * detailedFragmentShaderSource =
91 " uniform sampler2D texture; \n"
92 " uniform vec4 neutralColor; \n"
93 " void main( void ) \n"
94 " { \n"
95 " gl_FragColor = mix( neutralColor, \n"
96 " texture2D(texture, gl_TexCoord[0].xy), \n"
97 " gl_TexCoord[0].z \n"
98 " ); \n"
99 " } \n";
100
101
102
103 #endif // GRASS_SHADERS_SOURCE_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Grass/grass_triangle_collector.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Grass
grass_triangle_collector.h
Go to the documentation of this file.
1 #ifndef GRASS_TRIANGLE_COLLECTOR_H
2 #define GRASS_TRIANGLE_COLLECTOR_H
3
4 #include <osg/TriangleFunctor>
5 #include <osg/Vec3>
6 #include <map>
7 #include <vector>
8
9 #include "grass_mesh.h"
10
11 using namespace std;
12 using namespace osg;
13
14 namespace grass
15 {
16
17
18
19
20 // collects triangles od osg::Drawable and computes very interesting things
21 // like normals and area of those triangles.
22 class TriangleCollector
23 {
24 public:
25 // this should be called for every triangle
26 void operator() (const osg::Vec3 v1, const osg::Vec3 v2, const osg::Vec3 v3, bool treatVertexDataAsTemporary);
27
28 // returns mesh with all accesible triangles of given Geode
29 static Mesh * GetMesh(const Geode & geode, const float maxGrassHeight);
30 private:
31 Mesh * FinalizeAndReturn(const float maxGrassHeight);
32
33 map<Vec3, unsigned int> verticesLookup; // key is a positon, value is its index
34 vector<Vec3> vertices;
35 vector<unsigned int> triangles;
36
37 // returns index of vertex
38 unsigned int AddVertex(const Vec3 & v);
39 };
40
41
42
43
44 }; // end of namespace grass
45
46
47 #endif // GRASS_TRIANGLE_COLLECTOR_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/hand.h Source File

  • File List
  • File Members
  • include
  • base
hand.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vrecko/EnvironmentObject.h>
4
5 using namespace vrecko;
6
7 namespace base {
8
9 class hand: public Ability {
10 public:
11 hand();
12 ~hand() {};
13
14 // ------ BaseClass functions ------------------------
16 // void processEvent(const std::string &input_name, void *value);
17 // ---------------------------------------------------
18
19 void update(void);
20
21 void preInitialize() {owner = (EnvironmentObject*)pOwner;}
22
23 protected:
24 osg::Vec3 _grab_position, _actual_position, _last_position;
25 osg::Matrix _grab_rotation, _actual_rotation, _last_rotation;
26 osg::Matrix _parent_rotation, _parent_inverse_rotation;
27 bool _first;
28 bool dyn_version;
29
30 EnvironmentObject *selected_object;
31 Ability *ab_with_input_Use;
32 bool manipulate;
33
34 osg::Vec3 _last_positions[200];
35 int _current_pos;
36 osg::Matrix _grab_rotation2;
37 osg::Vec3 _grab_position2;
38 osg::Vec3 force;
39 bool first;
40
41 // new
42 osg::Matrix grab_transform, current_transform, last_transform;
43 osg::Matrix grab_transform_SO, SOparent_mat;
44
45 EnvironmentObject *owner;
46
47 DECLARE_INPUT(Grab, MessageBool);
48 DECLARE_OUTPUT(RelativeLocation, MessageMatrix);
49 };
50
51 }
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoDP/base/hci.h Source File

  • File List
  • File Members
  • include
  • vreckoDP
  • base
hci.h
Go to the documentation of this file.
1 /***************************************************
2 * - - - - - - - IMMERSION CORP. - - - - - - - *
3 * *
4 * Platform-independent software series *
5 * Copyright (c) 1993 *
6 ***************************************************
7 * HCI.C | SDK1-2a | January 1996
8 *
9 * Immersion Corp. Software Developer's Kit
10 * Functions for direct communication with the Immersion HCI
11 * Not for use with the Probe or Personal Digitizer
12 * Requires Microscribe HCI firmware version MSCR1-1C
13 */
14
15
16 #ifndef hci_h
17 #define hci_h
18
19 #include "classes.h"
20
21 /*-----------*/
22 /* Constants */
23 /*-----------*/
24
25 #define HCI_CHECK_FGND 1
26 #define HCI_CHECK_BGND 2
27 #define HCI_CHECK_MOTION 3
28
29 #define NUM_ENCODERS 7 /* Max # encoders supported by Immersion HCI */
30 #define NUM_ANALOGS 8 /* Max # of A/D channels supported */
31 #define NUM_BUTTONS 7 /* Max # of buttons supported */
32
33 /* These numbers are the maximum numbers available in Immersion HCI hardware.
34 * Various Immersion Corp. products based on the Immersion HCI will
35 * support various subsets of these components.
36 */
37
38
39 /*------------*/
40 /* Data Types */
41 /*------------*/
42
43 /* Constants for hci_result variables */
44 extern char BAD_PORT_NUM[]; /* Port number not valid */
45 extern char CANT_OPEN_PORT[]; /* Can't open the port during start-up */
46 extern char NO_HCI[]; /* No response from HCI during start-up */
47 extern char CANT_BEGIN[]; /* No response to "BEGIN" at start of session */
48 extern char NO_PACKET_YET[]; /* Complete packet not yet recv'd */
49 extern char TIMED_OUT[]; /* Didn't get complete packet in time */
50 extern char BAD_PACKET[]; /* Received packet that did not make sense */
51 extern char BAD_PASSWORD[]; /* Cfg cmd requiring passwd was denied */
52 extern char SUCCESS[]; /* Successful operation */
53 extern char TRY__AGAIN[]; /* Try the operation again */
54 extern char BAD_VERSION[]; /* Feature isn't supported by firmware */
55 extern char BAD_FORMAT[]; /* Parameter block is in unreadable format */
56
57
58 /* # of bytes in longest possible packet, plus some extra room */
59 #define MAX_PACKET_SIZE 42
60
61 /* Max # of args to a special config command */
62 #define MAX_CFG_SIZE 40
63
64 /* Max length of descriptor string from HCI */
65 #define MAX_STRING_SIZE 32
66
67 /* Space for arguments to config commands */
68 extern byte cfg_args[MAX_CFG_SIZE];
69 extern int num_cfg_args; /* # of values stored in cfg_args[] */
70
71 /* Record for packet
72 */
73 typedef struct
74 {
75 int parsed; /* Flag tells whether this packet has been parsed */
76 int error; /* Flag tells whether there has been com error */
77 int num_bytes_needed;
78 byte cmd_byte;
79 byte data[MAX_PACKET_SIZE];
80 byte *data_ptr;
81 } packet_rec;
82
83
84 /* Record containing all HCI data
85 * Declare one of these structs for each Immersion HCI in use.
86 * The hci_connect() command will establish communication with an Immersion
87 * HCI and set up an hci_rec corresponding to it.
88 * Example references: (assuming 'hci' is declared as an hci_rec)
89 * hci.button[2] - ON/OFF status of button #2
90 * hci.encoder[1] - total count for encoder #1
91 */
92 class Hci
93 {
94 private:
95 /* Communications parameters */
96 char port[20]; /* This HCI's serial port number */
97 int slow_timeout; /* Timeout period for slow process */
98 int fast_timeout; /* Timeout period for fast process */
99 packet_rec packet; /* The current packet */
100 int packets_expected; /* Determines whether timeout is important */
101
102 /* Marker field lets you mark different segments of data in incoming
103 * buffer. hci_insert_marker() makes HCI insert a marker into the
104 * data stream, so you can switch modes in a host application
105 * without misinterpreting some data that may still be waiting
106 * in the buffer; just insert a marker, and don't switch modes
107 * until you see the marker come back.
108 */
109 int marker;
110 int marker_updated;
111
112
113 /* Encoder "home" position:
114 * The relative encoders supported by the Immersion HCI only report
115 * their NET angular motion from the time they are powered up. If
116 * an encoder's initial angular value is important, it must somehow
117 * be assumed or calibrated at start-up. These fields contain values
118 * to be assumed at start-up. They can be read from or written to the
119 * Immersion HCI EEPROM. If written to the Immersion HCI EEPROM,
120 * these "home" values will be retained even after power is turned off.
121 */
122 int home_pos [NUM_ENCODERS];
123
124 /* Home position references:
125 * In many cases some calibration procedure will be required to ensure
126 * that the encoder positions truly match the assumed home position.
127 * This array can store any data that is useful for that purpose.
128 */
129 int home_ref [NUM_ENCODERS];
130
131
132 /* Extra field available for user's application-specific purpose */
133 long int user_data;
134
135 /* Conversion between baud rates and 6811 BAUD register codes */
136 /* byte baud_to_code(long int baud);
137 long int code_to_baud(byte code);*/
138 int packetSize(int cmd);
139
140 public:
141 /* Descriptor strings:
142 * These strings provide information about a particular HCI system.
143 */
144 char serial_number [MAX_STRING_SIZE];
145 char product_name [MAX_STRING_SIZE];
146 char product_id [MAX_STRING_SIZE];
147 char model_name [MAX_STRING_SIZE];
148 char comment [MAX_STRING_SIZE];
149 char param_format [MAX_STRING_SIZE];
150 char version [MAX_STRING_SIZE];
151
152 /* Primary quantities: */
153 int buttons; /* button bits all together */
154 int button [NUM_BUTTONS]; /* ON/OFF flags for buttons */
155 long timer; /* Running counter */
156 int analog [NUM_ANALOGS]; /* A/D channels */
157 int encoder [NUM_ENCODERS]; /* Encoder counts */
158
159 /* Status of primary fields:
160 * A zero in any of these fields indicates that the corresponding
161 * primary quantity is out of date (wasn't updated by the
162 * previous packets)
163 * Note: buttons are updated with every packet
164 */
165 int timer_updated;
166 int analog_updated [NUM_ANALOGS];
167 int encoder_updated [NUM_ENCODERS];
168
169 /* Normalization values for primary quantities:
170 * These values give some reference or normalization quantity
171 * for each field.
172 * A zero in any of these fields means there is no hardware
173 * support for that data in this particular system.
174 */
175 int button_supported [NUM_BUTTONS]; /* zero = butt not supported */
176 int max_timer; /* Max count reached before wrapping */
177 int max_analog [NUM_ANALOGS]; /* Full-scale A/D reading */
178 int max_encoder [NUM_ENCODERS]; /* Max value each encoder reaches
179 * INCLUDING quadrature */
180
181
182 /* Function pointers to handle application-specific functions
183 * These pointers are initialized to NULL.
184 * The user can make these point to handlers for each specific condition.
185 * These handlers must be declared as follows:
186 * hci_result my_handler(hci_rec *hci, hci_result condition);
187 * See programmer's guide for more discussion.
188 */
189
190 /* Handlers for errors */
191 hci_result (*BAD_PORT_handler)(hci_result condition);
192 hci_result (*CANT_OPEN_handler)(hci_result condition);
193 hci_result (*NO_HCI_handler)(hci_result condition);
194 hci_result (*CANT_BEGIN_handler)(hci_result condition);
195 hci_result (*TIMED_OUT_handler)(hci_result condition);
196 hci_result (*BAD_PACKET_handler)(hci_result condition);
197 hci_result (*BAD_PASSWORD_handler)(hci_result condition);
198 hci_result (*BAD_VERSION_handler)(hci_result condition);
199 hci_result (*BAD_FORMAT_handler)(hci_result condition);
200
201 /* Handler to use for an error if everything above is NULL
202 * The simplest way to get diagnostic reporting is to
203 * set default_handler to a function that outputs the string
204 * that is passed as the 'condition'. This can be implemented
205 * under any operating system or window environment by including
206 * the appropriate o.s. calls in the function pointed to by
207 * this handler pointer.
208 */
209 hci_result (*default_handler)();
210
211
212 /*---------------------*/
213 /* Function Prototypes */
214 /*---------------------*/
215
216 /* Initialize and setup an hci_rec */
217 void init(const char* port);
218 hci_result connect();
219 void disconnect();
220 hci_result getStrings();
221 // void resetCom();
222 hci_result autosynch();
223 hci_result begin();
224 void end();
225 void clearPacket();
226 void comParams(const char* port);
227 void fastTimeout();
228 void slowTimeout();
229
230 /* Issuing commands to HCI */
231 void stdCmd(int timer_flag, int analog_reports,
232 int encoder_reports);
233 void simpleCfgCmd(byte cmnd);
234 hci_result stringCmd(byte cmnd);
235 // hci_result passwdCmd(byte cmnd);
236 // void insertMarker(byte marker);
237 hci_result getParams(byte *block, int *block_size);
238 hci_result getExtParams(byte *block, int *block_size);
239 /* hci_result setParams(byte *block, int block_size);
240 hci_result getHomeRef();
241 hci_result setHomeRef(int *homeref);*/
242 hci_result goHomePos();
243 /* hci_result setHomePos(int *homepos);*/
244 hci_result getMaxes();
245 /* hci_result factorySettings();
246 void reportMotion(int timer_flag, int analog_reports,
247 int encoder_reports, int delay, byte active_btns,
248 int *analog_deltas, int *encoder_deltas);
249 void endMotion();*/
250
251 /* Compatibility Checking */
252 // float versionNum();
253
254 /* Packet monitoring functions */
255 hci_result waitPacket();
256 hci_result checkPacket(int checkType);
257 // hci_result checkMotion();
258 hci_result buildPacket(int checkTYpe);
259
260 /* Packet parsing functions */
261 hci_result parsePacket();
262 hci_result parseCfgPacket();
263
264 /* Helper functions */
265 hci_result readString(char *str);
266 hci_result readBlock(byte *block, int *bytes_read);
267 void invalidateFields();
268 /* void strcopy(char *from, char *to);
269 int strcmp(char *s1, char *s2);*/
270
271 /* Error handling */
272 hci_result error(hci_result condition);
273 hci_result simpleString(hci_result condition);
274
275 };
276
277
278
279 /* Macro for creating a command byte from a timer flag and the # of analog
280 * and encoder reports desired
281 */
282 #define CMD_BYTE(t, anlg, encd) \
283 ( (t ? TIMER_BIT : 0) \
284 | (anlg > 4 ? ANALOG_BITS : \
285 (anlg > 2 ? ANALOG_HI_BIT : \
286 (anlg ? ANALOG_LO_BIT : 0))) \
287 | (encd > 6 ? ENCODER_HI_BIT : \
288 (encd > 5 ? ENCODER_BITS : \
289 (encd ? ENCODER_LO_BIT : 0))) )
290
291
292 /*---------------------*/
293 /* Low-level Constants */
294 /*---------------------*/
295
296 /* Labels for the Special Configuration Commands */
297 #define CONFIG_MIN 0xC0 /* Minimum cmd byte for a config cmd */
298 #define GET_PARAMS 0xC0
299 #define GET_HOME_REF 0xC1
300 #define HOME_POS 0xC2
301 #define SET_HOME 0xC3
302 #define SET_BAUD 0xC4
303 #define END_SESSION 0xC5
304 #define GET_MAXES 0xC6
305 #define SET_PARAMS 0xC7
306 #define GET_PROD_NAME 0xC8
307 #define GET_PROD_ID 0xC9
308 #define GET_MODEL_NAME 0xCA
309 #define GET_SERNUM 0xCB
310 #define GET_COMMENT 0xCC
311 #define GET_PRM_FORMAT 0xCD
312 #define GET_VERSION 0xCE
313 #define REPORT_MOTION 0xCF
314 #define SET_HOME_REF 0xD0
315 #define RESTORE_FACTORY 0xD1
316 #define INSERT_MARKER 0xD2
317 #define GET_EXT_PARAMS 0xD3
318
319 /* Command bit-field place values */
320 #define PACKET_MARKER 0x80
321 #define CONFIG_BIT 0x40
322 #define TIMER_BIT 0x20
323 #define FUTURE_BIT 0x10
324 #define ANALOG_BITS 0x0C
325 #define ANALOG_HI_BIT 0x08
326 #define ANALOG_LO_BIT 0x04
327 #define ENCODER_BITS 0x03
328 #define ENCODER_HI_BIT 0x02
329 #define ENCODER_LO_BIT 0x01
330
331 /* A timeout period is the time to transmit this many chars */
332 #define TIMEOUT_CHARS 2*MAX_PACKET_SIZE
333
334 /* Time (sec) to wait between signon attempts in 'connect' process */
335 #define SIGNON_PAUSE 15
336
337 /* Time (sec) to wait after ending session */
338 #define END_PAUSE 15
339
340 /* Time (sec) to wait for each byte arg to a passwd-protected cfg cmd */
341 #define CFG_ARG_PAUSE 15
342
343 /* Time (sec) to wait after restoring factory settings */
344 #define RESTORE_PAUSE 2000
345
346 /* Code sent by HCI to accept a password */
347 #define PASSWD_OK 0xFF
348
349
350 #endif /* hci_h */
351
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/hermitpipe.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
hermitpipe.h
Go to the documentation of this file.
1 #ifndef HERMITPIPE_H_
2 #define HERMITPIPE_H_
3
4 #include "straightpipe.h"
5
6 namespace AP_LSystem {
7 class HermitPipe : public StraightPipe
8 {
9 private:
10 void initializePipe();
11 void finalizePipe();
12 void drawCap();
13 public:
14 HermitPipe(void){};
15 ~HermitPipe(void){};
16
17 virtual int drawStep( double dist );
18
19 virtual int initialize( );
20 virtual int finalize( );
21
22 };
23 }
24
25 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/HeadTracking/htUtils.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • HeadTracking
htUtils.h
Go to the documentation of this file.
1 #pragma once
2 #ifndef __HEAD_TRACKING_UTILS_H
3 #define __HEAD_TRACKING_UTILS_H
4
5 // TODO Left/right handed coordinate systems
6
7 #include <osg/Vec3>
8 #include <osg/Vec4>
9 #include <osg/Matrix>
10 #include "Vec2i"
11
12 namespace ht
13 {
14
16 class Screen
17 {
18 private:
20 osg::Matrix scr_matrix;
21 osg::Matrix scr_matrix_inv;
22
24 bool valid;
25 public:
26 Screen();
27
36 void SetScreen(osg::Vec3 corner, osg::Vec3 width, osg::Vec3 height);
37
45 // bool GetScreen(osg::Vec3 &corner, osg::Vec3 &width, osg::Vec3 &height) const;
46
48 inline const osg::Matrix& GetMatrix() const
49 { return scr_matrix; }
50
53 inline const osg::Matrix& GetMatrixInv() const
54 { return scr_matrix_inv; }
55
57 inline bool IsValid() const
58 { return valid; }
59 };
60
61 }
62
63 #endif // __HEAD_TRACKING_UTILS_H
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/icp_functions.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
icp_functions.h
Go to the documentation of this file.
1 #ifndef JACOBI_H
2 #define JACOBI_H
3
4 #ifndef STDLIB_H
5 #define STDLIB_H
6 #include <stdlib.h>
7 #endif
8
9
10 int jacobi2(int n, double *a[], double d[], double *v[]);
11
12 void Perpendiculars(const double x[3], double y[3], double z[3], double theta);
13
14
15 #endif //JACOBI_H
16
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/base/Avatar.h Source File

  • File List
  • File Members
  • include
  • base
Avatar.h
Go to the documentation of this file.
1 #ifndef AVATAR_H
2 #define ABATAR_H
3
4 #include <vrecko/Ability.h>
5
6 #include <vrecko/EnvironmentObject.h>
7 #include <vrecko/World.h>
8
9
10 using namespace vrecko;
11
12 namespace base {
13
14 class Avatar: public Ability {
15 public:
16 Avatar();
17 ~Avatar();
18
19 // ------ BaseClass functions ------------------------
21 // void processEvent(const std::string &input_name, void *value);
22 // ---------------------------------------------------
23
24 void preInitialize(void);
25 void postInitialize(void);
26 void update(void);
27
28 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
29 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
30
31 protected:
32 World::AvatarView avatar_view;
33 osg::Quat orientation; // [orientation] and [avatar_view] should be kept in sync
34
35 EnvironmentObject *head;
36 EnvironmentObject *left_hand, *right_hand;
37 EnvironmentObject *left_leg, *right_leg;
38 EnvironmentObject *free_move_EO;
39
40 long int headEO_ID, leftHandEO_ID, rightHandEO_ID, freeMoveEO_ID;
41
42 // osg::Vec3 eye_position, up_vector;
43 // osg::Vec3 direction_and_shift; // look direction and the GLOVES SHIFT !!! (0, 0, -24) typically
44
45 osg::Vec3 cursor_shift; // must be in the form (0, 0, X)
46
47 EnvironmentObject *owner;
48 bool gravity_mode;
49 osg::Vec3 reference_point;
50
51 //void applyPosChange(const std::string &input_name, osg::Vec3 posChange);
52
54 void setOrientationKeepUp(osg::Quat *newOrientation);
55
56 void updatePosRot(bool bUpdatePos, bool bUpdateRot, osg::Vec3 *position, osg::Quat *orientation);
57
58 DECLARE_INPUT(FreeMovement, MessageBool);
59 DECLARE_INPUT(Move, MessageVec3);
60 DECLARE_INPUT(MoveLocal, MessageVec3);
61 DECLARE_INPUT(Rotation, MessageQuat);
62 DECLARE_INPUT(RotationKeepUp, MessageQuat);
63 DECLARE_INPUT(Position, MessageVec3);
64 DECLARE_INPUT(Orientation, MessageQuat);
65 DECLARE_INPUT(OrientationKeepUp, MessageQuat);
66
67 DECLARE_INPUT(DebugOutputViewPosition, MessageVoid);
68 };
69
70 }
71
72 #endif
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/FFDEditor/Grid.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • FFDEditor
Grid.h
Go to the documentation of this file.
1 #ifndef APGRID_H
2 #define APGRID_H
3
4 #include <vrecko/Ability.h>
5 #include <osg/Group>
6 #include <osg/Geometry>
7
8 using namespace vrecko;
9
10 namespace APFFDEditor {
11
12 class Grid {
13 friend class EditorLogic;
14 public:
15 Grid();
16 ~Grid();
17
18
19 //this set count of control points in each direction in grid
20 inline void setCountOfControlPoints(osg::Vec3 pom) {
21 //we can not change count of control points if grid was one created(this variable is used in array iteration)
22 if (!gridWasCreated)
23 countOfCP.set(pom);
24 }
25
26 inline osg::Vec3 getCountOfControlPoints(void) {
27 return countOfCP;
28 }
29
30 //this function creates grid around selected object, it needs pWold pointer too
31 bool createGrid(vrecko::EnvironmentObject * object);
32
33 //function that control if grid was changed, return id of ControlPoint which position was changed
34 //this function also set position of edges
35 bool updateGrid(void);
36
37
38 inline void setOptimalizationOfCP(unsigned int value){optimalizationOfCP=value;}
39
40 //two main structures of grid
41
42
43
44 protected:
45 //allocation and deallocation of arrays
46 inline void allocateControlPointArray() {
47 controlPoints = new ControlPoint**[countOfCP.x()];
48 for(unsigned long i=0; i<countOfCP.x(); i++){
49 controlPoints[i] = new ControlPoint*[countOfCP.y()];
50 }
51 for(unsigned long i=0; i<countOfCP.x(); i++){
52 for(unsigned long j=0; j<countOfCP.y(); j++){
53 controlPoints[i][j] = new ControlPoint[countOfCP.z()];
54 }
55 }
56 controlPoint_count = countOfCP.x()*countOfCP.y()*countOfCP.z();
57 }
58
59 inline void allocateEdgeArray() {
60 //here i am counting number of edges in grid.
61 int countOfEdges = ((countOfCP.y()-1)*(countOfCP.x()) + (countOfCP.y())*(countOfCP.x()-1))*(countOfCP.z()) + (countOfCP.x())*(countOfCP.y())*(countOfCP.z()-1);
62 edges = new Edge[countOfEdges]; edge_count = countOfEdges;
63 }
64
65 inline void deallocateEdgeArray() { if (edges) { delete[] (edges); } }
66
67 inline void deallocateControlPointArray() {
68 if (controlPoints) {
69 for(unsigned long i=0; i<countOfCP.x(); i++){
70 for(unsigned long j=0; j<countOfCP.y(); j++){
71 delete[] (controlPoints[i][j]) ;
72 }
73 }
74 for(unsigned long i=0; i<countOfCP.x(); i++){
75 delete[] (controlPoints[i]) ;
76 }
77 delete[] (controlPoints) ;
78 }
79 }
80 struct ControlPoint {
81 vrecko::EnvironmentObject* EO;
82 osg::Vec3 startPos;
83 osg::Vec3 prevPos;
84
85 //this is only for construction of edges
86 bool visited;
87 };
88 struct Edge {
89 unsigned long ID1;//id of environmet object ControlPoint
90 unsigned long ID2;
91 osg::ref_ptr<osg::Geometry> osgGeom;
92 };
93 ControlPoint*** controlPoints;
94 Edge* edges;
95
96 //count of control points
97 osg::Vec3 countOfCP;
98
99 unsigned long controlPoint_count;
100 unsigned long edge_count;
101
102 virtual void destroyGeometry();
103
104 //osgGeode of all edges
105 osg::ref_ptr<osg::Geode> osgGeode;
106 float CPscaling;
107 bool gridWasCreated;
108 unsigned int optimalizationOfCP;
109 //this function get transform of all parents
110 //void getParentsTransform(osg::Matrix &parentsTransform, osg::Node * object);
111 };
112
113 }
114 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Icon.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Icon.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4 #include "ItemsGroup.h"
5
6 # ifdef GUI_LIBRARY
7 # define GUI_EXPORT __declspec(dllexport)
8 # else
9 # define GUI_EXPORT __declspec(dllimport)
10 #endif
11
12
13
14 using namespace vrecko;
15
16 namespace APGUI
17 {
18
19
21 typedef enum IconType {
22 ICON__BUTTON = 1,
23 ICON__SWITCH,
24 ICON__MULTISWITCH,
25 };
26
28 //typedef enum IconState {
29 // ICON__BASIC,
30 // ICON__HOVERED,
31 // ICON__HOVERED_PRESSED,
32 // ICON__PRESSED,
33 //};
34
35
36
38
46 class GUI_EXPORT Icon : public GUI_Item
47 {
48 public:
49
50 Icon();
51 ~Icon();
52
61 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
62
74 bool initialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position = osg::Vec3() );
75
77 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed);
78
79
80 // Called when user pointed to this icon with some sensor
81 void pointed(bool pointed);
82
83
84 //TODO Remove this function
86
89 //void setState(bool active);
90
91 void setState(GUI_ITEM_STATE newState);
92
93 // not just very effective, but working
94 // if part with given name is not found, nothing happens
95 void setPartColour(string partName, osg::Vec4 newColour);
96
97
98 protected:
99
101 IconType _type;
102
104 //bool _switchActive;
105
107 //bool _switchActive_HullColourChange;
108
109 bool _switchActive_CoreChange;
110
111 // should icon send extra message (event), that it should be deactivated by receiver
112 bool _externalDeactivation;
113
115 osg::Switch *_models;
116
117 // Load models of different states of Icon
118 // Called from initialize
119 bool createModels( string basicModelString, string hullModelString );
120
122 bool postInitialize(string name, string receiver, string label, string tooltip, string group, osg::Vec3 position );
123
124
126 void switchVisuals();
127
128
129 DECLARE_OUTPUT(GUIItemClicked, MessageString);
130
131 //icon want to be deactivated (switched to default state) externaly - by receiver
132 DECLARE_OUTPUT(ExternalDeactivation, MessageObjectID);
133
134 ItemsGroup *_group;
135 osg::Vec3 _initialScale;
136
137 };
138
139 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/log.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
log.h
Go to the documentation of this file.
1 #ifndef LS_LOG_H_
2 #define LS_LOG_H_
3
4 #include <string>
5 #include <sstream>
6 #include "windows.h"
7
8 namespace AP_LSystem {
9 class Log
10 {
11 private:
12 static Log * logInst;
13
14 unsigned m_RewritingCounter;
15 unsigned m_ModuleCounter;
16 unsigned m_TurtleCounter;
17 unsigned m_QueryCounter;
18
19 Log(): m_RewritingCounter(0), m_ModuleCounter(0), m_TurtleCounter(0), m_QueryCounter(0) {}
20
21 ~Log(){}
22
23 enum Output
24 {
25 OUTPUTDEBUGSTRING,
26 FILE,
27 VRECKO,
28 } type;
29
30 void output( const char * str )
31 {
32 switch(type)
33 {
34 case OUTPUTDEBUGSTRING:
35 OutputDebugStringA( str );
36 break;
37 case FILE:
38 break;
39 case VRECKO:
40 break;
41 }
42 }
43
44 public:
45
46 static Log * get()
47 {
48 if(!logInst) logInst = new Log();
49
50 return logInst;
51 }
52
53 void write( std::string str)
54 {
55 OutputDebugStringA( str.c_str() );
56 output( str.c_str() );
57 }
58
59 void write( int i )
60 {
61 std::stringstream str;
62 str << i;
63 OutputDebugStringA( str.str().c_str() );
64 }
65
66 unsigned int getRewritingCounter() const {return m_RewritingCounter;}
67
68 unsigned int getModuleCounter() const {return m_ModuleCounter;}
69
70 unsigned int getTurtleCounter() const {return m_TurtleCounter;}
71
72 unsigned int getQueryCounter() const {return m_QueryCounter;}
73
74 void incRewritingCounter() { m_RewritingCounter++;}
75
76 void incModuleCounter() { m_ModuleCounter++;}
77
78 void incTurtleCounter() { m_TurtleCounter++;}
79
80 void incQueryCounter() { m_QueryCounter++;}
81 };
82 }
83
84 #endif // LOG_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ODE/Sphere.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ODE
Sphere.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include "DynamicScene.h"
3
4 using namespace vrecko;
5
6
7 namespace ode {
8
9 class Sphere: public Ability {
10 public:
11 Sphere();
12 ~Sphere() {};
13
14 void postInitialize(void);
15 void update(void);
16
17 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
18 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
19
20 protected:
21 double _radius;
22 double _density;
23
24 DECLARE_REQUEST_OUTPUT(ODE, DynamicScene::MessageODERequest, MessageVoid);
25 };
26
27 }
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/jointedpipe.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
jointedpipe.h
Go to the documentation of this file.
1 #ifndef JOINTEDPIPE_H_
2 #define JOINTEDPIPE_H_
3
4 #include "loftturtle.h"
5
6 namespace AP_LSystem {
11 class JointedPipe : public LoftTurtle
12 {
13 private:
17 void createHemisphere();
18
23 virtual int addHemisphereGeometry( );
24 public:
25 JointedPipe(void);
26 ~JointedPipe(void);
27
32 virtual int initialize();
33
38 virtual int preStep();
39
44 virtual int postStep();
45
46 };
47 }
48
49 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/loftturtle.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
loftturtle.h
Go to the documentation of this file.
1 #ifndef LOFTTURTLE_H_
2 #define LOFTTURTLE_H_
3
4 #include "movingturtle.h"
5
6 namespace AP_LSystem {
10 class LoftTurtle : public MovingTurtle
11 {
12 protected:
18 virtual int drawStep( double dist)
19 {
20 int ret = LS_OK;
21
22 preStep( );
23
24 osg::Matrixd t;
25 // set movement as half of step
26 t.makeTranslate( HeadVec * dist/2.0f );
27 // move to the center of the step
28 properties.matrix = t * properties.matrix;
29
30 // adjust matrices - process tropism, twist minimalizing
31 adjustMatrices( );
32
33 // do whatever in the center
34 ret = insideStep();
35 // draw debug
36 drawFrame( properties.matrix );
37
38 // store control point - center of step
39 properties.controlPoint = osg::Vec3d( 0.0, 0.0, 0.0 ) * properties.matrix;
40
41 // move forward - second half of the step
42 properties.matrix = t * properties.matrix;
43
44 postStep( );
45
46 return ret;
47 }
48
52 void createCircleContour()
53 {
54 if(properties.contour.get())
55 return;
56
57 osg::Quat q( 2.0f * PI / static_cast<double>(properties.contourDetail), HeadVec );
58
59 properties.contour = new osg::Vec3dArray( );
60
61 properties.contour->push_back( LeftVec );
62
63 for(unsigned int i=1; i<properties.contourDetail; i++)
64 {
65 properties.contour->push_back( q * *(properties.contour->rbegin()) );
66 }
67 }
68
73 virtual int addContourLoftGeometry();
74
79 virtual int createLoftGeometryOpening();
80
81 virtual int insideStep() { return 0; }
82 public:
83 LoftTurtle(void);
84 ~LoftTurtle(void);
85 };
86 }
87
88 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/longstring.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
longstring.h
Go to the documentation of this file.
1 #ifndef LONGSTRING_H_
2 #define LONGSTRING_H_
3
4 #include <string>
5 #include "utils.h"
6
7 namespace AP_LSystem {
8 static unsigned int ZERO = 0;
9
14 class LongString
15 {
16 private:
17 char * m_String;
18 unsigned int m_Length;
19 unsigned int m_Allocated;
20 unsigned int m_Increment;
21
23
27 inline Parameter::Type getType(double) { return Parameter::LS_DOUBLE; }
28 inline Parameter::Type getType(double *) { return Parameter::LS_DOUBLE; }
29 inline Parameter::Type getType(unsigned int) { return Parameter::LS_UINT; }
30 inline Parameter::Type getType(unsigned char) { return Parameter::LS_UBYTE; }
31 inline Parameter::Type getType(int) { return Parameter::LS_INT; }
32 inline Parameter::Type getType(int *) { return Parameter::LS_INT; }
34
38 void resize();
39
44 void append( std::string str );
45
50 void append( Parameter::Type type );
51 public:
56 LongString( unsigned int length = 1048576); // 2^20 bytes - 1 MB
57
61 LongString( const LongString& c );
62
66 LongString& operator=( const LongString & c );
67
71 ~LongString( );
72
77 void convertFromString( std::string * str, unsigned int & = ZERO, const char = '\0' );
78
84 template< class T >
85 void append( T par )
86 {
87 if(m_Allocated < m_Length + sizeof( T ) + 2)
88 {
89 resize( );
90 }
91 append( getType(par) );
92 memcpy( m_String + m_Length, &par, sizeof( T ) );
93 m_Length += sizeof( T );
94 append( getType(par) );
95 }
96
101 void append( const char ch );
102
103
109 void append( const char * data, int length);
110
115 void append( LongString * ls);
116
125 template< class T >
126 bool getParameters( unsigned int & pos, T * pParams, int & paramsCnt )
127 {
128 if(pos >= m_Length)
129 return false;
130
131 char * pPos = m_String + pos + 1;
132 // while pointer pPos points correctly to m_String buffer
133 // and
134 // the parameter in buffer has the same type as parameter array pParams
135 while(((pPos - m_String) < static_cast<int>(m_Length) ) && (*pPos == getType(pParams)))
136 {
137 // copy parameter to parameter array
138 memcpy(pParams + paramsCnt, ++pPos, sizeof(T));
139 // increment parameter counter
140 paramsCnt++;
141 // move pointer behind the parameter in m_String buffer
142 pPos += sizeof(T)+1;
143 }
144 pos = pPos - m_String - 1;
145 return true;
146 }
147
152 char * getData( );
153
154
162 char * getData( unsigned int & pos, unsigned int & length, char delimiter);
163
169 char * getSymbol( unsigned int & pos );
170
180 int matchRight( char ch, int pos, const std::string * ignore = NULL, const std::string * consider = NULL );
181
191 int matchLeft( char ch, int pos, const std::string * ignore = NULL, const std::string * consider = NULL );
192
199 char peekSymbol( int & pos, bool direction );
200
206 int findMatchingRightBracket( int pos );
207
213 int findMatchingLeftBracket( int pos );
214
220 std::string toString( );
221
225 inline char& operator[](unsigned int i) const
226 {
227 return m_String[i];
228 }
229
234 inline unsigned int length() const
235 {
236 return m_Length;
237 }
238 };
239 }
240 #endif // LONGSTRING_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsfile.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsfile.h
Go to the documentation of this file.
1 #ifndef LSFILE_H_
2 #define LSFILE_H_
3
4 #include <vector>
5 #include <map>
6 #include <string>
7 #include <osgDB/fstream>
8 #include <sstream>
9
10 #include "abstractfile.h"
11 #include "utils.h"
12 #include "lsystemexception.h"
13 #include "configuration.h"
14
15
16 using std::string;
17
18 namespace AP_LSystem{
22 class LSFile : public AbstractFile
23 {
24 private:
25 std::map<string, string> m_Defines;
26
32 void processType( std::string expression );
33
34 public:
35 LSFile();
41 virtual void open(string & filename);
42 };
43 }
44
45 #endif // LSFILE_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsgeode.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsgeode.h
Go to the documentation of this file.
1 #ifndef LSGEODE_H_
2 #define LSGEODE_H_
3
4 namespace AP_LSystem {
8 struct TurtleProperties
9 {
13 enum Flags
14 {
15 DRAW_DEBUG_GEOMETRY = 0x00000001,
16 MINIMIZE_TWIST = 0x00000002,
17 DEGREES_TO_RADIANS = 0x00000004,
18 SEPARATE_GEOMETRY_FOR_TRANSLUCENT = 0x00000008,
19 USE_QUERIES = 0x00000010,
20 DRAW_PIPE_CAPS = 0x00000100,
21 };
22
23 TurtleProperties():modelFile(NULL){};
24
28 void clean()
29 {
30 if(modelFile)
31 delete modelFile;
32 }
33
34 osg::ref_ptr<osg::Geometry> geometry;
35
36 osg::Matrixd matrix;
37 osg::Matrixd lastMatrix;
38 osg::Matrixd lastFrame;
39
40 double length;
41 double lengthMultiplier;
42 double angle;
43 double angleMultiplier;
44 unsigned int angleVariance;
45 double radius;
46 double radiusMultiplier;
47 double texCoordT;
48 unsigned int texRepeatingS;
49
50 unsigned int curveDetail;
51
52 osg::Vec3 controlPoint;
53
54 unsigned int flags;
55
56 // direction stimuli
57 double elasticityMultiplier;
58 double gravitropismElasticity;
59 double tropismElasticity;
60 double tropismAngle;
61 osg::Vec3d tropismVector;
62
63 std::string * modelFile;
64
65 osg::ref_ptr<osg::Vec3dArray> contour;
66 osg::ref_ptr<osg::Vec3dArray> contourLastV;
67 osg::ref_ptr<osg::Vec3dArray> contourLastN;
68 unsigned int contourDetail;
69
70 vector<osg::ref_ptr<osg::Vec3dArray> > hemisphere;
71
72 double debugGeometryScale;
73 };
77 enum TurtleType
78 {
79 LS_TURTLE_JOINTEDPIPE,
80 LS_TURTLE_STRAIGHTPIPE,
81 LS_TURTLE_HERMITPIPE,
82 LS_TURTLE_OBJMODEL,
83 LS_TURTLE_RECTANGLE,
84 LS_TURTLE_QUERY,
85 };
86
92 class LSGeode : public osg::Geode
93 {
94 private:
95 TurtleType turtleType;
96 TurtleProperties defaultTurtleProperties;
97 public:
102 void setTurtleType(const std::string & type);
103
108 void setTurtleType(TurtleType type);
109
114 TurtleType getTurtleType();
115
120 void setDefaultTurtleProperties( TurtleProperties & p );
121
122
127 void setDefaultTurtleProperties( int index );
128
129
134 TurtleProperties & getDefaultTurtleProperties( );
135
141 LSGeode( unsigned int index );
142 };
143 }
144
145 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsobject.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsobject.h
Go to the documentation of this file.
1 #ifndef LSOBJECT_H_
2 #define LSOBJECT_H_
3
4 #include "abstractgenerator.h"
5 #include "abstractinterpret.h"
6
7 using namespace vrecko;
8
9 namespace AP_LSystem {
13 class LSObject: public Ability {
14 private:
15 EnvironmentObject* m_EOOwner;
16 AbstractGenerator * m_Generator;
17 AbstractInterpret * m_Interpreter;
18 string m_LSystemFileName;
19 string m_ConfigFileName;
20
21 public:
25 LSObject();
26
30 virtual ~LSObject();
31
35 virtual void preInitialize();
36
40 virtual void postInitialize();
41
45 virtual bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
46 };
47 }
48 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsystem.h
Go to the documentation of this file.
1 #ifndef LSYSTEM_H_
2 #define LSYSTEM_H_
3
4 #include "abstractlsystem.h"
5 #include "rule.h"
6 #include "longstring.h"
7
8 using std::multimap;
9 using std::vector;
10 using std::string;
11
12 namespace AP_LSystem {
13 class LSystem : public AbstractLSystem
14 {
15 protected:
16 LongString * m_Word;
17 multimap<char, Rule> m_Rules;
18 multimap<char, Rule> m_Homomorphisms;
19 vector<string> m_SubSystemsFilenames;
20 vector< LongString *> m_SubSystemsWords;
21 string m_Ignore;
22
23 // Loading and parsing
24 virtual void setAxiom(std::string &);
25 virtual void addRule(std::string *);
26 virtual void addHomomorphism(std::string *);
27 virtual void processPredecessor( Rule &, string *, string::iterator & ) = 0;
28 virtual void processRuleSuccessor( Rule &, string *, string::iterator &) = 0;
29 virtual void processHomomorphismSuccessor( Rule &, string *, string::iterator &) = 0;
30
31 // Generating
36 virtual bool nextIteration();
37
44 virtual bool transcribe( multimap<char, Rule> & rules );
45
57 virtual multimap<char, Rule>::iterator * selectRule(multimap<char, Rule>::iterator & begin,
58 multimap<char, Rule>::iterator & end,
59 LongString * word,
60 unsigned int & pos,
61 double * parameters);
62
70 virtual void generateSuccessor( LongString * word, multimap<char, Rule>::iterator & rule, double * params);
71 public:
72
76 LSystem(AbstractFile *);
77
81 LSystem( const LSystem & );
82
86 ~LSystem();
87
91 LSystem & operator=( const LSystem & );
92
97 virtual void loadFromFile( AbstractFile * file );
98
99 unsigned int wordLength() { return m_Word->length(); }
100 virtual void transcribeSubSystems( );
101 virtual LongString * translate( );
102 virtual void processCutSymbol( );
103 };
104 }
105 #endif // LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemexception.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsystemexception.h
Go to the documentation of this file.
1 #ifndef ABSTRACTLSYSTEMEX_H
2 #define ABSTRACTLSYSTEMEX_H
3
4 #include <exception>
5 #include <string>
6
7 namespace AP_LSystem {
11 class LSystemException : public std::exception
12 {
13 public:
14 std::string type, message;
15
16 public:
17 LSystemException()
18 {
19 appendType();
20 }
21
22 LSystemException( const char * description)
23 {
24 appendType();
25 this->message.append(description);
26 }
27
28 ~LSystemException() throw() {}
29
30 virtual const char * what() const throw()
31 {
32 return this->message.c_str();
33 }
34
35 virtual void appendType()
36 {
37 message = "LSystem: ";
38 }
39 };
40
44 class ParsingException : public LSystemException
45 {
46 public:
47 ParsingException()
48 {
49 appendType();
50 }
51
52 ParsingException( const char * description )
53 {
54 appendType();
55 this->message.append(description);
56 }
57
58 ParsingException( std::string description )
59 {
60 appendType();
61 this->message.append(description);
62 }
63
64 virtual void appendType()
65 {
66 this->message.append( "parsing error: " );
67 }
68 };
69
73 class FileException : public LSystemException
74 {
75 public:
76 FileException()
77 {
78 appendType();
79 }
80
81 FileException( const char * description)
82 {
83 appendType();
84 this->message.append(description);
85 }
86
87 FileException( std::string description)
88 {
89 appendType();
90 this->message.append(description);
91 }
92
93 virtual void appendType()
94 {
95 type.append( "file i/o error: " );
96 }
97 };
98
102 class ConfigurationException : public LSystemException
103 {
104 public:
105 ConfigurationException()
106 {
107 appendType();
108 }
109
110 ConfigurationException( const char * description)
111 {
112 appendType();
113 this->message.append(description);
114 }
115
116 ConfigurationException( std::string description)
117 {
118 appendType();
119 this->message.append(description);
120 }
121
122 virtual void appendType()
123 {
124 type.append( "Configuration error: " );
125 }
126 };
127 }
128
129 #endif // ABSTRACTLSYSTEMEX_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/lsystemgenerator.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
lsystemgenerator.h
Go to the documentation of this file.
1 #ifndef LSYSTEMGENERATOR_H_
2 #define LSYSTEMGENERATOR_H_
3
4 #include "abstractgenerator.h"
5
6 namespace AP_LSystem {
10 class LSystemGenerator : public AbstractGenerator
11 {
12 public:
16 LSystemGenerator(void);
17
21 ~LSystemGenerator(void);
22
27 virtual void loadFile( std::string & filename );
28
32 virtual void nextIteration();
33
38 virtual ParseableString * getWord();
39 };
40 }
41 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Nature/Clouds/math_aux.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Nature
  • Clouds
math_aux.h
Go to the documentation of this file.
1
9 #ifndef _VRECKO_CLOUDS_MATH_AUX_H
10 #define _VRECKO_CLOUDS_MATH_AUX_H
11
12 #include <osg/Vec4f>
13
21 unsigned int randGauss(unsigned int cislo, unsigned int n);
22
28 float randFloat(void);
29
37 float interpolationLinear(float a, float b, float t);
38
45 void clampColor(osg::Vec4f& color, float maximum);
46
47 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/model.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
model.h
Go to the documentation of this file.
1 #ifndef modelH
2 #define modelH 1
3
4 #include <vrecko/Ability.h>
5 #include <vrecko/EnvironmentObject.h>
6 #include <vrecko/World.h>
7 #include <vector>
8 #include <string>
9 #include <osgCal/CoreModel>
10 #include <osgCal/Model>
11 #include "awHelper.h"
12
13 using namespace vrecko;
14
15 namespace ArtificialWorld
16 {
18 enum ModelType
19 {
20 none,
22 geometry,
24 cal3D,
26 other
27 };
28
30 enum ModelFlags
31 {
32 NONE = 1,
34 NO_SUBBLOCKS = NONE << 1
35 };
36
38 class Model
39 {
40 public:
41
43 osg::ref_ptr<EnvironmentObject> Geometry;
44
45 Model(void);
46 virtual ~Model(void){};
47
49 void SetModelFlags(ModelFlags flags){ modelFlags = flags; };
51 void SetMinVisibleDistance(unsigned long minDist){ hasMinDistance = true; minVisibleDistance = minDist; };
53 void SetMaxVisibleDistance(unsigned long maxDist){ hasMaxDistance = true; maxVisibleDistance = maxDist; };
55 void SetPosition(osg::Vec3 pos){ position = pos; };
57 void SetRotation(osg::Quat rot){ rotation = rot; };
59 void SetScale(osg::Vec3 sc){ scale = sc; };
61 void SetFileName(string fname){ fileName = fname; };
63 void SetFileName(char* fname){ fileName.assign(fname); };
65 void SetModelType(ModelType mtype){ modelType = mtype; };
66
68 ModelFlags GetModelFlags(void){ return modelFlags; };
70 unsigned long GetMaxVisibleDistance(void){ return maxVisibleDistance; };
72 unsigned long GetMinVisibleDistance(void){ return minVisibleDistance; };
74 osg::Vec3 GetPosition(void){ return position; };
76 osg::Quat GetRotation(void){ return rotation; };
78 osg::Vec3 GetScale(void){ return scale; };
80 string GetFileName(void){ return fileName; }
82 ModelType GetModelType(void){ return modelType; };
83
85 bool HasMinVisibleDistance(void){ return hasMinDistance; };
87 bool HasMaxVisibleDistance(void){ return hasMaxDistance; };
89 bool HasPositionSet(void){ return hasPositionSet; };
90
91 protected:
93 ModelFlags modelFlags;
95 unsigned long maxVisibleDistance;
97 unsigned long minVisibleDistance;
99 osg::Vec3 position;
101 osg::Quat rotation;
103 osg::Vec3 scale;
105 string fileName;
107 ModelType modelType;
109 bool hasMinDistance;
111 bool hasMaxDistance;
113 bool hasPositionSet;
114
115 };
116
118 class AnimatedModel : public Model{
119 public:
120 AnimatedModel(void):Model(){
121 animationIndex = 0;
122 };
123
125 void SetAnimationIndex(int index){ animationIndex = index; };
127 int GetAnimationIndex(void){ return animationIndex; };
128
129 private:
131 int animationIndex;
132 };
133 }
134
135 #endif
136
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/movingturtle.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
movingturtle.h
Go to the documentation of this file.
1 #ifndef MOVINGTURTLE_H_
2 #define MOVINGTURTLE_H_
3
4 #include "abstractturtle.h"
5
6 namespace AP_LSystem {
7 class MovingTurtle : public AbstractTurtle
8 {
9 protected:
10 virtual int makeRotate( osg::Quat & );
11 virtual int preRotate() { return 0; }
12 virtual int postRotate() { return 0; }
13
19 virtual int doStep( double dist );
20
26 virtual int drawStep( double );
27
32 virtual int preStep(){ return 0; }
33
38 virtual int postStep(){ return 0; }
39
40 virtual void drawFrame( osg::Matrixd &, osg::Vec4d * = NULL);
41
46 virtual void adjustMatrices( );
47 public:
48 //****************************************************************
49 //** ROTATION **
50 //****************************************************************
51 virtual int turnLeft(std::vector<Parameter> & p);
52 virtual int turnRight(std::vector<Parameter> & p);
53 virtual int pitchDown(std::vector<Parameter> & p);
54 virtual int pitchUp(std::vector<Parameter> & p);
55 virtual int rollLeft(std::vector<Parameter> & p);
56 virtual int rollRight(std::vector<Parameter> & p);
57
58 virtual int turnArround();
59 virtual int rollArround();
60 virtual int rollUntilHorizontal();
61 virtual int randomTurnPitchRoll(std::vector<Parameter> & p);
62
63 //****************************************************************
64 //** CHANGE PROPERTIES **
65 //****************************************************************
66 virtual int multiplyLength(std::vector<Parameter> & p);
67 virtual int multiplyRadius(std::vector<Parameter> & p);
68 virtual int multiplyAngle(std::vector<Parameter> & p);
69 virtual int multiplyTropismElasticity(std::vector<Parameter> & p);
70 virtual int multiplyGravitropismElasticity(std::vector<Parameter> & p);
71
72 //****************************************************************
73 //** MOVEMENT **
74 //****************************************************************
75 virtual int drawForward(std::vector<Parameter> & p);
76 virtual int drawForwardHalf( );
77 virtual int moveForward(std::vector<Parameter> & p);
78 virtual int moveForwardHalf( );
79 };
80 }
81
82 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
mvect.h
Go to the documentation of this file.
1 /* mvect - movement vector
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.2 21.11.2002
4 */
5 #ifndef _MVECT_
6 #define _MVECT_
7
8 #include "gm.h"
9
10 namespace mv{
11
12 struct CPoint{
13 gmVector3 Pos;
14 //bool Relativ; //true relative, false absolute
15 bool Movable; //true relative, false absolute
16 // double Velocity; //velocity at control point
17 double WTime; //wait time
18 //int Control;
19 };
20
21 //enum _VType {ABS,REL,POINT}; //vector type .. absolute (P+V), relative (V), point (P)
22 //typedef enum _VType VTYPE; //vector type .. absolute (P+V), relative (V), point (P)
23
24 class CMVect{
25 // CPoint *PBeg; //first point of vector
26 // CPoint *PEnd; //last point of vector
27 gmVector3 Vect; //vector itself (PEnd - PBeg, but could be relative)
28 bool Once; //play once (and remove) if true, else play many times
30
31 double V0; //starting velocity
32 double V1; //ending velocity
33
34 // VTYPE VType; //vector type (absolute, relative, point)
35 public:
36 /*
37 CMVect();//
38 */
39 CMVect(gmVector3 newvect, double newv0=1, double newv1=1, bool newonce=false);
40 CMVect(double nx=0, double ny=0, double nz=0, double newv0=1, double newv1=1, bool newonce=false);
41 // CMVect(CPoint *NewPBeg);
42 // CMVect(CPoint *NewPBeg,Point *NewPEnd,gmVector3 Vect, VTYPE newvtype);
43 CMVect(CMVect &OtherVector);
44 ~CMVect();
45
46 // VTYPE getVType();
47 // void setVType(VTYPE val);
48 // CPoint* getPBeg();
49 // CPoint* getPEnd();
50 void setOnce(bool newonce) {Once = newonce;}; //deprecated
51 bool getOnce() {return Once;}; //deprecated
52 void setV0(double newv0) {V0 = newv0;};
53 double getV0() {return V0;};
54 void setV1(double newv1) {V1 = newv1;};
55 double getV1(){return V1;};
56 void setVect(gmVector3 newvect) {Vect=newvect;};
57 gmVector3 getVect() {return Vect;};
58 gmVector3 Eval(double p); //position on vector by param from <0,1>
59
60 double Length() {return Vect.length();};
61 };
62
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/mvect++.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
mvect++.h
Go to the documentation of this file.
1 /* mvect++ - C++ mvector library
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.2 22.11.2002
4 */
5 /*
6 some changes made to player 30.3.2005
7 */
8
9 #ifndef _MVECT_LIB_
10 #define _MVECT_LIB_
11
12 #include "mvect.h"
13 #include "gesture.h"
14 #include "player.h"
15 #include "reader.h"
16 #include "collection.h"
17
18 #include "gm.h"
19
20 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ConnectEditor/normal.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ConnectEditor
normal.h
Go to the documentation of this file.
1 #ifndef NORMAL_H
2 #define NORMAL_H
3
4 #include <vrecko/EnvironmentObject.h>
5 #include "functions.h"
6
7 using namespace osg;
8 using namespace vrecko;
9
10 //recompute all normals in object
11 bool recomputeNormals(EnvironmentObject *eo);
12
13 //spocte vektor ze dvou bodu
14 Vec3 Vector(Vec3 a, Vec3 b);// Výpoèet vektoru mezi dvìma body
15
16 //vypocita vektorovy soucin dvou vektoru
17 Vec3 Cross(Vec3 a, Vec3 b);// Vektorový souèin
18
19 //spocita vse v jedne funkci za pomoci predchozich
20 Vec3 CalculateVector(Vec3 a, Vec3 b, Vec3 c);
21
22 //get Angle of triangle
23 float getAngle(osg::Vec3 A, osg::Vec3 B, osg::Vec3 C);
24
25 #endif //NORMAL_H
26
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QSection.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
osgQ_QSection.h
Go to the documentation of this file.
1 #ifndef OSGQ_QSECTION
2 #define OSGQ_QSECTION
3
4 #include <osg/Shape>
5
6 namespace osgQ {
7
8 class QSection;
9
10 class QShapeVisitor
11 {
12 public:
13 QShapeVisitor() {}
14 virtual ~QShapeVisitor() {}
15 virtual void apply(const QSection&) {}
16 };
17
18
19 class QConstShapeVisitor : public osg::ConstShapeVisitor
20 {
21 public:
22 QConstShapeVisitor() {}
23 virtual ~QConstShapeVisitor() {}
24 virtual void apply(const QSection&) {}
25 };
26
27 class QSection : public osg::Shape
28 {
29 public:
30
31 QSection():
32 _center(0.0f,0.0f,0.0f),
33 _outerRadius(1.0f),
34 _innerRadius(0.5f),
35 _angleFrom(osg::PI / 4.0f),
36 _angleTo(osg::PI * 3.0f / 4.0f),
37 _outerAngleAddition(0.0f),
38 _height(1.0f) {}
39
40 QSection(const osg::Vec3& center,float innerRadius,float outerRadius,
41 float angleFrom,float angleTo,float outerAngleAddition,float height):
42 _center(center),
43 _outerRadius(outerRadius),
44 _innerRadius(innerRadius),
45 _angleFrom(angleFrom),
46 _angleTo(angleTo),
47 _outerAngleAddition(0.0f),
48 _height(height) {}
49
50 QSection(const QSection& qsection,const osg::CopyOp& copyop=osg::CopyOp::SHALLOW_COPY):
51 osg::Shape(qsection,copyop),
52 _center(qsection._center),
53 _outerRadius(qsection._outerRadius),
54 _innerRadius(qsection._innerRadius),
55 _angleFrom(qsection._angleFrom),
56 _angleTo(qsection._angleTo),
57 _outerAngleAddition(qsection._outerAngleAddition),
58 _height(qsection._height),
59 _rotation(qsection._rotation) {}
60
61
62 virtual osg::Object* cloneType() const { return new QSection(); }
63 virtual osg::Object* clone(const osg::CopyOp& copyop) const { return new QSection (*this,copyop); }
64 virtual bool isSameKindAs(const osg::Object* obj) const { return dynamic_cast<const QSection *>(obj)!=NULL; }
65 virtual const char* libraryName() const { return "osgq"; }
66 virtual const char* className() const { return "QSection"; }
67
68 virtual void accept(osg::ShapeVisitor& sv) { (dynamic_cast< QShapeVisitor *>(&sv))->apply(*this); }
69 virtual void accept(osg::ConstShapeVisitor& csv) const { (dynamic_cast< QConstShapeVisitor *>(&csv))->apply(*this); }
70
71 // virtual void accept(QShapeVisitor& sv) { sv.apply(*this); }
72 // virtual void accept(QConstShapeVisitor& csv) const { csv.apply(*this); }
73
74 inline bool valid() const { return ((_innerRadius>=0.0f) && (_outerRadius >= _innerRadius) && (_angleFrom <= _angleTo)); }
75
76 inline void set(const osg::Vec3& center,float outerRadius,float innerRadius,
77 float angleFrom,float angleTo,float outerAngleAddition,float height)
78 {
79 _center = center;
80 _outerRadius = outerRadius;
81 _innerRadius = innerRadius;
82 _angleFrom = angleFrom;
83 _angleTo = angleTo;
84 _outerAngleAddition = outerAngleAddition;
85 _height = height;
86 }
87
88 inline void setCenter(const osg::Vec3& center) { _center = center; }
89 inline const osg::Vec3& getCenter() const { return _center; }
90
91 inline void setOuterRadius(float outerRadius) { _outerRadius = outerRadius; }
92 inline float getOuterRadius() const { return _outerRadius; }
93
94 inline void setInnerRadius(float innerRadius) { _innerRadius = innerRadius; }
95 inline float getInnerRadius() const { return _innerRadius; }
96
97 inline void setAngleFrom(float angleFrom) { _angleFrom = angleFrom; }
98 inline float getAngleFrom() const { return _angleFrom; }
99
100 inline void setAngleTo(float angleTo) { _angleTo = angleTo; }
101 inline float getAngleTo() const { return _angleTo; }
102
103 inline void setOuterAngleAddition(float outerAngleAddition) { _outerAngleAddition = outerAngleAddition; }
104 // half of this addition will be added to [angleFrom] and half of it to [angleTo]
105 // (only on the outer side of the section)
106 inline float getOuterAngleAddition() const { return _outerAngleAddition; }
107
108 inline void setHeight(float height) { _height = height; }
109 inline float getHeight() const { return _height; }
110
111 inline void setRotation(const osg::Quat& quat) { _rotation = quat; }
112 inline const osg::Quat& getRotation() const { return _rotation; }
113 inline osg::Matrix computeRotationMatrix() const { return osg::Matrix(_rotation); }
114 bool zeroRotation() const { return _rotation.zeroRotation(); }
115
116 inline int computeNumberOfSegments() const;
117
118 protected:
119 virtual ~QSection() {}
120
121 osg::Vec3 _center;
122 float _outerRadius;
123 float _innerRadius;
124 float _angleFrom;
125 float _angleTo;
126 float _outerAngleAddition;
127 float _height;
128 osg::Quat _rotation;
129 };
130
131
132 int QSection::computeNumberOfSegments() const
133 {
134 int n = (int) (_outerRadius * (_angleTo - _angleFrom) * (20.0f / osg::PI));
135 return (n < 0) ? 0 : n;
136 }
137
138 }
139
140 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Menu/osgQ_QShapeDrawable.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Menu
osgQ_QShapeDrawable.h
Go to the documentation of this file.
1 #ifndef OSGQ_QSHAPEDRAWABLE_H
2 #define OSGQ_QSHAPEDRAWABLE_H
3
4 #include <osg/ShapeDrawable>
5 #include <osg/RenderInfo>
6
7 namespace osgQ {
8
9 class QShapeDrawable : public osg::ShapeDrawable {
10 public:
11 QShapeDrawable(osg::Shape* shape, osg::TessellationHints* hints=0) : osg::ShapeDrawable(shape, hints) {}
12
13 virtual void drawImplementation(osg::RenderInfo& renderInfo) const;
14 virtual void accept(osg::PrimitiveFunctor& pf) const;
15 virtual osg::BoundingBox computeBound() const;
16 };
17
18 }
19 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: Related Pages

Related Pages
Here is a list of all related documentation pages:
o Dynamic Art module
o L-system plant modeler - module for Vrecko
o Head Up Display module
o Space Partitioning - module for Vrecko
o Todo List
\ Deprecated List
Generated on Sun Feb 17 2013 23:30:16 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/par2lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
par2lsystem.h
Go to the documentation of this file.
1 #ifndef PAR2LSYSTEM_H_
2 #define PAR2LSYSTEM_H_
3
4 #include "abstractklsystem.h"
5
6 namespace AP_LSystem {
10 class Par2LSystem : public AbstractkLSystem
11 {
12 private:
13 static const unsigned int capabilities = LS_2L | LS_DETERMINISTIC | LS_PARAMETRIC;
14 public:
15 Par2LSystem( AbstractFile * );
16 virtual void processPredecessor(Rule &, string *, string::iterator &);
17 virtual void processRuleSuccessor(Rule &, string *, string::iterator &);
18 virtual void processHomomorphismSuccessor(Rule &, string *, string::iterator &);
19 virtual multimap<char, Rule>::iterator * selectRule(multimap<char, Rule>::iterator &,
20 multimap<char, Rule>::iterator &,
21 LongString *,
22 unsigned int &,
23 double *);
24
25 static bool isCapable( unsigned int type )
26 {
27 if( ( type & capabilities ) == type )
28 return true;
29 else
30 return false;
31 }
32
36 boost::shared_ptr<AbstractLSystem> clone() const
37 {
38 return boost::shared_ptr<AbstractLSystem>( new Par2LSystem(*this) );
39 }
40 };
41 }
42
43 #endif // PAR2LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/pard0lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
pard0lsystem.h
Go to the documentation of this file.
1 #ifndef PARD0LSYSTEM_H_
2 #define PARD0LSYSTEM_H_
3
4 #include "abstract0lsystem.h"
5
6 namespace AP_LSystem {
7 class ParD0LSystem : public Abstract0LSystem
8 {
9 private:
10 static const unsigned int capabilities = LS_0L | LS_DETERMINISTIC | LS_PARAMETRIC;
11 public:
12 ParD0LSystem( AbstractFile * );
13
14 static bool isCapable( unsigned int type )
15 {
16 if( ( type & capabilities ) == type )
17 return true;
18 else
19 return false;
20 }
21 };
22 }
23 #endif // PARD0LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parseablestring.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
parseablestring.h
Go to the documentation of this file.
1 #ifndef PARSEABLESTRING_H_
2 #define PARSEABLESTRING_H_
3
4 #include <vector>
5 #include "utils.h"
6 #include "longstring.h"
7 #include <iostream>
8
9 namespace AP_LSystem {
10 class ParseableString
11 {
12 private:
13 unsigned m_Pos;
14 bool m_Eof;
15 protected:
16 char * m_Str;
17 unsigned m_Length;
18 public:
23 ParseableString( LongString * string);
24
30 ParseableString( char * string, unsigned int length);
31
35 ParseableString( const ParseableString & );
36
40 ParseableString & operator=( const ParseableString & );
41
45 friend std::basic_ostream<char> & operator<<(std::basic_ostream<char> & os, const ParseableString ps);
46
51 inline bool eof()
52 {
53 return m_Eof;
54 }
55
59 inline void reset()
60 {
61 m_Pos = 0;
62 m_Eof = false;
63 }
64
70 char next( std::vector<Parameter> & parameters );
71 };
72
73 std::basic_ostream<char> & operator<<(std::basic_ostream<char> & os, const ParseableString ps);
74 }
75 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/parstoch0lsystem.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
parstoch0lsystem.h
Go to the documentation of this file.
1 #ifndef PARSTOCH0LSYSTEM_H_
2 #define PARSTOCH0LSYSTEM_H_
3
4 #include "abstract0lsystem.h"
5
6 namespace AP_LSystem {
10 class ParStoch0LSystem : public Abstract0LSystem
11 {
12 private:
13
17 static const unsigned int capabilities = LS_0L | LS_DETERMINISTIC | LS_STOCHASTIC | LS_PARAMETRIC;
18 public:
19 ParStoch0LSystem( AbstractFile * );
20 ParStoch0LSystem( const ParStoch0LSystem & );
21 ParStoch0LSystem & operator=( const ParStoch0LSystem & );
22
36 virtual multimap<char, Rule>::iterator * selectRule(multimap<char, Rule>::iterator & begin,
37 multimap<char, Rule>::iterator & end,
38 LongString * word,
39 unsigned int & pos,
40 double * parameters);
41
48 static bool isCapable( unsigned int type )
49 {
50 if( ( type & capabilities ) == type )
51 return true;
52 else
53 return false;
54 }
55
59 boost::shared_ptr<AbstractLSystem> clone() const
60 {
61 return boost::shared_ptr<AbstractLSystem>( new ParStoch0LSystem(*this) );
62 }
63 };
64 }
65
66 #endif // PARSTOCH0LSYSTEM_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/player.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
player.h
Go to the documentation of this file.
1 /* player - player for collection of gestures (lists of mvectors)
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.3 30.03.2005
4 *
5 * Delta changed -> compute exact delta time //nothing changed in this file, only in cpp
6 *
7 * v0.0.4 10.10.2005
8 * Step is split in
9 * Step_forward, Step_backward
10 */
11 #ifndef _PLAYER_
12 #define _PLAYER_
13
14 #include "collection.h"
15 #include <vector>
16
17
18 namespace mv{
19 #define DEFAULT_FREQ 5000
20
21 //enum DirT={BACKWARD,FORWARD};
22
23 class CPlayer{
24 //MVectList *ActList; //actual list of mvectors
25 //CCollection *ActCollection; //actual list of gestures
26 //CMVect *ActVect; //actual mvector
27 long int ActGesture; //actual
28 long int ActVect; //actual mvector
29 gmVector3 ActPos; //actual position
30 gmVector3 ActVel; //actual velocity, actual only in start or end of vect, user for smooth connection of mvectors
31 gmVector3 StartPos; //starting position on actual vector (for recomputing relative position)
32 double ActT; //actual time on vector
33 bool Loop; //play in loop
34 bool All; //play all/one
35 bool Play; //true for play, false for stop
36 bool Pause; //simply pause playing
37 bool Force; //true for return force, false for return position
38 bool Direction; //true for forward, false for backward
39 unsigned int Freq; //playing frequency
40 double Delta; //playing time - we can compute it from frequency, but better is to measure it
41
42 public:
43 std::vector <CGesture *> ActCollection; //actual list of gestures
44
45 CPlayer();
46 // CPlayer(CCollection *newcollection);
47 ~CPlayer();
48
49 // void addCollection(CCollection *newcollection);
50 // void removeCollection();
51 void addGesture(CGesture *newgesture);
52 void delGesture();
53 void delAllGestures();
54
55 // void delAllVect();
56 // void delVectFromActToEnd();
57 // void delVectFromActToHead();
58 // void splitVect(); //create two vector from act vector
59
60 // CMVect *getActVect();
61 // CCollection *getActCollection() {return ActCollection;};
62 gmVector3 getActPos() {return ActPos;}
63 gmVector3 getActVel() {return ActVel;}
64 unsigned int getActGesture() {return ActGesture;}; //info only
65 unsigned int getActVect() {return ActVect;}; //info only
66 double getActT() {return ActT;}; //info only
67 bool getLoop() {return Loop;} std::vector <CGesture *>::iterator i;
68
69 void setLoop(bool val) {Loop = val;}
70 bool getAll() {return All;}
71 void setAll(bool val) {All = val;}
72 bool getPlay() {return Play;}
73 void setPlay(bool val) {Play = val;}
74 bool getPause() {return Pause;}
75 void setPause(bool val) {Pause = val;}
76 bool getForce() {return Force;}
77 void setForce(bool val) {Force = val;}
78 bool getDirection() {return Direction;}
79 //void setDirection(DirT val) {Direction = val;}
80 void setDirection(bool val) {Direction = val;}
81
82
83 gmVector3 ControlPosition(gmVector3 Pos); //control if Pos is in workspace, return projection to workspace
84 gmVector3 ComputeForce(gmVector3 DevicePos, gmVector3 DeviceVel, gmVector3 Pos); //compute force from device position and velocity and act position on mvector
85
86 gmVector3 Step_forward(gmVector3 &r,double &wtime,bool &rflag,double &p,double &v0, double &v1, double &l); //go to next vector, gesture
87 gmVector3 Step_backward(gmVector3 &r,double &wtime,bool &rflag,double &p,double &v0, double &v1, double &l); //go to previous vector, gesture
88 gmVector3 Step(); //return only pos //for animation
89 gmVector3 Step(gmVector3 DevicePos,gmVector3 DeviceVel); //return position or force
90
91 /*
92 gmVector3 PosPlayAll(); //go through whole list of mvector, return position
93 gmVector3 PosPlayAct(); //play only act mvector, return position
94 gmVector3 ForcePlayAll(); //go through whole list of mvector, return force
95 gmVector3 ForcePlayAct(); //play only act mvector, return force
96 */
97
98 };
99
100 double ActTtoP(double t,double v0, double v1,double l); //from ActT (actual time on vector) to param in <0,1>
101
102 double PtoActT(double p,double v0, double v1,double l); //form param in <0,1> to ActT (actual time on vector)
103
104 }//namespace mv
105 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/query.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
query.h
Go to the documentation of this file.
1 #ifndef QUERY_H_
2 #define QUERY_H_
3
4 #include "queryinterpret.h"
5
6 namespace AP_LSystem {
11 class Query
12 {
13 private:
14 // dont create an instances
15 Query(){};
16 public:
20 static double positionX( const double * )
21 {
22 return QueryInterpret::get()->positionX();
23 }
24
28 static double positionY( const double * )
29 {
30 return QueryInterpret::get()->positionY();
31 }
32
36 static double positionZ( const double * )
37 {
38 return QueryInterpret::get()->positionZ();
39 }
40
44 static double headingX( const double * )
45 {
46 return QueryInterpret::get()->headingX();
47 }
48
52 static double headingY( const double * )
53 {
54 return QueryInterpret::get()->headingY();
55 }
56
60 static double headingZ( const double * )
61 {
62 return QueryInterpret::get()->headingZ();
63 }
64
68 static double upX( const double * )
69 {
70 return QueryInterpret::get()->upX();
71 }
72
76 static double upY( const double * )
77 {
78 return QueryInterpret::get()->upY();
79 }
80
84 static double upZ( const double * )
85 {
86 return QueryInterpret::get()->upZ();
87 }
88
92 static double leftX( const double * )
93 {
94 return QueryInterpret::get()->leftX();
95 }
96
100 static double leftY( const double * )
101 {
102 return QueryInterpret::get()->leftY();
103 }
104
108 static double leftZ( const double * )
109 {
110 return QueryInterpret::get()->leftZ();
111 }
112 };
113 }
114
115 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryinterpret.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
queryinterpret.h
Go to the documentation of this file.
1 #ifndef QUERYINTERPRET_H_
2 #define QUERYINTERPRET_H_
3
4 #include "abstractinterpret.h"
5 #include "lsgeode.h"
6 #include "log.h"
7
8 namespace AP_LSystem {
9 class QueryInterpret : public AbstractInterpret
10 {
11 private:
12 static QueryInterpret * interpret;
13 osg::Matrixd matrix;
14
19 unsigned dirty;
20
21 LongString * word;
22
26 enum dirtyBits
27 {
28 CLEAR = 0x00000000,
29 POSITION = 0x0000000F,
30 POSITIONX = 0x00000001,
31 POSITIONY = 0x00000002,
32 POSITIONZ = 0x00000004,
33 HEADING = 0x000000F0,
34 HEADINGX = 0x00000010,
35 HEADINGY = 0x00000020,
36 HEADINGZ = 0x00000040,
37 UP = 0x00000F00,
38 UPX = 0x00000100,
39 UPY = 0x00000200,
40 UPZ = 0x00000400,
41 LEFT = 0x0000F000,
42 LEFTX = 0x00001000,
43 LEFTY = 0x00002000,
44 LEFTZ = 0x00004000,
45 DIRTY = 0xFFFFFFFF,
46 };
47
51 QueryInterpret()
52 {
53 // create group for geodes
54 m_Owner = new osg::Group();
55
56 word = NULL;
57
58 createGeodes();
59
60 dirty = QueryInterpret::DIRTY;
61
62 for( vector<LSGeode *>::iterator it = m_Geodes.begin(); it != m_Geodes.end(); it++ )
63 {
64 (*it)->setTurtleType( LS_TURTLE_QUERY );
65 }
66 };
67
71 void update()
72 {
73 ParseableString * pW = new ParseableString( word );
74
75 if(!pW)
76 return;
77
78 parse( pW );
79 }
80
81 virtual int parse( ParseableString * word);
82
83 ~QueryInterpret(void);
84
85 public:
89 static QueryInterpret * get()
90 {
91 if(!interpret) interpret = new QueryInterpret();
92
93 return interpret;
94 }
95
96
100 double positionX( )
101 {
102 if( dirty & QueryInterpret::POSITIONX )
103 {
104 // update matrix
105 update();
106
107 // set Position as CLEAR
108 dirty &= ~QueryInterpret::POSITION;
109 }
110 dirty |= QueryInterpret::POSITIONX;
111
112 Log::get()->incQueryCounter();
113
114 return matrix.getTrans().x();
115 }
116
120 double positionY( )
121 {
122 if( dirty & QueryInterpret::POSITIONY )
123 {
124 // update matrix
125 update();
126
127 // set Position as CLEAR
128 dirty &= ~QueryInterpret::POSITION;
129 }
130 dirty |= QueryInterpret::POSITIONY;
131
132 Log::get()->incQueryCounter();
133
134 return matrix.getTrans().y();
135 }
136
140 double positionZ( )
141 {
142 if( dirty & QueryInterpret::POSITIONZ )
143 {
144 // update matrix
145 update();
146
147 // set Position as CLEAR
148 dirty &= ~QueryInterpret::POSITION;
149 }
150 dirty |= QueryInterpret::POSITIONZ;
151
152 Log::get()->incQueryCounter();
153
154 return matrix.getTrans().z();
155 }
156
160 double headingX( )
161 {
162 if( dirty & QueryInterpret::HEADINGX )
163 {
164 // update matrix
165 update();
166
167 // set Position as CLEAR
168 dirty &= ~QueryInterpret::HEADING;
169 }
170 dirty |= QueryInterpret::HEADING;
171
172 osg::Vec3d v = matrix.getRotate() * HeadVec;
173
174 Log::get()->incQueryCounter();
175
176 return v.x();
177 }
178
182 double headingY( )
183 {
184 if( dirty & QueryInterpret::HEADINGY )
185 {
186 // update matrix
187 update();
188
189 // set Position as CLEAR
190 dirty &= ~QueryInterpret::HEADING;
191 }
192 dirty |= QueryInterpret::HEADING;
193
194 osg::Vec3d v = matrix.getRotate() * HeadVec;
195
196 Log::get()->incQueryCounter();
197
198 return v.y();
199 }
200
204 double headingZ( )
205 {
206 if( dirty & QueryInterpret::HEADINGZ )
207 {
208 // update matrix
209 update();
210
211 // set Position as CLEAR
212 dirty &= ~QueryInterpret::HEADING;
213 }
214 dirty |= QueryInterpret::HEADING;
215
216 osg::Vec3d v = matrix.getRotate() * HeadVec;
217
218 Log::get()->incQueryCounter();
219
220 return v.z();
221 }
222
226 double upX( )
227 {
228 if( dirty & QueryInterpret::UPX )
229 {
230 // update matrix
231 update();
232
233 // set Position as CLEAR
234 dirty &= ~QueryInterpret::UP;
235 }
236 dirty |= QueryInterpret::UP;
237
238 osg::Vec3d v = matrix.getRotate() * UpVec;
239
240 Log::get()->incQueryCounter();
241
242 return v.x();
243 }
244
248 double upY( )
249 {
250 if( dirty & QueryInterpret::UPY )
251 {
252 // update matrix
253 update();
254
255 // set Position as CLEAR
256 dirty &= ~QueryInterpret::UP;
257 }
258 dirty |= QueryInterpret::UP;
259
260 osg::Vec3d v = matrix.getRotate() * UpVec;
261
262 Log::get()->incQueryCounter();
263
264 return v.y();
265 }
266
270 double upZ( )
271 {
272 if( dirty & QueryInterpret::UPZ )
273 {
274 // update matrix
275 update();
276
277 // set Position as CLEAR
278 dirty &= ~QueryInterpret::UP;
279 }
280 dirty |= QueryInterpret::UP;
281
282 osg::Vec3d v = matrix.getRotate() * UpVec;
283
284 Log::get()->incQueryCounter();
285
286 return v.z();
287 }
288
292 double leftX( )
293 {
294 if( dirty & QueryInterpret::LEFTX )
295 {
296 // update matrix
297 update();
298
299 // set Position as CLEAR
300 dirty &= ~QueryInterpret::LEFT;
301 }
302 dirty |= QueryInterpret::LEFT;
303
304 osg::Vec3d v = matrix.getRotate() * LeftVec;
305
306 Log::get()->incQueryCounter();
307
308 return v.x();
309 }
310
314 double leftY( )
315 {
316 if( dirty & QueryInterpret::LEFTY )
317 {
318 // update matrix
319 update();
320
321 // set Position as CLEAR
322 dirty &= ~QueryInterpret::LEFT;
323 }
324 dirty |= QueryInterpret::LEFT;
325
326 osg::Vec3d v = matrix.getRotate() * LeftVec;
327
328 Log::get()->incQueryCounter();
329
330 return v.y();
331 }
332
336 double leftZ( )
337 {
338 if( dirty & QueryInterpret::LEFTZ )
339 {
340 // update matrix
341 update();
342
343 // set Position as CLEAR
344 dirty &= ~QueryInterpret::LEFT;
345 }
346 dirty |= QueryInterpret::LEFT;
347
348 osg::Vec3d v = matrix.getRotate() * LeftVec;
349
350 Log::get()->incQueryCounter();
351
352 return v.z();
353 }
354
358 void bindWord( LongString * str)
359 {
360 word = str;
361 matrix.makeIdentity();
362 }
363
364 };
365 }
366
367 #endif
368
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/queryturtle.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
queryturtle.h
Go to the documentation of this file.
1 #ifndef QUERYTURTLE_H_
2 #define QUERYTURTLE_H_
3
4 #include "movingturtle.h"
5
6 namespace AP_LSystem {
10 class QueryTurtle : public MovingTurtle
11 {
12 public:
13 QueryTurtle(void){};
14 ~QueryTurtle(void){};
15
16 virtual int initialize( )
17 {
18 return LS_OK;
19 }
20 virtual int finalize( )
21 {
22 return LS_OK;
23 }
24 };
25 }
26
27
28 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomindex.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
randomindex.h
Go to the documentation of this file.
1 #ifndef RANDOMINDEX_H_
2 #define RANDOMINDEX_H_
3
4 #include <vector>
5 #include <cstdlib>
6 #include <ctime>
7 #include "configuration.h"
8
9 using namespace boost::program_options;
10
11 namespace AP_LSystem {
15 class RandomIndex
16 {
17 private:
18 std::vector<double> probabilities;
19 double sum;
20 public:
24 static void init()
25 {
26 const variable_value * seed = Configuration::get()->getProperty( "RandomSeed" );
27 if( seed )
28 {
29 srand( seed->as<unsigned int>() );
30 }
31 else
32 {
33 srand( time( NULL ) );
34 }
35 }
36
40 RandomIndex()
41 {
42 sum = 0;
43 }
44
49 void addProbability( double p )
50 {
51 probabilities.push_back( sum + p );
52 sum += p;
53 }
54
59 unsigned int getRandomIndex()
60 {
61 double r = (static_cast<double>(rand() % 100)) * sum / 100.0f;
62
63 for(std::vector<double>::iterator it = probabilities.begin(); it != probabilities.end()-1; it++)
64 {
65 if( *it >= r )
66 {
67 return it - probabilities.begin();
68 }
69 }
70
71 return probabilities.size( ) - 1;
72 }
73 };
74 }
75 #endif // RANDOMINDEX_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/randomizer.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
randomizer.h
Go to the documentation of this file.
1 #ifndef RANDOMIZER_H_
2 #define RANDOMIZER_H_
3
4 #include <vector>
5 #include <cstdlib>
6 #include <ctime>
7 #include "configuration.h"
8
9 using namespace boost::program_options;
10
11 namespace AP_LSystem {
15 class Randomizer
16 {
17 public:
21 static void init()
22 {
23 const variable_value * seed = Configuration::get()->getProperty( "RandomSeed" );
24 if( seed )
25 {
26 srand( seed->as<unsigned int>() );
27 }
28 else
29 {
30 srand( time( NULL ) );
31 }
32 }
33
39 static double get( unsigned int maxPercents )
40 {
41 return 1 + (((rand()%2)?(-1):(1)) * (static_cast<double>(rand() % (maxPercents*10)) / 1000.0f));
42 }
43
50 static double get( const double * max )
51 {
52 return get( static_cast<unsigned>(abs(*max)) );
53 }
54 };
55 }
56
57 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/reader.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
reader.h
Go to the documentation of this file.
1 /* reader - read collections, gestures and mvectors
2 * Ludek Pokluda, xpokluda@fi.muni.cz
3 * v0.0.2 22.11.2002
4 */
5 #ifndef _READER_
6 #define _READER_
7
8 #include "collection.h"
9 #include "gesture.h"
10 #include "mvect.h"
11
12 namespace mv{
13
14 class Reader{
15 public:
16 Reader();
17 Reader(const char*filename);
18 ~Reader();
19
20 void Load(const char*filename);
21 void Save(const char*filename);
22 };
23
24 }
25
26 #endif
Generated on Sun Feb 17 2013 23:29:48 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rectangle.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
rectangle.h
Go to the documentation of this file.
1 #ifndef RECTANGLE_H_
2 #define RECTANGLE_H_
3
4 #include "movingturtle.h"
5
6 namespace AP_LSystem {
10 class Rectangle : public MovingTurtle
11 {
12 private:
13
14 public:
15 Rectangle(void){};
16 ~Rectangle(void){};
17
21 virtual int drawStep( double dist );
22
23 virtual int initialize( ) {return LS_OK;}
24 virtual int finalize( ) {return LS_OK;}
25 };
26 }
27
28 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/rule.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
rule.h
Go to the documentation of this file.
1 #ifndef RULE_H_
2 #define RULE_H_
3
4 #include <vector>
5 #include "fparser/fparser.hh"
6 #include "staticstring.h"
7
8 using std::string;
9
10 namespace AP_LSystem {
14 struct Rule
15 {
16 char strictPredecessor;
17 FunctionParser* condition;
18 std::string variables;
19 FunctionParser * probabilityFactor;
20 std::vector<StaticString*> staticStrings;
21 std::vector<FunctionParser*> dynamicStrings;
22 string leftContext;
23 string rightContext;
24
28 Rule():condition(NULL),variables(""),probabilityFactor(NULL), leftContext(""), rightContext(""){}
29
33 Rule(const Rule &);
34
38 Rule& operator=( const Rule & );
39
43 ~Rule();
44
50 void processProbabilityFactor(string * rule, string::iterator & it);
51
57 void processCondition(string * rule, string::iterator & it);
58
64 void processParameters(string * rule, string::iterator & it);
65
73 bool addStaticString(string * rule, string::iterator & it);
74
80 void addDynamicString(string * rule, string::iterator & it);
81
87 bool evaluateCondition( double * p );
88
89 private:
97 void addQueryFunctions( FunctionParser * expression, string & expressionString);
98 };
99 }
100
101 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/Icon.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
Icon.h
Go to the documentation of this file.
1 #ifndef _DA_ICON_H
2 #define _DA_ICON_H
3
4 #include "PoB.h"
5 #include "Icon.h"
6
7 using namespace vrecko;
8
10 typedef enum IconType {
11 ICON__BUTTON = 1,
12 ICON__SWITCH,
13 ICON__MULTISWITCH,
14 };
15
17
26 class Icon : public PoB
27 {
28 public:
29
30 Icon();
31 ~Icon();
32
33 void clicked();
34
35 int load(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* IconNode);
36
37 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
38
39 void postInitialize();
40
41 void pointed(bool pointed);
42
43 void save(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument* Document, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode* IconNode) ;
44
46 /*
47 * traverse node structure, find sub-node with given name
48 * change color (material) of founded sub-node
49 *
50 * \param partName name of geometry-part (Cinema4D export function cuts the object names to a length of up to eight characters)
51 * \param newColor pointer to new color (and transparency) of part. if newColor == NULL, original color is used/restored
52 */
53 void setColorofPart(std::string partName, osg::Vec4* newColor);
54
55 virtual void update();
56
57 protected:
58
60 IconType type;
61
63 bool defaultState;
64
66 //TODO what about materials?
67 osg::Vec4 originalColor;
68
69 // Name of part of 3D model which will change color (i.e. during pointing)
70 std::string colorablePartName;
71 };
72
73
74 #endif // _DA_ICON_H
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/Sphere.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
Sphere.h
Go to the documentation of this file.
1 #ifndef Sphere_h
2 #define Sphere_h
3
4 #include <vrecko/Ability.h>
5 #include <osg/Vec3>
6
7 #include "BaseActor.h"
8
9
10 using namespace vrecko;
11
12
13 namespace PhysXPlugin
14 {
15 class Sphere : public BaseActor
16 {
17 public:
18 Sphere();
19 ~Sphere();
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 protected:
25 void Create();
26 NxSphereShapeDesc _sphereDesc;
27 };
28 }
29
30 #endif
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Avatar.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Avatar.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2
3 #include <vrecko/EnvironmentObject.h>
4 #include <vrecko/World.h>
5
6
7 using namespace vrecko;
8 namespace VirtualFixture { //namespace of VirtualFixture plugin!!! we use own avatar, not base one
9
10 class Avatar: public Ability {
11 public:
12 Avatar();
13 ~Avatar() {};
14
15 // ------ BaseClass functions ------------------------
17 void processEvent(const std::string &input_name, void *value);
18 // ---------------------------------------------------
19
20 void preInitialize(void);
21 void postInitialize(void);
22 void update(void);
23
24 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
25 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
26
27 protected:
28 World::AvatarView *avatar_view;
29
30 EnvironmentObject *head;
31 EnvironmentObject *left_hand, *right_hand;
32 EnvironmentObject *left_leg, *right_leg;
33 EnvironmentObject *free_move_EO;
34
35 long int headEO_ID, leftHandEO_ID, rightHandEO_ID, freeMoveEO_ID;
36
37 EnvironmentObject *owner;
38 };
39
40 };
Generated on Sun Feb 17 2013 23:29:42 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Grid.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Grid.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3
4 using namespace vrecko;
5 using namespace vreckoDP_base;
6 namespace VirtualFixture{
7
8 class Grid: public PHANToMFilter {
9 public:
10 Grid();
11 ~Grid() {};
12
14 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
15 void processEvent(const std::string &input_name, void *value);
16
17 void preInitialize(void);
18 void postInitialize(void);
19 void update(void);
20
21 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
22 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
23
24 protected:
25 PHANToM *PHANToMDevice;
26 bool all_on;
27 bool active; //VF switcher
28 osg::Vec3 position; //position of starting point
29 osg::Vec3 vector; //vector on cylinder axis (from bottom to top)
30 float nullradius; //radius close to centre, where attractive field is NOT applied
31 float stiffness; //stiffness of attractive field = how strong it would be for every meter of space
32 float gravity; //gravity constant (continues linear field)
33 bool gravity_on; //gravity on/off
34 };
35
36 };
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Sphere.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Sphere.h
Go to the documentation of this file.
1 #include <vrecko/Ability.h>
2 #include <vreckoDP/base/PHANToM.h>
3 #include <osg/Vec4>
4 #include <osg/Geode>
5 #include <osg/MatrixTransform>
6 #include <osg/Group>
7
8
9 using namespace vrecko;
10 using namespace vreckoDP_base;
11 namespace VirtualFixture{
12
13 class Sphere: public PHANToMFilter {
14 public:
15 Sphere();
16 ~Sphere() {};
17
19 void apply(PHANToM *pPHANToM, osg::Vec3 &force);
20 void processEvent(const std::string &input_name, void *value);
21
22 void preInitialize(void);
23 void postInitialize(void);
24 void update(void);
25 void display(void); //show/hide object
26
27 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
28 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
29
30 protected:
31 PHANToM *PHANToMDevice;
32 bool all_on;
33 bool active; //if true, attractive field will be active
34
35 bool visible; //if geometric representation will be visible
36 osg::MatrixTransform *tnode; //transform node pointer
37 osg::Group *gnode; //group pointer
38 osg::Geode *node; //geometry node pointer (for bouning cylinder)
39 osg::Geode *node2; //geometry node2 pointer (for center cylinder)
40 osg::Vec4 color; //color of border sphere (radius)
41 osg::Vec4 color2; //color of inner sphere (nullradius)
42 float transparency; //border sphere transparency
43 float transparency2;//inner sphere transparency
44
45 osg::Vec3 position; //position of centre (the point where PHANToM will be attracted to)
46 float radius; //radius of attractive field
47 float nullradius; //radius close to center where attractive force is NOT applied
48 float stiffness; //force divided by meter
49 };
50
51 };
Generated on Sun Feb 17 2013 23:29:46 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/VF/Log.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • VF
Log.h
Go to the documentation of this file.
1 #ifndef VF_LOG
2 #define VF_LOG
3 #include <vrecko/Ability.h>
4
5 using namespace vrecko;
6 namespace VirtualFixture {
7
8 class Log: public Ability {
9 public:
10 Log();
11 ~Log() {};
12
13 // ------ BaseClass functions ------------------------
15 void processEvent(const std::string &input_name, void *value);
16 // ---------------------------------------------------
17
18 void preInitialize(void);
19 void postInitialize(void);
20 void update(void);
21
22 bool loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *pParametersNode);
23 XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *getXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *);
24
25 protected:
26 osg::Vec3 position; //for logging position -> set it first (eg. from Phantom), then log, when need it (event)
27 };
28
29 };
30 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/staticstring.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
staticstring.h
Go to the documentation of this file.
1 #ifndef STATICSTRING_H_
2 #define STATICSTRING_H_
3
4 #include <string>
5 #include <cstring>
6 #include "utils.h"
7 #include "longstring.h"
8
9 namespace AP_LSystem {
13 class StaticString
14 {
15 public:
16 char * str;
17 int length;
18
19 StaticString( const char * str, int length ):length(length)
20 {
21 this->str = new char[length];
22 memcpy( (void *) this->str, str, length);
23 }
24
25 StaticString( LongString * str)
26 {
27 this->length = str->length();
28 this->str = new char[length];
29 memcpy( (void *) this->str, str->getData(), length);
30 }
31
32 StaticString( char ch ):length(1)
33 {
34 this->str = new char[1];
35 this->str[0] = ch;
36 }
37
38 StaticString( std::string str )
39 {
40 this->length = str.length();
41 this->str = new char[length];
42 memcpy( (void *) this->str, str.c_str(), length);
43 }
44
45 StaticString( const StaticString & c )
46 {
47 this->length = c.length;
48 this->str = new char[this->length];
49 memcpy( (void *) this->str, c.str, this->length);
50 }
51
52 StaticString& operator=( const StaticString & c )
53 {
54 this->length = c.length;
55 this->str = new char[this->length];
56 memcpy( (void *) this->str, c.str, this->length);
57
58 return *this;
59 }
60
61 std::string toString()
62 {
63 return std::string(this->str, this->length);
64 }
65
66 ~StaticString( )
67 {
68 if(str)
69 {
70 delete[] str;
71 }
72 }
73 };
74 }
75
76 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/straightpipe.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
straightpipe.h
Go to the documentation of this file.
1 #ifndef STRAIGHTPIPE_H_
2 #define STRAIGHTPIPE_H_
3
4 #include "loftturtle.h"
5
6 namespace AP_LSystem {
10 class StraightPipe : public LoftTurtle
11 {
12 private:
16 void initializePipe();
17
21 void finalizePipe();
22
26 void drawCap();
27 public:
28 StraightPipe(void){};
29 ~StraightPipe(void){};
30
31 virtual int preStep( );
32
37 virtual int insideStep( );
38 virtual int initialize( );
39 virtual int finalize( );
40
41 };
42 }
43
44 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Parameter
AP_LSystem::Parameter Member List

This is the complete list of members for AP_LSystem::Parameter, including all inherited members.

LS_BYTE enum value | AP_LSystem::Parameter |
LS_DOUBLE enum value | AP_LSystem::Parameter |
LS_FLOAT enum value | AP_LSystem::Parameter |
LS_INT enum value | AP_LSystem::Parameter |
LS_UBYTE enum value | AP_LSystem::Parameter |
LS_UINT enum value | AP_LSystem::Parameter |
Parameter(void *value, Type type) | AP_LSystem::Parameter | inline
Type enum name | AP_LSystem::Parameter |
type | AP_LSystem::Parameter |
value | AP_LSystem::Parameter |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • Rule
AP_LSystem::Rule Member List

This is the complete list of members for AP_LSystem::Rule, including all inherited members.

addDynamicString(string *rule, string::iterator &it) | AP_LSystem::Rule |
addStaticString(string *rule, string::iterator &it) | AP_LSystem::Rule |
condition | AP_LSystem::Rule |
dynamicStrings | AP_LSystem::Rule |
evaluateCondition(double *p) | AP_LSystem::Rule |
leftContext | AP_LSystem::Rule |
operator=(const Rule &) | AP_LSystem::Rule |
probabilityFactor | AP_LSystem::Rule |
processCondition(string *rule, string::iterator &it) | AP_LSystem::Rule |
processParameters(string *rule, string::iterator &it) | AP_LSystem::Rule |
processProbabilityFactor(string *rule, string::iterator &it) | AP_LSystem::Rule |
rightContext | AP_LSystem::Rule |
Rule() | AP_LSystem::Rule | inline
Rule(const Rule &) | AP_LSystem::Rule |
staticStrings | AP_LSystem::Rule |
strictPredecessor | AP_LSystem::Rule |
variables | AP_LSystem::Rule |
~Rule() | AP_LSystem::Rule |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AP_LSystem
  • TurtleProperties
AP_LSystem::TurtleProperties Member List

This is the complete list of members for AP_LSystem::TurtleProperties, including all inherited members.

angle | AP_LSystem::TurtleProperties |
angleMultiplier | AP_LSystem::TurtleProperties |
angleVariance | AP_LSystem::TurtleProperties |
clean() | AP_LSystem::TurtleProperties | inline
contour | AP_LSystem::TurtleProperties |
contourDetail | AP_LSystem::TurtleProperties |
contourLastN | AP_LSystem::TurtleProperties |
contourLastV | AP_LSystem::TurtleProperties |
controlPoint | AP_LSystem::TurtleProperties |
curveDetail | AP_LSystem::TurtleProperties |
debugGeometryScale | AP_LSystem::TurtleProperties |
DEGREES_TO_RADIANS enum value | AP_LSystem::TurtleProperties |
DRAW_DEBUG_GEOMETRY enum value | AP_LSystem::TurtleProperties |
DRAW_PIPE_CAPS enum value | AP_LSystem::TurtleProperties |
elasticityMultiplier | AP_LSystem::TurtleProperties |
Flags enum name | AP_LSystem::TurtleProperties |
flags | AP_LSystem::TurtleProperties |
geometry | AP_LSystem::TurtleProperties |
gravitropismElasticity | AP_LSystem::TurtleProperties |
hemisphere | AP_LSystem::TurtleProperties |
lastFrame | AP_LSystem::TurtleProperties |
lastMatrix | AP_LSystem::TurtleProperties |
length | AP_LSystem::TurtleProperties |
lengthMultiplier | AP_LSystem::TurtleProperties |
matrix | AP_LSystem::TurtleProperties |
MINIMIZE_TWIST enum value | AP_LSystem::TurtleProperties |
modelFile | AP_LSystem::TurtleProperties |
radius | AP_LSystem::TurtleProperties |
radiusMultiplier | AP_LSystem::TurtleProperties |
SEPARATE_GEOMETRY_FOR_TRANSLUCENT enum value | AP_LSystem::TurtleProperties |
texCoordT | AP_LSystem::TurtleProperties |
texRepeatingS | AP_LSystem::TurtleProperties |
tropismAngle | AP_LSystem::TurtleProperties |
tropismElasticity | AP_LSystem::TurtleProperties |
tropismVector | AP_LSystem::TurtleProperties |
TurtleProperties() | AP_LSystem::TurtleProperties | inline
USE_QUERIES enum value | AP_LSystem::TurtleProperties |
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • ControlPoint
APCameraMovement::ControlPoint Member List

This is the complete list of members for APCameraMovement::ControlPoint, including all inherited members.

cameraRotation | APCameraMovement::ControlPoint
pathIndex | APCameraMovement::ControlPoint
pathLength | APCameraMovement::ControlPoint
position | APCameraMovement::ControlPoint
totalPathLength | APCameraMovement::ControlPoint
vectorCounterPathWise | APCameraMovement::ControlPoint
vectorPathWise | APCameraMovement::ControlPoint
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraMovement
  • MyReadCallback
APCameraMovement::MyReadCallback Member List

This is the complete list of members for APCameraMovement::MyReadCallback, including all inherited members.

readNodeFile(const std::string &filename) APCameraMovement::MyReadCallback inlinevirtual
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APCameraPath
  • ControlPoint
APCameraPath::ControlPoint Member List

This is the complete list of members for APCameraPath::ControlPoint, including all inherited members.

Path_ptr | APCameraPath::ControlPoint
View_ptr | APCameraPath::ControlPoint
Generated on Sun Feb 17 2013 23:29:56 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APConnectEditor
  • MyReadCallback
APConnectEditor::MyReadCallback Member List

This is the complete list of members for APConnectEditor::MyReadCallback, including all inherited members.

readNodeFile(const std::string &filename) APConnectEditor::MyReadCallback inlinevirtual
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Configuration
APDYNAMICART::Configuration Member List

This is the complete list of members for APDYNAMICART::Configuration, including all inherited members.

crossSectionGenerator | APDYNAMICART::Configuration |
get() | APDYNAMICART::Configuration | inline
sculptureSize | APDYNAMICART::Configuration |
shapeCurveGenerator | APDYNAMICART::Configuration |
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • InitSettings
APDYNAMICART::InitSettings Member List

This is the complete list of members for APDYNAMICART::InitSettings, including all inherited members.

interpolationSteps | APDYNAMICART::InitSettings
iterationCount | APDYNAMICART::InitSettings
params | APDYNAMICART::InitSettings
randomRun | APDYNAMICART::InitSettings
settleIterations | APDYNAMICART::InitSettings
size | APDYNAMICART::InitSettings
strategy | APDYNAMICART::InitSettings
Generated on Sun Feb 17 2013 23:29:57 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Limits
APDYNAMICART::Limits Member List

This is the complete list of members for APDYNAMICART::Limits, including all inherited members.

adjustLimits(const osg::Vec3 &point) | APDYNAMICART::Limits | inline
getVolume() | APDYNAMICART::Limits | inline
maxX | APDYNAMICART::Limits |
maxY | APDYNAMICART::Limits |
maxZ | APDYNAMICART::Limits |
minX | APDYNAMICART::Limits |
minY | APDYNAMICART::Limits |
minZ | APDYNAMICART::Limits |
reset() | APDYNAMICART::Limits | inline
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Parameter
APDYNAMICART::Parameter Member List

This is the complete list of members for APDYNAMICART::Parameter, including all inherited members.

canBeRandom | APDYNAMICART::Parameter |
Parameter(double rangeStart, double rangeEnd, double value, std::string title="", bool canBeRandom=true) | APDYNAMICART::Parameter | inline
rangeEnd | APDYNAMICART::Parameter |
rangeStart | APDYNAMICART::Parameter |
title | APDYNAMICART::Parameter |
value | APDYNAMICART::Parameter |
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • ParticleSystemParameters
APDYNAMICART::ParticleSystemParameters Member List

This is the complete list of members for APDYNAMICART::ParticleSystemParameters, including all inherited members.

BirthRateMax | APDYNAMICART::ParticleSystemParameters
BirthRateMin | APDYNAMICART::ParticleSystemParameters
dispersion | APDYNAMICART::ParticleSystemParameters
gravity | APDYNAMICART::ParticleSystemParameters
lifeTime | APDYNAMICART::ParticleSystemParameters
sizeBirth | APDYNAMICART::ParticleSystemParameters
sizeDeath | APDYNAMICART::ParticleSystemParameters
speedMax | APDYNAMICART::ParticleSystemParameters
speedMin | APDYNAMICART::ParticleSystemParameters
textureFile | APDYNAMICART::ParticleSystemParameters
Generated on Sun Feb 17 2013 23:29:59 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SectorInfo
APDYNAMICART::SectorInfo Member List

This is the complete list of members for APDYNAMICART::SectorInfo, including all inherited members.

hoop | APDYNAMICART::SectorInfo |
pattern | APDYNAMICART::SectorInfo |
sector | APDYNAMICART::SectorInfo |
SectorInfo(SectorPtr sector, PatternPtr pattern, HoopPtr hoop) | APDYNAMICART::SectorInfo | inline
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SimulationParameters
APDYNAMICART::SimulationParameters Member List

This is the complete list of members for APDYNAMICART::SimulationParameters, including all inherited members.

detailCoef | APDYNAMICART::SimulationParameters |
hoopDensity | APDYNAMICART::SimulationParameters |
SimulationParameters() | APDYNAMICART::SimulationParameters | inline
stringDamper | APDYNAMICART::SimulationParameters |
stringSpring | APDYNAMICART::SimulationParameters |
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • SnapPoint
APDYNAMICART::SnapPoint Member List

This is the complete list of members for APDYNAMICART::SnapPoint, including all inherited members.

_center | APDYNAMICART::SnapPoint |
SnapPoint(osg::Vec3 center) | APDYNAMICART::SnapPoint | inline
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • Trait
APDYNAMICART::Trait Member List

This is the complete list of members for APDYNAMICART::Trait, including all inherited members.

max | APDYNAMICART::Trait
mean | APDYNAMICART::Trait
min | APDYNAMICART::Trait
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • symmetry_axis
APDYNAMICART::symmetry_axis Member List

This is the complete list of members for APDYNAMICART::symmetry_axis, including all inherited members.

order | APDYNAMICART::symmetry_axis
point | APDYNAMICART::symmetry_axis
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APDYNAMICART
  • symmetry_pair
APDYNAMICART::symmetry_pair Member List

This is the complete list of members for APDYNAMICART::symmetry_pair, including all inherited members.

axis | APDYNAMICART::symmetry_pair
face | APDYNAMICART::symmetry_pair
Generated on Sun Feb 17 2013 23:30:00 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • BUTTON_MAPPING
APEditorController::AbilityMapper::BUTTON_MAPPING Member List

This is the complete list of members for APEditorController::AbilityMapper::BUTTON_MAPPING, including all inherited members.

buttonID | APEditorController::AbilityMapper::BUTTON_MAPPING
mappedAbility | APEditorController::AbilityMapper::BUTTON_MAPPING
pointerID | APEditorController::AbilityMapper::BUTTON_MAPPING
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorController
  • AbilityMapper
  • MAPPING
APEditorController::AbilityMapper::MAPPING Member List

This is the complete list of members for APEditorController::AbilityMapper::MAPPING, including all inherited members.

operator=(const MAPPING &rhs) | APEditorController::AbilityMapper::MAPPING | inline
vector | APEditorController::AbilityMapper::MAPPING |
Generated on Sun Feb 17 2013 23:30:01 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APEditorQAbilities
  • ObjectMovement
  • CANDIDATEPLANE
APEditorQAbilities::ObjectMovement::CANDIDATEPLANE Member List

This is the complete list of members for APEditorQAbilities::ObjectMovement::CANDIDATEPLANE, including all inherited members.

bIgnore | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
center | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
fMaxU | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
fMaxV | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
fMinU | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
fMinV | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
fObjProjectionArea | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
halfRect1 | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
halfRect2 | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
hR1SnapMul | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
hR2SnapMul | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
normal | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
objectID | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
objectSide | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
shiftLen2 | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
shiftVec | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
snapPoint | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
type | APEditorQAbilities::ObjectMovement::CANDIDATEPLANE
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoader
  • Geometry
APFFDEditor::GeometryLoader::Geometry Member List

This is the complete list of members for APFFDEditor::GeometryLoader::Geometry, including all inherited members.

pVertexRelposition | APFFDEditor::GeometryLoader::Geometry
pVertexStartArray | APFFDEditor::GeometryLoader::Geometry
SetNode | APFFDEditor::GeometryLoader::Geometry
transformMatrix | APFFDEditor::GeometryLoader::Geometry
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
  • FaceBase
APFFDEditor::GeometryLoaderBase::FaceBase Member List

This is the complete list of members for APFFDEditor::GeometryLoaderBase::FaceBase, including all inherited members.

min | APFFDEditor::GeometryLoaderBase::FaceBase
normal | APFFDEditor::GeometryLoaderBase::FaceBase
vIndex | APFFDEditor::GeometryLoaderBase::FaceBase
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • GeometryLoaderBase
  • VertexBase
APFFDEditor::GeometryLoaderBase::VertexBase Member List

This is the complete list of members for APFFDEditor::GeometryLoaderBase::VertexBase, including all inherited members.

normal | APFFDEditor::GeometryLoaderBase::VertexBase
pos | APFFDEditor::GeometryLoaderBase::VertexBase
realPos | APFFDEditor::GeometryLoaderBase::VertexBase
relPosInGrid | APFFDEditor::GeometryLoaderBase::VertexBase
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
  • ControlPoint
APFFDEditor::Grid::ControlPoint Member List

This is the complete list of members for APFFDEditor::Grid::ControlPoint, including all inherited members.

EO | APFFDEditor::Grid::ControlPoint
prevPos | APFFDEditor::Grid::ControlPoint
startPos | APFFDEditor::Grid::ControlPoint
visited | APFFDEditor::Grid::ControlPoint
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APFFDEditor
  • Grid
  • Edge
APFFDEditor::Grid::Edge Member List

This is the complete list of members for APFFDEditor::Grid::Edge, including all inherited members.

ID1 | APFFDEditor::Grid::Edge
ID2 | APFFDEditor::Grid::Edge
osgGeom | APFFDEditor::Grid::Edge
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDColorProfile
APHUD::HUDColorProfile Member List

This is the complete list of members for APHUD::HUDColorProfile, including all inherited members.

backgroundColor | APHUD::HUDColorProfile
fontColor | APHUD::HUDColorProfile
gradientEndColor | APHUD::HUDColorProfile
gradientStartColor | APHUD::HUDColorProfile
Generated on Sun Feb 17 2013 23:30:02 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDField
APHUD::HUDField Member List

This is the complete list of members for APHUD::HUDField, including all inherited members.

actual_string | APHUD::HUDField
actualValue | APHUD::HUDField
animated | APHUD::HUDField
color | APHUD::HUDField
colorMax | APHUD::HUDField
colorMin | APHUD::HUDField
geometry | APHUD::HUDField
maxValue | APHUD::HUDField
minValue | APHUD::HUDField
name | APHUD::HUDField
posX | APHUD::HUDField
posY | APHUD::HUDField
text | APHUD::HUDField
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APHUD
  • HUDWindow
APHUD::HUDWindow Member List

This is the complete list of members for APHUD::HUDWindow, including all inherited members.

color | APHUD::HUDWindow
fields | APHUD::HUDWindow
geometry | APHUD::HUDWindow
name | APHUD::HUDWindow
posX | APHUD::HUDWindow
posY | APHUD::HUDWindow
sizeX | APHUD::HUDWindow
sizeY | APHUD::HUDWindow
visible | APHUD::HUDWindow
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APLightsEditor
  • _Light
APLightsEditor::_Light Member List

This is the complete list of members for APLightsEditor::_Light, including all inherited members.

_eoPtr | APLightsEditor::_Light |
_eoSpotPtr | APLightsEditor::_Light |
_Light(EnvironmentObject *eoPtr, int lightID, EnvironmentObject *eoSpotPtr=NULL) | APLightsEditor::_Light | inline
_lightID | APLightsEditor::_Light |
Generated on Sun Feb 17 2013 23:30:03 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APObjectUtils
  • MyReadCallback
APObjectUtils::MyReadCallback Member List

This is the complete list of members for APObjectUtils::MyReadCallback, including all inherited members.

readNodeFile(const std::string &filename) APObjectUtils::MyReadCallback inlinevirtual
Generated on Sun Feb 17 2013 23:30:04 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • ELOD
APSpacePartitioning::ELOD Member List

This is the complete list of members for APSpacePartitioning::ELOD, including all inherited members.

cost | APSpacePartitioning::ELOD
dist | APSpacePartitioning::ELOD
edgeCostRecompute | APSpacePartitioning::ELOD
id | APSpacePartitioning::ELOD
importance | APSpacePartitioning::ELOD
p1 | APSpacePartitioning::ELOD
p2 | APSpacePartitioning::ELOD
requiredDeletedEdges | APSpacePartitioning::ELOD
v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
valid | APSpacePartitioning::ELOD
visible | APSpacePartitioning::ELOD
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
  • FaceBase
APSpacePartitioning::GeometryLoaderBase::FaceBase Member List

This is the complete list of members for APSpacePartitioning::GeometryLoaderBase::FaceBase, including all inherited members.

min | APSpacePartitioning::GeometryLoaderBase::FaceBase
normal | APSpacePartitioning::GeometryLoaderBase::FaceBase
vIndex | APSpacePartitioning::GeometryLoaderBase::FaceBase
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • GeometryLoaderBase
  • VertexBase
APSpacePartitioning::GeometryLoaderBase::VertexBase Member List

This is the complete list of members for APSpacePartitioning::GeometryLoaderBase::VertexBase, including all inherited members.

normal | APSpacePartitioning::GeometryLoaderBase::VertexBase
pos | APSpacePartitioning::GeometryLoaderBase::VertexBase
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
  • CollisionStruct
APSpacePartitioning::NoPartitioning_Scene::CollisionStruct Member List

This is the complete list of members for APSpacePartitioning::NoPartitioning_Scene::CollisionStruct, including all inherited members.

boundingSpherePosition | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
boundingSphereRadius | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
collisionObjects | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
objectID | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
pointShellSize | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
position | APSpacePartitioning::NoPartitioning_Scene::CollisionStruct
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • NoPartitioning_Scene
  • CollisionStructObject
APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject Member List

This is the complete list of members for APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject, including all inherited members.

boundingSpherePosition | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
boundingSphereRadius | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
objectID | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
position | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
timeDivision | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
voxelSize | APSpacePartitioning::NoPartitioning_Scene::CollisionStructObject
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PLOD
APSpacePartitioning::PLOD Member List

This is the complete list of members for APSpacePartitioning::PLOD, including all inherited members.

e1 | APSpacePartitioning::PLOD
e2 | APSpacePartitioning::PLOD
e3 | APSpacePartitioning::PLOD
id | APSpacePartitioning::PLOD
norm | APSpacePartitioning::PLOD
v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v3ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
visible | APSpacePartitioning::PLOD
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data
  • PSpoint
APSpacePartitioning::PointShell_Object_Data::PSpoint Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data::PSpoint, including all inherited members.

a | APSpacePartitioning::PointShell_Object_Data::PSpoint
b | APSpacePartitioning::PointShell_Object_Data::PSpoint
c | APSpacePartitioning::PointShell_Object_Data::PSpoint
x | APSpacePartitioning::PointShell_Object_Data::PSpoint
y | APSpacePartitioning::PointShell_Object_Data::PSpoint
z | APSpacePartitioning::PointShell_Object_Data::PSpoint
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • E
APSpacePartitioning::PointShell_Object_Data_Geometry::E Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry::E, including all inherited members.

v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • P
APSpacePartitioning::PointShell_Object_Data_Geometry::P Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry::P, including all inherited members.

norm | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v3ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry
  • V
APSpacePartitioning::PointShell_Object_Data_Geometry::V Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry::V, including all inherited members.

norm | APSpacePartitioning::PointShell_Object_Data_Geometry::V
pos | APSpacePartitioning::PointShell_Object_Data_Geometry::V
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • EExt
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt, including all inherited members.

length | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
p1ID | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
p2ID | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::EExt
v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::E
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • PExt
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt, including all inherited members.

e1ID | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
e2ID | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
e3ID | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
norm | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
size | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::PExt
v1ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v2ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
v3ID | APSpacePartitioning::PointShell_Object_Data_Geometry::P
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • PointShell_Object_Data_Geometry_Analyser
  • VExt
APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt Member List

This is the complete list of members for APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt, including all inherited members.

comNorm | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
edges | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
id | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
norm | APSpacePartitioning::PointShell_Object_Data_Geometry::V
polygons | APSpacePartitioning::PointShell_Object_Data_Geometry_Analyser::VExt
pos | APSpacePartitioning::PointShell_Object_Data_Geometry::V
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • InternalPointStruct
APSpacePartitioning::SNCH_Object::InternalPointStruct Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object::InternalPointStruct, including all inherited members.

normal | APSpacePartitioning::SNCH_Object::InternalPointStruct
pos | APSpacePartitioning::SNCH_Object::InternalPointStruct
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object
  • LocalMinimumDistance
APSpacePartitioning::SNCH_Object::LocalMinimumDistance Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object::LocalMinimumDistance, including all inherited members.

closeFeatures | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
dwFlags | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
faces | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
pointsTrans | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
vecTriMaxNegDist | APSpacePartitioning::SNCH_Object::LocalMinimumDistance
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • DebugLevelStats
APSpacePartitioning::SNCH_Object_Data::DebugLevelStats Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data::DebugLevelStats, including all inherited members.

cntAngle | APSpacePartitioning::SNCH_Object_Data::DebugLevelStats |
cntNodes | APSpacePartitioning::SNCH_Object_Data::DebugLevelStats |
cntRadius | APSpacePartitioning::SNCH_Object_Data::DebugLevelStats |
DebugLevelStats() | APSpacePartitioning::SNCH_Object_Data::DebugLevelStats | inline
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • DebugStats
APSpacePartitioning::SNCH_Object_Data::DebugStats Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data::DebugStats, including all inherited members.

DebugStats() | APSpacePartitioning::SNCH_Object_Data::DebugStats | inline
levels | APSpacePartitioning::SNCH_Object_Data::DebugStats |
totalNodes | APSpacePartitioning::SNCH_Object_Data::DebugStats |
twoNeighbours | APSpacePartitioning::SNCH_Object_Data::DebugStats |
twoTotal | APSpacePartitioning::SNCH_Object_Data::DebugStats |
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • FaceSNCH
APSpacePartitioning::SNCH_Object_Data::FaceSNCH Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data::FaceSNCH, including all inherited members.

dwGroup | APSpacePartitioning::SNCH_Object_Data::FaceSNCH
dwSNCHFlags | APSpacePartitioning::SNCH_Object_Data::FaceSNCH
edgeFlags | APSpacePartitioning::SNCH_Object_Data::FaceSNCH
fIndex | APSpacePartitioning::SNCH_Object_Data::FaceSNCH
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • STNodeSNCH
APSpacePartitioning::SNCH_Object_Data::STNodeSNCH Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data::STNodeSNCH, including all inherited members.

cone_axis | APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
half_spread_angle | APSpacePartitioning::SNCH_Object_Data::STNodeSNCH
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SNCH_Object_Data
  • VertexSNCH
APSpacePartitioning::SNCH_Object_Data::VertexSNCH Member List

This is the complete list of members for APSpacePartitioning::SNCH_Object_Data::VertexSNCH, including all inherited members.

averageNormal | APSpacePartitioning::SNCH_Object_Data::VertexSNCH
dwRepresentant | APSpacePartitioning::SNCH_Object_Data::VertexSNCH
faces | APSpacePartitioning::SNCH_Object_Data::VertexSNCH
normal | APSpacePartitioning::GeometryLoaderBase::VertexBase
pos | APSpacePartitioning::GeometryLoaderBase::VertexBase
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • SphereBVH_Object_Data
  • STNodeSphere
APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere Member List

This is the complete list of members for APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere, including all inherited members.

center | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
face_index | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
pChild | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
pParent | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
radius | APSpacePartitioning::SphereBVH_Object_Data::STNodeSphere
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VGReadCallback
APSpacePartitioning::VGReadCallback Member List

This is the complete list of members for APSpacePartitioning::VGReadCallback, including all inherited members.

readNodeFile(const std::string &filename) APSpacePartitioning::VGReadCallback inlinevirtual
Generated on Sun Feb 17 2013 23:30:06 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • VLOD
APSpacePartitioning::VLOD Member List

This is the complete list of members for APSpacePartitioning::VLOD, including all inherited members.

ancestor | APSpacePartitioning::VLOD
childs | APSpacePartitioning::VLOD
comNorm | APSpacePartitioning::VLOD
comPos | APSpacePartitioning::VLOD
edges | APSpacePartitioning::VLOD
id | APSpacePartitioning::VLOD
importance | APSpacePartitioning::VLOD
leaf | APSpacePartitioning::VLOD
level | APSpacePartitioning::VLOD
norm | APSpacePartitioning::PointShell_Object_Data_Geometry::V
pos | APSpacePartitioning::PointShell_Object_Data_Geometry::V
radius | APSpacePartitioning::VLOD
valid | APSpacePartitioning::VLOD
visible | APSpacePartitioning::VLOD
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • APSpacePartitioning
  • int_3
APSpacePartitioning::int_3 Member List

This is the complete list of members for APSpacePartitioning::int_3, including all inherited members.

i1 | APSpacePartitioning::int_3
i2 | APSpacePartitioning::int_3
i3 | APSpacePartitioning::int_3
Generated on Sun Feb 17 2013 23:30:05 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
AllCloudsUpdateCallBack Member List

This is the complete list of members for AllCloudsUpdateCallBack, including all inherited members.

AllCloudsUpdateCallBack() | AllCloudsUpdateCallBack | inline
AllCloudsUpdateCallBack(osg::ref_ptr< CloudDataType > data) | AllCloudsUpdateCallBack | inline
AllCloudsUpdateCallBack(const AllCloudsUpdateCallBack &, const osg::CopyOp &) | AllCloudsUpdateCallBack | inline
Cloud::SetViewMatrix(camera.getViewMatrix()) | AllCloudsUpdateCallBack |
cloudData | AllCloudsUpdateCallBack |
META_Object(osgCloud, AllCloudsUpdateCallBack) virtual void operator()(const osg | AllCloudsUpdateCallBack | inline
Update(cloudData->getCameraPos(), cloudData->getCameraView(), cloudData->getCameraUp()) | AllCloudsUpdateCallBack |
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
AnimatedGeometryState Member List

This is the complete list of members for AnimatedGeometryState, including all inherited members.

AddReference() | AnimatedGeometryState | inline
AnimatedGeometryState() | AnimatedGeometryState | inline
AnimatedGeometryState(osgCal::CoreModel *cm) | AnimatedGeometryState | inline
Count() | AnimatedGeometryState | inline
GetAnimatedGeometry() | AnimatedGeometryState | inline
RemoveGeometry() | AnimatedGeometryState | inline
RemoveReference() | AnimatedGeometryState | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BehindObstacleExp_wT
  • ExperimentRec
BehindObstacleExp_wT::ExperimentRec Member List

This is the complete list of members for BehindObstacleExp_wT::ExperimentRec, including all inherited members.

nic BehindObstacleExp_wT::ExperimentRec
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BehindObstacleExperiment
  • ExperimentRec
BehindObstacleExperiment::ExperimentRec Member List

This is the complete list of members for BehindObstacleExperiment::ExperimentRec, including all inherited members.

nic BehindObstacleExperiment::ExperimentRec
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarEdgeData
CarSim::CarEdgeData Member List

This is the complete list of members for CarSim::CarEdgeData, including all inherited members.

carId | CarSim::CarEdgeData
carLength | CarSim::CarEdgeData
edgeId | CarSim::CarEdgeData
offset | CarSim::CarEdgeData
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarEnvirons
CarSim::CarEnvirons Member List

This is the complete list of members for CarSim::CarEnvirons, including all inherited members.

carEdgeId | CarSim::CarEnvirons
carNextJuncRel | CarSim::CarEnvirons
distToNextPoint | CarSim::CarEnvirons
nextCarDist | CarSim::CarEnvirons
nextCarVel | CarSim::CarEnvirons
nextJuncTurn | CarSim::CarEnvirons
pass | CarSim::CarEnvirons
recVelocityOnJunc | CarSim::CarEnvirons
wheelAngleOnJunc | CarSim::CarEnvirons
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarSize
CarSim::CarSize Member List

This is the complete list of members for CarSim::CarSize, including all inherited members.

height | CarSim::CarSize
length | CarSim::CarSize
width | CarSim::CarSize
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • CarState
CarSim::CarState Member List

This is the complete list of members for CarSim::CarState, including all inherited members.

acc | CarSim::CarState
blinkLightState | CarSim::CarState
bottomCarPosition | CarSim::CarState
carSize | CarSim::CarState
direction | CarSim::CarState
distFromLastFrame | CarSim::CarState
maxAcc | CarSim::CarState
minAcc | CarSim::CarState
normal | CarSim::CarState
position | CarSim::CarState
stoped | CarSim::CarState
v | CarSim::CarState
wheelAngle | CarSim::CarState
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Edge
CarSim::Edge Member List

This is the complete list of members for CarSim::Edge, including all inherited members.

direction | CarSim::Edge
edgesCars | CarSim::Edge
from | CarSim::Edge
fromPointRight | CarSim::Edge
fstCarId | CarSim::Edge
incomingCars | CarSim::Edge
inPos | CarSim::Edge
lastCarId | CarSim::Edge
length | CarSim::Edge
lowBoundForStartStopPosOffset | CarSim::Edge
normal | CarSim::Edge
numLanes | CarSim::Edge
outInVec | CarSim::Edge
outPos | CarSim::Edge
putAsideCars | CarSim::Edge
roadId | CarSim::Edge
stopBeforeJuncOffset | CarSim::Edge
stopOrGoDecisionOffset | CarSim::Edge
tlGreenInterv | CarSim::Edge
to | CarSim::Edge
toPointRight | CarSim::Edge
type | CarSim::Edge
widthFPR | CarSim::Edge
widthTPR | CarSim::Edge
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • EdgesCar
CarSim::EdgesCar Member List

This is the complete list of members for CarSim::EdgesCar, including all inherited members.

backCarId | CarSim::EdgesCar
frontCarId | CarSim::EdgesCar
headOffset | CarSim::EdgesCar
rearOffset | CarSim::EdgesCar
vel | CarSim::EdgesCar
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • First3Juncs
CarSim::First3Juncs Member List

This is the complete list of members for CarSim::First3Juncs, including all inherited members.

lastJunc | CarSim::First3Juncs
nextJunc | CarSim::First3Juncs
nextNextJunc | CarSim::First3Juncs
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • GeometryPartsPath
CarSim::GeometryPartsPath Member List

This is the complete list of members for CarSim::GeometryPartsPath, including all inherited members.

brakeLightsPath | CarSim::GeometryPartsPath
carWithoutWheelsPath | CarSim::GeometryPartsPath
frontLightsPath | CarSim::GeometryPartsPath
leftBlinkerPath | CarSim::GeometryPartsPath
leftWheelsPathVec | CarSim::GeometryPartsPath
rightBlinkerPath | CarSim::GeometryPartsPath
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • InOutEdgesAttr
CarSim::InOutEdgesAttr Member List

This is the complete list of members for CarSim::InOutEdgesAttr, including all inherited members.

angleInXZ | CarSim::InOutEdgesAttr
hfCubicsBorder | CarSim::InOutEdgesAttr
hfCubicsBorderVec | CarSim::InOutEdgesAttr
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • JuncsEdge
CarSim::JuncsEdge Member List

This is the complete list of members for CarSim::JuncsEdge, including all inherited members.

angle | CarSim::JuncsEdge
lockCount | CarSim::JuncsEdge
nextEdgeId | CarSim::JuncsEdge
prevEdgeId | CarSim::JuncsEdge
tlColors | CarSim::JuncsEdge
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Junction
CarSim::Junction Member List

This is the complete list of members for CarSim::Junction, including all inherited members.

carIdUnlockedEdge | CarSim::Junction
complexJunc | CarSim::Junction
controlSystem | CarSim::Junction
id | CarSim::Junction
inOutEdgesAttrMap | CarSim::Junction
lastCarInEdge | CarSim::Junction
lastCarOutEdge | CarSim::Junction
orderedEdges | CarSim::Junction
partJuncCardinality | CarSim::Junction
position | CarSim::Junction
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Lights
CarSim::Lights Member List

This is the complete list of members for CarSim::Lights, including all inherited members.

pBrakeLightMT | CarSim::Lights
pFrontLightMT | CarSim::Lights
pLeftBlinkerLightMT | CarSim::Lights
pRightBlinkerLightMT | CarSim::Lights
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • Parameters
CarSim::Parameters Member List

This is the complete list of members for CarSim::Parameters, including all inherited members.

carEdgeId | CarSim::Parameters
carId | CarSim::Parameters
carNextJuncRel | CarSim::Parameters
lastJuncInPath | CarSim::Parameters
pass | CarSim::Parameters
path | CarSim::Parameters
pCEU | CarSim::Parameters
startStopDestination | CarSim::Parameters
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • PolygonPoint
CarSim::PolygonPoint Member List

This is the complete list of members for CarSim::PolygonPoint, including all inherited members.

id | CarSim::PolygonPoint
junctionId | CarSim::PolygonPoint
position | CarSim::PolygonPoint
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • RoadsEdges
CarSim::RoadsEdges Member List

This is the complete list of members for CarSim::RoadsEdges, including all inherited members.

backEdgeId | CarSim::RoadsEdges
forwardEdgeId | CarSim::RoadsEdges
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • StartStopDestination
CarSim::StartStopDestination Member List

This is the complete list of members for CarSim::StartStopDestination, including all inherited members.

startEdge | CarSim::StartStopDestination
startOffset | CarSim::StartStopDestination
stopEdge | CarSim::StartStopDestination
stopOffset | CarSim::StartStopDestination
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CarSim
  • TLcolorsMT
CarSim::TLcolorsMT Member List

This is the complete list of members for CarSim::TLcolorsMT, including all inherited members.

pGreenMT | CarSim::TLcolorsMT
pOrangeMT | CarSim::TLcolorsMT
pRedMT | CarSim::TLcolorsMT
Generated on Sun Feb 17 2013 23:30:08 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ChessBoard
  • Request
ChessBoard::Request Member List

This is the complete list of members for ChessBoard::Request, including all inherited members.

location | ChessBoard::Request
new_position | ChessBoard::Request
type | ChessBoard::Request
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudParticle Member List

This is the complete list of members for CloudParticle, including all inherited members.

color | Particle
distToCam | CloudParticle
position | Particle
render_cloud_tex_u1 | CloudParticle
render_cloud_tex_u2 | CloudParticle
render_cloud_tex_v1 | CloudParticle
render_cloud_tex_v2 | CloudParticle
size | Particle
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudSceneInfo Member List

This is the complete list of members for CloudSceneInfo, including all inherited members.

Aspect | CloudSceneInfo
Far | CloudSceneInfo
Fovy | CloudSceneInfo
Near | CloudSceneInfo
screenHeight | CloudSceneInfo
screenWidth | CloudSceneInfo
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudVoxel Member List

This is the complete list of members for CloudVoxel, including all inherited members.

act | CloudVoxel
cld | CloudVoxel
hum | CloudVoxel
p_act | CloudVoxel
p_ext | CloudVoxel
p_hum | CloudVoxel
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
CloudsProperties Member List

This is the complete list of members for CloudsProperties, including all inherited members.

CloudFlatAreaPosition | CloudsProperties
CloudFlatAreaSize | CloudsProperties
CloudGrowth | CloudsProperties
CloudGrowthRand | CloudsProperties
groundCenterPosition | CloudsProperties
groundShow | CloudsProperties
groundTexturePath | CloudsProperties
GrowthSimulationSteps | CloudsProperties
GrowthSimulationStepsRand | CloudsProperties
loadFromFile | CloudsProperties
maxCloudUpdatesParFrame | CloudsProperties
numOfClouds | CloudsProperties
renderCloudTexturePath | CloudsProperties
saveToFile | CloudsProperties
scale | CloudsProperties
skyboxCenterPosition | CloudsProperties
skyboxShow | CloudsProperties
skyboxSize | CloudsProperties
skyBoxTexturePathEast | CloudsProperties
skyBoxTexturePathNorth | CloudsProperties
skyBoxTexturePathSouth | CloudsProperties
skyBoxTexturePathTop | CloudsProperties
skyBoxTexturePathWest | CloudsProperties
sun | CloudsProperties
sunShow | CloudsProperties
translateErrorTolerance | CloudsProperties
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Filter
  • PosNoiseRemover
  • SAMPLE
Filter::PosNoiseRemover::SAMPLE Member List

This is the complete list of members for Filter::PosNoiseRemover::SAMPLE, including all inherited members.

time | Filter::PosNoiseRemover::SAMPLE
vec | Filter::PosNoiseRemover::SAMPLE
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
GeometryState Member List

This is the complete list of members for GeometryState, including all inherited members.

AddReference() | GeometryState | inline
Count() | GeometryState | inline
GeometryState() | GeometryState | inline
GeometryState(EnvironmentObject *eo) | GeometryState | inline
GetGeometry() | GeometryState | inline
RemoveGeometry() | GeometryState | inline
RemoveReference() | GeometryState | inline
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
MyReadCallback Member List

This is the complete list of members for MyReadCallback, including all inherited members.

readNodeFile(const std::string &filename) MyReadCallback inlinevirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Particle Member List

This is the complete list of members for Particle, including all inherited members.

color | Particle
position | Particle
size | Particle
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PhysXPlugin
  • Particle
PhysXPlugin::Particle Member List

This is the complete list of members for PhysXPlugin::Particle, including all inherited members.

collisionNormal | PhysXPlugin::Particle
density | PhysXPlugin::Particle
id | PhysXPlugin::Particle
lifetime | PhysXPlugin::Particle
position | PhysXPlugin::Particle
velocity | PhysXPlugin::Particle
Generated on Sun Feb 17 2013 23:30:10 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Point3 Member List

This is the complete list of members for Point3, including all inherited members.

x | Point3
y | Point3
z | Point3
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Point3f Member List

This is the complete list of members for Point3f, including all inherited members.

x | Point3f
y | Point3f
z | Point3f
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Receiver Member List

This is the complete list of members for Receiver, including all inherited members.

inputPin | Receiver
receiver | Receiver
senderString | Receiver
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SNCH_THREAD_START_INFO Member List

This is the complete list of members for SNCH_THREAD_START_INFO, including all inherited members.

objectClass SNCH_THREAD_START_INFO
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Sector Member List

This is the complete list of members for Sector, including all inherited members.

color | Sector |
counter | Sector | protectedstatic
Direction enum name | Sector |
direction | Sector |
DoublePair typedef | Sector |
end | Sector |
getSectorRange(unsigned int arraySize) | Sector | inline
ID | Sector |
SD_FORWARD enum value | Sector |
SD_REVERSE enum value | Sector |
Sector() | Sector | inline
Sector(double start, double end, const osg::Vec4 &color, Direction direction=SD_FORWARD) | Sector | inline
set(double start, double end, const osg::Vec4 &color, Direction direction=SD_FORWARD) | Sector | inline
start | Sector |
~Sector() | Sector | inlineprotectedvirtual
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
SunLight Member List

This is the complete list of members for SunLight, including all inherited members.

ambientLight | SunLight
position | SunLight
sunColor | SunLight
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Triangle3 Member List

This is the complete list of members for Triangle3, including all inherited members.

v1 | Triangle3
v2 | Triangle3
v3 | Triangle3
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Triangle3v Member List

This is the complete list of members for Triangle3v, including all inherited members.

v1 | Triangle3v
v2 | Triangle3v
v3 | Triangle3v
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Triangle Member List

This is the complete list of members for Triangle, including all inherited members.

normal | Triangle
rot | Triangle
transf | Triangle
triangle | Triangle
vertex | Triangle
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
angle_3D Member List

This is the complete list of members for angle_3D, including all inherited members.

x | angle_3D
y | angle_3D
z | angle_3D
Generated on Sun Feb 17 2013 23:29:54 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • _CLIENT_ID
base::_CLIENT_ID Member List

This is the complete list of members for base::_CLIENT_ID, including all inherited members.

UniqueProcess | base::_CLIENT_ID
UniqueThread | base::_CLIENT_ID
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • _THREAD_BASIC_INFORMATION
base::_THREAD_BASIC_INFORMATION Member List

This is the complete list of members for base::_THREAD_BASIC_INFORMATION, including all inherited members.

AffinityMask | base::_THREAD_BASIC_INFORMATION
BasePriority | base::_THREAD_BASIC_INFORMATION
ClientId | base::_THREAD_BASIC_INFORMATION
ExitStatus | base::_THREAD_BASIC_INFORMATION
Priority | base::_THREAD_BASIC_INFORMATION
TebBaseAddress | base::_THREAD_BASIC_INFORMATION
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • SIThreadInfo
base::SystemInfo::SIThreadInfo Member List

This is the complete list of members for base::SystemInfo::SIThreadInfo, including all inherited members.

bThreadInitialized | base::SystemInfo::SIThreadInfo |
bTimeInitialized | base::SystemInfo::SIThreadInfo |
dwLastKernelTime | base::SystemInfo::SIThreadInfo |
dwLastUserTime | base::SystemInfo::SIThreadInfo |
name | base::SystemInfo::SIThreadInfo |
SIThreadInfo() | base::SystemInfo::SIThreadInfo | inline
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • base
  • SystemInfo
  • SIThreadInit
base::SystemInfo::SIThreadInit Member List

This is the complete list of members for base::SystemInfo::SIThreadInit, including all inherited members.

dwAffinity base::SystemInfo::SIThreadInit
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • behindO
  • WIM
  • ObjectCopy
behindO::WIM::ObjectCopy Member List

This is the complete list of members for behindO::WIM::ObjectCopy, including all inherited members.

copy | behindO::WIM::ObjectCopy
last_position | behindO::WIM::ObjectCopy
last_rotation | behindO::WIM::ObjectCopy
Generated on Sun Feb 17 2013 23:30:07 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • GrassAbilityParameters
grass::GrassAbilityParameters Member List

This is the complete list of members for grass::GrassAbilityParameters, including all inherited members.

density | grass::GrassAbilityParameters |
detailedGrassStateSet | grass::GrassAbilityParameters |
EnsureGrassBladesArePrepared() | grass::GrassAbilityParameters | inline
GrassAbilityParameters() | grass::GrassAbilityParameters |
grassBlades | grass::GrassAbilityParameters |
grassCullCallback | grass::GrassAbilityParameters |
Init() | grass::GrassAbilityParameters |
invVisibilityRange | grass::GrassAbilityParameters |
loadXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode) | grass::GrassAbilityParameters |
lowDetailGrassStateSet | grass::GrassAbilityParameters |
maxArea | grass::GrassAbilityParameters |
maxBend | grass::GrassAbilityParameters |
maxFractions | grass::GrassAbilityParameters |
maxHeight | grass::GrassAbilityParameters |
maxLODdifference | grass::GrassAbilityParameters |
maxVisibility | grass::GrassAbilityParameters |
maxWidth | grass::GrassAbilityParameters |
minBend | grass::GrassAbilityParameters |
minFractions | grass::GrassAbilityParameters |
minHeight | grass::GrassAbilityParameters |
minVisibility | grass::GrassAbilityParameters |
minWidth | grass::GrassAbilityParameters |
neutralColor | grass::GrassAbilityParameters |
saveXMLParameters(XERCES_CPP_NAMESPACE_QUALIFIER DOMDocument *) | grass::GrassAbilityParameters |
visibilityRange | grass::GrassAbilityParameters |
~GrassAbilityParameters() | grass::GrassAbilityParameters | inlinevirtual
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Triangle
grass::Triangle Member List

This is the complete list of members for grass::Triangle, including all inherited members.

A | grass::Triangle |
area | grass::Triangle |
B | grass::Triangle |
C | grass::Triangle |
center | grass::Triangle |
GetRandomPoint() const | grass::Triangle | inline
Triangle() | grass::Triangle | inline
Triangle(Vertex *nA, Vertex *nB, Vertex *nC) | grass::Triangle | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • grass
  • Vertex
grass::Vertex Member List

This is the complete list of members for grass::Vertex, including all inherited members.

IsAverageOf(const Vertex &a, const Vertex &b) | grass::Vertex | inline
normal | grass::Vertex |
position | grass::Vertex |
Vertex() | grass::Vertex | inline
Vertex(Vec3 nPosition) | grass::Vertex | inline
Vertex(Vec3 nPosition, Vec3 nNormal) | grass::Vertex | inline
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetup
  • ScreenSetupState
ht::ScreenSetup::ScreenSetupState Member List

This is the complete list of members for ht::ScreenSetup::ScreenSetupState, including all inherited members.

monitor_corner | ht::ScreenSetup::ScreenSetupState
monitor_orientation | ht::ScreenSetup::ScreenSetupState
monitor_position | ht::ScreenSetup::ScreenSetupState
rim_height | ht::ScreenSetup::ScreenSetupState
rim_width | ht::ScreenSetup::ScreenSetupState
sensor_offset | ht::ScreenSetup::ScreenSetupState
wire_length | ht::ScreenSetup::ScreenSetupState
wire_orientation | ht::ScreenSetup::ScreenSetupState
wire_position | ht::ScreenSetup::ScreenSetupState
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ht
  • ScreenSetupSimple
  • ScreenSetupSimpleState
ht::ScreenSetupSimple::ScreenSetupSimpleState Member List

This is the complete list of members for ht::ScreenSetupSimple::ScreenSetupSimpleState, including all inherited members.

mon_cor_position | ht::ScreenSetupSimple::ScreenSetupSimpleState
sensor_offset | ht::ScreenSetupSimple::ScreenSetupSimpleState
wire_length | ht::ScreenSetupSimple::ScreenSetupSimpleState
wire_orientation | ht::ScreenSetupSimple::ScreenSetupSimpleState
wire_position | ht::ScreenSetupSimple::ScreenSetupSimpleState
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
length_3D Member List

This is the complete list of members for length_3D, including all inherited members.

x | length_3D
y | length_3D
z | length_3D
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • mv
  • CPoint
mv::CPoint Member List

This is the complete list of members for mv::CPoint, including all inherited members.

Movable | mv::CPoint
Pos | mv::CPoint
WTime | mv::CPoint
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • CompositeObject
  • Data
ode::CompositeObject::Data Member List

This is the complete list of members for ode::CompositeObject::Data, including all inherited members.

_density | ode::CompositeObject::Data
_direction | ode::CompositeObject::Data
_length | ode::CompositeObject::Data
_radius | ode::CompositeObject::Data
_size | ode::CompositeObject::Data
_translate | ode::CompositeObject::Data
_type | ode::CompositeObject::Data
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ode
  • ODEObject
ode::ODEObject Member List

This is the complete list of members for ode::ODEObject, including all inherited members.

body | ode::ODEObject
enable | ode::ODEObject
geom | ode::ODEObject
geom_translate | ode::ODEObject
steps_before_disable_state | ode::ODEObject
translate | ode::ODEObject
Generated on Sun Feb 17 2013 23:30:09 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
packet_rec Member List

This is the complete list of members for packet_rec, including all inherited members.

cmd_byte | packet_rec
data | packet_rec
data_ptr | packet_rec
error | packet_rec
num_bytes_needed | packet_rec
parsed | packet_rec
Generated on Sun Feb 17 2013 23:29:55 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Ability
  • ParameterStruct
vrecko::Ability::ParameterStruct Member List

This is the complete list of members for vrecko::Ability::ParameterStruct, including all inherited members.

description | vrecko::Ability::ParameterStruct
name | vrecko::Ability::ParameterStruct
range | vrecko::Ability::ParameterStruct
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • BaseClass
  • NOTIFICATION_DESCRIPTION
vrecko::BaseClass::NOTIFICATION_DESCRIPTION Member List

This is the complete list of members for vrecko::BaseClass::NOTIFICATION_DESCRIPTION, including all inherited members.

notificationTypes | vrecko::BaseClass::NOTIFICATION_DESCRIPTION
receiver | vrecko::BaseClass::NOTIFICATION_DESCRIPTION
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CABUTTONEVENT
vrecko::CABUTTONEVENT Member List

This is the complete list of members for vrecko::CABUTTONEVENT, including all inherited members.

bState | vrecko::CABUTTONEVENT
dwSize | vrecko::CABUTTONEVENT
iButtonID | vrecko::CABUTTONEVENT
iPointerID | vrecko::CABUTTONEVENT
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CAINFO__VER1
vrecko::CAINFO__VER1 Member List

This is the complete list of members for vrecko::CAINFO__VER1, including all inherited members.

AbilityMapper enum value | vrecko::CAINFO__VER1
CAType enum name | vrecko::CAINFO__VER1
DummyCATypeToDWORD enum value | vrecko::CAINFO__VER1
dwFlags | vrecko::CAINFO__VER1
dwSize | vrecko::CAINFO__VER1
SimpleVREdit enum value | vrecko::CAINFO__VER1
type | vrecko::CAINFO__VER1
Unknown enum value | vrecko::CAINFO__VER1
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • CAINFO__VER2
vrecko::CAINFO__VER2 Member List

This is the complete list of members for vrecko::CAINFO__VER2, including all inherited members.

AbilityMapper enum value | vrecko::CAINFO__VER1
CAType enum name | vrecko::CAINFO__VER1
DummyCATypeToDWORD enum value | vrecko::CAINFO__VER1
dwActiveFlags | vrecko::CAINFO__VER2
dwFlags | vrecko::CAINFO__VER1
dwSize | vrecko::CAINFO__VER1
SimpleVREdit enum value | vrecko::CAINFO__VER1
type | vrecko::CAINFO__VER1
Unknown enum value | vrecko::CAINFO__VER1
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • DeviceManager
  • DT
vrecko::DeviceManager::DT Member List

This is the complete list of members for vrecko::DeviceManager::DT, including all inherited members.

devicePtr | vrecko::DeviceManager::DT
threadPtr | vrecko::DeviceManager::DT
Generated on Sun Feb 17 2013 23:30:12 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EnvironmentObject
  • UserData
vrecko::EnvironmentObject::UserData Member List

This is the complete list of members for vrecko::EnvironmentObject::UserData, including all inherited members.

pointer | vrecko::EnvironmentObject::UserData
type | vrecko::EnvironmentObject::UserData
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • EventDefinitionStruct
vrecko::EventDispatcher::EventDefinitionStruct Member List

This is the complete list of members for vrecko::EventDispatcher::EventDefinitionStruct, including all inherited members.

receiver | vrecko::EventDispatcher::EventDefinitionStruct
sceneFile | vrecko::EventDispatcher::EventDefinitionStruct
sender | vrecko::EventDispatcher::EventDefinitionStruct
type | vrecko::EventDispatcher::EventDefinitionStruct
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • EventStruct
vrecko::EventDispatcher::EventStruct Member List

This is the complete list of members for vrecko::EventDispatcher::EventStruct, including all inherited members.

eventType | vrecko::EventDispatcher::EventStruct
message | vrecko::EventDispatcher::EventStruct
pReceiver | vrecko::EventDispatcher::EventStruct
senderIdOrInputName | vrecko::EventDispatcher::EventStruct
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • ICS
vrecko::EventDispatcher::ICS Member List

This is the complete list of members for vrecko::EventDispatcher::ICS, including all inherited members.

_receiver_ptr | vrecko::EventDispatcher::ICSBase | protected
activationMessage | vrecko::EventDispatcher::ICS |
conditionalMessage | vrecko::EventDispatcher::ICS |
EventDispatcher | vrecko::EventDispatcher::ICSBase |
getReceiverPtr() | vrecko::EventDispatcher::ICSBase | inline
getReceiverPtrCore() | vrecko::EventDispatcher::ICSBase | protected
ICSBase() | vrecko::EventDispatcher::ICSBase | inline
receiver | vrecko::EventDispatcher::ICSBase |
receiverPin | vrecko::EventDispatcher::ICSBase |
sender | vrecko::EventDispatcher::ICS |
setReceiverPtrDirty() | vrecko::EventDispatcher::ICSBase | inline
type | vrecko::EventDispatcher::ICSBase |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • ICSBase
vrecko::EventDispatcher::ICSBase Member List

This is the complete list of members for vrecko::EventDispatcher::ICSBase, including all inherited members.

_receiver_ptr | vrecko::EventDispatcher::ICSBase | protected
EventDispatcher | vrecko::EventDispatcher::ICSBase |
getReceiverPtr() | vrecko::EventDispatcher::ICSBase | inline
getReceiverPtrCore() | vrecko::EventDispatcher::ICSBase | protected
ICSBase() | vrecko::EventDispatcher::ICSBase | inline
receiver | vrecko::EventDispatcher::ICSBase |
receiverPin | vrecko::EventDispatcher::ICSBase |
setReceiverPtrDirty() | vrecko::EventDispatcher::ICSBase | inline
type | vrecko::EventDispatcher::ICSBase |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • REQUEST_Struct
vrecko::EventDispatcher::REQUEST_Struct Member List

This is the complete list of members for vrecko::EventDispatcher::REQUEST_Struct, including all inherited members.

_receiver_ptr | vrecko::EventDispatcher::ICSBase | protected
EventDispatcher | vrecko::EventDispatcher::ICSBase |
getReceiverPtr() | vrecko::EventDispatcher::ICSBase | inline
getReceiverPtrCore() | vrecko::EventDispatcher::ICSBase | protected
ICSBase() | vrecko::EventDispatcher::ICSBase | inline
receiver | vrecko::EventDispatcher::ICSBase |
receiverPin | vrecko::EventDispatcher::ICSBase |
sceneFile | vrecko::EventDispatcher::REQUEST_Struct |
setReceiverPtrDirty() | vrecko::EventDispatcher::ICSBase | inline
type | vrecko::EventDispatcher::ICSBase |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • StringWithHash
vrecko::EventDispatcher::StringWithHash Member List

This is the complete list of members for vrecko::EventDispatcher::StringWithHash, including all inherited members.

calculateHash(const char *str) | vrecko::EventDispatcher::StringWithHash | inline
hashValue | vrecko::EventDispatcher::StringWithHash |
originalString | vrecko::EventDispatcher::StringWithHash |
StringWithHash() | vrecko::EventDispatcher::StringWithHash | inline
StringWithHash(const std::string &str) | vrecko::EventDispatcher::StringWithHash | inline
StringWithHash(const StringWithHash &src) | vrecko::EventDispatcher::StringWithHash | inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • EventDispatcher
  • StringWithHashComparator
vrecko::EventDispatcher::StringWithHashComparator Member List

This is the complete list of members for vrecko::EventDispatcher::StringWithHashComparator, including all inherited members.

operator()(const StringWithHash &a, StringWithHash const &b) vrecko::EventDispatcher::StringWithHashComparator inline
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • OutputNotificationFuncStored
vrecko::Logger::OutputNotificationFuncStored Member List

This is the complete list of members for vrecko::Logger::OutputNotificationFuncStored, including all inherited members.

outFunc | vrecko::Logger::OutputNotificationFuncStored
userParam | vrecko::Logger::OutputNotificationFuncStored
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Logger
  • TimingInfo
vrecko::Logger::TimingInfo Member List

This is the complete list of members for vrecko::Logger::TimingInfo, including all inherited members.

numRuns | vrecko::Logger::TimingInfo |
startTime | vrecko::Logger::TimingInfo |
TimingInfo() | vrecko::Logger::TimingInfo | inline
totalTime | vrecko::Logger::TimingInfo |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • OctTree
  • OctTreeNode
vrecko::OctTree::OctTreeNode Member List

This is the complete list of members for vrecko::OctTree::OctTreeNode, including all inherited members.

child_nodes | vrecko::OctTree::OctTreeNode
isCell | vrecko::OctTree::OctTreeNode
object_count | vrecko::OctTree::OctTreeNode
objects_in_cell | vrecko::OctTree::OctTreeNode
parent_node | vrecko::OctTree::OctTreeNode
position | vrecko::OctTree::OctTreeNode
subspace_size | vrecko::OctTree::OctTreeNode
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ReaderWriter
  • AbilityToInitialize
vrecko::ReaderWriter::AbilityToInitialize Member List

This is the complete list of members for vrecko::ReaderWriter::AbilityToInitialize, including all inherited members.

ability | vrecko::ReaderWriter::AbilityToInitialize |
AbilityToInitialize(Ability *_ab, XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *_params) | vrecko::ReaderWriter::AbilityToInitialize | inline
parameters | vrecko::ReaderWriter::AbilityToInitialize |
Generated on Sun Feb 17 2013 23:30:13 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • OBJ_INT_PRIO
vrecko::Scene::OBJ_INT_PRIO Member List

This is the complete list of members for vrecko::Scene::OBJ_INT_PRIO, including all inherited members.

objInt | vrecko::Scene::OBJ_INT_PRIO
priority | vrecko::Scene::OBJ_INT_PRIO
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scene
  • SC_INT_PRIO
vrecko::Scene::SC_INT_PRIO Member List

This is the complete list of members for vrecko::Scene::SC_INT_PRIO, including all inherited members.

priority | vrecko::Scene::SC_INT_PRIO
scInt | vrecko::Scene::SC_INT_PRIO
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • ScenePSThreadInfo
vrecko::ScenePSThreadInfo Member List

This is the complete list of members for vrecko::ScenePSThreadInfo, including all inherited members.

bTerminateThread | vrecko::ScenePSThreadInfo
hThreadHandle | vrecko::ScenePSThreadInfo
lastRequest | vrecko::ScenePSThreadInfo
limitToEO1 | vrecko::ScenePSThreadInfo
limitToEO2 | vrecko::ScenePSThreadInfo
params | vrecko::ScenePSThreadInfo
scene | vrecko::ScenePSThreadInfo
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
  • TimerStruct
vrecko::Scheduler::TimerStruct Member List

This is the complete list of members for vrecko::Scheduler::TimerStruct, including all inherited members.

entity_vector | vrecko::Scheduler::TimerStruct
frequency | vrecko::Scheduler::TimerStruct
last_tick | vrecko::Scheduler::TimerStruct
thread_ptr | vrecko::Scheduler::TimerStruct
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • Scheduler
  • classcomp
vrecko::Scheduler::classcomp Member List

This is the complete list of members for vrecko::Scheduler::classcomp, including all inherited members.

operator()(const long int &lhs, const long int &rhs) const vrecko::Scheduler::classcomp inline
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • AvatarEye
vrecko::World::AvatarEye Member List

This is the complete list of members for vrecko::World::AvatarEye, including all inherited members.

eye_offset | vrecko::World::AvatarEye
projection | vrecko::World::AvatarEye
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • AvatarView
vrecko::World::AvatarView Member List

This is the complete list of members for vrecko::World::AvatarView, including all inherited members.

eye_position | vrecko::World::AvatarView
ID | vrecko::World::AvatarView
look_at_center | vrecko::World::AvatarView
owner | vrecko::World::AvatarView
up_vector | vrecko::World::AvatarView
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vrecko
  • World
  • SG_CHANGE
vrecko::World::SG_CHANGE Member List

This is the complete list of members for vrecko::World::SG_CHANGE, including all inherited members.

pGroup | vrecko::World::SG_CHANGE
pNode | vrecko::World::SG_CHANGE
pStateSet | vrecko::World::SG_CHANGE
pText | vrecko::World::SG_CHANGE
text_string | vrecko::World::SG_CHANGE
type | vrecko::World::SG_CHANGE
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • OptiTrack
  • info_struct
vreckoDP_base::OptiTrack::info_struct Member List

This is the complete list of members for vreckoDP_base::OptiTrack::info_struct, including all inherited members.

pOT | vreckoDP_base::OptiTrack::info_struct
T_ID | vreckoDP_base::OptiTrack::info_struct
Generated on Sun Feb 17 2013 23:30:15 for vrecko by doxygen 1.8.3.1


vrecko: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • vreckoDP_base
  • dataT
vreckoDP_base::dataT Member List

This is the complete list of members for vreckoDP_base::dataT, including all inherited members.

callback | vreckoDP_base::dataT
data | vreckoDP_base::dataT
Generated on Sun Feb 17 2013 23:30:14 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
subblock.h
Go to the documentation of this file.
1 #ifndef _SUBBLOCK
2 #define _SUBBLOCK 1
3
4 #include <string>
5 #include "subblock_animation.h"
6
7
8 //using namespace vrecko;
9 using namespace std;
10
11 namespace ArtificialWorld
12 {
14 class SubBlock{
15 public:
16 SubBlock(void);
17 ~SubBlock(void){};
18
20 void SetFileName(string fname) { filename = fname; };
22 void SetPosition(osg::Vec3 pos) { position = pos; };
24 void SetRotation(osg::Quat rot) { rotation = rot; };
26 void SetMaxVisibleDistance(unsigned long dist) { maxVisibleDistance = dist; hasMaxVisibleDistance = true; };
28 void SetSubBlockType(string sbType) { subBlockType = sbType; };
29
31 bool HasMaxVisibleDistance(void) { return hasMaxVisibleDistance; };
32
34 osg::Vec3 GetPosition(void) { return position; };
36 osg::Quat GetRotation(void) { return rotation; };
38 string GetFileName(void) { return filename; };
40 unsigned long GetMaxVisibleDistance(void) { return maxVisibleDistance; };
42 string GetSubBlockType(void) { return subBlockType; };
43
45 SubBlockAnimation* GetAnimation(void){
46 if(hasAnimation)
47 return &animation;
48 else
49 return NULL;
50 };
52 void SetAnimation(void)
53 {
54 hasAnimation = true;
55 };
57 bool HasAnimation(void){ return hasAnimation; };
59 void DeleteAnimation(void){
60 hasAnimation = false;
61 animation.ClearAnimation();
62 };
63
64 protected:
66 osg::Vec3 position;
68 osg::Quat rotation;
70 unsigned long maxVisibleDistance;
72 string filename;
74 string subBlockType;
75
77 bool hasMaxVisibleDistance;
78
80 bool hasAnimation;
82 SubBlockAnimation animation;
83 };
84 }
85
86 #endif
87
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/ArtificialWorld/subblock_animation.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • ArtificialWorld
subblock_animation.h
Go to the documentation of this file.
1 #ifndef _subblock_animation
2 #define _subblock_animation 1
3
4 #include <osg/Vec3>
5 #include <osg/Quat>
6 #include <osg/Node>
7 #include <vector>
8 #include "awHelper.h"
9
10 using namespace std;
11
12 namespace ArtificialWorld
13 {
15 enum AnimationType {
17 ScaleRotateTranslation = 1,
19 Alpha = 2,
21 NodeMask = 4
22 };
23
25 enum AnimationLoopType{
27 NoLoop,
29 Simple,
31 BiDirectional
32 };
33
35 enum AnimationInterpolationType{
37 Linear,
39 Sine
40 };
41
43 class AnimationPoint{
44 public:
46 osg::Vec3 translation;
48 osg::Quat rotation;
50 osg::Vec3 scale;
52 float alpha;
54 osg::Node::NodeMask nodeMask;
55
57 bool translationSet;
59 bool rotationSet;
61 bool scaleSet;
63 bool alphaSet;
65 bool nodeMaskSet;
66
67 AnimationPoint():translation(0.0, 0.0, 0.0), rotation(0.0, 0.0, 0.0, 0.0), scale(1.0, 1.0, 1.0), alpha(1.0), nodeMask(0x00000000){
68 translationSet = false;
69 rotationSet = false;
70 scaleSet = false;
71 alphaSet = false;
72 nodeMaskSet = false;
73 };
74 AnimationPoint(osg::Vec3 trans, osg::Quat rot, osg::Vec3 scal, float alfa, osg::Node::NodeMask nmask):
75 translation(trans), rotation(rot), scale(scal), alpha(alfa), nodeMask(nmask)
76 { translationSet = true;
77 rotationSet = true;
78 scaleSet = true;
79 alphaSet = true;
80 nodeMaskSet = true;
81 }
82 };
83
85 class SubBlockAnimation{
86 public:
88 SubBlockAnimation(){
89 animationType = 0;
90 interpolation = ArtificialWorld::Linear;
91 looping = AnimationLoopType::NoLoop;
92 timeForLoop = 1;
93 };
94 ~SubBlockAnimation(){ animationPoints.clear(); };
95
97 void AddAnimationPoint(AnimationPoint newPoint){ animationPoints.push_back(newPoint); };
99 int NumberOfAnimantionPoints(void){ return animationPoints.size(); };
101 AnimationPoint* GetAnimationPoint(int index){ return &(animationPoints.at(index)); };
103 void ClearAnimationPoints(void){ animationPoints.clear(); };
104
106 void SetAnimationType(unsigned int newType){ animationType = newType; };
108 unsigned int GetAnimationType(void){ return animationType; };
109
111 void SetInterpolation(AnimationInterpolationType newInterpolation){ interpolation = newInterpolation; };
113 AnimationInterpolationType GetInterpolation(void){ return interpolation; };
114
116 void SetLoopType(AnimationLoopType newLoop){ looping = newLoop; };
118 AnimationLoopType GetLoopType(void){ return looping; };
119
121 void SetTimePerLoop(int time){ timeForLoop = time; };
123 int GetTimePerLoop(void){ return timeForLoop; };
124
126 void ClearAnimation(void){
127 ClearAnimationPoints();
128 SetAnimationType(0);
129 SetInterpolation(Linear);
130 SetLoopType(NoLoop);
131 SetTimePerLoop(1);
132 };
133
134 protected:
136 vector<AnimationPoint> animationPoints;
138 unsigned int animationType;
140 AnimationInterpolationType interpolation;
142 AnimationLoopType looping;
144 int timeForLoop;
145
146 };
147
148 }
149
150 #endif
151
Generated on Sun Feb 17 2013 23:29:44 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/SpacePartitioning/triangleCube.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • SpacePartitioning
triangleCube.h
Go to the documentation of this file.
1 /*
2 * This class is taken from somewhere in the web and changes has been made to make it work for our purposes.
3 */
4
5 //#include "precompiled.h"
6 #include <math.h>
7
8 typedef struct {
9 float x;
10 float y;
11 float z;
12 } Point3;
13
14 typedef struct{
15 Point3 v1; /* Vertex1 */
16 Point3 v2; /* Vertex2 */
17 Point3 v3; /* Vertex3 */
18 } Triangle3;
19
20 long face_plane(Point3 p);
21 long bevel_2d(Point3 p);
22 long bevel_3d(Point3 p);
23 long check_point(Point3 p1, Point3 p2, float alpha, long mask);
24 long check_line(Point3 p1, Point3 p2, long outcode_diff);
25 long point_triangle_intersection(Point3 p, Triangle3 t);
26 long t_c_intersection(Triangle3 t);
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtleinterpret.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
turtleinterpret.h
Go to the documentation of this file.
1 #ifndef TURTLEINTERPRET_H_
2 #define TURTLEINTERPRET_H_
3
4 #include "abstractinterpret.h"
5 #include "lsgeode.h"
6
7 namespace AP_LSystem {
12 class TurtleInterpret : public AbstractInterpret
13 {
14 public:
20 TurtleInterpret( osg::Group * owner );
21
22 ~TurtleInterpret(void);
23
24 virtual int parse( ParseableString * word );
25 };
26 }
27
28 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/turtlestack.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
turtlestack.h
Go to the documentation of this file.
1 #ifndef TURTLESTACK_H_
2 #define TURTLESTACK_H_
3
4 #include <stack>
5 #include "abstractturtle.h"
6 #include "lsgeode.h"
7
8 using std::stack;
9
10 namespace AP_LSystem {
11
15 class TurtleStack
16 {
17 private:
18 stack< AbstractTurtle * > m_Turtles;
19
25 AbstractTurtle * createTurtle( TurtleType type );
26 public:
27 TurtleStack(void);
28 ~TurtleStack(void);
29
34 int pop( );
35
42 int push( );
43
50 int push( LSGeode * geode);
51
56 AbstractTurtle * top( );
57
61 void clear( );
62 };
63 }
64
65 #endif
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vrecko/vThread.h Source File

  • File List
  • File Members
  • include
  • vrecko
vThread.h
Go to the documentation of this file.
1 /***************************************************************************
2 vThread.h - description
3 -------------------
4 begin : September 2004
5 copyright : (C) 2004 by Jan Flasar
6 email : flasar@fi.muni.cz
7 ***************************************************************************/
8
9
10 #ifndef VTHREAD_H
11 #define VTHREAD_H
12
13 #include <vrecko/BaseClass.h>
14
15 #ifdef WIN32
16 #include <windows.h>
17 #else
18 #include <unistd.h>
19 #endif
20
21 #include <map>
22 #include <vector>
23 #include <osg/Timer>
24
25
26 namespace vrecko {
27
28 class BaseClass;
29
30 class VRECKO_EXPORT vThread {
31 public:
32 vThread(BaseClass *ent_ptr, float freq);
33 vThread(std::vector<BaseClass*> ent_vec, float freq);
34 vThread(void (*funcPtr)(void), float freq);
35 vThread(void (*funcPtr)(void), unsigned int step, float freq);
36 ~vThread();
37
38 void start(void) {run = true;}
39 void stop(void) {run = false;}
40
41 bool getDone(void) {return done;}
42 bool getRun(void) {return run;}
43 float getFrequency(void) {return frequency;}
44 osg::Timer_t getLastTick(void) {return last_tick;}
45 BaseClass *getEntityPtr(int pos) {return (*entity_vector)[pos];}
46 bool addEntity(BaseClass *ent);
47 bool removeEntity(BaseClass *ent);
48 void syncEntityVector(void);
49 std::vector<BaseClass*> *getEntityVec(void) {return entity_vector;}
50 void (*getFuncPtr(void))() {return voidFuncPtr;}
51 unsigned int getStepCounter(void) {return step_counter;}
52
53 #ifdef WIN32
54 static HANDLE createMutex();
55 static void destroyMutex(HANDLE mutex);
56 HANDLE getMutex(void) {return hvT_Mutex;}
57 #else
58 static pthread_mutex_t *createMutex();
59 static void destroyMutex(pthread_mutex_t *mutex);
60 pthread_mutex_t *getMutex(void) {return hvT_Mutex;}
61 #endif
62
63 void reportError(const std::string &error);
64 inline void reportError(char* error) { reportError(std::string(error)); }
65
66 static unsigned long getDelay(osg::Timer_t last_t, float freq);
67 inline unsigned long getDelay(void) { return getDelay(last_tick, frequency); }
68
69 static const osg::Timer *getTimerPtr(void) {return timer;}
70 osg::Timer_t last_tick;
71
72 protected:
73 #ifndef WIN32
74 pthread_t th_read;
75 #else
76 DWORD dwThreadId, dwThrdParam;
77 HANDLE hThread;
78 #endif
79 static const osg::Timer *timer;
80 std::vector<BaseClass*> *entity_vector;
81 std::map<BaseClass*, bool> temp_entity_map;
82 void (*voidFuncPtr)(void);
83 float frequency;
84 bool done, run;
85 unsigned int step_counter;
86
87 #ifdef WIN32
88 HANDLE hvT_Mutex;
89 #else
90 pthread_mutex_t *hvT_Mutex;
91 #endif
92 };
93
94 }
95
96 #endif
97
Generated on Sun Feb 17 2013 23:29:43 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vrecko/precompiled.h Source File

  • File List
  • File Members
  • src
  • vrecko
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #ifndef RELEASE_WITH_DEBUG_INFO
12
13 #pragma message("*")
14 #pragma message("==============================")
15 #pragma message("ERROR : At this time the only supported configuration is \"Release with Debug info\". Please switch to it and restart compilation.")
16 #pragma message("==============================")
17 #pragma message("*")
18
19 ERROR
20
21 #else
22
23 #include <stdio.h>
24 #include <vector>
25 #include <string>
26 #include <fstream>
27 #include <sstream>
28 #include <set>
29 #include <list>
30 #include <map>
31 #include <time.h>
32
33 #ifdef WIN32
34 #define WIN32_LEAN_AND_MEAN
35 #include <windows.h>
36 #else
37 #include <pthread.h>
38 #include <unistd.h>
39 #include <sys/time.h>
40 #endif
41
42 #include <osg/Vec2>
43 #include <osg/Vec3>
44 #include <osg/Vec4>
45 #include <osg/Node>
46 #include <osg/Matrix>
47 #include <osg/Quat>
48 #include <osg/MatrixTransform>
49 #include <osg/Timer>
50 #include <osg/Notify>
51 #include <osg/Group>
52 #include <osgUtil/SmoothingVisitor>
53
54 #include <osgDB/DynamicLibrary>
55
56 #include <osgText/Text>
57
58 #include <osgViewer/Viewer>
59
60 #include <xercesc/util/XercesDefs.hpp>
61 #include <xercesc/dom/DOM.hpp>
62 #include <xercesc/util/XMLString.hpp>
63 #include <xercesc/parsers/AbstractDOMParser.hpp>
64
65 #include <helpers/StringHelpers.h>
66
67 #if defined(XERCES_NEW_IOSTREAMS)
68 #include <iostream>
69 #else
70 #include <iostream.h>
71 #endif
72
73 #include <esg/Definitions.h>
74 #include <esg/OSGAdapter.h>
75
76 #include <helpers/XercesXMLUtils.h>
77
78 #include <vrecko/Timer.h>
79 #include <vrecko/Ability.h>
80 #include <vrecko/World.h>
81 #include <vrecko/EnvironmentObject.h>
82 #include <vrecko/EventDispatcher.h>
83 #include <vrecko/Device.h>
84 #include <vrecko/Scene.h>
85 #include <vrecko/Logger.h>
86 #include <vrecko/Message.h>
87 #include <vrecko/PersistentCache.h>
88 #include <vrecko/Scheduler.h>
89 #include <vrecko/ReaderWriter.h>
90 #include <vrecko/PluginManager.h>
91
92 #endif
93
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ArtificialWorld/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • ArtificialWorld
precompiled.h
Go to the documentation of this file.
1 #include <iostream>
2 #include <sstream>
3 #include <fstream>
4 #include <string.h>
5 #include <list>
6 #include <list>
7
8
9 #include <Windows.h>
10
11
12 #include <osg/Vec3>
13 #include <osg/Quat>
14 #include <osg/Node>
15
16 #include <xercesc/dom/DOM.hpp>
17 #include <xercesc/parsers/XercesDOMParser.hpp>
18 #include <xercesc/sax/HandlerBase.hpp>
19 #include <xercesc/util/XMLString.hpp>
20 #include <xercesc/util/PlatformUtils.hpp>
21 #include <xercesc/dom/DOMWriter.hpp>
22 #include <xercesc/framework/StdOutFormatTarget.hpp>
23 #include <xercesc/framework/LocalFileFormatTarget.hpp>
24
25
26 #include <helpers/XercesXMLUtils.h>
27
28 #include <vrecko/Ability.h>
29 #include <vrecko/EnvironmentObject.h>
30 #include <vrecko/World.h>
31 #include <vrecko/Logger.h>
32 #include <vrecko/PluginManager.h>
33 #include <vrecko/ReaderWriter.h>
34 #include <vrecko/Scene.h>
35 #include <vrecko/EventDispatcher.h>
36
37 #include <helpers/StringHelpers.h>
38
39 #include <vreckoAP/ObjectUtils/Animator.h>
40
41 #include <vreckoAP/ArtificialWorld/awHelper.h>
42 #include <vreckoAP/ArtificialWorld/subblock.h>
43 #include <vreckoAP/ArtificialWorld/model.h>
44 #include <vreckoAP/ArtificialWorld/BlockUpdater.h>
45 #include <vreckoAP/ArtificialWorld/Cache.h>
46 #include <vreckoAP/ArtificialWorld/WorldBuilder.h>
47 #include <vreckoAP/ArtificialWorld/ModelManager.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/CarSim/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • CarSim
precompiled.h
Go to the documentation of this file.
1 #include <sstream>
2 #include <limits>
3
4 #include <vrecko/EnvironmentObject.h>
5 #include <vrecko/EventDispatcher.h>
6 #include <vrecko/ReaderWriter.h>
7 #include <vrecko/World.h>
8 #include <vrecko/Scene.h>
9 #include <vrecko/Logger.h>
10
11
12 #include <osg/Material>
13 #include <osg/Geometry>
14 #include <osg/Geode>
15 #include <osg/Texture2D>
16
17 #include <osgDB/ReadFile>
18
19 #include <helpers/XercesXMLUtils.h>
20
21 #include <vreckoAP/CarSim/AP_CarSim.h>
22 #include <vreckoAP/CarSim/CarControlUnit.h>
23 #include <vreckoAP/CarSim/CarExecutionUnit.h>
24 #include <vreckoAP/CarSim/RoadsState.h>
25 #include <vreckoAP/CarSim/Remover.h>
26 #include <vreckoAP/CarSim/CarPartsNodeCache.h>
27 #include <vreckoAP/CarSim/TLsOnJuncManager.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ConnectEditor/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • ConnectEditor
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #include <vrecko/Ability.h>
13 #include <vrecko/EnvironmentObject.h>
14 #include <vrecko/EventDispatcher.h>
15
16 #include <vrecko/PluginManager.h>
17
18 #include <vreckoAP/EditorController/ControllableAbility.h>
19
20 #include <helpers/DynamicArray.h>
21 #include <helpers/XercesXMLUtils.h>
22
23 #include <stdlib.h>
24 #include <iostream>
25 #include <sstream>
26 #include <math.h>
27 #include <time.h>
28
29 #include <osg/PolygonMode>
30
31 #include <osgDB/ReadFile>
32
33 #include <osgGA/StateSetManipulator>
34
35
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/DynamicArt/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • DynamicArt
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #define NOMINMAX
12
13 #include <Windows.h>
14 // OSG particle systems
15 #include <osg/Point>
16 #include <osg/PointSprite>
17 #include <osg/Texture2D>
18 #include <osg/BlendFunc>
19 #include <osgDB/ReadFile>
20 #include <osgGA/StateSetManipulator>
21 #include <osgParticle/ParticleSystem>
22 #include <osgParticle/ParticleSystemUpdater>
23 #include <osgParticle/ModularEmitter>
24 #include <osgParticle/ModularProgram>
25 #include <osgParticle/AccelOperator>
26 #include <osgParticle/FluidFrictionOperator>
27 #include <osgDB/WriteFile>
28 #include <osg/Geode>
29 #include <osg/ShapeDrawable>
30 #include <osg/StateSet>
31 #include <osg/PolygonMode>
32 #include <osg/Depth>
33 #include <osg/ClipNode>
34 #include <osgUtil/SmoothingVisitor>
35
36 // OSG particle systems
37
38
39 #include <vrecko/Ability.h>
40
41 #include <vreckoAP/EditorController/ControllableAbility.h>
42
43 #include <vrecko/EventDispatcher.h>
44 #include <vrecko/Logger.h>
45 #include <vrecko/Message.h>
46 #include <vrecko/Scene.h>
47 #include <vrecko/PluginManager.h>
48 #include <vrecko/ReaderWriter.h>
49
50 #include <vreckoAP/GUI/GUI_Controller.h>
51 #include <vreckoAP/GUI/Menu.h>
52
53 //vrecko utils
54 #include <vreckoUtils/Menu.h>
55
56 #include <fstream>
57 #include <iostream>
58 #include <sstream>
59 #include <vector>
60 #include <math.h>
61
62 #include <xercesc/dom/DOM.hpp>
63 #include <xercesc/dom/DOMWriter.hpp>
64 #include <xercesc/framework/LocalFileFormatTarget.hpp>
65 #include <xercesc/framework/StdOutFormatTarget.hpp>
66 #include <xercesc/parsers/XercesDOMParser.hpp>
67 #include <xercesc/sax/HandlerBase.hpp>
68 #include <xercesc/util/PlatformUtils.hpp>
69 #include <xercesc/util/XMLString.hpp>
70
71
72 #define absf(x)(x<0.0?-x:x)
73
74 #define MAX_NUMBER_OF_TRACKED_SENSORS 9
75
76
77 #define MINIMAL_DISTANCE_BETWEEN_CONTROL_POINTS 0.05
78
79 #define DYNAMICART_PATH (string) "data/DynamicArt/"
80 #define AUTOSAVE_PATH (string) "data/DynamicArt/Autosave/"
81 #define USER_PATH (string) "data/DynamicArt/UserData/"
82 #define CURSORS_PATH (string) "data/DynamicArt/Models/Cursors/"
83 #define TEMPLATES_PATH (string) "data/DynamicArt/Templates/"
84 #define SYMMETRIES_PATH (string) "data/DynamicArt/Symmetries/"
85
86 #define MENU_SELECTED_ITEM_COLOR osg::Vec3(0.75, 1.0, 0.75)
87 #define MENU_NOTAVAILABLE_ITEM_COLOR osg::Vec4(0.35, 0.35, 0.35, 1.0)
88
89 typedef enum BrushStrokeInterpolationType {
90 BrushStroke_Interpolation_NONE = 0,
91 BrushStroke_Interpolation_LINEAR = 1,
92 BrushStroke_Interpolation_CUBIC,
93 BrushStroke_Interpolation_CATMULLROM,
94 BrushStroke_Interpolation_CIRCLE,
95 BrushStroke_Interpolation_USER_PREDEFINED,
96
97 };
98
99
100
101
103 inline string printColor(osg::Vec4 col)
104 {
105 std::ostringstream stream;
106 stream << "<Color>" << col.x() << " " << col.y() << " " << col.z() << "</Color>";
107 return stream.str();
108 }
109
110
111 //TODO move elsewhere
112 class DASample
113 {
114 public:
115 inline DASample() {this->position = osg::Vec3(0.0, 0.0, 0.0); this->orientation = osg::Quat(0.0, 0.0, 1.0, 0.0); }
116 DASample(osg::Vec3 p_pos, osg::Quat p_orient) {this->position = p_pos; this->orientation = p_orient; }
117
118 osg::Vec3 position;
119 osg::Quat orientation;
120 };
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/EditorQAbilities/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • EditorQAbilities
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <vrecko/Ability.h>
12 #include <vrecko/EnvironmentObject.h>
13 #include <vrecko/EventDispatcher.h>
14 #include <vrecko/Scene.h>
15 #include <vrecko/World.h>
16 #include <vrecko/Message.h>
17
18 #include <vrecko/PluginManager.h>
19 #include <vrecko/ReaderWriter.h>
20
21 #include <vreckoAP/EditorController/ControllableAbility.h>
22 #include <vreckoAP/ObjectUtils/ObjectInfo.h>
23
24 #include <helpers/DynamicArray.h>
25 #include <helpers/HelperMacros.h>
26 #include <helpers/StringHelpers.h>
27 #include <helpers/XercesXMLUtils.h>
28
29 #include <iostream>
30 #include <sstream>
31 #include <vector>
32 #include <math.h>
33
34 #include <osg/Vec3>
35 #include <osg/Quat>
36 #include <osg/io_utils>
37 #include <osg/Geometry>
38 #include <osg/Geode>
39 #include <osg/ShapeDrawable>
40 #include <osg/StateSet>
41 #include <osg/Material>
42 #include <osg/CullFace>
43 #include <osg/LightModel>
44
45 #include <xercesc/dom/DOMNamedNodeMap.hpp>
46 #include <xercesc/parsers/XercesDOMParser.hpp>
47 #include <xercesc/dom/DOM.hpp>
48 #include <xercesc/sax/HandlerBase.hpp>
49 #include <xercesc/util/XMLString.hpp>
50 #include <xercesc/util/PlatformUtils.hpp>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/FFDEditor/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • FFDEditor
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #include <float.h>
13
14 #include <osg/Geode>
15 #include <osg/Geometry>
16 #include <osg/Group>
17 #include <osg/Node>
18 #include <osg/PrimitiveSet>
19 #include <osg/Vec3>
20
21 #include <vrecko/Ability.h>
22 #include <vrecko/EnvironmentObject.h>
23 #include <vrecko/World.h>
24 #include <vrecko/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/GUI/Menu.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • GUI
Menu.h
Go to the documentation of this file.
1 #pragma once
2
3 #include "GUI_item.h"
4
5 # ifdef GUI_LIBRARY
6 # define GUI_EXPORT __declspec(dllexport)
7 # else
8 # define GUI_EXPORT __declspec(dllimport)
9 #endif
10
11 namespace APGUI
12 {
13
14
16
24 class GUI_EXPORT Menu : public GUI_Item
25 {
26 public:
27
28 Menu();
29 ~Menu();
30
39 bool initialize(XERCES_CPP_NAMESPACE_QUALIFIER DOMNode *parametersNode);
40
53 bool initialize( string name, string receiver, int sensor, string label = "", string tooltip = "", bool pointable = true );
54
55 void pointed(bool pointed) { }
56
58 bool processAction( const int sensorNumber, const GUI_ACTION action, const bool pressed);
59
60
61 void setState(GUI_ITEM_STATE newState);
62
63 protected:
64
66 int _activeSensor;
67
69 bool _opened;
70
72 vrecko::Ability * _dynamicMenuAbility;
73
75 bool postInitialize( string name, string receiver, int sensorNumber, string label, string tooltip );
76
77 //addInput("HidingMenu", BaseClass::BOOL);
78 DECLARE_INPUT(HidingMenu, MessageBool);
79
80 //addOutput("CreateMenuStructure", BaseClass::INT);
81 DECLARE_OUTPUT(CreateMenuStructure, MessageInt);
82
83 //addOutput("ButtonPress", BaseClass::BOOL);
84 DECLARE_OUTPUT(ButtonPress, MessageBool);
85
86 //addRequestOutput("ActivePointerID", BaseClass::ULONG);
87 DECLARE_REQUEST_OUTPUT(ActivePointerID, MessageInt, MessageInt);
88 };
89
90 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/GUI/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • GUI
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on pre-compiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <osgDB/ReadFile>
12 #include <osgDB/WriteFile>
13 #include <osg/Geode>
14 #include <osg/ShapeDrawable>
15 #include <osg/StateSet>
16 #include <osg/PolygonMode>
17 #include <osg/Depth>
18 #include <osg/ClipNode>
19 #include <osgUtil/SmoothingVisitor>
20 #include <osg/Switch>
21 #include <osg/BlendFunc>
22
23 #include <vrecko/Ability.h>
24 #include <vrecko/EventDispatcher.h>
25 #include <vrecko/Logger.h>
26 #include <vrecko/Message.h>
27 #include <vrecko/Scene.h>
28 #include <vrecko/PluginManager.h>
29 #include <vrecko/ReaderWriter.h>
30
31 #include <fstream>
32 #include <iostream>
33 #include <sstream>
34 #include <vector>
35 #include <math.h>
36
37 #include <xercesc/dom/DOM.hpp>
38 #include <xercesc/dom/DOMWriter.hpp>
39 #include <xercesc/framework/LocalFileFormatTarget.hpp>
40 #include <xercesc/framework/StdOutFormatTarget.hpp>
41 #include <xercesc/parsers/XercesDOMParser.hpp>
42 #include <xercesc/sax/HandlerBase.hpp>
43 #include <xercesc/util/PlatformUtils.hpp>
44 #include <xercesc/util/XMLString.hpp>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/Garden/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • Garden
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #ifdef _MSC_VER
12
13 #include <vrecko/Ability.h>
14 #include <vrecko/EventDispatcher.h>
15 #include <vrecko/EnvironmentObject.h>
16 #include <vrecko/Logger.h>
17 #include <vrecko/Scene.h>
18
19 //#include <osgDB/PluginManager.h>
20 #include <vrecko/ReaderWriter.h>
21
22 #include <osg/Geometry>
23 #include <osg/Geode>
24 #include <osg/Vec3>
25 #include <osg/ref_ptr>
26 #include <osg/Image>
27 #include <osg/Texture2D>
28 #include <osg/ShapeDrawable>
29 #include <osg/AlphaFunc>
30 #include <osg/BlendFunc>
31 #include <osg/LightModel>
32 #include <osgShadow/ShadowedScene>
33 #include <osgShadow/ShadowMap>
34 #include <osgShadow/SoftShadowMap>
35 #include <osgShadow/ShadowVolume>
36 #include <osgShadow/ShadowTexture>
37 #include <osgDB/ReadFile>
38
39 #include <xercesc/parsers/XercesDOMParser.hpp>
40 #include <xercesc/dom/DOM.hpp>
41 #include <xercesc/dom/DOMImplementation.hpp>
42 #include <xercesc/sax/HandlerBase.hpp>
43 #include <xercesc/util/XMLString.hpp>
44 #include <xercesc/util/PlatformUtils.hpp>
45 #include <xercesc/dom/DOMWriter.hpp>
46 #include <xercesc/framework/StdOutFormatTarget.hpp>
47 #include <xercesc/framework/LocalFileFormatTarget.hpp>
48 #include <helpers/XercesXMLUtils.h>
49
50 //#include "fparser/fparser.hh"
51
52 //#include <../EditorController/ControllableAbility.h>
53
54 #include <tchar.h>
55 #include <cstdlib>
56 #include <cstdio>
57 #include <sstream>
58 #include <fstream>
59 #include <map>
60 #include <set>
61 #include <vector>
62 #include <stack>
63 #include <string>
64 #include <exception>
65
66 //#include "configuration.h"
67
68 #endif // _MSC_VER
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/HeadTracking/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • HeadTracking
precompiled.h
Go to the documentation of this file.
1 #pragma once
2
3
4 #include <osg/Vec3>
5 #include <osg/Matrixf>
6
7 #include <vrecko/Ability.h>
8 #include <vreckoAP/Export>
9
10 #include <vrecko/World.h>
11 #include <vrecko/Scene.h>
12 #include <vrecko/ReaderWriter.h>
13
14 #include <vreckoAP/HeadTracking/Vec2i>
15 #include <vreckoAP/HeadTracking/Solver.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/InputConnector/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • InputConnector
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on pre-compiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <fstream>
12 #include <iostream>
13 #include <sstream>
14 #include <vector>
15 #include <math.h>
16
17 #include <vrecko/Ability.h>
18 #include <vrecko/EventDispatcher.h>
19 #include <vrecko/Logger.h>
20 #include <vrecko/Message.h>
21 #include <vrecko/Scene.h>
22 #include <vrecko/PluginManager.h>
23 #include <vrecko/ReaderWriter.h>
24
25 #include <osgDB/ReadFile>
26
27 #include <xercesc/dom/DOM.hpp>
28 #include <xercesc/dom/DOMWriter.hpp>
29 #include <xercesc/framework/LocalFileFormatTarget.hpp>
30 #include <xercesc/framework/StdOutFormatTarget.hpp>
31 #include <xercesc/parsers/XercesDOMParser.hpp>
32 #include <xercesc/sax/HandlerBase.hpp>
33 #include <xercesc/util/PlatformUtils.hpp>
34 #include <xercesc/util/XMLString.hpp>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ObjectUtils/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • ObjectUtils
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #include <vrecko/Ability.h>
13 #include <vrecko/EventDispatcher.h>
14 #include <vrecko/EnvironmentObject.h>
15 #include <vrecko/Scene.h>
16
17 #include <vrecko/PluginManager.h>
18
19 #include <helpers/DynamicArray.h>
20 #include <helpers/XercesXMLUtils.h>
21
22 #include <math.h>
23
24 #include <osg/BlendColor>
25 #include <osg/BlendFunc>
26 #include <osg/Geode>
27 #include <osg/Group>
28 #include <osg/ShapeDrawable>
29
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
precompiled.h
Go to the documentation of this file.
1 #include <string.h>
2 #include <sstream>
3
4
5 #include <vrecko/Scene.h>
6 #include <vrecko/Message.h>
7 #include <vrecko/EventDispatcher.h>
8 #include <vrecko/ReaderWriter.h>
9
10 #include <osg/Vec3>
11 #include <osg/Quat>
12 #include <osg/Matrix>
13 #include <osg/MatrixTransform>
14
15 #include "NXU_helper.h"
16 #include "NxCooking.h"
17
18 #include <xercesc/dom/DOMNode.hpp>
19 #include <xercesc/util/XMLString.hpp>
20
21 #include "Helper.h"
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/ShootingSimulation/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • ShootingSimulation
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <vrecko/Ability.h>
12 #include <vrecko/EnvironmentObject.h>
13 #include <vrecko/EventDispatcher.h>
14 #include <vrecko/Scene.h>
15 #include <vrecko/World.h>
16 #include <vrecko/Message.h>
17
18 #include <vrecko/PluginManager.h>
19 #include <vrecko/ReaderWriter.h>
20
21 #include "../EditorController/ControllableAbility.h"
22
23 #include "../ObjectUtils/ObjectInfo.h"
24
25 #include <helpers/DynamicArray.h>
26 #include <helpers/HelperMacros.h>
27 #include <helpers/StringHelpers.h>
28 #include <helpers/XercesXMLUtils.h>
29
30 #include <iostream>
31 #include <sstream>
32 #include <vector>
33 #include <math.h>
34
35 #include <osg/Vec3>
36 #include <osg/Quat>
37 #include <osg/io_utils>
38 #include <osg/Geometry>
39 #include <osg/Geode>
40 #include <osg/ShapeDrawable>
41 #include <osg/StateSet>
42 #include <osg/Material>
43 #include <osg/CullFace>
44 #include <osg/LightModel>
45
46 #include <xercesc/dom/DOMNamedNodeMap.hpp>
47 #include <xercesc/parsers/XercesDOMParser.hpp>
48 #include <xercesc/dom/DOM.hpp>
49 #include <xercesc/sax/HandlerBase.hpp>
50 #include <xercesc/util/XMLString.hpp>
51 #include <xercesc/util/PlatformUtils.hpp>
52
53 #include <vrecko/Ability.h>
54 #include <vrecko/EventDispatcher.h>
55 #include <vrecko/EnvironmentObject.h>
56 #include <vrecko/Scene.h>
57
58 #include <vrecko/PluginManager.h>
59
60 #include <helpers/DynamicArray.h>
61 #include <helpers/XercesXMLUtils.h>
62
63 #include <math.h>
64
65 #include <osg/BlendColor>
66 #include <osg/BlendFunc>
67 #include <osg/Geode>
68 #include <osg/Group>
69 #include <osg/ShapeDrawable>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/SpacePartitioning/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • SpacePartitioning
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #include <float.h>
13
14 #include <osg/Geode>
15 #include <osg/Geometry>
16 #include <osg/Group>
17 #include <osg/Node>
18 #include <osg/PrimitiveSet>
19 #include <osg/Vec3>
20
21 #include <vrecko/Ability.h>
22 #include <vrecko/EnvironmentObject.h>
23 #include <vrecko/World.h>
24 #include <vrecko/ReaderWriter.h>
25
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/navigation/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • navigation
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #include <esg/OSGAdapter.h>
13 #include <esg/PointEnv.h>
14 #include <esg/Shape.h>
15 #include <esg/spacesorting/FDH14Tree.h>
16
17 #include <stdlib.h>
18 #include <string>
19 #include <map>
20 #include <sstream>
21 #include <vector>
22 #include <time.h>
23
24 #ifndef WIN32
25 #include <sys/time.h>
26 #endif
27
28
29 #include <osg/Matrix>
30 #include <osg/Vec2>
31 #include <osg/Vec3>
32 #include <osg/Node>
33 #include <osg/Quat>
34 #include <osg/Geode>
35 #include <osg/Geometry>
36 #include <osg/Material>
37 #include <osg/Timer>
38 #include <osgUtil/CullVisitor>
39
40 #include <vrecko/Ability.h>
41 #include <vrecko/EnvironmentObject.h>
42 #include <vrecko/EventDispatcher.h>
43 #include <vrecko/Message.h>
44 #include <vrecko/Scene.h>
45 #include <vrecko/World.h>
46
47 #include <vrecko/ReaderWriter.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/Kinect/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • Kinect
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #ifdef WIN32
13 #include <windows.h>
14 #else // else
15 #include <termio.h>
16 #endif
17
18 #include <math.h>
19
20 #include <stdio.h>
21 #include <stdlib.h>
22 #include <iostream>
23 #include <sstream>
24 #include <map>
25 #include <string>
26
27 #include <osg/io_utils>
28 #include <osg/Matrix>
29 #include <osg/Notify>
30 #include <osg/Quat>
31 #include <osg/Timer>
32 #include <osg/Vec2>
33 #include <osg/Vec3>
34 #include <osg/Vec4>
35
36 #include <osgGA/GUIEventAdapter>
37
38 #include <vrecko/Device.h>
39 #include <vrecko/EventDispatcher.h>
40
41 #include <vrecko/ReaderWriter.h>
42
43
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/PHANToM/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • PHANToM
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 // Must be first, because it resolves whether Phantom support will be compiled or not
13 #include <vreckoDP/PHANToM/PHANToM_Device.h>
14
15
16 #ifdef WIN32
17 #include <windows.h>
18 #else // else
19 #include <termio.h>
20 #endif
21
22 #include <math.h>
23
24 #include <stdio.h>
25 #include <stdlib.h>
26 #include <iostream>
27 #include <sstream>
28 #include <map>
29 #include <string>
30
31 //#include <osg/io_utils>
32 #include <osg/Matrix>
33 //#include <osg/Notify>
34 #include <osg/Quat>
35 //#include <osg/Timer>
36 //#include <osg/Vec2>
37 #include <osg/Vec3>
38 //#include <osg/Vec4>
39
40 //#include <osgGA/GUIEventAdapter>
41
42 #include <vrecko/Device.h>
43 //#include <vrecko/EventDispatcher.h>
44 #include <vrecko/Logger.h>
45 #include <vrecko/SP_SceneInterface.h>
46
47 #include <vrecko/ReaderWriter.h>
48 #include <vrecko/Scene.h>
49
50 #include <base/SystemInfo.h>
51 #include <base/MTMatrixTransform.h>
52
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoDP/base/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoDP
  • base
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11
12 #ifdef WIN32
13 #include <windows.h>
14 #else // else
15 #include <termio.h>
16 #endif
17
18 #include <math.h>
19
20 #include <stdio.h>
21 #include <stdlib.h>
22 #include <iostream>
23 #include <sstream>
24 #include <map>
25 #include <string>
26 #include <math.h>
27 #include <algorithm>
28
29
30 #include <osg/io_utils>
31 #include <osg/Matrix>
32 #include <osg/Notify>
33 #include <osg/Quat>
34 #include <osg/Timer>
35 #include <osg/Vec2>
36 #include <osg/Vec3>
37 #include <osg/Vec4>
38
39
40 #include <osgGA/GUIEventAdapter>
41
42
43 #include <vrecko/Device.h>
44 #include <vrecko/EventDispatcher.h>
45 #include <vrecko/ReaderWriter.h>
46 #include <vrecko/Scene.h>
47
48 #include <vreckoDP/base/Ultratrak.h>
49 #include <vreckoDP/base/A3DBird.h>
50 #include <vreckoDP/base/arm.h>
51 #include <vreckoDP/base/classes.h>
52 #include <vreckoDP/base/fdtDataGlove.h>
53 #include <vreckoDP/base/fsPinchGlove.h>
54 #include <vreckoDP/base/hci.h>
55 #include <vreckoDP/base/classes.h>
56
57
58 #include <windows.h>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoUtils/Menu.h Source File

  • File List
  • File Members
  • include
  • vreckoUtils
Menu.h
Go to the documentation of this file.
1 /*
2 * VRECKO - Virtual reality engine
3 *
4 * This library is free software; you can redistribute it and/or
5 * modify it under the terms of the GNU Lesser General Public
6 * License version 2.1, as published by the Free Software Foundation.
7 *
8 * This library is distributed in the hope that it will be useful,
9 * but WITHOUT ANY WARRANTY; without even the implied warranty of
10 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
11 * Lesser General Public License for more details.
12 *
13 * Copyright (c) 2011 Martin Bezdeka <mbezdeka@mail.muni.cz>
14 *
15 */
16 #pragma once
17 #include <vreckoUtils/Export>
18
19 namespace vreckoUtils
20 {
21
22 class MenuVisitor;
23
24 class VRECKO_UTILS_EXPORT MenuCommon
25 {
26 public:
27 static void createMenuItem( std::ostringstream& menuSS, const char* itemName, const char* caption, osg::Vec3 color = osg::Vec3(0.9f, 0.8f, 0.8f) );
28 static void createMenuSlider(std::ostringstream& menuSS, const char* itemName, const char* caption, double sliderFrom,
29 double sliderTo, bool integerOnly, double sliderPos, osg::Vec3 color = osg::Vec3(0.9f, 0.8f, 0.8f));
30 };
31
32 class VRECKO_UTILS_EXPORT IMenuComponent : public osg::Referenced
33 {
34 public:
35 virtual std::string toXMLString() = 0;
36 virtual std::string getName() = 0;
37 virtual std::string getCaption() = 0;
38 virtual void accept(MenuVisitor& visitor) = 0;
39 virtual ~IMenuComponent() {};
40 };
41
42 typedef std::vector< osg::ref_ptr<IMenuComponent> >::const_iterator IMenuComponentIter;
43
44 class VRECKO_UTILS_EXPORT MenuBase : public IMenuComponent
45 {
46 protected:
47 std::vector<osg::ref_ptr<IMenuComponent>> _items;
48
49 public:
50 void addChild(osg::ref_ptr<IMenuComponent> menuComponent) {
51 _items.push_back(menuComponent);
52 }
53
54 void removeChild(int index) {
55 _items.erase(_items.begin() + index);
56 }
57 IMenuComponent* getChild(u_int index) {
58 if(index < 0 || index >= _items.size())
59 return NULL;
60 return _items[index];
61 }
62 };
63
64 class VRECKO_UTILS_EXPORT MenuRoot : public MenuBase
65 {
66 protected:
67 std::map<std::string, double> _attributes;
68 public:
69 MenuRoot() {};
70 virtual std::string toXMLString();
71
72 virtual std::string getName() { return ""; };
73 virtual std::string getCaption() { return ""; };
74
75 void addAttribute(const std::string& name, double value) {
76 _attributes[name] = value;
77 }
78
79 bool removeAttribute(const std::string& name)
80 {
81 return _attributes.erase(name) == 1;
82 }
83
84 virtual void accept(MenuVisitor& visitor);
85 };
86
87 class VRECKO_UTILS_EXPORT Menu : public MenuBase
88 {
89 protected:
90 std::string _menuName, _menuCaption;
91 public:
92 Menu(string name = "", string caption= "") : _menuName(name), _menuCaption(caption) {};
93
94 virtual std::string toXMLString();
95
96 virtual std::string getName() {
97 return _menuName;
98 }
99
100 virtual std::string getCaption() {
101 return _menuCaption;
102 }
103
104 virtual void accept(MenuVisitor& visitor);
105 };
106
107 typedef osg::ref_ptr<Menu> MenuPtr;
108
109 class VRECKO_UTILS_EXPORT MenuItem : public IMenuComponent
110 {
111 protected:
112 std::string _itemName, _itemCaption;
113 osg::Vec3 _color;
114
115 public:
116 MenuItem(string name, string caption, osg::Vec3 color = osg::Vec3(0.9f, 0.8f, 0.8f)) :
117 _itemName(name), _itemCaption(caption), _color(color) {};
118 MenuItem(string name, string caption, osg::Vec4 color) :
119 _itemName(name), _itemCaption(caption), _color(color._v[0], color._v[1], color._v[2]) {};
120
121 virtual std::string toXMLString();
122
123 virtual std::string getName() {
124 return _itemName;
125 }
126
127 virtual std::string getCaption() {
128 return _itemCaption;
129 }
130
131 virtual void accept(MenuVisitor& visitor);
132 };
133
134 class VRECKO_UTILS_EXPORT MenuSlider : public IMenuComponent
135 {
136 protected:
137 std::string _sliderName, _sliderCaption;
138 osg::Vec3 _color;
139 double _from, _to;
140 double _value;
141 bool _onlyInt;
142
143 public:
144 MenuSlider(string name, string caption, double from, double to,
145 double value, bool onlyInt, osg::Vec3 color = osg::Vec3(0.9f, 0.8f, 0.8f)) :
146 _sliderName(name), _sliderCaption(caption), _from(from), _to(to),
147 _value(value), _onlyInt(onlyInt), _color(color) {};
148
149 virtual std::string toXMLString();
150
151 virtual std::string getName() {
152 return _sliderName;
153 }
154
155 virtual std::string getCaption() {
156 return _sliderCaption;
157 }
158
159 double getValue() const {
160 return _value;
161 }
162
163 void setValue(double val) {
164 _value = val;
165 }
166
167 virtual void accept(MenuVisitor& visitor);
168 };
169
170 class VRECKO_UTILS_EXPORT MenuVisitor
171 {
172 public:
173 MenuVisitor() {}
174 virtual ~MenuVisitor() {}
175
176 virtual void apply(IMenuComponent&) {}
177 virtual void apply(Menu&) {}
178 virtual void apply(MenuRoot&) {}
179 virtual void apply(MenuItem&) {}
180 virtual void apply(MenuSlider&) {}
181 };
182
183 }
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoUtils/precompiled.h Source File

  • File List
  • File Members
  • src
  • vreckoUtils
precompiled.h
Go to the documentation of this file.
1 // Precompiled headers.
2
3 // !!!!!!!!!!!
4 // This file must be included in any other .cpp file in this project
5 // on the first line (except comments)
6 // !!!!!!!!!!!
7
8 // Documentation on precompiled headers:
9 // http://www.cygnus-software.com/papers/precompiledheaders.html
10
11 #include <osg/Vec2>
12 #include <osg/Vec3>
13 #include <osg/Vec4>
14 #include <osg/Node>
15 #include <osg/Matrix>
16 #include <osg/Quat>
17 #include <osg/MatrixTransform>
18 #include <osg/Timer>
19 #include <osg/Notify>
20 #include <osg/Group>
21
22 #include <osgDB/DynamicLibrary>
23
24 #include <osgText/Text>
25
26 #include <osgViewer/Viewer>
27
28 #include <esg/Definitions.h>
29 #include <esg/OSGAdapter.h>
30
31 #include <stdio.h>
32 #include <vector>
33 #include <string>
34 #include <fstream>
35 #include <sstream>
36 #include <set>
37 #include <list>
38 #include <map>
39 #include <time.h>
40
41 #define WIN32_LEAN_AND_MEAN
42 #include <windows.h>
43
44 #include <xercesc/util/XercesDefs.hpp>
45 #include <xercesc/dom/DOM.hpp>
46 #include <xercesc/util/XMLString.hpp>
47 #include <xercesc/parsers/AbstractDOMParser.hpp>
48
49 #include <helpers/StringHelpers.h>
50 #include <iostream>
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/src/vreckoAP/PhysX/common code/wavefront.h Source File

  • File List
  • File Members
  • src
  • vreckoAP
  • PhysX
  • common code
wavefront.h
Go to the documentation of this file.
1 #ifndef WAVEFRONT_OBJ_H
2
3
4 #define WAVEFRONT_OBJ_H
5
6
7 class WavefrontObj
8 {
9 public:
10
11 WavefrontObj(void);
12 ~WavefrontObj(void);
13
14 unsigned int loadObj(const char *fname, bool textured); // load a wavefront obj returns number of triangles that were loaded. Data is persists until the class is destructed.
15
16 int mVertexCount;
17 int mTriCount;
18 int *mIndices;
19 float *mVertices;
20 float *mTexCoords;
21 };
22
23 #endif
Generated on Sun Feb 17 2013 23:29:47 for vrecko by doxygen 1.8.3.1


vrecko: C:/Documents/School/OSG/VRECKO/include/vreckoAP/Garden/xmlfile.h Source File

  • File List
  • File Members
  • include
  • vreckoAP
  • Garden
xmlfile.h
Go to the documentation of this file.
1 #ifndef XMLFILE_H_
2 #define XMLFILE_H_
3
4 #include "abstractfile.h"
5
6 using std::string;
7
8 namespace AP_LSystem {
12 class XmlFile : public AbstractFile
13 {
14 private:
15 xercesc::XercesDOMParser * m_FileParser;
16 std::map<string, string> m_Defines;
17
22 void processParameters(xercesc::DOMNode * node);
23
28 void processRules(xercesc::DOMNode * node);
29
34 void processHomomorphisms(xercesc::DOMNode * node);
35
40 void processSubsystems(xercesc::DOMNode * node);
41
46 void processConstants(xercesc::DOMNode * node);
47
52 void processType(xercesc::DOMNode * node);
53 public:
54 XmlFile();
55
60 virtual void open( std::string & filename );
61 };
62 }
63
64 #endif // XMLFILE_H_
Generated on Sun Feb 17 2013 23:29:45 for vrecko by doxygen 1.8.3.1