


RealFlow Cinema 4D Plug-in
Features and TutorialsWith this new plug-in release, Next Limit enhances the connectivity between RealFlow and Cinema 4D. In developing this version, our focus has been on workflow and performance enhancements. Throughout this manual, you’ll find detailed explanations of settings and parameters. Tutorials highlighting certain specific workflow issues are included as well.
Installing the RealFlow plug-inThe plug-in can be installed with an installer wizard for Windows 32-bit, Windows 64-bit and Mac OSX 64-bit platforms, so you will not have to manually copy files into Cinema 4D’s plug-ins folder.
Installer for WindowsThe Windows installer wizards auto-detect the path of your Cinema 4D R11.5 plug-in folder. 

  
The wizard auto-detects Cinema 4D 11.5 installation location.



The installer only creates a folder under Cinema 4D’s “plug-ins” folder and copies the resource files  
and the plug-in binary into the folder. After a successful install Cinema 4D recognizes the plug-in  
automatically and a new group with the name “RealFlow” appears in the Plug-ins menu.

RealFlow plug-ins are installed successfully.

Installer for Mac OSX

The Mac OSX build of the plug-in requires OSX version 10.5 or above. The installer copies the 
resource files and the plug-in binary to the /Applications/MAXON/CINEMA4D 
R11.5/plugins/RealFlow folder and prompts for the admin password if needed. After a successful  
install Cinema 4D recognizes the plug-in automatically and a new group with the name “RealFlow” 
appears in the Plug-ins menu.



The steps of the installer on Mac OSX.

RealFlow tools 

The installed RealFlow plug-in contains several tools, with a variety of functions: Particle Importer: 
Imports RealFlow particle .bin and .pxy (proxy) sequences with the selected attributes.

• Particle Exporter: Exports particles to RealFlow .bin sequences.

• SD Importer: Imports RealFlow SD scene files.

• SD Exporter: Exports selected scene geometry and camera to a RealFlow SD scene file. 

• Mesh Importer: Imports RealFlow mesh .bin sequences with the selected attributes.



RealFlow Particle Importer 

The RealFlow Particle Importer tool loads RealFlow particle .bin or .pxy (proxy) sequences with the  
selected attributes. To add the importer, you need to select the Plugins -> RealFlow -> RealFlow 
Particle Importer menu. A new object will load into the Object Manager.

The Particle Importer shows three tabs in the Attribute Manager:

• Setup: Contains parameters to specify which particles should be imported, and when they 
should interact with your Cinema 4D scene.

• Attributes: Controls the values of the attributes of the imported particles.

• Display: Contains parameters that control how the particles are displayed in the editor 
view.

Add a particle sequence to the scene.

Setup 

To import particles, select any .bin or .pxy file from the sequence created previously by RealFlow in  
the File Path field. The plug-in recognizes the name of the particle system, the amount of numeric 
padding, and the start/end frame of the sequence. When the particles are loaded successfully, the  
object is renamed to the name of the particle system. In some cases the plug-in detects the name 



and padding values from the file path wrong. Then a manual correction is required by changing the  
padding value. 

The particles are added to the scene as Thinking Particles by the importer in a group named after 
the RealFlow particle system. The RealFlow particles behave like standard Thinking Particles. You 
can change their settings in the Objects -> Thinking Particles -> Thinking Particles Settings  dialog 
and you can add an Xpresso tag to the importer object.

Thinking particle settings.

Memory management and speed can be balanced via the Cache Mode feature which has the 
following options: Current Frame, Core Frames and All Frames. In Current Frame mode the plug-in 
only loads the current frame into RAM. This mode uses the least amount of memory but it must  
read each new frame from disc. Core Frames mode loads the neighborhood of the current frame to 
memory. The core size can be set dynamically. All Frames captures the whole sequence which 
requires the largest amount of memory but the least amount of disc access.

Start/End frames are set automatically after a correct file path is given. This can later be changed,  
so the plug-in will only render the particles inside the specified interval. Start/End frames and 
Offset define values on the Cinema 4D timeline. 
For example, if you want to render frame 00010 – 00020 of the .bin sequence from frame 50 in  
Cinema 4D you have to set the Start Frame and End Frame values to 50 and 60 because these 
define the visible frames on the timeline. The Offset value should be set to 40 because this shifts 
the first frame of the .bin sequence to frame 40 (which means the 00010 .bin frame will be set to  
frame 50).



Level of Detail (LOD) is used for filtering the particles in the viewport. Complex fluid systems can 
be displayed with fewer particles acting as “guides” for the larger system. Only the visible particles  
are saved to memory.

Frames of the sequence can be shifted, the current frame can be locked, and also the whole  
imported .bin sequence can be time-reversed.

The transformation (translation, rotation, scale) of the Particle Importer object is applied globally  
to the particles.

RealFlow Particle Importer plug-in parameters.

The setup properties in the RealFlow Particle Importer window are the following:

• File Path: the path of one of the RealFlow particle files from the .bin or .pxy sequence.

• Name: read-only field. The name of the particle system comes from the name of the 

RealFlow particle file. Recognized automatically after a particle file path is given.

• Padding: padding size of the RealFlow particle file. Recognized automatically after a particle 

file path is given.

• Cache Mode: defines disc / memory usage.



 - Current Frame: reads the current file from disc.

- Core Frames: reads frames inside the ''Cache Core'' range.

- All Frames: reads all frames inside the specified start/end range.

• Cache Core: the radius for the Core Frames mode. Defines the number of frames cached to 

the memory which is 2*[core_frames] + 1.

• Start/End Frame: the start and end frame of the sequence on the timeline.

• Offset: the shifting of the imported sequence on the timeline.

• LOD: the level of detail of displayed particles in percent. 

• Life Time: every particle in Cinema 4D has an age and a life time value. If the age is over the 

life time then the particle is dead and will not be displayed and rendered. The RealFlow 
.bin file only contains the age value, thus the life time of the particles can be controlled 
with this global parameter.

• Lock Current Frame: keeps the current frame displayed.

• Lock Last Frame: keeps the last imported frame displayed.

• Invert Sequence: inverts the file sequence.

Attributes 

Each particle has several attributes like age, number of neighbors or physical  parameters. These can 
be set on the Particles tab of the RF Particle Importer window. The attributes are separated into 
two groups: vector and scalar attributes. For every attribute the user can keep the original value 
stored in the particle file (Keep), override it by a custom expression (Add) or remove any value for 
the attribute (No).

A particle holds the following attributes:



• Velocity vector

• Force vector

• Vorticity vector

• Normal vector

• Texture vector

• Number of neighbors

• Information bit

• Age of the particle

• Isolation time

• Viscosity

• Density

• Pressure

• Mass

• Temperature

• Id of the current particle



RealFlow Particle Importer attribute parameters.

The attributes can also be accessed with the PGetData Xpresso node.

Display 

The viewport display of the particle system can be defined with the parameters of the Display tab.



RealFlow Particle Importer display parameters.

• Display Mode: 

• TP View Type: uses the native Thinking Particle display options.

• Particles: represents every particle with a point.

• Circles: represents every particle with a circle.

• Box: displays a bounding box around the imported particles as a guiding geometry.

• Circle Direction: active only in Circles display mode. Defines the direction of the displayed 

circles.

• Camera: the circles always face the camera.

• XY: the circles are oriented along the XY plane.

• YZ: the circles are oriented along the YZ plane.

• XZ: the circles are oriented along the XZ plane.



• Circle Radius: active only in Circles display mode. Defines the radius of the displayed 

circles.

• Color By: in Particles and Circles display mode sets the color of the particles by their 

velocity, pressure, or temperature value.

• Color: the particles are displayed with a color selected between the minimum and 

maximum values in the color configuration.. The color has a linear RGB gradient. The 
minimum color is always the first knot in the gradient and the maximum color is always the  
last (irrespective of the number of knots). When the Color Mode is set to None or the 
Display Mode is in Box mode, the maximum color is used to draw in the viewport.



Tutorial: How to import RealFlow particles into Cinema 4D

1- After installation select the Plugins -> RealFlow -> RealFlow Particle Importer  option from 
the menu.

Add the RealFlow Particle Importer plug-in to the scene.

2- Click on the Setup tab in the Attribute Manager. 

3- Click on the File Path button to choose a .bin file from the particle sequence generated by 
RealFlow. Any of the .bin files can be selected.

Selecting a BIN file from the particle sequence.



4- The particles are added to the scene. The Name and Padding values are set after the file 
name. If this is not correct, set the real padding size with the slider. 

5- You can control the import and display parameters of the particles in the Setup, Attributes 
and Display tabs in the Attribute Manager.

Particles displayed in the Cinema4D viewport.

6- Select the Objects -> Thinking Particles -> Thinking Particles Settings… option from the 
menu. You can set the native thinking particles settings such as View Type, color, and 
maximum number of particles displayed in the dialog window that popped up. The settings 
are active only when the TP Native View is selected as Display Mode in the Attribute 
Manager.

Tutorial: How to render RealFlow particles in Cinema 4D

1- Select the Plugins -> RealFlow -> RealFlow Particle Importer  option from the menu to add 
the RealFlow Particle Importer.

2- Click on the Setup tab in the Attribute Manager and click on the File Path button to choose 
a .bin file from the particle sequence generated by RealFlow. Any of the .bin files can be 
selected.

3- The particles are added to the scene. The Name and Padding values are set after the file 
name. If   this is not correct, set the real padding size with the slider. 



4- Add a sphere or any object you want to replace the particles with to the scene.

5- Set the sphere radius or object size to an appropriate value.

6- Right-     click on the importer object and select Cinema   4D Tags -> Xpresso from the menu.

Add Xpresso node to the importer.

7- Right click in the Xpresso Editor dialog and select New Node -> Thinking Particles -> TP 
Initiator -> P Pass from the menu. This node passes the RealFlow particles to other nodes 
inside the Xpresso setup.



Add P Pass Xpresso node.

8- Add the New Node -> Thinking Particles -> TP Standard -> PShape node to the Xpresso 
Editor in the same way. This node holds the object which will be rendered in place of the 
particles.

9- Drag & drop the Sphere or other object from the Object Editor to the PShape node.

10- Connect the P Pass and PShape nodes.

Note:  P  Pass  node  now  iterates  over  all  Thinking  Particles of  the  scene.  If  you  have  more 
particles in the scene and want to render only the imported ones you should set the particle  
group in the P Pass node. Select  Objects -> Thinking Particles -> Thinking Particles Settings… 
from the menu and drag & drop the required particle group from the dialog to the P Pass node.

11- Select Objects -> Thinking Particles -> Particle Geometry  from the menu. This object is 
required to replace the particles with the selected geometry.



 
Add Particle Geometry to the scene.

12- Move the Particle Geometry object as the child of the Particle Importer. This is necessary 
because the Particle Geometry object has to be evaluated after the Particle Importer added 
the particles to the scene. 

Note: If the Particle Geometry is not a child of the importer then the particles will be shifted 
one frame in the render.



Particle Geometry has to be a child of the importer.

13- Render the scene for example by pressing the Render to Picture Viewer button in the 
toolbar. 



The rendered image.

Tutorial: How to render RealFlow particles with motion blur in 
Cinema 4D

1- Select the Plugins -> RealFlow -> RealFlow Particle Importer  option from the menu and 
add the particle sequence to the scene with the Xpresso nodes as described in the previous 
tutorial.

2- Click on the Render Settings… button in the toolbar or press CTRL + b. 

3- Click on the Effect… button in the dialog and select Scene Motion Blur.



Add Scene Motion Blur.

4- Set the appropriate values for the motion blur.

5- Close the dialog and render the scene for example by pressing the Render to Picture 
Viewer button in the toolbar. 



The rendered image.



RealFlow Particle Exporter 

The RealFlow Particle Exporter plug-in writes particles data into RealFlow .bin sequence from 
Cinema 4D. The exporter dialog window can be reached via Plugins -> RealFlow -> RealFlow 
Particle Exporter. 

The available particle systems of the scene are listed in a combo box. Particles from emitter objects  
and Thinking Particle groups can be selected to export. The file names in the sequence are 
generated from the name and padding parameters when exporting a frame range. 
For example if the name is particle_emitter and the padding is 5 then the name of the exported  
.bin files will be particle-emitter00001.bin, particle-emitter00002.bin and so on.

Particle attributes for the .bin files have default values for emitter objects except velocity and age  
which are read from the scene. Thinking Particles have velocity, age and mass parameters. The 
other attributes are inherited from the channels of the TP system which are the following:

• force Vector

• vorticity Vector

• normal Vector

• texture Vector

• neighbors Integer

• infobit Integer

• isolation Real

• viscosity Real

• density Real

• pressure Real

• temperature Real

• id Integer



RealFlow Particle Exporter setup interface.

The basic setup parameters and additional file information can be set in the RealFlow Particle  
Exporter dialog. The setup properties are the following:

• Particle  System: emitter  object  (emitter)  or  Thinking  Particle  group (tp)  which holds  the  
particles to export.

• Directory: path of the directory where the RealFlow particle file sequence is written.

• Name: particle system name. Used in the .bin file name.

• Padding: padding used in the .bin file name.

• Start/End Frame: indicates the frames to export.

• Inc Frame: indicates the increment to generate the frames when exporting.

• Export: starts exporting the particles.

• Cancel: closes the dialog window.

The RealFlow particle file contains some meta-information which cannot be read from a Cinema 4D 
particle system. These parameters can be set in the Particle File tab:

• Fluid  Name: name  of  the  fluid.  The  name  of  the  emitter  or  thinking  particle  group  by 
default.



• Fluid  Type: type of  the  fluid  which can be  Gas,  Liquid,  Dumb or  Elastic.  This  parameter  
defines the behavior of the fluid.

• Frame  /  sec:  frame /  sec  used  in  RealFlow rendering.  Set  by  the  fps  value  used  in  the 
application by default.

• Scene scale: scene scale parameter. Affects the “Resolution” parameter in RealFlow. 

• Radius: radius of the particles. Affects the “Resolution” parameter in RealFlow. 

• Emitter position / rotation / scale: fluid emitter properties.

RealFlow Particle Exporter Particle File tab parameters.



Tutorial: How to export Cinema 4D particles to BIN

1- In order to export particles in Cinema 4D you need to select the Plugins -> RealFlow -> 
RealFlow Particle Exporter option in the menu.

Open the RealFlow Particle Exporter dialog.

2- Select the particle system you want to export to BIN sequence. 

3- Click on the Directory button and select the folder to export the .bin files to.

4- Indicate padding in the file name, start / end frame parameters and meta-information 
on the Particle File tab.

5- Press the Export button to write the BIN sequence.

Cinema 4D particle scene to export to BIN files.



RealFlow SD Importer 

The RealFlow SD Importer plug-in loads RealFlow SD scene files. An .sd file contains camera and  
object parameters and animation. The camera can be loaded separately from the objects. When an 
object .sd file is selected the number of available objects and the names of the first several objects  
are listed in a read-only field.

When an object with the same name already exists in the scene, the animation will be applied to it  
from the .sd file. The plug-in creates missing objects during the import. The user can define  
whether to load the objects with or without texture information. More .sd files can be added to the  
same scene.

The plug-in is responsible only for adding objects to the scene; the animation is handled by the  
RealFlow SD Animation plug-in which is described in the next section. 

Import objects from RealFlow SD file.

The RealFlow SD Importer parameters are the following:

• Camera: path of the camera .sd file.

• Objects: path of object .sd file.

• Create Missing Objects: adds SD objects which are not present in the scene. 



• Add Texture: loads SD objects with texture data which means applying UV coordinates from 
the .sd file.

• Invert  Normals: inverts  polygon  normal  vectors  of  the  imported  objects.  This  option  is  
useful for RealWave objects.

• Create Motion Keys: adds keys for each frame of the animation.

• Import: adds the selected camera and / or objects to the scene.

• Cancel: closes the dialog window.

RealFlow SD Importer dialog.

RealFlow SD Animation 

The animation is applied to an object by the RealFlow SD Animation displacement plug-in. It is  
added automatically as the child of the imported objects when the .sd file is loaded by the 
RealFlow SD Importer plug-in.



RealFlow SD Animation plug-ins in a scene.

The .sd file has to contain the object with the same name to load the animation. Start and end  
frames are set automatically after a correct file path is given. Later this can be changed, so the  
plug-in will animate the object inside the specified interval. The animation sequence can be  
shifted, the current frame can be locked, and the whole sequence can be inverted.

Keys can be added for each frame of the animation with the Create Motion Keys button. If keys are 
added the motion of the object can be modified. Changing any parameters of the plug-in takes 
effect only when the keys are re-created (delete and create). Added keys can be removed for the  
selected frame range with the Delete Motion Keys button. If you do not create keys, the plug-in 
reads the .sd file on the fly and loads the animation.



RealFlow SD Animation plug-in parameters.

The plug-in parameters are the following:

• SD File: path of the .sd file which contains the object.

• Start/End Frame: the start and end frame of the animation.

• Offset: the shifting of the animation.

• Scale: scales the animated object.

• Lock Last Frame: keeps the last imported frame displayed.

• Lock Current Frame: keeps the current frame displayed.

• Invert Sequence: inverts the animation.



Realwave SD object imported in Cinema 4D. 

Note: RealWave can be imported as an SD file the same way as an SD object.



Tutorial: How to import RealFlow SD files into Cinema 4D

1- To import a RealFlow scene in Cinema 4D you need to select the Plugins -> RealFlow -> 
RealFlow SD Importer option in the menu.

Open the RealFlow SD Importer dialog.

2- Click on the Object(s) button and select the SD file you want to import to the scene. 

3- Click on the Camera button and select the SD file which contains the camera data if you 
want to add a camera to the scene. 

4- Create Missing Objects is checked which means the objects will be generated and 
added to the scene.

5- Press the Import button to add the camera and objects to the scene.



SD object displayed in LW viewport.

6- To modify the animation for an object, expand the object tree and select the child 
Animation plug-in.

7- Select the Setup tab in the Attribute Manager and modify the parameters you want.



RealFlow SD Exporter The RealFlow SD Exporter plug-in writes Cinema 4D scene data into a RealFlow SD file. The 
exporter dialog can be opened with the Plugins -> RealFlow -> RealFlow SD Exporter option in 
the menu. 

The SD scene can consist of geometry objects and an optional camera. Objects can be 
collected in a list to export. There are two listboxes in the dialog. The left one contains the 
polygon objects of the scene and the right one shows the objects which will be exported to the  
SD file. The Add button appends the objects selected for export to the collection. The Add All 
button moves all objects from the left box to the right. The Remove button removes the 
selected objects from the export list while the Delete All button clears the list. 

The color of the objects comes from the display color used in Cinema 4D. The mode of the  
export (transformation matrix or pre-vertex deformation) can be set in the list by clicking the  
checkbox next to the object name. The label shows if the object will be exported in “matrix” or  
“vertex” mode.

Exporting objects to SD file with the RealFlow SD Exporter plug-in.

The RealFlow SD Exporter plug-in parameters are the following:

• SD File: path of the output .sd file.



• Start/End Frame: indicates the frames to export.

• Inc Frame: indicates the increment to generate the frames when exporting.

• Scene Scale: global scale factor.

• Add Camera: exports the selected camera to the .sd file when checked.

• Camera: the camera to export. This field is active only when the “Add Camera” flag is set.

• Object / Add / Add All / Remove / Remove All:  collects the objects to export.

• Export: starts exporting the scene.

• Cancel: closes the dialog window.

SD file only accepts triangle polygons. When adding an object with non-triangle faces the plug-in  
tries to execute triangulation automatically. 



Tutorial: How to export Cinema 4D objects into a RealFlow SD file

1- In order to export SD from Cinema 4D you need to have your scene ready with the 
objects to export.

LW scene to export to SD file.

2- Select the Plugins -> RealFlow -> RealFlow SD Exporter option from the menu.

Open the RealFlow SD Exporter dialog.

3- Indicate the output .sd file with the SD File... button and set the start and end frames. 

4- Check Add Camera and select a camera if you want to add one to the SD file. Keep the 
option unchecked if you don’t want to write a camera to the scene.

5- Collect the objects to export with the Add / Add All / Remove / Remove All buttons.



6- Choose the export mode (matrix or vertex) of the selected objects with the Mode 
checkbox.

7- Press the Export button to write the RealFlow SD file.



RealFlow Mesh Importer 
The RealFlow Mesh Importer plug-in loads .bin RealFlow mesh sequences. To add the importer you 
need to select the Plugins -> RealFlow -> RealFlow Mesh Importer option from the menu. A new 
object will be added to the scene which has two added tabs in the Attribute Manager:

• Setup: contains parameters for which mesh to import, and when it should interact with 
your Cinema 4D scene.

• Vertices: controls the attributes of the imported mesh vertices.

Add a mesh sequence to the scene.

Setup 

To import a mesh sequence, select any .bin file from the sequence generated previously by 
RealFlow in the File Path field. The plug-in recognizes the name of the mesh, the amount of 
numeric padding, and the start/end frame of the sequence. When the mesh is loaded successfully,  
the object is renamed to the name of the mesh. In some cases the plug-in detects the name and  
padding values from the file path wrong. Then a manual correction changing the padding value is  
required. 

Memory management and speed can be balanced via the Cache Mode feature which has the 
following options: Current Frame, Core Frames and All Frames. In Current Frame mode the plug-in 
loads only the current frame into RAM. This mode uses the least amount of RAM but it must read 
each new frame from disc. Core Frames mode loads the neighborhood of the current frame to 
memory. The core size can be dynamically set. All Frames mode caches the whole sequence.



Start/End frames are set automatically after a correct file path is given. Later this can be changed,  
so the plug-in will only render the particles inside the specified interval. Start/End frames and 
Offset define values on the Cinema 4D timeline. 
For example if you want to render frame 00010 – 00020 of the .bin sequence from frame 50 in  
Cinema 4D you should set the Start Frame and End Frame values to 50 and 60 because these 
define the visible frames on the timeline. The offset value should be set to 40 because this shifts  
the first frame of the .bin sequence to frame 40 (which means the 00010 bin frame will be placed 
to frame 50).

Frames of the sequence can be shifted, the current frame can be locked, and the whole imported 
.bin sequence can be time-reversed.

RealFlow Mesh Importer plug-in parameters.

The parameters of the RealFlow Mesh Importer setup window are the following:

• File Path: the path of one of the RealFlow mesh files from the .bin sequence.

• Name: read-only field. The name of the mesh comes from the name of the RealFlow 

particle file. This is recognized automatically after a mesh file path is given.

• Padding: padding size of the RealFlow mesh file. This is recognized automatically after a 

mesh file path is given.



• Cache Mode: defines disc / memory usage.

 - Current Frame: reads the current file from disc.

- Core Frames: reads frames inside the ''Cache Core'' range.

- All Frames: reads all frames inside the specified start/end range.

• Cache Core: the radius for Core Frames mode. Defines the number of frames cached to the 

memory which is 2*[core_frames] + 1.

• Start/End Frame: the start and end frame of the sequence on the timeline.

• Offset: the shifting of the imported sequence on the timeline.

• Scale: scales the mesh, same as the Scale coordinates.

• Blur  Length: affects  motion  blur  quantity.  RealFlow  stores  the  mesh  information  of  the 
previous  frame  into  each  mesh  as  an  endomorph  (speed).  The  plug-in  will  morph  in 
between frames and allows different motion blur settings for each mesh through the Blur 
Lenght multiplier.

• Lock Current Frame: keeps the current frame displayed.

• Invert Sequence: inverts the file sequence.

Vertices 

Every vertex of a mesh has a velocity and texture UV attribute. These values can be controlled in  
the Vertices tab of the RealFlow Mesh Importer plug-in. For every attribute, the user can keep the  
original value stored in the mesh file (Keep), override it by a custom expression (Add) or remove 
any value for the attribute (No).



RealFlow Mesh Importer vertex parameters.

Note: When we import a mesh from RealFlow into Cinema   4D, the UV Map is applied to the mesh if  
there is    a gizmo texture daemon applied in the RealFlow scene. 

UV applied in RealFlow with a texture gizmo over the mesh.  

When the mesh .bin sequence contains more fluids, a weight map belongs to each fluid which 
describes the owner fluid of the vertices. These weight maps are added in each frame to the mesh  
importer object by the plug-in.



Tutorial: How to import a RealFlow mesh into Cinema 4D

1- After installation select the Plugins -> RealFlow -> RealFlow Mesh Importer  option from 
the menu.

Add the RealFlow Mesh Importer plug-in to the scene.

2- Click on the Setup tab in the Attribute Manager. 

3- Click on the File Path button to choose a .bin file from the mesh sequence generated by 
RealFlow. Any of the .bin files can be selected.

Selecting a BIN file from the mesh sequence.

4- The mesh is added to the scene. The Name and Padding values are set after the file name. 
If this is not correct, set the real padding size with the slider. 



5- You can control the import parameters of the mesh in the Setup and Vertices tabs in the 
Attribute Manager. A Phong tag is added automatically to the mesh to define the 
smoothness.

Mesh loaded in Cinema 4D viewport.

Tutorial: How to render a RealFlow mesh with motion blur in Cinema 
4D

6- Select the Plugins -> RealFlow -> RealFlow Mesh Importer option from the menu and add 
the mesh sequence to the scene as described in the previous tutorial.

7- Click on the Render Settings… button in the toolbar or press CTRL+b. 

8- Click on the Effect… button in the dialog and select Scene Motion Blur.



Add Scene Motion Blur.

9- Set the appropriate values for the motion blur.

10- Close the dialog and render the scene for example by pressing the Render to Picture 
Viewer button in the toolbar. 



The rendered image.



Tutorial: Rendering a RealFlow mesh that contains multiple fluids

This example shows a basic approach to rendering RealFlow meshes by creating a custom textured  
surface. It describes a setup that is able to render two fluids.

1- Import the mesh sequence into Cinema 4D. The imported mesh object contains a weight  
map for each fluid which represents the contribution of the fluid by every vertex. These 
vertex maps make it possible to render complex, multi-type fluids. 

Mesh loaded in the viewport.

2- Create a material for the first fluid in the Material Editor (File -> New Material).



 
Add new material to the scene.

3- Double click on the material and set the color to red. 

4- Create a new material with a blue color for the second fluid .

5- Select the Alpha channel.

6- Click the array button in the Texture field and select Effects -> Vertex Map.



Add vertex map to the alpha channel.

7- Click on the Vertex Map button and drag & drop a vertex map from the Object Editor to the 
Vertex Map field. The texture weight maps from the RealFlow mesh file are generated with 
the name of [object_name]_weight_[fluid_index].

Select the vertex map.



8- Close the Material Editor window and drag & drop the two materials to the mesh. First the 
red one and second the blue one.

Materials added to the mesh.

9- Render the current frame by pressing the Render To Picture Viewer button in the toolbar or 
render the whole scene.



Result of the rendering.



FAQ 

• Why is the RealFlow plug-in not installed iinside Cinema 4D?  

Make sure you have installed the correct version for Cinema 4D (11.5 is supported) and 
the installer will detect the right folder. 

• Why are the particles not loading in Cinema 4D?

Check the path for particles and their padding size.

• Why are the meshes not loading in Cinema 4D?

Check the path for the mesh and its padding size.

• Can you import RealWaves as BIN and SD files?

Yes, you can. In order to import them as BIN files you need to import them as a mesh, 
and if you use the SD file format you need to import them as SD.

• Why are the particles not exported from Cinema 4D?

Check that you have the particle system selected in the dialog and the path where you 
want to export it. 
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	RealFlow SD Exporter 

The RealFlow SD Exporter plug-in writes Cinema 4D scene data into a RealFlow SD file. The exporter dialog can be opened with the Plugins -> RealFlow -> RealFlow SD Exporter option in the menu. 
	The SD scene can consist of geometry objects and an optional camera. Objects can be collected in a list to export. There are two listboxes in the dialog. The left one contains the polygon objects of the scene and the right one shows the objects which will be exported to the SD file. The Add button appends the objects selected for export to the collection. The Add All button moves all objects from the left box to the right. The Remove button removes the selected objects from the export list while the Delete All button clears the list. 
	The color of the objects comes from the display color used in Cinema 4D. The mode of the export (transformation matrix or pre-vertex deformation) can be set in the list by clicking the checkbox next to the object name. The label shows if the object will be exported in “matrix” or “vertex” mode.

